Reference for unit 'agraphics': Procedures and functions

AddAnimOb | Add an AnimOb to the linked list of AnimObs.
AddBob | Adds a Bob to current gel list.
AddFont | Add a font to the system list
AddVSprite | Add a VSprite to the current gel list.
AllocBitMap | Allocate a bitmap and attach bitplanes to it.
AllocDBufInfo | Allocate structure for multi-buffered animation
AllocRaster | Allocate space for a bitplane.
AllocSpriteData | VarArgs Version of AllocSpriteDataA()
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.
Animate | Processes every AnimOb in the current animation list.
AreaCircle | Draws a Circle in an Area
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AskFont | Get the text attributes of the current font
AskSoftStyle | Get the soft style bits of the current font.
AttachPalExtra | Allocate and attach a palette sharing structure to a colormap
AttemptLockLayerRom | Attempt to Lock Layer structure by ROM(gfx lib) code
BestModeID | VarArgs version of BestModeIDA()
BestModeIDA | Calculate the best ModeID with given parameters
BitMapScale | Perform raster scaling on a bit map.
BltBitMap | Move a rectangular region of bits in a BitMap.
BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltClear | Clear a block of memory words to zero.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
BltPattern | Using standard drawing rules for areafill, blit through a mask.
BltTemplate | Cookie cut a shape in a rectangle to the RastPort.
BNDRYOFF | Turn Boundary off
CalcIVG | Calculate the number of blank lines above a ViewPort
CBump | Increment user copper list pointer (bump to next position in list).
ChangeExtSprite | VarArgs version of ChangeExtSpriteA
ChangeExtSpriteA | Change the sprite image pointer.
ChangeSprite | Change the sprite image pointer.
ChangeVPBitMap | Change display memory address for multi-buffered animation
ClearEOL | Clear from current position to end of line.
ClearRectRegion
ClearRegion |
ClearScreen | Clear from current position to end of RastPort.
ClipBlit | Calls BltBitMap() after accounting for windows
CloseFont | Release a pointer to a system font.
CloseMonitor | Close a MonitorSpec
CMove | Append copper move instruction to user copper list.
CoerceMode | Calculate ViewPort mode coercion
CopySBitMap | Syncronize Layer window with contents of Super BitMap
CWait | Append copper wait instruction to user copper list.
DisownBlitter | Returns blitter to free state.
DisposeRegion | Return all space for this region to free memory pool.
DoCollision | Test every gel in gel list for collisions.
Draw | Draw a line between the current pen position and the new x,y position.
DrawCircle | Draws a Circle
DrawEllipse | Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.
EraseRect | Fill a defined rectangular area using the current BackFill hook.
ExtendFont | Ensure TTextFont.tf_Extension has been built for a font
ExtendFontTags | VarArgs Version of ExtendFont()
FindColor | Find the closest matching color in a colormap.
FindDisplayInfo | Search for a record identified by a specific key
Flood | Flood rastport like areafill.
FontExtent | Get the font attributes of the current font
FreeBitMap | Free a bitmap created by AllocBitMap()
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.
FreeCopList | Deallocate intermediate copper list
FreeCprList | Deallocate hardware copper list
FreeDBufInfo | Free information for multi-buffered animation
FreeGBuffers | Deallocate memory obtained by GetGBuffers()
FreeRaster | Release an allocated area to the system free memory pool
FreeSprite | Return sprite for use by others and virtual sprite machine.
FreeSpriteData | free sprite data allocated by AllocSpriteData()
FreeVPortCopLists | Deallocate all intermediate copper lists and their headers from a viewport
GetAPen | Get the A Pen value for a RastPort
GetBitMapAttr | Returns information about a bitmap
GetBPen | Get the B Pen value for a RastPort
GetColorMap | Allocate and initialize Colormap
GetDisplayInfoData | Query DisplayInfo Record parameters
GetDrMd | Get the draw mode value for a RastPort
GetExtSprite | VarArgs Version of GetExtSpriteA()
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.
GetGBuffers | Attempt to allocate ALL buffers of an entire AnimOb.
GetOutlinePen | Get the O Pen value for a RastPort
GetRGB32 | Set a series of color registers for this Viewport.
GetRGB4 | Inquire value of entry in ColorMap.
GetRPAttrs | VarArgs Version for GetRPAttrsA()
GetRPAttrsA | Examine rastport settings via a tag list
GetSprite | Attempt to get a sprite for the simple sprite manager.
GetVPModeID | Get the 32 bit DisplayID from a ViewPort.
GfxAssociate | associate a graphics extended node with a given pointer
GfxFree | Free a graphics extended data structure
GfxLookUp | Find a graphics extended node associated with a given pointer
GfxMove | Move graphics pen position.
GfxNew | Allocate a graphics extended data structure
GfxText | Write text characters (no formatting).
InitAnimate | Init AnimObject pointer, set to nil
InitArea | Initialize vector collection matrix
InitBitMap | Initialize bit map structure with input values.
InitGels | initialize a gel list; must be called before using gels.
InitGMasks | Initialize all of the masks of an AnimOb.
InitGraphicsLibrary
InitMasks | Initialize the BorderLine and CollMask masks of a VSprite.
InitRastPort | Initialize raster port structure
InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.
InitView | Initialize View structure.
InitVPort | Initialize ViewPort structure.
LoadRGB32 | Set a series of color registers for this Viewport.
LoadRGB4 | Load RGB color values from table.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.
LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
MakeVPort | Generate display copper list for a viewport.
ModeNotAvailable | Check to see if a DisplayID isn't available.
MoveSprite | Move sprite to a point relative to top of viewport.
MrgCop | Merge together coprocessor instructions.
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.
NextDisplayInfo | Iterate current displayinfo identifiers
ObtainBestPen | VarArgs Version of ObtainBestPenA()
ObtainBestPenA | Search for the closest color match, or allocate a new one.
ObtainPen | Obtain a free palette entry for use by your program.
OFF_DISPLAY |
OFF_SPRITE |
OFF_VBLANK |
ON_DISPLAY |
ON_SPRITE |
ON_VBLANK |
OpenFont | Get a pointer to a system font.
OpenFontTagList
OpenFontTags
OpenMonitor | Open a named MonitorSpec
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
OwnBlitter | get the blitter for private usage
PolyDraw | Draw lines from table of (x,y) values.
QBlit | Queue up a request for blitter usage
QBSBlit | Synchronize the blitter request with the video beam.
RasSize | Get Size of an rastport.
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
ReadPixelArray8 | read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
ReadPixelLine8 | read the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.
RectFill | Fill a rectangular region in a RastPort.
ReleasePen | Release an allocated palette entry to the free pool.
RemFont | Remove a font from the system list.
RemIBob | Immediately remove a Bob from the gel list and the RastPort.
RemVSprite | Remove a VSprite from the current gel list.
SafeSetOutlinePen |
SafeSetWriteMask |
ScalerDiv | Get the scaling result that BitMapScale would.
ScrollRaster | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.
ScrollRasterBF | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().
ScrollVPort | Reinterpret RasInfo information in ViewPort to reflect the current Offset values.
SetABPenDrMd | Set pen colors and draw mode for a RastPort.
SetAfPt | Set Area PAttern and Point Size
SetAPen | Set the primary pen for a RastPort.
SetBPen | Set secondary pen for a RastPort
SetChipRev | Turns on the features of a Chip Set
SetCollision | Set a pointer to a user collision routine.
SetDrMd | Set drawing mode for a RastPort
SetDrPt | Set Draw Pattern
SetFont | Set the text font and attributes in a RastPort.
SetMaxPen | Set maximum pen value for a rastport
SetOPen | Set Outline pen
SetOutlinePen | Set the Outline Pen value for a RastPort
SetRast | Set an entire drawing area to a specified color.
SetRGB32 | Set one color register for this Viewport.
SetRGB32CM | Set one color register for this ColorMap.
SetRGB4 | Set one color register for this viewport.
SetRGB4CM | Set one color register for this ColorMap.
SetRPAttrs | VarArgs Version of SetRPAttrsA()
SetRPAttrsA | Modify rastport settings via a tag list
SetSoftStyle | Set the soft style of the current font.
SetWriteMask | Set the pixel write mask value for a RastPort
SetWrMsk | Set Write Mask for RastPort
SortGList | Sort the current gel list, ordering its y,x coordinates.
StripFont | Remove the TextFontExtension from a font
SyncSBitMap | Syncronize Super BitMap with whatever is in the standard Layer bounds.
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent
TextLength | Determine raster length of text data.
UCopperListInit | Allocates and initializes copperlist structures and buffers internal to UCopList structure.
UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.
VBeamPos | Get vertical beam position at this instant.
VideoControl | Modify the operation of a ViewPort's ColorMap
VideoControlTags | VarArgs Version of VideoControl()
WaitBlit | Wait for the blitter to be finished before proceeding with anything else.
WaitBOVP | Wait till vertical beam reached bottom of this viewport.
WaitTOF | Wait for the top of the next video frame.
WeighTAMatch | Determines how well two font descriptions match.
WeighTAMatchTags |
WriteChunkyPixels | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixel | Change the pen num of one specific pixel in a specified RastPort.
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelLine8 | Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
XorRegionRegion | Perform 2d XOR operation of one region with second region, leaving result in second region
Documentation generated on: 2021-07-30


Reference for unit 'agraphics': Variables

GfxBase

Graphics base library pointer for all graphics library functions, opened on unit initialization


Index of all identifiers in unit 'agraphics'

A B C D E F G H I J L M N O P Q R S T U V W X

A

A2024FIFTEENHERTZ_KEY | AllocSpriteData | AreaEnd
A2024_MONITOR_ID | AllocSpriteDataA | AreaMove
A2024TENHERTZ_KEY | AndRectRegion | AREAOUTLINE
AddAnimOb | AndRegionRegion | AskFont
AddBob | ANFRACSIZE | AskSoftStyle
AddFont | Animate | AttachPalExtra
AddVSprite | ANIMHALF | AttemptLockLayerRom
AllocBitMap | AreaCircle | AVOID_FLICKER
AllocDBufInfo | AreaDraw |
AllocRaster | AreaEllipse |

B

B2BOBBER | BIDTAG_ViewPort | BMF_MINPLANES
B2NORM | BITCLR | BMF_STANDARD
B2SWAP | BitMapScale | BNDRYOFF
BACKSAVED | BITSET | BOBISCOMP
BANDWIDTH_1X | BLITMSG_FAULT | BOBNIX
BANDWIDTH_2XDBL | BltBitMap | BOBSAWAY
BANDWIDTH_2XNML | BltBitMapRastPort | BOBUPDATE
BANDWIDTH_4X | BltClear | BORDER_BLANKING
BDRAWN | BltClearWait | BORDERHIT
BestModeID | BltClearXY | BORDER_NOTRANSPARENCY
BestModeIDA | BltMaskBitMapRastPort | BORDERSPRITES
BIDTAG_BlueBits | BltPattern | BOTTOMHIT
BIDTAG_COERCE | BltTemplate | BROADCAST_BEAMCON
BIDTAG_Depth | BMA_DEPTH | BROADCAST_HBSTOP
BIDTAG_DesiredHeight | BMA_FLAGS | BROADCAST_HBSTRT
BIDTAG_DesiredWidth | BMA_HEIGHT | BROADCAST_HSSTOP
BIDTAG_DIPFMustHave | BMA_WIDTH | BROADCAST_HSSTRT
BIDTAG_DIPFMustNotHave | BMB_CLEAR | BROADCAST_VBSTOP
BIDTAG_GfxPrivate | BMB_DISPLAYABLE | BROADCAST_VBSTRT
BIDTAG_GreenBits | BMB_INTERLEAVED | BROADCAST_VSSTOP
BIDTAG_MonitorID | BMB_MINPLANES | BROADCAST_VSSTRT
BIDTAG_NominalHeight | BMB_STANDARD | BUS_16
BIDTAG_NominalWidth | BMF_CLEAR | BUS_32
BIDTAG_RedBits | BMF_DISPLAYABLE | BUSERFLAGS
BIDTAG_SourceID | BMF_INTERLEAVED | BWAITING

C

CalcIVG | CMAB_NO_INTERMED_UPDATE | COLORPLANE_TRANSPARENCY
CBump | CMAF_DUALPF_DISABLE | COMPLEMENT
ChangeExtSprite | CMAF_FULLPALETTE | COPPER_MOVE
ChangeExtSpriteA | CMAF_NO_COLOR_LOAD | COPPER_WAIT
ChangeSprite | CMAF_NO_INTERMED_UPDATE | CopySBitMap
ChangeVPBitMap | CMF_BRDNTRAN | CPR_NT_LOF
CleanMe | CMF_BRDRBLNK | CPR_NT_SHT
CleanUp | CMF_BRDRSPRT | CPR_NT_SYS
ClearEOL | CMF_CMTRANS | CPRNXTBUF
ClearRectRegion | CMF_CPTRANS | CR_NEEDS_NO_CONCEALED_RASTERS
ClearRegion | CMove | CR_NEEDS_NO_LAYERBLIT_DAMAGE
ClearScreen | CoerceMode | CT_ANTIALIAS
ClipBlit | COLORMAP_TRANSPARENCY | CTB_MAPCOLOR
CloseFont | COLORMAP_TYPE_V1_2 | CT_COLORFONT
CloseMonitor | COLORMAP_TYPE_V1_4 | CT_COLORMASK
CMAB_DUALPF_DISABLE | COLORMAP_TYPE_V36 | CTF_MAPCOLOR
CMAB_FULLPALETTE | COLORMAP_TYPE_V39 | CT_GREYFONT
CMAB_NO_COLOR_LOAD | COLORON | CWait

D

DBL_CAS | DBLPALEXTRALORESDPF2_KEY | DEFAULT_MONITOR_NAME
DBLNTSCEXTRALORESDPF2FF_KEY | DBLPALEXTRALORESDPF2LACE_KEY | DFTCH_MASK
DBLNTSCEXTRALORESDPF2_KEY | DBLPALEXTRALORESDPFFF_KEY | DI_AVAIL_NOCHIPS
DBLNTSCEXTRALORESDPF2LACE_KEY | DBLPALEXTRALORESDPF_KEY | DI_AVAIL_NOMONITOR
DBLNTSCEXTRALORESDPFFF_KEY | DBLPALEXTRALORESDPFLACE_KEY | DI_AVAIL_NOTWITHGENLOCK
DBLNTSCEXTRALORESDPF_KEY | DBLPALEXTRALORESEHBFF_KEY | DIPF_IS_AA
DBLNTSCEXTRALORESDPFLACE_KEY | DBLPALEXTRALORESEHB_KEY | DIPF_IS_BEAMSYNC
DBLNTSCEXTRALORESEHBFF_KEY | DBLPALEXTRALORESEHBLACE_KEY | DIPF_IS_DBUFFER
DBLNTSCEXTRALORESEHB_KEY | DBLPALEXTRALORESFF_KEY | DIPF_IS_DRAGGABLE
DBLNTSCEXTRALORESEHBLACE_KEY | DBLPALEXTRALORESHAMFF_KEY | DIPF_IS_DUALPF
DBLNTSCEXTRALORESFF_KEY | DBLPALEXTRALORESHAM_KEY | DIPF_IS_ECS
DBLNTSCEXTRALORESHAMFF_KEY | DBLPALEXTRALORESHAMLACE_KEY | DIPF_IS_EXTRAHALFBRITE
DBLNTSCEXTRALORESHAM_KEY | DBLPALEXTRALORES_KEY | DIPF_IS_FOREIGN
DBLNTSCEXTRALORESHAMLACE_KEY | DBLPALEXTRALORESLACE_KEY | DIPF_IS_GENLOCK
DBLNTSCEXTRALORES_KEY | DBLPALHIRESDPF2FF_KEY | DIPF_IS_HAM
DBLNTSCEXTRALORESLACE_KEY | DBLPALHIRESDPF2_KEY | DIPF_IS_LACE
DBLNTSCHIRESDPF2FF_KEY | DBLPALHIRESDPF2LACE_KEY | DIPF_IS_PAL
DBLNTSCHIRESDPF2_KEY | DBLPALHIRESDPFFF_KEY | DIPF_IS_PANELLED
DBLNTSCHIRESDPF2LACE_KEY | DBLPALHIRESDPF_KEY | DIPF_IS_PF2PRI
DBLNTSCHIRESDPFFF_KEY | DBLPALHIRESDPFLACE_KEY | DIPF_IS_PROGBEAM
DBLNTSCHIRESDPF_KEY | DBLPALHIRESEHBFF_KEY | DIPF_IS_SCANDBL
DBLNTSCHIRESDPFLACE_KEY | DBLPALHIRESEHB_KEY | DIPF_IS_SPRITES
DBLNTSCHIRESEHBFF_KEY | DBLPALHIRESEHBLACE_KEY | DIPF_IS_SPRITES_ATT
DBLNTSCHIRESEHB_KEY | DBLPALHIRESFF_KEY | DIPF_IS_SPRITES_BORDER
DBLNTSCHIRESEHBLACE_KEY | DBLPALHIRESHAMFF_KEY | DIPF_IS_SPRITES_CHNG_BASE
DBLNTSCHIRESFF_KEY | DBLPALHIRESHAM_KEY | DIPF_IS_SPRITES_CHNG_PRI
DBLNTSCHIRESHAMFF_KEY | DBLPALHIRESHAMLACE_KEY | DIPF_IS_SPRITES_CHNG_RES
DBLNTSCHIRESHAM_KEY | DBLPALHIRES_KEY | DIPF_IS_WB
DBLNTSCHIRESHAMLACE_KEY | DBLPALHIRESLACE_KEY | DisownBlitter
DBLNTSCHIRES_KEY | DBLPALLORESDPF2FF_KEY | DisplayInfoHandle
DBLNTSCHIRESLACE_KEY | DBLPALLORESDPF2_KEY | DISPLAYNAMELEN
DBLNTSCLORESDPF2FF_KEY | DBLPALLORESDPF2LACE_KEY | DisposeRegion
DBLNTSCLORESDPF2_KEY | DBLPALLORESDPFFF_KEY | DIW_HORIZ_POS
DBLNTSCLORESDPF2LACE_KEY | DBLPALLORESDPF_KEY | DIW_VRTCL_POS
DBLNTSCLORESDPFFF_KEY | DBLPALLORESDPFLACE_KEY | DIW_VRTCL_POS_SHIFT
DBLNTSCLORESDPF_KEY | DBLPALLORESEHBFF_KEY | DoCollision
DBLNTSCLORESDPFLACE_KEY | DBLPALLORESEHB_KEY | DOUBLESCAN
DBLNTSCLORESEHBFF_KEY | DBLPALLORESEHBLACE_KEY | Draw
DBLNTSCLORESEHB_KEY | DBLPALLORESFF_KEY | DrawCircle
DBLNTSCLORESEHBLACE_KEY | DBLPALLORESHAMFF_KEY | DrawEllipse
DBLNTSCLORESFF_KEY | DBLPALLORESHAM_KEY | DrawGList
DBLNTSCLORESHAMFF_KEY | DBLPALLORESHAMLACE_KEY | DTAG_DIMS
DBLNTSCLORESHAM_KEY | DBLPALLORES_KEY | DTAG_DISP
DBLNTSCLORESHAMLACE_KEY | DBLPALLORESLACE_KEY | DTAG_MNTR
DBLNTSCLORES_KEY | DBLPAL_MONITOR_ID | DTAG_NAME
DBLNTSCLORESLACE_KEY | DBLPF | DTAG_VEC
DBLNTSC_MONITOR_ID | DBUFFER | DUALPF
DBLPALEXTRALORESDPF2FF_KEY | DEFAULT_MONITOR_ID |

E

EraseRect | EURO72EXTRALORESLACE_KEY | EURO72PRODUCTDPF2_KEY
EURO36_MONITOR_ID | EURO72HAM_KEY | EURO72PRODUCTDPF_KEY
EURO72EHB_KEY | EURO72HAMLACE_KEY | EURO72PRODUCTEHBDBL_KEY
EURO72EHBLACE_KEY | EURO72LORESDBL_KEY | EURO72PRODUCTHAMDBL_KEY
EURO72EXTRAHALFBRITE_KEY | EURO72LORESDPF2_KEY | EURO72PRODUCTHAM_KEY
EURO72EXTRAHALFBRITELACE_KEY | EURO72LORESDPF_KEY | EURO72PRODUCTHAMLACE_KEY
EURO72EXTRALORESDBL_KEY | EURO72LORESEHBDBL_KEY | EURO72PRODUCT_KEY
EURO72EXTRALORESDPF2_KEY | EURO72LORESEHB_KEY | EURO72PRODUCTLACEDPF2_KEY
EURO72EXTRALORESDPF_KEY | EURO72LORESEHBLACE_KEY | EURO72PRODUCTLACEDPF_KEY
EURO72EXTRALORESEHBDBL_KEY | EURO72LORESHAMDBL_KEY | EURO72PRODUCTLACE_KEY
EURO72EXTRALORESEHB_KEY | EURO72LORESHAM_KEY | EXACT_LINE
EURO72EXTRALORESEHBLACE_KEY | EURO72LORESHAMLACE_KEY | EXTENDED_MODE
EURO72EXTRALORESHAMDBL_KEY | EURO72LORES_KEY | ExtendFont
EURO72EXTRALORESHAM_KEY | EURO72LORESLACEDPF2_KEY | ExtendFontTags
EURO72EXTRALORESHAMLACE_KEY | EURO72LORESLACEDPF_KEY | EXTEND_VSTRUCT
EURO72EXTRALORES_KEY | EURO72LORESLACE_KEY | EXTRA_HALFBRITE
EURO72EXTRALORESLACEDPF2_KEY | EURO72_MONITOR_ID | EXTRAHALFBRITE_KEY
EURO72EXTRALORESLACEDPF_KEY | EURO72PRODUCTDBL_KEY | EXTRAHALFBRITELACE_KEY

F

FindColor | FPF_REMOVED | FROM_MONITOR
FindDisplayInfo | FPF_REVPATH | FRST_DOT
Flood | FPF_ROMFONT | FSB_BOLD
FontExtent | FPF_TALLDOT | FSB_COLORFONT
FPB_DESIGNED | FPF_WIDEDOT | FSB_EXTENDED
FPB_DISKFONT | FreeBitMap | FSB_ITALIC
FPB_PROPORTIONAL | FreeColorMap | FSB_TAGGED
FPB_REMOVED | FreeCopList | FSB_UNDERLINED
FPB_REVPATH | FreeCprList | FSF_BOLD
FPB_ROMFONT | FreeDBufInfo | FSF_COLORFONT
FPB_TALLDOT | FreeGBuffers | FSF_EXTENDED
FPB_WIDEDOT | FreeRaster | FSF_ITALIC
FPF_DESIGNED | FreeSprite | FSF_TAGGED
FPF_DISKFONT | FreeSpriteData | FSF_UNDERLINED
FPF_PROPORTIONAL | FreeVPortCopLists | FS_NORMAL

G

GELGONE | GetRGB4 | GFXF_AA_MLISA
GENLOC | GetRPAttrs | GFXF_BIG_BLITS
GENLOCK_AUDIO | GetRPAttrsA | GFXF_HR_AGNUS
GENLOCK_VIDEO | GetSprite | GFXF_HR_DENISE
GetAPen | GetVPModeID | GfxFree
GetBitMapAttr | GfxAssociate | GfxLookUp
GetBPen | GFXB_AA_ALICE | GfxMove
GetColorMap | GFXB_AA_LISA | GfxNew
GetDisplayInfoData | GFXB_AA_MLISA | GfxText
GetDrMd | GfxBase | GRAPHICSNAME
GetExtSprite | GFXB_BIG_BLITS | GSTAG_ATTACHED
GetExtSpriteA | GFXB_HR_AGNUS | GSTAG_SCANDOUBLED
GetGBuffers | GFXB_HR_DENISE | GSTAG_SOFTSPRITE
GetOutlinePen | GFXF_AA_ALICE | GSTAG_SPRITE_NUM
GetRGB32 | GFXF_AA_LISA |

H

HALF_LINE | HIRESDPF_KEY | HIRES_KEY
HAM | HIRESEHB_KEY | HIRESLACEDPF2_KEY
HAM_KEY | HIRESEHBLACE_KEY | HIRESLACEDPF_KEY
HAMLACE_KEY | HIRESHAM_KEY | HIRESLACE_KEY
HIRES | HIRESHAMLACE_KEY | HOLDNMODIFY
HIRESDPF2_KEY | HIRESHAMSDBL_KEY |

I

IGNORE_MCOMPAT | InitMasks | INVERSVID
InitAnimate | InitRastPort | InvertAndCopy
InitArea | InitTmpRas | InvertDest
InitBitMap | InitView | ISGRTRX
InitGels | InitVPort | ISGRTRY
InitGMasks | INTERLACE | ISLESSX
InitGraphicsLibrary | INVALID_ID | ISLESSY

J

JAM1 JAM2

L

LACE | LORESDPF2_KEY | LORESLACEDPF_KEY
LEFTHIT | LORESDPF_KEY | LORESLACE_KEY
LoadRGB32 | LORESEHBSDBL_KEY | LORESSDBL_KEY
LoadRGB4 | LORESHAMSDBL_KEY | LPEN_SWAP_FRAMES
LoadView | LORES_KEY |
LockLayerRom | LORESLACEDPF2_KEY |

M

MakeVPort | MODE_640 | MSF_REQUEST_A2024
MAXFONTMATCHWEIGHT | ModeNotAvailable | MSF_REQUEST_NTSC
MCOMPAT_MIXED | MONITOR_ID_MASK | MSF_REQUEST_PAL
MCOMPAT_NOBODY | MONITOR_SPEC_TYPE | MSF_REQUEST_SPECIAL
MCOMPAT_SELF | MoveSprite | MUSTDRAW
MCOP_NO_MEM | MrgCop | MVP_NO_DISPLAY
MCOP_NOP | MSB_DOUBLE_SPRITES | MVP_NO_DSPINS
MCOP_OK | MSB_REQUEST_A2024 | MVP_NO_MEM
MIN_NTSC_ROW | MSB_REQUEST_NTSC | MVP_NO_VPE
MIN_PAL_ROW | MSB_REQUEST_PAL | MVP_OFF_BOTTOM
MIN_VGA70_ROW | MSB_REQUEST_SPECIAL | MVP_OK
MIN_VGA_ROW | MSF_DOUBLE_SPRITES |

N

NEW_DATABASE | NML_CAS | NTSC_MONITOR_ID
NewRegion | NOCROSSFILL | NTSC_MONITOR_NAME
NextDisplayInfo | NTSC |

O

OBP_FailIfBad | OFF_VBLANK | OpenFontTags
OBP_Precision | ON_DISPLAY | OpenMonitor
ObtainBestPen | ONE_DOT | OrRectRegion
ObtainBestPenA | ON_SPRITE | OrRegionRegion
ObtainPen | ON_VBLANK | OUTSTEP
OFF_DISPLAY | OpenFont | OVERLAY
OFF_SPRITE | OpenFontTagList | OwnBlitter

P

PAL | PENF_NO_SETCOLOR | PRECISION_EXACT
PAL_MONITOR_ID | PEN_NO_SETCOLOR | PRECISION_GUI
PAL_MONITOR_NAME | PExtendedNode | PRECISION_ICON
PAnalogSignalInterval | PExtSprite | PRECISION_IMAGE
PAnimComp | PF2PRI | PRect32
PAnimOb | PFA_FINE_SCROLL | PRectangle
PAreaInfo | PFBA | PRegion
PBitMap | PFB_FINE_SCROLL_SHIFT | PRegionRectangle
PBitScaleArgs | PF_FINE_SCROLL_MASK | PRESERVE_COLORS
PBob | PGelsInfo | PROTO_MONITOR_ID
PClipRect | PGfxBase | PSimpleSprite
PCollTable | PIsrvstr | PSpecialMonitor
PColorFontColors | PLayer | PTextAttr
PColorMap | PLayer_Info | PTextExtent
PColorTextFont | PLNCNTMSK | PTextFont
PCopInit | PLNCNTSHFT | PTextFontExtension
PCopIns | PMonitorInfo | PTmpRas
PCopList | PMonitorSpec | PTTextAttr
PCprList | PNameInfo | PUCopList
PDBufInfo | PolyDraw | PVecInfo
PDBufPacket | PPaletteExtra | PView
PDimensionInfo | PPAnimOb | PViewExtra
PDisplayInfo | PPoint | PViewPort
PENB_EXCLUSIVE | PPSimpleSprite | PViewPortExtra
PENB_NO_SETCOLOR | PQueryHeader | PVSprite
PEN_EXCLUSIVE | PRasInfo |
PENF_EXCLUSIVE | PRastPort |

Q

QBlit QBSBlit

R

RasSize | RemVSprite | RPTAG_DrawBounds
RATIO_FIXEDPART | REQUEST_A2024 | RPTAG_DrMd
RATIO_UNITY | REQUEST_NTSC | RPTAG_FgColor
ReadPixel | REQUEST_PAL | RPTAG_Font
ReadPixelArray8 | REQUEST_SPECIAL | RPTAG_MaxPen
ReadPixelLine8 | RIGHTHIT | RPTAG_OutlinePen
REALLY_PAL | RINGTRIGGER | RPTAG_PenMode
RectFill | RPTAG_AlphaMode | RPTAG_RetainAlpha
ReleasePen | RPTAG_APen | RPTAG_WriteMask
RemFont | RPTAG_BgColor | RPTAG_XPos
RemIBob | RPTAG_BPen | RPTAG_YPos

S

SafeSetOutlinePen | SetWriteMask | STANDARD_VBSTOP
SafeSetWriteMask | SetWrMsk | STANDARD_VBSTRT
SAVEBACK | SortGList | STANDARD_VIEW_X
SAVEBOB | SPECIAL_BEAMCON | STANDARD_VIEW_Y
SAVEPRESERVE | SPECIAL_FLAGS | STANDARD_VSSTOP
ScalerDiv | SPECIAL_MONITOR_TYPE | STANDARD_VSSTRT
ScrollRaster | SPRITEA_Attached | STANDARD_XOFFSET
ScrollRasterBF | SPRITEA_OldDataFormat | STANDARD_YOFFSET
ScrollVPort | SPRITEA_OutputHeight | StraightCopy
SetABPenDrMd | SPRITE_ATTACHED | StripFont
SetAfPt | SPRITEA_ViewPort | SUPER72HIRESDBL_KEY
SetAPen | SPRITEA_Width | SUPER72HIRESEHBDBL_KEY
SetBPen | SPRITEA_XReplication | SUPER72HIRESHAMDBL_KEY
SetChipRev | SPRITEA_YReplication | SUPER72LORESDBL_KEY
SETCHIPREV_A | SPRITERESN_140NS | SUPER72LORESEHBDBL_KEY
SETCHIPREV_AA | SPRITERESN_35NS | SUPER72LORESHAMDBL_KEY
SETCHIPREV_BEST | SPRITERESN_70NS | SUPER72_MONITOR_ID
SETCHIPREV_ECS | SPRITERESN_DEFAULT | SUPER72SUPERDBL_KEY
SetCollision | SPRITERESN_ECS | SUPER72SUPEREHBDBL_KEY
SetDrMd | SPRITES | SUPER72SUPERHAMDBL_KEY
SetDrPt | SS_GRAPHICS | SUPERDPF2_KEY
SetFont | STANDARD_COLORCLOCKS | SUPERDPF_KEY
SetMaxPen | STANDARD_DENISE_MAX | SUPEREHB_KEY
SetOPen | STANDARD_DENISE_MIN | SUPEREHBLACE_KEY
SetOutlinePen | STANDARD_HBSTOP | SUPERHAM_KEY
SetRast | STANDARD_HBSTRT | SUPERHAMLACE_KEY
SetRGB32 | STANDARD_HSSTOP | SUPERHIRES
SetRGB32CM | STANDARD_HSSTRT | SUPER_KEY
SetRGB4 | STANDARD_MONITOR_MASK | SUPERLACEDPF2_KEY
SetRGB4CM | STANDARD_NTSC_BEAMCON | SUPERLACEDPF_KEY
SetRPAttrs | STANDARD_NTSC_ROWS | SUPERLACE_KEY
SetRPAttrsA | STANDARD_PAL_BEAMCON | SUSERFLAGS
SetSoftStyle | STANDARD_PAL_ROWS | SyncSBitMap

T

TA_Bold | TColorMap | TOPHIT
TA_ColorFont | TColorTextFont | TPaletteExtra
TA_Designed | TCopInit | PByte
TA_DeviceDPI | TCopIns | TPoint
TA_DiskFont | TCopList | TQueryHeader
TA_Extended | TCprList | TRasInfo
TA_Italic | TDBufInfo | TRastPort
TAnalogSignalInterval | TDBufPacket | TRect32
TA_Name | TDimensionInfo | TRectangle
TAnimComp | TDisplayInfo | TRegion
TAnimOb | TE0B_NOREMFONT | TRegionRectangle
TA_Proportional | TE0F_NOREMFONT | TSimpleSprite
TAreaInfo | TExtendedNode | TSpecialMonitor
TA_RevPath | TextExtent | TTextAttr
TA_ROMFont | TextFit | TTextExtent
TA_TallDot | TextLength | TTextFont
TA_Underlined | TExtSprite | TTextFontExtension
SmallInt | TGelsInfo | TTmpRas
TA_WideDot | TGfxBase | TTTextAttr
TA_YSize | TIsrvstr | TUCopList
TBitMap | TLayer | TVecInfo
TBitScaleArgs | TLayer_Info | TView
TBob | TMonitorInfo | TViewExtra
SmallInt | TMonitorSpec | TViewPort
TClipRect | TNameInfo | TViewPortExtra
TCollTable | TODA_SAFE | TVSprite
TColorFontColors | TO_MONITOR | SmallInt

U

UCopperListInit UnlockLayerRom USER_COPPER_CLIP

V

VBeamPos | VGALORESHAMLACE_KEY | VTAG_BITPLANEKEY_GET
VC_DUALPF_Disable | VGALORES_KEY | VTAG_BITPLANEKEY_SET
VC_DUALPF_Disable_Query | VGALORESLACEDPF2_KEY | VTAG_BORDERBLANK_CLR
VC_IntermediateCLUpdate | VGALORESLACEDPF_KEY | VTAG_BORDERBLANK_GET
VC_IntermediateCLUpdate_Query | VGALORESLACE_KEY | VTAG_BORDERBLANK_SET
VC_NoColorPaletteLoad | VGA_MONITOR_ID | VTAG_BORDERNOTRANS_CLR
VC_NoColorPaletteLoad_Query | VGA_MONITOR_NAME | VTAG_BORDERNOTRANS_GET
VGA70_BEAMCON | VGAPRODUCTDBL_KEY | VTAG_BORDERNOTRANS_SET
VGA70_COLORCLOCKS | VGAPRODUCTDPF2_KEY | VTAG_BORDERSPRITE_CLR
VGA70_DENISE_MIN | VGAPRODUCTDPF_KEY | VTAG_BORDERSPRITE_GET
VGA70_HBSTOP | VGAPRODUCTEHBDBL_KEY | VTAG_BORDERSPRITE_SET
VGA70_HBSTRT | VGAPRODUCTHAMDBL_KEY | VTAG_CHROMAKEY_CLR
VGA70_HSSTOP | VGAPRODUCTHAM_KEY | VTAG_CHROMAKEY_GET
VGA70_HSSTRT | VGAPRODUCTHAMLACE_KEY | VTAG_CHROMAKEY_SET
VGA70_MONITOR_NAME | VGAPRODUCT_KEY | VTAG_CHROMA_PEN_CLR
VGA70_TOTAL_ROWS | VGAPRODUCTLACEDPF2_KEY | VTAG_CHROMA_PEN_GET
VGA70_VBSTOP | VGAPRODUCTLACEDPF_KEY | VTAG_CHROMA_PEN_SET
VGA70_VBSTRT | VGAPRODUCTLACE_KEY | VTAG_CHROMA_PLANE_GET
VGA70_VSSTOP | VGA_TOTAL_ROWS | VTAG_CHROMA_PLANE_SET
VGA70_VSSTRT | VGA_VBSTOP | VTAG_COERCE_DISP_GET
VGA_COLORCLOCKS | VGA_VBSTRT | VTAG_COERCE_DISP_SET
VGA_DENISE_MIN | VGA_VSSTOP | VTAG_DEFSPRITERESN_GET
VGAEHB_KEY | VGA_VSSTRT | VTAG_DEFSPRITERESN_SET
VGAEHBLACE_KEY | VideoControl | VTAG_END_CM
VGAEXTRAHALFBRITE_KEY | VIDEOCONTROL_BATCH | VTAG_FULLPALETTE_CLR
VGAEXTRAHALFBRITELACE_KEY | VideoControlTags | VTAG_FULLPALETTE_GET
VGAEXTRALORESDBL_KEY | VIEW_EXTRA_TYPE | VTAG_FULLPALETTE_SET
VGAEXTRALORESDPF2_KEY | VIEWPORT_EXTRA_TYPE | VTAG_IMMEDIATE
VGAEXTRALORESDPF_KEY | VPB_A2024 | VTAG_NEXTBUF_CM
VGAEXTRALORESEHBDBL_KEY | VPB_TENHZ | VTAG_NORMAL_DISP_GET
VGAEXTRALORESEHB_KEY | VPF_A2024 | VTAG_NORMAL_DISP_SET
VGAEXTRALORESEHBLACE_KEY | VPF_TENHZ | VTAG_PF1_BASE_GET
VGAEXTRALORESHAMDBL_KEY | VP_HIDE | VTAG_PF1_BASE_SET
VGAEXTRALORESHAM_KEY | VPOSRLOF | VTAG_PF1_TO_SPRITEPRI_GET
VGAEXTRALORESHAMLACE_KEY | VPXB_FREE_ME | VTAG_PF1_TO_SPRITEPRI_SET
VGAEXTRALORES_KEY | VPXB_LAST | VTAG_PF2_BASE_GET
VGAEXTRALORESLACEDPF2_KEY | VPXB_STRADDLES256 | VTAG_PF2_BASE_SET
VGAEXTRALORESLACEDPF_KEY | VPXB_STRADDLES512 | VTAG_PF2_TO_SPRITEPRI_GET
VGAEXTRALORESLACE_KEY | VPXF_FREE_ME | VTAG_PF2_TO_SPRITEPRI_SET
VGAHAM_KEY | VPXF_LAST | VTAG_SPEVEN_BASE_GET
VGAHAMLACE_KEY | VPXF_STRADDLES256 | VTAG_SPEVEN_BASE_SET
VGA_HBSTOP | VPXF_STRADDLES512 | VTAG_SPODD_BASE_GET
VGA_HBSTRT | VSOVERFLOW | VTAG_SPODD_BASE_SET
VGA_HSSTOP | VSPRITE | VTAG_SPRITERESN_GET
VGA_HSSTRT | VTAG_ATTACH_CM_GET | VTAG_SPRITERESN_SET
VGALORESDBL_KEY | VTAG_ATTACH_CM_SET | VTAG_USERCLIP_CLR
VGALORESDPF2_KEY | VTAG_BATCH_CM_CLR | VTAG_USERCLIP_GET
VGALORESDPF_KEY | VTAG_BATCH_CM_GET | VTAG_USERCLIP_SET
VGALORESEHBDBL_KEY | VTAG_BATCH_CM_SET | VTAG_VIEWPORTEXTRA_GET
VGALORESEHB_KEY | VTAG_BATCH_ITEMS_ADD | VTAG_VIEWPORTEXTRA_SET
VGALORESEHBLACE_KEY | VTAG_BATCH_ITEMS_GET | VTAG_VPMODEID_CLR
VGALORESHAMDBL_KEY | VTAG_BATCH_ITEMS_SET | VTAG_VPMODEID_GET
VGALORESHAM_KEY | VTAG_BITPLANEKEY_CLR | VTAG_VPMODEID_SET

W

WaitBlit | WeighTAMatch | WritePixel
WaitBOVP | WeighTAMatchTags | WritePixelArray8
WaitTOF | WriteChunkyPixels | WritePixelLine8

X

XorRectRegion XorRegionRegion


AddAnimOb

Add an AnimOb to the linked list of AnimObs.

Declaration

Source position: agraphics.pas line 2005

procedure AddAnimOb(

  AnOb: PAnimOb;

  AnKey: PPAnimOb;

  Rp: PRastPort

);

Arguments

AnOb | Pointer to the TAnimOb structure to be added to the list
AnKey | Address of a Pointer to the first TAnimOb in the list (anKey = nil if there are no PAnimObs in the list so far)
Rp | Pointer to a valid RastPort

Description

Links this PAnimOb into the current list pointed to by animKey. Initializes all the Timers of the AnimOb's components. Calls AddBob with each component's Bob. TRastPort.GelsInfo must point to an initialized PGelsInfo structure.

See also

Animate

Processes every AnimOb in the current animation list.


AddBob

Adds a Bob to current gel list.

Declaration

Source position: agraphics.pas line 1995

procedure AddBob(

  Bob: PBob;

  Rp: PRastPort

);

Arguments

Bob | Pointer to the Bob structure to be added to the gel list
Rp | Pointer to a TRastPort structure

Description

Sets up the system Bob flags, then links this gel into the list via AddVSprite().

See also

InitGels | initialize a gel list; must be called before using gels.
AddVSprite | Add a VSprite to the current gel list.


AddFont

Add a font to the system list

Declaration

Source position: agraphics.pas line 2060

procedure AddFont(

  TextFont: PTextFont

);

Arguments

TextFont

A TextFont structure in public ram.

Description

This function adds the text font to the system, making it available for use by any application. The font added must be in public memory, and remain until successfully removed. This function will set the tf_Accessors to 0.

See also

SetFont | Set the text font and attributes in a RastPort.
RemFont | Remove a font from the system list.


AddVSprite

Add a VSprite to the current gel list.

Declaration

Source position: agraphics.pas line 1996

procedure AddVSprite(

  VSprite: PVSprite;

  Rp: PRastPort

);

Arguments

VSprite | Pointer to the VSprite structure to be added to the gel list
Rp | Pointer to a RastPort structure

See also

InitGels

initialize a gel list; must be called before using gels.


AllocBitMap

Allocate a bitmap and attach bitplanes to it.

Declaration

Source position: agraphics.pas line 2127

function AllocBitMap(

  SizeX: LongWord;

  SizeY: LongWord;

  Depth: LongWord;

  Flags: LongWord;

  Friend_Bitmap: PBitMap

):PBitMap;

Arguments

SizeX | The width (in pixels) desired for the bitmap data.
SizeY | The height (in pixels) desired.
Depth | The number of bitplanes deep for the allocation. Pixels with at least this many bits will be allocated.
Flags | Flags for Bitmap creation (BMF_*)
Friend_Bitmap | Pointer to another bitmap, or nil. If this pointer is passed, then the bitmap data will be allocated in the most efficient form for blitting to friend_bitmap.

Description

Allocates and initializes a bitmap structure. Allocates and initializes bitplane data, and sets the bitmap's planes to point to it.

BMF_CLEAR
to specify that the allocated raster should be filled with color 0.
BMF_DISPLAYABLE
to specify that this bitmap data should be allocated in such a manner that it can be displayed. Displayable data has more severe alignment restrictions than non-displayable data in some systems.
BMF_INTERLEAVED
tells graphics that you would like your bitmap to be allocated with one large chunk of display memory for all bitplanes. This minimizes color flashing on deep displays. If there is not enough contiguous RAM for an interleaved bitmap, graphics.library will fall back to a non-interleaved one.
BMF_MINPLANES
causes graphics to only allocate enough space in the bitmap structure for "depth" plane pointers. This is for system use and should not be used by applications use as it is inefficient, and may waste memory.

NOTE:

When allocating using a friend bitmap, it is not safe to assume anything about the structure of the bitmap data if that friend BitMap might not be a standard amiga bitmap (for instance, if the workbench is running on a non-amiga display device, its Screen^.RastPort^.BitMap won't be in standard amiga format. The only safe operations to perform on a non-standard BitMap are:

  • blitting it to another bitmap, which must be either a standard Amiga bitmap, or a friend of this bitmap.
  • blitting from this bitmap to a friend bitmap or to a standard Amiga bitmap.
  • attaching it to a rastport and making rendering calls.

Good arguments to pass for the friend_bitmap are your window's RPort^.BitMap, and your screen's RastPort^.BitMap. Do not pass @(screenptr^.BitMap)!

BitMaps not allocated with BMF_DISPLAYABLE may not be used as Intuition Custom BitMaps or as RasInfo^.BitMaps. They may be blitted to a BMF_DISPLAYABLE BitMap, using one of the BltBitMap() family of functions.

See also

FreeBitMap

Free a bitmap created by AllocBitMap()


AllocDBufInfo

Allocate structure for multi-buffered animation

Declaration

Source position: agraphics.pas line 2135

function AllocDBufInfo(

  Vp: PViewPort

):PDBufInfo;

Arguments

Vp

A pointer to a ViewPort structure.

Function result

Returns 0 if there is no memory available or if the display mode of the viewport does not support double-buffering.

Description

Allocates a structure which is used by the ChangeVPBitMap() routine.

The only fields of the TDBufInfo structure which can be used by application programs are the dbi_SafeMessage, dbi_DispMessage, dbi_UserData1 and dbi_UserData2 fields.

dbi_SafeMessage and dbi_DispMessage are standard exec message structures which may be used for synchronizing your animation with the screen update.

dbi_SafeMessage is a message which is replied to when it is safe to write to the old BitMap (the one which was installed when you called ChangeVPBitMap()).

dbi_DispMessage is replied to when it is safe to call ChangeVPBitMap() again and be certain that the new frame has been seen at least once.

The dbi_UserData1 and dbi_UserData2 fields, which are stored after each message, are for your application to stuff any data into that it may need to examine when looking at the reply coming into the ReplyPort for either of the embedded Message structures.

TDBufInfo structures must be allocated with this function. The size of the structure will grow in future releases.

See also

FreeDBufInfo | Free information for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation

Example

// The following fragment shows proper double buffering synchronization:
var
  SafeToChange: Boolean = True;
  SafeToWrite: Boolean = True;
  CurBuffer: Integer = 1;
  Ports: array[0..1] of PMsgPort; // reply ports for DispMessage and SafeMessage
  BmPtrs: array[0..1] of PBitmap;
  myDBI: PDBufInfo;
begin
  //... allocate bitmap pointers, DBufInfo, set up viewports, create Ports etc.
  myDBI^.dbi_SafeMessage.mn_ReplyPort := ports[0];
  myDBI^.dbi_DispMessage.mn_ReplyPort := ports[1];
  while not done do
  begin
    if not SafeToWrite then
    begin
      while GetMsg(ports[0]) = nil do
        Wait(1 shl ports[0]^.mp_SigBit);
    end;
    SafeToWrite := True;
// ... render to bitmap # CurBuffer.
    if not SafeToChange then
    begin
      while GetMsg(ports[1]) = nil do
        Wait(1 shl ports[1]^.mp_SigBit);
    end;
    SafeToChange := True;
    WaitBlit();         // be sure rendering has finished
    ChangeVPBitMap(vp, BmPtrs[CurBuffer], myDBI);
    SafeToChange := False;
    SafeToWrite := False;
    CurBuffer := (CurBuffer + 1) and 1; // toggle current buffer
  end;
  if not SafeToChange then
  begin
    while GetMsg(ports[1]) = nil do
      Wait(1 shl ports[1]^.mp_SigBit);
  end;
  if not SafeToWrite then
  begin
    while GetMsg(ports[0]) = nil do
      Wait(1 shl ports[0]^.mp_SigBit);
  end;
end;


AllocRaster

Allocate space for a bitplane.

Declaration

Source position: agraphics.pas line 2062

function AllocRaster(

  Width: LongWord;

  Height: LongWord

):PByte;

Arguments

Width | number of columns in bitplane
Height | number of rows in bitplane

Function result

Pointer to first word in bitplane, or nil if it was not possible to allocate the desired amount of memory.

Description

This function calls the memory allocation routines to allocate memory space for a bitplane "width" bits wide and "height" bits high.

In order to assure proper alignment of display memory, the AllocBitMap() function should be used instead of AllocRaster when you wish to allocate display memory (rasters which are attached to a ViewPort or Screen).

See also

FreeRaster

Release an allocated area to the system free memory pool


AllocSpriteData

VarArgs Version of AllocSpriteDataA()

Declaration

Source position: agraphics.pas line 2158

function AllocSpriteData(

  Bm: PBitMap;

  const Tags: array of PtrUInt

):PExtSprite;


AllocSpriteDataA

Allocate sprite data and convert from a bitmap.

Declaration

Source position: agraphics.pas line 2143

function AllocSpriteDataA(

  Bm: PBitMap;

  Tags: PTagItem

):PExtSprite;

Function result

a pointer to a ExtSprite structure, or nil if there is a failure. You should pass this pointer to FreeSpriteData() when finished with the sprite.

Description

Allocate memory to hold a sprite image, and convert the passed-in bitmap data to the appropriate format. The tags allow specification of width, scaling, and other options.

See also

FreeSpriteData | free sprite data allocated by AllocSpriteData()
FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.
AllocBitMap | Allocate a bitmap and attach bitplanes to it.
AllocSpriteData | VarArgs Version of AllocSpriteDataA()


AndRectRegion

Perform 2d AND operation of rectangle with region, leaving result in region.

Declaration

Source position: agraphics.pas line 2064

procedure AndRectRegion(

  Region: PRegion;

  Rectangle: PRectangle

);

Description

Clip away any portion of the region that exists outside of the rectangle. Leave the result in region. Unlike the other rect-region primitives, AndRectRegion() cannot fail.

See also

AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.
ClearRectRegion


AndRegionRegion

Perform 2d AND operation of one region with second region, leaving result in second region.

Declaration

Source position: agraphics.pas line 2084

function AndRegionRegion(

  SrcRegion: PRegion;

  DestRegion: PRegion

):LongBool;

Arguments

SrcRegion | A pointer to Region structure
DestRegion | A pointer to Region structure to use and for result

Function result

Returns True if successful operation, returns False if ran out of memory

Description

Remove any portion of region2 that is not in region1.

See also

OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.
ClearRectRegion


Animate

Processes every AnimOb in the current animation list.

Declaration

Source position: agraphics.pas line 2006

procedure Animate(

  AnKey: PPAnimOb;

  Rp: PRastPort

);

Arguments

AnKey | Address of the variable that points to the head AnimOb
Rp | Pointer to the RastPort structure

Description

For every AnimOb in the list:

  • update its location and velocities
  • call the AnimOb's special routine if one is supplied

for each component of the AnimOb:

  • if this sequence times out, switch to the new one
  • call this component's special routine if one is supplied
  • set the sequence's VSprite's y,x coordinates based on whatever these routines cause

See also

AddAnimOb

Add an AnimOb to the linked list of AnimObs.


AreaCircle

Draws a Circle in an Area

Declaration

Source position: agraphics.pas line 2185

function AreaCircle(

  Rp: PRastPort;

  xCenter: SmallInt;

  yCenter: SmallInt;

  r: SmallInt

):LongWord;

Arguments

Rp | A pointer to a RastPort
xCenter | X coordinate for center of Circle
yCenter | Y coordinate for center of Circle
r | Radius of Circle

Description

Calls AreaEllipse() with a = b = r


AreaDraw

Add a point to a list of end points for areafill.

Declaration

Source position: agraphics.pas line 2023

function AreaDraw(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongInt;

Arguments

Rp | Points to a RastPort structure.
X | X coordinate of a point in the raster.
Y | Y coordinate of a point in the raster.

Function result

0 for success, else -1 if no there was no space left in the vector list.

Description

Add point to the vector buffer.

See also

InitArea | Initialize vector collection matrix
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaCircle | Draws a Circle in an Area
AreaEnd | Process table of vectors and ellipses and produce areafill.


AreaEllipse

Add a ellipse to areainfo list for areafill.

Declaration

Source position: agraphics.pas line 2011

function AreaEllipse(

  Rp: PRastPort;

  XCenter: LongInt;

  YCenter: LongInt;

  a: LongInt;

  b: LongInt

):LongInt;

Arguments

Rp | A pointer to a RastPort structure
XCenter | X coordinate of the centerpoint relative to the rastport.
YCenter | Y coordinate of the centerpoint relative to the rastport.
a | The horizontal radius of the ellipse (note: a must be > 0)
b | The vertical radius of the ellipse (note: b must be > 0)

Function result

0 for success, or -1 if there is no space left in the vector list

Description

Add an ellipse to the vector buffer. It will be draw when AreaEnd() is called.

See also

InitArea | Initialize vector collection matrix
AreaMove | Define a new starting point for a new shape in the vector list.
AreaDraw | Add a point to a list of end points for areafill.
AreaCircle | Draws a Circle in an Area
AreaEnd | Process table of vectors and ellipses and produce areafill.


AreaEnd

Process table of vectors and ellipses and produce areafill.

Declaration

Source position: agraphics.pas line 2024

function AreaEnd(

  Rp: PRastPort

):LongInt;

Arguments

Rp

A pointer to a RastPort structure which specifies where the filled regions will be rendered to.

Function result

0 for success, or -1 if an error occurred anywhere.

Description

Trigger the filling operation. Process the vector buffer and generate required fill into the raster planes. After the fill is complete, reinitialize for the next AreaMove or AreaEllipse. Use the raster set up by InitTmpRas when generating an areafill mask.

Errors

There is still a problem when some polygons are filled that pixels are missing. This could be due to the way lines are drawn. All lines should be drawn from lower y coordinates to higher y coordinates since this is the way the algorithm calculates lines here. For example, it might make a difference whether a line is drawn from lower to higher y coordinates.

See also

InitArea | Initialize vector collection matrix
AreaMove | Define a new starting point for a new shape in the vector list.
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaCircle | Draws a Circle in an Area


AreaMove

Define a new starting point for a new shape in the vector list.

Declaration

Source position: agraphics.pas line 2022

function AreaMove(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongInt;

Arguments

Rp | Points to a RastPort structure
X | X position in Raster
Y | Y position in Raster

Function result

0 for success, or -1 if there is no space left in the vector list

Description

Close the last polygon and start another polygon at (x,y). Add the necessary points to vector buffer. Closing a polygon may result in the generation of another AreaDraw() to close previous polygon. Remember to have an initialized TAreaInfo structure attached to the RastPort.

See also

InitArea | Initialize vector collection matrix
AreaEnd | Process table of vectors and ellipses and produce areafill.
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaCircle | Draws a Circle in an Area


AskFont

Get the text attributes of the current font

Declaration

Source position: agraphics.pas line 2059

procedure AskFont(

  Rp: PRastPort;

  TextAttr: PTextAttr

);

Arguments

Rp | The RastPort from which the text attributes are extracted
TextAttr | The TextAttr structure to be filled. Note that there is no support for a TTextAttr.

Description

This function fills the text attributes structure with the attributes of the current font in the RastPort.


AskSoftStyle

Get the soft style bits of the current font.

Declaration

Source position: agraphics.pas line 1992

function AskSoftStyle(

  Rp: PRastPort

):LongWord;

Arguments

Rp

The RastPort from which the font and style are extracted.

Function result

Those bits in the style algorithmically generated. Style bits that are not defined are also set.

Description

This function returns those style bits of the current font that are not intrinsic in the font itself, but algorithmically generated. These are the bits that are valid to set in the enable mask for SetSoftStyle().

See also

SetSoftStyle

Set the soft style of the current font.


AttachPalExtra

Allocate and attach a palette sharing structure to a colormap

Declaration

Source position: agraphics.pas line 2114

function AttachPalExtra(

  Cm: PColorMap;

  Vp: PViewPort

):LongInt;

Arguments

Cm | A pointer to a color map created by GetColorMap().
Vp | A pointer to the viewport structure associated with the ColorMap.

Function result

0 if sucessful, else an error number. The only currently defined error number is out of memory (1).

Description

Allocates and attaches a PalExtra structure to a ColorMap. This is necessary for color palette sharing to work. The PalExtra structure will be freed by FreeColorMap(). The set of available colors will be determined by the mode and depth of the viewport.

Note:

This function is for use with custom ViewPorts and custom ColorMaps, as Intuition attaches a PalExtra to all of its Screens. If there is already a PalExtra associated with the ColorMap, then this function will do nothing.

See also

GetColorMap | Allocate and initialize Colormap
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.
ObtainPen | Obtain a free palette entry for use by your program.
ObtainBestPenA | Search for the closest color match, or allocate a new one.


AttemptLockLayerRom

Attempt to Lock Layer structure by ROM(gfx lib) code

Declaration

Source position: agraphics.pas line 2087

function AttemptLockLayerRom(

  Layer: PLayer

):LongBool;

Function result

True or False depending on whether the Layer was successfully locked by the caller.

Description

Query the current state of the lock on this Layer. If it is already locked then return False, could not lock. If the Layer was not locked then lock it and return True. This call does not destroy any registers. This call nests so that callers in this chain will not lock themselves out.

See also

LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.


BestModeID

VarArgs version of BestModeIDA()

Declaration

Source position: agraphics.pas line 2162

function BestModeID(

  const Tags: array of PtrUInt

):LongWord;


BestModeIDA

Calculate the best ModeID with given parameters

Declaration

Source position: agraphics.pas line 2148

function BestModeIDA(

  Tags: PTagItem

):LongWord;

Arguments

Tags

A pointer to an array of TagItems. (BIDTAGS_*)

Function result

ID of the best mode to use, or INVALID_ID if a match could not be found.

Description

This function takes into account the Compatability of the Monitor being matched to, and the source ViewPort or ModeID. Incompatibilitys will cause a result of INVALID_ID.

BIDTAG_NominalWidth, BIDTAG_NominalHeight, BIDTAG_DesiredWidth, BIDTAG_DesiredHeight, must all be non-0.

The comparisons are made against the DimensionInfo->Nominal values. ie, this will not return a best fit against overscan dimensions.

Snippet

IFF Display Program with a HAM image, to be displayed in the same monitor type as the Workbench ViewPort.

ID := BestModeID([BIDTAG_NominalWidth,  IFFImage^.Width,
                  BIDTAG_NominalHeight, IFFImage^.Height,
                  BIDTAG_Depth,         IFFImage^.Depth,
                  BIDTAG_DIPFMustHave,  DIPF_IS_HAM,
                  BIDTAG_MonitorID,     (GetVPModeID(WbVP) and MONITOR_ID_MASK)]);

To make an interlace version of a ViewPort:

ID := BestModeID([BIDTAG_ViewPort, ThisViewPort,
                  BIDTAG_MustHave, DIFP_IS_LACE]);

See also

BestModeID

VarArgs version of BestModeIDA()


BitMapScale

Perform raster scaling on a bit map.

Declaration

Source position: agraphics.pas line 2091

procedure BitMapScale(

  BitScaleArgs: PBitScaleArgs

);

Arguments

BitScaleArgs

Structure of parameters describing scale

Description

Scale a source bit map to a non-overlapping destination bit map.

Overlapping source and destination bitmaps are not supported Make sure that you provide enough memory for the destination bitmap to hold the result

In the destination bitmap only the area where the scaled source bitmap is put into is changed. A frame of the old bitmap is left.

Pass a BitScaleArgs structure filled with the following arguments to this function:

bsa_SrcX, bsa_SrcY
upper left coordinate in source bitmap
bsa_SrcWidth, bsa_SrcHeight
Width and Height of source bitmap
bsa_DestX, bsa_DestY
upper left coordinate in destination bitmap
bsa_DestWidth, bsa_DestHeight
this function will set these values. Use the bsa_???Factor for scaling
bsa_XSrcFactor:bsa_XDestFactor
Set these to get approximately the same ratio as bsa_SrcWidth:bsa_DestWidth, but usually not exactly the same number.
bsa_YSrcFactor:bsa_YDestFactor
Set these to get approximately the same ratio as bsa_SrcHeight:DestHeight, but usually not exactly the same number.
bsa_SrcBitMap
pointer to source bitmap to be scaled
bsa_DestBitMap
pointer to destination bitmap which will hold the scaled bitmap. Make sure it's big enough!
bsa_Flags
reserved for future use. Set it to zero!
bsa_XDDA, bsa_YDDA
for future use.
bsa_Reserved1, bsa_Reserved2
for future use.

bsa_DestWidth and bsa_DestHeight will be set by this function

See also

ScalerDiv

Get the scaling result that BitMapScale would.


BltBitMap

Move a rectangular region of bits in a BitMap.

Declaration

Source position: agraphics.pas line 1983

function BltBitMap(

  srcBitMap: PBitMap;

  XSrc: LongInt;

  YSrc: LongInt;

  DestBitMap: PBitMap;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt;

  MinTerm: LongWord;

  Mask: LongWord;

  TempA: PByte

):LongInt;

Arguments

srcBitMap | Copy from this bitmap. as a special case, if a plane pointer in the SrcBitMap is nil, it acts as a pointer to a plane of all zeros, and if the plane pointer is $ffffffff, it acts as a pointer to a plane of all ones.
XSrc | Top Left corner of the Source rectangle
YSrc | Valid range is positive signed integer such that the raster word's offset 0..(32767-Size)
DestBitMap | Copy to this bitmap. May be the same as srcBitMap.
XDest | the x and y coordinates of the upper left corner of the destination for the rectangle.
YDest | Valid range is as for Src.
XSize | The size of the rectangle to be moved.
YSize | Valid range is (X: 1..976; Y: 1..1023 such that final raster word's offset is 0..32767)
MinTerm | See description
Mask | the write mask to apply to this operation. Bits set indicate the corresponding planes (if not greater than the minimum plane count) are to participate in the operation. Typically this is set to $ff.
TempA | If the copy overlaps exactly to the left or right (i.e. the scan line addresses overlap), and TempA is non-zero, it points to enough chip accessible memory to hold a line of A source for the blit (ie CHIP RAM). BltBitMap will allocate (and free) the needed TempA if none is provided and one is needed. Blit overlap is determined from the relation of the first non-masked planes in the source and destination bit maps.

Function result

The number of planes actually involved in the blit.

Description

Perform non-destructive blits to move a rectangle from one area in a BitMap to another area, which can be on a different BitMap. This blit is assumed to be friendly: no error conditions (e.g. a rectangle outside the BitMap bounds) are tested or reported.

If a special hardware is available, this function will use it.

MinTerm:

How to copy. Most useful values are 0x00C0 for a vanilla copy, 0x0030 to invert the source and then copy or 0x0050 to ignore the source and just invert the destination. If you want to calculate other values, then you must know that channel A is set, if you are inside the rectangle, channel B is the source and channel C is the destination of the rectangle.

Bit | ABC
0 | 000
1 | 001
2 | 010
3 | 011
4 | 100
5 | 101
6 | 110
7 | 111

So 0x00C0 means: D is set if one is inside the rectangle (A is set) and B (the source) is set and cleared otherwise.

To fill the rectangle, you would want to set D when A is set, so the value is 0x00F0.

See also

ClipBlit | Calls BltBitMap() after accounting for windows
BltBitMapRastPort | Blit from source bitmap to destination rastport.


BltBitMapRastPort

Blit from source bitmap to destination rastport.

Declaration

Source position: agraphics.pas line 2081

procedure BltBitMapRastPort(

  SrcBitMap: PBitMap;

  XSrc: LongInt;

  YSrc: LongInt;

  DestRp: PRastPort;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt;

  MinTerm: LongWord

);

Arguments

SrcBitMap | A pointer to the source bitmap
XSrc | X offset into source bitmap
YSrc | Y offset into source bitmap
DestRp | A pointer to the destination rastport
XDest | X offset into dest rastport
YDest | Y offset into dest rastport
XSize | Width of blit in pixels
YSize | Height of blit in rows
MinTerm | Minterm to use for this blit see description

Description

Blits from source bitmap to position specified in destination rastport using minterm.

MinTerm:

How to copy. Most useful values are 0x00C0 for a vanilla copy, 0x0030 to invert the source and then copy or 0x0050 to ignore the source and just invert the destination. If you want to calculate other values, then you must know that channel A is set, if you are inside the rectangle, channel B is the source and channel C is the destination of the rectangle.

Bit | ABC
0 | 000
1 | 001
2 | 010
3 | 011
4 | 100
5 | 101
6 | 110
7 | 111

So 0x00C0 means: D is set if one is inside the rectangle (A is set) and B (the source) is set and cleared otherwise.

To fill the rectangle, you would want to set D when A is set, so the value is 0x00F0.

See also

BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ClipBlit | Calls BltBitMap() after accounting for windows


BltClear

Clear a block of memory words to zero.

Declaration

Source position: agraphics.pas line 2030

procedure BltClear(

  MemBlock: PByte;

  ByteCount: LongWord;

  Flags: LongWord

);

Arguments

MemBlock | pointer to local memory to be cleared memBlock is assumed to be even.
ByteCount | if bit 1 is set to 1: bytecount contains an even number of bytes to clear if bit 1 is set to 0: low 16 bits are taken as number of bytes per row and upper 16 bits are taken as number of rows.
Flags | set bit 0 to force function to wait until the blit is done. set bit 1 to use row/bytesperrow.

Description

For memory that is local and blitter accessible, the most efficient way to clear a range of memory locations is to use the system's most efficient data mover, the blitter. This command accepts the starting location and count and clears that block to zeros.

THIS FUNCTION IS DEPRECATED


BltClearWait

Waits for blit to finish

Declaration

Source position: agraphics.pas line 872

const BltClearWait = 1;


BltClearXY

Use Row/Bytes per row method

Declaration

Source position: agraphics.pas line 873

const BltClearXY = 2;


BltMaskBitMapRastPort

Blit from source bitmap to destination rastport with masking of source image.

Declaration

Source position: agraphics.pas line 2086

procedure BltMaskBitMapRastPort(

  SrcBitMap: PBitMap;

  XSrc: LongInt;

  YSrc: LongInt;

  DestRp: PRastPort;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt;

  MinTerm: LongWord;

  BltMask: PByte

);

Arguments

SrcBitMap | A pointer to the source bitmap
XSrc | X offset into source bitmap
YSrc | Y offset into source bitmap
DestRp | A pointer to the destination rastport
XDest | X offset into dest rastport
YDest | Y offset into dest rastport
XSize | Width of blit in pixels
YSize | Height of blit in rows
MinTerm | either (ABC or ABNC or ANBC) if copy source and blit thru mask or (ANBC) if invert source and blit thru mask
BltMask | A pointer to the single bit-plane mask, which must be the same size and dimensions as the planes of the source bitmap.

Description

Blits from source bitmap to position specified in destination rastport using bltmask to determine where source overlays destination, and minterm to determine whether to copy the source image "as is" or to "invert" the sense of the source image when copying. In either case, blit only occurs where the mask is non-zero.

See also

BltBitMapRastPort

Blit from source bitmap to destination rastport.


BltPattern

Using standard drawing rules for areafill, blit through a mask.

Declaration

Source position: agraphics.pas line 2032

procedure BltPattern(

  Rp: PRastPort;

  Mask: PByte;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt;

  MaskBPR: LongWord

);

Arguments

Rp | Points to the destination RastPort for the blit.
Mask | points to 2 dimensional mask if needed if mask = nil then use a rectangle.
XMin | coordinates of upper left of rectangular region in RastPort
XMax | points to lower right of rectangular region in RastPort

Description

Blit using drawmode,areafill pattern, and mask at position rectangle (xl,yl) (maxx,maxy).

See also

AreaEnd

Process table of vectors and ellipses and produce areafill.


BltTemplate

Cookie cut a shape in a rectangle to the RastPort.

Declaration

Source position: agraphics.pas line 1984

procedure BltTemplate(

  Source: PByte;

  XSrc: LongInt;

  SrcMod: LongInt;

  DestRP: PRastPort;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt

);

Arguments

Source | A pointer to the first (nearest) word of the template mask.
XSrc | X bit offset into the template mask (range 0..15).
SrcMod | Number of bytes per row in template mask.
DestRP | A pointer to destination RastPort.
XDest | x coordinate of the upper left corner of the destination for the blit.
YDest | y coordinate of the upper left corner of the destination for the blit.
XSize | x size of the rectangle to be used as the template.
YSize | y size of the rectangle to be used as the template.

Description

This function draws the image in the template into the RastPort in the current color and drawing mode at the specified position. The template is assumed not to overlap the destination. If the template falls outside the RastPort boundary, it is truncated to that boundary.

Note:

The SrcTemplate pointer should point to the "nearest" word (rounded down) of the template mask. Fine alignment of the mask is achieved by setting the SrcX bit offseet within the range of 0 to 15 decimal.

See also

BltBitMap

Move a rectangular region of bits in a BitMap.


BNDRYOFF

Turn Boundary off

Declaration

Source position: agraphics.pas line 2167

procedure BNDRYOFF(

  w: PRastPort

);


CalcIVG

Calculate the number of blank lines above a ViewPort

Declaration

Source position: agraphics.pas line 2113

function CalcIVG(

  V: PView;

  Vp: PViewPort

):LongWord;

Function result

the number of ViewPort resolution scan lines needed to execute all the copper instructions for ViewPort, or 0 if any error

Description

To calculate the maximum number of blank lines above a viewport needed to load all the copper instructions, after accounting for the viewport bandwidth and size.

Errors

This function is unimplemented.


CBump

Increment user copper list pointer (bump to next position in list).

Declaration

Source position: agraphics.pas line 2041

procedure CBump(

  CopList: PUCopList

);

Arguments

CopList

A pointer to UCopList structure

Description

Increment pointer to space for next instruction in user copper list.

Note:

CBump is usually invoked for the programmer as part of the helper functions CWAIT or CMOVE.

See also

CWAIT | Append copper wait instruction to user copper list.
CMOVE | Append copper move instruction to user copper list.


ChangeExtSprite

VarArgs version of ChangeExtSpriteA

Declaration

Source position: agraphics.pas line 2159

function ChangeExtSprite(

  Vp: PViewPort;

  OldSprite: PExtSprite;

  NewSprite: PExtSprite;

  const Tags: array of PtrUInt

):LongInt;


ChangeExtSpriteA

Change the sprite image pointer.

Declaration

Source position: agraphics.pas line 2144

function ChangeExtSpriteA(

  Vp: PViewPort;

  OldSprite: PExtSprite;

  NewSprite: PExtSprite;

  Tags: PTagItem

):LongInt;

Arguments

Vp | A pointer to ViewPort structure that this sprite is relative to, or nil if relative only top of View
OldSprite | A pointer the old ExtSprite structure
NewSprite | A pointer to the new ExtSprite structure.
Tags | Tags for change the Sprite (GSTAG_*)

Function result

0 if there was an error.

Description

Attempt to change which sprite is displayed for a given sprite engine.

See also

ChangeExtSprite | VarArgs version of ChangeExtSpriteA
FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.


ChangeSprite

Change the sprite image pointer.

Declaration

Source position: agraphics.pas line 2050

procedure ChangeSprite(

  Vp: PViewPort;

  Sprite: PSimpleSprite;

  NewData: PWord

);

Arguments

Vp | Pointer to ViewPort structure that this sprite is relative to, or nil if relative only top of View
NewData | Pointer to new data structure

Description

The sprite image is changed to use the data starting at newdata

Errors

This function is unimplemented.

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeExtSpriteA | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
AddVSprite | Add a VSprite to the current gel list.


ChangeVPBitMap

Change display memory address for multi-buffered animation

Declaration

Source position: agraphics.pas line 2131

procedure ChangeVPBitMap(

  Vp: PViewPort;

  Bm: PBitMap;

  Db: PDBufInfo

);

Arguments

Vp | A pointer to a viewport
Bm | This BitMap structure must be of the same layout as the one attached to the viewport (same depth, alignment, and BytesPerRow).
Db | A pointer to a DBufInfo.

Description

Changes the area of display memory which will be displayed in a viewport. This can be used to implement double (or triple) buffering, a method of achieving smooth animation.

This will set the vp^.RasInfo^.BitMap field to the bm pointer which is passed.

When using the synchronization features, you must carefully insure that all messages have been replied to before calling FreeDBufInfo or calling ChangeVPBitMap with the same DBufInfo.

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
AllocBitMap | Allocate a bitmap and attach bitplanes to it.


ClearEOL

Clear from current position to end of line.

Declaration

Source position: agraphics.pas line 1985

procedure ClearEOL(

  Rp: PRastPort

);

Arguments

Rp

A pointer to RastPort structure

Description

Clear a rectangular swath from the current position to the right edge of the rastPort. The height of the swath is taken from that of the current text font, and the vertical positioning of the swath is adjusted by the text baseline, such that text output at this position would lie wholly on this newly cleared area. Clearing consists of setting the color of the swath to zero, or, if the DrawMode is 2, to the BgPen. This function may use the blitter.

See also

GfxText | Write text characters (no formatting).
ClearScreen | Clear from current position to end of RastPort.
SetRast | Set an entire drawing area to a specified color.


ClearRectRegion

Declaration

Source position: agraphics.pas line 2067

function ClearRectRegion(

  Region: PRegion;

  Rectangle: PRectangle

):LongBool;


ClearRegion

Declaration

Source position: agraphics.pas line 2068

procedure ClearRegion(

  Region: PRegion

);


ClearScreen

Clear from current position to end of RastPort.

Declaration

Source position: agraphics.pas line 1986

procedure ClearScreen(

  Rp: PRastPort

);

Arguments

Rp

A pointer to RastPort structure

Description

Clear a rectangular swath from the current position to the right edge of the rastPort with ClearEOL(), then clear the rest of the screen from just beneath the swath to the bottom of the rastPort. Clearing consists of setting the color of the swath to zero, or, if the DrawMode is 2, to the BgPen. This function may use the blitter.

See also

ClearEOL | Clear from current position to end of line.
GfxText | Write text characters (no formatting).
SetRast | Set an entire drawing area to a specified color.


ClipBlit

Calls BltBitMap() after accounting for windows

Declaration

Source position: agraphics.pas line 2072

procedure ClipBlit(

  SrcRp: PRastPort;

  XSrc: LongInt;

  YSrc: LongInt;

  DestRp: PRastPort;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt;

  MinTerm: LongWord

);

Arguments

SrcRp | A pointer to the RastPort of the source for your blit
XSrc | The left offset into Src for your data
YSrc | The top offset into Src for your data
DestRp | A pointer to the RastPort to receive the blitted data
XDest | The left offset into the destination RastPort
YDest | The top offset into the destination RastPort
XSize | the width of the blit (must be ta least 1)
YSize | the height of the blit (must be at least 1)
MinTerm | the boolean blitter function, where SRCB is associated with the Src RastPort and SRCC goes to the Dest RastPort. see BltBitMap

Description

Performs the same function as BltBitMap(), except that it takes into account the Layers and ClipRects of the layer library, all of which are (and should be) transparent to you. So, whereas BltBitMap() requires pointers to BitMaps, ClipBlit requires pointers to the RastPorts that contain the Bitmaps, Layers, etcetera.

If you are going to blit blocks of data around via the RastPort of your Intuition Window, you must call this routine (rather than BltBitMap()).

Either the Src RastPort, the Dest RastPort, both, or neither, can have Layers. This routine takes care of all cases.

See BltBitMap() for a thorough explanation.

See also

BltBitMap

Move a rectangular region of bits in a BitMap.


CloseFont

Release a pointer to a system font.

Declaration

Source position: agraphics.pas line 1991

procedure CloseFont(

  TextFont: PTextFont

);

Arguments

TextFont

A font pointer as returned by OpenFont() or OpenDiskFont()

Description

This function indicates that the font specified is no longer in use. It is used to close a font opened by OpenFont(), so that fonts that are no longer in use do not consume system resources.


CloseMonitor

Close a MonitorSpec

Declaration

Source position: agraphics.pas line 2098

function CloseMonitor(

  MonitorSpec: PMonitorSpec

):LongBool;

Function result

False if MonitorSpec closed uneventfully. True if MonitorSpec could not be closed.

Description

Relinquish access to a MonitorSpec.


CMove

Append copper move instruction to user copper list.

Declaration

Source position: agraphics.pas line 2042

procedure CMove(

  CopList: PUCopList;

  Destination: Pointer;

  Data: LongInt

);

Arguments

CopList

A pointer to a UCopList structure

Description

Add a copper move instruction to the given user copper list. The copper is told to move a value to register reg. If you are using CMOVE() a call to CMove() and CBump() will be made.


CoerceMode

Calculate ViewPort mode coercion

Declaration

Source position: agraphics.pas line 2130

function CoerceMode(

  Vp: PViewPort;

  MonitorID: LongWord;

  Flags: LongWord

):LongWord;

Arguments

MonitorID | Monitor number to coerce to (i.e. a mode masked with MONITOR_ID_MASK)
Flags | PRESERVE_COLORS = keep the number of bitplanes in the ViewPort AVOID_FLICKER = do not coerce to an interlace mode

Function result

ID of best mode to coerce to, or INVALID_ID if could not coerce

Description

To determine the best mode in the MonitorID to coerce RealViewPort to, given the restrictions set in Flags.

This function takes into account the compatibility of the Monitor being coerced to, and the ViewPort that is being coerced. Incompatibilities will cause a result of INVALID_ID.

Snippet

newmode := CoerceMode(vp, VGA_MONITOR_ID, PRESERVE_COLORS);

Errors

This function is unimplemented.


CopySBitMap

Syncronize Layer window with contents of Super BitMap

Declaration

Source position: agraphics.pas line 2055

procedure CopySBitMap(

  Layer: PLayer

);

Description

This is the inverse of SyncSBitMap(). Copy all bits from SuperBitMap to Layer bounds. This is used for those functions that do not want to deal with the ClipRect structures but do want to be able to work with a SuperBitMap Layer.

See also

LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
SyncSBitMap | Syncronize Super BitMap with whatever is in the standard Layer bounds.


CWait

Append copper wait instruction to user copper list.

Declaration

Source position: agraphics.pas line 2043

procedure CWait(

  CopList: PUCopList;

  V: LongInt;

  H: LongInt

);

Arguments

CopList | A pointer to UCopList structure
V | vertical beam position (relative to top of viewport)
H | horizontal beam position

Description

Add instruction to wait for vertical beam position v and horizontal position h to this intermediate copper list.

Errors

It's illegal to wait for horizontal values greater than 222 decimal!

See also

CMOVE

Append copper move instruction to user copper list.


DisownBlitter

Returns blitter to free state.

Declaration

Source position: agraphics.pas line 2057

procedure DisownBlitter;

Description

Free blitter up for use by other blitter users.

See also

OwnBlitter

get the blitter for private usage


DisposeRegion

Return all space for this region to free memory pool.

Declaration

Source position: agraphics.pas line 2069

procedure DisposeRegion(

  Region: PRegion

);

Arguments

Region

A pointer to Region structure

Description

Free all RegionRectangles for this Region then free the Region itself.

See also

NewRegion

Allocates memory for a new Region and initializes it to an empty Region.


DoCollision

Test every gel in gel list for collisions.

Declaration

Source position: agraphics.pas line 1997

procedure DoCollision(

  Rp: PRastPort

);

Arguments

Rp

A pointer to a RastPort

Description

Tests each gel in gel list for boundary and gel-to-gel collisions. On detecting one of these collisions, the appropriate collision- handling routine is called. See the documentation for a thorough description of which collision routine is called. This routine expects to find the gel list correctly sorted in Y,X order. The system routine SortGList() performs this function for the user.

See also

InitGels | initialize a gel list; must be called before using gels.
SortGList | Sort the current gel list, ordering its y,x coordinates.


Draw

Draw a line between the current pen position and the new x,y position.

Declaration

Source position: agraphics.pas line 2021

procedure Draw(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

);

Arguments

Rp | A pointer to the destination RastPort
X | X coordinate of where in the RastPort to end the line.
Y | Y coordinate of where in the RastPort to end the line.

Description

Draw a line from the current pen position to (x,y).

Errors

Not yet implemented:

  • handle layer^.Scroll_X/Scroll_Y.
  • handle FRST_DOT which indicates whether to draw or to don't draw first pixel of line. Important for COMPLEMENT drawmode.

See also

GfxMove

Move graphics pen position.


DrawCircle

Draws a Circle

Declaration

Source position: agraphics.pas line 2184

procedure DrawCircle(

  Rp: PRastPort;

  xCenter: LongInt;

  yCenter: LongInt;

  r: LongInt

);

Arguments

Rp | A pointer to a RastPort
xCenter | X coordinate for center of Circle
yCenter | Y coordinate for center of Circle
r | Radius of Circle

Description

Calls DrawEllipse() with a = b = r

See also

DrawEllipse

Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively


DrawEllipse

Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively

Declaration

Source position: agraphics.pas line 2010

procedure DrawEllipse(

  Rp: PRastPort;

  XCenter: LongInt;

  YCenter: LongInt;

  a: LongInt;

  b: LongInt

);

Arguments

Rp | A pointer to the RastPort into which the ellipse will be drawn.
XCenter | X coordinate of the centerpoint relative to the rastport.
YCenter | Y coordinate of the centerpoint relative to the rastport.
a | The horizontal radius of the ellipse (note: a must be > 0)
b | The vertical radius of the ellipse (note: b must be > 0)

Description

Creates an elliptical outline within the rectangular region specified by the parameters, using the current foreground pen color. this routine does not clip the ellipse to a non-layered rastport.

See also

DrawCircle

Draws a Circle


DrawGList

Process the gel list, queueing VSprites, drawing Bobs.

Declaration

Source position: agraphics.pas line 1998

procedure DrawGList(

  Rp: PRastPort;

  Vp: PViewPort

);

Arguments

Rp | A pointer to the RastPort where Bobs will be drawn
Vp | A pointer to the ViewPort for which VSprites will be created

Description

Performs one pass of the current gel list.

  • If nextLine and lastColor are defined, these are initialized for each gel.
  • If it's a VSprite, build it into the copper list.
  • If it's a Bob, draw it into the current raster.
  • Copy the save values into the "old" variables, double-buffering if required.

See also

InitGels

initialize a gel list; must be called before using gels.


EraseRect

Fill a defined rectangular area using the current BackFill hook.

Declaration

Source position: agraphics.pas line 2110

procedure EraseRect(

  Rp: PRastPort;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Rp | A pointer to a RastPort structure
XMin | X coordinate of the upper left corner of the region to fill.
YMin | Y coordinate of the upper left corner of the region to fill.
XMax | X coordinate of the lower right corner of the region to fill.
YMax | Y coordinate of the lower right corner of the region to fill.

Description

Fill the rectangular region specified by the parameters with the BackFill hook. If non-layered, the rectangular region specified by the parameters is cleared. If layered the ^.BackFill Hook is used. The following relation must be true: (xmax >= xmin) and (ymax >= ymin)


ExtendFont

Ensure TTextFont.tf_Extension has been built for a font

Declaration

Source position: agraphics.pas line 2111

function ExtendFont(

  Font: PTextFont;

  FontTags: PTagItem

):LongWord;

Arguments

Font | The font to extend.
FontTags | An optional taglist. If nil, then a default is used. Currently, the only tag defined is TA_DeviceDPI.

Function result

1 if the TextFont was properly extended, else 0.

See also

ExtendFontTags

VarArgs Version of ExtendFont()


ExtendFontTags

VarArgs Version of ExtendFont()

Declaration

Source position: agraphics.pas line 2155

function ExtendFontTags(

  Font: PTextFont;

  const FontTags: array of PtrUInt

):LongWord;


FindColor

Find the closest matching color in a colormap.

Declaration

Source position: agraphics.pas line 2142

function FindColor(

  Cm: PColorMap;

  R: LongWord;

  G: LongWord;

  B: LongWord;

  MaxColor: LongInt

):LongInt;

Arguments

Cm | Colormap
R | red level (32 bit left justified fraction)
G | green level (32 bit left justified fraction)
B | blue level (32 bit left justified fraction)

Description

The system will attempt to find the color in the passed colormap which most closely matches the RGB values passed. No new pens will be allocated, and you should not ReleasePen() the returned pen. This function is not sensitive to palette sharing issues. Its intended use is for:

  1. programs which pop up on public screens when those screens are not using palette sharing. You might use this function as a fallback when ObtainBestPenA() says that there are no sharable pens.
  2. Internal color matching by an application which is either running on a non-public screen, or which wants to match colors to an internal color table which may not be associated with any displayed screen.

In order to use the MaxPen=-1 feature, you must have initialized palette sharing via AttachPalExtra() (all intuition screens do this). Otherwise, MaxPen=-1 will search all colors in the colormap.

See also

ObtainBestPenA | Search for the closest color match, or allocate a new one.
GetColorMap | Allocate and initialize Colormap
ObtainPen | Obtain a free palette entry for use by your program.
ReleasePen | Release an allocated palette entry to the free pool.


FindDisplayInfo

Search for a record identified by a specific key

Declaration

Source position: agraphics.pas line 2099

function FindDisplayInfo(

  DisplayID: LongWord

):DisplayInfoHandle;

Function result

Handle to a displayinfo Record with that key or nil if no match.

Description

Given a 32-bit Mode Key, return a handle to a valid DisplayInfoRecord found in the graphics database. Using this handle, you can obtain information about this Mode, including its default dimensions, properties, and whether it is currently available for use.


Flood

Flood rastport like areafill.

Declaration

Source position: agraphics.pas line 2035

function Flood(

  Rp: PRastPort;

  Mode: LongWord;

  X: LongInt;

  Y: LongInt

):LongBool;

Arguments

Rp | A pointer to RastPort
Mode | 0 fill all adjacent pixels searching for border. 1 fill all adjacent pixels that have same pen number as the one at (x,y).
X | X coordinate in BitMap to start the flood fill at.
Y | Y coordinate in BitMap to start the flood fill at.

Description

Search the BitMap starting at (x,y). Fill all adjacent pixels if they are:

  • Mode 0: not the same color as AOLPen
  • Mode 1: the same color as the pixel at (x,y)

When actually doing the fill use the modes that apply to standard areafill routine such as drawmodes and patterns.

In order to use Flood, the destination RastPort must have a valid TmpRas raster whose size is as large as that of the RastPort.

See also

AreaEnd | Process table of vectors and ellipses and produce areafill.
InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.


FontExtent

Get the font attributes of the current font

Declaration

Source position: agraphics.pas line 2102

procedure FontExtent(

  Font: PTextFont;

  FontExtent: PTextExtent

);

Arguments

Font | The TextFont from which the font metrics are extracted.
FontExtent | The TextExtent structure to be filled.

Description

This function fills the text extent structure with a bounding (i.e. maximum) extent for the characters in the specified font.

The TextFont, not the RastPort, is specified -- unlike TextExtent(), effect of algorithmic enhancements is not included, nor does te_Width include any effect of rp_TxSpacing. The returned te_Width will be negative only when FPF_REVPATH is set in the tf_Flags of the font -- the effect of left-moving characters is ignored for the width of a normal font, and the effect of right-moving characters is ignored if a REVPATH font. These characters will, however, be reflected in the bounding extent.

See also

TextExtent

Determine raster extent of text data.


FreeBitMap

Free a bitmap created by AllocBitMap()

Declaration

Source position: agraphics.pas line 2128

procedure FreeBitMap(

  Bm: PBitMap

);

Arguments

Bm

A pointer to a BitMap structure. Passing a nil-pointer (meaning "do nothing") is OK.

Description

Frees bitmap and all associated bitplanes. Be careful to insure that any rendering done to the bitmap has completed (by calling WaitBlit()) before you call this function.

See also

AllocBitMap

Allocate a bitmap and attach bitplanes to it.


FreeColorMap

Free the ColorMap structure and return memory to free memory pool.

Declaration

Source position: agraphics.pas line 2076

procedure FreeColorMap(

  ColorMap: PColorMap

);

Arguments

ColorMap

A pointer to ColorMap allocated with GetColorMap(). Passing a nil pointer (meaning "do nothing") is acceptable.

Description

Return the memory to the free memory pool that was allocated with GetColorMap().

See also

SetRGB4 | Set one color register for this viewport.
GetColorMap | Allocate and initialize Colormap


FreeCopList

Deallocate intermediate copper list

Declaration

Source position: agraphics.pas line 2071

procedure FreeCopList(

  CopList: PCopList

);

Arguments

CopList

A pointer to structure CopList

Description

Deallocate all memory associated with this copper list.


FreeCprList

Deallocate hardware copper list

Declaration

Source position: agraphics.pas line 2074

procedure FreeCprList(

  CprList: PCprList

);

Arguments

CprList

A pointer to cprlist structure

Description

Return cprlist to free memory pool


FreeDBufInfo

Free information for multi-buffered animation

Declaration

Source position: agraphics.pas line 2136

procedure FreeDBufInfo(

  Dbi: PDBufInfo

);

Arguments

Dbi

A pointer to a DBufInfo.

Description

Frees a structure obtained from AllocDBufInfo() FreeDBufInfo(nil) is a no-op.

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation


FreeGBuffers

Deallocate memory obtained by GetGBuffers()

Declaration

Source position: agraphics.pas line 2080

procedure FreeGBuffers(

  AnOb: PAnimOb;

  Rp: PRastPort;

  Flag: LongInt

);

Arguments

AnOb | A pointer to the AnimOb structure
Rp | A pointer to the current RastPort

Description

For each sequence of each component of the AnimOb, deallocate memory for:

  • SaveBuffer
  • BorderLine
  • CollMask and ImageShadow (point to same buffer)

if db is set (user had used double-buffering) deallocate:

  • DBufPacket
  • BufBuffer

A call to GetGBuffers() that resulted in a partially allocation of the required buffers will result in a deallocation of these buffers. (Possible incompatibility with the real thing, though)

See also

GetGBuffers

Attempt to allocate ALL buffers of an entire AnimOb.


FreeRaster

Release an allocated area to the system free memory pool

Declaration

Source position: agraphics.pas line 2063

procedure FreeRaster(

  P: PByte;

  Width: LongWord;

  Height: LongWord

);

Arguments

P | a pointer to a memory space returned as a result of a call to AllocRaster().
Width | The width in bits of the bitplane.
Height | Number of rows in bitplane.

Description

Return the memory associated with this PlanePtr of size width and height to the exec.MEMF_CHIP memory pool.

See also

AllocRaster | Allocate space for a bitplane.
AllocBitmap | Allocate a bitmap and attach bitplanes to it.
FreeBitmap | Free a bitmap created by AllocBitMap()


FreeSprite

Return sprite for use by others and virtual sprite machine.

Declaration

Source position: agraphics.pas line 2049

procedure FreeSprite(

  Num: LongInt

);

Description

Mark sprite as available for others to use. These sprite routines are provided to ease sharing of sprite hardware and to handle simple cases of sprite usage and movement. It is assumed the programs that use these routines do want to be good citizens in their hearts. ie: they will not FreeSprite unless they actually own the sprite. The Virtual Sprite machine may ignore the simple sprite machine.

See also

GetSprite | Attempt to get a sprite for the simple sprite manager.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.


FreeSpriteData

free sprite data allocated by AllocSpriteData()

Declaration

Source position: agraphics.pas line 2145

procedure FreeSpriteData(

  Sp: PExtSprite

);

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.
AllocBitMap | Allocate a bitmap and attach bitplanes to it.


FreeVPortCopLists

Deallocate all intermediate copper lists and their headers from a viewport

Declaration

Source position: agraphics.pas line 2070

procedure FreeVPortCopLists(

  Vp: PViewPort

);

Arguments

Vp

A pointer to ViewPort structure

Description

Search display, color, sprite, and user copper lists and call ExecFreeMem() to deallocate them from memory

The memory allocated to the various copper lists will be returned to the system's free memory pool, and the following fields in the viewport structure will be set to nil:

DspIns, Sprins, ClrIns, UCopIns


GetAPen

Get the A Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2117

function GetAPen(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the A pen for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently, for instance, using more bits.

See also

SetAPen

Set the primary pen for a RastPort.


GetBitMapAttr

Returns information about a bitmap

Declaration

Source position: agraphics.pas line 2134

function GetBitMapAttr(

  Bm: PBitMap;

  AttrNum: LongWord

):LongWord;

Description

Determines information about a bitmap. This function should be used instead of reading the bitmap structure fields directly. This will provide future compatibility.

attribute_number = A number telling graphics which attribute of the bitmap should be returned:

BMA_HEIGHT
returns the height in pixels
BMA_WIDTH
returns the width in pixels.
BMA_DEPTH
returns the depth. This is the number of bits which are required to store the information for one pixel in the bitmap.
BMA_FLAGS
returns a longword bitfield describing various attributes which the bitmap may have. Currently defined flags are BMF_DISPLAYABLE, BMF_INTERLEAVED (see AllocBitMap()). The flag BMF_STANDARD returns will be set if the bitmap is represented as planar data in Amiga Chip RAM.

Unknown attributes are reserved for future use, and return zero.

BMF_DISPLAYABLE will only be set if the source bitmap meets all of the required alignment restrictions. A bitmap which does not meet these restrictions may still be displayable at some loss of efficiency.

Size values returned by this function may not exactly match the values which were passed to AllocBitMap(), due to alignment restrictions.

See also

AllocBitMap

Allocate a bitmap and attach bitplanes to it.


GetBPen

Get the B Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2118

function GetBPen(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the B pen for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently, using more bits.

See also

SetBPen

Set secondary pen for a RastPort


GetColorMap

Allocate and initialize Colormap

Declaration

Source position: agraphics.pas line 2075

function GetColorMap(

  Entries: LongInt

):PColorMap;

Arguments

Entries

Number of entries for this colormap

Function result

The pointer value returned by this routine, if nonzero, may be stored into the ViewPort.ColorMap pointer. If a value of 0 is returned, the system was unable to allocate enough memory space for the required data structures.

Description

Allocates, initializes and returns a pointer to a ColorMap data structure, later enabling calls to SetRGB4()/SetRGB32() and LoadRGB4()/LoadRGB32() to load colors for a view port. The ColorTable pointer in the ColorMap structure points to a hardware specific colormap data structure. You should not count on it being anything you can understand. Use GetRGB4()/GetRGB32() to query it or SetRGB4CM()/SetRGB32CM() to set it directly.


GetDisplayInfoData

Query DisplayInfo Record parameters

Declaration

Source position: agraphics.pas line 2101

function GetDisplayInfoData(

  Handle: DisplayInfoHandle;

  buf: Pointer;

  Size: LongWord;

  TagID: LongWord;

  DisplayID: LongWord

):LongWord;

Arguments

Handle | A displayinfo handle
buf | A pointer to destination buffer
Size | Buffer size in bytes
TagID | data chunk type (DTAG_*)

Function result

If positive, number of bytes actually transferred if zero, no information for ID was available

Description

GetDisplayInfoData() fills a buffer with data meaningful to the DisplayInfoRecord pointed at by your valid handle. The data type that you are interested in is indicated by a tagID for that chunk. The types of tagged information that may be available include:

DTAG_DISP:
(TDisplayInfo) properties and availability information.
DTAG_DIMS:
(TDimensionInfo) default dimensions and overscan info.
DTAG_MNTR:
(TMonitorInfo) type, position, scanrate, and compatibility
DTAG_NAME:
(TNameInfo) a user friendly way to refer to this mode.

See also

FindDisplayInfo | Search for a record identified by a specific key
NextDisplayInfo | Iterate current displayinfo identifiers


GetDrMd

Get the draw mode value for a RastPort

Declaration

Source position: agraphics.pas line 2119

function GetDrMd(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the draw mode for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently.

See also

SetDrMd

Set drawing mode for a RastPort


GetExtSprite

VarArgs Version of GetExtSpriteA()

Declaration

Source position: agraphics.pas line 2157

function GetExtSprite(

  Ss: PExtSprite;

  const Tags: array of PtrUInt

):LongInt;

See also

GetExtSprite

VarArgs Version of GetExtSpriteA()


GetExtSpriteA

Attempt to get a sprite for the extended sprite manager.

Declaration

Source position: agraphics.pas line 2129

function GetExtSpriteA(

  Ss: PExtSprite;

  Tags: PTagItem

):LongInt;

Arguments

Tags

Tags GSTAG_*

Function result

a sprite number or -1 for an error. This call will fail if no sprites could be allocated, or if you try to allocate a sprite which would require a mode change when there are other sprites of incompatible modes in use.

Description

Attempt to allocate one of the eight sprites for private use with the extended sprite manager.

a standard tag list:

GSTAG_SPRITE_NUM
specifies a specific sprite to get by number.
GSTAG_ATTACHED
specifies that you wish to get a sprite pair. the tag data field points to a ExtSprite structure for the second sprite. You must free both sprites.

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
GetSprite | Attempt to get a sprite for the simple sprite manager.


GetGBuffers

Attempt to allocate ALL buffers of an entire AnimOb.

Declaration

Source position: agraphics.pas line 2007

function GetGBuffers(

  AnOb: PAnimOb;

  Rp: PRastPort;

  Flag: LongInt

):LongBool;

Arguments

AnOb | A pointer to the AnimOb structure
Rp | A pointer to the current RastPort

Function result

True if the memory allocations were all successful, else False

Description

For each sequence of each component of the AnimOb, allocate memory for:

  • SaveBuffer
  • BorderLine
  • CollMask and ImageShadow (point to same buffer)

if db is set TRUE (user wants double-buffering) allocate:

  • DBufPacket
  • BufBuffer

If an AnimOb is passed to GetGBuffers twice new buffers will be allocated and therefore old pointers to buffers will be lost in space.

Errors

If any of the memory allocations fail it does not free the partial allocations that did succeed.

See also

FreeGBuffers

Deallocate memory obtained by GetGBuffers()


GetOutlinePen

Get the O Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2120

function GetOutlinePen(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the O pen for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently, for instance, using more bits.

See also

SetOutlinePen

Set the Outline Pen value for a RastPort


GetRGB32

Set a series of color registers for this Viewport.

Declaration

Source position: agraphics.pas line 2125

procedure GetRGB32(

  Cm: PColorMap;

  FirstColor: LongWord;

  NColors: LongWord;

  var Table: LongWord

); overload;

procedure GetRGB32(

  Cm: PColorMap;

  FirstColor: LongWord;

  NColors: LongWord;

  Table: PLongWord

); overload;

Arguments

Cm | colormap
FirstColor | The first color register to get
NColors | The number of color registers to set.
Table | A pointer to a series of 32-bit RGB triplets. Should point to at least ncolors*3 longwords.

Arguments

Cm | colormap
FirstColor | The first color register to get
NColors | The number of color registers to set.
Table | A pointer to a series of 32-bit RGB triplets. Should point to at least ncolors*3 longwords.

See also

LoadRGB4 | Load RGB color values from table.
LoadRGB32 | Set a series of color registers for this Viewport.
GetColorMap | Allocate and initialize Colormap
SetRGB32CM | Set one color register for this ColorMap.


GetRGB4

Inquire value of entry in ColorMap.

Declaration

Source position: agraphics.pas line 2077

function GetRGB4(

  ColorMap: PColorMap;

  Entry: LongInt

):LongWord;

Arguments

ColorMap | A pointer to ColorMap structure
Entry | Index into colormap

Function result

Returns -1 if no valid entry return Word RGB value 4 bits per run right justified

Description

Read and format a value from the ColorMap.

Errors

Intuition's DisplayBeep() changes color 0. Reading Color 0 during a DisplayBeep() will lead to incorrect results.

See also

SetRGB4 | Set one color register for this viewport.
LoadRGB4 | Load RGB color values from table.
GetColorMap | Allocate and initialize Colormap
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.


GetRPAttrs

VarArgs Version for GetRPAttrsA()

Declaration

Source position: agraphics.pas line 2161

procedure GetRPAttrs(

  Rp: PRastPort;

  const Tags: array of PtrUInt

);


GetRPAttrsA

Examine rastport settings via a tag list

Declaration

Source position: agraphics.pas line 2147

procedure GetRPAttrsA(

  Rp: PRastPort;

  Tags: PTagItem

);

Arguments

Rp | A pointer to a RastPort structure
Tags | A pointer to a taglist specifying the attributes to read and the addresses to store the results (RPTAG_*)

Description

Read the settings of a rastport into variables. The ti_Tag field of the TagItem specifies which attribute should be read, and the ti_Data field points at the location where the result hsould be stored. All current tags store the return data as LonInts (32 bits).

currently available tags are:

RPTAG_Font
(Byte) Font for GfxText()
RPTAG_APen
(Byte) Primary rendering pen
RPTAG_BPen
(Byte) Secondary rendering pen
RPTAG_DrMd
(Byte) Drawing mode
RPTAG_OutLinePen
(Byte) Area Outline pen
RPTAG_WriteMask
(LongWord) Bit Mask for writing.
RPTAG_MaxPen
(LongWord) Maximum pen to render (see SetMaxPen())

See also

GetRPAttrs | VarArgs Version for GetRPAttrsA()
SetRPAttrsA | Modify rastport settings via a tag list
GetAPen | Get the A Pen value for a RastPort
GetBPen | Get the B Pen value for a RastPort
GetOutLinePen | Get the O Pen value for a RastPort


GetSprite

Attempt to get a sprite for the simple sprite manager.

Declaration

Source position: agraphics.pas line 2048

function GetSprite(

  Sprite: PSimpleSprite;

  Num: LongInt

):LongInt;

Arguments

Sprite

A Pointer to programmers SimpleSprite structure.

Function result

If pick is 0-7 attempt to allocate the sprite. If the sprite is already allocated then return -1. If pick -1 allocate the next sprite starting search at 0. If no sprites are available return -1 and fill -1 in num entry of SimpleSprite structure. If the sprite is available for allocation, mark it allocated and fill in the 'num' entry of the SimpleSprite structure. If successful return the sprite number.

Description

Attempt to allocate one of the eight sprites for private use with the simple sprite manager. This must be done before using further calls to the simple sprite machine. If the programmer wants to use 15 color sprites, they must allocate both sprites and set the SPRITE_ATTACHED bit in the odd sprite's posctldata array.

Errors

On some machines this will never return anything else than -1!

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.


GetVPModeID

Get the 32 bit DisplayID from a ViewPort.

Declaration

Source position: agraphics.pas line 2107

function GetVPModeID(

  Vp: PViewPort

):LongInt;

Arguments

Vp

A pointer to a ViewPort structure.

Function result

A 32 bit DisplayInfoRecord identifier associated with this ViewPort, or INVALID_ID.

Description

Returns the normal display modeID, if one is currently associated with this ViewPort. Test the return value of this function against INVALID_ID, not nil.

See also

ModeNotAvailable

Check to see if a DisplayID isn't available.


GfxAssociate

associate a graphics extended node with a given pointer

Declaration

Source position: agraphics.pas line 2090

procedure GfxAssociate(

  AssociateNode: Pointer;

  GfxNodePtr: Pointer

);

Description

Associate a special graphics extended data structure (each of which begins with an ExtendedNode structure) with another structure via the other structure's pointer. Later, when you call GfxLookUp() with the other structure's pointer you may retrieve a pointer to this special graphics extended data structure, if it is available.Never associate one special graphics extended data structure to several pointers. Only one pointer is allowed!

See also

GfxNew | Allocate a graphics extended data structure
GfxFree | Free a graphics extended data structure
GfxLookUp | Find a graphics extended node associated with a given pointer


GfxFree

Free a graphics extended data structure

Declaration

Source position: agraphics.pas line 2089

procedure GfxFree(

  GfxNodePtr: Pointer

);

Description

Free a special graphics extended data structure (each of which begins with an ExtendedNode structure). The node is deallocated from memory. graphics will disassociate this special graphics extended node from any associated data structures, if necessary, before freeing it (see GfxAssociate()).

Errors

An Alert() will be called if you attempt to free any structure other than a graphics extended data structure obtained via GfxFree().

See also

GfxNew | Allocate a graphics extended data structure
GfxAssociate | associate a graphics extended node with a given pointer
GfxLookUp | Find a graphics extended node associated with a given pointer


GfxLookUp

Find a graphics extended node associated with a given pointer

Declaration

Source position: agraphics.pas line 2095

function GfxLookUp(

  associateNode: Pointer

):Pointer;

Function result

A pointer to the ExtendedNode that has previously been associated with the pointer.

Description

Finds a special graphics extended data structure (if any) associated with the pointer to a data structure (eg: ViewExtra associated with a View structure).

See also

GfxNew | Allocate a graphics extended data structure
GfxAssociate | associate a graphics extended node with a given pointer
GfxFree | Free a graphics extended data structure


GfxMove

Move graphics pen position.

Declaration

Source position: agraphics.pas line 2020

procedure GfxMove(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

);

Description

Move graphics pen position to (x,y) relative to upper left (0,0) of RastPort. This sets the starting point for subsequent Draw() and GfxText() calls.

See also

Draw

Draw a line between the current pen position and the new x,y position.


GfxNew

Allocate a graphics extended data structure

Declaration

Source position: agraphics.pas line 2088

function GfxNew(

  GfxNodeType: LongWord

):Pointer;

Function result

A pointer to the allocated graphics node or nil if the allocation failed.

Description

Allocate a special graphics extended data structure (each of which begins with an ExtendedNode structure). The type of structure to be allocated is specified by the node_type identifier.

See also

GfxLookUp | Find a graphics extended node associated with a given pointer
GfxAssociate | associate a graphics extended node with a given pointer
GfxFree | Free a graphics extended data structure


GfxText

Write text characters (no formatting).

Declaration

Source position: agraphics.pas line 1988

function GfxText(

  Rp: PRastPort;

  String1: PChar;

  Count: LongWord

):LongInt;

Arguments

Rp | A pointer to the RastPort which describes where the text is to be output
Count | The number of characters in the string. If 0, there are no characters to be output.

Description

This graphics function writes printable text characters to the specified RastPort at the current position. No control meaning is applied to any of the characters, thus only text on the current line is output.

The current position in the RastPort is updated to the next character position. If the characters displayed run past the RastPort boundary, the current position is truncated to the boundary, and thus does not equal the old position plus the text length.

See also

GfxMove | Move graphics pen position.
TextLength | Determine raster length of text data.
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent


InitAnimate

Init AnimObject pointer, set to nil

Declaration

Source position: agraphics.pas line 2168

procedure InitAnimate(

  animkey: PPAnimOb

);


InitArea

Initialize vector collection matrix

Declaration

Source position: agraphics.pas line 2027

procedure InitArea(

  AreaInfo: PAreaInfo;

  VectorBuffer: Pointer;

  MaxVectors: LongInt

);

Arguments

AreaInfo | A pointer to AreaInfo structure
MaxVectors | max number of vectors this buffer can hold

Description

This function provides initialization for the vector collection matrix such that it has a size of (max vectors ). The size of the region pointed to by buffer (short pointer) should be five (5) times as large as maxvectors. This size is in bytes. Areafills done by using AreaMove, AreaDraw() and AreaEnd() must have enough space allocated in this table to store all the points of the largest fill. AreaEllipse() takes up two vectors for every call. If AreaMove/AreaDraw()/AreaEllipse() detect too many vectors going into the buffer they will return -1.

See also

AreaEnd | Process table of vectors and ellipses and produce areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.


InitBitMap

Initialize bit map structure with input values.

Declaration

Source position: agraphics.pas line 2045

procedure InitBitMap(

  BitMap: PBitMap;

  Depth: LongInt;

  Width: LongInt;

  Height: LongInt

);

Arguments

Depth | Number of bitplanes that this bitmap will have
Width | Number of bits (columns) wide for this BitMap
Height | Number of bits (rows) tall for this BitMap

Description

Initialize various elements in the BitMap structure to correctly reflect depth, width, and height. Must be used before use of BitMap in other graphics calls. The Planes[0..7] are not initialized and need to be set up by the caller. The Planes table was put at the end of the structure so that it may be truncated to conserve space, as well as extended. All routines that use BitMap should only depend on existence of depth number of bitplanes. The Flagsh and pad fields are reserved for future use and should not be used by application programs.


InitGels

initialize a gel list; must be called before using gels.

Declaration

Source position: agraphics.pas line 1999

procedure InitGels(

  Head: PVSprite;

  Tail: PVSprite;

  GelsInfo: PGelsInfo

);

Arguments

Head | Pointer to the VSprite structure to be used as the gel list head
Tail | Pointer to the VSprite structure to be used as the gel list tail
GelsInfo | Pointer to the GelsInfo structure to be initialized

Description

Assigns the VSprites as the head and tail of the gel list in GfxBase. Links these two gels together as the keystones of the list. If the collHandler vector points to some memory array, sets the BORDERHIT vector to nil.


InitGMasks

Initialize all of the masks of an AnimOb.

Declaration

Source position: agraphics.pas line 2008

procedure InitGMasks(

  AnOb: PAnimOb

);

Arguments

AnOb

A pointer to the AnimOb

Description

For every sequence of every component call InitMasks().

See also

InitMasks

Initialize the BorderLine and CollMask masks of a VSprite.


InitGraphicsLibrary

Declaration

Source position: agraphics.pas line 2192

function InitGraphicsLibrary: Boolean;


InitMasks

Initialize the BorderLine and CollMask masks of a VSprite.

Declaration

Source position: agraphics.pas line 2000

procedure InitMasks(

  VSprite: PVSprite

);

Arguments

VSprite

A pointer to the VSprite structure

Description

Creates the appropriate BorderLine and CollMask masks of the VSprite. Correctly detects if the VSprite is actually a Bob definition, handles the image data accordingly.

See also

InitGels

initialize a gel list; must be called before using gels.


InitRastPort

Initialize raster port structure

Declaration

Source position: agraphics.pas line 2013

procedure InitRastPort(

  Rp: PRastPort

);

Arguments

Rp

A pointer to a RastPort structure.

Description

Initialize a RastPort structure to standard values.

The struct Rastport describes a control structure for a write-able raster. The RastPort structure describes how a complete single playfield display will be written into. A RastPort structure is referenced whenever any drawing or filling operations are to be performed on a section of memory.

The section of memory which is being used in this way may or may not be presently a part of the current actual onscreen display memory. The name of the actual memory section which is linked to the RastPort is referred to here as a "raster" or as a bitmap.

Note:

Calling the routine InitRastPort only establishes various defaults. It does not establish where, in memory, the rasters are located. To do graphics with this RastPort the user must set up the BitMap pointer in the RastPort.

all entries in RastPort get zeroed out, with the following exceptions:

  • Mask, FgPen, AOLPen, and LinePtrn are set to -1.
  • The DrawMode is set to JAM2
  • The font is set to the standard system font


InitTmpRas

Initialize area of local memory for usage by areafill, floodfill, gfxtext.

Declaration

Source position: agraphics.pas line 2058

function InitTmpRas(

  TmpRas: PTmpRas;

  Buffer: PByte;

  Size: LongInt

):PTmpRas;

Arguments

TmpRas | A pointer to a TmpRas structure to be linked into a RastPort
Buffer | A pointer to a contiguous piece of chip memory.
Size | Size in bytes of buffer

Function result

Makes buffer available for users of RastPort

Description

The area of memory pointed to by buffer is set up to be used by RastPort routines that may need to get some memory for intermediate operations in preparation to putting the graphics into the final BitMap. Tmpras is used to control the usage of buffer.

Errors

The function itself is a bug. Why does this function exist at all? The necessary memory should be allocated in InitRastPort() or the functions that need it.

See also

AreaEnd | Process table of vectors and ellipses and produce areafill.
Flood | Flood rastport like areafill.
GfxText | Write text characters (no formatting).


InitView

Initialize View structure.

Declaration

Source position: agraphics.pas line 2040

procedure InitView(

  View: PView

);

Arguments

View

A pointer to a View structure

Description

Initialize View structure to default values. View structure set to all 0's except DxOffset,DyOffset, These are set to properly position: default display about .5 inches from top and left on monitor. InitView pays no attention to previous contents of view.

See also

MakeVPort

Generate display copper list for a viewport.


InitVPort

Initialize ViewPort structure.

Declaration

Source position: agraphics.pas line 2014

procedure InitVPort(

  Vp: PViewPort

);

Arguments

Vp

A pointer to a ViewPort structure

Description

Initialize ViewPort structure to default values. ViewPort is initialized to it`s default values - doesn't care about previous contents of this structure. All values except for SpritePriorities are set to 0's.

See also

MakeVPort

Generate display copper list for a viewport.


LoadRGB32

Set a series of color registers for this Viewport.

Declaration

Source position: agraphics.pas line 2121

procedure LoadRGB32(

  Vp: PViewPort;

  var Table: LongWord

); overload;

procedure LoadRGB32(

  Vp: PViewPort;

  Table: PLongWord

); overload;

Arguments

Vp | viewport
Table | A pointer to a series of records which describe which colors to modify.

Arguments

Vp | viewport
Table | A pointer to a series of records which describe which colors to modify.

Description

The selected color registers are changed to match your specs. LoadRGB32() is faster than SetRGB32(), even for one color.

Passing a nil "table" is ignored. The format of the table passed to this function is a series of records, each with the following format:

1 Word with the number of colors to load 1 Word with the first color to be loaded. 3 longwords representing a left justified 32 bit rgb triplet. The list is terminated by a count value of 0.

Lower order bits of the palette specification will be discarded, depending on the color palette resolution of the target graphics device. Use 0xffffffff for the full value, 0x7fffffff for 50%, etc. You can find out the palette range for your screen by querying the graphics data base.

See also

LoadRGB4 | Load RGB color values from table.
GetColorMap | Allocate and initialize Colormap
GetRGB32 | Set a series of color registers for this Viewport.
SetRGB32CM | Set one color register for this ColorMap.


LoadRGB4

Load RGB color values from table.

Declaration

Source position: agraphics.pas line 2012

procedure LoadRGB4(

  Vp: PViewPort;

  Colors: PWord;

  Count: LongInt

);

Arguments

Vp | A pointer to ViewPort, whose colors you wish to change
Colors | pointer to table of RGB values set up as an array of Words The colors are interpreted as 15 = maximum intensity. 0 = minimum intensity.
Count | number of Words in the table to load into the colormap starting at color 0(background) and proceeding to the next higher color number

Description

load the count words of the colormap from table starting at entry 0.

The ViewPort should have a pointer to a valid ColorMap to store the colors in. Updates the hardware copperlist to reflect the new colors. Updates the intermediate copperlist with the new colors.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB4 | Inquire value of entry in ColorMap.
SetRGB4 | Set one color register for this viewport.


LoadView

Use a (possibly freshly created) coprocessor instruction list to create the current display.

Declaration

Source position: agraphics.pas line 2017

procedure LoadView(

  View: PView

);

Arguments

View

A pointer to the View structure which contains the pointer to the constructed coprocessor instructions list, or nil.

Description

Install a new view to be displayed during the next display refresh pass. Coprocessor instruction list has been created by InitVPort(), MakeVPort(), and MrgCop().

If the View pointer is non-nil, the new View is displayed, according to your instructions. The vertical blank routine will pick this pointer up and direct the copper to start displaying this View.

If the View pointer is nil, no View is displayed.

Even though a LoadView(nil) is performed, display DMA will still be active. Sprites will continue to be displayed after a LoadView(nil) unless an OFF_SPRITE is subsequently performed.

See also

InitVPort | Initialize ViewPort structure.
MakeVPort | Generate display copper list for a viewport.
MrgCop | Merge together coprocessor instructions.
RethinkDisplay | Grand manipulation of the entire Intuition display.


LockLayerRom

Lock Layer structure by ROM(gfx lib) code.

Declaration

Source position: agraphics.pas line 2052

procedure LockLayerRom(

  Layer: PLayer

);

Description

Return when the layer is locked and no other task may alter the ClipRect structure in the Layer structure. This call does not destroy any registers. This call nests so that callers in this chain will not lock themselves out. Do not have the Layer locked during a call to intuition. There is a potential deadlock problem here, if intuition needs to get other locks as well. Having the layer locked prevents other tasks from using the layer library functions, most notably intuition itself. So be brief. layers.library's LockLayer() is identical to LockLayerRom().

The layer is locked and the task can render assuming the ClipRects will not change out from underneath it until an UnlockLayerRom() is called.

See also

UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.
LockLayer | Lock layer to make changes to ClipRects.


MakeVPort

Generate display copper list for a viewport.

Declaration

Source position: agraphics.pas line 2016

function MakeVPort(

  View: PView;

  Vp: PViewPort

):LongWord;

Arguments

View

A pointer to a View structure

Function result

MakeVPort() will return an error if there is not enough memory, or the requested mode cannot be opened with the requested depth with the given bitmap (for higher bandwidth alignments). Check (MVP_*)

Description

Uses information in the View, ViewPort, TViewPort^.RasInfo to construct and intermediate copper list for this ViewPort.

Constructs intermediate copper list and puts pointers in viewport.DspIns If the ColorMap ptr in ViewPort is nil then it uses colors from the default color table. If DUALPF in Modes then there must be a second TRasInfo pointed to by the first TRasInfo

See also

InitVPort | Initialize ViewPort structure.
MrgCop | Merge together coprocessor instructions.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.
RemakeDisplay |
RethinkDisplay | Grand manipulation of the entire Intuition display.


ModeNotAvailable

Check to see if a DisplayID isn't available.

Declaration

Source position: agraphics.pas line 2108

function ModeNotAvailable(

  ModeID: LongWord

):LongInt;

Arguments

ModeID

A 32 bit DisplayInfoRecord identifier.

Function result

A general indication of why this modeID is not available, or nil if there is no reason why it shouldn't be available.

Description

Rturns an error code, indicating why this modeID is not available, or 0 if there is no reason known why this mode should not be there.

See also

GetVPModeID

Get the 32 bit DisplayID from a ViewPort.


MoveSprite

Move sprite to a point relative to top of viewport.

Declaration

Source position: agraphics.pas line 2051

procedure MoveSprite(

  Vp: PViewPort;

  Sprite: PSimpleSprite;

  X: LongInt;

  Y: LongInt

);

Arguments

Vp | A ViewPort for relative sprite positioning or nil
Sprite | A pointer to a sprite descriptor structure
X | A new X coordinate
Y | A new Y coordinate

Description

Move sprite to a new position on the screen. Coordinates are specified relatively to given ViewPort, or relatively to the entire View (physical display) if the ViewPort is nil.

This function works also with extended sprites, since TSimpleSprite is a part of TExtSprite.

Amiga currently supports only one sprite #0 for mouse pointer. Other sprite numbers are ignored by this function.

ViewPort is also used in order to specify the physical display. If it's not specified, Amiga(tm) chipset display is assumed. This is available only on Amiga(tm) architecture.

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
GetSprite | Attempt to get a sprite for the simple sprite manager.


MrgCop

Merge together coprocessor instructions.

Declaration

Source position: agraphics.pas line 2015

function MrgCop(

  View: PView

):LongWord;

Arguments

View

A pointer to the view structure to prepare

Function result

MrgCop() will return an error if there is not enough memory, or for some reason MrgCop() did not need to make any copper lists. Check MCOP_* for error codes

Description

Merge together the display, color, sprite and user coprocessor instructions into a single coprocessor instruction stream. This essentially creates a per-display-frame program for the coprocessor. This function MrgCop is used, for example, by the graphics animation routines which effectively add information into an essentially static background display. This changes some of the user or sprite instructions, but not those which have formed the basic display in the first place. When all forms of coprocessor instructions are merged together, you will have a complete per- frame instruction list for the coprocessor.

Restrictions: Each of the coprocessor instruction lists MUST be internally sorted in min to max Y-X order. The merge routines depend on this!

If the given view is already on display, changes appear immediately.

On non Amiga Systems it only prepares the View for being displayed.

See also

InitVPort | Initialize ViewPort structure.
MakeVPort | Generate display copper list for a viewport.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.
RethinkDisplay | Grand manipulation of the entire Intuition display.


NewRegion

Allocates memory for a new Region and initializes it to an empty Region.

Declaration

Source position: agraphics.pas line 2066

function NewRegion: PRegion;

Function result

A pointer to a newly created Region structure that should be freed by a call to DisposeRegion() or nil if not enough memory.


NextDisplayInfo

Iterate current displayinfo identifiers

Declaration

Source position: agraphics.pas line 2100

function NextDisplayInfo(

  DisplayID: LongWord

):LongWord;

Function result

subsequent displayinfo identifier or INVALID_ID if no more records.

Description

The basic iteration function with which to find all records in the graphics database. Using each ID in succession, you can then call FindDisplayInfo() to obtain the handle associated with each ID. Each ID is a 32-bit Key which uniquely identifies one record. The INVALID_ID is special, and indicates the end-of-list.

See also

FindDisplayInfo

Search for a record identified by a specific key


ObtainBestPen

VarArgs Version of ObtainBestPenA()

Declaration

Source position: agraphics.pas line 2156

function ObtainBestPen(

  Cm: PColorMap;

  r: LongWord;

  g: LongWord;

  b: LongWord;

  const Tags: array of PtrUInt

):LongInt;


ObtainBestPenA

Search for the closest color match, or allocate a new one.

Declaration

Source position: agraphics.pas line 2115

function ObtainBestPenA(

  Cm: PColorMap;

  R: LongWord;

  G: LongWord;

  B: LongWord;

  Tags: PTagItem

):LongInt;

Arguments

Cm | Colormap
R | Red level (32 bit left justified fraction)
G | Green level (32 bit left justified fraction)
B | Blue level (32 bit left justified fraction)
Tags | a pointer to a standard tag list specifying the color matching settings desired: OBP_Precision, OBP_FailIfBad

Function result

The correct pen value, or -1 if no sharable palette entries are available.

Description

This function can be used by applications to figure out what pen to use to represent a given color.

The system will attempt to find the color in your viewport closest to the specified color. If there is no color within your tolerance, then a new one will be allocated, if available. If none is available, then the closest one found will be returned.

If this call succceeds, then you must call ReleasePen() when you are done with the color.

The error metric used for ObtainBestPen() is based on the magnitude squared between the two RGB values, scaled by the percentage of free entries.

See also

ObtainBestPen | VarArgs Version of ObtainBestPenA()
GetColorMap | Allocate and initialize Colormap
ObtainPen | Obtain a free palette entry for use by your program.
ReleasePen | Release an allocated palette entry to the free pool.


ObtainPen

Obtain a free palette entry for use by your program.

Declaration

Source position: agraphics.pas line 2133

function ObtainPen(

  Cm: PColorMap;

  N: LongInt;

  R: LongWord;

  G: LongWord;

  B: LongWord;

  F: LongInt

):LongWord;

Arguments

Cm | A pointer to a color map created by GetColorMap().
N | The index of the desired entry, or -1 if any one is acceptable
R | Red Value (32 bit left justified fractions)
G | Green Value (32 bit left justified fractions)
B | Blue Value (32 bit left justified fractions)

Description

Attempt to allocate an entry in the colormap for use by the application. If successful, you should ReleasePen() this entry after you have finished with it.

Applications needing exclusive use of a color register (say for color cycling) will typically call this function with n=-1. Applications needing only the shared use of a color will typically use ObtainBestPenA() instead. Other uses of this function are rare.

When you allocate a palette entry in non-exclusive mode, you should not change it (via SetRGB32()), because other programs on the same screen may be using it. With PEN_EXCLUSIVE mode, you can change the returned entry at will.

To avoid visual artifacts, you should not free up a palette entry until you are sure that your application is not displaying any pixels in that color at the time you free it. Otherwise, another task could allocate and set that color index, thus changing the colors of your pixels.

Generally, for shared access, you should use ObtainBestPenA() instead, since it will not allocate a new color if there is one "close enough" to the one you want already. If there is no Palextra attached to the colormap, then this routine will always fail.

See also

ObtainBestPenA | Search for the closest color match, or allocate a new one.
GetColorMap | Allocate and initialize Colormap
AttachPalExtra | Allocate and attach a palette sharing structure to a colormap
ReleasePen | Release an allocated palette entry to the free pool.


OFF_DISPLAY

Declaration

Source position: agraphics.pas line 2177

procedure OFF_DISPLAY(

  cust: PCustom

);


OFF_SPRITE

Declaration

Source position: agraphics.pas line 2179

procedure OFF_SPRITE(

  cust: PCustom

);


OFF_VBLANK

Declaration

Source position: agraphics.pas line 2181

procedure OFF_VBLANK(

  cust: PCustom

);


ON_DISPLAY

Declaration

Source position: agraphics.pas line 2178

procedure ON_DISPLAY(

  cust: PCustom

);


ON_SPRITE

Declaration

Source position: agraphics.pas line 2180

procedure ON_SPRITE(

  cust: PCustom

);


ON_VBLANK

Declaration

Source position: agraphics.pas line 2182

procedure ON_VBLANK(

  cust: PCustom

);


OpenFont

Get a pointer to a system font.

Declaration

Source position: agraphics.pas line 1990

function OpenFont(

  TextAttr: PTextAttr

):PTextFont;

Arguments

TextAttr

A PTextAttr or PTTextAttr structure that describes the text font attributes desired.

Function result

Nil if the desired font cannot be found. If the named font is found, but the size and style specified are not available, a font with the nearest attributes is returned.

Description

This function searches the system font space for the graphics text font that best matches the attributes specified. The pointer to the font returned can be used in subsequent SetFont() and CloseFont() calls. It is important to match this call with a corresponding CloseFont() call for effective management of ram fonts.

See also

CloseFont | Release a pointer to a system font.
SetFont | Set the text font and attributes in a RastPort.
OpenDiskFont |


OpenFontTagList

Declaration

Source position: agraphics.pas line 2150

function OpenFontTagList(

  Textattr: PTextAttr;

  Tags: PTagItem

):PTextFont;


OpenFontTags

Declaration

Source position: agraphics.pas line 2163

function OpenFontTags(

  Textattr: PTextAttr;

  const Tags: array of PtrUInt

):PTextFont;


OpenMonitor

Open a named MonitorSpec

Declaration

Source position: agraphics.pas line 2097

function OpenMonitor(

  MonitorName: PChar;

  DisplayID: LongWord

):PMonitorSpec;

Arguments

MonitorName | A pointer to a null terminated string.
DisplayID | An optional 32 bit monitor/mode identifier

Function result

A pointer to an open MonitorSpec structure. nil if MonitorSpec could not be opened.

Description

Locate and open a named MonitorSpec.

  • if monitor_name is non-nil, the monitor will be opened by name.
  • if monitor_name is nil the monitor will be opened by optional ID.
  • if both monitor_name and display_id are nil returns default monitor.

See also

CloseMonitor

Close a MonitorSpec


OrRectRegion

Perform 2d OR operation of rectangle with region, leaving result in region.

Declaration

Source position: agraphics.pas line 2065

function OrRectRegion(

  Region: PRegion;

  Rectangle: PRectangle

):LongBool;

Function result

Return True if successful operation, Return False if ran out of memory

Description

If any portion of rectangle is not in the region then add that portion to the region.

See also

AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
XorRegionRegion | Perform 2d XOR operation of one region with second region, leaving result in second region
ClearRectRegion
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.


OrRegionRegion

Perform 2d OR operation of one region with second region, leaving result in second region

Declaration

Source position: agraphics.pas line 2082

function OrRegionRegion(

  SrcRegion: PRegion;

  DestRegion: PRegion

):LongBool;

Arguments

SrcRegion | A pointer to Source Region
DestRegion | A pointer to Destination Region

Function result

Return True if successful operation, Return False if ran out of memory

Description

If any portion of region1 is not in the region then add that portion to the region2

See also

AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRegionRegion | Perform 2d XOR operation of one region with second region, leaving result in second region
ClearRectRegion
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.


OwnBlitter

get the blitter for private usage

Declaration

Source position: agraphics.pas line 2056

procedure OwnBlitter;

Description

If blitter is available return immediately with the blitter locked for your exclusive use. If the blitter is not available put task to sleep. It will be awakened as soon as the blitter is available. When the task first owns the blitter the blitter may still be finishing up a blit for the previous owner. You must do a WaitBlit() before actually using the blitter registers.

Calls to OwnBlitter() do not nest. If a task that owns the blitter calls OwnBlitter() again, a lockup will result. (Same situation if the task calls a system function that tries to own the blitter).

It is good practice to start the blitter immediately after calling this function and then call DisownBlitter() so other tasks can use the blitter.

See also

DisOwnBlitter | Returns blitter to free state.
WaitBlit | Wait for the blitter to be finished before proceeding with anything else.


PolyDraw

Draw lines from table of (x,y) values.

Declaration

Source position: agraphics.pas line 2036

procedure PolyDraw(

  Rp: PRastPort;

  Count: LongInt;

  PolyTable: PSmallInt

);

Arguments

Rp | A pointer to RastPort structure
Count | Number of (x,y) pairs in the array
PolyTable | Pointer to first (x,y) pair

Description

Starting with the first pair in the array, draw connected lines to it and every successive pair.

See also

Draw | Draw a line between the current pen position and the new x,y position.
GfxMove | Move graphics pen position.


QBlit

Queue up a request for blitter usage

Declaration

Source position: agraphics.pas line 2026

procedure QBlit(

  Blit: Pbltnode

);

Arguments

Blit

A pointer to blitnode structure

Description

The routine that function in the bltnode is pointing to is called when the blitter is ready for work. No other task will be able to access the blitter while you're doing the blit. Queued blits have precedence over a task that tries to own the blitter via OwnBlitter(). So all queued blitter requests will be done first until the task that attempts a OwnBlitter can actually access the blitter.

Not all hardware has a blitter. On hardware where there is no blitter, a blitter is simulated. Therefore all code that will be executed in the function that is called must not contain code that is hacking the blitter's register but should contain calls to graphics functions instead.

See also

QBSBlit | Synchronize the blitter request with the video beam.
OwnBlitter | get the blitter for private usage
DisOwnBlitter | Returns blitter to free state.


QBSBlit

Synchronize the blitter request with the video beam.

Declaration

Source position: agraphics.pas line 2029

procedure QBSBlit(

  Blit: Pbltnode

);

Arguments

Blit

A pointer to blitnode structure

Description

The routine that function in the bltnode is pointing to is called when the blitter is ready for work. No other task will be able to access the blitter while you're doing the blit. Queued blits have precedence over a task that tries to own the blitter via OwnBlitter(). So all queued blitter requests will be done first until the task that attempts a OwnBlitter can actually access the blitter.

Not all hardware has a blitter. On hardware where there is no blitter, a blitter is simulated. Therefore all code that will be executed in the function that is called must not contain code that is hacking the blitter's register but should contain calls to graphics functions instead.

See also

QBlit | Queue up a request for blitter usage
OwnBlitter | get the blitter for private usage
DisOwnBlitter | Returns blitter to free state.


RasSize

Get Size of an rastport.

Declaration

Source position: agraphics.pas line 2187

function RasSize(

  w: Word;

  h: Word

):Integer;


ReadPixel

read the pen number value of the pixel at a specified x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2033

function ReadPixel(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongWord;

Arguments

Rp | A pointer to a RastPort structure
X | X Coordinate to read
Y | Y Coordinate to read

Function result

The pen number of the pixel at (x,y) is returned. -1 is returned if the pixel cannot be read for some reason.

Description

Combine the bits from each of the bit-planes used to describe a particular RastPort into the pen number selector which that bit combination normally forms for the system hardware selection of pixel color.

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


ReadPixelArray8

read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2105

function ReadPixelArray8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  XStop: LongWord;

  YStop: LongWord;

  Array1: PByte;

  TempRp: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X starting point
YStart | Y starting point
XStop | X stop point
YStop | Y stop point
TempRp | A temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set == 1, temprp^.BytesPerRow = (((width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

The number of pixels read.

Description

For each pixel in a rectangular region, combine the bits from each of the bit-planes used to describe a particular RastPort into the pen number selector which that bit combination normally forms for the system hardware selection of pixel color.

xstop must be >= xstart; ystop must be >= ystart

This function doesn't make sense on true-/hicolor rastports.

See also

ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
ReadPixelLine8 | read the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelLine8 | Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.


ReadPixelLine8

read the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.

Declaration

Source position: agraphics.pas line 2103

function ReadPixelLine8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  Width: LongWord;

  Array1: PByte;

  TempRp: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X Postion in Line to start to read
YStart | Line to Read
Width | Length of line to read
TempRp | A temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set == 1, temprp^.BytesPerRow = (((width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

The number of pixels read.

Description

For each pixel in a rectangular region, combine the bits from each of the bit-planes used to describe a particular RastPort into the pen number selector which that bit combination normally forms for the system hardware selection of pixel color.

width must be non negative

This function doesn't make sense on true-/hicolor rastports.

See also

ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
ReadPixelArray8 | read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelLine8 | Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.


RectFill

Fill a rectangular region in a RastPort.

Declaration

Source position: agraphics.pas line 2031

procedure RectFill(

  Rp: PRastPort;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Rp | A pointer to a RastPort
XMin | Left edge of rectange to fill
YMin | Top edge of rectange to fill
XMax | Right edge of rectange to fill
YMax | Bottom edge of rectange to fill

Description

Fills the rectangular region specified by the parameters with the chosen pen colors, areafill pattern, and drawing mode. If no areafill pattern is specified, fill the rectangular region with the FgPen color, taking into account the drawing mode.

The following relation must be true: (xmax >= xmin) and (ymax >= ymin)

Errors

Complement mode with FgPen complements all bitplanes.

See also

AreaEnd

Process table of vectors and ellipses and produce areafill.


ReleasePen

Release an allocated palette entry to the free pool.

Declaration

Source position: agraphics.pas line 2132

procedure ReleasePen(

  Cm: PColorMap;

  N: LongWord

);

Arguments

Cm | ColorMap structure where the pen was allocated
N | A palette index obtained via any of the palette allocation functions. Passing a -1 will result in this call doing nothing.

Description

Return the palette entry for use by other applications. If the reference count for this palette entry goes to zero, then it may be set to another RGB value.

See also

GetColorMap | Allocate and initialize Colormap
ObtainPen | Obtain a free palette entry for use by your program.
ObtainBestPenA | Search for the closest color match, or allocate a new one.


RemFont

Remove a font from the system list.

Declaration

Source position: agraphics.pas line 2061

procedure RemFont(

  TextFont: PTextFont

);

Arguments

TextFont

the TextFont structure to remove.

Description

This function removes a font from the system, ensuring that access to it is restricted to those applications that currently have an active pointer to it: i.e. no new SetFont() requests to this font are satisfied.

See also

OpenFont | Get a pointer to a system font.
CloseFont | Release a pointer to a system font.
SetFont | Set the text font and attributes in a RastPort.
AddFont | Add a font to the system list


RemIBob

Immediately remove a Bob from the gel list and the RastPort.

Declaration

Source position: agraphics.pas line 2001

procedure RemIBob(

  Bob: PBob;

  Rp: PRastPort;

  Vp: PViewPort

);

Arguments

Bob | A pointer to the Bob to be removed
Rp | A pointer to the RastPort if the Bob is to be erased
Vp | A pointer to the ViewPort for beam-synchronizing

Description

Removes a Bob immediately by uncoupling it from the gel list and erases it from the RastPort.

See also

InitGels | initialize a gel list; must be called before using gels.
RemVSprite | Remove a VSprite from the current gel list.


RemVSprite

Remove a VSprite from the current gel list.

Declaration

Source position: agraphics.pas line 2002

procedure RemVSprite(

  VSprite: PVSprite

);

Arguments

VSprite

A pointer to the VSprite structure to be removed from the gel list

Description

Unlinks the VSprite from the current gel list.

See also

InitGels | initialize a gel list; must be called before using gels.
RemIBob | Immediately remove a Bob from the gel list and the RastPort.


SafeSetOutlinePen

Declaration

Source position: agraphics.pas line 2174

procedure SafeSetOutlinePen(

  w: PRastPort;

  c: Byte

);


SafeSetWriteMask

Declaration

Source position: agraphics.pas line 2175

procedure SafeSetWriteMask(

  w: PRastPort;

  m: SmallInt

);


ScalerDiv

Get the scaling result that BitMapScale would.

Declaration

Source position: agraphics.pas line 2092

function ScalerDiv(

  Factor: LongWord;

  Numerator: LongWord;

  Denominator: LongWord

):LongWord;

Arguments

Factor | A number in the range 0..16383
Numerator | A number in the range 0..16383
Denominator | A number in the range 0..16383

Function result

Returns factor * numerator / denominator

Description

Calculate the expression (factor * numerator / denominator) such that the result is the same as the width of the destination result of BitMapScale() when the factor here is the width of the source, and the numerator and denominator are the XDestFactor and XSrcFactor for BitMapScale().

See also

BitMapScale

Perform raster scaling on a bit map.


ScrollRaster

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.

Declaration

Source position: agraphics.pas line 2046

procedure ScrollRaster(

  Rp: PRastPort;

  Dx: LongInt;

  Dy: LongInt;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Rp | A pointer to a rastport
Dx | x value to move
Dy | y value to move
XMin | Left edge of the rect to scroll
YMin | Upper edge of the rect to scroll
XMax | right edge of the rect to scroll
YMax | lower edge of the rect to scroll

Description

Scroll the contents of a rastport (dx,dy) towards (0,0). The empty spaces is filled by a call to RectFill(). Only the pixel in the rectangle (xMin,yMin)-(xMax,yMax) will be affected. The lower right corner (xMax, yMax) is automatically adjusted to the lower right corner in case it would be outside. After this operation the Flags bit of the layer associated with this rastport, if there is any layer, should be tested for simple layers in case there has any damage been created.

See also

ScrollRasterBF

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().


ScrollRasterBF

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().

Declaration

Source position: agraphics.pas line 2141

procedure ScrollRasterBF(

  Rp: PRastPort;

  Dx: LongInt;

  Dy: LongInt;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Rp | A pointer to a rastport
Dx | x value to move
Dy | y value to move
XMin | Left edge of the rect to scroll
YMin | Upper edge of the rect to scroll
XMax | right edge of the rect to scroll
YMax | lower edge of the rect to scroll

Description

Scroll the contents of a rastport (dx,dy) towards (0,0). The empty spaces is filled by a call to EraseRect(). Only the pixel in the rectangle (xMin,yMin)-(xMax,yMax) will be affected. The lower right corner (xMax, yMax) is automatically adjusted to the lower right corner in case it would be outside. After this operation the Flags bit of the layer associated with this rastport, if there is any layer, should be tested for simple layers in case there has any damage been created.

See also

ScrollRaster

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.


ScrollVPort

Reinterpret RasInfo information in ViewPort to reflect the current Offset values.

Declaration

Source position: agraphics.pas line 2078

procedure ScrollVPort(

  Vp: PViewPort

);

Arguments

Vp

A pointer to a ViewPort structure that is currently be displayed.

Description

After the programmer has adjusted the Offset values in the RasInfo structures of ViewPort, change the the copper lists to reflect the the Scroll positions. Changing the BitMap ptr in RasInfo and not changing the the Offsets will effect a double buffering affect.

Errors

Amiga video drivers can perform a validation of offsets, and may refuse to scroll the screen too far (if they somehow can't provide the requested offset). In this case offset values in the ViewPort will be updated in order to reflect the real result of the operation.


SetABPenDrMd

Set pen colors and draw mode for a RastPort.

Declaration

Source position: agraphics.pas line 2124

procedure SetABPenDrMd(

  Rp: PRastPort;

  APen: LongWord;

  BPen: LongWord;

  DrawMode: LongWord

);

Arguments

Rp | A pointer to a RastPort
APen | primary pen value
BPen | secondary pen value
DrawMode | 0-255, some combinations may not make much sense.

Description

Set the pen values and drawing mode for lines, fills and text.

This call is essentially the same as a sequence of SetAPen()/SetBPen()/SetDrMD() calls, except that it is significantly faster. The minterms will only be generated once, or not at all if nothing changed (warning to illegal RastPort pokers!).

This functions turns on PenMode for the RastPort.

See also

SetAPen | Set the primary pen for a RastPort.
SetBPen | Set secondary pen for a RastPort
SetDrMD | Set drawing mode for a RastPort


SetAfPt

Set Area PAttern and Point Size

Declaration

Source position: agraphics.pas line 2169

procedure SetAfPt(

  w: PRastPort;

  p: Pointer;

  n: Byte

);

Arguments

w | A pointer to a Rastport
p | Area Fill pattern
n | Area Point Size


SetAPen

Set the primary pen for a RastPort.

Declaration

Source position: agraphics.pas line 2037

procedure SetAPen(

  Rp: PRastPort;

  Pen: LongWord

);

Arguments

Rp | A pointer to a RastPort
Pen | Pen (0..255)

Description

Set the primary drawing pen (A-Pen) for lines, fills, and text. This functions turns on PenMode for the RastPort.

See also

GetAPen | Get the A Pen value for a RastPort
SetBPen | Set secondary pen for a RastPort
GetBPen | Get the B Pen value for a RastPort


SetBPen

Set secondary pen for a RastPort

Declaration

Source position: agraphics.pas line 2038

procedure SetBPen(

  Rp: PRastPort;

  Pen: LongWord

);

Arguments

Rp | A pointer to a RastPort
Pen | Pen (0..255)

Description

Set the secondary drawing pen (B-Pen) for lines, fills, and text. This functions turns on PenMode for the RastPort.

See also

GetBPen | Get the B Pen value for a RastPort
SetAPen | Set the primary pen for a RastPort.
GetAPen | Get the A Pen value for a RastPort


SetChipRev

Turns on the features of a Chip Set

Declaration

Source position: agraphics.pas line 2123

function SetChipRev(

  Want: LongWord

):LongWord;

Function result

Actual bits set in GfxBase^.ChipRevBits0.

Description

Enables the features of the requested Chip Set if available, and updates the graphics database accordingly.

This routine should only be called once. It will be called by the system in the startup-sequence, but is included in the autodocs for authors of bootblock-games that wish to take advantage of post-ECS features.

Errors

This function isn't implemented on all platforms.


SETCHIPREV_A

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 1959

const SETCHIPREV_A = GFXF_HR_AGNUS;


SETCHIPREV_AA

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 1961

const SETCHIPREV_AA = GFXF_AA_ALICE or GFXF_AA_LISA or SETCHIPREV_ECS;


SETCHIPREV_BEST

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 1962

const SETCHIPREV_BEST = $ffffffff;


SETCHIPREV_ECS

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 1960

const SETCHIPREV_ECS = GFXF_HR_AGNUS or GFXF_HR_DENISE;


SetCollision

Set a pointer to a user collision routine.

Declaration

Source position: agraphics.pas line 2003

procedure SetCollision(

  Num: LongWord;

  Routine: TProcedure;

  GInfo: PGelsInfo

);

Arguments

Num | Collision vector number
Routine | A pointer to the user's collision routine
GInfo | A pointer to a GelsInfo structure

Description

Sets a specified entry (num) in the user's collision vectors table equal to the address of the specified collision routine.

See also

InitGels

initialize a gel list; must be called before using gels.


SetDrMd

Set drawing mode for a RastPort

Declaration

Source position: agraphics.pas line 2039

procedure SetDrMd(

  Rp: PRastPort;

  DrawMode: LongWord

);

Arguments

Rp | A pointer to a RastPort.
DrawMode | 0-255, some combinations may not make much sense. (e.g. JAM1, JAM2, COMPLEMENT, INVERSVID, AREAOUTLINE or NOCROSSFILL )

Description

Set the drawing mode for lines, fills and text.


SetDrPt

Set Draw Pattern

Declaration

Source position: agraphics.pas line 2170

procedure SetDrPt(

  w: PRastPort;

  p: Word

);

Arguments

w | A pointer to a RastPort
p | Pattern to Set


SetFont

Set the text font and attributes in a RastPort.

Declaration

Source position: agraphics.pas line 1989

function SetFont(

  Rp: PRastPort;

  TextFont: PTextFont

):LongInt;

Arguments

Rp | The RastPort in which the text attributes are to be changed
TextFont | pointer to a TextFont structure returned from OpenFont() or OpenDiskFont

Description

This function sets the font in the RastPort to that described by font, and updates the text attributes to reflect that change. This function clears the effect of any previous soft styles.

This function had previously been documented that it would accept a null font. This practice is discouraged.

  • Use of a RastPort with a null font with text routines has always been incorrect and risked the guru.
  • Keeping an obsolete font pointer in the RastPort is no more dangerous than keeping a zero one there.
  • SetFont(rp, 0) causes spurious low memory accesses under some system software releases.

See also

OpenFont | Get a pointer to a system font.
OpenDiskFont |
StripFont | Remove the TextFontExtension from a font


SetMaxPen

Set maximum pen value for a rastport

Declaration

Source position: agraphics.pas line 2139

procedure SetMaxPen(

  Rp: PRastPort;

  MaxPen: LongWord

);

Arguments

Rp | A pointer to a RastPort
MaxPen | A longword pen value.

Description

This will instruct the graphics library that the owner of the rastport will not be rendering in any colors whose index is >maxpen. If there are any speed optimizations which the graphics device can make based on this fact (for instance, setting the pixel write mask), they will be done.

Basically this call sets the rastport mask, if this would improve speed. On devices where masking would slow things down (like with chunky pixels), it will be a no-op.

The maximum pen value passed must take into account not only which colors you intend to render in the future, but what colors you will be rendering on top of. SetMaxPen(rp, 0); doesn't make much sense.

See also

SetWriteMask

Set the pixel write mask value for a RastPort


SetOPen

Set Outline pen

Declaration

Source position: agraphics.pas line 2171

procedure SetOPen(

  w: PRastPort;

  c: Byte

);

Arguments

w | A pointer to a RastPort
c | Pen 0..255


SetOutlinePen

Set the Outline Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2137

function SetOutlinePen(

  Rp: PRastPort;

  Pen: LongWord

):LongWord;

Arguments

Rp | A pointer to a RastPort
Pen | Pen 0..255

Function result

Returns the previous outline pen

Description

Set the current value of the O pen for the rastport and turn on area outline mode. This function should be used instead of poking the structure directly, because future graphics devices may store it differently, for instance, using more bits.


SetRast

Set an entire drawing area to a specified color.

Declaration

Source position: agraphics.pas line 2019

procedure SetRast(

  Rp: PRastPort;

  Pen: LongWord

);

Arguments

Rp | A pointer to a RastPort
Pen | The pen number (0-255) to jam into bitmap

Description

Set the entire contents of the specified RastPort to the specified pen.

See also

RectFill

Fill a rectangular region in a RastPort.


SetRGB32

Set one color register for this Viewport.

Declaration

Source position: agraphics.pas line 2116

procedure SetRGB32(

  Vp: PViewPort;

  N: LongWord;

  R: LongWord;

  G: LongWord;

  B: LongWord

);

Arguments

Vp | Viewport
N | The number of the color register to set.
R | Red level (32 bit left justified fraction)
G | green level (32 bit left justified fraction)
B | blue level (32 bit left justified fraction)

Description

If there is a ColorMap for this viewport, then the value will be stored in the ColorMap. The selected color register is changed to match your specs. If the color value is unused then nothing will happen.

Lower order bits of the palette specification will be discarded, depending on the color palette resolution of the target graphics device. Use $ffffffff for the full value, $7fffffff for 50%, etc. You can find out the palette range for your screen by querying the graphics data base.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB32 | Set a series of color registers for this Viewport.
SetRGB32CM | Set one color register for this ColorMap.
LoadRGB32 | Set a series of color registers for this Viewport.


SetRGB32CM

Set one color register for this ColorMap.

Declaration

Source position: agraphics.pas line 2140

procedure SetRGB32CM(

  Cm: PColorMap;

  N: LongWord;

  R: LongWord;

  G: LongWord;

  B: LongWord

);

Arguments

Cm | Colormap
N | The number of the color register to set. Must not exceed the number of colors allocated for the colormap.
R | red level (32 bit unsigned left justified fraction)
G | green level (32 bit unsigned left justified fraction)
B | blue level (32 bit unsigned left justified fraction)

Description

Store the (r,g,b) triplet at index n of the ColorMap structure. This function can be used to set up a ColorMap before before linking it into a viewport.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB32 | Set a series of color registers for this Viewport.
SetRGB32 | Set one color register for this Viewport.
LoadRGB32 | Set a series of color registers for this Viewport.


SetRGB4

Set one color register for this viewport.

Declaration

Source position: agraphics.pas line 2028

procedure SetRGB4(

  Vp: PViewPort;

  Index: LongInt;

  Red: LongWord;

  Green: LongWord;

  Blue: LongWord

);

Arguments

Vp

Modify this viewport

Description

Change the color look up table so that this viewport displays the color (r,g,b) for pen number n.

If there is a ColorMap for this viewport, then the value will be stored in the ColorMap. The selected color register is changed to match your specs. If the color value is unused then nothing will happen.

Lower order bits of the palette specification will be discarded, depending on the color palette resolution of the target graphics device. Use $f for the full value, $7 for 50%, etc. You can find out the palette range for your screen by querying the graphics data base.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB4 | Inquire value of entry in ColorMap.
SetRGB4CM | Set one color register for this ColorMap.


SetRGB4CM

Set one color register for this ColorMap.

Declaration

Source position: agraphics.pas line 2085

procedure SetRGB4CM(

  ColorMap: PColorMap;

  Index: LongInt;

  Red: LongWord;

  Green: LongWord;

  Blue: LongWord

);

Description

Store the (r,g,b) triplet at index n in the ColorMap structure. The changes will not be immediately displayed. Use this function before linking the ColorMap to a ViewPort.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB4 | Inquire value of entry in ColorMap.
SetRGB4 | Set one color register for this viewport.


SetRPAttrs

VarArgs Version of SetRPAttrsA()

Declaration

Source position: agraphics.pas line 2160

procedure SetRPAttrs(

  Rp: PRastPort;

  const Tags: array of PtrUInt

);


SetRPAttrsA

Modify rastport settings via a tag list

Declaration

Source position: agraphics.pas line 2146

procedure SetRPAttrsA(

  Rp: PRastPort;

  Tags: PTagItem

);

Arguments

Rp | A pointer to a RastPort
Tags | Tags for the elements to get

Description

Modify settings of a rastport, based on the taglist passed. See GetRPAttrsA() for possible Tags

See also

SetRPAttrsA | Modify rastport settings via a tag list
SetFont | Set the text font and attributes in a RastPort.
SetSoftStyle | Set the soft style of the current font.
SetAPen | Set the primary pen for a RastPort.
SetBPen | Set secondary pen for a RastPort
SetDrMd | Set drawing mode for a RastPort
SetOutLinePen | Set the Outline Pen value for a RastPort
SetWriteMask | Set the pixel write mask value for a RastPort
SetMaxPen | Set maximum pen value for a rastport
GetRPAttrsA | Examine rastport settings via a tag list


SetSoftStyle

Set the soft style of the current font.

Declaration

Source position: agraphics.pas line 1993

function SetSoftStyle(

  Rp: PRastPort;

  Style: LongWord;

  Enable: LongWord

):LongWord;

Arguments

Rp | A pointer to a RastPort
Style | The new font style to set, subject to enable.
Enable | Those bits in style to be changed. Any set bits here that would not be set as a result of AskSoftStyle() will be ignored, and the Result will not be as expected.

Function result

The resulting style, both as a result of previous soft style selection, the effect of this function, and the style inherent in the set font.

Description

This function alters the soft style of the current font. Only those bits that are also set in enable are affected. The resulting style is returned, since some style request changes will not be honored when the implicit style of the font precludes changing them.

See also

AskSoftStyle

Get the soft style bits of the current font.


SetWriteMask

Set the pixel write mask value for a RastPort

Declaration

Source position: agraphics.pas line 2138

function SetWriteMask(

  Rp: PRastPort;

  Msk: LongWord

):LongWord;

Arguments

Rp

A pointer to a RastPort

Function result

Graphics devices which do not support per-bit masking will return 0 (failure).

Description

Set the current value of the bit write mask for the rastport. bits of the pixel with zeros in their mask will not be modified by subsequent drawing operations.


SetWrMsk

Set Write Mask for RastPort

Declaration

Source position: agraphics.pas line 2172

procedure SetWrMsk(

  w: PRastPort;

  m: Byte

);

Arguments

w | A pointer to a RastPort
m | Mask to set


SortGList

Sort the current gel list, ordering its y,x coordinates.

Declaration

Source position: agraphics.pas line 2004

procedure SortGList(

  Rp: PRastPort

);

Arguments

Rp

A pointer to the RastPort structure containing the GelsInfo

Description

Sorts the current gel list according to the gels' y,x coordinates. This sorting is essential before calls to DrawGList() or DoCollision().

See also

InitGels | initialize a gel list; must be called before using gels.
DoCollision | Test every gel in gel list for collisions.
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.


StripFont

Remove the TextFontExtension from a font

Declaration

Source position: agraphics.pas line 2112

procedure StripFont(

  Font: PTextFont

);

Arguments

Font

Font to remove extension from.

See also

ExtendFont

Ensure TTextFont.tf_Extension has been built for a font


SyncSBitMap

Syncronize Super BitMap with whatever is in the standard Layer bounds.

Declaration

Source position: agraphics.pas line 2054

procedure SyncSBitMap(

  Layer: PLayer

);

Description

Copy all bits from ClipRects in Layer into Super BitMap BitMap. This is used for those functions that do not want to deal with the ClipRect structures but do want to be able to work with a SuperBitMap Layer.

After calling this function, the programmer can manipulate the bits in the superbitmap associated with the layer. Afterwards, the programmer should call CopySBitMap to copy the bits back into the onscreen layer.

See also

CopySBitmap

Syncronize Layer window with contents of Super BitMap


TextExtent

Determine raster extent of text data.

Declaration

Source position: agraphics.pas line 2093

function TextExtent(

  Rp: PRastPort;

  String1: PChar;

  Count: LongInt;

  TextExtent: PTextExtent

):LongInt;

Arguments

Rp | A pointer to the RastPort which describes where the text attributes reside.
Count | the number of characters in the string. If 0, there are no characters in the string.

Description

This function determines a more complete metric of the space that a text string would render into than the TextLength() function.

TextExtent_ is filled in as follows:

te_Width
same as TextLength() result: the RastPort current x position advance that rendering this text would cause.
te_Height
same as tf_YSize. The height of the font.
te_Extent.MinX
the offset to the left side of the rectangle this would render into. Often zero.
te_Extent.MinY
same as -tf_Baseline. The offset from the baseline to the top of the rectangle this would render into.
te_Extent.MaxX
the offset of the left side of the rectangle this would render into. Often the same as te_Width - 1.
te_Extent.MaxY
same as tf_YSize - tf_Baseline - 1. The offset from the baseline to the bottom of the rectangle this would render into.

See also

TextLength | Determine raster length of text data.
GfxText | Write text characters (no formatting).
TextFit | Count characters that will fit in a given extent


TextFit

Count characters that will fit in a given extent

Declaration

Source position: agraphics.pas line 2094

function TextFit(

  Rp: PRastPort;

  String1: PChar;

  StrLen: LongWord;

  TextExtent: PTextExtent;

  ConstrainingExtent: PTextExtent;

  StrDirection: LongInt;

  ConstrainingBitWidth: LongWord;

  constrainingBitHeight: LongWord

):LongWord;

Arguments

Rp | A pointer to the RastPort which describes where the text attributes reside.
StrLen | The number of characters in the string. If 0, there are no characters in the string.
ConstrainingExtent | The extent that the text must fit in. This can be nil, indicating only the constrainingBit dimensions will describe the constraint.
StrDirection | the offset to add to the string pointer to get to the next character in the string. Usually 1. Set to -1 and the string to the end of the string to perform a TextFit() anchored at the end. No other value is valid.
ConstrainingBitWidth | An alternative way to specify the rendering box constraint width that is independent of the rendering origin. Range 0..32767.
constrainingBitHeight | An alternative way to specify the rendering box constraint height that is independent of the rendering origin. Range 0..32767.

Function result

The number of characters from the origin of the given string that will fit in both the constraining extent (which specifies a CP bound and a rendering box relative to the origin) and in the rendering width and height specified.The result is 0 chars and an empty TextExtent when the fit cannot be performed. This occurs not only when no text will fit in the provided constraints, but also when: The RastPort's rp_TxSpacing sign and magnitude is so great it reverses the path of the text or the constrainingExtent does not include x = 0.

Description

This function determines how many of the characters of the provided string will fit into the space described by the constraining parameters. It also returns the extent of that number of characters.

See also

TextLength | Determine raster length of text data.
TextExtent | Determine raster extent of text data.
GfxText | Write text characters (no formatting).


TextLength

Determine raster length of text data.

Declaration

Source position: agraphics.pas line 1987

function TextLength(

  Rp: PRastPort;

  String1: PChar;

  Count: LongWord

):LongInt;

Arguments

Rp | A pointer to the RastPort which describes where the text attributes reside.
Count | The string length. If 0, there are no characters in the string.

Function result

The number of pixels in x this text would occupy, not including any negative kerning that may take place at the beginning of the text string, nor taking into account the effects of any clipping that may take place.

Description

This graphics function determines the length that text data would occupy if output to the specified RastPort with the current attributes. The length is specified as the number of raster dots: to determine what the current position would be after a GfxText() using this string, add the length to cp_x (cp_y is unchanged by GfxText()). Use the newer TextExtent() to get more information.

See also

TextFit | Count characters that will fit in a given extent
TextExtent | Determine raster extent of text data.
GfxText | Write text characters (no formatting).


UCopperListInit

Allocates and initializes copperlist structures and buffers internal to UCopList structure.

Declaration

Source position: agraphics.pas line 2079

function UCopperListInit(

  UCopList: PUCopList;

  N: LongInt

):PCopList;

See also

CMOVE | Append copper move instruction to user copper list.
CWAIT | Append copper wait instruction to user copper list.


UnlockLayerRom

Unlock Layer structure by ROM(gfx lib) code.

Declaration

Source position: agraphics.pas line 2053

procedure UnlockLayerRom(

  Layer: PLayer

);

Description

Release the lock on this layer. If the same task has called LockLayerRom() more than once than the same number of calls to UnlockLayerRom() must happen before the layer is actually freed so that other tasks may use it. This call does destroy scratch registers. This call is identical to UnlockLayer().

See also

LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
UnlockLayer | Unlock layer and allow graphics routines to use it.
LockLayer | Lock layer to make changes to ClipRects.


VBeamPos

Get vertical beam position at this instant.

Declaration

Source position: agraphics.pas line 2044

function VBeamPos: LongInt;

Description

interrogates hardware for beam position and returns value. valid results in are the range of 0-511. Because of multitasking, the actual value returned may have no use. If you are the highest priority task then the value returned should be close, within 1 line.

Errors

This function isn't implemented on all platforms.


VideoControl

Modify the operation of a ViewPort's ColorMap

Declaration

Source position: agraphics.pas line 2096

function VideoControl(

  ColorMap: PColorMap;

  TagArray: PTagItem

):LongBool;

Function result

error = nil

Description

Process the commands in the VideoControl command TagItem buffer using cm as the target, with respect to its "attached" ViewPort.

Errors

Not implemented


VIDEOCONTROL_BATCH

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1072

const VIDEOCONTROL_BATCH = $10;


VideoControlTags

VarArgs Version of VideoControl()

Declaration

Source position: agraphics.pas line 2153

function VideoControlTags(

  ColorMap: PColorMap;

  const Tags: array of PtrUInt

):LongBool;

See also

GetColorMap | Allocate and initialize Colormap
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.


WaitBlit

Wait for the blitter to be finished before proceeding with anything else.

Declaration

Source position: agraphics.pas line 2018

procedure WaitBlit;

Description

WaitBlit returns when the blitter is idle. This function should normally only be used when dealing with the blitter in a synchronous manner, such as when using OwnBlitter() and DisownBlitter(). WaitBlit() does not wait for all blits queued up using QBlit() or QBSBlit(). You should call WaitBlit() if you are just about to modify or free some memory that the blitter may be using.

Errors

This function is unimplemented.

See also

OwnBlitter | get the blitter for private usage
DisownBlitter | Returns blitter to free state.


WaitBOVP

Wait till vertical beam reached bottom of this viewport.

Declaration

Source position: agraphics.pas line 2047

procedure WaitBOVP(

  Vp: PViewPort

);

Arguments

Vp

A pointer to ViewPort structure

Description

Returns when the vertical beam has reached the bottom of this viewport

Errors

This function is unimplemented.


WaitTOF

Wait for the top of the next video frame.

Declaration

Source position: agraphics.pas line 2025

procedure WaitTOF;

Description

Wait for vertical blank to occur and all vertical blank interrupt routines to complete before returning to caller. Adds the task to the TOF queue; it will be signalled when the vertical blank interrupt occurs.


WeighTAMatch

Determines how well two font descriptions match.

Declaration

Source position: agraphics.pas line 2109

function WeighTAMatch(

  ReqTextAttr: PTTextAttr;

  TargetTextAttr: PTextAttr;

  TargetTags: PTagItem

):LongInt;

Arguments

ReqTextAttr | The required textattr.
TargetTextAttr | A textattr of potential match.
TargetTags | Tags for the targetTextAttr.

Function result

A weight number which measures how well the TextAttrs match. The weight may vary from 0 (no match) to MAXFONTMATCHWEIGHT (perfect match).

Errors

Does not yet take tags into account.


WeighTAMatchTags

Declaration

Source position: agraphics.pas line 2154

function WeighTAMatchTags(

  ReqTextAttr: PTTextAttr;

  TargetTextAttr: PTextAttr;

  const TargetTags: array of PtrUInt

):LongInt;


WriteChunkyPixels

Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2149

procedure WriteChunkyPixels(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  XStop: LongWord;

  YStop: LongWord;

  Array1: PByte;

  BytesPerRow: LongInt

);

Arguments

Rp | Destination RastPort
XStart | Starting x Point
YStart | Starting y Point
XStop | Stop X Point
YStop | Stop Y Point
BytesPerRow | The number of bytes per row in the source array. This should be at least as large as the number of pixels being written per line.

Description

For each pixel in a rectangular region, decode the pen number selector from a linear array of pen numbers into the bit-planes used to describe a particular rastport.

xstop must be >= xstart and ystop must be >= ystart The source array can be in fast RAM.

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


WritePixel

Change the pen num of one specific pixel in a specified RastPort.

Declaration

Source position: agraphics.pas line 2034

function WritePixel(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongInt;

Arguments

Rp | A pointer to a RastPort
X | X coordinate of Pixel
Y | Y coordinate of Pixel

Function result

0 if pixel succesfully changed = -1 if (x,y) is outside the RastPort

Description

Changes the pen number of the selected pixel in the specified RastPort to that currently specified by PenA, the primary drawing pen. Obeys minterms in RastPort.

See also

ReadPixel

read the pen number value of the pixel at a specified x,y location within a certain RastPort.


WritePixelArray8

Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2106

function WritePixelArray8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  XStop: LongWord;

  YStop: LongWord;

  Array1: PByte;

  TempRp: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X Start point
YStart | Y Start point
XStop | X end point
YStop | Y end point
TempRp | A temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set = 1, temprp^.BitMap with BytesPerRow = (((width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

Count will be set to the number of pixels plotted.

Description

For each pixel in a rectangular region, decode the pen number selector from a linear array of pen numbers into the bit-planes used to describe a particular rastport. xstop must be >= xstart and ystop must be >= ystart

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


WritePixelLine8

Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.

Declaration

Source position: agraphics.pas line 2104

function WritePixelLine8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  Width: LongWord;

  Array1: PByte;

  TempRp: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X Start point
YStart | Line To write
Width | Count of horizontal pixels to write
TempRp | temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set = 1, temprp^.BitMap BytesPerRow = (((Width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

Count will be set to the number of pixels plotted

Description

For each pixel in a horizontal region, decode the pen number selector from a linear array of pen numbers into the bit-planes used to describe a particular rastport.

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


XorRectRegion

Perform 2d XOR operation of rectangle with region, leaving result in region

Declaration

Source position: agraphics.pas line 2073

function XorRectRegion(

  Region: PRegion;

  Rectangle: PRectangle

):LongBool;

Function result

True if successful operation, False if ran out of memory

Description

Add portions of rectangle to region if they are not in the region. Remove portions of rectangle from region if they are in the region.

See also

OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.


XorRegionRegion

Perform 2d XOR operation of one region with second region, leaving result in second region

Declaration

Source position: agraphics.pas line 2083

function XorRegionRegion(

  SrcRegion: PRegion;

  DestRegion: PRegion

):LongBool;

Arguments

SrcRegion | A pointer to Source Region
DestRegion | A pointer to Destination Region

Function result

True if successful operation, False if ran out of memory

Description

Join the regions together. If any part of SrcRegion overlaps DestRegion then remove that from the new region.

See also

OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.


Reference for unit 'AHI': Procedures and functions

AHI_AddAudioMode

AHI_AllocAudio

AHI_AllocAudioA

AHI_AllocAudioRequest

AHI_AllocAudioRequestA

AHI_AudioRequest

AHI_AudioRequestA

AHI_BestAudioID

AHI_BestAudioIDA

AHI_ControlAudio

AHI_ControlAudioA

AHI_FreeAudio

AHI_FreeAudioRequest

AHI_GetAudioAttrs

AHI_GetAudioAttrsA

AHI_KillAudio

AHI_LoadModeFile

AHI_LoadSound

AHI_NextAudioID

AHI_Play

AHI_PlayA

AHI_RemoveAudioMode

AHI_SampleFrameSize

AHI_SetEffect

AHI_SetFreq

AHI_SetSound

AHI_SetVol

AHI_UnloadSound

InitAHILibrary


Unit 'AHI' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'AHI': Variables

AHIBase


Index of all identifiers in unit 'AHI'

A F I P S T

A

AHIA_AudioID | AHIDB_MaxPlaySamples | AHIP_Length
AHIA_Channels | AHIDB_MaxRecordSamples | AHIP_LoopFreq
AHI_AddAudioMode | AHIDB_MinInputGain | AHIP_LoopLength
AHI_AllocAudio | AHIDB_MinMixFreq | AHIP_LoopOffset
AHI_AllocAudioA | AHIDB_MinMonitorVolume | AHIP_LoopPan
AHI_AllocAudioRequest | AHIDB_MinOutputVolume | AHIP_LoopSound
AHI_AllocAudioRequestA | AHIDB_MultTable | AHIP_LoopVol
AHIA_MaxPlayerFreq | AHIDB_Name | AHIP_Offset
AHIA_MinPlayerFreq | AHIDB_NOMODESCAN | AHIP_Pan
AHIA_MixFreq | AHIDB_Output | AHIP_Sound
AHIA_PlayerFreq | AHIDB_OutputArg | AHIP_Vol
AHIA_PlayerFunc | AHIDB_Outputs | AHIR_DoDefaultMode
AHIA_RecordFunc | AHIDB_Panning | AHIR_DoMixFreq
AHIA_SoundFunc | AHIDB_PingPong | AHI_RemoveAudioMode
AHIA_Sounds | AHIDB_Realtime | AHIR_FilterFunc
AHI_AudioRequest | AHIDB_Record | AHIR_FilterTags
AHI_AudioRequestA | AHIDB_Stereo | AHIR_InitialAudioID
AHIA_UserData | AHIDB_Version | AHIR_InitialHeight
AHIBase | AHIDB_Volume | AHIR_InitialInfoHeight
AHIB_Dizzy | AHI_DEBUG_ALL | AHIR_InitialInfoLeftEdge
AHI_BestAudioID | AHI_DEBUG_HIGH | AHIR_InitialInfoOpened
AHI_BestAudioIDA | AHI_DEBUG_LOW | AHIR_InitialInfoTopEdge
AHIC_Input | AHI_DEBUG_NONE | AHIR_InitialInfoWidth
AHIC_InputGain | AHI_DEFAULT_FREQ | AHIR_InitialLeftEdge
AHIC_InputGain_Query | AHI_DEFAULT_ID | AHIR_InitialMixFreq
AHIC_Input_Query | AHI_DEFAULT_UNIT | AHIR_InitialTopEdge
AHIC_MixFreq_Query | AHIDF_NOMODESCAN | AHIR_InitialWidth
AHIC_MonitorVolume | AHIE_ABORTED | AHIR_IntuiMsgFunc
AHIC_MonitorVolume_Query | AHIE_BADSAMPLETYPE | AHIR_Locale
AHI_ControlAudio | AHIE_BADSOUNDTYPE | AHIR_NegativeText
AHI_ControlAudioA | AHIEDM_DRY | AHIR_PositiveText
AHIC_Output | AHIEDM_WET | AHIR_PrivateIDCMP
AHIC_Output_Query | AHIE_HALFDUPLEX | AHIR_PubScreenName
AHIC_OutputVolume | AHIE_NOMEM | AHIR_Screen
AHIC_OutputVolume_Query | AHIE_OK | AHIR_SleepWindow
AHIC_Play | AHIET_CANCEL | AHIR_TextAttr
AHIC_Record | AHIET_CHANNELINFO | AHIR_TitleText
AHIDB_Annotation | AHIET_DSPECHO | AHIR_UserData
AHIDB_AudioID | AHIET_DSPMASK | AHIR_Window
AHIDB_Author | AHIET_MASTERVOLUME | AHI_SampleFrameSize
AHIDB_Bits | AHIET_OUTPUTBUFFER | AHISB_IMM
AHIDB_BufferLen | AHIE_UNKNOWN | AHI_SetEffect
AHIDB_Copyright | AHI_FreeAudio | AHI_SetFreq
AHIDB_Data | AHI_FreeAudioRequest | AHI_SetSound
AHIDB_Driver | AHI_GetAudioAttrs | AHI_SetVol
AHIDB_Flags | AHI_GetAudioAttrsA | AHISF_IMM
AHIDB_Frequencies | AHI_INVALID_ID | AHIST_BW
AHIDB_Frequency | AHI_KillAudio | AHIST_DYNAMICSAMPLE
AHIDB_FrequencyArg | AHI_LoadModeFile | AHIST_INPUT
AHIDB_FullDuplex | AHI_LoadSound | AHIST_M16S
AHIDB_HiFi | AHI_LOOPBACK_ID | AHIST_M32S
AHIDB_Index | AHI_MIXFREQ | AHIST_M8S
AHIDB_IndexArg | AHINAME | AHIST_M8U
AHIDB_Input | AHI_NextAudioID | AHIST_NOTYPE
AHIDB_InputArg | AHI_NOSOUND | AHIST_S16S
AHIDB_Inputs | AHI_NO_UNIT | AHIST_S32S
AHIDB_MaxChannels | AHIP_BeginChannel | AHIST_S8S
AHIDB_MaxInputGain | AHIP_EndChannel | AHIST_SAMPLE
AHIDB_MaxMixFreq | AHIP_Freq | AHI_TagBase
AHIDB_MaxMonitorVolume | AHI_Play | AHI_TagBaseR
AHIDB_MaxOutputVolume | AHI_PlayA | AHI_UnloadSound

F

LongInt

I

ID_AHIG ID_AHIU InitAHILibrary

P

PAHIAudioCtrl | PAHIEffMasterVolume | PAHISampleInfo
PAHIAudioModeRequester | PAHIEffOutputBuffer | PAHISoundMessage
PAHIDSPEcho | PAHIGlobalPrefs | PAHIUnitPrefs
PAHIEffChannelInfo | PAHIRecordMessage | PFixed
PAHIEffDSPMask | PAHIRequest | Psposition

S

sposition

T

tAHIAudioCtrl | tAHIEffMasterVolume | tAHISampleInfo
tAHIAudioModeRequester | tAHIEffOutputBuffer | tAHISoundMessage
tAHIDSPEcho | tAHIGlobalPrefs | tAHIUnitPrefs
tAHIEffChannelInfo | tAHIRecordMessage |
tAHIEffDSPMask | tAHIRequest |


AHI_AddAudioMode

Declaration

Source position: ahi.pas line 535

function AHI_AddAudioMode(

  a0arg: PTagItem

):Cardinal;


AHI_AllocAudio

Declaration

Source position: ahi.pas line 548

function AHI_AllocAudio(

  tagList: array of DWord

):PAHIAudioCtrl;


AHI_AllocAudioA

Declaration

Source position: ahi.pas line 481

function AHI_AllocAudioA(

  tagList: PTagItem

):PAHIAudioCtrl;


AHI_AllocAudioRequest

Declaration

Source position: ahi.pas line 552

function AHI_AllocAudioRequest(

  taglist: array of DWord

):PAHIAudioModeRequester;


AHI_AllocAudioRequestA

Declaration

Source position: ahi.pas line 520

function AHI_AllocAudioRequestA(

  tagList: PTagItem

):PAHIAudioModeRequester;


AHI_AudioRequest

Declaration

Source position: ahi.pas line 553

function AHI_AudioRequest(

  Requester: PAHIAudioModeRequester;

  taglist: array of DWord

):Boolean;


AHI_AudioRequestA

Declaration

Source position: ahi.pas line 523

function AHI_AudioRequestA(

  Requester: PAHIAudioModeRequester;

  tagList: PTagItem

):LongBool;


AHI_BestAudioID

Declaration

Source position: ahi.pas line 551

function AHI_BestAudioID(

  taglist: array of DWord

):Cardinal;


AHI_BestAudioIDA

Declaration

Source position: ahi.pas line 517

function AHI_BestAudioIDA(

  tagList: PTagItem

):Cardinal;


AHI_ControlAudio

Declaration

Source position: ahi.pas line 549

function AHI_ControlAudio(

  AudioCtrl: PAHIAudioCtrl;

  tagList: array of DWord

):Cardinal;


AHI_ControlAudioA

Declaration

Source position: ahi.pas line 490

function AHI_ControlAudioA(

  AudioCtrl: PAHIAudioCtrl;

  tagList: PTagItem

):Cardinal;


AHI_FreeAudio

Declaration

Source position: ahi.pas line 484

procedure AHI_FreeAudio(

  AudioCtrl: PAHIAudioCtrl

);


AHI_FreeAudioRequest

Declaration

Source position: ahi.pas line 526

procedure AHI_FreeAudioRequest(

  Requester: PAHIAudioModeRequester

);


AHI_GetAudioAttrs

Declaration

Source position: ahi.pas line 550

function AHI_GetAudioAttrs(

  ID: Cardinal;

  Audioctrl: PAHIAudioCtrl;

  taglist: array of DWord

):Boolean;


AHI_GetAudioAttrsA

Declaration

Source position: ahi.pas line 514

function AHI_GetAudioAttrsA(

  ID: Cardinal;

  Audioctrl: PAHIAudioCtrl;

  tagList: PTagItem

):LongBool;


AHI_KillAudio

Declaration

Source position: ahi.pas line 487

procedure AHI_KillAudio;


AHI_LoadModeFile

Declaration

Source position: ahi.pas line 541

function AHI_LoadModeFile(

  a0arg: PChar

):Cardinal;


AHI_LoadSound

Declaration

Source position: ahi.pas line 505

function AHI_LoadSound(

  Sound: Word;

  SType: Cardinal;

  Info: Pointer;

  AudioCtrl: PAHIAudioCtrl

):Cardinal;


AHI_NextAudioID

Declaration

Source position: ahi.pas line 511

function AHI_NextAudioID(

  Last_ID: Cardinal

):Cardinal;


AHI_Play

Declaration

Source position: ahi.pas line 554

procedure AHI_Play(

  Audioctrl: PAHIAudioCtrl;

  taglist: array of DWord

);


AHI_PlayA

Declaration

Source position: ahi.pas line 529

procedure AHI_PlayA(

  Audioctrl: PAHIAudioCtrl;

  tagList: PTagItem

);


AHI_RemoveAudioMode

Declaration

Source position: ahi.pas line 538

function AHI_RemoveAudioMode(

  d0arg: Cardinal

):Cardinal;


AHI_SampleFrameSize

Declaration

Source position: ahi.pas line 532

function AHI_SampleFrameSize(

  SampleType: Cardinal

):Cardinal;


AHI_SetEffect

Declaration

Source position: ahi.pas line 502

function AHI_SetEffect(

  Effect: Pointer;

  AudioCtrl: PAHIAudioCtrl

):Cardinal;


AHI_SetFreq

Declaration

Source position: ahi.pas line 496

procedure AHI_SetFreq(

  Channel: Word;

  Freq: Cardinal;

  AudioCtrl: PAHIAudioCtrl;

  Flags: Cardinal

);


AHI_SetSound

Declaration

Source position: ahi.pas line 499

procedure AHI_SetSound(

  Channel: Word;

  Sound: Word;

  Offset: Cardinal;

  Length: LongInt;

  AudioCtrl: PAHIAudioCtrl;

  Flags: Cardinal

);


AHI_SetVol

Declaration

Source position: ahi.pas line 493

procedure AHI_SetVol(

  Channel: Word;

  Volume: LongInt;

  Pan: LongInt;

  AudioCtrl: PAHIAudioCtrl;

  Flags: Cardinal

);


AHI_UnloadSound

Declaration

Source position: ahi.pas line 508

procedure AHI_UnloadSound(

  Sound: Word;

  Audioctrl: PAHIAudioCtrl

);


InitAHILibrary

Declaration

Source position: ahi.pas line 556

function InitAHILibrary: Boolean;


Reference for unit 'AmigaDOS': Procedures and functions

AbortPkt | Aborts an asynchronous packet, if possible.
AddBuffers | Changes the number of buffers for a filesystem
AddDosEntry | Add a Dos List entry to the lists
AddPart | Appends a file/dir to the end of a path
AddSegment | Adds a resident segment to the resident list
AddSegmentTagList | Adds a program segment to the system resident list.
AllocDosObject | Creates a dos object
AllocDosObjectTagList | VarArgs version of AllocDosObject
AllocDosObjectTags | Variable args version for AllocDosObject for direct tag use.
AssignAdd | Adds a lock to an assign for multi-directory assigns
AssignLate | Creates an assignment to a specified path later
AssignLock | Creates an assignment to a locked object
AssignPath | Creates an assignment to a specified path
AttemptLockDosList | Attempt to lock the Dos Lists for use
BADDR | Convert a BPTR to a Pointer
ChangeMode | Change the current mode of a lock or filehandle
CheckSignal | Checks for break signals
Cli | Returns a pointer to the CLI structure of the process
CliInitNewcli | Set up a process to be a shell using a startup packet.
CliInitRun | Set up a process to be a shell from initial packet
CompareDates | Compares two datestamps
CreateNewProc | Create a new process from taglist
CreateNewProcTagList |
CreateNewProcTags | Variable args version for CreateNewProc for direct tag use.
CreateProc | Create a new process
CurrentDir | Make a directory lock the current directory
DateStamp | Fills the structure with the current time. Time is measured from 1. Jan. 1978.
DeleteVar | Deletes a local or environment variable
DeviceProc | Return the process MsgPort of specific I/O handler
DoPkt | Send a dos packet and wait for reply
DoPkt0 |
DoPkt1 |
DoPkt2 |
DoPkt3 |
DoPkt4 |
dosClose |
dosCreateDir | Creates a new directory under the given name.
DOSDateToStr |
DOSDelay | Delay a process for a specified time
dosDeleteFile | Delete a file or directory
dosExit | Instantly terminate the program.
dosFlush | Flushes buffers for a buffered filehandle
dosInput | Identify the program's initial input file handle
dosOpen | Open a file for input or output
dosOutput | Identify the programs' initial output file handle
dosRead | Read bytes of data from a file
dosReadLn |
dosRename | Rename a directory or file
dosSeek | Set the current position for reading and writing
DOSStrToDate |
dosSystem |
dosWrite | Write bytes of data to a file
dosWriteStr |
DupLock | Duplicate a lock
DupLockFromFH | Gets a lock on an open file
EndNotify | Ends a notification request
ErrorReport | Displays a Retry/Cancel requester for an error
ExAll | Examine an entire directory
ExAllEnd | Stop an ExAll()
Examine | Examine a directory or file associated with a lock
Examine64 | Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock.
Examine64TagList | VarArgs version of Examine64
Examine64Tags | VarArgs Version of Examine64
ExamineFH | Gets information on an open file
ExamineFH64 | Fill in a FileInfoBlock structure concerning a file associated with a particular filehandle.
ExamineFH64TagList | VarArgs Version of ExamineFH64
ExamineFH64Tags | VarArgs Version of ExamineFH64
Execute | Execute a CLI command
ExNext | Examine the next entry in a directory
ExNext64 | Examine the next entry in a directory.
ExNext64TagList | VarArgs Version of ExNext64
ExNext64Tags | VarArgs Version of ExNext64
Fault | Returns the text associated with a DOS error code
FGetC | Read a character from the specified input (buffered)
FGets | Reads a line from the specified input (buffered)
FilePart | Returns the last component of a path
FindArg | Find a keyword in a template
FindCliProc | Returns a pointer to the requested CLI process
FindDosEntry | Finds a specific Dos List entry
FindSegment | Finds a segment on the resident list
FindSegmentTagList | Search for a resident segment by name and type.
FindVar | Finds a local variable
Format | Initialise a filesystem for use by the system.
FPutC | Write a character to the specified output
FPuts | Writes a string the the specified output
FRead | Reads a number of blocks from an input (buffered)
FreeArgs | Free allocated memory after ReadArgs()
FreeCLIData |
FreeDeviceProc | Releases port returned by GetDeviceProc()
FreeDosEntry | Frees an entry created by MakeDosEntry
FreeDosObject | Frees an object allocated by AllocDosObject()
FWrite | Writes a number of blocks to an output (buffered)
GetArgStr | Returns the arguments for the process
GetConsoleTask | Returns the default console for the process
GetCurrentDirName | Returns the current directory name
GetDeviceProc | Finds a handler to send a message to
GetDosObjectAttr |
GetDosObjectAttrTagList |
GetFileSysAttr | Query filesystem for attributes, such as maximum filename length, or maximum file size.
GetFileSysTask | Returns the default filesystem for the process
GetProgramDir | Returns a lock on the directory the program was loaded from
GetProgramName | Returns the current program name
GetPrompt | Returns the prompt for the current process
GetSegListAttr | Query seglist for attributes, such as the ObjData ptr.
GetSegListAttrTagList | VarArgs Version of GetSegListAttr
GetSegListAttrTags | VarArgs Version of GetSegListAttrTagList
GetVar | Returns the value of a local or global variable
Info | Returns information about the disk
Inhibit | Inhibits access to a filesystem
InternalLoadSeg | Low-level load routine
IoErr | Return extra information from the system
IsFileSystem | Returns whether a Dos handler is a filesystem
IsInteractive | Discover whether a file is "interactive"
LoadSeg | Scatterload a loadable file into memory
Lock | Lock a directory or file
LockDosList | Locks the specified Dos Lists for use
LockRecord | Locks a portion of a file
LockRecord64 | Lock a portion of a file for exclusive access.
LockRecords | Lock a series of records
LockRecords64 | Lock several records at the same time.
MakeDosEntry | Creates a DosList structure
MakeLink | Creates a filesystem link
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
MatchPattern | Checks for a pattern match with a string
MatchPatternNoCase | Checks for a pattern match with a string
MaxCli | Returns the highest CLI process number possibly in use
MKBADDR | Conbert a Pointer to a BPTR Value
NameFromFH | Get the name of an open filehandle
NameFromLock | Returns the name of a locked object
NewLoadSeg | Improved version of LoadSeg for stacksizes
NewLoadSegTagList |
NewReadLink | Read the filename referred to by the soft-linked object
NextDosEntry | Get the next Dos List entry
OpenFromLock | Opens a file you have a lock on
ParentDir |
ParentOfFH | Returns a lock on the parent directory of a file
ParsePattern | Create a tokenized string for MatchPattern()
ParsePatternNoCase | Create a tokenized string for MatchPatternNoCase()
PathPart | Returns a pointer to the end of the next-to-last component of a path.
PrintFault | Returns the text associated with a DOS error code
PutStr | Writes a string the the default output (buffered)
QueryCLIDataTagList |
QueryCLIDataTags | VarArgsVersion of QueryCLIDataTagList
ReadArgs | Read bytes of data from a file
ReadChar |
ReadChars |
ReadItem | Reads a single argument/name from command line
ReadLink | Reads the path for a soft filesystem link
Relabel | Change the volume name of a volume
ReleaseCLINumber |
RemAssignList | Remove an entry from a multi-dir assign
RemDosEntry | Removes a Dos List entry from it's list
RemSegment | Removes a resident segment from the resident list
ReplyPkt | Replies a packet to the person who sent it to you
RunCommand | Runs a program using the current process
SameDevice | Are two locks are on partitions of the device?
SameLock | Returns whether two locks are on the same object
Seek64 | Changes the current read/write position in a file
SelectInput | Select a filehandle as the default input channel
SelectOutput | Select a filehandle as the default output channel
SendPkt | Sends a packet to a handler
SetArgStr | Sets the arguments for the current process
SetComment | Change a files' comment string
SetConsoleTask | ets the default console for the process
SetCurrentDirName | Sets the directory name for the process
SetDosObjectAttr |
SetDosObjectAttrTagList |
SetFileDate | Sets the modification date for a file or dir
SetFileSize | Sets the size of a file
SetFileSize64 | Change the size of a file.
SetFileSysTask | Sets the default filesystem for the process
SetIoErr | Sets the value returned by IoErr()
SetMode | Set the current behavior of a handler
SetOwner | Set owner information for a file or directory
SetProgramDir | Sets the directory returned by GetProgramDir
SetProgramName | Sets the name of the program being run
SetPrompt | Sets the CLI/shell prompt for the current process
SetProtection | Set protection for a file or directory
SetVar | Sets a local or environment variable
SetVBuf | Set buffering modes and size
SplitName | splits out a component of a pathname into a buffer
StartNotify | Starts notification on a file or directory
StrToLong | string to Integer value (decimal)
SystemTagList | Have a shell execute a command line
SystemTags | Variable args version for SystemTagList for direct tag use.
UnGetC | Makes a char available for reading again. (buffered)
UnLoadSeg | Unload a seglist previously loaded by LoadSeg()
Unlock | Unlock a directory or file
UnLockDosList | Unlocks the Dos List
UnLockRecord | Unlock a record
UnLockRecord64 | Release a lock made with LockRecord64().
UnLockRecords | Unlock a list of records
UnLockRecords64 | Release an array of record locks obtained with LockRecords64().
UnReadChar |
VFPrintf | format and print a string to a file (buffered)
VFWritef | Write a BCPL formatted string to a file (buffered)
VPrintf | Format and print string (buffered)
VWritef |
WaitForChar | Determine if chars arrive within a time limit
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
WriteChar |
WriteChars | Writes bytes to the the default output (buffered)


Unit 'AmigaDOS' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'AmigaDOS': Variables

DosBase


Index of all identifiers in unit 'AmigaDOS'

A B C D E F G H I L M N O P Q R S T U V W

A

ABORT_BUSY | ACTION_SEEK64 | ADO_DE_Surfaces
ABORT_DISK_ERROR | ACTION_SERIALIZE_DISK | ADO_DE_TableSize
AbortPkt | ACTION_SET_COMMENT | ADO_DE_UpperCyl
ACCESS_READ | ACTION_SET_DATE | ADO_DirLen
ACCESS_WRITE | ACTION_SET_FILE_SIZE | ADO_DN_ExitNotifyMsg
ACTION_ADD_NOTIFY | ACTION_SET_FILE_SIZE64 | ADO_DN_Flags
ACTION_CHANGE_MODE | ACTION_SET_MAP | ADO_DN_GlobalVec
ACTION_CHANGE_SIGNAL | ACTION_SET_OWNER | ADO_DN_Handler
ACTION_COPY_DIR | ACTION_SET_PREFS | ADO_DN_Lock
ACTION_COPY_DIR_FH | ACTION_SET_PROTECT | ADO_DN_MsgPort
ACTION_CREATE_DIR | ACTION_STARTUP | ADO_DN_Name
ACTION_CURRENT_VOLUME | ACTION_TIMER | ADO_DN_Priority
ACTION_DELETE_OBJECT | ACTION_WAIT_CHAR | ADO_DN_Seglist
ACTION_DIE | ACTION_WRITE | ADO_DN_SerialID
ACTION_DISK_CHANGE | ACTION_WRITE_PROTECT | ADO_DN_StackSize
ACTION_DISK_INFO | ACTION_WRITE_RETURN | ADO_DN_Startup
ACTION_DISK_TYPE | AddBuffers | ADO_DN_StartupValue
ACTION_END | AddDosEntry | ADO_DN_Status
ACTION_EVENT | AddPart | ADO_Dummy
ACTION_EXAMINE_ALL | ADDS_Dummy | ADO_FH_Mode
ACTION_EXAMINE_ALL_END | AddSegment | ADO_FS_DosType
ACTION_EXAMINE_FH | AddSegmentTagList | ADO_FSSM
ACTION_EXAMINE_FH64 | ADDS_Filename | ADO_FSSM_Device
ACTION_EXAMINE_NEXT | ADDS_Name | ADO_FSSM_Flags
ACTION_EXAMINE_NEXT64 | ADDS_Seglist | ADO_FSSM_Unit
ACTION_EXAMINE_OBJECT | ADDS_Type | ADO_PromptLen
ACTION_EXAMINE_OBJECT64 | ADO_AN_AssignList | ADO_VN_Date
ACTION_FH_FROM_LOCK | ADO_AN_AssignName | ADO_VN_DiskType
ACTION_FINDINPUT | ADO_AN_Lock | ADO_VN_Lock
ACTION_FINDOUTPUT | ADO_AN_MsgPort | ADO_VN_LockList
ACTION_FINDUPDATE | ADO_AN_Name | ADO_VN_MsgPort
ACTION_FLUSH | ADO_AN_Type | ADO_VN_Name
ACTION_FORMAT | ADO_CLI_Background | AllocDosObject
ACTION_FREE_DISK_FSSM | ADO_CLI_CommFile | AllocDosObjectTagList
ACTION_FREE_LOCK | ADO_CLI_CommName | AllocDosObjectTags
ACTION_FREE_RECORD | ADO_CLI_DefaultStack | APB_DIDDIR
ACTION_FREE_RECORD64 | ADO_CLI_Dir | APB_DirChanged
ACTION_GET_BLOCK | ADO_CLI_FailLevel | APB_DODIR
ACTION_GET_CURRENT_PREFS | ADO_CLI_Interactive | APB_DODOT
ACTION_GET_DISK_FSSM | ADO_CLI_Prompt | APB_DOWILD
ACTION_GET_PREFS_TEMPLATE | ADO_CLI_Result2 | APB_FollowHLinks
ACTION_INFO | ADO_CLI_ReturnCode | APB_ITSWILD
ACTION_INHIBIT | ADO_CommFileLen | APB_NOMEMERR
ACTION_IS_FILESYSTEM | ADO_CommNameLen | APEB_DontFollowSLinks
ACTION_LOCATE_OBJECT | ADO_DE | APEB_FutureExtension
ACTION_LOCK_RECORD | ADO_DE_Baud | APEB_LiteralSLinks
ACTION_LOCK_RECORD64 | ADO_DE_BlksPerTrack | APEF_DontFollowSLinks
ACTION_MAKE_LINK | ADO_DE_BootBlocks | APEF_FutureExtension
ACTION_MORE_CACHE | ADO_DE_BootPri | APEF_LiteralSLinks
ACTION_NEW_READ_LINK | ADO_DE_BufMemType | APF_DIDDIR
ACTION_NIL | ADO_DE_Control | APF_DirChanged
ACTION_PARENT | ADO_DE_DosType | APF_DODIR
ACTION_PARENT_FH | ADO_DE_HighCyl | APF_DODOT
ACTION_QUERY_ATTR | ADO_DE_Interleave | APF_DOWILD
ACTION_READ | ADO_DE_LowCyl | APF_FollowHLinks
ACTION_READ_LINK | ADO_DE_Mask | APF_ITSWILD
ACTION_READ_RETURN | ADO_DE_MaxTransfer | APF_NOMEMERR
ACTION_REMOVE_NOTIFY | ADO_DE_NumBuffers | APSB_EXTENDED
ACTION_RENAME_DISK | ADO_DE_NumHeads | APSF_EXTENDED
ACTION_RENAME_OBJECT | ADO_DE_PreAlloc | AssignAdd
ACTION_RESERVED_1 | ADO_DE_PreFac | AssignLate
ACTION_RESERVED_2 | ADO_DE_ReservedBlks | AssignLock
ACTION_SAME_LOCK | ADO_DE_SecOrg | AssignPath
ACTION_SCREEN_MODE | ADO_DE_SecsPerBlk | AttemptLockDosList
ACTION_SEEK | ADO_DE_SizeBlock |

B

BADDR | LongInt | BUF_LINE
BITSPERBYTE | LongInt | BUF_NONE
BITSPERLONG | BUF_FULL | BYTESPERLONG

C

CHANGE_FH | CLIDATATAG_Sorted | COMPLEX_BIT
CHANGE_LOCK | CliInitNewcli | CreateNewProc
ChangeMode | CliInitRun | CreateNewProcTagList
CheckSignal | CMD_DISABLED | CreateNewProcTags
Cli | CMD_INTERNAL | CreateProc
CLIDATATAG_CLINumber | CMD_NOTLOADED | CurrentDir
CLIDATATAG_CommandName | CMD_SYSTEM |
CLIDATATAG_Dummy | CompareDates |

D

DateStamp | DE_UPPERCYL | dosFlush
DDB_AllBit | DeviceProc | DOS_FSCONTEXT
DDB_Completed | DLT_DEVICE | dosInput
DDB_ExaminedBit | DLT_DIRECTORY | DOSNAME
DDB_PatternBit | DLT_FSCONTEXT | dosOpen
DDB_Single | DLT_LATE | dosOutput
DDF_AllBit | DLT_NONBINDING | DOS_RDARGS
DDF_Completed | DLT_PRIVATE | dosRead
DDF_ExaminedBit | DLT_VOLUME | dosReadLn
DDF_PatternBit | DNF_REMDOSLIST | dosRename
DDF_Single | DNF_STARTONCE | dosSeek
DE_BAUD | DNF_UNLOADSEGLIST | DOS_STDPKT
DE_BLKSPERTRACK | DoPkt | DOSStrToDate
DE_BOOTBLOCKS | DoPkt0 | dosSystem
DE_BOOTPRI | DoPkt1 | DOSTRUE
DE_BUFMEMTYPE | DoPkt2 | DOS_VOLUMENODE
DE_CONTROL | DoPkt3 | dosWrite
DE_DOSTYPE | DoPkt4 | dosWriteStr
DE_INTERLEAVE | DOS_ASSIGNNODE | DTB_FUTURE
DeleteVar | DosBase | DTB_SUBST
DE_LOWCYL | DOS_CLI | DTF_FUTURE
DE_MASK | dosClose | DTF_SUBST
DE_MAXTRANSFER | dosCreateDir | DupLock
DE_MEMBUFTYPE | DOSDateToStr | DupLockFromFH
DE_NUMBUFFERS | DOSDelay | DVPB_ASSIGN
DE_NUMHEADS | dosDeleteFile | DVPB_FSCONTEXT
DE_PREFAC | DOS_DEVICENODE | DVPB_UNLOCK
DE_RESERVEDBLKS | DOS_EXALLCONTROL | DVPF_ASSIGN
DE_SECORG | dosExit | DVPF_FSCONTEXT
DE_SECSPERBLK | DOSFALSE | DVPF_UNLOCK
DE_SIZEBLOCK | DOS_FIB |
DE_TABLESIZE | DOS_FILEHANDLE |

E

ED_COMMENT | ERROR_LOCK_COLLISION | Examine64Tags
ED_DATE | ERROR_LOCK_TIMEOUT | EXAMINE_BIT
ED_NAME | ERROR_NO_DEFAULT_DIR | ExamineFH
ED_OWNER | ERROR_NO_DISK | ExamineFH64
ED_PROTECTION | ERROR_NO_FREE_STORE | ExamineFH64TagList
ED_SIZE | ERROR_NO_MORE_ENTRIES | ExamineFH64Tags
ED_SIZE64 | ERROR_NOT_A_DOS_DISK | EXCLUSIVE_LOCK
ED_TYPE | ERROR_NOT_EXECUTABLE | Execute
EndNotify | ERROR_NOT_IMPLEMENTED | ExNext
ENDSTREAMCH | ERROR_OBJECT_EXISTS | ExNext64
ERROR_ACTION_NOT_KNOWN | ERROR_OBJECT_IN_USE | ExNext64TagList
ERROR_BAD_HUNK | ERROR_OBJECT_LINKED | ExNext64Tags
ERROR_BAD_NUMBER | ERROR_OBJECT_NOT_FOUND | EXT_ABS
ERROR_BAD_STREAM_NAME | ERROR_OBJECT_TOO_LARGE | EXT_ABSCOMMON
ERROR_BAD_TEMPLATE | ERROR_OBJECT_WRONG_TYPE | EXT_ABSREF16
ERROR_BREAK | ERROR_READ_PROTECTED | EXT_ABSREF32
ERROR_BUFFER_OVERFLOW | ERROR_RECORD_NOT_LOCKED | EXT_ABSREF8
ERROR_COMMENT_TOO_BIG | ERROR_RENAME_ACROSS_DEVICES | EXT_COMMON
ERROR_DELETE_PROTECTED | ErrorReport | EXT_DEF
ERROR_DEVICE_NOT_MOUNTED | ERROR_REQUIRED_ARG_MISSING | EXT_DEXT16
ERROR_DIRECTORY_NOT_EMPTY | ERROR_SEEK_ERROR | EXT_DEXT32
ERROR_DIR_NOT_FOUND | ERROR_TASK_TABLE_FULL | EXT_DEXT8
ERROR_DISK_FULL | ERROR_TOO_MANY_ARGS | EXT_REF16
ERROR_DISK_NOT_VALIDATED | ERROR_TOO_MANY_LEVELS | EXT_REF32
ERROR_DISK_WRITE_PROTECTED | ERROR_UNLOCK_ERROR | EXT_REF8
ERROR_FILE_NOT_OBJECT | ERROR_UNMATCHED_QUOTES | EXT_RELCOMMON
ERROR_INVALID_COMPONENT_NAME | ERROR_WRITE_PROTECTED | EXT_RELREF16
ERROR_INVALID_LOCK | ExAll | EXT_RELREF32
ERROR_INVALID_RESIDENT_LIBRARY | ExAllEnd | EXT_RELREF8
ERROR_IS_SOFT_LINK | Examine | EXT_RES
ERROR_KEY_NEEDS_ARG | Examine64 | EXT_SYMB
ERROR_LINE_TOO_LONG | Examine64TagList |

F

Fault | FIBF_OTR_EXECUTE | FPuts
FAULT_MAX | FIBF_OTR_READ | FQA_DeviceType
FGetC | FIBF_OTR_WRITE | FQA_IsCaseSensitive
FGets | FIBF_PURE | FQA_MaxFileNameLength
FIBB_ARCHIVE | FIBF_READ | FQA_MaxFileSize
FIBB_DELETE | FIBF_SCRIPT | FQA_MaxVolumeNameLength
FIBB_EXECUTE | FIBF_WRITE | FQA_NumBlocks
FIBB_GRP_DELETE | FilePart | FQA_NumBlocksUsed
FIBB_GRP_EXECUTE | FindArg | FQA_ReservedAttr1
FIBB_GRP_READ | FindCliProc | FRead
FIBB_GRP_WRITE | FindDosEntry | FreeArgs
FIBB_OTR_DELETE | FindSegment | FreeCLIData
FIBB_OTR_EXECUTE | FindSegmentTagList | FreeDeviceProc
FIBB_OTR_READ | FindVar | FreeDosEntry
FIBB_OTR_WRITE | FNDS_Dummy | FreeDosObject
FIBB_PURE | FNDS_From | FSCONTEXTINFOTAG_Dummy
FIBB_READ | FNDS_Load | FSCONTEXTINFOTAG_NAME
FIBB_SCRIPT | FNDS_Name | FSCONTEXTTAG_DOSTYPE
FIBB_WRITE | FNDS_System | FSCONTEXTTAG_Dummy
FIBF_ARCHIVE | Format | FSCONTEXTTAG_FSSM
FIBF_DELETE | FORMAT_CDN | FSCONTEXTTAG_PRIORITY
FIBF_EXECUTE | FORMAT_DEF | FSCONTEXTTAG_SEGLIST
FIBF_GRP_DELETE | FORMAT_DOS | FSCONTEXTTAG_STACKSIZE
FIBF_GRP_EXECUTE | FORMAT_INT | FSCONTEXTTAG_STARTUPSTRING
FIBF_GRP_READ | FORMAT_MAX | FSCONTEXTTAG_STARTUPVALUE
FIBF_GRP_WRITE | FORMAT_USA | FWrite
FIBF_OTR_DELETE | FPutC |

G

GetArgStr | GetProgramName | GVB_LOCAL_ONLY
GetConsoleTask | GetPrompt | GVB_SAVE_VAR
GetCurrentDirName | GetSegListAttr | GVF_BINARY_VAR
GetDeviceProc | GetSegListAttrTagList | GVF_DONT_NULL_TERM
GetDosObjectAttr | GetSegListAttrTags | GVF_GLOBAL_ONLY
GetDosObjectAttrTagList | GetVar | GVF_LOCAL_ONLY
GetFileSysAttr | GVB_BINARY_VAR | GVF_SAVE_VAR
GetFileSysTask | GVB_DONT_NULL_TERM |
GetProgramDir | GVB_GLOBAL_ONLY |

H

HUNK_ABSRELOC16 | HUNK_DREL32 | HUNK_OVERLAY
HUNK_ABSRELOC32 | HUNK_DREL8 | HUNK_RELOC16
HUNKB_ADVISORY | HUNK_END | HUNK_RELOC32
HUNKB_CHIP | HUNK_EXT | HUNK_RELOC32SHORT
HUNKB_FAST | HUNKF_ADVISORY | HUNK_RELOC8
HUNK_BREAK | HUNKF_CHIP | HUNK_RELRELOC16
HUNK_BSS | HUNKF_FAST | HUNK_RELRELOC32
HUNK_CODE | HUNK_HEADER | HUNK_RELRELOC8
HUNK_DATA | HUNK_INDEX | HUNK_SYMBOL
HUNK_DEBUG | HUNK_LIB | HUNK_UNIT
HUNK_DREL16 | HUNK_NAME |

I

ID_CDFS_DISK | ID_LNFS_DOS_DISK | Inhibit
ID_CDROM_CDDA_DISK | ID_LNFS_FFS_DISK | InternalLoadSeg
ID_CDROM_HSF_DISK | ID_MSDOS_DISK | IoErr
ID_CDROM_ISO_DISK | ID_NO_DISK_PRESENT | IsFileSystem
ID_DOS_DISK | ID_NOT_REALLY_DOS | IsInteractive
ID_FASTDIR_DOS_DISK | ID_SFS_DISK | ITEM_EQUAL
ID_FASTDIR_FFS_DISK | ID_UNREADABLE_DISK | ITEM_ERROR
ID_FFS_DISK | ID_VALIDATED | ITEM_NOTHING
ID_INTER_DOS_DISK | ID_VALIDATING | ITEM_QUOTED
ID_INTER_FFS_DISK | ID_WRITE_PROTECTED | ITEM_UNQUOTED
ID_KICKSTART_DISK | Info |

L

LDB_ASSIGNS | LDF_ENTRY | LockRecord
LDB_DELETE | LDF_READ | LockRecord64
LDB_DEVICES | LDF_VOLUMES | LockRecords
LDB_ENTRY | LDF_WRITE | LockRecords64
LDB_READ | LEN_DATSTRING | LOCK_SAME
LDB_VOLUMES | LINK_HARD | LOCK_SAME_HANDLER
LDB_WRITE | LINK_SOFT | LOCK_SAME_VOLUME
LDF_ALL | LoadSeg | LV_ALIAS
LDF_ASSIGNS | Lock | LVB_IGNORE
LDF_DELETE | LOCK_DIFFERENT | LVF_IGNORE
LDF_DEVICES | LockDosList | LV_VAR

M

MakeDosEntry | MatchPatternNoCase | MKBADDR
MakeLink | MaxCli | MODE_NEWFILE
MatchEnd | _MAXINT | MODE_OLDFILE
MatchFirst | MAX_MULTIARGS | MODE_READWRITE
MatchNext | MAX_TEMPLATE_ITEMS |
MatchPattern | _MININT |

N

NameFromFH | NP_Error | NP_Seglist
NameFromLock | NP_ExitCode | NP_SeglistArray
NewLoadSeg | NP_ExitData | NP_StackSize
NewLoadSegTagList | NP_FreeSeglist | NP_StartupMsg
NewReadLink | NP_HomeDir | NP_Synchronous
NextDosEntry | NP_Input | NP_TaskMsgPort
NOTIFY_CLASS | NP_Name | NP_UserData
NOTIFY_CODE | NP_NotifyOnDeath | NP_WindowPtr
NP_Arguments | NP_Output | NRB_MAGIC
NP_Cli | NP_Path | NRB_NOTIFY_INITIAL
NP_CloseError | NP_PPC_Arg1 | NRB_SEND_MESSAGE
NP_CloseInput | NP_PPC_Arg2 | NRB_SEND_SIGNAL
NP_CloseOutput | NP_PPC_Arg3 | NRB_WAIT_REPLY
NP_CodeType | NP_PPC_Arg4 | NRF_MAGIC
NP_CommandName | NP_PPC_Arg5 | NRF_NOTIFY_INITIAL
NP_ConsoleTask | NP_PPC_Arg6 | NRF_SEND_MESSAGE
NP_CopyVars | NP_PPC_Arg7 | NRF_SEND_SIGNAL
NP_CurrentDir | NP_PPC_Arg8 | NRF_WAIT_REPLY
NP_Dummy | NP_PPCStackSize | NR_HANDLER_FLAGS
NP_Entry | NP_Priority |

O

OFFSET_BEGINING | OFFSET_CURRENT | OpenFromLock
OFFSET_BEGINNING | OFFSET_END |

P

PAChain | PDOSList | PRB_FREECURRDIR
PAnchorPath | PDOSPacket | PRB_FREESEGLIST
P_ANY | PErrorString | PRDArgs
ParentDir | PExAllControl | PRecordLock
ParentOfFH | PExAllData | PRecordLock64
ParsePattern | PFileHandle | P_REPBEG
ParsePatternNoCase | PFileInfoBlock | P_REPEND
PAssignList | PFileLock | PRF_CLOSEERROR
PathPart | PFileSysStartupMsg | PRF_CLOSEINPUT
P_CLASS | PInfoData | PRF_CLOSEOUTPUT
PCLIData | PLocalVar | PRF_FREEARGS
PCLIDataItem | P_NOT | PRF_FREECLI
PCliProcList | P_NOTCLASS | PRF_FREECURRDIR
PCommandLineInterface | P_NOTEND | PRF_FREESEGLIST
PCSource | PNotifyMessage | PrintFault
PDateStamp | PNotifyRequest | PRootNode
_PDateTime | P_OREND | PSegArray
PDeviceList | P_ORNEXT | PSegment
PDeviceNode | P_ORSTART | PSegNode
PDevInfo | PProcess | PSegSem
PDevProc | PRB_CLOSEERROR | P_SINGLE
PDosAttrBuffer | PRB_CLOSEINPUT | PStandardPacket
PDosEnvec | PRB_CLOSEOUTPUT | P_STOP
PDOSInfo | PRB_FREEARGS | PutStr
PDOSLibrary | PRB_FREECLI |

Q

QueryCLIDataTagList QueryCLIDataTags

R

RDAB_NOALLOC | REC_SHARED | RETURN_ERROR
RDAB_NOPROMPT | REC_SHARED_IMMED | RETURN_FAIL
RDAB_STDIN | Relabel | RETURN_OK
RDAF_NOALLOC | ReleaseCLINumber | RETURN_WARN
RDAF_NOPROMPT | RemAssignList | RNB_PRIVATE1
RDAF_STDIN | RemDosEntry | RNB_WILDSTAR
ReadArgs | RemSegment | RNF_PRIVATE1
ReadChar | ReplyPkt | RNF_WILDSTAR
ReadChars | REPORT_INSERT | RunCommand
ReadItem | REPORT_LOCK | RUN_EXECUTE
ReadLink | REPORT_STREAM | RUN_SYSTEM
REC_EXCLUSIVE | REPORT_TASK | RUN_SYSTEM_ASYNCH
REC_EXCLUSIVE_IMMED | REPORT_VOLUME |

S

SameDevice | SetComment | SIGBREAKF_CTRL_C
SameLock | SetConsoleTask | SIGBREAKF_CTRL_D
Seek64 | SetCurrentDirName | SIGBREAKF_CTRL_E
SEGLISTTAG_DOS_SEGINDEX | SetDosObjectAttr | SIGBREAKF_CTRL_F
SEGLISTTAG_Dummy | SetDosObjectAttrTagList | SplitName
SEGLISTTAG_ELF_SEGADDRALIGN | SetFileDate | StartNotify
SEGLISTTAG_ELF_SEGFLAGS | SetFileSize | ST_FILE
SEGLISTTAG_ELF_SEGINDEX | SetFileSize64 | ST_LINKDIR
SEGLISTTAG_ELF_SEGNAME | SetFileSysTask | ST_LINKFILE
SEGLISTTAG_ELF_SEGOFFSET | SetIoErr | ST_PIPEFILE
SEGLISTTAG_ELF_SEGTYPE | SetMode | ST_ROOT
SEGLISTTAG_OBJDATA | SetOwner | StrToLong
SEGLISTTAG_SEGLISTTYPE | SetProgramDir | ST_SOFTLINK
SEGLISTTAG_SEGSIZE | SetProgramName | ST_USERDIR
SEGLISTTAG_SEGSTART | SetPrompt | SYS_Asynch
SEGLISTTYPE_AMIGA | SetProtection | SYS_CustomShell
SEGLISTTYPE_ELF | SetVar | SYS_Dummy
SEGLISTTYPE_POWERUP | SetVBuf | SYS_FilterTags
SEG_SEM | SHARED_LOCK | SYS_Input
SelectInput | SIGBREAKB_CTRL_C | SYS_Output
SelectOutput | SIGBREAKB_CTRL_D | SystemTagList
SendPkt | SIGBREAKB_CTRL_E | SystemTags
SetArgStr | SIGBREAKB_CTRL_F | SYS_UserShell

T

TAChain | TDosAttrBuffer | TInfoData
TAnchorPath | TDosEnvec | TLocalVar
TAssignList | TDOSInfo | TNotifyMessage
TCLIData | TDOSLibrary | TNotifyRequest
TCLIDataItem | TDOSList | TProcess
TCliProcList | TDOSPacket | TRDArgs
TCommandLineInterface | TErrorString | TRecordLock
TCSource | TexAllControl | TRecordLock64
TDateStamp | TExAllData | TRootNode
_TDateTime | TFileHandle | TSegArray
TDeviceList | TFileInfoBlock | TSegment
TDeviceNode | TFileLock | TSegNode
TDevInfo | TFileSysStartupMsg | TSegSem
TDevProc | TICKS_PER_SECOND | TStandardPacket

U

UnGetC | UnLockDosList | UnLockRecords
UnLoadSeg | UnLockRecord | UnLockRecords64
Unlock | UnLockRecord64 | UnReadChar

V

VFPrintf | VPrintf
VFWritef | VWritef

W

WaitForChar | WriteChar
WaitPkt | WriteChars


AbortPkt

Aborts an asynchronous packet, if possible.

Declaration

Source position: amigados.pas line 1805

procedure AbortPkt(

  port: PMsgPort;

  pkt: PDOSPacket

);

Arguments

port | The message port to where the packet was sent.
pkt | The packet to be aborted.

Description

This function does currently nothing. You can use WaitForChar() to poll for characters from an interactive handler.

The planned purpose of this function is: Tries to abort an asynchronous packet. There is no guarantee that this succeeds. You must wait with WaitPkt() for the packet to return before you can reuse or deallocate it.


AddBuffers

Changes the number of buffers for a filesystem

Declaration

Source position: amigados.pas line 2123

function AddBuffers(

  name: PChar;

  number: LongInt

):LongBool;

Description

Add or remove cache memory to/from a filesystem. The amount of memory per cache buffer and the limit depends on the filesystem.

  • DosTrue on success (IoErr() gives the actual number of buffers).
  • DosFalse on error (IoErr() gives the error code).

Some old filesystems return the actual buffer size. See the snippet for a workaround for that case.

Snippet:

Res1 := AddBuffers('df0:', 10);
Res2 := IoErr();
if (res1 <> DosFalse) and (res1 <> DosTrue) then
begin
  Res2 := Res1;
  Res1 := DosTrue;
end;

See also

IoErr

Return extra information from the system


AddDosEntry

Add a Dos List entry to the lists

Declaration

Source position: amigados.pas line 2088

function AddDosEntry(

  dlist: PDOSList

):LongBool;

Arguments

dlist

Pointer to DOS list entry.

Function result

DosTrue if all went well. DosFalsefor errors; IoErr() will return additional error code.

Description

Adds a given dos list entry to the DOS list. Automatically locks the list for writing. There may be not more than one device or assign node of the same name. There are no restrictions on volume nodes except that the time stamps must differ.

See also

RemDosEntry | Removes a Dos List entry from it's list
FindDosEntry | Finds a specific Dos List entry
NextDosEntry | Get the next Dos List entry
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry
LockDosList | Locks the specified Dos Lists for use
AttemptLockDosList | Attempt to lock the Dos Lists for use


AddPart

Appends a file/dir to the end of a path

Declaration

Source position: amigados.pas line 2213

function AddPart(

  dirname: PChar;

  filename: PChar;

  size: Cardinal

):LongBool;

Arguments

dirname | The path to add a file/directory name to.
filename | The filename or directory name to add. May be a relative pathname from the current directory. (example: foo/bar). Can deal with leading '/'(s), indicating one directory up per '/', or with a ':', indicating it's relative to the root of the appropriate volume.
size | size in bytes of the space allocated for dirname. Must not be 0.

Description

This functions adds a file, directory or other path name to a directory path. It will take into account any pre-existing separator characters (':','/'). If filename is an absolute path it will replace the current value of dirname.

See also

FilePart | Returns the last component of a path
PathPart | Returns a pointer to the end of the next-to-last component of a path.


AddSegment

Adds a resident segment to the resident list

Declaration

Source position: amigados.pas line 2151

function AddSegment(

  name: PChar;

  seg: LongInt;

  system: LongInt

):LongBool;

Arguments

name | Name of the segment. This is used by FindSegment(). Will be copied.
seg | Segment to add.

Function result

<> 0 = success, 0 = Error

Description

Adds a program segment to the system resident list. You can later use these segments to run programs.

The type field determines the type of resident program. Normal programs should have type >= 0, system segments should have type = CMD_SYSTEM.

Note that all other values of type are reserved.

See also

FindSegment | Finds a segment on the resident list
RemSegment | Removes a resident segment from the resident list
LoadSeg | Scatterload a loadable file into memory


AddSegmentTagList

Adds a program segment to the system resident list.

Declaration

Source position: amigados.pas line 2285

function AddSegmentTagList(

  tags: Pointer

):LongInt;

Arguments

tags

pointer to a taglist

Function result

= 0 failure, otherwise success

Description

Adds a program segment to the system resident list. You can later use these segments to run programs.

The name field should refer to a #0 terminated strings, which will be copied. The type field determines the type of resident program. Normal programs should have type >= 0, system segments should have type = CMD_SYSTEM. The file name is only used if no seglist is given. It is the name of the file that will be loaded when someone tries to access this segment.

Note that all other values of ADDS_Type are reserved.

Available Tags

ADDS_Name
(PChar), required
ADDS_Seglist
(BPTR)
ADDS_Filename
(PChar) required if no seglist is given
ADDS_Type
(LongInt) Defaults to 0

Errors

Uses Forbid() based locking.

See also

FindSegment | Finds a segment on the resident list
RemSegment | Removes a resident segment from the resident list


AllocDosObject

Creates a dos object

Declaration

Source position: amigados.pas line 1741

function AllocDosObject(

  type1: Cardinal;

  tags: Pointer

):Pointer;

Arguments

type1 | Type of object requested
tags | Pointer to taglist with additional information (DOS_* and ADO_*)

Function result

Pointer to the object or nil

Description

Create a dos objects of a given type, initializes it, and returns it to you. Note the DOS_STDPKT returns a pointer to the sp_Pkt of the structure.This memory has to be freed with FreeDosObject().

This function may be called by a task for all types and tags DOS_* and ADO_*. Any future types or tags will be documented as to whether a task may use them.

See also

FreeDosObject

Frees an object allocated by AllocDosObject()


AllocDosObjectTagList

VarArgs version of AllocDosObject

Declaration

Source position: amigados.pas line 1745

function AllocDosObjectTagList(

  type1: Cardinal;

  tags: Pointer

):Pointer;


AllocDosObjectTags

Variable args version for AllocDosObject for direct tag use.

Declaration

Source position: amigados.pas line 2344

function AllocDosObjectTags(

  type1: Cardinal;

  Tags: array of DWord

):Pointer;

Arguments

Tags

Variable array of Tags use [TAG_1, 1, TAG_2, 2 ....] TAG_END will be automatically added at the end


AssignAdd

Adds a lock to an assign for multi-directory assigns

Declaration

Source position: amigados.pas line 2061

function AssignAdd(

  name: PChar;

  lock: LongInt

):LongBool;

Arguments

name | Name of the assign (without trailing ':').
lock | Lock associated with the assigned name

Function result

If False the adding failed, lock is not unlocked. IoErr() gives more information.

Description

Adds a lock to an assign, making or adding to a multi-directory assign. Note that this only will succeed on an assign created with AssignLock(), or an assign created with AssignLate() which has been resolved (converted into a AssignLock()-assign).

NOTE: you should not use the lock in any way after making this call successfully. It becomes the part of the assign, and will be unlocked by the system when the assign is removed. If you need to keep the lock, pass a lock from DupLock() to AssignLock().

See also

Lock | Lock a directory or file
AssignLock | Creates an assignment to a locked object
AssignPath | Creates an assignment to a specified path
AssignLate | Creates an assignment to a specified path later
DupLock | Duplicate a lock
RemAssignList | Remove an entry from a multi-dir assign


AssignLate

Creates an assignment to a specified path later

Declaration

Source position: amigados.pas line 2053

function AssignLate(

  name: PChar;

  path: PChar

):LongBool;

Arguments

name | Name of device to be assigned (without trailing ':')
path | Name of late assignment to be resolved on the first reference.

Function result

IoErr() gives more information of fail

Description

Create an assign for the given name, which will be resolved upon the first reference to it. If this succeeds (i.e. the path exists and can be locked) it will be turned into an AssignLock() type assign. This way you can create assigns to unmounted volumes which will only be requested when accessed.

See also

Lock | Lock a directory or file
AssignAdd | Adds a lock to an assign for multi-directory assigns
AssignPath | Creates an assignment to a specified path
AssignLock | Creates an assignment to a locked object


AssignLock

Creates an assignment to a locked object

Declaration

Source position: amigados.pas line 2049

function AssignLock(

  name: PChar;

  lock: LongInt

):LongBool;

Arguments

name | Name of device to assign lock to (without trailing ':')
lock | Lock associated with the assigned name

Function result

On failure, the lock is not unlocked. IoErr() gives more information.

Description

Sets up an assign of a name to a given lock. Passing nil for a lock cancels any outstanding assign to that name. If an assign entry of that name is already on the list, this routine replaces that entry. If an entry is on the list that conflicts with the new assign, then a failure code is returned.

NOTE: you should not use the lock in any way after making this call successfully. It becomes the part of the assign, and will be unlocked by the system when the assign is removed. If you need to keep the lock, pass a lock from DupLock() to AssignLock().

See also

Lock | Lock a directory or file
AssignAdd | Adds a lock to an assign for multi-directory assigns
AssignPath | Creates an assignment to a specified path
AssignLate | Creates an assignment to a specified path later
DupLock | Duplicate a lock
RemAssignList | Remove an entry from a multi-dir assign


AssignPath

Creates an assignment to a specified path

Declaration

Source position: amigados.pas line 2057

function AssignPath(

  name: PChar;

  path: PChar

):LongBool;

Arguments

name | Name of device to be assigned (without trailing ':')
path | Name of late assignment to be resolved at each reference

Function result

IoErr() gives more information of fail

Description

Sets up a assignment that is expanded upon EACH reference to the name. This is implemented through a new device list type. The path (a string) would be attached to the node. When the name is referenced (DosOpen("FOO:xyzzy"...), the string will be used to determine where to do the open. No permanent lock will be part of it. For example, you could AssignPath() c2: to df2:c, and references to c2: would go to df2:c, even if you change disks.

The other major advantage is assigning things to unmounted volumes, which will be requested upon access (useful in startup sequences).


AttemptLockDosList

Attempt to lock the Dos Lists for use

Declaration

Source position: amigados.pas line 2082

function AttemptLockDosList(

  flags: Cardinal

):PDOSList;

Arguments

flags

Flags stating which types of nodes you want to lock. (LDF_*)

Function result

Pointer to the beginning of the list or nil. Not a valid node its a pseudo element!

Description

Tries to get a lock on some of the dos lists. If all went well a handle is returned that can be used for FindDosEntry(). Don't try to busy wait until the lock can be granted - use LockDosList() instead.


BADDR

Convert a BPTR to a Pointer

Declaration

Source position: amigados.pas line 2322

function BADDR(

  x: LongInt

):Pointer;


ChangeMode

Change the current mode of a lock or filehandle

Declaration

Source position: amigados.pas line 1946

function ChangeMode(

  type1: LongInt;

  fh: LongInt;

  newmode: LongInt

):LongBool;

Arguments

newmode

The new mode you want

Description

This allows you to attempt to change the mode in use by a lock or filehandle. For example, you could attempt to turn a shared lock into an exclusive lock. The handler may well reject this request. Warning: if you use the wrong type for the object, the system may crash.

See also

Lock | Lock a directory or file
DosOpen | Open a file for input or output


CheckSignal

Checks for break signals

Declaration

Source position: amigados.pas line 2164

function CheckSignal(

  mask: LongInt

):LongInt;

Arguments

mask

The signal mask to check. ()SIGBREAKF_*)

Function result

The mask of all signals which were set. (SIGBREAKF_*)

Description

Checks the current task to see if any of the signals specified in the mask have been set. The mask of all signals which were set is returned. The signals specified in the mask will be cleared.


Cli

Returns a pointer to the CLI structure of the process

Declaration

Source position: amigados.pas line 1975

function Cli: PCommandLineInterface;

Function result

Pointer to the CLI structure, or nil

Description

Returns a pointer to the CLI structure of the current process, or nil if the process has no CLI structure.

Note: There is no CLI structure if started from WB, but also in shell it can be that it has no CLI structure, for example if it is started by an other program which didn't set the structure (famous example "make")


CLIDATATAG_CLINumber

Declaration

Source position: amigados.pas line 1342

const CLIDATATAG_CLINumber = CLIDATATAG_Dummy + $1;


CLIDATATAG_CommandName

Declaration

Source position: amigados.pas line 1343

const CLIDATATAG_CommandName = CLIDATATAG_Dummy + $2;


CLIDATATAG_Dummy

Declaration

Source position: amigados.pas line 1341

const CLIDATATAG_Dummy = TAG_USER + 3500;


CLIDATATAG_Sorted

Declaration

Source position: amigados.pas line 1344

const CLIDATATAG_Sorted = CLIDATATAG_Dummy + $3;


CliInitNewcli

Set up a process to be a shell using a startup packet.

Declaration

Source position: amigados.pas line 2244

function CliInitNewcli(

  dp: PDOSPacket

):LongInt;

Arguments

dp

startup arguments that were passed to the shell If NULL, defaults will be used

Function result

Flags or a Pointer

Description

This function initializes a process and CLI structure for a new shell, from parameters in an initial packet passed by the system (NewShell or NewCLI, etc). The format of the data in the packet is purposely not defined. The setup includes all the normal fields in the structures that are required for proper operation (current directory, paths, input streams, etc).

It returns a set of flags containing information about what type of shell invocation this is.

Definitions for the values of fn:

Bit 31
Set to indicate flags are valid
Bit 3
Set to indicate asynch system call
Bit 2
Set if this is a SystemTagList() call
Bit 1
Set if user provided input stream
Bit 0
Set if RUN provided output stream

If Bit 31 is 0, then you must check IoErr() to determine if an error occurred. If IoErr() returns a pointer to your process, there has been an error, and you should clean up and exit. The packet will have already been returned by CliInitNewcli(). If it isn't a pointer to your process and Bit 31 is 0, reply the packet immediately. (Note: this is different from what you do for CliInitRun().)

This function is very similar to CliInitRun().

See also

CliInitRun | Set up a process to be a shell from initial packet
ReplyPkt | Replies a packet to the person who sent it to you
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
IoErr | Return extra information from the system


CliInitRun

Set up a process to be a shell from initial packet

Declaration

Source position: amigados.pas line 2247

function CliInitRun(

  dp: PDOSPacket

):LongInt;

Arguments

dp

startup arguments specified as a packet

Function result

Flags or a Pointer

Description

This function initializes a process and CLI structure for a new shell, from parameters in an initial packet passed by the system (Run, SystemTagList(), Execute())). The format of the data in the packet is purposely not defined. The setup includes all the normal fields in the structures that are required for proper operation (current directory, paths, input streams, etc).

It returns a set of flags containing information about what type of shell invocation this is.

Definitions for the values of fn:

Bit 31
Set to indicate flags are valid
Bit 3
Set to indicate asynch system call
Bit 2
Set if this is a SystemTagList() call
Bit 1
Set if user provided input stream
Bit 0
Set if RUN provided output stream

If Bit 31 is 0, then you must check IoErr() to determine if an error occurred. If IoErr() returns a pointer to your process, there has been an error, and you should clean up and exit. The packet will have already been returned by CliInitNewcli(). If it isn't a pointer to your process and Bit 31 is 0, you should wait before replying the packet until after you've loaded the first command (or when you exit). This helps avoid disk "gronking" with the Run command. (Note: this is different from what you do for CliInitNewcli()).)

If Bit 31 is 1, then if Bit 3 is one, ReplyPkt() the packet immediately (Asynch SystemTagList()), otherwise wait until your shell exits (Sync SystemTagList(), Execute()). (Note: this is different from what you do for CliInitNewcli().)

This function is very similar to CliInitNewcli().

See also

CliInitNewcli | Set up a process to be a shell using a startup packet.
ReplyPkt | Replies a packet to the person who sent it to you
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
IoErr | Return extra information from the system
SystemTagList | Have a shell execute a command line
Execute | Execute a CLI command


CompareDates

Compares two datestamps

Declaration

Source position: amigados.pas line 2127

function CompareDates(

  date1: PDateStamp;

  date2: PDateStamp

):LongInt;

Arguments

date1 | DateStamps to compare
date2 | DateStamps to compare

Function result

<0, 0, or >0 based on comparison of two date stamps

Description

Compares two times for relative magnitide. <0 is returned if date1 is later than date2, 0 if they are equal, or >0 if date2 is later than date1. NOTE: this is not the same ordering as strcmp!

See also

DateStamp | Fills the structure with the current time. Time is measured from 1. Jan. 1978.
DOSStrToDate |


CreateNewProc

Create a new process from taglist

Declaration

Source position: amigados.pas line 1978

function CreateNewProc(

  tags: Pointer

):PProcess;

Arguments

tags

Information on the new process as tags (NP_*).

Description

You must specify one of NP_Seglist or NP_Entry. NP_Seglist takes a seglist (as returned by LoadSeg()). NP_Entry takes a function pointer for the routine to call.

There are many options, as you can see by examining dos/dostags.h. The defaults are for a non-CLI process, with copies of your CurrentDir, HomeDir (used for PROGDIR:), priority, consoletask, windowptr, and variables. The input and output filehandles default to opens of NIL:, stack to 4000, and others as shown in dostags.h. This is a fairly reasonable default setting for creating threads, though you may wish to modify it (for example, to give a descriptive name to the process.)

CreateNewProc() is callable from a task, though any actions that require doing Dos I/O (DupLock() of currentdir, for example) will not occur.

NOTE: if you call CreateNewProc() with both NP_Arguments, you must not specify an NP_Input of nil. When NP_Arguments is specified, it needs to modify the input filehandle to make ReadArgs() work properly.


CreateNewProcTagList

Declaration

Source position: amigados.pas line 1981

function CreateNewProcTagList(

  tags: Pointer

):PProcess;


CreateNewProcTags

Variable args version for CreateNewProc for direct tag use.

Declaration

Source position: amigados.pas line 2343

function CreateNewProcTags(

  tags: array of dword

):PProcess;

Arguments

tags

Variable array of Tags use [TAG_1, 1, TAG_2, 2 ....] TAG_END will be automatically added at the end


CreateProc

Create a new process

Declaration

Source position: amigados.pas line 1694

function CreateProc(

  name: PChar;

  pri: LongInt;

  segList: LongInt;

  stackSize: LongInt

):PMsgPort;

Arguments

name | Name of Process
pri | Priority for the process
segList | Pointer to a seglist to run
stackSize | Initial Stacksize for the process

Function result

Pointer to the new Process messageport or nil

Description

CreateProc() creates a new process of name 'name'. Processes are a superset of exec tasks.

A seglist, as returned by LoadSeg(), is passed as 'seglist'. This represents a section of code which is to be run as a new process. The code is entered at the first hunk in the segment list, which should contain suitable initialization code or a jump to such. A process control structure is allocated from memory and initialized.

The size of the root stack upon activation is passed as 'stackSize'. 'pri' specifies the required priority of the new process. The result will be the process msgport address of the new process, or nil if the routine failed. The argument 'name' specifies the new process name. A nil return code indicates error.

The seglist passed to CreateProc() is not freed when it exits; it is up to the parent process to free it, or for the code to unload itself.

See also

CreateNewProc | Create a new process from taglist
LoadSeg | Scatterload a loadable file into memory
UnLoadSeg | Unload a seglist previously loaded by LoadSeg()


CurrentDir

Make a directory lock the current directory

Declaration

Source position: amigados.pas line 1688

function CurrentDir(

  lock: LongInt

):LongInt;

Arguments

lock

Lock to directory should become new current directory

Function result

Pointer to a lock

Description

CurrentDir() causes a directory associated with a lock to be made the current directory. The old current directory lock is returned.

A value of nil is a valid result here, this nil lock represents the root of file system that you booted from.

Any call that has to DosOpen() or Lock() files (etc.) requires that the current directory be a valid lock or nil.

See also

Lock | Lock a directory or file
UnLock | Unlock a directory or file
DosOpen | Open a file for input or output
DupLock | Duplicate a lock


DateStamp

Fills the structure with the current time. Time is measured from 1. Jan. 1978.

Declaration

Source position: amigados.pas line 1720

function DateStamp(

  date: PDateStamp

):PDateStamp;

Arguments

date

Pointer to recieve the timing information.

Function result

Returns the supplied pointer

Description

DateStamp() takes a structure of three longwords that is set to the current time. The first element in the vector is a count of the number of days. The second element is the number of minutes elapsed in the day. The third is the number of ticks elapsed in the current minute. A tick happens 50 times a second. DateStamp() ensures that the day and minute are consistent. All three elements are zero if the date is unset.

See also

DOSStrToDate |
SetFileDate | Sets the modification date for a file or dir
CompareDates | Compares two datestamps


DeleteVar

Deletes a local or environment variable

Declaration

Source position: amigados.pas line 2236

function DeleteVar(

  name: PChar;

  flags: Cardinal

):LongBool;

Arguments

name | Pointer to an variable name. Note variable names follow filesystem syntax and semantics.
flags | combination of type of var to delete (low 8 bits), and flags to control the behavior of this routine. Currently defined flags include: GVF_LOCAL_ONLY - delete a local (to your process) variable. GVF_GLOBAL_ONLY - delete a global environment variable. The default is to delete a local variable if found, otherwise a global environment variable if found (only for LV_VAR).

Function result

If not 0, the variable was sucessfully deleted, 0 indicates failure.

Description

Deletes a local or environment variable.

The default is to delete a local variable if one was found, or to delete a global environmental variable otherwise.

A global environmental variable will only be deleted for the type LV_VAR.

See also

GetVar | Returns the value of a local or global variable
SetVar | Sets a local or environment variable
FindVar | Finds a local variable
DOSDeleteFile | Delete a file or directory


DeviceProc

Return the process MsgPort of specific I/O handler

Declaration

Source position: amigados.pas line 1709

function DeviceProc(

  name: PChar

):PMsgPort;

Arguments

name

The name of the DOS device, INCLUDING the ':'

Function result

A message port or nil

Description

DeviceProc() is an obsolete function that returns the MsgPort responsible for a DOS device.

DeviceProc() will fail if you ask for the MsgPort of a device created with AssignPath() as there is no process to return. If the device requested is an assign, the IoErr() will contain the Lock to the directory (the function will return the device on which the lock is set).

You should really use GetDeviceProc(), as that function returns a more useful structure (TDevProc), that will persist until FreeDeviceProc() is called on it.

See also

GetDeviceProc | Finds a handler to send a message to
FreeDeviceProc | Releases port returned by GetDeviceProc()
DupLock | Duplicate a lock
UnLock | Unlock a directory or file
Examine | Examine a directory or file associated with a lock


DoPkt

Send a dos packet and wait for reply

Declaration

Source position: amigados.pas line 1753

function DoPkt(

  port: PMsgPort;

  action: LongInt;

  arg1: LongInt;

  arg2: LongInt;

  arg3: LongInt;

  arg4: LongInt;

  arg5: LongInt

):LongInt;

Description

Send a dos packet to a filesystem and wait for the action to complete. Callable from a task. This function should NOT be used; it's only here for AmigaOS compatibility.

See also

AllocDosObject | Creates a dos object
FreeDosObject | Frees an object allocated by AllocDosObject()
SendPkt | Sends a packet to a handler
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
CreateNewProc | Create a new process from taglist
AbortPkt | Aborts an asynchronous packet, if possible.


DoPkt0

Declaration

Source position: amigados.pas line 1762

function DoPkt0(

  port: PMsgPort;

  action: LongInt

):LongInt;


DoPkt1

Declaration

Source position: amigados.pas line 1766

function DoPkt1(

  port: PMsgPort;

  action: LongInt;

  arg1: LongInt

):LongInt;


DoPkt2

Declaration

Source position: amigados.pas line 1771

function DoPkt2(

  port: PMsgPort;

  action: LongInt;

  arg1: LongInt;

  arg2: LongInt

):LongInt;


DoPkt3

Declaration

Source position: amigados.pas line 1777

function DoPkt3(

  port: PMsgPort;

  action: LongInt;

  arg1: LongInt;

  arg2: LongInt;

  arg3: LongInt

):LongInt;


DoPkt4

Declaration

Source position: amigados.pas line 1784

function DoPkt4(

  port: PMsgPort;

  action: LongInt;

  arg1: LongInt;

  arg2: LongInt;

  arg3: LongInt;

  arg4: LongInt

):LongInt;


dosClose

Declaration

Source position: amigados.pas line 1632

function dosClose(

  fileh: LongInt

):LongBool;


dosCreateDir

Creates a new directory under the given name.

Declaration

Source position: amigados.pas line 1685

function dosCreateDir(

  dname: PChar

):LongInt;

Function result

Exclusive lock to the new directory or 0 if couldn't be created. IoErr() gives additional information in that case.

Description

Creates a new directory under the given name. If all went an exclusive lock on the new diretory is returned.


DOSDateToStr

Declaration

Source position: amigados.pas line 2131

function DOSDateToStr(

  datetime: _PDateTime

):LongBool;


DOSDelay

Delay a process for a specified time

Declaration

Source position: amigados.pas line 1723

procedure DOSDelay(

  timeout: LongInt

);

Arguments

timeout

The minimum time to wait in ticks (1/50 seconds)

Description

The argument ticks specifies how many ticks (50 per second) to wait before returning control.


dosDeleteFile

Delete a file or directory

Declaration

Source position: amigados.pas line 1656

function dosDeleteFile(

  fname: PChar

):LongBool;

Function result

If failed IoErr() gives detailed error message.

Description

This attempts to delete the file or directory specified by name. An error is returned if the deletion fails. Note that all the files within a directory must be deleted before the directory itself can be deleted.


dosExit

Instantly terminate the program.

Declaration

Source position: amigados.pas line 1700

procedure dosExit(

  returnCode: LongInt

);

Arguments

returnCode

Process' return code.

Description

Calling this function bypasses normal termination sequence of your program. Automatically opened libraries will not be closed, destructors will not be called, etc. Do this only if you really know what are you doing. It's not advised to use this function at all.


dosFlush

Flushes buffers for a buffered filehandle

Declaration

Source position: amigados.pas line 1876

function dosFlush(

  fh: LongInt

):LongBool;

Function result

0 on error. IoErr() gives additional information in that case.

Description

Flushes any pending writes on the file. If the file was used for input and there is still some data to read it tries to seek back to the expected position.

On Amiga calling DosFlush() from different tasks on the same file handle is serialised. This means that most of the time it is possible to do I/O in one task to a file handle where DosFlush() is being called in another task on that file handle. No multi-thread safety is guaranteed though and data may be lost if I/O is done in parallel from different tasks on the same file handle.


dosInput

Identify the program's initial input file handle

Declaration

Source position: amigados.pas line 1645

function dosInput: LongInt;

Function result

Nil if no current input stream defined.

Description

Input() is used to identify the initial input stream allocated when the program was initiated. Never close the filehandle returned by Input!

See also

DosOutput | Identify the programs' initial output file handle
SelectInput | Select a filehandle as the default input channel


dosOpen

Open a file for input or output

Declaration

Source position: amigados.pas line 1628

function dosOpen(

  fname: PChar;

  accessMode: LongInt

):LongInt;

Arguments

accessMode

Access mode for file (MODE_*)

Description

The named file is opened and a file handle returned. If the accessMode is MODE_OLDFILE, an existing file is opened for reading or writing. If the value is MODE_NEWFILE, a new file is created for writing. MODE_READWRITE opens a file with an shared lock, but creates it if it didn't exist.

The name can be a filename (optionally prefaced by a device name), a simple device such as 'NIL:', a window specification such as 'CON:' or 'RAW:' followed by window parameters, or '*', representing the current window.

If the file cannot be opened for any reason, the value returned will be zero, and a secondary error code will be available by calling the routine IoErr().

See also

DosClose |
ChangeMode | Change the current mode of a lock or filehandle
NameFromFH | Get the name of an open filehandle
ParentOfFH | Returns a lock on the parent directory of a file
ExamineFH | Gets information on an open file


dosOutput

Identify the programs' initial output file handle

Declaration

Source position: amigados.pas line 1648

function dosOutput: LongInt;

Function result

Nil if no current output stream defined.

Description

Output() is used to identify the initial output stream allocated when the program was initiated. Never close the filehandle returned by Output().

See also

DosInput

Identify the program's initial input file handle


dosRead

Read bytes of data from a file

Declaration

Source position: amigados.pas line 1635

function dosRead(

  fileh: LongInt;

  buffer: Pointer;

  length: LongInt

):LongInt;

Arguments

buffer | Pointer to the buffer for the data
length | number of bytes to read. The filesystem is advised to try to fulfill the request as good as possible.

Description

Data can be copied using a combination of DOSRead() and DOSWrite(). DosRead() reads bytes of information from an opened file (represented here by the argument file) into the buffer given. The argument length is the length of the buffer given.

The value returned is the length of the information actually read. So, when result is greater than 0, the value of result is the the number of characters read. Usually DosRead() will try to fill up your buffer before returning. A value of 0 means that end-of-file has been reached. Errors are indicated by a value of -1.

See also

DosOpen | Open a file for input or output
DosClose |
DosWrite | Write bytes of data to a file
DosSeek | Set the current position for reading and writing


dosReadLn

Declaration

Source position: amigados.pas line 2334

function dosReadLn(

  buf: PChar;

  num: LongInt

):PChar;


dosRename

Rename a directory or file

Declaration

Source position: amigados.pas line 1659

function dosRename(

  oldName: PChar;

  newName: PChar

):LongBool;

Arguments

oldName | File to rename.
newName | New name for the file.

Description

Rename() attempts to rename the file or directory specified as oldName with the name newName. If the file or directory newName exists, Rename() fails and returns an error. Both oldName and the newName can contain a directory specification. In this case, the file will be moved from one directory to another.

Note: it is impossible to Rename() a file from one volume to another.


dosSeek

Set the current position for reading and writing

Declaration

Source position: amigados.pas line 1651

function dosSeek(

  fileh: LongInt;

  position: LongInt;

  posmode: LongInt

):LongInt;

Arguments

position

Value to seek (can be also negative for OFFSET_CURRENT or OFFSET_END)

Function result

Returns the position before the seek.

Description

DosSeek() sets the read/write cursor for the file file to the position 'position'. This position is used by both DosRead() and DosWrite() as a place to start reading or writing. The result is the current absolute position in the file, or -1 if an error occurs, in which case IoErr() can be used to find more information. mode can be OFFSET_BEGINNING (Start seek from file start), OFFSET_CURRENT (start seek from current position) or OFFSET_END (start seek from end of file). It is used to specify the relative start position. For example, 20 from current is a position 20 bytes forward from current, -20 is 20 bytes back from current.

So that to find out where you are, seek 0 from current. The end of the file is a Seek() positioned by 0 from end. You cannot Seek() beyond the end of a file.

See also

DosRead | Read bytes of data from a file
DosWrite | Write bytes of data to a file
SetFileSize | Sets the size of a file


DOSStrToDate

Declaration

Source position: amigados.pas line 2134

function DOSStrToDate(

  datetime: _PDateTime

):LongBool;


dosSystem

Declaration

Source position: amigados.pas line 2045

function dosSystem(

  command: PChar;

  tags: Pointer

):LongInt;


dosWrite

Write bytes of data to a file

Declaration

Source position: amigados.pas line 1640

function dosWrite(

  fileh: LongInt;

  buffer: Pointer;

  length: LongInt

):LongInt;

Arguments

buffer | Pointer to a buffer to write to file
length | Number of bytes to write. The filesystem is advised to try to fulfill the request as good as possible.

Function result

Number of bytes written, -1 for error.

Description

DosWrite() writes bytes of data to the opened file file. length indicates the length of data to be transferred; buffer is a pointer to the buffer. The value returned is the length of information actually written. So, when length is greater than zero, the result is the number of characters written. Errors are indicated by a value of -1.

See also

DosRead | Read bytes of data from a file
DosSeek | Set the current position for reading and writing
DosOpen | Open a file for input or output
DosClose |


dosWriteStr

Declaration

Source position: amigados.pas line 2335

function dosWriteStr(

  str: PChar

):LongInt;


DupLock

Duplicate a lock

Declaration

Source position: amigados.pas line 1670

function DupLock(

  lock: LongInt

):LongInt;

Arguments

lock

Lock to copy

Function result

Result 0 indicates an error.

Description

DupLock() is passed a shared filing system lock. This is the only way to obtain a duplicate of a lock... simply copying is not allowed.

Another lock to the same object is then returned. It is not possible to create a copy of a exclusive lock.

See also

Lock | Lock a directory or file
UnLock | Unlock a directory or file
DupLockFromFH | Gets a lock on an open file
ParentOfFH | Returns a lock on the parent directory of a file


DupLockFromFH

Gets a lock on an open file

Declaration

Source position: amigados.pas line 1885

function DupLockFromFH(

  fh: LongInt

):LongInt;

Function result

Obtained lock or 0 for failure

Description

Obtain a lock on the object associated with fh. Only works if the file was opened using a non-exclusive mode. Other restrictions may be placed on success by the filesystem.

See also

DupLock | Duplicate a lock
Lock | Lock a directory or file
UnLock | Unlock a directory or file


EndNotify

Ends a notification request

Declaration

Source position: amigados.pas line 2221

procedure EndNotify(

  notify: PNotifyRequest

);

Arguments

notify

a structure passed to StartNotify()

Description

Removes a notification request. Safe to call even if StartNotify() failed. For NRF_SEND_MESSAGE, it searches your port for any messages about the object in question and removes and replies them before returning.

See also

StartNotify

Starts notification on a file or directory


ErrorReport

Displays a Retry/Cancel requester for an error

Declaration

Source position: amigados.pas line 1969

function ErrorReport(

  code: LongInt;

  type1: LongInt;

  arg1: Cardinal;

  device: PMsgPort

):LongBool;

Arguments

code | Error code to put a requester up for.
arg1 | Variable parameter (see type)
device | Optional handler task address (obsolete!)

Function result

Cancel/Retry indicator (0 means Retry)

Description

Based on the request type, this routine formats the appropriate requester to be displayed. If the code is not understood, it returns DOSTRUE immediately. Returns DOSTRUE if the user selects CANCEL or if the attempt to put up the requester fails, or if the process pr_WindowPtr is -1. Returns DOSFALSE if the user selects Retry. The routine will retry on DISKINSERTED for appropriate error codes. These return values are the opposite of what AutoRequest returns.

Note: this routine sets IoErr() to code before returning.

Error codes to put a requester up for. Current valid error codes are: ERROR_DISK_NOT_VALIDATED, ERROR_DISK_WRITE_PROTECTED, ERROR_DISK_FULL, ERROR_DEVICE_NOT_MOUNTED, ERROR_NOT_A_DOS_DISK, ERROR_NO_DISK, ABORT_DISK_ERROR, ABORT_BUSY

Valid Request types:

REPORT_LOCK
arg1 is a lock.
REPORT_VOLUME
arg1 is a volumenode.
REPORT_INSERT
arg1 is the string for the volumename

See also

Fault | Returns the text associated with a DOS error code
IoErr | Return extra information from the system


ExAll

Examine an entire directory

Declaration

Source position: amigados.pas line 1927

function ExAll(

  lock: LongInt;

  buffer: PExAllData;

  size: LongInt;

  data: LongInt;

  control: PExAllControl

):LongBool;

Arguments

lock | Lock on the directory to be examined
buffer | Buffer for the data that is returned (must be aligned) which is filled with (partial) TExAllData structures
size | Size of buffer
data | Type of the data to be returned
control | A control structure allocated by AllocDosObject()

Function result

An indicator of if ExAll() is done. If False is returned, either ExAll() has completed in which case IoErr() is ERROR_NO_MORE_ENTRIES or an error occurred. If a True is returned ExAll() must be called again until it returns False.

Description

Lock must be on a directory. Size is the size of the buffer supplied. The buffer will be filled with (partial) ExAllData structures, as specified by the type field.

ed_Type is a value from those shown below that determines which information is to be stored in the buffer. Each higher value adds a new thing to the list as described in the table below:

ED_NAME
FileName
ED_TYPE
Type
ED_SIZE
Size in bytes
ED_PROTECTION
Protection bits
ED_DATE
3 longwords of date
ED_COMMENT
Comment (will be nil if no comment)
ED_OWNER
Owner user-id and Group-id

Thus, ED_OWNER gives only filenames, and ED_OWNER gives everything.

The ed_Next entry gives a pointer to the next entry in the buffer. The last entry will have nil in ed_Next.

This is an incremental list meaning that if you specify ED_OWNER you will get all attributes!

Filesystems that support ExAll() must support at least up to ED_COMMENT. If a filesystem doesn't support a particular type, ERROR_BAD_NUMBER must be returned.

ed_Next
Pointer to the next entry in the buffer. The last entry has a nil value for ed_Next.
The control structure have the following fields.
eac_Entries
the number of entries in the buffer after a call to ExAll(). Make sure that your code handles the case when eac_Entries is 0 and ExAll() returns True.
eac_LastKey
Must be initialized to 0 before calling ExAll() for the first time.
eac_MatchString
If nil then information on all files will be returned. If non-nil it's interpreted as a pointer to a string used for pattern matching which files to return information on. This string must have been parsed by ParsePatternNoCase()!
ac_MatchFunc
to a hook that will be called to decide if an entry should be included in the buffer. If nil, no matching function will be called. The hook is called as follows

See also

ExAllEnd | Stop an ExAll()
AllocDosObject | Creates a dos object


ExAllEnd

Stop an ExAll()

Declaration

Source position: amigados.pas line 2274

procedure ExAllEnd(

  lock: LongInt;

  buffer: PExAllData;

  size: LongInt;

  data: LongInt;

  control: PExAllControl

);

Arguments

lock | Lock on directory to be examined.
buffer | Buffer for data returned (must be at least word-aligned, preferably long-word aligned).
size | Size in bytes of buffer.
data | Type of data to be returned.
control | Control data structure (see notes above). MUST have been allocated by AllocDosObject()!

Description

Stops an ExAll() on a directory before it hits ERROR_NO_MORE_ENTRIES. The full set of arguments that had been passed to ExAll() must be passed to ExAllEnd(), so it can handle filesystems that can't abort an ExAll() directly.

See also

ExAll | Examine an entire directory
AllocDosObject | Creates a dos object


Examine

Examine a directory or file associated with a lock

Declaration

Source position: amigados.pas line 1673

function Examine(

  lock: LongInt;

  fileInfoBlock: PFileInfoBlock

):LongBool;

Arguments

lock | Pointer to a Lock
fileInfoBlock | allocated File info Block

Description

Examine() fills in information in the TFileInfoBlock concerning the file or directory associated with the lock. This information includes the name, size, creation date and whether it is a file or directory. FileInfoBlock must be longword aligned. Examine() gives a return code of False if it fails.

You may make a local copy of the TFileInfoBlock, as long as it is never passed to ExNext().

So, follow these steps to examine a directory:

  1. Pass a Lock and a FileInfoBlock to Examine(). The lock must be on the directory you wish to examine.
  2. Pass ExNext() the same lock and TFileInfoBlock.
  3. Do something with the information returned in the TFileInfoBlock. Note that the fib_DirEntryType field is positive for directories, negative for files.
  4. Keep calling ExNext() until it returns False. Check IoErr() to ensure that the reason for failure was ERROR_NO_MORE_ENTRIES.

See also

Lock | Lock a directory or file
UnLock | Unlock a directory or file
ExNext | Examine the next entry in a directory
ExamineFH | Gets information on an open file
ExAll | Examine an entire directory

Example

program ExamineTest;
uses
  AmigaDos;
procedure CheckDir(ALock: BPTR);
var
  FIB: PFileInfoBlock;
begin
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) then
  begin
    if Examine(ALock, FIB) <> 0 then
    begin
      repeat
        writeln(FIB^.fib_FileName);
      until ExNext(ALock, FIB) = 0;
    end;
    if IOErr() = ERROR_NO_MORE_ENTRIES then
      writeln('nothing more found')
    else
      writeln('Something went wrong ', IOErr);
    FreeDosObject(DOS_FIB, FIB);
  end;
end;
var
  RAMLock: BPTR;
begin
  RAMLock := Lock('RAM:', SHARED_LOCK);
  CheckDir(RAMLock);
  unlock(RAMLock);
end.


Examine64

Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock.

Declaration

Source position: amigados.pas line 2304

function Examine64(

  Lock: LongInt;

  Fib: PFileInfoBlock;

  Tags: Pointer

):LongInt;

Arguments

Lock | lock to examine
Fib | file info to recieve the data
Tags | tags, no tags defined for now

Function result

= 0 for error, otherwise success

Description

Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock. FileInfoBlock.fib_Size64 contains the size of the file. FileInfoBlock.fib_NumBlocks64 contains the number of blocks for the file.

If scanning a filesystem tree recursively, you'll need to allocated a new PFileInfoBlock for each directory level.

To examine a directory, do the following:

  1. Pass a lock on the directory and a PFileInfoBlock (allocated by AllocDosObject()) to Examine64().
  2. Pass the same parameters to ExNext64()).
  3. Do something with the PFileInfoBlock returned.
  4. Call ExNext64() repeatedly until it returns FALSE and use the information you are provided. When ExNext64 returns False, check IoErr() to make sure that there was no real failure (ERROR_NO_MORE_ENTRIES).

See also

Examine64 | Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock.
AllocDosObject | Creates a dos object
ExAll | Examine an entire directory
IOErr | Return extra information from the system
ExamineFH64 | Fill in a FileInfoBlock structure concerning a file associated with a particular filehandle.

Example

program Examine64Test;
uses
  AmigaDos;
procedure CheckDir(ALock: BPTR);
var
  FIB: PFileInfoBlock;
begin
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) then
  begin
    if Examine64(ALock, FIB, nil) <> 0 then
    begin
      repeat
        writeln(FIB^.fib_FileName);
      until ExNext64(ALock, FIB, nil) = 0;
    end;
    if IOErr() = ERROR_NO_MORE_ENTRIES then
      writeln('nothing more found')
    else
      writeln('Something went wrong ', IOErr);
    FreeDosObject(DOS_FIB, FIB);
  end;
end;
var
  RamLock: BPTR;
begin
  RamLock := Lock('RAM:', SHARED_LOCK);
  CheckDir(RamLock);
  Unlock(RamLock);
end.


Examine64TagList

VarArgs version of Examine64

Declaration

Source position: amigados.pas line 2305

function Examine64TagList(

  Lock: LongInt;

  Fib: PFileInfoBlock;

  Tags: Pointer

):LongInt;


Examine64Tags

VarArgs Version of Examine64

Declaration

Source position: amigados.pas line 2349

function Examine64Tags(

  Lock: LongInt;

  Fib: PFileInfoBlock;

  const Tags: array of PtrUInt

):LongInt;


ExamineFH

Gets information on an open file

Declaration

Source position: amigados.pas line 1894

function ExamineFH(

  fh: LongInt;

  fib: PFileInfoBlock

):LongBool;

Arguments

fh | Filehandle you wish to examine
fib | FileInfoBlock, must be longword aligned.

Description

Examines a filehandle and returns information about the file in the FileInfoBlock. There are no guarantees as to whether the fib_Size field will reflect any changes made to the file size it was opened, though filesystems should attempt to provide up-to-date information for it.

Example

program ExamineFHTest;
uses
  AmigaDOS;
var
  FH: BPTR;
  FIB: PFileInfoBlock;
begin
  FH := DOSOpen('c:dir', MODE_OLDFILE);
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) and (FH <> 0) then
  begin
    if Boolean(ExamineFH(FH, FIB)) then
      writeln('Size: ',FIB^.fib_size);
  end;
  if Assigned(FIB) then FreeDosObject(DOS_FIB, FIB);
  if FH <> 0 then DOSClose(FH);
end.


ExamineFH64

Fill in a FileInfoBlock structure concerning a file associated with a particular filehandle.

Declaration

Source position: amigados.pas line 2308

function ExamineFH64(

  Fh: LongInt;

  Fib: PFileInfoBlock;

  Tags: Pointer

):LongInt;

Arguments

Fh | filehandle to examine
Fib | FileInfoBlock where the result of the examination is stored
Tags | tags, no tags defined for now

Function result

=0 fail, <> 0 success

Description

Fill in a FileInfoBlock structure where TFileHandle.fib_Size64 containing the size of the file. TFileHandle.fib_NumBlocks64 contains the number of blocks for the file.

See also

Examine64

Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock.

Example

program ExamineFH64Test;
uses
  AmigaDOS;
var
  FH: BPTR;
  FIB: PFileInfoBlock;
begin
  FH := DOSOpen('c:dir', MODE_OLDFILE);
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) and (FH <> 0) then
  begin
    if Boolean(ExamineFH64(FH, FIB, nil)) then
      writeln('Size: ', FIB^.fib_size64);
  end;
  if Assigned(FIB) then FreeDosObject(DOS_FIB, FIB);
  if FH <> 0 then DOSClose(FH);
end.


ExamineFH64TagList

VarArgs Version of ExamineFH64

Declaration

Source position: amigados.pas line 2309

function ExamineFH64TagList(

  Fh: LongInt;

  Fib: PFileInfoBlock;

  Tags: Pointer

):LongInt;


ExamineFH64Tags

VarArgs Version of ExamineFH64

Declaration

Source position: amigados.pas line 2351

function ExamineFH64Tags(

  Fh: LongInt;

  Fib: PFileInfoBlock;

  const Tags: array of PtrUInt

):LongInt;


Execute

Execute a CLI command

Declaration

Source position: amigados.pas line 1736

function Execute(

  string1: PChar;

  file1: LongInt;

  file2: LongInt

):LongBool;

Function result

Boolean indicating whether Execute was successful in finding and starting the specified program. Note this is not the return code of the command(s).

Description

This function attempts to execute the string commandString as a Shell command and arguments. The string can contain any valid input that you could type directly in a Shell, including input and output redirection using < and >. Note that Execute() doesn't return until the command(s) in commandstring have returned.

The input file handle will normally be zero, and in this case Execute() will perform whatever was requested in the commandString and then return. If the input file handle is nonzero then after the (possibly empty) commandString is performed subsequent input is read from the specified input file handle until end of that file is reached.

In most cases the output file handle must be provided, and is used by the Shell commands as their output stream unless output redirection was specified. If the output file handle is set to zero then the current window, normally specified as *, is used. Note that programs running under the Workbench do not normally have a current window.

Execute() may also be used to create a new interactive Shell process just like those created with the NewShell command. In order to do this you would call Execute() with an empty commandString, and pass a file handle relating to a new window as the input file handle. The output file handle would be set to zero. The Shell will read commands from the new window, and will use the same window for output. This new Shell window can only be terminated by using the EndCLI command.


ExNext

Examine the next entry in a directory

Declaration

Source position: amigados.pas line 1677

function ExNext(

  lock: LongInt;

  fileInfoBlock: PFileInfoBlock

):LongBool;

Arguments

lock | Pointer to a lock originally used for the Examine() call
fileInfoBlock | Pointer to a TFileInfoBlock used on the previous Examine() or ExNext() call.

Function result

=0 for fail, <> 0 for success

Description

This routine is passed a directory lock and a TFileInfoBlock that have been initialized by a previous call to Examine(), or updated by a previous call to ExNext(). ExNext() gives a return code of zero on failure. The most common cause of failure is reaching the end of the list of files in the owning directory. In this case, IoErr() will return ERROR_NO_MORE_ENTRIES and a good exit is appropriate.

So, follow these steps to examine a directory:

  1. Pass a Lock and a FileInfoBlock to Examine(). The lock must be on the directory you wish to examine.
  2. Pass ExNext() the same lock and TFileInfoBlock.
  3. Do something with the information returned in the TFileInfoBlock. Note that the fib_DirEntryType field is positive for directories, negative for files.
  4. Keep calling ExNext() until it returns False. Check IoErr() to ensure that the reason for failure was ERROR_NO_MORE_ENTRIES.

Attention

If you wish to recursively scan the file tree and you find another directory while ExNext()ing you must Lock that directory and Examine() it using a new FileInfoBlock. Use of the same FileInfoBlock to enter a directory would lose important state information such that it will be impossible to continue scanning the parent directory. While it is permissible to UnLock() and Lock() the parent directory between ExNext() calls, this is not recommended. Important state information is associated with the parent lock, so if it is freed between ExNext() calls this information has to be rebuilt on each new ExNext() call, and will significantly slow down directory scanning.

It is not legal to Examine() a file, and then to ExNext() from that TFileInfoBlock. You may make a local copy of the TFileInfoBlock, as long as it is never passed back to the operating system.

See also

Examine | Examine a directory or file associated with a lock
Lock | Lock a directory or file
UnLock | Unlock a directory or file
IoErr | Return extra information from the system
ExamineFH | Gets information on an open file
AllocDosObject | Creates a dos object
ExAll | Examine an entire directory

Example

program ExamineTest;
uses
  AmigaDos;
procedure CheckDir(ALock: BPTR);
var
  FIB: PFileInfoBlock;
begin
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) then
  begin
    if Examine(ALock, FIB) <> 0 then
    begin
      repeat
        writeln(FIB^.fib_FileName);
      until ExNext(ALock, FIB) = 0;
    end;
    if IOErr() = ERROR_NO_MORE_ENTRIES then
      writeln('nothing more found')
    else
      writeln('Something went wrong ', IOErr);
    FreeDosObject(DOS_FIB, FIB);
  end;
end;
var
  RAMLock: BPTR;
begin
  RAMLock := Lock('RAM:', SHARED_LOCK);
  CheckDir(RAMLock);
  unlock(RAMLock);
end.


ExNext64

Examine the next entry in a directory.

Declaration

Source position: amigados.pas line 2306

function ExNext64(

  Lock: LongInt;

  Fib: PFileInfoBlock;

  Tags: Pointer

):LongInt;

Arguments

Lock | lock on the direcory the contents of which to examine
Fib | A FileInfoBlock previously initialized by Examine64() (or used before with ExNext64()), fib_Size64 contains the size of the file. fib_NumBlocks64 contains the number of blocks for the file.
Tags | tags, no tags defined for now, supply nil

Function result

= 0 for fail, <> 0 for success whether the operation was successful or not. A failure occurs also if there is no "next" entry in the directory. Then IoErr() equals ERROR_NO_MORE_ENTRIES.

Description

If scanning a filesystem tree recursively, you'll need to allocated a new PFileInfoBlock for each directory level.

To examine a directory, do the following:

  1. Pass a lock on the directory and a PFileInfoBlock (allocated by AllocDosObject()) to Examine64().
  2. Pass the same parameters to ExNext64()).
  3. Do something with the PFileInfoBlock returned.
  4. Call ExNext64() repeatedly until it returns FALSE and use the information you are provided. When ExNext64 returns False, check IoErr() to make sure that there was no real failure (ERROR_NO_MORE_ENTRIES).

See also

Examine64 | Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock.
AllocDosObject | Creates a dos object
ExAll | Examine an entire directory
IOErr | Return extra information from the system

Example

program Examine64Test;
uses
  AmigaDos;
procedure CheckDir(ALock: BPTR);
var
  FIB: PFileInfoBlock;
begin
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) then
  begin
    if Examine64(ALock, FIB, nil) <> 0 then
    begin
      repeat
        writeln(FIB^.fib_FileName);
      until ExNext64(ALock, FIB, nil) = 0;
    end;
    if IOErr() = ERROR_NO_MORE_ENTRIES then
      writeln('nothing more found')
    else
      writeln('Something went wrong ', IOErr);
    FreeDosObject(DOS_FIB, FIB);
  end;
end;
var
  RamLock: BPTR;
begin
  RamLock := Lock('RAM:', SHARED_LOCK);
  CheckDir(RamLock);
  Unlock(RamLock);
end.


ExNext64TagList

VarArgs Version of ExNext64

Declaration

Source position: amigados.pas line 2307

function ExNext64TagList(

  Lock: LongInt;

  Fib: PFileInfoBlock;

  Tags: Pointer

):LongInt;


ExNext64Tags

VarArgs Version of ExNext64

Declaration

Source position: amigados.pas line 2350

function ExNext64Tags(

  Lock: LongInt;

  Fib: PFileInfoBlock;

  const Tags: array of PtrUInt

):LongInt;


Fault

Returns the text associated with a DOS error code

Declaration

Source position: amigados.pas line 1959

function Fault(

  code: LongInt;

  header: PChar;

  buffer: PChar;

  len: LongInt

):LongBool;

Arguments

code | Error code
header | Header to output before error text
buffer | Buffer to receive error message
len | Length of buffer

Function result

Number of characters put into buffer (may be 0)

Description

This routine obtains the error message text for the given error code. The header is prepended to the text of the error message, followed by a colon. Puts a null-terminated string for the error message into the buffer. By convention, error messages should be no longer than 80 characters (+1 for termination), and preferably no more than 60. The value returned by IoErr() is set to the code passed in. If there is no message for the error code, the message will be "Error code number".

The number of characters put into the buffer is returned, which will be 0 if the code passed in was 0.

See also

IoErr | Return extra information from the system
SetIoErr | Sets the value returned by IoErr()
PrintFault | Returns the text associated with a DOS error code


FAULT_MAX

Max Length for error string

Declaration

Source position: amigados.pas line 143

const FAULT_MAX = 82;

Description

Standard maximum length for an error string from fault. However, most error strings should be kept under 60 characters if possible. Don't forget space for the header you pass in.


FGetC

Read a character from the specified input (buffered)

Declaration

Source position: amigados.pas line 1834

function FGetC(

  fh: LongInt

):LongInt;

Function result

character read (0-255) or -1

Description

Reads the next character from the input stream. A -1 is returned when EOF or an error is encountered. This call is buffered. Use DosFlush() between buffered and unbuffered I/O on a filehandle.

See also

FPutC | Write a character to the specified output
UnGetC | Makes a char available for reading again. (buffered)
DosFlush | Flushes buffers for a buffered filehandle


FGets

Reads a line from the specified input (buffered)

Declaration

Source position: amigados.pas line 1857

function FGets(

  fh: LongInt;

  buf: PChar;

  buflen: Cardinal

):PChar;

Arguments

fh | filehandle to use for buffered I/O
buf | Area to read bytes into.
buflen | Number of bytes to read, must be > 0.

Function result

Pointer to buffer passed in, or nil for immediate EOF or for an error. If nil is returnd for an EOF, IoErr() will return 0.

Description

This routine reads in a single line from the specified input stopping at a NEWLINE character or EOF. In either event, UP TO the number of len specified bytes minus 1 will be copied into the buffer. Hence if a length of 50 is passed and the input line is longer than 49 bytes, it will return 49 characters. It returns the buffer pointer normally, or NULL if EOF is the first thing read.

If terminated by a newline, the newline WILL be the last character in the buffer. This is a buffered read routine. The string read in IS null-terminated.

See also

FRead | Reads a number of blocks from an input (buffered)
FPuts | Writes a string the the specified output
FGetC | Read a character from the specified input (buffered)


FilePart

Returns the last component of a path

Declaration

Source position: amigados.pas line 2207

function FilePart(

  path: PChar

):PChar;

Arguments

path

pointer to an path string. May be relative to the current directory or the current disk.

Function result

pointer to the last component of the path.

Description

This function returns a pointer to the last component of a string path specification, which will normally be the file name. If there is only one component, it returns a pointer to the beginning of the string.

See also

PathPart | Returns a pointer to the end of the next-to-last component of a path.
AddPart | Appends a file/dir to the end of a path


FindArg

Find a keyword in a template

Declaration

Source position: amigados.pas line 2172

function FindArg(

  keyword: PChar;

  arg_template: PChar

):LongInt;

Arguments

keyword

Keyword to search for in template

Function result

Number of entry in template, or -1 if not found

Description

Returns the argument number of the keyword, or -1 if it is not a keyword for the template. Abbreviations are handled.

See also

ReadArgs | Read bytes of data from a file
ReadItem | Reads a single argument/name from command line
FreeArgs | Free allocated memory after ReadArgs()


FindCliProc

Returns a pointer to the requested CLI process

Declaration

Source position: amigados.pas line 2008

function FindCliProc(

  num: Cardinal

):PProcess;

Arguments

num

Task number of CLI process (range 1-N)

Function result

Pointer to given CLI process

Description

This routine returns a pointer to the CLI process associated with the given CLI number. If the process isn't an active CLI process, nil is returned. NOTE: should normally be called inside a Forbid(), if you must use this function at all.

See also

Cli | Returns a pointer to the CLI structure of the process
MaxCli | Returns the highest CLI process number possibly in use
exec.Forbid | Forbid task scheduling.


FindDosEntry

Finds a specific Dos List entry

Declaration

Source position: amigados.pas line 2091

function FindDosEntry(

  dlist: PDOSList;

  name: PChar;

  flags: Cardinal

):PDOSList;

Arguments

dlist | The device entry to start with.
name | Name of device entry (without ':') to locate.
flags | Search control flags. Use the flags you passed to LockDosList, or a subset of them. LDF_READ/LDF_WRITE are not required for this call.

Function result

The device entry or nil

Description

Locates an entry on the device list. Starts with the entry dlist. NOTE: must be called with the device list locked, no references may be made to dlist after unlocking.

See also

AddDosEntry | Add a Dos List entry to the lists
RemDosEntry | Removes a Dos List entry from it's list
NextDosEntry | Get the next Dos List entry
LockDosList | Locks the specified Dos Lists for use
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry


FindSegment

Finds a segment on the resident list

Declaration

Source position: amigados.pas line 2156

function FindSegment(

  name: PChar;

  seg: PSegment;

  system: LongInt

):PSegment;

Arguments

name | Name of Segment to find
seg | Segment to start the search after
system | True for system segment. False for normal segments

Function result

The Segment found or nil

Description

Finds a segment on the Dos resident list by name and type, starting at the segment after 'start', or at the beginning if start is nil. If system is zero, it will only return nodes with a seg_UC of 0 or more. It does not increment the seg_UC, and it does not do any locking of the list. You must Forbid() lock the list to use this call.

To use an entry you have found, you must: if the seg_UC is 0 or more, increment it, and decrement it (under Forbid()!) when you're done the the seglist.

The other values for seg_UC are:

-1
system module, such as a filesystem or shell
-2
resident shell command
-999
disabled internal command, ignore

Negative values should never be modified. All other negative values between 0 and -32767 are reserved to AmigaDos and should not be used.

See also

AddSegment | Adds a resident segment to the resident list
RemSegment | Removes a resident segment from the resident list
exec.Forbid | Forbid task scheduling.


FindSegmentTagList

Search for a resident segment by name and type.

Declaration

Source position: amigados.pas line 2288

function FindSegmentTagList(

  tags: Pointer

):PSegment;

Function result

Will return the segment structure if a match is found, otherwise will return nil.

Description

Search for a resident segment by name and type. FindSegmentTagList() will return the first segment that exactly matches the name and type.

You can continue searching by specifying the last returned segment as the seg argument.

Attention

FindSegmentTagList() does no locking of the segment list. You should lock yourself. FindSegmentTagList() also does not increment the value of the seg_UC field. If the value of seg_UC > 0, you must perform user counting in order to prevent the segment from being unloaded.

See also

AddSegment | Adds a resident segment to the resident list
FindSegment | Finds a segment on the resident list
RemSegment | Removes a resident segment from the resident list


FindVar

Finds a local variable

Declaration

Source position: amigados.pas line 2240

function FindVar(

  name: PChar;

  type1: Cardinal

):PLocalVar;

Arguments

name

pointer to an variable name. Note variable names follow filesystem syntax and semantics.

Description

Finds a local variable structure.

See also

DeleteVar | Deletes a local or environment variable
GetVar | Returns the value of a local or global variable
SetVar | Sets a local or environment variable


Format

Initialise a filesystem for use by the system.

Declaration

Source position: amigados.pas line 2110

function Format(

  filesystem: PChar;

  volumename: PChar;

  dostype: Cardinal

):LongBool;

Arguments

filesystem | Name of the device to format.
volumename | The name you wish the volume to be called.
dostype | The DOS type you wish on the disk.

Function result

<> 0 if the format was successful, 0 otherwise.

Description

This instructs a filesystem to write out the data that it uses to describe the device. The device should already have been formatted.


FORMAT_CDN

Declaration

Source position: amigados.pas line 318

const FORMAT_CDN = 3;


FORMAT_DEF

Declaration

Source position: amigados.pas line 320

const FORMAT_DEF = 4;


FORMAT_DOS

Declaration

Source position: amigados.pas line 315

const FORMAT_DOS = 0;


FORMAT_INT

Declaration

Source position: amigados.pas line 316

const FORMAT_INT = 1;


FORMAT_MAX

Declaration

Source position: amigados.pas line 319

const FORMAT_MAX = FORMAT_CDN;


FORMAT_USA

Declaration

Source position: amigados.pas line 317

const FORMAT_USA = 2;


FPutC

Write a character to the specified output

Declaration

Source position: amigados.pas line 1837

function FPutC(

  fh: LongInt;

  ch: LongInt

):LongInt;

Function result

Either the character written, or EOF for an error.

Description

Writes a single character to the output stream. This call is buffered. Use DosFlush() between buffered and unbuffered I/O on a filehandle. Interactive filehandles are flushed automatically on a newline, return, 0, or line feed.

See also

FGetC | Read a character from the specified input (buffered)
UnGetC | Makes a char available for reading again. (buffered)
DosFlush | Flushes buffers for a buffered filehandle


FPuts

Writes a string the the specified output

Declaration

Source position: amigados.pas line 1862

function FPuts(

  fh: LongInt;

  str: PChar

):LongInt;

Function result

0 normally, otherwise -1. Note that this is opposite of most other Dos functions, which return success.

Description

This routine writes an unformatted string to the filehandle. No newline is appended to the string. This routine is buffered.

See also

FGets | Reads a line from the specified input (buffered)
FPutC | Write a character to the specified output
FWrite | Writes a number of blocks to an output (buffered)
PutStr | Writes a string the the default output (buffered)


FRead

Reads a number of blocks from an input (buffered)

Declaration

Source position: amigados.pas line 1845

function FRead(

  fh: LongInt;

  block: Pointer;

  blocklen: Cardinal;

  number: Cardinal

):LongInt;

Arguments

fh | filehandle to use for buffered I/O
block | Area to read bytes into.
blocklen | number of bytes per block. Must be > 0.
number | number of blocks to read. Must be > 0.

Function result

Number of _blocks_ read, or 0 for EOF. On an error, the number of blocks actually read is returned.

Description

Attempts to read a number of blocks, each blocklen long, into the specified buffer from the input stream. May return less than the number of blocks requested, either due to EOF or read errors. This call is buffered.

See also

FGetC | Read a character from the specified input (buffered)
FWrite | Writes a number of blocks to an output (buffered)
FGets | Reads a line from the specified input (buffered)


FreeArgs

Free allocated memory after ReadArgs()

Declaration

Source position: amigados.pas line 2204

procedure FreeArgs(

  args: PRDArgs

);

Arguments

args

The data used by ReadArgs(). May be nil, in which case, FreeArgs() does nothing.

Description

FreeArgs() will clean up after a call to ReadArgs(). If the TRDArgs structure was allocated by the system in a call to ReadArgs(), then it will be freed. If however, you allocated the TRDArgs structure with AllocDosObject(), then you will have to free it yourself with FreeDosObject().

See also

ReadArgs | Read bytes of data from a file
ReadItem | Reads a single argument/name from command line
FindArg | Find a keyword in a template


FreeCLIData

Declaration

Source position: amigados.pas line 2313

procedure FreeCLIData(

  Data: PCLIData

);


FreeDeviceProc

Releases port returned by GetDeviceProc()

Declaration

Source position: amigados.pas line 2073

procedure FreeDeviceProc(

  dp: PDevProc

);

Arguments

dp

A value returned by GetDeviceProc()

Description

Frees up the structure created by GetDeviceProc(), and any associated temporary locks.

Decrements the counter incremented by GetDeviceProc(). The counter is in an extension to the 1.3 process structure. After calling FreeDeviceProc(), do not use the port or lock again! It is safe to call FreeDeviceProc(nil).

See also

GetDeviceProc | Finds a handler to send a message to
AssignLock | Creates an assignment to a locked object
AssignLate | Creates an assignment to a specified path later
AssignPath | Creates an assignment to a specified path


FreeDosEntry

Frees an entry created by MakeDosEntry

Declaration

Source position: amigados.pas line 2104

procedure FreeDosEntry(

  dlist: PDOSList

);

Arguments

dlist

DosList to free.

Description

This routine should be eliminated and replaced by a value passed to FreeDosObject()!


FreeDosObject

Frees an object allocated by AllocDosObject()

Declaration

Source position: amigados.pas line 1749

procedure FreeDosObject(

  type1: Cardinal;

  ptr: Pointer

);

Arguments

ptr

Pointer returned by AllocDosObject()

Description

Do not call for objects allocated in any other way.

See also

AllocDosObject | Creates a dos object
FreeVec | Free memory with tracked size made using AllocVec()


FWrite

Writes a number of blocks to an output (buffered)

Declaration

Source position: amigados.pas line 1851

function FWrite(

  fh: LongInt;

  block: Pointer;

  blocklen: Cardinal;

  number: Cardinal

):LongInt;

Arguments

fh | filehandle to use for buffered I/O
block | Area to write bytes from.
blocklen | Number of blocks to block. Must be > 0.

Function result

Number of _blocks_ written. On an error, the number of blocks actually written is returned.

Description

Attempts to write a number of blocks, each blocklen long, from the specified buffer to the output stream. May return less than the number of blocks requested, if there is some error such as a full disk or r/w error. This call is buffered.

See also

FPutC | Write a character to the specified output
FRead | Reads a number of blocks from an input (buffered)
FPuts | Writes a string the the specified output


GetArgStr

Returns the arguments for the process

Declaration

Source position: amigados.pas line 2002

function GetArgStr: PChar;

Function result

Pointer to arguments

Description

Returns a pointer to the (null-terminated) arguments for the program (process). This is the same string passed on startup from CLI.

See also

SetArgStr | Sets the arguments for the current process
RunCommand | Runs a program using the current process


GetConsoleTask

Returns the default console for the process

Declaration

Source position: amigados.pas line 1990

function GetConsoleTask: PMsgPort;

Description

Returns the default console task's port (pr_ConsoleTask) for the current process.

See also

SetConsoleTask | ets the default console for the process
DosOpen | Open a file for input or output


GetCurrentDirName

Returns the current directory name

Declaration

Source position: amigados.pas line 2017

function GetCurrentDirName(

  buf: PChar;

  len: LongInt

):LongBool;

Arguments

buf

Number of bytes of space in buffer

Function result

Buffer to hold extracted name

Description

Extracts the current directory name from the CLI structure and puts it into the buffer. If the buffer is too small, the name is truncated appropriately and a failure code returned. If no CLI structure is present, a null string is returned in the buffer, and failure from the call (with IoErr() = ERROR_OBJECT_WRONG_TYPE);

See also

SetCurrentDirName

Sets the directory name for the process


GetDeviceProc

Finds a handler to send a message to

Declaration

Source position: amigados.pas line 2069

function GetDeviceProc(

  name: PChar;

  dp: PDevProc

):PDevProc;

Arguments

name | name of the object you wish to access. This can be a relative path ('foo/bar'), relative to the current volume (':foo/bar'), or relative to a device/volume/assign ('foo:bar').
dp | A value returned by GetDeviceProc() before, or nil

Function result

a pointer to a DevProc structure or nil

Description

Finds the handler/filesystem to send packets regarding name to. This may involve getting temporary locks. It returns a structure that includes a lock and msgport to send to to attempt your operation. It also includes information on how to handle multiple-directory assigns (by passing the DevProc back to GetDeviceProc() until it returns nil).

The initial call to GetDeviceProc() should pass nil for devproc. If after using the returned DevProc, you get an ERROR_OBJECT_NOT_FOUND, and (TDevProc and DVPF_ASSIGN) is True, you should call GetDeviceProc() again, passing it the devproc structure. It will either return a modified devproc structure, or nil (with ERROR_NO_MORE_ENTRIES in IoErr()). Continue until it returns nil.

This call also increments the counter that locks a handler/fs into memory. After calling FreeDeviceProc(), do not use the port or lock again!

See also

FreeDeviceProc | Releases port returned by GetDeviceProc()
AssignLock | Creates an assignment to a locked object
AssignLate | Creates an assignment to a specified path later
AssignPath | Creates an assignment to a specified path


GetDosObjectAttr

Declaration

Source position: amigados.pas line 2303

function GetDosObjectAttr(

  Type_: LongWord;

  Ptr: Pointer;

  Tags: Pointer

):LongInt;


GetDosObjectAttrTagList

Declaration

Source position: amigados.pas line 2348

function GetDosObjectAttrTagList(

  Type_: LongWord;

  Ptr: Pointer;

  const Tags: array of PtrUInt

):LongInt;


GetFileSysAttr

Query filesystem for attributes, such as maximum filename length, or maximum file size.

Declaration

Source position: amigados.pas line 2300

function GetFileSysAttr(

  DeviceName: PChar;

  Attr: LongInt;

  Storage: Pointer;

  StorageSize: LongInt

):LongInt;

Arguments

DeviceName | name of the filesystem to get attributes from
Attr | attribute to get information about
Storage | storage to hold the result
StorageSize | size of the storage

Description

In case of a failure, IoErr() gives more information about the failure:

ERROR_ACTION_NOT_KNOWN
the packet is not supported
ERROR_BAD_NUMBER
the attribute is not known
ERROR_LINE_TOO_LONG
the result doesn't fit the provided StorageSize.


GetFileSysTask

Returns the default filesystem for the process

Declaration

Source position: amigados.pas line 1996

function GetFileSysTask: PMsgPort;

Function result

The pr_MsgPort of the filesystem, or nil.

Description

Returns the default filesystem task's port (pr_FileSystemTask) for the current process.

See also

SetFileSysTask | Sets the default filesystem for the process
DosOpen | Open a file for input or output


GetProgramDir

Returns a lock on the directory the program was loaded from

Declaration

Source position: amigados.pas line 2038

function GetProgramDir: LongInt;

Function result

A lock on the directory the current program was loaded from, or nil if loaded from resident list, etc.

Description

Returns a shared lock on the directory the program was loaded from. This can be used for a program to find data files, etc, that are stored with the program, or to find the program file itself. nil returns are valid, and may occur, for example, when running a program from the resident list. You should not unlock the lock.

See also

SetFileSysTask | Sets the default filesystem for the process
DosOpen | Open a file for input or output


GetProgramName

Returns the current program name

Declaration

Source position: amigados.pas line 2024

function GetProgramName(

  buf: PChar;

  len: LongInt

):LongBool;

Arguments

buf | Buffer to hold extracted name
len | Number of bytes of space in buffer

Description

Extracts the program name from the CLI structure and puts it into the buffer. If the buffer is too small, the name is truncated. If no CLI structure is present, a null string is returned in the buffer, and failure from the call (with IoErr() = ERROR_OBJECT_WRONG_TYPE);

See also

SetProgramName

Sets the name of the program being run


GetPrompt

Returns the prompt for the current process

Declaration

Source position: amigados.pas line 2031

function GetPrompt(

  buf: PChar;

  len: LongInt

):LongBool;

Arguments

buf | Buffer to hold extracted prompt
len | Number of bytes of space in buffer

Description

Extracts the prompt string from the CLI structure and puts it into the buffer. If the buffer is too small, the string is truncated appropriately and a failure code returned. If no CLI structure is present, a null string is returned in the buffer, and failure from the call (with IoErr() = ERROR_OBJECT_WRONG_TYPE);

See also

SetPrompt

Sets the CLI/shell prompt for the current process


GetSegListAttr

Query seglist for attributes, such as the ObjData ptr.

Declaration

Source position: amigados.pas line 2301

function GetSegListAttr(

  SegList: LongInt;

  Attr: LongInt;

  Storage: Pointer;

  StorageSize: LongInt

):LongInt;

Arguments

SegList | SegList BPTR
Attr | attribute to get information about
Storage | storage to hold the result
StorageSize | size of the storage

Function result

Success/failure indication

Description

In case of a failure, IoErr() gives more information about the failure:

ERROR_ACTION_NOT_KNOWN
the packet is not supported
ERROR_BAD_NUMBER
the attribute is not known
ERROR_LINE_TOO_LONG
the result doesn't fit the provided StorageSize.


GetSegListAttrTagList

VarArgs Version of GetSegListAttr

Declaration

Source position: amigados.pas line 2315

function GetSegListAttrTagList(

  SegList: LongInt;

  Attr: LongInt;

  Storage: Pointer;

  StorageSize: LongInt;

  Tags: Pointer

):LongInt;


GetSegListAttrTags

VarArgs Version of GetSegListAttrTagList

Declaration

Source position: amigados.pas line 2354

function GetSegListAttrTags(

  SegList: LongInt;

  Attr: LongInt;

  Storage: Pointer;

  StorageSize: LongInt;

  const Tags: array of PtrUInt

):LongInt;


GetVar

Returns the value of a local or global variable

Declaration

Source position: amigados.pas line 2230

function GetVar(

  name: PChar;

  buffer: PChar;

  size: LongInt;

  flags: LongInt

):LongInt;

Arguments

name | Pointer to a variable name.
buffer | A user allocated area which will be used to store the value associated with the variable.
size | Length of the buffer region in bytes.
flags | combination of type of var to get value of (low 8 bits), and flags to control the behavior of this routine.

Function result

Size of environment variable. -1 indicates that the variable was not defined.

Description

Gets the value of a local or environment variable. It is advised to only use ASCII strings inside variables, but not required. This stops putting characters into the destination when a n is hit, unless GVF_BINARY_VAR is specified. (The n is not stored in the buffer.)

Currently defined flags include:

GVF_GLOBAL_ONLY
tries to get a global env variable.
GVF_LOCAL_ONLY
tries to get a local variable.
GVF_BINARY_VAR
don't stop at n
GVF_DONT_NULL_TERM
no null termination (only valid for binary variables).

The default is to try to get a local variable first, then to try to get a global environment variable.

See also

SetVar | Sets a local or environment variable
DeleteVar | Deletes a local or environment variable
FindVar | Finds a local variable


Info

Returns information about the disk

Declaration

Source position: amigados.pas line 1681

function Info(

  lock: LongInt;

  parameterBlock: PInfoData

):LongBool;

Arguments

lock | A lock on any file on the volume for which information should be supplied, or 0
parameterBlock | pointer to the info

Description

Info() can be used to find information about any disk in use. lock refers to the disk, or any file on the disk. The parameter block is returned with information about the size of the disk, number of free blocks and any soft errors.


Inhibit

Inhibits access to a filesystem

Declaration

Source position: amigados.pas line 2119

function Inhibit(

  name: PChar;

  onoff: LongInt

):LongBool;

Arguments

name | Name of device to inhibit (with ':')
onoff | New status. DOSTRUE = inhibited, DOSFALSE = uninhibited

Description

Sends an ACTION_INHIBIT packet to the indicated handler. This stops all activity by the handler until uninhibited. When uninhibited, anything may have happened to the disk in the drive, or there may no longer be one.


InternalLoadSeg

Low-level load routine

Declaration

Source position: amigados.pas line 2137

function InternalLoadSeg(

  fh: LongInt;

  table: LongInt;

  var funcarray: LongInt;

  var stack: LongInt

):LongInt;

Arguments

fh | Filehandle to load from
table | ignored
funcarray | array of functions to be used for read, seek, alloc and free
stack | pointer to storage for stacksize. (currently ignored)

Function result

Pointer to loaded Seglist or nil in case of failure.

Description

Loads from fh. Functionarray is a pointer to an array of functions.

This function really only tries to load the different file formats aos, elf and aout.

FuncTable[0]
bytes = ReadFunc(readhandle, buffer, length), DOSBase
FuncTable[1]
Memory = AllocFunc(size,flags), ExecBase
FuncTable[2]
FreeFunc(memory, size), ExecBase
FuncTable[3] -
pos = SeekFunc(readhandle, pos, mode), DOSBase

See also

LoadSeg | Scatterload a loadable file into memory
UnLoadSeg | Unload a seglist previously loaded by LoadSeg()
NewLoadSeg | Improved version of LoadSeg for stacksizes


IoErr

Return extra information from the system

Declaration

Source position: amigados.pas line 1691

function IoErr: LongInt;

Description

Most I/O routines return zero to indicate an error. When this happens (or whatever the defined error return for the routine) this routine may be called to determine more information. It is also used in some routines to pass back a secondary result.

Note: there is no guarantee as to the value returned from IoErr() after a successful operation, unless to specified by the routine.

See also

Fault | Returns the text associated with a DOS error code
PrintFault | Returns the text associated with a DOS error code
SetIoErr | Sets the value returned by IoErr()


IsFileSystem

Returns whether a Dos handler is a filesystem

Declaration

Source position: amigados.pas line 2107

function IsFileSystem(

  name: PChar

):LongBool;

Arguments

name

Name of device in question, with trailing ':'.

Function result

Flag to indicate if device is a file system

Description

Returns whether the device is a filesystem or not. A filesystem supports seperate files storing information. It may also support sub-directories, but is not required to. If the filesystem doesn't support this new packet, IsFileSystem() will use Lock(":",...) as an indicator.

DF0:, HD0:, ... are filesystems. CON:, PIPE:, AUX:, ... are not. In AmigaOS if devicename contains no ':' then result is always True. Also volume and assign names return True.

See also

Lock

Lock a directory or file


IsInteractive

Discover whether a file is "interactive"

Declaration

Source position: amigados.pas line 1733

function IsInteractive(

  file1: LongInt

):LongBool;

Description

The return value status indicates whether the file associated with the file handle file is connected to a virtual terminal like a console or shell window.


LoadSeg

Scatterload a loadable file into memory

Declaration

Source position: amigados.pas line 1703

function LoadSeg(

  name: PChar

):LongInt;

Arguments

name

Name of the file to load

Function result

Pointer to the seglist

Description

The file name should be a load module produced by the linker. LoadSeg() scatterloads the CODE, DATA and BSS segments into memory, chaining together the segments with BPTR's on their first words. The end of the chain is indicated by a zero. There can be any number of segments in a file. All necessary relocation is handled by LoadSeg().

In the event of an error any blocks loaded will be unloaded and a NULL result returned.

If the module is correctly loaded then the output will be a pointer at the beginning of the list of blocks. Loaded code is unloaded via a call to UnLoadSeg().

See also

UnLoadSeg | Unload a seglist previously loaded by LoadSeg()
InternalLoadSeg | Low-level load routine
CreateProc | Create a new process
CreateNewProc | Create a new process from taglist
NewLoadSeg | Improved version of LoadSeg for stacksizes


Lock

Lock a directory or file

Declaration

Source position: amigados.pas line 1663

function Lock(

  lname: PChar;

  accessMode: LongInt

):LongInt;

Arguments

accessMode

ON of SHARED_LOCK or EXCLUSIVE_LOCK

Function result

Pointer to lock or nil

Description

Gets a lock on a file or directory. There may be more than one shared lock on a file but only one if it is an exclusive one. Locked files or directories may not be deleted.

See also

UnLock | Unlock a directory or file
DupLock | Duplicate a lock
ChangeMode | Change the current mode of a lock or filehandle
NameFromLock | Returns the name of a locked object
DupLockFromFH | Gets a lock on an open file


LOCK_DIFFERENT

Value returned by SameLock

Declaration

Source position: amigados.pas line 254

const LOCK_DIFFERENT = - 1;


LOCK_SAME

Value returned by SameLock

Declaration

Source position: amigados.pas line 255

const LOCK_SAME = 0;


LOCK_SAME_HANDLER

Value returned by SameLock

Declaration

Source position: amigados.pas line 257

const LOCK_SAME_HANDLER = LOCK_SAME_VOLUME;


LOCK_SAME_VOLUME

Declaration

Source position: amigados.pas line 256

const LOCK_SAME_VOLUME = 1;


LockDosList

Locks the specified Dos Lists for use

Declaration

Source position: amigados.pas line 2076

function LockDosList(

  flags: Cardinal

):PDOSList;

Arguments

flags

what lists to lock

Function result

Handle to the dos list. This is not a direct pointer to the first list element but to a pseudo element instead.

Description

Waits until the desired dos lists are free then gets a lock on them. A handle is returned that can be used for FindDosEntry(). Calls to this function nest, i.e. you must call UnLockDosList() as often as you called LockDosList(). Always lock all lists at once - do not try to get a lock on one of them then on another.

See also

AttemptLockDosList | Attempt to lock the Dos Lists for use
UnLockDosList | Unlocks the Dos List
exec.Forbid | Forbid task scheduling.
NextDosEntry | Get the next Dos List entry


LockRecord

Locks a portion of a file

Declaration

Source position: amigados.pas line 1809

function LockRecord(

  fh: LongInt;

  offset: Cardinal;

  length: Cardinal;

  mode: Cardinal;

  timeout: Cardinal

):LongBool;

Arguments

fh | File handle for the file to lock a record of
offset | Starting position of the lock
length | Length of the record in bytes
mode | Lock type (REC_*) For the IMMED modes, the timeout is ignored.
timeout | imeout interval in ticks (1/50 seconds). 0 is legal.

Description

Lock a portion of a file for exclusive access. A timeout may be specified which is the maximum amount of time to wait for the record to be available.

See also

LockRecords | Lock a series of records
UnLockRecord | Unlock a record
UnLockRecords | Unlock a list of records


LockRecord64

Lock a portion of a file for exclusive access.

Declaration

Source position: amigados.pas line 2295

function LockRecord64(

  fh: LongInt;

  Offset: QWord;

  Length: QWord;

  Mode: LongWord;

  TimeOut: LongWord

):LongInt;

Arguments

fh | file handle for the file to lock a record of
Offset | starting position of the lock
Length | length of the record in bytes
Mode | lock type
TimeOut | timeout interval measured in ticks (may be 0)

Description

A timeout may be specified which is the maximum amount of time to wait for the record to be available.

Record locks are cooperative, meaning that they only affect other calls to LockRecord().

See also

LockRecords64 | Lock several records at the same time.
UnLockRecord64 | Release a lock made with LockRecord64().


LockRecords

Lock a series of records

Declaration

Source position: amigados.pas line 1816

function LockRecords(

  recArray: PRecordLock;

  timeout: Cardinal

):LongBool;

Arguments

recArray | Array of records to lock
timeout | maximum number of ticks to wait for a lock to be ready (1/50 seconds)

Function result

Success/failure indication. In case of a success, all the record locks are locked. In case of failure, no record locks are locked.

Description

Lock several records at the same time. The timeout specified is applied to each lock to attempt. The array of RecordLock:s is terminated with an entry where rec_FH is equal to nil. A set of records should always be locked in the same order so as to reduce possiblities of deadlock.

See also

UnLockRecords

Unlock a list of records


LockRecords64

Lock several records at the same time.

Declaration

Source position: amigados.pas line 2296

function LockRecords64(

  RecArray: TRecordLock64;

  TimeOut: LongWord

):LongInt;

Arguments

RecArray | array of records to lock
TimeOut | maximum number of ticks to wait for a lock to be ready

Description

The timeout specified is applied to each lock to attempt. The array of RecordLock:s is terminated with an entry where rec_FH is equal to nil.

A set of records should always be locked in the same order so as to reduce possiblities of deadlock.

See also

UnLockRecords64

Release an array of record locks obtained with LockRecords64().


MakeDosEntry

Creates a DosList structure

Declaration

Source position: amigados.pas line 2100

function MakeDosEntry(

  name: PChar;

  type1: LongInt

):PDOSList;

Arguments

name

Name for the device/volume/assign node.

Function result

New device entry or nil

Description

Create a DosList structure, including allocating a name and correctly null-terminating the BSTR. It also sets the dol_Type field, and sets all other fields to 0. This routine should be eliminated and replaced by a value passed to AllocDosObject()!

See also

AllocDosObject | Creates a dos object
RemDosEntry | Removes a Dos List entry from it's list
FindDosEntry | Finds a specific Dos List entry
LockDosList | Locks the specified Dos Lists for use
NextDosEntry | Get the next Dos List entry
FreeDosEntry | Frees an entry created by MakeDosEntry


MakeLink

Creates a filesystem link

Declaration

Source position: amigados.pas line 1941

function MakeLink(

  name: PChar;

  dest: LongInt;

  soft: LongInt

):LongBool;

Arguments

name | The name of the link to create
dest | If soft is True this must be a filename; if it is False a lock pointing to the file to be hard-linked must be provided
soft | True, if a soft link is to be created, False for a hard link

Function result

DOSTRUE or DOSFALSE. On error, IoErr() will contain more information.

Description

MakeLink() will create a link between two files or directories. A link is a filesystem object that refers to another file.

A soft link refers to another file or directory by name, and is resolved by the filesystem and the caller. Soft links are not restricted to the same volume and the target does not have to exist.

A hard link refers to another file by the location on a disk, and is resolved by the filesystem. Hard links are restricted to files or directories on the same volume.


MatchEnd

Free storage allocated for MatchFirst()/MatchNext()

Declaration

Source position: amigados.pas line 2192

procedure MatchEnd(

  anchor: PAnchorPath

);

Description

Return all storage associated with a given search.

See also

MatchFirst | Finds file that matches pattern
ParsePattern | Create a tokenized string for MatchPattern()
Examine | Examine a directory or file associated with a lock
CurrentDir | Make a directory lock the current directory
MatchNext | Finds the next file or directory that matches pattern
ExNext | Examine the next entry in a directory


MatchFirst

Finds file that matches pattern

Declaration

Source position: amigados.pas line 2185

function MatchFirst(

  pat: PChar;

  anchor: PAnchorPath

):LongInt;

Arguments

pat

Pattern to search for

Function result

0 for success or error code.

Description

Locates the first file or directory that matches a given pattern. MatchFirst() is passed your pattern (you do not pass it through ParsePattern() - MatchFirst() does that for you), and the control structure. MatchFirst() normally initializes your AnchorPath structure for you, and returns the first file that matched your pattern, or an error. Note that MatchFirst()/ MatchNext() are unusual for Dos in that they return 0 for success, or the error code, instead of the application getting the error code from IoErr().

When looking at the result of MatchFirst()/ MatchNext(), the ap_Info field of your TAnchorPath has the results of an Examine() of the object. You normally get the name of the object from fib_FileName, and the directory it's in from ap_Current.an_Lock. To access this object, normally you would temporarily CurrentDir() to the lock, do an action to the file/dir, and then CurrentDir() back to your original directory. This makes certain you affect the right object even when two volumes of the same name are in the system. You can use ap_Buf (with ap_StrLen) to get a name to report to the user.

To initialize the TAnchorPath structure (particularily when reusing it), set ap_BreakBits to the signal bits (CDEF) that you want to take a break on, or nil, if you don't want to convenience the user. ap_Flags should be set to any flags you need or all 0's otherwise. ap_FoundBreak should be cleared if you'll be using breaks.

If you want to have the FULL PATH NAME of the files you found, allocate a buffer at the END of this structure, and put the size of it into ap_StrLen. If you don't want the full path name, make sure you set ap_StrLen to zero. In this case, the name of the file, and stats are available in the ap_Info, as per usual.

Then call MatchFirst() and then afterwards, MatchNext() with this structure. You should check the return value each time (see below) and take the appropriate action, ultimately calling MatchEnd() when there are no more files or you are done. You can tell when you are done by checking for the normal AmigaDOS return code ERROR_NO_MORE_ENTRIES.

Note: patterns with trailing slashes may cause MatchFirst()/ MatchNext() to return with an ap_Current.an_Lock on the object, and a filename of the empty string ('').

See ParsePattern() for more information on the patterns.

See also

MatchNext | Finds the next file or directory that matches pattern
ParsePattern | Create a tokenized string for MatchPattern()
Examine | Examine a directory or file associated with a lock
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()
ExNext | Examine the next entry in a directory

Example

program MatchTest;
uses
  amigados;
procedure FindIcons(Pattern: AnsiString);
var
  Anchor: TAnchorPath;
begin
  if MatchFirst(PChar(Pattern), @Anchor) = 0 then
  begin
    repeat
      writeln(Anchor.ap_Info.fib_Filename);
    until MatchNext(@Anchor) <> 0;
    MatchEnd(@Anchor);
  end;
end;
begin
  FindIcons('sys:#?.info');
end.


MatchNext

Finds the next file or directory that matches pattern

Declaration

Source position: amigados.pas line 2189

function MatchNext(

  anchor: PAnchorPath

):LongInt;

Function result

0 for success or error code.

Description

Locates the next file or directory that matches a given pattern. Various bits in the flags (APF_*) allow the application to control the operation of MatchNext().

See also

MatchFirst | Finds file that matches pattern
ParsePattern | Create a tokenized string for MatchPattern()
Examine | Examine a directory or file associated with a lock
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()
ExNext | Examine the next entry in a directory


MatchPattern

Checks for a pattern match with a string

Declaration

Source position: amigados.pas line 2200

function MatchPattern(

  pat: PChar;

  str: PChar

):LongBool;

Arguments

pat | Special pattern string to match as returned by ParsePattern()
str | String to match against given pattern

Function result

Success or failure of pattern match. On failure, IoErr() will return 0 or ERROR_TOO_MANY_LEVELS

Description

The pattern must be a tokenized string output by ParsePattern(). This routine is case-sensitive.

NOTE: this routine is highly recursive. You must have at least 1500 free bytes of stack to call this (it will cut off it's recursion before going any deeper than that and return failure). That's currently enough for about 100 levels deep of #, (, ~, etc.

See also

ParsePattern | Create a tokenized string for MatchPattern()
MatchPatternNoCase | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern


MatchPatternNoCase

Checks for a pattern match with a string

Declaration

Source position: amigados.pas line 2266

function MatchPatternNoCase(

  pat: PChar;

  str: PChar

):LongBool;

Arguments

pat | Special pattern string to match as returned by ParsePattern()
str | String to match against given pattern

Function result

Success or failure of pattern match. On failure, IoErr() will return 0 or ERROR_TOO_MANY_LEVELS

Description

The pattern must be a tokenized string output by ParsePattern(). This routine is case-insensitive.

NOTE: this routine is highly recursive. You must have at least 1500 free bytes of stack to call this (it will cut off it's recursion before going any deeper than that and return failure). That's currently enough for about 100 levels deep of #, (, ~, etc.

See also

ParsePattern | Create a tokenized string for MatchPattern()
MatchPattern | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern


MaxCli

Returns the highest CLI process number possibly in use

Declaration

Source position: amigados.pas line 2011

function MaxCli: Cardinal;

Function result

The highest CLI number that may be in use.

Description

Returns the highest CLI number that may be in use. CLI numbers are reused, and are usually as small as possible. To find all CLIs, scan using FindCliProc() from 1 to MaxCLI(). The number returned by MaxCli() may change as processes are created and destroyed.

See also

FindCliProc | Returns a pointer to the requested CLI process
Cli | Returns a pointer to the CLI structure of the process


MKBADDR

Conbert a Pointer to a BPTR Value

Declaration

Source position: amigados.pas line 2323

function MKBADDR(

  x: Pointer

):LongInt;


NameFromFH

Get the name of an open filehandle

Declaration

Source position: amigados.pas line 1907

function NameFromFH(

  fh: LongInt;

  buffer: PChar;

  len: LongInt

):LongBool;

Arguments

fh | Lock of object to be examined.
buffer | Buffer to store name.

Description

Returns a fully qualified path for the filehandle. This routine is guaranteed not to write more than len characters into the buffer. The name will be null-terminated. See NameFromLock() for more information.

Note: Older filesystems that don't support ExamineFH() will cause NameFromFH().

See also

NameFromLock | Returns the name of a locked object
ExamineFH | Gets information on an open file


NameFromLock

Returns the name of a locked object

Declaration

Source position: amigados.pas line 1902

function NameFromLock(

  lock: LongInt;

  buffer: PChar;

  len: LongInt

):LongBool;

Arguments

lock | Lock of object to be examined.
buffer | Buffer to store name.

Description

Returns a fully qualified path for the lock. This routine is guaranteed not to write more than len characters into the buffer. The name will be null-terminated.

NOTE: if the volume is not mounted, the system will request it (unless of course you set pr_WindowPtr to -1). If the volume is not mounted or inserted, it will return an error. If the lock passed in is nil, 'SYS:' will be returned. If the buffer is too short, an error will be returned, and IoErr() will return ERROR_LINE_TOO_LONG.

See also

NameFromFH | Get the name of an open filehandle
Lock | Lock a directory or file


NewLoadSeg

Improved version of LoadSeg for stacksizes

Declaration

Source position: amigados.pas line 2143

function NewLoadSeg(

  file1: PChar;

  tags: Pointer

):LongInt;

Arguments

tags

Pointer to tagitem array

Function result

Seglist loaded, or nil

Description

Does a LoadSeg on a file, and takes additional actions based on the tags supplied.

Clears unused portions of Code and Data hunks (as well as BSS hunks). (This also applies to InternalLoadSeg() and LoadSeg()).

See also

LoadSeg | Scatterload a loadable file into memory
UnLoadSeg | Unload a seglist previously loaded by LoadSeg()
InternalLoadSeg | Low-level load routine


NewLoadSegTagList

Declaration

Source position: amigados.pas line 2147

function NewLoadSegTagList(

  file1: PChar;

  tags: Pointer

):LongInt;


NewReadLink

Read the filename referred to by the soft-linked object

Declaration

Source position: amigados.pas line 2299

function NewReadLink(

  Port: PMsgPort;

  Lock: LongInt;

  Path: PChar;

  Buffer: PByte;

  Size: LongInt

):LongInt;

Arguments

Port | The handler to send the request to.
Lock | Object that path is relative to.
Path | Name of the object that caused the error.
Buffer | Buffer to fill with resolved filename.
Size | Length of the buffer.

Function result

> 0 success, actual length of the returned string; 0 failure, probably ERROR_NOT_IMPLEMENTED.; -1 failure, see IoErr() for more information. -2 failure, not enough space in the buffer.

Description

Read the filename referred to by the soft-linked object contained in path (relative to the lock lock) into the buffer buffer. The variable path should contain the name of the object that caused the original OBJECT_IS_SOFT_LINK error. Unlike original ReadLink, NewReadLink works on hardlinks aswell as softlinks.

Errors

Before dos 51.41 the filesystems not implementing this functionality would result in IoErr() not being set. This was fixed in dos 51.41 which now consistently sets IoErr() to ERROR_NOT_IMPLMENTED in this case.

See also

ReadLink

Reads the path for a soft filesystem link


NextDosEntry

Get the next Dos List entry

Declaration

Source position: amigados.pas line 2096

function NextDosEntry(

  dlist: PDOSList;

  flags: Cardinal

):PDOSList;

Arguments

dlist | Structure given by LockDosList() or the last call to FindDosEntry().
flags | The same flags as given to LockDosList() or a subset of them.

Description

Find the next Dos List entry of the right type. You must have locked the types you're looking for. Returns nil if there are no more of that type in the list.

See also

AddDosEntry | Add a Dos List entry to the lists
RemDosEntry | Removes a Dos List entry from it's list
FindDosEntry | Finds a specific Dos List entry
LockDosList | Locks the specified Dos Lists for use
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry


OpenFromLock

Opens a file you have a lock on

Declaration

Source position: amigados.pas line 1888

function OpenFromLock(

  lock: LongInt

):LongInt;

Arguments

lock

Lock on object to be opened.

Function result

Newly opened file handle or nil for failure

Description

Given a lock, this routine performs an open on that lock. If the open succeeds, the lock is (effectively) relinquished, and should not be UnLock()ed or used. If the open fails, the lock is still usable. The lock associated with the file internally is of the same access mode as the lock you gave up - shared is similar to MODE_OLDFILE, exclusive is similar to MODE_NEWFILE.

See also

DosOpen | Open a file for input or output
DosClose |
Lock | Lock a directory or file
UnLock | Unlock a directory or file


ParentDir

Declaration

Source position: amigados.pas line 1730

function ParentDir(

  lock: LongInt

):LongInt;

Arguments

lock

Lock to get parent directory of.

Function result

Returns a lock to the parent directory or 0, in which case the supplied lock has no parent directory (because it is the root directory) or an error occured. IoErr() returns 0 in the former case and a different value on error.

Description

The argument lock is associated with a given file or directory. ParentDir() returns newlock which is associated the parent directory of lock.

Taking the ParentDir() of the root of the current filing system returns a 0 lock. Note this 0 lock represents the root of file system that you booted from (which is, in effect, the parent of all other file system roots.)

See also

Lock | Lock a directory or file
DupLock | Duplicate a lock
UnLock | Unlock a directory or file
ParentOfFH | Returns a lock on the parent directory of a file
DupLockFromFH | Gets a lock on an open file


ParentOfFH

Returns a lock on the parent directory of a file

Declaration

Source position: amigados.pas line 1891

function ParentOfFH(

  fh: LongInt

):LongInt;

Arguments

fh

Filehandle you want the parent of.

Function result

Lock on parent directory of the filehandle or nil for failure.

Description

Returns a shared lock on the parent directory of the filehandle.

See also

ParentDir |
Lock | Lock a directory or file
UnLock | Unlock a directory or file
DupLockFromFH | Gets a lock on an open file


ParsePattern

Create a tokenized string for MatchPattern()

Declaration

Source position: amigados.pas line 2195

function ParsePattern(

  pat: PChar;

  buf: PChar;

  buflen: LongInt

):LongInt;

Function result

1
There are wildcards in the pattern (it might match more than one string).
0
No wildcards in it, all went fine.
-1
An error happened. IoErr() gives additional information in that case.

Description

Tokenizes a pattern, for use by MatchPattern(). Also indicates if there are any wildcards in the pattern (i.e. whether it might match more than one item). Note that Dest must be at least 2 times as large as Source plus bytes to be (almost) 100% certain of no buffer overflow. This is because each input character can currently expand to 2 tokens (with one exception that can expand to 3, but only once per string). Note: this implementation may change in the future, so you should handle error returns in all cases, but the size above should still be a reasonable upper bound for a buffer allocation.

The patterns are fairly extensive, and approximate some of the ability of Unix/grep "regular expression" patterns. Here are the available tokens:

?
Matches a single character.
#
Matches the following expression 0 or more times.
(ab|cd)
Matches any one of the items seperated by '|'.
~
Negates the following expression. It matches all strings that do not match the expression (aka ~(foo) matches all strings that are not exactly 'foo').
[abc]
Character class: matches any of the characters in the class.
[~bc]
Character class: matches any of the characters not in the class.
a-z
Character range (only within character classes).
%
Matches 0 characters always (useful in '(foo|bar|%)').
*
Synonym for "#?", not available by default in 2.0. Available as an option that can be turned on.

'Expression' in the above table means either a single character (ex: "#?"), or an alternation (ex: "#(ab|cd|ef)"), or a character class (ex: "#[a-zA-Z]").

See also

ParsePatternNoCase | Create a tokenized string for MatchPatternNoCase()
MatchPattern | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern


ParsePatternNoCase

Create a tokenized string for MatchPatternNoCase()

Declaration

Source position: amigados.pas line 2261

function ParsePatternNoCase(

  pat: PChar;

  buf: PChar;

  buflen: LongInt

):LongInt;

Function result

1
There are wildcards in the pattern (it might match more than one string).
0
No wildcards in it, all went fine.
-1
An error happened. IoErr() gives additional information in that case.

Description

Tokenizes a pattern, for use by MatchPatternNoCase(). Also indicates if there are any wildcards in the pattern (i.e. whether it might match more than one item). Note that Dest must be at least 2 times as large as Source plus 2 bytes. For a description of the wildcards, see ParsePattern().

See also

ParsePattern | Create a tokenized string for MatchPattern()
MatchPattern | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
ToUpper | Convert a character to upper case.


PathPart

Returns a pointer to the end of the next-to-last component of a path.

Declaration

Source position: amigados.pas line 2210

function PathPart(

  path: PChar

):PChar;

Arguments

path

Pointer to an path string. May be relative to the current directory or the current disk.

Function result

Pointer to the end of the next-to-last component of the path.

Description

This function returns a pointer to the character after the next-to-last component of a path specification, which will normally be the directory name. If there is only one component, it returns a pointer to the beginning of the string. The only real difference between this and FilePart() is the handling of '/'.

See also

FilePart | Returns the last component of a path
AddPart | Appends a file/dir to the end of a path


PrintFault

Returns the text associated with a DOS error code

Declaration

Source position: amigados.pas line 1965

function PrintFault(

  code: LongInt;

  header: PChar

):LongBool;

Arguments

code | Error code
header | Header to output before error text

Description

This routine obtains the error message text for the given error code. This is similar to the Fault() function, except that the output is written to the default output channel with buffered output. The value returned by IoErr() is set to the code passed in.

See also

IoErr | Return extra information from the system
Fault | Returns the text associated with a DOS error code
SetIoErr | Sets the value returned by IoErr()
DosOutput | Identify the programs' initial output file handle
FPuts | Writes a string the the specified output


PutStr

Writes a string the the default output (buffered)

Declaration

Source position: amigados.pas line 2254

function PutStr(

  str: PChar

):LongInt;

Function result

0 for success, -1 for any error. NOTE: this is opposite most Dos function returns!

Description

This routine writes an unformatted string to the default output. No newline is appended to the string and any error is returned. This routine is buffered.

See also

FPuts | Writes a string the the specified output
FPutC | Write a character to the specified output
FWrite | Writes a number of blocks to an output (buffered)
WriteChars | Writes bytes to the the default output (buffered)


QueryCLIDataTagList

Declaration

Source position: amigados.pas line 2312

function QueryCLIDataTagList(

  Tags: Pointer

):PCLIData;


QueryCLIDataTags

VarArgsVersion of QueryCLIDataTagList

Declaration

Source position: amigados.pas line 2353

function QueryCLIDataTags(

  const Tags: array of PtrUInt

):PCLIData;


ReadArgs

Read bytes of data from a file

Declaration

Source position: amigados.pas line 2167

function ReadArgs(

  arg_template: PChar;

  var array1: LongInt;

  args: PRDArgs

):PRDArgs;

Function result

A handle for the memory allocated by ReadArgs(). Must be freed with FreeArgs() later.

Description

Parses the commandline, a given string or DosInput() and fills an argument array according to the options template given. The array must be initialized to the wanted defaults before each call to ReadArgs(). If the rdargs argument is nilReadArgs() tries to parse the commandline and continues on the input channel if it just consists of a single '?', prompting the user for input.

The template string is given as a number of options separated by ',' and modified by '/' modifiers, e.g. 'NAME,WIDTH/N,HEIGHT/N' means get a name string and two numbers (width and height). The possible modifiers are:

/S
Option is a switch. It may be either set or left out.
/T
Option is a boolean value. Requires an argument which may be "ON", "YES" (setting the respective argument to 1), "OFF" or "NO" (setting the respective argument to 0).
/N
Option is a number. Strings are not allowed. If the option is optional, a pointer to the actual number is returned. This is how you know if it was really given. The number is always of type LONG.
/A
Argument is required. If it is left out ReadArgs() fails.
/K
The keyword must be given when filling the option. Normally it's skipped.
/M
Multiple strings or, when used in combination with /N, numbers. The result is returned as an array of pointers to strings or LONGs, and is terminated with NULL. /M eats all strings that don't fit into any other option. If there are unfilled /A arguments after parsing they steal strings from /M. This makes it possible to, for example, write a Copy command template like 'FROM/A/M,TO/A'. There may be only one /M option in a template.
/F
Eats the rest of the line even if there are option keywords in it.

See also

FindArg | Find a keyword in a template
ReadItem | Reads a single argument/name from command line
FreeArgs | Free allocated memory after ReadArgs()
AllocDosObject | Creates a dos object
FreeDosObject | Frees an object allocated by AllocDosObject()


ReadChar

Declaration

Source position: amigados.pas line 2330

function ReadChar: LongInt;


ReadChars

Declaration

Source position: amigados.pas line 2333

function ReadChars(

  buf: Pointer;

  num: LongInt

):LongInt;


ReadItem

Reads a single argument/name from command line

Declaration

Source position: amigados.pas line 2176

function ReadItem(

  name: PChar;

  maxchars: LongInt;

  cSource: PCSource

):LongInt;

Arguments

maxchars | Size of the buffer. Must be at least 1 (for the #0 terminator).
cSource | A ready to use TCSource structure or nil which means 'read from the input stream'.

Function result

ITEM_UNQUOTED
Normal word read.
ITEM_QUOTED
Quoted string read.
ITEM_NOTHING
End of line found. Nothing read.
ITEM_EQUAL
'=' read. Buffer is empty.
ITEM_ERROR
An error happened. IoErr() gives additional information in that case.

Description

Read an item from a given character source. Items are words or quoted strings separated by whitespace or '=' just like on the commandline. The separator is unread and the output string is terminated by a #0 character.

See also

ReadArgs | Read bytes of data from a file
FindArg | Find a keyword in a template
UnGetC | Makes a char available for reading again. (buffered)
FGetC | Read a character from the specified input (buffered)
DosInput | Identify the program's initial input file handle
FreeArgs | Free allocated memory after ReadArgs()


ReadLink

Reads the path for a soft filesystem link

Declaration

Source position: amigados.pas line 1934

function ReadLink(

  port: PMsgPort;

  lock: LongInt;

  path: PChar;

  buffer: PChar;

  size: Cardinal

):LongBool;

Arguments

port | MsgPort of the filesystem
lock | Lock this path is relative to on the filesystem
buffer | Pointer to buffer for new path from handler.
size | Size of buffer.

Function result

>= 0
Length of resolved filename in case of success
= -1
Failure, see IoErr() for more information
= -2
Buffer size was too small to store resolved filename

Description

ReadLink() takes a lock/name pair (usually from a failed attempt to use them to access an object with packets), and asks the filesystem to find the softlink and fill buffer with the modified path string. You then start the resolution process again by calling GetDeviceProc() with the new string from ReadLink().

Soft-links are resolved at access time by a combination of the filesystem (by returning ERROR_IS_SOFT_LINK to dos), and by Dos (using ReadLink() to resolve any links that are hit).

See also

MakeLink | Creates a filesystem link
DosOpen | Open a file for input or output
Lock | Lock a directory or file
GetDeviceProc | Finds a handler to send a message to


Relabel

Change the volume name of a volume

Declaration

Source position: amigados.pas line 2115

function Relabel(

  drive: PChar;

  newname: PChar

):LongBool;

Arguments

drive | Full name of device to rename (with ':')
newname | New name to apply to device (without ':')

Description

Changes the volumename of a volume, if supported by the filesystem.


ReleaseCLINumber

Declaration

Source position: amigados.pas line 2311

procedure ReleaseCLINumber(

  CLINum: LongInt

);


RemAssignList

Remove an entry from a multi-dir assign

Declaration

Source position: amigados.pas line 2065

function RemAssignList(

  name: PChar;

  lock: LongInt

):LongBool;

Arguments

name | Name of device to remove lock from (without trailing ':')
lock | Lock associated with the object to remove from the list

Description

Remove an entry from a multi-dir assign. The entry removed will be the first one that the SameLock() function called on the lock parameter returns that they belong to the same object.

The entry for this lock will be removed from the lock, and the lock for the entry in the list will be unlocked.

See also

Lock | Lock a directory or file
AssignLock | Creates an assignment to a locked object
AssignPath | Creates an assignment to a specified path
AssignLate | Creates an assignment to a specified path later
DupLock | Duplicate a lock
AssignAdd | Adds a lock to an assign for multi-directory assigns
UnLock | Unlock a directory or file


RemDosEntry

Removes a Dos List entry from it's list

Declaration

Source position: amigados.pas line 2085

function RemDosEntry(

  dlist: PDOSList

):LongBool;

Arguments

dlist

Device list entry to be removed.

Description

This removes an entry from the Dos Device list. The memory associated with the entry is not freed. NOTE: you must have locked the Dos List with the appropriate flags before calling this routine. Handler writers should see the AddDosEntry() caveats about locking and use a similar workaround to avoid deadlocks.

See also

AddDosEntry | Add a Dos List entry to the lists
FindDosEntry | Finds a specific Dos List entry
NextDosEntry | Get the next Dos List entry
LockDosList | Locks the specified Dos Lists for use
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry


RemSegment

Removes a resident segment from the resident list

Declaration

Source position: amigados.pas line 2161

function RemSegment(

  seg: PSegment

):LongBool;

Arguments

seg

The segment to be removed

Description

Removes a resident segment from the Dos resident segment list, unloads it, and does any other cleanup required. Will only succeed if the seg_UC (usecount) is 0.

See also

FindSegment | Finds a segment on the resident list
AddSegment | Adds a resident segment to the resident list


ReplyPkt

Replies a packet to the person who sent it to you

Declaration

Source position: amigados.pas line 1800

procedure ReplyPkt(

  dp: PDOSPacket;

  res1: LongInt;

  res2: LongInt

);

Arguments

dp | Packet to reply, assumed to set up correctly.
res1 | First result
res2 | Secondary result

Description

This returns a packet to the process which sent it to you. In addition, puts your pr_MsgPort address in dp_Port, so using ReplyPkt() again will send the message to you. (This is used in "ping-ponging" packets between two processes). It uses result 1 and 2 to set the dp_Res1 and dp_Res2dp_Res2 fields of the packet.

See also

DoPkt | Send a dos packet and wait for reply
SendPkt | Sends a packet to a handler
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
IoErr | Return extra information from the system


RunCommand

Runs a program using the current process

Declaration

Source position: amigados.pas line 1984

function RunCommand(

  seg: LongInt;

  stack: LongInt;

  paramptr: PChar;

  paramlen: LongInt

):LongInt;

Function result

Return code from executed command. -1 indicates failure

Description

Runs a command on your process/cli. Seg may be any language, including BCPL programs. Stack is in bytes. paramptr is a null- terminated string, paramlen is its length. Returns the returncode the program exited. Returns -1 if the stack couldn't be allocated.

NOTE: the argument string must be terminated with a newline to work properly with ReadArgs() and other argument parsers.

RunCommand also takes care of setting up the current input filehandle in such a way that ReadArgs() can be used in the program, and restores the state of the buffering before returning. It also sets the value returned by GetArgStr(), and restores it before returning.

It's usually appropriate to set the command name (via SetProgramName()) before calling RunCommand(). RunCommand() sets the value returned by GetArgStr() while the command is running.

See also

CreateNewProc | Create a new process from taglist
SystemTagList | Have a shell execute a command line
Execute | Execute a CLI command
GetArgStr | Returns the arguments for the process
SetProgramName | Sets the name of the program being run
ReadArgs | Read bytes of data from a file


SameDevice

Are two locks are on partitions of the device?

Declaration

Source position: amigados.pas line 2270

function SameDevice(

  lock1: LongInt;

  lock2: LongInt

):LongBool;

Arguments

lock1 | Lock to compare
lock2 | Lock to compare

Function result

Whether they're on the same device as far as Dos can determine. DosTrue

Description

SameDevice() returns whether two locks refer to partitions that are on the same physical device (if it can figure it out). This may be useful in writing copy routines to take advantage of asynchronous multi-device copies.


SameLock

Returns whether two locks are on the same object

Declaration

Source position: amigados.pas line 1919

function SameLock(

  lock1: LongInt;

  lock2: LongInt

):LongInt;

Arguments

lock1 | 1st lock for comparison
lock2 | 2nd lock for comparison

Function result

LOCK_SAME, LOCK_SAME_HANDLER or LOCK_DIFFERENT

Description

Compares two locks. Returns LOCK_SAME if they are on the same object, LOCK_SAME_HANDLER if on different objects on the same volume, and LOCK_DIFFERENT if they are on different volumes. Always compare for equality or non-equality with the results, in case new return values are added.


Seek64

Changes the current read/write position in a file

Declaration

Source position: amigados.pas line 2293

function Seek64(

  fh: LongInt;

  Position: Int64;

  Mode: LongInt

):Int64;

Arguments

fh | filehandle
Position | relative offset in bytes (positive, negative or 0).
Mode | Where to count from. Either OFFSET_BEGINNING, OFFSET_CURRENT or OFFSET_END.

Function result

Absolute position in bytes before the Seek64(), -1 if an error happened. IoErr() will give additional information in that case.

Description

Changes the current read/write position in a file and/or reads the current position, e.g to get the current position do a

Seek64(file, 0, OFFSET_CURRENT).

This function may fail (obviously) on certain devices such as pipes or console handlers.


SelectInput

Select a filehandle as the default input channel

Declaration

Source position: amigados.pas line 1828

function SelectInput(

  fh: LongInt

):LongInt;

Arguments

fh

Newly default input handle

Function result

Previous default input filehandle

Description

Set the current input as the default input for the process. This changes the value returned by DosInput(). old_fh should be closed or saved as needed.

See also

DosInput | Identify the program's initial input file handle
SelectOutput | Select a filehandle as the default output channel
DosOutput | Identify the programs' initial output file handle


SelectOutput

Select a filehandle as the default output channel

Declaration

Source position: amigados.pas line 1831

function SelectOutput(

  fh: LongInt

):LongInt;

Arguments

fh

Newly desired output handle

Function result

Previous current output

Description

Set the current output as the default output for the process. This changes the value returned by Output(). old_fh should be closed or saved as needed.

See also

DosInput | Identify the program's initial input file handle
SelectInput | Select a filehandle as the default input channel
DosOutput | Identify the programs' initial output file handle


SendPkt

Sends a packet to a handler

Declaration

Source position: amigados.pas line 1792

procedure SendPkt(

  dp: PDOSPacket;

  port: PMsgPort;

  replyport: PMsgPort

);

Arguments

dp | Packet to send, must be initialized and have a message.
port | pr_MsgPort of handler process to send to.
replyport | MsgPort for the packet to come back to.

Description

Sends a packet to a handler and does not wait. All fields in the packet must be initialized before calling this routine. The packet will be returned to replyport. If you wish to use this with WaitPkt(), use the address of your pr_MsgPort for replyport.

See also

DoPkt | Send a dos packet and wait for reply
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
AllocDosObject | Creates a dos object
FreeDosObject | Frees an object allocated by AllocDosObject()
AbortPkt | Aborts an asynchronous packet, if possible.


SetArgStr

Sets the arguments for the current process

Declaration

Source position: amigados.pas line 2005

function SetArgStr(

  str: PChar

):LongBool;

Function result

The previous argument string, can be nil

Description

Sets the arguments for the current program. The ptr MUST be reset to it's original value before process exit.

See also

GetArgStr | Returns the arguments for the process
RunCommand | Runs a program using the current process


SetComment

Change a files' comment string

Declaration

Source position: amigados.pas line 1712

function SetComment(

  name: PChar;

  comment: PChar

):LongBool;

Arguments

name | Name of File to set comment
comment | Comment to set

Description

SetComment() sets a comment on a file or directory. The comment is a pointer to a null-terminated string of up to 80 characters in the current ROM filesystem (and RAM:). Note that not all filesystems will support comments (for example, NFS usually will not), or the size of comment supported may vary.

See also

Examine | Examine a directory or file associated with a lock
ExNext | Examine the next entry in a directory
SetProtection | Set protection for a file or directory


SetConsoleTask

ets the default console for the process

Declaration

Source position: amigados.pas line 1993

function SetConsoleTask(

  task: PMsgPort

):PMsgPort;

Description

Sets the default console task's port (pr_ConsoleTask) for the current process.

See also

GetConsoleTask | Returns the default console for the process
DosOpen | Open a file for input or output


SetCurrentDirName

Sets the directory name for the process

Declaration

Source position: amigados.pas line 2014

function SetCurrentDirName(

  name: PChar

):LongBool;

Arguments

name

Name of directory to be set.

Description

Sets the name for the current dir in the cli structure. If the name is too long to fit, a failure is returned, and the old value is left intact. It is advised that you inform the user of this condition. This routine is safe to call even if there is no CLI structure.

See also

GetCurrentDirName

Returns the current directory name


SetDosObjectAttr

Declaration

Source position: amigados.pas line 2302

function SetDosObjectAttr(

  Type_: LongWord;

  Ptr: Pointer;

  Tags: Pointer

):LongInt;


SetDosObjectAttrTagList

Declaration

Source position: amigados.pas line 2347

function SetDosObjectAttrTagList(

  Type_: LongWord;

  Ptr: Pointer;

  const Tags: array of PtrUInt

):LongInt;


SetFileDate

Sets the modification date for a file or dir

Declaration

Source position: amigados.pas line 1898

function SetFileDate(

  name: PChar;

  date: PDateStamp

):LongBool;

Arguments

name | Name of object
date | New modification date

Description

Sets the file date for a file or directory. Note that for the Old File System and the Fast File System, the date of the root directory cannot be set. Other filesystems may not support setting the date for all files/directories.

See also

DateStamp | Fills the structure with the current time. Time is measured from 1. Jan. 1978.
Examine | Examine a directory or file associated with a lock
ExNext | Examine the next entry in a directory
ExAll | Examine an entire directory


SetFileSize

Sets the size of a file

Declaration

Source position: amigados.pas line 1951

function SetFileSize(

  fh: LongInt;

  pos: LongInt;

  mode: LongInt

):LongInt;

Arguments

mode

One of OFFSET_BEGINNING, OFFSET_CURRENT, or OFFSET_END.

Description

Changes the file size, truncating or extending as needed. Not all handlers may support this; be careful and check the return code. If the file is extended, no values should be assumed for the new bytes. If the new position would be before the filehandle's current position in the file, the filehandle will end with a position at the end-of-file. If there are other filehandles open onto the file, the new size will not leave any filehandle pointing past the end-of-file. You can check for this by looking at the new size (which would be different than what you requested).

The seek position should not be changed unless the file is made smaller than the current seek position. However, see Errors.

Do NOT count on any specific values to be in any extended area.

Errors

The RAM: filesystem and the normal Amiga filesystem act differently in where the file position is left after SetFileSize(). RAM: leaves you at the new end of the file (incorrectly), while the Amiga ROM filesystem leaves the seek position alone, unless the new position is less than the current position, in which case you're left at the new EOF.

The best workaround is to not make any assumptions about the seek position after SetFileSize().

See also

DosSeek

Set the current position for reading and writing


SetFileSize64

Change the size of a file.

Declaration

Source position: amigados.pas line 2294

function SetFileSize64(

  fh: LongInt;

  Pos: Int64;

  Mode: LongInt

):Int64;

Arguments

fh | filehandle
Pos | relative size
Mode | OFFSET_BEGINNING, OFFSET_CURRENT or OFFSET_END

Function result

New size of the file or -1 in case of an error. IoErr() gives additional information in that case.


SetFileSysTask

Sets the default filesystem for the process

Declaration

Source position: amigados.pas line 1999

function SetFileSysTask(

  task: PMsgPort

):PMsgPort;

Arguments

task

The pr_MsgPort of the default filesystem for the process

Description

Sets the default filesystem task's port (pr_FileSystemTask) for the current process.

See also

GetFileSysTask | Returns the default filesystem for the process
DosOpen | Open a file for input or output


SetIoErr

Sets the value returned by IoErr()

Declaration

Source position: amigados.pas line 1956

function SetIoErr(

  result: LongInt

):LongInt;

Description

This routine sets up the secondary result (pr_Result2) return code (returned by the IoErr() function).

See also

IoErr | Return extra information from the system
Fault | Returns the text associated with a DOS error code
PrintFault | Returns the text associated with a DOS error code


SetMode

Set the current behavior of a handler

Declaration

Source position: amigados.pas line 1923

function SetMode(

  fh: LongInt;

  mode: LongInt

):LongBool;

Arguments

fh | filehandle
mode | The new mode you want

Description

SetMode() sends an ACTION_SCREEN_MODE packet to the handler in question, normally for changing a CON: handler to raw mode or vice-versa. For CON:, use 1 to go to RAW: mode, 0 for CON: mode.


SetOwner

Set owner information for a file or directory

Declaration

Source position: amigados.pas line 2281

function SetOwner(

  name: PChar;

  owner_info: LongInt

):LongBool;

Arguments

name | Name of file
owner_info | Owner uid (31:16) and group id (15:0)

Description

SetOwner() sets the owner information for the file or directory. This value is a 32-bit value that is normally split into 16 bits of owner user id (bits 31-16), and 16 bits of owner group id (bits 15-0). However, other than returning them as shown by Examine()/ ExNext()/ExAll(), the filesystem take no interest in the values. These are primarily for use by networking software (clients and hosts), in conjunction with the FIBF_OTR_* and FIBF_GRP_* protection bits.

See also

Examine | Examine a directory or file associated with a lock
ExNext | Examine the next entry in a directory
ExAll | Examine an entire directory


SetProgramDir

Sets the directory returned by GetProgramDir

Declaration

Source position: amigados.pas line 2035

function SetProgramDir(

  lock: LongInt

):LongInt;

Arguments

lock

A lock on the directory the current program was loaded from

Function result

The previous ProgramDir.

Description

Sets a shared lock on the directory the program was loaded from. This can be used for a program to find data files, etc, that are stored with the program, or to find the program file itself. Nil is a valid input. This can be accessed via GetProgramDir or by using paths relative to PROGDIR:.

See also

GetProgramDir | Returns a lock on the directory the program was loaded from
DosOpen | Open a file for input or output


SetProgramName

Sets the name of the program being run

Declaration

Source position: amigados.pas line 2021

function SetProgramName(

  name: PChar

):LongBool;

Arguments

name

New Name of Program

Description

Sets the name for the program in the cli structure. If the name is too long to fit, a failure is returned, and the old value is left intact. It is advised that you inform the user if possible of this condition, and/or set the program name to an empty string. This routine is safe to call even if there is no CLI structure.

See also

GetProgramName

Returns the current program name


SetPrompt

Sets the CLI/shell prompt for the current process

Declaration

Source position: amigados.pas line 2028

function SetPrompt(

  name: PChar

):LongBool;

Arguments

name

Name of prompt to be set.

Description

Sets the text for the prompt in the cli structure. If the prompt is too long to fit, a failure is returned, and the old value is left intact. It is advised that you inform the user of this condition. This routine is safe to call even if there is no CLI structure.

See also

GetPrompt

Returns the prompt for the current process


SetProtection

Set protection for a file or directory

Declaration

Source position: amigados.pas line 1716

function SetProtection(

  name: PChar;

  mask: LongInt

):LongBool;

Arguments

name

Name of File

Description

Sets the protection attributes on a file or directory. Use FIBF_* for protection bits. The archive bit should be cleared by the filesystem whenever the file is changed. Backup utilities will generally set the bit after backing up each file.

See also

SetComment | Change a files' comment string
Examine | Examine a directory or file associated with a lock
ExNext | Examine the next entry in a directory


SetVar

Sets a local or environment variable

Declaration

Source position: amigados.pas line 2224

function SetVar(

  name: PChar;

  buffer: PChar;

  size: LongInt;

  flags: LongInt

):LongBool;

Arguments

name | pointer to an variable name. Note variable names follow filesystem syntax and semantics.
buffer | a user allocated area which contains a string that is the value to be associated with this variable.
size | combination of type of var to set (low 8 bits), and flags to control the behavior of this routine.

Function result

If non-zero, the variable was sucessfully set, False indicates failure.

Description

Sets a local or environment variable. It is advised to only use ASCII strings inside variables, but not required.

GVF_LOCAL_ONLY
set a local (to your process) variable.
GVF_GLOBAL_ONLY
set a global environment variable.

The default is to set a local environment variable.

See also

GetVar | Returns the value of a local or global variable
DeleteVar | Deletes a local or environment variable
FindVar | Finds a local variable


SetVBuf

Set buffering modes and size

Declaration

Source position: amigados.pas line 1879

function SetVBuf(

  fh: LongInt;

  buff: PChar;

  type1: LongInt;

  size: LongInt

):LongBool;

Arguments

buff | Buffer pointer for buffered I/O or nil. Must be 4-aligned!
size | Size of buffer for buffered I/O (sizes less than 208 bytes will be rounded up to 208), or -1.

Description

Changes the buffering modes and buffer size for a filehandle. With buff = nil, the current buffer will be deallocated and a new one of (approximately) size will be allocated. If buffer is non-nil, it will be used for buffering and must be at least max(size,208) bytes long, and must be longword aligned. If size is -1, then only the buffering mode will be changed.

Note that a user-supplied buffer will not be freed if it is later replaced by another SetVBuf() call, nor will it be freed if the filehandle is closed.

Has no effect on the buffersize of filehandles that were not created by AllocDosObject().

See also

FPutC | Write a character to the specified output
FGetC | Read a character from the specified input (buffered)
UnGetC | Makes a char available for reading again. (buffered)
DosFlush | Flushes buffers for a buffered filehandle
FRead | Reads a number of blocks from an input (buffered)
FWrite | Writes a number of blocks to an output (buffered)
FGets | Reads a line from the specified input (buffered)
FPuts | Writes a string the the specified output
AllocDosObject | Creates a dos object


SplitName

splits out a component of a pathname into a buffer

Declaration

Source position: amigados.pas line 1912

function SplitName(

  name: PChar;

  separator: Cardinal;

  buf: PChar;

  oldpos: LongInt;

  size: LongInt

):SmallInt;

Arguments

name | Filename being parsed.
buf | Buffer to hold separated name.
oldpos | Current position in the file.
size | Size of buf in bytes (including null termination).

Function result

New position for next call to splitname. -1 for last one.

Description

This routine splits out the next piece of a name from a given file name. Each piece is copied into the buffer, truncating at size-1 characters. The new position is then returned so that it may be passed in to the next call to splitname. If the separator is not found within size characters, then size-1 characters plus a null will be put into the buffer, and the position of the next separator will be returned.

If a a separator cannot be found, -1 is returned (but the characters from the old position to the end of the string are copied into the buffer, up to a maximum of size-1 characters). Both strings are null-terminated.

This function is mainly intended to support handlers.

See also

FilePart | Returns the last component of a path
PathPart | Returns a pointer to the end of the next-to-last component of a path.
AddPart | Appends a file/dir to the end of a path


StartNotify

Starts notification on a file or directory

Declaration

Source position: amigados.pas line 2218

function StartNotify(

  notify: PNotifyRequest

):LongBool;

Arguments

notify

A filled-in NotifyRequest structure

Description

Posts a notification request. Do not modify the notify structure while it is active. You will be notified when the file or directory changes. For files, you will be notified after the file is closed. Not all filesystems will support this: applications should not require it. In particular, most network filesystems won't support it.

See also

EndNotify

Ends a notification request


StrToLong

string to Integer value (decimal)

Declaration

Source position: amigados.pas line 2181

function StrToLong(

  string1: PChar;

  var value: LongInt

):LongInt;

Arguments

value

Pointer to integer value. Set to 0 if no digits are converted.

Function result

Number of characters converted or -1.

Description

Converts decimal string into Integer value. Returns number of characters converted. Skips over leading spaces and tabs (included in count). If no decimal digits are found (after skipping leading spaces and tabs), StrToLong() returns -1 for characters converted, and puts 0 into value.


SystemTagList

Have a shell execute a command line

Declaration

Source position: amigados.pas line 2041

function SystemTagList(

  command: PChar;

  tags: Pointer

):LongInt;

Arguments

command | Program and arguments
tags | Tags for start (SYS_*) some (NP_*)

Description

Similar to Execute(), but does not read commands from the input filehandle. Spawns a Shell process to execute the command, and returns the returncode the command produced, or -1 if the command could not be run for any reason. The input and output filehandles will not be closed by System, you must close them (if needed) after System returns, if you specified them via SYS_Input or SYS_Output.

By default the new process will use your current DosInput() and Output() filehandles. Normal Shell command-line parsing will be done including redirection on command. The current directory and path will be inherited from your process. Your path will be used to find the command (if no path is specified).

Note that you may NOT pass the same filehandle for both SYS_Input and SYS_Output. If you want input and output to both be to the same CON: window, pass a SYS_Input of a filehandle on the CON: window, and pass a SYS_Output of nil. The shell will automatically set the default Output() stream to the window you passed via SYS_Input, by opening '*' on that handler.

If used with the SYS_Asynch flag, it will close both it's input and output filehandles after running the command (even if these were your DosInput() and Output()!)

Normally uses the boot (ROM) shell, but other shells can be specified via SYS_UserShell and SYS_CustomShell. Normally, you should send things written by the user to the UserShell. The UserShell defaults to the same shell as the boot shell.

The tags are passed through to CreateNewProc() (tags that conflict with SystemTagList() will be filtered out). This allows setting things like priority, etc for the new process. The tags that are currently filtered out are:

  • NP_Seglist
  • NP_FreeSeglist
  • NP_Entry
  • NP_Input
  • NP_Output
  • NP_CloseInput
  • NP_CloseOutput
  • NP_HomeDir
  • NP_Cli

See also

Execute | Execute a CLI command
CreateNewProc | Create a new process from taglist
DosInput | Identify the program's initial input file handle
DosOutput | Identify the programs' initial output file handle


SystemTags

Variable args version for SystemTagList for direct tag use.

Declaration

Source position: amigados.pas line 2345

function SystemTags(

  command: PChar;

  Tags: array of DWord

):LongInt;

Arguments

Tags

Variable array of Tags use [TAG_1, 1, TAG_2, 2 ....] TAG_END will be automatically added at the end


UnGetC

Makes a char available for reading again. (buffered)

Declaration

Source position: amigados.pas line 1841

function UnGetC(

  fh: LongInt;

  character: LongInt

):LongInt;

Arguments

character

Character to push back or -1

Function result

Character pushed back, or False if the character cannot be pushed back.

Description

Pushes the character specified back into the input buffer. Every time you use a buffered read routine, you can always push back 1 character. You may be able to push back more, though it is not recommended, since there is no guarantee on how many can be pushed back at a given moment.

Passing -1 for the character will cause the last character read to be pushed back. If the last character read was an EOF, the next character read will be an EOF.

Note: UnGetC can be used to make sure that a filehandle is set up as a read filehandle. This is only of importance if you are writing a shell, and must manipulate the filehandle's buffer.


UnLoadSeg

Unload a seglist previously loaded by LoadSeg()

Declaration

Source position: amigados.pas line 1706

procedure UnLoadSeg(

  seglist: LongInt

);

Arguments

seglist

Pointer to a segment identifier

Description

Unload a seglist loaded by LoadSeg(). seglist> may be zero. Overlaid segments will have all needed cleanup done, including closing files.

See also

LoadSeg | Scatterload a loadable file into memory
InternalLoadSeg | Low-level load routine


Unlock

Unlock a directory or file

Declaration

Source position: amigados.pas line 1667

procedure Unlock(

  lock: LongInt

);

Arguments

lock

Lock to unlock, zero is harmless

Description

The filing system lock (obtained from Lock(), DupLock(), or DOSCreateDir()) is removed and deallocated.

See also

Lock | Lock a directory or file
DupLock | Duplicate a lock
ParentOfFH | Returns a lock on the parent directory of a file
DupLockFromFH | Gets a lock on an open file


UnLockDosList

Unlocks the Dos List

Declaration

Source position: amigados.pas line 2079

procedure UnLockDosList(

  flags: Cardinal

);

Description

Unlocks the access on the Dos Device List. You must pass the same flags you used to lock the list.

See also

AttemptLockDosList | Attempt to lock the Dos Lists for use
LockDosList | Locks the specified Dos Lists for use
Permit | Permit task rescheduling.


UnLockRecord

Unlock a record

Declaration

Source position: amigados.pas line 1820

function UnLockRecord(

  fh: LongInt;

  offset: Cardinal;

  length: Cardinal

):LongBool;

Arguments

fh | File handle of locked file
offset | Record start position
length | Length of record in bytes

Description

This releases the specified lock on a file. Note that you must use the same filehandle you used to lock the record, and offset and length must be the same values used to lock it. Every LockRecord() call must be balanced with an UnLockRecord() call.

See also

LockRecords | Lock a series of records
LockRecord | Locks a portion of a file
UnLockRecords | Unlock a list of records


UnLockRecord64

Release a lock made with LockRecord64().

Declaration

Source position: amigados.pas line 2297

function UnLockRecord64(

  Fh: LongInt;

  Offset: QWord;

  Length: QWord

):LongInt;

Arguments

Fh | filehandle the lock was made on
Offset | starting position of the lock
Length | length of the record in bytes

Description

The length and offset must match the corresponding LockRecord64() call.

See also

LockRecord64 | Lock a portion of a file for exclusive access.
LockRecords64 | Lock several records at the same time.
UnLockRecords64 | Release an array of record locks obtained with LockRecords64().


UnLockRecords

Unlock a list of records

Declaration

Source position: amigados.pas line 1825

function UnLockRecords(

  recArray: PRecordLock

):LongBool;

Arguments

recArray

List of records to be unlocked

Description

This releases an array of record locks obtained using LockRecords. You should not modify the record_array while you have the records locked. Every LockRecords() call must be balanced with an UnLockRecords() call.

See also

LockRecords | Lock a series of records
LockRecord | Locks a portion of a file
UnLockRecord | Unlock a record


UnLockRecords64

Release an array of record locks obtained with LockRecords64().

Declaration

Source position: amigados.pas line 2298

function UnLockRecords64(

  RecArray: TRecordLock64

):LongInt;

Arguments

RecArray

array of record locks (previously locked with LockRecords64())

Description

A array of records may not be modified when records are locked.

See also

LockRecords64

Lock several records at the same time.


UnReadChar

Declaration

Source position: amigados.pas line 2332

function UnReadChar(

  ch: Char

):LongInt;


VFPrintf

format and print a string to a file (buffered)

Declaration

Source position: amigados.pas line 1871

function VFPrintf(

  fh: LongInt;

  format: PChar;

  argarray: PLongInt

):LongInt;

Arguments

fh | Filehandle to write to
format | RawDoFmt() style formatting string
argarray | Pointer to array of formatting values

Function result

Number of bytes written or -1 (EOF) for an error

Description

Writes the formatted string and values to the given file. This routine is assumed to handle all internal buffering so that the formatting string and resultant formatted values can be arbitrarily long. Any secondary error code is returned in IoErr(). This routine is buffered.

See also

VPrintf | Format and print string (buffered)
VFWritef | Write a BCPL formatted string to a file (buffered)
RawDoFmt | Format data into a character stream.
FPutC | Write a character to the specified output


VFWritef

Write a BCPL formatted string to a file (buffered)

Declaration

Source position: amigados.pas line 1866

procedure VFWritef(

  fh: LongInt;

  format: PChar;

  argarray: Pointer

);

Arguments

fh | Filehandle to write to
argarray | Pointer to array of formatting values

Description

Writes the formatted string and values to the specified file. This routine is assumed to handle all internal buffering so that the formatting string and resultant formatted values can be arbitrarily long. The formats are in BCPL form. This routine is buffered.

Supported formats are: (Note x is in base 36!)

%S
string (CSTR)
%Tx
writes a left-justified string in a field at least x bytes long.
%C
writes a single character
%Ox
writes a number in octal, maximum x characters wide
%Xx
writes a number in hex, maximum x characters wide
%Ix
writes a number in decimal, maximum x characters wide
%N
writes a number in decimal, any length
%Ux
writes an unsigned number, maximum x characters wide
%$
ignore parameter

Note: 'x' above is actually the character value - '0'.

See also

VPrintf | Format and print string (buffered)
VFPrintf | format and print a string to a file (buffered)
FPutC | Write a character to the specified output


VPrintf

Format and print string (buffered)

Declaration

Source position: amigados.pas line 2257

function VPrintf(

  format: PChar;

  argarray: Pointer

):LongInt;

Arguments

format | exec.library RawDoFmt style formatting string
argarray | Pointer to array of formatting values

Function result

Number of bytes written or -1 (EOF) for an error

Description

Writes the formatted string and values to DosOutput(). This routine is assumed to handle all internal buffering so that the formatting string and resultant formatted values can be arbitrarily long. Any secondary error code is returned in IoErr(). This routine is buffered.

Note: RawDoFmt assumes 16 bit ints, so you will usually need 'l's in your formats (ex: %ld versus %d).

See also

VFPrintf | format and print a string to a file (buffered)
VFWritef | Write a BCPL formatted string to a file (buffered)
RawDoFmt | Format data into a character stream.
FPutC | Write a character to the specified output


VWritef

Declaration

Source position: amigados.pas line 2336

procedure VWritef(

  format: PChar;

  argv: Pointer

);


WaitForChar

Determine if chars arrive within a time limit

Declaration

Source position: amigados.pas line 1726

function WaitForChar(

  file1: LongInt;

  timeout: LongInt

):LongBool;

Arguments

timeout

In miliseconds

Description

If a character is available to be read from file within the time (in microseconds) indicated by timeout, WaitForChar() returns -1 (True). If a character is available, you can use Read() to read it. Note that WaitForChar() is only valid when the I/O stream is connected to a virtual terminal device. If a character is not available within timeout, a 0 (False) is returned.

See also

DosRead | Read bytes of data from a file
FGetC | Read a character from the specified input (buffered)


WaitPkt

Waits for a packet to arrive at your pr_MsgPort

Declaration

Source position: amigados.pas line 1797

function WaitPkt: PDOSPacket;

Function result

the packet that arrived at the port (from ln_Name of message).

Description

Waits for a packet to arrive at your pr_MsgPort. If anyone has installed a packet wait function in pr_PktWait, it will be called. The message will be automatically GetMsg()ed so that it is no longer on the port. It assumes the message is a dos packet. It is not guaranteed to clear the signal for the port.

See also

SendPkt | Sends a packet to a handler
DoPkt | Send a dos packet and wait for reply
AbortPkt | Aborts an asynchronous packet, if possible.


WriteChar

Declaration

Source position: amigados.pas line 2331

function WriteChar(

  ch: Char

):LongInt;


WriteChars

Writes bytes to the the default output (buffered)

Declaration

Source position: amigados.pas line 2250

function WriteChars(

  buf: PChar;

  buflen: Cardinal

):LongInt;

Arguments

buf | Buffer of characters to write
buflen | Number of characters to write

Function result

Number of bytes written. -1 (EOF) indicates an error

Description

This routine writes a number of bytes to the default output. The length is returned. This routine is buffered.

See also

FPuts | Writes a string the the specified output
FPutC | Write a character to the specified output
FWrite | Writes a number of blocks to an output (buffered)
PutStr | Writes a string the the default output (buffered)


Reference for unit 'amigalib': Procedures and functions

DISPATCHERARG

DoMethod

DoMethodA

DoSuperMethod

DoSuperMethodA

DoSuperNew

HookEntry


Index of all identifiers in unit 'amigalib'

D H

D

DISPATCHERARG | DoMethodA | DoSuperMethodA
DoMethod | DoSuperMethod | DoSuperNew

H

HookEntry


DISPATCHERARG

Declaration

Source position: amigalib.pas line 35

procedure DISPATCHERARG(

  var cl;

  var obj;

  var msg

);


DoMethod

Declaration

Source position: amigalib.pas line 24

function DoMethod(

  obj: LongWord;

  const msg: array of LongWord

):LongWord;

function DoMethod(

  obj: pointer;

  const msg: array of LongWord

):LongWord;


DoMethodA

Declaration

Source position: amigalib.pas line 26

function DoMethodA(

  obj: LongWord;

  msg1: Pointer

):LongWord;


DoSuperMethod

Declaration

Source position: amigalib.pas line 28

function DoSuperMethod(

  class_: LongWord;

  obj: LongWord;

  const msg: array of LongWord

):LongWord;


DoSuperMethodA

Declaration

Source position: amigalib.pas line 29

function DoSuperMethodA(

  class_: LongWord;

  obj: LongWord;

  msg1: Pointer

):LongWord;

function DoSuperMethodA(

  class_: pointer;

  obj: pointer;

  msg1: Pointer

):LongWord;


DoSuperNew

Declaration

Source position: amigalib.pas line 32

function DoSuperNew(

  class_: pointer;

  obj: pointer;

  const tags: array of LongWord

):LongWord;


HookEntry

Declaration

Source position: amigalib.pas line 37

function HookEntry: PtrUInt;


Reference for unit 'asl': Procedures and functions

AbortAslRequest

ActivateAslRequest

AllocAslRequest

AllocAslRequestTags

AllocFileRequest

AslRequest

AslRequestTags

FreeAslRequest

FreeFileRequest

InitAslLibrary

RequestFile


Unit 'asl' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'asl': Variables

AslBase


Index of all identifiers in unit 'asl'

A F I P R T

A

AbortAslRequest | ASLFR_DoSaveMode | ASLPOS_WindowPosition
ActivateAslRequest | ASLFR_DrawersOnly | AslRequest
AllocAslRequest | ASLFR_FilterDrawers | AslRequestTags
AllocAslRequestTags | ASLFR_FilterFunc | ASL_ScreenModeRequest
AllocFileRequest | ASLFR_Flags1 | ASL_SEMAPHORE_NAME
AslBase | ASLFR_Flags2 | ASLSIZE_DefaultSize
ASL_FileRequest | ASLFR_GetSortBy | ASLSIZE_MASK
ASLFO_Activate | ASLFR_GetSortDrawers | ASLSIZE_RelativeSize
ASLFO_BackPens | ASLFR_GetSortOrder | ASLSM_Activate
ASLFO_DoBackPen | ASLFR_HookFunc | ASLSM_CustomSMList
ASLFO_DoDrawMode | ASLFR_InitialDrawer | ASLSM_DoAutoScroll
ASLFO_DoFrontPen | ASLFR_InitialFile | ASLSM_DoDepth
ASLFO_DoStyle | ASLFR_InitialHeight | ASLSM_DoHeight
ASLFO_FilterFunc | ASLFR_InitialLeftEdge | ASLSM_DoOverscanType
ASLFO_FixedWidthOnly | ASLFR_InitialPattern | ASLSM_DoWidth
ASLFO_Flags | ASLFR_InitialShowVolumes | ASLSM_FilterFunc
ASLFO_FrontPens | ASLFR_InitialTopEdge | ASLSM_InitialAutoScroll
ASLFO_HookFunc | ASLFR_InitialWidth | ASLSM_InitialDisplayDepth
ASLFO_InitialBackPen | ASLFR_IntuiMsgFunc | ASLSM_InitialDisplayHeight
ASLFO_InitialDrawMode | ASLFR_Locale | ASLSM_InitialDisplayID
ASLFO_InitialFlags | ASLFR_NegativeText | ASLSM_InitialDisplayWidth
ASLFO_InitialFrontPen | ASLFR_PopToFront | ASLSM_InitialHeight
ASLFO_InitialHeight | ASLFR_PositiveText | ASLSM_InitialInfoLeftEdge
ASLFO_InitialLeftEdge | ASLFR_PrivateIDCMP | ASLSM_InitialInfoOpened
ASLFO_InitialName | ASLFR_PubScreenName | ASLSM_InitialInfoTopEdge
ASLFO_InitialSize | ASLFR_RejectIcons | ASLSM_InitialLeftEdge
ASLFO_InitialStyle | ASLFR_RejectPattern | ASLSM_InitialOverscanType
ASLFO_InitialTopEdge | ASLFR_Screen | ASLSM_InitialTopEdge
ASLFO_InitialWidth | ASLFR_SetSortBy | ASLSM_InitialWidth
ASLFO_IntuiMsgFunc | ASLFR_SetSortDrawers | ASLSM_IntuiMsgFunc
ASLFO_Locale | ASLFR_SetSortOrder | ASLSM_Locale
ASLFO_MaxBackPen | ASLFR_SleepWindow | ASLSM_MaxDepth
ASLFO_MaxFrontPen | ASLFRSORTBY_Date | ASLSM_MaxHeight
ASLFO_MaxHeight | ASLFRSORTBY_Name | ASLSM_MaxWidth
ASLFO_MinHeight | ASLFRSORTBY_Size | ASLSM_MinDepth
ASLFO_ModeList | ASLFRSORTDRAWERS_First | ASLSM_MinHeight
ASLFO_NegativeText | ASLFRSORTDRAWERS_Last | ASLSM_MinWidth
ASL_FontRequest | ASLFRSORTDRAWERS_Mix | ASLSM_NegativeText
ASLFO_PopToFront | ASLFRSORTORDER_Ascend | ASLSM_PopToFront
ASLFO_PositiveText | ASLFRSORTORDER_Descend | ASLSM_PositiveText
ASLFO_PrivateIDCMP | ASLFR_TextAttr | ASLSM_PrivateIDCMP
ASLFO_PubScreenName | ASLFR_TitleText | ASLSM_PropertyFlags
ASLFO_SampleText | ASLFR_UserData | ASLSM_PropertyMask
ASLFO_Screen | ASLFR_Window | ASLSM_PubScreenName
ASLFO_SleepWindow | ASL_LAST_TAG | ASLSM_Screen
ASLFO_TextAttr | ASLNAME | ASLSM_SleepWindow
ASLFO_TitleText | ASLOPTION_ASLOverrides | ASLSM_TextAttr
ASLFO_UserData | ASLPOS_CenterMouse | ASLSM_TitleText
ASLFO_Window | ASLPOS_CenterScreen | ASLSM_UserData
ASLFR_AcceptPattern | ASLPOS_CenterWindow | ASLSM_Window
ASLFR_Activate | ASLPOS_DefaultPosition | ASL_TB
ASLFR_DoMultiSelect | ASLPOS_MASK |
ASLFR_DoPatterns | ASLPOS_ScreenPosition |

F

FOB_DOBACKPEN | FOF_FILTERFUNC | FRB_REJECTICONS
FOB_DODRAWMODE | FOF_FIXEDWIDTHONLY | FreeAslRequest
FOB_DOFRONTPEN | FOF_INTUIFUNC | FreeFileRequest
FOB_DOSTYLE | FOF_PRIVATEIDCMP | FRF_DOMULTISELECT
FOB_FILTERFUNC | FRB_DOMULTISELECT | FRF_DOPATTERNS
FOB_FIXEDWIDTHONLY | FRB_DOPATTERNS | FRF_DOSAVEMODE
FOB_INTUIFUNC | FRB_DOSAVEMODE | FRF_DRAWERSONLY
FOB_PRIVATEIDCMP | FRB_DRAWERSONLY | FRF_FILTERDRAWERS
FOF_DOBACKPEN | FRB_FILTERDRAWERS | FRF_FILTERFUNC
FOF_DODRAWMODE | FRB_FILTERFUNC | FRF_INTUIFUNC
FOF_DOFRONTPEN | FRB_INTUIFUNC | FRF_PRIVATEIDCMP
FOF_DOSTYLE | FRB_PRIVATEIDCMP | FRF_REJECTICONS

I

InitAslLibrary

P

PAslSemaphore | PFileRequester | PScreenModeRequester
PDisplayMode | PFontRequester |

R

RequestFile

T

TAslSemaphore | TFileRequester | TScreenModeRequester
TDisplayMode | TFontRequester |


AbortAslRequest

Declaration

Source position: asl.pas line 545

procedure AbortAslRequest(

  Requester: Pointer

);


ActivateAslRequest

Declaration

Source position: asl.pas line 546

procedure ActivateAslRequest(

  Requester: Pointer

);


AllocAslRequest

Declaration

Source position: asl.pas line 542

function AllocAslRequest(

  ReqType: Cardinal;

  TagList: PTagItem

):Pointer;


AllocAslRequestTags

Declaration

Source position: asl.pas line 548

function AllocAslRequestTags(

  ReqType: Cardinal;

  const TagList: array of PtrUInt

):Pointer;


AllocFileRequest

Declaration

Source position: asl.pas line 539

function AllocFileRequest: PFileRequester;


AslRequest

Declaration

Source position: asl.pas line 544

function AslRequest(

  Requester: Pointer;

  TagList: PTagItem

):LongBool;


AslRequestTags

Declaration

Source position: asl.pas line 549

function AslRequestTags(

  Requester: Pointer;

  const TagList: array of PtrUInt

):LongBool;


FreeAslRequest

Declaration

Source position: asl.pas line 543

procedure FreeAslRequest(

  Requester: Pointer

);


FreeFileRequest

Declaration

Source position: asl.pas line 540

procedure FreeFileRequest(

  FileReq: PFileRequester

);


InitAslLibrary

Declaration

Source position: asl.pas line 551

function InitAslLibrary: Boolean;


RequestFile

Declaration

Source position: asl.pas line 541

function RequestFile(

  FileReq: PFileRequester

):LongBool;


Reference for unit 'cgxvideo': Procedures and functions

AttachVLayerTagList

CreateVLayerHandleTagList

DeleteVLayerHandle

DetachVLayer

GetVLayerAttr

InitCGXVideoLibrary

LockVLayer

QueryVLayerAttr

SetVLayerAttrTagList

SwapVLayerBuffer

UnlockVLayer

WriteSPLine


Unit 'cgxvideo' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'cgxvideo': Variables

CGXVideoBase


Index of all identifiers in unit 'cgxvideo'

A C D G I L P Q S T U V W

A

AttachVLayerTagList

C

CGXVideoBase CGXVIDEONAME CreateVLayerHandleTagList

D

DeleteVLayerHandle DetachVLayer

G

GetVLayerAttr

I

InitCGXVideoLibrary

L

LockVLayer

P

PVLayerHandle

Q

QueryVLayerAttr

S

SetVLayerAttrTagList | SRCFMT_RGB15 | SRCFMT_YCbCr420
SRCFMT_R5G5B5PC | SRCFMT_RGB16 | SRCFMT_YUV16
SRCFMT_R5G6B5PC | SRCFMT_YCbCr16 | SwapVLayerBuffer

T

Pointer

U

UnlockVLayer

V

VOA_BaseAddress | VOA_ColorKeyPen | VOA_UseFilter
VOA_BaseOffset | VOA_DoubleBuffer | VOA_Width
VOA_BaseOffset0 | VOA_EnableSP | VOA_ZoomRect
VOA_BaseOffset1 | VOA_Error | VOERR_INVSCRMODE
VOA_BaseOffset2 | VOA_FrameBase0 | VOERR_INVSRCFMT
VOA_BaseOffset3 | VOA_FrameBase1 | VOERR_NOMEMORY
VOA_BaseOffset4 | VOA_FrameIndex | VOERR_NOOVLMEMORY
VOA_BaseOffset5 | VOA_FrameType | VOERR_OK
VOA_BottomIndent | VOA_Height | VSQ_Dummy
VOA_CaptureMode | VOA_HLColConSP | VSQ_FEAT_CAPTUREMODE
VOA_ColConSP | VOA_HLEnableSP | VSQ_FEAT_COLORKEYING
VOA_Color0SP | VOA_HLRectSP | VSQ_FEAT_DOUBLEBUFFER
VOA_Color10SP | VOA_Identifier | VSQ_FEAT_FILTERING
VOA_Color11SP | VOA_InterLaced | VSQ_FEAT_INTERLACE
VOA_Color12SP | VOA_LeftIndent | VSQ_FEAT_MULTIBUFFER
VOA_Color13SP | VOA_Modulo | VSQ_FEAT_OVERLAY
VOA_Color14SP | VOA_MultiBuffer | VSQ_FEAT_SUBPICTURE
VOA_Color15SP | VOA_RightIndent | VSQ_FEAT_ZOOMRECT
VOA_Color1SP | VOA_SrcHeight | VSQ_FMT_R5G5B5_LE
VOA_Color2SP | VOA_SrcHeightSP | VSQ_FMT_R5G6B5_LE
VOA_Color3SP | VOA_SrcType | VSQ_FMT_YUV420_PLANAR
VOA_Color4SP | VOA_SrcWidth | VSQ_FMT_YUYV
VOA_Color5SP | VOA_SrcWidthSP | VSQ_MaxWidth
VOA_Color6SP | VOA_StreamRectSP | VSQ_MaxWidthSP
VOA_Color7SP | VOA_SubPicture | VSQ_SupportedFeatures
VOA_Color8SP | VOA_TopIndent | VSQ_SupportedFormats
VOA_Color9SP | VOA_UseBackfill |
VOA_ColorKey | VOA_UseColorKey |

W

WriteSPLine


AttachVLayerTagList

Declaration

Source position: cgxvideo.pas line 175

function AttachVLayerTagList(

  VLayerHandle: PVLayerHandle;

  window: PWindow;

  tags: PTagItem

):LongWord;


CreateVLayerHandleTagList

Declaration

Source position: cgxvideo.pas line 173

function CreateVLayerHandleTagList(

  screen: PScreen;

  tags: PTagItem

):PVLayerHandle;


DeleteVLayerHandle

Declaration

Source position: cgxvideo.pas line 174

function DeleteVLayerHandle(

  VLayerHandle: PVLayerHandle

):LongWord;


DetachVLayer

Declaration

Source position: cgxvideo.pas line 176

function DetachVLayer(

  VLayerHandle: PVLayerHandle

):LongWord;


GetVLayerAttr

Declaration

Source position: cgxvideo.pas line 177

function GetVLayerAttr(

  VLayerHandle: PVLayerHandle;

  AttrID: LongWord

):LongWord;


InitCGXVideoLibrary

Declaration

Source position: cgxvideo.pas line 199

function InitCGXVideoLibrary: Boolean;


LockVLayer

Declaration

Source position: cgxvideo.pas line 178

function LockVLayer(

  VLayerHandle: PVLayerHandle

):LongWord;


QueryVLayerAttr

Declaration

Source position: cgxvideo.pas line 183

function QueryVLayerAttr(

  screen: PScreen;

  AttrID: LongWord

):LongWord;


SetVLayerAttrTagList

Declaration

Source position: cgxvideo.pas line 180

procedure SetVLayerAttrTagList(

  VLayerHandle: PVLayerHandle;

  tags: PTagItem

);


SwapVLayerBuffer

Declaration

Source position: cgxvideo.pas line 181

procedure SwapVLayerBuffer(

  VLayerHandle: PVLayerHandle

);


UnlockVLayer

Declaration

Source position: cgxvideo.pas line 179

function UnlockVLayer(

  VLayerHandle: PVLayerHandle

):LongWord;


WriteSPLine

Declaration

Source position: cgxvideo.pas line 182

function WriteSPLine(

  VLayerHandle: PVLayerHandle;

  buffer: PByte;

  x: LongInt;

  y: LongInt;

  w: LongInt

):LongWord;


Reference for unit 'commodities': Procedures and functions

ActivateCxObj

AddIEvents

AttachCxObj

ClearCxObjError

CreateCxObj

CxBroker

CxCustom

CxDebug

CxFilter

CxMsgData

CxMsgID

CxMsgType

CxObjError

CxObjType

CxSender

CxSignal

CxTranslate

DeleteCxObj

DeleteCxObjAll

DisposeCxMsg

DivertCxMsg

EnqueueCxObj

InsertCxObj

InvertKeyMap

MatchIX

Null_IX

ParseIX

RemoveCxObj

RouteCxMsg

SetCxObjPri

SetFilter

SetFilterIX

SetTranslate


Unit 'commodities' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'commodities': Variables

CxBase


Index of all identifiers in unit 'commodities'

A C D E I M N P R S T

A

ActivateCxObj AddIEvents AttachCxObj

C

CBD_DESCRLEN | CX_BROKER | LongInt
CBD_NAMELEN | CXCMD_APPEAR | CxMsgData
CBD_TITLELEN | CXCMD_DISABLE | CxMsgID
CBERR_DUP | CXCMD_DISAPPEAR | CxMsgType
CBERR_OK | CXCMD_ENABLE | LongInt
CBERR_SYSERR | CXCMD_KILL | CxObjError
CBERR_VERSION | CXCMD_LIST_CHG | CxObjType
ClearCxObjError | CXCMD_UNIQUE | CX_SEND
COERR_BADFILTER | CxCustom | CxSender
COERR_BADTYPE | CX_CUSTOM | CxSignal
COERR_ISNULL | CxDebug | CX_SIGNAL
COERR_NULLATTACH | CX_DEBUG | CxTranslate
COF_SHOW_HIDE | CxFilter | CX_TRANSLATE
COMMODITIESNAME | CX_FILTER | CX_TYPEFILTER
CreateCxObj | CX_INVALID | CX_ZERO
CxBase | CXM_COMMAND |
CxBroker | CXM_IEVENT |

D

DeleteCxObj | DisposeCxMsg
DeleteCxObjAll | DivertCxMsg

E

EnqueueCxObj

I

InsertCxObj | IXSYM_ALT | IXSYM_SHIFT
InvertKeyMap | IXSYM_ALTMASK | IXSYM_SHIFTMASK
IX | IXSYM_CAPS | IX_VERSION
IX_NORMALQUALS | IXSYM_CAPSMASK |

M

MatchIX

N

NBU_DUPLICATE | NBU_UNIQUE | Null_IX
NBU_NOTIFY | NB_VERSION |

P

ParseIX | PCxObj | PIX
PCXMsg | PInputXpression | PNewBroker

R

RemoveCxObj RouteCxMsg

S

SetCxObjPri | SetFilterIX
SetFilter | SetTranslate

T

TInputXpression TNewBroker


ActivateCxObj

Declaration

Source position: commodities.pas line 131

function ActivateCxObj(

  Co: PCxObj;

  Tru: LongInt

):LongInt;


AddIEvents

Declaration

Source position: commodities.pas line 153

procedure AddIEvents(

  Events: PInputEvent

);


AttachCxObj

Declaration

Source position: commodities.pas line 138

procedure AttachCxObj(

  HeadObj: PCxObj;

  Co: PCxObj

);


ClearCxObjError

Declaration

Source position: commodities.pas line 136

procedure ClearCxObjError(

  Co: PCxObj

);


CreateCxObj

Declaration

Source position: commodities.pas line 129

function CreateCxObj(

  Typ: LongWord;

  Arg1: LongInt;

  Arg2: LongInt

):PCxObj;


CxBroker

Declaration

Source position: commodities.pas line 130

function CxBroker(

  Nb: PNewBroker;

  var Error: LongInt

):PCxObj;


CxCustom

Declaration

Source position: commodities.pas line 163

function CxCustom(

  Action: Pointer;

  Id: LongInt

):PCxObj;


CxDebug

Declaration

Source position: commodities.pas line 162

function CxDebug(

  Id: LongInt

):PCxObj;


CxFilter

Declaration

Source position: commodities.pas line 158

function CxFilter(

  D: PChar

):PCxObj;


CxMsgData

Declaration

Source position: commodities.pas line 147

function CxMsgData(

  Cxm: PCXMsg

):Pointer;


CxMsgID

Declaration

Source position: commodities.pas line 148

function CxMsgID(

  Cxm: PCXMsg

):LongInt;


CxMsgType

Declaration

Source position: commodities.pas line 146

function CxMsgType(

  Cxm: PCXMsg

):LongWord;


CxObjError

Declaration

Source position: commodities.pas line 135

function CxObjError(

  Co: PCxObj

):LongInt;


CxObjType

Declaration

Source position: commodities.pas line 134

function CxObjType(

  Co: PCxObj

):LongWord;


CxSender

Declaration

Source position: commodities.pas line 159

function CxSender(

  Port: PMsgPort;

  Id: LongInt

):PCxObj;


CxSignal

Declaration

Source position: commodities.pas line 160

function CxSignal(

  Task: PTask;

  Sig: Byte

):PCxObj;


CxTranslate

Declaration

Source position: commodities.pas line 161

function CxTranslate(

  Ie: PInputEvent

):PCxObj;


DeleteCxObj

Declaration

Source position: commodities.pas line 132

procedure DeleteCxObj(

  Co: PCxObj

);


DeleteCxObjAll

Declaration

Source position: commodities.pas line 133

procedure DeleteCxObjAll(

  Co: PCxObj

);


DisposeCxMsg

Declaration

Source position: commodities.pas line 151

procedure DisposeCxMsg(

  Cxm: PCXMsg

);


DivertCxMsg

Declaration

Source position: commodities.pas line 149

procedure DivertCxMsg(

  Cxm: PCXMsg;

  HeadObj: PCxObj;

  ReturnObj: PCxObj

);


EnqueueCxObj

Declaration

Source position: commodities.pas line 139

procedure EnqueueCxObj(

  HeadObj: PCxObj;

  Co: PCxObj

);


InsertCxObj

Declaration

Source position: commodities.pas line 140

procedure InsertCxObj(

  HeadObj: PCxObj;

  Co: PCxObj;

  Pred: PCxObj

);


InvertKeyMap

Declaration

Source position: commodities.pas line 152

function InvertKeyMap(

  AnsiCode: LongWord;

  Event: PInputEvent;

  Km: PKeyMap

):LongBool;


MatchIX

Declaration

Source position: commodities.pas line 154

function MatchIX(

  Event: PInputEvent;

  Ix: PInputXpression

):LongBool;


Null_IX

Declaration

Source position: commodities.pas line 164

function Null_IX(

  ix: PIX

):Boolean;


ParseIX

Declaration

Source position: commodities.pas line 145

function ParseIX(

  Description: PChar;

  Ix: PInputXpression

):LongInt;


RemoveCxObj

Declaration

Source position: commodities.pas line 141

procedure RemoveCxObj(

  Co: PCxObj

);


RouteCxMsg

Declaration

Source position: commodities.pas line 150

procedure RouteCxMsg(

  Cxm: PCXMsg;

  Co: PCxObj

);


SetCxObjPri

Declaration

Source position: commodities.pas line 137

function SetCxObjPri(

  Co: PCxObj;

  Pri: LongInt

):LongInt;


SetFilter

Declaration

Source position: commodities.pas line 143

procedure SetFilter(

  Filter: PCxObj;

  Text: PChar

);


SetFilterIX

Declaration

Source position: commodities.pas line 144

procedure SetFilterIX(

  Filter: PCxObj;

  Ix: PInputXpression

);


SetTranslate

Declaration

Source position: commodities.pas line 142

procedure SetTranslate(

  Translator: PCxObj;

  Events: PInputEvent

);


Reference for unit 'console': Procedures and functions

CDInputHandler

RawKeyConvert


Unit 'console' | Package
[Overview][Constants][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'console': Variables

ConsoleDevice


Index of all identifiers in unit 'console'

C D M R S T

C

CD_ASKDEFAULTKEYMAP | CD_SETDEFAULTKEYMAP | CTC_HCLRTAB
CD_ASKKEYMAP | CD_SETKEYMAP | CTC_HCLRTABSALL
CDInputHandler | ConsoleDevice | CTC_HSETTAB

D

DSR_CPR

M

M_ASM M_AWM M_LNM

R

RawKeyConvert

S

SGR_BLACK | SGR_CLR5 | SGR_NEGATIVE
SGR_BLACKBG | SGR_CLR5BG | SGR_NORMAL
SGR_BLUE | SGR_CLR6 | SGR_NOTITALIC
SGR_BLUEBG | SGR_CLR6BG | SGR_NOTUNDERSCORE
SGR_BOLD | SGR_CLR7 | SGR_POSITIVE
SGR_CLR0 | SGR_CLR7BG | SGR_PRIMARY
SGR_CLR0BG | SGR_CYAN | SGR_RED
SGR_CLR1 | SGR_CYANBG | SGR_REDBG
SGR_CLR1BG | SGR_DEFAULT | SGR_UNDERSCORE
SGR_CLR2 | SGR_DEFAULTBG | SGR_WHITE
SGR_CLR2BG | SGR_GREEN | SGR_WHITEBG
SGR_CLR3 | SGR_GREENBG | SGR_YELLOW
SGR_CLR3BG | SGR_ITALIC | SGR_YELLOWBG
SGR_CLR4 | SGR_MAGENTA |
SGR_CLR4BG | SGR_MAGENTABG |

T

TBC_HCLRTAB TBC_HCLRTABSALL


CDInputHandler

Declaration

Source position: console.pas line 115

function CDInputHandler(

  Events: PInputEvent;

  ConsoleDev: PLibrary

):PInputEvent;


RawKeyConvert

Declaration

Source position: console.pas line 116

function RawKeyConvert(

  Events: PInputEvent;

  Buffer: PChar;

  Length: LongInt;

  KeyMap: PKeyMap

):LongInt;


Reference for unit 'CYBERGRAPHICS': Procedures and functions

AllocCModeListTagList | Get an exec list with requested modes
BestCModeIDTagList | Calculate the best ModeID with given parameters
BltBitMapAlpha | Blend a rectangular region of pixels in a BitMap. (v51)
BltBitMapRastPortAlpha | Blends from source bitmap to destination rastport. (v51)
BltTemplateAlpha | Blends an alpha mask into a rectangular area into the target RastPort. (v51)
CModeRequestTagList | Get screenmode from user using a requester.
CVideoCtrlTagList | Control video output
DoCDrawMethodTagList | Do the given hook for the supplied rastport
ExtractColor | Extract the specified colour/CLUT value from a given CyberGraphX RastPort
FillPixelArray | fill a rectangular area with the supplied ARGB
FreeCModeList | Frees a previously allocated ModeList
GetCyberIDAttr | Returns information about a cybergraphics ID
GetCyberMapAttr | Returns information about a cybergraphics bitmap
InitCyberGfxLibrary | deprecated, to open the cybergraphics library, only here for compatibilty reasons
InvertPixelArray | Invert a rectangular area
IsCyberModeID | Returns whether supplied ModeID is a cybergraphics ID
LockBitMapTagList | Lock supplied BitMap for a short amount of time to allow direct memory access
MovePixelArray | move the color values of a rectangular area
ProcessPixelArray | Applies one of a variety of transformations to a rectangular portion of a RastPort.
ReadPixelArray | Read the color values of a rectangular array
ReadRGBPixel | Reads a pixel from a specified location
ScalePixelArray | Scale the colors values of a rectangular array (V41)
ScalePixelArrayAlpha | Scale the colors value of a rectangular array (V51)
SHIFT_PIXFMT |
UnLockBitMap | Unlock CyberGraphX BitMap that was previously locked
UnLockBitMapTagList | Unlock CyberGraphX BitMap that was previously
WriteLUTPixelArray | write the color value generated from a given color table (V41)
WritePixelArray | write the color value of a rectangular array
WritePixelArrayAlpha | Write the color value of a rectangular array
WriteRGBPixel | Writes a pixel to a specified location


Reference for unit 'CYBERGRAPHICS': Variables

CyberGfxBase

CyberGraphics library base structure


Index of all identifiers in unit 'CYBERGRAPHICS'

A B C D E F G I L M P R S T U W

A

AllocCModeListTagList

B

BestCModeIDTagList | BLTBMA_MIXLEVEL | BMB_SPECIALFMT
BltBitMapAlpha | BLTBMA_USESOURCEALPHA | BMF_3DTARGET
BltBitMapRastPortAlpha | BltTemplateAlpha | BMF_REQUESTVMEM
BLTBMA_DESTALPHAVALUE | BMB_3DTARGET | BMF_ROOTMAP
BLTBMA_GLOBALALPHA | BMB_ROOTMAP | BMF_SPECIALFMT

C

CModeRequestTagList | CYBRIDATTR_DEPTH | CYBRMREQ_CancelText
CTABFMT_XRGB8 | CYBRIDATTR_HEIGHT | CYBRMREQ_CModelArray
CVideoCtrlTagList | CYBRIDATTR_PIXFMT | CYBRMREQ_MaxDepth
CyberGfxBase | CYBRIDATTR_WIDTH | CYBRMREQ_MaxHeight
CYBERGFX_INCLUDE_VERSION | CYBRMATTR_BPPIX | CYBRMREQ_MaxWidth
CYBERGFXNAME | CYBRMATTR_COLORMAP | CYBRMREQ_MinDepth
CYBERGRAPHICSNAME | CYBRMATTR_DEPTH | CYBRMREQ_MinHeight
CYBRBIDTG_BoardName | CYBRMATTR_DISPADR | CYBRMREQ_MinWidth
CYBRBIDTG_Depth | CYBRMATTR_HEIGHT | CYBRMREQ_OKText
CYBRBIDTG_MonitorID | CYBRMATTR_ISCYBERGFX | CYBRMREQ_Screen
CYBRBIDTG_NominalHeight | CYBRMATTR_ISLINEARMEM | CYBRMREQ_TB
CYBRBIDTG_NominalWidth | CYBRMATTR_PIXFMT | CYBRMREQ_WinTitle
CYBRBIDTG_TB | CYBRMATTR_WIDTH |
CYBRIDATTR_BPPIX | CYBRMATTR_XMOD |

D

DESTALPHAVALUE_ONE | DESTALPHAVALUE_USESOURCE | DPMS_ON
DESTALPHAVALUE_UNDEFINED | DoCDrawMethodTagList | DPMS_STANDBY
DESTALPHAVALUE_USEDEST | DPMS_OFF | DPMS_SUSPEND

E

ExtractColor

F

FillPixelArray FreeCModeList

G

GetCyberIDAttr | GRADTYPE_HORIZONTAL | GRADTYPE_RECTANGLE
GetCyberMapAttr | GRADTYPE_LINEAR_ANGLE | GRADTYPE_VERTICAL
GRADIENT_NUMTYPES | GRADTYPE_RADIAL |

I

InitCyberGfxLibrary InvertPixelArray IsCyberModeID

L

LBMI_BASEADDRESS | LBMI_DEPTH | LBMI_WIDTH
LBMI_BYTESPERPIX | LBMI_HEIGHT | LockBitMapTagList
LBMI_BYTESPERROW | LBMI_PIXFMT |

M

MovePixelArray

P

PCDrawMsg | PIXFMT_RGB16 | POP_TINT
PCyberModeNode | PIXFMT_RGB16PC | POP_TINTFADE
PIXFMT_ARGB32 | PIXFMT_RGB24 | PPAOPTAG_FADEFULLSCALE
PIXFMT_BGR15 | PIXFMT_RGBA32 | PPAOPTAG_FADEOFFSET
PIXFMT_BGR15PC | POP_BLUR | PPAOPTAG_GRADCOLOR1
PIXFMT_BGR16 | POP_BRIGHTEN | PPAOPTAG_GRADCOLOR2
PIXFMT_BGR16PC | POP_COLOR2GREY | PPAOPTAG_GRADFULLSCALE
PIXFMT_BGR24 | POP_DARKEN | PPAOPTAG_GRADIENTTYPE
PIXFMT_BGRA32 | POP_GRADIENT | PPAOPTAG_GRADOFFSET
PIXFMT_LUT8 | POP_NEGATIVE | PPAOPTAG_GRADSYMCENTER
PIXFMT_RGB15 | POP_NEGFADE | PPAOPTAG_RGBMASK
PIXFMT_RGB15PC | POP_SETALPHA | ProcessPixelArray
PIXFMT_RGB15X | POP_SHIFTRGB |

R

ReadPixelArray | RECTFMT_RAW | RGBSHIFT_GBR
ReadRGBPixel | RECTFMT_RGB | RGBSHIFT_GRB
RECTFMT_ARGB | RECTFMT_RGBA | RGBSHIFT_RBG
RECTFMT_GREY8 | RGBSHIFT_BGR |
RECTFMT_LUT8 | RGBSHIFT_BRG |

S

ScalePixelArray | SETVC_DPMSLevel
ScalePixelArrayAlpha | SHIFT_PIXFMT

T

tCDrawMsg tCyberModeNode

U

UBMI_REALLYUNLOCK | UnLockBitMap
UBMI_UPDATERECTS | UnLockBitMapTagList

W

WriteLUTPixelArray | WritePixelArrayAlpha
WritePixelArray | WriteRGBPixel


AllocCModeListTagList

Get an exec list with requested modes

Declaration

Source position: cybergraphics.pas line 299

function AllocCModeListTagList(

  ModeListTags: PTagItem

):PList;

Arguments

ModeListTags

Pointer to an optional tag list which may be used to control the number of returned modes

Function result

nil if no modes are available, a pointer to a exec list if there are modes which fit your needs. Use FreeCModeList to free it after use.

Description

Allocates a list structure which contains all requested modes (All nodes are of type CyberModeNode). See defines for more information about the structure of this nodes.

Available Tags:

CYBRMREQ_MinWidth
(LongWord) The minimum display width to let the user choose. Default is 320.
CYBRMREQ_MaxWidth
(LongWord) The maximum display width to let the user choose. Default is 1600.
CYBRMREQ_MinHeight
(LongWord) The minimum display height to let the user choose. Default is 240.
CYBRMREQ_MaxHeight
(LongWord) The maximum display height to let the user choose. Default is 1200.
CYBRMREQ_MinDepth
(Word) The minimum display depth to let the user choose. Default is 8.
CYBRMREQ_MaxDepth
(Word) The maximum display depth to let the user choose. Default is 32.
CYBRMREQ_CModelArray
(PWord) Array of color models which should be available for screenmode selection. Currently supported colormodels are: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32 default is all colormodels available, nothing filtered

See also

FreeCModeList

Frees a previously allocated ModeList


BestCModeIDTagList

Calculate the best ModeID with given parameters

Declaration

Source position: cybergraphics.pas line 300

function BestCModeIDTagList(

  BestModeIDTags: PTagItem

):LongWord;

Arguments

BestModeIDTags

Pointer to an array of TagItems describing the wanted screen mode

Function result

DisplayID of the best mode to use, or INVALID_ID if a match could not be found.

Description

Returns the CyberGraphX displaymode ID which fits best for the parameters supplied in the TagList.

Available Tags:

CYBRBIDTG_Depth
(Word) Depth the returned ModeID must support. Default is 8
CYBRBIDTG_NominalWidth
(Word) desired width the ModeID should have
CYBRBIDTAG_NominalHeight
(Word) desired height the ModeID should have
CYBRBIDTG_MonitorID

(LongWord) if multiple graphics boards are installed in the system, you can choose the desired one with this tag Currently supported boards are:

  • 1 = CVision64
  • 2 = Piccolo
  • 3 = PicassoII
  • 4 = Spectrum
  • 5 = Domino
  • 6 = RetinaZ3/DraCoAltais
  • 7 = PiccoSD64
  • 8 = A2410
  • 13 = CVision3D (V41)
  • 14 = Inferno (V41)
  • 15 = PicassoIV (V41)
CYBRBIDTG_BoardName
(STRPTR) - Specify the card name directly. For example, pass 'CVision3D' to get a CyberVision64/3D board ID

Errors

Older versions return displaymode IDs with wrong depth if the desired color depth is not available. If you specify very small widths/heights (e.g. 50/20 icon size) this call returns INVALID_ID instead of the smallest available lowres ID.


BltBitMapAlpha

Blend a rectangular region of pixels in a BitMap. (v51)

Declaration

Source position: cybergraphics.pas line 328

function BltBitMapAlpha(

  srcBitMap: PBitMap;

  xSrc: LongInt;

  ySrc: LongInt;

  destBitMap: PBitMap;

  xDest: LongInt;

  yDest: LongInt;

  xSize: LongInt;

  ySize: LongInt;

  tagList: PTagItem

):LongWord;

Arguments

srcBitMap | the BitMap(s) containing the source rectangle
xSrc | Left corner of the source rectangle. Valid range is positive signed integer such that the raster word's offset 0..(32767-Size)
ySrc | Top corner of the source rectangle. Valid range is positive signed integer such that the raster word's offset 0..(32767-Size)
destBitMap | the BitMap(s) containing the destination rectangle
xDest | the x coordinate of the upper left corner of the destination for the rectangle. Valid range is as for Src.
yDest | the y coordinate of the upper left corner of the destination for the rectangle. Valid range is as for Src.
xSize | Width of the rectangle to be moved.
ySize | Height of the rectangle to be moved.
tagList | tags for options

Description

Blend a rectangular region of pixels in a BitMap.

Available Tags

BLTBMA_DESTALPHAVALUE
Determines what happens to the destination pixel alpha component. DESTALPHAVALUE_UNDEFINED, DESTALPHAVALUE_ONE, DESTALPHAVALUE_USESOURCE, DESTALPHAVALUE_USEDEST
BLTBMA_MIXLEVEL
Set the global 32bit left-justified alpha mix level, defaults to $80808080 (50%) if source alpha is not used, otherwise $FFFFFFFF (100%)
BLTBMA_USESOURCEALPHA
Use the supplied per pixel source alpha value if a non-zero data value is passed, disabled by default

Uses hardware acceleration on dedicated hardware

Uses Altivec enabled code if hardware acceleration is not available but an Altivec unit is available

See also

ClipBlit | Calls BltBitMap() after accounting for windows
BltBitMap | Move a rectangular region of bits in a BitMap.


BltBitMapRastPortAlpha

Blends from source bitmap to destination rastport. (v51)

Declaration

Source position: cybergraphics.pas line 329

function BltBitMapRastPortAlpha(

  srcBitMap: PBitMap;

  xSrc: LongInt;

  ySrc: LongInt;

  destRP: PRastPort;

  xDest: LongInt;

  yDest: LongInt;

  xSize: LongInt;

  ySize: LongInt;

  tagList: PTagItem

):LongWord;

Arguments

srcBitMap | a pointer to the source bitmap
xSrc | x offset into source bitmap
ySrc | y offset into source bitmap
destRP | a pointer to the destination rastport
xDest | x offset into dest rastport
yDest | y offset into dest rastport
xSize | width of blit in pixels
ySize | height of blit in rows
tagList | optional taglist, see BltBitMapAlpha() for options and defaults

Function result

True

Description

Blends from source bitmap to position specified in destination rastport.

Uses hardware acceleration on dedicated hardware

Uses Altivec enabled code if hardware acceleration is not available but an Altivec unit is available


BltTemplateAlpha

Blends an alpha mask into a rectangular area into the target RastPort. (v51)

Declaration

Source position: cybergraphics.pas line 324

procedure BltTemplateAlpha(

  source: pWORD;

  xSrc: LongInt;

  srcMod: LongInt;

  destRP: PRastPort;

  xDest: LongInt;

  yDest: LongInt;

  xSize: LongInt;

  ySize: LongInt

);

Arguments

source | pointer to the alpha 8bit mask array.
xSrc | x offset into the alpha mask
srcMod | number of bytes per row in alpha mask array.
destRP | pointer to destination RastPort.
xDest | x coordinate of the upper left corner of the destination for the blit.
yDest | y coordinate of the upper left corner of the destination for the blit.
xSize | Width of the rectangle to be used as the template.
ySize | Height of the rectangle to be used as the template.

Description

This function blends the alpha image in the template into the RastPort using the current color and drawing mode at the specified position. The alpha template is assumed not to overlap the destination.

If the alpha template falls outside the RastPort boundary, it is truncated to that boundary.

See also

BltTemplate


CModeRequestTagList

Get screenmode from user using a requester.

Declaration

Source position: cybergraphics.pas line 301

function CModeRequestTagList(

  ModeRequest: POINTER;

  ModeRequestTags: PTagItem

):LongWord;

Arguments

ModeRequest | not used currently. You have to set it to nil!
ModeRequestTags | Pointer to an optional tag list which may be used to control features of the requester

Function result

0 if the user cancelled the requester or if something prevented the requester from opening. If <> 0 the displaymode ID of the selected screenmode is returned.

Description

Prompts the user for input by showing all available CyberGraphX screenmodes in a requester. If the user cancels or the system aborts the request, 0 is returned, otherwise the displaymode ID of the selected screenmode.

Available Tags:

CYBRMREQ_Screen
(PScreen) Screen on which to open the requester. Default locale will be used.
CYBRMREQ_WinTitle
(PChar) Title to use for the requesting window.
CYBRMREQ_OKText
(PChar) Label of the positive gadget in the requester. English default is 'OK'.
CYBRMREQ_CancelText
(PChar) Label of the negative gadget in the requester. English default is 'Cancel'.
CYBRMREQ_MinWidth
(LongWord) The minimum display width to let the user choose. Default is 320.
CYBRMREQ_MaxWidth
(LongWord) The maximum display width to let the user choose. Default is 1600.
CYBRMREQ_MinHeight
(LongWord) The minimum display height to let the user choose. Default is 240.
CYBRMREQ_MaxHeight
(LongWord) The maximum display height to let the user choose. Default is 1200.
CYBRMREQ_MinDepth
(Word) The minimum display depth to let the user choose. Default is 8.
CYBRMREQ_MaxDepth
(Word) The maximum display depth to let the user choose. Default is 32.
CYBRMREQ_CModelArray
(PWord) Array of color models which should be available for screenmode selection. Currently supported colormodels are: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32 default is all colormodels available, nothing filtered

Errors

The requester structure is not supported. You should better use asl.library/AslRequest() instead.

See also

AslRequest()


CVideoCtrlTagList

Control video output

Declaration

Source position: cybergraphics.pas line 302

procedure CVideoCtrlTagList(

  ViewPort: PViewPort;

  TagList: PTagItem

);

Arguments

ViewPort | Pointer to a ViewPort of a CyberGraphX screen
TagList | Pointer to Taglist to control operation

Description

This function controls the video output of the gfx board to which the specified ViewPort belongs to.

Available Tags

SETVC_DPMSLevel

(LongWord) Set the DPMS level for the specified viewport Supported levels are:

  • DPMS_ON Full operation
  • DPMS_STANDBY Optional state of minimal power reduction
  • DPMS_SUSPEND Significant reduction of power consumption
  • DPMS_OFF Lowest level of power consumption

Snippet

{ set DPMS level }
CVideoCtrlTags(@Scr^.ViewPort, [SETVC_DPMSLevel, DPMS_OFF, TAG_DONE]);

Errors

Some DPMS levels are not implemented for certain graphics cards


DoCDrawMethodTagList

Do the given hook for the supplied rastport

Declaration

Source position: cybergraphics.pas line 303

procedure DoCDrawMethodTagList(

  Hook: PHook;

  a1arg: PRastPort;

  TagList: PTagItem

);

Arguments

Hook | Pointer to callback hook which will be called
a1arg | A pointer to a cybergraphics RastPort
TagList | optional taglist, currently not used. Set it to nil!

Description

This function will call the given hook for the given rastport. Is is mainly used to do direct bitmap modifications in a locked graphics environment. You have to support all known color models, so only use this call if you really need it!!

Hook call parameter

object
PRastPort
message

pointer to TCDrawMsg:

  • MemPtr: APTR
  • XOffset: LongWord
  • YOffset: LongWord
  • XSize: LongWord
  • YSize: LongWord
  • BytesPerRow: Word
  • BytesPerPix: Word
  • ColorModel: Word

where colormodel is on of following: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32

Errors

In previous autodocs, the bytesperrow message field was described as an LongWord which in fact was an Word.


ExtractColor

Extract the specified colour/CLUT value from a given CyberGraphX RastPort

Declaration

Source position: cybergraphics.pas line 304

function ExtractColor(

  a0arg: PRastPort;

  BitMap: PBitMap;

  Colour: LongWord;

  SrcX: LongWord;

  SrcY: LongWord;

  Width: LongWord;

  Height: LongWord

):LongWord;

Arguments

a0arg | pointer to a CyberGraphX RastPort structure
BitMap | Planar destination bitmap that has at least a depth of one and the minimum width and height specified.
Colour | the color that should be extracted in AARRGGBB format for true color rastports or in indexed mode for CLUT rastports (index in BB).
SrcX | X starting point in the RastPort that should be analyzed
SrcY | Y starting point in the RastPort that should be analyzed
Width | Width of the rectangle that should be analyzed
Height | Height of the rectangle that should be analyzed

Function result

Returns True (<> 0) if colour could be extracted, False (= 0) if not

Description

Extract the specified colour/CLUT value from a given CyberGraphX RastPort into a single plane bitmap starting at a certain x,y location and using the specified width and height. Use this function if you want to create masks. (V41)

Errors

This call was a no-op in very early revisions of cybergraphics v41


FillPixelArray

fill a rectangular area with the supplied ARGB

Declaration

Source position: cybergraphics.pas line 305

function FillPixelArray(

  a1arg: PRastPort;

  DestX: Word;

  DestY: Word;

  SizeX: Word;

  SizeY: Word;

  ARGB: LongWord

):LongWord;

Arguments

a1arg | Pointer to a RastPort structure
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered
ARGB | the desired color in AARRGGBB format for true color rastports or in indexed mode for CLUT rastports. Every component uses 8 bits in the supplied longword.

Function result

Count will be set to the number of pixels plotted

Description

fill a rectangular area with the supplied ARGB value starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the supplied color value into the bitmap used to describe a particular rastport.

Attention

This function should only be used on screens depths >8 bits in cybergraphics versions prior v41.

Errors

The returned count value is wrong up to and including v41 of the cybergraphics.library

See also

InvertPixelArray

Invert a rectangular area


FreeCModeList

Frees a previously allocated ModeList

Declaration

Source position: cybergraphics.pas line 306

procedure FreeCModeList(

  ModeList: PList

);

Arguments

ModeList

a list structure which contains all the mode data.

Description

Frees all data which was previously allocated by AllocCModeListTagList

See also

AllocCModeListTagList

Get an exec list with requested modes


GetCyberIDAttr

Returns information about a cybergraphics ID

Declaration

Source position: cybergraphics.pas line 307

function GetCyberIDAttr(

  CyberIDAttr: LongWord;

  CyberDisplayModeID: LongWord

):LongWord;

Arguments

CyberIDAttr | A number telling cybergraphics which attribute of the displaymode id should be returned
CyberDisplayModeID | CyberGraphX displaymode ID

Function result

depends on the supplied CyberIDAttr

Description

Returns information about a specified displaymode ID.

Available CyberIDAttr

You should know what you are doing if you call this function! Don't apply it on a non cybergraphics displaymode!

CYBRIDATTR_PIXFMT
return the pixel format of the supplied screenmode id
CYBRIDATTR_WIDTH
returns visible width in pixels
CYBRIDATTR_HEIGHT
returns visible height in lines
CYBRIDATTR_DEPTH
returns bits per pixel
CYBRIDATTR_BPPIX
returns bytes per pixel

Unknown attributes are reserved for future use, and return ($FFFFFFFF).


GetCyberMapAttr

Returns information about a cybergraphics bitmap

Declaration

Source position: cybergraphics.pas line 308

function GetCyberMapAttr(

  CyberGfxBitmap: PBitMap;

  CyberAttrTag: LongWord

):LongWord;

Arguments

CyberAttrTag

A number telling cybergraphics which attribute of the bitmap should be returned

Function result

Value described by CyberAttrTag

Description

Gets information about an extended cybergraphics bitmap. This function should be used instead of making any assumptions about fields in the bitmap structure. This will provide future compatibility.

You should know what you are doing if you call this function! Always use the CYBRMATTR_ISCYBERGFX attribute first to check if the bitmap is a CyberGraphX one.

Available CyberAttrTag

CYBRMATTR_XMOD
returns bytes per row of the supplied bitmap
CYBRMATTR_BPPIX
returns number of bytes per pixel
CYBRMATTR_PIXFMT
return the pixel format of the bitmap
CYBRMATTR_WIDTH
return width of the bitmap in pixels
CYBRMATTR_HEIGHT
return the height in lines
CYBRMATTR_DEPTH
returns bits per pixel
CYBRMATTR_ISCYBERGFX
returns True (result <> 0) if supplied bitmap is a CyberGraphX one
CYBRMATTR_ISLINEARMEM
returns True (result <> 0) if the related display buffer supports linear memory access

Unknown attributes are reserved for future use, and return ($FFFFFFFF).


InitCyberGfxLibrary

deprecated, to open the cybergraphics library, only here for compatibilty reasons

Declaration

Source position: cybergraphics.pas line 346

function InitCyberGfxLibrary: Boolean;

Function result

True if cybergraphics lib is open


InvertPixelArray

Invert a rectangular area

Declaration

Source position: cybergraphics.pas line 309

function InvertPixelArray(

  a1arg: PRastPort;

  DestX: Word;

  DestY: Word;

  SizeX: Word;

  SizeY: Word

):LongWord;

Arguments

a1arg | pointer to a RastPort structure
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered

Function result

count will be set to the number of pixels plotted

Description

Invert each pixel in a rectangular region.

Attention

This function should only be used on screens depths > 8 bits with cybergraphics versions prior v41.

Errors

The count value returned is totally wrong.

See also

FillPixelArray

fill a rectangular area with the supplied ARGB


IsCyberModeID

Returns whether supplied ModeID is a cybergraphics ID

Declaration

Source position: cybergraphics.pas line 310

function IsCyberModeID(

  displayID: LongWord

):wordbool;

Arguments

displayID

a 32 bit display identifier.

Function result

Returns whether the supplied ModeID is a cybergraphics.library mode identifier (True) or not (False).


LockBitMapTagList

Lock supplied BitMap for a short amount of time to allow direct memory access

Declaration

Source position: cybergraphics.pas line 311

function LockBitMapTagList(

  BitMap: POINTER;

  TagList: PTagItem

):POINTER;

Arguments

BitMap | Pointer to a CyberGraphX bitmap pointer. please check if it is a cybermap by calling GetCyberMapAttr() first.
TagList | Pointer to a mandatory taglist which's tagdata pointer fields contain valid LongWords after a successful call.

Function result

0 if the bitmap could not be locked, <> 0 it contains a handle which should be passed to UnLockBitMap afterwards

Description

Lock supplied BitMap for a short amount of time to allow direct memory access

Available Tags

LBMI_WIDTH
(PLongWord) Points to a longword which contains the bitmap width after a succesful call
LBMI_HEIGHT
(PLongWord) Points to a longword which contains the bitmap height after a succesful call
LBMI_DEPTH
(PLongWord) Points to a longword which contains the bitmap depth after a succesful call
LBMI_PIXFMT
(PLongWord) Points to a longword which contains the usedpixel format. Possibly returned colormodels are: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32
LBMI_BYTESPERPIX
(PLongWord) points to a longword which contains the amount of bytes per pixel data.
LBMI_BYTESPERROW
(PLongWord) points to a longword which contains the number of bytes per row for one bitmap line
LBMI_BASEADDRESS
(PLongWord) points to a longword which contains the bitmap base address. This address is only valid inside of the Lock/UnLockBitmap call!

See also

UnLockBitMap

Unlock CyberGraphX BitMap that was previously locked


MovePixelArray

move the color values of a rectangular area

Declaration

Source position: cybergraphics.pas line 312

function MovePixelArray(

  SrcX: Word;

  SrcY: Word;

  a1arg: PRastPort;

  DestX: Word;

  DestY: Word;

  SizeX: Word;

  SizeY: Word

):LongWord;

Arguments

SrcX | Starting x point in the source rectangle
SrcY | Starting y point in the source rectangle
a1arg | Pointer to a RastPort structure
DestX | Starting x point in the destination rectangle
DestY | Starting y point in the destination rectangle
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered

Function result

number of pixels moved

Description

move the color values of a rectangular area of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, move the pixel value from a specified source to a specified destination

The blitter can be used to move the data if the bitmap is in display memory. This is why you should use this call.

Errors

The count value returned is totally wrong. This function should only be used on screens depths > 8 bits with cybergraphics versions up to v40.

See also

FillPixelArray | fill a rectangular area with the supplied ARGB
InvertPixelArray | Invert a rectangular area
BltBitMapRastPort | Blit from source bitmap to destination rastport.


ProcessPixelArray

Applies one of a variety of transformations to a rectangular portion of a RastPort.

Declaration

Source position: cybergraphics.pas line 325

procedure ProcessPixelArray(

  rastPort: PRastPort;

  destX: LongWord;

  destY: LongWord;

  sizeX: LongWord;

  sizeY: LongWord;

  operation: LongWord;

  value: LongInt;

  taglist: PTagItem

);

Arguments

rastPort | the RastPort to process.
destX | Left corner of portion of RastPort to process.
destY | Top corner of portion of RastPort to process.
sizeX | Width of the affected area.
sizeY | Height of the affected area.
operation | one of the following transformation types: POP_TINT, POP_BLUR, POP_BRIGHTEN, POP_DARKEN, POP_SETALPHA, POP_GRADIENT
value | see description of operation input.
taglist | currently describes gradient parameters

Description

Available Tags

PPAOPTAG_GRADIENTTYPE
GRADTYPE_HORIZONTAL or GRADTYPE_VERTICAL
PPAOPTAG_GRADCOLOR1
The starting color of the gradient (ARGB32).
PPAOPTAG_GRADCOLOR2
The ending color of the gradient (ARGB32).
PPAOPTAG_GRADFULLSCALE
PPAOPTAG_GRADOFFSET


ReadPixelArray

Read the color values of a rectangular array

Declaration

Source position: cybergraphics.pas line 313

function ReadPixelArray(

  destRect: POINTER;

  destX: Word;

  destY: Word;

  destMod: Word;

  a1arg: PRastPort;

  SrcX: Word;

  SrcY: Word;

  SizeX: Word;

  SizeY: Word;

  DestFormat: Byte

):LongWord;

Arguments

destRect | Pointer to an array of pixels where to write the pixel data to. The pixel format is specified in DestFormat
destX | X starting point in the destination rectangle
destY | Y starting point in the destination rectangle
destMod | The number of bytes per row in the destination rectangle.
a1arg | Pointer to a RastPort structure
SrcX | X starting point in the RastPort
SrcY | Y starting point in the RastPort
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered
DestFormat | pixel format in the destination rectangle Currently supported formats are: RECTFMT_RGB, RECTFMT_RGBA, RECTFMT_ARGB

Function result

number of pixels read

Description

Read the color values of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the color value to a linear array of color values from the bitmap used to describe a particular rastport.

Attention

This function should only be used on screens depths > 8 bits.

Errors

The count value returned is totally wrong.

See also

WritePixelArray | write the color value of a rectangular array
ReadPixelArray8 | read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.


ReadRGBPixel

Reads a pixel from a specified location

Declaration

Source position: cybergraphics.pas line 314

function ReadRGBPixel(

  a1arg: PRastPort;

  x: Word;

  y: Word

):LongWord;

Arguments

a1arg | pointer to a RastPort structure
x | the x coordinate of the pixel
y | the y coordinate of the pixel

Function result

the desired color in AARRGGBB format. Every component allocates 8 bits in the returned longword.

Description

Read the alpha,red,green and blue 8-bit color components of the pixel at a specified x,y location within a certain RastPort

Attention

This function should only be used on screens depths > 8 bits. Use ReadPixel() on 8 bit screens!

See also

WriteRGBPixel | Writes a pixel to a specified location
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.


ScalePixelArray

Scale the colors values of a rectangular array (V41)

Declaration

Source position: cybergraphics.pas line 315

function ScalePixelArray(

  srcRect: POINTER;

  SrcW: Word;

  SrcH: Word;

  SrcMod: Word;

  a1arg: PRastPort;

  DestX: Word;

  DestY: Word;

  DestW: Word;

  DestH: Word;

  SrcFormat: Byte

):LongInt;

Arguments

srcRect | Pointer to an array of pixels from which to fetch the pixel data. The pixel format is specified in SrcFormat
SrcW | Width of the source rectangle
SrcH | Height of the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
a1arg | pointer to a RastPort structure
DestX | starting x point in the RastPort
DestY | starting y point in the RastPort
DestW | Width of the destination area
DestH | Height of the destination area
SrcFormat | pixel format in the source rectangle. Currently supported formats are: RECTFMT_RGB, RECTFMT_RGBA, RECTFMT_ARGB, RECTFMT_LUT8, RECTFMT_GREY8

Function result

number of pixels plotted

Description

Scale the colors values of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, scale the color values from a linear array of color values into the bitmap used to describe a particular rastport.

Attention

Up to v40, this function only worked on screens depths > 8 bits. You may specify RECTFMT_LUT8 on 8bit screens, too now if v41 is available

Errors

Very early v40 revision did not support RECTFMT_LUT8 and RECTFMT_GREY8. Scaling is not very accurate. If you need high quality, use graphics.library/BitMapScale() instead or custom code. The count value returned is totally wrong.

See also

BitMapScale()

Perform raster scaling on a bit map.


ScalePixelArrayAlpha

Scale the colors value of a rectangular array (V51)

Declaration

Source position: cybergraphics.pas line 330

function ScalePixelArrayAlpha(

  srcRect: POINTER;

  SrcW: Word;

  SrcH: Word;

  SrcMod: Word;

  a1arg: PRastPort;

  DestX: Word;

  DestY: Word;

  DestW: Word;

  DestH: Word;

  globalAlpha: LongWord

):LongInt;

Arguments

srcRect | pointer to an array of pixels from which to fetch the pixel data. The pixel format is fixed to RECTFMT_ARGB and the alpha 8bit value is used to blend the data into the target
SrcW | Width of the source rectangle
SrcH | Height of the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
a1arg | pointer to a RastPort structure
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
DestW | Width of the destination area
DestH | Height of the destination area
globalAlpha | 32bit left justified global alpha value, e.g. use $FFFFFFFF for full opacity. This global value is combined with the per pixel alpha of the source rectangle

Description

Scale the colors value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort (v51)

For each pixel in a rectangular region, scale and blend the color values from a linear alpha array of truecolor values into the bitmap used to describe a particular rastport.

This function should only be used on screens depths > 8 bits.

Uses hardware acceleration on dedicated hardware


SHIFT_PIXFMT

Declaration

Source position: cybergraphics.pas line 344

function SHIFT_PIXFMT(

  fmt: LongInt

):LongInt;


UnLockBitMap

Unlock CyberGraphX BitMap that was previously locked

Declaration

Source position: cybergraphics.pas line 316

procedure UnLockBitMap(

  Handle: POINTER

);

Arguments

Handle

handle to the previously locked BitMap

Description

Unlock CyberGraphX BitMap that was previously locked.

See also

LockBitMapTagList

Lock supplied BitMap for a short amount of time to allow direct memory access


UnLockBitMapTagList

Unlock CyberGraphX BitMap that was previously

Declaration

Source position: cybergraphics.pas line 317

procedure UnLockBitMapTagList(

  Handle: POINTER;

  TagList: PTagItem

);

Arguments

Handle | handle to the previously locked BitMap
TagList | pointer to a mandatory taglist

Description

Unlock CyberGraphX BitMap that was previously locked

Available Tags

UBMI_UPDATERECTS

(PRectList) - Pointer to a rectlist which contains rectangles that should be updated. This is needed for cards that don't have a linear display memory address space

The RectList structure looks like this:

TRectList = record
  rl_num: LongWord;     // no. of rects in this list
  rl_next: PRectList;  // pointer to next list
  rect1: TRectangle;   // This is the first
end;
UBMI_REALLYUNLOCK
Specifies whether bitmap should really be unlocked (True) or not (False) in case you just want to update certain rectangles and unlock later.

Errors

Very early v40 revisions did not support this call

See also

LockBitMapTagList | Lock supplied BitMap for a short amount of time to allow direct memory access
UnLockBitMap | Unlock CyberGraphX BitMap that was previously locked


WriteLUTPixelArray

write the color value generated from a given color table (V41)

Declaration

Source position: cybergraphics.pas line 318

function WriteLUTPixelArray(

  srcRect: POINTER;

  SrcX: Word;

  SrcY: Word;

  SrcMod: Word;

  a1arg: PRastPort;

  ColorTab: POINTER;

  DestX: Word;

  DestY: Word;

  SizeX: Word;

  SizeY: Word;

  CTFormat: Byte

):LongWord;

Arguments

srcRect | Pointer to an array of pixels from which to fetch the CLUT data. Pixels are specified in bytes, 8bits/pixel
SrcX | X starting point in the source rectangle
SrcY | Y starting point in the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
a1arg | Pointer to a RastPort structure
ColorTab | pointer to the color table using the format specified with CTabFormat
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered
CTFormat | color table format in the source rectangle Currently supported formats are: CTABFMT_XRGB8

Function result

number of pixels plotted

Description

write the color value generated from a given color table of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the color value generated with a given color lookup table from a linear array of indexed pixel values into the bitmap used to describe a particular rastport.

Attention

Does only work on rastports with depth > 8bits

Errors

The count value returned is totally wrong.

With cgxsystem.library up to version 41.19, the call returns immediately with CTABFMT_XRGB8 due to a bug in the code

See also

ReadPixelArray | Read the color values of a rectangular array
WritePixelArray | write the color value of a rectangular array
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.


WritePixelArray

write the color value of a rectangular array

Declaration

Source position: cybergraphics.pas line 319

function WritePixelArray(

  srcRect: POINTER;

  SrcX: Word;

  SrcY: Word;

  SrcMod: Word;

  a1arg: PRastPort;

  DestX: Word;

  DestY: Word;

  SizeX: Word;

  SizeY: Word;

  SrcFormat: Byte

):LongWord;

Arguments

srcRect | pointer to an array of pixels from which to fetch the pixel data. The pixel format is specified in SrcFormat
SrcX | X starting point in the source rectangle
SrcY | Y starting point in the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
a1arg | Pointer to a RastPort structure
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
SizeX | Widht of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered
SrcFormat | pixel format in the source rectangle. Currently supported formats are: RECTFMT_RGB, RECTFMT_RGBA, RECTFMT_ARGB, RECTFMT_LUT8, RECTFMT_GREY8

Function result

number of pixels plotted

Description

write the color value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the color value from a linear array of color values into the bitmap used to describe a particular rastport.

Attention

Only RECTFMT_LUT8 can be used on screen depths <= 8 bits. For > 8 bit rastport RECTFMT_LUT8 uses the actual colormap "attached" to the bitmap. If the bitmap is a friend bitmap of a screen bitmap or the screen bitmap itself, it uses the screen's viewport colormap.

Errors

The count value returned is totally wrong.

See also

ReadPixelArray | Read the color values of a rectangular array
WriteLUTPixelArray | write the color value generated from a given color table (V41)
WritePixelArray | write the color value of a rectangular array


WritePixelArrayAlpha

Write the color value of a rectangular array

Declaration

Source position: cybergraphics.pas line 323

function WritePixelArrayAlpha(

  srcRect: POINTER;

  SrcX: Word;

  SrcY: Word;

  SrcMod: Word;

  a1arg: PRastPort;

  DestX: Word;

  DestY: Word;

  SizeX: Word;

  SizeY: Word;

  globalAlpha: LongWord

):LongWord;

Arguments

srcRect | pointer to an array of pixels from which to fetch the pixel data. The pixel format is always RECTFMT_ARGB
SrcX | X starting point in the source rectangle
SrcY | Y starting point in the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
a1arg | Pointer to a RastPort structure
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered
globalAlpha | 32 bit unsigned left justified fraction (1.0 = $ffffffff)

Function result

Number of pixels plotted

Description

write the color value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the color value from a linear array of color values into the bitmap used to describe a particular rastport.

Attention

Only currently supported pixelformat is RECTFMT_ARGB


WriteRGBPixel

Writes a pixel to a specified location

Declaration

Source position: cybergraphics.pas line 320

function WriteRGBPixel(

  a1arg: PRastPort;

  x: Word;

  y: Word;

  argb: LongWord

):LongInt;

Arguments

a1arg | Pointer to a RastPort structure
x | X coordinate of the pixel
y | Y coordinate of the pixel
argb | The desired color in AARRGGBB format. Every component allocates 8 bits of the longword.

Function result

error = 0 if pixel succesfully changed

= -1 if (x,y) is outside the rastport

Description

Write the alpha,red,green and blue 8-bit color component of the given color to a specified x,y location within a certain RastPort

Attention

This function should only be used on screens depths > 8 bits. Use WritePixel on 8 bit screens!

See also

ReadRGBPixel | Reads a pixel from a specified location
WritePixel | Change the pen num of one specific pixel in a specified RastPort.


Reference for unit 'datatypes': Procedures and functions

AddDTObject

CopyDTMethods

CopyDTTriggerMethods

DisposeDTObject

DoAsyncLayout

DoDTDomain

DoDTDomainA

DoDTMethod

DoDTMethodA

DrawDTObject

DrawDTObjectA

FindMethod

FindToolNode

FindToolNodeA

FindTriggerMethod

FreeDTMethods

GetDTAttrs

GetDTAttrsA

GetDTMethods

GetDTString

GetDTTriggerMethodDataFlags

GetDTTriggerMethods

InitDatatypesLibrary

LaunchTool

LaunchToolA

LockDataType

NewDTObject

NewDTObjectA

ObtainDataType

ObtainDataTypeA

ObtainDTDrawInfo

ObtainDTDrawInfoA

PrintDTObjectA

RefreshDTObject

RefreshDTObjectA

ReleaseDataType

ReleaseDTDrawInfo

RemoveDTObject

SaveDTObject

SaveDTObjectA

SetDTAttrs

SetDTAttrsA

StartDragSelect


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'datatypes': Variables

DataTypesBase


Index of all identifiers in unit 'datatypes'

A C D F G I L M N O P R S T

A

AddDTObject | ADTA_Height | ADTA_Screen
ADTA_Allocated | ADTA_KeyFrame | ADTA_SparseTable
ADTA_ColorRegisters | ADTA_LeftSample | ADTA_Volume
ADTA_ColorTable | ADTA_ModeID | ADTA_Width
ADTA_ColorTable2 | ADTA_NumAlloc | ADTM_Dummy
ADTA_CRegs | ADTA_NumColors | ADTM_LOADFRAME
ADTA_Cycles | ADTA_NumSparse | ADTM_LOADNEWFORMATFRAME
ADTA_Depth | ADTA_Period | ADTM_LOCATE
ADTA_Dummy | ADTA_PreloadFrameCount | ADTM_PAUSE
ADTA_Frame | ADTA_Remap | ADTM_START
ADTA_FrameIncrement | ADTA_RightSample | ADTM_STOP
ADTA_Frames | ADTA_Sample | ADTM_UNLOADFRAME
ADTA_FramesPerSecond | ADTA_SampleLength | ADTM_UNLOADNEWFORMATFRAME
ADTA_GRegs | ADTA_SamplesPerSec | ANIMATIONDTCLASS

C

cmpByteRun1 | cmpNone | CopyDTTriggerMethods
cmpByteRun2 | CMP_NONE |
CMP_FIBDELTA | CopyDTMethods |

D

DataTypesBase | DTA_ObjName | DTERROR_UNKNOWN_DATATYPE
DATATYPESCLASS | DTA_ObjVersion | DTF_ASCII
DATATYPESNAME | DTA_PrinterProc | DTF_BINARY
DisposeDTObject | DTA_PrinterStatus | DTF_CASE
DoAsyncLayout | DTA_RastPort | DTF_IFF
DoDTDomain | DTA_RelBottom | DTF_MISC
DoDTDomainA | DTA_RelHeight | DTF_SYSTEM1
DoDTMethod | DTA_RelRight | DTF_TYPE_MASK
DoDTMethodA | DTA_RelWidth | DTHSIZE
DrawDTObject | DTA_Repeat | DTM_ABORTPRINT
DrawDTObjectA | DTA_Reserved | DTM_ASYNCLAYOUT
DTA_ARexxPortName | DTA_SelectDomain | DTM_CLEARSELECTED
DTA_BaseName | DTA_SourceAddress | DTM_COPY
DTA_Busy | DTA_SourceSize | DTM_DISPOSEMEMBER
DTA_Conductor | DTA_SourceType | DTM_DRAW
DTA_ControlPanel | DTA_Special | DTM_Dummy
DTA_Data | DTA_Sync | DTM_FRAMEBOX
DTA_DataType | DTA_TextAttr | DTM_GOTO
DTA_DestCols | DTA_TextFont | DTM_NEWMEMBER
DTA_DestRows | DTA_Title | DTM_OBTAINDRAWINFO
DTA_Domain | DTA_Top | DTM_PRINT
DTA_Dummy | DTA_TopHoriz | DTM_PROCLAYOUT
DTA_ErrorLevel | DTA_TopVert | DTM_RELEASEDRAWINFO
DTA_ErrorNumber | DTA_TotalHoriz | DTM_REMOVEDTOBJECT
DTA_ErrorString | DTA_TotalPHoriz | DTM_SELECT
DTA_FrameInfo | DTA_TotalPVert | DTMSG_TYPE_OFFSET
DTA_GroupID | DTA_TotalVert | DTM_TRIGGER
DTA_Handle | DTA_TriggerMethods | DTM_WRITE
DTA_Height | DTA_UserData | DTSIF_DRAGGING
DTA_HorizUnit | DTA_VertUnit | DTSIF_DRAGSELECT
DTA_Immediate | DTA_VisibleHoriz | DTSIF_HIGHLIGHT
DTA_LayoutProc | DTA_VisibleVert | DTSIF_LAYOUT
DTA_Left | DTA_Width | DTSIF_LAYOUTPROC
DTA_Methods | DTERROR_COULDNT_OPEN | DTSIF_NEWSIZE
DTA_Name | DTERROR_COULDNT_OPEN_CLIPBOARD | DTSIF_PRINTING
DTA_NodeName | DTERROR_COULDNT_SAVE | DTST_CLIPBOARD
DTA_NominalHoriz | DTERROR_COULDNT_SEND_MESSAGE | DTST_FILE
DTA_NominalVert | DTERROR_INVALID_DATA | DTST_HOTLINK
DTA_ObjAnnotation | DTERROR_NOT_AVAILABLE | DTST_MEMORY
DTA_ObjAuthor | DTERROR_NOT_ENOUGH_DATA | DTST_RAM
DTA_ObjCopyright | DTERROR_Reserved | DTWM_IFF
DTA_ObjectID | DTERROR_UNKNOWN_COMPRESSION | DTWM_RAW

F

FIF_REMAPPABLE | FindMethod | FindTriggerMethod
FIF_SCALABLE | FindToolNode | FreeDTMethods
FIF_SCROLLABLE | FindToolNodeA |

G

GetDTAttrs | GetDTTriggerMethods | GID_MUSIC
GetDTAttrsA | GID_ANIMATION | GID_PICTURE
GetDTMethods | GID_DOCUMENT | GID_SOUND
GetDTString | GID_INSTRUMENT | GID_SYSTEM
GetDTTriggerMethodDataFlags | GID_MOVIE | GID_TEXT

I

ID_8SVX | ID_CMAP | ID_GRAB
ID_ANHD | ID_CODE | ID_ILBM
ID_ANIM | ID_CRNG | ID_NAME
ID_BMHD | ID_DEST | ID_SPRT
ID_BODY | ID_DLTA | ID_TAGS
ID_CAMG | ID_DTHD | ID_TOOL
ID_CHAN | ID_DTYP | ID_VHDR
ID_CHRS | ID_FTXT | InitDatatypesLibrary

L

LaunchTool | LNF_LINK | LockDataType
LaunchToolA | LNF_OBJECT |
LNF_LF | LNF_SELECTED |

M

mskHasAlpha | mskHasTransparentColor | mskNone
mskHasMask | mskLasso |

N

NewDTObject NewDTObjectA

O

ObtainDataType | ObtainDTDrawInfo
ObtainDataTypeA | ObtainDTDrawInfoA

P

padtFrame | PDTA_DestMode | pdtGeneral
PadtNewFormatFrame | PDTA_Displayable | pdtGoto
padtStart | PDTA_DitherQuality | pDTHookContext
pAnimHeader | PDTA_FreeSourceBitMap | PDTM_Dummy
pBitMapHeader | PDTA_GetNumPictures | pDTMethod
PBPAFMT_ARGB | PDTA_Grab | PDTM_READPIXELARRAY
PBPAFMT_GREY8 | PDTA_GRegs | PDTM_WRITEPIXELARRAY
PBPAFMT_LUT8 | PDTA_MaskPlane | pdtPrint
PBPAFMT_RGB | PDTA_MaxDitherPens | PdtReleaseDrawInfo
PBPAFMT_RGBA | PDTA_ModeID | pdtSelect
pColorRegister | PDTA_NumAlloc | pDTSpecialInfo
pDataType | PDTA_NumColors | pdtTrigger
pDataTypeHeader | PDTANUMPICTURES_Unknown | pdtWrite
PDTA_Allocated | PDTA_NumSparse | pFrameInfo
PDTA_AllocatedPens | PDTA_Remap | PICTUREDTCLASS
PDTA_BitMap | PDTA_ScaleQuality | pLine
PDTA_BitMapHeader | PDTA_Screen | PMODE_V42
PDTA_ClassBitMap | PDTA_SourceMode | PMODE_V43
PDTA_ColorRegisters | PDTA_SparseTable | pprinterIO
PDTA_ColorTable | PDTA_UseFriendBitMap | PrintDTObjectA
PDTA_ColorTable2 | PDTA_WhichPicture | pTool
PDTA_CRegs | pdtDraw | pToolNode
PDTA_DestBitMap | pdtFrameBox | pVoiceHeader

R

RefreshDTObject | ReleaseDataType | RemoveDTObject
RefreshDTObjectA | ReleaseDTDrawInfo |

S

SAMPLETYPE_Left | SDTA_SampleLength | STM_BROWSE_PREV
SAMPLETYPE_Right | SDTA_SamplesPerSec | STM_COMMAND
SAMPLETYPE_Stereo | SDTA_SignalBit | STM_CONTENTS
SaveDTObject | SDTA_SignalBitMask | STM_FASTFORWARD
SaveDTObjectA | SDTA_SignalBitNumber | STM_INDEX
SDTA_Continuous | SDTA_SignalTask | STM_LOCATE
SDTA_Cycles | SDTA_SyncSampleChange | STM_NEXT_FIELD
SDTA_Dummy | SDTA_VoiceHeader | STM_PAUSE
SDTA_FreeSampleData | SDTA_Volume | STM_PLAY
SDTA_LeftSample | SetDTAttrs | STM_PREV_FIELD
SDTA_Pan | SetDTAttrsA | STM_RESUME
SDTA_Period | SOUNDDTCLASS | STM_RETRACE
SDTA_ReplayPeriod | StartDragSelect | STM_REWIND
SDTA_RightSample | STM_ACTIVATE_FIELD | STM_STOP
SDTA_Sample | STM_BROWSE_NEXT |

T

tadtFrame | tdtFrameBox | TF_SHELL
tadtNewFormatFrame | tdtGeneral | TF_WORKBENCH
tadtStart | tdtGoto | tLine
tAnimHeader | tDTHookContext | tprinterIO
tBitMapHeader | tDTMethod | TSIZE
tColorRegister | tdtPrint | tTool
tDataType | TdtReleaseDrawInfo | tToolNode
tDataTypeHeader | tdtSelect | tVoiceHeader
TDTA_Buffer | tDTSpecialInfo | TW_BROWSE
TDTA_BufferLen | tdtTrigger | TW_EDIT
TDTA_LineList | tdtWrite | TW_INFO
TDTA_WordDelim | TEXTDTCLASS | TW_MAIL
TDTA_WordSelect | TF_LAUNCH_MASK | TW_PRINT
TDTA_WordWrap | tFrameInfo |
tdtDraw | TF_RX |


AddDTObject

Declaration

Source position: datatypes.pas line 1273

function AddDTObject(

  Win: PWindow;

  Req: PRequester;

  o: PObject_;

  Pos: LongInt

):LongInt;


CopyDTMethods

Declaration

Source position: datatypes.pas line 1290

function CopyDTMethods(

  Src: LongWord;

  Include: LongWord;

  Exclude: LongWord

):PLongWord;


CopyDTTriggerMethods

Declaration

Source position: datatypes.pas line 1291

function CopyDTTriggerMethods(

  Src: pDTMethod;

  Include: pDTMethod;

  Exclude: pDTMethod

):pDTMethod;


DisposeDTObject

Declaration

Source position: datatypes.pas line 1270

procedure DisposeDTObject(

  o: PObject_

);


DoAsyncLayout

Declaration

Source position: datatypes.pas line 1275

function DoAsyncLayout(

  o: PObject_;

  Gpl: PgpLayout

):LongWord;


DoDTDomain

Declaration

Source position: datatypes.pas line 1309

function DoDTDomain(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  RPort: PRastPort;

  Which: LongWord;

  Domain: PIBox;

  const Attrs: array of LongWord

):LongWord;


DoDTDomainA

Declaration

Source position: datatypes.pas line 1296

function DoDTDomainA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  RPort: PRastPort;

  Which: LongWord;

  Domain: PIBox;

  Attrs: PTagItem

):LongWord;


DoDTMethod

Declaration

Source position: datatypes.pas line 1303

function DoDTMethod(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  const Msg: array of LongWord

):LongWord;


DoDTMethodA

Declaration

Source position: datatypes.pas line 1276

function DoDTMethodA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  Msg: PLongInt

):LongWord;


DrawDTObject

Declaration

Source position: datatypes.pas line 1305

function DrawDTObject(

  Rp: PRastPort;

  o: PObject_;

  x: LongInt;

  y: LongInt;

  w: LongInt;

  h: LongInt;

  th: LongInt;

  tv: LongInt;

  const Attrs: array of LongWord

):LongInt;


DrawDTObjectA

Declaration

Source position: datatypes.pas line 1282

function DrawDTObjectA(

  Rp: PRastPort;

  o: PObject_;

  x: LongInt;

  y: LongInt;

  w: LongInt;

  h: LongInt;

  th: LongInt;

  tv: LongInt;

  Attrs: PTagItem

):LongInt;


FindMethod

Declaration

Source position: datatypes.pas line 1288

function FindMethod(

  Methods: LongWord;

  Id: LongWord

):PLongWord;


FindToolNode

Declaration

Source position: datatypes.pas line 1306

function FindToolNode(

  Tl: PList;

  const Attrs: array of LongWord

):pToolNode;


FindToolNodeA

Declaration

Source position: datatypes.pas line 1286

function FindToolNodeA(

  Tl: PList;

  Attrs: PTagItem

):pToolNode;


FindTriggerMethod

Declaration

Source position: datatypes.pas line 1289

function FindTriggerMethod(

  TriggerMethods: pDTMethod;

  Command: PShortInt;

  Method: LongWord

):pDTMethod;


FreeDTMethods

Declaration

Source position: datatypes.pas line 1292

procedure FreeDTMethods(

  m: Pointer

);


GetDTAttrs

Declaration

Source position: datatypes.pas line 1301

function GetDTAttrs(

  o: PObject_;

  const Attrs: array of LongWord

):LongWord;


GetDTAttrsA

Declaration

Source position: datatypes.pas line 1272

function GetDTAttrsA(

  o: PObject_;

  Attrs: PTagItem

):LongWord;


GetDTMethods

Declaration

Source position: datatypes.pas line 1278

function GetDTMethods(

  o: PObject_

):Pointer;


GetDTString

Declaration

Source position: datatypes.pas line 1284

function GetDTString(

  Id: LongWord

):PChar;


GetDTTriggerMethodDataFlags

Declaration

Source position: datatypes.pas line 1293

function GetDTTriggerMethodDataFlags(

  TriggerMethod: LongWord

):LongWord;


GetDTTriggerMethods

Declaration

Source position: datatypes.pas line 1279

function GetDTTriggerMethods(

  o: PObject_

):pDTMethod;


InitDatatypesLibrary

Declaration

Source position: datatypes.pas line 1311

function InitDatatypesLibrary: Boolean;


LaunchTool

Declaration

Source position: datatypes.pas line 1307

function LaunchTool(

  t: pTool;

  Project: PShortInt;

  const Attrs: array of LongWord

):LongWord;


LaunchToolA

Declaration

Source position: datatypes.pas line 1287

function LaunchToolA(

  t: pTool;

  Project: PShortInt;

  Attrs: PTagItem

):LongWord;


LockDataType

Declaration

Source position: datatypes.pas line 1285

procedure LockDataType(

  Dt: pDataType

);


NewDTObject

Declaration

Source position: datatypes.pas line 1299

function NewDTObject(

  Name: PChar;

  const attrs: array of LongWord

):Pointer;


NewDTObjectA

Declaration

Source position: datatypes.pas line 1269

function NewDTObjectA(

  name: PChar;

  Attrs: PTagItem

):Pointer;


ObtainDataType

Declaration

Source position: datatypes.pas line 1298

function ObtainDataType(

  Typ: LongWord;

  Handle: Pointer;

  const Attrs: array of LongWord

):pDataType;


ObtainDataTypeA

Declaration

Source position: datatypes.pas line 1267

function ObtainDataTypeA(

  Typ: LongWord;

  Handle: POINTER;

  Attrs: PTagItem

):pDataType;


ObtainDTDrawInfo

Declaration

Source position: datatypes.pas line 1304

function ObtainDTDrawInfo(

  o: PObject_;

  const Attrs: array of LongWord

):Pointer;


ObtainDTDrawInfoA

Declaration

Source position: datatypes.pas line 1281

function ObtainDTDrawInfoA(

  o: PObject_;

  Attrs: PTagItem

):Pointer;


PrintDTObjectA

Declaration

Source position: datatypes.pas line 1280

function PrintDTObjectA(

  o: PObject_;

  w: PWindow;

  r: PRequester;

  Msg: pdtPrint

):LongWord;


RefreshDTObject

Declaration

Source position: datatypes.pas line 1302

procedure RefreshDTObject(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  const Attrs: array of LongWord

);


RefreshDTObjectA

Declaration

Source position: datatypes.pas line 1274

procedure RefreshDTObjectA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  Attrs: PTagItem

);


ReleaseDataType

Declaration

Source position: datatypes.pas line 1268

procedure ReleaseDataType(

  Dt: pDataType

);


ReleaseDTDrawInfo

Declaration

Source position: datatypes.pas line 1283

procedure ReleaseDTDrawInfo(

  o: PObject_;

  Handle: Pointer

);


RemoveDTObject

Declaration

Source position: datatypes.pas line 1277

function RemoveDTObject(

  Win: PWindow;

  o: PObject_

):LongInt;


SaveDTObject

Declaration

Source position: datatypes.pas line 1308

function SaveDTObject(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  File_: PChar;

  Mode: LongWord;

  SaveIcon: Boolean;

  const Attrs: array of LongWord

):LongWord;


SaveDTObjectA

Declaration

Source position: datatypes.pas line 1294

function SaveDTObjectA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  File_: PChar;

  Mode: LongWord;

  SaveIcon: Boolean;

  Attrs: PTagItem

):LongWord;


SetDTAttrs

Declaration

Source position: datatypes.pas line 1300

function SetDTAttrs(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  const Attrs: array of LongWord

):LongWord;


SetDTAttrsA

Declaration

Source position: datatypes.pas line 1271

function SetDTAttrsA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  Attrs: PTagItem

):LongWord;


StartDragSelect

Declaration

Source position: datatypes.pas line 1295

function StartDragSelect(

  o: PObject_

):LongWord;


Reference for unit 'diskfont': Procedures and functions

AvailFonts | Inquire available memory and disk fonts.
DisposeFontContents |
GetDiskFontCtrl |
InitDiskFontLibrary
NewFontContents |
NewScaledDiskFont |
OpenDiskFont |
SetDiskFontCtrl
SetDiskFontCtrlA |


Unit 'diskfont' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'diskfont': Variables

DiskfontBase


Index of all identifiers in unit 'diskfont'

A D F G I M N O P S T

A

AFB_BITMAP | AFB_TAGGED | AFF_SCALED
AFB_DISK | AFF_BITMAP | AFF_TAGGED
AFB_MEMORY | AFF_DISK | AvailFonts
AFB_SCALED | AFF_MEMORY |

D

DFCTRL_BASE | DFCTRL_SORT_OFF | DFH_ID
DFCTRL_CACHE | DFCTRL_XDOTP | DiskfontBase
DFCTRL_SORT_ASC | DFCTRL_XDPI | DISKFONTNAME
DFCTRL_SORT_DES | DFCTRL_YDOTP | DisposeFontContents
DFCTRL_SORTMODE | DFCTRL_YDPI |

F

FCH_ID LongInt

G

GetDiskFontCtrl

I

InitDiskFontLibrary

M

MAXFONTNAME MAXFONTPATH

N

NewFontContents NewScaledDiskFont

O

OFCH_ID | OTH_ExtraCompressed | OTSF_DesignedItalic
OpenDiskFont | OTH_ExtraExpanded | OT_ShearCos
OT_AvailSizes | OTH_Normal | OT_ShearSin
OT_BIName | OT_HorizStyle | OTS_Italic
OT_BName | OTH_SemiExpanded | OT_SlantStyle
OT_DesignKernPair | OTH_UltraCompressed | OTS_LeftItalic
OT_DeviceDPI | OT_IName | OTS_Light
OT_DotSize | OT_Indirect | OTS_Medium
OTE_Bullet | OT_InhibitAlgoStyle | OT_SpaceFactor
OT_EmboldenX | OT_IsFixed | OT_SpaceWidth
OT_EmboldenY | OT_Level0 | OT_Spec
OT_Engine | OT_Level1 | OT_Spec1
OTERR_BadData | OT_Level2 | OT_SpecCount
OTERR_BadFace | OT_Level3 | OTS_SemiBold
OTERR_BadGlyph | OT_MAXAVAILSIZES | OTS_SemiLight
OTERR_BadTag | OT_OTagList | OT_StemWeight
OTERR_Failure | OT_OTagPath | OTS_Thin
OTERR_NoFace | OT_PointHeight | OT_StrikeThrough
OTERR_NoGlyph | OT_PointSize | OT_StyleFlags
OTERR_NoMemory | OT_RName | OTSUFFIX
OTERR_NoRotate | OT_RotateCos | OTS_UltraBlack
OTERR_NoShear | OT_RotateSin | OTS_UltraThin
OTERR_Success | OTS_Black | OTS_Upright
OTERR_TooSmall | OTS_Bold | OT_SymbolSet
OTERR_UnknownGlyph | OTS_Book | OT_TextKernPair
OTERR_UnknownTag | OTS_DemiBold | OTUL_Broken
OT_Family | OTS_DemiLight | OTUL_DoubleBroken
OT_FileIdent | OT_SerifFlag | OTUL_DoubleSolid
OT_GlyphCode | OT_SetFactor | OTUL_None
OT_GlyphCode2 | OTS_ExtraBlack | OTUL_Solid
OT_GlyphMap | OTS_ExtraBold | OT_UnderLined
OT_GlyphMap8Bits | OTS_ExtraLight | OT_WidthList
OT_GlyphWidth | OTS_ExtraThin | OT_YSizeFactor
OTH_Compressed | OTSF_AlgoBold | OUTL_DoubleBroken
OTH_Condensed | OTSF_AlgoItalic |
OTH_Expanded | OTSF_DesignedBold |

P

PAvailFonts | PFontContentsHeader | PTAvailFonts
PAvailFontsHeader | PGlyphEngine | PTFontContents
PDiskFontHeader | PGlyphMap |
PFontContents | PGlyphWidthEntry |

S

SetDiskFontCtrl SetDiskFontCtrlA

T

TAvailFonts | TFontContents | TGlyphWidthEntry
TAvailFontsHeader | TFontContentsHeader | TTAvailFonts
TDiskFontHeader | TGlyphEngine | TTFontContents
TFCH_ID | TGlyphMap |


AvailFonts

Inquire available memory and disk fonts.

Declaration

Source position: diskfont.pas line 294

function AvailFonts(

  Buffer: PChar;

  BufBytes: LongInt;

  Flags: LongInt

):LongInt;

Arguments

Buffer | memory to be filled with TAvailFontsHeader followed by an array of TAvailFonts elements, which contains entries for the available fonts and their names.
BufBytes | the number of bytes in the buffer
Flags | AFF_MEMORY is set to search memory for fonts to fill the structure, AFF_DISK is set to search the disk for fonts to fill the structure. AFF_SCALED is set to not filter out memory fonts that are not designed. Any combination may be specified. AFF_TAGGED is set to fill the buffer with TTAvailFonts elements instead of TAvailFonts elements.

Function result

if non-zero, this indicates the number of bytes needed for AvailFonts in addition to those supplied. Thus structure elements were not returned because of insufficient bufBytes.

Description

AvailFonts fills a user supplied buffer with the structure, described below, that contains information about all the fonts available in memory and/or on disk. Those fonts available on disk need to be loaded into memory and opened via OpenDiskFont, those already in memory are accessed via OpenFont. The TTextAttr structure required by the open calls is part of the information AvailFonts supplies.

When AvailFonts fails, it returns the number of extra bytes it needed to complete the command. Add this number to your current buffer size, allocate a new buffer, and try again.


DisposeFontContents

Declaration

Source position: diskfont.pas line 296

procedure DisposeFontContents(

  FontContentsHeader: PFontContentsHeader

);


GetDiskFontCtrl

Declaration

Source position: diskfont.pas line 300

function GetDiskFontCtrl(

  TagID: LongInt

):LongInt;


InitDiskFontLibrary

Declaration

Source position: diskfont.pas line 306

function InitDiskFontLibrary: Boolean;


NewFontContents

Declaration

Source position: diskfont.pas line 295

function NewFontContents(

  FontsLock: LongInt;

  FontName: PChar

):PFontContentsHeader;


NewScaledDiskFont

Declaration

Source position: diskfont.pas line 297

function NewScaledDiskFont(

  SourceFont: PTextFont;

  DestTextAttr: PTextAttr

):PDiskFontHeader;


OpenDiskFont

Declaration

Source position: diskfont.pas line 293

function OpenDiskFont(

  TextAttr: PTextAttr

):PTextFont;


SetDiskFontCtrl

Declaration

Source position: diskfont.pas line 304

procedure SetDiskFontCtrl(

  const Tags: array of PtrUInt

);


SetDiskFontCtrlA

Declaration

Source position: diskfont.pas line 301

procedure SetDiskFontCtrlA(

  TagList: PTagItem

);


Reference for unit 'exec': Procedures and functions

AbortIO | Attempt to abort an in-progress I/O request
AddDevice | Adds a device to the system
AddExecNode |
AddExecNodeA |
AddExecNotify |
AddExecNotifyType |
AddHead | Insert a node at the head of a list
AddIntServer | Adds a interrupt server to the system
AddLibrary | Adds a library to the system
AddMemHandler |
AddMemList | add memory to the system free pool
AddPort | Add a public message port to the system
AddResident |
AddResource | Add a resource to the system
AddSemaphore | Initialize then add a signal semaphore to the system
AddTail | Append node to tail of a list
AddTask | Add a Task to the System
Alert | Alert the user of an error
AllocAbs | Allocate at a given location
Allocate | Allocate a block of memory
AllocateAligned |
AllocEntry | Allocate many regions of memory
AllocMemAligned |
AllocPooled | Allocate memory in a memory pool
AllocPooledAligned |
AllocSignal | Allocate a signal bit
AllocTaskPooled |
AllocTrap | Allocate a processor trap vector
AllocVec | Allocate memory and keep track of the size
AllocVecAligned |
AllocVecDMA |
AllocVecPooled |
AllocVecTaskPooled |
AttemptSemaphore | Try to obtain a Semaphore without blocking
AttemptSemaphoreShared | Try to obtain a Semaphore without blocking in shared mode
AvailMem | Check memory available given certain requirements
AvailPool |
CacheClearE |
CacheClearU |
CacheControl |
CacheFlushDataArea |
CacheFlushDataInstArea |
CacheInvalidDataArea |
CacheInvalidInstArea |
CachePostDMA |
CachePreDMA |
CacheTrashCacheArea |
Cause | Fire and software interrupt
CheckIO | Check status on an I/O request
CloseDevice | Close access to a device.
CloseLibrary | Close access to library
ColdReboot | Reboot the Computer
CopyMem | Copy a given numbers ob bytes in memory
CopyMemQuick | Fast memory copy function
CreateExtIO |
CreateIORequest | Create a structure usable for an I/O request
CreateMsgPort | Create a new message port
CreatePool | Create a new pool for memory allocations
Deallocate | Free a block of memory
Debug | Calls the debugger
DeleteExtIO |
DeleteIORequest | Free an i/O request
DeleteMsgPort | Free a message port
DeletePool | Free a memory pool
Disable | Disable interrupt processing
DoIO | Perform an I/O request and wait for its finish
DumpTaskState |
Enable | Enable interrupt processing
Enqueue | Insert or append node to a system list
execAllocMem | Allocate memory given certain requirements
execFreeMem | Free a memory block with given size
execInsert | Insert a node into a list
FindExecNode |
FindName | Find a node in a system list by name
FindPort | Find a system message port by name
FindResident | Find a resident module by name
FindSemaphore | Find Semaphore by name
FindTask | Find task by name get own task
FindTaskByPID |
FlushPool |
FlushTaskPool |
Forbid | Forbid task scheduling.
FreeEntry | Free many blocks of memory at once
FreePooled | Free pooled memory block
FreeSignal | Free a signal bit
FreeTaskPooled |
FreeTrap | Free a processor trap
FreeVec | Free memory with tracked size made using AllocVec()
FreeVecDMA |
FreeVecPooled |
FreeVecTaskPooled |
GetCC |
GetEmulHandle |
GetMsg | Get next message from message port
InitCode | Initialize resident code modules (internal function)
InitResident | Initialize resident module
InitSemaphore | Initialize a signal semaphore
InitStruct | Initialize memory from a table
MakeFunctions | Construct a function jump table
MakeLibrary | Construct a library
NewCreateLibrary |
NewCreateLibraryTags |
NewCreateTask |
NewCreateTaskA |
NewGetSystemAttrs |
NewGetSystemAttrsA |
NewGetTaskAttrs |
NewGetTaskAttrsA |
NewGetTaskPIDAttrs |
NewGetTaskPIDAttrsA |
NewPPCStackSwap |
NewSetFunction |
NewSetSystemAttrs |
NewSetSystemAttrsA |
NewSetTaskAttrs |
NewSetTaskAttrsA |
NewSetTaskPIDAttrs |
NewSetTaskPIDAttrsA |
ObtainQuickVector | Obtain and install a Quick Interrupt vector
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreList | Get a List of semaphores
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
OldOpenLibrary | Old Version of OpenLibrary (deprecated)
OpenDevice | Open a device for use
OpenLibrary | Open a library to use
OpenResource | Open an resource for use
Permit | Permit task rescheduling.
Procure | Asynchron locking of a semaphore
PutMsg | Put a message to a message port
PutMsgHead |
RawDoFmt | Format data into a character stream.
RawIOInit |
RawMayGetChar |
RawPutChar |
ReadGayle |
REG_A0 |
REG_A1 |
REG_A2 |
REG_A3 |
REG_A4 |
REG_A5 |
REG_A6 |
REG_A7 |
REG_D0 |
REG_D1 |
REG_D2 |
REG_D3 |
REG_D4 |
REG_D5 |
REG_D6 |
REG_D7 |
REG_PC |
REG_SR |
ReleaseSemaphore | Make signal semaphore available to others
ReleaseSemaphoreList | Make a list of semaphores available
RemDevice | Remove a device from the system
RemExecNotify |
RemHead | Remove the head node from a list
RemIntServer | Remove an interrupt server from a server chain
RemLibrary | Remove a library from the system
RemMemHandler | Remove low memory handler from exec
Remove | Remove a node from a list
RemPort | Remove a message port from the system
RemResource | Remove a resource from the system
RemSemaphore | Remove a signal semaphore from the system
RemTail | Remove the tail node from a list
RemTask | Remove a task from the system
ReplyMsg | Put a message to its reply port
SendIO | Initiate an I/O command
SetExcept | Define certain signals to cause exceptions
SetFunction | Change a function vector in a library
SetIntVector | Set a new handler for a system interrupt vector
SetSignal | Define the state of this task's signals
SetSR | Get and/or set processor status register
SetTaskPri | Get and set the priority of a task
ShutdownA |
Signal | Signal a task
StackSwap |
SumKickData |
SumLibrary | Compute and check the checksum on a library
SuperState | Enter supervisor state with user stack
Supervisor | Trap to a short supervisor mode function
TaggedOpenLibrary |
TLSAlloc | VarArgs version of TLSAllocA
TLSAllocA | Allocate Thread-Local Storage index (V51.46)
TLSCallDestructors | Call Thread-Local Storage index destructors for the given task (V51.46)
TLSFree | Free Thread-Local Storage index
TLSGetValue | get the task specific value associated with a given Thread-Local Storage index (V51.46)
TLSSetValue | set the task specific value associated with a given Thread-Local Storage index (V51.46)
TypeOfMem | Determine attributes of a given memory address
UserState | Return to user state with user stack
Vacate | Release a bidMessage from Procure()
VNewRawDoFmt |
Wait | Wait for one or more signals
WaitIO | Wait for completion of an I/O request
WaitPort | Wait for a given port to be non-empty


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'exec': Variables

ExecBase


Index of all identifiers in unit 'exec'

A B C D E F G I L M N O P R S T U V W

A

AbortIO | AllocPooled | AN_MakeVPort
ACPU_AddressErr | AllocPooledAligned | AN_MathLib
ACPU_AutoVec1 | AllocSignal | AN_MemCorrupt
ACPU_AutoVec2 | AllocTaskPooled | AN_MemoryInsane
ACPU_AutoVec3 | AllocTrap | AN_MiscRsrc
ACPU_AutoVec4 | AllocVec | AN_NoConsole
ACPU_AutoVec5 | AllocVecAligned | AN_NoFonts
ACPU_AutoVec6 | AllocVecDMA | AN_NoISem
ACPU_AutoVec7 | AllocVecPooled | AN_NoWindow
ACPU_BusErr | AllocVecTaskPooled | AN_ObsoleteFont
ACPU_CHK | AN_AddSWGadget | AN_OpenScreen
ACPU_DivZero | AN_AsyncPkt | AN_OpenScrnRast
ACPU_Format | AN_AudioDev | AN_OpenWindow
ACPU_InstErr | AN_BadChkSum | AN_PlaneAlloc
ACPU_LineA | AN_BadExpansionFree | AN_QPktFail
ACPU_LineF | AN_BadFreeAddr | AN_RAMLib
ACPU_PrivErr | AN_BadGadget | AN_RegionMemory
ACPU_Spurious | AN_BadInitFunc | AN_SemCorrupt
ACPU_Trace | AN_BadMessage | AN_ShortFrame
ACPU_TRAPV | AN_BadOverlay | AN_StackProbe
AddDevice | AN_BadSegList | AN_StartMem
AddExecNode | AN_BadSemaphore | AN_SubAlloc
AddExecNodeA | AN_BadState | AN_SysScrnType
AddExecNotify | AN_BaseChkSum | AN_TDCalibSeek
AddExecNotifyType | AN_BitMap | AN_TDDelay
AddHead | AN_BltBitMap | AN_TextTmpRas
AddIntServer | AN_BogusExcpt | AN_TimerDev
AddLibrary | AN_BootError | AN_TMBadReq
AddMemHandler | AN_BootStrap | AN_TMBadSupply
AddMemList | AN_CIARsrc | AN_TrackDiskDev
AddPort | AN_ConsoleDev | AN_Unknown
AddResident | AN_CreatePort | AN_UtilityLib
AddResource | AN_DiskBlkSeq | AN_WBBadIOMsg
AddSemaphore | AN_DiskCopy | AN_WBBadStartupMsg1
AddTail | AN_DiskError | AN_WBBadStartupMsg2
AddTask | AN_DiskfontLib | AN_WBReLayoutToolMenu
AFB_68010 | AN_DiskRsrc | AN_WeirdEcho
AFB_68020 | AN_DOSLib | AN_Workbench
AFB_68030 | AN_DRHasDisk | AO_AudioDev
AFB_68040 | AN_DRIntNoAct | AO_BootStrap
AFB_68060 | AN_EndTask | AO_CIARsrc
AFB_68881 | AN_ExcptVect | AO_ConsoleDev
AFB_68882 | AN_ExecLib | AO_DiskCopy
AFB_FPU40 | AN_ExpansionLib | AO_DiskfontLib
AFB_PRIVATE | AN_FileReclosed | AO_DiskRsrc
AFF_68010 | AN_FreeTwice | AO_DOSLib
AFF_68020 | AN_FreeVec | AO_ExecLib
AFF_68030 | AN_GadgetType | AO_ExpansionLib
AFF_68040 | AN_GadTools | AO_GadTools
AFF_68060 | AN_GamePortDev | AO_GamePortDev
AFF_68881 | AN_GfxFreeError | AO_GraphicsLib
AFF_68882 | AN_GfxNewError | AO_IconLib
AFF_FPU40 | AN_GfxNoLCM | AO_Intuition
AFF_PRIVATE | AN_GfxNoMem | AO_KeyboardDev
AG_BadParm | AN_GfxNoMemMspc | AO_KeyMapLib
AG_CloseDev | AN_GraphicsLib | AO_LayersLib
AG_CloseLib | AN_IconLib | AO_MathLib
AG_IOError | AN_InitAPtr | AO_MiscRsrc
AG_MakeLib | AN_IntrMem | AO_RAMLib
AG_MsgPortNotEmpty | AN_Intuition | AO_TimerDev
AG_NoMemory | AN_IOAfterClose | AO_TrackDiskDev
AG_NoSignal | AN_IOUsedTwice | AO_Unknown
AG_OpenDev | AN_ISemOrder | AO_UtilityLib
AG_OpenLib | AN_ItemAlloc | AO_Workbench
AG_OpenRes | AN_ItemBoxTop | Pointer
AG_ProcCreate | AN_KeyboardDev | AT_DeadEnd
Alert | AN_KeyFree | AT_Recovery
AllocAbs | AN_KeyRange | AttemptSemaphore
Allocate | AN_LayersLib | AttemptSemaphoreShared
AllocateAligned | AN_LayersNoMem | AvailMem
AllocEntry | AN_LibChkSum | AvailPool
AllocMemAligned | AN_LongFrame |

B

SmallInt LongInt LongInt

C

CacheClearE | CACRF_EnableE | CMD_RESET
CacheClearU | CACRF_EnableI | CMD_START
CacheControl | CACRF_FreezeD | CMD_STOP
CacheFlushDataArea | CACRF_FreezeI | CMD_UPDATE
CacheFlushDataInstArea | CACRF_IBE | CMD_WRITE
CacheInvalidDataArea | CACRF_WriteAllocate | CODETYPE_M68K
CacheInvalidInstArea | Cause | CODETYPE_PPC
CachePostDMA | CheckIO | ColdReboot
CachePreDMA | CloseDevice | CopyMem
CacheTrashCacheArea | CloseLibrary | CopyMemQuick
CACRF_ClearD | CMD_CLEAR | CPUTBSTACKTRACECOUNT
CACRF_ClearI | CMD_FLUSH | CreateExtIO
CACRF_CopyBack | CMD_INVALID | CreateIORequest
CACRF_DBE | CMD_NONSTD | CreateMsgPort
CACRF_EnableD | CMD_READ | CreatePool

D

Deallocate | DeleteExtIO | Disable
Debug | DeleteIORequest | DMA_Continue
DEFAULT_M68KSTACKSIZE | DeleteMsgPort | DMA_NoModify
DEFAULT_PPCSTACKSIZE | DeletePool | DMA_ReadFromRAM
DEFAULT_TASKPUDDLESIZE | DEV_ABORTIO | DoIO
DEFAULT_TASKTHRESHSIZE | DEV_BEGINIO | DumpTaskState

E

EMULTAG_EMULHANDLE | EXECDEBUGF_CYBERGUARDDEADLY | EXECDEBUGF_RAMLIB
EMULTAG_EMULHANDLESIZE | EXECDEBUGF_EXCEPTHANDLER | EXECDEBUGF_REMTASK
EMULTAG_NAME | EXECDEBUGF_FINDRESIDENT | EXECDEBUGF_SETFUNCTION
EMULTAG_OPCODETABLE | EXECDEBUGF_GETTASKATTR | EXECDEBUGF_SETTASKATTR
EMULTAG_REVISION | EXECDEBUGF_INIT | EXECDEBUGF_UNLOADSEG
EMULTAG_SUPERHANDLE | EXECDEBUGF_INITCODE | execFreeMem
EMULTAG_SUPERHANDLESIZE | EXECDEBUGF_INITRESIDENT | execInsert
EMULTAG_TYPE | EXECDEBUGF_LOADSEG | EXECLIST_DEVICE
EMULTAG_VERSION | EXECDEBUGF_LOG | EXECLIST_INTERRUPT
Enable | EXECDEBUGF_LOGFILE | EXECLIST_LIBRARY
Enqueue | EXECDEBUGF_LOGKPRINTF | EXECLIST_MEMHANDLER
execAllocMem | EXECDEBUGF_MEMTRACK | EXECLIST_MEMHEADER
ExecBase | EXECDEBUGF_NEWSETFUNCTION | EXECLIST_PORT
EXECDEBUGF_ADDDOSNODE | EXECDEBUGF_NOLOGSERVER | EXECLIST_RESOURCE
EXECDEBUGF_ADDTASK | EXECDEBUGF_NOLOGWINDOW | EXECLIST_SEMAPHORE
EXECDEBUGF_CGXDEBUG | EXECDEBUGF_PCI | EXECLIST_TASK
EXECDEBUGF_CHIPRAM | EXECDEBUGF_PERMMEMTRACK | EXECNOTIFYF_POST
EXECDEBUGF_CREATELIBRARY | EXECDEBUGF_PPCSTART | EXECNOTIFYF_REMOVE

F

FindExecNode | FreeSignal | FUNCARRAY_32BIT_NR_NATIVE
FindName | FreeTaskPooled | FUNCARRAY_32BIT_QUICK_NATIVE
FindPort | FreeTrap | FUNCARRAY_32BIT_QUICKNR_NATIVE
FindResident | FreeVec | FUNCARRAY_32BIT_RESTORE_NATIVE
FindSemaphore | FreeVecDMA | FUNCARRAY_32BIT_SR_NATIVE
FindTask | FreeVecPooled | FUNCARRAY_32BIT_SRNR_NATIVE
FindTaskByPID | FreeVecTaskPooled | FUNCARRAY_32BIT_SYSTEMV
FlushPool | FUNCARRAY_16BIT_OLD | FUNCARRAY_BEGIN
FlushTaskPool | FUNCARRAY_32BIT_D0D1A0A1SR_NATIVE | FUNCARRAY_END
Forbid | FUNCARRAY_32BIT_D0D1_NATIVE | FUNCENTRYEXTF_LIBRARY
FreeEntry | FUNCARRAY_32BIT_D0D1SR_NATIVE | FUNCENTRYEXTF_SETFUNCTION
FreePooled | FUNCARRAY_32BIT_NATIVE |

G

GetCC GetEmulHandle GetMsg

I

InitCode | IOB_QUICK | IOERR_OPENFAIL
InitResident | IOERR_ABORTED | IOERR_SELFTEST
InitSemaphore | IOERR_BADADDRESS | IOERR_UNITBUSY
InitStruct | IOERR_BADLENGTH | IOF_QUICK
INTB_NMI | IOERR_NOCMD | PtrUInt
INTF_NMI | IOERR_NOMEMORY |

L

LFalse | LIB_NONSTD | LIBTAG_PUBLIC
LIB_BASE | LIB_OPEN | LIBTAG_QUERYINFO
LIB_CLOSE | LIB_RESERVED | LIBTAG_REVISION
LIB_EXPUNGE | LIBTAG_BASE | LIBTAG_SEGLIST
LIB_EXTFUNC | LIBTAG_BASESIZE | LIBTAG_STRUCTINIT
LIBF_CHANGED | LIBTAG_FLAGS | LIBTAG_TYPE
LIBF_DELEXP | LIBTAG_FUNCTIONINIT | LIBTAG_VERSION
LIBF_QUERYINFO | LIBTAG_IDSTRING | LIB_USERDEF
LIBF_RAMLIB | LIBTAG_LIBRARYINIT | LIB_VECTSIZE
LIBF_SUMMING | LIBTAG_MACHINE | LongInt
LIBF_SUMUSED | LIBTAG_NAME | LongWord
LIB_GETQUERYATTR | LIBTAG_PRI | LTrue

M

MACHINE_M68k | MEMF_24BITDMA | MEMF_NO_EXPUNGE
MACHINE_NO | MEMF_31BIT | MEMF_PUBLIC
MACHINE_PPC | MEMF_ANY | MEMF_REVERSE
MakeFunctions | MEMF_CHIP | MEMF_SEM_PROTECTED
MakeLibrary | MEMF_CLEAR | MEMF_SWAP
MEM_ALL_DONE | MEMF_FAST | MEMF_TOTAL
MEM_BLOCKMASK | MEMF_KICK | MEMHF_RECYCLE
MEM_BLOCKSIZE | MEMF_LARGEST | MEM_TRY_AGAIN
MEM_DID_NOTHING | MEMF_LOCAL |

N

NewCreateLibrary | NewSetTaskAttrs | NT_MEMORY
NewCreateLibraryTags | NewSetTaskAttrsA | NT_MESSAGE
NewCreateTask | NewSetTaskPIDAttrs | NT_MSGPORT
NewCreateTaskA | NewSetTaskPIDAttrsA | NT_PROCESS
NewGetSystemAttrs | NT_BOOTNODE | NT_REPLYMSG
NewGetSystemAttrsA | NT_DEATHMESSAGE | NT_RESOURCE
NewGetTaskAttrs | NT_DEVICE | NT_SEMAPHORE
NewGetTaskAttrsA | NT_EXTENDED | NT_SIGNALSEM
NewGetTaskPIDAttrs | NT_FONT | NT_SOFTINT
NewGetTaskPIDAttrsA | NT_FREEMSG | NT_TASK
NewPPCStackSwap | NT_GRAPHICS | NT_UNKNOWN
NewSetFunction | NT_INTERRUPT | NT_USER
NewSetSystemAttrs | NT_KICKMEM |
NewSetSystemAttrsA | NT_LIBRARY |

O

ObtainQuickVector | ObtainSemaphoreShared | OpenLibrary
ObtainSemaphore | OldOpenLibrary | OpenResource
ObtainSemaphoreList | OpenDevice |

P

PA_IGNORE | PIntVector | PResident
PAPTR | PIORequest | Procure
PA_SIGNAL | PIOStdReq | PSemaphoreMessage
PA_SOFTINT | PLibrary | PSemaphoreRequest
PDevice | PList | PSignalSemaphore
PEmulHandle | PLONG | PSoftIntList
PEmulLibEntry | PLONGBITS | PStackSwapStruct
Permit | PMemChunk | Pointer
PETask | PMemEntry | PTask
PExecBase | PMemHandlerData | PTaskFrame68k
PExecNotifyMessage | PMemHeader | PTaskInitExtension
PF_ACTION | PMemList | PTaskTrapMessage
PFreeBlocksData | PMessage | PTaskTrapMessage_68k
PFuncEntry | PMinList | PULONG
PFuncOldEntry | PMinNode | PUnit
Pointer | PMsgPort | PutMsg
PID_CURRENT | PNode | PutMsgHead
PInterrupt | PPPCStackSwapArgs |

R

RawDoFmt | REG_A7 | RemDevice
RAWFMTFUNC_COUNT | regD0 | RemExecNotify
RAWFMTFUNC_SERIAL | REG_D0 | RemHead
RAWFMTFUNC_STRING | regD1 | RemIntServer
RawIOInit | REG_D1 | RemLibrary
RawMayGetChar | regD2 | RemMemHandler
RawPutChar | REG_D2 | Remove
ReadGayle | regD3 | RemPort
regA0 | REG_D3 | RemResource
REG_A0 | regD4 | RemSemaphore
regA1 | REG_D4 | RemTail
REG_A1 | regD5 | RemTask
regA2 | REG_D5 | ReplyMsg
REG_A2 | regD6 | RTC_MATCHWORD
regA3 | REG_D6 | RTF_AFTERDOS
REG_A3 | regD7 | RTF_AUTOINIT
regA4 | REG_D7 | RTF_COLDSTART
REG_A4 | regPC | RTF_EXTENDED
regA5 | REG_PC | RTF_PPC
REG_A5 | regSR | RTF_SINGLETASK
regA6 | REG_SR | RTW_COLDSTART
REG_A6 | ReleaseSemaphore | RTW_NEVER
regA7 | ReleaseSemaphoreList |

S

SAL_Dummy | SIH_PRIMASK | SYSTEMINFOTYPE_PPC_CACHEL2TYPE
SAL_Name | PtrInt | SYSTEMINFOTYPE_PPC_CACHEL3FLAGS
SAL_Priority | SM_EXCLUSIVE | SYSTEMINFOTYPE_PPC_CACHEL3TYPE
SAL_Type | SM_SHARED | SYSTEMINFOTYPE_PPC_CPUCLOCK
SB_SAR | StackSwap | SYSTEMINFOTYPE_PPC_CPUREVISION
SB_SINT | PChar | SYSTEMINFOTYPE_PPC_CPUTEMP
SB_TQE | SumKickData | SYSTEMINFOTYPE_PPC_CPUVERSION
SendIO | SumLibrary | SYSTEMINFOTYPE_PPC_DABR
SetExcept | SuperState | SYSTEMINFOTYPE_PPC_DATASTREAM
SETFUNCTAG_DELETE | Supervisor | SYSTEMINFOTYPE_PPC_DCACHEL1LINES
SETFUNCTAG_Dummy | SYSTEMINFOTAG_CPUINDEX | SYSTEMINFOTYPE_PPC_DCACHEL1LINESIZE
SETFUNCTAG_IDNAME | SYSTEMINFOTAG_DUMMY | SYSTEMINFOTYPE_PPC_DCACHEL1SIZE
SETFUNCTAG_MACHINE | SYSTEMINFOTAG_HOOK | SYSTEMINFOTYPE_PPC_DCACHEL2LINES
SETFUNCTAG_TYPE | SYSTEMINFOTAG_MEMHEADER | SYSTEMINFOTYPE_PPC_DCACHEL2LINESIZE
SetFunction | SYSTEMINFOTYPE_ALERTMSGPORT | SYSTEMINFOTYPE_PPC_DCACHEL2SIZE
SETFUNCTYPE_NORMAL | SYSTEMINFOTYPE_CPUCOUNT | SYSTEMINFOTYPE_PPC_DCACHEL3LINES
SETFUNCTYPE_NORMALD0_D1 | SYSTEMINFOTYPE_CPUFAMILYNAME | SYSTEMINFOTYPE_PPC_DCACHEL3LINESIZE
SETFUNCTYPE_NORMALD0D1A0A1SR | SYSTEMINFOTYPE_CPUNAME | SYSTEMINFOTYPE_PPC_DCACHEL3SIZE
SETFUNCTYPE_NORMALD0D1SR | SYSTEMINFOTYPE_CPUTIME | SYSTEMINFOTYPE_PPC_FPU
SETFUNCTYPE_NORMALNR | SYSTEMINFOTYPE_EMULATION_SIZE | SYSTEMINFOTYPE_PPC_ICACHEL1LINES
SETFUNCTYPE_NORMALRESTORE | SYSTEMINFOTYPE_EMULATION_START | SYSTEMINFOTYPE_PPC_ICACHEL1LINESIZE
SETFUNCTYPE_NORMALSR | SYSTEMINFOTYPE_EMULHANDLESIZE | SYSTEMINFOTYPE_PPC_ICACHEL1SIZE
SETFUNCTYPE_NORMALSRNR | SYSTEMINFOTYPE_EXCEPTIONMSGPORT | SYSTEMINFOTYPE_PPC_ICACHEL2LINES
SETFUNCTYPE_QUICK | SYSTEMINFOTYPE_EXCEPTIONMSGPORT_68K | SYSTEMINFOTYPE_PPC_ICACHEL2LINESIZE
SETFUNCTYPE_QUICKNR | SYSTEMINFOTYPE_FREEBLOCKS | SYSTEMINFOTYPE_PPC_ICACHEL2SIZE
SETFUNCTYPE_SYSTEMV | SYSTEMINFOTYPE_INVOLUNTARYCSW | SYSTEMINFOTYPE_PPC_ICACHEL3LINES
SetIntVector | SYSTEMINFOTYPE_LASTSECCPUTIME | SYSTEMINFOTYPE_PPC_ICACHEL3LINESIZE
SetSignal | SYSTEMINFOTYPE_LASTSECINVOLUNTARYCSW | SYSTEMINFOTYPE_PPC_ICACHEL3SIZE
SetSR | SYSTEMINFOTYPE_LASTSECTICKS | SYSTEMINFOTYPE_PPC_PERFMONITOR
SetTaskPri | SYSTEMINFOTYPE_LASTSECVOLUNTARYCSW | SYSTEMINFOTYPE_PPC_RESERVATIONSIZE
SF_SAR | SYSTEMINFOTYPE_LAUNCHTIMETICKS | SYSTEMINFOTYPE_PPC_TLBENTRIES
SF_SINT | SYSTEMINFOTYPE_LAUNCHTIMETICKS1978 | SYSTEMINFOTYPE_PPC_TLBSETS
SF_TQE | SYSTEMINFOTYPE_LOADAVG1 | SYSTEMINFOTYPE_RECENTCPUTIME
ShutdownA | SYSTEMINFOTYPE_LOADAVG2 | SYSTEMINFOTYPE_RECENTTICKS
SIGB_ABORT | SYSTEMINFOTYPE_LOADAVG3 | SYSTEMINFOTYPE_REGUSER
SIGB_BLIT | SYSTEMINFOTYPE_MACHINE | SYSTEMINFOTYPE_REVISION
SIGB_CHILD | SYSTEMINFOTYPE_MAGIC1 | SYSTEMINFOTYPE_SYSTEM
SIGB_DOS | SYSTEMINFOTYPE_MAGIC2 | SYSTEMINFOTYPE_TASKEXITCODE
SIGB_INTUITION | SYSTEMINFOTYPE_MAXALERTCOUNT | SYSTEMINFOTYPE_TASKEXITCODE_M68K
SIGB_NET | SYSTEMINFOTYPE_MAXHITCOUNT | SYSTEMINFOTYPE_TASKSCREATED
SIGB_SINGLE | SYSTEMINFOTYPE_MODULE_SIZE | SYSTEMINFOTYPE_TASKSFINISHED
SIGF_ABORT | SYSTEMINFOTYPE_MODULE_START | SYSTEMINFOTYPE_TASKSRUNNING
SIGF_BLIT | SYSTEMINFOTYPE_PAGESIZE | SYSTEMINFOTYPE_TASKSSLEEPING
SIGF_CHILD | SYSTEMINFOTYPE_PPC_ALTIVEC | SYSTEMINFOTYPE_TBCLOCKFREQUENCY
SIGF_DOS | SYSTEMINFOTYPE_PPC_BUSCLOCK | SYSTEMINFOTYPE_UPTIMETICKS
SIGF_INTUITION | SYSTEMINFOTYPE_PPC_BUSTICKS | SYSTEMINFOTYPE_VENDOR
SIGF_NET | SYSTEMINFOTYPE_PPC_CACHEL1FLAGS | SYSTEMINFOTYPE_VOLUNTARYCSW
SIGF_SINGLE | SYSTEMINFOTYPE_PPC_CACHEL1TYPE |
Signal | SYSTEMINFOTYPE_PPC_CACHEL2FLAGS |

T

TaggedOpenLibrary | TASKINFOTYPE_SPUPPER_M68K | TIORequest
TAG_USER | TASKINFOTYPE_STACKSIZE | TIOStdReq
TAlertMessage | TASKINFOTYPE_STACKSIZE_M68K | TLibrary
TASKERROR_NOMEMORY | TASKINFOTYPE_STARTUPMSG | TList
TASKERROR_OK | TASKINFOTYPE_STATE | TLSAlloc
TASKINFOTAG_DUMMY | TASKINFOTYPE_TASKMSGPORT | TLSAllocA
TASKINFOTAG_HOOK | TASKINFOTYPE_TRAPCODE | TLSCallDestructors
TASKINFOTAG_REGCOUNT | TASKINFOTYPE_TRAPDATA | TLSFree
TASKINFOTAG_REGSTART | TASKINFOTYPE_TRAPMSGPORT | TLSGetValue
TASKINFOTYPE_68K_NEWFRAME | TASKINFOTYPE_TYPE | TLS_INVALID_INDEX
TASKINFOTYPE_AGETICKS | TASKINFOTYPE_USEDSTACKSIZE | TLSSetValue
TASKINFOTYPE_ALERTCOUNT | TASKINFOTYPE_USEDSTACKSIZE_M68K | TLSTAG_DESTRUCTOR
TASKINFOTYPE_ALLTASK | TASKINFOTYPE_USERDATA | TLSTAG_DUMMY
TASKINFOTYPE_CPUTIME | TASKINFOTYPE_VOLUNTARYCSW | TLSTAG_USERDATA
TASKINFOTYPE_EMULHANDLE | TASKTAG_CODETYPE | TMemChunk
TASKINFOTYPE_EXCEPTCODE | TASKTAG_DUMMY | TMemEntry
TASKINFOTYPE_EXCEPTDATA | TASKTAG_ERROR | TMemHandlerData
TASKINFOTYPE_EXCEPTIONCOUNT | TASKTAG_FINALPC | TMemHeader
TASKINFOTYPE_FLAGS | TASKTAG_FLAGS | TMemList
TASKINFOTYPE_HITCOUNT | TASKTAG_NAME | TMessage
TASKINFOTYPE_INVOLUNTARYCSW | TASKTAG_PC | TMinList
TASKINFOTYPE_LASTSECCPUTIME | TASKTAG_POOLPUDDLE | TMinNode
TASKINFOTYPE_LASTSECINVOLUNTARYCSW | TASKTAG_POOLTHRESH | TMsgPort
TASKINFOTYPE_LASTSECVOLUNTARYCSW | TASKTAG_PPC_ARG1 | TNode
TASKINFOTYPE_LAUNCHTIMETICKS | TASKTAG_PPC_ARG2 | TPPCStackSwapArgs
TASKINFOTYPE_LAUNCHTIMETICKS1978 | TASKTAG_PPC_ARG3 | TRAP_AREA_START
TASKINFOTYPE_MAXALERTCOUNT | TASKTAG_PPC_ARG4 | TRAP_EIEIO
TASKINFOTYPE_MAXHITCOUNT | TASKTAG_PPC_ARG5 | TRAP_ISYNC
TASKINFOTYPE_NAME | TASKTAG_PPC_ARG6 | TRAP_LIB
TASKINFOTYPE_NAMECOPY | TASKTAG_PPC_ARG7 | TRAP_LIBD0_D1
TASKINFOTYPE_NICE | TASKTAG_PPC_ARG8 | TRAP_LIBD0D1A0A1SR
TASKINFOTYPE_PID | TASKTAG_PRI | TRAP_LIBD0D1SR
TASKINFOTYPE_PID_CLI | TASKTAG_STACKSIZE | TRAP_LIBNR
TASKINFOTYPE_POOLMEMFLAGS | TASKTAG_STACKSIZE_M68K | TRAP_LIBNR_QUICK
TASKINFOTYPE_POOLPTR | TASKTAG_STARTUPMSG | TRAP_LIB_QUICK
TASKINFOTYPE_POOLPUDDLESIZE | TASKTAG_TASKMSGPORT | TRAP_LIBRESTORE
TASKINFOTYPE_POOLTHRESHSIZE | TASKTAG_TCBEXTRASIZE | TRAP_LIBSR
TASKINFOTYPE_PPC_CR | TASKTAG_USERDATA | TRAP_LIBSRNR
TASKINFOTYPE_PPC_CTR | TB_ETASK | TRAP_MASK
TASKINFOTYPE_PPC_FPR | TB_EXCEPT | TRAP_SYNC
TASKINFOTYPE_PPC_FPSCR | TB_LAUNCH | TResident
TASKINFOTYPE_PPC_FRAME | TB_PROCTIME | TS_ADDED
TASKINFOTYPE_PPC_FRAMESIZE | TB_STACKCHK | TSemaphoreMessage
TASKINFOTYPE_PPC_GPR | TB_SWITCH | TSemaphoreRequest
TASKINFOTYPE_PPC_LR | TDevice | TS_EXCEPT
TASKINFOTYPE_PPC_NEWFRAME | TEmulHandle | TSignalSemaphore
TASKINFOTYPE_PPC_SRR0 | TEmulLibEntry | TS_INVALID
TASKINFOTYPE_PPC_SRR1 | TEmulRegs | TSoftIntList
TASKINFOTYPE_PPC_VMX | TETask | TS_READY
TASKINFOTYPE_PPC_VSAVE | TExecBase | TS_REMOVED
TASKINFOTYPE_PPC_VSCR | TExecNotifyMessage | TS_RUN
TASKINFOTYPE_PPC_XER | TF_ETASK | TStackSwapStruct
TASKINFOTYPE_PRI | TF_EXCEPT | TS_WAIT
TASKINFOTYPE_RECENTCPUTIME | TF_LAUNCH | TTask
TASKINFOTYPE_RESURRECT_TASK | TF_PROCTIME | TTaskFrame68k
TASKINFOTYPE_SIGALLOC | TFreeBlocksData | TTaskInitExtension
TASKINFOTYPE_SIGEXCEPT | TF_STACKCHK | TTaskTrapMessage
TASKINFOTYPE_SIGRECVD | TF_SWITCH | TTaskTrapMessage_68k
TASKINFOTYPE_SIGWAIT | TFuncEntry | TUnit
TASKINFOTYPE_SPLOWER | TFuncOldEntry | TypeOfMem
TASKINFOTYPE_SPLOWER_M68K | TInterrupt |
TASKINFOTYPE_SPUPPER | TIntVector |

U

Byte | UNITF_ACTIVE | UserState
LongWord | UNITF_INTASK | Word

V

Vacate | VERSION_TASKTRAPMESSAGE | VNewRawDoFmt
VERSION_ALERTMESSAGE | VERSION_TASKTRAPMESSAGE_68k |

W

Wait | WaitPort | PWideChar
WaitIO | Word |


AbortIO

Attempt to abort an in-progress I/O request

Declaration

Source position: exec.pas line 2010

procedure AbortIO(

  ioRequest: PIORequest

);

Arguments

ioRequest

Pointer to an I/O request block (must have been used at least once. May be active or finished).

Description

Ask a device to abort a previously started IORequest. This is done by calling the device's ABORTIO vector, with your given IORequest.

AbortIO() is a command the device that may or may not grant. If successful, the device will stop processing the IORequest, and reply to it earlier than it would otherwise have done.

NOTE:

AbortIO() does NOT Remove() the IORequest from your ReplyPort, OR wait for it to complete. After an AbortIO() you must wait normally for the reply message before actually reusing the request.

If a request has already completed when AbortIO() is called, no action is taken.

Snippet:

AbortIO(timer_request);
WaitIO(timer_request);
// Message is free to be reused

See also

SendIO | Initiate an I/O command
WaitIO | Wait for completion of an I/O request
DoIO | Perform an I/O request and wait for its finish


AddDevice

Adds a device to the system

Declaration

Source position: exec.pas line 1983

procedure AddDevice(

  device: PDevice

);

Arguments

device

Pointer to a initialized device structure

Description

This function adds a new device to the system device list, making it available to other programs. The device must be ready to be opened at this time.

See also

RemDevice | Remove a device from the system
OpenDevice | Open a device for use
CloseDevice | Close access to a device.
MakeLibrary | Construct a library


AddExecNode

Declaration

Source position: exec.pas line 2359

function AddExecNode(

  InNode: Pointer;

  const Tags: array of PtrUInt

):Pointer;


AddExecNodeA

Declaration

Source position: exec.pas line 2313

function AddExecNodeA(

  innode: Pointer;

  TagItems: Pointer

):Pointer;


AddExecNotify

Declaration

Source position: exec.pas line 2303

procedure AddExecNotify(

  hook: Pointer

);


AddExecNotifyType

Declaration

Source position: exec.pas line 2337

procedure AddExecNotifyType(

  Hook: Pointer;

  Type_: LongInt

);


AddHead

Insert a node at the head of a list

Declaration

Source position: exec.pas line 1874

procedure AddHead(

  list: PList;

  node: PNode

);

Arguments

list | Pointer to list to which the node should be inserted
node | Pointer to node to insert

Description

This function inserts a node at the head of the list. The node will be the first node in the list after this function.

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.

See also

Exec.ExecInsert | Insert a node into a list
Remove | Remove a node from a list
RemHead | Remove the head node from a list
AddTail | Append node to tail of a list
RemTail | Remove the tail node from a list
Enqueue | Insert or append node to a system list


AddIntServer

Adds a interrupt server to the system

Declaration

Source position: exec.pas line 1825

procedure AddIntServer(

  intNumber: LongInt;

  interrupt: PInterrupt

);

Arguments

intNumber

Number of Interrupt

Description

This function adds a new interrupt server to a given server chain. The node is located on the chain in a priority dependent position. If this is the first server on a particular chain, interrupts will be enabled for that chain.

See also

RemIntServer | Remove an interrupt server from a server chain
Cause | Fire and software interrupt


AddLibrary

Adds a library to the system

Declaration

Source position: exec.pas line 1963

procedure AddLibrary(

  libHandle: PLibrary

);

Description

This function adds a new library to the library list. All programs can open it from now on. This function also calculates the checksum of the library.

See also

MakeLibrary | Construct a library
OpenLibrary | Open a library to use
RemLibrary | Remove a library from the system
CloseLibrary | Close access to library


AddMemHandler

Declaration

Source position: exec.pas line 2187

procedure AddMemHandler(

  memhand: PInterrupt

);


AddMemList

add memory to the system free pool

Declaration

Source position: exec.pas line 2085

procedure AddMemList(

  size: Cardinal;

  attributes: Cardinal;

  pri: LongInt;

  base: Pointer;

  name: PChar

);

Arguments

size | the size (in bytes) of the memory area
attributes | the attributes word that the memory pool will have
pri | the priority for this memory. The higher the priority, the closer to the head of the memory list it will be placed.
base | the base of the new memory area
name | the name that will be used in the memory header, or nil if no name is to be provided. This name is not copied, so it must remain valid for as long as the memory header is in the system.

Description

Add a new region of memory to the system free pool. The first few bytes will be used to hold the MemHeader structure. The remainder will be made available to the rest of the world.

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


AddPort

Add a public message port to the system

Declaration

Source position: exec.pas line 1941

procedure AddPort(

  port: PMsgPort

);

Arguments

port

Pointer to a message port

Description

This function attaches a message port structure to the system's public message port list, where it can be found by the FindPort() function. The name and priority fields of the port structure must be initialized prior to calling this function. If the user does not require the priority field, it should be initialized to zero.

Only ports that will be searched for with FindPort() need to be added to the system list. In addition, adding ports is often useful during debugging. If the port will be searched for, the priority field should be at least 1 (to avoid the large number of inactive ports at priority zero). If the port will be searched for often, set the priority in the 50-100 range (so it will be before other less used ports).

Once a port has been added to the naming list, you must be careful to remove the port from the list (via RemPort()) before deallocating its memory.

Do not AddPort an active port.

See also

RemPort | Remove a message port from the system
FindPort | Find a system message port by name


AddResident

Declaration

Source position: exec.pas line 2330

function AddResident(

  resident: PResident

):LongInt;


AddResource

Add a resource to the system

Declaration

Source position: exec.pas line 2013

procedure AddResource(

  resource: Pointer

);

Arguments

resource

Pointer an initialized resource node

Description

This function adds a new resource to the system and makes it available to other users. The resource must be ready to be called at this time.

Resources currently have no system-imposed structure, however they must start with a standard named node (LN_SIZE), and should with a standard Library node (LIB_SIZE).

See also

RemResource | Remove a resource from the system
OpenResource | Open an resource for use
MakeLibrary | Construct a library


AddSemaphore

Initialize then add a signal semaphore to the system

Declaration

Source position: exec.pas line 2076

procedure AddSemaphore(

  sigSem: PSignalSemaphore

);

Arguments

sigSem

An signal semaphore structure

Description

This function attaches a signal semaphore structure to the system's public signal semaphore list. The name and priority fields of the semaphore structure must be initialized prior to calling this function. If you do not want to let others rendezvous with this semaphore, use InitSemaphore() instead.

If a semaphore has been added to the naming list, you must be careful to remove the semaphore from the list (via RemSemaphore()) before deallocating its memory.

Semaphores that are linked together in an allocation list (which ObtainSemaphoreList() would use) may not be added to the system naming list, because the facilities use the link field of the signal semaphore in incompatible ways

See also

RemSemaphore | Remove a signal semaphore from the system
FindSemaphore | Find Semaphore by name
InitSemaphore | Initialize a signal semaphore


AddTail

Append node to tail of a list

Declaration

Source position: exec.pas line 1878

procedure AddTail(

  list: PList;

  node: PNode

);

Arguments

list | Pointer to the target list
node | Pointer to the Node to be added

Description

Add a node to the tail of a list. The Node will be the last node in the list.

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.


AddTask

Add a Task to the System

Declaration

Source position: exec.pas line 1899

function AddTask(

  task: PTask;

  initPC: Pointer;

  finalPC: Pointer

):Pointer;

Arguments

task | Pointer to the task control block (TCB). All unset fields must be zero.
initPC | The initial entry point's address
finalPC | the finalization code entry point's address. If zero, the system will use a general finalizer. This pointer is placed on the stack as if it were the outermost return address.

Function result

Pointer to Task

Description

Add a task to the system. A reschedule will be run; the task with the highest priority in the system will start to execute (this may or may not be the new task).

Certain fields of the task control block must be initialized and a stack allocated prior to calling this function. The absolute smallest stack that is allowable is something in the range of 100 bytes, but in general the stack size is dependent on what subsystems are called. In general 256 bytes is sufficient if only Exec is called, and 4K will do if anything in the system is called. DO NOT UNDERESTIMATE. If you use a stack sniffing utility, leave a healthy pad above the minimum value. The system guarantees that its stack operations will leave the stack longword aligned.

This function will temporarily use space from the new task's stack for the task's initial set of registers. This space is allocated starting at the SPREG location specified in the task control block (not from SPUPPER). This means that a task's stack may contain static data put there prior to its execution. This is useful for providing initialized global variables or some tasks may want to use this space for passing the task its initial arguments.

A task's initial registers are set to zero (except the PC).

The TC_MEMENTRY field of the task structure may be extended by the user to hold additional MemLists (as returned by AllocEntry()). These will be automatically be deallocated at RemTask() time. If the code you have used to start the task has already added something to the MEMENTRY list, simply use AddHead to add your new MemLists in. If no initialization has been done, a NewList will need to be performed.

Errors

If cannot create task Result will be nil.

See also

RemTask | Remove a task from the system
FindTask | Find task by name get own task


Alert

Alert the user of an error

Declaration

Source position: exec.pas line 1793

procedure Alert(

  alertNum: Cardinal

);

Arguments

alertNum

A number indicating the particular alert. -1 is not a valid input.

Description

Alerts the user of a serious system problem. This function will bring the system to a grinding halt, and do whatever is necessary to present the user with a message stating what happened. Interrupts are disabled, and an attempt to post the alert is made. If that fails, the system is reset. When the system comes up again, Exec notices the cause of the failure and tries again to post the alert.

If the Alert is a recoverable type, this call MAY return.

This call may be made at any time, including interrupts.


AllocAbs

Allocate at a given location

Declaration

Source position: exec.pas line 1850

function AllocAbs(

  byteSize: Cardinal;

  location: Pointer

):Pointer;

Arguments

byteSize | The size of the desired block in bytes This number is rounded up to the next larger block size for the actual allocation.
location | The address where the memory MUST be.

Function result

A pointer to the newly allocated memory block or nil

Description

This function attempts to allocate memory at a given absolute memory location. Often this is used by boot-surviving entities such as recoverable ram-disks. If the memory is already being used, or if there is not enough memory to satisfy the request, AllocAbs will return nil.

This block may not be exactly the same as the requested block because of rounding, but if the return value is non-zero, the block is guaranteed to contain the requested range.

Errors

Result is nil if failed. If the free list is corrupt, the system will panic with alert AN_MemCorrupt, $01000005.

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
Exec.ExecFreeMem | Free a memory block with given size


Allocate

Allocate a block of memory

Declaration

Source position: exec.pas line 1836

function Allocate(

  freeList: PMemHeader;

  byteSize: Cardinal

):Pointer;

Arguments

freeList | Pointer to the local memory list header.
byteSize | Size of the desired block in bytes.

Function result

A pointer to the just allocated free block. If there are no free regions large enough to satisfy the request, return nil.

Description

This function is used to allocate blocks of memory from a given private free memory pool (as specified by a MemHeader and its memory chunk list). Allocate will return the first free block that is greater than or equal to the requested size.

All blocks, whether free or allocated, will be block aligned; hence, all allocation sizes are rounded up to the next block even value (e.g. the minimum allocation resolution is currently 8 bytes. A request for 8 bytes will use up exactly 8 bytes. A request for 7 bytes will also use up exactly 8 bytes.).

This function can be used to manage an application's internal data memory. Note that no arbitration of the MemHeader and associated free chunk list is done. You must be the owner before calling Allocate.

Errors

If the free list is corrupt, the system will panic with alert AN_MemCorrupt, $01000005.

See also

Deallocate

Free a block of memory


AllocateAligned

Declaration

Source position: exec.pas line 2285

function AllocateAligned(

  memHeader: PMemHeader;

  byteSize: Cardinal;

  alignSize: Cardinal;

  alignOffset: Cardinal

):Pointer;


AllocEntry

Allocate many regions of memory

Declaration

Source position: exec.pas line 1862

function AllocEntry(

  entry: PMemList

):PMemList;

Arguments

entry

A MemList structure filled in with MemEntry structures.

Function result

A different MemList filled in with the actual memory allocated in the me_Addr field, and their sizes in me_Length. If enough memory cannot be obtained, then the requirements of the allocation that failed is returned and bit 31 is set.

Description

This function takes a memList structure and allocates enough memory to hold the required memory as well as a MemList structure to keep track of it.

These MemList structures may be linked together in a task control block to keep track of the total memory usage of this task. (See the description of TC_MEMENTRY under RemTask).

See also

RemTask

Remove a task from the system


AllocMemAligned

Declaration

Source position: exec.pas line 2291

function AllocMemAligned(

  byteSize: Cardinal;

  attributes: Cardinal;

  alignSize: Cardinal;

  alignOffset: Cardinal

):Pointer;


AllocPooled

Allocate memory in a memory pool

Declaration

Source position: exec.pas line 2145

function AllocPooled(

  poolHeader: Pointer;

  memSize: Cardinal

):Pointer;

Arguments

poolHeader | Pointer to the memory pool in which the memory should be allocated.
memSize | Size of the memory block in bytes

Function result

Pointer to the allocated memory or nil

Description

Allocates memory in a memory pool which is tracked in the pool. A call to DeletePool will free all memory blocks allocated in the pool.

See also

FreePooled | Free pooled memory block
CreatePool | Create a new pool for memory allocations
DeletePool | Free a memory pool


AllocPooledAligned

Declaration

Source position: exec.pas line 2324

function AllocPooledAligned(

  poolHeader: Pointer;

  byteSize: Cardinal;

  alignSize: Cardinal;

  alignOffset: Cardinal

):Pointer;


AllocSignal

Allocate a signal bit

Declaration

Source position: exec.pas line 1929

function AllocSignal(

  signalNum: LongInt

):ShortInt;

Arguments

signalNum

The desired signal number (of [0..31]) or -1 for no preference.

Function result

The signal bit number allocated [0..31]. If no signals are available, this function returns -1.

Description

Allocate a signal bit from the current tasks' pool. Either a particular bit, or the next free bit may be allocated. The signal associated with the bit will be properly initialized (cleared). At least 16 user signals are available per task. Signals should be deallocated before the task exits.

If the signal is already in use (or no free signals are available) a -1 is returned.

Allocated signals are only valid for use with the task that allocated them.

WARNING

Signals may not be allocated or freed from exception handling code.

See also

FreeSignal

Free a signal bit


AllocTaskPooled

Declaration

Source position: exec.pas line 2242

function AllocTaskPooled(

  Size: Cardinal

):Pointer;


AllocTrap

Allocate a processor trap vector

Declaration

Source position: exec.pas line 1935

function AllocTrap(

  trapNum: LongInt

):LongInt;

Arguments

trapNum

the desired trap number [0..15] or -1 for no preference.

Function result

The trap number allocated [0..15]. If no traps are available, this function returns -1.

Description

Allocate a trap number from the current task's pool. These trap numbers are those associated with the 68000 TRAP type instructions. Either a particular number, or the next free number may be allocated.

If the trap is already in use (or no free traps are available) a -1 is returned.

This function only affects the currently running task.

Traps are sent to the trap handler pointed at by tc_TrapCode. Unless changed by user code, this points to a standard trap handler.

tc_TrapData is not used.

WARNING

Traps may not be allocated or freed from exception handling code. You are not allowed to write to the exception table yourself.

See also

FreeTrap

Free a processor trap


AllocVec

Allocate memory and keep track of the size

Declaration

Source position: exec.pas line 2130

function AllocVec(

  byteSize: Cardinal;

  requirements: Cardinal

):Pointer;

Arguments

byteSize | The size of the desired block in bytes. (The operating system will automatically round this number to a multiple of the system memory chunk size)
requirements | If no flags are set, the system will return the best available memory block. For expanded systems, the fast memory pool is searched first. (MEMF_*)

Function result

A pointer to the newly allocated memory block. If there are no free memory regions large enough to satisfy the request, nil will be returned. The pointer must be checked for zero before the memory block may be used!

Description

Allocate a memory block and record its size, FreeVec() knows how many bytes to free.

Memory is allocated based on requirements and options. Any "requirement" must be met by a memory allocation, any "option" will be applied to the block regardless. AllocMem will try all memory spaces until one is found with the proper requirements and room for the memory request.

See also

FreeVec | Free memory with tracked size made using AllocVec()
Exec.ExecAllocMem | Allocate memory given certain requirements


AllocVecAligned

Declaration

Source position: exec.pas line 2297

function AllocVecAligned(

  byteSize: Cardinal;

  attributes: Cardinal;

  alignSize: Cardinal;

  alignOffset: Cardinal

):Pointer;


AllocVecDMA

Declaration

Source position: exec.pas line 2317

function AllocVecDMA(

  byteSize: Cardinal;

  requirements: Cardinal

):Pointer;


AllocVecPooled

Declaration

Source position: exec.pas line 2261

function AllocVecPooled(

  poolHeader: Pointer;

  memSize: LongWord

):Pointer;


AllocVecTaskPooled

Declaration

Source position: exec.pas line 2249

function AllocVecTaskPooled(

  Size: Cardinal

):Pointer;


AttemptSemaphore

Try to obtain a Semaphore without blocking

Declaration

Source position: exec.pas line 2064

function AttemptSemaphore(

  sigSem: PSignalSemaphore

):Cardinal;

Arguments

sigSem

An initialized signal semaphore structure

Function result

True if the semaphore was locked, false if some other task already possessed the semaphore.

Description

Try to obtain a lock on a Semaphore in exclusive mode all other exclusive and shared locks on this semaphore has to be released before. This call is similar to ObtainSemaphore(), except that it will not block if the semaphore could not be locked.

See also

ReleaseSemaphore | Make signal semaphore available to others
ObtainSemaphore | Gain exclusive access to a semaphore
AttemptSemaphoreShared | Try to obtain a Semaphore without blocking in shared mode
ObtainSemaphoreShared | Gain access to a semaphore in shared mode


AttemptSemaphoreShared

Try to obtain a Semaphore without blocking in shared mode

Declaration

Source position: exec.pas line 2154

function AttemptSemaphoreShared(

  sigSem: PSignalSemaphore

):Cardinal;

Arguments

sigSem

An initialized signal semaphore structure

Function result

True if the semaphore was locked, false if some other task already exclusively locked the semaphore.

Description

A lock on a signal semaphore may either be exclusive, or shared. Exclusive locks are granted by the ObtainSemaphore() and AttemptSemaphore() functions. Shared locks are granted by ObtainSemaphoreShared(). Calls may be nested.

Any number of tasks may simultaneously hold a shared lock on a semaphore. Only one task may hold an exclusive lock. A typical application is a list that is often read, but only occasionally written to.

Any exlusive locker will be held off until all shared lockers release the semaphore. Likewise, if an exlusive lock is held, all potential shared lockers will block until the exclusive lock is released. All shared lockers are restarted at the same time. This call is similar to ObtainSemaphoreShared(), except that it will not block if the semaphore could not be locked.


AvailMem

Check memory available given certain requirements

Declaration

Source position: exec.pas line 1859

function AvailMem(

  requirements: Cardinal

):Cardinal;

Arguments

requirements

A requirements mask for the memory properties (MEMF_*)

Function result

Number of bytes free with the given properties (or biggest Memory Block)

Description

This function returns the amount of free memory given certain attributes.

To find out what the largest block of a particular type is, add MEMF_LARGEST into the requirements argument. Returning the largest block is a slow operation.

WARNING

Due to the effect of multitasking, the value returned may not actually be the amount of free memory available at that instant.

Snippet:

AvailMem(MEMF_LARGEST);
  // return size of largest available memory chunk


AvailPool

Declaration

Source position: exec.pas line 2339

function AvailPool(

  PoolHeader: Pointer;

  Flags: LongWord

):LongWord;


CacheClearE

Declaration

Source position: exec.pas line 2105

procedure CacheClearE(

  address: Pointer;

  length: Cardinal;

  caches: Cardinal

);


CacheClearU

Declaration

Source position: exec.pas line 2102

procedure CacheClearU;


CacheControl

Declaration

Source position: exec.pas line 2110

function CacheControl(

  cacheBits: Cardinal;

  cacheMask: Cardinal

):Cardinal;


CacheFlushDataArea

Declaration

Source position: exec.pas line 2222

procedure CacheFlushDataArea(

  Address: Pointer;

  Size: Cardinal

);


CacheFlushDataInstArea

Declaration

Source position: exec.pas line 2234

procedure CacheFlushDataInstArea(

  Address: Pointer;

  Size: Cardinal

);


CacheInvalidDataArea

Declaration

Source position: exec.pas line 2230

procedure CacheInvalidDataArea(

  Address: Pointer;

  Size: Cardinal

);


CacheInvalidInstArea

Declaration

Source position: exec.pas line 2226

procedure CacheInvalidInstArea(

  Address: Pointer;

  Size: Cardinal

);


CachePostDMA

Declaration

Source position: exec.pas line 2182

procedure CachePostDMA(

  address: Pointer;

  var length: Cardinal;

  flags: Cardinal

);


CachePreDMA

Declaration

Source position: exec.pas line 2177

function CachePreDMA(

  address: Pointer;

  var length: Cardinal;

  flags: Cardinal

):Pointer;


CacheTrashCacheArea

Declaration

Source position: exec.pas line 2238

procedure CacheTrashCacheArea(

  Address: Pointer;

  Size: Cardinal

);


Cause

Fire and software interrupt

Declaration

Source position: exec.pas line 1833

procedure Cause(

  interrupt: PInterrupt

);

Description

This function causes a software interrupt to occur. If it is called from user mode (and processor level 0), the software interrupt will preempt the current task. This call is often used by high-level hardware interrupts to defer medium-length processing down to a lower interrupt level. Note that a software interrupt is still a real interrupt, and must obey the same restrictions on what system function it may call.

NOTE

When setting up the PInterrupt structure, set the node type to NT_INTERRUPT, or NT_UNKOWN.


CheckIO

Check status on an I/O request

Declaration

Source position: exec.pas line 2004

function CheckIO(

  ioRequest: PIORequest

):PIORequest;

Arguments

ioRequest

Pointer to an I/O request block

Function result

Nil if I/O is still in progress otherwise a pointer to the I/O Request.

Description

This function determines the current state of an I/O request and returns False if the I/O has not yet completed. This function effectively hides the internals of the I/O completion mechanism.

CheckIO() will NOT remove the returned IORequest from the reply port. This is best performed with WaitIO(). If the request has already completed, WaitIO() will return quickly. Use of the Remove() function is dangerous, since other tasks may still be adding things to your message port; a Disable() would be required.

This function should NOT be used to busy loop (looping until IO is complete). WaitIO() is provided for that purpose.

See also

DoIO | Perform an I/O request and wait for its finish
SendIO | Initiate an I/O command
WaitIO | Wait for completion of an I/O request
AbortIO | Attempt to abort an in-progress I/O request


CloseDevice

Close access to a device.

Declaration

Source position: exec.pas line 1995

procedure CloseDevice(

  ioRequest: PIORequest

);

Arguments

ioRequest

A pointer to an I/O request structure

Description

This function informs the device that access to a device/unit previously opened has been concluded. The device may perform certain house-cleaning operations.

The user must ensure that all outstanding IORequests have been returned before closing the device. The AbortIO function can kill any stragglers.

After a close, the I/O request structure is free to be reused.

See also

OpenDevice

Open a device for use


CloseLibrary

Close access to library

Declaration

Source position: exec.pas line 1972

procedure CloseLibrary(

  libHandle: PLibrary

);

Description

This function informs the system that access to the given library has been concluded. The user must not reference the library or any function in the library after this close.

See also

OpenLibrary

Open a library to use


ColdReboot

Reboot the Computer

Declaration

Source position: exec.pas line 2157

procedure ColdReboot;

Description

Reboot the machine. All external memory and periperals will be reseted, and the machine will start its power up diagnostics.

This function never returns.


CopyMem

Copy a given numbers ob bytes in memory

Declaration

Source position: exec.pas line 2092

procedure CopyMem(

  source: Pointer;

  dest: Pointer;

  size: Cardinal

);

Arguments

source | A pointer to the begin of source data
dest | A pointer to the begin of destination memory block
size | Number of bytes to be copied from source to destination, 0 is allowed and do nothing

Description

This function implements a fast memory copy function. It can deal with arbitrary lengths, with its pointers on arbitrary alignments. It attempts to optimize larger copies with more efficient copies, it uses byte copies for small moves, parts of larger copies, or the entire copy if the source and destination are misaligned with respect to each other.

Arbitrary overlapping copies are not supported.

See also

CopyMemQuick

Fast memory copy function


CopyMemQuick

Fast memory copy function

Declaration

Source position: exec.pas line 2097

procedure CopyMemQuick(

  source: Pointer;

  dest: Pointer;

  size: Cardinal

);

Arguments

source | A long aligned pointer to the begin of source data
dest | A long aligned pointer to begin of destination memory block
size | Number of bytes to be copied from source to destination, 0 is allowed and do nothing

Description

CopyMemQuick is a highly optimized memory copy function, with restrictions on the size and alignment of its arguments. Both the source and destination pointers must be longword aligned. In addition, the size must be an integral number of longwords (e.g. the size must be evenly divisible by four).

Arbitrary overlapping copies are not supported.

See also

CopyMem

Copy a given numbers ob bytes in memory


CreateExtIO

Declaration

Source position: exec.pas line 2365

function CreateExtIO(

  const Mp: PMsgPort;

  Size: Integer

):PIORequest;


CreateIORequest

Create a structure usable for an I/O request

Declaration

Source position: exec.pas line 2114

function CreateIORequest(

  port: PMsgPort;

  size: Cardinal

):Pointer;

Arguments

port | A pointer to a port for replies (an initialized message port, as created by CreateMsgPort()). If nil, this function fails.
size | The size of the IO request to be created.

Function result

A pointer to the I/O request structure created or nil

Description

Allocates memory for and initializes a new IO request block of a user-specified number of bytes. The number of bytes must be at least as large as a TMessage.

See also

DeleteIORequest | Free an i/O request
CreateMsgPort | Create a new message port


CreateMsgPort

Create a new message port

Declaration

Source position: exec.pas line 2121

function CreateMsgPort: PMsgPort;

Function result

A pointer to the fresh allocted and initialized MsgPort or nil if failed.

Description

Allocates and initializes a new message port. The message list of the new port will be prepared for use (via NewList). A signal bit will be allocated, and the port will be set to signal your task when a message arrives (PA_SIGNAL).

You must use DeleteMsgPort() to delete ports created with this function!

See also

DeleteMsgPort

Free a message port


CreatePool

Create a new pool for memory allocations

Declaration

Source position: exec.pas line 2137

function CreatePool(

  requirements: Cardinal;

  puddleSize: Cardinal;

  threshSize: Cardinal

):Pointer;

Arguments

requirements | Memory flags requirement (MEMF_*), all puddles will have this requirement.
puddleSize | Size of puddles
threshSize | The largest allocation that goes into normal puddles This MUST be less than or equal to puddleSize (CreatePool() will fail if it is not)

Function result

A pointer to the new pool, or nil for error.

Description

Each pool is a separate tracking system for memory of a specific type. Any number of pools may exist in the system.

Pools automatically expand and shrink based on demand. Fixed sized "puddles" are allocated by the pool manager when more total memory is needed. Many small allocations can fit in a single puddle. Allocations larger than the threshSize are allocation in their own puddles.

At any time individual allocations may be freed. Or, the entire pool may be removed in a single step.

See also

DeletePool | Free a memory pool
AllocPooled | Allocate memory in a memory pool
FreePooled | Free pooled memory block


Deallocate

Free a block of memory

Declaration

Source position: exec.pas line 1840

procedure Deallocate(

  freeList: PMemHeader;

  memoryBlock: Pointer;

  byteSize: Cardinal

);

Arguments

freeList | Points to the memory header this block is part of
memoryBlock | Address of memory block to free
byteSize | Number of bytes to free. nil is allowed and does nothing

Description

This function deallocates memory by returning it to the appropriate private free memory pool. This function can be used to free an entire block allocated with the above function, or it can be used to free a sub-block of a previously allocated block. Sub-blocks must be an even multiple of the memory chunk size (currently 8 bytes).

This function can even be used to add a new free region to an existing MemHeader, however the extent pointers in the MemHeader will no longer be valid.

If memoryBlock is not on a block boundary then it will be rounded down in a manner compatible with Allocate(). Note that this will work correctly with all the memory allocation functions, but may cause surprises if one is freeing only part of a region. The size of the block will be rounded up, so the freed block will fill to an even memory block boundary.

See also

Allocate

Allocate a block of memory


Debug

Calls the debugger

Declaration

Source position: exec.pas line 1796

procedure Debug(

  flags: Cardinal

);

Arguments

flags

Currently a 0 is passed to allow future expansion.

Description

This function calls the system debugger. Debuggers are encouraged to take over this entry point (via SetFunction()) so that when an application calls Debug(), the alternative debugger will get control.

See also

SetFunction

Change a function vector in a library


DeleteExtIO

Declaration

Source position: exec.pas line 2366

procedure DeleteExtIO(

  ioReq: PIORequest

);


DeleteIORequest

Free an i/O request

Declaration

Source position: exec.pas line 2118

procedure DeleteIORequest(

  iorequest: Pointer

);

Arguments

iorequest

A pointer to the I/O request block to be freed. This function uses the mn_Length field to determine how much memory to free. nil is allowed and does nothing.

Description

Frees up an I/O request created by CreateIORequest().

See also

CreateIORequest

Create a structure usable for an I/O request


DeleteMsgPort

Free a message port

Declaration

Source position: exec.pas line 2124

procedure DeleteMsgPort(

  port: PMsgPort

);

Arguments

port

A pointer to a message port to free. nil is allowed and does nothing

Description

Frees a message port create by CreateMsgPort(). All messages that may have been attached to this port must have already been replied to.

See also

CreateMsgPort

Create a new message port


DeletePool

Free a memory pool

Declaration

Source position: exec.pas line 2142

procedure DeletePool(

  poolHeader: Pointer

);

Description

Frees all memory in all pudles of the specified pool header, then deletes the pool header. Individual free calls are not needed.

See also

CreatePool | Create a new pool for memory allocations
AllocPooled | Allocate memory in a memory pool
FreePooled | Free pooled memory block


Disable

Disable interrupt processing

Declaration

Source position: exec.pas line 1799

procedure Disable;

Description

Prevents interrupts from being handled by the system, until a matching Enable() is executed. Disable() implies Forbid(). Normal task rescheduling does not occur while interrupts are disabled.

Do not use this call without a special reason, its very dangerous and hinder the basic function of the operating system and computer. It is important to remember that there is a danger in using disabled sections. Disabling interrupts for more than ~250 microseconds will prevent vital system functions (especially serial I/0) from operating in a normal fashion.

Think twice before using Disable(), then think once more. After all that, think again. With enough thought, the need for a Disable() can often be eliminated.

See also

Forbid | Forbid task scheduling.
Permit | Permit task rescheduling.
Enable | Enable interrupt processing


DoIO

Perform an I/O request and wait for its finish

Declaration

Source position: exec.pas line 1998

function DoIO(

  ioRequest: PIORequest

):ShortInt;

Arguments

ioRequest

A sign-extended copy of the io_Error field of the I/O request. Most device commands require that the error return be checked.

Function result

A pointer to an I/O Request initialized by OpenDevice()

Description

This function requests a device driver to perform the I/O command specified in the I/O request. This function will always wait until the I/O request is fully complete.

DoIO() handles all the details, including Quick I/O, waiting for the request, and removing the reply message, etc..

This function first tries to complete the IO via the "Quick I/O" mechanism. The io_Flags field is always set to IOF_QUICK (0x01) before the internal device call.

The LN_TYPE field is used internally to flag completion. Active requests have type NT_MESSAGE. Requests that have been replied have type NT_REPLYMSG. It is illegal to start IO using a still active IORequest, or a request with type NT_REPLYMSG.

See also

SendIO | Initiate an I/O command
CheckIO | Check status on an I/O request
WaitIO | Wait for completion of an I/O request
AbortIO | Attempt to abort an in-progress I/O request


DumpTaskState

Declaration

Source position: exec.pas line 2336

procedure DumpTaskState(

  Task: PTask

);


Enable

Enable interrupt processing

Declaration

Source position: exec.pas line 1802

procedure Enable;

Description

Allow system interrupts again occur after a Disable() was called.

Errors

The programmer must execute exactly one call to Enable() for every call to Disable().

See also

Disable | Disable interrupt processing
Permit | Permit task rescheduling.
Forbid | Forbid task scheduling.


Enqueue

Insert or append node to a system list

Declaration

Source position: exec.pas line 1891

procedure Enqueue(

  list: PList;

  node: PNode

);

Arguments

list | A pointer to the system list header
node | The node to enqueue. This must be a full featured node with type, priority and name fields.

Description

Insert or append a node into a system list. The insert is performed based on the node priority. It will keep the list properly sorted. New nodes will be inserted in front of the first node with a lower priority. Hence a FIFO queue for nodes of equal priority

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
Exec.ExecInsert | Insert a node into a list
Remove | Remove a node from a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list


execAllocMem

Allocate memory given certain requirements

Declaration

Source position: exec.pas line 1846

function execAllocMem(

  byteSize: Cardinal;

  requirements: Cardinal

):Pointer;

Arguments

byteSize | The size of the desired block in bytes. (The operating system will automatically round this number to a multiple of the system memory chunk size)
requirements | If no flags are set, the system will return the best available memory block. (MEMF_*)

Function result

A pointer to the newly allocated memory block. If there are no free memory regions large enough to satisfy the request, nil will be returned. The pointer must be checked for nil before the memory block may be used!

Description

This is the memory allocator to be used by system code and applications. It provides a means of specifying that the allocation should be made in a memory area accessible to the chips, or accessible to shared system code.

Memory is allocated based on requirements and options. Any "requirement" must be met by a memory allocation, any "option" will be applied to the block regardless. AllocMem will try all memory spaces until one is found with the proper requirements and room for the memory request.

Errors

>If the free list is corrupt, the system will panic with alert AN_MemCorrupt, $01000005.

This function may not be called from interrupts.

A DOS process will have its pr_Result2 field set to ERROR_NO_FREE_STORE if the memory allocation fails.

See also

Exec.ExecFreeMem | Free a memory block with given size
AllocVec | Allocate memory and keep track of the size


execFreeMem

Free a memory block with given size

Declaration

Source position: exec.pas line 1855

procedure execFreeMem(

  memoryBlock: Pointer;

  byteSize: Cardinal

);

Arguments

memoryBlock | A pointer to the memory block to free
byteSize | The size of the desired block in bytes. (The operating system will automatically round this number to a multiple of the system memory chunk size)

Description

Free a memory block allocated using ExecAllocMem(), program should not access this memory area anymore. If a memory block is freed twice an Guru will appear AN_FreeTwice. if a wrong pointer is passed a AN_MemCorrupt is fired. The original name FreeMem is colliding with the RTL Freemem.

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


execInsert

Insert a node into a list

Declaration

Source position: exec.pas line 1869

procedure execInsert(

  list: PList;

  node: PNode;

  pred: PNode

);

Arguments

list | A pointer to the target list
node | Node to insert
pred | A node of the list after the new node will be inserted

Description

Insert a node into a system list after a given node. Insertion at the head of a list is possible by passing a nil value for listNode, though the AddHead() function is slightly faster for that special case. The original name Insert is colliding with the RTL Insert.

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
Enqueue | Insert or append node to a system list
Remove | Remove a node from a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list


FindExecNode

Declaration

Source position: exec.pas line 2309

function FindExecNode(

  ttype: Cardinal;

  name: PChar

):PNode;


FindName

Find a node in a system list by name

Declaration

Source position: exec.pas line 1895

function FindName(

  list: PList;

  name: PChar

):PNode;

Arguments

list | A list or a list node to start the search (if node, this one is skipped)
name | Node name to find in the list

Function result

A pointer to the node with the same name else nil to indicate that the string was not found.

Description

Search a system list for a node with the given name. To find multiple occurrences of a string, this function may be called with a different node starting point.

No arbitration is done for access to the list! If multiple tasks access the same list, an arbitration mechanism such as SignalSemaphores must be used.


FindPort

Find a system message port by name

Declaration

Source position: exec.pas line 1960

function FindPort(

  name: PChar

):PMsgPort;

Arguments

name

Name of the message port to find.

Function result

A pointer to the message port, or nil if not found.

Description

This function will search the system message port list for a port with the given name. The first port matching this name will be returned. No arbitration of the port list is done. This function must be protected with A Forbid()/Permit() pair!

Example

function SafePutToPort(Msg: PMessage; Portname: string): Integer;
var
  Port: PMsgPort;
  PName: PChar;
begin
  Result := -1;
  PName := PChar(Portname + #0);
  Forbid();
  Port := FindPort(PName);
  if Assigned(Port) then
  begin
    PutMsg(Port, Msg);
    Result := 0;
  end;
  Permit();
end;


FindResident

Find a resident module by name

Declaration

Source position: exec.pas line 1786

function FindResident(

  name: PChar

):PResident;

Arguments

name

Name of the resident to find

Function result

A pointer to the resident tag structure or nil if none found.

Description

Search the system resident tag list for a resident tag ("ROMTag") with the given name. If found return a pointer to the resident tag structure, else return nil.

Resident modules are used by the system to pull all its parts together at startup. Resident tags are also found in disk based devices and libraries.

See also

InitResident

Initialize resident module


FindSemaphore

Find Semaphore by name

Declaration

Source position: exec.pas line 2073

function FindSemaphore(

  sigSem: PChar

):PSignalSemaphore;

Arguments

sigSem

Name of the semaphore to find

Function result

A pointer to the signal semaphore, or nil if none found.

Description

This function will search the system signal semaphore list for a semaphore with the given name. The first semaphore matching this name will be returned. This function must be protected with A Forbid()/Permit() pair!


FindTask

Find task by name get own task

Declaration

Source position: exec.pas line 1907

function FindTask(

  name: PChar

):PTask;

Arguments

name

Name of task to found.

Function result

A pointer to the task or process, or nil if none found.

Description

This function will check all task queues for a task with the given name, and return a pointer to its task control block. If a nil name pointer is given a pointer to the current task will be returned.

Finding oneself with a nil for the name is very quick. Finding a task by name is very system expensive, and will disable interrupts for a long time. Since a task may remove itself at any time, a Forbid()/Permit() pair may be needed to ensure the pointer returned by FindTask() is still valid when used.


FindTaskByPID

Declaration

Source position: exec.pas line 2333

function FindTaskByPID(

  processID: Cardinal

):PTask;


FlushPool

Declaration

Source position: exec.pas line 2255

procedure FlushPool(

  poolHeader: Pointer

);


FlushTaskPool

Declaration

Source position: exec.pas line 2258

procedure FlushTaskPool;


Forbid

Forbid task scheduling.

Declaration

Source position: exec.pas line 1805

procedure Forbid;

Description

Prevents other tasks from being scheduled to run by the dispatcher, until a matching Permit() is executed, or this task is scheduled to Wait(). Interrupts are not disabled.

The current task will not be rescheduled as long as it is ready to run. In the event that the current task enters a wait state, other tasks may be scheduled. Upon return from the wait state, the original task will continue to run without disturbing the Forbid().

Calls to Forbid() nest. In order to restore normal task rescheduling, the programmer must execute exactly one call to Permit() for every call to Forbid().

Warning:

In the event of a task entering a Wait() after a Forbid(), the system "breaks" the forbidden state and runs normally until the task which called Forbid() is rescheduled. If caution is not taken, this can cause subtile bugs, since any device or DOS call will (in effect) cause your task to wait.

See also

Permit | Permit task rescheduling.
Disable | Disable interrupt processing
Enable | Enable interrupt processing


FreeEntry

Free many blocks of memory at once

Declaration

Source position: exec.pas line 1865

procedure FreeEntry(

  entry: PMemList

);

Arguments

entry

A Pointer to a list filled with PMemEntry

Description

This function frees a list of memory blocks and frees all entries at once.

See also

AllocEntry

Allocate many regions of memory


FreePooled

Free pooled memory block

Declaration

Source position: exec.pas line 2149

procedure FreePooled(

  poolHeader: Pointer;

  memory: Pointer;

  memSize: Cardinal

);

Arguments

poolHeader | A pointer to the pool this memory block belongs to.
memory | Pointer to the memory to free.
memSize | Number of bytes to free. Must match the size used when AllocPooled was done.

Description

Free a memory block which belongs to a memory pool. The block is removed from the pool. Only Memory allocated with AllocPooled() are freed with this function.

See also

AllocPooled | Allocate memory in a memory pool
CreatePool | Create a new pool for memory allocations
DeletePool | Free a memory pool


FreeSignal

Free a signal bit

Declaration

Source position: exec.pas line 1932

procedure FreeSignal(

  signalNum: LongInt

);

Arguments

signalNum

The signal number to free [0..31].

Description

This function frees a previously allocated signal bit for reuse. This call must be performed while running in the same task in which the signal was allocated.

See also

AllocSignal

Allocate a signal bit


FreeTaskPooled

Declaration

Source position: exec.pas line 2245

procedure FreeTaskPooled(

  Address: Pointer;

  Size: Cardinal

);


FreeTrap

Free a processor trap

Declaration

Source position: exec.pas line 1938

procedure FreeTrap(

  trapNum: LongInt

);

Arguments

trapNum

The trap number to free [of 0..15]

Description

This function frees a previously allocated trap number for reuse. This call must be performed while running in the same task in which the trap was allocated.

See also

AllocTrap

Allocate a processor trap vector


FreeVec

Free memory with tracked size made using AllocVec()

Declaration

Source position: exec.pas line 2134

procedure FreeVec(

  memoryBlock: Pointer

);

Arguments

memoryBlock

A Pointer to the memory block to free. nil is allowed and does nothing.

See also

AllocVec

Allocate memory and keep track of the size


FreeVecDMA

Declaration

Source position: exec.pas line 2321

procedure FreeVecDMA(

  memoryBlock: Pointer

);


FreeVecPooled

Declaration

Source position: exec.pas line 2265

function FreeVecPooled(

  poolHeader: Pointer;

  memory: Pointer

):Pointer;


FreeVecTaskPooled

Declaration

Source position: exec.pas line 2252

procedure FreeVecTaskPooled(

  Address: Pointer

);


GetCC

Declaration

Source position: exec.pas line 2037

function GetCC: Cardinal;


GetEmulHandle

Declaration

Source position: exec.pas line 114

function GetEmulHandle: PEmulHandle;


GetMsg

Get next message from message port

Declaration

Source position: exec.pas line 1951

function GetMsg(

  port: PMsgPort

):PMessage;

Arguments

port

Message port to check for new message

Function result

A pointer to the first message available. If there are no messages, nil is returned.

Description

This function receives a message from a given message port. It provides a fast, non-copying message receiving mechanism. The received message is removed from the message port.

This function will not wait. If a message is not present this function will return nil. If a program must wait for a message, it can Wait() on the signal specified for the port or use the WaitPort() function. There can only be one task waiting for any given port.

Getting a message does not imply to the sender that the message is free to be reused by the sender. When the receiver is finished with the message, it may ReplyMsg() it back to the sender.

Getting a signal does NOT always imply a message is ready. More than one message may arrive per signal, and signals may show up without messages. Typically you must loop to GetMsg() until it returns zero, then Wait() or WaitPort().

See also

PutMsg | Put a message to a message port
ReplyMsg | Put a message to its reply port
WaitPort | Wait for a given port to be non-empty
Wait | Wait for one or more signals


InitCode

Initialize resident code modules (internal function)

Declaration

Source position: exec.pas line 1765

procedure InitCode(

  startClass: Cardinal;

  version: Cardinal

);

Description

(This function may be ignored by application programmers)


InitResident

Initialize resident module

Declaration

Source position: exec.pas line 1789

function InitResident(

  resident: PResident;

  segList: Cardinal

):Pointer;

Arguments

segList

SegList of the loaded object, if loaded from disk. Libraries and Devices will cache this value for later return at close or expunge time. Pass nil for ROM modules.

Function result

Return value from the init code, usually the library or device base. Nil for failure.

Description

Initialize a ROMTag. ROMTags are used to link system modules together. Each disk based device or library must contain a ROMTag structure in the first code hunk.

Errors

FindResident


InitSemaphore

Initialize a signal semaphore

Declaration

Source position: exec.pas line 2055

procedure InitSemaphore(

  sigSem: PSignalSemaphore

);

Arguments

sigSem

A pointer to a signal semaphore structure (with all fields set to 0 before the call)

Description

This function initializes a signal semaphore and prepares it for use. It does not allocate anything, but does initialize list pointers and the semaphore counters.

Semaphores are often used to protect critical data structures or hardware that can only be accessed by one task at a time. After initialization, the address of the SignalSemaphore may be made available to any number of tasks. Typically a task will try to ObtainSemaphore(), passing this address in. If no other task owns the semaphore, then the call will lock and return quickly. If more tasks try to ObtainSemaphore(), they will be put to sleep. When the owner of the semaphore releases it, the next waiter in turn will be woken up.

Semaphores are often preferable to the old-style Forbid()/Permit() type arbitration. With Forbid()/Permit() >all other tasks are prevented from running. With semaphores, only those tasks that need access to whatever the semaphore protects are subject to waiting.

See also

ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
AttemptSemaphore | Try to obtain a Semaphore without blocking
ReleaseSemaphore | Make signal semaphore available to others
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


InitStruct

Initialize memory from a table

Declaration

Source position: exec.pas line 1769

procedure InitStruct(

  initTable: Pointer;

  memory: Pointer;

  size: Cardinal

);

Arguments

initTable | The beginning of the commands and data to init Memory with. Must be on an even boundary unless only byte initialization is done.
memory | The beginning of the memory to initialize. Must be on an even boundary if size is specified.
size | The size of memory, which is used to clear it before initializing it via the initTable. If Size is zero, memory is not cleared before initializing. Must be an even number.

Description

Clear a memory area, then set up default values according to the data and offset values in the initTable.


MakeFunctions

Construct a function jump table

Declaration

Source position: exec.pas line 1781

procedure MakeFunctions(

  target: Pointer;

  functionArray: Pointer;

  funcDispBase: Pointer

);

Arguments

target | The target address for the high memory end of the function jump table. Typically this will be the library base pointer.
functionArray | A Pointer to an array of function pointers or function displacements. If nil, the array is assumed to contain absolute pointers to functions. If not nil, then the array is assumed to contain word displacements to functions. In both cases, the array is terminated by a -1 (of the same size as the actual entry.
funcDispBase | A Pointer to the base about which all function displacements are relative. If nil, then the function array contains absolute pointers.

Description

A low level function used by MakeLibrary() to build jump tables of the type used by libraries, devices and resources. It allows the table to be built anywhere in memory, and can be used both for initialization and replacement. This function also supports function pointer compression by expanding relative displacements into absolute pointers.

See also

MakeLibrary

Construct a library


MakeLibrary

Construct a library

Declaration

Source position: exec.pas line 1774

function MakeLibrary(

  funcInit: Pointer;

  structInit: Pointer;

  libInit: Pointer;

  dataSize: Cardinal;

  segList: Cardinal

):PLibrary;

Arguments

funcInit | A pointer to an array of function pointers or function displacements. If the first word of the array is -1, then the array contains relative word displacements (based off of vectors); otherwise, the array contains absolute function pointers. The vector list is terminated by a -1 (of the same size as the pointers).
structInit | points to an InitStruct" data region. If nil, then it will not be used.
libInit | Entry point for the library, used for initcode, function must return the library address or nil
dataSize | the size of the library data area, including the standard library node data. This must be at leas SizeOf(TLibrary).
segList | A pointer to an Amiga SegList (segment list). This is passed to a library's init code, and is used later for removing the library from memory.

Function result

The reference address of the library. This is the address used in references to the library, not the beginning of the memory area allocated. If the library vector table require more system memory than is available, this function will return nil.

Description

This function is used for constructing a library vector and data area. The same call is used to make devices. Space for the library is allocated from the system's free memory pool. The data portion of the library is initialized. Init may point to a library specific entry point.

See also

InitStruct | Initialize memory from a table
InitResident | Initialize resident module


NewCreateLibrary

Declaration

Source position: exec.pas line 2202

function NewCreateLibrary(

  Tags: Pointer

):PLibrary;


NewCreateLibraryTags

Declaration

Source position: exec.pas line 2355

function NewCreateLibraryTags(

  const Tags: array of PtrUInt

):PLibrary;


NewCreateTask

Declaration

Source position: exec.pas line 2358

function NewCreateTask(

  const Tags: array of PtrUInt

):PTask;


NewCreateTaskA

Declaration

Source position: exec.pas line 2282

function NewCreateTaskA(

  Tags: Pointer

):PTask;


NewGetSystemAttrs

Declaration

Source position: exec.pas line 2356

function NewGetSystemAttrs(

  Data: Pointer;

  DataSize: LongWord;

  MyType: LongWord;

  const Tags: array of PtrUInt

):LongWord;


NewGetSystemAttrsA

Declaration

Source position: exec.pas line 2270

function NewGetSystemAttrsA(

  Data: Pointer;

  DataSize: Cardinal;

  TType: Cardinal;

  Tags: Pointer

):Cardinal;


NewGetTaskAttrs

Declaration

Source position: exec.pas line 2353

function NewGetTaskAttrs(

  Task: PTask;

  Data: Pointer;

  DataSize: LongWord;

  TType: LongWord;

  const Tags: array of PtrUInt

):LongWord;


NewGetTaskAttrsA

Declaration

Source position: exec.pas line 2163

function NewGetTaskAttrsA(

  Task: PTask;

  Data: Pointer;

  DataSize: LongWord;

  TType: LongWord;

  Tags: Pointer

):LongWord;


NewGetTaskPIDAttrs

Declaration

Source position: exec.pas line 2360

function NewGetTaskPIDAttrs(

  PID: LongWord;

  Data: Pointer;

  DataSize: LongWord;

  Type_: LongWord;

  const Tags: array of PtrUInt

):LongWord;


NewGetTaskPIDAttrsA

Declaration

Source position: exec.pas line 2341

function NewGetTaskPIDAttrsA(

  PID: LongWord;

  Data: Pointer;

  DataSize: LongWord;

  Type_: LongWord;

  Tags: Pointer

):LongWord;


NewPPCStackSwap

Declaration

Source position: exec.pas line 2205

function NewPPCStackSwap(

  newStack: PStackSwapStruct;

  sfunction: Pointer;

  args: PPPCStackSwapArgs

):Cardinal;


NewSetFunction

Declaration

Source position: exec.pas line 2196

function NewSetFunction(

  libHandle: PLibrary;

  newfunction: Pointer;

  offset: LongInt;

  tags: Pointer

):Pointer;


NewSetSystemAttrs

Declaration

Source position: exec.pas line 2357

function NewSetSystemAttrs(

  Data: Pointer;

  DataSize: LongWord;

  MyType: LongWord;

  const Tags: array of PtrUInt

):LongWord;


NewSetSystemAttrsA

Declaration

Source position: exec.pas line 2276

function NewSetSystemAttrsA(

  Data: Pointer;

  DataSize: Cardinal;

  TType: Cardinal;

  Tags: Pointer

):Cardinal;


NewSetTaskAttrs

Declaration

Source position: exec.pas line 2354

function NewSetTaskAttrs(

  Task: PTask;

  Data: Pointer;

  DataSize: Cardinal;

  TType: Cardinal;

  const Tags: array of PtrUInt

):LongWord;


NewSetTaskAttrsA

Declaration

Source position: exec.pas line 2170

function NewSetTaskAttrsA(

  Task: PTask;

  Data: Pointer;

  DataSize: LongWord;

  TType: LongWord;

  Tags: Pointer

):LongWord;


NewSetTaskPIDAttrs

Declaration

Source position: exec.pas line 2361

function NewSetTaskPIDAttrs(

  PID: LongWord;

  Data: Pointer;

  DataSize: LongWord;

  Type_: LongWord;

  const Tags: array of PtrUInt

):LongWord;


NewSetTaskPIDAttrsA

Declaration

Source position: exec.pas line 2342

function NewSetTaskPIDAttrsA(

  PID: LongWord;

  Data: Pointer;

  DataSize: LongWord;

  Type_: LongWord;

  Tags: Pointer

):LongWord;


ObtainQuickVector

Obtain and install a Quick Interrupt vector

Declaration

Source position: exec.pas line 2193

function ObtainQuickVector(

  interruptCode: Pointer

):Cardinal;

Arguments

interruptCode

A pointer to your interrupt code. This code is not an EXEC interrupt but is dirrectly connected to the hardware interrupt.

Function result

If it returns 0, no quick interrupt was allocatable. The device should at this point switch to using the shared interrupt server method.

Description

This function will install the code pointer into the quick interrupt vector it allocates and returns to you the interrupt vector that your Quick Interrupt system needs to use.

This function may also return 0 if no vectors are available. Your hardware should be able to then fall back to using the shared interrupt server chain should this happen.

The interrupt code is a direct connect to the physical interrupt. This means that it is the responsibility of your code to do all of the context saving/restoring required by interrupt code.

Also, due to the performance of the interrupt controller, you may need to also watch for "false" interrupts. These are interrupts that come in just after a DISABLE. The reason this happens is because the interrupt may have been posted before the DISABLE hardware access is completed.


ObtainSemaphore

Gain exclusive access to a semaphore

Declaration

Source position: exec.pas line 2058

procedure ObtainSemaphore(

  sigSem: PSignalSemaphore

);

Arguments

sigSem

An initialized signal semaphore structure

Description

Signal semaphores are used to gain exclusive access to an object. ObtainSemaphore is the call used to gain this access. If another user currently has the semaphore locked the call will block until the object is available.

If the current task already has locked the semaphore and attempts to lock it again the call will still succeed. A "nesting count" is incremented each time the current owning task of the semaphore calls ObtainSemaphore(). This counter is decremented each time ReleaseSemaphore() is called. When the counter returns to zero the semaphore is actually released, and the next waiting task is called.

A queue of waiting tasks is maintained on the stacks of the waiting tasks. Each will be called in turn as soon as the current task releases the semaphore.

Signal Semaphores are different than Procure()/Vacate() semaphores. The former requires less CPU time, especially if the semaphore is not currently locked. They require very little set up and user thought. The latter flavor of semaphore make no assumptions about how they are used -- they are completely general. Unfortunately they are not as efficient as signal semaphores, and require the locker to have done some setup before doing the call.

See also

ObtainSemaphoreShared | Gain access to a semaphore in shared mode
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphoreList | Get a List of semaphores
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


ObtainSemaphoreList

Get a List of semaphores

Declaration

Source position: exec.pas line 2067

procedure ObtainSemaphoreList(

  sigSem: PList

);

Arguments

sigSem

A list of signal semaphores

Description

Signal semaphores may be linked together into a list. This function takes a list of these semaphores and attempts to lock all of them at once. This call is preferable to applying ObtainSemaphore() to each element in the list because it attempts to lock all the elements simultaneously, and won't deadlock if someone is attempting to lock in some other order.

This function assumes that only one task at a time will attempt to lock the entire list of semaphores. In other words, there needs to be a higher level lock (perhaps another signal semaphore...) that is used before someone attempts to lock the semaphore list via ObtainSemaphoreList().

Note that deadlocks may result if this call is used AND someone attempts to use ObtainSemaphore() to lock more than one semaphore on the list. If you wish to lock more than one semaphore (but not all of them) then you should obtain the higher level lock

See also

ObtainSemaphoreShared | Gain access to a semaphore in shared mode
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


ObtainSemaphoreShared

Gain access to a semaphore in shared mode

Declaration

Source position: exec.pas line 2127

procedure ObtainSemaphoreShared(

  sigSem: PSignalSemaphore

);

Arguments

sigSem

An initialized signal semaphore structure

Description

A lock on a signal semaphore may either be exclusive, or shared. Exclusive locks are granted by the ObtainSemaphore() and AttemptSemaphore() functions. Shared locks are granted by ObtainSemaphoreShared(). Calls may be nested.

Any number of tasks may simultaneously hold a shared lock on a semaphore. Only one task may hold an exclusive lock. A typical application is a list that is often read, but only occasionally written to.

Any exlusive locker will be held off until all shared lockers release the semaphore. Likewise, if an exlusive lock is held, all potential shared lockers will block until the exclusive lock is released. All shared lockers are restarted at the same time.

A task owning a shared lock must not attempt to get an exclusive lock on the same semaphore.

See also

ObtainSemaphoreList | Get a List of semaphores
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


OldOpenLibrary

Old Version of OpenLibrary (deprecated)

Declaration

Source position: exec.pas line 1969

function OldOpenLibrary(

  libName: PChar

):PLibrary;

Arguments

libName

The name of the library to open

Function result

A library pointer for a successful open, else nil.

Description

This is the same function as OpenLibrary(), only that it uses 0 as version number. This function is obsolete. Don't use it.

See also

OpenLibrary

Open a library to use


OpenDevice

Open a device for use

Declaration

Source position: exec.pas line 1989

function OpenDevice(

  devName: PChar;

  numunit: Cardinal;

  ioRequest: PIORequest;

  flags: Cardinal

):ShortInt;

Arguments

devName | Requested device name
ioRequest | The I/O request block to be returned with appropriate fields initialized.
flags | An additional driver specific information. This is sometimes used to request opening a device with exclusive access.

Function result

Returns a sign-extended copy of the io_Error field of the IORequest. Zero if successful, else an error code is returned.

Description

This function opens the named device/unit and initializes the given I/O request block. Specific documentation on opening procedures may come with certain devices.

The device may exist in memory, or on disk; this is transparent to the OpenDevice caller.

A full path name for the device name is legitimate. For example "test:devs/fred.device". This allows the use of custom devices without requiring the user to copy the device into the system's DEVS: directory.

See also

CloseDevice | Close access to a device.
DoIO | Perform an I/O request and wait for its finish
SendIO | Initiate an I/O command
CheckIO | Check status on an I/O request
AbortIO | Attempt to abort an in-progress I/O request
WaitIO | Wait for completion of an I/O request


OpenLibrary

Open a library to use

Declaration

Source position: exec.pas line 2051

function OpenLibrary(

  libname: PChar;

  libver: Cardinal

):Pointer;

Arguments

libname

The name of the library to open

Function result

A library pointer for a successful open, else nil

Description

This function returns a pointer to a library that was previously installed into the system. If the requested library is exists, and if the library version is greater than or equal to the requested version, then the open will succeed.

The library may exist in memory, or on disk; this is transparent to the OpenLibrary caller. Only Processes are allowed to call OpenLibrary (since OpenLibrary may in turn call dos.library).

A full path name for the library name is legitimate. For example "wp:libs/wp.library". This allows the use of custom libraries without requiring the user to copy the library into the system's LIBS: directory.

See also

CloseLibrary

Close access to library


OpenResource

Open an resource for use

Declaration

Source position: exec.pas line 2019

function OpenResource(

  resName: PChar

):Pointer;

Arguments

resName

The name of the resource requested.

Function result

A resource pointer if successful, else nil

Description

This function returns a pointer to a resource that was previously installed into the system.

There is no CloseResource() function.


Permit

Permit task rescheduling.

Declaration

Source position: exec.pas line 1808

procedure Permit;

Description

Allow other tasks to be scheduled to run by the dispatcher, after a matching Forbid() has been executed. Other tasks will be rescheduled as they are ready to run. In order to restore normal task rescheduling, the programmer must execute exactly one call to Permit() for every call to Forbid().


Procure

Asynchron locking of a semaphore

Declaration

Source position: exec.pas line 2043

function Procure(

  sigSem: PSignalSemaphore;

  bidMsg: PSemaphoreMessage

):Cardinal;

Arguments

sigSem | The SignalSemaphore that you wish to lock
bidMsg | The SemaphoreMessage that you wish replied when you obtain access to the semaphore. The message's ssm_Semaphore field will point at the semaphore that was obtained. If the ssm_Semaphore field is nil, the Procure() was aborted via Vacate(). The mn_ReplyPort field of the message must point to a valid message port. To obtain a shared semaphore, the ln_Name field must be set to 1. For an exclusive lock, the ln_Name field must be 0. No other values are valid.

Description

This function is used to obtain a semaphore in an async manner. Like ObtainSemaphore(), it will obtain a SignalSemaphore for you but unlike ObtainSemaphore(), you will not block until you get the semaphore. Procure() will just post a request for the semaphore and will return. When the semaphore is available (which could be at any time) the bidMessage will ReplyMsg() and you will own the semaphore. This lets you wait on multiple semaphores at once and to continue processing while waiting for the semaphore.

See also

ObtainSemaphoreList | Get a List of semaphores
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
Vacate | Release a bidMessage from Procure()


PutMsg

Put a message to a message port

Declaration

Source position: exec.pas line 1947

procedure PutMsg(

  port: PMsgPort;

  message: PMessage

);

Arguments

port | A pointer to a message port
message | A pointer to a message

Description

This function attaches a message to the end of a given message port. It provides a fast, non-copying message sending mechanism.

Messages can be attached to only one port at a time. The message body can be of any size or form. Because messages are not copied, cooperating tasks share the same message memory. The sender task must not recycle the message until it has been replied by the receiver. Of course this depends on the message handling conventions setup by the involved tasks. If the ReplyPort field is non-zero, when the message is replied by the receiver, it will be sent back to that port.

See also

GetMsg | Get next message from message port
ReplyMsg | Put a message to its reply port


PutMsgHead

Declaration

Source position: exec.pas line 2340

procedure PutMsgHead(

  Port: PMsgPort;

  Message: PMessage

);


RawDoFmt

Format data into a character stream.

Declaration

Source position: exec.pas line 2031

function RawDoFmt(

  formatString: PChar;

  dataStream: Pointer;

  putChProc: Pointer;

  putChData: Pointer

):Pointer;

Arguments

formatString | %[flags][width.limit][length]type
dataStream | A pointer to a zone of memory containing the data. Data has to be WORD aligned.
putChProc | Callback function. Called for each character, including the NULL terminator. or one of the values RAWFMTFUNC_*
putChData | Data propagated to each call of the callback hook.

Function result

A pointer to the rest of the DataStream.

Description

perform "C"-language-like formatting of a data stream, outputting the result a character at a time. Where % formatting commands are found in the FormatString, they will be replaced with the corresponding element in the DataStream. %% must be used in the string if a % is desired in the output.


RawIOInit

Declaration

Source position: exec.pas line 2022

procedure RawIOInit;


RawMayGetChar

Declaration

Source position: exec.pas line 2025

function RawMayGetChar: Char;


RawPutChar

Declaration

Source position: exec.pas line 2028

procedure RawPutChar(

  d0arg: Char

);


ReadGayle

Declaration

Source position: exec.pas line 2213

function ReadGayle: Cardinal;


REG_A0

Declaration

Source position: exec.pas line 125

function REG_A0: Pointer;


REG_A1

Declaration

Source position: exec.pas line 126

function REG_A1: Pointer;


REG_A2

Declaration

Source position: exec.pas line 127

function REG_A2: Pointer;


REG_A3

Declaration

Source position: exec.pas line 128

function REG_A3: Pointer;


REG_A4

Declaration

Source position: exec.pas line 129

function REG_A4: Pointer;


REG_A5

Declaration

Source position: exec.pas line 130

function REG_A5: Pointer;


REG_A6

Declaration

Source position: exec.pas line 131

function REG_A6: Pointer;


REG_A7

Declaration

Source position: exec.pas line 132

function REG_A7: Pointer;


REG_D0

Declaration

Source position: exec.pas line 116

function REG_D0: DWord;


REG_D1

Declaration

Source position: exec.pas line 117

function REG_D1: DWord;


REG_D2

Declaration

Source position: exec.pas line 118

function REG_D2: DWord;


REG_D3

Declaration

Source position: exec.pas line 119

function REG_D3: DWord;


REG_D4

Declaration

Source position: exec.pas line 120

function REG_D4: DWord;


REG_D5

Declaration

Source position: exec.pas line 121

function REG_D5: DWord;


REG_D6

Declaration

Source position: exec.pas line 122

function REG_D6: DWord;


REG_D7

Declaration

Source position: exec.pas line 123

function REG_D7: DWord;


REG_PC

Declaration

Source position: exec.pas line 134

function REG_PC: Pointer;


REG_SR

Declaration

Source position: exec.pas line 135

function REG_SR: DWord;


ReleaseSemaphore

Make signal semaphore available to others

Declaration

Source position: exec.pas line 2061

procedure ReleaseSemaphore(

  sigSem: PSignalSemaphore

);

Arguments

sigSem

An initialized signal semaphore structure which was obtained before

Description

ReleaseSemaphore() is the inverse of ObtainSemaphore(). It makes the semaphore lockable to other users. If tasks are waiting for the semaphore and this this task is done with the semaphore then the next waiting task is signalled.

Each ObtainSemaphore() call must be balanced by exactly one ReleaseSemaphore() call. This is because there is a nesting count maintained in the semaphore of the number of times that the current task has locked the semaphore. The semaphore is not released to other tasks until the number of releases matches the number of obtains.

Signal semaphores locked via ObtainSemaphoreShared are also released with this function.

Semaphores must released the same amount as is obtained.

See also

InitSemaphore | Initialize a signal semaphore
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode


ReleaseSemaphoreList

Make a list of semaphores available

Declaration

Source position: exec.pas line 2070

procedure ReleaseSemaphoreList(

  sigSem: PList

);

Arguments

sigSem

A list of signal semaphores

Description

ReleaseSemaphoreList() is the inverse of ObtainSemaphoreList(). It releases each element in the semaphore list.

See also

ObtainSemaphoreList

Get a List of semaphores


RemDevice

Remove a device from the system

Declaration

Source position: exec.pas line 1986

procedure RemDevice(

  device: PDevice

);

Arguments

device

A pointer to a device node

Description

This function calls the device's EXPUNGE vector, which requests that a device delete itself. The device may refuse to do this if it is busy or currently open. This is not typically called by user code.

There are certain, limited circumstances where it may be appropriate to attempt to specifically flush a certain device.

See also

AddDevice | Adds a device to the system
OpenDevice | Open a device for use
CloseDevice | Close access to a device.


RemExecNotify

Declaration

Source position: exec.pas line 2306

procedure RemExecNotify(

  hook: Pointer

);


RemHead

Remove the head node from a list

Declaration

Source position: exec.pas line 1885

function RemHead(

  list: PList

):PNode;

Arguments

list

A pointer to the list

Function result

The node removed or nil when empty list

Description

Get a pointer to the head node and remove it from the list.

See also

AddTail | Append node to tail of a list
AddHead | Insert a node at the head of a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
Remove | Remove a node from a list
RemTail | Remove the tail node from a list


RemIntServer

Remove an interrupt server from a server chain

Declaration

Source position: exec.pas line 1829

procedure RemIntServer(

  intNumber: LongInt;

  interrupt: PInterrupt

);

Arguments

intNumber

The interrupt bit [0..14]

Description

>This function removes an interrupt server node from the given server chain.

If this server was the last one on this chain, interrupts for this chain are disabled.

See also

AddIntServer

Adds a interrupt server to the system


RemLibrary

Remove a library from the system

Declaration

Source position: exec.pas line 1966

procedure RemLibrary(

  libHandle: PLibrary

);

Description

This function calls the library's EXPUNGE vector, which requests that a library delete itself. The library may refuse to do this if it is busy or currently open. This is not typically called by user code.

There are certain, limited circumstances where it may be appropriate to attempt to specifically flush a certain Library.


RemMemHandler

Remove low memory handler from exec

Declaration

Source position: exec.pas line 2190

procedure RemMemHandler(

  memhand: PInterrupt

);

Arguments

memhand

Pointer to a handler added with AddMemHandler()

Description

This function removes the low memory handler from the system. This function can be called from within a handler. If removing oneself, it is important that the handler returns MEM_ALL_DONE.

See also

AddMemHandler


Remove

Remove a node from a list

Declaration

Source position: exec.pas line 1882

procedure Remove(

  node: PNode

);

Arguments

node

A node to remove

Description

Unlink a node from whatever list it is in. Nodes that are not part of a list must not be passed to this function!

See also

AddTail | Append node to tail of a list
AddHead | Insert a node at the head of a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list


RemPort

Remove a message port from the system

Declaration

Source position: exec.pas line 1944

procedure RemPort(

  port: PMsgPort

);

Arguments

port

A pointer to a message port

Description

This function removes a message port structure from the system's message port list. Subsequent attempts to rendezvous by name with this port will fail.

See also

AddPort | Add a public message port to the system
FindPort | Find a system message port by name


RemResource

Remove a resource from the system

Declaration

Source position: exec.pas line 2016

procedure RemResource(

  resource: Pointer

);

Arguments

resource

A pointer to a resource node

Description

This function removes an existing resource from the system resource list. There must be no outstanding users of the resource.

See also

AddResource

Add a resource to the system


RemSemaphore

Remove a signal semaphore from the system

Declaration

Source position: exec.pas line 2079

procedure RemSemaphore(

  sigSem: PSignalSemaphore

);

Arguments

sigSem

An initialized signal semaphore structure

Description

This function removes a signal semaphore structure from the system's signal semaphore list. Subsequent attempts to rendezvous by name with this semaphore will fail.

See also

AddSemaphore | Initialize then add a signal semaphore to the system
FindSemaphore | Find Semaphore by name


RemTail

Remove the tail node from a list

Declaration

Source position: exec.pas line 1888

function RemTail(

  list: PList

):PNode;

Arguments

list

A pointer to a list

Function result

The node removed or nil when empty list

Description

Remove the last node from a list, and return a pointer to it. If the list is empty, return nil.

See also

AddTail | Append node to tail of a list
AddHead | Insert a node at the head of a list
Enqueue | Insert or append node to a system list
ExecInsert | Insert a node into a list
RemHead | Remove the head node from a list
Remove | Remove a node from a list


RemTask

Remove a task from the system

Declaration

Source position: exec.pas line 1904

procedure RemTask(

  task: PTask

);

Arguments

task

A pointer to the task node representing the task to be removed. A zero value indicates self removal, and will cause the next ready task to begin execution.

See also

AddTask | Add a Task to the System
AllocEntry | Allocate many regions of memory


ReplyMsg

Put a message to its reply port

Declaration

Source position: exec.pas line 1954

procedure ReplyMsg(

  message: PMessage

);

Arguments

message

A pointer to the message

Description

This function sends a message to its reply port. This is usually done when the receiver of a message has finished and wants to return it to the sender (so that it can be re-used or deallocated, whatever). The contents of the message should be copied before if it is needed for further processing.

This call may be made from interrupts.

See also

GetMsg | Get next message from message port
PutMsg | Put a message to a message port


SendIO

Initiate an I/O command

Declaration

Source position: exec.pas line 2001

procedure SendIO(

  ioRequest: PIORequest

);

Arguments

ioRequest

A pointer to an I/O request, or a device specific extended IORequest.

Description

This function requests the device driver start processing the given I/O request. The device will return control without waiting for the I/O to complete.

The io_Flags field of the IORequest will be set to zero before the request is sent.

See also

DoIO | Perform an I/O request and wait for its finish
CheckIO | Check status on an I/O request
WaitIO | Wait for completion of an I/O request
AbortIO | Attempt to abort an in-progress I/O request


SetExcept

Define certain signals to cause exceptions

Declaration

Source position: exec.pas line 1918

function SetExcept(

  newSignals: Cardinal;

  signalSet: Cardinal

):Cardinal;

Arguments

newSignals | Set of signals causing the exception.
signalSet | the set of signals to be effected

Function result

The prior exception signals

Description

This function defines which of the task's signals will cause a private task exception. When any of the signals occurs the task's exception handler will be dispatched. If the signal occurred prior to calling SetExcept, the exception will happen immediately.


SetFunction

Change a function vector in a library

Declaration

Source position: exec.pas line 1975

function SetFunction(

  libHandle: PLibrary;

  funcOffset: LongInt;

  newFunction: Pointer

):Pointer;

Arguments

funcOffset | The offset of the function to be replaced
newFunction | A Pointer to new function

Function result

Pointer to the old function that was just replaced

Description

SetFunction is a functional way of changing where vectors in a library point. They are changed in such a way that the checksumming process will never falsely declare a library to be invalid.

Warning

While it's more or less safe to patch a library vector with SetFunction() it's not possible to safely remove the patch later. So don't use this function if it can be avoided.


SetIntVector

Set a new handler for a system interrupt vector

Declaration

Source position: exec.pas line 1821

function SetIntVector(

  intNumber: LongInt;

  interrupt: PInterrupt

):PInterrupt;

Arguments

intNumber

Interrupt bit number [0..14]. Only non-chained interrupts should be set. Use AddIntServer() for server chains.

Function result

A pointer to the prior interrupt structure which had control of this interrupt.

Description

This function provides a mechanism for setting the system interrupt vectors. These are non-sharable; setting a new interrupt handler disconnects the old one. Installed handlers are responsible for processing, enabling and clearing the interrupt. Note that interrupts may have been left in any state by the previous code.

The IS_CODE and IS_DATA pointers of the Interrupt structure will be copied into a private place by Exec. A pointer to the previously installed Interrupt structure is returned.

See also

AddIntServer

Adds a interrupt server to the system


SetSignal

Define the state of this task's signals

Declaration

Source position: exec.pas line 1914

function SetSignal(

  newSignals: Cardinal;

  signalSet: Cardinal

):Cardinal;

Arguments

newSignals | The new values for the signals specified in signalSet.
signalSet | The set of signals to be affected.

Function result

The prior values for all signals

Description

This function can query or modify the state of the current task's received signal mask. Setting the state of signals is considered dangerous. Reading the state of signals is safe.

//Get the current state of all signals
Sig := SetSignal(0, 0);
//Clear the CTRL-C signal:
Sig := SetSignal(0, SIGBREAKF_CTRL_C);
// Check and Clear Ctrl C Signal
if (SetSignal(0, SIGBREAKF_CTRL_C) and SIGBREAKF_CTRL_C) <> 0 then
begin
  writeln('CTRL-C pressed!');
end;

See also

Signal

Signal a task


SetSR

Get and/or set processor status register

Declaration

Source position: exec.pas line 1811

function SetSR(

  newSR: Cardinal;

  mask: Cardinal

):Cardinal;

Arguments

newSR | The new contents of the status register.
mask | Mask of bits to change.

Function result

The old contents of the status register or 0 if this function is not implemented.

Description

This function provides a means of modifying the CPU status register in a "safe" way (well, how safe can a function like this be anyway?). This function will only affect the status register bits specified in the mask parameter. The prior content of the entire status register is returned.

The bits in the register mapped to those of the Motorola MC680x0 family of microprocessors.


SetTaskPri

Get and set the priority of a task

Declaration

Source position: exec.pas line 1910

function SetTaskPri(

  task: PTask;

  priority: LongInt

):ShortInt;

Arguments

task | Task to be affected
priority | The new priority for the task (-127 to 5).

Function result

The tasks previous priority

Description

This function changes the priority of a task regardless of its state. The old priority of the task is returned. A reschedule is performed, and a context switch may result.

To change the priority of the currently running task, pass the result of FindTask(nil); as the task pointer.


ShutdownA

Declaration

Source position: exec.pas line 2338

function ShutdownA(

  MyTags: Pointer

):LongWord;


Signal

Signal a task

Declaration

Source position: exec.pas line 1925

procedure Signal(

  task: PTask;

  signalSet: Cardinal

);

Arguments

task | The task to be signalled
signalSet | The signals to be sent

Description

This function signals a task with the given signals. If the task is currently waiting for one or more of these signals, it will be made ready and a reschedule will occur. If the task is not waiting for any of these signals, the signals will be posted to the task for possible later use. A signal may be sent to a task regardless of whether it is running, ready, or waiting.

This function is considered "low level". Its main purpose is to support multiple higher level functions like PutMsg().

This function is safe to call from interrupts.

See also

Wait | Wait for one or more signals
SetSignal | Define the state of this task's signals


StackSwap

Declaration

Source position: exec.pas line 2160

procedure StackSwap(

  newStack: PStackSwapStruct

);


SumKickData

Declaration

Source position: exec.pas line 2082

function SumKickData: Cardinal;


SumLibrary

Compute and check the checksum on a library

Declaration

Source position: exec.pas line 1980

procedure SumLibrary(

  libHandle: PLibrary

);

Description

SumLibrary computes a new checksum on a library. It can also be used to check an old checksum. If an old checksum does not match, and the library has not been marked as changed, then the system will call Alert.

This call could also be periodically made by some future system-checking task.

See also

SetFunction

Change a function vector in a library


SuperState

Enter supervisor state with user stack

Declaration

Source position: exec.pas line 1815

function SuperState: Pointer;

Description

Enter supervisor mode while running on the user's stack. The user still has access to user stack variables. Be careful though, the user stack must be large enough to accommodate space for all interrupt data -- this includes all possible nesting of interrupts. This function does nothing when called from supervisor state. This is not a good function to use, it has limited scope, and will probably be even less useful in the future.

Errors

You can easily cause your system to cease operating normally.

See also

Supervisor | Trap to a short supervisor mode function
UserState | Return to user state with user stack


Supervisor

Trap to a short supervisor mode function

Declaration

Source position: exec.pas line 1762

function Supervisor(

  userFunction: Pointer

):Cardinal;

Arguments

userFunction

The address of the code you want called in supervisor mode.

Description

Allow a normal user-mode program to execute a short assembly language function in the supervisor mode of the processor. Supervisor() does not modify or save registers; the user function has full access to the register set. All rules that apply to interrupt code must be followed. In addition, no system calls are permitted.

Errors

You can very easily make the system unusable with this function. In fact it is recommended that you do not use it at all.

See also

SuperState | Enter supervisor state with user stack
UserState | Return to user state with user stack


TaggedOpenLibrary

Declaration

Source position: exec.pas line 2210

function TaggedOpenLibrary(

  d0arg: LongInt

):Pointer;


TLSAlloc

VarArgs version of TLSAllocA

Declaration

Source position: exec.pas line 2363

function TLSAlloc(

  const Tags: array of PtrUInt

):LongWord;


TLSAllocA

Allocate Thread-Local Storage index (V51.46)

Declaration

Source position: exec.pas line 2345

function TLSAllocA(

  Tags: Pointer

):LongWord;

Arguments

Tags

Pointer to a taglist, or nil

Function result

a global index to Thread-Local Storage or TLS_INVALID_INDEX if no index was available due to lack of resources.

Description

Allocates a Thread-Local Storage index from the global index pool.

Available Tags

TLSTAG_DESTRUCTOR

A function to call when TLSCallDestructors() function is called or when the task/process terminates. Default is to call no function. Passing nil has the same effect. destructor is called as

procedure(value: APTR; userdata: APTR);
TLSTAG_USERDATA
Optional userdata to the TLSTAG_DESTRUCTOR function. The default value is nil if thistag is not specified.

The destructor function should not take very long to complete. It is for example unwise to ask for user input or similar. The destructor may call TLSSetValue(index, nil) for the same index. It is also legal to TLSSetValue some other index to non-nil value. Refer to TLSCallDestructors documentation for details about this.

Care must be taken that all accessed resources are valid and accessible during destructor execution. It is also up to the caller to implement any arbitration of resources with for example signalsemaphore, if needed.

It is the responsiblity of the TLSAlloc caller to ensure that code pointed by TLSTAG_DESTRUCTOR will remain executable for the duration teh index is in use. Specifically the application may not terminate (which unloads the code segment) if there are any other tasks running which may call the destructor.

If you do not call TLSCallDestructors yourself the destructor will be executed when the process/task is about to terminate. For process this happens before struct Process fields are deallocated.

Attention

The destructor function must remain callable for as long as index remains allocated.

It is illegal to TLSFree an index while it is still being used by TLSGetValue and/or TLSSetValue by other tasks. The caller is responsible for making sure this does not happen.

See also

TLSAlloc | VarArgs version of TLSAllocA
TLSFree | Free Thread-Local Storage index
TLSCallDestructors | Call Thread-Local Storage index destructors for the given task (V51.46)
TLSSetValue | set the task specific value associated with a given Thread-Local Storage index (V51.46)
TLSGetValue | get the task specific value associated with a given Thread-Local Storage index (V51.46)

Example

uses
  Exec;
function func(value: APTR; userdata: APTR): APTR;
begin
  FreeVec(value);
end;
// ...
var
  TLSIndex: LongWord;
begin
  TLSIndex := TLSAlloc([TLSTAG_DESTRUCTOR, AsTag(@func),
                        TLSTAG_USERDATA,   AsTag(something),
                        TAG_DONE]);
  if TLSIndex <> TLS_INVALID_INDEX then
  begin

    // ... more code ...

    TLSFree(TLSIndex);
  end
end.


TLSCallDestructors

Call Thread-Local Storage index destructors for the given task (V51.46)

Declaration

Source position: exec.pas line 2349

procedure TLSCallDestructors(

  Task: PTask

);

Description

Calls destructors for all Thread-Local Storage indices with non-NULL value. The value is passed to the destructor as the first parameter. The value for the given index is set to nil before the call.

If new indices with destructors appear after the destructors have been called this function performs unspecified number of retries until either there are no more destructors to call or the function gives up due to excessive retry attempts.

Attention

TLSCallDestructors is mainly meant to be used by someone implementing a custom threading solution. This function can be called after the thread has completed its processing and is about the end.

Calling this function for any other purpose, or before being terminated is illegal.

Calling this function for other task than self is unwise. The destructor functions might not be called in this case, but could still get deallocated and not called again, ever. Just Don't Do It.

Errors

MorphOS 3.14 (exec 51.46) had a bug which resulted in the destructors being called out of the expected order. In particular this could cause issues if destructor execution expected destructors getting called once before (potentially) getting called again. This bug was fixed in MorphOS 3.15 (exec 51.48) and later versions. Now all destructors are guaranteed to get called once before getting called again due to non-nil value appearing during some destructor function execution.

See also

TLSFree | Free Thread-Local Storage index
TLSAlloc | VarArgs version of TLSAllocA
TLSSetValue | set the task specific value associated with a given Thread-Local Storage index (V51.46)
TLSGetValue | get the task specific value associated with a given Thread-Local Storage index (V51.46)

Example

procedure Proc(Parent: PTask; ParentSigMask: LongWord);
begin
  // Much work here...

  // Call destructors before we do internal cleanup
  TLSCallDestructors(nil);
  // Some cleanup that we need to do before exit

  Forbid();
  Signal(Parent, ParentSigMask);
end;

var
  Sig: ShortInt;
begin
  Sig := AllocSignal(-1);
  if Sig <> -1 then
  begin
    if CreateNewProc([
      NP_Entry,    AsTag(@Proc),
      NP_CodeType, CODETYPE_PPC,
      NP_PPC_Arg1, AsTag(FindTask(nil)),
      NP_PPC_Arg2, 1 shl Sig,
      TAG_DONE]) <> 0 then
    begin
      Wait(1 shl Sig);
    end;
  FreeSignal(Sig);
end;


TLSFree

Free Thread-Local Storage index

Declaration

Source position: exec.pas line 2346

function TLSFree(

  Idx: LongWord

):LongInt;

Arguments

Idx

Index to free. Must have been allocated with TLSAlloc earlier. Passing TLS_INVALID_INDEX is safe and does nothing.

Description

Deallocates a Thread-Local Storage index and returns it to the global index pool.

Attention

It is illegal to free a Thread-Local Storage index while it is still in use. Unspecified bad things may happen if this is done. The caller is responsible for ensuring that TLSFree is not called prematurely.

See also

TLSAlloc | VarArgs version of TLSAllocA
TLSGetValue | get the task specific value associated with a given Thread-Local Storage index (V51.46)
TLSSetValue | set the task specific value associated with a given Thread-Local Storage index (V51.46)
TLSCallDestructors | Call Thread-Local Storage index destructors for the given task (V51.46)


TLSGetValue

get the task specific value associated with a given Thread-Local Storage index (V51.46)

Declaration

Source position: exec.pas line 2347

function TLSGetValue(

  Idx: LongWord

):Pointer;

Arguments

Idx

index to return value for.

Function result

value associated with the current task.

Description

Return the task specific value currently associated with the given Thread-Local Storage index. Initial value is NULL if not yet set with TLSSetValue.

Attention

This function is safe to abort mid-execution: This means that there is are global locks, nor does any state change during the execution of this function. Typically you don't need to care about such issues but in some specific instances this information is valueable.

This function is very fast.

See also

TLSAlloc | VarArgs version of TLSAllocA
TLSFree | Free Thread-Local Storage index
TLSSetValue | set the task specific value associated with a given Thread-Local Storage index (V51.46)
TLSCallDestructors | Call Thread-Local Storage index destructors for the given task (V51.46)


TLSSetValue

set the task specific value associated with a given Thread-Local Storage index (V51.46)

Declaration

Source position: exec.pas line 2348

function TLSSetValue(

  Idx: LongWord;

  Value: Pointer

):LongInt;

Arguments

Idx | index to set value for.
Value | value to set.

Function result

Non-zero if the value could be set, zero if out of resources. Note that setting value to nil will always succeed.

Description

Set the task specific value associated with the given Thread-Local Storage index.

Attention

The result of this call must be checked and a viable error handling path taken.

See also

TLSFree | Free Thread-Local Storage index
TLSAlloc | VarArgs version of TLSAllocA
TLSCallDestructors | Call Thread-Local Storage index destructors for the given task (V51.46)
TLSGetValue | get the task specific value associated with a given Thread-Local Storage index (V51.46)

Example

type
  TTLSData = record
    foo: LongWord;
    bar: PChar;
    // ...
  end;
  PTLSData = ^TTtlsdata;

var
  TLSIndex: LongWord; // Set and cleaned up elsewhere
  TLSData: Ptlsdata;

begin
  Data := PTLSData(TLSGetValue(TLSIndex));
  if not Assigned(data) then
  begin
    data := PTLSData(AllocVec(SizeOf(Ttlsdata), MEMF_CLEAR));
    if not Assigned(data) or (TLSSetValue(TLSIndex, data) <> 0) then
    begin
      if Assigned(data) then
      begin
        FreeVec(data);
        data := NULL;
      end;
    end;
  end;

  if Assigned(data) then
  begin
    // Use the thread specific data. ...
  end;

  //...

  // Thread specific data is no longer needed, free it.
  data := PTLSData(TLSGetValue(tlsindex));
  if Assigned(data) then
  begin
    FreeVec(Data);
    TLSSetValue(tlsindex, nil); // Always succeeds
  end;
end;


TypeOfMem

Determine attributes of a given memory address

Declaration

Source position: exec.pas line 2040

function TypeOfMem(

  address: Pointer

):Cardinal;

Arguments

address

A memory address

Function result

A long word of memory attribute flags. If the address is not in known RAM, zero is returned.

Description

Given a RAM memory address, search the system memory lists and return its memory attributes. The memory attributes are similar to those specified when the memory was first allocated: (eg. MEMF_*)

If the address is not in known-space, a zero will be returned. (Anything that is not RAM, like the ROM or expansion area, will return zero. Also the first few bytes of a memory area are used up by the MemHeader.)


UserState

Return to user state with user stack

Declaration

Source position: exec.pas line 1818

procedure UserState(

  sysStack: Pointer

);

Arguments

sysStack

Supervisor stack pointer

Description

Return to user state with user stack, from supervisor state with user stack. This function is normally used in conjunction with the SuperState function.

This function must not be called from the user state.

See also

SuperState

Enter supervisor state with user stack


Vacate

Release a bidMessage from Procure()

Declaration

Source position: exec.pas line 2047

procedure Vacate(

  sigSem: PSignalSemaphore;

  bidMsg: PSemaphoreMessage

);

Arguments

sigSem | The SignalSemaphore that you wish to Vacate()
bidMsg | The SemaphoreMessage that you wish to abort. The message's ssm_Semaphore field will be cleared. The message will be replied if it is still on the waiting list. If it is not on the waiting list, it is assumed that the semaphore is owned and it will be released.

Description

This function can be used to release a semaphore obtained via Procure(). However, the main purpose for this call is to be able to remove a bid for a semaphore that has not yet responded. This is required when a Procure() was issued and the program no longer needs to get the semaphore and wishes to cancel the Procure() request. The canceled request will be replied with the ssm_Semaphore field set to nil. If you own the semaphore, the message was already replied and only the ssm_Semaphore field will be cleared.

See also

ObtainSemaphoreList | Get a List of semaphores
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
Procure | Asynchron locking of a semaphore


VNewRawDoFmt

Declaration

Source position: exec.pas line 2216

function VNewRawDoFmt(

  FmtString: PChar;

  PutChProc: Pointer;

  PutChData: PChar;

  args: PChar

):PChar;


Wait

Wait for one or more signals

Declaration

Source position: exec.pas line 1922

function Wait(

  signalSet: Cardinal

):Cardinal;

Arguments

signalSet

The set of signals for which to wait. Each bit represents a particular signal.

Function result

The set of signals that were active

Description

This function will cause the current task to suspend waiting for one or more signals. When one or more of the specified signals occurs, the task will return to the ready state, and those signals will be cleared.

If a signal occurred prior to calling Wait(), the wait condition will be immediately satisfied, and the task will continue to run without delay.

Warning:

This function cannot be called while in supervisor mode or interrupts! This function will break the action of a Forbid() or Disable() call.


WaitIO

Wait for completion of an I/O request

Declaration

Source position: exec.pas line 2007

function WaitIO(

  ioRequest: PIORequest

):ShortInt;

Arguments

ioRequest

A pointer to an I/O request block

Function result

A zero if successful, else an error is returned (a sign extended copy of io_Error).

Description

This function waits for the specified I/O request to complete, then removes it from the replyport. If the I/O has already completed, this function will return immediately.

This function should be used with care, as it does not return until the I/O request completes; if the I/O never completes, this function will never return, and your task will hang. If this situation is a possibility, it is safer to use the Wait() function. Wait() will return return when any of a specified set of signal is received. This is how I/O timeouts can be properly handled.

See also

DoIO | Perform an I/O request and wait for its finish
SendIO | Initiate an I/O command
CheckIO | Check status on an I/O request
AbortIO | Attempt to abort an in-progress I/O request


WaitPort

Wait for a given port to be non-empty

Declaration

Source position: exec.pas line 1957

function WaitPort(

  port: PMsgPort

):PMessage;

Arguments

port

A pointer to the message port

Function result

A pointer to the first available message

Description

This function waits for the given port to become non-empty. If necessary, the Wait() function will be called to wait for the port signal. If a message is already present at the port, this function will return immediately. The return value is always a pointer to the first message queued (but it is not removed from the queue).

More than one message may be at the port when this returns. It is proper to call the GetMsg() function in a loop until all messages have been handled, then wait for more to arrive.

To wait for more than one port, combine the signal bits from each port into one call to the Wait() function, then use a GetMsg() loop to collect any and all messages. It is possible to get a signal for a port WITHOUT a message showing up. Plan for this.

See also

GetMsg

Get next message from message port


Reference for unit 'gadtools': Procedures and functions

CreateContext

CreateGadgetA

CreateMenusA

DrawBevelBoxA

FreeGadgets

FreeMenus

FreeVisualInfo

GetVisualInfoA

GTMENUITEM_USERDATA

GTMENU_USERDATA

GT_BeginRefresh

GT_EndRefresh

GT_FilterIMsg

GT_GetGadgetAttrsA

GT_GetIMsg

GT_PostFilterIMsg

GT_RefreshWindow

GT_ReplyIMsg

GT_SetGadgetAttrsA

InitGadToolsLibrary

LayoutMenuItemsA

LayoutMenusA


Unit 'gadtools' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'gadtools': Variables

GadToolsBase


Index of all identifiers in unit 'gadtools'

A B C D F G I L M N P S T

A

ARROWIDCMP

B

BBFT_BUTTON | BBFT_RIDGE | BUTTON_KIND
BBFT_ICONDROPBOX | BUTTONIDCMP |

C

CHECKBOX_HEIGHT | CHECKBOX_WIDTH | CreateMenusA
CHECKBOXIDCMP | CreateContext | CYCLEIDCMP
CHECKBOX_KIND | CreateGadgetA | CYCLE_KIND

D

DrawBevelBoxA

F

FreeGadgets FreeMenus FreeVisualInfo

G

GADTOOLBIT | GTMENU_NOMEM | GT_Private0
GADTOOLMASK | GTMENU_TRIMMED | GT_RefreshWindow
GadToolsBase | GTMENU_USERDATA | GT_ReplyIMsg
GADTOOLSNAME | GTMN_AmigaKey | GT_Reserved0
GENERIC_KIND | GTMN_Checkmark | GT_Reserved1
GetVisualInfoA | GTMN_FrontPen | GTSC_Arrows
GTBB_FrameType | GTMN_FullMenu | GTSC_Overlap
GTBB_Recessed | GTMN_Menu | GTSC_Top
GT_BeginRefresh | GTMN_NewLookMenus | GTSC_Total
GTCB_Checked | GTMN_SecondaryError | GTSC_Visible
GTCB_Scaled | GTMN_TextAttr | GT_SetGadgetAttrsA
GTCY_Active | GTMX_Active | GTSL_DispFunc
GTCY_Labels | GTMX_Labels | GTSL_Justification
GT_EndRefresh | GTMX_Scaled | GTSL_Level
GT_FilterIMsg | GTMX_Spacing | GTSL_LevelFormat
GT_GetGadgetAttrsA | GTMX_TitlePlace | GTSL_LevelPlace
GT_GetIMsg | GTNM_BackPen | GTSL_Max
GTIN_MaxChars | GTNM_Border | GTSL_MaxLevelLen
GTIN_Number | GTNM_Clipped | GTSL_MaxPixelLen
GTJ_CENTER | GTNM_Format | GTSL_Min
GTJ_LEFT | GTNM_FrontPen | GTST_MaxChars
GTJ_RIGHT | GTNM_Justification | GTST_String
GTLV_CallBack | GTNM_MaxNumberLen | GT_TagBase
GTLV_ItemHeight | GTNM_Number | GTTX_BackPen
GTLV_Labels | GTNW_Active | GTTX_Border
GTLV_MakeVisible | GTNW_Labels | GTTX_Clipped
GTLV_MaxPen | GTPA_Color | GTTX_CopyText
GTLV_ReadOnly | GTPA_ColorOffset | GTTX_FrontPen
GTLV_ScrollWidth | GTPA_ColorTable | GTTX_Justification
GTLV_Selected | GTPA_Depth | GTTX_Text
GTLV_ShowSelected | GTPA_IndicatorHeight | GT_Underscore
GTLV_Top | GTPA_IndicatorWidth | GTVI_NewWindow
GTMENU_INVALID | GTPA_NumColors | GTVI_NWTags
GTMENUITEM_USERDATA | GT_PostFilterIMsg | GT_VisualInfo

I

IM_ITEM | INTEGERIDCMP | INTERWIDTH
IM_SUB | INTEGER_KIND |
InitGadToolsLibrary | INTERHEIGHT |

L

LayoutMenuItemsA | LVCB_OK | LVR_NORMALDISABLED
LayoutMenusA | LVCB_UNKNOWN | LVR_SELECTED
LISTVIEWIDCMP | LV_DRAW | LVR_SELECTEDDISABLED
LISTVIEW_KIND | LVR_NORMAL |

M

MENU_IMAGE | MXIDCMP | MX_WIDTH
MX_HEIGHT | MX_KIND |

N

NG_HIGHLABEL | NM_IGNORE | NUMBERIDCMP
NM_BARLABEL | NM_ITEM | NUMBER_KIND
NM_COMMANDSTRING | NM_ITEMDISABLED | NUM_KINDS
NM_END | NM_MENUDISABLED | NWAYIDCMP
NM_FLAGMASK | NM_SUB | NWAY_KIND
NM_FLAGMASK_V39 | NM_TITLE |

P

PALETTEIDCMP | PLACETEXT_IN | pNewGadget
PALETTE_KIND | PLACETEXT_LEFT | pNewMenu
PLACETEXT_ABOVE | PLACETEXT_RIGHT |
PLACETEXT_BELOW | pLVDrawMsg |

S

SCROLLERIDCMP | SLIDERIDCMP | STRINGIDCMP
SCROLLER_KIND | SLIDER_KIND | STRING_KIND

T

TEXTIDCMP | tLVDrawMsg | tNewMenu
TEXT_KIND | tNewGadget |


CreateContext

Declaration

Source position: gadtools.pas line 440

function CreateContext(

  glistptr: PGadget

):PGadget;


CreateGadgetA

Declaration

Source position: gadtools.pas line 441

function CreateGadgetA(

  kind: LongWord;

  gad: PGadget;

  const ng: pNewGadget;

  const taglist: PTagItem

):PGadget;


CreateMenusA

Declaration

Source position: gadtools.pas line 442

function CreateMenusA(

  const newmenu: pNewMenu;

  const taglist: PTagItem

):PMenu;


DrawBevelBoxA

Declaration

Source position: gadtools.pas line 443

procedure DrawBevelBoxA(

  rport: PRastPort;

  left: LongInt;

  top: LongInt;

  width: LongInt;

  height: LongInt;

  const taglist: PTagItem

);


FreeGadgets

Declaration

Source position: gadtools.pas line 444

procedure FreeGadgets(

  gad: PGadget

);


FreeMenus

Declaration

Source position: gadtools.pas line 445

procedure FreeMenus(

  menu: PMenu

);


FreeVisualInfo

Declaration

Source position: gadtools.pas line 446

procedure FreeVisualInfo(

  vi: POINTER

);


GetVisualInfoA

Declaration

Source position: gadtools.pas line 447

function GetVisualInfoA(

  screen: PScreen;

  const taglist: PTagItem

):POINTER;


GTMENUITEM_USERDATA

Declaration

Source position: gadtools.pas line 460

function GTMENUITEM_USERDATA(

  menuitem: PMenuItem

):pointer;


GTMENU_USERDATA

Declaration

Source position: gadtools.pas line 461

function GTMENU_USERDATA(

  menu: PMenu

):pointer;


GT_BeginRefresh

Declaration

Source position: gadtools.pas line 448

procedure GT_BeginRefresh(

  win: PWindow

);


GT_EndRefresh

Declaration

Source position: gadtools.pas line 449

procedure GT_EndRefresh(

  win: PWindow;

  complete: LongInt

);


GT_FilterIMsg

Declaration

Source position: gadtools.pas line 450

function GT_FilterIMsg(

  const imsg: PIntuiMessage

):PIntuiMessage;


GT_GetGadgetAttrsA

Declaration

Source position: gadtools.pas line 451

function GT_GetGadgetAttrsA(

  gad: PGadget;

  win: PWindow;

  req: PRequester;

  const taglist: PTagItem

):LongInt;


GT_GetIMsg

Declaration

Source position: gadtools.pas line 452

function GT_GetIMsg(

  iport: PMsgPort

):PIntuiMessage;


GT_PostFilterIMsg

Declaration

Source position: gadtools.pas line 453

function GT_PostFilterIMsg(

  imsg: PIntuiMessage

):PIntuiMessage;


GT_RefreshWindow

Declaration

Source position: gadtools.pas line 454

procedure GT_RefreshWindow(

  win: PWindow;

  req: PRequester

);


GT_ReplyIMsg

Declaration

Source position: gadtools.pas line 455

procedure GT_ReplyIMsg(

  imsg: PIntuiMessage

);


GT_SetGadgetAttrsA

Declaration

Source position: gadtools.pas line 456

procedure GT_SetGadgetAttrsA(

  gad: PGadget;

  win: PWindow;

  req: PRequester;

  const taglist: PTagItem

);


InitGadToolsLibrary

Declaration

Source position: gadtools.pas line 463

function InitGadToolsLibrary: Boolean;


LayoutMenuItemsA

Declaration

Source position: gadtools.pas line 457

function LayoutMenuItemsA(

  firstitem: PMenuItem;

  vi: POINTER;

  const taglist: PTagItem

):LongBool;


LayoutMenusA

Declaration

Source position: gadtools.pas line 458

function LayoutMenusA(

  firstmenu: PMenu;

  vi: POINTER;

  const taglist: PTagItem

):LongBool;


Reference for unit 'get9': Procedures and functions

DNetCheck

InitGet9Library


Unit 'get9' | Package
[Overview][Constants][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'get9': Variables

Get9Base


Index of all identifiers in unit 'get9'

D G I

D

DNetCheck

G

Get9Base GET9NAME

I

InitGet9Library


DNetCheck

Declaration

Source position: get9.pas line 30

procedure DNetCheck(

  force: Boolean

);


InitGet9Library

Declaration

Source position: get9.pas line 33

function InitGet9Library: Boolean;


Reference for unit 'icon': Procedures and functions

AddFreeList | Add memory to a free list.
BumpRevision | Reformat a name for a second copy.
ChangeToSelectedIconColor | Modify an RGB colour value for use in a selected icon image
DeleteDiskObject | Delete a Workbench disk object from disk.
DrawIconStateA | Draw an icon as if it were an image
DupDiskObjectA | Duplicate an icon
FindToolType | Find the value of a ToolType variable.
FreeDiskObject | Free all memory in a Workbench disk object.
FreeFreeList | Free all memory in a free list.
GetDefDiskObject | Read default wb disk object from disk.
GetDiskObject | Read in a Workbench disk object from disk.
GetDiskObjectNew | Read in a Workbench disk object from disk.
GetIconRectangleA | Query the size of the area an icon renders into
GetIconTagList | Retrieve an icon
IconControlA | Set and get icon and icon.library options
LayoutIconA | Adapt a palette-mapped icon for display
MatchToolValue | Check a tool type variable for a particular value.
NewDiskObject | Create an empty icon
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
PutDefDiskObject | Write disk object as the default for its type.
PutDiskObject | Write out a DiskObject to disk.
PutIconTagList | Store an icon


Unit 'icon' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'icon': Variables

IconBase


Index of all identifiers in unit 'icon'

A B C D F G I L M N P T

A

AddFreeList

B

BumpRevision

C

ChangeToSelectedIconColor

D

DeleteDiskObject DrawIconStateA DupDiskObjectA

F

FindToolType FreeDiskObject FreeFreeList

G

GetDefDiskObject | GetDiskObjectNew | GetIconTagList
GetDiskObject | GetIconRectangleA |

I

ICONA_Dummy | ICONCTRLA_GetPalette2 | ICONDRAWA_Borderless
ICONA_ErrorCode | ICONCTRLA_GetPaletteSize1 | ICONDRAWA_DrawInfo
ICONA_ErrorTagItem | ICONCTRLA_GetPaletteSize2 | ICONDRAWA_EraseBackground
ICONA_LAST_TAG | ICONCTRLA_GetScreen | ICONDRAWA_Frameless
ICONA_Reserved1 | ICONCTRLA_GetTransparentColor1 | ICONDRAWA_IsLink
ICONA_Reserved2 | ICONCTRLA_GetTransparentColor2 | ICONDUPA_ActivateImageData
ICONA_Reserved3 | ICONCTRLA_GetWidth | ICONDUPA_DuplicateDefaultTool
ICONA_Reserved4 | ICONCTRLA_HasRealImage2 | ICONDUPA_DuplicateDrawerData
ICONA_Reserved5 | ICONCTRLA_IsNativeIcon | ICONDUPA_DuplicateImageData
ICONA_Reserved6 | ICONCTRLA_IsNewIcon | ICONDUPA_DuplicateImages
ICONA_Reserved7 | ICONCTRLA_IsPaletteMapped | ICONDUPA_DuplicateToolTypes
ICONA_Reserved8 | ICONCTRLA_SetAspectRatio | ICONDUPA_DuplicateToolWindow
ICON_ASPECT_RATIO_UNKNOWN | ICONCTRLA_SetFrameless | ICONGETA_FailIfUnavailable
IconBase | ICONCTRLA_SetGlobalColorIconSupport | ICONGETA_GenerateImageMasks
IconControlA | ICONCTRLA_SetGlobalEmbossRect | ICONGETA_GetDefaultName
ICONCTRLA_GetAspectRatio | ICONCTRLA_SetGlobalFrameless | ICONGETA_GetDefaultType
ICONCTRLA_GetFrameless | ICONCTRLA_SetGlobalIdentifyHook | ICONGETA_GetPaletteMappedIcon
ICONCTRLA_GetGlobalColorIconSupport | ICONCTRLA_SetGlobalMaxNameLength | ICONGETA_IsDefaultIcon
ICONCTRLA_GetGlobalEmbossRect | ICONCTRLA_SetGlobalNewIconsSupport | ICONGETA_Label
ICONCTRLA_GetGlobalFrameless | ICONCTRLA_SetGlobalPrecision | ICONGETA_RemapIcon
ICONCTRLA_GetGlobalIdentifyHook | ICONCTRLA_SetGlobalScreen | ICONGETA_Screen
ICONCTRLA_GetGlobalMaxNameLength | ICONCTRLA_SetHeight | ICONNAME
ICONCTRLA_GetGlobalNewIconsSupport | ICONCTRLA_SetImageData1 | ICONPUTA_DropChunkyIconImage
ICONCTRLA_GetGlobalPrecision | ICONCTRLA_SetImageData2 | ICONPUTA_DropNewIconToolTypes
ICONCTRLA_GetGlobalScreen | ICONCTRLA_SetNewIconsSupport | ICONPUTA_DropPlanarIconImage
ICONCTRLA_GetHeight | ICONCTRLA_SetPalette1 | ICONPUTA_NotifyWorkbench
ICONCTRLA_GetImageData1 | ICONCTRLA_SetPalette2 | ICONPUTA_OnlyUpdatePosition
ICONCTRLA_GetImageData2 | ICONCTRLA_SetPaletteSize1 | ICONPUTA_OptimizeImageSpace
ICONCTRLA_GetImageMask1 | ICONCTRLA_SetPaletteSize2 | ICONPUTA_PreserveOldIconImages
ICONCTRLA_GetImageMask2 | ICONCTRLA_SetTransparentColor1 | ICONPUTA_PutDefaultName
ICONCTRLA_GetNewIconsSupport | ICONCTRLA_SetTransparentColor2 | ICONPUTA_PutDefaultType
ICONCTRLA_GetPalette1 | ICONCTRLA_SetWidth |

L

LayoutIconA

M

MatchToolValue

N

NewDiskObject

P

PACK_ICON_ASPECT_RATIO | PutDefDiskObject | PutIconTagList
PIconIdentifyMsg | PutDiskObject |

T

tIconIdentifyMsg


AddFreeList

Add memory to a free list.

Declaration

Source position: icon.pas line 351

function AddFreeList(

  freelist: PFreeList;

  const mem: POINTER;

  size: LongWord

):LongBool;

Arguments

freelist | A Pointer to freelist struct previously allocated by the programmer.
mem | Memory to add to the freelist.
size | Size of memory chunk to add to the frelist.

Function result

TRue if the call succeeded else False

Description

This routine adds the specified memory to the free list. The free list will be extended (if required). If there is not enough memory to complete the call, NULL is returned.

Note that AddFreeList() does not allocate the requested memory. It only records the memory in the free list.

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Allocate many regions of memory
FreeFreeList | Free all memory in a free list.


BumpRevision

Reformat a name for a second copy.

Declaration

Source position: icon.pas line 352

function BumpRevision(

  newname: pCHAR;

  const oldname: pCHAR

):pCHAR;

function BumpRevision(

  newname: pCHar;

  const oldname: RawByteString

):pCHAR;

Arguments

newname | The new buffer that will receive the name (it must be at least 31 characters long).
oldname | The original name

Function result

Pointer to NewName

Arguments

newname | The new buffer that will receive the name (it must be at least 31 characters long).
oldname | The original name

Description

BumpRevision takes a name and turns it into a "copy_of_name". It knows how to deal with copies of copies. The routine will truncate the new name to the maximum dos name size (currently 30 characters).

Examples:

OldName | NewName
'foo' | 'copy_of_foo'
'copy_of_foo' | 'copy_2_of_foo'
'copy foo' | 'copy_1_of_foo'
'012345678901234567890123456789' | 'copy_of_0123456789012345678901'


ChangeToSelectedIconColor

Modify an RGB colour value for use in a selected icon image

Declaration

Source position: icon.pas line 373

procedure ChangeToSelectedIconColor(

  cr: pColorRegister

);

Arguments

cr

Pointer to a ColorRegister, containing the RGB colour value to be changed.

Description

This function will change the provided RGB colour value to make it suitable for use in an icon's select image. This may involve darkening or toning the colour. Usually, icon.library calls this function when creating a select image for palette mapped icons which do not contain "real" select images.


DeleteDiskObject

Delete a Workbench disk object from disk.

Declaration

Source position: icon.pas line 353

function DeleteDiskObject(

  const name: pCHAR

):LongBool;

function DeleteDiskObject(

  const name: RawByteString

):Boolean;

Arguments

name

Name of the icon file without the ".info"

Function result

True if it worked, False if not, check IoErr() for details.

Arguments

name

Name of the icon file without the ".info"

Description

This routine will try to delete a Workbench disk object from disk. The name parameter will have ".info" postpended to it, and the icon file of that name will be deleted. If the call fails, it will return False. The reason for the failure may be obtained via IoErr().

This call also updates the Workbench screen if needed.

Using this routine protects you from any future changes to the way icons are stored within the system.

See also

IoErr() | Return extra information from the system
PutDiskObject | Write out a DiskObject to disk.
GetDiskObject | Read in a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetIconTagList | Retrieve an icon
PutIconTagList | Store an icon


DrawIconStateA

Draw an icon as if it were an image

Declaration

Source position: icon.pas line 367

procedure DrawIconStateA(

  rp: PRastPort;

  const icon: PDiskObject;

  const label_: pCHAR;

  leftOffset: LongInt;

  topOffset: LongInt;

  state: LongWord;

  const tags: PTagItem

);

Arguments

rp | Pointer to the RastPort to draw into; the RastPort clipping rules, font, style, text colours and drawing mode will be used.
icon | Pointer to a struct DiskObject.
label_ | Label for the icon, if nil no label is printed
state | Select how and which icon image should be drawn; (IDS_*)
tags | Additional drawing options (ICONDRAWA_*)

Description

This function will draw an icon as if it were an image; if a label is provided, it will be printed below it.

See also

DrawImageState | Draw an (extended) Intuition Image with special visual state.
GetIconRectangleA | Query the size of the area an icon renders into
IconControlA | Set and get icon and icon.library options


DupDiskObjectA

Duplicate an icon

Declaration

Source position: icon.pas line 365

function DupDiskObjectA(

  const diskObject: PDiskObject;

  const tags: PTagItem

):PDiskObject;

Arguments

tags

Control options. (ICONDUPA_*)

Function result

Pointer to a struct DiskObject or nil in case of error. You can use IoErr() to retrieve the error code or use the ICONA_ErrorCode tag instead.

Description

This function is used to create a duplicate of a DiskObject in memory. It can also be used to create an extended ("native") DiskObject data structure from an existing, traditional format DiskObject data structure.

See also

IoErr()

Return extra information from the system


FindToolType

Find the value of a ToolType variable.

Declaration

Source position: icon.pas line 354

function FindToolType(

  const toolTypeArray: POINTER;

  const typeName: pCHAR

):pCHAR;

function FindToolType(

  const toolTypeArray: POINTER;

  const typeName: RawByteString

):pCHAR;

Arguments

toolTypeArray | A Pointer to an array of tool types.
typeName | The name of the tooltype entry

Arguments

toolTypeArray | A Pointer to an array of tool types.
typeName | The name of the tooltype entry

Description

This function searches a tool type array for a given entry, and returns a pointer to that entry. This is useful for finding standard tool type variables. The returned value is not a new copy of the string but is only a pointer to the part of the string after TypeName.

The ToolTypeArray can be get from TDiskObject.do_Tooltypes via GetDiskObject()

Snippet

//Assume the tool type array has two strings in it:
//    "FILETYPE=text"
//    "TEMPDIR=:t"
FindToolType(toolTypeArray, 'FILETYPE'); // returns 'text'
FindToolType(toolTypeArray, 'filetype'); // returns 'text'
FindToolType(toolTypeArray, 'TEMPDIR');  // returns ':t'
FindToolType(toolTypeArray, 'MAXSIZE');  // returns nil
FindToolType(toolTypeArray, 'text');     // returns nil
FindToolType(toolTypeArray, ':t');       // returns nil

See also

FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObject | Read in a Workbench disk object from disk.
MatchToolValue | Check a tool type variable for a particular value.
PDiskObject |


FreeDiskObject

Free all memory in a Workbench disk object.

Declaration

Source position: icon.pas line 355

procedure FreeDiskObject(

  diskobj: PDiskObject

);

Arguments

diskobj

A pointer to a DiskObject structure to free. Nil is allowed and does nothing.

Description

This routine frees all memory in a Workbench disk object, and the object itself. It is implemented via FreeFreeList().

GetDiskObject() takes care of all the initialization required to set up the object's free list. This procedure may only be called on a DiskObject allocated via GetDiskObject().

See also

GetDiskObject | Read in a Workbench disk object from disk.
PutDiskObject | Write out a DiskObject to disk.
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeFreeList | Free all memory in a free list.
GetIconTagList | Retrieve an icon
PutIconTagList | Store an icon


FreeFreeList

Free all memory in a free list.

Declaration

Source position: icon.pas line 356

procedure FreeFreeList(

  freelist: PFreeList

);

Arguments

freelist

A Pointer to FreeList struct. Nil is allowed and does nothing.

Description

This routine frees all memory in a free list, and the free list itself. It is useful for easily getting rid of all memory in a series of structures. There is a free list in a Workbench object, and this contains all the memory associated with that object.

A TFreeList is a list of TMemList structures. See the TMemList and TMemEntry documentation for more information.

If the TFreeList itself is in the free list, it must be in the first TMemList in the TFreeList.

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Free many blocks of memory at once
AddFreeList | Add memory to a free list.


GetDefDiskObject

Read default wb disk object from disk.

Declaration

Source position: icon.pas line 357

function GetDefDiskObject(

  typ: LongInt

):PDiskObject;

Arguments

typ

Default icon type (Workbench.WBDISK thru Workbench.WBKICK see links).

Function result

The default Workbench disk object in question

Description

This routine reads in a default Workbench disk object from disk. The valid def_types can be found in workbench/workbench.h and currently include WBDISK thru WBKICK. If the call fails, it will return NULL. The reason for the failure may be obtained via IoErr().

Using this routine protects you from any future changes to the way default icons are stored within the system.

See also

IoErr() | Return extra information from the system
PutDefDiskObject | Write disk object as the default for its type.
PutIconTagList | Store an icon
WBDISK | Type of Icon: Disk
WBDRAWER | Type of Icon: Drawer/Folder
WBTOOL | Type of Icon: Tool (Excutable)
WBPROJECT | Type of Icon: Project (Data file)
WBGARBAGE | Type of Icon: Trashcan
WBDEVICE | Type of Icon: Device
WBKICK | Type of Icon: KickStart disk
WBAPPICON | Type of Icon: AppIcon


GetDiskObject

Read in a Workbench disk object from disk.

Declaration

Source position: icon.pas line 358

function GetDiskObject(

  const name: pCHAR

):PDiskObject;

function GetDiskObject(

  const name: RawByteString

):PDiskObject;

Arguments

name

Name of the object or nil if you just want a DiskObject structure allocated for you (useful when calling AddAppIcon() in workbench.library).

Function result

The Workbench disk object in question

Arguments

name

Name of the object or nil if you just want a DiskObject structure allocated for you (useful when calling AddAppIcon() in workbench.library).

Description

This routine reads in a Workbench disk object in from disk. The name parameter will have ".info" postpended to it, and the icon file of that name will be read. If the call fails, it will return nil. The reason for the failure may be obtained via IoErr().

Using this routine protects you from any future changes to the way icons are stored within the system.

A TFreeList structure is allocated just after the DiskObject structure; FreeDiskObject() makes use of this to get rid of the memory that was allocated.

See also

IoErr() | Return extra information from the system
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObjectNew | Read in a Workbench disk object from disk.
GetIconTagList | Retrieve an icon
NewDiskObject | Create an empty icon
PutDiskObject | Write out a DiskObject to disk.
PutIconTagList | Store an icon
AddAppIconA |


GetDiskObjectNew

Read in a Workbench disk object from disk.

Declaration

Source position: icon.pas line 359

function GetDiskObjectNew(

  const name: pCHAR

):PDiskObject;

function GetDiskObjectNew(

  const name: RawByteString

):PDiskObject;

Arguments

name

Name of the object or nil if you just want a DiskObject structure allocated for you (useful when calling AddAppIcon() in workbench.library).

Function result

The Workbench disk object in question

Arguments

name

Name of the object or nil if you just want a DiskObject structure allocated for you (useful when calling AddAppIcon() in workbench.library).

Description

This routine reads in a Workbench disk object in from disk. The name parameter will have ".info" postpended to it, and the icon file of that name will be read. If the call fails, it will return zero. The reason for the failure may be obtained via IoErr().

Using this routine protects you from any future changes to the way icons are stored within the system.

A TFreeList structure is allocated just after the DiskObject structure; FreeDiskObject() makes use of this to get rid of the memory that was allocated.

This call is functionally identical to GetDiskObject() with one exception. If its call to GetDiskObject() fails, this function calls GetDefDiskObject(). This is useful when there is no .info file for the icon you are trying to get a disk object for. Applications that use workbench application windows must use this call if they want to handle the user dropping an icon (that doesn't have a '.info' file) on their window.

See also

IoErr() | Return extra information from the system
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObject | Read in a Workbench disk object from disk.
GetIconTagList | Retrieve an icon
NewDiskObject | Create an empty icon
PutDiskObject | Write out a DiskObject to disk.
PutIconTagList | Store an icon
AddAppIconA |


GetIconRectangleA

Query the size of the area an icon renders into

Declaration

Source position: icon.pas line 368

function GetIconRectangleA(

  rp: PRastPort;

  const icon: PDiskObject;

  const label_: pCHAR;

  rect: PRectangle;

  const tags: PTagItem

):LongBool;

Arguments

rp | Pointer to the RastPort to use for calculating the the size of the label with respect to the font and style options currently in use; this parameter may be NULL if the label is NULL, too.
icon | True if the parameters were well-formed and the output data fits into the Rectangle data structure (which may not be the case if the image is too large for a signed 16 bit integer to hold).
label_ | Label for icon, if nil no text is calculated
rect | Pointer to a Rectangle to fill in. The contents will take the size of the icon image, the icon border size and -- if you provide RastPort and label text -- the icon label into account. Due to how labels are printed, the rectangle^.MinX and rectangle^.MinY members may be negative.
tags | Additional drawing options to be taken into account. (ICONDRAWA_*)

Description

This function will calculate the size of the area icon rendering would affect.

Notes:

This function can be used to optimize on-screen rendering by precalculating the area rendering would cover. To make sure that the precalculated area size matches the one covered by the actual drawing operation, the RastPorts you use for measuring and for drawing should share the same font and the same text styles.

The image size calculated by this function can be slightly larger than the data you will find in the icon's do_Gadget.GadgetRender Image structure since the icon border will be taken into account. This happens regardless of whether icon.library was switched into frameless icon rendering mode or whether the icon is frameless. To obtain the size of the icon without taking the border into account, use the ICONDRAWA_Borderless tag.

See also

DrawIconStateA | Draw an icon as if it were an image
IconControlA | Set and get icon and icon.library options


GetIconTagList

Retrieve an icon

Declaration

Source position: icon.pas line 370

function GetIconTagList(

  const name: pCHAR;

  const tags: PTagItem

):PDiskObject;

function GetIconTagList(

  const name: RawByteString;

  const tags: PTagItem

):PDiskObject;

Arguments

name | Name of the object an icon is to be retrieved for, or nil if a default icon is to be retrieved.
tags | Retrieval options. (ICONGETA_*)

Function result

Pointer to a struct DiskObject or nil in case of error. You can use IoErr() to retrieve the error code or use the ICONA_ErrorCode tag instead.

Arguments

name | Name of the object an icon is to be retrieved for, or nil if a default icon is to be retrieved.
tags | Retrieval options. (ICONGETA_*)

Description

This function is used to retrieve an icon; the icon can belong to a file/drawer/volume or it can be a default icon.

This function is a superset of GetDefDiskObject(), GetDiskObject() and GetDiskObjectNew().

If a palette-mapped icon is set to allocate its colours from the default screen, such as the Workbench screen, icon.library may resort to remap its colours in the course of Workbench screen close/reopen transitions. This means that you cannot depend upon the icon's image bitmaps to stay the same size, shape or colour. If this is what you need, you should either create your own images from the palette mapped data or make copies of the icon image bitmaps and the associated colour table.

If during Workbench close/open transitions the global remap screen becomes nil, GetIconTagList() may refuse to return a remapped icon and return with an error (ERROR_REQUIRED_ARG_MISSING) instead.

See also

GetDiskObject | Read in a Workbench disk object from disk.
GetDiskObjectNew | Read in a Workbench disk object from disk.
GetDefDiskObject | Read default wb disk object from disk.
IconControlA | Set and get icon and icon.library options
PutIconTagList | Store an icon


IconControlA

Set and get icon and icon.library options

Declaration

Source position: icon.pas line 366

function IconControlA(

  icon: PDiskObject;

  const tags: PTagItem

):LongWord;

Arguments

icon | Pointer to a struct DiskObject, or NULL if global options are to be modified/queried.
tags | Options to modify/query.

Function result

Number of tags that were processed correctly, i.e. the number of tags whose parameters are in order, for which information could be returned, etc. If processing stops because of an error, the number returned by this function will be smaller than the number of tag items passed in. The same happens if the information you wanted to obtain is unavailable. In any case, check the error code this routine can set up for you.

Changing an icon's palette or image data does not automatically produce a different icon image you can use. To do this, you must re-layout it using LayoutIconA().

When querying parameters, make sure to always pass in a pointer to a LongWord variable to store the result in.

Some get/set operations may cause additional memory to be allocated. This may fail; be prepared.

IconControlA() processes the tag item list in sequential order. This has consequences for several tags, such as the palette size and the transparent colour. For example, if you want to make colour #14 of an icon image transparent, make sure to have the palette size set to at least 15 colours before you try to change the transparent colour. Otherwise, IconControlA() may refuse to set the transparent colour to #14 since it won't know that there should be more than 14 colours in that image at the time you try to set it. Therefore, if you wanted to change the palette size and the transparent colour in the same tag item list, make sure that the palette size change tag appears before the transparent colour change tag.

As described above, some of the operations on icons are not supported for DiskObjects not allocated through icon.library. In such cases you will receive an error code ERROR_ACTION_NOT_KNOWN.

Description

This function is used to modify and query icon and icon.library options.

See also

IoErr | Return extra information from the system
DupDiskObjectA | Duplicate an icon
GetIconTagList | Retrieve an icon
LayoutIconA | Adapt a palette-mapped icon for display
NewDiskObject | Create an empty icon
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ObtainBestPenA | Search for the closest color match, or allocate a new one.
CallHookPkt | Invoke a Hook function callback.


LayoutIconA

Adapt a palette-mapped icon for display

Declaration

Source position: icon.pas line 372

function LayoutIconA(

  icon: PDiskObject;

  screen: PScreen;

  tags: PTagItem

):LongBool;

Arguments

icon | The icon to be remapped. This must be a palette mapped icon.
screen | Pointer to a screen to remap the icon for or nil to remap the icon to use the system default colour palette or something very similar to it (this means: four colours only).
tags | Additional rendering options. OBP_Precision

Function result

True if the icon could be remapped, False if the remapping failed for some reason. In case of of failure, icon.library will try its best to keep the icon in a presentable state, but this may fail. In case of failure, the error code can be retrieved using IoErr().

Description

This function will prepare an icon for display, either on a specific screen or using a default colour palette. It is useful only for palette mapped icons.

You must make sure that the screen you remap to does not go away while there is an icon to use its colours. For a public screen, the easiest way to guarantee this is to keep it locked (see LockPubScreen()). For custom screens, just don't close them! If you have to close the screen or need to keep your icon around until after a screen is closed, you should call LayoutIconA() with a nil screen parameter. This will release all pens the icon has allocated and remap the icon to a default set of colours. Alternatively, you can dispose of the icon via FreeDiskObject() which will also release all pens the icon has allocated, including the icon itself, of course.

Icons remapped to the global default screen (normally, that would be the Workbench screen) may get changed and remapped again during Workbench close/open transitions. To prevent this from taking place, just make sure that the Workbench screen does not close (e.g. via LockPubScreen()("Workbench")).

See also

IoErr | Return extra information from the system
ObtainBestPenA | Search for the closest color match, or allocate a new one.
ObtainBestPenA | Release an allocated palette entry to the free pool.
FreeDiskObject | Free all memory in a Workbench disk object.
GetIconTagList | Retrieve an icon
IconControlA | Set and get icon and icon.library options
LockPubScreen | Prevent a public screen from closing.
UnLockPubScreen | Release lock on a public screen.


MatchToolValue

Check a tool type variable for a particular value.

Declaration

Source position: icon.pas line 360

function MatchToolValue(

  const typeString: pCHAR;

  const value: pCHAR

):LongBool;

function MatchToolValue(

  const typeString: RawByteString;

  const value: pCHAR

):Boolean;

function MatchToolValue(

  const typeString: pCHAR;

  const value: RawByteString

):Boolean;

function MatchToolValue(

  const typeString: RawByteString;

  const value: RawByteString

):Boolean;

Arguments

typeString | A ToolType value (as returned by FindToolType())
value | You are interested if value appears in TypeString

Function result

True if the value was in TypeString else False.

Arguments

typeString | A ToolType value (as returned by FindToolType())
value | You are interested if value appears in TypeString

Arguments

typeString | A ToolType value (as returned by FindToolType())
value | You are interested if value appears in TypeString

Arguments

typeString | A ToolType value (as returned by FindToolType())
value | You are interested if value appears in TypeString

Description

MatchToolValue is useful for parsing a tool type value for a known value. It knows how to parse the syntax for a tool type value (in particular, it knows that '|' separates alternate values). Note that the parsing is case insensitive.

Snippet

//Assume there are two type strings:
type1 := 'text';
type2 := 'a|b|c';
MatchToolValue(type1, 'text'); // returns True
MatchToolValue(type1, 'TEXT'); // returns True
MatchToolValue(type1, 'data'); // returns False
MatchToolValue(type2, 'a');    // returns True
MatchToolValue(type2, 'b');    // returns True
MatchToolValue(type2, 'd');    // returns False
MatchToolValue(type2, 'a|b');  // returns False

See also

FindToolType | Find the value of a ToolType variable.
Stricmp | Case-insensitive string comparison.


NewDiskObject

Create an empty icon

Declaration

Source position: icon.pas line 369

function NewDiskObject(

  type_: LongInt

):PDiskObject;

Arguments

type_

Icon type to create, this must be one of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK.

Function result

Pointer to a struct DiskObject or nil in case of error. You can use IoErr() to retrieve the error code.

Description

This function is used to create an "empty" DiskObject structure, which has no image data associated with it. Still, all the necessary structures are in place, you just have to fill them in.

The DiskObject returned by this function will have a zero width and height Image in the do_Gadget.GadgetRender member and the do_Gadget.Width/do_Gadget.Height members will both be 0, too.

See also

IoErr()

Return extra information from the system


PACK_ICON_ASPECT_RATIO

Pack Numerator and a denominator into a single byte as icon aspect

Declaration

Source position: icon.pas line 391

function PACK_ICON_ASPECT_RATIO(

  num: LongInt;

  den: LongInt

):LongInt;

Arguments

num | Numerator
den | Denominator

See also

ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
IconControlA | Set and get icon and icon.library options


PutDefDiskObject

Write disk object as the default for its type.

Declaration

Source position: icon.pas line 361

function PutDefDiskObject(

  const diskObject: PDiskObject

):LongBool;

Function result

True if the call succeeded else False

Description

This routine writes out a DiskObject structure, and its associated information. If the call fails, False will be returned. The reason for the failure may be obtained via IoErr().

Note that this function calls PutDiskObject() internally which means that this call (if sucessful) notifies workbench than an icon has been created/modified.

Using this routine protects you from any future changes to the way default icons are stored within the system.

See also

IoErr() | Return extra information from the system
GetDefDiskObject | Read default wb disk object from disk.
GetIconTagList | Retrieve an icon
PutDiskObject | Write out a DiskObject to disk.


PutDiskObject

Write out a DiskObject to disk.

Declaration

Source position: icon.pas line 362

function PutDiskObject(

  const name: pCHAR;

  const diskobj: PDiskObject

):LongBool;

function PutDiskObject(

  const name: RawByteString;

  const diskobj: PDiskObject

):Boolean;

Arguments

name

Name of the object

Arguments

name

Name of the object

Description

This routine writes out a DiskObject structure, and its associated information. The file name of the info file will be the name parameter with ".info" postpended to it. If the call fails, False will be returned. The reason for the failure may be obtained via IoErr().

PutDiskObject() (if successful) notifies Workbench when an icon has been created/modified.

Using this routine protects you from any future changes to the way icons are stored within the system.

Note:

It is recommended that if you wish to copy an icon from one place to another than you use GetDiskObject() and PutDiskObject() and do not copy them directly.

See also

IoErr() | Return extra information from the system
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObject | Read in a Workbench disk object from disk.
GetIconTagList | Retrieve an icon
PutIconTagList | Store an icon


PutIconTagList

Store an icon

Declaration

Source position: icon.pas line 371

function PutIconTagList(

  const name: pCHAR;

  const icon: PDiskObject;

  const tags: PTagItem

):LongBool;

function PutIconTagList(

  const name: RawByteString;

  const icon: PDiskObject;

  const tags: PTagItem

):Boolean;

Arguments

name | Name of the object the icon is to be stored for, or nil if a default icon is to be stored.
icon | The icon to be stored.
tags | Storage options. (ICONPUTA_*)

Function result

True if the icon file could be stored, FALSE otherwise. You can use IoErr() to retrieve the error code or use the ICONA_ErrorCode tag instead.

Arguments

name | Name of the object the icon is to be stored for, or nil if a default icon is to be stored.
icon | The icon to be stored.
tags | Storage options. (ICONPUTA_*)

Description

This function is used to store an icon; the icon can belong to a file/drawer/volume or it can be a default icon.

This function is a superset of PutDefDiskObject() and PutDiskObject().

If the name of the icon file to be stored would be too long to fit (as set with IconControlA(..., ICONCTRLA_SetGlobalMaxNameLength, ...)) then PutIconTagList() will silently pretend that the icon file has been written to disk. However, it will not store the icon file on the disk since there would a risk of accidentally overwriting the file the icon belongs to. If you want to know whether the icon you wrote was in fact written to disk, provide an error code pointer with the ICONA_ErrorCode tag. If the name of the file was too long, PutIconTagList() will still pretend that the icon file was written successfully, but the error code ERROR_TOO_MANY_LEVELS will be stored in the variable you passed in with the ICONA_ErrorCode tag.

See also

GetIconTagList | Retrieve an icon
PutDefDiskObject | Write disk object as the default for its type.
PutDiskObject | Write out a DiskObject to disk.


Reference for unit 'iffparse': Procedures and functions

AllocIFF

AllocLocalItem

CloseClipboard

CloseIFF

CollectionChunk

CollectionChunks

CurrentChunk

EntryHandler

ExitHandler

FindCollection

FindLocalItem

FindProp

FindPropContext

FreeIFF

FreeLocalItem

GoodID

GoodType

IDtoStr

InitIFF

InitIFFasClip

InitIFFasDOS

InitIFFPARSELibrary

LocalItemData

Make_ID

OpenClipboard

OpenIFF

ParentChunk

ParseIFF

PopChunk

PropChunk

PropChunks

PushChunk

ReadChunkBytes

ReadChunkRecords

SeekChunkBytes

SeekChunkRecords

SetLocalItemPurge

StopChunk

StopChunks

StopOnExit

StoreItemInContext

StoreLocalItem

WriteChunkBytes

WriteChunkRecords


Unit 'iffparse' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'iffparse': Variables

IFFParseBase


Index of all identifiers in unit 'iffparse'

A C E F G I L M O P R S T W

A

AllocIFF AllocLocalItem

C

CloseClipboard | CollectionChunk | CurrentChunk
CloseIFF | CollectionChunks |

E

EntryHandler ExitHandler

F

FindCollection | FindProp | FreeIFF
FindLocalItem | FindPropContext | FreeLocalItem

G

GoodID GoodType

I

ID_CAT | IFFERR_NOSCOPE | IFFParseBase
ID_FORM | IFFERR_NOTIFF | IFFPARSENAME
ID_LIST | IFFERR_READ | IFFPARSE_RAWSTEP
ID_NULL | IFFERR_SEEK | IFFPARSE_SCAN
ID_PROP | IFFERR_SYNTAX | IFFPARSE_STEP
IDtoStr | IFFERR_WRITE | IFF_RETURN2CLIENT
IFFCMD_CLEANUP | IFFF_FSEEK | IFFSCC_CLEANUP
IFFCMD_ENTRY | IFFF_READ | IFFSCC_INIT
IFFCMD_EXIT | IFFF_RESERVED | IFFSCC_READ
IFFCMD_INIT | IFFF_RSEEK | IFFSCC_SEEK
IFFCMD_PURGELCI | IFFF_RWBITS | IFFSCC_WRITE
IFFCMD_READ | IFFF_WRITE | IFFSIZE_UNKNOWN
IFFCMD_SEEK | IFFLCI_COLLECTION | IFFSLI_PROP
IFFCMD_WRITE | IFFLCI_ENTRYHANDLER | IFFSLI_ROOT
IFFERR_EOC | IFFLCI_EXITHANDLER | IFFSLI_TOP
IFFERR_EOF | IFFLCI_PROP | InitIFF
IFFERR_MANGLED | IFFOFFSET_BEGINNING | InitIFFasClip
IFFERR_NOHOOK | IFFOFFSET_CURRENT | InitIFFasDOS
IFFERR_NOMEM | IFFOFFSET_END | InitIFFPARSELibrary

L

LocalItemData

M

Make_ID

O

OpenClipboard OpenIFF

P

ParentChunk | pIFFHandle | PropChunks
ParseIFF | pIFFStreamCmd | pStoredProperty
pClipboardHandle | pLocalContextItem | PushChunk
pCollectionItem | PopChunk |
pContextNode | PropChunk |

R

ReadChunkBytes ReadChunkRecords

S

SeekChunkBytes | StopChunk | StoreItemInContext
SeekChunkRecords | StopChunks | StoreLocalItem
SetLocalItemPurge | StopOnExit |

T

tClipboardHandle | tIFFHandle | tStoredProperty
tCollectionItem | tIFFStreamCmd |
tContextNode | tLocalContextItem |

W

WriteChunkBytes WriteChunkRecords


AllocIFF

Declaration

Source position: iffparse.pas line 228

function AllocIFF: pIFFHandle;


AllocLocalItem

Declaration

Source position: iffparse.pas line 229

function AllocLocalItem(

  typ: LongInt;

  id: LongInt;

  ident: LongInt;

  dataSize: LongInt

):pLocalContextItem;


CloseClipboard

Declaration

Source position: iffparse.pas line 230

procedure CloseClipboard(

  clipHandle: pClipboardHandle

);


CloseIFF

Declaration

Source position: iffparse.pas line 231

procedure CloseIFF(

  iff: pIFFHandle

);


CollectionChunk

Declaration

Source position: iffparse.pas line 232

function CollectionChunk(

  iff: pIFFHandle;

  typ: LongInt;

  id: LongInt

):LongInt;


CollectionChunks

Declaration

Source position: iffparse.pas line 233

function CollectionChunks(

  iff: pIFFHandle;

  const propArray: pLONGINT;

  numPairs: LongInt

):LongInt;


CurrentChunk

Declaration

Source position: iffparse.pas line 234

function CurrentChunk(

  const iff: pIFFHandle

):pContextNode;


EntryHandler

Declaration

Source position: iffparse.pas line 235

function EntryHandler(

  iff: pIFFHandle;

  typ: LongInt;

  id: LongInt;

  position: LongInt;

  handler: PHook;

  obj: POINTER

):LongInt;


ExitHandler

Declaration

Source position: iffparse.pas line 236

function ExitHandler(

  iff: pIFFHandle;

  typ: LongInt;

  id: LongInt;

  position: LongInt;

  handler: PHook;

  obj: POINTER

):LongInt;


FindCollection

Declaration

Source position: iffparse.pas line 237

function FindCollection(

  const iff: pIFFHandle;

  typ: LongInt;

  id: LongInt

):pCollectionItem;


FindLocalItem

Declaration

Source position: iffparse.pas line 238

function FindLocalItem(

  const iff: pIFFHandle;

  typ: LongInt;

  id: LongInt;

  ident: LongInt

):pLocalContextItem;


FindProp

Declaration

Source position: iffparse.pas line 239

function FindProp(

  const iff: pIFFHandle;

  typ: LongInt;

  id: LongInt

):pStoredProperty;


FindPropContext

Declaration

Source position: iffparse.pas line 240

function FindPropContext(

  const iff: pIFFHandle

):pContextNode;


FreeIFF

Declaration

Source position: iffparse.pas line 241

procedure FreeIFF(

  iff: pIFFHandle

);


FreeLocalItem

Declaration

Source position: iffparse.pas line 242

procedure FreeLocalItem(

  localItem: pLocalContextItem

);


GoodID

Declaration

Source position: iffparse.pas line 243

function GoodID(

  id: LongInt

):LongInt;


GoodType

Declaration

Source position: iffparse.pas line 244

function GoodType(

  typ: LongInt

):LongInt;


IDtoStr

Declaration

Source position: iffparse.pas line 245

function IDtoStr(

  id: LongInt;

  buf: pCHAR

):pCHAR;


InitIFF

Declaration

Source position: iffparse.pas line 246

procedure InitIFF(

  iff: pIFFHandle;

  flags: LongInt;

  const streamHook: PHook

);


InitIFFasClip

Declaration

Source position: iffparse.pas line 247

procedure InitIFFasClip(

  iff: pIFFHandle

);


InitIFFasDOS

Declaration

Source position: iffparse.pas line 248

procedure InitIFFasDOS(

  iff: pIFFHandle

);


InitIFFPARSELibrary

Declaration

Source position: iffparse.pas line 274

function InitIFFPARSELibrary: Boolean;


LocalItemData

Declaration

Source position: iffparse.pas line 249

function LocalItemData(

  const localItem: pLocalContextItem

):POINTER;


Make_ID

Declaration

Source position: iffparse.pas line 273

function Make_ID(

  const str: string

):LongInt;


OpenClipboard

Declaration

Source position: iffparse.pas line 250

function OpenClipboard(

  unitNumber: LongInt

):pClipboardHandle;


OpenIFF

Declaration

Source position: iffparse.pas line 251

function OpenIFF(

  iff: pIFFHandle;

  rwMode: LongInt

):LongInt;


ParentChunk

Declaration

Source position: iffparse.pas line 252

function ParentChunk(

  const contextNode: pContextNode

):pContextNode;


ParseIFF

Declaration

Source position: iffparse.pas line 253

function ParseIFF(

  iff: pIFFHandle;

  control: LongInt

):LongInt;


PopChunk

Declaration

Source position: iffparse.pas line 254

function PopChunk(

  iff: pIFFHandle

):LongInt;


PropChunk

Declaration

Source position: iffparse.pas line 255

function PropChunk(

  iff: pIFFHandle;

  typ: LongInt;

  id: LongInt

):LongInt;


PropChunks

Declaration

Source position: iffparse.pas line 256

function PropChunks(

  iff: pIFFHandle;

  const propArray: pLONGINT;

  numPairs: LongInt

):LongInt;


PushChunk

Declaration

Source position: iffparse.pas line 257

function PushChunk(

  iff: pIFFHandle;

  typ: LongInt;

  id: LongInt;

  size: LongInt

):LongInt;


ReadChunkBytes

Declaration

Source position: iffparse.pas line 258

function ReadChunkBytes(

  iff: pIFFHandle;

  buf: POINTER;

  numBytes: LongInt

):LongInt;


ReadChunkRecords

Declaration

Source position: iffparse.pas line 259

function ReadChunkRecords(

  iff: pIFFHandle;

  buf: POINTER;

  bytesPerRecord: LongInt;

  numRecords: LongInt

):LongInt;


SeekChunkBytes

Declaration

Source position: iffparse.pas line 270

function SeekChunkBytes(

  iff: pIFFHandle;

  numBytes: LongInt;

  mode: LongInt

):LongInt;


SeekChunkRecords

Declaration

Source position: iffparse.pas line 271

function SeekChunkRecords(

  iff: pIFFHandle;

  bytesPerRecord: LongInt;

  numRecords: LongInt;

  mode: LongInt

):LongInt;


SetLocalItemPurge

Declaration

Source position: iffparse.pas line 260

procedure SetLocalItemPurge(

  localItem: pLocalContextItem;

  const purgeHook: PHook

);


StopChunk

Declaration

Source position: iffparse.pas line 261

function StopChunk(

  iff: pIFFHandle;

  typ: LongInt;

  id: LongInt

):LongInt;


StopChunks

Declaration

Source position: iffparse.pas line 262

function StopChunks(

  iff: pIFFHandle;

  const propArray: pLONGINT;

  numPairs: LongInt

):LongInt;


StopOnExit

Declaration

Source position: iffparse.pas line 263

function StopOnExit(

  iff: pIFFHandle;

  typ: LongInt;

  id: LongInt

):LongInt;


StoreItemInContext

Declaration

Source position: iffparse.pas line 264

procedure StoreItemInContext(

  iff: pIFFHandle;

  localItem: pLocalContextItem;

  contextNode: pContextNode

);


StoreLocalItem

Declaration

Source position: iffparse.pas line 265

function StoreLocalItem(

  iff: pIFFHandle;

  localItem: pLocalContextItem;

  position: LongInt

):LongInt;


WriteChunkBytes

Declaration

Source position: iffparse.pas line 266

function WriteChunkBytes(

  iff: pIFFHandle;

  const buf: POINTER;

  numBytes: LongInt

):LongInt;


WriteChunkRecords

Declaration

Source position: iffparse.pas line 267

function WriteChunkRecords(

  iff: pIFFHandle;

  const buf: POINTER;

  bytesPerRecord: LongInt;

  numRecords: LongInt

):LongInt;


Unit 'input' | Package
[Overview][Constants][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'input': Procedures and functions

PeekQualifier


Unit 'input' | Package
[Overview][Constants][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'input': Variables

InputBase


Index of all identifiers in unit 'input'

I P

I

IND_ADDHANDLER | IND_SETMTRIG | IND_SETTHRESH
IND_REMHANDLER | IND_SETMTYPE | IND_WRITEEVENT
IND_SETMPORT | IND_SETPERIOD | InputBase

P

PeekQualifier


PeekQualifier

Declaration

Source position: input.pas line 47

function PeekQualifier: Word;


Reference for unit 'intuition': Procedures and functions

ActivateGadget | Activate a (string or custom) gadget.
ActivateWindow | Activate an Intuition window.
AddClass | Make a public class available
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
AllocRemember | Allocate Memory with tracking to make freeing easy.
AllocScreenBuffer | Get a ScreenBuffer for double-buffering.
AutoRequest | Automatically build and get response from a requester.
BASEOBJECT | Get "public" handle on baseclass instance from real beginning of obj data
BeginRefresh | Sets up a window for optimized refreshing.
BuildEasyRequest
BuildEasyRequestArgs | Simple creation of system request.
BuildSysRequest | Build and display a system requester.
ChangeScreenBuffer | Swap the screen's BitMap.
ChangeWindowBox | Change window position and dimensions.
ClearDMRequest | Clear (detaches) the DMRequest of the window.
ClearMenuStrip | Clear (detach) the menu strip from the window.
ClearPointer | Clear the mouse pointer definition from a window.
CloseScreen | Close an Intuition screen.
CloseWindow | Close an Intuition window.
CloseWorkBench | Closes the Workbench screen.
CurrentTime | Get the current time values.
CUSTOM_HOOK | Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget
DisplayAlert | Create the display of an alert message.
DisplayBeep | Flash the video display.
DisposeObject | Deletes a 'boopsi' object.
DoGadgetMethod
DoGadgetMethodA | Invoke method on a boopsi gadget.
DoMethod | VarArgs Version of DoMethodA()
DoMethodA | Perform method on object.
DoSuperMethod | VarArgs Version of DoSuperMethodA()
DoSuperMethodA | Perform method on object coerced to superclass.
DoSuperNew
DoubleClick | Test two time values for double-click timing.
DrawBorder | Draw the specified Border structure into a RastPort.
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.
EasyRequest | VarArgs Version of EasyRequestArgs()
EasyRequestArgs | Easy alternative to AutoRequest()
EndRefresh | End the optimized refresh state of the window.
EndRequest | Remove a currently active requester.
EraseImage | Erases an Image.
FreeClass | Frees a boopsi class created by MakeClass().
FreeMonitorList
FreeRemember | Free memory allocated by calls to AllocRemember().
FreeScreenBuffer | Free a ScreenBuffer structure.
FreeScreenDrawInfo | Finish using a DrawInfo structure.
FreeSysRequest | Free resources gotten by a call to BuildSysRequest().
FULLMENUNUM | Menu helper macro
GadgetMouse | Calculate gadget-relative mouse position.
GADGET_BOX | Get bounding box of a gadget
GetAttr | Inquire the value of some attribute of an object.
GetDefaultPubScreen | Get name of default public screen.
GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetDrawInfoAttr
GetMonitorList
GetPrefs | Get the current Intuition Preferences structure.
GetScreenData | Get copy of a screen data structure.
GetScreenDrawInfo | Get pointer to rendering information.
GetSkinInfoAttr
GetSkinInfoAttrA
HelpControl | Enable/disable Gadget-Help feature.
HideWindow
IM_BGPEN | Set Image Background Pen
IM_BOX | Get Image bounding rectangle
IM_FGPEN | Set Image Foreground pen
InitIntuitionLibrary
InitRequester | Initialize a Requester structure.
INST_DATA | Finds Object local instance data
IntuiTextLength | Return the length (pixel-width) of an IntuiText.
Intuition
ItemAddress | Returns the address of the specified MenuItem.
ITEMNUM | Menu helper macro
LendMenus | Lend window's menu action to another window.
LockIBase | Invoke semaphore arbitration of TIntuitionBase.
LockPubScreen | Prevent a public screen from closing.
LockPubScreenList | Prevent changes to the system list.
MakeClass | Create and initialize a boopsi class.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.
MENUNUM | Menu helper macro
ModifyIDCMP | Modify the state of a window's IDCMPFlags.
ModifyProp | Modify the current parameters of a proportional gadget.
MoveScreen | Attempt to move the screen by the increments provided.
MoveWindow | Ask Intuition to move a window.
MoveWindowInFrontOf | Arrange the relative depth of a window.
NewModifyProp | ModifyProp(), but with selective refresh.
NewObject | Varargs version of NewObjectA()
NewObjectA | Create an object from a class.
NextObject | Iterate through the object on an Exec list.
NextPubScreen | Identify next public screen in the cycle.
ObtainGIRPort | Set up a RastPort for a custom gadget.
OCLASS | Get class pointer from an object handle
OffGadget | Disable the specified gadget.
OffMenu | Disable the given menu or menu item.
OnGadget | Enable the specified gadget.
OnMenu | Enable the given menu or menu item.
OpenIntuition
OpenScreen | Open an Intuition screen
OpenScreenTagList | OpenScreen() with TagItem extension array.
OpenScreenTags | Varargs Version of OpenScreenTagList()
OpenWindow | Open an Intuition window.
OpenWindowTagList | OpenWindow() with TagItem extension.
OpenWindowTags | Varargs Version of OpenWindowTagList()
OpenWorkBench | Open the Workbench screen.
PointInImage | Tests whether an image "contains" a point.
PrintIText | Print text described by the IntuiText argument.
PubScreenStatus | Change status flags for a public screen.
QueryOverscan | Inquire about a standard overscan region.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
RefreshWindowFrame | Ask Intuition to redraw your window border.
ReleaseGIRPort | Release a custom gadget RastPort.
RemakeDisplay |
RemoveClass | Make a public boopsi class unavailable.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
ReportMouse | Tell Intuition whether to report mouse movement.
Request | Activate a requester.
ResetMenuStrip | Re-attach a menu strip to a window.
RethinkDisplay | Grand manipulation of the entire Intuition display.
ScreenbarControl
ScreenbarControlA
ScreenDepth | Depth arrange a screen with extra control.
ScreenPosition | Move screens with greater control.
ScreenToBack | Send the specified screen to the back of the display.
ScreenToFront | Make the specified screen the frontmost.
ScrollWindowRaster | Scrolls the content of the rectangle
ScrollWindowRasterNoFill
SetAttrs | Varargs Version of SetAttrsA()
SetAttrsA | Specify attribute values for an object.
SetDefaultPubScreen | Choose a new default public screen.
SetDMRequest | Set the DMRequest of a window.
SetEditHook | Set global processing for string gadgets.
SetGadgetAttrs | Varargs Version of SetGadgetAttrsA()
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.
SetMenuStrip | Attach a menu strip to a window.
SetMouseQueue | Change limit on pending mouse messages.
SetPointer | Specify a pointer sprite image for a window.
SetPrefs | Set Intuition preferences data.
SetPubScreenModes | Establish global public screen behavior.
SetWindowPointer | Varargs Version of SetWindowPointerA()
SetWindowPointerA | Select a pointer for your window.
SetWindowTitles | Set the window's titles for both window and screen.
SHIFTITEM | Menu helper macro
SHIFTMENU | Menu helper macro
SHIFTSUB | Menu helper macro
ShowTitle | Set the screen title bar display mode.
ShowWindow
SIZEOF_INSTANCE | Sizeof the instance data for a given class
SizeWindow | Ask Intuition to size a window.
SUBNUM | Menu helper macro
SysReqHandler | Handle system requester input.
TimedDisplayAlert | Display an alert with automatic time-out.
TransparencyControl
UnlockIBase | Release a an Intuition lock gotten by LockIBase().
UnlockPubScreen | Release lock on a public screen.
UnlockPubScreenList | Release public screen list semaphore.
ViewAddress | Return the address of the Intuition View structure.
ViewPortAddress | Return the address of a window's viewport.
WBenchToBack | Send the Workbench screen in back of all screens.
WBenchToFront | Bring the Workbench screen in front of all screens.
WindowAction
WindowLimits | Set the minimum and maximum limits of a window.
WindowToBack | Ask Intuition to send a window behind others.
WindowToFront | Ask Intuition to bring a window to the front.
ZipWindow | Change window to "alternate" position and dimensions.
_OBJ | convenient typecast to P_Object
__OBJECT | Get back to object data struct from public handle


Reference for unit 'intuition': Variables

Intuitionbase

Library Base for intuition.library


Index of all identifiers in unit 'intuition'

A B C D E F G H I J K L M N O P Q R S T U V W Z

A

ABSOLUTE_DIMENSIONS | ALTLEFT | AUTODRAWMODE
ActivateGadget | ALTRIGHT | AUTOFRONTPEN
ActivateWindow | AMIGAKEY | AUTOITEXTFONT
AddClass | AMIGAKEYS | AUTOKNOB
AddGadget | AMIGALEFT | AUTOLEFTEDGE
AddGList | AMIGARIGHT | AUTONEXTTEXT
ALERT_TYPE | ANTI_ALIAS | AutoRequest
AllocRemember | ASPECT_HORIZ | AUTOSCROLL
AllocScreenBuffer | ASPECT_VERT | AUTOTOPEDGE
ALPHA_P_101 | AUTOBACKPEN |

B

BACKGROUNDPEN | BeginRefresh | BTDIF_Fast3D
BARBLOCKPEN | BLOCKPEN | BTDI_Revision
BARDETAILPEN | BOOLMASK | BTDMAXSTRLEN
BARTRIMPEN | BOUNDED_DIMENSIONS | BTD_PreviewMode
BASEOBJECT | BROTHER_15XL | BTDPT_BOOLEAN
BAUD_110 | BTD_Client | BTDPT_CYCLE
BAUD_1200 | BTD_DrawInfo | BTDPT_FILE
BAUD_19200 | BTD_Dummy | BTDPT_FONT
BAUD_2400 | BTDERR_Display | BTDPT_INTEGER
BAUD_300 | BTDERR_Memory | BTDPT_STRING
BAUD_4800 | BTD_Error | BuildEasyRequest
BAUD_9600 | BTDERR_Size | BuildEasyRequestArgs
BAUD_MIDI | BTDIF_3DBlanker | BuildSysRequest
BEEPING_f | BTDIF_DoNotWait | BUTTONGCLASS

C

CBM_MPS1000 | CLOSEGADGET | CURSORLEFT
CENTER_IMAGE | CLOSEIMAGE | CURSORRIGHT
ChangeScreenBuffer | CloseScreen | CURSORUP
ChangeWindowBox | CloseWindow | CUSTOMBITMAP_f
CHECKED | CloseWorkBench | CUSTOM_HOOK
CHECKIMAGE | COMMSEQ | CUSTOMIMAGEDEPTH
CHECKIT | COMMWIDTH | CUSTOM_NAME
CHECKWIDTH | CORRECT_BLUE | CUSTOM_PAPER
ClassID | CORRECT_GREEN | CUSTOMSCREEN_f
ClearDMRequest | CORRECT_RED | CWCODE_DEPTH
ClearMenuStrip | CORRECT_RGB_MASK | CWCODE_MOVESIZE
ClearPointer | CurrentTime |
CLF_INLIST | CURSORDOWN |

D

DEADEND_ALERT | DOSLOGO_DISKBUSY | DRIF_DIRECTCOLOR
DEFAULTMOUSEQUEUE | DOSLOGO_DISKERROR | DRIF_NEWLOOK
DEFERREFRESH | DOSLOGO_DISKFULL | DRIPEN_BACKGROUND
DEPTHIMAGE | DOSLOGO_DISKINSERT | DRIPEN_BARBLOCK
DETAILPEN | DOSLOGO_DISKNOTVALIDATED | DRIPEN_BARDETAIL
DEVNAME_SIZE | DOSLOGO_DISKPROTECTED | DRIPEN_BARTRIM
DIAB_630 | DOSLOGO_NODISK | DRIPEN_BLOCK
DIAB_ADV_D25 | DOSLOGO_NOTADOSDISK | DRIPEN_DETAIL
DIAB_C_150 | DoSuperMethod | DRIPEN_FILL
DIMENSIONS_MASK | DoSuperMethodA | DRIPEN_FILLTEXT
DisplayAlert | DoSuperNew | DRIPEN_HALFSHADOW
DisplayBeep | DoubleClick | DRIPEN_HALFSHINE
DisposeObject | DOWNBACKGADGET | DRIPEN_HIGHLIGHTTEXT
DITHERING_MASK | DOWNIMAGE | DRIPEN_NUMDRIPENS
DMODECOUNT | DRAFT | DRIPEN_SHADOW
DoGadgetMethod | DRAGGADGET | DRIPEN_SHINE
DoGadgetMethodA | DrawBorder | DRIPEN_TEXT
DoMethod | DrawImage | DRI_VERSION
DoMethodA | DrawImageState |

E

EasyRequest | EO_REPLACECHAR | ETI_Dummy
EasyRequestArgs | EO_RESET | ETI_Iconify
EES_ActiveButton | EO_SPECIAL | ETI_Jump
EES_DiskBased | EO_UNDO | ETI_Lock
EES_DosLogo | EPSON | ETI_MUI
EES_Dummy | EPSON_JX_80 | ETI_PopUp
EIGHT_LPI | EraseImage | ETI_Snapshot
ELITE | ETD_Iconify | EURO_A0
EndRefresh | ETD_Jump | EURO_A1
EndRequest | ETD_Lock | EURO_A2
EO_BADFORMAT | ETD_MUI | EURO_A3
EO_BIGCHANGE | ETD_PopUp | EURO_A4
EO_CLEAR | ETD_Snapshot | EURO_A5
EO_DELBACKWARD | ETG_ICONIFY | EURO_A6
EO_DELFORWARD | ETG_JUMP | EURO_A7
EO_ENTER | ETG_LOCK | EURO_A8
EO_INSERTCHAR | ETG_MUI | EVENTMAX
EO_MOVECURSOR | ETG_POPUP |
EO_NOOP | ETG_SNAPSHOT |

F

FANFOLD_PT | FRAME_DEFAULT | FreeMonitorList
FILENAME_SIZE | FRAMEF_SPECIFY | FreeRemember
FILLPEN | FRAMEICLASS | FreeScreenBuffer
FILLRECTCLASS | FRAME_ICONDROPBOX | FreeScreenDrawInfo
FILLTEXTPEN | FRAME_RIDGE | FreeSysRequest
FINE | FRBUTTONCLASS | FREEVERT
FLOYD_DITHERING | FreeClass | FULLMENUNUM
FRAME_BUTTON | FREEHORIZ |

G

GA_ActivateKey | GA_SysGadget | GM_GOACTIVE
GA_BackFill | GA_SysGType | GM_GOINACTIVE
GA_Border | GA_TabCycle | GM_HANDLEINPUT
GA_BottomBorder | GA_Text | GM_HELPTEST
GA_Bounds | GA_TextAttr | GM_HITTEST
GACT_ACTIVEGADGET | GA_ToggleSelect | GMLA_DisplayID
GACT_ALTKEYMAP | GA_Top | GMLA_Dummy
GACT_BOOLEXTEND | GA_TopBorder | GM_LAYOUT
GACT_BORDERSNIFF | GA_Underscore | GMORE_BOUNDS
GACT_BOTTOMBORDER | GA_UserData | GMORE_GADGETHELP
GACT_ENDGADGET | GA_UserInput | GMORE_SCROLLRASTER
GACT_FOLLOWMOUSE | GA_Width | GM_RENDER
GACT_IMMEDIATE | GDIA_CheckMark | GMR_GADGETHIT
GACT_LEFTBORDER | GDIA_Color | GMR_HELPCODE
GACT_LONGINT | GDIA_Depth | GMR_HELPHIT
GACT_RELVERIFY | GDIA_DirectColor | GMR_KEYACTIVE
GACT_RIGHTBORDER | GDIA_Font | GMR_KEYVERIFY
GACT_STRINGCENTER | GDIA_MenuKey | GMR_MEACTIVE
GACT_STRINGEXTEND | GDIA_NumPens | GMR_NEXTACTIVE
GACT_STRINGLEFT | GDIA_Pen | GMR_NOHELPHIT
GACT_STRINGRIGHT | GDIA_ResolutionX | GMR_NOREUSE
GACT_TOGGLESELECT | GDIA_ResolutionY | GMR_PREVACTIVE
GACT_TOPBORDER | GDIA_Version | GMR_REUSE
GADGET_BOX | GDOMAIN_MAXIMUM | GMR_VERIFY
GADGETCLASS | GDOMAIN_MINIMUM | GREDRAW_REDRAW
GADGETCOUNT | GDOMAIN_NOMINAL | GREDRAW_TOGGLE
GadgetMouse | GetAttr | GREDRAW_UPDATE
GA_Disabled | GetDefaultPubScreen | GREY_SCALE2
GA_DrawInfo | GetDefPrefs | GROUPGCLASS
GA_Dummy | GetDrawInfoAttr | GTYP_BOOLGADGET
GA_EndGadget | GetMonitorList | GTYP_CLOSE
GA_FollowMouse | GetPrefs | GTYP_CUSTOMGADGET
GA_GadgetHelp | GetScreenData | GTYP_GADGET0002
GA_GadgetHelpText | GetScreenDrawInfo | GTYP_GADGETTYPE
GA_GZZGadget | GetSkinInfoAttr | GTYP_GTYPEMASK
GA_Height | GetSkinInfoAttrA | GTYP_GZZGADGET
GA_Highlight | GFLG_DISABLED | GTYP_PROPGADGET
GA_ID | GFLG_EXTENDED | GTYP_REQGADGET
GA_Image | GFLG_GADGHBOX | GTYP_SCRGADGET
GA_Immediate | GFLG_GADGHCOMP | GTYP_SDEPTH
GA_IntuiText | GFLG_GADGHIGHBITS | GTYP_SDOWNBACK
GA_LabelImage | GFLG_GADGHIMAGE | GTYP_SDRAGGING
GA_LabelPlace | GFLG_GADGHNONE | GTYP_SIZING
GA_Left | GFLG_GADGIMAGE | GTYP_STRGADGET
GA_LeftBorder | GFLG_IMAGEDISABLE | GTYP_SUNUSED
GA_Next | GFLG_LABELIMAGE | GTYP_SUPFRONT
GA_Previous | GFLG_LABELITEXT | GTYP_SYSGADGET
GA_ReadOnly | GFLG_LABELMASK | GTYP_WDEPTH
GA_RelBottom | GFLG_LABELSTRING | GTYP_WDOWNBACK
GA_RelHeight | GFLG_RELBOTTOM | GTYP_WDRAGGING
GA_RelRight | GFLG_RELHEIGHT | GTYP_WDRAGGING2
GA_RelSpecial | GFLG_RELRIGHT | GTYP_WUPFRONT
GA_RelVerify | GFLG_RELSPECIAL | GTYP_WZOOM
GA_RelWidth | GFLG_RELWIDTH | GV_LabelPlace_Above
GA_RightBorder | GFLG_SELECTED | GV_LabelPlace_Below
GA_Selected | GFLG_STRINGEXTEND | GV_LabelPlace_In
GA_SelectRender | GFLG_TABCYCLE | GV_LabelPlace_Left
GA_SpecialInfo | GM_Dummy | GV_LabelPlace_Right

H

HALFTONE_DITHERING | HIGHFLAGS | HIRESPICK
HC_GADGETHELP | HIGHIMAGE | HOVERSTART
HelpControl | HIGHITEM | HOVERSTOP
HideWindow | HIGHLIGHTTEXTPEN | HP_LASERJET
HIGHBOX | HIGHNONE | HP_LASERJET_PLUS
HIGHCOMP | HIRESGADGET |

I

IA_ActivateKey | IDCMP_DELTAMOVE | IMAGE_NEGATIVE
IA_APatSize | IDCMP_DISKINSERTED | IMAGE_POSITIVE
IA_APattern | IDCMP_DISKREMOVED | IM_BGPEN
IA_BGPen | IDCMP_GADGETDOWN | IM_BOX
IA_Data | IDCMP_GADGETHELP | IM_DOMAINFRAME
IA_DoubleEmboss | IDCMP_GADGETUP | IM_DRAW
IA_Dummy | IDCMP_IDCMPUPDATE | IM_DRAWFRAME
IA_EdgesOnly | IDCMP_INACTIVEWINDOW | IM_ERASE
IA_FGPen | IDCMP_INTUITICKS | IM_ERASEFRAME
IA_Font | IDCMP_LONELYMESSAGE | IM_FGPEN
IA_FrameType | IDCMP_MENUHELP | IM_FRAMEBOX
IA_Height | IDCMP_MENUPICK | IM_HITFRAME
IA_HighlightPen | IDCMP_MENUVERIFY | IM_HITTEST
IA_Left | IDCMP_MOUSEBUTTONS | IM_MOVE
IA_LineWidth | IDCMP_MOUSEHOVER | IMSGA_Class
IA_Mode | IDCMP_MOUSEMOVE | IMSGA_Code
IA_Outline | IDCMP_MOUSEOBJECTMUI | IMSGA_Dummy
IA_Pens | IDCMP_NEWPREFS | IMSGA_IAddress
IA_Precision | IDCMP_NEWSIZE | IMSGA_IDCMPWindow
IA_Recessed | IDCMP_RAWKEY | IMSGA_Micros
IA_Resolution | IDCMP_REFRESHWINDOW | IMSGA_MouseX
IA_Scalable | IDCMP_REQCLEAR | IMSGA_MouseY
IA_Screen | IDCMP_REQSET | IMSGA_Qualifier
IA_ShadowPen | IDCMP_REQVERIFY | IMSGA_RawMouseX
IA_SupportsDisable | IDCMP_SIZEVERIFY | IMSGA_RawMouseY
IA_Top | IDCMP_VANILLAKEY | IMSGA_Seconds
IA_Underscore | IDCMP_WBENCHMESSAGE | IMSGA_UCS4
IA_Width | IDOMAIN_MAXIMUM | IMSGM_NewCopy
ICA_Dummy | IDOMAIN_MINIMUM | InitIntuitionLibrary
ICA_MAP | IDOMAIN_NOMINAL | InitRequester
ICA_TARGET | IDS_BUSY | INST_DATA
ICCLASS | IDS_DISABLED | INTEGER_SCALING
ICM_CHECKLOOP | IDS_INACTIVEDISABLED | IntuiTextLength
ICM_CLEARLOOP | IDS_INACTIVENORMAL | Intuition
ICM_Dummy | IDS_INACTIVESELECTED | Intuitionbase
ICM_SETLOOP | IDS_INDETERMINANT | INTUITIONNAME
ICONIFYIMAGE | IDS_INDETERMINATE | ISDRAWN
ICSPECIAL_CODE | IDS_NORMAL | ItemAddress
ICTARGET_IDCMP | IDS_SELECTED | ITEMENABLED
IDCMP_ACTIVEWINDOW | IDS_SELECTEDDISABLED | ITEMNUM
IDCMP_CHANGEWINDOW | IGNORE_DIMENSIONS | ITEMTEXT
IDCMP_CLOSEWINDOW | IMAGECLASS | ITEXTICLASS

J

JUMPIMAGE

K

KEYCODE_B | KEYCODE_N | KNOBHIT
KEYCODE_GREATER | KEYCODE_Q | KNOBHMIN
KEYCODE_LESS | KEYCODE_V | KNOBVMIN
KEYCODE_M | KEYCODE_X |

L

LACEWB | LendMenus | LORIENT_NONE
LAYOUTA_ChildMaxHeight | LETTER | LORIENT_VERT
LAYOUTA_ChildMaxWidth | LockIBase | LOWCHECKWIDTH
LAYOUTA_Dummy | LOCKIMAGE | LOWCOMMWIDTH
LAYOUTA_LayoutObj | LockPubScreen | LOWRESGADGET
LAYOUTA_Orientation | LockPubScreenList | LOWRESPICK
LAYOUTA_Spacing | LOGO_CRASH | LW_RESERVED
LEFTIMAGE | LORIENT_HORIZ |

M

MA_BacklightControl | MAXPUBSCREENNAME | ModifyIDCMP
MA_BacklightLevel | MENUCANCEL | ModifyProp
MA_BacklightLevelSteps | MENUCHECK | MONITOR_MAXPIXELFORMATS
MA_BottomLeftMonitor | MENUDOWN | MOUSE_ACCEL
MA_BottomMiddleMonitor | MENUENABLED | MoveScreen
MA_BottomRightMonitor | MENUHOT | MoveWindow
MA_DriverName | MENUNULL | MoveWindowInFrontOf
MA_Dummy | MENUNUM | MSQUERY3D_HWDRIVER
MA_GammaControl | MENUTOGGLE | MSQUERY3D_NODRIVER
MakeClass | MENUTOGGLED | MSQUERY3D_SWDRIVER
MakeScreen | MENUTOGGLEIMAGE | MSQUERY3D_UNKNOWN
MA_Manufacturer | MENUUP | MUIA_Screenbar_DisplayedImage
MA_ManufacturerID | MENUWAITING | MUIA_Screenbar_DisplayedName
MA_MemoryClock | MIDDLEDOWN | MUIIMAGE
MA_MemorySize | MIDDLEUP | MUIM_Screenbar_BuildSettingsPanel
MA_MiddleLeftMonitor | MIDRAWN | MUIM_Screenbar_DefaultConfigItem
MA_MiddleRightMonitor | MM_Authorization | MUIM_Screenbar_KnowsConfigItem
MA_MonitorName | MM_EnterPowerSaveMode | MUIM_Screenbar_Lock
MA_PixelFormats | MM_ExitBlanker | MUIM_Screenbar_Signal
MA_PointerType | MM_GetDefaultGammaTables | MUIM_Screenbar_Unlock
MA_ProductID | MM_GetDefaultPixelFormat | MUIM_Screenbar_UpdateConfigItem
MA_TopLeftMonitor | MM_GetPointerBounds | MUIM_UpdateConfig
MA_TopMiddleMonitor | MM_GetRootBitMap | MUISERIALNO_INTUITION
MA_TopRightMonitor | MM_Query3DSupport | MULTIPLY_DIMENSIONS
MAXBODY | MM_RunBlanker | MXIMAGE
MAXPOT | MODELCLASS |

N

NewModifyProp | NOISYREQ | NS_EXTENDED
NewObject | NOITEM | N_TRACTOR
NewObjectA | NOMENU | NUMDRIPENS
NextObject | NOREQBACKFILL | _OBJ
NextPubScreen | NOSUB | __OBJECT

O

LongWord | OM_NOTIFY | OPUF_INTERIM
ObtainGIRPort | OM_REMMEMBER | ORDERED_DITHERING
OCLASS | OM_REMOVE | OSCAN_MAX
OffGadget | OM_SET | OSCAN_STANDARD
OffMenu | OM_UPDATE | OSCAN_TEXT
OKABORT | OnGadget | OSCAN_VIDEO
OKCANCEL | OnMenu | OSERR_ATTACHFAIL
OKIMATE_20 | OpenIntuition | OSERR_NOCHIPMEM
OKOK | OpenScreen | OSERR_NOCHIPS
OM_ADDMEMBER | OpenScreenTagList | OSERR_NOMEM
OM_ADDTAIL | OpenScreenTags | OSERR_NOMONITOR
OM_DISPOSE | OpenWindow | OSERR_NOTAVAILABLE
OM_Dummy | OpenWindowTagList | OSERR_PUBNOTUNIQUE
OM_GET | OpenWindowTags | OSERR_TOODEEP
OM_NEW | OpenWorkBench | OSERR_UNKNOWNMODE

P

PARALLEL_PRINTER | PIClass | POINTERTYPE_NORMAL
PBoolInfo | PImage | POINTERTYPE_NOTAVAILABLE
PBorder | PimpDomainFrame | POINTERTYPE_NUMTYPES
PBTDBoolean | PimpDraw | POINTERTYPE_SELECTLINK
PBTDCycle | PimpErase | POINTERTYPE_SELECTTEXT
PBTDDrawInfo | PimpFrameBox | POINTERTYPE_VERTICALRESIZE
PBTDFile | PimpHitTest | POINTERTYPE_WORKING
PBTDFont | PIntuiMessage | POINTERXRESN_140NS
PBTDInfo | PIntuiText | POINTERXRESN_35NS
PBTDInteger | PIntuitionBase | POINTERXRESN_70NS
PBTDNode | PIXEL_DIMENSIONS | POINTERXRESN_DEFAULT
PBTDString | PMenu | POINTERXRESN_HIRES
PClassLibrary | PMenuItem | POINTERXRESN_LORES
PColorSpec | PMsg | POINTERXRESN_SCREENRES
PDrawInfo | PmsGetDefaultGammaTables | POINTERYRESN_DEFAULT
PEasyStruct | PmsGetDefaultPixelFormat | POINTERYRESN_HIGH
PEN_C0 | PmsGetPointerBounds | POINTERYRESN_HIGHASPECT
PEN_C1 | PmsGetRootBitMap | POINTERYRESN_SCREENRES
PEN_C2 | PmsQuery3DSupport | POINTERYRESN_SCREENRESASPECT
PEN_C3 | PmsSetDefaultGammaTables | PointInImage
PENSHARED | PMUIP_Screenbar_BuildSettingsPanel | POINTREL
PExtEasyStruct | PMUIP_Screenbar_DefaultConfigItem | PopAddMember
PExtGadget | PMUIP_Screenbar_KnowsConfigItem | PopAddTail
PExtIntuiMessage | PMUIP_Screenbar_Lock | PopGet
PExtNewScreen | PMUIP_Screenbar_Signal | PopMember
PExtNewWindow | PMUIP_Screenbar_Unlock | POPPUBSCREEN
PGA_Borderless | PMUIP_UpdateConfig | PopSet
PGadget | PNewScreen | PopUpdate
PGadgetInfo | PNewWindow | POPUPIMAGE
PGA_Dummy | P_Object | PPBTDNode
PGA_Freedom | PObject_ | PPGX
PGA_HorizBody | POINTERA_BitMap | PPObject_
PGA_HorizPot | POINTERA_Dummy | PPreferences
PGA_NewLook | POINTERA_WordWidth | PPropInfo
PGA_NotifyBehaviour | POINTERA_XOffset | PPubScreenNode
PGA_RenderBehaviour | POINTERA_XResolution | PREDRAWN
PGA_Top | POINTERA_YOffset | PRemember
PGA_Total | POINTERA_YResolution | PRequester
PGA_VertBody | POINTERCLASS | PrintIText
PGA_VertPot | POINTERSIZE | PROPBORDERLESS
PGA_Visible | PointerType_2Plus1 | PROPGCLASS
PG_BEHAVIOUR_COMPATIBLE | PointerType_3Plus1 | PROPNEWLOOK
PG_BEHAVIOUR_NICE | POINTERTYPE_AIMING | PScreen
PgpDomain | POINTERTYPE_ALTERNATIVECHOICE | PScreenBuffer
PgpGoInactive | PointerType_ARGB | PSGWork
PgpHitTest | POINTERTYPE_BUSY | PSNF_PRIVATE
PgpInput | POINTERTYPE_DIAGONALRESIZE1 | PStringExtend
PgpKeyGoInactive | POINTERTYPE_DIAGONALRESIZE2 | PStringInfo
PgpKeyInput | POINTERTYPE_DOT | PTabletData
PgpKeyTest | POINTERTYPE_HANDWRITING | PTabletHookData
PgpLayout | POINTERTYPE_HELP | PTransparencyMessage
PgpRender | POINTERTYPE_HORIZONTALRESIZE | PUBLICSCREEN_f
PIBox | POINTERTYPE_INVISIBLE | PubScreenStatus
PICA | POINTERTYPE_MOVE | PWindow

Q

QueryOverscan QUME_LP_20

R

RECOVERY_ALERT | RemoveGadget | ResetMenuStrip
RefreshGadgets | RemoveGList | RethinkDisplay
RefreshGList | ReportMouse | RIGHTIMAGE
RefreshWindowFrame | REQACTIVE | RI_VERSION
ReleaseGIRPort | REQOFFWINDOW | ROOTCLASS
RemakeDisplay | Request |
RemoveClass | RESCOUNT |

S

SA_3DSupport | SBCT_Dummy | SHSHAKE_RTS
SA_AdaptSize | SBCT_InstallPlugin | SHSHAKE_XON
SA_AutoScroll | SBCT_UninstallPlugin | SI_BorderBottom
SA_BackChild | SB_SCREEN_BITMAP | SI_BorderBottomSize
SA_BackFill | SBUF_1024 | SI_BorderLeft
SA_Behind | SBUF_16000 | SI_BorderRight
SA_BitMap | SBUF_2048 | SI_BorderRightSize
SA_BlockPen | SBUF_4096 | SI_BorderTop
SA_BottomLeftScreen | SBUF_512 | SI_BorderTopTitle
SA_BottomMiddleScreen | SBUF_8000 | SI_BottomArrowBox
SA_BottomRightScreen | SBUFSIZE_BITS | SI_BottomPropHeight
SA_ColorMapEntries | ScreenbarControl | SI_Dummy
SA_Colors | ScreenbarControlA | SIMPLEREQ
SA_Colors32 | SCREENBEHIND_f | Single_PT
SA_CompositingLayers | ScreenDepth | SI_RightArrowBox
SA_DClip | SCREEN_DRAG | SI_RightPropWidth
SA_Depth | SCREENHIRES | SI_ScreenTitlebarHeight
SA_DetailPen | ScreenPosition | SI_Shadows
SA_Displayed | SCREENQUIET_f | SIX_LPI
SA_DisplayHeight | ScreenToBack | SIZEGADGET
SA_DisplayID | ScreenToFront | SIZEIMAGE
SA_DisplayWidth | SCREENTYPE_f | SIZEOF_INSTANCE
SA_Draggable | ScrollWindowRaster | SizeWindow
SA_Dummy | ScrollWindowRasterNoFill | SNAPSHOTIMAGE
SA_ErrorCode | SDEPTHIMAGE | SPARITY_BITS
SA_ExactMatchMonitorName | SDEPTH_TOBACK | SPARITY_EVEN
SA_Exclusive | SDEPTH_TOFRONT | SPARITY_MARK
SA_Font | SDOWNBACKGADGET | SPARITY_NONE
SA_FrontChild | SDRAGGADGET | SPARITY_ODD
SA_FullPalette | SELECTDOWN | SPARITY_SPACE
SA_GammaBlue | SELECTUP | SPOS_ABSOLUTE
SA_GammaControl | SERIAL_PRINTER | SPOS_FORCEDRAG
SA_GammaGreen | SetAttrs | SPOS_MAKEVISIBLE
SA_GammaRed | SetAttrsA | SPOS_RELATIVE
SA_Height | SetDefaultPubScreen | SREAD_BITS
SA_Interleaved | SetDMRequest | SSTOP_BITS
SA_Left | SetEditHook | STDSCREENHEIGHT
SA_LikeWorkbench | SetGadgetAttrs | STDSCREENWIDTH
SA_MiddleLeftScreen | SetGadgetAttrsA | STRGCLASS
SA_MiddleRightScreen | SetMenuStrip | STRINGA_ActivePens
SA_MinimizeISG | SetMouseQueue | STRINGA_AltKeyMap
SA_MonitorName | SetPointer | STRINGA_Buffer
SA_MonitorObject | SetPrefs | STRINGA_BufferPos
SA_OpacitySupport | SetPubScreenModes | STRINGA_DispPos
SAOS_OpacitySupport_CPU | SetWindowPointer | STRINGA_Dummy
SAOS_OpacitySupport_HW | SetWindowPointerA | STRINGA_EditHook
SAOS_OpacitySupport_None | SetWindowTitles | STRINGA_EditModes
SAOS_OpacitySupport_OnOff | SGA_BEEP | STRINGA_ExitHelp
SA_Overscan | SGA_END | STRINGA_FixedFieldMode
SA_Parent | SGA_NEXTACTIVE | STRINGA_Font
SA_Pens | SGA_PREVACTIVE | STRINGA_Justification
SA_PixelFormat | SGA_REDISPLAY | STRINGA_LongVal
SA_PubName | SGA_REUSE | STRINGA_MaxChars
SA_PubSig | SGA_USE | STRINGA_NoFilterMode
SA_PubTask | SG_DEFAULTMAXCHARS | STRINGA_Pens
SA_Quiet | SGH_CLICK | STRINGA_ReplaceMode
SA_Reserved | SGH_KEY | STRINGA_TextVal
SASA_SourceAlphaSupport_CPU | SGM_CONTROL | STRINGA_UndoBuffer
SASA_SourceAlphaSupport_HW | SGM_EXITHELP | STRINGA_WorkBuffer
SASA_SourceAlphaSupport_None | SGM_FIXEDFIELD | SUBMENUIMAGE
SA_ScreenbarSignal | SGM_LONGINT | SUBNUM
SA_ScreenbarTextFont | SGM_NOCHANGE | SUPFRONTGADGET
SA_ScreenbarTextPen | SGM_NOFILTER | SWRITE_BITS
SA_ScreenbarTextYPos | SGM_NOWORKB | SYSIA_Depth
SA_SharePens | SGM_REPLACE | SYSIA_DrawInfo
SA_ShowPointer | SHADE_BW | SYSIA_Pens
SA_ShowTitle | SHADE_COLOR | SYSIA_ReferenceFont
SA_SourceAlphaSupport | SHADE_GREYSCALE | SYSIA_Size
SA_StopBlanker | SHADOWPEN | SYSIA_Style
SA_SysFont | SHANGHAI | SYSIA_Which
SA_Title | SHIFTITEM | SYSIA_WithBorder
SA_Top | SHIFTMENU | SYSICLASS
SA_TopLeftScreen | SHIFTSUB | SYSISIZE_HIRES
SA_TopMiddleScreen | SHINEPEN | SYSISIZE_LOWRES
SA_TopRightScreen | ShowTitle | SYSISIZE_MEDRES
SA_Type | SHOWTITLE_f | SYSISTYLE_GADTOOLS
SA_VideoControl | ShowWindow | SYSISTYLE_NORMAL
SA_Width | SHSHAKE_BITS | SysReqHandler
SB_COPY_BITMAP | SHSHAKE_NONE | SYSREQUEST

T

TABLETA_AngleX | TgpGoInactive | TNewScreen
TABLETA_AngleY | TgpHitTest | TNewWindow
TABLETA_AngleZ | TgpInput | T_Object
TABLETA_ButtonBits | TgpKeyGoInactive | TopAddMember
TABLETA_Dummy | tgpKeyInput | TopAddTail
TABLETA_InProximity | TgpKeyTest | TOPAZ_EIGHTY
TABLETA_Pressure | TgpLayout | TOPAZ_SIXTY
TABLETA_RangeZ | TgpRender | TopGet
TABLETA_ResolutionX | TIBox | TopMember
TABLETA_ResolutionY | TIClass | TopSet
TABLETA_TabletZ | TImage | TopUpdate
TAGBASE_SCREENBAR | TimedDisplayAlert | TPGX
TBoolInfo | TimpDomainFrame | TPreferences
TBorder | TimpDraw | TPropInfo
TBTDBoolean | TimpErase | TPubScreenNode
TBTDCycle | TimpFrameBox | TransparencyControl
TBTDDrawInfo | TimpHitTest | TRANSPCONTROL_DUMMY
TBTDFile | TIntuiMessage | TRANSPCONTROLMETHOD_INSTALLREGION
TBTDFont | TIntuiText | TRANSPCONTROLMETHOD_INSTALLREGIONHOOK
TBTDInfo | TIntuitionBase | TRANSPCONTROLMETHOD_UPDATETRANSPARENCY
TBTDInteger | TMenu | TRANSPCONTROL_OLDREGION
TBTDNode | TMenuItem | TRANSPCONTROL_OLDREGIONHOOK
TBTDString | TMsg | TRANSPCONTROL_REGION
TClassLibrary | TmsGetDefaultGammaTables | TRANSPCONTROL_REGIONHOOK
TColorSpec | TmsGetDefaultPixelFormat | TRemember
TDrawInfo | TmsGetPointerBounds | TRequester
TEasyStruct | TmsGetRootBitMap | TScreen
TExtEasyStruct | TmsQuery3DSupport | TScreenBuffer
TExtGadget | TmsSetDefaultGammaTables | TSGWork
TExtIntuiMessage | TMUIP_Screenbar_BuildSettingsPanel | TStringExtend
TExtNewScreen | TMUIP_Screenbar_DefaultConfigItem | TStringInfo
TExtNewWindow | TMUIP_Screenbar_KnowsConfigItem | TTabletData
TEXTPEN | TMUIP_Screenbar_Lock | TTabletHookData
TGadget | TMUIP_Screenbar_Signal | TTransparencyMessage
TGadgetInfo | TMUIP_Screenbar_Unlock | TWindow
TgpDomain | TMUIP_UpdateConfig |

U

UnlockIBase | UPFRONTGADGET | US_LEGAL
UnlockPubScreen | UPIMAGE | US_LETTER
UnlockPubScreenList | USEREQIMAGE |

V

ViewAddress ViewPortAddress

W

WA_Activate | WA_InnerHeight | WAT_WINDOWBOXLEFT
WA_AmigaKey | WA_InnerWidth | WAT_WINDOWBOXTOP
WA_AutoAdjust | WA_Left | WAT_WINDOWBOXWIDTH
WA_Backdrop | WA_MaxHeight | WA_UserPort
WA_BackFill | WA_MaxWidth | WA_VisibleOnMaximize
WA_BlockPen | WA_MenuHelp | WA_WBenchWindow
WA_Borderless | WA_MinHeight | WA_Width
WA_BusyPointer | WA_MinWidth | WA_WindowName
WAC_ACTIVATEWINDOW | WA_MouseQueue | WA_Zoom
WAC_CHANGEWINDOWBOX | WA_NewLookMenus | WBENCHCLOSE
WAC_DUMMY | WA_NoCareRefresh | WBENCHOPEN
WAC_FAMILYTOBACK | WA_NotifyDepth | WBENCHSCREEN_f
WAC_FAMILYTOFRONT | WA_Opacity | WBenchToBack
WA_Checkmark | WA_Parent | WBenchToFront
WAC_HIDEWINDOW | WA_Pointer | WFLG_ACTIVATE
WA_CloseGadget | WA_PointerDelay | WFLG_BACKDROP
WAC_MAXIMIZEWINDOW | WA_PointerType | WFLG_BORDERLESS
WAC_MINIMIZEWINDOW | WA_PubScreen | WFLG_CLOSEGADGET
WAC_MOVEWINDOW | WA_PubScreenFallBack | WFLG_DEPTHGADGET
WAC_MOVEWINDOWINFRONTOF | WA_PubScreenName | WFLG_DRAGBAR
WA_Colors | WA_ReportMouse | WFLG_GIMMEZEROZERO
WAC_OPENMENU | WA_RMBTrap | WFLG_HASZOOM
WAC_RESTOREINITIALSIZEPOS | WA_RptQueue | WFLG_INREQUEST
WAC_SENDIDCMPCLOSE | WA_ScreenTitle | WFLG_MENUSTATE
WAC_SHOWWINDOW | WA_ShadowBottom | WFLG_NEWLOOKMENUS
WAC_SIZEWINDOW | WA_ShadowLeft | WFLG_NOCAREREFRESH
WA_CustomScreen | WA_ShadowRight | WFLG_NW_EXTENDED
WAC_WINDOWTOBACK | WA_ShadowTop | WFLG_OTHER_REFRESH
WAC_WINDOWTOFRONT | WA_SimpleRefresh | WFLG_REFRESHBITS
WAC_ZIPWINDOW | WA_SizeBBottom | WFLG_REPORTMOUSE
WA_DepthGadget | WA_SizeBRight | WFLG_RMBTRAP
WA_DetailPen | WA_SizeDenominator | WFLG_SIMPLE_REFRESH
WA_DragBar | WA_SizeExtraHeight | WFLG_SIZEBBOTTOM
WA_Dummy | WA_SizeExtraWidth | WFLG_SIZEBRIGHT
WA_ExtraGadget_Iconify | WA_SizeGadget | WFLG_SIZEGADGET
WA_ExtraGadget_Jump | WA_SizeNumerator | WFLG_SMART_REFRESH
WA_ExtraGadget_Lock | WA_SkinInfo | WFLG_SUPER_BITMAP
WA_ExtraGadget_MUI | WA_SmartRefresh | WFLG_VISITOR
WA_ExtraGadget_PopUp | WA_SuperBitMap | WFLG_WBENCHWINDOW
WA_ExtraGadget_Snapshot | WA_TabletMessages | WFLG_WINDOWACTIVE
WA_ExtraGadgetsStartID | WAT_DUMMY | WFLG_WINDOWREFRESH
WA_ExtraTitlebarGadgets | WA_Title | WFLG_WINDOWTICKED
WA_Flags | WAT_MOVEWBEHINDWINDOW | WFLG_ZOOMED
WA_FrontWindow | WAT_MOVEWINDOWX | WindowAction
WA_Gadgets | WAT_MOVEWINDOWY | WindowLimits
WA_GimmeZeroZero | WA_ToolbarWindow | WindowToBack
WA_HasAlpha | WA_Top | WindowToFront
WA_Height | WA_TransparentRegion | WM_Dummy
WA_HelpGroup | WA_TransparentRegionHook | WM_ObtainEvents
WA_HelpGroupWindow | WAT_SIZEWINDOWX | WM_OpenMenu
WA_HitLevel | WAT_SIZEWINDOWY | WM_ReleaseEvents
WA_IDCMP | WAT_WINDOWBOXHEIGHT | W_TRACTOR

Z

ZipWindow ZOOMIMAGE


ActivateGadget

Activate a (string or custom) gadget.

Declaration

Source position: intuition.pas line 3534

function ActivateGadget(

  Gadgets: PGadget;

  Window: PWindow;

  Requester: PRequester

):LongBool;

Arguments

Window | A pointer to a window structure containing the gadget.
Requester | A pointer to a requester (may by nil if this isn't a requester gadget (i.e. GTYP_REQGADGET is not set)).

Function result

If the conditions are met, and the gadget is in fact a string gadget, then this function will return True, else False.

Description

Activates a string or custom gadget. If successful, this means that the user does not need to click in the gadget before typing.

The window parameter must point to the window which contains the gadget. If the gadget is actually in a requester, the window must contain the requester, and a pointer to the requester must also be passed. The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

The success of this function depends on a rather complex set of conditions. The intent is that the user is never interrupted from what interactions he may have underway.

The current set of conditions includes:

  • The window must be active. If you are opening a new window and want an active gadget in it, it is not sufficient to assume that the WFLG_ACTIVATE flag has taken effect by the time OpenWindow() returns, even if you insert a delay of some finite amount of time. Use the IDCMP_ACTIVEWINDOW IntuiMessage to tell when your window really becomes active. Many programs use an event loop that calls ActivateGadget() whenever they receive the IDCMP_ACTIVEWINDOW message, and also the IDCMP_MOUSEBUTTONS messages, and so on, to keep the gadget active until it is used (or the user selects some other "Cancel" gadget).
  • No other gadgets may be in use. This includes system gadgets, such as those for window sizing, dragging, etc.
  • If the gadget is in a requester, that requester must be active. (Use IDCMP_REQSET and IDCMP_REQCLEAR).
  • The right mouse button cannot be held down (e.g. menus)

Note: Don't try to activate a gadget which is disabled or not attached to a window or requester.


ActivateWindow

Activate an Intuition window.

Declaration

Source position: intuition.pas line 3532

procedure ActivateWindow(

  Window: PWindow

);

Arguments

Window

The window to activate

Description

Note that this call may have its action deferred: you cannot assume that when this call is made the selected window has become active. This action will be postponed while the user plays with gadgets and menus, or sizes and drags windows. You may detect when the window actually has become active by the IDCMP_ACTIVEWINDOW IDCMP message.

This call is intended to provide flexibility but not to confuse the user. Please call this function synchronously with some action by the user.

Errors

If the user has an autopointer tool (sunmouse), the call will succeed, but the tool will deactivate the window right after this function has activated it. It is not a good idea to try to prevent this by waiting for IDCMP_INACTIVEWINDOW and activating the window again since that will produce an annoying flicker and it will slow down the computer a lot.

See also

ModifyIDCMP | Modify the state of a window's IDCMPFlags.
OpenWindow | Open an Intuition window.
CloseWindow | Close an Intuition window.


AddClass

Make a public class available

Declaration

Source position: intuition.pas line 3579

procedure AddClass(

  ClassPtr: PIClass

);

Arguments

ClassPtr

The result of MakeClass()

Description

Adds a public boopsi class to the internal list of classes available for public consumption. You must call this function after you call MakeClass(). Do not use this function for private classes.

Errors

There is no protection against creating multiple classes with the same name yet. The operation of the system is undefined in this case.

See also

MakeClass | Create and initialize a boopsi class.
FreeClass | Frees a boopsi class created by MakeClass().
RemoveClass | Make a public boopsi class unavailable.


AddGadget

Add a gadget to the gadget list of a window.

Declaration

Source position: intuition.pas line 3457

function AddGadget(

  Window: PWindow;

  Gadget: PGadget;

  Position: LongWord

):Word;

Arguments

Window | A pointer to the window to get your gadget
Gadget | A pointer to the new gadget
Position | Integer position in the list for the new gadget (starting from zero as the first position in the list)

Function result

Returns the position of where the gadget was actually added.

Description

Adds the specified gadget to the gadget list of the given window, linked in at the position in the list specified by the position argument (that is, if Position == 0, the gadget will be inserted at the head of the list, and if Position == 1 then the gadget will be inserted after the first gadget and before the second). If the position you specify is greater than the number of gadgets in the list, your gadget will be added to the end of the list.

Calling AddGadget() does not cause your gadget to be redisplayed. The benefit of this is that you may add several gadgets without having the gadget list redrawn every time.

This procedure returns the position at which your gadget was added.

Note: A relatively safe way to add the gadget to the end of the list is to specify a position of -1 (i.e. Word $FFFF). That way, only the 65536th (and multiples of it) will be inserted at the wrong position. The return value of the procedure will tell you where it was actually inserted.

Note: The system window gadgets are initially added to the front of the gadget list. The reason for this is: If you position your own gadgets in some way that interferes with the graphical representation of the system gadgets, the system's ones will be "hit" first by user. If you then start adding gadgets to the front of the list, you will disturb this plan, so beware. On the other hand, if you don't violate the design rule of never overlapping your gadgets, there's no problem.

Note: You may not add your own gadgets to a screen. Gadgets may be added to backdrop windows, however, which can be visually similar, but also provide an IDCMP channel for gadget input messages.

See also

AddGList | Add a linked list of gadgets to a window or requester.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.


AddGList

Add a linked list of gadgets to a window or requester.

Declaration

Source position: intuition.pas line 3530

function AddGList(

  Window: PWindow;

  Gadget: PGadget;

  Position: LongWord;

  NumGad: LongInt;

  Requester: PRequester

):Word;

Arguments

Window | A pointer to the window to get your gadget
Gadget | A pointer to the first gadget to be added
Position | Integer position in the list for the new gadget (starting from zero as the first position in the list)
NumGad | The number of gadgets from the linked list to be added if Numgad equals -1, the entire nil-terminated list of gadgets will be added.
Requester | The requester the gadgets will be added to if the GTYP_REQGADGET GadgetType flag is set for the first gadget in the list

Function result

Returns the position of where the first gadget in the list was actually added.

Description

Adds the list of gadgets to the gadget list of the given window or requester linked in at the position in the list specified by the position argument.

See AddGadget() for more information about gadget list position, and more information about gadgets in general.

The requester parameter will be ignored unless the GTYP_REQGADGET bit is set in the GadgetType field of the first gadget in the list. In that case, the gadget list is added to the requester gadgets.

Note: be sure that GTYP_REQGADGET is either set or cleared consistently for all gadgets in the list.

Note also: The window parameter should point to the window that the requester (will) appear in.

Will add Numgad gadgets from gadget list linked by the field TGadget.NextGadget, or until some TGadget.NextGadget field is found to be nil. Does not assume that the Numgad'th gadget has TGadget.NextGadget equal to nil.

Note well: In order to link your gadget list in, the TGadget.NextGadget field of the Numgad'th (or last) gadget will be modified. Thus, if you are adding the first 3 gadgets from a linked list of five gadgets, this call will sever the connection between your third and fourth gadgets.

The gadgets will just be added. To make them visible, you must refresh the window or the gadgets.

See also

AddGadget | Add a gadget to the gadget list of a window.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.


AllocRemember

Allocate Memory with tracking to make freeing easy.

Declaration

Source position: intuition.pas line 3522

function AllocRemember(

  var RememberKey: PRemember;

  Size: LongWord;

  Flags: LongWord

):Pointer;

Arguments

RememberKey | Store information in this list. Must be nil for initial call.
Size | How many bytes to allocate
Flags | Attributes (see AllocMem())

Function result

If the memory allocation is successful, this routine returns the byte address of your requested memory block. Also, the node to your block will be linked into the list pointed to by your RememberKey variable. If the allocation fails, this routine returns nil and the list pointed to by RememberKey, if any, will be unchanged.

Description

This routine calls the Exec AllocMem() function for you, but also links the parameters of the allocation into a master list, so that you can simply call the Intuition routine FreeRemember() at a later time to deallocate all allocated memory without being required to remember the details of the memory you've allocated.

This routine will have two primary uses:

  • Let's say that you're doing a long series of allocations in a procedure. If any one of the allocations fails, your program may need to abort the procedure. Abandoning ship correctly involves freeing up what memory you've already allocated. This procedure allows you to free up that memory easily, without being required to keep track of how many allocations you've already done, what the sizes of the allocations were, or where the memory was allocated.
  • Also, in the more general case, you may do all of the allocations in your entire program using this routine. Then, when your program is exiting, you can free it all up at once with a simple call to FreeRemember().

You create the "anchor" for the allocation master list by creating a variable that's a pointer to struct Remember, and initializing that pointer to NULL. This is called the RememberKey. Whenever you call AllocRemember(), the routine actually does two memory allocations, one for the memory you want and the other for a copy of a Remember structure. The Remember structure is filled in with data describing your memory allocation, and it's linked into the master list pointed to by your RememberKey. Then, to free up any memory that's been allocated, all you have to do is call FreeRemember() with your RememberKey.

Please read the FreeRemember() function description, too. As you will see, you can select either to free just the link nodes and keep all the allocated memory for yourself, or to free both the nodes and your memory buffers.

See also

FreeRemember | Free memory allocated by calls to AllocRemember().
AllocMem | Allocate memory given certain requirements

Example

program RememberTest;
uses
  Intuition;
var
  RememberKey: PRemember;
begin
  RememberKey := nil;
  buffer := AllocRemember(@RememberKey, BUFSIZE, MEMF_CHIP);
  if Assigned(buffer) then
  begin
    // Use the buffer
    //...
  end;
  FreeRemember(@RememberKey, True);
end.


AllocScreenBuffer

Get a ScreenBuffer for double-buffering.

Declaration

Source position: intuition.pas line 3588

function AllocScreenBuffer(

  Sc: PScreen;

  Bm: PBitMap;

  Flags: LongWord

):PScreenBuffer;

Arguments

Flags

Flags see list SB_*

Function result

Pointer to a valid ScreenBuffer structure, or nil if failure. You may render into the resulting BitMap as appropriate. You may use the TScreenBuffer.sb_DBufInfo field to access graphics.library ViewPort-buffering features such as learning when it is safe to reuse the previous BitMap. If not, you risk writing into the on-screen BitMap, which can damage menu or gadget rendering!

Description

Allocates a ScreenBuffer structure and usually a BitMap. This structure can be used for double (or multiple) buffering in Intuition screens. You may use this call to obtain a ScreenBuffer structure for the screen's initial BitMap, or for other BitMaps you intend to swap in.

AllocScreenBuffer() also allocates a graphics.library DBufInfo structure. The ScreenBuffer structure this call returns contains a pointer to that TDBufInfo structure, which is free for your use. See AllocDBufInfo() for full details on using this structure to achieve notification of when it is safe to render into an old buffer and when it is right to switch again.

Flags:

SB_SCREEN_BITMAP
to get a ScreenBuffer referring to the screen's actual BitMap. (For CUSTOMBITMAP screens, just set the BitMap parameter to the BitMap you passed to OpenScreen()).
SB_COPY_BITMAP
If you would like the screen's BitMap copied into this ScreenBuffer's BitMap. This is required to get any menu-bar or gadget imagery into each ScreenBuffer's BitMap. If the screen has no Intuition rendering, you may omit this flag. Also, when allocating a ScreenBuffer for the screen's initial BitMap, this flag should not be set.

See also

FreeScreenBuffer | Free a ScreenBuffer structure.
ChangeScreenBuffer | Swap the screen's BitMap.
AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation


AutoRequest

Automatically build and get response from a requester.

Declaration

Source position: intuition.pas line 3512

function AutoRequest(

  Window: PWindow;

  Body: PIntuiText;

  PosText: PIntuiText;

  NegText: PIntuiText;

  PFlag: LongWord;

  NFlag: LongWord;

  Width: LongWord;

  Height: LongWord

):LongBool;

Arguments

Window | A pointer to a Window structure. See BuildSysRequest() for a full discussion.
Body | A pointer to an TIntuiText structure
PosText | A pointer to an TIntuiText structure, may by nil.
NegText | A pointer to an TIntuiText structure, must be valid!
PFlag | Flags for the IDCMP
NFlag | Flags for the IDCMP
Width | The width to be used for the rendering of the requester
Height | The height to be used for the rendering of the requester

Function result

The return value is either True or False. See the text above for a complete description of the chain of events that might lead to either of these values being returned.

Description

This procedure automatically builds a requester for you and then waits for a response from the user, or for the system to satisfy your request. If the response is positive, this procedure returns TRUE. If the response is negative, this procedure returns FALSE.

An IDCMPFlag specification is created by bitwise "or'ing" your PosFlags, NegFlags, and the IDCMP classes IDCMP_GADGETUP and IDCMP_RAWKEY. You may specify zero flags for either the PosFlags or NegFlags arguments.

The IntuiText arguments, and the width and height values, are passed directly to the BuildSysRequest() procedure along with your window pointer and the IDCMP flags. Please refer to BuildSysRequest() for a description of the IntuiText that you are expected to supply when calling this routine. It's an important but long-winded description that need not be duplicated here.

If the BuildSysRequest() procedure does not return a pointer to a window, it will return TRUE or FALSE (not valid structure pointers) instead, and these BOOL values will be returned to you immediately.

On the other hand, if a valid window pointer is returned, that window will have had its IDCMP ports and flags initialized according to your specifications. AutoRequest() then waits for IDCMP messages on the UserPort, which satisfies one of four requirements:

  • Iither the message is of a class that matches one of your PosFlags arguments (if you've supplied any), in which case this routine returns True.
  • or the message class matches one of your NegFlags arguments (if you've supplied any), in which case this routine returns False.
  • or the IDCMP message is of class IDCMP_GADGETUP, which means that one of the two gadgets, as provided with the PosText and NegText arguments, was selected by the user. If the True gadget was selected, True is returned. If the False gadget was selected, False is returned.
  • Lastly, two IDCMP_RAWKEY messages may satisfy the request: those for the V and B keys with the left Amiga key depressed. These keys, satisfy the gadgets on the left or right side of the requester--True or False--, respectively.

When the dust has settled, this routine calls FreeSysRequest() if necessary to clean up the requester and any other allocated memory.

When DOS brings up AutoRequests() on your process (eg. "Please insert volume XXX in any drive", they normally come up on the Workbench screen. If you set your Process pr_WindowPtr field to point to one of your windows, then DOS will bring its requesters up on the same screen as that window. A pr_WindowPtr of -1 prevents requesters from coming up at all. (Some FileSystem requesters cannot be redirected or supressed).

See also

EasyRequestArgs | Easy alternative to AutoRequest()
BuildSysRequest | Build and display a system requester.
SysReqHandler | Handle system requester input.


BASEOBJECT

Get "public" handle on baseclass instance from real beginning of obj data

Declaration

Source position: intuition.pas line 3616

function BASEOBJECT(

  O: P_Object

):Pointer;


BeginRefresh

Sets up a window for optimized refreshing.

Declaration

Source position: intuition.pas line 3513

procedure BeginRefresh(

  Window: PWindow

);

Arguments

Window

A pointer to the window structure which needs refreshing

Description

This routine sets up your window for optimized refreshing.

Its role is to provide Intuition integrated access to the Layers library function BeginUpdate(). Its additional contribution is to be sure that locking protocols for layers are followed, by locking both layers of a WFLG_GIMMEZEROZERO window only after the parent Layer_Info has been locked. Also, the WFLG_WINDOWREFRESH flag is set in your window, for your information.

The purpose of BeginUpdate(), and hence BeginRefresh(), is to restrict rendering in a window (layer) to the region that needs refreshing after an operation such as window sizing or uncovering. This restriction to the "damage region" persists until you call EndRefresh().

For instance, if you have a WFLG_SIMPLE_REFRESH window which is partially concealed and the user brings it to the front, you can receive an IDCMP_REFRESHWINDOW message asking you to refresh your display. If you call BeginRefresh() before doing any of the rendering, then the layer that underlies your window will be arranged so that the only rendering that will actually take place will be that which goes to the newly-revealed areas. This is very performance- efficient, and visually attractive.

After you have performed your refresh of the display, you should call EndRefresh() to reset the state of the layer and the window. Then you may proceed with rendering to the entire window as usual.

You learn that your window needs refreshing by receiving either a message of class IDCMP_REFRESHWINDOW through the IDCMP, or an input event of class IECLASS_REFRESHWINDOW through the Console device. Whenever you are told that your window needs refreshing, you should call BeginRefresh() and EndRefresh() to clear the refresh-needed state, even if you don't plan on doing any rendering. You may relieve yourself of even this burden by setting the WFLG_NOCAREREFRESH flag when opening your window.

Warning:

You should only perform simple graphics refreshing operations between BeginRefresh() and EndRefresh(). These include any graphics.library drawing functions or the simple Intuition rendering functions (DrawImage(), PrintIText(), DrawBorder(), and so on). In particular, do not call RefreshGadgets(), RefreshGList(), RefreshWindowFrame(), etc., since any of the complex Intuition functions run the risk of creating a deadlock. Also avoid any other high-level calls in Intuition or ones that might invoke Intuition. This means no calling SetPointer(), no calling LockIBase(), no dos.library functions (since an EasyRequest() might result), etc. Keep it simple.

By the time the application receives its IDCMP_REFRESHWINDOW message, Intuition has already repaired any damaged regions of the window border or the gadgets in the window, so attempts to redraw gadgets or borders are as unnecessary as they are dangerous.

Another Warning:

The concept of multiple refresh passes using EndRefresh(w, False); is not completely sound without further protection. The reason is that between two sessions, more damage can occur to your window. Your final EndRefresh(w, True); will dispose of all damage, including the new, and your initial refreshing pass will never get the chance to refresh the new damage.

To avoid this, you must protect your session using LockLayerInfo() which will prevent Intuition from performing window operations or anything else which might cause further damage from occurring. Again, while holding the LayerInfo lock make no Intuition function calls dealing with gadgets; just render.

You can, however, call InstallClipRegion() for the different refresh passes, if you have two clip regions.

Similar Warning:

Your program and Intuition "share" your window layer's DamageList. BeginRefresh() helps arbitrate this sharing, but the lower-level function layers.library/BeginUpdate() does not. It isn't really supported to use BeginUpdate() on a window's layer, but if you do for whatever reason it is critical that you first acquire the LayerInfo lock as in the above example: even if you only have one pass of refresh rendering to do. Otherwise, the refreshing of your window's borders and gadgets can be incomplete, and the problem might occur only under certain conditions of task priority and system load.

See also

EndRefresh | End the optimized refresh state of the window.
layers.BeginUpdate | Prepare to repair damaged layer.
OpenWindow | Open an Intuition window.
layers.InstallClipRegion | Install clip region in layer
layers.LockLayerInfo | Lock the LayerInfo structure.


BuildEasyRequest

Declaration

Source position: intuition.pas line 3634

function BuildEasyRequest(

  Window: PWindow;

  EasyStruct: PEasyStruct;

  IDCMP: LongWord;

  const Args: array of PtrUInt

):PWindow;


BuildEasyRequestArgs

Simple creation of system request.

Declaration

Source position: intuition.pas line 3558

function BuildEasyRequestArgs(

  Window: PWindow;

  EasyStruct: PEasyStruct;

  IDCMP: LongWord;

  Args: Pointer

):PWindow;

Arguments

Window | Reference window for requester: determines the requester window title and screen.
EasyStruct | A pointer to EasyStruct structure, as described in the EasyRequestArgs() .
IDCMP | (not a pointer) provided application specific IDCMP flags for the system requester window.
Args | see EasyRequestArgs()

Function result

A pointer to the system request window opened. In the event of problems, you may also be returned the value '0' which is to be interpreted as the "False, Cancel" choice, or (if you have a second gadget defined) the value '1', which is to be taken to mean the equivalent of your corresponding left-most gadget. If there is a problem creating the window, a recoverable alert may be substituted for the requester, and the result, either 0 or 1, returned.

Description

This function is to EasyRequestArgs() as BuildSysRequest() is to AutoRequest(): it returns a pointer to the system requester window. The input from that window can then be processed under application control.

It is recommended that this processing be done with SysReqHandler(), so that future enhancement to the processing will be enjoyed.

After you have determined that the requester is satisfied or cancelled, you must free this requester using FreeSysRequest().

Please see the autodoc for EasyRequestArgs().

Note: This function switches the processor stack to ensure sufficient stack space for the function to complete.

See also

EasyRequestArgs | Easy alternative to AutoRequest()
FreeSysRequest | Free resources gotten by a call to BuildSysRequest().
SysReqHandler | Handle system requester input.
BuildSysRequest | Build and display a system requester.
AutoRequest | Automatically build and get response from a requester.


BuildSysRequest

Build and display a system requester.

Declaration

Source position: intuition.pas line 3514

function BuildSysRequest(

  Window: PWindow;

  Body: PIntuiText;

  PosText: PIntuiText;

  NegText: PIntuiText;

  Flags: LongWord;

  Width: LongWord;

  Height: LongWord

):PWindow;

Arguments

Window | A pointer to a Window structure
Body | A pointer to an IntuiText structure
PosText | A pointer to an IntuiText structure
NegText | A pointer to an IntuiText structure
Flags | The IDCMP flags you want used for the initialization of the IDCMP of the window containing this requester
Width | The width required to render your requester
Height | The height required to render your requester

Function result

If the requester was successfully created, the value returned by this procedure is a pointer to the window in which the requester is rendered. If the requester could not be created, this routine might have called DisplayAlert() before returning (it depends on the version) and will pass back True if the user pressed the left mouse button and False if the user pressed the right mouse button. If the version of Intuition doesn't call DisplayAlert(), or if it does, and there's not enough memory for the alert, the value of False is returned.

Description

This procedure builds a system requester based on the supplied information. If all goes well and the requester is constructed, this procedure returns a pointer to the window in which the requester appears. That window will have its IDCMP initialized to reflect the flags found in the IDCMPFlags argument. You may then wait on those ports to detect the user's response to your requester, which response may include either selecting one of the gadgets or causing some other event to be noticed by Intuition (like IDCMP_DISKINSERTED, for instance). After the requester is satisfied, you should call the FreeSysRequest() procedure to remove the requester and free up any allocated memory.

See the autodoc for SysReqHandler() for more information on the how to handle the IntuiMessages this window will receive.

The requester used by this function has the NOISYREQ flag bit set, which means that the set of IDCMPFlags that may be used here include IDCMP_RAWKEYIDCMP_RAWKEY, IDCMP_MOUSEBUTTONS, and others.

The function may return True (1) or False (nil) if it cannot post the requester.

If the window argument you supply is equal to NULL, a new window will be created for you in the Workbench screen. If you want the requester created by this routine to be bound to a particular window (i.e., to appear in the same screen as the window), you should not supply a window argument of nil.

If you pass a nil window pointer, the system requester will appear on the default public screen, which is not always the Workbench.

The text arguments are used to construct the display. Each is a pointer to an instance of the structure IntuiText.

The BodyText argument should be used to describe the nature of the requester. As usual with IntuiText data, you may link several lines of text together, and the text may be placed in various locations in the requester. This IntuiText pointer will be stored in the ReqText variable of the new requester.

The PosText argument describes the text that you want associated with the user choice of "Yes, True, Retry, Good." If the requester is successfully opened, this text will be rendered in a gadget in the lower-left of the requester, which gadget will have the GadgetID field set to True. If the requester cannot be opened and the DisplayAlert() mechanism is used, this text will be rendered in the lower-left corner of the alert display with additional text specifying that the left mouse button will select this choice. This pointer can be set to nil, which specifies that there is no True choice that can be made.

The NegText argument describes the text that you want associated with the user choice of "No, False, Cancel, Bad." If the requester is successfully opened, this text will be rendered in a gadget in the lower-right of the requester, which gadget will have the GadgetID field set to FALSE. If the requester cannot be opened and the DisplayAlert() mechanism is used, this text will be rendered in the lower-right corner of the alert display with additional text specifying that the right mouse button will select this choice. This pointer cannot be set to nil. There must always be a way for the user to cancel this requester.

The Positive and Negative Gadgets created by this routine have the following features:

  • GTYP_BOOLGADGET
  • GACT_RELVERIFY
  • GTYP_REQGADGET
  • GACT_TOGGLESELECT

When defining the text for your gadgets, you may find it convenient to use the special constants used by Intuition for the construction of the gadgets. These include defines like AUTODRAWMODE, AUTOLEFTEDGE, AUTOTOPEDGE and AUTOFRONTPEN.

These hard-coded constants are not very resolution or font sensitive.

The width and height values describe the size of the requester. All of your BodyText must fit within the width and height of your requester. The gadgets will be created to conform to your sizes.

Very important Note: for this release of this procedure, a new window is opened in the same screen as the one containing your window. Future alternatives may be provided as a function distinct from this one.

Note: This function will pop the screen the requester and its window appears in to the front of all screens. If the user doesn't perform any other screen arrangement before finishing with the requester, a popped screen will be pushed back behind.

See also

FreeSysRequest | Free resources gotten by a call to BuildSysRequest().
DisplayAlert | Create the display of an alert message.
ModifyIDCMP | Modify the state of a window's IDCMPFlags.
Wait | Wait for one or more signals
Request | Activate a requester.
AutoRequest | Automatically build and get response from a requester.
EasyRequestArgs | Easy alternative to AutoRequest()
BuildEasyRequestArgs | Simple creation of system request.


ChangeScreenBuffer

Swap the screen's BitMap.

Declaration

Source position: intuition.pas line 3590

function ChangeScreenBuffer(

  Sc: PScreen;

  Sb: PScreenBuffer

):LongWord;

Function result

Returns non-zero if the operation succeeded. Returns zero if the operation cannot be performed. This function will fail if Intuition's state cannot permit it, for example the user is playing with menus or gadgets.

Description

Performs double (or multiple) buffering on an Intuition screen in an Intuition-cooperative manner. The BitMap associated with the supplied ScreenBuffer will be installed in the specified screen, if possible. The previously-installed BitMap is available for re-use upon receiving a signal from graphics.library. See the graphics.library autodocs for AllocDBufInfo() and ChangeVPBitMap() for details.

It is not required to restore the original ScreenBuffer before closing the screen. Simply FreeScreenBuffer() each buffer (including the original and the currently-installed one) then close the screen. Of course, you cannot call ChangeScreenBuffer() after freeing the currently-installed one.

See also

AllocScreenBuffer | Get a ScreenBuffer for double-buffering.
FreeScreenBuffer | Free a ScreenBuffer structure.
ChangeVPBitMap | Change display memory address for multi-buffered animation


ChangeWindowBox

Change window position and dimensions.

Declaration

Source position: intuition.pas line 3539

procedure ChangeWindowBox(

  Window: PWindow;

  Left: LongInt;

  Top: LongInt;

  Width: LongInt;

  Height: LongInt

);

Arguments

Window | The window to change position/dimension
Left | Left edge the window should move to
Top | Top edge the window should move to
Width | New Width for window
Height | New height for window

Description

Makes simultaneous changes in window position and dimensions, in absolute (not relative) coordinates.

Like MoveWindow() and SizeWindow(), the effect of this function is deferred until the next input comes along. Unlike these functions, ChangeWindowBox() specifies absolute window position and dimensions, not relative. This makes for more reliable results considering that the action is deferred, so this function is typically preferable to MoveWindow() and SizeWindow() paired.

You can detect that this operation has completed by receiving the IDCMP_CHANGEWINDOW IDCMP message

The dimensions are limited to legal range, but you should still take care to specify sensible inputs based on the window's dimension limits and the size of its screen.

This function limits the position and dimensions to legal values.

See also

MoveWindow | Ask Intuition to move a window.
SizeWindow | Ask Intuition to size a window.
ZipWindow | Change window to "alternate" position and dimensions.
MoveSizeLayer | Position/Size layer


ClearDMRequest

Clear (detaches) the DMRequest of the window.

Declaration

Source position: intuition.pas line 3458

function ClearDMRequest(

  Window: PWindow

):LongBool;

Arguments

Window

A pointer to the window from which the DMRequest is to be cleared.

Function result

If the DMRequest was not currently in use, detaches the DMRequest from the window and returns True. If the DMRequest was currently in use, doesn't change anything and returns False.

Description

Attempts to clear the DMRequest from the specified window, that is detaches the special requester that you attach to the double-click of the menu button which the user can then bring up on demand. This routine will not clear the DMRequest if it's active (in use by the user). The IDCMP message class IDCMP_REQCLEAR can be used to detect that the requester is not in use, but that message is sent only when the last of perhaps several requesters in use in a window is terminated.

See also

SetDMRequest | Set the DMRequest of a window.
Request | Activate a requester.


ClearMenuStrip

Clear (detach) the menu strip from the window.

Declaration

Source position: intuition.pas line 3459

procedure ClearMenuStrip(

  Window: PWindow

);

Arguments

Window

A pointer to a window structure

Description

Detaches the current menu strip from the window; menu strips are attached to windows using the SetMenuStrip() function.

If the menu is in use (for that matter if any menu is in use) this function will block (Wait()) until the user has finished.

Call this function before you make any changes to the data in a TMenu or TMenuItem structure# which is part of a menu strip linked into a window.

See also

SetMenuStrip | Attach a menu strip to a window.
ResetMenuStrip | Re-attach a menu strip to a window.


ClearPointer

Clear the mouse pointer definition from a window.

Declaration

Source position: intuition.pas line 3460

procedure ClearPointer(

  window: PWindow

);

Arguments

window

A pointer to the window to be cleared of its pointer definition

Description

Clears the window of its own definition of the Intuition mouse pointer. After calling ClearPointer(), every time this window is the active one the default Intuition pointer will be the pointer displayed to the user. If your window is the active one when this routine is called, the change will take place immediately.

Custom definitions of the mouse pointer which this function clears are installed by a call to SetPointer().

See also

SetWindowPointerA | Select a pointer for your window.
SetPointer | Specify a pointer sprite image for a window.


CloseScreen

Close an Intuition screen.

Declaration

Source position: intuition.pas line 3461

function CloseScreen(

  screen: PScreen

):LongBool;

Arguments

screen

A pointer to the screen to be closed.

Function result

Returns DOSTrue (1) if screen is closed, returns DOSFalse (0) if screen had open windows when called.

Description

Unlinks the screen, unlinks the viewport, deallocates everything that Intuition allocated when the screen was opened (using OpenScreen()). Doesn't care whether or not there are still any windows attached to the screen. Doesn't try to close any attached windows; in fact, ignores them altogether.

If this is the last screen to go, attempts to reopen Workbench.

This function will refuse to close the screen if there are windows open on the screen or if there are any outstanding screen locks (see LockPubScreen()) when CloseScreen() is called. This avoids the almost certain crash when a screen is closed out from under a window.

See also

OpenScreen

Open an Intuition screen


CloseWindow

Close an Intuition window.

Declaration

Source position: intuition.pas line 3462

procedure CloseWindow(

  window: PWindow

);

Arguments

window

A pointer to a Window structure

Description

Closes an Intuition window. Unlinks it from the system, deallocates its memory, and makes it disappear.

When this function is called, all IDCMP messages which have been sent to your window are deallocated. If the window had shared a message Port with other windows, you must be sure that there are no unreplied messages for this window in the message queue. Otherwise, your program will try to make use of a linked list (the queue) which contains free memory (the old messages). This will give you big problems. See the code fragment CloseWindowSafely(), below.

Note: If you have added a Menu strip to this Window (via a call to SetMenuStrip()) you must be sure to remove that Menu strip (via a call to ClearMenuStrip()) before closing your Window.

Note: This function may block until it is safe to de-link and free your window. Your program may thus be suspended while the user plays with gadgets, menus, or window sizes and position.

If your window is a "Visitor Window" (see OpenWindow()) CloseWindow() will decrement the "visitor count" in the public screen on which the window was open. When the last visitor window is closed, a signal will be sent to the public screen task, if this was pre-arranged (see OpenWindow()).

{ these functions close an Intuition window
  that shares a port with other Intuition
  windows or IPC customers.

  We are careful to set the UserPort to
  nil before closing, and to free
  any messages that it might have been
  sent.}
procedure CloseWindowSafely(Win: PWindow);
begin
  // we forbid here to keep out of race conditions with Intuition
  Forbid();
  // send back any messages for this window that have not yet been processed
  StripIntuiMessages(Win^.UserPort, Win);
  // clear UserPort so Intuition will not free it
  Win^.UserPort := nil;
  // tell Intuition to stop sending more messages
  ModifyIDCMP(Win, 0);
  // turn multitasking back on
  Permit();
  // and really close the window
  CloseWindow(Win);
end;

{ Remove and reply all IntuiMessages on a port that
  have been sent to a particular window
  (note that we don't rely on the ln_Succ pointer
  of a message after we have replied it)}
procedure StripIntuiMessages(var Mp: PMsgPort; var Win: PWindow);
var
  msg: PIntuiMessage;
  Succ: PNode;
begin
  Msg := PIntuiMessage(Mp^.mp_MsgList.lh_Head);
  Succ := Msg^.ExecMessage.mn_Node.ln_Succ;
  while Assigned(succ) do
  begin
    if Msg^.IDCMPWindow = Win then
    begin
      // Intuition is about to free this message. Make sure that we have politely sent it back.
      Remove(Msg);
      ReplyMsg(Msg);
    end;
    Msg := PIntuiMessage(Succ);
    Succ := Msg^.ExecMessage.mn_Node.ln_Succ;
  end;
end;

See also

OpenWindow | Open an Intuition window.
OpenScreen | Open an Intuition screen
CloseScreen | Close an Intuition screen.


CloseWorkBench

Closes the Workbench screen.

Declaration

Source position: intuition.pas line 3463

function CloseWorkBench: LongInt;

Function result

DOSTrue if the Workbench screen closed successfully DOSFalse if the Workbench was not open, or if it has windows open which are not Workbench drawers.

Description

This routine attempts to close the Workbench screen:

  • Test whether or not any applications have opened windows on the Workbench, and return False if so. Otherwise ...
  • Clean up all special buffers
  • Close the Workbench screen
  • Make the Workbench program mostly inactive (it will still monitor disk activity)
  • Return DOSTrue

See also

OpenWorkBench

Open the Workbench screen.


CurrentTime

Get the current time values.

Declaration

Source position: intuition.pas line 3464

procedure CurrentTime(

  var seconds: LongWord;

  var micros: LongWord

);

Arguments

seconds | A pointer to a LongInt variable to receive the current seconds value
micros | A pointer to a LongInt variable for the current microseconds value

Description

Puts copies of the current time into the supplied argument pointers.

This time value is not extremely accurate, nor is it of a very fine resolution. This time will be updated no more than sixty times a a second, and will typically be updated far fewer times a second.


CUSTOM_HOOK

Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget

Declaration

Source position: intuition.pas line 3628

function CUSTOM_HOOK(

  Gadget: PGadget

):PHook;


DisplayAlert

Create the display of an alert message.

Declaration

Source position: intuition.pas line 3465

function DisplayAlert(

  AlertNumber: LongWord;

  String1: PChar;

  Height: LongWord

):LongBool;

Arguments

AlertNumber | The number of this alert message. The only pertinent bits of this number are the ALERT_TYPE bit(s). The rest of the number is ignored by this routine.
Height | Minimum display lines required for your message

Function result

A LongBool value of True or False. If this is a DEADEND_ALERT, False is always the return value. If this is a RECOVERY_ALERT. The return value will be True if the user presses the left mouse button in response to your message, and False if the user presses the right hand button is response to your text, or if the alert could not be posted.

Description

Creates an alert display with the specified message.

If the system can recover from this alert, it's a RECOVERY_ALERT and this routine waits until the user presses one of the mouse buttons, after which the display is restored to its original state and a LongBool value is returned by this routine to specify whether or not the user pressed the Left mouse button.

If the system cannot recover from this alert, it's a DEADEND_ALERT and this routine returns immediately upon creating the alert display. The return value is False.

NOTE: If Intuition can't get enough memory for a RECOVERY_ALERT, the value False will be returned.

AlertNumber is a LongInt value, historically related to the value sent to the Alert() routine. But the only bits that are pertinent to this routine are the ALERT_TYPE bit(s). These bits must be set to either RECOVERY_ALERT for alerts from which the system may safely recover, or DEADEND_ALERT for those fatal alerts. These states are described in the paragraph above. There is a third type of alert, the DAISY_ALERT, which is used only by the Exec.

The String_ argument points to an AlertMessage string. The AlertMessage string is comprised of one or more substrings, each of which is composed of the following components:

  • first, a 16-bit x-coordinate and an 8-bit y-coordinate, describing where on the alert display you want this string to appear. The y-coordinate describes the offset to the baseline of the text.
  • then, the bytes of the string itself, which must be null-terminated (end with a byte of zero)
  • lastly, the continuation byte, which specifies whether or not there's another substring following this one. If the continuation byte is non-zero, there is another substring to be processed in this alert message. If the continuation byte is zero, this is the last substring in the message.

The last argument, Height, describes how many video lines tall you want the alert display to be.

Alerts are always rendered in Topaz 8 (80 column font), regardless of the system default font. Also, RECOVERY_ALERTs are displayed in amber, while DEADEND_ALERTs are still red. Alerts no longer push down the application screens to be displayed. Rather, they appear alone in a black display.

Alerts block each other out, and input during an alert is deprived of the rest of the system. Internal input buffers still cause alert clicks to be processed by applications sometimes.

Errors

This function is obsolete and exists only for backwards compatibility with AmigaOS(tm). On various modern systems this function has different effects. On classic Amiga(tm) this function may not work with RTG displays, so it is generally deprecated. Please don't use it in a new software! Use legitimate intuition requesters if you want to present some message to the user.

See also

TimedDisplayAlert

Display an alert with automatic time-out.


DisplayBeep

Flash the video display.

Declaration

Source position: intuition.pas line 3466

procedure DisplayBeep(

  Screen: PScreen

);

Arguments

Screen

A pointer to a screen. If nil, every screen in the display will be flashed

Description

"Beeps" the video display by flashing the background color of the specified screen. If the screen argument is nil, every screen in the display will be beeped. Flashing everyone's screen is not a polite thing to do, so this should be reserved for dire circumstances.

The reason such a routine is supported is because the Amiga has no internal bell or speaker. When the user needs to know of an event that is not serious enough to require the use of a requester, the DisplayBeep() function may be called.

Intuition calls DisplayBeep() through the external library vector. This means that if you call SetFunction() to replace DisplayBeep() with an audible beep, for example, then your change will affect even Intuition's calls to DisplayBeep().

Since this function changes color zero of the affected screen(s), surprising results could occur if the screen's owner reading colors or perhaps cycling them.


DisposeObject

Deletes a 'boopsi' object.

Declaration

Source position: intuition.pas line 3569

procedure DisposeObject(

  Object1: Pointer

);

Description

Deletes a boopsi object and all of it auxiliary data. These objects are all created by NewObject(). Objects of certain classes "own" other objects, which will also be deleted when the object is passed to DisposeObject(). Read the per-class documentation carefully to be aware of these instances.

This function invokes the OM_DISPOSE method.

See also

NewObject | Varargs version of NewObjectA()
SetAttrs | Varargs Version of SetAttrsA()
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


DoGadgetMethod

Declaration

Source position: intuition.pas line 3639

function DoGadgetMethod(

  Gad: PGadget;

  Win: PWindow;

  Req: PRequester;

  const Args: array of PtrUInt

):LongWord;


DoGadgetMethodA

Invoke method on a boopsi gadget.

Declaration

Source position: intuition.pas line 3595

function DoGadgetMethodA(

  Gad: PGadget;

  Win: PWindow;

  Req: PRequester;

  Message: PLongWord

):LongWord;

Arguments

Gad | An abstract pointer to a boopsi gadget
Win | window gadget has been added to using AddGList() or AddGadget()
Req | For REQGADGETs, requester containing the gadget

Function result

The object does whatever it wants with the message you sent, which might include updating its gadget visuals. The return value is defined per-method.

Description

Same as the DoMethodA() function, but provides context information and arbitration for classes which implement custom Intuition gadgets.

You should use this function for boopsi gadget objects, or for "models" which propagate information to gadgets.

Unlike DoMethodA(), this function provides a TGadgetInfo pointer (if possible) when invoking the method. Some classes may require or benefit from this.

Note: This function invokes the specified method with a TGadgetInfo derived from the Window and Requester pointers. The TGadgetInfo is passed as the second parameter of the message, except for OM_NEW, OM_SET, OM_NOTIFY, and OM_UPDATE, where the TGadgetInfo is passed as the third parameter.

Implementers of new gadget methods should ensure that the TGadgetInfo is the second long-word of their message!

See also

NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


DoMethod

VarArgs Version of DoMethodA()

Declaration

Source position: intuition.pas line 3649

function DoMethod(

  obj: PObject_;

  const Msg: array of PtrUInt

):PtrUInt;

Description

Boopsi support function that invokes the supplied message on the specified object. The message is invoked on the object's true class.

See also

DoMethodA | Perform method on object.
DoSuperMethodA | Perform method on object coerced to superclass.


DoMethodA

Perform method on object.

Declaration

Source position: intuition.pas line 3648

function DoMethodA(

  Obj: PObject_;

  Msg: Pointer

):PtrUInt;

Arguments

Obj

A pointer to boopsi object

Function result

Specific to the message and the object's class.

Description

Boopsi support function that invokes the supplied message on the specified object. The message is invoked on the object's true class.

See also

DoMethod | VarArgs Version of DoMethodA()
DoSuperMethodA | Perform method on object coerced to superclass.


DoSuperMethod

VarArgs Version of DoSuperMethodA()

Declaration

Source position: intuition.pas line 3652

function DoSuperMethod(

  Cl: PIClass;

  Obj: PObject_;

  const Msg: array of PtrUInt

):PtrUInt;


DoSuperMethodA

Perform method on object coerced to superclass.

Declaration

Source position: intuition.pas line 3651

function DoSuperMethodA(

  Cl: PIClass;

  Obj: PObject_;

  Message: Pointer

):PtrUInt;

Arguments

Cl | A pointer to boopsi class whose superclass is to receive the message
Obj | A pointer to boopsi object
Message | A pointer to method-specific message to send

Function result

A class and message-specific result.

Description

Boopsi support function that invokes the supplied message on the specified object, as though it were the superclass of the specified class.

See also

DoMethodA | Perform method on object.
DoSuperMethod | VarArgs Version of DoSuperMethodA()


DoSuperNew

Declaration

Source position: intuition.pas line 3654

function DoSuperNew(

  Cl: PIClass;

  Obj: PObject_;

  const Tags: array of PtrUInt

):PtrUInt;


DoubleClick

Test two time values for double-click timing.

Declaration

Source position: intuition.pas line 3467

function DoubleClick(

  SSeconds: LongWord;

  SMicros: LongWord;

  CSeconds: LongWord;

  CMicros: LongWord

):LongBool;

Arguments

SSeconds | The timestamp value describing the start of the double-click time period you are considering
SMicros | Microseconds of start
CSeconds | The timestamp value describing the end of the double-click time period you are considering
CMicros | Microsecond of end

Function result

If the difference between the supplied timestamp values is within the double-click time range in the current set of Preferences, this function returns True, else it returns False

Description

Compares the difference in the time values with the double-click timeout range that the user has set (using the "Preferences" tool) or some other program has configured into the system. If the difference between the specified time values is within the current double-click time range, this function returns True, else it returns False.

These time values can be found in input events and IDCMP messages. The time values are not perfect; however, they are precise enough for nearly all applications.

See also

CurrentTime

Get the current time values.


DrawBorder

Draw the specified Border structure into a RastPort.

Declaration

Source position: intuition.pas line 3468

procedure DrawBorder(

  Rp: PRastPort;

  Border: PBorder;

  LeftOffset: LongInt;

  TopOffset: LongInt

);

Arguments

Rp | A pointer to the RastPort to receive the border rendering
Border | A pointer to a Border structure
LeftOffset | The offset to be added to each vector's x coordinate
TopOffset | The offset to be added to each vector's y coordinate

Description

First, sets up the draw mode and pens in the RastPort according to the arguments of the Border structure. Then, draws the vectors of the border argument into the RastPort, offset by the left and top offsets.

As with all graphics rendering routines, the border will be clipped to to the boundaries of the RastPort's layer, if it exists. This is the case with window RastPorts.

This routine will draw all borders in the null-terminated list linked by the NextBorder field of the border argument.


DrawImage

Draw the specified Image structure into a RastPort.

Declaration

Source position: intuition.pas line 3469

procedure DrawImage(

  Rp: PRastPort;

  Image: PImage;

  LeftOffset: LongInt;

  TopOffset: LongInt

);

Arguments

Rp | A pointer to the RastPort to receive image rendering
Image | A pointer to an image structure
LeftOffset | The offset which will be added to the image's x coordinate
TopOffset | The offset which will be added to the image's y coordinate

Description

First, sets up the draw mode and pens in the RastPort according to the arguments of the Image structure. Then, moves the image data of the image argument into the RastPort, offset by the left and top offsets.

This routine does window layer clipping if you pass your window's (layered) RastPort -- if you draw an image outside of your window, your imagery will be clipped at the window's edge. If you pass a (non-layered) screen RastPort, you must be sure your image is wholly contained within the rastport bounds.

If the NextImage field of the image argument is non-nil, the next image is rendered as well, and so on until some NextImage field is found to be nil.

Note:

Intuition always has and will continue to assume there are at least as many planes of data pointed to by ImageData as there are '1' bits in the PlanePick field. Please ensure that this is so.

See also

DrawImageState | Draw an (extended) Intuition Image with special visual state.
EraseImage | Erases an Image.


DrawImageState

Draw an (extended) Intuition Image with special visual state.

Declaration

Source position: intuition.pas line 3563

procedure DrawImageState(

  Rp: PRastPort;

  Image: PImage;

  LeftOffset: LongInt;

  TopOffset: LongInt;

  State: LongWord;

  DrawInfo: PDrawInfo

);

Arguments

Rp | RastPort for rendering
Image | A pointer to a (preferably custom) image
LeftOffset | Left positional offsets in pixels
TopOffset | Top positional offsets in pixels
State | Visual state selected from above
DrawInfo | A pointer to packed of pen selections and resolution.

Description

This function draws an Intuition Image structure in a variety of "visual states", these include:

IDS_NORMAL
like DrawImage()
IDS_SELECTED
represents the "selected state" of a Gadget
IDS_DISABLED
the "ghosted state" of a gadget
IDS_BUSY
for future functionality
IDS_INDETERMINATE
for future functionality
IDS_INACTIVENORMAL
for gadgets in window border
IDS_INACTIVESELECTED
for gadgets in window border
IDS_INACTIVEDISABLED
for gadgets in window border

Only IDS_NORMAL will make sense for traditional Image structures, this function is more useful when applied to new custom images or "object-oriented image classes."

Each class of custom images is responsible for documenting which visual states it supports, and you typically want to use images which support the appropriate states with your custom gadgets.

The DrawInfo parameter provides information invaluable to "rendered" images, such as pen color and resolution. Each image class must document whether this parameter is required.

See also

DrawImage | Draw the specified Image structure into a RastPort.
GetScreenDrawInfo | Get pointer to rendering information.


EasyRequest

VarArgs Version of EasyRequestArgs()

Declaration

Source position: intuition.pas line 3633

function EasyRequest(

  Window: PWindow;

  const EasyStruct: PEasyStruct;

  IDCMPPtr: PLongWord;

  const Args: array of PtrUInt

):LongInt;


EasyRequestArgs

Easy alternative to AutoRequest()

Declaration

Source position: intuition.pas line 3557

function EasyRequestArgs(

  Window: PWindow;

  EasyStruct: PEasyStruct;

  IDCMPPtr: PLongWord;

  Args: Pointer

):LongInt;

Arguments

Window | Reference window pointer, determines the screen and title of the requester window. This can be nil, which means the requester is to appear on the Workbench screen, or default public screen, if defined.
EasyStruct | A Pointer to EasyStruct structure
Args | Arguments for format commands. Arguments for GadFmt follow arguments for TextFmt.

Function result

0, 1, ..., N = Successive GadgetID values, for the gadgets you specify for the requester. Note: The numbering from left to right is actually: 1, 2, ..., N, 0. This is for compatibility with AutoRequest(), which has False for the rightmost gadget.

-1 = Means that one of the caller-supplied IDCMPFlags occurred. The IDCMPFlag value is in the LongWord pointed to by IDCMP_ptr.

Description

This function provides a simpler method of using a 'System Requester' than provided by AutoRequest(). It performs layout and size calculations sensitive to the current font and screen resolution.

It provides for the descriptive body text and the gadget text to be constructed from printf style format strings.

It also provides a general way for the requester to be sensitive to particular IDCMP messages.

The first function listed is the actual Intuition library function. It is passed the arguments for the formatting operations as a pointer to the first argument.

Note: The formatting is done by RawDoFmt(), so be aware that to display a 32-bit integer argument, for example, you must say "%ld", not "%d", since RawDoFmt() is "word-oriented."

Note: This function switches the processor stack to ensure sufficient stack space for the function to complete.

See also

EasyRequest | VarArgs Version of EasyRequestArgs()
RawDoFmt | Format data into a character stream.
BuildEasyRequestArgs | Simple creation of system request.
SysReqHandler | Handle system requester input.
AutoRequest | Automatically build and get response from a requester.
BuildSysRequest | Build and display a system requester.


EndRefresh

End the optimized refresh state of the window.

Declaration

Source position: intuition.pas line 3515

procedure EndRefresh(

  Window: PWindow;

  Complete: LongBool

);

Arguments

Window | A pointer to the window currently in optimized-refresh mode
Complete | Boolean True or False describing whether or not this window is completely refreshed

Description

This function gets you out of the special refresh state of your window. It is called following a call to BeginRefresh(), which routine puts you into the special refresh state. While your window is in the refresh state, the only rendering that will be wrought in your window will be to those areas which were recently revealed and need to be refreshed.

After you've done all the refreshing you want to do for this window, you should call this routine to restore the window to its non-refreshing state. Then all rendering will go to the entire window, as usual.

The Complete argument is a boolean True or False value used to describe whether or not the refreshing you've done was all the refreshing that needs to be done at this time. Most often, this argument will be True. But if, for instance, you have multiple tasks or multiple procedure calls which must run to completely refresh the window, then each can call its own BeginRefresh()/EndRefresh() pair with a Complete argument of False, and only the last calls with a Complete argument of True.

Warning: Passing this function the value of False has its pitfalls. Please see BeginRefresh().

For your information, this routine calls the Layers library function EndUpdate(), unlocks your layers (calls UnlockLayerRom()), clears the LAYERREFRESH bit in your Layer Flags, and clears the WFLG_WINDOWREFRESH bit in your window Flags.

See also

BeginRefresh | Sets up a window for optimized refreshing.
EndUpdate | remove damage list and restore state of layer to normal.
UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.


EndRequest

Remove a currently active requester.

Declaration

Source position: intuition.pas line 3470

procedure EndRequest(

  Requester: PRequester;

  Window: PWindow

);

Arguments

Requester | A pointer to the requester to be removed
Window | A pointer to the Window structure with which this requester is associated

Description

Ends the request by erasing the requester and decoupling it from the window.

Note that this doesn't necessarily clear all requesters from the window, only the specified one. If the window labors under other requesters, they will remain in the window.

See also

InitRequester | Initialize a Requester structure.
Request | Activate a requester.


EraseImage

Erases an Image.

Declaration

Source position: intuition.pas line 3565

procedure EraseImage(

  Rp: PRastPort;

  Image: PImage;

  LeftOffset: LongInt;

  TopOffset: LongInt

);

Arguments

Rp | RastPort to erase a part of
Image | Custom or standard image
LeftOffset | Left pixel offsets of Image position
TopOffset | Top pixel offsets of Image position

Description

Erases an Image. For a normal Image structure, this will call the graphics function EraseRect() (clear using layer backfill, if any) for the Image box (LeftEdge/TopEdge/Width/Height).

For custom image, the exact behavior is determined by the custom image class.

See also

EraseRect() | Fill a defined rectangular area using the current BackFill hook.
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.


FreeClass

Frees a boopsi class created by MakeClass().

Declaration

Source position: intuition.pas line 3586

function FreeClass(

  ClassPtr: PIClass

):LongBool;

Function result

Returns False if the class could not be freed. Reasons include, but will not be limited to, having non-zero cl_ObjectCount or cl_SubclassCount. Returns True if the class could be freed. Calls RemoveClass() for the class in either case.

Description

For class implementors only.

Tries to free a boopsi class created by MakeClass(). This won't always succeed: classes with outstanding objects or with subclasses cannot be freed. You cannot allow the code which implements the class to be unloaded in this case.

For public classes, this function will always remove the class (see RemoveClass() ) making it unavailable, whether it succeeds or not.

If you have a dynamically allocated data for your class (hanging off of cl_UserData), try to free the class before you free the user data, so you don't get stuck with a half-freed class.

Snippet

// Free a public class with dynamic memory in cl_UserData
function freeMyClass(cl: PClass): Boolean;
var
  mpcd: PMyPerClassData;
begin
  Result := False;
  mpcd = PMyPerClassData(cl^.cl_UserData);
  if FreeClass(cl) then
  begin
    FreeMem(mpcd, SizeOf(TMyPerClassData));
    Result := True;
  end;
end;

See also

MakeClass

Create and initialize a boopsi class.


FreeMonitorList

Declaration

Source position: intuition.pas line 3610

procedure FreeMonitorList(

  List: PPObject_

);


FreeRemember

Free memory allocated by calls to AllocRemember().

Declaration

Source position: intuition.pas line 3523

procedure FreeRemember(

  var RememberKey: PRemember;

  ReallyForget: LongInt

);

Arguments

RememberKey | The address of a pointer to struct Remember. This pointer should either be nil or set to some value (possibly nil) by a call to AllocRemember().
ReallyForget | A LongBool False or True describing, respectively, whether you want to free up only the Remember nodes or if you want this procedure to really forget about all of the memory, including both the nodes and the memory buffers referenced by the nodes.

Description

This function frees up memory allocated by the AllocRemember() function. It will either free up just the Remember structures, which supply the link nodes that tie your allocations together, or it will deallocate both the link nodes AND your memory buffers too.

If you want to deallocate just the Remember structure link nodes, you should set the ReallyForget argument to False. However, if you want FreeRemember() to really deallocate all the memory, including both the Remember structure link nodes and the buffers you requested via earlier calls to AllocRemember(), then you should set the ReallyForget argument to True.

Note well: Once you call this function passing it False, the linkages between all the memory chunks are lost, and you cannot subsequently use FreeRemember() to free them.

See also

AllocRemember | Allocate Memory with tracking to make freeing easy.
ExecFreeMem | Free a memory block with given size

Example

program RememberTest;
uses
  Intuition;
var
  RememberKey: PRemember;
begin
  RememberKey := nil;
  buffer := AllocRemember(@RememberKey, BUFSIZE, MEMF_CHIP);
  if Assigned(buffer) then
  begin
    // Use the buffer
    //...
  end;
  FreeRemember(@RememberKey, True);
end.


FreeScreenBuffer

Free a ScreenBuffer structure.

Declaration

Source position: intuition.pas line 3589

procedure FreeScreenBuffer(

  Sc: PScreen;

  Sb: PScreenBuffer

);

Description

Frees a ScreenBuffer structure you got from AllocScreenBuffer(), and releases associated resources. You must call FreeScreenBuffer() before you close your screen.

Notes:

Originally, FreeScreenBuffer() did not WaitBlit() before freeing a BitMap. The intent was that the application should do this. Application writers should ensure that freeing the buffer is safe by calling WaitBlit() themselves.

The SB_SCREEN_BITMAP flag instructs AllocScreenBuffer() to provide a ScreenBuffer referring to the screen's actual bitmap. When you are done changing screen buffers, you must FreeScreenBuffer() the currently-installed ScreenBuffer before you close the screen. Intuition will recognize when FreeScreenBuffer() is called for the currently-installed ScreenBuffer, and will know to free the supporting structures but not the BitMap. CloseScreen() will take care of that.

See also

AllocScreenBuffer | Get a ScreenBuffer for double-buffering.
ChangeScreenBuffer | Swap the screen's BitMap.
ChangeVPBitMap | Change display memory address for multi-buffered animation


FreeScreenDrawInfo

Finish using a DrawInfo structure.

Declaration

Source position: intuition.pas line 3582

procedure FreeScreenDrawInfo(

  Screen: PScreen;

  DrawInfo: PDrawInfo

);

Arguments

Screen | A pointer to screen passed to GetScreenDrawInfo().
DrawInfo | A pointer to DrawInfo returned by GetScreenDrawInfo(). A nil DrawInfo pointer is a valid parameter, signifying "do nothing".

Description

Declares that you are finished with the DrawInfo structure returned by GetScreenDrawInfo().

This function, and GetScreenDrawInfo(), don't really do much, but they provide an upward compatibility path. That means that if you misuse them today, they probably won't cause a problem, although they may someday later. So, please be very careful only to use the DrawInfo structure between calls to GetScreenDrawInfo() and FreeScreenDrawInfo(), and be sure that you don't forget FreeScreenDrawInfo().

See also

GetScreenDrawInfo

Get pointer to rendering information.


FreeSysRequest

Free resources gotten by a call to BuildSysRequest().

Declaration

Source position: intuition.pas line 3516

procedure FreeSysRequest(

  Window: PWindow

);

Arguments

Window

Value of the window pointer returned by a successful call to the BuildSysRequest() procedure

Description

This routine frees up all memory allocated by a successful call to the BuildSysRequest() procedure. If BuildSysRequest() returned a pointer to a window, then you are able to wait on the message port of that window to detect an event which satisfies the requester. When you want to remove the requester, you call this procedure. It ends the requester and deallocates any memory used in the creation of the requester. It also closes the special window that was opened for your system requester.

See also

BuildSysRequest | Build and display a system requester.
AutoRequest | Automatically build and get response from a requester.
CloseWindow | Close an Intuition window.


FULLMENUNUM

Menu helper macro

Declaration

Source position: intuition.pas line 3623

function FULLMENUNUM(

  Menu: SmallInt;

  Item: SmallInt;

  Sub: SmallInt

):Word;


GadgetMouse

Calculate gadget-relative mouse position.

Declaration

Source position: intuition.pas line 3555

procedure GadgetMouse(

  Gadget: PGadget;

  GInfo: PGadgetInfo;

  var MousePoint: SmallInt

);

Arguments

Gadget | A pointer to the Gadget
GInfo | A pointer to a GadgetInfo structure as passed to the custom gadget hook routine.
MousePoint | Address of two Words, or a pointer to a structure of type Point.

Description

Determines the current location of the mouse pointer relative to the upper-left corner of a custom gadget. Typically used only in the GM_HANDLEINPUT and GM_GOACTIVE custom gadget hook routines.

News flash!!: These two hook routines are now passed the mouse coordinates, so this function has no known usefulness.

We recommend that you don't call it.

Note that this function calculates the mouse position taking "gadget relativity" (GFLG_RELRIGHT, GFLG_RELBOTTOM) into consideration. If your custom gadget intends to ignore these properties, then you should either enjoin or inhibit your users from setting those bits, since Intuition won't ask if you respect them.

Errors

This function is useless, because programs which need this information can get it in a cleaner way. It is recommended not to call this function!


GADGET_BOX

Get bounding box of a gadget

Declaration

Source position: intuition.pas line 3627

function GADGET_BOX(

  G: PGadget

):PIBox;


GetAttr

Inquire the value of some attribute of an object.

Declaration

Source position: intuition.pas line 3572

function GetAttr(

  AttrID: LongWord;

  Object1: Pointer;

  StoragePtr: PLongWord

):LongWord; overload;

function GetAttr(

  AttrID: LongWord;

  Object1: Pointer;

  var Storage: LongWord

):LongWord; overload;

Arguments

AttrID | The attribute tag ID understood by the object's class
StoragePtr | A pointer to appropriate storage for the answer

Function result

Mostly True if the method is supported for the specified attribute and False if it isn't or the attribute can't be read at this time. See the classes documentation for details.

Arguments

AttrID

The attribute tag ID understood by the object's class

Description

Inquires from the specified object the value of the specified attribute.

You always pass the address of a long variable, which will receive the same value that would be passed to SetAttrs() in the ti_Data portion of a TagItem element.

Not all attributes will respond to this function. Those that will are documented on a class-by-class basis.

This function sends OM_GET to the object.

See also

NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
SetAttrs | Varargs Version of SetAttrsA()
MakeClass | Create and initialize a boopsi class.


GetDefaultPubScreen

Get name of default public screen.

Declaration

Source position: intuition.pas line 3556

procedure GetDefaultPubScreen(

  NameBuffer: PChar

);

Arguments

NameBuffer

A buffer of MAXPUBSCREENNAME. This can be nil.

Description

Provides the name of the current default public screen. Only anticipated use is for Public Screen Manager utilities, since it is easy to open a visitor window on the default public screen without specifying the name.

Note:

Only Public Screen Manager utilities want to use this function since it is easy to open a window on the default public screen without specifying a name.

Also note that if there no default public screen has been set, the return value of this function will be zero, and not a pointer to the Workbench screen.

See also

SetDefaultPubScreen | Choose a new default public screen.
OpenWindow | Open an Intuition window.


GetDefPrefs

Get a copy of the the Intuition default Preferences.

Declaration

Source position: intuition.pas line 3471

function GetDefPrefs(

  Preferences: PPreferences;

  size: LongInt

):PPreferences;

Arguments

Preferences | A pointer to the memory buffer to receive your copy of the Intuition Preferences structure
size | The number of bytes in your PrefBuffer, the number of bytes you want copied from the system's internal Preference settings

Function result

Returns your parameter Preferences.

Description

Gets a copy of the Intuition default preferences data. Writes the data into the buffer you specify. The number of bytes you want copied is specified by the size argument.

The default preferences are those that Intuition uses when it is first opened. If no preferences file is found, these are the preferences that are used. These would also be the startup preferences in an AmigaDOS-less environment.

It is legal to take a partial copy of the Preferences structure. The more pertinent preferences variables have been grouped near the top of the structure to facilitate the memory conservation that can be had by taking a copy of only some of the Preferences structure.

See also

GetPrefs | Get the current Intuition Preferences structure.
SetPrefs | Set Intuition preferences data.


GetDrawInfoAttr

Declaration

Source position: intuition.pas line 3605

function GetDrawInfoAttr(

  Drawinfo: PDrawInfo;

  Attr: LongWord;

  var ErrorPtr: LongWord

):LongWord;


GetMonitorList

Declaration

Source position: intuition.pas line 3609

function GetMonitorList(

  Tags: PTagItem

):PPObject_;


GetPrefs

Get the current Intuition Preferences structure.

Declaration

Source position: intuition.pas line 3472

function GetPrefs(

  Preferences: PPreferences;

  Size: LongInt

):PPreferences;

Arguments

Preferences | A pointer to the memory buffer to receive your copy of the Intuition Preferences
Size | The number of bytes in your PrefBuffer, the number of bytes you want copied from the system's internal Preference settings

Function result

Returns your parameter Preferences.

Description

Gets a copy of the current Intuition Preferences structure. Writes the data into the buffer you specify. The number of bytes you want copied is specified by the size argument.

It is legal to take a partial copy of the Preferences structure. The more pertinent preferences variables have been grouped near the top of the structure to facilitate the memory conservation that can be had by taking a copy of only some of the Preferences structure.

A new and more extensible method for supplying Preferences has been introduced in V36, and relies on file system notification. The Intuition preferences items rely also on the IPrefs program. Certain elements of the Preferences structure have been superseded by this new method. As much as possible, the Preferences structure returned by GetPrefs() reflect the current state of Preferences. However, it is impossible to represent some of the V36-style preferences items using the existing Preferences structure.

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
SetPrefs | Set Intuition preferences data.


GetScreenData

Get copy of a screen data structure.

Declaration

Source position: intuition.pas line 3528

function GetScreenData(

  Buffer: Pointer;

  Size: LongWord;

  Type1: LongWord;

  Screen: PScreen

):LongInt;

Arguments

Buffer | A pointer to a buffer into which data can be copied
Size | The size of the buffer provided, in bytes
Screen | Ignored, unless type is CUSTOMSCREEN_f, which results only in copying 'size' bytes from 'screen' to 'buffer'

Function result

True if successful. False if standard screen of Type 'type' could not be opened.

Description

This function copies into the caller's buffer data from a Screen structure. Typically, this call will be used to find the size, title bar height, and other values for a standard screen, such as the Workbench screen.

To get the data for the Workbench screen, one would call:

GetScreenData(buff, SizeOf(TScreen), WBENCHSCREEN_f, nil);

Note: If the requested standard screen is not open, this function will have the effect of opening it.

This function has been useful for two basic types of things:

  1. Determining information about the Workbench screen, in preparation for opening a window on it.
  2. Attempts at discerning the user's preferences in a working screen, for "cloning" the Workbench modes and dimensions when opening a similar custom screen.

The function LockPubScreen() is an improvement over this function, in that it doesn't copy the screen data but returns a pointer and a guarantee that the screen will not be closed.

If the global public screen SHANGHAI mode is in effect (see SetPubScreenModes()), this function will actually report on the default public screen, where "Workbench" windows will actually open.

This function does some "compatibility tricks" when you inquire about the WBENCHSCREEN_f. To keep programs from "stumbling" into modes they don't understand, and because an NTSC machine may be running a PAL Workbench or PRODUCTIVITY, for example, the following "false" information is returned.

The Screen.ViewPort.Modes field will either be HIRES or HIRES+LACE (with the SPRITES flag also set, as usual). HIRES+LACE is used if the display mode selected for the Workbench screen is an interlaced screen of any type.

The dimensions returned will be the smaller of the OSCAN_TEXT dimensions for the returned mode, and the actual dimensions of the Workbench screen.

Exception: For specific compatibility considerations, if the Workbench is in one of the A2024 modes, the mode returned in Screen.ViewPort.Modes will be HIRES+LACE (with perhaps some "special" bits also set for future improvement), but with dimensions equal to the actual A2024-mode Workbench screen. This will favor programs which open windows on the A2024 Workbench, but will cause some problems for programs which try to "clone" the Workbench screen using this function.

If you want the real information about the modern Workbench screen, call LockPubScreen('Workbench') and acquire its display mode ID by inquiring of the actual ViewPort (using GetVPModeID()).

You may then use the information you get to clone as many of the properties of the Workbench screen that you wish.

In the long run, it's probably better to provide your user with a screen mode selection option, and skip all this.

See also

OpenWindow | Open an Intuition window.
LockPubScreen | Prevent a public screen from closing.
GetVPModeID | Get the 32 bit DisplayID from a ViewPort.
SetPubScreenModes | Establish global public screen behavior.
OpenScreen | Open an Intuition screen


GetScreenDrawInfo

Get pointer to rendering information.

Declaration

Source position: intuition.pas line 3581

function GetScreenDrawInfo(

  Screen: PScreen

):PDrawInfo;

Arguments

Screen

A pointer to a valid, open screen.

Function result

A pointer to a system-allocated DrawInfo structure.

Description

Returns a pointer to a TDrawInfo structure derived from the screen passed. This data structure is Read Only. The field dri_Version identifies which version of TDrawInfo you are given a pointer to.

Note:

Some information in the TDrawInfo structure may in the future be calculated the first time this function is called for a particular screen.

You must call FreeScreenDrawInfo() when you are done using the returned pointer.

This function does not prevent a screen from closing. Apply it only to the screens you opened yourself, or apply a protocol such as LockPubScreen().

WARNING: Until further notice, the pointer returned does not remain valid after the screen is closed.

This function and FreeScreenDrawInfo() don't really do much now, but they provide an upward compatibility path. That means that if you misuse them today, they probably won't cause a problem, although they may someday later. So, please be very careful only to use the TDrawInfo structure between calls to GetScreenDrawInfo() and FreeScreenDrawInfo(), and be sure that you don't forget FreeScreenDrawInfo().

See also

LockPubScreen | Prevent a public screen from closing.
FreeScreenDrawInfo | Finish using a DrawInfo structure.


GetSkinInfoAttr

Declaration

Source position: intuition.pas line 3642

function GetSkinInfoAttr(

  Drawinfo: PDrawInfo;

  Attr: LongWord;

  const Taglist: array of PtrUInt

):LongWord;


GetSkinInfoAttrA

Declaration

Source position: intuition.pas line 3604

function GetSkinInfoAttrA(

  Drawinfo: PDrawInfo;

  Attr: LongWord;

  Taglist: PTagItem

):LongWord;


HelpControl

Enable/disable Gadget-Help feature.

Declaration

Source position: intuition.pas line 3598

procedure HelpControl(

  Win: PWindow;

  Flags: LongWord

);

Arguments

Flags

Currently, HC_GADGETHELP or zero are the allowed values.

Description

This function can be used to turn Gadget-Help on or off for your window. Gadget-Help will also be enabled/disabled accordingly for all other windows which share the same help-group. This allows Gadget-Help to be well-behaved for multiple-window applications.

You must use GetUniqueID() to get a help-group identifier. Never ever supply your own!

See also

WA_HelpGroup | Tag for OpenWindowTagList(). Form Help groups
OpenWindowTagList | OpenWindow() with TagItem extension.


HideWindow

Declaration

Source position: intuition.pas line 3602

procedure HideWindow(

  win: PWindow

);


IM_BGPEN

Set Image Background Pen

Declaration

Source position: intuition.pas line 3624

function IM_BGPEN(

  Im: PImage

):Byte;


IM_BOX

Get Image bounding rectangle

Declaration

Source position: intuition.pas line 3625

function IM_BOX(

  Im: PImage

):PIBox;


IM_FGPEN

Set Image Foreground pen

Declaration

Source position: intuition.pas line 3626

function IM_FGPEN(

  Im: PImage

):Byte;


InitIntuitionLibrary

Declaration

Source position: intuition.pas line 3646

function InitIntuitionLibrary: Boolean;


InitRequester

Initialize a Requester structure.

Declaration

Source position: intuition.pas line 3473

procedure InitRequester(

  Requester: PRequester

);

Arguments

Requester

A pointer to a Requester structure

Description

Initializes a requester for general use. After calling InitRequester, you need fill in only those Requester values that fit your needs. The other values are set to nil--or zero--states.

Note that the example in the early versions of the Intuition Reference Manual is flawed because the Requester structure is initialized before InitRequester is called. Be sure to perform your initialization after calling InitRequester.

Errors

This function is obsolete.


INST_DATA

Finds Object local instance data

Declaration

Source position: intuition.pas line 3614

function INST_DATA(

  Cl: PIClass;

  O: P_Object

):Pointer;

Arguments

Cl | A pointer to a class
O | A pointer to the object

Function result

a pointer to the instance data local to Cl


IntuiTextLength

Return the length (pixel-width) of an IntuiText.

Declaration

Source position: intuition.pas line 3508

function IntuiTextLength(

  IText: PIntuiText

):LongInt;

Arguments

IText

A pointer to an instance of an IntuiText structure

Function result

The width of the text in pixels.

Description

This routine accepts a pointer to an instance of an IntuiText structure, and returns the length (the pixel-width) of the string which that instance of the structure represents.

Note: if the Font pointer of your IntuiText structure is set to nil, you'll get the pixel-width of your text in terms of the current system default font. You may wish to be sure that the field IText^.ITextFont for 'default font' text is equal to the Font field of the screen it is being measured for.

See also

OpenScreen

Open an Intuition screen


Intuition

Declaration

Source position: intuition.pas line 3456

procedure Intuition(

  IEvent: PInputEvent

);


Intuitionbase

Library Base for intuition.library

Declaration

Source position: intuition.pas line 3453

var Intuitionbase: PIntuitionBase = Nil;


INTUITIONNAME

Declaration

Source position: intuition.pas line 3450

const INTUITIONNAME: PChar = 'intuition.library';


ItemAddress

Returns the address of the specified MenuItem.

Declaration

Source position: intuition.pas line 3474

function ItemAddress(

  MenuStrip: PMenu;

  MenuNumber: LongWord

):PMenuItem;

Arguments

MenuStrip | A pointer to the first menu in your menu strip
MenuNumber | The value which contains the packed data that selects the menu and item (and sub-item). See the Intuition Reference Manual for information on menu numbers.

Function result

If MenuNumber = MENUNULL, this routine returns nil, else this routine returns the address of the menu item specified by MenuNumber.

Description

This routine feels through the specified menu strip and returns the address of the item specified by the menu number. Typically, you will use this routine to get the address of a menu item from a menu number sent to you by Intuition after user has chosen from a window's menus.

This routine requires that the arguments are well-defined. MenuNumber may be equal to MENUNULL, in which case this routine returns nil. If MenuNumber doesn't equal MENUNULL, it's presumed to be a valid item number selector for your menu strip, which includes:

  • a valid menu number
  • a valid item number
  • if the item specified by the above two components has a sub-item, the menu number may have a sub-item component, too.

Note that there must be both a menu number and an item number. Because a sub-item specifier is optional, the address returned by this routine may point to either an item or a sub-item.


ITEMNUM

Menu helper macro

Declaration

Source position: intuition.pas line 3629

function ITEMNUM(

  N: Word

):Word;


LendMenus

Lend window's menu action to another window.

Declaration

Source position: intuition.pas line 3594

procedure LendMenus(

  Fromwindow: PWindow;

  ToWindow: PWindow

);

Arguments

Fromwindow | A pointer to the Window structure whose menu actions are to go to another window.
ToWindow | A pointer to the Window structure whose menus are to be displayed in place of the fromWindow's. If nil, turns off menu-lending from the fromWindow.

Description

This function is used to "lend" the menus of one window to another. This means that menu events (for example, the user presses the mouse menu button) will take place in another window's menu (using that other window's menu strip and screen).

The sole intended use of this function is to unify two windows on different screens that are attached. (See SA_Parent, SA_FrontChild, SA_BackChild). An example would be a program with a full-sized parent screen which has a short control panel screen attached in the front. Pressing the menu button even when the control panel window of the canvas screen is active can now cause the menus of the parent screen to appear.

See also

SetMenuStrip | Attach a menu strip to a window.
ClearMenuStrip | Clear (detach) the menu strip from the window.


LockIBase

Invoke semaphore arbitration of TIntuitionBase.

Declaration

Source position: intuition.pas line 3525

function LockIBase(

  DontKnow: LongWord

):LongWord;

Function result

The result of this function must be passed to UnlockIBase().

Description

Grabs Intuition internal semaphore so that caller may examine TIntuitionBase safely. This function is not a magic "fix all my race conditions" panacea.

The idea here is that you can get the locks Intuition needs before such IntuitionBase fields as ActiveWindow and FirstScreen are changed, or linked lists of windows and screens are changed.

Do Not Get Tricky with this entry point, and do not hold these locks for long, as all Intuition input processing will wait for you to surrender the lock by a call to UnlockIBase().

Note Well: A call to this function must be paired with a subsequent call to UnlockIBase(), and soon, please.

Note Well: Do not call any Intuition functions (nor any graphics, layers, dos, or other high-level system function) while holding this lock.

See also

UnlockIBase

Release a an Intuition lock gotten by LockIBase().


LockPubScreen

Prevent a public screen from closing.

Declaration

Source position: intuition.pas line 3544

function LockPubScreen(

  Name: PChar

):PScreen;

Arguments

Name

Name string for public screen or NULL for default public screen. The string 'Workbench' indicates the Workbench screen.

Function result

Returns pointer to a screen, if successful, else nil. The call can fail for reasons including that the named public screen doesn't exist or is in private state.

Description

Prevents a public screen (or the Workbench) from closing while you examine it in preparation of opening a visitor window.

The sequence you use to open a visitor window that needs to examine fields in the screen it is about to open on is:

LockPubScreen();
  // ... examine fields ...
  OpenWindow(); //on public screen
  UnlockPubScreen();
  // ... use your window ...
  // CloseWindow();

You needn't hold the "pubscreen lock" for the duration that your window is opened. LockPubScreen() basically has the same effect as an open visitor window: it prevents the screen from being closed.

If you pass the string 'Workbench' or you pass nil and there is no default public screen, the Workbench screen will be automatically opened if it is not already present.

See also

OpenWindow | Open an Intuition window.
UnlockPubScreen | Release lock on a public screen.
GetScreenData | Get copy of a screen data structure.


LockPubScreenList

Prevent changes to the system list.

Declaration

Source position: intuition.pas line 3546

function LockPubScreenList: PList;

Function result

A pointer to the public screen list.

Description

Arbitrates access to public screen list while you quickly make a copy of it for display to the user.

Note that this is intended only for the Public Screen Manager program.

Note:

The nodes on the list are PubScreenNode structures. Act quickly while holding this lock. The restrictions on LockIBase() apply here as well.

See also

UnlockPubScreenList | Release public screen list semaphore.
OpenScreen | Open an Intuition screen


MakeClass

Create and initialize a boopsi class.

Declaration

Source position: intuition.pas line 3578

function MakeClass(

  ClassID: PChar;

  SuperClassID: PChar;

  SuperClassPtr: PIClass;

  InstanceSize: LongWord;

  Flags: LongWord

):PIClass;

Arguments

ClassID | Nil for private classes, the name/ID string for public classes
SuperClassID | Name/ID of your new class's superclass. Nil if superclass is a private class
SuperClassPtr | A pointer to private superclass. Only used if SuperClassID is nil. You are required never to provide a nil superclass.
InstanceSize | The size of the instance data that your class's objects will require, beyond that data defined for your superclass's objects.
Flags | For future enhancement, including possible additional parameters. Provide zero for now.

Function result

A pointer to the resulting class, or nil if not possible: no memory for class data structure, public superclass not found, public class of same name/ID as this one already exists

Description

For class implementors only.

This function creates a new public or private boopsi class. The superclass should be defined to be another boopsi class: all classes are descendants of the class "rootclass".

Superclasses can be public or private. You provide a name/ID for your class if it is to be a public class (but you must have registered your class name and your attribute ID's with Commodore before you do this!). For a public class, you would also call AddClass() to make it available after you have finished your initialization.

Returns pointer to an TIClass data structure for your class. You then initialize the Hook cl_Dispatcher for your class methods code. You can also set up special data shared by all objects in your class, and point cl_UserData at it. The last step for public classes is to call AddClass().

You dispose of a class created by this function by calling FreeClass().

No copy is made of classID. So make sure the lifetime of the contents of classID is at least the same as the lifetime of the class itself.

See also

FreeClass | Frees a boopsi class created by MakeClass().
AddClass | Make a public class available
RemoveClass | Make a public boopsi class unavailable.
NewObject | Varargs version of NewObjectA()


MakeScreen

Do an Intuition-integrated MakeVPort() of a screen.

Declaration

Source position: intuition.pas line 3518

function MakeScreen(

  Screen: PScreen

):LongInt;

Arguments

Screen

Address of the custom screen structure

Function result

Returns zero for success, non-zero for failure. Probable cause of failure is failure of MakeVPort().

Description

This procedure allows you to do a MakeVPort() for the viewport of your custom screen in an Intuition-integrated way. This way you can do your own screen manipulations without worrying about interference with Intuition's usage of the same viewport.

The operation of this function is as follows:

  • Block until the Intuition View structure is not in being changed.
  • Set the view modes correctly to reflect if there is a (visible) interlaced screen.
  • call MakeVPort(), passing the Intuition View and your screen's ViewPort.
  • Unlocks the Intuition View.

After calling this routine, you should call RethinkDisplay() to incorporate the new viewport of your custom screen into the Intuition display.

Note: Intuition may determine that because of a change in global interlace needs that all viewports need to be remade, so it may effectively call RemakeDisplay().

See also

RemakeDisplay |
RethinkDisplay | Grand manipulation of the entire Intuition display.
MakeVPort | Generate display copper list for a viewport.


MENUNUM

Menu helper macro

Declaration

Source position: intuition.pas line 3630

function MENUNUM(

  N: Word

):Word;


ModifyIDCMP

Modify the state of a window's IDCMPFlags.

Declaration

Source position: intuition.pas line 3475

function ModifyIDCMP(

  Window: PWindow;

  Flags: LongWord

):LongBool;

Arguments

Window | A pointer to the Window structure containing the IDCMP ports
Flags | The flag bits describing the new desired state of the IDCMP. (IDCMP_*)

Function result

This function returns False if it was unable to create the necessary message ports.

Description

This routine modifies the state of your window's IDCMP (Intuition Direct Communication Message Port). The state is modified to reflect your desires as described by the flag bits in the value IDCMPFlags.

The four actions that might be taken are:

  • if there is currently no IDCMP in the given window, and IDCMPFlags is zero, nothing happens
  • if there is currently no IDCMP in the given window, and any of the IDCMPFlags is selected (set), then the IDCMP of the window is created, including allocating and initializing the message ports and allocating a signal bit for your port.
  • if the IDCMP for the given window exists, and the IDCMPFlags argument is zero, this says that you want Intuition to close the ports, free the buffers and free your signal bit. You MUST be the same task that was active when this signal bit was allocated (either by ModifyIDCMP() or OpenWindow()).
  • if the IDCMP for the given window is opened, and the IDCMPFlags argument is not zero, this means that you want to change the state of which events will be broadcast to you through the IDCMP

Note: You can set up the Window^.UserPort to any port of your own before you call ModifyIDCMP(). If IDCMPFlags is non-null but your UserPort is already initialized, Intuition will assume that it's a valid port with task and signal data preset and Intuition won't disturb your set-up at all, Intuition will just allocate the Intuition message port half of it. The converse is true as well: if UserPort is nil when you call here with IDCMPFlags = 0, Intuition will deallocate only the Intuition side of the port.

This allows you to use a port that you already have allocated:

  • OpenWindow() with IDCMPFlags equal to 0 (open no ports)
  • set the UserPort variable of your window to any valid port of your own choosing
  • call ModifyIDCMP() with IDCMPFlags set to what you want
  • then, to clean up later, set UserPort equal to nil before calling CloseWindow() (leave IDCMPFlags alone) But first: you must make sure that no messages sent your window are queued at the port, since they will be returned to the memory free pool.

For an example of how to close a window with a shared IDCMP, see the description for CloseWindow().

See also

OpenWindow | Open an Intuition window.
CloseWindow | Close an Intuition window.


ModifyProp

Modify the current parameters of a proportional gadget.

Declaration

Source position: intuition.pas line 3476

procedure ModifyProp(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  Flags: LongWord;

  HorizPot: LongWord;

  VertPot: LongWord;

  HorizBody: LongWord;

  VertBody: LongWord

);

Arguments

Gadget | A pointer to a proportional gadget
Window | A pointer to the window containing the gadget or the window containing the requester containing the gadget.
Requester | A pointer to a requester (may be nil if this isn't a requester gadget)
Flags | Value to be stored in the Flags field of the TPropInfo
HorizPot | Value to be stored in the HorizPot field of the TPropInfo
VertPot | Value to be stored in the VertPot field of the TPropInfo
HorizBody | Value to be stored in the HorizBody field of the TPropInfo
VertBody | Value to be stored in the VertBody field of the TPropInfo

Description

Modifies the parameters of the specified proportional gadget. The gadget's internal state is then recalculated and the imagery is redisplayed in the window or requester that contains the gadget.

The requester variable can point to a requester structure. If the gadget has the GTYP_REQGADGET flag set, the gadget is in a requester and the window pointer must point to the window of the requester. If this is not the gadget of a requester, the requester argument may be nil.

Note: this function causes all gadgets from the proportional gadget to the end of the gadget list to be refreshed, for reasons of compatibility. For more refined display updating, use NewModifyProp().

ModifyProp() refreshing consists of redrawing gadgets completely. NewModifyProp() has changed this behavior.

See also

NewModifyProp

ModifyProp(), but with selective refresh.


MoveScreen

Attempt to move the screen by the increments provided.

Declaration

Source position: intuition.pas line 3477

procedure MoveScreen(

  Screen: PScreen;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Screen | A pointer to a Screen structure
Dx | Amount to move the screen on the x-axis
Dy | Amount to move the screen on the y-axis

Description

Moves the screen the specified increment, specified in screen pixel resolution coordinates.

Screen movement limits have been greatly relaxed, to support screen scrolling. In particular, negative values for screen LeftEdge and TopEdge may now be valid.

If the dX and dY variables you specify would move the screen in a way that violates any restrictions, the screen will be moved as far as possible. You may examine the LeftEdge and TopEdge fields of the Screen structure after this function returns to see where the screen really ended up.

See also

ScreenPosition | Move screens with greater control.
RethinkDisplay | Grand manipulation of the entire Intuition display.


MoveWindow

Ask Intuition to move a window.

Declaration

Source position: intuition.pas line 3478

procedure MoveWindow(

  Window: PWindow;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Window | A pointer to the structure of the Window to be moved
Dx | How far to move the Window on the x-axis
Dy | How far to move the Window on the y-axis

Description

This routine sends a request to Intuition asking to move the window the specified distance. The delta (dX, dY) arguments describe how far to move the window along the respective axes.

Note that the window will not be moved immediately, but rather will be moved the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second.

Interactions with other arbitration of Intuition data structures may defer this operation longer. You can use the IDCMP class IDCMP_CHANGEWINDOW to detect when this operation has completed.

Intuition now will do validity checking on the final position. To send absolute movements, or to move and size a window in one step, use ChangeWindowBox().

See also

ChangeWindowBox | Change window position and dimensions.
SizeWindow | Ask Intuition to size a window.
WindowToFront | Ask Intuition to bring a window to the front.
WindowToBack | Ask Intuition to send a window behind others.


MoveWindowInFrontOf

Arrange the relative depth of a window.

Declaration

Source position: intuition.pas line 3538

procedure MoveWindowInFrontOf(

  Window: PWindow;

  BehindWindow: PWindow

);

Arguments

Window | Window to re-position in front of another window
BehindWindow | Window to re-position in front of

Description

Depth-arranges a window in front of an another window. Brings out the MoveLayerInFrontOf() to the Intuition user.

See also

WindowToFront | Ask Intuition to bring a window to the front.
WindowToBack | Ask Intuition to send a window behind others.
MoveLayerInFrontOf | Put layer in front of another layer.


NewModifyProp

ModifyProp(), but with selective refresh.

Declaration

Source position: intuition.pas line 3535

procedure NewModifyProp(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  Flags: LongWord;

  HorizPot: LongWord;

  VertPot: LongWord;

  HorizBody: LongWord;

  VertBody: LongWord;

  NumGad: LongInt

);

Arguments

Gadget | A pointer to a proportional gadget
Window | A pointer to the window containing the gadget or the window containing the requester containing the gadget.
Requester | A pointer to a requester (may be nil if this isn't a requester gadget)
Flags | Value to be stored in the Flags field of the TPropInfo
HorizPot | Value to be stored in the HorizPot field of the
VertPot | Value to be stored in the VertPot field of the
HorizBody | Value to be stored in the HorizBody field of the
VertBody | Value to be stored in the VertBody field of the
NumGad | Number of gadgets to be refreshed after propgadget internals have been adjusted. -1 means "to end of list."

Description

Performs the function of ModifyProp(), but refreshes gadgets in the list as specified by the NumGad parameter. With NumGad = -1, this function is identical to ModifyProp().

When NumGad = 1, this function will now perform an incremental update of the proportional gadget knob image, rather than refreshing the entire gadget. This means much less flashing when programmatically scrolling a proportional gadget.

See also

ModifyProp

Modify the current parameters of a proportional gadget.


NewObject

Varargs version of NewObjectA()

Declaration

Source position: intuition.pas line 3637

function NewObject(

  ClassPtr: PIClass;

  ClassID: PChar;

  const Tags: array of PtrUInt

):Pointer;


NewObjectA

Create an object from a class.

Declaration

Source position: intuition.pas line 3567

function NewObjectA(

  ClassPtr: PIClass;

  ClassID: PChar;

  TagList: PTagItem

):Pointer;

Arguments

ClassPtr | An abstract pointer to a boopsi class gotten via MakeClass().
ClassID | The name/ID string of a public class. This parameter is only used if class is nil.
TagList | A pointer to array of TTagItems containing attribute/value pairs to be applied to the object being created

Function result

A boopsi object, which may be used in different contexts such as a gadget or image, and may be manipulated by generic functions. You eventually free the object using DisposeObject().

Description

This is the general method of creating objects from 'boopsi' classes. ('Boopsi' stands for "basic object-oriented programming system for Intuition".)

You specify a class either as a pointer (for a private class) or by its ID string (for public classes). If the class pointer is nil, then the classID is used.

You further specify initial "create-time" attributes for the object via a TagItem list, and they are applied to the resulting generic data object that is returned. The attributes, their meanings, attributes applied only at create-time, and required attributes are all defined and documented on a class-by-class basis.

This functions send OM_NEW to the dispatcher of the class.

See also

NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
SetAttrs | Varargs Version of SetAttrsA()
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


NextObject

Iterate through the object on an Exec list.

Declaration

Source position: intuition.pas line 3577

function NextObject(

  ObjectPtrPtr: Pointer

):Pointer;

Arguments

ObjectPtrPtr

The pointer to a variable. This must be the same variable, as long as you iterate though the same list. This variable must initially be filled with the lh_Head of a list.

Function result

Returns pointers to each object in the list in turn, and nil when there are no more.

Description

Use this function to iterate through a list of BOOPSI objects. You may do whatever you want with the object returned, even remove it from the list or dispose it, and then continue to iterate through the list.

When you collect a set of boopsi objects on an Exec List structure by invoking their OM_ADDMEMBER method, you can (only) retrieve them by iterations of this function.

See also

DisposeObject | Deletes a 'boopsi' object.
SetAttrs | Varargs Version of SetAttrsA()
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


NextPubScreen

Identify next public screen in the cycle.

Declaration

Source position: intuition.pas line 3548

function NextPubScreen(

  Screen: PScreen;

  NameBuf: PChar

):PChar;

Arguments

Screen | A pointer to the public screen your window is open in or nil if you don't have a pointer to a public screen.
NameBuf | A pointer to a buffer with (at least) MAXPUBSCREENNAME + 1 characters to put the name of the next public screen in.

Function result

Returns namebuff or nil if there are no public screens.

Description

Returns name of next public screen in system rotation, to allow visitor windows to provide function to "jump" among public-screens in a cycle.

Notes:

There is no guarantee that the public screen whose name was returned by this function will exist or be in "public" state by the time you call LockPubScreen(), etc. You must handle cases where LockPubScreen(), etc. will fail.

Note that this function may return the name of a public screen which is open but in "private mode" (see PubScreenStatus() and PSNF_PRIVATE).

The cycle order is undefined, so draw no conclusions based on it!

See also

OpenScreen | Open an Intuition screen
PubScreenStatus | Change status flags for a public screen.


ObtainGIRPort

Set up a RastPort for a custom gadget.

Declaration

Source position: intuition.pas line 3553

function ObtainGIRPort(

  GInfo: PGadgetInfo

):PRastPort;

Arguments

GInfo

A pointer to a GadgetInfo structure, as passed to each custom gadget hook function.

Function result

A pointer to a RastPort that may be used for gadget rendering. This pointer may be nil, in which case you should do no rendering. You may (optionally) pass a nil return value to ReleReleaseGIRPort().

Description

Sets up a RastPort for use (only) by custom gadget hook routines. This function must be called each time a hook routine needing to perform gadget rendering is called, and must be accompanied by a corresponding call to ReleaseGIRPort().

Note that if a hook function passes you a RastPort pointer, e.g., GM_RENDER, you needn't call ObtainGIRPort() in that case.

See also

ReleaseGIRPort

Release a custom gadget RastPort.


OCLASS

Get class pointer from an object handle

Declaration

Source position: intuition.pas line 3619

function OCLASS(

  O: Pointer

):PIClass;


OffGadget

Disable the specified gadget.

Declaration

Source position: intuition.pas line 3479

procedure OffGadget(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester

);

Arguments

Gadget | A pointer to the gadget that you want disabled
Window | A pointer to a window structure containing the gadget or containing the requester which contains the gadget
Requester | A pointer to a requester (may by nil if this isn't a requester gadget (i.e. GTYP_REQGADGET is not set)).

Description

This command disables the specified gadget. When a gadget is disabled, these things happen:

  • its imagery is displayed ghosted
  • the GFLG_DISABLED flag is set
  • the gadget cannot be selected by User

The window parameter must point to the window which contains the gadget, or which contains the requester that contains the gadget. The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

Note:it's never safe to tinker with the gadget list yourself. Don't supply some gadget that Intuition hasn't already processed in the usual way.

Note: This function will update the gadget (unlike the original function which would update all gadgets in the window).

See also

OnGadget | Enable the specified gadget.
AddGadget | Add a gadget to the gadget list of a window.
RefreshGadgets | Refresh (redraw) the gadget display.


OffMenu

Disable the given menu or menu item.

Declaration

Source position: intuition.pas line 3480

procedure OffMenu(

  Window: PWindow;

  MenuNumber: LongWord

);

Arguments

Window | A pointer to the window
MenuNumber | The menu piece to be disabled

Description

This command disables a sub-item, an item, or a whole menu. This depends on the contents of the data packed into MenuNumber, which is described in the Intuition Reference Manual.

See also

OnMenu | Enable the given menu or menu item.
ResetMenuStrip | Re-attach a menu strip to a window.


OnGadget

Enable the specified gadget.

Declaration

Source position: intuition.pas line 3481

procedure OnGadget(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester

);

Arguments

Gadget | A pointer to the gadget that you want disabled
Window | A pointer to a window structure containing the gadget or containing the requester which contains the gadget
Requester | A pointer to a requester (may by nil if this isn't a requester gadget (i.e. GTYP_REQGADGET is not set)).

Description

This command enables the specified gadget. When a gadget is enabled, these things happen:

  • its imagery is displayed normally (not ghosted)
  • the GFLG_DISABLED flag is cleared
  • the gadget can thereafter be selected by the user

The window parameter must point to the window which contains the gadget, or which contains the requester that contains the gadget The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

Note: it's never safe to tinker with the gadget list yourself. Don't supply some gadget that Intuition hasn't already processed in the usual way.

Note: This function will update the gadget (unlike the original function which would update all gadgets in the window).

See also

OffGadget

Disable the specified gadget.


OnMenu

Enable the given menu or menu item.

Declaration

Source position: intuition.pas line 3482

procedure OnMenu(

  Window: PWindow;

  MenuNumber: LongWord

);

Arguments

Window | A pointer to the window
MenuNumber | The menu piece to be enables

Description

This command enables a sub-item, an item, or a whole menu. This depends on the contents of the data packed into MenuNumber, which is described in the Intuition Reference Manual.

See also

OffMenu | Disable the given menu or menu item.
ResetMenuStrip | Re-attach a menu strip to a window.


OpenIntuition

Declaration

Source position: intuition.pas line 3455

procedure OpenIntuition;


OpenScreen

Open an Intuition screen

Declaration

Source position: intuition.pas line 3483

function OpenScreen(

  NewScreen: PNewScreen

):PScreen;

Arguments

NewScreen

A pointer to an instance of a NewScreen structure.

Function result

If all is well, returns the pointer to your new screen If anything goes wrong, returns nil, with further error specification in the variable pointed to by the SA_ErrorCode data field.

Description

Opens an Intuition screen according to the specified parameters found in the TNewScreen structure.

Does all the allocations, sets up the screen structure and all substructures completely, and links this screen's viewport into Intuition's View structure.

Before you call OpenScreen(), you must initialize an instance of a NewScreen structure. TNewScreen is a structure that contains all of the arguments needed to open a screen. The TNewScreen structure may be discarded immediately after OpenScreen() returns.

The SHOWTITLE flag is set to True by default when a screen is opened. To change this, you must call the routine ShowTitle().

See also

OpenScreenTagList | OpenScreen() with TagItem extension array.
OpenWindow | Open an Intuition window.
PrintIText | Print text described by the IntuiText argument.
CloseScreen | Close an Intuition screen.
QueryOverscan | Inquire about a standard overscan region.
PubScreenStatus | Change status flags for a public screen.
ModeNotAvailable | Check to see if a DisplayID isn't available.
OpenDiskFont |
GetColorMap | Allocate and initialize Colormap


OpenScreenTagList

OpenScreen() with TagItem extension array.

Declaration

Source position: intuition.pas line 3561

function OpenScreenTagList(

  NewScreen: PNewScreen;

  TagList: PTagItem

):PScreen;

Arguments

NewScreen | An optional pointer to a NewScreen structure.
TagList | An optional pointer to (an array of) TagItem structures, terminated by the value TAG_END.

Function result

An open Intuition screen. Check ErrorCode when Screen is returned nil.

Description

Provides an extension to the parameters passed to OpenScreen(). This extensions is in the form of (a pointer to) an array of TagItem structures, which have to fields: ti_Tag, an ID identifying the meaning of the other field, ti_Data.

The tag items can supplement or override the values in NewScreen. In fact, you can pass a nil value of the TNewScreen pointer. For that matter, if you pass nil in both arguments, you'll get a screen with defaults in all fields, including display mode, depth, colors, dimension, title, and so on. We ask that you at least supply a title when you open a screen.

If you need a pointer to the screen's bitmap use Screen^.RastPort.BitMap instead of @(Screen^.BitMap).

If you want DOS requester to appear on your screen you have to do:

process := PProcess(FindTask(nil));
process^.pr_WindowPtr := APTR(window);

The old value of pr_WindowPtr must be reset before you quit your program.

See also

OpenScreen

Open an Intuition screen


OpenScreenTags

Varargs Version of OpenScreenTagList()

Declaration

Source position: intuition.pas line 3636

function OpenScreenTags(

  NewScreen: PNewScreen;

  const TagList: array of PtrUInt

):PScreen;


OpenWindow

Open an Intuition window.

Declaration

Source position: intuition.pas line 3484

function OpenWindow(

  NewWindow: PNewWindow

):PWindow;

Arguments

NewWindow

A pointer to an instance of a NewWindow structure.

Function result

A pointer to the new window or nil if it couldn't be opened. Reasons for this might be lack of memory or illegal attributes.

Description

Opens an Intuition window of the given dimensions and position, with the properties specified in the NewWindow structure. Allocates everything you need to get going.

You can provide extensions to the NewWindow parameters using and array of TagItem structures.

Before you call OpenWindow(), you must initialize an instance of a NewWindow structure. NewWindow is a structure that contains all of the arguments needed to open a window. The NewWindow structure may be discarded immediately after it is used to open the window.

If Type = CUSTOMSCREEN_f, you must have opened your own screen already via a call to OpenScreen(). Then Intuition uses your screen argument for the pertinent information needed to get your window going. On the other hand, if Type = one of the Intuition's standard screens, your screen argument is ignored. Instead, Intuition will check to see whether or not that screen already exists: if it doesn't, it will be opened first before Intuition opens your window in the standard screen.

If you specify Type = WBENCHSCREEN_f, then your window will appear on the Workbench screen, unless the global public screen mode SHANGHAI is set, in which case your window will be "hijacked" to the default public screen. See also SetPubScreenModes().

If the WFLG_NW_EXTENDED flag is set, it means that the field TExtNewWindow.Extension points to an array of TagItems. This provides an extensible means of providing extra parameters to OpenWindow(). For compatibility reasons, we could not add the Extension field to the TNewWindow structure, so we have define a new structure TExtNewWindow, which is identical to TNewWindow with the addition of the Extension field.

We recommend that rather than using TExtNewWindow.Extension, you use the new Intuition function OpenWindowTagList() and its varargs equivalent OpenWindowTags(). We document the window attribute tag ID's (ti_Tag values) here, rather than in OpenWindowTagList(), so that you can find all the parameters for a new window defined in one place.

If the WFLG_SUPER_BITMAP flag is set, the bitmap variable must point to your own bitmap.

See also

CloseWindow | Close an Intuition window.
ModifyIDCMP | Modify the state of a window's IDCMPFlags.


OpenWindowTagList

OpenWindow() with TagItem extension.

Declaration

Source position: intuition.pas line 3560

function OpenWindowTagList(

  NewWindow: PNewWindow;

  TagList: PTagItem

):PWindow;

Arguments

NewWindow | A optional pointer to a NewWindow structure.
TagList | A optional pointer to TagItem array, with tag values as described under the description for OpenWindow().

Function result

A newly created window, per your specifications.

Description

A variation of OpenWindow() that allow direct specification of a TagItem array of extension data. Recommended over using the TExtNewWindow.Extension field.

If you omit the NewWindow (pass nil), a set of defaults are used, and overridden by the tag items. Even without any tag items at all, a reasonable window opens on the Workbench or default public screen.

See also

OpenWindow

Open an Intuition window.


OpenWindowTags

Varargs Version of OpenWindowTagList()

Declaration

Source position: intuition.pas line 3635

function OpenWindowTags(

  NewWindow: PNewWindow;

  const TagList: array of PtrUInt

):PWindow;


OpenWorkBench

Open the Workbench screen.

Declaration

Source position: intuition.pas line 3485

function OpenWorkBench: LongWord;

Function result

Non-zero if Workbench screen opened successfully, or was already opened. Zero if anything went wrong and the Workbench screen isn't out there.

Description

Tries to (re)open WorkBench screen. If successful return value is a pointer to the screen structure, which shouldn't be used, because other programs may close the WorkBench and make the pointer invalid.

If this function fails the return value is 0.

See also

CloseWorkBench

Closes the Workbench screen.


PointInImage

Tests whether an image "contains" a point.

Declaration

Source position: intuition.pas line 3564

function PointInImage(

  Point: LongWord;

  Image: PImage

):LongBool;

Arguments

Point | Two words, X/Y packed into a LongInt, with high word containing X. This is what you get if you pass a Point structure (not a pointer!).
Image | A pointer to a standard or custom Image data object. Note: If Image is nil, this function returns True.

Function result

Boolean result of the test. True is the point is inside the image, False otherwise.

Description

Tests whether a point is properly contained in an image. The intention of this is to provide custom gadgets a means to delegate "image mask" processing to the Image, where it belongs (superseding things like BOOLMASK). After all, a rounded rect image with a drop shadow knows more about what points are inside it than anybody else should.

For traditional Intuition Images, this routine checks if the point is in the Image box (LeftEdge/RightEdge/Width/Height).


PrintIText

Print text described by the IntuiText argument.

Declaration

Source position: intuition.pas line 3486

procedure PrintIText(

  Rp: PRastPort;

  IText: PIntuiText;

  Left: LongInt;

  Top: LongInt

);

Arguments

Rp | The RastPort destination of the text
IText | A pointer to an instance of the structure IntuiText
Left | Left offset of the IntuiText into the RastPort
Top | Top offset of the IntuiText into the RastPort

Description

Prints the IntuiText into the specified RastPort. Sets up the RastPort as specified by the IntuiText values, then prints the text into the RastPort at the IntuiText x/y coordinates offset by the left/top arguments. Note, though, that the IntuiText structure itself may contain further text position coordinates: those coordinates and the Left/TopOffsets are added to obtain the true position of the text to be rendered.

This routine does window layer clipping as appropriate -- if you print text outside of your window, your characters will be clipped at the window's edge, providing you pass your window's (layered) RastPort.

If the NextText field of the IntuiText argument is non-nil, the next IntuiText is rendered as well, and so on until some NextText field is nil.

IntuiText with the ITextFont field nil are displayed in the font of the RastPort. If the RastPort font is also nil, the system default font, as set via the Preferences tool, will be used.


PubScreenStatus

Change status flags for a public screen.

Declaration

Source position: intuition.pas line 3551

function PubScreenStatus(

  Screen: PScreen;

  StatusFlags: LongWord

):Word;

Arguments

Screen | A pointer to public screen
StatusFlags | Any of the PSNF_ flags (only PSNF_PRIVATE is currently defined).

Function result

Returns 0 in the lowest order bit of the return value if the screen wasn't public, or because it can not be taken private because visitors are open in it. All other bits in the return code are reserved for future enhancement.

Description

Changes status flags for a given public screen. The only flag bit currently defined is PSNF_PRIVATE. Thus, PubScreenStatus(Screen, PSNF_PRIVATE); makes a screen private, while PubScreenStatus(Screen, 0); makes it public.

Do not apply this function to a screen if your program isn't the screen's "owner", in particular, don't call this function for the Workbench screen.

See also

OpenScreen

Open an Intuition screen


QueryOverscan

Inquire about a standard overscan region.

Declaration

Source position: intuition.pas line 3537

function QueryOverscan(

  DisplayID: LongWord;

  Rect: PRectangle;

  OScanType: LongInt

):LongInt;

Arguments

DisplayID | ID to be queried
Rect | Pointer to struct Rectangle to store result
OScanType | Overscan type OSCAN_*

Function result

0 (False) if the MonitorSpec your NewScreen requests does not exist. Non-zero (True) if it does.

Description

This function fills in a rectangle with one of the system overscan dimensions, scaled appropriately for the mode of the DisplayID it is passed.

System overscan values for OScanType:

OSCAN_TEXT:
completely visible, by user preference. Used for Workbench screen and screen dimensions STDSCREENWIDTH and STDSCREENHEIGHT. Left/Top is always 0,0.
OSCAN_STANDARD:
just beyond visible bounds of monitor, by user preference. Left/Top may be negative.
OSCAN_MAX:
The largest region we can display, and display any smaller region.
OSCAN_VIDEO:
The absolute largest region that the graphics.library can display. This region must be used as-is.

See also

OpenScreen

Open an Intuition screen


RefreshGadgets

Refresh (redraw) the gadget display.

Declaration

Source position: intuition.pas line 3487

procedure RefreshGadgets(

  Gadgets: PGadget;

  Window: PWindow;

  Requester: PRequester

);

Arguments

Gadgets | A pointer to the first in the list of gadgets wanting refreshment
Window | A pointer to the window containing the gadget or its requester
Requester | A pointer to a requester (ignored if gadget is not attached to a requester).

Description

Refreshes (redraws) all of the gadgets in the gadget list starting from the specified gadget.

The window parameter must point to the window which contains the gadget, or which contains the requester that contains the gadget The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

The two main reasons why you might want to use this routine are: first, that you've modified the imagery of the gadgets in your display and you want the new imagery to be displayed; secondly, if you think that some graphic operation you just performed trashed the gadgetry of your display, this routine will refresh the imagery for you.

Note that to modify the imagery of a gadget, you must first remove that gadget from the window's gadget list, using RemoveGadget() (or RemoveGList()). After changing the image, border, text (including text for a string gadget), the gadget is replaced in the gadget list (using AddGadget() or AddGList()). Adding gadgets does not cause them to be displayed (refreshed), so this function, or RefreshGList() is typically called.

A common technique is to set or reset the GFLG_SELECTED flag of a Boolean gadget and then call RefreshGadgets() to see it displayed highlighted if and only if GFLG_SELECTED is set. If you wish to do this and be completely proper, you must RemoveGadget(), change the GFLG_SELECTED flag, AddGadget(), and RefreshGadgets(), or the equivalent.

The gadgets argument can be a copy of the FirstGadget variable in the Window structure that you want refreshed: the effect of this will be that all gadgets will be redrawn. However, you can selectively refresh just some of the gadgets by starting the refresh part-way into the list: for instance, redrawing your window non-GTYP_GZZGADGET gadgets only, which you've conveniently grouped at the end of your gadget list.

Even more control is available using the RefreshGList() routine which enables you to refresh a single gadget, or number of your choice.

Note: It's never safe to tinker with the gadget list yourself. Don't supply some gadget list that Intuition hasn't already processed in the usual way.

Snippet

//Refresh all gadgets of a window
RefreshGadgets(Win^.FirstGadget, Win, nil);

See also

RefreshGList | Refresh (redraw) a chosen number of gadgets.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.


RefreshGList

Refresh (redraw) a chosen number of gadgets.

Declaration

Source position: intuition.pas line 3529

procedure RefreshGList(

  Gadgets: PGadget;

  Window: PWindow;

  Requester: PRequester;

  NumGad: LongInt

);

Arguments

Gadgets | A pointer to the first in the list of gadgets wanting refreshment
Window | A pointer to the window containing the gadget or its requester
Requester | A pointer to a requester (ignored if Gadget is not attached to a Requester).
NumGad | Maximum number of gadgets to be refreshed. A value of -1 will cause all gadgets to be refreshed from gadget to the end of the list. A value of -2 will also do this, but if Gadgets points to a Requester Gadget (GTYP_REQGADGET) ALL gadgets in the requester will be refreshed.)

Description

Refreshes (redraws) gadgets in the gadget list starting from the specified gadget. At most NumGad gadgets are redrawn. If NumGad is -1, all gadgets until a terminating nil value in the NextGadget field is found will be refreshed, making this routine a superset of RefreshGadgets().

The Requester parameter can point to a Requester structure. If the first gadget in the list has the GTYP_REQGADGET flag set, the gadget list refers to gadgets in a requester and the pointer must necessarily point to a window. If these are not the gadgets of a requester, the requester argument may be nil.

Be sure to see the RefreshGadgets() function description, as this function is simply an extension of that.

Snippet

// Refresh one gadget
RefreshGList(@Gadget, Win, nil, 1);

// Refresh all gadgets in the window
RefreshGList(Win^.FirstGadget, Win, nil, -1);

See also

RefreshGadgets

Refresh (redraw) the gadget display.


RefreshWindowFrame

Ask Intuition to redraw your window border.

Declaration

Source position: intuition.pas line 3533

procedure RefreshWindowFrame(

  Window: PWindow

);

Arguments

Window

A pointer to a Window structure

Description

Refreshes the border of a window, including title region and all of the window's gadgets.

You may use this call if you wish to update the display of your borders. The expected use of this is to correct unavoidable corruption.


ReleaseGIRPort

Release a custom gadget RastPort.

Declaration

Source position: intuition.pas line 3554

procedure ReleaseGIRPort(

  Rp: PRastPort

);

Arguments

Rp

A pointer to the RastPort returned by ObtainGIRPort(). This pointer can be nil, in which case nothing happens.

Description

The corresponding function to ObtainGIRPort(), it releases arbitration used by Intuition for gadget RastPorts.

See also

ObtainGIRPort

Set up a RastPort for a custom gadget.


RemakeDisplay

Declaration

Source position: intuition.pas line 3519

function RemakeDisplay: LongInt;

Function result

Returns zero for success, non-zero for failure. Probable cause of failure is failure of MakeVPort() or of MrgCop().

Description

This is the big one.

This procedure remakes the entire View structure for the Intuition display. It does the equivalent of MakeScreen() for every screen in the system, and then it calls the internal equivalent of RethinkDisplay().

Warning: This routine can take many milliseconds to run, so do not use it lightly.

Calling MakeScreen() followed by RethinkDisplay() is typically a more efficient method for affecting changes to a single screen's ViewPort.

See also

RethinkDisplay | Grand manipulation of the entire Intuition display.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.
MakeVPort | Generate display copper list for a viewport.
MrgCop | Merge together coprocessor instructions.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.


RemoveClass

Make a public boopsi class unavailable.

Declaration

Source position: intuition.pas line 3585

procedure RemoveClass(

  ClassPtr: PIClass

);

Arguments

ClassPtr

A pointer to public class created by MakeClass(), may be nil.

Description

Makes a public class unavailable for public consumption. It's OK to call this function for a class which is not yet in the internal public class list, or has been already removed.

See also

MakeClass | Create and initialize a boopsi class.
FreeClass | Frees a boopsi class created by MakeClass().
AddClass | Make a public class available


RemoveGadget

Remove a gadget from a window.

Declaration

Source position: intuition.pas line 3488

function RemoveGadget(

  Window: PWindow;

  Gadget: PGadget

):Word;

Arguments

Window | A pointer to the window containing the gadget or the requester containing the gadget to be removed.
Gadget | A pointer to the gadget to be removed. The gadget itself describes whether this is a gadget that should be removed from the window or some requester.

Function result

Returns the ordinal position of the removed gadget. If the gadget wasn't found in the appropriate list, or if there are no gadgets in the list, returns $FFFF.

Description

Removes the given gadget from the gadget list of the specified window. Returns the ordinal position of the removed gadget.

If the gadget is in a requester attached the the window, this routine will look for it and remove it if it is found.

If the gadget pointer points to a gadget that isn't in the appropriate list, $FFFF is returned. If there aren't any gadgets in the list, $FFFF is returned. If you remove the 65535th gadget from the list $FFFF is returned.

Note: If one of the gadgets you wish to remove is the active gadget, this routine will wait for the user to release the mouse button before deactivating and removing the gadget.

See also

AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
RemoveGList | Remove a sublist of gadgets from a window.


RemoveGList

Remove a sublist of gadgets from a window.

Declaration

Source position: intuition.pas line 3531

function RemoveGList(

  RemPtr: PWindow;

  Gadget: PGadget;

  NumGad: LongInt

):Word;

Arguments

RemPtr | A pointer to the window containing the gadget or the requester containing the gadget to be removed.
Gadget | A pointer to the gadget to be removed. The gadget itself describes whether this is a gadget that should be removed from the window or some requester.
NumGad | Number of gadgets to be removed. If $FFFF, remove all gadgets to end of window gadget list

Function result

Returns the ordinal position of the removed gadget. If the gadget wasn't found in the appropriate list, or if there are no gadgets in the list, returns $FFFF.

Description

Removes Numgad gadgets from the gadget list of the specified window. Will remove gadgets from a requester if the first gadget's GadgetType flag GTYP_REQGADGET is set.

Otherwise identical to RemoveGadget().

Note: Last gadget's NextGadget field is set to nil.

If one of the gadgets you wish to remove is the active gadget, this routine will wait for the user to release the mouse button before deactivating and removing the gadget.

See also

RemoveGadget | Remove a gadget from a window.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.


ReportMouse

Tell Intuition whether to report mouse movement.

Declaration

Source position: intuition.pas line 3490

procedure ReportMouse(

  Flag: LongInt;

  Window: PWindow

);

Arguments

Flag | True (-1) or False (0) value specifying whether to turn this function on or off
Window | A pointer to a Window structure associated with this request

Description

Tells Intuition whether or not to broadcast mouse-movement events to your window when it's the active one. The Boolean value specifies whether to start or stop broadcasting position information of mouse-movement. If the window is the active one, mouse-movement reports start coming immediately afterwards. This same routine will change the current state of the GACT_FOLLOWMOUSE function of a currently-selected gadget too.

Note that calling ReportMouse() when a gadget is selected will only temporarily change whether or not mouse movements are reported while that gadget remains selected; the next time the gadget is selected, its GACT_FOLLOWMOUSE flag is examined anew.

The ReportMouse() function is first performed when OpenWindow() is first called; if the flag WFLG_REPORTMOUSE is included among the options, then all mouse-movement events are reported to the opening task and will continue to be reported until ReportMouse() is called with a Boolean value of FALSE. If WFLG_REPORTMOUSE is not set, then no mouse-movement reports will be broadcast until ReportMouse() is called with a Boolean of True.

Note that the WFLG_REPORTMOUSE flag, as managed by this routine, determines if mouse messages are to be broadcast. Determining how they are to be broadcast is determined by the IDCMP_MOUSEMOVE IDCMPFlag.


Request

Activate a requester.

Declaration

Source position: intuition.pas line 3491

function Request(

  Requester: PRequester;

  Window: PWindow

):LongBool;

Arguments

Requester | A pointer to the requester to be displayed.
Window | A pointer to the window into which this requester goes.

Function result

If the requester is successfully opened, True is returned. Otherwise, if the requester could not be opened, False is returned.

Description

Links in and displays a requester into the specified window. This routine ignores the window's IDCMP_REQVERIFY flag.

See also

EndRequest | Remove a currently active requester.
InitRequester | Initialize a Requester structure.


ResetMenuStrip

Re-attach a menu strip to a window.

Declaration

Source position: intuition.pas line 3584

function ResetMenuStrip(

  Window: PWindow;

  Menu: PMenu

):LongBool;

Arguments

Window | A pointer to a Window structure
Menu | A pointer to the first menu in the menu strip

Function result

True always.

Description

This function is simply a "fast" version of SetMenuStrip() that doesn't perform the precalculations of menu page sizes that SetMenuStrip() does.

You may call this function only if the menu strip and all items and sub-items have not changed since the menu strip was passed to SetMenuStrip(), with the following exceptions:

  • You may change the CHECKED flag to turn a checkmark on or off.
  • You may change the ITEMENABLED flag to enable/disable some MenuItem or Menu structures.

In all other ways, this function performs like SetMenuStrip().

The new sequence of events you can use is:

  • OpenWindow()

  • SetMenuStrip()

    zero or more iterations of:

    • ClearMenuStrip()
    • change CHECKED or ITEMENABLED flags
    • ResetMenuStrip()
  • ClearMenuStrip()
  • CloseWindow()

See also

SetMenuStrip | Attach a menu strip to a window.
ClearMenuStrip | Clear (detach) the menu strip from the window.


RethinkDisplay

Grand manipulation of the entire Intuition display.

Declaration

Source position: intuition.pas line 3520

function RethinkDisplay: LongInt;

Function result

Returns zero for success, non-zero for failure. Probable cause of failure is failure of MakeVPort() or of MrgCop().

Description

This function performs the Intuition global display reconstruction. This includes rethinking about all of the ViewPorts and their relationship to one another and reconstructing the entire display based on the results of this rethinking.

Specifically, and omitting many internal details, the operation consists of this:

  • Determine which ViewPorts are invisible and set their VP_HIDE ViewPort Mode flag. VP_HIDE flags are also set for screens that may not be simultaneously displayed with the frontmost.
  • If a change to a viewport height, or changing interlace or monitor scan rates require, MakeVPort() is called for specific screen viewports. After this phase, the intermediate Copper lists for each screen's viewport are correctly set up.
  • MrgCop() and LoadView() are then called to get these Copper lists in action, thus establishing the new state of the Intuition display.

You may perform a MakeScreen() on your Custom Screen before calling this routine. The results will be incorporated in the new display, but changing the interlace ViewPort mode for one screens must be reflected in the Intuition View, which is left to Intuition.

Warning: This routine can take several milliseconds to run, so do not use it lightly.

This routine is substantially changed to support new screen modes. In particular, if screen rearrangement has caused a change in interlace mode or scan rate, this routine will remake the copper lists for each screen's viewport.

See also

RemakeDisplay |
MakeVPort | Generate display copper list for a viewport.
MrgCop | Merge together coprocessor instructions.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.


ScreenbarControl

Declaration

Source position: intuition.pas line 3643

function ScreenbarControl(

  const Tags: array of PtrUInt

):LongWord;


ScreenbarControlA

Declaration

Source position: intuition.pas line 3611

function ScreenbarControlA(

  Tags: PTagItem

):LongWord;


ScreenDepth

Depth arrange a screen with extra control.

Declaration

Source position: intuition.pas line 3591

procedure ScreenDepth(

  Screen: PScreen;

  Flags: LongWord;

  Reserved: Pointer

);

Arguments

Screen | A pointer to the screen to move
Flags | One of SDEPTH_TOFRONT or SDEPTH_TOBACK (bringing the screen to front or back respectively).
Reserved | Must be nil for now.

Description

Brings the specified screen to the front or back, based on the supplied flags. Also allows control of screen depth-arranging within screen families.

See also

ScreenToFront | Make the specified screen the frontmost.
ScreenToBack | Send the specified screen to the back of the display.
SA_Parent | Tag start for OpenScreenTagList() Pointer to a "parent" screen to attach this one to. Attached screens slide and depth-arrange together.
SA_FrontChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the front of its family.
SA_BackChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the back of its family.


ScreenPosition

Move screens with greater control.

Declaration

Source position: intuition.pas line 3592

procedure ScreenPosition(

  Screen: PScreen;

  Flags: LongWord;

  X1: LongInt;

  Y1: LongInt;

  X2: LongInt;

  Y2: LongInt

);

Arguments

Screen | A pointer to a Screen structure
Flags | Set to one of SPOS_RELATIVE, SPOS_ABSOLUTE, or SPOS_MAKEVISIBLE. You may additionally set SPOS_FORCEDRAG if you need. Use SPOS_RELATIVE (zero) for normal use (move screen a relative amount expressed by x1,y1). Set the SPOS_ABSOLUTE flag if you wish x1 and y1 to be absolute coordinates to move the screen to. Set SPOS_MAKEVISIBLE to position an oversized scrolling screen so that the rectangle described by (x1,y1)-(x2,y2) is on the visible part of the display. (A word-processor may wish to support autoscrolling as the user types. In that case, it could call ScreenPosition() with the SPOS_MAKEVISIBLE flag and a rectangle that encompasses the cursor with some space around it. In addition to any one of the above choices, you can additionally set SPOS_FORCEDRAG if you wish to reposition a screen that was opened with the [SA_Draggable, False] attribute.
X1 | Absolute position or change in position you wish to apply to the screen, when using SPOS_ABSOLUTE or SPOS_RELATIVE.
Y1 | When using SPOS_MAKEVISIBLE, these variables describe the upper-left corner of the rectangle you would like to ensure is on the visible part of a scrolling screen.
X2 | Ignored when using SPOS_ABSOLUTE or SPOS_RELATIVE. When using SPOS_MAKEVISIBLE, these variables describe the lower-right corner of the rectangle you would like to ensure is on the visible part of a scrolling screen.
Y2 | Note that these coordinates are in the same resolution as the screen.

Description

Moves the screen to the specified position or by the specified increment, in screen pixel resolution coordinates.

If the x1 and y1 variables you specify would move the screen in a way that violates any restrictions, the screen will be moved as far as possible. You may examine the LeftEdge and TopEdge fields of the Screen structure after this function returns to see where the screen really ended up.

Note that negative values for screen LeftEdge and TopEdge are valid for screens bigger than their display clip.

See also

MoveScreen | Attempt to move the screen by the increments provided.
RethinkDisplay | Grand manipulation of the entire Intuition display.


ScreenToBack

Send the specified screen to the back of the display.

Declaration

Source position: intuition.pas line 3492

procedure ScreenToBack(

  Screen: PScreen

);

Arguments

Screen

A pointer to a Screen structure

Description

Move a screen behind all other screens. If the screen is in a group, the screen will be moved behind all other screens in the group only. If the screen is the parent of a group, the whole group will be moved in the back.

You will see the screen move behind all other screens. If some screen before this screen occupies the whole display, then it will disappear completely. If all other screens occupy only part of the display, the screen will appear behind the screens.

See also

ScreenToFront | Make the specified screen the frontmost.
ScreenDepth | Depth arrange a screen with extra control.


ScreenToFront

Make the specified screen the frontmost.

Declaration

Source position: intuition.pas line 3493

procedure ScreenToFront(

  Screen: PScreen

);

Arguments

Screen

A pointer to a Screen structure

Description

Move a screen in front of all other screens. If the screen is in a group, the screen will be moved in front of all other screens in the group only. If the screen is the parent of a group, the whole group will be moved in the front.

You will see the screen move in front of all other screens.

See also

ScreenToBack | Send the specified screen to the back of the display.
ScreenDepth | Depth arrange a screen with extra control.


ScrollWindowRaster

Scrolls the content of the rectangle

Declaration

Source position: intuition.pas line 3593

procedure ScrollWindowRaster(

  Win: PWindow;

  Dx: LongInt;

  Dy: LongInt;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Win | A pointer to a Window structure
Dx | May be postive, zero, or negative
Dy | May be postive, zero, or negative
XMin | Left of bounding rectangle
YMin | Upper of bounding rectangle
XMax | Right of bounding rectangle
YMax | Lower of bounding rectangle

Description

Calls ScrollRasterBF(), which moves the bits in the raster by (dx,dy) towards (0,0) The space vacated is filled by calling EraseRect().

Note: that vacated space is not considered damage! The scroll operation is limited to the rectangle defined by (xmin,ymin)-(xmax,ymax). Bits outside will not be affected. If (xmax,ymax) is outside the rastport then use the lower right corner of the rastport.

If a window is partly obscured, then it is possible for ScrollWindowRaster() to scroll some of the obscured area into view. If the window is simple-refresh, then the formerly obscured area is damage, and the application needs to repair it. If Intuition detects damage as a result of ScrollWindowRaster(), it will send an IDCMP_REFRESHWINDOW event to the application's window. This handling of damage is the principal reason ScrollWindowRaster() is preferred to ScrollRaster() and ScrollRasterBF().

Note: This call uses ScrollRasterBF(), which calls EraseRect() when clearing the newly exposed area. This allows use of a custom layer backfill hook.

Important: boopsi gadgets should use ScrollRaster() or ScrollRasterBF() directly! Never call ScrollWindowRaster() from inside a boopsi gadget's method handler. Note that Intuition will detect and handle damage caused by such use of ScrollRaster() or ScrollRasterBF(), for gadgets with the GMORE_SCROLLRASTER property.

VERY IMPORTANT: if you have any gadgets in your simple-refresh window with the GMORE_SCROLLRASTER property, you must use ScrollWindowRaster() instead of ScrollRaster() or ScrollRasterBF(). Handling of gadget scroll damage is incompatible with continued use of these graphics functions in an Intuition window. NB: If you're using a gadget class whose source code you do not control, that class might be using GMORE_SCROLLRASTER or might start to in a future version. For that reason, you should use ScrollWindowRaster() if you are using any such gadgets.

See also

ScrollRaster() | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.
ScrollRasterBF() | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().
EraseRect() | Fill a defined rectangular area using the current BackFill hook.
WA_BackFill | Tag for OpenWindowTagList(). BackFill hook


ScrollWindowRasterNoFill

Declaration

Source position: intuition.pas line 3608

procedure ScrollWindowRasterNoFill(

  Win: PWindow;

  Dx: LongInt;

  Dy: LongInt;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);


SetAttrs

Varargs Version of SetAttrsA()

Declaration

Source position: intuition.pas line 3638

function SetAttrs(

  Object1: Pointer;

  const Tags: array of PtrUInt

):LongWord;


SetAttrsA

Specify attribute values for an object.

Declaration

Source position: intuition.pas line 3570

function SetAttrsA(

  Object1: Pointer;

  TagList: PTagItem

):LongWord;

Arguments

TagList

Array of TagItem structures with attribute/value pairs.

Function result

The object does whatever it wants with the attributes you provide. The return value tends to be non-zero if the changes would require refreshing gadget imagery, if the object is a gadget.

Description

Specifies a set of attribute/value pairs with meaning as defined by a 'boopsi' object's class.

This function does not provide enough context information or arbitration for boopsi gadgets which are attached to windows or requesters. For those objects, use SetGadgetAttrsA().

Note: This function invokes the OM_SET method with a nil GadgetInfo parameter.

See also

SetAttrs | Varargs Version of SetAttrsA()
NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


SetDefaultPubScreen

Choose a new default public screen.

Declaration

Source position: intuition.pas line 3549

procedure SetDefaultPubScreen(

  Name: PChar

);

Arguments

Name

name of chosen public screen to be the new default. A value of nil means that the Workbench screen is to be the default public screen.

Description

Establishes a new default public screen for visitor windows.

This screen is used by windows asking for a named public screen that doesn't exist and the faqllback option is selected, and for windows asking for the default public screen directly.

See also

OpenWindow | Open an Intuition window.
OpenScreen | Open an Intuition screen


SetDMRequest

Set the DMRequest of a window.

Declaration

Source position: intuition.pas line 3494

function SetDMRequest(

  Window: PWindow;

  Requester: PRequester

):LongBool;

Arguments

Window | The window from which the DMRequest is to be set
Requester | A pointer to the requester

Function result

True if old DMRequest was not in use and therefore changed to the new one, or False if the old DMRequest was in use and could not be set to the new one.

Description

A DMRequest is a requester that appears if the user double-clicks with the menu button. The new DMRequest will only be set if the old DMRequest is not in use. The official way to change the DMRequest is to call ClearDMRequest() until it returns True and then call SetDMRequest().

Note: If the DMRequest has the POINTREL flag set, the DMR will show up as close to the pointer as possible. The RelLeft/Top fields are used to fine-tune the positioning.

See also

ClearDMRequest | Clear (detaches) the DMRequest of the window.
Request | Activate a requester.


SetEditHook

Set global processing for string gadgets.

Declaration

Source position: intuition.pas line 3540

function SetEditHook(

  Hook: PHook

):PHook;

Arguments

Hook

A pointer to a struct Hook which determines a function in your code to be called every time the user types a key. This is done before control is passed to the gadget custom editing hook, so affects all string gadgets.

Function result

Returns previous global edit hook structure. You may need this hook if you wish to invoke the previous edit hook's behavior in addition to your own.

Description

Sets new global editing hook for string gadgets.

Warning: The use and integration of this function has not been explored, and thus should be considered a risky function. Do not use this in a commercial product until further notice.

There are a few key differences between a global edit hook and the more famililar per-gadget StringExtend->EditHook field. In the case of the latter, the hook's creator supplies a WorkBuffer. Intuition's idea of the result of a keystroke is stored in the SGWork structure (which references the WorkBuffer). The state of the gadget before Intuition's hook acted is available in the TStringInfo.Buffer, .BufferPos, and .NumChars fields.

In the case of a global editing hook, your hook becomes Intuition's hook, which affects all gadgets, most of which do not have a WorkBuffer. This means that if you invoke Intuition's original hook (which you got as the result of this function), there isn't any easy way for you to "undo" that after the fact. This means that if Intuition's behavior for certain keystrokes is incompatible with your hook's objectives, then you must avoid calling Intuition's hook for those keys. One approach is to run through your hook's code first, acting on those keys you wish to recognize. Then, call Intuition's hook for those keys you do not recognize, or for those keys whose default actions you wish to add to.

Do not forget to set SGA_REDISPLAY when needed, and please be sure to give the TSGWork^.EditOp field a value which is as meaningful as possible.

Currently, only SGH_KEY messages are sent to the global edit hook, though custom edit hooks do receive SGH_CLICK messages in addition.

Finally, there is currently no arbitration between a global edit hook and a custom edit hook as to ownership of keystrokes. It would be fair to expect that a custom edit hook would be written to match the current Intuition edit hook. If your global edit hook acts on (say) up and down arrow keystrokes, an undesirable result may occur if some string gadget's custom hook also acts on these keystrokes. There is currently no easy way to resolve this issue.


SetGadgetAttrs

Varargs Version of SetGadgetAttrsA()

Declaration

Source position: intuition.pas line 3640

function SetGadgetAttrs(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  const Tags: array of PtrUInt

):LongWord;


SetGadgetAttrsA

Specify attribute values for a boopsi gadget.

Declaration

Source position: intuition.pas line 3575

function SetGadgetAttrsA(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  TagList: PTagItem

):LongWord;

Arguments

Gadget | An abstract pointer to a boopsi gadget
Window | A window gadget has been added to using AddGList() or AddGadget()
Requester | For GTYP_REQGADGETs, requester containing the gadget
TagList | An array of TagItem structures with attribute/value pairs.

Function result

The object does whatever it wants with the attributes you provide, which might include updating its gadget visuals. The return value tends to be non-zero if the changes would require refreshing gadget imagery, if the object is a gadget.

Description

Same as SetAttrsA(), but provides context information and arbitration for classes which implement custom Intuition gadgets.

You should use this function for boopsi gadget objects which have already been added to a requester or a window, or for "models" which propagate information to gadget already added.

Typically, the gadgets will refresh their visuals to reflect changes to visible attributes, such as the value of a slider, the text in a string-type gadget, the selected state of a button.

You can use this as a replacement for SetAttrsA(), too, if you specify nil for the Window and Requester parameters.

Notes:

This function invokes the OM_SET method with a GadgetInfo derived from the Window and Requester pointers.

See also

SetGadgetAttrs | Varargs Version of SetGadgetAttrsA()
NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


SetMenuStrip

Attach a menu strip to a window.

Declaration

Source position: intuition.pas line 3495

function SetMenuStrip(

  Window: PWindow;

  Menu: PMenu

):LongBool;

Arguments

Window | The window to add the MenuStrip to
Menu | The menu to be added to the window above.

Function result

True if all menus have at least one menuitem.

Description

Attaches the menu strip to the window. After calling this routine, if the user presses the menu button, this specified menu strip will be displayed and accessible by the user.

Menus with zero menu items are not allowed.

Note: You should always design your menu strip changes to be a two-way operation, where for every menu strip you add to your window you should always plan to clear that strip sometime. Even in the simplest case, where you will have just one menu strip for the lifetime of your window, you should always clear the menu strip before closing the window. If you already have a menu strip attached to this window, the correct procedure for changing to a new menu strip involves calling ClearMenuStrip() to clear the old first.

The sequence of events should be:

  • OpenWindow()

  • zero or more iterations of:

    • SetMenuStrip()
    • ClearMenuStrip()
  • CloseWindow()

See also

ResetMenuStrip | Re-attach a menu strip to a window.
ClearMenuStrip | Clear (detach) the menu strip from the window.


SetMouseQueue

Change limit on pending mouse messages.

Declaration

Source position: intuition.pas line 3541

function SetMouseQueue(

  Window: PWindow;

  QueueLength: LongWord

):LongInt;

Arguments

Window | Your window
QueueLength | The new value of outstanding mouse movement messages you wish to allow.

Function result

-1 if Window is not known Otherwise the previous value of the queue limit. The corresponding function for changing the repeat key queue limit is not yet implemented.

Description

Change the number of mouse messages for your window to be allowed to be outstanding.

See also

OpenWindow

Open an Intuition window.


SetPointer

Specify a pointer sprite image for a window.

Declaration

Source position: intuition.pas line 3496

procedure SetPointer(

  Window: PWindow;

  Pointer: PWord;

  Height: LongInt;

  Width: LongInt;

  XOffset: LongInt;

  YOffset: LongInt

);

Arguments

Window | A pointer to the window to receive this pointer definition
Height | The height of the pointer
Width | The width of the sprite (must be less than or equal to sixteen)
XOffset | The offset for your sprite from the mouse position
YOffset | The offset for your sprite from the mouse position

Description

Sets up the window with the sprite definition for the pointer. Then, whenever the window is the active one, the pointer image will change to the window's version. If the window is the active one when this routine is called, the change takes place immediately.

The XOffset and YOffset parameters are used to offset the upper-left corner of the hardware sprite image from what Intuition regards as the current position of the pointer. Another way of describing it is as the offset from the "hot spot" of the pointer to the top-left corner of the sprite. For instance, if you specify offsets of zero, zero, then the top-left corner of your sprite image will be placed at the mouse position. On the other hand, if you specify an XOffset of -7 (remember, sprites are 16 pixels wide) then your sprite will be centered over the mouse position. If you specify an XOffset of -15, the right-edge of the sprite will be over the mouse position.

See also

SetWindowPointerA | Select a pointer for your window.
ClearPointer | Clear the mouse pointer definition from a window.


SetPrefs

Set Intuition preferences data.

Declaration

Source position: intuition.pas line 3506

function SetPrefs(

  Preferences: PPreferences;

  Size: LongInt;

  Inform: LongInt

):PPreferences;

Arguments

Size | The number of bytes of the buffer you want to be copied.
Inform | If True, all windows with IDCMP_NEWPREFS IDCMPFlags set get an IDCMP_NEWPREFS message.

Function result

Returns your parameter buffer.

Description

Sets new preferences values. Copies the first Size bytes from your preferences buffer to the system preferences table, and puts them into effect.

The Inform parameter, if True, indicates that an IDCMP_NEWPREFS message is to be sent to all windows that have the IDCMP_NEWPREFS IDCMPFlags set.

It is legal to set a partial copy of the Preferences structure. The most frequently changed values are grouped at the beginning of the Preferences structure.

Note: A new and more extensible method for supplying Preferences has been introduced, and relies on file system notification. The Intuition preferences items rely also on the IPrefs program. Certain elements of the Preferences structure have been superseded by this new method. (Elements are generally superseded as new hardware or software features demand more information than fits in struct Preferences. Parts of struct Preferences must be ignored so that applications calling GetPrefs(), modifying some other part of struct Preferences, then calling SetPrefs(), don't end up truncating the extended data).

Pointer Preferences: Only the pointer from the initial SetPrefs() (i.e. devs:system-configuration) is heeded.

Palette Preferences: Color changes submitted through SetPrefs() are ignored after the first time IPrefs sends Intuition new style palette preferences.

FontHeight and LaceWB: These are only respected from devs:system-configuration.

View centering and size: Changes to ViewX/YOffset and Row/ColumnSizeChange only apply to the default monitor (NTSC or PAL), and not to other monitors such as Productivity.

Other fields may be superseded in the future.

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetPrefs | Get the current Intuition Preferences structure.


SetPubScreenModes

Establish global public screen behavior.

Declaration

Source position: intuition.pas line 3550

function SetPubScreenModes(

  Modes: LongWord

):Word;

Arguments

Modes

new global modes flags.

Function result

Previous global mode settings

Description

Sets GLOBAL Intuition public screen modes. Values for flag bits are:

SHANGHAI:
workbench windows are to be opened on the default public screen
POPPUBSCREEN:
when a visitor window is opened, the public screen it opens on is to be brought to the front.

See also

OpenScreen

Open an Intuition screen


SetWindowPointer

Varargs Version of SetWindowPointerA()

Declaration

Source position: intuition.pas line 3641

procedure SetWindowPointer(

  Win: PWindow;

  const Tags: array of PtrUInt

);


SetWindowPointerA

Select a pointer for your window.

Declaration

Source position: intuition.pas line 3596

procedure SetWindowPointerA(

  Win: PWindow;

  Taglist: PTagItem

);

Arguments

Win | A pointer to the window to receive this pointer definition
Taglist | A pointer to a taglist describing your pointer

Description

Allows you to set the pointer image associated with the specified window. Whenever the window is the active one, the pointer image will change to the window's version. If the window is the active one when this routine is called, the change takes place immediately.

Tags:

The same three tags are also accepted by OpenWindowTagList(), which allows you to establish the initial pointer at the time you open your window.

WA_Pointer (APTR)
The pointer you wish to associate with your window. If nil, you are requesting the Preferences default pointer. Custom pointers should be allocated by performing a NewObject() on "pointerclass". Defaults to nil.
WA_BusyPointer (LongBool)
Set to True to request the Preferences busy-pointer. If False, your pointer will be as requested by WA_Pointer. Defaults to False.
WA_PointerDelay (LongBool)
Set to True to defer changing your pointer for a brief instant. This is typically used along with setting the busy pointer, especially when the application knows it may be busy for a very short while. If the application clears the pointer or sets another pointer before the delay expires, the pending pointer change is cancelled. This reduces short flashes of the busy pointer.

Snippet

This example sets the standard busy pointer with pointer-delay, does a bit of work, then clears the pointer:

// Put up the busy pointer, with pointer-delay
SetWindowPointer(Win,
   [WA_BusyPointer, True,
    WA_PointerDelay, True,
    TAG_DONE]);
// Do busy stuff here
  // No tags means "clear the pointer"
SetWindowPointer(Win, [TAG_DONE]);

See also

SetWindowPointer | Varargs Version of SetWindowPointerA()
SetPointer | Specify a pointer sprite image for a window.
ClearPointer | Clear the mouse pointer definition from a window.


SetWindowTitles

Set the window's titles for both window and screen.

Declaration

Source position: intuition.pas line 3497

procedure SetWindowTitles(

  Window: PWindow;

  WindowTitle: PChar;

  ScreenTitle: PChar

);

Arguments

Window | A pointer to your window structure
WindowTitle | A pointer to a null-terminated text string, or set to either the value of -1 (negative one) or 0 (zero). If you specify a string, this string is not copied.
ScreenTitle | A pointer to a null-terminated text string, or set to either the value of -1 (negative one) or 0 (zero). If you specify a title for the screen, this title will be shown when the window becomes active. If you specify a string, this string is not copied.

Description

Allows you to set the text which appears in the Window and/or Screen title bars.

The window title appears at all times along the window title bar. The window's screen title appears at the screen title bar whenever this window is the active one.

When this routine is called, your window title will be changed immediately. If your window is the active one when this routine is called, the screen title will be changed immediately.

You can specify a value of -1 (i.e. PByte($FF)) for either of the title pointers. This designates that you want Intuition to leave the current setting of that particular title alone, and modify only the other one. Of course, you could set both to -1.

Furthermore, you can set a value of nil for either of the title pointers. Doing so specifies that you want no title to appear (the title bar will be blank).

Both of the titles are rendered in the default font of the window's screen, as set using OpenScreen().

In setting the window's title, Intuition may do some other rendering in the top border of your window. If your own rendering sometimes appears in your window border areas, you may want to restore the entire window border frame. The function SetWindowTitles() does not do this in the newer versions. The function RefreshWindowFrame() is provided to do this kind of thing for you.

Note:You should be careful with specifying a screen title because that may irritate the user.

See also

OpenWindow | Open an Intuition window.
RefreshWindowFrame | Ask Intuition to redraw your window border.
OpenScreen | Open an Intuition screen


SHIFTITEM

Menu helper macro

Declaration

Source position: intuition.pas line 3620

function SHIFTITEM(

  N: SmallInt

):Word;


SHIFTMENU

Menu helper macro

Declaration

Source position: intuition.pas line 3621

function SHIFTMENU(

  N: SmallInt

):Word;


SHIFTSUB

Menu helper macro

Declaration

Source position: intuition.pas line 3622

function SHIFTSUB(

  N: SmallInt

):Word;


ShowTitle

Set the screen title bar display mode.

Declaration

Source position: intuition.pas line 3498

procedure ShowTitle(

  Screen: PScreen;

  ShowIt: LongInt

);

Arguments

Screen | A pointer to a Screen structure
ShowIt | A Boolean: True or False describing whether to show or hide the screen title bar

Description

This routine sets the SHOWTITLE flag of the specified screen, and then coordinates the redisplay of the screen and its windows.

The screen title bar can appear either in front of or behind WFLG_BACKDROP windows. This is contrasted with the fact that non-WFLG_BACKDROP windows always appear in front of the screen title bar. You specify whether you want the screen title bar to be in front of or behind the screen's WFLG_BACKDROP windows by calling this routine.

The ShowIt argument should be set to either True or False. If True, the screen's title bar will be shown in front of WFLG_BACKDROP windows.

If False, the title bar will be rendered behind all windows.

When a screen is first opened, the default setting of the SHOWTITLE flag is True.


SHOWTITLE_f

Flag for TScreen.Flags. This gets set by a call to ShowTitle()

Declaration

Source position: intuition.pas line 1408

const SHOWTITLE_f = 1 shl 4;


ShowWindow

Declaration

Source position: intuition.pas line 3601

procedure ShowWindow(

  win: PWindow

);


SIZEOF_INSTANCE

Sizeof the instance data for a given class

Declaration

Source position: intuition.pas line 3615

function SIZEOF_INSTANCE(

  Cl: PIClass

):LongInt;


SizeWindow

Ask Intuition to size a window.

Declaration

Source position: intuition.pas line 3499

procedure SizeWindow(

  Window: PWindow;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Window | A pointer to the structure of the window to be sized
Dx | A signed value describing how much to size the window on the x-axis
Dy | A signed value describing how much to size the window on the y-axis

Description

This routine sends a request to Intuition asking to size the window the specified amounts. The delta arguments describe how much to size the window along the respective axes.

Note that the window will not be sized immediately, but rather will be sized the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second. You can discover when you window has finally been sized by setting the IDCMP_NEWSIZE flag of the IDCMP of your window.

Intuition now will do validity checking on the final dimensions. To change to new absolute dimensions, or to move and size a window in one step, use ChangeWindowBox().

However, limit checking against window MinWidth, MinHeight, MaxWidth, and MaxHeight was not done prior to V36, and these fields are still ignored (as documented) if you have no sizing gadget (WFLG_SIZEGADGET is not set). The are respected if WFLG_SIZEGADGET is set.

You can determine when the change in size has taken effect by receiving the IDCMP_CHANGEWINDOW IDCMP message.

See also

ChangeWindowBox | Change window position and dimensions.
MoveWindow | Ask Intuition to move a window.
WindowToFront | Ask Intuition to bring a window to the front.
WindowToBack | Ask Intuition to send a window behind others.


SUBNUM

Menu helper macro

Declaration

Source position: intuition.pas line 3631

function SUBNUM(

  N: Word

):Word;


SysReqHandler

Handle system requester input.

Declaration

Source position: intuition.pas line 3559

function SysReqHandler(

  Window: PWindow;

  IDCMPPtr: PLongWord;

  WaitInput: LongInt

):LongInt;

Arguments

Window | Window pointer returned from BuildSysRequest(). Those functions can also return values 0 or 1, and these values may also be passed to SysReqHandler(), which will immediately return the same value.
WaitInput | Specifies that you want SysReqHandler() to to wait for IDCMP input if there is none pending.

Function result

0, 1, ..., N = Successive GadgetID values, for the gadgets you specify for the requester. NOTE: The numbering from left to right is actually: 1, 2, ..., N, 0. This is for compatibility with AutoRequests which has FALSE for the rightmost gadget.

-1 = Means that one of the caller-supplied IDCMPFlags occurred. The IDCMPFlag value is in the longword pointed to by IDCMPFlagsPtr.

-2 = input processed did not satisfy the requester. One example is a keystroke that does not satisfy the requester. Another example is if there is no input pending and you specified False for WaitInput.

Description

Handles input for a window returned by either BuildSysRequest(). These functions with SysReqHandler() you can perform an "asynchronous" EasyRequest() or AutoRequest(). That is to say, you can perform other processing while you wait for the requester to be satisfied.

Each time this function is called, it will process all IDCMPMessages that the window has received. If the parameter WaitInput is non-zero, SysReqHandler() will wait for input (by calling WaitPort()) if there are no IDCMP messages.

SysReqHandler() returns the same values as EasyRequest(): A gadget ID greater than equal to 0, and -1 if one of the other IDCMP events were received.

An additional value of -2 is returned if the input processed does not satisfy the requester. In this case, you might perform some processing and call SysReqHandler() again.

Note: this function does not terminate the system request. Not only must you call FreeSysRequest() to eliminate the request, but you may also continue processing after an event which would normally terminate a normal call to EasyRequest().

Snippet

Implementation of EasyRequest input loop:

Window := BuildEasyRequest(...);
while SysReqHandler(Window, IDCMP_Ptr, True) = -2 do
begin
 // loop
end;
FreeSysRequest(Window);

Errors

Gadget placing is still untidy. Does not support BuildSysRequest() requesters, yet.

See also

WaitPort | Wait for a given port to be non-empty
BuildSysRequest | Build and display a system requester.


TimedDisplayAlert

Display an alert with automatic time-out.

Declaration

Source position: intuition.pas line 3597

function TimedDisplayAlert(

  AlertNumber: LongWord;

  String1: PChar;

  Height: LongWord;

  Time: LongWord

):LongBool;

Arguments

AlertNumber | The number of this alert message. The only pertinent bits of this number are the ALERT_TYPE bit(s). The rest of the number is ignored by this routine.
Height | Minimum display lines required for your message
Time | Length of time the alert should wait for the user to respond. This time is the number of video frames the alert should remain up for.

Function result

A LongBool value of True or False. If this is a DEADEND_ALERT, False is always the return value. If this is a RECOVERY_ALERT. The return value will be True if the user presses the left mouse button in response to your message, and False if the user presses the right hand button is response to your text, or if the alert could not be posted. If the alert times out, the return value will be False.

Description

This function is equivalent to DisplayAlert(), except that if the user fails to respond in a given time, the alert comes down automatically.

See also

DisplayAlert

Create the display of an alert message.


TransparencyControl

Declaration

Source position: intuition.pas line 3607

function TransparencyControl(

  Window: PWindow;

  Method: LongWord;

  Tags: PTagItem

):LongBool;


UnlockIBase

Release a an Intuition lock gotten by LockIBase().

Declaration

Source position: intuition.pas line 3526

procedure UnlockIBase(

  IbLock: LongWord

);

Description

Calling this function when you do not own the specified lock will immediately crash the system.

See also

LockIBase

Invoke semaphore arbitration of TIntuitionBase.


UnlockPubScreen

Release lock on a public screen.

Declaration

Source position: intuition.pas line 3545

procedure UnlockPubScreen(

  Name: PChar;

  Screen: PScreen

);

Arguments

Name | A pointer to name of public screen. If Name is nil, then argument Screen is used as a direct pointer to a public screen.
Screen | A pointer to a public screen. Used only if Name is nil. This pointer must have been returned by LockPubScreen(). It is safe to call UnlockPubScreen() with nil Name and Screen (the function will have no effect).

Description

Releases lock gotten by LockPubScreen(). It is best to identify the locked public screen by the pointer returned from LockPubScreen(). To do this, supply a nil Name pointer and the screen pointer.

In rare circumstances where it would be more convenient to pass a non-nil pointer to the public screen name string, the Screen parameter is ignored.

See also

LockPubScreen

Prevent a public screen from closing.


UnlockPubScreenList

Release public screen list semaphore.

Declaration

Source position: intuition.pas line 3547

procedure UnlockPubScreenList;

Description

Releases lock gotten by LockPubScreenList().


ViewAddress

Return the address of the Intuition View structure.

Declaration

Source position: intuition.pas line 3500

function ViewAddress: PView;

Function result

Returns the address of the Intuition View structure

Description

Returns the address of the Intuition View structure. If you want to use any of the graphics, text, or animation primitives in your window and that primitive requires a pointer to a view, this routine will return the address of the view for you.


ViewPortAddress

Return the address of a window's viewport.

Declaration

Source position: intuition.pas line 3501

function ViewPortAddress(

  Window: PWindow

):PViewPort;

Arguments

Window

A pointer to the window for which you want the viewport address

Function result

Returns the address of the Intuition ViewPort structure for your window's screen.

Description

Returns the address of the viewport associated with the specified window. The viewport is actually the viewport of the screen within which the window is displayed. If you want to use any of the graphics, text, or animation primitives in your window and that primitive requires a pointer to a viewport, you can use this call.

This pointer is only valid as long as your window's screen remains open, which is ensured by keeping your window open.


WBenchToBack

Send the Workbench screen in back of all screens.

Declaration

Source position: intuition.pas line 3509

function WBenchToBack: LongBool;

Function result

If the Workbench screen was opened, this function returns True, otherwise it returns False.

Description

Causes the Workbench screen, if it's currently opened, to go behind all other screens. This does not 'move' the screen up or down, instead only affects the depth-arrangement of the screens.

See also

ScreenToBack | Send the specified screen to the back of the display.
ScreenToFront | Make the specified screen the frontmost.
WBenchToFront | Bring the Workbench screen in front of all screens.


WBenchToFront

Bring the Workbench screen in front of all screens.

Declaration

Source position: intuition.pas line 3510

function WBenchToFront: LongBool;

Function result

If the Workbench screen was opened, this function returns True, otherwise it returns False.

Description

Causes the Workbench Screen, if it's currently opened, to come to the foreground. This does not 'move' the screen up or down, instead only affects the depth-arrangement of the screen.

See also

ScreenToBack | Send the specified screen to the back of the display.
ScreenToFront | Make the specified screen the frontmost.
WBenchToBack | Send the Workbench screen in back of all screens.


WindowAction

Declaration

Source position: intuition.pas line 3606

procedure WindowAction(

  Window: PWindow;

  Action: LongWord;

  Tags: PTagItem

);


WindowLimits

Set the minimum and maximum limits of a window.

Declaration

Source position: intuition.pas line 3504

function WindowLimits(

  Window: PWindow;

  WidthMin: LongInt;

  HeightMin: LongInt;

  WidthMax: LongWord;

  HeightMax: LongWord

):LongBool;

Arguments

Window | A pointer to a Window structure
WidthMin | The new limits for the size of this window. If any of these is set to zero, it will be ignored and that setting will be unchanged.

Function result

Returns True if everything was in order. If any of the parameters was out of range (minimums greater than current size, maximums less than current size), False is returned and the errant limit request is not fulfilled (though the valid ones will be).

Description

Sets the minimum and maximum limits of the window's size. Until this routine is called, the window's size limits are equal to the initial values established in the OpenWindow() function.

After a call to this routine, the Window will be able to be sized to any dimensions within the specified limits.

If you don't want to change any one of the dimensions, set the limit argument for that dimension to zero. If any of the limit arguments is equal to zero, that argument is ignored and the initial setting of that parameter remains undisturbed.

If any of the arguments is out of range (minimums greater than the current size, maximums less than the current size), that limit will be ignored, though the others will still take effect if they are in range. If any are out of range, the return value from this procedure will be False. If all arguments are valid, the return value will be True.

If you want your window to be able to become "as large as possible" you may put -1 (i.e. not 0) in either or both Max arguments. But please note: screen sizes may vary for several reasons, and you must be able to handle any possible size of window you might end up with if you use this method. Note that you can use the function LockPubScreen() to find out how big the screen your window will appear in is. You may also refer to the WScreen field in your window structure, providing that your window remains open, which will ensure that the screen remains open, and thus the pointer remains valid.

If the user is currently sizing this window, the new limits will not take effect until after the sizing is completed.

See also

LockPubScreen

Prevent a public screen from closing.


WindowToBack

Ask Intuition to send a window behind others.

Declaration

Source position: intuition.pas line 3502

procedure WindowToBack(

  Window: PWindow

);

Arguments

Window

A pointer to the structure of the window to be sent to the back

Description

This routine sends a request to Intuition asking to send the window in back of all other windows in the screen.

Note that the window will not be depth-arranged immediately, but rather will be arranged the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second.

Remember that WFLG_BACKDROP windows cannot be depth-arranged.

See also

MoveWindow | Ask Intuition to move a window.
SizeWindow | Ask Intuition to size a window.
WindowToFront | Ask Intuition to bring a window to the front.
MoveWindowInFrontOf | Arrange the relative depth of a window.


WindowToFront

Ask Intuition to bring a window to the front.

Declaration

Source position: intuition.pas line 3503

procedure WindowToFront(

  Window: PWindow

);

Arguments

Window

A pointer to the structure of the window to be brought to front

Description

This routine sends a request to Intuition asking to bring the window in front of all other windows in the screen.

Note that the window will not be depth-arranged immediately, but rather will be arranged the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second.

Remember that WFLG_BACKDROP windows cannot be depth-arranged.

See also

MoveWindow | Ask Intuition to move a window.
SizeWindow | Ask Intuition to size a window.
WindowToBack | Ask Intuition to send a window behind others.
MoveWindowInFrontOf | Arrange the relative depth of a window.


ZipWindow

Change window to "alternate" position and dimensions.

Declaration

Source position: intuition.pas line 3542

procedure ZipWindow(

  Window: PWindow

);

Arguments

Window

Window to be changed.

Description

Changes the position and dimension of a window to the values at the last occasion of ZipWindow being called (or invoked via the "zoom" gadget).

Typically this is used to snap between a normal, large, working dimension of the window to a smaller, more innocuous position and dimension.

Like MoveWindow(), SizeWindow(), and ChangeWindowBox(), the action of this function is deferred to the Intuition input handler.

More tuning needs to be done to establish initial values for the first invocation of this function for a window. You can provide initial values using the OpenWindowTagList() tag item WA_Zoom.

It could also use a new name, but "ZoomWindow" is misleading, since "Zoom" normally implies "scale."

The zoom gadget will appear (in the place of the old "toback" gadget) when you open your window if you either specify a sizing gadget or use WA_Zoom.

You can detect that this function has taken effect by receiving an IDCMP_CHANGEWINDOW IDCMP message.


_OBJ

convenient typecast to P_Object

Declaration

Source position: intuition.pas line 3617

function _OBJ(

  O: P_Object

):P_Object;


__OBJECT

Get back to object data struct from public handle

Declaration

Source position: intuition.pas line 3618

function __OBJECT(

  O: Pointer

):P_Object;


Reference for unit 'keymap': Procedures and functions

AskKeyMapDefault

GetKeyMapCodePage

InitKeymapLibrary

MapANSI

MapRawKey

MapRawKeyUCS4

MapUCS4

SetKeyMapDefault

ToANSI

ToUCS4


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'keymap': Variables

KeyMapBase


Index of all identifiers in unit 'keymap'

A D G I K M P S T

A

AskKeyMapDefault

D

DP_2DFACSHIFT | DPB_DEAD | DPF_DEAD
DP_2DINDEXMASK | DPB_MOD | DPF_MOD

G

GetKeyMapCodePage

I

InitKeymapLibrary

K

KCB_ALT | KCB_STRING | KCF_SHIFT
KCB_CONTROL | KCF_ALT | KCF_STRING
KCB_DEAD | KCF_CONTROL | KC_NOQUAL
KCB_DOWNUP | KCF_DEAD | KC_VANILLA
KCB_NOP | KCF_DOWNUP | KeyMapBase
KCB_SHIFT | KCF_NOP | KEYMAPNAME

M

MapANSI | MapRawKeyUCS4
MapRawKey | MapUCS4

P

PExtendedKeyMapNode | PKeyMapResource | PUCS4_ConvTable
PKeyMap | PUCS4_CharsetCode |
PKeymapNode | PUCS4_CharsetConvTable |

S

SetKeyMapDefault

T

TExtendedKeyMapNode | TKeyMapResource | TUCS4_CharsetCode
TKeyMap | ToANSI | TUCS4_CharsetConvTable
TKeyMapNode | ToUCS4 | TUCS4_ConvTable


AskKeyMapDefault

Declaration

Source position: keymap.pas line 119

function AskKeyMapDefault: PKeyMap;


GetKeyMapCodePage

Declaration

Source position: keymap.pas line 126

function GetKeyMapCodePage(

  const KeyMap: PKeyMap

):PChar;


InitKeymapLibrary

Declaration

Source position: keymap.pas line 129

function InitKeymapLibrary: Boolean;


MapANSI

Declaration

Source position: keymap.pas line 121

function MapANSI(

  const Strg: PChar;

  Count: LongInt;

  Buffer: PChar;

  Length: LongInt;

  const KeyMap: PKeyMap

):LongInt;


MapRawKey

Declaration

Source position: keymap.pas line 120

function MapRawKey(

  const Event: PInputEvent;

  Buffer: PChar;

  Length: LongInt;

  const KeyMap: PKeyMap

):LongInt;


MapRawKeyUCS4

Declaration

Source position: keymap.pas line 122

function MapRawKeyUCS4(

  const Event: PInputEvent;

  Buffer: PWideChar;

  Length: LongInt;

  const KeyMap: PKeyMap

):LongInt;


MapUCS4

Declaration

Source position: keymap.pas line 123

function MapUCS4(

  const Strg: PWideChar;

  Count: LongInt;

  Buffer: PChar;

  Length: LongInt;

  const KeyMap: PKeyMap

):LongInt;


SetKeyMapDefault

Declaration

Source position: keymap.pas line 118

procedure SetKeyMapDefault(

  const KeyMap: PKeyMap

);


ToANSI

Declaration

Source position: keymap.pas line 124

function ToANSI(

  UCS4Char: WideChar;

  const KeyMap: PKeyMap

):Char;


ToUCS4

Declaration

Source position: keymap.pas line 125

function ToUCS4(

  ASCIIChar: Char;

  const KeyMap: PKeyMap

):WideChar;


Reference for unit 'layers': Procedures and functions

BeginUpdate | Prepare to repair damaged layer.
BehindLayer | Put layer behind other layers.
CreateBehindHookLayer | Create a new layer behind all existing layers, using supplied callback BackFill hook.
CreateBehindLayer | Create a new layer behind all existing layers.
CreateBehindLayerTagList
CreateUpfrontHookLayer | Create a new layer on top of existing layers, using supplied callback BackFill hook.
CreateUpfrontLayer | Create a new layer on top of existing layers.
CreateUpfrontLayerTagList
DeleteLayer | delete layer from layer list.
DisposeLayerInfo | Return all memory for LayerInfo to memory pool
DoHookClipRects | Do the given hook for each of the ClipRects
EndUpdate | remove damage list and restore state of layer to normal.
FattenLayerInfo | convert 1.0 LayerInfo to 1.1 LayerInfo Obsolete
InitLayers | Initialize Layer_Info structure Obsolete
InitLayersLibrary
InstallClipRegion | Install clip region in layer
InstallLayerHook | safely install a new TLayer.BackFill hook
InstallLayerInfoHook | Install a backfill hook for non-layer
IsLayerHitable
IsLayerVisible
IsVisibleInLayer
LockLayer | Lock layer to make changes to ClipRects.
LockLayerInfo | Lock the LayerInfo structure.
LockLayers | lock all layers from graphics output.
LockLayerUpdates
MoveLayer | Move layer to new position in BitMap.
MoveLayerInFrontOf | Put layer in front of another layer.
MoveSizeLayer | Position/Size layer
NewLayerInfo | Allocate and Initialize full Layer_Info structure.
RenderLayerInfoTagList
RenderLayerInfoTags
ScrollLayer | Scroll around in a superbitmap, translate coordinates in non-superbitmap layer.
SizeLayer | Change the size of this nonbackdrop layer.
SortLayerCR |
SwapBitsRastPortClipRect | Swap bits between common bitmap and obscured ClipRect
ThinLayerInfo | convert 1.1 LayerInfo to 1.0 LayerInfo. Obsolete
UnlockLayer | Unlock layer and allow graphics routines to use it.
UnlockLayerInfo | Unlock the LayerInfo structure.
UnlockLayers | Unlock all layers from graphics output. Restart graphics output to layers that have been waiting
UnlockLayerUpdates
UpfrontLayer | Put layer in front of all other layers.
WhichLayer | Which Layer is this point in?
WhichLayerBehindLayer


Unit 'layers' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'layers': Variables

LayersBase


Index of all identifiers in unit 'layers'

B C D E F I L M N P R S T U W

B

BeginUpdate BehindLayer

C

CreateBehindHookLayer | CreateBehindLayerTagList | CreateUpfrontLayer
CreateBehindLayer | CreateUpfrontHookLayer | CreateUpfrontLayerTagList

D

DeleteLayer DisposeLayerInfo DoHookClipRects

E

EndUpdate

F

FattenLayerInfo

I

InitLayers | InstallLayerHook | IsLayerVisible
InitLayersLibrary | InstallLayerInfoHook | IsVisibleInLayer
InstallClipRegion | IsLayerHitable |

L

LA_BackfillHook | LAYERS_BACKFILL | LockLayers
LA_Dummy | LayersBase | LockLayerUpdates
LA_SuperBitMap | LAYERSIMPLE | LR_Destination_BitMap
LA_TransHook | LAYERSMART | LR_Destination_Bounds
LA_TransRegion | LAYERSNAME | LR_Destination_RastPort
LA_WindowPtr | LAYERS_NEVERBACKFILL | LR_Dummy
LAYERBACKDROP | LAYERS_NOBACKFILL | LR_Erase
LAYER_CLIPRECTS_LOST | LAYERSUPER | LR_IgnoreList
LAYERIREFRESH | LAYERUPDATING | LR_LayerInfo_Bounds
LAYERIREFRESH2 | LockLayer | LR_RenderList
LAYERREFRESH | LockLayerInfo |

M

MoveLayer MoveLayerInFrontOf MoveSizeLayer

N

NewLayerInfo NEWLAYERINFO_CALLED

P

PLayer_Info

R

RenderLayerInfoTagList RenderLayerInfoTags

S

ScrollLayer | SortLayerCR
SizeLayer | SwapBitsRastPortClipRect

T

ThinLayerInfo TLayer_Info

U

UnlockLayer | UnlockLayers | UpfrontLayer
UnlockLayerInfo | UnlockLayerUpdates |

W

WhichLayer WhichLayerBehindLayer


BeginUpdate

Prepare to repair damaged layer.

Declaration

Source position: layers.pas line 102

function BeginUpdate(

  L: PLayer

):LongInt;

Arguments

L

pointer to a layer

Function result

True if damage list converted to ClipRect list successfully. False if list conversion aborted. (probably out of memory)

Description

Convert damage list to ClipRect list and swap in for programmer to redraw through. This routine simulates the ROM library environment. The idea is to only render in the "damaged" areas, saving time over redrawing all of the layer. The layer is locked against changes made by the layer library.

Errors

If BeginUpdate returns False, programmer must abort the attempt to refresh this layer and instead call EndUpdate(Layer, False) to restore original ClipRect and damage list.

See also

EndUpdate

remove damage list and restore state of layer to normal.


BehindLayer

Put layer behind other layers.

Declaration

Source position: layers.pas line 98

function BehindLayer(

  Dummy: LongInt;

  Layer: PLayer

):LongInt;

Arguments

Dummy | unused
Layer | Pointer to a layer

Function result

True - if operation successful. False - if operation unsuccessful (probably out of memory)

Description

Move this layer to the most behind position swapping bits in and out of the display with other layers. If other layers are REFRESH then collect their damage lists and set the LAYERREFRESH bit in the Flags fields of those layers that may be revealed. If this layer is a backdrop layer then put this layer behind all other backdrop layers. If this layer is not a backdrop layer then put in front of the top backdrop layer and behind all other layers.

Attention

This operation may generate refresh events in other layers associated with this layer's TLayer_Info structure.


CreateBehindHookLayer

Create a new layer behind all existing layers, using supplied callback BackFill hook.

Declaration

Source position: layers.pas line 121

function CreateBehindHookLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Hook: PHook;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Hook | BackFill callback Hook
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) Make this layer of type found in flags. Install Layer->BackFill callback Hook. If SuperBitMap, use bm2 as pointer to real SuperBitMap, and copy contents of Superbitmap into display layer. If this layer is a backdrop layer then place it behind all other layers including other backdrop layers. If this is not a backdrop layer then place it behind all nonbackdrop layers.

Attention

When using bm2 SuperBitmap, you should also set LAYERSMART flag.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


CreateBehindLayer

Create a new layer behind all existing layers.

Declaration

Source position: layers.pas line 96

function CreateBehindLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) Make this layer of type found in flags. If SuperBitMap, use bm2 as pointer to real SuperBitMap, and copy contents of Superbitmap into display layer. If this layer is a backdrop layer then place it behind all other layers including other backdrop layers. If this is not a backdrop layer then place it behind all nonbackdrop layers.

Attention

When using bm2 SuperBitmap, you should also set LAYERSMART flag.


CreateBehindLayerTagList

Declaration

Source position: layers.pas line 129

function CreateBehindLayerTagList(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Taglist: PTagItem

):PLayer;


CreateUpfrontHookLayer

Create a new layer on top of existing layers, using supplied callback BackFill hook.

Declaration

Source position: layers.pas line 120

function CreateUpfrontHookLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Hook: PHook;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Hook | BackFill callback Hook
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) and place it on top of all other layers. Make this layer of type found in flags Install Layer^.BackFill callback hook. if SuperBitMap, use bm2 as pointer to real SuperBitMap. and copy contents of Superbitmap into display layer.

Attention

When using bm2 SuperBitmap, you should also set LAYERSMART flag.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


CreateUpfrontLayer

Create a new layer on top of existing layers.

Declaration

Source position: layers.pas line 95

function CreateUpfrontLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) and place it on top of all other layers. Make this layer of type found in flags if SuperBitMap, use bm2 as pointer to real SuperBitMap. and copy contents of Superbitmap into display layer.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


CreateUpfrontLayerTagList

Declaration

Source position: layers.pas line 128

function CreateUpfrontLayerTagList(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Taglist: PTagItem

):PLayer;


DeleteLayer

delete layer from layer list.

Declaration

Source position: layers.pas line 104

function DeleteLayer(

  Dummy: LongInt;

  Layer: PLayer

):LongInt;

Arguments

Dummy | unused
Layer | pointer to a layer

Function result

True if this layer successfully deleted from the system. False if layer not deleted. (probably out of memory )

Description

Remove this layer from the list of layers. Release memory associated with it. Restore other layers that may have been obscured by it. Trigger refresh in those that may need it. If this is a superbitmap layer make sure SuperBitMap is current. The SuperBitMap is not removed from the system but is available for program use even though the rest of the layer information has been deallocated.


DisposeLayerInfo

Return all memory for LayerInfo to memory pool

Declaration

Source position: layers.pas line 114

procedure DisposeLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to LayerInfo structure

Description

return LayerInfo and any other memory attached to this LayerInfo to memory allocator.

Attention

if you wish to delete the layers associated with this TLayer_Info structure, remember to call DeleteLayer() for each of the layers before calling DisposeLayerInfo().

Snippet

// delete the layers associated this Layer_Info structure --
DeleteLayer(li, Simple_Layer);
DeleteLayer(li, Smart_Layer);

// see documentation on DeleteLayer about deleting SuperBitMap layers --
My_Super_Bitmap_Ptr := Super_Layer^.SuperBitMap;
DeleteLayer(li, Super_Layer);

// now dispose of the Layer_Info structure itself --
DisposeLayerInfo(li);

See also

DeleteLayer

delete layer from layer list.


DoHookClipRects

Do the given hook for each of the ClipRects

Declaration

Source position: layers.pas line 125

procedure DoHookClipRects(

  Hook: PHook;

  RPort: PRastPort;

  const Rect: PRectangle

);

Arguments

Hook | pointer to layer callback Hook which will be called
RPort | A pointer to the RastPort that is to be operated on. This function will lock the layer if the RastPort is layered... If the rport is non-layered your hook will be called with the rectangle as passed, the RastPort, and a nil layer...
Rect | The bounding rectangle that should be used on the layer. This rectangle "clips" the cliprects to the bound given. If this is NULL, no bounding will take place. must not be nil if the RastPort is non-layered!

Description

This function will call the given hook for each cliprect in the layer that can be rendered into. This is how the backfill hook in Layers is implemented. This means that hidden simple-refresh cliprects will be ignored. It will call the SuperBitMap cliprects, smart refresh off-screen cliprects, and all on screen cliprects. If the rect parameter is not nil, the cliprects are bounded to the rectangle given.

Hook will be called with:

object = PRastPort(Result^.RastPort);
message = [ layer: PLayer, bounds: TRectangle, offsetx: LongInt, offsety: LongInt;]

This hook should fill the Rectangle in the RastPort with the BackFill pattern appropriate for offset x/y.

If hook is LAYERS_BACKFILL, the default backfill is used for the layer.

If hook is LAYERS_NOBACKFILL, the layer will not be backfilled (NO-OP).

Attention

The RastPort you are passed back is the same one passed to the function. You should not use "layered" rendering functions on this RastPort. Generally, you will wish to do BitMap operations such as BltBitMap(). The callback is a raw, low-level rendering call-back. If you need to call a rendering operation with a RastPort, make sure you use a copy of the RastPort and nil the Layer pointer.


EndUpdate

remove damage list and restore state of layer to normal.

Declaration

Source position: layers.pas line 103

procedure EndUpdate(

  Layer: PLayer;

  Flag: LongWord

);

Arguments

Layer | pointer to a layer
Flag | Use True if update was completed. The damage list is cleared. Use False if update not complete. The damage list is retained.

Description

After the programmer has redrawn his picture he calls this routine to restore the ClipRects to point to his standard layer tiling. The layer is then unlocked for access by the layer library.

Attention

Use flag := False if you are only making a partial update. You may use the other region functions (graphics functions such as OrRectRegion, AndRectRegion, and XorRectRegion) to clip adjust the DamageList to reflect a partial update.

Snippet

// begin update for first part of two-part refresh
BeginUpdate(my_layer);
// do some refresh, but not all
my_partial_refresh_routine(my_layer);
// end update, false (not completely done refreshing yet)
EndUpdate(my_layer, False);
// begin update for last part of refresh
BeginUpdate(my_layer);
// do rest of refresh
my_complete_refresh_routine(my_layer);
// end update, true (completely done refreshing now)
EndUpdate(my_layer, True);

See also

BeginUpdate

Prepare to repair damaged layer.


FattenLayerInfo

convert 1.0 LayerInfo to 1.1 LayerInfo Obsolete

Declaration

Source position: layers.pas line 115

function FattenLayerInfo(

  Li: PLayer_Info

):LongInt;

Arguments

Li

pointer to LayerInfo structure

Description

Obsolete

V1.1 software and any later releases need to have more info in the Layer_Info structure. To do this in a 1.0 supportable manner requires allocation and deallocation of the memory whenever most layer library functions are called. To prevent unnecessary allocation/deallocation FattenLayerInfo will preallocate the necessary data structures and fake out the layer library into thinking it has a LayerInfo gotten from NewLayerInfo. NewLayerInfo is the approved method for getting this structure. When a program needs to give up the LayerInfo structure it must call ThinLayerInfo before freeing the memory. ThinLayerInfo is not necessary if New/DisposeLayerInfo are used however.

See also

NewLayerInfo | Allocate and Initialize full Layer_Info structure.
ThinLayerInfo | convert 1.1 LayerInfo to 1.0 LayerInfo. Obsolete
DisposeLayerInfo | Return all memory for LayerInfo to memory pool


InitLayers

Initialize Layer_Info structure Obsolete

Declaration

Source position: layers.pas line 94

procedure InitLayers(

  Li: PLayer_Info

);

Arguments

Li

pointer to LayerInfo structure

Description

Obsolete

Initialize Layer_Info structure in preparation to use other layer operations on this list of layers. Make the Layers unlocked (open), available to layer operations.

See also

NewLayerInfo | Allocate and Initialize full Layer_Info structure.
DisposeLayerInfo | Return all memory for LayerInfo to memory pool


InitLayersLibrary

Declaration

Source position: layers.pas line 146

function InitLayersLibrary: Boolean;


InstallClipRegion

Install clip region in layer

Declaration

Source position: layers.pas line 118

function InstallClipRegion(

  Layer: PLayer;

  const Region: PRegion

):PRegion;

Arguments

Layer | pointer to a layer
Region | pointer to a region

Function result

The pointer to the previous ClipRegion that was installed. Returns nil if no previous ClipRegion installed.

Description

Installs a transparent Clip region in the layer. All subsequent graphics calls will be clipped to this region. You must remember to call InstallClipRegion(l, nil) before calling DeleteLayer(l) or the Intuition function CloseWindow() if you have installed a non-nil ClipRegion in layer.

Attention

If the system runs out of memory while computing the resulting ClipRects the LAYERS_CLIPRECTS_LOST bit will be set in layer^.Flags.

Errors

If the system runs out of memory during normal layer operations, the ClipRect list may get swept away and not restored. As soon as there is enough memory and the layer library gets called again the ClipRect list will be rebuilt.

See also

BeginUpdate | Prepare to repair damaged layer.
EndUpdate | remove damage list and restore state of layer to normal.

Example

program clipping;
{$mode fpc}
{ The following example shows the use of the layers library call
  InstallClipRegion(), as well as simple use of the graphics library
  regions functions. Be aware that it uses Release 2 functions for
  opening and closing Intuition windows.

  Clipping.pp converted from original RKRM clipping.c
  tested with FPC 3.2.0}
uses
  Exec, AmigaDOS, AGraphics, Layers, Intuition, Utility;

const
  MY_WIN_WIDTH  = 300;
  MY_WIN_HEIGHT = 100;

{ UnclipWindow()
 Used to remove a clipping region installed by ClipWindow() or
 ClipWindowToBorders(), disposing of the installed region and
 reinstalling the region removed.}
procedure UnclipWindow(Win: PWindow);
var
  Old_Region: PRegion;
begin
  Old_Region := InstallClipRegion(Win^.WLayer, nil);
  // Remove any old region by installing a nil region, then dispose of the old region if one was installed.
  if Assigned(Old_Region) then
    DisposeRegion(Old_Region);
end;

{ ClipWindow()
  Clip a window to a specified rectangle (given by upper left and
  lower right corner.)  the removed region is returned so that it
  may be re-installed later.}
function ClipWindow(Win: PWindow; MinX, MinY, MaxX, MaxY: LongInt): PRegion;
var
  New_Region: PRegion;
  My_Rectangle: TRectangle;
begin
  // set up the limits for the clip
  My_Rectangle.MinX := MinX;
  My_Rectangle.MinY := MinY;
  My_Rectangle.MaxX := MaxX;
  My_Rectangle.MaxY := MaxY;

  New_Region := NewRegion();
  // get a new region and OR in the limits.
  if Assigned(NewRegion()) then
  begin
    if not Boolean(OrRectRegion(New_Region, @My_Rectangle)) then
    begin
      DisposeRegion(New_Region);
      New_Region := nil;
    end;
  end;

  // Install the new region, and return any existing region.
  // If the above allocation and region processing failed, then
  // New_Region will be NULL and no clip region will be installed.
  ClipWindow := InstallClipRegion(Win^.WLayer, New_Region);
end;

{ ClipWindowToBorders()
 clip a window to its borders. The removed region is returned so that it may be re-installed later.}
function ClipWindowToBorders(Win: PWindow): PRegion;
begin
  ClipWindowToBorders := ClipWindow(Win, Win^.BorderLeft, Win^.BorderTop, Win^.Width - Win^.BorderRight - 1, Win^.Height - Win^.BorderBottom - 1);
end;

// Wait for the user to select the close gadget.
procedure Wait_For_Close(win: PWindow);
var
  Msg: PIntuiMessage;
  Done: Boolean;
begin
  Done := False;
  while not Done do
  begin
    // we only have one signal bit, so we do not have to check which bit broke the Wait().
    Wait(1 shl win^.UserPort^.mp_SigBit);
    repeat
      Msg := PIntuiMessage(GetMsg(win^.UserPort));
      if not Assigned(Msg) then
        Break;
      //* use a switch statement if looking for multiple event types */
      if Msg^.IClass = IDCMP_CLOSEWINDOW then
        Done := True;

      ReplyMsg(PMessage(Msg));
    until Done;
  end;
end;

{ Simple routine to blast all bits in a window with color three to show
  where the window is clipped.  After a delay, flush back to color zero
  and refresh the window borders.}
procedure Draw_In_Window(Win: PWindow; Message: AnsiString);
begin
  Write(Message, '...');
  SetRast(Win^.RPort, 3);
  DOSDelay(200);
  SetRast(Win^.RPort, 0);
  RefreshWindowFrame(Win);
  Writeln('done');
end;

{ Show drawing into an unclipped window, a window clipped to the
 borders and a window clipped to a random rectangle.  It is possible
 to clip more complex shapes by AND'ing, OR'ing and exclusive-OR'ing
 regions and rectangles to build a user clip region.

 This example assumes that old regions are not going to be re-used,
 so it simply throws them away.}
procedure Clip_Test(Win: PWindow);
var
  Old_Region: PRegion;
begin
  Draw_In_Window(Win, 'Window with no clipping');

  // if the application has never installed a user clip region, then Old_Region will be nil here.
  // Otherwise, delete the old region (you could save it and re-install it later...)
  Old_Region := ClipWindowToBorders(Win);
  if not Assigned(Old_Region) then
    DisposeRegion(Old_Region);
  Draw_In_Window(Win, 'Window clipped to window borders');
  UnclipWindow(Win);

  // here we know Old_Region will be NULL, as that is what we installed with UnclipWindow()...
  Old_Region := ClipWindow(Win,20,20,100,50);
  if not Assigned(Old_Region) then
    DisposeRegion(Old_Region);
  Draw_In_Window(Win, 'Window clipped from (20,20) to (100,50)');
  UnclipWindow(Win);

  Wait_For_Close(Win);
end;

// Open and close resources, call the test routine when ready.
procedure StartMe;
var
  Win: PWindow;
begin
  Win := OpenWindowTags(nil, [
          TAG_(WA_Width)      , AsTag(MY_WIN_WIDTH),
          TAG_(WA_Height)     , AsTag(MY_WIN_HEIGHT),
          TAG_(WA_IDCMP)      , AsTag(IDCMP_CLOSEWINDOW),
          TAG_(WA_CloseGadget), AsTag(True),
          TAG_(WA_DragBar)    , AsTag(True),
          TAG_(WA_Activate)   , AsTag(True),
          TAG_END]);
  if Assigned(Win) then
  begin
    Clip_Test(Win);
    CloseWindow(Win);
  end;
end;

begin
  StartMe
end.


InstallLayerHook

safely install a new TLayer.BackFill hook

Declaration

Source position: layers.pas line 122

function InstallLayerHook(

  Layer: PLayer;

  Hook: PHook

):PHook;

Arguments

Layer | pointer to the layer in which to install the Backfill Hook.
Hook | pointer to layer callback Hook which will be called

Function result

pointer to the TLayer.BackFill Hook that was previously active. Returns nil if it was the default hook. In V39, it could return 1 if there was no hook.

Description

Installs a new TLayer.BackFill Hook, waiting until it is safe to do so. Locks the layer while substituting the new Hook and removing the old one. If a new Hook is not provided, will install the default layer BackFill Hook.

Hook will be called with:

object = PRastPort(Result^.RastPort);
message = [ layer: PLayer, bounds: TRectangle, offsetx: LongInt, offsety: LongInt;]

This hook should fill the Rectangle in the RastPort with the BackFill pattern appropriate for offset x/y.

If hook is LAYERS_BACKFILL, the default backfill is used for the layer.

If hook is LAYERS_NOBACKFILL, the layer will not be backfilled (NO-OP).

Attention

The RastPort you are passed back is the same one passed to the function. You should not use "layered" rendering functions on this RastPort. Generally, you will wish to do BitMap operations such as BltBitMap(). The callback is a raw, low-level rendering call-back. If you need to call a rendering operation with a RastPort, make sure you use a copy of the RastPort and nil the Layer pointer.


InstallLayerInfoHook

Install a backfill hook for non-layer

Declaration

Source position: layers.pas line 123

function InstallLayerInfoHook(

  Li: PLayer_Info;

  const Hook: PHook

):PHook;

Arguments

Li | pointer to LayerInfo structure
Hook | pointer to layer callback Hook which will be called

Function result

Returns the backfill hook that was in the Layer_Info. Returns LAYERS_BACKFILL if the default was installed. Returns LAYERS_NOBACKFILL if there was a NO-OP hook. Returns -1 if there was some failure.

Description

This function will install a backfill hook for the Layer_Info structure passed. This backfill hook will be used to clear the background area where no layer exists. The hook function is passed the RastPort and the bounds just like the layer backfill hook. Note that this hook could be called for any layer.

Hook will be called with:

object = PRastPort(Result^.RastPort);
message = [ layer: PLayer, bounds: TRectangle, offsetx: LongInt, offsety: LongInt;]

This hook should fill the Rectangle in the RastPort with the BackFill pattern appropriate for offset x/y.

If hook is LAYERS_BACKFILL, the default backfill is used for the layer.

If hook is LAYERS_NOBACKFILL, the layer will not be backfilled (NO-OP).

Attention

When the hook is first installed, it is not called. It is up to the application to know if it is safe to fill in the area. Since the hook will be called when a layer is deleted, the easiest way to have layers call this hook is to create and delete a backdrop layer that is the size of the area.

Also, note that currently the first long word of the hook message contains an undefined value. This value may look like a layer pointer. It is not a layer pointer.

The RastPort you are passed back is the same one passed to the function. You should not use "layered" rendering functions on this RastPort. Generally, you will wish to do BitMap operations such as BltBitMap(). The callback is a raw, low-level rendering call-back. If you need to call a rendering operation with a RastPort, make sure you use a copy of the RastPort and nil the Layer pointer.


IsLayerHitable

Declaration

Source position: layers.pas line 140

function IsLayerHitable(

  L: PLayer

):LongBool;


IsLayerVisible

Declaration

Source position: layers.pas line 133

function IsLayerVisible(

  L: PLayer

):LongBool;


IsVisibleInLayer

Declaration

Source position: layers.pas line 139

function IsVisibleInLayer(

  L: PLayer;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt

):LongBool;


LockLayer

Lock layer to make changes to ClipRects.

Declaration

Source position: layers.pas line 105

procedure LockLayer(

  Dummy: LongInt;

  Layer: PLayer

);

Arguments

Dummy | unused
Layer | pointer to a layer

Description

Make this layer unavailable for other tasks to use. If another task is already using this layer then wait for it to complete and then reserve the layer for your own use. (this function does the same thing as graphics.library/LockLayerRom)

Atention

if you wish to lock more than one layer at a time, you must call LockLayerInfo() before locking those layers and then call UnlockLayerInfo() when you have finished. This is to prevent system "deadlocks".

while you hold the lock on a layer, Intuition will block on operations such as windowsizing, dragging, menus, and depth arranging windows in this layer's screen. It is recommended that you do not make Intuition function calls while the layer is locked.


LockLayerInfo

Lock the LayerInfo structure.

Declaration

Source position: layers.pas line 109

procedure LockLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to Layer_Info structure

Description

Before doing an operation that requires the LayerInfo structure, make sure that no other task is also using the LayerInfo structure. LockLayerInfo() returns when the LayerInfo belongs to this task. There should be an UnlockLayerInfo for every LockLayerInfo.

Attention

All layer routines presently LockLayerInfo() when they start up and UnlockLayerInfo() as they exit. Programmers will need to use these Lock/Unlock routines if they wish to do something with the LayerStructure that is not supported by the layer library.

See also

UnlockLayerInfo

Unlock the LayerInfo structure.


LockLayers

lock all layers from graphics output.

Declaration

Source position: layers.pas line 107

procedure LockLayers(

  Li: PLayer_Info

);

Arguments

Li

pointer to Layer_Info structure

Description

First calls LockLayerInfo() Make all layers in this layer list locked.

See also

LockLayer | Lock layer to make changes to ClipRects.
LockLayerInfo | Lock the LayerInfo structure.


LockLayerUpdates

Declaration

Source position: layers.pas line 136

procedure LockLayerUpdates(

  L: PLayer

);


MoveLayer

Move layer to new position in BitMap.

Declaration

Source position: layers.pas line 99

function MoveLayer(

  Dummy: LongInt;

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

):LongInt;

Arguments

Dummy | unused
Layer | pointer to a nonbackdrop layer
Dx | delta to add to current x position
Dy | delta to add to current y position

Function result

True if operation successful. False if failed (out of memory)

Description

Move this layer to new position in shared BitMap. If any refresh layers become revealed, collect damage and set REFRESH bit in layer Flags.

Errors

May not handle (dx,dy) which attempts to move the layer outside the layer's RastPort^.BitMap bounds .

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


MoveLayerInFrontOf

Put layer in front of another layer.

Declaration

Source position: layers.pas line 117

function MoveLayerInFrontOf(

  Layer_To_Move: PLayer;

  Other_Layer: PLayer

):LongInt;

Arguments

Layer_To_Move | pointer to layer which should be moved
Other_Layer | pointer to target layer in front of which to move layer

Function result

True if operation successful. False if operation unsuccessful (probably out of memory)

Description

Move this layer in front of target layer, swapping bits in and out of the display with other layers. If this is a refresh layer then collect damage list and set the LAYERREFRESH bit in TLayer.Flags if redraw required.

Attention

this operation may generate refresh events in other layers associated with this layer's TLayer_Info structure.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


MoveSizeLayer

Position/Size layer

Declaration

Source position: layers.pas line 119

function MoveSizeLayer(

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt;

  Dw: LongInt;

  Dh: LongInt

):LongInt;

Arguments

Layer | pointer to a nonbackdrop layer
Dx | change left corner by dx
Dy | change upper corner by dy
Dw | change size by dw
Dh | change size by dh

Function result

True if operation successful. False if failed (due to out of memory). False if failed (due to illegal layer^.bounds)

Description

Change upperleft and lower right position of Layer.


NewLayerInfo

Allocate and Initialize full Layer_Info structure.

Declaration

Source position: layers.pas line 113

function NewLayerInfo: PLayer_Info;

Function result

pointer to PLayer_Info structure if successful nil if not enough memory

Description

Allocate memory required for full PLayer_Info structure. Initialize PLayer_Info structure in preparation to use other layer operations on this list of layers. Make the PLayer_Info unlocked (open).


NEWLAYERINFO_CALLED

Declaration

Source position: layers.pas line 62

const NEWLAYERINFO_CALLED = 1;


RenderLayerInfoTagList

Declaration

Source position: layers.pas line 134

function RenderLayerInfoTagList(

  Li: PLayer_Info;

  Tags: PTagItem

):LongBool;


RenderLayerInfoTags

Declaration

Source position: layers.pas line 143

function RenderLayerInfoTags(

  Li: PLayer_Info;

  const Tags: array of PtrUInt

):LongBool;


ScrollLayer

Scroll around in a superbitmap, translate coordinates in non-superbitmap layer.

Declaration

Source position: layers.pas line 101

procedure ScrollLayer(

  Dummy: LongInt;

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Dummy | unused
Layer | pointer to a layer
Dx | delta to add to current x scroll value
Dy | delta to add to current y scroll value

Description

For a SuperBitMap Layer:

Update the SuperBitMap from the layer display, then copy bits between Layer and SuperBitMap to reposition layer over different portion of SuperBitMap.

For nonSuperBitMap layers, all (x,y) pairs are adjusted by the scroll(x,y) value in the layer. To cause (0,0) to actually be drawn at (3,10) use ScrollLayer(-3,-10). This can be useful along with InstallClipRegion to simulate Intuition GZZWindows without the overhead of an extra layer.

Errors

ay not handle (dx,dy) which attempts to move the layer outside the layer's SuperBitMap bounds.


SizeLayer

Change the size of this nonbackdrop layer.

Declaration

Source position: layers.pas line 100

function SizeLayer(

  Dummy: LongInt;

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

):LongInt;

Arguments

Dummy | unused
Layer | pointer to a nonbackdrop layer
Dx | delta to add to current x size
Dy | delta to add to current y size

Function result

True if operation successful. False if failed (out of memory)

Description

Change the size of this layer by (dx,dy). The lower right hand corner is extended to make room for the larger layer. If there is SuperBitMap for this layer then copy pixels into or out of the layer depending on whether the layer increases or decreases in size. Collect damage list for those layers that may need to be refreshed if damage occurred.


SortLayerCR

Declaration

Source position: layers.pas line 124

procedure SortLayerCR(

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

);


SwapBitsRastPortClipRect

Swap bits between common bitmap and obscured ClipRect

Declaration

Source position: layers.pas line 110

procedure SwapBitsRastPortClipRect(

  Rp: PRastPort;

  Cr: PClipRect

);

Arguments

Rp | pointer to rastport
Cr | pointer to cliprect to swap bits with

Description

Support routine useful for those that need to do some operations not done by the layer library. Allows programmer to swap the contents of a small BitMap with a subsection of the display. This is accomplished without using extra memory. The bits in the display RastPort are exchanged with the bits in the ClipRect's BitMap.

Note: the ClipRect structures which the layer library allocates are actually a little bigger than those described in the graphics/clip.h include file. So be warned that it is not a good idea to have instances of cliprects in your code.

Attention

Because the blit operation started by this function is done asynchronously, it is imperative that a WaitBlit() be performed before releasing or using the processor to modify any of the associated structures.


ThinLayerInfo

convert 1.1 LayerInfo to 1.0 LayerInfo. Obsolete

Declaration

Source position: layers.pas line 116

procedure ThinLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to LayerInfo structure

Description

Obsolete

return the extra memory needed that was allocated with FattenLayerInfo. This is must be done prior to freeing the Layer_Info structure itself. V1.1 software should be using DisposeLayerInfo.

See also

DisposeLayerInfo | Return all memory for LayerInfo to memory pool
FattenLayerInfo | convert 1.0 LayerInfo to 1.1 LayerInfo Obsolete


UnlockLayer

Unlock layer and allow graphics routines to use it.

Declaration

Source position: layers.pas line 106

procedure UnlockLayer(

  Layer: PLayer

);

Arguments

Layer

pointer to a layer

Description

When finished changing the ClipRects or whatever you were doing with this layer you must call UnlockLayer() to allow other tasks to proceed with graphic output to the layer.


UnlockLayerInfo

Unlock the LayerInfo structure.

Declaration

Source position: layers.pas line 112

procedure UnlockLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to the Layer_Info structure

Description

After the operation is complete that required a LockLayerInfo, unlock the LayerInfo structure so that other tasks may affect the layers.


UnlockLayers

Unlock all layers from graphics output. Restart graphics output to layers that have been waiting

Declaration

Source position: layers.pas line 108

procedure UnlockLayers(

  Li: PLayer_Info

);

Arguments

Li

pointer to the Layer_Info structure

Description

Make all layers in this layer list unlocked. Then call UnlockLayerInfo

See also

LockLayers | lock all layers from graphics output.
UnlockLayer | Unlock layer and allow graphics routines to use it.


UnlockLayerUpdates

Declaration

Source position: layers.pas line 137

procedure UnlockLayerUpdates(

  L: PLayer

);


UpfrontLayer

Put layer in front of all other layers.

Declaration

Source position: layers.pas line 97

function UpfrontLayer(

  Dummy: LongInt;

  Layer: PLayer

):LongInt;

Arguments

Dummy | unused
Layer | pointer to a nonbackdrop layer

Function result

True if operation successful. False if operation unsuccessful (probably out of memory)

Description

Move this layer to the most upfront position swapping bits in and out of the display with other layers. If this is a refresh layer then collect damage list and set the LAYERREFRESH bit in layer->Flags if redraw required. By clearing the BACKDROP bit in the layers Flags you may bring a Backdrop layer up to the front of all other layers.

Attention

This operation may generate refresh events in other layers associated with this layer's Layer_Info structure.


WhichLayer

Which Layer is this point in?

Declaration

Source position: layers.pas line 111

function WhichLayer(

  Li: PLayer_Info;

  X: LongInt;

  Y: LongInt

):PLayer;

Arguments

Li | pointer to LayerInfo structure
X | x coordinate in the BitMap
Y | y coordinate in the BitMap

Function result

pointer to the topmost layer that this point is in nil if this point is not in a layer

Description

Starting at the topmost layer check to see if this point (x,y) occurs in this layer. If it does return the pointer to this layer. Return nil if there is no layer at this point.


WhichLayerBehindLayer

Declaration

Source position: layers.pas line 132

function WhichLayerBehindLayer(

  L: PLayer;

  X: LongInt;

  Y: LongInt

):PLayer;


Reference for unit 'locale': Procedures and functions

CloseCatalog

CloseLocale

ConvertUCS4ToUTF8

ConvertUTF8ToUCS4

ConvToLower

ConvToUpper

FormatClockData

FormatDate

FormatString

GetCatalogStr

GetLocaleStr

IsAlNum

IsAlpha

IsCntrl

IsDigit

IsGraph

IsLower

IsPrint

IsPunct

IsSpace

IsUnicode

IsUpper

IsXDigit

OpenCatalog

OpenCatalogA

OpenLocale

ParseDate

StrConvert

StrnCmp

UCS4_CanonicalDecompose

UCS4_Compare

UCS4_ConvToLower

UCS4_ConvToUpper

UCS4_Decompose

UCS4_FormatClockData

UCS4_FormatDate

UCS4_FormatString

UCS4_GetCatalogStr

UCS4_GetCombiningClass

UCS4_GetLocaleStr

UCS4_IsAlNum

UCS4_IsAlpha

UCS4_IsCntrl

UCS4_IsCombining

UCS4_IsDigit

UCS4_IsGraph

UCS4_IsLower

UCS4_IsNSM

UCS4_IsPrint

UCS4_IsPunct

UCS4_IsSpace

UCS4_IsUpper

UCS4_IsXDigit

UCS4_Normalize

UCS4_NormalizedLength

UCS4_StrnCmp

UCS4_StrToLower

UCS4_StrToUpper

UTF8_CheckEncoding

UTF8_Decode

UTF8_DecodeSafe

UTF8_Encode

UTF8_EncodingLength


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'locale': Variables

LocaleBase


Index of all identifiers in unit 'locale'

A C D F G H I L M N O P S T U Y

A

ABDAY_1 | ABMON_1 | ABMON_5
ABDAY_2 | ABMON_10 | ABMON_6
ABDAY_3 | ABMON_11 | ABMON_7
ABDAY_4 | ABMON_12 | ABMON_8
ABDAY_5 | ABMON_2 | ABMON_9
ABDAY_6 | ABMON_3 | AM_STR
ABDAY_7 | ABMON_4 |

C

CloseCatalog | CODESET_UTF8 | CT_7MON
CloseLocale | ConvertUCS4ToUTF8 | CT_7SAT
CLOSEQUOTE | ConvertUTF8ToUCS4 | CT_7SUN
CODESET_COUNT | ConvToLower | CT_7THU
CODESET_LATIN1 | ConvToUpper | CT_7TUE
CODESET_LEGACY | CSP_PRECEDES | CT_7WED
CODESET_UCS4 | CSP_SUCCEEDS |
CODESET_UTF32 | CT_7FRI |

D

DAY_1 | DAY_4 | DAY_7
DAY_2 | DAY_5 |
DAY_3 | DAY_6 |

F

FormatClockData | FormatString
FormatDate | FUTURESTR

G

GetCatalogStr GetLocaleStr

H

HARDHYPHEN

I

IsAlNum | IsGraph | IsSpace
IsAlpha | IsLower | IsUnicode
IsCntrl | IsPrint | IsUpper
IsDigit | IsPunct | IsXDigit

L

LocaleBase LOCALENAME

M

MAXSTRMSG | MON_3 | MON_9
MON_1 | MON_4 | MS_AMERICAN
MON_10 | MON_5 | MS_BRITISH
MON_11 | MON_6 | MS_IMPERIAL
MON_12 | MON_7 | MS_ISO
MON_2 | MON_8 |

N

NOSTR

O

OC_BuiltInCodeSet | OC_Language | OpenCatalogA
OC_BuiltInLanguage | OC_TagBase | OpenLocale
OC_BuiltInStrings | OC_Version | OPENQUOTE
OC_CodeSet | OpenCatalog |

P

ParseDate | PLocale | PM_STR
PCatalog | PLocaleBase |

S

SC_ASCII | SP_PARENS | SS_NOSPACE
SC_COLLATE1 | SP_PREC_ALL | SS_SPACE
SC_COLLATE2 | SP_PREC_CURR | StrConvert
SC_UNICODE | SP_SUCC_ALL | StrnCmp
SOFTHYPHEN | SP_SUCC_CURR |

T

TCatalog | TLocaleBase | TOMORROWSTR
TLocale | TODAYSTR |

U

UCF_IGNORE_CASE | UCS4_IsCombining | UNICODE_16_BE
UCS4_CanonicalDecompose | UCS4_IsDigit | UNICODE_16_LE
UCS4_Compare | UCS4_IsGraph | UNICODE_32_BE
UCS4_ConvToLower | UCS4_IsLower | UNICODE_32_LE
UCS4_ConvToUpper | UCS4_IsNSM | UNICODE_INVALID
UCS4_Decompose | UCS4_IsPrint | UNICODE_NFD
UCS4_FormatClockData | UCS4_IsPunct | UNICODE_NFKD
UCS4_FormatDate | UCS4_IsSpace | UNICODE_UTF8
UCS4_FormatString | UCS4_IsUpper | UTF8_CheckEncoding
UCS4_GetCatalogStr | UCS4_IsXDigit | UTF8_Decode
UCS4_GetCombiningClass | UCS4_Normalize | UTF8_DecodeSafe
UCS4_GetLocaleStr | UCS4_NormalizedLength | UTF8_Encode
UCS4_IsAlNum | UCS4_StrnCmp | UTF8_EncodingLength
UCS4_IsAlpha | UCS4_StrToLower |
UCS4_IsCntrl | UCS4_StrToUpper |

Y

YESSTR YESTERDAYSTR


CloseCatalog

Declaration

Source position: locale.pas line 239

procedure CloseCatalog(

  Catalog: PCatalog

);


CloseLocale

Declaration

Source position: locale.pas line 240

procedure CloseLocale(

  Locale: PLocale

);


ConvertUCS4ToUTF8

Declaration

Source position: locale.pas line 291

function ConvertUCS4ToUTF8(

  Src: PWideChar;

  Dst: PChar;

  Length: LongInt

):LongWord;


ConvertUTF8ToUCS4

Declaration

Source position: locale.pas line 290

function ConvertUTF8ToUCS4(

  Src: PChar;

  Dst: PWideChar;

  Length: LongInt

):LongWord;


ConvToLower

Declaration

Source position: locale.pas line 241

function ConvToLower(

  Locale: PLocale;

  Character: LongWord

):LongWord;


ConvToUpper

Declaration

Source position: locale.pas line 242

function ConvToUpper(

  Locale: PLocale;

  Character: LongWord

):LongWord;


FormatClockData

Declaration

Source position: locale.pas line 300

procedure FormatClockData(

  Locale: PLocale;

  FormatString: PChar;

  CData: PClockData;

  Hook: PHook

);


FormatDate

Declaration

Source position: locale.pas line 243

procedure FormatDate(

  Locale: PLocale;

  FmtTemplate: PChar;

  Date: PDateStamp;

  PutCharFunc: PHook

);


FormatString

Declaration

Source position: locale.pas line 244

function FormatString(

  Locale: PLocale;

  FmtTemplate: PChar;

  DataStream: Pointer;

  PutCharFunc: PHook

):Pointer;


GetCatalogStr

Declaration

Source position: locale.pas line 245

function GetCatalogStr(

  Catalog: PCatalog;

  StringNum: LongInt;

  DefaultString: PChar

):PChar;


GetLocaleStr

Declaration

Source position: locale.pas line 246

function GetLocaleStr(

  Locale: PLocale;

  StringNum: LongWord

):PChar;


IsAlNum

Declaration

Source position: locale.pas line 247

function IsAlNum(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsAlpha

Declaration

Source position: locale.pas line 248

function IsAlpha(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsCntrl

Declaration

Source position: locale.pas line 249

function IsCntrl(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsDigit

Declaration

Source position: locale.pas line 250

function IsDigit(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsGraph

Declaration

Source position: locale.pas line 251

function IsGraph(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsLower

Declaration

Source position: locale.pas line 252

function IsLower(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsPrint

Declaration

Source position: locale.pas line 253

function IsPrint(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsPunct

Declaration

Source position: locale.pas line 254

function IsPunct(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsSpace

Declaration

Source position: locale.pas line 255

function IsSpace(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsUnicode

Declaration

Source position: locale.pas line 297

function IsUnicode(

  Buffer: Pointer;

  Length: LongWord

):LongWord;


IsUpper

Declaration

Source position: locale.pas line 256

function IsUpper(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsXDigit

Declaration

Source position: locale.pas line 257

function IsXDigit(

  Locale: PLocale;

  Character: LongWord

):LongBool;


OpenCatalog

Declaration

Source position: locale.pas line 303

function OpenCatalog(

  Locale: PLocale;

  Name: PChar;

  const Tags: array of PtrUInt

):PCatalog;


OpenCatalogA

Declaration

Source position: locale.pas line 258

function OpenCatalogA(

  Locale: PLocale;

  Name: PChar;

  Tags: PTagItem

):PCatalog;


OpenLocale

Declaration

Source position: locale.pas line 259

function OpenLocale(

  Name: PChar

):PLocale;


ParseDate

Declaration

Source position: locale.pas line 260

function ParseDate(

  Locale: PLocale;

  Date: PDateStamp;

  FmtTemplate: PChar;

  GetCharFunc: PHook

):LongBool;


StrConvert

Declaration

Source position: locale.pas line 261

function StrConvert(

  Locale: PLocale;

  String1: PChar;

  Buffer: Pointer;

  BufferSize: LongWord;

  Typ: LongWord

):LongWord;


StrnCmp

Declaration

Source position: locale.pas line 262

function StrnCmp(

  Locale: PLocale;

  String1: PChar;

  String2: PChar;

  Length: LongInt;

  Typ: LongWord

):LongInt;


UCS4_CanonicalDecompose

Declaration

Source position: locale.pas line 288

function UCS4_CanonicalDecompose(

  Ch: WideChar

):PWideChar;


UCS4_Compare

Declaration

Source position: locale.pas line 293

function UCS4_Compare(

  Locale: PLocale;

  String1: PWideChar;

  String2: PWideChar;

  Length: LongInt;

  Flags: LongWord

):LongInt;


UCS4_ConvToLower

Declaration

Source position: locale.pas line 264

function UCS4_ConvToLower(

  UCharacter: WideChar

):WideChar;


UCS4_ConvToUpper

Declaration

Source position: locale.pas line 265

function UCS4_ConvToUpper(

  UCharacter: WideChar

):WideChar;


UCS4_Decompose

Declaration

Source position: locale.pas line 286

function UCS4_Decompose(

  Ch: WideChar

):PWideChar;


UCS4_FormatClockData

Declaration

Source position: locale.pas line 301

procedure UCS4_FormatClockData(

  Locale: PLocale;

  FormatString: PWideChar;

  CData: PClockData;

  Hook: PHook

);


UCS4_FormatDate

Declaration

Source position: locale.pas line 280

procedure UCS4_FormatDate(

  Locale: PLocale;

  FmtTemplate: PWideChar;

  Date: PDateStamp;

  PutCharFunc: PHook

);


UCS4_FormatString

Declaration

Source position: locale.pas line 281

function UCS4_FormatString(

  Locale: PLocale;

  FmtTemplate: PWideChar;

  DataStream: Pointer;

  PutCharFunc: PHook

):Pointer;


UCS4_GetCatalogStr

Declaration

Source position: locale.pas line 268

function UCS4_GetCatalogStr(

  Catalog: PCatalog;

  StringNum: LongWord;

  defaultString: PWideChar

):PWideChar;


UCS4_GetCombiningClass

Declaration

Source position: locale.pas line 294

function UCS4_GetCombiningClass(

  UCharacter: WideChar

):LongWord;


UCS4_GetLocaleStr

Declaration

Source position: locale.pas line 282

function UCS4_GetLocaleStr(

  Locale: PLocale;

  StringNum: LongWord

):PWideChar;


UCS4_IsAlNum

Declaration

Source position: locale.pas line 269

function UCS4_IsAlNum(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsAlpha

Declaration

Source position: locale.pas line 270

function UCS4_IsAlpha(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsCntrl

Declaration

Source position: locale.pas line 271

function UCS4_IsCntrl(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsCombining

Declaration

Source position: locale.pas line 292

function UCS4_IsCombining(

  UCharacter: WideChar

):LongWord;


UCS4_IsDigit

Declaration

Source position: locale.pas line 272

function UCS4_IsDigit(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsGraph

Declaration

Source position: locale.pas line 273

function UCS4_IsGraph(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsLower

Declaration

Source position: locale.pas line 274

function UCS4_IsLower(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsNSM

Declaration

Source position: locale.pas line 287

function UCS4_IsNSM(

  UCharacter: WideChar

):LongBool;


UCS4_IsPrint

Declaration

Source position: locale.pas line 275

function UCS4_IsPrint(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsPunct

Declaration

Source position: locale.pas line 276

function UCS4_IsPunct(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsSpace

Declaration

Source position: locale.pas line 277

function UCS4_IsSpace(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsUpper

Declaration

Source position: locale.pas line 278

function UCS4_IsUpper(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_IsXDigit

Declaration

Source position: locale.pas line 279

function UCS4_IsXDigit(

  Locale: PLocale;

  Character: WideChar

):LongBool;


UCS4_Normalize

Declaration

Source position: locale.pas line 289

procedure UCS4_Normalize(

  Src: PWideChar;

  Dst: PWideChar;

  Length: LongInt;

  Typ: LongWord

);


UCS4_NormalizedLength

Declaration

Source position: locale.pas line 295

function UCS4_NormalizedLength(

  String1: PWideChar;

  Lenght: LongInt;

  Typ: LongWord

):LongWord;


UCS4_StrnCmp

Declaration

Source position: locale.pas line 283

function UCS4_StrnCmp(

  Locale: PLocale;

  String1: PWideChar;

  String2: PWideChar;

  Length: LongInt;

  Typ: LongWord

):LongInt;


UCS4_StrToLower

Declaration

Source position: locale.pas line 284

function UCS4_StrToLower(

  Locale: PLocale;

  String1: PWideChar;

  buffer: PWideChar;

  BufferSize: LongWord;

  Typ: LongWord

):LongInt;


UCS4_StrToUpper

Declaration

Source position: locale.pas line 285

function UCS4_StrToUpper(

  Locale: PLocale;

  String1: PWideChar;

  buffer: PWideChar;

  BufferSize: LongWord;

  Typ: LongWord

):LongInt;


UTF8_CheckEncoding

Declaration

Source position: locale.pas line 296

function UTF8_CheckEncoding(

  String1: PChar;

  Length: LongInt

):LongInt;


UTF8_Decode

Declaration

Source position: locale.pas line 266

function UTF8_Decode(

  UTF8: PChar;

  UCharacter: PWideChar

):LongWord;


UTF8_DecodeSafe

Declaration

Source position: locale.pas line 299

function UTF8_DecodeSafe(

  Src: PChar;

  Dest: PWideChar;

  Length: LongWord

):LongWord;


UTF8_Encode

Declaration

Source position: locale.pas line 267

function UTF8_Encode(

  UCharacter: WideChar;

  UTF8: PChar

):LongWord;


UTF8_EncodingLength

Declaration

Source position: locale.pas line 298

function UTF8_EncodingLength(

  Utf32: WideChar

):LongWord;


Reference for unit 'mui': Procedures and functions

InitMUIMasterLibrary

MAKE_ID

MUIAreaData

MUIget

MUIGlobalInfo

MUINotifyData

MUIPen

MUIRenderInfo

MUIset

MUIUserData

MUIV_Window_AltHeight_MinMax

MUIV_Window_AltHeight_Screen

MUIV_Window_AltHeight_Visible

MUIV_Window_AltTopEdge_Delta

MUIV_Window_AltWidth_MinMax

MUIV_Window_AltWidth_Screen

MUIV_Window_AltWidth_Visible

MUIV_Window_Height_MinMax

MUIV_Window_Height_Screen

MUIV_Window_Height_Visible

MUIV_Window_TopEdge_Delta

MUIV_Window_Width_MinMax

MUIV_Window_Width_Screen

MUIV_Window_Width_Visible

MUI_AddClipping

MUI_AddClipRegion

MUI_AllocAslRequest

MUI_AllocAslRequestTags

MUI_AslRequest

MUI_AslRequestTags

MUI_BeginRefresh

MUI_CreateCustomClass

MUI_DeleteCustomClass

MUI_DisposeObject

MUI_EndRefresh

MUI_Error

MUI_FreeAslRequest

MUI_FreeClass

MUI_GetClass

MUI_Layout

MUI_MakeObject

MUI_MakeObjectA

MUI_NewObject

MUI_NewObjectA

MUI_ObtainPen

MUI_Redraw

MUI_RejectIDCMP

MUI_ReleasePen

MUI_RemoveClipping

MUI_RemoveClipRegion

MUI_Request

MUI_RequestA

MUI_RequestIDCMP

MUI_SetError

OBJ_AddLeft

OBJ_AddTop

OBJ_App

OBJ_Between

OBJ_Bottom

OBJ_DefHeight

OBJ_DefWidth

OBJ_Dri

OBJ_Flags

OBJ_Font

OBJ_Height

OBJ_IsInObject

OBJ_Left

OBJ_MaxHeight

OBJ_MaxWidth

OBJ_MBottom

OBJ_MHeight

OBJ_MinHeight

OBJ_MinWidth

OBJ_MLeft

OBJ_MRight

OBJ_MTop

OBJ_MWidth

OBJ_Pens

OBJ_Right

OBJ_Rp

OBJ_Screen

OBJ_SubHeight

OBJ_SubWidth

OBJ_Top

OBJ_Width

OBJ_Win

OBJ_Window


Unit 'mui' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'mui': Variables

MUIMasterBase


Index of all identifiers in unit 'mui'

I M O P T

I

InitMUIMasterLibrary

M

MADF_DRAWOBJECT | MUIA_Virtgroup_Input | MUIM_Group_Sort
MADF_DRAWUPDATE | MUIA_Virtgroup_Left | MUIM_HandleEvent
MAKE_ID | MUIA_Virtgroup_Top | MUIM_HandleInput
MBQF_HORIZ | MUIA_Virtgroup_Width | MUIM_Hide
MBQ_MUI_MAXMAX | MUIA_Weight | MUIM_Import
MC_TEMPLATE_ID | MUIA_Width | MUIM_KillNotify
MPEN_BACKGROUND | MUIA_Window | MUIM_KillNotifyObj
MPEN_COUNT | MUIA_Window_Activate | MUIM_List_Clear
MPEN_FILL | MUIA_Window_ActiveObject | MUIM_List_CreateImage
MPEN_HALFSHADOW | MUIA_Window_AltHeight | MUIM_List_DeleteImage
MPEN_HALFSHINE | MUIA_Window_AltLeftEdge | MUIM_List_Exchange
MPEN_MARK | MUIA_Window_AltTopEdge | MUIM_List_GetEntry
MPEN_SHADOW | MUIA_Window_AltWidth | MUIM_List_Insert
MPEN_SHINE | MUIA_Window_AppWindow | MUIM_List_InsertSingle
MPEN_TEXT | MUIA_Window_Backdrop | MUIM_List_Jump
MUIA_Aboutmui_Application | MUIA_Window_Borderless | MUIM_List_Move
MUIA_Application_Active | MUIA_Window_CloseGadget | MUIM_List_NextSelected
MUIA_Application_Author | MUIA_Window_CloseRequest | MUIM_List_Redraw
MUIA_Application_Base | MUIA_Window_DefaultObject | MUIM_List_Remove
MUIA_Application_Broker | MUIA_Window_DepthGadget | MUIM_List_Select
MUIA_Application_BrokerHook | MUIA_Window_DragBar | MUIM_List_Sort
MUIA_Application_BrokerPort | MUIA_Window_FancyDrawing | MUIM_List_TestPos
MUIA_Application_BrokerPri | MUIA_Window_Height | MUIM_Menustrip_ExitChange
MUIA_Application_Commands | MUIA_Window_ID | MUIM_Menustrip_InitChange
MUIA_Application_Copyright | MUIA_Window_InputEvent | MUIM_MultiSet
MUIA_Application_Description | MUIA_Window_IsSubWindow | MUIM_NoNotifySet
MUIA_Application_DiskObject | MUIA_Window_LeftEdge | MUIM_Notify
MUIA_Application_DoubleStart | MUIA_Window_MenuAction | MUIM_Numeric_Decrease
MUIA_Application_DropObject | MUIA_Window_Menustrip | MUIM_Numeric_Increase
MUIA_Application_ForceQuit | MUIA_Window_MouseObject | MUIM_Numeric_ScaleToValue
MUIA_Application_HelpFile | MUIA_Window_NeedsMouseObject | MUIM_Numeric_SetDefault
MUIA_Application_Iconified | MUIA_Window_NoMenus | MUIM_Numeric_Stringify
MUIA_Application_MenuAction | MUIA_WindowObject | MUIM_Numeric_ValueToScale
MUIA_Application_MenuHelp | MUIA_Window_Open | MUIM_Pendisplay_SetColormap
MUIA_Application_Menustrip | MUIA_Window_PublicScreen | MUIM_Pendisplay_SetMUIPen
MUIA_ApplicationObject | MUIA_Window_RefWindow | MUIM_Pendisplay_SetRGB
MUIA_Application_RexxHook | MUIA_Window_RootObject | MUIM_Popstring_Close
MUIA_Application_RexxMsg | MUIA_Window_Screen | MUIM_Popstring_Open
MUIA_Application_RexxString | MUIA_Window_ScreenTitle | MUIM_Prop_Decrease
MUIA_Application_SingleTask | MUIA_Window_SizeGadget | MUIM_Prop_Increase
MUIA_Application_Sleep | MUIA_Window_SizeRight | MUIMRI_RECTFILL
MUIA_Application_Title | MUIA_Window_Sleep | MUIMRI_REFRESHMODE
MUIA_Application_UseCommodities | MUIA_Window_Title | MUIMRI_THINFRAMES
MUIA_Application_UsedClasses | MUIA_Window_TopEdge | MUIMRI_TRUECOLOR
MUIA_Application_UseRexx | MUIA_Window_UseBottomBorderScroller | MUIM_Semaphore_Attempt
MUIA_Application_Version | MUIA_Window_UseLeftBorderScroller | MUIM_Semaphore_AttemptShared
MUIA_Application_Window | MUIA_Window_UseRightBorderScroller | MUIM_Semaphore_Obtain
MUIA_Application_WindowList | MUIA_Window_Width | MUIM_Semaphore_ObtainShared
MUIA_AppMessage | MUIA_Window_Window | MUIM_Semaphore_Release
MUIA_Background | MUI_BeginRefresh | MUIM_Set
MUIA_Balance_Quiet | MUIC_Aboutmui | MUIM_SetAsString
MUIA_Bitmap_Alpha | MUIC_Application | MUIM_Settingsgroup_ConfigToGadgets
MUIA_Bitmap_Bitmap | MUIC_Applist | MUIM_Settingsgroup_GadgetsToConfig
MUIA_Bitmap_Height | MUIC_Area | MUIM_SetUData
MUIA_Bitmap_MappingTable | MUIC_Balance | MUIM_SetUDataOnce
MUIA_Bitmap_Precision | MUIC_Bitmap | MUIM_Setup
MUIA_Bitmap_RemappedBitmap | MUIC_Bodychunk | MUIM_Show
MUIA_Bitmap_SourceColors | MUIC_Boopsi | MUIM_UpdateConfig
MUIA_Bitmap_Transparent | MUIC_Cclist | MUIM_Window_AddEventHandler
MUIA_Bitmap_UseFriend | MUIC_Coloradjust | MUIM_Window_Cleanup
MUIA_Bitmap_Width | MUIC_Colorfield | MUIM_Window_RemEventHandler
MUIA_Bodychunk_Body | MUIC_Configdata | MUIM_Window_ScreenToBack
MUIA_Bodychunk_Compression | MUIC_Cycle | MUIM_Window_ScreenToFront
MUIA_Bodychunk_Depth | MUIC_Dataspace | MUIM_Window_Setup
MUIA_Bodychunk_Masking | MUIC_Dirlist | MUIM_Window_Snapshot
MUIA_Boopsi_Class | MUIC_Dtpic | MUIM_Window_ToBack
MUIA_Boopsi_ClassID | MUIC_Family | MUIM_Window_ToFront
MUIA_Boopsi_MaxHeight | MUICFG_PublicScreen | MUIM_WriteLong
MUIA_Boopsi_MaxWidth | MUIC_Floattext | MUIM_WriteString
MUIA_Boopsi_MinHeight | MUIC_Frameadjust | MUI_NewObject
MUIA_Boopsi_MinWidth | MUIC_Framedisplay | MUI_NewObjectA
MUIA_Boopsi_Object | MUIC_Gadget | MUINotifyData
MUIA_Boopsi_Remember | MUIC_Gauge | MUIO_BarTitle
MUIA_Boopsi_Smart | MUIC_Group | MUI_ObtainPen
MUIA_Boopsi_TagDrawInfo | MUIC_Image | MUIO_Button
MUIA_Boopsi_TagScreen | MUIC_Imageadjust | MUIO_Checkmark
MUIA_Boopsi_TagWindow | MUIC_Imagedisplay | MUIO_Cycle
MUIA_BottomEdge | MUIC_Knob | MUIO_HBar
MUIA_Coloradjust_Blue | MUIC_Levelmeter | MUIO_HSpace
MUIA_Coloradjust_Green | MUIC_List | MUIO_Label
MUIA_Coloradjust_ModeID | MUIC_Listview | MUIO_Label_Centered
MUIA_Coloradjust_Red | MUIC_Mccprefs | MUIO_Label_DoubleFrame
MUIA_Coloradjust_RGB | MUIC_Menu | MUIO_Label_FreeVert
MUIA_Colorfield_Blue | MUIC_Menubar | MUIO_Label_LeftAligned
MUIA_Colorfield_Green | MUIC_Menuitem | MUIO_Label_SingleFrame
MUIA_Colorfield_Pen | MUIC_Menustrip | MUIO_Menuitem
MUIA_Colorfield_Red | MUIC_Notify | MUIO_Menuitem_CopyStrings
MUIA_Colorfield_RGB | MUIC_Numeric | MUIO_MenustripNM
MUIA_ContextMenu | MUIC_Numericbutton | MUIO_MenustripNM_CommandKeyCheck
MUIA_ContextMenuTrigger | MUIC_Palette | MUIO_NumericButton
MUIA_ControlChar | MUIC_Penadjust | MUIO_PopButton
MUIA_Cycle_Active | MUIC_Pendisplay | MUIO_Radio
MUIA_CycleChain | MUIC_Popasl | MUIO_Slider
MUIA_Cycle_Entries | MUIC_Popframe | MUIO_String
MUIA_Dataspace_Pool | MUIC_Popimage | MUIO_VBar
MUI_AddClipping | MUIC_Poplist | MUIO_VSpace
MUI_AddClipRegion | MUIC_Popobject | MUIP_BoopsiQuery
MUIA_Dirlist_AcceptPattern | MUIC_Poppen | MUIP_Dirlist_ReRead
MUIA_Dirlist_Directory | MUIC_Popscreen | MUIPen
MUIA_Dirlist_DrawersOnly | MUIC_Popstring | MUIPEN_MASK
MUIA_Dirlist_FilesOnly | MUIC_Prop | MUIP_Pendisplay_SetColormap
MUIA_Dirlist_FilterDrawers | MUIC_Radio | MUIP_Pendisplay_SetMUIPen
MUIA_Dirlist_FilterHook | MUI_CreateCustomClass | MUIP_Pendisplay_SetRGB
MUIA_Dirlist_MultiSelDirs | MUIC_Rectangle | MUI_Redraw
MUIA_Dirlist_NumBytes | MUIC_Register | MUI_RejectIDCMP
MUIA_Dirlist_NumDrawers | MUIC_Scale | MUI_ReleasePen
MUIA_Dirlist_NumFiles | MUIC_Scrmodelist | MUI_RemoveClipping
MUIA_Dirlist_Path | MUIC_Scrollbar | MUI_RemoveClipRegion
MUIA_Dirlist_RejectIcons | MUIC_Scrollgroup | MUIRenderInfo
MUIA_Dirlist_RejectPattern | MUIC_Semaphore | MUI_Request
MUIA_Dirlist_SortDirs | MUIC_Settings | MUI_RequestA
MUIA_Dirlist_SortHighLow | MUIC_Settingsgroup | MUI_RequestIDCMP
MUIA_Dirlist_SortType | MUIC_Slider | MUI_RXERR_BADDEFINITION
MUIA_Dirlist_Status | MUIC_String | MUI_RXERR_BADSYNTAX
MUIA_Disabled | MUIC_Text | MUI_RXERR_OUTOFMEMORY
MUIA_DoubleBuffer | MUIC_Virtgroup | MUI_RXERR_UNKNOWNCOMMAND
MUIA_Draggable | MUIC_Volumelist | MUIset
MUIA_Dropable | MUIC_Window | MUI_SetError
MUIA_Dtpic_Name | MUI_DeleteCustomClass | MUI_TRUE
MUIA_Family_Child | MUI_DisposeObject | MUIUserData
MUIA_Family_List | MUI_EHF_ALWAYSKEYS | MUIV_Application_OCW_ScreenPage
MUIA_FillArea | MUIE_InvalidWindowObject | MUIV_Application_ReturnID_Quit
MUIA_FixHeight | MUIE_MissingLibrary | MUIV_ContextMenuBuild_Default
MUIA_FixHeightTxt | MUI_END | MUIV_CreateBubble_DontHidePointer
MUIA_FixWidth | MUI_EndRefresh | MUIV_Cycle_Active_Next
MUIA_FixWidthTxt | MUIE_NoARexx | MUIV_Cycle_Active_Prev
MUIA_Floattext_Justify | MUIE_OK | MUIV_Dirlist_SortDirs_First
MUIA_Floattext_SkipChars | MUIE_OutOfGfxMemory | MUIV_Dirlist_SortDirs_Last
MUIA_Floattext_TabSize | MUIE_OutOfMemory | MUIV_Dirlist_SortDirs_Mix
MUIA_Floattext_Text | MUI_Error | MUIV_Dirlist_SortType_Date
MUIA_Font | MUIE_SingleTask | MUIV_Dirlist_SortType_Name
MUIA_Frame | MUI_EventHandlerRC_Eat | MUIV_Dirlist_SortType_Size
MUIA_FrameDynamic | MUI_FALSE | MUIV_Dirlist_Status_Invalid
MUIA_FramePhantomHoriz | MUI_FreeAslRequest | MUIV_Dirlist_Status_Reading
MUIA_FrameTitle | MUI_FreeClass | MUIV_Dirlist_Status_Valid
MUIA_FrameVisible | MUIget | MUIV_DragQuery_Accept
MUIA_Gadget_Gadget | MUI_GetClass | MUIV_DragQuery_Refuse
MUIA_Gauge_Current | MUIGlobalInfo | MUIV_DragReport_Abort
MUIA_Gauge_Divide | MUII_ArrowDown | MUIV_DragReport_Continue
MUIA_Gauge_Horiz | MUII_ArrowLeft | MUIV_DragReport_Lock
MUIA_Gauge_InfoRate | MUII_ArrowRight | MUIV_DragReport_Refresh
MUIA_Gauge_InfoText | MUII_ArrowUp | MUIV_EveryTime
MUIA_Gauge_Max | MUII_Assign | MUIV_Family_GetChild_First
MUIA_Group_ActivePage | MUII_BACKGROUND | MUIV_Family_GetChild_Iterate
MUIA_Group_Child | MUII_BARBLOCK | MUIV_Family_GetChild_Last
MUIA_Group_ChildList | MUII_BARDETAIL | MUIV_Family_GetChild_Next
MUIA_Group_Columns | MUII_ButtonBack | MUIV_Family_GetChild_Previous
MUIA_Group_Horiz | MUII_CheckMark | MUIV_Font_Big
MUIA_Group_HorizSpacing | MUII_Chip | MUIV_Font_Button
MUIA_Group_LayoutHook | MUII_Count | MUIV_Font_Fixed
MUIA_Group_PageMode | MUII_Cycle | MUIV_Font_Gauge
MUIA_Group_Rows | MUII_Disk | MUIV_Font_Inherit
MUIA_Group_SameHeight | MUII_Drawer | MUIV_Font_List
MUIA_Group_SameSize | MUII_FILL | MUIV_Font_Menudisplay
MUIA_Group_SameWidth | MUII_FILLBACK | MUIV_Font_Normal
MUIA_Group_Spacing | MUII_FILLBACK2 | MUIV_Font_Slider
MUIA_Group_VertSpacing | MUII_FILLSHINE | MUIV_Font_Tiny
MUIA_Height | MUII_GaugeEmpty | MUIV_Font_Title
MUIA_HelpLine | MUII_GaugeFull | MUIV_Frame_Button
MUIA_HelpNode | MUII_GroupBack | MUIV_Frame_Count
MUIA_HorizDisappear | MUII_HardDisk | MUIV_Frame_Gauge
MUIA_HorizWeight | MUIIHNF_TIMER | MUIV_Frame_GaugeInner
MUIA_Image_FontMatch | MUII_HSHADOWBACK | MUIV_Frame_Group
MUIA_Image_FontMatchHeight | MUII_HSHADOWSHADOW | MUIV_Frame_ImageButton
MUIA_Image_FontMatchWidth | MUII_HSHINEBACK | MUIV_Frame_InputList
MUIA_Image_FreeHoriz | MUII_HSHINESHINE | MUIV_Frame_Menudisplay
MUIA_Image_FreeVert | MUII_ImageButtonBack | MUIV_Frame_MenudisplayMenu
MUIA_Image_OldImage | MUII_ImageSelectedBack | MUIV_Frame_None
MUIA_Image_Spec | MUII_LASTPAT | MUIV_Frame_Page
MUIA_Image_State | MUII_ListBack | MUIV_Frame_PopUp
MUIA_InnerBottom | MUII_ListCursor | MUIV_Frame_Prop
MUIA_InnerLeft | MUII_ListSelCur | MUIV_Frame_PropKnob
MUIA_InnerRight | MUII_ListSelect | MUIV_Frame_ReadList
MUIA_InnerTop | MUII_MARKBACKGROUND | MUIV_Frame_Register
MUIA_InputMode | MUII_MARKHALFSHINE | MUIV_Frame_Requester
MUIA_LeftEdge | MUII_MARKSHINE | MUIV_Frame_Slider
MUIA_Levelmeter_Label | MUII_Menudisplay | MUIV_Frame_SliderKnob
MUIA_List_Active | MUII_Network | MUIV_Frame_String
MUIA_List_AdjustHeight | MUII_PageBack | MUIV_Frame_Text
MUIA_List_AdjustWidth | MUII_PopDrawer | MUIV_Frame_Virtual
MUIA_List_AutoVisible | MUII_PopFile | MUIV_Frame_Window
MUIA_List_CompareHook | MUII_PopFont | MUIV_Group_ActivePage_Advance
MUIA_List_ConstructHook | MUII_PopUp | MUIV_Group_ActivePage_First
MUIA_List_DestructHook | MUII_PopupBack | MUIV_Group_ActivePage_Last
MUIA_List_DisplayHook | MUII_PropBack | MUIV_Group_ActivePage_Next
MUIA_List_DragSortable | MUII_PropKnob | MUIV_Group_ActivePage_Prev
MUIA_List_DropMark | MUII_PullOpen | MUIV_Group_GetChild_First
MUIA_List_Entries | MUII_RadioButton | MUIV_Group_GetChild_Iterate
MUIA_List_First | MUII_ReadListBack | MUIV_Group_GetChild_Last
MUIA_List_Format | MUII_RegisterBack | MUIV_Group_GetChild_Next
MUIA_List_InsertPosition | MUII_RequesterBack | MUIV_Group_GetChild_Previous
MUIA_List_MinLineHeight | MUII_SelectedBack | MUIV_Imageadjust_Type_All
MUIA_List_MultiTestHook | MUII_SHADOW | MUIV_Imageadjust_Type_Background
MUIA_List_Pool | MUII_SHADOWBACK | MUIV_Imageadjust_Type_Image
MUIA_List_PoolPuddleSize | MUII_SHADOWFILL | MUIV_Imageadjust_Type_Pen
MUIA_List_PoolThreshSize | MUII_SHADOWSHINE | MUIV_InputMode_Immediate
MUIA_List_Quiet | MUII_SHINE | MUIV_InputMode_None
MUIA_List_ShowDropMarks | MUII_SHINEBACK | MUIV_InputMode_RelVerify
MUIA_List_SourceArray | MUII_SliderBack | MUIV_InputMode_Toggle
MUIA_List_Title | MUII_SliderKnob | MUIV_List_Active_Bottom
MUIA_Listview_ClickColumn | MUII_StringActiveBack | MUIV_List_Active_Down
MUIA_Listview_DefClickColumn | MUII_StringBack | MUIV_List_Active_Off
MUIA_Listview_DoubleClick | MUII_TapeDown | MUIV_List_Active_PageDown
MUIA_Listview_DragType | MUII_TapePause | MUIV_List_Active_PageUp
MUIA_Listview_Input | MUII_TapePlay | MUIV_List_Active_Top
MUIA_Listview_List | MUII_TapePlayBack | MUIV_List_Active_Up
MUIA_Listview_MultiSelect | MUII_TapeRecord | MUIV_List_ConstructHook_String
MUIA_Listview_ScrollerPos | MUII_TapeStop | MUIV_List_CopyHook_String
MUIA_Listview_SelectChange | MUII_TapeUp | MUIV_List_CursorType_Bar
MUIA_List_Visible | MUII_TextBack | MUIV_List_CursorType_None
MUI_AllocAslRequest | MUII_Volume | MUIV_List_CursorType_Rect
MUI_AllocAslRequestTags | MUII_WindowBack | MUIV_List_DestructHook_String
MUIA_MaxHeight | MUIKEY_BOTTOM | MUIV_List_EditEntry_Active
MUIA_MaxWidth | MUIKEY_COUNT | MUIV_List_Exchange_Active
MUIA_Menu_Enabled | MUIKEY_DOWN | MUIV_List_Exchange_Bottom
MUIA_Menuitem_Checked | MUIKEYF_BOTTOM | MUIV_List_Exchange_Next
MUIA_Menuitem_Checkit | MUIKEYF_DOWN | MUIV_List_Exchange_Previous
MUIA_Menuitem_CommandString | MUIKEYF_GADGET_NEXT | MUIV_List_Exchange_Top
MUIA_Menuitem_Enabled | MUIKEYF_GADGET_OFF | MUIV_List_GetEntry_Active
MUIA_Menuitem_Exclude | MUIKEYF_GADGET_PREV | MUIV_List_Insert_Active
MUIA_Menuitem_Shortcut | MUIKEYF_HELP | MUIV_List_Insert_Bottom
MUIA_Menuitem_Title | MUIKEYF_LEFT | MUIV_List_Insert_Sorted
MUIA_Menuitem_Toggle | MUIKEYF_LINEEND | MUIV_List_Insert_Top
MUIA_Menuitem_Trigger | MUIKEYF_LINESTART | MUIV_List_Jump_Active
MUIA_Menustrip_Enabled | MUIKEYF_PAGEDOWN | MUIV_List_Jump_Bottom
MUIA_Menu_Title | MUIKEYF_PAGEUP | MUIV_List_Jump_Down
MUIA_NoNotify | MUIKEYF_POPUP | MUIV_List_Jump_Top
MUIA_NoNotifyMethod | MUIKEYF_PRESS | MUIV_List_Jump_Up
MUIA_Numeric_CheckAllSizes | MUIKEYF_RIGHT | MUIV_List_Move_Active
MUIA_Numeric_Default | MUIKEYF_TOGGLE | MUIV_List_Move_Bottom
MUIA_Numeric_Format | MUIKEYF_TOP | MUIV_List_Move_Next
MUIA_Numeric_Max | MUIKEYF_UP | MUIV_List_Move_Previous
MUIA_Numeric_Min | MUIKEYF_WINDOW_CLOSE | MUIV_List_Move_Top
MUIA_Numeric_Reverse | MUIKEYF_WINDOW_NEXT | MUIV_List_NextSelected_End
MUIA_Numeric_RevLeftRight | MUIKEYF_WINDOW_PREV | MUIV_List_NextSelected_Start
MUIA_Numeric_RevUpDown | MUIKEYF_WORDLEFT | MUIV_List_Redraw_Active
MUIA_Numeric_Value | MUIKEYF_WORDRIGHT | MUIV_List_Redraw_All
MUIA_ObjectID | MUIKEY_GADGET_NEXT | MUIV_List_Remove_Active
MUIA_Palette_Entries | MUIKEY_GADGET_OFF | MUIV_List_Remove_First
MUIA_Palette_Groupable | MUIKEY_GADGET_PREV | MUIV_List_Remove_Last
MUIA_Palette_Names | MUIKEY_HELP | MUIV_List_Remove_Selected
MUIA_Parent | MUIKEY_LEFT | MUIV_List_Select_Active
MUIA_Penadjust_PSIMode | MUIKEY_LINEEND | MUIV_List_Select_All
MUIA_Pendisplay_Pen | MUIKEY_LINESTART | MUIV_List_Select_Ask
MUIA_Pendisplay_Reference | MUIKEY_NONE | MUIV_List_Select_Off
MUIA_Pendisplay_RGBcolor | MUIKEY_PAGEDOWN | MUIV_List_Select_On
MUIA_Pendisplay_Spec | MUIKEY_PAGEUP | MUIV_List_Select_Toggle
MUIA_Popasl_Active | MUIKEY_POPUP | MUIV_Listview_DragType_Immediate
MUIA_Popasl_StartHook | MUIKEY_PRESS | MUIV_Listview_DragType_None
MUIA_Popasl_StopHook | MUIKEY_RELEASE | MUIV_Listview_MultiSelect_Always
MUIA_Popasl_Type | MUIKEY_RIGHT | MUIV_Listview_MultiSelect_Default
MUIA_Poplist_Array | MUIKEY_TOGGLE | MUIV_Listview_MultiSelect_None
MUIA_Popobject_Follow | MUIKEY_TOP | MUIV_Listview_MultiSelect_Shifted
MUIA_Popobject_Light | MUIKEY_UP | MUIV_Listview_ScrollerPos_Default
MUIA_Popobject_Object | MUIKEY_WINDOW_CLOSE | MUIV_Listview_ScrollerPos_Left
MUIA_Popobject_ObjStrHook | MUIKEY_WINDOW_NEXT | MUIV_Listview_ScrollerPos_None
MUIA_Popobject_StrObjHook | MUIKEY_WINDOW_PREV | MUIV_Listview_ScrollerPos_Right
MUIA_Popobject_Volatile | MUIKEY_WORDLEFT | MUIV_Menuitem_Shortcut_Check
MUIA_Popobject_WindowHook | MUIKEY_WORDRIGHT | MUIV_Notify_Application
MUIA_Popstring_Button | MUI_Layout | MUIV_Notify_Parent
MUIA_Popstring_CloseHook | MUILM_LAYOUT | MUIV_Notify_ParentParent
MUIA_Popstring_OpenHook | MUILM_MINMAX | MUIV_Notify_ParentParentParent
MUIA_Popstring_String | MUILM_UNKNOWN | MUIV_Notify_Self
MUIA_Popstring_Toggle | MUI_LPR_ABOVE | MUIV_Notify_Window
MUIA_Pressed | MUI_LPR_BELOW | MUIV_NotTriggerValue
MUIA_Prop_Entries | MUI_LPR_LEFT | MUIV_Palette_Entry_End
MUIA_Prop_First | MUI_LPR_RIGHT | MUIV_Prop_UseWinBorder_Bottom
MUIA_Prop_Horiz | MUI_MakeObject | MUIV_Prop_UseWinBorder_Left
MUIA_Prop_Slider | MUI_MakeObjectA | MUIV_Prop_UseWinBorder_None
MUIA_Prop_UseWinBorder | MUIM_Application_AboutMUI | MUIV_Prop_UseWinBorder_Right
MUIA_Prop_Visible | MUIM_Application_AddInputHandler | MUIV_Scrollbar_Type_Bottom
MUIA_Radio_Active | MUIM_Application_BuildSettingsPanel | MUIV_Scrollbar_Type_Default
MUIA_Radio_Entries | MUIM_Application_CheckRefresh | MUIV_Scrollbar_Type_Sym
MUIAreaData | MUIM_Application_DefaultConfigItem | MUIV_Scrollbar_Type_Top
MUIA_Rectangle_BarTitle | MUIM_Application_InputBuffered | MUIV_String_Format_Center
MUIA_Rectangle_HBar | MUIM_Application_Load | MUIV_String_Format_Left
MUIA_Rectangle_VBar | MUIM_Application_NewInput | MUIV_String_Format_Right
MUIA_Register_Frame | MUIM_Application_OpenConfigWindow | MUIV_Text_Shorten_Cutoff
MUIA_Register_Titles | MUIM_Application_PushMethod | MUIV_Text_Shorten_Hide
MUIA_Revision | MUIM_Application_RemInputHandler | MUIV_Text_Shorten_Nothing
MUIA_RightEdge | MUIM_Application_ReturnID | MUIV_TriggerValue
MUIA_Scale_Horiz | MUIM_Application_Save | MUIV_Window_ActiveObject_Down
MUIA_Scrollbar_Type | MUIM_Application_SetConfigItem | MUIV_Window_ActiveObject_Left
MUIA_Scrollgroup_Contents | MUIM_Application_ShowHelp | MUIV_Window_ActiveObject_Next
MUIA_Scrollgroup_FreeHoriz | MUIM_AskMinMax | MUIV_Window_ActiveObject_None
MUIA_Scrollgroup_FreeVert | MUIMasterBase | MUIV_Window_ActiveObject_Prev
MUIA_Scrollgroup_HorizBar | MUIMASTER_NAME | MUIV_Window_ActiveObject_Right
MUIA_Scrollgroup_UseWinBorder | MUIMASTER_VLATEST | MUIV_Window_ActiveObject_Up
MUIA_Scrollgroup_VertBar | MUIMASTER_VMIN | MUIV_Window_AltHeight_MinMax
MUIA_Selected | MUI_MAXMAX | MUIV_Window_AltHeight_Scaled
MUIA_ShortHelp | MUIM_BoopsiQuery | MUIV_Window_AltHeight_Screen
MUIA_ShowMe | MUIM_CallHook | MUIV_Window_AltHeight_Visible
MUIA_ShowSelState | MUIM_Cleanup | MUIV_Window_AltLeftEdge_Centered
MUIA_Slider_Horiz | MUIM_ContextMenuAdd | MUIV_Window_AltLeftEdge_Moused
MUIA_Slider_Quiet | MUIM_ContextMenuBuild | MUIV_Window_AltLeftEdge_NoChange
MUI_AslRequest | MUIM_ContextMenuChoice | MUIV_Window_AltTopEdge_Centered
MUI_AslRequestTags | MUIM_CreateBubble | MUIV_Window_AltTopEdge_Delta
MUIA_String_Accept | MUIM_CreateShortHelp | MUIV_Window_AltTopEdge_Moused
MUIA_String_Acknowledge | MUIM_Dataspace_Add | MUIV_Window_AltTopEdge_NoChange
MUIA_String_AdvanceOnCR | MUIM_Dataspace_Clear | MUIV_Window_AltWidth_MinMax
MUIA_String_AttachedList | MUIM_Dataspace_Find | MUIV_Window_AltWidth_Scaled
MUIA_String_BufferPos | MUIM_Dataspace_Merge | MUIV_Window_AltWidth_Screen
MUIA_String_Contents | MUIM_Dataspace_ReadIFF | MUIV_Window_AltWidth_Visible
MUIA_String_DisplayPos | MUIM_Dataspace_Remove | MUIV_Window_Height_Default
MUIA_String_EditHook | MUIM_Dataspace_WriteIFF | MUIV_Window_Height_MinMax
MUIA_String_Format | MUIM_DeleteBubble | MUIV_Window_Height_Scaled
MUIA_String_Integer | MUIM_DeleteShortHelp | MUIV_Window_Height_Screen
MUIA_String_LonelyEditHook | MUIM_Dirlist_ReRead | MUIV_Window_Height_Visible
MUIA_String_MaxLen | MUIM_DoDrag | MUIV_Window_LeftEdge_Centered
MUIA_String_Reject | MUIM_DragBegin | MUIV_Window_LeftEdge_Moused
MUIA_String_Secret | MUIM_DragDrop | MUIV_Window_TopEdge_Centered
MUIA_Text_Contents | MUIM_DragFinish | MUIV_Window_TopEdge_Delta
MUIA_Text_ControlChar | MUIM_DragQuery | MUIV_Window_TopEdge_Moused
MUIA_Text_Copy | MUIM_DragReport | MUIV_Window_Width_Default
MUIA_Text_HiChar | MUIM_Draw | MUIV_Window_Width_MinMax
MUIA_Text_PreParse | MUIM_DrawBackground | MUIV_Window_Width_Scaled
MUIA_Text_SetMax | MUIM_Export | MUIV_Window_Width_Screen
MUIA_Text_SetMin | MUIM_Family_AddHead | MUIV_Window_Width_Visible
MUIA_Text_SetVMax | MUIM_Family_AddTail | MUIX_B
MUIA_Text_Shorten | MUIM_Family_Insert | MUIX_C
MUIA_Text_Shortened | MUIM_Family_Remove | MUIX_I
MUIA_Timer | MUIM_Family_Sort | MUIX_L
MUIA_TopEdge | MUIM_Family_Transfer | MUIX_N
MUIA_UserData | MUIM_FindUData | MUIX_PH
MUIA_Version | MUIM_GetConfigItem | MUIX_PT
MUIA_VertDisappear | MUIM_GetUData | MUIX_R
MUIA_VertWeight | MUIM_Group_ExitChange | MUIX_U
MUIA_Virtgroup_Height | MUIM_Group_InitChange |

O

OBJ_AddLeft | OBJ_IsInObject | OBJ_MWidth
OBJ_AddTop | OBJ_Left | OBJ_Pens
OBJ_App | OBJ_MaxHeight | OBJ_Right
OBJ_Between | OBJ_MaxWidth | OBJ_Rp
OBJ_Bottom | OBJ_MBottom | OBJ_Screen
OBJ_DefHeight | OBJ_MHeight | OBJ_SubHeight
OBJ_DefWidth | OBJ_MinHeight | OBJ_SubWidth
OBJ_Dri | OBJ_MinWidth | OBJ_Top
OBJ_Flags | OBJ_MLeft | OBJ_Width
OBJ_Font | OBJ_MRight | OBJ_Win
OBJ_Height | OBJ_MTop | OBJ_Window

P

p__dummyXFC2__ | pMUIP_DragFinish | pMUIP_Popstring_Open
plongword | pMUIP_DragQuery | pMUIP_Prop_Decrease
pMUI_AreaData | pMUIP_DragReport | pMUIP_Prop_Increase
pMUI_BoopsiQuery | pMUIP_Draw | pMUIP_Semaphore_Attempt
pMUI_Command | pMUIP_DrawBackground | pMUIP_Semaphore_AttemptShared
pMUI_CustomClass | pMUI_PenSpec | pMUIP_Semaphore_Obtain
pMUI_EventHandlerNode | pMUIP_Export | pMUIP_Semaphore_ObtainShared
pMUI_GlobalInfo | pMUIP_Family_AddHead | pMUIP_Semaphore_Release
pMUI_InputHandlerNode | pMUIP_Family_AddTail | pMUIP_Set
pMUI_LayoutMsg | pMUIP_Family_Insert | pMUIP_SetAsString
pMUI_List_TestPos_Result | pMUIP_Family_Remove | pMUIP_Settingsgroup_ConfigToGadgets
pMUI_MinMax | pMUIP_Family_Sort | pMUIP_Settingsgroup_GadgetsToConfig
pMUI_NotifyData | pMUIP_Family_Transfer | pMUIP_SetUData
pMUI_Palette_Entry | pMUIP_FindUData | pMUIP_SetUDataOnce
pMUIP_Application_AboutMUI | pMUIP_GetConfigItem | pMUIP_Setup
pMUIP_Application_AddInputHandler | pMUIP_GetUData | pMUIP_Show
pMUIP_Application_BuildSettingsPanel | pMUIP_Group_ExitChange | pMUI_PubScreenDesc
pMUIP_Application_CheckRefresh | pMUIP_Group_InitChange | pMUIP_UpdateConfig
pMUIP_Application_DefaultConfigItem | pMUIP_Group_Sort | pMUIP_Window_AddEventHandler
pMUIP_Application_GetMenuCheck | pMUIP_HandleEvent | pMUIP_Window_Cleanup
pMUIP_Application_GetMenuState | pMUIP_HandleInput | pMUIP_Window_GetMenuCheck
pMUIP_Application_Input | pMUIP_Hide | pMUIP_Window_GetMenuState
pMUIP_Application_InputBuffered | pMUIP_Import | pMUIP_Window_RemEventHandler
pMUIP_Application_NewInput | pMUIP_KillNotify | pMUIP_Window_ScreenToBack
pMUIP_Application_OpenConfigWindow | pMUIP_KillNotifyObj | pMUIP_Window_ScreenToFront
pMUIP_Application_PushMethod | pMUIP_List_Clear | pMUIP_Window_SetCycleChain
pMUIP_Application_RemInputHandler | pMUIP_List_CreateImage | pMUIP_Window_SetMenuCheck
pMUIP_Application_ReturnID | pMUIP_List_DeleteImage | pMUIP_Window_SetMenuState
pMUIP_Application_SetConfigItem | pMUIP_List_Exchange | pMUIP_Window_Setup
pMUIP_Application_SetMenuCheck | pMUIP_List_GetEntry | pMUIP_Window_Snapshot
pMUIP_Application_SetMenuState | pMUIP_List_Insert | pMUIP_Window_ToBack
pMUIP_Application_ShowHelp | pMUIP_List_InsertSingle | pMUIP_Window_ToFront
pMUIP_AskMinMax | pMUIP_List_Jump | pMUIP_WriteLong
pMUIP_CallHook | pMUIP_List_Move | pMUIP_WriteString
pMUIP_Cleanup | pMUIP_List_NextSelected | pMUI_RenderInfo
pMUIP_ContextMenuAdd | pMUIP_List_Redraw | pMUI_RGBColor
pMUIP_ContextMenuBuild | pMUIP_List_Remove | pMUIS_InfoClient
pMUIP_ContextMenuChoice | pMUIP_List_Select | PSD_FILENAME_SAVE
pMUIP_CreateBubble | pMUIP_List_Sort | PSD_FILENAME_USE
pMUIP_CreateShortHelp | pMUIP_List_TestPos | PSD_INITIAL_NAME
pMUIP_Dataspace_Add | pMUIP_Menustrip_ExitChange | PSD_INITIAL_TITLE
pMUIP_Dataspace_Clear | pMUIP_Menustrip_InitChange | PSD_MAXLEN_BACKGROUND
pMUIP_Dataspace_Find | pMUIP_MultiSet | PSD_MAXLEN_FONT
pMUIP_Dataspace_Merge | pMUIP_NoNotifySet | PSD_MAXLEN_NAME
pMUIP_Dataspace_ReadIFF | pMUIP_Notify | PSD_MAXLEN_TITLE
pMUIP_Dataspace_Remove | pMUIP_Numeric_Decrease | PSD_MAXMUIPENS
pMUIP_Dataspace_WriteIFF | pMUIP_Numeric_Increase | PSD_MAXSYSPENS
pMUIP_DeleteBubble | pMUIP_Numeric_ScaleToValue | PSD_NAME_FRONTMOST
pMUIP_DeleteShortHelp | pMUIP_Numeric_SetDefault | PSD_NUMCOLS
pMUIP_DoDrag | pMUIP_Numeric_Stringify | PSD_NUMMUIPENS
pMUIP_DragBegin | pMUIP_Numeric_ValueToScale | PSD_NUMSYSPENS
pMUIP_DragDrop | pMUIP_Popstring_Close |

T

t__dummyXFC2__ | tMUIP_DeleteBubble | tMUIP_NoNotifySet
tMUI_AreaData | tMUIP_DeleteShortHelp | tMUIP_Notify
tMUI_BoopsiQuery | tMUIP_DoDrag | tMUIP_Numeric_Decrease
tMUI_Command | tMUIP_DragBegin | tMUIP_Numeric_Increase
tMUI_CustomClass | tMUIP_DragDrop | tMUIP_Numeric_ScaleToValue
tMUI_EventHandlerNode | tMUIP_DragFinish | tMUIP_Numeric_SetDefault
tMUI_GlobalInfo | tMUIP_DragQuery | tMUIP_Numeric_Stringify
tMUI_InputHandlerNode | tMUIP_DragReport | tMUIP_Numeric_ValueToScale
tMUI_LayoutMsg | tMUIP_Draw | tMUIP_Popstring_Close
tMUI_List_TestPos_Result | tMUIP_DrawBackground | tMUIP_Popstring_Open
tMUI_MinMax | tMUI_PenSpec | tMUIP_Prop_Decrease
tMUI_NotifyData | tMUIP_Export | tMUIP_Prop_Increase
tMUI_Palette_Entry | tMUIP_Family_AddHead | tMUIP_Semaphore_Attempt
tMUIP_Application_AboutMUI | tMUIP_Family_AddTail | tMUIP_Semaphore_AttemptShared
tMUIP_Application_AddInputHandler | tMUIP_Family_Insert | tMUIP_Semaphore_Obtain
tMUIP_Application_BuildSettingsPanel | tMUIP_Family_Remove | tMUIP_Semaphore_ObtainShared
tMUIP_Application_CheckRefresh | tMUIP_Family_Sort | tMUIP_Semaphore_Release
tMUIP_Application_DefaultConfigItem | tMUIP_Family_Transfer | tMUIP_Set
tMUIP_Application_GetMenuCheck | tMUIP_FindUData | tMUIP_SetAsString
tMUIP_Application_GetMenuState | tMUIP_GetConfigItem | tMUIP_Settingsgroup_ConfigToGadgets
tMUIP_Application_Input | tMUIP_GetUData | tMUIP_Settingsgroup_GadgetsToConfig
tMUIP_Application_InputBuffered | tMUIP_Group_ExitChange | tMUIP_SetUData
tMUIP_Application_Load | tMUIP_Group_InitChange | tMUIP_SetUDataOnce
tMUIP_Application_NewInput | tMUIP_Group_Sort | tMUIP_Setup
tMUIP_Application_OpenConfigWindow | tMUIP_HandleEvent | tMUIP_Show
tMUIP_Application_PushMethod | tMUIP_HandleInput | tMUI_PubScreenDesc
tMUIP_Application_RemInputHandler | tMUIP_Hide | tMUIP_UpdateConfig
tMUIP_Application_ReturnID | tMUIP_Import | tMUIP_Window_AddEventHandler
tMUIP_Application_Save | tMUIP_KillNotify | tMUIP_Window_Cleanup
tMUIP_Application_SetConfigItem | tMUIP_KillNotifyObj | tMUIP_Window_GetMenuCheck
tMUIP_Application_SetMenuCheck | tMUIP_List_Clear | tMUIP_Window_GetMenuState
tMUIP_Application_SetMenuState | tMUIP_List_CreateImage | tMUIP_Window_RemEventHandler
tMUIP_Application_ShowHelp | tMUIP_List_DeleteImage | tMUIP_Window_ScreenToBack
tMUIP_AskMinMax | tMUIP_List_Exchange | tMUIP_Window_ScreenToFront
tMUIP_CallHook | tMUIP_List_GetEntry | tMUIP_Window_SetCycleChain
tMUIP_Cleanup | tMUIP_List_Insert | tMUIP_Window_SetMenuCheck
tMUIP_ContextMenuAdd | tMUIP_List_InsertSingle | tMUIP_Window_SetMenuState
tMUIP_ContextMenuBuild | tMUIP_List_Jump | tMUIP_Window_Setup
tMUIP_ContextMenuChoice | tMUIP_List_Move | tMUIP_Window_Snapshot
tMUIP_CreateBubble | tMUIP_List_NextSelected | tMUIP_Window_ToBack
tMUIP_CreateShortHelp | tMUIP_List_Redraw | tMUIP_Window_ToFront
tMUIP_Dataspace_Add | tMUIP_List_Remove | tMUIP_WriteLong
tMUIP_Dataspace_Clear | tMUIP_List_Select | tMUIP_WriteString
tMUIP_Dataspace_Find | tMUIP_List_Sort | tMUI_RenderInfo
tMUIP_Dataspace_Merge | tMUIP_List_TestPos | tMUI_RGBcolor
tMUIP_Dataspace_ReadIFF | tMUIP_Menustrip_ExitChange | tMUIS_InfoClient
tMUIP_Dataspace_Remove | tMUIP_Menustrip_InitChange |
tMUIP_Dataspace_WriteIFF | tMUIP_MultiSet |


InitMUIMasterLibrary

Declaration

Source position: mui.pas line 3492

function InitMUIMasterLibrary: Boolean;


MAKE_ID

Declaration

Source position: mui.pas line 3478

function MAKE_ID(

  a: Char;

  b: Char;

  c: Char;

  d: Char

):LongWord;


MUIAreaData

Declaration

Source position: mui.pas line 3414

function MUIAreaData(

  obj: Pointer

):pMUI_AreaData;


MUIget

Declaration

Source position: mui.pas line 3479

function MUIget(

  obj: PObject_;

  attr: LongWord;

  store: LongWord

):LongWord;


MUIGlobalInfo

Declaration

Source position: mui.pas line 3415

function MUIGlobalInfo(

  obj: Pointer

):pMUI_GlobalInfo;


MUINotifyData

Declaration

Source position: mui.pas line 3413

function MUINotifyData(

  obj: Pointer

):pMUI_NotifyData;


MUIPen

Declaration

Source position: mui.pas line 3418

function MUIPen(

  pen: LongInt

):LongInt;


MUIPEN_MASK

Declaration

Source position: mui.pas line 3188

const MUIPEN_MASK = $0000ffff;


MUIRenderInfo

Declaration

Source position: mui.pas line 3417

function MUIRenderInfo(

  obj: Pointer

):pMUI_RenderInfo;


MUIset

Declaration

Source position: mui.pas line 3480

function MUIset(

  obj: PObject_;

  attr: LongWord;

  value: LongWord

):LongWord;


MUIUserData

Declaration

Source position: mui.pas line 3416

function MUIUserData(

  obj: Pointer

):Pointer;


MUIV_Window_AltHeight_MinMax

Declaration

Source position: mui.pas line 3462

function MUIV_Window_AltHeight_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_AltHeight_Screen

Declaration

Source position: mui.pas line 3464

function MUIV_Window_AltHeight_Screen(

  p: LongInt

):LongInt;


MUIV_Window_AltHeight_Visible

Declaration

Source position: mui.pas line 3463

function MUIV_Window_AltHeight_Visible(

  p: LongInt

):LongInt;


MUIV_Window_AltTopEdge_Delta

Declaration

Source position: mui.pas line 3465

function MUIV_Window_AltTopEdge_Delta(

  p: LongInt

):LongInt;


MUIV_Window_AltWidth_MinMax

Declaration

Source position: mui.pas line 3466

function MUIV_Window_AltWidth_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_AltWidth_Screen

Declaration

Source position: mui.pas line 3468

function MUIV_Window_AltWidth_Screen(

  p: LongInt

):LongInt;


MUIV_Window_AltWidth_Visible

Declaration

Source position: mui.pas line 3467

function MUIV_Window_AltWidth_Visible(

  p: LongInt

):LongInt;


MUIV_Window_Height_MinMax

Declaration

Source position: mui.pas line 3469

function MUIV_Window_Height_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_Height_Screen

Declaration

Source position: mui.pas line 3471

function MUIV_Window_Height_Screen(

  p: LongInt

):LongInt;


MUIV_Window_Height_Visible

Declaration

Source position: mui.pas line 3470

function MUIV_Window_Height_Visible(

  p: LongInt

):LongInt;


MUIV_Window_TopEdge_Delta

Declaration

Source position: mui.pas line 3472

function MUIV_Window_TopEdge_Delta(

  p: LongInt

):LongInt;


MUIV_Window_Width_MinMax

Declaration

Source position: mui.pas line 3473

function MUIV_Window_Width_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_Width_Screen

Declaration

Source position: mui.pas line 3475

function MUIV_Window_Width_Screen(

  p: LongInt

):LongInt;


MUIV_Window_Width_Visible

Declaration

Source position: mui.pas line 3474

function MUIV_Window_Width_Visible(

  p: LongInt

):LongInt;


MUI_AddClipping

Declaration

Source position: mui.pas line 3385

function MUI_AddClipping(

  mri: pMUI_RenderInfo;

  l: SmallInt;

  t: SmallInt;

  w: SmallInt;

  h: SmallInt

):POINTER;


MUI_AddClipRegion

Declaration

Source position: mui.pas line 3396

function MUI_AddClipRegion(

  mri: pMUI_RenderInfo;

  region: PRegion

):POINTER;


MUI_AllocAslRequest

Declaration

Source position: mui.pas line 3324

function MUI_AllocAslRequest(

  typ: LongWord;

  tags: PTagItem

):POINTER;


MUI_AllocAslRequestTags

Declaration

Source position: mui.pas line 3485

function MUI_AllocAslRequestTags(

  _type: LongWord;

  tags: array of LongWord

):POINTER;


MUI_AslRequest

Declaration

Source position: mui.pas line 3327

function MUI_AslRequest(

  req: POINTER;

  tags: PTagItem

):Boolean;


MUI_AslRequestTags

Declaration

Source position: mui.pas line 3486

function MUI_AslRequestTags(

  req: POINTER;

  tags: array of LongWord

):Boolean;


MUI_BeginRefresh

Declaration

Source position: mui.pas line 3402

function MUI_BeginRefresh(

  mri: pMUI_RenderInfo;

  flags: LongWord

):Boolean;


MUI_CreateCustomClass

Declaration

Source position: mui.pas line 3354

function MUI_CreateCustomClass(

  base: PLibrary;

  supername: pChar;

  supermcc: pMUI_CustomClass;

  datasize: LongInt;

  dispatcher: POINTER

):pMUI_CustomClass;


MUI_DeleteCustomClass

Declaration

Source position: mui.pas line 3361

function MUI_DeleteCustomClass(

  mcc: pMUI_CustomClass

):Boolean;


MUI_DisposeObject

Declaration

Source position: mui.pas line 3312

procedure MUI_DisposeObject(

  obj: PObject_

);


MUI_EndRefresh

Declaration

Source position: mui.pas line 3405

procedure MUI_EndRefresh(

  mri: pMUI_RenderInfo;

  flags: LongWord

);


MUI_Error

Declaration

Source position: mui.pas line 3333

function MUI_Error: LongInt;


MUI_FreeAslRequest

Declaration

Source position: mui.pas line 3330

procedure MUI_FreeAslRequest(

  req: POINTER

);


MUI_FreeClass

Declaration

Source position: mui.pas line 3342

procedure MUI_FreeClass(

  cl: PIClass

);


MUI_GetClass

Declaration

Source position: mui.pas line 3339

function MUI_GetClass(

  name: pChar

):PIClass;


MUI_Layout

Declaration

Source position: mui.pas line 3367

function MUI_Layout(

  obj: PObject_;

  l: LongInt;

  t: LongInt;

  w: LongInt;

  h: LongInt;

  flags: LongWord

):Boolean;


MUI_MakeObject

Declaration

Source position: mui.pas line 3487

function MUI_MakeObject(

  _type: LongInt;

  params: array of LongWord

):plongword;


MUI_MakeObjectA

Declaration

Source position: mui.pas line 3364

function MUI_MakeObjectA(

  typ: LongInt;

  params: plongword

):plongword;


MUI_NewObject

Declaration

Source position: mui.pas line 3488

function MUI_NewObject(

  a0arg: pCHAR;

  tags: array of LongWord

):plongword;


MUI_NewObjectA

Declaration

Source position: mui.pas line 3309

function MUI_NewObjectA(

  class_: pChar;

  tags: PTagItem

):PObject_;


MUI_ObtainPen

Declaration

Source position: mui.pas line 3376

function MUI_ObtainPen(

  mri: pMUI_RenderInfo;

  spec: pMUI_PenSpec;

  flags: LongWord

):LongInt;


MUI_Redraw

Declaration

Source position: mui.pas line 3351

procedure MUI_Redraw(

  obj: PObject_;

  flags: LongWord

);


MUI_RejectIDCMP

Declaration

Source position: mui.pas line 3348

procedure MUI_RejectIDCMP(

  obj: PObject_;

  flags: LongWord

);


MUI_ReleasePen

Declaration

Source position: mui.pas line 3381

procedure MUI_ReleasePen(

  mri: pMUI_RenderInfo;

  pen: LongInt

);


MUI_RemoveClipping

Declaration

Source position: mui.pas line 3392

procedure MUI_RemoveClipping(

  mri: pMUI_RenderInfo;

  h: POINTER

);


MUI_RemoveClipRegion

Declaration

Source position: mui.pas line 3399

procedure MUI_RemoveClipRegion(

  mri: pMUI_RenderInfo;

  region: POINTER

);


MUI_Request

Declaration

Source position: mui.pas line 3489

function MUI_Request(

  app: POINTER;

  win: POINTER;

  flags: LongWord;

  title: pCHAR;

  gadgets: pCHAR;

  format: pCHAR;

  params: array of LongWord

):LongInt;


MUI_RequestA

Declaration

Source position: mui.pas line 3315

function MUI_RequestA(

  app: POINTER;

  win: POINTER;

  flags: LongWord;

  title: pChar;

  gadgets: pChar;

  format: pChar;

  params: POINTER

):LongInt;


MUI_RequestIDCMP

Declaration

Source position: mui.pas line 3345

procedure MUI_RequestIDCMP(

  obj: PObject_;

  flags: LongWord

);


MUI_SetError

Declaration

Source position: mui.pas line 3336

function MUI_SetError(

  errnum: LongInt

):LongInt;


OBJ_AddLeft

Declaration

Source position: mui.pas line 3440

function OBJ_AddLeft(

  obj: Pointer

):SmallInt;


OBJ_AddTop

Declaration

Source position: mui.pas line 3441

function OBJ_AddTop(

  obj: Pointer

):SmallInt;


OBJ_App

Declaration

Source position: mui.pas line 3427

function OBJ_App(

  obj: Pointer

):PObject_;


OBJ_Between

Declaration

Source position: mui.pas line 3459

function OBJ_Between(

  a: SmallInt;

  x: SmallInt;

  b: SmallInt

):Boolean;


OBJ_Bottom

Declaration

Source position: mui.pas line 3439

function OBJ_Bottom(

  obj: Pointer

):SmallInt;


OBJ_DefHeight

Declaration

Source position: mui.pas line 3456

function OBJ_DefHeight(

  obj: Pointer

):LongWord;


OBJ_DefWidth

Declaration

Source position: mui.pas line 3455

function OBJ_DefWidth(

  obj: Pointer

):LongWord;


OBJ_Dri

Declaration

Source position: mui.pas line 3429

function OBJ_Dri(

  obj: Pointer

):PDrawInfo;


OBJ_Flags

Declaration

Source position: mui.pas line 3457

function OBJ_Flags(

  obj: Pointer

):LongWord;


OBJ_Font

Declaration

Source position: mui.pas line 3450

function OBJ_Font(

  obj: Pointer

):PTextFont;


OBJ_Height

Declaration

Source position: mui.pas line 3437

function OBJ_Height(

  obj: Pointer

):SmallInt;


OBJ_IsInObject

Declaration

Source position: mui.pas line 3460

function OBJ_IsInObject(

  x: SmallInt;

  y: SmallInt;

  obj: PObject_

):Boolean;


OBJ_Left

Declaration

Source position: mui.pas line 3434

function OBJ_Left(

  obj: Pointer

):SmallInt;


OBJ_MaxHeight

Declaration

Source position: mui.pas line 3454

function OBJ_MaxHeight(

  obj: Pointer

):LongWord;


OBJ_MaxWidth

Declaration

Source position: mui.pas line 3453

function OBJ_MaxWidth(

  obj: Pointer

):LongWord;


OBJ_MBottom

Declaration

Source position: mui.pas line 3449

function OBJ_MBottom(

  obj: Pointer

):SmallInt;


OBJ_MHeight

Declaration

Source position: mui.pas line 3447

function OBJ_MHeight(

  obj: Pointer

):SmallInt;


OBJ_MinHeight

Declaration

Source position: mui.pas line 3452

function OBJ_MinHeight(

  obj: Pointer

):LongWord;


OBJ_MinWidth

Declaration

Source position: mui.pas line 3451

function OBJ_MinWidth(

  obj: Pointer

):LongWord;


OBJ_MLeft

Declaration

Source position: mui.pas line 3444

function OBJ_MLeft(

  obj: Pointer

):SmallInt;


OBJ_MRight

Declaration

Source position: mui.pas line 3448

function OBJ_MRight(

  obj: Pointer

):SmallInt;


OBJ_MTop

Declaration

Source position: mui.pas line 3445

function OBJ_MTop(

  obj: Pointer

):SmallInt;


OBJ_MWidth

Declaration

Source position: mui.pas line 3446

function OBJ_MWidth(

  obj: Pointer

):SmallInt;


OBJ_Pens

Declaration

Source position: mui.pas line 3431

function OBJ_Pens(

  obj: Pointer

):pWord;


OBJ_Right

Declaration

Source position: mui.pas line 3438

function OBJ_Right(

  obj: Pointer

):SmallInt;


OBJ_Rp

Declaration

Source position: mui.pas line 3433

function OBJ_Rp(

  obj: Pointer

):PRastPort;


OBJ_Screen

Declaration

Source position: mui.pas line 3430

function OBJ_Screen(

  obj: Pointer

):PScreen;


OBJ_SubHeight

Declaration

Source position: mui.pas line 3443

function OBJ_SubHeight(

  obj: Pointer

):SmallInt;


OBJ_SubWidth

Declaration

Source position: mui.pas line 3442

function OBJ_SubWidth(

  obj: Pointer

):SmallInt;


OBJ_Top

Declaration

Source position: mui.pas line 3435

function OBJ_Top(

  obj: Pointer

):SmallInt;


OBJ_Width

Declaration

Source position: mui.pas line 3436

function OBJ_Width(

  obj: Pointer

):SmallInt;


OBJ_Win

Declaration

Source position: mui.pas line 3428

function OBJ_Win(

  obj: Pointer

):PObject_;


OBJ_Window

Declaration

Source position: mui.pas line 3432

function OBJ_Window(

  obj: Pointer

):PWindow;


Reference for unit 'timer': Procedures and functions

AddTime

CmpTime

GetSysTime

ReadEClock

SubTime


Unit 'timer' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'timer': Variables

TimerBase


Index of all identifiers in unit 'timer'

A C G P R S T U

A

AddTime

C

CmpTime

G

GetSysTime

P

PEClockVal PTimeRequest PTimeVal

R

ReadEClock

S

SubTime

T

TEClockVal | TR_ADDREQUEST | TTimeRequest
TimerBase | TR_GETSYSTIME | TTimeVal
TIMERNAME | TR_SETSYSTIME |

U

UNIT_CPUCLOCK | UNIT_VBLANK | UNIT_WAITUNTIL
UNIT_ECLOCK | UNIT_WAITCPUCLOCK |
UNIT_MICROHZ | UNIT_WAITECLOCK |


AddTime

Declaration

Source position: timer.pas line 77

procedure AddTime(

  Dest: PTimeVal;

  Source: PTimeVal

);


CmpTime

Declaration

Source position: timer.pas line 85

function CmpTime(

  Dest: PTimeVal;

  Source: PTimeVal

):LongInt;


GetSysTime

Declaration

Source position: timer.pas line 92

procedure GetSysTime(

  Dest: PTimeVal

);


ReadEClock

Declaration

Source position: timer.pas line 89

function ReadEClock(

  Dest: PTimeVal

):DWord;


SubTime

Declaration

Source position: timer.pas line 81

procedure SubTime(

  Dest: PTimeVal;

  Source: PTimeVal

);


Reference for unit 'tinygl': Procedures and functions

InitTinyGLLibrary


Unit 'tinygl' | Package
[Overview][Constants][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'tinygl': Variables

tglContext

TinyGLBase


Index of all identifiers in unit 'tinygl'

I T

I

InitTinyGLLibrary

T

tglContext TinyGLBase TINYGLNAME


InitTinyGLLibrary

Declaration

Source position: tinygl.pas line 35

function InitTinyGLLibrary: Boolean;


Reference for unit 'utility': Procedures and functions

AddNamedObject | Add a named object to the given namespace.
AllocateTagItems | Allocate a tag list.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
AllocNamedObjectA | Allocate a named object.
Amiga2Date | Fill in a ClockData structure based on a system time stamp
ApplyTagChanges | Change a tag list based on a second tag list.
AsTag |
AttemptRemNamedObject | Attempt to remove a named object.
CallHookPkt | Invoke a Hook function callback.
CheckDate | Checks a ClockData structure for legal date.
CloneTagItems | Copy a tag list.
Date2Amiga | Calculate seconds from 01-Jan-1978.
DISPATCHERARG
FilterTagChanges | Eliminate tags which specify no change.
FilterTagItems | Remove selected items from a tag list.
FindNamedObject | Find the next object of a given name.
FindTagItem | Scan a tag list for a specific tag.
FreeNamedObject | Frees a name object.
FreeTagItems | Free an allocated tag list.
GetTagData | Obtain the data corresponding to a tag.
GetUniqueID | Return a relatively unique number.
HookEntry |
MapTags | Convert ti_Tag values in a list via map pairing.
NamedObjectName | Return the name of the object.
NextTagItem | Iterate through a tag list.
PackBoolTags | Builds a "flag" word from a tag list
PackStructureTags | Pack a structure with values from taglist.
RefreshTagItemClones | Rejuvenate a clone from the original.
ReleaseNamedObject | Free a named object.
RemNamedObject | Remove a named object.
SDivMod32 | Signed 32 by 32 bit division and modulus.
SMult32 | Signed 32 by 32 bit multiply with 32 bit result.
SMult64 | Signed 32 by 32 bit multiply with 64 bit result.
Stricmp | Case-insensitive string comparison.
Strnicmp | Length-limited case-insensitive string compare.
TagInArray | Check if a tag value appears in an array of tag values.
TAG_ |
ToLower | Convert a character to lower case.
ToUpper | Convert a character to upper case.
UDivMod32 | Unsigned 32 by 32 bit division and modulus.
UMult32 | Unsigned 32 by 32 bit multiply with 32 bit result.
UMult64 | Unsigned 32 by 32 bit multiply with 64 bit result.
UnpackStructureTags | Unpack a structure to values in taglist.


Unit 'utility' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'utility': Variables

UtilityBase


Index of all identifiers in unit 'utility'

A C D F G H M N P R S T U

A

AddNamedObject | Amiga2Date | ANO_UserSpace
AllocateTagItems | ANO_Flags | ApplyTagChanges
AllocNamedObject | ANO_NameSpace | AsTag
AllocNamedObjectA | ANO_Priority | AttemptRemNamedObject

C

CallHookPkt CheckDate CloneTagItems

D

Date2Amiga DISPATCHERARG

F

FilterTagChanges | FindNamedObject | FreeNamedObject
FilterTagItems | FindTagItem | FreeTagItems

G

GetTagData GetUniqueID

H

HookEntry

M

MAP_KEEP_NOT_FOUND MAP_REMOVE_NOT_FOUND MapTags

N

NamedObjectName | NSB_CASE | NSF_CASE
NextTagItem | NSB_NODUPS | NSF_NODUPS

P

PackBoolTags | PKCTRL_UBYTE | PSTB_UNPACK
PackStructureTags | PKCTRL_ULONG | PSTF_EXISTS
PClockData | PKCTRL_UNPACKONLY | PSTF_PACK
PHook | PKCTRL_UWORD | PSTF_SIGNED
PKCTRL_BIT | PKCTRL_WORD | PSTF_UNPACK
PKCTRL_BYTE | PNamedObject | PTag
PKCTRL_FLIPBIT | PPTagItem | PTagItem
PKCTRL_LONG | PSTB_EXISTS | PUtilityBase
PKCTRL_PACKONLY | PSTB_PACK |
PKCTRL_PACKUNPACK | PSTB_SIGNED |

R

RefreshTagItemClones ReleaseNamedObject RemNamedObject

S

SDivMod32 | SMult64 | Strnicmp
SMult32 | Stricmp |

T

LongWord | TAG_IGNORE | THook
TAG_ | TagInArray | TNamedObject
TAG_DONE | TAG_MORE | ToLower
TAG_END | TAG_SKIP | ToUpper
TAGFILTER_AND | TAG_USER | TTagItem
TAGFILTER_NOT | TClockData | TUtilityBase

U

UDivMod32 | UMult64 | UtilityBase
UMult32 | UnpackStructureTags | UtilityName


AddNamedObject

Add a named object to the given namespace.

Declaration

Source position: utility.pas line 200

function AddNamedObject(

  NameSpace: PNamedObject;

  NObject: PNamedObject

):LongBool;

Arguments

NameSpace

The NameSpace to add the NamedObject object to. If this value is nil, then the NamedObject will be added to the root NameSpace. This is useful for sharing NamedObjects between Tasks.

Function result

If the NamedObject can be added to either the supplied NameSpace or the system global NameSpace, this function will return True. Otherwise it will return False. This will generally happen when the NSF_NODUPS flag is set and this NamedObject has the same name as a second object, or when the object is already in a NameSpace.

Description

Adds a given NamedObject to a NameSpace which is addressed through a second NamedObject. Allows you to link a common group of NamedObjects together. If the NameSpace doesn't support duplicate names, then a search for a duplicate will be made, and False returned if one is found.

Errors

Although the AmigaOS 3.1 autodocs did not say so, under 3.0 you couldn't add a NamedObject to a NameSpace when the NamedObject you were adding had a NameSpace itself. This has changed. This is because the autodocs did not say this, and they are right :)

See also

RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AttemptRemNamedObject | Attempt to remove a named object.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


AllocateTagItems

Allocate a tag list.

Declaration

Source position: utility.pas line 168

function AllocateTagItems(

  NumTags: Cardinal

):PTagItem;

Function result

the allocated chain of TagItem structures, or nil if there was not enough memory. An allocated tag list must eventually be freed using FreeTagItems().

Description

Allocates the specified number of usable TagItems slots.

Note that to access the TagItems in 'tagList', you should use the function NextTagItem(). This will insure you respect any chaining (TAG_MORE) and secret hiding places (TAG_IGNORE) that this function might generate.

See also

FreeTagItems | Free an allocated tag list.
CloneTagItems | Copy a tag list.


AllocNamedObject

VarArgs Version for AllocNamedObjectA()

Declaration

Source position: utility.pas line 212

function AllocNamedObject(

  Name: PChar;

  const Tags: array of PtrUInt

):PNamedObject;


AllocNamedObjectA

Allocate a named object.

Declaration

Source position: utility.pas line 201

function AllocNamedObjectA(

  Name: PChar;

  TagList: PTagItem

):PNamedObject;

Arguments

Name | The name of the NamedObject. Obviously this must be specified
TagList | A TagList containing some extra information for this NamedObject. (ANO_*)

Function result

The object allocated, or nil for failure. The object is defined as a pointer to a pointer. You can do what you wish with the pointer. (It may be nil or contain a pointer to memory that you had asked for in the tags.)

Description

Allocate a new NamedObject and initializes it as requested. This object can then be used as an object in a name space. Optionally you give this object a name space, and use it to nest name spaces. You can also allocate some memory which is attached to this object for your own personal use.

When the object is allocated, it will automatically have one user. To allow other users to remove this object from a namespace, you must call ReleaseNamedObject() on this object.

See also

FreeNamedObject | Frees a name object.
ANO_NameSpace | Tag for AllocNamedObjectA(). Tag to define namespace
ANO_UserSpace | Tag for AllocNamedObjectA(). Taf to define userspace
ANO_Priority | Tag for AllocNamedObjectA(). Tag to define priority
ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)


Amiga2Date

Fill in a ClockData structure based on a system time stamp

Declaration

Source position: utility.pas line 177

procedure Amiga2Date(

  Seconds: LongWord;

  Result: PClockData

);

Arguments

Seconds

Number of seconds since 1.1.78 00:00:00

Description

Convert the time value given as the number of seconds since the 1st of January 1978 (00:00:00 1.1.78), to a more useful values, which is easier for most people to understand. These values will be stored in the ClockData structure whose address is passed as an argument.

The ClockData structure will contain the converted time values.

See also

CheckDate | Checks a ClockData structure for legal date.
Date2Amiga | Calculate seconds from 01-Jan-1978.


ApplyTagChanges

Change a tag list based on a second tag list.

Declaration

Source position: utility.pas line 192

procedure ApplyTagChanges(

  List: PTagItem;

  ChangeList: PTagItem

);

Arguments

List | A list of existing tags (may be nil)
ChangeList | A list of tags to modify 'list' with (may be nil)

Description

For any tag that appears in both 'list' and 'changeList', this function will change the ti_Data field of the tag in 'list' to match the ti_Data field of the tag in 'changeList'. In effect, 'changeList' contains a series of new values for tags already in 'list'. Any tag in 'changeList' that is not in 'list' is ignored.

See also

FilterTagChanges

Eliminate tags which specify no change.


AsTag

Declaration

Source position: utility.pas line 220

function AsTag(

  Value: Pointer

):PtrUInt; overload;

function AsTag(

  Value: PChar

):PtrUInt; overload;

function AsTag(

  Value: Boolean

):PtrUInt; overload;

function AsTag(

  Value: LongInt

):PtrUInt; overload;

function AsTag(

  Value: LongWord

):PtrUInt; overload;


AttemptRemNamedObject

Attempt to remove a named object.

Declaration

Source position: utility.pas line 202

function AttemptRemNamedObject(

  NObject: PNamedObject

):LongInt;

Function result

If the NamedObject can be removed, then it will be removed from the list. Otherwise the routine will just return. If the NamedObject has a removal message associated with it that message will be returned to the owner of the NamedObject.

Description

Attempts to remove an object from whatever NameSpace it's in. You must have found the object first (in order to get a use count) before trying to remove it. If the object is in use or is in the process of being removed, this function will return a failure code. If the object is fully removed, the object will then be available to be FreeNamedObject().

See also

RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AddNamedObject | Add a named object to the given namespace.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


CallHookPkt

Invoke a Hook function callback.

Declaration

Source position: utility.pas line 175

function CallHookPkt(

  Hook: PHook;

  HObject: Pointer;

  ParamPacket: Pointer

):LongWord;

Arguments

Hook

Pointer to an initialized Hook structure.

Function result

Depends upon the Hook itself.

Description

Call the callback hook defined by a Hook structure. This is effectively a long jump to the PHook^.h_Entry vector of the structure.

The Hook will be called with the same arguments as this function.

Errors

If your callback function does not have the correct register definitions, the result of this function is entirely unreliable.


CheckDate

Checks a ClockData structure for legal date.

Declaration

Source position: utility.pas line 179

function CheckDate(

  Date: PClockData

):LongWord;

Arguments

Date

A ClockData structure desribing the date to check.

Function result

If the date is valid, the number of seconds from midnight 1-Jan-1978 AD to the date, or 0 if the date is invalud.

Description

Examine the date described in the ClockData structure and determine whether it is a valid date. In particular this checks whether the ranges of the fields are within normal limits.

This function does not check whether the wday field of the ClockData structure is valid.

The date 01-Jan-78 00:00:00 is actually returned as invalid.

This also assumes that the ClockDate refers to a date in the Gregorian calendar. (60 sec/min, 60 min/hour, 24 hr/day, 12 months/year).

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
Date2Amiga | Calculate seconds from 01-Jan-1978.


CloneTagItems

Copy a tag list.

Declaration

Source position: utility.pas line 169

function CloneTagItems(

  TagList: PTagItem

):PTagItem;

Arguments

TagList

A tag list to clone. May be nil, in which case an empty tag list is returned.

Function result

Copy of the original tag list, or nil if there was not enough memory. This tag list must eventually by freed by calling FreeTagItems().

Description

Copies the essential contents of a tag list into a new tag list.

The cloning is such that calling FindTagItem() with a given tag on the original or cloned tag lists will always return the same tag value. That is, the ordering of the tags is maintained.

See also

AllocateTagItems | Allocate a tag list.
FreeTagItems | Free an allocated tag list.
RefreshTagItemClones | Rejuvenate a clone from the original.


Date2Amiga

Calculate seconds from 01-Jan-1978.

Declaration

Source position: utility.pas line 178

function Date2Amiga(

  Date: PClockData

):LongWord;

Arguments

Date

A pointer to a ClockData structure containing the date of interest.

Function result

The number of seconds from 01-Jan-1978 to the date specified.

Description

Calculates the number of seconds from 01-Jan-1978 to the date specified in the ClockData structure.

Errors

This function does no sanity checking of the data in the ClockData structure.

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
CheckDate | Checks a ClockData structure for legal date.


DISPATCHERARG

Declaration

Source position: utility.pas line 228

procedure DISPATCHERARG(

  var cl;

  var obj;

  var msg

);


FilterTagChanges

Eliminate tags which specify no change.

Declaration

Source position: utility.pas line 166

procedure FilterTagChanges(

  ChangeList: PTagItem;

  OriginalList: PTagItem;

  Apply: LongWord

);

Arguments

ChangeList | A list of new tags (may be nil)
Apply | Boolean specification as to whether the data values in originalList are to be updated to the data values in changeList.

Description

This function goes through changeList. For each item found in changeList, if the item is also present in originalList, and their data values are identical, then the tag is removed from changeList. If the two tag's data values are different and the 'apply' value is True, then the tag data in OldValues will be updated to match the value from ChangeList.

See also

ApplyTagChanges

Change a tag list based on a second tag list.


FilterTagItems

Remove selected items from a tag list.

Declaration

Source position: utility.pas line 173

function FilterTagItems(

  TagList: PTagItem;

  FilterArray: PTag;

  Logic: LongWord

):LongWord;

Arguments

TagList | input list of tag items which is to be filtered by having selected items changed to TAG_IGNORE.
FilterArray | An array of tag values, terminated by TAG_DONE, as specified in the documentation for TagInArray().
Logic | Apecification whether items in 'tagArray' are to be included or excluded in the filtered result.

Function result

Number of valid items left in resulting filtered list.

Description

Removes tag items from a tag list (by changing ti_Data to TAG_IGNORETAG_IGNORE) depending on whether its ti_Data value is found in an array of tag values.

If the 'logic' parameter is TAGFILTER_ANDTAGFILTER_AND, then all items not appearing in 'tagArray' are excluded from 'tagList'.

If 'logic' is TAGFILTER_NOTTAGFILTER_NOT, then items not found in 'tagArray' are preserved, and the ones in the array are cast out.

See also

TagInArray

Check if a tag value appears in an array of tag values.


FindNamedObject

Find the next object of a given name.

Declaration

Source position: utility.pas line 203

function FindNamedObject(

  NameSpace: PNamedObject;

  Name: PChar;

  LastObject: PNamedObject

):PNamedObject;

Arguments

NameSpace | The NameSpace to search through. If nil will use the system default NameSpace.
Name | The name of the object to search for. If nil, any and all NamedObjects will be matched.
LastObject | The (optional) last NamedObject to start the search from.

Function result

If a NamedObject with the name supplied exists, it will be returned. Otherwise will return nil. When you have finised with this NamedObject, you should call ReleaseNamedObject().

Description

Finds an object and adds to the open count of the object. The object is guaranteed not to be freed until ReleaseNamedObject() is called. The name comparison is caseless, using the current locale string comparison routines.

If name is nil, then all objects will be matched.

If lastObject is non-nil, it must be an object from the same NameSpace found on a previous call to FindNamedObject(). It will not be freed by this call. The search will start at the node after lastobject, if non-nil.

nameSpace is the name space from the named object given or the root name space if nil is given.

If you are going to use a returned NamedObject to be the starting point for another search you must call ReleaseNamedObject() after searching, as the ReleaseNamedObject() call can cause the NamedObject to be freed, leaving you with an invalid pointer.

See also

ReleaseNamedObject

Free a named object.


FindTagItem

Scan a tag list for a specific tag.

Declaration

Source position: utility.pas line 161

function FindTagItem(

  TagVal: LongWord;

  TagList: PTagItem

):PTagItem;

Arguments

TagList

A tag item list to search (may be nil)

Function result

A pointer to the item with ti_Tag matching 'tagValue' or nil if no match was found.

Description

Scans a tag list and returns a pointer to the first item with ti_Tag matching the 'tagValue' parameter.

See also

GetTagData | Obtain the data corresponding to a tag.
PackBoolTags | Builds a "flag" word from a tag list
NextTagITem | Iterate through a tag list.


FreeNamedObject

Frees a name object.

Declaration

Source position: utility.pas line 204

procedure FreeNamedObject(

  NObject: PNamedObject

);

Description

Free one of a number of structures used by utility.library. The item must not be a member of any NameSpace, and no one may have it open other than yourself. If the object also contained a NameSpace, that namespace must be empty. Any additional space allocated via the datasize parameter for AllocNamedObject() is also released.

See also

AllocNamedObjectA

Allocate a named object.


FreeTagItems

Free an allocated tag list.

Declaration

Source position: utility.pas line 170

procedure FreeTagItems(

  TagList: PTagItem

);

Arguments

TagList

list to free, must have been obtained from AllocateTagItems() or CloneTagItems() (may be nil)

Description

Frees the memory of a TagItem list allocated either by AllocateTagItems() or CloneTagItems().

var
  tagList: PTagItem;
begin
  tagList := AllocateTagItems(4);
  tagList[0]^.ti_Tag := NA_Name;
  tagList[0]^.ti_Data := IPTR(PChar('A list of tags'));
  tagList[3]^.ti_Tag := TAG_DONE;
// Do what you want with your TagList here ...
  FreeTagItems(tagList);
end;

See also

AllocateTagItems

Allocate a tag list.


GetTagData

Obtain the data corresponding to a tag.

Declaration

Source position: utility.pas line 162

function GetTagData(

  TagValue: LongWord;

  DefaultVal: LongWord;

  TagList: PTagItem

):LongWord;

Arguments

TagValue | A tag value to search for
TagList | The tag list to search.

Function result

The ti_Data value for the first matching TagItem, or 'default' if a ti_Tag matching 'Tag' is not found.

Description

Searches a tag list for a matching tag, and returns the corresponding ti_Data value for the TagItem found. If no match is found, this function returns the value passed in as 'default'.

// Find out the value for the WA_Left tag
window^.Left := GetTagData(WA_Left, 320, wintags);

If the input TagList doesn't exist (e.g. for some reason equals nil), then the return value will be nil. This way you can check for broken code, whereas returing the default would allow code that is possibly buggy to still seem to work. (Until you tried to do anything special at least).

See also

FindTagItem | Scan a tag list for a specific tag.
PackBoolTags | Builds a "flag" word from a tag list
NextTagItem | Iterate through a tag list.


GetUniqueID

Return a relatively unique number.

Declaration

Source position: utility.pas line 209

function GetUniqueID: LongWord;

Function result

A 32-bit value that is unique.

Description

Returns a unique value each time it is called. This is useful for things that need unique ID such as the GadgetHelp ID, etc. Note that this is only unique for 4,294,967,295 calls to this function. Under normal use this is not a problem. This function is safe in interrupts.


HookEntry

Declaration

Source position: utility.pas line 229

function HookEntry: PtrUInt;


MapTags

Convert ti_Tag values in a list via map pairing.

Declaration

Source position: utility.pas line 167

procedure MapTags(

  TagList: PTagItem;

  MapList: PTagItem;

  MapType: Cardinal

);

Arguments

TagList | Input list of tag items which is to be mapped to tag values as specified in MapList.
MapList | A "mapping list" tag list which pairs tag values expected to appear in tagList with new values to be substituted in the ti_Tag fields of tagList (may be nil)
MapType | one of the available mapping types (MAP_*)

Description

Apply a "mapping list" mapList to tagList.

If the ti_Tag field of an item in tagList appears as ti_Tag in some item in mapList, overwrite ti_Tag with the corresponding ti_Data from the map list.

The mapType parameter specifies how the mapping operation is to proceed, with the following available types:

MAP_REMOVE_NOT_FOUND
If a tag in tagList does not appear in the mapList, remove it from tagList.
MAP_KEEP_NOT_FOUND
To have items which do not appear in the mapList survive the mapping process as-is.

MapTags() is central to BOOPSI gadget interconnections where you want to convert the tag values from one space (the sender) to another (the receiver).

The procedure will change the values of the input tag list tagList (but not mapList).

You can "filter" a list by passing MAP_REMOVE_NOT_FOUND as mapType, and having the data items in mapList equal the corresponding tags.

You can perform the inverse filter ("everything but") by passing a mapType of MAP_KEEP_NOT_FOUND, and creating a map item for every tag you want to filter out, pairing it with a mapped data value of TAG_IGNORE.

For safety and "order independence" of tag item arrays, if you attempt to map some tag to the value TAG_DONE, the value TAG_IGNORE will be substituted instead.

See also

ApplyTagChanges | Change a tag list based on a second tag list.
FilterTagChanges | Eliminate tags which specify no change.
MAP_REMOVE_NOT_FOUND | Mapping types for use with MapTags() remove tags that aren't in mapList
MAP_KEEP_NOT_FOUND | Mapping types for use with MapTags() keep tags that aren't in mapList


NamedObjectName

Return the name of the object.

Declaration

Source position: utility.pas line 205

function NamedObjectName(

  NObject: PNamedObject

):PChar;

Function result

A pointer to the name string, or nil if 'object' is nil.

Description

Returns the name of the object passed in... Note that the name string is passed back as just a pointer to a read-only name. If the object goes away, so does the name.

See also

FindNamedObject | Find the next object of a given name.
RemNamedObject | Remove a named object.


NextTagItem

Iterate through a tag list.

Declaration

Source position: utility.pas line 164

function NextTagItem(

  TagListPtr: PPTagItem

):PTagItem; overload;

function NextTagItem(

  var TagList: PTagItem

):PTagItem; overload;

Function result

Each TagItem in the array or chain of arrays that should be processed according to system tag values is returned in turn with successive calls.

Description

Iterates through a tag list, skipping and chaining as dictated by system tags. TAG_SKIP will cause it to skip the entry and a number of following tags as specified in ti_Data. TAG_IGNORE ignores that single entry, and TAG_MORE has a pointer to another array of tags (and terminates the current array!). TAG_DONE also terminates the current array. Each call returns either the next tagitem you should examine, or nil when the end of the list has been reached.

procedure Iterate(tags: PTagItem);
var
  tag: PTagItem;
begin
  tag := NextTagItem(tags);
  while tag <> nil do
  begin
    case tag^.ti_Tag of
      TAG1: ...
      TAG2: ...
    else ...
    end;
    tag := NextTagItem(tags);
  end;
end;

See also

GetTagData | Obtain the data corresponding to a tag.
PackBoolTags | Builds a "flag" word from a tag list
FindTagItem | Scan a tag list for a specific tag.


PackBoolTags

Builds a "flag" word from a tag list

Declaration

Source position: utility.pas line 163

function PackBoolTags(

  InitialFlags: LongWord;

  TagList: PTagItem;

  BoolMap: PTagItem

):LongWord;

Arguments

InitialFlags | A starting set of bit-flags which will be changed by the processing of True and False boolean tags in tagList.
TagList | A TagItem list which may contain several tag items defined to be boolean by their presence in boolMap. The logical value of ti_Data determines whether a tag item causes the bit-flag value related by boolMap to be set or cleared in the returned flag longword.
BoolMap | A tag list defining the boolean tags to be recognized, and the bit (or bits) in the returned longword that are to be set or cleared when a boolean Tag is found to be True or False in tagList.

Function result

The accumulated longword of bit-flags, starting with initialFlags and modified by each boolean tag item encountered.

Description

Picks out the boolean tag items in a tag list and converts them into bit-flag representations according to a correspondence defined by the tag list 'boolMap'.

A boolean tag item is one where only the logical value of the ti_Data is relevant. If this field is 0, the value is False, otherwise True.


PackStructureTags

Pack a structure with values from taglist.

Declaration

Source position: utility.pas line 197

function PackStructureTags(

  Pack: Pointer;

  PackTable: PLongWord;

  TagList: PTagItem

):LongWord;

Arguments

Pack | A pointer to the data area to fill in.
PackTable | A pointer to the packing information table.
TagList | A pointer to the taglist to pack into the structure

Function result

The number of tag items packed

Description

For each table entry, a FindTagItem() will be done and if the matching tag is found in the taglist, the data field will be packed into the given structure based on the packtable definition.

See also

FindTagItem | Scan a tag list for a specific tag.
UnpackStructureTags | Unpack a structure to values in taglist.


RefreshTagItemClones

Rejuvenate a clone from the original.

Declaration

Source position: utility.pas line 171

procedure RefreshTagItemClones(

  Clone: PTagItem;

  Original: PTagItem

);

Arguments

Clone | Return value from CloneTagItems(original)
Original | A tag list that hasn't changed since CloneTagItems()

Description

If (and only if) the tag list 'clone' was created from 'original' by CloneTagItems(), and if 'original' has not been changed in any way, you can reset the clone list to its original state by using this function.

See also

CloneTagItems | Copy a tag list.
AllocateTagItems | Allocate a tag list.
FreeTagItems | Free an allocated tag list.
ApplyTagChanges | Change a tag list based on a second tag list.


ReleaseNamedObject

Free a named object.

Declaration

Source position: utility.pas line 206

procedure ReleaseNamedObject(

  NObject: PNamedObject

);

Description

Decrements the open count of the object. If the object has been removed, and the count goes to 0, the remover will be notified that the object is now free.

See also

FindNamedObject | Find the next object of a given name.
RemNamedObject | Remove a named object.


RemNamedObject

Remove a named object.

Declaration

Source position: utility.pas line 207

procedure RemNamedObject(

  NObject: PNamedObject;

  Message: PMessage

);

Arguments

Message

Message to ReplyMsg() (must be supplied)

Description

This function will post a request to release the object from whatever NameSpace it is in. It will reply the message when the object is fully removed. The TMessage.mn_Node.ln_Name field will contain the object pointer or nil if the object was removed by another process.

This function will effectively do a ReleaseNamedObject() thus you must have "found" the object first.

The message is replied with the ln_Name field either being the object or nil. If it contains the object, the object is completely removed.

See also

AttemptRemNamedObject | Attempt to remove a named object.
AddNamedObject | Add a named object to the given namespace.
ReleaseNamedObject | Free a named object.


SDivMod32

Signed 32 by 32 bit division and modulus.

Declaration

Source position: utility.pas line 184

function SDivMod32(

  Dividend: LongInt;

  Divisor: LongInt

):LongInt;

Arguments

Dividend | The number to divide.
Divisor | The to divide by.

Function result

The quotient is returned in the high 32 bits of the result. The remainder in the low 32 bits.

Description

Divides the signed 32 bit dividend by the signed 32 bit divisor and returns a signed 32 bit quotient and remainder.

Errors

It is very hard for a C programmer to obtain the value of the remainder. In fact, its pretty near impossible.

See also

SMult32 | Signed 32 by 32 bit multiply with 32 bit result.
UDivMod32 | Unsigned 32 by 32 bit division and modulus.
UMult32 | Unsigned 32 by 32 bit multiply with 32 bit result.
SMult64 | Signed 32 by 32 bit multiply with 64 bit result.
UMult64 | Unsigned 32 by 32 bit multiply with 64 bit result.


SMult32

Signed 32 by 32 bit multiply with 32 bit result.

Declaration

Source position: utility.pas line 181

function SMult32(

  Arg1: LongInt;

  Arg2: LongInt

):LongInt;

Arguments

Arg1 | Number to multiply
Arg2 | Number to multiply

Function result

The signed 32 bit result of multiplying arg1 by arg2.

Description

Performs the signed 32-bit multiplication of arg1 * arg2 and returns a signed 32 bit value.

This can perform the multiplication either using the machines native instructions (if they exist), or in software using a simple algorithm based on expanding algebraic products.

See also

SDivMod32 | Signed 32 by 32 bit division and modulus.
UDivMod32 | Unsigned 32 by 32 bit division and modulus.
UMult32 | Unsigned 32 by 32 bit multiply with 32 bit result.
SMult64 | Signed 32 by 32 bit multiply with 64 bit result.
UMult64 | Unsigned 32 by 32 bit multiply with 64 bit result.


SMult64

Signed 32 by 32 bit multiply with 64 bit result.

Declaration

Source position: utility.pas line 194

function SMult64(

  Arg1: LongInt;

  Arg2: LongInt

):LongInt;

Arguments

Arg1 | Number to multiply
Arg2 | Number to multiply

Function result

The signed 64 bit result of multiplying arg1 by arg2.

Description

Returns the signed 64 bit result of multiplying arg1 by arg2.

See also

SDivMod32 | Signed 32 by 32 bit division and modulus.
UDivMod32 | Unsigned 32 by 32 bit division and modulus.
UMult32 | Unsigned 32 by 32 bit multiply with 32 bit result.
SMult32 | Signed 32 by 32 bit multiply with 32 bit result.
UMult64 | Unsigned 32 by 32 bit multiply with 64 bit result.


Stricmp

Case-insensitive string comparison.

Declaration

Source position: utility.pas line 187

function Stricmp(

  String1: PChar;

  String2: PChar

):LongInt;

Function result

Relationship between string1 and string2 <0 means string1 < string2 =0 means string1 = string2 >0 means string1 > string2

Description

This function compares two strings, ignoring case using a generic case conversion routine. If the strings have different lengths, the shorter is treated as if it were extended with zeros.

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, identical pairs of strings may return different values when passed to this function. This fact must be taken into consideration when using this function.

See also

Strnicmp

Length-limited case-insensitive string compare.


Strnicmp

Length-limited case-insensitive string compare.

Declaration

Source position: utility.pas line 188

function Strnicmp(

  String1: PChar;

  String2: PChar;

  Length: LongInt

):LongInt;

Function result

Relationship between string1 and string2 <0 means string1 < string2 =0 means string1 = string2 >0 means string1 > string2

Description

This function compares two strings, ignoring case using a generic case conversion routine. If the strings have different lengths, the shorter is treated as if it were extended with zeros. This function never compares more than 'length' characters.

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, identical pairs of strings may return different values when passed to this function. This fact must be taken into consideration when using this function.

See also

Stricmp

Case-insensitive string comparison.


TagInArray

Check if a tag value appears in an array of tag values.

Declaration

Source position: utility.pas line 172

function TagInArray(

  TagValue: LongWord;

  TagArray: PTag

):LongBool;

Arguments

TagValue | Tag value to search array for in array.
TagArray | A simple array of tag values terminated by TAG_DONE.

Function result

True if tagValue was found in tagArray.

Description

Determines whether the value tagValue exists in an array of Tags pointed to by tagArray. This array must be contiguous, and must be terminated by TAG_DONE. This is an array of Tags, not an array of TagItems.

See also

FilterTagItems

Remove selected items from a tag list.


TAG_

Declaration

Source position: utility.pas line 214

function TAG_(

  Value: Pointer

):PtrUInt; overload;

function TAG_(

  Value: PChar

):PtrUInt; overload;

function TAG_(

  Value: Boolean

):PtrUInt; overload;

function TAG_(

  Value: LongInt

):PtrUInt; overload;

function TAG_(

  Value: LongWord

):PtrUInt; overload;


TAG_DONE

Tag terminate the array of TagItems.ti_Data unused

Declaration

Source position: utility.pas line 57

const TAG_DONE = 0;


TAG_END

Tag terminate the array of TagItems.ti_Data unused

Declaration

Source position: utility.pas line 58

const TAG_END = 0;


TAG_IGNORE

Ignore this item, not end of array

Declaration

Source position: utility.pas line 59

const TAG_IGNORE = 1;


TAG_MORE

ti_Data is pointer to another array of TagItems note that this tag terminates the current array

Declaration

Source position: utility.pas line 60

const TAG_MORE = 2;


TAG_SKIP

Skip this and the next ti_Data items

Declaration

Source position: utility.pas line 61

const TAG_SKIP = 3;


TAG_USER

Declaration

Source position: utility.pas line 63

const TAG_USER = DWord(1 shl 31);


ToLower

Convert a character to lower case.

Declaration

Source position: utility.pas line 190

function ToLower(

  character: LongWord

):Char;

Function result

Lower case version of the input character.

Description

Converts a character to lower case, handling international character sets. Currently only works for ASCII characters. Would not be difficult to adapt for other character sets (Unicode for example).

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, a given character may return different results when passed to this function. This fact must be taken into consideration when using this function.

See also

ToUpper

Convert a character to upper case.


ToUpper

Convert a character to upper case.

Declaration

Source position: utility.pas line 189

function ToUpper(

  Character: LongWord

):Char;

Function result

Upper case version of input character.

Description

Converts a character to upper case, handling international character sets. Currently only works for ASCII characters. Would not be difficult to adapt for other character sets (Unicode for example).

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, a given character may return different results when passed to this function. This fact must be taken into consideration when using this function.

See also

ToLower

Convert a character to lower case.


UDivMod32

Unsigned 32 by 32 bit division and modulus.

Declaration

Source position: utility.pas line 185

function UDivMod32(

  Dividend: LongWord;

  Divisor: LongWord

):LongWord;

Description

Divides the unsigned 32 bit dividend by the unsigned 32 bit divisor and returns an unsigned 32 bit quotient and remainder.

Errors

It is impossible for Pascal/C programmers to obtain the value of remainder.

See also

SDivMod32 | Signed 32 by 32 bit division and modulus.
SMult64 | Signed 32 by 32 bit multiply with 64 bit result.
UMult32 | Unsigned 32 by 32 bit multiply with 32 bit result.
SMult32 | Signed 32 by 32 bit multiply with 32 bit result.
UMult64 | Unsigned 32 by 32 bit multiply with 64 bit result.


UMult32

Unsigned 32 by 32 bit multiply with 32 bit result.

Declaration

Source position: utility.pas line 182

function UMult32(

  Arg1: LongWord;

  Arg2: LongWord

):LongWord;

Arguments

Arg1 | Number to multiply
Arg2 | Number to multiply

Function result

The unsigned 32 bit result of multiplying arg1 by arg2.

Description

Returns the unsigned 32 bit result of multiplying arg1 by arg2.

See also

SDivMod32 | Signed 32 by 32 bit division and modulus.
SMult64 | Signed 32 by 32 bit multiply with 64 bit result.
UDivMod32 | Unsigned 32 by 32 bit division and modulus.
SMult32 | Signed 32 by 32 bit multiply with 32 bit result.
UMult64 | Unsigned 32 by 32 bit multiply with 64 bit result.


UMult64

Unsigned 32 by 32 bit multiply with 64 bit result.

Declaration

Source position: utility.pas line 195

function UMult64(

  Arg1: LongWord;

  Arg2: LongWord

):LongWord;

Arguments

Arg1 | Number to multiply
Arg2 | Number to multiply

Function result

The unsigned 64 bit result of multiplying arg1 by arg2.

Description

Returns the unsigned 64 bit result of multiplying arg1 by arg2.

See also

SDivMod32 | Signed 32 by 32 bit division and modulus.
SMult64 | Signed 32 by 32 bit multiply with 64 bit result.
UDivMod32 | Unsigned 32 by 32 bit division and modulus.
SMult32 | Signed 32 by 32 bit multiply with 32 bit result.
UMult32 | Unsigned 32 by 32 bit multiply with 32 bit result.


UnpackStructureTags

Unpack a structure to values in taglist.

Declaration

Source position: utility.pas line 198

function UnpackStructureTags(

  Pack: Pointer;

  PackTable: PLongWord;

  TagList: PTagItem

):LongWord;

Arguments

Pack | A pointer to the data area to be unpacked
PackTable | A pointer to the packing information table.
TagList | A pointer to the taglist to unpack into

Function result

The number of tag items unpacked

Description

For each table entry, a FindTagItem() will be done and if the matching tag is found in the taglist, the data in the structure will be placed into the memory pointed to by the tag's ti_Data. ti_Data must point to a LongWord.

See also

FindTagITem | Scan a tag list for a specific tag.
PackStructureTags | Pack a structure with values from taglist.


Reference for unit 'workbench': Procedures and functions

AddAppIcon

AddAppIconA

AddAppMenuItem

AddAppMenuItemA

AddAppWindow

AddAppWindowA

AddAppWindowDropZone

AddAppWindowDropZoneA

ChangeWorkbenchSelection

ChangeWorkbenchSelectionA

CloseWorkbenchObject

CloseWorkbenchObjectA

CreateDrawerA

CreateDrawerTags

CreateIconA

CreateIconTags

MakeWorkbenchObjectVisible

MakeWorkbenchObjectVisibleA

ManageDesktopObjectA

ManageDesktopObjectTags

OpenWorkbenchObject

OpenWorkbenchObjectA

RemoveAppIcon

RemoveAppMenuItem

RemoveAppWindow

RemoveAppWindowDropZone

WBInfo

WorkbenchControl

WorkbenchControlA


Unit 'workbench' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'workbench': Variables

WorkbenchBase


Index of all identifiers in unit 'workbench'

A C D G I M N O P R S T U W

A

AddAppIcon | AMCLASSICON_Copy | AMCLASSICON_Snapshot
AddAppIconA | AMCLASSICON_Delete | AMCLASSICON_Unselected
AddAppMenuItem | AMCLASSICON_EmptyTrash | AMCLASSICON_UnSnapshot
AddAppMenuItemA | AMCLASSICON_FormatDisk | AMTYPE_APPICON
AddAppWindow | AMCLASSICON_Information | AMTYPE_APPMENUITEM
AddAppWindowA | AMCLASSICON_LeaveOut | AMTYPE_APPWINDOW
AddAppWindowDropZone | AMCLASSICON_Open | AMTYPE_APPWINDOWZONE
AddAppWindowDropZoneA | AMCLASSICON_PutAway | AM_VERSION
ADZMACTION_Enter | AMCLASSICON_Rename |
ADZMACTION_Leave | AMCLASSICON_Selected |

C

ChangeWorkbenchSelection | CPACTION_Begin | CreateDrawerTags
ChangeWorkbenchSelectionA | CPACTION_Copy | CreateIconA
CloseWorkbenchObject | CPACTION_End | CreateIconTags
CloseWorkbenchObjectA | CreateDrawerA |

D

DDFLAGS_SHOWALL | DDVM_BYICON | DLACTION_BeginEmptyTrash
DDFLAGS_SHOWDEFAULT | DDVM_BYNAME | DLACTION_DeleteContents
DDFLAGS_SHOWICONS | DDVM_BYSIZE | DLACTION_DeleteObject
DDVM_BYDATE | DDVM_BYTYPE | DLACTION_End
DDVM_BYDEFAULT | DLACTION_BeginDiscard | DRAWERDATAFILESIZE

G

GADGBACKFILL GFLG_GADGBACKFILL

I

ISMACTION_Ignore | ISMACTION_Stop
ISMACTION_Select | ISMACTION_Unselect

M

MakeWorkbenchObjectVisible | ManageDesktopObjectA
MakeWorkbenchObjectVisibleA | ManageDesktopObjectTags

N

NO_ICON_POSITION

O

OLDDRAWERDATAFILESIZE OpenWorkbenchObject OpenWorkbenchObjectA

P

PAppIcon | PCopyBeginMsg | PFreeList
PAppIconRenderMsg | PCopyDataMsg | PIconSelectMsg
PAppMenu | PCopyEndMsg | POldDrawerData
PAppMenuItem | PDeleteBeginMsg | PSetupCleanupHookMsg
PAppMessage | PDeleteDataMsg | PTextInputMsg
PAppWindow | PDeleteEndMsg | PWBArg
PAppWindowDropZone | PDiskObject | PWBArgList
PAppWindowDropZoneMsg | PDrawerData | PWBStartup

R

RemoveAppIcon | RemoveAppWindow
RemoveAppMenuItem | RemoveAppWindowDropZone

S

SCHMSTATE_Cleanup SCHMSTATE_Setup SCHMSTATE_TryCleanup

T

TAppIcon | TCopyDataMsg | TIACTION_NewDrawer
TAppIconRenderMsg | TCopyEndMsg | TIACTION_RelabelVolume
TAppMenu | TDeleteBeginMsg | TIACTION_Rename
TAppMenuItem | TDeleteDataMsg | TIconSelectMsg
TAppMessage | TDeleteEndMsg | TOldDrawerData
TAppWindow | TDiskObject | TSetupCleanupHookMsg
TAppWindowDropZone | TDrawerData | TTextInputMsg
TAppWindowDropZoneMsg | TFreeList | TWBArg
TCopyBeginMsg | TIACTION_Execute | TWBStartup

U

UPDATEWB_ObjectAdded UPDATEWB_ObjectRemoved

W

WBA_Dummy | WBA_Reserved2 | WBCTRLA_SetTextInputHook
WBA_LAST_TAG | WBA_Reserved3 | WBCTRLA_SetTypeRestartTime
WBAPPICON | WBA_Reserved4 | WBDEVICE
WBAPPICONA_Clone | WBA_Reserved5 | WBDISK
WBAPPICONA_NotifySelectState | WBA_Reserved6 | WB_DISKMAGIC
WBAPPICONA_PropagatePosition | WBA_Reserved7 | WB_DISKREVISION
WBAPPICONA_RenderHook | WBA_Reserved8 | WB_DISKREVISIONMASK
WBAPPICONA_SupportsCopy | WBA_Reserved9 | WB_DISKVERSION
WBAPPICONA_SupportsDelete | WBArgList | WBDRAWER
WBAPPICONA_SupportsEmptyTrash | WBCTRLA_AddHiddenDeviceName | WBDZA_Box
WBAPPICONA_SupportsFormatDisk | WBCTRLA_AddSetupCleanupHook | WBDZA_Height
WBAPPICONA_SupportsInformation | WBCTRLA_DuplicateSearchPath | WBDZA_Hook
WBAPPICONA_SupportsLeaveOut | WBCTRLA_FreeHiddenDeviceList | WBDZA_Left
WBAPPICONA_SupportsOpen | WBCTRLA_FreeOpenDrawerList | WBDZA_RelBottom
WBAPPICONA_SupportsPutAway | WBCTRLA_FreeProgramList | WBDZA_RelHeight
WBAPPICONA_SupportsRename | WBCTRLA_FreeSearchPath | WBDZA_RelRight
WBAPPICONA_SupportsSnapshot | WBCTRLA_FreeSelectedIconList | WBDZA_RelWidth
WBAPPICONA_SupportsUnSnapshot | WBCTRLA_GetCopyHook | WBDZA_Top
WBAPPMENUA_CommandKeyString | WBCTRLA_GetDefaultStackSize | WBDZA_Width
WBAPPMENUA_GetKey | WBCTRLA_GetDeleteHook | WBGARBAGE
WBAPPMENUA_GetTitleKey | WBCTRLA_GetHiddenDeviceList | WBInfo
WBAPPMENUA_UseKey | WBCTRLA_GetOpenDrawerList | WBKICK
WBA_Reserved1 | WBCTRLA_GetProgramList | WBOPENA_ArgLock
WBA_Reserved10 | WBCTRLA_GetSelectedIconList | WBOPENA_ArgName
WBA_Reserved11 | WBCTRLA_GetTextInputHook | WBOPENA_Show
WBA_Reserved12 | WBCTRLA_GetTypeRestartTime | WBOPENA_ViewBy
WBA_Reserved13 | WBCTRLA_IsOpen | WBPROJECT
WBA_Reserved14 | WBCTRLA_RedrawAppIcon | WBTOOL
WBA_Reserved15 | WBCTRLA_RemoveHiddenDeviceName | WorkbenchBase
WBA_Reserved16 | WBCTRLA_RemSetupCleanupHook | WorkbenchControl
WBA_Reserved17 | WBCTRLA_SetCopyHook | WorkbenchControlA
WBA_Reserved18 | WBCTRLA_SetDefaultStackSize | WORKBENCHNAME
WBA_Reserved19 | WBCTRLA_SetDeleteHook |


AddAppIcon

Declaration

Source position: workbench.pas line 487

function AddAppIcon(

  Id: LongWord;

  UserData: LongWord;

  Text_: PChar;

  MsgPort: PMsgPort;

  Lock: LongInt;

  DiskObj: PDiskObject;

  const TagList: array of PtrUInt

):PAppIcon;


AddAppIconA

Declaration

Source position: workbench.pas line 467

function AddAppIconA(

  Id: LongWord;

  UserData: LongWord;

  Text_: PChar;

  MsgPort: PMsgPort;

  Lock: LongInt;

  DiskObj: PDiskObject;

  const TagList: PTagItem

):PAppIcon;


AddAppMenuItem

Declaration

Source position: workbench.pas line 488

function AddAppMenuItem(

  Id: LongWord;

  UserData: LongWord;

  Text_: PChar;

  MsgPort: PMsgPort;

  const Tags: array of PtrUInt

):PAppMenuItem;


AddAppMenuItemA

Declaration

Source position: workbench.pas line 468

function AddAppMenuItemA(

  Id: LongWord;

  UserData: LongWord;

  Text_: PChar;

  MsgPort: PMsgPort;

  const TagList: PTagItem

):PAppMenuItem;


AddAppWindow

Declaration

Source position: workbench.pas line 489

function AddAppWindow(

  Id: LongWord;

  UserData: LongWord;

  Window: PWindow;

  MsgPort: PMsgPort;

  const Tags: array of PtrUInt

):PAppWindow;


AddAppWindowA

Declaration

Source position: workbench.pas line 469

function AddAppWindowA(

  Id: LongWord;

  UserData: LongWord;

  Window: PWindow;

  MsgPort: PMsgPort;

  const TagList: PTagItem

):PAppWindow;


AddAppWindowDropZone

Declaration

Source position: workbench.pas line 494

function AddAppWindowDropZone(

  Aw: PAppWindow;

  Id: LongWord;

  UserData: LongWord;

  const Tags: array of PtrUInt

):PAppWindowDropZone;


AddAppWindowDropZoneA

Declaration

Source position: workbench.pas line 475

function AddAppWindowDropZoneA(

  Aw: PAppWindow;

  Id: LongWord;

  UserData: LongWord;

  const Tags: PTagItem

):PAppWindowDropZone;


ChangeWorkbenchSelection

Declaration

Source position: workbench.pas line 495

function ChangeWorkbenchSelection(

  Name: PChar;

  Hook: PHook;

  const Tags: array of PtrUInt

):LongBool;


ChangeWorkbenchSelectionA

Declaration

Source position: workbench.pas line 476

function ChangeWorkbenchSelectionA(

  Name: PChar;

  Hook: PHook;

  const Tags: PTagItem

):LongBool;


CloseWorkbenchObject

Declaration

Source position: workbench.pas line 492

function CloseWorkbenchObject(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


CloseWorkbenchObjectA

Declaration

Source position: workbench.pas line 477

function CloseWorkbenchObjectA(

  Name: PChar;

  const Tags: PTagItem

):LongBool;


CreateDrawerA

Declaration

Source position: workbench.pas line 484

function CreateDrawerA(

  Drawer: PChar;

  Tags: PTagItem

):Boolean;


CreateDrawerTags

Declaration

Source position: workbench.pas line 499

function CreateDrawerTags(

  Drawer: PChar;

  const Tags: array of PtrUInt

):Boolean;


CreateIconA

Declaration

Source position: workbench.pas line 485

function CreateIconA(

  Name: PChar;

  Tags: PTagItem

):Boolean;


CreateIconTags

Declaration

Source position: workbench.pas line 500

function CreateIconTags(

  Name: PChar;

  const Tags: array of PtrUInt

):Boolean;


MakeWorkbenchObjectVisible

Declaration

Source position: workbench.pas line 496

function MakeWorkbenchObjectVisible(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


MakeWorkbenchObjectVisibleA

Declaration

Source position: workbench.pas line 478

function MakeWorkbenchObjectVisibleA(

  Name: PChar;

  const Tags: PTagItem

):LongBool;


ManageDesktopObjectA

Declaration

Source position: workbench.pas line 483

function ManageDesktopObjectA(

  Name: PChar;

  Action: LongInt;

  Tags: PTagItem

):Boolean;


ManageDesktopObjectTags

Declaration

Source position: workbench.pas line 498

function ManageDesktopObjectTags(

  Name: PChar;

  Action: LongInt;

  const Tags: array of PtrUInt

):Boolean;


OpenWorkbenchObject

Declaration

Source position: workbench.pas line 491

function OpenWorkbenchObject(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


OpenWorkbenchObjectA

Declaration

Source position: workbench.pas line 479

function OpenWorkbenchObjectA(

  Name: PChar;

  const Tags: PTagItem

):LongBool;


RemoveAppIcon

Declaration

Source position: workbench.pas line 470

function RemoveAppIcon(

  AppIcon: PAppIcon

):LongBool;


RemoveAppMenuItem

Declaration

Source position: workbench.pas line 471

function RemoveAppMenuItem(

  AppMenuItem: PAppMenuItem

):LongBool;


RemoveAppWindow

Declaration

Source position: workbench.pas line 472

function RemoveAppWindow(

  AppWindow: PAppWindow

):LongBool;


RemoveAppWindowDropZone

Declaration

Source position: workbench.pas line 480

function RemoveAppWindowDropZone(

  Aw: PAppWindow;

  DropZone: PAppWindowDropZone

):LongBool;


WBInfo

Declaration

Source position: workbench.pas line 473

procedure WBInfo(

  Lock: LongInt;

  Name: PChar;

  Screen: PScreen

);


WorkbenchControl

Declaration

Source position: workbench.pas line 493

function WorkbenchControl(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


WorkbenchControlA

Declaration

Source position: workbench.pas line 481

function WorkbenchControlA(

  Name: PChar;

  const Tags: PTagItem

):LongBool;


Reference for package 'morphunits'

Units

agraphics | Native Amiga graphic functions (graphics.library)
AHI
akeyboard
AmigaDOS | File and directory handling routines and types (dos.library)
amigalib
asl
cgxvideo
clipboard
commodities
console
conunit
CYBERGRAPHICS | CyberGraphics System compatbible interface for MorphOS (cybergraphics.library)
datatypes
diskfont |
exec | This unit contains the types and wrapper functions for the exec.library.
gadtools
get9
hardware
icon | Icon handling routines (icon.library)
iffparse
input
inputevent
intuition | Screen and Window handling routines of intuition.library
keymap
layers | Layer handling
locale
mui |
serial
timer
tinygl
utility | Tag Handling, Date routines in utility.library
workbench | Basic Workbench/AppIcons functions (workbench.library)


Index of all identifiers in package 'morphunits'

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

A2024FIFTEENHERTZ_KEY | AFB_68030 | ANFRACSIZE
A2024_MONITOR_ID | AFB_68040 | AN_FreeTwice
A2024TENHERTZ_KEY | AFB_68060 | AN_FreeVec
ABC | AFB_68881 | AN_GadgetType
ABDAY_1 | AFB_68882 | AN_GadTools
ABDAY_2 | AFB_BITMAP | AN_GamePortDev
ABDAY_3 | AFB_DISK | AN_GfxFreeError
ABDAY_4 | AFB_FPU40 | AN_GfxNewError
ABDAY_5 | AFB_MEMORY | AN_GfxNoLCM
ABDAY_6 | AFB_PRIVATE | AN_GfxNoMem
ABDAY_7 | AFB_SCALED | AN_GfxNoMemMspc
ABMON_1 | AFB_TAGGED | AN_GraphicsLib
ABMON_10 | AFF_68010 | AN_IconLib
ABMON_11 | AFF_68020 | Animate
ABMON_12 | AFF_68030 | ANIMATIONDTCLASS
ABMON_2 | AFF_68040 | ANIMHALF
ABMON_3 | AFF_68060 | AN_InitAPtr
ABMON_4 | AFF_68881 | AN_IntrMem
ABMON_5 | AFF_68882 | AN_Intuition
ABMON_6 | AFF_BITMAP | AN_IOAfterClose
ABMON_7 | AFF_DISK | AN_IOUsedTwice
ABMON_8 | AFF_FPU40 | AN_ISemOrder
ABMON_9 | AFF_MEMORY | AN_ItemAlloc
ABNC | AFF_PRIVATE | AN_ItemBoxTop
AbortAslRequest | AFF_SCALED | AN_KeyboardDev
ABORT_BUSY | AFF_TAGGED | AN_KeyFree
ABORT_DISK_ERROR | AG_BadParm | AN_KeyRange
AbortIO | AG_CloseDev | AN_LayersLib
AbortPkt | AG_CloseLib | AN_LayersNoMem
ABSOLUTE_DIMENSIONS | AG_IOError | AN_LibChkSum
ACCESS_READ | AG_MakeLib | AN_LongFrame
ACCESS_WRITE | AG_MsgPortNotEmpty | AN_MakeVPort
ACPU_AddressErr | AG_NoMemory | AN_MathLib
ACPU_AutoVec1 | AG_NoSignal | AN_MemCorrupt
ACPU_AutoVec2 | AG_OpenDev | AN_MemoryInsane
ACPU_AutoVec3 | AG_OpenLib | AN_MiscRsrc
ACPU_AutoVec4 | AG_OpenRes | AN_NoConsole
ACPU_AutoVec5 | AG_ProcCreate | AN_NoFonts
ACPU_AutoVec6 | agraphics | AN_NoISem
ACPU_AutoVec7 | AHI | AN_NoWindow
ACPU_BusErr | AHIA_AudioID | AN_ObsoleteFont
ACPU_CHK | AHIA_Channels | ANO_Flags
ACPU_DivZero | AHI_AddAudioMode | ANO_NameSpace
ACPU_Format | AHI_AllocAudio | AN_OpenScreen
ACPU_InstErr | AHI_AllocAudioA | AN_OpenScrnRast
ACPU_LineA | AHI_AllocAudioRequest | AN_OpenWindow
ACPU_LineF | AHI_AllocAudioRequestA | ANO_Priority
ACPU_PrivErr | AHIA_MaxPlayerFreq | ANO_UserSpace
ACPU_Spurious | AHIA_MinPlayerFreq | AN_PlaneAlloc
ACPU_Trace | AHIA_MixFreq | AN_QPktFail
ACPU_TRAPV | AHIA_PlayerFreq | AN_RAMLib
ACTION_ADD_NOTIFY | AHIA_PlayerFunc | AN_RegionMemory
ACTION_CHANGE_MODE | AHIA_RecordFunc | AN_SemCorrupt
ACTION_CHANGE_SIGNAL | AHIA_SoundFunc | AN_ShortFrame
ACTION_COPY_DIR | AHIA_Sounds | AN_StackProbe
ACTION_COPY_DIR_FH | AHI_AudioRequest | AN_StartMem
ACTION_CREATE_DIR | AHI_AudioRequestA | AN_SubAlloc
ACTION_CURRENT_VOLUME | AHIA_UserData | AN_SysScrnType
ACTION_DELETE_OBJECT | AHIBase | AN_TDCalibSeek
ACTION_DIE | AHIB_Dizzy | AN_TDDelay
ACTION_DISK_CHANGE | AHI_BestAudioID | AN_TextTmpRas
ACTION_DISK_INFO | AHI_BestAudioIDA | ANTI_ALIAS
ACTION_DISK_TYPE | AHIC_Input | AN_TimerDev
ACTION_END | AHIC_InputGain | AN_TMBadReq
ACTION_EVENT | AHIC_InputGain_Query | AN_TMBadSupply
ACTION_EXAMINE_ALL | AHIC_Input_Query | AN_TrackDiskDev
ACTION_EXAMINE_ALL_END | AHIC_MixFreq_Query | AN_Unknown
ACTION_EXAMINE_FH | AHIC_MonitorVolume | AN_UtilityLib
ACTION_EXAMINE_FH64 | AHIC_MonitorVolume_Query | AN_WBBadIOMsg
ACTION_EXAMINE_NEXT | AHI_ControlAudio | AN_WBBadStartupMsg1
ACTION_EXAMINE_NEXT64 | AHI_ControlAudioA | AN_WBBadStartupMsg2
ACTION_EXAMINE_OBJECT | AHIC_Output | AN_WBReLayoutToolMenu
ACTION_EXAMINE_OBJECT64 | AHIC_Output_Query | AN_WeirdEcho
ACTION_FH_FROM_LOCK | AHIC_OutputVolume | AN_Workbench
ACTION_FINDINPUT | AHIC_OutputVolume_Query | AO_AudioDev
ACTION_FINDOUTPUT | AHIC_Play | AO_BootStrap
ACTION_FINDUPDATE | AHIC_Record | AO_CIARsrc
ACTION_FLUSH | AHIDB_Annotation | AO_ConsoleDev
ACTION_FORMAT | AHIDB_AudioID | AO_DiskCopy
ACTION_FREE_DISK_FSSM | AHIDB_Author | AO_DiskfontLib
ACTION_FREE_LOCK | AHIDB_Bits | AO_DiskRsrc
ACTION_FREE_RECORD | AHIDB_BufferLen | AO_DOSLib
ACTION_FREE_RECORD64 | AHIDB_Copyright | AO_ExecLib
ACTION_GET_BLOCK | AHIDB_Data | AO_ExpansionLib
ACTION_GET_CURRENT_PREFS | AHIDB_Driver | AO_GadTools
ACTION_GET_DISK_FSSM | AHIDB_Flags | AO_GamePortDev
ACTION_GET_PREFS_TEMPLATE | AHIDB_Frequencies | AO_GraphicsLib
ACTION_INFO | AHIDB_Frequency | AO_IconLib
ACTION_INHIBIT | AHIDB_FrequencyArg | AO_Intuition
ACTION_IS_FILESYSTEM | AHIDB_FullDuplex | AO_KeyboardDev
ACTION_LOCATE_OBJECT | AHIDB_HiFi | AO_KeyMapLib
ACTION_LOCK_RECORD | AHIDB_Index | AO_LayersLib
ACTION_LOCK_RECORD64 | AHIDB_IndexArg | AO_MathLib
ACTION_MAKE_LINK | AHIDB_Input | AO_MiscRsrc
ACTION_MORE_CACHE | AHIDB_InputArg | AO_RAMLib
ACTION_NEW_READ_LINK | AHIDB_Inputs | A_OR_B
ACTION_NIL | AHIDB_MaxChannels | A_OR_C
ACTION_PARENT | AHIDB_MaxInputGain | AO_TimerDev
ACTION_PARENT_FH | AHIDB_MaxMixFreq | AO_TrackDiskDev
ACTION_QUERY_ATTR | AHIDB_MaxMonitorVolume | AO_Unknown
ACTION_READ | AHIDB_MaxOutputVolume | AO_UtilityLib
ACTION_READ_LINK | AHIDB_MaxPlaySamples | AO_Workbench
ACTION_READ_RETURN | AHIDB_MaxRecordSamples | APB_DIDDIR
ACTION_REMOVE_NOTIFY | AHIDB_MinInputGain | APB_DirChanged
ACTION_RENAME_DISK | AHIDB_MinMixFreq | APB_DODIR
ACTION_RENAME_OBJECT | AHIDB_MinMonitorVolume | APB_DODOT
ACTION_RESERVED_1 | AHIDB_MinOutputVolume | APB_DOWILD
ACTION_RESERVED_2 | AHIDB_MultTable | APB_FollowHLinks
ACTION_SAME_LOCK | AHIDB_Name | APB_ITSWILD
ACTION_SCREEN_MODE | AHIDB_NOMODESCAN | APB_NOMEMERR
ACTION_SEEK | AHIDB_Output | APEB_DontFollowSLinks
ACTION_SEEK64 | AHIDB_OutputArg | APEB_FutureExtension
ACTION_SERIALIZE_DISK | AHIDB_Outputs | APEB_LiteralSLinks
ACTION_SET_COMMENT | AHIDB_Panning | APEF_DontFollowSLinks
ACTION_SET_DATE | AHIDB_PingPong | APEF_FutureExtension
ACTION_SET_FILE_SIZE | AHIDB_Realtime | APEF_LiteralSLinks
ACTION_SET_FILE_SIZE64 | AHIDB_Record | APF_DIDDIR
ACTION_SET_MAP | AHIDB_Stereo | APF_DirChanged
ACTION_SET_OWNER | AHIDB_Version | APF_DODIR
ACTION_SET_PREFS | AHIDB_Volume | APF_DODOT
ACTION_SET_PROTECT | AHI_DEBUG_ALL | APF_DOWILD
ACTION_STARTUP | AHI_DEBUG_HIGH | APF_FollowHLinks
ACTION_TIMER | AHI_DEBUG_LOW | APF_ITSWILD
ACTION_WAIT_CHAR | AHI_DEBUG_NONE | APF_NOMEMERR
ACTION_WRITE | AHI_DEFAULT_FREQ | ApplyTagChanges
ACTION_WRITE_PROTECT | AHI_DEFAULT_ID | APSB_EXTENDED
ACTION_WRITE_RETURN | AHI_DEFAULT_UNIT | APSF_EXTENDED
ActivateAslRequest | AHIDF_NOMODESCAN | Pointer
ActivateCxObj | AHIE_ABORTED | AreaCircle
ActivateGadget | AHIE_BADSAMPLETYPE | AreaDraw
ActivateWindow | AHIE_BADSOUNDTYPE | AreaEllipse
AddAnimOb | AHIEDM_DRY | AreaEnd
AddAppIcon | AHIEDM_WET | AreaMove
AddAppIconA | AHIE_HALFDUPLEX | AREAOUTLINE
AddAppMenuItem | AHIE_NOMEM | ARROWIDCMP
AddAppMenuItemA | AHIE_OK | ASHIFTSHIFT
AddAppWindow | AHIET_CANCEL | AskFont
AddAppWindowA | AHIET_CHANNELINFO | AskKeyMapDefault
AddAppWindowDropZone | AHIET_DSPECHO | AskSoftStyle
AddAppWindowDropZoneA | AHIET_DSPMASK | asl
AddBob | AHIET_MASTERVOLUME | AslBase
AddBuffers | AHIET_OUTPUTBUFFER | ASL_FileRequest
AddClass | AHIE_UNKNOWN | ASLFO_Activate
AddDevice | AHI_FreeAudio | ASLFO_BackPens
AddDosEntry | AHI_FreeAudioRequest | ASLFO_DoBackPen
AddDTObject | AHI_GetAudioAttrs | ASLFO_DoDrawMode
AddExecNode | AHI_GetAudioAttrsA | ASLFO_DoFrontPen
AddExecNodeA | AHI_INVALID_ID | ASLFO_DoStyle
AddExecNotify | AHI_KillAudio | ASLFO_FilterFunc
AddExecNotifyType | AHI_LoadModeFile | ASLFO_FixedWidthOnly
AddFont | AHI_LoadSound | ASLFO_Flags
AddFreeList | AHI_LOOPBACK_ID | ASLFO_FrontPens
AddGadget | AHI_MIXFREQ | ASLFO_HookFunc
AddGList | AHINAME | ASLFO_InitialBackPen
AddHead | AHI_NextAudioID | ASLFO_InitialDrawMode
AddIEvents | AHI_NOSOUND | ASLFO_InitialFlags
AddIntServer | AHI_NO_UNIT | ASLFO_InitialFrontPen
AddLibrary | AHIP_BeginChannel | ASLFO_InitialHeight
AddMemHandler | AHIP_EndChannel | ASLFO_InitialLeftEdge
AddMemList | AHIP_Freq | ASLFO_InitialName
AddNamedObject | AHI_Play | ASLFO_InitialSize
AddPart | AHI_PlayA | ASLFO_InitialStyle
AddPort | AHIP_Length | ASLFO_InitialTopEdge
AddResident | AHIP_LoopFreq | ASLFO_InitialWidth
AddResource | AHIP_LoopLength | ASLFO_IntuiMsgFunc
ADDS_Dummy | AHIP_LoopOffset | ASLFO_Locale
AddSegment | AHIP_LoopPan | ASLFO_MaxBackPen
AddSegmentTagList | AHIP_LoopSound | ASLFO_MaxFrontPen
AddSemaphore | AHIP_LoopVol | ASLFO_MaxHeight
ADDS_Filename | AHIP_Offset | ASLFO_MinHeight
ADDS_Name | AHIP_Pan | ASLFO_ModeList
ADDS_Seglist | AHIP_Sound | ASLFO_NegativeText
ADDS_Type | AHIP_Vol | ASL_FontRequest
AddTail | AHIR_DoDefaultMode | ASLFO_PopToFront
AddTask | AHIR_DoMixFreq | ASLFO_PositiveText
AddTime | AHI_RemoveAudioMode | ASLFO_PrivateIDCMP
AddVSprite | AHIR_FilterFunc | ASLFO_PubScreenName
ADKB_FAST | AHIR_FilterTags | ASLFO_SampleText
ADKB_MFMPREC | AHIR_InitialAudioID | ASLFO_Screen
ADKB_MSBSYNC | AHIR_InitialHeight | ASLFO_SleepWindow
ADKB_PRECOMP0 | AHIR_InitialInfoHeight | ASLFO_TextAttr
ADKB_PRECOMP1 | AHIR_InitialInfoLeftEdge | ASLFO_TitleText
ADKB_SETCLR | AHIR_InitialInfoOpened | ASLFO_UserData
ADKB_UARTBRK | AHIR_InitialInfoTopEdge | ASLFO_Window
ADKB_USE0P1 | AHIR_InitialInfoWidth | ASLFR_AcceptPattern
ADKB_USE0V1 | AHIR_InitialLeftEdge | ASLFR_Activate
ADKB_USE1P2 | AHIR_InitialMixFreq | ASLFR_DoMultiSelect
ADKB_USE1V2 | AHIR_InitialTopEdge | ASLFR_DoPatterns
ADKB_USE2P3 | AHIR_InitialWidth | ASLFR_DoSaveMode
ADKB_USE2V3 | AHIR_IntuiMsgFunc | ASLFR_DrawersOnly
ADKB_USE3PN | AHIR_Locale | ASLFR_FilterDrawers
ADKB_USE3VN | AHIR_NegativeText | ASLFR_FilterFunc
ADKB_WORDSYNC | AHIR_PositiveText | ASLFR_Flags1
ADKF_FAST | AHIR_PrivateIDCMP | ASLFR_Flags2
ADKF_MFMPREC | AHIR_PubScreenName | ASLFR_GetSortBy
ADKF_MSBSYNC | AHIR_Screen | ASLFR_GetSortDrawers
ADKF_PRE000NS | AHIR_SleepWindow | ASLFR_GetSortOrder
ADKF_PRE140NS | AHIR_TextAttr | ASLFR_HookFunc
ADKF_PRE280NS | AHIR_TitleText | ASLFR_InitialDrawer
ADKF_PRE560NS | AHIR_UserData | ASLFR_InitialFile
ADKF_PRECOMP0 | AHIR_Window | ASLFR_InitialHeight
ADKF_PRECOMP1 | AHI_SampleFrameSize | ASLFR_InitialLeftEdge
ADKF_SETCLR | AHISB_IMM | ASLFR_InitialPattern
ADKF_UARTBRK | AHI_SetEffect | ASLFR_InitialShowVolumes
ADKF_USE0P1 | AHI_SetFreq | ASLFR_InitialTopEdge
ADKF_USE0V1 | AHI_SetSound | ASLFR_InitialWidth
ADKF_USE1P2 | AHI_SetVol | ASLFR_IntuiMsgFunc
ADKF_USE1V2 | AHISF_IMM | ASLFR_Locale
ADKF_USE2P3 | AHIST_BW | ASLFR_NegativeText
ADKF_USE2V3 | AHIST_DYNAMICSAMPLE | ASLFR_PopToFront
ADKF_USE3PN | AHIST_INPUT | ASLFR_PositiveText
ADKF_USE3VN | AHIST_M16S | ASLFR_PrivateIDCMP
ADKF_WORDSYNC | AHIST_M32S | ASLFR_PubScreenName
ADO_AN_AssignList | AHIST_M8S | ASLFR_RejectIcons
ADO_AN_AssignName | AHIST_M8U | ASLFR_RejectPattern
ADO_AN_Lock | AHIST_NOTYPE | ASLFR_Screen
ADO_AN_MsgPort | AHIST_S16S | ASLFR_SetSortBy
ADO_AN_Name | AHIST_S32S | ASLFR_SetSortDrawers
ADO_AN_Type | AHIST_S8S | ASLFR_SetSortOrder
ADO_CLI_Background | AHIST_SAMPLE | ASLFR_SleepWindow
ADO_CLI_CommFile | AHI_TagBase | ASLFRSORTBY_Date
ADO_CLI_CommName | AHI_TagBaseR | ASLFRSORTBY_Name
ADO_CLI_DefaultStack | AHI_UnloadSound | ASLFRSORTBY_Size
ADO_CLI_Dir | akeyboard | ASLFRSORTDRAWERS_First
ADO_CLI_FailLevel | Alert | ASLFRSORTDRAWERS_Last
ADO_CLI_Interactive | ALERT_TYPE | ASLFRSORTDRAWERS_Mix
ADO_CLI_Prompt | AllocAbs | ASLFRSORTORDER_Ascend
ADO_CLI_Result2 | AllocAslRequest | ASLFRSORTORDER_Descend
ADO_CLI_ReturnCode | AllocAslRequestTags | ASLFR_TextAttr
ADO_CommFileLen | Allocate | ASLFR_TitleText
ADO_CommNameLen | AllocateAligned | ASLFR_UserData
ADO_DE | AllocateTagItems | ASLFR_Window
ADO_DE_Baud | AllocBitMap | ASL_LAST_TAG
ADO_DE_BlksPerTrack | AllocCModeListTagList | ASLNAME
ADO_DE_BootBlocks | AllocDBufInfo | ASLOPTION_ASLOverrides
ADO_DE_BootPri | AllocDosObject | ASLPOS_CenterMouse
ADO_DE_BufMemType | AllocDosObjectTagList | ASLPOS_CenterScreen
ADO_DE_Control | AllocDosObjectTags | ASLPOS_CenterWindow
ADO_DE_DosType | AllocEntry | ASLPOS_DefaultPosition
ADO_DE_HighCyl | AllocFileRequest | ASLPOS_MASK
ADO_DE_Interleave | AllocIFF | ASLPOS_ScreenPosition
ADO_DE_LowCyl | AllocLocalItem | ASLPOS_WindowPosition
ADO_DE_Mask | AllocMemAligned | AslRequest
ADO_DE_MaxTransfer | AllocNamedObject | AslRequestTags
ADO_DE_NumBuffers | AllocNamedObjectA | ASL_ScreenModeRequest
ADO_DE_NumHeads | AllocPooled | ASL_SEMAPHORE_NAME
ADO_DE_PreAlloc | AllocPooledAligned | ASLSIZE_DefaultSize
ADO_DE_PreFac | AllocRaster | ASLSIZE_MASK
ADO_DE_ReservedBlks | AllocRemember | ASLSIZE_RelativeSize
ADO_DE_SecOrg | AllocScreenBuffer | ASLSM_Activate
ADO_DE_SecsPerBlk | AllocSignal | ASLSM_CustomSMList
ADO_DE_SizeBlock | AllocSpriteData | ASLSM_DoAutoScroll
ADO_DE_Surfaces | AllocSpriteDataA | ASLSM_DoDepth
ADO_DE_TableSize | AllocTaskPooled | ASLSM_DoHeight
ADO_DE_UpperCyl | AllocTrap | ASLSM_DoOverscanType
ADO_DirLen | AllocVec | ASLSM_DoWidth
ADO_DN_ExitNotifyMsg | AllocVecAligned | ASLSM_FilterFunc
ADO_DN_Flags | AllocVecDMA | ASLSM_InitialAutoScroll
ADO_DN_GlobalVec | AllocVecPooled | ASLSM_InitialDisplayDepth
ADO_DN_Handler | AllocVecTaskPooled | ASLSM_InitialDisplayHeight
ADO_DN_Lock | ALPHA_P_101 | ASLSM_InitialDisplayID
ADO_DN_MsgPort | ALTLEFT | ASLSM_InitialDisplayWidth
ADO_DN_Name | ALTRIGHT | ASLSM_InitialHeight
ADO_DN_Priority | AMCLASSICON_Copy | ASLSM_InitialInfoLeftEdge
ADO_DN_Seglist | AMCLASSICON_Delete | ASLSM_InitialInfoOpened
ADO_DN_SerialID | AMCLASSICON_EmptyTrash | ASLSM_InitialInfoTopEdge
ADO_DN_StackSize | AMCLASSICON_FormatDisk | ASLSM_InitialLeftEdge
ADO_DN_Startup | AMCLASSICON_Information | ASLSM_InitialOverscanType
ADO_DN_StartupValue | AMCLASSICON_LeaveOut | ASLSM_InitialTopEdge
ADO_DN_Status | AMCLASSICON_Open | ASLSM_InitialWidth
ADO_Dummy | AMCLASSICON_PutAway | ASLSM_IntuiMsgFunc
ADO_FH_Mode | AMCLASSICON_Rename | ASLSM_Locale
ADO_FS_DosType | AMCLASSICON_Selected | ASLSM_MaxDepth
ADO_FSSM | AMCLASSICON_Snapshot | ASLSM_MaxHeight
ADO_FSSM_Device | AMCLASSICON_Unselected | ASLSM_MaxWidth
ADO_FSSM_Flags | AMCLASSICON_UnSnapshot | ASLSM_MinDepth
ADO_FSSM_Unit | Amiga2Date | ASLSM_MinHeight
ADO_PromptLen | AmigaDOS | ASLSM_MinWidth
ADO_VN_Date | AMIGAKEY | ASLSM_NegativeText
ADO_VN_DiskType | AMIGAKEYS | ASLSM_PopToFront
ADO_VN_Lock | AMIGALEFT | ASLSM_PositiveText
ADO_VN_LockList | amigalib | ASLSM_PrivateIDCMP
ADO_VN_MsgPort | AMIGARIGHT | ASLSM_PropertyFlags
ADO_VN_Name | AM_STR | ASLSM_PropertyMask
ADTA_Allocated | AMTYPE_APPICON | ASLSM_PubScreenName
ADTA_ColorRegisters | AMTYPE_APPMENUITEM | ASLSM_Screen
ADTA_ColorTable | AMTYPE_APPWINDOW | ASLSM_SleepWindow
ADTA_ColorTable2 | AMTYPE_APPWINDOWZONE | ASLSM_TextAttr
ADTA_CRegs | AM_VERSION | ASLSM_TitleText
ADTA_Cycles | AN_AddSWGadget | ASLSM_UserData
ADTA_Depth | AN_AsyncPkt | ASLSM_Window
ADTA_Dummy | AN_AudioDev | ASL_TB
ADTA_Frame | AN_BadChkSum | ASPECT_HORIZ
ADTA_FrameIncrement | AN_BadExpansionFree | ASPECT_VERT
ADTA_Frames | AN_BadFreeAddr | AssignAdd
ADTA_FramesPerSecond | AN_BadGadget | AssignLate
ADTA_GRegs | AN_BadInitFunc | AssignLock
ADTA_Height | AN_BadMessage | AssignPath
ADTA_KeyFrame | AN_BadOverlay | AsTag
ADTA_LeftSample | AN_BadSegList | AT_DeadEnd
ADTA_ModeID | AN_BadSemaphore | A_TO_D
ADTA_NumAlloc | AN_BadState | AT_Recovery
ADTA_NumColors | AN_BaseChkSum | AttachCxObj
ADTA_NumSparse | ANBC | AttachPalExtra
ADTA_Period | AN_BitMap | AttachVLayerTagList
ADTA_PreloadFrameCount | AN_BltBitMap | AttemptLockDosList
ADTA_Remap | ANBNC | AttemptLockLayerRom
ADTA_RightSample | AN_BogusExcpt | AttemptRemNamedObject
ADTA_Sample | AN_BootError | AttemptSemaphore
ADTA_SampleLength | AN_BootStrap | AttemptSemaphoreShared
ADTA_SamplesPerSec | AN_CIARsrc | AUL
ADTA_Screen | AN_ConsoleDev | AUTOBACKPEN
ADTA_SparseTable | AN_CreatePort | AUTODRAWMODE
ADTA_Volume | AN_DiskBlkSeq | AUTOFRONTPEN
ADTA_Width | AN_DiskCopy | AUTOITEXTFONT
ADTM_Dummy | AN_DiskError | AUTOKNOB
ADTM_LOADFRAME | AN_DiskfontLib | AUTOLEFTEDGE
ADTM_LOADNEWFORMATFRAME | AN_DiskRsrc | AUTONEXTTEXT
ADTM_LOCATE | AN_DOSLib | AutoRequest
ADTM_PAUSE | AndRectRegion | AUTOSCROLL
ADTM_START | AndRegionRegion | AUTOTOPEDGE
ADTM_STOP | AN_DRHasDisk | AvailFonts
ADTM_UNLOADFRAME | AN_DRIntNoAct | AvailMem
ADTM_UNLOADNEWFORMATFRAME | AN_EndTask | AvailPool
ADZMACTION_Enter | AN_ExcptVect | AVOID_FLICKER
ADZMACTION_Leave | AN_ExecLib | A_XOR_C
AFB_68010 | AN_ExpansionLib |
AFB_68020 | AN_FileReclosed |

B

B2BOBBER | BitMapScale | BPLCON2_ZDBPSEL1
B2NORM | BITSET | BPLCON2_ZDBPSEL2
B2SWAP | BITSPERBYTE | BPLCON2_ZDCTEN
BACKGROUNDPEN | BITSPERLONG | BPLCON3_BRDNBLNK
BACKSAVED | BLITMSG_FAULT | BPLCON3_BRDNTRAN
BADDR | BLITREVERSE | BPLCON3_EXTBLKZD
BANDWIDTH_1X | BLOCKPEN | BPLCON3_EXTBLNKEN
BANDWIDTH_2XDBL | BltBitMap | BPLCON3_ZDCLKEN
BANDWIDTH_2XNML | BltBitMapAlpha | LongInt
BANDWIDTH_4X | BltBitMapRastPort | LongInt
BARBLOCKPEN | BltBitMapRastPortAlpha | BROADCAST_BEAMCON
BARDETAILPEN | BLTBMA_DESTALPHAVALUE | BROADCAST_HBSTOP
BARTRIMPEN | BLTBMA_GLOBALALPHA | BROADCAST_HBSTRT
BASEOBJECT | BLTBMA_MIXLEVEL | BROADCAST_HSSTOP
BAUD_110 | BLTBMA_USESOURCEALPHA | BROADCAST_HSSTRT
BAUD_1200 | BltClear | BROADCAST_VBSTOP
BAUD_19200 | BltClearWait | BROADCAST_VBSTRT
BAUD_2400 | BltClearXY | BROADCAST_VSSTOP
BAUD_300 | BltMaskBitMapRastPort | BROADCAST_VSSTRT
BAUD_4800 | BltPattern | BROTHER_15XL
BAUD_9600 | BltTemplate | BSHIFTSHIFT
BAUD_MIDI | BltTemplateAlpha | LongInt
BBFT_BUTTON | BMA_DEPTH | LongInt
BBFT_ICONDROPBOX | BMA_FLAGS | BTD_Client
BBFT_RIDGE | BMA_HEIGHT | BTD_DrawInfo
BC0B_DEST | BMA_WIDTH | BTD_Dummy
BC0B_SRCA | BMB_3DTARGET | BTDERR_Display
BC0B_SRCB | BMB_CLEAR | BTDERR_Memory
BC0B_SRCC | BMB_DISPLAYABLE | BTD_Error
BC0F_DEST | BMB_INTERLEAVED | BTDERR_Size
BC0F_SRCA | BMB_MINPLANES | BTDIF_3DBlanker
BC0F_SRCB | BMB_ROOTMAP | BTDIF_DoNotWait
BC0F_SRCC | BMB_SPECIALFMT | BTDIF_Fast3D
BC1F_DESC | BMB_STANDARD | BTDI_Revision
BDRAWN | BMF_3DTARGET | BTDMAXSTRLEN
BEEPING_f | BMF_CLEAR | BTD_PreviewMode
BeginRefresh | BMF_DISPLAYABLE | BTDPT_BOOLEAN
BeginUpdate | BMF_INTERLEAVED | BTDPT_CYCLE
BehindLayer | BMF_MINPLANES | BTDPT_FILE
BestCModeIDTagList | BMF_REQUESTVMEM | BTDPT_FONT
BestModeID | BMF_ROOTMAP | BTDPT_INTEGER
BestModeIDA | BMF_SPECIALFMT | BTDPT_STRING
BIDTAG_BlueBits | BMF_STANDARD | BUF_FULL
BIDTAG_COERCE | BNDRYOFF | BUF_LINE
BIDTAG_Depth | BOBISCOMP | BUF_NONE
BIDTAG_DesiredHeight | BOBNIX | BuildEasyRequest
BIDTAG_DesiredWidth | BOBSAWAY | BuildEasyRequestArgs
BIDTAG_DIPFMustHave | BOBUPDATE | BuildSysRequest
BIDTAG_DIPFMustNotHave | SmallInt | BumpRevision
BIDTAG_GfxPrivate | BOOLMASK | BUS_16
BIDTAG_GreenBits | BORDER_BLANKING | BUS_32
BIDTAG_MonitorID | BORDERHIT | BUSERFLAGS
BIDTAG_NominalHeight | BORDER_NOTRANSPARENCY | BUTTONGCLASS
BIDTAG_NominalWidth | BORDERSPRITES | BUTTONIDCMP
BIDTAG_RedBits | BOTTOMHIT | BUTTON_KIND
BIDTAG_SourceID | BOUNDED_DIMENSIONS | BWAITING
BIDTAG_ViewPort | BPLCON2_ZDBPEN | BYTESPERLONG
BITCLR | BPLCON2_ZDBPSEL0 |

C

CacheClearE | CIAF_GAMEPORT1 | CORRECT_RED
CacheClearU | CIAF_LED | CORRECT_RGB_MASK
CacheControl | CIAF_OVERLAY | CPACTION_Begin
CacheFlushDataArea | CIAF_PRTRBUSY | CPACTION_Copy
CacheFlushDataInstArea | CIAF_PRTRPOUT | CPACTION_End
CacheInvalidDataArea | CIAF_PRTRSEL | CPR_NT_LOF
CacheInvalidInstArea | CIAICRB_ALRM | CPR_NT_SHT
CachePostDMA | CIAICRB_FLG | CPR_NT_SYS
CachePreDMA | CIAICRB_IR | CPRNXTBUF
CacheTrashCacheArea | CIAICRB_SETCLR | CPUTBSTACKTRACECOUNT
CACRF_ClearD | CIAICRB_SP | CreateBehindHookLayer
CACRF_ClearI | CIAICRB_TA | CreateBehindLayer
CACRF_CopyBack | CIAICRB_TB | CreateBehindLayerTagList
CACRF_DBE | CIAICRF_ALRM | CreateContext
CACRF_EnableD | CIAICRF_FLG | CreateCxObj
CACRF_EnableE | CIAICRF_IR | CreateDrawerA
CACRF_EnableI | CIAICRF_SETCLR | CreateDrawerTags
CACRF_FreezeD | CIAICRF_SP | CreateExtIO
CACRF_FreezeI | CIAICRF_TA | CreateGadgetA
CACRF_IBE | CIAICRF_TB | CreateIconA
CACRF_WriteAllocate | ClassID | CreateIconTags
CalcIVG | CleanMe | CreateIORequest
CallHookPkt | CLEANME | CreateMenusA
Cause | CLEANUP | CreateMsgPort
CBD_CHANGEHOOK | CleanUp | CreateNewProc
CBD_CURRENTREADID | ClearCxObjError | CreateNewProcTagList
CBD_CURRENTWRITEID | ClearDMRequest | CreateNewProcTags
CBD_DESCRLEN | ClearEOL | CreatePool
CBD_NAMELEN | ClearMenuStrip | CreateProc
CBD_POST | ClearPointer | CreateUpfrontHookLayer
CBD_TITLELEN | ClearRectRegion | CreateUpfrontLayer
CBERR_DUP | ClearRegion | CreateUpfrontLayerTagList
CBERR_OBSOLETEID | ClearScreen | CreateVLayerHandleTagList
CBERR_OK | CLF_INLIST | CR_NEEDS_NO_CONCEALED_RASTERS
CBERR_SYSERR | Cli | CR_NEEDS_NO_LAYERBLIT_DAMAGE
CBERR_VERSION | CLIDATATAG_CLINumber | CSBLANK
CBM_MPS1000 | CLIDATATAG_CommandName | CSCBLANKEN
CBump | CLIDATATAG_Dummy | CSP_PRECEDES
CD_ASKDEFAULTKEYMAP | CLIDATATAG_Sorted | CSP_SUCCEEDS
CD_ASKKEYMAP | CliInitNewcli | CSYNCTRUE
CDInputHandler | CliInitRun | CT_7FRI
CD_SETDEFAULTKEYMAP | ClipBlit | CT_7MON
CD_SETKEYMAP | clipboard | CT_7SAT
CENTER_IMAGE | CloneTagItems | CT_7SUN
cgxvideo | CloseCatalog | CT_7THU
CGXVideoBase | CloseClipboard | CT_7TUE
CGXVIDEONAME | CloseDevice | CT_7WED
ChangeExtSprite | CloseFont | CTABFMT_XRGB8
ChangeExtSpriteA | CLOSEGADGET | CT_ANTIALIAS
CHANGE_FH | CloseIFF | CTB_MAPCOLOR
CHANGE_LOCK | CLOSEIMAGE | CTC_HCLRTAB
ChangeMode | CloseLibrary | CTC_HCLRTABSALL
ChangeScreenBuffer | CloseLocale | CTC_HSETTAB
ChangeSprite | CloseMonitor | CT_COLORFONT
ChangeToSelectedIconColor | CLOSEQUOTE | CT_COLORMASK
ChangeVPBitMap | CloseScreen | CTF_MAPCOLOR
ChangeWindowBox | CloseWindow | CT_GREYFONT
ChangeWorkbenchSelection | CloseWorkBench | CurrentChunk
ChangeWorkbenchSelectionA | CloseWorkbenchObject | CurrentDir
CHECKBOX_HEIGHT | CloseWorkbenchObjectA | CurrentTime
CHECKBOXIDCMP | CMAB_DUALPF_DISABLE | CURSORDOWN
CHECKBOX_KIND | CMAB_FULLPALETTE | CURSORLEFT
CHECKBOX_WIDTH | CMAB_NO_COLOR_LOAD | CURSORRIGHT
CheckDate | CMAB_NO_INTERMED_UPDATE | CURSORUP
CHECKED | CMAF_DUALPF_DISABLE | CUSTOMBITMAP_f
CHECKIMAGE | CMAF_FULLPALETTE | CUSTOM_HOOK
CheckIO | CMAF_NO_COLOR_LOAD | CUSTOMIMAGEDEPTH
CHECKIT | CMAF_NO_INTERMED_UPDATE | CUSTOM_NAME
CheckSignal | CMD_CLEAR | CUSTOM_PAPER
CHECKWIDTH | CMD_DISABLED | CUSTOMSCREEN_f
CIAB_COMCD | CMD_FLUSH | CVideoCtrlTagList
CIAB_COMCTS | CMD_INTERNAL | CWait
CIAB_COMDSR | CMD_INVALID | CWCODE_DEPTH
CIAB_COMDTR | CMD_NONSTD | CWCODE_MOVESIZE
CIAB_COMRTS | CMD_NOTLOADED | CxBase
CIAB_DSKCHANGE | CMD_READ | CxBroker
CIAB_DSKDIREC | CMD_RESET | CX_BROKER
CIAB_DSKMOTOR | CMD_START | CXCMD_APPEAR
CIAB_DSKPROT | CMD_STOP | CXCMD_DISABLE
CIAB_DSKRDY | CMD_SYSTEM | CXCMD_DISAPPEAR
CIAB_DSKSEL0 | CMD_UPDATE | CXCMD_ENABLE
CIAB_DSKSEL1 | CMD_WRITE | CXCMD_KILL
CIAB_DSKSEL2 | CMF_BRDNTRAN | CXCMD_LIST_CHG
CIAB_DSKSEL3 | CMF_BRDRBLNK | CXCMD_UNIQUE
CIAB_DSKSIDE | CMF_BRDRSPRT | CxCustom
CIAB_DSKSTEP | CMF_CMTRANS | CX_CUSTOM
CIAB_DSKTRACK0 | CMF_CPTRANS | CxDebug
CIAB_GAMEPORT0 | CModeRequestTagList | CX_DEBUG
CIAB_GAMEPORT1 | CMove | CxFilter
CIAB_LED | cmpByteRun1 | CX_FILTER
CIAB_OVERLAY | cmpByteRun2 | CX_INVALID
CIAB_PRTRBUSY | CMP_FIBDELTA | CXM_COMMAND
CIAB_PRTRPOUT | cmpNone | CXM_IEVENT
CIAB_PRTRSEL | CMP_NONE | LongInt
CIACRAB_INMODE | CmpTime | CxMsgData
CIACRAB_LOAD | CODESET_COUNT | CxMsgID
CIACRAB_OUTMODE | CODESET_LATIN1 | CxMsgType
CIACRAB_PBON | CODESET_LEGACY | LongInt
CIACRAB_RUNMODE | CODESET_UCS4 | CxObjError
CIACRAB_SPMODE | CODESET_UTF32 | CxObjType
CIACRAB_START | CODESET_UTF8 | CX_SEND
CIACRAB_TODIN | CODETYPE_M68K | CxSender
CIACRAF_INMODE | CODETYPE_PPC | CxSignal
CIACRAF_LOAD | CoerceMode | CX_SIGNAL
CIACRAF_OUTMODE | COERR_BADFILTER | CxTranslate
CIACRAF_PBON | COERR_BADTYPE | CX_TRANSLATE
CIACRAF_RUNMODE | COERR_ISNULL | CX_TYPEFILTER
CIACRAF_SPMODE | COERR_NULLATTACH | CX_ZERO
CIACRAF_START | COF_SHOW_HIDE | CyberGfxBase
CIACRAF_TODIN | ColdReboot | CYBERGFX_INCLUDE_VERSION
CIACRBB_ALARM | CollectionChunk | CYBERGFXNAME
CIACRBB_INMODE0 | CollectionChunks | CYBERGRAPHICS
CIACRBB_INMODE1 | COLORMAP_TRANSPARENCY | CYBERGRAPHICSNAME
CIACRBB_LOAD | COLORMAP_TYPE_V1_2 | CYBRBIDTG_BoardName
CIACRBB_OUTMODE | COLORMAP_TYPE_V1_4 | CYBRBIDTG_Depth
CIACRBB_PBON | COLORMAP_TYPE_V36 | CYBRBIDTG_MonitorID
CIACRBB_RUNMODE | COLORMAP_TYPE_V39 | CYBRBIDTG_NominalHeight
CIACRBB_START | COLORON | CYBRBIDTG_NominalWidth
CIACRBF_ALARM | COLORPLANE_TRANSPARENCY | CYBRBIDTG_TB
CIACRBF_IN_CNT | commodities | CYBRIDATTR_BPPIX
CIACRBF_IN_CNT_TA | COMMODITIESNAME | CYBRIDATTR_DEPTH
CIACRBF_INMODE0 | COMMSEQ | CYBRIDATTR_HEIGHT
CIACRBF_INMODE1 | COMMWIDTH | CYBRIDATTR_PIXFMT
CIACRBF_IN_PHI2 | CompareDates | CYBRIDATTR_WIDTH
CIACRBF_IN_TA | COMPLEMENT | CYBRMATTR_BPPIX
CIACRBF_LOAD | COMPLEX_BIT | CYBRMATTR_COLORMAP
CIACRBF_OUTMODE | CONFLAG_DEFAULT | CYBRMATTR_DEPTH
CIACRBF_PBON | CONFLAG_NODRAW_ON_NEWSIZE | CYBRMATTR_DISPADR
CIACRBF_RUNMODE | console | CYBRMATTR_HEIGHT
CIACRBF_START | ConsoleDevice | CYBRMATTR_ISCYBERGFX
CIAF_COMCD | CONU_CHARMAP | CYBRMATTR_ISLINEARMEM
CIAF_COMCTS | CONU_LIBRARY | CYBRMATTR_PIXFMT
CIAF_COMDSR | conunit | CYBRMATTR_WIDTH
CIAF_COMDTR | CONU_SNIPMAP | CYBRMATTR_XMOD
CIAF_COMRTS | CONU_STANDARD | CYBRMREQ_CancelText
CIAF_DSKCHANGE | ConvertUCS4ToUTF8 | CYBRMREQ_CModelArray
CIAF_DSKDIREC | ConvertUTF8ToUCS4 | CYBRMREQ_MaxDepth
CIAF_DSKMOTOR | ConvToLower | CYBRMREQ_MaxHeight
CIAF_DSKPROT | ConvToUpper | CYBRMREQ_MaxWidth
CIAF_DSKRDY | COPPER_MOVE | CYBRMREQ_MinDepth
CIAF_DSKSEL0 | COPPER_WAIT | CYBRMREQ_MinHeight
CIAF_DSKSEL1 | CopyDTMethods | CYBRMREQ_MinWidth
CIAF_DSKSEL2 | CopyDTTriggerMethods | CYBRMREQ_OKText
CIAF_DSKSEL3 | CopyMem | CYBRMREQ_Screen
CIAF_DSKSIDE | CopyMemQuick | CYBRMREQ_TB
CIAF_DSKSTEP | CopySBitMap | CYBRMREQ_WinTitle
CIAF_DSKTRACK0 | CORRECT_BLUE | CYCLEIDCMP
CIAF_GAMEPORT0 | CORRECT_GREEN | CYCLE_KIND

D

datatypes | DFCTRL_CACHE | DoubleClick
DataTypesBase | DFCTRL_SORT_ASC | DOUBLESCAN
DATATYPESCLASS | DFCTRL_SORT_DES | DOWNBACKGADGET
DATATYPESNAME | DFCTRL_SORTMODE | DOWNIMAGE
Date2Amiga | DFCTRL_SORT_OFF | DP_2DFACSHIFT
DateStamp | DFCTRL_XDOTP | DP_2DINDEXMASK
DAY_1 | DFCTRL_XDPI | DPB_DEAD
DAY_2 | DFCTRL_YDOTP | DPB_MOD
DAY_3 | DFCTRL_YDPI | DPF_DEAD
DAY_4 | DFH_ID | DPF_MOD
DAY_5 | DFTCH_MASK | DPMS_OFF
DAY_6 | DIAB_630 | DPMS_ON
DAY_7 | DIAB_ADV_D25 | DPMS_STANDBY
DBL_CAS | DIAB_C_150 | DPMS_SUSPEND
DBLNTSCEXTRALORESDPF2FF_KEY | DI_AVAIL_NOCHIPS | DRAFT
DBLNTSCEXTRALORESDPF2_KEY | DI_AVAIL_NOMONITOR | DRAGGADGET
DBLNTSCEXTRALORESDPF2LACE_KEY | DI_AVAIL_NOTWITHGENLOCK | Draw
DBLNTSCEXTRALORESDPFFF_KEY | DIMENSIONS_MASK | DrawBevelBoxA
DBLNTSCEXTRALORESDPF_KEY | DIPF_IS_AA | DrawBorder
DBLNTSCEXTRALORESDPFLACE_KEY | DIPF_IS_BEAMSYNC | DrawCircle
DBLNTSCEXTRALORESEHBFF_KEY | DIPF_IS_DBUFFER | DrawDTObject
DBLNTSCEXTRALORESEHB_KEY | DIPF_IS_DRAGGABLE | DrawDTObjectA
DBLNTSCEXTRALORESEHBLACE_KEY | DIPF_IS_DUALPF | DrawEllipse
DBLNTSCEXTRALORESFF_KEY | DIPF_IS_ECS | DRAWERDATAFILESIZE
DBLNTSCEXTRALORESHAMFF_KEY | DIPF_IS_EXTRAHALFBRITE | DrawGList
DBLNTSCEXTRALORESHAM_KEY | DIPF_IS_FOREIGN | DrawIconStateA
DBLNTSCEXTRALORESHAMLACE_KEY | DIPF_IS_GENLOCK | DrawImage
DBLNTSCEXTRALORES_KEY | DIPF_IS_HAM | DrawImageState
DBLNTSCEXTRALORESLACE_KEY | DIPF_IS_LACE | DRIF_DIRECTCOLOR
DBLNTSCHIRESDPF2FF_KEY | DIPF_IS_PAL | DRIF_NEWLOOK
DBLNTSCHIRESDPF2_KEY | DIPF_IS_PANELLED | DRIPEN_BACKGROUND
DBLNTSCHIRESDPF2LACE_KEY | DIPF_IS_PF2PRI | DRIPEN_BARBLOCK
DBLNTSCHIRESDPFFF_KEY | DIPF_IS_PROGBEAM | DRIPEN_BARDETAIL
DBLNTSCHIRESDPF_KEY | DIPF_IS_SCANDBL | DRIPEN_BARTRIM
DBLNTSCHIRESDPFLACE_KEY | DIPF_IS_SPRITES | DRIPEN_BLOCK
DBLNTSCHIRESEHBFF_KEY | DIPF_IS_SPRITES_ATT | DRIPEN_DETAIL
DBLNTSCHIRESEHB_KEY | DIPF_IS_SPRITES_BORDER | DRIPEN_FILL
DBLNTSCHIRESEHBLACE_KEY | DIPF_IS_SPRITES_CHNG_BASE | DRIPEN_FILLTEXT
DBLNTSCHIRESFF_KEY | DIPF_IS_SPRITES_CHNG_PRI | DRIPEN_HALFSHADOW
DBLNTSCHIRESHAMFF_KEY | DIPF_IS_SPRITES_CHNG_RES | DRIPEN_HALFSHINE
DBLNTSCHIRESHAM_KEY | DIPF_IS_WB | DRIPEN_HIGHLIGHTTEXT
DBLNTSCHIRESHAMLACE_KEY | Disable | DRIPEN_NUMDRIPENS
DBLNTSCHIRES_KEY | diskfont | DRIPEN_SHADOW
DBLNTSCHIRESLACE_KEY | DiskfontBase | DRIPEN_SHINE
DBLNTSCLORESDPF2FF_KEY | DISKFONTNAME | DRIPEN_TEXT
DBLNTSCLORESDPF2_KEY | DisownBlitter | DRI_VERSION
DBLNTSCLORESDPF2LACE_KEY | DISPATCHERARG | DSR_CPR
DBLNTSCLORESDPFFF_KEY | DISPATCHERARG | DTA_ARexxPortName
DBLNTSCLORESDPF_KEY | DisplayAlert | DTA_BaseName
DBLNTSCLORESDPFLACE_KEY | DisplayBeep | DTA_Busy
DBLNTSCLORESEHBFF_KEY | DISPLAYDUAL | DTA_Conductor
DBLNTSCLORESEHB_KEY | DisplayInfoHandle | DTA_ControlPanel
DBLNTSCLORESEHBLACE_KEY | DISPLAYNAMELEN | DTA_Data
DBLNTSCLORESFF_KEY | DISPLAYPAL | DTA_DataType
DBLNTSCLORESHAMFF_KEY | DisposeCxMsg | DTA_DestCols
DBLNTSCLORESHAM_KEY | DisposeDTObject | DTA_DestRows
DBLNTSCLORESHAMLACE_KEY | DisposeFontContents | DTA_Domain
DBLNTSCLORES_KEY | DisposeLayerInfo | DTA_Dummy
DBLNTSCLORESLACE_KEY | DisposeObject | DTA_ErrorLevel
DBLNTSC_MONITOR_ID | DisposeRegion | DTA_ErrorNumber
DBLPALEXTRALORESDPF2FF_KEY | DITHERING_MASK | DTA_ErrorString
DBLPALEXTRALORESDPF2_KEY | DivertCxMsg | DTA_FrameInfo
DBLPALEXTRALORESDPF2LACE_KEY | DIW_HORIZ_POS | DTAG_DIMS
DBLPALEXTRALORESDPFFF_KEY | DIW_VRTCL_POS | DTAG_DISP
DBLPALEXTRALORESDPF_KEY | DIW_VRTCL_POS_SHIFT | DTAG_MNTR
DBLPALEXTRALORESDPFLACE_KEY | DLACTION_BeginDiscard | DTAG_NAME
DBLPALEXTRALORESEHBFF_KEY | DLACTION_BeginEmptyTrash | DTA_GroupID
DBLPALEXTRALORESEHB_KEY | DLACTION_DeleteContents | DTAG_VEC
DBLPALEXTRALORESEHBLACE_KEY | DLACTION_DeleteObject | DTA_Handle
DBLPALEXTRALORESFF_KEY | DLACTION_End | DTA_Height
DBLPALEXTRALORESHAMFF_KEY | DLT_DEVICE | DTA_HorizUnit
DBLPALEXTRALORESHAM_KEY | DLT_DIRECTORY | DTA_Immediate
DBLPALEXTRALORESHAMLACE_KEY | DLT_FSCONTEXT | DTA_LayoutProc
DBLPALEXTRALORES_KEY | DLT_LATE | DTA_Left
DBLPALEXTRALORESLACE_KEY | DLT_NONBINDING | DTA_Methods
DBLPALHIRESDPF2FF_KEY | DLT_PRIVATE | DTA_Name
DBLPALHIRESDPF2_KEY | DLT_VOLUME | DTA_NodeName
DBLPALHIRESDPF2LACE_KEY | DMAB_AUD0 | DTA_NominalHoriz
DBLPALHIRESDPFFF_KEY | DMAB_AUD1 | DTA_NominalVert
DBLPALHIRESDPF_KEY | DMAB_AUD2 | DTA_ObjAnnotation
DBLPALHIRESDPFLACE_KEY | DMAB_AUD3 | DTA_ObjAuthor
DBLPALHIRESEHBFF_KEY | DMAB_BLITHOG | DTA_ObjCopyright
DBLPALHIRESEHB_KEY | DMAB_BLITTER | DTA_ObjectID
DBLPALHIRESEHBLACE_KEY | DMAB_BLTDONE | DTA_ObjName
DBLPALHIRESFF_KEY | DMAB_BLTNZERO | DTA_ObjVersion
DBLPALHIRESHAMFF_KEY | DMAB_COPPER | DTA_PrinterProc
DBLPALHIRESHAM_KEY | DMAB_DISK | DTA_PrinterStatus
DBLPALHIRESHAMLACE_KEY | DMAB_MASTER | DTA_RastPort
DBLPALHIRES_KEY | DMAB_RASTER | DTA_RelBottom
DBLPALHIRESLACE_KEY | DMAB_SETCLR | DTA_RelHeight
DBLPALLORESDPF2FF_KEY | DMAB_SPRITE | DTA_RelRight
DBLPALLORESDPF2_KEY | DMA_Continue | DTA_RelWidth
DBLPALLORESDPF2LACE_KEY | DMAF_ALL | DTA_Repeat
DBLPALLORESDPFFF_KEY | DMAF_AUD0 | DTA_Reserved
DBLPALLORESDPF_KEY | DMAF_AUD1 | DTA_SelectDomain
DBLPALLORESDPFLACE_KEY | DMAF_AUD2 | DTA_SourceAddress
DBLPALLORESEHBFF_KEY | DMAF_AUD3 | DTA_SourceSize
DBLPALLORESEHB_KEY | DMAF_AUDIO | DTA_SourceType
DBLPALLORESEHBLACE_KEY | DMAF_BLITHOG | DTA_Special
DBLPALLORESFF_KEY | DMAF_BLITTER | DTA_Sync
DBLPALLORESHAMFF_KEY | DMAF_BLTDONE | DTA_TextAttr
DBLPALLORESHAM_KEY | DMAF_BLTNZERO | DTA_TextFont
DBLPALLORESHAMLACE_KEY | DMAF_COPPER | DTA_Title
DBLPALLORES_KEY | DMAF_DISK | DTA_Top
DBLPALLORESLACE_KEY | DMAF_MASTER | DTA_TopHoriz
DBLPAL_MONITOR_ID | DMAF_RASTER | DTA_TopVert
DBLPF | DMAF_SETCLR | DTA_TotalHoriz
DBUFFER | DMAF_SPRITE | DTA_TotalPHoriz
DDB_AllBit | DMA_NoModify | DTA_TotalPVert
DDB_Completed | DMA_ReadFromRAM | DTA_TotalVert
DDB_ExaminedBit | DMODECOUNT | DTA_TriggerMethods
DDB_PatternBit | DNetCheck | DTA_UserData
DDB_Single | DNF_REMDOSLIST | DTA_VertUnit
DDF_AllBit | DNF_STARTONCE | DTA_VisibleHoriz
DDF_Completed | DNF_UNLOADSEGLIST | DTA_VisibleVert
DDF_ExaminedBit | DoAsyncLayout | DTA_Width
DDFLAGS_SHOWALL | DoCDrawMethodTagList | DTB_FUTURE
DDFLAGS_SHOWDEFAULT | DoCollision | DTB_SUBST
DDFLAGS_SHOWICONS | DoDTDomain | DTERROR_COULDNT_OPEN
DDF_PatternBit | DoDTDomainA | DTERROR_COULDNT_OPEN_CLIPBOARD
DDF_Single | DoDTMethod | DTERROR_COULDNT_SAVE
DDVM_BYDATE | DoDTMethodA | DTERROR_COULDNT_SEND_MESSAGE
DDVM_BYDEFAULT | DoGadgetMethod | DTERROR_INVALID_DATA
DDVM_BYICON | DoGadgetMethodA | DTERROR_NOT_AVAILABLE
DDVM_BYNAME | DoHookClipRects | DTERROR_NOT_ENOUGH_DATA
DDVM_BYSIZE | DoIO | DTERROR_Reserved
DDVM_BYTYPE | DoMethod | DTERROR_UNKNOWN_COMPRESSION
DEADEND_ALERT | DoMethod | DTERROR_UNKNOWN_DATATYPE
Deallocate | DoMethodA | DTF_ASCII
DE_BAUD | DoMethodA | DTF_BINARY
DE_BLKSPERTRACK | DoPkt | DTF_CASE
DE_BOOTBLOCKS | DoPkt0 | DTF_FUTURE
DE_BOOTPRI | DoPkt1 | DTF_IFF
DE_BUFMEMTYPE | DoPkt2 | DTF_MISC
Debug | DoPkt3 | DTF_SUBST
DE_CONTROL | DoPkt4 | DTF_SYSTEM1
DE_DOSTYPE | DOS_ASSIGNNODE | DTF_TYPE_MASK
DEFAULT_M68KSTACKSIZE | DosBase | DTHSIZE
DEFAULT_MONITOR_ID | DOS_CLI | DTM_ABORTPRINT
DEFAULT_MONITOR_NAME | dosClose | DTM_ASYNCLAYOUT
DEFAULTMOUSEQUEUE | dosCreateDir | DTM_CLEARSELECTED
DEFAULT_PPCSTACKSIZE | DOSDateToStr | DTM_COPY
DEFAULT_TASKPUDDLESIZE | DOSDelay | DTM_DISPOSEMEMBER
DEFAULT_TASKTHRESHSIZE | dosDeleteFile | DTM_DRAW
DEFERREFRESH | DOS_DEVICENODE | DTM_Dummy
DE_INTERLEAVE | DOS_EXALLCONTROL | DTM_FRAMEBOX
DeleteCxObj | dosExit | DTM_GOTO
DeleteCxObjAll | DOSFALSE | DTM_NEWMEMBER
DeleteDiskObject | DOS_FIB | DTM_OBTAINDRAWINFO
DeleteExtIO | DOS_FILEHANDLE | DTM_PRINT
DeleteIORequest | dosFlush | DTM_PROCLAYOUT
DeleteLayer | DOS_FSCONTEXT | DTM_RELEASEDRAWINFO
DeleteMsgPort | dosInput | DTM_REMOVEDTOBJECT
DeletePool | DOSLOGO_DISKBUSY | DTM_SELECT
DeleteVar | DOSLOGO_DISKERROR | DTMSG_TYPE_OFFSET
DeleteVLayerHandle | DOSLOGO_DISKFULL | DTM_TRIGGER
DE_LOWCYL | DOSLOGO_DISKINSERT | DTM_WRITE
DE_MASK | DOSLOGO_DISKNOTVALIDATED | DTSIF_DRAGGING
DE_MAXTRANSFER | DOSLOGO_DISKPROTECTED | DTSIF_DRAGSELECT
DE_MEMBUFTYPE | DOSLOGO_NODISK | DTSIF_HIGHLIGHT
DE_NUMBUFFERS | DOSLOGO_NOTADOSDISK | DTSIF_LAYOUT
DE_NUMHEADS | DOSNAME | DTSIF_LAYOUTPROC
DE_PREFAC | dosOpen | DTSIF_NEWSIZE
DEPTHIMAGE | dosOutput | DTSIF_PRINTING
DE_RESERVEDBLKS | DOS_RDARGS | DTST_CLIPBOARD
DE_SECORG | dosRead | DTST_FILE
DE_SECSPERBLK | dosReadLn | DTST_HOTLINK
DE_SIZEBLOCK | dosRename | DTST_MEMORY
DEST | dosSeek | DTST_RAM
DESTALPHAVALUE_ONE | DOS_STDPKT | DTWM_IFF
DESTALPHAVALUE_UNDEFINED | DOSStrToDate | DTWM_RAW
DESTALPHAVALUE_USEDEST | dosSystem | DUALPF
DESTALPHAVALUE_USESOURCE | DOSTRUE | DumpTaskState
DE_TABLESIZE | DoSuperMethod | DupDiskObjectA
DetachVLayer | DoSuperMethod | DupLock
DETAILPEN | DoSuperMethodA | DupLockFromFH
DE_UPPERCYL | DoSuperMethodA | DVPB_ASSIGN
DEV_ABORTIO | DoSuperNew | DVPB_FSCONTEXT
DEV_BEGINIO | DoSuperNew | DVPB_UNLOCK
DeviceProc | DOS_VOLUMENODE | DVPF_ASSIGN
DEVNAME_SIZE | dosWrite | DVPF_FSCONTEXT
DFCTRL_BASE | dosWriteStr | DVPF_UNLOCK

E

EasyRequest | ERROR_READ_PROTECTED | ExAllEnd
EasyRequestArgs | ERROR_RECORD_NOT_LOCKED | Examine
ED_COMMENT | ERROR_RENAME_ACROSS_DEVICES | Examine64
ED_DATE | ErrorReport | Examine64TagList
ED_NAME | ERROR_REQUIRED_ARG_MISSING | Examine64Tags
ED_OWNER | ERROR_SEEK_ERROR | EXAMINE_BIT
ED_PROTECTION | ERROR_TASK_TABLE_FULL | ExamineFH
ED_SIZE | ERROR_TOO_MANY_ARGS | ExamineFH64
ED_SIZE64 | ERROR_TOO_MANY_LEVELS | ExamineFH64TagList
ED_TYPE | ERROR_UNLOCK_ERROR | ExamineFH64Tags
EES_ActiveButton | ERROR_UNMATCHED_QUOTES | EXCLUSIVE_LOCK
EES_DiskBased | ERROR_WRITE_PROTECTED | exec
EES_DosLogo | ETD_Iconify | execAllocMem
EES_Dummy | ETD_Jump | ExecBase
EIGHT_LPI | ETD_Lock | EXECDEBUGF_ADDDOSNODE
ELITE | ETD_MUI | EXECDEBUGF_ADDTASK
EMULTAG_EMULHANDLE | ETD_PopUp | EXECDEBUGF_CGXDEBUG
EMULTAG_EMULHANDLESIZE | ETD_Snapshot | EXECDEBUGF_CHIPRAM
EMULTAG_NAME | ETG_ICONIFY | EXECDEBUGF_CREATELIBRARY
EMULTAG_OPCODETABLE | ETG_JUMP | EXECDEBUGF_CYBERGUARDDEADLY
EMULTAG_REVISION | ETG_LOCK | EXECDEBUGF_EXCEPTHANDLER
EMULTAG_SUPERHANDLE | ETG_MUI | EXECDEBUGF_FINDRESIDENT
EMULTAG_SUPERHANDLESIZE | ETG_POPUP | EXECDEBUGF_GETTASKATTR
EMULTAG_TYPE | ETG_SNAPSHOT | EXECDEBUGF_INIT
EMULTAG_VERSION | ETI_Dummy | EXECDEBUGF_INITCODE
Enable | ETI_Iconify | EXECDEBUGF_INITRESIDENT
EndNotify | ETI_Jump | EXECDEBUGF_LOADSEG
EndRefresh | ETI_Lock | EXECDEBUGF_LOG
EndRequest | ETI_MUI | EXECDEBUGF_LOGFILE
ENDSTREAMCH | ETI_PopUp | EXECDEBUGF_LOGKPRINTF
EndUpdate | ETI_Snapshot | EXECDEBUGF_MEMTRACK
Enqueue | EURO36_MONITOR_ID | EXECDEBUGF_NEWSETFUNCTION
EnqueueCxObj | EURO72EHB_KEY | EXECDEBUGF_NOLOGSERVER
EntryHandler | EURO72EHBLACE_KEY | EXECDEBUGF_NOLOGWINDOW
EO_BADFORMAT | EURO72EXTRAHALFBRITE_KEY | EXECDEBUGF_PCI
EO_BIGCHANGE | EURO72EXTRAHALFBRITELACE_KEY | EXECDEBUGF_PERMMEMTRACK
EO_CLEAR | EURO72EXTRALORESDBL_KEY | EXECDEBUGF_PPCSTART
EO_DELBACKWARD | EURO72EXTRALORESDPF2_KEY | EXECDEBUGF_RAMLIB
EO_DELFORWARD | EURO72EXTRALORESDPF_KEY | EXECDEBUGF_REMTASK
EO_ENTER | EURO72EXTRALORESEHBDBL_KEY | EXECDEBUGF_SETFUNCTION
EO_INSERTCHAR | EURO72EXTRALORESEHB_KEY | EXECDEBUGF_SETTASKATTR
EO_MOVECURSOR | EURO72EXTRALORESEHBLACE_KEY | EXECDEBUGF_UNLOADSEG
EO_NOOP | EURO72EXTRALORESHAMDBL_KEY | execFreeMem
EO_REPLACECHAR | EURO72EXTRALORESHAM_KEY | execInsert
EO_RESET | EURO72EXTRALORESHAMLACE_KEY | EXECLIST_DEVICE
EO_SPECIAL | EURO72EXTRALORES_KEY | EXECLIST_INTERRUPT
EO_UNDO | EURO72EXTRALORESLACEDPF2_KEY | EXECLIST_LIBRARY
EPSON | EURO72EXTRALORESLACEDPF_KEY | EXECLIST_MEMHANDLER
EPSON_JX_80 | EURO72EXTRALORESLACE_KEY | EXECLIST_MEMHEADER
EraseImage | EURO72HAM_KEY | EXECLIST_PORT
EraseRect | EURO72HAMLACE_KEY | EXECLIST_RESOURCE
ERROR_ACTION_NOT_KNOWN | EURO72LORESDBL_KEY | EXECLIST_SEMAPHORE
ERROR_BAD_HUNK | EURO72LORESDPF2_KEY | EXECLIST_TASK
ERROR_BAD_NUMBER | EURO72LORESDPF_KEY | EXECNOTIFYF_POST
ERROR_BAD_STREAM_NAME | EURO72LORESEHBDBL_KEY | EXECNOTIFYF_REMOVE
ERROR_BAD_TEMPLATE | EURO72LORESEHB_KEY | Execute
ERROR_BREAK | EURO72LORESEHBLACE_KEY | ExitHandler
ERROR_BUFFER_OVERFLOW | EURO72LORESHAMDBL_KEY | ExNext
ERROR_COMMENT_TOO_BIG | EURO72LORESHAM_KEY | ExNext64
ERROR_DELETE_PROTECTED | EURO72LORESHAMLACE_KEY | ExNext64TagList
ERROR_DEVICE_NOT_MOUNTED | EURO72LORES_KEY | ExNext64Tags
ERROR_DIRECTORY_NOT_EMPTY | EURO72LORESLACEDPF2_KEY | EXT_ABS
ERROR_DIR_NOT_FOUND | EURO72LORESLACEDPF_KEY | EXT_ABSCOMMON
ERROR_DISK_FULL | EURO72LORESLACE_KEY | EXT_ABSREF16
ERROR_DISK_NOT_VALIDATED | EURO72_MONITOR_ID | EXT_ABSREF32
ERROR_DISK_WRITE_PROTECTED | EURO72PRODUCTDBL_KEY | EXT_ABSREF8
ERROR_FILE_NOT_OBJECT | EURO72PRODUCTDPF2_KEY | EXT_COMMON
ERROR_INVALID_COMPONENT_NAME | EURO72PRODUCTDPF_KEY | EXT_DEF
ERROR_INVALID_LOCK | EURO72PRODUCTEHBDBL_KEY | EXT_DEXT16
ERROR_INVALID_RESIDENT_LIBRARY | EURO72PRODUCTHAMDBL_KEY | EXT_DEXT32
ERROR_IS_SOFT_LINK | EURO72PRODUCTHAM_KEY | EXT_DEXT8
ERROR_KEY_NEEDS_ARG | EURO72PRODUCTHAMLACE_KEY | EXTENDED_MODE
ERROR_LINE_TOO_LONG | EURO72PRODUCT_KEY | ExtendFont
ERROR_LOCK_COLLISION | EURO72PRODUCTLACEDPF2_KEY | ExtendFontTags
ERROR_LOCK_TIMEOUT | EURO72PRODUCTLACEDPF_KEY | EXTEND_VSTRUCT
ERROR_NO_DEFAULT_DIR | EURO72PRODUCTLACE_KEY | ExtractColor
ERROR_NO_DISK | EURO_A0 | EXTRA_HALFBRITE
ERROR_NO_FREE_STORE | EURO_A1 | EXTRAHALFBRITE_KEY
ERROR_NO_MORE_ENTRIES | EURO_A2 | EXTRAHALFBRITELACE_KEY
ERROR_NOT_A_DOS_DISK | EURO_A3 | EXT_REF16
ERROR_NOT_EXECUTABLE | EURO_A4 | EXT_REF32
ERROR_NOT_IMPLEMENTED | EURO_A5 | EXT_REF8
ERROR_OBJECT_EXISTS | EURO_A6 | EXT_RELCOMMON
ERROR_OBJECT_IN_USE | EURO_A7 | EXT_RELREF16
ERROR_OBJECT_LINKED | EURO_A8 | EXT_RELREF32
ERROR_OBJECT_NOT_FOUND | EVENTMAX | EXT_RELREF8
ERROR_OBJECT_TOO_LARGE | EXACT_LINE | EXT_RES
ERROR_OBJECT_WRONG_TYPE | ExAll | EXT_SYMB

F

FANFOLD_PT | FNDS_Load | FreeDosEntry
FattenLayerInfo | FNDS_Name | FreeDosObject
Fault | FNDS_System | FreeDTMethods
FAULT_MAX | FOB_DOBACKPEN | FreeEntry
FCH_ID | FOB_DODRAWMODE | FreeFileRequest
FGetC | FOB_DOFRONTPEN | FreeFreeList
FGets | FOB_DOSTYLE | FreeGadgets
FIBB_ARCHIVE | FOB_FILTERFUNC | FreeGBuffers
FIBB_DELETE | FOB_FIXEDWIDTHONLY | FREEHORIZ
FIBB_EXECUTE | FOB_INTUIFUNC | FreeIFF
FIBB_GRP_DELETE | FOB_PRIVATEIDCMP | FreeLocalItem
FIBB_GRP_EXECUTE | FOF_DOBACKPEN | FreeMenus
FIBB_GRP_READ | FOF_DODRAWMODE | FreeMonitorList
FIBB_GRP_WRITE | FOF_DOFRONTPEN | FreeNamedObject
FIBB_OTR_DELETE | FOF_DOSTYLE | FreePooled
FIBB_OTR_EXECUTE | FOF_FILTERFUNC | FreeRaster
FIBB_OTR_READ | FOF_FIXEDWIDTHONLY | FreeRemember
FIBB_OTR_WRITE | FOF_INTUIFUNC | FreeScreenBuffer
FIBB_PURE | FOF_PRIVATEIDCMP | FreeScreenDrawInfo
FIBB_READ | FontExtent | FreeSignal
FIBB_SCRIPT | Forbid | FreeSprite
FIBB_WRITE | Format | FreeSpriteData
FIBF_ARCHIVE | FORMAT_CDN | FreeSysRequest
FIBF_DELETE | FormatClockData | FreeTagItems
FIBF_EXECUTE | FormatDate | FreeTaskPooled
FIBF_GRP_DELETE | FORMAT_DEF | FreeTrap
FIBF_GRP_EXECUTE | FORMAT_DOS | FreeVec
FIBF_GRP_READ | FORMAT_INT | FreeVecDMA
FIBF_GRP_WRITE | FORMAT_MAX | FreeVecPooled
FIBF_OTR_DELETE | FormatString | FreeVecTaskPooled
FIBF_OTR_EXECUTE | FORMAT_USA | FREEVERT
FIBF_OTR_READ | FPB_DESIGNED | FreeVisualInfo
FIBF_OTR_WRITE | FPB_DISKFONT | FreeVPortCopLists
FIBF_PURE | FPB_PROPORTIONAL | FRF_DOMULTISELECT
FIBF_READ | FPB_REMOVED | FRF_DOPATTERNS
FIBF_SCRIPT | FPB_REVPATH | FRF_DOSAVEMODE
FIBF_WRITE | FPB_ROMFONT | FRF_DRAWERSONLY
FIF_REMAPPABLE | FPB_TALLDOT | FRF_FILTERDRAWERS
FIF_SCALABLE | FPB_WIDEDOT | FRF_FILTERFUNC
FIF_SCROLLABLE | FPF_DESIGNED | FRF_INTUIFUNC
FILENAME_SIZE | FPF_DISKFONT | FRF_PRIVATEIDCMP
FilePart | FPF_PROPORTIONAL | FRF_REJECTICONS
FILL_CARRYIN | FPF_REMOVED | FROM_MONITOR
FILL_OR | FPF_REVPATH | FRST_DOT
FILLPEN | FPF_ROMFONT | FSB_BOLD
FillPixelArray | FPF_TALLDOT | FSB_COLORFONT
FILLRECTCLASS | FPF_WIDEDOT | FSB_EXTENDED
FILLTEXTPEN | FPutC | FSB_ITALIC
FILL_XOR | FPuts | FSB_TAGGED
FilterTagChanges | FQA_DeviceType | FSB_UNDERLINED
FilterTagItems | FQA_IsCaseSensitive | FSCONTEXTINFOTAG_Dummy
FindArg | FQA_MaxFileNameLength | FSCONTEXTINFOTAG_NAME
FindCliProc | FQA_MaxFileSize | FSCONTEXTTAG_DOSTYPE
FindCollection | FQA_MaxVolumeNameLength | FSCONTEXTTAG_Dummy
FindColor | FQA_NumBlocks | FSCONTEXTTAG_FSSM
FindDisplayInfo | FQA_NumBlocksUsed | FSCONTEXTTAG_PRIORITY
FindDosEntry | FQA_ReservedAttr1 | FSCONTEXTTAG_SEGLIST
FindExecNode | FRAME_BUTTON | FSCONTEXTTAG_STACKSIZE
FindLocalItem | FRAME_DEFAULT | FSCONTEXTTAG_STARTUPSTRING
FindMethod | FRAMEF_SPECIFY | FSCONTEXTTAG_STARTUPVALUE
FindName | FRAMEICLASS | FSF_BOLD
FindNamedObject | FRAME_ICONDROPBOX | FSF_COLORFONT
FindPort | FRAME_RIDGE | FSF_EXTENDED
FindProp | FRB_DOMULTISELECT | FSF_ITALIC
FindPropContext | FRB_DOPATTERNS | FSF_TAGGED
FindResident | FRB_DOSAVEMODE | FSF_UNDERLINED
FindSegment | FRB_DRAWERSONLY | FS_NORMAL
FindSegmentTagList | FRB_FILTERDRAWERS | FULLMENUNUM
FindSemaphore | FRB_FILTERFUNC | FUNCARRAY_16BIT_OLD
FindTagItem | FRB_INTUIFUNC | FUNCARRAY_32BIT_D0D1A0A1SR_NATIVE
FindTask | FRB_PRIVATEIDCMP | FUNCARRAY_32BIT_D0D1_NATIVE
FindTaskByPID | FRB_REJECTICONS | FUNCARRAY_32BIT_D0D1SR_NATIVE
FindToolNode | FRBUTTONCLASS | FUNCARRAY_32BIT_NATIVE
FindToolNodeA | FRead | FUNCARRAY_32BIT_NR_NATIVE
FindToolType | FreeArgs | FUNCARRAY_32BIT_QUICK_NATIVE
FindTriggerMethod | FreeAslRequest | FUNCARRAY_32BIT_QUICKNR_NATIVE
FindVar | FreeBitMap | FUNCARRAY_32BIT_RESTORE_NATIVE
FINE | FreeClass | FUNCARRAY_32BIT_SR_NATIVE
LongInt | FreeCLIData | FUNCARRAY_32BIT_SRNR_NATIVE
LongInt | FreeCModeList | FUNCARRAY_32BIT_SYSTEMV
Flood | FreeColorMap | FUNCARRAY_BEGIN
FLOYD_DITHERING | FreeCopList | FUNCARRAY_END
FlushPool | FreeCprList | FUNCENTRYEXTF_LIBRARY
FlushTaskPool | FreeDBufInfo | FUNCENTRYEXTF_SETFUNCTION
FNDS_Dummy | FreeDeviceProc | FUTURESTR
FNDS_From | FreeDiskObject | FWrite

G

GA_ActivateKey | GetFileSysAttr | GTCY_Active
GA_BackFill | GetFileSysTask | GTCY_Labels
GA_Border | GetGBuffers | GT_EndRefresh
GA_BottomBorder | GetIconRectangleA | GT_FilterIMsg
GA_Bounds | GetIconTagList | GT_GetGadgetAttrsA
GACT_ACTIVEGADGET | GetKeyMapCodePage | GT_GetIMsg
GACT_ALTKEYMAP | GetLocaleStr | GTIN_MaxChars
GACT_BOOLEXTEND | GetMonitorList | GTIN_Number
GACT_BORDERSNIFF | GetMsg | GTJ_CENTER
GACT_BOTTOMBORDER | GetOutlinePen | GTJ_LEFT
GACT_ENDGADGET | GetPrefs | GTJ_RIGHT
GACT_FOLLOWMOUSE | GetProgramDir | GTLV_CallBack
GACT_IMMEDIATE | GetProgramName | GTLV_ItemHeight
GACT_LEFTBORDER | GetPrompt | GTLV_Labels
GACT_LONGINT | GetRGB32 | GTLV_MakeVisible
GACT_RELVERIFY | GetRGB4 | GTLV_MaxPen
GACT_RIGHTBORDER | GetRPAttrs | GTLV_ReadOnly
GACT_STRINGCENTER | GetRPAttrsA | GTLV_ScrollWidth
GACT_STRINGEXTEND | GetScreenData | GTLV_Selected
GACT_STRINGLEFT | GetScreenDrawInfo | GTLV_ShowSelected
GACT_STRINGRIGHT | GetSegListAttr | GTLV_Top
GACT_TOGGLESELECT | GetSegListAttrTagList | GTMENU_INVALID
GACT_TOPBORDER | GetSegListAttrTags | GTMENUITEM_USERDATA
GADGBACKFILL | GetSkinInfoAttr | GTMENU_NOMEM
GADGET_BOX | GetSkinInfoAttrA | GTMENU_TRIMMED
GADGETCLASS | GetSprite | GTMENU_USERDATA
GADGETCOUNT | GetSysTime | GTMN_AmigaKey
GadgetMouse | GetTagData | GTMN_Checkmark
GA_Disabled | GetUniqueID | GTMN_FrontPen
GA_DrawInfo | GetVar | GTMN_FullMenu
GADTOOLBIT | GetVisualInfoA | GTMN_Menu
GADTOOLMASK | GetVLayerAttr | GTMN_NewLookMenus
gadtools | GetVPModeID | GTMN_SecondaryError
GadToolsBase | GFLG_DISABLED | GTMN_TextAttr
GADTOOLSNAME | GFLG_EXTENDED | GTMX_Active
GA_Dummy | GFLG_GADGBACKFILL | GTMX_Labels
GA_EndGadget | GFLG_GADGHBOX | GTMX_Scaled
GA_FollowMouse | GFLG_GADGHCOMP | GTMX_Spacing
GA_GadgetHelp | GFLG_GADGHIGHBITS | GTMX_TitlePlace
GA_GadgetHelpText | GFLG_GADGHIMAGE | GTNM_BackPen
GA_GZZGadget | GFLG_GADGHNONE | GTNM_Border
GA_Height | GFLG_GADGIMAGE | GTNM_Clipped
GA_Highlight | GFLG_IMAGEDISABLE | GTNM_Format
GA_ID | GFLG_LABELIMAGE | GTNM_FrontPen
GA_Image | GFLG_LABELITEXT | GTNM_Justification
GA_Immediate | GFLG_LABELMASK | GTNM_MaxNumberLen
GA_IntuiText | GFLG_LABELSTRING | GTNM_Number
GA_LabelImage | GFLG_RELBOTTOM | GTNW_Active
GA_LabelPlace | GFLG_RELHEIGHT | GTNW_Labels
GA_Left | GFLG_RELRIGHT | GTPA_Color
GA_LeftBorder | GFLG_RELSPECIAL | GTPA_ColorOffset
GA_Next | GFLG_RELWIDTH | GTPA_ColorTable
GA_Previous | GFLG_SELECTED | GTPA_Depth
GA_ReadOnly | GFLG_STRINGEXTEND | GTPA_IndicatorHeight
GA_RelBottom | GFLG_TABCYCLE | GTPA_IndicatorWidth
GA_RelHeight | GfxAssociate | GTPA_NumColors
GA_RelRight | GFXB_AA_ALICE | GT_PostFilterIMsg
GA_RelSpecial | GFXB_AA_LISA | GT_Private0
GA_RelVerify | GFXB_AA_MLISA | GT_RefreshWindow
GA_RelWidth | GfxBase | GT_ReplyIMsg
GA_RightBorder | GFXB_BIG_BLITS | GT_Reserved0
GA_Selected | GFXB_HR_AGNUS | GT_Reserved1
GA_SelectRender | GFXB_HR_DENISE | GTSC_Arrows
GA_SpecialInfo | GFXF_AA_ALICE | GTSC_Overlap
GA_SysGadget | GFXF_AA_LISA | GTSC_Top
GA_SysGType | GFXF_AA_MLISA | GTSC_Total
GA_TabCycle | GFXF_BIG_BLITS | GTSC_Visible
GA_Text | GFXF_HR_AGNUS | GT_SetGadgetAttrsA
GA_TextAttr | GFXF_HR_DENISE | GTSL_DispFunc
GA_ToggleSelect | GfxFree | GTSL_Justification
GA_Top | GfxLookUp | GTSL_Level
GA_TopBorder | GfxMove | GTSL_LevelFormat
GA_Underscore | GfxNew | GTSL_LevelPlace
GA_UserData | GfxText | GTSL_Max
GA_UserInput | GID_ANIMATION | GTSL_MaxLevelLen
GA_Width | GID_DOCUMENT | GTSL_MaxPixelLen
GDIA_CheckMark | GID_INSTRUMENT | GTSL_Min
GDIA_Color | GID_MOVIE | GTST_MaxChars
GDIA_Depth | GID_MUSIC | GTST_String
GDIA_DirectColor | GID_PICTURE | GT_TagBase
GDIA_Font | GID_SOUND | GTTX_BackPen
GDIA_MenuKey | GID_SYSTEM | GTTX_Border
GDIA_NumPens | GID_TEXT | GTTX_Clipped
GDIA_Pen | GM_Dummy | GTTX_CopyText
GDIA_ResolutionX | GM_GOACTIVE | GTTX_FrontPen
GDIA_ResolutionY | GM_GOINACTIVE | GTTX_Justification
GDIA_Version | GM_HANDLEINPUT | GTTX_Text
GDOMAIN_MAXIMUM | GM_HELPTEST | GT_Underscore
GDOMAIN_MINIMUM | GM_HITTEST | GTVI_NewWindow
GDOMAIN_NOMINAL | GMLA_DisplayID | GTVI_NWTags
GELGONE | GMLA_Dummy | GT_VisualInfo
GENERIC_KIND | GM_LAYOUT | GTYP_BOOLGADGET
GENLOC | GMORE_BOUNDS | GTYP_CLOSE
GENLOCK_AUDIO | GMORE_GADGETHELP | GTYP_CUSTOMGADGET
GENLOCK_VIDEO | GMORE_SCROLLRASTER | GTYP_GADGET0002
get9 | GM_RENDER | GTYP_GADGETTYPE
Get9Base | GMR_GADGETHIT | GTYP_GTYPEMASK
GET9NAME | GMR_HELPCODE | GTYP_GZZGADGET
GetAPen | GMR_HELPHIT | GTYP_PROPGADGET
GetArgStr | GMR_KEYACTIVE | GTYP_REQGADGET
GetAttr | GMR_KEYVERIFY | GTYP_SCRGADGET
GetBitMapAttr | GMR_MEACTIVE | GTYP_SDEPTH
GetBPen | GMR_NEXTACTIVE | GTYP_SDOWNBACK
GetCatalogStr | GMR_NOHELPHIT | GTYP_SDRAGGING
GetCC | GMR_NOREUSE | GTYP_SIZING
GetColorMap | GMR_PREVACTIVE | GTYP_STRGADGET
GetConsoleTask | GMR_REUSE | GTYP_SUNUSED
GetCurrentDirName | GMR_VERIFY | GTYP_SUPFRONT
GetCyberIDAttr | GoodID | GTYP_SYSGADGET
GetCyberMapAttr | GoodType | GTYP_WDEPTH
GetDefaultPubScreen | GRADIENT_NUMTYPES | GTYP_WDOWNBACK
GetDefDiskObject | GRADTYPE_HORIZONTAL | GTYP_WDRAGGING
GetDefPrefs | GRADTYPE_LINEAR_ANGLE | GTYP_WDRAGGING2
GetDeviceProc | GRADTYPE_RADIAL | GTYP_WUPFRONT
GetDiskFontCtrl | GRADTYPE_RECTANGLE | GTYP_WZOOM
GetDiskObject | GRADTYPE_VERTICAL | GVB_BINARY_VAR
GetDiskObjectNew | GRAPHICSNAME | GVB_DONT_NULL_TERM
GetDisplayInfoData | GREDRAW_REDRAW | GVB_GLOBAL_ONLY
GetDosObjectAttr | GREDRAW_TOGGLE | GVB_LOCAL_ONLY
GetDosObjectAttrTagList | GREDRAW_UPDATE | GVB_SAVE_VAR
GetDrawInfoAttr | GREY_SCALE2 | GVF_BINARY_VAR
GetDrMd | GROUPGCLASS | GVF_DONT_NULL_TERM
GetDTAttrs | GSTAG_ATTACHED | GVF_GLOBAL_ONLY
GetDTAttrsA | GSTAG_SCANDOUBLED | GVF_LOCAL_ONLY
GetDTMethods | GSTAG_SOFTSPRITE | GVF_SAVE_VAR
GetDTString | GSTAG_SPRITE_NUM | GV_LabelPlace_Above
GetDTTriggerMethodDataFlags | GTBB_FrameType | GV_LabelPlace_Below
GetDTTriggerMethods | GTBB_Recessed | GV_LabelPlace_In
GetEmulHandle | GT_BeginRefresh | GV_LabelPlace_Left
GetExtSprite | GTCB_Checked | GV_LabelPlace_Right
GetExtSpriteA | GTCB_Scaled |

H

HALF_LINE | HIRESHAMSDBL_KEY | HUNK_DEBUG
HALFTONE_DITHERING | HIRES_KEY | HUNK_DREL16
HAM | HIRESLACEDPF2_KEY | HUNK_DREL32
HAM_KEY | HIRESLACEDPF_KEY | HUNK_DREL8
HAMLACE_KEY | HIRESLACE_KEY | HUNK_END
HARDHYPHEN | HIRESPICK | HUNK_EXT
hardware | HOLDNMODIFY | HUNKF_ADVISORY
HC_GADGETHELP | HookEntry | HUNKF_CHIP
HelpControl | HookEntry | HUNKF_FAST
HideWindow | HOVERSTART | HUNK_HEADER
HIGHBOX | HOVERSTOP | HUNK_INDEX
HIGHCOMP | HP_LASERJET | HUNK_LIB
HIGHFLAGS | HP_LASERJET_PLUS | HUNK_NAME
HIGHIMAGE | HSIZEBITS | HUNK_OVERLAY
HIGHITEM | HSIZEMASK | HUNK_RELOC16
HIGHLIGHTTEXTPEN | HSYNCTRUE | HUNK_RELOC32
HIGHNONE | HUNK_ABSRELOC16 | HUNK_RELOC32SHORT
HIRES | HUNK_ABSRELOC32 | HUNK_RELOC8
HIRESDPF2_KEY | HUNKB_ADVISORY | HUNK_RELRELOC16
HIRESDPF_KEY | HUNKB_CHIP | HUNK_RELRELOC32
HIRESEHB_KEY | HUNKB_FAST | HUNK_RELRELOC8
HIRESEHBLACE_KEY | HUNK_BREAK | HUNK_SYMBOL
HIRESGADGET | HUNK_BSS | HUNK_UNIT
HIRESHAM_KEY | HUNK_CODE |
HIRESHAMLACE_KEY | HUNK_DATA |

I

IA_ActivateKey | ID_INTER_DOS_DISK | IMSGA_UCS4
IA_APatSize | ID_INTER_FFS_DISK | IMSGM_NewCopy
IA_APattern | ID_KICKSTART_DISK | IM_SUB
IA_BGPen | ID_LIST | IND_ADDHANDLER
IA_Data | ID_LNFS_DOS_DISK | IND_REMHANDLER
IA_DoubleEmboss | ID_LNFS_FFS_DISK | IND_SETMPORT
IA_Dummy | ID_MSDOS_DISK | IND_SETMTRIG
IA_EdgesOnly | ID_NAME | IND_SETMTYPE
IA_FGPen | ID_NO_DISK_PRESENT | IND_SETPERIOD
IA_Font | ID_NOT_REALLY_DOS | IND_SETTHRESH
IA_FrameType | ID_NULL | IND_WRITEEVENT
IA_Height | IDOMAIN_MAXIMUM | Info
IA_HighlightPen | IDOMAIN_MINIMUM | Inhibit
IA_Left | IDOMAIN_NOMINAL | InitAHILibrary
IA_LineWidth | ID_PROP | InitAnimate
IA_Mode | IDS_BUSY | InitArea
IA_Outline | IDS_DISABLED | InitAslLibrary
IA_Pens | ID_SFS_DISK | InitBitMap
IA_Precision | IDS_INACTIVEDISABLED | InitCGXVideoLibrary
IA_Recessed | IDS_INACTIVENORMAL | InitCode
IA_Resolution | IDS_INACTIVESELECTED | InitCyberGfxLibrary
IA_Scalable | IDS_INDETERMINANT | InitDatatypesLibrary
IA_Screen | IDS_INDETERMINATE | InitDiskFontLibrary
IA_ShadowPen | IDS_NORMAL | InitGadToolsLibrary
IA_SupportsDisable | ID_SPRT | InitGels
IA_Top | IDS_SELECTED | InitGet9Library
IA_Underscore | IDS_SELECTEDDISABLED | InitGMasks
IA_Width | ID_TAGS | InitGraphicsLibrary
ICA_Dummy | ID_TOOL | InitIFF
ICA_MAP | IDtoStr | InitIFFasClip
ICA_TARGET | ID_UNREADABLE_DISK | InitIFFasDOS
ICCLASS | ID_VALIDATED | InitIFFPARSELibrary
ICM_CHECKLOOP | ID_VALIDATING | InitIntuitionLibrary
ICM_CLEARLOOP | ID_VHDR | InitKeymapLibrary
ICM_Dummy | ID_WRITE_PROTECTED | InitLayers
ICM_SETLOOP | IECLASS_ACTIVEWINDOW | InitLayersLibrary
icon | IECLASS_CHANGEWINDOW | InitMasks
ICONA_Dummy | IECLASS_CLOSEWINDOW | InitMUIMasterLibrary
ICONA_ErrorCode | IECLASS_DISKINSERTED | InitRastPort
ICONA_ErrorTagItem | IECLASS_DISKREMOVED | InitRequester
ICONA_LAST_TAG | IECLASS_EVENT | InitResident
ICONA_Reserved1 | IECLASS_GADGETDOWN | InitSemaphore
ICONA_Reserved2 | IECLASS_GADGETUP | InitStruct
ICONA_Reserved3 | IECLASS_INACTIVEWINDOW | InitTinyGLLibrary
ICONA_Reserved4 | IECLASS_MAX | InitTmpRas
ICONA_Reserved5 | IECLASS_MENUHELP | InitView
ICONA_Reserved6 | IECLASS_MENULIST | InitVPort
ICONA_Reserved7 | IECLASS_NEWMOUSE | input
ICONA_Reserved8 | IECLASS_NEWPOINTERPOS | InputBase
ICON_ASPECT_RATIO_UNKNOWN | IECLASS_NEWPREFS | inputevent
IconBase | IECLASS_NULL | InsertCxObj
IconControlA | IECLASS_POINTERPOS | InstallClipRegion
ICONCTRLA_GetAspectRatio | IECLASS_RAWKEY | InstallLayerHook
ICONCTRLA_GetFrameless | IECLASS_RAWMOUSE | InstallLayerInfoHook
ICONCTRLA_GetGlobalColorIconSupport | IECLASS_REFRESHWINDOW | INST_DATA
ICONCTRLA_GetGlobalEmbossRect | IECLASS_REQUESTER | INTB_AUD0
ICONCTRLA_GetGlobalFrameless | IECLASS_SIZEWINDOW | INTB_AUD1
ICONCTRLA_GetGlobalIdentifyHook | IECLASS_TIMER | INTB_AUD2
ICONCTRLA_GetGlobalMaxNameLength | IECODE_ASCII_DEL | INTB_AUD3
ICONCTRLA_GetGlobalNewIconsSupport | IECODE_ASCII_FIRST | INTB_BLIT
ICONCTRLA_GetGlobalPrecision | IECODE_ASCII_LAST | INTB_COPER
ICONCTRLA_GetGlobalScreen | IECODE_C0_FIRST | INTB_DSKBLK
ICONCTRLA_GetHeight | IECODE_C0_LAST | INTB_DSKSYNC
ICONCTRLA_GetImageData1 | IECODE_C1_FIRST | INTB_EXTER
ICONCTRLA_GetImageData2 | IECODE_C1_LAST | INTB_INTEN
ICONCTRLA_GetImageMask1 | IECODE_COMM_CODE_FIRST | INTB_NMI
ICONCTRLA_GetImageMask2 | IECODE_COMM_CODE_LAST | INTB_PORTS
ICONCTRLA_GetNewIconsSupport | IECODE_KEY_CODE_FIRST | INTB_RBF
ICONCTRLA_GetPalette1 | IECODE_KEY_CODE_LAST | INTB_SETCLR
ICONCTRLA_GetPalette2 | IECODE_LATIN1_FIRST | INTB_SOFTINT
ICONCTRLA_GetPaletteSize1 | IECODE_LATIN1_LAST | INTB_TBE
ICONCTRLA_GetPaletteSize2 | IECODE_LBUTTON | INTB_VERTB
ICONCTRLA_GetScreen | IECODE_MBUTTON | INTEGERIDCMP
ICONCTRLA_GetTransparentColor1 | IECODE_NEWACTIVE | INTEGER_KIND
ICONCTRLA_GetTransparentColor2 | IECODE_NEWSIZE | INTEGER_SCALING
ICONCTRLA_GetWidth | IECODE_NOBUTTON | INTERHEIGHT
ICONCTRLA_HasRealImage2 | IECODE_RBUTTON | INTERLACE
ICONCTRLA_IsNativeIcon | IECODE_REFRESH | InternalLoadSeg
ICONCTRLA_IsNewIcon | IECODE_REQCLEAR | INTERWIDTH
ICONCTRLA_IsPaletteMapped | IECODE_REQSET | INTF_AUD0
ICONCTRLA_SetAspectRatio | IECODE_UP_PREFIX | INTF_AUD1
ICONCTRLA_SetFrameless | IEQUALIFIERB_CAPSLOCK | INTF_AUD2
ICONCTRLA_SetGlobalColorIconSupport | IEQUALIFIERB_CONTROL | INTF_AUD3
ICONCTRLA_SetGlobalEmbossRect | IEQUALIFIERB_INTERRUPT | INTF_BLIT
ICONCTRLA_SetGlobalFrameless | IEQUALIFIERB_LALT | INTF_COPER
ICONCTRLA_SetGlobalIdentifyHook | IEQUALIFIERB_LCOMMAND | INTF_DSKBLK
ICONCTRLA_SetGlobalMaxNameLength | IEQUALIFIERB_LEFTBUTTON | INTF_DSKSYNC
ICONCTRLA_SetGlobalNewIconsSupport | IEQUALIFIERB_LSHIFT | INTF_EXTER
ICONCTRLA_SetGlobalPrecision | IEQUALIFIERB_MIDBUTTON | INTF_INTEN
ICONCTRLA_SetGlobalScreen | IEQUALIFIERB_MULTIBROADCAST | INTF_NMI
ICONCTRLA_SetHeight | IEQUALIFIERB_NUMERICPAD | INTF_PORTS
ICONCTRLA_SetImageData1 | IEQUALIFIERB_RALT | INTF_RBF
ICONCTRLA_SetImageData2 | IEQUALIFIERB_RBUTTON | INTF_SETCLR
ICONCTRLA_SetNewIconsSupport | IEQUALIFIERB_RCOMMAND | INTF_SOFTINT
ICONCTRLA_SetPalette1 | IEQUALIFIERB_RELATIVEMOUSE | INTF_TBE
ICONCTRLA_SetPalette2 | IEQUALIFIERB_REPEAT | INTF_VERTB
ICONCTRLA_SetPaletteSize1 | IEQUALIFIERB_RSHIFT | IntuiTextLength
ICONCTRLA_SetPaletteSize2 | IEQUALIFIER_CAPSLOCK | intuition
ICONCTRLA_SetTransparentColor1 | IEQUALIFIER_CONTROL | Intuition
ICONCTRLA_SetTransparentColor2 | IEQUALIFIER_INTERRUPT | Intuitionbase
ICONCTRLA_SetWidth | IEQUALIFIER_LALT | INTUITIONNAME
ICONDRAWA_Borderless | IEQUALIFIER_LCOMMAND | INVALID_ID
ICONDRAWA_DrawInfo | IEQUALIFIER_LEFTBUTTON | INVERSVID
ICONDRAWA_EraseBackground | IEQUALIFIER_LSHIFT | InvertAndCopy
ICONDRAWA_Frameless | IEQUALIFIER_MIDBUTTON | InvertDest
ICONDRAWA_IsLink | IEQUALIFIER_MULTIBROADCAST | InvertKeyMap
ICONDUPA_ActivateImageData | IEQUALIFIER_NUMERICPAD | InvertPixelArray
ICONDUPA_DuplicateDefaultTool | IEQUALIFIER_RALT | IOB_QUICK
ICONDUPA_DuplicateDrawerData | IEQUALIFIER_RBUTTON | IoErr
ICONDUPA_DuplicateImageData | IEQUALIFIER_RCOMMAND | IOERR_ABORTED
ICONDUPA_DuplicateImages | IEQUALIFIER_RELATIVEMOUSE | IOERR_BADADDRESS
ICONDUPA_DuplicateToolTypes | IEQUALIFIER_REPEAT | IOERR_BADLENGTH
ICONDUPA_DuplicateToolWindow | IEQUALIFIER_RSHIFT | IOERR_NOCMD
ICONGETA_FailIfUnavailable | IESUBCLASS_COMPATIBLE | IOERR_NOMEMORY
ICONGETA_GenerateImageMasks | IESUBCLASS_NEWTABLET | IOERR_OPENFAIL
ICONGETA_GetDefaultName | IESUBCLASS_PIXEL | IOERR_SELFTEST
ICONGETA_GetDefaultType | IESUBCLASS_TABLET | IOERR_UNITBUSY
ICONGETA_GetPaletteMappedIcon | IFFCMD_CLEANUP | IOF_QUICK
ICONGETA_IsDefaultIcon | IFFCMD_ENTRY | IOSERB_ABORT
ICONGETA_Label | IFFCMD_EXIT | IOSERB_ACTIVE
ICONGETA_RemapIcon | IFFCMD_INIT | IOSERB_BUFRREAD
ICONGETA_Screen | IFFCMD_PURGELCI | IOSERB_QUEUED
ICONIFYIMAGE | IFFCMD_READ | IOSERF_ABORT
ICONNAME | IFFCMD_SEEK | IOSERF_ACTIVE
ICONPUTA_DropChunkyIconImage | IFFCMD_WRITE | IOSERF_BUFRREAD
ICONPUTA_DropNewIconToolTypes | IFFERR_EOC | IOSERF_QUEUED
ICONPUTA_DropPlanarIconImage | IFFERR_EOF | IO_STATB_OVERRUN
ICONPUTA_NotifyWorkbench | IFFERR_MANGLED | IO_STATB_READBREAK
ICONPUTA_OnlyUpdatePosition | IFFERR_NOHOOK | IO_STATB_WROTEBREAK
ICONPUTA_OptimizeImageSpace | IFFERR_NOMEM | IO_STATB_XOFFREAD
ICONPUTA_PreserveOldIconImages | IFFERR_NOSCOPE | IO_STATB_XOFFWRITE
ICONPUTA_PutDefaultName | IFFERR_NOTIFF | IO_STATF_OVERRUN
ICONPUTA_PutDefaultType | IFFERR_READ | IO_STATF_READBREAK
ICSPECIAL_CODE | IFFERR_SEEK | IO_STATF_WROTEBREAK
ICTARGET_IDCMP | IFFERR_SYNTAX | IO_STATF_XOFFREAD
ID_8SVX | IFFERR_WRITE | IO_STATF_XOFFWRITE
ID_AHIG | IFFF_FSEEK | IOSTB_OVERRUN
ID_AHIU | IFFF_READ | IOSTB_READBREAK
ID_ANHD | IFFF_RESERVED | IOSTB_WROTEBREAK
ID_ANIM | IFFF_RSEEK | IOSTB_XOFFREAD
ID_BMHD | IFFF_RWBITS | IOSTB_XOFFWRITE
ID_BODY | IFFF_WRITE | IOSTF_OVERRUN
ID_CAMG | IFFLCI_COLLECTION | IOSTF_READBREAK
ID_CAT | IFFLCI_ENTRYHANDLER | IOSTF_WROTEBREAK
ID_CDFS_DISK | IFFLCI_EXITHANDLER | IOSTF_XOFFREAD
ID_CDROM_CDDA_DISK | IFFLCI_PROP | IOSTF_XOFFWRITE
ID_CDROM_HSF_DISK | IFFOFFSET_BEGINNING | PtrUInt
ID_CDROM_ISO_DISK | IFFOFFSET_CURRENT | IsAlNum
ID_CHAN | IFFOFFSET_END | IsAlpha
ID_CHRS | iffparse | IsCntrl
ID_CMAP | IFFParseBase | IsCyberModeID
IDCMP_ACTIVEWINDOW | IFFPARSENAME | IsDigit
IDCMP_CHANGEWINDOW | IFFPARSE_RAWSTEP | ISDRAWN
IDCMP_CLOSEWINDOW | IFFPARSE_SCAN | IsFileSystem
IDCMP_DELTAMOVE | IFFPARSE_STEP | IsGraph
IDCMP_DISKINSERTED | IFF_RETURN2CLIENT | ISGRTRX
IDCMP_DISKREMOVED | IFFSCC_CLEANUP | ISGRTRY
IDCMP_GADGETDOWN | IFFSCC_INIT | IsInteractive
IDCMP_GADGETHELP | IFFSCC_READ | IsLayerHitable
IDCMP_GADGETUP | IFFSCC_SEEK | IsLayerVisible
IDCMP_IDCMPUPDATE | IFFSCC_WRITE | ISLESSX
IDCMP_INACTIVEWINDOW | IFFSIZE_UNKNOWN | ISLESSY
IDCMP_INTUITICKS | IFFSLI_PROP | IsLower
IDCMP_LONELYMESSAGE | IFFSLI_ROOT | ISMACTION_Ignore
IDCMP_MENUHELP | IFFSLI_TOP | ISMACTION_Select
IDCMP_MENUPICK | IGNORE_DIMENSIONS | ISMACTION_Stop
IDCMP_MENUVERIFY | IGNORE_MCOMPAT | ISMACTION_Unselect
IDCMP_MOUSEBUTTONS | IMAGECLASS | IsPrint
IDCMP_MOUSEHOVER | IMAGE_NEGATIVE | IsPunct
IDCMP_MOUSEMOVE | IMAGE_POSITIVE | IsSpace
IDCMP_MOUSEOBJECTMUI | IM_BGPEN | IsUnicode
IDCMP_NEWPREFS | IM_BOX | IsUpper
IDCMP_NEWSIZE | IM_DOMAINFRAME | IsVisibleInLayer
IDCMP_RAWKEY | IM_DRAW | IsXDigit
IDCMP_REFRESHWINDOW | IM_DRAWFRAME | ItemAddress
IDCMP_REQCLEAR | IM_ERASE | ITEMENABLED
IDCMP_REQSET | IM_ERASEFRAME | ITEM_EQUAL
IDCMP_REQVERIFY | IM_FGPEN | ITEM_ERROR
IDCMP_SIZEVERIFY | IM_FRAMEBOX | ITEM_NOTHING
IDCMP_VANILLAKEY | IM_HITFRAME | ITEMNUM
IDCMP_WBENCHMESSAGE | IM_HITTEST | ITEM_QUOTED
ID_CODE | IM_ITEM | ITEMTEXT
ID_CRNG | IM_MOVE | ITEM_UNQUOTED
ID_DEST | IMSGA_Class | ITEXTICLASS
ID_DLTA | IMSGA_Code | IX
ID_DOS_DISK | IMSGA_Dummy | IX_NORMALQUALS
ID_DTHD | IMSGA_IAddress | IXSYM_ALT
ID_DTYP | IMSGA_IDCMPWindow | IXSYM_ALTMASK
ID_FASTDIR_DOS_DISK | IMSGA_Micros | IXSYM_CAPS
ID_FASTDIR_FFS_DISK | IMSGA_MouseX | IXSYM_CAPSMASK
ID_FFS_DISK | IMSGA_MouseY | IXSYM_SHIFT
ID_FORM | IMSGA_Qualifier | IXSYM_SHIFTMASK
ID_FTXT | IMSGA_RawMouseX | IX_VERSION
ID_GRAB | IMSGA_RawMouseY |
ID_ILBM | IMSGA_Seconds |

J

JAM1 JAM2 JUMPIMAGE

K

KBD_ADDRESETHANDLER | KCF_ALT | KEYCODE_M
KBD_READEVENT | KCF_CONTROL | KEYCODE_N
KBD_READMATRIX | KCF_DEAD | KEYCODE_Q
KBD_REMRESETHANDLER | KCF_DOWNUP | KEYCODE_V
KBD_RESETHANDLERDONE | KCF_NOP | KEYCODE_X
KCB_ALT | KCF_SHIFT | keymap
KCB_CONTROL | KCF_STRING | KeyMapBase
KCB_DEAD | KC_NOQUAL | KEYMAPNAME
KCB_DOWNUP | KC_VANILLA | KNOBHIT
KCB_NOP | KEYCODE_B | KNOBHMIN
KCB_SHIFT | KEYCODE_GREATER | KNOBVMIN
KCB_STRING | KEYCODE_LESS |

L

LA_BackfillHook | LendMenus | LockLayer
LACE | LETTER | LockLayerInfo
LACEWB | LFalse | LockLayerRom
LA_Dummy | LIB_BASE | LockLayers
LA_SuperBitMap | LIB_CLOSE | LockLayerUpdates
LA_TransHook | LIB_EXPUNGE | LockPubScreen
LA_TransRegion | LIB_EXTFUNC | LockPubScreenList
LaunchTool | LIBF_CHANGED | LockRecord
LaunchToolA | LIBF_DELEXP | LockRecord64
LA_WindowPtr | LIBF_QUERYINFO | LockRecords
LAYERBACKDROP | LIBF_RAMLIB | LockRecords64
LAYER_CLIPRECTS_LOST | LIBF_SUMMING | LOCK_SAME
LAYERIREFRESH | LIBF_SUMUSED | LOCK_SAME_HANDLER
LAYERIREFRESH2 | LIB_GETQUERYATTR | LOCK_SAME_VOLUME
LAYERREFRESH | LIB_NONSTD | LockVLayer
layers | LIB_OPEN | LOGO_CRASH
LAYERS_BACKFILL | LIB_RESERVED | LOLDIS
LayersBase | LIBTAG_BASE | LongInt
LAYERSIMPLE | LIBTAG_BASESIZE | LongWord
LAYERSMART | LIBTAG_FLAGS | LORESDPF2_KEY
LAYERSNAME | LIBTAG_FUNCTIONINIT | LORESDPF_KEY
LAYERS_NEVERBACKFILL | LIBTAG_IDSTRING | LORESEHBSDBL_KEY
LAYERS_NOBACKFILL | LIBTAG_LIBRARYINIT | LORESHAMSDBL_KEY
LAYERSUPER | LIBTAG_MACHINE | LORES_KEY
LAYERUPDATING | LIBTAG_NAME | LORESLACEDPF2_KEY
LAYOUTA_ChildMaxHeight | LIBTAG_PRI | LORESLACEDPF_KEY
LAYOUTA_ChildMaxWidth | LIBTAG_PUBLIC | LORESLACE_KEY
LAYOUTA_Dummy | LIBTAG_QUERYINFO | LORESSDBL_KEY
LAYOUTA_LayoutObj | LIBTAG_REVISION | LORIENT_HORIZ
LAYOUTA_Orientation | LIBTAG_SEGLIST | LORIENT_NONE
LAYOUTA_Spacing | LIBTAG_STRUCTINIT | LORIENT_VERT
LayoutIconA | LIBTAG_TYPE | LOWCHECKWIDTH
LayoutMenuItemsA | LIBTAG_VERSION | LOWCOMMWIDTH
LayoutMenusA | LIB_USERDEF | LOWRESGADGET
LBMI_BASEADDRESS | LIB_VECTSIZE | LOWRESPICK
LBMI_BYTESPERPIX | LINEMODE | LPEN_SWAP_FRAMES
LBMI_BYTESPERROW | LINK_HARD | LR_Destination_BitMap
LBMI_DEPTH | LINK_SOFT | LR_Destination_Bounds
LBMI_HEIGHT | LISTVIEWIDCMP | LR_Destination_RastPort
LBMI_PIXFMT | LISTVIEW_KIND | LR_Dummy
LBMI_WIDTH | LNF_LF | LR_Erase
LDB_ASSIGNS | LNF_LINK | LR_IgnoreList
LDB_DELETE | LNF_OBJECT | LR_LayerInfo_Bounds
LDB_DEVICES | LNF_SELECTED | LR_RenderList
LDB_ENTRY | LoadRGB32 | LTrue
LDB_READ | LoadRGB4 | LV_ALIAS
LDB_VOLUMES | LoadSeg | LVB_IGNORE
LDB_WRITE | LoadView | LVCB_OK
LDF_ALL | locale | LVCB_UNKNOWN
LDF_ASSIGNS | LocaleBase | LV_DRAW
LDF_DELETE | LOCALENAME | LVF_IGNORE
LDF_DEVICES | LocalItemData | LVR_NORMAL
LDF_ENTRY | Lock | LVR_NORMALDISABLED
LDF_READ | LockBitMapTagList | LVR_SELECTED
LDF_VOLUMES | LockDataType | LVR_SELECTEDDISABLED
LDF_WRITE | LOCK_DIFFERENT | LV_VAR
LEFTHIT | LockDosList | LW_RESERVED
LEFTIMAGE | LockIBase |
LEN_DATSTRING | LOCKIMAGE |

M

MA_BacklightControl | MUIA_Menu_Enabled | MUIM_Application_ReturnID
MA_BacklightLevel | MUIA_Menuitem_Checked | MUIM_Application_Save
MA_BacklightLevelSteps | MUIA_Menuitem_Checkit | MUIM_Application_SetConfigItem
MA_BottomLeftMonitor | MUIA_Menuitem_CommandString | MUIM_Application_ShowHelp
MA_BottomMiddleMonitor | MUIA_Menuitem_Enabled | MUIM_AskMinMax
MA_BottomRightMonitor | MUIA_Menuitem_Exclude | MUIMasterBase
MACHINE_M68k | MUIA_Menuitem_Shortcut | MUIMASTER_NAME
MACHINE_NO | MUIA_Menuitem_Title | MUIMASTER_VLATEST
MACHINE_PPC | MUIA_Menuitem_Toggle | MUIMASTER_VMIN
MADF_DRAWOBJECT | MUIA_Menuitem_Trigger | MUI_MAXMAX
MADF_DRAWUPDATE | MUIA_Menustrip_Enabled | MUIM_BoopsiQuery
MA_DriverName | MUIA_Menu_Title | MUIM_CallHook
MA_Dummy | MUIA_NoNotify | MUIM_Cleanup
MA_GammaControl | MUIA_NoNotifyMethod | MUIM_ContextMenuAdd
MakeClass | MUIA_Numeric_CheckAllSizes | MUIM_ContextMenuBuild
MakeDosEntry | MUIA_Numeric_Default | MUIM_ContextMenuChoice
MakeFunctions | MUIA_Numeric_Format | MUIM_CreateBubble
Make_ID | MUIA_Numeric_Max | MUIM_CreateShortHelp
MAKE_ID | MUIA_Numeric_Min | MUIM_Dataspace_Add
MakeLibrary | MUIA_Numeric_Reverse | MUIM_Dataspace_Clear
MakeLink | MUIA_Numeric_RevLeftRight | MUIM_Dataspace_Find
MakeScreen | MUIA_Numeric_RevUpDown | MUIM_Dataspace_Merge
MakeVPort | MUIA_Numeric_Value | MUIM_Dataspace_ReadIFF
MakeWorkbenchObjectVisible | MUIA_ObjectID | MUIM_Dataspace_Remove
MakeWorkbenchObjectVisibleA | MUIA_Palette_Entries | MUIM_Dataspace_WriteIFF
MA_Manufacturer | MUIA_Palette_Groupable | MUIM_DeleteBubble
MA_ManufacturerID | MUIA_Palette_Names | MUIM_DeleteShortHelp
MA_MemoryClock | MUIA_Parent | MUIM_Dirlist_ReRead
MA_MemorySize | MUIA_Penadjust_PSIMode | MUIM_DoDrag
MA_MiddleLeftMonitor | MUIA_Pendisplay_Pen | MUIM_DragBegin
MA_MiddleRightMonitor | MUIA_Pendisplay_Reference | MUIM_DragDrop
MA_MonitorName | MUIA_Pendisplay_RGBcolor | MUIM_DragFinish
ManageDesktopObjectA | MUIA_Pendisplay_Spec | MUIM_DragQuery
ManageDesktopObjectTags | MUIA_Popasl_Active | MUIM_DragReport
MapANSI | MUIA_Popasl_StartHook | MUIM_Draw
MA_PixelFormats | MUIA_Popasl_StopHook | MUIM_DrawBackground
MAP_KEEP_NOT_FOUND | MUIA_Popasl_Type | MUIM_Export
MA_PointerType | MUIA_Poplist_Array | MUIM_Family_AddHead
MapRawKey | MUIA_Popobject_Follow | MUIM_Family_AddTail
MapRawKeyUCS4 | MUIA_Popobject_Light | MUIM_Family_Insert
MAP_REMOVE_NOT_FOUND | MUIA_Popobject_Object | MUIM_Family_Remove
MA_ProductID | MUIA_Popobject_ObjStrHook | MUIM_Family_Sort
MapTags | MUIA_Popobject_StrObjHook | MUIM_Family_Transfer
MapUCS4 | MUIA_Popobject_Volatile | MUIM_FindUData
M_ASM | MUIA_Popobject_WindowHook | MUIM_GetConfigItem
MatchEnd | MUIA_Popstring_Button | MUIM_GetUData
MatchFirst | MUIA_Popstring_CloseHook | MUIM_Group_ExitChange
MatchIX | MUIA_Popstring_OpenHook | MUIM_Group_InitChange
MatchNext | MUIA_Popstring_String | MUIM_Group_Sort
MatchPattern | MUIA_Popstring_Toggle | MUIM_HandleEvent
MatchPatternNoCase | MUIA_Pressed | MUIM_HandleInput
MatchToolValue | MUIA_Prop_Entries | MUIM_Hide
MA_TopLeftMonitor | MUIA_Prop_First | MUIM_Import
MA_TopMiddleMonitor | MUIA_Prop_Horiz | MUIM_KillNotify
MA_TopRightMonitor | MUIA_Prop_Slider | MUIM_KillNotifyObj
M_AWM | MUIA_Prop_UseWinBorder | MUIM_List_Clear
MAXBODY | MUIA_Prop_Visible | MUIM_List_CreateImage
MAXBYTESPERROW | MUIA_Radio_Active | MUIM_List_DeleteImage
MaxCli | MUIA_Radio_Entries | MUIM_List_Exchange
MAXFONTMATCHWEIGHT | MUIAreaData | MUIM_List_GetEntry
MAXFONTNAME | MUIA_Rectangle_BarTitle | MUIM_List_Insert
MAXFONTPATH | MUIA_Rectangle_HBar | MUIM_List_InsertSingle
_MAXINT | MUIA_Rectangle_VBar | MUIM_List_Jump
MAX_MULTIARGS | MUIA_Register_Frame | MUIM_List_Move
MAXPOT | MUIA_Register_Titles | MUIM_List_NextSelected
MAXPUBSCREENNAME | MUIA_Revision | MUIM_List_Redraw
MAXSTRMSG | MUIA_RightEdge | MUIM_List_Remove
MAXTABS | MUIA_Scale_Horiz | MUIM_List_Select
MAX_TEMPLATE_ITEMS | MUIA_Screenbar_DisplayedImage | MUIM_List_Sort
MBQF_HORIZ | MUIA_Screenbar_DisplayedName | MUIM_List_TestPos
MBQ_MUI_MAXMAX | MUIA_Scrollbar_Type | MUIM_Menustrip_ExitChange
MCOMPAT_MIXED | MUIA_Scrollgroup_Contents | MUIM_Menustrip_InitChange
MCOMPAT_NOBODY | MUIA_Scrollgroup_FreeHoriz | MUIM_MultiSet
MCOMPAT_SELF | MUIA_Scrollgroup_FreeVert | MUIM_NoNotifySet
MCOP_NO_MEM | MUIA_Scrollgroup_HorizBar | MUIM_Notify
MCOP_NOP | MUIA_Scrollgroup_UseWinBorder | MUIM_Numeric_Decrease
MCOP_OK | MUIA_Scrollgroup_VertBar | MUIM_Numeric_Increase
MC_TEMPLATE_ID | MUIA_Selected | MUIM_Numeric_ScaleToValue
MEM_ALL_DONE | MUIA_ShortHelp | MUIM_Numeric_SetDefault
MEM_BLOCKMASK | MUIA_ShowMe | MUIM_Numeric_Stringify
MEM_BLOCKSIZE | MUIA_ShowSelState | MUIM_Numeric_ValueToScale
MEM_DID_NOTHING | MUIA_Slider_Horiz | MUIM_Pendisplay_SetColormap
MEMF_24BITDMA | MUIA_Slider_Quiet | MUIM_Pendisplay_SetMUIPen
MEMF_31BIT | MUI_AslRequest | MUIM_Pendisplay_SetRGB
MEMF_ANY | MUI_AslRequestTags | MUIM_Popstring_Close
MEMF_CHIP | MUIA_String_Accept | MUIM_Popstring_Open
MEMF_CLEAR | MUIA_String_Acknowledge | MUIM_Prop_Decrease
MEMF_FAST | MUIA_String_AdvanceOnCR | MUIM_Prop_Increase
MEMF_KICK | MUIA_String_AttachedList | MUIMRI_RECTFILL
MEMF_LARGEST | MUIA_String_BufferPos | MUIMRI_REFRESHMODE
MEMF_LOCAL | MUIA_String_Contents | MUIMRI_THINFRAMES
MEMF_NO_EXPUNGE | MUIA_String_DisplayPos | MUIMRI_TRUECOLOR
MEMF_PUBLIC | MUIA_String_EditHook | MUIM_Screenbar_BuildSettingsPanel
MEMF_REVERSE | MUIA_String_Format | MUIM_Screenbar_DefaultConfigItem
MEMF_SEM_PROTECTED | MUIA_String_Integer | MUIM_Screenbar_KnowsConfigItem
MEMF_SWAP | MUIA_String_LonelyEditHook | MUIM_Screenbar_Lock
MEMF_TOTAL | MUIA_String_MaxLen | MUIM_Screenbar_Signal
MEMHF_RECYCLE | MUIA_String_Reject | MUIM_Screenbar_Unlock
MEM_TRY_AGAIN | MUIA_String_Secret | MUIM_Screenbar_UpdateConfigItem
MENUCANCEL | MUIA_Text_Contents | MUIM_Semaphore_Attempt
MENUCHECK | MUIA_Text_ControlChar | MUIM_Semaphore_AttemptShared
MENUDOWN | MUIA_Text_Copy | MUIM_Semaphore_Obtain
MENUENABLED | MUIA_Text_HiChar | MUIM_Semaphore_ObtainShared
MENUHOT | MUIA_Text_PreParse | MUIM_Semaphore_Release
MENU_IMAGE | MUIA_Text_SetMax | MUIM_Set
MENUNULL | MUIA_Text_SetMin | MUIM_SetAsString
MENUNUM | MUIA_Text_SetVMax | MUIM_Settingsgroup_ConfigToGadgets
MENUTOGGLE | MUIA_Text_Shorten | MUIM_Settingsgroup_GadgetsToConfig
MENUTOGGLED | MUIA_Text_Shortened | MUIM_SetUData
MENUTOGGLEIMAGE | MUIA_Timer | MUIM_SetUDataOnce
MENUUP | MUIA_TopEdge | MUIM_Setup
MENUWAITING | MUIA_UserData | MUIM_Show
MIDDLEDOWN | MUIA_Version | MUIM_UpdateConfig
MIDDLEUP | MUIA_VertDisappear | MUIM_UpdateConfig
MIDRAWN | MUIA_VertWeight | MUIM_Window_AddEventHandler
MINBYTESPERROW | MUIA_Virtgroup_Height | MUIM_Window_Cleanup
_MININT | MUIA_Virtgroup_Input | MUIM_Window_RemEventHandler
MIN_NTSC_ROW | MUIA_Virtgroup_Left | MUIM_Window_ScreenToBack
MIN_PAL_ROW | MUIA_Virtgroup_Top | MUIM_Window_ScreenToFront
MIN_VGA70_ROW | MUIA_Virtgroup_Width | MUIM_Window_Setup
MIN_VGA_ROW | MUIA_Weight | MUIM_Window_Snapshot
MKBADDR | MUIA_Width | MUIM_Window_ToBack
M_LNM | MUIA_Window | MUIM_Window_ToFront
MM_Authorization | MUIA_Window_Activate | MUIM_WriteLong
MM_EnterPowerSaveMode | MUIA_Window_ActiveObject | MUIM_WriteString
MM_ExitBlanker | MUIA_Window_AltHeight | MUI_NewObject
MM_GetDefaultGammaTables | MUIA_Window_AltLeftEdge | MUI_NewObjectA
MM_GetDefaultPixelFormat | MUIA_Window_AltTopEdge | MUINotifyData
MM_GetPointerBounds | MUIA_Window_AltWidth | MUIO_BarTitle
MM_GetRootBitMap | MUIA_Window_AppWindow | MUI_ObtainPen
MM_Query3DSupport | MUIA_Window_Backdrop | MUIO_Button
MM_RunBlanker | MUIA_Window_Borderless | MUIO_Checkmark
MODE_640 | MUIA_Window_CloseGadget | MUIO_Cycle
MODELCLASS | MUIA_Window_CloseRequest | MUIO_HBar
MODE_NEWFILE | MUIA_Window_DefaultObject | MUIO_HSpace
ModeNotAvailable | MUIA_Window_DepthGadget | MUIO_Label
MODE_OLDFILE | MUIA_Window_DragBar | MUIO_Label_Centered
MODE_READWRITE | MUIA_Window_FancyDrawing | MUIO_Label_DoubleFrame
ModifyIDCMP | MUIA_Window_Height | MUIO_Label_FreeVert
ModifyProp | MUIA_Window_ID | MUIO_Label_LeftAligned
MON_1 | MUIA_Window_InputEvent | MUIO_Label_SingleFrame
MON_10 | MUIA_Window_IsSubWindow | MUIO_Menuitem
MON_11 | MUIA_Window_LeftEdge | MUIO_Menuitem_CopyStrings
MON_12 | MUIA_Window_MenuAction | MUIO_MenustripNM
MON_2 | MUIA_Window_Menustrip | MUIO_MenustripNM_CommandKeyCheck
MON_3 | MUIA_Window_MouseObject | MUIO_NumericButton
MON_4 | MUIA_Window_NeedsMouseObject | MUIO_PopButton
MON_5 | MUIA_Window_NoMenus | MUIO_Radio
MON_6 | MUIA_WindowObject | MUIO_Slider
MON_7 | MUIA_Window_Open | MUIO_String
MON_8 | MUIA_Window_PublicScreen | MUIO_VBar
MON_9 | MUIA_Window_RefWindow | MUIO_VSpace
MONITOR_ID_MASK | MUIA_Window_RootObject | MUIP_BoopsiQuery
MONITOR_MAXPIXELFORMATS | MUIA_Window_Screen | MUIP_Dirlist_ReRead
MONITOR_SPEC_TYPE | MUIA_Window_ScreenTitle | MUIPen
MOUSE_ACCEL | MUIA_Window_SizeGadget | MUIPEN_MASK
MoveLayer | MUIA_Window_SizeRight | MUIP_Pendisplay_SetColormap
MoveLayerInFrontOf | MUIA_Window_Sleep | MUIP_Pendisplay_SetMUIPen
MovePixelArray | MUIA_Window_Title | MUIP_Pendisplay_SetRGB
MoveScreen | MUIA_Window_TopEdge | MUI_Redraw
MoveSizeLayer | MUIA_Window_UseBottomBorderScroller | MUI_RejectIDCMP
MoveSprite | MUIA_Window_UseLeftBorderScroller | MUI_ReleasePen
MoveWindow | MUIA_Window_UseRightBorderScroller | MUI_RemoveClipping
MoveWindowInFrontOf | MUIA_Window_Width | MUI_RemoveClipRegion
MPEN_BACKGROUND | MUIA_Window_Window | MUIRenderInfo
MPEN_COUNT | MUI_BeginRefresh | MUI_Request
MPEN_FILL | MUIC_Aboutmui | MUI_RequestA
MPEN_HALFSHADOW | MUIC_Application | MUI_RequestIDCMP
MPEN_HALFSHINE | MUIC_Applist | MUI_RXERR_BADDEFINITION
MPEN_MARK | MUIC_Area | MUI_RXERR_BADSYNTAX
MPEN_SHADOW | MUIC_Balance | MUI_RXERR_OUTOFMEMORY
MPEN_SHINE | MUIC_Bitmap | MUI_RXERR_UNKNOWNCOMMAND
MPEN_TEXT | MUIC_Bodychunk | MUISERIALNO_INTUITION
MrgCop | MUIC_Boopsi | MUIset
MS_AMERICAN | MUIC_Cclist | MUI_SetError
MSB_DOUBLE_SPRITES | MUIC_Coloradjust | MUI_TRUE
MSB_REQUEST_A2024 | MUIC_Colorfield | MUIUserData
MSB_REQUEST_NTSC | MUIC_Configdata | MUIV_Application_OCW_ScreenPage
MSB_REQUEST_PAL | MUIC_Cycle | MUIV_Application_ReturnID_Quit
MSB_REQUEST_SPECIAL | MUIC_Dataspace | MUIV_ContextMenuBuild_Default
MS_BRITISH | MUIC_Dirlist | MUIV_CreateBubble_DontHidePointer
MSF_DOUBLE_SPRITES | MUIC_Dtpic | MUIV_Cycle_Active_Next
MSF_REQUEST_A2024 | MUIC_Family | MUIV_Cycle_Active_Prev
MSF_REQUEST_NTSC | MUICFG_PublicScreen | MUIV_Dirlist_SortDirs_First
MSF_REQUEST_PAL | MUIC_Floattext | MUIV_Dirlist_SortDirs_Last
MSF_REQUEST_SPECIAL | MUIC_Frameadjust | MUIV_Dirlist_SortDirs_Mix
MS_IMPERIAL | MUIC_Framedisplay | MUIV_Dirlist_SortType_Date
MS_ISO | MUIC_Gadget | MUIV_Dirlist_SortType_Name
mskHasAlpha | MUIC_Gauge | MUIV_Dirlist_SortType_Size
mskHasMask | MUIC_Group | MUIV_Dirlist_Status_Invalid
mskHasTransparentColor | MUIC_Image | MUIV_Dirlist_Status_Reading
mskLasso | MUIC_Imageadjust | MUIV_Dirlist_Status_Valid
mskNone | MUIC_Imagedisplay | MUIV_DragQuery_Accept
MSQUERY3D_HWDRIVER | MUIC_Knob | MUIV_DragQuery_Refuse
MSQUERY3D_NODRIVER | MUIC_Levelmeter | MUIV_DragReport_Abort
MSQUERY3D_SWDRIVER | MUIC_List | MUIV_DragReport_Continue
MSQUERY3D_UNKNOWN | MUIC_Listview | MUIV_DragReport_Lock
mui | MUIC_Mccprefs | MUIV_DragReport_Refresh
MUIA_Aboutmui_Application | MUIC_Menu | MUIV_EveryTime
MUIA_Application_Active | MUIC_Menubar | MUIV_Family_GetChild_First
MUIA_Application_Author | MUIC_Menuitem | MUIV_Family_GetChild_Iterate
MUIA_Application_Base | MUIC_Menustrip | MUIV_Family_GetChild_Last
MUIA_Application_Broker | MUIC_Notify | MUIV_Family_GetChild_Next
MUIA_Application_BrokerHook | MUIC_Numeric | MUIV_Family_GetChild_Previous
MUIA_Application_BrokerPort | MUIC_Numericbutton | MUIV_Font_Big
MUIA_Application_BrokerPri | MUIC_Palette | MUIV_Font_Button
MUIA_Application_Commands | MUIC_Penadjust | MUIV_Font_Fixed
MUIA_Application_Copyright | MUIC_Pendisplay | MUIV_Font_Gauge
MUIA_Application_Description | MUIC_Popasl | MUIV_Font_Inherit
MUIA_Application_DiskObject | MUIC_Popframe | MUIV_Font_List
MUIA_Application_DoubleStart | MUIC_Popimage | MUIV_Font_Menudisplay
MUIA_Application_DropObject | MUIC_Poplist | MUIV_Font_Normal
MUIA_Application_ForceQuit | MUIC_Popobject | MUIV_Font_Slider
MUIA_Application_HelpFile | MUIC_Poppen | MUIV_Font_Tiny
MUIA_Application_Iconified | MUIC_Popscreen | MUIV_Font_Title
MUIA_Application_MenuAction | MUIC_Popstring | MUIV_Frame_Button
MUIA_Application_MenuHelp | MUIC_Prop | MUIV_Frame_Count
MUIA_Application_Menustrip | MUIC_Radio | MUIV_Frame_Gauge
MUIA_ApplicationObject | MUI_CreateCustomClass | MUIV_Frame_GaugeInner
MUIA_Application_RexxHook | MUIC_Rectangle | MUIV_Frame_Group
MUIA_Application_RexxMsg | MUIC_Register | MUIV_Frame_ImageButton
MUIA_Application_RexxString | MUIC_Scale | MUIV_Frame_InputList
MUIA_Application_SingleTask | MUIC_Scrmodelist | MUIV_Frame_Menudisplay
MUIA_Application_Sleep | MUIC_Scrollbar | MUIV_Frame_MenudisplayMenu
MUIA_Application_Title | MUIC_Scrollgroup | MUIV_Frame_None
MUIA_Application_UseCommodities | MUIC_Semaphore | MUIV_Frame_Page
MUIA_Application_UsedClasses | MUIC_Settings | MUIV_Frame_PopUp
MUIA_Application_UseRexx | MUIC_Settingsgroup | MUIV_Frame_Prop
MUIA_Application_Version | MUIC_Slider | MUIV_Frame_PropKnob
MUIA_Application_Window | MUIC_String | MUIV_Frame_ReadList
MUIA_Application_WindowList | MUIC_Text | MUIV_Frame_Register
MUIA_AppMessage | MUIC_Virtgroup | MUIV_Frame_Requester
MUIA_Background | MUIC_Volumelist | MUIV_Frame_Slider
MUIA_Balance_Quiet | MUIC_Window | MUIV_Frame_SliderKnob
MUIA_Bitmap_Alpha | MUI_DeleteCustomClass | MUIV_Frame_String
MUIA_Bitmap_Bitmap | MUI_DisposeObject | MUIV_Frame_Text
MUIA_Bitmap_Height | MUI_EHF_ALWAYSKEYS | MUIV_Frame_Virtual
MUIA_Bitmap_MappingTable | MUIE_InvalidWindowObject | MUIV_Frame_Window
MUIA_Bitmap_Precision | MUIE_MissingLibrary | MUIV_Group_ActivePage_Advance
MUIA_Bitmap_RemappedBitmap | MUI_END | MUIV_Group_ActivePage_First
MUIA_Bitmap_SourceColors | MUI_EndRefresh | MUIV_Group_ActivePage_Last
MUIA_Bitmap_Transparent | MUIE_NoARexx | MUIV_Group_ActivePage_Next
MUIA_Bitmap_UseFriend | MUIE_OK | MUIV_Group_ActivePage_Prev
MUIA_Bitmap_Width | MUIE_OutOfGfxMemory | MUIV_Group_GetChild_First
MUIA_Bodychunk_Body | MUIE_OutOfMemory | MUIV_Group_GetChild_Iterate
MUIA_Bodychunk_Compression | MUI_Error | MUIV_Group_GetChild_Last
MUIA_Bodychunk_Depth | MUIE_SingleTask | MUIV_Group_GetChild_Next
MUIA_Bodychunk_Masking | MUI_EventHandlerRC_Eat | MUIV_Group_GetChild_Previous
MUIA_Boopsi_Class | MUI_FALSE | MUIV_Imageadjust_Type_All
MUIA_Boopsi_ClassID | MUI_FreeAslRequest | MUIV_Imageadjust_Type_Background
MUIA_Boopsi_MaxHeight | MUI_FreeClass | MUIV_Imageadjust_Type_Image
MUIA_Boopsi_MaxWidth | MUIget | MUIV_Imageadjust_Type_Pen
MUIA_Boopsi_MinHeight | MUI_GetClass | MUIV_InputMode_Immediate
MUIA_Boopsi_MinWidth | MUIGlobalInfo | MUIV_InputMode_None
MUIA_Boopsi_Object | MUII_ArrowDown | MUIV_InputMode_RelVerify
MUIA_Boopsi_Remember | MUII_ArrowLeft | MUIV_InputMode_Toggle
MUIA_Boopsi_Smart | MUII_ArrowRight | MUIV_List_Active_Bottom
MUIA_Boopsi_TagDrawInfo | MUII_ArrowUp | MUIV_List_Active_Down
MUIA_Boopsi_TagScreen | MUII_Assign | MUIV_List_Active_Off
MUIA_Boopsi_TagWindow | MUII_BACKGROUND | MUIV_List_Active_PageDown
MUIA_BottomEdge | MUII_BARBLOCK | MUIV_List_Active_PageUp
MUIA_Coloradjust_Blue | MUII_BARDETAIL | MUIV_List_Active_Top
MUIA_Coloradjust_Green | MUII_ButtonBack | MUIV_List_Active_Up
MUIA_Coloradjust_ModeID | MUII_CheckMark | MUIV_List_ConstructHook_String
MUIA_Coloradjust_Red | MUII_Chip | MUIV_List_CopyHook_String
MUIA_Coloradjust_RGB | MUII_Count | MUIV_List_CursorType_Bar
MUIA_Colorfield_Blue | MUII_Cycle | MUIV_List_CursorType_None
MUIA_Colorfield_Green | MUII_Disk | MUIV_List_CursorType_Rect
MUIA_Colorfield_Pen | MUII_Drawer | MUIV_List_DestructHook_String
MUIA_Colorfield_Red | MUII_FILL | MUIV_List_EditEntry_Active
MUIA_Colorfield_RGB | MUII_FILLBACK | MUIV_List_Exchange_Active
MUIA_ContextMenu | MUII_FILLBACK2 | MUIV_List_Exchange_Bottom
MUIA_ContextMenuTrigger | MUII_FILLSHINE | MUIV_List_Exchange_Next
MUIA_ControlChar | MUII_GaugeEmpty | MUIV_List_Exchange_Previous
MUIA_Cycle_Active | MUII_GaugeFull | MUIV_List_Exchange_Top
MUIA_CycleChain | MUII_GroupBack | MUIV_List_GetEntry_Active
MUIA_Cycle_Entries | MUII_HardDisk | MUIV_List_Insert_Active
MUIA_Dataspace_Pool | MUIIHNF_TIMER | MUIV_List_Insert_Bottom
MUI_AddClipping | MUII_HSHADOWBACK | MUIV_List_Insert_Sorted
MUI_AddClipRegion | MUII_HSHADOWSHADOW | MUIV_List_Insert_Top
MUIA_Dirlist_AcceptPattern | MUII_HSHINEBACK | MUIV_List_Jump_Active
MUIA_Dirlist_Directory | MUII_HSHINESHINE | MUIV_List_Jump_Bottom
MUIA_Dirlist_DrawersOnly | MUII_ImageButtonBack | MUIV_List_Jump_Down
MUIA_Dirlist_FilesOnly | MUII_ImageSelectedBack | MUIV_List_Jump_Top
MUIA_Dirlist_FilterDrawers | MUII_LASTPAT | MUIV_List_Jump_Up
MUIA_Dirlist_FilterHook | MUII_ListBack | MUIV_List_Move_Active
MUIA_Dirlist_MultiSelDirs | MUII_ListCursor | MUIV_List_Move_Bottom
MUIA_Dirlist_NumBytes | MUII_ListSelCur | MUIV_List_Move_Next
MUIA_Dirlist_NumDrawers | MUII_ListSelect | MUIV_List_Move_Previous
MUIA_Dirlist_NumFiles | MUIIMAGE | MUIV_List_Move_Top
MUIA_Dirlist_Path | MUII_MARKBACKGROUND | MUIV_List_NextSelected_End
MUIA_Dirlist_RejectIcons | MUII_MARKHALFSHINE | MUIV_List_NextSelected_Start
MUIA_Dirlist_RejectPattern | MUII_MARKSHINE | MUIV_List_Redraw_Active
MUIA_Dirlist_SortDirs | MUII_Menudisplay | MUIV_List_Redraw_All
MUIA_Dirlist_SortHighLow | MUII_Network | MUIV_List_Remove_Active
MUIA_Dirlist_SortType | MUII_PageBack | MUIV_List_Remove_First
MUIA_Dirlist_Status | MUII_PopDrawer | MUIV_List_Remove_Last
MUIA_Disabled | MUII_PopFile | MUIV_List_Remove_Selected
MUIA_DoubleBuffer | MUII_PopFont | MUIV_List_Select_Active
MUIA_Draggable | MUII_PopUp | MUIV_List_Select_All
MUIA_Dropable | MUII_PopupBack | MUIV_List_Select_Ask
MUIA_Dtpic_Name | MUII_PropBack | MUIV_List_Select_Off
MUIA_Family_Child | MUII_PropKnob | MUIV_List_Select_On
MUIA_Family_List | MUII_PullOpen | MUIV_List_Select_Toggle
MUIA_FillArea | MUII_RadioButton | MUIV_Listview_DragType_Immediate
MUIA_FixHeight | MUII_ReadListBack | MUIV_Listview_DragType_None
MUIA_FixHeightTxt | MUII_RegisterBack | MUIV_Listview_MultiSelect_Always
MUIA_FixWidth | MUII_RequesterBack | MUIV_Listview_MultiSelect_Default
MUIA_FixWidthTxt | MUII_SelectedBack | MUIV_Listview_MultiSelect_None
MUIA_Floattext_Justify | MUII_SHADOW | MUIV_Listview_MultiSelect_Shifted
MUIA_Floattext_SkipChars | MUII_SHADOWBACK | MUIV_Listview_ScrollerPos_Default
MUIA_Floattext_TabSize | MUII_SHADOWFILL | MUIV_Listview_ScrollerPos_Left
MUIA_Floattext_Text | MUII_SHADOWSHINE | MUIV_Listview_ScrollerPos_None
MUIA_Font | MUII_SHINE | MUIV_Listview_ScrollerPos_Right
MUIA_Frame | MUII_SHINEBACK | MUIV_Menuitem_Shortcut_Check
MUIA_FrameDynamic | MUII_SliderBack | MUIV_Notify_Application
MUIA_FramePhantomHoriz | MUII_SliderKnob | MUIV_Notify_Parent
MUIA_FrameTitle | MUII_StringActiveBack | MUIV_Notify_ParentParent
MUIA_FrameVisible | MUII_StringBack | MUIV_Notify_ParentParentParent
MUIA_Gadget_Gadget | MUII_TapeDown | MUIV_Notify_Self
MUIA_Gauge_Current | MUII_TapePause | MUIV_Notify_Window
MUIA_Gauge_Divide | MUII_TapePlay | MUIV_NotTriggerValue
MUIA_Gauge_Horiz | MUII_TapePlayBack | MUIV_Palette_Entry_End
MUIA_Gauge_InfoRate | MUII_TapeRecord | MUIV_Prop_UseWinBorder_Bottom
MUIA_Gauge_InfoText | MUII_TapeStop | MUIV_Prop_UseWinBorder_Left
MUIA_Gauge_Max | MUII_TapeUp | MUIV_Prop_UseWinBorder_None
MUIA_Group_ActivePage | MUII_TextBack | MUIV_Prop_UseWinBorder_Right
MUIA_Group_Child | MUII_Volume | MUIV_Scrollbar_Type_Bottom
MUIA_Group_ChildList | MUII_WindowBack | MUIV_Scrollbar_Type_Default
MUIA_Group_Columns | MUIKEY_BOTTOM | MUIV_Scrollbar_Type_Sym
MUIA_Group_Horiz | MUIKEY_COUNT | MUIV_Scrollbar_Type_Top
MUIA_Group_HorizSpacing | MUIKEY_DOWN | MUIV_String_Format_Center
MUIA_Group_LayoutHook | MUIKEYF_BOTTOM | MUIV_String_Format_Left
MUIA_Group_PageMode | MUIKEYF_DOWN | MUIV_String_Format_Right
MUIA_Group_Rows | MUIKEYF_GADGET_NEXT | MUIV_Text_Shorten_Cutoff
MUIA_Group_SameHeight | MUIKEYF_GADGET_OFF | MUIV_Text_Shorten_Hide
MUIA_Group_SameSize | MUIKEYF_GADGET_PREV | MUIV_Text_Shorten_Nothing
MUIA_Group_SameWidth | MUIKEYF_HELP | MUIV_TriggerValue
MUIA_Group_Spacing | MUIKEYF_LEFT | MUIV_Window_ActiveObject_Down
MUIA_Group_VertSpacing | MUIKEYF_LINEEND | MUIV_Window_ActiveObject_Left
MUIA_Height | MUIKEYF_LINESTART | MUIV_Window_ActiveObject_Next
MUIA_HelpLine | MUIKEYF_PAGEDOWN | MUIV_Window_ActiveObject_None
MUIA_HelpNode | MUIKEYF_PAGEUP | MUIV_Window_ActiveObject_Prev
MUIA_HorizDisappear | MUIKEYF_POPUP | MUIV_Window_ActiveObject_Right
MUIA_HorizWeight | MUIKEYF_PRESS | MUIV_Window_ActiveObject_Up
MUIA_Image_FontMatch | MUIKEYF_RIGHT | MUIV_Window_AltHeight_MinMax
MUIA_Image_FontMatchHeight | MUIKEYF_TOGGLE | MUIV_Window_AltHeight_Scaled
MUIA_Image_FontMatchWidth | MUIKEYF_TOP | MUIV_Window_AltHeight_Screen
MUIA_Image_FreeHoriz | MUIKEYF_UP | MUIV_Window_AltHeight_Visible
MUIA_Image_FreeVert | MUIKEYF_WINDOW_CLOSE | MUIV_Window_AltLeftEdge_Centered
MUIA_Image_OldImage | MUIKEYF_WINDOW_NEXT | MUIV_Window_AltLeftEdge_Moused
MUIA_Image_Spec | MUIKEYF_WINDOW_PREV | MUIV_Window_AltLeftEdge_NoChange
MUIA_Image_State | MUIKEYF_WORDLEFT | MUIV_Window_AltTopEdge_Centered
MUIA_InnerBottom | MUIKEYF_WORDRIGHT | MUIV_Window_AltTopEdge_Delta
MUIA_InnerLeft | MUIKEY_GADGET_NEXT | MUIV_Window_AltTopEdge_Moused
MUIA_InnerRight | MUIKEY_GADGET_OFF | MUIV_Window_AltTopEdge_NoChange
MUIA_InnerTop | MUIKEY_GADGET_PREV | MUIV_Window_AltWidth_MinMax
MUIA_InputMode | MUIKEY_HELP | MUIV_Window_AltWidth_Scaled
MUIA_LeftEdge | MUIKEY_LEFT | MUIV_Window_AltWidth_Screen
MUIA_Levelmeter_Label | MUIKEY_LINEEND | MUIV_Window_AltWidth_Visible
MUIA_List_Active | MUIKEY_LINESTART | MUIV_Window_Height_Default
MUIA_List_AdjustHeight | MUIKEY_NONE | MUIV_Window_Height_MinMax
MUIA_List_AdjustWidth | MUIKEY_PAGEDOWN | MUIV_Window_Height_Scaled
MUIA_List_AutoVisible | MUIKEY_PAGEUP | MUIV_Window_Height_Screen
MUIA_List_CompareHook | MUIKEY_POPUP | MUIV_Window_Height_Visible
MUIA_List_ConstructHook | MUIKEY_PRESS | MUIV_Window_LeftEdge_Centered
MUIA_List_DestructHook | MUIKEY_RELEASE | MUIV_Window_LeftEdge_Moused
MUIA_List_DisplayHook | MUIKEY_RIGHT | MUIV_Window_TopEdge_Centered
MUIA_List_DragSortable | MUIKEY_TOGGLE | MUIV_Window_TopEdge_Delta
MUIA_List_DropMark | MUIKEY_TOP | MUIV_Window_TopEdge_Moused
MUIA_List_Entries | MUIKEY_UP | MUIV_Window_Width_Default
MUIA_List_First | MUIKEY_WINDOW_CLOSE | MUIV_Window_Width_MinMax
MUIA_List_Format | MUIKEY_WINDOW_NEXT | MUIV_Window_Width_Scaled
MUIA_List_InsertPosition | MUIKEY_WINDOW_PREV | MUIV_Window_Width_Screen
MUIA_List_MinLineHeight | MUIKEY_WORDLEFT | MUIV_Window_Width_Visible
MUIA_List_MultiTestHook | MUIKEY_WORDRIGHT | MUIX_B
MUIA_List_Pool | MUI_Layout | MUIX_C
MUIA_List_PoolPuddleSize | MUILM_LAYOUT | MUIX_I
MUIA_List_PoolThreshSize | MUILM_MINMAX | MUIX_L
MUIA_List_Quiet | MUILM_UNKNOWN | MUIX_N
MUIA_List_ShowDropMarks | MUI_LPR_ABOVE | MUIX_PH
MUIA_List_SourceArray | MUI_LPR_BELOW | MUIX_PT
MUIA_List_Title | MUI_LPR_LEFT | MUIX_R
MUIA_Listview_ClickColumn | MUI_LPR_RIGHT | MUIX_U
MUIA_Listview_DefClickColumn | MUI_MakeObject | MULTIPLY_DIMENSIONS
MUIA_Listview_DoubleClick | MUI_MakeObjectA | MUSTDRAW
MUIA_Listview_DragType | MUIM_Application_AboutMUI | MVP_NO_DISPLAY
MUIA_Listview_Input | MUIM_Application_AddInputHandler | MVP_NO_DSPINS
MUIA_Listview_List | MUIM_Application_BuildSettingsPanel | MVP_NO_MEM
MUIA_Listview_MultiSelect | MUIM_Application_CheckRefresh | MVP_NO_VPE
MUIA_Listview_ScrollerPos | MUIM_Application_DefaultConfigItem | MVP_OFF_BOTTOM
MUIA_Listview_SelectChange | MUIM_Application_InputBuffered | MVP_OK
MUIA_List_Visible | MUIM_Application_Load | MX_HEIGHT
MUI_AllocAslRequest | MUIM_Application_NewInput | MXIDCMP
MUI_AllocAslRequestTags | MUIM_Application_OpenConfigWindow | MXIMAGE
MUIA_MaxHeight | MUIM_Application_PushMethod | MX_KIND
MUIA_MaxWidth | MUIM_Application_RemInputHandler | MX_WIDTH

N

NABC | NM_IGNORE | NP_StartupMsg
NABNC | NM_ITEM | NP_Synchronous
NamedObjectName | NM_ITEMDISABLED | NP_TaskMsgPort
NameFromFH | NML_CAS | NP_UserData
NameFromLock | NM_MENUDISABLED | NP_WindowPtr
NANBC | NM_SUB | NRB_MAGIC
NANBNC | NM_TITLE | NRB_NOTIFY_INITIAL
NBU_DUPLICATE | NM_WHEEL_DOWN | NRB_SEND_MESSAGE
NBU_NOTIFY | NM_WHEEL_LEFT | NRB_SEND_SIGNAL
NBU_UNIQUE | NM_WHEEL_RIGHT | NRB_WAIT_REPLY
NB_VERSION | NM_WHEEL_UP | NRF_MAGIC
NewCreateLibrary | NOCROSSFILL | NRF_NOTIFY_INITIAL
NewCreateLibraryTags | NO_ICON_POSITION | NRF_SEND_MESSAGE
NewCreateTask | NOISYREQ | NRF_SEND_SIGNAL
NewCreateTaskA | NOITEM | NRF_WAIT_REPLY
NEW_DATABASE | NOMENU | NR_HANDLER_FLAGS
NewDiskObject | NOREQBACKFILL | NSB_CASE
NewDTObject | NOSTR | NSB_NODUPS
NewDTObjectA | NOSUB | NS_EXTENDED
NewFontContents | NOTIFY_CLASS | NSF_CASE
NewGetSystemAttrs | NOTIFY_CODE | NSF_NODUPS
NewGetSystemAttrsA | NP_Arguments | NT_BOOTNODE
NewGetTaskAttrs | NP_Cli | NT_DEATHMESSAGE
NewGetTaskAttrsA | NP_CloseError | NT_DEVICE
NewGetTaskPIDAttrs | NP_CloseInput | NT_EXTENDED
NewGetTaskPIDAttrsA | NP_CloseOutput | NT_FONT
NewLayerInfo | NP_CodeType | NT_FREEMSG
NEWLAYERINFO_CALLED | NP_CommandName | NT_GRAPHICS
NewLoadSeg | NP_ConsoleTask | NT_INTERRUPT
NewLoadSegTagList | NP_CopyVars | NT_KICKMEM
NewModifyProp | NP_CurrentDir | NT_LIBRARY
NewObject | NP_Dummy | NT_MEMORY
NewObjectA | NP_Entry | NT_MESSAGE
NewPPCStackSwap | NP_Error | NT_MSGPORT
NewReadLink | NP_ExitCode | NT_PROCESS
NewRegion | NP_ExitData | N_TRACTOR
NewScaledDiskFont | NP_FreeSeglist | NT_REPLYMSG
NewSetFunction | NP_HomeDir | NT_RESOURCE
NewSetSystemAttrs | NP_Input | NTSC
NewSetSystemAttrsA | NP_Name | NTSC_MONITOR_ID
NewSetTaskAttrs | NP_NotifyOnDeath | NTSC_MONITOR_NAME
NewSetTaskAttrsA | NP_Output | NT_SEMAPHORE
NewSetTaskPIDAttrs | NP_Path | NT_SIGNALSEM
NewSetTaskPIDAttrsA | NP_PPC_Arg1 | NT_SOFTINT
NextDisplayInfo | NP_PPC_Arg2 | NT_TASK
NextDosEntry | NP_PPC_Arg3 | NT_UNKNOWN
NextObject | NP_PPC_Arg4 | NT_USER
NextPubScreen | NP_PPC_Arg5 | Null_IX
NextTagItem | NP_PPC_Arg6 | NUMBERIDCMP
NG_HIGHLABEL | NP_PPC_Arg7 | NUMBER_KIND
NM_BARLABEL | NP_PPC_Arg8 | NUMDRIPENS
NM_BUTTON_FOURTH | NP_PPCStackSize | NUM_KINDS
NM_COMMANDSTRING | NP_Priority | NWAYIDCMP
NM_END | NP_Seglist | NWAY_KIND
NM_FLAGMASK | NP_SeglistArray | _OBJ
NM_FLAGMASK_V39 | NP_StackSize |

O

OBJ_AddLeft | OM_DISPOSE | OT_FileIdent
OBJ_AddTop | OM_Dummy | OT_GlyphCode
OBJ_App | OM_GET | OT_GlyphCode2
OBJ_Between | OM_NEW | OT_GlyphMap
OBJ_Bottom | OM_NOTIFY | OT_GlyphMap8Bits
OBJ_DefHeight | OM_REMMEMBER | OT_GlyphWidth
OBJ_DefWidth | OM_REMOVE | OTH_Compressed
OBJ_Dri | OM_SET | OTH_Condensed
__OBJECT | OM_UPDATE | OTH_Expanded
LongWord | ON_DISPLAY | OTH_ExtraCompressed
OBJ_Flags | ONEDOT | OTH_ExtraExpanded
OBJ_Font | ONE_DOT | OTH_Normal
OBJ_Height | OnGadget | OT_HorizStyle
OBJ_IsInObject | OnMenu | OTH_SemiExpanded
OBJ_Left | ON_SPRITE | OTH_UltraCompressed
OBJ_MaxHeight | ON_VBLANK | OT_IName
OBJ_MaxWidth | OpenCatalog | OT_Indirect
OBJ_MBottom | OpenCatalogA | OT_InhibitAlgoStyle
OBJ_MHeight | OpenClipboard | OT_IsFixed
OBJ_MinHeight | OpenDevice | OT_Level0
OBJ_MinWidth | OpenDiskFont | OT_Level1
OBJ_MLeft | OpenFont | OT_Level2
OBJ_MRight | OpenFontTagList | OT_Level3
OBJ_MTop | OpenFontTags | OT_MAXAVAILSIZES
OBJ_MWidth | OpenFromLock | OT_OTagList
OBJ_Pens | OpenIFF | OT_OTagPath
OBJ_Right | OpenIntuition | OT_PointHeight
OBJ_Rp | OpenLibrary | OT_PointSize
OBJ_Screen | OpenLocale | OT_RName
OBJ_SubHeight | OpenMonitor | OT_RotateCos
OBJ_SubWidth | OPENQUOTE | OT_RotateSin
OBJ_Top | OpenResource | OTS_Black
OBJ_Width | OpenScreen | OTS_Bold
OBJ_Win | OpenScreenTagList | OTS_Book
OBJ_Window | OpenScreenTags | OTS_DemiBold
OBP_FailIfBad | OpenWindow | OTS_DemiLight
OBP_Precision | OpenWindowTagList | OT_SerifFlag
ObtainBestPen | OpenWindowTags | OT_SetFactor
ObtainBestPenA | OpenWorkBench | OTS_ExtraBlack
ObtainDataType | OpenWorkbenchObject | OTS_ExtraBold
ObtainDataTypeA | OpenWorkbenchObjectA | OTS_ExtraLight
ObtainDTDrawInfo | OPUF_INTERIM | OTS_ExtraThin
ObtainDTDrawInfoA | ORDERED_DITHERING | OTSF_AlgoBold
ObtainGIRPort | OrRectRegion | OTSF_AlgoItalic
ObtainPen | OrRegionRegion | OTSF_DesignedBold
ObtainQuickVector | OSCAN_MAX | OTSF_DesignedItalic
ObtainSemaphore | OSCAN_STANDARD | OT_ShearCos
ObtainSemaphoreList | OSCAN_TEXT | OT_ShearSin
ObtainSemaphoreShared | OSCAN_VIDEO | OTS_Italic
OC_BuiltInCodeSet | OSERR_ATTACHFAIL | OT_SlantStyle
OC_BuiltInLanguage | OSERR_NOCHIPMEM | OTS_LeftItalic
OC_BuiltInStrings | OSERR_NOCHIPS | OTS_Light
OC_CodeSet | OSERR_NOMEM | OTS_Medium
OC_Language | OSERR_NOMONITOR | OT_SpaceFactor
OCLASS | OSERR_NOTAVAILABLE | OT_SpaceWidth
OC_TagBase | OSERR_PUBNOTUNIQUE | OT_Spec
OCTANT1 | OSERR_TOODEEP | OT_Spec1
OCTANT2 | OSERR_UNKNOWNMODE | OT_SpecCount
OCTANT3 | OT_AvailSizes | OTS_SemiBold
OCTANT4 | OT_BIName | OTS_SemiLight
OCTANT5 | OT_BName | OT_StemWeight
OCTANT6 | OT_DesignKernPair | OTS_Thin
OCTANT7 | OT_DeviceDPI | OT_StrikeThrough
OCTANT8 | OT_DotSize | OT_StyleFlags
OC_Version | OTE_Bullet | OTSUFFIX
OFCH_ID | OT_EmboldenX | OTS_UltraBlack
OFF_DISPLAY | OT_EmboldenY | OTS_UltraThin
OffGadget | OT_Engine | OTS_Upright
OffMenu | OTERR_BadData | OT_SymbolSet
OFFSET_BEGINING | OTERR_BadFace | OT_TextKernPair
OFFSET_BEGINNING | OTERR_BadGlyph | OTUL_Broken
OFFSET_CURRENT | OTERR_BadTag | OTUL_DoubleBroken
OFFSET_END | OTERR_Failure | OTUL_DoubleSolid
OFF_SPRITE | OTERR_NoFace | OTUL_None
OFF_VBLANK | OTERR_NoGlyph | OTUL_Solid
OKABORT | OTERR_NoMemory | OT_UnderLined
OKCANCEL | OTERR_NoRotate | OT_WidthList
OKIMATE_20 | OTERR_NoShear | OT_YSizeFactor
OKOK | OTERR_Success | OUTL_DoubleBroken
OLDDRAWERDATAFILESIZE | OTERR_TooSmall | OUTSTEP
OldOpenLibrary | OTERR_UnknownGlyph | OVERLAY
OM_ADDMEMBER | OTERR_UnknownTag | OVFLAG
OM_ADDTAIL | OT_Family | OwnBlitter

P

PAChain | PGlyphWidthEntry | pMUIP_Window_ToFront
PackBoolTags | PgpDomain | pMUIP_WriteLong
PACK_ICON_ASPECT_RATIO | PgpGoInactive | pMUIP_WriteString
PackStructureTags | PgpHitTest | pMUI_RenderInfo
padtFrame | PgpInput | pMUI_RGBColor
PadtNewFormatFrame | PgpKeyGoInactive | pMUIS_InfoClient
padtStart | PgpKeyInput | PNamedObject
PAHIAudioCtrl | PgpKeyTest | PNameInfo
PAHIAudioModeRequester | PgpLayout | PNewBroker
PAHIDSPEcho | PgpRender | pNewGadget
PAHIEffChannelInfo | Pointer | pNewMenu
PAHIEffDSPMask | PHook | PNewScreen
PAHIEffMasterVolume | PIBox | PNewWindow
PAHIEffOutputBuffer | PICA | PNode
PAHIGlobalPrefs | PIClass | P_NOT
PAHIRecordMessage | PIconIdentifyMsg | P_NOTCLASS
PAHIRequest | PIconSelectMsg | P_NOTEND
PAHISampleInfo | PICTUREDTCLASS | PNotifyMessage
PAHISoundMessage | PID_CURRENT | PNotifyRequest
PAHIUnitPrefs | PIENewTablet | P_Object
PA_IGNORE | PIEPointerPixel | PObject_
PAL | PIEPointerTablet | POINTERA_BitMap
PALETTEIDCMP | pIFFHandle | POINTERA_Dummy
PALETTE_KIND | pIFFStreamCmd | POINTERA_WordWidth
PAL_MONITOR_ID | PImage | POINTERA_XOffset
PAL_MONITOR_NAME | PimpDomainFrame | POINTERA_XResolution
PAnalogSignalInterval | PimpDraw | POINTERA_YOffset
PAnchorPath | PimpErase | POINTERA_YResolution
PAnimComp | PimpFrameBox | POINTERCLASS
pAnimHeader | PimpHitTest | POINTERSIZE
PAnimOb | PInfoData | PointerType_2Plus1
P_ANY | PInputEvent | PointerType_3Plus1
PAppIcon | PInputXpression | POINTERTYPE_AIMING
PAppIconRenderMsg | PInterrupt | POINTERTYPE_ALTERNATIVECHOICE
PAppMenu | PIntuiMessage | PointerType_ARGB
PAppMenuItem | PIntuiText | POINTERTYPE_BUSY
PAppMessage | PIntuitionBase | POINTERTYPE_DIAGONALRESIZE1
PAppWindow | PIntVector | POINTERTYPE_DIAGONALRESIZE2
PAppWindowDropZone | pIOClipReq | POINTERTYPE_DOT
PAppWindowDropZoneMsg | PIOExtSer | POINTERTYPE_HANDWRITING
PAPTR | PIORequest | POINTERTYPE_HELP
PARALLEL_PRINTER | PIOStdReq | POINTERTYPE_HORIZONTALRESIZE
PAreaInfo | PIOTArray | POINTERTYPE_INVISIBLE
ParentChunk | PIsrvstr | POINTERTYPE_MOVE
ParentDir | PIX | POINTERTYPE_NORMAL
ParentOfFH | PIXEL_DIMENSIONS | POINTERTYPE_NOTAVAILABLE
ParseDate | PIXFMT_ARGB32 | POINTERTYPE_NUMTYPES
ParseIFF | PIXFMT_BGR15 | POINTERTYPE_SELECTLINK
ParseIX | PIXFMT_BGR15PC | POINTERTYPE_SELECTTEXT
ParsePattern | PIXFMT_BGR16 | POINTERTYPE_VERTICALRESIZE
ParsePatternNoCase | PIXFMT_BGR16PC | POINTERTYPE_WORKING
PA_SIGNAL | PIXFMT_BGR24 | POINTERXRESN_140NS
PAslSemaphore | PIXFMT_BGRA32 | POINTERXRESN_35NS
PA_SOFTINT | PIXFMT_LUT8 | POINTERXRESN_70NS
PAssignList | PIXFMT_RGB15 | POINTERXRESN_DEFAULT
PathPart | PIXFMT_RGB15PC | POINTERXRESN_HIRES
PAudChannel | PIXFMT_RGB15X | POINTERXRESN_LORES
PAvailFonts | PIXFMT_RGB16 | POINTERXRESN_SCREENRES
PAvailFontsHeader | PIXFMT_RGB16PC | POINTERYRESN_DEFAULT
PBitMap | PIXFMT_RGB24 | POINTERYRESN_HIGH
pBitMapHeader | PIXFMT_RGBA32 | POINTERYRESN_HIGHASPECT
PBitScaleArgs | PKCTRL_BIT | POINTERYRESN_SCREENRES
Pbltnode | PKCTRL_BYTE | POINTERYRESN_SCREENRESASPECT
PBob | PKCTRL_FLIPBIT | PointInImage
PBoolInfo | PKCTRL_LONG | POINTREL
PBorder | PKCTRL_PACKONLY | POldDrawerData
PBPAFMT_ARGB | PKCTRL_PACKUNPACK | PolyDraw
PBPAFMT_GREY8 | PKCTRL_UBYTE | PopAddMember
PBPAFMT_LUT8 | PKCTRL_ULONG | PopAddTail
PBPAFMT_RGB | PKCTRL_UNPACKONLY | POP_BLUR
PBPAFMT_RGBA | PKCTRL_UWORD | POP_BRIGHTEN
PBTDBoolean | PKCTRL_WORD | PopChunk
PBTDCycle | PKeyMap | POP_COLOR2GREY
PBTDDrawInfo | PKeymapNode | POP_DARKEN
PBTDFile | PKeyMapResource | PopGet
PBTDFont | PLACETEXT_ABOVE | POP_GRADIENT
PBTDInfo | PLACETEXT_BELOW | PopMember
PBTDInteger | PLACETEXT_IN | POP_NEGATIVE
PBTDNode | PLACETEXT_LEFT | POP_NEGFADE
PBTDString | PLACETEXT_RIGHT | POPPUBSCREEN
PCatalog | PLayer | PopSet
PCDrawMsg | PLayer_Info | POP_SETALPHA
PCIA | PLayer_Info | POP_SHIFTRGB
P_CLASS | PLibrary | POP_TINT
PClassLibrary | pLine | POP_TINTFADE
PCLIData | PList | PopUpdate
PCLIDataItem | PLNCNTMSK | POPUPIMAGE
pClipboardHandle | PLNCNTSHFT | P_OREND
pClipboardUnitPartial | pLocalContextItem | P_ORNEXT
pClipHookMsg | PLocale | P_ORSTART
PClipRect | PLocaleBase | PPaletteExtra
PCliProcList | PLocalVar | PPAnimOb
PClockData | PLONG | PPAOPTAG_FADEFULLSCALE
pCollectionItem | PLONGBITS | PPAOPTAG_FADEOFFSET
PCollTable | plongword | PPAOPTAG_GRADCOLOR1
PColorFontColors | pLVDrawMsg | PPAOPTAG_GRADCOLOR2
PColorMap | PMB_ASM | PPAOPTAG_GRADFULLSCALE
pColorRegister | PMB_AWM | PPAOPTAG_GRADIENTTYPE
PColorSpec | PMemChunk | PPAOPTAG_GRADOFFSET
PColorTextFont | PMemEntry | PPAOPTAG_GRADSYMCENTER
PCommandLineInterface | PMemHandlerData | PPAOPTAG_RGBMASK
pContextNode | PMemHeader | PPBTDNode
PConUnit | PMemList | PPGX
PCopInit | PMenu | PPObject_
PCopIns | PMenuItem | PPoint
PCopList | PMessage | PPPCStackSwapArgs
PCopyBeginMsg | PMinList | PPreferences
PCopyDataMsg | PMinNode | pprinterIO
PCopyEndMsg | PMODE_V42 | PProcess
PCprList | PMODE_V43 | PPropInfo
PCSource | PMonitorInfo | PPSimpleSprite
PCustom | PMonitorSpec | PPTagItem
PCXMsg | PMsg | PPubScreenNode
PCxObj | PmsGetDefaultGammaTables | PQueryHeader
PCyberModeNode | PmsGetDefaultPixelFormat | PRasInfo
pDataType | PmsGetPointerBounds | PRastPort
pDataTypeHeader | PmsGetRootBitMap | PRB_CLOSEERROR
PDateStamp | PMsgPort | PRB_CLOSEINPUT
_PDateTime | PmsQuery3DSupport | PRB_CLOSEOUTPUT
PDBufInfo | PmsSetDefaultGammaTables | PRB_FREEARGS
PDBufPacket | PM_STR | PRB_FREECLI
PDeleteBeginMsg | pMUI_AreaData | PRB_FREECURRDIR
PDeleteDataMsg | pMUI_BoopsiQuery | PRB_FREESEGLIST
PDeleteEndMsg | pMUI_Command | PRDArgs
PDevice | pMUI_CustomClass | PRECISION_EXACT
PDeviceList | pMUI_EventHandlerNode | PRECISION_GUI
PDeviceNode | pMUI_GlobalInfo | PRECISION_ICON
PDevInfo | pMUI_InputHandlerNode | PRECISION_IMAGE
PDevProc | pMUI_LayoutMsg | PRecordLock
PDimensionInfo | pMUI_List_TestPos_Result | PRecordLock64
PDiskFontHeader | pMUI_MinMax | PRect32
PDiskObject | pMUI_NotifyData | PRectangle
PDisplayInfo | pMUI_Palette_Entry | PREDRAWN
PDisplayMode | pMUIP_Application_AboutMUI | PRegion
PDosAttrBuffer | pMUIP_Application_AddInputHandler | PRegionRectangle
PDosEnvec | pMUIP_Application_BuildSettingsPanel | PRemember
PDOSInfo | pMUIP_Application_CheckRefresh | P_REPBEG
PDOSLibrary | pMUIP_Application_DefaultConfigItem | P_REPEND
PDOSList | pMUIP_Application_GetMenuCheck | PRequester
PDOSPacket | pMUIP_Application_GetMenuState | PRESERVE_COLORS
PDrawerData | pMUIP_Application_Input | PResident
PDrawInfo | pMUIP_Application_InputBuffered | PRF_CLOSEERROR
PDTA_Allocated | pMUIP_Application_NewInput | PRF_CLOSEINPUT
PDTA_AllocatedPens | pMUIP_Application_OpenConfigWindow | PRF_CLOSEOUTPUT
PDTA_BitMap | pMUIP_Application_PushMethod | PRF_FREEARGS
PDTA_BitMapHeader | pMUIP_Application_RemInputHandler | PRF_FREECLI
PDTA_ClassBitMap | pMUIP_Application_ReturnID | PRF_FREECURRDIR
PDTA_ColorRegisters | pMUIP_Application_SetConfigItem | PRF_FREESEGLIST
PDTA_ColorTable | pMUIP_Application_SetMenuCheck | PRIMARY_CLIP
PDTA_ColorTable2 | pMUIP_Application_SetMenuState | PrintDTObjectA
PDTA_CRegs | pMUIP_Application_ShowHelp | PrintFault
PDTA_DestBitMap | pMUIP_AskMinMax | PrintIText
PDTA_DestMode | pMUIP_CallHook | ProcessPixelArray
PDTA_Displayable | pMUIP_Cleanup | Procure
PDTA_DitherQuality | pMUIP_ContextMenuAdd | PRootNode
PDTA_FreeSourceBitMap | pMUIP_ContextMenuBuild | PROPBORDERLESS
PDTA_GetNumPictures | pMUIP_ContextMenuChoice | PropChunk
PDTA_Grab | pMUIP_CreateBubble | PropChunks
PDTA_GRegs | pMUIP_CreateShortHelp | PROPGCLASS
PDTA_MaskPlane | pMUIP_Dataspace_Add | PROPNEWLOOK
PDTA_MaxDitherPens | pMUIP_Dataspace_Clear | PROTO_MONITOR_ID
PDTA_ModeID | pMUIP_Dataspace_Find | pSatisfyMsg
PDTA_NumAlloc | pMUIP_Dataspace_Merge | PScreen
PDTA_NumColors | pMUIP_Dataspace_ReadIFF | PScreenBuffer
PDTANUMPICTURES_Unknown | pMUIP_Dataspace_Remove | PScreenModeRequester
PDTA_NumSparse | pMUIP_Dataspace_WriteIFF | PSD_FILENAME_SAVE
PDTA_Remap | pMUIP_DeleteBubble | PSD_FILENAME_USE
PDTA_ScaleQuality | pMUIP_DeleteShortHelp | PSD_INITIAL_NAME
PDTA_Screen | pMUIP_DoDrag | PSD_INITIAL_TITLE
PDTA_SourceMode | pMUIP_DragBegin | PSD_MAXLEN_BACKGROUND
PDTA_SparseTable | pMUIP_DragDrop | PSD_MAXLEN_FONT
PDTA_UseFriendBitMap | pMUIP_DragFinish | PSD_MAXLEN_NAME
PDTA_WhichPicture | pMUIP_DragQuery | PSD_MAXLEN_TITLE
pdtDraw | pMUIP_DragReport | PSD_MAXMUIPENS
pdtFrameBox | pMUIP_Draw | PSD_MAXSYSPENS
pdtGeneral | pMUIP_DrawBackground | PSD_NAME_FRONTMOST
pdtGoto | pMUI_PenSpec | PSD_NUMCOLS
pDTHookContext | pMUIP_Export | PSD_NUMMUIPENS
PDTM_Dummy | pMUIP_Family_AddHead | PSD_NUMSYSPENS
pDTMethod | pMUIP_Family_AddTail | PSegArray
PDTM_READPIXELARRAY | pMUIP_Family_Insert | PSegment
PDTM_WRITEPIXELARRAY | pMUIP_Family_Remove | PSegNode
pdtPrint | pMUIP_Family_Sort | PSegSem
PdtReleaseDrawInfo | pMUIP_Family_Transfer | PSemaphoreMessage
pdtSelect | pMUIP_FindUData | PSemaphoreRequest
pDTSpecialInfo | pMUIP_GetConfigItem | PSetupCleanupHookMsg
pdtTrigger | pMUIP_GetUData | PSGWork
pdtWrite | pMUIP_Group_ExitChange | PSignalSemaphore
p__dummyXFC2__ | pMUIP_Group_InitChange | PSimpleSprite
PEasyStruct | pMUIP_Group_Sort | P_SINGLE
PEClockVal | pMUIP_HandleEvent | PSNF_PRIVATE
PeekQualifier | pMUIP_HandleInput | PSoftIntList
PEmulHandle | pMUIP_Hide | PSpecialMonitor
PEmulLibEntry | pMUIP_Import | Psposition
PENB_EXCLUSIVE | pMUIP_KillNotify | PSpriteDef
PENB_NO_SETCOLOR | pMUIP_KillNotifyObj | PStackSwapStruct
PEN_C0 | pMUIP_List_Clear | PStandardPacket
PEN_C1 | pMUIP_List_CreateImage | PSTB_EXISTS
PEN_C2 | pMUIP_List_DeleteImage | PSTB_PACK
PEN_C3 | pMUIP_List_Exchange | PSTB_SIGNED
PEN_EXCLUSIVE | pMUIP_List_GetEntry | PSTB_UNPACK
PENF_EXCLUSIVE | pMUIP_List_Insert | PSTF_EXISTS
PENF_NO_SETCOLOR | pMUIP_List_InsertSingle | PSTF_PACK
PEN_NO_SETCOLOR | pMUIP_List_Jump | PSTF_SIGNED
PENSHARED | pMUIP_List_Move | PSTF_UNPACK
Permit | pMUIP_List_NextSelected | P_STOP
PErrorString | pMUIP_List_Redraw | pStoredProperty
PETask | pMUIP_List_Remove | PStringExtend
PExAllControl | pMUIP_List_Select | PStringInfo
PExAllData | pMUIP_List_Sort | PTabletData
PExecBase | pMUIP_List_TestPos | PTabletHookData
PExecNotifyMessage | pMUIP_Menustrip_ExitChange | PTag
PExtEasyStruct | pMUIP_Menustrip_InitChange | Pointer
PExtendedKeyMapNode | pMUIP_MultiSet | PTagItem
PExtendedNode | pMUIP_NoNotifySet | PTask
PExtGadget | pMUIP_Notify | PTaskFrame68k
PExtIntuiMessage | pMUIP_Numeric_Decrease | PTaskInitExtension
PExtNewScreen | pMUIP_Numeric_Increase | PTaskTrapMessage
PExtNewWindow | pMUIP_Numeric_ScaleToValue | PTaskTrapMessage_68k
PExtSprite | pMUIP_Numeric_SetDefault | PTAvailFonts
PF2PRI | pMUIP_Numeric_Stringify | PTextAttr
PF_ACTION | pMUIP_Numeric_ValueToScale | PTextExtent
PFA_FINE_SCROLL | pMUIP_Popstring_Close | PTextFont
PFBA | pMUIP_Popstring_Open | PTextFontExtension
PFB_FINE_SCROLL_SHIFT | pMUIP_Prop_Decrease | PTextInputMsg
PF_FINE_SCROLL_MASK | pMUIP_Prop_Increase | PTFontContents
PFileHandle | PMUIP_Screenbar_BuildSettingsPanel | PTimeRequest
PFileInfoBlock | PMUIP_Screenbar_DefaultConfigItem | PTimeVal
PFileLock | PMUIP_Screenbar_KnowsConfigItem | PTmpRas
PFileRequester | PMUIP_Screenbar_Lock | pTool
PFileSysStartupMsg | PMUIP_Screenbar_Signal | pToolNode
PFixed | PMUIP_Screenbar_Unlock | PTransparencyMessage
PFontContents | pMUIP_Semaphore_Attempt | PTTextAttr
PFontContentsHeader | pMUIP_Semaphore_AttemptShared | PUBLICSCREEN_f
PFontRequester | pMUIP_Semaphore_Obtain | PubScreenStatus
pFrameInfo | pMUIP_Semaphore_ObtainShared | PUCopList
PFreeBlocksData | pMUIP_Semaphore_Release | PUCS4_CharsetCode
PFreeList | pMUIP_Set | PUCS4_CharsetConvTable
PFuncEntry | pMUIP_SetAsString | PUCS4_ConvTable
PFuncOldEntry | pMUIP_Settingsgroup_ConfigToGadgets | PULONG
PGA_Borderless | pMUIP_Settingsgroup_GadgetsToConfig | PUnit
PGadget | pMUIP_SetUData | PushChunk
PGadgetInfo | pMUIP_SetUDataOnce | PutDefDiskObject
PGA_Dummy | pMUIP_Setup | PutDiskObject
PGA_Freedom | pMUIP_Show | PutIconTagList
PGA_HorizBody | pMUI_PubScreenDesc | PUtilityBase
PGA_HorizPot | PMUIP_UpdateConfig | PutMsg
PGA_NewLook | pMUIP_UpdateConfig | PutMsgHead
PGA_NotifyBehaviour | pMUIP_Window_AddEventHandler | PutStr
PGA_RenderBehaviour | pMUIP_Window_Cleanup | PVecInfo
PGA_Top | pMUIP_Window_GetMenuCheck | PView
PGA_Total | pMUIP_Window_GetMenuState | PViewExtra
PGA_VertBody | pMUIP_Window_RemEventHandler | PViewPort
PGA_VertPot | pMUIP_Window_ScreenToBack | PViewPortExtra
PGA_Visible | pMUIP_Window_ScreenToFront | PVLayerHandle
PG_BEHAVIOUR_COMPATIBLE | pMUIP_Window_SetCycleChain | pVoiceHeader
PG_BEHAVIOUR_NICE | pMUIP_Window_SetMenuCheck | PVSprite
PGelsInfo | pMUIP_Window_SetMenuState | PWBArg
PGfxBase | pMUIP_Window_Setup | PWBArgList
PGlyphEngine | pMUIP_Window_Snapshot | PWBStartup
PGlyphMap | pMUIP_Window_ToBack | PWindow

Q

QBlit | QueryCLIDataTags | QUME_LP_20
QBSBlit | QueryOverscan |
QueryCLIDataTagList | QueryVLayerAttr |

R

RasSize | regA7 | REPORT_INSERT
RATIO_FIXEDPART | REG_A7 | REPORT_LOCK
RATIO_UNITY | regD0 | ReportMouse
RawDoFmt | REG_D0 | REPORT_STREAM
RAWFMTFUNC_COUNT | regD1 | REPORT_TASK
RAWFMTFUNC_SERIAL | REG_D1 | REPORT_VOLUME
RAWFMTFUNC_STRING | regD2 | REQACTIVE
RawIOInit | REG_D2 | REQOFFWINDOW
RawKeyConvert | regD3 | Request
RawMayGetChar | REG_D3 | REQUEST_A2024
RawPutChar | regD4 | RequestFile
RDAB_NOALLOC | REG_D4 | REQUEST_NTSC
RDAB_NOPROMPT | regD5 | REQUEST_PAL
RDAB_STDIN | REG_D5 | REQUEST_SPECIAL
RDAF_NOALLOC | regD6 | RESCOUNT
RDAF_NOPROMPT | REG_D6 | ResetMenuStrip
RDAF_STDIN | regD7 | RethinkDisplay
ReadArgs | REG_D7 | RETURN_ERROR
ReadChar | regPC | RETURN_FAIL
ReadChars | REG_PC | RETURN_OK
ReadChunkBytes | regSR | RETURN_WARN
ReadChunkRecords | REG_SR | RGBSHIFT_BGR
ReadEClock | Relabel | RGBSHIFT_BRG
ReadGayle | ReleaseCLINumber | RGBSHIFT_GBR
ReadItem | ReleaseDataType | RGBSHIFT_GRB
ReadLink | ReleaseDTDrawInfo | RGBSHIFT_RBG
ReadPixel | ReleaseGIRPort | RIGHTHIT
ReadPixelArray | ReleaseNamedObject | RIGHTIMAGE
ReadPixelArray8 | ReleasePen | RINGTRIGGER
ReadPixelLine8 | ReleaseSemaphore | RI_VERSION
ReadRGBPixel | ReleaseSemaphoreList | RNB_PRIVATE1
REALLY_PAL | RemakeDisplay | RNB_WILDSTAR
REC_EXCLUSIVE | RemAssignList | RNF_PRIVATE1
REC_EXCLUSIVE_IMMED | RemDevice | RNF_WILDSTAR
RECOVERY_ALERT | RemDosEntry | ROOTCLASS
REC_SHARED | RemExecNotify | RouteCxMsg
REC_SHARED_IMMED | RemFont | RPTAG_AlphaMode
RectFill | RemHead | RPTAG_APen
RECTFMT_ARGB | RemIBob | RPTAG_BgColor
RECTFMT_GREY8 | RemIntServer | RPTAG_BPen
RECTFMT_LUT8 | RemLibrary | RPTAG_DrawBounds
RECTFMT_RAW | RemMemHandler | RPTAG_DrMd
RECTFMT_RGB | RemNamedObject | RPTAG_FgColor
RECTFMT_RGBA | Remove | RPTAG_Font
RefreshDTObject | RemoveAppIcon | RPTAG_MaxPen
RefreshDTObjectA | RemoveAppMenuItem | RPTAG_OutlinePen
RefreshGadgets | RemoveAppWindow | RPTAG_PenMode
RefreshGList | RemoveAppWindowDropZone | RPTAG_RetainAlpha
RefreshTagItemClones | RemoveClass | RPTAG_WriteMask
RefreshWindowFrame | RemoveCxObj | RPTAG_XPos
regA0 | RemoveDTObject | RPTAG_YPos
REG_A0 | RemoveGadget | RTC_MATCHWORD
regA1 | RemoveGList | RTF_AFTERDOS
REG_A1 | RemPort | RTF_AUTOINIT
regA2 | RemResource | RTF_COLDSTART
REG_A2 | RemSegment | RTF_EXTENDED
regA3 | RemSemaphore | RTF_PPC
REG_A3 | RemTail | RTF_SINGLETASK
regA4 | RemTask | RTW_COLDSTART
REG_A4 | RemVSprite | RTW_NEVER
regA5 | RenderLayerInfoTagList | RunCommand
REG_A5 | RenderLayerInfoTags | RUN_EXECUTE
regA6 | ReplyMsg | RUN_SYSTEM
REG_A6 | ReplyPkt | RUN_SYSTEM_ASYNCH

S

SA_3DSupport | SetDTAttrsA | SP_SUCC_CURR
SA_AdaptSize | SetEditHook | SRCA
SA_AutoScroll | SetExcept | SRCB
SA_BackChild | SetFileDate | SRCC
SA_BackFill | SetFileSize | SRCFMT_R5G5B5PC
SA_Behind | SetFileSize64 | SRCFMT_R5G6B5PC
SA_BitMap | SetFileSysTask | SRCFMT_RGB15
SA_BlockPen | SetFilter | SRCFMT_RGB16
SA_BottomLeftScreen | SetFilterIX | SRCFMT_YCbCr16
SA_BottomMiddleScreen | SetFont | SRCFMT_YCbCr420
SA_BottomRightScreen | SETFUNCTAG_DELETE | SRCFMT_YUV16
SA_ColorMapEntries | SETFUNCTAG_Dummy | SREAD_BITS
SA_Colors | SETFUNCTAG_IDNAME | SS_GRAPHICS
SA_Colors32 | SETFUNCTAG_MACHINE | SS_NOSPACE
SA_CompositingLayers | SETFUNCTAG_TYPE | SS_SPACE
SA_DClip | SetFunction | SSTOP_BITS
SA_Depth | SETFUNCTYPE_NORMAL | StackSwap
SA_DetailPen | SETFUNCTYPE_NORMALD0_D1 | STANDARD_COLORCLOCKS
SA_Displayed | SETFUNCTYPE_NORMALD0D1A0A1SR | STANDARD_DENISE_MAX
SA_DisplayHeight | SETFUNCTYPE_NORMALD0D1SR | STANDARD_DENISE_MIN
SA_DisplayID | SETFUNCTYPE_NORMALNR | STANDARD_HBSTOP
SA_DisplayWidth | SETFUNCTYPE_NORMALRESTORE | STANDARD_HBSTRT
SA_Draggable | SETFUNCTYPE_NORMALSR | STANDARD_HSSTOP
SA_Dummy | SETFUNCTYPE_NORMALSRNR | STANDARD_HSSTRT
SA_ErrorCode | SETFUNCTYPE_QUICK | STANDARD_MONITOR_MASK
SA_ExactMatchMonitorName | SETFUNCTYPE_QUICKNR | STANDARD_NTSC_BEAMCON
SA_Exclusive | SETFUNCTYPE_SYSTEMV | STANDARD_NTSC_ROWS
SafeSetOutlinePen | SetGadgetAttrs | STANDARD_PAL_BEAMCON
SafeSetWriteMask | SetGadgetAttrsA | STANDARD_PAL_ROWS
SA_Font | SetIntVector | STANDARD_VBSTOP
SA_FrontChild | SetIoErr | STANDARD_VBSTRT
SA_FullPalette | SetKeyMapDefault | STANDARD_VIEW_X
SA_GammaBlue | SetLocalItemPurge | STANDARD_VIEW_Y
SA_GammaControl | SetMaxPen | STANDARD_VSSTOP
SA_GammaGreen | SetMenuStrip | STANDARD_VSSTRT
SA_GammaRed | SetMode | STANDARD_XOFFSET
SA_Height | SetMouseQueue | STANDARD_YOFFSET
SA_Interleaved | SetOPen | StartDragSelect
SAL_Dummy | SetOutlinePen | StartNotify
SA_Left | SetOwner | STDSCREENHEIGHT
SA_LikeWorkbench | SetPointer | STDSCREENWIDTH
SAL_Name | SetPrefs | ST_FILE
SAL_Priority | SetProgramDir | ST_LINKDIR
SAL_Type | SetProgramName | ST_LINKFILE
SameDevice | SetPrompt | STM_ACTIVATE_FIELD
SameLock | SetProtection | STM_BROWSE_NEXT
SA_MiddleLeftScreen | SetPubScreenModes | STM_BROWSE_PREV
SA_MiddleRightScreen | SetRast | STM_COMMAND
SA_MinimizeISG | SetRGB32 | STM_CONTENTS
SA_MonitorName | SetRGB32CM | STM_FASTFORWARD
SA_MonitorObject | SetRGB4 | STM_INDEX
SAMPLETYPE_Left | SetRGB4CM | STM_LOCATE
SAMPLETYPE_Right | SetRPAttrs | STM_NEXT_FIELD
SAMPLETYPE_Stereo | SetRPAttrsA | STM_PAUSE
SA_OpacitySupport | SetSignal | STM_PLAY
SAOS_OpacitySupport_CPU | SetSoftStyle | STM_PREV_FIELD
SAOS_OpacitySupport_HW | SetSR | STM_RESUME
SAOS_OpacitySupport_None | SetTaskPri | STM_RETRACE
SAOS_OpacitySupport_OnOff | SetTranslate | STM_REWIND
SA_Overscan | SetVar | STM_STOP
SA_Parent | SetVBuf | StopChunk
SA_Pens | SETVC_DPMSLevel | StopChunks
SA_PixelFormat | SetVLayerAttrTagList | StopOnExit
SA_PubName | SetWindowPointer | StoreItemInContext
SA_PubSig | SetWindowPointerA | StoreLocalItem
SA_PubTask | SetWindowTitles | ST_PIPEFILE
SA_Quiet | SetWriteMask | StraightCopy
SA_Reserved | SetWrMsk | StrConvert
SASA_SourceAlphaSupport_CPU | SEXTB_MARK | STRGCLASS
SASA_SourceAlphaSupport_HW | SEXTB_MSPON | Stricmp
SASA_SourceAlphaSupport_None | SEXTF_MARK | STRINGA_ActivePens
SA_ScreenbarSignal | SEXTF_MSPON | STRINGA_AltKeyMap
SA_ScreenbarTextFont | SF_SAR | STRINGA_Buffer
SA_ScreenbarTextPen | SF_SINT | STRINGA_BufferPos
SA_ScreenbarTextYPos | SF_TQE | STRINGA_DispPos
SA_SharePens | SGA_BEEP | STRINGA_Dummy
SA_ShowPointer | SGA_END | STRINGA_EditHook
SA_ShowTitle | SGA_NEXTACTIVE | STRINGA_EditModes
SA_SourceAlphaSupport | SGA_PREVACTIVE | STRINGA_ExitHelp
SA_StopBlanker | SGA_REDISPLAY | STRINGA_FixedFieldMode
SA_SysFont | SGA_REUSE | STRINGA_Font
SA_Title | SGA_USE | STRINGA_Justification
SA_Top | SG_DEFAULTMAXCHARS | STRINGA_LongVal
SA_TopLeftScreen | SGH_CLICK | STRINGA_MaxChars
SA_TopMiddleScreen | SGH_KEY | STRINGA_NoFilterMode
SA_TopRightScreen | SGM_CONTROL | STRINGA_Pens
SA_Type | SGM_EXITHELP | STRINGA_ReplaceMode
SAVEBACK | SGM_FIXEDFIELD | STRINGA_TextVal
SAVEBOB | SGM_LONGINT | STRINGA_UndoBuffer
SaveDTObject | SGM_NOCHANGE | STRINGA_WorkBuffer
SaveDTObjectA | SGM_NOFILTER | STRINGIDCMP
SAVEPRESERVE | SGM_NOWORKB | STRING_KIND
SA_VideoControl | SGM_REPLACE | StripFont
SA_Width | SGR_BLACK | StrnCmp
SB_COPY_BITMAP | SGR_BLACKBG | Strnicmp
SBCT_Dummy | SGR_BLUE | ST_ROOT
SBCT_InstallPlugin | SGR_BLUEBG | PChar
SBCT_UninstallPlugin | SGR_BOLD | StrToLong
SB_SAR | SGR_CLR0 | ST_SOFTLINK
SB_SCREEN_BITMAP | SGR_CLR0BG | ST_USERDIR
SB_SINT | SGR_CLR1 | SUBMENUIMAGE
SB_TQE | SGR_CLR1BG | SUBNUM
SBUF_1024 | SGR_CLR2 | SubTime
SBUF_16000 | SGR_CLR2BG | SUD
SBUF_2048 | SGR_CLR3 | SUL
SBUF_4096 | SGR_CLR3BG | SumKickData
SBUF_512 | SGR_CLR4 | SumLibrary
SBUF_8000 | SGR_CLR4BG | SUPER72HIRESDBL_KEY
SBUFSIZE_BITS | SGR_CLR5 | SUPER72HIRESEHBDBL_KEY
ScalePixelArray | SGR_CLR5BG | SUPER72HIRESHAMDBL_KEY
ScalePixelArrayAlpha | SGR_CLR6 | SUPER72LORESDBL_KEY
ScalerDiv | SGR_CLR6BG | SUPER72LORESEHBDBL_KEY
SC_ASCII | SGR_CLR7 | SUPER72LORESHAMDBL_KEY
SC_COLLATE1 | SGR_CLR7BG | SUPER72_MONITOR_ID
SC_COLLATE2 | SGR_CYAN | SUPER72SUPERDBL_KEY
SCHMSTATE_Cleanup | SGR_CYANBG | SUPER72SUPEREHBDBL_KEY
SCHMSTATE_Setup | SGR_DEFAULT | SUPER72SUPERHAMDBL_KEY
SCHMSTATE_TryCleanup | SGR_DEFAULTBG | SUPERDPF2_KEY
ScreenbarControl | SGR_GREEN | SUPERDPF_KEY
ScreenbarControlA | SGR_GREENBG | SUPEREHB_KEY
SCREENBEHIND_f | SGR_ITALIC | SUPEREHBLACE_KEY
ScreenDepth | SGR_MAGENTA | SUPERHAM_KEY
SCREEN_DRAG | SGR_MAGENTABG | SUPERHAMLACE_KEY
SCREENHIRES | SGR_NEGATIVE | SUPERHIRES
ScreenPosition | SGR_NORMAL | SUPER_KEY
SCREENQUIET_f | SGR_NOTITALIC | SUPERLACEDPF2_KEY
ScreenToBack | SGR_NOTUNDERSCORE | SUPERLACEDPF_KEY
ScreenToFront | SGR_POSITIVE | SUPERLACE_KEY
SCREENTYPE_f | SGR_PRIMARY | SuperState
SCROLLERIDCMP | SGR_RED | Supervisor
SCROLLER_KIND | SGR_REDBG | SUPFRONTGADGET
ScrollLayer | SGR_UNDERSCORE | SUSERFLAGS
ScrollRaster | SGR_WHITE | SwapBitsRastPortClipRect
ScrollRasterBF | SGR_WHITEBG | SwapVLayerBuffer
ScrollVPort | SGR_YELLOW | SWRITE_BITS
ScrollWindowRaster | SGR_YELLOWBG | SyncSBitMap
ScrollWindowRasterNoFill | SHADE_BW | SYS_Asynch
SC_UNICODE | SHADE_COLOR | SYS_CustomShell
SDCMD_BREAK | SHADE_GREYSCALE | SYS_Dummy
SDCMD_QUERY | SHADOWPEN | SYS_FilterTags
SDCMD_SETPARAMS | SHANGHAI | SYSIA_Depth
SDEPTHIMAGE | SHARED_LOCK | SYSIA_DrawInfo
SDEPTH_TOBACK | SHIFTITEM | SYSIA_Pens
SDEPTH_TOFRONT | SHIFTMENU | SYSIA_ReferenceFont
SDivMod32 | SHIFT_PIXFMT | SYSIA_Size
SDOWNBACKGADGET | SHIFTSUB | SYSIA_Style
SDRAGGADGET | SHINEPEN | SYSIA_Which
SDTA_Continuous | ShowTitle | SYSIA_WithBorder
SDTA_Cycles | SHOWTITLE_f | SYSICLASS
SDTA_Dummy | ShowWindow | SYS_Input
SDTA_FreeSampleData | SHSHAKE_BITS | SYSISIZE_HIRES
SDTA_LeftSample | SHSHAKE_NONE | SYSISIZE_LOWRES
SDTA_Pan | SHSHAKE_RTS | SYSISIZE_MEDRES
SDTA_Period | SHSHAKE_XON | SYSISTYLE_GADTOOLS
SDTA_ReplayPeriod | ShutdownA | SYSISTYLE_NORMAL
SDTA_RightSample | SI_BorderBottom | SYS_Output
SDTA_Sample | SI_BorderBottomSize | SysReqHandler
SDTA_SampleLength | SI_BorderLeft | SYSREQUEST
SDTA_SamplesPerSec | SI_BorderRight | SYSTEMINFOTAG_CPUINDEX
SDTA_SignalBit | SI_BorderRightSize | SYSTEMINFOTAG_DUMMY
SDTA_SignalBitMask | SI_BorderTop | SYSTEMINFOTAG_HOOK
SDTA_SignalBitNumber | SI_BorderTopTitle | SYSTEMINFOTAG_MEMHEADER
SDTA_SignalTask | SI_BottomArrowBox | SYSTEMINFOTYPE_ALERTMSGPORT
SDTA_SyncSampleChange | SI_BottomPropHeight | SYSTEMINFOTYPE_CPUCOUNT
SDTA_VoiceHeader | SI_Dummy | SYSTEMINFOTYPE_CPUFAMILYNAME
SDTA_Volume | SIGB_ABORT | SYSTEMINFOTYPE_CPUNAME
Seek64 | SIGB_BLIT | SYSTEMINFOTYPE_CPUTIME
SeekChunkBytes | SIGB_CHILD | SYSTEMINFOTYPE_EMULATION_SIZE
SeekChunkRecords | SIGB_DOS | SYSTEMINFOTYPE_EMULATION_START
SEGLISTTAG_DOS_SEGINDEX | SIGB_INTUITION | SYSTEMINFOTYPE_EMULHANDLESIZE
SEGLISTTAG_Dummy | SIGB_NET | SYSTEMINFOTYPE_EXCEPTIONMSGPORT
SEGLISTTAG_ELF_SEGADDRALIGN | SIGBREAKB_CTRL_C | SYSTEMINFOTYPE_EXCEPTIONMSGPORT_68K
SEGLISTTAG_ELF_SEGFLAGS | SIGBREAKB_CTRL_D | SYSTEMINFOTYPE_FREEBLOCKS
SEGLISTTAG_ELF_SEGINDEX | SIGBREAKB_CTRL_E | SYSTEMINFOTYPE_INVOLUNTARYCSW
SEGLISTTAG_ELF_SEGNAME | SIGBREAKB_CTRL_F | SYSTEMINFOTYPE_LASTSECCPUTIME
SEGLISTTAG_ELF_SEGOFFSET | SIGBREAKF_CTRL_C | SYSTEMINFOTYPE_LASTSECINVOLUNTARYCSW
SEGLISTTAG_ELF_SEGTYPE | SIGBREAKF_CTRL_D | SYSTEMINFOTYPE_LASTSECTICKS
SEGLISTTAG_OBJDATA | SIGBREAKF_CTRL_E | SYSTEMINFOTYPE_LASTSECVOLUNTARYCSW
SEGLISTTAG_SEGLISTTYPE | SIGBREAKF_CTRL_F | SYSTEMINFOTYPE_LAUNCHTIMETICKS
SEGLISTTAG_SEGSIZE | SIGB_SINGLE | SYSTEMINFOTYPE_LAUNCHTIMETICKS1978
SEGLISTTAG_SEGSTART | SIGF_ABORT | SYSTEMINFOTYPE_LOADAVG1
SEGLISTTYPE_AMIGA | SIGF_BLIT | SYSTEMINFOTYPE_LOADAVG2
SEGLISTTYPE_ELF | SIGF_CHILD | SYSTEMINFOTYPE_LOADAVG3
SEGLISTTYPE_POWERUP | SIGF_DOS | SYSTEMINFOTYPE_MACHINE
SEG_SEM | SIGF_INTUITION | SYSTEMINFOTYPE_MAGIC1
SELECTDOWN | SIGF_NET | SYSTEMINFOTYPE_MAGIC2
SelectInput | SIGF_SINGLE | SYSTEMINFOTYPE_MAXALERTCOUNT
SelectOutput | Signal | SYSTEMINFOTYPE_MAXHITCOUNT
SELECTUP | SIGNFLAG | SYSTEMINFOTYPE_MODULE_SIZE
SendIO | SIH_PRIMASK | SYSTEMINFOTYPE_MODULE_START
SendPkt | SIMPLEREQ | SYSTEMINFOTYPE_PAGESIZE
SERB_7WIRE | Single_PT | SYSTEMINFOTYPE_PPC_ALTIVEC
SERB_EOFMODE | PtrInt | SYSTEMINFOTYPE_PPC_BUSCLOCK
SERB_PARTY_ODD | SI_RightArrowBox | SYSTEMINFOTYPE_PPC_BUSTICKS
SERB_PARTY_ON | SI_RightPropWidth | SYSTEMINFOTYPE_PPC_CACHEL1FLAGS
SERB_QUEUEDBRK | SI_ScreenTitlebarHeight | SYSTEMINFOTYPE_PPC_CACHEL1TYPE
SERB_RAD_BOOGIE | SI_Shadows | SYSTEMINFOTYPE_PPC_CACHEL2FLAGS
SERB_SHARED | SIX_LPI | SYSTEMINFOTYPE_PPC_CACHEL2TYPE
SERB_XDISABLED | SIZEGADGET | SYSTEMINFOTYPE_PPC_CACHEL3FLAGS
SER_DEFAULT_CTLCHAR | SIZEIMAGE | SYSTEMINFOTYPE_PPC_CACHEL3TYPE
SerErr_BaudMismatch | SizeLayer | SYSTEMINFOTYPE_PPC_CPUCLOCK
SerErr_BufErr | SIZEOF_INSTANCE | SYSTEMINFOTYPE_PPC_CPUREVISION
SerErr_BufOverflow | SizeWindow | SYSTEMINFOTYPE_PPC_CPUTEMP
SerErr_DetectedBreak | SLIDERIDCMP | SYSTEMINFOTYPE_PPC_CPUVERSION
SerErr_DevBusy | SLIDER_KIND | SYSTEMINFOTYPE_PPC_DABR
SerErr_InvParam | SM_EXCLUSIVE | SYSTEMINFOTYPE_PPC_DATASTREAM
SerErr_LineErr | SM_SHARED | SYSTEMINFOTYPE_PPC_DCACHEL1LINES
SerErr_NoDSR | SMult32 | SYSTEMINFOTYPE_PPC_DCACHEL1LINESIZE
SerErr_ParityErr | SMult64 | SYSTEMINFOTYPE_PPC_DCACHEL1SIZE
SerErr_TimerErr | SNAPSHOTIMAGE | SYSTEMINFOTYPE_PPC_DCACHEL2LINES
SERF_7WIRE | SOFTHYPHEN | SYSTEMINFOTYPE_PPC_DCACHEL2LINESIZE
SERF_EOFMODE | SortGList | SYSTEMINFOTYPE_PPC_DCACHEL2SIZE
SERF_PARTY_ODD | SortLayerCR | SYSTEMINFOTYPE_PPC_DCACHEL3LINES
SERF_PARTY_ON | SOUNDDTCLASS | SYSTEMINFOTYPE_PPC_DCACHEL3LINESIZE
SERF_QUEUEDBRK | SPARITY_BITS | SYSTEMINFOTYPE_PPC_DCACHEL3SIZE
SERF_RAD_BOOGIE | SPARITY_EVEN | SYSTEMINFOTYPE_PPC_FPU
SERF_SHARED | SPARITY_MARK | SYSTEMINFOTYPE_PPC_ICACHEL1LINES
SERF_XDISABLED | SPARITY_NONE | SYSTEMINFOTYPE_PPC_ICACHEL1LINESIZE
serial | SPARITY_ODD | SYSTEMINFOTYPE_PPC_ICACHEL1SIZE
SERIALNAME | SPARITY_SPACE | SYSTEMINFOTYPE_PPC_ICACHEL2LINES
SERIAL_PRINTER | SPECIAL_BEAMCON | SYSTEMINFOTYPE_PPC_ICACHEL2LINESIZE
SetABPenDrMd | SPECIAL_FLAGS | SYSTEMINFOTYPE_PPC_ICACHEL2SIZE
SetAfPt | SPECIAL_MONITOR_TYPE | SYSTEMINFOTYPE_PPC_ICACHEL3LINES
SetAPen | SplitName | SYSTEMINFOTYPE_PPC_ICACHEL3LINESIZE
SetArgStr | SPOS_ABSOLUTE | SYSTEMINFOTYPE_PPC_ICACHEL3SIZE
SetAttrs | SPOS_FORCEDRAG | SYSTEMINFOTYPE_PPC_PERFMONITOR
SetAttrsA | sposition | SYSTEMINFOTYPE_PPC_RESERVATIONSIZE
SetBPen | SPOS_MAKEVISIBLE | SYSTEMINFOTYPE_PPC_TLBENTRIES
SetChipRev | SPOS_RELATIVE | SYSTEMINFOTYPE_PPC_TLBSETS
SETCHIPREV_A | SP_PARENS | SYSTEMINFOTYPE_RECENTCPUTIME
SETCHIPREV_AA | SP_PREC_ALL | SYSTEMINFOTYPE_RECENTTICKS
SETCHIPREV_BEST | SP_PREC_CURR | SYSTEMINFOTYPE_REGUSER
SETCHIPREV_ECS | SPRITEA_Attached | SYSTEMINFOTYPE_REVISION
SetCollision | SPRITEA_OldDataFormat | SYSTEMINFOTYPE_SYSTEM
SetComment | SPRITEA_OutputHeight | SYSTEMINFOTYPE_TASKEXITCODE
SetConsoleTask | SPRITE_ATTACHED | SYSTEMINFOTYPE_TASKEXITCODE_M68K
SetCurrentDirName | SPRITEA_ViewPort | SYSTEMINFOTYPE_TASKSCREATED
SetCxObjPri | SPRITEA_Width | SYSTEMINFOTYPE_TASKSFINISHED
SetDefaultPubScreen | SPRITEA_XReplication | SYSTEMINFOTYPE_TASKSRUNNING
SetDiskFontCtrl | SPRITEA_YReplication | SYSTEMINFOTYPE_TASKSSLEEPING
SetDiskFontCtrlA | SPRITERESN_140NS | SYSTEMINFOTYPE_TBCLOCKFREQUENCY
SetDMRequest | SPRITERESN_35NS | SYSTEMINFOTYPE_UPTIMETICKS
SetDosObjectAttr | SPRITERESN_70NS | SYSTEMINFOTYPE_VENDOR
SetDosObjectAttrTagList | SPRITERESN_DEFAULT | SYSTEMINFOTYPE_VOLUNTARYCSW
SetDrMd | SPRITERESN_ECS | SystemTagList
SetDrPt | SPRITES | SystemTags
SetDTAttrs | SP_SUCC_ALL | SYS_UserShell

T

TABLETA_AngleX | TDimensionInfo | tMUIP_Export
TABLETA_AngleY | TDiskFontHeader | tMUIP_Family_AddHead
TABLETA_AngleZ | TDiskObject | tMUIP_Family_AddTail
TABLETA_ButtonBits | TDisplayInfo | tMUIP_Family_Insert
TABLETA_Dummy | TDisplayMode | tMUIP_Family_Remove
TABLETA_InProximity | TDosAttrBuffer | tMUIP_Family_Sort
TABLETA_Pressure | TDosEnvec | tMUIP_Family_Transfer
TABLETA_RangeZ | TDOSInfo | tMUIP_FindUData
TABLETA_ResolutionX | TDOSLibrary | tMUIP_GetConfigItem
TABLETA_ResolutionY | TDOSList | tMUIP_GetUData
TABLETA_TabletZ | TDOSPacket | tMUIP_Group_ExitChange
TA_Bold | TDrawerData | tMUIP_Group_InitChange
TAChain | TDrawInfo | tMUIP_Group_Sort
TA_ColorFont | TDTA_Buffer | tMUIP_HandleEvent
TA_Designed | TDTA_BufferLen | tMUIP_HandleInput
TA_DeviceDPI | TDTA_LineList | tMUIP_Hide
TA_DiskFont | TDTA_WordDelim | tMUIP_Import
tadtFrame | TDTA_WordSelect | tMUIP_KillNotify
tadtNewFormatFrame | TDTA_WordWrap | tMUIP_KillNotifyObj
tadtStart | tdtDraw | tMUIP_List_Clear
TA_Extended | tdtFrameBox | tMUIP_List_CreateImage
LongWord | tdtGeneral | tMUIP_List_DeleteImage
TAG_ | tdtGoto | tMUIP_List_Exchange
TAGBASE_SCREENBAR | tDTHookContext | tMUIP_List_GetEntry
TAG_DONE | tDTMethod | tMUIP_List_Insert
TAG_END | tdtPrint | tMUIP_List_InsertSingle
TAGFILTER_AND | TdtReleaseDrawInfo | tMUIP_List_Jump
TAGFILTER_NOT | tdtSelect | tMUIP_List_Move
TaggedOpenLibrary | tDTSpecialInfo | tMUIP_List_NextSelected
TAG_IGNORE | tdtTrigger | tMUIP_List_Redraw
TagInArray | tdtWrite | tMUIP_List_Remove
TAG_MORE | t__dummyXFC2__ | tMUIP_List_Select
TAG_SKIP | TE0B_NOREMFONT | tMUIP_List_Sort
TAG_USER | TE0F_NOREMFONT | tMUIP_List_TestPos
TAG_USER | TEasyStruct | tMUIP_Menustrip_ExitChange
tAHIAudioCtrl | TEClockVal | tMUIP_Menustrip_InitChange
tAHIAudioModeRequester | TEmulHandle | tMUIP_MultiSet
tAHIDSPEcho | TEmulLibEntry | tMUIP_NoNotifySet
tAHIEffChannelInfo | TEmulRegs | tMUIP_Notify
tAHIEffDSPMask | TErrorString | tMUIP_Numeric_Decrease
tAHIEffMasterVolume | TETask | tMUIP_Numeric_Increase
tAHIEffOutputBuffer | TexAllControl | tMUIP_Numeric_ScaleToValue
tAHIGlobalPrefs | TExAllData | tMUIP_Numeric_SetDefault
tAHIRecordMessage | TExecBase | tMUIP_Numeric_Stringify
tAHIRequest | TExecNotifyMessage | tMUIP_Numeric_ValueToScale
tAHISampleInfo | TEXTDTCLASS | tMUIP_Popstring_Close
tAHISoundMessage | TExtEasyStruct | tMUIP_Popstring_Open
tAHIUnitPrefs | TExtendedKeyMapNode | tMUIP_Prop_Decrease
TA_Italic | TExtendedNode | tMUIP_Prop_Increase
TAlertMessage | TextExtent | TMUIP_Screenbar_BuildSettingsPanel
TAnalogSignalInterval | TextFit | TMUIP_Screenbar_DefaultConfigItem
TA_Name | TExtGadget | TMUIP_Screenbar_KnowsConfigItem
TAnchorPath | TEXTIDCMP | TMUIP_Screenbar_Lock
TAnimComp | TExtIntuiMessage | TMUIP_Screenbar_Signal
tAnimHeader | TEXT_KIND | TMUIP_Screenbar_Unlock
TAnimOb | TextLength | tMUIP_Semaphore_Attempt
TAppIcon | TExtNewScreen | tMUIP_Semaphore_AttemptShared
TAppIconRenderMsg | TExtNewWindow | tMUIP_Semaphore_Obtain
TAppMenu | TEXTPEN | tMUIP_Semaphore_ObtainShared
TAppMenuItem | TExtSprite | tMUIP_Semaphore_Release
TAppMessage | TFCH_ID | tMUIP_Set
TAppWindow | TF_ETASK | tMUIP_SetAsString
TAppWindowDropZone | TF_EXCEPT | tMUIP_Settingsgroup_ConfigToGadgets
TAppWindowDropZoneMsg | TFileHandle | tMUIP_Settingsgroup_GadgetsToConfig
TA_Proportional | TFileInfoBlock | tMUIP_SetUData
TAreaInfo | TFileLock | tMUIP_SetUDataOnce
TA_RevPath | TFileRequester | tMUIP_Setup
TA_ROMFont | TFileSysStartupMsg | tMUIP_Show
TASKERROR_NOMEMORY | TF_LAUNCH | tMUI_PubScreenDesc
TASKERROR_OK | TF_LAUNCH_MASK | TMUIP_UpdateConfig
TASKINFOTAG_DUMMY | TFontContents | tMUIP_UpdateConfig
TASKINFOTAG_HOOK | TFontContentsHeader | tMUIP_Window_AddEventHandler
TASKINFOTAG_REGCOUNT | TFontRequester | tMUIP_Window_Cleanup
TASKINFOTAG_REGSTART | TF_PROCTIME | tMUIP_Window_GetMenuCheck
TASKINFOTYPE_68K_NEWFRAME | tFrameInfo | tMUIP_Window_GetMenuState
TASKINFOTYPE_AGETICKS | TFreeBlocksData | tMUIP_Window_RemEventHandler
TASKINFOTYPE_ALERTCOUNT | TFreeList | tMUIP_Window_ScreenToBack
TASKINFOTYPE_ALLTASK | TF_RX | tMUIP_Window_ScreenToFront
TASKINFOTYPE_CPUTIME | TF_SHELL | tMUIP_Window_SetCycleChain
TASKINFOTYPE_EMULHANDLE | TF_STACKCHK | tMUIP_Window_SetMenuCheck
TASKINFOTYPE_EXCEPTCODE | TF_SWITCH | tMUIP_Window_SetMenuState
TASKINFOTYPE_EXCEPTDATA | TFuncEntry | tMUIP_Window_Setup
TASKINFOTYPE_EXCEPTIONCOUNT | TFuncOldEntry | tMUIP_Window_Snapshot
TASKINFOTYPE_FLAGS | TF_WORKBENCH | tMUIP_Window_ToBack
TASKINFOTYPE_HITCOUNT | TGadget | tMUIP_Window_ToFront
TASKINFOTYPE_INVOLUNTARYCSW | TGadgetInfo | tMUIP_WriteLong
TASKINFOTYPE_LASTSECCPUTIME | TGelsInfo | tMUIP_WriteString
TASKINFOTYPE_LASTSECINVOLUNTARYCSW | TGfxBase | tMUI_RenderInfo
TASKINFOTYPE_LASTSECVOLUNTARYCSW | tglContext | tMUI_RGBcolor
TASKINFOTYPE_LAUNCHTIMETICKS | TGlyphEngine | tMUIS_InfoClient
TASKINFOTYPE_LAUNCHTIMETICKS1978 | TGlyphMap | TNamedObject
TASKINFOTYPE_MAXALERTCOUNT | TGlyphWidthEntry | TNameInfo
TASKINFOTYPE_MAXHITCOUNT | TgpDomain | TNewBroker
TASKINFOTYPE_NAME | TgpGoInactive | tNewGadget
TASKINFOTYPE_NAMECOPY | TgpHitTest | tNewMenu
TASKINFOTYPE_NICE | TgpInput | TNewScreen
TASKINFOTYPE_PID | TgpKeyGoInactive | TNewWindow
TASKINFOTYPE_PID_CLI | tgpKeyInput | TNode
TASKINFOTYPE_POOLMEMFLAGS | TgpKeyTest | TNotifyMessage
TASKINFOTYPE_POOLPTR | TgpLayout | TNotifyRequest
TASKINFOTYPE_POOLPUDDLESIZE | TgpRender | ToANSI
TASKINFOTYPE_POOLTHRESHSIZE | ThinLayerInfo | T_Object
TASKINFOTYPE_PPC_CR | THook | TODA_SAFE
TASKINFOTYPE_PPC_CTR | TIACTION_Execute | TODAYSTR
TASKINFOTYPE_PPC_FPR | TIACTION_NewDrawer | TOldDrawerData
TASKINFOTYPE_PPC_FPSCR | TIACTION_RelabelVolume | ToLower
TASKINFOTYPE_PPC_FRAME | TIACTION_Rename | TO_MONITOR
TASKINFOTYPE_PPC_FRAMESIZE | TIBox | TOMORROWSTR
TASKINFOTYPE_PPC_GPR | TICKS_PER_SECOND | TopAddMember
TASKINFOTYPE_PPC_LR | TIClass | TopAddTail
TASKINFOTYPE_PPC_NEWFRAME | tIconIdentifyMsg | TOPAZ_EIGHTY
TASKINFOTYPE_PPC_SRR0 | TIconSelectMsg | TOPAZ_SIXTY
TASKINFOTYPE_PPC_SRR1 | TIENewTablet | TopGet
TASKINFOTYPE_PPC_VMX | TIEPointerPixel | TOPHIT
TASKINFOTYPE_PPC_VSAVE | TIEPointerTablet | TopMember
TASKINFOTYPE_PPC_VSCR | tIFFHandle | TopSet
TASKINFOTYPE_PPC_XER | tIFFStreamCmd | TopUpdate
TASKINFOTYPE_PRI | TImage | ToUCS4
TASKINFOTYPE_RECENTCPUTIME | TimedDisplayAlert | ToUpper
TASKINFOTYPE_RESURRECT_TASK | timer | TPaletteExtra
TASKINFOTYPE_SIGALLOC | TimerBase | TPGX
TASKINFOTYPE_SIGEXCEPT | TIMERNAME | PByte
TASKINFOTYPE_SIGRECVD | TimpDomainFrame | TPoint
TASKINFOTYPE_SIGWAIT | TimpDraw | TPPCStackSwapArgs
TASKINFOTYPE_SPLOWER | TimpErase | TPreferences
TASKINFOTYPE_SPLOWER_M68K | TimpFrameBox | tprinterIO
TASKINFOTYPE_SPUPPER | TimpHitTest | TProcess
TASKINFOTYPE_SPUPPER_M68K | TInfoData | TPropInfo
TASKINFOTYPE_STACKSIZE | TInputEvent | TPubScreenNode
TASKINFOTYPE_STACKSIZE_M68K | TInputXpression | TQueryHeader
TASKINFOTYPE_STARTUPMSG | TInterrupt | TR_ADDREQUEST
TASKINFOTYPE_STATE | TIntuiMessage | TransparencyControl
TASKINFOTYPE_TASKMSGPORT | TIntuiText | TRANSPCONTROL_DUMMY
TASKINFOTYPE_TRAPCODE | TIntuitionBase | TRANSPCONTROLMETHOD_INSTALLREGION
TASKINFOTYPE_TRAPDATA | TIntVector | TRANSPCONTROLMETHOD_INSTALLREGIONHOOK
TASKINFOTYPE_TRAPMSGPORT | tinygl | TRANSPCONTROLMETHOD_UPDATETRANSPARENCY
TASKINFOTYPE_TYPE | TinyGLBase | TRANSPCONTROL_OLDREGION
TASKINFOTYPE_USEDSTACKSIZE | TINYGLNAME | TRANSPCONTROL_OLDREGIONHOOK
TASKINFOTYPE_USEDSTACKSIZE_M68K | tIOClipReq | TRANSPCONTROL_REGION
TASKINFOTYPE_USERDATA | TIOExtSer | TRANSPCONTROL_REGIONHOOK
TASKINFOTYPE_VOLUNTARYCSW | TIORequest | TRAP_AREA_START
TASKTAG_CODETYPE | TIOStdReq | TRAP_EIEIO
TASKTAG_DUMMY | TIOTArray | TRAP_ISYNC
TASKTAG_ERROR | TIsrvstr | TRAP_LIB
TASKTAG_FINALPC | TKeyMap | TRAP_LIBD0_D1
TASKTAG_FLAGS | TKeyMapNode | TRAP_LIBD0D1A0A1SR
TASKTAG_NAME | TKeyMapResource | TRAP_LIBD0D1SR
TASKTAG_PC | TLayer | TRAP_LIBNR
TASKTAG_POOLPUDDLE | TLayer_Info | TRAP_LIBNR_QUICK
TASKTAG_POOLTHRESH | TLayer_Info | TRAP_LIB_QUICK
TASKTAG_PPC_ARG1 | TLibrary | TRAP_LIBRESTORE
TASKTAG_PPC_ARG2 | tLine | TRAP_LIBSR
TASKTAG_PPC_ARG3 | TList | TRAP_LIBSRNR
TASKTAG_PPC_ARG4 | tLocalContextItem | TRAP_MASK
TASKTAG_PPC_ARG5 | TLocale | TRAP_SYNC
TASKTAG_PPC_ARG6 | TLocaleBase | TRasInfo
TASKTAG_PPC_ARG7 | TLocalVar | TRastPort
TASKTAG_PPC_ARG8 | TLSAlloc | TRDArgs
TASKTAG_PRI | TLSAllocA | TRecordLock
TASKTAG_STACKSIZE | TLSCallDestructors | TRecordLock64
TASKTAG_STACKSIZE_M68K | TLSFree | TRect32
TASKTAG_STARTUPMSG | TLSGetValue | TRectangle
TASKTAG_TASKMSGPORT | TLS_INVALID_INDEX | TRegion
TASKTAG_TCBEXTRASIZE | TLSSetValue | TRegionRectangle
TASKTAG_USERDATA | TLSTAG_DESTRUCTOR | TRemember
TAslSemaphore | TLSTAG_DUMMY | TRequester
TAssignList | TLSTAG_USERDATA | TResident
TA_TallDot | tLVDrawMsg | TR_GETSYSTIME
TAudChannel | TMemChunk | TRootNode
TA_Underlined | TMemEntry | TR_SETSYSTIME
SmallInt | TMemHandlerData | TS_ADDED
TAvailFonts | TMemHeader | tSatisfyMsg
TAvailFontsHeader | TMemList | TScreen
TA_WideDot | TMenu | TScreenBuffer
TA_YSize | TMenuItem | TScreenModeRequester
TBC_HCLRTAB | TMessage | TSegArray
TBC_HCLRTABSALL | TMinList | TSegment
TB_ETASK | TMinNode | TSegNode
TB_EXCEPT | TMonitorInfo | TSegSem
TBitMap | TMonitorSpec | TSemaphoreMessage
tBitMapHeader | TMsg | TSemaphoreRequest
TBitScaleArgs | TmsGetDefaultGammaTables | TSetupCleanupHookMsg
TB_LAUNCH | TmsGetDefaultPixelFormat | TS_EXCEPT
Tbltnode | TmsGetPointerBounds | TSGWork
TBob | TmsGetRootBitMap | TSignalSemaphore
TBoolInfo | TMsgPort | TSimpleSprite
TBorder | TmsQuery3DSupport | TS_INVALID
TB_PROCTIME | TmsSetDefaultGammaTables | TSIZE
TB_STACKCHK | tMUI_AreaData | TSoftIntList
TB_SWITCH | tMUI_BoopsiQuery | TSpecialMonitor
TBTDBoolean | tMUI_Command | TSpriteDef
TBTDCycle | tMUI_CustomClass | TS_READY
TBTDDrawInfo | tMUI_EventHandlerNode | TS_REMOVED
TBTDFile | tMUI_GlobalInfo | TS_RUN
TBTDFont | tMUI_InputHandlerNode | TStackSwapStruct
TBTDInfo | tMUI_LayoutMsg | TStandardPacket
TBTDInteger | tMUI_List_TestPos_Result | tStoredProperty
TBTDNode | tMUI_MinMax | TStringExtend
TBTDString | tMUI_NotifyData | TStringInfo
SmallInt | tMUI_Palette_Entry | TS_WAIT
TCatalog | tMUIP_Application_AboutMUI | TTabletData
tCDrawMsg | tMUIP_Application_AddInputHandler | TTabletHookData
TCIA | tMUIP_Application_BuildSettingsPanel | TTagItem
TClassLibrary | tMUIP_Application_CheckRefresh | TTask
TCLIData | tMUIP_Application_DefaultConfigItem | TTaskFrame68k
TCLIDataItem | tMUIP_Application_GetMenuCheck | TTaskInitExtension
tClipboardHandle | tMUIP_Application_GetMenuState | TTaskTrapMessage
tClipboardUnitPartial | tMUIP_Application_Input | TTaskTrapMessage_68k
tClipHookMsg | tMUIP_Application_InputBuffered | TTAvailFonts
TClipRect | tMUIP_Application_Load | TTextAttr
TCliProcList | tMUIP_Application_NewInput | TTextExtent
TClockData | tMUIP_Application_OpenConfigWindow | TTextFont
tCollectionItem | tMUIP_Application_PushMethod | TTextFontExtension
TCollTable | tMUIP_Application_RemInputHandler | TTextInputMsg
TColorFontColors | tMUIP_Application_ReturnID | TTFontContents
TColorMap | tMUIP_Application_Save | TTimeRequest
tColorRegister | tMUIP_Application_SetConfigItem | TTimeVal
TColorSpec | tMUIP_Application_SetMenuCheck | TTmpRas
TColorTextFont | tMUIP_Application_SetMenuState | tTool
TCommandLineInterface | tMUIP_Application_ShowHelp | tToolNode
tContextNode | tMUIP_AskMinMax | TTransparencyMessage
TConUnit | tMUIP_CallHook | TTTextAttr
TCopInit | tMUIP_Cleanup | TUCopList
TCopIns | tMUIP_ContextMenuAdd | TUCS4_CharsetCode
TCopList | tMUIP_ContextMenuBuild | TUCS4_CharsetConvTable
TCopyBeginMsg | tMUIP_ContextMenuChoice | TUCS4_ConvTable
TCopyDataMsg | tMUIP_CreateBubble | TUnit
TCopyEndMsg | tMUIP_CreateShortHelp | TUtilityBase
TCprList | tMUIP_Dataspace_Add | TVecInfo
TCSource | tMUIP_Dataspace_Clear | TView
TCustom | tMUIP_Dataspace_Find | TViewExtra
tCyberModeNode | tMUIP_Dataspace_Merge | TViewPort
tDataType | tMUIP_Dataspace_ReadIFF | TViewPortExtra
tDataTypeHeader | tMUIP_Dataspace_Remove | Pointer
TDateStamp | tMUIP_Dataspace_WriteIFF | tVoiceHeader
_TDateTime | tMUIP_DeleteBubble | TVSprite
TDBufInfo | tMUIP_DeleteShortHelp | SmallInt
TDBufPacket | tMUIP_DoDrag | TWBArg
TDeleteBeginMsg | tMUIP_DragBegin | TW_BROWSE
TDeleteDataMsg | tMUIP_DragDrop | TWBStartup
TDeleteEndMsg | tMUIP_DragFinish | TW_EDIT
TDevice | tMUIP_DragQuery | TWindow
TDeviceList | tMUIP_DragReport | TW_INFO
TDeviceNode | tMUIP_Draw | TW_MAIL
TDevInfo | tMUIP_DrawBackground | TW_PRINT
TDevProc | tMUI_PenSpec | TypeOfMem

U

UBMI_REALLYUNLOCK | UCS4_StrToLower | UnlockLayerRom
UBMI_UPDATERECTS | UCS4_StrToUpper | UnlockLayers
Byte | UDivMod32 | UnlockLayerUpdates
UCF_IGNORE_CASE | LongWord | UnlockPubScreen
UCopperListInit | UMult32 | UnlockPubScreenList
UCS4_CanonicalDecompose | UMult64 | UnLockRecord
UCS4_Compare | UnGetC | UnLockRecord64
UCS4_ConvToLower | UNICODE_16_BE | UnLockRecords
UCS4_ConvToUpper | UNICODE_16_LE | UnLockRecords64
UCS4_Decompose | UNICODE_32_BE | UnlockVLayer
UCS4_FormatClockData | UNICODE_32_LE | UnpackStructureTags
UCS4_FormatDate | UNICODE_INVALID | UnReadChar
UCS4_FormatString | UNICODE_NFD | UPDATEWB_ObjectAdded
UCS4_GetCatalogStr | UNICODE_NFKD | UPDATEWB_ObjectRemoved
UCS4_GetCombiningClass | UNICODE_UTF8 | UPFRONTGADGET
UCS4_GetLocaleStr | UNIT_CPUCLOCK | UpfrontLayer
UCS4_IsAlNum | UNIT_ECLOCK | UPIMAGE
UCS4_IsAlpha | UNITF_ACTIVE | USE_BPLCON3
UCS4_IsCntrl | UNITF_INTASK | USER_COPPER_CLIP
UCS4_IsCombining | UNIT_MICROHZ | USEREQIMAGE
UCS4_IsDigit | UNIT_VBLANK | UserState
UCS4_IsGraph | UNIT_WAITCPUCLOCK | US_LEGAL
UCS4_IsLower | UNIT_WAITECLOCK | US_LETTER
UCS4_IsNSM | UNIT_WAITUNTIL | UTF8_CheckEncoding
UCS4_IsPrint | UnLoadSeg | UTF8_Decode
UCS4_IsPunct | Unlock | UTF8_DecodeSafe
UCS4_IsSpace | UnLockBitMap | UTF8_Encode
UCS4_IsUpper | UnLockBitMapTagList | UTF8_EncodingLength
UCS4_IsXDigit | UnLockDosList | utility
UCS4_Normalize | UnlockIBase | UtilityBase
UCS4_NormalizedLength | UnlockLayer | UtilityName
UCS4_StrnCmp | UnlockLayerInfo | Word

V

Vacate | VideoControl | VSIZEBITS
VARBEAM | VIDEOCONTROL_BATCH | VSIZEMASK
VARCSYNC | VideoControlTags | VSOVERFLOW
VARHSYNC | ViewAddress | VSPRITE
VARVBLANK | VIEW_EXTRA_TYPE | VSQ_Dummy
VARVSYNC | ViewPortAddress | VSQ_FEAT_CAPTUREMODE
VBeamPos | VIEWPORT_EXTRA_TYPE | VSQ_FEAT_COLORKEYING
VC_DUALPF_Disable | VNewRawDoFmt | VSQ_FEAT_DOUBLEBUFFER
VC_DUALPF_Disable_Query | VOA_BaseAddress | VSQ_FEAT_FILTERING
VC_IntermediateCLUpdate | VOA_BaseOffset | VSQ_FEAT_INTERLACE
VC_IntermediateCLUpdate_Query | VOA_BaseOffset0 | VSQ_FEAT_MULTIBUFFER
VC_NoColorPaletteLoad | VOA_BaseOffset1 | VSQ_FEAT_OVERLAY
VC_NoColorPaletteLoad_Query | VOA_BaseOffset2 | VSQ_FEAT_SUBPICTURE
VERSION_ALERTMESSAGE | VOA_BaseOffset3 | VSQ_FEAT_ZOOMRECT
VERSION_TASKTRAPMESSAGE | VOA_BaseOffset4 | VSQ_FMT_R5G5B5_LE
VERSION_TASKTRAPMESSAGE_68k | VOA_BaseOffset5 | VSQ_FMT_R5G6B5_LE
VFPrintf | VOA_BottomIndent | VSQ_FMT_YUV420_PLANAR
VFWritef | VOA_CaptureMode | VSQ_FMT_YUYV
VGA70_BEAMCON | VOA_ColConSP | VSQ_MaxWidth
VGA70_COLORCLOCKS | VOA_Color0SP | VSQ_MaxWidthSP
VGA70_DENISE_MIN | VOA_Color10SP | VSQ_SupportedFeatures
VGA70_HBSTOP | VOA_Color11SP | VSQ_SupportedFormats
VGA70_HBSTRT | VOA_Color12SP | VSYNCTRUE
VGA70_HSSTOP | VOA_Color13SP | VTAG_ATTACH_CM_GET
VGA70_HSSTRT | VOA_Color14SP | VTAG_ATTACH_CM_SET
VGA70_MONITOR_NAME | VOA_Color15SP | VTAG_BATCH_CM_CLR
VGA70_TOTAL_ROWS | VOA_Color1SP | VTAG_BATCH_CM_GET
VGA70_VBSTOP | VOA_Color2SP | VTAG_BATCH_CM_SET
VGA70_VBSTRT | VOA_Color3SP | VTAG_BATCH_ITEMS_ADD
VGA70_VSSTOP | VOA_Color4SP | VTAG_BATCH_ITEMS_GET
VGA70_VSSTRT | VOA_Color5SP | VTAG_BATCH_ITEMS_SET
VGA_COLORCLOCKS | VOA_Color6SP | VTAG_BITPLANEKEY_CLR
VGA_DENISE_MIN | VOA_Color7SP | VTAG_BITPLANEKEY_GET
VGAEHB_KEY | VOA_Color8SP | VTAG_BITPLANEKEY_SET
VGAEHBLACE_KEY | VOA_Color9SP | VTAG_BORDERBLANK_CLR
VGAEXTRAHALFBRITE_KEY | VOA_ColorKey | VTAG_BORDERBLANK_GET
VGAEXTRAHALFBRITELACE_KEY | VOA_ColorKeyPen | VTAG_BORDERBLANK_SET
VGAEXTRALORESDBL_KEY | VOA_DoubleBuffer | VTAG_BORDERNOTRANS_CLR
VGAEXTRALORESDPF2_KEY | VOA_EnableSP | VTAG_BORDERNOTRANS_GET
VGAEXTRALORESDPF_KEY | VOA_Error | VTAG_BORDERNOTRANS_SET
VGAEXTRALORESEHBDBL_KEY | VOA_FrameBase0 | VTAG_BORDERSPRITE_CLR
VGAEXTRALORESEHB_KEY | VOA_FrameBase1 | VTAG_BORDERSPRITE_GET
VGAEXTRALORESEHBLACE_KEY | VOA_FrameIndex | VTAG_BORDERSPRITE_SET
VGAEXTRALORESHAMDBL_KEY | VOA_FrameType | VTAG_CHROMAKEY_CLR
VGAEXTRALORESHAM_KEY | VOA_Height | VTAG_CHROMAKEY_GET
VGAEXTRALORESHAMLACE_KEY | VOA_HLColConSP | VTAG_CHROMAKEY_SET
VGAEXTRALORES_KEY | VOA_HLEnableSP | VTAG_CHROMA_PEN_CLR
VGAEXTRALORESLACEDPF2_KEY | VOA_HLRectSP | VTAG_CHROMA_PEN_GET
VGAEXTRALORESLACEDPF_KEY | VOA_Identifier | VTAG_CHROMA_PEN_SET
VGAEXTRALORESLACE_KEY | VOA_InterLaced | VTAG_CHROMA_PLANE_GET
VGAHAM_KEY | VOA_LeftIndent | VTAG_CHROMA_PLANE_SET
VGAHAMLACE_KEY | VOA_Modulo | VTAG_COERCE_DISP_GET
VGA_HBSTOP | VOA_MultiBuffer | VTAG_COERCE_DISP_SET
VGA_HBSTRT | VOA_RightIndent | VTAG_DEFSPRITERESN_GET
VGA_HSSTOP | VOA_SrcHeight | VTAG_DEFSPRITERESN_SET
VGA_HSSTRT | VOA_SrcHeightSP | VTAG_END_CM
VGALORESDBL_KEY | VOA_SrcType | VTAG_FULLPALETTE_CLR
VGALORESDPF2_KEY | VOA_SrcWidth | VTAG_FULLPALETTE_GET
VGALORESDPF_KEY | VOA_SrcWidthSP | VTAG_FULLPALETTE_SET
VGALORESEHBDBL_KEY | VOA_StreamRectSP | VTAG_IMMEDIATE
VGALORESEHB_KEY | VOA_SubPicture | VTAG_NEXTBUF_CM
VGALORESEHBLACE_KEY | VOA_TopIndent | VTAG_NORMAL_DISP_GET
VGALORESHAMDBL_KEY | VOA_UseBackfill | VTAG_NORMAL_DISP_SET
VGALORESHAM_KEY | VOA_UseColorKey | VTAG_PF1_BASE_GET
VGALORESHAMLACE_KEY | VOA_UseFilter | VTAG_PF1_BASE_SET
VGALORES_KEY | VOA_Width | VTAG_PF1_TO_SPRITEPRI_GET
VGALORESLACEDPF2_KEY | VOA_ZoomRect | VTAG_PF1_TO_SPRITEPRI_SET
VGALORESLACEDPF_KEY | VOERR_INVSCRMODE | VTAG_PF2_BASE_GET
VGALORESLACE_KEY | VOERR_INVSRCFMT | VTAG_PF2_BASE_SET
VGA_MONITOR_ID | VOERR_NOMEMORY | VTAG_PF2_TO_SPRITEPRI_GET
VGA_MONITOR_NAME | VOERR_NOOVLMEMORY | VTAG_PF2_TO_SPRITEPRI_SET
VGAPRODUCTDBL_KEY | VOERR_OK | VTAG_SPEVEN_BASE_GET
VGAPRODUCTDPF2_KEY | VPB_A2024 | VTAG_SPEVEN_BASE_SET
VGAPRODUCTDPF_KEY | VPB_TENHZ | VTAG_SPODD_BASE_GET
VGAPRODUCTEHBDBL_KEY | VPF_A2024 | VTAG_SPODD_BASE_SET
VGAPRODUCTHAMDBL_KEY | VPF_TENHZ | VTAG_SPRITERESN_GET
VGAPRODUCTHAM_KEY | VP_HIDE | VTAG_SPRITERESN_SET
VGAPRODUCTHAMLACE_KEY | VPOSRLOF | VTAG_USERCLIP_CLR
VGAPRODUCT_KEY | VPrintf | VTAG_USERCLIP_GET
VGAPRODUCTLACEDPF2_KEY | VPXB_FREE_ME | VTAG_USERCLIP_SET
VGAPRODUCTLACEDPF_KEY | VPXB_LAST | VTAG_VIEWPORTEXTRA_GET
VGAPRODUCTLACE_KEY | VPXB_STRADDLES256 | VTAG_VIEWPORTEXTRA_SET
VGA_TOTAL_ROWS | VPXB_STRADDLES512 | VTAG_VPMODEID_CLR
VGA_VBSTOP | VPXF_FREE_ME | VTAG_VPMODEID_GET
VGA_VBSTRT | VPXF_LAST | VTAG_VPMODEID_SET
VGA_VSSTOP | VPXF_STRADDLES256 | VWritef
VGA_VSSTRT | VPXF_STRADDLES512 |

W

WA_Activate | WA_SizeGadget | WBCTRLA_SetTypeRestartTime
WA_AmigaKey | WA_SizeNumerator | WBDEVICE
WA_AutoAdjust | WA_SkinInfo | WBDISK
WA_Backdrop | WA_SmartRefresh | WB_DISKMAGIC
WA_BackFill | WA_SuperBitMap | WB_DISKREVISION
WA_BlockPen | WA_TabletMessages | WB_DISKREVISIONMASK
WA_Borderless | WAT_DUMMY | WB_DISKVERSION
WA_BusyPointer | WA_Title | WBDRAWER
WAC_ACTIVATEWINDOW | WAT_MOVEWBEHINDWINDOW | WBDZA_Box
WAC_CHANGEWINDOWBOX | WAT_MOVEWINDOWX | WBDZA_Height
WAC_DUMMY | WAT_MOVEWINDOWY | WBDZA_Hook
WAC_FAMILYTOBACK | WA_ToolbarWindow | WBDZA_Left
WAC_FAMILYTOFRONT | WA_Top | WBDZA_RelBottom
WA_Checkmark | WA_TransparentRegion | WBDZA_RelHeight
WAC_HIDEWINDOW | WA_TransparentRegionHook | WBDZA_RelRight
WA_CloseGadget | WAT_SIZEWINDOWX | WBDZA_RelWidth
WAC_MAXIMIZEWINDOW | WAT_SIZEWINDOWY | WBDZA_Top
WAC_MINIMIZEWINDOW | WAT_WINDOWBOXHEIGHT | WBDZA_Width
WAC_MOVEWINDOW | WAT_WINDOWBOXLEFT | WBENCHCLOSE
WAC_MOVEWINDOWINFRONTOF | WAT_WINDOWBOXTOP | WBENCHOPEN
WA_Colors | WAT_WINDOWBOXWIDTH | WBENCHSCREEN_f
WAC_OPENMENU | WA_UserPort | WBenchToBack
WAC_RESTOREINITIALSIZEPOS | WA_VisibleOnMaximize | WBenchToFront
WAC_SENDIDCMPCLOSE | WA_WBenchWindow | WBGARBAGE
WAC_SHOWWINDOW | WA_Width | WBInfo
WAC_SIZEWINDOW | WA_WindowName | WBKICK
WA_CustomScreen | WA_Zoom | WBOPENA_ArgLock
WAC_WINDOWTOBACK | WBA_Dummy | WBOPENA_ArgName
WAC_WINDOWTOFRONT | WBA_LAST_TAG | WBOPENA_Show
WAC_ZIPWINDOW | WBAPPICON | WBOPENA_ViewBy
WA_DepthGadget | WBAPPICONA_Clone | WBPROJECT
WA_DetailPen | WBAPPICONA_NotifySelectState | WBTOOL
WA_DragBar | WBAPPICONA_PropagatePosition | WeighTAMatch
WA_Dummy | WBAPPICONA_RenderHook | WeighTAMatchTags
WA_ExtraGadget_Iconify | WBAPPICONA_SupportsCopy | WFLG_ACTIVATE
WA_ExtraGadget_Jump | WBAPPICONA_SupportsDelete | WFLG_BACKDROP
WA_ExtraGadget_Lock | WBAPPICONA_SupportsEmptyTrash | WFLG_BORDERLESS
WA_ExtraGadget_MUI | WBAPPICONA_SupportsFormatDisk | WFLG_CLOSEGADGET
WA_ExtraGadget_PopUp | WBAPPICONA_SupportsInformation | WFLG_DEPTHGADGET
WA_ExtraGadget_Snapshot | WBAPPICONA_SupportsLeaveOut | WFLG_DRAGBAR
WA_ExtraGadgetsStartID | WBAPPICONA_SupportsOpen | WFLG_GIMMEZEROZERO
WA_ExtraTitlebarGadgets | WBAPPICONA_SupportsPutAway | WFLG_HASZOOM
WA_Flags | WBAPPICONA_SupportsRename | WFLG_INREQUEST
WA_FrontWindow | WBAPPICONA_SupportsSnapshot | WFLG_MENUSTATE
WA_Gadgets | WBAPPICONA_SupportsUnSnapshot | WFLG_NEWLOOKMENUS
WA_GimmeZeroZero | WBAPPMENUA_CommandKeyString | WFLG_NOCAREREFRESH
WA_HasAlpha | WBAPPMENUA_GetKey | WFLG_NW_EXTENDED
WA_Height | WBAPPMENUA_GetTitleKey | WFLG_OTHER_REFRESH
WA_HelpGroup | WBAPPMENUA_UseKey | WFLG_REFRESHBITS
WA_HelpGroupWindow | WBA_Reserved1 | WFLG_REPORTMOUSE
WA_HitLevel | WBA_Reserved10 | WFLG_RMBTRAP
WA_IDCMP | WBA_Reserved11 | WFLG_SIMPLE_REFRESH
WA_InnerHeight | WBA_Reserved12 | WFLG_SIZEBBOTTOM
WA_InnerWidth | WBA_Reserved13 | WFLG_SIZEBRIGHT
Wait | WBA_Reserved14 | WFLG_SIZEGADGET
WaitBlit | WBA_Reserved15 | WFLG_SMART_REFRESH
WaitBOVP | WBA_Reserved16 | WFLG_SUPER_BITMAP
WaitForChar | WBA_Reserved17 | WFLG_VISITOR
WaitIO | WBA_Reserved18 | WFLG_WBENCHWINDOW
WaitPkt | WBA_Reserved19 | WFLG_WINDOWACTIVE
WaitPort | WBA_Reserved2 | WFLG_WINDOWREFRESH
WaitTOF | WBA_Reserved3 | WFLG_WINDOWTICKED
WA_Left | WBA_Reserved4 | WFLG_ZOOMED
WA_MaxHeight | WBA_Reserved5 | WhichLayer
WA_MaxWidth | WBA_Reserved6 | WhichLayerBehindLayer
WA_MenuHelp | WBA_Reserved7 | WindowAction
WA_MinHeight | WBA_Reserved8 | WindowLimits
WA_MinWidth | WBA_Reserved9 | WindowToBack
WA_MouseQueue | WBArgList | WindowToFront
WA_NewLookMenus | WBCTRLA_AddHiddenDeviceName | WM_Dummy
WA_NoCareRefresh | WBCTRLA_AddSetupCleanupHook | WM_ObtainEvents
WA_NotifyDepth | WBCTRLA_DuplicateSearchPath | WM_OpenMenu
WA_Opacity | WBCTRLA_FreeHiddenDeviceList | WM_ReleaseEvents
WA_Parent | WBCTRLA_FreeOpenDrawerList | Word
WA_Pointer | WBCTRLA_FreeProgramList | workbench
WA_PointerDelay | WBCTRLA_FreeSearchPath | WorkbenchBase
WA_PointerType | WBCTRLA_FreeSelectedIconList | WorkbenchControl
WA_PubScreen | WBCTRLA_GetCopyHook | WorkbenchControlA
WA_PubScreenFallBack | WBCTRLA_GetDefaultStackSize | WORKBENCHNAME
WA_PubScreenName | WBCTRLA_GetDeleteHook | WriteChar
WA_ReportMouse | WBCTRLA_GetHiddenDeviceList | WriteChars
WA_RMBTrap | WBCTRLA_GetOpenDrawerList | WriteChunkBytes
WA_RptQueue | WBCTRLA_GetProgramList | WriteChunkRecords
WA_ScreenTitle | WBCTRLA_GetSelectedIconList | WriteChunkyPixels
WA_ShadowBottom | WBCTRLA_GetTextInputHook | WriteLUTPixelArray
WA_ShadowLeft | WBCTRLA_GetTypeRestartTime | WritePixel
WA_ShadowRight | WBCTRLA_IsOpen | WritePixelArray
WA_ShadowTop | WBCTRLA_RedrawAppIcon | WritePixelArray8
WA_SimpleRefresh | WBCTRLA_RemoveHiddenDeviceName | WritePixelArrayAlpha
WA_SizeBBottom | WBCTRLA_RemSetupCleanupHook | WritePixelLine8
WA_SizeBRight | WBCTRLA_SetCopyHook | WriteRGBPixel
WA_SizeDenominator | WBCTRLA_SetDefaultStackSize | WriteSPLine
WA_SizeExtraHeight | WBCTRLA_SetDeleteHook | PWideChar
WA_SizeExtraWidth | WBCTRLA_SetTextInputHook | W_TRACTOR

X

XorRectRegion XorRegionRegion

Y

YESSTR YESTERDAYSTR

Z

ZipWindow ZOOMIMAGE


A2024_MONITOR_ID

Declaration

Source position: agraphics.pas line 1276

const A2024_MONITOR_ID = $00041000;


A2024FIFTEENHERTZ_KEY

Declaration

Source position: agraphics.pas line 1279

const A2024FIFTEENHERTZ_KEY = $00049000;


A2024TENHERTZ_KEY

Declaration

Source position: agraphics.pas line 1278

const A2024TENHERTZ_KEY = $00041000;


ANFRACSIZE

Define for the animation procedures

Declaration

Source position: agraphics.pas line 918

const ANFRACSIZE = 6;


ANIMHALF

Define for the animation procedures

Declaration

Source position: agraphics.pas line 920

const ANIMHALF = $0020;


AREAOUTLINE

Used by areafiller only used for bobs

Declaration

Source position: agraphics.pas line 859

const AREAOUTLINE = $08;

See also

TRastPort

Basic structure for all drawing actions


AVOID_FLICKER

Flag for CoerceMode Ensure that the mode coerced to is not interlaced.

Declaration

Source position: agraphics.pas line 886

const AVOID_FLICKER = 2;


B2BOBBER

Declaration

Source position: agraphics.pas line 722

const B2BOBBER = 2;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

B2NORM

Declaration

Source position: agraphics.pas line 720

const B2NORM = 0;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

B2SWAP

Declaration

Source position: agraphics.pas line 721

const B2SWAP = 1;


BACKSAVED

System Set flag for TVsprite.Flags. This Bob's background has been saved

Declaration

Source position: agraphics.pas line 901

const BACKSAVED = $0100;


BANDWIDTH_1X

Memory Type

Declaration

Source position: agraphics.pas line 1970

const BANDWIDTH_1X = BUS_16 or NML_CAS;


BANDWIDTH_2XDBL

Memory Type

Declaration

Source position: agraphics.pas line 1972

const BANDWIDTH_2XDBL = DBL_CAS;


BANDWIDTH_2XNML

Memory Type

Declaration

Source position: agraphics.pas line 1971

const BANDWIDTH_2XNML = BUS_32;


BANDWIDTH_4X

Memory Type

Declaration

Source position: agraphics.pas line 1973

const BANDWIDTH_4X = BUS_32 or DBL_CAS;


BDRAWN

Bob System Flag for TBob.Flags set when Bob is drawn this DrawG pass

Declaration

Source position: agraphics.pas line 912

const BDRAWN = $0200;


BIDTAG_BlueBits

Tag for BestModeID() Match up from the DataBase default - 4

Declaration

Source position: agraphics.pas line 1503

const BIDTAG_BlueBits = $8000000c;


BIDTAG_COERCE

Flags for CoerceMode Private

Declaration

Source position: agraphics.pas line 889

const BIDTAG_COERCE = 1;


BIDTAG_Depth

Tag for BestModeID() ModeID must support this depth. Default - TViewPort.RasInfo^.BitMap^.Depth or 1

Declaration

Source position: agraphics.pas line 1498

const BIDTAG_Depth = $80000008;


BIDTAG_DesiredHeight

Tag for BestModeID() Nominal Height of the returned ModeID. Default - same as Nominal

Declaration

Source position: agraphics.pas line 1496

const BIDTAG_DesiredHeight = $80000007;


BIDTAG_DesiredWidth

Tag for BestModeID() Nominal Width of the returned ModeID. Default - same as Nominal

Declaration

Source position: agraphics.pas line 1495

const BIDTAG_DesiredWidth = $80000006;


BIDTAG_DIPFMustHave

Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0

Declaration

Source position: agraphics.pas line 1486

const BIDTAG_DIPFMustHave = $80000001;


BIDTAG_DIPFMustNotHave

Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS

Declaration

Source position: agraphics.pas line 1487

const BIDTAG_DIPFMustNotHave = $80000002;


BIDTAG_GfxPrivate

Tag for BestModeID() Private do not use

Declaration

Source position: agraphics.pas line 1506

const BIDTAG_GfxPrivate = $8000000e;


BIDTAG_GreenBits

Tag for BestModeID() Match up from the DataBase default - 4

Declaration

Source position: agraphics.pas line 1504

const BIDTAG_GreenBits = $8000000d;


BIDTAG_MonitorID

Tag for BestModeID() ModeID must use this monitor. Default - use best monitor available

Declaration

Source position: agraphics.pas line 1499

const BIDTAG_MonitorID = $80000009;


BIDTAG_NominalHeight

Tag for BestModeID() Override the TViewPort.Height. Default - SourceID NominalDimensionInfo or TViewPort.DHeight or 200 in that order

Declaration

Source position: agraphics.pas line 1491

const BIDTAG_NominalHeight = $80000005;


BIDTAG_NominalWidth

Tag for BestModeID() Override the TViewPort.Width. Default - SourceID NominalDimensionInfo or TViewPort.DWidth or 640 in that order

Declaration

Source position: agraphics.pas line 1490

const BIDTAG_NominalWidth = $80000004;


BIDTAG_RedBits

Tag for BestModeID() Match up from the DataBase default - 4

Declaration

Source position: agraphics.pas line 1502

const BIDTAG_RedBits = $8000000b;


BIDTAG_SourceID

Tag for BestModeID() Instead of a ViewPort. Default - VPModeID(vp) if BIDTAG_ViewPort is specified, else leave the BIDTAG_DIPFMustHave and BIDTAG_DIPFMustNotHave values untouched.

Declaration

Source position: agraphics.pas line 1500

const BIDTAG_SourceID = $8000000a;


BIDTAG_ViewPort

Tag for BestModeID() ViewPort for which a ModeID is sought. Default - nil

Declaration

Source position: agraphics.pas line 1488

const BIDTAG_ViewPort = $80000003;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

BITCLR

Declaration

Source position: agraphics.pas line 32

const BITCLR = 0;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

BITSET

Declaration

Source position: agraphics.pas line 31

const BITSET = $8000;


BLITMSG_FAULT

Declaration

Source position: agraphics.pas line 1941

const BLITMSG_FAULT = 4;


BMA_DEPTH

ID are for GetBitMapAttr. Query depth of bitmap.

Declaration

Source position: agraphics.pas line 97

const BMA_DEPTH = 4;


BMA_FLAGS

ID are for GetBitMapAttr. Query Flags (BMF_*) of bitmap.

Declaration

Source position: agraphics.pas line 99

const BMA_FLAGS = 12;


BMA_HEIGHT

ID are for GetBitMapAttr. Query height of bitmap.

Declaration

Source position: agraphics.pas line 96

const BMA_HEIGHT = 0;


BMA_WIDTH

ID are for GetBitMapAttr. Query width of bitmap.

Declaration

Source position: agraphics.pas line 98

const BMA_WIDTH = 8;


BMB_CLEAR

Bit flag for AllocBitMap Fill Bitmap with color 0

Declaration

Source position: agraphics.pas line 83

const BMB_CLEAR = 0;


BMB_DISPLAYABLE

Bit flag for AllocBitMap Displayable Bitmap

Declaration

Source position: agraphics.pas line 84

const BMB_DISPLAYABLE = 1;

Description

This bitmap data should be allocated in such a manner that it can be displayed. Displayable data has more severe alignment restrictions than non-displayable data in some systems.


BMB_INTERLEAVED

Bit flag for AllocBitMap Interleaved Bitmap

Declaration

Source position: agraphics.pas line 85

const BMB_INTERLEAVED = 2;

Description

The bitmap will be allocated with one large chunk of display memory for all bitplanes. This minimizes color flashing on deep displays. If there is not enough contiguous RAM for an interleaved bitmap, graphics.library will fall back to a non-interleaved one.


BMB_MINPLANES

Bit flag for AllocBitMap Minimal memory use

Declaration

Source position: agraphics.pas line 87

const BMB_MINPLANES = 4;


BMB_STANDARD

Bit flag for AllocBitMap

Declaration

Source position: agraphics.pas line 86

const BMB_STANDARD = 3;


BMF_CLEAR

Bit value for AllocBitMap Fill Bitmap with color 0

Declaration

Source position: agraphics.pas line 89

const BMF_CLEAR = 1 shl BMB_CLEAR;


BMF_DISPLAYABLE

Bit flag for AllocBitMap Displayable Bitmap

Declaration

Source position: agraphics.pas line 90

const BMF_DISPLAYABLE = 1 shl BMB_DISPLAYABLE;

Description

This bitmap data should be allocated in such a manner that it can be displayed. Displayable data has more severe alignment restrictions than non-displayable data in some systems.


BMF_INTERLEAVED

Bit flag for AllocBitMap Interleaved Bitmap

Declaration

Source position: agraphics.pas line 91

const BMF_INTERLEAVED = 1 shl BMB_INTERLEAVED;

Description

The bitmap will be allocated with one large chunk of display memory for all bitplanes. This minimizes color flashing on deep displays. If there is not enough contiguous RAM for an interleaved bitmap, graphics.library will fall back to a non-interleaved one.


BMF_MINPLANES

Bit value for AllocBitMap Minimal memory use

Declaration

Source position: agraphics.pas line 93

const BMF_MINPLANES = 1 shl BMB_MINPLANES;


BMF_STANDARD

Bit value for AllocBitMap

Declaration

Source position: agraphics.pas line 92

const BMF_STANDARD = 1 shl BMB_STANDARD;


BOBISCOMP

Bob User Flag for TBob.Flags set to identify Bob as AnimComp

Declaration

Source position: agraphics.pas line 908

const BOBISCOMP = $0002;


BOBNIX

Bob System Flag for TBob.Flags Set when Bob is completely removed

Declaration

Source position: agraphics.pas line 914

const BOBNIX = $0800;


BOBSAWAY

Bob System Flag for TBob.Flags Set to initiate removal of Bob

Declaration

Source position: agraphics.pas line 913

const BOBSAWAY = $0400;


BOBUPDATE

System Set flag for TVsprite.Flags. Temporary flag, useless to outside world

Declaration

Source position: agraphics.pas line 902

const BOBUPDATE = $0200;


BORDER_BLANKING

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1070

const BORDER_BLANKING = $04;


BORDER_NOTRANSPARENCY

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1071

const BORDER_NOTRANSPARENCY = $08;


BORDERHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 931

const BORDERHIT = 0;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


BORDERSPRITES

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1074

const BORDERSPRITES = $40;


BOTTOMHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 940

const BOTTOMHIT = 2;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


BROADCAST_BEAMCON

Declaration

Source position: agraphics.pas line 1054

const BROADCAST_BEAMCON = LOLDIS or CSBLANK;


BROADCAST_HBSTOP

Declaration

Source position: agraphics.pas line 1049

const BROADCAST_HBSTOP = $27;


BROADCAST_HBSTRT

Declaration

Source position: agraphics.pas line 1046

const BROADCAST_HBSTRT = $01;


BROADCAST_HSSTOP

Declaration

Source position: agraphics.pas line 1048

const BROADCAST_HSSTOP = $17;


BROADCAST_HSSTRT

Declaration

Source position: agraphics.pas line 1047

const BROADCAST_HSSTRT = $06;


BROADCAST_VBSTOP

Declaration

Source position: agraphics.pas line 1053

const BROADCAST_VBSTOP = $1C40;


BROADCAST_VBSTRT

Declaration

Source position: agraphics.pas line 1050

const BROADCAST_VBSTRT = $0000;


BROADCAST_VSSTOP

Declaration

Source position: agraphics.pas line 1052

const BROADCAST_VSSTOP = $054C;


BROADCAST_VSSTRT

Declaration

Source position: agraphics.pas line 1051

const BROADCAST_VSSTRT = $02A6;


BUS_16

Memory Type

Declaration

Source position: agraphics.pas line 1965

const BUS_16 = 0;


BUS_32

Memory Type

Declaration

Source position: agraphics.pas line 1967

const BUS_32 = 1;


BUSERFLAGS

Bob user Flag for TBob.Flags mask of all user-settable Bob-flags

Declaration

Source position: agraphics.pas line 909

const BUSERFLAGS = $00FF;


BWAITING

Bob System Flag for TBob.Flags set while Bob is waiting on 'after'

Declaration

Source position: agraphics.pas line 911

const BWAITING = $0100;


CleanMe

Declaration

Source position: agraphics.pas line 870

const CleanMe = CleanUp;


CleanUp

Declaration

Source position: agraphics.pas line 869

const CleanUp = $40;


CMAB_DUALPF_DISABLE

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1097

const CMAB_DUALPF_DISABLE = 3;


CMAB_FULLPALETTE

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1091

const CMAB_FULLPALETTE = 0;


CMAB_NO_COLOR_LOAD

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1095

const CMAB_NO_COLOR_LOAD = 2;


CMAB_NO_INTERMED_UPDATE

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1093

const CMAB_NO_INTERMED_UPDATE = 1;


CMAF_DUALPF_DISABLE

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1098

const CMAF_DUALPF_DISABLE = 1 shl CMAB_DUALPF_DISABLE;


CMAF_FULLPALETTE

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1092

const CMAF_FULLPALETTE = 1 shl CMAB_FULLPALETTE;


CMAF_NO_COLOR_LOAD

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1096

const CMAF_NO_COLOR_LOAD = 1 shl CMAB_NO_COLOR_LOAD;


CMAF_NO_INTERMED_UPDATE

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1094

const CMAF_NO_INTERMED_UPDATE = 1 shl CMAB_NO_INTERMED_UPDATE;


CMF_BRDNTRAN

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1081

const CMF_BRDNTRAN = 3;


CMF_BRDRBLNK

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1080

const CMF_BRDRBLNK = 2;


CMF_BRDRSPRT

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1082

const CMF_BRDRSPRT = 6;


CMF_CMTRANS

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1078

const CMF_CMTRANS = 0;


CMF_CPTRANS

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1079

const CMF_CPTRANS = 1;


COLORMAP_TRANSPARENCY

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1068

const COLORMAP_TRANSPARENCY = $01;


COLORMAP_TYPE_V1_2

Colormap type for TColorMap.Type_ WB 1.2

Declaration

Source position: agraphics.pas line 1063

const COLORMAP_TYPE_V1_2 = $00;


COLORMAP_TYPE_V1_4

Declaration

Source position: agraphics.pas line 1064

const COLORMAP_TYPE_V1_4 = $01;


COLORMAP_TYPE_V36

Colormap type for TColorMap.Type_ V36

Declaration

Source position: agraphics.pas line 1065

const COLORMAP_TYPE_V36 = COLORMAP_TYPE_V1_4;


COLORMAP_TYPE_V39

Colormap type for TColorMap.Type_ V39

Declaration

Source position: agraphics.pas line 1066

const COLORMAP_TYPE_V39 = $02;


COLORON

Declaration

Source position: agraphics.pas line 1515

const COLORON = $0200;


COLORPLANE_TRANSPARENCY

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1069

const COLORPLANE_TRANSPARENCY = $02;


COMPLEMENT

Drawing mode: XOR bits into raster

Declaration

Source position: agraphics.pas line 850

const COMPLEMENT = 2;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


COPPER_MOVE

Copper command. Pseudo opcode for move #XXXX,dir

Declaration

Source position: agraphics.pas line 795

const COPPER_MOVE = 0;


COPPER_WAIT

Copper command. Pseudo opcode for wait y,x

Declaration

Source position: agraphics.pas line 796

const COPPER_WAIT = 1;


CPR_NT_LOF

Copper command. Copper instruction only for Longint frames

Declaration

Source position: agraphics.pas line 798

const CPR_NT_LOF = $8000;


CPR_NT_SHT

Copper command. Copper instruction only for long frames

Declaration

Source position: agraphics.pas line 799

const CPR_NT_SHT = $4000;


CPR_NT_SYS

Copper command. Copper user instruction only

Declaration

Source position: agraphics.pas line 800

const CPR_NT_SYS = $2000;


CPRNXTBUF

Copper command. Continue processing with next buffer

Declaration

Source position: agraphics.pas line 797

const CPRNXTBUF = 2;


CR_NEEDS_NO_CONCEALED_RASTERS

Internal ClipRect flag

Declaration

Source position: agraphics.pas line 804

const CR_NEEDS_NO_CONCEALED_RASTERS = 1;


CR_NEEDS_NO_LAYERBLIT_DAMAGE

Internal ClipRect flag

Declaration

Source position: agraphics.pas line 805

const CR_NEEDS_NO_LAYERBLIT_DAMAGE = 2;


CT_ANTIALIAS

Flag for TColorTextFont.ctf_Flags zero background thru fully saturated char

Declaration

Source position: agraphics.pas line 788

const CT_ANTIALIAS = $0004;


CT_COLORFONT

Flag for TColorTextFont.ctf_Flags color map contains designer's colors

Declaration

Source position: agraphics.pas line 786

const CT_COLORFONT = $0001;


CT_COLORMASK

Flag mask for TColorTextFont.ctf_Flags mask to get to all color styles

Declaration

Source position: agraphics.pas line 785

const CT_COLORMASK = $000F;


CT_GREYFONT

Flag for TColorTextFont.ctf_Flags color map describes even-stepped

Declaration

Source position: agraphics.pas line 787

const CT_GREYFONT = $0002;

Description

brightnesses from TColorTextFont.ctf_Low to TColorTextFont.ctf_High


CTB_MAPCOLOR

Flag Bit for TColorTextFont.ctf_Flags

Declaration

Source position: agraphics.pas line 790

const CTB_MAPCOLOR = 0;


CTF_MAPCOLOR

Flag for TColorTextFont.ctf_Flags mapped color

Declaration

Source position: agraphics.pas line 791

const CTF_MAPCOLOR = 1 shl CTB_MAPCOLOR;

Description

Map TColorTextFont.ctf_FgColor to the TRastPort.rp_FgPen. If it's is a valid color from TColorTextFont.ctf_Low to TColorTextFont.ctf_High.


DBL_CAS

Memory Type

Declaration

Source position: agraphics.pas line 1968

const DBL_CAS = 2;


DBLNTSC_MONITOR_ID

Declaration

Source position: agraphics.pas line 1353

const DBLNTSC_MONITOR_ID = $00091000;


DBLNTSCEXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1385

const DBLNTSCEXTRALORES_KEY = $00091200;


DBLNTSCEXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1389

const DBLNTSCEXTRALORESDPF2_KEY = $00091640;


DBLNTSCEXTRALORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1394

const DBLNTSCEXTRALORESDPF2FF_KEY = $00091644;


DBLNTSCEXTRALORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1399

const DBLNTSCEXTRALORESDPF2LACE_KEY = $00091645;


DBLNTSCEXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1388

const DBLNTSCEXTRALORESDPF_KEY = $00091600;


DBLNTSCEXTRALORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1393

const DBLNTSCEXTRALORESDPFFF_KEY = $00091604;


DBLNTSCEXTRALORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1398

const DBLNTSCEXTRALORESDPFLACE_KEY = $00091605;


DBLNTSCEXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1387

const DBLNTSCEXTRALORESEHB_KEY = $00091280;


DBLNTSCEXTRALORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1392

const DBLNTSCEXTRALORESEHBFF_KEY = $00091284;


DBLNTSCEXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1397

const DBLNTSCEXTRALORESEHBLACE_KEY = $00091285;


DBLNTSCEXTRALORESFF_KEY

Declaration

Source position: agraphics.pas line 1390

const DBLNTSCEXTRALORESFF_KEY = $00091204;


DBLNTSCEXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1386

const DBLNTSCEXTRALORESHAM_KEY = $00091a00;


DBLNTSCEXTRALORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1391

const DBLNTSCEXTRALORESHAMFF_KEY = $00091a04;


DBLNTSCEXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1396

const DBLNTSCEXTRALORESHAMLACE_KEY = $00091a05;


DBLNTSCEXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1395

const DBLNTSCEXTRALORESLACE_KEY = $00091205;


DBLNTSCHIRES_KEY

Declaration

Source position: agraphics.pas line 1370

const DBLNTSCHIRES_KEY = $00099000;


DBLNTSCHIRESDPF2_KEY

Declaration

Source position: agraphics.pas line 1382

const DBLNTSCHIRESDPF2_KEY = $00099440;


DBLNTSCHIRESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1383

const DBLNTSCHIRESDPF2FF_KEY = $00099444;


DBLNTSCHIRESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1384

const DBLNTSCHIRESDPF2LACE_KEY = $00099445;


DBLNTSCHIRESDPF_KEY

Declaration

Source position: agraphics.pas line 1379

const DBLNTSCHIRESDPF_KEY = $00099400;


DBLNTSCHIRESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1380

const DBLNTSCHIRESDPFFF_KEY = $00099404;


DBLNTSCHIRESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1381

const DBLNTSCHIRESDPFLACE_KEY = $00099405;


DBLNTSCHIRESEHB_KEY

Declaration

Source position: agraphics.pas line 1376

const DBLNTSCHIRESEHB_KEY = $00099080;


DBLNTSCHIRESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1377

const DBLNTSCHIRESEHBFF_KEY = $00099084;


DBLNTSCHIRESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1378

const DBLNTSCHIRESEHBLACE_KEY = $00099085;


DBLNTSCHIRESFF_KEY

Declaration

Source position: agraphics.pas line 1371

const DBLNTSCHIRESFF_KEY = $00099004;


DBLNTSCHIRESHAM_KEY

Declaration

Source position: agraphics.pas line 1372

const DBLNTSCHIRESHAM_KEY = $00099800;


DBLNTSCHIRESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1373

const DBLNTSCHIRESHAMFF_KEY = $00099804;


DBLNTSCHIRESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1375

const DBLNTSCHIRESHAMLACE_KEY = $00099805;


DBLNTSCHIRESLACE_KEY

Declaration

Source position: agraphics.pas line 1374

const DBLNTSCHIRESLACE_KEY = $00099005;


DBLNTSCLORES_KEY

Declaration

Source position: agraphics.pas line 1355

const DBLNTSCLORES_KEY = $00091000;


DBLNTSCLORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1367

const DBLNTSCLORESDPF2_KEY = $00091440;


DBLNTSCLORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1368

const DBLNTSCLORESDPF2FF_KEY = $00091444;


DBLNTSCLORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1369

const DBLNTSCLORESDPF2LACE_KEY = $00091445;


DBLNTSCLORESDPF_KEY

Declaration

Source position: agraphics.pas line 1364

const DBLNTSCLORESDPF_KEY = $00091400;


DBLNTSCLORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1365

const DBLNTSCLORESDPFFF_KEY = $00091404;


DBLNTSCLORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1366

const DBLNTSCLORESDPFLACE_KEY = $00091405;


DBLNTSCLORESEHB_KEY

Declaration

Source position: agraphics.pas line 1359

const DBLNTSCLORESEHB_KEY = $00091080;


DBLNTSCLORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1360

const DBLNTSCLORESEHBFF_KEY = $00091084;


DBLNTSCLORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1363

const DBLNTSCLORESEHBLACE_KEY = $00091085;


DBLNTSCLORESFF_KEY

Declaration

Source position: agraphics.pas line 1356

const DBLNTSCLORESFF_KEY = $00091004;


DBLNTSCLORESHAM_KEY

Declaration

Source position: agraphics.pas line 1357

const DBLNTSCLORESHAM_KEY = $00091800;


DBLNTSCLORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1358

const DBLNTSCLORESHAMFF_KEY = $00091804;


DBLNTSCLORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1362

const DBLNTSCLORESHAMLACE_KEY = $00091805;


DBLNTSCLORESLACE_KEY

Declaration

Source position: agraphics.pas line 1361

const DBLNTSCLORESLACE_KEY = $00091005;


DBLPAL_MONITOR_ID

Declaration

Source position: agraphics.pas line 1401

const DBLPAL_MONITOR_ID = $000a1000;


DBLPALEXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1433

const DBLPALEXTRALORES_KEY = $000a1200;


DBLPALEXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1437

const DBLPALEXTRALORESDPF2_KEY = $000a1640;


DBLPALEXTRALORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1442

const DBLPALEXTRALORESDPF2FF_KEY = $000a1644;


DBLPALEXTRALORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1447

const DBLPALEXTRALORESDPF2LACE_KEY = $000a1645;


DBLPALEXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1436

const DBLPALEXTRALORESDPF_KEY = $000a1600;


DBLPALEXTRALORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1441

const DBLPALEXTRALORESDPFFF_KEY = $000a1604;


DBLPALEXTRALORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1446

const DBLPALEXTRALORESDPFLACE_KEY = $000a1605;


DBLPALEXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1435

const DBLPALEXTRALORESEHB_KEY = $000a1280;


DBLPALEXTRALORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1440

const DBLPALEXTRALORESEHBFF_KEY = $000a1284;


DBLPALEXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1445

const DBLPALEXTRALORESEHBLACE_KEY = $000a1285;


DBLPALEXTRALORESFF_KEY

Declaration

Source position: agraphics.pas line 1438

const DBLPALEXTRALORESFF_KEY = $000a1204;


DBLPALEXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1434

const DBLPALEXTRALORESHAM_KEY = $000a1a00;


DBLPALEXTRALORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1439

const DBLPALEXTRALORESHAMFF_KEY = $000a1a04;


DBLPALEXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1444

const DBLPALEXTRALORESHAMLACE_KEY = $000a1a05;


DBLPALEXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1443

const DBLPALEXTRALORESLACE_KEY = $000a1205;


DBLPALHIRES_KEY

Declaration

Source position: agraphics.pas line 1418

const DBLPALHIRES_KEY = $000a9000;


DBLPALHIRESDPF2_KEY

Declaration

Source position: agraphics.pas line 1430

const DBLPALHIRESDPF2_KEY = $000a9440;


DBLPALHIRESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1431

const DBLPALHIRESDPF2FF_KEY = $000a9444;


DBLPALHIRESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1432

const DBLPALHIRESDPF2LACE_KEY = $000a9445;


DBLPALHIRESDPF_KEY

Declaration

Source position: agraphics.pas line 1427

const DBLPALHIRESDPF_KEY = $000a9400;


DBLPALHIRESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1428

const DBLPALHIRESDPFFF_KEY = $000a9404;


DBLPALHIRESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1429

const DBLPALHIRESDPFLACE_KEY = $000a9405;


DBLPALHIRESEHB_KEY

Declaration

Source position: agraphics.pas line 1424

const DBLPALHIRESEHB_KEY = $000a9080;


DBLPALHIRESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1425

const DBLPALHIRESEHBFF_KEY = $000a9084;


DBLPALHIRESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1426

const DBLPALHIRESEHBLACE_KEY = $000a9085;


DBLPALHIRESFF_KEY

Declaration

Source position: agraphics.pas line 1419

const DBLPALHIRESFF_KEY = $000a9004;


DBLPALHIRESHAM_KEY

Declaration

Source position: agraphics.pas line 1420

const DBLPALHIRESHAM_KEY = $000a9800;


DBLPALHIRESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1421

const DBLPALHIRESHAMFF_KEY = $000a9804;


DBLPALHIRESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1423

const DBLPALHIRESHAMLACE_KEY = $000a9805;


DBLPALHIRESLACE_KEY

Declaration

Source position: agraphics.pas line 1422

const DBLPALHIRESLACE_KEY = $000a9005;


DBLPALLORES_KEY

Declaration

Source position: agraphics.pas line 1403

const DBLPALLORES_KEY = $000a1000;


DBLPALLORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1415

const DBLPALLORESDPF2_KEY = $000a1440;


DBLPALLORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1416

const DBLPALLORESDPF2FF_KEY = $000a1444;


DBLPALLORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1417

const DBLPALLORESDPF2LACE_KEY = $000a1445;


DBLPALLORESDPF_KEY

Declaration

Source position: agraphics.pas line 1412

const DBLPALLORESDPF_KEY = $000a1400;


DBLPALLORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1413

const DBLPALLORESDPFFF_KEY = $000a1404;


DBLPALLORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1414

const DBLPALLORESDPFLACE_KEY = $000a1405;


DBLPALLORESEHB_KEY

Declaration

Source position: agraphics.pas line 1407

const DBLPALLORESEHB_KEY = $000a1080;


DBLPALLORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1408

const DBLPALLORESEHBFF_KEY = $000a1084;


DBLPALLORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1411

const DBLPALLORESEHBLACE_KEY = $000a1085;


DBLPALLORESFF_KEY

Declaration

Source position: agraphics.pas line 1404

const DBLPALLORESFF_KEY = $000a1004;


DBLPALLORESHAM_KEY

Declaration

Source position: agraphics.pas line 1405

const DBLPALLORESHAM_KEY = $000a1800;


DBLPALLORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1406

const DBLPALLORESHAMFF_KEY = $000a1804;


DBLPALLORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1410

const DBLPALLORESHAMLACE_KEY = $000a1805;


DBLPALLORESLACE_KEY

Declaration

Source position: agraphics.pas line 1409

const DBLPALLORESLACE_KEY = $000a1005;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DBLPF

Declaration

Source position: agraphics.pas line 1516

const DBLPF = $400;


DBUFFER

Flag set when RastPorts are double-buffered

Declaration

Source position: agraphics.pas line 856

const DBUFFER = $04;

See also

TRastPort

Basic structure for all drawing actions


DEFAULT_MONITOR_ID

Declaration

Source position: agraphics.pas line 1178

const DEFAULT_MONITOR_ID = $00000000;


DEFAULT_MONITOR_NAME

Declaration

Source position: agraphics.pas line 988

const DEFAULT_MONITOR_NAME: PChar = 'default.monitor';


DFTCH_MASK

Declaration

Source position: agraphics.pas line 1528

const DFTCH_MASK = $FF;


DI_AVAIL_NOCHIPS

Availability for TDisplayInfo.NotAvailable

Declaration

Source position: agraphics.pas line 1450

const DI_AVAIL_NOCHIPS = $0001;


DI_AVAIL_NOMONITOR

Availability for TDisplayInfo.NotAvailable

Declaration

Source position: agraphics.pas line 1451

const DI_AVAIL_NOMONITOR = $0002;


DI_AVAIL_NOTWITHGENLOCK

Availability for TDisplayInfo.NotAvailable

Declaration

Source position: agraphics.pas line 1452

const DI_AVAIL_NOTWITHGENLOCK = $0004;


DIPF_IS_AA

Flag for TDisplayInfo.PropertyFlagsAA modes - may only be available if machine has correct memory type to support required bandwidth - check availability.

Declaration

Source position: agraphics.pas line 1459

const DIPF_IS_AA = $00010000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_BEAMSYNC

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1468

const DIPF_IS_BEAMSYNC = $00000800;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_DBUFFER

Flag for TDisplayInfo.PropertyFlags Mode supports double buffering

Declaration

Source position: agraphics.pas line 1479

const DIPF_IS_DBUFFER = $00100000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_DRAGGABLE

Flag for TDisplayInfo.PropertyFlags Mode can be dragged down

Declaration

Source position: agraphics.pas line 1466

const DIPF_IS_DRAGGABLE = $00000200;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_DUALPF

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1455

const DIPF_IS_DUALPF = $00000002;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_ECS

Flag for TDisplayInfo.PropertyFlags Mode which needs ECS Chipset (SHIRES, VGA, AND PRODUCTIVITY) do not support attached sprites.

Declaration

Source position: agraphics.pas line 1458

const DIPF_IS_ECS = $00000010;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_EXTRAHALFBRITE

Flag for TDisplayInfo.PropertyFlags EHB mode

Declaration

Source position: agraphics.pas line 1470

const DIPF_IS_EXTRAHALFBRITE = $00001000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_FOREIGN

Flag for TDisplayInfo.PropertyFlagsMode is not native to the Amiga

Declaration

Source position: agraphics.pas line 1481

const DIPF_IS_FOREIGN = $80000000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_GENLOCK

Flag for TDisplayInfo.PropertyFlags Mode wich support Genlocks

Declaration

Source position: agraphics.pas line 1463

const DIPF_IS_GENLOCK = $00000080;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_HAM

Flag for TDisplayInfo.PropertyFlags HAM6/8 Mode

Declaration

Source position: agraphics.pas line 1457

const DIPF_IS_HAM = $00000008;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_LACE

Flag for TDisplayInfo.PropertyFlags Interlace mode

Declaration

Source position: agraphics.pas line 1454

const DIPF_IS_LACE = $00000001;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_PAL

Flag for TDisplayInfo.PropertyFlags PAL Mode

Declaration

Source position: agraphics.pas line 1461

const DIPF_IS_PAL = $00000020;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_PANELLED

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1467

const DIPF_IS_PANELLED = $00000400;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_PF2PRI

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1456

const DIPF_IS_PF2PRI = $00000004;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_PROGBEAM

Flag for TDisplayInfo.PropertyFlags Mode is a programmed beam-sync mode

Declaration

Source position: agraphics.pas line 1480

const DIPF_IS_PROGBEAM = $00200000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_SCANDBL

Flag for TDisplayInfo.PropertyFlags Scan doubled mode

Declaration

Source position: agraphics.pas line 1476

const DIPF_IS_SCANDBL = $00020000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_SPRITES

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1462

const DIPF_IS_SPRITES = $00000040;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_SPRITES_ATT

Flag for TDisplayInfo.PropertyFlags Mode supports attached sprites

Declaration

Source position: agraphics.pas line 1473

const DIPF_IS_SPRITES_ATT = $00002000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_SPRITES_BORDER

Flag for TDisplayInfo.PropertyFlags Sprite can be displayed in the border

Declaration

Source position: agraphics.pas line 1475

const DIPF_IS_SPRITES_BORDER = $00008000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_SPRITES_CHNG_BASE

Flag for TDisplayInfo.PropertyFlags Mode can change the sprite base color

Declaration

Source position: agraphics.pas line 1477

const DIPF_IS_SPRITES_CHNG_BASE = $00040000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_SPRITES_CHNG_PRI

Flag for TDisplayInfo.PropertyFlags Mode can change the sprite priority with respect to the playfield(s).

Declaration

Source position: agraphics.pas line 1478

const DIPF_IS_SPRITES_CHNG_PRI = $00080000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_SPRITES_CHNG_RES

Flag for TDisplayInfo.PropertyFlags Mode supports variable sprite resolution

Declaration

Source position: agraphics.pas line 1474

const DIPF_IS_SPRITES_CHNG_RES = $00004000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DIPF_IS_WB

Flag for TDisplayInfo.PropertyFlags Mode is useable for Workbench/Wanderer

Declaration

Source position: agraphics.pas line 1465

const DIPF_IS_WB = $00000100;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


DisplayInfoHandle

The "public" handle to a DisplayInfoRecord

Declaration

Source position: agraphics.pas line 1536

type DisplayInfoHandle = Pointer;


DISPLAYNAMELEN

Max name of monitor names see TNameInfo.Name

Declaration

Source position: agraphics.pas line 1616

const DISPLAYNAMELEN = 32;


DIW_HORIZ_POS

Declaration

Source position: agraphics.pas line 1524

const DIW_HORIZ_POS = $7F;


DIW_VRTCL_POS

Declaration

Source position: agraphics.pas line 1525

const DIW_VRTCL_POS = $1FF;


DIW_VRTCL_POS_SHIFT

Declaration

Source position: agraphics.pas line 1526

const DIW_VRTCL_POS_SHIFT = $7;


DOUBLESCAN

Declaration

Source position: agraphics.pas line 743

const DOUBLESCAN = 1 shl 3;


DTAG_DIMS

GetDisplayInfoData, results in PDimensionInfo

Declaration

Source position: agraphics.pas line 1542

const DTAG_DIMS = $80001000;


DTAG_DISP

Start tag for GetDisplayInfoData

Declaration

Source position: agraphics.pas line 1541

const DTAG_DISP = $80000000;


DTAG_MNTR

GetDisplayInfoData, results in PMonitorInfo

Declaration

Source position: agraphics.pas line 1543

const DTAG_MNTR = $80002000;


DTAG_NAME

GetDisplayInfoData, results in PNameInfo

Declaration

Source position: agraphics.pas line 1544

const DTAG_NAME = $80003000;


DTAG_VEC

GetDisplayInfoData, Internal use only (PVecInfo)

Declaration

Source position: agraphics.pas line 1545

const DTAG_VEC = $80004000;


DUALPF

Declaration

Source position: agraphics.pas line 748

const DUALPF = 1 shl 10;


EURO36_MONITOR_ID

Declaration

Source position: agraphics.pas line 1333

const EURO36_MONITOR_ID = $00071000;


EURO72_MONITOR_ID

Declaration

Source position: agraphics.pas line 1283

const EURO72_MONITOR_ID = $00061000;


EURO72EHB_KEY

Declaration

Source position: agraphics.pas line 1318

const EURO72EHB_KEY = $000690a4;


EURO72EHBLACE_KEY

Declaration

Source position: agraphics.pas line 1319

const EURO72EHBLACE_KEY = $000690a5;


EURO72EXTRAHALFBRITE_KEY

Declaration

Source position: agraphics.pas line 1305

const EURO72EXTRAHALFBRITE_KEY = $00061084;


EURO72EXTRAHALFBRITELACE_KEY

Declaration

Source position: agraphics.pas line 1306

const EURO72EXTRAHALFBRITELACE_KEY = $00061085;


EURO72EXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1285

const EURO72EXTRALORES_KEY = $00061004;


EURO72EXTRALORESDBL_KEY

Declaration

Source position: agraphics.pas line 1323

const EURO72EXTRALORESDBL_KEY = $00061000;


EURO72EXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1299

const EURO72EXTRALORESDPF2_KEY = $00061444;


EURO72EXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1293

const EURO72EXTRALORESDPF_KEY = $00061404;


EURO72EXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1314

const EURO72EXTRALORESEHB_KEY = EURO72EXTRAHALFBRITE_KEY;


EURO72EXTRALORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1329

const EURO72EXTRALORESEHBDBL_KEY = $00061080;


EURO72EXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1315

const EURO72EXTRALORESEHBLACE_KEY = EURO72EXTRAHALFBRITELACE_KEY;


EURO72EXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1312

const EURO72EXTRALORESHAM_KEY = EURO72HAM_KEY;


EURO72EXTRALORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1326

const EURO72EXTRALORESHAMDBL_KEY = $00061800;


EURO72EXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1313

const EURO72EXTRALORESHAMLACE_KEY = EURO72HAMLACE_KEY;


EURO72EXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1289

const EURO72EXTRALORESLACE_KEY = $00061005;


EURO72EXTRALORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1302

const EURO72EXTRALORESLACEDPF2_KEY = $00061445;


EURO72EXTRALORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1296

const EURO72EXTRALORESLACEDPF_KEY = $00061405;


EURO72HAM_KEY

Declaration

Source position: agraphics.pas line 1288

const EURO72HAM_KEY = $00061804;


EURO72HAMLACE_KEY

Declaration

Source position: agraphics.pas line 1292

const EURO72HAMLACE_KEY = $00061805;


EURO72LORES_KEY

Declaration

Source position: agraphics.pas line 1286

const EURO72LORES_KEY = $00069004;


EURO72LORESDBL_KEY

Declaration

Source position: agraphics.pas line 1324

const EURO72LORESDBL_KEY = $00069000;


EURO72LORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1300

const EURO72LORESDPF2_KEY = $00069444;


EURO72LORESDPF_KEY

Declaration

Source position: agraphics.pas line 1294

const EURO72LORESDPF_KEY = $00069404;


EURO72LORESEHB_KEY

Declaration

Source position: agraphics.pas line 1316

const EURO72LORESEHB_KEY = $00069084;


EURO72LORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1330

const EURO72LORESEHBDBL_KEY = $00069080;


EURO72LORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1317

const EURO72LORESEHBLACE_KEY = $00069085;


EURO72LORESHAM_KEY

Declaration

Source position: agraphics.pas line 1310

const EURO72LORESHAM_KEY = $00069804;


EURO72LORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1327

const EURO72LORESHAMDBL_KEY = $00069800;


EURO72LORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1311

const EURO72LORESHAMLACE_KEY = $00069805;


EURO72LORESLACE_KEY

Declaration

Source position: agraphics.pas line 1290

const EURO72LORESLACE_KEY = $00069005;


EURO72LORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1303

const EURO72LORESLACEDPF2_KEY = $00069445;


EURO72LORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1297

const EURO72LORESLACEDPF_KEY = $00069405;


EURO72PRODUCT_KEY

Declaration

Source position: agraphics.pas line 1287

const EURO72PRODUCT_KEY = $00069024;


EURO72PRODUCTDBL_KEY

Declaration

Source position: agraphics.pas line 1325

const EURO72PRODUCTDBL_KEY = $00069020;


EURO72PRODUCTDPF2_KEY

Declaration

Source position: agraphics.pas line 1301

const EURO72PRODUCTDPF2_KEY = $00069464;


EURO72PRODUCTDPF_KEY

Declaration

Source position: agraphics.pas line 1295

const EURO72PRODUCTDPF_KEY = $00069424;


EURO72PRODUCTEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1331

const EURO72PRODUCTEHBDBL_KEY = $000690a0;


EURO72PRODUCTHAM_KEY

Declaration

Source position: agraphics.pas line 1308

const EURO72PRODUCTHAM_KEY = $00069824;


EURO72PRODUCTHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1328

const EURO72PRODUCTHAMDBL_KEY = $00069820;


EURO72PRODUCTHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1309

const EURO72PRODUCTHAMLACE_KEY = $00069825;


EURO72PRODUCTLACE_KEY

Declaration

Source position: agraphics.pas line 1291

const EURO72PRODUCTLACE_KEY = $00069025;


EURO72PRODUCTLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1304

const EURO72PRODUCTLACEDPF2_KEY = $00069465;


EURO72PRODUCTLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1298

const EURO72PRODUCTLACEDPF_KEY = $00069425;


EXACT_LINE

Declaration

Source position: agraphics.pas line 845

const EXACT_LINE = 1;


EXTEND_VSTRUCT

Unused bit in Modes field of View TViewPort

Declaration

Source position: agraphics.pas line 1076

const EXTEND_VSTRUCT = $1000;


EXTENDED_MODE

Declaration

Source position: agraphics.pas line 750

const EXTENDED_MODE = 1 shl 12;


EXTRA_HALFBRITE

Declaration

Source position: agraphics.pas line 746

const EXTRA_HALFBRITE = 1 shl 7;


EXTRAHALFBRITE_KEY

Declaration

Source position: agraphics.pas line 1209

const EXTRAHALFBRITE_KEY = $00000080;


EXTRAHALFBRITELACE_KEY

Declaration

Source position: agraphics.pas line 1210

const EXTRAHALFBRITELACE_KEY = $00000084;


FPB_DESIGNED

Flag Bit size is "designed", not constructed

Declaration

Source position: agraphics.pas line 839

const FPB_DESIGNED = 6;


FPB_DISKFONT

Flag Bit font is from diskfont.library

Declaration

Source position: agraphics.pas line 829

const FPB_DISKFONT = 1;


FPB_PROPORTIONAL

Flag Bit character sizes can vary from nominal

Declaration

Source position: agraphics.pas line 837

const FPB_PROPORTIONAL = 5;


FPB_REMOVED

Flag Bit the font has been removed

Declaration

Source position: agraphics.pas line 841

const FPB_REMOVED = 7;


FPB_REVPATH

Flag Bit designed path is reversed (e.g. left)

Declaration

Source position: agraphics.pas line 831

const FPB_REVPATH = 2;


FPB_ROMFONT

Flag Bit font is in rom

Declaration

Source position: agraphics.pas line 827

const FPB_ROMFONT = 0;


FPB_TALLDOT

Flag Bit designed for hires non-interlaced

Declaration

Source position: agraphics.pas line 833

const FPB_TALLDOT = 3;


FPB_WIDEDOT

Flag Bit designed for lores interlaced

Declaration

Source position: agraphics.pas line 835

const FPB_WIDEDOT = 4;


FPF_DESIGNED

Flag value size is "designed", not constructed

Declaration

Source position: agraphics.pas line 840

const FPF_DESIGNED = 1 shl FPB_DESIGNED;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_DISKFONT

Flag value font is from diskfont.library

Declaration

Source position: agraphics.pas line 830

const FPF_DISKFONT = 1 shl FPB_DISKFONT;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_PROPORTIONAL

Flag value character sizes can vary from nominal

Declaration

Source position: agraphics.pas line 838

const FPF_PROPORTIONAL = 1 shl FPB_PROPORTIONAL;

Description

For TTextAttr.ta_Flags, TTTextAttr.tta_Flags


FPF_REMOVED

Flag value the font has been removed

Declaration

Source position: agraphics.pas line 842

const FPF_REMOVED = 1 shl FPB_REMOVED;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_REVPATH

Flag value designed path is reversed (e.g. left)

Declaration

Source position: agraphics.pas line 832

const FPF_REVPATH = 1 shl FPB_REVPATH;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_ROMFONT

Flag value font is in rom

Declaration

Source position: agraphics.pas line 828

const FPF_ROMFONT = 1 shl FPB_ROMFONT;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_TALLDOT

Flag value designed for hires non-interlaced

Declaration

Source position: agraphics.pas line 834

const FPF_TALLDOT = 1 shl FPB_TALLDOT;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_WIDEDOT

Flag value designed for lores interlaced

Declaration

Source position: agraphics.pas line 836

const FPF_WIDEDOT = 1 shl FPB_WIDEDOT;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FROM_MONITOR

Declaration

Source position: agraphics.pas line 965

const FROM_MONITOR = 1;


FRST_DOT

Draw the first dot of this line

Declaration

Source position: agraphics.pas line 854

const FRST_DOT = $01;

See also

TRastPort

Basic structure for all drawing actions


FS_NORMAL

Bit Font Style normal text (no style bits set)

Declaration

Source position: agraphics.pas line 813

const FS_NORMAL = 0;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSB_BOLD

Bit Font Style bold face text (ORed w/ shifted)

Declaration

Source position: agraphics.pas line 816

const FSB_BOLD = 1;


FSB_COLORFONT

Bit Font Style this uses ColorTextFont structure

Declaration

Source position: agraphics.pas line 822

const FSB_COLORFONT = 6;


FSB_EXTENDED

Bit Font Style extended face (wider than normal)

Declaration

Source position: agraphics.pas line 820

const FSB_EXTENDED = 3;


FSB_ITALIC

Bit Font Style italic (slanted 1:2 right)

Declaration

Source position: agraphics.pas line 818

const FSB_ITALIC = 2;


FSB_TAGGED

Bit Font Style the TextAttr is really an TTextAttr

Declaration

Source position: agraphics.pas line 824

const FSB_TAGGED = 7;


FSB_UNDERLINED

Bit Font Style underlined (under baseline)

Declaration

Source position: agraphics.pas line 814

const FSB_UNDERLINED = 0;


FSF_BOLD

Font Style bold face text (ORed w/ shifted)

Declaration

Source position: agraphics.pas line 817

const FSF_BOLD = 1 shl FSB_BOLD;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_COLORFONT

Bit Font Style this uses ColorTextFont structure

Declaration

Source position: agraphics.pas line 823

const FSF_COLORFONT = 1 shl FSB_COLORFONT;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_EXTENDED

Font Style extended face (wider than normal)

Declaration

Source position: agraphics.pas line 821

const FSF_EXTENDED = 1 shl FSB_EXTENDED;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_ITALIC

Font Style italic (slanted 1:2 right)

Declaration

Source position: agraphics.pas line 819

const FSF_ITALIC = 1 shl FSB_ITALIC;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_TAGGED

Font Style the TextAttr is really an TTextAttr

Declaration

Source position: agraphics.pas line 825

const FSF_TAGGED = 1 shl FSB_TAGGED;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_UNDERLINED

Font Style underlined (under baseline)

Declaration

Source position: agraphics.pas line 815

const FSF_UNDERLINED = 1 shl FSB_UNDERLINED;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


GELGONE

System Set flag for TVsprite.Flags. Set if gel is completely clipped (offscreen)

Declaration

Source position: agraphics.pas line 903

const GELGONE = $0400;


GENLOC

Flag for TGfxBase.DisplayFlags Genlock is in use

Declaration

Source position: agraphics.pas line 1935

const GENLOC = 2;


GENLOCK_AUDIO

Declaration

Source position: agraphics.pas line 747

const GENLOCK_AUDIO = 1 shl 8;


GENLOCK_VIDEO

Declaration

Source position: agraphics.pas line 741

const GENLOCK_VIDEO = 1 shl 1;


GFXB_AA_ALICE

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1947

const GFXB_AA_ALICE = 2;


GFXB_AA_LISA

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1948

const GFXB_AA_LISA = 3;


GFXB_AA_MLISA

Bit defintion for TGfxBase.ChipRevBits0 Internal use only

Declaration

Source position: agraphics.pas line 1949

const GFXB_AA_MLISA = 4;


GFXB_BIG_BLITS

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1944

const GFXB_BIG_BLITS = 0;


GFXB_HR_AGNUS

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1945

const GFXB_HR_AGNUS = 0;


GFXB_HR_DENISE

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1946

const GFXB_HR_DENISE = 1;


GfxBase

Graphics base library pointer for all graphics library functions, opened on unit initialization

Declaration

Source position: agraphics.pas line 1981

var GfxBase: PGfxBase = Nil;


GFXF_AA_ALICE

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1954

const GFXF_AA_ALICE = 1 shl GFXB_AA_ALICE;


GFXF_AA_LISA

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1955

const GFXF_AA_LISA = 1 shl GFXB_AA_LISA;


GFXF_AA_MLISA

Bit value for TGfxBase.ChipRevBits0 internal use only

Declaration

Source position: agraphics.pas line 1956

const GFXF_AA_MLISA = 1 shl GFXB_AA_MLISA;


GFXF_BIG_BLITS

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1951

const GFXF_BIG_BLITS = 1 shl GFXB_BIG_BLITS;


GFXF_HR_AGNUS

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1952

const GFXF_HR_AGNUS = 1 shl GFXB_HR_AGNUS;


GFXF_HR_DENISE

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 1953

const GFXF_HR_DENISE = 1 shl GFXB_HR_DENISE;


GRAPHICSNAME

Name of graphics library

Declaration

Source position: agraphics.pas line 1978

const GRAPHICSNAME: PChar = 'graphics.library';


GSTAG_ATTACHED

Tag for GetExtSpriteA()

Declaration

Source position: agraphics.pas line 1761

const GSTAG_ATTACHED = $82000022;


GSTAG_SCANDOUBLED

Tag for GetExtSpriteA() or ChangeExtSpriteA() request "NTSC-Like" height if possible.

Declaration

Source position: agraphics.pas line 1765

const GSTAG_SCANDOUBLED = $83000000;


GSTAG_SOFTSPRITE

Tag for GetExtSpriteA()

Declaration

Source position: agraphics.pas line 1762

const GSTAG_SOFTSPRITE = $82000024;


GSTAG_SPRITE_NUM

Tag for GetExtSpriteA()

Declaration

Source position: agraphics.pas line 1760

const GSTAG_SPRITE_NUM = $82000020;


HALF_LINE

Declaration

Source position: agraphics.pas line 846

const HALF_LINE = 2;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

HAM

Declaration

Source position: agraphics.pas line 749

const HAM = 1 shl 11;


HAM_KEY

Declaration

Source position: agraphics.pas line 1192

const HAM_KEY = $00000800;


HAMLACE_KEY

Declaration

Source position: agraphics.pas line 1196

const HAMLACE_KEY = $00000804;


HIRES

Declaration

Source position: agraphics.pas line 753

const HIRES = 1 shl 15;


HIRES_KEY

Declaration

Source position: agraphics.pas line 1190

const HIRES_KEY = $00008000;


HIRESDPF2_KEY

Declaration

Source position: agraphics.pas line 1204

const HIRESDPF2_KEY = $00008440;


HIRESDPF_KEY

Declaration

Source position: agraphics.pas line 1198

const HIRESDPF_KEY = $00008400;


HIRESEHB_KEY

Declaration

Source position: agraphics.pas line 1214

const HIRESEHB_KEY = $00008080;


HIRESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1218

const HIRESEHBLACE_KEY = $00008084;


HIRESHAM_KEY

Declaration

Source position: agraphics.pas line 1212

const HIRESHAM_KEY = $00008800;


HIRESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1216

const HIRESHAMLACE_KEY = $00008804;


HIRESHAMSDBL_KEY

Declaration

Source position: agraphics.pas line 1224

const HIRESHAMSDBL_KEY = $00008808;


HIRESLACE_KEY

Declaration

Source position: agraphics.pas line 1194

const HIRESLACE_KEY = $00008004;


HIRESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1207

const HIRESLACEDPF2_KEY = $00008444;


HIRESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1201

const HIRESLACEDPF_KEY = $00008404;


HOLDNMODIFY

Declaration

Source position: agraphics.pas line 1517

const HOLDNMODIFY = $800;


IGNORE_MCOMPAT

Flags for CoerceMode Coercion should ignore monitor compatibility issues.

Declaration

Source position: agraphics.pas line 887

const IGNORE_MCOMPAT = 4;


Reference for unit 'agraphics'

Native Amiga graphic functions (graphics.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
hardware,
utility; | Tag Handling, Date routines in utility.library

Overview

The Graphics library provide graphic functions for graphic centered programs. Beside drawing lines and circles, set points it provides function for Sprite-, Bob and VSprite manipulation. There are also some functions to work together with the layers.library.


Reference for unit 'agraphics': Constants

A2024FIFTEENHERTZ_KEY |
A2024TENHERTZ_KEY |
A2024_MONITOR_ID |
ANFRACSIZE | Define for the animation procedures
ANIMHALF | Define for the animation procedures
AREAOUTLINE | Used by areafiller only used for bobs
AVOID_FLICKER | Flag for CoerceMode Ensure that the mode coerced to is not interlaced.
B2BOBBER |
B2NORM |
B2SWAP |
BACKSAVED | System Set flag for TVsprite.Flags. This Bob's background has been saved
BANDWIDTH_1X | Memory Type
BANDWIDTH_2XDBL | Memory Type
BANDWIDTH_2XNML | Memory Type
BANDWIDTH_4X | Memory Type
BDRAWN | Bob System Flag for TBob.Flags set when Bob is drawn this DrawG pass
BIDTAG_BlueBits | Tag for BestModeID() Match up from the DataBase default - 4
BIDTAG_COERCE | Flags for CoerceMode Private
BIDTAG_Depth | Tag for BestModeID() ModeID must support this depth. Default - TViewPort.RasInfo^.BitMap^.Depth or 1
BIDTAG_DesiredHeight | Tag for BestModeID() Nominal Height of the returned ModeID. Default - same as Nominal
BIDTAG_DesiredWidth | Tag for BestModeID() Nominal Width of the returned ModeID. Default - same as Nominal
BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS
BIDTAG_GfxPrivate | Tag for BestModeID() Private do not use
BIDTAG_GreenBits | Tag for BestModeID() Match up from the DataBase default - 4
BIDTAG_MonitorID | Tag for BestModeID() ModeID must use this monitor. Default - use best monitor available
BIDTAG_NominalHeight | Tag for BestModeID() Override the TViewPort.Height. Default - SourceID NominalDimensionInfo or TViewPort.DHeight or 200 in that order
BIDTAG_NominalWidth | Tag for BestModeID() Override the TViewPort.Width. Default - SourceID NominalDimensionInfo or TViewPort.DWidth or 640 in that order
BIDTAG_RedBits | Tag for BestModeID() Match up from the DataBase default - 4
BIDTAG_SourceID | Tag for BestModeID() Instead of a ViewPort. Default - VPModeID(vp) if BIDTAG_ViewPort is specified, else leave the BIDTAG_DIPFMustHave and BIDTAG_DIPFMustNotHave values untouched.
BIDTAG_ViewPort | Tag for BestModeID() ViewPort for which a ModeID is sought. Default - nil
BITCLR |
BITSET |
BLITMSG_FAULT |
BltClearWait | Waits for blit to finish
BltClearXY | Use Row/Bytes per row method
BMA_DEPTH | ID are for GetBitMapAttr. Query depth of bitmap.
BMA_FLAGS | ID are for GetBitMapAttr. Query Flags (BMF_*) of bitmap.
BMA_HEIGHT | ID are for GetBitMapAttr. Query height of bitmap.
BMA_WIDTH | ID are for GetBitMapAttr. Query width of bitmap.
BMB_CLEAR | Bit flag for AllocBitMap Fill Bitmap with color 0
BMB_DISPLAYABLE | Bit flag for AllocBitMap Displayable Bitmap
BMB_INTERLEAVED | Bit flag for AllocBitMap Interleaved Bitmap
BMB_MINPLANES | Bit flag for AllocBitMap Minimal memory use
BMB_STANDARD | Bit flag for AllocBitMap
BMF_CLEAR | Bit value for AllocBitMap Fill Bitmap with color 0
BMF_DISPLAYABLE | Bit flag for AllocBitMap Displayable Bitmap
BMF_INTERLEAVED | Bit flag for AllocBitMap Interleaved Bitmap
BMF_MINPLANES | Bit value for AllocBitMap Minimal memory use
BMF_STANDARD | Bit value for AllocBitMap
BOBISCOMP | Bob User Flag for TBob.Flags set to identify Bob as AnimComp
BOBNIX | Bob System Flag for TBob.Flags Set when Bob is completely removed
BOBSAWAY | Bob System Flag for TBob.Flags Set to initiate removal of Bob
BOBUPDATE | System Set flag for TVsprite.Flags. Temporary flag, useless to outside world
BORDERHIT | Bit Description for SetCollision
BORDERSPRITES | Flag value for TColorMap.Flags
BORDER_BLANKING | Flag value for TColorMap.Flags
BORDER_NOTRANSPARENCY | Flag value for TColorMap.Flags
BOTTOMHIT | Bit Description for SetCollision
BROADCAST_BEAMCON |
BROADCAST_HBSTOP |
BROADCAST_HBSTRT |
BROADCAST_HSSTOP |
BROADCAST_HSSTRT |
BROADCAST_VBSTOP |
BROADCAST_VBSTRT |
BROADCAST_VSSTOP |
BROADCAST_VSSTRT |
BUSERFLAGS | Bob user Flag for TBob.Flags mask of all user-settable Bob-flags
BUS_16 | Memory Type
BUS_32 | Memory Type
BWAITING | Bob System Flag for TBob.Flags set while Bob is waiting on 'after'
CleanMe |
CleanUp |
CMAB_DUALPF_DISABLE | Flag bit for TColorMap.AuxFlags
CMAB_FULLPALETTE | Flag bit for TColorMap.AuxFlags
CMAB_NO_COLOR_LOAD | Flag bit for TColorMap.AuxFlags
CMAB_NO_INTERMED_UPDATE | Flag bit for TColorMap.AuxFlags
CMAF_DUALPF_DISABLE | Flag value for TColorMap.AuxFlags
CMAF_FULLPALETTE | Flag value for TColorMap.AuxFlags
CMAF_NO_COLOR_LOAD | Flag value for TColorMap.AuxFlags
CMAF_NO_INTERMED_UPDATE | Flag value for TColorMap.AuxFlags
CMF_BRDNTRAN | Flag Bit for TColorMap.Flags
CMF_BRDRBLNK | Flag Bit for TColorMap.Flags
CMF_BRDRSPRT | Flag Bit for TColorMap.Flags
CMF_CMTRANS | Flag Bit for TColorMap.Flags
CMF_CPTRANS | Flag Bit for TColorMap.Flags
COLORMAP_TRANSPARENCY | Flag value for TColorMap.Flags
COLORMAP_TYPE_V1_2 | Colormap type for TColorMap.Type_ WB 1.2
COLORMAP_TYPE_V1_4 |
COLORMAP_TYPE_V36 | Colormap type for TColorMap.Type_ V36
COLORMAP_TYPE_V39 | Colormap type for TColorMap.Type_ V39
COLORON |
COLORPLANE_TRANSPARENCY | Flag value for TColorMap.Flags
COMPLEMENT | Drawing mode: XOR bits into raster
COPPER_MOVE | Copper command. Pseudo opcode for move #XXXX,dir
COPPER_WAIT | Copper command. Pseudo opcode for wait y,x
CPRNXTBUF | Copper command. Continue processing with next buffer
CPR_NT_LOF | Copper command. Copper instruction only for Longint frames
CPR_NT_SHT | Copper command. Copper instruction only for long frames
CPR_NT_SYS | Copper command. Copper user instruction only
CR_NEEDS_NO_CONCEALED_RASTERS | Internal ClipRect flag
CR_NEEDS_NO_LAYERBLIT_DAMAGE | Internal ClipRect flag
CTB_MAPCOLOR | Flag Bit for TColorTextFont.ctf_Flags
CTF_MAPCOLOR | Flag for TColorTextFont.ctf_Flags mapped color
CT_ANTIALIAS | Flag for TColorTextFont.ctf_Flags zero background thru fully saturated char
CT_COLORFONT | Flag for TColorTextFont.ctf_Flags color map contains designer's colors
CT_COLORMASK | Flag mask for TColorTextFont.ctf_Flags mask to get to all color styles
CT_GREYFONT | Flag for TColorTextFont.ctf_Flags color map describes even-stepped
DBLNTSCEXTRALORESDPF2FF_KEY |
DBLNTSCEXTRALORESDPF2LACE_KEY |
DBLNTSCEXTRALORESDPF2_KEY |
DBLNTSCEXTRALORESDPFFF_KEY |
DBLNTSCEXTRALORESDPFLACE_KEY |
DBLNTSCEXTRALORESDPF_KEY |
DBLNTSCEXTRALORESEHBFF_KEY |
DBLNTSCEXTRALORESEHBLACE_KEY |
DBLNTSCEXTRALORESEHB_KEY |
DBLNTSCEXTRALORESFF_KEY |
DBLNTSCEXTRALORESHAMFF_KEY |
DBLNTSCEXTRALORESHAMLACE_KEY |
DBLNTSCEXTRALORESHAM_KEY |
DBLNTSCEXTRALORESLACE_KEY |
DBLNTSCEXTRALORES_KEY |
DBLNTSCHIRESDPF2FF_KEY |
DBLNTSCHIRESDPF2LACE_KEY |
DBLNTSCHIRESDPF2_KEY |
DBLNTSCHIRESDPFFF_KEY |
DBLNTSCHIRESDPFLACE_KEY |
DBLNTSCHIRESDPF_KEY |
DBLNTSCHIRESEHBFF_KEY |
DBLNTSCHIRESEHBLACE_KEY |
DBLNTSCHIRESEHB_KEY |
DBLNTSCHIRESFF_KEY |
DBLNTSCHIRESHAMFF_KEY |
DBLNTSCHIRESHAMLACE_KEY |
DBLNTSCHIRESHAM_KEY |
DBLNTSCHIRESLACE_KEY |
DBLNTSCHIRES_KEY |
DBLNTSCLORESDPF2FF_KEY |
DBLNTSCLORESDPF2LACE_KEY |
DBLNTSCLORESDPF2_KEY |
DBLNTSCLORESDPFFF_KEY |
DBLNTSCLORESDPFLACE_KEY |
DBLNTSCLORESDPF_KEY |
DBLNTSCLORESEHBFF_KEY |
DBLNTSCLORESEHBLACE_KEY |
DBLNTSCLORESEHB_KEY |
DBLNTSCLORESFF_KEY |
DBLNTSCLORESHAMFF_KEY |
DBLNTSCLORESHAMLACE_KEY |
DBLNTSCLORESHAM_KEY |
DBLNTSCLORESLACE_KEY |
DBLNTSCLORES_KEY |
DBLNTSC_MONITOR_ID |
DBLPALEXTRALORESDPF2FF_KEY |
DBLPALEXTRALORESDPF2LACE_KEY |
DBLPALEXTRALORESDPF2_KEY |
DBLPALEXTRALORESDPFFF_KEY |
DBLPALEXTRALORESDPFLACE_KEY |
DBLPALEXTRALORESDPF_KEY |
DBLPALEXTRALORESEHBFF_KEY |
DBLPALEXTRALORESEHBLACE_KEY |
DBLPALEXTRALORESEHB_KEY |
DBLPALEXTRALORESFF_KEY |
DBLPALEXTRALORESHAMFF_KEY |
DBLPALEXTRALORESHAMLACE_KEY |
DBLPALEXTRALORESHAM_KEY |
DBLPALEXTRALORESLACE_KEY |
DBLPALEXTRALORES_KEY |
DBLPALHIRESDPF2FF_KEY |
DBLPALHIRESDPF2LACE_KEY |
DBLPALHIRESDPF2_KEY |
DBLPALHIRESDPFFF_KEY |
DBLPALHIRESDPFLACE_KEY |
DBLPALHIRESDPF_KEY |
DBLPALHIRESEHBFF_KEY |
DBLPALHIRESEHBLACE_KEY |
DBLPALHIRESEHB_KEY |
DBLPALHIRESFF_KEY |
DBLPALHIRESHAMFF_KEY |
DBLPALHIRESHAMLACE_KEY |
DBLPALHIRESHAM_KEY |
DBLPALHIRESLACE_KEY |
DBLPALHIRES_KEY |
DBLPALLORESDPF2FF_KEY |
DBLPALLORESDPF2LACE_KEY |
DBLPALLORESDPF2_KEY |
DBLPALLORESDPFFF_KEY |
DBLPALLORESDPFLACE_KEY |
DBLPALLORESDPF_KEY |
DBLPALLORESEHBFF_KEY |
DBLPALLORESEHBLACE_KEY |
DBLPALLORESEHB_KEY |
DBLPALLORESFF_KEY |
DBLPALLORESHAMFF_KEY |
DBLPALLORESHAMLACE_KEY |
DBLPALLORESHAM_KEY |
DBLPALLORESLACE_KEY |
DBLPALLORES_KEY |
DBLPAL_MONITOR_ID |
DBLPF |
DBL_CAS | Memory Type
DBUFFER | Flag set when RastPorts are double-buffered
DEFAULT_MONITOR_ID |
DEFAULT_MONITOR_NAME |
DFTCH_MASK |
DIPF_IS_AA | Flag for TDisplayInfo.PropertyFlagsAA modes - may only be available if machine has correct memory type to support required bandwidth - check availability.
DIPF_IS_BEAMSYNC | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_DBUFFER | Flag for TDisplayInfo.PropertyFlags Mode supports double buffering
DIPF_IS_DRAGGABLE | Flag for TDisplayInfo.PropertyFlags Mode can be dragged down
DIPF_IS_DUALPF | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_ECS | Flag for TDisplayInfo.PropertyFlags Mode which needs ECS Chipset (SHIRES, VGA, AND PRODUCTIVITY) do not support attached sprites.
DIPF_IS_EXTRAHALFBRITE | Flag for TDisplayInfo.PropertyFlags EHB mode
DIPF_IS_FOREIGN | Flag for TDisplayInfo.PropertyFlagsMode is not native to the Amiga
DIPF_IS_GENLOCK | Flag for TDisplayInfo.PropertyFlags Mode wich support Genlocks
DIPF_IS_HAM | Flag for TDisplayInfo.PropertyFlags HAM6/8 Mode
DIPF_IS_LACE | Flag for TDisplayInfo.PropertyFlags Interlace mode
DIPF_IS_PAL | Flag for TDisplayInfo.PropertyFlags PAL Mode
DIPF_IS_PANELLED | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_PF2PRI | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_PROGBEAM | Flag for TDisplayInfo.PropertyFlags Mode is a programmed beam-sync mode
DIPF_IS_SCANDBL | Flag for TDisplayInfo.PropertyFlags Scan doubled mode
DIPF_IS_SPRITES | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_SPRITES_ATT | Flag for TDisplayInfo.PropertyFlags Mode supports attached sprites
DIPF_IS_SPRITES_BORDER | Flag for TDisplayInfo.PropertyFlags Sprite can be displayed in the border
DIPF_IS_SPRITES_CHNG_BASE | Flag for TDisplayInfo.PropertyFlags Mode can change the sprite base color
DIPF_IS_SPRITES_CHNG_PRI | Flag for TDisplayInfo.PropertyFlags Mode can change the sprite priority with respect to the playfield(s).
DIPF_IS_SPRITES_CHNG_RES | Flag for TDisplayInfo.PropertyFlags Mode supports variable sprite resolution
DIPF_IS_WB | Flag for TDisplayInfo.PropertyFlags Mode is useable for Workbench/Wanderer
DISPLAYNAMELEN | Max name of monitor names see TNameInfo.Name
DIW_HORIZ_POS |
DIW_VRTCL_POS |
DIW_VRTCL_POS_SHIFT |
DI_AVAIL_NOCHIPS | Availability for TDisplayInfo.NotAvailable
DI_AVAIL_NOMONITOR | Availability for TDisplayInfo.NotAvailable
DI_AVAIL_NOTWITHGENLOCK | Availability for TDisplayInfo.NotAvailable
DOUBLESCAN
DTAG_DIMS | GetDisplayInfoData, results in PDimensionInfo
DTAG_DISP | Start tag for GetDisplayInfoData
DTAG_MNTR | GetDisplayInfoData, results in PMonitorInfo
DTAG_NAME | GetDisplayInfoData, results in PNameInfo
DTAG_VEC | GetDisplayInfoData, Internal use only (PVecInfo)
DUALPF |
EURO36_MONITOR_ID |
EURO72EHBLACE_KEY |
EURO72EHB_KEY |
EURO72EXTRAHALFBRITELACE_KEY |
EURO72EXTRAHALFBRITE_KEY |
EURO72EXTRALORESDBL_KEY |
EURO72EXTRALORESDPF2_KEY |
EURO72EXTRALORESDPF_KEY |
EURO72EXTRALORESEHBDBL_KEY |
EURO72EXTRALORESEHBLACE_KEY |
EURO72EXTRALORESEHB_KEY |
EURO72EXTRALORESHAMDBL_KEY |
EURO72EXTRALORESHAMLACE_KEY |
EURO72EXTRALORESHAM_KEY |
EURO72EXTRALORESLACEDPF2_KEY |
EURO72EXTRALORESLACEDPF_KEY |
EURO72EXTRALORESLACE_KEY |
EURO72EXTRALORES_KEY |
EURO72HAMLACE_KEY |
EURO72HAM_KEY |
EURO72LORESDBL_KEY |
EURO72LORESDPF2_KEY |
EURO72LORESDPF_KEY |
EURO72LORESEHBDBL_KEY |
EURO72LORESEHBLACE_KEY |
EURO72LORESEHB_KEY |
EURO72LORESHAMDBL_KEY |
EURO72LORESHAMLACE_KEY |
EURO72LORESHAM_KEY |
EURO72LORESLACEDPF2_KEY |
EURO72LORESLACEDPF_KEY |
EURO72LORESLACE_KEY |
EURO72LORES_KEY |
EURO72PRODUCTDBL_KEY |
EURO72PRODUCTDPF2_KEY |
EURO72PRODUCTDPF_KEY |
EURO72PRODUCTEHBDBL_KEY |
EURO72PRODUCTHAMDBL_KEY |
EURO72PRODUCTHAMLACE_KEY |
EURO72PRODUCTHAM_KEY |
EURO72PRODUCTLACEDPF2_KEY |
EURO72PRODUCTLACEDPF_KEY |
EURO72PRODUCTLACE_KEY |
EURO72PRODUCT_KEY |
EURO72_MONITOR_ID |
EXACT_LINE
EXTENDED_MODE |
EXTEND_VSTRUCT | Unused bit in Modes field of View TViewPort
EXTRAHALFBRITELACE_KEY |
EXTRAHALFBRITE_KEY |
EXTRA_HALFBRITE |
FPB_DESIGNED | Flag Bit size is "designed", not constructed
FPB_DISKFONT | Flag Bit font is from diskfont.library
FPB_PROPORTIONAL | Flag Bit character sizes can vary from nominal
FPB_REMOVED | Flag Bit the font has been removed
FPB_REVPATH | Flag Bit designed path is reversed (e.g. left)
FPB_ROMFONT | Flag Bit font is in rom
FPB_TALLDOT | Flag Bit designed for hires non-interlaced
FPB_WIDEDOT | Flag Bit designed for lores interlaced
FPF_DESIGNED | Flag value size is "designed", not constructed
FPF_DISKFONT | Flag value font is from diskfont.library
FPF_PROPORTIONAL | Flag value character sizes can vary from nominal
FPF_REMOVED | Flag value the font has been removed
FPF_REVPATH | Flag value designed path is reversed (e.g. left)
FPF_ROMFONT | Flag value font is in rom
FPF_TALLDOT | Flag value designed for hires non-interlaced
FPF_WIDEDOT | Flag value designed for lores interlaced
FROM_MONITOR |
FRST_DOT | Draw the first dot of this line
FSB_BOLD | Bit Font Style bold face text (ORed w/ shifted)
FSB_COLORFONT | Bit Font Style this uses ColorTextFont structure
FSB_EXTENDED | Bit Font Style extended face (wider than normal)
FSB_ITALIC | Bit Font Style italic (slanted 1:2 right)
FSB_TAGGED | Bit Font Style the TextAttr is really an TTextAttr
FSB_UNDERLINED | Bit Font Style underlined (under baseline)
FSF_BOLD | Font Style bold face text (ORed w/ shifted)
FSF_COLORFONT | Bit Font Style this uses ColorTextFont structure
FSF_EXTENDED | Font Style extended face (wider than normal)
FSF_ITALIC | Font Style italic (slanted 1:2 right)
FSF_TAGGED | Font Style the TextAttr is really an TTextAttr
FSF_UNDERLINED | Font Style underlined (under baseline)
FS_NORMAL | Bit Font Style normal text (no style bits set)
GELGONE | System Set flag for TVsprite.Flags. Set if gel is completely clipped (offscreen)
GENLOC | Flag for TGfxBase.DisplayFlags Genlock is in use
GENLOCK_AUDIO |
GENLOCK_VIDEO |
GFXB_AA_ALICE | Bit defintion for TGfxBase.ChipRevBits0
GFXB_AA_LISA | Bit defintion for TGfxBase.ChipRevBits0
GFXB_AA_MLISA | Bit defintion for TGfxBase.ChipRevBits0 Internal use only
GFXB_BIG_BLITS | Bit defintion for TGfxBase.ChipRevBits0
GFXB_HR_AGNUS | Bit defintion for TGfxBase.ChipRevBits0
GFXB_HR_DENISE | Bit defintion for TGfxBase.ChipRevBits0
GFXF_AA_ALICE | Bit value for TGfxBase.ChipRevBits0
GFXF_AA_LISA | Bit value for TGfxBase.ChipRevBits0
GFXF_AA_MLISA | Bit value for TGfxBase.ChipRevBits0 internal use only
GFXF_BIG_BLITS | Bit value for TGfxBase.ChipRevBits0
GFXF_HR_AGNUS | Bit value for TGfxBase.ChipRevBits0
GFXF_HR_DENISE | Bit value for TGfxBase.ChipRevBits0
GRAPHICSNAME | Name of graphics library
GSTAG_ATTACHED | Tag for GetExtSpriteA()
GSTAG_SCANDOUBLED | Tag for GetExtSpriteA() or ChangeExtSpriteA() request "NTSC-Like" height if possible.
GSTAG_SOFTSPRITE | Tag for GetExtSpriteA()
GSTAG_SPRITE_NUM | Tag for GetExtSpriteA()
HALF_LINE
HAM |
HAMLACE_KEY |
HAM_KEY |
HIRES |
HIRESDPF2_KEY |
HIRESDPF_KEY |
HIRESEHBLACE_KEY |
HIRESEHB_KEY |
HIRESHAMLACE_KEY |
HIRESHAMSDBL_KEY |
HIRESHAM_KEY |
HIRESLACEDPF2_KEY |
HIRESLACEDPF_KEY |
HIRESLACE_KEY |
HIRES_KEY |
HOLDNMODIFY |
IGNORE_MCOMPAT | Flags for CoerceMode Coercion should ignore monitor compatibility issues.
INTERLACE |
INVALID_ID |
INVERSVID | Drawing mode: Inverse video for drawing modes
InvertAndCopy | Invert the source before copy
InvertDest | Forget source, invert dest
ISGRTRX |
ISGRTRY |
ISLESSX |
ISLESSY |
JAM1 | Drawing mode: Jam 1 color into raster
JAM2 | Drawing mode: Jam 2 colors into raster
LACE |
LEFTHIT | Bit Description for SetCollision
LORESDPF2_KEY |
LORESDPF_KEY |
LORESEHBSDBL_KEY |
LORESHAMSDBL_KEY |
LORESLACEDPF2_KEY |
LORESLACEDPF_KEY |
LORESLACE_KEY |
LORESSDBL_KEY |
LORES_KEY |
LPEN_SWAP_FRAMES
MAXFONTMATCHWEIGHT | Perfect match from WeighTAMatch
MCOMPAT_MIXED | Monitor compatibility for TMonitorInfo.Compatibility Can share display with other MCOMPAT_MIXED
MCOMPAT_NOBODY | Monitor compatibility for TMonitorInfo.Compatibility Only one viewport at a time
MCOMPAT_SELF | Monitor compatibility for TMonitorInfo.Compatibility Can share only within same monitor
MCOP_NOP | MrgCop() Error code: Can not merge any copper lists (eg, no ViewPorts in the list, or all marked as hidden).
MCOP_NO_MEM | MrgCop() Error code: insufficient memory to allocate the system copper lists.
MCOP_OK | MrgCop() Error code: No Error
MIN_NTSC_ROW |
MIN_PAL_ROW |
MIN_VGA70_ROW |
MIN_VGA_ROW |
MODE_640 |
MONITOR_ID_MASK |
MONITOR_SPEC_TYPE | TExtendedNode.xln_Subsystem
MSB_DOUBLE_SPRITES | Flag bit for TMonitorSpec.ms_Flags>
MSB_REQUEST_A2024 | Flag bit for TMonitorSpec.ms_Flags>
MSB_REQUEST_NTSC | Flag bit for TMonitorSpec.ms_Flags
MSB_REQUEST_PAL | Flag bit for TMonitorSpec.ms_Flags>
MSB_REQUEST_SPECIAL | Flag bit for TMonitorSpec.ms_Flags>
MSF_DOUBLE_SPRITES | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_A2024 | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_NTSC | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_PAL | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_SPECIAL | Flag value for TMonitorSpec.ms_Flags>
MUSTDRAW | User Set flag for TVsprite.Flags. Set if VSprite absolutely must be drawn
MVP_NO_DISPLAY | MakeVPort() Error code: BitMap data is misaligned for this viewport's mode and depth - see AllocBitMap()
MVP_NO_DSPINS | MakeVPort() Error code: insufficient memory for intermidiate copper instructions.
MVP_NO_MEM | MakeVPort() Error code: insufficient memory for intermediate workspace
MVP_NO_VPE | MakeVPort() Error code: ViewPort does not have a ViewPortExtra, and insufficient memory to allocate a temporary one.
MVP_OFF_BOTTOM | MakeVPort() Error code: PRIVATE - you will never see this.
MVP_OK | MakeVPort() Error code: No Error
NEW_DATABASE | TGfxBase.GfxFlags private
NML_CAS | Memory Type
NOCROSSFILL | Areafills have no crossovers only used for bobs
NTSC | Flag for TGfxBase.DisplayFlags Default mode is NTSC
NTSC_MONITOR_ID |
NTSC_MONITOR_NAME |
OBP_FailIfBad | Tag for ObtainBestPenA() If True and Precision is PRECISION_EXACT and no exact color can be found or allocated the function will fail.
OBP_Precision | Tag for ObtainBestPenA() Set the pen precision (PRECISION_*)
ONE_DOT | Use one dot mode for drawing lines
OUTSTEP | Bob System Flag for TBob.Flags For double-clearing if double-buffer
OVERLAY | User Set flag for TVsprite.Flags. Set to mask image of Bob onto background
PAL | Flag for TGfxBase.DisplayFlags Default mode is PAL
PAL_MONITOR_ID |
PAL_MONITOR_NAME |
PENB_EXCLUSIVE | Flag bit for ObtainPen()
PENB_NO_SETCOLOR | Flag bit for ObtainPen()
PENF_EXCLUSIVE | Flag value for ObtainPen()
PENF_NO_SETCOLOR | Flag value for ObtainPen()
PEN_EXCLUSIVE | Obsolete name for PENF_EXCLUSIVE
PEN_NO_SETCOLOR | Obsolete name for PENF_NO_SETCOLOR
PF2PRI |
PFA_FINE_SCROLL |
PFBA |
PFB_FINE_SCROLL_SHIFT |
PF_FINE_SCROLL_MASK |
PLNCNTMSK |
PLNCNTSHFT |
PRECISION_EXACT | Precision value for ObtainBestPenA()
PRECISION_GUI | Precision value for ObtainBestPenA()
PRECISION_ICON | Precision value for ObtainBestPenA()
PRECISION_IMAGE | Precision value for ObtainBestPenA()
PRESERVE_COLORS | Flag for CoerceMode Ensure that the mode coerced to can display just as many colours as the ViewPort being coerced.
PROTO_MONITOR_ID |
RATIO_FIXEDPART |
RATIO_UNITY |
REALLY_PAL
REQUEST_A2024 |
REQUEST_NTSC |
REQUEST_PAL |
REQUEST_SPECIAL |
RIGHTHIT | Bit Description for SetCollision
RINGTRIGGER | Define for the animation procedures
RPTAG_AlphaMode
RPTAG_APen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set apen
RPTAG_BgColor
RPTAG_BPen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set bpen
RPTAG_DrawBounds | Tag for GetRPAttrsA() Get rastport draw bounds. pass PRectangle
RPTAG_DrMd | Tag for GetRPAttrsA(), SetRPAttrsA() get/set draw mode
RPTAG_FgColor
RPTAG_Font | Tag for GetRPAttrsA(), SetRPAttrsA() get/set font
RPTAG_MaxPen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set maxpen
RPTAG_OutlinePen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set outline pen.
RPTAG_PenMode
RPTAG_RetainAlpha
RPTAG_WriteMask | Tag for GetRPAttrsA(), SetRPAttrsA() get/set WriteMask
RPTAG_XPos
RPTAG_YPos
SAVEBACK | User Set flag for TVsprite.Flags. Set if background is to be saved/restored
SAVEBOB | Bob User Flag for TBob.Flags set to not erase Bob
SAVEPRESERVE | Bob System Flag for TBob.Flags For back-restore during double-buffer
SETCHIPREV_A | Pass to SetChipRev()
SETCHIPREV_AA | Pass to SetChipRev()
SETCHIPREV_BEST | Pass to SetChipRev()
SETCHIPREV_ECS | Pass to SetChipRev()
SPECIAL_BEAMCON |
SPECIAL_FLAGS | Flag for TDisplayInfo.PropertyFlags
SPECIAL_MONITOR_TYPE | TExtendedNode.xln_Subsystem
SPRITEA_Attached | Tag for AllocSpriteDataA()
SPRITEA_OldDataFormat | Tag for AllocSpriteDataA() must pass in outputheight if using this tag
SPRITEA_OutputHeight | Tag for AllocSpriteDataA() height of Sprite
SPRITEA_ViewPort
SPRITEA_Width | Tag for AllocSpriteDataA() Width of Sprite Default - 16
SPRITEA_XReplication | Tag for AllocSpriteDataA() Controls the horizontal pixel replication factor used when converting the bitmap data. Default - 0
SPRITEA_YReplication | Tag for AllocSpriteDataA() Controls the vertical pixel replication factor used when converting the bitmap data. Default - 0
SPRITERESN_140NS | Resolution for TColorMap.SpriteResolution
SPRITERESN_35NS | Resolution for TColorMap.SpriteResolution
SPRITERESN_70NS | Resolution for TColorMap.SpriteResolution
SPRITERESN_DEFAULT | Resolution for TColorMap.SpriteResolution
SPRITERESN_ECS | Resolution for TColorMap.SpriteResolution
SPRITES |
SPRITE_ATTACHED |
SS_GRAPHICS | TExtendedNode.xln_Subtype
STANDARD_COLORCLOCKS |
STANDARD_DENISE_MAX |
STANDARD_DENISE_MIN |
STANDARD_HBSTOP |
STANDARD_HBSTRT |
STANDARD_HSSTOP |
STANDARD_HSSTRT |
STANDARD_MONITOR_MASK |
STANDARD_NTSC_BEAMCON |
STANDARD_NTSC_ROWS |
STANDARD_PAL_BEAMCON |
STANDARD_PAL_ROWS |
STANDARD_VBSTOP |
STANDARD_VBSTRT |
STANDARD_VIEW_X |
STANDARD_VIEW_Y |
STANDARD_VSSTOP |
STANDARD_VSSTRT |
STANDARD_XOFFSET |
STANDARD_YOFFSET |
StraightCopy | Vanilla copy
SUPER72HIRESDBL_KEY |
SUPER72HIRESEHBDBL_KEY |
SUPER72HIRESHAMDBL_KEY |
SUPER72LORESDBL_KEY |
SUPER72LORESEHBDBL_KEY |
SUPER72LORESHAMDBL_KEY |
SUPER72SUPERDBL_KEY |
SUPER72SUPEREHBDBL_KEY |
SUPER72SUPERHAMDBL_KEY |
SUPER72_MONITOR_ID |
SUPERDPF2_KEY |
SUPERDPF_KEY |
SUPEREHBLACE_KEY |
SUPEREHB_KEY |
SUPERHAMLACE_KEY |
SUPERHAM_KEY |
SUPERHIRES |
SUPERLACEDPF2_KEY |
SUPERLACEDPF_KEY |
SUPERLACE_KEY |
SUPER_KEY |
SUSERFLAGS | Mask of all user-settable TVsprite.Flags
TA_Bold
TA_ColorFont
TA_Designed
TA_DeviceDPI | Tag for TTTextAttr.tta_Tags
TA_DiskFont
TA_Extended
TA_Italic
TA_Name
TA_Proportional
TA_RevPath
TA_ROMFont
TA_TallDot
TA_Underlined
TA_WideDot
TA_YSize
TE0B_NOREMFONT | Flag bit TTextFontExtension.tfe_Flags0 disallow RemFont for this font
TE0F_NOREMFONT | Flag value TTextFontExtension.tfe_Flags0 disallow RemFont for this font
TODA_SAFE | Flag for TGfxBase.DisplayFlags
TOPHIT | Bit Description for SetCollision
TO_MONITOR |
USER_COPPER_CLIP | Flag value for TColorMap.Flags
VC_DUALPF_Disable | Tag for VideoControl() When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Default = False.
VC_DUALPF_Disable_Query | Tag for VideoControl()
VC_IntermediateCLUpdate | Tag for VideoControl() When set graphics will update the intermediate copper lists on color changes, etc. When False, it won't, and will be faster. default = True.
VC_IntermediateCLUpdate_Query | Tag for VideoControl() Get if intermediate copper is activated
VC_NoColorPaletteLoad | Tag for VideoControl() When set, graphics will only load color 0 for this View Port default = False.
VC_NoColorPaletteLoad_Query | Tag for VideoControl() Get if only color 0 will be set for this viewport.
VGA70_BEAMCON |
VGA70_COLORCLOCKS |
VGA70_DENISE_MIN |
VGA70_HBSTOP |
VGA70_HBSTRT |
VGA70_HSSTOP |
VGA70_HSSTRT |
VGA70_MONITOR_NAME |
VGA70_TOTAL_ROWS |
VGA70_VBSTOP |
VGA70_VBSTRT |
VGA70_VSSTOP |
VGA70_VSSTRT |
VGAEHBLACE_KEY |
VGAEHB_KEY |
VGAEXTRAHALFBRITELACE_KEY |
VGAEXTRAHALFBRITE_KEY |
VGAEXTRALORESDBL_KEY |
VGAEXTRALORESDPF2_KEY |
VGAEXTRALORESDPF_KEY |
VGAEXTRALORESEHBDBL_KEY |
VGAEXTRALORESEHBLACE_KEY |
VGAEXTRALORESEHB_KEY |
VGAEXTRALORESHAMDBL_KEY |
VGAEXTRALORESHAMLACE_KEY |
VGAEXTRALORESHAM_KEY |
VGAEXTRALORESLACEDPF2_KEY |
VGAEXTRALORESLACEDPF_KEY |
VGAEXTRALORESLACE_KEY |
VGAEXTRALORES_KEY |
VGAHAMLACE_KEY |
VGAHAM_KEY |
VGALORESDBL_KEY |
VGALORESDPF2_KEY |
VGALORESDPF_KEY |
VGALORESEHBDBL_KEY |
VGALORESEHBLACE_KEY |
VGALORESEHB_KEY |
VGALORESHAMDBL_KEY |
VGALORESHAMLACE_KEY |
VGALORESHAM_KEY |
VGALORESLACEDPF2_KEY |
VGALORESLACEDPF_KEY |
VGALORESLACE_KEY |
VGALORES_KEY |
VGAPRODUCTDBL_KEY |
VGAPRODUCTDPF2_KEY |
VGAPRODUCTDPF_KEY |
VGAPRODUCTEHBDBL_KEY |
VGAPRODUCTHAMDBL_KEY |
VGAPRODUCTHAMLACE_KEY |
VGAPRODUCTHAM_KEY |
VGAPRODUCTLACEDPF2_KEY |
VGAPRODUCTLACEDPF_KEY |
VGAPRODUCTLACE_KEY |
VGAPRODUCT_KEY |
VGA_COLORCLOCKS |
VGA_DENISE_MIN |
VGA_HBSTOP |
VGA_HBSTRT |
VGA_HSSTOP |
VGA_HSSTRT |
VGA_MONITOR_ID |
VGA_MONITOR_NAME |
VGA_TOTAL_ROWS |
VGA_VBSTOP |
VGA_VBSTRT |
VGA_VSSTOP |
VGA_VSSTRT |
VIDEOCONTROL_BATCH | Flag value for TColorMap.Flags
VIEWPORT_EXTRA_TYPE | TExtendedNode.xln_Subsystem
VIEW_EXTRA_TYPE | TExtendedNode.xln_Subsystem
VPB_A2024
VPB_TENHZ
VPF_A2024 |
VPF_TENHZ |
VPOSRLOF |
VPXB_FREE_ME
VPXB_LAST
VPXB_STRADDLES256
VPXB_STRADDLES512
VPXF_FREE_ME
VPXF_LAST
VPXF_STRADDLES256
VPXF_STRADDLES512
VP_HIDE |
VSOVERFLOW | System Set flag for TVsprite.Flags. VSprite overflow (if MUSTDRAW set we draw!)
VSPRITE
VTAG_ATTACH_CM_GET | Tag for VideoControl()
VTAG_ATTACH_CM_SET | Tag for VideoControl()
VTAG_BATCH_CM_CLR | Tag for VideoControl()
VTAG_BATCH_CM_GET | Tag for VideoControl()
VTAG_BATCH_CM_SET | Tag for VideoControl()
VTAG_BATCH_ITEMS_ADD | Tag for VideoControl()
VTAG_BATCH_ITEMS_GET | Tag for VideoControl()
VTAG_BATCH_ITEMS_SET | Tag for VideoControl()
VTAG_BITPLANEKEY_CLR | Tag for VideoControl()
VTAG_BITPLANEKEY_GET | Tag for VideoControl()
VTAG_BITPLANEKEY_SET | Tag for VideoControl()
VTAG_BORDERBLANK_CLR | Tag for VideoControl()
VTAG_BORDERBLANK_GET | Tag for VideoControl()
VTAG_BORDERBLANK_SET | Tag for VideoControl()
VTAG_BORDERNOTRANS_CLR | Tag for VideoControl()
VTAG_BORDERNOTRANS_GET | Tag for VideoControl()
VTAG_BORDERNOTRANS_SET | Tag for VideoControl()
VTAG_BORDERSPRITE_CLR | Tag for VideoControl()
VTAG_BORDERSPRITE_GET | Tag for VideoControl()
VTAG_BORDERSPRITE_SET | Tag for VideoControl()
VTAG_CHROMAKEY_CLR | Tag for VideoControl()
VTAG_CHROMAKEY_GET | Tag for VideoControl()
VTAG_CHROMAKEY_SET | Tag for VideoControl()
VTAG_CHROMA_PEN_CLR | Tag for VideoControl()
VTAG_CHROMA_PEN_GET | Tag for VideoControl()
VTAG_CHROMA_PEN_SET | Tag for VideoControl()
VTAG_CHROMA_PLANE_GET | Tag for VideoControl()
VTAG_CHROMA_PLANE_SET | Tag for VideoControl()
VTAG_COERCE_DISP_GET | Tag for VideoControl()
VTAG_COERCE_DISP_SET | Tag for VideoControl()
VTAG_DEFSPRITERESN_GET | Tag for VideoControl()
VTAG_DEFSPRITERESN_SET | Tag for VideoControl()
VTAG_END_CM | Tag for VideoControl()
VTAG_FULLPALETTE_CLR | Tag for VideoControl()
VTAG_FULLPALETTE_GET | Tag for VideoControl()
VTAG_FULLPALETTE_SET | Tag for VideoControl()
VTAG_IMMEDIATE | Tag for VideoControl()
VTAG_NEXTBUF_CM | Tag for VideoControl()
VTAG_NORMAL_DISP_GET | Tag for VideoControl()
VTAG_NORMAL_DISP_SET | Tag for VideoControl()
VTAG_PF1_BASE_GET | Tag for VideoControl()
VTAG_PF1_BASE_SET | Tag for VideoControl()
VTAG_PF1_TO_SPRITEPRI_GET | Tag for VideoControl()
VTAG_PF1_TO_SPRITEPRI_SET | Tag for VideoControl()
VTAG_PF2_BASE_GET | Tag for VideoControl()
VTAG_PF2_BASE_SET | Tag for VideoControl()
VTAG_PF2_TO_SPRITEPRI_GET | Tag for VideoControl()
VTAG_PF2_TO_SPRITEPRI_SET | Tag for VideoControl()
VTAG_SPEVEN_BASE_GET | Tag for VideoControl()
VTAG_SPEVEN_BASE_SET | Tag for VideoControl()
VTAG_SPODD_BASE_GET | Tag for VideoControl()
VTAG_SPODD_BASE_SET | Tag for VideoControl()
VTAG_SPRITERESN_GET | Tag for VideoControl()
VTAG_SPRITERESN_SET | Tag for VideoControl()
VTAG_USERCLIP_CLR | Tag for VideoControl()
VTAG_USERCLIP_GET | Tag for VideoControl()
VTAG_USERCLIP_SET | Tag for VideoControl()
VTAG_VIEWPORTEXTRA_GET | Tag for VideoControl()
VTAG_VIEWPORTEXTRA_SET | Tag for VideoControl()
VTAG_VPMODEID_CLR | Tag for VideoControl()
VTAG_VPMODEID_GET | Tag for VideoControl()
VTAG_VPMODEID_SET | Tag for VideoControl()


Reference for unit 'agraphics': Types

DisplayInfoHandle | The "public" handle to a DisplayInfoRecord
PAnalogSignalInterval |
PAnimComp | Pointer to an animation
PAnimOb | Pointer to an animation object
PAreaInfo |
PBitMap | Pointer to a bitmap in memory, properties and data.
PBitScaleArgs | Pointer to BitScaleArgs structure used by BitMapScale()
PBob | Pointer to an Blitter object structure
PClipRect | Pointer to a clip rectange
PCollTable | Pointer to a structure to contain the 16 collision procedure addresses
PColorFontColors |
PColorMap |
PColorTextFont | Pointer to color Text font
PCopInit |
PCopIns |
PCopList |
PCprList | Structure of cprlist that points to list that hardware actually executes
PDBufInfo | Pointer to a double buffer structure
PDBufPacket | Defines the values needed to be saved across buffer to buffer when in double-buffer mode
PDimensionInfo | Pointer to monitor dimensions
PDisplayInfo | Pointer to informations about the display
PExtendedNode |
PExtSprite | Pointer to an extended sprite Structure
PGelsInfo |
PGfxBase | Graphics Library Base pointer
PIsrvstr |
PLayer | Pointer to a layer structure
PLayer_Info
PMonitorInfo | Pointer to Monitor informations
PMonitorSpec |
PNameInfo | Pointer to Monitor name structure
PPaletteExtra | Structure controlling palette sharing
PPAnimOb |
PPoint | Pointer to an x,y defined point.
PPSimpleSprite
PQueryHeader | Header for TDisplayInfo
PRasInfo | Used in TViewPort
PRastPort | Basic structure for all drawing actions
PRect32 | Pointer to Rectangle (Integer size Values)
PRectangle | Pointer to Rectangle (Word size values)
PRegion |
PRegionRectangle |
PSimpleSprite | Pointer to a simple sprite description
PSpecialMonitor |
PTextAttr | TextAttr node, matches text attributes in TRastPort
PTextExtent | Pointer to a measured text size
PTextFont |
PTextFontExtension |
PTmpRas | Temporary rast port
PTTextAttr | Extended TextAttr node, matches text attributes in TRastPort
PUCopList |
PVecInfo | This structure is PRIVATE, for our use only Touch these, and burn!
PView |
PViewExtra | Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree
PViewPort |
PViewPortExtra | Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()
PVSprite | Pointer to Sprite structure
TAnalogSignalInterval |
TAnimComp |
TAnimOb |
TAreaInfo |
SmallInt
TBitMap | Represents an image in ram.
TBitScaleArgs | BitScaleArgs structure used by BitMapScale()
TBob | Blitter object
SmallInt
TClipRect | Clip rectangle
TCollTable
TColorFontColors |
TColorMap | This structure is the primary storage for palette data.
TColorTextFont | Color font structure
TCopInit |
TCopIns | Copper structure
TCopList |
TCprList | Structure of cprlist that points to list that hardware actually executes
TDBufInfo | Double buffer structure
TDBufPacket | Defines the values needed to be saved across buffer to buffer when in double-buffer mode
TDimensionInfo | Monitor dimensions (like overscan)
TDisplayInfo | Structure to hold informations about Display.
TExtendedNode |
TExtSprite | Extended sprite Structure
TGelsInfo |
TGfxBase | Graphics library structure
TIsrvstr |
TLayer | Layer Structure
TLayer_Info
TMonitorInfo | Monitor Informations structure
TMonitorSpec |
TNameInfo | Name of the Display
TPaletteExtra | Structure controlling palette sharing
PByte | Pointer to Bitplane coded image data, can be created with AllocRaster
TPoint | Basic definition of a point (x,y)
TQueryHeader | Header for TDisplayInfo
TRasInfo | Used in TViewPort
TRastPort | Basic structure for all drawing actions
TRect32 | Basic struct for defining a rectengular region with integer values
TRectangle | Basic struct for defining a rectengular region with word values
TRegion |
TRegionRectangle |
TSimpleSprite | Sprite description structure
TSpecialMonitor |
TTextAttr | TextAttr node, matches text attributes in TRastPort
TTextExtent | A measured text size
TTextFont |
TTextFontExtension | Extended font description
TTmpRas | Temporary rast port
TTTextAttr | Extended TextAttr node, matches text attributes in TRastPort
TUCopList |
TVecInfo | This structure is PRIVATE, for our use only Touch these, and burn!
TView |
TViewExtra | Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree
TViewPort | Describes a displayed bitmap (or logical screen). Copperlists are relevant only to Amiga(tm) chipset, for other hardware they are nil.
TViewPortExtra | Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()
TVSprite | Sprite description
SmallInt


INTERLACE

Declaration

Source position: agraphics.pas line 1518

const INTERLACE = 4;


INVALID_ID

Declaration

Source position: agraphics.pas line 1161

const INVALID_ID = not 0;


INVERSVID

Drawing mode: Inverse video for drawing modes

Declaration

Source position: agraphics.pas line 851

const INVERSVID = 4;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


InvertAndCopy

Invert the source before copy

Declaration

Source position: agraphics.pas line 878

const InvertAndCopy = $30;


InvertDest

Forget source, invert dest

Declaration

Source position: agraphics.pas line 879

const InvertDest = $50;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ISGRTRX

Declaration

Source position: agraphics.pas line 809

const ISGRTRX = 4;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ISGRTRY

Declaration

Source position: agraphics.pas line 810

const ISGRTRY = 8;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ISLESSX

Declaration

Source position: agraphics.pas line 807

const ISLESSX = 1;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ISLESSY

Declaration

Source position: agraphics.pas line 808

const ISLESSY = 2;


JAM1

Drawing mode: Jam 1 color into raster

Declaration

Source position: agraphics.pas line 848

const JAM1 = 0;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


JAM2

Drawing mode: Jam 2 colors into raster

Declaration

Source position: agraphics.pas line 849

const JAM2 = 1;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

LACE

Declaration

Source position: agraphics.pas line 742

const LACE = 1 shl 2;


LEFTHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 941

const LEFTHIT = 4;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


LORES_KEY

Declaration

Source position: agraphics.pas line 1189

const LORES_KEY = $00000000;


LORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1203

const LORESDPF2_KEY = $00000440;


LORESDPF_KEY

Declaration

Source position: agraphics.pas line 1197

const LORESDPF_KEY = $00000400;


LORESEHBSDBL_KEY

Declaration

Source position: agraphics.pas line 1223

const LORESEHBSDBL_KEY = $00000088;


LORESHAMSDBL_KEY

Declaration

Source position: agraphics.pas line 1222

const LORESHAMSDBL_KEY = $00000808;


LORESLACE_KEY

Declaration

Source position: agraphics.pas line 1193

const LORESLACE_KEY = $00000004;


LORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1206

const LORESLACEDPF2_KEY = $00000444;


LORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1200

const LORESLACEDPF_KEY = $00000404;


LORESSDBL_KEY

Declaration

Source position: agraphics.pas line 1221

const LORESSDBL_KEY = $00000008;


LPEN_SWAP_FRAMES

Declaration

Source position: agraphics.pas line 1939

const LPEN_SWAP_FRAMES = 32;


MAXFONTMATCHWEIGHT

Perfect match from WeighTAMatch

Declaration

Source position: agraphics.pas line 776

const MAXFONTMATCHWEIGHT = 32767;


MCOMPAT_MIXED

Monitor compatibility for TMonitorInfo.Compatibility Can share display with other MCOMPAT_MIXED

Declaration

Source position: agraphics.pas line 1612

const MCOMPAT_MIXED = 0;


MCOMPAT_NOBODY

Monitor compatibility for TMonitorInfo.Compatibility Only one viewport at a time

Declaration

Source position: agraphics.pas line 1614

const MCOMPAT_NOBODY = - 1;


MCOMPAT_SELF

Monitor compatibility for TMonitorInfo.Compatibility Can share only within same monitor

Declaration

Source position: agraphics.pas line 1613

const MCOMPAT_SELF = 1;


MCOP_NO_MEM

MrgCop() Error code: insufficient memory to allocate the system copper lists.

Declaration

Source position: agraphics.pas line 1136

const MCOP_NO_MEM = 1;


MCOP_NOP

MrgCop() Error code: Can not merge any copper lists (eg, no ViewPorts in the list, or all marked as hidden).

Declaration

Source position: agraphics.pas line 1137

const MCOP_NOP = 2;


MCOP_OK

MrgCop() Error code: No Error

Declaration

Source position: agraphics.pas line 1135

const MCOP_OK = 0;


MIN_NTSC_ROW

Declaration

Source position: agraphics.pas line 1005

const MIN_NTSC_ROW = 21;


MIN_PAL_ROW

Declaration

Source position: agraphics.pas line 1006

const MIN_PAL_ROW = 29;


MIN_VGA70_ROW

Declaration

Source position: agraphics.pas line 1034

const MIN_VGA70_ROW = 35;


MIN_VGA_ROW

Declaration

Source position: agraphics.pas line 1021

const MIN_VGA_ROW = 29;


MODE_640

Declaration

Source position: agraphics.pas line 1511

const MODE_640 = $8000;


MONITOR_ID_MASK

Declaration

Source position: agraphics.pas line 1176

const MONITOR_ID_MASK = $FFFF1000;


MONITOR_SPEC_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 950

const MONITOR_SPEC_TYPE = 4;


MSB_DOUBLE_SPRITES

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 974

const MSB_DOUBLE_SPRITES = 4;


MSB_REQUEST_A2024

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 973

const MSB_REQUEST_A2024 = 3;


MSB_REQUEST_NTSC

Flag bit for TMonitorSpec.ms_Flags

Declaration

Source position: agraphics.pas line 970

const MSB_REQUEST_NTSC = 0;


MSB_REQUEST_PAL

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 971

const MSB_REQUEST_PAL = 1;


MSB_REQUEST_SPECIAL

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 972

const MSB_REQUEST_SPECIAL = 2;


MSF_DOUBLE_SPRITES

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 979

const MSF_DOUBLE_SPRITES = 1 shl MSB_DOUBLE_SPRITES;


MSF_REQUEST_A2024

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 978

const MSF_REQUEST_A2024 = 1 shl MSB_REQUEST_A2024;


MSF_REQUEST_NTSC

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 975

const MSF_REQUEST_NTSC = 1 shl MSB_REQUEST_NTSC;


MSF_REQUEST_PAL

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 976

const MSF_REQUEST_PAL = 1 shl MSB_REQUEST_PAL;


MSF_REQUEST_SPECIAL

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 977

const MSF_REQUEST_SPECIAL = 1 shl MSB_REQUEST_SPECIAL;


MUSTDRAW

User Set flag for TVsprite.Flags. Set if VSprite absolutely must be drawn

Declaration

Source position: agraphics.pas line 898

const MUSTDRAW = $0008;


MVP_NO_DISPLAY

MakeVPort() Error code: BitMap data is misaligned for this viewport's mode and depth - see AllocBitMap()

Declaration

Source position: agraphics.pas line 1130

const MVP_NO_DISPLAY = 4;


MVP_NO_DSPINS

MakeVPort() Error code: insufficient memory for intermidiate copper instructions.

Declaration

Source position: agraphics.pas line 1129

const MVP_NO_DSPINS = 3;


MVP_NO_MEM

MakeVPort() Error code: insufficient memory for intermediate workspace

Declaration

Source position: agraphics.pas line 1127

const MVP_NO_MEM = 1;


MVP_NO_VPE

MakeVPort() Error code: ViewPort does not have a ViewPortExtra, and insufficient memory to allocate a temporary one.

Declaration

Source position: agraphics.pas line 1128

const MVP_NO_VPE = 2;


MVP_OFF_BOTTOM

MakeVPort() Error code: PRIVATE - you will never see this.

Declaration

Source position: agraphics.pas line 1131

const MVP_OFF_BOTTOM = 5;


MVP_OK

MakeVPort() Error code: No Error

Declaration

Source position: agraphics.pas line 1126

const MVP_OK = 0;


NEW_DATABASE

TGfxBase.GfxFlags private

Declaration

Source position: agraphics.pas line 1976

const NEW_DATABASE = 1;


NML_CAS

Memory Type

Declaration

Source position: agraphics.pas line 1966

const NML_CAS = 0;


NOCROSSFILL

Areafills have no crossovers only used for bobs

Declaration

Source position: agraphics.pas line 860

const NOCROSSFILL = $20;

See also

TRastPort

Basic structure for all drawing actions


NTSC

Flag for TGfxBase.DisplayFlags Default mode is NTSC

Declaration

Source position: agraphics.pas line 1934

const NTSC = 1;


NTSC_MONITOR_ID

Declaration

Source position: agraphics.pas line 1179

const NTSC_MONITOR_ID = $00011000;


NTSC_MONITOR_NAME

Declaration

Source position: agraphics.pas line 989

const NTSC_MONITOR_NAME: PChar = 'ntsc.monitor';


OBP_FailIfBad

Tag for ObtainBestPenA() If True and Precision is PRECISION_EXACT and no exact color can be found or allocated the function will fail.

Declaration

Source position: agraphics.pas line 1121

const OBP_FailIfBad = $84000001;

Description

Specifies that you want ObtainBestPenA() to return a failure value if there is not a color within the given tolerance, instead of returning the closest color. With OBP_FailIfBad = False, ObtainBestPenA() will only fail if the ViewPort contains no sharable colors. Defaults to False.


OBP_Precision

Tag for ObtainBestPenA() Set the pen precision (PRECISION_*)

Declaration

Source position: agraphics.pas line 1120

const OBP_Precision = $84000000;

Description

Specifies the desired precision for the match. Should be PRECISION_GUI, PRECISION_ICON, or PRECISION_IMAGE or PRECISION_EXACT. Defaults to PRECISION_IMAGE.


ONE_DOT

Use one dot mode for drawing lines

Declaration

Source position: agraphics.pas line 855

const ONE_DOT = $02;

See also

TRastPort

Basic structure for all drawing actions


OUTSTEP

Bob System Flag for TBob.Flags For double-clearing if double-buffer

Declaration

Source position: agraphics.pas line 916

const OUTSTEP = $2000;


OVERLAY

User Set flag for TVsprite.Flags. Set to mask image of Bob onto background

Declaration

Source position: agraphics.pas line 897

const OVERLAY = $0004;


PAL

Flag for TGfxBase.DisplayFlags Default mode is PAL

Declaration

Source position: agraphics.pas line 1936

const PAL = 4;


PAL_MONITOR_ID

Declaration

Source position: agraphics.pas line 1180

const PAL_MONITOR_ID = $00021000;


PAL_MONITOR_NAME

Declaration

Source position: agraphics.pas line 990

const PAL_MONITOR_NAME: PChar = 'pal.monitor';


PAnalogSignalInterval

Declaration

Source position: agraphics.pas line 440

type PAnalogSignalInterval = ^TAnalogSignalInterval;

See also

TSpecialMonitor


PAnimComp

Pointer to an animation

Declaration

Source position: agraphics.pas line 611

type PAnimComp = ^TAnimComp;


PAnimOb

Pointer to an animation object

Declaration

Source position: agraphics.pas line 612

type PAnimOb = ^TAnimOb;


PAreaInfo

Declaration

Source position: agraphics.pas line 355

type PAreaInfo = ^TAreaInfo;

See also

InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


PBitMap

Pointer to a bitmap in memory, properties and data.

Declaration

Source position: agraphics.pas line 58

type PBitMap = ^TBitMap;

See also

AllocBitmap | Allocate a bitmap and attach bitplanes to it.
FreeBitmap | Free a bitmap created by AllocBitMap()
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
BltBitMap | Move a rectangular region of bits in a BitMap.
BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ChangeVPBitmap | Change display memory address for multi-buffered animation
GetBitMapAttr | Returns information about a bitmap
InitBitMap | Initialize bit map structure with input values.
TRastPort | Basic structure for all drawing actions


PBitScaleArgs

Pointer to BitScaleArgs structure used by BitMapScale()

Declaration

Source position: agraphics.pas line 1769

type PBitScaleArgs = ^TBitScaleArgs;


PBob

Pointer to an Blitter object structure

Declaration

Source position: agraphics.pas line 610

type PBob = ^TBob;


PClipRect

Pointer to a clip rectange

Declaration

Source position: agraphics.pas line 104

type PClipRect = ^TClipRect;

See also

TLayer

Layer Structure


PCollTable

Pointer to a structure to contain the 16 collision procedure addresses

Declaration

Source position: agraphics.pas line 374

type PCollTable = ^TCollTable;

See also

TGelsInfo


PColorFontColors

Declaration

Source position: agraphics.pas line 246

type PColorFontColors = ^TColorFontColors;


PColorMap

Declaration

Source position: agraphics.pas line 109

type PColorMap = ^TColorMap;


PColorTextFont

Pointer to color Text font

Declaration

Source position: agraphics.pas line 253

type PColorTextFont = ^TColorTextFont;


PCopInit

Declaration

Source position: agraphics.pas line 339

type PCopInit = ^TCopInit;


PCopIns

Declaration

Source position: agraphics.pas line 288

type PCopIns = ^TCopIns;


PCopList

Declaration

Source position: agraphics.pas line 107

type PCopList = ^TCopList;


PCprList

Structure of cprlist that points to list that hardware actually executes

Declaration

Source position: agraphics.pas line 310

type PCprList = ^TCprList;


PDBufInfo

Pointer to a double buffer structure

Declaration

Source position: agraphics.pas line 1140

type PDBufInfo = ^TDBufInfo;

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation
FreeDBufInfo | Free information for multi-buffered animation


PDBufPacket

Defines the values needed to be saved across buffer to buffer when in double-buffer mode

Declaration

Source position: agraphics.pas line 651

type PDBufPacket = ^TDBufPacket;


PDimensionInfo

Pointer to monitor dimensions

Declaration

Source position: agraphics.pas line 1575

type PDimensionInfo = ^TDimensionInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_DIMS | GetDisplayInfoData, results in PDimensionInfo


PDisplayInfo

Pointer to informations about the display

Declaration

Source position: agraphics.pas line 1556

type PDisplayInfo = ^TDisplayInfo;

See also

FindDisplayInfo | Search for a record identified by a specific key
GetDisplayInfoData | Query DisplayInfo Record parameters


PEN_EXCLUSIVE

Obsolete name for PENF_EXCLUSIVE

Declaration

Source position: agraphics.pas line 1109

const PEN_EXCLUSIVE = PENF_EXCLUSIVE;


PEN_NO_SETCOLOR

Obsolete name for PENF_NO_SETCOLOR

Declaration

Source position: agraphics.pas line 1110

const PEN_NO_SETCOLOR = PENF_NO_SETCOLOR;


PENB_EXCLUSIVE

Flag bit for ObtainPen()

Declaration

Source position: agraphics.pas line 1102

const PENB_EXCLUSIVE = 0;


PENB_NO_SETCOLOR

Flag bit for ObtainPen()

Declaration

Source position: agraphics.pas line 1103

const PENB_NO_SETCOLOR = 1;


PENF_EXCLUSIVE

Flag value for ObtainPen()

Declaration

Source position: agraphics.pas line 1105

const PENF_EXCLUSIVE = 1 shl PENB_EXCLUSIVE;


PENF_NO_SETCOLOR

Flag value for ObtainPen()

Declaration

Source position: agraphics.pas line 1106

const PENF_NO_SETCOLOR = 1 shl PENB_NO_SETCOLOR;


PExtendedNode

Declaration

Source position: agraphics.pas line 68

type PExtendedNode = ^TExtendedNode;


PExtSprite

Pointer to an extended sprite Structure

Declaration

Source position: agraphics.pas line 1741

type PExtSprite = ^TExtSprite;

See also

AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
ChangeExtSpriteA | Change the sprite image pointer.
FreeSpriteData | free sprite data allocated by AllocSpriteData()
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PF2PRI

Declaration

Source position: agraphics.pas line 1514

const PF2PRI = $40;


PF_FINE_SCROLL_MASK

Declaration

Source position: agraphics.pas line 1522

const PF_FINE_SCROLL_MASK = $F;


PFA_FINE_SCROLL

Declaration

Source position: agraphics.pas line 1520

const PFA_FINE_SCROLL = $F;


PFB_FINE_SCROLL_SHIFT

Declaration

Source position: agraphics.pas line 1521

const PFB_FINE_SCROLL_SHIFT = 4;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PFBA

Declaration

Source position: agraphics.pas line 745

const PFBA = 1 shl 6;


PGelsInfo

Declaration

Source position: agraphics.pas line 379

type PGelsInfo = ^TGelsInfo;

See also

TRastPort | Basic structure for all drawing actions
InitGels | initialize a gel list; must be called before using gels.
SetCollision | Set a pointer to a user collision routine.


PGfxBase

Graphics Library Base pointer

Declaration

Source position: agraphics.pas line 1809

type PGfxBase = ^tGfxBase;


PIsrvstr

Declaration

Source position: agraphics.pas line 954

type PIsrvstr = ^TIsrvstr;


PLayer

Pointer to a layer structure

Declaration

Source position: agraphics.pas line 105

type PLayer = ^TLayer;

See also

AttemptLockLayerRom | Attempt to Lock Layer structure by ROM(gfx lib) code
UnLockLayerRom | Unlock Layer structure by ROM(gfx lib) code.
LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
CopySBitMap | Syncronize Layer window with contents of Super BitMap
SyncSBitMap | Syncronize Super BitMap with whatever is in the standard Layer bounds.
TRastPort | Basic structure for all drawing actions


PLayer_Info

Declaration

Source position: agraphics.pas line 133

type PLayer_Info = ^TLayer_Info;


PLNCNTMSK

Declaration

Source position: agraphics.pas line 1512

const PLNCNTMSK = $7;


PLNCNTSHFT

Declaration

Source position: agraphics.pas line 1513

const PLNCNTSHFT = 12;


PMonitorInfo

Pointer to Monitor informations

Declaration

Source position: agraphics.pas line 1592

type PMonitorInfo = ^TMonitorInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_MNTR | GetDisplayInfoData, results in PMonitorInfo


PMonitorSpec

Declaration

Source position: agraphics.pas line 461

type PMonitorSpec = ^TMonitorSpec;


PNameInfo

Pointer to Monitor name structure

Declaration

Source position: agraphics.pas line 1619

type PNameInfo = ^TNameInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_NAME | GetDisplayInfoData, results in PNameInfo


PPaletteExtra

Structure controlling palette sharing

Declaration

Source position: agraphics.pas line 291

type PPaletteExtra = ^TPaletteExtra;


PPAnimOb

Declaration

Source position: agraphics.pas line 717

type PPAnimOb = ^PAnimOb;


PPoint

Pointer to an x,y defined point.

Declaration

Source position: agraphics.pas line 51

type PPoint = ^TPoint;


PPSimpleSprite

Declaration

Source position: agraphics.pas line 1732

type PPSimpleSprite = ^PSimpleSprite;


PQueryHeader

Header for TDisplayInfo

Declaration

Source position: agraphics.pas line 1548

type PQueryHeader = ^TQueryHeader;


PRasInfo

Used in TViewPort

Declaration

Source position: agraphics.pas line 431

type PRasInfo = ^TRasInfo;


PRastPort

Basic structure for all drawing actions

Declaration

Source position: agraphics.pas line 106

type PRastPort = ^TRastPort;

See also

BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
BltPattern | Using standard drawing rules for areafill, blit through a mask.
ClearEOL | Clear from current position to end of line.
ClearScreen | Clear from current position to end of RastPort.
ClipBlit | Calls BltBitMap() after accounting for windows
Draw | Draw a line between the current pen position and the new x,y position.
DrawEllipse | Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.
EraseRect | Fill a defined rectangular area using the current BackFill hook.
Flood | Flood rastport like areafill.
GfxMove | Move graphics pen position.
InitRastPort | Initialize raster port structure
PolyDraw | Draw lines from table of (x,y) values.
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
WritePixel | Change the pen num of one specific pixel in a specified RastPort.
GfxText | Write text characters (no formatting).


PRECISION_EXACT

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1113

const PRECISION_EXACT = - 1;


PRECISION_GUI

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1116

const PRECISION_GUI = 32;


PRECISION_ICON

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1115

const PRECISION_ICON = 16;


PRECISION_IMAGE

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1114

const PRECISION_IMAGE = 0;


PRect32

Pointer to Rectangle (Integer size Values)

Declaration

Source position: agraphics.pas line 43

type PRect32 = ^TRect32;


PRectangle

Pointer to Rectangle (Word size values)

Declaration

Source position: agraphics.pas line 35

type PRectangle = ^TRectangle;

See also

AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
ClearRectRegion
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
TRegionRectangle |
TClipRect | Clip rectangle
TLayer | Layer Structure
TTextExtent | A measured text size


PRegion

Declaration

Source position: agraphics.pas line 117

type PRegion = ^TRegion;


PRegionRectangle

Declaration

Source position: agraphics.pas line 111

type PRegionRectangle = ^TRegionRectangle;


PRESERVE_COLORS

Flag for CoerceMode Ensure that the mode coerced to can display just as many colours as the ViewPort being coerced.

Declaration

Source position: agraphics.pas line 885

const PRESERVE_COLORS = 1;


PROTO_MONITOR_ID

Declaration

Source position: agraphics.pas line 1281

const PROTO_MONITOR_ID = $00051000;


PSimpleSprite

Pointer to a simple sprite description

Declaration

Source position: agraphics.pas line 1733

type PSimpleSprite = ^TSimpleSprite;

See also

ChangeSprite | Change the sprite image pointer.
GetSprite | Attempt to get a sprite for the simple sprite manager.
MoveSprite | Move sprite to a point relative to top of viewport.


PSpecialMonitor

Declaration

Source position: agraphics.pas line 446

type PSpecialMonitor = ^TSpecialMonitor;


PTextAttr

TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 192

type PTextAttr = ^TTextAttr;

See also

SetFont | Set the text font and attributes in a RastPort.
OpenFont | Get a pointer to a system font.
StripFont | Remove the TextFontExtension from a font
OpenDiskFont |


PTextExtent

Pointer to a measured text size

Declaration

Source position: agraphics.pas line 270

type PTextExtent = ^TTextExtent;

See also

FontExtent | Get the font attributes of the current font
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent


PTextFont

Declaration

Source position: agraphics.pas line 210

type PTextFont = ^TTextFont;


PTextFontExtension

Declaration

Source position: agraphics.pas line 231

type PTextFontExtension = ^TTextFontExtension;


PTmpRas

Temporary rast port

Declaration

Source position: agraphics.pas line 367

type PTmpRas = ^TTmpRas;

See also

InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.
InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


PTTextAttr

Extended TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 200

type PTTextAttr = ^TTTextAttr;


PUCopList

Declaration

Source position: agraphics.pas line 289

type PUCopList = ^TUCopList;


PVecInfo

This structure is PRIVATE, for our use only Touch these, and burn!

Declaration

Source position: agraphics.pas line 1627

type PVecInfo = ^TVecInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_VEC | GetDisplayInfoData, Internal use only (PVecInfo)


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PView

Declaration

Source position: agraphics.pas line 497

type PView = ^TView;


PViewExtra

Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree

Declaration

Source position: agraphics.pas line 511

type PViewExtra = ^TViewExtra;


PViewPort

Declaration

Source position: agraphics.pas line 108

type PViewPort = ^TViewPort;


PViewPortExtra

Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()

Declaration

Source position: agraphics.pas line 540

type PViewPortExtra = ^TViewPortExtra;


PVSprite

Pointer to Sprite structure

Declaration

Source position: agraphics.pas line 290

type PVSprite = ^TVSprite;


RATIO_FIXEDPART

Declaration

Source position: agraphics.pas line 1056

const RATIO_FIXEDPART = 4;


RATIO_UNITY

Declaration

Source position: agraphics.pas line 1057

const RATIO_UNITY = 1 shl RATIO_FIXEDPART;


REALLY_PAL

Declaration

Source position: agraphics.pas line 1938

const REALLY_PAL = 16;


REQUEST_A2024

Declaration

Source position: agraphics.pas line 986

const REQUEST_A2024 = 1 shl MSB_REQUEST_A2024;


REQUEST_NTSC

Declaration

Source position: agraphics.pas line 983

const REQUEST_NTSC = 1 shl MSB_REQUEST_NTSC;


REQUEST_PAL

Declaration

Source position: agraphics.pas line 984

const REQUEST_PAL = 1 shl MSB_REQUEST_PAL;


REQUEST_SPECIAL

Declaration

Source position: agraphics.pas line 985

const REQUEST_SPECIAL = 1 shl MSB_REQUEST_SPECIAL;


RIGHTHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 942

const RIGHTHIT = 8;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


RINGTRIGGER

Define for the animation procedures

Declaration

Source position: agraphics.pas line 919

const RINGTRIGGER = $0001;


RPTAG_AlphaMode

Declaration

Source position: agraphics.pas line 1802

const RPTAG_AlphaMode = $80000083;


RPTAG_APen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set apen

Declaration

Source position: agraphics.pas line 1790

const RPTAG_APen = $80000002;


RPTAG_BgColor

Declaration

Source position: agraphics.pas line 1801

const RPTAG_BgColor = $80000082;


RPTAG_BPen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set bpen

Declaration

Source position: agraphics.pas line 1791

const RPTAG_BPen = $80000003;


RPTAG_DrawBounds

Tag for GetRPAttrsA() Get rastport draw bounds. pass PRectangle

Declaration

Source position: agraphics.pas line 1797

const RPTAG_DrawBounds = $80000008;


RPTAG_DrMd

Tag for GetRPAttrsA(), SetRPAttrsA() get/set draw mode

Declaration

Source position: agraphics.pas line 1792

const RPTAG_DrMd = $80000004;


RPTAG_FgColor

Declaration

Source position: agraphics.pas line 1800

const RPTAG_FgColor = $80000081;


RPTAG_Font

Tag for GetRPAttrsA(), SetRPAttrsA() get/set font

Declaration

Source position: agraphics.pas line 1789

const RPTAG_Font = $80000000;


RPTAG_MaxPen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set maxpen

Declaration

Source position: agraphics.pas line 1795

const RPTAG_MaxPen = $80000007;


RPTAG_OutlinePen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set outline pen.

Declaration

Source position: agraphics.pas line 1793

const RPTAG_OutlinePen = $80000005;


RPTAG_PenMode

Declaration

Source position: agraphics.pas line 1799

const RPTAG_PenMode = $80000080;


RPTAG_RetainAlpha

Declaration

Source position: agraphics.pas line 1803

const RPTAG_RetainAlpha = $80000084;


RPTAG_WriteMask

Tag for GetRPAttrsA(), SetRPAttrsA() get/set WriteMask

Declaration

Source position: agraphics.pas line 1794

const RPTAG_WriteMask = $80000006;


RPTAG_XPos

Declaration

Source position: agraphics.pas line 1805

const RPTAG_XPos = $80000085;


RPTAG_YPos

Declaration

Source position: agraphics.pas line 1806

const RPTAG_YPos = $80000086;


SAVEBACK

User Set flag for TVsprite.Flags. Set if background is to be saved/restored

Declaration

Source position: agraphics.pas line 896

const SAVEBACK = $0002;


SAVEBOB

Bob User Flag for TBob.Flags set to not erase Bob

Declaration

Source position: agraphics.pas line 907

const SAVEBOB = $0001;


SAVEPRESERVE

Bob System Flag for TBob.Flags For back-restore during double-buffer

Declaration

Source position: agraphics.pas line 915

const SAVEPRESERVE = $1000;


SPECIAL_BEAMCON

Declaration

Source position: agraphics.pas line 1003

const SPECIAL_BEAMCON = VARVBLANK or LOLDIS or VARVSYNC or VARHSYNC or VARBEAM or CSBLANK or VSYNCTRUE;


SPECIAL_FLAGS

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1484

const SPECIAL_FLAGS = DIPF_IS_DUALPF or DIPF_IS_PF2PRI or DIPF_IS_HAM or DIPF_IS_EXTRAHALFBRITE;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default - SPECIAL_FLAGS


SPECIAL_MONITOR_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 949

const SPECIAL_MONITOR_TYPE = 3;


SPRITE_ATTACHED

Declaration

Source position: agraphics.pas line 1729

const SPRITE_ATTACHED = $80;


SPRITEA_Attached

Tag for AllocSpriteDataA()

Declaration

Source position: agraphics.pas line 1754

const SPRITEA_Attached = $81000008;

Description

Tells the function that you wish to convert the data for the second sprite in an attached sprite pair. This will cause AllocSpriteDataA() to take its data from the 3rd and 4th bitplanes of the passed in bitmap.


SPRITEA_OldDataFormat

Tag for AllocSpriteDataA() must pass in outputheight if using this tag

Declaration

Source position: agraphics.pas line 1755

const SPRITEA_OldDataFormat = $8100000a;


SPRITEA_OutputHeight

Tag for AllocSpriteDataA() height of Sprite

Declaration

Source position: agraphics.pas line 1753

const SPRITEA_OutputHeight = $81000006;

Description

Specifies how tall the resulting sprite should be. Defaults to the bitmap height. The bitmap must be at least as tall as the output height.


SPRITEA_ViewPort

Declaration

Source position: agraphics.pas line 1757

const SPRITEA_ViewPort = $81000020;


SPRITEA_Width

Tag for AllocSpriteDataA() Width of Sprite Default - 16

Declaration

Source position: agraphics.pas line 1750

const SPRITEA_Width = $81000000;

Description

specifies how many pixels wide you desire the sprite to be. Specifying a width wider than the hardware can handle will cause the function to return failure. If the bitmap passed in is narrower than the width asked for, then it will be padded on the right with transparent pixels. Defaults to 16.


SPRITEA_XReplication

Tag for AllocSpriteDataA() Controls the horizontal pixel replication factor used when converting the bitmap data. Default - 0

Declaration

Source position: agraphics.pas line 1751

const SPRITEA_XReplication = $81000002;

Description

Controls the horizontal pixel replication factor used when converting the bitmap data. Valid values are:

0
perform a 1 to 1 conversion
1
each pixel from the source is replicated twice in the output.
2
each pixel is replicated 4 times.
-1
skip every other pixel in the source bitmap
-2
only include every fourth pixel from the source.

This tag is useful for converting data from one resolution to another. For instance, hi-res bitmap data can be correctly converted for a lo-res sprite by using an x replication factor of -1. Defaults to 0.


SPRITEA_YReplication

Tag for AllocSpriteDataA() Controls the vertical pixel replication factor used when converting the bitmap data. Default - 0

Declaration

Source position: agraphics.pas line 1752

const SPRITEA_YReplication = $81000004;

Description

controls the vertical pixel replication factor in the same manner as SPRITEA_XReplication controls the horizontal.


SPRITERESN_35NS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1087

const SPRITERESN_35NS = 3;


SPRITERESN_70NS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1086

const SPRITERESN_70NS = 2;


SPRITERESN_140NS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1085

const SPRITERESN_140NS = 1;


SPRITERESN_DEFAULT

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1088

const SPRITERESN_DEFAULT = - 1;


SPRITERESN_ECS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1084

const SPRITERESN_ECS = 0;


SPRITES

Declaration

Source position: agraphics.pas line 752

const SPRITES = 1 shl 14;


SS_GRAPHICS

TExtendedNode.xln_Subtype

Declaration

Source position: agraphics.pas line 945

const SS_GRAPHICS = $02;


STANDARD_COLORCLOCKS

Declaration

Source position: agraphics.pas line 997

const STANDARD_COLORCLOCKS = 226;


STANDARD_DENISE_MAX

Declaration

Source position: agraphics.pas line 998

const STANDARD_DENISE_MAX = 455;


STANDARD_DENISE_MIN

Declaration

Source position: agraphics.pas line 999

const STANDARD_DENISE_MIN = 93;


STANDARD_HBSTOP

Declaration

Source position: agraphics.pas line 1012

const STANDARD_HBSTOP = $2C;


STANDARD_HBSTRT

Declaration

Source position: agraphics.pas line 1009

const STANDARD_HBSTRT = $06;


STANDARD_HSSTOP

Declaration

Source position: agraphics.pas line 1011

const STANDARD_HSSTOP = $1C;


STANDARD_HSSTRT

Declaration

Source position: agraphics.pas line 1010

const STANDARD_HSSTRT = $0B;


STANDARD_MONITOR_MASK

Declaration

Source position: agraphics.pas line 993

const STANDARD_MONITOR_MASK = REQUEST_NTSC or REQUEST_PAL;


STANDARD_NTSC_BEAMCON

Declaration

Source position: agraphics.pas line 1000

const STANDARD_NTSC_BEAMCON = $0000;


STANDARD_NTSC_ROWS

Declaration

Source position: agraphics.pas line 995

const STANDARD_NTSC_ROWS = 262;


STANDARD_PAL_BEAMCON

Declaration

Source position: agraphics.pas line 1001

const STANDARD_PAL_BEAMCON = DISPLAYPAL;


STANDARD_PAL_ROWS

Declaration

Source position: agraphics.pas line 996

const STANDARD_PAL_ROWS = 312;


STANDARD_VBSTOP

Declaration

Source position: agraphics.pas line 1016

const STANDARD_VBSTOP = $1066;


STANDARD_VBSTRT

Declaration

Source position: agraphics.pas line 1013

const STANDARD_VBSTRT = $0122;


STANDARD_VIEW_X

Declaration

Source position: agraphics.pas line 1007

const STANDARD_VIEW_X = $81;


STANDARD_VIEW_Y

Declaration

Source position: agraphics.pas line 1008

const STANDARD_VIEW_Y = $2C;


STANDARD_VSSTOP

Declaration

Source position: agraphics.pas line 1015

const STANDARD_VSSTOP = $03AA;


STANDARD_VSSTRT

Declaration

Source position: agraphics.pas line 1014

const STANDARD_VSSTRT = $02A6;


STANDARD_XOFFSET

Declaration

Source position: agraphics.pas line 966

const STANDARD_XOFFSET = 9;


STANDARD_YOFFSET

Declaration

Source position: agraphics.pas line 967

const STANDARD_YOFFSET = 0;


StraightCopy

Vanilla copy

Declaration

Source position: agraphics.pas line 877

const StraightCopy = $C0;


SUPER72_MONITOR_ID

Declaration

Source position: agraphics.pas line 1337

const SUPER72_MONITOR_ID = $00081000;


SUPER72HIRESDBL_KEY

Declaration

Source position: agraphics.pas line 1344

const SUPER72HIRESDBL_KEY = $00089008;


SUPER72HIRESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1350

const SUPER72HIRESEHBDBL_KEY = $00089088;


SUPER72HIRESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1347

const SUPER72HIRESHAMDBL_KEY = $00089808;


SUPER72LORESDBL_KEY

Declaration

Source position: agraphics.pas line 1343

const SUPER72LORESDBL_KEY = $00081008;


SUPER72LORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1349

const SUPER72LORESEHBDBL_KEY = $00081088;


SUPER72LORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1346

const SUPER72LORESHAMDBL_KEY = $00081808;


SUPER72SUPERDBL_KEY

Declaration

Source position: agraphics.pas line 1345

const SUPER72SUPERDBL_KEY = $00089028;


SUPER72SUPEREHBDBL_KEY

Declaration

Source position: agraphics.pas line 1351

const SUPER72SUPEREHBDBL_KEY = $000890a8;


SUPER72SUPERHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1348

const SUPER72SUPERHAMDBL_KEY = $00089828;


SUPER_KEY

Declaration

Source position: agraphics.pas line 1191

const SUPER_KEY = $00008020;


SUPERDPF2_KEY

Declaration

Source position: agraphics.pas line 1205

const SUPERDPF2_KEY = $00008460;


SUPERDPF_KEY

Declaration

Source position: agraphics.pas line 1199

const SUPERDPF_KEY = $00008420;


SUPEREHB_KEY

Declaration

Source position: agraphics.pas line 1215

const SUPEREHB_KEY = $000080a0;


SUPEREHBLACE_KEY

Declaration

Source position: agraphics.pas line 1219

const SUPEREHBLACE_KEY = $000080a4;


SUPERHAM_KEY

Declaration

Source position: agraphics.pas line 1213

const SUPERHAM_KEY = $00008820;


SUPERHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1217

const SUPERHAMLACE_KEY = $00008824;


SUPERHIRES

Declaration

Source position: agraphics.pas line 744

const SUPERHIRES = 1 shl 5;


SUPERLACE_KEY

Declaration

Source position: agraphics.pas line 1195

const SUPERLACE_KEY = $00008024;


SUPERLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1208

const SUPERLACEDPF2_KEY = $00008464;


SUPERLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1202

const SUPERLACEDPF_KEY = $00008424;


SUSERFLAGS

Mask of all user-settable TVsprite.Flags

Declaration

Source position: agraphics.pas line 899

const SUSERFLAGS = $00FF;

See also

SAVEBACK | User Set flag for TVsprite.Flags. Set if background is to be saved/restored
OVERLAY | User Set flag for TVsprite.Flags. Set to mask image of Bob onto background
MUSTDRAW | User Set flag for TVsprite.Flags. Set if VSprite absolutely must be drawn


TA_Bold

Declaration

Source position: agraphics.pas line 763

const TA_Bold = TAG_USER + 103;


TA_ColorFont

Declaration

Source position: agraphics.pas line 766

const TA_ColorFont = TAG_USER + 106;


TA_Designed

Declaration

Source position: agraphics.pas line 774

const TA_Designed = TAG_USER + 113;


TA_DeviceDPI

Tag for TTTextAttr.tta_Tags

Declaration

Source position: agraphics.pas line 757

const TA_DeviceDPI = TAG_USER + 1;

Description

Tag value is Point union: Hi word XDPI, Lo word YDPI


TA_DiskFont

Declaration

Source position: agraphics.pas line 769

const TA_DiskFont = TAG_USER + 108;


TA_Extended

Declaration

Source position: agraphics.pas line 765

const TA_Extended = TAG_USER + 105;


TA_Italic

Declaration

Source position: agraphics.pas line 764

const TA_Italic = TAG_USER + 104;


TA_Name

Declaration

Source position: agraphics.pas line 759

const TA_Name = TAG_USER + 100;


TA_Proportional

Declaration

Source position: agraphics.pas line 773

const TA_Proportional = TAG_USER + 112;


TA_RevPath

Declaration

Source position: agraphics.pas line 770

const TA_RevPath = TAG_USER + 109;


TA_ROMFont

Declaration

Source position: agraphics.pas line 768

const TA_ROMFont = TAG_USER + 107;


TA_TallDot

Declaration

Source position: agraphics.pas line 771

const TA_TallDot = TAG_USER + 110;


TA_Underlined

Declaration

Source position: agraphics.pas line 762

const TA_Underlined = TAG_USER + 102;


TA_WideDot

Declaration

Source position: agraphics.pas line 772

const TA_WideDot = TAG_USER + 111;


TA_YSize

Declaration

Source position: agraphics.pas line 760

const TA_YSize = TAG_USER + 101;


TAnalogSignalInterval

Declaration

Source position: agraphics.pas line 441

type TAnalogSignalInterval = record

  asi_Start: Word;

  asi_Stop: Word;

end;

See also

TSpecialMonitor


TAnimComp

Declaration

Source position: agraphics.pas line 676

type TAnimComp = record
Flags: SmallInt; | AnimComp flags for system and user
Timer: SmallInt; | timer defines how long to keep this component active: if set non-zero, timer decrements to zero then switches to nextSeq if set to zero, AnimComp never switches
TimeSet: SmallInt; | Initial value for timer when the AnimComp is activated by the system
NextComp: PAnimComp; | Pointer to next components of animation object
PrevComp: PAnimComp; | Pointer to previous components of animation object
NextSeq: PAnimComp; | Pointer to component component definition of next image in sequence
PrevSeq: PAnimComp; | pointer to component component definition of previous image in sequence
AnimCRoutine: Pointer; | Pointer of special animation procedure
YTrans: SmallInt; | Initial y translation (if this is a component)
XTrans: SmallInt; | Initial x translation (if this is a component)
HeadOb: PAnimOb; |
AnimBob: PBob; |
end;


TAnimOb

Declaration

Source position: agraphics.pas line 696

type TAnimOb = record
NextOb: PAnimOb; | Next Bob
PrevOb: PAnimOb; | Previous Bob
Clock: LongInt; | Number of calls to Animate this AnimOb has endured
AnOldY: SmallInt; | Old y coordinate
AnOldX: SmallInt; | Old x coordinate
AnY: SmallInt; | y coordinate of the AnimOb
AnX: SmallInt; | x coordinate of the AnimOb
YVel: SmallInt; | Velocity of this object in y direction
XVel: SmallInt; | Velocity of this object in x direction
YAccel: SmallInt; | Acceleration of this object in y direction
XAccel: SmallInt; | Acceleration of this object in x direction
RingYTrans: SmallInt; | Ring translation y value
RingXTrans: SmallInt; | Ring translation x values
AnimORoutine: Pointer; | Pointer of special animation procedure
HeadComp: PAnimComp; | Pointer to first component
AUserExt: SmallInt; | AnimOb user extension
end;


TAreaInfo

Declaration

Source position: agraphics.pas line 356

type TAreaInfo = record
VctrTbl: PSmallInt; | Pointer to start of vector table
VctrPtr: PSmallInt; | Pointer to current vertex
FlagTbl: PShortInt; | Pointer to start of vector flag table
FlagPtr: PShortInt; | Pointers to areafill flags
Count: SmallInt; | Number of vertices in list
MaxCount: SmallInt; | AreaMove/AreaDraw will not allow Count>MaxCount
FirstX: SmallInt; | First point for this polygon (X coordinate)
FirstY: SmallInt; | First point for this polygon (Y coordinate)
end;

See also

InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


TAUserStuff

Declaration

Source position: agraphics.pas line 602

type TAUserStuff = SmallInt;


TBitMap

Represents an image in ram.

Declaration

Source position: agraphics.pas line 59

type TBitMap = record
BytesPerRow: Word; | Width of a line it Bytes (To get the width of the Bitmap in pixels you have to multiply this value with 8 and divide by the Depth.)
Rows: Word; | Number of lines in the Bitmap
Flags: Byte; | Flags for the bitmap when created on AllocBitmap (BMF_*)
Depth: Byte; | Number of Bitplanes
Pad: Word; | Padding byte
Planes: array [0..7] of PByte; | Pointer to the bitplanes. Depth defines how many pointers
end;

Description

Drawing to a Bitmap is mostly done by drawing on a TRastPort with the linked Bitmap TRastPort.Bitmap.

See also

AllocBitmap | Allocate a bitmap and attach bitplanes to it.
FreeBitmap | Free a bitmap created by AllocBitMap()
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
BltBitMap | Move a rectangular region of bits in a BitMap.
BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ChangeVPBitmap | Change display memory address for multi-buffered animation
GetBitMapAttr | Returns information about a bitmap
InitBitMap | Initialize bit map structure with input values.
TRastPort | Basic structure for all drawing actions


TBitScaleArgs

BitScaleArgs structure used by BitMapScale()

Declaration

Source position: agraphics.pas line 1770

type TBitScaleArgs = record
bsa_SrcX: Word; | Source origin x position
bsa_SrcY: Word; | Source origin y position
bsa_SrcWidth: Word; | Source width
bsa_SrcHeight: Word; | Source height
bsa_XSrcFactor: Word; | Scale factor in x direction denominator
bsa_YSrcFactor: Word; | Scale factor in y direction denominator
bsa_DestX: Word; | Destination origin x position
bsa_DestY: Word; | Destination origin y position
bsa_DestWidth: Word; | Destination width
bsa_DestHeight: Word; | Destination height
bsa_XDestFactor: Word; | Destination scale factor in x direction numerator
bsa_YDestFactor: Word; | Destination scale factor in y direction numerator
bsa_SrcBitMap: PBitMap; | Source Bitmap
bsa_DestBitMap: PBitMap; | Destination Bitmap
bsa_Flags: LongWord; | reserved. Must be zero!
bsa_XDDA: Word; | reserved
bsa_YDDA: Word; | reserved
bsa_Reserved1: LongInt; |
bsa_Reserved2: LongInt; |
end;


TBob

Blitter object

Declaration

Source position: agraphics.pas line 660

type TBob = record
Flags: SmallInt; | General purpose flags
SaveBuffer: PSmallInt; | Pointer to the buffer for background save
ImageShadow: PSmallInt; | Pointer to the buffer for background save
Before: PBob; | Draw this Bob before Bob pointed to by before
After: PBob; | Draw this Bob after Bob pointed to by after
BobVSprite: PVSprite; | This Bob's VSprite definition
BobComp: PAnimComp; | PAnimComp pointer to this Bob's AnimComp def
DBuffer: PDBufPacket; | Pointer to this Bob's dBuf packet
BUserExt: SmallInt; | Bob user extension
end;


TBUserStuff

Declaration

Source position: agraphics.pas line 601

type TBUserStuff = SmallInt;


TClipRect

Clip rectangle

Declaration

Source position: agraphics.pas line 123

type TClipRect = record
Next: PClipRect; | Pointer to next ClipRect
prev: PClipRect; | Pointer to previous ClipRect
lobs: PLayer; | Ignored by roms, used by windowlib
BitMap: PBitMap; |
Bounds: TRectangle; | Set up by windowlib, used by roms
_p1: Pointer; | system reserved
_p2: Pointer; | system reserved
reserved: LongInt; | system use
end;

See also

TLayer

Layer Structure


TCollTable

Declaration

Source position: agraphics.pas line 375

type TCollTable = array [0..15] of Pointer;


TColorFontColors

Declaration

Source position: agraphics.pas line 247

type TColorFontColors = record
cfc_Reserved: Word; | Must be zero
cfc_Count: Word; | Number of entries in cfc_ColorTable
cfc_ColorTable: PWord; | 4 bit per component color map packed xRGB
end;


TColorMap

This structure is the primary storage for palette data.

Declaration

Source position: agraphics.pas line 553

type TColorMap = record
Flags: Byte; | Colormap flags (COLORMAP_*)
Type_: Byte; | Colormap type, reflects version (COLORMAP_TYPE_)
Count: Word; | Number of palette entries
ColorTable: PWord; | Table of high nibbles of color values (see description above)
cm_vpe: PViewPortExtra; | ViewPortExtra, for faster access
LowColorBits: PWord; | Table of low nibbles of color values
TransparencyPlane: Byte; |
SpriteResolution: Byte; |
SpriteResDefault: Byte; |
AuxFlags: Byte; | Additional flags (CMAF_*)
cm_vp: PViewPort; | Points back to a ViewPort this colormap belongs to
NormalDisplayInfo: Pointer; |
CoerceDisplayInfo: Pointer; |
cm_batch_items: PTagItem; |
VPModeID: LongWord; |
PalExtra: PPaletteExtra; | Structure controlling palette sharing
SpriteBase_Even: Word; | Color bank for even sprites
SpriteBase_Odd: Word; | The same for odd sprites
Bp_0_base: Word; |
Bp_1_base: Word; |
end;

Description

Color data itself is stored in two tables: ColorTable and LowColorBits. These fields are actually pointer to arrays of Words. Each Word corresponds to one color. Number of Words in these array is equal to Count value in this structure. ColorTable stores upper nibbles of RGB values, LowColorBits stores low nibbles.

Example:

color number 4, value: $00ABCDEF
   ColorTable[4] := $0ACE,
   LowColorBits[4] := $0BDF

SpriteBase fields keep bank number, not a color number. On m68k Amiga colors are divided into banks, 16 per each. So bank number is color number divided by 16. Base color is a number which is added to all colors of the sprite in order to look up the actual palette entry. Amiga may run on different hardware where sprites may have base colors that do not divide by 16. In order to cover this bank numbers have a form: ((c and $0F) shl 8 ) or (c shr 4), where c is actual color number (i. e. remainder is stored in a high byte of Word).


TColorTextFont

Color font structure

Declaration

Source position: agraphics.pas line 254

type TColorTextFont = record
ctf_TF: TTextFont; | Standard Textfont structure
ctf_Flags: Word; | Extended flags (CT_*)
ctf_Depth: Byte; | Number of bit planes
ctf_FgColor: Byte; | Color that is remapped to FgPen
ctf_Low: Byte; | Lowest color represented here
ctf_High: Byte; | Highest color represented here
ctf_PlanePick: Byte; | PlanePick ala Images
ctf_PlaneOnOff: Byte; | PlaneOnOff ala Images
ctf_ColorFontColors: PColorFontColors; | Colors for font
ctf_CharData: array [0..7] of Pointer; | Pointers to bit planes ala TTextFont.tf_CharData
end;


TCopInit

Declaration

Source position: agraphics.pas line 340

type TCopInit = record

  vsync_hblank: array [0..1] of Word;

  diagstrt: array [0..11] of Word;

  fm0: array [0..1] of Word;

  diwstart: array [0..9] of Word;

  bplcon2: array [0..1] of Word;

  sprfix: array [0..15] of Word;

  sprstrtup: array [0..31] of Word;

  wait14: array [0..1] of Word;

  norm_hblank: array [0..1] of Word;

  jump: array [0..1] of Word;

  wait_forever: array [0..5] of Word;

  sprstop: array [0..7] of Word;

end;


TCopIns

Copper structure

Declaration

Source position: agraphics.pas line 293

type TCopIns = record
OpCode: SmallInt; | 0 = move, 1 = wait
case SmallInt of
0: (
NxtList: PCopList; |
);
1: (
DestAddr: SmallInt; | destination Pointer
DestData: SmallInt; | data to send
);
2: (
VWaitPos: SmallInt; | vertical wait position
HWaitPos: SmallInt; | horizontal wait position
);
end;


TCopList

Declaration

Source position: agraphics.pas line 324

type TCopList = record
Next: PCopList; | Next block for this copper list
_CopList: PCopList; | System use
_ViewPort: PViewPort; | System use
CopIns: PCopIns; | start of this block
CopPtr: PCopIns; | intermediate ptr
CopLStart: PSmallInt; | mrgcop fills this in for Long Frame
CopSStart: PSmallInt; | mrgcop fills this in for Longint Frame
Count: SmallInt; | intermediate counter
MaxCount: SmallInt; | max # of copins for this block
DyOffset: SmallInt; | offset this copper list vertical waits
SLRepeat: Word; |
Flags: Word; |
end;


TCprList

Structure of cprlist that points to list that hardware actually executes

Declaration

Source position: agraphics.pas line 311

type TCprList = record
Next: PCprList; |
Start: PWord; | start of copper list
MaxCount: SmallInt; | Number of long instructions
end;


TDBufInfo

Double buffer structure

Declaration

Source position: agraphics.pas line 1141

type TDBufInfo = record
dbi_Link1: Pointer; |
dbi_Count1: LongWord; |
dbi_SafeMessage: TMessage; | Replied to when safe to write to old bitmap
dbi_UserData1: Pointer; | First user data
dbi_Link2: Pointer; |
dbi_Count2: LongWord; |
dbi_DispMessage: TMessage; | Replied to when new bitmap has been displayed at least once
dbi_UserData2: Pointer; | Second user data
dbi_MatchLong: LongWord; |
dbi_CopPtr1: Pointer; |
dbi_CopPtr2: Pointer; |
dbi_CopPtr3: Pointer; |
dbi_BeamPos1: Word; |
dbi_BeamPos2: Word; |
end;

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation
FreeDBufInfo | Free information for multi-buffered animation


TDBufPacket

Defines the values needed to be saved across buffer to buffer when in double-buffer mode

Declaration

Source position: agraphics.pas line 652

type TDBufPacket = record
BufY: SmallInt; | Save other buffers screen coordinates
BufX: SmallInt; | Save other buffers screen coordinates
BufPath: PVSprite; | Carry the draw path over the gap
BufBuffer: PSmallInt; | These pointers must be filled in by the user pointer to other buffer's background save buffer
end;


TDimensionInfo

Monitor dimensions (like overscan)

Declaration

Source position: agraphics.pas line 1576

type TDimensionInfo = record
Header: TQueryHeader; |
MaxDepth: Word; | log2(max number of colors)
MinRasterWidth: Word; | Minimum width in pixels
MinRasterHeight: Word; | Minimum height in pixels
MaxRasterWidth: Word; | Maximum width in pixels
MaxRasterHeight: Word; | Maximum height in pixels
Nominal: TRectangle; | "Standard" dimensions without overscan
MaxOScan: TRectangle; | Fixed, hardware dependant
VideoOScan: TRectangle; | Fixed, hardware dependant
TxtOScan: TRectangle; | Editable via preferences
StdOScan: TRectangle; | Editable via preferences
Pad: array [0..13] of Byte; |
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_DIMS | GetDisplayInfoData, results in PDimensionInfo


TDisplayInfo

Structure to hold informations about Display.

Declaration

Source position: agraphics.pas line 1557

type TDisplayInfo = record
Header: TQueryHeader; |
NotAvailable: Word; | If 0 DisplayInfo available, else not available -> see Constants DI_AVAIL_*
PropertyFlags: LongWord; | Properties of this mode (DIPF_*)
Resolution: TPoint; | Ticks-per-pixel X/Y
PixelSpeed: Word; | Approximation in nanoseconds
NumStdSprites: Word; | Number of standard amiga sprites
PaletteRange: Word; | Distinguishable shades available
SpriteResolution: TPoint; | Standard sprite ticks-per-pixel X/Y
pad: array [0..3] of Byte; |
RedBits: Byte; | Number of bits for Red color
GreenBits: Byte; | Number of bits for Green color
BlueBits: Byte; | Number of bits for Blue color
pad2: array [0..4] of Byte; |
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

FindDisplayInfo | Search for a record identified by a specific key
GetDisplayInfoData | Query DisplayInfo Record parameters


TE0B_NOREMFONT

Flag bit TTextFontExtension.tfe_Flags0 disallow RemFont for this font

Declaration

Source position: agraphics.pas line 780

const TE0B_NOREMFONT = 0;


TE0F_NOREMFONT

Flag value TTextFontExtension.tfe_Flags0 disallow RemFont for this font

Declaration

Source position: agraphics.pas line 781

const TE0F_NOREMFONT = $01;


TExtendedNode

Declaration

Source position: agraphics.pas line 69

type TExtendedNode = record
xln_Succ: PNode; |
xln_Pred: PNode; |
xln_Type: Byte; | NT_GRAPHICS
xln_Pri: ShortInt; |
xln_Name: PChar; |
xln_Subsystem: Byte; | VIEW_EXTRA_TYPE, VIEWPORT_EXTRA_TYPE, SPECIAL_MONITOR_TYPE or MONITOR_SPEC_TYPE
xln_Subtype: Byte; | SS_GRAPHICS
xln_Library: LongInt; |
xln_Init: Pointer; |
end;


TExtSprite

Extended sprite Structure

Declaration

Source position: agraphics.pas line 1742

type TExtSprite = record
es_SimpleSprite: TSimpleSprite; | Conventional simple sprite structure
es_WordWidth: Word; | Graphics use only, subject to change
es_Flags: Word; | Graphics use only, subject to change
end;

See also

AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
ChangeExtSpriteA | Change the sprite image pointer.
FreeSpriteData | free sprite data allocated by AllocSpriteData()
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.


TGelsInfo

Declaration

Source position: agraphics.pas line 380

type TGelsInfo = record
sprRsrvd: ShortInt; | Flag of which sprites to reserve from vsprite system
Flags: Byte; | System use
gelHead: PVSprite; | PVSprite Dummy vSprite for list management
gelTail: PVSprite; | PVSprite Dummy vSprite for list management
NextLine: PSmallInt; | Pointer to array of 8 WORDS for sprite available lines
LastColor: ; | Pointer to array of 8 pointers for color-last-assigned to vSprites
CollHandler: PCollTable; | PCollTable Pointeres of collision routines
LeftMost: SmallInt; |
RightMost: SmallInt; |
TopMost: SmallInt; |
BottomMost: SmallInt; |
FirstBlissObj: Pointer; | System use only
LastBlissObj: Pointer; | System use only
end;

See also

TRastPort | Basic structure for all drawing actions
InitGels | initialize a gel list; must be called before using gels.
SetCollision | Set a pointer to a user collision routine.


TGfxBase

Graphics library structure

Declaration

Source position: agraphics.pas line 1810

type TGfxBase = record
LibNode: TLibrary; | Basic Library structure
ActiView: PView; |
CopInit: PCopInit; | Pointer to copper start up list
Cia: PLongInt; | For 8520 resource use
blitter: PLongInt; | For future blitter resource use
LOFlist: PWord; |
SHFlist: PWord; |
blthd: Pbltnode; |
blttl: Pbltnode; |
bsblthd: Pbltnode; |
bsblttl: Pbltnode; |
vbsrv: TInterrupt; |
timsrv: TInterrupt; |
bltsrv: TInterrupt; |
TextFonts: TList; | List of Fonts
DefaultFont: PTextFont; | Current default font
Modes: Word; | Copy of current first bplcon0
VBlank: ShortInt; |
Debug: ShortInt; |
BeamSync: SmallInt; |
system_bplcon0: SmallInt; | It is ored into each bplcon0 for display
SpriteReserved: Byte; |
bytereserved: Byte; |
Flags: Word; |
BlitLock: SmallInt; |
BlitNest: SmallInt; |
BlitWaitQ: TList; |
BlitOwner: PTask; |
TOF_WaitQ: TList; |
DisplayFlags: Word; | NTSC PAL GENLOC etc. Display flags are determined at power on
SimpleSprites: PPSimpleSprite; | Simple sprite pointer
MaxDisplayRow: Word; | hardware stuff, do not use
MaxDisplayColumn: Word; | hardware stuff, do not use
NormalDisplayRows: Word; |
NormalDisplayColumns: Word; |
NormalDPMX: Word; | Dots per meter on display standard non interlace, 1/2 wb width
NormalDPMY: Word; | Dots per meter on display standard non interlace, 1/2 wb width
LastChanceMemory: PSignalSemaphore; |
LCMptr: PWord; |
MicrosPerLine: Word; | 256 time usec/line
MinDisplayColumn: Word; |
ChipRevBits0: Byte; |
MemType: Byte; |
crb_reserved: array [0..3] of Byte; |
monitor_id: Word; | normally 0
hedley: array [0..7] of LongWord; |
hedley_sprites: array [0..7] of LongWord; | sprite ptrs for intuition mouse
hedley_sprites1: array [0..7] of LongWord; | sprite ptrs for intuition mouse
hedley_count: SmallInt; |
hedley_flags: Word; |
hedley_tmp: SmallInt; |
hash_table: PLongInt; | Hashtable used for GfxAssociate() and GfxLookup() (private!)
current_tot_rows: Word; |
current_tot_cclks: Word; |
hedley_hint: Byte; |
hedley_hint2: Byte; |
nreserved: array [0..3] of LongWord; |
a2024_sync_raster: PLongInt; |
control_delta_pal: Word; |
control_delta_ntsc: Word; |
Current_Monitor: PMonitorSpec; | MonitorSpec used for current display
MonitorList: TList; | List of all MonitorSpecs in the system
Default_Monitor: PMonitorSpec; | MonitorSpec of "default.monitor"
MonitorListSemaphore: PSignalSemaphore; | Semaphore for MonitorList access
DisplayInfoDataBase: Pointer; |
TopLine: Word; |
ActiViewCprSemaphore: PSignalSemaphore; | Semaphore for active view access
UtilityBase: PLongWord; | for hook and tag utilities
ExecBase: PLongWord; | to link with rom.lib
bwshifts: PShortInt; |
StrtFetchMasks: PWord; |
StopFetchMasks: PWord; |
Overrun: PWord; |
RealStops: PSmallInt; |
SpriteWidth: Word; | current width (in words) of sprites
SpriteFMode: Word; | current sprite fmode bits
SoftSprites: ShortInt; | bit mask of size change knowledgeable sprites
arraywidth: ShortInt; |
DefaultSpriteWidth: Word; | What width intuition wants
SprMoveDisable: ShortInt; |
WantChips: Byte; |
BoardMemType: Byte; |
Bugs: Byte; |
gb_LayersBase: PLongWord; | layers.library base
ColorMask: LongWord; |
IVector: Pointer; |
IData: Pointer; |
SpecialCounter: LongWord; | special for double buffering
DBList: Pointer; |
MonitorFlags: Word; |
ScanDoubledSprites: Byte; |
BP3Bits: Byte; |
MonitorVBlank: TAnalogSignalInterval; |
Natural_Monitor: PMonitorSpec; | Default MonitorSpec for view without explicit MonitorSpec in ViewExtra
ProgData: Pointer; |
ExtSprites: Byte; |
pad3: Byte; |
GfxFlags: Word; |
VBCounter: LongWord; |
HashTableSemaphore: PSignalSemaphore; | Semaphore for hash_table access, private in fact
case Boolean of
True: (
ChunkyToPlanarPtr: PLongWord; | = HWEmul[0];
);
False: (
HWEmul: array [0..8] of PLongWord; |
);
end;


TIsrvstr

Declaration

Source position: agraphics.pas line 955

type TIsrvstr = record

  is_Node: TNode;

  Iptr: PIsrvstr;

  code: Pointer;

  ccode: Pointer;

  Carg: Pointer;

end;


TLayer

Layer Structure

Declaration

Source position: agraphics.pas line 158

type TLayer = record
Front: PLayer; | Link to next layer (in front of the current one)
Back: PLayer; | Link to the previous layer (behind the current one)
ClipRect: PClipRect; | Read by roms to find first cliprect
Rp: PRastPort; | Ignored by roms, I hope
Bounds: TRectangle; | Ignored by roms
Reserved: array [0..3] of Byte; |
Priority: Word; | system use only
Flags: Word; | obscured ?, Virtual BitMap?
SuperBitMap: PBitMap; |
SuperClipRect: PClipRect; | Super bitmap cliprects if VBitMap <> 0 else damage cliprect list for refresh
Window: Pointer; | Reserved for user interface use
Scroll_X: Word; |
Scroll_Y: Word; |
Cr: PClipRect; | used by dedice
Cr2: PClipRect; | used by dedice
CrNew: PClipRect; | used by dedice
SuperSaveClipRects: PClipRect; | preallocated Clip rects
_ClipRects: PClipRect; | System use during refresh
LayerInfo: Pointer; | Points to head of the list
Lock: TSignalSemaphore; |
BackFill: PHook; |
Reserved1: LongWord; |
ClipRegion: PRegion; |
SaveClipRects: PRegion; | Used to back out when in trouble
Width: SmallInt; | Width of layer
Height: SmallInt; | Height of Layer
Reserved2: array [0..17] of Byte; |
DamageList: PRegion; | List of rectangles to refreshthrough
end;


TLayer_Info

Declaration

Source position: agraphics.pas line 134

type TLayer_Info = record

  Top_Layer: PLayer;

  check_lp: PLayer;

  Obs: PClipRect;

  FreeClipRects: PClipRect;

  PrivateReserve1: LongInt;

  PrivateReserve2: LongInt;

  Lock: TSignalSemaphore;

  gs_Head: TMinList;

  PrivateReserve3: SmallInt;

  PrivateReserve4: Pointer;

  Flags: Word;

  fatten_count: ShortInt;

  LockLayersCount: ShortInt;

  PrivateReserve5: SmallInt;

  BlankHook: Pointer;

  LayerInfo_extra: Pointer;

end;


TMonitorInfo

Monitor Informations structure

Declaration

Source position: agraphics.pas line 1593

type TMonitorInfo = record
Header: TQueryHeader; |
Mspc: PMonitorSpec; | Pointer to monitor specification
ViewPosition: TPoint; | Editable via preferences
ViewResolution: TPoint; | Standard monitor ticks-per-pixel
ViewPositionRange: TRectangle; | Fixed, hardware dependant
TotalRows: Word; | Display height in scanlines
TotalColorClocks: Word; | Scanline width in 280 ns units
MinRow: Word; | Absolute minimum active scanline
Compatibility: SmallInt; | how this coexists with others (MCOMPAT_*)
Pad: array [0..31] of Byte; |
MouseTicks: TPoint; |
DefaultViewPosition: TPoint; |
PreferredModeID: LongWord; |
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_MNTR | GetDisplayInfoData, results in PMonitorInfo


TMonitorSpec

Declaration

Source position: agraphics.pas line 462

type TMonitorSpec = record
ms_Node: TExtendedNode; |
ms_Flags: Word; | Monitor Flags: (MSF_*)
ratioh: LongInt; |
ratiov: LongInt; |
total_rows: Word; | Total number of scanlines per frame
total_colorclocks: Word; | Total number of color clocks per line (in 1/280 ns units)
DeniseMaxDisplayColumn: Word; |
BeamCon0: Word; | Value for beamcon0 Amiga(tm) chipset register
min_row: Word; |
ms_Special: PSpecialMonitor; | Synchro signal timings description (optional)
ms_OpenCount: Word; | Driver open count
ms_transform: Pointer; |
ms_translate: Pointer; |
ms_scale: Pointer; |
ms_xoffset: Word; |
ms_yoffset: Word; |
ms_LegalView: TRectangle; | Allowed range for view positioning (right-bottom position included)
ms_maxoscan: Pointer; | maximum legal overscan
ms_videoscan: Pointer; | video display overscan
DeniseMinDisplayColumn: Word; |
DisplayCompatible: LongWord; |
DisplayInfoDataBase: TList; |
DisplayInfoDataBaseSemaphore: TSignalSemaphore; |
ms_MrgCop: Pointer; |
ms_LoadView: Pointer; |
ms_KillView: Pointer; |
end;


TNameInfo

Name of the Display

Declaration

Source position: agraphics.pas line 1620

type TNameInfo = record
Header: TQueryHeader; |
Name: array [0..DISPLAYNAMELEN-1] of Char; |
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_NAME | GetDisplayInfoData, results in PNameInfo


TO_MONITOR

Declaration

Source position: agraphics.pas line 964

const TO_MONITOR = 0;


TODA_SAFE

Flag for TGfxBase.DisplayFlags

Declaration

Source position: agraphics.pas line 1937

const TODA_SAFE = 8;


TOPHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 939

const TOPHIT = 1;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


TPaletteExtra

Structure controlling palette sharing

Declaration

Source position: agraphics.pas line 583

type TPaletteExtra = record
pe_Semaphore: TSignalSemaphore; | shared semaphore for arbitration
pe_FirstFree: Word; | private
pe_NFree: Word; | number of free colors
pe_FirstShared: Word; | private
pe_NShared: Word; | private
pe_RefCnt: PByte; | private
pe_AllocList: PByte; | private
pe_ViewPort: PViewPort; | Back pointer to viewport
pe_SharableColors: Word; | The number of sharable colors.
end;

Description

Structure may be extended so watch out!


TPlanePtr

Pointer to Bitplane coded image data, can be created with AllocRaster

Declaration

Source position: agraphics.pas line 56

type TPlanePtr = PByte;

See also

AllocRaster | Allocate space for a bitplane.
FreeRaster | Release an allocated area to the system free memory pool


TPoint

Basic definition of a point (x,y)

Declaration

Source position: agraphics.pas line 52

type TPoint = record
x: SmallInt; | X-Value
y: SmallInt; | Y-Value
end;


TQueryHeader

Header for TDisplayInfo

Declaration

Source position: agraphics.pas line 1549

type TQueryHeader = record
StructID: LongWord; | datachunk type identifiers
DisplayID: LongWord; | Copy of display record key
SkipID: LongWord; | utility.TAG_SKIP
Length: LongWord; | Length of local data in double-longwords
end;


TRasInfo

Used in TViewPort

Declaration

Source position: agraphics.pas line 432

type TRasInfo = record
Next: PRasInfo; | Used for Dual playfield
BitMap: PBitMap; |
RxOffset: SmallInt; | X Scroll offset in this BitMap
RyOffset: SmallInt; | Y Scroll offset in this BitMap
end;


TRastPort

Basic structure for all drawing actions

Declaration

Source position: agraphics.pas line 396

type TRastPort = record
Layer: PLayer; | Pointer to Layer of Rastport
BitMap: PBitMap; | Pointer to Bitmap data
AreaPtrn: PWord; | Area Fill pattern
TmpRas: PTmpRas; | Temporary Rastport, needed for Area actions
AreaInfo: PAreaInfo; |
GelsInfo: PGelsInfo; |
Mask: Byte; | Write mask for this raster
FgPen: ShortInt; | Foreground pen for this raster
BgPen: ShortInt; | Background pen for this raster
AOlPen: ShortInt; | AreaFill outline pen
DrawMode: ShortInt; | Drawing mode for fill, lines, and text (JAM1, JAM2, COMPLEMENT, INVERSVID)
AreaPtSz: ShortInt; | 2**n words for areafill pattern
LinPatCnt: ShortInt; | current line drawing pattern preshift
dummy: ShortInt; |
Flags: Word; | Miscellaneous control bits (FRST_DOT, ONE_DOT, DBUFFER)
LinePtrn: Word; | 16 bits for textured lines
cp_x: SmallInt; | Current x pen position
cp_y: SmallInt; | Current y pen position
minterms: array [0..7] of Byte; |
PenWidth: SmallInt; |
PenHeight: SmallInt; |
Font: PTextFont; | PTextFont current font Pointer
AlgoStyle: Byte; | The algorithmically generated style
TxFlags: Byte; | Text specific flags
TxHeight: Word; | Text height
TxWidth: Word; | Text nominal width
TxBaseline: Word; | Text baseline
TxSpacing: SmallInt; | Text spacing (per character)
RP_User: Pointer; |
longreserved: array [0..1] of LongWord; |
wordreserved: array [0..6] of Word; | Used to be a node
reserved: array [0..7] of Byte; | For future use
end;

See also

BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
BltPattern | Using standard drawing rules for areafill, blit through a mask.
ClearEOL | Clear from current position to end of line.
ClearScreen | Clear from current position to end of RastPort.
ClipBlit | Calls BltBitMap() after accounting for windows
Draw | Draw a line between the current pen position and the new x,y position.
DrawEllipse | Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.
EraseRect | Fill a defined rectangular area using the current BackFill hook.
Flood | Flood rastport like areafill.
GfxMove | Move graphics pen position.
InitRastPort | Initialize raster port structure
PolyDraw | Draw lines from table of (x,y) values.
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
WritePixel | Change the pen num of one specific pixel in a specified RastPort.
GfxText | Write text characters (no formatting).


TRect32

Basic struct for defining a rectengular region with integer values

Declaration

Source position: agraphics.pas line 44

type TRect32 = record
MinX: LongInt; | Left Edge
MinY: LongInt; | Top edge
MaxX: LongInt; | Right Edge
MaxY: LongInt; | Bottom Edge
end;


TRectangle

Basic struct for defining a rectengular region with word values

Declaration

Source position: agraphics.pas line 36

type TRectangle = record
MinX: SmallInt; | Left edge
MinY: SmallInt; | Top edge
MaxX: SmallInt; | Right edge
MaxY: SmallInt; | Bottom Edge
end;

See also

AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
ClearRectRegion
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
TRegionRectangle |
TClipRect | Clip rectangle
TLayer | Layer Structure
TTextExtent | A measured text size


TRegion

Declaration

Source position: agraphics.pas line 118

type TRegion = record

  Bounds: TRectangle;

  RegionRectangle: PRegionRectangle;

end;


TRegionRectangle

Declaration

Source position: agraphics.pas line 112

type TRegionRectangle = record

  Next: PRegionRectangle;

  Prev: PRegionRectangle;

  Bounds: TRectangle;

end;


TSimpleSprite

Sprite description structure

Declaration

Source position: agraphics.pas line 1734

type TSimpleSprite = record
PosCtlData: PWord; |
Height: Word; |
x: Word; | Current x position
y: Word; | Current y position
Num: Word; |
end;

See also

ChangeSprite | Change the sprite image pointer.
GetSprite | Attempt to get a sprite for the simple sprite manager.
MoveSprite | Move sprite to a point relative to top of viewport.


TSpecialMonitor

Declaration

Source position: agraphics.pas line 447

type TSpecialMonitor = record
spm_Node: TExtendedNode; |
spm_Flags: Word; | Reserved, set to 0
do_monitor: Pointer; | Driver call vector - set up a video mode
reserved1: Pointer; | Private do not touch
reserved2: Pointer; | Private do not touch
reserved3: Pointer; | Private do not touch
hblank: TAnalogSignalInterval; | Signal timings by themselves
vblank: TAnalogSignalInterval; |
hsync: TAnalogSignalInterval; |
vsync: TAnalogSignalInterval; |
end;


TTextAttr

TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 193

type TTextAttr = record
ta_Name: PChar; | Name of Font
ta_YSize: Word; | Height of Font
ta_Style: Byte; | Intrinsic Font Style (FSF_*)
ta_Flags: Byte; | Font preferences and flags (FPF_*)
end;

See also

SetFont | Set the text font and attributes in a RastPort.
OpenFont | Get a pointer to a system font.
StripFont | Remove the TextFontExtension from a font
OpenDiskFont |


TTextExtent

A measured text size

Declaration

Source position: agraphics.pas line 271

type TTextExtent = record
te_Width: Word; | Same as TextLength() the RastPort current x postion advance that rendering this text would cause.
te_Height: Word; | same as tf_YSize The height of the font.
te_Extent: TRectangle; | relative to CP
end;

See also

FontExtent | Get the font attributes of the current font
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent


TTextFont

Declaration

Source position: agraphics.pas line 211

type TTextFont = record
tf_Message: TMessage; | Reply message for font removal, Font name in tf_Message.mn_Node.ln_Name
tf_YSize: Word; | Font height
tf_Style: Byte; | Font style (FSF_*)
tf_Flags: Byte; | Preferences and flags (FPF_*)
tf_XSize: Word; | Nominal font width
tf_Baseline: Word; | Distance from the top of char to baseline
tf_BoldSmear: Word; | Smear to affect a bold enhancement
tf_Accessors: Word; | Access count
tf_LoChar: Byte; | The first character described here
tf_HiChar: Byte; | The last character described here
tf_CharData: Pointer; | The bit character data
tf_Modulo: Word; | The row modulo for the strike font data
tf_CharLoc: Pointer; | Pointer to location data for the strike font 2 words: bit offset then size
tf_CharSpace: Pointer; | Pointer to words of proportional spacing data
tf_CharKern: Pointer; | Pointer to words of kerning data
end;


TTextFontExtension

Extended font description

Declaration

Source position: agraphics.pas line 232

type TTextFontExtension = record
tfe_MatchWord: Word; | A magic cookie for the extension
tfe_Flags0: Byte; | System private flags TE0F_NOREMFONT
tfe_Flags1: Byte; | System private flags
tfe_BackPtr: PTextFont; | Validation of compilation
tfe_OrigReplyPort: PMsgPort; | Original value in TTextFont.tf_Extension
tfe_Tags: PTagItem; | Text Tags for the font
tfe_OFontPatchS: PWord; | System private use
tfe_OFontPatchK: PWord; | System private use
end;

Description

This structure is read-only


TTmpRas

Temporary rast port

Declaration

Source position: agraphics.pas line 368

type TTmpRas = record

  RasPtr: PShortInt;

  Size: LongInt;

end;

See also

InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.
InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


TTTextAttr

Extended TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 201

type TTTextAttr = record
tta_Name: PChar; | Name of the Font
tta_YSize: Word; | Height of the Font
tta_Style: Byte; | Intrinsic Font Style (FSF_*)
tta_Flags: Byte; | Font preferences and flags (FPF_*)
tta_Tags: PTagItem; | Extended Attributes (TA_*)
end;


TUCopList

Declaration

Source position: agraphics.pas line 318

type TUCopList = record
Next: PUCopList; |
FirstCopList: PCopList; | head node of this copper list
CopList: PCopList; | Node in use
end;


TVecInfo

This structure is PRIVATE, for our use only Touch these, and burn!

Declaration

Source position: agraphics.pas line 1628

type TVecInfo = record
Header: TQueryHeader; |
Vec: Pointer; |
Data: Pointer; |
Type_: Word; | renamed from "Type" in C
pad: array [0..2] of Word; |
Reserved: array [0..1] of LongWord; |
end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_VEC | GetDisplayInfoData, Internal use only (PVecInfo)


TView

Declaration

Source position: agraphics.pas line 498

type TView = record
ViewPort: PViewPort; |
LOFCprList: PCprList; | Used for interlaced and noninterlaced
SHFCprList: PCprList; | Only used during interlace
DyOffset: SmallInt; | For complete View positioning offsets are +- adjustments to standard #s
DxOffset: SmallInt; | For complete View positioning offsets are +- adjustments to standard #s
Modes: Word; | such as INTERLACE, GENLOC
end;


TViewExtra

Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree

Declaration

Source position: agraphics.pas line 512

type TViewExtra = record
n: TExtendedNode; | Common Header
View: PView; | View it relates to
Monitor: PMonitorSpec; | Monitor used for displaying this View
TopLine: Word; |
end;


TViewPort

Describes a displayed bitmap (or logical screen). Copperlists are relevant only to Amiga(tm) chipset, for other hardware they are nil.

Declaration

Source position: agraphics.pas line 521

type TViewPort = record
Next: PViewPort; |
ColorMap: PColorMap; | Table of colors for this viewport if this is nil, MakeVPort assumes default values
DspIns: PCopList; | user by MakeView, Preliminary partial display copperlist
SprIns: PCopList; | used by sprite stuff, Preliminary partial sprite copperlist
ClrIns: PCopList; | used by sprite stuff
UCopIns: PUCopList; | User copper list
DWidth: SmallInt; | Width of currently displayed part in pixels
DHeight: SmallInt; | Height of currently displayed part in pixels
DxOffset: SmallInt; | Displacement from the (0, 0) of the physical screen to (0, 0) of the raster
DyOffset: SmallInt; |
Modes: Word; | The same as in View
SpritePriorities: Byte; | used by makevp
reserved: Byte; |
RasInfo: PRasInfo; | Playfield specification
end;


TViewPortExtra

Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()

Declaration

Source position: agraphics.pas line 541

type TViewPortExtra = record
n: TExtendedNode; |
ViewPort: PViewPort; | ViewPort it relates to (backward link)
DisplayClip: TRectangle; | makevp display clipping information, Total size of displayable part
VecTable: Pointer; |
DriverData: array [0..1] of Pointer; | Private storage for display drivers. Do not touch!
Flags: Word; | Flags (VPXF_*)
Origin: array [0..1] of TPoint; | First visible point relative to the DClip. One for each possible playfield.
cop1ptr: LongWord; | private
cop2ptr: LongWord; | private
end;


TVSprite

Sprite description

Declaration

Source position: agraphics.pas line 613

type TVSprite = record
NextVSprite: PVSprite; | GEL linked list forward pointer sorted by y,x value
PrevVSprite: PVSprite; | GEL linked list backward pointer sorted by y,x value
DrawPath: PVSprite; | Pointer of overlay drawing
ClearPath: PVSprite; | Pointer for overlay clearing
OldY: SmallInt; | Previous x position
OldX: SmallInt; | Previous y position
Flags: SmallInt; | VSprite flags
Y: SmallInt; | Screen y position
X: SmallInt; | Screen x position
Height: SmallInt; | Number of lines of image data
Width: SmallInt; | Number of words per row of image data
Depth: SmallInt; | Number of planes
MeMask: SmallInt; | Which types can collide with this VSprite
HitMask: SmallInt; | Which types this VSprite can collide with
ImageData: PSmallInt; | Pointer to VSprite image
BorderLine: PSmallInt; | Logical OR of all VSprite bits
CollMask: PSmallInt; | Similar to above except this is a matrix
SprColors: PSmallInt; | Pointer to this VSprite's color definitions (not used by Bobs)
VSBob: PBob; | (PBob) points home if this VSprite is part of a Bob
PlanePick: ShortInt; | Plane flags
PlaneOnOff: ShortInt; |
VUserExt: SmallInt; | User definable
end;

Description

The VSprite positions are defined in (y,x) order to make sorting sorting easier, since (y,x) as a long Longint.

BorderLine is the one-dimensional logical OR of all the VSprite bits, used for fast collision detection of edge

PlanePick flag: set bit selects a plane from image, clear bit selects use of shadow mask for that plane OnOff flag: if using shadow mask to fill plane, this bit (corresponding to bit in planePick) describes whether to fill with 0's or 1's

There are two uses for these flags:

  • if this is the VSprite of a Bob, these flags describe how the Bob is to be drawn into memory
  • if this is a simple VSprite and the user intends on setting the MUSTDRAW flag of the VSprite, these flags must be set too to describe which color registers the user wants for the image


TVUserStuff

Declaration

Source position: agraphics.pas line 600

type TVUserStuff = SmallInt;


USER_COPPER_CLIP

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1073

const USER_COPPER_CLIP = $20;


VC_DUALPF_Disable

Tag for VideoControl() When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Default = False.

Declaration

Source position: agraphics.pas line 1715

const VC_DUALPF_Disable = $80000084;

Description

When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Even bitplanes will still come from the first BitMap and odd bitplanes from the second BitMap, and both R[xy]Offsets will be considered. This can be used (with appropriate palette selection) for cross-fades between differently scrolling images. When this flag is turned on, colors will be loaded forthe viewport as if it were a single viewport of depth depth1+depth2

See also

VC_DUALPF_Disable_Query

Tag for VideoControl()


VC_DUALPF_Disable_Query

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1726

const VC_DUALPF_Disable_Query = $80000085;

See also

VC_DUALPF_Disable

Tag for VideoControl() When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Default = False.


VC_IntermediateCLUpdate

Tag for VideoControl() When set graphics will update the intermediate copper lists on color changes, etc. When False, it won't, and will be faster. default = True.

Declaration

Source position: agraphics.pas line 1710

const VC_IntermediateCLUpdate = $80000080;

See also

VC_IntermediateCLUpdate_Query

Tag for VideoControl() Get if intermediate copper is activated


VC_IntermediateCLUpdate_Query

Tag for VideoControl() Get if intermediate copper is activated

Declaration

Source position: agraphics.pas line 1711

const VC_IntermediateCLUpdate_Query = $80000081;

See also

VC_IntermediateCLUpdate

Tag for VideoControl() When set graphics will update the intermediate copper lists on color changes, etc. When False, it won't, and will be faster. default = True.


VC_NoColorPaletteLoad

Tag for VideoControl() When set, graphics will only load color 0 for this View Port default = False.

Declaration

Source position: agraphics.pas line 1712

const VC_NoColorPaletteLoad = $80000082;

Description

When set, graphics will only load color 0 for this ViewPort, and so the ViewPort's colors will come from the previous ViewPort's. Using this tag and VTAG_FULLPALETTE_SET together is undefined.

See also

VC_NoColorPaletteLoad_Query

Tag for VideoControl() Get if only color 0 will be set for this viewport.


VC_NoColorPaletteLoad_Query

Tag for VideoControl() Get if only color 0 will be set for this viewport.

Declaration

Source position: agraphics.pas line 1714

const VC_NoColorPaletteLoad_Query = $80000083;

See also

VC_NoColorPaletteLoad

Tag for VideoControl() When set, graphics will only load color 0 for this View Port default = False.


VGA70_BEAMCON

Declaration

Source position: agraphics.pas line 1044

const VGA70_BEAMCON = SPECIAL_BEAMCON xor VSYNCTRUE;


VGA70_COLORCLOCKS

Declaration

Source position: agraphics.pas line 1031

const VGA70_COLORCLOCKS = STANDARD_COLORCLOCKS / 2;


VGA70_DENISE_MIN

Declaration

Source position: agraphics.pas line 1033

const VGA70_DENISE_MIN = 59;


VGA70_HBSTOP

Declaration

Source position: agraphics.pas line 1038

const VGA70_HBSTOP = $1E;


VGA70_HBSTRT

Declaration

Source position: agraphics.pas line 1035

const VGA70_HBSTRT = $08;


VGA70_HSSTOP

Declaration

Source position: agraphics.pas line 1037

const VGA70_HSSTOP = $1C;


VGA70_HSSTRT

Declaration

Source position: agraphics.pas line 1036

const VGA70_HSSTRT = $0E;


VGA70_MONITOR_NAME

Declaration

Source position: agraphics.pas line 992

const VGA70_MONITOR_NAME: PChar = 'vga70.monitor';


VGA70_TOTAL_ROWS

Declaration

Source position: agraphics.pas line 1032

const VGA70_TOTAL_ROWS = 449;


VGA70_VBSTOP

Declaration

Source position: agraphics.pas line 1042

const VGA70_VBSTOP = $0F73;


VGA70_VBSTRT

Declaration

Source position: agraphics.pas line 1039

const VGA70_VBSTRT = $0000;


VGA70_VSSTOP

Declaration

Source position: agraphics.pas line 1041

const VGA70_VSSTOP = $0388;


VGA70_VSSTRT

Declaration

Source position: agraphics.pas line 1040

const VGA70_VSSTRT = $02A6;


VGA_COLORCLOCKS

Declaration

Source position: agraphics.pas line 1018

const VGA_COLORCLOCKS = STANDARD_COLORCLOCKS / 2;


VGA_DENISE_MIN

Declaration

Source position: agraphics.pas line 1020

const VGA_DENISE_MIN = 59;


VGA_HBSTOP

Declaration

Source position: agraphics.pas line 1025

const VGA_HBSTOP = $1E;


VGA_HBSTRT

Declaration

Source position: agraphics.pas line 1022

const VGA_HBSTRT = $08;


VGA_HSSTOP

Declaration

Source position: agraphics.pas line 1024

const VGA_HSSTOP = $1C;


VGA_HSSTRT

Declaration

Source position: agraphics.pas line 1023

const VGA_HSSTRT = $0E;


VGA_MONITOR_ID

Declaration

Source position: agraphics.pas line 1226

const VGA_MONITOR_ID = $00031000;


VGA_MONITOR_NAME

Declaration

Source position: agraphics.pas line 991

const VGA_MONITOR_NAME: PChar = 'vga.monitor';


VGA_TOTAL_ROWS

Declaration

Source position: agraphics.pas line 1019

const VGA_TOTAL_ROWS = STANDARD_NTSC_ROWS * 2;


VGA_VBSTOP

Declaration

Source position: agraphics.pas line 1029

const VGA_VBSTOP = $0CCD;


VGA_VBSTRT

Declaration

Source position: agraphics.pas line 1026

const VGA_VBSTRT = $0000;


VGA_VSSTOP

Declaration

Source position: agraphics.pas line 1028

const VGA_VSSTOP = $0235;


VGA_VSSTRT

Declaration

Source position: agraphics.pas line 1027

const VGA_VSSTRT = $0153;


VGAEHB_KEY

Declaration

Source position: agraphics.pas line 1261

const VGAEHB_KEY = $000390a4;


VGAEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1262

const VGAEHBLACE_KEY = $000390a5;


VGAEXTRAHALFBRITE_KEY

Declaration

Source position: agraphics.pas line 1248

const VGAEXTRAHALFBRITE_KEY = $00031084;


VGAEXTRAHALFBRITELACE_KEY

Declaration

Source position: agraphics.pas line 1249

const VGAEXTRAHALFBRITELACE_KEY = $00031085;


VGAEXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1228

const VGAEXTRALORES_KEY = $00031004;


VGAEXTRALORESDBL_KEY

Declaration

Source position: agraphics.pas line 1266

const VGAEXTRALORESDBL_KEY = $00031000;


VGAEXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1242

const VGAEXTRALORESDPF2_KEY = $00031444;


VGAEXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1236

const VGAEXTRALORESDPF_KEY = $00031404;


VGAEXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1257

const VGAEXTRALORESEHB_KEY = VGAEXTRAHALFBRITE_KEY;


VGAEXTRALORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1272

const VGAEXTRALORESEHBDBL_KEY = $00031080;


VGAEXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1258

const VGAEXTRALORESEHBLACE_KEY = VGAEXTRAHALFBRITELACE_KEY;


VGAEXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1253

const VGAEXTRALORESHAM_KEY = VGAHAM_KEY;


VGAEXTRALORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1269

const VGAEXTRALORESHAMDBL_KEY = $00031800;


VGAEXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1256

const VGAEXTRALORESHAMLACE_KEY = VGAHAMLACE_KEY;


VGAEXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1232

const VGAEXTRALORESLACE_KEY = $00031005;


VGAEXTRALORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1245

const VGAEXTRALORESLACEDPF2_KEY = $00031445;


VGAEXTRALORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1239

const VGAEXTRALORESLACEDPF_KEY = $00031405;


VGAHAM_KEY

Declaration

Source position: agraphics.pas line 1231

const VGAHAM_KEY = $00031804;


VGAHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1235

const VGAHAMLACE_KEY = $00031805;


VGALORES_KEY

Declaration

Source position: agraphics.pas line 1229

const VGALORES_KEY = $00039004;


VGALORESDBL_KEY

Declaration

Source position: agraphics.pas line 1267

const VGALORESDBL_KEY = $00039000;


VGALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1243

const VGALORESDPF2_KEY = $00039444;


VGALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1237

const VGALORESDPF_KEY = $00039404;


VGALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1259

const VGALORESEHB_KEY = $00039084;


VGALORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1273

const VGALORESEHBDBL_KEY = $00039080;


VGALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1260

const VGALORESEHBLACE_KEY = $00039085;


VGALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1252

const VGALORESHAM_KEY = $00039804;


VGALORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1270

const VGALORESHAMDBL_KEY = $00039800;


VGALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1255

const VGALORESHAMLACE_KEY = $00039805;


VGALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1233

const VGALORESLACE_KEY = $00039005;


VGALORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1246

const VGALORESLACEDPF2_KEY = $00039445;


VGALORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1240

const VGALORESLACEDPF_KEY = $00039405;


VGAPRODUCT_KEY

Declaration

Source position: agraphics.pas line 1230

const VGAPRODUCT_KEY = $00039024;


VGAPRODUCTDBL_KEY

Declaration

Source position: agraphics.pas line 1268

const VGAPRODUCTDBL_KEY = $00039020;


VGAPRODUCTDPF2_KEY

Declaration

Source position: agraphics.pas line 1244

const VGAPRODUCTDPF2_KEY = $00039464;


VGAPRODUCTDPF_KEY

Declaration

Source position: agraphics.pas line 1238

const VGAPRODUCTDPF_KEY = $00039424;


VGAPRODUCTEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1274

const VGAPRODUCTEHBDBL_KEY = $000390a0;


VGAPRODUCTHAM_KEY

Declaration

Source position: agraphics.pas line 1251

const VGAPRODUCTHAM_KEY = $00039824;


VGAPRODUCTHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1271

const VGAPRODUCTHAMDBL_KEY = $00039820;


VGAPRODUCTHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1254

const VGAPRODUCTHAMLACE_KEY = $00039825;


VGAPRODUCTLACE_KEY

Declaration

Source position: agraphics.pas line 1234

const VGAPRODUCTLACE_KEY = $00039025;


VGAPRODUCTLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1247

const VGAPRODUCTLACEDPF2_KEY = $00039465;


VGAPRODUCTLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1241

const VGAPRODUCTLACEDPF_KEY = $00039425;


VIEW_EXTRA_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 947

const VIEW_EXTRA_TYPE = 1;


VIEWPORT_EXTRA_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 948

const VIEWPORT_EXTRA_TYPE = 2;


VP_HIDE

Declaration

Source position: agraphics.pas line 751

const VP_HIDE = 1 shl 13;


VPB_A2024

Declaration

Source position: agraphics.pas line 738

const VPB_A2024 = 6;


VPB_TENHZ

Declaration

Source position: agraphics.pas line 736

const VPB_TENHZ = 4;


VPF_A2024

Declaration

Source position: agraphics.pas line 739

const VPF_A2024 = 1 shl 6;


VPF_TENHZ

Declaration

Source position: agraphics.pas line 737

const VPF_TENHZ = 1 shl 4;


VPOSRLOF

Declaration

Source position: agraphics.pas line 1530

const VPOSRLOF = $8000;


VPXB_FREE_ME

Declaration

Source position: agraphics.pas line 726

const VPXB_FREE_ME = 0;


VPXB_LAST

Declaration

Source position: agraphics.pas line 729

const VPXB_LAST = 1;


VPXB_STRADDLES256

Declaration

Source position: agraphics.pas line 731

const VPXB_STRADDLES256 = 4;


VPXB_STRADDLES512

Declaration

Source position: agraphics.pas line 733

const VPXB_STRADDLES512 = 5;


VPXF_FREE_ME

Declaration

Source position: agraphics.pas line 727

const VPXF_FREE_ME = 1 shl 0;


VPXF_LAST

Declaration

Source position: agraphics.pas line 730

const VPXF_LAST = 1 shl 1;


VPXF_STRADDLES256

Declaration

Source position: agraphics.pas line 732

const VPXF_STRADDLES256 = 1 shl 4;


VPXF_STRADDLES512

Declaration

Source position: agraphics.pas line 734

const VPXF_STRADDLES512 = 1 shl 5;


VSOVERFLOW

System Set flag for TVsprite.Flags. VSprite overflow (if MUSTDRAW set we draw!)

Declaration

Source position: agraphics.pas line 904

const VSOVERFLOW = $0800;


VSPRITE

Declaration

Source position: agraphics.pas line 895

const VSPRITE = $0001;


VTAG_ATTACH_CM_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1667

const VTAG_ATTACH_CM_GET = $8000001B;


VTAG_ATTACH_CM_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1651

const VTAG_ATTACH_CM_SET = $8000000B;


VTAG_BATCH_CM_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1653

const VTAG_BATCH_CM_CLR = $8000000D;


VTAG_BATCH_CM_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1668

const VTAG_BATCH_CM_GET = $8000001C;


VTAG_BATCH_CM_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1654

const VTAG_BATCH_CM_SET = $8000000E;


VTAG_BATCH_ITEMS_ADD

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1671

const VTAG_BATCH_ITEMS_ADD = $8000001F;


VTAG_BATCH_ITEMS_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1669

const VTAG_BATCH_ITEMS_GET = $8000001D;


VTAG_BATCH_ITEMS_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1670

const VTAG_BATCH_ITEMS_SET = $8000001E;


VTAG_BITPLANEKEY_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1642

const VTAG_BITPLANEKEY_CLR = $80000002;


VTAG_BITPLANEKEY_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1662

const VTAG_BITPLANEKEY_GET = $80000016;


VTAG_BITPLANEKEY_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1643

const VTAG_BITPLANEKEY_SET = $80000003;


VTAG_BORDERBLANK_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1644

const VTAG_BORDERBLANK_CLR = $80000004;


VTAG_BORDERBLANK_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1663

const VTAG_BORDERBLANK_GET = $80000017;


VTAG_BORDERBLANK_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1645

const VTAG_BORDERBLANK_SET = $80000005;


VTAG_BORDERNOTRANS_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1646

const VTAG_BORDERNOTRANS_CLR = $80000006;


VTAG_BORDERNOTRANS_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1664

const VTAG_BORDERNOTRANS_GET = $80000018;


VTAG_BORDERNOTRANS_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1647

const VTAG_BORDERNOTRANS_SET = $80000007;


VTAG_BORDERSPRITE_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1689

const VTAG_BORDERSPRITE_CLR = $80000030;


VTAG_BORDERSPRITE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1687

const VTAG_BORDERSPRITE_GET = $8000002e;


VTAG_BORDERSPRITE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1688

const VTAG_BORDERSPRITE_SET = $8000002f;


VTAG_CHROMA_PEN_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1648

const VTAG_CHROMA_PEN_CLR = $80000008;


VTAG_CHROMA_PEN_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1665

const VTAG_CHROMA_PEN_GET = $80000019;


VTAG_CHROMA_PEN_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1649

const VTAG_CHROMA_PEN_SET = $80000009;


VTAG_CHROMA_PLANE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1666

const VTAG_CHROMA_PLANE_GET = $8000001A;


VTAG_CHROMA_PLANE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1650

const VTAG_CHROMA_PLANE_SET = $8000000A;


VTAG_CHROMAKEY_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1640

const VTAG_CHROMAKEY_CLR = $80000000;


VTAG_CHROMAKEY_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1661

const VTAG_CHROMAKEY_GET = $80000015;


VTAG_CHROMAKEY_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1641

const VTAG_CHROMAKEY_SET = $80000001;


VTAG_COERCE_DISP_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1657

const VTAG_COERCE_DISP_GET = $80000011;


VTAG_COERCE_DISP_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1658

const VTAG_COERCE_DISP_SET = $80000012;


VTAG_DEFSPRITERESN_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1701

const VTAG_DEFSPRITERESN_GET = $8000003C;


VTAG_DEFSPRITERESN_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1700

const VTAG_DEFSPRITERESN_SET = $8000003B;


VTAG_END_CM

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1639

const VTAG_END_CM = $00000000;


VTAG_FULLPALETTE_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1699

const VTAG_FULLPALETTE_CLR = $8000003A;


VTAG_FULLPALETTE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1698

const VTAG_FULLPALETTE_GET = $80000039;


VTAG_FULLPALETTE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1697

const VTAG_FULLPALETTE_SET = $80000038;


VTAG_IMMEDIATE

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1696

const VTAG_IMMEDIATE = $80000037;


VTAG_NEXTBUF_CM

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1652

const VTAG_NEXTBUF_CM = $8000000C;


VTAG_NORMAL_DISP_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1655

const VTAG_NORMAL_DISP_GET = $8000000F;


VTAG_NORMAL_DISP_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1656

const VTAG_NORMAL_DISP_SET = $80000010;


VTAG_PF1_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1679

const VTAG_PF1_BASE_GET = $80000026;


VTAG_PF1_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1683

const VTAG_PF1_BASE_SET = $8000002a;


VTAG_PF1_TO_SPRITEPRI_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1693

const VTAG_PF1_TO_SPRITEPRI_GET = $80000034;


VTAG_PF1_TO_SPRITEPRI_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1692

const VTAG_PF1_TO_SPRITEPRI_SET = $80000033;


VTAG_PF2_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1680

const VTAG_PF2_BASE_GET = $80000027;


VTAG_PF2_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1684

const VTAG_PF2_BASE_SET = $8000002b;


VTAG_PF2_TO_SPRITEPRI_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1695

const VTAG_PF2_TO_SPRITEPRI_GET = $80000036;


VTAG_PF2_TO_SPRITEPRI_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1694

const VTAG_PF2_TO_SPRITEPRI_SET = $80000035;


VTAG_SPEVEN_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1681

const VTAG_SPEVEN_BASE_GET = $80000028;


VTAG_SPEVEN_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1685

const VTAG_SPEVEN_BASE_SET = $8000002c;


VTAG_SPODD_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1682

const VTAG_SPODD_BASE_GET = $80000029;


VTAG_SPODD_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1686

const VTAG_SPODD_BASE_SET = $8000002d;


VTAG_SPRITERESN_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1691

const VTAG_SPRITERESN_GET = $80000032;


VTAG_SPRITERESN_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1690

const VTAG_SPRITERESN_SET = $80000031;


VTAG_USERCLIP_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1677

const VTAG_USERCLIP_CLR = $80000025;


VTAG_USERCLIP_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1675

const VTAG_USERCLIP_GET = $80000023;


VTAG_USERCLIP_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1676

const VTAG_USERCLIP_SET = $80000024;


VTAG_VIEWPORTEXTRA_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1659

const VTAG_VIEWPORTEXTRA_GET = $80000013;


VTAG_VIEWPORTEXTRA_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1660

const VTAG_VIEWPORTEXTRA_SET = $80000014;


VTAG_VPMODEID_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1674

const VTAG_VPMODEID_CLR = $80000022;


VTAG_VPMODEID_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1672

const VTAG_VPMODEID_GET = $80000020;


VTAG_VPMODEID_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1673

const VTAG_VPMODEID_SET = $80000021;


AHI_DEBUG_ALL

Declaration

Source position: ahi.pas line 456

const AHI_DEBUG_ALL = 3;


AHI_DEBUG_HIGH

Declaration

Source position: ahi.pas line 455

const AHI_DEBUG_HIGH = 2;


AHI_DEBUG_LOW

Declaration

Source position: ahi.pas line 454

const AHI_DEBUG_LOW = 1;


AHI_DEBUG_NONE

Declaration

Source position: ahi.pas line 453

const AHI_DEBUG_NONE = 0;


AHI_DEFAULT_FREQ

Declaration

Source position: ahi.pas line 354

const AHI_DEFAULT_FREQ = 0;


AHI_DEFAULT_ID

Declaration

Source position: ahi.pas line 350

const AHI_DEFAULT_ID = $00000000;


AHI_DEFAULT_UNIT

Declaration

Source position: ahi.pas line 416

const AHI_DEFAULT_UNIT = 0;


AHI_INVALID_ID

Declaration

Source position: ahi.pas line 348

const AHI_INVALID_ID = not 0;


AHI_LOOPBACK_ID

Declaration

Source position: ahi.pas line 352

const AHI_LOOPBACK_ID = $00000001;


AHI_MIXFREQ

Declaration

Source position: ahi.pas line 356

const AHI_MIXFREQ = not 0;


AHI_NO_UNIT

Declaration

Source position: ahi.pas line 417

const AHI_NO_UNIT = 255;


AHI_NOSOUND

Declaration

Source position: ahi.pas line 358

const AHI_NOSOUND = $ffff;


AHI_TagBase

Declaration

Source position: ahi.pas line 147

const AHI_TagBase = TAG_USER;


AHI_TagBaseR

Declaration

Source position: ahi.pas line 148

const AHI_TagBaseR = AHI_TagBase or $8000;


AHIA_AudioID

Declaration

Source position: ahi.pas line 151

const AHIA_AudioID = AHI_TagBase + 1;


AHIA_Channels

Declaration

Source position: ahi.pas line 155

const AHIA_Channels = AHI_TagBase + 3;


AHIA_MaxPlayerFreq

Declaration

Source position: ahi.pas line 167

const AHIA_MaxPlayerFreq = AHI_TagBase + 9;


AHIA_MinPlayerFreq

Declaration

Source position: ahi.pas line 165

const AHIA_MinPlayerFreq = AHI_TagBase + 8;


AHIA_MixFreq

Declaration

Source position: ahi.pas line 153

const AHIA_MixFreq = AHI_TagBase + 2;


AHIA_PlayerFreq

Declaration

Source position: ahi.pas line 163

const AHIA_PlayerFreq = AHI_TagBase + 7;


AHIA_PlayerFunc

Declaration

Source position: ahi.pas line 161

const AHIA_PlayerFunc = AHI_TagBase + 6;


AHIA_RecordFunc

Declaration

Source position: ahi.pas line 169

const AHIA_RecordFunc = AHI_TagBase + 10;


AHIA_SoundFunc

Declaration

Source position: ahi.pas line 159

const AHIA_SoundFunc = AHI_TagBase + 5;


AHIA_Sounds

Declaration

Source position: ahi.pas line 157

const AHIA_Sounds = AHI_TagBase + 4;


AHIA_UserData

Declaration

Source position: ahi.pas line 171

const AHIA_UserData = AHI_TagBase + 11;


AHIB_Dizzy

Declaration

Source position: ahi.pas line 287

const AHIB_Dizzy = AHI_TagBase + 190;


AHIBase

Declaration

Source position: ahi.pas line 30

var AHIBase: PLibrary = Nil;


AHIC_Input

Declaration

Source position: ahi.pas line 206

const AHIC_Input = AHI_TagBase + 89;


AHIC_Input_Query

Declaration

Source position: ahi.pas line 208

const AHIC_Input_Query = AHI_TagBase + 90;


AHIC_InputGain

Declaration

Source position: ahi.pas line 200

const AHIC_InputGain = AHI_TagBase + 85;


AHIC_InputGain_Query

Declaration

Source position: ahi.pas line 202

const AHIC_InputGain_Query = AHI_TagBase + 86;


AHIC_MixFreq_Query

Declaration

Source position: ahi.pas line 198

const AHIC_MixFreq_Query = AHI_TagBase + 84;


AHIC_MonitorVolume

Declaration

Source position: ahi.pas line 194

const AHIC_MonitorVolume = AHI_TagBase + 82;


AHIC_MonitorVolume_Query

Declaration

Source position: ahi.pas line 196

const AHIC_MonitorVolume_Query = AHI_TagBase + 83;


AHIC_Output

Declaration

Source position: ahi.pas line 209

const AHIC_Output = AHI_TagBase + 91;


AHIC_Output_Query

Declaration

Source position: ahi.pas line 211

const AHIC_Output_Query = AHI_TagBase + 92;


AHIC_OutputVolume

Declaration

Source position: ahi.pas line 203

const AHIC_OutputVolume = AHI_TagBase + 87;


AHIC_OutputVolume_Query

Declaration

Source position: ahi.pas line 205

const AHIC_OutputVolume_Query = AHI_TagBase + 88;


AHIC_Play

Declaration

Source position: ahi.pas line 191

const AHIC_Play = AHI_TagBase + 80;


AHIC_Record

Declaration

Source position: ahi.pas line 193

const AHIC_Record = AHI_TagBase + 81;


AHIDB_Annotation

Declaration

Source position: ahi.pas line 253

const AHIDB_Annotation = AHI_TagBase + 121;


AHIDB_AudioID

Declaration

Source position: ahi.pas line 213

const AHIDB_AudioID = AHI_TagBase + 100;


AHIDB_Author

Declaration

Source position: ahi.pas line 247

const AHIDB_Author = AHI_TagBase + 118;


AHIDB_Bits

Declaration

Source position: ahi.pas line 233

const AHIDB_Bits = AHI_TagBase + 110;


AHIDB_BufferLen

Declaration

Source position: ahi.pas line 255

const AHIDB_BufferLen = AHI_TagBase + 122;


AHIDB_Copyright

Declaration

Source position: ahi.pas line 249

const AHIDB_Copyright = AHI_TagBase + 119;


AHIDB_Data

Declaration

Source position: ahi.pas line 284

const AHIDB_Data = AHI_TagBaseR + 142;


AHIDB_Driver

Declaration

Source position: ahi.pas line 215

const AHIDB_Driver = AHI_TagBaseR + 101;


AHIDB_Flags

Declaration

Source position: ahi.pas line 217

const AHIDB_Flags = AHI_TagBase + 102;


AHIDB_Frequencies

Declaration

Source position: ahi.pas line 242

const AHIDB_Frequencies = AHI_TagBase + 115;


AHIDB_Frequency

Declaration

Source position: ahi.pas line 245

const AHIDB_Frequency = AHI_TagBase + 117;


AHIDB_FrequencyArg

Declaration

Source position: ahi.pas line 244

const AHIDB_FrequencyArg = AHI_TagBase + 116;


AHIDB_FullDuplex

Declaration

Source position: ahi.pas line 266

const AHIDB_FullDuplex = AHI_TagBase + 129;


AHIDB_HiFi

Declaration

Source position: ahi.pas line 225

const AHIDB_HiFi = AHI_TagBase + 106;


AHIDB_Index

Declaration

Source position: ahi.pas line 258

const AHIDB_Index = AHI_TagBase + 124;


AHIDB_IndexArg

Declaration

Source position: ahi.pas line 257

const AHIDB_IndexArg = AHI_TagBase + 123;


AHIDB_Input

Declaration

Source position: ahi.pas line 277

const AHIDB_Input = AHI_TagBase + 138;


AHIDB_InputArg

Declaration

Source position: ahi.pas line 276

const AHIDB_InputArg = AHI_TagBase + 137;


AHIDB_Inputs

Declaration

Source position: ahi.pas line 274

const AHIDB_Inputs = AHI_TagBase + 136;


AHIDB_MaxChannels

Declaration

Source position: ahi.pas line 235

const AHIDB_MaxChannels = AHI_TagBase + 111;


AHIDB_MaxInputGain

Declaration

Source position: ahi.pas line 271

const AHIDB_MaxInputGain = AHI_TagBase + 133;


AHIDB_MaxMixFreq

Declaration

Source position: ahi.pas line 239

const AHIDB_MaxMixFreq = AHI_TagBase + 113;


AHIDB_MaxMonitorVolume

Declaration

Source position: ahi.pas line 269

const AHIDB_MaxMonitorVolume = AHI_TagBase + 131;


AHIDB_MaxOutputVolume

Declaration

Source position: ahi.pas line 273

const AHIDB_MaxOutputVolume = AHI_TagBase + 135;


AHIDB_MaxPlaySamples

Declaration

Source position: ahi.pas line 262

const AHIDB_MaxPlaySamples = AHI_TagBase + 126;


AHIDB_MaxRecordSamples

Declaration

Source position: ahi.pas line 264

const AHIDB_MaxRecordSamples = AHI_TagBase + 127;


AHIDB_MinInputGain

Declaration

Source position: ahi.pas line 270

const AHIDB_MinInputGain = AHI_TagBase + 132;


AHIDB_MinMixFreq

Declaration

Source position: ahi.pas line 237

const AHIDB_MinMixFreq = AHI_TagBase + 112;


AHIDB_MinMonitorVolume

Declaration

Source position: ahi.pas line 268

const AHIDB_MinMonitorVolume = AHI_TagBase + 130;


AHIDB_MinOutputVolume

Declaration

Source position: ahi.pas line 272

const AHIDB_MinOutputVolume = AHI_TagBase + 134;


AHIDB_MultTable

Declaration

Source position: ahi.pas line 229

const AHIDB_MultTable = AHI_TagBase + 108;


AHIDB_Name

Declaration

Source position: ahi.pas line 231

const AHIDB_Name = AHI_TagBaseR + 109;


AHIDB_NOMODESCAN

Declaration

Source position: ahi.pas line 478

const AHIDB_NOMODESCAN = 0;


AHIDB_Output

Declaration

Source position: ahi.pas line 281

const AHIDB_Output = AHI_TagBase + 141;


AHIDB_OutputArg

Declaration

Source position: ahi.pas line 280

const AHIDB_OutputArg = AHI_TagBase + 140;


AHIDB_Outputs

Declaration

Source position: ahi.pas line 278

const AHIDB_Outputs = AHI_TagBase + 139;


AHIDB_Panning

Declaration

Source position: ahi.pas line 221

const AHIDB_Panning = AHI_TagBase + 104;


AHIDB_PingPong

Declaration

Source position: ahi.pas line 227

const AHIDB_PingPong = AHI_TagBase + 107;


AHIDB_Realtime

Declaration

Source position: ahi.pas line 260

const AHIDB_Realtime = AHI_TagBase + 125;


AHIDB_Record

Declaration

Source position: ahi.pas line 241

const AHIDB_Record = AHI_TagBase + 114;


AHIDB_Stereo

Declaration

Source position: ahi.pas line 223

const AHIDB_Stereo = AHI_TagBase + 105;


AHIDB_Version

Declaration

Source position: ahi.pas line 251

const AHIDB_Version = AHI_TagBase + 120;


AHIDB_Volume

Declaration

Source position: ahi.pas line 219

const AHIDB_Volume = AHI_TagBase + 103;


AHIDF_NOMODESCAN

Declaration

Source position: ahi.pas line 477

const AHIDF_NOMODESCAN = 1 shl 0;


AHIE_ABORTED

Declaration

Source position: ahi.pas line 409

const AHIE_ABORTED = 4;


AHIE_BADSAMPLETYPE

Declaration

Source position: ahi.pas line 407

const AHIE_BADSAMPLETYPE = 3;


AHIE_BADSOUNDTYPE

Declaration

Source position: ahi.pas line 405

const AHIE_BADSOUNDTYPE = 2;


AHIE_HALFDUPLEX

Declaration

Source position: ahi.pas line 413

const AHIE_HALFDUPLEX = 6;


AHIE_NOMEM

Declaration

Source position: ahi.pas line 403

const AHIE_NOMEM = 1;


Unit 'AHI' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

AHIE_OK

Declaration

Source position: ahi.pas line 401

const AHIE_OK = 0;


AHIE_UNKNOWN

Declaration

Source position: ahi.pas line 411

const AHIE_UNKNOWN = 5;


AHIEDM_DRY

Declaration

Source position: ahi.pas line 121

const AHIEDM_DRY = 1;


AHIEDM_WET

Declaration

Source position: ahi.pas line 120

const AHIEDM_WET = 0;


AHIET_CANCEL

Declaration

Source position: ahi.pas line 364

const AHIET_CANCEL = 1 shl 31;


AHIET_CHANNELINFO

Declaration

Source position: ahi.pas line 370

const AHIET_CHANNELINFO = 5;


AHIET_DSPECHO

Declaration

Source position: ahi.pas line 369

const AHIET_DSPECHO = 4;


AHIET_DSPMASK

Declaration

Source position: ahi.pas line 368

const AHIET_DSPMASK = 3;


AHIET_MASTERVOLUME

Declaration

Source position: ahi.pas line 365

const AHIET_MASTERVOLUME = 1;


AHIET_OUTPUTBUFFER

Declaration

Source position: ahi.pas line 366

const AHIET_OUTPUTBUFFER = 2;


AHINAME

Declaration

Source position: ahi.pas line 346

const AHINAME: PChar = 'ahi.device';


AHIP_BeginChannel

Declaration

Source position: ahi.pas line 174

const AHIP_BeginChannel = AHI_TagBase + 40;


AHIP_EndChannel

Declaration

Source position: ahi.pas line 176

const AHIP_EndChannel = AHI_TagBase + 41;


AHIP_Freq

Declaration

Source position: ahi.pas line 177

const AHIP_Freq = AHI_TagBase + 50;


AHIP_Length

Declaration

Source position: ahi.pas line 182

const AHIP_Length = AHI_TagBase + 55;


AHIP_LoopFreq

Declaration

Source position: ahi.pas line 183

const AHIP_LoopFreq = AHI_TagBase + 60;


AHIP_LoopLength

Declaration

Source position: ahi.pas line 188

const AHIP_LoopLength = AHI_TagBase + 65;


AHIP_LoopOffset

Declaration

Source position: ahi.pas line 187

const AHIP_LoopOffset = AHI_TagBase + 64;


AHIP_LoopPan

Declaration

Source position: ahi.pas line 185

const AHIP_LoopPan = AHI_TagBase + 62;


AHIP_LoopSound

Declaration

Source position: ahi.pas line 186

const AHIP_LoopSound = AHI_TagBase + 63;


AHIP_LoopVol

Declaration

Source position: ahi.pas line 184

const AHIP_LoopVol = AHI_TagBase + 61;


AHIP_Offset

Declaration

Source position: ahi.pas line 181

const AHIP_Offset = AHI_TagBase + 54;


AHIP_Pan

Declaration

Source position: ahi.pas line 179

const AHIP_Pan = AHI_TagBase + 52;


AHIP_Sound

Declaration

Source position: ahi.pas line 180

const AHIP_Sound = AHI_TagBase + 53;


AHIP_Vol

Declaration

Source position: ahi.pas line 178

const AHIP_Vol = AHI_TagBase + 51;


AHIR_DoDefaultMode

Declaration

Source position: ahi.pas line 339

const AHIR_DoDefaultMode = AHI_TagBase + 261;


AHIR_DoMixFreq

Declaration

Source position: ahi.pas line 337

const AHIR_DoMixFreq = AHI_TagBase + 260;


AHIR_FilterFunc

Declaration

Source position: ahi.pas line 344

const AHIR_FilterFunc = AHI_TagBase + 271;


AHIR_FilterTags

Declaration

Source position: ahi.pas line 342

const AHIR_FilterTags = AHI_TagBase + 270;


AHIR_InitialAudioID

Declaration

Source position: ahi.pas line 323

const AHIR_InitialAudioID = AHI_TagBase + 244;


AHIR_InitialHeight

Declaration

Source position: ahi.pas line 321

const AHIR_InitialHeight = AHI_TagBase + 243;


AHIR_InitialInfoHeight

Declaration

Source position: ahi.pas line 334

const AHIR_InitialInfoHeight = AHI_TagBase + 250;


AHIR_InitialInfoLeftEdge

Declaration

Source position: ahi.pas line 329

const AHIR_InitialInfoLeftEdge = AHI_TagBase + 247;


AHIR_InitialInfoOpened

Declaration

Source position: ahi.pas line 327

const AHIR_InitialInfoOpened = AHI_TagBase + 246;


AHIR_InitialInfoTopEdge

Declaration

Source position: ahi.pas line 330

const AHIR_InitialInfoTopEdge = AHI_TagBase + 248;


AHIR_InitialInfoWidth

Declaration

Source position: ahi.pas line 332

const AHIR_InitialInfoWidth = AHI_TagBase + 249;


AHIR_InitialLeftEdge

Declaration

Source position: ahi.pas line 317

const AHIR_InitialLeftEdge = AHI_TagBase + 240;


AHIR_InitialMixFreq

Declaration

Source position: ahi.pas line 325

const AHIR_InitialMixFreq = AHI_TagBase + 245;


AHIR_InitialTopEdge

Declaration

Source position: ahi.pas line 318

const AHIR_InitialTopEdge = AHI_TagBase + 241;


AHIR_InitialWidth

Declaration

Source position: ahi.pas line 320

const AHIR_InitialWidth = AHI_TagBase + 242;


AHIR_IntuiMsgFunc

Declaration

Source position: ahi.pas line 299

const AHIR_IntuiMsgFunc = AHI_TagBase + 204;


AHIR_Locale

Declaration

Source position: ahi.pas line 308

const AHIR_Locale = AHI_TagBase + 221;


AHIR_NegativeText

Declaration

Source position: ahi.pas line 314

const AHIR_NegativeText = AHI_TagBase + 224;


AHIR_PositiveText

Declaration

Source position: ahi.pas line 312

const AHIR_PositiveText = AHI_TagBase + 223;


AHIR_PrivateIDCMP

Declaration

Source position: ahi.pas line 297

const AHIR_PrivateIDCMP = AHI_TagBase + 203;


AHIR_PubScreenName

Declaration

Source position: ahi.pas line 295

const AHIR_PubScreenName = AHI_TagBase + 202;


AHIR_Screen

Declaration

Source position: ahi.pas line 293

const AHIR_Screen = AHI_TagBase + 201;


AHIR_SleepWindow

Declaration

Source position: ahi.pas line 301

const AHIR_SleepWindow = AHI_TagBase + 205;


AHIR_TextAttr

Declaration

Source position: ahi.pas line 306

const AHIR_TextAttr = AHI_TagBase + 220;


AHIR_TitleText

Declaration

Source position: ahi.pas line 310

const AHIR_TitleText = AHI_TagBase + 222;


AHIR_UserData

Declaration

Source position: ahi.pas line 303

const AHIR_UserData = AHI_TagBase + 206;


AHIR_Window

Declaration

Source position: ahi.pas line 291

const AHIR_Window = AHI_TagBase + 200;


AHISB_IMM

Declaration

Source position: ahi.pas line 361

const AHISB_IMM = 0;


AHISF_IMM

Declaration

Source position: ahi.pas line 360

const AHISF_IMM = 1 shl 0;


AHIST_BW

Declaration

Source position: ahi.pas line 381

const AHIST_BW = 1 shl 30;


AHIST_DYNAMICSAMPLE

Declaration

Source position: ahi.pas line 377

const AHIST_DYNAMICSAMPLE = 1;


AHIST_INPUT

Declaration

Source position: ahi.pas line 379

const AHIST_INPUT = 1 shl 29;


AHIST_M8S

Declaration

Source position: ahi.pas line 386

const AHIST_M8S = 0;


AHIST_M8U

Declaration

Source position: ahi.pas line 398

const AHIST_M8U = 4;


AHIST_M16S

Declaration

Source position: ahi.pas line 388

const AHIST_M16S = 1;


AHIST_M32S

Declaration

Source position: ahi.pas line 394

const AHIST_M32S = 8;


AHIST_NOTYPE

Declaration

Source position: ahi.pas line 373

const AHIST_NOTYPE = not 0;


AHIST_S8S

Declaration

Source position: ahi.pas line 390

const AHIST_S8S = 2;


AHIST_S16S

Declaration

Source position: ahi.pas line 392

const AHIST_S16S = 3;


AHIST_S32S

Declaration

Source position: ahi.pas line 396

const AHIST_S32S = 10;


AHIST_SAMPLE

Declaration

Source position: ahi.pas line 375

const AHIST_SAMPLE = 0;


Unit 'AHI' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Fixed

Declaration

Source position: ahi.pas line 35

type Fixed = LongInt;


ID_AHIG

Declaration

Source position: ahi.pas line 420

const ID_AHIG = $41484947;


ID_AHIU

Declaration

Source position: ahi.pas line 419

const ID_AHIU = $41484955;


Reference for unit 'AHI'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'AHI': Constants

AHIA_AudioID

AHIA_Channels

AHIA_MaxPlayerFreq

AHIA_MinPlayerFreq

AHIA_MixFreq

AHIA_PlayerFreq

AHIA_PlayerFunc

AHIA_RecordFunc

AHIA_SoundFunc

AHIA_Sounds

AHIA_UserData

AHIB_Dizzy

AHIC_Input

AHIC_InputGain

AHIC_InputGain_Query

AHIC_Input_Query

AHIC_MixFreq_Query

AHIC_MonitorVolume

AHIC_MonitorVolume_Query

AHIC_Output

AHIC_OutputVolume

AHIC_OutputVolume_Query

AHIC_Output_Query

AHIC_Play

AHIC_Record

AHIDB_Annotation

AHIDB_AudioID

AHIDB_Author

AHIDB_Bits

AHIDB_BufferLen

AHIDB_Copyright

AHIDB_Data

AHIDB_Driver

AHIDB_Flags

AHIDB_Frequencies

AHIDB_Frequency

AHIDB_FrequencyArg

AHIDB_FullDuplex

AHIDB_HiFi

AHIDB_Index

AHIDB_IndexArg

AHIDB_Input

AHIDB_InputArg

AHIDB_Inputs

AHIDB_MaxChannels

AHIDB_MaxInputGain

AHIDB_MaxMixFreq

AHIDB_MaxMonitorVolume

AHIDB_MaxOutputVolume

AHIDB_MaxPlaySamples

AHIDB_MaxRecordSamples

AHIDB_MinInputGain

AHIDB_MinMixFreq

AHIDB_MinMonitorVolume

AHIDB_MinOutputVolume

AHIDB_MultTable

AHIDB_Name

AHIDB_NOMODESCAN

AHIDB_Output

AHIDB_OutputArg

AHIDB_Outputs

AHIDB_Panning

AHIDB_PingPong

AHIDB_Realtime

AHIDB_Record

AHIDB_Stereo

AHIDB_Version

AHIDB_Volume

AHIDF_NOMODESCAN

AHIEDM_DRY

AHIEDM_WET

AHIET_CANCEL

AHIET_CHANNELINFO

AHIET_DSPECHO

AHIET_DSPMASK

AHIET_MASTERVOLUME

AHIET_OUTPUTBUFFER

AHIE_ABORTED

AHIE_BADSAMPLETYPE

AHIE_BADSOUNDTYPE

AHIE_HALFDUPLEX

AHIE_NOMEM

AHIE_OK

AHIE_UNKNOWN

AHINAME

AHIP_BeginChannel

AHIP_EndChannel

AHIP_Freq

AHIP_Length

AHIP_LoopFreq

AHIP_LoopLength

AHIP_LoopOffset

AHIP_LoopPan

AHIP_LoopSound

AHIP_LoopVol

AHIP_Offset

AHIP_Pan

AHIP_Sound

AHIP_Vol

AHIR_DoDefaultMode

AHIR_DoMixFreq

AHIR_FilterFunc

AHIR_FilterTags

AHIR_InitialAudioID

AHIR_InitialHeight

AHIR_InitialInfoHeight

AHIR_InitialInfoLeftEdge

AHIR_InitialInfoOpened

AHIR_InitialInfoTopEdge

AHIR_InitialInfoWidth

AHIR_InitialLeftEdge

AHIR_InitialMixFreq

AHIR_InitialTopEdge

AHIR_InitialWidth

AHIR_IntuiMsgFunc

AHIR_Locale

AHIR_NegativeText

AHIR_PositiveText

AHIR_PrivateIDCMP

AHIR_PubScreenName

AHIR_Screen

AHIR_SleepWindow

AHIR_TextAttr

AHIR_TitleText

AHIR_UserData

AHIR_Window

AHISB_IMM

AHISF_IMM

AHIST_BW

AHIST_DYNAMICSAMPLE

AHIST_INPUT

AHIST_M16S

AHIST_M32S

AHIST_M8S

AHIST_M8U

AHIST_NOTYPE

AHIST_S16S

AHIST_S32S

AHIST_S8S

AHIST_SAMPLE

AHI_DEBUG_ALL

AHI_DEBUG_HIGH

AHI_DEBUG_LOW

AHI_DEBUG_NONE

AHI_DEFAULT_FREQ

AHI_DEFAULT_ID

AHI_DEFAULT_UNIT

AHI_INVALID_ID

AHI_LOOPBACK_ID

AHI_MIXFREQ

AHI_NOSOUND

AHI_NO_UNIT

AHI_TagBase

AHI_TagBaseR

ID_AHIG

ID_AHIU


Reference for unit 'AHI': Types

LongInt

PAHIAudioCtrl

PAHIAudioModeRequester

PAHIDSPEcho

PAHIEffChannelInfo

PAHIEffDSPMask

PAHIEffMasterVolume

PAHIEffOutputBuffer

PAHIGlobalPrefs

PAHIRecordMessage

PAHIRequest

PAHISampleInfo

PAHISoundMessage

PAHIUnitPrefs

PFixed

Psposition

sposition

tAHIAudioCtrl

tAHIAudioModeRequester

tAHIDSPEcho

tAHIEffChannelInfo

tAHIEffDSPMask

tAHIEffMasterVolume

tAHIEffOutputBuffer

tAHIGlobalPrefs

tAHIRecordMessage

tAHIRequest

tAHISampleInfo

tAHISoundMessage

tAHIUnitPrefs


PAHIAudioCtrl

Declaration

Source position: ahi.pas line 47

type PAHIAudioCtrl = ^tAHIAudioCtrl;


PAHIAudioModeRequester

Declaration

Source position: ahi.pas line 75

type PAHIAudioModeRequester = ^tAHIAudioModeRequester;


PAHIDSPEcho

Declaration

Source position: ahi.pas line 124

type PAHIDSPEcho = ^tAHIDSPEcho;


PAHIEffChannelInfo

Declaration

Source position: ahi.pas line 134

type PAHIEffChannelInfo = ^tAHIEffChannelInfo;


PAHIEffDSPMask

Declaration

Source position: ahi.pas line 111

type PAHIEffDSPMask = ^tAHIEffDSPMask;


PAHIEffMasterVolume

Declaration

Source position: ahi.pas line 93

type PAHIEffMasterVolume = ^tAHIEffMasterVolume;


PAHIEffOutputBuffer

Declaration

Source position: ahi.pas line 100

type PAHIEffOutputBuffer = ^tAHIEffOutputBuffer;


PAHIGlobalPrefs

Declaration

Source position: ahi.pas line 440

type PAHIGlobalPrefs = ^tAHIGlobalPrefs;


PAHIRecordMessage

Declaration

Source position: ahi.pas line 59

type PAHIRecordMessage = ^tAHIRecordMessage;


PAHIRequest

Declaration

Source position: ahi.pas line 460

type PAHIRequest = ^tAHIRequest;


PAHISampleInfo

Declaration

Source position: ahi.pas line 67

type PAHISampleInfo = ^tAHISampleInfo;


PAHISoundMessage

Declaration

Source position: ahi.pas line 53

type PAHISoundMessage = ^tAHISoundMessage;


PAHIUnitPrefs

Declaration

Source position: ahi.pas line 424

type PAHIUnitPrefs = ^tAHIUnitPrefs;


Unit 'AHI' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PFixed

Declaration

Source position: ahi.pas line 34

type PFixed = ^Fixed;


Psposition

Declaration

Source position: ahi.pas line 42

type Psposition = ^sposition;


sposition

Declaration

Source position: ahi.pas line 43

type sposition = LongInt;


tAHIAudioCtrl

Declaration

Source position: ahi.pas line 48

type tAHIAudioCtrl = record

  ahiac_UserData: Pointer;

end;


tAHIAudioModeRequester

Declaration

Source position: ahi.pas line 76

type tAHIAudioModeRequester = record

  ahiam_AudioID: Cardinal;

  ahiam_MixFreq: Cardinal;

  ahiam_LeftEdge: Word;

  ahiam_TopEdge: Word;

  ahiam_Width: Word;

  ahiam_Height: Word;

  ahiam_InfoOpened: Boolean;

  ahiam_InfoLeftEdge: Word;

  ahiam_InfoTopEdge: Word;

  ahiam_InfoWidth: Word;

  ahiam_InfoHeight: Word;

  ahiam_UserData: Pointer;

end;


tAHIDSPEcho

Declaration

Source position: ahi.pas line 125

type tAHIDSPEcho = record

  ahie_Effect: Cardinal;

  ahiede_Delay: Cardinal;

  ahiede_Feedback: LongInt;

  ahiede_Mix: LongInt;

  ahiede_Cross: LongInt;

end;


tAHIEffChannelInfo

Declaration

Source position: ahi.pas line 135

type tAHIEffChannelInfo = record

  ahie_Effect: Cardinal;

  ahieci_Func: PHook;

  ahieci_Channels: Word;

  ahieci_Pad: Word;

  ahieci_Offset: array [0..0] of Cardinal;

end;


tAHIEffDSPMask

Declaration

Source position: ahi.pas line 112

type tAHIEffDSPMask = record

  ahie_Effect: Cardinal;

  ahiedm_Channels: Word;

  ahiedm_Mask: array [0..0] of Byte;

end;


tAHIEffMasterVolume

Declaration

Source position: ahi.pas line 94

type tAHIEffMasterVolume = record

  ahie_Effect: Cardinal;

  ahiemv_Volume: LongInt;

end;


tAHIEffOutputBuffer

Declaration

Source position: ahi.pas line 101

type tAHIEffOutputBuffer = record

  ahie_Effect: Cardinal;

  ahieob_Func: PHook;

  ahieob_Type: Cardinal;

  ahieob_Buffer: Pointer;

  ahieob_Length: Cardinal;

end;


tAHIGlobalPrefs

Declaration

Source position: ahi.pas line 441

type tAHIGlobalPrefs = record

  ahigp_DebugLevel: Word;

  ahigp_DisableSurround: Boolean;

  ahigp_DisableEcho: Boolean;

  ahigp_FastEcho: Boolean;

  ahigp_MaxCPU: LongInt;

  ahigp_ClipMasterVolume: Boolean;

end;


tAHIRecordMessage

Declaration

Source position: ahi.pas line 60

type tAHIRecordMessage = record

  ahirm_Type: Cardinal;

  ahirm_Buffer: Pointer;

  ahirm_Length: Cardinal;

end;


tAHIRequest

Declaration

Source position: ahi.pas line 461

type tAHIRequest = record

  ahir_Std: TIOStdReq;

  ahir_Version: Word;

  ahir_Pad1: Word;

  ahir_Private: array [0..1] of Cardinal;

  ahir_Type: Cardinal;

  ahir_Frequency: Cardinal;

  ahir_Volume: LongInt;

  ahir_Position: LongInt;

  ahir_Link: PAHIRequest;

end;


tAHISampleInfo

Declaration

Source position: ahi.pas line 68

type tAHISampleInfo = record

  ahisi_Type: Cardinal;

  ahisi_Address: Pointer;

  ahisi_Length: Cardinal;

end;


tAHISoundMessage

Declaration

Source position: ahi.pas line 54

type tAHISoundMessage = record

  ahism_Channel: Word;

end;


tAHIUnitPrefs

Declaration

Source position: ahi.pas line 425

type tAHIUnitPrefs = record

  ahiup_Unit: Byte;

  ahiup_Pad: Byte;

  ahiup_Channels: Word;

  ahiup_AudioMode: Cardinal;

  ahiup_Frequency: Cardinal;

  ahiup_MonitorVolume: LongInt;

  ahiup_InputGain: LongInt;

  ahiup_OutputVolume: LongInt;

  ahiup_Input: Cardinal;

  ahiup_Output: Cardinal;

end;


Reference for unit 'akeyboard'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'akeyboard': Constants

KBD_ADDRESETHANDLER

KBD_READEVENT

KBD_READMATRIX

KBD_REMRESETHANDLER

KBD_RESETHANDLERDONE


Index of all identifiers in unit 'akeyboard'

K

K

KBD_ADDRESETHANDLER | KBD_READMATRIX | KBD_RESETHANDLERDONE
KBD_READEVENT | KBD_REMRESETHANDLER |


KBD_ADDRESETHANDLER

Declaration

Source position: akeyboard.pas line 35

const KBD_ADDRESETHANDLER = CMD_NONSTD + 2;


KBD_READEVENT

Declaration

Source position: akeyboard.pas line 33

const KBD_READEVENT = CMD_NONSTD + 0;


KBD_READMATRIX

Declaration

Source position: akeyboard.pas line 34

const KBD_READMATRIX = CMD_NONSTD + 1;


KBD_REMRESETHANDLER

Declaration

Source position: akeyboard.pas line 36

const KBD_REMRESETHANDLER = CMD_NONSTD + 3;


KBD_RESETHANDLERDONE

Declaration

Source position: akeyboard.pas line 37

const KBD_RESETHANDLERDONE = CMD_NONSTD + 4;


_MAXINT

Declaration

Source position: amigados.pas line 58

const _MAXINT = $7FFFFFFF;


_MININT

Declaration

Source position: amigados.pas line 59

const _MININT = $80000000;


_PDateTime

Declaration

Source position: amigados.pas line 295

type _PDateTime = ^_TDateTime;


_TDateTime

Declaration

Source position: amigados.pas line 296

type _TDateTime = packed record

  dat_Stamp: TDateStamp;

  dat_Format: Byte;

  dat_Flags: Byte;

  dat_StrDay: PChar;

  dat_StrDate: PChar;

  dat_StrTime: PChar;

end;


ABORT_BUSY

Error report busy at ErrorReport()

Declaration

Source position: amigados.pas line 801

const ABORT_BUSY = 288;


ABORT_DISK_ERROR

Error report Read write error at ErrorReport()

Declaration

Source position: amigados.pas line 800

const ABORT_DISK_ERROR = 296;


ACCESS_READ

Parameter for Lock File is readable by others

Declaration

Source position: amigados.pas line 63

const ACCESS_READ = - 2;


ACCESS_WRITE

Parameter for Lock Exclusive lock, so other access allowed

Declaration

Source position: amigados.pas line 65

const ACCESS_WRITE = - 1;


ACTION_ADD_NOTIFY

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 510

const ACTION_ADD_NOTIFY = 4097;


ACTION_CHANGE_MODE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 497

const ACTION_CHANGE_MODE = 1028;


ACTION_CHANGE_SIGNAL

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 478

const ACTION_CHANGE_SIGNAL = 995;


ACTION_COPY_DIR

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 457

const ACTION_COPY_DIR = 19;


ACTION_COPY_DIR_FH

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 499

const ACTION_COPY_DIR_FH = 1030;


ACTION_CREATE_DIR

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 460

const ACTION_CREATE_DIR = 22;


ACTION_CURRENT_VOLUME

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 448

const ACTION_CURRENT_VOLUME = 7;


ACTION_DELETE_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 454

const ACTION_DELETE_OBJECT = 16;


ACTION_DIE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 446

const ACTION_DIE = 5;


ACTION_DISK_CHANGE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 471

const ACTION_DISK_CHANGE = 33;


ACTION_DISK_INFO

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 463

const ACTION_DISK_INFO = 25;


ACTION_DISK_TYPE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 470

const ACTION_DISK_TYPE = 32;


ACTION_END

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 486

const ACTION_END = 1007;


ACTION_EVENT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 447

const ACTION_EVENT = 6;


ACTION_EXAMINE_ALL

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 501

const ACTION_EXAMINE_ALL = 1033;


ACTION_EXAMINE_ALL_END

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 504

const ACTION_EXAMINE_ALL_END = 1035;


ACTION_EXAMINE_FH

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 502

const ACTION_EXAMINE_FH = 1034;


ACTION_EXAMINE_FH64

Declaration

Source position: amigados.pas line 529

const ACTION_EXAMINE_FH64 = 26410;


ACTION_EXAMINE_NEXT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 462

const ACTION_EXAMINE_NEXT = 24;


ACTION_EXAMINE_NEXT64

Declaration

Source position: amigados.pas line 528

const ACTION_EXAMINE_NEXT64 = 26409;


ACTION_EXAMINE_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 461

const ACTION_EXAMINE_OBJECT = 23;


ACTION_EXAMINE_OBJECT64

Declaration

Source position: amigados.pas line 527

const ACTION_EXAMINE_OBJECT64 = 26408;


ACTION_FH_FROM_LOCK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 495

const ACTION_FH_FROM_LOCK = 1026;


ACTION_FINDINPUT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 484

const ACTION_FINDINPUT = 1005;


ACTION_FINDOUTPUT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 485

const ACTION_FINDOUTPUT = 1006;


ACTION_FINDUPDATE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 483

const ACTION_FINDUPDATE = 1004;


ACTION_FLUSH

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 465

const ACTION_FLUSH = 27;


ACTION_FORMAT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 488

const ACTION_FORMAT = 1020;


ACTION_FREE_DISK_FSSM

Declaration

Source position: amigados.pas line 516

const ACTION_FREE_DISK_FSSM = 4202;


ACTION_FREE_LOCK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 453

const ACTION_FREE_LOCK = 15;


ACTION_FREE_RECORD

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 508

const ACTION_FREE_RECORD = 2009;


ACTION_FREE_RECORD64

Declaration

Source position: amigados.pas line 522

const ACTION_FREE_RECORD64 = 26403;


ACTION_GET_BLOCK

Action for TDosPacket.dp_Type Obsolete

Declaration

Source position: amigados.pas line 444

const ACTION_GET_BLOCK = 2;


ACTION_GET_CURRENT_PREFS

Declaration

Source position: amigados.pas line 542

const ACTION_GET_CURRENT_PREFS = 26501;


ACTION_GET_DISK_FSSM

Declaration

Source position: amigados.pas line 515

const ACTION_GET_DISK_FSSM = 4201;


ACTION_GET_PREFS_TEMPLATE

Declaration

Source position: amigados.pas line 541

const ACTION_GET_PREFS_TEMPLATE = 26500;


ACTION_INFO

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 464

const ACTION_INFO = 26;


ACTION_INHIBIT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 469

const ACTION_INHIBIT = 31;


ACTION_IS_FILESYSTEM

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 496

const ACTION_IS_FILESYSTEM = 1027;


ACTION_LOCATE_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 449

const ACTION_LOCATE_OBJECT = 8;


ACTION_LOCK_RECORD

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 507

const ACTION_LOCK_RECORD = 2008;


ACTION_LOCK_RECORD64

Declaration

Source position: amigados.pas line 521

const ACTION_LOCK_RECORD64 = 26402;


ACTION_MAKE_LINK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 489

const ACTION_MAKE_LINK = 1021;


ACTION_MORE_CACHE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 456

const ACTION_MORE_CACHE = 18;


ACTION_NEW_READ_LINK

Declaration

Source position: amigados.pas line 525

const ACTION_NEW_READ_LINK = 26406;


ACTION_NIL

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 442

const ACTION_NIL = 0;


ACTION_PARENT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 467

const ACTION_PARENT = 29;


ACTION_PARENT_FH

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 500

const ACTION_PARENT_FH = 1031;


ACTION_QUERY_ATTR

Declaration

Source position: amigados.pas line 526

const ACTION_QUERY_ATTR = 26407;


ACTION_READ

Action for TDosPacket.dp_Type = Ord('R') read from Filesystem

Declaration

Source position: amigados.pas line 452

const ACTION_READ = $52;


ACTION_READ_LINK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 494

const ACTION_READ_LINK = 1024;


ACTION_READ_RETURN

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 480

const ACTION_READ_RETURN = 1001;


ACTION_REMOVE_NOTIFY

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 511

const ACTION_REMOVE_NOTIFY = 4098;


ACTION_RENAME_DISK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 450

const ACTION_RENAME_DISK = 9;


ACTION_RENAME_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 455

const ACTION_RENAME_OBJECT = 17;


ACTION_RESERVED_1

Declaration

Source position: amigados.pas line 523

const ACTION_RESERVED_1 = 26404;


ACTION_RESERVED_2

Declaration

Source position: amigados.pas line 524

const ACTION_RESERVED_2 = 26405;


ACTION_SAME_LOCK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 474

const ACTION_SAME_LOCK = 40;


ACTION_SCREEN_MODE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 476

const ACTION_SCREEN_MODE = 994;


ACTION_SEEK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 482

const ACTION_SEEK = 1008;


ACTION_SEEK64

Declaration

Source position: amigados.pas line 519

const ACTION_SEEK64 = 26400;


ACTION_SERIALIZE_DISK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 513

const ACTION_SERIALIZE_DISK = 4200;


ACTION_SET_COMMENT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 466

const ACTION_SET_COMMENT = 28;


ACTION_SET_DATE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 472

const ACTION_SET_DATE = 34;


ACTION_SET_FILE_SIZE

Declaration

Source position: amigados.pas line 491

const ACTION_SET_FILE_SIZE = 1022;


ACTION_SET_FILE_SIZE64

Declaration

Source position: amigados.pas line 520

const ACTION_SET_FILE_SIZE64 = 26401;


ACTION_SET_MAP

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 445

const ACTION_SET_MAP = 4;


ACTION_SET_OWNER

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 505

const ACTION_SET_OWNER = 1036;


ACTION_SET_PREFS

Declaration

Source position: amigados.pas line 543

const ACTION_SET_PREFS = 26502;


ACTION_SET_PROTECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 459

const ACTION_SET_PROTECT = 21;


ACTION_STARTUP

Declaration

Source position: amigados.pas line 443

const ACTION_STARTUP = 0;


ACTION_TIMER

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 468

const ACTION_TIMER = 30;


ACTION_WAIT_CHAR

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 458

const ACTION_WAIT_CHAR = 20;


ACTION_WRITE

Action for TDosPacket.dp_Type = Ord('W') write to Filesystem

Declaration

Source position: amigados.pas line 451

const ACTION_WRITE = $57;


ACTION_WRITE_PROTECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 492

const ACTION_WRITE_PROTECT = 1023;


ACTION_WRITE_RETURN

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 481

const ACTION_WRITE_RETURN = 1002;


ADDS_Dummy

Declaration

Source position: amigados.pas line 1190

const ADDS_Dummy = TAG_USER + 3000;


ADDS_Filename

Tag for AddSegmentTagList

Declaration

Source position: amigados.pas line 1193

const ADDS_Filename = ADDS_Dummy + 3;

Description

Value is a PChar


ADDS_Name

Tag for AddSegmentTagList

Declaration

Source position: amigados.pas line 1191

const ADDS_Name = ADDS_Dummy + 1;

Description

Valus is a PChar


ADDS_Seglist

Tag for AddSegmentTagList

Declaration

Source position: amigados.pas line 1192

const ADDS_Seglist = ADDS_Dummy + 2;

Description

Value is a BPTR


ADDS_Type

Tag for AddSegmentTagList

Declaration

Source position: amigados.pas line 1194

const ADDS_Type = ADDS_Dummy + 4;

Description

Value is a LongInt


ADO_AN_AssignList

Declaration

Source position: amigados.pas line 1283

const ADO_AN_AssignList = ADO_Dummy + 125;


ADO_AN_AssignName

Declaration

Source position: amigados.pas line 1282

const ADO_AN_AssignName = ADO_Dummy + 124;


ADO_AN_Lock

Declaration

Source position: amigados.pas line 1280

const ADO_AN_Lock = ADO_Dummy + 122;


ADO_AN_MsgPort

Declaration

Source position: amigados.pas line 1279

const ADO_AN_MsgPort = ADO_Dummy + 121;


ADO_AN_Name

Declaration

Source position: amigados.pas line 1278

const ADO_AN_Name = ADO_Dummy + 120;


ADO_AN_Type

Declaration

Source position: amigados.pas line 1281

const ADO_AN_Type = ADO_Dummy + 123;


ADO_CLI_Background

Declaration

Source position: amigados.pas line 1204

const ADO_CLI_Background = ADO_Dummy + 28;


ADO_CLI_CommFile

Declaration

Source position: amigados.pas line 1198

const ADO_CLI_CommFile = ADO_Dummy + 22;


ADO_CLI_CommName

Declaration

Source position: amigados.pas line 1197

const ADO_CLI_CommName = ADO_Dummy + 21;


ADO_CLI_DefaultStack

Declaration

Source position: amigados.pas line 1205

const ADO_CLI_DefaultStack = ADO_Dummy + 29;


ADO_CLI_Dir

Declaration

Source position: amigados.pas line 1196

const ADO_CLI_Dir = ADO_Dummy + 20;


ADO_CLI_FailLevel

Declaration

Source position: amigados.pas line 1202

const ADO_CLI_FailLevel = ADO_Dummy + 26;


ADO_CLI_Interactive

Declaration

Source position: amigados.pas line 1203

const ADO_CLI_Interactive = ADO_Dummy + 27;


ADO_CLI_Prompt

Declaration

Source position: amigados.pas line 1199

const ADO_CLI_Prompt = ADO_Dummy + 23;


ADO_CLI_Result2

Declaration

Source position: amigados.pas line 1200

const ADO_CLI_Result2 = ADO_Dummy + 24;


ADO_CLI_ReturnCode

Declaration

Source position: amigados.pas line 1201

const ADO_CLI_ReturnCode = ADO_Dummy + 25;


ADO_CommFileLen

Tag for AllocDosObject size in bytes for command file buffer

Declaration

Source position: amigados.pas line 1186

const ADO_CommFileLen = ADO_Dummy + 4;


ADO_CommNameLen

Tag for AllocDosObject size in bytes for command name buffer

Declaration

Source position: amigados.pas line 1185

const ADO_CommNameLen = ADO_Dummy + 3;


ADO_DE

Declaration

Source position: amigados.pas line 1242

const ADO_DE = ADO_Dummy + 60;


ADO_DE_Baud

Declaration

Source position: amigados.pas line 1263

const ADO_DE_Baud = ADO_Dummy + 78;


ADO_DE_BlksPerTrack

Declaration

Source position: amigados.pas line 1249

const ADO_DE_BlksPerTrack = ADO_Dummy + 66;


ADO_DE_BootBlocks

Declaration

Source position: amigados.pas line 1265

const ADO_DE_BootBlocks = ADO_Dummy + 80;


ADO_DE_BootPri

Declaration

Source position: amigados.pas line 1261

const ADO_DE_BootPri = ADO_Dummy + 76;


ADO_DE_BufMemType

Declaration

Source position: amigados.pas line 1258

const ADO_DE_BufMemType = ADO_Dummy + 73;


ADO_DE_Control

Declaration

Source position: amigados.pas line 1264

const ADO_DE_Control = ADO_Dummy + 79;


ADO_DE_DosType

Declaration

Source position: amigados.pas line 1262

const ADO_DE_DosType = ADO_Dummy + 77;


ADO_DE_HighCyl

Declaration

Source position: amigados.pas line 1256

const ADO_DE_HighCyl = ADO_DE_UpperCyl;


ADO_DE_Interleave

Declaration

Source position: amigados.pas line 1253

const ADO_DE_Interleave = ADO_Dummy + 69;


ADO_DE_LowCyl

Declaration

Source position: amigados.pas line 1254

const ADO_DE_LowCyl = ADO_Dummy + 70;


ADO_DE_Mask

Declaration

Source position: amigados.pas line 1260

const ADO_DE_Mask = ADO_Dummy + 75;


ADO_DE_MaxTransfer

Declaration

Source position: amigados.pas line 1259

const ADO_DE_MaxTransfer = ADO_Dummy + 74;


ADO_DE_NumBuffers

Declaration

Source position: amigados.pas line 1257

const ADO_DE_NumBuffers = ADO_Dummy + 72;


ADO_DE_NumHeads

Declaration

Source position: amigados.pas line 1246

const ADO_DE_NumHeads = ADO_Dummy + 64;


ADO_DE_PreAlloc

Declaration

Source position: amigados.pas line 1252

const ADO_DE_PreAlloc = ADO_DE_PreFac;


ADO_DE_PreFac

Declaration

Source position: amigados.pas line 1251

const ADO_DE_PreFac = ADO_Dummy + 68;


ADO_DE_ReservedBlks

Declaration

Source position: amigados.pas line 1250

const ADO_DE_ReservedBlks = ADO_Dummy + 67;


ADO_DE_SecOrg

Declaration

Source position: amigados.pas line 1245

const ADO_DE_SecOrg = ADO_Dummy + 63;


ADO_DE_SecsPerBlk

Declaration

Source position: amigados.pas line 1248

const ADO_DE_SecsPerBlk = ADO_Dummy + 65;


ADO_DE_SizeBlock

Declaration

Source position: amigados.pas line 1244

const ADO_DE_SizeBlock = ADO_Dummy + 62;


ADO_DE_Surfaces

Declaration

Source position: amigados.pas line 1247

const ADO_DE_Surfaces = ADO_DE_NumHeads;


ADO_DE_TableSize

Declaration

Source position: amigados.pas line 1243

const ADO_DE_TableSize = ADO_Dummy + 61;


ADO_DE_UpperCyl

Declaration

Source position: amigados.pas line 1255

const ADO_DE_UpperCyl = ADO_Dummy + 71;


ADO_DirLen

Tag for AllocDosObject size in bytes for current dir buffer

Declaration

Source position: amigados.pas line 1184

const ADO_DirLen = ADO_Dummy + 2;


ADO_DN_ExitNotifyMsg

Declaration

Source position: amigados.pas line 1226

const ADO_DN_ExitNotifyMsg = ADO_Dummy + 43;


ADO_DN_Flags

Declaration

Source position: amigados.pas line 1224

const ADO_DN_Flags = ADO_Dummy + 41;


ADO_DN_GlobalVec

Declaration

Source position: amigados.pas line 1216

const ADO_DN_GlobalVec = ADO_Dummy + 38;


ADO_DN_Handler

Declaration

Source position: amigados.pas line 1211

const ADO_DN_Handler = ADO_Dummy + 33;


ADO_DN_Lock

Declaration

Source position: amigados.pas line 1210

const ADO_DN_Lock = ADO_Dummy + 32;


ADO_DN_MsgPort

Declaration

Source position: amigados.pas line 1209

const ADO_DN_MsgPort = ADO_Dummy + 31;


ADO_DN_Name

Declaration

Source position: amigados.pas line 1208

const ADO_DN_Name = ADO_Dummy + 30;


ADO_DN_Priority

Declaration

Source position: amigados.pas line 1214

const ADO_DN_Priority = ADO_Dummy + 36;


ADO_DN_Seglist

Declaration

Source position: amigados.pas line 1212

const ADO_DN_Seglist = ADO_Dummy + 34;


ADO_DN_SerialID

Declaration

Source position: amigados.pas line 1219

const ADO_DN_SerialID = ADO_Dummy + 39;


ADO_DN_StackSize

Declaration

Source position: amigados.pas line 1213

const ADO_DN_StackSize = ADO_Dummy + 35;


ADO_DN_Startup

Declaration

Source position: amigados.pas line 1215

const ADO_DN_Startup = ADO_Dummy + 37;


ADO_DN_StartupValue

Declaration

Source position: amigados.pas line 1221

const ADO_DN_StartupValue = ADO_Dummy + 40;


ADO_DN_Status

Declaration

Source position: amigados.pas line 1225

const ADO_DN_Status = ADO_Dummy + 42;


ADO_Dummy

Tag for AllocDosObject start of Tag range

Declaration

Source position: amigados.pas line 1181

const ADO_Dummy = TAG_USER + 2000;


ADO_FH_Mode

Tag for AllocDosObject sets up FH for mode

Declaration

Source position: amigados.pas line 1182

const ADO_FH_Mode = ADO_Dummy + 1;

Description

for type DOS_FILEHANDLE only, sets up FH for mode specified. This can make a big difference for buffered files


ADO_FS_DosType

Declaration

Source position: amigados.pas line 1268

const ADO_FS_DosType = ADO_Dummy + 90;


ADO_FSSM

Declaration

Source position: amigados.pas line 1236

const ADO_FSSM = ADO_Dummy + 50;


ADO_FSSM_Device

Declaration

Source position: amigados.pas line 1237

const ADO_FSSM_Device = ADO_Dummy + 51;


ADO_FSSM_Flags

Declaration

Source position: amigados.pas line 1239

const ADO_FSSM_Flags = ADO_Dummy + 53;


ADO_FSSM_Unit

Declaration

Source position: amigados.pas line 1238

const ADO_FSSM_Unit = ADO_Dummy + 52;


ADO_PromptLen

Tag for AllocDosObject size in bytes for the prompt buffer

Declaration

Source position: amigados.pas line 1187

const ADO_PromptLen = ADO_Dummy + 5;


ADO_VN_Date

Declaration

Source position: amigados.pas line 1274

const ADO_VN_Date = ADO_Dummy + 104;


ADO_VN_DiskType

Declaration

Source position: amigados.pas line 1275

const ADO_VN_DiskType = ADO_Dummy + 105;


ADO_VN_Lock

Declaration

Source position: amigados.pas line 1272

const ADO_VN_Lock = ADO_Dummy + 102;


ADO_VN_LockList

Declaration

Source position: amigados.pas line 1273

const ADO_VN_LockList = ADO_Dummy + 103;


ADO_VN_MsgPort

Declaration

Source position: amigados.pas line 1271

const ADO_VN_MsgPort = ADO_Dummy + 101;


ADO_VN_Name

Declaration

Source position: amigados.pas line 1270

const ADO_VN_Name = ADO_Dummy + 100;


APB_DIDDIR

Flag Bit for ap_Flags. Marks an an "expired" dir node.

Declaration

Source position: amigados.pas line 889

const APB_DIDDIR = 3;


APB_DirChanged

Flag Bit for ap_Flags. Allow conversion of '.' to CurrentDir

Declaration

Source position: amigados.pas line 898

const APB_DirChanged = 6;


APB_DODIR

Flag Bit for ap_Flags. Marks a Directory

Declaration

Source position: amigados.pas line 886

const APB_DODIR = 2;


APB_DODOT

Flag Bit for ap_Flags.

Declaration

Source position: amigados.pas line 895

const APB_DODOT = 5;


APB_DOWILD

User option ALL

Declaration

Source position: amigados.pas line 880

const APB_DOWILD = 0;


APB_FollowHLinks

Declaration

Source position: amigados.pas line 901

const APB_FollowHLinks = 7;


APB_ITSWILD

Flag Bit for ap_Flags. Set by MatchFirst, used by MatchNext

Declaration

Source position: amigados.pas line 883

const APB_ITSWILD = 1;


APB_NOMEMERR

Flag Bit for ap_Flags. Set on memory error

Declaration

Source position: amigados.pas line 892

const APB_NOMEMERR = 4;


APEB_DontFollowSLinks

Declaration

Source position: amigados.pas line 916

const APEB_DontFollowSLinks = 2;


APEB_FutureExtension

Declaration

Source position: amigados.pas line 919

const APEB_FutureExtension = 7;


APEB_LiteralSLinks

Declaration

Source position: amigados.pas line 912

const APEB_LiteralSLinks = 1;


APEF_DontFollowSLinks

Declaration

Source position: amigados.pas line 917

const APEF_DontFollowSLinks = 1 shl APEB_DontFollowSLinks;


APEF_FutureExtension

Declaration

Source position: amigados.pas line 920

const APEF_FutureExtension = 1 shl APEB_FutureExtension;


APEF_LiteralSLinks

Declaration

Source position: amigados.pas line 913

const APEF_LiteralSLinks = 1 shl APEB_LiteralSLinks;


APF_DIDDIR

Flag Value for ap_Flags. Marks an "expired" dir node.

Declaration

Source position: amigados.pas line 890

const APF_DIDDIR = 1 shl APB_DIDDIR;


APF_DirChanged

Flag Value for ap_Flags. Allow conversion of '.' to CurrentDir

Declaration

Source position: amigados.pas line 899

const APF_DirChanged = 1 shl APB_DirChanged;


APF_DODIR

Flag Value for ap_Flags. Marks a Directories

Declaration

Source position: amigados.pas line 887

const APF_DODIR = 1 shl APB_DODIR;


APF_DODOT

Flag Value for ap_Flags.

Declaration

Source position: amigados.pas line 896

const APF_DODOT = 1 shl APB_DODOT;


APF_DOWILD

Declaration

Source position: amigados.pas line 881

const APF_DOWILD = 1 shl APB_DOWILD;


APF_FollowHLinks

Declaration

Source position: amigados.pas line 902

const APF_FollowHLinks = 1 shl APB_FollowHLinks;


APF_ITSWILD

Flag Value for ap_Flags. Set by MatchFirst, used by MatchNext

Declaration

Source position: amigados.pas line 884

const APF_ITSWILD = 1 shl APB_ITSWILD;


APF_NOMEMERR

Flag Value for ap_Flags. Set on memory error

Declaration

Source position: amigados.pas line 893

const APF_NOMEMERR = 1 shl APB_NOMEMERR;


APSB_EXTENDED

Declaration

Source position: amigados.pas line 905

const APSB_EXTENDED = 15;


APSF_EXTENDED

Declaration

Source position: amigados.pas line 906

const APSF_EXTENDED = 1 shl APSB_EXTENDED;


BITSPERBYTE

Numbers of Bits per Byte

Declaration

Source position: amigados.pas line 55

const BITSPERBYTE = 8;


BITSPERLONG

Number of Bits per LongWord

Declaration

Source position: amigados.pas line 57

const BITSPERLONG = 32;


Unit 'AmigaDOS' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

BPTR

Declaration

Source position: amigados.pas line 146

type BPTR = LongInt;


Unit 'AmigaDOS' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

BSTR

Declaration

Source position: amigados.pas line 147

type BSTR = LongInt;


BUF_FULL

Declaration

Source position: amigados.pas line 1353

const BUF_FULL = 1;


BUF_LINE

Declaration

Source position: amigados.pas line 1352

const BUF_LINE = 0;


BUF_NONE

Declaration

Source position: amigados.pas line 1354

const BUF_NONE = 2;


BYTESPERLONG

Number of Bytes per LongWord

Declaration

Source position: amigados.pas line 56

const BYTESPERLONG = 4;


CHANGE_FH

Type for ChangeMode

Declaration

Source position: amigados.pas line 261

const CHANGE_FH = 1;


CHANGE_LOCK

Type for ChangeMode

Declaration

Source position: amigados.pas line 260

const CHANGE_LOCK = 0;


CMD_DISABLED

Declaration

Source position: amigados.pas line 631

const CMD_DISABLED = - 999;


CMD_INTERNAL

Declaration

Source position: amigados.pas line 629

const CMD_INTERNAL = - 2;


CMD_NOTLOADED

Declaration

Source position: amigados.pas line 630

const CMD_NOTLOADED = - 998;


CMD_SYSTEM

Declaration

Source position: amigados.pas line 628

const CMD_SYSTEM = - 1;


COMPLEX_BIT

Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers

Declaration

Source position: amigados.pas line 953

const COMPLEX_BIT = 1;


DDB_AllBit

Declaration

Source position: amigados.pas line 932

const DDB_AllBit = 3;


DDB_Completed

Declaration

Source position: amigados.pas line 929

const DDB_Completed = 2;


DDB_ExaminedBit

Declaration

Source position: amigados.pas line 926

const DDB_ExaminedBit = 1;


DDB_PatternBit

Bit for ap_Current->an_Lock changed since last MatchNext call

Declaration

Source position: amigados.pas line 923

const DDB_PatternBit = 0;


DDB_Single

Declaration

Source position: amigados.pas line 935

const DDB_Single = 4;


DDF_AllBit

Declaration

Source position: amigados.pas line 933

const DDF_AllBit = 1 shl DDB_AllBit;


DDF_Completed

Declaration

Source position: amigados.pas line 930

const DDF_Completed = 1 shl DDB_Completed;


DDF_ExaminedBit

Declaration

Source position: amigados.pas line 927

const DDF_ExaminedBit = 1 shl DDB_ExaminedBit;


DDF_PatternBit

Value for ap_Current->an_Lock changed since last MatchNext call

Declaration

Source position: amigados.pas line 924

const DDF_PatternBit = 1 shl DDB_PatternBit;


DDF_Single

Declaration

Source position: amigados.pas line 936

const DDF_Single = 1 shl DDB_Single;


DE_BAUD

Offset TDosEnvec: in longwords: Baud rate for serial handler

Declaration

Source position: amigados.pas line 1492

const DE_BAUD = 17;


DE_BLKSPERTRACK

Offset TDosEnvec: in longwords: blocks per track. drive specific

Declaration

Source position: amigados.pas line 1479

const DE_BLKSPERTRACK = 5;


DE_BOOTBLOCKS

Offset TDosEnvec: in longwords: Number of blocks containing boot code

Declaration

Source position: amigados.pas line 1494

const DE_BOOTBLOCKS = 19;


DE_BOOTPRI

Offset TDosEnvec: in longwords: Boot priority for autoboot

Declaration

Source position: amigados.pas line 1490

const DE_BOOTPRI = 15;


DE_BUFMEMTYPE

Offset TDosEnvec: in longwords: type of mem to allocate for buffers.

Declaration

Source position: amigados.pas line 1487

const DE_BUFMEMTYPE = 12;


DE_CONTROL

Offset TDosEnvec: in longwords: Control SmallInt for handler/filesystem

Declaration

Source position: amigados.pas line 1493

const DE_CONTROL = 18;


DE_DOSTYPE

Offset TDosEnvec: in longwords: ASCII (HEX) string showing filesystem type

Declaration

Source position: amigados.pas line 1491

const DE_DOSTYPE = 16;


DE_INTERLEAVE

Offset TDosEnvec: in longwords: usually 0

Declaration

Source position: amigados.pas line 1482

const DE_INTERLEAVE = 8;


DE_LOWCYL

Offset TDosEnvec: in longwords: starting cylinder. typically 0

Declaration

Source position: amigados.pas line 1483

const DE_LOWCYL = 9;


DE_MASK

Offset TDosEnvec: in longwords: Address Mask to block out certain memory

Declaration

Source position: amigados.pas line 1489

const DE_MASK = 14;


DE_MAXTRANSFER

Offset TDosEnvec: in longwords: Max number bytes to transfer at a time

Declaration

Source position: amigados.pas line 1488

const DE_MAXTRANSFER = 13;


DE_MEMBUFTYPE

Offset TDosEnvec: in longwords: type of mem to allocate for buffers.

Declaration

Source position: amigados.pas line 1486

const DE_MEMBUFTYPE = 12;


DE_NUMBUFFERS

Offset TDosEnvec: in longwords: starting # of buffers. typically 5

Declaration

Source position: amigados.pas line 1485

const DE_NUMBUFFERS = 11;


DE_NUMHEADS

Offset TDosEnvec: in longwords: # of heads (surfaces). drive specific

Declaration

Source position: amigados.pas line 1477

const DE_NUMHEADS = 3;


DE_PREFAC

Offset TDosEnvec: in longwords: not used; must be 0

Declaration

Source position: amigados.pas line 1481

const DE_PREFAC = 7;


DE_RESERVEDBLKS

Offset TDosEnvec: in longwords: unavailable blocks at start. usually 2

Declaration

Source position: amigados.pas line 1480

const DE_RESERVEDBLKS = 6;


DE_SECORG

Offset TDosEnvec: in longwords: not used; must be 0

Declaration

Source position: amigados.pas line 1476

const DE_SECORG = 2;


DE_SECSPERBLK

Offset TDosEnvec: in longwords: not used; must be 1

Declaration

Source position: amigados.pas line 1478

const DE_SECSPERBLK = 4;


DE_SIZEBLOCK

Offset TDosEnvec: in longwords: standard value is 128

Declaration

Source position: amigados.pas line 1475

const DE_SIZEBLOCK = 1;


DE_TABLESIZE

Offset TDosEnvec: standard value is 11

Declaration

Source position: amigados.pas line 1474

const DE_TABLESIZE = 0;


DE_UPPERCYL

Offset TDosEnvec: in longwords: max cylinder. drive specific

Declaration

Source position: amigados.pas line 1484

const DE_UPPERCYL = 10;


DLT_DEVICE

Type for TDosList.dol_Type identifiers a device

Declaration

Source position: amigados.pas line 727

const DLT_DEVICE = 0;


DLT_DIRECTORY

Type for TDosList.dol_Type identifiers a directory

Declaration

Source position: amigados.pas line 728

const DLT_DIRECTORY = 1;


DLT_FSCONTEXT

Declaration

Source position: amigados.pas line 734

const DLT_FSCONTEXT = 5;


DLT_LATE

Type for TDosList.dol_Type identifiers a late binding assign

Declaration

Source position: amigados.pas line 730

const DLT_LATE = 3;


DLT_NONBINDING

Type for TDosList.dol_Type identifiers a non binding assign

Declaration

Source position: amigados.pas line 731

const DLT_NONBINDING = 4;


DLT_PRIVATE

Type for TDosList.dol_Type for internal use

Declaration

Source position: amigados.pas line 732

const DLT_PRIVATE = - 1;


DLT_VOLUME

Type for TDosList.dol_Type identifiers a volume

Declaration

Source position: amigados.pas line 729

const DLT_VOLUME = 2;


DNF_REMDOSLIST

Declaration

Source position: amigados.pas line 1233

const DNF_REMDOSLIST = 1 shl 2;


DNF_STARTONCE

Declaration

Source position: amigados.pas line 1229

const DNF_STARTONCE = 1 shl 0;


DNF_UNLOADSEGLIST

Declaration

Source position: amigados.pas line 1231

const DNF_UNLOADSEGLIST = 1 shl 1;


DOS_ASSIGNNODE

Declaration

Source position: amigados.pas line 286

const DOS_ASSIGNNODE = 9;


DOS_CLI

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 280

const DOS_CLI = 4;


DOS_DEVICENODE

Declaration

Source position: amigados.pas line 283

const DOS_DEVICENODE = 6;


DOS_EXALLCONTROL

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 277

const DOS_EXALLCONTROL = 1;


DOS_FIB

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 278

const DOS_FIB = 2;


DOS_FILEHANDLE

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 276

const DOS_FILEHANDLE = 0;


DOS_FSCONTEXT

Declaration

Source position: amigados.pas line 284

const DOS_FSCONTEXT = 7;


DOS_RDARGS

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 281

const DOS_RDARGS = 5;


DOS_STDPKT

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 279

const DOS_STDPKT = 3;


DOS_VOLUMENODE

Declaration

Source position: amigados.pas line 285

const DOS_VOLUMENODE = 8;


DosBase

Declaration

Source position: amigados.pas line 28

var DosBase: Pointer;


DOSFALSE

=0 as False Value for some Amiga functions.

Declaration

Source position: amigados.pas line 41

const DOSFALSE = 0;

Description

Some DOS functions can not handle the freepascal representation of True as -1. This functions expect a 1 as boolean True, for this purpose two constants are defined for True and False

See also

DOSTRUE

=1 as True Value for some Amiga functions.


DOSNAME

Declaration

Source position: amigados.pas line 37

const DOSNAME = 'dos.library';


DOSTRUE

=1 as True Value for some Amiga functions.

Declaration

Source position: amigados.pas line 40

const DOSTRUE = - 1;

Description

Some DOS functions can not handle the freepascal representation of True as -1. This functions expect a 1 as boolean True, for this purpose two constants are defined for True and False

See also

DOSFALSE

=0 as False Value for some Amiga functions.


DTB_FUTURE

Declaration

Source position: amigados.pas line 311

const DTB_FUTURE = 1;


DTB_SUBST

Declaration

Source position: amigados.pas line 309

const DTB_SUBST = 0;


DTF_FUTURE

Declaration

Source position: amigados.pas line 312

const DTF_FUTURE = 1 shl DTB_FUTURE;


DTF_SUBST

Declaration

Source position: amigados.pas line 310

const DTF_SUBST = 1 shl DTB_SUBST;


DVPB_ASSIGN

Flag Bit for TDevProc.dvp_Flags

Declaration

Source position: amigados.pas line 750

const DVPB_ASSIGN = 1;


DVPB_FSCONTEXT

Declaration

Source position: amigados.pas line 753

const DVPB_FSCONTEXT = 2;


DVPB_UNLOCK

Flag Bit for TDevProc.dvp_Flags

Declaration

Source position: amigados.pas line 747

const DVPB_UNLOCK = 0;


DVPF_ASSIGN

Flag Value for TDevProc.dvp_Flags

Declaration

Source position: amigados.pas line 751

const DVPF_ASSIGN = 1 shl DVPB_ASSIGN;


DVPF_FSCONTEXT

Declaration

Source position: amigados.pas line 754

const DVPF_FSCONTEXT = 1 shl DVPB_FSCONTEXT;


DVPF_UNLOCK

Flag Value for TDevProc.dvp_Flags

Declaration

Source position: amigados.pas line 748

const DVPF_UNLOCK = 1 shl DVPB_UNLOCK;


ED_COMMENT

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1052

const ED_COMMENT = 6;


ED_DATE

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1051

const ED_DATE = 5;


ED_NAME

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1047

const ED_NAME = 1;


ED_OWNER

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1053

const ED_OWNER = 7;


ED_PROTECTION

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1050

const ED_PROTECTION = 4;


ED_SIZE

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1049

const ED_SIZE = 3;


ED_SIZE64

Declaration

Source position: amigados.pas line 1056

const ED_SIZE64 = 8;


ED_TYPE

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1048

const ED_TYPE = 2;


ENDSTREAMCH

Declaration

Source position: amigados.pas line 1357

const ENDSTREAMCH = - 1;


ERROR_ACTION_NOT_KNOWN

Errorcode of IoErr

Declaration

Source position: amigados.pas line 207

const ERROR_ACTION_NOT_KNOWN = 209;


ERROR_BAD_HUNK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 229

const ERROR_BAD_HUNK = 235;


ERROR_BAD_NUMBER

Errorcode of IoErr

Declaration

Source position: amigados.pas line 192

const ERROR_BAD_NUMBER = 115;


ERROR_BAD_STREAM_NAME

Errorcode of IoErr

Declaration

Source position: amigados.pas line 205

const ERROR_BAD_STREAM_NAME = 206;


ERROR_BAD_TEMPLATE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 191

const ERROR_BAD_TEMPLATE = 114;


ERROR_BREAK

Returns from MatchFirst, MatchNext: A break character was received

Declaration

Source position: amigados.pas line 958

const ERROR_BREAK = 304;


ERROR_BUFFER_OVERFLOW

Returns from MatchFirst, MatchNext: User OR internal buffer overflow

Declaration

Source position: amigados.pas line 957

const ERROR_BUFFER_OVERFLOW = 303;


ERROR_COMMENT_TOO_BIG

Errorcode of IoErr

Declaration

Source position: amigados.pas line 218

const ERROR_COMMENT_TOO_BIG = 220;


ERROR_DELETE_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 220

const ERROR_DELETE_PROTECTED = 222;


ERROR_DEVICE_NOT_MOUNTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 216

const ERROR_DEVICE_NOT_MOUNTED = 218;


ERROR_DIR_NOT_FOUND

Errorcode of IoErr

Declaration

Source position: amigados.pas line 203

const ERROR_DIR_NOT_FOUND = 204;


ERROR_DIRECTORY_NOT_EMPTY

Errorcode of IoErr

Declaration

Source position: amigados.pas line 214

const ERROR_DIRECTORY_NOT_EMPTY = 216;


ERROR_DISK_FULL

Errorcode of IoErr

Declaration

Source position: amigados.pas line 219

const ERROR_DISK_FULL = 221;


ERROR_DISK_NOT_VALIDATED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 211

const ERROR_DISK_NOT_VALIDATED = 213;


ERROR_DISK_WRITE_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 212

const ERROR_DISK_WRITE_PROTECTED = 214;


ERROR_FILE_NOT_OBJECT

Errorcode of IoErr

Declaration

Source position: amigados.pas line 198

const ERROR_FILE_NOT_OBJECT = 121;


ERROR_INVALID_COMPONENT_NAME

Errorcode of IoErr

Declaration

Source position: amigados.pas line 208

const ERROR_INVALID_COMPONENT_NAME = 210;


ERROR_INVALID_LOCK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 209

const ERROR_INVALID_LOCK = 211;


ERROR_INVALID_RESIDENT_LIBRARY

Errorcode of IoErr

Declaration

Source position: amigados.pas line 199

const ERROR_INVALID_RESIDENT_LIBRARY = 122;


ERROR_IS_SOFT_LINK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 227

const ERROR_IS_SOFT_LINK = 233;


ERROR_KEY_NEEDS_ARG

Errorcode of IoErr

Declaration

Source position: amigados.pas line 194

const ERROR_KEY_NEEDS_ARG = 117;


ERROR_LINE_TOO_LONG

Errorcode of IoErr

Declaration

Source position: amigados.pas line 197

const ERROR_LINE_TOO_LONG = 120;


ERROR_LOCK_COLLISION

Errorcode of IoErr

Declaration

Source position: amigados.pas line 232

const ERROR_LOCK_COLLISION = 241;


ERROR_LOCK_TIMEOUT

Errorcode of IoErr

Declaration

Source position: amigados.pas line 233

const ERROR_LOCK_TIMEOUT = 242;


ERROR_NO_DEFAULT_DIR

Errorcode of IoErr

Declaration

Source position: amigados.pas line 200

const ERROR_NO_DEFAULT_DIR = 201;


ERROR_NO_DISK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 224

const ERROR_NO_DISK = 226;


ERROR_NO_FREE_STORE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 189

const ERROR_NO_FREE_STORE = 103;


ERROR_NO_MORE_ENTRIES

Errorcode of IoErr

Declaration

Source position: amigados.pas line 225

const ERROR_NO_MORE_ENTRIES = 232;


ERROR_NOT_A_DOS_DISK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 223

const ERROR_NOT_A_DOS_DISK = 225;


ERROR_NOT_EXECUTABLE

Returns from MatchFirst, MatchNext: A file has E bit cleared

Declaration

Source position: amigados.pas line 959

const ERROR_NOT_EXECUTABLE = 305;


ERROR_NOT_IMPLEMENTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 230

const ERROR_NOT_IMPLEMENTED = 236;


ERROR_OBJECT_EXISTS

Errorcode of IoErr

Declaration

Source position: amigados.pas line 202

const ERROR_OBJECT_EXISTS = 203;


ERROR_OBJECT_IN_USE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 201

const ERROR_OBJECT_IN_USE = 202;


ERROR_OBJECT_LINKED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 228

const ERROR_OBJECT_LINKED = 234;


ERROR_OBJECT_NOT_FOUND

Errorcode of IoErr

Declaration

Source position: amigados.pas line 204

const ERROR_OBJECT_NOT_FOUND = 205;


ERROR_OBJECT_TOO_LARGE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 206

const ERROR_OBJECT_TOO_LARGE = 207;


ERROR_OBJECT_WRONG_TYPE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 210

const ERROR_OBJECT_WRONG_TYPE = 212;


ERROR_READ_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 222

const ERROR_READ_PROTECTED = 224;


ERROR_RECORD_NOT_LOCKED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 231

const ERROR_RECORD_NOT_LOCKED = 240;


ERROR_RENAME_ACROSS_DEVICES

Errorcode of IoErr

Declaration

Source position: amigados.pas line 213

const ERROR_RENAME_ACROSS_DEVICES = 215;


ERROR_REQUIRED_ARG_MISSING

Errorcode of IoErr

Declaration

Source position: amigados.pas line 193

const ERROR_REQUIRED_ARG_MISSING = 116;


ERROR_SEEK_ERROR

Errorcode of IoErr

Declaration

Source position: amigados.pas line 217

const ERROR_SEEK_ERROR = 219;


ERROR_TASK_TABLE_FULL

Errorcode of IoErr

Declaration

Source position: amigados.pas line 190

const ERROR_TASK_TABLE_FULL = 105;


ERROR_TOO_MANY_ARGS

Errorcode of IoErr

Declaration

Source position: amigados.pas line 195

const ERROR_TOO_MANY_ARGS = 118;


ERROR_TOO_MANY_LEVELS

Errorcode of IoErr

Declaration

Source position: amigados.pas line 215

const ERROR_TOO_MANY_LEVELS = 217;


ERROR_UNLOCK_ERROR

Errorcode of IoErr

Declaration

Source position: amigados.pas line 234

const ERROR_UNLOCK_ERROR = 243;


ERROR_UNMATCHED_QUOTES

Errorcode of IoErr

Declaration

Source position: amigados.pas line 196

const ERROR_UNMATCHED_QUOTES = 119;


ERROR_WRITE_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 221

const ERROR_WRITE_PROTECTED = 223;


EXAMINE_BIT

Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers

Declaration

Source position: amigados.pas line 954

const EXAMINE_BIT = 2;


EXCLUSIVE_LOCK

Parameter for Lock Exclusive lock, so other access allowed

Declaration

Source position: amigados.pas line 64

const EXCLUSIVE_LOCK = - 1;


Unit 'AmigaDOS' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

EXT_ABS

Declaration

Source position: amigados.pas line 1015

const EXT_ABS = 2;


EXT_ABSCOMMON

Declaration

Source position: amigados.pas line 1022

const EXT_ABSCOMMON = EXT_COMMON;


EXT_ABSREF8

Declaration

Source position: amigados.pas line 1039

const EXT_ABSREF8 = 139;


EXT_ABSREF16

Declaration

Source position: amigados.pas line 1037

const EXT_ABSREF16 = 138;


EXT_ABSREF32

Declaration

Source position: amigados.pas line 1019

const EXT_ABSREF32 = EXT_REF32;


EXT_COMMON

Declaration

Source position: amigados.pas line 1021

const EXT_COMMON = 130;


Unit 'AmigaDOS' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

EXT_DEF

Declaration

Source position: amigados.pas line 1014

const EXT_DEF = 1;


EXT_DEXT8

Declaration

Source position: amigados.pas line 1032

const EXT_DEXT8 = 135;


EXT_DEXT16

Declaration

Source position: amigados.pas line 1031

const EXT_DEXT16 = 134;


EXT_DEXT32

Declaration

Source position: amigados.pas line 1030

const EXT_DEXT32 = 133;


EXT_REF8

Declaration

Source position: amigados.pas line 1027

const EXT_REF8 = 132;


EXT_REF16

Declaration

Source position: amigados.pas line 1024

const EXT_REF16 = 131;


EXT_REF32

Declaration

Source position: amigados.pas line 1018

const EXT_REF32 = 129;


EXT_RELCOMMON

Declaration

Source position: amigados.pas line 1035

const EXT_RELCOMMON = 137;


EXT_RELREF8

Declaration

Source position: amigados.pas line 1028

const EXT_RELREF8 = EXT_REF8;


EXT_RELREF16

Declaration

Source position: amigados.pas line 1025

const EXT_RELREF16 = EXT_REF16;


EXT_RELREF32

Declaration

Source position: amigados.pas line 1034

const EXT_RELREF32 = 136;


Unit 'AmigaDOS' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

EXT_RES

Declaration

Source position: amigados.pas line 1016

const EXT_RES = 3;


EXT_SYMB

Declaration

Source position: amigados.pas line 1013

const EXT_SYMB = 0;


FIBB_ARCHIVE

Protection Bit: Set as archive

Declaration

Source position: amigados.pas line 118

const FIBB_ARCHIVE = 4;

Description

Cleared whenever file is changed

See also

TFileInfoBlock

File information structure


FIBB_DELETE

Protection Bit: file can be deleted

Declaration

Source position: amigados.pas line 122

const FIBB_DELETE = 0;

See also

TFileInfoBlock

File information structure


FIBB_EXECUTE

Protection Bit: file is executable

Declaration

Source position: amigados.pas line 121

const FIBB_EXECUTE = 1;

See also

TFileInfoBlock

File information structure


FIBB_GRP_DELETE

Protection Bit Group: prevent file from being deleted

Declaration

Source position: amigados.pas line 114

const FIBB_GRP_DELETE = 8;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_GRP_EXECUTE

Protection Bit Group: file is executable

Declaration

Source position: amigados.pas line 113

const FIBB_GRP_EXECUTE = 9;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_GRP_READ

Protection Bit Group: file is readable

Declaration

Source position: amigados.pas line 111

const FIBB_GRP_READ = 11;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_GRP_WRITE

Protection Bit Group: file is writable

Declaration

Source position: amigados.pas line 112

const FIBB_GRP_WRITE = 10;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_DELETE

Protection Bit Other: prevent file from being deleted

Declaration

Source position: amigados.pas line 110

const FIBB_OTR_DELETE = 12;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_EXECUTE

Protection Bit Other: file is executable

Declaration

Source position: amigados.pas line 109

const FIBB_OTR_EXECUTE = 13;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_READ

Protection Bit Other: file is readable

Declaration

Source position: amigados.pas line 107

const FIBB_OTR_READ = 15;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_WRITE

Protection Bit Other: file is writable

Declaration

Source position: amigados.pas line 108

const FIBB_OTR_WRITE = 14;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_PURE

Protection Bit program is reentrant and rexecutable

Declaration

Source position: amigados.pas line 117

const FIBB_PURE = 5;

See also

TFileInfoBlock

File information structure


FIBB_READ

Protection Bit: file is readable

Declaration

Source position: amigados.pas line 119

const FIBB_READ = 3;

See also

TFileInfoBlock

File information structure


FIBB_SCRIPT

Protection Bit File can run as script

Declaration

Source position: amigados.pas line 116

const FIBB_SCRIPT = 6;

Description

File is a shell script file can be executed.

See also

TFileInfoBlock

File information structure


FIBB_WRITE

Protection Bit: file is writeable

Declaration

Source position: amigados.pas line 120

const FIBB_WRITE = 2;

See also

TFileInfoBlock

File information structure


FIBF_ARCHIVE

Protection Value File is marked as archived

Declaration

Source position: amigados.pas line 136

const FIBF_ARCHIVE = 1 shl FIBB_ARCHIVE;

Description

Is cleared on every filechange

See also

TFileInfoBlock

File information structure


FIBF_DELETE

Protection Value file can be deleted

Declaration

Source position: amigados.pas line 140

const FIBF_DELETE = 1 shl FIBB_DELETE;

See also

TFileInfoBlock

File information structure


FIBF_EXECUTE

Protection Value file can be exceuted

Declaration

Source position: amigados.pas line 139

const FIBF_EXECUTE = 1 shl FIBB_EXECUTE;

See also

TFileInfoBlock

File information structure


FIBF_GRP_DELETE

Protection Value Group: Deleteable

Declaration

Source position: amigados.pas line 132

const FIBF_GRP_DELETE = 1 shl FIBB_GRP_DELETE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_GRP_EXECUTE

Protection Value: Group Executeable

Declaration

Source position: amigados.pas line 131

const FIBF_GRP_EXECUTE = 1 shl FIBB_GRP_EXECUTE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_GRP_READ

Protection Value Group Readable

Declaration

Source position: amigados.pas line 129

const FIBF_GRP_READ = 1 shl FIBB_GRP_READ;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_GRP_WRITE

Protection Value Group Writeable

Declaration

Source position: amigados.pas line 130

const FIBF_GRP_WRITE = 1 shl FIBB_GRP_WRITE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_DELETE

Protection Value Other Deleteable

Declaration

Source position: amigados.pas line 128

const FIBF_OTR_DELETE = 1 shl FIBB_OTR_DELETE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_EXECUTE

Protection Value: Other executeable

Declaration

Source position: amigados.pas line 127

const FIBF_OTR_EXECUTE = 1 shl FIBB_OTR_EXECUTE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_READ

Protection Value Other Readable

Declaration

Source position: amigados.pas line 125

const FIBF_OTR_READ = 1 shl FIBB_OTR_READ;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_WRITE

Protection Value Other writeable

Declaration

Source position: amigados.pas line 126

const FIBF_OTR_WRITE = 1 shl FIBB_OTR_WRITE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_PURE

Protection Value program is reentrant and rexecutable

Declaration

Source position: amigados.pas line 135

const FIBF_PURE = 1 shl FIBB_PURE;

See also

TFileInfoBlock

File information structure


FIBF_READ

Protection Value: File is readable

Declaration

Source position: amigados.pas line 137

const FIBF_READ = 1 shl FIBB_READ;

See also

TFileInfoBlock

File information structure


FIBF_SCRIPT

Protection Value: File is a script

Declaration

Source position: amigados.pas line 134

const FIBF_SCRIPT = 1 shl FIBB_SCRIPT;

Description

File is a shell script and can be executed

See also

TFileInfoBlock

File information structure


FIBF_WRITE

Protection Value file is writeable

Declaration

Source position: amigados.pas line 138

const FIBF_WRITE = 1 shl FIBB_WRITE;

See also

TFileInfoBlock

File information structure


FNDS_Dummy

Declaration

Source position: amigados.pas line 1294

const FNDS_Dummy = TAG_USER + 3100;


FNDS_From

Declaration

Source position: amigados.pas line 1296

const FNDS_From = FNDS_Dummy + 2;


FNDS_Load

Declaration

Source position: amigados.pas line 1298

const FNDS_Load = FNDS_Dummy + 4;


FNDS_Name

Declaration

Source position: amigados.pas line 1295

const FNDS_Name = FNDS_Dummy + 1;


FNDS_System

Declaration

Source position: amigados.pas line 1297

const FNDS_System = FNDS_Dummy + 3;


FQA_DeviceType

Declaration

Source position: amigados.pas line 535

const FQA_DeviceType = 4;


FQA_IsCaseSensitive

Declaration

Source position: amigados.pas line 534

const FQA_IsCaseSensitive = 3;


FQA_MaxFileNameLength

Declaration

Source position: amigados.pas line 531

const FQA_MaxFileNameLength = 0;


FQA_MaxFileSize

Declaration

Source position: amigados.pas line 533

const FQA_MaxFileSize = 2;


FQA_MaxVolumeNameLength

Declaration

Source position: amigados.pas line 532

const FQA_MaxVolumeNameLength = 1;


FQA_NumBlocks

Declaration

Source position: amigados.pas line 537

const FQA_NumBlocks = 6;


FQA_NumBlocksUsed

Declaration

Source position: amigados.pas line 538

const FQA_NumBlocksUsed = 7;


FQA_ReservedAttr1

Declaration

Source position: amigados.pas line 536

const FQA_ReservedAttr1 = 5;


FSCONTEXTINFOTAG_Dummy

Declaration

Source position: amigados.pas line 1314

const FSCONTEXTINFOTAG_Dummy = TAG_USER + 3300;


FSCONTEXTINFOTAG_NAME

Declaration

Source position: amigados.pas line 1315

const FSCONTEXTINFOTAG_NAME = FSCONTEXTINFOTAG_Dummy + $1;


FSCONTEXTTAG_DOSTYPE

Declaration

Source position: amigados.pas line 1312

const FSCONTEXTTAG_DOSTYPE = FSCONTEXTTAG_Dummy + $7;


FSCONTEXTTAG_Dummy

Declaration

Source position: amigados.pas line 1301

const FSCONTEXTTAG_Dummy = TAG_USER + 3200;


FSCONTEXTTAG_FSSM

Declaration

Source position: amigados.pas line 1310

const FSCONTEXTTAG_FSSM = FSCONTEXTTAG_Dummy + $6;


FSCONTEXTTAG_PRIORITY

Declaration

Source position: amigados.pas line 1306

const FSCONTEXTTAG_PRIORITY = FSCONTEXTTAG_Dummy + $2;


FSCONTEXTTAG_SEGLIST

Declaration

Source position: amigados.pas line 1305

const FSCONTEXTTAG_SEGLIST = FSCONTEXTTAG_Dummy + $1;


FSCONTEXTTAG_STACKSIZE

Declaration

Source position: amigados.pas line 1307

const FSCONTEXTTAG_STACKSIZE = FSCONTEXTTAG_Dummy + $3;


FSCONTEXTTAG_STARTUPSTRING

Declaration

Source position: amigados.pas line 1308

const FSCONTEXTTAG_STARTUPSTRING = FSCONTEXTTAG_Dummy + $4;


FSCONTEXTTAG_STARTUPVALUE

Declaration

Source position: amigados.pas line 1309

const FSCONTEXTTAG_STARTUPVALUE = FSCONTEXTTAG_Dummy + $5;


GVB_BINARY_VAR

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1390

const GVB_BINARY_VAR = 10;


GVB_DONT_NULL_TERM

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1393

const GVB_DONT_NULL_TERM = 11;


GVB_GLOBAL_ONLY

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1384

const GVB_GLOBAL_ONLY = 8;


GVB_LOCAL_ONLY

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1387

const GVB_LOCAL_ONLY = 9;


GVB_SAVE_VAR

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1396

const GVB_SAVE_VAR = 12;


GVF_BINARY_VAR

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1391

const GVF_BINARY_VAR = 1 shl GVB_BINARY_VAR;


GVF_DONT_NULL_TERM

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1394

const GVF_DONT_NULL_TERM = 1 shl GVB_DONT_NULL_TERM;


GVF_GLOBAL_ONLY

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1385

const GVF_GLOBAL_ONLY = 1 shl GVB_GLOBAL_ONLY;


GVF_LOCAL_ONLY

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1388

const GVF_LOCAL_ONLY = 1 shl GVB_LOCAL_ONLY;


GVF_SAVE_VAR

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 1397

const GVF_SAVE_VAR = 1 shl GVB_SAVE_VAR;


HUNK_ABSRELOC16

Declaration

Source position: amigados.pas line 1001

const HUNK_ABSRELOC16 = 1022;


HUNK_ABSRELOC32

Declaration

Source position: amigados.pas line 974

const HUNK_ABSRELOC32 = HUNK_RELOC32;


HUNK_BREAK

Declaration

Source position: amigados.pas line 989

const HUNK_BREAK = 1014;


HUNK_BSS

Declaration

Source position: amigados.pas line 971

const HUNK_BSS = 1003;


HUNK_CODE

Declaration

Source position: amigados.pas line 969

const HUNK_CODE = 1001;


HUNK_DATA

Declaration

Source position: amigados.pas line 970

const HUNK_DATA = 1002;


HUNK_DEBUG

Declaration

Source position: amigados.pas line 984

const HUNK_DEBUG = 1009;


HUNK_DREL8

Declaration

Source position: amigados.pas line 993

const HUNK_DREL8 = 1017;


HUNK_DREL16

Declaration

Source position: amigados.pas line 992

const HUNK_DREL16 = 1016;


HUNK_DREL32

Declaration

Source position: amigados.pas line 991

const HUNK_DREL32 = 1015;


HUNK_END

Declaration

Source position: amigados.pas line 985

const HUNK_END = 1010;


HUNK_EXT

Declaration

Source position: amigados.pas line 982

const HUNK_EXT = 1007;


HUNK_HEADER

Declaration

Source position: amigados.pas line 986

const HUNK_HEADER = 1011;


HUNK_INDEX

Declaration

Source position: amigados.pas line 996

const HUNK_INDEX = 1019;


HUNK_LIB

Declaration

Source position: amigados.pas line 995

const HUNK_LIB = 1018;


HUNK_NAME

Declaration

Source position: amigados.pas line 968

const HUNK_NAME = 1000;


HUNK_OVERLAY

Declaration

Source position: amigados.pas line 988

const HUNK_OVERLAY = 1013;


HUNK_RELOC8

Declaration

Source position: amigados.pas line 979

const HUNK_RELOC8 = 1006;


HUNK_RELOC16

Declaration

Source position: amigados.pas line 976

const HUNK_RELOC16 = 1005;


HUNK_RELOC32

Declaration

Source position: amigados.pas line 973

const HUNK_RELOC32 = 1004;


HUNK_RELOC32SHORT

Declaration

Source position: amigados.pas line 998

const HUNK_RELOC32SHORT = 1020;


HUNK_RELRELOC8

Declaration

Source position: amigados.pas line 980

const HUNK_RELRELOC8 = HUNK_RELOC8;


HUNK_RELRELOC16

Declaration

Source position: amigados.pas line 977

const HUNK_RELRELOC16 = HUNK_RELOC16;


HUNK_RELRELOC32

Declaration

Source position: amigados.pas line 1000

const HUNK_RELRELOC32 = 1021;


HUNK_SYMBOL

Declaration

Source position: amigados.pas line 983

const HUNK_SYMBOL = 1008;


HUNK_UNIT

Declaration

Source position: amigados.pas line 967

const HUNK_UNIT = 999;


HUNKB_ADVISORY

Declaration

Source position: amigados.pas line 1004

const HUNKB_ADVISORY = 29;


HUNKB_CHIP

Declaration

Source position: amigados.pas line 1005

const HUNKB_CHIP = 30;


HUNKB_FAST

Declaration

Source position: amigados.pas line 1006

const HUNKB_FAST = 31;


HUNKF_ADVISORY

Declaration

Source position: amigados.pas line 1008

const HUNKF_ADVISORY = 1 shl HUNKB_ADVISORY;


HUNKF_CHIP

Declaration

Source position: amigados.pas line 1009

const HUNKF_CHIP = 1 shl HUNKB_CHIP;


HUNKF_FAST

Declaration

Source position: amigados.pas line 1010

const HUNKF_FAST = 1 shl HUNKB_FAST;


ID_CDFS_DISK

Declaration

Source position: amigados.pas line 182

const ID_CDFS_DISK = $43444653;


ID_CDROM_CDDA_DISK

Declaration

Source position: amigados.pas line 185

const ID_CDROM_CDDA_DISK = $43444441;


ID_CDROM_HSF_DISK

Declaration

Source position: amigados.pas line 184

const ID_CDROM_HSF_DISK = $43443030;


ID_CDROM_ISO_DISK

Declaration

Source position: amigados.pas line 183

const ID_CDROM_ISO_DISK = $43443031;


ID_DOS_DISK

Flag for Info .id_Diskstate DOS#0 OFS disk

Declaration

Source position: amigados.pas line 171

const ID_DOS_DISK = $444F5300;


ID_FASTDIR_DOS_DISK

Declaration

Source position: amigados.pas line 175

const ID_FASTDIR_DOS_DISK = $444F5304;


ID_FASTDIR_FFS_DISK

Declaration

Source position: amigados.pas line 176

const ID_FASTDIR_FFS_DISK = $444F5305;


ID_FFS_DISK

Flag for Info .id_Diskstate DOS#1 FFS disk

Declaration

Source position: amigados.pas line 172

const ID_FFS_DISK = $444F5301;


ID_INTER_DOS_DISK

Declaration

Source position: amigados.pas line 173

const ID_INTER_DOS_DISK = $444F5302;


ID_INTER_FFS_DISK

Declaration

Source position: amigados.pas line 174

const ID_INTER_FFS_DISK = $444F5303;


ID_KICKSTART_DISK

Flag for Info .id_Diskstate KICK Kickstart Disk

Declaration

Source position: amigados.pas line 180

const ID_KICKSTART_DISK = $4B49434B;


ID_LNFS_DOS_DISK

Declaration

Source position: amigados.pas line 177

const ID_LNFS_DOS_DISK = $444F5306;


ID_LNFS_FFS_DISK

Declaration

Source position: amigados.pas line 178

const ID_LNFS_FFS_DISK = $444F5307;


ID_MSDOS_DISK

Flag for Info .id_Diskstate MSD#0 MSDos Disk

Declaration

Source position: amigados.pas line 181

const ID_MSDOS_DISK = $4d534400;


ID_NO_DISK_PRESENT

Flag for Info .id_DiskType No Disk Present

Declaration

Source position: amigados.pas line 169

const ID_NO_DISK_PRESENT = - 1;


ID_NOT_REALLY_DOS

Flag for Info .id_Diskstate NDOS not a dos disk

Declaration

Source position: amigados.pas line 179

const ID_NOT_REALLY_DOS = $4E444F53;


ID_SFS_DISK

Declaration

Source position: amigados.pas line 186

const ID_SFS_DISK = $53465300;


ID_UNREADABLE_DISK

Flag for Info .id_Diskstate BAD#0 Disk defective

Declaration

Source position: amigados.pas line 170

const ID_UNREADABLE_DISK = $42414400;


ID_VALIDATED

Flag for Info .id_Diskstate Device validated and writeable

Declaration

Source position: amigados.pas line 167

const ID_VALIDATED = 82;


ID_VALIDATING

Flag for Info .id_Diskstate Device is currently validating status

Declaration

Source position: amigados.pas line 166

const ID_VALIDATING = 81;


ID_WRITE_PROTECTED

Flag for Info .id_Diskstate Device is write protected

Declaration

Source position: amigados.pas line 165

const ID_WRITE_PROTECTED = 80;


Reference for unit 'AmigaDOS'

File and directory handling routines and types (dos.library)

uses

  System,

  exec,

This unit contains the types and wrapper functions for the exec.library.

  timer;

Overview

The DOS-Library has functions and types to work with files and directories on floppy discs, hard discs and ram discs.


Reference for unit 'AmigaDOS': Constants

ABORT_BUSY | Error report busy at ErrorReport()
ABORT_DISK_ERROR | Error report Read write error at ErrorReport()
ACCESS_READ | Parameter for Lock File is readable by others
ACCESS_WRITE | Parameter for Lock Exclusive lock, so other access allowed
ACTION_ADD_NOTIFY | Action for TDosPacket.dp_Type
ACTION_CHANGE_MODE | Action for TDosPacket.dp_Type
ACTION_CHANGE_SIGNAL | Action for TDosPacket.dp_Type
ACTION_COPY_DIR | Action for TDosPacket.dp_Type
ACTION_COPY_DIR_FH | Action for TDosPacket.dp_Type
ACTION_CREATE_DIR | Action for TDosPacket.dp_Type
ACTION_CURRENT_VOLUME | Action for TDosPacket.dp_Type
ACTION_DELETE_OBJECT | Action for TDosPacket.dp_Type
ACTION_DIE | Action for TDosPacket.dp_Type
ACTION_DISK_CHANGE | Action for TDosPacket.dp_Type
ACTION_DISK_INFO | Action for TDosPacket.dp_Type
ACTION_DISK_TYPE | Action for TDosPacket.dp_Type
ACTION_END | Action for TDosPacket.dp_Type
ACTION_EVENT | Action for TDosPacket.dp_Type
ACTION_EXAMINE_ALL | Action for TDosPacket.dp_Type
ACTION_EXAMINE_ALL_END | Action for TDosPacket.dp_Type
ACTION_EXAMINE_FH | Action for TDosPacket.dp_Type
ACTION_EXAMINE_FH64 |
ACTION_EXAMINE_NEXT | Action for TDosPacket.dp_Type
ACTION_EXAMINE_NEXT64 |
ACTION_EXAMINE_OBJECT | Action for TDosPacket.dp_Type
ACTION_EXAMINE_OBJECT64 |
ACTION_FH_FROM_LOCK | Action for TDosPacket.dp_Type
ACTION_FINDINPUT | Action for TDosPacket.dp_Type
ACTION_FINDOUTPUT | Action for TDosPacket.dp_Type
ACTION_FINDUPDATE | Action for TDosPacket.dp_Type
ACTION_FLUSH | Action for TDosPacket.dp_Type
ACTION_FORMAT | Action for TDosPacket.dp_Type
ACTION_FREE_DISK_FSSM |
ACTION_FREE_LOCK | Action for TDosPacket.dp_Type
ACTION_FREE_RECORD | Action for TDosPacket.dp_Type
ACTION_FREE_RECORD64 |
ACTION_GET_BLOCK | Action for TDosPacket.dp_Type Obsolete
ACTION_GET_CURRENT_PREFS |
ACTION_GET_DISK_FSSM |
ACTION_GET_PREFS_TEMPLATE |
ACTION_INFO | Action for TDosPacket.dp_Type
ACTION_INHIBIT | Action for TDosPacket.dp_Type
ACTION_IS_FILESYSTEM | Action for TDosPacket.dp_Type
ACTION_LOCATE_OBJECT | Action for TDosPacket.dp_Type
ACTION_LOCK_RECORD | Action for TDosPacket.dp_Type
ACTION_LOCK_RECORD64 |
ACTION_MAKE_LINK | Action for TDosPacket.dp_Type
ACTION_MORE_CACHE | Action for TDosPacket.dp_Type
ACTION_NEW_READ_LINK |
ACTION_NIL | Action for TDosPacket.dp_Type
ACTION_PARENT | Action for TDosPacket.dp_Type
ACTION_PARENT_FH | Action for TDosPacket.dp_Type
ACTION_QUERY_ATTR |
ACTION_READ | Action for TDosPacket.dp_Type = Ord('R') read from Filesystem
ACTION_READ_LINK | Action for TDosPacket.dp_Type
ACTION_READ_RETURN | Action for TDosPacket.dp_Type
ACTION_REMOVE_NOTIFY | Action for TDosPacket.dp_Type
ACTION_RENAME_DISK | Action for TDosPacket.dp_Type
ACTION_RENAME_OBJECT | Action for TDosPacket.dp_Type
ACTION_RESERVED_1 |
ACTION_RESERVED_2 |
ACTION_SAME_LOCK | Action for TDosPacket.dp_Type
ACTION_SCREEN_MODE | Action for TDosPacket.dp_Type
ACTION_SEEK | Action for TDosPacket.dp_Type
ACTION_SEEK64 |
ACTION_SERIALIZE_DISK | Action for TDosPacket.dp_Type
ACTION_SET_COMMENT | Action for TDosPacket.dp_Type
ACTION_SET_DATE | Action for TDosPacket.dp_Type
ACTION_SET_FILE_SIZE |
ACTION_SET_FILE_SIZE64 |
ACTION_SET_MAP | Action for TDosPacket.dp_Type
ACTION_SET_OWNER | Action for TDosPacket.dp_Type
ACTION_SET_PREFS |
ACTION_SET_PROTECT | Action for TDosPacket.dp_Type
ACTION_STARTUP |
ACTION_TIMER | Action for TDosPacket.dp_Type
ACTION_WAIT_CHAR | Action for TDosPacket.dp_Type
ACTION_WRITE | Action for TDosPacket.dp_Type = Ord('W') write to Filesystem
ACTION_WRITE_PROTECT | Action for TDosPacket.dp_Type
ACTION_WRITE_RETURN | Action for TDosPacket.dp_Type
ADDS_Dummy |
ADDS_Filename | Tag for AddSegmentTagList
ADDS_Name | Tag for AddSegmentTagList
ADDS_Seglist | Tag for AddSegmentTagList
ADDS_Type | Tag for AddSegmentTagList
ADO_AN_AssignList |
ADO_AN_AssignName |
ADO_AN_Lock |
ADO_AN_MsgPort |
ADO_AN_Name |
ADO_AN_Type |
ADO_CLI_Background |
ADO_CLI_CommFile |
ADO_CLI_CommName |
ADO_CLI_DefaultStack |
ADO_CLI_Dir |
ADO_CLI_FailLevel |
ADO_CLI_Interactive |
ADO_CLI_Prompt |
ADO_CLI_Result2 |
ADO_CLI_ReturnCode |
ADO_CommFileLen | Tag for AllocDosObject size in bytes for command file buffer
ADO_CommNameLen | Tag for AllocDosObject size in bytes for command name buffer
ADO_DE |
ADO_DE_Baud |
ADO_DE_BlksPerTrack |
ADO_DE_BootBlocks |
ADO_DE_BootPri |
ADO_DE_BufMemType |
ADO_DE_Control |
ADO_DE_DosType |
ADO_DE_HighCyl |
ADO_DE_Interleave |
ADO_DE_LowCyl |
ADO_DE_Mask |
ADO_DE_MaxTransfer |
ADO_DE_NumBuffers |
ADO_DE_NumHeads |
ADO_DE_PreAlloc |
ADO_DE_PreFac |
ADO_DE_ReservedBlks |
ADO_DE_SecOrg |
ADO_DE_SecsPerBlk |
ADO_DE_SizeBlock |
ADO_DE_Surfaces |
ADO_DE_TableSize |
ADO_DE_UpperCyl |
ADO_DirLen | Tag for AllocDosObject size in bytes for current dir buffer
ADO_DN_ExitNotifyMsg |
ADO_DN_Flags |
ADO_DN_GlobalVec |
ADO_DN_Handler |
ADO_DN_Lock |
ADO_DN_MsgPort |
ADO_DN_Name |
ADO_DN_Priority |
ADO_DN_Seglist |
ADO_DN_SerialID |
ADO_DN_StackSize |
ADO_DN_Startup |
ADO_DN_StartupValue |
ADO_DN_Status |
ADO_Dummy | Tag for AllocDosObject start of Tag range
ADO_FH_Mode | Tag for AllocDosObject sets up FH for mode
ADO_FSSM |
ADO_FSSM_Device |
ADO_FSSM_Flags |
ADO_FSSM_Unit |
ADO_FS_DosType |
ADO_PromptLen | Tag for AllocDosObject size in bytes for the prompt buffer
ADO_VN_Date |
ADO_VN_DiskType |
ADO_VN_Lock |
ADO_VN_LockList |
ADO_VN_MsgPort |
ADO_VN_Name |
APB_DIDDIR | Flag Bit for ap_Flags. Marks an an "expired" dir node.
APB_DirChanged | Flag Bit for ap_Flags. Allow conversion of '.' to CurrentDir
APB_DODIR | Flag Bit for ap_Flags. Marks a Directory
APB_DODOT | Flag Bit for ap_Flags.
APB_DOWILD | User option ALL
APB_FollowHLinks |
APB_ITSWILD | Flag Bit for ap_Flags. Set by MatchFirst, used by MatchNext
APB_NOMEMERR | Flag Bit for ap_Flags. Set on memory error
APEB_DontFollowSLinks |
APEB_FutureExtension |
APEB_LiteralSLinks |
APEF_DontFollowSLinks |
APEF_FutureExtension |
APEF_LiteralSLinks |
APF_DIDDIR | Flag Value for ap_Flags. Marks an "expired" dir node.
APF_DirChanged | Flag Value for ap_Flags. Allow conversion of '.' to CurrentDir
APF_DODIR | Flag Value for ap_Flags. Marks a Directories
APF_DODOT | Flag Value for ap_Flags.
APF_DOWILD |
APF_FollowHLinks |
APF_ITSWILD | Flag Value for ap_Flags. Set by MatchFirst, used by MatchNext
APF_NOMEMERR | Flag Value for ap_Flags. Set on memory error
APSB_EXTENDED |
APSF_EXTENDED |
BITSPERBYTE | Numbers of Bits per Byte
BITSPERLONG | Number of Bits per LongWord
BUF_FULL |
BUF_LINE |
BUF_NONE |
BYTESPERLONG | Number of Bytes per LongWord
CHANGE_FH | Type for ChangeMode
CHANGE_LOCK | Type for ChangeMode
CLIDATATAG_CLINumber |
CLIDATATAG_CommandName |
CLIDATATAG_Dummy |
CLIDATATAG_Sorted |
CMD_DISABLED |
CMD_INTERNAL |
CMD_NOTLOADED |
CMD_SYSTEM |
COMPLEX_BIT | Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers
DDB_AllBit |
DDB_Completed |
DDB_ExaminedBit |
DDB_PatternBit | Bit for ap_Current->an_Lock changed since last MatchNext call
DDB_Single |
DDF_AllBit |
DDF_Completed |
DDF_ExaminedBit |
DDF_PatternBit | Value for ap_Current->an_Lock changed since last MatchNext call
DDF_Single |
DE_BAUD | Offset TDosEnvec: in longwords: Baud rate for serial handler
DE_BLKSPERTRACK | Offset TDosEnvec: in longwords: blocks per track. drive specific
DE_BOOTBLOCKS | Offset TDosEnvec: in longwords: Number of blocks containing boot code
DE_BOOTPRI | Offset TDosEnvec: in longwords: Boot priority for autoboot
DE_BUFMEMTYPE | Offset TDosEnvec: in longwords: type of mem to allocate for buffers.
DE_CONTROL | Offset TDosEnvec: in longwords: Control SmallInt for handler/filesystem
DE_DOSTYPE | Offset TDosEnvec: in longwords: ASCII (HEX) string showing filesystem type
DE_INTERLEAVE | Offset TDosEnvec: in longwords: usually 0
DE_LOWCYL | Offset TDosEnvec: in longwords: starting cylinder. typically 0
DE_MASK | Offset TDosEnvec: in longwords: Address Mask to block out certain memory
DE_MAXTRANSFER | Offset TDosEnvec: in longwords: Max number bytes to transfer at a time
DE_MEMBUFTYPE | Offset TDosEnvec: in longwords: type of mem to allocate for buffers.
DE_NUMBUFFERS | Offset TDosEnvec: in longwords: starting # of buffers. typically 5
DE_NUMHEADS | Offset TDosEnvec: in longwords: # of heads (surfaces). drive specific
DE_PREFAC | Offset TDosEnvec: in longwords: not used; must be 0
DE_RESERVEDBLKS | Offset TDosEnvec: in longwords: unavailable blocks at start. usually 2
DE_SECORG | Offset TDosEnvec: in longwords: not used; must be 0
DE_SECSPERBLK | Offset TDosEnvec: in longwords: not used; must be 1
DE_SIZEBLOCK | Offset TDosEnvec: in longwords: standard value is 128
DE_TABLESIZE | Offset TDosEnvec: standard value is 11
DE_UPPERCYL | Offset TDosEnvec: in longwords: max cylinder. drive specific
DLT_DEVICE | Type for TDosList.dol_Type identifiers a device
DLT_DIRECTORY | Type for TDosList.dol_Type identifiers a directory
DLT_FSCONTEXT |
DLT_LATE | Type for TDosList.dol_Type identifiers a late binding assign
DLT_NONBINDING | Type for TDosList.dol_Type identifiers a non binding assign
DLT_PRIVATE | Type for TDosList.dol_Type for internal use
DLT_VOLUME | Type for TDosList.dol_Type identifiers a volume
DNF_REMDOSLIST |
DNF_STARTONCE |
DNF_UNLOADSEGLIST |
DOSFALSE | =0 as False Value for some Amiga functions.
DOSNAME |
DOSTRUE | =1 as True Value for some Amiga functions.
DOS_ASSIGNNODE |
DOS_CLI | Type for AllocDosObject/FreeDosObject
DOS_DEVICENODE |
DOS_EXALLCONTROL | Type for AllocDosObject/FreeDosObject
DOS_FIB | Type for AllocDosObject/FreeDosObject
DOS_FILEHANDLE | Type for AllocDosObject/FreeDosObject
DOS_FSCONTEXT |
DOS_RDARGS | Type for AllocDosObject/FreeDosObject
DOS_STDPKT | Type for AllocDosObject/FreeDosObject
DOS_VOLUMENODE |
DTB_FUTURE |
DTB_SUBST |
DTF_FUTURE |
DTF_SUBST |
DVPB_ASSIGN | Flag Bit for TDevProc.dvp_Flags
DVPB_FSCONTEXT |
DVPB_UNLOCK | Flag Bit for TDevProc.dvp_Flags
DVPF_ASSIGN | Flag Value for TDevProc.dvp_Flags
DVPF_FSCONTEXT |
DVPF_UNLOCK | Flag Value for TDevProc.dvp_Flags
ED_COMMENT | Parameter for ExAll()
ED_DATE | Parameter for ExAll()
ED_NAME | Parameter for ExAll()
ED_OWNER | Parameter for ExAll()
ED_PROTECTION | Parameter for ExAll()
ED_SIZE | Parameter for ExAll()
ED_SIZE64 |
ED_TYPE | Parameter for ExAll()
ENDSTREAMCH |
ERROR_ACTION_NOT_KNOWN | Errorcode of IoErr
ERROR_BAD_HUNK | Errorcode of IoErr
ERROR_BAD_NUMBER | Errorcode of IoErr
ERROR_BAD_STREAM_NAME | Errorcode of IoErr
ERROR_BAD_TEMPLATE | Errorcode of IoErr
ERROR_BREAK | Returns from MatchFirst, MatchNext: A break character was received
ERROR_BUFFER_OVERFLOW | Returns from MatchFirst, MatchNext: User OR internal buffer overflow
ERROR_COMMENT_TOO_BIG | Errorcode of IoErr
ERROR_DELETE_PROTECTED | Errorcode of IoErr
ERROR_DEVICE_NOT_MOUNTED | Errorcode of IoErr
ERROR_DIRECTORY_NOT_EMPTY | Errorcode of IoErr
ERROR_DIR_NOT_FOUND | Errorcode of IoErr
ERROR_DISK_FULL | Errorcode of IoErr
ERROR_DISK_NOT_VALIDATED | Errorcode of IoErr
ERROR_DISK_WRITE_PROTECTED | Errorcode of IoErr
ERROR_FILE_NOT_OBJECT | Errorcode of IoErr
ERROR_INVALID_COMPONENT_NAME | Errorcode of IoErr
ERROR_INVALID_LOCK | Errorcode of IoErr
ERROR_INVALID_RESIDENT_LIBRARY | Errorcode of IoErr
ERROR_IS_SOFT_LINK | Errorcode of IoErr
ERROR_KEY_NEEDS_ARG | Errorcode of IoErr
ERROR_LINE_TOO_LONG | Errorcode of IoErr
ERROR_LOCK_COLLISION | Errorcode of IoErr
ERROR_LOCK_TIMEOUT | Errorcode of IoErr
ERROR_NOT_A_DOS_DISK | Errorcode of IoErr
ERROR_NOT_EXECUTABLE | Returns from MatchFirst, MatchNext: A file has E bit cleared
ERROR_NOT_IMPLEMENTED | Errorcode of IoErr
ERROR_NO_DEFAULT_DIR | Errorcode of IoErr
ERROR_NO_DISK | Errorcode of IoErr
ERROR_NO_FREE_STORE | Errorcode of IoErr
ERROR_NO_MORE_ENTRIES | Errorcode of IoErr
ERROR_OBJECT_EXISTS | Errorcode of IoErr
ERROR_OBJECT_IN_USE | Errorcode of IoErr
ERROR_OBJECT_LINKED | Errorcode of IoErr
ERROR_OBJECT_NOT_FOUND | Errorcode of IoErr
ERROR_OBJECT_TOO_LARGE | Errorcode of IoErr
ERROR_OBJECT_WRONG_TYPE | Errorcode of IoErr
ERROR_READ_PROTECTED | Errorcode of IoErr
ERROR_RECORD_NOT_LOCKED | Errorcode of IoErr
ERROR_RENAME_ACROSS_DEVICES | Errorcode of IoErr
ERROR_REQUIRED_ARG_MISSING | Errorcode of IoErr
ERROR_SEEK_ERROR | Errorcode of IoErr
ERROR_TASK_TABLE_FULL | Errorcode of IoErr
ERROR_TOO_MANY_ARGS | Errorcode of IoErr
ERROR_TOO_MANY_LEVELS | Errorcode of IoErr
ERROR_UNLOCK_ERROR | Errorcode of IoErr
ERROR_UNMATCHED_QUOTES | Errorcode of IoErr
ERROR_WRITE_PROTECTED | Errorcode of IoErr
EXAMINE_BIT | Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers
EXCLUSIVE_LOCK | Parameter for Lock Exclusive lock, so other access allowed
EXT_ABS |
EXT_ABSCOMMON |
EXT_ABSREF16 |
EXT_ABSREF32 |
EXT_ABSREF8 |
EXT_COMMON |
EXT_DEF |
EXT_DEXT16 |
EXT_DEXT32 |
EXT_DEXT8 |
EXT_REF16 |
EXT_REF32 |
EXT_REF8 |
EXT_RELCOMMON |
EXT_RELREF16 |
EXT_RELREF32 |
EXT_RELREF8 |
EXT_RES |
EXT_SYMB |
FAULT_MAX | Max Length for error string
FIBB_ARCHIVE | Protection Bit: Set as archive
FIBB_DELETE | Protection Bit: file can be deleted
FIBB_EXECUTE | Protection Bit: file is executable
FIBB_GRP_DELETE | Protection Bit Group: prevent file from being deleted
FIBB_GRP_EXECUTE | Protection Bit Group: file is executable
FIBB_GRP_READ | Protection Bit Group: file is readable
FIBB_GRP_WRITE | Protection Bit Group: file is writable
FIBB_OTR_DELETE | Protection Bit Other: prevent file from being deleted
FIBB_OTR_EXECUTE | Protection Bit Other: file is executable
FIBB_OTR_READ | Protection Bit Other: file is readable
FIBB_OTR_WRITE | Protection Bit Other: file is writable
FIBB_PURE | Protection Bit program is reentrant and rexecutable
FIBB_READ | Protection Bit: file is readable
FIBB_SCRIPT | Protection Bit File can run as script
FIBB_WRITE | Protection Bit: file is writeable
FIBF_ARCHIVE | Protection Value File is marked as archived
FIBF_DELETE | Protection Value file can be deleted
FIBF_EXECUTE | Protection Value file can be exceuted
FIBF_GRP_DELETE | Protection Value Group: Deleteable
FIBF_GRP_EXECUTE | Protection Value: Group Executeable
FIBF_GRP_READ | Protection Value Group Readable
FIBF_GRP_WRITE | Protection Value Group Writeable
FIBF_OTR_DELETE | Protection Value Other Deleteable
FIBF_OTR_EXECUTE | Protection Value: Other executeable
FIBF_OTR_READ | Protection Value Other Readable
FIBF_OTR_WRITE | Protection Value Other writeable
FIBF_PURE | Protection Value program is reentrant and rexecutable
FIBF_READ | Protection Value: File is readable
FIBF_SCRIPT | Protection Value: File is a script
FIBF_WRITE | Protection Value file is writeable
FNDS_Dummy |
FNDS_From |
FNDS_Load |
FNDS_Name |
FNDS_System |
FORMAT_CDN |
FORMAT_DEF |
FORMAT_DOS |
FORMAT_INT |
FORMAT_MAX |
FORMAT_USA |
FQA_DeviceType |
FQA_IsCaseSensitive |
FQA_MaxFileNameLength |
FQA_MaxFileSize |
FQA_MaxVolumeNameLength |
FQA_NumBlocks |
FQA_NumBlocksUsed |
FQA_ReservedAttr1 |
FSCONTEXTINFOTAG_Dummy |
FSCONTEXTINFOTAG_NAME |
FSCONTEXTTAG_DOSTYPE |
FSCONTEXTTAG_Dummy |
FSCONTEXTTAG_FSSM |
FSCONTEXTTAG_PRIORITY |
FSCONTEXTTAG_SEGLIST |
FSCONTEXTTAG_STACKSIZE |
FSCONTEXTTAG_STARTUPSTRING |
FSCONTEXTTAG_STARTUPVALUE |
GVB_BINARY_VAR | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_DONT_NULL_TERM | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_GLOBAL_ONLY | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_LOCAL_ONLY | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_SAVE_VAR | Flag bit passed to GetVar/SetVar/DeleteVar
GVF_BINARY_VAR | Flag value passed to GetVar/SetVar/DeleteVar
GVF_DONT_NULL_TERM | Flag value passed to GetVar/SetVar/DeleteVar
GVF_GLOBAL_ONLY | Flag value passed to GetVar/SetVar/DeleteVar
GVF_LOCAL_ONLY | Flag value passed to GetVar/SetVar/DeleteVar
GVF_SAVE_VAR | Flag value passed to GetVar/SetVar/DeleteVar
HUNKB_ADVISORY |
HUNKB_CHIP |
HUNKB_FAST |
HUNKF_ADVISORY |
HUNKF_CHIP |
HUNKF_FAST |
HUNK_ABSRELOC16 |
HUNK_ABSRELOC32 |
HUNK_BREAK |
HUNK_BSS |
HUNK_CODE |
HUNK_DATA |
HUNK_DEBUG |
HUNK_DREL16 |
HUNK_DREL32 |
HUNK_DREL8 |
HUNK_END |
HUNK_EXT |
HUNK_HEADER |
HUNK_INDEX |
HUNK_LIB |
HUNK_NAME |
HUNK_OVERLAY |
HUNK_RELOC16 |
HUNK_RELOC32 |
HUNK_RELOC32SHORT |
HUNK_RELOC8 |
HUNK_RELRELOC16 |
HUNK_RELRELOC32 |
HUNK_RELRELOC8 |
HUNK_SYMBOL |
HUNK_UNIT |
ID_CDFS_DISK |
ID_CDROM_CDDA_DISK |
ID_CDROM_HSF_DISK |
ID_CDROM_ISO_DISK |
ID_DOS_DISK | Flag for Info .id_Diskstate DOS#0 OFS disk
ID_FASTDIR_DOS_DISK |
ID_FASTDIR_FFS_DISK |
ID_FFS_DISK | Flag for Info .id_Diskstate DOS#1 FFS disk
ID_INTER_DOS_DISK |
ID_INTER_FFS_DISK |
ID_KICKSTART_DISK | Flag for Info .id_Diskstate KICK Kickstart Disk
ID_LNFS_DOS_DISK |
ID_LNFS_FFS_DISK |
ID_MSDOS_DISK | Flag for Info .id_Diskstate MSD#0 MSDos Disk
ID_NOT_REALLY_DOS | Flag for Info .id_Diskstate NDOS not a dos disk
ID_NO_DISK_PRESENT | Flag for Info .id_DiskType No Disk Present
ID_SFS_DISK |
ID_UNREADABLE_DISK | Flag for Info .id_Diskstate BAD#0 Disk defective
ID_VALIDATED | Flag for Info .id_Diskstate Device validated and writeable
ID_VALIDATING | Flag for Info .id_Diskstate Device is currently validating status
ID_WRITE_PROTECTED | Flag for Info .id_Diskstate Device is write protected
ITEM_EQUAL |
ITEM_ERROR |
ITEM_NOTHING |
ITEM_QUOTED |
ITEM_UNQUOTED |
LDB_ASSIGNS | Flag bit passed to LockDosList()
LDB_DELETE | Flag bit passed to LockDosList()
LDB_DEVICES | Flag bit passed to LockDosList()
LDB_ENTRY | Flag bit passed to LockDosList()
LDB_READ | Flag bit passed to LockDosList()
LDB_VOLUMES | Flag bit passed to LockDosList()
LDB_WRITE | Flag bit passed to LockDosList()
LDF_ALL | Flag value passed to LockDosList()
LDF_ASSIGNS | Flag value passed to LockDosList()
LDF_DELETE | Flag value passed to LockDosList()
LDF_DEVICES | Flag value passed to LockDosList()
LDF_ENTRY | Flag value passed to LockDosList()
LDF_READ | Flag valuepassed to LockDosList()
LDF_VOLUMES | Flag value passed to LockDosList()
LDF_WRITE | Flag value passed to LockDosList()
LEN_DATSTRING |
LINK_HARD | Value for MakeLink Hard link
LINK_SOFT | Value for MakeLink Soft link
LOCK_DIFFERENT | Value returned by SameLock
LOCK_SAME | Value returned by SameLock
LOCK_SAME_HANDLER | Value returned by SameLock
LOCK_SAME_VOLUME |
LVB_IGNORE | Bit Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar
LVF_IGNORE | Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar
LV_ALIAS | Bit Definition for TLocalVar.lv_Node.ln_Type defines an alias
LV_VAR | Bit Definition for TLocalVar.lv_Node.ln_Type defines a Variable
MAX_MULTIARGS | Maximum number of MULTIARG items returned by ReadArgs(), before an ERROR_LINE_TOO_LONG. These two limitations are due to stack usage. Applications should allow "a lot" of stack to use ReadArgs().
MAX_TEMPLATE_ITEMS | Maximum number of template keywords which can be in a template passed to ReadArgs(). Note: must be a multiple of 4.
MODE_NEWFILE | Parameter for DosOpen Create new file
MODE_OLDFILE | Parameter for DosOpen Open existing file read/write
MODE_READWRITE | Parameter for DosOpen Exclusive read/write file
NOTIFY_CLASS | NotifyMessage Class
NOTIFY_CODE | NotifyMessage Code
NP_Arguments | Tag for CreateNewProc pointer to argument string (Default empty string)
NP_Cli | Tag for CreateNewProc create a CLI structure for new process (Default False)
NP_CloseError | Tag for CreateNewProc close error output on exit (Default True)
NP_CloseInput | Tag for CreateNewProc Close Input on exit (Default True)
NP_CloseOutput | Tag for CreateNewProc Close Output on ext (Default True)
NP_CodeType |
NP_CommandName | Tag for CreateNewProc command name, valid only for CLI process
NP_ConsoleTask | Tag for CreateNewProc Pointer to console task (default same as host)
NP_CopyVars | Tag for CreateNewProc boolean to copy local vars to new process (Default True)
NP_CurrentDir | Tag for CreateNewProc Lock (default is host's current dir)
NP_Dummy | Tag for CreateNewProc start of tag range
NP_Entry | Tag for CreateNewProc Entry point to run - mutually exclusive with NP_Seglist
NP_Error | Tag for CreateNewProc error filehandle (Default NIL:)
NP_ExitCode | Tag for CreateNewProc code to be called on process exit.
NP_ExitData | Tag for CreateNewProc argument for NP_ExitCode (default nil)
NP_FreeSeglist | Tag for CreateNewProc free the seglist when program finished. (Default True)
NP_HomeDir | Tag for CreateNewProc home directory (Default current directory)
NP_Input | Tag for CreateNewProc input file handle (Default NIL:)
NP_Name | Tag for CreateNewProc Name for the process (Default New Process)
NP_NotifyOnDeath | Tag for CreateNewProc Inform the host when prcess died (Default False) (not working?)
NP_Output | Tag for CreateNewProc output filehandle (Default NIL:)
NP_Path | Tag for CreateNewProc Path, only valid if an CLI process (default copy of host's)
NP_PPCStackSize |
NP_PPC_Arg1 |
NP_PPC_Arg2 |
NP_PPC_Arg3 |
NP_PPC_Arg4 |
NP_PPC_Arg5 |
NP_PPC_Arg6 |
NP_PPC_Arg7 |
NP_PPC_Arg8 |
NP_Priority | Tag for CreateNewProc Priority for the new process (Default same as host application)
NP_Seglist | Tag for CreateNewProc seglist of code to run for the process
NP_SeglistArray |
NP_StackSize | Tag for CreateNewProc Stacksize for the programm (Default 4000)
NP_StartupMsg |
NP_Synchronous | Tag for CreateNewProc Do not return until process finished (Default False) (not working?)
NP_TaskMsgPort |
NP_UserData |
NP_WindowPtr | Tag for CreateNewProc Window pointer (default same as host)
NRB_MAGIC | Flag bit for TNotifyRequest.nr_Flags do not set or remove it! Only for use by handlers!
NRB_NOTIFY_INITIAL | Flag bit for TNotifyRequest.nr_Flags
NRB_SEND_MESSAGE | Flag bit for TNotifyRequest.nr_Flags
NRB_SEND_SIGNAL | Flag bit for TNotifyRequest.nr_Flags
NRB_WAIT_REPLY | Flag bit for TNotifyRequest.nr_Flags
NRF_MAGIC | Flag for TNotifyRequest.nr_Flags
NRF_NOTIFY_INITIAL | Flag for TNotifyRequest.nr_Flags
NRF_SEND_MESSAGE | Flag for TNotifyRequest.nr_Flags
NRF_SEND_SIGNAL | Flag for TNotifyRequest.nr_Flags
NRF_WAIT_REPLY | Flag for TNotifyRequest.nr_Flags
NR_HANDLER_FLAGS | Flag for TNotifyRequest.nr_Flags reserved for private use by the handler
OFFSET_BEGINING |
OFFSET_BEGINNING | Parameter for DosSeek Start seek from the beginning of file
OFFSET_CURRENT | Parameter for DosSeek Start the seek from the current position
OFFSET_END | Parameter for DosSeek Start the seek from the end of file
PRB_CLOSEERROR |
PRB_CLOSEINPUT | Flag bit for tProcess
PRB_CLOSEOUTPUT | Flag bit for tProcess
PRB_FREEARGS | Flag bit for tProcess
PRB_FREECLI | Flag bit for tProcess
PRB_FREECURRDIR | Flag bit for tProcess
PRB_FREESEGLIST | Flag bit for tProcess
PRF_CLOSEERROR |
PRF_CLOSEINPUT | Flag value for tProcess
PRF_CLOSEOUTPUT | Flag value for tProcess
PRF_FREEARGS | Flag value for tProcess
PRF_FREECLI | Flag value for tProcess
PRF_FREECURRDIR | Flag value for tProcess
PRF_FREESEGLIST | Flag value for tProcess
P_ANY | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_CLASS | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_NOT | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_NOTCLASS | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_NOTEND | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_OREND | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_ORNEXT | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_ORSTART | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_REPBEG | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_REPEND | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_SINGLE | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_STOP | Internal constants used by wildcard routines of MatchFirst and MatchNext
RDAB_NOALLOC | Flag bit for TRDArgs.RDA_Flags If set, do not allocate extra string space.
RDAB_NOPROMPT | Flag bit for TRDArgs.RDA_Flags Disable reprompting for string input.
RDAB_STDIN | Flag bit for TRDArgs.RDA_Flags use StdIn rather than command line
RDAF_NOALLOC | Flag value for TRDArgs.RDA_Flags If set, do not allocate extra string space.
RDAF_NOPROMPT | Flag value for TRDArgs.RDA_Flags Disable reprompting for string input.
RDAF_STDIN | Flag value for TRDArgs.RDA_Flags use StdIn rather than command line
REC_EXCLUSIVE | Mode for TRecordLock.rec_Mode
REC_EXCLUSIVE_IMMED | Mode for TRecordLock.rec_Mode
REC_SHARED | Mode for TRecordLock.rec_Mode
REC_SHARED_IMMED | Mode for TRecordLock.rec_Mode
REPORT_INSERT | Error report ""please inser volume" at ErrorReport()
REPORT_LOCK | Error report Lock at ErrorReport()
REPORT_STREAM | Error report stream at ErrorReport()
REPORT_TASK | Error report task at ErrorReport()
REPORT_VOLUME | Error report volume at ErrorReport()
RETURN_ERROR | Return Level error: errors occour can not finish
RETURN_FAIL | Return level Fail: something really bad happend
RETURN_OK | Return Level OK = no Problem, success
RETURN_WARN | Return level warn: some warnings appear
RNB_PRIVATE1 |
RNB_WILDSTAR |
RNF_PRIVATE1 |
RNF_WILDSTAR |
RUN_EXECUTE | Type for initial packets to shells from run/newcli/execute/system.
RUN_SYSTEM | Type for initial packets to shells from run/newcli/execute/system.
RUN_SYSTEM_ASYNCH | Type for initial packets to shells from run/newcli/execute/system.
SEGLISTTAG_DOS_SEGINDEX |
SEGLISTTAG_Dummy |
SEGLISTTAG_ELF_SEGADDRALIGN |
SEGLISTTAG_ELF_SEGFLAGS |
SEGLISTTAG_ELF_SEGINDEX |
SEGLISTTAG_ELF_SEGNAME |
SEGLISTTAG_ELF_SEGOFFSET |
SEGLISTTAG_ELF_SEGTYPE |
SEGLISTTAG_OBJDATA |
SEGLISTTAG_SEGLISTTYPE |
SEGLISTTAG_SEGSIZE |
SEGLISTTAG_SEGSTART |
SEGLISTTYPE_AMIGA |
SEGLISTTYPE_ELF |
SEGLISTTYPE_POWERUP |
SEG_SEM |
SHARED_LOCK | Parameter for Lock File is readable by others
SIGBREAKB_CTRL_C | Bit numbers that signal you that a user has issued a break
SIGBREAKB_CTRL_D | Bit numbers that signal you that a user has issued a break
SIGBREAKB_CTRL_E | Bit numbers that signal you that a user has issued a break
SIGBREAKB_CTRL_F | Bit numbers that signal you that a user has issued a break
SIGBREAKF_CTRL_C | Value that signal you that a user has issued a break
SIGBREAKF_CTRL_D | Value that signal you that a user has issued a break
SIGBREAKF_CTRL_E | Value that signal you that a user has issued a break
SIGBREAKF_CTRL_F | Value that signal you that a user has issued a break
ST_FILE | Type for TFileInfoBlock.fib_DirEntryType ordinary file
ST_LINKDIR | Type for TFileInfoBlock.fib_DirEntryType hard link to directory
ST_LINKFILE | Type for TFileInfoBlock.fib_DirEntryType hard link to file
ST_PIPEFILE | Type for TFileInfoBlock.fib_DirEntryType pipes support ExamineFH
ST_ROOT | Type for TFileInfoBlock.fib_DirEntryType root directory of a device
ST_SOFTLINK | Type for TFileInfoBlock.fib_DirEntryType looks like a dir, but may point to a file
ST_USERDIR | Type for TFileInfoBlock.fib_DirEntryType
SYS_Asynch | Tag for SystemTagList run the process asynchron, closes the input/output on exit
SYS_CustomShell | Tag for SystemTagList send to a specific shell (name)
SYS_Dummy | Tag for SystemTagList start of Tag range
SYS_FilterTags |
SYS_Input | Tag for SystemTagList specifies an input file handle
SYS_Output | Tag for SystemTagList specifies an output file handle
SYS_UserShell | Tag for SystemTagList send to user shell instead of boot shell
TICKS_PER_SECOND | Number of ticks per second. Defines the acuracy of your time
_MAXINT |
_MININT |


Reference for unit 'AmigaDOS': Types

LongInt |
LongInt |
PAChain |
PAnchorPath | Structure expected by MatchFirst, MatchNext to find Files.
PAssignList |
PCLIData |
PCLIDataItem |
PCliProcList |
PCommandLineInterface | DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them
PCSource | Pointer to Input structure for ReadItem and ReadArgs
PDateStamp | Pointer to a Date and Time representation
PDeviceList |
PDeviceNode | Pointer to Device node list
PDevInfo |
PDevProc | Structure return by GetDeviceProc()
PDosAttrBuffer |
PDosEnvec | Describes the disk geometry
PDOSInfo |
PDOSLibrary | This is how the base of dos.library looks like.
PDOSList |
PDOSPacket | This is the extension to EXEC Messages used by DOS
PErrorString | A structure for holding error messages - stored as array with error = 0 for the last entry.
PExAllControl | Control structure passed to ExAll().
PExAllData | Structure in which exall results are returned in.
PFileHandle | This pointer is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls
PFileInfoBlock | Pointer to a file information structure
PFileLock | Lock structure, as returned by Lock() or DupLock()
PFileSysStartupMsg | Pointer to filesystem startup message for a device
PInfoData | General Disk informatons from Info
PLocalVar | Pointer to a Localvars list
PNotifyMessage |
PNotifyRequest |
PProcess | All DOS processes have this structure
PRDArgs | Input parameter ReadArgs()
PRecordLock | Parameter for TRecordLock.rec_Mode
PRecordLock64 |
PRootNode |
PSegArray |
PSegment |
PSegNode |
PSegSem |
PStandardPacket |
TAChain |
TAnchorPath | Structure expected by MatchFirst, MatchNext to find Files.
TAssignList | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure used for multi-directory assigns.
TCLIData |
TCLIDataItem |
TCliProcList | Only to be allocated by DOS!
TCommandLineInterface | DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them
TCSource | Input structure for ReadItem and ReadArgs
TDateStamp | Date and Time representation
TDeviceList | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a volume.
TDeviceNode | Device node list DLT_DEVICE
TDevInfo | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a device
TDevProc | Structure return by GetDeviceProc()
TDosAttrBuffer |
TDosEnvec | Describes the disk geometry
TDOSInfo |
TDOSLibrary | This is how the base of dos.library looks like.
TDOSList | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure combined structure for devices, assigned directories, volumes.
TDOSPacket | This is the extension to EXEC Messages used by DOS
TErrorString | A structure for holding error messages - stored as array with error = 0 for the last entry.
TexAllControl | Control structure passed to ExAll().
TExAllData | Structure in which exall results are returned in. Note that only the fields asked for will exist!
TFileHandle | The pointer of this structure is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls
TFileInfoBlock | File information structure
TFileLock | Lock structure, as returned by Lock() or DupLock()
TFileSysStartupMsg | Filesystem startup message for a device
TInfoData | General Disk informatons from Info
TLocalVar | The structure in the TProcess.pr_LocalVars list
TNotifyMessage |
TNotifyRequest |
TProcess | All DOS processes have this structure
TRDArgs | Input parameter structure used in ReadArgs()
TRecordLock | Parameter struct for TRecordLock.rec_Mode
TRecordLock64 |
TRootNode |
TSegArray |
TSegment |
TSegNode |
TSegSem |
TStandardPacket |
_PDateTime |
_TDateTime |


ITEM_EQUAL

Declaration

Source position: amigados.pas line 268

const ITEM_EQUAL = - 2;


ITEM_ERROR

Declaration

Source position: amigados.pas line 269

const ITEM_ERROR = - 1;


ITEM_NOTHING

Declaration

Source position: amigados.pas line 270

const ITEM_NOTHING = 0;


ITEM_QUOTED

Declaration

Source position: amigados.pas line 272

const ITEM_QUOTED = 2;


ITEM_UNQUOTED

Declaration

Source position: amigados.pas line 271

const ITEM_UNQUOTED = 1;


LDB_ASSIGNS

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 769

const LDB_ASSIGNS = 4;


LDB_DELETE

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 775

const LDB_DELETE = 6;


LDB_DEVICES

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 763

const LDB_DEVICES = 2;


LDB_ENTRY

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 772

const LDB_ENTRY = 5;


LDB_READ

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 757

const LDB_READ = 0;


LDB_VOLUMES

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 766

const LDB_VOLUMES = 3;


LDB_WRITE

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 760

const LDB_WRITE = 1;


LDF_ALL

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 778

const LDF_ALL = LDF_DEVICES or LDF_VOLUMES or LDF_ASSIGNS;


LDF_ASSIGNS

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 770

const LDF_ASSIGNS = 1 shl LDB_ASSIGNS;


LDF_DELETE

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 776

const LDF_DELETE = 1 shl LDB_DELETE;


LDF_DEVICES

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 764

const LDF_DEVICES = 1 shl LDB_DEVICES;


LDF_ENTRY

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 773

const LDF_ENTRY = 1 shl LDB_ENTRY;


LDF_READ

Flag valuepassed to LockDosList()

Declaration

Source position: amigados.pas line 758

const LDF_READ = 1 shl LDB_READ;


LDF_VOLUMES

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 767

const LDF_VOLUMES = 1 shl LDB_VOLUMES;


LDF_WRITE

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 761

const LDF_WRITE = 1 shl LDB_WRITE;


LEN_DATSTRING

Declaration

Source position: amigados.pas line 306

const LEN_DATSTRING = 16;


LINK_HARD

Value for MakeLink Hard link

Declaration

Source position: amigados.pas line 264

const LINK_HARD = 0;


LINK_SOFT

Value for MakeLink Soft link

Declaration

Source position: amigados.pas line 265

const LINK_SOFT = 1;


LV_ALIAS

Bit Definition for TLocalVar.lv_Node.ln_Type defines an alias

Declaration

Source position: amigados.pas line 1378

const LV_ALIAS = 1;


LV_VAR

Bit Definition for TLocalVar.lv_Node.ln_Type defines a Variable

Declaration

Source position: amigados.pas line 1377

const LV_VAR = 0;


LVB_IGNORE

Bit Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar

Declaration

Source position: amigados.pas line 1381

const LVB_IGNORE = 7;


LVF_IGNORE

Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar

Declaration

Source position: amigados.pas line 1382

const LVF_IGNORE = 1 shl LVB_IGNORE;


MAX_MULTIARGS

Maximum number of MULTIARG items returned by ReadArgs(), before an ERROR_LINE_TOO_LONG. These two limitations are due to stack usage. Applications should allow "a lot" of stack to use ReadArgs().

Declaration

Source position: amigados.pas line 1438

const MAX_MULTIARGS = 128;


MAX_TEMPLATE_ITEMS

Maximum number of template keywords which can be in a template passed to ReadArgs(). Note: must be a multiple of 4.

Declaration

Source position: amigados.pas line 1437

const MAX_TEMPLATE_ITEMS = 100;


MODE_NEWFILE

Parameter for DosOpen Create new file

Declaration

Source position: amigados.pas line 45

const MODE_NEWFILE = 1006;

Description

Create a new file an open it, if the file already exists it will be deleted and a new empty file is created.

See also

DosOpen

Open a file for input or output


MODE_OLDFILE

Parameter for DosOpen Open existing file read/write

Declaration

Source position: amigados.pas line 44

const MODE_OLDFILE = 1005;

Description

Open existing file read/write and set file position to beginning of file. Other programs can still access this file. (e.g. shared reading)

See also

DosOpen

Open a file for input or output


MODE_READWRITE

Parameter for DosOpen Exclusive read/write file

Declaration

Source position: amigados.pas line 46

const MODE_READWRITE = 1004;

Description

Open old file and lock it that noone else can open it as long as it is open.

See also

DosOpen

Open a file for input or output


NOTIFY_CLASS

NotifyMessage Class

Declaration

Source position: amigados.pas line 1530

const NOTIFY_CLASS = $40000000;


NOTIFY_CODE

NotifyMessage Code

Declaration

Source position: amigados.pas line 1531

const NOTIFY_CODE = $1234;


NP_Arguments

Tag for CreateNewProc pointer to argument string (Default empty string)

Declaration

Source position: amigados.pas line 1156

const NP_Arguments = NP_Dummy + 21;


NP_Cli

Tag for CreateNewProc create a CLI structure for new process (Default False)

Declaration

Source position: amigados.pas line 1153

const NP_Cli = NP_Dummy + 18;


NP_CloseError

Tag for CreateNewProc close error output on exit (Default True)

Declaration

Source position: amigados.pas line 1144

const NP_CloseError = NP_Dummy + 9;


NP_CloseInput

Tag for CreateNewProc Close Input on exit (Default True)

Declaration

Source position: amigados.pas line 1141

const NP_CloseInput = NP_Dummy + 6;


NP_CloseOutput

Tag for CreateNewProc Close Output on ext (Default True)

Declaration

Source position: amigados.pas line 1142

const NP_CloseOutput = NP_Dummy + 7;


NP_CodeType

Declaration

Source position: amigados.pas line 1169

const NP_CodeType = NP_Dummy + 100;


NP_CommandName

Tag for CreateNewProc command name, valid only for CLI process

Declaration

Source position: amigados.pas line 1155

const NP_CommandName = NP_Dummy + 20;


NP_ConsoleTask

Tag for CreateNewProc Pointer to console task (default same as host)

Declaration

Source position: amigados.pas line 1149

const NP_ConsoleTask = NP_Dummy + 14;


NP_CopyVars

Tag for CreateNewProc boolean to copy local vars to new process (Default True)

Declaration

Source position: amigados.pas line 1152

const NP_CopyVars = NP_Dummy + 17;


NP_CurrentDir

Tag for CreateNewProc Lock (default is host's current dir)

Declaration

Source position: amigados.pas line 1145

const NP_CurrentDir = NP_Dummy + 10;


NP_Dummy

Tag for CreateNewProc start of tag range

Declaration

Source position: amigados.pas line 1135

const NP_Dummy = TAG_USER + 1000;


NP_Entry

Tag for CreateNewProc Entry point to run - mutually exclusive with NP_Seglist

Declaration

Source position: amigados.pas line 1138

const NP_Entry = NP_Dummy + 3;


NP_Error

Tag for CreateNewProc error filehandle (Default NIL:)

Declaration

Source position: amigados.pas line 1143

const NP_Error = NP_Dummy + 8;


NP_ExitCode

Tag for CreateNewProc code to be called on process exit.

Declaration

Source position: amigados.pas line 1160

const NP_ExitCode = NP_Dummy + 24;


NP_ExitData

Tag for CreateNewProc argument for NP_ExitCode (default nil)

Declaration

Source position: amigados.pas line 1161

const NP_ExitData = NP_Dummy + 25;


NP_FreeSeglist

Tag for CreateNewProc free the seglist when program finished. (Default True)

Declaration

Source position: amigados.pas line 1137

const NP_FreeSeglist = NP_Dummy + 2;


NP_HomeDir

Tag for CreateNewProc home directory (Default current directory)

Declaration

Source position: amigados.pas line 1151

const NP_HomeDir = NP_Dummy + 16;


NP_Input

Tag for CreateNewProc input file handle (Default NIL:)

Declaration

Source position: amigados.pas line 1139

const NP_Input = NP_Dummy + 4;


NP_Name

Tag for CreateNewProc Name for the process (Default New Process)

Declaration

Source position: amigados.pas line 1147

const NP_Name = NP_Dummy + 12;


NP_NotifyOnDeath

Tag for CreateNewProc Inform the host when prcess died (Default False) (not working?)

Declaration

Source position: amigados.pas line 1158

const NP_NotifyOnDeath = NP_Dummy + 22;


NP_Output

Tag for CreateNewProc output filehandle (Default NIL:)

Declaration

Source position: amigados.pas line 1140

const NP_Output = NP_Dummy + 5;


NP_Path

Tag for CreateNewProc Path, only valid if an CLI process (default copy of host's)

Declaration

Source position: amigados.pas line 1154

const NP_Path = NP_Dummy + 19;


NP_PPC_Arg1

Declaration

Source position: amigados.pas line 1170

const NP_PPC_Arg1 = NP_Dummy + 101;


NP_PPC_Arg2

Declaration

Source position: amigados.pas line 1171

const NP_PPC_Arg2 = NP_Dummy + 102;


NP_PPC_Arg3

Declaration

Source position: amigados.pas line 1172

const NP_PPC_Arg3 = NP_Dummy + 103;


NP_PPC_Arg4

Declaration

Source position: amigados.pas line 1173

const NP_PPC_Arg4 = NP_Dummy + 104;


NP_PPC_Arg5

Declaration

Source position: amigados.pas line 1174

const NP_PPC_Arg5 = NP_Dummy + 105;


NP_PPC_Arg6

Declaration

Source position: amigados.pas line 1175

const NP_PPC_Arg6 = NP_Dummy + 106;


NP_PPC_Arg7

Declaration

Source position: amigados.pas line 1176

const NP_PPC_Arg7 = NP_Dummy + 107;


NP_PPC_Arg8

Declaration

Source position: amigados.pas line 1177

const NP_PPC_Arg8 = NP_Dummy + 108;


NP_PPCStackSize

Declaration

Source position: amigados.pas line 1178

const NP_PPCStackSize = NP_Dummy + 109;


NP_Priority

Tag for CreateNewProc Priority for the new process (Default same as host application)

Declaration

Source position: amigados.pas line 1148

const NP_Priority = NP_Dummy + 13;


NP_Seglist

Tag for CreateNewProc seglist of code to run for the process

Declaration

Source position: amigados.pas line 1136

const NP_Seglist = NP_Dummy + 1;


NP_SeglistArray

Declaration

Source position: amigados.pas line 1164

const NP_SeglistArray = NP_Dummy + 26;


NP_StackSize

Tag for CreateNewProc Stacksize for the programm (Default 4000)

Declaration

Source position: amigados.pas line 1146

const NP_StackSize = NP_Dummy + 11;


NP_StartupMsg

Declaration

Source position: amigados.pas line 1166

const NP_StartupMsg = NP_Dummy + 28;


NP_Synchronous

Tag for CreateNewProc Do not return until process finished (Default False) (not working?)

Declaration

Source position: amigados.pas line 1159

const NP_Synchronous = NP_Dummy + 23;


NP_TaskMsgPort

Declaration

Source position: amigados.pas line 1167

const NP_TaskMsgPort = NP_Dummy + 29;


NP_UserData

Declaration

Source position: amigados.pas line 1165

const NP_UserData = NP_Dummy + 27;


NP_WindowPtr

Tag for CreateNewProc Window pointer (default same as host)

Declaration

Source position: amigados.pas line 1150

const NP_WindowPtr = NP_Dummy + 15;


NR_HANDLER_FLAGS

Flag for TNotifyRequest.nr_Flags reserved for private use by the handler

Declaration

Source position: amigados.pas line 1586

const NR_HANDLER_FLAGS = $ffff0000;


NRB_MAGIC

Flag bit for TNotifyRequest.nr_Flags do not set or remove it! Only for use by handlers!

Declaration

Source position: amigados.pas line 1575

const NRB_MAGIC = 31;


NRB_NOTIFY_INITIAL

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1573

const NRB_NOTIFY_INITIAL = 4;


NRB_SEND_MESSAGE

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1570

const NRB_SEND_MESSAGE = 0;


NRB_SEND_SIGNAL

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1571

const NRB_SEND_SIGNAL = 1;


NRB_WAIT_REPLY

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1572

const NRB_WAIT_REPLY = 3;


NRF_MAGIC

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1583

const NRF_MAGIC = 1 shl NRB_MAGIC;


NRF_NOTIFY_INITIAL

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1581

const NRF_NOTIFY_INITIAL = 1 shl NRB_NOTIFY_INITIAL;


NRF_SEND_MESSAGE

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1578

const NRF_SEND_MESSAGE = 1 shl NRB_SEND_MESSAGE;


NRF_SEND_SIGNAL

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1579

const NRF_SEND_SIGNAL = 1 shl NRB_SEND_SIGNAL;


NRF_WAIT_REPLY

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1580

const NRF_WAIT_REPLY = 1 shl NRB_WAIT_REPLY;


OFFSET_BEGINING

Declaration

Source position: amigados.pas line 52

const OFFSET_BEGINING = OFFSET_BEGINNING;


OFFSET_BEGINNING

Parameter for DosSeek Start seek from the beginning of file

Declaration

Source position: amigados.pas line 49

const OFFSET_BEGINNING = - 1;

See also

DosSeek

Set the current position for reading and writing


OFFSET_CURRENT

Parameter for DosSeek Start the seek from the current position

Declaration

Source position: amigados.pas line 50

const OFFSET_CURRENT = 0;

See also

DosSeek

Set the current position for reading and writing


OFFSET_END

Parameter for DosSeek Start the seek from the end of file

Declaration

Source position: amigados.pas line 51

const OFFSET_END = 1;

See also

DosSeek

Set the current position for reading and writing


P_ANY

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 939

const P_ANY = $80;


P_CLASS

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 947

const P_CLASS = $88;


P_NOT

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 944

const P_NOT = $85;


P_NOTCLASS

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 946

const P_NOTCLASS = $87;


P_NOTEND

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 945

const P_NOTEND = $86;


P_OREND

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 943

const P_OREND = $84;


P_ORNEXT

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 942

const P_ORNEXT = $83;


P_ORSTART

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 941

const P_ORSTART = $82;


P_REPBEG

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 948

const P_REPBEG = $89;


P_REPEND

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 949

const P_REPEND = $8A;


P_SINGLE

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 940

const P_SINGLE = $81;


P_STOP

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 950

const P_STOP = $8B;


PAChain

Declaration

Source position: amigados.pas line 843

type PAChain = ^TAChain;


PAnchorPath

Structure expected by MatchFirst, MatchNext to find Files.

Declaration

Source position: amigados.pas line 855

type PAnchorPath = ^TAnchorPath;

Description

To search for files call MatchFirst() and then afterwards, MatchNext() with this structure. You should check the return value each time and take the appropriate action, ultimately calling MatchEnd() when there are no more files and you are done. You can tell when you are done by checking for the normal DOS return code ERROR_NO_MORE_ENTRIES.

See also

MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()


PAssignList

Declaration

Source position: amigados.pas line 686

type PAssignList = ^TAssignList;


PCLIData

Declaration

Source position: amigados.pas line 833

type PCLIData = ^TCLIData;


PCLIDataItem

Declaration

Source position: amigados.pas line 827

type PCLIDataItem = ^TCLIDataItem;


PCliProcList

Declaration

Source position: amigados.pas line 592

type PCliProcList = ^TCliProcList;


PCommandLineInterface

DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them

Declaration

Source position: amigados.pas line 635

type PCommandLineInterface = ^TCommandLineInterface;


PCSource

Pointer to Input structure for ReadItem and ReadArgs

Declaration

Source position: amigados.pas line 1407

type PCSource = ^TCSource;


PDateStamp

Pointer to a Date and Time representation

Declaration

Source position: amigados.pas line 69

type PDateStamp = ^TDateStamp;


PDeviceList

Declaration

Source position: amigados.pas line 656

type PDeviceList = ^TDeviceList;


PDeviceNode

Pointer to Device node list

Declaration

Source position: amigados.pas line 1507

type PDeviceNode = ^TDeviceNode;


PDevInfo

Declaration

Source position: amigados.pas line 670

type PDevInfo = ^TDevInfo;


PDevProc

Structure return by GetDeviceProc()

Declaration

Source position: amigados.pas line 737

type PDevProc = ^TDevProc;


PDosAttrBuffer

Declaration

Source position: amigados.pas line 1291

type PDosAttrBuffer = ^TDosAttrBuffer;


PDosEnvec

Describes the disk geometry

Declaration

Source position: amigados.pas line 1448

type PDosEnvec = ^TDosEnvec;


PDOSInfo

Declaration

Source position: amigados.pas line 600

type PDOSInfo = ^TDOSInfo;


PDOSLibrary

This is how the base of dos.library looks like.

Declaration

Source position: amigados.pas line 568

type PDOSLibrary = ^TDOSLibrary;


PDOSList

Declaration

Source position: amigados.pas line 693

type PDOSList = ^TDOSList;


PDOSPacket

This is the extension to EXEC Messages used by DOS

Declaration

Source position: amigados.pas line 410

type PDOSPacket = ^TDOSPacket;


PErrorString

A structure for holding error messages - stored as array with error = 0 for the last entry.

Declaration

Source position: amigados.pas line 546

type PErrorString = ^TErrorString;


PExAllControl

Control structure passed to ExAll().

Declaration

Source position: amigados.pas line 1076

type PExAllControl = ^TExAllControl;


PExAllData

Structure in which exall results are returned in.

Declaration

Source position: amigados.pas line 1059

type PExAllData = ^TExAllData;


PFileHandle

This pointer is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls

Declaration

Source position: amigados.pas line 384

type PFileHandle = ^TFileHandle;


PFileInfoBlock

Pointer to a file information structure

Declaration

Source position: amigados.pas line 81

type PFileInfoBlock = ^TFileInfoBlock;

See also

Examine | Examine a directory or file associated with a lock
Examine64 | Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock.


PFileLock

Lock structure, as returned by Lock() or DupLock()

Declaration

Source position: amigados.pas line 782

type PFileLock = ^TFileLock;


PFileSysStartupMsg

Pointer to filesystem startup message for a device

Declaration

Source position: amigados.pas line 1498

type PFileSysStartupMsg = ^TFileSysStartupMsg;


PInfoData

General Disk informatons from Info

Declaration

Source position: amigados.pas line 150

type PInfoData = ^TInfoData;


PLocalVar

Pointer to a Localvars list

Declaration

Source position: amigados.pas line 1367

type PLocalVar = ^TLocalVar;


PNotifyMessage

Declaration

Source position: amigados.pas line 1558

type PNotifyMessage = ^TNotifyMessage;


PNotifyRequest

Declaration

Source position: amigados.pas line 1535

type PNotifyRequest = ^TNotifyRequest;


PProcess

All DOS processes have this structure

Declaration

Source position: amigados.pas line 330

type PProcess = ^TProcess;


PRB_CLOSEERROR

Declaration

Source position: amigados.pas line 379

const PRB_CLOSEERROR = 6;


PRB_CLOSEINPUT

Flag bit for tProcess

Declaration

Source position: amigados.pas line 370

const PRB_CLOSEINPUT = 3;


PRB_CLOSEOUTPUT

Flag bit for tProcess

Declaration

Source position: amigados.pas line 373

const PRB_CLOSEOUTPUT = 4;


PRB_FREEARGS

Flag bit for tProcess

Declaration

Source position: amigados.pas line 376

const PRB_FREEARGS = 5;


PRB_FREECLI

Flag bit for tProcess

Declaration

Source position: amigados.pas line 367

const PRB_FREECLI = 2;


PRB_FREECURRDIR

Flag bit for tProcess

Declaration

Source position: amigados.pas line 364

const PRB_FREECURRDIR = 1;


PRB_FREESEGLIST

Flag bit for tProcess

Declaration

Source position: amigados.pas line 361

const PRB_FREESEGLIST = 0;


PRDArgs

Input parameter ReadArgs()

Declaration

Source position: amigados.pas line 1415

type PRDArgs = ^TRDArgs;


PRecordLock

Parameter for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 1100

type PRecordLock = ^TRecordLock;


PRecordLock64

Declaration

Source position: amigados.pas line 1109

type PRecordLock64 = ^TRecordLock64;


PRF_CLOSEERROR

Declaration

Source position: amigados.pas line 380

const PRF_CLOSEERROR = 1 shl PRB_CLOSEERROR;


PRF_CLOSEINPUT

Flag value for tProcess

Declaration

Source position: amigados.pas line 371

const PRF_CLOSEINPUT = 1 shl PRB_CLOSEINPUT;


PRF_CLOSEOUTPUT

Flag value for tProcess

Declaration

Source position: amigados.pas line 374

const PRF_CLOSEOUTPUT = 1 shl PRB_CLOSEOUTPUT;


PRF_FREEARGS

Flag value for tProcess

Declaration

Source position: amigados.pas line 377

const PRF_FREEARGS = 1 shl PRB_FREEARGS;


PRF_FREECLI

Flag value for tProcess

Declaration

Source position: amigados.pas line 368

const PRF_FREECLI = 1 shl PRB_FREECLI;


PRF_FREECURRDIR

Flag value for tProcess

Declaration

Source position: amigados.pas line 365

const PRF_FREECURRDIR = 1 shl PRB_FREECURRDIR;


PRF_FREESEGLIST

Flag value for tProcess

Declaration

Source position: amigados.pas line 362

const PRF_FREESEGLIST = 1 shl PRB_FREESEGLIST;


PRootNode

Declaration

Source position: amigados.pas line 553

type PRootNode = ^TRootNode;


PSegArray

Declaration

Source position: amigados.pas line 1608

type PSegArray = ^TSegArray;


PSegment

Declaration

Source position: amigados.pas line 617

type PSegment = ^TSegment;


PSegNode

Declaration

Source position: amigados.pas line 1615

type PSegNode = ^TSegNode;


PSegSem

Declaration

Source position: amigados.pas line 1600

type PSegSem = ^TSegSem;


PStandardPacket

Declaration

Source position: amigados.pas line 434

type PStandardPacket = ^TStandardPacket;


RDAB_NOALLOC

Flag bit for TRDArgs.RDA_Flags If set, do not allocate extra string space.

Declaration

Source position: amigados.pas line 1430

const RDAB_NOALLOC = 1;


RDAB_NOPROMPT

Flag bit for TRDArgs.RDA_Flags Disable reprompting for string input.

Declaration

Source position: amigados.pas line 1433

const RDAB_NOPROMPT = 2;


RDAB_STDIN

Flag bit for TRDArgs.RDA_Flags use StdIn rather than command line

Declaration

Source position: amigados.pas line 1427

const RDAB_STDIN = 0;


RDAF_NOALLOC

Flag value for TRDArgs.RDA_Flags If set, do not allocate extra string space.

Declaration

Source position: amigados.pas line 1431

const RDAF_NOALLOC = 1 shl RDAB_NOALLOC;


RDAF_NOPROMPT

Flag value for TRDArgs.RDA_Flags Disable reprompting for string input.

Declaration

Source position: amigados.pas line 1434

const RDAF_NOPROMPT = 1 shl RDAB_NOPROMPT;


RDAF_STDIN

Flag value for TRDArgs.RDA_Flags use StdIn rather than command line

Declaration

Source position: amigados.pas line 1428

const RDAF_STDIN = 1 shl RDAB_STDIN;


REC_EXCLUSIVE

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 1093

const REC_EXCLUSIVE = 0;


REC_EXCLUSIVE_IMMED

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 1094

const REC_EXCLUSIVE_IMMED = 1;


REC_SHARED

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 1095

const REC_SHARED = 2;


REC_SHARED_IMMED

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 1096

const REC_SHARED_IMMED = 3;


REPORT_INSERT

Error report ""please inser volume" at ErrorReport()

Declaration

Source position: amigados.pas line 797

const REPORT_INSERT = 4;


REPORT_LOCK

Error report Lock at ErrorReport()

Declaration

Source position: amigados.pas line 795

const REPORT_LOCK = 2;


REPORT_STREAM

Error report stream at ErrorReport()

Declaration

Source position: amigados.pas line 793

const REPORT_STREAM = 0;


REPORT_TASK

Error report task at ErrorReport()

Declaration

Source position: amigados.pas line 794

const REPORT_TASK = 1;


REPORT_VOLUME

Error report volume at ErrorReport()

Declaration

Source position: amigados.pas line 796

const REPORT_VOLUME = 3;


RETURN_ERROR

Return Level error: errors occour can not finish

Declaration

Source position: amigados.pas line 239

const RETURN_ERROR = 10;


RETURN_FAIL

Return level Fail: something really bad happend

Declaration

Source position: amigados.pas line 240

const RETURN_FAIL = 20;


RETURN_OK

Return Level OK = no Problem, success

Declaration

Source position: amigados.pas line 237

const RETURN_OK = 0;


RETURN_WARN

Return level warn: some warnings appear

Declaration

Source position: amigados.pas line 238

const RETURN_WARN = 5;


RNB_PRIVATE1

Declaration

Source position: amigados.pas line 587

const RNB_PRIVATE1 = 1;


RNB_WILDSTAR

Declaration

Source position: amigados.pas line 584

const RNB_WILDSTAR = 24;


RNF_PRIVATE1

Declaration

Source position: amigados.pas line 588

const RNF_PRIVATE1 = 1 shl RNB_PRIVATE1;


RNF_WILDSTAR

Declaration

Source position: amigados.pas line 585

const RNF_WILDSTAR = 1 shl RNB_WILDSTAR;


RUN_EXECUTE

Type for initial packets to shells from run/newcli/execute/system.

Declaration

Source position: amigados.pas line 804

const RUN_EXECUTE = - 1;


RUN_SYSTEM

Type for initial packets to shells from run/newcli/execute/system.

Declaration

Source position: amigados.pas line 805

const RUN_SYSTEM = - 2;


RUN_SYSTEM_ASYNCH

Type for initial packets to shells from run/newcli/execute/system.

Declaration

Source position: amigados.pas line 806

const RUN_SYSTEM_ASYNCH = - 3;


SEG_SEM

Declaration

Source position: amigados.pas line 1596

const SEG_SEM = 'SegTracker';


SEGLISTTAG_DOS_SEGINDEX

Declaration

Source position: amigados.pas line 1322

const SEGLISTTAG_DOS_SEGINDEX = SEGLISTTAG_Dummy + $3;


SEGLISTTAG_Dummy

Declaration

Source position: amigados.pas line 1317

const SEGLISTTAG_Dummy = TAG_USER + 3400;


SEGLISTTAG_ELF_SEGADDRALIGN

Declaration

Source position: amigados.pas line 1331

const SEGLISTTAG_ELF_SEGADDRALIGN = SEGLISTTAG_Dummy + $a;


SEGLISTTAG_ELF_SEGFLAGS

Declaration

Source position: amigados.pas line 1330

const SEGLISTTAG_ELF_SEGFLAGS = SEGLISTTAG_Dummy + $9;


SEGLISTTAG_ELF_SEGINDEX

Declaration

Source position: amigados.pas line 1323

const SEGLISTTAG_ELF_SEGINDEX = SEGLISTTAG_Dummy + $4;


SEGLISTTAG_ELF_SEGNAME

Declaration

Source position: amigados.pas line 1332

const SEGLISTTAG_ELF_SEGNAME = SEGLISTTAG_Dummy + $b;


SEGLISTTAG_ELF_SEGOFFSET

Declaration

Source position: amigados.pas line 1329

const SEGLISTTAG_ELF_SEGOFFSET = SEGLISTTAG_Dummy + $8;


SEGLISTTAG_ELF_SEGTYPE

Declaration

Source position: amigados.pas line 1328

const SEGLISTTAG_ELF_SEGTYPE = SEGLISTTAG_Dummy + $7;


SEGLISTTAG_OBJDATA

Declaration

Source position: amigados.pas line 1319

const SEGLISTTAG_OBJDATA = SEGLISTTAG_Dummy + $1;


SEGLISTTAG_SEGLISTTYPE

Declaration

Source position: amigados.pas line 1321

const SEGLISTTAG_SEGLISTTYPE = SEGLISTTAG_Dummy + $2;


SEGLISTTAG_SEGSIZE

Declaration

Source position: amigados.pas line 1326

const SEGLISTTAG_SEGSIZE = SEGLISTTAG_Dummy + $6;


SEGLISTTAG_SEGSTART

Declaration

Source position: amigados.pas line 1324

const SEGLISTTAG_SEGSTART = SEGLISTTAG_Dummy + $5;


SEGLISTTYPE_AMIGA

Declaration

Source position: amigados.pas line 1338

const SEGLISTTYPE_AMIGA = 3;


SEGLISTTYPE_ELF

Declaration

Source position: amigados.pas line 1336

const SEGLISTTYPE_ELF = 1;


SEGLISTTYPE_POWERUP

Declaration

Source position: amigados.pas line 1337

const SEGLISTTYPE_POWERUP = 2;


SHARED_LOCK

Parameter for Lock File is readable by others

Declaration

Source position: amigados.pas line 62

const SHARED_LOCK = - 2;


SIGBREAKB_CTRL_C

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 243

const SIGBREAKB_CTRL_C = 12;


SIGBREAKB_CTRL_D

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 244

const SIGBREAKB_CTRL_D = 13;


SIGBREAKB_CTRL_E

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 245

const SIGBREAKB_CTRL_E = 14;


SIGBREAKB_CTRL_F

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 246

const SIGBREAKB_CTRL_F = 15;


SIGBREAKF_CTRL_C

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 248

const SIGBREAKF_CTRL_C = 1 shl SIGBREAKB_CTRL_C;


SIGBREAKF_CTRL_D

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 249

const SIGBREAKF_CTRL_D = 1 shl SIGBREAKB_CTRL_D;


SIGBREAKF_CTRL_E

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 250

const SIGBREAKF_CTRL_E = 1 shl SIGBREAKB_CTRL_E;


SIGBREAKF_CTRL_F

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 251

const SIGBREAKF_CTRL_F = 1 shl SIGBREAKB_CTRL_F;


ST_FILE

Type for TFileInfoBlock.fib_DirEntryType ordinary file

Declaration

Source position: amigados.pas line 813

const ST_FILE = - 3;


ST_LINKDIR

Type for TFileInfoBlock.fib_DirEntryType hard link to directory

Declaration

Source position: amigados.pas line 812

const ST_LINKDIR = 4;


ST_LINKFILE

Type for TFileInfoBlock.fib_DirEntryType hard link to file

Declaration

Source position: amigados.pas line 814

const ST_LINKFILE = - 4;


ST_PIPEFILE

Type for TFileInfoBlock.fib_DirEntryType pipes support ExamineFH

Declaration

Source position: amigados.pas line 815

const ST_PIPEFILE = - 5;


ST_ROOT

Type for TFileInfoBlock.fib_DirEntryType root directory of a device

Declaration

Source position: amigados.pas line 809

const ST_ROOT = 1;


ST_SOFTLINK

Type for TFileInfoBlock.fib_DirEntryType looks like a dir, but may point to a file

Declaration

Source position: amigados.pas line 811

const ST_SOFTLINK = 3;


ST_USERDIR

Type for TFileInfoBlock.fib_DirEntryType

Declaration

Source position: amigados.pas line 810

const ST_USERDIR = 2;


SYS_Asynch

Tag for SystemTagList run the process asynchron, closes the input/output on exit

Declaration

Source position: amigados.pas line 1127

const SYS_Asynch = SYS_Dummy + 3;


SYS_CustomShell

Tag for SystemTagList send to a specific shell (name)

Declaration

Source position: amigados.pas line 1129

const SYS_CustomShell = SYS_Dummy + 5;


SYS_Dummy

Tag for SystemTagList start of Tag range

Declaration

Source position: amigados.pas line 1124

const SYS_Dummy = TAG_USER + 32;


SYS_FilterTags

Declaration

Source position: amigados.pas line 1132

const SYS_FilterTags = SYS_Dummy + 6;


SYS_Input

Tag for SystemTagList specifies an input file handle

Declaration

Source position: amigados.pas line 1125

const SYS_Input = SYS_Dummy + 1;


SYS_Output

Tag for SystemTagList specifies an output file handle

Declaration

Source position: amigados.pas line 1126

const SYS_Output = SYS_Dummy + 2;


SYS_UserShell

Tag for SystemTagList send to user shell instead of boot shell

Declaration

Source position: amigados.pas line 1128

const SYS_UserShell = SYS_Dummy + 4;


TAChain

Declaration

Source position: amigados.pas line 844

type TAChain = packed record

  an_Child: PAChain;

  an_Parent: PAChain;

  an_Lock: LongInt;

  an_Info: TFileInfoBlock;

  an_Flags: ShortInt;

  an_String: array [0..0] of Char;

end;


TAnchorPath

Structure expected by MatchFirst, MatchNext to find Files.

Declaration

Source position: amigados.pas line 856

type TAnchorPath = packed record
case Byte of
0: (
ap_First: PAChain; | Pointer to first anchor
ap_Last: PAChain; | Pointer to last anchor
ap_BreakBits_1: LongInt; |
ap_FoundBreak_1: LongInt; |
ap_Length: ShortInt; |
ap_Extended: ShortInt; |
);
1: (
ap_Base: PAChain; |
ap_Current: PAChain; |
ap_BreakBits: LongInt; | Bits we want to break on (DDF_*)
ap_FoundBreak: LongInt; | Bits we broke on. Also returns ERROR_BREAK
ap_Flags: ShortInt; | Extra flags
ap_Reserved: ShortInt; |
ap_Strlen: SmallInt; | This is what ap_Length used to be
ap_Info: TFileInfoBlock; | Info block of the found file
ap_Buf: array [0..1] of Char; | Buffer start for full path output
);
end;

Description

Allocate this structure and initialize it as follows:

Set ap_BreakBits to the signal bits (DDB) that you want to take a break on, or nil, if you don't want to convenience the user.

If you want to have the full path name of the files you found, allocate a buffer at the end of this structure, and put the size of it into ap_Strlen. If you don't want the full path name, make sure you set ap_Strlen to 0. In this case, the name of the file, and stats are available in the ap_Info, as per usual.

Then call MatchFirst() and then afterwards, MatchNext() with this structure. You should check the return value each time and take the appropriate action, ultimately calling MatchEnd() when there are no more files and you are done. You can tell when you are done by checking for the normal DOS return code ERROR_NO_MORE_ENTRIES.

See also

MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()


TAssignList

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure used for multi-directory assigns.

Declaration

Source position: amigados.pas line 687

type TAssignList = packed record

  al_Next: PAssignList;

  al_Lock: LongInt;

end;


TCLIData

Declaration

Source position: amigados.pas line 829

type TCLIData = record

  cd_NumCLIs: LongWord;

  cd_CLI: array [0..100] of PCLIDataItem;

end;


TCLIDataItem

Declaration

Source position: amigados.pas line 818

type TCLIDataItem = record

  cdi_CLINum: LongInt;

  cdi_DefaultStack: LongInt;

  cdi_GlobVec: LongInt;

  cdi_Future: LongWord;

  cdi_Pri: ShortInt;

  cdi_Flags: Byte;

  cdi_Command: array [0..0] of Char;

end;


TCliProcList

Only to be allocated by DOS!

Declaration

Source position: amigados.pas line 593

type TCliProcList = packed record
cpl_Node: TMinNode; |
cpl_First: LongInt; | number of first entry in array
cpl_Array: array [0..0] of PMsgPort; | [0] is max number of CLI's in this entry (n), [1] is CPTR to process id of CLI cpl_First, [n] is CPTR to process id of CLI cpl_First+n-1
end;


TCommandLineInterface

DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them

Declaration

Source position: amigados.pas line 636

type TCommandLineInterface = packed record
cli_Result2: LongInt; | Value of IoErr from last command
cli_SetName: LongInt; | Name of current directory
cli_CommandDir: LongInt; | Lock associated with command directory
cli_ReturnCode: LongInt; | Return code from last command
cli_CommandName: LongInt; | Name of current command
cli_FailLevel: LongInt; | Fail level (set by FAILAT)
cli_Prompt: LongInt; | Current prompt (set by PROMPT)
cli_StandardInput: LongInt; | Default (terminal) CLI input
cli_CurrentInput: LongInt; | Current CLI input
cli_CommandFile: LongInt; | Name of EXECUTE command file
cli_Interactive: LongInt; | Boolean; True if prompts required
cli_Background: LongInt; | Boolean; True if CLI created by RUN
cli_CurrentOutput: LongInt; | Current CLI output
cli_DefaultStack: LongInt; | Stack size to be obtained in long words
cli_StandardOutput: LongInt; | Default (terminal) CLI output
cli_Module: LongInt; | SegList of currently loaded command
end;


TCSource

Input structure for ReadItem and ReadArgs

Declaration

Source position: amigados.pas line 1408

type TCSource = packed record
CS_Buffer: PChar; | Data source
CS_Length: LongInt; | Length of string
CS_CurChr: LongInt; |
end;

Description

The TCSource data structure defines the input source for ReadItem as well as the ReadArgs call. It is a publicly defined structure which may be used by applications which use code that follows the conventions defined for access.

To initialize a TCSource, you set TCSource.CS_Buffer to a string which is used as the data source, and set CS_Length to the number of characters in the string. Normally CS_CurChr should be initialized to 0, or left as it was from prior use as a TCSource.

When passed to the dos.library functions, the value passed as PCSource is defined as follows:

if PCSource = nil then
  // Use buffered IO  as data source
else
  // Use PCSource for input character stream


TDateStamp

Date and Time representation

Declaration

Source position: amigados.pas line 70

type TDateStamp = packed record
ds_Days: LongInt; | Number of days since 1. Jan. 1978
ds_Minute: LongInt; | Number of minutes of the day
ds_Tick: LongInt; | Number of ticks since past minute. Use TICKS_PER_SECOND to calculate the seconds.
end;

See also

TICKS_PER_SECOND | Number of ticks per second. Defines the acuracy of your time
DateStamp | Fills the structure with the current time. Time is measured from 1. Jan. 1978.
CompareDates | Compares two datestamps
SetFileDate | Sets the modification date for a file or dir
TFileInfoBlock | File information structure


TDeviceList

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a volume.

Declaration

Source position: amigados.pas line 657

type TDeviceList = packed record
dl_Next: LongInt; | Pointer to next device list
dl_Type: LongInt; | Type of record (DLT_*)
dl_Task: PMsgPort; | Pointer to handler task
dl_Lock: LongInt; | not for volumes
dl_VolumeDate: TDateStamp; | Creation date
dl_LockList: LongInt; | Outstanding locks
dl_DiskType: LongInt; | 'DOS', etc
dl_unused: LongInt; |
dl_Name: LongInt; | Name of device
end;


TDeviceNode

Device node list DLT_DEVICE

Declaration

Source position: amigados.pas line 1508

type TDeviceNode = packed record
dn_Next: LongInt; | Link to next node
dn_Type: LongWord; | Always 0 for dos "devices"
dn_Task: PMsgPort; | standard dos "task" field. If this is nil when the node is accesses, a task will be started up
dn_Lock: LongInt; | Not used for devices, leave nil
dn_Handler: LongInt; | Filename to loadseg (if seglist is nil)
dn_StackSize: LongWord; | Stacksize to use when starting task
dn_Priority: LongInt; | Task priority when starting task
dn_Startup: LongInt; | Pointer to TFileSysStartupMsg for disks
dn_SegList: LongInt; | code to run to start new task (if necessary). if nil then dn_Handler will be loaded.
dn_GlobalVec: LongInt; | Global vector to use when starting a task.-1 means that dn_SegList is not for a bcpl program, so the dos won't try and construct one. 0 tell the dos that you obey BCPL linkage rules, and that it should construct a global vector for you.
dn_Name: LongInt; | the node name, e.g. '\3','D','F','3' for DF3:
end;


TDevInfo

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a device

Declaration

Source position: amigados.pas line 671

type TDevInfo = packed record
dvi_Next: LongInt; | Pointer to next device list
dvi_Type: LongInt; | Type of record (DLT_*)
dvi_Task: Pointer; | Pointer to handler task
dvi_Lock: LongInt; | Lock to Device
dvi_Handler: LongInt; | Handler for device
dvi_StackSize: LongInt; | Stacksize
dvi_Priority: LongInt; | Priority in list
dvi_Startup: LongInt; |
dvi_SegList: LongInt; |
dvi_GlobVec: LongInt; |
dvi_Name: LongInt; |
end;


TDevProc

Structure return by GetDeviceProc()

Declaration

Source position: amigados.pas line 738

type TDevProc = packed record
dvp_Port: PMsgPort; |
dvp_Lock: LongInt; |
dvp_Flags: LongWord; | Flags (DVPF_*)
dvp_DevNode: PDOSList; |
end;


TDosAttrBuffer

Declaration

Source position: amigados.pas line 1287

type TDosAttrBuffer = record

  dab_Ptr: Pointer;

  dab_Len: LongWord;

end;


TDosEnvec

Describes the disk geometry

Declaration

Source position: amigados.pas line 1449

type TDosEnvec = packed record
de_TableSize: LongWord; | Size of Environment vector
de_SizeBlock: LongWord; | in longwords: standard value is 128
de_SecOrg: LongWord; | not used; must be 0
de_Surfaces: LongWord; | # of heads (surfaces). drive specific
de_SectorPerBlock: LongWord; | not used; must be 1
de_BlocksPerTrack: LongWord; | blocks per track. drive specific
de_Reserved: LongWord; | DOS reserved blocks at start of partition.
de_PreAlloc: LongWord; | DOS reserved blocks at end of partition
de_Interleave: LongWord; | usually 0
de_LowCyl: LongWord; | starting cylinder. typically 0
de_HighCyl: LongWord; | max cylinder. drive specific
de_NumBuffers: LongWord; | Initial # DOS of buffers.
de_BufMemType: LongWord; | Type of mem to allocate for buffers
de_MaxTransfer: LongWord; | Max number of bytes to transfer at a time
de_Mask: LongWord; | Address Mask to block out certain memory
de_BootPri: LongInt; | Boot priority for autoboot
de_DosType: LongWord; | ASCII (HEX) string showing filesystem type; $444F5300 OFS, $444F5301 FFS
de_Baud: LongWord; | Baud rate for serial handler
de_Control: LongWord; | Control SmallInt for handler/filesystem
de_BootBlocks: LongWord; | Number of blocks containing boot code
end;

Description

Here are the constants for a standard geometry. if you treat it as an array you can use the DE_* constants


TDOSInfo

Declaration

Source position: amigados.pas line 601

type TDOSInfo = packed record
case Byte of
0: (
di_ResList: LongInt; |
);
1: (
di_McName: LongInt; | Network name of this machine; currently 0
di_DevInfo: LongInt; | Device List
di_Devices: LongInt; | Currently 0
di_Handlers: LongInt; | Currently 0
di_NetHand: Pointer; | Network handler processid; currently 0
di_DevLock: TSignalSemaphore; | do NOT access directly!
di_EntryLock: TSignalSemaphore; | do NOT access directly!
di_DeleteLock: TSignalSemaphore; | do NOT access directly!
);
end;


TDOSLibrary

This is how the base of dos.library looks like.

Declaration

Source position: amigados.pas line 569

type TDOSLibrary = packed record
dl_Lib: TLibrary; |
dl_Root: PRootNode; | Pointer to RootNode
dl_GU: Pointer; |
dl_A2: LongInt; |
dl_A5: LongInt; |
dl_A6: LongInt; |
dl_Errors: PErrorString; | Pointer to array of error msgs
dl_TimeReq: PTimeRequest; | Private pointer to timer request
dl_UtilityBase: PLibrary; | Private ptr to utility library
dl_IntuitionBase: PLibrary; | Private ptr to intuition library
end;


TDOSList

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure combined structure for devices, assigned directories, volumes.

Declaration

Source position: amigados.pas line 694

type TDOSList = packed record
dol_Next: LongInt; | Pointer to next device on list
dol_Type: LongInt; | Type of record (DLT_*)
dol_Task: PMsgPort; | Pointer to handler task
dol_Lock: LongInt; |
case Byte of
0: (
dol_handler: record | file name to load if seglist is nil
dol_Handler: LongInt; |
dol_StackSize: LongInt; |
dol_Priority: LongInt; |
dol_Startup: LongWord; |
dol_SegList: LongInt; |
dol_GlobVec: LongInt; |
end;
);
1: (
dol_volume: record |
dol_VolumeDate: TDateStamp; |
dol_LockList: LongInt; |
dol_DiskType: LongInt; |
end;
);
2: (
dol_assign: record |
dol_AssignName: PChar; |
dol_List: PAssignList; |
end;
);
3: (
dol_Misc: array [0..23] of Byte; |
dol_Name: LongInt; | Name of Entry
);
end;


TDOSPacket

This is the extension to EXEC Messages used by DOS

Declaration

Source position: amigados.pas line 411

type TDOSPacket = packed record
dp_Link: PMessage; | Exec Message
dp_Port: PMsgPort; | Reply port for the packet. Must be filled in each send.
case Byte of
0: (
dp_Action: LongInt; |
dp_Status: LongInt; |
dp_Status2: LongInt; |
dp_BufAddr: LongInt; |
);
1: (
dp_Type: LongInt; | Type of access =Ord('W') write = Ord('R') read (ACTION_*)
dp_Res1: LongInt; |
dp_Res2: LongInt; |
dp_Arg1: LongInt; |
dp_Arg2: LongInt; |
dp_Arg3: LongInt; |
dp_Arg4: LongInt; |
dp_Arg5: LongInt; |
dp_Arg6: LongInt; |
dp_Arg7: LongInt; |
);
end;


TErrorString

A structure for holding error messages - stored as array with error = 0 for the last entry.

Declaration

Source position: amigados.pas line 547

type TErrorString = packed record

  estr_Nums: PLongInt;

  estr_Strings: PByte;

end;


TexAllControl

Control structure passed to ExAll().

Declaration

Source position: amigados.pas line 1077

type TexAllControl = packed record
eac_Entries: LongWord; | Number of entries returned in buffer
eac_LastKey: LongWord; | Don't touch inbetween linked ExAll calls!
eac_MatchString: PChar; | Wildcard string for pattern match or nil
eac_MatchFunc: Pointer; | optional private wildcard function pointer
end;

Description

Unused fields must be initialized to 0, expecially eac_LastKey.

eac_MatchFunc is a hook (see utility.library documentation for usage) It should return True if the entry is to returned, False if it is to be ignored.

This structure must be allocated by AllocDosObject()!


TExAllData

Structure in which exall results are returned in. Note that only the fields asked for will exist!

Declaration

Source position: amigados.pas line 1060

type TExAllData = packed record

  ed_Next: PExAllData;

  ed_Name: PChar;

  ed_Type: LongInt;

  ed_Size: LongWord;

  ed_Prot: LongWord;

  ed_Days: LongWord;

  ed_Mins: LongWord;

  ed_Ticks: LongWord;

  ed_Comment: PChar;

  ed_OwnerUID: Word;

  ed_OwnerGID: Word;

  ed_Size64: QWord;

end;


TFileHandle

The pointer of this structure is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls

Declaration

Source position: amigados.pas line 385

type TFileHandle = packed record
case Byte of
0: (
fh_Link: LongWord; | Exec message
fh_Port: LongInt; | Reply port for the packet
);
1: (
fh_Flags: LongWord; | EXEC message
fh_Interactive: LongInt; |
fh_Type: PMsgPort; |
fh_Buf: LongInt; | Port to do ReplyMsg()
fh_Pos: LongInt; |
fh_End: LongInt; |
fh_Func1: LongInt; |
fh_Func2: LongInt; |
fh_Func3: LongInt; |
fh_Arg1: LongInt; |
fh_Arg2: LongInt; |
fh_BufSize: LongInt; |
fh_OrigBuf: LongInt; |
);
end;


TFileInfoBlock

File information structure

Declaration

Source position: amigados.pas line 82

type TFileInfoBlock = packed record
fib_DiskKey: LongInt; |
fib_DirEntryType: LongInt; | Type of File. < 0 plain file, > 0 a directory
fib_FileName: array [0..107] of Char; | Name of the File or Directory
fib_Protection: LongInt; | Protection bits (FIBF_*)
fib_EntryType: LongInt; |
fib_Size: LongInt; | Size of file in Bytes
fib_NumBlocks: LongInt; | Size of File in blocks
fib_Date: TDateStamp; | Last change Date of File
fib_Comment: array [0..79] of Char; | Comment of File
fib_OwnerUID: Word; | Owners User ID (0 = no user id)
fib_OwnerGID: Word; | Owners Group ID (0 = no group ID)
case SmallInt of
0: (
fib_Reserved: array [0..31] of Char; |
);
1: (
fib_Size64: QWord; |
fib_NumBlocks64: QWord; |
);
end;

Description

Provides many informations about a file without a need to open it.

See also

Examine | Examine a directory or file associated with a lock
Examine64 | Fill in a FileInfoBlock structure concerning a file or directory associated with a particular lock.
FIBF_DELETE | Protection Value file can be deleted
FIBF_EXECUTE | Protection Value file can be exceuted
FIBF_WRITE | Protection Value file is writeable
FIBF_READ | Protection Value: File is readable
FIBF_ARCHIVE | Protection Value File is marked as archived
FIBF_PURE | Protection Value program is reentrant and rexecutable
FIBF_SCRIPT | Protection Value: File is a script


TFileLock

Lock structure, as returned by Lock() or DupLock()

Declaration

Source position: amigados.pas line 783

type TFileLock = packed record
fl_Link: LongInt; | Pointer to next lock
fl_Key: LongInt; | Disk block number
fl_Access: LongInt; | Exclusive or share
fl_Task: PMsgPort; | Handler task's port
fl_Volume: LongInt; | Pointer to a DeviceList
end;


TFileSysStartupMsg

Filesystem startup message for a device

Declaration

Source position: amigados.pas line 1499

type TFileSysStartupMsg = packed record
fssm_Unit: LongWord; | Exec unit number for this device
fssm_Device: LongInt; | Device Name
fssm_Environ: LongInt; | Pointer to Dos environment table
fssm_Flags: LongWord; | Flags for OpenDevice()
end;

Description

The file system startup message is linked into a device node's startup field. It contains a pointer to the Dos environment table and the information needed to do an OpenDevice()


TICKS_PER_SECOND

Number of ticks per second. Defines the acuracy of your time

Declaration

Source position: amigados.pas line 77

const TICKS_PER_SECOND = 50;


TInfoData

General Disk informatons from Info

Declaration

Source position: amigados.pas line 151

type TInfoData = packed record
id_NumSoftErrors: LongInt; | Number of soft errors on disk
id_UnitNumber: LongInt; | Which unit disk is (was) mounted on
id_DiskState: LongInt; | Disk State (ID_*)
id_NumBlocks: LongInt; | Number of blocks on disk
id_NumBlocksUsed: LongInt; | Number of block in use
id_BytesPerBlock: LongInt; | Number of bytes per block
id_DiskType: LongInt; | Disk type code (ID_*)
id_VolumeNode: LongInt; | Pointer to volume node
id_InUse: LongInt; | If not it use = 0
end;

See also

Info

Returns information about the disk


TLocalVar

The structure in the TProcess.pr_LocalVars list

Declaration

Source position: amigados.pas line 1368

type TLocalVar = packed record
lv_Node: TNode; | Node of the entry. the .ln_Type (LV_*)
lv_Flags: Word; |
lv_Value: PChar; |
lv_Len: LongWord; |
end;

Description

Do not allocate yourself, use SetVar()! This structure may grow in future releases. The list should be left in alphabetical order, and may have multiple entries with the same name but different types.


TNotifyMessage

Declaration

Source position: amigados.pas line 1559

type TNotifyMessage = packed record

  nm_ExecMessage: TMessage;

  nm_Class: LongWord;

  nm_Code: Word;

  nm_NReq: PNotifyRequest;

  nm_DoNotTouch: LongWord;

  nm_DoNotTouch2: LongWord;

end;


TNotifyRequest

Declaration

Source position: amigados.pas line 1536

type TNotifyRequest = packed record
nr_Name: PChar; |
nr_FullName: PChar; |
nr_UserData: LongWord; |
nr_Flags: LongWord; | Flags for Notify Requesr (NRF_*)
nr_stuff: record |
case Byte of
0: (
nr_Msg: record |
nr_Port: PMsgPort; |
end;
);
1: (
nr_Signal: record |
nr_Task: PTask; |
nr_SignalNum: Byte; |
nr_pad: array [0..2] of Byte; |
end;
);
end;
nr_Reserved: array [0..3] of LongWord; |
nr_MsgCount: LongWord; |
nr_Handler: PMsgPort; |
end;


TProcess

All DOS processes have this structure

Declaration

Source position: amigados.pas line 331

type TProcess = packed record
pr_Task: TTask; |
pr_MsgPort: TMsgPort; | This is address from DOS functions
pr_Pad: Word; | Remaining variables on 4 byte boundaries
pr_SegList: LongInt; | Array of seg lists used by this process
pr_StackSize: LongInt; | Size of process stack in bytes
pr_GlobVec: Pointer; | Global vector for this process
pr_TaskNum: LongInt; | CLI task number of zero if not a CLI
pr_StackBase: LongInt; | Pointer to high memory end of process stack
pr_Result2: LongInt; | Value of secondary result from last call
pr_CurrentDir: LongInt; | Lock associated with current directory
pr_CIS: LongInt; | Current CLI Input Stream
pr_COS: LongInt; | Current CLI Output Stream
pr_ConsoleTask: Pointer; | Console handler process for current window
pr_FileSystemTask: Pointer; | File handler process for current drive
pr_CLI: LongInt; | pointer to TConsoleLineInterpreter
pr_ReturnAddr: Pointer; | Pointer to previous stack frame
pr_PktWait: Pointer; | Function to be called when awaiting msg
pr_WindowPtr: Pointer; | Window for error printing
pr_HomeDir: LongInt; | Home directory of executing program
pr_Flags: LongInt; | Flags telling dos about process (PRF_*)
pr_ExitCode: Pointer; | Code to call on exit of program or nil
pr_ExitData: LongInt; | Passed as an argument to pr_ExitCode.
pr_Arguments: PChar; | Arguments passed to the process at start
pr_LocalVars: TMinList; | Local environment variables
pr_ShellPrivate: LongWord; | for the use of the current shell
pr_CES: LongInt; | Error stream - if nil, use pr_COS
end;

Description

Create and Device Proc returns pointer to the MsgPort in this structure dev_proc = Address(SmallInt(DeviceProc()) - SizeOf(Task))


TRDArgs

Input parameter structure used in ReadArgs()

Declaration

Source position: amigados.pas line 1416

type TRDArgs = packed record
RDA_Source: TCSource; | Select input source
RDA_DAList: LongInt; | private field do not touch.
RDA_Buffer: PChar; | Optional string parsing space.
RDA_BufSiz: LongInt; | Size of RDA_Buffer (0..n)
RDA_ExtHelp: PChar; | Optional extended help
RDA_Flags: LongInt; | Flags for any required control (RDAF_*)
end;

Description

if RDA_Source.CS_Buffer is not nil, RDA_Source is used as the input character stream to parse, else the input comes from the buffered STDIN

RDA_DAList is a private address which is used internally to track allocations which are freed by FreeArgs(). This must be initialized to nil prior to the first call to ReadArgs().

The RDA_Buffer and RDA_BufSiz fields allow the application to supply a fixed-size buffer in which to store the parsed data. This allows the application to pre-allocate a buffer rather than requiring buffer space to be allocated. If either RDA_Buffer or RDA_BufSiz is nil or 0, the application has not supplied a buffer.

RDA_ExtHelp is a text string which will be displayed instead of the template string, if the user is prompted for input.

RDA_Flags bits control how ReadArgs() works. The flag bits are defined with (RDAF_*). Defaults are initialized to 0.


TRecordLock

Parameter struct for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 1101

type TRecordLock = packed record
rec_FH: LongInt; | Filehandle
rec_Offset: LongWord; | Offset in file
rec_Length: LongWord; | Length of file to be locked
rec_Mode: LongWord; | Type of lock (REC_*)
end;


TRecordLock64

Declaration

Source position: amigados.pas line 1110

type TRecordLock64 = packed record

  rec_FH: LongInt;

  rec_Offset: QWord;

  rec_Length: QWord;

  rec_Mode: LongWord;

end;


TRootNode

Declaration

Source position: amigados.pas line 554

type TRootNode = packed record
rn_TaskArray: LongInt; | [0] is max number of CLI's [1] is APTR to process id of CLI 1 [n] is APTR to process id of CLI n
rn_ConsoleSegment: LongInt; | SegList for the CLI
rn_Time: TDateStamp; | Current time
rn_RestartSeg: LongInt; | SegList for the disk validator process
rn_Info: LongInt; | Pointer ot the Info structure
rn_FileHandlerSegment: LongInt; | Segment for a file handler
rn_CliList: TMinList; | New list of all CLI processes the first cpl_Array is also rn_TaskArray
rn_BootProc: PMsgPort; | Private pointer to msgport of boot file system
rn_ShellSegment: LongInt; | Seglist for Shell (for NewShell)
rn_Flags: LongInt; | dos flags
end;


TSegArray

Declaration

Source position: amigados.pas line 1609

type TSegArray = packed record

  seg_Address: Cardinal;

  seg_Size: Cardinal;

end;


TSegment

Declaration

Source position: amigados.pas line 618

type TSegment = packed record

  seg_Next: LongInt;

  seg_UC: LongInt;

  seg_Seg: LongInt;

  seg_Name: array [0..3] of Byte;

end;


TSegNode

Declaration

Source position: amigados.pas line 1616

type TSegNode = packed record

  seg_Node: TMinNode;

  seg_Name: PChar;

  seg_Array: array [0..0] of TSegArray;

end;


TSegSem

Declaration

Source position: amigados.pas line 1601

type TSegSem = packed record

  seg_Semaphore: TSignalSemaphore;

  seg_Find: procedure;

  seg_List: TMinList;

end;


TStandardPacket

Declaration

Source position: amigados.pas line 435

type TStandardPacket = packed record

  sp_Msg: TMessage;

  sp_Pkt: TDOSPacket;

end;


Reference for unit 'amigalib'

Unit 'amigalib' | Package
[Overview][Procedures and functions][Index] | [#morphunits]

Reference for unit 'amigalib' (deprecated)

uses

  System;


ASL_FileRequest

Declaration

Source position: asl.pas line 39

const ASL_FileRequest = 0;


ASL_FontRequest

Declaration

Source position: asl.pas line 40

const ASL_FontRequest = 1;


ASL_LAST_TAG

Declaration

Source position: asl.pas line 412

const ASL_LAST_TAG = ASL_TB + 134;


ASL_ScreenModeRequest

Declaration

Source position: asl.pas line 41

const ASL_ScreenModeRequest = 2;


ASL_SEMAPHORE_NAME

Declaration

Source position: asl.pas line 421

const ASL_SEMAPHORE_NAME: PChar = 'asl.library';


ASL_TB

Declaration

Source position: asl.pas line 34

const ASL_TB = TAG_USER + $80000;


AslBase

Declaration

Source position: asl.pas line 537

var AslBase: PLibrary = Nil;


ASLFO_Activate

Declaration

Source position: asl.pas line 274

const ASLFO_Activate = ASL_TB + 132;


ASLFO_BackPens

Declaration

Source position: asl.pas line 265

const ASLFO_BackPens = ASL_TB + 65;


ASLFO_DoBackPen

Declaration

Source position: asl.pas line 250

const ASLFO_DoBackPen = ASL_TB + 45;


ASLFO_DoDrawMode

Declaration

Source position: asl.pas line 252

const ASLFO_DoDrawMode = ASL_TB + 47;


ASLFO_DoFrontPen

Declaration

Source position: asl.pas line 249

const ASLFO_DoFrontPen = ASL_TB + 44;


ASLFO_DoStyle

Declaration

Source position: asl.pas line 251

const ASLFO_DoStyle = ASL_TB + 46;


ASLFO_FilterFunc

Declaration

Source position: asl.pas line 256

const ASLFO_FilterFunc = ASL_TB + 49;


ASLFO_FixedWidthOnly

Declaration

Source position: asl.pas line 254

const ASLFO_FixedWidthOnly = ASL_TB + 48;


ASLFO_Flags

Declaration

Source position: asl.pas line 240

const ASLFO_Flags = ASL_TB + 20;


ASLFO_FrontPens

Declaration

Source position: asl.pas line 264

const ASLFO_FrontPens = ASL_TB + 64;


ASLFO_HookFunc

Declaration

Source position: asl.pas line 225

const ASLFO_HookFunc = ASL_TB + 7;


ASLFO_InitialBackPen

Declaration

Source position: asl.pas line 232

const ASLFO_InitialBackPen = ASL_TB + 15;


ASLFO_InitialDrawMode

Declaration

Source position: asl.pas line 262

const ASLFO_InitialDrawMode = ASL_TB + 59;


ASLFO_InitialFlags

Declaration

Source position: asl.pas line 230

const ASLFO_InitialFlags = ASL_TB + 13;


ASLFO_InitialFrontPen

Declaration

Source position: asl.pas line 231

const ASLFO_InitialFrontPen = ASL_TB + 14;


ASLFO_InitialHeight

Declaration

Source position: asl.pas line 223

const ASLFO_InitialHeight = ASL_TB + 6;


ASLFO_InitialLeftEdge

Declaration

Source position: asl.pas line 220

const ASLFO_InitialLeftEdge = ASL_TB + 3;


ASLFO_InitialName

Declaration

Source position: asl.pas line 227

const ASLFO_InitialName = ASL_TB + 10;


ASLFO_InitialSize

Declaration

Source position: asl.pas line 228

const ASLFO_InitialSize = ASL_TB + 11;


ASLFO_InitialStyle

Declaration

Source position: asl.pas line 229

const ASLFO_InitialStyle = ASL_TB + 12;


ASLFO_InitialTopEdge

Declaration

Source position: asl.pas line 221

const ASLFO_InitialTopEdge = ASL_TB + 4;


ASLFO_InitialWidth

Declaration

Source position: asl.pas line 222

const ASLFO_InitialWidth = ASL_TB + 5;


ASLFO_IntuiMsgFunc

Declaration

Source position: asl.pas line 270

const ASLFO_IntuiMsgFunc = ASL_TB + 70;


ASLFO_Locale

Declaration

Source position: asl.pas line 258

const ASLFO_Locale = ASL_TB + 50;


ASLFO_MaxBackPen

Declaration

Source position: asl.pas line 268

const ASLFO_MaxBackPen = ASL_TB + 67;


ASLFO_MaxFrontPen

Declaration

Source position: asl.pas line 267

const ASLFO_MaxFrontPen = ASL_TB + 66;


ASLFO_MaxHeight

Declaration

Source position: asl.pas line 235

const ASLFO_MaxHeight = ASL_TB + 17;


ASLFO_MinHeight

Declaration

Source position: asl.pas line 234

const ASLFO_MinHeight = ASL_TB + 16;


ASLFO_ModeList

Declaration

Source position: asl.pas line 242

const ASLFO_ModeList = ASL_TB + 21;


ASLFO_NegativeText

Declaration

Source position: asl.pas line 238

const ASLFO_NegativeText = ASL_TB + 19;


ASLFO_PopToFront

Declaration

Source position: asl.pas line 272

const ASLFO_PopToFront = ASL_TB + 131;


ASLFO_PositiveText

Declaration

Source position: asl.pas line 237

const ASLFO_PositiveText = ASL_TB + 18;


ASLFO_PrivateIDCMP

Declaration

Source position: asl.pas line 246

const ASLFO_PrivateIDCMP = ASL_TB + 42;


ASLFO_PubScreenName

Declaration

Source position: asl.pas line 245

const ASLFO_PubScreenName = ASL_TB + 41;


ASLFO_SampleText

Declaration

Source position: asl.pas line 275

const ASLFO_SampleText = ASL_TB + 133;


ASLFO_Screen

Declaration

Source position: asl.pas line 244

const ASLFO_Screen = ASL_TB + 40;


ASLFO_SleepWindow

Declaration

Source position: asl.pas line 247

const ASLFO_SleepWindow = ASL_TB + 43;


ASLFO_TextAttr

Declaration

Source position: asl.pas line 259

const ASLFO_TextAttr = ASL_TB + 51;


ASLFO_TitleText

Declaration

Source position: asl.pas line 217

const ASLFO_TitleText = ASL_TB + 1;


ASLFO_UserData

Declaration

Source position: asl.pas line 260

const ASLFO_UserData = ASL_TB + 52;


ASLFO_Window

Declaration

Source position: asl.pas line 218

const ASLFO_Window = ASL_TB + 2;


ASLFR_AcceptPattern

Declaration

Source position: asl.pas line 133

const ASLFR_AcceptPattern = ASL_TB + 62;


ASLFR_Activate

Declaration

Source position: asl.pas line 148

const ASLFR_Activate = ASL_TB + 132;


ASLFR_DoMultiSelect

Declaration

Source position: asl.pas line 121

const ASLFR_DoMultiSelect = ASL_TB + 45;


ASLFR_DoPatterns

Declaration

Source position: asl.pas line 122

const ASLFR_DoPatterns = ASL_TB + 46;


ASLFR_DoSaveMode

Declaration

Source position: asl.pas line 120

const ASLFR_DoSaveMode = ASL_TB + 44;


ASLFR_DrawersOnly

Declaration

Source position: asl.pas line 124

const ASLFR_DrawersOnly = ASL_TB + 47;


ASLFR_FilterDrawers

Declaration

Source position: asl.pas line 134

const ASLFR_FilterDrawers = ASL_TB + 63;


ASLFR_FilterFunc

Declaration

Source position: asl.pas line 125

const ASLFR_FilterFunc = ASL_TB + 49;


ASLFR_Flags1

Declaration

Source position: asl.pas line 112

const ASLFR_Flags1 = ASL_TB + 20;


ASLFR_Flags2

Declaration

Source position: asl.pas line 113

const ASLFR_Flags2 = ASL_TB + 22;


ASLFR_GetSortBy

Declaration

Source position: asl.pas line 139

const ASLFR_GetSortBy = ASL_TB + 125;


ASLFR_GetSortDrawers

Declaration

Source position: asl.pas line 141

const ASLFR_GetSortDrawers = ASL_TB + 127;


ASLFR_GetSortOrder

Declaration

Source position: asl.pas line 143

const ASLFR_GetSortOrder = ASL_TB + 129;


ASLFR_HookFunc

Declaration

Source position: asl.pas line 103

const ASLFR_HookFunc = ASL_TB + 7;


ASLFR_InitialDrawer

Declaration

Source position: asl.pas line 106

const ASLFR_InitialDrawer = ASL_TB + 9;


ASLFR_InitialFile

Declaration

Source position: asl.pas line 105

const ASLFR_InitialFile = ASL_TB + 8;


ASLFR_InitialHeight

Declaration

Source position: asl.pas line 101

const ASLFR_InitialHeight = ASL_TB + 6;


ASLFR_InitialLeftEdge

Declaration

Source position: asl.pas line 98

const ASLFR_InitialLeftEdge = ASL_TB + 3;


ASLFR_InitialPattern

Declaration

Source position: asl.pas line 107

const ASLFR_InitialPattern = ASL_TB + 10;


ASLFR_InitialShowVolumes

Declaration

Source position: asl.pas line 145

const ASLFR_InitialShowVolumes = ASL_TB + 130;


ASLFR_InitialTopEdge

Declaration

Source position: asl.pas line 99

const ASLFR_InitialTopEdge = ASL_TB + 4;


ASLFR_InitialWidth

Declaration

Source position: asl.pas line 100

const ASLFR_InitialWidth = ASL_TB + 5;


ASLFR_IntuiMsgFunc

Declaration

Source position: asl.pas line 136

const ASLFR_IntuiMsgFunc = ASL_TB + 70;


ASLFR_Locale

Declaration

Source position: asl.pas line 127

const ASLFR_Locale = ASL_TB + 50;


ASLFR_NegativeText

Declaration

Source position: asl.pas line 110

const ASLFR_NegativeText = ASL_TB + 19;


ASLFR_PopToFront

Declaration

Source position: asl.pas line 146

const ASLFR_PopToFront = ASL_TB + 131;


ASLFR_PositiveText

Declaration

Source position: asl.pas line 109

const ASLFR_PositiveText = ASL_TB + 18;


ASLFR_PrivateIDCMP

Declaration

Source position: asl.pas line 117

const ASLFR_PrivateIDCMP = ASL_TB + 42;


ASLFR_PubScreenName

Declaration

Source position: asl.pas line 116

const ASLFR_PubScreenName = ASL_TB + 41;


ASLFR_RejectIcons

Declaration

Source position: asl.pas line 131

const ASLFR_RejectIcons = ASL_TB + 60;


ASLFR_RejectPattern

Declaration

Source position: asl.pas line 132

const ASLFR_RejectPattern = ASL_TB + 61;


ASLFR_Screen

Declaration

Source position: asl.pas line 115

const ASLFR_Screen = ASL_TB + 40;


ASLFR_SetSortBy

Declaration

Source position: asl.pas line 138

const ASLFR_SetSortBy = ASL_TB + 124;


ASLFR_SetSortDrawers

Declaration

Source position: asl.pas line 140

const ASLFR_SetSortDrawers = ASL_TB + 126;


ASLFR_SetSortOrder

Declaration

Source position: asl.pas line 142

const ASLFR_SetSortOrder = ASL_TB + 128;


ASLFR_SleepWindow

Declaration

Source position: asl.pas line 118

const ASLFR_SleepWindow = ASL_TB + 43;


ASLFR_TextAttr

Declaration

Source position: asl.pas line 128

const ASLFR_TextAttr = ASL_TB + 51;


ASLFR_TitleText

Declaration

Source position: asl.pas line 95

const ASLFR_TitleText = ASL_TB + 1;


ASLFR_UserData

Declaration

Source position: asl.pas line 129

const ASLFR_UserData = ASL_TB + 52;


ASLFR_Window

Declaration

Source position: asl.pas line 96

const ASLFR_Window = ASL_TB + 2;


ASLFRSORTBY_Date

Declaration

Source position: asl.pas line 176

const ASLFRSORTBY_Date = 1;


ASLFRSORTBY_Name

Declaration

Source position: asl.pas line 175

const ASLFRSORTBY_Name = 0;


ASLFRSORTBY_Size

Declaration

Source position: asl.pas line 177

const ASLFRSORTBY_Size = 2;


ASLFRSORTDRAWERS_First

Declaration

Source position: asl.pas line 180

const ASLFRSORTDRAWERS_First = 0;


ASLFRSORTDRAWERS_Last

Declaration

Source position: asl.pas line 182

const ASLFRSORTDRAWERS_Last = 2;


ASLFRSORTDRAWERS_Mix

Declaration

Source position: asl.pas line 181

const ASLFRSORTDRAWERS_Mix = 1;


ASLFRSORTORDER_Ascend

Declaration

Source position: asl.pas line 185

const ASLFRSORTORDER_Ascend = 0;


ASLFRSORTORDER_Descend

Declaration

Source position: asl.pas line 186

const ASLFRSORTORDER_Descend = 1;


ASLNAME

Declaration

Source position: asl.pas line 33

const ASLNAME: PChar = 'asl.library';


ASLOPTION_ASLOverrides

Declaration

Source position: asl.pas line 459

const ASLOPTION_ASLOverrides = 1 shl 6;


ASLPOS_CenterMouse

Declaration

Source position: asl.pas line 450

const ASLPOS_CenterMouse = 5;


ASLPOS_CenterScreen

Declaration

Source position: asl.pas line 447

const ASLPOS_CenterScreen = 2;


ASLPOS_CenterWindow

Declaration

Source position: asl.pas line 446

const ASLPOS_CenterWindow = 1;


ASLPOS_DefaultPosition

Declaration

Source position: asl.pas line 445

const ASLPOS_DefaultPosition = 0;


ASLPOS_MASK

Declaration

Source position: asl.pas line 451

const ASLPOS_MASK = $0F;


ASLPOS_ScreenPosition

Declaration

Source position: asl.pas line 449

const ASLPOS_ScreenPosition = 4;


ASLPOS_WindowPosition

Declaration

Source position: asl.pas line 448

const ASLPOS_WindowPosition = 3;


ASLSIZE_DefaultSize

Declaration

Source position: asl.pas line 453

const ASLSIZE_DefaultSize = 0 shl 4;


ASLSIZE_MASK

Declaration

Source position: asl.pas line 457

const ASLSIZE_MASK = $30;


ASLSIZE_RelativeSize

Declaration

Source position: asl.pas line 454

const ASLSIZE_RelativeSize = 1 shl 4;


ASLSM_Activate

Declaration

Source position: asl.pas line 408

const ASLSM_Activate = ASL_TB + 132;


ASLSM_CustomSMList

Declaration

Source position: asl.pas line 404

const ASLSM_CustomSMList = ASL_TB + 123;


ASLSM_DoAutoScroll

Declaration

Source position: asl.pas line 392

const ASLSM_DoAutoScroll = ASL_TB + 113;


ASLSM_DoDepth

Declaration

Source position: asl.pas line 390

const ASLSM_DoDepth = ASL_TB + 111;


ASLSM_DoHeight

Declaration

Source position: asl.pas line 389

const ASLSM_DoHeight = ASL_TB + 110;


ASLSM_DoOverscanType

Declaration

Source position: asl.pas line 391

const ASLSM_DoOverscanType = ASL_TB + 112;


ASLSM_DoWidth

Declaration

Source position: asl.pas line 388

const ASLSM_DoWidth = ASL_TB + 109;


ASLSM_FilterFunc

Declaration

Source position: asl.pas line 402

const ASLSM_FilterFunc = ASL_TB + 122;


ASLSM_InitialAutoScroll

Declaration

Source position: asl.pas line 383

const ASLSM_InitialAutoScroll = ASL_TB + 105;


ASLSM_InitialDisplayDepth

Declaration

Source position: asl.pas line 381

const ASLSM_InitialDisplayDepth = ASL_TB + 103;


ASLSM_InitialDisplayHeight

Declaration

Source position: asl.pas line 380

const ASLSM_InitialDisplayHeight = ASL_TB + 102;


ASLSM_InitialDisplayID

Declaration

Source position: asl.pas line 378

const ASLSM_InitialDisplayID = ASL_TB + 100;


ASLSM_InitialDisplayWidth

Declaration

Source position: asl.pas line 379

const ASLSM_InitialDisplayWidth = ASL_TB + 101;


ASLSM_InitialHeight

Declaration

Source position: asl.pas line 362

const ASLSM_InitialHeight = ASL_TB + 6;


ASLSM_InitialInfoLeftEdge

Declaration

Source position: asl.pas line 385

const ASLSM_InitialInfoLeftEdge = ASL_TB + 107;


ASLSM_InitialInfoOpened

Declaration

Source position: asl.pas line 384

const ASLSM_InitialInfoOpened = ASL_TB + 106;


ASLSM_InitialInfoTopEdge

Declaration

Source position: asl.pas line 386

const ASLSM_InitialInfoTopEdge = ASL_TB + 108;


ASLSM_InitialLeftEdge

Declaration

Source position: asl.pas line 359

const ASLSM_InitialLeftEdge = ASL_TB + 3;


ASLSM_InitialOverscanType

Declaration

Source position: asl.pas line 382

const ASLSM_InitialOverscanType = ASL_TB + 104;


ASLSM_InitialTopEdge

Declaration

Source position: asl.pas line 360

const ASLSM_InitialTopEdge = ASL_TB + 4;


ASLSM_InitialWidth

Declaration

Source position: asl.pas line 361

const ASLSM_InitialWidth = ASL_TB + 5;


ASLSM_IntuiMsgFunc

Declaration

Source position: asl.pas line 376

const ASLSM_IntuiMsgFunc = ASL_TB + 70;


ASLSM_Locale

Declaration

Source position: asl.pas line 372

const ASLSM_Locale = ASL_TB + 50;


ASLSM_MaxDepth

Declaration

Source position: asl.pas line 401

const ASLSM_MaxDepth = ASL_TB + 121;


ASLSM_MaxHeight

Declaration

Source position: asl.pas line 399

const ASLSM_MaxHeight = ASL_TB + 119;


ASLSM_MaxWidth

Declaration

Source position: asl.pas line 397

const ASLSM_MaxWidth = ASL_TB + 117;


ASLSM_MinDepth

Declaration

Source position: asl.pas line 410

const ASLSM_MinDepth = ASL_TB + 133;


ASLSM_MinHeight

Declaration

Source position: asl.pas line 398

const ASLSM_MinHeight = ASL_TB + 118;


ASLSM_MinWidth

Declaration

Source position: asl.pas line 396

const ASLSM_MinWidth = ASL_TB + 116;


ASLSM_NegativeText

Declaration

Source position: asl.pas line 365

const ASLSM_NegativeText = ASL_TB + 19;


ASLSM_PopToFront

Declaration

Source position: asl.pas line 406

const ASLSM_PopToFront = ASL_TB + 131;


ASLSM_PositiveText

Declaration

Source position: asl.pas line 364

const ASLSM_PositiveText = ASL_TB + 18;


ASLSM_PrivateIDCMP

Declaration

Source position: asl.pas line 369

const ASLSM_PrivateIDCMP = ASL_TB + 42;


ASLSM_PropertyFlags

Declaration

Source position: asl.pas line 394

const ASLSM_PropertyFlags = ASL_TB + 114;


ASLSM_PropertyMask

Declaration

Source position: asl.pas line 395

const ASLSM_PropertyMask = ASL_TB + 115;


ASLSM_PubScreenName

Declaration

Source position: asl.pas line 368

const ASLSM_PubScreenName = ASL_TB + 41;


ASLSM_Screen

Declaration

Source position: asl.pas line 367

const ASLSM_Screen = ASL_TB + 40;


ASLSM_SleepWindow

Declaration

Source position: asl.pas line 370

const ASLSM_SleepWindow = ASL_TB + 43;


ASLSM_TextAttr

Declaration

Source position: asl.pas line 373

const ASLSM_TextAttr = ASL_TB + 51;


ASLSM_TitleText

Declaration

Source position: asl.pas line 356

const ASLSM_TitleText = ASL_TB + 1;


ASLSM_UserData

Declaration

Source position: asl.pas line 374

const ASLSM_UserData = ASL_TB + 52;


ASLSM_Window

Declaration

Source position: asl.pas line 357

const ASLSM_Window = ASL_TB + 2;


FOB_DOBACKPEN

Declaration

Source position: asl.pas line 279

const FOB_DOBACKPEN = 1;


FOB_DODRAWMODE

Declaration

Source position: asl.pas line 281

const FOB_DODRAWMODE = 3;


FOB_DOFRONTPEN

Declaration

Source position: asl.pas line 278

const FOB_DOFRONTPEN = 0;


FOB_DOSTYLE

Declaration

Source position: asl.pas line 280

const FOB_DOSTYLE = 2;


FOB_FILTERFUNC

Declaration

Source position: asl.pas line 285

const FOB_FILTERFUNC = 7;


FOB_FIXEDWIDTHONLY

Declaration

Source position: asl.pas line 282

const FOB_FIXEDWIDTHONLY = 4;


FOB_INTUIFUNC

Declaration

Source position: asl.pas line 284

const FOB_INTUIFUNC = 6;


FOB_PRIVATEIDCMP

Declaration

Source position: asl.pas line 283

const FOB_PRIVATEIDCMP = 5;


FOF_DOBACKPEN

Declaration

Source position: asl.pas line 288

const FOF_DOBACKPEN = 1 shl FOB_DOBACKPEN;


FOF_DODRAWMODE

Declaration

Source position: asl.pas line 290

const FOF_DODRAWMODE = 1 shl FOB_DODRAWMODE;


FOF_DOFRONTPEN

Declaration

Source position: asl.pas line 287

const FOF_DOFRONTPEN = 1 shl FOB_DOFRONTPEN;


FOF_DOSTYLE

Declaration

Source position: asl.pas line 289

const FOF_DOSTYLE = 1 shl FOB_DOSTYLE;


FOF_FILTERFUNC

Declaration

Source position: asl.pas line 294

const FOF_FILTERFUNC = 1 shl FOB_FILTERFUNC;


FOF_FIXEDWIDTHONLY

Declaration

Source position: asl.pas line 291

const FOF_FIXEDWIDTHONLY = 1 shl FOB_FIXEDWIDTHONLY;


FOF_INTUIFUNC

Declaration

Source position: asl.pas line 293

const FOF_INTUIFUNC = 1 shl FOB_INTUIFUNC;


FOF_PRIVATEIDCMP

Declaration

Source position: asl.pas line 292

const FOF_PRIVATEIDCMP = 1 shl FOB_PRIVATEIDCMP;


FRB_DOMULTISELECT

Declaration

Source position: asl.pas line 155

const FRB_DOMULTISELECT = 3;


FRB_DOPATTERNS

Declaration

Source position: asl.pas line 156

const FRB_DOPATTERNS = 0;


FRB_DOSAVEMODE

Declaration

Source position: asl.pas line 153

const FRB_DOSAVEMODE = 5;


FRB_DRAWERSONLY

Declaration

Source position: asl.pas line 166

const FRB_DRAWERSONLY = 0;


FRB_FILTERDRAWERS

Declaration

Source position: asl.pas line 167

const FRB_FILTERDRAWERS = 1;


FRB_FILTERFUNC

Declaration

Source position: asl.pas line 151

const FRB_FILTERFUNC = 7;


FRB_INTUIFUNC

Declaration

Source position: asl.pas line 152

const FRB_INTUIFUNC = 6;


FRB_PRIVATEIDCMP

Declaration

Source position: asl.pas line 154

const FRB_PRIVATEIDCMP = 4;


FRB_REJECTICONS

Declaration

Source position: asl.pas line 168

const FRB_REJECTICONS = 2;


FRF_DOMULTISELECT

Declaration

Source position: asl.pas line 162

const FRF_DOMULTISELECT = 1 shl FRB_DOMULTISELECT;


FRF_DOPATTERNS

Declaration

Source position: asl.pas line 163

const FRF_DOPATTERNS = 1 shl FRB_DOPATTERNS;


FRF_DOSAVEMODE

Declaration

Source position: asl.pas line 160

const FRF_DOSAVEMODE = 1 shl FRB_DOSAVEMODE;


FRF_DRAWERSONLY

Declaration

Source position: asl.pas line 170

const FRF_DRAWERSONLY = 1 shl FRB_DRAWERSONLY;


FRF_FILTERDRAWERS

Declaration

Source position: asl.pas line 171

const FRF_FILTERDRAWERS = 1 shl FRB_FILTERDRAWERS;


FRF_FILTERFUNC

Declaration

Source position: asl.pas line 158

const FRF_FILTERFUNC = 1 shl FRB_FILTERFUNC;


FRF_INTUIFUNC

Declaration

Source position: asl.pas line 159

const FRF_INTUIFUNC = 1 shl FRB_INTUIFUNC;


FRF_PRIVATEIDCMP

Declaration

Source position: asl.pas line 161

const FRF_PRIVATEIDCMP = 1 shl FRB_PRIVATEIDCMP;


FRF_REJECTICONS

Declaration

Source position: asl.pas line 172

const FRF_REJECTICONS = 1 shl FRB_REJECTICONS;


Reference for unit 'asl'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility, | Tag Handling, Date routines in utility.library
workbench, | Basic Workbench/AppIcons functions (workbench.library)
agraphics; | Native Amiga graphic functions (graphics.library)


Reference for unit 'asl': Constants

ASLFO_Activate

ASLFO_BackPens

ASLFO_DoBackPen

ASLFO_DoDrawMode

ASLFO_DoFrontPen

ASLFO_DoStyle

ASLFO_FilterFunc

ASLFO_FixedWidthOnly

ASLFO_Flags

ASLFO_FrontPens

ASLFO_HookFunc

ASLFO_InitialBackPen

ASLFO_InitialDrawMode

ASLFO_InitialFlags

ASLFO_InitialFrontPen

ASLFO_InitialHeight

ASLFO_InitialLeftEdge

ASLFO_InitialName

ASLFO_InitialSize

ASLFO_InitialStyle

ASLFO_InitialTopEdge

ASLFO_InitialWidth

ASLFO_IntuiMsgFunc

ASLFO_Locale

ASLFO_MaxBackPen

ASLFO_MaxFrontPen

ASLFO_MaxHeight

ASLFO_MinHeight

ASLFO_ModeList

ASLFO_NegativeText

ASLFO_PopToFront

ASLFO_PositiveText

ASLFO_PrivateIDCMP

ASLFO_PubScreenName

ASLFO_SampleText

ASLFO_Screen

ASLFO_SleepWindow

ASLFO_TextAttr

ASLFO_TitleText

ASLFO_UserData

ASLFO_Window

ASLFRSORTBY_Date

ASLFRSORTBY_Name

ASLFRSORTBY_Size

ASLFRSORTDRAWERS_First

ASLFRSORTDRAWERS_Last

ASLFRSORTDRAWERS_Mix

ASLFRSORTORDER_Ascend

ASLFRSORTORDER_Descend

ASLFR_AcceptPattern

ASLFR_Activate

ASLFR_DoMultiSelect

ASLFR_DoPatterns

ASLFR_DoSaveMode

ASLFR_DrawersOnly

ASLFR_FilterDrawers

ASLFR_FilterFunc

ASLFR_Flags1

ASLFR_Flags2

ASLFR_GetSortBy

ASLFR_GetSortDrawers

ASLFR_GetSortOrder

ASLFR_HookFunc

ASLFR_InitialDrawer

ASLFR_InitialFile

ASLFR_InitialHeight

ASLFR_InitialLeftEdge

ASLFR_InitialPattern

ASLFR_InitialShowVolumes

ASLFR_InitialTopEdge

ASLFR_InitialWidth

ASLFR_IntuiMsgFunc

ASLFR_Locale

ASLFR_NegativeText

ASLFR_PopToFront

ASLFR_PositiveText

ASLFR_PrivateIDCMP

ASLFR_PubScreenName

ASLFR_RejectIcons

ASLFR_RejectPattern

ASLFR_Screen

ASLFR_SetSortBy

ASLFR_SetSortDrawers

ASLFR_SetSortOrder

ASLFR_SleepWindow

ASLFR_TextAttr

ASLFR_TitleText

ASLFR_UserData

ASLFR_Window

ASLNAME

ASLOPTION_ASLOverrides

ASLPOS_CenterMouse

ASLPOS_CenterScreen

ASLPOS_CenterWindow

ASLPOS_DefaultPosition

ASLPOS_MASK

ASLPOS_ScreenPosition

ASLPOS_WindowPosition

ASLSIZE_DefaultSize

ASLSIZE_MASK

ASLSIZE_RelativeSize

ASLSM_Activate

ASLSM_CustomSMList

ASLSM_DoAutoScroll

ASLSM_DoDepth

ASLSM_DoHeight

ASLSM_DoOverscanType

ASLSM_DoWidth

ASLSM_FilterFunc

ASLSM_InitialAutoScroll

ASLSM_InitialDisplayDepth

ASLSM_InitialDisplayHeight

ASLSM_InitialDisplayID

ASLSM_InitialDisplayWidth

ASLSM_InitialHeight

ASLSM_InitialInfoLeftEdge

ASLSM_InitialInfoOpened

ASLSM_InitialInfoTopEdge

ASLSM_InitialLeftEdge

ASLSM_InitialOverscanType

ASLSM_InitialTopEdge

ASLSM_InitialWidth

ASLSM_IntuiMsgFunc

ASLSM_Locale

ASLSM_MaxDepth

ASLSM_MaxHeight

ASLSM_MaxWidth

ASLSM_MinDepth

ASLSM_MinHeight

ASLSM_MinWidth

ASLSM_NegativeText

ASLSM_PopToFront

ASLSM_PositiveText

ASLSM_PrivateIDCMP

ASLSM_PropertyFlags

ASLSM_PropertyMask

ASLSM_PubScreenName

ASLSM_Screen

ASLSM_SleepWindow

ASLSM_TextAttr

ASLSM_TitleText

ASLSM_UserData

ASLSM_Window

ASL_FileRequest

ASL_FontRequest

ASL_LAST_TAG

ASL_ScreenModeRequest

ASL_SEMAPHORE_NAME

ASL_TB

FOB_DOBACKPEN

FOB_DODRAWMODE

FOB_DOFRONTPEN

FOB_DOSTYLE

FOB_FILTERFUNC

FOB_FIXEDWIDTHONLY

FOB_INTUIFUNC

FOB_PRIVATEIDCMP

FOF_DOBACKPEN

FOF_DODRAWMODE

FOF_DOFRONTPEN

FOF_DOSTYLE

FOF_FILTERFUNC

FOF_FIXEDWIDTHONLY

FOF_INTUIFUNC

FOF_PRIVATEIDCMP

FRB_DOMULTISELECT

FRB_DOPATTERNS

FRB_DOSAVEMODE

FRB_DRAWERSONLY

FRB_FILTERDRAWERS

FRB_FILTERFUNC

FRB_INTUIFUNC

FRB_PRIVATEIDCMP

FRB_REJECTICONS

FRF_DOMULTISELECT

FRF_DOPATTERNS

FRF_DOSAVEMODE

FRF_DRAWERSONLY

FRF_FILTERDRAWERS

FRF_FILTERFUNC

FRF_INTUIFUNC

FRF_PRIVATEIDCMP

FRF_REJECTICONS


Reference for unit 'asl': Types

PAslSemaphore

PDisplayMode

PFileRequester

PFontRequester

PScreenModeRequester

TAslSemaphore

TDisplayMode

TFileRequester

TFontRequester

TScreenModeRequester


PAslSemaphore

Declaration

Source position: asl.pas line 424

type PAslSemaphore = ^TAslSemaphore;


PDisplayMode

Declaration

Source position: asl.pas line 347

type PDisplayMode = ^TDisplayMode;


PFileRequester

Declaration

Source position: asl.pas line 55

type PFileRequester = ^TFileRequester;


PFontRequester

Declaration

Source position: asl.pas line 199

type PFontRequester = ^TFontRequester;


PScreenModeRequester

Declaration

Source position: asl.pas line 307

type PScreenModeRequester = ^TScreenModeRequester;


TAslSemaphore

Declaration

Source position: asl.pas line 425

type TAslSemaphore = record

  as_Semaphore: TSignalSemaphore;

  as_Version: Word;

  as_Size: Cardinal;

  as_SortBy: Byte;

  as_SortDrawers: Byte;

  as_SortOrder: Byte;

  as_SizePosition: Byte;

  as_RelativeLeft: Word;

  as_RelativeTop: Word;

  as_RelativeWidth: Byte;

  as_RelativeHeight: Byte;

end;


TDisplayMode

Declaration

Source position: asl.pas line 348

type TDisplayMode = record

  dm_Node: TNode;

  dm_DimensionInfo: TDimensionInfo;

  dm_PropertyFlags: Cardinal;

end;


TFileRequester

Declaration

Source position: asl.pas line 56

type TFileRequester = record

  case SmallInt of

    0: (

        rf_Reserved0: array [0..3] of Byte;

        rf_File: PChar;

        rf_Dir: PChar;

        rf_Reserved1: array [0..9] of Byte;

        rf_LeftEdge: SmallInt;

        rf_TopEdge: SmallInt;

        rf_Width: SmallInt;

        rf_Height: SmallInt;

        rf_Reserved2: array [0..1] of Byte;

        rf_NumArgs: LongInt;

        rf_ArgList: PWBArgList;

        rf_UserData: Pointer;

        rf_Reserved3: array [0..7] of Byte;

        rf_Pat: PChar;

      );

    1: (

        fr_Reserved0: array [0..3] of Byte;

        fr_File: PChar;

        fr_Drawer: PChar;

        fr_Reserved1: array [0..9] of Byte;

        fr_LeftEdge: SmallInt;

        fr_TopEdge: SmallInt;

        fr_Width: SmallInt;

        fr_Height: SmallInt;

        fr_Reserved2: array [0..1] of Byte;

        fr_NumArgs: LongInt;

        fr_ArgList: PWBArgList;

        fr_UserData: Pointer;

        fr_Reserved3: array [0..7] of Byte;

        fr_Pattern: PChar;

      );

end;


TFontRequester

Declaration

Source position: asl.pas line 200

type TFontRequester = record

  fo_Reserved0: array [0..7] of Byte;

  fo_Attr: TTextAttr;

  fo_FrontPen: Byte;

  fo_BackPen: Byte;

  fo_DrawMode: Byte;

  fo_Reserved1: Byte;

  fo_UserData: Pointer;

  fo_LeftEdge: SmallInt;

  fo_TopEdge: SmallInt;

  fo_Width: SmallInt;

  fo_Height: SmallInt;

  fo_TAttr: TTTextAttr;

end;


TScreenModeRequester

Declaration

Source position: asl.pas line 308

type TScreenModeRequester = record

  sm_DisplayID: Cardinal;

  sm_DisplayWidth: Cardinal;

  sm_DisplayHeight: Cardinal;

  sm_DisplayDepth: Word;

  sm_OverscanType: Word;

  sm_AutoScroll: WordBool;

  sm_BitMapWidth: Cardinal;

  sm_BitMapHeight: Cardinal;

  sm_LeftEdge: SmallInt;

  sm_TopEdge: SmallInt;

  sm_Width: SmallInt;

  sm_Height: SmallInt;

  sm_InfoOpened: WordBool;

  sm_InfoLeftEdge: SmallInt;

  sm_InfoTopEdge: SmallInt;

  sm_InfoWidth: SmallInt;

  sm_InfoHeight: SmallInt;

  sm_UserData: Pointer;

  sm_MonitorName: PChar;

  sm_DisplayIDWidth: Cardinal;

  sm_DisplayIDHeight: Cardinal;

end;


CGXVideoBase

Declaration

Source position: cgxvideo.pas line 41

var CGXVideoBase: PLibrary = Nil;


CGXVIDEONAME

Declaration

Source position: cgxvideo.pas line 38

const CGXVIDEONAME = 'cgxvideo.library';


Reference for unit 'cgxvideo'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
intuition, | Screen and Window handling routines of intuition.library
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'cgxvideo': Constants

CGXVIDEONAME

SRCFMT_R5G5B5PC

SRCFMT_R5G6B5PC

SRCFMT_RGB15

SRCFMT_RGB16

SRCFMT_YCbCr16

SRCFMT_YCbCr420

SRCFMT_YUV16

VOA_BaseAddress

VOA_BaseOffset

VOA_BaseOffset0

VOA_BaseOffset1

VOA_BaseOffset2

VOA_BaseOffset3

VOA_BaseOffset4

VOA_BaseOffset5

VOA_BottomIndent

VOA_CaptureMode

VOA_ColConSP

VOA_Color0SP

VOA_Color10SP

VOA_Color11SP

VOA_Color12SP

VOA_Color13SP

VOA_Color14SP

VOA_Color15SP

VOA_Color1SP

VOA_Color2SP

VOA_Color3SP

VOA_Color4SP

VOA_Color5SP

VOA_Color6SP

VOA_Color7SP

VOA_Color8SP

VOA_Color9SP

VOA_ColorKey

VOA_ColorKeyPen

VOA_DoubleBuffer

VOA_EnableSP

VOA_Error

VOA_FrameBase0

VOA_FrameBase1

VOA_FrameIndex

VOA_FrameType

VOA_Height

VOA_HLColConSP

VOA_HLEnableSP

VOA_HLRectSP

VOA_Identifier

VOA_InterLaced

VOA_LeftIndent

VOA_Modulo

VOA_MultiBuffer

VOA_RightIndent

VOA_SrcHeight

VOA_SrcHeightSP

VOA_SrcType

VOA_SrcWidth

VOA_SrcWidthSP

VOA_StreamRectSP

VOA_SubPicture

VOA_TopIndent

VOA_UseBackfill

VOA_UseColorKey

VOA_UseFilter

VOA_Width

VOA_ZoomRect

VOERR_INVSCRMODE

VOERR_INVSRCFMT

VOERR_NOMEMORY

VOERR_NOOVLMEMORY

VOERR_OK

VSQ_Dummy

VSQ_FEAT_CAPTUREMODE

VSQ_FEAT_COLORKEYING

VSQ_FEAT_DOUBLEBUFFER

VSQ_FEAT_FILTERING

VSQ_FEAT_INTERLACE

VSQ_FEAT_MULTIBUFFER

VSQ_FEAT_OVERLAY

VSQ_FEAT_SUBPICTURE

VSQ_FEAT_ZOOMRECT

VSQ_FMT_R5G5B5_LE

VSQ_FMT_R5G6B5_LE

VSQ_FMT_YUV420_PLANAR

VSQ_FMT_YUYV

VSQ_MaxWidth

VSQ_MaxWidthSP

VSQ_SupportedFeatures

VSQ_SupportedFormats


Unit 'cgxvideo' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'cgxvideo': Types

PVLayerHandle

Pointer


PVLayerHandle

Declaration

Source position: cgxvideo.pas line 45

type PVLayerHandle = ^Pointer;


SRCFMT_R5G5B5PC

Declaration

Source position: cgxvideo.pas line 168

const SRCFMT_R5G5B5PC = 2;


SRCFMT_R5G6B5PC

Declaration

Source position: cgxvideo.pas line 170

const SRCFMT_R5G6B5PC = 3;


SRCFMT_RGB15

Declaration

Source position: cgxvideo.pas line 167

const SRCFMT_RGB15 = 2;


SRCFMT_RGB16

Declaration

Source position: cgxvideo.pas line 169

const SRCFMT_RGB16 = 3;


SRCFMT_YCbCr16

Declaration

Source position: cgxvideo.pas line 166

const SRCFMT_YCbCr16 = 1;


SRCFMT_YCbCr420

Declaration

Source position: cgxvideo.pas line 171

const SRCFMT_YCbCr420 = 4;


SRCFMT_YUV16

Declaration

Source position: cgxvideo.pas line 165

const SRCFMT_YUV16 = 0;


TVLayerHandle

Declaration

Source position: cgxvideo.pas line 44

type TVLayerHandle = Pointer;


VOA_BaseAddress

Declaration

Source position: cgxvideo.pas line 65

const VOA_BaseAddress = $88000030;


VOA_BaseOffset

Declaration

Source position: cgxvideo.pas line 86

const VOA_BaseOffset = $88000039;


VOA_BaseOffset0

Declaration

Source position: cgxvideo.pas line 94

const VOA_BaseOffset0 = $88000040;


VOA_BaseOffset1

Declaration

Source position: cgxvideo.pas line 95

const VOA_BaseOffset1 = $88000041;


VOA_BaseOffset2

Declaration

Source position: cgxvideo.pas line 96

const VOA_BaseOffset2 = $88000042;


VOA_BaseOffset3

Declaration

Source position: cgxvideo.pas line 97

const VOA_BaseOffset3 = $88000043;


VOA_BaseOffset4

Declaration

Source position: cgxvideo.pas line 98

const VOA_BaseOffset4 = $88000044;


VOA_BaseOffset5

Declaration

Source position: cgxvideo.pas line 99

const VOA_BaseOffset5 = $88000045;


VOA_BottomIndent

Declaration

Source position: cgxvideo.pas line 51

const VOA_BottomIndent = $88000004;


VOA_CaptureMode

Declaration

Source position: cgxvideo.pas line 84

const VOA_CaptureMode = $8800000f;


VOA_ColConSP

Declaration

Source position: cgxvideo.pas line 122

const VOA_ColConSP = $88000063;


VOA_Color0SP

Declaration

Source position: cgxvideo.pas line 102

const VOA_Color0SP = $88000050;


VOA_Color1SP

Declaration

Source position: cgxvideo.pas line 103

const VOA_Color1SP = $88000051;


VOA_Color2SP

Declaration

Source position: cgxvideo.pas line 104

const VOA_Color2SP = $88000052;


VOA_Color3SP

Declaration

Source position: cgxvideo.pas line 105

const VOA_Color3SP = $88000053;


VOA_Color4SP

Declaration

Source position: cgxvideo.pas line 106

const VOA_Color4SP = $88000054;


VOA_Color5SP

Declaration

Source position: cgxvideo.pas line 107

const VOA_Color5SP = $88000055;


VOA_Color6SP

Declaration

Source position: cgxvideo.pas line 108

const VOA_Color6SP = $88000056;


VOA_Color7SP

Declaration

Source position: cgxvideo.pas line 109

const VOA_Color7SP = $88000057;


VOA_Color8SP

Declaration

Source position: cgxvideo.pas line 110

const VOA_Color8SP = $88000058;


VOA_Color9SP

Declaration

Source position: cgxvideo.pas line 111

const VOA_Color9SP = $88000059;


VOA_Color10SP

Declaration

Source position: cgxvideo.pas line 112

const VOA_Color10SP = $8800005A;


VOA_Color11SP

Declaration

Source position: cgxvideo.pas line 113

const VOA_Color11SP = $8800005B;


VOA_Color12SP

Declaration

Source position: cgxvideo.pas line 114

const VOA_Color12SP = $8800005C;


VOA_Color13SP

Declaration

Source position: cgxvideo.pas line 115

const VOA_Color13SP = $8800005D;


VOA_Color14SP

Declaration

Source position: cgxvideo.pas line 116

const VOA_Color14SP = $8800005E;


VOA_Color15SP

Declaration

Source position: cgxvideo.pas line 117

const VOA_Color15SP = $8800005F;


VOA_ColorKey

Declaration

Source position: cgxvideo.pas line 67

const VOA_ColorKey = $88000032;


VOA_ColorKeyPen

Declaration

Source position: cgxvideo.pas line 66

const VOA_ColorKeyPen = $88000031;


VOA_DoubleBuffer

Declaration

Source position: cgxvideo.pas line 82

const VOA_DoubleBuffer = $8800000d;


VOA_EnableSP

Declaration

Source position: cgxvideo.pas line 120

const VOA_EnableSP = $88000061;


VOA_Error

Declaration

Source position: cgxvideo.pas line 57

const VOA_Error = $88000008;


VOA_FrameBase0

Declaration

Source position: cgxvideo.pas line 72

const VOA_FrameBase0 = $88000033;


VOA_FrameBase1

Declaration

Source position: cgxvideo.pas line 73

const VOA_FrameBase1 = $88000034;


VOA_FrameIndex

Declaration

Source position: cgxvideo.pas line 90

const VOA_FrameIndex = $88000010;


VOA_FrameType

Declaration

Source position: cgxvideo.pas line 74

const VOA_FrameType = $88000035;


VOA_Height

Declaration

Source position: cgxvideo.pas line 77

const VOA_Height = $88000037;


VOA_HLColConSP

Declaration

Source position: cgxvideo.pas line 125

const VOA_HLColConSP = $88000066;


VOA_HLEnableSP

Declaration

Source position: cgxvideo.pas line 123

const VOA_HLEnableSP = $88000065;


VOA_HLRectSP

Declaration

Source position: cgxvideo.pas line 124

const VOA_HLRectSP = $88000064;


VOA_Identifier

Declaration

Source position: cgxvideo.pas line 70

const VOA_Identifier = $8800000b;


VOA_InterLaced

Declaration

Source position: cgxvideo.pas line 83

const VOA_InterLaced = $8800000e;


VOA_LeftIndent

Declaration

Source position: cgxvideo.pas line 48

const VOA_LeftIndent = $88000001;


VOA_Modulo

Declaration

Source position: cgxvideo.pas line 78

const VOA_Modulo = $88000038;


VOA_MultiBuffer

Declaration

Source position: cgxvideo.pas line 91

const VOA_MultiBuffer = $88000011;


VOA_RightIndent

Declaration

Source position: cgxvideo.pas line 49

const VOA_RightIndent = $88000002;


VOA_SrcHeight

Declaration

Source position: cgxvideo.pas line 55

const VOA_SrcHeight = $88000007;


VOA_SrcHeightSP

Declaration

Source position: cgxvideo.pas line 127

const VOA_SrcHeightSP = $88000068;


VOA_SrcType

Declaration

Source position: cgxvideo.pas line 53

const VOA_SrcType = $88000005;


VOA_SrcWidth

Declaration

Source position: cgxvideo.pas line 54

const VOA_SrcWidth = $88000006;


VOA_SrcWidthSP

Declaration

Source position: cgxvideo.pas line 126

const VOA_SrcWidthSP = $88000067;


VOA_StreamRectSP

Declaration

Source position: cgxvideo.pas line 121

const VOA_StreamRectSP = $88000062;


VOA_SubPicture

Declaration

Source position: cgxvideo.pas line 119

const VOA_SubPicture = $88000060;


VOA_TopIndent

Declaration

Source position: cgxvideo.pas line 50

const VOA_TopIndent = $88000003;


VOA_UseBackfill

Declaration

Source position: cgxvideo.pas line 61

const VOA_UseBackfill = $8800000a;


VOA_UseColorKey

Declaration

Source position: cgxvideo.pas line 59

const VOA_UseColorKey = $88000009;


VOA_UseFilter

Declaration

Source position: cgxvideo.pas line 63

const VOA_UseFilter = $8800000c;


VOA_Width

Declaration

Source position: cgxvideo.pas line 76

const VOA_Width = $88000036;


VOA_ZoomRect

Declaration

Source position: cgxvideo.pas line 92

const VOA_ZoomRect = $88000012;


VOERR_INVSCRMODE

Declaration

Source position: cgxvideo.pas line 157

const VOERR_INVSCRMODE = 1;


VOERR_INVSRCFMT

Declaration

Source position: cgxvideo.pas line 159

const VOERR_INVSRCFMT = 3;


VOERR_NOMEMORY

Declaration

Source position: cgxvideo.pas line 160

const VOERR_NOMEMORY = 4;


VOERR_NOOVLMEMORY

Declaration

Source position: cgxvideo.pas line 158

const VOERR_NOOVLMEMORY = 2;


VOERR_OK

Declaration

Source position: cgxvideo.pas line 156

const VOERR_OK = 0;


VSQ_Dummy

Declaration

Source position: cgxvideo.pas line 130

const VSQ_Dummy = TAG_USER + $A5000;


VSQ_FEAT_CAPTUREMODE

Declaration

Source position: cgxvideo.pas line 138

const VSQ_FEAT_CAPTUREMODE = 1 shl 5;


VSQ_FEAT_COLORKEYING

Declaration

Source position: cgxvideo.pas line 136

const VSQ_FEAT_COLORKEYING = 1 shl 3;


VSQ_FEAT_DOUBLEBUFFER

Declaration

Source position: cgxvideo.pas line 134

const VSQ_FEAT_DOUBLEBUFFER = 1 shl 1;


VSQ_FEAT_FILTERING

Declaration

Source position: cgxvideo.pas line 137

const VSQ_FEAT_FILTERING = 1 shl 4;


VSQ_FEAT_INTERLACE

Declaration

Source position: cgxvideo.pas line 139

const VSQ_FEAT_INTERLACE = 1 shl 6;


VSQ_FEAT_MULTIBUFFER

Declaration

Source position: cgxvideo.pas line 135

const VSQ_FEAT_MULTIBUFFER = 1 shl 2;


VSQ_FEAT_OVERLAY

Declaration

Source position: cgxvideo.pas line 133

const VSQ_FEAT_OVERLAY = 1 shl 0;


VSQ_FEAT_SUBPICTURE

Declaration

Source position: cgxvideo.pas line 141

const VSQ_FEAT_SUBPICTURE = 1 shl 8;


VSQ_FEAT_ZOOMRECT

Declaration

Source position: cgxvideo.pas line 140

const VSQ_FEAT_ZOOMRECT = 1 shl 7;


VSQ_FMT_R5G5B5_LE

Declaration

Source position: cgxvideo.pas line 146

const VSQ_FMT_R5G5B5_LE = 1 shl 1;


VSQ_FMT_R5G6B5_LE

Declaration

Source position: cgxvideo.pas line 147

const VSQ_FMT_R5G6B5_LE = 1 shl 2;


VSQ_FMT_YUV420_PLANAR

Declaration

Source position: cgxvideo.pas line 148

const VSQ_FMT_YUV420_PLANAR = 1 shl 3;


VSQ_FMT_YUYV

Declaration

Source position: cgxvideo.pas line 145

const VSQ_FMT_YUYV = 1 shl 0;


VSQ_MaxWidth

Declaration

Source position: cgxvideo.pas line 150

const VSQ_MaxWidth = VSQ_Dummy + 3;


VSQ_MaxWidthSP

Declaration

Source position: cgxvideo.pas line 152

const VSQ_MaxWidthSP = VSQ_Dummy + 4;


VSQ_SupportedFeatures

Declaration

Source position: cgxvideo.pas line 131

const VSQ_SupportedFeatures = VSQ_Dummy + 1;


VSQ_SupportedFormats

Declaration

Source position: cgxvideo.pas line 143

const VSQ_SupportedFormats = VSQ_Dummy + 2;


CBD_CHANGEHOOK

Declaration

Source position: clipboard.pas line 33

const CBD_CHANGEHOOK = CMD_NONSTD + 3;


CBD_CURRENTREADID

Declaration

Source position: clipboard.pas line 31

const CBD_CURRENTREADID = CMD_NONSTD + 1;


CBD_CURRENTWRITEID

Declaration

Source position: clipboard.pas line 32

const CBD_CURRENTWRITEID = CMD_NONSTD + 2;


CBD_POST

Declaration

Source position: clipboard.pas line 30

const CBD_POST = CMD_NONSTD + 0;


CBERR_OBSOLETEID

Declaration

Source position: clipboard.pas line 35

const CBERR_OBSOLETEID = 1;


Reference for unit 'clipboard'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'clipboard': Constants

CBD_CHANGEHOOK

CBD_CURRENTREADID

CBD_CURRENTWRITEID

CBD_POST

CBERR_OBSOLETEID

PRIMARY_CLIP


Reference for unit 'clipboard': Types

pClipboardUnitPartial

pClipHookMsg

pIOClipReq

pSatisfyMsg

tClipboardUnitPartial

tClipHookMsg

tIOClipReq

tSatisfyMsg


Index of all identifiers in unit 'clipboard'

C P T

C

CBD_CHANGEHOOK | CBD_CURRENTWRITEID | CBERR_OBSOLETEID
CBD_CURRENTREADID | CBD_POST |

P

pClipboardUnitPartial | pIOClipReq | pSatisfyMsg
pClipHookMsg | PRIMARY_CLIP |

T

tClipboardUnitPartial | tIOClipReq
tClipHookMsg | tSatisfyMsg


pClipboardUnitPartial

Declaration

Source position: clipboard.pas line 39

type pClipboardUnitPartial = ^tClipboardUnitPartial;


pClipHookMsg

Declaration

Source position: clipboard.pas line 74

type pClipHookMsg = ^tClipHookMsg;


pIOClipReq

Declaration

Source position: clipboard.pas line 47

type pIOClipReq = ^tIOClipReq;


PRIMARY_CLIP

Declaration

Source position: clipboard.pas line 63

const PRIMARY_CLIP = 0;


pSatisfyMsg

Declaration

Source position: clipboard.pas line 67

type pSatisfyMsg = ^tSatisfyMsg;


tClipboardUnitPartial

Declaration

Source position: clipboard.pas line 40

type tClipboardUnitPartial = record

  cu_Node: TNode;

  cu_UnitNum: DWord;

end;


tClipHookMsg

Declaration

Source position: clipboard.pas line 75

type tClipHookMsg = record

  chm_Type: DWord;

  chm_ChangeCmd: LongInt;

  chm_ClipID: LongInt;

end;


tIOClipReq

Declaration

Source position: clipboard.pas line 48

type tIOClipReq = record

  io_Message: TMessage;

  io_Device: PDevice;

  io_Unit: pClipboardUnitPartial;

  io_Command: Word;

  io_Flags: Byte;

  io_Error: ShortInt;

  io_Actual: DWord;

  io_Length: DWord;

  io_Data: PChar;

  io_Offset: DWord;

  io_ClipID: LongInt;

end;


tSatisfyMsg

Declaration

Source position: clipboard.pas line 68

type tSatisfyMsg = record

  sm_Msg: TMessage;

  sm_Unit: Word;

  sm_ClipID: LongInt;

end;


CBD_DESCRLEN

Declaration

Source position: commodities.pas line 48

const CBD_DESCRLEN = 40;


CBD_NAMELEN

Declaration

Source position: commodities.pas line 46

const CBD_NAMELEN = 24;


CBD_TITLELEN

Declaration

Source position: commodities.pas line 47

const CBD_TITLELEN = 40;


CBERR_DUP

Declaration

Source position: commodities.pas line 114

const CBERR_DUP = 2;


CBERR_OK

Declaration

Source position: commodities.pas line 112

const CBERR_OK = 0;


CBERR_SYSERR

Declaration

Source position: commodities.pas line 113

const CBERR_SYSERR = 1;


CBERR_VERSION

Declaration

Source position: commodities.pas line 115

const CBERR_VERSION = 3;


COERR_BADFILTER

Declaration

Source position: commodities.pas line 120

const COERR_BADFILTER = 4;


COERR_BADTYPE

Declaration

Source position: commodities.pas line 121

const COERR_BADTYPE = 8;


COERR_ISNULL

Declaration

Source position: commodities.pas line 118

const COERR_ISNULL = 1;


COERR_NULLATTACH

Declaration

Source position: commodities.pas line 119

const COERR_NULLATTACH = 2;


COF_SHOW_HIDE

Declaration

Source position: commodities.pas line 54

const COF_SHOW_HIDE = 4;


COMMODITIESNAME

Declaration

Source position: commodities.pas line 127

const COMMODITIESNAME: PChar = 'commodities.library';


CX_BROKER

Declaration

Source position: commodities.pas line 63

const CX_BROKER = 6;


CX_CUSTOM

Declaration

Source position: commodities.pas line 65

const CX_CUSTOM = 8;


Unit 'commodities' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CX_DEBUG

Declaration

Source position: commodities.pas line 64

const CX_DEBUG = 7;


CX_FILTER

Declaration

Source position: commodities.pas line 58

const CX_FILTER = 1;


CX_INVALID

Declaration

Source position: commodities.pas line 57

const CX_INVALID = 0;


Unit 'commodities' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CX_SEND

Declaration

Source position: commodities.pas line 60

const CX_SEND = 3;


CX_SIGNAL

Declaration

Source position: commodities.pas line 61

const CX_SIGNAL = 4;


CX_TRANSLATE

Declaration

Source position: commodities.pas line 62

const CX_TRANSLATE = 5;


CX_TYPEFILTER

Declaration

Source position: commodities.pas line 59

const CX_TYPEFILTER = 2;


Unit 'commodities' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CX_ZERO

Declaration

Source position: commodities.pas line 66

const CX_ZERO = 9;


CxBase

Declaration

Source position: commodities.pas line 124

var CxBase: PLibrary = Nil;


CXCMD_APPEAR

Declaration

Source position: commodities.pas line 74

const CXCMD_APPEAR = 19;


CXCMD_DISABLE

Declaration

Source position: commodities.pas line 72

const CXCMD_DISABLE = 15;


CXCMD_DISAPPEAR

Declaration

Source position: commodities.pas line 75

const CXCMD_DISAPPEAR = 21;


CXCMD_ENABLE

Declaration

Source position: commodities.pas line 73

const CXCMD_ENABLE = 17;


CXCMD_KILL

Declaration

Source position: commodities.pas line 76

const CXCMD_KILL = 23;


CXCMD_LIST_CHG

Declaration

Source position: commodities.pas line 77

const CXCMD_LIST_CHG = 27;


CXCMD_UNIQUE

Declaration

Source position: commodities.pas line 78

const CXCMD_UNIQUE = 25;


CXM_COMMAND

Declaration

Source position: commodities.pas line 69

const CXM_COMMAND = 1 shl 6;


CXM_IEVENT

Declaration

Source position: commodities.pas line 68

const CXM_IEVENT = 1 shl 5;


Unit 'commodities' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CxMsg

Declaration

Source position: commodities.pas line 26

type CxMsg = LongInt;


Unit 'commodities' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CxObj

Declaration

Source position: commodities.pas line 24

type CxObj = LongInt;


Reference for unit 'commodities'

uses

  System,

  exec,

This unit contains the types and wrapper functions for the exec.library.

  inputevent,

  keymap;


Reference for unit 'commodities': Constants

CBD_DESCRLEN

CBD_NAMELEN

CBD_TITLELEN

CBERR_DUP

CBERR_OK

CBERR_SYSERR

CBERR_VERSION

COERR_BADFILTER

COERR_BADTYPE

COERR_ISNULL

COERR_NULLATTACH

COF_SHOW_HIDE

COMMODITIESNAME

CXCMD_APPEAR

CXCMD_DISABLE

CXCMD_DISAPPEAR

CXCMD_ENABLE

CXCMD_KILL

CXCMD_LIST_CHG

CXCMD_UNIQUE

CXM_COMMAND

CXM_IEVENT

CX_BROKER

CX_CUSTOM

CX_DEBUG

CX_FILTER

CX_INVALID

CX_SEND

CX_SIGNAL

CX_TRANSLATE

CX_TYPEFILTER

CX_ZERO

IXSYM_ALT

IXSYM_ALTMASK

IXSYM_CAPS

IXSYM_CAPSMASK

IXSYM_SHIFT

IXSYM_SHIFTMASK

IX_NORMALQUALS

IX_VERSION

NBU_DUPLICATE

NBU_NOTIFY

NBU_UNIQUE

NB_VERSION


Reference for unit 'commodities': Types

LongInt

LongInt

IX

PCXMsg

PCxObj

PInputXpression

PIX

PNewBroker

TInputXpression

TNewBroker


IX

Declaration

Source position: commodities.pas line 91

type IX = TInputXpression;


IX_NORMALQUALS

Declaration

Source position: commodities.pas line 109

const IX_NORMALQUALS = $7FFF;


IX_VERSION

Declaration

Source position: commodities.pas line 96

const IX_VERSION = 2;


IXSYM_ALT

Declaration

Source position: commodities.pas line 101

const IXSYM_ALT = 4;


IXSYM_ALTMASK

Declaration

Source position: commodities.pas line 106

const IXSYM_ALTMASK = IEQUALIFIER_LALT or IEQUALIFIER_RALT;


IXSYM_CAPS

Declaration

Source position: commodities.pas line 100

const IXSYM_CAPS = 2;


IXSYM_CAPSMASK

Declaration

Source position: commodities.pas line 105

const IXSYM_CAPSMASK = IXSYM_SHIFTMASK or IEQUALIFIER_CAPSLOCK;


IXSYM_SHIFT

Declaration

Source position: commodities.pas line 99

const IXSYM_SHIFT = 1;


IXSYM_SHIFTMASK

Declaration

Source position: commodities.pas line 104

const IXSYM_SHIFTMASK = IEQUALIFIER_LSHIFT or IEQUALIFIER_RSHIFT;


NB_VERSION

Declaration

Source position: commodities.pas line 44

const NB_VERSION = 5;


NBU_DUPLICATE

Declaration

Source position: commodities.pas line 50

const NBU_DUPLICATE = 0;


NBU_NOTIFY

Declaration

Source position: commodities.pas line 52

const NBU_NOTIFY = 2;


NBU_UNIQUE

Declaration

Source position: commodities.pas line 51

const NBU_UNIQUE = 1;


PCXMsg

Declaration

Source position: commodities.pas line 27

type PCXMsg = ^LongInt;


PCxObj

Declaration

Source position: commodities.pas line 25

type PCxObj = ^LongInt;


PInputXpression

Declaration

Source position: commodities.pas line 81

type PInputXpression = ^TInputXpression;


Unit 'commodities' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PIX

Declaration

Source position: commodities.pas line 92

type PIX = ^IX;


PNewBroker

Declaration

Source position: commodities.pas line 29

type PNewBroker = ^TNewBroker;


TInputXpression

Declaration

Source position: commodities.pas line 82

type TInputXpression = record

  ix_Version: Byte;

  ix_Class: Byte;

  ix_Code: Word;

  ix_CodeMask: Word;

  ix_Qualifier: Word;

  ix_QualMask: Word;

  ix_QualSame: Word;

end;


TNewBroker

Declaration

Source position: commodities.pas line 30

type TNewBroker = record

  nb_Version: ShortInt;

  nb_Name: PChar;

  nb_Title: PChar;

  nb_Descr: PChar;

  nb_Unique: SmallInt;

  nb_Flags: SmallInt;

  nb_Pri: ShortInt;

  nb_Port: PMsgPort;

  nb_ReservedChannel: SmallInt;

end;


CD_ASKDEFAULTKEYMAP

Declaration

Source position: console.pas line 36

const CD_ASKDEFAULTKEYMAP = CMD_NONSTD + 2;


CD_ASKKEYMAP

Declaration

Source position: console.pas line 34

const CD_ASKKEYMAP = CMD_NONSTD + 0;


CD_SETDEFAULTKEYMAP

Declaration

Source position: console.pas line 37

const CD_SETDEFAULTKEYMAP = CMD_NONSTD + 3;


CD_SETKEYMAP

Declaration

Source position: console.pas line 35

const CD_SETKEYMAP = CMD_NONSTD + 1;


ConsoleDevice

Declaration

Source position: console.pas line 113

var ConsoleDevice: PDevice = Nil;


CTC_HCLRTAB

Declaration

Source position: console.pas line 100

const CTC_HCLRTAB = 2;


CTC_HCLRTABSALL

Declaration

Source position: console.pas line 101

const CTC_HCLRTABSALL = 5;


CTC_HSETTAB

Declaration

Source position: console.pas line 99

const CTC_HSETTAB = 0;


DSR_CPR

Declaration

Source position: console.pas line 96

const DSR_CPR = 6;


Reference for unit 'console'

uses

  System,

  exec,

This unit contains the types and wrapper functions for the exec.library.

  inputevent,

  keymap;


Reference for unit 'console': Constants

CD_ASKDEFAULTKEYMAP

CD_ASKKEYMAP

CD_SETDEFAULTKEYMAP

CD_SETKEYMAP

CTC_HCLRTAB

CTC_HCLRTABSALL

CTC_HSETTAB

DSR_CPR

M_ASM

M_AWM

M_LNM

SGR_BLACK

SGR_BLACKBG

SGR_BLUE

SGR_BLUEBG

SGR_BOLD

SGR_CLR0

SGR_CLR0BG

SGR_CLR1

SGR_CLR1BG

SGR_CLR2

SGR_CLR2BG

SGR_CLR3

SGR_CLR3BG

SGR_CLR4

SGR_CLR4BG

SGR_CLR5

SGR_CLR5BG

SGR_CLR6

SGR_CLR6BG

SGR_CLR7

SGR_CLR7BG

SGR_CYAN

SGR_CYANBG

SGR_DEFAULT

SGR_DEFAULTBG

SGR_GREEN

SGR_GREENBG

SGR_ITALIC

SGR_MAGENTA

SGR_MAGENTABG

SGR_NEGATIVE

SGR_NORMAL

SGR_NOTITALIC

SGR_NOTUNDERSCORE

SGR_POSITIVE

SGR_PRIMARY

SGR_RED

SGR_REDBG

SGR_UNDERSCORE

SGR_WHITE

SGR_WHITEBG

SGR_YELLOW

SGR_YELLOWBG

TBC_HCLRTAB

TBC_HCLRTABSALL


M_ASM

Declaration

Source position: console.pas line 109

const M_ASM = '>1';


M_AWM

Declaration

Source position: console.pas line 110

const M_AWM = '?7';


M_LNM

Declaration

Source position: console.pas line 108

const M_LNM = 20;


SGR_BLACK

Declaration

Source position: console.pas line 54

const SGR_BLACK = 30;


SGR_BLACKBG

Declaration

Source position: console.pas line 64

const SGR_BLACKBG = 40;


SGR_BLUE

Declaration

Source position: console.pas line 58

const SGR_BLUE = 34;


SGR_BLUEBG

Declaration

Source position: console.pas line 68

const SGR_BLUEBG = 44;


SGR_BOLD

Declaration

Source position: console.pas line 42

const SGR_BOLD = 1;


SGR_CLR0

Declaration

Source position: console.pas line 77

const SGR_CLR0 = 30;


SGR_CLR0BG

Declaration

Source position: console.pas line 86

const SGR_CLR0BG = 40;


SGR_CLR1

Declaration

Source position: console.pas line 78

const SGR_CLR1 = 31;


SGR_CLR1BG

Declaration

Source position: console.pas line 87

const SGR_CLR1BG = 41;


SGR_CLR2

Declaration

Source position: console.pas line 79

const SGR_CLR2 = 32;


SGR_CLR2BG

Declaration

Source position: console.pas line 88

const SGR_CLR2BG = 42;


SGR_CLR3

Declaration

Source position: console.pas line 80

const SGR_CLR3 = 33;


SGR_CLR3BG

Declaration

Source position: console.pas line 89

const SGR_CLR3BG = 43;


SGR_CLR4

Declaration

Source position: console.pas line 81

const SGR_CLR4 = 34;


SGR_CLR4BG

Declaration

Source position: console.pas line 90

const SGR_CLR4BG = 44;


SGR_CLR5

Declaration

Source position: console.pas line 82

const SGR_CLR5 = 35;


SGR_CLR5BG

Declaration

Source position: console.pas line 91

const SGR_CLR5BG = 45;


SGR_CLR6

Declaration

Source position: console.pas line 83

const SGR_CLR6 = 36;


SGR_CLR6BG

Declaration

Source position: console.pas line 92

const SGR_CLR6BG = 46;


SGR_CLR7

Declaration

Source position: console.pas line 84

const SGR_CLR7 = 37;


SGR_CLR7BG

Declaration

Source position: console.pas line 93

const SGR_CLR7BG = 47;


SGR_CYAN

Declaration

Source position: console.pas line 60

const SGR_CYAN = 36;


SGR_CYANBG

Declaration

Source position: console.pas line 70

const SGR_CYANBG = 46;


SGR_DEFAULT

Declaration

Source position: console.pas line 62

const SGR_DEFAULT = 39;


SGR_DEFAULTBG

Declaration

Source position: console.pas line 72

const SGR_DEFAULTBG = 49;


SGR_GREEN

Declaration

Source position: console.pas line 56

const SGR_GREEN = 32;


SGR_GREENBG

Declaration

Source position: console.pas line 66

const SGR_GREENBG = 42;


SGR_ITALIC

Declaration

Source position: console.pas line 43

const SGR_ITALIC = 3;


SGR_MAGENTA

Declaration

Source position: console.pas line 59

const SGR_MAGENTA = 35;


SGR_MAGENTABG

Declaration

Source position: console.pas line 69

const SGR_MAGENTABG = 45;


SGR_NEGATIVE

Declaration

Source position: console.pas line 45

const SGR_NEGATIVE = 7;


SGR_NORMAL

Declaration

Source position: console.pas line 47

const SGR_NORMAL = 22;


SGR_NOTITALIC

Declaration

Source position: console.pas line 48

const SGR_NOTITALIC = 23;


SGR_NOTUNDERSCORE

Declaration

Source position: console.pas line 49

const SGR_NOTUNDERSCORE = 24;


SGR_POSITIVE

Declaration

Source position: console.pas line 50

const SGR_POSITIVE = 27;


SGR_PRIMARY

Declaration

Source position: console.pas line 41

const SGR_PRIMARY = 0;


SGR_RED

Declaration

Source position: console.pas line 55

const SGR_RED = 31;


SGR_REDBG

Declaration

Source position: console.pas line 65

const SGR_REDBG = 41;


SGR_UNDERSCORE

Declaration

Source position: console.pas line 44

const SGR_UNDERSCORE = 4;


SGR_WHITE

Declaration

Source position: console.pas line 61

const SGR_WHITE = 37;


SGR_WHITEBG

Declaration

Source position: console.pas line 71

const SGR_WHITEBG = 47;


SGR_YELLOW

Declaration

Source position: console.pas line 57

const SGR_YELLOW = 33;


SGR_YELLOWBG

Declaration

Source position: console.pas line 67

const SGR_YELLOWBG = 43;


TBC_HCLRTAB

Declaration

Source position: console.pas line 104

const TBC_HCLRTAB = 0;


TBC_HCLRTABSALL

Declaration

Source position: console.pas line 105

const TBC_HCLRTABSALL = 3;


CONFLAG_DEFAULT

Declaration

Source position: conunit.pas line 34

const CONFLAG_DEFAULT = 0;


CONFLAG_NODRAW_ON_NEWSIZE

Declaration

Source position: conunit.pas line 35

const CONFLAG_NODRAW_ON_NEWSIZE = 1;


CONU_CHARMAP

Declaration

Source position: conunit.pas line 30

const CONU_CHARMAP = 1;


CONU_LIBRARY

Declaration

Source position: conunit.pas line 26

const CONU_LIBRARY = - 1;


CONU_SNIPMAP

Declaration

Source position: conunit.pas line 31

const CONU_SNIPMAP = 3;


CONU_STANDARD

Declaration

Source position: conunit.pas line 27

const CONU_STANDARD = 0;


Reference for unit 'conunit'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
console,
keymap,
inputevent,
intuition, | Screen and Window handling routines of intuition.library
agraphics; | Native Amiga graphic functions (graphics.library)


Reference for unit 'conunit': Constants

CONFLAG_DEFAULT

CONFLAG_NODRAW_ON_NEWSIZE

CONU_CHARMAP

CONU_LIBRARY

CONU_SNIPMAP

CONU_STANDARD

MAXTABS

PMB_ASM

PMB_AWM


Reference for unit 'conunit': Types

PConUnit

TConUnit


Index of all identifiers in unit 'conunit'

C M P T

C

CONFLAG_DEFAULT | CONU_CHARMAP | CONU_SNIPMAP
CONFLAG_NODRAW_ON_NEWSIZE | CONU_LIBRARY | CONU_STANDARD

M

MAXTABS

P

PConUnit PMB_ASM PMB_AWM

T

TConUnit


MAXTABS

Declaration

Source position: conunit.pas line 39

const MAXTABS = 80;


PConUnit

Declaration

Source position: conunit.pas line 44

type PConUnit = ^TConUnit;


PMB_ASM

Declaration

Source position: conunit.pas line 37

const PMB_ASM = M_LNM + 1;


PMB_AWM

Declaration

Source position: conunit.pas line 38

const PMB_AWM = PMB_ASM + 1;


TConUnit

Declaration

Source position: conunit.pas line 45

type TConUnit = record

  cu_MP: TMsgPort;

  cu_Window: PWindow;

  cu_XCP: SmallInt;

  cu_YCP: SmallInt;

  cu_XMax: SmallInt;

  cu_YMax: SmallInt;

  cu_XRSize: SmallInt;

  cu_YRSize: SmallInt;

  cu_XROrigin: SmallInt;

  cu_YROrigin: SmallInt;

  cu_XRExtant: SmallInt;

  cu_YRExtant: SmallInt;

  cu_XMinShrink: SmallInt;

  cu_YMinShrink: SmallInt;

  cu_XCCP: SmallInt;

  cu_YCCP: SmallInt;

  cu_KeyMapStruct: TKeyMap;

  cu_TabStops: array [0..MAXTABS-1] of Word;

  cu_Mask: ShortInt;

  cu_FgPen: ShortInt;

  cu_BgPen: ShortInt;

  cu_AOLPen: ShortInt;

  cu_DrawMode: ShortInt;

  cu_Obsolete1: ShortInt;

  cu_Obsolete2: Pointer;

  cu_Minterms: array [0..7] of Byte;

  cu_Font: PTextFont;

  cu_AlgoStyle: Byte;

  cu_TxFlags: Byte;

  cu_TxHeight: Word;

  cu_TxWidth: Word;

  cu_TxBaseline: Word;

  cu_TxSpacing: Word;

  cu_Modes: array [0..(PMB_AWM+7)div8-1] of Byte;

  cu_RawEvents: array [0..(IECLASS_MAX+7)div8-1] of Byte;

end;


BLTBMA_DESTALPHAVALUE

Tag for BltBitMapAlpha and BltBitMapRastPortAlpha

Declaration

Source position: cybergraphics.pas line 290

const BLTBMA_DESTALPHAVALUE = $88802002;


BLTBMA_GLOBALALPHA

Tag for BltBitMapAlpha and BltBitMapRastPortAlpha

Declaration

Source position: cybergraphics.pas line 289

const BLTBMA_GLOBALALPHA = BLTBMA_MIXLEVEL;


BLTBMA_MIXLEVEL

Tag for BltBitMapAlpha and BltBitMapRastPortAlpha

Declaration

Source position: cybergraphics.pas line 287

const BLTBMA_MIXLEVEL = $88802000;


BLTBMA_USESOURCEALPHA

Tag for BltBitMapAlpha and BltBitMapRastPortAlpha

Declaration

Source position: cybergraphics.pas line 288

const BLTBMA_USESOURCEALPHA = $88802001;


BMB_3DTARGET

Declaration

Source position: cybergraphics.pas line 221

const BMB_3DTARGET = 8;


BMB_ROOTMAP

Declaration

Source position: cybergraphics.pas line 218

const BMB_ROOTMAP = 5;


BMB_SPECIALFMT

Use for AllocBitmap

Declaration

Source position: cybergraphics.pas line 213

const BMB_SPECIALFMT = 7;

Description

If you specify the BMB_SPECIALFMT bit for AllocBitmap extended flag, the upper 8 bits of the flags longword contain information on the pixel format of the requested bitmap. The following pixel formats are available:

PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32

Many of this pixel formats are device specific and should not be used, recommended formats are PIXFMT_LUT8, PIXFMT_RGB16, PIXFMT_RGB24 and PIXFMT_ARGB32.


BMF_3DTARGET

Declaration

Source position: cybergraphics.pas line 222

const BMF_3DTARGET = 1 shl BMB_3DTARGET;


BMF_REQUESTVMEM

Declaration

Source position: cybergraphics.pas line 216

const BMF_REQUESTVMEM = BMF_MINPLANES or BMF_DISPLAYABLE;


BMF_ROOTMAP

Declaration

Source position: cybergraphics.pas line 219

const BMF_ROOTMAP = 1 shl BMB_ROOTMAP;


BMF_SPECIALFMT

see BMB_SPECIALFMT

Declaration

Source position: cybergraphics.pas line 214

const BMF_SPECIALFMT = 1 shl BMB_SPECIALFMT;


CTABFMT_XRGB8

CTabFormat for WriteLUTPixelArray

Declaration

Source position: cybergraphics.pas line 209

const CTABFMT_XRGB8 = 0;

Description

CTable is a pointer to a LongWord table which contains 256 entries. Each entry specifies the rgb colour value for the related index. The format is XXRRGGBB.

  • XX - unused
  • RR - 8-bit red component of the pixel
  • GG - 8-bit green component
  • BB - 8-bit blue component


CYBERGFX_INCLUDE_VERSION

Minimal version of supported cybergraphics.library

Declaration

Source position: cybergraphics.pas line 44

const CYBERGFX_INCLUDE_VERSION = 41;


CyberGfxBase

CyberGraphics library base structure

Declaration

Source position: cybergraphics.pas line 28

var CyberGfxBase: PLibrary = Nil;


CYBERGFXNAME

Name of cybergraphics main library

Declaration

Source position: cybergraphics.pas line 43

const CYBERGFXNAME = 'cybergraphics.library';


CYBERGRAPHICSNAME

Name of cybergraphics main library

Declaration

Source position: cybergraphics.pas line 31

const CYBERGRAPHICSNAME: PChar = 'cybergraphics.library';


CYBRBIDTG_BoardName

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 131

const CYBRBIDTG_BoardName = CYBRBIDTG_TB + 5;

Description

Value is PChar, specifies the card name directly. For example, pass "CVision3D" to get a CyberVision64/3D board ID

See also

BestCModeIDTagList

Calculate the best ModeID with given parameters


CYBRBIDTG_Depth

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 127

const CYBRBIDTG_Depth = CYBRBIDTG_TB + 0;

Description

Value is a LongWord describing the wanted depth the returned ModeID must support. Default = 8.

See also

BestCModeIDTagList

Calculate the best ModeID with given parameters


CYBRBIDTG_MonitorID

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 130

const CYBRBIDTG_MonitorID = CYBRBIDTG_TB + 3;

Description

Value is a Longword. If multiple graphics boards are installed in the system, you can choose the desired one with this tag

See also

BestCModeIDTagList

Calculate the best ModeID with given parameters


CYBRBIDTG_NominalHeight

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 129

const CYBRBIDTG_NominalHeight = CYBRBIDTG_TB + 2;

Description

Value is a Word describing the desired height the ModeID should have.

See also

BestCModeIDTagList

Calculate the best ModeID with given parameters


CYBRBIDTG_NominalWidth

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 128

const CYBRBIDTG_NominalWidth = CYBRBIDTG_TB + 1;

Description

Value is a Word describing the desired width the ModeID should have.

See also

BestCModeIDTagList

Calculate the best ModeID with given parameters


CYBRBIDTG_TB

Declaration

Source position: cybergraphics.pas line 125

const CYBRBIDTG_TB = TAG_USER + $50000;


CYBRIDATTR_BPPIX

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 96

const CYBRIDATTR_BPPIX = $80000005;


CYBRIDATTR_DEPTH

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 94

const CYBRIDATTR_DEPTH = $80000004;


CYBRIDATTR_HEIGHT

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 92

const CYBRIDATTR_HEIGHT = $80000003;


CYBRIDATTR_PIXFMT

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 88

const CYBRIDATTR_PIXFMT = $80000001;


CYBRIDATTR_WIDTH

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 90

const CYBRIDATTR_WIDTH = $80000002;


CYBRMATTR_BPPIX

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 67

const CYBRMATTR_BPPIX = $80000002;


CYBRMATTR_COLORMAP

Declaration

Source position: cybergraphics.pas line 83

const CYBRMATTR_COLORMAP = $8000000A;


CYBRMATTR_DEPTH

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 77

const CYBRMATTR_DEPTH = $80000007;


CYBRMATTR_DISPADR

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 69

const CYBRMATTR_DISPADR = $80000003;


CYBRMATTR_HEIGHT

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 75

const CYBRMATTR_HEIGHT = $80000006;


CYBRMATTR_ISCYBERGFX

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 79

const CYBRMATTR_ISCYBERGFX = $80000008;


CYBRMATTR_ISLINEARMEM

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 81

const CYBRMATTR_ISLINEARMEM = $80000009;


CYBRMATTR_PIXFMT

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 71

const CYBRMATTR_PIXFMT = $80000004;


CYBRMATTR_WIDTH

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 73

const CYBRMATTR_WIDTH = $80000005;


CYBRMATTR_XMOD

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 65

const CYBRMATTR_XMOD = $80000001;


CYBRMREQ_CancelText

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 119

const CYBRMREQ_CancelText = CYBRMREQ_TB + 22;

Description

Value is PChar as Label of the negative gadget in the requester. English default is 'Cancel'.

See also

CModeRequestTagList

Get screenmode from user using a requester.


CYBRMREQ_CModelArray

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 116

const CYBRMREQ_CModelArray = CYBRMREQ_TB + 6;

See also

AllocCModeListTagList | Get an exec list with requested modes
CModeRequestTagList | Get screenmode from user using a requester.


CYBRMREQ_MaxDepth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 107

const CYBRMREQ_MaxDepth = CYBRMREQ_TB + 1;

Description

Value is a word describing the maximum display depth to let the user choose. Default is 32.

See also

AllocCModeListTagList | Get an exec list with requested modes
CModeRequestTagList | Get screenmode from user using a requester.


CYBRMREQ_MaxHeight

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 115

const CYBRMREQ_MaxHeight = CYBRMREQ_TB + 5;

Description

Value is a longword describing the maximum display width to let the user choose. Default is 1200.

See also

AllocCModeListTagList | Get an exec list with requested modes
CModeRequestTagList | Get screenmode from user using a requester.


CYBRMREQ_MaxWidth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 111

const CYBRMREQ_MaxWidth = CYBRMREQ_TB + 3;

Description

Value is a longword describing the maximum display width to let the user choose. Default is 1600.

See also

AllocCModeListTagList | Get an exec list with requested modes
CModeRequestTagList | Get screenmode from user using a requester.


CYBRMREQ_MinDepth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 105

const CYBRMREQ_MinDepth = CYBRMREQ_TB + 0;

Description

Value is a word describing the minimum display depth to let the user choose. Default is 8.

See also

AllocCModeListTagList | Get an exec list with requested modes
CModeRequestTagList | Get screenmode from user using a requester.


CYBRMREQ_MinHeight

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 113

const CYBRMREQ_MinHeight = CYBRMREQ_TB + 4;

Description

Value is a longword describing the minimum display width to let the user choose. Default is 240.

See also

AllocCModeListTagList | Get an exec list with requested modes
CModeRequestTagList | Get screenmode from user using a requester.


CYBRMREQ_MinWidth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 109

const CYBRMREQ_MinWidth = CYBRMREQ_TB + 2;

Description

Value is a longword describing the minimum display width to let the user choose. Default is 320.

See also

AllocCModeListTagList | Get an exec list with requested modes
CModeRequestTagList | Get screenmode from user using a requester.


CYBRMREQ_OKText

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 118

const CYBRMREQ_OKText = CYBRMREQ_TB + 21;

Description

Value is PChar as Label of the positive gadget in the requester. English default is 'OK'.

See also

CModeRequestTagList

Get screenmode from user using a requester.


CYBRMREQ_Screen

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 121

const CYBRMREQ_Screen = CYBRMREQ_TB + 30;

Description

Value is PScreen setting the Screen on which to open the requester. Default locale will be used.

See also

CModeRequestTagList

Get screenmode from user using a requester.


CYBRMREQ_TB

Declaration

Source position: cybergraphics.pas line 100

const CYBRMREQ_TB = TAG_USER + $40000;


CYBRMREQ_WinTitle

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 117

const CYBRMREQ_WinTitle = CYBRMREQ_TB + 20;

Description

Value is PChar as Title to use for the requesting window.

See also

CModeRequestTagList

Get screenmode from user using a requester.


DESTALPHAVALUE_ONE

Value for Tag BLTBMA_DESTALPHAVALUE

Declaration

Source position: cybergraphics.pas line 293

const DESTALPHAVALUE_ONE = 1;

See also

BltBitMapAlpha | Blend a rectangular region of pixels in a BitMap. (v51)
BltBitMapRastPortAlpha | Blends from source bitmap to destination rastport. (v51)


DESTALPHAVALUE_UNDEFINED

Value for Tag BLTBMA_DESTALPHAVALUE

Declaration

Source position: cybergraphics.pas line 292

const DESTALPHAVALUE_UNDEFINED = 0;

See also

BltBitMapAlpha | Blend a rectangular region of pixels in a BitMap. (v51)
BltBitMapRastPortAlpha | Blends from source bitmap to destination rastport. (v51)


DESTALPHAVALUE_USEDEST

Value for Tag BLTBMA_DESTALPHAVALUE

Declaration

Source position: cybergraphics.pas line 295

const DESTALPHAVALUE_USEDEST = 3;

See also

BltBitMapAlpha | Blend a rectangular region of pixels in a BitMap. (v51)
BltBitMapRastPortAlpha | Blends from source bitmap to destination rastport. (v51)


DESTALPHAVALUE_USESOURCE

Value for Tag BLTBMA_DESTALPHAVALUE

Declaration

Source position: cybergraphics.pas line 294

const DESTALPHAVALUE_USESOURCE = 2;

See also

BltBitMapAlpha | Blend a rectangular region of pixels in a BitMap. (v51)
BltBitMapRastPortAlpha | Blends from source bitmap to destination rastport. (v51)


DPMS_OFF

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 170

const DPMS_OFF = 3;

See also

CVideoCtrlTagList

Control video output


DPMS_ON

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 164

const DPMS_ON = 0;

See also

CVideoCtrlTagList

Control video output


DPMS_STANDBY

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 166

const DPMS_STANDBY = 1;

See also

CVideoCtrlTagList

Control video output


DPMS_SUSPEND

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 168

const DPMS_SUSPEND = 2;

See also

CVideoCtrlTagList

Control video output


GRADIENT_NUMTYPES

Declaration

Source position: cybergraphics.pas line 270

const GRADIENT_NUMTYPES = 2;


GRADTYPE_HORIZONTAL

Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 262

const GRADTYPE_HORIZONTAL = 0;


GRADTYPE_LINEAR_ANGLE

Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 267

const GRADTYPE_LINEAR_ANGLE = 3;


GRADTYPE_RADIAL

Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 268

const GRADTYPE_RADIAL = 4;


GRADTYPE_RECTANGLE

Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 266

const GRADTYPE_RECTANGLE = 2;


GRADTYPE_VERTICAL

Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 263

const GRADTYPE_VERTICAL = 1;


Reference for unit 'CYBERGRAPHICS'

CyberGraphics System compatbible interface for MorphOS (cybergraphics.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility; | Tag Handling, Date routines in utility.library

Overview

CyberGraphics System compatbible interface for MorphOS (cybergraphics.library) Texts mainly from the official Autodocs http://aminet.net/package/dev/misc/CGraphX-DevKit.lha and MorphOS SDK.

Purpose

cybergraphics.library started as a videoboard extension for the native C= graphics.library. Because C= never completed/released a RTG compliant library (up to and including OS3.1 there was no way to add custom extension boards to the display database in a system friendly way), CyberGraphX patched some of the original graphics functions in order to add custom graphics board support in the system.

It also featured some new functions which were not available in the original graphics.library implementation. Due to the patch approach this new functions had to be moved into a new library base, namely cybergraphics.library. Both OS3.0 graphics.library v39 and OS 3.1 v40 were supported with this patch.

For the first time, CyberGraphX offered the possibility to open non CLUT screens with more than 256 colours which offered complete intuition level legacy compatibility. Nearly every function could be used on such views except some special blits which relied on planar bitmap graphics targets. This screens featured 8bit backwards compatibility which means that nearly every legacy, standard 8bit application even not aware of truecolour abilities worked on this improved screens. The pen allocation system, formerly used to lock certain colour indexes for shared/exclusive application access, had been fully mapped to this new display targets to allow maximum legacy compatibility.

The additional truecolour features could only be used with CyberGraphX aware applications, though. Since there was no similar approach which allowed easy adaption of existing applications, CyberGraphX was widely adopted as the standard interface for truecolour applications at that time.

There were attempts to imitate this efforts but those never caught up with the widely accepted CyberGraphX API.

MorphOS builds upon the above approach and still uses both graphics and cybergraphics library as it's graphics API layer. Additional functions have been added, especially in regard to alpha blending support and other additional eyecandy which is commonly used within MorphOS. Many of this functions are either GPU or AltiVec accelerated starting with Version 2 of MorphOS, dynamically enabled based on the underlying hardware which MorphOS has been started on.

Overview

This part only describes how to use the extended features of CyberGraphX. Anything else about programming graphics can be found in the original graphics.library documentation. Most graphics.library functions are extended to work on CyberGraphX's 15/16/24 bit rastports.

Bitmaps and CyberGraphX

Before OS 3.x there was no standard method to create bitmaps. It was up to the application programmer to allocate memory for the bitmap structure and to get the plane pointers by subsequent calls to AllocRaster()/gfx. A InitBitMap() call was available to initialize various elements in the bitmap structure.

Unfortunately some people didn't even use AllocRaster() and InitBitMap() to setup their bitmaps but used ExecAllocMem() and initialized the bitmap structure on their own.

Because there was only one certain bitplane format description, it was no problem to directly poke into the allocated planes. It even was no problem to alter the contents of the bitmap structure because the application had total control over the location and the contents of this structure and related plane pointers.

Starting with OS 3.x two new graphics calls were added to support bitmap creation and removal: AllocBitmap()/gfx and FreeBitmap()/gfx. With this calls the first step was made to allow custom bitmap formats. Before it was no problem at all to directly render into the planes or to make assumptions about the structure of the bitmap data. To get more information about the bitmap data an information retrieval call was added: GetBitmapAttr()/gfx. With this one you could get information on the width, height, depth and certain flags of the bitmap. This was the first step into the RTG direction. As soon as GetBitmapAttr(bm, BMA_FLAGS) didn't return BMF_STANDARD, the bitmap was not direct accessable anymore and could only be accessed by attachment to a rastport and subsequent rendering calls or by using blit calls with a standard amiga bitmap as destination.

Unfortunately many programs didn't follow these guide lines and didn't check for the BMF_STANDARD flag with OS3.0 and above. Up to now many programs still use the methods described at the beginning of this chapter. That's one reason why graphics extensions like CyberGraphX still have to fiddle around with planar to chunky conversions, even if the underlying hardware doesn't support planar graphics anymore. This often leads to dramatic speed losses with certain applications which often could be redundant if standard rendering calls were used.

So please use AllocBitmap()/FreeBitmap() whereever possible when running 3.x. It really gives you a major performance improvement in most cases when used on 3rd party display adapters. Don't forget to add a friend bitmap pointer whereever possible to allocate compatible bitmap structures.

With CyberGraphX you also have to add BMF_MINPLANES in the flags field of AllocBitmap()/gfx. This is due to bug in the standard picture.datatype which doesn't check for BMF_STANDARD and directly pokes into the bitplanes even if the returned bitmap is non planar ...... Using BMF_MINPLANES in a non CyberGraphX environment remains still compatible and should not lead to any problems, with CyberGraphX a chunky bitmap is returned, if a chunky friendbitmap is supplied. How to access the bitmap data will be discussed later on. Don't make assumptions on the bitmap contents before you have called the required CyberGraphX library calls!!

Besides the AllocBitmap() friend bitmap method, AllocBitmap() has been extended to allow for allocation of certain pixel format bitmaps when using CyberGraphX. With CyberGraphX, bitmaps aren't limited to planar image maps or 8 bit chunky data (which wasn't even available with the standard chipset/ graphics.library) anymore. It is also possible now to allocate device dependant pixel format bitmaps and standard 15/16/24/32 bit depth image maps. Therefore new bits in the 32bit flags field parameter of AllocBitmap() have been added. If you specify the BMB_SPECIALFMT bit (see includes), the upper 8 bits of the flags longword contain information on the pixel format of the requested bitmap. The following pixel formats are available:

PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32

Many of this pixel formats are device specific and should not be used, recommended formats are PIXFMT_LUT8, PIXFMT_RGB16, PIXFMT_RGB24 and PIXFMT_ARGB32.

Once allocated, you can attach the returned bitmap to a rastport and do rendering calls. It is not possible to attach this bitmap to a screen by supplying it as custom bitmap with OpenScreenTagList()!!

You are not allowed to directly poke into the bitmap image data as long as the bitmap isn't locked! The location and contents of the image data is subject to change and is only valid when it's locked by using the available locking calls (see autodocs). LockBitmapTagList()/UnLockBitmap() has been added for this purpose. You have to supply a taglist with LockBitmapTagList() which contains pointers to longwords which are filled with valid data if the call returns with a non-zero value. Only if a non-zero value is returned you are able to access the bitmap directly! Check the address you get back with the LBMI_BASEADDRESS tag. This is the base address you can do your rendering to. Get the value of the LBMI_PIXFMT ULONG field to get information on the colormodel you have to use for image rendering. All models have to be supported! The other fields give you information on the layout of the bitmap data. It should be no problem, to directly render into the bitmap anymore. Keep in mind that all this values are only valid until a subsequent call to UnLockBitmap(). Afterwards you have to lock the bitmap again. Don't hold this lock for longer than one frame! You may use the standard graphics.library bitmap blitting calls to copy the bitmap contents to another bitmap. Copying truecolour bitmaps into indexed colour chunky bitmaps is not supported by now.


Reference for unit 'CYBERGRAPHICS': Constants

BLTBMA_DESTALPHAVALUE | Tag for BltBitMapAlpha and BltBitMapRastPortAlpha
BLTBMA_GLOBALALPHA | Tag for BltBitMapAlpha and BltBitMapRastPortAlpha
BLTBMA_MIXLEVEL | Tag for BltBitMapAlpha and BltBitMapRastPortAlpha
BLTBMA_USESOURCEALPHA | Tag for BltBitMapAlpha and BltBitMapRastPortAlpha
BMB_3DTARGET |
BMB_ROOTMAP |
BMB_SPECIALFMT | Use for AllocBitmap
BMF_3DTARGET |
BMF_REQUESTVMEM |
BMF_ROOTMAP |
BMF_SPECIALFMT | see BMB_SPECIALFMT
CTABFMT_XRGB8 | CTabFormat for WriteLUTPixelArray
CYBERGFXNAME | Name of cybergraphics main library
CYBERGFX_INCLUDE_VERSION | Minimal version of supported cybergraphics.library
CYBERGRAPHICSNAME | Name of cybergraphics main library
CYBRBIDTG_BoardName | Tag for BestCModeIDTagList
CYBRBIDTG_Depth | Tag for BestCModeIDTagList
CYBRBIDTG_MonitorID | Tag for BestCModeIDTagList
CYBRBIDTG_NominalHeight | Tag for BestCModeIDTagList
CYBRBIDTG_NominalWidth | Tag for BestCModeIDTagList
CYBRBIDTG_TB |
CYBRIDATTR_BPPIX | Attribute for GetCyberIDAttr
CYBRIDATTR_DEPTH | Attribute for GetCyberIDAttr
CYBRIDATTR_HEIGHT | Attribute for GetCyberIDAttr
CYBRIDATTR_PIXFMT | Attribute for GetCyberIDAttr
CYBRIDATTR_WIDTH | Attribute for GetCyberIDAttr
CYBRMATTR_BPPIX | Attribute for GetCyberMapAttr
CYBRMATTR_COLORMAP |
CYBRMATTR_DEPTH | Attribute for GetCyberMapAttr
CYBRMATTR_DISPADR | Attribute for GetCyberMapAttr
CYBRMATTR_HEIGHT | Attribute for GetCyberMapAttr
CYBRMATTR_ISCYBERGFX | Attribute for GetCyberMapAttr
CYBRMATTR_ISLINEARMEM | Attribute for GetCyberMapAttr
CYBRMATTR_PIXFMT | Attribute for GetCyberMapAttr
CYBRMATTR_WIDTH | Attribute for GetCyberMapAttr
CYBRMATTR_XMOD | Attribute for GetCyberMapAttr
CYBRMREQ_CancelText | Tag for CModeRequestTagList
CYBRMREQ_CModelArray | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MaxDepth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MaxHeight | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MaxWidth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MinDepth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MinHeight | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MinWidth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_OKText | Tag for CModeRequestTagList
CYBRMREQ_Screen | Tag for CModeRequestTagList
CYBRMREQ_TB |
CYBRMREQ_WinTitle | Tag for CModeRequestTagList
DESTALPHAVALUE_ONE | Value for Tag BLTBMA_DESTALPHAVALUE
DESTALPHAVALUE_UNDEFINED | Value for Tag BLTBMA_DESTALPHAVALUE
DESTALPHAVALUE_USEDEST | Value for Tag BLTBMA_DESTALPHAVALUE
DESTALPHAVALUE_USESOURCE | Value for Tag BLTBMA_DESTALPHAVALUE
DPMS_OFF | Value for Tag SETVC_DPMSLevel
DPMS_ON | Value for Tag SETVC_DPMSLevel
DPMS_STANDBY | Value for Tag SETVC_DPMSLevel
DPMS_SUSPEND | Value for Tag SETVC_DPMSLevel
GRADIENT_NUMTYPES |
GRADTYPE_HORIZONTAL | Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray
GRADTYPE_LINEAR_ANGLE | Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray
GRADTYPE_RADIAL | Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray
GRADTYPE_RECTANGLE | Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray
GRADTYPE_VERTICAL | Tag Value for Tags PPAOPTAG_GRADIENTTYPE of ProcessPixelArray
LBMI_BASEADDRESS | Tag for LockBitMapTagList
LBMI_BYTESPERPIX | Tag for LockBitMapTagList
LBMI_BYTESPERROW | Tag for LockBitMapTagList
LBMI_DEPTH | Tag for LockBitMapTagList
LBMI_HEIGHT | Tag for LockBitMapTagList
LBMI_PIXFMT | Tag for LockBitMapTagList
LBMI_WIDTH | Tag for LockBitMapTagList
PIXFMT_ARGB32 |
PIXFMT_BGR15 |
PIXFMT_BGR15PC |
PIXFMT_BGR16 |
PIXFMT_BGR16PC |
PIXFMT_BGR24 |
PIXFMT_BGRA32 |
PIXFMT_LUT8 |
PIXFMT_RGB15 |
PIXFMT_RGB15PC |
PIXFMT_RGB15X |
PIXFMT_RGB16 |
PIXFMT_RGB16PC |
PIXFMT_RGB24 |
PIXFMT_RGBA32 |
POP_BLUR | Operation for ProcessPixelArray
POP_BRIGHTEN | Operation for ProcessPixelArray
POP_COLOR2GREY | Operation for ProcessPixelArray
POP_DARKEN | Operation for ProcessPixelArray
POP_GRADIENT | Operation for ProcessPixelArray
POP_NEGATIVE | Operation for ProcessPixelArray
POP_NEGFADE | Operation for ProcessPixelArray
POP_SETALPHA | Operation for ProcessPixelArray
POP_SHIFTRGB | Operation for ProcessPixelArray
POP_TINT | Operation for ProcessPixelArray
POP_TINTFADE | Operation for ProcessPixelArray
PPAOPTAG_FADEFULLSCALE | Tag for ProcessPixelArray
PPAOPTAG_FADEOFFSET | Tag for ProcessPixelArray
PPAOPTAG_GRADCOLOR1 | Tag for ProcessPixelArray
PPAOPTAG_GRADCOLOR2 | Tag for ProcessPixelArray
PPAOPTAG_GRADFULLSCALE | Tag for ProcessPixelArray
PPAOPTAG_GRADIENTTYPE | Tag for ProcessPixelArray
PPAOPTAG_GRADOFFSET | Tag for ProcessPixelArray
PPAOPTAG_GRADSYMCENTER | Tag for ProcessPixelArray
PPAOPTAG_RGBMASK | Tag for ProcessPixelArray
RECTFMT_ARGB | PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray
RECTFMT_GREY8 | PixelFormat for ScalePixelArray, WritePixelArray
RECTFMT_LUT8 | PixelFormat for ScalePixelArray, WritePixelArray
RECTFMT_RAW |
RECTFMT_RGB | PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray
RECTFMT_RGBA | PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray
RGBSHIFT_BGR | Value for Tag POP_SHIFTRGB
RGBSHIFT_BRG | Value for Tag POP_SHIFTRGB
RGBSHIFT_GBR | Value for Tag POP_SHIFTRGB
RGBSHIFT_GRB | Value for Tag POP_SHIFTRGB
RGBSHIFT_RBG | Value for Tag POP_SHIFTRGB
SETVC_DPMSLevel | Tag for CVideoCtrlTagList
UBMI_REALLYUNLOCK | Tag for UnLockBitMapTagList
UBMI_UPDATERECTS | Tag for UnLockBitMapTagList


Reference for unit 'CYBERGRAPHICS': Types

PCDrawMsg | Message passed to the DoCDrawMethodTagList() hook function
PCyberModeNode | List of available screen modes returned by AllocCModeListTagList
tCDrawMsg |
tCyberModeNode | List of available screen modes pointer to it returned by AllocCModeListTagList


LBMI_BASEADDRESS

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 180

const LBMI_BASEADDRESS = $84001007;

Description

Value is a PLongWord to get the bitmap base address.


LBMI_BYTESPERPIX

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 178

const LBMI_BYTESPERPIX = $84001005;

Description

Value is a PLongWord to get bitmaps amount of bytes per pixel data.


LBMI_BYTESPERROW

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 179

const LBMI_BYTESPERROW = $84001006;

Description

Value is a PLongWord to get the number of bytes per row for one bitmap line.


LBMI_DEPTH

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 176

const LBMI_DEPTH = $84001003;

Description

Value is a PLongWord to get bitmaps color depth.


LBMI_HEIGHT

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 175

const LBMI_HEIGHT = $84001002;

Description

Value is a PLongWord to get bitmaps height.


LBMI_PIXFMT

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 177

const LBMI_PIXFMT = $84001004;

Description

Value is a PLongWord to get bitmaps pixel format.


LBMI_WIDTH

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 174

const LBMI_WIDTH = $84001001;

Description

Value is a PLongWord to get bitmaps width.


PCDrawMsg

Message passed to the DoCDrawMethodTagList() hook function

Declaration

Source position: cybergraphics.pas line 191

type PCDrawMsg = ^tCDrawMsg;


PCyberModeNode

List of available screen modes returned by AllocCModeListTagList

Declaration

Source position: cybergraphics.pas line 49

type PCyberModeNode = ^tCyberModeNode;

See also

AllocCModeListTagList

Get an exec list with requested modes


PIXFMT_ARGB32

Declaration

Source position: cybergraphics.pas line 147

const PIXFMT_ARGB32 = 11;


PIXFMT_BGR15

Declaration

Source position: cybergraphics.pas line 138

const PIXFMT_BGR15 = 2;


PIXFMT_BGR15PC

Declaration

Source position: cybergraphics.pas line 140

const PIXFMT_BGR15PC = 4;


PIXFMT_BGR16

Declaration

Source position: cybergraphics.pas line 142

const PIXFMT_BGR16 = 6;


PIXFMT_BGR16PC

Declaration

Source position: cybergraphics.pas line 144

const PIXFMT_BGR16PC = 8;


PIXFMT_BGR24

Declaration

Source position: cybergraphics.pas line 146

const PIXFMT_BGR24 = 10;


PIXFMT_BGRA32

Declaration

Source position: cybergraphics.pas line 148

const PIXFMT_BGRA32 = 12;


PIXFMT_LUT8

Declaration

Source position: cybergraphics.pas line 135

const PIXFMT_LUT8 = 0;


PIXFMT_RGB15

Declaration

Source position: cybergraphics.pas line 136

const PIXFMT_RGB15 = 1;


PIXFMT_RGB15PC

Declaration

Source position: cybergraphics.pas line 139

const PIXFMT_RGB15PC = 3;


PIXFMT_RGB15X

Declaration

Source position: cybergraphics.pas line 137

const PIXFMT_RGB15X = 2;


PIXFMT_RGB16

Declaration

Source position: cybergraphics.pas line 141

const PIXFMT_RGB16 = 5;


PIXFMT_RGB16PC

Declaration

Source position: cybergraphics.pas line 143

const PIXFMT_RGB16PC = 7;


PIXFMT_RGB24

Declaration

Source position: cybergraphics.pas line 145

const PIXFMT_RGB24 = 9;


PIXFMT_RGBA32

Declaration

Source position: cybergraphics.pas line 149

const PIXFMT_RGBA32 = 13;


POP_BLUR

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 233

const POP_BLUR = 4;

Description

blur the rectangle.


POP_BRIGHTEN

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 229

const POP_BRIGHTEN = 0;

Description

brighten the rectangle. The amount of brightening to be done is defined by the value input, which must be in the range 0 to 255.


POP_COLOR2GREY

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 234

const POP_COLOR2GREY = 5;


POP_DARKEN

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 230

const POP_DARKEN = 1;

Description

darken the rectangle. The amount of darkening to be done is defined by the value input, which must be in the range 0 to 255.


POP_GRADIENT

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 238

const POP_GRADIENT = 9;

Description

apply a gradient to the rectangle. Gradient parameters are supplied through the taglist.


POP_NEGATIVE

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 235

const POP_NEGATIVE = 6;


POP_NEGFADE

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 236

const POP_NEGFADE = 7;


POP_SETALPHA

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 231

const POP_SETALPHA = 2;

Description

set the alpha channel value for all pixels in the rectangle to that specified in the value input. The valid range is 0 to 255.


POP_SHIFTRGB

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 239

const POP_SHIFTRGB = 10;

Description

Values: RGBSHIFT_BGR, RGBSHIFT_BRG, RGBSHIFT_GBR, RGBSHIFT_GRB, RGBSHIFT_RBG


POP_TINT

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 232

const POP_TINT = 3;

Description

tint the rectangle with an ARGB32 color (value input).


POP_TINTFADE

Operation for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 237

const POP_TINTFADE = 8;


PPAOPTAG_FADEFULLSCALE

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 257

const PPAOPTAG_FADEFULLSCALE = $85231020;


PPAOPTAG_FADEOFFSET

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 258

const PPAOPTAG_FADEOFFSET = $85231021;


PPAOPTAG_GRADCOLOR1

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 272

const PPAOPTAG_GRADCOLOR1 = $85231023;


PPAOPTAG_GRADCOLOR2

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 273

const PPAOPTAG_GRADCOLOR2 = $85231024;


PPAOPTAG_GRADFULLSCALE

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 275

const PPAOPTAG_GRADFULLSCALE = PPAOPTAG_FADEFULLSCALE;


PPAOPTAG_GRADIENTTYPE

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 260

const PPAOPTAG_GRADIENTTYPE = $85231022;


PPAOPTAG_GRADOFFSET

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 276

const PPAOPTAG_GRADOFFSET = PPAOPTAG_FADEOFFSET;


PPAOPTAG_GRADSYMCENTER

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 280

const PPAOPTAG_GRADSYMCENTER = $85231026;


PPAOPTAG_RGBMASK

Tag for ProcessPixelArray

Declaration

Source position: cybergraphics.pas line 278

const PPAOPTAG_RGBMASK = $85231025;


RECTFMT_ARGB

PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 155

const RECTFMT_ARGB = 2;

Description

4 bytes per pixel, one byte red, one blue, one byte green component and the first byte is alpha channel information. If the board does not support alpha channel a 0 is returned for alpha channel information


RECTFMT_GREY8

PixelFormat for ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 157

const RECTFMT_GREY8 = 4;

Description

1 byte per pixel, specifying grey scale value.


RECTFMT_LUT8

PixelFormat for ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 156

const RECTFMT_LUT8 = 3;

Description

1 byte per pixel, specifying the pen number. On screen depths > 8 bits the data is converted using the actual color lookup table.


RECTFMT_RAW

Declaration

Source position: cybergraphics.pas line 158

const RECTFMT_RAW = 5;


RECTFMT_RGB

PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 153

const RECTFMT_RGB = 0;

Description

3 bytes per pixel, one byte red, one blue and one byte green component


RECTFMT_RGBA

PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 154

const RECTFMT_RGBA = 1;

Description

4 bytes per pixel, one byte red, one blue, one byte green component and the last byte is alpha channel information which is 0 if the board does not support alpha channel


RGBSHIFT_BGR

Value for Tag POP_SHIFTRGB

Declaration

Source position: cybergraphics.pas line 246

const RGBSHIFT_BGR = 1;


RGBSHIFT_BRG

Value for Tag POP_SHIFTRGB

Declaration

Source position: cybergraphics.pas line 247

const RGBSHIFT_BRG = 2;


RGBSHIFT_GBR

Value for Tag POP_SHIFTRGB

Declaration

Source position: cybergraphics.pas line 248

const RGBSHIFT_GBR = 3;


RGBSHIFT_GRB

Value for Tag POP_SHIFTRGB

Declaration

Source position: cybergraphics.pas line 249

const RGBSHIFT_GRB = 4;


RGBSHIFT_RBG

Value for Tag POP_SHIFTRGB

Declaration

Source position: cybergraphics.pas line 250

const RGBSHIFT_RBG = 5;


SETVC_DPMSLevel

Tag for CVideoCtrlTagList

Declaration

Source position: cybergraphics.pas line 162

const SETVC_DPMSLevel = $88002001;


tCDrawMsg

Declaration

Source position: cybergraphics.pas line 192

type tCDrawMsg = record

  cdm_MemPtr: Pointer;

  cdm_offx: LongWord;

  cdm_offy: LongWord;

  cdm_xsize: LongWord;

  cdm_ysize: LongWord;

  cdm_BytesPerRow: Word;

  cdm_BytesPerPix: Word;

  cdm_ColorModel: Word;

end;


tCyberModeNode

List of available screen modes pointer to it returned by AllocCModeListTagList

Declaration

Source position: cybergraphics.pas line 50

type tCyberModeNode = record
Node: TNode; | Standard exec list structure.
ModeText: array [0..(DISPLAYNAMELEN)-1] of Char; | Name for this mode
DisplayID: LongWord; | Display id associated with the node
Width: Word; | Visible width
Height: Word; | Visible height
Depth: Word; | Display depth
DisplayTagList: PTagItem; | Taglist with extended ModeID information
end;

See also

AllocCModeListTagList | Get an exec list with requested modes
PCyberModeNode | List of available screen modes returned by AllocCModeListTagList


UBMI_REALLYUNLOCK

Tag for UnLockBitMapTagList

Declaration

Source position: cybergraphics.pas line 185

const UBMI_REALLYUNLOCK = $85001002;


UBMI_UPDATERECTS

Tag for UnLockBitMapTagList

Declaration

Source position: cybergraphics.pas line 184

const UBMI_UPDATERECTS = $85001001;


ADTA_Allocated

Declaration

Source position: datatypes.pas line 1043

const ADTA_Allocated = PDTA_Allocated;


ADTA_ColorRegisters

Declaration

Source position: datatypes.pas line 1038

const ADTA_ColorRegisters = PDTA_ColorRegisters;


ADTA_ColorTable

Declaration

Source position: datatypes.pas line 1041

const ADTA_ColorTable = PDTA_ColorTable;


ADTA_ColorTable2

Declaration

Source position: datatypes.pas line 1042

const ADTA_ColorTable2 = PDTA_ColorTable2;


ADTA_CRegs

Declaration

Source position: datatypes.pas line 1039

const ADTA_CRegs = PDTA_CRegs;


ADTA_Cycles

Declaration

Source position: datatypes.pas line 1084

const ADTA_Cycles = SDTA_Cycles;


ADTA_Depth

Declaration

Source position: datatypes.pas line 1064

const ADTA_Depth = ADTA_Dummy + 3;


ADTA_Dummy

Declaration

Source position: datatypes.pas line 1033

const ADTA_Dummy = DTA_Dummy + 600;


ADTA_Frame

Declaration

Source position: datatypes.pas line 1068

const ADTA_Frame = ADTA_Dummy + 5;


ADTA_FrameIncrement

Declaration

Source position: datatypes.pas line 1074

const ADTA_FrameIncrement = ADTA_Dummy + 7;


ADTA_Frames

Declaration

Source position: datatypes.pas line 1065

const ADTA_Frames = ADTA_Dummy + 4;


ADTA_FramesPerSecond

Declaration

Source position: datatypes.pas line 1071

const ADTA_FramesPerSecond = ADTA_Dummy + 6;


ADTA_GRegs

Declaration

Source position: datatypes.pas line 1040

const ADTA_GRegs = PDTA_GRegs;


ADTA_Height

Declaration

Source position: datatypes.pas line 1063

const ADTA_Height = ADTA_Dummy + 2;


ADTA_KeyFrame

Declaration

Source position: datatypes.pas line 1035

const ADTA_KeyFrame = PDTA_BitMap;


ADTA_LeftSample

Declaration

Source position: datatypes.pas line 1086

const ADTA_LeftSample = SDTA_LeftSample;


ADTA_ModeID

Declaration

Source position: datatypes.pas line 1034

const ADTA_ModeID = PDTA_ModeID;


ADTA_NumAlloc

Declaration

Source position: datatypes.pas line 1045

const ADTA_NumAlloc = PDTA_NumAlloc;


ADTA_NumColors

Declaration

Source position: datatypes.pas line 1044

const ADTA_NumColors = PDTA_NumColors;


ADTA_NumSparse

Declaration

Source position: datatypes.pas line 1053

const ADTA_NumSparse = PDTA_NumSparse;


ADTA_Period

Declaration

Source position: datatypes.pas line 1082

const ADTA_Period = SDTA_Period;


ADTA_PreloadFrameCount

Declaration

Source position: datatypes.pas line 1078

const ADTA_PreloadFrameCount = ADTA_Dummy + 8;


ADTA_Remap

Declaration

Source position: datatypes.pas line 1047

const ADTA_Remap = PDTA_Remap;


ADTA_RightSample

Declaration

Source position: datatypes.pas line 1087

const ADTA_RightSample = SDTA_RightSample;


ADTA_Sample

Declaration

Source position: datatypes.pas line 1080

const ADTA_Sample = SDTA_Sample;


ADTA_SampleLength

Declaration

Source position: datatypes.pas line 1081

const ADTA_SampleLength = SDTA_SampleLength;


ADTA_SamplesPerSec

Declaration

Source position: datatypes.pas line 1088

const ADTA_SamplesPerSec = SDTA_SamplesPerSec;


ADTA_Screen

Declaration

Source position: datatypes.pas line 1050

const ADTA_Screen = PDTA_Screen;


ADTA_SparseTable

Declaration

Source position: datatypes.pas line 1056

const ADTA_SparseTable = PDTA_SparseTable;


ADTA_Volume

Declaration

Source position: datatypes.pas line 1083

const ADTA_Volume = SDTA_Volume;


ADTA_Width

Declaration

Source position: datatypes.pas line 1062

const ADTA_Width = ADTA_Dummy + 1;


ADTM_Dummy

Declaration

Source position: datatypes.pas line 1178

const ADTM_Dummy = $700;


ADTM_LOADFRAME

Declaration

Source position: datatypes.pas line 1180

const ADTM_LOADFRAME = $701;


ADTM_LOADNEWFORMATFRAME

Declaration

Source position: datatypes.pas line 1199

const ADTM_LOADNEWFORMATFRAME = $707;


ADTM_LOCATE

Declaration

Source position: datatypes.pas line 1195

const ADTM_LOCATE = $706;


ADTM_PAUSE

Declaration

Source position: datatypes.pas line 1189

const ADTM_PAUSE = $704;


ADTM_START

Declaration

Source position: datatypes.pas line 1186

const ADTM_START = $703;


ADTM_STOP

Declaration

Source position: datatypes.pas line 1192

const ADTM_STOP = $705;


ADTM_UNLOADFRAME

Declaration

Source position: datatypes.pas line 1183

const ADTM_UNLOADFRAME = $702;


ADTM_UNLOADNEWFORMATFRAME

Declaration

Source position: datatypes.pas line 1202

const ADTM_UNLOADNEWFORMATFRAME = $708;


ANIMATIONDTCLASS

Declaration

Source position: datatypes.pas line 1028

const ANIMATIONDTCLASS: PChar = 'animation.datatype';


CMP_FIBDELTA

Declaration

Source position: datatypes.pas line 938

const CMP_FIBDELTA = 1;


CMP_NONE

Declaration

Source position: datatypes.pas line 937

const CMP_NONE = 0;


cmpByteRun1

Declaration

Source position: datatypes.pas line 820

const cmpByteRun1 = 1;


cmpByteRun2

Declaration

Source position: datatypes.pas line 821

const cmpByteRun2 = 2;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

cmpNone

Declaration

Source position: datatypes.pas line 819

const cmpNone = 0;


DataTypesBase

Declaration

Source position: datatypes.pas line 1261

var DataTypesBase: PLibrary = Nil;


DATATYPESCLASS

Declaration

Source position: datatypes.pas line 230

const DATATYPESCLASS: Pchar = 'datatypesclass';


DATATYPESNAME

Declaration

Source position: datatypes.pas line 1264

const DATATYPESNAME: PChar = 'datatypes.library';


DTA_ARexxPortName

Declaration

Source position: datatypes.pas line 398

const DTA_ARexxPortName = DTA_Dummy + 404;


DTA_BaseName

Declaration

Source position: datatypes.pas line 304

const DTA_BaseName = DTA_Dummy + 30;


DTA_Busy

Declaration

Source position: datatypes.pas line 296

const DTA_Busy = DTA_Dummy + 28;


DTA_Conductor

Declaration

Source position: datatypes.pas line 319

const DTA_Conductor = DTA_Dummy + 35;


DTA_ControlPanel

Declaration

Source position: datatypes.pas line 323

const DTA_ControlPanel = DTA_Dummy + 36;


DTA_Data

Declaration

Source position: datatypes.pas line 275

const DTA_Data = DTA_Dummy + 22;


DTA_DataType

Declaration

Source position: datatypes.pas line 353

const DTA_DataType = DTA_Dummy + 103;


DTA_DestCols

Declaration

Source position: datatypes.pas line 386

const DTA_DestCols = DTA_Dummy + 400;


DTA_DestRows

Declaration

Source position: datatypes.pas line 389

const DTA_DestRows = DTA_Dummy + 401;


DTA_Domain

Declaration

Source position: datatypes.pas line 354

const DTA_Domain = DTA_Dummy + 104;


DTA_Dummy

Declaration

Source position: datatypes.pas line 234

const DTA_Dummy = TAG_USER + $1000;


DTA_ErrorLevel

Declaration

Source position: datatypes.pas line 310

const DTA_ErrorLevel = DTA_Dummy + 32;


DTA_ErrorNumber

Declaration

Source position: datatypes.pas line 313

const DTA_ErrorNumber = DTA_Dummy + 33;


DTA_ErrorString

Declaration

Source position: datatypes.pas line 316

const DTA_ErrorString = DTA_Dummy + 34;


DTA_FrameInfo

Declaration

Source position: datatypes.pas line 370

const DTA_FrameInfo = DTA_Dummy + 116;


DTA_GroupID

Declaration

Source position: datatypes.pas line 307

const DTA_GroupID = DTA_Dummy + 31;


DTA_Handle

Declaration

Source position: datatypes.pas line 352

const DTA_Handle = DTA_Dummy + 102;


DTA_Height

Declaration

Source position: datatypes.pas line 361

const DTA_Height = DTA_Dummy + 108;


DTA_HorizUnit

Declaration

Source position: datatypes.pas line 262

const DTA_HorizUnit = DTA_Dummy + 18;


DTA_Immediate

Declaration

Source position: datatypes.pas line 328

const DTA_Immediate = DTA_Dummy + 37;


DTA_LayoutProc

Declaration

Source position: datatypes.pas line 293

const DTA_LayoutProc = DTA_Dummy + 27;


DTA_Left

Declaration

Source position: datatypes.pas line 358

const DTA_Left = DTA_Dummy + 105;


DTA_Methods

Declaration

Source position: datatypes.pas line 282

const DTA_Methods = DTA_Dummy + 24;


DTA_Name

Declaration

Source position: datatypes.pas line 350

const DTA_Name = DTA_Dummy + 100;


DTA_NodeName

Declaration

Source position: datatypes.pas line 265

const DTA_NodeName = DTA_Dummy + 19;


DTA_NominalHoriz

Declaration

Source position: datatypes.pas line 383

const DTA_NominalHoriz = DTA_Dummy + 125;


DTA_NominalVert

Declaration

Source position: datatypes.pas line 382

const DTA_NominalVert = DTA_Dummy + 124;


DTA_ObjAnnotation

Declaration

Source position: datatypes.pas line 365

const DTA_ObjAnnotation = DTA_Dummy + 111;


DTA_ObjAuthor

Declaration

Source position: datatypes.pas line 364

const DTA_ObjAuthor = DTA_Dummy + 110;


DTA_ObjCopyright

Declaration

Source position: datatypes.pas line 366

const DTA_ObjCopyright = DTA_Dummy + 112;


DTA_ObjectID

Declaration

Source position: datatypes.pas line 368

const DTA_ObjectID = DTA_Dummy + 114;


DTA_ObjName

Declaration

Source position: datatypes.pas line 363

const DTA_ObjName = DTA_Dummy + 109;


DTA_ObjVersion

Declaration

Source position: datatypes.pas line 367

const DTA_ObjVersion = DTA_Dummy + 113;


DTA_PrinterProc

Declaration

Source position: datatypes.pas line 290

const DTA_PrinterProc = DTA_Dummy + 26;


DTA_PrinterStatus

Declaration

Source position: datatypes.pas line 286

const DTA_PrinterStatus = DTA_Dummy + 25;


DTA_RastPort

Declaration

Source position: datatypes.pas line 395

const DTA_RastPort = DTA_Dummy + 403;


DTA_RelBottom

Declaration

Source position: datatypes.pas line 375

const DTA_RelBottom = DTA_Dummy + 118;


DTA_RelHeight

Declaration

Source position: datatypes.pas line 377

const DTA_RelHeight = DTA_Dummy + 120;


DTA_RelRight

Declaration

Source position: datatypes.pas line 374

const DTA_RelRight = DTA_Dummy + 117;


DTA_RelWidth

Declaration

Source position: datatypes.pas line 376

const DTA_RelWidth = DTA_Dummy + 119;


DTA_Repeat

Declaration

Source position: datatypes.pas line 332

const DTA_Repeat = DTA_Dummy + 38;


DTA_Reserved

Declaration

Source position: datatypes.pas line 347

const DTA_Reserved = DTA_Dummy + 41;


DTA_SelectDomain

Declaration

Source position: datatypes.pas line 379

const DTA_SelectDomain = DTA_Dummy + 121;


DTA_SourceAddress

Declaration

Source position: datatypes.pas line 339

const DTA_SourceAddress = DTA_Dummy + 39;


DTA_SourceSize

Declaration

Source position: datatypes.pas line 344

const DTA_SourceSize = DTA_Dummy + 40;


DTA_SourceType

Declaration

Source position: datatypes.pas line 351

const DTA_SourceType = DTA_Dummy + 101;


DTA_Special

Declaration

Source position: datatypes.pas line 392

const DTA_Special = DTA_Dummy + 402;


DTA_Sync

Declaration

Source position: datatypes.pas line 299

const DTA_Sync = DTA_Dummy + 29;


DTA_TextAttr

Declaration

Source position: datatypes.pas line 237

const DTA_TextAttr = DTA_Dummy + 10;


DTA_TextFont

Declaration

Source position: datatypes.pas line 278

const DTA_TextFont = DTA_Dummy + 23;


DTA_Title

Declaration

Source position: datatypes.pas line 268

const DTA_Title = DTA_Dummy + 20;


DTA_Top

Declaration

Source position: datatypes.pas line 359

const DTA_Top = DTA_Dummy + 106;


DTA_TopHoriz

Declaration

Source position: datatypes.pas line 253

const DTA_TopHoriz = DTA_Dummy + 15;


DTA_TopVert

Declaration

Source position: datatypes.pas line 241

const DTA_TopVert = DTA_Dummy + 11;


DTA_TotalHoriz

Declaration

Source position: datatypes.pas line 259

const DTA_TotalHoriz = DTA_Dummy + 17;


DTA_TotalPHoriz

Declaration

Source position: datatypes.pas line 381

const DTA_TotalPHoriz = DTA_Dummy + 123;


DTA_TotalPVert

Declaration

Source position: datatypes.pas line 380

const DTA_TotalPVert = DTA_Dummy + 122;


DTA_TotalVert

Declaration

Source position: datatypes.pas line 247

const DTA_TotalVert = DTA_Dummy + 13;


DTA_TriggerMethods

Declaration

Source position: datatypes.pas line 271

const DTA_TriggerMethods = DTA_Dummy + 21;


DTA_UserData

Declaration

Source position: datatypes.pas line 369

const DTA_UserData = DTA_Dummy + 115;


DTA_VertUnit

Declaration

Source position: datatypes.pas line 250

const DTA_VertUnit = DTA_Dummy + 14;


DTA_VisibleHoriz

Declaration

Source position: datatypes.pas line 256

const DTA_VisibleHoriz = DTA_Dummy + 16;


DTA_VisibleVert

Declaration

Source position: datatypes.pas line 244

const DTA_VisibleVert = DTA_Dummy + 12;


DTA_Width

Declaration

Source position: datatypes.pas line 360

const DTA_Width = DTA_Dummy + 107;


DTERROR_COULDNT_OPEN

Declaration

Source position: datatypes.pas line 212

const DTERROR_COULDNT_OPEN = 2002;


DTERROR_COULDNT_OPEN_CLIPBOARD

Declaration

Source position: datatypes.pas line 216

const DTERROR_COULDNT_OPEN_CLIPBOARD = 2004;


DTERROR_COULDNT_SAVE

Declaration

Source position: datatypes.pas line 211

const DTERROR_COULDNT_SAVE = 2001;


DTERROR_COULDNT_SEND_MESSAGE

Declaration

Source position: datatypes.pas line 213

const DTERROR_COULDNT_SEND_MESSAGE = 2003;


DTERROR_INVALID_DATA

Declaration

Source position: datatypes.pas line 220

const DTERROR_INVALID_DATA = 2008;


DTERROR_NOT_AVAILABLE

Declaration

Source position: datatypes.pas line 223

const DTERROR_NOT_AVAILABLE = 2009;


DTERROR_NOT_ENOUGH_DATA

Declaration

Source position: datatypes.pas line 219

const DTERROR_NOT_ENOUGH_DATA = 2007;


DTERROR_Reserved

Declaration

Source position: datatypes.pas line 217

const DTERROR_Reserved = 2005;


DTERROR_UNKNOWN_COMPRESSION

Declaration

Source position: datatypes.pas line 218

const DTERROR_UNKNOWN_COMPRESSION = 2006;


DTERROR_UNKNOWN_DATATYPE

Declaration

Source position: datatypes.pas line 210

const DTERROR_UNKNOWN_DATATYPE = 2000;


DTF_ASCII

Declaration

Source position: datatypes.pas line 62

const DTF_ASCII = $0001;


DTF_BINARY

Declaration

Source position: datatypes.pas line 61

const DTF_BINARY = $0000;


DTF_CASE

Declaration

Source position: datatypes.pas line 67

const DTF_CASE = $0010;


DTF_IFF

Declaration

Source position: datatypes.pas line 63

const DTF_IFF = $0002;


DTF_MISC

Declaration

Source position: datatypes.pas line 64

const DTF_MISC = $0003;


DTF_SYSTEM1

Declaration

Source position: datatypes.pas line 70

const DTF_SYSTEM1 = $1000;


DTF_TYPE_MASK

Declaration

Source position: datatypes.pas line 60

const DTF_TYPE_MASK = $000F;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DTHSIZE

Declaration

Source position: datatypes.pas line 55

const DTHSIZE = 32;


DTM_ABORTPRINT

Declaration

Source position: datatypes.pas line 486

const DTM_ABORTPRINT = $609;


DTM_ASYNCLAYOUT

Declaration

Source position: datatypes.pas line 476

const DTM_ASYNCLAYOUT = $603;


DTM_CLEARSELECTED

Declaration

Source position: datatypes.pas line 482

const DTM_CLEARSELECTED = $606;


DTM_COPY

Declaration

Source position: datatypes.pas line 484

const DTM_COPY = $607;


DTM_DISPOSEMEMBER

Declaration

Source position: datatypes.pas line 489

const DTM_DISPOSEMEMBER = $611;


DTM_DRAW

Declaration

Source position: datatypes.pas line 495

const DTM_DRAW = $641;


DTM_Dummy

Declaration

Source position: datatypes.pas line 467

const DTM_Dummy = $600;


DTM_FRAMEBOX

Declaration

Source position: datatypes.pas line 470

const DTM_FRAMEBOX = $601;


DTM_GOTO

Declaration

Source position: datatypes.pas line 491

const DTM_GOTO = $630;


DTM_NEWMEMBER

Declaration

Source position: datatypes.pas line 488

const DTM_NEWMEMBER = $610;


DTM_OBTAINDRAWINFO

Declaration

Source position: datatypes.pas line 494

const DTM_OBTAINDRAWINFO = $640;


DTM_PRINT

Declaration

Source position: datatypes.pas line 485

const DTM_PRINT = $608;


DTM_PROCLAYOUT

Declaration

Source position: datatypes.pas line 473

const DTM_PROCLAYOUT = $602;


DTM_RELEASEDRAWINFO

Declaration

Source position: datatypes.pas line 496

const DTM_RELEASEDRAWINFO = $642;


DTM_REMOVEDTOBJECT

Declaration

Source position: datatypes.pas line 479

const DTM_REMOVEDTOBJECT = $604;


DTM_SELECT

Declaration

Source position: datatypes.pas line 481

const DTM_SELECT = $605;


DTM_TRIGGER

Declaration

Source position: datatypes.pas line 492

const DTM_TRIGGER = $631;


DTM_WRITE

Declaration

Source position: datatypes.pas line 498

const DTM_WRITE = $650;


DTMSG_TYPE_OFFSET

Declaration

Source position: datatypes.pas line 226

const DTMSG_TYPE_OFFSET = 2100;


DTSIF_DRAGGING

Declaration

Source position: datatypes.pas line 443

const DTSIF_DRAGGING = 4;


DTSIF_DRAGSELECT

Declaration

Source position: datatypes.pas line 444

const DTSIF_DRAGSELECT = 8;


DTSIF_HIGHLIGHT

Declaration

Source position: datatypes.pas line 446

const DTSIF_HIGHLIGHT = 16;


DTSIF_LAYOUT

Declaration

Source position: datatypes.pas line 438

const DTSIF_LAYOUT = 1;


DTSIF_LAYOUTPROC

Declaration

Source position: datatypes.pas line 452

const DTSIF_LAYOUTPROC = 64;


DTSIF_NEWSIZE

Declaration

Source position: datatypes.pas line 441

const DTSIF_NEWSIZE = 2;


DTSIF_PRINTING

Declaration

Source position: datatypes.pas line 449

const DTSIF_PRINTING = 32;


DTST_CLIPBOARD

Declaration

Source position: datatypes.pas line 406

const DTST_CLIPBOARD = 3;


DTST_FILE

Declaration

Source position: datatypes.pas line 405

const DTST_FILE = 2;


DTST_HOTLINK

Declaration

Source position: datatypes.pas line 407

const DTST_HOTLINK = 4;


DTST_MEMORY

Declaration

Source position: datatypes.pas line 408

const DTST_MEMORY = 5;


DTST_RAM

Declaration

Source position: datatypes.pas line 404

const DTST_RAM = 1;


DTWM_IFF

Declaration

Source position: datatypes.pas line 651

const DTWM_IFF = 0;


DTWM_RAW

Declaration

Source position: datatypes.pas line 654

const DTWM_RAW = 1;


FIF_REMAPPABLE

Declaration

Source position: datatypes.pas line 524

const FIF_REMAPPABLE = $4;


FIF_SCALABLE

Declaration

Source position: datatypes.pas line 522

const FIF_SCALABLE = $1;


FIF_SCROLLABLE

Declaration

Source position: datatypes.pas line 523

const FIF_SCROLLABLE = $2;


GID_ANIMATION

Declaration

Source position: datatypes.pas line 112

const GID_ANIMATION = 1634625901;


GID_DOCUMENT

Declaration

Source position: datatypes.pas line 97

const GID_DOCUMENT = 1685021557;


GID_INSTRUMENT

Declaration

Source position: datatypes.pas line 103

const GID_INSTRUMENT = 1768846196;


GID_MOVIE

Declaration

Source position: datatypes.pas line 115

const GID_MOVIE = 1836021353;


GID_MUSIC

Declaration

Source position: datatypes.pas line 106

const GID_MUSIC = 1836413801;


GID_PICTURE

Declaration

Source position: datatypes.pas line 109

const GID_PICTURE = 1885954932;


GID_SOUND

Declaration

Source position: datatypes.pas line 100

const GID_SOUND = 1936684398;


GID_SYSTEM

Declaration

Source position: datatypes.pas line 91

const GID_SYSTEM = 1937339252;


GID_TEXT

Declaration

Source position: datatypes.pas line 94

const GID_TEXT = 1952807028;


ID_8SVX

Declaration

Source position: datatypes.pas line 962

const ID_8SVX = 944985688;


ID_ANHD

Declaration

Source position: datatypes.pas line 1093

const ID_ANHD = 1095649348;


ID_ANIM

Declaration

Source position: datatypes.pas line 1092

const ID_ANIM = 1095649613;


ID_BMHD

Declaration

Source position: datatypes.pas line 855

const ID_BMHD = 1112361028;


ID_BODY

Declaration

Source position: datatypes.pas line 856

const ID_BODY = 1112491097;


ID_CAMG

Declaration

Source position: datatypes.pas line 862

const ID_CAMG = 1128353095;


ID_CHAN

Declaration

Source position: datatypes.pas line 964

const ID_CHAN = $4348414E;


ID_CHRS

Declaration

Source position: datatypes.pas line 1024

const ID_CHRS = 1128813139;


ID_CMAP

Declaration

Source position: datatypes.pas line 857

const ID_CMAP = 1129136464;


ID_CODE

Declaration

Source position: datatypes.pas line 121

const ID_CODE = 1146372932;


ID_CRNG

Declaration

Source position: datatypes.pas line 858

const ID_CRNG = 1129467463;


ID_DEST

Declaration

Source position: datatypes.pas line 861

const ID_DEST = 1145394004;


ID_DLTA

Declaration

Source position: datatypes.pas line 1094

const ID_DLTA = 1145852993;


ID_DTHD

Declaration

Source position: datatypes.pas line 37

const ID_DTHD = 1146374212;


ID_DTYP

Declaration

Source position: datatypes.pas line 33

const ID_DTYP = 1146378576;


ID_FTXT

Declaration

Source position: datatypes.pas line 1023

const ID_FTXT = 1179932756;


ID_GRAB

Declaration

Source position: datatypes.pas line 859

const ID_GRAB = 1196572994;


ID_ILBM

Declaration

Source position: datatypes.pas line 854

const ID_ILBM = 1229734477;


ID_NAME

Declaration

Source position: datatypes.pas line 205

const ID_NAME = 1312902469;


ID_SPRT

Declaration

Source position: datatypes.pas line 860

const ID_SPRT = 1397772884;


ID_TAGS

Declaration

Source position: datatypes.pas line 177

const ID_TAGS = 1146377287;


ID_TOOL

Declaration

Source position: datatypes.pas line 149

const ID_TOOL = 1146377292;


ID_VHDR

Declaration

Source position: datatypes.pas line 963

const ID_VHDR = 1447576658;


Reference for unit 'datatypes'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
AmigaDOS, | File and directory handling routines and types (dos.library)
intuition, | Screen and Window handling routines of intuition.library
utility, | Tag Handling, Date routines in utility.library
agraphics; | Native Amiga graphic functions (graphics.library)


Reference for unit 'datatypes': Constants

ADTA_Allocated

ADTA_ColorRegisters

ADTA_ColorTable

ADTA_ColorTable2

ADTA_CRegs

ADTA_Cycles

ADTA_Depth

ADTA_Dummy

ADTA_Frame

ADTA_FrameIncrement

ADTA_Frames

ADTA_FramesPerSecond

ADTA_GRegs

ADTA_Height

ADTA_KeyFrame

ADTA_LeftSample

ADTA_ModeID

ADTA_NumAlloc

ADTA_NumColors

ADTA_NumSparse

ADTA_Period

ADTA_PreloadFrameCount

ADTA_Remap

ADTA_RightSample

ADTA_Sample

ADTA_SampleLength

ADTA_SamplesPerSec

ADTA_Screen

ADTA_SparseTable

ADTA_Volume

ADTA_Width

ADTM_Dummy

ADTM_LOADFRAME

ADTM_LOADNEWFORMATFRAME

ADTM_LOCATE

ADTM_PAUSE

ADTM_START

ADTM_STOP

ADTM_UNLOADFRAME

ADTM_UNLOADNEWFORMATFRAME

ANIMATIONDTCLASS

cmpByteRun1

cmpByteRun2

cmpNone

CMP_FIBDELTA

CMP_NONE

DATATYPESCLASS

DATATYPESNAME

DTA_ARexxPortName

DTA_BaseName

DTA_Busy

DTA_Conductor

DTA_ControlPanel

DTA_Data

DTA_DataType

DTA_DestCols

DTA_DestRows

DTA_Domain

DTA_Dummy

DTA_ErrorLevel

DTA_ErrorNumber

DTA_ErrorString

DTA_FrameInfo

DTA_GroupID

DTA_Handle

DTA_Height

DTA_HorizUnit

DTA_Immediate

DTA_LayoutProc

DTA_Left

DTA_Methods

DTA_Name

DTA_NodeName

DTA_NominalHoriz

DTA_NominalVert

DTA_ObjAnnotation

DTA_ObjAuthor

DTA_ObjCopyright

DTA_ObjectID

DTA_ObjName

DTA_ObjVersion

DTA_PrinterProc

DTA_PrinterStatus

DTA_RastPort

DTA_RelBottom

DTA_RelHeight

DTA_RelRight

DTA_RelWidth

DTA_Repeat

DTA_Reserved

DTA_SelectDomain

DTA_SourceAddress

DTA_SourceSize

DTA_SourceType

DTA_Special

DTA_Sync

DTA_TextAttr

DTA_TextFont

DTA_Title

DTA_Top

DTA_TopHoriz

DTA_TopVert

DTA_TotalHoriz

DTA_TotalPHoriz

DTA_TotalPVert

DTA_TotalVert

DTA_TriggerMethods

DTA_UserData

DTA_VertUnit

DTA_VisibleHoriz

DTA_VisibleVert

DTA_Width

DTERROR_COULDNT_OPEN

DTERROR_COULDNT_OPEN_CLIPBOARD

DTERROR_COULDNT_SAVE

DTERROR_COULDNT_SEND_MESSAGE

DTERROR_INVALID_DATA

DTERROR_NOT_AVAILABLE

DTERROR_NOT_ENOUGH_DATA

DTERROR_Reserved

DTERROR_UNKNOWN_COMPRESSION

DTERROR_UNKNOWN_DATATYPE

DTF_ASCII

DTF_BINARY

DTF_CASE

DTF_IFF

DTF_MISC

DTF_SYSTEM1

DTF_TYPE_MASK

DTHSIZE

DTMSG_TYPE_OFFSET

DTM_ABORTPRINT

DTM_ASYNCLAYOUT

DTM_CLEARSELECTED

DTM_COPY

DTM_DISPOSEMEMBER

DTM_DRAW

DTM_Dummy

DTM_FRAMEBOX

DTM_GOTO

DTM_NEWMEMBER

DTM_OBTAINDRAWINFO

DTM_PRINT

DTM_PROCLAYOUT

DTM_RELEASEDRAWINFO

DTM_REMOVEDTOBJECT

DTM_SELECT

DTM_TRIGGER

DTM_WRITE

DTSIF_DRAGGING

DTSIF_DRAGSELECT

DTSIF_HIGHLIGHT

DTSIF_LAYOUT

DTSIF_LAYOUTPROC

DTSIF_NEWSIZE

DTSIF_PRINTING

DTST_CLIPBOARD

DTST_FILE

DTST_HOTLINK

DTST_MEMORY

DTST_RAM

DTWM_IFF

DTWM_RAW

FIF_REMAPPABLE

FIF_SCALABLE

FIF_SCROLLABLE

GID_ANIMATION

GID_DOCUMENT

GID_INSTRUMENT

GID_MOVIE

GID_MUSIC

GID_PICTURE

GID_SOUND

GID_SYSTEM

GID_TEXT

ID_8SVX

ID_ANHD

ID_ANIM

ID_BMHD

ID_BODY

ID_CAMG

ID_CHAN

ID_CHRS

ID_CMAP

ID_CODE

ID_CRNG

ID_DEST

ID_DLTA

ID_DTHD

ID_DTYP

ID_FTXT

ID_GRAB

ID_ILBM

ID_NAME

ID_SPRT

ID_TAGS

ID_TOOL

ID_VHDR

LNF_LF

LNF_LINK

LNF_OBJECT

LNF_SELECTED

mskHasAlpha

mskHasMask

mskHasTransparentColor

mskLasso

mskNone

PBPAFMT_ARGB

PBPAFMT_GREY8

PBPAFMT_LUT8

PBPAFMT_RGB

PBPAFMT_RGBA

PDTANUMPICTURES_Unknown

PDTA_Allocated

PDTA_AllocatedPens

PDTA_BitMap

PDTA_BitMapHeader

PDTA_ClassBitMap

PDTA_ColorRegisters

PDTA_ColorTable

PDTA_ColorTable2

PDTA_CRegs

PDTA_DestBitMap

PDTA_DestMode

PDTA_Displayable

PDTA_DitherQuality

PDTA_FreeSourceBitMap

PDTA_GetNumPictures

PDTA_Grab

PDTA_GRegs

PDTA_MaskPlane

PDTA_MaxDitherPens

PDTA_ModeID

PDTA_NumAlloc

PDTA_NumColors

PDTA_NumSparse

PDTA_Remap

PDTA_ScaleQuality

PDTA_Screen

PDTA_SourceMode

PDTA_SparseTable

PDTA_UseFriendBitMap

PDTA_WhichPicture

PDTM_Dummy

PDTM_READPIXELARRAY

PDTM_WRITEPIXELARRAY

PICTUREDTCLASS

PMODE_V42

PMODE_V43

SAMPLETYPE_Left

SAMPLETYPE_Right

SAMPLETYPE_Stereo

SDTA_Continuous

SDTA_Cycles

SDTA_Dummy

SDTA_FreeSampleData

SDTA_LeftSample

SDTA_Pan

SDTA_Period

SDTA_ReplayPeriod

SDTA_RightSample

SDTA_Sample

SDTA_SampleLength

SDTA_SamplesPerSec

SDTA_SignalBit

SDTA_SignalBitMask

SDTA_SignalBitNumber

SDTA_SignalTask

SDTA_SyncSampleChange

SDTA_VoiceHeader

SDTA_Volume

SOUNDDTCLASS

STM_ACTIVATE_FIELD

STM_BROWSE_NEXT

STM_BROWSE_PREV

STM_COMMAND

STM_CONTENTS

STM_FASTFORWARD

STM_INDEX

STM_LOCATE

STM_NEXT_FIELD

STM_PAUSE

STM_PLAY

STM_PREV_FIELD

STM_RESUME

STM_RETRACE

STM_REWIND

STM_STOP

TDTA_Buffer

TDTA_BufferLen

TDTA_LineList

TDTA_WordDelim

TDTA_WordSelect

TDTA_WordWrap

TEXTDTCLASS

TF_LAUNCH_MASK

TF_RX

TF_SHELL

TF_WORKBENCH

TSIZE

TW_BROWSE

TW_EDIT

TW_INFO

TW_MAIL

TW_PRINT


Reference for unit 'datatypes': Types

padtFrame

PadtNewFormatFrame

padtStart

pAnimHeader

pBitMapHeader

pColorRegister

pDataType

pDataTypeHeader

pdtDraw

pdtFrameBox

pdtGeneral

pdtGoto

pDTHookContext

pDTMethod

pdtPrint

PdtReleaseDrawInfo

pdtSelect

pDTSpecialInfo

pdtTrigger

pdtWrite

pFrameInfo

pLine

pprinterIO

pTool

pToolNode

pVoiceHeader

tadtFrame

tadtNewFormatFrame

tadtStart

tAnimHeader

tBitMapHeader

tColorRegister

tDataType

tDataTypeHeader

tdtDraw

tdtFrameBox

tdtGeneral

tdtGoto

tDTHookContext

tDTMethod

tdtPrint

TdtReleaseDrawInfo

tdtSelect

tDTSpecialInfo

tdtTrigger

tdtWrite

tFrameInfo

tLine

tprinterIO

tTool

tToolNode

tVoiceHeader


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

LNF_LF

Declaration

Source position: datatypes.pas line 1009

const LNF_LF = 1;


LNF_LINK

Declaration

Source position: datatypes.pas line 1012

const LNF_LINK = 2;


LNF_OBJECT

Declaration

Source position: datatypes.pas line 1015

const LNF_OBJECT = 4;


LNF_SELECTED

Declaration

Source position: datatypes.pas line 1018

const LNF_SELECTED = 8;


mskHasAlpha

Declaration

Source position: datatypes.pas line 816

const mskHasAlpha = 4;


mskHasMask

Declaration

Source position: datatypes.pas line 813

const mskHasMask = 1;


mskHasTransparentColor

Declaration

Source position: datatypes.pas line 814

const mskHasTransparentColor = 2;


mskLasso

Declaration

Source position: datatypes.pas line 815

const mskLasso = 3;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

mskNone

Declaration

Source position: datatypes.pas line 812

const mskNone = 0;


padtFrame

Declaration

Source position: datatypes.pas line 1207

type padtFrame = ^tadtFrame;


PadtNewFormatFrame

Declaration

Source position: datatypes.pas line 1230

type PadtNewFormatFrame = ^tadtNewFormatFrame;


padtStart

Declaration

Source position: datatypes.pas line 1252

type padtStart = ^tadtStart;


pAnimHeader

Declaration

Source position: datatypes.pas line 1100

type pAnimHeader = ^tAnimHeader;


pBitMapHeader

Declaration

Source position: datatypes.pas line 825

type pBitMapHeader = ^tBitMapHeader;


PBPAFMT_ARGB

Declaration

Source position: datatypes.pas line 806

const PBPAFMT_ARGB = 2;


PBPAFMT_GREY8

Declaration

Source position: datatypes.pas line 808

const PBPAFMT_GREY8 = 4;


PBPAFMT_LUT8

Declaration

Source position: datatypes.pas line 807

const PBPAFMT_LUT8 = 3;


PBPAFMT_RGB

Declaration

Source position: datatypes.pas line 804

const PBPAFMT_RGB = 0;


PBPAFMT_RGBA

Declaration

Source position: datatypes.pas line 805

const PBPAFMT_RGBA = 1;


pColorRegister

Declaration

Source position: datatypes.pas line 845

type pColorRegister = ^tColorRegister;


pDataType

Declaration

Source position: datatypes.pas line 182

type pDataType = ^tDataType;


pDataTypeHeader

Declaration

Source position: datatypes.pas line 40

type pDataTypeHeader = ^tDataTypeHeader;


PDTA_Allocated

Declaration

Source position: datatypes.pas line 699

const PDTA_Allocated = DTA_Dummy + 208;


PDTA_AllocatedPens

Declaration

Source position: datatypes.pas line 751

const PDTA_AllocatedPens = DTA_Dummy + 223;


PDTA_BitMap

Declaration

Source position: datatypes.pas line 668

const PDTA_BitMap = DTA_Dummy + 202;


PDTA_BitMapHeader

Declaration

Source position: datatypes.pas line 666

const PDTA_BitMapHeader = DTA_Dummy + 201;


PDTA_ClassBitMap

Declaration

Source position: datatypes.pas line 722

const PDTA_ClassBitMap = DTA_Dummy + 216;


PDTA_ColorRegisters

Declaration

Source position: datatypes.pas line 673

const PDTA_ColorRegisters = DTA_Dummy + 203;


PDTA_ColorTable

Declaration

Source position: datatypes.pas line 688

const PDTA_ColorTable = DTA_Dummy + 206;


PDTA_ColorTable2

Declaration

Source position: datatypes.pas line 696

const PDTA_ColorTable2 = DTA_Dummy + 207;


PDTA_CRegs

Declaration

Source position: datatypes.pas line 676

const PDTA_CRegs = DTA_Dummy + 204;


PDTA_DestBitMap

Declaration

Source position: datatypes.pas line 719

const PDTA_DestBitMap = DTA_Dummy + 215;


PDTA_DestMode

Declaration

Source position: datatypes.pas line 771

const PDTA_DestMode = DTA_Dummy + 251;


PDTA_Displayable

Declaration

Source position: datatypes.pas line 779

const PDTA_Displayable = DTA_Dummy + 259;


PDTA_DitherQuality

Declaration

Source position: datatypes.pas line 748

const PDTA_DitherQuality = DTA_Dummy + 222;


PDTA_FreeSourceBitMap

Declaration

Source position: datatypes.pas line 713

const PDTA_FreeSourceBitMap = DTA_Dummy + 213;


PDTA_GetNumPictures

Declaration

Source position: datatypes.pas line 740

const PDTA_GetNumPictures = DTA_Dummy + 220;


PDTA_Grab

Declaration

Source position: datatypes.pas line 716

const PDTA_Grab = DTA_Dummy + 214;


PDTA_GRegs

Declaration

Source position: datatypes.pas line 683

const PDTA_GRegs = DTA_Dummy + 205;


PDTA_MaskPlane

Declaration

Source position: datatypes.pas line 777

const PDTA_MaskPlane = DTA_Dummy + 258;


PDTA_MaxDitherPens

Declaration

Source position: datatypes.pas line 743

const PDTA_MaxDitherPens = DTA_Dummy + 221;


PDTA_ModeID

Declaration

Source position: datatypes.pas line 663

const PDTA_ModeID = DTA_Dummy + 200;


PDTA_NumAlloc

Declaration

Source position: datatypes.pas line 705

const PDTA_NumAlloc = DTA_Dummy + 210;


PDTA_NumColors

Declaration

Source position: datatypes.pas line 702

const PDTA_NumColors = DTA_Dummy + 209;


PDTA_NumSparse

Declaration

Source position: datatypes.pas line 727

const PDTA_NumSparse = DTA_Dummy + 217;


PDTA_Remap

Declaration

Source position: datatypes.pas line 707

const PDTA_Remap = DTA_Dummy + 211;


PDTA_ScaleQuality

Declaration

Source position: datatypes.pas line 754

const PDTA_ScaleQuality = DTA_Dummy + 224;


PDTA_Screen

Declaration

Source position: datatypes.pas line 710

const PDTA_Screen = DTA_Dummy + 212;


PDTA_SourceMode

Declaration

Source position: datatypes.pas line 768

const PDTA_SourceMode = DTA_Dummy + 250;


PDTA_SparseTable

Declaration

Source position: datatypes.pas line 730

const PDTA_SparseTable = DTA_Dummy + 218;


PDTA_UseFriendBitMap

Declaration

Source position: datatypes.pas line 774

const PDTA_UseFriendBitMap = DTA_Dummy + 255;


PDTA_WhichPicture

Declaration

Source position: datatypes.pas line 737

const PDTA_WhichPicture = DTA_Dummy + 219;


PDTANUMPICTURES_Unknown

Declaration

Source position: datatypes.pas line 761

const PDTANUMPICTURES_Unknown = 0;


pdtDraw

Declaration

Source position: datatypes.pas line 619

type pdtDraw = ^tdtDraw;


pdtFrameBox

Declaration

Source position: datatypes.pas line 545

type pdtFrameBox = ^tdtFrameBox;


pdtGeneral

Declaration

Source position: datatypes.pas line 529

type pdtGeneral = ^tdtGeneral;


pdtGoto

Declaration

Source position: datatypes.pas line 556

type pdtGoto = ^tdtGoto;


pDTHookContext

Declaration

Source position: datatypes.pas line 127

type pDTHookContext = ^tDTHookContext;


PDTM_Dummy

Declaration

Source position: datatypes.pas line 792

const PDTM_Dummy = DTM_Dummy + $60;


PDTM_READPIXELARRAY

Declaration

Source position: datatypes.pas line 798

const PDTM_READPIXELARRAY = PDTM_Dummy + 1;


PDTM_WRITEPIXELARRAY

Declaration

Source position: datatypes.pas line 795

const PDTM_WRITEPIXELARRAY = PDTM_Dummy + 0;


pDTMethod

Declaration

Source position: datatypes.pas line 457

type pDTMethod = ^tDTMethod;


pdtPrint

Declaration

Source position: datatypes.pas line 609

type pdtPrint = ^tdtPrint;


PdtReleaseDrawInfo

Declaration

Source position: datatypes.pas line 633

type PdtReleaseDrawInfo = ^TdtReleaseDrawInfo;


pdtSelect

Declaration

Source position: datatypes.pas line 536

type pdtSelect = ^tdtSelect;


pDTSpecialInfo

Declaration

Source position: datatypes.pas line 417

type pDTSpecialInfo = ^tDTSpecialInfo;


pdtTrigger

Declaration

Source position: datatypes.pas line 566

type pdtTrigger = ^tdtTrigger;


pdtWrite

Declaration

Source position: datatypes.pas line 640

type pdtWrite = ^tdtWrite;


pFrameInfo

Declaration

Source position: datatypes.pas line 502

type pFrameInfo = ^tFrameInfo;


PICTUREDTCLASS

Declaration

Source position: datatypes.pas line 658

const PICTUREDTCLASS: PChar = 'picture.datatype';


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

pLine

Declaration

Source position: datatypes.pas line 987

type pLine = ^tLine;


PMODE_V42

Declaration

Source position: datatypes.pas line 785

const PMODE_V42 = 0;


PMODE_V43

Declaration

Source position: datatypes.pas line 786

const PMODE_V43 = 1;


pprinterIO

Declaration

Source position: datatypes.pas line 598

type pprinterIO = ^tprinterIO;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

pTool

Declaration

Source position: datatypes.pas line 152

type pTool = ^tTool;


pToolNode

Declaration

Source position: datatypes.pas line 195

type pToolNode = ^tToolNode;


pVoiceHeader

Declaration

Source position: datatypes.pas line 941

type pVoiceHeader = ^tVoiceHeader;


SAMPLETYPE_Left

Declaration

Source position: datatypes.pas line 957

const SAMPLETYPE_Left = 2;


SAMPLETYPE_Right

Declaration

Source position: datatypes.pas line 958

const SAMPLETYPE_Right = 4;


SAMPLETYPE_Stereo

Declaration

Source position: datatypes.pas line 959

const SAMPLETYPE_Stereo = 6;


SDTA_Continuous

Declaration

Source position: datatypes.pas line 905

const SDTA_Continuous = SDTA_Dummy + 9;


SDTA_Cycles

Declaration

Source position: datatypes.pas line 885

const SDTA_Cycles = SDTA_Dummy + 6;


SDTA_Dummy

Declaration

Source position: datatypes.pas line 871

const SDTA_Dummy = DTA_Dummy + 500;


SDTA_FreeSampleData

Declaration

Source position: datatypes.pas line 928

const SDTA_FreeSampleData = SDTA_Dummy + 16;


SDTA_LeftSample

Declaration

Source position: datatypes.pas line 921

const SDTA_LeftSample = SDTA_Dummy + 13;


SDTA_Pan

Declaration

Source position: datatypes.pas line 925

const SDTA_Pan = SDTA_Dummy + 15;


SDTA_Period

Declaration

Source position: datatypes.pas line 879

const SDTA_Period = SDTA_Dummy + 4;


SDTA_ReplayPeriod

Declaration

Source position: datatypes.pas line 918

const SDTA_ReplayPeriod = SDTA_Dummy + 12;


SDTA_RightSample

Declaration

Source position: datatypes.pas line 922

const SDTA_RightSample = SDTA_Dummy + 14;


SDTA_Sample

Declaration

Source position: datatypes.pas line 873

const SDTA_Sample = SDTA_Dummy + 2;


SDTA_SampleLength

Declaration

Source position: datatypes.pas line 876

const SDTA_SampleLength = SDTA_Dummy + 3;


SDTA_SamplesPerSec

Declaration

Source position: datatypes.pas line 915

const SDTA_SamplesPerSec = SDTA_Dummy + 11;


SDTA_SignalBit

Declaration

Source position: datatypes.pas line 901

const SDTA_SignalBit = SDTA_Dummy + 8;


SDTA_SignalBitMask

Declaration

Source position: datatypes.pas line 902

const SDTA_SignalBitMask = SDTA_SignalBit;


SDTA_SignalBitNumber

Declaration

Source position: datatypes.pas line 912

const SDTA_SignalBitNumber = SDTA_Dummy + 10;


SDTA_SignalTask

Declaration

Source position: datatypes.pas line 888

const SDTA_SignalTask = SDTA_Dummy + 7;


SDTA_SyncSampleChange

Declaration

Source position: datatypes.pas line 933

const SDTA_SyncSampleChange = SDTA_Dummy + 17;


SDTA_VoiceHeader

Declaration

Source position: datatypes.pas line 872

const SDTA_VoiceHeader = SDTA_Dummy + 1;


SDTA_Volume

Declaration

Source position: datatypes.pas line 882

const SDTA_Volume = SDTA_Dummy + 5;


SOUNDDTCLASS

Declaration

Source position: datatypes.pas line 866

const SOUNDDTCLASS: PChar = 'sound.datatype';


STM_ACTIVATE_FIELD

Declaration

Source position: datatypes.pas line 585

const STM_ACTIVATE_FIELD = 10;


STM_BROWSE_NEXT

Declaration

Source position: datatypes.pas line 581

const STM_BROWSE_NEXT = 7;


STM_BROWSE_PREV

Declaration

Source position: datatypes.pas line 580

const STM_BROWSE_PREV = 6;


STM_COMMAND

Declaration

Source position: datatypes.pas line 587

const STM_COMMAND = 11;


STM_CONTENTS

Declaration

Source position: datatypes.pas line 577

const STM_CONTENTS = 3;


STM_FASTFORWARD

Declaration

Source position: datatypes.pas line 591

const STM_FASTFORWARD = 13;


STM_INDEX

Declaration

Source position: datatypes.pas line 578

const STM_INDEX = 4;


STM_LOCATE

Declaration

Source position: datatypes.pas line 594

const STM_LOCATE = 16;


STM_NEXT_FIELD

Declaration

Source position: datatypes.pas line 583

const STM_NEXT_FIELD = 8;


STM_PAUSE

Declaration

Source position: datatypes.pas line 575

const STM_PAUSE = 1;


STM_PLAY

Declaration

Source position: datatypes.pas line 576

const STM_PLAY = 2;


STM_PREV_FIELD

Declaration

Source position: datatypes.pas line 584

const STM_PREV_FIELD = 9;


STM_RESUME

Declaration

Source position: datatypes.pas line 593

const STM_RESUME = 15;


STM_RETRACE

Declaration

Source position: datatypes.pas line 579

const STM_RETRACE = 5;


STM_REWIND

Declaration

Source position: datatypes.pas line 590

const STM_REWIND = 12;


STM_STOP

Declaration

Source position: datatypes.pas line 592

const STM_STOP = 14;


tadtFrame

Declaration

Source position: datatypes.pas line 1208

type tadtFrame = record

  MethodID: LongWord;

  alf_TimeStamp: LongWord;

  alf_Frame: LongWord;

  alf_Duration: LongWord;

  alf_BitMap: PBitMap;

  alf_CMap: PColorMap;

  alf_Sample: Pointer;

  alf_SampleLength: LongWord;

  alf_Period: LongWord;

  alf_UserData: Pointer;

end;


tadtNewFormatFrame

Declaration

Source position: datatypes.pas line 1231

type tadtNewFormatFrame = record

  MethodID: LongWord;

  alf_TimeStamp: LongWord;

  alf_Frame: LongWord;

  alf_Duration: LongWord;

  alf_BitMap: PBitMap;

  alf_CMap: PColorMap;

  alf_Sample: PBYTE;

  alf_SampleLength: LongWord;

  alf_Period: LongWord;

  alf_UserData: Pointer;

  alf_Size: LongWord;

  alf_LeftSample: PBYTE;

  alf_RightSample: PBYTE;

  alf_SamplesPerSec: LongWord;

end;


tadtStart

Declaration

Source position: datatypes.pas line 1253

type tadtStart = record

  MethodID: LongWord;

  asa_Frame: LongWord;

end;


tAnimHeader

Declaration

Source position: datatypes.pas line 1101

type tAnimHeader = record

  ah_Operation: Byte;

  ah_Mask: Byte;

  ah_Width: Word;

  ah_Height: Word;

  ah_Left: Word;

  ah_Top: Word;

  ah_AbsTime: LongWord;

  ah_RelTime: LongWord;

  ah_Interleave: Byte;

  ah_Pad0: Byte;

  ah_Flags: LongWord;

  ah_Pad: array [0..15] of Byte;

end;


tBitMapHeader

Declaration

Source position: datatypes.pas line 826

type tBitMapHeader = record

  bmh_Width: Word;

  bmh_Height: Word;

  bmh_Left: SmallInt;

  bmh_Top: SmallInt;

  bmh_Depth: Byte;

  bmh_Masking: Byte;

  bmh_Compression: Byte;

  bmh_Pad: Byte;

  bmh_Transparent: Word;

  bmh_XAspect: Byte;

  bmh_YAspect: Byte;

  bmh_PageWidth: SmallInt;

  bmh_PageHeight: SmallInt;

end;


tColorRegister

Declaration

Source position: datatypes.pas line 846

type tColorRegister = record

  red: Byte;

  green: Byte;

  blue: Byte;

end;


tDataType

Declaration

Source position: datatypes.pas line 183

type tDataType = record

  dtn_Node1: TNode;

  dtn_Node2: TNode;

  dtn_Header: pDataTypeHeader;

  dtn_ToolList: TList;

  dtn_FunctionName: PChar;

  dtn_AttrList: PTagItem;

  dtn_Length: LongWord;

end;


tDataTypeHeader

Declaration

Source position: datatypes.pas line 41

type tDataTypeHeader = record

  dth_Name: PChar;

  dth_BaseName: PChar;

  dth_Pattern: PChar;

  dth_Mask: Pointer;

  dth_GroupID: LongWord;

  dth_ID: LongWord;

  dth_MaskLen: SmallInt;

  dth_Pad: SmallInt;

  dth_Flags: Word;

  dth_Priority: Word;

end;


TDTA_Buffer

Declaration

Source position: datatypes.pas line 975

const TDTA_Buffer = DTA_Dummy + 300;


TDTA_BufferLen

Declaration

Source position: datatypes.pas line 976

const TDTA_BufferLen = DTA_Dummy + 301;


TDTA_LineList

Declaration

Source position: datatypes.pas line 977

const TDTA_LineList = DTA_Dummy + 302;


TDTA_WordDelim

Declaration

Source position: datatypes.pas line 979

const TDTA_WordDelim = DTA_Dummy + 304;


TDTA_WordSelect

Declaration

Source position: datatypes.pas line 978

const TDTA_WordSelect = DTA_Dummy + 303;


TDTA_WordWrap

Declaration

Source position: datatypes.pas line 980

const TDTA_WordWrap = DTA_Dummy + 305;


tdtDraw

Declaration

Source position: datatypes.pas line 620

type tdtDraw = record

  MethodID: LongWord;

  dtd_RPort: PRastPort;

  dtd_Left: LongInt;

  dtd_Top: LongInt;

  dtd_Width: LongInt;

  dtd_Height: LongInt;

  dtd_TopHoriz: LongInt;

  dtd_TopVert: LongInt;

  dtd_AttrList: PTagItem;

end;


tdtFrameBox

Declaration

Source position: datatypes.pas line 546

type tdtFrameBox = record

  MethodID: LongWord;

  dtf_GInfo: PGadgetInfo;

  dtf_ContentsInfo: pFrameInfo;

  dtf_FrameInfo: pFrameInfo;

  dtf_SizeFrameInfo: LongWord;

  dtf_FrameFlags: LongWord;

end;


tdtGeneral

Declaration

Source position: datatypes.pas line 530

type tdtGeneral = record

  MethodID: LongWord;

  dtg_GInfo: PGadgetInfo;

end;


tdtGoto

Declaration

Source position: datatypes.pas line 557

type tdtGoto = record

  MethodID: LongWord;

  dtg_GInfo: PGadgetInfo;

  dtg_NodeName: PChar;

  dtg_AttrList: PTagItem;

end;


tDTHookContext

Declaration

Source position: datatypes.pas line 128

type tDTHookContext = record

  dthc_SysBase: PLibrary;

  dthc_DOSBase: PLibrary;

  dthc_IFFParseBase: PLibrary;

  dthc_UtilityBase: PLibrary;

  dthc_Lock: LongWord;

  dthc_FIB: PFileInfoBlock;

  dthc_FileHandle: LongWord;

  dthc_IFF: Pointer;

  dthc_Buffer: PChar;

  dthc_BufferLength: LongWord;

end;


tDTMethod

Declaration

Source position: datatypes.pas line 458

type tDTMethod = record

  dtm_Label: PChar;

  dtm_Command: PChar;

  dtm_Method: LongWord;

end;


tdtPrint

Declaration

Source position: datatypes.pas line 610

type tdtPrint = record

  MethodID: LongWord;

  dtp_GInfo: PGadgetInfo;

  dtp_PIO: pprinterIO;

  dtp_AttrList: PTagItem;

end;


TdtReleaseDrawInfo

Declaration

Source position: datatypes.pas line 634

type TdtReleaseDrawInfo = record

  MethodID: PtrUInt;

  dtr_Handle: Pointer;

end;


tdtSelect

Declaration

Source position: datatypes.pas line 537

type tdtSelect = record

  MethodID: LongWord;

  dts_GInfo: PGadgetInfo;

  dts_Select: TRectangle;

end;


tDTSpecialInfo

Declaration

Source position: datatypes.pas line 418

type tDTSpecialInfo = record

  si_Lock: TSignalSemaphore;

  si_Flags: LongInt;

  si_TopVert: LongInt;

  si_VisVert: LongInt;

  si_TotVert: LongInt;

  si_OTopVert: LongInt;

  si_VertUnit: LongInt;

  si_TopHoriz: LongInt;

  si_VisHoriz: LongInt;

  si_TotHoriz: LongInt;

  si_OTopHoriz: LongInt;

  si_HorizUnit: LongInt;

end;


tdtTrigger

Declaration

Source position: datatypes.pas line 567

type tdtTrigger = record

  MethodID: LongWord;

  dtt_GInfo: PGadgetInfo;

  dtt_Function: LongWord;

  dtt_Data: Pointer;

end;


tdtWrite

Declaration

Source position: datatypes.pas line 641

type tdtWrite = record

  MethodID: LongWord;

  dtw_GInfo: PGadgetInfo;

  dtw_FileHandle: LongWord;

  dtw_Mode: LongWord;

  dtw_AttrList: PTagItem;

end;


TEXTDTCLASS

Declaration

Source position: datatypes.pas line 970

const TEXTDTCLASS: PChar = 'text.datatype';


TF_LAUNCH_MASK

Declaration

Source position: datatypes.pas line 170

const TF_LAUNCH_MASK = $000F;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

TF_RX

Declaration

Source position: datatypes.pas line 173

const TF_RX = $0003;


TF_SHELL

Declaration

Source position: datatypes.pas line 171

const TF_SHELL = $0001;


TF_WORKBENCH

Declaration

Source position: datatypes.pas line 172

const TF_WORKBENCH = $0002;


tFrameInfo

Declaration

Source position: datatypes.pas line 503

type tFrameInfo = record

  fri_PropertyFlags: LongWord;

  fri_Resolution: TPoint;

  fri_RedBits: Byte;

  fri_GreenBits: Byte;

  fri_BlueBits: Byte;

  fri_Dimensions: record

    Width: LongWord;

    Height: LongWord;

    Depth: LongWord;

  end;

  fri_Screen: PScreen;

  fri_ColorMap: PColorMap;

  fri_Flags: LongWord;

end;


tLine

Declaration

Source position: datatypes.pas line 988

type tLine = record

  ln_Link: TMinNode;

  ln_Text: PChar;

  ln_TextLen: LongWord;

  ln_XOffset: Word;

  ln_YOffset: Word;

  ln_Width: Word;

  ln_Height: Word;

  ln_Flags: Word;

  ln_FgPen: ShortInt;

  ln_BgPen: ShortInt;

  ln_Style: LongWord;

  ln_Data: Pointer;

end;


tprinterIO

Declaration

Source position: datatypes.pas line 599

type tprinterIO = record

  ios: TIOStdReq;

end;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

TSIZE

Declaration

Source position: datatypes.pas line 160

const TSIZE = 8;


tTool

Declaration

Source position: datatypes.pas line 153

type tTool = record

  tn_Which: Word;

  tn_Flags: Word;

  tn_Program: PChar;

end;


tToolNode

Declaration

Source position: datatypes.pas line 196

type tToolNode = record

  tn_Node: TNode;

  tn_Tool: tTool;

  tn_Length: LongWord;

end;


tVoiceHeader

Declaration

Source position: datatypes.pas line 942

type tVoiceHeader = record

  vh_OneShotHiSamples: LongWord;

  vh_RepeatHiSamples: LongWord;

  vh_SamplesPerHiCycle: LongWord;

  vh_SamplesPerSec: Word;

  vh_Octaves: Byte;

  vh_Compression: Byte;

  vh_Volume: LongWord;

end;


TW_BROWSE

Declaration

Source position: datatypes.pas line 164

const TW_BROWSE = 2;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

TW_EDIT

Declaration

Source position: datatypes.pas line 165

const TW_EDIT = 3;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

TW_INFO

Declaration

Source position: datatypes.pas line 163

const TW_INFO = 1;


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

TW_MAIL

Declaration

Source position: datatypes.pas line 167

const TW_MAIL = 5;


TW_PRINT

Declaration

Source position: datatypes.pas line 166

const TW_PRINT = 4;


AFB_BITMAP

Declaration

Source position: diskfont.pas line 84

const AFB_BITMAP = 3;


Unit 'diskfont' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

AFB_DISK

Declaration

Source position: diskfont.pas line 80

const AFB_DISK = 1;


AFB_MEMORY

Declaration

Source position: diskfont.pas line 78

const AFB_MEMORY = 0;


AFB_SCALED

Declaration

Source position: diskfont.pas line 82

const AFB_SCALED = 2;


AFB_TAGGED

return TAvailFonts

Declaration

Source position: diskfont.pas line 87

const AFB_TAGGED = 16;


AFF_BITMAP

Declaration

Source position: diskfont.pas line 85

const AFF_BITMAP = 1 shl AFB_BITMAP;


AFF_DISK

Declaration

Source position: diskfont.pas line 81

const AFF_DISK = 1 shl AFB_DISK;


AFF_MEMORY

Declaration

Source position: diskfont.pas line 79

const AFF_MEMORY = 1 shl AFB_MEMORY;


AFF_SCALED

Declaration

Source position: diskfont.pas line 83

const AFF_SCALED = 1 shl AFB_SCALED;


AFF_TAGGED

return TAvailFonts

Declaration

Source position: diskfont.pas line 88

const AFF_TAGGED = 1 shl AFB_TAGGED;


DFCTRL_BASE

Declaration

Source position: diskfont.pas line 224

const DFCTRL_BASE = TAG_USER + $0B000000;


DFCTRL_CACHE

Declaration

Source position: diskfont.pas line 229

const DFCTRL_CACHE = DFCTRL_BASE + 5;


DFCTRL_SORT_ASC

Declaration

Source position: diskfont.pas line 233

const DFCTRL_SORT_ASC = 1;


DFCTRL_SORT_DES

Declaration

Source position: diskfont.pas line 234

const DFCTRL_SORT_DES = - 1;


DFCTRL_SORT_OFF

Declaration

Source position: diskfont.pas line 232

const DFCTRL_SORT_OFF = 0;


DFCTRL_SORTMODE

Declaration

Source position: diskfont.pas line 230

const DFCTRL_SORTMODE = DFCTRL_BASE + 6;


DFCTRL_XDOTP

Declaration

Source position: diskfont.pas line 227

const DFCTRL_XDOTP = DFCTRL_BASE + 3;


DFCTRL_XDPI

Declaration

Source position: diskfont.pas line 225

const DFCTRL_XDPI = DFCTRL_BASE + 1;


DFCTRL_YDOTP

Declaration

Source position: diskfont.pas line 228

const DFCTRL_YDOTP = DFCTRL_BASE + 4;


DFCTRL_YDPI

Declaration

Source position: diskfont.pas line 226

const DFCTRL_YDPI = DFCTRL_BASE + 2;


DFH_ID

TDiskFontHeader.dfh_FileID

Declaration

Source position: diskfont.pas line 62

const DFH_ID = $0f80;


DiskfontBase

Declaration

Source position: diskfont.pas line 291

var DiskfontBase: PLibrary = Nil;


DISKFONTNAME

Declaration

Source position: diskfont.pas line 289

const DISKFONTNAME: PChar = 'diskfont.library';


FCH_ID

TFontContentsHeader.fch_FileID, then TFontContents

Declaration

Source position: diskfont.pas line 50

const FCH_ID = $0f00;


Unit 'diskfont' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

FIXED

Declaration

Source position: diskfont.pas line 244

type FIXED = LongInt;


Reference for unit 'diskfont'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'diskfont': Constants

AFB_BITMAP |
AFB_DISK |
AFB_MEMORY |
AFB_SCALED |
AFB_TAGGED | return TAvailFonts
AFF_BITMAP |
AFF_DISK |
AFF_MEMORY |
AFF_SCALED |
AFF_TAGGED | return TAvailFonts
DFCTRL_BASE
DFCTRL_CACHE
DFCTRL_SORTMODE
DFCTRL_SORT_ASC
DFCTRL_SORT_DES
DFCTRL_SORT_OFF
DFCTRL_XDOTP
DFCTRL_XDPI
DFCTRL_YDOTP
DFCTRL_YDPI
DFH_ID | TDiskFontHeader.dfh_FileID
DISKFONTNAME |
FCH_ID | TFontContentsHeader.fch_FileID, then TFontContents
MAXFONTNAME | Font name including '.font'#0
MAXFONTPATH | Maximum length (including null terminator) of a filesystem path to a Font file.
OFCH_ID |
OTERR_BadData
OTERR_BadFace
OTERR_BadGlyph
OTERR_BadTag
OTERR_Failure
OTERR_NoFace
OTERR_NoGlyph
OTERR_NoMemory
OTERR_NoRotate
OTERR_NoShear
OTERR_Success
OTERR_TooSmall
OTERR_UnknownGlyph
OTERR_UnknownTag
OTE_Bullet
OTH_Compressed
OTH_Condensed
OTH_Expanded
OTH_ExtraCompressed
OTH_ExtraExpanded
OTH_Normal
OTH_SemiExpanded
OTH_UltraCompressed
OTSF_AlgoBold
OTSF_AlgoItalic
OTSF_DesignedBold
OTSF_DesignedItalic
OTSUFFIX
OTS_Black
OTS_Bold
OTS_Book
OTS_DemiBold
OTS_DemiLight
OTS_ExtraBlack
OTS_ExtraBold
OTS_ExtraLight
OTS_ExtraThin
OTS_Italic
OTS_LeftItalic
OTS_Light
OTS_Medium
OTS_SemiBold
OTS_SemiLight
OTS_Thin
OTS_UltraBlack
OTS_UltraThin
OTS_Upright
OTUL_Broken
OTUL_DoubleBroken
OTUL_DoubleSolid
OTUL_None
OTUL_Solid
OT_AvailSizes
OT_BIName
OT_BName
OT_DesignKernPair
OT_DeviceDPI
OT_DotSize
OT_EmboldenX
OT_EmboldenY
OT_Engine
OT_Family
OT_FileIdent
OT_GlyphCode
OT_GlyphCode2
OT_GlyphMap
OT_GlyphMap8Bits
OT_GlyphWidth
OT_HorizStyle
OT_IName
OT_Indirect
OT_InhibitAlgoStyle
OT_IsFixed
OT_Level0
OT_Level1
OT_Level2
OT_Level3
OT_MAXAVAILSIZES
OT_OTagList
OT_OTagPath
OT_PointHeight
OT_PointSize
OT_RName
OT_RotateCos
OT_RotateSin
OT_SerifFlag
OT_SetFactor
OT_ShearCos
OT_ShearSin
OT_SlantStyle
OT_SpaceFactor
OT_SpaceWidth
OT_Spec
OT_Spec1
OT_SpecCount
OT_StemWeight
OT_StrikeThrough
OT_StyleFlags
OT_SymbolSet
OT_TextKernPair
OT_UnderLined
OT_WidthList
OT_YSizeFactor
OUTL_DoubleBroken
TFCH_ID | TFontContentsHeader.fch_FileID, then TTFontContents


Reference for unit 'diskfont': Types

LongInt
PAvailFonts |
PAvailFontsHeader |
PDiskFontHeader |
PFontContents |
PFontContentsHeader |
PGlyphEngine
PGlyphMap
PGlyphWidthEntry
PTAvailFonts |
PTFontContents |
TAvailFonts |
TAvailFontsHeader |
TDiskFontHeader | If dfh_TF.tf_Style FSB_TAGGED bit is set, dfh_Segment points to a TagList the taglist is destroyed on loading
TFontContents |
TFontContentsHeader |
TGlyphEngine
TGlyphMap
TGlyphWidthEntry
TTAvailFonts |
TTFontContents |


MAXFONTNAME

Font name including '.font'#0

Declaration

Source position: diskfont.pas line 64

const MAXFONTNAME = 32;


MAXFONTPATH

Maximum length (including null terminator) of a filesystem path to a Font file.

Declaration

Source position: diskfont.pas line 29

const MAXFONTPATH = 256;


OFCH_ID

Declaration

Source position: diskfont.pas line 52

const OFCH_ID = $0f03;


OT_AvailSizes

Declaration

Source position: diskfont.pas line 187

const OT_AvailSizes = OT_Level1 or OT_Indirect or $20;


OT_BIName

Declaration

Source position: diskfont.pas line 174

const OT_BIName = OT_Level2 or OT_Indirect or $07;


OT_BName

Declaration

Source position: diskfont.pas line 172

const OT_BName = OT_Level2 or OT_Indirect or $05;


OT_DesignKernPair

Declaration

Source position: diskfont.pas line 135

const OT_DesignKernPair = OT_Level0 or OT_Indirect or $23;


OT_DeviceDPI

Declaration

Source position: diskfont.pas line 116

const OT_DeviceDPI = OT_Level0 or $01;


OT_DotSize

Declaration

Source position: diskfont.pas line 117

const OT_DotSize = OT_Level0 or $02;


OT_EmboldenX

Declaration

Source position: diskfont.pas line 124

const OT_EmboldenX = OT_Level0 or $0e;


OT_EmboldenY

Declaration

Source position: diskfont.pas line 125

const OT_EmboldenY = OT_Level0 or $0f;


OT_Engine

Declaration

Source position: diskfont.pas line 169

const OT_Engine = OT_Level1 or OT_Indirect or $02;


OT_Family

Declaration

Source position: diskfont.pas line 170

const OT_Family = OT_Level1 or OT_Indirect or $03;


OT_FileIdent

Declaration

Source position: diskfont.pas line 168

const OT_FileIdent = OT_Level1 or $01;


OT_GlyphCode

Declaration

Source position: diskfont.pas line 127

const OT_GlyphCode = OT_Level0 or $11;


OT_GlyphCode2

Declaration

Source position: diskfont.pas line 128

const OT_GlyphCode2 = OT_Level0 or $12;


OT_GlyphMap

Declaration

Source position: diskfont.pas line 132

const OT_GlyphMap = OT_Level0 or OT_Indirect or $20;


OT_GlyphMap8Bits

Declaration

Source position: diskfont.pas line 138

const OT_GlyphMap8Bits = OT_Level0 or OT_Indirect or $50;


OT_GlyphWidth

Declaration

Source position: diskfont.pas line 129

const OT_GlyphWidth = OT_Level0 or $13;


OT_HorizStyle

Declaration

Source position: diskfont.pas line 184

const OT_HorizStyle = OT_Level1 or $17;


OT_IName

Declaration

Source position: diskfont.pas line 173

const OT_IName = OT_Level2 or OT_Indirect or $06;


OT_Indirect

Declaration

Source position: diskfont.pas line 114

const OT_Indirect = $8000;


OT_InhibitAlgoStyle

Declaration

Source position: diskfont.pas line 186

const OT_InhibitAlgoStyle = OT_Level2 or $19;


OT_IsFixed

Declaration

Source position: diskfont.pas line 180

const OT_IsFixed = OT_Level2 or $13;


OT_Level0

Declaration

Source position: diskfont.pas line 110

const OT_Level0 = TAG_USER;


OT_Level1

Declaration

Source position: diskfont.pas line 111

const OT_Level1 = TAG_USER or $1000;


OT_Level2

Declaration

Source position: diskfont.pas line 112

const OT_Level2 = TAG_USER or $2000;


OT_Level3

Declaration

Source position: diskfont.pas line 113

const OT_Level3 = TAG_USER or $3000;


OT_MAXAVAILSIZES

Declaration

Source position: diskfont.pas line 189

const OT_MAXAVAILSIZES = 20;


OT_OTagList

Declaration

Source position: diskfont.pas line 131

const OT_OTagList = OT_Level0 or OT_Indirect or $15;


OT_OTagPath

Declaration

Source position: diskfont.pas line 130

const OT_OTagPath = OT_Level0 or OT_Indirect or $14;


OT_PointHeight

Declaration

Source position: diskfont.pas line 118

const OT_PointHeight = OT_Level0 or $08;


OT_PointSize

Declaration

Source position: diskfont.pas line 126

const OT_PointSize = OT_Level0 or $10;


OT_RName

Declaration

Source position: diskfont.pas line 175

const OT_RName = OT_Level2 or OT_Indirect or $09;


OT_RotateCos

Declaration

Source position: diskfont.pas line 123

const OT_RotateCos = OT_Level0 or $0d;


OT_RotateSin

Declaration

Source position: diskfont.pas line 122

const OT_RotateSin = OT_Level0 or $0c;


OT_SerifFlag

Declaration

Source position: diskfont.pas line 181

const OT_SerifFlag = OT_Level1 or $14;


OT_SetFactor

Declaration

Source position: diskfont.pas line 119

const OT_SetFactor = OT_Level0 or $09;


OT_ShearCos

Declaration

Source position: diskfont.pas line 121

const OT_ShearCos = OT_Level0 or $0b;


OT_ShearSin

Declaration

Source position: diskfont.pas line 120

const OT_ShearSin = OT_Level0 or $0a;


OT_SlantStyle

Declaration

Source position: diskfont.pas line 183

const OT_SlantStyle = OT_Level1 or $16;


OT_SpaceFactor

Declaration

Source position: diskfont.pas line 185

const OT_SpaceFactor = OT_Level2 or $18;


OT_SpaceWidth

Declaration

Source position: diskfont.pas line 179

const OT_SpaceWidth = OT_Level2 or $12;


OT_Spec

Declaration

Source position: diskfont.pas line 221

const OT_Spec = OT_Level1 or $100;


OT_Spec1

Declaration

Source position: diskfont.pas line 222

const OT_Spec1 = OT_Level1 or $101;


OT_SpecCount

Declaration

Source position: diskfont.pas line 220

const OT_SpecCount = OT_Level1 or $100;


OT_StemWeight

Declaration

Source position: diskfont.pas line 182

const OT_StemWeight = OT_Level1 or $15;


OT_StrikeThrough

Declaration

Source position: diskfont.pas line 137

const OT_StrikeThrough = OT_Level0 or $25;


OT_StyleFlags

Declaration

Source position: diskfont.pas line 141

const OT_StyleFlags = OT_Level0 or $101;


OT_SymbolSet

Declaration

Source position: diskfont.pas line 177

const OT_SymbolSet = OT_Level1 or $10;


OT_TextKernPair

Declaration

Source position: diskfont.pas line 134

const OT_TextKernPair = OT_Level0 or OT_Indirect or $22;


OT_UnderLined

Declaration

Source position: diskfont.pas line 136

const OT_UnderLined = OT_Level0 or $24;


OT_WidthList

Declaration

Source position: diskfont.pas line 133

const OT_WidthList = OT_Level0 or OT_Indirect or $21;


OT_YSizeFactor

Declaration

Source position: diskfont.pas line 178

const OT_YSizeFactor = OT_Level1 or $11;


OTE_Bullet

Declaration

Source position: diskfont.pas line 166

const OTE_Bullet = 'bullet';


OTERR_BadData

Declaration

Source position: diskfont.pas line 277

const OTERR_BadData = 3;


OTERR_BadFace

Declaration

Source position: diskfont.pas line 280

const OTERR_BadFace = 6;


OTERR_BadGlyph

Declaration

Source position: diskfont.pas line 282

const OTERR_BadGlyph = 8;


OTERR_BadTag

Declaration

Source position: diskfont.pas line 275

const OTERR_BadTag = 1;


OTERR_Failure

Declaration

Source position: diskfont.pas line 273

const OTERR_Failure = - 1;


OTERR_NoFace

Declaration

Source position: diskfont.pas line 279

const OTERR_NoFace = 5;


OTERR_NoGlyph

Declaration

Source position: diskfont.pas line 281

const OTERR_NoGlyph = 7;


OTERR_NoMemory

Declaration

Source position: diskfont.pas line 278

const OTERR_NoMemory = 4;


OTERR_NoRotate

Declaration

Source position: diskfont.pas line 284

const OTERR_NoRotate = 10;


OTERR_NoShear

Declaration

Source position: diskfont.pas line 283

const OTERR_NoShear = 9;


OTERR_Success

Declaration

Source position: diskfont.pas line 274

const OTERR_Success = 0;


OTERR_TooSmall

Declaration

Source position: diskfont.pas line 285

const OTERR_TooSmall = 11;


OTERR_UnknownGlyph

Declaration

Source position: diskfont.pas line 286

const OTERR_UnknownGlyph = 12;


OTERR_UnknownTag

Declaration

Source position: diskfont.pas line 276

const OTERR_UnknownTag = 2;


OTH_Compressed

Declaration

Source position: diskfont.pas line 213

const OTH_Compressed = 80;


OTH_Condensed

Declaration

Source position: diskfont.pas line 214

const OTH_Condensed = 112;


OTH_Expanded

Declaration

Source position: diskfont.pas line 217

const OTH_Expanded = 208;


OTH_ExtraCompressed

Declaration

Source position: diskfont.pas line 212

const OTH_ExtraCompressed = 48;


OTH_ExtraExpanded

Declaration

Source position: diskfont.pas line 218

const OTH_ExtraExpanded = 240;


OTH_Normal

Declaration

Source position: diskfont.pas line 215

const OTH_Normal = 144;


OTH_SemiExpanded

Declaration

Source position: diskfont.pas line 216

const OTH_SemiExpanded = 176;


OTH_UltraCompressed

Declaration

Source position: diskfont.pas line 211

const OTH_UltraCompressed = 16;


OTS_Black

Declaration

Source position: diskfont.pas line 207

const OTS_Black = 216;


OTS_Bold

Declaration

Source position: diskfont.pas line 205

const OTS_Bold = 184;


OTS_Book

Declaration

Source position: diskfont.pas line 201

const OTS_Book = 120;


OTS_DemiBold

Declaration

Source position: diskfont.pas line 204

const OTS_DemiBold = 168;


OTS_DemiLight

Declaration

Source position: diskfont.pas line 199

const OTS_DemiLight = 88;


OTS_ExtraBlack

Declaration

Source position: diskfont.pas line 208

const OTS_ExtraBlack = 232;


OTS_ExtraBold

Declaration

Source position: diskfont.pas line 206

const OTS_ExtraBold = 200;


OTS_ExtraLight

Declaration

Source position: diskfont.pas line 197

const OTS_ExtraLight = 56;


OTS_ExtraThin

Declaration

Source position: diskfont.pas line 195

const OTS_ExtraThin = 24;


OTS_Italic

Declaration

Source position: diskfont.pas line 192

const OTS_Italic = 1;


OTS_LeftItalic

Declaration

Source position: diskfont.pas line 193

const OTS_LeftItalic = 2;


OTS_Light

Declaration

Source position: diskfont.pas line 198

const OTS_Light = 72;


OTS_Medium

Declaration

Source position: diskfont.pas line 202

const OTS_Medium = 136;


OTS_SemiBold

Declaration

Source position: diskfont.pas line 203

const OTS_SemiBold = 152;


OTS_SemiLight

Declaration

Source position: diskfont.pas line 200

const OTS_SemiLight = 104;


OTS_Thin

Declaration

Source position: diskfont.pas line 196

const OTS_Thin = 40;


OTS_UltraBlack

Declaration

Source position: diskfont.pas line 209

const OTS_UltraBlack = 248;


OTS_UltraThin

Declaration

Source position: diskfont.pas line 194

const OTS_UltraThin = 8;


OTS_Upright

Declaration

Source position: diskfont.pas line 191

const OTS_Upright = 0;


OTSF_AlgoBold

Declaration

Source position: diskfont.pas line 154

const OTSF_AlgoBold = 1 shl 16;


OTSF_AlgoItalic

Declaration

Source position: diskfont.pas line 155

const OTSF_AlgoItalic = 1 shl 17;


OTSF_DesignedBold

Declaration

Source position: diskfont.pas line 152

const OTSF_DesignedBold = 1 shl 0;


OTSF_DesignedItalic

Declaration

Source position: diskfont.pas line 153

const OTSF_DesignedItalic = 1 shl 1;


OTSUFFIX

Declaration

Source position: diskfont.pas line 165

const OTSUFFIX = '.otag';


OTUL_Broken

Declaration

Source position: diskfont.pas line 160

const OTUL_Broken = 2;


OTUL_DoubleBroken

Declaration

Source position: diskfont.pas line 162

const OTUL_DoubleBroken = 4;


OTUL_DoubleSolid

Declaration

Source position: diskfont.pas line 161

const OTUL_DoubleSolid = 3;


OTUL_None

Declaration

Source position: diskfont.pas line 158

const OTUL_None = 0;


OTUL_Solid

Declaration

Source position: diskfont.pas line 159

const OTUL_Solid = 1;


OUTL_DoubleBroken

Declaration

Source position: diskfont.pas line 163

const OUTL_DoubleBroken = OTUL_DoubleBroken;


PAvailFonts

Declaration

Source position: diskfont.pas line 91

type PAvailFonts = ^TAvailFonts;


PAvailFontsHeader

Declaration

Source position: diskfont.pas line 103

type PAvailFontsHeader = ^TAvailFontsHeader;


PDiskFontHeader

Declaration

Source position: diskfont.pas line 67

type PDiskFontHeader = ^TDiskFontHeader;


PFontContents

Declaration

Source position: diskfont.pas line 32

type PFontContents = ^TFontContents;


PFontContentsHeader

Declaration

Source position: diskfont.pas line 55

type PFontContentsHeader = ^TFontContentsHeader;

See also

NewFontContents

DisposeFontContents


PGlyphEngine

Declaration

Source position: diskfont.pas line 238

type PGlyphEngine = ^TGlyphEngine;


PGlyphMap

Declaration

Source position: diskfont.pas line 246

type PGlyphMap = ^TGlyphMap;


PGlyphWidthEntry

Declaration

Source position: diskfont.pas line 264

type PGlyphWidthEntry = ^TGlyphWidthEntry;


PTAvailFonts

Declaration

Source position: diskfont.pas line 97

type PTAvailFonts = ^TTAvailFonts;


PTFontContents

Declaration

Source position: diskfont.pas line 40

type PTFontContents = ^TTFontContents;


TAvailFonts

Declaration

Source position: diskfont.pas line 92

type TAvailFonts = record
af_Type: Word; | AFF_MEMORY, AFF_DISK or AFF_SCALED
af_Attr: TTextAttr; | text attributes for font
end;


TAvailFontsHeader

Declaration

Source position: diskfont.pas line 104

type TAvailFontsHeader = record

  afh_NumEntries: Word;

number of AvailFonts elements

end;


TDiskFontHeader

If dfh_TF.tf_Style FSB_TAGGED bit is set, dfh_Segment points to a TagList the taglist is destroyed on loading

Declaration

Source position: diskfont.pas line 68

type TDiskFontHeader = record
dfh_DF: TNode; | Node to link disk fonts
dfh_FileID: Word; | DFH_ID
dfh_Revision: Word; | The font revision
dfh_Segment: LongInt; | The segment address when loaded
dfh_Name: array [0..MAXFONTNAME-1] of Char; | the font name (#0 terminated)
dfh_TF: TTextFont; | loaded TextFont structure
end;


TFCH_ID

TFontContentsHeader.fch_FileID, then TTFontContents

Declaration

Source position: diskfont.pas line 51

const TFCH_ID = $0f02;


TFontContents

Declaration

Source position: diskfont.pas line 33

type TFontContents = record

  fc_FileName: array [0..MAXFONTPATH-1] of Char;

  fc_YSize: Word;

  fc_Style: Byte;

  fc_Flags: Byte;

end;

See also

TFontContentsHeader


TFontContentsHeader

Declaration

Source position: diskfont.pas line 56

type TFontContentsHeader = record
fch_FileID: Word; |
fch_NumEntries: Word; | FCH_ID, TFCH_ID or OFCH_ID
end;

See also

NewFontContents

DisposeFontContents


TGlyphEngine

Declaration

Source position: diskfont.pas line 239

type TGlyphEngine = record

  gle_Library: PLibrary;

  gle_Name: PChar;

end;


TGlyphMap

Declaration

Source position: diskfont.pas line 247

type TGlyphMap = record

  glm_BMModulo: Word;

  glm_BMRows: Word;

  glm_BlackLeft: Word;

  glm_BlackTop: Word;

  glm_BlackWidth: Word;

  glm_BlackHeight: Word;

  glm_XOrigin: LongInt;

  glm_YOrigin: LongInt;

  glm_X0: SmallInt;

  glm_Y0: SmallInt;

  glm_X1: SmallInt;

  glm_Y1: SmallInt;

  glm_Width: LongInt;

  glm_BitMap: PByte;

end;


TGlyphWidthEntry

Declaration

Source position: diskfont.pas line 265

type TGlyphWidthEntry = record

  gwe_Node: TMinNode;

  gwe_Code: Word;

  gwe_Width: LongInt;

end;


TTAvailFonts

Declaration

Source position: diskfont.pas line 98

type TTAvailFonts = record
taf_Type: Word; | AFF_MEMORY, AFF_DISK or AFF_SCALED
taf_Attr: TTTextAttr; | text attributes for font
end;


TTFontContents

Declaration

Source position: diskfont.pas line 41

type TTFontContents = record
tfc_FileName: array [0..MAXFONTPATH-3] of Char; |
tfc_TagCount: Word; | Including the TAG_DONE tag. if tfc_TagCount is non-zero, tfc_FileName is overlayed with Text Tags
tfc_YSize: Word; |
tfc_Style: Byte; |
tfc_Flags: Byte; |
end;


ACPU_AddressErr

CPU AlertCode for Alert() Illegal address access (ie: odd)

Declaration

Source position: exec.pas line 739

const ACPU_AddressErr = $80000003;


ACPU_AutoVec1

CPU AlertCode for Alert() AutoVector Level 1 interrupt error

Declaration

Source position: exec.pas line 750

const ACPU_AutoVec1 = $80000019;


ACPU_AutoVec2

CPU AlertCode for Alert() AutoVector Level 2 interrupt error

Declaration

Source position: exec.pas line 751

const ACPU_AutoVec2 = $8000001A;


ACPU_AutoVec3

CPU AlertCode for Alert() AutoVector Level 3 interrupt error

Declaration

Source position: exec.pas line 752

const ACPU_AutoVec3 = $8000001B;


ACPU_AutoVec4

CPU AlertCode for Alert() AutoVector Level 4 interrupt error

Declaration

Source position: exec.pas line 753

const ACPU_AutoVec4 = $8000001C;


ACPU_AutoVec5

CPU AlertCode for Alert() AutoVector Level 5 interrupt error

Declaration

Source position: exec.pas line 754

const ACPU_AutoVec5 = $8000001D;


ACPU_AutoVec6

CPU AlertCode for Alert() AutoVector Level 6 interrupt error

Declaration

Source position: exec.pas line 755

const ACPU_AutoVec6 = $8000001E;


ACPU_AutoVec7

CPU AlertCode for Alert() AutoVector Level 7 interrupt error

Declaration

Source position: exec.pas line 756

const ACPU_AutoVec7 = $8000001F;


ACPU_BusErr

CPU AlertCode for Alert() Hardware bus fault/access error

Declaration

Source position: exec.pas line 738

const ACPU_BusErr = $80000002;


ACPU_CHK

CPU AlertCode for Alert() Check instruction error

Declaration

Source position: exec.pas line 742

const ACPU_CHK = $80000006;


ACPU_DivZero

CPU AlertCode for Alert() Divide by zero

Declaration

Source position: exec.pas line 741

const ACPU_DivZero = $80000005;


ACPU_Format

CPU AlertCode for Alert() Stack frame format error

Declaration

Source position: exec.pas line 748

const ACPU_Format = $8000000E;


ACPU_InstErr

CPU AlertCode for Alert() Illegal instruction

Declaration

Source position: exec.pas line 740

const ACPU_InstErr = $80000004;


ACPU_LineA

CPU AlertCode for Alert() Line 1010 Emulator error

Declaration

Source position: exec.pas line 746

const ACPU_LineA = $8000000A;


ACPU_LineF

CPU AlertCode for Alert() Line 1111 Emulator error

Declaration

Source position: exec.pas line 747

const ACPU_LineF = $8000000B;


ACPU_PrivErr

CPU AlertCode for Alert() Privilege violation error

Declaration

Source position: exec.pas line 744

const ACPU_PrivErr = $80000008;


ACPU_Spurious

CPU AlertCode for Alert() Spurious interrupt error

Declaration

Source position: exec.pas line 749

const ACPU_Spurious = $80000018;


ACPU_Trace

CPU AlertCode for Alert() Trace error

Declaration

Source position: exec.pas line 745

const ACPU_Trace = $80000009;


ACPU_TRAPV

CPU AlertCode for Alert() TrapV instruction error

Declaration

Source position: exec.pas line 743

const ACPU_TRAPV = $80000007;


AFB_68010

Declaration

Source position: exec.pas line 1457

const AFB_68010 = 0;


AFB_68020

Declaration

Source position: exec.pas line 1458

const AFB_68020 = 1;


AFB_68030

Declaration

Source position: exec.pas line 1459

const AFB_68030 = 2;


AFB_68040

Declaration

Source position: exec.pas line 1460

const AFB_68040 = 3;


AFB_68060

Declaration

Source position: exec.pas line 1464

const AFB_68060 = 7;


AFB_68881

Declaration

Source position: exec.pas line 1461

const AFB_68881 = 4;


AFB_68882

Declaration

Source position: exec.pas line 1462

const AFB_68882 = 5;


AFB_FPU40

Declaration

Source position: exec.pas line 1463

const AFB_FPU40 = 6;


AFB_PRIVATE

Declaration

Source position: exec.pas line 1465

const AFB_PRIVATE = 15;


AFF_68010

Declaration

Source position: exec.pas line 1467

const AFF_68010 = 1 shl AFB_68010;


AFF_68020

Declaration

Source position: exec.pas line 1468

const AFF_68020 = 1 shl AFB_68020;


AFF_68030

Declaration

Source position: exec.pas line 1469

const AFF_68030 = 1 shl AFB_68030;


AFF_68040

Declaration

Source position: exec.pas line 1470

const AFF_68040 = 1 shl AFB_68040;


AFF_68060

Declaration

Source position: exec.pas line 1474

const AFF_68060 = 1 shl AFB_68060;


AFF_68881

Declaration

Source position: exec.pas line 1471

const AFF_68881 = 1 shl AFB_68881;


AFF_68882

Declaration

Source position: exec.pas line 1472

const AFF_68882 = 1 shl AFB_68882;


AFF_FPU40

Declaration

Source position: exec.pas line 1473

const AFF_FPU40 = 1 shl AFB_FPU40;


AFF_PRIVATE

Declaration

Source position: exec.pas line 1475

const AFF_PRIVATE = 1 shl AFB_PRIVATE;


AG_BadParm

General AlertCode for Alert()

Declaration

Source position: exec.pas line 768

const AG_BadParm = $00080000;


AG_CloseDev

General AlertCode for Alert() Usually too many closes or a mismatched close

Declaration

Source position: exec.pas line 770

const AG_CloseDev = $000A0000;


AG_CloseLib

General AlertCode for Alert() Usually too many closes or a mismatched close

Declaration

Source position: exec.pas line 769

const AG_CloseLib = $00090000;


AG_IOError

General AlertCode for Alert()

Declaration

Source position: exec.pas line 766

const AG_IOError = $00060000;


AG_MakeLib

General AlertCode for Alert()

Declaration

Source position: exec.pas line 762

const AG_MakeLib = $00020000;


AG_MsgPortNotEmpty

Declaration

Source position: exec.pas line 772

const AG_MsgPortNotEmpty = $000C0000;


AG_NoMemory

General AlertCode for Alert()

Declaration

Source position: exec.pas line 761

const AG_NoMemory = $00010000;


AG_NoSignal

General AlertCode for Alert()

Declaration

Source position: exec.pas line 767

const AG_NoSignal = $00070000;


AG_OpenDev

General AlertCode for Alert()

Declaration

Source position: exec.pas line 764

const AG_OpenDev = $00040000;


AG_OpenLib

General AlertCode for Alert()

Declaration

Source position: exec.pas line 763

const AG_OpenLib = $00030000;


AG_OpenRes

General AlertCode for Alert()

Declaration

Source position: exec.pas line 765

const AG_OpenRes = $00050000;


AG_ProcCreate

General AlertCode for Alert() Process creation failed

Declaration

Source position: exec.pas line 771

const AG_ProcCreate = $000B0000;


AN_AddSWGadget

Intuition AlertCode for Alert() add SW gadgets, no memory

Declaration

Source position: exec.pas line 858

const AN_AddSWGadget = $8401000A;


AN_AsyncPkt

Dos AlertCode for Alert() Unexpected packet received

Declaration

Source position: exec.pas line 875

const AN_AsyncPkt = $07000004;


AN_AudioDev

Audio AlertCode for Alert()

Declaration

Source position: exec.pas line 902

const AN_AudioDev = $10000000;


AN_BadChkSum

Dos AlertCode for Alert() Invalid checksum

Declaration

Source position: exec.pas line 880

const AN_BadChkSum = $07000009;


AN_BadExpansionFree

Expansion AlertCode for Alert() freeed free region

Declaration

Source position: exec.pas line 896

const AN_BadExpansionFree = $0A000001;


AN_BadFreeAddr

Exec AlertCode for Alert() Memory header not located. Usually an invalid address passed to exec.ExecFreeMem

Declaration

Source position: exec.pas line 822

const AN_BadFreeAddr = $0100000F;


AN_BadGadget

Intuition AlertCode for Alert() Recovery form of AN_GadgetType

Declaration

Source position: exec.pas line 849

const AN_BadGadget = $04000001;


AN_BadInitFunc

Dos AlertCode for Alert() Invalid init packet for cli/shell

Declaration

Source position: exec.pas line 884

const AN_BadInitFunc = $0700000D;


AN_BadMessage

Intuition AlertCode for Alert() Bad Message received by IDCMP

Declaration

Source position: exec.pas line 861

const AN_BadMessage = $8400000D;


AN_BadOverlay

Dos AlertCode for Alert() Bad overlay

Declaration

Source position: exec.pas line 883

const AN_BadOverlay = $0700000C;


AN_BadSegList

Ramlib AlertCode for Alert() no overlays in library seglists

Declaration

Source position: exec.pas line 889

const AN_BadSegList = $08000001;


AN_BadSemaphore

Exec AlertCode for Alert() An attempt was made to use the old message semaphores.

Declaration

Source position: exec.pas line 823

const AN_BadSemaphore = $01000010;


AN_BadState

Intuition AlertCode for Alert() Bad State Return entering Intuition

Declaration

Source position: exec.pas line 860

const AN_BadState = $8400000C;


AN_BaseChkSum

Exec AlertCode for Alert() Execbase checksum (obs.)

Declaration

Source position: exec.pas line 807

const AN_BaseChkSum = $01000002;


AN_BitMap

Dos AlertCode for Alert() Bitmap corrupt

Declaration

Source position: exec.pas line 878

const AN_BitMap = $07000007;


AN_BltBitMap

Graphics AlertCode for Alert() BltBitMap, no memory

Declaration

Source position: exec.pas line 832

const AN_BltBitMap = $8201000A;


AN_BogusExcpt

Exec AlertCode for Alert() illegal 68k exception taken (obs.)

Declaration

Source position: exec.pas line 816

const AN_BogusExcpt = $8100000A;


AN_BootError

Bootstrap AlertCode for Alert() boot code returned an error

Declaration

Source position: exec.pas line 937

const AN_BootError = $30000001;


AN_BootStrap

Bootstrap AlertCode for Alert()

Declaration

Source position: exec.pas line 936

const AN_BootStrap = $30000000;


AN_CIARsrc

CIA AlertCode for Alert()

Declaration

Source position: exec.pas line 925

const AN_CIARsrc = $20000000;


AN_ConsoleDev

Console AlertCode for Alert()

Declaration

Source position: exec.pas line 905

const AN_ConsoleDev = $11000000;


AN_CreatePort

Intuition AlertCode for Alert() create port, no memory

Declaration

Source position: exec.pas line 850

const AN_CreatePort = $84010002;


AN_DiskBlkSeq

Dos AlertCode for Alert() Disk block sequence error

Declaration

Source position: exec.pas line 877

const AN_DiskBlkSeq = $07000006;


AN_DiskCopy

Diskcopy AlertCode for Alert()

Declaration

Source position: exec.pas line 948

const AN_DiskCopy = $32000000;


AN_DiskError

Dos AlertCode for Alert() Disk Error

Declaration

Source position: exec.pas line 881

const AN_DiskError = $0700000A;


AN_DiskfontLib

DiskFont AlertCode for Alert()

Declaration

Source position: exec.pas line 899

const AN_DiskfontLib = $0B000000;


AN_DiskRsrc

Disk AlertCode for Alert()

Declaration

Source position: exec.pas line 928

const AN_DiskRsrc = $21000000;


AN_DOSLib

Dos AlertCode for Alert()

Declaration

Source position: exec.pas line 871

const AN_DOSLib = $07000000;


AN_DRHasDisk

Disk AlertCode for Alert() get unit: already has disk

Declaration

Source position: exec.pas line 929

const AN_DRHasDisk = $21000001;


AN_DRIntNoAct

Disk AlertCode for Alert() interrupt: no active unit

Declaration

Source position: exec.pas line 930

const AN_DRIntNoAct = $21000002;


AN_EndTask

Dos AlertCode for Alert() EndTask didn't end the Task

Declaration

Source position: exec.pas line 873

const AN_EndTask = $07000002;


AN_ExcptVect

Exec AlertCode for Alert() 68000 exception vector checksum (obs.)

Declaration

Source position: exec.pas line 806

const AN_ExcptVect = $01000001;


AN_ExecLib

Exec AlertCode for Alert()

Declaration

Source position: exec.pas line 805

const AN_ExecLib = $01000000;


AN_ExpansionLib

Expansion AlertCode for Alert()

Declaration

Source position: exec.pas line 895

const AN_ExpansionLib = $0A000000;


AN_FileReclosed

Dos AlertCode for Alert() A filehandle was closed more than once

Declaration

Source position: exec.pas line 885

const AN_FileReclosed = $0700000E;


AN_FreeTwice

Exec AlertCode for Alert() Freeing memory already freed

Declaration

Source position: exec.pas line 815

const AN_FreeTwice = $01000009;


AN_FreeVec

Dos AlertCode for Alert() Freevec failed

Declaration

Source position: exec.pas line 876

const AN_FreeVec = $07000005;


AN_GadgetType

Intuition AlertCode for Alert() unknown gadget type

Declaration

Source position: exec.pas line 848

const AN_GadgetType = $84000001;


AN_GadTools

Gadtools AlertCode for Alert()

Declaration

Source position: exec.pas line 951

const AN_GadTools = $33000000;


AN_GamePortDev

Gameport AlertCode for Alert()

Declaration

Source position: exec.pas line 909

const AN_GamePortDev = $12000000;


AN_GfxFreeError

Graphics AlertCode for Alert()

Declaration

Source position: exec.pas line 836

const AN_GfxFreeError = $0200000D;


AN_GfxNewError

Graphics AlertCode for Alert()

Declaration

Source position: exec.pas line 835

const AN_GfxNewError = $0200000C;


AN_GfxNoLCM

Graphics AlertCode for Alert() emergency memory not available

Declaration

Source position: exec.pas line 838

const AN_GfxNoLCM = $82011234;


AN_GfxNoMem

Graphics AlertCode for Alert() graphics out of memory

Declaration

Source position: exec.pas line 827

const AN_GfxNoMem = $82010000;


AN_GfxNoMemMspc

Graphics AlertCode for Alert() MonitorSpec alloc, no memory

Declaration

Source position: exec.pas line 828

const AN_GfxNoMemMspc = $82010001;


AN_GraphicsLib

Graphics AlertCode for Alert()

Declaration

Source position: exec.pas line 826

const AN_GraphicsLib = $02000000;


AN_IconLib

Icon AlertCode for Alert()

Declaration

Source position: exec.pas line 892

const AN_IconLib = $09000000;


AN_InitAPtr

Exec AlertCode for Alert() InitStruct() of an APTR source (obs.)

Declaration

Source position: exec.pas line 812

const AN_InitAPtr = $01000007;


AN_IntrMem

Exec AlertCode for Alert() No memory for interrupt servers

Declaration

Source position: exec.pas line 811

const AN_IntrMem = $81000006;


AN_Intuition

Intuition AlertCode for Alert()

Declaration

Source position: exec.pas line 847

const AN_Intuition = $04000000;


AN_IOAfterClose

Exec AlertCode for Alert() IO attempted on closed IORequest

Declaration

Source position: exec.pas line 820

const AN_IOAfterClose = $0100000D;


AN_IOUsedTwice

Exec AlertCode for Alert() Attempt to reuse active IORequest

Declaration

Source position: exec.pas line 817

const AN_IOUsedTwice = $0100000B;


AN_ISemOrder

Intuition AlertCode for Alert() Intuition obtained a semaphore in bad order

Declaration

Source position: exec.pas line 865

const AN_ISemOrder = $04000011;


AN_ItemAlloc

Intuition AlertCode for Alert() item plane alloc, no memory

Declaration

Source position: exec.pas line 851

const AN_ItemAlloc = $04010003;


AN_ItemBoxTop

Intuition AlertCode for Alert() item box top smaller than RelZero

Declaration

Source position: exec.pas line 854

const AN_ItemBoxTop = $84000006;


AN_KeyboardDev

Keyboard AlertCode for Alert()

Declaration

Source position: exec.pas line 912

const AN_KeyboardDev = $13000000;


AN_KeyFree

Dos AlertCode for Alert() Key already free

Declaration

Source position: exec.pas line 879

const AN_KeyFree = $07000008;


AN_KeyRange

Dos AlertCode for Alert() Key out of range

Declaration

Source position: exec.pas line 882

const AN_KeyRange = $0700000B;


AN_LayersLib

Layers AlertCode for Alert()

Declaration

Source position: exec.pas line 843

const AN_LayersLib = $03000000;


AN_LayersNoMem

Layers AlertCode for Alert() layers out of memory

Declaration

Source position: exec.pas line 844

const AN_LayersNoMem = $83010000;


AN_LibChkSum

Exec AlertCode for Alert() Library checksum failure

Declaration

Source position: exec.pas line 808

const AN_LibChkSum = $01000003;


AN_LongFrame

Graphics AlertCode for Alert() long frame, no memory

Declaration

Source position: exec.pas line 829

const AN_LongFrame = $82010006;


AN_MakeVPort

Graphics AlertCode for Alert() MakeVPort, no memory

Declaration

Source position: exec.pas line 834

const AN_MakeVPort = $82010030;


AN_MathLib

Math AlertCode for Alert()

Declaration

Source position: exec.pas line 868

const AN_MathLib = $05000000;


AN_MemCorrupt

Exec AlertCode for Alert() Corrupt memory list detected in exec.ExecFreeMem

Declaration

Source position: exec.pas line 810

const AN_MemCorrupt = $81000005;


AN_MemoryInsane

Exec AlertCode for Alert() Sanity check on memory list failed during AvailMem(MEMF_LARGEST)

Declaration

Source position: exec.pas line 818

const AN_MemoryInsane = $0100000C;


AN_MiscRsrc

Misc AlertCode for Alert()

Declaration

Source position: exec.pas line 933

const AN_MiscRsrc = $22000000;


AN_NoConsole

Intuition AlertCode for Alert() couldn't open the Console Device

Declaration

Source position: exec.pas line 863

const AN_NoConsole = $8400000F;


AN_NoFonts

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 941

const AN_NoFonts = $B1000001;


AN_NoISem

Intuition AlertCode for Alert() Intuition skipped obtaining a semaphore

Declaration

Source position: exec.pas line 864

const AN_NoISem = $04000010;


AN_NoWindow

Console AlertCode for Alert() Console can't open initial window

Declaration

Source position: exec.pas line 906

const AN_NoWindow = $11000001;


AN_ObsoleteFont

Graphics AlertCode for Alert() unsupported font description used

Declaration

Source position: exec.pas line 840

const AN_ObsoleteFont = $02000401;


AN_OpenScreen

Intuition AlertCode for Alert() open screen, no memory

Declaration

Source position: exec.pas line 855

const AN_OpenScreen = $84010007;


AN_OpenScrnRast

Intuition AlertCode for Alert() open screen, raster alloc, no memory

Declaration

Source position: exec.pas line 856

const AN_OpenScrnRast = $84010008;


AN_OpenWindow

Intuition AlertCode for Alert() open window, no memory

Declaration

Source position: exec.pas line 859

const AN_OpenWindow = $8401000B;


AN_PlaneAlloc

Intuition AlertCode for Alert() plane alloc, no memory

Declaration

Source position: exec.pas line 853

const AN_PlaneAlloc = $84010005;


AN_QPktFail

Dos AlertCode for Alert() Qpkt failure

Declaration

Source position: exec.pas line 874

const AN_QPktFail = $07000003;


AN_RAMLib

Ramlib AlertCode for Alert()

Declaration

Source position: exec.pas line 888

const AN_RAMLib = $08000000;


AN_RegionMemory

Graphics AlertCode for Alert() regions, memory not available

Declaration

Source position: exec.pas line 833

const AN_RegionMemory = $8201000B;


AN_SemCorrupt

Exec AlertCode for Alert() A semaphore is in an illegal state at ReleaseSempahore

Declaration

Source position: exec.pas line 813

const AN_SemCorrupt = $01000008;


AN_ShortFrame

Graphics AlertCode for Alert() short frame, no memory

Declaration

Source position: exec.pas line 830

const AN_ShortFrame = $82010007;


AN_StackProbe

Exec AlertCode for Alert() Stack appears to extend out of range

Declaration

Source position: exec.pas line 821

const AN_StackProbe = $0100000E;


AN_StartMem

Dos AlertCode for Alert() no memory at startup

Declaration

Source position: exec.pas line 872

const AN_StartMem = $07010001;


AN_SubAlloc

Intuition AlertCode for Alert() sub alloc, no memory

Declaration

Source position: exec.pas line 852

const AN_SubAlloc = $04010004;


AN_SysScrnType

Intuition AlertCode for Alert() open sys screen, unknown type

Declaration

Source position: exec.pas line 857

const AN_SysScrnType = $84000009;


AN_TDCalibSeek

Trackdisk AlertCode for Alert() calibrate: seek error

Declaration

Source position: exec.pas line 916

const AN_TDCalibSeek = $14000001;


AN_TDDelay

Trackdisk AlertCode for Alert() delay: error on timer wait

Declaration

Source position: exec.pas line 917

const AN_TDDelay = $14000002;


AN_TextTmpRas

Graphics AlertCode for Alert() text, no memory for TmpRas

Declaration

Source position: exec.pas line 831

const AN_TextTmpRas = $02010009;


AN_TimerDev

Timer AlertCode for Alert()

Declaration

Source position: exec.pas line 920

const AN_TimerDev = $15000000;


AN_TMBadReq

Timer AlertCode for Alert() bad request

Declaration

Source position: exec.pas line 921

const AN_TMBadReq = $15000001;


AN_TMBadSupply

Timer AlertCode for Alert() power supply -- no 50/60Hz ticks

Declaration

Source position: exec.pas line 922

const AN_TMBadSupply = $15000002;


AN_TrackDiskDev

Trackdisk AlertCode for Alert()

Declaration

Source position: exec.pas line 915

const AN_TrackDiskDev = $14000000;


AN_Unknown

utility AlertCode for Alert()

Declaration

Source position: exec.pas line 957

const AN_Unknown = $35000000;


AN_UtilityLib

utility AlertCode for Alert()

Declaration

Source position: exec.pas line 954

const AN_UtilityLib = $34000000;


AN_WBBadIOMsg

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 944

const AN_WBBadIOMsg = $31000003;


AN_WBBadStartupMsg1

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 942

const AN_WBBadStartupMsg1 = $31000001;


AN_WBBadStartupMsg2

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 943

const AN_WBBadStartupMsg2 = $31000002;


AN_WBReLayoutToolMenu

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 945

const AN_WBReLayoutToolMenu = $B1010009;


AN_WeirdEcho

Intuition AlertCode for Alert() Weird echo causing incomprehension

Declaration

Source position: exec.pas line 862

const AN_WeirdEcho = $8400000E;


AN_Workbench

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 940

const AN_Workbench = $31000000;


AO_AudioDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 787

const AO_AudioDev = $00008010;


AO_BootStrap

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 798

const AO_BootStrap = $00008030;


AO_CIARsrc

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 794

const AO_CIARsrc = $00008020;


AO_ConsoleDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 788

const AO_ConsoleDev = $00008011;


AO_DiskCopy

AlertCode for Alert()

Declaration

Source position: exec.pas line 800

const AO_DiskCopy = $00008032;


AO_DiskfontLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 783

const AO_DiskfontLib = $0000800B;


AO_DiskRsrc

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 795

const AO_DiskRsrc = $00008021;


AO_DOSLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 779

const AO_DOSLib = $00008007;


AO_ExecLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 774

const AO_ExecLib = $00008001;


AO_ExpansionLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 782

const AO_ExpansionLib = $0000800A;


AO_GadTools

AlertCode for Alert()

Declaration

Source position: exec.pas line 801

const AO_GadTools = $00008033;


AO_GamePortDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 789

const AO_GamePortDev = $00008012;


AO_GraphicsLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 775

const AO_GraphicsLib = $00008002;


AO_IconLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 781

const AO_IconLib = $00008009;


AO_Intuition

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 777

const AO_Intuition = $00008004;


AO_KeyboardDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 790

const AO_KeyboardDev = $00008013;


AO_KeyMapLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 785

const AO_KeyMapLib = $0000800D;


AO_LayersLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 776

const AO_LayersLib = $00008003;


AO_MathLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 778

const AO_MathLib = $00008005;


AO_MiscRsrc

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 796

const AO_MiscRsrc = $00008022;


AO_RAMLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 780

const AO_RAMLib = $00008008;


AO_TimerDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 792

const AO_TimerDev = $00008015;


AO_TrackDiskDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 791

const AO_TrackDiskDev = $00008014;


AO_Unknown

AlertCode for Alert()

Declaration

Source position: exec.pas line 802

const AO_Unknown = $00008035;


AO_UtilityLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 784

const AO_UtilityLib = $0000800C;


AO_Workbench

AlertCode for Alert()

Declaration

Source position: exec.pas line 799

const AO_Workbench = $00008031;


APTR

A type free pointer.

Declaration

Source position: exec.pas line 29

type APTR = Pointer;


AT_DeadEnd

CPU AlertCode for Alert() Alert type. Error can not be recovered, Computer must be restarted.

Declaration

Source position: exec.pas line 758

const AT_DeadEnd = $80000000;


AT_Recovery

CPU AlertCode for Alert() Alert type. Error can be recovered, system can continue running.

Declaration

Source position: exec.pas line 759

const AT_Recovery = $00000000;


BOOL

Boolean representation

Declaration

Source position: exec.pas line 32

type BOOL = SmallInt;


BPTR

A type free pointer. in ABIv0 its just a Pointer.

Declaration

Source position: exec.pas line 30

type BPTR = LongInt;


BSTR

Pointer to a string, in ABIv0 just like PChar.

Declaration

Source position: exec.pas line 31

type BSTR = LongInt;


CACRF_ClearD

Declaration

Source position: exec.pas line 1488

const CACRF_ClearD = 1 shl 11;


CACRF_ClearI

Declaration

Source position: exec.pas line 1484

const CACRF_ClearI = 1 shl 3;


CACRF_CopyBack

Declaration

Source position: exec.pas line 1492

const CACRF_CopyBack = 1 shl 31;


CACRF_DBE

Declaration

Source position: exec.pas line 1489

const CACRF_DBE = 1 shl 12;


CACRF_EnableD

Declaration

Source position: exec.pas line 1486

const CACRF_EnableD = 1 shl 8;


CACRF_EnableE

Declaration

Source position: exec.pas line 1491

const CACRF_EnableE = 1 shl 30;


CACRF_EnableI

Declaration

Source position: exec.pas line 1482

const CACRF_EnableI = 1 shl 0;


CACRF_FreezeD

Declaration

Source position: exec.pas line 1487

const CACRF_FreezeD = 1 shl 9;


CACRF_FreezeI

Declaration

Source position: exec.pas line 1483

const CACRF_FreezeI = 1 shl 1;


CACRF_IBE

Declaration

Source position: exec.pas line 1485

const CACRF_IBE = 1 shl 4;


CACRF_WriteAllocate

Declaration

Source position: exec.pas line 1490

const CACRF_WriteAllocate = 1 shl 13;


CMD_CLEAR

Declaration

Source position: exec.pas line 1362

const CMD_CLEAR = 5;


CMD_FLUSH

Declaration

Source position: exec.pas line 1365

const CMD_FLUSH = 8;


CMD_INVALID

Declaration

Source position: exec.pas line 1357

const CMD_INVALID = 0;


CMD_NONSTD

Declaration

Source position: exec.pas line 1366

const CMD_NONSTD = 9;


CMD_READ

Declaration

Source position: exec.pas line 1359

const CMD_READ = 2;


CMD_RESET

Declaration

Source position: exec.pas line 1358

const CMD_RESET = 1;


CMD_START

Declaration

Source position: exec.pas line 1364

const CMD_START = 7;


CMD_STOP

Declaration

Source position: exec.pas line 1363

const CMD_STOP = 6;


CMD_UPDATE

Declaration

Source position: exec.pas line 1361

const CMD_UPDATE = 4;


CMD_WRITE

Declaration

Source position: exec.pas line 1360

const CMD_WRITE = 3;


CODETYPE_M68K

Declaration

Source position: exec.pas line 529

const CODETYPE_M68K = $0;


CODETYPE_PPC

Declaration

Source position: exec.pas line 531

const CODETYPE_PPC = $1;


CPUTBSTACKTRACECOUNT

Declaration

Source position: exec.pas line 1374

const CPUTBSTACKTRACECOUNT = 16;


DEFAULT_M68KSTACKSIZE

Declaration

Source position: exec.pas line 726

const DEFAULT_M68KSTACKSIZE = 2048;


DEFAULT_PPCSTACKSIZE

Declaration

Source position: exec.pas line 725

const DEFAULT_PPCSTACKSIZE = 32768;


DEFAULT_TASKPUDDLESIZE

Declaration

Source position: exec.pas line 727

const DEFAULT_TASKPUDDLESIZE = 4096;


DEFAULT_TASKTHRESHSIZE

Declaration

Source position: exec.pas line 728

const DEFAULT_TASKTHRESHSIZE = 4096;


DEV_ABORTIO

Declaration

Source position: exec.pas line 1352

const DEV_ABORTIO = - 36;


DEV_BEGINIO

Declaration

Source position: exec.pas line 1351

const DEV_BEGINIO = - 30;


DMA_Continue

Declaration

Source position: exec.pas line 1494

const DMA_Continue = 1 shl 1;


DMA_NoModify

Declaration

Source position: exec.pas line 1495

const DMA_NoModify = 1 shl 2;


DMA_ReadFromRAM

Declaration

Source position: exec.pas line 1496

const DMA_ReadFromRAM = 1 shl 3;


EMULTAG_EMULHANDLE

Declaration

Source position: exec.pas line 77

const EMULTAG_EMULHANDLE = $5;


EMULTAG_EMULHANDLESIZE

Declaration

Source position: exec.pas line 78

const EMULTAG_EMULHANDLESIZE = $6;


EMULTAG_NAME

Declaration

Source position: exec.pas line 72

const EMULTAG_NAME = $0;


EMULTAG_OPCODETABLE

Declaration

Source position: exec.pas line 75

const EMULTAG_OPCODETABLE = $3;


EMULTAG_REVISION

Declaration

Source position: exec.pas line 74

const EMULTAG_REVISION = $2;


EMULTAG_SUPERHANDLE

Declaration

Source position: exec.pas line 79

const EMULTAG_SUPERHANDLE = $7;


EMULTAG_SUPERHANDLESIZE

Declaration

Source position: exec.pas line 80

const EMULTAG_SUPERHANDLESIZE = $8;


EMULTAG_TYPE

Declaration

Source position: exec.pas line 76

const EMULTAG_TYPE = $4;


EMULTAG_VERSION

Declaration

Source position: exec.pas line 73

const EMULTAG_VERSION = $1;


ExecBase

Declaration

Source position: exec.pas line 1760

var ExecBase: PExecBase;


EXECDEBUGF_ADDDOSNODE

Declaration

Source position: exec.pas line 1524

const EXECDEBUGF_ADDDOSNODE = $2000;


EXECDEBUGF_ADDTASK

Declaration

Source position: exec.pas line 1518

const EXECDEBUGF_ADDTASK = $100;


EXECDEBUGF_CGXDEBUG

Declaration

Source position: exec.pas line 1560

const EXECDEBUGF_CGXDEBUG = $08000000;


EXECDEBUGF_CHIPRAM

Declaration

Source position: exec.pas line 1516

const EXECDEBUGF_CHIPRAM = $80;


EXECDEBUGF_CREATELIBRARY

Declaration

Source position: exec.pas line 1513

const EXECDEBUGF_CREATELIBRARY = $10;


EXECDEBUGF_CYBERGUARDDEADLY

Declaration

Source position: exec.pas line 1545

const EXECDEBUGF_CYBERGUARDDEADLY = $400000;


EXECDEBUGF_EXCEPTHANDLER

Declaration

Source position: exec.pas line 1523

const EXECDEBUGF_EXCEPTHANDLER = $1000;


EXECDEBUGF_FINDRESIDENT

Declaration

Source position: exec.pas line 1511

const EXECDEBUGF_FINDRESIDENT = $4;


EXECDEBUGF_GETTASKATTR

Declaration

Source position: exec.pas line 1520

const EXECDEBUGF_GETTASKATTR = $400;


EXECDEBUGF_INIT

Declaration

Source position: exec.pas line 1565

const EXECDEBUGF_INIT = $40000000;


EXECDEBUGF_INITCODE

Declaration

Source position: exec.pas line 1510

const EXECDEBUGF_INITCODE = $2;


EXECDEBUGF_INITRESIDENT

Declaration

Source position: exec.pas line 1509

const EXECDEBUGF_INITRESIDENT = $1;


EXECDEBUGF_LOADSEG

Declaration

Source position: exec.pas line 1549

const EXECDEBUGF_LOADSEG = $01000000;


EXECDEBUGF_LOG

Declaration

Source position: exec.pas line 1570

const EXECDEBUGF_LOG = $80000000;


EXECDEBUGF_LOGFILE

Declaration

Source position: exec.pas line 1535

const EXECDEBUGF_LOGFILE = $40000;


EXECDEBUGF_LOGKPRINTF

Declaration

Source position: exec.pas line 1536

const EXECDEBUGF_LOGKPRINTF = $80000;


EXECDEBUGF_MEMTRACK

Declaration

Source position: exec.pas line 1541

const EXECDEBUGF_MEMTRACK = $200000;


EXECDEBUGF_NEWSETFUNCTION

Declaration

Source position: exec.pas line 1515

const EXECDEBUGF_NEWSETFUNCTION = $40;


EXECDEBUGF_NOLOGSERVER

Declaration

Source position: exec.pas line 1528

const EXECDEBUGF_NOLOGSERVER = $10000;


EXECDEBUGF_NOLOGWINDOW

Declaration

Source position: exec.pas line 1529

const EXECDEBUGF_NOLOGWINDOW = $20000;


EXECDEBUGF_PCI

Declaration

Source position: exec.pas line 1525

const EXECDEBUGF_PCI = $4000;


EXECDEBUGF_PERMMEMTRACK

Declaration

Source position: exec.pas line 1540

const EXECDEBUGF_PERMMEMTRACK = $100000;


EXECDEBUGF_PPCSTART

Declaration

Source position: exec.pas line 1551

const EXECDEBUGF_PPCSTART = $04000000;


EXECDEBUGF_RAMLIB

Declaration

Source position: exec.pas line 1526

const EXECDEBUGF_RAMLIB = $8000;


EXECDEBUGF_REMTASK

Declaration

Source position: exec.pas line 1519

const EXECDEBUGF_REMTASK = $200;


EXECDEBUGF_SETFUNCTION

Declaration

Source position: exec.pas line 1514

const EXECDEBUGF_SETFUNCTION = $20;


EXECDEBUGF_SETTASKATTR

Declaration

Source position: exec.pas line 1521

const EXECDEBUGF_SETTASKATTR = $800;


EXECDEBUGF_UNLOADSEG

Declaration

Source position: exec.pas line 1550

const EXECDEBUGF_UNLOADSEG = $02000000;


EXECLIST_DEVICE

Declaration

Source position: exec.pas line 1575

const EXECLIST_DEVICE = 0;


EXECLIST_INTERRUPT

Declaration

Source position: exec.pas line 1576

const EXECLIST_INTERRUPT = 1;


EXECLIST_LIBRARY

Declaration

Source position: exec.pas line 1577

const EXECLIST_LIBRARY = 2;


EXECLIST_MEMHANDLER

Declaration

Source position: exec.pas line 1578

const EXECLIST_MEMHANDLER = 3;


EXECLIST_MEMHEADER

Declaration

Source position: exec.pas line 1579

const EXECLIST_MEMHEADER = 4;


EXECLIST_PORT

Declaration

Source position: exec.pas line 1580

const EXECLIST_PORT = 5;


EXECLIST_RESOURCE

Declaration

Source position: exec.pas line 1581

const EXECLIST_RESOURCE = 6;


EXECLIST_SEMAPHORE

Declaration

Source position: exec.pas line 1582

const EXECLIST_SEMAPHORE = 7;


EXECLIST_TASK

Declaration

Source position: exec.pas line 1583

const EXECLIST_TASK = 8;


EXECNOTIFYF_POST

Declaration

Source position: exec.pas line 1601

const EXECNOTIFYF_POST = 1 shl 1;


EXECNOTIFYF_REMOVE

Declaration

Source position: exec.pas line 1600

const EXECNOTIFYF_REMOVE = 1 shl 0;


FUNCARRAY_16BIT_OLD

Declaration

Source position: exec.pas line 1174

const FUNCARRAY_16BIT_OLD = $ffffffff;


FUNCARRAY_32BIT_D0D1_NATIVE

Declaration

Source position: exec.pas line 1250

const FUNCARRAY_32BIT_D0D1_NATIVE = $fff6fff6;


FUNCARRAY_32BIT_D0D1A0A1SR_NATIVE

Declaration

Source position: exec.pas line 1288

const FUNCARRAY_32BIT_D0D1A0A1SR_NATIVE = $fff2fff2;


FUNCARRAY_32BIT_D0D1SR_NATIVE

Declaration

Source position: exec.pas line 1283

const FUNCARRAY_32BIT_D0D1SR_NATIVE = $fff3fff3;


FUNCARRAY_32BIT_NATIVE

Declaration

Source position: exec.pas line 1179

const FUNCARRAY_32BIT_NATIVE = $fffefffe;


FUNCARRAY_32BIT_NR_NATIVE

Declaration

Source position: exec.pas line 1235

const FUNCARRAY_32BIT_NR_NATIVE = $fff9fff9;


FUNCARRAY_32BIT_QUICK_NATIVE

Declaration

Source position: exec.pas line 1225

const FUNCARRAY_32BIT_QUICK_NATIVE = $fffbfffb;


FUNCARRAY_32BIT_QUICKNR_NATIVE

Declaration

Source position: exec.pas line 1230

const FUNCARRAY_32BIT_QUICKNR_NATIVE = $fffafffa;


FUNCARRAY_32BIT_RESTORE_NATIVE

Declaration

Source position: exec.pas line 1255

const FUNCARRAY_32BIT_RESTORE_NATIVE = $fff5fff5;


FUNCARRAY_32BIT_SR_NATIVE

Declaration

Source position: exec.pas line 1240

const FUNCARRAY_32BIT_SR_NATIVE = $fff8fff8;


FUNCARRAY_32BIT_SRNR_NATIVE

Declaration

Source position: exec.pas line 1245

const FUNCARRAY_32BIT_SRNR_NATIVE = $fff7fff7;


FUNCARRAY_32BIT_SYSTEMV

Declaration

Source position: exec.pas line 1278

const FUNCARRAY_32BIT_SYSTEMV = $fff4fff4;


FUNCARRAY_BEGIN

Declaration

Source position: exec.pas line 1206

const FUNCARRAY_BEGIN = $fffdfffd;


FUNCARRAY_END

Declaration

Source position: exec.pas line 1210

const FUNCARRAY_END = $fffcfffc;


FUNCENTRYEXTF_LIBRARY

Declaration

Source position: exec.pas line 1159

const FUNCENTRYEXTF_LIBRARY = $1;


FUNCENTRYEXTF_SETFUNCTION

Declaration

Source position: exec.pas line 1160

const FUNCENTRYEXTF_SETFUNCTION = $2;


Reference for unit 'exec'

This unit contains the types and wrapper functions for the exec.library.

uses

  System;

Overview

This unit contains the types and wrapper functions for the exec.library. This library supports the very basic functions of Amiga. It provides function for working with other libraries, tasks and other basic structures.


Reference for unit 'exec': Constants

ACPU_AddressErr | CPU AlertCode for Alert() Illegal address access (ie: odd)
ACPU_AutoVec1 | CPU AlertCode for Alert() AutoVector Level 1 interrupt error
ACPU_AutoVec2 | CPU AlertCode for Alert() AutoVector Level 2 interrupt error
ACPU_AutoVec3 | CPU AlertCode for Alert() AutoVector Level 3 interrupt error
ACPU_AutoVec4 | CPU AlertCode for Alert() AutoVector Level 4 interrupt error
ACPU_AutoVec5 | CPU AlertCode for Alert() AutoVector Level 5 interrupt error
ACPU_AutoVec6 | CPU AlertCode for Alert() AutoVector Level 6 interrupt error
ACPU_AutoVec7 | CPU AlertCode for Alert() AutoVector Level 7 interrupt error
ACPU_BusErr | CPU AlertCode for Alert() Hardware bus fault/access error
ACPU_CHK | CPU AlertCode for Alert() Check instruction error
ACPU_DivZero | CPU AlertCode for Alert() Divide by zero
ACPU_Format | CPU AlertCode for Alert() Stack frame format error
ACPU_InstErr | CPU AlertCode for Alert() Illegal instruction
ACPU_LineA | CPU AlertCode for Alert() Line 1010 Emulator error
ACPU_LineF | CPU AlertCode for Alert() Line 1111 Emulator error
ACPU_PrivErr | CPU AlertCode for Alert() Privilege violation error
ACPU_Spurious | CPU AlertCode for Alert() Spurious interrupt error
ACPU_Trace | CPU AlertCode for Alert() Trace error
ACPU_TRAPV | CPU AlertCode for Alert() TrapV instruction error
AFB_68010 |
AFB_68020 |
AFB_68030 |
AFB_68040 |
AFB_68060 |
AFB_68881 |
AFB_68882 |
AFB_FPU40 |
AFB_PRIVATE |
AFF_68010 |
AFF_68020 |
AFF_68030 |
AFF_68040 |
AFF_68060 |
AFF_68881 |
AFF_68882 |
AFF_FPU40 |
AFF_PRIVATE |
AG_BadParm | General AlertCode for Alert()
AG_CloseDev | General AlertCode for Alert() Usually too many closes or a mismatched close
AG_CloseLib | General AlertCode for Alert() Usually too many closes or a mismatched close
AG_IOError | General AlertCode for Alert()
AG_MakeLib | General AlertCode for Alert()
AG_MsgPortNotEmpty |
AG_NoMemory | General AlertCode for Alert()
AG_NoSignal | General AlertCode for Alert()
AG_OpenDev | General AlertCode for Alert()
AG_OpenLib | General AlertCode for Alert()
AG_OpenRes | General AlertCode for Alert()
AG_ProcCreate | General AlertCode for Alert() Process creation failed
AN_AddSWGadget | Intuition AlertCode for Alert() add SW gadgets, no memory
AN_AsyncPkt | Dos AlertCode for Alert() Unexpected packet received
AN_AudioDev | Audio AlertCode for Alert()
AN_BadChkSum | Dos AlertCode for Alert() Invalid checksum
AN_BadExpansionFree | Expansion AlertCode for Alert() freeed free region
AN_BadFreeAddr | Exec AlertCode for Alert() Memory header not located. Usually an invalid address passed to exec.ExecFreeMem
AN_BadGadget | Intuition AlertCode for Alert() Recovery form of AN_GadgetType
AN_BadInitFunc | Dos AlertCode for Alert() Invalid init packet for cli/shell
AN_BadMessage | Intuition AlertCode for Alert() Bad Message received by IDCMP
AN_BadOverlay | Dos AlertCode for Alert() Bad overlay
AN_BadSegList | Ramlib AlertCode for Alert() no overlays in library seglists
AN_BadSemaphore | Exec AlertCode for Alert() An attempt was made to use the old message semaphores.
AN_BadState | Intuition AlertCode for Alert() Bad State Return entering Intuition
AN_BaseChkSum | Exec AlertCode for Alert() Execbase checksum (obs.)
AN_BitMap | Dos AlertCode for Alert() Bitmap corrupt
AN_BltBitMap | Graphics AlertCode for Alert() BltBitMap, no memory
AN_BogusExcpt | Exec AlertCode for Alert() illegal 68k exception taken (obs.)
AN_BootError | Bootstrap AlertCode for Alert() boot code returned an error
AN_BootStrap | Bootstrap AlertCode for Alert()
AN_CIARsrc | CIA AlertCode for Alert()
AN_ConsoleDev | Console AlertCode for Alert()
AN_CreatePort | Intuition AlertCode for Alert() create port, no memory
AN_DiskBlkSeq | Dos AlertCode for Alert() Disk block sequence error
AN_DiskCopy | Diskcopy AlertCode for Alert()
AN_DiskError | Dos AlertCode for Alert() Disk Error
AN_DiskfontLib | DiskFont AlertCode for Alert()
AN_DiskRsrc | Disk AlertCode for Alert()
AN_DOSLib | Dos AlertCode for Alert()
AN_DRHasDisk | Disk AlertCode for Alert() get unit: already has disk
AN_DRIntNoAct | Disk AlertCode for Alert() interrupt: no active unit
AN_EndTask | Dos AlertCode for Alert() EndTask didn't end the Task
AN_ExcptVect | Exec AlertCode for Alert() 68000 exception vector checksum (obs.)
AN_ExecLib | Exec AlertCode for Alert()
AN_ExpansionLib | Expansion AlertCode for Alert()
AN_FileReclosed | Dos AlertCode for Alert() A filehandle was closed more than once
AN_FreeTwice | Exec AlertCode for Alert() Freeing memory already freed
AN_FreeVec | Dos AlertCode for Alert() Freevec failed
AN_GadgetType | Intuition AlertCode for Alert() unknown gadget type
AN_GadTools | Gadtools AlertCode for Alert()
AN_GamePortDev | Gameport AlertCode for Alert()
AN_GfxFreeError | Graphics AlertCode for Alert()
AN_GfxNewError | Graphics AlertCode for Alert()
AN_GfxNoLCM | Graphics AlertCode for Alert() emergency memory not available
AN_GfxNoMem | Graphics AlertCode for Alert() graphics out of memory
AN_GfxNoMemMspc | Graphics AlertCode for Alert() MonitorSpec alloc, no memory
AN_GraphicsLib | Graphics AlertCode for Alert()
AN_IconLib | Icon AlertCode for Alert()
AN_InitAPtr | Exec AlertCode for Alert() InitStruct() of an APTR source (obs.)
AN_IntrMem | Exec AlertCode for Alert() No memory for interrupt servers
AN_Intuition | Intuition AlertCode for Alert()
AN_IOAfterClose | Exec AlertCode for Alert() IO attempted on closed IORequest
AN_IOUsedTwice | Exec AlertCode for Alert() Attempt to reuse active IORequest
AN_ISemOrder | Intuition AlertCode for Alert() Intuition obtained a semaphore in bad order
AN_ItemAlloc | Intuition AlertCode for Alert() item plane alloc, no memory
AN_ItemBoxTop | Intuition AlertCode for Alert() item box top smaller than RelZero
AN_KeyboardDev | Keyboard AlertCode for Alert()
AN_KeyFree | Dos AlertCode for Alert() Key already free
AN_KeyRange | Dos AlertCode for Alert() Key out of range
AN_LayersLib | Layers AlertCode for Alert()
AN_LayersNoMem | Layers AlertCode for Alert() layers out of memory
AN_LibChkSum | Exec AlertCode for Alert() Library checksum failure
AN_LongFrame | Graphics AlertCode for Alert() long frame, no memory
AN_MakeVPort | Graphics AlertCode for Alert() MakeVPort, no memory
AN_MathLib | Math AlertCode for Alert()
AN_MemCorrupt | Exec AlertCode for Alert() Corrupt memory list detected in exec.ExecFreeMem
AN_MemoryInsane | Exec AlertCode for Alert() Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
AN_MiscRsrc | Misc AlertCode for Alert()
AN_NoConsole | Intuition AlertCode for Alert() couldn't open the Console Device
AN_NoFonts | Workbench AlertCode for Alert()
AN_NoISem | Intuition AlertCode for Alert() Intuition skipped obtaining a semaphore
AN_NoWindow | Console AlertCode for Alert() Console can't open initial window
AN_ObsoleteFont | Graphics AlertCode for Alert() unsupported font description used
AN_OpenScreen | Intuition AlertCode for Alert() open screen, no memory
AN_OpenScrnRast | Intuition AlertCode for Alert() open screen, raster alloc, no memory
AN_OpenWindow | Intuition AlertCode for Alert() open window, no memory
AN_PlaneAlloc | Intuition AlertCode for Alert() plane alloc, no memory
AN_QPktFail | Dos AlertCode for Alert() Qpkt failure
AN_RAMLib | Ramlib AlertCode for Alert()
AN_RegionMemory | Graphics AlertCode for Alert() regions, memory not available
AN_SemCorrupt | Exec AlertCode for Alert() A semaphore is in an illegal state at ReleaseSempahore
AN_ShortFrame | Graphics AlertCode for Alert() short frame, no memory
AN_StackProbe | Exec AlertCode for Alert() Stack appears to extend out of range
AN_StartMem | Dos AlertCode for Alert() no memory at startup
AN_SubAlloc | Intuition AlertCode for Alert() sub alloc, no memory
AN_SysScrnType | Intuition AlertCode for Alert() open sys screen, unknown type
AN_TDCalibSeek | Trackdisk AlertCode for Alert() calibrate: seek error
AN_TDDelay | Trackdisk AlertCode for Alert() delay: error on timer wait
AN_TextTmpRas | Graphics AlertCode for Alert() text, no memory for TmpRas
AN_TimerDev | Timer AlertCode for Alert()
AN_TMBadReq | Timer AlertCode for Alert() bad request
AN_TMBadSupply | Timer AlertCode for Alert() power supply -- no 50/60Hz ticks
AN_TrackDiskDev | Trackdisk AlertCode for Alert()
AN_Unknown | utility AlertCode for Alert()
AN_UtilityLib | utility AlertCode for Alert()
AN_WBBadIOMsg | Workbench AlertCode for Alert()
AN_WBBadStartupMsg1 | Workbench AlertCode for Alert()
AN_WBBadStartupMsg2 | Workbench AlertCode for Alert()
AN_WBReLayoutToolMenu | Workbench AlertCode for Alert()
AN_WeirdEcho | Intuition AlertCode for Alert() Weird echo causing incomprehension
AN_Workbench | Workbench AlertCode for Alert()
AO_AudioDev | Device AlertCode for Alert()
AO_BootStrap | Resource AlertCode for Alert()
AO_CIARsrc | Resource AlertCode for Alert()
AO_ConsoleDev | Device AlertCode for Alert()
AO_DiskCopy | AlertCode for Alert()
AO_DiskfontLib | Library AlertCode for Alert()
AO_DiskRsrc | Resource AlertCode for Alert()
AO_DOSLib | Library AlertCode for Alert()
AO_ExecLib | Library AlertCode for Alert()
AO_ExpansionLib | Library AlertCode for Alert()
AO_GadTools | AlertCode for Alert()
AO_GamePortDev | Device AlertCode for Alert()
AO_GraphicsLib | Library AlertCode for Alert()
AO_IconLib | Library AlertCode for Alert()
AO_Intuition | Library AlertCode for Alert()
AO_KeyboardDev | Device AlertCode for Alert()
AO_KeyMapLib | Library AlertCode for Alert()
AO_LayersLib | Library AlertCode for Alert()
AO_MathLib | Library AlertCode for Alert()
AO_MiscRsrc | Resource AlertCode for Alert()
AO_RAMLib | Library AlertCode for Alert()
AO_TimerDev | Device AlertCode for Alert()
AO_TrackDiskDev | Device AlertCode for Alert()
AO_Unknown | AlertCode for Alert()
AO_UtilityLib | Library AlertCode for Alert()
AO_Workbench | AlertCode for Alert()
AT_DeadEnd | CPU AlertCode for Alert() Alert type. Error can not be recovered, Computer must be restarted.
AT_Recovery | CPU AlertCode for Alert() Alert type. Error can be recovered, system can continue running.
CACRF_ClearD |
CACRF_ClearI |
CACRF_CopyBack |
CACRF_DBE |
CACRF_EnableD |
CACRF_EnableE |
CACRF_EnableI |
CACRF_FreezeD |
CACRF_FreezeI |
CACRF_IBE |
CACRF_WriteAllocate |
CMD_CLEAR |
CMD_FLUSH |
CMD_INVALID |
CMD_NONSTD |
CMD_READ |
CMD_RESET |
CMD_START |
CMD_STOP |
CMD_UPDATE |
CMD_WRITE |
CODETYPE_M68K |
CODETYPE_PPC |
CPUTBSTACKTRACECOUNT |
DEFAULT_M68KSTACKSIZE |
DEFAULT_PPCSTACKSIZE |
DEFAULT_TASKPUDDLESIZE |
DEFAULT_TASKTHRESHSIZE |
DEV_ABORTIO |
DEV_BEGINIO |
DMA_Continue |
DMA_NoModify |
DMA_ReadFromRAM |
EMULTAG_EMULHANDLE |
EMULTAG_EMULHANDLESIZE |
EMULTAG_NAME |
EMULTAG_OPCODETABLE |
EMULTAG_REVISION |
EMULTAG_SUPERHANDLE |
EMULTAG_SUPERHANDLESIZE |
EMULTAG_TYPE |
EMULTAG_VERSION |
EXECDEBUGF_ADDDOSNODE |
EXECDEBUGF_ADDTASK |
EXECDEBUGF_CGXDEBUG |
EXECDEBUGF_CHIPRAM |
EXECDEBUGF_CREATELIBRARY |
EXECDEBUGF_CYBERGUARDDEADLY |
EXECDEBUGF_EXCEPTHANDLER |
EXECDEBUGF_FINDRESIDENT |
EXECDEBUGF_GETTASKATTR |
EXECDEBUGF_INIT |
EXECDEBUGF_INITCODE |
EXECDEBUGF_INITRESIDENT |
EXECDEBUGF_LOADSEG |
EXECDEBUGF_LOG |
EXECDEBUGF_LOGFILE |
EXECDEBUGF_LOGKPRINTF |
EXECDEBUGF_MEMTRACK |
EXECDEBUGF_NEWSETFUNCTION |
EXECDEBUGF_NOLOGSERVER |
EXECDEBUGF_NOLOGWINDOW |
EXECDEBUGF_PCI |
EXECDEBUGF_PERMMEMTRACK |
EXECDEBUGF_PPCSTART |
EXECDEBUGF_RAMLIB |
EXECDEBUGF_REMTASK |
EXECDEBUGF_SETFUNCTION |
EXECDEBUGF_SETTASKATTR |
EXECDEBUGF_UNLOADSEG |
EXECLIST_DEVICE |
EXECLIST_INTERRUPT |
EXECLIST_LIBRARY |
EXECLIST_MEMHANDLER |
EXECLIST_MEMHEADER |
EXECLIST_PORT |
EXECLIST_RESOURCE |
EXECLIST_SEMAPHORE |
EXECLIST_TASK |
EXECNOTIFYF_POST |
EXECNOTIFYF_REMOVE |
FUNCARRAY_16BIT_OLD |
FUNCARRAY_32BIT_D0D1A0A1SR_NATIVE |
FUNCARRAY_32BIT_D0D1SR_NATIVE |
FUNCARRAY_32BIT_D0D1_NATIVE |
FUNCARRAY_32BIT_NATIVE |
FUNCARRAY_32BIT_NR_NATIVE |
FUNCARRAY_32BIT_QUICKNR_NATIVE |
FUNCARRAY_32BIT_QUICK_NATIVE |
FUNCARRAY_32BIT_RESTORE_NATIVE |
FUNCARRAY_32BIT_SRNR_NATIVE |
FUNCARRAY_32BIT_SR_NATIVE |
FUNCARRAY_32BIT_SYSTEMV |
FUNCARRAY_BEGIN |
FUNCARRAY_END |
FUNCENTRYEXTF_LIBRARY |
FUNCENTRYEXTF_SETFUNCTION |
INTB_NMI |
INTF_NMI |
IOB_QUICK |
IOERR_ABORTED | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error request terminated early AbortIO
IOERR_BADADDRESS | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error invalid address (misaligned or bad range)
IOERR_BADLENGTH | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error not a valid length (usually IO_LENGTH)
IOERR_NOCMD | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error command not supported by device
IOERR_NOMEMORY |
IOERR_OPENFAIL | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device/unit failed to open
IOERR_SELFTEST | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error hardware failed self-test
IOERR_UNITBUSY | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device opens ok, but requested unit is busy
IOF_QUICK |
LFalse | Representation of False for Amiga function
LIBF_CHANGED | One or some Library functions are changed.
LIBF_DELEXP | Library should be closed but an other tasks still use it. Waiting.
LIBF_QUERYINFO |
LIBF_RAMLIB |
LIBF_SUMMING | The checksum of Library is currently being calculated.
LIBF_SUMUSED | A checksum error of a Library results into a reset.
LIBTAG_BASE |
LIBTAG_BASESIZE |
LIBTAG_FLAGS |
LIBTAG_FUNCTIONINIT |
LIBTAG_IDSTRING |
LIBTAG_LIBRARYINIT |
LIBTAG_MACHINE |
LIBTAG_NAME |
LIBTAG_PRI |
LIBTAG_PUBLIC |
LIBTAG_QUERYINFO |
LIBTAG_REVISION |
LIBTAG_SEGLIST |
LIBTAG_STRUCTINIT |
LIBTAG_TYPE |
LIBTAG_VERSION |
LIB_BASE |
LIB_CLOSE |
LIB_EXPUNGE |
LIB_EXTFUNC |
LIB_GETQUERYATTR |
LIB_NONSTD |
LIB_OPEN |
LIB_RESERVED |
LIB_USERDEF |
LIB_VECTSIZE |
LTrue | Representation of True for Amiga functions
MACHINE_M68k |
MACHINE_NO |
MACHINE_PPC |
MEMF_24BITDMA | Memory Requirement Type. DMAable memory within 24 bits of address.
MEMF_31BIT |
MEMF_ANY | Memory Requirement Type. Any type of memory will do.
MEMF_CHIP | Memory Requirement Type
MEMF_CLEAR | Memory Requirement Type. Clear the memory when allocate.
MEMF_FAST | Memory Requirement Type
MEMF_KICK | Memory Requirement Type. Memory that can be used for KickTags.
MEMF_LARGEST | Memory Requirement Type. Return the largest available memory block.
MEMF_LOCAL | Memory Requirement Type
MEMF_NO_EXPUNGE | Memory Requirement Type. Do not cause expunge on failure
MEMF_PUBLIC | Memory Requirement Type.
MEMF_REVERSE | Memory Requirement Type
MEMF_SEM_PROTECTED |
MEMF_SWAP |
MEMF_TOTAL | Memory Requirement Type. Return the total size of Memory.
MEMHF_RECYCLE | 0 = First time, 1 = recycle
MEM_ALL_DONE | We did all we could do
MEM_BLOCKMASK |
MEM_BLOCKSIZE |
MEM_DID_NOTHING | Nothing we could do
MEM_TRY_AGAIN | We did some, try the allocation again
NT_BOOTNODE | For TNode.ln_Type
NT_DEATHMESSAGE | For TNode.ln_Type
NT_DEVICE | For TNode.ln_Type identifies a device
NT_EXTENDED | For TNode.ln_Type
NT_FONT | For TNode.ln_Type
NT_FREEMSG | For TNode.ln_Type Message has beed freed
NT_GRAPHICS | For TNode.ln_Type
NT_INTERRUPT | For TNode.ln_Type identifies an interrupt
NT_KICKMEM | For TNode.ln_Type
NT_LIBRARY | For TNode.ln_Type
NT_MEMORY | For TNode.ln_Type
NT_MESSAGE | For TNode.ln_Type indicates message is currently pending
NT_MSGPORT | For TNode.ln_Type identifies a message port
NT_PROCESS | For TNode.ln_Type identifies and Amiga Dos process
NT_REPLYMSG | For TNode.ln_Type Message has been replied
NT_RESOURCE | For TNode.ln_Type
NT_SEMAPHORE | For TNode.ln_Type
NT_SIGNALSEM | For TNode.ln_Type identifies an signal semaphore
NT_SOFTINT | For TNode.ln_Type Internal flag used ny SoftInits
NT_TASK | For TNode.ln_Type identifies an Exec Task
NT_UNKNOWN | For TNode.ln_Type
NT_USER | For TNode.ln_Type User nodes type.
PA_IGNORE | Ignore arrival in TMsgPort
PA_SIGNAL | Signal task in mp_SigTask in tMsgPort
PA_SOFTINT | Signal SoftInt in mp_SoftInt/mp_SigTask in TMsgPort
PF_ACTION | Mask for all PA_* tMsgPort Flags
PID_CURRENT |
RAWFMTFUNC_COUNT |
RAWFMTFUNC_SERIAL |
RAWFMTFUNC_STRING |
RTC_MATCHWORD | Matchword for rt_MatchWord
RTF_AFTERDOS | Flag for rt_Flags
RTF_AUTOINIT | Flag for rt_Flags
RTF_COLDSTART | Flag for rt_Flags
RTF_EXTENDED |
RTF_PPC |
RTF_SINGLETASK | Flag for rt_Flags
RTW_COLDSTART |
RTW_NEVER |
SAL_Dummy |
SAL_Name |
SAL_Priority |
SAL_Type |
SB_SAR |
SB_SINT |
SB_TQE |
SETFUNCTAG_DELETE |
SETFUNCTAG_Dummy |
SETFUNCTAG_IDNAME |
SETFUNCTAG_MACHINE |
SETFUNCTAG_TYPE |
SETFUNCTYPE_NORMAL |
SETFUNCTYPE_NORMALD0D1A0A1SR |
SETFUNCTYPE_NORMALD0D1SR |
SETFUNCTYPE_NORMALD0_D1 |
SETFUNCTYPE_NORMALNR |
SETFUNCTYPE_NORMALRESTORE |
SETFUNCTYPE_NORMALSR |
SETFUNCTYPE_NORMALSRNR |
SETFUNCTYPE_QUICK |
SETFUNCTYPE_QUICKNR |
SETFUNCTYPE_SYSTEMV |
SF_SAR |
SF_SINT |
SF_TQE |
SIGB_ABORT |
SIGB_BLIT |
SIGB_CHILD |
SIGB_DOS |
SIGB_INTUITION |
SIGB_NET |
SIGB_SINGLE |
SIGF_ABORT |
SIGF_BLIT |
SIGF_CHILD |
SIGF_DOS |
SIGF_INTUITION |
SIGF_NET |
SIGF_SINGLE |
SIH_PRIMASK |
SM_EXCLUSIVE |
SM_SHARED |
SYSTEMINFOTAG_CPUINDEX |
SYSTEMINFOTAG_DUMMY |
SYSTEMINFOTAG_HOOK |
SYSTEMINFOTAG_MEMHEADER |
SYSTEMINFOTYPE_ALERTMSGPORT |
SYSTEMINFOTYPE_CPUCOUNT |
SYSTEMINFOTYPE_CPUFAMILYNAME |
SYSTEMINFOTYPE_CPUNAME |
SYSTEMINFOTYPE_CPUTIME |
SYSTEMINFOTYPE_EMULATION_SIZE |
SYSTEMINFOTYPE_EMULATION_START |
SYSTEMINFOTYPE_EMULHANDLESIZE |
SYSTEMINFOTYPE_EXCEPTIONMSGPORT |
SYSTEMINFOTYPE_EXCEPTIONMSGPORT_68K |
SYSTEMINFOTYPE_FREEBLOCKS |
SYSTEMINFOTYPE_INVOLUNTARYCSW |
SYSTEMINFOTYPE_LASTSECCPUTIME |
SYSTEMINFOTYPE_LASTSECINVOLUNTARYCSW |
SYSTEMINFOTYPE_LASTSECTICKS |
SYSTEMINFOTYPE_LASTSECVOLUNTARYCSW |
SYSTEMINFOTYPE_LAUNCHTIMETICKS |
SYSTEMINFOTYPE_LAUNCHTIMETICKS1978 |
SYSTEMINFOTYPE_LOADAVG1 |
SYSTEMINFOTYPE_LOADAVG2 |
SYSTEMINFOTYPE_LOADAVG3 |
SYSTEMINFOTYPE_MACHINE |
SYSTEMINFOTYPE_MAGIC1 |
SYSTEMINFOTYPE_MAGIC2 |
SYSTEMINFOTYPE_MAXALERTCOUNT |
SYSTEMINFOTYPE_MAXHITCOUNT |
SYSTEMINFOTYPE_MODULE_SIZE |
SYSTEMINFOTYPE_MODULE_START |
SYSTEMINFOTYPE_PAGESIZE |
SYSTEMINFOTYPE_PPC_ALTIVEC |
SYSTEMINFOTYPE_PPC_BUSCLOCK |
SYSTEMINFOTYPE_PPC_BUSTICKS |
SYSTEMINFOTYPE_PPC_CACHEL1FLAGS |
SYSTEMINFOTYPE_PPC_CACHEL1TYPE |
SYSTEMINFOTYPE_PPC_CACHEL2FLAGS |
SYSTEMINFOTYPE_PPC_CACHEL2TYPE |
SYSTEMINFOTYPE_PPC_CACHEL3FLAGS |
SYSTEMINFOTYPE_PPC_CACHEL3TYPE |
SYSTEMINFOTYPE_PPC_CPUCLOCK |
SYSTEMINFOTYPE_PPC_CPUREVISION |
SYSTEMINFOTYPE_PPC_CPUTEMP |
SYSTEMINFOTYPE_PPC_CPUVERSION |
SYSTEMINFOTYPE_PPC_DABR |
SYSTEMINFOTYPE_PPC_DATASTREAM |
SYSTEMINFOTYPE_PPC_DCACHEL1LINES |
SYSTEMINFOTYPE_PPC_DCACHEL1LINESIZE |
SYSTEMINFOTYPE_PPC_DCACHEL1SIZE |
SYSTEMINFOTYPE_PPC_DCACHEL2LINES |
SYSTEMINFOTYPE_PPC_DCACHEL2LINESIZE |
SYSTEMINFOTYPE_PPC_DCACHEL2SIZE |
SYSTEMINFOTYPE_PPC_DCACHEL3LINES |
SYSTEMINFOTYPE_PPC_DCACHEL3LINESIZE |
SYSTEMINFOTYPE_PPC_DCACHEL3SIZE |
SYSTEMINFOTYPE_PPC_FPU |
SYSTEMINFOTYPE_PPC_ICACHEL1LINES |
SYSTEMINFOTYPE_PPC_ICACHEL1LINESIZE |
SYSTEMINFOTYPE_PPC_ICACHEL1SIZE |
SYSTEMINFOTYPE_PPC_ICACHEL2LINES |
SYSTEMINFOTYPE_PPC_ICACHEL2LINESIZE |
SYSTEMINFOTYPE_PPC_ICACHEL2SIZE |
SYSTEMINFOTYPE_PPC_ICACHEL3LINES |
SYSTEMINFOTYPE_PPC_ICACHEL3LINESIZE |
SYSTEMINFOTYPE_PPC_ICACHEL3SIZE |
SYSTEMINFOTYPE_PPC_PERFMONITOR |
SYSTEMINFOTYPE_PPC_RESERVATIONSIZE |
SYSTEMINFOTYPE_PPC_TLBENTRIES |
SYSTEMINFOTYPE_PPC_TLBSETS |
SYSTEMINFOTYPE_RECENTCPUTIME |
SYSTEMINFOTYPE_RECENTTICKS |
SYSTEMINFOTYPE_REGUSER |
SYSTEMINFOTYPE_REVISION |
SYSTEMINFOTYPE_SYSTEM |
SYSTEMINFOTYPE_TASKEXITCODE |
SYSTEMINFOTYPE_TASKEXITCODE_M68K |
SYSTEMINFOTYPE_TASKSCREATED |
SYSTEMINFOTYPE_TASKSFINISHED |
SYSTEMINFOTYPE_TASKSRUNNING |
SYSTEMINFOTYPE_TASKSSLEEPING |
SYSTEMINFOTYPE_TBCLOCKFREQUENCY |
SYSTEMINFOTYPE_UPTIMETICKS |
SYSTEMINFOTYPE_VENDOR |
SYSTEMINFOTYPE_VOLUNTARYCSW |
TAG_USER |
TASKERROR_NOMEMORY |
TASKERROR_OK |
TASKINFOTAG_DUMMY |
TASKINFOTAG_HOOK |
TASKINFOTAG_REGCOUNT |
TASKINFOTAG_REGSTART |
TASKINFOTYPE_68K_NEWFRAME |
TASKINFOTYPE_AGETICKS |
TASKINFOTYPE_ALERTCOUNT |
TASKINFOTYPE_ALLTASK |
TASKINFOTYPE_CPUTIME |
TASKINFOTYPE_EMULHANDLE |
TASKINFOTYPE_EXCEPTCODE |
TASKINFOTYPE_EXCEPTDATA |
TASKINFOTYPE_EXCEPTIONCOUNT |
TASKINFOTYPE_FLAGS |
TASKINFOTYPE_HITCOUNT |
TASKINFOTYPE_INVOLUNTARYCSW |
TASKINFOTYPE_LASTSECCPUTIME |
TASKINFOTYPE_LASTSECINVOLUNTARYCSW |
TASKINFOTYPE_LASTSECVOLUNTARYCSW |
TASKINFOTYPE_LAUNCHTIMETICKS |
TASKINFOTYPE_LAUNCHTIMETICKS1978 |
TASKINFOTYPE_MAXALERTCOUNT |
TASKINFOTYPE_MAXHITCOUNT |
TASKINFOTYPE_NAME |
TASKINFOTYPE_NAMECOPY |
TASKINFOTYPE_NICE |
TASKINFOTYPE_PID |
TASKINFOTYPE_PID_CLI |
TASKINFOTYPE_POOLMEMFLAGS |
TASKINFOTYPE_POOLPTR |
TASKINFOTYPE_POOLPUDDLESIZE |
TASKINFOTYPE_POOLTHRESHSIZE |
TASKINFOTYPE_PPC_CR |
TASKINFOTYPE_PPC_CTR |
TASKINFOTYPE_PPC_FPR |
TASKINFOTYPE_PPC_FPSCR |
TASKINFOTYPE_PPC_FRAME |
TASKINFOTYPE_PPC_FRAMESIZE |
TASKINFOTYPE_PPC_GPR |
TASKINFOTYPE_PPC_LR |
TASKINFOTYPE_PPC_NEWFRAME |
TASKINFOTYPE_PPC_SRR0 |
TASKINFOTYPE_PPC_SRR1 |
TASKINFOTYPE_PPC_VMX |
TASKINFOTYPE_PPC_VSAVE |
TASKINFOTYPE_PPC_VSCR |
TASKINFOTYPE_PPC_XER |
TASKINFOTYPE_PRI |
TASKINFOTYPE_RECENTCPUTIME |
TASKINFOTYPE_RESURRECT_TASK |
TASKINFOTYPE_SIGALLOC |
TASKINFOTYPE_SIGEXCEPT |
TASKINFOTYPE_SIGRECVD |
TASKINFOTYPE_SIGWAIT |
TASKINFOTYPE_SPLOWER |
TASKINFOTYPE_SPLOWER_M68K |
TASKINFOTYPE_SPUPPER |
TASKINFOTYPE_SPUPPER_M68K |
TASKINFOTYPE_STACKSIZE |
TASKINFOTYPE_STACKSIZE_M68K |
TASKINFOTYPE_STARTUPMSG |
TASKINFOTYPE_STATE |
TASKINFOTYPE_TASKMSGPORT |
TASKINFOTYPE_TRAPCODE |
TASKINFOTYPE_TRAPDATA |
TASKINFOTYPE_TRAPMSGPORT |
TASKINFOTYPE_TYPE |
TASKINFOTYPE_USEDSTACKSIZE |
TASKINFOTYPE_USEDSTACKSIZE_M68K |
TASKINFOTYPE_USERDATA |
TASKINFOTYPE_VOLUNTARYCSW |
TASKTAG_CODETYPE |
TASKTAG_DUMMY |
TASKTAG_ERROR |
TASKTAG_FINALPC |
TASKTAG_FLAGS |
TASKTAG_NAME |
TASKTAG_PC |
TASKTAG_POOLPUDDLE |
TASKTAG_POOLTHRESH |
TASKTAG_PPC_ARG1 |
TASKTAG_PPC_ARG2 |
TASKTAG_PPC_ARG3 |
TASKTAG_PPC_ARG4 |
TASKTAG_PPC_ARG5 |
TASKTAG_PPC_ARG6 |
TASKTAG_PPC_ARG7 |
TASKTAG_PPC_ARG8 |
TASKTAG_PRI |
TASKTAG_STACKSIZE |
TASKTAG_STACKSIZE_M68K |
TASKTAG_STARTUPMSG |
TASKTAG_TASKMSGPORT |
TASKTAG_TCBEXTRASIZE |
TASKTAG_USERDATA |
TB_ETASK | Flag Bit for tc_Flags
TB_EXCEPT | Flag Bit for tc_Flags Task gets no CPU time.
TB_LAUNCH | Flag Bit for tc_Flags Task is switched to CPU.
TB_PROCTIME | Flag Bit for tc_Flags Task uses CPU.
TB_STACKCHK | Flag Bit for tc_Flags Stack is checked.
TB_SWITCH | Flag Bit for tc_Flags Task is switched away from CPU.
TF_ETASK | Flag value for tc_Flags
TF_EXCEPT | Flag value for tc_Flags Task gets no CPU time.
TF_LAUNCH | Flag value for tc_Flags Task is switched to CPU.
TF_PROCTIME | Flag value for tc_Flags Task uses CPU.
TF_STACKCHK | Flag value for tc_Flags Stack is checked.
TF_SWITCH | Flag value for tc_Flags Task is switched away from CPU.
TLSTAG_DESTRUCTOR | Tag for TLSAllocA
TLSTAG_DUMMY |
TLSTAG_USERDATA | Tag for TLSAllocA
TLS_INVALID_INDEX |
TRAP_AREA_START |
TRAP_EIEIO |
TRAP_ISYNC |
TRAP_LIB |
TRAP_LIBD0D1A0A1SR |
TRAP_LIBD0D1SR |
TRAP_LIBD0_D1 |
TRAP_LIBNR |
TRAP_LIBNR_QUICK |
TRAP_LIBRESTORE |
TRAP_LIBSR |
TRAP_LIBSRNR |
TRAP_LIB_QUICK |
TRAP_MASK |
TRAP_SYNC |
TS_ADDED | Task State for tc_State Task is currently inserted in List.
TS_EXCEPT | Task State for tc_State Task gets no CPU time.
TS_INVALID | Task State for tc_State Invalid Task.
TS_READY | Task State for tc_State Task is ready to work.
TS_REMOVED | Task State for tc_State Task is removed at the moment.
TS_RUN | Task State for tc_State Task is running.
TS_WAIT | Task State for tc_State Task is waiting for a signal.
UNITF_ACTIVE | tUnit is accessable
UNITF_INTASK | tUnit is currently working
VERSION_ALERTMESSAGE |
VERSION_TASKTRAPMESSAGE |
VERSION_TASKTRAPMESSAGE_68k |


Reference for unit 'exec': Types

Pointer | A type free pointer.
SmallInt | Boolean representation
LongInt | A type free pointer. in ABIv0 its just a Pointer.
LongInt | Pointer to a string, in ABIv0 just like PChar.
PtrUInt |
LongInt | signed 32-Bit integer Value
LongWord |
PAPTR |
PDevice | Device has the same structure as an Library
PEmulHandle |
PEmulLibEntry |
PETask |
PExecBase |
PExecNotifyMessage |
PFreeBlocksData |
PFuncEntry |
PFuncOldEntry |
Pointer |
PInterrupt |
PIntVector | For EXEC use ONLY!
PIORequest |
PIOStdReq |
PLibrary | Library Base Structure
PList | Pointer to List structure
PLONG |
PLONGBITS |
PMemChunk |
PMemEntry |
PMemHandlerData | Memory Handler
PMemHeader |
PMemList | Pointer to the list of all Memory
PMessage | Message from/for a MessagePort
PMinList | Pointer to a minal list structure.
PMinNode |
PMsgPort | Port for inter-task communication.
PNode | Pointer to node structure
PPPCStackSwapArgs |
PResident |
PSemaphoreMessage |
PSemaphoreRequest | This is the structure used to request a signal semaphore
PSignalSemaphore |
PSoftIntList | For EXEC use ONLY!
PStackSwapStruct | Stack swap structure as passed to StackSwap
Pointer |
PTask | Pointer to Task structure
PTaskFrame68k |
PTaskInitExtension |
PTaskTrapMessage |
PTaskTrapMessage_68k |
PULONG |
PUnit |
PtrInt |
PChar | Pointer to a string (compareable with a PChar)
TAlertMessage |
TDevice | Device has the same structure as an Library
TEmulHandle |
TEmulLibEntry |
TEmulRegs |
TETask |
TExecBase |
TExecNotifyMessage |
TFreeBlocksData |
TFuncEntry |
TFuncOldEntry |
TInterrupt |
TIntVector | For EXEC use ONLY!
TIORequest |
TIOStdReq |
TLibrary | Library Base Structure
TList | List header.
TMemChunk |
TMemEntry |
TMemHandlerData | Memory Handler
TMemHeader |
TMemList | List of all available Memory
TMessage | Message from/for a MessagePort
TMinList | Minimal list strcture.
TMinNode | Minimal list entry without any type or name.
TMsgPort | Port for inter-task communication.
TNode | List node structure, Each member in a list starts with a node.
TPPCStackSwapArgs |
TResident |
TSemaphoreMessage |
TSemaphoreRequest | This is the structure used to request a signal semaphore
TSignalSemaphore |
TSoftIntList | For EXEC use ONLY!
TStackSwapStruct | Stack swap structure as passed to StackSwap
TTask | Every Amiga Task has one of these Task structures associated with it. To find yours, use FindTask(nil). Amiga processes tack a few more values on to the end of this structure, which is the difference between Tasks and Processes.
TTaskFrame68k |
TTaskInitExtension |
TTaskTrapMessage |
TTaskTrapMessage_68k |
TUnit |
Byte | unsigned 8-Bit Value
LongWord | unsigned 32-Bit integer value
Word | unsigned 16-Bit Value
Word |
PWideChar |


INTB_NMI

Declaration

Source position: exec.pas line 1000

const INTB_NMI = 15;


INTF_NMI

Declaration

Source position: exec.pas line 1001

const INTF_NMI = 1 shl INTB_NMI;


IOB_QUICK

Declaration

Source position: exec.pas line 1354

const IOB_QUICK = 0;


IOERR_ABORTED

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error request terminated early AbortIO

Declaration

Source position: exec.pas line 224

const IOERR_ABORTED = - 2;


IOERR_BADADDRESS

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error invalid address (misaligned or bad range)

Declaration

Source position: exec.pas line 227

const IOERR_BADADDRESS = - 5;


IOERR_BADLENGTH

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error not a valid length (usually IO_LENGTH)

Declaration

Source position: exec.pas line 226

const IOERR_BADLENGTH = - 4;


IOERR_NOCMD

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error command not supported by device

Declaration

Source position: exec.pas line 225

const IOERR_NOCMD = - 3;


IOERR_NOMEMORY

Declaration

Source position: exec.pas line 230

const IOERR_NOMEMORY = - 8;


IOERR_OPENFAIL

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device/unit failed to open

Declaration

Source position: exec.pas line 223

const IOERR_OPENFAIL = - 1;


IOERR_SELFTEST

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error hardware failed self-test

Declaration

Source position: exec.pas line 229

const IOERR_SELFTEST = - 7;


IOERR_UNITBUSY

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device opens ok, but requested unit is busy

Declaration

Source position: exec.pas line 228

const IOERR_UNITBUSY = - 6;


IOF_QUICK

Declaration

Source position: exec.pas line 1355

const IOF_QUICK = 1 shl IOB_QUICK;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

IPTR

Declaration

Source position: exec.pas line 43

type IPTR = PtrUInt;


LFalse

Representation of False for Amiga function

Declaration

Source position: exec.pas line 49

const LFalse: LongInt = 0;

Description

Some Amiga functions expect a "1" for as True value and a "0" as False value and cannot handle the "-1" set by freepascal.

See also

ltrue

Representation of True for Amiga functions


LIB_BASE

Declaration

Source position: exec.pas line 1057

const LIB_BASE = - LIB_VECTSIZE;


LIB_CLOSE

Declaration

Source position: exec.pas line 1062

const LIB_CLOSE = - 12;


LIB_EXPUNGE

Declaration

Source position: exec.pas line 1063

const LIB_EXPUNGE = - 18;


LIB_EXTFUNC

Declaration

Source position: exec.pas line 1064

const LIB_EXTFUNC = - 24;


LIB_GETQUERYATTR

Declaration

Source position: exec.pas line 1065

const LIB_GETQUERYATTR = - 24;


LIB_NONSTD

Declaration

Source position: exec.pas line 1059

const LIB_NONSTD = LIB_USERDEF;


LIB_OPEN

Declaration

Source position: exec.pas line 1061

const LIB_OPEN = - 6;


LIB_RESERVED

Declaration

Source position: exec.pas line 1056

const LIB_RESERVED = 4;


LIB_USERDEF

Declaration

Source position: exec.pas line 1058

const LIB_USERDEF = LIB_BASE - LIB_RESERVED * LIB_VECTSIZE;


LIB_VECTSIZE

Declaration

Source position: exec.pas line 1055

const LIB_VECTSIZE = 6;


LIBF_CHANGED

One or some Library functions are changed.

Declaration

Source position: exec.pas line 1086

const LIBF_CHANGED = 1 shl 1;


LIBF_DELEXP

Library should be closed but an other tasks still use it. Waiting.

Declaration

Source position: exec.pas line 1088

const LIBF_DELEXP = 1 shl 3;


LIBF_QUERYINFO

Declaration

Source position: exec.pas line 1092

const LIBF_QUERYINFO = 1 shl 5;


LIBF_RAMLIB

Declaration

Source position: exec.pas line 1090

const LIBF_RAMLIB = 1 shl 4;


LIBF_SUMMING

The checksum of Library is currently being calculated.

Declaration

Source position: exec.pas line 1085

const LIBF_SUMMING = 1 shl 0;


LIBF_SUMUSED

A checksum error of a Library results into a reset.

Declaration

Source position: exec.pas line 1087

const LIBF_SUMUSED = 1 shl 2;


LIBTAG_BASE

Declaration

Source position: exec.pas line 1122

const LIBTAG_BASE = TAG_USER + $01000100;


LIBTAG_BASESIZE

Declaration

Source position: exec.pas line 1127

const LIBTAG_BASESIZE = LIBTAG_BASE + $4;


LIBTAG_FLAGS

Declaration

Source position: exec.pas line 1132

const LIBTAG_FLAGS = LIBTAG_BASE + $9;


LIBTAG_FUNCTIONINIT

Declaration

Source position: exec.pas line 1123

const LIBTAG_FUNCTIONINIT = LIBTAG_BASE + $0;


LIBTAG_IDSTRING

Declaration

Source position: exec.pas line 1134

const LIBTAG_IDSTRING = LIBTAG_BASE + $b;


LIBTAG_LIBRARYINIT

Declaration

Source position: exec.pas line 1125

const LIBTAG_LIBRARYINIT = LIBTAG_BASE + $2;


LIBTAG_MACHINE

Declaration

Source position: exec.pas line 1126

const LIBTAG_MACHINE = LIBTAG_BASE + $3;


LIBTAG_NAME

Declaration

Source position: exec.pas line 1133

const LIBTAG_NAME = LIBTAG_BASE + $a;


LIBTAG_PRI

Declaration

Source position: exec.pas line 1129

const LIBTAG_PRI = LIBTAG_BASE + $6;


LIBTAG_PUBLIC

Declaration

Source position: exec.pas line 1138

const LIBTAG_PUBLIC = LIBTAG_BASE + $c;


LIBTAG_QUERYINFO

Declaration

Source position: exec.pas line 1140

const LIBTAG_QUERYINFO = LIBTAG_BASE + $e;


LIBTAG_REVISION

Declaration

Source position: exec.pas line 1139

const LIBTAG_REVISION = LIBTAG_BASE + $d;


LIBTAG_SEGLIST

Declaration

Source position: exec.pas line 1128

const LIBTAG_SEGLIST = LIBTAG_BASE + $5;


LIBTAG_STRUCTINIT

Declaration

Source position: exec.pas line 1124

const LIBTAG_STRUCTINIT = LIBTAG_BASE + $1;


LIBTAG_TYPE

Declaration

Source position: exec.pas line 1130

const LIBTAG_TYPE = LIBTAG_BASE + $7;


LIBTAG_VERSION

Declaration

Source position: exec.pas line 1131

const LIBTAG_VERSION = LIBTAG_BASE + $8;


LONG

signed 32-Bit integer Value

Declaration

Source position: exec.pas line 28

type LONG = LongInt;


LONGBITS

Declaration

Source position: exec.pas line 35

type LONGBITS = LongWord;


LTrue

Representation of True for Amiga functions

Declaration

Source position: exec.pas line 48

const LTrue: LongInt = 1;

Description

Some Amiga functions expect a "1" for as True value and a "0" as False value and cannot handle the "-1" set by freepascal.

See also

lfalse

Representation of False for Amiga function


MACHINE_M68k

Declaration

Source position: exec.pas line 1043

const MACHINE_M68k = $0;


MACHINE_NO

Declaration

Source position: exec.pas line 1045

const MACHINE_NO = $ffffffff;


MACHINE_PPC

Declaration

Source position: exec.pas line 1044

const MACHINE_PPC = $1;


MEM_ALL_DONE

We did all we could do

Declaration

Source position: exec.pas line 348

const MEM_ALL_DONE = - 1;


MEM_BLOCKMASK

Declaration

Source position: exec.pas line 332

const MEM_BLOCKMASK = MEM_BLOCKSIZE - 1;


MEM_BLOCKSIZE

Declaration

Source position: exec.pas line 331

const MEM_BLOCKSIZE = 8;


MEM_DID_NOTHING

Nothing we could do

Declaration

Source position: exec.pas line 347

const MEM_DID_NOTHING = 0;


MEM_TRY_AGAIN

We did some, try the allocation again

Declaration

Source position: exec.pas line 349

const MEM_TRY_AGAIN = 1;


MEMF_24BITDMA

Memory Requirement Type. DMAable memory within 24 bits of address.

Declaration

Source position: exec.pas line 319

const MEMF_24BITDMA = 1 shl 9;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_31BIT

Declaration

Source position: exec.pas line 322

const MEMF_31BIT = 1 shl 12;


MEMF_ANY

Memory Requirement Type. Any type of memory will do.

Declaration

Source position: exec.pas line 314

const MEMF_ANY = 0;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_CHIP

Memory Requirement Type

Declaration

Source position: exec.pas line 316

const MEMF_CHIP = 1 shl 1;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_CLEAR

Memory Requirement Type. Clear the memory when allocate.

Declaration

Source position: exec.pas line 324

const MEMF_CLEAR = 1 shl 16;

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


MEMF_FAST

Memory Requirement Type

Declaration

Source position: exec.pas line 317

const MEMF_FAST = 1 shl 2;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_KICK

Memory Requirement Type. Memory that can be used for KickTags.

Declaration

Source position: exec.pas line 320

const MEMF_KICK = 1 shl 10;

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


MEMF_LARGEST

Memory Requirement Type. Return the largest available memory block.

Declaration

Source position: exec.pas line 325

const MEMF_LARGEST = 1 shl 17;

See also

AvailMem

Check memory available given certain requirements


MEMF_LOCAL

Memory Requirement Type

Declaration

Source position: exec.pas line 318

const MEMF_LOCAL = 1 shl 8;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_NO_EXPUNGE

Memory Requirement Type. Do not cause expunge on failure

Declaration

Source position: exec.pas line 329

const MEMF_NO_EXPUNGE = 1 shl 31;

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


MEMF_PUBLIC

Memory Requirement Type.

Declaration

Source position: exec.pas line 315

const MEMF_PUBLIC = 1 shl 0;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_REVERSE

Memory Requirement Type

Declaration

Source position: exec.pas line 326

const MEMF_REVERSE = 1 shl 18;

See also

AvailMem

Check memory available given certain requirements


MEMF_SEM_PROTECTED

Declaration

Source position: exec.pas line 328

const MEMF_SEM_PROTECTED = 1 shl 20;


MEMF_SWAP

Declaration

Source position: exec.pas line 321

const MEMF_SWAP = 1 shl 11;


MEMF_TOTAL

Memory Requirement Type. Return the total size of Memory.

Declaration

Source position: exec.pas line 327

const MEMF_TOTAL = 1 shl 19;

See also

AvailMem

Check memory available given certain requirements


MEMHF_RECYCLE

0 = First time, 1 = recycle

Declaration

Source position: exec.pas line 345

const MEMHF_RECYCLE = 1 shl 0;


NT_BOOTNODE

For TNode.ln_Type

Declaration

Source position: exec.pas line 184

const NT_BOOTNODE = 16;


NT_DEATHMESSAGE

For TNode.ln_Type

Declaration

Source position: exec.pas line 187

const NT_DEATHMESSAGE = 19;


NT_DEVICE

For TNode.ln_Type identifies a device

Declaration

Source position: exec.pas line 171

const NT_DEVICE = 3;


NT_EXTENDED

For TNode.ln_Type

Declaration

Source position: exec.pas line 189

const NT_EXTENDED = 255;


NT_FONT

For TNode.ln_Type

Declaration

Source position: exec.pas line 180

const NT_FONT = 12;


NT_FREEMSG

For TNode.ln_Type Message has beed freed

Declaration

Source position: exec.pas line 174

const NT_FREEMSG = 6;


NT_GRAPHICS

For TNode.ln_Type

Declaration

Source position: exec.pas line 186

const NT_GRAPHICS = 18;


NT_INTERRUPT

For TNode.ln_Type identifies an interrupt

Declaration

Source position: exec.pas line 170

const NT_INTERRUPT = 2;


NT_KICKMEM

For TNode.ln_Type

Declaration

Source position: exec.pas line 185

const NT_KICKMEM = 17;


NT_LIBRARY

For TNode.ln_Type

Declaration

Source position: exec.pas line 177

const NT_LIBRARY = 9;


NT_MEMORY

For TNode.ln_Type

Declaration

Source position: exec.pas line 178

const NT_MEMORY = 10;


NT_MESSAGE

For TNode.ln_Type indicates message is currently pending

Declaration

Source position: exec.pas line 173

const NT_MESSAGE = 5;


NT_MSGPORT

For TNode.ln_Type identifies a message port

Declaration

Source position: exec.pas line 172

const NT_MSGPORT = 4;


NT_PROCESS

For TNode.ln_Type identifies and Amiga Dos process

Declaration

Source position: exec.pas line 181

const NT_PROCESS = 13;


NT_REPLYMSG

For TNode.ln_Type Message has been replied

Declaration

Source position: exec.pas line 175

const NT_REPLYMSG = 7;


NT_RESOURCE

For TNode.ln_Type

Declaration

Source position: exec.pas line 176

const NT_RESOURCE = 8;


NT_SEMAPHORE

For TNode.ln_Type

Declaration

Source position: exec.pas line 182

const NT_SEMAPHORE = 14;


NT_SIGNALSEM

For TNode.ln_Type identifies an signal semaphore

Declaration

Source position: exec.pas line 183

const NT_SIGNALSEM = 15;


NT_SOFTINT

For TNode.ln_Type Internal flag used ny SoftInits

Declaration

Source position: exec.pas line 179

const NT_SOFTINT = 11;


NT_TASK

For TNode.ln_Type identifies an Exec Task

Declaration

Source position: exec.pas line 169

const NT_TASK = 1;


NT_UNKNOWN

For TNode.ln_Type

Declaration

Source position: exec.pas line 168

const NT_UNKNOWN = 0;


NT_USER

For TNode.ln_Type User nodes type.

Declaration

Source position: exec.pas line 188

const NT_USER = 254;


PA_IGNORE

Ignore arrival in TMsgPort

Declaration

Source position: exec.pas line 379

const PA_IGNORE = 2;


PA_SIGNAL

Signal task in mp_SigTask in tMsgPort

Declaration

Source position: exec.pas line 377

const PA_SIGNAL = 0;


PA_SOFTINT

Signal SoftInt in mp_SoftInt/mp_SigTask in TMsgPort

Declaration

Source position: exec.pas line 378

const PA_SOFTINT = 1;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PAPTR

Declaration

Source position: exec.pas line 39

type PAPTR = ^Pointer;


PDevice

Device has the same structure as an Library

Declaration

Source position: exec.pas line 1297

type PDevice = ^TDevice;


PEmulHandle

Declaration

Source position: exec.pas line 96

type PEmulHandle = ^TEmulHandle;


PEmulLibEntry

Declaration

Source position: exec.pas line 85

type PEmulLibEntry = ^TEmulLibEntry;


PETask

Declaration

Source position: exec.pas line 393

type PETask = ^TETask;


PExecBase

Declaration

Source position: exec.pas line 1377

type PExecBase = ^TExecBase;


PExecNotifyMessage

Declaration

Source position: exec.pas line 1590

type PExecNotifyMessage = ^TExecNotifyMessage;


PF_ACTION

Mask for all PA_* tMsgPort Flags

Declaration

Source position: exec.pas line 376

const PF_ACTION = 3;


PFreeBlocksData

Declaration

Source position: exec.pas line 356

type PFreeBlocksData = ^TFreeBlocksData;


PFuncEntry

Declaration

Source position: exec.pas line 1144

type PFuncEntry = ^TFuncEntry;


PFuncOldEntry

Declaration

Source position: exec.pas line 1150

type PFuncOldEntry = ^TFuncOldEntry;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PHook

Declaration

Source position: exec.pas line 141

type PHook = Pointer;


PID_CURRENT

Declaration

Source position: exec.pas line 730

const PID_CURRENT = 0;


PInterrupt

Declaration

Source position: exec.pas line 977

type PInterrupt = ^TInterrupt;

See also

AddIntServer | Adds a interrupt server to the system
RemIntServer | Remove an interrupt server from a server chain
AddMemHandler |
RemMemHandler | Remove low memory handler from exec
Cause | Fire and software interrupt
SetIntVector | Set a new handler for a system interrupt vector


PIntVector

For EXEC use ONLY!

Declaration

Source position: exec.pas line 984

type PIntVector = ^TIntVector;

See also

TExecBase


PIORequest

Declaration

Source position: exec.pas line 1324

type PIORequest = ^TIORequest;


PIOStdReq

Declaration

Source position: exec.pas line 1335

type PIOStdReq = ^TIOStdReq;


PLibrary

Library Base Structure

Declaration

Source position: exec.pas line 1069

type PLibrary = ^TLibrary;

Description

Also used for Devices and some Resources

See also

OpenLibrary | Open a library to use
OldOpenLibrary | Old Version of OpenLibrary (deprecated)
CloseLibrary | Close access to library
AddLibrary | Adds a library to the system
MakeLibrary | Construct a library
RemLibrary | Remove a library from the system
SumLibrary | Compute and check the checksum on a library
SetFunction | Change a function vector in a library


PList

Pointer to List structure

Declaration

Source position: exec.pas line 199

type PList = ^TList;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PLONG

Declaration

Source position: exec.pas line 40

type PLONG = ^LongInt;


PLONGBITS

Declaration

Source position: exec.pas line 36

type PLONGBITS = ^LongWord;


PMemChunk

Declaration

Source position: exec.pas line 276

type PMemChunk = ^TMemChunk;

See also

TMemHeader


PMemEntry

Declaration

Source position: exec.pas line 294

type PMemEntry = ^TMemEntry;

See also

TMemList

List of all available Memory


PMemHandlerData

Memory Handler

Declaration

Source position: exec.pas line 336

type PMemHandlerData = ^TMemHandlerData;

Description

This structure is READ ONLY and only EXEC can create it!


PMemHeader

Declaration

Source position: exec.pas line 283

type PMemHeader = ^TMemHeader;

See also

Allocate | Allocate a block of memory
Deallocate | Free a block of memory


PMemList

Pointer to the list of all Memory

Declaration

Source position: exec.pas line 305

type PMemList = ^TMemList;

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Free many blocks of memory at once


PMessage

Message from/for a MessagePort

Declaration

Source position: exec.pas line 383

type PMessage = ^TMessage;

See also

GetMsg | Get next message from message port
PutMsg | Put a message to a message port
ReplyMsg | Put a message to its reply port
WaitPort | Wait for a given port to be non-empty


PMinList

Pointer to a minal list structure.

Declaration

Source position: exec.pas line 209

type PMinList = ^TMinList;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name


PMinNode

Declaration

Source position: exec.pas line 160

type PMinNode = ^TMinNode;


PMsgPort

Port for inter-task communication.

Declaration

Source position: exec.pas line 365

type PMsgPort = ^TMsgPort;

See also

AddPort | Add a public message port to the system
RemPort | Remove a message port from the system
CreateIORequest | Create a structure usable for an I/O request
CreateMsgPort | Create a new message port
DeleteMsgPort | Free a message port
FindPort | Find a system message port by name
GetMsg | Get next message from message port
PutMsg | Put a message to a message port
WaitPort | Wait for a given port to be non-empty


PNode

Pointer to node structure

Declaration

Source position: exec.pas line 150

type PNode = ^TNode;


PPPCStackSwapArgs

Declaration

Source position: exec.pas line 613

type PPPCStackSwapArgs = ^TPPCStackSwapArgs;


PResident

Declaration

Source position: exec.pas line 237

type PResident = ^TResident;

See also

FindResident | Find a resident module by name
InitResident | Initialize resident module


PSemaphoreMessage

Declaration

Source position: exec.pas line 1028

type PSemaphoreMessage = ^TSemaphoreMessage;


PSemaphoreRequest

This is the structure used to request a signal semaphore

Declaration

Source position: exec.pas line 1012

type PSemaphoreRequest = ^TSemaphoreRequest;


PSignalSemaphore

Declaration

Source position: exec.pas line 1018

type PSignalSemaphore = ^TSignalSemaphore;


PSoftIntList

For EXEC use ONLY!

Declaration

Source position: exec.pas line 991

type PSoftIntList = ^TSoftIntList;

See also

TExecBase


PStackSwapStruct

Stack swap structure as passed to StackSwap

Declaration

Source position: exec.pas line 605

type PStackSwapStruct = ^TStackSwapStruct;


PTagItem

Declaration

Source position: exec.pas line 140

type PTagItem = Pointer;


PTask

Pointer to Task structure

Declaration

Source position: exec.pas line 392

type PTask = ^TTask;

Description

Every Amiga Task has one of these Task structures associated with it. To find yours, use FindTask(nil). Amiga processes tack a few more values on to the end of this structure, which is the difference between Tasks and Processes.

See also

FindTask | Find task by name get own task
AddTask | Add a Task to the System
RemTask | Remove a task from the system
SetTaskPri | Get and set the priority of a task
Signal | Signal a task


PTaskFrame68k

Declaration

Source position: exec.pas line 713

type PTaskFrame68k = ^TTaskFrame68k;


PTaskInitExtension

Declaration

Source position: exec.pas line 489

type PTaskInitExtension = ^TTaskInitExtension;


PTaskTrapMessage

Declaration

Source position: exec.pas line 394

type PTaskTrapMessage = ^TTaskTrapMessage;


PTaskTrapMessage_68k

Declaration

Source position: exec.pas line 585

type PTaskTrapMessage_68k = ^TTaskTrapMessage_68k;


PULONG

Declaration

Source position: exec.pas line 38

type PULONG = ^LongWord;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PUnit

Declaration

Source position: exec.pas line 1303

type PUnit = ^TUnit;


RAWFMTFUNC_COUNT

Declaration

Source position: exec.pas line 1616

const RAWFMTFUNC_COUNT = 2;


RAWFMTFUNC_SERIAL

Declaration

Source position: exec.pas line 1615

const RAWFMTFUNC_SERIAL = 1;


RAWFMTFUNC_STRING

Declaration

Source position: exec.pas line 1614

const RAWFMTFUNC_STRING = 0;


RTC_MATCHWORD

Matchword for rt_MatchWord

Declaration

Source position: exec.pas line 256

const RTC_MATCHWORD = $4AFC;


RTF_AFTERDOS

Flag for rt_Flags

Declaration

Source position: exec.pas line 263

const RTF_AFTERDOS = 1 shl 2;


RTF_AUTOINIT

Flag for rt_Flags

Declaration

Source position: exec.pas line 258

const RTF_AUTOINIT = 1 shl 7;


RTF_COLDSTART

Flag for rt_Flags

Declaration

Source position: exec.pas line 265

const RTF_COLDSTART = 1 shl 0;


RTF_EXTENDED

Declaration

Source position: exec.pas line 259

const RTF_EXTENDED = 1 shl 6;


RTF_PPC

Declaration

Source position: exec.pas line 262

const RTF_PPC = 1 shl 3;


RTF_SINGLETASK

Flag for rt_Flags

Declaration

Source position: exec.pas line 264

const RTF_SINGLETASK = 1 shl 1;


RTW_COLDSTART

Declaration

Source position: exec.pas line 268

const RTW_COLDSTART = 1;


RTW_NEVER

Declaration

Source position: exec.pas line 267

const RTW_NEVER = 0;


SAL_Dummy

Declaration

Source position: exec.pas line 1608

const SAL_Dummy = TAG_USER + 1000;


SAL_Name

Declaration

Source position: exec.pas line 1611

const SAL_Name = SAL_Dummy + 3;


SAL_Priority

Declaration

Source position: exec.pas line 1610

const SAL_Priority = SAL_Dummy + 2;


SAL_Type

Declaration

Source position: exec.pas line 1609

const SAL_Type = SAL_Dummy + 1;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

SB_SAR

Declaration

Source position: exec.pas line 1498

const SB_SAR = 15;


SB_SINT

Declaration

Source position: exec.pas line 1500

const SB_SINT = 13;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

SB_TQE

Declaration

Source position: exec.pas line 1499

const SB_TQE = 14;


SETFUNCTAG_DELETE

Declaration

Source position: exec.pas line 1101

const SETFUNCTAG_DELETE = SETFUNCTAG_Dummy + $4;


SETFUNCTAG_Dummy

Declaration

Source position: exec.pas line 1097

const SETFUNCTAG_Dummy = TAG_USER + $01000000;


SETFUNCTAG_IDNAME

Declaration

Source position: exec.pas line 1100

const SETFUNCTAG_IDNAME = SETFUNCTAG_Dummy + $3;


SETFUNCTAG_MACHINE

Declaration

Source position: exec.pas line 1098

const SETFUNCTAG_MACHINE = SETFUNCTAG_Dummy + $1;


SETFUNCTAG_TYPE

Declaration

Source position: exec.pas line 1099

const SETFUNCTAG_TYPE = SETFUNCTAG_Dummy + $2;


SETFUNCTYPE_NORMAL

Declaration

Source position: exec.pas line 1103

const SETFUNCTYPE_NORMAL = 0;


SETFUNCTYPE_NORMALD0_D1

Declaration

Source position: exec.pas line 1115

const SETFUNCTYPE_NORMALD0_D1 = 6;


SETFUNCTYPE_NORMALD0D1A0A1SR

Declaration

Source position: exec.pas line 1119

const SETFUNCTYPE_NORMALD0D1A0A1SR = 10;


SETFUNCTYPE_NORMALD0D1SR

Declaration

Source position: exec.pas line 1118

const SETFUNCTYPE_NORMALD0D1SR = 9;


SETFUNCTYPE_NORMALNR

Declaration

Source position: exec.pas line 1108

const SETFUNCTYPE_NORMALNR = 2;


SETFUNCTYPE_NORMALRESTORE

Declaration

Source position: exec.pas line 1116

const SETFUNCTYPE_NORMALRESTORE = 7;


SETFUNCTYPE_NORMALSR

Declaration

Source position: exec.pas line 1113

const SETFUNCTYPE_NORMALSR = 4;


SETFUNCTYPE_NORMALSRNR

Declaration

Source position: exec.pas line 1114

const SETFUNCTYPE_NORMALSRNR = 5;


SETFUNCTYPE_QUICK

Declaration

Source position: exec.pas line 1104

const SETFUNCTYPE_QUICK = 1;


SETFUNCTYPE_QUICKNR

Declaration

Source position: exec.pas line 1112

const SETFUNCTYPE_QUICKNR = 3;


SETFUNCTYPE_SYSTEMV

Declaration

Source position: exec.pas line 1117

const SETFUNCTYPE_SYSTEMV = 8;


SF_SAR

Declaration

Source position: exec.pas line 1502

const SF_SAR = 1 shl SB_SAR;


SF_SINT

Declaration

Source position: exec.pas line 1504

const SF_SINT = 1 shl SB_SINT;


SF_TQE

Declaration

Source position: exec.pas line 1503

const SF_TQE = 1 shl SB_TQE;


SIGB_ABORT

Declaration

Source position: exec.pas line 564

const SIGB_ABORT = 0;


SIGB_BLIT

Declaration

Source position: exec.pas line 566

const SIGB_BLIT = 4;


SIGB_CHILD

Declaration

Source position: exec.pas line 565

const SIGB_CHILD = 1;


SIGB_DOS

Declaration

Source position: exec.pas line 570

const SIGB_DOS = 8;


SIGB_INTUITION

Declaration

Source position: exec.pas line 568

const SIGB_INTUITION = 5;


SIGB_NET

Declaration

Source position: exec.pas line 569

const SIGB_NET = 7;


SIGB_SINGLE

Declaration

Source position: exec.pas line 567

const SIGB_SINGLE = 4;


SIGF_ABORT

Declaration

Source position: exec.pas line 572

const SIGF_ABORT = 1 shl SIGB_ABORT;


SIGF_BLIT

Declaration

Source position: exec.pas line 574

const SIGF_BLIT = 1 shl SIGB_BLIT;


SIGF_CHILD

Declaration

Source position: exec.pas line 573

const SIGF_CHILD = 1 shl SIGB_CHILD;


SIGF_DOS

Declaration

Source position: exec.pas line 578

const SIGF_DOS = 1 shl SIGB_DOS;


SIGF_INTUITION

Declaration

Source position: exec.pas line 576

const SIGF_INTUITION = 1 shl SIGB_INTUITION;


SIGF_NET

Declaration

Source position: exec.pas line 577

const SIGF_NET = 1 shl SIGB_NET;


SIGF_SINGLE

Declaration

Source position: exec.pas line 575

const SIGF_SINGLE = 1 shl SIGB_SINGLE;


SIH_PRIMASK

Declaration

Source position: exec.pas line 998

const SIH_PRIMASK = $f0;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

SIPTR

Declaration

Source position: exec.pas line 44

type SIPTR = PtrInt;


SM_EXCLUSIVE

Declaration

Source position: exec.pas line 1036

const SM_EXCLUSIVE = 0;


SM_SHARED

Declaration

Source position: exec.pas line 1035

const SM_SHARED = 1;


STRPTR

Pointer to a string (compareable with a PChar)

Declaration

Source position: exec.pas line 25

type STRPTR = PChar;


SYSTEMINFOTAG_CPUINDEX

Declaration

Source position: exec.pas line 1746

const SYSTEMINFOTAG_CPUINDEX = SYSTEMINFOTAG_DUMMY + $0;


SYSTEMINFOTAG_DUMMY

Declaration

Source position: exec.pas line 1745

const SYSTEMINFOTAG_DUMMY = TAG_USER + $112000;


SYSTEMINFOTAG_HOOK

Declaration

Source position: exec.pas line 1748

const SYSTEMINFOTAG_HOOK = SYSTEMINFOTAG_DUMMY + $2;


SYSTEMINFOTAG_MEMHEADER

Declaration

Source position: exec.pas line 1747

const SYSTEMINFOTAG_MEMHEADER = SYSTEMINFOTAG_DUMMY + $1;


SYSTEMINFOTYPE_ALERTMSGPORT

Declaration

Source position: exec.pas line 1706

const SYSTEMINFOTYPE_ALERTMSGPORT = $235;


SYSTEMINFOTYPE_CPUCOUNT

Declaration

Source position: exec.pas line 1665

const SYSTEMINFOTYPE_CPUCOUNT = $101;


SYSTEMINFOTYPE_CPUFAMILYNAME

Declaration

Source position: exec.pas line 1743

const SYSTEMINFOTYPE_CPUFAMILYNAME = $23f;


SYSTEMINFOTYPE_CPUNAME

Declaration

Source position: exec.pas line 1742

const SYSTEMINFOTYPE_CPUNAME = $23e;


SYSTEMINFOTYPE_CPUTIME

Declaration

Source position: exec.pas line 1672

const SYSTEMINFOTYPE_CPUTIME = $204;


SYSTEMINFOTYPE_EMULATION_SIZE

Declaration

Source position: exec.pas line 1698

const SYSTEMINFOTYPE_EMULATION_SIZE = $231;


SYSTEMINFOTYPE_EMULATION_START

Declaration

Source position: exec.pas line 1697

const SYSTEMINFOTYPE_EMULATION_START = $230;


SYSTEMINFOTYPE_EMULHANDLESIZE

Declaration

Source position: exec.pas line 1691

const SYSTEMINFOTYPE_EMULHANDLESIZE = $217;


SYSTEMINFOTYPE_EXCEPTIONMSGPORT

Declaration

Source position: exec.pas line 1692

const SYSTEMINFOTYPE_EXCEPTIONMSGPORT = $218;


SYSTEMINFOTYPE_EXCEPTIONMSGPORT_68K

Declaration

Source position: exec.pas line 1703

const SYSTEMINFOTYPE_EXCEPTIONMSGPORT_68K = $234;


SYSTEMINFOTYPE_FREEBLOCKS

Declaration

Source position: exec.pas line 1740

const SYSTEMINFOTYPE_FREEBLOCKS = $23d;


SYSTEMINFOTYPE_INVOLUNTARYCSW

Declaration

Source position: exec.pas line 1676

const SYSTEMINFOTYPE_INVOLUNTARYCSW = $208;


SYSTEMINFOTYPE_LASTSECCPUTIME

Declaration

Source position: exec.pas line 1673

const SYSTEMINFOTYPE_LASTSECCPUTIME = $205;


SYSTEMINFOTYPE_LASTSECINVOLUNTARYCSW

Declaration

Source position: exec.pas line 1678

const SYSTEMINFOTYPE_LASTSECINVOLUNTARYCSW = $20a;


SYSTEMINFOTYPE_LASTSECTICKS

Declaration

Source position: exec.pas line 1670

const SYSTEMINFOTYPE_LASTSECTICKS = $202;


SYSTEMINFOTYPE_LASTSECVOLUNTARYCSW

Declaration

Source position: exec.pas line 1677

const SYSTEMINFOTYPE_LASTSECVOLUNTARYCSW = $209;


SYSTEMINFOTYPE_LAUNCHTIMETICKS

Declaration

Source position: exec.pas line 1685

const SYSTEMINFOTYPE_LAUNCHTIMETICKS = $210;


SYSTEMINFOTYPE_LAUNCHTIMETICKS1978

Declaration

Source position: exec.pas line 1686

const SYSTEMINFOTYPE_LAUNCHTIMETICKS1978 = $211;


SYSTEMINFOTYPE_LOADAVG1

Declaration

Source position: exec.pas line 1679

const SYSTEMINFOTYPE_LOADAVG1 = $20b;


SYSTEMINFOTYPE_LOADAVG2

Declaration

Source position: exec.pas line 1680

const SYSTEMINFOTYPE_LOADAVG2 = $20c;


SYSTEMINFOTYPE_LOADAVG3

Declaration

Source position: exec.pas line 1681

const SYSTEMINFOTYPE_LOADAVG3 = $20d;


SYSTEMINFOTYPE_MACHINE

Declaration

Source position: exec.pas line 1620

const SYSTEMINFOTYPE_MACHINE = $1;


SYSTEMINFOTYPE_MAGIC1

Declaration

Source position: exec.pas line 1713

const SYSTEMINFOTYPE_MAGIC1 = $238;


SYSTEMINFOTYPE_MAGIC2

Declaration

Source position: exec.pas line 1714

const SYSTEMINFOTYPE_MAGIC2 = $239;


SYSTEMINFOTYPE_MAXALERTCOUNT

Declaration

Source position: exec.pas line 1718

const SYSTEMINFOTYPE_MAXALERTCOUNT = $23b;


SYSTEMINFOTYPE_MAXHITCOUNT

Declaration

Source position: exec.pas line 1716

const SYSTEMINFOTYPE_MAXHITCOUNT = $23a;


SYSTEMINFOTYPE_MODULE_SIZE

Declaration

Source position: exec.pas line 1700

const SYSTEMINFOTYPE_MODULE_SIZE = $233;


SYSTEMINFOTYPE_MODULE_START

Declaration

Source position: exec.pas line 1699

const SYSTEMINFOTYPE_MODULE_START = $232;


SYSTEMINFOTYPE_PAGESIZE

Declaration

Source position: exec.pas line 1664

const SYSTEMINFOTYPE_PAGESIZE = $100;


SYSTEMINFOTYPE_PPC_ALTIVEC

Declaration

Source position: exec.pas line 1657

const SYSTEMINFOTYPE_PPC_ALTIVEC = $51;


SYSTEMINFOTYPE_PPC_BUSCLOCK

Declaration

Source position: exec.pas line 1625

const SYSTEMINFOTYPE_PPC_BUSCLOCK = $5;


SYSTEMINFOTYPE_PPC_BUSTICKS

Declaration

Source position: exec.pas line 1661

const SYSTEMINFOTYPE_PPC_BUSTICKS = $61;


SYSTEMINFOTYPE_PPC_CACHEL1FLAGS

Declaration

Source position: exec.pas line 1634

const SYSTEMINFOTYPE_PPC_CACHEL1FLAGS = $17;


SYSTEMINFOTYPE_PPC_CACHEL1TYPE

Declaration

Source position: exec.pas line 1633

const SYSTEMINFOTYPE_PPC_CACHEL1TYPE = $16;


SYSTEMINFOTYPE_PPC_CACHEL2FLAGS

Declaration

Source position: exec.pas line 1643

const SYSTEMINFOTYPE_PPC_CACHEL2FLAGS = $27;


SYSTEMINFOTYPE_PPC_CACHEL2TYPE

Declaration

Source position: exec.pas line 1642

const SYSTEMINFOTYPE_PPC_CACHEL2TYPE = $26;


SYSTEMINFOTYPE_PPC_CACHEL3FLAGS

Declaration

Source position: exec.pas line 1652

const SYSTEMINFOTYPE_PPC_CACHEL3FLAGS = $37;


SYSTEMINFOTYPE_PPC_CACHEL3TYPE

Declaration

Source position: exec.pas line 1651

const SYSTEMINFOTYPE_PPC_CACHEL3TYPE = $36;


SYSTEMINFOTYPE_PPC_CPUCLOCK

Declaration

Source position: exec.pas line 1624

const SYSTEMINFOTYPE_PPC_CPUCLOCK = $4;


SYSTEMINFOTYPE_PPC_CPUREVISION

Declaration

Source position: exec.pas line 1623

const SYSTEMINFOTYPE_PPC_CPUREVISION = $3;


SYSTEMINFOTYPE_PPC_CPUTEMP

Declaration

Source position: exec.pas line 1662

const SYSTEMINFOTYPE_PPC_CPUTEMP = $62;


SYSTEMINFOTYPE_PPC_CPUVERSION

Declaration

Source position: exec.pas line 1622

const SYSTEMINFOTYPE_PPC_CPUVERSION = $2;


SYSTEMINFOTYPE_PPC_DABR

Declaration

Source position: exec.pas line 1663

const SYSTEMINFOTYPE_PPC_DABR = $63;


SYSTEMINFOTYPE_PPC_DATASTREAM

Declaration

Source position: exec.pas line 1659

const SYSTEMINFOTYPE_PPC_DATASTREAM = $53;


SYSTEMINFOTYPE_PPC_DCACHEL1LINES

Declaration

Source position: exec.pas line 1631

const SYSTEMINFOTYPE_PPC_DCACHEL1LINES = $14;


SYSTEMINFOTYPE_PPC_DCACHEL1LINESIZE

Declaration

Source position: exec.pas line 1632

const SYSTEMINFOTYPE_PPC_DCACHEL1LINESIZE = $15;


SYSTEMINFOTYPE_PPC_DCACHEL1SIZE

Declaration

Source position: exec.pas line 1630

const SYSTEMINFOTYPE_PPC_DCACHEL1SIZE = $13;


SYSTEMINFOTYPE_PPC_DCACHEL2LINES

Declaration

Source position: exec.pas line 1640

const SYSTEMINFOTYPE_PPC_DCACHEL2LINES = $24;


SYSTEMINFOTYPE_PPC_DCACHEL2LINESIZE

Declaration

Source position: exec.pas line 1641

const SYSTEMINFOTYPE_PPC_DCACHEL2LINESIZE = $25;


SYSTEMINFOTYPE_PPC_DCACHEL2SIZE

Declaration

Source position: exec.pas line 1639

const SYSTEMINFOTYPE_PPC_DCACHEL2SIZE = $23;


SYSTEMINFOTYPE_PPC_DCACHEL3LINES

Declaration

Source position: exec.pas line 1649

const SYSTEMINFOTYPE_PPC_DCACHEL3LINES = $34;


SYSTEMINFOTYPE_PPC_DCACHEL3LINESIZE

Declaration

Source position: exec.pas line 1650

const SYSTEMINFOTYPE_PPC_DCACHEL3LINESIZE = $35;


SYSTEMINFOTYPE_PPC_DCACHEL3SIZE

Declaration

Source position: exec.pas line 1648

const SYSTEMINFOTYPE_PPC_DCACHEL3SIZE = $33;


SYSTEMINFOTYPE_PPC_FPU

Declaration

Source position: exec.pas line 1656

const SYSTEMINFOTYPE_PPC_FPU = $50;


SYSTEMINFOTYPE_PPC_ICACHEL1LINES

Declaration

Source position: exec.pas line 1628

const SYSTEMINFOTYPE_PPC_ICACHEL1LINES = $11;


SYSTEMINFOTYPE_PPC_ICACHEL1LINESIZE

Declaration

Source position: exec.pas line 1629

const SYSTEMINFOTYPE_PPC_ICACHEL1LINESIZE = $12;


SYSTEMINFOTYPE_PPC_ICACHEL1SIZE

Declaration

Source position: exec.pas line 1627

const SYSTEMINFOTYPE_PPC_ICACHEL1SIZE = $10;


SYSTEMINFOTYPE_PPC_ICACHEL2LINES

Declaration

Source position: exec.pas line 1637

const SYSTEMINFOTYPE_PPC_ICACHEL2LINES = $21;


SYSTEMINFOTYPE_PPC_ICACHEL2LINESIZE

Declaration

Source position: exec.pas line 1638

const SYSTEMINFOTYPE_PPC_ICACHEL2LINESIZE = $22;


SYSTEMINFOTYPE_PPC_ICACHEL2SIZE

Declaration

Source position: exec.pas line 1636

const SYSTEMINFOTYPE_PPC_ICACHEL2SIZE = $20;


SYSTEMINFOTYPE_PPC_ICACHEL3LINES

Declaration

Source position: exec.pas line 1646

const SYSTEMINFOTYPE_PPC_ICACHEL3LINES = $31;


SYSTEMINFOTYPE_PPC_ICACHEL3LINESIZE

Declaration

Source position: exec.pas line 1647

const SYSTEMINFOTYPE_PPC_ICACHEL3LINESIZE = $32;


SYSTEMINFOTYPE_PPC_ICACHEL3SIZE

Declaration

Source position: exec.pas line 1645

const SYSTEMINFOTYPE_PPC_ICACHEL3SIZE = $30;


SYSTEMINFOTYPE_PPC_PERFMONITOR

Declaration

Source position: exec.pas line 1658

const SYSTEMINFOTYPE_PPC_PERFMONITOR = $52;


SYSTEMINFOTYPE_PPC_RESERVATIONSIZE

Declaration

Source position: exec.pas line 1660

const SYSTEMINFOTYPE_PPC_RESERVATIONSIZE = $60;


SYSTEMINFOTYPE_PPC_TLBENTRIES

Declaration

Source position: exec.pas line 1654

const SYSTEMINFOTYPE_PPC_TLBENTRIES = $40;


SYSTEMINFOTYPE_PPC_TLBSETS

Declaration

Source position: exec.pas line 1655

const SYSTEMINFOTYPE_PPC_TLBSETS = $41;


SYSTEMINFOTYPE_RECENTCPUTIME

Declaration

Source position: exec.pas line 1674

const SYSTEMINFOTYPE_RECENTCPUTIME = $206;


SYSTEMINFOTYPE_RECENTTICKS

Declaration

Source position: exec.pas line 1671

const SYSTEMINFOTYPE_RECENTTICKS = $203;


SYSTEMINFOTYPE_REGUSER

Declaration

Source position: exec.pas line 1720

const SYSTEMINFOTYPE_REGUSER = $23c;


SYSTEMINFOTYPE_REVISION

Declaration

Source position: exec.pas line 1710

const SYSTEMINFOTYPE_REVISION = $237;


SYSTEMINFOTYPE_SYSTEM

Declaration

Source position: exec.pas line 1619

const SYSTEMINFOTYPE_SYSTEM = $0;


SYSTEMINFOTYPE_TASKEXITCODE

Declaration

Source position: exec.pas line 1693

const SYSTEMINFOTYPE_TASKEXITCODE = $219;


SYSTEMINFOTYPE_TASKEXITCODE_M68K

Declaration

Source position: exec.pas line 1694

const SYSTEMINFOTYPE_TASKEXITCODE_M68K = $21a;


SYSTEMINFOTYPE_TASKSCREATED

Declaration

Source position: exec.pas line 1683

const SYSTEMINFOTYPE_TASKSCREATED = $20e;


SYSTEMINFOTYPE_TASKSFINISHED

Declaration

Source position: exec.pas line 1684

const SYSTEMINFOTYPE_TASKSFINISHED = $20f;


SYSTEMINFOTYPE_TASKSRUNNING

Declaration

Source position: exec.pas line 1687

const SYSTEMINFOTYPE_TASKSRUNNING = $212;


SYSTEMINFOTYPE_TASKSSLEEPING

Declaration

Source position: exec.pas line 1688

const SYSTEMINFOTYPE_TASKSSLEEPING = $213;


SYSTEMINFOTYPE_TBCLOCKFREQUENCY

Declaration

Source position: exec.pas line 1668

const SYSTEMINFOTYPE_TBCLOCKFREQUENCY = $200;


SYSTEMINFOTYPE_UPTIMETICKS

Declaration

Source position: exec.pas line 1669

const SYSTEMINFOTYPE_UPTIMETICKS = $201;


SYSTEMINFOTYPE_VENDOR

Declaration

Source position: exec.pas line 1709

const SYSTEMINFOTYPE_VENDOR = $236;


SYSTEMINFOTYPE_VOLUNTARYCSW

Declaration

Source position: exec.pas line 1675

const SYSTEMINFOTYPE_VOLUNTARYCSW = $207;


TAG_USER

Declaration

Source position: exec.pas line 500

const TAG_USER = 1 shl 31;


TAlertMessage

Declaration

Source position: exec.pas line 960

type TAlertMessage = packed record

  Message: TMessage;

  Task: PTask;

  Version: LongWord;

  ID: LongWord;

end;


TASKERROR_NOMEMORY

Declaration

Source position: exec.pas line 535

const TASKERROR_NOMEMORY = 1;


TASKERROR_OK

Declaration

Source position: exec.pas line 534

const TASKERROR_OK = 0;


TASKINFOTAG_DUMMY

Declaration

Source position: exec.pas line 704

const TASKINFOTAG_DUMMY = TAG_USER + $110000;


TASKINFOTAG_HOOK

Declaration

Source position: exec.pas line 705

const TASKINFOTAG_HOOK = TASKINFOTAG_DUMMY + $0;


TASKINFOTAG_REGCOUNT

Declaration

Source position: exec.pas line 707

const TASKINFOTAG_REGCOUNT = TASKINFOTAG_DUMMY + $2;


TASKINFOTAG_REGSTART

Declaration

Source position: exec.pas line 706

const TASKINFOTAG_REGSTART = TASKINFOTAG_DUMMY + $1;


TASKINFOTYPE_68K_NEWFRAME

Declaration

Source position: exec.pas line 686

const TASKINFOTYPE_68K_NEWFRAME = $50;


TASKINFOTYPE_AGETICKS

Declaration

Source position: exec.pas line 653

const TASKINFOTYPE_AGETICKS = $1a;


TASKINFOTYPE_ALERTCOUNT

Declaration

Source position: exec.pas line 681

const TASKINFOTYPE_ALERTCOUNT = $31;


TASKINFOTYPE_ALLTASK

Declaration

Source position: exec.pas line 623

const TASKINFOTYPE_ALLTASK = $0;


TASKINFOTYPE_CPUTIME

Declaration

Source position: exec.pas line 654

const TASKINFOTYPE_CPUTIME = $1b;


TASKINFOTYPE_EMULHANDLE

Declaration

Source position: exec.pas line 674

const TASKINFOTYPE_EMULHANDLE = $2d;


TASKINFOTYPE_EXCEPTCODE

Declaration

Source position: exec.pas line 634

const TASKINFOTYPE_EXCEPTCODE = $b;


TASKINFOTYPE_EXCEPTDATA

Declaration

Source position: exec.pas line 633

const TASKINFOTYPE_EXCEPTDATA = $a;


TASKINFOTYPE_EXCEPTIONCOUNT

Declaration

Source position: exec.pas line 676

const TASKINFOTYPE_EXCEPTIONCOUNT = $2e;


TASKINFOTYPE_FLAGS

Declaration

Source position: exec.pas line 628

const TASKINFOTYPE_FLAGS = $5;


TASKINFOTYPE_HITCOUNT

Declaration

Source position: exec.pas line 677

const TASKINFOTYPE_HITCOUNT = $2f;


TASKINFOTYPE_INVOLUNTARYCSW

Declaration

Source position: exec.pas line 658

const TASKINFOTYPE_INVOLUNTARYCSW = $1f;


TASKINFOTYPE_LASTSECCPUTIME

Declaration

Source position: exec.pas line 655

const TASKINFOTYPE_LASTSECCPUTIME = $1c;


TASKINFOTYPE_LASTSECINVOLUNTARYCSW

Declaration

Source position: exec.pas line 660

const TASKINFOTYPE_LASTSECINVOLUNTARYCSW = $21;


TASKINFOTYPE_LASTSECVOLUNTARYCSW

Declaration

Source position: exec.pas line 659

const TASKINFOTYPE_LASTSECVOLUNTARYCSW = $20;


TASKINFOTYPE_LAUNCHTIMETICKS

Declaration

Source position: exec.pas line 662

const TASKINFOTYPE_LAUNCHTIMETICKS = $22;


TASKINFOTYPE_LAUNCHTIMETICKS1978

Declaration

Source position: exec.pas line 663

const TASKINFOTYPE_LAUNCHTIMETICKS1978 = $23;


TASKINFOTYPE_MAXALERTCOUNT

Declaration

Source position: exec.pas line 682

const TASKINFOTYPE_MAXALERTCOUNT = $32;


TASKINFOTYPE_MAXHITCOUNT

Declaration

Source position: exec.pas line 679

const TASKINFOTYPE_MAXHITCOUNT = $30;


TASKINFOTYPE_NAME

Declaration

Source position: exec.pas line 624

const TASKINFOTYPE_NAME = $1;


TASKINFOTYPE_NAMECOPY

Declaration

Source position: exec.pas line 670

const TASKINFOTYPE_NAMECOPY = $2a;


TASKINFOTYPE_NICE

Declaration

Source position: exec.pas line 652

const TASKINFOTYPE_NICE = $19;


TASKINFOTYPE_PID

Declaration

Source position: exec.pas line 684

const TASKINFOTYPE_PID = $33;


TASKINFOTYPE_PID_CLI

Declaration

Source position: exec.pas line 664

const TASKINFOTYPE_PID_CLI = $24;


TASKINFOTYPE_POOLMEMFLAGS

Declaration

Source position: exec.pas line 645

const TASKINFOTYPE_POOLMEMFLAGS = $16;


TASKINFOTYPE_POOLPTR

Declaration

Source position: exec.pas line 644

const TASKINFOTYPE_POOLPTR = $15;


TASKINFOTYPE_POOLPUDDLESIZE

Declaration

Source position: exec.pas line 646

const TASKINFOTYPE_POOLPUDDLESIZE = $17;


TASKINFOTYPE_POOLTHRESHSIZE

Declaration

Source position: exec.pas line 647

const TASKINFOTYPE_POOLTHRESHSIZE = $18;


TASKINFOTYPE_PPC_CR

Declaration

Source position: exec.pas line 692

const TASKINFOTYPE_PPC_CR = $104;


TASKINFOTYPE_PPC_CTR

Declaration

Source position: exec.pas line 691

const TASKINFOTYPE_PPC_CTR = $103;


TASKINFOTYPE_PPC_FPR

Declaration

Source position: exec.pas line 695

const TASKINFOTYPE_PPC_FPR = $107;


TASKINFOTYPE_PPC_FPSCR

Declaration

Source position: exec.pas line 696

const TASKINFOTYPE_PPC_FPSCR = $108;


TASKINFOTYPE_PPC_FRAME

Declaration

Source position: exec.pas line 700

const TASKINFOTYPE_PPC_FRAME = $10c;


TASKINFOTYPE_PPC_FRAMESIZE

Declaration

Source position: exec.pas line 701

const TASKINFOTYPE_PPC_FRAMESIZE = $10d;


TASKINFOTYPE_PPC_GPR

Declaration

Source position: exec.pas line 694

const TASKINFOTYPE_PPC_GPR = $106;


TASKINFOTYPE_PPC_LR

Declaration

Source position: exec.pas line 690

const TASKINFOTYPE_PPC_LR = $102;


TASKINFOTYPE_PPC_NEWFRAME

Declaration

Source position: exec.pas line 702

const TASKINFOTYPE_PPC_NEWFRAME = $10e;


TASKINFOTYPE_PPC_SRR0

Declaration

Source position: exec.pas line 688

const TASKINFOTYPE_PPC_SRR0 = $100;


TASKINFOTYPE_PPC_SRR1

Declaration

Source position: exec.pas line 689

const TASKINFOTYPE_PPC_SRR1 = $101;


TASKINFOTYPE_PPC_VMX

Declaration

Source position: exec.pas line 698

const TASKINFOTYPE_PPC_VMX = $10a;


TASKINFOTYPE_PPC_VSAVE

Declaration

Source position: exec.pas line 699

const TASKINFOTYPE_PPC_VSAVE = $10b;


TASKINFOTYPE_PPC_VSCR

Declaration

Source position: exec.pas line 697

const TASKINFOTYPE_PPC_VSCR = $109;


TASKINFOTYPE_PPC_XER

Declaration

Source position: exec.pas line 693

const TASKINFOTYPE_PPC_XER = $105;


TASKINFOTYPE_PRI

Declaration

Source position: exec.pas line 625

const TASKINFOTYPE_PRI = $2;


TASKINFOTYPE_RECENTCPUTIME

Declaration

Source position: exec.pas line 656

const TASKINFOTYPE_RECENTCPUTIME = $1d;


TASKINFOTYPE_RESURRECT_TASK

Declaration

Source position: exec.pas line 673

const TASKINFOTYPE_RESURRECT_TASK = $2c;


TASKINFOTYPE_SIGALLOC

Declaration

Source position: exec.pas line 629

const TASKINFOTYPE_SIGALLOC = $6;


TASKINFOTYPE_SIGEXCEPT

Declaration

Source position: exec.pas line 632

const TASKINFOTYPE_SIGEXCEPT = $9;


TASKINFOTYPE_SIGRECVD

Declaration

Source position: exec.pas line 631

const TASKINFOTYPE_SIGRECVD = $8;


TASKINFOTYPE_SIGWAIT

Declaration

Source position: exec.pas line 630

const TASKINFOTYPE_SIGWAIT = $7;


TASKINFOTYPE_SPLOWER

Declaration

Source position: exec.pas line 666

const TASKINFOTYPE_SPLOWER = $26;


TASKINFOTYPE_SPLOWER_M68K

Declaration

Source position: exec.pas line 668

const TASKINFOTYPE_SPLOWER_M68K = $28;


TASKINFOTYPE_SPUPPER

Declaration

Source position: exec.pas line 667

const TASKINFOTYPE_SPUPPER = $27;


TASKINFOTYPE_SPUPPER_M68K

Declaration

Source position: exec.pas line 669

const TASKINFOTYPE_SPUPPER_M68K = $29;


TASKINFOTYPE_STACKSIZE

Declaration

Source position: exec.pas line 638

const TASKINFOTYPE_STACKSIZE = $f;


TASKINFOTYPE_STACKSIZE_M68K

Declaration

Source position: exec.pas line 637

const TASKINFOTYPE_STACKSIZE_M68K = $e;


TASKINFOTYPE_STARTUPMSG

Declaration

Source position: exec.pas line 642

const TASKINFOTYPE_STARTUPMSG = $13;


TASKINFOTYPE_STATE

Declaration

Source position: exec.pas line 627

const TASKINFOTYPE_STATE = $4;


TASKINFOTYPE_TASKMSGPORT

Declaration

Source position: exec.pas line 643

const TASKINFOTYPE_TASKMSGPORT = $14;


TASKINFOTYPE_TRAPCODE

Declaration

Source position: exec.pas line 636

const TASKINFOTYPE_TRAPCODE = $d;


TASKINFOTYPE_TRAPDATA

Declaration

Source position: exec.pas line 635

const TASKINFOTYPE_TRAPDATA = $c;


TASKINFOTYPE_TRAPMSGPORT

Declaration

Source position: exec.pas line 641

const TASKINFOTYPE_TRAPMSGPORT = $12;


TASKINFOTYPE_TYPE

Declaration

Source position: exec.pas line 626

const TASKINFOTYPE_TYPE = $3;


TASKINFOTYPE_USEDSTACKSIZE

Declaration

Source position: exec.pas line 640

const TASKINFOTYPE_USEDSTACKSIZE = $11;


TASKINFOTYPE_USEDSTACKSIZE_M68K

Declaration

Source position: exec.pas line 639

const TASKINFOTYPE_USEDSTACKSIZE_M68K = $10;


TASKINFOTYPE_USERDATA

Declaration

Source position: exec.pas line 672

const TASKINFOTYPE_USERDATA = $2b;


TASKINFOTYPE_VOLUNTARYCSW

Declaration

Source position: exec.pas line 657

const TASKINFOTYPE_VOLUNTARYCSW = $1e;


TASKTAG_CODETYPE

Declaration

Source position: exec.pas line 505

const TASKTAG_CODETYPE = TASKTAG_DUMMY + $1;


TASKTAG_DUMMY

Declaration

Source position: exec.pas line 503

const TASKTAG_DUMMY = TAG_USER + $100000;


TASKTAG_ERROR

Declaration

Source position: exec.pas line 504

const TASKTAG_ERROR = TASKTAG_DUMMY + $0;


TASKTAG_FINALPC

Declaration

Source position: exec.pas line 507

const TASKTAG_FINALPC = TASKTAG_DUMMY + $3;


TASKTAG_FLAGS

Declaration

Source position: exec.pas line 525

const TASKTAG_FLAGS = TASKTAG_DUMMY + $1a;


TASKTAG_NAME

Declaration

Source position: exec.pas line 510

const TASKTAG_NAME = TASKTAG_DUMMY + $6;


TASKTAG_PC

Declaration

Source position: exec.pas line 506

const TASKTAG_PC = TASKTAG_DUMMY + $2;


TASKTAG_POOLPUDDLE

Declaration

Source position: exec.pas line 513

const TASKTAG_POOLPUDDLE = TASKTAG_DUMMY + $9;


TASKTAG_POOLTHRESH

Declaration

Source position: exec.pas line 514

const TASKTAG_POOLTHRESH = TASKTAG_DUMMY + $a;


TASKTAG_PPC_ARG1

Declaration

Source position: exec.pas line 515

const TASKTAG_PPC_ARG1 = TASKTAG_DUMMY + $10;


TASKTAG_PPC_ARG2

Declaration

Source position: exec.pas line 516

const TASKTAG_PPC_ARG2 = TASKTAG_DUMMY + $11;


TASKTAG_PPC_ARG3

Declaration

Source position: exec.pas line 517

const TASKTAG_PPC_ARG3 = TASKTAG_DUMMY + $12;


TASKTAG_PPC_ARG4

Declaration

Source position: exec.pas line 518

const TASKTAG_PPC_ARG4 = TASKTAG_DUMMY + $13;


TASKTAG_PPC_ARG5

Declaration

Source position: exec.pas line 519

const TASKTAG_PPC_ARG5 = TASKTAG_DUMMY + $14;


TASKTAG_PPC_ARG6

Declaration

Source position: exec.pas line 520

const TASKTAG_PPC_ARG6 = TASKTAG_DUMMY + $15;


TASKTAG_PPC_ARG7

Declaration

Source position: exec.pas line 521

const TASKTAG_PPC_ARG7 = TASKTAG_DUMMY + $16;


TASKTAG_PPC_ARG8

Declaration

Source position: exec.pas line 522

const TASKTAG_PPC_ARG8 = TASKTAG_DUMMY + $17;


TASKTAG_PRI

Declaration

Source position: exec.pas line 512

const TASKTAG_PRI = TASKTAG_DUMMY + $8;


TASKTAG_STACKSIZE

Declaration

Source position: exec.pas line 508

const TASKTAG_STACKSIZE = TASKTAG_DUMMY + $4;


TASKTAG_STACKSIZE_M68K

Declaration

Source position: exec.pas line 509

const TASKTAG_STACKSIZE_M68K = TASKTAG_DUMMY + $5;


TASKTAG_STARTUPMSG

Declaration

Source position: exec.pas line 523

const TASKTAG_STARTUPMSG = TASKTAG_DUMMY + $18;


TASKTAG_TASKMSGPORT

Declaration

Source position: exec.pas line 524

const TASKTAG_TASKMSGPORT = TASKTAG_DUMMY + $19;


TASKTAG_TCBEXTRASIZE

Declaration

Source position: exec.pas line 526

const TASKTAG_TCBEXTRASIZE = TASKTAG_DUMMY + $1c;


TASKTAG_USERDATA

Declaration

Source position: exec.pas line 511

const TASKTAG_USERDATA = TASKTAG_DUMMY + $7;


TB_ETASK

Flag Bit for tc_Flags

Declaration

Source position: exec.pas line 543

const TB_ETASK = 3;


TB_EXCEPT

Flag Bit for tc_Flags Task gets no CPU time.

Declaration

Source position: exec.pas line 545

const TB_EXCEPT = 5;


TB_LAUNCH

Flag Bit for tc_Flags Task is switched to CPU.

Declaration

Source position: exec.pas line 547

const TB_LAUNCH = 7;


TB_PROCTIME

Flag Bit for tc_Flags Task uses CPU.

Declaration

Source position: exec.pas line 542

const TB_PROCTIME = 0;


TB_STACKCHK

Flag Bit for tc_Flags Stack is checked.

Declaration

Source position: exec.pas line 544

const TB_STACKCHK = 4;


TB_SWITCH

Flag Bit for tc_Flags Task is switched away from CPU.

Declaration

Source position: exec.pas line 546

const TB_SWITCH = 6;


TDevice

Device has the same structure as an Library

Declaration

Source position: exec.pas line 1298

type TDevice = packed record

  dd_Library: TLibrary;

Device has the same structure as an Library

end;


TEmulHandle

Declaration

Source position: exec.pas line 97

type TEmulHandle = packed record

  reg: array [TEmulRegs] of LongWord;

  SuperHandle: Pointer;

  _Type: LongWord;

  Flags: LongWord;

  EmulFunc: procedure;

  EmulCallOS: function(

  EmulCaos: pointer

):LongWord;

  EmulCall68k: function(

  EmulCaos: pointer

):LongWord;

  EmulCallQuick68k: function(

  EmulCaos: pointer

):LongWord;

  EmulCallDirectOS: function(

  arg: LongInt

):LongWord;

  EmulCallDirect68k: function(

  arg: Pointer

):LongWord;

  OldEmulHandle: PEmulHandle;

end;


TEmulLibEntry

Declaration

Source position: exec.pas line 86

type TEmulLibEntry = packed record

  Trap: Word;

  Extension: Word;

  Func: Pointer;

end;


TEmulRegs

Declaration

Source position: exec.pas line 93

type TEmulRegs = (

  regD0,

  regD1,

  regD2,

  regD3,

  regD4,

  regD5,

  regD6,

  regD7,

  regA0,

  regA1,

  regA2,

  regA3,

  regA4,

  regA5,

  regA6,

  regA7,

  regPC,

  regSR

);


TETask

Declaration

Source position: exec.pas line 424

type TETask = packed record

  Message: TMessage;

  Parent: PTask;

  UniqueID: LongWord;

  Children: TMinList;

  TrapAlloc: Word;

  TrapAble: Word;

  Result1: LongWord;

  Result2: Pointer;

  MsgPort: TMsgPort;

  MemPool: Pointer;

  PPCSPLower: Pointer;

  PPCSPUpper: Pointer;

  PPCRegFrame: Pointer;

  PPCLibData: Pointer;

  PPCTrapMsgPort: PMsgPort;

  PPCTrapMessage: PTaskTrapMessage;

end;


TExecBase

Declaration

Source position: exec.pas line 1378

type TExecBase = packed record
LIbNode: TLibrary; | Standard library structure
SoftVer: Word; | Kickstart release number
LowMemChkSum: SmallInt; | Lower memory checksum
ChkBase: LongWord; | System base address
ColdCapture: Pointer; | Cold boot address
CoolCapture: Pointer; |
WarmCapture: Pointer; | Warm start address
SysStkUpper: Pointer; | System stack: upper border
SysStkLower: Pointer; | System stack: lower border
MaxLocMem: LongWord; | Maximal useable memory
DebugEntry: Pointer; | Jump address for debugger
DebugData: Pointer; | Pointer to data for debugger
AlertData: Pointer; | Pointer to alert data
MaxExtMem: Pointer; | Maximal available external memory
ChkSum: Word; | Checksum of the upper values
IntVects: array [0..15] of TIntVector; | Vector table of interrupts
ThisTask: PTask; | Pointer of the currently running task
IdleCount: LongWord; | Idle Counter
DispCount: LongWord; | Dispatch Counter
Quantum: Word; | CPU time of every task
Elapsed: Word; |
SysFlags: Word; | Used cput time
IDNestCnt: ShortInt; | interrupt disable nesting count
TDNestCnt: ShortInt; | task disable nesting count
AttnFlags: Word; | special attention flags (readable)
AttnResched: Word; | rescheduling attention
ResModules: Pointer; | resident module array pointer
TaskTrapCode: Pointer; | Task - Pointer
TaskExceptCode: Pointer; |
TaskExitCode: Pointer; |
TaskSigAlloc: LongWord; | Task - Signals
TaskTrapAlloc: Word; | Task - Traps
MemList: TList; | List of available memory.
ResourceList: TList; | List of available resources.
DeviceList: TList; | List of available devices.
IntrList: TList; | List of available Interrupts
LibList: TList; | List of open libraries
PortList: TList; | List of open Ports.
TaskReady: TList; | Tasks with state Ready
TaskWait: TList; | Tasks with State waiting for singal
SoftInts: array [0..4] of TSoftIntList; |
LastAlert: array [0..3] of LongInt; | Last alert number
VBlankFrequency: Byte; |
PowerSupplyFrequency: Byte; |
SemaphoreList: TList; |
KickMemPtr: Pointer; | Pointer to queue of mem lists
KickTagPtr: Pointer; | Pointer to rom tag queue
KickCheckSum: Pointer; | Checksum for mem and tags
ex_Pad0: Word; |
ex_LaunchPoint: LongWord; |
ex_RamLibPrivate: Pointer; |
ex_EClockFrequency: LongWord; |
ex_CacheControl: LongWord; | Private to CacheControl calls
ex_TaskID: LongWord; | Next available Task ID
ex_EmulHandleSize: LongWord; |
ex_PPCTrapMsgPort: PMsgPort; |
ex_Reserved1: array [0..2] of LongWord; |
ex_MMULock: Pointer; |
ex_PatchPool: Pointer; |
ex_PPCTaskExitCode: Pointer; |
ex_DebugFlags: LongWord; |
ex_MemHandlers: TMinList; | Memory Handler List
ex_MemHandler: Pointer; |
end;


TExecNotifyMessage

Declaration

Source position: exec.pas line 1591

type TExecNotifyMessage = packed record

  MType: LongWord;

  Flags: LongWord;

  Extra: LongWord;

  Extension: Pointer;

end;


TF_ETASK

Flag value for tc_Flags

Declaration

Source position: exec.pas line 550

const TF_ETASK = 1 shl TB_ETASK;


TF_EXCEPT

Flag value for tc_Flags Task gets no CPU time.

Declaration

Source position: exec.pas line 552

const TF_EXCEPT = 1 shl TB_EXCEPT;


TF_LAUNCH

Flag value for tc_Flags Task is switched to CPU.

Declaration

Source position: exec.pas line 554

const TF_LAUNCH = 1 shl TB_LAUNCH;


TF_PROCTIME

Flag value for tc_Flags Task uses CPU.

Declaration

Source position: exec.pas line 549

const TF_PROCTIME = 1 shl TB_PROCTIME;


TF_STACKCHK

Flag value for tc_Flags Stack is checked.

Declaration

Source position: exec.pas line 551

const TF_STACKCHK = 1 shl TB_STACKCHK;


TF_SWITCH

Flag value for tc_Flags Task is switched away from CPU.

Declaration

Source position: exec.pas line 553

const TF_SWITCH = 1 shl TB_SWITCH;


TFreeBlocksData

Declaration

Source position: exec.pas line 352

type TFreeBlocksData = record

  fbd_NumBlocks: LongWord;

  fbd_Blocks: array [0..0] of TMemEntry;

end;


TFuncEntry

Declaration

Source position: exec.pas line 1145

type TFuncEntry = packed record

  EmulLibEntry: TEmulLibEntry;

  OldFunction: Pointer;

end;


TFuncOldEntry

Declaration

Source position: exec.pas line 1151

type TFuncOldEntry = packed record

  Command: Word;

  FuncEntry: PFuncEntry;

end;


TInterrupt

Declaration

Source position: exec.pas line 978

type TInterrupt = packed record
is_Node: TNode; |
is_Data: Pointer; | Server data segment
is_Code: Pointer; | Server code entry
end;

See also

AddIntServer | Adds a interrupt server to the system
RemIntServer | Remove an interrupt server from a server chain
AddMemHandler |
RemMemHandler | Remove low memory handler from exec
Cause | Fire and software interrupt
SetIntVector | Set a new handler for a system interrupt vector


TIntVector

For EXEC use ONLY!

Declaration

Source position: exec.pas line 985

type TIntVector = packed record

  iv_Data: Pointer;

  iv_Code: Pointer;

  iv_Node: PNode;

end;

See also

TExecBase


TIORequest

Declaration

Source position: exec.pas line 1325

type TIORequest = packed record
io_Message: TMessage; | Message structure
io_Device: PDevice; | Pointer to the device to use
io_Unit: PUnit; | pointer to unit (depends on device)
io_Command: Word; | Command send to device (CMD_*)
io_Flags: Byte; | Device flags, different for every device.
io_Error: ShortInt; | Device error messages, different for every device.
end;


TIOStdReq

Declaration

Source position: exec.pas line 1336

type TIOStdReq = packed record
io_Message: TMessage; | Message structure
io_Device: PDevice; | Pointer to device to use
io_Unit: PUnit; | Pointer to unit, depend on the device
io_Command: Word; | Command to sent to device
io_Flags: Byte; | Flags for device, depend on device.
io_Error: ShortInt; | Error of device, depend on device
io_Actual: DWord; | Number of bytes sent to device
io_Length: DWord; | Number of bytes transfered.
io_Data: Pointer; | Pointer to data buffer
io_Offset: DWord; | Offset for block structured devices
end;


TLibrary

Library Base Structure

Declaration

Source position: exec.pas line 1070

type TLibrary = packed record
lib_Node: TNode; | For integrating the library into the system lists.
lib_Flags: Byte; | Flags for the Library (LIBF_*)
lib_pad: Byte; | padding byte
lib_NegSize: Word; | Size of vector tavle in bytes.
lib_PosSize: Word; | Size of data in bytes.
lib_Version: Word; | Version number of the library.
lib_Revision: Word; | Revision number of the library.
lib_IdString: PChar; | Pointer to identification text.
lib_Sum: LongWord; | Library checksum.
lib_OpenCnt: Word; | Openning counter. Counts how many times this library is currently open.
end;

Description

Also used for Devices and some Resources

See also

OpenLibrary | Open a library to use
OldOpenLibrary | Old Version of OpenLibrary (deprecated)
CloseLibrary | Close access to library
AddLibrary | Adds a library to the system
MakeLibrary | Construct a library
RemLibrary | Remove a library from the system
SumLibrary | Compute and check the checksum on a library
SetFunction | Change a function vector in a library


TList

List header.

Declaration

Source position: exec.pas line 200

type TList = packed record
lh_Head: PNode; | Pointer to first node in list.
lh_Tail: PNode; | Pointer to last node in list.
lh_TailPred: PNode; | Pointer to node before last node in list.
lh_Type: Byte; | Type of List (NT_*)
lh_pad: Byte; |
end;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name


TLS_INVALID_INDEX

Declaration

Source position: exec.pas line 1752

const TLS_INVALID_INDEX = $ffffffff;


TLSTAG_DESTRUCTOR

Tag for TLSAllocA

Declaration

Source position: exec.pas line 1756

const TLSTAG_DESTRUCTOR = TLSTAG_DUMMY + $0;


TLSTAG_DUMMY

Declaration

Source position: exec.pas line 1755

const TLSTAG_DUMMY = TAG_USER + $120000;


TLSTAG_USERDATA

Tag for TLSAllocA

Declaration

Source position: exec.pas line 1757

const TLSTAG_USERDATA = TLSTAG_DUMMY + $1;


TMemChunk

Declaration

Source position: exec.pas line 277

type TMemChunk = packed record
mc_Next: PMemChunk; | pointer to next chunk
mc_Bytes: LongWord; | chunk byte size
end;

See also

TMemHeader


TMemEntry

Declaration

Source position: exec.pas line 295

type TMemEntry = packed record

  me_Un: packed record

    case Byte of

      0: (

          meu_Reqs: LongWord;

        );

      1: (

          meu_Addr: Pointer;

        );

  end;

  me_Length: LongWord;

end;

See also

TMemList

List of all available Memory


TMemHandlerData

Memory Handler

Declaration

Source position: exec.pas line 337

type TMemHandlerData = packed record
memh_RequestSize: LongWord; | Requested allocation size
memh_RequestFlags: LongWord; | Requested allocation flags
memh_Flags: LongWord; | Flags = MEMHF_RECYCLE
end;

Description

This structure is READ ONLY and only EXEC can create it!


TMemHeader

Declaration

Source position: exec.pas line 284

type TMemHeader = packed record
mh_Node: TNode; |
mh_Attributes: Word; | characteristics of this region (MEMF_*)
mh_First: PMemChunk; | first free region
mh_Lower: Pointer; | lower memory bound
mh_Upper: Pointer; | upper memory bound + 1
mh_Free: LongWord; | total number of free bytes
end;

See also

Allocate | Allocate a block of memory
Deallocate | Free a block of memory


TMemList

List of all available Memory

Declaration

Source position: exec.pas line 306

type TMemList = packed record
ml_Node: TNode; |
ml_NumEntries: Word; | Number of entries in this struct
ml_ME: array [0..0] of TMemEntry; | The first entry
end;

Description

Note: SizeOf(TMemList) includes the size of the first MemEntry!

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Free many blocks of memory at once


TMessage

Message from/for a MessagePort

Declaration

Source position: exec.pas line 384

type TMessage = packed record
mn_Node: TNode; | Node for linking of different messages.
mn_ReplyPort: PMsgPort; | Message port for the reply message using ReplyMsg.
mn_Length: Word; | Length ob message in bytes
end;

See also

GetMsg | Get next message from message port
PutMsg | Put a message to a message port
ReplyMsg | Put a message to its reply port
WaitPort | Wait for a given port to be non-empty


TMinList

Minimal list strcture.

Declaration

Source position: exec.pas line 210

type TMinList = packed record
mlh_Head: PMinNode; | Pointer to first node in list.
mlh_Tail: PMinNode; | Pointer to last node in list.
mlh_TailPred: PMinNode; | Pointer to node before last node in list.
end;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name


TMinNode

Minimal list entry without any type or name.

Declaration

Source position: exec.pas line 161

type TMinNode = packed record
mln_Succ: PMinNode; | Pointer next node of the list.
mln_Pred: PMinNode; | Pointer previous node of the list.
end;

See also

tNode

List node structure, Each member in a list starts with a node.


TMsgPort

Port for inter-task communication.

Declaration

Source position: exec.pas line 366

type TMsgPort = packed record
mp_Node: TNode; | Node for connections to other Msgports in the system.
mp_Flags: Byte; | Flags, showing if a message arrived at port. (PA_*)
mp_SigBit: Byte; | Number of signal bit dedicated to this port.
mp_SigTask: Pointer; | Pointer to task to get the signal.
mp_MsgList: TList; | List of all available messages
end;

See also

AddPort | Add a public message port to the system
RemPort | Remove a message port from the system
CreateIORequest | Create a structure usable for an I/O request
CreateMsgPort | Create a new message port
DeleteMsgPort | Free a message port
FindPort | Find a system message port by name
GetMsg | Get next message from message port
PutMsg | Put a message to a message port
WaitPort | Wait for a given port to be non-empty
tMessage | Message from/for a MessagePort


TNode

List node structure, Each member in a list starts with a node.

Declaration

Source position: exec.pas line 151

type TNode = packed record
ln_Succ: PNode; | Pointer next node of the list.
ln_Pred: PNode; | Pointer previous node of the list.
ln_Type: Byte; | Type code.
ln_Pri: ShortInt; | Priority of node, mainly for list sorting.
ln_Name: PChar; | Identification string
end;

See also

tMinNode | Minimal list entry without any type or name.
tList | List header.


TPPCStackSwapArgs

Declaration

Source position: exec.pas line 614

type TPPCStackSwapArgs = packed record

  Args: array [0..7] of LongWord;

end;


TRAP_AREA_START

Declaration

Source position: exec.pas line 56

const TRAP_AREA_START = $ff00;


TRAP_EIEIO

Declaration

Source position: exec.pas line 63

const TRAP_EIEIO = $ff11;


TRAP_ISYNC

Declaration

Source position: exec.pas line 61

const TRAP_ISYNC = $ff0f;


TRAP_LIB

Declaration

Source position: exec.pas line 57

const TRAP_LIB = $ff00;


TRAP_LIB_QUICK

Declaration

Source position: exec.pas line 58

const TRAP_LIB_QUICK = $ff01;


TRAP_LIBD0_D1

Declaration

Source position: exec.pas line 66

const TRAP_LIBD0_D1 = $ff14;


TRAP_LIBD0D1A0A1SR

Declaration

Source position: exec.pas line 69

const TRAP_LIBD0D1A0A1SR = $ff18;


TRAP_LIBD0D1SR

Declaration

Source position: exec.pas line 68

const TRAP_LIBD0D1SR = $ff17;


TRAP_LIBNR

Declaration

Source position: exec.pas line 59

const TRAP_LIBNR = $ff05;


TRAP_LIBNR_QUICK

Declaration

Source position: exec.pas line 60

const TRAP_LIBNR_QUICK = $ff06;


TRAP_LIBRESTORE

Declaration

Source position: exec.pas line 67

const TRAP_LIBRESTORE = $ff15;


TRAP_LIBSR

Declaration

Source position: exec.pas line 64

const TRAP_LIBSR = $ff12;


TRAP_LIBSRNR

Declaration

Source position: exec.pas line 65

const TRAP_LIBSRNR = $ff13;


TRAP_MASK

Declaration

Source position: exec.pas line 55

const TRAP_MASK = $00ff;


TRAP_SYNC

Declaration

Source position: exec.pas line 62

const TRAP_SYNC = $ff10;


TResident

Declaration

Source position: exec.pas line 238

type TResident = packed record
rt_MatchWord: Word; | smallint to match on RTC_MATCHWORD
rt_MatchTag: PResident; | pointer to the above
rt_EndSkip: Pointer; | address to continue scan
rt_Flags: Byte; | various tag flags (RTF_*)
rt_Version: Byte; | release version number
rt_Type: Byte; | type of module (NT_mumble)
rt_Pri: ShortInt; | initialization priority
rt_Name: PChar; | pointer to node name
rt_IdString: PChar; | pointer to ident string
rt_Init: Pointer; | pointer to init code
rt_Revision: Word; |
rt_Tags: Pointer; |
end;

Description

FindResident InitResident


TS_ADDED

Task State for tc_State Task is currently inserted in List.

Declaration

Source position: exec.pas line 557

const TS_ADDED = 1;


TS_EXCEPT

Task State for tc_State Task gets no CPU time.

Declaration

Source position: exec.pas line 561

const TS_EXCEPT = 5;


TS_INVALID

Task State for tc_State Invalid Task.

Declaration

Source position: exec.pas line 556

const TS_INVALID = 0;


TS_READY

Task State for tc_State Task is ready to work.

Declaration

Source position: exec.pas line 559

const TS_READY = 3;


TS_REMOVED

Task State for tc_State Task is removed at the moment.

Declaration

Source position: exec.pas line 562

const TS_REMOVED = 6;


TS_RUN

Task State for tc_State Task is running.

Declaration

Source position: exec.pas line 558

const TS_RUN = 2;


TS_WAIT

Task State for tc_State Task is waiting for a signal.

Declaration

Source position: exec.pas line 560

const TS_WAIT = 4;


TSemaphoreMessage

Declaration

Source position: exec.pas line 1029

type TSemaphoreMessage = packed record

  ssm_Message: TMessage;

  ssm_Semaphore: PSignalSemaphore;

end;


TSemaphoreRequest

This is the structure used to request a signal semaphore

Declaration

Source position: exec.pas line 1013

type TSemaphoreRequest = packed record

  sr_Link: TMinNode;

  sr_Waiter: PTask;

end;


TSignalSemaphore

Declaration

Source position: exec.pas line 1019

type TSignalSemaphore = packed record

  ss_Link: TNode;

  ss_NestCount: SmallInt;

  ss_WaitQueue: TMinList;

  ss_MultipleLink: TSemaphoreRequest;

  ss_Owner: PTask;

  ss_QueueCount: SmallInt;

end;


TSoftIntList

For EXEC use ONLY!

Declaration

Source position: exec.pas line 992

type TSoftIntList = packed record

  sh_List: TList;

  sh_Pad: Word;

end;

See also

TExecBase


TStackSwapStruct

Stack swap structure as passed to StackSwap

Declaration

Source position: exec.pas line 606

type TStackSwapStruct = packed record
stk_Lower: Pointer; | Lowest byte of stack
stk_Upper: LongWord; | Upper end of stack (size + Lowest)
stk_Pointer: Pointer; | Stack pointer at switch point
end;


TTask

Every Amiga Task has one of these Task structures associated with it. To find yours, use FindTask(nil). Amiga processes tack a few more values on to the end of this structure, which is the difference between Tasks and Processes.

Declaration

Source position: exec.pas line 395

type TTask = packed record
tc_Node: TNode; | Node for connecting several tasks.
tc_Flags: Byte; | Task flags (TF_*)
tc_State: Byte; | Task status (TS_*)
tc_IDNestCnt: ShortInt; | Number of suppressed Interrupts
tc_TDNestCnt: ShortInt; | Number of suppressed Tasks
tc_SigAlloc: LongWord; | Signals reserved for this Task
tc_SigWait: LongWord; | Signals, the task wait for.
tc_SigRecvd: LongWord; | Signals, the task recieved
tc_SigExcept: LongWord; | Signals, which fires Exceptions
tc_ETask: PETask; |
tc_ExceptData: Pointer; | Pointer to exception data.
tc_ExceptCode: Pointer; | Pointer to exception code
tc_TrapData: Pointer; | Pointer to trap data.
tc_TrapCode: Pointer; | Pointer to trap code
tc_SPReg: Pointer; | Pointer to Stack of Task
tc_SPLower: Pointer; | Lower border of stack.
tc_SPUpper: Pointer; | Upper border of stack + 2
tc_Switch: Pointer; | Pointer to switch code (remove task from CPU)
tc_Launch: Pointer; | Pointer to switch code (put task to CPU)
tc_MemEntry: TList; | Pointer to memory the task uses.
tc_UserData: Pointer; | Pointer for userdata.
end;

See also

FindTask | Find task by name get own task
AddTask | Add a Task to the System
RemTask | Remove a task from the system
SetTaskPri | Get and set the priority of a task
Signal | Signal a task


TTaskFrame68k

Declaration

Source position: exec.pas line 714

type TTaskFrame68k = packed record

  PC: Pointer;

  SR: Word;

  Xn: array [0..14] of LongWord;

end;


TTaskInitExtension

Declaration

Source position: exec.pas line 490

type TTaskInitExtension = packed record

  Trap: Word;

  Extension: Word;

  Tags: Pointer;

end;


TTaskTrapMessage

Declaration

Source position: exec.pas line 478

type TTaskTrapMessage = packed record

  Message: TMessage;

  Task: TTask;

  Version: LongWord;

  TType: LongWord;

  DAR: LongWord;

  DSISR: LongWord;

end;


TTaskTrapMessage_68k

Declaration

Source position: exec.pas line 586

type TTaskTrapMessage_68k = packed record

  Message: TMessage;

  Task: TTask;

  Version: LongWord;

  TType: LongWord;

  Format: LongWord;

  Address: Pointer;

  FLSW: LongWord;

  MyEmulHandle: PEmulHandle;

end;


TUnit

Declaration

Source position: exec.pas line 1304

type TUnit = packed record
unit_MsgPort: TMsgPort; | Pointer to message port for unprocessed messages
unit_flags: Byte; | Flags of Unit (UNITF_*)
unit_pad: Byte; | Padding byte
unit_OpenCnt: Word; | Number of open Requests
end;


UBYTE

unsigned 8-Bit Value

Declaration

Source position: exec.pas line 37

type UBYTE = Byte;


ULONG

unsigned 32-Bit integer value

Declaration

Source position: exec.pas line 27

type ULONG = LongWord;


UNITF_ACTIVE

tUnit is accessable

Declaration

Source position: exec.pas line 1313

const UNITF_ACTIVE = 1 shl 0;


UNITF_INTASK

tUnit is currently working

Declaration

Source position: exec.pas line 1314

const UNITF_INTASK = 1 shl 1;


UWORD

unsigned 16-Bit Value

Declaration

Source position: exec.pas line 33

type UWORD = Word;


VERSION_ALERTMESSAGE

Declaration

Source position: exec.pas line 969

const VERSION_ALERTMESSAGE = 0;


VERSION_TASKTRAPMESSAGE

Declaration

Source position: exec.pas line 599

const VERSION_TASKTRAPMESSAGE = $0;


VERSION_TASKTRAPMESSAGE_68k

Declaration

Source position: exec.pas line 598

const VERSION_TASKTRAPMESSAGE_68k = $0;


WORDBITS

Declaration

Source position: exec.pas line 34

type WORDBITS = Word;


WSTRPTR

Declaration

Source position: exec.pas line 26

type WSTRPTR = PWideChar;


ARROWIDCMP

Declaration

Source position: gadtools.pas line 56

const ARROWIDCMP = IDCMP_GADGETUP + IDCMP_GADGETDOWN + IDCMP_INTUITICKS + IDCMP_MOUSEBUTTONS;


BBFT_BUTTON

Declaration

Source position: gadtools.pas line 380

const BBFT_BUTTON = 1;


BBFT_ICONDROPBOX

Declaration

Source position: gadtools.pas line 382

const BBFT_ICONDROPBOX = 3;


BBFT_RIDGE

Declaration

Source position: gadtools.pas line 381

const BBFT_RIDGE = 2;


BUTTON_KIND

Declaration

Source position: gadtools.pas line 33

const BUTTON_KIND = 1;


BUTTONIDCMP

Declaration

Source position: gadtools.pas line 59

const BUTTONIDCMP = IDCMP_GADGETUP;


CHECKBOX_HEIGHT

Declaration

Source position: gadtools.pas line 220

const CHECKBOX_HEIGHT = 11;


CHECKBOX_KIND

Declaration

Source position: gadtools.pas line 34

const CHECKBOX_KIND = 2;


CHECKBOX_WIDTH

Declaration

Source position: gadtools.pas line 219

const CHECKBOX_WIDTH = 26;


CHECKBOXIDCMP

Declaration

Source position: gadtools.pas line 60

const CHECKBOXIDCMP = IDCMP_GADGETUP;


CYCLE_KIND

Declaration

Source position: gadtools.pas line 39

const CYCLE_KIND = 7;


CYCLEIDCMP

Declaration

Source position: gadtools.pas line 67

const CYCLEIDCMP = IDCMP_GADGETUP;


GADTOOLBIT

Declaration

Source position: gadtools.pas line 404

const GADTOOLBIT = $8000;


GADTOOLMASK

Declaration

Source position: gadtools.pas line 406

const GADTOOLMASK = not GADTOOLBIT;


GadToolsBase

Declaration

Source position: gadtools.pas line 438

var GadToolsBase: PLibrary = Nil;


GADTOOLSNAME

Declaration

Source position: gadtools.pas line 49

const GADTOOLSNAME: PChar = 'gadtools.library';


GENERIC_KIND

Declaration

Source position: gadtools.pas line 32

const GENERIC_KIND = 0;


GT_Private0

Declaration

Source position: gadtools.pas line 234

const GT_Private0 = GT_TagBase + 3;


GT_Reserved0

Declaration

Source position: gadtools.pas line 296

const GT_Reserved0 = GT_TagBase + 55;


GT_Reserved1

Declaration

Source position: gadtools.pas line 297

const GT_Reserved1 = GT_TagBase + 56;


GT_TagBase

Declaration

Source position: gadtools.pas line 229

const GT_TagBase = TAG_USER + $80000;


GT_Underscore

Declaration

Source position: gadtools.pas line 318

const GT_Underscore = GT_TagBase + 64;


GT_VisualInfo

Declaration

Source position: gadtools.pas line 289

const GT_VisualInfo = GT_TagBase + 52;


GTBB_FrameType

Declaration

Source position: gadtools.pas line 349

const GTBB_FrameType = GT_TagBase + 77;


GTBB_Recessed

Declaration

Source position: gadtools.pas line 287

const GTBB_Recessed = GT_TagBase + 51;


GTCB_Checked

Declaration

Source position: gadtools.pas line 236

const GTCB_Checked = GT_TagBase + 4;


GTCB_Scaled

Declaration

Source position: gadtools.pas line 332

const GTCB_Scaled = GT_TagBase + 68;


GTCY_Active

Declaration

Source position: gadtools.pas line 254

const GTCY_Active = GT_TagBase + 15;


GTCY_Labels

Declaration

Source position: gadtools.pas line 253

const GTCY_Labels = GT_TagBase + 14;


GTIN_MaxChars

Declaration

Source position: gadtools.pas line 282

const GTIN_MaxChars = GT_TagBase + 48;


GTIN_Number

Declaration

Source position: gadtools.pas line 281

const GTIN_Number = GT_TagBase + 47;


GTJ_CENTER

Declaration

Source position: gadtools.pas line 375

const GTJ_CENTER = 2;


GTJ_LEFT

Declaration

Source position: gadtools.pas line 373

const GTJ_LEFT = 0;


GTJ_RIGHT

Declaration

Source position: gadtools.pas line 374

const GTJ_RIGHT = 1;


GTLV_CallBack

Declaration

Source position: gadtools.pas line 363

const GTLV_CallBack = GT_TagBase + 83;


GTLV_ItemHeight

Declaration

Source position: gadtools.pas line 356

const GTLV_ItemHeight = GT_TagBase + 79;


GTLV_Labels

Declaration

Source position: gadtools.pas line 239

const GTLV_Labels = GT_TagBase + 6;


GTLV_MakeVisible

Declaration

Source position: gadtools.pas line 355

const GTLV_MakeVisible = GT_TagBase + 78;


GTLV_MaxPen

Declaration

Source position: gadtools.pas line 364

const GTLV_MaxPen = GT_TagBase + 84;


GTLV_ReadOnly

Declaration

Source position: gadtools.pas line 240

const GTLV_ReadOnly = GT_TagBase + 7;


GTLV_ScrollWidth

Declaration

Source position: gadtools.pas line 242

const GTLV_ScrollWidth = GT_TagBase + 8;


GTLV_Selected

Declaration

Source position: gadtools.pas line 294

const GTLV_Selected = GT_TagBase + 54;


GTLV_ShowSelected

Declaration

Source position: gadtools.pas line 291

const GTLV_ShowSelected = GT_TagBase + 53;


GTLV_Top

Declaration

Source position: gadtools.pas line 238

const GTLV_Top = GT_TagBase + 5;


GTMENU_INVALID

Declaration

Source position: gadtools.pas line 203

const GTMENU_INVALID = $00000002;


GTMENU_NOMEM

Declaration

Source position: gadtools.pas line 204

const GTMENU_NOMEM = $00000003;


GTMENU_TRIMMED

Declaration

Source position: gadtools.pas line 200

const GTMENU_TRIMMED = $00000001;


GTMN_AmigaKey

Declaration

Source position: gadtools.pas line 324

const GTMN_AmigaKey = GT_TagBase + 66;


GTMN_Checkmark

Declaration

Source position: gadtools.pas line 323

const GTMN_Checkmark = GT_TagBase + 65;


GTMN_FrontPen

Declaration

Source position: gadtools.pas line 285

const GTMN_FrontPen = GT_TagBase + 50;


GTMN_FullMenu

Declaration

Source position: gadtools.pas line 314

const GTMN_FullMenu = GT_TagBase + 62;


GTMN_Menu

Declaration

Source position: gadtools.pas line 307

const GTMN_Menu = GT_TagBase + 60;


GTMN_NewLookMenus

Declaration

Source position: gadtools.pas line 325

const GTMN_NewLookMenus = GT_TagBase + 67;


GTMN_SecondaryError

Declaration

Source position: gadtools.pas line 316

const GTMN_SecondaryError = GT_TagBase + 63;


GTMN_TextAttr

Declaration

Source position: gadtools.pas line 284

const GTMN_TextAttr = GT_TagBase + 49;


GTMX_Active

Declaration

Source position: gadtools.pas line 245

const GTMX_Active = GT_TagBase + 10;


GTMX_Labels

Declaration

Source position: gadtools.pas line 244

const GTMX_Labels = GT_TagBase + 9;


GTMX_Scaled

Declaration

Source position: gadtools.pas line 333

const GTMX_Scaled = GT_TagBase + 69;


GTMX_Spacing

Declaration

Source position: gadtools.pas line 309

const GTMX_Spacing = GT_TagBase + 61;


GTMX_TitlePlace

Declaration

Source position: gadtools.pas line 337

const GTMX_TitlePlace = GT_TagBase + 71;


GTNM_BackPen

Declaration

Source position: gadtools.pas line 344

const GTNM_BackPen = GT_TagBase + 73;


GTNM_Border

Declaration

Source position: gadtools.pas line 301

const GTNM_Border = GT_TagBase + 58;


GTNM_Clipped

Declaration

Source position: gadtools.pas line 367

const GTNM_Clipped = GT_TagBase + 85;


GTNM_Format

Declaration

Source position: gadtools.pas line 346

const GTNM_Format = GT_TagBase + 75;


GTNM_FrontPen

Declaration

Source position: gadtools.pas line 343

const GTNM_FrontPen = GT_TagBase + 72;


GTNM_Justification

Declaration

Source position: gadtools.pas line 345

const GTNM_Justification = GT_TagBase + 74;


GTNM_MaxNumberLen

Declaration

Source position: gadtools.pas line 347

const GTNM_MaxNumberLen = GT_TagBase + 76;


GTNM_Number

Declaration

Source position: gadtools.pas line 251

const GTNM_Number = GT_TagBase + 13;


GTNW_Active

Declaration

Source position: gadtools.pas line 397

const GTNW_Active = GTCY_Active;


GTNW_Labels

Declaration

Source position: gadtools.pas line 396

const GTNW_Labels = GTCY_Labels;


GTPA_Color

Declaration

Source position: gadtools.pas line 257

const GTPA_Color = GT_TagBase + 17;


GTPA_ColorOffset

Declaration

Source position: gadtools.pas line 258

const GTPA_ColorOffset = GT_TagBase + 18;


GTPA_ColorTable

Declaration

Source position: gadtools.pas line 361

const GTPA_ColorTable = GT_TagBase + 82;


GTPA_Depth

Declaration

Source position: gadtools.pas line 256

const GTPA_Depth = GT_TagBase + 16;


GTPA_IndicatorHeight

Declaration

Source position: gadtools.pas line 260

const GTPA_IndicatorHeight = GT_TagBase + 20;


GTPA_IndicatorWidth

Declaration

Source position: gadtools.pas line 259

const GTPA_IndicatorWidth = GT_TagBase + 19;


GTPA_NumColors

Declaration

Source position: gadtools.pas line 335

const GTPA_NumColors = GT_TagBase + 70;


GTSC_Arrows

Declaration

Source position: gadtools.pas line 304

const GTSC_Arrows = GT_TagBase + 59;


GTSC_Overlap

Declaration

Source position: gadtools.pas line 265

const GTSC_Overlap = GT_TagBase + 24;


GTSC_Top

Declaration

Source position: gadtools.pas line 262

const GTSC_Top = GT_TagBase + 21;


GTSC_Total

Declaration

Source position: gadtools.pas line 263

const GTSC_Total = GT_TagBase + 22;


GTSC_Visible

Declaration

Source position: gadtools.pas line 264

const GTSC_Visible = GT_TagBase + 23;


GTSL_DispFunc

Declaration

Source position: gadtools.pas line 275

const GTSL_DispFunc = GT_TagBase + 44;


GTSL_Justification

Declaration

Source position: gadtools.pas line 359

const GTSL_Justification = GT_TagBase + 81;


GTSL_Level

Declaration

Source position: gadtools.pas line 271

const GTSL_Level = GT_TagBase + 40;


GTSL_LevelFormat

Declaration

Source position: gadtools.pas line 273

const GTSL_LevelFormat = GT_TagBase + 42;


GTSL_LevelPlace

Declaration

Source position: gadtools.pas line 274

const GTSL_LevelPlace = GT_TagBase + 43;


GTSL_Max

Declaration

Source position: gadtools.pas line 270

const GTSL_Max = GT_TagBase + 39;


GTSL_MaxLevelLen

Declaration

Source position: gadtools.pas line 272

const GTSL_MaxLevelLen = GT_TagBase + 41;


GTSL_MaxPixelLen

Declaration

Source position: gadtools.pas line 358

const GTSL_MaxPixelLen = GT_TagBase + 80;


GTSL_Min

Declaration

Source position: gadtools.pas line 269

const GTSL_Min = GT_TagBase + 38;


GTST_MaxChars

Declaration

Source position: gadtools.pas line 279

const GTST_MaxChars = GT_TagBase + 46;


GTST_String

Declaration

Source position: gadtools.pas line 278

const GTST_String = GT_TagBase + 45;


GTTX_BackPen

Declaration

Source position: gadtools.pas line 340

const GTTX_BackPen = GT_TagBase + 73;


GTTX_Border

Declaration

Source position: gadtools.pas line 299

const GTTX_Border = GT_TagBase + 57;


GTTX_Clipped

Declaration

Source position: gadtools.pas line 366

const GTTX_Clipped = GT_TagBase + 85;


GTTX_CopyText

Declaration

Source position: gadtools.pas line 248

const GTTX_CopyText = GT_TagBase + 12;


GTTX_FrontPen

Declaration

Source position: gadtools.pas line 339

const GTTX_FrontPen = GT_TagBase + 72;


GTTX_Justification

Declaration

Source position: gadtools.pas line 341

const GTTX_Justification = GT_TagBase + 74;


GTTX_Text

Declaration

Source position: gadtools.pas line 247

const GTTX_Text = GT_TagBase + 11;


GTVI_NewWindow

Declaration

Source position: gadtools.pas line 231

const GTVI_NewWindow = GT_TagBase + 1;


GTVI_NWTags

Declaration

Source position: gadtools.pas line 232

const GTVI_NWTags = GT_TagBase + 2;


IM_ITEM

Declaration

Source position: gadtools.pas line 140

const IM_ITEM = NM_ITEM or MENU_IMAGE;


IM_SUB

Declaration

Source position: gadtools.pas line 141

const IM_SUB = NM_SUB or MENU_IMAGE;


Reference for unit 'gadtools'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
intuition, | Screen and Window handling routines of intuition.library
agraphics, | Native Amiga graphic functions (graphics.library)
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'gadtools': Constants

ARROWIDCMP

BBFT_BUTTON

BBFT_ICONDROPBOX

BBFT_RIDGE

BUTTONIDCMP

BUTTON_KIND

CHECKBOXIDCMP

CHECKBOX_HEIGHT

CHECKBOX_KIND

CHECKBOX_WIDTH

CYCLEIDCMP

CYCLE_KIND

GADTOOLBIT

GADTOOLMASK

GADTOOLSNAME

GENERIC_KIND

GTBB_FrameType

GTBB_Recessed

GTCB_Checked

GTCB_Scaled

GTCY_Active

GTCY_Labels

GTIN_MaxChars

GTIN_Number

GTJ_CENTER

GTJ_LEFT

GTJ_RIGHT

GTLV_CallBack

GTLV_ItemHeight

GTLV_Labels

GTLV_MakeVisible

GTLV_MaxPen

GTLV_ReadOnly

GTLV_ScrollWidth

GTLV_Selected

GTLV_ShowSelected

GTLV_Top

GTMENU_INVALID

GTMENU_NOMEM

GTMENU_TRIMMED

GTMN_AmigaKey

GTMN_Checkmark

GTMN_FrontPen

GTMN_FullMenu

GTMN_Menu

GTMN_NewLookMenus

GTMN_SecondaryError

GTMN_TextAttr

GTMX_Active

GTMX_Labels

GTMX_Scaled

GTMX_Spacing

GTMX_TitlePlace

GTNM_BackPen

GTNM_Border

GTNM_Clipped

GTNM_Format

GTNM_FrontPen

GTNM_Justification

GTNM_MaxNumberLen

GTNM_Number

GTNW_Active

GTNW_Labels

GTPA_Color

GTPA_ColorOffset

GTPA_ColorTable

GTPA_Depth

GTPA_IndicatorHeight

GTPA_IndicatorWidth

GTPA_NumColors

GTSC_Arrows

GTSC_Overlap

GTSC_Top

GTSC_Total

GTSC_Visible

GTSL_DispFunc

GTSL_Justification

GTSL_Level

GTSL_LevelFormat

GTSL_LevelPlace

GTSL_Max

GTSL_MaxLevelLen

GTSL_MaxPixelLen

GTSL_Min

GTST_MaxChars

GTST_String

GTTX_BackPen

GTTX_Border

GTTX_Clipped

GTTX_CopyText

GTTX_FrontPen

GTTX_Justification

GTTX_Text

GTVI_NewWindow

GTVI_NWTags

GT_Private0

GT_Reserved0

GT_Reserved1

GT_TagBase

GT_Underscore

GT_VisualInfo

IM_ITEM

IM_SUB

INTEGERIDCMP

INTEGER_KIND

INTERHEIGHT

INTERWIDTH

LISTVIEWIDCMP

LISTVIEW_KIND

LVCB_OK

LVCB_UNKNOWN

LVR_NORMAL

LVR_NORMALDISABLED

LVR_SELECTED

LVR_SELECTEDDISABLED

LV_DRAW

MENU_IMAGE

MXIDCMP

MX_HEIGHT

MX_KIND

MX_WIDTH

NG_HIGHLABEL

NM_BARLABEL

NM_COMMANDSTRING

NM_END

NM_FLAGMASK

NM_FLAGMASK_V39

NM_IGNORE

NM_ITEM

NM_ITEMDISABLED

NM_MENUDISABLED

NM_SUB

NM_TITLE

NUMBERIDCMP

NUMBER_KIND

NUM_KINDS

NWAYIDCMP

NWAY_KIND

PALETTEIDCMP

PALETTE_KIND

PLACETEXT_ABOVE

PLACETEXT_BELOW

PLACETEXT_IN

PLACETEXT_LEFT

PLACETEXT_RIGHT

SCROLLERIDCMP

SCROLLER_KIND

SLIDERIDCMP

SLIDER_KIND

STRINGIDCMP

STRING_KIND

TEXTIDCMP

TEXT_KIND


Reference for unit 'gadtools': Types

pLVDrawMsg

pNewGadget

pNewMenu

tLVDrawMsg

tNewGadget

tNewMenu


INTEGER_KIND

Declaration

Source position: gadtools.pas line 35

const INTEGER_KIND = 3;


INTEGERIDCMP

Declaration

Source position: gadtools.pas line 61

const INTEGERIDCMP = IDCMP_GADGETUP;


INTERHEIGHT

Declaration

Source position: gadtools.pas line 388

const INTERHEIGHT = 4;


INTERWIDTH

Declaration

Source position: gadtools.pas line 387

const INTERWIDTH = 8;


LISTVIEW_KIND

Declaration

Source position: gadtools.pas line 36

const LISTVIEW_KIND = 4;


LISTVIEWIDCMP

Declaration

Source position: gadtools.pas line 62

const LISTVIEWIDCMP = IDCMP_GADGETUP + IDCMP_GADGETDOWN + IDCMP_MOUSEMOVE + ARROWIDCMP;


LV_DRAW

Declaration

Source position: gadtools.pas line 413

const LV_DRAW = $202;


Unit 'gadtools' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

LVCB_OK

Declaration

Source position: gadtools.pas line 416

const LVCB_OK = 0;


LVCB_UNKNOWN

Declaration

Source position: gadtools.pas line 417

const LVCB_UNKNOWN = 1;


LVR_NORMAL

Declaration

Source position: gadtools.pas line 420

const LVR_NORMAL = 0;


LVR_NORMALDISABLED

Declaration

Source position: gadtools.pas line 422

const LVR_NORMALDISABLED = 2;


LVR_SELECTED

Declaration

Source position: gadtools.pas line 421

const LVR_SELECTED = 1;


LVR_SELECTEDDISABLED

Declaration

Source position: gadtools.pas line 423

const LVR_SELECTEDDISABLED = 8;


MENU_IMAGE

Declaration

Source position: gadtools.pas line 126

const MENU_IMAGE = 128;


MX_HEIGHT

Declaration

Source position: gadtools.pas line 216

const MX_HEIGHT = 9;


Unit 'gadtools' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MX_KIND

Declaration

Source position: gadtools.pas line 37

const MX_KIND = 5;


MX_WIDTH

Declaration

Source position: gadtools.pas line 215

const MX_WIDTH = 17;


MXIDCMP

Declaration

Source position: gadtools.pas line 65

const MXIDCMP = IDCMP_GADGETDOWN;


NG_HIGHLABEL

Declaration

Source position: gadtools.pas line 107

const NG_HIGHLABEL = $0020;


NM_BARLABEL

Declaration

Source position: gadtools.pas line 158

const NM_BARLABEL = - 1;


NM_COMMANDSTRING

Declaration

Source position: gadtools.pas line 173

const NM_COMMANDSTRING = COMMSEQ;


Unit 'gadtools' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

NM_END

Declaration

Source position: gadtools.pas line 146

const NM_END = 0;


NM_FLAGMASK

Declaration

Source position: gadtools.pas line 180

const NM_FLAGMASK = not COMMSEQ or ITEMTEXT or HIGHFLAGS;


NM_FLAGMASK_V39

Declaration

Source position: gadtools.pas line 181

const NM_FLAGMASK_V39 = not ITEMTEXT or HIGHFLAGS;


NM_IGNORE

Declaration

Source position: gadtools.pas line 151

const NM_IGNORE = 64;


Unit 'gadtools' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

NM_ITEM

Declaration

Source position: gadtools.pas line 137

const NM_ITEM = 2;


NM_ITEMDISABLED

Declaration

Source position: gadtools.pas line 167

const NM_ITEMDISABLED = ITEMENABLED;


NM_MENUDISABLED

Declaration

Source position: gadtools.pas line 166

const NM_MENUDISABLED = MENUENABLED;


Unit 'gadtools' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

NM_SUB

Declaration

Source position: gadtools.pas line 138

const NM_SUB = 3;


NM_TITLE

Declaration

Source position: gadtools.pas line 136

const NM_TITLE = 1;


NUM_KINDS

Declaration

Source position: gadtools.pas line 47

const NUM_KINDS = 14;


NUMBER_KIND

Declaration

Source position: gadtools.pas line 38

const NUMBER_KIND = 6;


NUMBERIDCMP

Declaration

Source position: gadtools.pas line 66

const NUMBERIDCMP = 0;


NWAY_KIND

Declaration

Source position: gadtools.pas line 394

const NWAY_KIND = CYCLE_KIND;


NWAYIDCMP

Declaration

Source position: gadtools.pas line 395

const NWAYIDCMP = CYCLEIDCMP;


PALETTE_KIND

Declaration

Source position: gadtools.pas line 40

const PALETTE_KIND = 8;


PALETTEIDCMP

Declaration

Source position: gadtools.pas line 68

const PALETTEIDCMP = IDCMP_GADGETUP;


PLACETEXT_ABOVE

Declaration

Source position: gadtools.pas line 103

const PLACETEXT_ABOVE = $0004;


PLACETEXT_BELOW

Declaration

Source position: gadtools.pas line 104

const PLACETEXT_BELOW = $0008;


PLACETEXT_IN

Declaration

Source position: gadtools.pas line 105

const PLACETEXT_IN = $0010;


PLACETEXT_LEFT

Declaration

Source position: gadtools.pas line 101

const PLACETEXT_LEFT = $0001;


PLACETEXT_RIGHT

Declaration

Source position: gadtools.pas line 102

const PLACETEXT_RIGHT = $0002;


pLVDrawMsg

Declaration

Source position: gadtools.pas line 427

type pLVDrawMsg = ^tLVDrawMsg;


pNewGadget

Declaration

Source position: gadtools.pas line 83

type pNewGadget = ^tNewGadget;


pNewMenu

Declaration

Source position: gadtools.pas line 114

type pNewMenu = ^tNewMenu;


SCROLLER_KIND

Declaration

Source position: gadtools.pas line 41

const SCROLLER_KIND = 9;


SCROLLERIDCMP

Declaration

Source position: gadtools.pas line 71

const SCROLLERIDCMP = IDCMP_GADGETUP + IDCMP_GADGETDOWN + IDCMP_MOUSEMOVE;


SLIDER_KIND

Declaration

Source position: gadtools.pas line 43

const SLIDER_KIND = 11;


SLIDERIDCMP

Declaration

Source position: gadtools.pas line 72

const SLIDERIDCMP = IDCMP_GADGETUP + IDCMP_GADGETDOWN + IDCMP_MOUSEMOVE;


STRING_KIND

Declaration

Source position: gadtools.pas line 44

const STRING_KIND = 12;


STRINGIDCMP

Declaration

Source position: gadtools.pas line 73

const STRINGIDCMP = IDCMP_GADGETUP;


TEXT_KIND

Declaration

Source position: gadtools.pas line 45

const TEXT_KIND = 13;


TEXTIDCMP

Declaration

Source position: gadtools.pas line 75

const TEXTIDCMP = 0;


tLVDrawMsg

Declaration

Source position: gadtools.pas line 428

type tLVDrawMsg = record

  lvdm_MethodID: LongWord;

  lvdm_RastPort: PRastPort;

  lvdm_DrawInfo: PDrawInfo;

  lvdm_Bounds: TRectangle;

  lvdm_State: LongWord;

end;


tNewGadget

Declaration

Source position: gadtools.pas line 84

type tNewGadget = record

  ng_LeftEdge: SmallInt;

  ng_TopEdge: SmallInt;

  ng_Width: SmallInt;

  ng_Height: SmallInt;

  ng_GadgetText: PChar;

  ng_TextAttr: PTextAttr;

  ng_GadgetID: Word;

  ng_Flags: LongWord;

  ng_VisualInfo: Pointer;

  ng_UserData: Pointer;

end;


tNewMenu

Declaration

Source position: gadtools.pas line 115

type tNewMenu = record

  nm_Type: Byte;

  nm_Label: PChar;

  nm_CommKey: PChar;

  nm_Flags: Word;

  nm_MutualExclude: LongInt;

  nm_UserData: Pointer;

end;


Get9Base

Declaration

Source position: get9.pas line 25

var Get9Base: Pointer = Nil;


GET9NAME

Declaration

Source position: get9.pas line 28

const GET9NAME: PChar = 'get9.library';


Reference for unit 'get9'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Unit 'get9' | Package
[Overview][Constants][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'get9': Constants

GET9NAME


A_OR_B

Declaration

Source position: hardware.pas line 104

const A_OR_B = ABC or ANBC or NABC or ABNC or ANBNC or NABNC;


A_OR_C

Declaration

Source position: hardware.pas line 105

const A_OR_C = ABC or NABC or ABNC or ANBC or NANBC or ANBNC;


A_TO_D

Declaration

Source position: hardware.pas line 107

const A_TO_D = ABC or ANBC or ABNC or ANBNC;


A_XOR_C

Declaration

Source position: hardware.pas line 106

const A_XOR_C = NABC or ABNC or NANBC or ANBNC;


ABC

Declaration

Source position: hardware.pas line 94

const ABC = $80;


ABNC

Declaration

Source position: hardware.pas line 95

const ABNC = $40;


ADKB_FAST

Declaration

Source position: hardware.pas line 40

const ADKB_FAST = 8;


ADKB_MFMPREC

Declaration

Source position: hardware.pas line 36

const ADKB_MFMPREC = 12;


ADKB_MSBSYNC

Declaration

Source position: hardware.pas line 39

const ADKB_MSBSYNC = 9;


ADKB_PRECOMP0

Declaration

Source position: hardware.pas line 35

const ADKB_PRECOMP0 = 13;


ADKB_PRECOMP1

Declaration

Source position: hardware.pas line 34

const ADKB_PRECOMP1 = 14;


ADKB_SETCLR

Declaration

Source position: hardware.pas line 33

const ADKB_SETCLR = 15;


ADKB_UARTBRK

Declaration

Source position: hardware.pas line 37

const ADKB_UARTBRK = 11;


ADKB_USE0P1

Declaration

Source position: hardware.pas line 44

const ADKB_USE0P1 = 4;


ADKB_USE0V1

Declaration

Source position: hardware.pas line 48

const ADKB_USE0V1 = 0;


ADKB_USE1P2

Declaration

Source position: hardware.pas line 43

const ADKB_USE1P2 = 5;


ADKB_USE1V2

Declaration

Source position: hardware.pas line 47

const ADKB_USE1V2 = 1;


ADKB_USE2P3

Declaration

Source position: hardware.pas line 42

const ADKB_USE2P3 = 6;


ADKB_USE2V3

Declaration

Source position: hardware.pas line 46

const ADKB_USE2V3 = 2;


ADKB_USE3PN

Declaration

Source position: hardware.pas line 41

const ADKB_USE3PN = 7;


ADKB_USE3VN

Declaration

Source position: hardware.pas line 45

const ADKB_USE3VN = 3;


ADKB_WORDSYNC

Declaration

Source position: hardware.pas line 38

const ADKB_WORDSYNC = 10;


ADKF_FAST

Declaration

Source position: hardware.pas line 58

const ADKF_FAST = 1 shl ADKB_FAST;


ADKF_MFMPREC

Declaration

Source position: hardware.pas line 54

const ADKF_MFMPREC = 1 shl ADKB_MFMPREC;


ADKF_MSBSYNC

Declaration

Source position: hardware.pas line 57

const ADKF_MSBSYNC = 1 shl ADKB_MSBSYNC;


ADKF_PRE000NS

Declaration

Source position: hardware.pas line 69

const ADKF_PRE000NS = 0;


ADKF_PRE140NS

Declaration

Source position: hardware.pas line 70

const ADKF_PRE140NS = ADKF_PRECOMP0;


ADKF_PRE280NS

Declaration

Source position: hardware.pas line 71

const ADKF_PRE280NS = ADKF_PRECOMP1;


ADKF_PRE560NS

Declaration

Source position: hardware.pas line 72

const ADKF_PRE560NS = ADKF_PRECOMP0 or ADKF_PRECOMP1;


ADKF_PRECOMP0

Declaration

Source position: hardware.pas line 53

const ADKF_PRECOMP0 = 1 shl ADKB_PRECOMP0;


ADKF_PRECOMP1

Declaration

Source position: hardware.pas line 52

const ADKF_PRECOMP1 = 1 shl ADKB_PRECOMP1;


ADKF_SETCLR

Declaration

Source position: hardware.pas line 51

const ADKF_SETCLR = 1 shl ADKB_SETCLR;


ADKF_UARTBRK

Declaration

Source position: hardware.pas line 55

const ADKF_UARTBRK = 1 shl ADKB_UARTBRK;


ADKF_USE0P1

Declaration

Source position: hardware.pas line 62

const ADKF_USE0P1 = 1 shl ADKB_USE0P1;


ADKF_USE0V1

Declaration

Source position: hardware.pas line 66

const ADKF_USE0V1 = 1 shl ADKB_USE0V1;


ADKF_USE1P2

Declaration

Source position: hardware.pas line 61

const ADKF_USE1P2 = 1 shl ADKB_USE1P2;


ADKF_USE1V2

Declaration

Source position: hardware.pas line 65

const ADKF_USE1V2 = 1 shl ADKB_USE1V2;


ADKF_USE2P3

Declaration

Source position: hardware.pas line 60

const ADKF_USE2P3 = 1 shl ADKB_USE2P3;


ADKF_USE2V3

Declaration

Source position: hardware.pas line 64

const ADKF_USE2V3 = 1 shl ADKB_USE2V3;


ADKF_USE3PN

Declaration

Source position: hardware.pas line 59

const ADKF_USE3PN = 1 shl ADKB_USE3PN;


ADKF_USE3VN

Declaration

Source position: hardware.pas line 63

const ADKF_USE3VN = 1 shl ADKB_USE3VN;


ADKF_WORDSYNC

Declaration

Source position: hardware.pas line 56

const ADKF_WORDSYNC = 1 shl ADKB_WORDSYNC;


ANBC

Declaration

Source position: hardware.pas line 96

const ANBC = $20;


ANBNC

Declaration

Source position: hardware.pas line 97

const ANBNC = $10;


ASHIFTSHIFT

Declaration

Source position: hardware.pas line 126

const ASHIFTSHIFT = 12;


AUL

Declaration

Source position: hardware.pas line 141

const AUL = $4;


BC0B_DEST

Declaration

Source position: hardware.pas line 110

const BC0B_DEST = 8;


BC0B_SRCA

Declaration

Source position: hardware.pas line 113

const BC0B_SRCA = 11;


BC0B_SRCB

Declaration

Source position: hardware.pas line 112

const BC0B_SRCB = 10;


BC0B_SRCC

Declaration

Source position: hardware.pas line 111

const BC0B_SRCC = 9;


BC0F_DEST

Declaration

Source position: hardware.pas line 114

const BC0F_DEST = 1 shl BC0B_DEST;


BC0F_SRCA

Declaration

Source position: hardware.pas line 117

const BC0F_SRCA = 1 shl BC0B_SRCA;


BC0F_SRCB

Declaration

Source position: hardware.pas line 116

const BC0F_SRCB = 1 shl BC0B_SRCB;


BC0F_SRCC

Declaration

Source position: hardware.pas line 115

const BC0F_SRCC = 1 shl BC0B_SRCC;


BC1F_DESC

Declaration

Source position: hardware.pas line 119

const BC1F_DESC = 2;


BLITREVERSE

Declaration

Source position: hardware.pas line 137

const BLITREVERSE = $2;


BPLCON2_ZDBPEN

Declaration

Source position: hardware.pas line 487

const BPLCON2_ZDBPEN = 1 shl 11;


BPLCON2_ZDBPSEL0

Declaration

Source position: hardware.pas line 488

const BPLCON2_ZDBPSEL0 = 1 shl 12;


BPLCON2_ZDBPSEL1

Declaration

Source position: hardware.pas line 489

const BPLCON2_ZDBPSEL1 = 1 shl 13;


BPLCON2_ZDBPSEL2

Declaration

Source position: hardware.pas line 490

const BPLCON2_ZDBPSEL2 = 1 shl 14;


BPLCON2_ZDCTEN

Declaration

Source position: hardware.pas line 486

const BPLCON2_ZDCTEN = 1 shl 10;


BPLCON3_BRDNBLNK

Declaration

Source position: hardware.pas line 496

const BPLCON3_BRDNBLNK = 1 shl 5;


BPLCON3_BRDNTRAN

Declaration

Source position: hardware.pas line 495

const BPLCON3_BRDNTRAN = 1 shl 4;


BPLCON3_EXTBLKZD

Declaration

Source position: hardware.pas line 493

const BPLCON3_EXTBLKZD = 1 shl 1;


BPLCON3_EXTBLNKEN

Declaration

Source position: hardware.pas line 492

const BPLCON3_EXTBLNKEN = 1 shl 0;


BPLCON3_ZDCLKEN

Declaration

Source position: hardware.pas line 494

const BPLCON3_ZDCLKEN = 1 shl 2;


BSHIFTSHIFT

Declaration

Source position: hardware.pas line 127

const BSHIFTSHIFT = 12;


CIAB_COMCD

Declaration

Source position: hardware.pas line 300

const CIAB_COMCD = 5;


CIAB_COMCTS

Declaration

Source position: hardware.pas line 301

const CIAB_COMCTS = 4;


CIAB_COMDSR

Declaration

Source position: hardware.pas line 302

const CIAB_COMDSR = 3;


CIAB_COMDTR

Declaration

Source position: hardware.pas line 298

const CIAB_COMDTR = 7;


CIAB_COMRTS

Declaration

Source position: hardware.pas line 299

const CIAB_COMRTS = 6;


CIAB_DSKCHANGE

Declaration

Source position: hardware.pas line 284

const CIAB_DSKCHANGE = 2;


CIAB_DSKDIREC

Declaration

Source position: hardware.pas line 323

const CIAB_DSKDIREC = 1;


CIAB_DSKMOTOR

Declaration

Source position: hardware.pas line 317

const CIAB_DSKMOTOR = 7;


CIAB_DSKPROT

Declaration

Source position: hardware.pas line 283

const CIAB_DSKPROT = 3;


CIAB_DSKRDY

Declaration

Source position: hardware.pas line 281

const CIAB_DSKRDY = 5;


CIAB_DSKSEL0

Declaration

Source position: hardware.pas line 321

const CIAB_DSKSEL0 = 3;


CIAB_DSKSEL1

Declaration

Source position: hardware.pas line 320

const CIAB_DSKSEL1 = 4;


CIAB_DSKSEL2

Declaration

Source position: hardware.pas line 319

const CIAB_DSKSEL2 = 5;


CIAB_DSKSEL3

Declaration

Source position: hardware.pas line 318

const CIAB_DSKSEL3 = 6;


CIAB_DSKSIDE

Declaration

Source position: hardware.pas line 322

const CIAB_DSKSIDE = 2;


CIAB_DSKSTEP

Declaration

Source position: hardware.pas line 324

const CIAB_DSKSTEP = 0;


CIAB_DSKTRACK0

Declaration

Source position: hardware.pas line 282

const CIAB_DSKTRACK0 = 4;


CIAB_GAMEPORT0

Declaration

Source position: hardware.pas line 280

const CIAB_GAMEPORT0 = 6;


CIAB_GAMEPORT1

Declaration

Source position: hardware.pas line 279

const CIAB_GAMEPORT1 = 7;


CIAB_LED

Declaration

Source position: hardware.pas line 285

const CIAB_LED = 1;


CIAB_OVERLAY

Declaration

Source position: hardware.pas line 286

const CIAB_OVERLAY = 0;


CIAB_PRTRBUSY

Declaration

Source position: hardware.pas line 305

const CIAB_PRTRBUSY = 0;


CIAB_PRTRPOUT

Declaration

Source position: hardware.pas line 304

const CIAB_PRTRPOUT = 1;


CIAB_PRTRSEL

Declaration

Source position: hardware.pas line 303

const CIAB_PRTRSEL = 2;


CIACRAB_INMODE

Declaration

Source position: hardware.pas line 240

const CIACRAB_INMODE = 5;


CIACRAB_LOAD

Declaration

Source position: hardware.pas line 239

const CIACRAB_LOAD = 4;


CIACRAB_OUTMODE

Declaration

Source position: hardware.pas line 237

const CIACRAB_OUTMODE = 2;


CIACRAB_PBON

Declaration

Source position: hardware.pas line 236

const CIACRAB_PBON = 1;


CIACRAB_RUNMODE

Declaration

Source position: hardware.pas line 238

const CIACRAB_RUNMODE = 3;


CIACRAB_SPMODE

Declaration

Source position: hardware.pas line 241

const CIACRAB_SPMODE = 6;


CIACRAB_START

Declaration

Source position: hardware.pas line 235

const CIACRAB_START = 0;


CIACRAB_TODIN

Declaration

Source position: hardware.pas line 242

const CIACRAB_TODIN = 7;


CIACRAF_INMODE

Declaration

Source position: hardware.pas line 249

const CIACRAF_INMODE = 1 shl CIACRAB_INMODE;


CIACRAF_LOAD

Declaration

Source position: hardware.pas line 248

const CIACRAF_LOAD = 1 shl CIACRAB_LOAD;


CIACRAF_OUTMODE

Declaration

Source position: hardware.pas line 246

const CIACRAF_OUTMODE = 1 shl CIACRAB_OUTMODE;


CIACRAF_PBON

Declaration

Source position: hardware.pas line 245

const CIACRAF_PBON = 1 shl CIACRAB_PBON;


CIACRAF_RUNMODE

Declaration

Source position: hardware.pas line 247

const CIACRAF_RUNMODE = 1 shl CIACRAB_RUNMODE;


CIACRAF_SPMODE

Declaration

Source position: hardware.pas line 250

const CIACRAF_SPMODE = 1 shl CIACRAB_SPMODE;


CIACRAF_START

Declaration

Source position: hardware.pas line 244

const CIACRAF_START = 1 shl CIACRAB_START;


CIACRAF_TODIN

Declaration

Source position: hardware.pas line 251

const CIACRAF_TODIN = 1 shl CIACRAB_TODIN;


CIACRBB_ALARM

Declaration

Source position: hardware.pas line 261

const CIACRBB_ALARM = 7;


CIACRBB_INMODE0

Declaration

Source position: hardware.pas line 259

const CIACRBB_INMODE0 = 5;


CIACRBB_INMODE1

Declaration

Source position: hardware.pas line 260

const CIACRBB_INMODE1 = 6;


CIACRBB_LOAD

Declaration

Source position: hardware.pas line 258

const CIACRBB_LOAD = 4;


CIACRBB_OUTMODE

Declaration

Source position: hardware.pas line 256

const CIACRBB_OUTMODE = 2;


CIACRBB_PBON

Declaration

Source position: hardware.pas line 255

const CIACRBB_PBON = 1;


CIACRBB_RUNMODE

Declaration

Source position: hardware.pas line 257

const CIACRBB_RUNMODE = 3;


CIACRBB_START

Declaration

Source position: hardware.pas line 254

const CIACRBB_START = 0;


CIACRBF_ALARM

Declaration

Source position: hardware.pas line 270

const CIACRBF_ALARM = 1 shl CIACRBB_ALARM;


CIACRBF_IN_CNT

Declaration

Source position: hardware.pas line 274

const CIACRBF_IN_CNT = CIACRBF_INMODE0;


CIACRBF_IN_CNT_TA

Declaration

Source position: hardware.pas line 276

const CIACRBF_IN_CNT_TA = CIACRBF_INMODE0 or CIACRBF_INMODE1;


CIACRBF_IN_PHI2

Declaration

Source position: hardware.pas line 273

const CIACRBF_IN_PHI2 = 0;


CIACRBF_IN_TA

Declaration

Source position: hardware.pas line 275

const CIACRBF_IN_TA = CIACRBF_INMODE1;


CIACRBF_INMODE0

Declaration

Source position: hardware.pas line 268

const CIACRBF_INMODE0 = 1 shl CIACRBB_INMODE0;


CIACRBF_INMODE1

Declaration

Source position: hardware.pas line 269

const CIACRBF_INMODE1 = 1 shl CIACRBB_INMODE1;


CIACRBF_LOAD

Declaration

Source position: hardware.pas line 267

const CIACRBF_LOAD = 1 shl CIACRBB_LOAD;


CIACRBF_OUTMODE

Declaration

Source position: hardware.pas line 265

const CIACRBF_OUTMODE = 1 shl CIACRBB_OUTMODE;


CIACRBF_PBON

Declaration

Source position: hardware.pas line 264

const CIACRBF_PBON = 1 shl CIACRBB_PBON;


CIACRBF_RUNMODE

Declaration

Source position: hardware.pas line 266

const CIACRBF_RUNMODE = 1 shl CIACRBB_RUNMODE;


CIACRBF_START

Declaration

Source position: hardware.pas line 263

const CIACRBF_START = 1 shl CIACRBB_START;


CIAF_COMCD

Declaration

Source position: hardware.pas line 309

const CIAF_COMCD = 1 shl CIAB_COMCD;


CIAF_COMCTS

Declaration

Source position: hardware.pas line 310

const CIAF_COMCTS = 1 shl CIAB_COMCTS;


CIAF_COMDSR

Declaration

Source position: hardware.pas line 311

const CIAF_COMDSR = 1 shl CIAB_COMDSR;


CIAF_COMDTR

Declaration

Source position: hardware.pas line 307

const CIAF_COMDTR = 1 shl CIAB_COMDTR;


CIAF_COMRTS

Declaration

Source position: hardware.pas line 308

const CIAF_COMRTS = 1 shl CIAB_COMRTS;


CIAF_DSKCHANGE

Declaration

Source position: hardware.pas line 293

const CIAF_DSKCHANGE = 1 shl CIAB_DSKCHANGE;


CIAF_DSKDIREC

Declaration

Source position: hardware.pas line 332

const CIAF_DSKDIREC = 1 shl CIAB_DSKDIREC;


CIAF_DSKMOTOR

Declaration

Source position: hardware.pas line 326

const CIAF_DSKMOTOR = 1 shl CIAB_DSKMOTOR;


CIAF_DSKPROT

Declaration

Source position: hardware.pas line 292

const CIAF_DSKPROT = 1 shl CIAB_DSKPROT;


CIAF_DSKRDY

Declaration

Source position: hardware.pas line 290

const CIAF_DSKRDY = 1 shl CIAB_DSKRDY;


CIAF_DSKSEL0

Declaration

Source position: hardware.pas line 330

const CIAF_DSKSEL0 = 1 shl CIAB_DSKSEL0;


CIAF_DSKSEL1

Declaration

Source position: hardware.pas line 329

const CIAF_DSKSEL1 = 1 shl CIAB_DSKSEL1;


CIAF_DSKSEL2

Declaration

Source position: hardware.pas line 328

const CIAF_DSKSEL2 = 1 shl CIAB_DSKSEL2;


CIAF_DSKSEL3

Declaration

Source position: hardware.pas line 327

const CIAF_DSKSEL3 = 1 shl CIAB_DSKSEL3;


CIAF_DSKSIDE

Declaration

Source position: hardware.pas line 331

const CIAF_DSKSIDE = 1 shl CIAB_DSKSIDE;


CIAF_DSKSTEP

Declaration

Source position: hardware.pas line 333

const CIAF_DSKSTEP = 1 shl CIAB_DSKSTEP;


CIAF_DSKTRACK0

Declaration

Source position: hardware.pas line 291

const CIAF_DSKTRACK0 = 1 shl CIAB_DSKTRACK0;


CIAF_GAMEPORT0

Declaration

Source position: hardware.pas line 289

const CIAF_GAMEPORT0 = 1 shl CIAB_GAMEPORT0;


CIAF_GAMEPORT1

Declaration

Source position: hardware.pas line 288

const CIAF_GAMEPORT1 = 1 shl CIAB_GAMEPORT1;


CIAF_LED

Declaration

Source position: hardware.pas line 294

const CIAF_LED = 1 shl CIAB_LED;


CIAF_OVERLAY

Declaration

Source position: hardware.pas line 295

const CIAF_OVERLAY = 1 shl CIAB_OVERLAY;


CIAF_PRTRBUSY

Declaration

Source position: hardware.pas line 314

const CIAF_PRTRBUSY = 1 shl CIAB_PRTRBUSY;


CIAF_PRTRPOUT

Declaration

Source position: hardware.pas line 313

const CIAF_PRTRPOUT = 1 shl CIAB_PRTRPOUT;


CIAF_PRTRSEL

Declaration

Source position: hardware.pas line 312

const CIAF_PRTRSEL = 1 shl CIAB_PRTRSEL;


CIAICRB_ALRM

Declaration

Source position: hardware.pas line 220

const CIAICRB_ALRM = 2;


CIAICRB_FLG

Declaration

Source position: hardware.pas line 222

const CIAICRB_FLG = 4;


CIAICRB_IR

Declaration

Source position: hardware.pas line 223

const CIAICRB_IR = 7;


CIAICRB_SETCLR

Declaration

Source position: hardware.pas line 224

const CIAICRB_SETCLR = 7;


CIAICRB_SP

Declaration

Source position: hardware.pas line 221

const CIAICRB_SP = 3;


CIAICRB_TA

Declaration

Source position: hardware.pas line 218

const CIAICRB_TA = 0;


CIAICRB_TB

Declaration

Source position: hardware.pas line 219

const CIAICRB_TB = 1;


CIAICRF_ALRM

Declaration

Source position: hardware.pas line 228

const CIAICRF_ALRM = 1 shl CIAICRB_ALRM;


CIAICRF_FLG

Declaration

Source position: hardware.pas line 230

const CIAICRF_FLG = 1 shl CIAICRB_FLG;


CIAICRF_IR

Declaration

Source position: hardware.pas line 231

const CIAICRF_IR = 1 shl CIAICRB_IR;


CIAICRF_SETCLR

Declaration

Source position: hardware.pas line 232

const CIAICRF_SETCLR = 1 shl CIAICRB_SETCLR;


CIAICRF_SP

Declaration

Source position: hardware.pas line 229

const CIAICRF_SP = 1 shl CIAICRB_SP;


CIAICRF_TA

Declaration

Source position: hardware.pas line 226

const CIAICRF_TA = 1 shl CIAICRB_TA;


CIAICRF_TB

Declaration

Source position: hardware.pas line 227

const CIAICRF_TB = 1 shl CIAICRB_TB;


CLEANME

Declaration

Source position: hardware.pas line 165

const CLEANME = CLEANUP;


CLEANUP

Declaration

Source position: hardware.pas line 164

const CLEANUP = $40;


CSBLANK

Declaration

Source position: hardware.pas line 479

const CSBLANK = $0008;


CSCBLANKEN

Declaration

Source position: hardware.pas line 472

const CSCBLANKEN = $0400;


CSYNCTRUE

Declaration

Source position: hardware.pas line 480

const CSYNCTRUE = $0004;


DEST

Declaration

Source position: hardware.pas line 121

const DEST = BC0F_DEST;


DISPLAYDUAL

Declaration

Source position: hardware.pas line 476

const DISPLAYDUAL = $0040;


DISPLAYPAL

Declaration

Source position: hardware.pas line 477

const DISPLAYPAL = $0020;


DMAB_AUD0

Declaration

Source position: hardware.pas line 505

const DMAB_AUD0 = 0;


DMAB_AUD1

Declaration

Source position: hardware.pas line 506

const DMAB_AUD1 = 1;


DMAB_AUD2

Declaration

Source position: hardware.pas line 507

const DMAB_AUD2 = 2;


DMAB_AUD3

Declaration

Source position: hardware.pas line 508

const DMAB_AUD3 = 3;


DMAB_BLITHOG

Declaration

Source position: hardware.pas line 515

const DMAB_BLITHOG = 10;


DMAB_BLITTER

Declaration

Source position: hardware.pas line 511

const DMAB_BLITTER = 6;


DMAB_BLTDONE

Declaration

Source position: hardware.pas line 517

const DMAB_BLTDONE = 14;


DMAB_BLTNZERO

Declaration

Source position: hardware.pas line 516

const DMAB_BLTNZERO = 13;


DMAB_COPPER

Declaration

Source position: hardware.pas line 512

const DMAB_COPPER = 7;


DMAB_DISK

Declaration

Source position: hardware.pas line 509

const DMAB_DISK = 4;


DMAB_MASTER

Declaration

Source position: hardware.pas line 514

const DMAB_MASTER = 9;


DMAB_RASTER

Declaration

Source position: hardware.pas line 513

const DMAB_RASTER = 8;


DMAB_SETCLR

Declaration

Source position: hardware.pas line 518

const DMAB_SETCLR = 15;


DMAB_SPRITE

Declaration

Source position: hardware.pas line 510

const DMAB_SPRITE = 5;


DMAF_ALL

Declaration

Source position: hardware.pas line 537

const DMAF_ALL = DMAF_AUD0 or DMAF_AUD1 or DMAF_AUD2 or DMAF_AUD3 or DMAF_DISK or DMAF_SPRITE or DMAF_BLITTER or DMAF_COPPER or DMAF_RASTER;


DMAF_AUD0

Declaration

Source position: hardware.pas line 520

const DMAF_AUD0 = 1 shl DMAB_AUD0;


DMAF_AUD1

Declaration

Source position: hardware.pas line 521

const DMAF_AUD1 = 1 shl DMAB_AUD1;


DMAF_AUD2

Declaration

Source position: hardware.pas line 522

const DMAF_AUD2 = 1 shl DMAB_AUD2;


DMAF_AUD3

Declaration

Source position: hardware.pas line 523

const DMAF_AUD3 = 1 shl DMAB_AUD3;


DMAF_AUDIO

Declaration

Source position: hardware.pas line 536

const DMAF_AUDIO = DMAF_AUD0 or DMAF_AUD1 or DMAF_AUD2 or DMAF_AUD3;


DMAF_BLITHOG

Declaration

Source position: hardware.pas line 530

const DMAF_BLITHOG = 1 shl DMAB_BLITHOG;


DMAF_BLITTER

Declaration

Source position: hardware.pas line 526

const DMAF_BLITTER = 1 shl DMAB_BLITTER;


DMAF_BLTDONE

Declaration

Source position: hardware.pas line 532

const DMAF_BLTDONE = 1 shl DMAB_BLTDONE;


DMAF_BLTNZERO

Declaration

Source position: hardware.pas line 531

const DMAF_BLTNZERO = 1 shl DMAB_BLTNZERO;


DMAF_COPPER

Declaration

Source position: hardware.pas line 527

const DMAF_COPPER = 1 shl DMAB_COPPER;


DMAF_DISK

Declaration

Source position: hardware.pas line 524

const DMAF_DISK = 1 shl DMAB_DISK;


DMAF_MASTER

Declaration

Source position: hardware.pas line 529

const DMAF_MASTER = 1 shl DMAB_MASTER;


DMAF_RASTER

Declaration

Source position: hardware.pas line 528

const DMAF_RASTER = 1 shl DMAB_RASTER;


DMAF_SETCLR

Declaration

Source position: hardware.pas line 533

const DMAF_SETCLR = 1 shl DMAB_SETCLR;


DMAF_SPRITE

Declaration

Source position: hardware.pas line 525

const DMAF_SPRITE = 1 shl DMAB_SPRITE;


FILL_CARRYIN

Declaration

Source position: hardware.pas line 133

const FILL_CARRYIN = $4;


FILL_OR

Declaration

Source position: hardware.pas line 131

const FILL_OR = $8;


FILL_XOR

Declaration

Source position: hardware.pas line 132

const FILL_XOR = $10;


HSIZEBITS

Declaration

Source position: hardware.pas line 81

const HSIZEBITS = 6;


HSIZEMASK

Declaration

Source position: hardware.pas line 83

const HSIZEMASK = $3F;


HSYNCTRUE

Declaration

Source position: hardware.pas line 482

const HSYNCTRUE = $0001;


Reference for unit 'hardware'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'hardware': Constants

ABC

ABNC

ADKB_FAST

ADKB_MFMPREC

ADKB_MSBSYNC

ADKB_PRECOMP0

ADKB_PRECOMP1

ADKB_SETCLR

ADKB_UARTBRK

ADKB_USE0P1

ADKB_USE0V1

ADKB_USE1P2

ADKB_USE1V2

ADKB_USE2P3

ADKB_USE2V3

ADKB_USE3PN

ADKB_USE3VN

ADKB_WORDSYNC

ADKF_FAST

ADKF_MFMPREC

ADKF_MSBSYNC

ADKF_PRE000NS

ADKF_PRE140NS

ADKF_PRE280NS

ADKF_PRE560NS

ADKF_PRECOMP0

ADKF_PRECOMP1

ADKF_SETCLR

ADKF_UARTBRK

ADKF_USE0P1

ADKF_USE0V1

ADKF_USE1P2

ADKF_USE1V2

ADKF_USE2P3

ADKF_USE2V3

ADKF_USE3PN

ADKF_USE3VN

ADKF_WORDSYNC

ANBC

ANBNC

ASHIFTSHIFT

AUL

A_OR_B

A_OR_C

A_TO_D

A_XOR_C

BC0B_DEST

BC0B_SRCA

BC0B_SRCB

BC0B_SRCC

BC0F_DEST

BC0F_SRCA

BC0F_SRCB

BC0F_SRCC

BC1F_DESC

BLITREVERSE

BPLCON2_ZDBPEN

BPLCON2_ZDBPSEL0

BPLCON2_ZDBPSEL1

BPLCON2_ZDBPSEL2

BPLCON2_ZDCTEN

BPLCON3_BRDNBLNK

BPLCON3_BRDNTRAN

BPLCON3_EXTBLKZD

BPLCON3_EXTBLNKEN

BPLCON3_ZDCLKEN

BSHIFTSHIFT

CIAB_COMCD

CIAB_COMCTS

CIAB_COMDSR

CIAB_COMDTR

CIAB_COMRTS

CIAB_DSKCHANGE

CIAB_DSKDIREC

CIAB_DSKMOTOR

CIAB_DSKPROT

CIAB_DSKRDY

CIAB_DSKSEL0

CIAB_DSKSEL1

CIAB_DSKSEL2

CIAB_DSKSEL3

CIAB_DSKSIDE

CIAB_DSKSTEP

CIAB_DSKTRACK0

CIAB_GAMEPORT0

CIAB_GAMEPORT1

CIAB_LED

CIAB_OVERLAY

CIAB_PRTRBUSY

CIAB_PRTRPOUT

CIAB_PRTRSEL

CIACRAB_INMODE

CIACRAB_LOAD

CIACRAB_OUTMODE

CIACRAB_PBON

CIACRAB_RUNMODE

CIACRAB_SPMODE

CIACRAB_START

CIACRAB_TODIN

CIACRAF_INMODE

CIACRAF_LOAD

CIACRAF_OUTMODE

CIACRAF_PBON

CIACRAF_RUNMODE

CIACRAF_SPMODE

CIACRAF_START

CIACRAF_TODIN

CIACRBB_ALARM

CIACRBB_INMODE0

CIACRBB_INMODE1

CIACRBB_LOAD

CIACRBB_OUTMODE

CIACRBB_PBON

CIACRBB_RUNMODE

CIACRBB_START

CIACRBF_ALARM

CIACRBF_INMODE0

CIACRBF_INMODE1

CIACRBF_IN_CNT

CIACRBF_IN_CNT_TA

CIACRBF_IN_PHI2

CIACRBF_IN_TA

CIACRBF_LOAD

CIACRBF_OUTMODE

CIACRBF_PBON

CIACRBF_RUNMODE

CIACRBF_START

CIAF_COMCD

CIAF_COMCTS

CIAF_COMDSR

CIAF_COMDTR

CIAF_COMRTS

CIAF_DSKCHANGE

CIAF_DSKDIREC

CIAF_DSKMOTOR

CIAF_DSKPROT

CIAF_DSKRDY

CIAF_DSKSEL0

CIAF_DSKSEL1

CIAF_DSKSEL2

CIAF_DSKSEL3

CIAF_DSKSIDE

CIAF_DSKSTEP

CIAF_DSKTRACK0

CIAF_GAMEPORT0

CIAF_GAMEPORT1

CIAF_LED

CIAF_OVERLAY

CIAF_PRTRBUSY

CIAF_PRTRPOUT

CIAF_PRTRSEL

CIAICRB_ALRM

CIAICRB_FLG

CIAICRB_IR

CIAICRB_SETCLR

CIAICRB_SP

CIAICRB_TA

CIAICRB_TB

CIAICRF_ALRM

CIAICRF_FLG

CIAICRF_IR

CIAICRF_SETCLR

CIAICRF_SP

CIAICRF_TA

CIAICRF_TB

CLEANME

CLEANUP

CSBLANK

CSCBLANKEN

CSYNCTRUE

DEST

DISPLAYDUAL

DISPLAYPAL

DMAB_AUD0

DMAB_AUD1

DMAB_AUD2

DMAB_AUD3

DMAB_BLITHOG

DMAB_BLITTER

DMAB_BLTDONE

DMAB_BLTNZERO

DMAB_COPPER

DMAB_DISK

DMAB_MASTER

DMAB_RASTER

DMAB_SETCLR

DMAB_SPRITE

DMAF_ALL

DMAF_AUD0

DMAF_AUD1

DMAF_AUD2

DMAF_AUD3

DMAF_AUDIO

DMAF_BLITHOG

DMAF_BLITTER

DMAF_BLTDONE

DMAF_BLTNZERO

DMAF_COPPER

DMAF_DISK

DMAF_MASTER

DMAF_RASTER

DMAF_SETCLR

DMAF_SPRITE

FILL_CARRYIN

FILL_OR

FILL_XOR

HSIZEBITS

HSIZEMASK

HSYNCTRUE

INTB_AUD0

INTB_AUD1

INTB_AUD2

INTB_AUD3

INTB_BLIT

INTB_COPER

INTB_DSKBLK

INTB_DSKSYNC

INTB_EXTER

INTB_INTEN

INTB_PORTS

INTB_RBF

INTB_SETCLR

INTB_SOFTINT

INTB_TBE

INTB_VERTB

INTF_AUD0

INTF_AUD1

INTF_AUD2

INTF_AUD3

INTF_BLIT

INTF_COPER

INTF_DSKBLK

INTF_DSKSYNC

INTF_EXTER

INTF_INTEN

INTF_PORTS

INTF_RBF

INTF_SETCLR

INTF_SOFTINT

INTF_TBE

INTF_VERTB

LINEMODE

LOLDIS

MAXBYTESPERROW

MINBYTESPERROW

NABC

NABNC

NANBC

NANBNC

OCTANT1

OCTANT2

OCTANT3

OCTANT4

OCTANT5

OCTANT6

OCTANT7

OCTANT8

ONEDOT

OVFLAG

SIGNFLAG

SRCA

SRCB

SRCC

SUD

SUL

USE_BPLCON3

VARBEAM

VARCSYNC

VARHSYNC

VARVBLANK

VARVSYNC

VSIZEBITS

VSIZEMASK

VSYNCTRUE


Reference for unit 'hardware': Types

PAudChannel

Pbltnode

PCIA

PCustom

PSpriteDef

TAudChannel

Tbltnode

TCIA

TCustom

TSpriteDef


Index of all identifiers in unit 'hardware'

A B C D F H I L M N O P S T U V

A

ABC | ADKB_USE3VN | ADKF_USE1V2
ABNC | ADKB_WORDSYNC | ADKF_USE2P3
ADKB_FAST | ADKF_FAST | ADKF_USE2V3
ADKB_MFMPREC | ADKF_MFMPREC | ADKF_USE3PN
ADKB_MSBSYNC | ADKF_MSBSYNC | ADKF_USE3VN
ADKB_PRECOMP0 | ADKF_PRE000NS | ADKF_WORDSYNC
ADKB_PRECOMP1 | ADKF_PRE140NS | ANBC
ADKB_SETCLR | ADKF_PRE280NS | ANBNC
ADKB_UARTBRK | ADKF_PRE560NS | A_OR_B
ADKB_USE0P1 | ADKF_PRECOMP0 | A_OR_C
ADKB_USE0V1 | ADKF_PRECOMP1 | ASHIFTSHIFT
ADKB_USE1P2 | ADKF_SETCLR | A_TO_D
ADKB_USE1V2 | ADKF_UARTBRK | AUL
ADKB_USE2P3 | ADKF_USE0P1 | A_XOR_C
ADKB_USE2V3 | ADKF_USE0V1 |
ADKB_USE3PN | ADKF_USE1P2 |

B

BC0B_DEST | BC0F_SRCC | BPLCON2_ZDCTEN
BC0B_SRCA | BC1F_DESC | BPLCON3_BRDNBLNK
BC0B_SRCB | BLITREVERSE | BPLCON3_BRDNTRAN
BC0B_SRCC | BPLCON2_ZDBPEN | BPLCON3_EXTBLKZD
BC0F_DEST | BPLCON2_ZDBPSEL0 | BPLCON3_EXTBLNKEN
BC0F_SRCA | BPLCON2_ZDBPSEL1 | BPLCON3_ZDCLKEN
BC0F_SRCB | BPLCON2_ZDBPSEL2 | BSHIFTSHIFT

C

CIAB_COMCD | CIACRAF_PBON | CIAF_DSKSEL0
CIAB_COMCTS | CIACRAF_RUNMODE | CIAF_DSKSEL1
CIAB_COMDSR | CIACRAF_SPMODE | CIAF_DSKSEL2
CIAB_COMDTR | CIACRAF_START | CIAF_DSKSEL3
CIAB_COMRTS | CIACRAF_TODIN | CIAF_DSKSIDE
CIAB_DSKCHANGE | CIACRBB_ALARM | CIAF_DSKSTEP
CIAB_DSKDIREC | CIACRBB_INMODE0 | CIAF_DSKTRACK0
CIAB_DSKMOTOR | CIACRBB_INMODE1 | CIAF_GAMEPORT0
CIAB_DSKPROT | CIACRBB_LOAD | CIAF_GAMEPORT1
CIAB_DSKRDY | CIACRBB_OUTMODE | CIAF_LED
CIAB_DSKSEL0 | CIACRBB_PBON | CIAF_OVERLAY
CIAB_DSKSEL1 | CIACRBB_RUNMODE | CIAF_PRTRBUSY
CIAB_DSKSEL2 | CIACRBB_START | CIAF_PRTRPOUT
CIAB_DSKSEL3 | CIACRBF_ALARM | CIAF_PRTRSEL
CIAB_DSKSIDE | CIACRBF_IN_CNT | CIAICRB_ALRM
CIAB_DSKSTEP | CIACRBF_IN_CNT_TA | CIAICRB_FLG
CIAB_DSKTRACK0 | CIACRBF_INMODE0 | CIAICRB_IR
CIAB_GAMEPORT0 | CIACRBF_INMODE1 | CIAICRB_SETCLR
CIAB_GAMEPORT1 | CIACRBF_IN_PHI2 | CIAICRB_SP
CIAB_LED | CIACRBF_IN_TA | CIAICRB_TA
CIAB_OVERLAY | CIACRBF_LOAD | CIAICRB_TB
CIAB_PRTRBUSY | CIACRBF_OUTMODE | CIAICRF_ALRM
CIAB_PRTRPOUT | CIACRBF_PBON | CIAICRF_FLG
CIAB_PRTRSEL | CIACRBF_RUNMODE | CIAICRF_IR
CIACRAB_INMODE | CIACRBF_START | CIAICRF_SETCLR
CIACRAB_LOAD | CIAF_COMCD | CIAICRF_SP
CIACRAB_OUTMODE | CIAF_COMCTS | CIAICRF_TA
CIACRAB_PBON | CIAF_COMDSR | CIAICRF_TB
CIACRAB_RUNMODE | CIAF_COMDTR | CLEANME
CIACRAB_SPMODE | CIAF_COMRTS | CLEANUP
CIACRAB_START | CIAF_DSKCHANGE | CSBLANK
CIACRAB_TODIN | CIAF_DSKDIREC | CSCBLANKEN
CIACRAF_INMODE | CIAF_DSKMOTOR | CSYNCTRUE
CIACRAF_LOAD | CIAF_DSKPROT |
CIACRAF_OUTMODE | CIAF_DSKRDY |

D

DEST | DMAB_COPPER | DMAF_AUDIO
DISPLAYDUAL | DMAB_DISK | DMAF_BLITHOG
DISPLAYPAL | DMAB_MASTER | DMAF_BLITTER
DMAB_AUD0 | DMAB_RASTER | DMAF_BLTDONE
DMAB_AUD1 | DMAB_SETCLR | DMAF_BLTNZERO
DMAB_AUD2 | DMAB_SPRITE | DMAF_COPPER
DMAB_AUD3 | DMAF_ALL | DMAF_DISK
DMAB_BLITHOG | DMAF_AUD0 | DMAF_MASTER
DMAB_BLITTER | DMAF_AUD1 | DMAF_RASTER
DMAB_BLTDONE | DMAF_AUD2 | DMAF_SETCLR
DMAB_BLTNZERO | DMAF_AUD3 | DMAF_SPRITE

F

FILL_CARRYIN FILL_OR FILL_XOR

H

HSIZEBITS HSIZEMASK HSYNCTRUE

I

INTB_AUD0 | INTB_RBF | INTF_DSKBLK
INTB_AUD1 | INTB_SETCLR | INTF_DSKSYNC
INTB_AUD2 | INTB_SOFTINT | INTF_EXTER
INTB_AUD3 | INTB_TBE | INTF_INTEN
INTB_BLIT | INTB_VERTB | INTF_PORTS
INTB_COPER | INTF_AUD0 | INTF_RBF
INTB_DSKBLK | INTF_AUD1 | INTF_SETCLR
INTB_DSKSYNC | INTF_AUD2 | INTF_SOFTINT
INTB_EXTER | INTF_AUD3 | INTF_TBE
INTB_INTEN | INTF_BLIT | INTF_VERTB
INTB_PORTS | INTF_COPER |

L

LINEMODE LOLDIS

M

MAXBYTESPERROW MINBYTESPERROW

N

NABC | NANBC
NABNC | NANBNC

O

OCTANT1 | OCTANT5 | ONEDOT
OCTANT2 | OCTANT6 | OVFLAG
OCTANT3 | OCTANT7 |
OCTANT4 | OCTANT8 |

P

PAudChannel | PCIA | PSpriteDef
Pbltnode | PCustom |

S

SIGNFLAG | SRCB | SUD
SRCA | SRCC | SUL

T

TAudChannel | TCIA | TSpriteDef
Tbltnode | TCustom |

U

USE_BPLCON3

V

VARBEAM | VARVBLANK | VSIZEMASK
VARCSYNC | VARVSYNC | VSYNCTRUE
VARHSYNC | VSIZEBITS |


INTB_AUD0

Declaration

Source position: hardware.pas line 554

const INTB_AUD0 = 7;


INTB_AUD1

Declaration

Source position: hardware.pas line 553

const INTB_AUD1 = 8;


INTB_AUD2

Declaration

Source position: hardware.pas line 552

const INTB_AUD2 = 9;


INTB_AUD3

Declaration

Source position: hardware.pas line 551

const INTB_AUD3 = 10;


INTB_BLIT

Declaration

Source position: hardware.pas line 555

const INTB_BLIT = 6;


INTB_COPER

Declaration

Source position: hardware.pas line 557

const INTB_COPER = 4;


INTB_DSKBLK

Declaration

Source position: hardware.pas line 560

const INTB_DSKBLK = 1;


INTB_DSKSYNC

Declaration

Source position: hardware.pas line 549

const INTB_DSKSYNC = 12;


INTB_EXTER

Declaration

Source position: hardware.pas line 548

const INTB_EXTER = 13;


INTB_INTEN

Declaration

Source position: hardware.pas line 547

const INTB_INTEN = 14;


INTB_PORTS

Declaration

Source position: hardware.pas line 558

const INTB_PORTS = 3;


INTB_RBF

Declaration

Source position: hardware.pas line 550

const INTB_RBF = 11;


INTB_SETCLR

Declaration

Source position: hardware.pas line 546

const INTB_SETCLR = 15;


INTB_SOFTINT

Declaration

Source position: hardware.pas line 559

const INTB_SOFTINT = 2;


INTB_TBE

Declaration

Source position: hardware.pas line 561

const INTB_TBE = 0;


INTB_VERTB

Declaration

Source position: hardware.pas line 556

const INTB_VERTB = 5;


INTF_AUD0

Declaration

Source position: hardware.pas line 571

const INTF_AUD0 = 1 shl INTB_AUD0;


INTF_AUD1

Declaration

Source position: hardware.pas line 570

const INTF_AUD1 = 1 shl INTB_AUD1;


INTF_AUD2

Declaration

Source position: hardware.pas line 569

const INTF_AUD2 = 1 shl INTB_AUD2;


INTF_AUD3

Declaration

Source position: hardware.pas line 568

const INTF_AUD3 = 1 shl INTB_AUD3;


INTF_BLIT

Declaration

Source position: hardware.pas line 572

const INTF_BLIT = 1 shl INTB_BLIT;


INTF_COPER

Declaration

Source position: hardware.pas line 574

const INTF_COPER = 1 shl INTB_COPER;


INTF_DSKBLK

Declaration

Source position: hardware.pas line 577

const INTF_DSKBLK = 1 shl INTB_DSKBLK;


INTF_DSKSYNC

Declaration

Source position: hardware.pas line 566

const INTF_DSKSYNC = 1 shl INTB_DSKSYNC;


INTF_EXTER

Declaration

Source position: hardware.pas line 565

const INTF_EXTER = 1 shl INTB_EXTER;


INTF_INTEN

Declaration

Source position: hardware.pas line 564

const INTF_INTEN = 1 shl INTB_INTEN;


INTF_PORTS

Declaration

Source position: hardware.pas line 575

const INTF_PORTS = 1 shl INTB_PORTS;


INTF_RBF

Declaration

Source position: hardware.pas line 567

const INTF_RBF = 1 shl INTB_RBF;


INTF_SETCLR

Declaration

Source position: hardware.pas line 563

const INTF_SETCLR = 1 shl INTB_SETCLR;


INTF_SOFTINT

Declaration

Source position: hardware.pas line 576

const INTF_SOFTINT = 1 shl INTB_SOFTINT;


INTF_TBE

Declaration

Source position: hardware.pas line 578

const INTF_TBE = 1 shl INTB_TBE;


INTF_VERTB

Declaration

Source position: hardware.pas line 573

const INTF_VERTB = 1 shl INTB_VERTB;


LINEMODE

Declaration

Source position: hardware.pas line 130

const LINEMODE = $1;


LOLDIS

Declaration

Source position: hardware.pas line 471

const LOLDIS = $0800;


MAXBYTESPERROW

Declaration

Source position: hardware.pas line 88

const MAXBYTESPERROW = 4096;


MINBYTESPERROW

Declaration

Source position: hardware.pas line 87

const MINBYTESPERROW = 128;


NABC

Declaration

Source position: hardware.pas line 98

const NABC = $8;


NABNC

Declaration

Source position: hardware.pas line 99

const NABNC = $4;


NANBC

Declaration

Source position: hardware.pas line 100

const NANBC = $2;


NANBNC

Declaration

Source position: hardware.pas line 101

const NANBNC = $1;


OCTANT1

Declaration

Source position: hardware.pas line 150

const OCTANT1 = 16;


OCTANT2

Declaration

Source position: hardware.pas line 149

const OCTANT2 = 0;


OCTANT3

Declaration

Source position: hardware.pas line 148

const OCTANT3 = 8;


OCTANT4

Declaration

Source position: hardware.pas line 147

const OCTANT4 = 20;


OCTANT5

Declaration

Source position: hardware.pas line 146

const OCTANT5 = 28;


OCTANT6

Declaration

Source position: hardware.pas line 145

const OCTANT6 = 12;


OCTANT7

Declaration

Source position: hardware.pas line 144

const OCTANT7 = 4;


OCTANT8

Declaration

Source position: hardware.pas line 143

const OCTANT8 = 24;


ONEDOT

Declaration

Source position: hardware.pas line 134

const ONEDOT = $2;


OVFLAG

Declaration

Source position: hardware.pas line 135

const OVFLAG = $20;


PAudChannel

Declaration

Source position: hardware.pas line 342

type PAudChannel = ^TAudChannel;


Pbltnode

Declaration

Source position: hardware.pas line 153

type Pbltnode = ^Tbltnode;


PCIA

Declaration

Source position: hardware.pas line 182

type PCIA = ^TCIA;


PCustom

Declaration

Source position: hardware.pas line 360

type PCustom = ^TCustom;


PSpriteDef

Declaration

Source position: hardware.pas line 352

type PSpriteDef = ^TSpriteDef;


SIGNFLAG

Declaration

Source position: hardware.pas line 136

const SIGNFLAG = $40;


SRCA

Declaration

Source position: hardware.pas line 124

const SRCA = BC0F_SRCA;


SRCB

Declaration

Source position: hardware.pas line 123

const SRCB = BC0F_SRCB;


SRCC

Declaration

Source position: hardware.pas line 122

const SRCC = BC0F_SRCC;


SUD

Declaration

Source position: hardware.pas line 139

const SUD = $10;


SUL

Declaration

Source position: hardware.pas line 140

const SUL = $8;


TAudChannel

Declaration

Source position: hardware.pas line 343

type TAudChannel = record

  ac_ptr: Pointer;

  ac_len: Word;

  ac_per: Word;

  ac_vol: Word;

  ac_dat: Word;

  ac_pad: array [0..1] of Word;

end;


Tbltnode

Declaration

Source position: hardware.pas line 154

type Tbltnode = record

  n: Pbltnode;

  _function: Pointer;

  stat: Byte;

  blitsize: SmallInt;

  beamsync: SmallInt;

  cleanup: Pointer;

end;


TCIA

Declaration

Source position: hardware.pas line 183

type TCIA = record

  ciapra: Byte;

  pad0: array [0..254] of Byte;

  ciaprb: Byte;

  pad1: array [0..254] of Byte;

  ciaddra: Byte;

  pad2: array [0..254] of Byte;

  ciaddrb: Byte;

  pad3: array [0..254] of Byte;

  ciatalo: Byte;

  pad4: array [0..254] of Byte;

  ciatahi: Byte;

  pad5: array [0..254] of Byte;

  ciatblo: Byte;

  pad6: array [0..254] of Byte;

  ciatbhi: Byte;

  pad7: array [0..254] of Byte;

  ciatodlow: Byte;

  pad8: array [0..254] of Byte;

  ciatodmid: Byte;

  pad9: array [0..254] of Byte;

  ciatodhi: Byte;

  pad10: array [0..254] of Byte;

  unusedreg: Byte;

  pad11: array [0..254] of Byte;

  ciasdr: Byte;

  pad12: array [0..254] of Byte;

  ciaicr: Byte;

  pad13: array [0..254] of Byte;

  ciacra: Byte;

  pad14: array [0..254] of Byte;

  ciacrb: Byte;

end;


TCustom

Declaration

Source position: hardware.pas line 361

type TCustom = record

  bltddat: Word;

  dmaconr: Word;

  vposr: Word;

  vhposr: Word;

  dskdatr: Word;

  joy0dat: Word;

  joy1dat: Word;

  clxdat: Word;

  adkconr: Word;

  pot0dat: Word;

  pot1dat: Word;

  potinp: Word;

  serdatr: Word;

  dskbytr: Word;

  intenar: Word;

  intreqr: Word;

  dskpt: Pointer;

  dsklen: Word;

  dskdat: Word;

  refptr: Word;

  vposw: Word;

  vhposw: Word;

  copcon: Word;

  serdat: Word;

  serper: Word;

  potgo: Word;

  joytest: Word;

  strequ: Word;

  strvbl: Word;

  strhor: Word;

  strlong: Word;

  bltcon0: Word;

  bltcon1: Word;

  bltafwm: Word;

  bltalwm: Word;

  bltcpt: Pointer;

  bltbpt: Pointer;

  bltapt: Pointer;

  bltdpt: Pointer;

  bltsize: Word;

  pad2d: Byte;

  bltcon0l: Byte;

  bltsizv: Word;

  bltsizh: Word;

  bltcmod: Word;

  bltbmod: Word;

  bltamod: Word;

  bltdmod: Word;

  pad34: array [0..3] of Word;

  bltcdat: Word;

  bltbdat: Word;

  bltadat: Word;

  pad3b: array [0..2] of Word;

  deniseid: Word;

  dsksync: Word;

  cop1lc: LongInt;

  cop2lc: LongInt;

  copjmp1: Word;

  copjmp2: Word;

  copins: Word;

  diwstrt: Word;

  diwstop: Word;

  ddfstrt: Word;

  ddfstop: Word;

  dmacon: Word;

  clxcon: Word;

  intena: Word;

  intreq: Word;

  adkcon: Word;

  aud: array [0..3] of TAudChannel;

  bplpt: array [0..7] of Pointer;

  bplcon0: Word;

  bplcon1: Word;

  bplcon2: Word;

  bplcon3: Word;

  bpl1mod: Word;

  bpl2mod: Word;

  bplcon4: Word;

  clxcon2: Word;

  bpldat: array [0..7] of Word;

  sprpt: array [0..7] of Pointer;

  spr: array [0..7] of TSpriteDef;

  color: array [0..31] of Word;

  htotal: Word;

  hsstop: Word;

  hbstrt: Word;

  hbstop: Word;

  vtotal: Word;

  vsstop: Word;

  vbstrt: Word;

  vbstop: Word;

  sprhstrt: Word;

  sprhstop: Word;

  bplhstrt: Word;

  bplhstop: Word;

  hhposw: Word;

  hhposr: Word;

  beamcon0: Word;

  hsstrt: Word;

  vsstrt: Word;

  hcenter: Word;

  diwhigh: Word;

  padf3: array [0..10] of Word;

  fmode: Word;

end;


TSpriteDef

Declaration

Source position: hardware.pas line 353

type TSpriteDef = record

  pos: Word;

  ctl: Word;

  dataa: Word;

  datab: Word;

end;


USE_BPLCON3

Declaration

Source position: hardware.pas line 484

const USE_BPLCON3 = 1;


VARBEAM

Declaration

Source position: hardware.pas line 475

const VARBEAM = $0080;


VARCSYNC

Declaration

Source position: hardware.pas line 478

const VARCSYNC = $0010;


VARHSYNC

Declaration

Source position: hardware.pas line 474

const VARHSYNC = $0100;


VARVBLANK

Declaration

Source position: hardware.pas line 470

const VARVBLANK = $1000;


VARVSYNC

Declaration

Source position: hardware.pas line 473

const VARVSYNC = $0200;


VSIZEBITS

Declaration

Source position: hardware.pas line 82

const VSIZEBITS = 16 - HSIZEBITS;


VSIZEMASK

Declaration

Source position: hardware.pas line 84

const VSIZEMASK = $3FF;


VSYNCTRUE

Declaration

Source position: hardware.pas line 481

const VSYNCTRUE = $0002;


ICON_ASPECT_RATIO_UNKNOWN

Icon aspect ratio is not known.

Declaration

Source position: icon.pas line 176

const ICON_ASPECT_RATIO_UNKNOWN = 0;

See also

ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
IconControlA | Set and get icon and icon.library options


ICONA_Dummy

Start of icon.library tags

Declaration

Source position: icon.pas line 62

const ICONA_Dummy = TAG_USER + $9000;


ICONA_ErrorCode

Errorcode (PLongInt)

Declaration

Source position: icon.pas line 65

const ICONA_ErrorCode = ICONA_Dummy + 1;

Description

Pointer to a LongWord variable to store error codes in. Note that this variable will be initialized regardless of whether an error occured or not. Thus, you can check for an error condition by comparing the variable contents against 0; 0 indicates success, all other values are error codes as defined by dos.library.

See also

ICONA_ErrorTagItem

Points to the tag item that caused the error (^PTagItem)


ICONA_ErrorTagItem

Points to the tag item that caused the error (^PTagItem)

Declaration

Source position: icon.pas line 68

const ICONA_ErrorTagItem = ICONA_Dummy + 75;

See also

ICONA_ErrorCode

Errorcode (PLongInt)


ICONA_LAST_TAG

The last Tag of icon.library

Declaration

Source position: icon.pas line 340

const ICONA_LAST_TAG = ICONA_Dummy + 89;


ICONA_Reserved1

Reserved tag; don't use!

Declaration

Source position: icon.pas line 331

const ICONA_Reserved1 = ICONA_Dummy + 73;


ICONA_Reserved2

Reserved tag; don't use!

Declaration

Source position: icon.pas line 332

const ICONA_Reserved2 = ICONA_Dummy + 74;


ICONA_Reserved3

Reserved tag; don't use!

Declaration

Source position: icon.pas line 333

const ICONA_Reserved3 = ICONA_Dummy + 76;


ICONA_Reserved4

Reserved tag; don't use!

Declaration

Source position: icon.pas line 334

const ICONA_Reserved4 = ICONA_Dummy + 81;


ICONA_Reserved5

Reserved tag; don't use!

Declaration

Source position: icon.pas line 335

const ICONA_Reserved5 = ICONA_Dummy + 85;


ICONA_Reserved6

Reserved tag; don't use!

Declaration

Source position: icon.pas line 336

const ICONA_Reserved6 = ICONA_Dummy + 86;


ICONA_Reserved7

Reserved tag; don't use!

Declaration

Source position: icon.pas line 337

const ICONA_Reserved7 = ICONA_Dummy + 87;


ICONA_Reserved8

Reserved tag; don't use!

Declaration

Source position: icon.pas line 338

const ICONA_Reserved8 = ICONA_Dummy + 88;


IconBase

Declaration

Source position: icon.pas line 349

var IconBase: PLibrary = Nil;


ICONCTRLA_GetAspectRatio

Tag for IconControlA(),

Declaration

Source position: icon.pas line 147

const ICONCTRLA_GetAspectRatio = ICONA_Dummy + 37;

Description

Per Icon Option for IconControlA() Get the icon aspect ratio; this consists of a numerator and a denominator packed into a single byte. If the icon aspect ratio is unknown, ICON_ASPECT_RATIO_UNKNOWN will be returned.

See also

ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
ICON_ASPECT_RATIO_UNKNOWN | Icon aspect ratio is not known.


ICONCTRLA_GetFrameless

Tag for IconControlA(), Get if rendered without frame (BOOL)

Declaration

Source position: icon.pas line 139

const ICONCTRLA_GetFrameless = ICONA_Dummy + 33;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetFrameless

Tag for IconControlA(), Set if rendered without frame (BOOL)


ICONCTRLA_GetGlobalColorIconSupport

Tag for IconControlA(), Get Status of color icon support (BOOL)

Declaration

Source position: icon.pas line 94

const ICONCTRLA_GetGlobalColorIconSupport = ICONA_Dummy + 78;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalColorIconSupport

Tag for IconControlA(), Enable color icon support (BOOL)


ICONCTRLA_GetGlobalEmbossRect

Tag for IconControlA(), Get Icon frame size dimensions (PRectange)

Declaration

Source position: icon.pas line 82

const ICONCTRLA_GetGlobalEmbossRect = ICONA_Dummy + 7;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalEmbossRect

Tag for IconControlA(), Icon frame size dimensions (PRectange)


ICONCTRLA_GetGlobalFrameless

Tag for IconControlA(), Get if images are rendered without frame (BOOL)

Declaration

Source position: icon.pas line 86

const ICONCTRLA_GetGlobalFrameless = ICONA_Dummy + 9;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalFrameless

Tag for IconControlA(), Render image without frame (BOOL)


ICONCTRLA_GetGlobalIdentifyHook

Tag for IconControlA(), Get the hook to be called when identifying a file (Utility.PHook)

Declaration

Source position: icon.pas line 98

const ICONCTRLA_GetGlobalIdentifyHook = ICONA_Dummy + 13;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalIdentifyHook

Tag for IconControlA(), Set the hook to be called when identifying a file (Utility.PHook)


ICONCTRLA_GetGlobalMaxNameLength

Tag for IconControlA(), Get the maximum length of a file/drawer name supported by icon.library (LONG).

Declaration

Source position: icon.pas line 104

const ICONCTRLA_GetGlobalMaxNameLength = ICONA_Dummy + 68;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalMaxNameLength

Tag for IconControlA(), Set the maximum length of a file/drawer name supported by icon.library (LONG).


ICONCTRLA_GetGlobalNewIconsSupport

Tag for IconControlA(), Get Status of NewIcons support (BOOL)

Declaration

Source position: icon.pas line 90

const ICONCTRLA_GetGlobalNewIconsSupport = ICONA_Dummy + 11;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalNewIconsSupport

Tag for IconControlA(), Enable NewIcons support (BOOL)


ICONCTRLA_GetGlobalPrecision

Tag for IconControlA(), Get Icon color remapping precision (PLongInt)

Declaration

Source position: icon.pas line 78

const ICONCTRLA_GetGlobalPrecision = ICONA_Dummy + 5;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalPrecision

Tag for IconControlA(), Icon color remapping precision (LongInt)


ICONCTRLA_GetGlobalScreen

Tag for IconControlA(), Get the Screen which is used icons (^PScreen)

Declaration

Source position: icon.pas line 74

const ICONCTRLA_GetGlobalScreen = ICONA_Dummy + 3;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalScreen

Tag for IconControlA(), Screen to use for remapping Workbench icons to (PScreen)


ICONCTRLA_GetHeight

Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 153

const ICONCTRLA_GetHeight = ICONA_Dummy + 41;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONCTRLA_GetImageData1

Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)

Declaration

Source position: icon.pas line 133

const ICONCTRLA_GetImageData1 = ICONA_Dummy + 29;

Description

Per Icon Option for IconControlA() Get the image data to be used for a palette mapped icon image, in this case the regular icon image (icon->do_Gadget.GadgetRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result.

See also

ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)


ICONCTRLA_GetImageData2

Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)

Declaration

Source position: icon.pas line 135

const ICONCTRLA_GetImageData2 = ICONA_Dummy + 31;

Description

Per Icon Option for IconControlA() Get the image data to be used for a palette mapped icon image, in this case the alternate icon image (icon->do_Gadget.SelectRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. If there is no alternate image, no information may be available.

See also

ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)


ICONCTRLA_GetImageMask1

Tag for IconControlA(), Get the icon rendering mask 1 (PLANEPTR)

Declaration

Source position: icon.pas line 110

const ICONCTRLA_GetImageMask1 = ICONA_Dummy + 14;

Description

Per Icon Option for IconControlA() Pointer to the mask plane for the regular icon image (Icon^.do_Gadget.GadgetRender). Note that this may be nil.

See also

ICONCTRLA_GetImageMask2

Tag for IconControlA(), Get the icon rendering mask 2 (PLANEPTR)


ICONCTRLA_GetImageMask2

Tag for IconControlA(), Get the icon rendering mask 2 (PLANEPTR)

Declaration

Source position: icon.pas line 111

const ICONCTRLA_GetImageMask2 = ICONA_Dummy + 15;

Description

Per Icon Option for IconControlA() Pointer to the mask plane for the alternate icon image (Icon^.do_Gadget.SelectRender). Note that this may be nil.

See also

ICONCTRLA_GetImageMask1

Tag for IconControlA(), Get the icon rendering mask 1 (PLANEPTR)


ICONCTRLA_GetNewIconsSupport

Tag for IconControlA(), Get if NewIcons support is enabled (BOOL)

Declaration

Source position: icon.pas line 143

const ICONCTRLA_GetNewIconsSupport = ICONA_Dummy + 35;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetNewIconsSupport

Tag for IconControlA(), Set if NewIcons support is enabled (BOOL)


ICONCTRLA_GetPalette1

Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)

Declaration

Source position: icon.pas line 121

const ICONCTRLA_GetPalette1 = ICONA_Dummy + 21;

Description

Per Icon Option for IconControlA() Get the colour palette for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. Note that the number of palette entries in this table matches the number of colours in use when the icon was first created.

See also

ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_GetPalette2

Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)

Declaration

Source position: icon.pas line 123

const ICONCTRLA_GetPalette2 = ICONA_Dummy + 23;

Description

Per Icon Option for IconControlA() Get the colour palette for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. If there is no alternate image, no information may be available. Note that the number of palette entries in this table matches the number of colours in use when the icon was first created.

See also

ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_GetPaletteSize1

Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)

Declaration

Source position: icon.pas line 127

const ICONCTRLA_GetPaletteSize1 = ICONA_Dummy + 25;

Description

Per Icon Option for IconControlA() Get the size of the colour palette to be used for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result.

See also

ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_GetPaletteSize2

Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)

Declaration

Source position: icon.pas line 129

const ICONCTRLA_GetPaletteSize2 = ICONA_Dummy + 27;

Description

Per Icon Option for IconControlA() Get the size of the colour palette to be used for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. If there is no alternate image, no information may be available.

See also

ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_GetScreen

Tag for IconControlA(), Get the screen the icon is attached to (^PScreen).

Declaration

Source position: icon.pas line 159

const ICONCTRLA_GetScreen = ICONA_Dummy + 43;

Description

Per Icon Option for IconControlA()


ICONCTRLA_GetTransparentColor1

Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)

Declaration

Source position: icon.pas line 115

const ICONCTRLA_GetTransparentColor1 = ICONA_Dummy + 17;

Description

Per Icon Option for IconControlA() Get the transparent colour for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). If the image is opaque, its "transparent colour" will be returned as -1. Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result.

See also

ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque


ICONCTRLA_GetTransparentColor2

Tag for IconControlA(), Get second transparent image color; -1 if opaque

Declaration

Source position: icon.pas line 117

const ICONCTRLA_GetTransparentColor2 = ICONA_Dummy + 19;

Description

Per Icon Option for IconControlA() Get the transparent colour for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). If the image is opaque, its "transparent colour" will be returned as -1. Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. Likewise, if there is no alternate image, no information may be available.

See also

ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque


ICONCTRLA_GetWidth

Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 151

const ICONCTRLA_GetWidth = ICONA_Dummy + 39;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONCTRLA_HasRealImage2

Tag for IconControlA(), Check whether the icon has a real select image (PLongInt).

Declaration

Source position: icon.pas line 162

const ICONCTRLA_HasRealImage2 = ICONA_Dummy + 44;

Description

Per Icon Option for IconControlA()


ICONCTRLA_IsNativeIcon

Tag for IconControlA(), Check whether this icon was allocated by icon.library or if consists solely of a statically allocated struct DiskObject. (PLongInt).

Declaration

Source position: icon.pas line 171

const ICONCTRLA_IsNativeIcon = ICONA_Dummy + 80;

Description

Per Icon Option for IconControlA() There is an important difference between struct DiskObject icons allocated by icon.library itself (these are the so-called "native" icons) and statically initialized icons which consist solely of a simple struct DiskObject which may be part of a program's static data area. For example, you can attach a palette mapped icon image to a "native" icon, which is something you cannot do with a statically allocated icon. To help you tell the two types apart, you can use the ICONCTRLA_IsNativeIcon query tag.


ICONCTRLA_IsNewIcon

Tag for IconControlA(), Check whether the icon is of the NewIcon type (PLongInt).

Declaration

Source position: icon.pas line 165

const ICONCTRLA_IsNewIcon = ICONA_Dummy + 79;

Description

Per Icon Option for IconControlA()


ICONCTRLA_IsPaletteMapped

Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).

Declaration

Source position: icon.pas line 156

const ICONCTRLA_IsPaletteMapped = ICONA_Dummy + 42;

Description

Per Icon Option for IconControlA()


ICONCTRLA_SetAspectRatio

Tag for IconControlA(), Set Icon aspect ratio (PBYTE)

Declaration

Source position: icon.pas line 146

const ICONCTRLA_SetAspectRatio = ICONA_Dummy + 36;

Description

Per Icon Option for IconControlA() Set the icon aspect ratio; this consists of a numerator and a denominator packed into a single byte (PACK_ICON_ASPECT_RATIO can be used for encoding this parameter). If the icon aspect ratio is unknown, ICON_ASPECT_RATIO_UNKNOWN should be used.

See also

ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
ICON_ASPECT_RATIO_UNKNOWN | Icon aspect ratio is not known.


ICONCTRLA_SetFrameless

Tag for IconControlA(), Set if rendered without frame (BOOL)

Declaration

Source position: icon.pas line 138

const ICONCTRLA_SetFrameless = ICONA_Dummy + 32;

Description

Per Icon Option for IconControlA() This option defaults to False.

See also

ICONCTRLA_GetFrameless

Tag for IconControlA(), Get if rendered without frame (BOOL)


ICONCTRLA_SetGlobalColorIconSupport

Tag for IconControlA(), Enable color icon support (BOOL)

Declaration

Source position: icon.pas line 93

const ICONCTRLA_SetGlobalColorIconSupport = ICONA_Dummy + 77;

Description

Global Option for IconControlA() This option defaults to True.

See also

ICONCTRLA_GetGlobalColorIconSupport

Tag for IconControlA(), Get Status of color icon support (BOOL)


ICONCTRLA_SetGlobalEmbossRect

Tag for IconControlA(), Icon frame size dimensions (PRectange)

Declaration

Source position: icon.pas line 81

const ICONCTRLA_SetGlobalEmbossRect = ICONA_Dummy + 6;

Description

Global Option for IconControlA()

Set the frame sizes used for drawing icons. The Rectangle must be initialized as follows:

Rectangle^.MinX
Width of left edge border (negative), must be in the range [-255..-1]
Rectangle^.MinY
Height of top edge border (negative), must be in the range [-255..-1]
Rectangle^.MaxX
Width of right edge border (positive), must be in the range [1..255]
Rectangle^.MaxY
Height of bottom edge border (positive), must be in the range [1..255]

See also

ICONCTRLA_GetGlobalEmbossRect

Tag for IconControlA(), Get Icon frame size dimensions (PRectange)


ICONCTRLA_SetGlobalFrameless

Tag for IconControlA(), Render image without frame (BOOL)

Declaration

Source position: icon.pas line 85

const ICONCTRLA_SetGlobalFrameless = ICONA_Dummy + 8;

Description

Global Option for IconControlA() This option defaults to False.

See also

ICONCTRLA_GetGlobalFrameless

Tag for IconControlA(), Get if images are rendered without frame (BOOL)


ICONCTRLA_SetGlobalIdentifyHook

Tag for IconControlA(), Set the hook to be called when identifying a file (Utility.PHook)

Declaration

Source position: icon.pas line 97

const ICONCTRLA_SetGlobalIdentifyHook = ICONA_Dummy + 12;

Description

Global Option for IconControlA()

Set the hook that is invoked when trying to find an icon for a file/drawer/volume that does not have an icon associated with it. If set to nil, no hook will be called. The hook will be called with the following parameters:

procedure HookFunc(Hook: Phook; reserved: APTR; IIMsg: PIconIdentifyMsg); cdecl;

The reserved parameter will be set to nil

See also

ICONCTRLA_GetGlobalIdentifyHook

Tag for IconControlA(), Get the hook to be called when identifying a file (Utility.PHook)


ICONCTRLA_SetGlobalMaxNameLength

Tag for IconControlA(), Set the maximum length of a file/drawer name supported by icon.library (LONG).

Declaration

Source position: icon.pas line 103

const ICONCTRLA_SetGlobalMaxNameLength = ICONA_Dummy + 67;

Description

Global Option for IconControlA()

icon.library has a built-in file name length limit that affects whether icon files are read and written. Currently, the default for this value is 25 characters. This is sufficient for an icon file name acceptable with the ROM filing system. This limit has two effects: if an icon file is to be written whose name would be longer than the limit, icon.library will silently abort the write attempt and pretend that the icon file has been written; this is done in order to avoid overwriting the original data file with the icon file. If an icon file was read that turns out to contain invalid icon data, another test is done in order to find out whether the file name was longer than the limit. If this is the case, it is assumed that the data was read from the original file rather than from the icon file. The library then pretends that the icon file was not found.

This tag can be used to set this length limit. The limit must be in the range [8..255].

See also

ICONCTRLA_GetGlobalMaxNameLength

Tag for IconControlA(), Get the maximum length of a file/drawer name supported by icon.library (LONG).


ICONCTRLA_SetGlobalNewIconsSupport

Tag for IconControlA(), Enable NewIcons support (BOOL)

Declaration

Source position: icon.pas line 89

const ICONCTRLA_SetGlobalNewIconsSupport = ICONA_Dummy + 10;

Description

Global Option for IconControlA() This option defaults to True.

See also

ICONCTRLA_GetGlobalNewIconsSupport

Tag for IconControlA(), Get Status of NewIcons support (BOOL)


ICONCTRLA_SetGlobalPrecision

Tag for IconControlA(), Icon color remapping precision (LongInt)

Declaration

Source position: icon.pas line 77

const ICONCTRLA_SetGlobalPrecision = ICONA_Dummy + 4;

Description

Global Option for IconControlA(), Default is PRECISION_ICON.

See also

ICONCTRLA_GetGlobalPrecision

Tag for IconControlA(), Get Icon color remapping precision (PLongInt)


ICONCTRLA_SetGlobalScreen

Tag for IconControlA(), Screen to use for remapping Workbench icons to (PScreen)

Declaration

Source position: icon.pas line 73

const ICONCTRLA_SetGlobalScreen = ICONA_Dummy + 2;

Description

Global Option for IconControlA(),Pointer to the screen to remap palette mapped icons to. This is commonly used by workbench.library after it has initialized itself and before/after screen open/close transitions. If the screen is set to nil, the icon colour remapping strategy is changed: colours are no longer allocated from a screen and the colours to map to will come from a default colour colour table with four palette entries. Please note that once you select a screen to remap to, you cannot tell icon.library to use a different screen; you first need to tell icon.library to "let go" of the previously selected screen by passing a nil ICONCTRLA_SetGlobalScreen parameter. You can set a different screen only after this is done.

See also

ICONCTRLA_GetGlobalScreen

Tag for IconControlA(), Get the Screen which is used icons (^PScreen)


ICONCTRLA_SetHeight

Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 152

const ICONCTRLA_SetHeight = ICONA_Dummy + 40;

Description

Per Icon Option for IconControlA() This value must be in the range [1..256].

See also

ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONCTRLA_SetImageData1

Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)

Declaration

Source position: icon.pas line 132

const ICONCTRLA_SetImageData1 = ICONA_Dummy + 28;

Description

Per Icon Option for IconControlA() Set the image data to be used for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). There must be exactly as many bytes of image data as the image width multiplied by its height requires. To drop the palette mapped image data associated with an icon, use "ICONCTRLA_SetImageData1,nil".

See also

ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)


ICONCTRLA_SetImageData2

Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)

Declaration

Source position: icon.pas line 134

const ICONCTRLA_SetImageData2 = ICONA_Dummy + 30;

Description

Per Icon Option for IconControlA() Set the image data to be used for a palette mapped icon image, in this case the alternate icon image (icon->do_Gadget.SelectRender). There must be exactly as many bytes of image data as the image width multiplied by its height requires. To drop the palette mapped image data associated with the alternate image of an icon, use "ICONCTRLA_SetImageData1,nil".

See also

ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)


ICONCTRLA_SetNewIconsSupport

Tag for IconControlA(), Set if NewIcons support is enabled (BOOL)

Declaration

Source position: icon.pas line 142

const ICONCTRLA_SetNewIconsSupport = ICONA_Dummy + 34;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_GetNewIconsSupport

Tag for IconControlA(), Get if NewIcons support is enabled (BOOL)


ICONCTRLA_SetPalette1

Tag for IconControlA(), Set Image color palette 1 (PColorRegister)

Declaration

Source position: icon.pas line 120

const ICONCTRLA_SetPalette1 = ICONA_Dummy + 20;

Description

Per Icon Option for IconControlA() Set the colour palette for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender).

See also

ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_SetPalette2

Tag for IconControlA(), Set Image color palette 2 (PColorRegister)

Declaration

Source position: icon.pas line 122

const ICONCTRLA_SetPalette2 = ICONA_Dummy + 22;

Description

Per Icon Option for IconControlA() Set the colour palette for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender).

See also

ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_SetPaletteSize1

Tag for IconControlA(), Set Size of image color palette 1 (LongInt)

Declaration

Source position: icon.pas line 126

const ICONCTRLA_SetPaletteSize1 = ICONA_Dummy + 24;

Description

Per Icon Option for IconControlA() Set the size of the colour palette to be used for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). This value must be in the range [1..256].

See also

ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_SetPaletteSize2

Tag for IconControlA(), Set Size of image color palette 2 (LongInt)

Declaration

Source position: icon.pas line 128

const ICONCTRLA_SetPaletteSize2 = ICONA_Dummy + 26;

Description

Per Icon Option for IconControlA() Set the size of the colour palette to be used for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). This value must be in the range [1..256].

See also

ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_SetTransparentColor1

Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)

Declaration

Source position: icon.pas line 114

const ICONCTRLA_SetTransparentColor1 = ICONA_Dummy + 16;

Description

Per Icon Option for IconControlA() Set the transparent colour for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). The colour must be among the valid palette entries, e.g. for a 16 colour image, the transparent colour may not be larger than 15. To make the icon image opaque, set its transparent colour to -1.

See also

ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque


ICONCTRLA_SetTransparentColor2

Tag for IconControlA(), Set second transparent image color; set to -1 if opaque

Declaration

Source position: icon.pas line 116

const ICONCTRLA_SetTransparentColor2 = ICONA_Dummy + 18;

Description

Per Icon Option for IconControlA() Set the transparent colour for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). The colour must be among the valid palette entries, e.g. for a 16 colour image, the transparent colour may not be larger than 15. To make the icon image opaque, set its transparent colour to -1. Please note that you can set the alternate image transparent colour only if there is an alternate image.

See also

ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque


ICONCTRLA_SetWidth

Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 150

const ICONCTRLA_SetWidth = ICONA_Dummy + 38;

Description

Per Icon Option for IconControlA() This value must be in the range [1..256].

See also

ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONDRAWA_Borderless

Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding border and frame (BOOL).

Declaration

Source position: icon.pas line 323

const ICONDRAWA_Borderless = ICONA_Dummy + 83;

Description

This tag defaults to False.


ICONDRAWA_DrawInfo

Tag for DrawIconStateA() and GetIconRectangleA, Drawing information to use (PDrawInfo).

Declaration

Source position: icon.pas line 314

const ICONDRAWA_DrawInfo = ICONA_Dummy + 66;

Description

Drawing information data associated with the RastPort to draw into. The DrawInfo contents affect the colours of the border drawn around the icon image and also carry display aspect ratio information. If this tag is nil, the default rendering pens for the screen selected via IconControlA(...,ICONCTRLA_SetGlobalScreen,...); will be used instead. This tag defaults to nil.


ICONDRAWA_EraseBackground

Tag for DrawIconStateA() and GetIconRectangleA, Erase the background before drawing a frameless icon (BOOL).

Declaration

Source position: icon.pas line 320

const ICONDRAWA_EraseBackground = ICONA_Dummy + 71;

Description

This tag defaults to True.


ICONDRAWA_Frameless

Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding frame (BOOL).

Declaration

Source position: icon.pas line 317

const ICONDRAWA_Frameless = ICONA_Dummy + 70;

Description

This tag defaults to False.


ICONDRAWA_IsLink

Declaration

Source position: icon.pas line 326

const ICONDRAWA_IsLink = ICONA_Dummy + 89;


ICONDUPA_ActivateImageData

Tag for DupDiskObjectA(), If the icon to be duplicated is in fact a palette mapped icon which has never been set up to be displayed on the screen, turn the duplicate into that palette mapped icon.

Declaration

Source position: icon.pas line 307

const ICONDUPA_ActivateImageData = ICONA_Dummy + 82;

Description

If the source icon contains palette mapped image data that was never put to use (this happens if it is retrieved with the GetDiskObject() call rather than the new GetIconTagList() call), this tag will cause the image data to be analyzed and an attempt to be made to use that image data in the duplicate. The resulting icon will be remapped for display on the default screen, such as the Workbench screen.

This tag defaults to False.


ICONDUPA_DuplicateDefaultTool

Tag for DupDiskObjectA(), Duplicate the default tool.

Declaration

Source position: icon.pas line 295

const ICONDUPA_DuplicateDefaultTool = ICONA_Dummy + 63;

Description

This tag defaults to True.


ICONDUPA_DuplicateDrawerData

Tag for DupDiskObjectA(), Duplicate do_DrawerData

Declaration

Source position: icon.pas line 286

const ICONDUPA_DuplicateDrawerData = ICONA_Dummy + 60;

Description

This tag defaults to True.


ICONDUPA_DuplicateImageData

Tag for DupDiskObjectA(), Duplicate the image data (Image->ImageData) itself.

Declaration

Source position: icon.pas line 292

const ICONDUPA_DuplicateImageData = ICONA_Dummy + 62;

Description

Duplicate the icon image data; this tag works together with the ICONDUPA_DuplicateImages tag. If ICONDUPA_DuplicateImageData is set to True, you must also set ICONDUPA_DuplicateImages to True.

This tag defaults to TRUE.


ICONDUPA_DuplicateImages

Tag for DupDiskObjectA(), Duplicate the Image structures.

Declaration

Source position: icon.pas line 289

const ICONDUPA_DuplicateImages = ICONA_Dummy + 61;

Description

Duplicate the icon images; note that this DOES NOT include the associated image data. To get the image data duplicated, too, also use the ICONDUPA_DuplicateImageData tag.

This tag defaults to True.


ICONDUPA_DuplicateToolTypes

Tag for DupDiskObjectA(), Duplicate the tool types list.

Declaration

Source position: icon.pas line 298

const ICONDUPA_DuplicateToolTypes = ICONA_Dummy + 64;

Description

This tag defaults to True.


ICONDUPA_DuplicateToolWindow

Tag for DupDiskObjectA(), Duplicate the tool window.

Declaration

Source position: icon.pas line 301

const ICONDUPA_DuplicateToolWindow = ICONA_Dummy + 65;

Description

This tag defaults to True.


ICONGETA_FailIfUnavailable

Tag for GetIconTagList(), Return a default icon if the requested icon file cannot be found (BOOL).

Declaration

Source position: icon.pas line 189

const ICONGETA_FailIfUnavailable = ICONA_Dummy + 47;

Description

If there is no icon for the specified object, this tag will control how to proceed: if ICONGETA_FailIfUnavailable is set to True, NULL and an error code will be returned; if set to False, icon.library will first invoke the global identification hook (see IconControlA) and then, if necessary, provide a default icon for the object in question. This tag defaults to True.


ICONGETA_GenerateImageMasks

Tag for GetIconTagList(), Generate icon image masks (BOOL).

Declaration

Source position: icon.pas line 201

const ICONGETA_GenerateImageMasks = ICONA_Dummy + 51;

Description

When loading icons with transparent colours or backfill imagery, bit plane masks will be generated for later use with DrawIconStateA(). If you do not need these masks, set this tag to FALSE. This tag defaults to TRUE.


ICONGETA_GetDefaultName

Tag for GetIconTagList(), Retrieve default icon for the given name (PChar)

Declaration

Source position: icon.pas line 184

const ICONGETA_GetDefaultName = ICONA_Dummy + 46;

Description

Query whether this icon is associated with a file/drawer/volume or is a "fake" icon that was constructed for an object that has no icon associated with it.


ICONGETA_GetDefaultType

Tag for GetIconTagList(), Default icon type to retrieve (LongInt)

Declaration

Source position: icon.pas line 181

const ICONGETA_GetDefaultType = ICONA_Dummy + 45;

Description

Type of the default icon to retrieve; must be one of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK. If this tag is used, the "name" parameter will be ignored.


ICONGETA_GetPaletteMappedIcon

Tag for GetIconTagList(), If possible, retrieve a palette mapped icon (BOOL).

Declaration

Source position: icon.pas line 192

const ICONGETA_GetPaletteMappedIcon = ICONA_Dummy + 48;

Description

By default, icon.library will try to retrieve the palette mapped version of an icon. To change this, set the ICONGETA_GetPaletteMappedIcon tag to False. This tag defaults to True.


ICONGETA_IsDefaultIcon

Tag for GetIconTagList(), Set if the icon returned is a default icon (PLongBool).

Declaration

Source position: icon.pas line 195

const ICONGETA_IsDefaultIcon = ICONA_Dummy + 49;

Description

When retrieving an icon with the ICONGETA_FailIfUnavailable tag set to False, you may receive a default icon because there is no on-disk icon file for the object you wanted to retrieve it for. This type of default icon is also known as a "fake" icon. To find out whether you have received a fake icon, use the ICONGETA_IsDefaultIcon tag.


ICONGETA_Label

Tag for GetIconTagList(), Label text to be assigned to the icon (PChar).

Declaration

Source position: icon.pas line 204

const ICONGETA_Label = ICONA_Dummy + 52;

Description

The label text to be printed below the icon when it is put to use lateron. This parameter can be useful to figure out the type of the icon to be retrieved by the identification hook. For example, Workbench may label unreadable disk icons as "DF0:????". The identification hook could key on this and supply an appropriate icon for the disk. This tag defaults to NULL.


ICONGETA_RemapIcon

Tag for GetIconTagList(), Remap the icon to the default screen, if possible (BOOL).

Declaration

Source position: icon.pas line 198

const ICONGETA_RemapIcon = ICONA_Dummy + 50;

Description

Palette mapped icons will usually be automatically remapped for display on the screen selected using IconControlA. If you do not want this to happen because, for example, you want to use LayoutIconA instead, you can set the ICONGETA_RemapIcon tag to FALSE. Take care when doing this as the icon returned to you will have nil pointers in the do_Gadget.GadgetRender and do_Gadget.SelectRender members. This tag defaults to TRUE.


ICONGETA_Screen

Tag for GetIconTagList(), Screen to remap the icon to (PScreen).

Declaration

Source position: icon.pas line 207

const ICONGETA_Screen = ICONA_Dummy + 69;

Description

Pointer to the screen to remap the icon to; if set to nil, this keeps the icon from getting remapped in the first place (see ICONGETA_RemapIcon for the consequences). This tag defaults to the default screen to remap to, as preset by IconControlA().


ICONNAME

Icon library name

Declaration

Source position: icon.pas line 347

const ICONNAME: PChar = 'icon.library';


ICONPUTA_DropChunkyIconImage

Tag for PutIconTagList(), Don't write the chunky icon image data to disk. (BOOL)

Declaration

Source position: icon.pas line 229

const ICONPUTA_DropChunkyIconImage = ICONA_Dummy + 57;

Description

This tag can be used to keep the chunky icon image data from getting written to disk. This tag defaults to FALSE.


ICONPUTA_DropNewIconToolTypes

Tag for PutIconTagList(), Don't write the NewIcons tool types to disk. (BOOL)

Declaration

Source position: icon.pas line 232

const ICONPUTA_DropNewIconToolTypes = ICONA_Dummy + 58;

Description

This tag controls whether any NewIcon tool types will be omitted when writing the icon to disk. TRUE will omit the data. This tag defaults to FALSE.


ICONPUTA_DropPlanarIconImage

Tag for PutIconTagList(), Do not store planar icon image (BOOL)

Declaration

Source position: icon.pas line 226

const ICONPUTA_DropPlanarIconImage = ICONA_Dummy + 56;

Description

If you decide that the palette mapped icon imagery is sufficient to represent an icon, you can tell icon.library not to store the original, planar icon image data with the icon file. To do this, set this tag to True. Instead of the planar icon images, a single default image will be stored. This can result in space savings but may not look too pretty. This tag defaults to False.


ICONPUTA_NotifyWorkbench

Tag for PutIconTagList(), Notify Workbench of the icon being written (BOOL)

Declaration

Source position: icon.pas line 214

const ICONPUTA_NotifyWorkbench = ICONA_Dummy + 53;

Description

Set this to True to notify Workbench of the fact that an icon was changed. This tag defaults to False.


ICONPUTA_OnlyUpdatePosition

Tag for PutIconTagList(), Write only new position. (Bool)

Declaration

Source position: icon.pas line 245

const ICONPUTA_OnlyUpdatePosition = ICONA_Dummy + 72;

Description

This tag can be used to reduce the overhead in updating icon information on disk if the only information changed is the icon position. For this case, you can set this tag to TRUE. The icon to be modified will have only its do_CurrentX/do_CurrentY member values changed, the remainer will stay unmodified. Please note that this tag only takes effect if the ICONPUTA_PutDefaultType and ICONPUTA_PutDefaultName tags are omitted.


ICONPUTA_OptimizeImageSpace

Tag for PutIconTagList(), Try to compress image data (BOOL)

Declaration

Source position: icon.pas line 239

const ICONPUTA_OptimizeImageSpace = ICONA_Dummy + 59;

Description

A palette mapped icon image might not use the entire icon palette. By default, icon.library does not bother about this, it expects the creator of the icon to choose its palette efficiently. But just in case, you can tell icon.library to attempt to identify how many colours are really in use and to optimize its image compressor for them. This may take extra time and is not recommended for daily use. This tag defaults to False.


ICONPUTA_PreserveOldIconImages

Tag for PutIconTagList(), Save old image before writing (BOOL)

Declaration

Source position: icon.pas line 254

const ICONPUTA_PreserveOldIconImages = ICONA_Dummy + 84;

Description

Before writing a palette mapped icon back to disk, icon.library will make sure that the original planar image data is stored in the file. If you don't want that to happen, set this option to False. This will allow you to change the planar icon image data written back to disk.


ICONPUTA_PutDefaultName

Tag for PutIconTagList(), Store icon as a default for the given name (PChar)

Declaration

Source position: icon.pas line 220

const ICONPUTA_PutDefaultName = ICONA_Dummy + 55;

Description

Name of the default object type this icon is to be stored as. If this tag is used, the "name" parameter will be ignored.


ICONPUTA_PutDefaultType

Tag for PutIconTagList(), Store icon as the default for this type (LongInt)

Declaration

Source position: icon.pas line 217

const ICONPUTA_PutDefaultType = ICONA_Dummy + 54;

Description

Type of the default icon to retrieve; must be one of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK. If this tag is used, the "name" parameter will be ignored.


Reference for unit 'icon'

Icon handling routines (icon.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
workbench, | Basic Workbench/AppIcons functions (workbench.library)
utility, | Tag Handling, Date routines in utility.library
AmigaDOS, | File and directory handling routines and types (dos.library)
agraphics, | Native Amiga graphic functions (graphics.library)
intuition, | Screen and Window handling routines of intuition.library
datatypes;

Overview

Functions and structures to work with Icons.


Reference for unit 'icon': Constants

ICONA_Dummy | Start of icon.library tags
ICONA_ErrorCode | Errorcode (PLongInt)
ICONA_ErrorTagItem | Points to the tag item that caused the error (^PTagItem)
ICONA_LAST_TAG | The last Tag of icon.library
ICONA_Reserved1 | Reserved tag; don't use!
ICONA_Reserved2 | Reserved tag; don't use!
ICONA_Reserved3 | Reserved tag; don't use!
ICONA_Reserved4 | Reserved tag; don't use!
ICONA_Reserved5 | Reserved tag; don't use!
ICONA_Reserved6 | Reserved tag; don't use!
ICONA_Reserved7 | Reserved tag; don't use!
ICONA_Reserved8 | Reserved tag; don't use!
ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
ICONCTRLA_GetFrameless | Tag for IconControlA(), Get if rendered without frame (BOOL)
ICONCTRLA_GetGlobalColorIconSupport | Tag for IconControlA(), Get Status of color icon support (BOOL)
ICONCTRLA_GetGlobalEmbossRect | Tag for IconControlA(), Get Icon frame size dimensions (PRectange)
ICONCTRLA_GetGlobalFrameless | Tag for IconControlA(), Get if images are rendered without frame (BOOL)
ICONCTRLA_GetGlobalIdentifyHook | Tag for IconControlA(), Get the hook to be called when identifying a file (Utility.PHook)
ICONCTRLA_GetGlobalMaxNameLength | Tag for IconControlA(), Get the maximum length of a file/drawer name supported by icon.library (LONG).
ICONCTRLA_GetGlobalNewIconsSupport | Tag for IconControlA(), Get Status of NewIcons support (BOOL)
ICONCTRLA_GetGlobalPrecision | Tag for IconControlA(), Get Icon color remapping precision (PLongInt)
ICONCTRLA_GetGlobalScreen | Tag for IconControlA(), Get the Screen which is used icons (^PScreen)
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)
ICONCTRLA_GetImageMask1 | Tag for IconControlA(), Get the icon rendering mask 1 (PLANEPTR)
ICONCTRLA_GetImageMask2 | Tag for IconControlA(), Get the icon rendering mask 2 (PLANEPTR)
ICONCTRLA_GetNewIconsSupport | Tag for IconControlA(), Get if NewIcons support is enabled (BOOL)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetScreen | Tag for IconControlA(), Get the screen the icon is attached to (^PScreen).
ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque
ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_HasRealImage2 | Tag for IconControlA(), Check whether the icon has a real select image (PLongInt).
ICONCTRLA_IsNativeIcon | Tag for IconControlA(), Check whether this icon was allocated by icon.library or if consists solely of a statically allocated struct DiskObject. (PLongInt).
ICONCTRLA_IsNewIcon | Tag for IconControlA(), Check whether the icon is of the NewIcon type (PLongInt).
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).
ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
ICONCTRLA_SetFrameless | Tag for IconControlA(), Set if rendered without frame (BOOL)
ICONCTRLA_SetGlobalColorIconSupport | Tag for IconControlA(), Enable color icon support (BOOL)
ICONCTRLA_SetGlobalEmbossRect | Tag for IconControlA(), Icon frame size dimensions (PRectange)
ICONCTRLA_SetGlobalFrameless | Tag for IconControlA(), Render image without frame (BOOL)
ICONCTRLA_SetGlobalIdentifyHook | Tag for IconControlA(), Set the hook to be called when identifying a file (Utility.PHook)
ICONCTRLA_SetGlobalMaxNameLength | Tag for IconControlA(), Set the maximum length of a file/drawer name supported by icon.library (LONG).
ICONCTRLA_SetGlobalNewIconsSupport | Tag for IconControlA(), Enable NewIcons support (BOOL)
ICONCTRLA_SetGlobalPrecision | Tag for IconControlA(), Icon color remapping precision (LongInt)
ICONCTRLA_SetGlobalScreen | Tag for IconControlA(), Screen to use for remapping Workbench icons to (PScreen)
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)
ICONCTRLA_SetNewIconsSupport | Tag for IconControlA(), Set if NewIcons support is enabled (BOOL)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque
ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONDRAWA_Borderless | Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding border and frame (BOOL).
ICONDRAWA_DrawInfo | Tag for DrawIconStateA() and GetIconRectangleA, Drawing information to use (PDrawInfo).
ICONDRAWA_EraseBackground | Tag for DrawIconStateA() and GetIconRectangleA, Erase the background before drawing a frameless icon (BOOL).
ICONDRAWA_Frameless | Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding frame (BOOL).
ICONDRAWA_IsLink |
ICONDUPA_ActivateImageData | Tag for DupDiskObjectA(), If the icon to be duplicated is in fact a palette mapped icon which has never been set up to be displayed on the screen, turn the duplicate into that palette mapped icon.
ICONDUPA_DuplicateDefaultTool | Tag for DupDiskObjectA(), Duplicate the default tool.
ICONDUPA_DuplicateDrawerData | Tag for DupDiskObjectA(), Duplicate do_DrawerData
ICONDUPA_DuplicateImageData | Tag for DupDiskObjectA(), Duplicate the image data (Image->ImageData) itself.
ICONDUPA_DuplicateImages | Tag for DupDiskObjectA(), Duplicate the Image structures.
ICONDUPA_DuplicateToolTypes | Tag for DupDiskObjectA(), Duplicate the tool types list.
ICONDUPA_DuplicateToolWindow | Tag for DupDiskObjectA(), Duplicate the tool window.
ICONGETA_FailIfUnavailable | Tag for GetIconTagList(), Return a default icon if the requested icon file cannot be found (BOOL).
ICONGETA_GenerateImageMasks | Tag for GetIconTagList(), Generate icon image masks (BOOL).
ICONGETA_GetDefaultName | Tag for GetIconTagList(), Retrieve default icon for the given name (PChar)
ICONGETA_GetDefaultType | Tag for GetIconTagList(), Default icon type to retrieve (LongInt)
ICONGETA_GetPaletteMappedIcon | Tag for GetIconTagList(), If possible, retrieve a palette mapped icon (BOOL).
ICONGETA_IsDefaultIcon | Tag for GetIconTagList(), Set if the icon returned is a default icon (PLongBool).
ICONGETA_Label | Tag for GetIconTagList(), Label text to be assigned to the icon (PChar).
ICONGETA_RemapIcon | Tag for GetIconTagList(), Remap the icon to the default screen, if possible (BOOL).
ICONGETA_Screen | Tag for GetIconTagList(), Screen to remap the icon to (PScreen).
ICONNAME | Icon library name
ICONPUTA_DropChunkyIconImage | Tag for PutIconTagList(), Don't write the chunky icon image data to disk. (BOOL)
ICONPUTA_DropNewIconToolTypes | Tag for PutIconTagList(), Don't write the NewIcons tool types to disk. (BOOL)
ICONPUTA_DropPlanarIconImage | Tag for PutIconTagList(), Do not store planar icon image (BOOL)
ICONPUTA_NotifyWorkbench | Tag for PutIconTagList(), Notify Workbench of the icon being written (BOOL)
ICONPUTA_OnlyUpdatePosition | Tag for PutIconTagList(), Write only new position. (Bool)
ICONPUTA_OptimizeImageSpace | Tag for PutIconTagList(), Try to compress image data (BOOL)
ICONPUTA_PreserveOldIconImages | Tag for PutIconTagList(), Save old image before writing (BOOL)
ICONPUTA_PutDefaultName | Tag for PutIconTagList(), Store icon as a default for the given name (PChar)
ICONPUTA_PutDefaultType | Tag for PutIconTagList(), Store icon as the default for this type (LongInt)
ICON_ASPECT_RATIO_UNKNOWN | Icon aspect ratio is not known.


Reference for unit 'icon': Types

PIconIdentifyMsg | Pointer to file identification structure
tIconIdentifyMsg | Tag for use with the file identification hook.


PIconIdentifyMsg

Pointer to file identification structure

Declaration

Source position: icon.pas line 261

type PIconIdentifyMsg = ^tIconIdentifyMsg;


tIconIdentifyMsg

Tag for use with the file identification hook.

Declaration

Source position: icon.pas line 262

type tIconIdentifyMsg = record
iim_SysBase: PLibrary; | ExecBase already opened for your use
iim_DOSBase: PLibrary; | DosBase already opened for your use
iim_UtilityBase: PLibrary; | Utility Base already opened for your use
iim_IconBase: PLibrary; | IconBase already opened for your use
iim_FileLock: LongInt; | Lock on the object to return an icon for.
iim_ParentLock: LongInt; | Lock on the object's parent directory, if available.
iim_FIB: PFileInfoBlock; | Already initialized for you.
iim_FileHandle: LongInt; | If non-NULL, pointer to the file to examine, positioned right at the first byte, ready for you to use.
iim_Tags: PTagItem; | Tags passed to GetIconTagList().
end;


ID_CAT

Declaration

Source position: iffparse.pas line 166

const ID_CAT = 1128354848;


ID_FORM

Declaration

Source position: iffparse.pas line 164

const ID_FORM = 1179603533;


ID_LIST

Declaration

Source position: iffparse.pas line 165

const ID_LIST = 1279873876;


ID_NULL

Declaration

Source position: iffparse.pas line 168

const ID_NULL = 538976288;


ID_PROP

Declaration

Source position: iffparse.pas line 167

const ID_PROP = 1347571536;


IFF_RETURN2CLIENT

Declaration

Source position: iffparse.pas line 155

const IFF_RETURN2CLIENT = - 12;


IFFCMD_CLEANUP

Declaration

Source position: iffparse.pas line 206

const IFFCMD_CLEANUP = 1;


IFFCMD_ENTRY

Declaration

Source position: iffparse.pas line 210

const IFFCMD_ENTRY = 5;


IFFCMD_EXIT

Declaration

Source position: iffparse.pas line 211

const IFFCMD_EXIT = 6;


IFFCMD_INIT

Declaration

Source position: iffparse.pas line 205

const IFFCMD_INIT = 0;


IFFCMD_PURGELCI

Declaration

Source position: iffparse.pas line 212

const IFFCMD_PURGELCI = 7;


IFFCMD_READ

Declaration

Source position: iffparse.pas line 207

const IFFCMD_READ = 2;


IFFCMD_SEEK

Declaration

Source position: iffparse.pas line 209

const IFFCMD_SEEK = 4;


IFFCMD_WRITE

Declaration

Source position: iffparse.pas line 208

const IFFCMD_WRITE = 3;


IFFERR_EOC

Declaration

Source position: iffparse.pas line 145

const IFFERR_EOC = - 2;


IFFERR_EOF

Declaration

Source position: iffparse.pas line 144

const IFFERR_EOF = - 1;


IFFERR_MANGLED

Declaration

Source position: iffparse.pas line 151

const IFFERR_MANGLED = - 8;


IFFERR_NOHOOK

Declaration

Source position: iffparse.pas line 154

const IFFERR_NOHOOK = - 11;


IFFERR_NOMEM

Declaration

Source position: iffparse.pas line 147

const IFFERR_NOMEM = - 4;


IFFERR_NOSCOPE

Declaration

Source position: iffparse.pas line 146

const IFFERR_NOSCOPE = - 3;


IFFERR_NOTIFF

Declaration

Source position: iffparse.pas line 153

const IFFERR_NOTIFF = - 10;


IFFERR_READ

Declaration

Source position: iffparse.pas line 148

const IFFERR_READ = - 5;


IFFERR_SEEK

Declaration

Source position: iffparse.pas line 150

const IFFERR_SEEK = - 7;


IFFERR_SYNTAX

Declaration

Source position: iffparse.pas line 152

const IFFERR_SYNTAX = - 9;


IFFERR_WRITE

Declaration

Source position: iffparse.pas line 149

const IFFERR_WRITE = - 6;


IFFF_FSEEK

Declaration

Source position: iffparse.pas line 56

const IFFF_FSEEK = 2;


IFFF_READ

Declaration

Source position: iffparse.pas line 53

const IFFF_READ = 0;


IFFF_RESERVED

Declaration

Source position: iffparse.pas line 58

const IFFF_RESERVED = $FFFF0000;


IFFF_RSEEK

Declaration

Source position: iffparse.pas line 57

const IFFF_RSEEK = 4;


IFFF_RWBITS

Declaration

Source position: iffparse.pas line 55

const IFFF_RWBITS = IFFF_READ + IFFF_WRITE;


IFFF_WRITE

Declaration

Source position: iffparse.pas line 54

const IFFF_WRITE = 1;


IFFLCI_COLLECTION

Declaration

Source position: iffparse.pas line 174

const IFFLCI_COLLECTION = 1668246636;


IFFLCI_ENTRYHANDLER

Declaration

Source position: iffparse.pas line 175

const IFFLCI_ENTRYHANDLER = 1701734500;


IFFLCI_EXITHANDLER

Declaration

Source position: iffparse.pas line 176

const IFFLCI_EXITHANDLER = 1702389860;


IFFLCI_PROP

Declaration

Source position: iffparse.pas line 173

const IFFLCI_PROP = 1886547824;


IFFOFFSET_BEGINNING

Declaration

Source position: iffparse.pas line 222

const IFFOFFSET_BEGINNING = 0;


IFFOFFSET_CURRENT

Declaration

Source position: iffparse.pas line 224

const IFFOFFSET_CURRENT = 2;


IFFOFFSET_END

Declaration

Source position: iffparse.pas line 223

const IFFOFFSET_END = 1;


IFFPARSE_RAWSTEP

Declaration

Source position: iffparse.pas line 184

const IFFPARSE_RAWSTEP = 2;


IFFPARSE_SCAN

Declaration

Source position: iffparse.pas line 182

const IFFPARSE_SCAN = 0;


IFFPARSE_STEP

Declaration

Source position: iffparse.pas line 183

const IFFPARSE_STEP = 1;


IFFParseBase

Declaration

Source position: iffparse.pas line 226

var IFFParseBase: PLibrary = Nil;


IFFPARSENAME

Declaration

Source position: iffparse.pas line 32

const IFFPARSENAME: PChar = 'iffparse.library';


IFFSCC_CLEANUP

Declaration

Source position: iffparse.pas line 216

const IFFSCC_CLEANUP = IFFCMD_CLEANUP;


IFFSCC_INIT

Declaration

Source position: iffparse.pas line 215

const IFFSCC_INIT = IFFCMD_INIT;


IFFSCC_READ

Declaration

Source position: iffparse.pas line 217

const IFFSCC_READ = IFFCMD_READ;


IFFSCC_SEEK

Declaration

Source position: iffparse.pas line 219

const IFFSCC_SEEK = IFFCMD_SEEK;


IFFSCC_WRITE

Declaration

Source position: iffparse.pas line 218

const IFFSCC_WRITE = IFFCMD_WRITE;


IFFSIZE_UNKNOWN

Declaration

Source position: iffparse.pas line 199

const IFFSIZE_UNKNOWN = - 1;


IFFSLI_PROP

Declaration

Source position: iffparse.pas line 191

const IFFSLI_PROP = 3;


IFFSLI_ROOT

Declaration

Source position: iffparse.pas line 189

const IFFSLI_ROOT = 1;


IFFSLI_TOP

Declaration

Source position: iffparse.pas line 190

const IFFSLI_TOP = 2;


Reference for unit 'iffparse'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
clipboard,
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'iffparse': Constants

ID_CAT

ID_FORM

ID_LIST

ID_NULL

ID_PROP

IFFCMD_CLEANUP

IFFCMD_ENTRY

IFFCMD_EXIT

IFFCMD_INIT

IFFCMD_PURGELCI

IFFCMD_READ

IFFCMD_SEEK

IFFCMD_WRITE

IFFERR_EOC

IFFERR_EOF

IFFERR_MANGLED

IFFERR_NOHOOK

IFFERR_NOMEM

IFFERR_NOSCOPE

IFFERR_NOTIFF

IFFERR_READ

IFFERR_SEEK

IFFERR_SYNTAX

IFFERR_WRITE

IFFF_FSEEK

IFFF_READ

IFFF_RESERVED

IFFF_RSEEK

IFFF_RWBITS

IFFF_WRITE

IFFLCI_COLLECTION

IFFLCI_ENTRYHANDLER

IFFLCI_EXITHANDLER

IFFLCI_PROP

IFFOFFSET_BEGINNING

IFFOFFSET_CURRENT

IFFOFFSET_END

IFFPARSENAME

IFFPARSE_RAWSTEP

IFFPARSE_SCAN

IFFPARSE_STEP

IFFSCC_CLEANUP

IFFSCC_INIT

IFFSCC_READ

IFFSCC_SEEK

IFFSCC_WRITE

IFFSIZE_UNKNOWN

IFFSLI_PROP

IFFSLI_ROOT

IFFSLI_TOP

IFF_RETURN2CLIENT


Reference for unit 'iffparse': Types

pClipboardHandle

pCollectionItem

pContextNode

pIFFHandle

pIFFStreamCmd

pLocalContextItem

pStoredProperty

tClipboardHandle

tCollectionItem

tContextNode

tIFFHandle

tIFFStreamCmd

tLocalContextItem

tStoredProperty


pClipboardHandle

Declaration

Source position: iffparse.pas line 129

type pClipboardHandle = ^tClipBoardHandle;


pCollectionItem

Declaration

Source position: iffparse.pas line 117

type pCollectionItem = ^tCollectionItem;


pContextNode

Declaration

Source position: iffparse.pas line 78

type pContextNode = ^tContextNode;


pIFFHandle

Declaration

Source position: iffparse.pas line 41

type pIFFHandle = ^tIFFHandle;


pIFFStreamCmd

Declaration

Source position: iffparse.pas line 65

type pIFFStreamCmd = ^tIFFStreamCmd;


pLocalContextItem

Declaration

Source position: iffparse.pas line 93

type pLocalContextItem = ^tLocalContextItem;


pStoredProperty

Declaration

Source position: iffparse.pas line 106

type pStoredProperty = ^tStoredProperty;


tClipboardHandle

Declaration

Source position: iffparse.pas line 130

type tClipboardHandle = record

  cbh_Req: tIOClipReq;

  cbh_CBport: TMsgPort;

  cbh_SatisfyPort: TMsgPort;

end;


tCollectionItem

Declaration

Source position: iffparse.pas line 118

type tCollectionItem = record

  ci_Next: pCollectionItem;

  ci_Size: LongInt;

  ci_Data: Pointer;

end;


tContextNode

Declaration

Source position: iffparse.pas line 79

type tContextNode = record

  cn_Node: TMinNode;

  cn_ID: LongInt;

  cn_Type: LongInt;

  cn_Size: LongInt;

  cn_Scan: LongInt;

end;


tIFFHandle

Declaration

Source position: iffparse.pas line 42

type tIFFHandle = record

  iff_Stream: DWord;

  iff_Flags: DWord;

  iff_Depth: LongInt;

end;


tIFFStreamCmd

Declaration

Source position: iffparse.pas line 66

type tIFFStreamCmd = record

  sc_Command: LongInt;

  sc_Buf: Pointer;

  sc_NBytes: LongInt;

end;


tLocalContextItem

Declaration

Source position: iffparse.pas line 94

type tLocalContextItem = record

  lci_Node: TMinNode;

  lci_ID: DWord;

  lci_Type: DWord;

  lci_Ident: DWord;

end;


tStoredProperty

Declaration

Source position: iffparse.pas line 107

type tStoredProperty = record

  sp_Size: LongInt;

  sp_Data: Pointer;

end;


IND_ADDHANDLER

Declaration

Source position: input.pas line 34

const IND_ADDHANDLER = CMD_NONSTD + 0;


IND_REMHANDLER

Declaration

Source position: input.pas line 35

const IND_REMHANDLER = CMD_NONSTD + 1;


IND_SETMPORT

Declaration

Source position: input.pas line 39

const IND_SETMPORT = CMD_NONSTD + 5;


IND_SETMTRIG

Declaration

Source position: input.pas line 41

const IND_SETMTRIG = CMD_NONSTD + 7;


IND_SETMTYPE

Declaration

Source position: input.pas line 40

const IND_SETMTYPE = CMD_NONSTD + 6;


IND_SETPERIOD

Declaration

Source position: input.pas line 38

const IND_SETPERIOD = CMD_NONSTD + 4;


IND_SETTHRESH

Declaration

Source position: input.pas line 37

const IND_SETTHRESH = CMD_NONSTD + 3;


IND_WRITEEVENT

Declaration

Source position: input.pas line 36

const IND_WRITEEVENT = CMD_NONSTD + 2;


Reference for unit 'input'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'input': Constants

IND_ADDHANDLER

IND_REMHANDLER

IND_SETMPORT

IND_SETMTRIG

IND_SETMTYPE

IND_SETPERIOD

IND_SETTHRESH

IND_WRITEEVENT


InputBase

Declaration

Source position: input.pas line 45

var InputBase: PDevice;


IECLASS_ACTIVEWINDOW

Declaration

Source position: inputevent.pas line 48

const IECLASS_ACTIVEWINDOW = $11;


IECLASS_CHANGEWINDOW

Declaration

Source position: inputevent.pas line 52

const IECLASS_CHANGEWINDOW = $15;


IECLASS_CLOSEWINDOW

Declaration

Source position: inputevent.pas line 42

const IECLASS_CLOSEWINDOW = $0B;


IECLASS_DISKINSERTED

Declaration

Source position: inputevent.pas line 47

const IECLASS_DISKINSERTED = $10;


IECLASS_DISKREMOVED

Declaration

Source position: inputevent.pas line 46

const IECLASS_DISKREMOVED = $0F;


IECLASS_EVENT

Declaration

Source position: inputevent.pas line 35

const IECLASS_EVENT = $03;


IECLASS_GADGETDOWN

Declaration

Source position: inputevent.pas line 38

const IECLASS_GADGETDOWN = $07;


IECLASS_GADGETUP

Declaration

Source position: inputevent.pas line 39

const IECLASS_GADGETUP = $08;


IECLASS_INACTIVEWINDOW

Declaration

Source position: inputevent.pas line 49

const IECLASS_INACTIVEWINDOW = $12;


IECLASS_MAX

Declaration

Source position: inputevent.pas line 61

const IECLASS_MAX = $16;


IECLASS_MENUHELP

Declaration

Source position: inputevent.pas line 51

const IECLASS_MENUHELP = $14;


IECLASS_MENULIST

Declaration

Source position: inputevent.pas line 41

const IECLASS_MENULIST = $0A;


IECLASS_NEWMOUSE

Declaration

Source position: inputevent.pas line 56

const IECLASS_NEWMOUSE = $16;


IECLASS_NEWPOINTERPOS

Declaration

Source position: inputevent.pas line 50

const IECLASS_NEWPOINTERPOS = $13;


IECLASS_NEWPREFS

Declaration

Source position: inputevent.pas line 45

const IECLASS_NEWPREFS = $0E;


IECLASS_NULL

Declaration

Source position: inputevent.pas line 32

const IECLASS_NULL = $00;


IECLASS_POINTERPOS

Declaration

Source position: inputevent.pas line 36

const IECLASS_POINTERPOS = $04;


IECLASS_RAWKEY

Declaration

Source position: inputevent.pas line 33

const IECLASS_RAWKEY = $01;


IECLASS_RAWMOUSE

Declaration

Source position: inputevent.pas line 34

const IECLASS_RAWMOUSE = $02;


IECLASS_REFRESHWINDOW

Declaration

Source position: inputevent.pas line 44

const IECLASS_REFRESHWINDOW = $0D;


IECLASS_REQUESTER

Declaration

Source position: inputevent.pas line 40

const IECLASS_REQUESTER = $09;


IECLASS_SIZEWINDOW

Declaration

Source position: inputevent.pas line 43

const IECLASS_SIZEWINDOW = $0C;


IECLASS_TIMER

Declaration

Source position: inputevent.pas line 37

const IECLASS_TIMER = $06;


IECODE_ASCII_DEL

Declaration

Source position: inputevent.pas line 115

const IECODE_ASCII_DEL = $7F;


IECODE_ASCII_FIRST

Declaration

Source position: inputevent.pas line 113

const IECODE_ASCII_FIRST = $20;


IECODE_ASCII_LAST

Declaration

Source position: inputevent.pas line 114

const IECODE_ASCII_LAST = $7E;


IECODE_C0_FIRST

Declaration

Source position: inputevent.pas line 111

const IECODE_C0_FIRST = $00;


IECODE_C0_LAST

Declaration

Source position: inputevent.pas line 112

const IECODE_C0_LAST = $1F;


IECODE_C1_FIRST

Declaration

Source position: inputevent.pas line 116

const IECODE_C1_FIRST = $80;


IECODE_C1_LAST

Declaration

Source position: inputevent.pas line 117

const IECODE_C1_LAST = $9F;


IECODE_COMM_CODE_FIRST

Declaration

Source position: inputevent.pas line 109

const IECODE_COMM_CODE_FIRST = $78;


IECODE_COMM_CODE_LAST

Declaration

Source position: inputevent.pas line 110

const IECODE_COMM_CODE_LAST = $7F;


IECODE_KEY_CODE_FIRST

Declaration

Source position: inputevent.pas line 107

const IECODE_KEY_CODE_FIRST = $00;


IECODE_KEY_CODE_LAST

Declaration

Source position: inputevent.pas line 108

const IECODE_KEY_CODE_LAST = $77;


IECODE_LATIN1_FIRST

Declaration

Source position: inputevent.pas line 118

const IECODE_LATIN1_FIRST = $A0;


IECODE_LATIN1_LAST

Declaration

Source position: inputevent.pas line 119

const IECODE_LATIN1_LAST = $FF;


IECODE_LBUTTON

Declaration

Source position: inputevent.pas line 120

const IECODE_LBUTTON = $68;


IECODE_MBUTTON

Declaration

Source position: inputevent.pas line 122

const IECODE_MBUTTON = $6A;


IECODE_NEWACTIVE

Declaration

Source position: inputevent.pas line 124

const IECODE_NEWACTIVE = $01;


IECODE_NEWSIZE

Declaration

Source position: inputevent.pas line 125

const IECODE_NEWSIZE = $02;


IECODE_NOBUTTON

Declaration

Source position: inputevent.pas line 123

const IECODE_NOBUTTON = $FF;


IECODE_RBUTTON

Declaration

Source position: inputevent.pas line 121

const IECODE_RBUTTON = $69;


IECODE_REFRESH

Declaration

Source position: inputevent.pas line 126

const IECODE_REFRESH = $03;


IECODE_REQCLEAR

Declaration

Source position: inputevent.pas line 128

const IECODE_REQCLEAR = $00;


IECODE_REQSET

Declaration

Source position: inputevent.pas line 127

const IECODE_REQSET = $01;


IECODE_UP_PREFIX

Declaration

Source position: inputevent.pas line 106

const IECODE_UP_PREFIX = $80;


IEQUALIFIER_CAPSLOCK

Declaration

Source position: inputevent.pas line 131

const IEQUALIFIER_CAPSLOCK = $0004;


IEQUALIFIER_CONTROL

Declaration

Source position: inputevent.pas line 132

const IEQUALIFIER_CONTROL = $0008;


IEQUALIFIER_INTERRUPT

Declaration

Source position: inputevent.pas line 139

const IEQUALIFIER_INTERRUPT = $0400;


IEQUALIFIER_LALT

Declaration

Source position: inputevent.pas line 133

const IEQUALIFIER_LALT = $0010;


IEQUALIFIER_LCOMMAND

Declaration

Source position: inputevent.pas line 135

const IEQUALIFIER_LCOMMAND = $0040;


IEQUALIFIER_LEFTBUTTON

Declaration

Source position: inputevent.pas line 143

const IEQUALIFIER_LEFTBUTTON = $4000;


IEQUALIFIER_LSHIFT

Declaration

Source position: inputevent.pas line 129

const IEQUALIFIER_LSHIFT = $0001;


IEQUALIFIER_MIDBUTTON

Declaration

Source position: inputevent.pas line 141

const IEQUALIFIER_MIDBUTTON = $1000;


IEQUALIFIER_MULTIBROADCAST

Declaration

Source position: inputevent.pas line 140

const IEQUALIFIER_MULTIBROADCAST = $0800;


IEQUALIFIER_NUMERICPAD

Declaration

Source position: inputevent.pas line 137

const IEQUALIFIER_NUMERICPAD = $0100;


IEQUALIFIER_RALT

Declaration

Source position: inputevent.pas line 134

const IEQUALIFIER_RALT = $0020;


IEQUALIFIER_RBUTTON

Declaration

Source position: inputevent.pas line 142

const IEQUALIFIER_RBUTTON = $2000;


IEQUALIFIER_RCOMMAND

Declaration

Source position: inputevent.pas line 136

const IEQUALIFIER_RCOMMAND = $0080;


IEQUALIFIER_RELATIVEMOUSE

Declaration

Source position: inputevent.pas line 144

const IEQUALIFIER_RELATIVEMOUSE = $8000;


IEQUALIFIER_REPEAT

Declaration

Source position: inputevent.pas line 138

const IEQUALIFIER_REPEAT = $0200;


IEQUALIFIER_RSHIFT

Declaration

Source position: inputevent.pas line 130

const IEQUALIFIER_RSHIFT = $0002;


IEQUALIFIERB_CAPSLOCK

Declaration

Source position: inputevent.pas line 147

const IEQUALIFIERB_CAPSLOCK = 2;


IEQUALIFIERB_CONTROL

Declaration

Source position: inputevent.pas line 148

const IEQUALIFIERB_CONTROL = 3;


IEQUALIFIERB_INTERRUPT

Declaration

Source position: inputevent.pas line 155

const IEQUALIFIERB_INTERRUPT = 10;


IEQUALIFIERB_LALT

Declaration

Source position: inputevent.pas line 149

const IEQUALIFIERB_LALT = 4;


IEQUALIFIERB_LCOMMAND

Declaration

Source position: inputevent.pas line 151

const IEQUALIFIERB_LCOMMAND = 6;


IEQUALIFIERB_LEFTBUTTON

Declaration

Source position: inputevent.pas line 159

const IEQUALIFIERB_LEFTBUTTON = 14;


IEQUALIFIERB_LSHIFT

Declaration

Source position: inputevent.pas line 145

const IEQUALIFIERB_LSHIFT = 0;


IEQUALIFIERB_MIDBUTTON

Declaration

Source position: inputevent.pas line 157

const IEQUALIFIERB_MIDBUTTON = 12;


IEQUALIFIERB_MULTIBROADCAST

Declaration

Source position: inputevent.pas line 156

const IEQUALIFIERB_MULTIBROADCAST = 11;


IEQUALIFIERB_NUMERICPAD

Declaration

Source position: inputevent.pas line 153

const IEQUALIFIERB_NUMERICPAD = 8;


IEQUALIFIERB_RALT

Declaration

Source position: inputevent.pas line 150

const IEQUALIFIERB_RALT = 5;


IEQUALIFIERB_RBUTTON

Declaration

Source position: inputevent.pas line 158

const IEQUALIFIERB_RBUTTON = 13;


IEQUALIFIERB_RCOMMAND

Declaration

Source position: inputevent.pas line 152

const IEQUALIFIERB_RCOMMAND = 7;


IEQUALIFIERB_RELATIVEMOUSE

Declaration

Source position: inputevent.pas line 160

const IEQUALIFIERB_RELATIVEMOUSE = 15;


IEQUALIFIERB_REPEAT

Declaration

Source position: inputevent.pas line 154

const IEQUALIFIERB_REPEAT = 9;


IEQUALIFIERB_RSHIFT

Declaration

Source position: inputevent.pas line 146

const IEQUALIFIERB_RSHIFT = 1;


IESUBCLASS_COMPATIBLE

Declaration

Source position: inputevent.pas line 62

const IESUBCLASS_COMPATIBLE = $00;


IESUBCLASS_NEWTABLET

Declaration

Source position: inputevent.pas line 65

const IESUBCLASS_NEWTABLET = $03;


IESUBCLASS_PIXEL

Declaration

Source position: inputevent.pas line 63

const IESUBCLASS_PIXEL = $01;


IESUBCLASS_TABLET

Declaration

Source position: inputevent.pas line 64

const IESUBCLASS_TABLET = $02;


Reference for unit 'inputevent'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility, | Tag Handling, Date routines in utility.library
timer;


Reference for unit 'inputevent': Constants

IECLASS_ACTIVEWINDOW

IECLASS_CHANGEWINDOW

IECLASS_CLOSEWINDOW

IECLASS_DISKINSERTED

IECLASS_DISKREMOVED

IECLASS_EVENT

IECLASS_GADGETDOWN

IECLASS_GADGETUP

IECLASS_INACTIVEWINDOW

IECLASS_MAX

IECLASS_MENUHELP

IECLASS_MENULIST

IECLASS_NEWMOUSE

IECLASS_NEWPOINTERPOS

IECLASS_NEWPREFS

IECLASS_NULL

IECLASS_POINTERPOS

IECLASS_RAWKEY

IECLASS_RAWMOUSE

IECLASS_REFRESHWINDOW

IECLASS_REQUESTER

IECLASS_SIZEWINDOW

IECLASS_TIMER

IECODE_ASCII_DEL

IECODE_ASCII_FIRST

IECODE_ASCII_LAST

IECODE_C0_FIRST

IECODE_C0_LAST

IECODE_C1_FIRST

IECODE_C1_LAST

IECODE_COMM_CODE_FIRST

IECODE_COMM_CODE_LAST

IECODE_KEY_CODE_FIRST

IECODE_KEY_CODE_LAST

IECODE_LATIN1_FIRST

IECODE_LATIN1_LAST

IECODE_LBUTTON

IECODE_MBUTTON

IECODE_NEWACTIVE

IECODE_NEWSIZE

IECODE_NOBUTTON

IECODE_RBUTTON

IECODE_REFRESH

IECODE_REQCLEAR

IECODE_REQSET

IECODE_UP_PREFIX

IEQUALIFIERB_CAPSLOCK

IEQUALIFIERB_CONTROL

IEQUALIFIERB_INTERRUPT

IEQUALIFIERB_LALT

IEQUALIFIERB_LCOMMAND

IEQUALIFIERB_LEFTBUTTON

IEQUALIFIERB_LSHIFT

IEQUALIFIERB_MIDBUTTON

IEQUALIFIERB_MULTIBROADCAST

IEQUALIFIERB_NUMERICPAD

IEQUALIFIERB_RALT

IEQUALIFIERB_RBUTTON

IEQUALIFIERB_RCOMMAND

IEQUALIFIERB_RELATIVEMOUSE

IEQUALIFIERB_REPEAT

IEQUALIFIERB_RSHIFT

IEQUALIFIER_CAPSLOCK

IEQUALIFIER_CONTROL

IEQUALIFIER_INTERRUPT

IEQUALIFIER_LALT

IEQUALIFIER_LCOMMAND

IEQUALIFIER_LEFTBUTTON

IEQUALIFIER_LSHIFT

IEQUALIFIER_MIDBUTTON

IEQUALIFIER_MULTIBROADCAST

IEQUALIFIER_NUMERICPAD

IEQUALIFIER_RALT

IEQUALIFIER_RBUTTON

IEQUALIFIER_RCOMMAND

IEQUALIFIER_RELATIVEMOUSE

IEQUALIFIER_REPEAT

IEQUALIFIER_RSHIFT

IESUBCLASS_COMPATIBLE

IESUBCLASS_NEWTABLET

IESUBCLASS_PIXEL

IESUBCLASS_TABLET

NM_BUTTON_FOURTH

NM_WHEEL_DOWN

NM_WHEEL_LEFT

NM_WHEEL_RIGHT

NM_WHEEL_UP


Reference for unit 'inputevent': Types

PIENewTablet

PIEPointerPixel

PIEPointerTablet

PInputEvent

TIENewTablet

TIEPointerPixel

TIEPointerTablet

TInputEvent


Index of all identifiers in unit 'inputevent'

I N P T

I

IECLASS_ACTIVEWINDOW | IECODE_C1_FIRST | IEQUALIFIERB_RALT
IECLASS_CHANGEWINDOW | IECODE_C1_LAST | IEQUALIFIERB_RBUTTON
IECLASS_CLOSEWINDOW | IECODE_COMM_CODE_FIRST | IEQUALIFIERB_RCOMMAND
IECLASS_DISKINSERTED | IECODE_COMM_CODE_LAST | IEQUALIFIERB_RELATIVEMOUSE
IECLASS_DISKREMOVED | IECODE_KEY_CODE_FIRST | IEQUALIFIERB_REPEAT
IECLASS_EVENT | IECODE_KEY_CODE_LAST | IEQUALIFIERB_RSHIFT
IECLASS_GADGETDOWN | IECODE_LATIN1_FIRST | IEQUALIFIER_CAPSLOCK
IECLASS_GADGETUP | IECODE_LATIN1_LAST | IEQUALIFIER_CONTROL
IECLASS_INACTIVEWINDOW | IECODE_LBUTTON | IEQUALIFIER_INTERRUPT
IECLASS_MAX | IECODE_MBUTTON | IEQUALIFIER_LALT
IECLASS_MENUHELP | IECODE_NEWACTIVE | IEQUALIFIER_LCOMMAND
IECLASS_MENULIST | IECODE_NEWSIZE | IEQUALIFIER_LEFTBUTTON
IECLASS_NEWMOUSE | IECODE_NOBUTTON | IEQUALIFIER_LSHIFT
IECLASS_NEWPOINTERPOS | IECODE_RBUTTON | IEQUALIFIER_MIDBUTTON
IECLASS_NEWPREFS | IECODE_REFRESH | IEQUALIFIER_MULTIBROADCAST
IECLASS_NULL | IECODE_REQCLEAR | IEQUALIFIER_NUMERICPAD
IECLASS_POINTERPOS | IECODE_REQSET | IEQUALIFIER_RALT
IECLASS_RAWKEY | IECODE_UP_PREFIX | IEQUALIFIER_RBUTTON
IECLASS_RAWMOUSE | IEQUALIFIERB_CAPSLOCK | IEQUALIFIER_RCOMMAND
IECLASS_REFRESHWINDOW | IEQUALIFIERB_CONTROL | IEQUALIFIER_RELATIVEMOUSE
IECLASS_REQUESTER | IEQUALIFIERB_INTERRUPT | IEQUALIFIER_REPEAT
IECLASS_SIZEWINDOW | IEQUALIFIERB_LALT | IEQUALIFIER_RSHIFT
IECLASS_TIMER | IEQUALIFIERB_LCOMMAND | IESUBCLASS_COMPATIBLE
IECODE_ASCII_DEL | IEQUALIFIERB_LEFTBUTTON | IESUBCLASS_NEWTABLET
IECODE_ASCII_FIRST | IEQUALIFIERB_LSHIFT | IESUBCLASS_PIXEL
IECODE_ASCII_LAST | IEQUALIFIERB_MIDBUTTON | IESUBCLASS_TABLET
IECODE_C0_FIRST | IEQUALIFIERB_MULTIBROADCAST |
IECODE_C0_LAST | IEQUALIFIERB_NUMERICPAD |

N

NM_BUTTON_FOURTH | NM_WHEEL_LEFT | NM_WHEEL_UP
NM_WHEEL_DOWN | NM_WHEEL_RIGHT |

P

PIENewTablet | PIEPointerTablet
PIEPointerPixel | PInputEvent

T

TIENewTablet | TIEPointerTablet
TIEPointerPixel | TInputEvent


NM_BUTTON_FOURTH

Declaration

Source position: inputevent.pas line 181

const NM_BUTTON_FOURTH = $7e;


NM_WHEEL_DOWN

Declaration

Source position: inputevent.pas line 169

const NM_WHEEL_DOWN = $7b;


NM_WHEEL_LEFT

Declaration

Source position: inputevent.pas line 173

const NM_WHEEL_LEFT = $7c;


NM_WHEEL_RIGHT

Declaration

Source position: inputevent.pas line 177

const NM_WHEEL_RIGHT = $7d;


NM_WHEEL_UP

Declaration

Source position: inputevent.pas line 165

const NM_WHEEL_UP = $7a;


PIENewTablet

Declaration

Source position: inputevent.pas line 90

type PIENewTablet = ^TIENewTablet;


PIEPointerPixel

Declaration

Source position: inputevent.pas line 68

type PIEPointerPixel = ^TIEPointerPixel;


PIEPointerTablet

Declaration

Source position: inputevent.pas line 77

type PIEPointerTablet = ^TIEPointerTablet;


PInputEvent

Declaration

Source position: inputevent.pas line 185

type PInputEvent = ^TInputEvent;


TIENewTablet

Declaration

Source position: inputevent.pas line 91

type TIENewTablet = record

  ient_CallBack: PHook;

  ient_ScaledX: Word;

  ient_ScaledY: Word;

  ient_ScaledXFraction: Word;

  ient_ScaledYFraction: Word;

  ient_TabletX: DWord;

  ient_TabletY: DWord;

  ient_RangeX: DWord;

  ient_RangeY: DWord;

  ient_TagList: PTagItem;

end;


TIEPointerPixel

Declaration

Source position: inputevent.pas line 69

type TIEPointerPixel = record

  iepp_Screen: Pointer;

  iepp_Position: record

    X: Integer;

    Y: Integer;

  end;

end;


TIEPointerTablet

Declaration

Source position: inputevent.pas line 78

type TIEPointerTablet = record

  iept_Range: record

    X: Word;

    Y: Word;

  end;

  iept_Value: record

    X: Word;

    Y: Word;

  end;

  iept_Pressure: Integer;

end;


TInputEvent

Declaration

Source position: inputevent.pas line 186

type TInputEvent = record

  ie_NextEvent: PInputEvent;

  ie_Class: Byte;

  ie_SubClass: Byte;

  ie_Code: Word;

  ie_Qualifier: Word;

  ie_position: record

    case LongInt of

      0: (

          ie_xy: record

            ie_x: Integer;

            ie_y: Integer;

          end;

        );

      1: (

          ie_addr: Pointer;

        );

      2: (

          ie_dead: record

            ie_prev1DownCode: Byte;

            ie_prev1DownQual: Byte;

            ie_prev2DownCode: Byte;

            ie_prev2DownQual: Byte;

          end;

        );

  end;

  ie_TimeStamp: TTimeVal;

end;


ABSOLUTE_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as absolutes

Declaration

Source position: intuition.pas line 1868

const ABSOLUTE_DIMENSIONS = $0020;


ALERT_TYPE

Alert Type for DisplayAlert()

Declaration

Source position: intuition.pas line 1275

const ALERT_TYPE = $80000000;


ALPHA_P_101

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1821

const ALPHA_P_101 = $01;


ALTLEFT

Qualifier for TIntuiMessage.Qualifier. Left Alt Key pressed.

Declaration

Source position: intuition.pas line 1299

const ALTLEFT = IEQUALIFIER_LALT;


ALTRIGHT

Qualifier for TIntuiMessage.Qualifier. Right Alt Key pressed.

Declaration

Source position: intuition.pas line 1300

const ALTRIGHT = IEQUALIFIER_RALT;


AMIGAKEY

SYSIA_Which tag data values. Menu Amiga-key image

Declaration

Source position: intuition.pas line 2498

const AMIGAKEY = $11;


AMIGAKEYS

Qualifier for TIntuiMessage.Qualifier. An Amiga Key pressed.

Declaration

Source position: intuition.pas line 1303

const AMIGAKEYS = AMIGALEFT or AMIGARIGHT;


AMIGALEFT

Qualifier for TIntuiMessage.Qualifier. Left Amiga Key pressed.

Declaration

Source position: intuition.pas line 1301

const AMIGALEFT = IEQUALIFIER_LCOMMAND;


AMIGARIGHT

Qualifier for TIntuiMessage.Qualifier. Right Amiga Key pressed.

Declaration

Source position: intuition.pas line 1302

const AMIGARIGHT = IEQUALIFIER_RCOMMAND;


ANTI_ALIAS

Flag for TPreferences.PrintFlags anti-alias image

Declaration

Source position: intuition.pas line 1878

const ANTI_ALIAS = $0800;


ASPECT_HORIZ

Value for TPreferences.PrintAspect

Declaration

Source position: intuition.pas line 1797

const ASPECT_HORIZ = $00;


ASPECT_VERT

Value for TPreferences.PrintAspect

Declaration

Source position: intuition.pas line 1798

const ASPECT_VERT = $01;


AUTOBACKPEN

Declaration

Source position: intuition.pas line 1285

const AUTOBACKPEN = 1;


AUTODRAWMODE

Declaration

Source position: intuition.pas line 1286

const AUTODRAWMODE = JAM2;


AUTOFRONTPEN

Declaration

Source position: intuition.pas line 1284

const AUTOFRONTPEN = 0;


AUTOITEXTFONT

Declaration

Source position: intuition.pas line 1289

const AUTOITEXTFONT = Nil;


AUTOKNOB

Flag value for TPropInfo.Flags. Gimme that old auto-knob

Declaration

Source position: intuition.pas line 411

const AUTOKNOB = $0001;

Description

If you do not use an AUTOKNOB for a proportional gadget, you are currently limited to using a single Image of your own design: Intuition won't handle a linked list of images as a proportional gadget knob.


AUTOLEFTEDGE

Declaration

Source position: intuition.pas line 1287

const AUTOLEFTEDGE = 6;


AUTONEXTTEXT

Declaration

Source position: intuition.pas line 1290

const AUTONEXTTEXT = Nil;


AUTOSCROLL

Flag for TScreen.Flags. Screen is to autoscoll

Declaration

Source position: intuition.pas line 1416

const AUTOSCROLL = 1 shl 14;


AUTOTOPEDGE

Declaration

Source position: intuition.pas line 1288

const AUTOTOPEDGE = 3;


BACKGROUNDPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. always color 0

Declaration

Source position: intuition.pas line 1385

const BACKGROUNDPEN = 7;


BARBLOCKPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. screen-bar/menus fill

Declaration

Source position: intuition.pas line 1389

const BARBLOCKPEN = 10;

Description

Only present if DRI_VERSION >= 2


BARDETAILPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. text/detail in screen-bar/menus

Declaration

Source position: intuition.pas line 1388

const BARDETAILPEN = 9;

Description

Only present if DRI_VERSION >= 2


BARTRIMPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. trim under screen-bar

Declaration

Source position: intuition.pas line 1390

const BARTRIMPEN = 11;

Description

Only present if DRI_VERSION >= 2


BAUD_110

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1772

const BAUD_110 = $00;


BAUD_300

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1773

const BAUD_300 = $01;


BAUD_1200

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1774

const BAUD_1200 = $02;


BAUD_2400

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1775

const BAUD_2400 = $03;


BAUD_4800

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1776

const BAUD_4800 = $04;


BAUD_9600

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1777

const BAUD_9600 = $05;


BAUD_19200

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1778

const BAUD_19200 = $06;


BAUD_MIDI

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 1779

const BAUD_MIDI = $07;


BEEPING_f

Flag for TScreen.Flags. Set when Screen is beeping

Declaration

Source position: intuition.pas line 1409

const BEEPING_f = 1 shl 5;


BLOCKPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. compatible Intuition rendering pens

Declaration

Source position: intuition.pas line 1379

const BLOCKPEN = 1;


BOOLMASK

Extension is for masked gadget

Declaration

Source position: intuition.pas line 357

const BOOLMASK = $0001;

Description

Set TBoolInfo.Flags to this flag bit. in the future, additional bits might mean more stuff hanging off of TBoolInfo.Reserved.


BOUNDED_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as boundaries

Declaration

Source position: intuition.pas line 1867

const BOUNDED_DIMENSIONS = $0010;


BROTHER_15XL

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1822

const BROTHER_15XL = $02;


BTD_Client

Declaration

Source position: intuition.pas line 2972

const BTD_Client = BTD_Dummy + 100;


BTD_DrawInfo

Declaration

Source position: intuition.pas line 2968

const BTD_DrawInfo = BTD_Dummy + 1;


BTD_Dummy

Declaration

Source position: intuition.pas line 2967

const BTD_Dummy = TAG_USER + $425444;


BTD_Error

Declaration

Source position: intuition.pas line 2969

const BTD_Error = BTD_Dummy + 2;


BTD_PreviewMode

Declaration

Source position: intuition.pas line 2970

const BTD_PreviewMode = BTD_Dummy + 4;


BTDERR_Display

Declaration

Source position: intuition.pas line 2965

const BTDERR_Display = 3;


BTDERR_Memory

Declaration

Source position: intuition.pas line 2964

const BTDERR_Memory = 2;


BTDERR_Size

Declaration

Source position: intuition.pas line 2963

const BTDERR_Size = 1;


BTDI_Revision

Declaration

Source position: intuition.pas line 2937

const BTDI_Revision = 7;


BTDIF_3DBlanker

Declaration

Source position: intuition.pas line 2939

const BTDIF_3DBlanker = 1 shl 0;


BTDIF_DoNotWait

Declaration

Source position: intuition.pas line 2941

const BTDIF_DoNotWait = 1 shl 2;


BTDIF_Fast3D

Declaration

Source position: intuition.pas line 2940

const BTDIF_Fast3D = 1 shl 1;


BTDMAXSTRLEN

Declaration

Source position: intuition.pas line 2864

const BTDMAXSTRLEN = 128;


BTDPT_BOOLEAN

Declaration

Source position: intuition.pas line 2857

const BTDPT_BOOLEAN = 1;


BTDPT_CYCLE

Declaration

Source position: intuition.pas line 2859

const BTDPT_CYCLE = 3;


BTDPT_FILE

Declaration

Source position: intuition.pas line 2860

const BTDPT_FILE = 4;


BTDPT_FONT

Declaration

Source position: intuition.pas line 2862

const BTDPT_FONT = 6;


BTDPT_INTEGER

Declaration

Source position: intuition.pas line 2858

const BTDPT_INTEGER = 2;


BTDPT_STRING

Declaration

Source position: intuition.pas line 2861

const BTDPT_STRING = 5;


BUTTONGCLASS

Class identifier. A button gadget that keeps sending button presses while the user holds it down.

Declaration

Source position: intuition.pas line 1982

const BUTTONGCLASS: PChar = 'buttongclass';

Description

SuperClass: gadgetclass

A class of button gadget that continually sends interim OM_UPDATE messages to its target while the user holds down the button. The button sends a final OM_UPDATE message when the user lets go of the button. The imagery for these objects is not built directly into the gadget. Instead, a buttongclass object uses a Boopsi image object, which it gets from its GA_Image attribute.

Changed Methods:

GM_HITTEST, GM_HANDLEINPUT, GM_RENDER

Attributes:

GA_Image (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


CBM_MPS1000

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1823

const CBM_MPS1000 = $03;


CENTER_IMAGE

Flag for TPreferences.PrintFlags center image on paper

Declaration

Source position: intuition.pas line 1864

const CENTER_IMAGE = $0008;


CHECKED

Flag for TMenuItem.Flags set by the Application and intuition, if CHECKIT, then set this when selected

Declaration

Source position: intuition.pas line 103

const CHECKED = $0100;


CHECKIMAGE

SYSIA_Which tag data values. GadTools checkbox image

Declaration

Source position: intuition.pas line 2494

const CHECKIMAGE = $0E;


CHECKIT

Flag for TMenuItem.Flags set by the Application, whether to check this item if selected

Declaration

Source position: intuition.pas line 91

const CHECKIT = $0001;


CHECKWIDTH

Define for CHECKIT width for the CheckMark in a menu item

Declaration

Source position: intuition.pas line 1267

const CHECKWIDTH = 19;


ClassID

Name of the Object class

Declaration

Source position: intuition.pas line 1956

type ClassID = ^Byte;


CLF_INLIST

class is in public class list (TIClass.cl_Flags)

Declaration

Source position: intuition.pas line 2081

const CLF_INLIST = $00000001;


CLOSEGADGET

Declaration

Source position: intuition.pas line 1335

const CLOSEGADGET = 3;


CLOSEIMAGE

SYSIA_Which tag data values. Window close gadget image

Declaration

Source position: intuition.pas line 2488

const CLOSEIMAGE = $03;


COMMSEQ

Flag for TMenuItem.Flags set by the Application, set if there's an command sequence

Declaration

Source position: intuition.pas line 93

const COMMSEQ = $0004;


COMMWIDTH

Define for COMMSEQ width for the Command sequence in a menu item

Declaration

Source position: intuition.pas line 1268

const COMMWIDTH = 27;


CORRECT_BLUE

Flag for TPreferences.PrintFlags color correct blue shades

Declaration

Source position: intuition.pas line 1862

const CORRECT_BLUE = $0004;


CORRECT_GREEN

Flag for TPreferences.PrintFlags color correct green shades

Declaration

Source position: intuition.pas line 1861

const CORRECT_GREEN = $0002;


CORRECT_RED

Flag for TPreferences.PrintFlags color correct red shades

Declaration

Source position: intuition.pas line 1860

const CORRECT_RED = $0001;


CORRECT_RGB_MASK

Mask for TPreferences.PrintFlags color corrections RGB

Declaration

Source position: intuition.pas line 1882

const CORRECT_RGB_MASK = CORRECT_RED or CORRECT_GREEN or CORRECT_BLUE;


CURSORDOWN

RawKeycode for TIntuiMessage.Code. Cursor Down key pressed.

Declaration

Source position: intuition.pas line 1308

const CURSORDOWN = $4D;


CURSORLEFT

RawKeycode for TIntuiMessage.Code. Cursor left key pressed.

Declaration

Source position: intuition.pas line 1306

const CURSORLEFT = $4F;


CURSORRIGHT

RawKeycode for TIntuiMessage.Code. Cursor right key pressed.

Declaration

Source position: intuition.pas line 1307

const CURSORRIGHT = $4E;


CURSORUP

RawKeycode for TIntuiMessage.Code. Cursor up key pressed.

Declaration

Source position: intuition.pas line 1305

const CURSORUP = $4C;


CUSTOM_NAME

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1820

const CUSTOM_NAME = $00;


CUSTOM_PAPER

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 1808

const CUSTOM_PAPER = $40;


CUSTOMBITMAP_f

Flag for TScreen.Flags. If you are supplying your own BitMap

Declaration

Source position: intuition.pas line 1410

const CUSTOMBITMAP_f = 1 shl 6;


CUSTOMIMAGEDEPTH

if TImage.Depth is this, it's a new Image class object

Declaration

Source position: intuition.pas line 2424

const CUSTOMIMAGEDEPTH = - 1;


CUSTOMSCREEN_f

Screentype flag for TScreen.Flags and TNewScreen.SType. For that special look

Declaration

Source position: intuition.pas line 1405

const CUSTOMSCREEN_f = $000F;


CWCODE_DEPTH

Code for IDCMP_CHANGEWINDOW Window was depth-arranged

Declaration

Source position: intuition.pas line 892

const CWCODE_DEPTH = $0001;


CWCODE_MOVESIZE

Code for IDCMP_CHANGEWINDOW Window was moved and/or sized

Declaration

Source position: intuition.pas line 891

const CWCODE_MOVESIZE = $0000;


DEADEND_ALERT

Alert Type for DisplayAlert() no recovery possible, this is it

Declaration

Source position: intuition.pas line 1277

const DEADEND_ALERT = $80000000;


DEFAULTMOUSEQUEUE

Window value, No more mouse messaged

Declaration

Source position: intuition.pas line 949

const DEFAULTMOUSEQUEUE = 5;


DEFERREFRESH

Flag for TRequester.Flags. Read-Only. This Requester stops a Refresh broadcast

Declaration

Source position: intuition.pas line 470

const DEFERREFRESH = $8000;


DEPTHIMAGE

SYSIA_Which tag data values. Window depth gadget image

Declaration

Source position: intuition.pas line 2485

const DEPTHIMAGE = $00;


DETAILPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. Compatible Intuition rendering pens

Declaration

Source position: intuition.pas line 1378

const DETAILPEN = 0;


DEVNAME_SIZE

Devicename size for printer configuration

Declaration

Source position: intuition.pas line 1663

const DEVNAME_SIZE = 16;


DIAB_630

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1824

const DIAB_630 = $04;


DIAB_ADV_D25

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1825

const DIAB_ADV_D25 = $05;


DIAB_C_150

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1826

const DIAB_C_150 = $06;


DIMENSIONS_MASK

Mask for TPreferences.PrintFlags Dimensions mask

Declaration

Source position: intuition.pas line 1883

const DIMENSIONS_MASK = BOUNDED_DIMENSIONS or ABSOLUTE_DIMENSIONS or PIXEL_DIMENSIONS or MULTIPLY_DIMENSIONS;


DITHERING_MASK

Mask for TPreferences.PrintFlags Dithering mask

Declaration

Source position: intuition.pas line 1884

const DITHERING_MASK = HALFTONE_DITHERING or FLOYD_DITHERING;


DMODECOUNT

Declaration

Source position: intuition.pas line 1320

const DMODECOUNT = $0002;


DOSLOGO_DISKBUSY

Declaration

Source position: intuition.pas line 3150

const DOSLOGO_DISKBUSY = 7;


DOSLOGO_DISKERROR

Declaration

Source position: intuition.pas line 3151

const DOSLOGO_DISKERROR = 8;


DOSLOGO_DISKFULL

Declaration

Source position: intuition.pas line 3147

const DOSLOGO_DISKFULL = 4;


DOSLOGO_DISKINSERT

Declaration

Source position: intuition.pas line 3144

const DOSLOGO_DISKINSERT = 1;


DOSLOGO_DISKNOTVALIDATED

Declaration

Source position: intuition.pas line 3145

const DOSLOGO_DISKNOTVALIDATED = 2;


DOSLOGO_DISKPROTECTED

Declaration

Source position: intuition.pas line 3146

const DOSLOGO_DISKPROTECTED = 3;


DOSLOGO_NODISK

Declaration

Source position: intuition.pas line 3149

const DOSLOGO_NODISK = 6;


DOSLOGO_NOTADOSDISK

Declaration

Source position: intuition.pas line 3148

const DOSLOGO_NOTADOSDISK = 5;


DOWNBACKGADGET

Declaration

Source position: intuition.pas line 1333

const DOWNBACKGADGET = 1;


DOWNIMAGE

SYSIA_Which tag data values. Down-arrow gadget image

Declaration

Source position: intuition.pas line 2493

const DOWNIMAGE = $0D;


DRAFT

Value for TPreferences.PrintQuality

Declaration

Source position: intuition.pas line 1788

const DRAFT = $000;


DRAGGADGET

Declaration

Source position: intuition.pas line 1336

const DRAGGADGET = 4;


DRI_VERSION

Version of the TDrawInfo structure, can be found in TDrawInfo.dri_Version

Declaration

Source position: intuition.pas line 1348

const DRI_VERSION = 3;

Description

If you find TDrawInfo.dri_Version >= DRI_VERSION, you know this structure has at least the fields defined in this version of the include file


DRIF_DIRECTCOLOR

Declaration

Source position: intuition.pas line 1376

const DRIF_DIRECTCOLOR = 1 shl 1;


DRIF_NEWLOOK

Flag for TDrawInfo.dri_Flags specified SA_Pens, full treatment

Declaration

Source position: intuition.pas line 1375

const DRIF_NEWLOOK = 1 shl 0;


DRIPEN_BACKGROUND

Declaration

Source position: intuition.pas line 2996

const DRIPEN_BACKGROUND = BACKGROUNDPEN;


DRIPEN_BARBLOCK

Declaration

Source position: intuition.pas line 2999

const DRIPEN_BARBLOCK = BARBLOCKPEN;


DRIPEN_BARDETAIL

Declaration

Source position: intuition.pas line 2998

const DRIPEN_BARDETAIL = BARDETAILPEN;


DRIPEN_BARTRIM

Declaration

Source position: intuition.pas line 3000

const DRIPEN_BARTRIM = BARTRIMPEN;


DRIPEN_BLOCK

Declaration

Source position: intuition.pas line 2990

const DRIPEN_BLOCK = BLOCKPEN;


DRIPEN_DETAIL

Declaration

Source position: intuition.pas line 2989

const DRIPEN_DETAIL = DETAILPEN;


DRIPEN_FILL

Declaration

Source position: intuition.pas line 2994

const DRIPEN_FILL = FILLPEN;


DRIPEN_FILLTEXT

Declaration

Source position: intuition.pas line 2995

const DRIPEN_FILLTEXT = FILLTEXTPEN;


DRIPEN_HALFSHADOW

Declaration

Source position: intuition.pas line 3003

const DRIPEN_HALFSHADOW = $000D;


DRIPEN_HALFSHINE

Declaration

Source position: intuition.pas line 3002

const DRIPEN_HALFSHINE = $000C;


DRIPEN_HIGHLIGHTTEXT

Declaration

Source position: intuition.pas line 2997

const DRIPEN_HIGHLIGHTTEXT = HIGHLIGHTTEXTPEN;


DRIPEN_NUMDRIPENS

Declaration

Source position: intuition.pas line 3004

const DRIPEN_NUMDRIPENS = $000E;


DRIPEN_SHADOW

Declaration

Source position: intuition.pas line 2993

const DRIPEN_SHADOW = SHADOWPEN;


DRIPEN_SHINE

Declaration

Source position: intuition.pas line 2992

const DRIPEN_SHINE = SHINEPEN;


DRIPEN_TEXT

Declaration

Source position: intuition.pas line 2991

const DRIPEN_TEXT = TEXTPEN;


EES_ActiveButton

Declaration

Source position: intuition.pas line 3140

const EES_ActiveButton = EES_Dummy + 1;


EES_DiskBased

Declaration

Source position: intuition.pas line 3142

const EES_DiskBased = EES_Dummy + 3;


EES_DosLogo

Declaration

Source position: intuition.pas line 3141

const EES_DosLogo = EES_Dummy + 2;


EES_Dummy

Declaration

Source position: intuition.pas line 3139

const EES_Dummy = TAG_USER;


EIGHT_LPI

Value for TPreferences.PrintSpacing

Declaration

Source position: intuition.pas line 1792

const EIGHT_LPI = $200;


ELITE

Value for TPreferences.PrintPitch

Declaration

Source position: intuition.pas line 1785

const ELITE = $400;


EO_BADFORMAT

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2764

const EO_BADFORMAT = $0009;

Description

didn't like the text data, e.g., Bad LONGINT


EO_BIGCHANGE

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2765

const EO_BIGCHANGE = $000A;

Description

unused by Intuition complete or major change to the text, e.g. new string


EO_CLEAR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2767

const EO_CLEAR = $000C;

Description

clear the string


EO_DELBACKWARD

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2757

const EO_DELBACKWARD = $0002;

Description

deleted some chars (maybe 0).


EO_DELFORWARD

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2758

const EO_DELFORWARD = $0003;

Description

deleted some characters under and in front of the cursor


EO_ENTER

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2760

const EO_ENTER = $0005;

Description

"enter" or "return" key, terminate


EO_INSERTCHAR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2763

const EO_INSERTCHAR = $0008;

Description

inserted one char into string or added one at end


EO_MOVECURSOR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2759

const EO_MOVECURSOR = $0004;

Description

moved the cursor


EO_NOOP

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2756

const EO_NOOP = $0001;

Description

did nothing


EO_REPLACECHAR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2762

const EO_REPLACECHAR = $0007;

Description

replaced one character and (maybe) advanced cursor


EO_RESET

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2761

const EO_RESET = $0006;

Description

current Intuition-style undo


EO_SPECIAL

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2768

const EO_SPECIAL = $000D;

Description

unused by Intuition some operation that doesn't fit into the categories here


EO_UNDO

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 2766

const EO_UNDO = $000B;

Description

unused by Intuition some other style of undo


EPSON

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1827

const EPSON = $07;


EPSON_JX_80

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1828

const EPSON_JX_80 = $08;


ETD_Iconify

Declaration

Source position: intuition.pas line 3036

const ETD_Iconify = 0;


ETD_Jump

Declaration

Source position: intuition.pas line 3041

const ETD_Jump = 5;


ETD_Lock

Declaration

Source position: intuition.pas line 3037

const ETD_Lock = 1;


Unit 'intuition' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ETD_MUI

Declaration

Source position: intuition.pas line 3038

const ETD_MUI = 2;


ETD_PopUp

Declaration

Source position: intuition.pas line 3039

const ETD_PopUp = 3;


ETD_Snapshot

Declaration

Source position: intuition.pas line 3040

const ETD_Snapshot = 4;


ETG_ICONIFY

Declaration

Source position: intuition.pas line 3019

const ETG_ICONIFY = $1;


ETG_JUMP

Declaration

Source position: intuition.pas line 3024

const ETG_JUMP = $20;


ETG_LOCK

Declaration

Source position: intuition.pas line 3020

const ETG_LOCK = $2;


ETG_MUI

Declaration

Source position: intuition.pas line 3021

const ETG_MUI = $4;


ETG_POPUP

Declaration

Source position: intuition.pas line 3022

const ETG_POPUP = $8;


ETG_SNAPSHOT

Declaration

Source position: intuition.pas line 3023

const ETG_SNAPSHOT = $10;


ETI_Dummy

Declaration

Source position: intuition.pas line 3027

const ETI_Dummy = $FFD0;


ETI_Iconify

Declaration

Source position: intuition.pas line 3028

const ETI_Iconify = ETI_Dummy;


ETI_Jump

Declaration

Source position: intuition.pas line 3033

const ETI_Jump = ETI_Dummy + 5;


ETI_Lock

Declaration

Source position: intuition.pas line 3029

const ETI_Lock = ETI_Dummy + 1;


ETI_MUI

Declaration

Source position: intuition.pas line 3030

const ETI_MUI = ETI_Dummy + 2;


ETI_PopUp

Declaration

Source position: intuition.pas line 3031

const ETI_PopUp = ETI_Dummy + 3;


ETI_Snapshot

Declaration

Source position: intuition.pas line 3032

const ETI_Snapshot = ETI_Dummy + 4;


EURO_A0

Value for TPreferences.PaperSize European size A0: 841 x 1189

Declaration

Source position: intuition.pas line 1810

const EURO_A0 = $50;


EURO_A1

Value for TPreferences.PaperSize European size A1: 594 x 841

Declaration

Source position: intuition.pas line 1811

const EURO_A1 = $60;


EURO_A2

Value for TPreferences.PaperSize European size A2: 420 x 594

Declaration

Source position: intuition.pas line 1812

const EURO_A2 = $70;


EURO_A3

Value for TPreferences.PaperSize European size A3: 297 x 420

Declaration

Source position: intuition.pas line 1813

const EURO_A3 = $80;


EURO_A4

Value for TPreferences.PaperSize European size A4: 210 x 297

Declaration

Source position: intuition.pas line 1814

const EURO_A4 = $90;


EURO_A5

Value for TPreferences.PaperSize European size A5: 148 x 210

Declaration

Source position: intuition.pas line 1815

const EURO_A5 = $A0;


EURO_A6

Value for TPreferences.PaperSize European size A6: 105 x 148

Declaration

Source position: intuition.pas line 1816

const EURO_A6 = $B0;


EURO_A7

Value for TPreferences.PaperSize European size A7: 74 x 105

Declaration

Source position: intuition.pas line 1817

const EURO_A7 = $C0;


EURO_A8

Value for TPreferences.PaperSize European size A8: 52 x 74

Declaration

Source position: intuition.pas line 1818

const EURO_A8 = $D0;


EVENTMAX

Declaration

Source position: intuition.pas line 1324

const EVENTMAX = 10;


FANFOLD_PT

Declaration

Source position: intuition.pas line 1781

const FANFOLD_PT = $00;


FILENAME_SIZE

Filename size for printer configuration

Declaration

Source position: intuition.pas line 1662

const FILENAME_SIZE = 30;


FILLPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. active-window/selected-gadget fill

Declaration

Source position: intuition.pas line 1383

const FILLPEN = 5;


FILLRECTCLASS

Class identifier

Declaration

Source position: intuition.pas line 1978

const FILLRECTCLASS: PChar = 'fillrectclass';

Description

SuperClass: imageclass

This is a class of filled rectangles. The fillrectclass object can use a pattern to fill in its interior.

Changed Methods:

IM_DRAW

Attributes:

IA_APattern (IS)

IA_APatSize (IS)

IA_Mode (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


FILLTEXTPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. text over FILLPEN

Declaration

Source position: intuition.pas line 1384

const FILLTEXTPEN = 6;


FINE

Value for TPreferences.PrintPitch

Declaration

Source position: intuition.pas line 1786

const FINE = $800;


FLOYD_DITHERING

Flag for TPreferences.PrintFlags Floyd-Steinberg dithering

Declaration

Source position: intuition.pas line 1876

const FLOYD_DITHERING = $0400;


FRAME_BUTTON

Data value for IA_FrameType Standard button gadget frames, having thicker sides and nicely edged corners.

Declaration

Source position: intuition.pas line 2502

const FRAME_BUTTON = 1;

Description

recognized by FrameIClass


FRAME_DEFAULT

Data value for IA_FrameType The standard V37-type frame, which has thin edges.

Declaration

Source position: intuition.pas line 2501

const FRAME_DEFAULT = 0;

Description

recognized by FrameIClass


FRAME_ICONDROPBOX

Data value for IA_FrameType A broad ridge which is the standard imagery for areas in AppWindows where icons may be dropped.

Declaration

Source position: intuition.pas line 2504

const FRAME_ICONDROPBOX = 3;

Description

recognized by FrameIClass


FRAME_RIDGE

Data value for IA_FrameType A ridge such as used by standard string gadgets. You can recess the ridge to get a groove image.

Declaration

Source position: intuition.pas line 2503

const FRAME_RIDGE = 2;

Description

recognized by FrameIClass


FRAMEF_SPECIFY

Flag for TimpFrameBox.imp_FrameFlags

Declaration

Source position: intuition.pas line 2544

const FRAMEF_SPECIFY = 1 shl 0;


FRAMEICLASS

Class identifier. This is a class of framing image, which can optionally fill itself.

Declaration

Source position: intuition.pas line 1976

const FRAMEICLASS: PChar = 'frameiclass';

Description

SuperClass: imageclass

This is a class of framing image, which can optionally fill itself. Its purpose is to frame other display elements using an embossed or recessed rectangular frame. The frame renders itself using the appropriate TDrawInfo pens (SHINEPEN, SHADOWPEN, etc.). This class is intelligent enough to bound or center its contents.

Changed Methods:

IM_DRAW, IDS_NORMAL, IDS_INACTIVENORMAL, IDS_DISABLED, IDS_SELECTED, IDS_INACTIVESELECTED, IM_DRAWFRAME, IM_FRAMEBOX

Attributes:

IA_Recessed (IS)

IA_EdgesOnly (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


FRBUTTONCLASS

Class identifier. A buttongclass gadget that outlines its imagery with a frame.

Declaration

Source position: intuition.pas line 1983

const FRBUTTONCLASS: PChar = 'frbuttonclass';

Description

This is a special class of button gadget that puts a Boopsi framing image around some other display element. This display element can be one of three things: plain text from the GA_Text attribute, an IntuiText from the GA_IntuiText attribute, or an Image from the GA_LabelImage attribute.

The user activates the gadget by clicking within the bounds of the gadget's framing image, which it gets from the GA_Image attribute. Usually the framing image is an instance of an image class that supports the IM_FRAMEBOX method (like frameiclass). If the framing image supports the IM_FRAMEBOX method, the frbuttonclass object centers the frame image around the display element. See the imageclass description of IM_FRAMEBOX for more information.

Changed Methods:

OM_NEW, GM_HITTEST, GM_RENDER

Attributes:

GA_Width (S)

GA_Height (S)

GA_DrawInfo (I)

GA_Text (IS)

GA_IntuiText (IS)

GA_LabelImage (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


FREEHORIZ

Flag value for TPropInfo.Flags. if set, the knob can move horizontally

Declaration

Source position: intuition.pas line 412

const FREEHORIZ = $0002;


FREEVERT

Flag value for TPropInfo.Flags. if set, the knob can move vertically

Declaration

Source position: intuition.pas line 413

const FREEVERT = $0004;


GA_ActivateKey

GadgetClass Tag. (PChar) Set/Get the gadgets shortcut/activation key(s) Default = nil

Declaration

Source position: intuition.pas line 2160

const GA_ActivateKey = GA_Dummy + 43;


GA_BackFill

GadgetClass Tag. (PHook) Backfill pattern hook. Defaults to nil.

Declaration

Source position: intuition.pas line 2161

const GA_BackFill = GA_Dummy + 44;


GA_Border

GadgetClass Tag. (PBorder) Gadget imagry is a border

Declaration

Source position: intuition.pas line 2120

const GA_Border = GA_Dummy + 11;


GA_BottomBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the bottom border or not. Default = False.

Declaration

Source position: intuition.pas line 2137

const GA_BottomBorder = GA_Dummy + 27;


GA_Bounds

GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.

Declaration

Source position: intuition.pas line 2152

const GA_Bounds = GA_Dummy + 38;


GA_Disabled

GadgetClass Tag. [IS.] (LongWord) Takes GFLG_GADGH* flags as argument. Used to specify the highlighting technique.

Declaration

Source position: intuition.pas line 2123

const GA_Disabled = GA_Dummy + 14;


GA_DrawInfo

GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.

Declaration

Source position: intuition.pas line 2144

const GA_DrawInfo = GA_Dummy + 33;

Description

Read the documentation of the subclasses to learn, which need this attribute. To be on the safe side, you can always supply it.


GA_Dummy

GadgetClass Start Tag.

Declaration

Source position: intuition.pas line 2109

const GA_Dummy = TAG_USER + $30000;


GA_EndGadget

GadgetClass Tag. [ISG] (LongBool) Indicate whether the gadget is selected or not. Default = False

Declaration

Source position: intuition.pas line 2129

const GA_EndGadget = GA_Dummy + 20;


GA_FollowMouse

GadgetClass Tag. [IS.] (LongBool) If this is set, the gadget receives information about the movement of the mouse as long as it is activated. Default = False

Declaration

Source position: intuition.pas line 2132

const GA_FollowMouse = GA_Dummy + 23;


GA_GadgetHelp

GadgetClass Tag. [..G] (LongBool) If this is set by the gadget, the sends GADGETHELP messages.

Declaration

Source position: intuition.pas line 2151

const GA_GadgetHelp = GA_Dummy + 37;


GA_GadgetHelpText

GadgetClass Tag. (PChar) RESERVERD/PRIVATE DO NOT USE. Default = nil

Declaration

Source position: intuition.pas line 2162

const GA_GadgetHelpText = GA_Dummy + 45;


GA_GZZGadget

GadgetClass Tag. [ISG] (LongBool) If this is set to true, the gadget is not selectable.

Declaration

Source position: intuition.pas line 2124

const GA_GZZGadget = GA_Dummy + 15;

Description

Often this is visually represented by using a special disabled pattern.


GA_Height

GadgetClass Tag. [ISG] (LongInt) Height of gadget.

Declaration

Source position: intuition.pas line 2116

const GA_Height = GA_Dummy + 7;


GA_Highlight

GadgetClass Tag. [IS.] (PImage) Gadgets' image in selected state.

Declaration

Source position: intuition.pas line 2122

const GA_Highlight = GA_Dummy + 13;

Description

Note that if this is nil and GA_Image is in fact an image object, GA_Image may be tried to be drawn with IDS_SELECTED. So you do not need to fill this in, if you wish to have a special selected image and GA_Image is an image object that supports the selected state.


GA_ID

GadgetClass Tag. [IS.] (LongBool) The Gadget is a GimmeZeroZero gadget. Default = False

Declaration

Source position: intuition.pas line 2125

const GA_ID = GA_Dummy + 16;


GA_Image

GadgetClass Tag. (PImage) Gadget imagry is an image

Declaration

Source position: intuition.pas line 2119

const GA_Image = GA_Dummy + 10;


GA_Immediate

GadgetClass Tag. [IS.] (LongBool) Only used for requester gadgets. Default = False

Declaration

Source position: intuition.pas line 2130

const GA_Immediate = GA_Dummy + 21;

Description

This tells intuition that the requester is to be closed, when the gadget is released.


GA_IntuiText

GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.

Declaration

Source position: intuition.pas line 2146

const GA_IntuiText = GA_Dummy + 34;


GA_LabelImage

GadgetClass Tag. [IS.] (PObject_) Label is an image object.

Declaration

Source position: intuition.pas line 2147

const GA_LabelImage = GA_Dummy + 35;


GA_LabelPlace

Declaration

Source position: intuition.pas line 2166

const GA_LabelPlace = GA_Dummy + 100;


GA_Left

GadgetClass Tag. [ISG] (LongInt) Left edge of gadget.

Declaration

Source position: intuition.pas line 2110

const GA_Left = GA_Dummy + 1;


GA_LeftBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the left border or not. Default = False.

Declaration

Source position: intuition.pas line 2135

const GA_LeftBorder = GA_Dummy + 25;


GA_Next

GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.

Declaration

Source position: intuition.pas line 2143

const GA_Next = GA_Dummy + 32;


GA_Previous

GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.

Declaration

Source position: intuition.pas line 2141

const GA_Previous = GA_Dummy + 31;

Description

This is used to link the current gadget into a gadget list, before this list is used. It can not be used to add a gadget to a list of an open window or requester!


GA_ReadOnly

GadgetClass Tag. (LongBool) Indicate that the gadget is read-only (non-selectable). Default = False

Declaration

Source position: intuition.pas line 2157

const GA_ReadOnly = GA_Dummy + 41;


GA_RelBottom

GadgetClass Tag. [ISG] (LongInt) Top edge of gadget, depending on bottom window border: Top := Win^.Height - this - 1

Declaration

Source position: intuition.pas line 2113

const GA_RelBottom = GA_Dummy + 4;


GA_RelHeight

GadgetClass Tag. [ISG] (LongInt) Height of gadget, depending on window height: Height := Win^.Height - this

Declaration

Source position: intuition.pas line 2117

const GA_RelHeight = GA_Dummy + 8;


GA_RelRight

GadgetClass Tag. [ISG] (LongInt) Left edge of gadget, depending on right window border: Left := Win^.Width - this - 1

Declaration

Source position: intuition.pas line 2111

const GA_RelRight = GA_Dummy + 2;


GA_RelSpecial

GadgetClass Tag. [IS.] (LongInt) This attribute should only be set by subclasses of GadgetClass.

Declaration

Source position: intuition.pas line 2153

const GA_RelSpecial = GA_Dummy + 39;

Description

Applications should keep their hands away! If set this means, that GM_LAYOUT is called, when the window it is in is opened or its size changes. This allows gadgets to make their own size dependent on the size of the window.


GA_RelVerify

GadgetClass Tag. [IS.] (LongBool) If set the gadget responds immediatly, when the gadget is selected. Default = False

Declaration

Source position: intuition.pas line 2131

const GA_RelVerify = GA_Dummy + 22;


GA_RelWidth

GadgetClass Tag. [ISG] (LongInt) Width of gadget, depending on window width: Width := Win^.Width - this

Declaration

Source position: intuition.pas line 2115

const GA_RelWidth = GA_Dummy + 6;


GA_RightBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the right border or not. Default = False.

Declaration

Source position: intuition.pas line 2134

const GA_RightBorder = GA_Dummy + 24;


GA_Selected

GadgetClass Tag. (APTR) Pointer to additional information

Declaration

Source position: intuition.pas line 2128

const GA_Selected = GA_Dummy + 19;

Description

Needed by some gadgets (like string or integer gadgets). This field should generally only be set by subclasses of GadgetClass. Applications should keep their hands off it.


GA_SelectRender

GadgetClass Tag.

Declaration

Source position: intuition.pas line 2121

const GA_SelectRender = GA_Dummy + 12;


GA_SpecialInfo

GadgetClass Tag. [ISG] (IPTR) Fill with whatever you want to. This field is ignored by the system.

Declaration

Source position: intuition.pas line 2127

const GA_SpecialInfo = GA_Dummy + 18;


GA_SysGadget

GadgetClass private Tag. [IS.] (LongBool) Set, if gadget is a system-gadget e.g. a standard window border gadget. Default = False.

Declaration

Source position: intuition.pas line 2139

const GA_SysGadget = GA_Dummy + 29;


GA_SysGType

GadgetClass private Tag. [IS.] (LongWord) Reserved for system use to indicate the gadget type.

Declaration

Source position: intuition.pas line 2140

const GA_SysGType = GA_Dummy + 30;


GA_TabCycle

GadgetClass Tag. [IS.] (LongBool) If set to true that gadget participates in TAB handling, i.e. if tab is pressed, the next gadget is activated.

Declaration

Source position: intuition.pas line 2149

const GA_TabCycle = GA_Dummy + 36;


GA_Text

GadgetClass Tag. [IS.] (PChar) Label text. This is mutually exclusive with GA_IntuiText and GA_LabelImage.

Declaration

Source position: intuition.pas line 2118

const GA_Text = GA_Dummy + 9;


GA_TextAttr

GadgetClass Tag. [IS.] (PTextAttr) Indicate the font to use for the gadget.

Declaration

Source position: intuition.pas line 2156

const GA_TextAttr = GA_Dummy + 40;


GA_ToggleSelect

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is toggle-selected or not. Default = False.

Declaration

Source position: intuition.pas line 2138

const GA_ToggleSelect = GA_Dummy + 28;


GA_Top

GadgetClass Tag. [ISG] (LongInt) Top edge of gadget.

Declaration

Source position: intuition.pas line 2112

const GA_Top = GA_Dummy + 3;


GA_TopBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the top border or not. Default = False.

Declaration

Source position: intuition.pas line 2136

const GA_TopBorder = GA_Dummy + 26;


GA_Underscore

GadgetClass Tag. (Char) Underscore/escape character for keyboard shortcuts. Defaults = '_'

Declaration

Source position: intuition.pas line 2159

const GA_Underscore = GA_Dummy + 42;


GA_UserData

GadgetClass Tag. (LongInt) Gadget ID assigned by the application (prevent double numbers)

Declaration

Source position: intuition.pas line 2126

const GA_UserData = GA_Dummy + 17;


GA_UserInput

GadgetClass Tag. (LongBool) Notification tag indicates this notification is from the activite gadget receiving user input - an attempt to make IDCMPUPDATE more efficient.

Declaration

Source position: intuition.pas line 2163

const GA_UserInput = GA_Dummy + 46;


GA_Width

GadgetClass Tag. [ISG] (LongInt) Width of gadget.

Declaration

Source position: intuition.pas line 2114

const GA_Width = GA_Dummy + 5;


GACT_ACTIVEGADGET

Activation flag for TGadget.Activation. This gadget is "active".

Declaration

Source position: intuition.pas line 294

const GACT_ACTIVEGADGET = $4000;

Description

This flag is maintained by Intuition, and you cannot count on its value persisting while you do something on your program's task. It can only be trusted by people implementing custom gadgets


GACT_ALTKEYMAP

Activation flag for TGadget.Activation. this String has an alternate keymap

Declaration

Source position: intuition.pas line 292

const GACT_ALTKEYMAP = $1000;


GACT_BOOLEXTEND

Activation flag for TGadget.Activation. this Boolean Gadget has a BoolInfo

Declaration

Source position: intuition.pas line 285

const GACT_BOOLEXTEND = $2000;


GACT_BORDERSNIFF

Activation flag for TGadget.Activation. neither set nor rely on this bit

Declaration

Source position: intuition.pas line 282

const GACT_BORDERSNIFF = $8000;


GACT_BOTTOMBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 281

const GACT_BOTTOMBORDER = $0080;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GACT_ENDGADGET

Activation flag for TGadget.Activation. when set, tells the system that this gadget, when selected, causes the Requester to be ended. Requesters that are ended are erased and unlinked from the system.

Declaration

Source position: intuition.pas line 265

const GACT_ENDGADGET = $0004;


GACT_FOLLOWMOUSE

Activation flag for TGadget.Activation. when set, specifies that you want to receive reports on mouse movements

Declaration

Source position: intuition.pas line 273

const GACT_FOLLOWMOUSE = $0008;

Description

Flag, when set, specifies that you want to receive reports on mouse movements while this gadget is active. You probably want to set the GACT_IMMEDIATE flag when using GACT_FOLLOWMOUSE, since that's the only reasonable way you have of learning why Intuition is suddenly sending you a stream of mouse movement events. If you don't set GACT_RELVERIFY, you'll get at least one Mouse Position event.


GACT_IMMEDIATE

Activation flag for TGadget.Activation. when set, informs the caller that the gadget was activated when it was activated. This flag works in conjunction with the GACT_RELVERIFY flag

Declaration

Source position: intuition.pas line 261

const GACT_IMMEDIATE = $0002;


GACT_LEFTBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 279

const GACT_LEFTBORDER = $0020;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GACT_LONGINT

Activation flag for TGadget.Activation. this String Gadget is for LongInts

Declaration

Source position: intuition.pas line 291

const GACT_LONGINT = $0800;


GACT_RELVERIFY

Activation flag for TGadget.Activation. Set if you want to verify that the pointer was still over the gadget when the select button was released. Will cause an IDCMP_GADGETUP message to be sent if so.

Declaration

Source position: intuition.pas line 257

const GACT_RELVERIFY = $0001;


GACT_RIGHTBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 278

const GACT_RIGHTBORDER = $0010;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GACT_STRINGCENTER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 289

const GACT_STRINGCENTER = $0200;


GACT_STRINGEXTEND

Activation flag for TGadget.Activation. this String Gadget has PStringExtend

Declaration

Source position: intuition.pas line 293

const GACT_STRINGEXTEND = $2000;


GACT_STRINGLEFT

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 288

const GACT_STRINGLEFT = $0000;


GACT_STRINGRIGHT

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 290

const GACT_STRINGRIGHT = $0400;


GACT_TOGGLESELECT

Activation flag for TGadget.Activation. this bit for toggle-select mode

Declaration

Source position: intuition.pas line 284

const GACT_TOGGLESELECT = $0100;


GACT_TOPBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 280

const GACT_TOPBORDER = $0040;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GADGETCLASS

Class identifier. This is a base class for Intuition compatible gadget objects.

Declaration

Source position: intuition.pas line 1979

const GADGETCLASS: PChar = 'gadgetclass';

Description

SuperClass: rootclass

This is a base class for Intuition compatible gadget objects. The dispatcher for this class takes care of creating an Intuition Gadget structure as part of its local instance data. All of the standard Boopsi gadget classes build on this class. Normally there are no direct instances of this class, only instances of subclasses of gadgetclass.

The behavior of a Boopsi gadget depends on how it handles the five Boopsi gadget methods: GM_HITTEST, GM_RENDER, GM_GOACTIVE, GM_HANDLEINPUT, and GM_GOINACTIVE. Intuition controls a Boopsi gadget by sending it these types of messages. The structures that these methods use for their messages begin with the method's ID followed by a pointer to a TGadgetInfo structure . The GadgetInfo structure is a read-only structure that contains information about the gadget's rendering environment. The gadget uses this to find things like its window, screen, or pen array. Although this structure does contain a pointer to a RastPort for the gadget, the gadget must not use this RastPort for rendering. The gadget can obtain a RastPort for rendering by calling the Intuition function ObtainGIRPort() using the GadgetInfo structure.

These methods are not defined directly by gadgetclass. It is up to subclasses of gadgetclass to implement them.

Like all Boopsi methods, these methods run on the context of the task that called the method. Normally, Intuition is the only entity that calls these methods, so these normally operate in the input.device's task. Because a gadget may have to process a large number of input events, poor implementations of gadget methods (especially the GM_HANDLEINPUT method) can degrade system performance.

New Methods:

GM_HITTEST, GM_GOACTIVE, GM_GOINACTIVE, GM_RENDER, GM_HANDLEINPUT

Changed Methods:

OM_NEW, OM_NOTIFY

Attributes:

GA_Previous (I)

ICA_TARGET (IS)

ICA_MAP (IS)

GA_Left (IS)

GA_Top (IS)

GA_Width (IS)

GA_Height (IS)

GA_RelRight (IS)

GA_RelBottom (IS)

GA_RelWidth (IS)

GA_RelHeight (IS)

The remaining attributes defined by gadgetclass are used to set the fields in the Gadget structure of the Boopsi gadget. Some Boopsi gadgets do not pay attention to many of the fields in its Gadget structure, so most applications will not have to worry about the majority of these attributes. Some gadget classes assign special meanings to these attributes. See the documentation of the specific gadget classes for more details.

GA_IntuiText (IS)

GA_Text (IS)

GA_LabelImage (IS)

GA_Image (IS)

GA_Border (IS)

GA_SelectRender (IS)

GA_ID (IS)

GA_UserData (IS)

GA_SpecialInfo (IS)

GA_GZZGadget (IS)

GA_SysGadget (IS)

GA_Disabled (IS)

GA_Selected (IS)

GA_EndGadget (IS)

GA_Immediate (IS)

GA_RelVerify (IS)

GA_FollowMouse (IS)

GA_RightBorder (IS)

GA_LeftBorder (IS)

GA_TopBorder (IS)

GA_BottomBorder (IS)

GA_ToggleSelect (IS)

GA_TabCycle (IS)

GA_Highlight (IS)

GA_SysGType (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


GADGETCOUNT

Declaration

Source position: intuition.pas line 1331

const GADGETCOUNT = 8;


GDIA_CheckMark

Declaration

Source position: intuition.pas line 2985

const GDIA_CheckMark = $00A00000;


GDIA_Color

Declaration

Source position: intuition.pas line 2976

const GDIA_Color = $00100000;


GDIA_Depth

Declaration

Source position: intuition.pas line 2982

const GDIA_Depth = $00700000;


GDIA_DirectColor

Declaration

Source position: intuition.pas line 2979

const GDIA_DirectColor = $00400000;


GDIA_Font

Declaration

Source position: intuition.pas line 2981

const GDIA_Font = $00600000;


GDIA_MenuKey

Declaration

Source position: intuition.pas line 2986

const GDIA_MenuKey = $00B00000;


GDIA_NumPens

Declaration

Source position: intuition.pas line 2980

const GDIA_NumPens = $00500000;


GDIA_Pen

Declaration

Source position: intuition.pas line 2977

const GDIA_Pen = $00200000;


GDIA_ResolutionX

Declaration

Source position: intuition.pas line 2983

const GDIA_ResolutionX = $00800000;


GDIA_ResolutionY

Declaration

Source position: intuition.pas line 2984

const GDIA_ResolutionY = $00900000;


GDIA_Version

Declaration

Source position: intuition.pas line 2978

const GDIA_Version = $00300000;


GDOMAIN_MAXIMUM

Declaration

Source position: intuition.pas line 2359

const GDOMAIN_MAXIMUM = 2;


GDOMAIN_MINIMUM

Declaration

Source position: intuition.pas line 2357

const GDOMAIN_MINIMUM = 0;


GDOMAIN_NOMINAL

Declaration

Source position: intuition.pas line 2358

const GDOMAIN_NOMINAL = 1;


GFLG_DISABLED

Flag for TGadget.SpecialInfo. Is initialized by you and later set by Intuition according to your calls to OnGadget/OffGadget. It specifies whether or not this Gadget is currently disabled from being selected

Declaration

Source position: intuition.pas line 217

const GFLG_DISABLED = $0100;


GFLG_EXTENDED

Flag for TGadget.SpecialInfo. Gadget is an PExtGadget

Declaration

Source position: intuition.pas line 251

const GFLG_EXTENDED = $8000;

Description

If set, this bit means that the Gadget is actually a PExtGadget, with new fields and flags. All boopsi gadgets are PExtGadget. Never ever attempt to read the extended fields of a gadget if this flag is not set.


GFLG_GADGHBOX

Flag for TGadget.SpecialInfo. Draw a box around the image

Declaration

Source position: intuition.pas line 191

const GFLG_GADGHBOX = $0001;


GFLG_GADGHCOMP

Flag for TGadget.Flags. Complement the select box

Declaration

Source position: intuition.pas line 190

const GFLG_GADGHCOMP = $0000;


GFLG_GADGHIGHBITS

Flag for TGadget.SpecialInfo.

Declaration

Source position: intuition.pas line 189

const GFLG_GADGHIGHBITS = $0003;


GFLG_GADGHIMAGE

Flag for TGadget.SpecialInfo. Blast in this alternate image

Declaration

Source position: intuition.pas line 192

const GFLG_GADGHIMAGE = $0002;


GFLG_GADGHNONE

Flag for TGadget.SpecialInfo. don't highlight

Declaration

Source position: intuition.pas line 193

const GFLG_GADGHNONE = $0003;


GFLG_GADGIMAGE

Flag for TGadget.SpecialInfo. set if TGadget.GadgetRender and TGadget.SelectRender is PImage, clear if it is a PBorder

Declaration

Source position: intuition.pas line 194

const GFLG_GADGIMAGE = $0004;


GFLG_IMAGEDISABLE

Flag for TGadget.SpecialInfo. Gadget's image knows how to do disabled rendering

Declaration

Source position: intuition.pas line 245

const GFLG_IMAGEDISABLE = $0800;

Description

This flag is automatically set if the custom image of this gadget knows how to do disabled rendering (more specifically, if its IA_SupportsDisable attribute is True). Intuition uses this to defer the ghosting to the image-class, instead of doing it itself (the old compatible way). Do not set this flag yourself - Intuition will do it for you.


GFLG_LABELIMAGE

Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PImage

Declaration

Source position: intuition.pas line 228

const GFLG_LABELIMAGE = $2000;


GFLG_LABELITEXT

Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText

Declaration

Source position: intuition.pas line 226

const GFLG_LABELITEXT = $0000;


GFLG_LABELMASK

Flag for TGadget.SpecialInfo.

Declaration

Source position: intuition.pas line 225

const GFLG_LABELMASK = $3000;


GFLG_LABELSTRING

Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PChar

Declaration

Source position: intuition.pas line 227

const GFLG_LABELSTRING = $1000;


GFLG_RELBOTTOM

Flag for TGadget.SpecialInfo. vertical position is relative to bottom edge

Declaration

Source position: intuition.pas line 202

const GFLG_RELBOTTOM = $0008;


GFLG_RELHEIGHT

Flag for TGadget.SpecialInfo. height is relative to req/window

Declaration

Source position: intuition.pas line 205

const GFLG_RELHEIGHT = $0040;


GFLG_RELRIGHT

Flag for TGadget.SpecialInfo. horizontal position is relative to right edge

Declaration

Source position: intuition.pas line 203

const GFLG_RELRIGHT = $0010;


GFLG_RELSPECIAL

Flag for TGadget.SpecialInfo. Custom gadget has special relativity. Gadget box values are absolutes, but can be changed via the GM_LAYOUT method.

Declaration

Source position: intuition.pas line 212

const GFLG_RELSPECIAL = $4000;

Description

Allows custom gadget implementors to make gadgets whose position and size depend in an arbitrary way on their window's dimensions. The GM_LAYOUT method will be invoked for such a gadget (or any other GREL_xxx gadget) at suitable times, such as when the window opens or the window's size changes.


GFLG_RELWIDTH

Flag for TGadget.SpecialInfo. width is relative to req/window

Declaration

Source position: intuition.pas line 204

const GFLG_RELWIDTH = $0020;


GFLG_SELECTED

Flag for TGadget.SpecialInfo. you may initialize and look at this

Declaration

Source position: intuition.pas line 213

const GFLG_SELECTED = $0080;


GFLG_STRINGEXTEND

Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend

Declaration

Source position: intuition.pas line 238

const GFLG_STRINGEXTEND = $0400;


GFLG_TABCYCLE

Flag for TGadget.SpecialInfo. (string OR custom) gadget participates in cycling activation with Tab or Shift-Tab

Declaration

Source position: intuition.pas line 231

const GFLG_TABCYCLE = $0200;


GM_Dummy

GadgetClass Method IDs Start

Declaration

Source position: intuition.pas line 2236

const GM_Dummy = - 1;


GM_GOACTIVE

GadgetClass Method ID. You are now going to be fed input

Declaration

Source position: intuition.pas line 2239

const GM_GOACTIVE = 2;

Description

Tells the gadget that it has become active and will receive input from now on from the method GM_HANDLEINPUT. This is stopped by using GM_GOINACTIVE.

See also

PgpInput | Pointer to Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT


GM_GOINACTIVE

GadgetClass Method ID. Whether or not by choice, you are done

Declaration

Source position: intuition.pas line 2241

const GM_GOINACTIVE = 4;

See also

PgpGoInactive | Pointer to Message parameter passed for GM_GOINACTIVE
TgpGoInactive | Message parameter passed for GM_GOINACTIVE


GM_HANDLEINPUT

GadgetClass Method ID.

Declaration

Source position: intuition.pas line 2240

const GM_HANDLEINPUT = 3;

Description

GM_GOACTIVE tells the gadget that it has become active and will receive input from now on from the method >GM_HANDLEINPUT. This is stopped by using GM_GOINACTIVE.


GM_HELPTEST

GadgetClass Method ID. Will you send gadget help if the mouse is at the specified coordinates? See below for possible GMR_ values.

Declaration

Source position: intuition.pas line 2242

const GM_HELPTEST = 5;

See also

PgpHitTest | Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST


GM_HITTEST

GadgetClass Method ID. Returns GMR_GADGETHIT if you are clicked on (whether or not you are disabled).

Declaration

Source position: intuition.pas line 2237

const GM_HITTEST = 0;

Description

This method is used to test, if a mouse-click hit the gadget. You return GMR_GADGETHIT, if you were hit and 0 otherwise. Note that you have to test, if you were hit, no matter if you are disabled or not.

See also

PgpHitTest | Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST


GM_LAYOUT

GadgetClass Method ID. Re-evaluate your size based on the GadgetInfo Domain. Do NOT re-render yourself yet, you will be called when it is time...

Declaration

Source position: intuition.pas line 2243

const GM_LAYOUT = 6;

Description

This method is called by intuition, if on of the GFLG_REL* flags or one of the GA_Rel* attributes is set and the window size changes or you are added to a window. In this method you should re-evaluate the size of yourself. You are not allowed to do any rendering operation during this method!

See also

PgpLayout | Pointer to Message parameter passed for GM_LAYOUT
TgpLayout | Message parameter passed for GM_LAYOUT


GM_RENDER

GadgetClass Method ID. Draw yourself, in the appropriate state

Declaration

Source position: intuition.pas line 2238

const GM_RENDER = 1;

Description

This method is invoked to draw the gadget into a rastport.

See also

PgpRender | Pointer to Message parameter passed for GM_RENDER
TgpRender | Message parameter passed for GM_RENDER


GMLA_DisplayID

Declaration

Source position: intuition.pas line 3156

const GMLA_DisplayID = GMLA_Dummy + 1;


GMLA_Dummy

Declaration

Source position: intuition.pas line 3155

const GMLA_Dummy = TAG_USER + $4000;


GMORE_BOUNDS

Flag for TExtGadget.MoreFlags ExtGadget has valid Bounds

Declaration

Source position: intuition.pas line 340

const GMORE_BOUNDS = $00000001;


GMORE_GADGETHELP

Flag for TExtGadget.MoreFlags This gadget responds to gadget help

Declaration

Source position: intuition.pas line 341

const GMORE_GADGETHELP = $00000002;


GMORE_SCROLLRASTER

Flag for TExtGadget.MoreFlags This (custom) gadget uses ScrollRaster

Declaration

Source position: intuition.pas line 342

const GMORE_SCROLLRASTER = $00000004;


GMR_GADGETHIT

Result for GM_HITTEST Hit

Declaration

Source position: intuition.pas line 2265

const GMR_GADGETHIT = $00000004;


GMR_HELPCODE

Result for GM_HELPTEST Hit, return low Word as code.

Declaration

Source position: intuition.pas line 2268

const GMR_HELPCODE = $00010000;

Description

The gadget was hit. Pass the lower word, returned by this method to the application by using the Code field of the IntuiMessage.


GMR_HELPHIT

Result for GM_HELPTEST Hit, The gadget was hit.

Declaration

Source position: intuition.pas line 2267

const GMR_HELPHIT = $FFFFFFFF;

Description

The lower word of the Code field of the IntuiMessage will be set to -1.


GMR_KEYACTIVE

Declaration

Source position: intuition.pas line 2384

const GMR_KEYACTIVE = 1 shl 4;


GMR_KEYVERIFY

Declaration

Source position: intuition.pas line 2386

const GMR_KEYVERIFY = 1 shl 5;


GMR_MEACTIVE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2306

const GMR_MEACTIVE = 0;

Description

Gadget is still alive.


GMR_NEXTACTIVE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate next gadget.

Declaration

Source position: intuition.pas line 2312

const GMR_NEXTACTIVE = 1 shl 4;

Description

the gadget has become inactive, but the next or previous gadget, which has the GFLG_TABCYCLE flag set is to be activated.


GMR_NOHELPHIT

Result for GM_HELPTEST didn't hit

Declaration

Source position: intuition.pas line 2266

const GMR_NOHELPHIT = $00000000;


GMR_NOREUSE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2307

const GMR_NOREUSE = 1 shl 1;

Description

Gadget has become inactive, but the input event may not be used again.


GMR_PREVACTIVE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate previous gadget.

Declaration

Source position: intuition.pas line 2313

const GMR_PREVACTIVE = 1 shl 5;

Description

the gadget has become inactive, but the next or previous gadget, which has the GFLG_TABCYCLE flag set is to be activated.


GMR_REUSE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2308

const GMR_REUSE = 1 shl 2;

Description

Gadget has become inactive, and the input event may be reused by intuition.


GMR_VERIFY

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2309

const GMR_VERIFY = 1 shl 3;


GREDRAW_REDRAW

TgpRender.gpr_Redraw. Redraw the whole gadget

Declaration

Source position: intuition.pas line 2283

const GREDRAW_REDRAW = 1;


GREDRAW_TOGGLE

TgpRender.gpr_Redraw. Toggle highlight, if applicable

Declaration

Source position: intuition.pas line 2284

const GREDRAW_TOGGLE = 0;


GREDRAW_UPDATE

TgpRender.gpr_Redraw. Incremental update. Some data (e.g. the level of a slider) was updated. Just redraw the necessary parts.

Declaration

Source position: intuition.pas line 2282

const GREDRAW_UPDATE = 2;


GREY_SCALE2

Flag for TPreferences.PrintFlags for use with hi-res monitor

Declaration

Source position: intuition.pas line 1879

const GREY_SCALE2 = $1000;


GROUPGCLASS

Class identifier. A special gadget class that creates one composite gadget out of several others.

Declaration

Source position: intuition.pas line 1984

const GROUPGCLASS: PChar = 'groupgclass';

Description

SuperClass: gadgetclass

This is a class of objects that maintains an internal list of gadgets. Its purpose is to make it easier to layout a group of gadgets. Any gadgets that are a member of a groupgclass object are rendered relative to the groupgclass object's GA_Left and GA_Top attributes. As new gadgets are added to the groupgclass object, the groupgclass object's dimensions grow to enclose the new gadgets. When the groupgclass object receives an OM_DISPOSE message, it not only disposes of itself, it also disposes of all the gadgets in its list. Groupgclass does not support the gadget relative flags (GA_RelWidth, GA_RelHeight, GA_RelBottom, and GA_RelRight).

Changed Methods:

OM_SET, GM_HITTEST, OM_ADDMEMBER, GM_RENDER, OM_REMMEMBER, GM_GOACTIVE, GM_GOINACTIVE, GM_HANDLEINPUT, OM_DISPOSE

Attributes:

GA_Left (IS)

GA_Top (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


GTYP_BOOLGADGET

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 328

const GTYP_BOOLGADGET = $0001;


GTYP_CLOSE

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 316

const GTYP_CLOSE = $0080;


GTYP_CUSTOMGADGET

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 332

const GTYP_CUSTOMGADGET = $0005;


GTYP_GADGET0002

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 329

const GTYP_GADGET0002 = $0002;


GTYP_GADGETTYPE

All Gadget Global type flags for TGadget.Type

Declaration

Source position: intuition.pas line 303

const GTYP_GADGETTYPE = $FC00;


GTYP_GTYPEMASK

Application gadget type for TGadget.Type mask you can apply to tell what class of gadget this is.

Declaration

Source position: intuition.pas line 325

const GTYP_GTYPEMASK = $0007;

Description

The possible classes: GTYP_BOOLGADGET, GTYP_GADGET0002, GTYP_PROPGADGET, GTYP_STRGADGET or GTYP_CUSTOMGADGET


GTYP_GZZGADGET

Application gadget type for TGadget.Type for WFLG_GIMMEZEROZERO borders

Declaration

Source position: intuition.pas line 306

const GTYP_GZZGADGET = $2000;


GTYP_PROPGADGET

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 330

const GTYP_PROPGADGET = $0003;


GTYP_REQGADGET

Application gadget type for TGadget.Type this is a Requester Gadget

Declaration

Source position: intuition.pas line 307

const GTYP_REQGADGET = $1000;


GTYP_SCRGADGET

Application gadget type for TGadget.Type 1 = ScreenGadget, 0 = WindowGadget

Declaration

Source position: intuition.pas line 305

const GTYP_SCRGADGET = $4000;


GTYP_SDEPTH

Declaration

Source position: intuition.pas line 321

const GTYP_SDEPTH = GTYP_SUPFRONT;


GTYP_SDOWNBACK

Declaration

Source position: intuition.pas line 315

const GTYP_SDOWNBACK = $0070;


GTYP_SDRAGGING

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 311

const GTYP_SDRAGGING = $0030;


GTYP_SIZING

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 309

const GTYP_SIZING = $0010;


GTYP_STRGADGET

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 331

const GTYP_STRGADGET = $0004;


GTYP_SUNUSED

Declaration

Source position: intuition.pas line 323

const GTYP_SUNUSED = GTYP_SDOWNBACK;


GTYP_SUPFRONT

Declaration

Source position: intuition.pas line 313

const GTYP_SUPFRONT = $0050;


GTYP_SYSGADGET

Application gadget type for TGadget.Type 1 = Allocated by the system, 0 = by application

Declaration

Source position: intuition.pas line 304

const GTYP_SYSGADGET = $8000;


GTYP_WDEPTH

Declaration

Source position: intuition.pas line 320

const GTYP_WDEPTH = GTYP_WUPFRONT;


GTYP_WDOWNBACK

Declaration

Source position: intuition.pas line 314

const GTYP_WDOWNBACK = $0060;


GTYP_WDRAGGING

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 310

const GTYP_WDRAGGING = $0020;


GTYP_WDRAGGING2

Declaration

Source position: intuition.pas line 318

const GTYP_WDRAGGING2 = $0090;


GTYP_WUPFRONT

Declaration

Source position: intuition.pas line 312

const GTYP_WUPFRONT = $0040;


GTYP_WZOOM

Declaration

Source position: intuition.pas line 322

const GTYP_WZOOM = GTYP_WDOWNBACK;


GV_LabelPlace_Above

Declaration

Source position: intuition.pas line 2171

const GV_LabelPlace_Above = 4;


GV_LabelPlace_Below

Declaration

Source position: intuition.pas line 2172

const GV_LabelPlace_Below = 5;


GV_LabelPlace_In

Declaration

Source position: intuition.pas line 2168

const GV_LabelPlace_In = 1;


GV_LabelPlace_Left

Declaration

Source position: intuition.pas line 2169

const GV_LabelPlace_Left = 2;


GV_LabelPlace_Right

Declaration

Source position: intuition.pas line 2170

const GV_LabelPlace_Right = 3;


HALFTONE_DITHERING

Flag for TPreferences.PrintFlags halftone dithering

Declaration

Source position: intuition.pas line 1875

const HALFTONE_DITHERING = $0200;


HC_GADGETHELP

Flag for HelpControl() Set this flag to enable Gadget-Help for one or more windows.

Declaration

Source position: intuition.pas line 1224

const HC_GADGETHELP = 1;


HIGHBOX

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by "boxing" the selectbox

Declaration

Source position: intuition.pas line 100

const HIGHBOX = $0080;


HIGHCOMP

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by complementing the selectbox

Declaration

Source position: intuition.pas line 99

const HIGHCOMP = $0040;


HIGHFLAGS

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, see definitions below for these bits

Declaration

Source position: intuition.pas line 97

const HIGHFLAGS = $00C0;


HIGHIMAGE

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, use the user's "select image"

Declaration

Source position: intuition.pas line 98

const HIGHIMAGE = $0000;


HIGHITEM

Flag for TMenuItem.Flags set by intuition (ReadOnly), this item is currently highlighted

Declaration

Source position: intuition.pas line 106

const HIGHITEM = $2000;


HIGHLIGHTTEXTPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. special color text, on background

Declaration

Source position: intuition.pas line 1386

const HIGHLIGHTTEXTPEN = 8;


HIGHNONE

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, don't highlight

Declaration

Source position: intuition.pas line 101

const HIGHNONE = $00C0;


HIRESGADGET

Declaration

Source position: intuition.pas line 1328

const HIRESGADGET = 0;


HIRESPICK

Declaration

Source position: intuition.pas line 1321

const HIRESPICK = $0000;


HOVERSTART

Declaration

Source position: intuition.pas line 905

const HOVERSTART = $0001;


HOVERSTOP

Declaration

Source position: intuition.pas line 906

const HOVERSTOP = $0002;


HP_LASERJET

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1831

const HP_LASERJET = $0B;


HP_LASERJET_PLUS

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1832

const HP_LASERJET_PLUS = $0C;


IA_ActivateKey

Declaration

Source position: intuition.pas line 2465

const IA_ActivateKey = IA_Dummy + 30;


IA_APatSize

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2445

const IA_APatSize = IA_Dummy + 17;


IA_APattern

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2444

const IA_APattern = IA_Dummy + 16;


IA_BGPen

ImageClass Attribute. IA_BGPen also means "PlaneOnOff"

Declaration

Source position: intuition.pas line 2433

const IA_BGPen = IA_Dummy + 6;


IA_Data

ImageClass Attribute. bitplanes, for classic image, other image classes may use it for other things

Declaration

Source position: intuition.pas line 2434

const IA_Data = IA_Dummy + 7;


IA_DoubleEmboss

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2450

const IA_DoubleEmboss = IA_Dummy + 22;


IA_Dummy

ImageClass Attributes start.

Declaration

Source position: intuition.pas line 2427

const IA_Dummy = TAG_USER + $20000;


IA_EdgesOnly

ImageClass Attribute. to specify that the interior of a frame should not be cleared

Declaration

Source position: intuition.pas line 2451

const IA_EdgesOnly = IA_Dummy + 23;


IA_FGPen

ImageClass Attribute. IA_FGPen also means "PlanePick"

Declaration

Source position: intuition.pas line 2432

const IA_FGPen = IA_Dummy + 5;


IA_Font

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2447

const IA_Font = IA_Dummy + 19;


IA_FrameType

SysIClass Attribute. FrameIClass recognizes several standard types of frame.

Declaration

Source position: intuition.pas line 2460

const IA_FrameType = IA_Dummy + 27;

Description

Use one of the FRAME_* specifiers below. Default = FRAME_DEFAULT.


IA_Height

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2431

const IA_Height = IA_Dummy + 4;


IA_HighlightPen

Declaration

Source position: intuition.pas line 2477

const IA_HighlightPen = IA_Dummy + 10;


IA_Left

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2428

const IA_Left = IA_Dummy + 1;


IA_LineWidth

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2435

const IA_LineWidth = IA_Dummy + 8;


IA_Mode

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2446

const IA_Mode = IA_Dummy + 18;


IA_Outline

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2448

const IA_Outline = IA_Dummy + 20;


IA_Pens

ImageClass Attribute. pointer to Word pens[], ala TDrawInfo.Pens, must be terminated by (not 0). Some classes can choose to have this, or SYSIA_DrawInfo, or both.

Declaration

Source position: intuition.pas line 2441

const IA_Pens = IA_Dummy + 14;


IA_Precision

Declaration

Source position: intuition.pas line 2467

const IA_Precision = IA_Dummy + 32;


IA_Recessed

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2449

const IA_Recessed = IA_Dummy + 21;


IA_Resolution

ImageClass Attribute. packed Words for x/y resolution into a LongWord ala TDrawInfo.Resolution

Declaration

Source position: intuition.pas line 2442

const IA_Resolution = IA_Dummy + 15;


IA_Scalable

Declaration

Source position: intuition.pas line 2464

const IA_Scalable = IA_Dummy + 29;


IA_Screen

Declaration

Source position: intuition.pas line 2466

const IA_Screen = IA_Dummy + 31;


IA_ShadowPen

Declaration

Source position: intuition.pas line 2476

const IA_ShadowPen = IA_Dummy + 9;


IA_SupportsDisable

SysIClass Attribute. Tell intuition to use IDS_*DISABLED instead of own code

Declaration

Source position: intuition.pas line 2457

const IA_SupportsDisable = IA_Dummy + 26;


IA_Top

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2429

const IA_Top = IA_Dummy + 2;


IA_Underscore

Declaration

Source position: intuition.pas line 2463

const IA_Underscore = IA_Dummy + 28;


IA_Width

ImageClass Attribute.

Declaration

Source position: intuition.pas line 2430

const IA_Width = IA_Dummy + 3;


ICA_Dummy

Interconnection attributes start used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 2405

const ICA_Dummy = TAG_USER + $40000;


ICA_MAP

interconnection map tagitem list used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 2407

const ICA_MAP = ICA_Dummy + 2;

Description

see ICTARGET_IDCMP


ICA_TARGET

Interconnection target used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 2406

const ICA_TARGET = ICA_Dummy + 1;

Description

see ICTARGET_IDCMP


ICCLASS

Class identifier. Interconnection class

Declaration

Source position: intuition.pas line 1985

const ICCLASS: PChar = 'icclass';

Description

SuperClass: rootclass

Base class of simple OM_UPDATE forwarding objects. When an icclass object gets an OM_UPDATE message, it maps the attributes in the OM_UPDATE message according to its mapping list (its ICA_MAP attribute) and forwards the OM_UPDATE to its target (its ICA_TARGET attribute).

Changed Methods:

OM_SET, OM_UPDATE, OM_NOTIFY

Attributes:

ICA_TARGET (IS)

ICA_MAP (IS)

ICSPECIAL_CODE (*)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


ICM_CHECKLOOP

icclass Method. Set/increment loop

Declaration

Source position: intuition.pas line 2401

const ICM_CHECKLOOP = ICM_Dummy + 3;


ICM_CLEARLOOP

icclass Method. Clear/decrement loop counter

Declaration

Source position: intuition.pas line 2400

const ICM_CLEARLOOP = ICM_Dummy + 2;


ICM_Dummy

icclass Methods start

Declaration

Source position: intuition.pas line 2398

const ICM_Dummy = $0401;


ICM_SETLOOP

icclass Method. Set/increment loop counter

Declaration

Source position: intuition.pas line 2399

const ICM_SETLOOP = ICM_Dummy + 1;


ICONIFYIMAGE

Declaration

Source position: intuition.pas line 3009

const ICONIFYIMAGE = $12;


ICSPECIAL_CODE

a "pseudo-attribute" used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 2408

const ICSPECIAL_CODE = ICA_Dummy + 3;

Description

see ICTARGET_IDCMP


ICTARGET_IDCMP

Declaration

Source position: intuition.pas line 2421

const ICTARGET_IDCMP: LongWord = not 0;

Description

Normally, the value for ICA_TARGET is some object pointer, but if you specify the special value ICTARGET_IDCMP, notification will be send as an IDCMP_IDCMPUPDATE message to the appropriate window's IDCMP port. See the definition of IDCMP_IDCMPUPDATE. When you specify ICTARGET_IDCMP for ICA_TARGET, the map you specify will be applied to derive the attribute list that is sent with the IDCMP_IDCMPUPDATE message. If you specify a map list which results in the attribute tag id ICSPECIAL_CODE, the lower sixteen bits of the corresponding ti_Data value will be copied into the Code field of the IDCMP_IDCMPUPDATE IntuiMessage.


IDCMP_ACTIVEWINDOW

IDCMP class: Window is activated

Declaration

Source position: intuition.pas line 869

const IDCMP_ACTIVEWINDOW = $00040000;

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_CHANGEWINDOW

IDCMP class: Window changed size or position

Declaration

Source position: intuition.pas line 879

const IDCMP_CHANGEWINDOW = $02000000;

Description

This message provides the window with notification of any change in the size or position of a window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_CLOSEWINDOW

IDCMP class: User pressed close button of window

Declaration

Source position: intuition.pas line 860

const IDCMP_CLOSEWINDOW = $00000200;

Description

IDCMP_CLOSEWINDOW messages are sent when the user selects the window's close gadget. Intuition does not close the window when the close gadget is selected. Rather, an IDCMP_CLOSEWINDOW message is sent to the window's IDCMP. It is up to the application to clean up and close the window itself. If closing a window means losing some data (perhaps the spreadsheet the user was working on), it would be appropriate for the application to first confirm that the user really meant to close the window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_DELTAMOVE

IDCMP class:

Declaration

Source position: intuition.pas line 871

const IDCMP_DELTAMOVE = $00100000;

Description

IDCMP_DELTAMOVE is not a message type, and events will never be sent to the application with this IDCMP identifier. This flag is a modifier, which changes how mouse movements are reported. When this flag is set, mouse movements are sent as delta values rather than as absolute positions.

The deltas are the amount of change of the mouse position from the last reported position. If the mouse does not move, then the delta values will be zero.

This flag works in conjunction with the IDCMP_MOUSEMOVE flag. When IDCMP_DELTAMOVE is set, IDCMP_MOUSEBUTTONS messages will also have relative values, instead of the absolute window position of the mouse.

Delta mouse movements are reported even after the Intuition pointer has reached the limits of the display. That is, if the pointer has reached the edge of the display and the user continues to move the mouse in the same direction, the IDCMP_MOUSEMOVE messages will continue to report changes in the mouse position even though the pointer is no longer moving.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_DISKINSERTED

IDCMP class: Floppy disk inserted

Declaration

Source position: intuition.pas line 866

const IDCMP_DISKINSERTED = $00008000;

Description

When the user inserts a floppy disk from any drive, Intuition will send one of these message types. This message type is broadcast to all IDCMP that have this flag set, not just to the active window. If the application has this flag set, it should be prepared to handle the event even if it is not active.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_DISKREMOVED

IDCMP class: Floppy disk removed

Declaration

Source position: intuition.pas line 867

const IDCMP_DISKREMOVED = $00010000;

Description

When the user removes a floppy disk from any drive, Intuition will send one of these message types. This message type is broadcast to all IDCMP that have this flag set, not just to the active window. If the application has this flag set, it should be prepared to handle the event even if it is not active.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_GADGETDOWN

IDCMP class: user selects a gadget

Declaration

Source position: intuition.pas line 856

const IDCMP_GADGETDOWN = $00000020;

Description

IDCMP_GADGETDOWN messages are sent when the user selects a gadget that was created with the GACT_IMMEDIATEGACT_IMMEDIATE flag set. The IAddress field will contain a pointer to the selected gadget.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_GADGETHELP

IDCMP class

Declaration

Source position: intuition.pas line 880

const IDCMP_GADGETHELP = $04000000;

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_GADGETUP

IDCMP class: user selects a gadget

Declaration

Source position: intuition.pas line 857

const IDCMP_GADGETUP = $00000040;

Description

IDCMP_GADGETUP messages are sent when the user selects a gadget that was created with the GACT_RELVERIFY flag set. The IAddress field will contain a pointer to the selected gadget.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_IDCMPUPDATE

IDCMP Class: gadget notification

Declaration

Source position: intuition.pas line 875

const IDCMP_IDCMPUPDATE = $00800000;

Description

Used for notification from Boopsi custom gadgets. The IAddress field contains a pointer to a tag item list.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_INACTIVEWINDOW

IDCMP class: Window is deactivated

Declaration

Source position: intuition.pas line 870

const IDCMP_INACTIVEWINDOW = $00080000;

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_INTUITICKS

IDCMP Class: Time ticks

Declaration

Source position: intuition.pas line 873

const IDCMP_INTUITICKS = $00400000;

Description

Intuition sends these messages to the active window based on an internal timer which "ticks" roughly ten times a second. This provides the application with simple timer events from Intuition.

Intuition does not allow IDCMP_INTUITICKS events to accumulate at a port. After an IDCMP_INTUITICKS message has been sent to a port, Intuition will not send another until the application replies to the first. This means that an application that has not been able to service the IDCMP for an extended period can expect at most one IDCMP_INTUITICKS message to be waiting at the port.

These events are to be used as "prods", and not as time counters. Do not rely on the timing accuracy of the event, or on the exact frequency at which they appear. Remember, IDCMP_INTUITICKS will only be sent to the active window. If the user selects another window, the events will no longer be received at the first window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_LONELYMESSAGE

IDCMP class: Private

Declaration

Source position: intuition.pas line 887

const IDCMP_LONELYMESSAGE = $80000000;

Description

For internal tracking by Intuition, system use only.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MENUHELP

IDCMP Class: Help key pressed

Declaration

Source position: intuition.pas line 877

const IDCMP_MENUHELP = $01000000;

Description

This message is sent by Intuition when the user selects the Help key while the menu system is activated. If a menu item was selected, the menu number of the menu item can be found in the Code field. If no item was selected, the Code field will be equal to MENUNULL.

These messages will only be sent if the WA_MenuHelp attribute is set for the window.

The menu number returned in IDCMP_MENUHELP may specify a position that cannot be generated through normal menu activity. For instance, the menu number may indicate one of the menu headers with no item or sub-item.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MENUPICK

IDCMP class: User opened the menu

Declaration

Source position: intuition.pas line 859

const IDCMP_MENUPICK = $00000100;

Description

This flag indicates that the user has pressed the menu button. If a menu item was selected, the menu number of the menu item can be found in the Code field. If no item was selected, the Code field will be equal to MENUNULL.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MENUVERIFY

IDCMP class: Verify ready to show menu

Declaration

Source position: intuition.pas line 864

const IDCMP_MENUVERIFY = $00002000;

Description

This is a special verification mode which allows the program to confirm that it is prepared to handle Intuition rendering, in this case, allowing menus to be drawn in the screen.

This is a special kind of verification, in that any window in the entire screen that has this flag set must respond before the menu operations may proceed. Also, the active window of the screen is allowed to cancel the menu operation. This is unique to IDCMP_MENUVERIFY. Refer to the "Intuition Menus" for a complete description.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MOUSEBUTTONS

IDCMP class: Contains reports about mouse button up and down events.

Declaration

Source position: intuition.pas line 854

const IDCMP_MOUSEBUTTONS = $00000008;

Description

Contains reports about mouse button up and down events. The events will be sent to the application only if they are not used internally by Intuition.

The Code field contains information on the specific mouse button event this message represents. The Code field will be equal to SELECTDOWN, SELECTUP, MENUDOWN, MENUUP, MIDDLEDOWN or MIDDLEUP, depending on the button pressed or released. In general, the select button is the left mouse button, the menu button is the right mouse button and the middle button is an optional third button usually located between the select and menu buttons.

Often, a mouse button event has extra meaning to Intuition, and the application may hear about it through a more specific message, for example a gadget or menu event. Other times, no event is generated at all, such as when the user depth-arranges a screen by clicking on the screen depth gadget. Note that menu button events are normally consumed by Intuition for menu handling. If an application wishes to hear IDCMP_MOUSEBUTTONS events for the menu button, it must set the WA_RMBTrap> attribute for its window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MOUSEHOVER

Declaration

Source position: intuition.pas line 881

const IDCMP_MOUSEHOVER = $08000000;


IDCMP_MOUSEMOVE

IDCMP class: Reports about mouse movements

Declaration

Source position: intuition.pas line 855

const IDCMP_MOUSEMOVE = $00000010;

Description

Reports about mouse movements, sent in the form of x and y coordinates relative to the upper left corner of the window. One message will be sent to the application for each "tick" of the mouse.

The application can opt to receive IDCMP_MOUSEMOVE events only while certain gadgets are active, or during normal window operation. These events are sent whenever a gadget with GACT_FOLLOWMOUSE gadget is active, or for any window that has the WA_ReportMouse attribute set. This window attribute can be set or cleared by the application at will.

Requesting IDCMP_MOUSEMOVE messages can create a very large volume of messages arriving at the window's IDCMP. Do not request these messages unless the program is prepared to keep up with them. Intuition limits the number of mouse move events that pile up at your IDCMP.

All IDCMP messages contain a mouse x and y position that can be absolute values or delta values. See IDCMP_DELTAMOVE. If the application requires a less frequent reporting of the mouse position, consider using IDCMP_INTUITICKS. While IDCMP_MOUSEMOVE events are generated by changes in the mouse's position, IDCMP_INTUITICKS IntuiMessages are based on a timer. Since they contain mouse coordinates, they effectively sample the mouse position. These message come often enough for many applications, but not so frequently as to swamp the application.

The program will not be sent IDCMP_MOUSEMOVE messages while Intuition has the layers of the screen locked (during menu operations and window sizing/dragging). This avoids problems of messages accumulating while the program is blocked, waiting to render into a locked layer.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MOUSEOBJECTMUI

Declaration

Source position: intuition.pas line 882

const IDCMP_MOUSEOBJECTMUI = $40000000;


IDCMP_NEWPREFS

IDCMP class: Preferences are changed

Declaration

Source position: intuition.pas line 865

const IDCMP_NEWPREFS = $00004000;

Description

IDCMP_NEWPREFS messages are sent when the system Preferences are changed by a call to SetPrefs(). The program can learn of these changes by setting this flag.

After receiving a message of class IDCMP_NEWPREFS, the application should call GetPrefs() to obtain a copy of the new Preferences.

Under the new Preferences scheme used an IDCMP_NEWPREFS message will not always be sent when the user changes a Preferences setting. Only Preferences values that can be modified by a call to SetPrefs(), will cause an IDCMP_NEWPREFS message to be sent. New Preferences items such as overscan or font settings rely on filesystem notification for monitoring changes.

This message type is broadcast to all IDCMP that have this flag set, not just to the active window. If the application has this flag set, it should be prepared to handle the event even if it is not active.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_NEWSIZE

IDCMP class: User resized the Window

Declaration

Source position: intuition.pas line 852

const IDCMP_NEWSIZE = $00000002;

Description

Intuition sends this message after the user has resized the window. After receiving this, the program can examine the size variables in the window structure to discover the new size of the window. The message is sent, even if the size of the window did not actually change.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_RAWKEY

IDCMP class: Raw keycodes from keyboard

Declaration

Source position: intuition.pas line 861

const IDCMP_RAWKEY = $00000400;

Description

IDCMP_RAWKEY messages give the raw keycodes from the keyboard. The numeric value of the keycode is sent in the Code field. Separate codes are returned for key down and key up. Qualifier codes, such as Shift or Alt and whether this key is a repeat, may be found in the Qualifier field of the message.

In general, the application should not assume any correspondence between the keycode and the key value. Character positions on the keyboard change from country to country, and the application should respect the keymap set by the user.

Programs using IDCMP_RAWKEY messages should perform their own key mapping by calling the console.device function RawKeyConvert(), or the keymap.library function MapRawKey(). (The latter is a bit more convenient). The Autodoc for the MapRawKey() function shows how you can process so-called dead keys. A dead key is a key combination that has no immediate effect, but instead modifies a subsequent keystroke. For example, on the default keymap, Alt-F is a dead key for the acute accent mark. The sequence of Alt-F followed by the E key yields an Ã© with an acute accent.

The application can assume that certain keys will always return the same raw keycode, these keys do not have to be mapped. In general these keys are in the high part of the keymap, above $40, and includes all non-alphanumeric keys. The fixed keys include the function keys, backspace, delete, help and cursor keys.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REFRESHWINDOW

IDCMP class: Window needs refreshing

Declaration

Source position: intuition.pas line 853

const IDCMP_REFRESHWINDOW = $00000004;

Description

This message is sent whenever the window needs refreshing. This flag makes sense only with windows that have a refresh type of WA_SimpleRefresh or WA_SmartRefresh.

As a minimum, the application must call BeginRefresh() and EndRefresh() for the window after receiving an IDCMP_REFRESHWINDOW event. Create the window with the WA_NoCareRefresh attribute if you do not want to manage these events.

Most of the graphics library calls used for display output are compatible with Intuition, with the exception of ScrollRaster(). Intuition will not send an IDCMP_REFRESHWINDOW event when damage is caused to a window by ScrollRaster(). This may happen in a simple refresh window which is partially obscured by another window--the region that scrolls out from behind the front window will be damaged, but the window will receive no notification. Check the layers.LAYERREFRESH bit in the Layer structure Flags field to see if damage did happen as a result of ScrollRaster().

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REQCLEAR

IDCMP class: Requester is cleared

Declaration

Source position: intuition.pas line 863

const IDCMP_REQCLEAR = $00001000;

Description

Intuition sends an IDCMP_REQCLEAR message to the window each time a requester is cleared from that window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REQSET

IDCMP class: Recive message when a requester opens

Declaration

Source position: intuition.pas line 858

const IDCMP_REQSET = $00000080;

Description

With this flag set, the program will receive a message whenever a requester opens in its window. The application will receive one IDCMP_REQSET event for each requester opened in the window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REQVERIFY

IDCMP class: Verify intuition is ready to render a requester

Declaration

Source position: intuition.pas line 862

const IDCMP_REQVERIFY = $00000800;

Description

Set this flag to allow the application to ensure it is prepared for Intuition to render a requester in the window. With this flag set, Intuition sends the application a message that a requester is pending, and then waits for the application to reply before drawing the requester in the window.

If several requesters open in the window, Intuition asks the application to verify only the first one. After that, Intuition assumes that all output is being held off until all the requesters are gone.

By setting the IDCMP_REQSET and IDCMP_REQCLEAR flags, the application can track how many requesters are open in the window and when the last requester is cleared. Once all of the requesters are cleared from the window, it is safe to write to the window until another IDCMP_REQVERIFY is received.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_SIZEVERIFY

IDCMP class: resize must be verified by application

Declaration

Source position: intuition.pas line 851

const IDCMP_SIZEVERIFY = $00000001;

Description

Set this flag if the program must complete some operation before the user sizes the window. When the user sizes the window, Intuition sends an IDCMP_SIZEVERIFY message to the application and then waits until the program replies before allowing the user to size the window. See the "Verification Functions" section below for some things to consider when using this flag.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_VANILLAKEY

IDCMP class: keyboard events

Declaration

Source position: intuition.pas line 872

const IDCMP_VANILLAKEY = $00200000;

Description

IDCMP_VANILLAKEY messages return keyboard events translated into the current default character keymap. The mapped character value is returned in the Code field.

An IDCMP_VANILLAKEY message is sent only if the translation results in a single byte value, therefore the program cannot read the Help or function keys using IDCMP_VANILLAKEY.

Programs using IDCMP_VANILLAKEY which also require the additional information of special keys, such as the Help key and the function keys, may set both IDCMP_VANILLAKEY and IDCMP_RAWKEY. When this combination is used, all keypresses that map to single character values will be returned as IDCMP_VANILLAKEY events; all other keyboard events will be sent as IDCMP_RAWKEY messages. Note that IDCMP_VANILLAKEY processing uses all of the key-up events, so the application will only receive key-down events in the IDCMP_RAWKEY format.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_WBENCHMESSAGE

IDCMP class: private

Declaration

Source position: intuition.pas line 868

const IDCMP_WBENCHMESSAGE = $00020000;

Description

Special messages for Workbench, system use only.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDOMAIN_MAXIMUM

Declaration

Source position: intuition.pas line 2614

const IDOMAIN_MAXIMUM = 2;


IDOMAIN_MINIMUM

Declaration

Source position: intuition.pas line 2612

const IDOMAIN_MINIMUM = 0;


IDOMAIN_NOMINAL

Declaration

Source position: intuition.pas line 2613

const IDOMAIN_NOMINAL = 1;


IDS_BUSY

Image draw style for IM_DRAW for future functionality

Declaration

Source position: intuition.pas line 2522

const IDS_BUSY = 3;


IDS_DISABLED

Image draw state for IM_DRAW for disabled gadgets

Declaration

Source position: intuition.pas line 2521

const IDS_DISABLED = 2;


IDS_INACTIVEDISABLED

Image draw style for IM_DRAW disabled, in inactive border

Declaration

Source position: intuition.pas line 2526

const IDS_INACTIVEDISABLED = 7;


IDS_INACTIVENORMAL

Image draw style for IM_DRAW normal, in inactive window border

Declaration

Source position: intuition.pas line 2524

const IDS_INACTIVENORMAL = 5;


IDS_INACTIVESELECTED

Image draw style for IM_DRAW selected, in inactive border

Declaration

Source position: intuition.pas line 2525

const IDS_INACTIVESELECTED = 6;


IDS_INDETERMINANT

Declaration

Source position: intuition.pas line 2530

const IDS_INDETERMINANT = IDS_INDETERMINATE;


IDS_INDETERMINATE

Image draw style for IM_DRAW for future functionality

Declaration

Source position: intuition.pas line 2523

const IDS_INDETERMINATE = 4;


IDS_NORMAL

Image draw style for IM_DRAW

Declaration

Source position: intuition.pas line 2519

const IDS_NORMAL = 0;


IDS_SELECTED

Image draw state for IM_DRAW for selected gadgets

Declaration

Source position: intuition.pas line 2520

const IDS_SELECTED = 1;


IDS_SELECTEDDISABLED

Image draw style for IM_DRAW disabled and selected

Declaration

Source position: intuition.pas line 2527

const IDS_SELECTEDDISABLED = 8;


IGNORE_DIMENSIONS

Flag for TPreferences.PrintFlags ignore max width/height settings

Declaration

Source position: intuition.pas line 1866

const IGNORE_DIMENSIONS = $0000;


IM_DOMAINFRAME

Declaration

Source position: intuition.pas line 2516

const IM_DOMAINFRAME = $20A;


IM_DRAW

imageclass message id. draw yourself, with "state" (IDS_*)

Declaration

Source position: intuition.pas line 2507

const IM_DRAW = $202;

See also

PimpDraw | Pointer to message argument for IM_DRAW or IM_DRAWFRAME
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME


IM_DRAWFRAME

imageclass message id. draw with specified dimensions

Declaration

Source position: intuition.pas line 2512

const IM_DRAWFRAME = $206;

See also

PimpDraw | Pointer to message argument for IM_DRAW or IM_DRAWFRAME
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME


IM_ERASE

imageclass message id. erase yourself

Declaration

Source position: intuition.pas line 2509

const IM_ERASE = $204;

See also

PimpErase | Pointer to message argument for IM_ERASE or IM_ERASEFRAME
TimpErase | Message argument for IM_ERASE or IM_ERASEFRAME


IM_ERASEFRAME

imageclass message id. hittest with dimensions

Declaration

Source position: intuition.pas line 2515

const IM_ERASEFRAME = $209;

See also

PimpErase | Pointer to message argument for IM_ERASE or IM_ERASEFRAME
TimpErase | Message argument for IM_ERASE or IM_ERASEFRAME


IM_FRAMEBOX

imageclass message id. get recommended frame around some box

Declaration

Source position: intuition.pas line 2513

const IM_FRAMEBOX = $207;

See also

PimpFrameBox | Pointer to message argument for IM_FRAMEBOX
TimpFrameBox | Message argument for IM_FRAMEBOX


IM_HITFRAME

imageclass message id. hittest with dimensions

Declaration

Source position: intuition.pas line 2514

const IM_HITFRAME = $208;

See also

PimpHitTest | Pointer to message argument for IM_HITTEST or IM_HITFRAME
TimpHitTest | Message argument for IM_HITTEST or IM_HITFRAME


IM_HITTEST

imageclass message id. return True if click hits image

Declaration

Source position: intuition.pas line 2508

const IM_HITTEST = $203;

See also

PimpHitTest | Pointer to message argument for IM_HITTEST or IM_HITFRAME
TimpHitTest | Message argument for IM_HITTEST or IM_HITFRAME


IM_MOVE

imageclass message id. draw new and erase old, smoothly

Declaration

Source position: intuition.pas line 2510

const IM_MOVE = $205;


IMAGE_NEGATIVE

Value for TPreferences.PrintImage

Declaration

Source position: intuition.pas line 1795

const IMAGE_NEGATIVE = $01;


IMAGE_POSITIVE

Value for TPreferences.PrintImage

Declaration

Source position: intuition.pas line 1794

const IMAGE_POSITIVE = $00;


IMAGECLASS

Class identifier. This class is the base class for Boopsi Images.

Declaration

Source position: intuition.pas line 1975

const IMAGECLASS: PChar = 'imageclass';

Description

SuperClass: rootclass

This class is the base class for Boopsi Images. These images are backwards compatible with the conventional Intuition Images. Every Boopsi image has an Intuition Image structure embedded in it so Intuition can access the Boopsi image as a conventional Image structure when necessary. Normally there are no direct instances of this class, only instances of subclasses of imageclass.

New Methods:

IM_DRAW, IM_ERASE, IM_HITFRAME, IM_FRAMEBOX, IM_HITTEST, IM_DRAWFRAME, IM_ERASEFRAME

Changed Methods:

OM_NEW, OM_SET

Attributes:

IA_Left (ISG)

IA_Top (ISG)

IA_Width (ISG)

IA_Height (ISG)

IA_FGPen (ISG)

IA_BGPen (ISG)

IA_Data (ISG)

IA_Pens ()

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


IMSGA_Class

Declaration

Source position: intuition.pas line 3165

const IMSGA_Class = IMSGA_Dummy + 1;


IMSGA_Code

Declaration

Source position: intuition.pas line 3166

const IMSGA_Code = IMSGA_Dummy + 3;


IMSGA_Dummy

Declaration

Source position: intuition.pas line 3164

const IMSGA_Dummy = TAG_USER + $60000;


IMSGA_IAddress

Declaration

Source position: intuition.pas line 3168

const IMSGA_IAddress = IMSGA_Dummy + 5;


IMSGA_IDCMPWindow

Declaration

Source position: intuition.pas line 3173

const IMSGA_IDCMPWindow = IMSGA_Dummy + 10;


IMSGA_Micros

Declaration

Source position: intuition.pas line 3172

const IMSGA_Micros = IMSGA_Dummy + 9;


IMSGA_MouseX

Declaration

Source position: intuition.pas line 3169

const IMSGA_MouseX = IMSGA_Dummy + 6;


IMSGA_MouseY

Declaration

Source position: intuition.pas line 3170

const IMSGA_MouseY = IMSGA_Dummy + 7;


IMSGA_Qualifier

Declaration

Source position: intuition.pas line 3167

const IMSGA_Qualifier = IMSGA_Dummy + 4;


IMSGA_RawMouseX

Declaration

Source position: intuition.pas line 3174

const IMSGA_RawMouseX = IMSGA_Dummy + 11;


IMSGA_RawMouseY

Declaration

Source position: intuition.pas line 3175

const IMSGA_RawMouseY = IMSGA_Dummy + 12;


IMSGA_Seconds

Declaration

Source position: intuition.pas line 3171

const IMSGA_Seconds = IMSGA_Dummy + 8;


IMSGA_UCS4

Declaration

Source position: intuition.pas line 3176

const IMSGA_UCS4 = IMSGA_Dummy + 13;


IMSGM_NewCopy

Declaration

Source position: intuition.pas line 3178

const IMSGM_NewCopy = $600;


Reference for unit 'intuition'

Screen and Window handling routines of intuition.library

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility, | Tag Handling, Date routines in utility.library
inputevent,
timer,
layers; | Layer handling


Reference for unit 'intuition': Constants

ABSOLUTE_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as absolutes
ALERT_TYPE | Alert Type for DisplayAlert()
ALPHA_P_101 | Value for TPreferences.PrinterType
ALTLEFT | Qualifier for TIntuiMessage.Qualifier. Left Alt Key pressed.
ALTRIGHT | Qualifier for TIntuiMessage.Qualifier. Right Alt Key pressed.
AMIGAKEY | SYSIA_Which tag data values. Menu Amiga-key image
AMIGAKEYS | Qualifier for TIntuiMessage.Qualifier. An Amiga Key pressed.
AMIGALEFT | Qualifier for TIntuiMessage.Qualifier. Left Amiga Key pressed.
AMIGARIGHT | Qualifier for TIntuiMessage.Qualifier. Right Amiga Key pressed.
ANTI_ALIAS | Flag for TPreferences.PrintFlags anti-alias image
ASPECT_HORIZ | Value for TPreferences.PrintAspect
ASPECT_VERT | Value for TPreferences.PrintAspect
AUTOBACKPEN |
AUTODRAWMODE |
AUTOFRONTPEN |
AUTOITEXTFONT
AUTOKNOB | Flag value for TPropInfo.Flags. Gimme that old auto-knob
AUTOLEFTEDGE |
AUTONEXTTEXT
AUTOSCROLL | Flag for TScreen.Flags. Screen is to autoscoll
AUTOTOPEDGE |
BACKGROUNDPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. always color 0
BARBLOCKPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. screen-bar/menus fill
BARDETAILPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. text/detail in screen-bar/menus
BARTRIMPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. trim under screen-bar
BAUD_110 | Value for TPreferences.BaudRate
BAUD_1200 | Value for TPreferences.BaudRate
BAUD_19200 | Value for TPreferences.BaudRate
BAUD_2400 | Value for TPreferences.BaudRate
BAUD_300 | Value for TPreferences.BaudRate
BAUD_4800 | Value for TPreferences.BaudRate
BAUD_9600 | Value for TPreferences.BaudRate
BAUD_MIDI | Value for TPreferences.BaudRate
BEEPING_f | Flag for TScreen.Flags. Set when Screen is beeping
BLOCKPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. compatible Intuition rendering pens
BOOLMASK | Extension is for masked gadget
BOUNDED_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as boundaries
BROTHER_15XL | Value for TPreferences.PrinterType
BTDERR_Display
BTDERR_Memory
BTDERR_Size
BTDIF_3DBlanker
BTDIF_DoNotWait
BTDIF_Fast3D
BTDI_Revision
BTDMAXSTRLEN
BTDPT_BOOLEAN
BTDPT_CYCLE
BTDPT_FILE
BTDPT_FONT
BTDPT_INTEGER
BTDPT_STRING
BTD_Client
BTD_DrawInfo
BTD_Dummy
BTD_Error
BTD_PreviewMode
BUTTONGCLASS | Class identifier. A button gadget that keeps sending button presses while the user holds it down.
CBM_MPS1000 | Value for TPreferences.PrinterType
CENTER_IMAGE | Flag for TPreferences.PrintFlags center image on paper
CHECKED | Flag for TMenuItem.Flags set by the Application and intuition, if CHECKIT, then set this when selected
CHECKIMAGE | SYSIA_Which tag data values. GadTools checkbox image
CHECKIT | Flag for TMenuItem.Flags set by the Application, whether to check this item if selected
CHECKWIDTH | Define for CHECKIT width for the CheckMark in a menu item
CLF_INLIST | class is in public class list (TIClass.cl_Flags)
CLOSEGADGET |
CLOSEIMAGE | SYSIA_Which tag data values. Window close gadget image
COMMSEQ | Flag for TMenuItem.Flags set by the Application, set if there's an command sequence
COMMWIDTH | Define for COMMSEQ width for the Command sequence in a menu item
CORRECT_BLUE | Flag for TPreferences.PrintFlags color correct blue shades
CORRECT_GREEN | Flag for TPreferences.PrintFlags color correct green shades
CORRECT_RED | Flag for TPreferences.PrintFlags color correct red shades
CORRECT_RGB_MASK | Mask for TPreferences.PrintFlags color corrections RGB
CURSORDOWN | RawKeycode for TIntuiMessage.Code. Cursor Down key pressed.
CURSORLEFT | RawKeycode for TIntuiMessage.Code. Cursor left key pressed.
CURSORRIGHT | RawKeycode for TIntuiMessage.Code. Cursor right key pressed.
CURSORUP | RawKeycode for TIntuiMessage.Code. Cursor up key pressed.
CUSTOMBITMAP_f | Flag for TScreen.Flags. If you are supplying your own BitMap
CUSTOMIMAGEDEPTH | if TImage.Depth is this, it's a new Image class object
CUSTOMSCREEN_f | Screentype flag for TScreen.Flags and TNewScreen.SType. For that special look
CUSTOM_NAME | Value for TPreferences.PrinterType
CUSTOM_PAPER | Value for TPreferences.PaperSize
CWCODE_DEPTH | Code for IDCMP_CHANGEWINDOW Window was depth-arranged
CWCODE_MOVESIZE | Code for IDCMP_CHANGEWINDOW Window was moved and/or sized
DEADEND_ALERT | Alert Type for DisplayAlert() no recovery possible, this is it
DEFAULTMOUSEQUEUE | Window value, No more mouse messaged
DEFERREFRESH | Flag for TRequester.Flags. Read-Only. This Requester stops a Refresh broadcast
DEPTHIMAGE | SYSIA_Which tag data values. Window depth gadget image
DETAILPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. Compatible Intuition rendering pens
DEVNAME_SIZE | Devicename size for printer configuration
DIAB_630 | Value for TPreferences.PrinterType
DIAB_ADV_D25 | Value for TPreferences.PrinterType
DIAB_C_150 | Value for TPreferences.PrinterType
DIMENSIONS_MASK | Mask for TPreferences.PrintFlags Dimensions mask
DITHERING_MASK | Mask for TPreferences.PrintFlags Dithering mask
DMODECOUNT |
DOSLOGO_DISKBUSY
DOSLOGO_DISKERROR
DOSLOGO_DISKFULL
DOSLOGO_DISKINSERT
DOSLOGO_DISKNOTVALIDATED
DOSLOGO_DISKPROTECTED
DOSLOGO_NODISK
DOSLOGO_NOTADOSDISK
DOWNBACKGADGET |
DOWNIMAGE | SYSIA_Which tag data values. Down-arrow gadget image
DRAFT | Value for TPreferences.PrintQuality
DRAGGADGET |
DRIF_DIRECTCOLOR
DRIF_NEWLOOK | Flag for TDrawInfo.dri_Flags specified SA_Pens, full treatment
DRIPEN_BACKGROUND
DRIPEN_BARBLOCK
DRIPEN_BARDETAIL
DRIPEN_BARTRIM
DRIPEN_BLOCK
DRIPEN_DETAIL
DRIPEN_FILL
DRIPEN_FILLTEXT
DRIPEN_HALFSHADOW
DRIPEN_HALFSHINE
DRIPEN_HIGHLIGHTTEXT
DRIPEN_NUMDRIPENS
DRIPEN_SHADOW
DRIPEN_SHINE
DRIPEN_TEXT
DRI_VERSION | Version of the TDrawInfo structure, can be found in TDrawInfo.dri_Version
EES_ActiveButton
EES_DiskBased
EES_DosLogo
EES_Dummy
EIGHT_LPI | Value for TPreferences.PrintSpacing
ELITE | Value for TPreferences.PrintPitch
EO_BADFORMAT | Value for TSGWork.EditOp
EO_BIGCHANGE | Value for TSGWork.EditOp
EO_CLEAR | Value for TSGWork.EditOp
EO_DELBACKWARD | Value for TSGWork.EditOp
EO_DELFORWARD | Value for TSGWork.EditOp
EO_ENTER | Value for TSGWork.EditOp
EO_INSERTCHAR | Value for TSGWork.EditOp
EO_MOVECURSOR | Value for TSGWork.EditOp
EO_NOOP | Value for TSGWork.EditOp
EO_REPLACECHAR | Value for TSGWork.EditOp
EO_RESET | Value for TSGWork.EditOp
EO_SPECIAL | Value for TSGWork.EditOp
EO_UNDO | Value for TSGWork.EditOp
EPSON | Value for TPreferences.PrinterType
EPSON_JX_80 | Value for TPreferences.PrinterType
ETD_Iconify
ETD_Jump
ETD_Lock
ETD_MUI
ETD_PopUp
ETD_Snapshot
ETG_ICONIFY
ETG_JUMP
ETG_LOCK
ETG_MUI
ETG_POPUP
ETG_SNAPSHOT
ETI_Dummy
ETI_Iconify
ETI_Jump
ETI_Lock
ETI_MUI
ETI_PopUp
ETI_Snapshot
EURO_A0 | Value for TPreferences.PaperSize European size A0: 841 x 1189
EURO_A1 | Value for TPreferences.PaperSize European size A1: 594 x 841
EURO_A2 | Value for TPreferences.PaperSize European size A2: 420 x 594
EURO_A3 | Value for TPreferences.PaperSize European size A3: 297 x 420
EURO_A4 | Value for TPreferences.PaperSize European size A4: 210 x 297
EURO_A5 | Value for TPreferences.PaperSize European size A5: 148 x 210
EURO_A6 | Value for TPreferences.PaperSize European size A6: 105 x 148
EURO_A7 | Value for TPreferences.PaperSize European size A7: 74 x 105
EURO_A8 | Value for TPreferences.PaperSize European size A8: 52 x 74
EVENTMAX |
FANFOLD_PT |
FILENAME_SIZE | Filename size for printer configuration
FILLPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. active-window/selected-gadget fill
FILLRECTCLASS | Class identifier
FILLTEXTPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. text over FILLPEN
FINE | Value for TPreferences.PrintPitch
FLOYD_DITHERING | Flag for TPreferences.PrintFlags Floyd-Steinberg dithering
FRAMEF_SPECIFY | Flag for TimpFrameBox.imp_FrameFlags
FRAMEICLASS | Class identifier. This is a class of framing image, which can optionally fill itself.
FRAME_BUTTON | Data value for IA_FrameType Standard button gadget frames, having thicker sides and nicely edged corners.
FRAME_DEFAULT | Data value for IA_FrameType The standard V37-type frame, which has thin edges.
FRAME_ICONDROPBOX | Data value for IA_FrameType A broad ridge which is the standard imagery for areas in AppWindows where icons may be dropped.
FRAME_RIDGE | Data value for IA_FrameType A ridge such as used by standard string gadgets. You can recess the ridge to get a groove image.
FRBUTTONCLASS | Class identifier. A buttongclass gadget that outlines its imagery with a frame.
FREEHORIZ | Flag value for TPropInfo.Flags. if set, the knob can move horizontally
FREEVERT | Flag value for TPropInfo.Flags. if set, the knob can move vertically
GACT_ACTIVEGADGET | Activation flag for TGadget.Activation. This gadget is "active".
GACT_ALTKEYMAP | Activation flag for TGadget.Activation. this String has an alternate keymap
GACT_BOOLEXTEND | Activation flag for TGadget.Activation. this Boolean Gadget has a BoolInfo
GACT_BORDERSNIFF | Activation flag for TGadget.Activation. neither set nor rely on this bit
GACT_BOTTOMBORDER | Activation flag for TGadget.Activation.
GACT_ENDGADGET | Activation flag for TGadget.Activation. when set, tells the system that this gadget, when selected, causes the Requester to be ended. Requesters that are ended are erased and unlinked from the system.
GACT_FOLLOWMOUSE | Activation flag for TGadget.Activation. when set, specifies that you want to receive reports on mouse movements
GACT_IMMEDIATE | Activation flag for TGadget.Activation. when set, informs the caller that the gadget was activated when it was activated. This flag works in conjunction with the GACT_RELVERIFY flag
GACT_LEFTBORDER | Activation flag for TGadget.Activation.
GACT_LONGINT | Activation flag for TGadget.Activation. this String Gadget is for LongInts
GACT_RELVERIFY | Activation flag for TGadget.Activation. Set if you want to verify that the pointer was still over the gadget when the select button was released. Will cause an IDCMP_GADGETUP message to be sent if so.
GACT_RIGHTBORDER | Activation flag for TGadget.Activation.
GACT_STRINGCENTER | Activation flag for TGadget.Activation.
GACT_STRINGEXTEND | Activation flag for TGadget.Activation. this String Gadget has PStringExtend
GACT_STRINGLEFT | Activation flag for TGadget.Activation.
GACT_STRINGRIGHT | Activation flag for TGadget.Activation.
GACT_TOGGLESELECT | Activation flag for TGadget.Activation. this bit for toggle-select mode
GACT_TOPBORDER | Activation flag for TGadget.Activation.
GADGETCLASS | Class identifier. This is a base class for Intuition compatible gadget objects.
GADGETCOUNT |
GA_ActivateKey | GadgetClass Tag. (PChar) Set/Get the gadgets shortcut/activation key(s) Default = nil
GA_BackFill | GadgetClass Tag. (PHook) Backfill pattern hook. Defaults to nil.
GA_Border | GadgetClass Tag. (PBorder) Gadget imagry is a border
GA_BottomBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the bottom border or not. Default = False.
GA_Bounds | GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.
GA_Disabled | GadgetClass Tag. [IS.] (LongWord) Takes GFLG_GADGH* flags as argument. Used to specify the highlighting technique.
GA_DrawInfo | GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.
GA_Dummy | GadgetClass Start Tag.
GA_EndGadget | GadgetClass Tag. [ISG] (LongBool) Indicate whether the gadget is selected or not. Default = False
GA_FollowMouse | GadgetClass Tag. [IS.] (LongBool) If this is set, the gadget receives information about the movement of the mouse as long as it is activated. Default = False
GA_GadgetHelp | GadgetClass Tag. [..G] (LongBool) If this is set by the gadget, the sends GADGETHELP messages.
GA_GadgetHelpText | GadgetClass Tag. (PChar) RESERVERD/PRIVATE DO NOT USE. Default = nil
GA_GZZGadget | GadgetClass Tag. [ISG] (LongBool) If this is set to true, the gadget is not selectable.
GA_Height | GadgetClass Tag. [ISG] (LongInt) Height of gadget.
GA_Highlight | GadgetClass Tag. [IS.] (PImage) Gadgets' image in selected state.
GA_ID | GadgetClass Tag. [IS.] (LongBool) The Gadget is a GimmeZeroZero gadget. Default = False
GA_Image | GadgetClass Tag. (PImage) Gadget imagry is an image
GA_Immediate | GadgetClass Tag. [IS.] (LongBool) Only used for requester gadgets. Default = False
GA_IntuiText | GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.
GA_LabelImage | GadgetClass Tag. [IS.] (PObject_) Label is an image object.
GA_LabelPlace
GA_Left | GadgetClass Tag. [ISG] (LongInt) Left edge of gadget.
GA_LeftBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the left border or not. Default = False.
GA_Next | GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.
GA_Previous | GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.
GA_ReadOnly | GadgetClass Tag. (LongBool) Indicate that the gadget is read-only (non-selectable). Default = False
GA_RelBottom | GadgetClass Tag. [ISG] (LongInt) Top edge of gadget, depending on bottom window border: Top := Win^.Height - this - 1
GA_RelHeight | GadgetClass Tag. [ISG] (LongInt) Height of gadget, depending on window height: Height := Win^.Height - this
GA_RelRight | GadgetClass Tag. [ISG] (LongInt) Left edge of gadget, depending on right window border: Left := Win^.Width - this - 1
GA_RelSpecial | GadgetClass Tag. [IS.] (LongInt) This attribute should only be set by subclasses of GadgetClass.
GA_RelVerify | GadgetClass Tag. [IS.] (LongBool) If set the gadget responds immediatly, when the gadget is selected. Default = False
GA_RelWidth | GadgetClass Tag. [ISG] (LongInt) Width of gadget, depending on window width: Width := Win^.Width - this
GA_RightBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the right border or not. Default = False.
GA_Selected | GadgetClass Tag. (APTR) Pointer to additional information
GA_SelectRender | GadgetClass Tag.
GA_SpecialInfo | GadgetClass Tag. [ISG] (IPTR) Fill with whatever you want to. This field is ignored by the system.
GA_SysGadget | GadgetClass private Tag. [IS.] (LongBool) Set, if gadget is a system-gadget e.g. a standard window border gadget. Default = False.
GA_SysGType | GadgetClass private Tag. [IS.] (LongWord) Reserved for system use to indicate the gadget type.
GA_TabCycle | GadgetClass Tag. [IS.] (LongBool) If set to true that gadget participates in TAB handling, i.e. if tab is pressed, the next gadget is activated.
GA_Text | GadgetClass Tag. [IS.] (PChar) Label text. This is mutually exclusive with GA_IntuiText and GA_LabelImage.
GA_TextAttr | GadgetClass Tag. [IS.] (PTextAttr) Indicate the font to use for the gadget.
GA_ToggleSelect | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is toggle-selected or not. Default = False.
GA_Top | GadgetClass Tag. [ISG] (LongInt) Top edge of gadget.
GA_TopBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the top border or not. Default = False.
GA_Underscore | GadgetClass Tag. (Char) Underscore/escape character for keyboard shortcuts. Defaults = '_'
GA_UserData | GadgetClass Tag. (LongInt) Gadget ID assigned by the application (prevent double numbers)
GA_UserInput | GadgetClass Tag. (LongBool) Notification tag indicates this notification is from the activite gadget receiving user input - an attempt to make IDCMPUPDATE more efficient.
GA_Width | GadgetClass Tag. [ISG] (LongInt) Width of gadget.
GDIA_CheckMark
GDIA_Color
GDIA_Depth
GDIA_DirectColor
GDIA_Font
GDIA_MenuKey
GDIA_NumPens
GDIA_Pen
GDIA_ResolutionX
GDIA_ResolutionY
GDIA_Version
GDOMAIN_MAXIMUM |
GDOMAIN_MINIMUM |
GDOMAIN_NOMINAL |
GFLG_DISABLED | Flag for TGadget.SpecialInfo. Is initialized by you and later set by Intuition according to your calls to OnGadget/OffGadget. It specifies whether or not this Gadget is currently disabled from being selected
GFLG_EXTENDED | Flag for TGadget.SpecialInfo. Gadget is an PExtGadget
GFLG_GADGHBOX | Flag for TGadget.SpecialInfo. Draw a box around the image
GFLG_GADGHCOMP | Flag for TGadget.Flags. Complement the select box
GFLG_GADGHIGHBITS | Flag for TGadget.SpecialInfo.
GFLG_GADGHIMAGE | Flag for TGadget.SpecialInfo. Blast in this alternate image
GFLG_GADGHNONE | Flag for TGadget.SpecialInfo. don't highlight
GFLG_GADGIMAGE | Flag for TGadget.SpecialInfo. set if TGadget.GadgetRender and TGadget.SelectRender is PImage, clear if it is a PBorder
GFLG_IMAGEDISABLE | Flag for TGadget.SpecialInfo. Gadget's image knows how to do disabled rendering
GFLG_LABELIMAGE | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PImage
GFLG_LABELITEXT | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText
GFLG_LABELMASK | Flag for TGadget.SpecialInfo.
GFLG_LABELSTRING | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PChar
GFLG_RELBOTTOM | Flag for TGadget.SpecialInfo. vertical position is relative to bottom edge
GFLG_RELHEIGHT | Flag for TGadget.SpecialInfo. height is relative to req/window
GFLG_RELRIGHT | Flag for TGadget.SpecialInfo. horizontal position is relative to right edge
GFLG_RELSPECIAL | Flag for TGadget.SpecialInfo. Custom gadget has special relativity. Gadget box values are absolutes, but can be changed via the GM_LAYOUT method.
GFLG_RELWIDTH | Flag for TGadget.SpecialInfo. width is relative to req/window
GFLG_SELECTED | Flag for TGadget.SpecialInfo. you may initialize and look at this
GFLG_STRINGEXTEND | Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend
GFLG_TABCYCLE | Flag for TGadget.SpecialInfo. (string OR custom) gadget participates in cycling activation with Tab or Shift-Tab
GMLA_DisplayID
GMLA_Dummy
GMORE_BOUNDS | Flag for TExtGadget.MoreFlags ExtGadget has valid Bounds
GMORE_GADGETHELP | Flag for TExtGadget.MoreFlags This gadget responds to gadget help
GMORE_SCROLLRASTER | Flag for TExtGadget.MoreFlags This (custom) gadget uses ScrollRaster
GMR_GADGETHIT | Result for GM_HITTEST Hit
GMR_HELPCODE | Result for GM_HELPTEST Hit, return low Word as code.
GMR_HELPHIT | Result for GM_HELPTEST Hit, The gadget was hit.
GMR_KEYACTIVE |
GMR_KEYVERIFY |
GMR_MEACTIVE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GMR_NEXTACTIVE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate next gadget.
GMR_NOHELPHIT | Result for GM_HELPTEST didn't hit
GMR_NOREUSE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GMR_PREVACTIVE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate previous gadget.
GMR_REUSE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GMR_VERIFY | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GM_Dummy | GadgetClass Method IDs Start
GM_GOACTIVE | GadgetClass Method ID. You are now going to be fed input
GM_GOINACTIVE | GadgetClass Method ID. Whether or not by choice, you are done
GM_HANDLEINPUT | GadgetClass Method ID.
GM_HELPTEST | GadgetClass Method ID. Will you send gadget help if the mouse is at the specified coordinates? See below for possible GMR_ values.
GM_HITTEST | GadgetClass Method ID. Returns GMR_GADGETHIT if you are clicked on (whether or not you are disabled).
GM_LAYOUT | GadgetClass Method ID. Re-evaluate your size based on the GadgetInfo Domain. Do NOT re-render yourself yet, you will be called when it is time...
GM_RENDER | GadgetClass Method ID. Draw yourself, in the appropriate state
GREDRAW_REDRAW | TgpRender.gpr_Redraw. Redraw the whole gadget
GREDRAW_TOGGLE | TgpRender.gpr_Redraw. Toggle highlight, if applicable
GREDRAW_UPDATE | TgpRender.gpr_Redraw. Incremental update. Some data (e.g. the level of a slider) was updated. Just redraw the necessary parts.
GREY_SCALE2 | Flag for TPreferences.PrintFlags for use with hi-res monitor
GROUPGCLASS | Class identifier. A special gadget class that creates one composite gadget out of several others.
GTYP_BOOLGADGET | Application gadget type for TGadget.Type
GTYP_CLOSE | System gadget type for TGadget.Type
GTYP_CUSTOMGADGET | Application gadget type for TGadget.Type
GTYP_GADGET0002 | Application gadget type for TGadget.Type
GTYP_GADGETTYPE | All Gadget Global type flags for TGadget.Type
GTYP_GTYPEMASK | Application gadget type for TGadget.Type mask you can apply to tell what class of gadget this is.
GTYP_GZZGADGET | Application gadget type for TGadget.Type for WFLG_GIMMEZEROZERO borders
GTYP_PROPGADGET | Application gadget type for TGadget.Type
GTYP_REQGADGET | Application gadget type for TGadget.Type this is a Requester Gadget
GTYP_SCRGADGET | Application gadget type for TGadget.Type 1 = ScreenGadget, 0 = WindowGadget
GTYP_SDEPTH
GTYP_SDOWNBACK |
GTYP_SDRAGGING | System gadget type for TGadget.Type
GTYP_SIZING | System gadget type for TGadget.Type
GTYP_STRGADGET | Application gadget type for TGadget.Type
GTYP_SUNUSED
GTYP_SUPFRONT |
GTYP_SYSGADGET | Application gadget type for TGadget.Type 1 = Allocated by the system, 0 = by application
GTYP_WDEPTH
GTYP_WDOWNBACK |
GTYP_WDRAGGING | System gadget type for TGadget.Type
GTYP_WDRAGGING2
GTYP_WUPFRONT |
GTYP_WZOOM
GV_LabelPlace_Above
GV_LabelPlace_Below
GV_LabelPlace_In
GV_LabelPlace_Left
GV_LabelPlace_Right
HALFTONE_DITHERING | Flag for TPreferences.PrintFlags halftone dithering
HC_GADGETHELP | Flag for HelpControl() Set this flag to enable Gadget-Help for one or more windows.
HIGHBOX | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by "boxing" the selectbox
HIGHCOMP | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by complementing the selectbox
HIGHFLAGS | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, see definitions below for these bits
HIGHIMAGE | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, use the user's "select image"
HIGHITEM | Flag for TMenuItem.Flags set by intuition (ReadOnly), this item is currently highlighted
HIGHLIGHTTEXTPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. special color text, on background
HIGHNONE | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, don't highlight
HIRESGADGET |
HIRESPICK |
HOVERSTART
HOVERSTOP
HP_LASERJET | Value for TPreferences.PrinterType
HP_LASERJET_PLUS | Value for TPreferences.PrinterType
IA_ActivateKey |
IA_APatSize | ImageClass Attribute.
IA_APattern | ImageClass Attribute.
IA_BGPen | ImageClass Attribute. IA_BGPen also means "PlaneOnOff"
IA_Data | ImageClass Attribute. bitplanes, for classic image, other image classes may use it for other things
IA_DoubleEmboss | ImageClass Attribute.
IA_Dummy | ImageClass Attributes start.
IA_EdgesOnly | ImageClass Attribute. to specify that the interior of a frame should not be cleared
IA_FGPen | ImageClass Attribute. IA_FGPen also means "PlanePick"
IA_Font | ImageClass Attribute.
IA_FrameType | SysIClass Attribute. FrameIClass recognizes several standard types of frame.
IA_Height | ImageClass Attribute.
IA_HighlightPen |
IA_Left | ImageClass Attribute.
IA_LineWidth | ImageClass Attribute.
IA_Mode | ImageClass Attribute.
IA_Outline | ImageClass Attribute.
IA_Pens | ImageClass Attribute. pointer to Word pens[], ala TDrawInfo.Pens, must be terminated by (not 0). Some classes can choose to have this, or SYSIA_DrawInfo, or both.
IA_Precision |
IA_Recessed | ImageClass Attribute.
IA_Resolution | ImageClass Attribute. packed Words for x/y resolution into a LongWord ala TDrawInfo.Resolution
IA_Scalable |
IA_Screen |
IA_ShadowPen |
IA_SupportsDisable | SysIClass Attribute. Tell intuition to use IDS_*DISABLED instead of own code
IA_Top | ImageClass Attribute.
IA_Underscore |
IA_Width | ImageClass Attribute.
ICA_Dummy | Interconnection attributes start used by icclass, modelclass and gadgetclass
ICA_MAP | interconnection map tagitem list used by icclass, modelclass and gadgetclass
ICA_TARGET | Interconnection target used by icclass, modelclass and gadgetclass
ICCLASS | Class identifier. Interconnection class
ICM_CHECKLOOP | icclass Method. Set/increment loop
ICM_CLEARLOOP | icclass Method. Clear/decrement loop counter
ICM_Dummy | icclass Methods start
ICM_SETLOOP | icclass Method. Set/increment loop counter
ICONIFYIMAGE
ICSPECIAL_CODE | a "pseudo-attribute" used by icclass, modelclass and gadgetclass
ICTARGET_IDCMP |
IDCMP_ACTIVEWINDOW | IDCMP class: Window is activated
IDCMP_CHANGEWINDOW | IDCMP class: Window changed size or position
IDCMP_CLOSEWINDOW | IDCMP class: User pressed close button of window
IDCMP_DELTAMOVE | IDCMP class:
IDCMP_DISKINSERTED | IDCMP class: Floppy disk inserted
IDCMP_DISKREMOVED | IDCMP class: Floppy disk removed
IDCMP_GADGETDOWN | IDCMP class: user selects a gadget
IDCMP_GADGETHELP | IDCMP class
IDCMP_GADGETUP | IDCMP class: user selects a gadget
IDCMP_IDCMPUPDATE | IDCMP Class: gadget notification
IDCMP_INACTIVEWINDOW | IDCMP class: Window is deactivated
IDCMP_INTUITICKS | IDCMP Class: Time ticks
IDCMP_LONELYMESSAGE | IDCMP class: Private
IDCMP_MENUHELP | IDCMP Class: Help key pressed
IDCMP_MENUPICK | IDCMP class: User opened the menu
IDCMP_MENUVERIFY | IDCMP class: Verify ready to show menu
IDCMP_MOUSEBUTTONS | IDCMP class: Contains reports about mouse button up and down events.
IDCMP_MOUSEHOVER
IDCMP_MOUSEMOVE | IDCMP class: Reports about mouse movements
IDCMP_MOUSEOBJECTMUI
IDCMP_NEWPREFS | IDCMP class: Preferences are changed
IDCMP_NEWSIZE | IDCMP class: User resized the Window
IDCMP_RAWKEY | IDCMP class: Raw keycodes from keyboard
IDCMP_REFRESHWINDOW | IDCMP class: Window needs refreshing
IDCMP_REQCLEAR | IDCMP class: Requester is cleared
IDCMP_REQSET | IDCMP class: Recive message when a requester opens
IDCMP_REQVERIFY | IDCMP class: Verify intuition is ready to render a requester
IDCMP_SIZEVERIFY | IDCMP class: resize must be verified by application
IDCMP_VANILLAKEY | IDCMP class: keyboard events
IDCMP_WBENCHMESSAGE | IDCMP class: private
IDOMAIN_MAXIMUM |
IDOMAIN_MINIMUM |
IDOMAIN_NOMINAL |
IDS_BUSY | Image draw style for IM_DRAW for future functionality
IDS_DISABLED | Image draw state for IM_DRAW for disabled gadgets
IDS_INACTIVEDISABLED | Image draw style for IM_DRAW disabled, in inactive border
IDS_INACTIVENORMAL | Image draw style for IM_DRAW normal, in inactive window border
IDS_INACTIVESELECTED | Image draw style for IM_DRAW selected, in inactive border
IDS_INDETERMINANT |
IDS_INDETERMINATE | Image draw style for IM_DRAW for future functionality
IDS_NORMAL | Image draw style for IM_DRAW
IDS_SELECTED | Image draw state for IM_DRAW for selected gadgets
IDS_SELECTEDDISABLED | Image draw style for IM_DRAW disabled and selected
IGNORE_DIMENSIONS | Flag for TPreferences.PrintFlags ignore max width/height settings
IMAGECLASS | Class identifier. This class is the base class for Boopsi Images.
IMAGE_NEGATIVE | Value for TPreferences.PrintImage
IMAGE_POSITIVE | Value for TPreferences.PrintImage
IMSGA_Class
IMSGA_Code
IMSGA_Dummy
IMSGA_IAddress
IMSGA_IDCMPWindow
IMSGA_Micros
IMSGA_MouseX
IMSGA_MouseY
IMSGA_Qualifier
IMSGA_RawMouseX
IMSGA_RawMouseY
IMSGA_Seconds
IMSGA_UCS4
IMSGM_NewCopy
IM_DOMAINFRAME |
IM_DRAW | imageclass message id. draw yourself, with "state" (IDS_*)
IM_DRAWFRAME | imageclass message id. draw with specified dimensions
IM_ERASE | imageclass message id. erase yourself
IM_ERASEFRAME | imageclass message id. hittest with dimensions
IM_FRAMEBOX | imageclass message id. get recommended frame around some box
IM_HITFRAME | imageclass message id. hittest with dimensions
IM_HITTEST | imageclass message id. return True if click hits image
IM_MOVE | imageclass message id. draw new and erase old, smoothly
INTEGER_SCALING | Flag for TPreferences.PrintFlags force integer scaling
INTUITIONNAME
ISDRAWN | Flag for TMenuItem.Flags set by intuition (ReadOnly), this item's subs are currently drawn
ITEMENABLED | Flag for TMenuItem.Flags set by the Application, set if this item is enabled
ITEMTEXT | Flag for TMenuItem.Flags set by the Application, set if textual, clear if graphical item
ITEXTICLASS | Class identifier. A specialized image class used for rendering text.
JUMPIMAGE
KEYCODE_B | RawKeycode for TIntuiMessage.Code. 'b' key pressed.
KEYCODE_GREATER | RawKeycode for TIntuiMessage.Code. '>' key pressed.
KEYCODE_LESS | RawKeycode for TIntuiMessage.Code. '<' key pressed.
KEYCODE_M | RawKeycode for TIntuiMessage.Code. 'm' key pressed.
KEYCODE_N | RawKeycode for TIntuiMessage.Code. 'n' key pressed.
KEYCODE_Q | RawKeycode for TIntuiMessage.Code. 'q' key pressed.
KEYCODE_V | RawKeycode for TIntuiMessage.Code. 'v' key pressed.
KEYCODE_X | RawKeycode for TIntuiMessage.Code. 'x' key pressed.
KNOBHIT | Flag value for TPropInfo.Flags. set when this Knob is hit
KNOBHMIN | Minimum horizontal size of the Knop
KNOBVMIN | minimum vertical size of the Knop
LACEWB | Interlace define for TPreferences.LaceWB
LAYOUTA_ChildMaxHeight | GadgetClass Layout Tag. (LongBool) Child objects are of equal height. Should default to True for gadgets with a vertical orientation.
LAYOUTA_ChildMaxWidth | GadgetClass Layout Tag. (LongBool) Child objects are of equal width. Should default to True for gadgets with a horizontal orientation.
LAYOUTA_Dummy | GadgetClass Layout start Tag.
LAYOUTA_LayoutObj | GadgetClass Layout Tag.
LAYOUTA_Orientation | GadgetClass Layout Tag. (LongInt) Orientation LORIENT_*
LAYOUTA_Spacing | GadgetClass Layout Tag.
LEFTIMAGE | SYSIA_Which tag data values. Left-arrow gadget image
LETTER | Value for TPreferences.PrintQuality
LOCKIMAGE
LOGO_CRASH
LORIENT_HORIZ | Orientation values for LAYOUTA_Orientation
LORIENT_NONE | Orientation values for LAYOUTA_Orientation
LORIENT_VERT | Orientation values for LAYOUTA_Orientation
LOWCHECKWIDTH | Define for CHECKIT width for the CheckMark (Low res resolution) in a menu item
LOWCOMMWIDTH | Define for COMMSEQ width for the Command sequence (Low resolution) in a menu item
LOWRESGADGET |
LOWRESPICK |
LW_RESERVED | internal use only for TPreferences.LaceWB
MAXBODY | Maximum body value in TPropInfo
MAXPOT | Maximum pot value in TPropInfo
MAXPUBSCREENNAME | Maximum length of public screen names. The buffers containing these strings must have a length of MAXPUBSCREENNAME + 1.
MA_BacklightControl
MA_BacklightLevel
MA_BacklightLevelSteps
MA_BottomLeftMonitor
MA_BottomMiddleMonitor
MA_BottomRightMonitor
MA_DriverName
MA_Dummy
MA_GammaControl
MA_Manufacturer
MA_ManufacturerID
MA_MemoryClock
MA_MemorySize
MA_MiddleLeftMonitor
MA_MiddleRightMonitor
MA_MonitorName
MA_PixelFormats
MA_PointerType
MA_ProductID
MA_TopLeftMonitor
MA_TopMiddleMonitor
MA_TopRightMonitor
MENUCANCEL | Code for IDCMP_MENUVERIFY HOT Reply of this cancels Menu operation
MENUCHECK | SYSIA_Which tag data values. Menu checkmark image
MENUDOWN | RawMouse code for TIntuiMessage.Code. Right Mouse Button down.
MENUENABLED | Flag for TMenu.Flags, whether or not this menu is enabled
MENUHOT | Code for IDCMP_MENUVERIFY Intuition wants verification or MENUCANCEL
MENUNULL |
MENUTOGGLE | Flag for TMenuItem.Flags set by the Application, set to toggle the check of a menu item
MENUTOGGLED | Flag for TMenuItem.Flags set by intuition (ReadOnly), this item was already toggled
MENUTOGGLEIMAGE
MENUUP | RawMouse code for TIntuiMessage.Code. Right Mouse Button up.
MENUWAITING | Code for IDCMP_MENUVERIFY Intuition simply wants a ReplyMsg() ASAP
MIDDLEDOWN | RawMouse code for TIntuiMessage.Code. Middle Mouse Button down.
MIDDLEUP | RawMouse code for TIntuiMessage.Code. Middle Mouse Button up.
MIDRAWN | Flag for TMenu.Flags, this menu's items are currently drawn (ReadOnly)
MM_Authorization
MM_EnterPowerSaveMode
MM_ExitBlanker
MM_GetDefaultGammaTables
MM_GetDefaultPixelFormat
MM_GetPointerBounds
MM_GetRootBitMap
MM_Query3DSupport
MM_RunBlanker
MODELCLASS | Class identifier. Multiple Targets
MONITOR_MAXPIXELFORMATS
MOUSE_ACCEL
MSQUERY3D_HWDRIVER
MSQUERY3D_NODRIVER
MSQUERY3D_SWDRIVER
MSQUERY3D_UNKNOWN
MUIA_Screenbar_DisplayedImage
MUIA_Screenbar_DisplayedName
MUIIMAGE
MUIM_Screenbar_BuildSettingsPanel
MUIM_Screenbar_DefaultConfigItem
MUIM_Screenbar_KnowsConfigItem
MUIM_Screenbar_Lock
MUIM_Screenbar_Signal
MUIM_Screenbar_Unlock
MUIM_Screenbar_UpdateConfigItem
MUIM_UpdateConfig
MUISERIALNO_INTUITION
MULTIPLY_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as multipliers
MXIMAGE | SYSIA_Which tag data values. GadTools mutual exclude "button" image
NOISYREQ | Flag for TRequester.Flags. Requester does not filter input.
NOITEM |
NOMENU |
NOREQBACKFILL | Flag for TRequester.Flags. Don't bother filling requester with TRequester.BackFill pen
NOSUB |
NS_EXTENDED | Flag for TScreen.Flags. TExtNewScreen.Extension is valid
NUMDRIPENS | Rendering pen number indexes into TDrawInfo.dri_Pens.
N_TRACTOR | Value for TPreferences.PaperSize
OKABORT | Internal token to represent state of verification attempts shown here as a clue. window rendered question moot
OKCANCEL | Internal token to represent state of verification attempts shown here as a clue. window sent cancel reply
OKIMATE_20 | Value for TPreferences.PrinterType
OKOK | Internal token to represent state of verification attempts shown here as a clue. guy didn't care
OM_ADDMEMBER | This method tells an object to add an object to its broadcast list.
OM_ADDTAIL | This method tells an object to add itself to the end of an Exec list.
OM_DISPOSE | This method tells an object to dispose of itself.
OM_Dummy | Start of dispatched method ID's
OM_GET | This method tells an object to report an attribute value.
OM_NEW | This method creates a new object.
OM_NOTIFY | This method tells an object to broadcast an attribute change to its broadcast list.
OM_REMMEMBER | This method tells an object to remove an object from its broadcast list.
OM_REMOVE | This method tells an object to remove itself from an Exec list.
OM_SET | This method tells an object to set one or more of its attribute values.
OM_UPDATE | This method tells an object to update one or more of its attribute values.
OPUF_INTERIM | Flag for TopUpdate.opu_Flags
ORDERED_DITHERING | Flag for TPreferences.PrintFlags ordered dithering
OSCAN_MAX | Identifier for SA_Overscan as much as possible
OSCAN_STANDARD | Identifier for SA_Overscan just past edges
OSCAN_TEXT | Identifier for SA_Overscan entirely visible
OSCAN_VIDEO | Identifier for SA_Overscan even more than is possible
OSERR_ATTACHFAIL
OSERR_NOCHIPMEM | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get chipmem
OSERR_NOCHIPS | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode You need newer custom chips
OSERR_NOMEM | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get normal memory
OSERR_NOMONITOR | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Named monitor spec not available
OSERR_NOTAVAILABLE
OSERR_PUBNOTUNIQUE | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Public screen name already used
OSERR_TOODEEP
OSERR_UNKNOWNMODE | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Don't recognize mode asked for
PARALLEL_PRINTER | Value for TPreferences.PrinterPort
PENSHARED | Flag for TScreen.Flags. Screen opener set (SA_SharePens,True)
PEN_C0 | Complement of color 0
PEN_C1 | Complement of color 1
PEN_C2 | Complement of color 2
PEN_C3 | Complement of color 3
PGA_Borderless | PropGClass Tag. (LongBool) If set, no border will be rendered.
PGA_Dummy | PropGClass Start Tag.
PGA_Freedom | PropGClass Tag. [IS.] (LongWord) Define in which the direction gadget should stretch.
PGA_HorizBody | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_HorizPot | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_NewLook | PropGClass Tag. [IS.] (LongBool) If set, this indicated that the new look should be used for rendering.
PGA_NotifyBehaviour
PGA_RenderBehaviour
PGA_Top | PropGClass Tag. [ISG] (Word) The first visible position.
PGA_Total | PropGClass Tag. [IS.] (Word) The total number of positions in the gadget.
PGA_VertBody | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_VertPot | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_Visible | PropGClass Tag. [IS.] (Word) The number of visible positions in the gadget.
PG_BEHAVIOUR_COMPATIBLE
PG_BEHAVIOUR_NICE
PICA | Value for TPreferences.PrintPitch
PIXEL_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as prt pixels
POINTERA_BitMap | PointerClass Attribute. (PBitmap) Pointer to bitmap to get pointer imagery from. Bitplane data need not be in chip RAM.
POINTERA_Dummy | PointerClass Attributes start.
POINTERA_WordWidth | PointerClass Attribute. (LongWord) - designed width of the pointer in words
POINTERA_XOffset | PointerClass Attribute. (LongInt) - X-offset of the pointer hotspot.
POINTERA_XResolution | PointerClass Attribute. (LongWord) - one of the POINTERXRESN_* flags
POINTERA_YOffset | PointerClass Attribute. (LongInt) - Y-offset of the pointer hotspot.
POINTERA_YResolution | PointerClass Attribute. (LongWord) - one of the POINTERYRESN_* flags
POINTERCLASS | Class identifier
POINTERSIZE | Size of Pointer data buffer for printer configuration
PointerType_2Plus1
PointerType_3Plus1
POINTERTYPE_AIMING
POINTERTYPE_ALTERNATIVECHOICE
PointerType_ARGB
POINTERTYPE_BUSY
POINTERTYPE_DIAGONALRESIZE1
POINTERTYPE_DIAGONALRESIZE2
POINTERTYPE_DOT
POINTERTYPE_HANDWRITING
POINTERTYPE_HELP
POINTERTYPE_HORIZONTALRESIZE
POINTERTYPE_INVISIBLE
POINTERTYPE_MOVE
POINTERTYPE_NORMAL
POINTERTYPE_NOTAVAILABLE
POINTERTYPE_NUMTYPES
POINTERTYPE_SELECTLINK
POINTERTYPE_SELECTTEXT
POINTERTYPE_VERTICALRESIZE
POINTERTYPE_WORKING
POINTERXRESN_140NS | Value for POINTERA_XResolution (pointer always in 140 ns pixels) = 140 ns always
POINTERXRESN_35NS | Value for POINTERA_XResolution (pointer always in 35 ns pixels) = 35 ns always
POINTERXRESN_70NS | Value for POINTERA_XResolution (pointer always in 70 ns pixels) = 70 ns always
POINTERXRESN_DEFAULT | Value for POINTERA_XResolution (ECS-compatible pointer width) = 70 ns if SUPERHIRES-type mode, 140 ns if not
POINTERXRESN_HIRES | Value for POINTERA_XResolution (pointer always in hires-like pixels) = 70 ns in 15kHz modes, 35 ns in 31kHz modes
POINTERXRESN_LORES | Value for POINTERA_XResolution (pointer always in lores-like pixels) = 140 ns in 15kHz modes, 70 ns in 31kHz modes
POINTERXRESN_SCREENRES | Value for POINTERA_XResolution Same as pixel speed of screen
POINTERYRESN_DEFAULT | Value for POINTERA_YResolution Default pointer
POINTERYRESN_HIGH | Value for POINTERA_YResolution Highres pointer
POINTERYRESN_HIGHASPECT | Value for POINTERA_YResolution Highres pointer
POINTERYRESN_SCREENRES | Value for POINTERA_YResolution Highres pointer
POINTERYRESN_SCREENRESASPECT | Value for POINTERA_YResolution Highres pointer
POINTREL | Flag for TRequester.Flags. If set TopLeft is relative to pointer to the coordinates of either the pointer or the window.
POPPUBSCREEN | Pub screen mode. pop pub screen to front when visitor opens
POPUPIMAGE
PREDRAWN | Flag for TRequester.Flags. If set, ImageBMap points to a custom bitmap.
PROPBORDERLESS | Flag value for TPropInfo.Flags. if set, no border will be rendered
PROPGCLASS | Class identifier. An easy to implement, horizontal or vertical proportional gadget.
PROPNEWLOOK | Flag value for TPropInfo.Flags. set this if you want to get the new look
PSNF_PRIVATE | Flag for TPubScreenNode.psn_Flags Private
PUBLICSCREEN_f | Screentype flag for TScreen.Flags and TNewScreen.SType.
QUME_LP_20 | Value for TPreferences.PrinterType
RECOVERY_ALERT | Alert Type for DisplayAlert() the system can recover from this
REQACTIVE | Flag for TRequester.Flags. Read-Only. This requester is active
REQOFFWINDOW | Flag for TRequester.Flags. Read-Only. Part of one of the Gadgets was offwindow
RESCOUNT |
RIGHTIMAGE | SYSIA_Which tag data values. Right-arrow gadget image
RI_VERSION |
ROOTCLASS | Root Class identifier, This is the universal base class for all other classes.
SAOS_OpacitySupport_CPU
SAOS_OpacitySupport_HW
SAOS_OpacitySupport_None
SAOS_OpacitySupport_OnOff
SASA_SourceAlphaSupport_CPU
SASA_SourceAlphaSupport_HW
SASA_SourceAlphaSupport_None
SA_3DSupport
SA_AdaptSize
SA_AutoScroll | Tag start for OpenScreenTagList() boolean equivalent to flag AUTOSCROLL
SA_BackChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the back of its family.
SA_BackFill | Tag start for OpenScreenTagList() provides a "backfill hook" for your screen's TLayer_Info. See Layers.InstallLayerInfoHook()
SA_Behind | Tag start for OpenScreenTagList() boolean equivalent to flag SCREENBEHIND_f
SA_BitMap | Tag start for OpenScreenTagList() ti_Data is pointer to custom BitMap. This implies TNewScreen.SType of CUSTOMBITMAP_f
SA_BlockPen | Tag start for OpenScreenTagList() serves as default for windows, too
SA_BottomLeftScreen
SA_BottomMiddleScreen
SA_BottomRightScreen
SA_ColorMapEntries | Tag start for OpenScreenTagList() Allows you to override the number of entries in the ColorMap for your screen.
SA_Colors | Tag start for OpenScreenTagList() ti_Data is an array of TColorSpec, terminated by ColorIndex = -1. Specifies initial screen palette colors.
SA_Colors32 | Tag start for OpenScreenTagList() set the screen's initial palette colors at 32 bits-per-gun.
SA_CompositingLayers
SA_DClip | Tag start for OpenScreenTagList() ti_Data points to a rectangle which defines screen display clip region
SA_Depth | Tag start for OpenScreenTagList() Screen bitmap depth
SA_DetailPen | Tag start for OpenScreenTagList() serves as default for windows, too
SA_Displayed
SA_DisplayHeight
SA_DisplayID | Tag start for OpenScreenTagList() ti_Data is new extended display ID
SA_DisplayWidth
SA_Draggable | Tag start for OpenScreenTagList() Boolean tag allowing non-draggable screens. Do not use without good reason! (Defaults to True).
SA_Dummy | Tag start for OpenScreenTagList() Tags
SA_ErrorCode | Tag start for OpenScreenTagList() ti_Data points to LongInt error code
SA_ExactMatchMonitorName
SA_Exclusive | Tag start for OpenScreenTagList() Boolean tag allowing screens that won't share the display. (Defaults to False)
SA_Font | Tag start for OpenScreenTagList() equiv. to TNewScreen.Font
SA_FrontChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the front of its family.
SA_FullPalette | Tag start for OpenScreenTagList() boolean: initialize color table to entire preferences palette, rather than compatible pens 0-3, 17-19, with remaining palette as returned by GetColorMap()
SA_GammaBlue
SA_GammaControl
SA_GammaGreen
SA_GammaRed
SA_Height | Tag start for OpenScreenTagList() eqivalent to TNewWindow.Height
SA_Interleaved | Tag start for OpenScreenTagList() Boolean tag requesting that the bitmap allocated for you be interleaved. (Defaults to False).
SA_Left | Tag start for OpenScreenTagList() eqivalent to TNewWindow.LeftEdge
SA_LikeWorkbench | Tag start for OpenScreenTagList() 1 = request a screen which is just like the Workbench. This gives you the same screen mode, depth, size, colors, etc., as the Workbench screen.
SA_MiddleLeftScreen
SA_MiddleRightScreen
SA_MinimizeISG | Tag start for OpenScreenTagList() inter-screen gap is at least three non-interlaced lines
SA_MonitorName
SA_MonitorObject
SA_OpacitySupport
SA_Overscan | Tag start for OpenScreenTagList() Set Overscan defaults to OSCAN_TEXT
SA_Parent | Tag start for OpenScreenTagList() Pointer to a "parent" screen to attach this one to. Attached screens slide and depth-arrange together.
SA_Pens | Tag start for OpenScreenTagList() pointer to $FFFFFFFF terminated LongWord array, as found in TDrawInfo
SA_PixelFormat
SA_PubName | Tag start for OpenScreenTagList() Presence of this tag means that the screen is to be a public screen. Please specify before SA_PubSig and SA_PubTask
SA_PubSig | Tag start for OpenScreenTagList()
SA_PubTask | Tag start for OpenScreenTagList() Task ID and signal for being notified that the last window has closed on a public screen.
SA_Quiet | Tag start for OpenScreenTagList() boolean equivalent to flag SCREENQUIET_f
SA_Reserved | Tag start for OpenScreenTagList() Reserved for private Intuition use
SA_ScreenbarSignal
SA_ScreenbarTextFont
SA_ScreenbarTextPen
SA_ScreenbarTextYPos
SA_SharePens | Tag start for OpenScreenTagList() Allocate pens as shared
SA_ShowPointer
SA_ShowTitle | Tag start for OpenScreenTagList() boolean equivalent to flag SHOWTITLE
SA_SourceAlphaSupport
SA_StopBlanker
SA_SysFont | Tag start for OpenScreenTagList() Selects one of the preferences system fonts: 0 - old DefaultFont, fixed-width 1 - WB Screen preferred font
SA_Title | Tag start for OpenScreenTagList() default screen title
SA_Top | Tag start for OpenScreenTagList() eqivalent to TNewWindow.TopEdge
SA_TopLeftScreen
SA_TopMiddleScreen
SA_TopRightScreen
SA_Type | Tag start for OpenScreenTagList() equiv. to TNewScreen.SType
SA_VideoControl | Tag start for OpenScreenTagList() Pointer to a taglist that Intuition will pass to VideoControl(), upon opening the screen.
SA_Width | Tag start for OpenScreenTagList() eqivalent to TNewWindow.Width
SBCT_Dummy
SBCT_InstallPlugin
SBCT_UninstallPlugin
SBUFSIZE_BITS | Mask for TPreferences.SerStopBuf lower nibble
SBUF_1024 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_16000 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_2048 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_4096 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_512 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_8000 | Value for TPreferences.SerStopBuf Lower Nibble
SB_COPY_BITMAP | Flag for AllocScreenBuffer().
SB_SCREEN_BITMAP | Flag for AllocScreenBuffer().
SCREENBEHIND_f | Flag for TScreen.Flags. If you want your screen to open behind already open screens
SCREENHIRES | Flag for TScreen.Flags. Do no use lowres gadgets (private)
SCREENQUIET_f | Flag for TScreen.Flags. If you do not want Intuition to render into your screen (gadgets, title)
SCREENTYPE_f | Screentype flag for TScreen.Flags and TNewScreen.SType. All Screenstypes available
SCREEN_DRAG
SDEPTHIMAGE | SYSIA_Which tag data values. Screen depth gadget image
SDEPTH_TOBACK | Flag for ScreenDepth(). Send screen to back
SDEPTH_TOFRONT | Flag for ScreenDepth(). Bring screen to front
SDOWNBACKGADGET |
SDRAGGADGET |
SELECTDOWN | RawMouse code for TIntuiMessage.Code. Left Mouse Button down.
SELECTUP | RawMouse code for TIntuiMessage.Code. Left Mouse Button up.
SERIAL_PRINTER | Value for TPreferences.PrinterPort
SGA_BEEP | String Gadget Action Flag in TSGWork.Actions flash the screen for the user
SGA_END | String Gadget Action Flag in TSGWork.Actions terminate gadget, code in Code field
SGA_NEXTACTIVE | String Gadget Action Flag in TSGWork.Actions Make next possible gadget active.
SGA_PREVACTIVE | String Gadget Action Flag in TSGWork.Actions Make previous possible gadget active.
SGA_REDISPLAY | String Gadget Action Flag in TSGWork.Actions gadget visuals changed
SGA_REUSE | String Gadget Action Flag in TSGWork.Actions reuse input event
SGA_USE | String Gadget Action Flag in TSGWork.Actions use contents of TSGWork
SGH_CLICK | Function id for only existing custom string gadget edit hook. process mouse click cursor position
SGH_KEY | Function id for only existing custom string gadget edit hook. process editing keystroke
SGM_CONTROL | Internal Mode for TSGWork.Mode control char escape mode
SGM_EXITHELP | Mode for TSGWork.Mode exit with code = $5F if help hit
SGM_FIXEDFIELD | Mode for TSGWork.Mode fixed length buffer always set SGM_REPLACE, too
SGM_LONGINT | Internal Mode for TSGWork.Mode an intuition LongInt gadget
SGM_NOCHANGE | Internal Mode for TSGWork.Mode no edit changes yet
SGM_NOFILTER | Mode for TSGWork.Mode don't filter control chars
SGM_NOWORKB | Internal Mode for TSGWork.Mode Buffer = PrevBuffer
SGM_REPLACE | Mode for TSGWork.Mode replace mode please initialize StringInfo with in-range value of BufferPos if you are using SGM_REPLACE mode.
SG_DEFAULTMAXCHARS | Maximal length of text in StrgClass, if STRINGA_MaxChars is not set.
SHADE_BW | Value for TPreferences.PrintShade
SHADE_COLOR | Value for TPreferences.PrintShade
SHADE_GREYSCALE | Value for TPreferences.PrintShade
SHADOWPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. dark edge on 3D objects
SHANGHAI | Pub Screen mode. put workbench windows on pub screen
SHINEPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. bright edge on 3D objects
SHOWTITLE_f | Flag for TScreen.Flags. This gets set by a call to ShowTitle()
SHSHAKE_BITS | Mask for TPreferences.SerParShk Lower nibble
SHSHAKE_NONE | Serial Handshake Mode TPreferences.SerParShk (lower nibble)
SHSHAKE_RTS | Serial Handshake Mode TPreferences.SerParShk (lower nibble)
SHSHAKE_XON | Serial Handshake Mode TPreferences.SerParShk (lower nibble
SIMPLEREQ | Flag for TRequester.Flags. If set, a SIMPLEREFRESH layer is used.
Single_PT |
SIX_LPI | Value for TPreferences.PrintSpacing
SIZEGADGET |
SIZEIMAGE | SYSIA_Which tag data values. Window sizing gadget image
SI_BorderBottom
SI_BorderBottomSize
SI_BorderLeft
SI_BorderRight
SI_BorderRightSize
SI_BorderTop
SI_BorderTopTitle
SI_BottomArrowBox
SI_BottomPropHeight
SI_Dummy
SI_RightArrowBox
SI_RightPropWidth
SI_ScreenTitlebarHeight
SI_Shadows
SNAPSHOTIMAGE
SPARITY_BITS | Mask for TPreferences.SerParShk upper nibble
SPARITY_EVEN | Serial Parity TPreferences.SerParShk (upper nibble)
SPARITY_MARK
SPARITY_NONE | Serial Parity TPreferences.SerParShk (upper nibble)
SPARITY_ODD | Serial Parity TPreferences.SerParShk (upper nibble)
SPARITY_SPACE
SPOS_ABSOLUTE | Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the absolute coordinates you wish to move the screen to. Coordinates are expressed as absolutes, not relatives.
SPOS_FORCEDRAG | Flag for ScreenPosition(). Move non-draggable screen, You may additionally set SPOS_FORCEDRAG along with any of the above. Set this if you wish to reposition an [SA_Draggable, False] screen that you opened.
SPOS_MAKEVISIBLE | Flag for ScreenPosition(). Coordinates describe a box on the screen you wish to be made visible by autoscrolling (x1,y1)-(x2,y2) describes a rectangle on the screen which you would like autoscrolled into view.
SPOS_RELATIVE | Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the offset in coordinates you wish to move the screen by. Coordinates are relative
SREAD_BITS | Mask for TPreferences.SerRWBits Upper nibble
SSTOP_BITS | Mask for TPreferences.SerStopBuf Upper nibble
STDSCREENHEIGHT | Supply in TNewScreen.Height Set Hight to standard height
STDSCREENWIDTH | Supply in TNewScreen.Width Set Hight to standard width
STRGCLASS | Class identifier. A string gadget.
STRINGA_ActivePens | StrgClass Tag. [IS.] (LongInt) Like STRINGA_Pens. These pens are used, if the gadget is active.
STRINGA_AltKeyMap | StrgClass Tag. [IS.] (PKeyMap) KeyMap to use
STRINGA_Buffer | StrgClass Tag. [I..] (STRPTR) Buffer for storing the current string of the gadget.
STRINGA_BufferPos | StrgClass Tag. [IS.] (SmallInt) Current position of cursor (relative to the beginning of the buffer).
STRINGA_DispPos | StrgClass Tag. [IS.] (SmallInt) FIXME
STRINGA_Dummy | StrgClass Start Tag.
STRINGA_EditHook | StrgClass Tag. [I..] (PHook) FIXME
STRINGA_EditModes | StrgClass Tag. [IS.] (LongWord) FIXME
STRINGA_ExitHelp | StrgClass Tag. [IS.] (LongBool) If this is set, pressing the "Help" key, while the gadget is active, will unselect the gadget.
STRINGA_FixedFieldMode | StrgClass Tag. [IS.] (LongBool) FIXME
STRINGA_Font | StrgClass Tag. [IS.] (PTextFont) Font to use for displaying the string
STRINGA_Justification | StrgClass Tag. [IS.] (Word) Where should the text be justified?
STRINGA_LongVal | StrgClass Tag. [ISG] (LongInt) If this is set, the string gadget will only accept numeric values.
STRINGA_MaxChars | StrgClass Tag. [I..] (SmallInt) Maximum number of characters the string gadget accepts. Default SG_DEFAULTMAXCHARS.
STRINGA_NoFilterMode | StrgClass Tag. [IS.] (LongBool) FIXME
STRINGA_Pens | StrgClass Tag. [IS.] (LongInt) The lower 16 bits specify the background-pen, the upper 16 bits the foreground-pen. The gadget is rendered, using these pens, if the gadget is inactive
STRINGA_ReplaceMode | StrgClass Tag. [IS.] (LongBool) If this is True, the current character is overwritten, if the use presses a key. Otherwise, the new character is inserted.
STRINGA_TextVal | StrgClass Tag. [ISG] (STRPTR) If this is set, the string gadget will accept strings.
STRINGA_UndoBuffer | StrgClass Tag. [I..] (STRPTR) Buffer for storing the old (undo) string of the gadget.
STRINGA_WorkBuffer | StrgClass Tag. [I..] (STRPTR) Buffer for the class to work with.
SUBMENUIMAGE
SUPFRONTGADGET |
SWRITE_BITS | Mask for TPreferences.SerRWBits Lower nibble
SYSIA_Depth | SysIClass Attribute.
SYSIA_DrawInfo | SysIClass Attribute. Must be specified
SYSIA_Pens |
SYSIA_ReferenceFont | SysIClass Attribute. Font to use as reference for scaling certain sysiclass images
SYSIA_Size | SysIClass Attribute. SYSISIZE_*
SYSIA_Style
SYSIA_Which | SysIClass Attribute. System image identifier
SYSIA_WithBorder
SYSICLASS | Class identifier. The class of system images. The class includes the images for the system and GadTools gadgets.
SYSISIZE_HIRES | Data value for SYSIA_Size
SYSISIZE_LOWRES | Data value for SYSIA_Size
SYSISIZE_MEDRES | Data value for SYSIA_Size
SYSISTYLE_GADTOOLS
SYSISTYLE_NORMAL
SYSREQUEST | Flag for TRequester.Flags. Read-Only. This requester caused by system
TABLETA_AngleX | Tag for TTabletData.td_TagList. The angle of rotation or tilt about the X-axis.
TABLETA_AngleY | Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Y-axis.
TABLETA_AngleZ | Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Z axis.
TABLETA_ButtonBits | Tag for TTabletData.td_TagList. Button States
TABLETA_Dummy | Tablet Tag Base
TABLETA_InProximity | Tag for TTabletData.td_TagList. For tablets that support proximity,
TABLETA_Pressure | Tag for TTabletData.td_TagList. The pressure reading of the stylus.
TABLETA_RangeZ | Tag for TTabletData.td_TagList. The maximum value of the tablet in the Z direction.
TABLETA_ResolutionX | Tag for TTabletData.td_TagList. X-axis resolution
TABLETA_ResolutionY | Tag for TTabletData.td_TagList. Y-axis resolution
TABLETA_TabletZ | Tag for TTabletData.td_TagList. The current value of the tablet in the Z direction.
TAGBASE_SCREENBAR
TEXTPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. text on background
TOPAZ_EIGHTY | default font size
TOPAZ_SIXTY | default font size
TRANSPCONTROLMETHOD_INSTALLREGION
TRANSPCONTROLMETHOD_INSTALLREGIONHOOK
TRANSPCONTROLMETHOD_UPDATETRANSPARENCY
TRANSPCONTROL_DUMMY
TRANSPCONTROL_OLDREGION
TRANSPCONTROL_OLDREGIONHOOK
TRANSPCONTROL_REGION
TRANSPCONTROL_REGIONHOOK
UPFRONTGADGET |
UPIMAGE | SYSIA_Which tag data values. Up-arrow gadget image
USEREQIMAGE | Flag for TRequester.Flags. Render linked list ReqImage after BackFill but before gadgets and text
US_LEGAL | Value for TPreferences.PaperSize
US_LETTER | Value for TPreferences.PaperSize
WAC_ACTIVATEWINDOW
WAC_CHANGEWINDOWBOX
WAC_DUMMY
WAC_FAMILYTOBACK
WAC_FAMILYTOFRONT
WAC_HIDEWINDOW
WAC_MAXIMIZEWINDOW
WAC_MINIMIZEWINDOW
WAC_MOVEWINDOW
WAC_MOVEWINDOWINFRONTOF
WAC_OPENMENU
WAC_RESTOREINITIALSIZEPOS
WAC_SENDIDCMPCLOSE
WAC_SHOWWINDOW
WAC_SIZEWINDOW
WAC_WINDOWTOBACK
WAC_WINDOWTOFRONT
WAC_ZIPWINDOW
WAT_DUMMY
WAT_MOVEWBEHINDWINDOW
WAT_MOVEWINDOWX
WAT_MOVEWINDOWY
WAT_SIZEWINDOWX
WAT_SIZEWINDOWY
WAT_WINDOWBOXHEIGHT
WAT_WINDOWBOXLEFT
WAT_WINDOWBOXTOP
WAT_WINDOWBOXWIDTH
WA_Activate | Tag for OpenWindowTagList(). Activate the window when it opens.
WA_AmigaKey | Tag for OpenWindowTagList(). Amiga key image for Menus
WA_AutoAdjust | Tag for OpenWindowTagList().Auto adjust window size to screen maximum.
WA_Backdrop | Tag for OpenWindowTagList(). Make this window a backdrop window
WA_BackFill | Tag for OpenWindowTagList(). BackFill hook
WA_BlockPen | Tag for OpenWindowTagList(). Specifies the pen number for window block fills, like the title bar.
WA_Borderless | Tag for OpenWindowTagList(). Make window borderless
WA_BusyPointer | Tag for OpenWindowTagList(). Request standard busy pointer
WA_Checkmark | Tag for OpenWindowTagList(). Image for Menu entries
WA_CloseGadget | Tag for OpenWindowTagList(). Add CloseGadget to window
WA_Colors | Tag for OpenWindowTagList().
WA_CustomScreen | Tag for OpenWindowTagList(). Open the window on a specific screen
WA_DepthGadget | Tag for OpenWindowTagList(). Add Depthgadget to window
WA_DetailPen | Tag for OpenWindowTagList(). Specifies the pen number for the rendering of window details like gadgets or text in the title bar.
WA_DragBar | Tag for OpenWindowTagList(). Titlebar used to drag window
WA_Dummy | Starting for window TagItems
WA_ExtraGadgetsStartID
WA_ExtraGadget_Iconify
WA_ExtraGadget_Jump
WA_ExtraGadget_Lock
WA_ExtraGadget_MUI
WA_ExtraGadget_PopUp
WA_ExtraGadget_Snapshot
WA_ExtraTitlebarGadgets
WA_Flags | Tag for OpenWindowTagList(). Window Flags (WFLG_*)
WA_FrontWindow
WA_Gadgets | Tag for OpenWindowTagList(). List of Gadgets
WA_GimmeZeroZero | Tag for OpenWindowTagList(). Zero-Zero window
WA_HasAlpha
WA_Height | Tag for OpenWindowTagList(). The initial window height in pixels
WA_HelpGroup | Tag for OpenWindowTagList(). Form Help groups
WA_HelpGroupWindow | Tag for OpenWindowTagList(). Form Help group windows
WA_HitLevel
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported
WA_InnerHeight | Tag for OpenWindowTagList(). Inner height of window
WA_InnerWidth | Tag for OpenWindowTagList(). Inner width for the window
WA_Left | Tag for OpenWindowTagList(). The initial x position
WA_MaxHeight | Tag for OpenWindowTagList(). Minimum height for resizeable windows
WA_MaxWidth | Tag for OpenWindowTagList(). Maximum width for resizeable windows
WA_MenuHelp | Tag for OpenWindowTagList(). Enabled Help button for Menu
WA_MinHeight | Tag for OpenWindowTagList(). Minimum height for resizeable windows
WA_MinWidth | Tag for OpenWindowTagList(). Minimum width for resizeable windows
WA_MouseQueue | Tag for OpenWindowTagList(). Mouse event queue size
WA_NewLookMenus | Tag for OpenWindowTagList(). Activate NewLook menus
WA_NoCareRefresh | Tag for OpenWindowTagList(). Do not need Refresh message
WA_NotifyDepth | Tag for OpenWindowTagList().
WA_Opacity
WA_Parent
WA_Pointer | Tag for OpenWindowTagList(). Custom Pointer for window.
WA_PointerDelay | Tag for OpenWindowTagList(). Delay of pointer change
WA_PointerType
WA_PubScreen | Tag for OpenWindowTagList(). Specify screen to open window on
WA_PubScreenFallBack | Tag for OpenWindowTagList(). Fallback screen to default
WA_PubScreenName | Tag for OpenWindowTagList(). Choose screen by name
WA_ReportMouse | Tag for OpenWindowTagList(). Report mouse events
WA_RMBTrap | Tag for OpenWindowTagList().
WA_RptQueue | Tag for OpenWindowTagList(). Key event queue size
WA_ScreenTitle | Tag for OpenWindowTagList(). Title for screen when window is activated
WA_ShadowBottom
WA_ShadowLeft
WA_ShadowRight
WA_ShadowTop
WA_SimpleRefresh | Tag for OpenWindowTagList().
WA_SizeBBottom | Tag for OpenWindowTagList(). Place the size gadget in the bottom border.
WA_SizeBRight | Tag for OpenWindowTagList(). Place the size gadget in the right border.
WA_SizeDenominator
WA_SizeExtraHeight
WA_SizeExtraWidth
WA_SizeGadget | Tag for OpenWindowTagList().
WA_SizeNumerator
WA_SkinInfo
WA_SmartRefresh | Tag for OpenWindowTagList().
WA_SuperBitMap | Tag for OpenWindowTagList(). SuperBitmap for scrolling windows
WA_TabletMessages | Tag for OpenWindowTagList(). Enabled tablet messages
WA_Title | Tag for OpenWindowTagList(). Title for window
WA_ToolbarWindow
WA_Top | Tag for OpenWindowTagList(). The initial y position
WA_TransparentRegion
WA_TransparentRegionHook
WA_UserPort
WA_VisibleOnMaximize
WA_WBenchWindow | Tag for OpenWindowTagList(). Private
WA_Width | Tag for OpenWindowTagList(). The initial window width in pixels
WA_WindowName | Tag for OpenWindowTagList().
WA_Zoom | Tag for OpenWindowTagList(). Define zoom size for window
WBENCHCLOSE | Code for IDCMP_WBENCHMESSAGE
WBENCHOPEN | Code for IDCMP_WBENCHMESSAGE
WBENCHSCREEN_f | Screentype flag for TScreen.Flags and TNewScreen.SType. The Workbench itself
WFLG_ACTIVATE | Flag for WA_Flags or TNewWindow.Flags. When window opens, it is active.
WFLG_BACKDROP | Flag for WA_Flags or TNewWindow.Flags. This is a backdrop window
WFLG_BORDERLESS | Flag for WA_Flags or TNewWindow.Flags. Get a window sans border.
WFLG_CLOSEGADGET | Flag for WA_Flags or TNewWindow.Flags. Include close-box system-gadget
WFLG_DEPTHGADGET | Flag for WA_Flags or TNewWindow.Flags. Include depth arrangement gadget
WFLG_DRAGBAR | Flag for WA_Flags or TNewWindow.Flags. Include dragging system-gadget
WFLG_GIMMEZEROZERO | Flag for WA_Flags or TNewWindow.Flags. A GimmeZeroZero window
WFLG_HASZOOM | Flag for TWindow.Flags. Window has a zoom gadget.
WFLG_INREQUEST | Flag for WA_Flags or TNewWindow.Flags. Private. This window is in request mode.
WFLG_MENUSTATE | Flag for WA_Flags or TNewWindow.Flags. Private. Window is active with menus on.
WFLG_NEWLOOKMENUS | Flag for WA_Flags or TNewWindow.Flags. Window has NewLook menus.
WFLG_NOCAREREFRESH | Flag for WA_Flags or TNewWindow.Flags. Not to be bothered with REFRESH
WFLG_NW_EXTENDED | Flag for TNewWindow.Flags. Extension data provided see TExtNewWindow.
WFLG_OTHER_REFRESH | Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap
WFLG_REFRESHBITS | Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap
WFLG_REPORTMOUSE | Flag for WA_Flags or TNewWindow.Flags. Fire an event for every mouse move
WFLG_RMBTRAP | Flag for WA_Flags or TNewWindow.Flags. Fire right mouse button events
WFLG_SIMPLE_REFRESH | Flag for WA_Flags or TNewWindow.Flags. Enable Simple Refresh
WFLG_SIZEBBOTTOM | Flag for WA_Flags or TNewWindow.Flags. Size gadget uses bottom border
WFLG_SIZEBRIGHT | Flag for WA_Flags or TNewWindow.Flags. Size gadget uses right border
WFLG_SIZEGADGET | Flag for WA_Flags or TNewWindow.Flags. Include sizing system-gadget
WFLG_SMART_REFRESH | Flag for WA_Flags or TNewWindow.Flags. Enable smart Refresh
WFLG_SUPER_BITMAP | Flag for WA_Flags or TNewWindow.Flags. Has super bitmap
WFLG_VISITOR | Flag for TWindow.Flags. Visitor window.
WFLG_WBENCHWINDOW | Flag for TWindow.Flags. Workbench tool only Window
WFLG_WINDOWACTIVE | Flag for WA_Flags or TNewWindow.Flags. Private. This window is the active one.
WFLG_WINDOWREFRESH | Flag for TWindow.Flags. Window is currently refreshing
WFLG_WINDOWTICKED | Flag for TWindow.Flags. Only one timer tick at a time
WFLG_ZOOMED | Flag for TWindow.Flags. Identifies "Zoom State"
WM_Dummy
WM_ObtainEvents
WM_OpenMenu
WM_ReleaseEvents
W_TRACTOR | Value for TPreferences.PaperSize
ZOOMIMAGE | SYSIA_Which tag data values. Window zoom gadget image


Reference for unit 'intuition': Types

ClassID | Name of the Object class
LongWord | Handle for an BOOPSI Objects / Classes / Messages
PBoolInfo | Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_BOOLGADGET
PBorder | Pointer to Border Drawing structure
PBTDBoolean
PBTDCycle
PBTDDrawInfo
PBTDFile
PBTDFont
PBTDInfo
PBTDInteger
PBTDNode
PBTDString
PClassLibrary | Pointer to a BOOPSI class libraries
PColorSpec | Pointer to Color table entry
PDrawInfo | Pointer to Draw info structure
PEasyStruct | The text and setup of an easy requester
PExtEasyStruct
PExtGadget | Pointer to and extended Gadget structure
PExtIntuiMessage | Pointer to an extended Intuition message
PExtNewScreen | Pointer to Extended New Screen structure
PExtNewWindow | Pointer to Future TNewWindow.
PGadget | Pointer to a Gadget structure
PGadgetInfo | Pointer to Gadget Render Info
PgpDomain |
PgpGoInactive | Pointer to Message parameter passed for GM_GOINACTIVE
PgpHitTest | Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST
PgpInput | Pointer to Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
PgpKeyGoInactive |
PgpKeyInput |
PgpKeyTest |
PgpLayout | Pointer to Message parameter passed for GM_LAYOUT
PgpRender | Pointer to Message parameter passed for GM_RENDER
PIBox | A data structure common in Intuition processing
PIClass | This structure is READ-ONLY, and allocated only by Intuition
PImage | This is a brief image structure for very simple transfers of image data to a RastPort
PimpDomainFrame |
PimpDraw | Pointer to message argument for IM_DRAW or IM_DRAWFRAME
PimpErase | Pointer to message argument for IM_ERASE or IM_ERASEFRAME
PimpFrameBox | Pointer to message argument for IM_FRAMEBOX
PimpHitTest | Pointer to message argument for IM_HITTEST or IM_HITFRAME
PIntuiMessage | Pointer to an Intuition message
PIntuiText | IntuiText is a series of strings.
PIntuitionBase | Pointer to Intution basic structures
PMenu | Pointer to a menu structure
PMenuItem | Pointer to an menu item
PMsg |
PmsGetDefaultGammaTables
PmsGetDefaultPixelFormat
PmsGetPointerBounds
PmsGetRootBitMap
PmsQuery3DSupport
PmsSetDefaultGammaTables
PMUIP_Screenbar_BuildSettingsPanel
PMUIP_Screenbar_DefaultConfigItem
PMUIP_Screenbar_KnowsConfigItem
PMUIP_Screenbar_Lock
PMUIP_Screenbar_Signal
PMUIP_Screenbar_Unlock
PMUIP_UpdateConfig
PNewScreen | pointer to an instance of a NewScreen structure.
PNewWindow | Pointer to structure describes a new window
PObject_ | Pointer to an BOOPSI Object / Classe / Message Handle
PopAddMember
PopAddTail | Pointer to message structure for OM_ADDTAIL
PopGet | Pointer to message structure for OM_GET
PopMember | Pointer to message structure for OM_ADDMEMBER/OM_REMMEMBER
PopSet | Pointer to message structure for OM_NEW/OM_SET
PopUpdate | Pointer to message structure for OM_NOTIFY/OM_UPDATE
PPBTDNode
PPGX | Pointer to System private data structure for now prop gadget extra info
PPObject_ | Pointer to an BOOPSI Object / Classe / Message Pointer Handle
PPreferences | Pointer to old style Preferences
PPropInfo | Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_PROPGADGET
PPubScreenNode | Pointer to Public Shared Screen Node
PRemember | Pointer to Memory allocating remember structure
PRequester | Requesters The following struct is used for standard intuition requesters
PScreen |
PScreenBuffer | Pointer to screen buffer
PSGWork | Pointer to String gadget message
PStringExtend | Extended string info for Gadgets texts
PStringInfo | Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_STRGADGET
PTabletData | Pointer to a IntuiMessage TabletData
PTabletHookData |
PTransparencyMessage
PWindow |
P_Object | Pointer to an Boopsi Object
TBoolInfo | Boolgadget informations PBoolInfo
TBorder | Pointer drawing structure
TBTDBoolean
TBTDCycle
TBTDDrawInfo
TBTDFile
TBTDFont
TBTDInfo
TBTDInteger
TBTDNode
TBTDString
TClassLibrary | BOOPSI class libraries structure
TColorSpec | Color table entry
TDrawInfo | Graphical informations for the 3D look
TEasyStruct | The text and setup of an easy requester
TExtEasyStruct
TExtGadget | Extended Gadget structure
TExtIntuiMessage | Extended Intuition message structure
TExtNewScreen | Extended TNewScreen structure
TExtNewWindow | Future TNewWindow
TGadget | Structure to describe a Gadget
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
TgpDomain |
TgpGoInactive | Message parameter passed for GM_GOINACTIVE
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
TgpKeyGoInactive |
tgpKeyInput |
TgpKeyTest |
TgpLayout | Message parameter passed for GM_LAYOUT
TgpRender | Message parameter passed for GM_RENDER
TIBox | A data structure common in Intuition processing
TIClass | This structure is READ-ONLY, and allocated only by Intuition
TImage | This is a brief image structure for very simple transfers of image data to a RastPort
TimpDomainFrame |
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME
TimpErase | Message argument for IM_ERASE or IM_ERASEFRAME
TimpFrameBox | Message argument for IM_FRAMEBOX
TimpHitTest | Message argument for IM_HITTEST or IM_HITFRAME
TIntuiMessage | Intuition message structure
TIntuiText | IntuiText is a series of strings.
TIntuitionBase | Intuition basic structure
TMenu | Structure to describe a menu
TMenuItem | Structure to describe a menu item
TMsg |
TmsGetDefaultGammaTables
TmsGetDefaultPixelFormat
TmsGetPointerBounds
TmsGetRootBitMap
TmsQuery3DSupport
TmsSetDefaultGammaTables
TMUIP_Screenbar_BuildSettingsPanel
TMUIP_Screenbar_DefaultConfigItem
TMUIP_Screenbar_KnowsConfigItem
TMUIP_Screenbar_Lock
TMUIP_Screenbar_Signal
TMUIP_Screenbar_Unlock
TMUIP_UpdateConfig
TNewScreen | Description of a new screen
TNewWindow | New window structure
TopAddMember
TopAddTail | Message structure for OM_ADDTAIL
TopGet | Message structure for OM_GET
TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TopSet | Message structure for OM_NEW/OM_SET
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TPGX | System private data structure for now prop gadget extra info
TPreferences | Old Style Preferences
TPropInfo | Proportional Gadget
TPubScreenNode | Public Shared Screen Node
TRemember | Structure to remember memory allocations
TRequester | Requesters The following struct is used for standard intuition requesters
TScreen | Basic screen structure
TScreenBuffer | Screen buffer structure
TSGWork | String gadget message
TStringExtend | Extended string info for Gadgets texts
TStringInfo | String Gadget structure
TTabletData | IntuiMessage TabletData
TTabletHookData |
TTransparencyMessage
TWindow | Window structure
T_Object | Boopsi Object structure


INTEGER_SCALING

Flag for TPreferences.PrintFlags force integer scaling

Declaration

Source position: intuition.pas line 1872

const INTEGER_SCALING = $0100;


ISDRAWN

Flag for TMenuItem.Flags set by intuition (ReadOnly), this item's subs are currently drawn

Declaration

Source position: intuition.pas line 105

const ISDRAWN = $1000;


ITEMENABLED

Flag for TMenuItem.Flags set by the Application, set if this item is enabled

Declaration

Source position: intuition.pas line 95

const ITEMENABLED = $0010;


ITEMTEXT

Flag for TMenuItem.Flags set by the Application, set if textual, clear if graphical item

Declaration

Source position: intuition.pas line 92

const ITEMTEXT = $0002;


ITEXTICLASS

Class identifier. A specialized image class used for rendering text.

Declaration

Source position: intuition.pas line 1987

const ITEXTICLASS: PChar = 'itexticlass';

Description

SuperClass: imageclass

This is a class of image objects that render an IntuiText structure. Using some of the imageclass attributes, the object can override some of the parameters in the IntuiText structure. This class makes it easy to share an IntuiText structure between objects.

Changed Methods:

IM_DRAW, IM_DRAWFRAME

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


JUMPIMAGE

Declaration

Source position: intuition.pas line 3014

const JUMPIMAGE = $17;


KEYCODE_B

RawKeycode for TIntuiMessage.Code. 'b' key pressed.

Declaration

Source position: intuition.pas line 1314

const KEYCODE_B = $35;


KEYCODE_GREATER

RawKeycode for TIntuiMessage.Code. '>' key pressed.

Declaration

Source position: intuition.pas line 1316

const KEYCODE_GREATER = $39;


KEYCODE_LESS

RawKeycode for TIntuiMessage.Code. '<' key pressed.

Declaration

Source position: intuition.pas line 1315

const KEYCODE_LESS = $38;


KEYCODE_M

RawKeycode for TIntuiMessage.Code. 'm' key pressed.

Declaration

Source position: intuition.pas line 1312

const KEYCODE_M = $37;


KEYCODE_N

RawKeycode for TIntuiMessage.Code. 'n' key pressed.

Declaration

Source position: intuition.pas line 1311

const KEYCODE_N = $36;


KEYCODE_Q

RawKeycode for TIntuiMessage.Code. 'q' key pressed.

Declaration

Source position: intuition.pas line 1309

const KEYCODE_Q = $10;


KEYCODE_V

RawKeycode for TIntuiMessage.Code. 'v' key pressed.

Declaration

Source position: intuition.pas line 1313

const KEYCODE_V = $34;


KEYCODE_X

RawKeycode for TIntuiMessage.Code. 'x' key pressed.

Declaration

Source position: intuition.pas line 1310

const KEYCODE_X = $32;


KNOBHIT

Flag value for TPropInfo.Flags. set when this Knob is hit

Declaration

Source position: intuition.pas line 415

const KNOBHIT = $0100;


KNOBHMIN

Minimum horizontal size of the Knop

Declaration

Source position: intuition.pas line 418

const KNOBHMIN = 6;


KNOBVMIN

minimum vertical size of the Knop

Declaration

Source position: intuition.pas line 419

const KNOBVMIN = 4;


LACEWB

Interlace define for TPreferences.LaceWB

Declaration

Source position: intuition.pas line 1764

const LACEWB = 1 shl 0;


LAYOUTA_ChildMaxHeight

GadgetClass Layout Tag. (LongBool) Child objects are of equal height. Should default to True for gadgets with a vertical orientation.

Declaration

Source position: intuition.pas line 2229

const LAYOUTA_ChildMaxHeight = LAYOUTA_Dummy + 5;


LAYOUTA_ChildMaxWidth

GadgetClass Layout Tag. (LongBool) Child objects are of equal width. Should default to True for gadgets with a horizontal orientation.

Declaration

Source position: intuition.pas line 2228

const LAYOUTA_ChildMaxWidth = LAYOUTA_Dummy + 4;


LAYOUTA_Dummy

GadgetClass Layout start Tag.

Declaration

Source position: intuition.pas line 2223

const LAYOUTA_Dummy = TAG_USER + $38000;


LAYOUTA_LayoutObj

GadgetClass Layout Tag.

Declaration

Source position: intuition.pas line 2224

const LAYOUTA_LayoutObj = LAYOUTA_Dummy + 1;


LAYOUTA_Orientation

GadgetClass Layout Tag. (LongInt) Orientation LORIENT_*

Declaration

Source position: intuition.pas line 2226

const LAYOUTA_Orientation = LAYOUTA_Dummy + 3;


LAYOUTA_Spacing

GadgetClass Layout Tag.

Declaration

Source position: intuition.pas line 2225

const LAYOUTA_Spacing = LAYOUTA_Dummy + 2;


LEFTIMAGE

SYSIA_Which tag data values. Left-arrow gadget image

Declaration

Source position: intuition.pas line 2490

const LEFTIMAGE = $0A;


LETTER

Value for TPreferences.PrintQuality

Declaration

Source position: intuition.pas line 1789

const LETTER = $100;


LOCKIMAGE

Declaration

Source position: intuition.pas line 3010

const LOCKIMAGE = $13;


LOGO_CRASH

Declaration

Source position: intuition.pas line 3152

const LOGO_CRASH = 9;


LORIENT_HORIZ

Orientation values for LAYOUTA_Orientation

Declaration

Source position: intuition.pas line 2232

const LORIENT_HORIZ = 1;


LORIENT_NONE

Orientation values for LAYOUTA_Orientation

Declaration

Source position: intuition.pas line 2231

const LORIENT_NONE = 0;


LORIENT_VERT

Orientation values for LAYOUTA_Orientation

Declaration

Source position: intuition.pas line 2233

const LORIENT_VERT = 2;


LOWCHECKWIDTH

Define for CHECKIT width for the CheckMark (Low res resolution) in a menu item

Declaration

Source position: intuition.pas line 1269

const LOWCHECKWIDTH = 13;


LOWCOMMWIDTH

Define for COMMSEQ width for the Command sequence (Low resolution) in a menu item

Declaration

Source position: intuition.pas line 1270

const LOWCOMMWIDTH = 16;


LOWRESGADGET

Declaration

Source position: intuition.pas line 1329

const LOWRESGADGET = 1;


LOWRESPICK

Declaration

Source position: intuition.pas line 1322

const LOWRESPICK = $0001;


LW_RESERVED

internal use only for TPreferences.LaceWB

Declaration

Source position: intuition.pas line 1765

const LW_RESERVED = 1;


MA_BacklightControl

Declaration

Source position: intuition.pas line 3321

const MA_BacklightControl = MA_Dummy + 19;


MA_BacklightLevel

Declaration

Source position: intuition.pas line 3323

const MA_BacklightLevel = MA_Dummy + 21;


MA_BacklightLevelSteps

Declaration

Source position: intuition.pas line 3322

const MA_BacklightLevelSteps = MA_Dummy + 20;


MA_BottomLeftMonitor

Declaration

Source position: intuition.pas line 3314

const MA_BottomLeftMonitor = MA_Dummy + 12;


MA_BottomMiddleMonitor

Declaration

Source position: intuition.pas line 3315

const MA_BottomMiddleMonitor = MA_Dummy + 13;


MA_BottomRightMonitor

Declaration

Source position: intuition.pas line 3316

const MA_BottomRightMonitor = MA_Dummy + 14;


MA_DriverName

Declaration

Source position: intuition.pas line 3319

const MA_DriverName = MA_Dummy + 17;


MA_Dummy

Declaration

Source position: intuition.pas line 3302

const MA_Dummy = TAG_USER;


MA_GammaControl

Declaration

Source position: intuition.pas line 3317

const MA_GammaControl = MA_Dummy + 15;


MA_Manufacturer

Declaration

Source position: intuition.pas line 3304

const MA_Manufacturer = MA_Dummy + 2;


MA_ManufacturerID

Declaration

Source position: intuition.pas line 3305

const MA_ManufacturerID = MA_Dummy + 3;


MA_MemoryClock

Declaration

Source position: intuition.pas line 3320

const MA_MemoryClock = MA_Dummy + 18;


MA_MemorySize

Declaration

Source position: intuition.pas line 3307

const MA_MemorySize = MA_Dummy + 5;


MA_MiddleLeftMonitor

Declaration

Source position: intuition.pas line 3312

const MA_MiddleLeftMonitor = MA_Dummy + 10;


MA_MiddleRightMonitor

Declaration

Source position: intuition.pas line 3313

const MA_MiddleRightMonitor = MA_Dummy + 11;


MA_MonitorName

Declaration

Source position: intuition.pas line 3303

const MA_MonitorName = MA_Dummy + 1;


MA_PixelFormats

Declaration

Source position: intuition.pas line 3308

const MA_PixelFormats = MA_Dummy + 6;


MA_PointerType

Declaration

Source position: intuition.pas line 3318

const MA_PointerType = MA_Dummy + 16;


MA_ProductID

Declaration

Source position: intuition.pas line 3306

const MA_ProductID = MA_Dummy + 4;


MA_TopLeftMonitor

Declaration

Source position: intuition.pas line 3309

const MA_TopLeftMonitor = MA_Dummy + 7;


MA_TopMiddleMonitor

Declaration

Source position: intuition.pas line 3310

const MA_TopMiddleMonitor = MA_Dummy + 8;


MA_TopRightMonitor

Declaration

Source position: intuition.pas line 3311

const MA_TopRightMonitor = MA_Dummy + 9;


MAXBODY

Maximum body value in TPropInfo

Declaration

Source position: intuition.pas line 420

const MAXBODY = $FFFF;


MAXPOT

Maximum pot value in TPropInfo

Declaration

Source position: intuition.pas line 421

const MAXPOT = $FFFF;


MAXPUBSCREENNAME

Maximum length of public screen names. The buffers containing these strings must have a length of MAXPUBSCREENNAME + 1.

Declaration

Source position: intuition.pas line 1620

const MAXPUBSCREENNAME = 139;

See also

TPubScreenNode

Public Shared Screen Node


MENUCANCEL

Code for IDCMP_MENUVERIFY HOT Reply of this cancels Menu operation

Declaration

Source position: intuition.pas line 895

const MENUCANCEL = $0002;


MENUCHECK

SYSIA_Which tag data values. Menu checkmark image

Declaration

Source position: intuition.pas line 2497

const MENUCHECK = $10;


MENUDOWN

RawMouse code for TIntuiMessage.Code. Right Mouse Button down.

Declaration

Source position: intuition.pas line 1296

const MENUDOWN = IECODE_RBUTTON;


MENUENABLED

Flag for TMenu.Flags, whether or not this menu is enabled

Declaration

Source position: intuition.pas line 129

const MENUENABLED = $0001;


MENUHOT

Code for IDCMP_MENUVERIFY Intuition wants verification or MENUCANCEL

Declaration

Source position: intuition.pas line 894

const MENUHOT = $0001;


MENUNULL

Declaration

Source position: intuition.pas line 1260

const MENUNULL = - 1;


MENUTOGGLE

Flag for TMenuItem.Flags set by the Application, set to toggle the check of a menu item

Declaration

Source position: intuition.pas line 94

const MENUTOGGLE = $0008;


MENUTOGGLED

Flag for TMenuItem.Flags set by intuition (ReadOnly), this item was already toggled

Declaration

Source position: intuition.pas line 107

const MENUTOGGLED = $4000;


MENUTOGGLEIMAGE

Declaration

Source position: intuition.pas line 3015

const MENUTOGGLEIMAGE = $19;


MENUUP

RawMouse code for TIntuiMessage.Code. Right Mouse Button up.

Declaration

Source position: intuition.pas line 1295

const MENUUP = IECODE_RBUTTON or IECODE_UP_PREFIX;


MENUWAITING

Code for IDCMP_MENUVERIFY Intuition simply wants a ReplyMsg() ASAP

Declaration

Source position: intuition.pas line 896

const MENUWAITING = $0003;


MIDDLEDOWN

RawMouse code for TIntuiMessage.Code. Middle Mouse Button down.

Declaration

Source position: intuition.pas line 1298

const MIDDLEDOWN = IECODE_MBUTTON;


MIDDLEUP

RawMouse code for TIntuiMessage.Code. Middle Mouse Button up.

Declaration

Source position: intuition.pas line 1297

const MIDDLEUP = IECODE_MBUTTON or IECODE_UP_PREFIX;


MIDRAWN

Flag for TMenu.Flags, this menu's items are currently drawn (ReadOnly)

Declaration

Source position: intuition.pas line 131

const MIDRAWN = $0100;


MM_Authorization

Declaration

Source position: intuition.pas line 3339

const MM_Authorization = $409;


MM_EnterPowerSaveMode

Declaration

Source position: intuition.pas line 3337

const MM_EnterPowerSaveMode = $407;


MM_ExitBlanker

Declaration

Source position: intuition.pas line 3338

const MM_ExitBlanker = $408;


MM_GetDefaultGammaTables

Declaration

Source position: intuition.pas line 3333

const MM_GetDefaultGammaTables = $403;


MM_GetDefaultPixelFormat

Declaration

Source position: intuition.pas line 3334

const MM_GetDefaultPixelFormat = $404;


MM_GetPointerBounds

Declaration

Source position: intuition.pas line 3335

const MM_GetPointerBounds = $405;


MM_GetRootBitMap

Declaration

Source position: intuition.pas line 3331

const MM_GetRootBitMap = $401;


MM_Query3DSupport

Declaration

Source position: intuition.pas line 3332

const MM_Query3DSupport = $402;


MM_RunBlanker

Declaration

Source position: intuition.pas line 3336

const MM_RunBlanker = $406;


MODELCLASS

Class identifier. Multiple Targets

Declaration

Source position: intuition.pas line 1986

const MODELCLASS: PChar = 'modelclass';

Description

SuperClass: icclass

A class of OM_UPDATE forwarding objects that have multiple targets. In addition to the features the modelclass object inherits from icclass, when a modelclass object gets an OM_UPDATE message, it forwards that OM_UPDATE message to all of the objects in its broadcast list.

Changed Methods:

OM_ADDMEMBER, OM_REMMEMBER, OM_DISPOSE, OM_NOTIFY, OM_UPDATE

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


MONITOR_MAXPIXELFORMATS

Declaration

Source position: intuition.pas line 3299

const MONITOR_MAXPIXELFORMATS = 14;


MOUSE_ACCEL

Declaration

Source position: intuition.pas line 1767

const MOUSE_ACCEL = 1 shl 15;


MSQUERY3D_HWDRIVER

Declaration

Source position: intuition.pas line 3359

const MSQUERY3D_HWDRIVER = 3;


MSQUERY3D_NODRIVER

Declaration

Source position: intuition.pas line 3357

const MSQUERY3D_NODRIVER = 1;


MSQUERY3D_SWDRIVER

Declaration

Source position: intuition.pas line 3358

const MSQUERY3D_SWDRIVER = 2;


MSQUERY3D_UNKNOWN

Declaration

Source position: intuition.pas line 3356

const MSQUERY3D_UNKNOWN = 0;


MUIA_Screenbar_DisplayedImage

Declaration

Source position: intuition.pas line 3396

const MUIA_Screenbar_DisplayedImage = TAGBASE_SCREENBAR + 3;


MUIA_Screenbar_DisplayedName

Declaration

Source position: intuition.pas line 3395

const MUIA_Screenbar_DisplayedName = TAGBASE_SCREENBAR + 2;


MUIIMAGE

Declaration

Source position: intuition.pas line 3011

const MUIIMAGE = $14;


MUIM_Screenbar_BuildSettingsPanel

Declaration

Source position: intuition.pas line 3399

const MUIM_Screenbar_BuildSettingsPanel = TAGBASE_SCREENBAR + 20;


MUIM_Screenbar_DefaultConfigItem

Declaration

Source position: intuition.pas line 3401

const MUIM_Screenbar_DefaultConfigItem = TAGBASE_SCREENBAR + 22;


MUIM_Screenbar_KnowsConfigItem

Declaration

Source position: intuition.pas line 3400

const MUIM_Screenbar_KnowsConfigItem = TAGBASE_SCREENBAR + 21;


MUIM_Screenbar_Lock

Declaration

Source position: intuition.pas line 3403

const MUIM_Screenbar_Lock = TAGBASE_SCREENBAR + 24;


MUIM_Screenbar_Signal

Declaration

Source position: intuition.pas line 3405

const MUIM_Screenbar_Signal = TAGBASE_SCREENBAR + 26;


MUIM_Screenbar_Unlock

Declaration

Source position: intuition.pas line 3404

const MUIM_Screenbar_Unlock = TAGBASE_SCREENBAR + 25;


MUIM_Screenbar_UpdateConfigItem

Declaration

Source position: intuition.pas line 3402

const MUIM_Screenbar_UpdateConfigItem = MUIM_UpdateConfig;


MUIM_UpdateConfig

Declaration

Source position: intuition.pas line 3393

const MUIM_UpdateConfig = $8042b0a9;


MUISERIALNO_INTUITION

Declaration

Source position: intuition.pas line 3389

const MUISERIALNO_INTUITION = $FECF;


MULTIPLY_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as multipliers

Declaration

Source position: intuition.pas line 1870

const MULTIPLY_DIMENSIONS = $0080;


MXIMAGE

SYSIA_Which tag data values. GadTools mutual exclude "button" image

Declaration

Source position: intuition.pas line 2495

const MXIMAGE = $0F;


N_TRACTOR

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 1806

const N_TRACTOR = $20;


NOISYREQ

Flag for TRequester.Flags. Requester does not filter input.

Declaration

Source position: intuition.pas line 461

const NOISYREQ = $0004;


NOITEM

Declaration

Source position: intuition.pas line 1258

const NOITEM = $003F;


NOMENU

Declaration

Source position: intuition.pas line 1257

const NOMENU = $001F;


NOREQBACKFILL

Flag for TRequester.Flags. Don't bother filling requester with TRequester.BackFill pen

Declaration

Source position: intuition.pas line 465

const NOREQBACKFILL = $0040;


Unit 'intuition' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

NOSUB

Declaration

Source position: intuition.pas line 1259

const NOSUB = $001F;


NS_EXTENDED

Flag for TScreen.Flags. TExtNewScreen.Extension is valid

Declaration

Source position: intuition.pas line 1415

const NS_EXTENDED = 1 shl 12;


NUMDRIPENS

Rendering pen number indexes into TDrawInfo.dri_Pens.

Declaration

Source position: intuition.pas line 1391

const NUMDRIPENS = 12;

Description

Only present if DRI_VERSION >= 2


Object_

Handle for an BOOPSI Objects / Classes / Messages

Declaration

Source position: intuition.pas line 1953

type Object_ = LongWord;


OKABORT

Internal token to represent state of verification attempts shown here as a clue. window rendered question moot

Declaration

Source position: intuition.pas line 899

const OKABORT = $0004;


OKCANCEL

Internal token to represent state of verification attempts shown here as a clue. window sent cancel reply

Declaration

Source position: intuition.pas line 900

const OKCANCEL = MENUCANCEL;


OKIMATE_20

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1829

const OKIMATE_20 = $09;


OKOK

Internal token to represent state of verification attempts shown here as a clue. guy didn't care

Declaration

Source position: intuition.pas line 898

const OKOK = MENUHOT;


OM_ADDMEMBER

This method tells an object to add an object to its broadcast list.

Declaration

Source position: intuition.pas line 2004

const OM_ADDMEMBER = OM_Dummy + 9;

Description

Tells an object to add another object to its personal Exec list. What the list is for depends on the class. The return value for this method is not explicitly defined.

One class that uses this method is modelclass. A modelclass object maintains a broadcast list. When a modelclass object gets an OM_NOTIFY message, it broadcasts an OM_UPDATE message about the OM_NOTIFY to every object in its broadcast list.

This method uses TopMember message.

opam_Object is the object to add to the list. A dispatcher typically implements OM_ADDMEMBER by sending the OM_ADDTAIL message to the opam_Object object.

See also

TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_ADDTAIL

This method tells an object to add itself to the end of an Exec list.

Declaration

Source position: intuition.pas line 2000

const OM_ADDTAIL = OM_Dummy + 5;

Description

This method tells an object to add itself to the end of a specified Exec list. Boopsi objects contain a MinNode structure used for this purpose. The return value for this method is not explicitly defined.

The method uses TopAddTail message

The opat_List can be any Exec list. Use the Intuition function NextObject() to step through this list.

See also

TopAddTail | Message structure for OM_ADDTAIL
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_DISPOSE

This method tells an object to dispose of itself.

Declaration

Source position: intuition.pas line 1997

const OM_DISPOSE = OM_Dummy + 2;

Description

This method instructs an object to delete itself. The rootclass dispatcher's OM_DISPOSE method decrements the true class's internal count of instances of true class. The return value for this method is not explicitly defined.

This method uses the default Boopsi message.

Applications should not call this method directly. Instead they should use the function DisposeObject().

For the OM_DISPOSE method, an object should do the following:

Free any additional resources the object explicitly allocated itself in the OM_NEW method (this does not include the instance data).

Pass the message up to the superclass, which will eventually reach rootclass, which will free the instance data allocated for the object.

If a class does not allocate any extra resources when it creates an object, it can defer all OM_DISPOSE processing to its superclass.

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_Dummy

Start of dispatched method ID's

Declaration

Source position: intuition.pas line 1995

const OM_Dummy = $100;


OM_GET

This method tells an object to report an attribute value.

Declaration

Source position: intuition.pas line 1999

const OM_GET = OM_Dummy + 4;

Description

Tells an object to report an attribute's value. Applications should not call this method directly. Instead, use the intuition.library function GetAttr(). The return value for this method is not explicitly defined.

This method uses TopGet message.

If the object's dispatcher recognizes opg_AttrID as one of the attributes defined by this class, the dispatcher should copy the value of that attribute to where opg_Storage points.

If the dispatcher does not recognize opg_AttrID, it should pass the message on to the superclass.

See also

TopGet | Message structure for OM_GET
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_NEW

This method creates a new object.

Declaration

Source position: intuition.pas line 1996

const OM_NEW = OM_Dummy + 1;

Description

This method tells a class to create a new instance of itself. If OM_NEW is successful, it returns a pointer to the new object, otherwise it returns nil.

For programmers who are only creating Boopsi objects rather than creating custom classes, use the intuition.library function NewObject()

The OM_NEW method receives the arguments via PopSet.

The ops_AttrList field contains a pointer to a tag list of attribute/value pairs. Each pair contains an attribute ID and the initial value of the corresponding attribute.

The ops_GInfo field is always nil for the OM_NEW method.

Unlike other methods, when the dispatcher gets an OM_NEW message, the object pointer does not point to an object, since the idea is to create a new object. The pointer normally used to pass a Boopsi object is instead used to pass the address of the object's "true class" (the class of which the object is an instance).

The first thing the dispatcher does when it processes an OM_NEW message is pass the OM_NEW message on to its superclass's dispatcher. It does this using function DoSuperMethodA().

Each superclass's dispatcher does this until the message gets to the rootclass dispatcher.

Each class keeps a record of how much memory its local instance data requires. The rootclass dispatcher's OM_NEW method looks at the object's true class (newobject from the prototype) to find out how much memory to allocate for the object's instance data. The rootclass dispatcher allocates enough memory for the true class's local instance data, plus enough memory for the local instance data of each of the true class's superclasses. If all goes well, the rootclass dispatcher increments the true class's internal count of instances of true class, and returns a pointer to the newly created object. it passes control back to the subclass dispatcher that called it. If there was a problem, the rootclass dispatcher passes back a nil.

When the rootclass dispatcher returns, the subclass dispatcher regains control from DoSuperMethodA(). DoSuperMethodA() will return either a pointer to the new object or nil if there was an error. Although the rootclass dispatcher allocated all the memory the object needs, it did not set up any of that memory. Now its the the subclass dispatcher's turn to do some work. It has to initialize the instance data that is local to its class. A dispatcher finds its local instance data by using the INST_DATA() macro.

After initializing its local instance data, the subclass dispatcher passes control down to its subclass dispatcher, which in turn, initializes its local instance data. Control passes down from class to subclass until the true class dispatcher regains control.

Now the true class dispatcher has to initialize its local instance data. It has to scan through the tag list of attribute/value pairs passed in the OM_NEW message (TopSet.ops_AttrList). If the dispatcher finds any attributes that the true class recognizes, it has to initialize them to the value passed in the attribute/value pair.

At this point, the new object can allocate other resources it needs that it did not allocate as part of its instance data. For example, the new Boopsi object might need a frame image around itself, so it can create a new one using a Boopsi frame image. If the object allocates any resources in this step, it must deallocate these resources later when it is disposed in the OM_DISPOSE method.

Finally, the dispatcher can return. When the dispatcher returns from an OM_NEW method, it returns a pointer to the new object.

See also

TopSet | Message structure for OM_NEW/OM_SET
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_NOTIFY

This method tells an object to broadcast an attribute change to its broadcast list.

Declaration

Source position: intuition.pas line 2002

const OM_NOTIFY = OM_Dummy + 7;

Description

This method tells an object to broadcast an attribute change to a set of target objects using OM_UPDATE messages. The return value for this method is not explicitly defined.

The OM_NOTIFY method uses the TopUpdate message structure.

Most dispatchers do not handle the OM_NOTIFY message directly. Normally they inherit this method from a superclass, so they pass the OM_NOTIFY message on to the superclass dispatcher.

Although most dispatchers don't have to process OM_NOTIFY messages, most do have to send them. Whenever an object receives an OM_SET or OM_UPDATE about one of its attributes, it may need to notify other objects of the change. For example, when a prop gadget's PGA_Top value changes, its target object(s) need to hear about it.

If an object needs to notify other objects about a change to one or more of its attributes, it sends itself an OM_NOTIFY message. The OM_NOTIFY message will eventually end up in the hands of a superclass that understands OM_NOTIFY and it will send OM_UPDATE messages to the target objects.

See also

TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_REMMEMBER

This method tells an object to remove an object from its broadcast list.

Declaration

Source position: intuition.pas line 2005

const OM_REMMEMBER = OM_Dummy + 10;

Description

Tells an object to remove a member object from its personal list. The member object should have already been added with OM_ADDMEMBER. This method uses the TopMember message. Normally a dispatcher implements OM_REMMEMBER by sending the OM_REMOVE message to the opam_Object object. The return value for this method is not explicitly defined.

See also

TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_REMOVE

This method tells an object to remove itself from an Exec list.

Declaration

Source position: intuition.pas line 2001

const OM_REMOVE = OM_Dummy + 6;

Description

Remove an object from an Exec list. The return value for this method is not explicitly defined. This method uses the default Boopsi message.

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_SET

This method tells an object to set one or more of its attribute values.

Declaration

Source position: intuition.pas line 1998

const OM_SET = OM_Dummy + 3;

Description

This method tells an object to set one or more of its attributes. Applications should not call this method directly. Instead, use the intuition.library functions SetAttrs() and SetGadgetAttrs() to call this method. The return value for this method is not explicitly defined.

The return value for this method is not explicitly defined. However, in general, when implementing the OM_SET method, if setting an object attribute causes some sort of visual state change, the OM_SET method should return a value greater than zero. If changing an attribute does not affect the visual state, OM_SET should return zero.

This method uses a TopSet Message.

The ops_AttrList field contains a pointer to a tag list of attribute/value pairs. These pairs contain the IDs and the new values of the attributes to set. The dispatcher has to look through this list (see NextTagItem() function) for attributes its class recognizes and set the attribute's value accordingly. The dispatcher should let its superclass handle any attributes it does not recognize.

If the object is a gadget, the ops_GInfo field contains a pointer to a TGadgetInfo structure. Otherwise, the value in ops_GInfo is undefined. Intuition use the TGadgetInfo structure to pass display information to gadgets. See the gadgetclass methods for more details.

See also

TopSet | Message structure for OM_NEW/OM_SET
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_UPDATE

This method tells an object to update one or more of its attribute values.

Declaration

Source position: intuition.pas line 2003

const OM_UPDATE = OM_Dummy + 8;

Description

This method tells an object to update one or more of its attributes. No application should call this method. Only Boopsi objects send OM_UPDATE messages. The return value for this method is not explicitly defined.

A Boopsi object uses an OM_UPDATE message to notify another Boopsi object about transitory changes to one or more attributes.

From the point of view of most objects, an OM_UPDATE message is almost identical to OM_SET. Because the methods are so similar, When a typical dispatcher receives an OM_UPDATE message, it processes the OM_UPDATE the same way it would process an OM_SET message, usually using the same code.

There are actually two kinds of OM_UPDATE, an interim and final one. While a Boopsi object's attribute is in a transient state, it can send out interim OM_UPDATE messages to its target(s). For example, while the user is sliding a Boopsi prop gadget, the prop gadget sends interim OM_UPDATE message about changes to its PGA_Top value (the integer value of the prop gadget is the PGA_Top attribute) to some target object. When the user lets go of the prop gadget, the gadget is no longer in a transient state, so the gadget sends out a final OM_UPDATE about its PGA_Top attribute. The target object can choose to change one of its attributes based on the OM_UPDATE messages it receives.

The layout of the OM_UPDATE message is almost identical to the OM_SET message

Some dispatchers need to know the difference between an interim and final OM_UPDATE. A dispatcher can tell the difference between an interim and final OM_UPDATE message because the OM_UPDATE message has an extra field for flags. If the low order bit (the OPUF_INTERIM bit) is set, this is an interim OM_UPDATE message. The interim flag is useful to a class that wants to ignore any interim messages, processing only final attribute values.

See also

TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OPUF_INTERIM

Flag for TopUpdate.opu_Flags

Declaration

Source position: intuition.pas line 2057

const OPUF_INTERIM = 1;

Description

This flag means that the update message is being issued from something like an active gadget, a la GACT_FOLLOWMOUSE. When the gadget goes inactive, it will issue a final update message with this bit cleared. Examples of use are for GACT_FOLLOWMOUSE equivalents for propgclass, and repeat strobes for buttons.


ORDERED_DITHERING

Flag for TPreferences.PrintFlags ordered dithering

Declaration

Source position: intuition.pas line 1874

const ORDERED_DITHERING = $0000;


OSCAN_MAX

Identifier for SA_Overscan as much as possible

Declaration

Source position: intuition.pas line 1594

const OSCAN_MAX = 3;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSCAN_STANDARD

Identifier for SA_Overscan just past edges

Declaration

Source position: intuition.pas line 1593

const OSCAN_STANDARD = 2;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSCAN_TEXT

Identifier for SA_Overscan entirely visible

Declaration

Source position: intuition.pas line 1592

const OSCAN_TEXT = 1;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSCAN_VIDEO

Identifier for SA_Overscan even more than is possible

Declaration

Source position: intuition.pas line 1595

const OSCAN_VIDEO = 4;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSERR_ATTACHFAIL

Declaration

Source position: intuition.pas line 1540

const OSERR_ATTACHFAIL = 8;


OSERR_NOCHIPMEM

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get chipmem

Declaration

Source position: intuition.pas line 1536

const OSERR_NOCHIPMEM = 4;


OSERR_NOCHIPS

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode You need newer custom chips

Declaration

Source position: intuition.pas line 1534

const OSERR_NOCHIPS = 2;


OSERR_NOMEM

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get normal memory

Declaration

Source position: intuition.pas line 1535

const OSERR_NOMEM = 3;


OSERR_NOMONITOR

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Named monitor spec not available

Declaration

Source position: intuition.pas line 1533

const OSERR_NOMONITOR = 1;


OSERR_NOTAVAILABLE

Declaration

Source position: intuition.pas line 1541

const OSERR_NOTAVAILABLE = 9;


OSERR_PUBNOTUNIQUE

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Public screen name already used

Declaration

Source position: intuition.pas line 1537

const OSERR_PUBNOTUNIQUE = 5;


OSERR_TOODEEP

Declaration

Source position: intuition.pas line 1539

const OSERR_TOODEEP = 7;


OSERR_UNKNOWNMODE

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Don't recognize mode asked for

Declaration

Source position: intuition.pas line 1538

const OSERR_UNKNOWNMODE = 6;


P_Object

Pointer to an Boopsi Object

Declaration

Source position: intuition.pas line 2087

type P_Object = ^T_Object;


PARALLEL_PRINTER

Value for TPreferences.PrinterPort

Declaration

Source position: intuition.pas line 1769

const PARALLEL_PRINTER = $00;


PBoolInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_BOOLGADGET

Declaration

Source position: intuition.pas line 347

type PBoolInfo = ^TBoolInfo;


PBorder

Pointer to Border Drawing structure

Declaration

Source position: intuition.pas line 59

type PBorder = ^TBorder;

Description

Data type Border, used for drawing a series of lines which is intended for use as a border drawing, but which may, in fact, be used to render any arbitrary vector shape. The routine DrawBorder sets up the RastPort with the appropriate variables, then does a Move to the first coordinate, then does Draws to the subsequent coordinates. After all the Draws are done, if NextBorder is non-zero we call DrawBorder recursively

See also

TRequester | Requesters The following struct is used for standard intuition requesters
GA_Border | GadgetClass Tag. (PBorder) Gadget imagry is a border
DrawBorder | Draw the specified Border structure into a RastPort.


PBTDBoolean

Declaration

Source position: intuition.pas line 2877

type PBTDBoolean = ^TBTDBoolean;


PBTDCycle

Declaration

Source position: intuition.pas line 2899

type PBTDCycle = ^TBTDCycle;


PBTDDrawInfo

Declaration

Source position: intuition.pas line 2952

type PBTDDrawInfo = ^TBTDDrawInfo;


PBTDFile

Declaration

Source position: intuition.pas line 2918

type PBTDFile = ^TBTDFile;


PBTDFont

Declaration

Source position: intuition.pas line 2912

type PBTDFont = ^TBTDFont;


PBTDInfo

Declaration

Source position: intuition.pas line 2925

type PBTDInfo = ^TBTDInfo;


PBTDInteger

Declaration

Source position: intuition.pas line 2883

type PBTDInteger = ^TBTDInteger;


PBTDNode

Declaration

Source position: intuition.pas line 2868

type PBTDNode = ^TBTDNode;


PBTDString

Declaration

Source position: intuition.pas line 2906

type PBTDString = ^TBTDString;


PClassLibrary

Pointer to a BOOPSI class libraries

Declaration

Source position: intuition.pas line 2096

type PClassLibrary = ^TClassLibrary;


PColorSpec

Pointer to Color table entry

Declaration

Source position: intuition.pas line 1237

type PColorSpec = ^TColorSpec;


PDrawInfo

Pointer to Draw info structure

Declaration

Source position: intuition.pas line 1352

type PDrawInfo = ^TDrawInfo;

See also

TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
GA_DrawInfo | GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.
TimpFrameBox | Message argument for IM_FRAMEBOX
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME
DrawImageState | Draw an (extended) Intuition Image with special visual state.
FreeScreenDrawInfo | Finish using a DrawInfo structure.
GetScreenDrawInfo | Get pointer to rendering information.


PEasyStruct

The text and setup of an easy requester

Declaration

Source position: intuition.pas line 1246

type PEasyStruct = ^TEasyStruct;

See also

BuildEasyRequestArgs | Simple creation of system request.
EasyRequestArgs | Easy alternative to AutoRequest()


PEN_C0

Complement of color 0

Declaration

Source position: intuition.pas line 1397

const PEN_C0 = $FEFF;

Description

It is sometimes useful to specify that a pen value is to be the complement of color zero. This "magic" number serve that purpose.


PEN_C1

Complement of color 1

Declaration

Source position: intuition.pas line 1396

const PEN_C1 = $FEFE;

Description

It is sometimes useful to specify that a pen value is to be the complement of color one. This "magic" number serve that purpose.


PEN_C2

Complement of color 2

Declaration

Source position: intuition.pas line 1395

const PEN_C2 = $FEFD;

Description

It is sometimes useful to specify that a pen value is to be the complement of color two. This "magic" number serve that purpose.


PEN_C3

Complement of color 3

Declaration

Source position: intuition.pas line 1394

const PEN_C3 = $FEFC;

Description

It is sometimes useful to specify that a pen value is to be the complement of color three. This "magic" number serve that purpose.


PENSHARED

Flag for TScreen.Flags. Screen opener set (SA_SharePens,True)

Declaration

Source position: intuition.pas line 1414

const PENSHARED = 1 shl 10;


PExtEasyStruct

Declaration

Source position: intuition.pas line 3129

type PExtEasyStruct = ^TExtEasyStruct;


PExtGadget

Pointer to and extended Gadget structure

Declaration

Source position: intuition.pas line 160

type PExtGadget = ^TExtGadget;

See also

PGadget | Pointer to a Gadget structure
GFLG_EXTENDED | Flag for TGadget.SpecialInfo. Gadget is an PExtGadget


PExtIntuiMessage

Pointer to an extended Intuition message

Declaration

Source position: intuition.pas line 596

type PExtIntuiMessage = ^TExtIntuiMessage;


PExtNewScreen

Pointer to Extended New Screen structure

Declaration

Source position: intuition.pas line 1571

type PExtNewScreen = ^TExtNewScreen;


PExtNewWindow

Pointer to Future TNewWindow.

Declaration

Source position: intuition.pas line 1010

type PExtNewWindow = ^TExtNewWindow;


PG_BEHAVIOUR_COMPATIBLE

Declaration

Source position: intuition.pas line 2194

const PG_BEHAVIOUR_COMPATIBLE = 0;


PG_BEHAVIOUR_NICE

Declaration

Source position: intuition.pas line 2195

const PG_BEHAVIOUR_NICE = 1;


PGA_Borderless

PropGClass Tag. (LongBool) If set, no border will be rendered.

Declaration

Source position: intuition.pas line 2178

const PGA_Borderless = PGA_Dummy + 2;


PGA_Dummy

PropGClass Start Tag.

Declaration

Source position: intuition.pas line 2175

const PGA_Dummy = TAG_USER + $31000;


PGA_Freedom

PropGClass Tag. [IS.] (LongWord) Define in which the direction gadget should stretch.

Declaration

Source position: intuition.pas line 2176

const PGA_Freedom = PGA_Dummy + 1;

Description

Possible values are FREEVERT and FREEHORIZ


PGA_HorizBody

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2180

const PGA_HorizBody = PGA_Dummy + 4;


PGA_HorizPot

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2179

const PGA_HorizPot = PGA_Dummy + 3;


PGA_NewLook

PropGClass Tag. [IS.] (LongBool) If set, this indicated that the new look should be used for rendering.

Declaration

Source position: intuition.pas line 2187

const PGA_NewLook = PGA_Dummy + 10;


PGA_NotifyBehaviour

Declaration

Source position: intuition.pas line 2189

const PGA_NotifyBehaviour = PGA_Dummy + 30;


PGA_RenderBehaviour

Declaration

Source position: intuition.pas line 2191

const PGA_RenderBehaviour = PGA_Dummy + 31;


PGA_Top

PropGClass Tag. [ISG] (Word) The first visible position.

Declaration

Source position: intuition.pas line 2185

const PGA_Top = PGA_Dummy + 9;

Description

Should not be used with PGA_HorizPot, PGA_HorizBody, PGA_VertPot and PGA_VertBody.


PGA_Total

PropGClass Tag. [IS.] (Word) The total number of positions in the gadget.

Declaration

Source position: intuition.pas line 2183

const PGA_Total = PGA_Dummy + 7;

Description

Should not be used with PGA_HorizPot, PGA_HorizBody, PGA_VertPot and PGA_VertBody.


PGA_VertBody

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2182

const PGA_VertBody = PGA_Dummy + 6;


PGA_VertPot

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2181

const PGA_VertPot = PGA_Dummy + 5;


PGA_Visible

PropGClass Tag. [IS.] (Word) The number of visible positions in the gadget.

Declaration

Source position: intuition.pas line 2184

const PGA_Visible = PGA_Dummy + 8;

Description

Should not be used with PGA_HorizPot, PGA_HorizBody, PGA_VertPot and PGA_VertBody.


PGadget

Pointer to a Gadget structure

Declaration

Source position: intuition.pas line 135

type PGadget = ^TGadget;

See also

TRequester | Requesters The following struct is used for standard intuition requesters
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TScreen | Basic screen structure
TNewScreen | Description of a new screen
TExtNewScreen | Extended TNewScreen structure
GA_Previous | GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.
GA_Next | GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.
TSGWork | String gadget message
ActivateGadget | Activate a (string or custom) gadget.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
GadgetMouse | Calculate gadget-relative mouse position.
ModifyProp | Modify the current parameters of a proportional gadget.
ObtainGIRPort | Set up a RastPort for a custom gadget.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.
GADGET_BOX | Get bounding box of a gadget
CUSTOM_HOOK | Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget


PGadgetInfo

Pointer to Gadget Render Info

Declaration

Source position: intuition.pas line 1914

type PGadgetInfo = ^TGadgetInfo;

See also

TopSet | Message structure for OM_NEW/OM_SET
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpRender | Message parameter passed for GM_RENDER
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
TgpGoInactive | Message parameter passed for GM_GOINACTIVE
TgpLayout | Message parameter passed for GM_LAYOUT
TgpDomain |
TSGWork | String gadget message
GadgetMouse | Calculate gadget-relative mouse position.
ObtainGIRPort | Set up a RastPort for a custom gadget.


PgpDomain

Declaration

Source position: intuition.pas line 2345

type PgpDomain = ^TgpDomain;


PgpGoInactive

Pointer to Message parameter passed for GM_GOINACTIVE

Declaration

Source position: intuition.pas line 2317

type PgpGoInactive = ^TgpGoInactive;


PgpHitTest

Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST

Declaration

Source position: intuition.pas line 2248

type PgpHitTest = ^TgpHitTest;


PgpInput

Pointer to Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT

Declaration

Source position: intuition.pas line 2288

type PgpInput = ^TgpInput;


PgpKeyGoInactive

Declaration

Source position: intuition.pas line 2390

type PgpKeyGoInactive = ^TgpKeyGoInactive;


PgpKeyInput

Declaration

Source position: intuition.pas line 2375

type PgpKeyInput = ^tgpKeyInput;


PgpKeyTest

Declaration

Source position: intuition.pas line 2364

type PgpKeyTest = ^TgpKeyTest;


PgpLayout

Pointer to Message parameter passed for GM_LAYOUT

Declaration

Source position: intuition.pas line 2335

type PgpLayout = ^TgpLayout;


PgpRender

Pointer to Message parameter passed for GM_RENDER

Declaration

Source position: intuition.pas line 2272

type PgpRender = ^TgpRender;


PIBox

A data structure common in Intuition processing

Declaration

Source position: intuition.pas line 603

type PIBox = ^TIBox;

See also

GA_Bounds | GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.
TimpFrameBox | Message argument for IM_FRAMEBOX
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
TPGX | System private data structure for now prop gadget extra info
TgpDomain |
IM_BOX | Get Image bounding rectangle
GADGET_BOX | Get bounding box of a gadget


PICA

Value for TPreferences.PrintPitch

Declaration

Source position: intuition.pas line 1784

const PICA = $000;


PIClass

This structure is READ-ONLY, and allocated only by Intuition

Declaration

Source position: intuition.pas line 2065

type PIClass = ^TIClass;


PImage

This is a brief image structure for very simple transfers of image data to a RastPort

Declaration

Source position: intuition.pas line 474

type PImage = ^TImage;

See also

TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TDrawInfo | Graphical informations for the 3D look
GA_Image | GadgetClass Tag. (PImage) Gadget imagry is an image
GA_SelectRender | GadgetClass Tag.
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.
EraseImage | Erases an Image.
PointInImage | Tests whether an image "contains" a point.
IM_BGPEN | Set Image Background Pen
IM_BOX | Get Image bounding rectangle
IM_FGPEN | Set Image Foreground pen


PimpDomainFrame

Declaration

Source position: intuition.pas line 2601

type PimpDomainFrame = ^TimpDomainFrame;


PimpDraw

Pointer to message argument for IM_DRAW or IM_DRAWFRAME

Declaration

Source position: intuition.pas line 2548

type PimpDraw = ^TimpDraw;


PimpErase

Pointer to message argument for IM_ERASE or IM_ERASEFRAME

Declaration

Source position: intuition.pas line 2568

type PimpErase = ^TimpErase;


PimpFrameBox

Pointer to message argument for IM_FRAMEBOX

Declaration

Source position: intuition.pas line 2534

type PimpFrameBox = ^TimpFrameBox;


PimpHitTest

Pointer to message argument for IM_HITTEST or IM_HITFRAME

Declaration

Source position: intuition.pas line 2584

type PimpHitTest = ^TimpHitTest;


PIntuiMessage

Pointer to an Intuition message

Declaration

Source position: intuition.pas line 567

type PIntuiMessage = ^TIntuiMessage;

See also

TWindow | Window structure
exec.GetMsg | Get next message from message port
exec.PutMsg | Put a message to a message port
exec.ReplyMsg | Put a message to its reply port
exec.WaitPort | Wait for a given port to be non-empty


PIntuiText

IntuiText is a series of strings.

Declaration

Source position: intuition.pas line 41

type PIntuiText = ^TIntuiText;

Description

IntuiText is a series of strings that start with a screen location (always relative to the upper-left corner of something) and then the text of the string. The text is null-terminated.

See also

TGadget | Structure to describe a Gadget
TExtGadget | Extended Gadget structure
TRequester | Requesters The following struct is used for standard intuition requesters
GFLG_LABELITEXT | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText
GA_IntuiText | GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.
AutoRequest | Automatically build and get response from a requester.
BuildSysRequest | Build and display a system requester.
IntuiTextLength | Return the length (pixel-width) of an IntuiText.
PrintIText | Print text described by the IntuiText argument.


PIntuitionBase

Pointer to Intution basic structures

Declaration

Source position: intuition.pas line 1889

type PIntuitionBase = ^TIntuitionBase;

See also

TIntuitionBase

Intuition basic structure


PIXEL_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as prt pixels

Declaration

Source position: intuition.pas line 1869

const PIXEL_DIMENSIONS = $0040;


PMenu

Pointer to a menu structure

Declaration

Source position: intuition.pas line 111

type PMenu = ^TMenu;

See also

TWindow | Window structure
ItemAddress | Returns the address of the specified MenuItem.
ResetMenuStrip | Re-attach a menu strip to a window.
SetMenuStrip | Attach a menu strip to a window.


PMenuItem

Pointer to an menu item

Declaration

Source position: intuition.pas line 73

type PMenuItem = ^TMenuItem;

See also

TMenu | Structure to describe a menu
ItemAddress | Returns the address of the specified MenuItem.


PMsg

Declaration

Source position: intuition.pas line 1964

type PMsg = ^TMsg;

Description

You can use this type to point to a 'generic' message, in the object-oriented programming parlance. Based on the value of MethodID, you dispatch to processing for the various message types. The meaningful parameter packet structure definitions are defined below.

See also

DoGadgetMethodA

Invoke method on a boopsi gadget.


PmsGetDefaultGammaTables

Declaration

Source position: intuition.pas line 3361

type PmsGetDefaultGammaTables = ^TmsGetDefaultGammaTables;


PmsGetDefaultPixelFormat

Declaration

Source position: intuition.pas line 3369

type PmsGetDefaultPixelFormat = ^TmsGetDefaultPixelFormat;


PmsGetPointerBounds

Declaration

Source position: intuition.pas line 3376

type PmsGetPointerBounds = ^TmsGetPointerBounds;


PmsGetRootBitMap

Declaration

Source position: intuition.pas line 3342

type PmsGetRootBitMap = ^TmsGetRootBitMap;


PmsQuery3DSupport

Declaration

Source position: intuition.pas line 3349

type PmsQuery3DSupport = ^TmsQuery3DSupport;


PmsSetDefaultGammaTables

Declaration

Source position: intuition.pas line 3384

type PmsSetDefaultGammaTables = PmsGetDefaultGammaTables;


PMUIP_Screenbar_BuildSettingsPanel

Declaration

Source position: intuition.pas line 3408

type PMUIP_Screenbar_BuildSettingsPanel = ^TMUIP_Screenbar_BuildSettingsPanel;


PMUIP_Screenbar_DefaultConfigItem

Declaration

Source position: intuition.pas line 3419

type PMUIP_Screenbar_DefaultConfigItem = ^TMUIP_Screenbar_DefaultConfigItem;


PMUIP_Screenbar_KnowsConfigItem

Declaration

Source position: intuition.pas line 3413

type PMUIP_Screenbar_KnowsConfigItem = ^TMUIP_Screenbar_KnowsConfigItem;


PMUIP_Screenbar_Lock

Declaration

Source position: intuition.pas line 3428

type PMUIP_Screenbar_Lock = ^TMUIP_Screenbar_Lock;


PMUIP_Screenbar_Signal

Declaration

Source position: intuition.pas line 3438

type PMUIP_Screenbar_Signal = ^TMUIP_Screenbar_Signal;


PMUIP_Screenbar_Unlock

Declaration

Source position: intuition.pas line 3433

type PMUIP_Screenbar_Unlock = ^TMUIP_Screenbar_Unlock;


PMUIP_UpdateConfig

Declaration

Source position: intuition.pas line 3425

type PMUIP_UpdateConfig = PMUIP_Screenbar_DefaultConfigItem;


PNewScreen

pointer to an instance of a NewScreen structure.

Declaration

Source position: intuition.pas line 1545

type PNewScreen = ^TNewScreen;


PNewWindow

Pointer to structure describes a new window

Declaration

Source position: intuition.pas line 952

type PNewWindow = ^TNewWindow;

See also

OpenWindow | Open an Intuition window.
OpenWindowTagList | OpenWindow() with TagItem extension.


PObject_

Pointer to an BOOPSI Object / Classe / Message Handle

Declaration

Source position: intuition.pas line 1954

type PObject_ = ^LongWord;


POINTERA_BitMap

PointerClass Attribute. (PBitmap) Pointer to bitmap to get pointer imagery from. Bitplane data need not be in chip RAM.

Declaration

Source position: intuition.pas line 2620

const POINTERA_BitMap = POINTERA_Dummy + $01;


POINTERA_Dummy

PointerClass Attributes start.

Declaration

Source position: intuition.pas line 2619

const POINTERA_Dummy = TAG_USER + $39000;


POINTERA_WordWidth

PointerClass Attribute. (LongWord) - designed width of the pointer in words

Declaration

Source position: intuition.pas line 2623

const POINTERA_WordWidth = POINTERA_Dummy + $04;


POINTERA_XOffset

PointerClass Attribute. (LongInt) - X-offset of the pointer hotspot.

Declaration

Source position: intuition.pas line 2621

const POINTERA_XOffset = POINTERA_Dummy + $02;


POINTERA_XResolution

PointerClass Attribute. (LongWord) - one of the POINTERXRESN_* flags

Declaration

Source position: intuition.pas line 2624

const POINTERA_XResolution = POINTERA_Dummy + $05;


POINTERA_YOffset

PointerClass Attribute. (LongInt) - Y-offset of the pointer hotspot.

Declaration

Source position: intuition.pas line 2622

const POINTERA_YOffset = POINTERA_Dummy + $03;


POINTERA_YResolution

PointerClass Attribute. (LongWord) - one of the POINTERYRESN_* flags

Declaration

Source position: intuition.pas line 2625

const POINTERA_YResolution = POINTERA_Dummy + $06;


POINTERCLASS

Class identifier

Declaration

Source position: intuition.pas line 1988

const POINTERCLASS: PChar = 'pointerclass';

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


POINTERSIZE

Size of Pointer data buffer for printer configuration

Declaration

Source position: intuition.pas line 1664

const POINTERSIZE = (1 + 16 + 1) * (2);


PointerType_2Plus1

Declaration

Source position: intuition.pas line 3327

const PointerType_2Plus1 = $0002;


PointerType_3Plus1

Declaration

Source position: intuition.pas line 3326

const PointerType_3Plus1 = $0001;


POINTERTYPE_AIMING

Declaration

Source position: intuition.pas line 2676

const POINTERTYPE_AIMING = 6;


POINTERTYPE_ALTERNATIVECHOICE

Declaration

Source position: intuition.pas line 2685

const POINTERTYPE_ALTERNATIVECHOICE = 15;


PointerType_ARGB

Declaration

Source position: intuition.pas line 3328

const PointerType_ARGB = $0004;


POINTERTYPE_BUSY

Declaration

Source position: intuition.pas line 2671

const POINTERTYPE_BUSY = 1;


POINTERTYPE_DIAGONALRESIZE1

Declaration

Source position: intuition.pas line 2682

const POINTERTYPE_DIAGONALRESIZE1 = 12;


POINTERTYPE_DIAGONALRESIZE2

Declaration

Source position: intuition.pas line 2683

const POINTERTYPE_DIAGONALRESIZE2 = 13;


POINTERTYPE_DOT

Declaration

Source position: intuition.pas line 2673

const POINTERTYPE_DOT = 3;


POINTERTYPE_HANDWRITING

Declaration

Source position: intuition.pas line 2678

const POINTERTYPE_HANDWRITING = 8;


POINTERTYPE_HELP

Declaration

Source position: intuition.pas line 2675

const POINTERTYPE_HELP = 5;


POINTERTYPE_HORIZONTALRESIZE

Declaration

Source position: intuition.pas line 2681

const POINTERTYPE_HORIZONTALRESIZE = 11;


POINTERTYPE_INVISIBLE

Declaration

Source position: intuition.pas line 2672

const POINTERTYPE_INVISIBLE = 2;


POINTERTYPE_MOVE

Declaration

Source position: intuition.pas line 2684

const POINTERTYPE_MOVE = 14;


POINTERTYPE_NORMAL

Declaration

Source position: intuition.pas line 2670

const POINTERTYPE_NORMAL = 0;


POINTERTYPE_NOTAVAILABLE

Declaration

Source position: intuition.pas line 2679

const POINTERTYPE_NOTAVAILABLE = 9;


POINTERTYPE_NUMTYPES

Declaration

Source position: intuition.pas line 2687

const POINTERTYPE_NUMTYPES = 17;


POINTERTYPE_SELECTLINK

Declaration

Source position: intuition.pas line 2686

const POINTERTYPE_SELECTLINK = 16;


POINTERTYPE_SELECTTEXT

Declaration

Source position: intuition.pas line 2677

const POINTERTYPE_SELECTTEXT = 7;


POINTERTYPE_VERTICALRESIZE

Declaration

Source position: intuition.pas line 2680

const POINTERTYPE_VERTICALRESIZE = 10;


POINTERTYPE_WORKING

Declaration

Source position: intuition.pas line 2674

const POINTERTYPE_WORKING = 4;


POINTERXRESN_35NS

Value for POINTERA_XResolution (pointer always in 35 ns pixels) = 35 ns always

Declaration

Source position: intuition.pas line 2632

const POINTERXRESN_35NS = 3;


POINTERXRESN_70NS

Value for POINTERA_XResolution (pointer always in 70 ns pixels) = 70 ns always

Declaration

Source position: intuition.pas line 2631

const POINTERXRESN_70NS = 2;


POINTERXRESN_140NS

Value for POINTERA_XResolution (pointer always in 140 ns pixels) = 140 ns always

Declaration

Source position: intuition.pas line 2630

const POINTERXRESN_140NS = 1;


POINTERXRESN_DEFAULT

Value for POINTERA_XResolution (ECS-compatible pointer width) = 70 ns if SUPERHIRES-type mode, 140 ns if not

Declaration

Source position: intuition.pas line 2629

const POINTERXRESN_DEFAULT = 0;


POINTERXRESN_HIRES

Value for POINTERA_XResolution (pointer always in hires-like pixels) = 70 ns in 15kHz modes, 35 ns in 31kHz modes

Declaration

Source position: intuition.pas line 2635

const POINTERXRESN_HIRES = 6;


POINTERXRESN_LORES

Value for POINTERA_XResolution (pointer always in lores-like pixels) = 140 ns in 15kHz modes, 70 ns in 31kHz modes

Declaration

Source position: intuition.pas line 2634

const POINTERXRESN_LORES = 5;


POINTERXRESN_SCREENRES

Value for POINTERA_XResolution Same as pixel speed of screen

Declaration

Source position: intuition.pas line 2633

const POINTERXRESN_SCREENRES = 4;


POINTERYRESN_DEFAULT

Value for POINTERA_YResolution Default pointer

Declaration

Source position: intuition.pas line 2663

const POINTERYRESN_DEFAULT = 0;

Description

In 15 kHz modes, the pointer resolution will be the same as a non-interlaced screen. In 31 kHz modes, the pointer will be doubled vertically. This means there will be about 200-256 pointer lines per screen.


POINTERYRESN_HIGH

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 2664

const POINTERYRESN_HIGH = 2;


POINTERYRESN_HIGHASPECT

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 2665

const POINTERYRESN_HIGHASPECT = 3;

Description

Where the hardware/software supports it, the pointer resolution will be high. This means there will be about 400-480 pointer lines per screen. When the pointer comes out double-height due to hardware/software restrictions, its width would be doubled as well, if possible (to preserve aspect).


POINTERYRESN_SCREENRES

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 2666

const POINTERYRESN_SCREENRES = 4;

Description

Will attempt to match the vertical resolution of the pointer to the screen's vertical resolution.


POINTERYRESN_SCREENRESASPECT

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 2667

const POINTERYRESN_SCREENRESASPECT = 5;

Description

Will attempt to match the vertical resolution of the pointer to the screen's vertical resolution. When the pointer comes out double-height due to hardware/software restrictions, its width would be doubled as well, if possible (to preserve aspect).


POINTREL

Flag for TRequester.Flags. If set TopLeft is relative to pointer to the coordinates of either the pointer or the window.

Declaration

Source position: intuition.pas line 459

const POINTREL = $0001;


PopAddMember

Declaration

Source position: intuition.pas line 2048

type PopAddMember = ^TopAddMember;


PopAddTail

Pointer to message structure for OM_ADDTAIL

Declaration

Source position: intuition.pas line 2035

type PopAddTail = ^TopAddTail;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


PopGet

Pointer to message structure for OM_GET

Declaration

Source position: intuition.pas line 2018

type PopGet = ^TopGet;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


PopMember

Pointer to message structure for OM_ADDMEMBER/OM_REMMEMBER

Declaration

Source position: intuition.pas line 2042

type PopMember = ^TopMember;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


POPPUBSCREEN

Pub screen mode. pop pub screen to front when visitor opens

Declaration

Source position: intuition.pas line 1624

const POPPUBSCREEN = $0002;


PopSet

Pointer to message structure for OM_NEW/OM_SET

Declaration

Source position: intuition.pas line 2010

type PopSet = ^TopSet;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


PopUpdate

Pointer to message structure for OM_NOTIFY/OM_UPDATE

Declaration

Source position: intuition.pas line 2026

type PopUpdate = ^TopUpdate;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


POPUPIMAGE

Declaration

Source position: intuition.pas line 3012

const POPUPIMAGE = $15;


PPBTDNode

Declaration

Source position: intuition.pas line 2869

type PPBTDNode = ^PBTDNode;


PPGX

Pointer to System private data structure for now prop gadget extra info

Declaration

Source position: intuition.pas line 1941

type PPGX = ^TPGX;


PPObject_

Pointer to an BOOPSI Object / Classe / Message Pointer Handle

Declaration

Source position: intuition.pas line 1955

type PPObject_ = ^PObject_;


PPreferences

Pointer to old style Preferences

Declaration

Source position: intuition.pas line 1678

type PPreferences = ^TPreferences;

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetPrefs | Get the current Intuition Preferences structure.
SetPrefs | Set Intuition preferences data.


PPropInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_PROPGADGET

Declaration

Source position: intuition.pas line 362

type PPropInfo = ^TPropInfo;


PPubScreenNode

Pointer to Public Shared Screen Node

Declaration

Source position: intuition.pas line 1606

type PPubScreenNode = ^TPubScreenNode;


PREDRAWN

Flag for TRequester.Flags. If set, ImageBMap points to a custom bitmap.

Declaration

Source position: intuition.pas line 460

const PREDRAWN = $0002;


PRemember

Pointer to Memory allocating remember structure

Declaration

Source position: intuition.pas line 1229

type PRemember = ^TRemember;

See also

AllocRemember | Allocate Memory with tracking to make freeing easy.
FreeRemember | Free memory allocated by calls to AllocRemember().


PRequester

Requesters The following struct is used for standard intuition requesters

Declaration

Source position: intuition.pas line 479

type PRequester = ^TRequester;

Description

not to be mixed up with asl or easy requesters. See Request() for more information.

See also

TWindow | Window structure
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
ActivateGadget | Activate a (string or custom) gadget.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
EndRequest | Remove a currently active requester.
InitRequester | Initialize a Requester structure.
ModifyProp | Modify the current parameters of a proportional gadget.
NewModifyProp | ModifyProp(), but with selective refresh.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
Request | Activate a requester.
SetDMRequest | Set the DMRequest of a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.


PROPBORDERLESS

Flag value for TPropInfo.Flags. if set, no border will be rendered

Declaration

Source position: intuition.pas line 414

const PROPBORDERLESS = $0008;


PROPGCLASS

Class identifier. An easy to implement, horizontal or vertical proportional gadget.

Declaration

Source position: intuition.pas line 1980

const PROPGCLASS: PChar = 'propgclass';

Description

SuperClass: gadgetclass

A Boopsi proportional ("prop") gadget. The Boopsi prop gadget is similar to the conventional prop gadget, but extends its function to make it easier to use. The Boopsi prop gadget keeps its current integer value in its PGA_Top attribute.

Changed Methods:

GM_HANDLEINPUT

Attributes:

GA_Image (I)

GA_Border (I)

GA_Highlight (I)

PGA_Freedom (IG)

PGA_Top (ISGNU)

PGA_NewLook (I)

PGA_Visible (ISU)

PGA_Total (ISU)

PGA_Borderless (I)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


PROPNEWLOOK

Flag value for TPropInfo.Flags. set this if you want to get the new look

Declaration

Source position: intuition.pas line 416

const PROPNEWLOOK = $0010;


PScreen

Declaration

Source position: intuition.pas line 475

type PScreen = ^TScreen;


PScreenBuffer

Pointer to screen buffer

Declaration

Source position: intuition.pas line 1639

type PScreenBuffer = ^TScreenBuffer;

See also

AGraphics.AllocDBufInfo | Allocate structure for multi-buffered animation
AllocScreenBuffer | Get a ScreenBuffer for double-buffering.


PSGWork

Pointer to String gadget message

Declaration

Source position: intuition.pas line 2733

type PSGWork = ^TSGWork;


PSNF_PRIVATE

Flag for TPubScreenNode.psn_Flags Private

Declaration

Source position: intuition.pas line 1618

const PSNF_PRIVATE = $0001;


PStringExtend

Extended string info for Gadgets texts

Declaration

Source position: intuition.pas line 2720

type PStringExtend = ^TStringExtend;

See also

GFLG_STRINGEXTEND | Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend
GACT_STRINGEXTEND | Activation flag for TGadget.Activation. this String Gadget has PStringExtend
TStringInfo | String Gadget structure


PStringInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_STRGADGET

Declaration

Source position: intuition.pas line 426

type PStringInfo = ^TStringInfo;


PTabletData

Pointer to a IntuiMessage TabletData

Declaration

Source position: intuition.pas line 477

type PTabletData = ^TTabletData;

Description

If your window sets WA_TabletMessages to True, then it will receive extended IntuiMessages (TExtIntuiMessage) whose .eim_TabletData field points at a TabletData structure. This structure contains additional information about the input event.

See also

TExtIntuiMessage

Extended Intuition message structure


PTabletHookData

Declaration

Source position: intuition.pas line 559

type PTabletHookData = ^TTabletHookData;


PTransparencyMessage

Declaration

Source position: intuition.pas line 3099

type PTransparencyMessage = ^TTransparencyMessage;


PUBLICSCREEN_f

Screentype flag for TScreen.Flags and TNewScreen.SType.

Declaration

Source position: intuition.pas line 1404

const PUBLICSCREEN_f = 1 shl 1;


PWindow

Declaration

Source position: intuition.pas line 476

type PWindow = ^TWindow;


QUME_LP_20

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 1830

const QUME_LP_20 = $0A;


RECOVERY_ALERT

Alert Type for DisplayAlert() the system can recover from this

Declaration

Source position: intuition.pas line 1276

const RECOVERY_ALERT = $00000000;


REQACTIVE

Flag for TRequester.Flags. Read-Only. This requester is active

Declaration

Source position: intuition.pas line 468

const REQACTIVE = $2000;


REQOFFWINDOW

Flag for TRequester.Flags. Read-Only. Part of one of the Gadgets was offwindow

Declaration

Source position: intuition.pas line 467

const REQOFFWINDOW = $1000;


RESCOUNT

Declaration

Source position: intuition.pas line 1327

const RESCOUNT = 2;


RI_VERSION

Declaration

Source position: intuition.pas line 1347

const RI_VERSION = 1;


RIGHTIMAGE

SYSIA_Which tag data values. Right-arrow gadget image

Declaration

Source position: intuition.pas line 2492

const RIGHTIMAGE = $0C;


ROOTCLASS

Root Class identifier, This is the universal base class for all other classes.

Declaration

Source position: intuition.pas line 1974

const ROOTCLASS: PChar = 'rootclass';

Description

All Classes are descendants of the rootclass. There are three primary classes that descend directly from rootclass: imageclass, gadgetclass, and icclass.

SuperClass: None

New Methods:

OM_NEW, OM_ADDTAIL, OM_DISPOSE, OM_REMOVE

The following methods are described at the rootclass level although its up to the subclasses to actually implement them. If a class does not implement these methods, it should either return zero, indicating that this class does not support the method, or defer processing on to its superclass.

OM_ADDMEMBER, OM_GET, OM_UPDATE, OM_REMMEMBER, OM_SET, OM_NOTIFY

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


SA_3DSupport

Declaration

Source position: intuition.pas line 1509

const SA_3DSupport = SA_Dummy + 127;


SA_AdaptSize

Declaration

Source position: intuition.pas line 1511

const SA_AdaptSize = SA_Dummy + 128;


SA_AutoScroll

Tag start for OpenScreenTagList() boolean equivalent to flag AUTOSCROLL

Declaration

Source position: intuition.pas line 1452

const SA_AutoScroll = SA_Dummy + 25;

Description

Setting this flag will enable autoscroll for this screen when it is the active screen. (Currently, the screen may only be made active by activating a window in that screen either under user or application control.) Data is a boolean value (True to set flag). This tag is equivalent to the AUTOSCROLL flag of the TNewScreen.SType field.

Autoscroll means that screens larger than the visible display will automatically scroll when the user moves the mouse to the edge of the screen. Without this tag, the user moves the screen either by using the screen drag bar, or by pressing the mouse select button anywhere within the screen while holding down the left Amiga key and moving the mouse.


SA_BackChild

Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the back of its family.

Declaration

Source position: intuition.pas line 1475

const SA_BackChild = SA_Dummy + 38;


SA_BackFill

Tag start for OpenScreenTagList() provides a "backfill hook" for your screen's TLayer_Info. See Layers.InstallLayerInfoHook()

Declaration

Source position: intuition.pas line 1467

const SA_BackFill = SA_Dummy + 33;


SA_Behind

Tag start for OpenScreenTagList() boolean equivalent to flag SCREENBEHIND_f

Declaration

Source position: intuition.pas line 1450

const SA_Behind = SA_Dummy + 23;

Description

Open this screen behind all other screens in the system. Data is a boolean value (True to set flag). This tag is equivalent to the SCREENBEHIND_f flag of the NewScreen.Type field.


SA_BitMap

Tag start for OpenScreenTagList() ti_Data is pointer to custom BitMap. This implies TNewScreen.SType of CUSTOMBITMAP_f

Declaration

Source position: intuition.pas line 1438

const SA_BitMap = SA_Dummy + 14;

Description

Use a custom bitmap for this screen. Data is a AGraphics.PBitMap. This tag is equivalent to TNewScreen.CustomBitMap and implies the CUSTOMBITMAP_f flag of the NewScreen.Type field. The application is responsible for allocating and freeing the screen's bitmap.


SA_BlockPen

Tag start for OpenScreenTagList() serves as default for windows, too

Declaration

Source position: intuition.pas line 1431

const SA_BlockPen = SA_Dummy + 7;

Description

Block pen for the screen. Data is a long, unsigned value. Used for rendering block fills in the screen title bar and menus. Use SA_Pens for more control of pen specification. If SA_Pens is not specified, the screen will not get the new 3D look and this value will be used as the block pen.


SA_BottomLeftScreen

Declaration

Source position: intuition.pas line 1494

const SA_BottomLeftScreen = SA_Dummy + 118;


SA_BottomMiddleScreen

Declaration

Source position: intuition.pas line 1495

const SA_BottomMiddleScreen = SA_Dummy + 119;


SA_BottomRightScreen

Declaration

Source position: intuition.pas line 1496

const SA_BottomRightScreen = SA_Dummy + 120;


SA_ColorMapEntries

Tag start for OpenScreenTagList() Allows you to override the number of entries in the ColorMap for your screen.

Declaration

Source position: intuition.pas line 1455

const SA_ColorMapEntries = SA_Dummy + 28;

Description

Intuition normally allocates ((1 shl depth) or 32), whichever is more, but you may require even more if you use certain graphics.library features (eg. palette-banking).


SA_Colors

Tag start for OpenScreenTagList() ti_Data is an array of TColorSpec, terminated by ColorIndex = -1. Specifies initial screen palette colors.

Declaration

Source position: intuition.pas line 1433

const SA_Colors = SA_Dummy + 9;

Description

Specifies initial screen palette colors. Data is a pointer to an array of TColorSpec structures, terminated by a ColorSpec structure with ColorIndex=-1. Screen colors may be changed after the screen is opened with the graphics library functions SetRGB4() and LoadRGB4(). ColorSpec colors are right-justified, four bits per gun.


SA_Colors32

Tag start for OpenScreenTagList() set the screen's initial palette colors at 32 bits-per-gun.

Declaration

Source position: intuition.pas line 1469

const SA_Colors32 = SA_Dummy + 35;

Description

ti_Data is a pointer to a table to be passed to the LoadRGB32() function. This format supports both runs of color registers and sparse registers. See the autodoc for that function for full details. Any color set here has precedence over the same register set by SA_Colors.


SA_CompositingLayers

Declaration

Source position: intuition.pas line 1529

const SA_CompositingLayers = SA_Dummy + 139;


SA_DClip

Tag start for OpenScreenTagList() ti_Data points to a rectangle which defines screen display clip region

Declaration

Source position: intuition.pas line 1443

const SA_DClip = SA_Dummy + 19;

Description

Custom display clip specification. Data is a pointer to a Rectangle structure that defines the screen display clip region.


SA_Depth

Tag start for OpenScreenTagList() Screen bitmap depth

Declaration

Source position: intuition.pas line 1429

const SA_Depth = SA_Dummy + 5;

Description

Screen bitmap depth. Data is a LongWord. The depth of the screen determines the number of available colors. Do not set the depth to a value greater than that supported by the specific display mode. This information is available to the application through the graphics library display database. The default is one bitplane.


SA_DetailPen

Tag start for OpenScreenTagList() serves as default for windows, too

Declaration

Source position: intuition.pas line 1430

const SA_DetailPen = SA_Dummy + 6;

Description

Detail pen for the screen. Data is a long, unsigned value. Used for rendering details in the screen title bar and menus. Use SA_Pens for more control of pen specification. If SA_Pens is not specified, the screen will not get the new 3D look of Intuition. Instead this value will be used as the detail pen.


SA_Displayed

Declaration

Source position: intuition.pas line 1483

const SA_Displayed = SA_Dummy + 101;


SA_DisplayHeight

Declaration

Source position: intuition.pas line 1515

const SA_DisplayHeight = SA_Dummy + 130;


SA_DisplayID

Tag start for OpenScreenTagList() ti_Data is new extended display ID

Declaration

Source position: intuition.pas line 1442

const SA_DisplayID = SA_Dummy + 18;


SA_DisplayWidth

Declaration

Source position: intuition.pas line 1514

const SA_DisplayWidth = SA_Dummy + 129;


SA_Draggable

Tag start for OpenScreenTagList() Boolean tag allowing non-draggable screens. Do not use without good reason! (Defaults to True).

Declaration

Source position: intuition.pas line 1459

const SA_Draggable = SA_Dummy + 30;


SA_Dummy

Tag start for OpenScreenTagList() Tags

Declaration

Source position: intuition.pas line 1423

const SA_Dummy = TAG_USER + 32;


SA_ErrorCode

Tag start for OpenScreenTagList() ti_Data points to LongInt error code

Declaration

Source position: intuition.pas line 1434

const SA_ErrorCode = SA_Dummy + 10;

Description

Extended error code. Data is a pointer to a LongInt which will contain the error code on return if OpenScreenTagList() returns nil. The error codes are described above.


SA_ExactMatchMonitorName

Declaration

Source position: intuition.pas line 1528

const SA_ExactMatchMonitorName = SA_Dummy + 138;


SA_Exclusive

Tag start for OpenScreenTagList() Boolean tag allowing screens that won't share the display. (Defaults to False)

Declaration

Source position: intuition.pas line 1460

const SA_Exclusive = SA_Dummy + 31;

Description

Use sparingly! Attached screens may be SA_Exclusive. Setting SA_Exclusive for each screen will produce an exclusive family.


SA_Font

Tag start for OpenScreenTagList() equiv. to TNewScreen.Font

Declaration

Source position: intuition.pas line 1435

const SA_Font = SA_Dummy + 11;

Description

Data is a pointer to a AGraphics.TTextAttr structure which specifies the font, size and style to use for the screen. Equivalent to TNewScreen.Font.


SA_FrontChild

Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the front of its family.

Declaration

Source position: intuition.pas line 1474

const SA_FrontChild = SA_Dummy + 37;


SA_FullPalette

Tag start for OpenScreenTagList() boolean: initialize color table to entire preferences palette, rather than compatible pens 0-3, 17-19, with remaining palette as returned by GetColorMap()

Declaration

Source position: intuition.pas line 1454

const SA_FullPalette = SA_Dummy + 27;


SA_GammaBlue

Declaration

Source position: intuition.pas line 1506

const SA_GammaBlue = SA_Dummy + 125;


SA_GammaControl

Declaration

Source position: intuition.pas line 1503

const SA_GammaControl = SA_Dummy + 123;


SA_GammaGreen

Declaration

Source position: intuition.pas line 1507

const SA_GammaGreen = SA_Dummy + 126;


SA_GammaRed

Declaration

Source position: intuition.pas line 1505

const SA_GammaRed = SA_Dummy + 124;


SA_Height

Tag start for OpenScreenTagList() eqivalent to TNewWindow.Height

Declaration

Source position: intuition.pas line 1428

const SA_Height = SA_Dummy + 4;

Description

Screen dimensions. Data is a LongWord. These may be larger, smaller or the same as the dimensions of the display clip Rectangle. The use of STDSCREENWIDTH will make the screen size equal to the display clip size.

To calculate the width of the display clip Rectangle, subtract the MinX value from the MaxX value plus one. Similarly, the height of the display clip may be calculated by subtracting the MinY value from the MaxY value plus one.


SA_Interleaved

Tag start for OpenScreenTagList() Boolean tag requesting that the bitmap allocated for you be interleaved. (Defaults to False).

Declaration

Source position: intuition.pas line 1468

const SA_Interleaved = SA_Dummy + 34;


SA_Left

Tag start for OpenScreenTagList() eqivalent to TNewWindow.LeftEdge

Declaration

Source position: intuition.pas line 1425

const SA_Left = SA_Dummy + 1;

Description

Initial screen position (left edge). Data is a LongInt, signed value. Offsets are relative to the text overscan rectangle.

If SA_Left is not specified and a TNewWindow structure is not passed in the OpenScreenTagList() call and SA_Width is not specified or is specified as STDSCREENWIDTH, then the left edge of the screen will default to the left edge of the actual display clip of the screen. If the other conditions are met but some explicit SA_Width is specified, then the left edge defaults to zero (text overscan rectangle left edge). Likewise, the top edge may, independent of the left edge value, default to zero or to the top edge of the actual display clip.

When opening a full sized overscan screen, SA_Left should be set to the MinX value of the display clip Rectangle used for the screen and This may be taken from the defaults, as explained above, or explicitly set by the application.

If your screen is larger than your display clip, you may wish to set the SA_Left to a value less than your display clip MinX in order to center a large screen on a smaller display.


SA_LikeWorkbench

Tag start for OpenScreenTagList() 1 = request a screen which is just like the Workbench. This gives you the same screen mode, depth, size, colors, etc., as the Workbench screen.

Declaration

Source position: intuition.pas line 1476

const SA_LikeWorkbench = SA_Dummy + 39;


SA_MiddleLeftScreen

Declaration

Source position: intuition.pas line 1492

const SA_MiddleLeftScreen = SA_Dummy + 115;


SA_MiddleRightScreen

Declaration

Source position: intuition.pas line 1493

const SA_MiddleRightScreen = SA_Dummy + 117;


SA_MinimizeISG

Tag start for OpenScreenTagList() inter-screen gap is at least three non-interlaced lines

Declaration

Source position: intuition.pas line 1479

const SA_MinimizeISG = SA_Dummy + 41;

Description

For compatibility, Intuition always ensures that the inter-screen gap is at least three non-interlaced lines. If your application would look best with the smallest possible inter-screen gap, set ti_Data to True. If you use the VideoControl() VC_NoColorPaletteLoad tag for your screen's ViewPort, you should also set this tag.


SA_MonitorName

Declaration

Source position: intuition.pas line 1484

const SA_MonitorName = SA_Dummy + 102;


SA_MonitorObject

Declaration

Source position: intuition.pas line 1487

const SA_MonitorObject = SA_Dummy + 103;


SA_OpacitySupport

Declaration

Source position: intuition.pas line 1517

const SA_OpacitySupport = SA_Dummy + 131;


SA_Overscan

Tag start for OpenScreenTagList() Set Overscan defaults to OSCAN_TEXT

Declaration

Source position: intuition.pas line 1444

const SA_Overscan = SA_Dummy + 20;

Description

Set to one of the OSCAN_* specifiers to get a system standard verscan region for your display clip, screen dimensions (unless otherwise specified), and automatically centered position (partial support only so far). If you use this, you shouldn't specify SA_DClip. SA_Overscan is for "standard" overscan dimensions, SA_DClip is for your custom numeric specifications.


SA_Parent

Tag start for OpenScreenTagList() Pointer to a "parent" screen to attach this one to. Attached screens slide and depth-arrange together.

Declaration

Source position: intuition.pas line 1458

const SA_Parent = SA_Dummy + 29;


SA_Pens

Tag start for OpenScreenTagList() pointer to $FFFFFFFF terminated LongWord array, as found in TDrawInfo

Declaration

Source position: intuition.pas line 1453

const SA_Pens = SA_Dummy + 26;

Description

Pen specification for the screen. Data is a pointer to a LongWord array terminated with $FFFFFFFF, as found in the DrawInfo structure. Specifying the SA_Pens tag informs the system that the application is prepared to handle a screen rendered with the new 3D look of Intuition. Omitting this tag produces a screen with a flat look, but whose color usage is more backwards compatible.


SA_PixelFormat

Declaration

Source position: intuition.pas line 1520

const SA_PixelFormat = SA_Dummy + 133;


SA_PubName

Tag start for OpenScreenTagList() Presence of this tag means that the screen is to be a public screen. Please specify before SA_PubSig and SA_PubTask

Declaration

Source position: intuition.pas line 1439

const SA_PubName = SA_Dummy + 15;

Description

Presence of this tag means that the screen is to be a public screen. Data is a PChar. The string is the name of the public screen which is used by other applications to find the screen. This tag is order dependent, specify before SA_PubSig and SA_PubTask.


SA_PubSig

Tag start for OpenScreenTagList()

Declaration

Source position: intuition.pas line 1440

const SA_PubSig = SA_Dummy + 16;

Description

Signal for notification that the last window has closed on a public screen. Data is a LongWord. This tag is order dependent, and must be specified after the tag SA_PubName.


SA_PubTask

Tag start for OpenScreenTagList() Task ID and signal for being notified that the last window has closed on a public screen.

Declaration

Source position: intuition.pas line 1441

const SA_PubTask = SA_Dummy + 17;

Description

Task (returned by FindTask()) notification that the last window has closed on a public screen. Data is a long, unsigned value. Data is a pointer to a exec.TTask structure. This tag is order dependent, and must be specified after the tag SA_PubName.


SA_Quiet

Tag start for OpenScreenTagList() boolean equivalent to flag SCREENQUIET_f

Declaration

Source position: intuition.pas line 1451

const SA_Quiet = SA_Dummy + 24;

Description

Disable Intuition rendering into screen. Data is a boolean value (True to set flag). This tag is equivalent to the SCREENQUIET_f flag of the TNewScreen.SType field. The screen will have no visible title bar or gadgets, but dragging and depth arrangement still function. In order to completely prevent Intuition from rendering into the screen, menu operations must be disabled for each window in the screen using WFLG_RMBTRAP.


SA_Reserved

Tag start for OpenScreenTagList() Reserved for private Intuition use

Declaration

Source position: intuition.pas line 1477

const SA_Reserved = SA_Dummy + 40;


SA_ScreenbarSignal

Declaration

Source position: intuition.pas line 1526

const SA_ScreenbarSignal = SA_Dummy + 137;


SA_ScreenbarTextFont

Declaration

Source position: intuition.pas line 1525

const SA_ScreenbarTextFont = SA_Dummy + 136;


SA_ScreenbarTextPen

Declaration

Source position: intuition.pas line 1524

const SA_ScreenbarTextPen = SA_Dummy + 135;


SA_ScreenbarTextYPos

Declaration

Source position: intuition.pas line 1522

const SA_ScreenbarTextYPos = SA_Dummy + 134;


SA_SharePens

Tag start for OpenScreenTagList() Allocate pens as shared

Declaration

Source position: intuition.pas line 1463

const SA_SharePens = SA_Dummy + 32;

Description

For those pens in the screen's DrawInfo^.dri_Pens, Intuition obtains them in shared mode (see ObtainPen()). For compatibility, Intuition obtains the other pens of a public screen as PEN_EXCLUSIVE. Screens that wish to manage the pens themselves should generally set this tag to True. This instructs Intuition to leave the other pens unallocated.


SA_ShowPointer

Declaration

Source position: intuition.pas line 1501

const SA_ShowPointer = SA_Dummy + 122;


SA_ShowTitle

Tag start for OpenScreenTagList() boolean equivalent to flag SHOWTITLE

Declaration

Source position: intuition.pas line 1449

const SA_ShowTitle = SA_Dummy + 22;

Description

Setting this flag places the screen's title bar in front of any backdrop windows that are opened on the screen. Data is a boolean value (True to set flag). This tag is equivalent to the SHOWTITLE flag of the TNewScreen.SType field. The title bar of the screen is always displayed behind any non-backdrop windows on that screen. This attribute can be changed after the screen is open with the ShowTitle() function.


SA_SourceAlphaSupport

Declaration

Source position: intuition.pas line 1518

const SA_SourceAlphaSupport = SA_Dummy + 132;


SA_StopBlanker

Declaration

Source position: intuition.pas line 1498

const SA_StopBlanker = SA_Dummy + 121;


SA_SysFont

Tag start for OpenScreenTagList() Selects one of the preferences system fonts: 0 - old DefaultFont, fixed-width 1 - WB Screen preferred font

Declaration

Source position: intuition.pas line 1436

const SA_SysFont = SA_Dummy + 12;

Description

Alternative to SA_Font. Selects one of the preferences system fonts. Data is a LongWord, with the following values defined:

0
Open screen with the user's preferred fixed width font (the default).
1
Open screen with the user's preferred font, which may be proportional.

The Workbench screen is opened with [SA_SysFont, 1]. Table summarizes how the font selected at OpenScreen() time effects subsequent text operations in screens and windows.

 | What you tell OpenScreen() | Screen font | Window.RPort font
A. | TNewScreen.Font = myfont | myfont | myfont
B. | TNewScreen.Font = nil | AGraphics.TGfxBase.DefaultFont | AGraphics.TGfxBase.DefaultFont
C. | [SA_Font, myfont] | myfont | myfont
D. | [SA_SysFont, 0] | AGraphics.TGfxBase.DefaultFont | AGraphics.TGfxBase.DefaultFont
E. | [SA_SysFont, 1] | Font Prefs Screen text | AGraphics.TGfxBase.DefaultFont

Notes:

  • A and B are the options that existed in V34 and earlier OS versions.
  • C and D are tags in Release 2 equivalent to A and B respectively.
  • E is a new option for V36. The Workbench screen uses this option.
  • For `myfont', any font may be used including a proportional one. This is true under all releases of the OS.
  • AGraphics.TGfxBase.DefaultFont is always monospace. (This is the "System Default Text" from Font Preferences.)
  • Font Prefs Screen text (the "Screen Text" choice from Font Preferences) can be monospace or proportional.

The screen's font may not legally be changed after a screen is opened. The menu bar, window titles, menu items, and the contents of a string gadget all use the screen's font. The font used for menu items can be overridden in the menu item's IntuiText structure. Under V36 and higher, the font used in a string gadget can be overridden through the StringExtend structure. The font of the menu bar and window titles cannot be overridden.

The Window.RPort font shown above is the initial font that Intuition sets in your window's RastPort. It is legal to change that subsequently with SetFont(). IntuiText rendered into a window (either through PrintIText() or as a TGadget.GadgetText) defaults to the window's RastPort font, but can be overridden using its TGadget.TITextFont field. Text rendered with the graphics library call GfxText() uses the window's RastPort font.


SA_Title

Tag start for OpenScreenTagList() default screen title

Declaration

Source position: intuition.pas line 1432

const SA_Title = SA_Dummy + 8;

Description

Default screen title. Data is a pointer to a character string. This is the title displayed when the active window has no screen title or when no window is active on the screen.


SA_Top

Tag start for OpenScreenTagList() eqivalent to TNewWindow.TopEdge

Declaration

Source position: intuition.pas line 1426

const SA_Top = SA_Dummy + 2;

Description

Initial screen position (top edge). Data is a LongInt, signed value. Offsets are relative to the text overscan rectangle.

If SA_Top is not specified and a TNewWindow structure is not passed in the OpenScreenTagList() call and SA_Width is not specified or specified as STDSCREENHEIGHT, then the top edge of the screen will default to the top edge of the actual display clip of the screen. If the other conditions are met but some explicit SA_Height is specified, then the top edge defaults to zero (text overscan rectangle top edge).

When opening a full sized overscan screen, SA_Top should be set to the MinY value of the display clip. This may be taken from the defaults, as explained above, or explicitly set by the application.

If your screen is larger than your display clip, you may wish to set the SA_Top to a value less than your display clip MinY in order to center a large screen on a smaller display.


SA_TopLeftScreen

Declaration

Source position: intuition.pas line 1489

const SA_TopLeftScreen = SA_Dummy + 112;


SA_TopMiddleScreen

Declaration

Source position: intuition.pas line 1490

const SA_TopMiddleScreen = SA_Dummy + 113;


SA_TopRightScreen

Declaration

Source position: intuition.pas line 1491

const SA_TopRightScreen = SA_Dummy + 114;


SA_Type

Tag start for OpenScreenTagList() equiv. to TNewScreen.SType

Declaration

Source position: intuition.pas line 1437

const SA_Type = SA_Dummy + 13;

Description

Equivalent to the SCREENTYPE_f bits of the TNewScreen.SType field. Data is a LongWord, which may be set to either CUSTOMSCREEN_f or PUBLICSCREEN_f (WBENCHSCREEN_f is reserved for system use). See the tags SA_BitMap, SA_Behind, SA_Quiet, SA_ShowTitle and SA_AutoScroll for the other attributes of the TNewScreen.SType field.


SA_VideoControl

Tag start for OpenScreenTagList() Pointer to a taglist that Intuition will pass to VideoControl(), upon opening the screen.

Declaration

Source position: intuition.pas line 1473

const SA_VideoControl = SA_Dummy + 36;


SA_Width

Tag start for OpenScreenTagList() eqivalent to TNewWindow.Width

Declaration

Source position: intuition.pas line 1427

const SA_Width = SA_Dummy + 3;

Description

Screen dimensions. Data is a LongWord. These may be larger, smaller or the same as the dimensions of the display clip Rectangle. The use of STDSCREENWIDTH will make the screen size equal to the display clip size.

To calculate the width of the display clip Rectangle, subtract the MinX value from the MaxX value plus one. Similarly, the height of the display clip may be calculated by subtracting the MinY value from the MaxY value plus one.


SAOS_OpacitySupport_CPU

Declaration

Source position: intuition.pas line 1653

const SAOS_OpacitySupport_CPU = 2;


SAOS_OpacitySupport_HW

Declaration

Source position: intuition.pas line 1654

const SAOS_OpacitySupport_HW = 3;


SAOS_OpacitySupport_None

Declaration

Source position: intuition.pas line 1651

const SAOS_OpacitySupport_None = 0;


SAOS_OpacitySupport_OnOff

Declaration

Source position: intuition.pas line 1652

const SAOS_OpacitySupport_OnOff = 1;


SASA_SourceAlphaSupport_CPU

Declaration

Source position: intuition.pas line 1657

const SASA_SourceAlphaSupport_CPU = 1;


SASA_SourceAlphaSupport_HW

Declaration

Source position: intuition.pas line 1658

const SASA_SourceAlphaSupport_HW = 2;


SASA_SourceAlphaSupport_None

Declaration

Source position: intuition.pas line 1656

const SASA_SourceAlphaSupport_None = 0;


SB_COPY_BITMAP

Flag for AllocScreenBuffer().

Declaration

Source position: intuition.pas line 1648

const SB_COPY_BITMAP = 2;


SB_SCREEN_BITMAP

Flag for AllocScreenBuffer().

Declaration

Source position: intuition.pas line 1647

const SB_SCREEN_BITMAP = 1;


SBCT_Dummy

Declaration

Source position: intuition.pas line 3445

const SBCT_Dummy = TAG_USER + $60500;


SBCT_InstallPlugin

Declaration

Source position: intuition.pas line 3446

const SBCT_InstallPlugin = SBCT_Dummy + 1;


SBCT_UninstallPlugin

Declaration

Source position: intuition.pas line 3447

const SBCT_UninstallPlugin = SBCT_Dummy + 2;


SBUF_512

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 1834

const SBUF_512 = $00;


SBUF_1024

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 1835

const SBUF_1024 = $01;


SBUF_2048

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 1836

const SBUF_2048 = $02;


SBUF_4096

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 1837

const SBUF_4096 = $03;


SBUF_8000

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 1838

const SBUF_8000 = $04;


SBUF_16000

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 1839

const SBUF_16000 = $05;


SBUFSIZE_BITS

Mask for TPreferences.SerStopBuf lower nibble

Declaration

Source position: intuition.pas line 1845

const SBUFSIZE_BITS = $0F;


SCREEN_DRAG

Declaration

Source position: intuition.pas line 1766

const SCREEN_DRAG = 1 shl 14;


SCREENBEHIND_f

Flag for TScreen.Flags. If you want your screen to open behind already open screens

Declaration

Source position: intuition.pas line 1411

const SCREENBEHIND_f = 1 shl 7;


SCREENHIRES

Flag for TScreen.Flags. Do no use lowres gadgets (private)

Declaration

Source position: intuition.pas line 1413

const SCREENHIRES = 1 shl 9;


SCREENQUIET_f

Flag for TScreen.Flags. If you do not want Intuition to render into your screen (gadgets, title)

Declaration

Source position: intuition.pas line 1412

const SCREENQUIET_f = 1 shl 8;


SCREENTYPE_f

Screentype flag for TScreen.Flags and TNewScreen.SType. All Screenstypes available

Declaration

Source position: intuition.pas line 1406

const SCREENTYPE_f = $000F;


SDEPTH_TOBACK

Flag for ScreenDepth(). Send screen to back

Declaration

Source position: intuition.pas line 1628

const SDEPTH_TOBACK = 1;


SDEPTH_TOFRONT

Flag for ScreenDepth(). Bring screen to front

Declaration

Source position: intuition.pas line 1627

const SDEPTH_TOFRONT = 0;


SDEPTHIMAGE

SYSIA_Which tag data values. Screen depth gadget image

Declaration

Source position: intuition.pas line 2489

const SDEPTHIMAGE = $05;


SDOWNBACKGADGET

Declaration

Source position: intuition.pas line 1338

const SDOWNBACKGADGET = 6;


SDRAGGADGET

Declaration

Source position: intuition.pas line 1339

const SDRAGGADGET = 7;


SELECTDOWN

RawMouse code for TIntuiMessage.Code. Left Mouse Button down.

Declaration

Source position: intuition.pas line 1294

const SELECTDOWN = IECODE_LBUTTON;


SELECTUP

RawMouse code for TIntuiMessage.Code. Left Mouse Button up.

Declaration

Source position: intuition.pas line 1293

const SELECTUP = IECODE_LBUTTON or IECODE_UP_PREFIX;


SERIAL_PRINTER

Value for TPreferences.PrinterPort

Declaration

Source position: intuition.pas line 1770

const SERIAL_PRINTER = $01;


SG_DEFAULTMAXCHARS

Maximal length of text in StrgClass, if STRINGA_MaxChars is not set.

Declaration

Source position: intuition.pas line 2220

const SG_DEFAULTMAXCHARS = 128;


SGA_BEEP

String Gadget Action Flag in TSGWork.Actions flash the screen for the user

Declaration

Source position: intuition.pas line 2783

const SGA_BEEP = $4;


SGA_END

String Gadget Action Flag in TSGWork.Actions terminate gadget, code in Code field

Declaration

Source position: intuition.pas line 2782

const SGA_END = $2;


SGA_NEXTACTIVE

String Gadget Action Flag in TSGWork.Actions Make next possible gadget active.

Declaration

Source position: intuition.pas line 2786

const SGA_NEXTACTIVE = $20;


SGA_PREVACTIVE

String Gadget Action Flag in TSGWork.Actions Make previous possible gadget active.

Declaration

Source position: intuition.pas line 2787

const SGA_PREVACTIVE = $40;


SGA_REDISPLAY

String Gadget Action Flag in TSGWork.Actions gadget visuals changed

Declaration

Source position: intuition.pas line 2785

const SGA_REDISPLAY = $10;


SGA_REUSE

String Gadget Action Flag in TSGWork.Actions reuse input event

Declaration

Source position: intuition.pas line 2784

const SGA_REUSE = $8;


SGA_USE

String Gadget Action Flag in TSGWork.Actions use contents of TSGWork

Declaration

Source position: intuition.pas line 2781

const SGA_USE = $1;


SGH_CLICK

Function id for only existing custom string gadget edit hook. process mouse click cursor position

Declaration

Source position: intuition.pas line 2790

const SGH_CLICK = 2;

Description

This hook command is called when Intuition wants to position the cursor in response to a mouse click in the string gadget. Again, here are no parameters following the command LongWord. This time, Intuition has already calculated the mouse position character cell and put it in TSGWork.BufferPos. The previous BufferPos value remains in the TSGWork.StringInfo.BufferPos.

Intuition will again use the TSGWork fields listed above for SGH_KEY. One restriction is that you are not allowed to set SGA_END or SGA_REUSE for this command. Intuition will not stand for a gadget which goes inactive when you click in it.

You should always leave the SGA_REDISPLAY flag set, since Intuition uses this processing when activating a string gadget.


SGH_KEY

Function id for only existing custom string gadget edit hook. process editing keystroke

Declaration

Source position: intuition.pas line 2789

const SGH_KEY = 1;

Description

There are no parameters following the command LongWord. Intuition will put its idea of proper values in the TSGWork before calling you, and if you leave SGA_USE set in the TSGWork.Actions field, Intuition will use the values found in TSGWork fields WorkBuffer, NumChars, BufferPos, and LongInt_, copying the WorkBuffer back to the StringInfo Buffer.

Note: You may not change other TSGWork fields. If you clear SGA_USE, the string gadget will be unchanged.

If you set SGA_END, Intuition will terminate the activation of the string gadget. If you also set SGA_REUSE, Intuition will reuse the input event after it deactivates your gadget. In this case, Intuition will put the value found in TSGWork.Code into the TIntuiMessage.Code field of the IDCMP_GADGETUP message it sends to the application.

If you set SGA_BEEP, Intuition will call DisplayBeep() use this if the user has typed in error, or buffer is full.

Set SGA_REDISPLAY if the changes to the gadget warrant a gadget redisplay. Note: cursor movement requires a redisplay. You may set SGA_PREVACTIVE or SGA_NEXTACTIVE when you set SGA_END. This tells Intuition that you want the next or previous gadget with GFLG_TABCYCLE to be activated.


SGM_CONTROL

Internal Mode for TSGWork.Mode control char escape mode

Declaration

Source position: intuition.pas line 2778

const SGM_CONTROL = 1 shl 5;


SGM_EXITHELP

Mode for TSGWork.Mode exit with code = $5F if help hit

Declaration

Source position: intuition.pas line 2774

const SGM_EXITHELP = 1 shl 7;


SGM_FIXEDFIELD

Mode for TSGWork.Mode fixed length buffer always set SGM_REPLACE, too

Declaration

Source position: intuition.pas line 2772

const SGM_FIXEDFIELD = 1 shl 1;


SGM_LONGINT

Internal Mode for TSGWork.Mode an intuition LongInt gadget

Declaration

Source position: intuition.pas line 2779

const SGM_LONGINT = 1 shl 6;


SGM_NOCHANGE

Internal Mode for TSGWork.Mode no edit changes yet

Declaration

Source position: intuition.pas line 2776

const SGM_NOCHANGE = 1 shl 3;


SGM_NOFILTER

Mode for TSGWork.Mode don't filter control chars

Declaration

Source position: intuition.pas line 2773

const SGM_NOFILTER = 1 shl 2;


SGM_NOWORKB

Internal Mode for TSGWork.Mode Buffer = PrevBuffer

Declaration

Source position: intuition.pas line 2777

const SGM_NOWORKB = 1 shl 4;


SGM_REPLACE

Mode for TSGWork.Mode replace mode please initialize StringInfo with in-range value of BufferPos if you are using SGM_REPLACE mode.

Declaration

Source position: intuition.pas line 2771

const SGM_REPLACE = 1 shl 0;


SHADE_BW

Value for TPreferences.PrintShade

Declaration

Source position: intuition.pas line 1800

const SHADE_BW = $00;


SHADE_COLOR

Value for TPreferences.PrintShade

Declaration

Source position: intuition.pas line 1802

const SHADE_COLOR = $02;


SHADE_GREYSCALE

Value for TPreferences.PrintShade

Declaration

Source position: intuition.pas line 1801

const SHADE_GREYSCALE = $01;


SHADOWPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. dark edge on 3D objects

Declaration

Source position: intuition.pas line 1382

const SHADOWPEN = 4;


SHANGHAI

Pub Screen mode. put workbench windows on pub screen

Declaration

Source position: intuition.pas line 1623

const SHANGHAI = $0001;


SHINEPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. bright edge on 3D objects

Declaration

Source position: intuition.pas line 1381

const SHINEPEN = 3;


SHSHAKE_BITS

Mask for TPreferences.SerParShk Lower nibble

Declaration

Source position: intuition.pas line 1848

const SHSHAKE_BITS = $0F;


SHSHAKE_NONE

Serial Handshake Mode TPreferences.SerParShk (lower nibble)

Declaration

Source position: intuition.pas line 1858

const SHSHAKE_NONE = 2;


SHSHAKE_RTS

Serial Handshake Mode TPreferences.SerParShk (lower nibble)

Declaration

Source position: intuition.pas line 1857

const SHSHAKE_RTS = 1;


SHSHAKE_XON

Serial Handshake Mode TPreferences.SerParShk (lower nibble

Declaration

Source position: intuition.pas line 1856

const SHSHAKE_XON = 0;


SI_BorderBottom

Declaration

Source position: intuition.pas line 3051

const SI_BorderBottom = SI_Dummy + 6;


SI_BorderBottomSize

Declaration

Source position: intuition.pas line 3052

const SI_BorderBottomSize = SI_Dummy + 7;


SI_BorderLeft

Declaration

Source position: intuition.pas line 3048

const SI_BorderLeft = SI_Dummy + 3;


SI_BorderRight

Declaration

Source position: intuition.pas line 3049

const SI_BorderRight = SI_Dummy + 4;


SI_BorderRightSize

Declaration

Source position: intuition.pas line 3050

const SI_BorderRightSize = SI_Dummy + 5;


SI_BorderTop

Declaration

Source position: intuition.pas line 3046

const SI_BorderTop = SI_Dummy + 1;


SI_BorderTopTitle

Declaration

Source position: intuition.pas line 3047

const SI_BorderTopTitle = SI_Dummy + 2;


SI_BottomArrowBox

Declaration

Source position: intuition.pas line 3061

const SI_BottomArrowBox = SI_Dummy + 13;


SI_BottomPropHeight

Declaration

Source position: intuition.pas line 3059

const SI_BottomPropHeight = SI_Dummy + 11;


SI_Dummy

Declaration

Source position: intuition.pas line 3044

const SI_Dummy = $8000000;


SI_RightArrowBox

Declaration

Source position: intuition.pas line 3060

const SI_RightArrowBox = SI_Dummy + 12;


SI_RightPropWidth

Declaration

Source position: intuition.pas line 3058

const SI_RightPropWidth = SI_Dummy + 10;


SI_ScreenTitlebarHeight

Declaration

Source position: intuition.pas line 3053

const SI_ScreenTitlebarHeight = SI_Dummy + 8;


SI_Shadows

Declaration

Source position: intuition.pas line 3063

const SI_Shadows = SI_Dummy + 14;


SIMPLEREQ

Flag for TRequester.Flags. If set, a SIMPLEREFRESH layer is used.

Declaration

Source position: intuition.pas line 462

const SIMPLEREQ = $0010;


Single_PT

Declaration

Source position: intuition.pas line 1782

const Single_PT = $80;


SIX_LPI

Value for TPreferences.PrintSpacing

Declaration

Source position: intuition.pas line 1791

const SIX_LPI = $000;


SIZEGADGET

Declaration

Source position: intuition.pas line 1334

const SIZEGADGET = 2;


SIZEIMAGE

SYSIA_Which tag data values. Window sizing gadget image

Declaration

Source position: intuition.pas line 2487

const SIZEIMAGE = $02;


SNAPSHOTIMAGE

Declaration

Source position: intuition.pas line 3013

const SNAPSHOTIMAGE = $16;


SPARITY_BITS

Mask for TPreferences.SerParShk upper nibble

Declaration

Source position: intuition.pas line 1847

const SPARITY_BITS = $F0;


SPARITY_EVEN

Serial Parity TPreferences.SerParShk (upper nibble)

Declaration

Source position: intuition.pas line 1851

const SPARITY_EVEN = 1;


SPARITY_MARK

Declaration

Source position: intuition.pas line 1853

const SPARITY_MARK = 3;


SPARITY_NONE

Serial Parity TPreferences.SerParShk (upper nibble)

Declaration

Source position: intuition.pas line 1850

const SPARITY_NONE = 0;


SPARITY_ODD

Serial Parity TPreferences.SerParShk (upper nibble)

Declaration

Source position: intuition.pas line 1852

const SPARITY_ODD = 2;


SPARITY_SPACE

Declaration

Source position: intuition.pas line 1854

const SPARITY_SPACE = 4;


SPOS_ABSOLUTE

Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the absolute coordinates you wish to move the screen to. Coordinates are expressed as absolutes, not relatives.

Declaration

Source position: intuition.pas line 1631

const SPOS_ABSOLUTE = 1;


SPOS_FORCEDRAG

Flag for ScreenPosition(). Move non-draggable screen, You may additionally set SPOS_FORCEDRAG along with any of the above. Set this if you wish to reposition an [SA_Draggable, False] screen that you opened.

Declaration

Source position: intuition.pas line 1633

const SPOS_FORCEDRAG = 4;


SPOS_MAKEVISIBLE

Flag for ScreenPosition(). Coordinates describe a box on the screen you wish to be made visible by autoscrolling (x1,y1)-(x2,y2) describes a rectangle on the screen which you would like autoscrolled into view.

Declaration

Source position: intuition.pas line 1632

const SPOS_MAKEVISIBLE = 2;


SPOS_RELATIVE

Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the offset in coordinates you wish to move the screen by. Coordinates are relative

Declaration

Source position: intuition.pas line 1630

const SPOS_RELATIVE = 0;


SREAD_BITS

Mask for TPreferences.SerRWBits Upper nibble

Declaration

Source position: intuition.pas line 1841

const SREAD_BITS = $F0;


SSTOP_BITS

Mask for TPreferences.SerStopBuf Upper nibble

Declaration

Source position: intuition.pas line 1844

const SSTOP_BITS = $F0;


STDSCREENHEIGHT

Supply in TNewScreen.Height Set Hight to standard height

Declaration

Source position: intuition.pas line 1418

const STDSCREENHEIGHT = - 1;


STDSCREENWIDTH

Supply in TNewScreen.Width Set Hight to standard width

Declaration

Source position: intuition.pas line 1419

const STDSCREENWIDTH = - 1;


STRGCLASS

Class identifier. A string gadget.

Declaration

Source position: intuition.pas line 1981

const STRGCLASS: PChar = 'strgclass';

Description

SuperClass: gadgetclass

Intuition compatible string gadgets. The Boopsi string gadget can either be a plain string gadget or an integer string gadget. An integer gadget filters out all characters except those that make up integer values.

Changed Methods:

OM_NEW

Attributes:

STRINGA_LongVal (ISGNU)

STRINGA_TextVal (ISGNU)

The remaining strgclass attributes correspond to the flags and fields that the conventional Intuition string gadget uses.

STRINGA_MaxChars (I)

STRINGA_Buffer (I)

STRINGA_UndoBuffer (I)

STRINGA_WorkBuffer (I)

STRINGA_BufferPos (ISU)

STRINGA_DispPos (ISU)

STRINGA_AltKeyMap (IS)

STRINGA_Font (IS)

STRINGA_Pens (IS)

STRINGA_ActivePens (IS)

STRINGA_EditHook (I)

STRINGA_EditModes (IS)

STRINGA_ReplaceMode (IS)

STRINGA_FixedFieldMode (IS)

STRINGA_NoFilterMode (IS)

STRINGA_Justification (IS)

STRINGA_ExitHelp (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


STRINGA_ActivePens

StrgClass Tag. [IS.] (LongInt) Like STRINGA_Pens. These pens are used, if the gadget is active.

Declaration

Source position: intuition.pas line 2208

const STRINGA_ActivePens = STRINGA_Dummy + 10;


STRINGA_AltKeyMap

StrgClass Tag. [IS.] (PKeyMap) KeyMap to use

Declaration

Source position: intuition.pas line 2205

const STRINGA_AltKeyMap = STRINGA_Dummy + 7;


STRINGA_Buffer

StrgClass Tag. [I..] (STRPTR) Buffer for storing the current string of the gadget.

Declaration

Source position: intuition.pas line 2200

const STRINGA_Buffer = STRINGA_Dummy + 2;


STRINGA_BufferPos

StrgClass Tag. [IS.] (SmallInt) Current position of cursor (relative to the beginning of the buffer).

Declaration

Source position: intuition.pas line 2203

const STRINGA_BufferPos = STRINGA_Dummy + 5;


STRINGA_DispPos

StrgClass Tag. [IS.] (SmallInt) FIXME

Declaration

Source position: intuition.pas line 2204

const STRINGA_DispPos = STRINGA_Dummy + 6;


STRINGA_Dummy

StrgClass Start Tag.

Declaration

Source position: intuition.pas line 2198

const STRINGA_Dummy = TAG_USER + $32000;


STRINGA_EditHook

StrgClass Tag. [I..] (PHook) FIXME

Declaration

Source position: intuition.pas line 2209

const STRINGA_EditHook = STRINGA_Dummy + 11;


STRINGA_EditModes

StrgClass Tag. [IS.] (LongWord) FIXME

Declaration

Source position: intuition.pas line 2210

const STRINGA_EditModes = STRINGA_Dummy + 12;


STRINGA_ExitHelp

StrgClass Tag. [IS.] (LongBool) If this is set, pressing the "Help" key, while the gadget is active, will unselect the gadget.

Declaration

Source position: intuition.pas line 2218

const STRINGA_ExitHelp = STRINGA_Dummy + 19;


STRINGA_FixedFieldMode

StrgClass Tag. [IS.] (LongBool) FIXME

Declaration

Source position: intuition.pas line 2213

const STRINGA_FixedFieldMode = STRINGA_Dummy + 14;


STRINGA_Font

StrgClass Tag. [IS.] (PTextFont) Font to use for displaying the string

Declaration

Source position: intuition.pas line 2206

const STRINGA_Font = STRINGA_Dummy + 8;


STRINGA_Justification

StrgClass Tag. [IS.] (Word) Where should the text be justified?

Declaration

Source position: intuition.pas line 2215

const STRINGA_Justification = STRINGA_Dummy + 16;

Description

Use one of GACT_STRINGCENTER, GACT_STRINGLEFT and GACT_STRINGRIGHT


STRINGA_LongVal

StrgClass Tag. [ISG] (LongInt) If this is set, the string gadget will only accept numeric values.

Declaration

Source position: intuition.pas line 2216

const STRINGA_LongVal = STRINGA_Dummy + 17;

Description

Argument is the number, the string gadget is to be set to. When getting this attribute, this number is returned.


STRINGA_MaxChars

StrgClass Tag. [I..] (SmallInt) Maximum number of characters the string gadget accepts. Default SG_DEFAULTMAXCHARS.

Declaration

Source position: intuition.pas line 2199

const STRINGA_MaxChars = STRINGA_Dummy + 1;


STRINGA_NoFilterMode

StrgClass Tag. [IS.] (LongBool) FIXME

Declaration

Source position: intuition.pas line 2214

const STRINGA_NoFilterMode = STRINGA_Dummy + 15;


STRINGA_Pens

StrgClass Tag. [IS.] (LongInt) The lower 16 bits specify the background-pen, the upper 16 bits the foreground-pen. The gadget is rendered, using these pens, if the gadget is inactive

Declaration

Source position: intuition.pas line 2207

const STRINGA_Pens = STRINGA_Dummy + 9;


STRINGA_ReplaceMode

StrgClass Tag. [IS.] (LongBool) If this is True, the current character is overwritten, if the use presses a key. Otherwise, the new character is inserted.

Declaration

Source position: intuition.pas line 2212

const STRINGA_ReplaceMode = STRINGA_Dummy + 13;


STRINGA_TextVal

StrgClass Tag. [ISG] (STRPTR) If this is set, the string gadget will accept strings.

Declaration

Source position: intuition.pas line 2217

const STRINGA_TextVal = STRINGA_Dummy + 18;

Description

Argument is a string that is to be copied into the string gadget and its buffer.


STRINGA_UndoBuffer

StrgClass Tag. [I..] (STRPTR) Buffer for storing the old (undo) string of the gadget.

Declaration

Source position: intuition.pas line 2201

const STRINGA_UndoBuffer = STRINGA_Dummy + 3;


STRINGA_WorkBuffer

StrgClass Tag. [I..] (STRPTR) Buffer for the class to work with.

Declaration

Source position: intuition.pas line 2202

const STRINGA_WorkBuffer = STRINGA_Dummy + 4;


SUBMENUIMAGE

Declaration

Source position: intuition.pas line 3016

const SUBMENUIMAGE = $1A;


SUPFRONTGADGET

Declaration

Source position: intuition.pas line 1337

const SUPFRONTGADGET = 5;


SWRITE_BITS

Mask for TPreferences.SerRWBits Lower nibble

Declaration

Source position: intuition.pas line 1842

const SWRITE_BITS = $0F;


SYSIA_Depth

SysIClass Attribute.

Declaration

Source position: intuition.pas line 2438

const SYSIA_Depth = IA_Dummy + 12;


SYSIA_DrawInfo

SysIClass Attribute. Must be specified

Declaration

Source position: intuition.pas line 2453

const SYSIA_DrawInfo = IA_Dummy + 24;


SYSIA_Pens

Declaration

Source position: intuition.pas line 2475

const SYSIA_Pens = IA_Pens;


SYSIA_ReferenceFont

SysIClass Attribute. Font to use as reference for scaling certain sysiclass images

Declaration

Source position: intuition.pas line 2455

const SYSIA_ReferenceFont = IA_Dummy + 25;


SYSIA_Size

SysIClass Attribute. SYSISIZE_*

Declaration

Source position: intuition.pas line 2437

const SYSIA_Size = IA_Dummy + 11;


SYSIA_Style

Declaration

Source position: intuition.pas line 2470

const SYSIA_Style = IA_BGPen;


SYSIA_Which

SysIClass Attribute. System image identifier

Declaration

Source position: intuition.pas line 2439

const SYSIA_Which = IA_Dummy + 13;

Description

Specifies which system gadget you want an image for. Some numbers correspond to internal Intuition

See also

DEPTHIMAGE | SYSIA_Which tag data values. Window depth gadget image
ZOOMIMAGE | SYSIA_Which tag data values. Window zoom gadget image
SIZEIMAGE | SYSIA_Which tag data values. Window sizing gadget image
CLOSEIMAGE | SYSIA_Which tag data values. Window close gadget image
SDEPTHIMAGE | SYSIA_Which tag data values. Screen depth gadget image
LEFTIMAGE | SYSIA_Which tag data values. Left-arrow gadget image
UPIMAGE | SYSIA_Which tag data values. Up-arrow gadget image
RIGHTIMAGE | SYSIA_Which tag data values. Right-arrow gadget image
DOWNIMAGE | SYSIA_Which tag data values. Down-arrow gadget image
CHECKIMAGE | SYSIA_Which tag data values. GadTools checkbox image
MXIMAGE | SYSIA_Which tag data values. GadTools mutual exclude "button" image
MENUCHECK | SYSIA_Which tag data values. Menu checkmark image
AMIGAKEY | SYSIA_Which tag data values. Menu Amiga-key image


SYSIA_WithBorder

Declaration

Source position: intuition.pas line 2469

const SYSIA_WithBorder = IA_FGPen;


SYSICLASS

Class identifier. The class of system images. The class includes the images for the system and GadTools gadgets.

Declaration

Source position: intuition.pas line 1977

const SYSICLASS: PChar = 'sysiclass';

Description

SuperClass: imageclass

This is a class of system images and standard application images. There are 11 possible sysiclass image glyphs to choose from:

DEPTHIMAGE
Window depth arrangement image.
ZOOMIMAGE
Window Zoom image.
SIZEIMAGE
Window Sizing image.
CLOSEIMAGE
Window close image.
SDEPTHIMAGE
Screen depth arrangement image.
LEFTIMAGE
Left arrow image.
RIGHTIMAGE
Right arrow image.
UPIMAGE
Up arrow image.
DOWNIMAGE
Down arrow image.
CHECKIMAGE
Checkmark image.
MXIMAGE
Radio button image.

The class caches the image's bitmap to improve rendering speed.

Attributes:

SYSIA_DrawInfo (I)

SYSIA_Which (I)

SYSIA_Size (I)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


SYSISIZE_HIRES

Data value for SYSIA_Size

Declaration

Source position: intuition.pas line 2482

const SYSISIZE_HIRES = 2;


SYSISIZE_LOWRES

Data value for SYSIA_Size

Declaration

Source position: intuition.pas line 2481

const SYSISIZE_LOWRES = 1;


SYSISIZE_MEDRES

Data value for SYSIA_Size

Declaration

Source position: intuition.pas line 2480

const SYSISIZE_MEDRES = 0;


SYSISTYLE_GADTOOLS

Declaration

Source position: intuition.pas line 2473

const SYSISTYLE_GADTOOLS = 1;


SYSISTYLE_NORMAL

Declaration

Source position: intuition.pas line 2472

const SYSISTYLE_NORMAL = 0;


SYSREQUEST

Flag for TRequester.Flags. Read-Only. This requester caused by system

Declaration

Source position: intuition.pas line 469

const SYSREQUEST = $4000;


T_Object

Boopsi Object structure

Declaration

Source position: intuition.pas line 2088

type T_Object = record
o_Node: TMinNode; |
o_Class: PIClass; | Class pointer
end;

Description

We have this, the instance data of the root class, PRECEDING the 'object'. This is so that Gadget objects are Gadget pointers, and so on. If this structure grows, it will always have o_Class at the end, so the macro OCLASS(o) will always have the same offset back from the pointer returned from NewObject().


TABLETA_AngleX

Tag for TTabletData.td_TagList. The angle of rotation or tilt about the X-axis.

Declaration

Source position: intuition.pas line 833

const TABLETA_AngleX = TABLETA_Dummy + 3;

Description

The angle of rotation or tilt about the X-axis. This number should be normalized to fill a signed long LongInt. Positive values imply a clockwise rotation about the X-axis when viewing from +X towards the origin.


TABLETA_AngleY

Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Y-axis.

Declaration

Source position: intuition.pas line 834

const TABLETA_AngleY = TABLETA_Dummy + 4;

Description

The angle of rotation or tilt about the Y-axis. This number should be normalized to fill a signed long LongInt. Positive values imply a clockwise rotation about the Y-axis when viewing from +Y towards the origin.


TABLETA_AngleZ

Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Z axis.

Declaration

Source position: intuition.pas line 835

const TABLETA_AngleZ = TABLETA_Dummy + 5;

Description

The angle of rotation or tilt about the Z axis. This number should be normalized to fill a signed long LongInt. Positive values imply a clockwise rotation about the Z-axis when viewing from +Z towards the origin.


TABLETA_ButtonBits

Tag for TTabletData.td_TagList. Button States

Declaration

Source position: intuition.pas line 837

const TABLETA_ButtonBits = TABLETA_Dummy + 7;

Description

ti_Data is a long LongInt whose bits are to be interpreted at the state of the first 32 buttons of the tablet.


TABLETA_Dummy

Tablet Tag Base

Declaration

Source position: intuition.pas line 830

const TABLETA_Dummy = TAG_USER + $3A000;


TABLETA_InProximity

Tag for TTabletData.td_TagList. For tablets that support proximity,

Declaration

Source position: intuition.pas line 838

const TABLETA_InProximity = TABLETA_Dummy + 8;

Description

ti_Data is a boolean. For tablets that support proximity, they should send the (TABLETA_InProximity, False) tag item when the stylus is out of proximity. One possible use we can forsee is a mouse-blanking commodity which keys off this to blank the mouse. When this tag is absent, the stylus is assumed to be in proximity.


TABLETA_Pressure

Tag for TTabletData.td_TagList. The pressure reading of the stylus.

Declaration

Source position: intuition.pas line 836

const TABLETA_Pressure = TABLETA_Dummy + 6;

Description

The pressure reading of the stylus. The pressure should be normalized to fill a signed long LongInt. Typical devices won't generate negative pressure, but the possibility is not precluded. The pressure threshold which is considered to cause a button-click is expected to be set in a Preferences program supplied by the tablet vendor. The tablet driver would send inputevent.IECODE_LBUTTON-type events as the pressure crossed that threshold.


TABLETA_RangeZ

Tag for TTabletData.td_TagList. The maximum value of the tablet in the Z direction.

Declaration

Source position: intuition.pas line 832

const TABLETA_RangeZ = TABLETA_Dummy + 2;

Description

The maximum value of the tablet in the Z direction. Normally specified along with TABLETA_TabletZ, this allows the application to scale the actual Z value across its range.


TABLETA_ResolutionX

Tag for TTabletData.td_TagList. X-axis resolution

Declaration

Source position: intuition.pas line 839

const TABLETA_ResolutionX = TABLETA_Dummy + 9;

Description

ti_Data is an unsigned long LongInt which is the x-axis resolution in dots per inch.


TABLETA_ResolutionY

Tag for TTabletData.td_TagList. Y-axis resolution

Declaration

Source position: intuition.pas line 840

const TABLETA_ResolutionY = TABLETA_Dummy + 10;

Description

ti_Data is an unsigned long LongInt which is the y-axis resolution in dots per inch.


TABLETA_TabletZ

Tag for TTabletData.td_TagList. The current value of the tablet in the Z direction.

Declaration

Source position: intuition.pas line 831

const TABLETA_TabletZ = TABLETA_Dummy + 1;

Description

The current value of the tablet in the Z direction. This unsigned value should typically be in the natural units of the tablet. You should also provide TABLETA_RangeZ.


TAGBASE_SCREENBAR

Declaration

Source position: intuition.pas line 3390

const TAGBASE_SCREENBAR = TAG_USER or MUISERIALNO_INTUITION shl 16 + 3000;


TBoolInfo

Boolgadget informations PBoolInfo

Declaration

Source position: intuition.pas line 348

type TBoolInfo = record
Flags: Word; | Flags for BoolGadget BOOLMASK
Mask: PWord; | Bit mask for highlighting and selecting mask must follow the same rules as an Image plane. It's width and height are determined by the width and height of the gadget's select box. (i.e. TGadget.Width and TGadget.Height).
Reserved: LongWord; | Set to 0
end;


TBorder

Pointer drawing structure

Declaration

Source position: intuition.pas line 60

type TBorder = record
LeftEdge: SmallInt; | Initial left offsets from the origin
TopEdge: SmallInt; | Initial top offsets from the origin
FrontPen: Byte; | Front pen for rendering
BackPen: Byte; | Back pen for rendering
DrawMode: Byte; | Draw Mode for rendering
Count: ShortInt; | Number of XY pairs
XY: PSmallInt; | Vector coordinate pairs relative to LeftTop
NextBorder: PBorder; | pointer to any other Border too
end;

Description

Data type Border, used for drawing a series of lines which is intended for use as a border drawing, but which may, in fact, be used to render any arbitrary vector shape. The routine DrawBorder sets up the RastPort with the appropriate variables, then does a Move to the first coordinate, then does Draws to the subsequent coordinates. After all the Draws are done, if NextBorder is non-zero we call DrawBorder recursively

See also

TRequester | Requesters The following struct is used for standard intuition requesters
GA_Border | GadgetClass Tag. (PBorder) Gadget imagry is a border
DrawBorder | Draw the specified Border structure into a RastPort.


TBTDBoolean

Declaration

Source position: intuition.pas line 2878

type TBTDBoolean = record

  BB_Node: TBTDNode;

  BB_Value: LongInt;

end;


TBTDCycle

Declaration

Source position: intuition.pas line 2900

type TBTDCycle = record

  BC_Node: TBTDNode;

  BC_Value: LongInt;

  BC_Labels: PPChar;

end;


TBTDDrawInfo

Declaration

Source position: intuition.pas line 2953

type TBTDDrawInfo = record

  BDI_RPort: PRastPort;

  BDI_Screen: PScreen;

  BDI_Left: LongInt;

  BDI_Top: LongInt;

  BDI_Width: LongInt;

  BDI_Height: LongInt;

end;


TBTDFile

Declaration

Source position: intuition.pas line 2919

type TBTDFile = record

  BF_Node: TBTDNode;

  BF_Font: array [0..BTDMAXSTRLEN-1] of Char;

end;


TBTDFont

Declaration

Source position: intuition.pas line 2913

type TBTDFont = record

  BF_Node: TBTDNode;

  BF_Font: array [0..BTDMAXSTRLEN-1] of Char;

end;


TBTDInfo

Declaration

Source position: intuition.pas line 2926

type TBTDInfo = record

  BI_Revision: LongWord;

  BI_ID: LongWord;

  BI_Name: PChar;

  BI_Description: PChar;

  BI_Author: PChar;

  BI_Flags: LongWord;

  BI_Params: PPBTDNode;

end;


TBTDInteger

Declaration

Source position: intuition.pas line 2884

type TBTDInteger = record

  BI_Node: TBTDNode;

  BI_Value: LongInt;

  BI_Min: LongInt;

  BI_Max: LongInt;

  BI_Slider: LongInt;

  BI_Format: PChar;

  BI_Hook: PHook;

end;


TBTDNode

Declaration

Source position: intuition.pas line 2870

type TBTDNode = record

  BN_Tag: LongWord;

  BN_Name: PChar;

  BN_Type: LongWord;

end;


TBTDString

Declaration

Source position: intuition.pas line 2907

type TBTDString = record

  BS_Node: TBTDNode;

  BS_String: array [0..BTDMAXSTRLEN-1] of Char;

end;


TClassLibrary

BOOPSI class libraries structure

Declaration

Source position: intuition.pas line 2097

type TClassLibrary = record
cl_Lib: TLibrary; | Embedded library
cl_Pad: Word; | Align the structure
cl_Class: PIClass; | Class pointer
end;

Description

BOOPSI class libraries should use this structure as the base for their library data. This allows developers to obtain the class pointer for performing object-less inquiries.


TColorSpec

Color table entry

Declaration

Source position: intuition.pas line 1238

type TColorSpec = record
ColorIndex: SmallInt; | -1 terminates an array of ColorSpec
Red: Word; | Only the bottom 4 bits recognized
Green: Word; | Only the bottom 4 bits recognized
Blue: Word; | Only the bottom 4 bits recognized
end;


TDrawInfo

Graphical informations for the 3D look

Declaration

Source position: intuition.pas line 1353

type TDrawInfo = record
dri_Version: Word; | Version of the structure, will be DRI_VERSION
dri_NumPens: Word; | Guaranteed to be >= numDrIPens
dri_Pens: PWord; | pointer to pen array
dri_Font: PTextFont; | Screen default font
dri_Depth: Word; | (initial) depth of screen bitmap
dri_Resolution: record | from DisplayInfo database for initial display mode
x: Word; |
y: Word; |
end;
dri_Flags: LongWord; | Draw Flags (DIRF_*)
dri_CheckMark: PImage; | pointer to scaled checkmark image Will be nil if DRI_VERSION < 2
dri_AmigaKey: PImage; | pointer to scaled Amiga-key image Will be nil if DRI_VERSION < 2
dri_Reserved: array [0..4] of LongWord; | Place for future extensions
end;

Description

The DrawInfo structure provides information Intuition uses to support the 3D look and specifies graphical information for applications that use the screen. The information includes such items as aspect ratio (resolution), font, number of colors and drawing pens.

See also

TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
GA_DrawInfo | GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.
TimpFrameBox | Message argument for IM_FRAMEBOX
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME
DrawImageState | Draw an (extended) Intuition Image with special visual state.
FreeScreenDrawInfo | Finish using a DrawInfo structure.
GetScreenDrawInfo | Get pointer to rendering information.


TEasyStruct

The text and setup of an easy requester

Declaration

Source position: intuition.pas line 1247

type TEasyStruct = record
es_StructSize: LongWord; | should be sizeof (TEasyStruct) Note that this size may change, if you update the includes! Do not use absolute values as the size of pointers may vary on different platforms!
es_Flags: LongWord; | should be 0 for now
es_Title: PChar; | Title of easy requester window. If this is nil, the title will be taken to be the same as the title of the reference window, if one is specified in the EasyRequestArgs() call, else the title will be "System Request".
es_TextFormat: PChar; | 'printf' style formatting string see RawDoFmt()
es_GadgetFormat: PChar; | Text of the gadgets, separated by '|' (vertical bar) support no further formating. At least one gadget must be specified.
end;

See also

BuildEasyRequestArgs | Simple creation of system request.
EasyRequestArgs | Easy alternative to AutoRequest()


TExtEasyStruct

Declaration

Source position: intuition.pas line 3130

type TExtEasyStruct = record

  es_StructSize: LongWord;

  es_Flags: LongWord;

  es_Title: PChar;

  es_TextFormat: PChar;

  es_GadgetFormat: PChar;

  es_Tags: PTagItem;

end;


TExtGadget

Extended Gadget structure

Declaration

Source position: intuition.pas line 161

type TExtGadget = record
NextGadget: PExtGadget; |
LeftEdge: SmallInt; |
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
Flags: Word; |
Activation: Word; |
GadgetType: Word; |
GadgetRender: Pointer; |
SelectRender: Pointer; |
GadgetText: PIntuiText; |
MutualExclude: LongInt; |
SpecialInfo: Pointer; |
GadgetID: Word; |
UserData: Pointer; |
MoreFlags: LongWord; | Additional flags (GMORE_*)
BoundsLeftEdge: SmallInt; | Bounding extent for gadget, valid
BoundsTopEdge: SmallInt; | only if GMORE_BOUNDS is set. The
BoundsWidth: SmallInt; | GFLG_RELxxx flags affect these
BoundsHeight: SmallInt; | coordinates as well.
end;

Description

Check TGadget for the meaning for the first fields.

See also

TGadget | Structure to describe a Gadget
GFLG_EXTENDED | Flag for TGadget.SpecialInfo. Gadget is an PExtGadget


TExtIntuiMessage

Extended Intuition message structure

Declaration

Source position: intuition.pas line 597

type TExtIntuiMessage = record
eim_IntuiMessage: TIntuiMessage; | Standard Intuition message
eim_TabletData: PTabletData; | Pointer to tablet data
end;

Description

All IntuiMessages are now slightly extended. The ExtIntuiMessage structure has an additional field for tablet data, which is usually nil.

Note

This structure is subject to grow in the future. Making assumptions about its size is a bad idea.


TExtNewScreen

Extended TNewScreen structure

Declaration

Source position: intuition.pas line 1572

type TExtNewScreen = record
LeftEdge: SmallInt; | see at TNewScreen
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
Depth: SmallInt; |
DetailPen: Byte; |
BlockPen: Byte; |
ViewModes: Word; |
ens_Type: Word; |
Font: PTextAttr; |
DefaultTitle: PChar; |
Gadgets: PGadget; |
CustomBitMap: PBitMap; |
Extension: PTagItem; | TExtNewScreen specific extension SA_*
end;


TExtNewWindow

Future TNewWindow

Declaration

Source position: intuition.pas line 1011

type TExtNewWindow = record
LeftEdge: SmallInt; | see TNewWindow for the field explanations
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
DetailPen: Byte; |
BlockPen: Byte; |
IDCMPFlags: LongWord; |
Flags: LongWord; |
FirstGadget: PGadget; |
CheckMark: PImage; |
Title: PChar; |
WScreen: PScreen; |
WBitMap: PBitMap; |
MinWidth: SmallInt; |
MinHeight: SmallInt; |
MaxWidth: Word; |
MaxHeight: Word; |
WType: Word; |
Extension: PTagItem; | If the Flags value WFLG_NW_EXTENDED is set, then this field is assumed to point to an array ( or chain of arrays) of TagItem structures. See also TExtNewScreen for another use of TagItems to pass optional data.
end;

Description

Compatibility issues require that the size of NewWindow not change. Data in the common part (NewWindow) indicates the the extension fields are being used. NOTE WELL: This structure may be subject to future extension. Writing code depending on its size is not allowed.


TEXTPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. text on background

Declaration

Source position: intuition.pas line 1380

const TEXTPEN = 2;


TGadget

Structure to describe a Gadget

Declaration

Source position: intuition.pas line 136

type TGadget = record
NextGadget: PGadget; | Next Gadget in the list
LeftEdge: SmallInt; | Left edge of Hitbox
TopEdge: SmallInt; | Top edge of Hitbox
Width: SmallInt; | Width of Hitbox
Height: SmallInt; | Height of Hitbox
Flags: Word; | Flag for Gadget (GFLG_*)
Activation: Word; | Activation flag (GACT_*)
GadgetType: Word; | Gadget typ (GTYP_*)
GadgetRender: Pointer; | Application can specify that the Gadget be rendered as either as Border or an Image. This variable points to which (or equals nil if there's nothing to be rendered about this Gadget)
SelectRender: Pointer; | Application can specify "highlighted" imagery rather than algorithmic this can point to either Border or Image data
GadgetText: PIntuiText; | Text for this gadget
MutualExclude: LongInt; | obsolete
SpecialInfo: Pointer; | A pointer to a structure of special data required by Proportional, String and LongInt Gadgets
GadgetID: Word; | User-definable ID field
UserData: Pointer; | A pointer to general purpose User data (ignored by Intuition)
end;

See also

TRequester | Requesters The following struct is used for standard intuition requesters
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TScreen | Basic screen structure
TNewScreen | Description of a new screen
TExtNewScreen | Extended TNewScreen structure
GA_Previous | GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.
GA_Next | GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.
TSGWork | String gadget message
ActivateGadget | Activate a (string or custom) gadget.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
GadgetMouse | Calculate gadget-relative mouse position.
ModifyProp | Modify the current parameters of a proportional gadget.
ObtainGIRPort | Set up a RastPort for a custom gadget.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.
GADGET_BOX | Get bounding box of a gadget
CUSTOM_HOOK | Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget


TGadgetInfo

The TGadgetInfo structure contains information about the display on which the gadget needs to render itself

Declaration

Source position: intuition.pas line 1916

type TGadgetInfo = record
gi_Screen: PScreen; | ScreenPtr
gi_Window: PWindow; | nil for screen gadgets
gi_Requester: PRequester; | nil IF not GTYP_REQGADGET
gi_RastPort: PRastPort; | Rendering information: don't use these without cloning/locking. Official way is to call ObtainGIRPort()
gi_Layer: PLayer; | LayerPtr
gi_Domain: TIBox; | Copy of dimensions of screen/window/g00/req(/group) that gadget resides in.
gi_Pens: record |
DetailPen: Byte; |
BlockPen: Byte; |
end;
gi_DrInfo: PDrawInfo; | the Detail and Block pens in gi_DrInfo^.dri_Pens[] are for the screen. Use the above for window-sensitive colors.
gi_Reserved: array [0..5] of LongWord; |
end;

Description

All the fields in this structure are read only.

Although this structure contains a pointer to the gadget's RastPort structure, applications should not use it for rendering. Instead, use the intuition.library function ObtainGIRPort() to obtain a copy of the GadgetInfo's RastPort. When the gadget is finished with this RastPort, it should call ReleaseGIRPort() to relinquish the RastPort.

See also

TopSet | Message structure for OM_NEW/OM_SET
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpRender | Message parameter passed for GM_RENDER
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
TgpGoInactive | Message parameter passed for GM_GOINACTIVE
TgpLayout | Message parameter passed for GM_LAYOUT
TgpDomain |
TSGWork | String gadget message
GadgetMouse | Calculate gadget-relative mouse position.
ObtainGIRPort | Set up a RastPort for a custom gadget.


TgpDomain

Declaration

Source position: intuition.pas line 2346

type TgpDomain = record

  MethodID: LongWord;

  gpd_GInfo: PGadgetInfo;

  gpd_RPort: PRastPort;

  gpd_Which: LongInt;

  gpd_Domain: TIBox;

  gpd_Attrs: PTagItem;

end;


TgpGoInactive

Message parameter passed for GM_GOINACTIVE

Declaration

Source position: intuition.pas line 2318

type TgpGoInactive = record
MethodID: LongWord; | GM_GOINACTIVE
gpgi_GInfo: PGadgetInfo; |
gpgi_Abort: LongWord; | Boolean field to indicate, who wanted the gadget to go inactive. If this is 1 this method was sent, because intution wants the gadget to go inactive, if it is 0, it was the gadget itself that wanted it.
end;

Description

See GM_GOACTIVE


TgpHitTest

Message parameter passed for GM_HITTEST or GM_HELPTEST

Declaration

Source position: intuition.pas line 2249

type TgpHitTest = record
MethodID: LongWord; | GM_HITTEST or GM_HELPTEST
gpht_GInfo: PGadgetInfo; |
gpht_Mouse: record | These values are relative to the gadget select box for GM_HITTEST. For
x: SmallInt; |
y: SmallInt; |
end;
end;


TgpInput

Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT

Declaration

Source position: intuition.pas line 2289

type TgpInput = record
MethodID: LongWord; | GM_GOACTIVE or GM_HANDLEINPUT
gpi_GInfo: PGadgetInfo; | gadget context
gpi_IEvent: PInputEvent; | Pointer to the InputEvent that caused the method to be invoked.
gpi_Termination: PLongInt; | Pointer to a variable that is to be set by the gadget class, if GMR_VERIFY is returned. The lower 16 bits of this value are returned in the Code field of the IntuiMessage passed back to the application
gpi_Mouse: record | This struct defines the current mouse position, relative to the gadgets' bounding box.
x: SmallInt; |
y: SmallInt; |
end;
gpi_TabletData: PTabletData; | Pointer to TabletData structure or nil, if this input event did not originate from a tablet.
end;

Description

GM_GOACTIVE tells the gadget that it has become active and will receive input from now on from the method GM_HANDLEINPUT. This is stopped by using GM_GOINACTIVE.


TgpKeyGoInactive

Declaration

Source position: intuition.pas line 2391

type TgpKeyGoInactive = record

  MethodID: LongWord;

  gpki_GInfo: PGadgetInfo;

  gpki_Abort: LongWord;

end;


tgpKeyInput

Declaration

Source position: intuition.pas line 2376

type tgpKeyInput = record

  MethodID: Cardinal;

  gpk_GInfo: PGadgetInfo;

  gpk_IEvent: PInputEvent;

  gpk_Termination: PLongInt;

end;


TgpKeyTest

Declaration

Source position: intuition.pas line 2365

type TgpKeyTest = record

  MethodID: LongWord;

  gpkt_GInfo: PGadgetInfo;

  gpkt_IMsg: PIntuiMessage;

  gpkt_VanillaKey: LongWord;

end;


TgpLayout

Message parameter passed for GM_LAYOUT

Declaration

Source position: intuition.pas line 2336

type TgpLayout = record
MethodID: LongWord; | GM_LAYOUT
gpl_GInfo: PGadgetInfo; |
gpl_Initial: LongWord; | Boolean that indicated, if this method was invoked, when you are added to a window (True) or if it is called, because the window was resized (False).
end;

Description

This method is called by intuition, if on of the GFLG_REL* flags or one of the GA_Rel* attributes is set and the window size changes or you are added to a window. In this method you should re-evaluate the size of yourself. You are not allowed to do any rendering operation during this method!


TgpRender

Message parameter passed for GM_RENDER

Declaration

Source position: intuition.pas line 2273

type TgpRender = record
MethodID: LongWord; | GM_RENDER
gpr_GInfo: PGadgetInfo; | Gadget context
gpr_RPort: PRastPort; | all ready for use
gpr_Redraw: LongInt; | might be a "highlight pass" (GREDRAW_*) Not all of these values make sense for all gadgets.
end;

Description

This method is invoked to draw the gadget into a rastport.


TIBox

A data structure common in Intuition processing

Declaration

Source position: intuition.pas line 604

type TIBox = record

  Left: SmallInt;

  Top: SmallInt;

  Width: SmallInt;

  Height: SmallInt;

end;

Description

Describes a rectangle via a point with width and height

See also

GA_Bounds | GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.
TimpFrameBox | Message argument for IM_FRAMEBOX
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
TPGX | System private data structure for now prop gadget extra info
TgpDomain |
IM_BOX | Get Image bounding rectangle
GADGET_BOX | Get bounding box of a gadget


TIClass

This structure is READ-ONLY, and allocated only by Intuition

Declaration

Source position: intuition.pas line 2066

type TIClass = record
cl_Dispatcher: THook; |
cl_Reserved: LongWord; | must be 0
cl_Super: PIClass; | Super Class
cl_ID: ClassID; |
cl_InstOffset: Word; | where within an object is the instance data for this class?
cl_InstSize: Word; | Size of instance data
cl_UserData: PtrUInt; | per-class data of your choice, application specific
cl_SubclassCount: LongWord; | # of direct suclasses
cl_ObjectCount: LongWord; | # of objects, made from this class must be 0, if the class is to be deleted
cl_Flags: LongWord; | Flags (CLF_INLIST)
end;


TImage

This is a brief image structure for very simple transfers of image data to a RastPort

Declaration

Source position: intuition.pas line 529

type TImage = record
LeftEdge: SmallInt; | Starting offset relative to some origin
TopEdge: SmallInt; | Starting offsets relative to some origin
Width: SmallInt; | Pixel size (though data is Word-aligned)
Height: SmallInt; | Height of image
Depth: SmallInt; | Pixel size
ImageData: PWord; | A Pointer to the actual Word-aligned bits
PlanePick: Byte; |
PlaneOnOff: Byte; |
NextImage: PImage; | If not nil, Intuition presumes that it points to another Image structure with another Image to be rendered
end;

Description

The TImage.PlanePick and PlaneOnOff variables work much the same way as the equivalent GELS Bob variables. It's a space-saving mechanism for image data. Rather than defining the image data for every plane of the RastPort, you need define data only for the planes that are not entirely zero or one. As you define your Imagery, you will often find that most of the planes ARE just as color selectors. For instance, if you're designing a two-color Gadget to use colors two and three, and the Gadget will reside in a five-plane display, bit plane zero of your imagery would be all ones, bit plane one would have data that describes the imagery, and bit planes two through four would be all zeroes. Using these flags allows you to avoid wasting all that memory in this way: first, you specify which planes you want your data to appear in using the PlanePick variable. For each bit set in the variable, the next "plane" of your image data is blitted to the display. For each bit clear in this variable, the corresponding bit in PlaneOnOff is examined. If that bit is clear, a "plane" of zeroes will be used. If the bit is set, ones will go out instead. So, for our example:

Gadget.PlanePick = $02;

Gadget.PlaneOnOff = $01;

Note that this also allows for generic Gadgets, like the System Gadgets, which will work in any number of bit planes. Note also that if you want an Image that is only a filled rectangle, you can get this by setting PlanePick to zero (pick no planes of data) and set PlaneOnOff to describe the pen color of the rectangle.

See also

PImage | This is a brief image structure for very simple transfers of image data to a RastPort
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TDrawInfo | Graphical informations for the 3D look
GA_Image | GadgetClass Tag. (PImage) Gadget imagry is an image
GA_SelectRender | GadgetClass Tag.
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.
EraseImage | Erases an Image.
PointInImage | Tests whether an image "contains" a point.
IM_BGPEN | Set Image Background Pen
IM_BOX | Get Image bounding rectangle
IM_FGPEN | Set Image Foreground pen


TimpDomainFrame

Declaration

Source position: intuition.pas line 2602

type TimpDomainFrame = record

  MethodID: LongWord;

  imp_DrInfo: PDrawInfo;

  imp_RPort: PRastPort;

  imp_Which: LongInt;

  imp_Domain: TIBox;

  imp_Attrs: PTagItem;

end;


TimpDraw

Message argument for IM_DRAW or IM_DRAWFRAME

Declaration

Source position: intuition.pas line 2549

type TimpDraw = record
MethodID: LongWord; | IM_DRAW or IM_DRAWFRAME
imp_RPort: PRastPort; |
imp_Offset: record |
x: SmallInt; |
y: SmallInt; |
end;
imp_State: LongWord; |
imp_DrInfo: PDrawInfo; | May be nil
imp_Dimensions: record | Only valid for IM_DRAWFRAME
Width: SmallInt; |
Height: SmallInt; |
end;
end;


TimpErase

Message argument for IM_ERASE or IM_ERASEFRAME

Declaration

Source position: intuition.pas line 2569

type TimpErase = record
MethodID: LongWord; | IM_ERASE or IM_ERASEFRAME
imp_RPort: PRastPort; |
imp_Offset: record |
x: SmallInt; |
y: SmallInt; |
end;
imp_Dimensions: record | Only valid for IM_DRAWFRAME
Width: SmallInt; |
Height: SmallInt; |
end;
end;

Description

This is a subset of TimpDraw


TimpFrameBox

Message argument for IM_FRAMEBOX

Declaration

Source position: intuition.pas line 2535

type TimpFrameBox = record
MethodID: LongWord; | IM_FRAMEBOX
imp_ContentsBox: PIBox; | input: relative box of contents
imp_FrameBox: PIBox; | output: rel. box of encl frame
imp_DrInfo: PDrawInfo; | may be nil
imp_FrameFlags: LongWord; | FRAMEF_SPECIFY
end;


TimpHitTest

Message argument for IM_HITTEST or IM_HITFRAME

Declaration

Source position: intuition.pas line 2585

type TimpHitTest = record
MethodID: LongWord; | IM_HITTEST or IM_HITFRAME
imp_Point: record |
x: SmallInt; |
y: SmallInt; |
end;
imp_Dimensions: record | only valid for IM_HITFRAME
Width: SmallInt; |
Height: SmallInt; |
end;
end;


TIntuiMessage

Intuition message structure

Declaration

Source position: intuition.pas line 568

type TIntuiMessage = record
ExecMessage: TMessage; | Standard Exec message
IClass: LongWord; | The Class bits correspond directly with the IDCMP Flags (IDCMP_*), except for the special bit IDCMP_LONELYMESSAGE
Code: Word; | The Code field is for special values like Menu number, Keycode and so on
Qualifier: Word; | The Qualifier field is a copy of the current InputEvent's Qualifier
IAddress: Pointer; | IAddress contains particular addresses for Intuition functions, like the pointer to the Gadget or the Screen
MouseX: SmallInt; | When getting mouse movement reports, any event you get will have the the mouse coordinates in these variables.
MouseY: SmallInt; | the coordinates are relative to the upper-left corner of your Window (WA_GIMMEZEROZERO notwithstanding)
Seconds: LongWord; | The time values are copies of the current system clock time.
Micros: LongWord; | Micros are in units of microseconds, Seconds in seconds.
IDCMPWindow: PWindow; | The IDCMPWindow variable will always have the Pointer of the Window of this IDCMP
SpecialLink: PIntuiMessage; | System-use variable
end;

See also

TWindow | Window structure
exec.GetMsg | Get next message from message port
exec.PutMsg | Put a message to a message port
exec.ReplyMsg | Put a message to its reply port
exec.WaitPort | Wait for a given port to be non-empty


TIntuiText

IntuiText is a series of strings.

Declaration

Source position: intuition.pas line 42

type TIntuiText = record
FrontPen: Byte; | Front pen for Font rendering
BackPen: Byte; | Back pen for Font rendering
DrawMode: Byte; | The mode for rendering the text
LeftEdge: SmallInt; | relative left start location for the text
TopEdge: SmallInt; | relative top start location for the text
ITextFont: PTextAttr; | If nil, you accept the default
IText: PChar; | A pointer to null-terminated text
NextText: PIntuiText; | Continuation to TxWrite another text
end;

Description

IntuiText is a series of strings that start with a screen location (always relative to the upper-left corner of something) and then the text of the string. The text is null-terminated.

See also

TGadget | Structure to describe a Gadget
TExtGadget | Extended Gadget structure
TRequester | Requesters The following struct is used for standard intuition requesters
GFLG_LABELITEXT | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText
GA_IntuiText | GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.
AutoRequest | Automatically build and get response from a requester.
BuildSysRequest | Build and display a system requester.
IntuiTextLength | Return the length (pixel-width) of an IntuiText.
PrintIText | Print text described by the IntuiText argument.


TIntuitionBase

Intuition basic structure

Declaration

Source position: intuition.pas line 1890

type TIntuitionBase = record
LibNode: TLibrary; | Standard Libnode
ViewLord: TView; |
ActiveWindow: PWindow; | Currently active Window
ActiveScreen: PScreen; | Currently Active Screen
FirstScreen: PScreen; | for linked list of all screens, the FirstScreen variable points to the frontmost Screen. Screens are then maintained in a front to back order using TScreen.NextScreen
Flags: LongWord; | values are all system private
MouseY: SmallInt; | Current Mouse position
MouseX: SmallInt; |
Seconds: LongWord; | timestamp of most current input event [s]
Micros: LongWord; | The data beyond this point has changed, is changing, and will continue to change.
end;

Description

It is sometimes necessary to examine the IntuitionBase structure. Items such as the address of the active screen and window, current mouse coordinates and more can be found there. It is never a good idea to simply read these fields, as they are prone to sudden change. The IntuitionBase structure must always be locked before looking at its fields.

It is necessary to inform Intuition that an application is about to examine IntuitionBase so that Intuition will not change any variables and IntuitionBase will remain static during the access. The call LockIBase(0) will lock the state of IntuitionBase so that it may be examined. During the time that the application has IntuitionBase locked, all Intuition input processing is frozen. Make every effort to examine IntuitionBase and release the lock as quickly as possible. When done call UnlockIBase(lock) where lock is what LockIBase(0) returned.

The values in IntuitionBase are read-only. Applications should never write values to IntuitionBase.


TMenu

Structure to describe a menu

Declaration

Source position: intuition.pas line 112

type TMenu = record
NextMenu: PMenu; | Next Menu on the same level
LeftEdge: SmallInt; | Left position of the select box
TopEdge: SmallInt; | Top position of the select box
Width: SmallInt; | Width of the select box
Height: SmallInt; | Height of the select box
Flags: Word; | Flags for the menu (MENUENABLED, MIDRAWN)
MenuName: PChar; | Text for this Menu Header
FirstItem: PMenuItem; | Pointer to first menu item in chain
JazzX: SmallInt; |
JazzY: SmallInt; |
BeatX: SmallInt; |
BeatY: SmallInt; |
end;

See also

TWindow | Window structure
ItemAddress | Returns the address of the specified MenuItem.
ResetMenuStrip | Re-attach a menu strip to a window.
SetMenuStrip | Attach a menu strip to a window.


TMenuItem

Structure to describe a menu item

Declaration

Source position: intuition.pas line 74

type TMenuItem = record
NextItem: PMenuItem; | Pointer to next in chained list
LeftEdge: SmallInt; | Left position of the select box
TopEdge: SmallInt; | Top position of the select box
Width: SmallInt; | Width of the select box
Height: SmallInt; | Height of the select box
Flags: Word; | Flags for the item (e.g. Checked, ISDRAWN, HIGHITEM, ITEMENABLED, MENUTOGGLE, COMMSEQ, ITEMTEXT, CHECKIT)
MutualExclude: LongInt; | Set bits mean this item excludes that
ItemFill: Pointer; | PImage, PIntuiText or nil
SelectFill: Pointer; | PImage, PIntuiText or nil when this item is pointed to by the cursor and the items highlight mode HIGHIMAGE is selected, this alternate image will be displayed.
Command: Char; | Only if application sets the COMMSEQ flag
SubItem: PMenuItem; | If non-nil, DrawMenu shows "->"
NextSelect: Word; | The NextSelect field represents the menu number of next selected item (when user has drag-selected several items)
end;

See also

TMenu | Structure to describe a menu
ItemAddress | Returns the address of the specified MenuItem.


TMsg

Declaration

Source position: intuition.pas line 1965

type TMsg = record

  MethodID: LongWord;

Message ID OM_*

end;

See also

DoGadgetMethodA | Invoke method on a boopsi gadget.
TopSet | Message structure for OM_NEW/OM_SET
TopGet | Message structure for OM_GET
TopAddTail | Message structure for OM_ADDTAIL
TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE


TmsGetDefaultGammaTables

Declaration

Source position: intuition.pas line 3362

type TmsGetDefaultGammaTables = record

  MethodID: LongWord;

  Red: PByte;

  Green: PByte;

  Blue: PByte;

end;


TmsGetDefaultPixelFormat

Declaration

Source position: intuition.pas line 3370

type TmsGetDefaultPixelFormat = record

  MethodID: LongWord;

  Depth: LongWord;

  Store: PLongWord;

end;


TmsGetPointerBounds

Declaration

Source position: intuition.pas line 3377

type TmsGetPointerBounds = record

  MethodID: LongWord;

  PointerType: LongWord;

  Width: PLongWord;

  Height: PLongWord;

end;


TmsGetRootBitMap

Declaration

Source position: intuition.pas line 3343

type TmsGetRootBitMap = record

  MethodID: LongWord;

  PixelFormat: LongWord;

  Store: ;

end;


TmsQuery3DSupport

Declaration

Source position: intuition.pas line 3350

type TmsQuery3DSupport = record

  MethodID: LongWord;

  PixelFormat: LongWord;

  Store: PLongWord;

end;


TmsSetDefaultGammaTables

Declaration

Source position: intuition.pas line 3385

type TmsSetDefaultGammaTables = TmsGetDefaultGammaTables;


TMUIP_Screenbar_BuildSettingsPanel

Declaration

Source position: intuition.pas line 3409

type TMUIP_Screenbar_BuildSettingsPanel = record

  ID: LongWord;

end;


TMUIP_Screenbar_DefaultConfigItem

Declaration

Source position: intuition.pas line 3420

type TMUIP_Screenbar_DefaultConfigItem = record

  id: LongWord;

  CfgID: LongWord;

end;


TMUIP_Screenbar_KnowsConfigItem

Declaration

Source position: intuition.pas line 3414

type TMUIP_Screenbar_KnowsConfigItem = record

  id: LongWord;

  CfgID: LongWord;

end;


TMUIP_Screenbar_Lock

Declaration

Source position: intuition.pas line 3429

type TMUIP_Screenbar_Lock = record

  ID: LongWord;

end;


TMUIP_Screenbar_Signal

Declaration

Source position: intuition.pas line 3439

type TMUIP_Screenbar_Signal = record

  ID: LongWord;

end;


TMUIP_Screenbar_Unlock

Declaration

Source position: intuition.pas line 3434

type TMUIP_Screenbar_Unlock = record

  ID: LongWord;

end;


TMUIP_UpdateConfig

Declaration

Source position: intuition.pas line 3426

type TMUIP_UpdateConfig = TMUIP_Screenbar_DefaultConfigItem;


TNewScreen

Description of a new screen

Declaration

Source position: intuition.pas line 1546

type TNewScreen = record
LeftEdge: SmallInt; | initial position of your screen
TopEdge: SmallInt; | Left and Top are specified relative to the Intuition's view, in same resolution as the screen pixels.
Width: SmallInt; | the width for this screen's RastPort, or the constant STDSCREENWIDTH to get the current default width
Height: SmallInt; | the height for his screen's RastPort, or the constant STDSCREENHEIGHT to get the current default height
Depth: SmallInt; | number of bitplanes
DetailPen: Byte; | pen number for details (like gadgets or text in title bar/border/gadget) The common value for this pen is 0.
BlockPen: Byte; | pen number for block fills (like title bar/border/gadget) The common value for this pen is 1.
ViewModes: Word; | the Modes for the ViewPort (and View)
SType: Word; | the Screen type CUSTOMSCREEN_f, CUSTOMBITMAP_f (Type in C-Include)
Font: PTextAttr; | this Screen's default text attributes
DefaultTitle: PChar; | the default title for this Screen
Gadgets: PGadget; | your own Gadgets for this Screen
CustomBitMap: PBitMap; | if you have your own display memory that you want used for this screen, the CustomBitMap field should point to the BitMap structure that describes your display memory.
end;


TNewWindow

New window structure

Declaration

Source position: intuition.pas line 953

type TNewWindow = record
LeftEdge: SmallInt; | Left edge of window
TopEdge: SmallInt; | Top edge of window
Width: SmallInt; | Width of window
Height: SmallInt; | Height of window
DetailPen: Byte; | For bar/border/gadget rendering
BlockPen: Byte; | For bar/border/gadget rendering
IDCMPFlags: LongWord; | User-selected IDCMP flags (IDCMP_*)
Flags: LongWord; | Window Flags (WFLG_*)
FirstGadget: PGadget; | You supply a linked-list of Gadgets for your Window. This list does not include system Gadgets.
CheckMark: PImage; | A Pointer to the imagery that will be used when rendering MenuItems of this Window that want to be checkmarked if this is equal to nil, you'll get the default imagery
Title: PChar; | The title text for this window
Screen: PScreen; | Only if you've defined a CUSTOMSCREEN and want this Window to open in it. If so, you pass the Pointer of the Custom Screen structure in this variable. Otherwise, this variable is ignored and doesn't have to be initialized.
BitMap: PBitMap; | SUPER_BITMAP Window? If so, put the Pointer of your BitMap structure in this variable. If not, this variable is ignored and doesn't have to be initialized
MinWidth: SmallInt; | Minimum / maximum size of your window, only if WFLG_SIZEGADGET is set,
MinHeight: SmallInt; | if MinWidth/Height = 0 then its set to the opening size.
MaxWidth: Word; |
MaxHeight: Word; |
WType: Word; | Describes the Screen in which you want this Window to open. The type value can either be CUSTOMSCREEN_f or one of the system standard Screen Types such as WBENCHSCREEN_f. See the type definitions under the Screen structure
end;

See also

OpenWindow | Open an Intuition window.
OpenWindowTagList | OpenWindow() with TagItem extension.


TopAddMember

Declaration

Source position: intuition.pas line 2047

type TopAddMember = TopMember;


TopAddTail

Message structure for OM_ADDTAIL

Declaration

Source position: intuition.pas line 2036

type TopAddTail = record
MethodID: LongWord; | OM_ADDTAIL
opat_List: PList; | The exec list to add the object to
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TOPAZ_EIGHTY

default font size

Declaration

Source position: intuition.pas line 1674

const TOPAZ_EIGHTY = 8;

Description

This actually describe the height of the default font. The default font type is the topaz font, which is a fixed width font that can be used in either eighty-column or sixty-column mode. The Preferences structure reflects which is currently selected by the value found in the variable FontSize, which may have either of the values defined below. These values actually are used to select the height of the default font. By changing the height, the resolution of the font changes as well.

See also

TOPAZ_SIXTY

default font size


TOPAZ_SIXTY

default font size

Declaration

Source position: intuition.pas line 1675

const TOPAZ_SIXTY = 9;

Description

This actually describe the height of the default font. The default font type is the topaz font, which is a fixed width font that can be used in either eighty-column or sixty-column mode. The Preferences structure reflects which is currently selected by the value found in the variable FontSize, which may have either of the values defined below. These values actually are used to select the height of the default font. By changing the height, the resolution of the font changes as well.

See also

TOPAZ_EIGHTY

default font size


TopGet

Message structure for OM_GET

Declaration

Source position: intuition.pas line 2019

type TopGet = record
MethodID: LongWord; | OM_GET
opg_AttrID: LongWord; | ID of attribute to get
opg_Storage: Pointer; | may be other types, but 'integer' types are all LongWord
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TopMember

Message structure for OM_ADDMEMBER/OM_REMMEMBER

Declaration

Source position: intuition.pas line 2043

type TopMember = record
MethodID: LongWord; | OM_ADDMEMBER or OM_REMMEMBER
opam_Object: PObject_; | add or remove this object
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TopSet

Message structure for OM_NEW/OM_SET

Declaration

Source position: intuition.pas line 2011

type TopSet = record
MethodID: LongWord; | OM_NEW or OM_SET
ops_AttrList: PTagItem; | new attributes
ops_GInfo: PGadgetInfo; | Always there for gadgets, when SetGadgetAttrsA() is used, but will be nil for OM_NEW
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TopUpdate

Message structure for OM_NOTIFY/OM_UPDATE

Declaration

Source position: intuition.pas line 2027

type TopUpdate = record
MethodID: LongWord; | OM_NOTIFY or OM_UPDATE
opu_AttrList: PTagItem; | tag list of new attributes
opu_GInfo: PGadgetInfo; | Non-nil when SetGadgetAttrsA() or notification resulting from gadget input occurs.
opu_Flags: LongWord; | Additional flags (OPUF_*)
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TPGX

System private data structure for now prop gadget extra info

Declaration

Source position: intuition.pas line 1942

type TPGX = record

  pgx_Container: TIBox;

  pgx_NewKnob: TIBox;

end;


TPreferences

Old Style Preferences

Declaration

Source position: intuition.pas line 1679

type TPreferences = record
FontHeight: ShortInt; | height for system default font
PrinterPort: Byte; | printer port connection constant describing what's hooked up to the port
BaudRate: Word; | baud rate for the serial port
KeyRptSpeed: TTimeVal; | repeat speed for keyboard
KeyRptDelay: TTimeVal; | Delay before keys repeat
DoubleClick: TTimeVal; | Interval allowed between clicks
PointerMatrix: array [0..POINTERSIZE-1] of Word; | Mouse Data: Definition of pointer sprite
XOffset: ShortInt; | Mouse Data: X-Offset for active 'bit'
YOffset: ShortInt; | Mouse Data: Y-Offset for active 'bit'
color17: Word; | Mouse Data: Colours for sprite pointer
color18: Word; | Mouse Data:
color19: Word; | Mouse Data:
PointerTicks: Word; | Mouse Data: Sensitivity of the pointer
color0: Word; | Workbench Screen colors
color1: Word; | Standard default colours
color2: Word; | Used in the Workbench
color3: Word; |
ViewXOffset: ShortInt; | Offset for top lefthand corner
ViewYOffset: ShortInt; | Y dimensions
ViewInitX: SmallInt; | X dimensions
ViewInitY: SmallInt; | View initial offset values
EnableCLI: WordBool; | CLI availability switch
PrinterType: Word; | printer type
PrinterFilename: array [0..FILENAME_SIZE-1] of Char; | file for printer
PrintPitch: Word; | print pitch
PrintQuality: Word; | print quality
PrintSpacing: Word; | number of lines per inch
PrintLeftMargin: Word; | left margin in characters
PrintRightMargin: Word; | right margin in characters
PrintImage: Word; | positive or negative
PrintAspect: Word; | horizontal or vertical
PrintShade: Word; | b/w, half-tone, or color
PrintThreshold: SmallInt; | darkness ctrl for b/w dumps
PaperSize: Word; | paper size
PaperLength: Word; | paper length in number of lines
PaperType: Word; | continuous or single sheet
SerRWBits: Byte; | Serial Setting: upper nibble = (8-number of read bits), lower nibble = (8-number of write bits)
SerStopBuf: Byte; | Serial Setting: upper nibble = (number of stop bits - 1), lower nibble = (table value for BufSize)
SerParShk: Byte; | Serial Setting: upper nibble = (value for Parity setting), lower nibble = (value for Handshake mode)
LaceWB: Byte; | if workbench is to be interlaced
Pad: array [0..11] of Byte; |
PrtDevName: array [0..DEVNAME_SIZE-1] of Char; | Device used by printer.device (leave out the ".device")
DefaultPrtUnit: Byte; | Default unit opened by printer.device
DefaultSerUnit: Byte; | Default serial unit
RowSizeChange: ShortInt; | Affect NormalDisplayRows/Columns
ColumnSizeChange: ShortInt; |
PrintFlags: Word; | user preference flags
PrintMaxWidth: Word; | max width of printed picture in 10ths/inch
PrintMaxHeight: Word; | max height of printed picture in 10ths/inch
PrintDensity: Byte; | print density
PrintXOffset: Byte; | offset of printed picture in 10ths/inch
wb_Width: Word; | override default workbench width
wb_Height: Word; | override default workbench height
wb_Depth: Byte; | override default workbench depth
ext_size: Byte; | extension information -- do not touch! extension size in blocks of 64 bytes DO NOT TOUCH
end;

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetPrefs | Get the current Intuition Preferences structure.
SetPrefs | Set Intuition preferences data.


TPropInfo

Proportional Gadget

Declaration

Source position: intuition.pas line 363

type TPropInfo = record
Flags: Word; | General purpose flag bits (e.g. AUTOKNOB, FREEHORIZ, FREEVERT, PROPBORDERLESS, KNOBHIT or PROPNEWLOOK)
HorizPot: Word; | 16-bit FixedPoint horizontal quantity percentage
VertPot: Word; | 16-bit FixedPoint vertical quantity percentage
HorizBody: Word; | horizontal Body
VertBody: Word; | vertical Body
CWidth: Word; | Container width (with any relativity absoluted) Intuition sets and maintain
CHeight: Word; | Container height (with any relativity absoluted) Intuition sets and maintain
HPotRes: Word; | Horizontal pot increment
VPotRes: Word; | Vertical pot increment
LeftBorder: Word; | Left Container border
TopBorder: Word; | Top Container border
end;

Description

You initialize the Pot variables before the Gadget is added to the system. Then you can look here for the current settings any time, even while User is playing with this Gadget. To adjust these after the Gadget is added to the System, use ModifyProp() The Pots are the actual proportional settings, where a value of zero means zero and a value of MAXPOT means that the Gadget is set to its maximum setting.

The 16-bit FixedPoint Body variables describe what percentage of the entire body of stuff referred to by this Gadget is actually shown at one time. This is used with the AUTOKNOB routines, to adjust the size of the AUTOKNOB according to how much of the data can be seen. This is also used to decide how far to advance the Pots when User hits the Container of the Gadget. For instance, if you were controlling the display of a 5-line Window of text with this Gadget, and there was a total of 15 lines that could be displayed, you would set the VertBody value to (MAXBODY / (TotalLines / DisplayLines)) = MAXBODY / 3. Therefore, the AUTOKNOB would fill 1/3 of the container, and if User hits the Cotainer outside of the knob, the pot would advance 1/3 (plus or minus) If there's no body to show, or the total amount of displayable info is less than the display area, set the Body variables to the max. To adjust these after the Gadget is added to the System, use ModifyProp()


TPubScreenNode

Public Shared Screen Node

Declaration

Source position: intuition.pas line 1607

type TPubScreenNode = record
psn_Node: TNode; | ln_Name is screen name
psn_Screen: PScreen; |
psn_Flags: Word; | Flags (PSNF_*)
psn_Size: SmallInt; | includes name buffer
psn_VisitorCount: SmallInt; | how many visitor windows
psn_SigTask: PTask; | who to signal when visitors gone
psn_SigBit: Byte; | which signal
end;

Description

This is the representative of a public shared screen. This is an internal data structure, but some functions may present a copy of it to the calling application. In that case, be aware that the screen pointer of the structure can NOT be used safely, since there is no guarantee that the referenced screen will remain open and a valid data structure. Never change one of these.


TRANSPCONTROL_DUMMY

Declaration

Source position: intuition.pas line 3115

const TRANSPCONTROL_DUMMY = TAG_USER;


TRANSPCONTROL_OLDREGION

Declaration

Source position: intuition.pas line 3118

const TRANSPCONTROL_OLDREGION = TRANSPCONTROL_DUMMY + 3;


TRANSPCONTROL_OLDREGIONHOOK

Declaration

Source position: intuition.pas line 3119

const TRANSPCONTROL_OLDREGIONHOOK = TRANSPCONTROL_DUMMY + 4;


TRANSPCONTROL_REGION

Declaration

Source position: intuition.pas line 3116

const TRANSPCONTROL_REGION = TRANSPCONTROL_DUMMY + 1;


TRANSPCONTROL_REGIONHOOK

Declaration

Source position: intuition.pas line 3117

const TRANSPCONTROL_REGIONHOOK = TRANSPCONTROL_DUMMY + 2;


TRANSPCONTROLMETHOD_INSTALLREGION

Declaration

Source position: intuition.pas line 3109

const TRANSPCONTROLMETHOD_INSTALLREGION = $1;


TRANSPCONTROLMETHOD_INSTALLREGIONHOOK

Declaration

Source position: intuition.pas line 3112

const TRANSPCONTROLMETHOD_INSTALLREGIONHOOK = $2;


TRANSPCONTROLMETHOD_UPDATETRANSPARENCY

Declaration

Source position: intuition.pas line 3113

const TRANSPCONTROLMETHOD_UPDATETRANSPARENCY = $3;


TRemember

Structure to remember memory allocations

Declaration

Source position: intuition.pas line 1230

type TRemember = record
NextRemember: PRemember; | Next memory block in List
RememberSize: LongWord; | Size of Memory Block
Memory: PByte; | Pointer to the allocated memory
end;

Description

This structure is used for remembering what memory has been allocated to date by a given routine, so that a premature abort or systematic exit can deallocate memory cleanly, easily, and completely

See also

AllocRemember | Allocate Memory with tracking to make freeing easy.
FreeRemember | Free memory allocated by calls to AllocRemember().


TRequester

Requesters The following struct is used for standard intuition requesters

Declaration

Source position: intuition.pas line 480

type TRequester = record
OlderRequest: PRequester; |
LeftEdge: SmallInt; | dimensions of the entire box
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
RelLeft: SmallInt; | For Pointer relativity offsets
RelTop: SmallInt; |
ReqGadget: PGadget; | First gadget of the requester
ReqBorder: PBorder; | First border of the requester
ReqText: PIntuiText; | First intuitext of the requester
Flags: Word; | Flags for requester (e.g. POINTREL, PREDRAWN, NOISYREQ, SIMPLEREQ, USEREQIMAGE, NOREQBACKFILL, REQOFFWINDOW,REQACTIVE, SYSREQUEST or DEFERREFRESH)
BackFill: Byte; | Pen number for back-plane fill before draws
ReqLayer: PLayer; | Layer in place of clip rect
ReqPad1: array [0..31] of Byte; | Private
ImageBMap: PBitMap; | you may use this to fill the requester with your own image
RWindow: PWindow; | Window, which the requester belongs to
ReqImage: PImage; | corresponds to USEREQIMAGE
ReqPad2: array [0..31] of ShortInt; | Private
end;

Description

The ClipRect and BitMap and used for rendering the requester

If the BitMap plane pointers are non-zero, this tells the system that the image comes pre-drawn (if the appliprog wants to define it's own box, in any shape or size it wants!); this is OK by Intuition as long as there's a good correspondence between the image and the specified Gadgets

See also

PRequester | Requesters The following struct is used for standard intuition requesters
TWindow | Window structure
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
ActivateGadget | Activate a (string or custom) gadget.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
EndRequest | Remove a currently active requester.
InitRequester | Initialize a Requester structure.
ModifyProp | Modify the current parameters of a proportional gadget.
NewModifyProp | ModifyProp(), but with selective refresh.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
Request | Activate a requester.
SetDMRequest | Set the DMRequest of a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.


TScreen

Basic screen structure

Declaration

Source position: intuition.pas line 708

type TScreen = record
NextScreen: PScreen; | linked list of screens in intuition
FirstWindow: PWindow; | linked list Screen's Windows
LeftEdge: SmallInt; | Left edge of Screen
TopEdge: SmallInt; | Top Edge of screen
Width: SmallInt; | Width of screen
Height: SmallInt; | Height of screen
MouseY: SmallInt; |
MouseX: SmallInt; | Current mouse position, relative to upper left edge
Flags: Word; | Screen flags
Title: PChar; | Screen title
DefaultTitle: PChar; | shown when window without screen title is active
BarHeight: ShortInt; | Bar sizes for this Screen
BarVBorder: ShortInt; |
BarHBorder: ShortInt; |
MenuVBorder: ShortInt; |
MenuHBorder: ShortInt; |
WBorTop: ShortInt; | Decoration size for all windows in this screen
WBorLeft: ShortInt; |
WBorRight: ShortInt; |
WBorBottom: ShortInt; |
Font: PTextAttr; | this screen's default font
ViewPort: TViewPort; | describing the Screen's display
RastPort: TRastPort; | describing Screen rendering
BitMap: TBitMap; | extra copy of RastPort BitMap obsolete
LayerInfo: TLayer_Info; | each screen gets a LayerInfo
FirstGadget: PGadget; | You supply a linked-list of Gadgets for your Screen. This list does not include system Gadgets. You get the standard system Screen Gadgets by default
DetailPen: Byte; | for bar/border/gadget rendering
BlockPen: Byte; | for bar/border/gadget rendering
SaveColor0: Word; | SAve variable for display Beep
BarLayer: PLayer; | This layer is for the Screen and Menu bars
ExtData: Pointer; | general purpose to User data extension
UserData: Pointer; |
end;


TScreenBuffer

Screen buffer structure

Declaration

Source position: intuition.pas line 1640

type TScreenBuffer = record
sb_BitMap: PBitMap; | BitMap of this buffer
sb_DBufInfo: PDBufInfo; | DBufInfo for this buffer
end;

Description

Intuition supports double-buffering in screens, with friendly interaction with menus and certain gadgets. For each buffer, you need to get one of these structures from the AllocScreenBuffer() call. Never allocate your own ScreenBuffer structures! The sb_DBufInfo field is for your use.

See also

AGraphics.AllocDBufInfo

Allocate structure for multi-buffered animation


TSGWork

String gadget message

Declaration

Source position: intuition.pas line 2734

type TSGWork = record
Gadget: PGadget; | the contestant itself
StringInfo: PStringInfo; | easy access to sinfo
WorkBuffer: PChar; | intuition's planned result
PrevBuffer: PChar; | what was there before
Modes: LongWord; | current mode (SGM_*)
IEvent: PInputEvent; | actual event: do not change
Code: Word; | character code, if one Byte
BufferPos: SmallInt; | cursor position
NumChars: SmallInt; |
Actions: LongWord; | what Intuition will do
LongInt_: LongInt; | temp storage for LongInt
GadgetInfo: PGadgetInfo; |
EditOp: Word; | from constants below
end;

Description

The local (application) hook may only change the Code, Actions, WorkBuffer, NumChars, BufferPos and LongInt fields. None of the other fields in the TSGWork structure may be modified.


TStringExtend

Extended string info for Gadgets texts

Declaration

Source position: intuition.pas line 2721

type TStringExtend = record
Font: PTextFont; | Must be an open Font (not TextAttr)
Pens: array [0..1] of Byte; | Color of text/background
ActivePens: array [0..1] of Byte; | Colors when gadget is active
InitialModes: LongWord; | Initial mode flags (e.g. Checked, ISDRAWN, HIGHITEM, ITEMENABLED, MENUTOGGLE, COMMSEQ, ITEMTEXT, CHECKIT)
EditHook: PHook; | If non-nil, must supply WorkBuffer
WorkBuffer: PChar; | Must be as large as StringInfo.Buffer
Reserved: array [0..3] of LongWord; | Set to 0
end;

See also

GFLG_STRINGEXTEND | Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend
GACT_STRINGEXTEND | Activation flag for TGadget.Activation. this String Gadget has PStringExtend
TStringInfo | String Gadget structure


TStringInfo

String Gadget structure

Declaration

Source position: intuition.pas line 427

type TStringInfo = record
Buffer: PChar; | The buffer containing the start and final string
UndoBuffer: PChar; | Optional buffer for undoing current entry
BufferPos: SmallInt; | Character position in Buffer
MaxChars: SmallInt; | Maximal number of chars in Buffer (including #0)
DispPos: SmallInt; | Buffer position of first displayed character
UndoPos: SmallInt; | Character position in the undo buffer
NumChars: SmallInt; | Number of characters currently in Buffer
DispCount: SmallInt; | Number of whole characters visible in Container
CLeft: SmallInt; | Left offset of the container
CTop: SmallInt; | Top offset of the container
Extension: Pointer; | you can initialize this variable before the gadget is submitted to Intuition, and then examine it later to discover what LongInt the user has entered (if the user never plays with the gadget, the value will be unchanged from your initial setting)
_LongInt: LongInt; |
AltKeyMap: Pointer; | If you want this Gadget to use your own Console keymapping, you set the GACT_ALTKEYMAP bit in the Activation flags of the Gadget, and then set this variable to point to your keymap. If you don't set the GACT_ALTKEYMAP, you'll get the standard ASCII keymapping.
end;

See also

PStringInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_STRGADGET


TTabletData

IntuiMessage TabletData

Declaration

Source position: intuition.pas line 543

type TTabletData = record
td_XFraction: Word; | Sub-pixel position of tablet, in screen coordinates, scaled to fill a Word fraction:
td_YFraction: Word; |
td_TabletX: LongWord; | Current tablet coordinates along each axis
td_TabletY: LongWord; |
td_RangeX: LongWord; | Tablet range along each axis. For example, if td_TabletX can take values 0-999, td_RangeX should be 1000.
td_RangeY: LongWord; |
td_TagList: PTagItem; | Pointer to tag-list of additional tablet attributes. TABLETA_*
end;

Description

If your window sets WA_TabletMessages to True, then it will receive extended IntuiMessages (TExtIntuiMessage) whose .eim_TabletData field points at a TabletData structure. This structure contains additional information about the input event.

See also

TExtIntuiMessage

Extended Intuition message structure


TTabletHookData

Declaration

Source position: intuition.pas line 560

type TTabletHookData = record
thd_Screen: PScreen; | Pointer to the active screen: Note: if there are no open screens, thd_Screen will be nil.
thd_Width: LongWord; | Scaled to a standard NTSC width of 640.
thd_Height: LongWord; | Scaled to a standard NTSC height of 400
thd_ScreenChanged: LongInt; | Non-zero if the screen or something about the screen changed since the last time you were invoked
end;


TTransparencyMessage

Declaration

Source position: intuition.pas line 3100

type TTransparencyMessage = record

  Layer: PLayer;

  Region: PRegion;

  NewBounds: PRectangle;

  OldBounds: PRectangle;

end;


TWindow

Window structure

Declaration

Source position: intuition.pas line 613

type TWindow = record
NextWindow: PWindow; | For the linked list in a screen
LeftEdge: SmallInt; | Left edge of window on the screen
TopEdge: SmallInt; | Top edge of window on the screen
Width: SmallInt; | Width of Window
Height: SmallInt; | Height of Window
MouseY: SmallInt; | Y Mouse position relative to upper-left edge of Window
MouseX: SmallInt; | X Mouse position relative to upper-left edge of Window
MinWidth: SmallInt; | Minimum width for resizeable windows
MinHeight: SmallInt; | Minimum height for resizeable windows
MaxWidth: SmallInt; | Maximum width of resizeable windows
MaxHeight: SmallInt; | Maximum height of resizeable windows
Flags: LongWord; | Window Flags (WFLG_*)
MenuStrip: PMenu; | The strip of menu headers
Title: PChar; | The title text for this window
FirstRequest: PRequester; | All active requesters
DMRequest: PRequester; | Double click requester
ReqCount: SmallInt; | Count of requester blocking Window
WScreen: PScreen; | This Window's Screen
RPort: PRastPort; | This Window's very own RastPort
BorderLeft: ShortInt; | Width of window decoration on the left
BorderTop: ShortInt; | Width of window decoration on the top
BorderRight: ShortInt; | Width of window decoration on the right
BorderBottom: ShortInt; | Width of window decoration on the bottom
BorderRPort: PRastPort; | Rastport to draw on the Border
FirstGadget: PGadget; | You supply a linked-list of Gadgets for your Window. This list does not include system gadgets.
Parent: PWindow; | these are for opening/closing the windows
Descendant: PWindow; |
_Pointer: Pointer; | sprite data
PtrHeight: ShortInt; | sprite height (not including sprite padding)
PtrWidth: ShortInt; | sprite width (must be less than or equal to 16)
XOffset: ShortInt; | sprite X offset
YOffset: ShortInt; | sprite Y offset
IDCMPFlags: LongWord; | User-selected flags (IDCMP_*)
UserPort: PMsgPort; | User message port
WindowPort: PMsgPort; | Intuition's message port
MessageKey: PIntuiMessage; |
DetailPen: Byte; | for bar/border/gadget rendering
BlockPen: Byte; | for bar/border/gadget rendering
CheckMark: PImage; | the CheckMark is a pointer to the imagery that will be used when rendering MenuItems of this Window that want to be checkmarked if this is equal to nil, you'll get the default imagery
ScreenTitle: PChar; | if non-nil, Screen title when Window is active
GZZMouseX: SmallInt; | These variables have the mouse coordinates relative to the
GZZMouseY: SmallInt; | inner-Window of GIMMEZEROZERO Windows.
GZZWidth: SmallInt; | width of the inner-Window of GIMMEZEROZERO Windows
GZZHeight: SmallInt; | height of the inner-Window of GIMMEZEROZERO Windows
ExtData: Pointer; | general-purpose pointer to User data extension
UserData: Pointer; | general-purpose pointer to User data extension
WLayer: PLayer; | Layer of the window
IFont: PTextFont; |
MoreFlags: LongWord; |
end;

Description

The border variables describe the window border. If you specify WA_GIMMEZEROZERO when you open the window, then the upper-left of the ClipRect for this window will be upper-left of the BitMap (with correct offsets when in SuperBitMap mode; you must select WA_GIMMEZEROZERO when using SuperBitMap). If you don't specify ZeroZero, then you save memory (no allocation of RastPort, Layer, ClipRect and associated Bitmaps), but you also must offset all your writes by BorderTop, BorderLeft and do your own mini-clipping to prevent writing over the system gadgets


UPFRONTGADGET

Declaration

Source position: intuition.pas line 1332

const UPFRONTGADGET = 0;


UPIMAGE

SYSIA_Which tag data values. Up-arrow gadget image

Declaration

Source position: intuition.pas line 2491

const UPIMAGE = $0B;


US_LEGAL

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 1805

const US_LEGAL = $10;


US_LETTER

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 1804

const US_LETTER = $00;


USEREQIMAGE

Flag for TRequester.Flags. Render linked list ReqImage after BackFill but before gadgets and text

Declaration

Source position: intuition.pas line 464

const USEREQIMAGE = $0020;


W_TRACTOR

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 1807

const W_TRACTOR = $30;


WA_Activate

Tag for OpenWindowTagList(). Activate the window when it opens.

Declaration

Source position: intuition.pas line 1107

const WA_Activate = WA_Dummy + 38;

Description

Activate the window when it opens. Equivalent to TNewWindow.Flags with set WFLG_ACTIVATE. Use this flag carefully, as it can change where the user's input is going.


WA_AmigaKey

Tag for OpenWindowTagList(). Amiga key image for Menus

Declaration

Source position: intuition.pas line 1123

const WA_AmigaKey = WA_Dummy + 49;

Description

Pointer to image for Amiga-key equiv in menus


WA_AutoAdjust

Tag for OpenWindowTagList().Auto adjust window size to screen maximum.

Declaration

Source position: intuition.pas line 1116

const WA_AutoAdjust = WA_Dummy + 45;

Description

Allow Intuition to change the window's position and dimensions in order to fit it on screen. The window's position is adjusted first, then the size. This property may be especially important when using WA_InnerWidth and WA_InnerHeight as border size depends on a user specified font.


WA_Backdrop

Tag for OpenWindowTagList(). Make this window a backdrop window

Declaration

Source position: intuition.pas line 1103

const WA_Backdrop = WA_Dummy + 34;

Description

Make this window a Backdrop window. Equivalent to TNewWindow.Flags with set WFLG_BACKDROP.


WA_BackFill

Tag for OpenWindowTagList(). BackFill hook

Declaration

Source position: intuition.pas line 1095

const WA_BackFill = WA_Dummy + 28;

Description

Provides a "backfill hook" for your window's layer.


WA_BlockPen

Tag for OpenWindowTagList(). Specifies the pen number for window block fills, like the title bar.

Declaration

Source position: intuition.pas line 1063

const WA_BlockPen = WA_Dummy + 6;

Description

Equivalent to TNewWindow.BlockPen The specific color associated with each pen number depends on the screen. Specifying -1 for these values sets the window's detail and block pen the same as the screen's detail and block pen.


WA_Borderless

Tag for OpenWindowTagList(). Make window borderless

Declaration

Source position: intuition.pas line 1106

const WA_Borderless = WA_Dummy + 37;

Description

Open a window with no borders rendered by Intuition. Equivalent to TNewWindow.Flags with set WFLG_BORDERLESS.

Use caution setting this flag, as it may cause visual confusion on the screen. Also, some borders may be rendered if any of the system gadgets are requested, if text is supplied for the window's title bar, or if any of application gadgets are in the borders.


WA_BusyPointer

Tag for OpenWindowTagList(). Request standard busy pointer

Declaration

Source position: intuition.pas line 1128

const WA_BusyPointer = WA_Dummy + 53;

Description

ti_Data is a boolean. Set to True to request the standard busy pointer. This tag may be passed to OpenWindowTagList() or SetWindowPointerA().


WA_Checkmark

Tag for OpenWindowTagList(). Image for Menu entries

Declaration

Source position: intuition.pas line 1067

const WA_Checkmark = WA_Dummy + 10;

Description

A pointer to an Image structure, which is to be used as the checkmark image in this window's menus. To use the default checkmark, do not specify this tag or set this field to nil. Equivalent to TNewWindow.CheckMark


WA_CloseGadget

Tag for OpenWindowTagList(). Add CloseGadget to window

Declaration

Source position: intuition.pas line 1102

const WA_CloseGadget = WA_Dummy + 33;

Description

Setting this flag attaches a close gadget to the window. When the user selects this gadget, Intuition transmits a message to the application. It is up to the application to close the window with a CloseWindow() call. Intuition places the close gadget in the upper left corner of the window. Equivalent to TNewWindow.Flags with set WFLG_CLOSEGADGET.


WA_Colors

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1088

const WA_Colors = WA_Dummy + 25;

Description

A ColorSpec array for colors to be set when this window is active. This is not implemented, and may not be, since the default values to restore would be hard to track. We'd like to at least support per-window colors for the mouse pointer sprite.


WA_CustomScreen

Tag for OpenWindowTagList(). Open the window on a specific screen

Declaration

Source position: intuition.pas line 1070

const WA_CustomScreen = WA_Dummy + 13;

Description

A pointer to the Screen structure of a screen created by this application. The window will be opened on this screen. The custom screen must already be opened when the OpenWindowTagList() call is made. Equivalent to NewWindow.Screen, also implies TNewWindow.Type of CUSTOMSCREEN_f.


WA_DepthGadget

Tag for OpenWindowTagList(). Add Depthgadget to window

Declaration

Source position: intuition.pas line 1101

const WA_DepthGadget = WA_Dummy + 32;

Description

Setting this flag adds a depth gadget to the window. This allows the user to change the window's depth arrangement with respect to other windows on the screen. Intuition places the depth gadget in the upper right corner of the window. Equivalent to TNewWindow.Flags with set WFLG_DEPTHGADGET.


WA_DetailPen

Tag for OpenWindowTagList(). Specifies the pen number for the rendering of window details like gadgets or text in the title bar.

Declaration

Source position: intuition.pas line 1062

const WA_DetailPen = WA_Dummy + 5;

Description

Equivalent to TNewWindow.DetailPen The specific color associated with each pen number depends on the screen. Specifying -1 for these values sets the window's detail and block pen the same as the screen's detail and block pen.


WA_DragBar

Tag for OpenWindowTagList(). Titlebar used to drag window

Declaration

Source position: intuition.pas line 1100

const WA_DragBar = WA_Dummy + 31;

Description

This flag turns the entire title bar of the window into a drag gadget, allowing the user to position the window by clicking in the title bar and dragging the mouse. Equivalent to TNewWindow.Flags with set WFLG_DRAGBAR.


WA_Dummy

Starting for window TagItems

Declaration

Source position: intuition.pas line 1056

const WA_Dummy = TAG_USER + 99;


WA_ExtraGadget_Iconify

Declaration

Source position: intuition.pas line 1152

const WA_ExtraGadget_Iconify = WA_Dummy + 153;


WA_ExtraGadget_Jump

Declaration

Source position: intuition.pas line 1157

const WA_ExtraGadget_Jump = WA_Dummy + 158;


WA_ExtraGadget_Lock

Declaration

Source position: intuition.pas line 1153

const WA_ExtraGadget_Lock = WA_Dummy + 154;


WA_ExtraGadget_MUI

Declaration

Source position: intuition.pas line 1154

const WA_ExtraGadget_MUI = WA_Dummy + 155;


WA_ExtraGadget_PopUp

Declaration

Source position: intuition.pas line 1155

const WA_ExtraGadget_PopUp = WA_Dummy + 156;


WA_ExtraGadget_Snapshot

Declaration

Source position: intuition.pas line 1156

const WA_ExtraGadget_Snapshot = WA_Dummy + 157;


WA_ExtraGadgetsStartID

Declaration

Source position: intuition.pas line 1149

const WA_ExtraGadgetsStartID = WA_Dummy + 152;


WA_ExtraTitlebarGadgets

Declaration

Source position: intuition.pas line 1147

const WA_ExtraTitlebarGadgets = WA_Dummy + 151;


WA_Flags

Tag for OpenWindowTagList(). Window Flags (WFLG_*)

Declaration

Source position: intuition.pas line 1065

const WA_Flags = WA_Dummy + 8;

Description

Multiple initialization of window flags, equivalent to TNewWindow.Flags. Use the WFLG_* constants to initialize this field, multiple bits may be set by ORing the values together.


WA_FrontWindow

Declaration

Source position: intuition.pas line 1182

const WA_FrontWindow = WA_Dummy + 165;


WA_Gadgets

Tag for OpenWindowTagList(). List of Gadgets

Declaration

Source position: intuition.pas line 1066

const WA_Gadgets = WA_Dummy + 9;

Description

A pointer to the first in the linked list of Gadget structures that are to be included in this window. These gadgets are application gadgets, not system gadgets. Equivalent to TNewWindow.FirstGadget


WA_GimmeZeroZero

Tag for OpenWindowTagList(). Zero-Zero window

Declaration

Source position: intuition.pas line 1117

const WA_GimmeZeroZero = WA_Dummy + 46;

Description

Set this tag to create a GimmeZeroZero window. GimmeZeroZero windows have the window border and border gadgets rendered into an extra layer. This extra layer slows down window operations, thus it is recommended that applications only use GimmeZeroZero windows when they are required. For clipping graphics to the area within the borders of a window. Equivalent to TNewWindow.Flags with set WFLG_GIMMEZEROZERO.


WA_HasAlpha

Declaration

Source position: intuition.pas line 1187

const WA_HasAlpha = WA_Dummy + 169;


WA_Height

Tag for OpenWindowTagList(). The initial window height in pixels

Declaration

Source position: intuition.pas line 1061

const WA_Height = WA_Dummy + 4;

Description

Equivalent to TNewWindow.Height


WA_HelpGroup

Tag for OpenWindowTagList(). Form Help groups

Declaration

Source position: intuition.pas line 1138

const WA_HelpGroup = WA_Dummy + 56;

Description

When the active window has gadget help enabled, other windows of the same HelpGroup number will also get GadgetHelp. This allows GadgetHelp to work for multi-windowed applications. Pass the ID as ti_Data to all your windows.

See also

HelpControl

Enable/disable Gadget-Help feature.


WA_HelpGroupWindow

Tag for OpenWindowTagList(). Form Help group windows

Declaration

Source position: intuition.pas line 1141

const WA_HelpGroupWindow = WA_Dummy + 57;

Description

When the active window has gadget help enabled, other windows of the same HelpGroup will also get GadgetHelp. This allows GadgetHelp to work for multi-windowed applications. As an alternative to WA_HelpGroup, you can pass a pointer to any other window of the same group to join its help group. Defaults to nil, which has no effect.

See also

HelpControl

Enable/disable Gadget-Help feature.


WA_HitLevel

Declaration

Source position: intuition.pas line 1194

const WA_HitLevel = WA_Dummy + 175;


WA_IDCMP

Tag for OpenWindowTagList(). Which events should be reported

Declaration

Source position: intuition.pas line 1064

const WA_IDCMP = WA_Dummy + 7;

Description

IDCMP flags tell Intuition what user input events the application wants to be notified about. (see IDCMP_*) Equivalent to TNewWindow.IDCMPFlags

If any of these flags are set, Intuition creates a pair of message ports for the window (one internal to Intuition and one used by the application). These ports are for handling messages about user input events. If WA_IDCMP is nil or unspecified, no IDCMP is created for this window.

The ModifyIDCMP() function can be used to change the window's IDCMP flags after it is open.


WA_InnerHeight

Tag for OpenWindowTagList(). Inner height of window

Declaration

Source position: intuition.pas line 1078

const WA_InnerHeight = WA_Dummy + 20;

Description

Specify the dimensions of the interior region of the window, i.e., inside the border, independent of the border widths. When using this flag an application will probably want to set WA_AutoAdjust.


WA_InnerWidth

Tag for OpenWindowTagList(). Inner width for the window

Declaration

Source position: intuition.pas line 1077

const WA_InnerWidth = WA_Dummy + 19;

Description

Specify the dimensions of the interior region of the window, i.e., inside the border, independent of the border widths. When using this flag an application will probably want to set WA_AutoAdjust.


WA_Left

Tag for OpenWindowTagList(). The initial x position

Declaration

Source position: intuition.pas line 1058

const WA_Left = WA_Dummy + 1;

Description

Describe where the window will first appear on the screen and how large it will be initially. These dimensions are relative to the top left corner of the screen, which has the coordinates (0,0).

WA_Left is the initial x position, or offset, from the left edge of the screen. The leftmost pixel is pixel 0, and values increase to the right. Equivalent to TNewWindow.LeftEdge.


WA_MaxHeight

Tag for OpenWindowTagList(). Minimum height for resizeable windows

Declaration

Source position: intuition.pas line 1075

const WA_MaxHeight = WA_Dummy + 18;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored. Values are measured in pixels. Use -1 for this value to allow for a window as tall as the screen. This is the complete screen, not the visible part or display clip.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MaxHeight Use the WindowLimits() function to change window size limits after the window is opened.


WA_MaxWidth

Tag for OpenWindowTagList(). Maximum width for resizeable windows

Declaration

Source position: intuition.pas line 1074

const WA_MaxWidth = WA_Dummy + 17;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored. Values are measured in pixels. Use -1 for this value to allow for a window as wide as the screen. This is the complete screen, not the visible part or display clip.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MaxWidth Use the WindowLimits() function to change window size limits after the window is opened.


WA_MenuHelp

Tag for OpenWindowTagList(). Enabled Help button for Menu

Declaration

Source position: intuition.pas line 1120

const WA_MenuHelp = WA_Dummy + 47;

Description

Enables IDCMP_MENUHELP: pressing Help during menus will return IDCMP_MENUHELP message.


WA_MinHeight

Tag for OpenWindowTagList(). Minimum height for resizeable windows

Declaration

Source position: intuition.pas line 1073

const WA_MinHeight = WA_Dummy + 16;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MinHeight Use the WindowLimits() function to change window size limits after the window is opened.


WA_MinWidth

Tag for OpenWindowTagList(). Minimum width for resizeable windows

Declaration

Source position: intuition.pas line 1072

const WA_MinWidth = WA_Dummy + 15;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MinWidth Use the WindowLimits() function to change window size limits after the window is opened.


WA_MouseQueue

Tag for OpenWindowTagList(). Mouse event queue size

Declaration

Source position: intuition.pas line 1094

const WA_MouseQueue = WA_Dummy + 27;

Description

An initial value for the mouse message backlog limit for this window. The SetMouseQueue() function will change this limit after the window is opened.


WA_NewLookMenus

Tag for OpenWindowTagList(). Activate NewLook menus

Declaration

Source position: intuition.pas line 1122

const WA_NewLookMenus = WA_Dummy + 48;

Description

Set to True if you want NewLook menus.


WA_NoCareRefresh

Tag for OpenWindowTagList(). Do not need Refresh message

Declaration

Source position: intuition.pas line 1105

const WA_NoCareRefresh = WA_Dummy + 36;

Description

This window does not want IDCMP_REFRESHWINDOW events. Set this flag to prevent the window from receiving refresh window messages. Equivalent to TNewWindow.Flags with set WFLG_NOCAREREFRESH. Intuition will manage BeginRefresh() and EndRefresh() internally.


WA_NotifyDepth

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1124

const WA_NotifyDepth = WA_Dummy + 50;

Description

Requests IDCMP_CHANGEWINDOW message when window is depth arranged (imsg^.Code = CWCODE_DEPTH)


WA_Opacity

Declaration

Source position: intuition.pas line 1186

const WA_Opacity = WA_Dummy + 168;


WA_Parent

Declaration

Source position: intuition.pas line 1183

const WA_Parent = WA_Dummy + 166;


WA_Pointer

Tag for OpenWindowTagList(). Custom Pointer for window.

Declaration

Source position: intuition.pas line 1126

const WA_Pointer = WA_Dummy + 52;

Description

Allows you to specify a custom pointer for your window. ti_Data points to a pointer object you obtained via "pointerclass". Nil signifies the default pointer. This tag may be passed to OpenWindowTagList() or SetWindowPointerA().


WA_PointerDelay

Tag for OpenWindowTagList(). Delay of pointer change

Declaration

Source position: intuition.pas line 1130

const WA_PointerDelay = WA_Dummy + 54;

Description

ti_Data is a boolean. Set to True to request that the changing of the pointer be slightly delayed. The change will be called off if you call SetPointer() before the delay expires. This allows you to post a busy-pointer even if you think the busy-time may be very short, without fear of a flashing pointer. This tag may be passed to OpenWindowTagList() or SetWindowPointerA().


WA_PointerType

Declaration

Source position: intuition.pas line 1181

const WA_PointerType = WA_Dummy + 164;


WA_PubScreen

Tag for OpenWindowTagList(). Specify screen to open window on

Declaration

Source position: intuition.pas line 1083

const WA_PubScreen = WA_Dummy + 22;

Description

Open the window as a visitor window on the public screen whose address is in the ti_Data field of the WA_PubScreen TagItem. To ensure that this screen remains open until OpenWindowTagList() has completed, the application must either be the screen's owner, have a window open on the screen, or use LockPubScreen(). Setting this tag implies screen type of PUBLICSCREEN_f.


WA_PubScreenFallBack

Tag for OpenWindowTagList(). Fallback screen to default

Declaration

Source position: intuition.pas line 1085

const WA_PubScreenFallBack = WA_Dummy + 23;

Description

A Boolean, specifies whether a visitor window should "fall back" to the default public screen (or Workbench) if the named public screen isn't available This tag is only meaningful when used in conjunction with WA_PubScreenName.


WA_PubScreenName

Tag for OpenWindowTagList(). Choose screen by name

Declaration

Source position: intuition.pas line 1082

const WA_PubScreenName = WA_Dummy + 21;

Description

Declares that the window is to be opened as a visitor on the public screen whose name is pointed to by the ti_Data field of the WA_PubScreenName TagItem. The OpenWindowTagList() call will fail if it cannot obtain a lock on the named public screen and no fall back name (WA_PubScreenFallBack) is specified. Setting this tag implies screen type of PUBLICSCREEN_f.


WA_ReportMouse

Tag for OpenWindowTagList(). Report mouse events

Declaration

Source position: intuition.pas line 1104

const WA_ReportMouse = WA_Dummy + 35;

Description

Send mouse movement events to the window as x,y coordinates. Also see the description of the IDCMP flag IDCMP_MOUSEMOVE. Equivalent to TNewWindow.Flags with set WFLG_REPORTMOUSE.

The WFLG_REPORTMOUSE flag in the Flags field of the Window structure may be modified on the fly by the program. Changing this flag must be done as an atomic operation. If you are unsure of getting an atomic operation from your compiler, you may wish to do this operation in assembler, or bracket the code with a Forbid()/Permit() pair.

The use of the ReportMouse() function is strongly discouraged, due to historic confusion over the parameter ordering.


WA_RMBTrap

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1108

const WA_RMBTrap = WA_Dummy + 39;

Description

Catch right mouse button events for application use. Set this flag to disable menu operations for the window. When set, right mouse button events will be received as IDCMP_MOUSEBUTTONS with the MENUUP and MENUDOWN qualifiers. Equivalent to TNewWindow.Flags with set WFLG_RMBTRAP.

The WFLG_RMBTRAP flag in the Window structure Flags field may be modified on the fly by the program. Changing this flag must be done as an atomic operation, as Intuition can preempt a multistep set or clear operation. An atomic operation can be done in assembler, using instructions that operate directly on memory. If you are unsure of generating such an instruction, place the operation within a Forbid()/Permit() pair. This will ensure proper operation by disabling multitasking while the flag is being changed.


WA_RptQueue

Tag for OpenWindowTagList(). Key event queue size

Declaration

Source position: intuition.pas line 1096

const WA_RptQueue = WA_Dummy + 29;

Description

An initial value of repeat key backlog limit for this window.


WA_ScreenTitle

Tag for OpenWindowTagList(). Title for screen when window is activated

Declaration

Source position: intuition.pas line 1069

const WA_ScreenTitle = WA_Dummy + 12;

Description

A pointer to a #0 terminated text string, which is used as the screen title and is displayed, when the window is active, in the screen's title bar. After the screen has been opened the screen's title may be changed by calling SetWindowTitles().


WA_ShadowBottom

Declaration

Source position: intuition.pas line 1200

const WA_ShadowBottom = WA_Dummy + 179;


WA_ShadowLeft

Declaration

Source position: intuition.pas line 1198

const WA_ShadowLeft = WA_Dummy + 177;


WA_ShadowRight

Declaration

Source position: intuition.pas line 1199

const WA_ShadowRight = WA_Dummy + 178;


WA_ShadowTop

Declaration

Source position: intuition.pas line 1197

const WA_ShadowTop = WA_Dummy + 176;


WA_SimpleRefresh

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1110

const WA_SimpleRefresh = WA_Dummy + 41;

Description

The application program takes complete responsibility for updating the window. Only specify if True. Equivalent to TNewWindow.Flags with set WFLG_SIMPLE_REFRESH.


WA_SizeBBottom

Tag for OpenWindowTagList(). Place the size gadget in the bottom border.

Declaration

Source position: intuition.pas line 1113

const WA_SizeBBottom = WA_Dummy + 44;

Description

Place the size gadget in the bottom border. Equivalent to TNewWindow.Flags with set WFLG_SIZEBBOTTOM.


WA_SizeBRight

Tag for OpenWindowTagList(). Place the size gadget in the right border.

Declaration

Source position: intuition.pas line 1112

const WA_SizeBRight = WA_Dummy + 43;

Description

Place the size gadget in the right border. Equivalent to TNewWindow.Flags with set WFLG_SIZEBRIGHT.


WA_SizeDenominator

Declaration

Source position: intuition.pas line 1190

const WA_SizeDenominator = WA_Dummy + 172;


WA_SizeExtraHeight

Declaration

Source position: intuition.pas line 1192

const WA_SizeExtraHeight = WA_Dummy + 174;


WA_SizeExtraWidth

Declaration

Source position: intuition.pas line 1191

const WA_SizeExtraWidth = WA_Dummy + 173;


WA_SizeGadget

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1099

const WA_SizeGadget = WA_Dummy + 30;

Description

Specifying this flag tells Intuition to add a sizing gadget to the window. Intuition places the sizing gadget in the lower right corner of the window. By default, the right border is adjusted to accommodate the sizing gadget, but the application can specify one of the following two flags to change this behavior. The WFLG_SIZEBRIGHT flag puts the sizing gadget in the right border. The WFLG_SIZEBBOTTOM flag puts the sizing gadget in the bottom border. Both flags may be specified, placing the gadget in both borders. Equivalent to TNewWindow.Flags with set WFLG_SIZEGADGET.


WA_SizeNumerator

Declaration

Source position: intuition.pas line 1189

const WA_SizeNumerator = WA_Dummy + 171;


WA_SkinInfo

Declaration

Source position: intuition.pas line 1159

const WA_SkinInfo = WA_Dummy + 159;


WA_SmartRefresh

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1111

const WA_SmartRefresh = WA_Dummy + 42;

Description

Intuition handles all window updating, except for parts of the window revealed when the window is sized larger. Only specify if True. Equivalent to TNewWindow.Flags with set WFLG_SMART_REFRESH.

WA_SmartRefresh windows without a sizing gadget will never receive refresh events due to the user sizing the window. However, if the application sizes the window through a call like ChangeWindowBox(), ZipWindow() or SizeWindow(), a refresh event may be generated. Use WA_NoCareRefresh to disable refresh events.


WA_SuperBitMap

Tag for OpenWindowTagList(). SuperBitmap for scrolling windows

Declaration

Source position: intuition.pas line 1071

const WA_SuperBitMap = WA_Dummy + 14;

Description

This is a pointer to a BitMap structure for a SuperBitMap window. The application will be allocating and maintaining its own bitmap. Equivalent to TNewWindow.BitMap. Setting this tag implies the WFLG_SUPER_BITMAP property.


WA_TabletMessages

Tag for OpenWindowTagList(). Enabled tablet messages

Declaration

Source position: intuition.pas line 1134

const WA_TabletMessages = WA_Dummy + 55;

Description

ti_Data is a boolean. Set to True to request that tablet information be included in TIntuiMessage sent to your window. For a pointer to the TabletData, examine the ExtIntuiMessage^.eim_TabletData field.


WA_Title

Tag for OpenWindowTagList(). Title for window

Declaration

Source position: intuition.pas line 1068

const WA_Title = WA_Dummy + 11;

Description

A pointer to a #0 terminated text string, which is used as the window title and is displayed in the window's title bar.

Intuition draws the text using the colors defined in the DrawInfo pen array (TDrawInfo.dri_Pens) and displays as much as possible of the window title, depending upon the current width of the title bar.

The title is rendered in the screen's default font.

A title bar is added to the window if any of the properties WA_DragBar (WFLG_DRAGBAR), WA_DepthGadget (WFLG_DEPTHGADGET), WA_CloseGadget (WFLG_CLOSEGADGET) or WA_Zoom are specified, or if text is specified for a window title. If no text is provided for the title, but one or more of these system gadgets are specified, the title bar will be blank. Equivalent to TNewWindow.Title.


WA_ToolbarWindow

Declaration

Source position: intuition.pas line 1178

const WA_ToolbarWindow = WA_Dummy + 163;


WA_Top

Tag for OpenWindowTagList(). The initial y position

Declaration

Source position: intuition.pas line 1059

const WA_Top = WA_Dummy + 2;

Description

Describe where the window will first appear on the screen and how large it will be initially. These dimensions are relative to the top left corner of the screen, which has the coordinates (0,0).

WA_Top is the initial y position, or offset, from the top edge of the screen. The topmost pixel is pixel 0, and values increase to the bottom. Equivalent to TNewWindow.TopEdge.


WA_TransparentRegion

Declaration

Source position: intuition.pas line 1166

const WA_TransparentRegion = WA_Dummy + 160;


WA_TransparentRegionHook

Declaration

Source position: intuition.pas line 1169

const WA_TransparentRegionHook = WA_Dummy + 161;


WA_UserPort

Declaration

Source position: intuition.pas line 1173

const WA_UserPort = WA_Dummy + 162;


WA_VisibleOnMaximize

Declaration

Source position: intuition.pas line 1202

const WA_VisibleOnMaximize = WA_Dummy + 180;


WA_WBenchWindow

Tag for OpenWindowTagList(). Private

Declaration

Source position: intuition.pas line 1109

const WA_WBenchWindow = WA_Dummy + 40;

Description

Private tag


WA_Width

Tag for OpenWindowTagList(). The initial window width in pixels

Declaration

Source position: intuition.pas line 1060

const WA_Width = WA_Dummy + 3;

Description

Equivalent to TNewWindow.Width


WA_WindowName

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1087

const WA_WindowName = WA_Dummy + 24;


WA_Zoom

Tag for OpenWindowTagList(). Define zoom size for window

Declaration

Source position: intuition.pas line 1091

const WA_Zoom = WA_Dummy + 26;

Description

Pointer to an array of four SmallInts, the initial LeftEdge, TopEdge, Width and Height values for the alternate zoom position and size. It also specifies that the application wants a zoom gadget for the window, whether or not it has a sizing gadget.

A zoom gadget is always supplied to a window if it has both depth and sizing gadgets. This tag allows the application to open a window with a zoom gadget when the window does not have both the depth and sizing gadgets.


WAC_ACTIVATEWINDOW

Declaration

Source position: intuition.pas line 3077

const WAC_ACTIVATEWINDOW = WAC_DUMMY + 10;


WAC_CHANGEWINDOWBOX

Declaration

Source position: intuition.pas line 3072

const WAC_CHANGEWINDOWBOX = WAC_DUMMY + 5;


WAC_DUMMY

Declaration

Source position: intuition.pas line 3066

const WAC_DUMMY = $0001;


WAC_FAMILYTOBACK

Declaration

Source position: intuition.pas line 3084

const WAC_FAMILYTOBACK = WAC_DUMMY + 16;


WAC_FAMILYTOFRONT

Declaration

Source position: intuition.pas line 3083

const WAC_FAMILYTOFRONT = WAC_DUMMY + 15;


WAC_HIDEWINDOW

Declaration

Source position: intuition.pas line 3067

const WAC_HIDEWINDOW = WAC_DUMMY;


WAC_MAXIMIZEWINDOW

Declaration

Source position: intuition.pas line 3079

const WAC_MAXIMIZEWINDOW = WAC_DUMMY + 11;


WAC_MINIMIZEWINDOW

Declaration

Source position: intuition.pas line 3080

const WAC_MINIMIZEWINDOW = WAC_DUMMY + 12;


WAC_MOVEWINDOW

Declaration

Source position: intuition.pas line 3070

const WAC_MOVEWINDOW = WAC_DUMMY + 3;


WAC_MOVEWINDOWINFRONTOF

Declaration

Source position: intuition.pas line 3076

const WAC_MOVEWINDOWINFRONTOF = WAC_DUMMY + 9;


WAC_OPENMENU

Declaration

Source position: intuition.pas line 3082

const WAC_OPENMENU = WAC_DUMMY + 14;


WAC_RESTOREINITIALSIZEPOS

Declaration

Source position: intuition.pas line 3081

const WAC_RESTOREINITIALSIZEPOS = WAC_DUMMY + 13;


WAC_SENDIDCMPCLOSE

Declaration

Source position: intuition.pas line 3069

const WAC_SENDIDCMPCLOSE = WAC_DUMMY + 2;


WAC_SHOWWINDOW

Declaration

Source position: intuition.pas line 3068

const WAC_SHOWWINDOW = WAC_DUMMY + 1;


WAC_SIZEWINDOW

Declaration

Source position: intuition.pas line 3071

const WAC_SIZEWINDOW = WAC_DUMMY + 4;


WAC_WINDOWTOBACK

Declaration

Source position: intuition.pas line 3074

const WAC_WINDOWTOBACK = WAC_DUMMY + 7;


WAC_WINDOWTOFRONT

Declaration

Source position: intuition.pas line 3073

const WAC_WINDOWTOFRONT = WAC_DUMMY + 6;


WAC_ZIPWINDOW

Declaration

Source position: intuition.pas line 3075

const WAC_ZIPWINDOW = WAC_DUMMY + 8;


WAT_DUMMY

Declaration

Source position: intuition.pas line 3087

const WAT_DUMMY = TAG_USER;


WAT_MOVEWBEHINDWINDOW

Declaration

Source position: intuition.pas line 3096

const WAT_MOVEWBEHINDWINDOW = WAT_DUMMY + 9;


WAT_MOVEWINDOWX

Declaration

Source position: intuition.pas line 3088

const WAT_MOVEWINDOWX = WAT_DUMMY + 1;


WAT_MOVEWINDOWY

Declaration

Source position: intuition.pas line 3089

const WAT_MOVEWINDOWY = WAT_DUMMY + 2;


WAT_SIZEWINDOWX

Declaration

Source position: intuition.pas line 3090

const WAT_SIZEWINDOWX = WAT_DUMMY + 3;


WAT_SIZEWINDOWY

Declaration

Source position: intuition.pas line 3091

const WAT_SIZEWINDOWY = WAT_DUMMY + 4;


WAT_WINDOWBOXHEIGHT

Declaration

Source position: intuition.pas line 3095

const WAT_WINDOWBOXHEIGHT = WAT_DUMMY + 8;


WAT_WINDOWBOXLEFT

Declaration

Source position: intuition.pas line 3092

const WAT_WINDOWBOXLEFT = WAT_DUMMY + 5;


WAT_WINDOWBOXTOP

Declaration

Source position: intuition.pas line 3093

const WAT_WINDOWBOXTOP = WAT_DUMMY + 6;


WAT_WINDOWBOXWIDTH

Declaration

Source position: intuition.pas line 3094

const WAT_WINDOWBOXWIDTH = WAT_DUMMY + 7;


WBENCHCLOSE

Code for IDCMP_WBENCHMESSAGE

Declaration

Source position: intuition.pas line 903

const WBENCHCLOSE = $0002;


WBENCHOPEN

Code for IDCMP_WBENCHMESSAGE

Declaration

Source position: intuition.pas line 902

const WBENCHOPEN = $0001;


WBENCHSCREEN_f

Screentype flag for TScreen.Flags and TNewScreen.SType. The Workbench itself

Declaration

Source position: intuition.pas line 1403

const WBENCHSCREEN_f = 1 shl 0;


WFLG_ACTIVATE

Flag for WA_Flags or TNewWindow.Flags. When window opens, it is active.

Declaration

Source position: intuition.pas line 929

const WFLG_ACTIVATE = $00001000;


WFLG_BACKDROP

Flag for WA_Flags or TNewWindow.Flags. This is a backdrop window

Declaration

Source position: intuition.pas line 925

const WFLG_BACKDROP = $00000100;


WFLG_BORDERLESS

Flag for WA_Flags or TNewWindow.Flags. Get a window sans border.

Declaration

Source position: intuition.pas line 928

const WFLG_BORDERLESS = $00000800;


WFLG_CLOSEGADGET

Flag for WA_Flags or TNewWindow.Flags. Include close-box system-gadget

Declaration

Source position: intuition.pas line 913

const WFLG_CLOSEGADGET = $00000008;


WFLG_DEPTHGADGET

Flag for WA_Flags or TNewWindow.Flags. Include depth arrangement gadget

Declaration

Source position: intuition.pas line 912

const WFLG_DEPTHGADGET = $00000004;


WFLG_DRAGBAR

Flag for WA_Flags or TNewWindow.Flags. Include dragging system-gadget

Declaration

Source position: intuition.pas line 911

const WFLG_DRAGBAR = $00000002;


WFLG_GIMMEZEROZERO

Flag for WA_Flags or TNewWindow.Flags. A GimmeZeroZero window

Declaration

Source position: intuition.pas line 927

const WFLG_GIMMEZEROZERO = $00000400;


WFLG_HASZOOM

Flag for TWindow.Flags. Window has a zoom gadget.

Declaration

Source position: intuition.pas line 947

const WFLG_HASZOOM = $20000000;


WFLG_INREQUEST

Flag for WA_Flags or TNewWindow.Flags. Private. This window is in request mode.

Declaration

Source position: intuition.pas line 939

const WFLG_INREQUEST = $00004000;


WFLG_MENUSTATE

Flag for WA_Flags or TNewWindow.Flags. Private. Window is active with menus on.

Declaration

Source position: intuition.pas line 940

const WFLG_MENUSTATE = $00008000;


WFLG_NEWLOOKMENUS

Flag for WA_Flags or TNewWindow.Flags. Window has NewLook menus.

Declaration

Source position: intuition.pas line 936

const WFLG_NEWLOOKMENUS = $00200000;


WFLG_NOCAREREFRESH

Flag for WA_Flags or TNewWindow.Flags. Not to be bothered with REFRESH

Declaration

Source position: intuition.pas line 932

const WFLG_NOCAREREFRESH = $00020000;


WFLG_NW_EXTENDED

Flag for TNewWindow.Flags. Extension data provided see TExtNewWindow.

Declaration

Source position: intuition.pas line 934

const WFLG_NW_EXTENDED = $00040000;


WFLG_OTHER_REFRESH

Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap

Declaration

Source position: intuition.pas line 923

const WFLG_OTHER_REFRESH = $000000C0;


WFLG_REFRESHBITS

Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap

Declaration

Source position: intuition.pas line 919

const WFLG_REFRESHBITS = $000000C0;


WFLG_REPORTMOUSE

Flag for WA_Flags or TNewWindow.Flags. Fire an event for every mouse move

Declaration

Source position: intuition.pas line 926

const WFLG_REPORTMOUSE = $00000200;


WFLG_RMBTRAP

Flag for WA_Flags or TNewWindow.Flags. Fire right mouse button events

Declaration

Source position: intuition.pas line 931

const WFLG_RMBTRAP = $00010000;


WFLG_SIMPLE_REFRESH

Flag for WA_Flags or TNewWindow.Flags. Enable Simple Refresh

Declaration

Source position: intuition.pas line 921

const WFLG_SIMPLE_REFRESH = $00000040;


WFLG_SIZEBBOTTOM

Flag for WA_Flags or TNewWindow.Flags. Size gadget uses bottom border

Declaration

Source position: intuition.pas line 916

const WFLG_SIZEBBOTTOM = $00000020;


WFLG_SIZEBRIGHT

Flag for WA_Flags or TNewWindow.Flags. Size gadget uses right border

Declaration

Source position: intuition.pas line 915

const WFLG_SIZEBRIGHT = $00000010;


WFLG_SIZEGADGET

Flag for WA_Flags or TNewWindow.Flags. Include sizing system-gadget

Declaration

Source position: intuition.pas line 910

const WFLG_SIZEGADGET = $00000001;


WFLG_SMART_REFRESH

Flag for WA_Flags or TNewWindow.Flags. Enable smart Refresh

Declaration

Source position: intuition.pas line 920

const WFLG_SMART_REFRESH = $00000000;


WFLG_SUPER_BITMAP

Flag for WA_Flags or TNewWindow.Flags. Has super bitmap

Declaration

Source position: intuition.pas line 922

const WFLG_SUPER_BITMAP = $00000080;


WFLG_VISITOR

Flag for TWindow.Flags. Visitor window.

Declaration

Source position: intuition.pas line 945

const WFLG_VISITOR = $08000000;


WFLG_WBENCHWINDOW

Flag for TWindow.Flags. Workbench tool only Window

Declaration

Source position: intuition.pas line 942

const WFLG_WBENCHWINDOW = $02000000;


WFLG_WINDOWACTIVE

Flag for WA_Flags or TNewWindow.Flags. Private. This window is the active one.

Declaration

Source position: intuition.pas line 938

const WFLG_WINDOWACTIVE = $00002000;


WFLG_WINDOWREFRESH

Flag for TWindow.Flags. Window is currently refreshing

Declaration

Source position: intuition.pas line 941

const WFLG_WINDOWREFRESH = $01000000;


WFLG_WINDOWTICKED

Flag for TWindow.Flags. Only one timer tick at a time

Declaration

Source position: intuition.pas line 943

const WFLG_WINDOWTICKED = $04000000;


WFLG_ZOOMED

Flag for TWindow.Flags. Identifies "Zoom State"

Declaration

Source position: intuition.pas line 946

const WFLG_ZOOMED = $10000000;


WM_Dummy

Declaration

Source position: intuition.pas line 1208

const WM_Dummy = WA_Dummy;


WM_ObtainEvents

Declaration

Source position: intuition.pas line 1210

const WM_ObtainEvents = WM_Dummy + 2;


WM_OpenMenu

Declaration

Source position: intuition.pas line 1209

const WM_OpenMenu = WM_Dummy + 1;


WM_ReleaseEvents

Declaration

Source position: intuition.pas line 1221

const WM_ReleaseEvents = WM_Dummy + 3;


ZOOMIMAGE

SYSIA_Which tag data values. Window zoom gadget image

Declaration

Source position: intuition.pas line 2486

const ZOOMIMAGE = $01;


DP_2DFACSHIFT

Declaration

Source position: keymap.pas line 90

const DP_2DFACSHIFT = 4;


DP_2DINDEXMASK

Declaration

Source position: keymap.pas line 89

const DP_2DINDEXMASK = $0f;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DPB_DEAD

Declaration

Source position: keymap.pas line 86

const DPB_DEAD = 3;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DPB_MOD

Declaration

Source position: keymap.pas line 84

const DPB_MOD = 0;


DPF_DEAD

Declaration

Source position: keymap.pas line 87

const DPF_DEAD = 1 shl DPB_DEAD;


DPF_MOD

Declaration

Source position: keymap.pas line 85

const DPF_MOD = 1 shl DPB_MOD;


Reference for unit 'keymap'

uses

  System,

  exec,

This unit contains the types and wrapper functions for the exec.library.

  inputevent;


Reference for unit 'keymap': Constants

DPB_DEAD

DPB_MOD

DPF_DEAD

DPF_MOD

DP_2DFACSHIFT

DP_2DINDEXMASK

KCB_ALT

KCB_CONTROL

KCB_DEAD

KCB_DOWNUP

KCB_NOP

KCB_SHIFT

KCB_STRING

KCF_ALT

KCF_CONTROL

KCF_DEAD

KCF_DOWNUP

KCF_NOP

KCF_SHIFT

KCF_STRING

KC_NOQUAL

KC_VANILLA

KEYMAPNAME


Reference for unit 'keymap': Types

PExtendedKeyMapNode

PKeyMap

PKeymapNode

PKeyMapResource

PUCS4_CharsetCode

PUCS4_CharsetConvTable

PUCS4_ConvTable

TExtendedKeyMapNode

TKeyMap

TKeyMapNode

TKeyMapResource

TUCS4_CharsetCode

TUCS4_CharsetConvTable

TUCS4_ConvTable


KC_NOQUAL

Declaration

Source position: keymap.pas line 62

const KC_NOQUAL = 0;


KC_VANILLA

Declaration

Source position: keymap.pas line 63

const KC_VANILLA = 7;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

KCB_ALT

Declaration

Source position: keymap.pas line 67

const KCB_ALT = 1;


KCB_CONTROL

Declaration

Source position: keymap.pas line 69

const KCB_CONTROL = 2;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

KCB_DEAD

Declaration

Source position: keymap.pas line 74

const KCB_DEAD = 5;


KCB_DOWNUP

Declaration

Source position: keymap.pas line 71

const KCB_DOWNUP = 3;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

KCB_NOP

Declaration

Source position: keymap.pas line 80

const KCB_NOP = 7;


KCB_SHIFT

Declaration

Source position: keymap.pas line 65

const KCB_SHIFT = 0;


KCB_STRING

Declaration

Source position: keymap.pas line 77

const KCB_STRING = 6;


KCF_ALT

Declaration

Source position: keymap.pas line 68

const KCF_ALT = 1 shl KCB_ALT;


KCF_CONTROL

Declaration

Source position: keymap.pas line 70

const KCF_CONTROL = 1 shl KCB_CONTROL;


KCF_DEAD

Declaration

Source position: keymap.pas line 75

const KCF_DEAD = 1 shl KCB_DEAD;


KCF_DOWNUP

Declaration

Source position: keymap.pas line 72

const KCF_DOWNUP = 1 shl KCB_DOWNUP;


KCF_NOP

Declaration

Source position: keymap.pas line 81

const KCF_NOP = 1 shl KCB_NOP;


KCF_SHIFT

Declaration

Source position: keymap.pas line 66

const KCF_SHIFT = 1 shl KCB_SHIFT;


KCF_STRING

Declaration

Source position: keymap.pas line 78

const KCF_STRING = 1 shl KCB_STRING;


KeyMapBase

Declaration

Source position: keymap.pas line 113

var KeyMapBase: PLibrary = Nil;


KEYMAPNAME

Declaration

Source position: keymap.pas line 116

const KEYMAPNAME: PChar = 'keymap.library';


PExtendedKeyMapNode

Declaration

Source position: keymap.pas line 43

type PExtendedKeyMapNode = ^TExtendedKeyMapNode;


PKeyMap

Declaration

Source position: keymap.pas line 25

type PKeyMap = ^TKeyMap;


PKeymapNode

Declaration

Source position: keymap.pas line 37

type PKeymapNode = ^TKeyMapNode;


PKeyMapResource

Declaration

Source position: keymap.pas line 54

type PKeyMapResource = ^TKeyMapResource;


PUCS4_CharsetCode

Declaration

Source position: keymap.pas line 100

type PUCS4_CharsetCode = ^TUCS4_CharsetCode;


PUCS4_CharsetConvTable

Declaration

Source position: keymap.pas line 106

type PUCS4_CharsetConvTable = ^TUCS4_CharsetConvTable;


PUCS4_ConvTable

Declaration

Source position: keymap.pas line 93

type PUCS4_ConvTable = ^TUCS4_ConvTable;


TExtendedKeyMapNode

Declaration

Source position: keymap.pas line 44

type TExtendedKeyMapNode = record

  ekn_Node: TNode;

  ekn_KeyMap: TKeyMap;

  pad1: Word;

  ekn_Seglist: LongInt;

  ekn_Resident: PResident;

  ekn_Future0: Pointer;

end;


TKeyMap

Declaration

Source position: keymap.pas line 26

type TKeyMap = record

  km_LoKeyMapTypes: PByte;

  km_LoKeyMap: PLongWord;

  km_LoCapsable: PByte;

  km_LoRepeatable: PByte;

  km_HiKeyMapTypes: PByte;

  km_HiKeyMap: PLongWord;

  km_HiCapsable: PByte;

  km_HiRepeatable: PByte;

end;


TKeyMapNode

Declaration

Source position: keymap.pas line 38

type TKeyMapNode = record

  kn_Node: TNode;

  kn_KeyMap: TKeyMap;

end;


TKeyMapResource

Declaration

Source position: keymap.pas line 55

type TKeyMapResource = record

  kr_Node: TNode;

  kr_List: TList;

end;


TUCS4_CharsetCode

Declaration

Source position: keymap.pas line 101

type TUCS4_CharsetCode = record

  UCS4: LongWord;

  CharsetCode: LongWord;

end;


TUCS4_CharsetConvTable

Declaration

Source position: keymap.pas line 107

type TUCS4_CharsetConvTable = record

  Mapping: PUCS4_CharsetCode;

  ConvTables: array [0..0] of TUCS4_ConvTable;

end;


TUCS4_ConvTable

Declaration

Source position: keymap.pas line 94

type TUCS4_ConvTable = record

  FirstChar: Word;

  LastChar: Word;

  ConvTable: Pointer;

end;


Reference for unit 'layers'

Layer handling

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility; | Tag Handling, Date routines in utility.library

Overview

provides routines that are used to manage overlapping rectangular drawing areas that share a common display. Intuition uses the layers library to manage its system of windows.

The concept of a layer is closely tied to Intuition windows. A layer is a rectangular drawing area. A layer can overlap other layers and has a display priority that determines whether it will appear in front or behind other layers. Every Intuition window has an associated Layer structure. Layers allow Intuition and application programs to :

  • Share a display's BitMap among various tasks in an orderly way by creating layers, separate drawing rectangles, within the BitMap.
  • Move, size or depth-arrange a layer while automatically keeping track of which portions of other layers are hidden or revealed by the operation.
  • Manage the remapping of coordinates, so the application need not track the layer's offset into the BitMap.
  • Maintain each layer as a separate entity, which may optionally have its own BitMap.
  • Automatically update same newly visible portions.

The layers library takes care of housekeeping: the low level, repetitive tasks which are required to keep track of where to place bits. The layers library also provides a locking mechanism which coordinates display updating when multiple tasks are drawing graphics to layers. The windowing environment provided by the Intuition library is largely based on layers.

Warning

Layers may not be created or used directly with Intuition screens. Intuition windows are the only supported method of adding layers to Intuition screens. Only the layer locking and unlocking functions are safe to use with Intuition. An application must create and manage its own View if it will be creating layers directly on the display.


Reference for unit 'layers': Constants

LAYERBACKDROP

LAYERIREFRESH

LAYERIREFRESH2

LAYERREFRESH

LAYERSIMPLE

LAYERSMART

LAYERSNAME

LAYERSUPER

LAYERS_BACKFILL

LAYERS_NEVERBACKFILL

LAYERS_NOBACKFILL

LAYERUPDATING

LAYER_CLIPRECTS_LOST

LA_BackfillHook

LA_Dummy

LA_SuperBitMap

LA_TransHook

LA_TransRegion

LA_WindowPtr

LR_Destination_BitMap

LR_Destination_Bounds

LR_Destination_RastPort

LR_Dummy

LR_Erase

LR_IgnoreList

LR_LayerInfo_Bounds

LR_RenderList

NEWLAYERINFO_CALLED


Unit 'layers' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'layers': Types

PLayer_Info

TLayer_Info


LA_BackfillHook

Declaration

Source position: layers.pas line 73

const LA_BackfillHook = LA_Dummy + $0001;


LA_Dummy

Declaration

Source position: layers.pas line 72

const LA_Dummy = TAG_USER + 1024;


LA_SuperBitMap

Declaration

Source position: layers.pas line 77

const LA_SuperBitMap = LA_Dummy + $0005;


LA_TransHook

Declaration

Source position: layers.pas line 75

const LA_TransHook = LA_Dummy + $0003;


LA_TransRegion

Declaration

Source position: layers.pas line 74

const LA_TransRegion = LA_Dummy + $0002;


LA_WindowPtr

Declaration

Source position: layers.pas line 76

const LA_WindowPtr = LA_Dummy + $0004;


LAYER_CLIPRECTS_LOST

Declaration

Source position: layers.pas line 36

const LAYER_CLIPRECTS_LOST = $100;


LAYERBACKDROP

Declaration

Source position: layers.pas line 34

const LAYERBACKDROP = $40;


LAYERIREFRESH

Declaration

Source position: layers.pas line 37

const LAYERIREFRESH = $200;


LAYERIREFRESH2

Declaration

Source position: layers.pas line 38

const LAYERIREFRESH2 = $400;


LAYERREFRESH

Declaration

Source position: layers.pas line 35

const LAYERREFRESH = $80;


LAYERS_BACKFILL

Declaration

Source position: layers.pas line 69

const LAYERS_BACKFILL = 0;


LAYERS_NEVERBACKFILL

Declaration

Source position: layers.pas line 67

const LAYERS_NEVERBACKFILL = 2;


LAYERS_NOBACKFILL

Declaration

Source position: layers.pas line 68

const LAYERS_NOBACKFILL = 1;


LayersBase

Declaration

Source position: layers.pas line 92

var LayersBase: PLibrary = Nil;


LAYERSIMPLE

Declaration

Source position: layers.pas line 30

const LAYERSIMPLE = 1;


LAYERSMART

Declaration

Source position: layers.pas line 31

const LAYERSMART = 2;


LAYERSNAME

Declaration

Source position: layers.pas line 89

const LAYERSNAME: PChar = 'layers.library';


LAYERSUPER

Declaration

Source position: layers.pas line 32

const LAYERSUPER = 4;


LAYERUPDATING

Declaration

Source position: layers.pas line 33

const LAYERUPDATING = $10;


LR_Destination_BitMap

Declaration

Source position: layers.pas line 81

const LR_Destination_BitMap = LR_Dummy + 2;


LR_Destination_Bounds

Declaration

Source position: layers.pas line 83

const LR_Destination_Bounds = LR_Dummy + 3;


LR_Destination_RastPort

Declaration

Source position: layers.pas line 80

const LR_Destination_RastPort = LR_Dummy + 1;


LR_Dummy

Declaration

Source position: layers.pas line 79

const LR_Dummy = TAG_USER + 1150;


LR_Erase

Declaration

Source position: layers.pas line 85

const LR_Erase = LR_Dummy + 5;


LR_IgnoreList

Declaration

Source position: layers.pas line 87

const LR_IgnoreList = LR_Dummy + 7;


LR_LayerInfo_Bounds

Declaration

Source position: layers.pas line 84

const LR_LayerInfo_Bounds = LR_Dummy + 4;


LR_RenderList

Declaration

Source position: layers.pas line 86

const LR_RenderList = LR_Dummy + 6;


PLayer_Info

Declaration

Source position: layers.pas line 41

type PLayer_Info = ^TLayer_Info;


TLayer_Info

Declaration

Source position: layers.pas line 42

type TLayer_Info = packed record

  top_layer: PLayer;

  check_lp: PLayer;

  obs: PClipRect;

  FreeClipRects: PClipRect;

  PrivateReserve1: LongInt;

  PrivateReserve2: LongInt;

  Lock: TSignalSemaphore;

  gs_Head: TMinList;

  PrivateReserve3: SmallInt;

  PrivateReserve4: Pointer;

  Flags: Word;

  fatten_count: ShortInt;

  LockLayersCount: ShortInt;

  PrivateReserve5: SmallInt;

  BlankHook: Pointer;

  LayerInfo_extra: Pointer;

end;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABDAY_1

Declaration

Source position: locale.pas line 35

const ABDAY_1 = 8;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABDAY_2

Declaration

Source position: locale.pas line 36

const ABDAY_2 = 9;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABDAY_3

Declaration

Source position: locale.pas line 37

const ABDAY_3 = 10;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABDAY_4

Declaration

Source position: locale.pas line 38

const ABDAY_4 = 11;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABDAY_5

Declaration

Source position: locale.pas line 39

const ABDAY_5 = 12;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABDAY_6

Declaration

Source position: locale.pas line 40

const ABDAY_6 = 13;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABDAY_7

Declaration

Source position: locale.pas line 41

const ABDAY_7 = 14;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_1

Declaration

Source position: locale.pas line 56

const ABMON_1 = 27;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_2

Declaration

Source position: locale.pas line 57

const ABMON_2 = 28;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_3

Declaration

Source position: locale.pas line 58

const ABMON_3 = 29;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_4

Declaration

Source position: locale.pas line 59

const ABMON_4 = 30;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_5

Declaration

Source position: locale.pas line 60

const ABMON_5 = 31;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_6

Declaration

Source position: locale.pas line 61

const ABMON_6 = 32;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_7

Declaration

Source position: locale.pas line 62

const ABMON_7 = 33;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_8

Declaration

Source position: locale.pas line 63

const ABMON_8 = 34;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

ABMON_9

Declaration

Source position: locale.pas line 64

const ABMON_9 = 35;


ABMON_10

Declaration

Source position: locale.pas line 65

const ABMON_10 = 36;


ABMON_11

Declaration

Source position: locale.pas line 66

const ABMON_11 = 37;


ABMON_12

Declaration

Source position: locale.pas line 67

const ABMON_12 = 38;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

AM_STR

Declaration

Source position: locale.pas line 72

const AM_STR = 41;


CLOSEQUOTE

Declaration

Source position: locale.pas line 79

const CLOSEQUOTE = 46;


CODESET_COUNT

Declaration

Source position: locale.pas line 220

const CODESET_COUNT = 3;


CODESET_LATIN1

Declaration

Source position: locale.pas line 222

const CODESET_LATIN1 = CODESET_LEGACY;


CODESET_LEGACY

Declaration

Source position: locale.pas line 217

const CODESET_LEGACY = 0;


CODESET_UCS4

Declaration

Source position: locale.pas line 223

const CODESET_UCS4 = CODESET_UTF32;


CODESET_UTF8

Declaration

Source position: locale.pas line 218

const CODESET_UTF8 = 1;


CODESET_UTF32

Declaration

Source position: locale.pas line 219

const CODESET_UTF32 = 2;


CSP_PRECEDES

Declaration

Source position: locale.pas line 180

const CSP_PRECEDES = 0;


CSP_SUCCEEDS

Declaration

Source position: locale.pas line 181

const CSP_SUCCEEDS = 1;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CT_7FRI

Declaration

Source position: locale.pas line 165

const CT_7FRI = 5;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CT_7MON

Declaration

Source position: locale.pas line 161

const CT_7MON = 1;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CT_7SAT

Declaration

Source position: locale.pas line 166

const CT_7SAT = 6;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CT_7SUN

Declaration

Source position: locale.pas line 160

const CT_7SUN = 0;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CT_7THU

Declaration

Source position: locale.pas line 164

const CT_7THU = 4;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CT_7TUE

Declaration

Source position: locale.pas line 162

const CT_7TUE = 2;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

CT_7WED

Declaration

Source position: locale.pas line 163

const CT_7WED = 3;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DAY_1

Declaration

Source position: locale.pas line 27

const DAY_1 = 1;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DAY_2

Declaration

Source position: locale.pas line 28

const DAY_2 = 2;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DAY_3

Declaration

Source position: locale.pas line 29

const DAY_3 = 3;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DAY_4

Declaration

Source position: locale.pas line 30

const DAY_4 = 4;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DAY_5

Declaration

Source position: locale.pas line 31

const DAY_5 = 5;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DAY_6

Declaration

Source position: locale.pas line 32

const DAY_6 = 6;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

DAY_7

Declaration

Source position: locale.pas line 33

const DAY_7 = 7;


FUTURESTR

Declaration

Source position: locale.pas line 84

const FUTURESTR = 50;


HARDHYPHEN

Declaration

Source position: locale.pas line 76

const HARDHYPHEN = 44;


Reference for unit 'locale'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
AmigaDOS, | File and directory handling routines and types (dos.library)
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'locale': Constants

ABDAY_1

ABDAY_2

ABDAY_3

ABDAY_4

ABDAY_5

ABDAY_6

ABDAY_7

ABMON_1

ABMON_10

ABMON_11

ABMON_12

ABMON_2

ABMON_3

ABMON_4

ABMON_5

ABMON_6

ABMON_7

ABMON_8

ABMON_9

AM_STR

CLOSEQUOTE

CODESET_COUNT

CODESET_LATIN1

CODESET_LEGACY

CODESET_UCS4

CODESET_UTF32

CODESET_UTF8

CSP_PRECEDES

CSP_SUCCEEDS

CT_7FRI

CT_7MON

CT_7SAT

CT_7SUN

CT_7THU

CT_7TUE

CT_7WED

DAY_1

DAY_2

DAY_3

DAY_4

DAY_5

DAY_6

DAY_7

FUTURESTR

HARDHYPHEN

LOCALENAME

MAXSTRMSG

MON_1

MON_10

MON_11

MON_12

MON_2

MON_3

MON_4

MON_5

MON_6

MON_7

MON_8

MON_9

MS_AMERICAN

MS_BRITISH

MS_IMPERIAL

MS_ISO

NOSTR

OC_BuiltInCodeSet

OC_BuiltInLanguage

OC_BuiltInStrings

OC_CodeSet

OC_Language

OC_TagBase

OC_Version

OPENQUOTE

PM_STR

SC_ASCII

SC_COLLATE1

SC_COLLATE2

SC_UNICODE

SOFTHYPHEN

SP_PARENS

SP_PREC_ALL

SP_PREC_CURR

SP_SUCC_ALL

SP_SUCC_CURR

SS_NOSPACE

SS_SPACE

TODAYSTR

TOMORROWSTR

UCF_IGNORE_CASE

UNICODE_16_BE

UNICODE_16_LE

UNICODE_32_BE

UNICODE_32_LE

UNICODE_INVALID

UNICODE_NFD

UNICODE_NFKD

UNICODE_UTF8

YESSTR

YESTERDAYSTR


Reference for unit 'locale': Types

PCatalog

PLocale

PLocaleBase

TCatalog

TLocale

TLocaleBase


LocaleBase

Declaration

Source position: locale.pas line 234

var LocaleBase: PLocaleBase = Nil;


LOCALENAME

Declaration

Source position: locale.pas line 237

const LOCALENAME: PChar = 'locale.library';


MAXSTRMSG

Declaration

Source position: locale.pas line 86

const MAXSTRMSG = 51;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_1

Declaration

Source position: locale.pas line 43

const MON_1 = 15;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_2

Declaration

Source position: locale.pas line 44

const MON_2 = 16;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_3

Declaration

Source position: locale.pas line 45

const MON_3 = 17;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_4

Declaration

Source position: locale.pas line 46

const MON_4 = 18;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_5

Declaration

Source position: locale.pas line 47

const MON_5 = 19;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_6

Declaration

Source position: locale.pas line 48

const MON_6 = 20;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_7

Declaration

Source position: locale.pas line 49

const MON_7 = 21;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_8

Declaration

Source position: locale.pas line 50

const MON_8 = 22;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_9

Declaration

Source position: locale.pas line 51

const MON_9 = 23;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_10

Declaration

Source position: locale.pas line 52

const MON_10 = 24;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_11

Declaration

Source position: locale.pas line 53

const MON_11 = 25;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MON_12

Declaration

Source position: locale.pas line 54

const MON_12 = 26;


MS_AMERICAN

Declaration

Source position: locale.pas line 155

const MS_AMERICAN = 1;


MS_BRITISH

Declaration

Source position: locale.pas line 157

const MS_BRITISH = 3;


MS_IMPERIAL

Declaration

Source position: locale.pas line 156

const MS_IMPERIAL = 2;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MS_ISO

Declaration

Source position: locale.pas line 154

const MS_ISO = 0;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

NOSTR

Declaration

Source position: locale.pas line 70

const NOSTR = 40;


OC_BuiltInCodeSet

Declaration

Source position: locale.pas line 186

const OC_BuiltInCodeSet = OC_TagBase + 2;


OC_BuiltInLanguage

Declaration

Source position: locale.pas line 185

const OC_BuiltInLanguage = OC_TagBase + 1;


OC_BuiltInStrings

Declaration

Source position: locale.pas line 190

const OC_BuiltInStrings = OC_TagBase + 6;


OC_CodeSet

Declaration

Source position: locale.pas line 189

const OC_CodeSet = OC_TagBase + 5;


OC_Language

Declaration

Source position: locale.pas line 188

const OC_Language = OC_TagBase + 4;


OC_TagBase

Declaration

Source position: locale.pas line 184

const OC_TagBase = TAG_USER + $90000;


OC_Version

Declaration

Source position: locale.pas line 187

const OC_Version = OC_TagBase + 3;


OPENQUOTE

Declaration

Source position: locale.pas line 78

const OPENQUOTE = 45;


PCatalog

Declaration

Source position: locale.pas line 205

type PCatalog = ^TCatalog;


PLocale

Declaration

Source position: locale.pas line 96

type PLocale = ^TLocale;


PLocaleBase

Declaration

Source position: locale.pas line 89

type PLocaleBase = ^TLocaleBase;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PM_STR

Declaration

Source position: locale.pas line 73

const PM_STR = 42;


SC_ASCII

Declaration

Source position: locale.pas line 193

const SC_ASCII = 0;


SC_COLLATE1

Declaration

Source position: locale.pas line 194

const SC_COLLATE1 = 1;


SC_COLLATE2

Declaration

Source position: locale.pas line 195

const SC_COLLATE2 = 2;


SC_UNICODE

Declaration

Source position: locale.pas line 196

const SC_UNICODE = SC_ASCII;


SOFTHYPHEN

Declaration

Source position: locale.pas line 75

const SOFTHYPHEN = 43;


SP_PARENS

Declaration

Source position: locale.pas line 173

const SP_PARENS = 0;


SP_PREC_ALL

Declaration

Source position: locale.pas line 174

const SP_PREC_ALL = 1;


SP_PREC_CURR

Declaration

Source position: locale.pas line 176

const SP_PREC_CURR = 3;


SP_SUCC_ALL

Declaration

Source position: locale.pas line 175

const SP_SUCC_ALL = 2;


SP_SUCC_CURR

Declaration

Source position: locale.pas line 177

const SP_SUCC_CURR = 4;


SS_NOSPACE

Declaration

Source position: locale.pas line 169

const SS_NOSPACE = 0;


SS_SPACE

Declaration

Source position: locale.pas line 170

const SS_SPACE = 1;


TCatalog

Declaration

Source position: locale.pas line 206

type TCatalog = record

  cat_Link: TNode;

  cat_Pad: Word;

  cat_Language: PChar;

  cat_CodeSet: LongWord;

  cat_Version: Word;

  cat_Revision: Word;

end;


TLocale

Declaration

Source position: locale.pas line 97

type TLocale = record

  loc_LocaleName: PChar;

  loc_LanguageName: PChar;

  loc_PrefLanguages: array [0..9] of PChar;

  loc_Flags: LongWord;

  loc_CodeSet: LongWord;

  loc_CountryCode: LongWord;

  loc_TelephoneCode: LongWord;

  loc_GMTOffset: LongInt;

  loc_MeasuringSystem: Byte;

  loc_CalendarType: Byte;

  loc_Reserved0: array [0..1] of Byte;

  loc_DateTimeFormat: PChar;

  loc_DateFormat: PChar;

  loc_TimeFormat: PChar;

  loc_ShortDateTimeFormat: PChar;

  loc_ShortDateFormat: PChar;

  loc_ShortTimeFormat: PChar;

  loc_DecimalPoint: PChar;

  loc_GroupSeparator: PChar;

  loc_FracGroupSeparator: PChar;

  loc_Grouping: PByte;

  loc_FracGrouping: PByte;

  loc_MonDecimalPoint: PChar;

  loc_MonGroupSeparator: PChar;

  loc_MonFracGroupSeparator: PChar;

  loc_MonGrouping: PByte;

  loc_MonFracGrouping: PByte;

  loc_MonFracDigits: Byte;

  loc_MonIntFracDigits: Byte;

  loc_Reserved1: array [0..1] of Byte;

  loc_MonCS: PChar;

  loc_MonSmallCS: PChar;

  loc_MonIntCS: PChar;

  loc_MonPositiveSign: PChar;

  loc_MonPositiveSpaceSep: Byte;

  loc_MonPositiveSignPos: Byte;

  loc_MonPositiveCSPos: Byte;

  loc_Reserved2: Byte;

  loc_MonNegativeSign: PChar;

  loc_MonNegativeSpaceSep: Byte;

  loc_MonNegativeSignPos: Byte;

  loc_MonNegativeCSPos: Byte;

  loc_Reserved3: Byte;

end;


TLocaleBase

Declaration

Source position: locale.pas line 90

type TLocaleBase = record

  lb_LibNode: TLibrary;

  lb_SysPatches: WordBool;

end;


TODAYSTR

Declaration

Source position: locale.pas line 82

const TODAYSTR = 48;


TOMORROWSTR

Declaration

Source position: locale.pas line 83

const TOMORROWSTR = 49;


UCF_IGNORE_CASE

Declaration

Source position: locale.pas line 198

const UCF_IGNORE_CASE = 1 shl 0;


UNICODE_16_BE

Declaration

Source position: locale.pas line 228

const UNICODE_16_BE = 2;


UNICODE_16_LE

Declaration

Source position: locale.pas line 229

const UNICODE_16_LE = 3;


UNICODE_32_BE

Declaration

Source position: locale.pas line 230

const UNICODE_32_BE = 4;


UNICODE_32_LE

Declaration

Source position: locale.pas line 231

const UNICODE_32_LE = 5;


UNICODE_INVALID

Declaration

Source position: locale.pas line 226

const UNICODE_INVALID = 0;


UNICODE_NFD

Declaration

Source position: locale.pas line 200

const UNICODE_NFD = 0;


UNICODE_NFKD

Declaration

Source position: locale.pas line 201

const UNICODE_NFKD = 1;


UNICODE_UTF8

Declaration

Source position: locale.pas line 227

const UNICODE_UTF8 = 1;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

YESSTR

Declaration

Source position: locale.pas line 69

const YESSTR = 39;


YESTERDAYSTR

Declaration

Source position: locale.pas line 81

const YESTERDAYSTR = 47;


Reference for unit 'mui'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
intuition, | Screen and Window handling routines of intuition.library
utility, | Tag Handling, Date routines in utility.library
agraphics; | Native Amiga graphic functions (graphics.library)

Overview

Notify |  |  |  |  |  | (implements notification mechanism)
+------------ | Family |  |  |  |  | (handles multiple children)
| | +------------ | Menustrip |  |  |  | (describes a complete menu strip)
| | +------------ | Menu |  |  |  | (describes a single menu)
| | \------------- | Menuitem |  |  |  | (describes a single menu item)
+------------ | Application |  |  |  |  | (main class for all applications)
+------------ | Window |  |  |  |  | (main class for all windows)
| | \------------- | Aboutmui |  |  |  | (About window of MUI preferences)
\------------- | Area |  |  |  |  | (base class for all GUI elements)
 | +------------ | Rectangle |  |  |  | (spacing object)
 | +------------ | Balance |  |  |  | (balancing separator bar)
 | +------------ | Image |  |  |  | (image display)
 | +------------ | Bitmap |  |  |  | (draws bitmaps)
 | | | \------------- | Bodychunk |  |  | (makes bitmap from ILBM body chunk)
 | +------------ | Text |  |  |  | (text display)
 | +------------ | Gadget |  |  |  | (base class for intuition gadgets)
 | | | +------------ | String |  |  | (string gadget)
 | | | +------------ | Boopsi |  |  | (interface to BOOPSI gadgets)
 | | | \------------- | Prop |  |  | (proportional gadget)
 | +------------ | Gauge |  |  |  | (fule gauge)
 | +------------ | Scale |  |  |  | (percentage scale)
 | +------------ | Colorfield |  |  |  | (field with changeable color)
 | +------------ | List |  |  |  | (line-oriented list)
 | | | +------------ | Floattext |  |  | (special list with floating text)
 | | | +------------ | Volumelist |  |  | (special list with volumes)
 | | | +------------ | Scrmodelist |  |  | (special list with screen modes)
 | | | \------------- | DirList |  |  | (special list with files)
 | +------------ | Numeric |  |  |  | (base class for slider gadgets)
 | | | +------------ | Knop |  |  | (turning knob)
 | | | +------------ | Levelmeter |  |  | (level display)
 | | | +------------ | Numericbutton |  |  | (space saving popup slider)
 | | | \------------- | Slider |  |  | (traditional slider)
 | +------------ | Framedisplay |  |  |  | (private)
 | | | \------------- | Popframe |  |  | (private)
 | +------------ | Imagedisplay |  |  |  | (private)
 | | | \------------- | Popimage |  |  | (private)
 | +------------ | Pendisplay |  |  |  | (displays a pen specification)
 | | | \------------- | Poppen |  |  | (popup button to adjust a pen spec)
 | \------------- | Group |  |  |  | (groups other GUI elements)
 |  | +------------ | Mccprefs |  |  | (private)
 |  | +------------ | Register |  |  | (handles page groups with titles)
 |  | | | \------------------ | Penadjust |  | (group to adjust a pen)
 |  | +------------ | Settingsgroup |  |  | (private)
 |  | +------------ | Settings |  |  | (private)
 |  | +------------ | Frameadjust |  |  | (private)
 |  | +------------ | Imageadjust |  |  | (private)
 |  | +------------ | Virtgroup |  |  | (handles virtual groups)
 |  | +------------ | Scrollgroup |  |  | (virtual groups with scrollbars)
 |  | +------------ | Scrollbar |  |  | (traditional scrollbar)
 |  | +------------ | Listview |  |  | (listview)
 |  | +------------ | Radio |  |  | (radio button)
 |  | +------------ | Cycle |  |  | (cycle gadget)
 |  | +------------ | Coloradjust |  |  | (several gadgets to adjust a color)
 |  | +------------ | Palette |  |  | (complete palette gadget)
 |  | \------------- | Popstring |  |  | (base class for popup objects)
 |  |  | +----------------- | Popobject |  | (popup aynthing in a separate window)
 |  |  | | | +------------ | Poplist | (popup a simple listview)
 |  |  | | | \------------- | Popscreen | (popup a list of public screens)
 |  |  | \------------------ | Popasl |  | (popup an asl requester)
Semaphore |  |  |  |  |  | (semaphore equipped objects)
+------------ | Applist |  |  |  |  | (private)
\------------- | Dataspace |  |  |  |  | (handles general purpose data spaces)
 | \------------- | Configdata |  |  |  | (private)


Reference for unit 'mui': Constants

MADF_DRAWOBJECT |
MADF_DRAWUPDATE |
MBQF_HORIZ |
MBQ_MUI_MAXMAX |
MC_TEMPLATE_ID |
MPEN_BACKGROUND |
MPEN_COUNT |
MPEN_FILL |
MPEN_HALFSHADOW |
MPEN_HALFSHINE |
MPEN_MARK |
MPEN_SHADOW |
MPEN_SHINE |
MPEN_TEXT |
MUIA_Aboutmui_Application |
MUIA_ApplicationObject |
MUIA_Application_Active |
MUIA_Application_Author |
MUIA_Application_Base |
MUIA_Application_Broker |
MUIA_Application_BrokerHook |
MUIA_Application_BrokerPort |
MUIA_Application_BrokerPri |
MUIA_Application_Commands |
MUIA_Application_Copyright |
MUIA_Application_Description |
MUIA_Application_DiskObject |
MUIA_Application_DoubleStart |
MUIA_Application_DropObject |
MUIA_Application_ForceQuit |
MUIA_Application_HelpFile |
MUIA_Application_Iconified |
MUIA_Application_MenuAction |
MUIA_Application_MenuHelp |
MUIA_Application_Menustrip |
MUIA_Application_RexxHook |
MUIA_Application_RexxMsg |
MUIA_Application_RexxString |
MUIA_Application_SingleTask |
MUIA_Application_Sleep |
MUIA_Application_Title |
MUIA_Application_UseCommodities |
MUIA_Application_UsedClasses |
MUIA_Application_UseRexx |
MUIA_Application_Version |
MUIA_Application_Window |
MUIA_Application_WindowList |
MUIA_AppMessage |
MUIA_Background |
MUIA_Balance_Quiet
MUIA_Bitmap_Alpha
MUIA_Bitmap_Bitmap |
MUIA_Bitmap_Height |
MUIA_Bitmap_MappingTable |
MUIA_Bitmap_Precision |
MUIA_Bitmap_RemappedBitmap |
MUIA_Bitmap_SourceColors |
MUIA_Bitmap_Transparent |
MUIA_Bitmap_UseFriend |
MUIA_Bitmap_Width |
MUIA_Bodychunk_Body |
MUIA_Bodychunk_Compression |
MUIA_Bodychunk_Depth |
MUIA_Bodychunk_Masking |
MUIA_Boopsi_Class |
MUIA_Boopsi_ClassID |
MUIA_Boopsi_MaxHeight |
MUIA_Boopsi_MaxWidth |
MUIA_Boopsi_MinHeight |
MUIA_Boopsi_MinWidth |
MUIA_Boopsi_Object |
MUIA_Boopsi_Remember |
MUIA_Boopsi_Smart |
MUIA_Boopsi_TagDrawInfo |
MUIA_Boopsi_TagScreen |
MUIA_Boopsi_TagWindow |
MUIA_BottomEdge |
MUIA_Coloradjust_Blue |
MUIA_Coloradjust_Green |
MUIA_Coloradjust_ModeID |
MUIA_Coloradjust_Red |
MUIA_Coloradjust_RGB |
MUIA_Colorfield_Blue |
MUIA_Colorfield_Green |
MUIA_Colorfield_Pen |
MUIA_Colorfield_Red |
MUIA_Colorfield_RGB |
MUIA_ContextMenu |
MUIA_ContextMenuTrigger |
MUIA_ControlChar |
MUIA_CycleChain |
MUIA_Cycle_Active |
MUIA_Cycle_Entries |
MUIA_Dataspace_Pool |
MUIA_Dirlist_AcceptPattern |
MUIA_Dirlist_Directory |
MUIA_Dirlist_DrawersOnly |
MUIA_Dirlist_FilesOnly |
MUIA_Dirlist_FilterDrawers |
MUIA_Dirlist_FilterHook |
MUIA_Dirlist_MultiSelDirs |
MUIA_Dirlist_NumBytes |
MUIA_Dirlist_NumDrawers |
MUIA_Dirlist_NumFiles |
MUIA_Dirlist_Path |
MUIA_Dirlist_RejectIcons |
MUIA_Dirlist_RejectPattern |
MUIA_Dirlist_SortDirs |
MUIA_Dirlist_SortHighLow |
MUIA_Dirlist_SortType |
MUIA_Dirlist_Status |
MUIA_Disabled |
MUIA_DoubleBuffer
MUIA_Draggable |
MUIA_Dropable |
MUIA_Dtpic_Name
MUIA_Family_Child |
MUIA_Family_List |
MUIA_FillArea |
MUIA_FixHeight |
MUIA_FixHeightTxt |
MUIA_FixWidth |
MUIA_FixWidthTxt |
MUIA_Floattext_Justify |
MUIA_Floattext_SkipChars |
MUIA_Floattext_TabSize |
MUIA_Floattext_Text |
MUIA_Font |
MUIA_Frame |
MUIA_FrameDynamic
MUIA_FramePhantomHoriz |
MUIA_FrameTitle |
MUIA_FrameVisible
MUIA_Gadget_Gadget |
MUIA_Gauge_Current |
MUIA_Gauge_Divide |
MUIA_Gauge_Horiz |
MUIA_Gauge_InfoRate
MUIA_Gauge_InfoText |
MUIA_Gauge_Max |
MUIA_Group_ActivePage |
MUIA_Group_Child |
MUIA_Group_ChildList |
MUIA_Group_Columns |
MUIA_Group_Horiz |
MUIA_Group_HorizSpacing |
MUIA_Group_LayoutHook |
MUIA_Group_PageMode |
MUIA_Group_Rows |
MUIA_Group_SameHeight |
MUIA_Group_SameSize |
MUIA_Group_SameWidth |
MUIA_Group_Spacing |
MUIA_Group_VertSpacing |
MUIA_Height |
MUIA_HelpLine |
MUIA_HelpNode |
MUIA_HorizDisappear |
MUIA_HorizWeight |
MUIA_Image_FontMatch |
MUIA_Image_FontMatchHeight |
MUIA_Image_FontMatchWidth |
MUIA_Image_FreeHoriz |
MUIA_Image_FreeVert |
MUIA_Image_OldImage |
MUIA_Image_Spec |
MUIA_Image_State |
MUIA_InnerBottom |
MUIA_InnerLeft |
MUIA_InnerRight |
MUIA_InnerTop |
MUIA_InputMode |
MUIA_LeftEdge |
MUIA_Levelmeter_Label |
MUIA_Listview_ClickColumn |
MUIA_Listview_DefClickColumn |
MUIA_Listview_DoubleClick |
MUIA_Listview_DragType |
MUIA_Listview_Input |
MUIA_Listview_List |
MUIA_Listview_MultiSelect |
MUIA_Listview_ScrollerPos |
MUIA_Listview_SelectChange |
MUIA_List_Active |
MUIA_List_AdjustHeight |
MUIA_List_AdjustWidth |
MUIA_List_AutoVisible |
MUIA_List_CompareHook |
MUIA_List_ConstructHook |
MUIA_List_DestructHook |
MUIA_List_DisplayHook |
MUIA_List_DragSortable |
MUIA_List_DropMark |
MUIA_List_Entries |
MUIA_List_First |
MUIA_List_Format |
MUIA_List_InsertPosition |
MUIA_List_MinLineHeight |
MUIA_List_MultiTestHook |
MUIA_List_Pool |
MUIA_List_PoolPuddleSize |
MUIA_List_PoolThreshSize |
MUIA_List_Quiet |
MUIA_List_ShowDropMarks |
MUIA_List_SourceArray |
MUIA_List_Title |
MUIA_List_Visible |
MUIA_MaxHeight |
MUIA_MaxWidth |
MUIA_Menuitem_Checked |
MUIA_Menuitem_Checkit |
MUIA_Menuitem_CommandString |
MUIA_Menuitem_Enabled |
MUIA_Menuitem_Exclude |
MUIA_Menuitem_Shortcut |
MUIA_Menuitem_Title |
MUIA_Menuitem_Toggle |
MUIA_Menuitem_Trigger |
MUIA_Menustrip_Enabled |
MUIA_Menu_Enabled |
MUIA_Menu_Title |
MUIA_NoNotify |
MUIA_NoNotifyMethod
MUIA_Numeric_CheckAllSizes |
MUIA_Numeric_Default |
MUIA_Numeric_Format |
MUIA_Numeric_Max |
MUIA_Numeric_Min |
MUIA_Numeric_Reverse |
MUIA_Numeric_RevLeftRight |
MUIA_Numeric_RevUpDown |
MUIA_Numeric_Value |
MUIA_ObjectID |
MUIA_Palette_Entries |
MUIA_Palette_Groupable |
MUIA_Palette_Names |
MUIA_Parent |
MUIA_Penadjust_PSIMode |
MUIA_Pendisplay_Pen |
MUIA_Pendisplay_Reference |
MUIA_Pendisplay_RGBcolor |
MUIA_Pendisplay_Spec |
MUIA_Popasl_Active |
MUIA_Popasl_StartHook |
MUIA_Popasl_StopHook |
MUIA_Popasl_Type |
MUIA_Poplist_Array |
MUIA_Popobject_Follow |
MUIA_Popobject_Light |
MUIA_Popobject_Object |
MUIA_Popobject_ObjStrHook |
MUIA_Popobject_StrObjHook |
MUIA_Popobject_Volatile |
MUIA_Popobject_WindowHook |
MUIA_Popstring_Button |
MUIA_Popstring_CloseHook |
MUIA_Popstring_OpenHook |
MUIA_Popstring_String |
MUIA_Popstring_Toggle |
MUIA_Pressed |
MUIA_Prop_Entries |
MUIA_Prop_First |
MUIA_Prop_Horiz |
MUIA_Prop_Slider |
MUIA_Prop_UseWinBorder |
MUIA_Prop_Visible |
MUIA_Radio_Active |
MUIA_Radio_Entries |
MUIA_Rectangle_BarTitle |
MUIA_Rectangle_HBar |
MUIA_Rectangle_VBar |
MUIA_Register_Frame |
MUIA_Register_Titles |
MUIA_Revision |
MUIA_RightEdge |
MUIA_Scale_Horiz |
MUIA_Scrollbar_Type |
MUIA_Scrollgroup_Contents |
MUIA_Scrollgroup_FreeHoriz |
MUIA_Scrollgroup_FreeVert |
MUIA_Scrollgroup_HorizBar |
MUIA_Scrollgroup_UseWinBorder |
MUIA_Scrollgroup_VertBar |
MUIA_Selected |
MUIA_ShortHelp |
MUIA_ShowMe |
MUIA_ShowSelState |
MUIA_Slider_Horiz |
MUIA_Slider_Quiet |
MUIA_String_Accept |
MUIA_String_Acknowledge |
MUIA_String_AdvanceOnCR |
MUIA_String_AttachedList |
MUIA_String_BufferPos |
MUIA_String_Contents |
MUIA_String_DisplayPos |
MUIA_String_EditHook |
MUIA_String_Format |
MUIA_String_Integer |
MUIA_String_LonelyEditHook |
MUIA_String_MaxLen |
MUIA_String_Reject |
MUIA_String_Secret |
MUIA_Text_Contents |
MUIA_Text_ControlChar
MUIA_Text_Copy
MUIA_Text_HiChar |
MUIA_Text_PreParse |
MUIA_Text_SetMax |
MUIA_Text_SetMin |
MUIA_Text_SetVMax |
MUIA_Text_Shorten
MUIA_Text_Shortened
MUIA_Timer |
MUIA_TopEdge |
MUIA_UserData |
MUIA_Version |
MUIA_VertDisappear |
MUIA_VertWeight |
MUIA_Virtgroup_Height |
MUIA_Virtgroup_Input |
MUIA_Virtgroup_Left |
MUIA_Virtgroup_Top |
MUIA_Virtgroup_Width |
MUIA_Weight |
MUIA_Width |
MUIA_Window |
MUIA_WindowObject |
MUIA_Window_Activate |
MUIA_Window_ActiveObject |
MUIA_Window_AltHeight |
MUIA_Window_AltLeftEdge |
MUIA_Window_AltTopEdge |
MUIA_Window_AltWidth |
MUIA_Window_AppWindow |
MUIA_Window_Backdrop |
MUIA_Window_Borderless |
MUIA_Window_CloseGadget |
MUIA_Window_CloseRequest |
MUIA_Window_DefaultObject |
MUIA_Window_DepthGadget |
MUIA_Window_DragBar |
MUIA_Window_FancyDrawing |
MUIA_Window_Height |
MUIA_Window_ID |
MUIA_Window_InputEvent |
MUIA_Window_IsSubWindow |
MUIA_Window_LeftEdge |
MUIA_Window_MenuAction |
MUIA_Window_Menustrip |
MUIA_Window_MouseObject |
MUIA_Window_NeedsMouseObject |
MUIA_Window_NoMenus |
MUIA_Window_Open |
MUIA_Window_PublicScreen |
MUIA_Window_RefWindow |
MUIA_Window_RootObject |
MUIA_Window_Screen |
MUIA_Window_ScreenTitle |
MUIA_Window_SizeGadget |
MUIA_Window_SizeRight |
MUIA_Window_Sleep |
MUIA_Window_Title |
MUIA_Window_TopEdge |
MUIA_Window_UseBottomBorderScroller |
MUIA_Window_UseLeftBorderScroller |
MUIA_Window_UseRightBorderScroller |
MUIA_Window_Width |
MUIA_Window_Window |
MUICFG_PublicScreen |
MUIC_Aboutmui |
MUIC_Application |
MUIC_Applist |
MUIC_Area | Area class is a super class for every other MUI class except windows and applications.
MUIC_Balance |
MUIC_Bitmap | Include a self-made image data in MUI applications.
MUIC_Bodychunk |
MUIC_Boopsi | MUI's boopsi class provides an interface to standard, system style boopsi gadgets.
MUIC_Cclist |
MUIC_Coloradjust |
MUIC_Colorfield |
MUIC_Configdata |
MUIC_Cycle |
MUIC_Dataspace |
MUIC_Dirlist |
MUIC_Dtpic |
MUIC_Family | Family class is the base class for objects that are able to handle a list of children.
MUIC_Floattext |
MUIC_Frameadjust |
MUIC_Framedisplay |
MUIC_Gadget | This is the base class for intuition gadgets in MUI windows.
MUIC_Gauge | A gauge object is a nice looking display element useful for some kind of progress display.
MUIC_Group |
MUIC_Image | Image class is used to display one of MUI's standard images or some selfmade image data.
MUIC_Imageadjust |
MUIC_Imagedisplay |
MUIC_Knob |
MUIC_Levelmeter |
MUIC_List |
MUIC_Listview |
MUIC_Mccprefs |
MUIC_Menu | Objects of menu class describe exactly one pulldown menu.
MUIC_Menubar
MUIC_Menuitem |
MUIC_Menustrip | Menustrip class is the base class for MUI's object oriented menus.
MUIC_Notify | Notify class is superclass of all other MUI classes.
MUIC_Numeric |
MUIC_Numericbutton |
MUIC_Palette |
MUIC_Penadjust |
MUIC_Pendisplay |
MUIC_Popasl |
MUIC_Popframe |
MUIC_Popimage |
MUIC_Poplist |
MUIC_Popobject |
MUIC_Poppen |
MUIC_Popscreen |
MUIC_Popstring |
MUIC_Prop | Prop class generates the well known proportional gadgets.
MUIC_Radio |
MUIC_Rectangle | Empty rectangle for space layout.
MUIC_Register |
MUIC_Scale | A Scale object generates a percentage scale running from 0% to 100%.
MUIC_Scrmodelist |
MUIC_Scrollbar |
MUIC_Scrollgroup |
MUIC_Semaphore |
MUIC_Settings |
MUIC_Settingsgroup |
MUIC_Slider |
MUIC_String | String class generates standard string gadgets with all editing facilities (clear, undo, etc.) enabled.
MUIC_Text | Text class allows generating objects that contain some kind of text.
MUIC_Virtgroup |
MUIC_Volumelist |
MUIC_Window | Objects of window class are used to generate windows and supply a place where MUI gadgets feel well.
MUIE_InvalidWindowObject |
MUIE_MissingLibrary |
MUIE_NoARexx |
MUIE_OK |
MUIE_OutOfGfxMemory |
MUIE_OutOfMemory |
MUIE_SingleTask |
MUIIHNF_TIMER |
MUII_ArrowDown |
MUII_ArrowLeft |
MUII_ArrowRight |
MUII_ArrowUp |
MUII_Assign |
MUII_BACKGROUND |
MUII_BARBLOCK
MUII_BARDETAIL
MUII_ButtonBack |
MUII_CheckMark |
MUII_Chip |
MUII_Count |
MUII_Cycle |
MUII_Disk |
MUII_Drawer |
MUII_FILL |
MUII_FILLBACK |
MUII_FILLBACK2 |
MUII_FILLSHINE |
MUII_GaugeEmpty
MUII_GaugeFull
MUII_GroupBack |
MUII_HardDisk |
MUII_HSHADOWBACK |
MUII_HSHADOWSHADOW |
MUII_HSHINEBACK |
MUII_HSHINESHINE |
MUII_ImageButtonBack
MUII_ImageSelectedBack
MUII_LASTPAT |
MUII_ListBack |
MUII_ListCursor |
MUII_ListSelCur |
MUII_ListSelect |
MUII_MARKBACKGROUND |
MUII_MARKHALFSHINE |
MUII_MARKSHINE |
MUII_Menudisplay
MUII_Network |
MUII_PageBack |
MUII_PopDrawer |
MUII_PopFile |
MUII_PopFont
MUII_PopUp |
MUII_PopupBack |
MUII_PropBack |
MUII_PropKnob |
MUII_PullOpen
MUII_RadioButton |
MUII_ReadListBack |
MUII_RegisterBack |
MUII_RequesterBack |
MUII_SelectedBack |
MUII_SHADOW |
MUII_SHADOWBACK |
MUII_SHADOWFILL |
MUII_SHADOWSHINE |
MUII_SHINE |
MUII_SHINEBACK |
MUII_SliderBack |
MUII_SliderKnob |
MUII_StringActiveBack
MUII_StringBack
MUII_TapeDown |
MUII_TapePause |
MUII_TapePlay |
MUII_TapePlayBack |
MUII_TapeRecord |
MUII_TapeStop |
MUII_TapeUp |
MUII_TextBack |
MUII_Volume |
MUII_WindowBack |
MUIKEYF_BOTTOM |
MUIKEYF_DOWN |
MUIKEYF_GADGET_NEXT |
MUIKEYF_GADGET_OFF |
MUIKEYF_GADGET_PREV |
MUIKEYF_HELP |
MUIKEYF_LEFT |
MUIKEYF_LINEEND |
MUIKEYF_LINESTART |
MUIKEYF_PAGEDOWN |
MUIKEYF_PAGEUP |
MUIKEYF_POPUP |
MUIKEYF_PRESS |
MUIKEYF_RIGHT |
MUIKEYF_TOGGLE |
MUIKEYF_TOP |
MUIKEYF_UP |
MUIKEYF_WINDOW_CLOSE |
MUIKEYF_WINDOW_NEXT |
MUIKEYF_WINDOW_PREV |
MUIKEYF_WORDLEFT |
MUIKEYF_WORDRIGHT |
MUIKEY_BOTTOM |
MUIKEY_COUNT |
MUIKEY_DOWN |
MUIKEY_GADGET_NEXT |
MUIKEY_GADGET_OFF |
MUIKEY_GADGET_PREV |
MUIKEY_HELP |
MUIKEY_LEFT |
MUIKEY_LINEEND |
MUIKEY_LINESTART |
MUIKEY_NONE |
MUIKEY_PAGEDOWN |
MUIKEY_PAGEUP |
MUIKEY_POPUP |
MUIKEY_PRESS |
MUIKEY_RELEASE |
MUIKEY_RIGHT |
MUIKEY_TOGGLE |
MUIKEY_TOP |
MUIKEY_UP |
MUIKEY_WINDOW_CLOSE |
MUIKEY_WINDOW_NEXT |
MUIKEY_WINDOW_PREV |
MUIKEY_WORDLEFT |
MUIKEY_WORDRIGHT |
MUILM_LAYOUT |
MUILM_MINMAX |
MUILM_UNKNOWN |
MUIMASTER_NAME |
MUIMASTER_VLATEST |
MUIMASTER_VMIN |
MUIMRI_RECTFILL |
MUIMRI_REFRESHMODE |
MUIMRI_THINFRAMES |
MUIMRI_TRUECOLOR |
MUIM_Application_AboutMUI |
MUIM_Application_AddInputHandler |
MUIM_Application_BuildSettingsPanel
MUIM_Application_CheckRefresh |
MUIM_Application_DefaultConfigItem
MUIM_Application_InputBuffered |
MUIM_Application_Load |
MUIM_Application_NewInput |
MUIM_Application_OpenConfigWindow |
MUIM_Application_PushMethod |
MUIM_Application_RemInputHandler |
MUIM_Application_ReturnID |
MUIM_Application_Save |
MUIM_Application_SetConfigItem |
MUIM_Application_ShowHelp |
MUIM_AskMinMax |
MUIM_BoopsiQuery |
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Cleanup |
MUIM_ContextMenuAdd
MUIM_ContextMenuBuild |
MUIM_ContextMenuChoice |
MUIM_CreateBubble |
MUIM_CreateShortHelp |
MUIM_Dataspace_Add |
MUIM_Dataspace_Clear |
MUIM_Dataspace_Find |
MUIM_Dataspace_Merge |
MUIM_Dataspace_ReadIFF |
MUIM_Dataspace_Remove |
MUIM_Dataspace_WriteIFF |
MUIM_DeleteBubble |
MUIM_DeleteShortHelp |
MUIM_Dirlist_ReRead |
MUIM_DoDrag
MUIM_DragBegin |
MUIM_DragDrop |
MUIM_DragFinish |
MUIM_DragQuery |
MUIM_DragReport |
MUIM_Draw |
MUIM_DrawBackground |
MUIM_Export | Called on export object to dataspace
MUIM_Family_AddHead |
MUIM_Family_AddTail |
MUIM_Family_Insert |
MUIM_Family_Remove |
MUIM_Family_Sort |
MUIM_Family_Transfer |
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData |
MUIM_Group_ExitChange |
MUIM_Group_InitChange |
MUIM_Group_Sort |
MUIM_HandleEvent |
MUIM_HandleInput |
MUIM_Hide |
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_List_Clear |
MUIM_List_CreateImage |
MUIM_List_DeleteImage |
MUIM_List_Exchange |
MUIM_List_GetEntry |
MUIM_List_Insert |
MUIM_List_InsertSingle |
MUIM_List_Jump |
MUIM_List_Move |
MUIM_List_NextSelected |
MUIM_List_Redraw |
MUIM_List_Remove |
MUIM_List_Select |
MUIM_List_Sort |
MUIM_List_TestPos |
MUIM_Menustrip_ExitChange
MUIM_Menustrip_InitChange
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Set but doesn't trigger any notification.
MUIM_Notify | Add a notification event handler to an object
MUIM_Numeric_Decrease |
MUIM_Numeric_Increase |
MUIM_Numeric_ScaleToValue |
MUIM_Numeric_SetDefault |
MUIM_Numeric_Stringify |
MUIM_Numeric_ValueToScale |
MUIM_Pendisplay_SetColormap |
MUIM_Pendisplay_SetMUIPen |
MUIM_Pendisplay_SetRGB |
MUIM_Popstring_Close |
MUIM_Popstring_Open |
MUIM_Prop_Decrease |
MUIM_Prop_Increase |
MUIM_Semaphore_Attempt |
MUIM_Semaphore_AttemptShared |
MUIM_Semaphore_Obtain |
MUIM_Semaphore_ObtainShared |
MUIM_Semaphore_Release |
MUIM_Set | Set an attribute to a value.
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_Settingsgroup_ConfigToGadgets |
MUIM_Settingsgroup_GadgetsToConfig |
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_Setup |
MUIM_Show |
MUIM_UpdateConfig
MUIM_Window_AddEventHandler |
MUIM_Window_Cleanup
MUIM_Window_RemEventHandler |
MUIM_Window_ScreenToBack |
MUIM_Window_ScreenToFront |
MUIM_Window_Setup
MUIM_Window_Snapshot |
MUIM_Window_ToBack |
MUIM_Window_ToFront |
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.
MUIO_BarTitle |
MUIO_Button |
MUIO_Checkmark |
MUIO_Cycle |
MUIO_HBar |
MUIO_HSpace |
MUIO_Label |
MUIO_Label_Centered |
MUIO_Label_DoubleFrame |
MUIO_Label_FreeVert |
MUIO_Label_LeftAligned |
MUIO_Label_SingleFrame |
MUIO_Menuitem |
MUIO_Menuitem_CopyStrings |
MUIO_MenustripNM |
MUIO_MenustripNM_CommandKeyCheck |
MUIO_NumericButton |
MUIO_PopButton |
MUIO_Radio |
MUIO_Slider |
MUIO_String |
MUIO_VBar |
MUIO_VSpace |
MUIPEN_MASK |
MUIV_Application_OCW_ScreenPage
MUIV_Application_ReturnID_Quit |
MUIV_ContextMenuBuild_Default
MUIV_CreateBubble_DontHidePointer
MUIV_Cycle_Active_Next |
MUIV_Cycle_Active_Prev |
MUIV_Dirlist_SortDirs_First |
MUIV_Dirlist_SortDirs_Last |
MUIV_Dirlist_SortDirs_Mix |
MUIV_Dirlist_SortType_Date |
MUIV_Dirlist_SortType_Name |
MUIV_Dirlist_SortType_Size |
MUIV_Dirlist_Status_Invalid |
MUIV_Dirlist_Status_Reading |
MUIV_Dirlist_Status_Valid |
MUIV_DragQuery_Accept |
MUIV_DragQuery_Refuse |
MUIV_DragReport_Abort |
MUIV_DragReport_Continue |
MUIV_DragReport_Lock |
MUIV_DragReport_Refresh |
MUIV_EveryTime |
MUIV_Family_GetChild_First
MUIV_Family_GetChild_Iterate
MUIV_Family_GetChild_Last
MUIV_Family_GetChild_Next
MUIV_Family_GetChild_Previous
MUIV_Font_Big |
MUIV_Font_Button |
MUIV_Font_Fixed |
MUIV_Font_Gauge
MUIV_Font_Inherit |
MUIV_Font_List |
MUIV_Font_Menudisplay
MUIV_Font_Normal |
MUIV_Font_Slider
MUIV_Font_Tiny |
MUIV_Font_Title |
MUIV_Frame_Button |
MUIV_Frame_Count |
MUIV_Frame_Gauge |
MUIV_Frame_GaugeInner
MUIV_Frame_Group |
MUIV_Frame_ImageButton |
MUIV_Frame_InputList |
MUIV_Frame_Menudisplay
MUIV_Frame_MenudisplayMenu
MUIV_Frame_None |
MUIV_Frame_Page
MUIV_Frame_PopUp |
MUIV_Frame_Prop |
MUIV_Frame_PropKnob
MUIV_Frame_ReadList |
MUIV_Frame_Register
MUIV_Frame_Requester
MUIV_Frame_Slider |
MUIV_Frame_SliderKnob
MUIV_Frame_String |
MUIV_Frame_Text |
MUIV_Frame_Virtual |
MUIV_Frame_Window
MUIV_Group_ActivePage_Advance |
MUIV_Group_ActivePage_First |
MUIV_Group_ActivePage_Last |
MUIV_Group_ActivePage_Next |
MUIV_Group_ActivePage_Prev |
MUIV_Group_GetChild_First
MUIV_Group_GetChild_Iterate
MUIV_Group_GetChild_Last
MUIV_Group_GetChild_Next
MUIV_Group_GetChild_Previous
MUIV_Imageadjust_Type_All |
MUIV_Imageadjust_Type_Background |
MUIV_Imageadjust_Type_Image |
MUIV_Imageadjust_Type_Pen |
MUIV_InputMode_Immediate |
MUIV_InputMode_None |
MUIV_InputMode_RelVerify |
MUIV_InputMode_Toggle |
MUIV_Listview_DragType_Immediate |
MUIV_Listview_DragType_None |
MUIV_Listview_MultiSelect_Always |
MUIV_Listview_MultiSelect_Default |
MUIV_Listview_MultiSelect_None |
MUIV_Listview_MultiSelect_Shifted |
MUIV_Listview_ScrollerPos_Default |
MUIV_Listview_ScrollerPos_Left |
MUIV_Listview_ScrollerPos_None |
MUIV_Listview_ScrollerPos_Right |
MUIV_List_Active_Bottom |
MUIV_List_Active_Down |
MUIV_List_Active_Off |
MUIV_List_Active_PageDown |
MUIV_List_Active_PageUp |
MUIV_List_Active_Top |
MUIV_List_Active_Up |
MUIV_List_ConstructHook_String |
MUIV_List_CopyHook_String |
MUIV_List_CursorType_Bar |
MUIV_List_CursorType_None |
MUIV_List_CursorType_Rect |
MUIV_List_DestructHook_String |
MUIV_List_EditEntry_Active
MUIV_List_Exchange_Active |
MUIV_List_Exchange_Bottom |
MUIV_List_Exchange_Next |
MUIV_List_Exchange_Previous |
MUIV_List_Exchange_Top |
MUIV_List_GetEntry_Active |
MUIV_List_Insert_Active |
MUIV_List_Insert_Bottom |
MUIV_List_Insert_Sorted |
MUIV_List_Insert_Top |
MUIV_List_Jump_Active |
MUIV_List_Jump_Bottom |
MUIV_List_Jump_Down |
MUIV_List_Jump_Top |
MUIV_List_Jump_Up |
MUIV_List_Move_Active |
MUIV_List_Move_Bottom |
MUIV_List_Move_Next |
MUIV_List_Move_Previous |
MUIV_List_Move_Top |
MUIV_List_NextSelected_End |
MUIV_List_NextSelected_Start |
MUIV_List_Redraw_Active |
MUIV_List_Redraw_All |
MUIV_List_Remove_Active |
MUIV_List_Remove_First |
MUIV_List_Remove_Last |
MUIV_List_Remove_Selected |
MUIV_List_Select_Active |
MUIV_List_Select_All |
MUIV_List_Select_Ask |
MUIV_List_Select_Off |
MUIV_List_Select_On |
MUIV_List_Select_Toggle |
MUIV_Menuitem_Shortcut_Check |
MUIV_Notify_Application |
MUIV_Notify_Parent |
MUIV_Notify_ParentParent
MUIV_Notify_ParentParentParent
MUIV_Notify_Self |
MUIV_Notify_Window |
MUIV_NotTriggerValue |
MUIV_Palette_Entry_End |
MUIV_Prop_UseWinBorder_Bottom |
MUIV_Prop_UseWinBorder_Left |
MUIV_Prop_UseWinBorder_None |
MUIV_Prop_UseWinBorder_Right |
MUIV_Scrollbar_Type_Bottom |
MUIV_Scrollbar_Type_Default |
MUIV_Scrollbar_Type_Sym |
MUIV_Scrollbar_Type_Top |
MUIV_String_Format_Center |
MUIV_String_Format_Left |
MUIV_String_Format_Right |
MUIV_Text_Shorten_Cutoff
MUIV_Text_Shorten_Hide
MUIV_Text_Shorten_Nothing
MUIV_TriggerValue |
MUIV_Window_ActiveObject_Down
MUIV_Window_ActiveObject_Left
MUIV_Window_ActiveObject_Next |
MUIV_Window_ActiveObject_None |
MUIV_Window_ActiveObject_Prev |
MUIV_Window_ActiveObject_Right
MUIV_Window_ActiveObject_Up
MUIV_Window_AltHeight_Scaled |
MUIV_Window_AltLeftEdge_Centered |
MUIV_Window_AltLeftEdge_Moused |
MUIV_Window_AltLeftEdge_NoChange |
MUIV_Window_AltTopEdge_Centered |
MUIV_Window_AltTopEdge_Moused |
MUIV_Window_AltTopEdge_NoChange |
MUIV_Window_AltWidth_Scaled |
MUIV_Window_Height_Default |
MUIV_Window_Height_Scaled |
MUIV_Window_LeftEdge_Centered |
MUIV_Window_LeftEdge_Moused |
MUIV_Window_TopEdge_Centered |
MUIV_Window_TopEdge_Moused |
MUIV_Window_Width_Default |
MUIV_Window_Width_Scaled |
MUIX_B |
MUIX_C |
MUIX_I |
MUIX_L |
MUIX_N |
MUIX_PH |
MUIX_PT |
MUIX_R |
MUIX_U |
MUI_EHF_ALWAYSKEYS |
MUI_END
MUI_EventHandlerRC_Eat |
MUI_FALSE
MUI_LPR_ABOVE |
MUI_LPR_BELOW |
MUI_LPR_LEFT |
MUI_LPR_RIGHT |
MUI_MAXMAX |
MUI_RXERR_BADDEFINITION |
MUI_RXERR_BADSYNTAX |
MUI_RXERR_OUTOFMEMORY |
MUI_RXERR_UNKNOWNCOMMAND |
MUI_TRUE
PSD_FILENAME_SAVE |
PSD_FILENAME_USE |
PSD_INITIAL_NAME |
PSD_INITIAL_TITLE |
PSD_MAXLEN_BACKGROUND |
PSD_MAXLEN_FONT |
PSD_MAXLEN_NAME |
PSD_MAXLEN_TITLE |
PSD_MAXMUIPENS |
PSD_MAXSYSPENS |
PSD_NAME_FRONTMOST |
PSD_NUMCOLS |
PSD_NUMMUIPENS |
PSD_NUMSYSPENS |


Reference for unit 'mui': Types

MUIP_BoopsiQuery

MUIP_Dirlist_ReRead

MUIP_Pendisplay_SetColormap

MUIP_Pendisplay_SetMUIPen

MUIP_Pendisplay_SetRGB

plongword

pMUIP_Application_AboutMUI

pMUIP_Application_AddInputHandler

pMUIP_Application_BuildSettingsPanel

pMUIP_Application_CheckRefresh

pMUIP_Application_DefaultConfigItem

pMUIP_Application_GetMenuCheck

pMUIP_Application_GetMenuState

pMUIP_Application_Input

pMUIP_Application_InputBuffered

pMUIP_Application_NewInput

pMUIP_Application_OpenConfigWindow

pMUIP_Application_PushMethod

pMUIP_Application_RemInputHandler

pMUIP_Application_ReturnID

pMUIP_Application_SetConfigItem

pMUIP_Application_SetMenuCheck

pMUIP_Application_SetMenuState

pMUIP_Application_ShowHelp

pMUIP_AskMinMax

pMUIP_CallHook

pMUIP_Cleanup

pMUIP_ContextMenuAdd

pMUIP_ContextMenuBuild

pMUIP_ContextMenuChoice

pMUIP_CreateBubble

pMUIP_CreateShortHelp

pMUIP_Dataspace_Add

pMUIP_Dataspace_Clear

pMUIP_Dataspace_Find

pMUIP_Dataspace_Merge

pMUIP_Dataspace_ReadIFF

pMUIP_Dataspace_Remove

pMUIP_Dataspace_WriteIFF

pMUIP_DeleteBubble

pMUIP_DeleteShortHelp

pMUIP_DoDrag

pMUIP_DragBegin

pMUIP_DragDrop

pMUIP_DragFinish

pMUIP_DragQuery

pMUIP_DragReport

pMUIP_Draw

pMUIP_DrawBackground

pMUIP_Export

pMUIP_Family_AddHead

pMUIP_Family_AddTail

pMUIP_Family_Insert

pMUIP_Family_Remove

pMUIP_Family_Sort

pMUIP_Family_Transfer

pMUIP_FindUData

pMUIP_GetConfigItem

pMUIP_GetUData

pMUIP_Group_ExitChange

pMUIP_Group_InitChange

pMUIP_Group_Sort

pMUIP_HandleEvent

pMUIP_HandleInput

pMUIP_Hide

pMUIP_Import

pMUIP_KillNotify

pMUIP_KillNotifyObj

pMUIP_List_Clear

pMUIP_List_CreateImage

pMUIP_List_DeleteImage

pMUIP_List_Exchange

pMUIP_List_GetEntry

pMUIP_List_Insert

pMUIP_List_InsertSingle

pMUIP_List_Jump

pMUIP_List_Move

pMUIP_List_NextSelected

pMUIP_List_Redraw

pMUIP_List_Remove

pMUIP_List_Select

pMUIP_List_Sort

pMUIP_List_TestPos

pMUIP_Menustrip_ExitChange

pMUIP_Menustrip_InitChange

pMUIP_MultiSet

pMUIP_NoNotifySet

pMUIP_Notify

pMUIP_Numeric_Decrease

pMUIP_Numeric_Increase

pMUIP_Numeric_ScaleToValue

pMUIP_Numeric_SetDefault

pMUIP_Numeric_Stringify

pMUIP_Numeric_ValueToScale

pMUIP_Popstring_Close

pMUIP_Popstring_Open

pMUIP_Prop_Decrease

pMUIP_Prop_Increase

pMUIP_Semaphore_Attempt

pMUIP_Semaphore_AttemptShared

pMUIP_Semaphore_Obtain

pMUIP_Semaphore_ObtainShared

pMUIP_Semaphore_Release

pMUIP_Set

pMUIP_SetAsString

pMUIP_Settingsgroup_ConfigToGadgets

pMUIP_Settingsgroup_GadgetsToConfig

pMUIP_SetUData

pMUIP_SetUDataOnce

pMUIP_Setup

pMUIP_Show

pMUIP_UpdateConfig

pMUIP_Window_AddEventHandler

pMUIP_Window_Cleanup

pMUIP_Window_GetMenuCheck

pMUIP_Window_GetMenuState

pMUIP_Window_RemEventHandler

pMUIP_Window_ScreenToBack

pMUIP_Window_ScreenToFront

pMUIP_Window_SetCycleChain

pMUIP_Window_SetMenuCheck

pMUIP_Window_SetMenuState

pMUIP_Window_Setup

pMUIP_Window_Snapshot

pMUIP_Window_ToBack

pMUIP_Window_ToFront

pMUIP_WriteLong

pMUIP_WriteString

pMUIS_InfoClient

pMUI_AreaData

pMUI_BoopsiQuery

pMUI_Command

pMUI_CustomClass

pMUI_EventHandlerNode

pMUI_GlobalInfo

pMUI_InputHandlerNode

pMUI_LayoutMsg

pMUI_List_TestPos_Result

pMUI_MinMax

pMUI_NotifyData

pMUI_Palette_Entry

pMUI_PenSpec

pMUI_PubScreenDesc

pMUI_RenderInfo

pMUI_RGBColor

p__dummyXFC2__

tMUIP_Application_AboutMUI

tMUIP_Application_AddInputHandler

tMUIP_Application_BuildSettingsPanel

tMUIP_Application_CheckRefresh

tMUIP_Application_DefaultConfigItem

tMUIP_Application_GetMenuCheck

tMUIP_Application_GetMenuState

tMUIP_Application_Input

tMUIP_Application_InputBuffered

tMUIP_Application_Load

tMUIP_Application_NewInput

tMUIP_Application_OpenConfigWindow

tMUIP_Application_PushMethod

tMUIP_Application_RemInputHandler

tMUIP_Application_ReturnID

tMUIP_Application_Save

tMUIP_Application_SetConfigItem

tMUIP_Application_SetMenuCheck

tMUIP_Application_SetMenuState

tMUIP_Application_ShowHelp

tMUIP_AskMinMax

tMUIP_CallHook

tMUIP_Cleanup

tMUIP_ContextMenuAdd

tMUIP_ContextMenuBuild

tMUIP_ContextMenuChoice

tMUIP_CreateBubble

tMUIP_CreateShortHelp

tMUIP_Dataspace_Add

tMUIP_Dataspace_Clear

tMUIP_Dataspace_Find

tMUIP_Dataspace_Merge

tMUIP_Dataspace_ReadIFF

tMUIP_Dataspace_Remove

tMUIP_Dataspace_WriteIFF

tMUIP_DeleteBubble

tMUIP_DeleteShortHelp

tMUIP_DoDrag

tMUIP_DragBegin

tMUIP_DragDrop

tMUIP_DragFinish

tMUIP_DragQuery

tMUIP_DragReport

tMUIP_Draw

tMUIP_DrawBackground

tMUIP_Export

tMUIP_Family_AddHead

tMUIP_Family_AddTail

tMUIP_Family_Insert

tMUIP_Family_Remove

tMUIP_Family_Sort

tMUIP_Family_Transfer

tMUIP_FindUData

tMUIP_GetConfigItem

tMUIP_GetUData

tMUIP_Group_ExitChange

tMUIP_Group_InitChange

tMUIP_Group_Sort

tMUIP_HandleEvent

tMUIP_HandleInput

tMUIP_Hide

tMUIP_Import

tMUIP_KillNotify

tMUIP_KillNotifyObj

tMUIP_List_Clear

tMUIP_List_CreateImage

tMUIP_List_DeleteImage

tMUIP_List_Exchange

tMUIP_List_GetEntry

tMUIP_List_Insert

tMUIP_List_InsertSingle

tMUIP_List_Jump

tMUIP_List_Move

tMUIP_List_NextSelected

tMUIP_List_Redraw

tMUIP_List_Remove

tMUIP_List_Select

tMUIP_List_Sort

tMUIP_List_TestPos

tMUIP_Menustrip_ExitChange

tMUIP_Menustrip_InitChange

tMUIP_MultiSet

tMUIP_NoNotifySet

tMUIP_Notify

tMUIP_Numeric_Decrease

tMUIP_Numeric_Increase

tMUIP_Numeric_ScaleToValue

tMUIP_Numeric_SetDefault

tMUIP_Numeric_Stringify

tMUIP_Numeric_ValueToScale

tMUIP_Popstring_Close

tMUIP_Popstring_Open

tMUIP_Prop_Decrease

tMUIP_Prop_Increase

tMUIP_Semaphore_Attempt

tMUIP_Semaphore_AttemptShared

tMUIP_Semaphore_Obtain

tMUIP_Semaphore_ObtainShared

tMUIP_Semaphore_Release

tMUIP_Set

tMUIP_SetAsString

tMUIP_Settingsgroup_ConfigToGadgets

tMUIP_Settingsgroup_GadgetsToConfig

tMUIP_SetUData

tMUIP_SetUDataOnce

tMUIP_Setup

tMUIP_Show

tMUIP_UpdateConfig

tMUIP_Window_AddEventHandler

tMUIP_Window_Cleanup

tMUIP_Window_GetMenuCheck

tMUIP_Window_GetMenuState

tMUIP_Window_RemEventHandler

tMUIP_Window_ScreenToBack

tMUIP_Window_ScreenToFront

tMUIP_Window_SetCycleChain

tMUIP_Window_SetMenuCheck

tMUIP_Window_SetMenuState

tMUIP_Window_Setup

tMUIP_Window_Snapshot

tMUIP_Window_ToBack

tMUIP_Window_ToFront

tMUIP_WriteLong

tMUIP_WriteString

tMUIS_InfoClient

tMUI_AreaData

tMUI_BoopsiQuery

tMUI_Command

tMUI_CustomClass

tMUI_EventHandlerNode

tMUI_GlobalInfo

tMUI_InputHandlerNode

tMUI_LayoutMsg

tMUI_List_TestPos_Result

tMUI_MinMax

tMUI_NotifyData

tMUI_Palette_Entry

tMUI_PenSpec

tMUI_PubScreenDesc

tMUI_RenderInfo

tMUI_RGBcolor

t__dummyXFC2__


MADF_DRAWOBJECT

Declaration

Source position: mui.pas line 3174

const MADF_DRAWOBJECT = 1 shl 0;


MADF_DRAWUPDATE

Declaration

Source position: mui.pas line 3176

const MADF_DRAWUPDATE = 1 shl 1;


MBQ_MUI_MAXMAX

Declaration

Source position: mui.pas line 686

const MBQ_MUI_MAXMAX = 10000;


MBQF_HORIZ

Declaration

Source position: mui.pas line 683

const MBQF_HORIZ = 1 shl 0;


MC_TEMPLATE_ID

Declaration

Source position: mui.pas line 300

const MC_TEMPLATE_ID = - 1;


MPEN_BACKGROUND

Declaration

Source position: mui.pas line 3180

const MPEN_BACKGROUND = 2;


MPEN_COUNT

Declaration

Source position: mui.pas line 3186

const MPEN_COUNT = 8;


MPEN_FILL

Declaration

Source position: mui.pas line 3184

const MPEN_FILL = 6;


MPEN_HALFSHADOW

Declaration

Source position: mui.pas line 3181

const MPEN_HALFSHADOW = 3;


MPEN_HALFSHINE

Declaration

Source position: mui.pas line 3179

const MPEN_HALFSHINE = 1;


MPEN_MARK

Declaration

Source position: mui.pas line 3185

const MPEN_MARK = 7;


MPEN_SHADOW

Declaration

Source position: mui.pas line 3182

const MPEN_SHADOW = 4;


MPEN_SHINE

Declaration

Source position: mui.pas line 3178

const MPEN_SHINE = 0;


MPEN_TEXT

Declaration

Source position: mui.pas line 3183

const MPEN_TEXT = 5;


MUI_EHF_ALWAYSKEYS

Declaration

Source position: mui.pas line 583

const MUI_EHF_ALWAYSKEYS = 1 shl 0;


MUI_END

Declaration

Source position: mui.pas line 148

const MUI_END = TAG_DONE;


MUI_EventHandlerRC_Eat

Declaration

Source position: mui.pas line 587

const MUI_EventHandlerRC_Eat = 1 shl 0;


MUI_FALSE

Declaration

Source position: mui.pas line 145

const MUI_FALSE = 0;


MUI_LPR_ABOVE

Declaration

Source position: mui.pas line 610

const MUI_LPR_ABOVE = 1 shl 0;


MUI_LPR_BELOW

Declaration

Source position: mui.pas line 611

const MUI_LPR_BELOW = 1 shl 1;


MUI_LPR_LEFT

Declaration

Source position: mui.pas line 612

const MUI_LPR_LEFT = 1 shl 2;


MUI_LPR_RIGHT

Declaration

Source position: mui.pas line 613

const MUI_LPR_RIGHT = 1 shl 3;


MUI_MAXMAX

Declaration

Source position: mui.pas line 3114

const MUI_MAXMAX = 10000;


MUI_RXERR_BADDEFINITION

Declaration

Source position: mui.pas line 301

const MUI_RXERR_BADDEFINITION = - 1;


MUI_RXERR_BADSYNTAX

Declaration

Source position: mui.pas line 304

const MUI_RXERR_BADSYNTAX = - 4;


MUI_RXERR_OUTOFMEMORY

Declaration

Source position: mui.pas line 302

const MUI_RXERR_OUTOFMEMORY = - 2;


MUI_RXERR_UNKNOWNCOMMAND

Declaration

Source position: mui.pas line 303

const MUI_RXERR_UNKNOWNCOMMAND = - 3;


MUI_TRUE

Declaration

Source position: mui.pas line 144

const MUI_TRUE = 1;


MUIA_Aboutmui_Application

Declaration

Source position: mui.pas line 1362

const MUIA_Aboutmui_Application = $80422523;


MUIA_Application_Active

Declaration

Source position: mui.pas line 1132

const MUIA_Application_Active = $804260ab;


MUIA_Application_Author

Declaration

Source position: mui.pas line 1133

const MUIA_Application_Author = $80424842;


MUIA_Application_Base

Declaration

Source position: mui.pas line 1134

const MUIA_Application_Base = $8042e07a;


MUIA_Application_Broker

Declaration

Source position: mui.pas line 1135

const MUIA_Application_Broker = $8042dbce;


MUIA_Application_BrokerHook

Declaration

Source position: mui.pas line 1136

const MUIA_Application_BrokerHook = $80428f4b;


MUIA_Application_BrokerPort

Declaration

Source position: mui.pas line 1137

const MUIA_Application_BrokerPort = $8042e0ad;


MUIA_Application_BrokerPri

Declaration

Source position: mui.pas line 1138

const MUIA_Application_BrokerPri = $8042c8d0;


MUIA_Application_Commands

Declaration

Source position: mui.pas line 1139

const MUIA_Application_Commands = $80428648;


MUIA_Application_Copyright

Declaration

Source position: mui.pas line 1140

const MUIA_Application_Copyright = $8042ef4d;


MUIA_Application_Description

Declaration

Source position: mui.pas line 1141

const MUIA_Application_Description = $80421fc6;


MUIA_Application_DiskObject

Declaration

Source position: mui.pas line 1142

const MUIA_Application_DiskObject = $804235cb;


MUIA_Application_DoubleStart

Declaration

Source position: mui.pas line 1143

const MUIA_Application_DoubleStart = $80423bc6;


MUIA_Application_DropObject

Declaration

Source position: mui.pas line 1144

const MUIA_Application_DropObject = $80421266;


MUIA_Application_ForceQuit

Declaration

Source position: mui.pas line 1145

const MUIA_Application_ForceQuit = $804257df;


MUIA_Application_HelpFile

Declaration

Source position: mui.pas line 1146

const MUIA_Application_HelpFile = $804293f4;


MUIA_Application_Iconified

Declaration

Source position: mui.pas line 1147

const MUIA_Application_Iconified = $8042a07f;


MUIA_Application_MenuAction

Declaration

Source position: mui.pas line 1148

const MUIA_Application_MenuAction = $80428961;


MUIA_Application_MenuHelp

Declaration

Source position: mui.pas line 1149

const MUIA_Application_MenuHelp = $8042540b;


MUIA_Application_Menustrip

Declaration

Source position: mui.pas line 1150

const MUIA_Application_Menustrip = $804252d9;


MUIA_Application_RexxHook

Declaration

Source position: mui.pas line 1151

const MUIA_Application_RexxHook = $80427c42;


MUIA_Application_RexxMsg

Declaration

Source position: mui.pas line 1152

const MUIA_Application_RexxMsg = $8042fd88;


MUIA_Application_RexxString

Declaration

Source position: mui.pas line 1153

const MUIA_Application_RexxString = $8042d711;


MUIA_Application_SingleTask

Declaration

Source position: mui.pas line 1154

const MUIA_Application_SingleTask = $8042a2c8;


MUIA_Application_Sleep

Declaration

Source position: mui.pas line 1155

const MUIA_Application_Sleep = $80425711;


MUIA_Application_Title

Declaration

Source position: mui.pas line 1156

const MUIA_Application_Title = $804281b8;


MUIA_Application_UseCommodities

Declaration

Source position: mui.pas line 1157

const MUIA_Application_UseCommodities = $80425ee5;


MUIA_Application_UsedClasses

Declaration

Source position: mui.pas line 1158

const MUIA_Application_UsedClasses = $8042e9a7;


MUIA_Application_UseRexx

Declaration

Source position: mui.pas line 1159

const MUIA_Application_UseRexx = $80422387;


MUIA_Application_Version

Declaration

Source position: mui.pas line 1160

const MUIA_Application_Version = $8042b33f;


MUIA_Application_Window

Declaration

Source position: mui.pas line 1161

const MUIA_Application_Window = $8042bfe0;


MUIA_Application_WindowList

Declaration

Source position: mui.pas line 1162

const MUIA_Application_WindowList = $80429abe;


MUIA_ApplicationObject

Declaration

Source position: mui.pas line 842

const MUIA_ApplicationObject = $8042d3ee;


MUIA_AppMessage

Declaration

Source position: mui.pas line 843

const MUIA_AppMessage = $80421955;


MUIA_Background

Declaration

Source position: mui.pas line 1575

const MUIA_Background = $8042545b;


MUIA_Balance_Quiet

Declaration

Source position: mui.pas line 1700

const MUIA_Balance_Quiet = $80427486;


MUIA_Bitmap_Alpha

Declaration

Source position: mui.pas line 1740

const MUIA_Bitmap_Alpha = $80423e71;


MUIA_Bitmap_Bitmap

Declaration

Source position: mui.pas line 1741

const MUIA_Bitmap_Bitmap = $804279bd;


MUIA_Bitmap_Height

Declaration

Source position: mui.pas line 1742

const MUIA_Bitmap_Height = $80421560;


MUIA_Bitmap_MappingTable

Declaration

Source position: mui.pas line 1743

const MUIA_Bitmap_MappingTable = $8042e23d;


MUIA_Bitmap_Precision

Declaration

Source position: mui.pas line 1744

const MUIA_Bitmap_Precision = $80420c74;


MUIA_Bitmap_RemappedBitmap

Declaration

Source position: mui.pas line 1745

const MUIA_Bitmap_RemappedBitmap = $80423a47;


MUIA_Bitmap_SourceColors

Declaration

Source position: mui.pas line 1746

const MUIA_Bitmap_SourceColors = $80425360;


MUIA_Bitmap_Transparent

Declaration

Source position: mui.pas line 1747

const MUIA_Bitmap_Transparent = $80422805;


MUIA_Bitmap_UseFriend

Declaration

Source position: mui.pas line 1748

const MUIA_Bitmap_UseFriend = $804239d8;


MUIA_Bitmap_Width

Declaration

Source position: mui.pas line 1749

const MUIA_Bitmap_Width = $8042eb3a;


MUIA_Bodychunk_Body

Declaration

Source position: mui.pas line 1761

const MUIA_Bodychunk_Body = $8042ca67;


MUIA_Bodychunk_Compression

Declaration

Source position: mui.pas line 1762

const MUIA_Bodychunk_Compression = $8042de5f;


MUIA_Bodychunk_Depth

Declaration

Source position: mui.pas line 1763

const MUIA_Bodychunk_Depth = $8042c392;


MUIA_Bodychunk_Masking

Declaration

Source position: mui.pas line 1764

const MUIA_Bodychunk_Masking = $80423b0e;


MUIA_Boopsi_Class

Declaration

Source position: mui.pas line 1846

const MUIA_Boopsi_Class = $80426999;


MUIA_Boopsi_ClassID

Declaration

Source position: mui.pas line 1847

const MUIA_Boopsi_ClassID = $8042bfa3;


MUIA_Boopsi_MaxHeight

Declaration

Source position: mui.pas line 1848

const MUIA_Boopsi_MaxHeight = $8042757f;


MUIA_Boopsi_MaxWidth

Declaration

Source position: mui.pas line 1849

const MUIA_Boopsi_MaxWidth = $8042bcb1;


MUIA_Boopsi_MinHeight

Declaration

Source position: mui.pas line 1850

const MUIA_Boopsi_MinHeight = $80422c93;


MUIA_Boopsi_MinWidth

Declaration

Source position: mui.pas line 1851

const MUIA_Boopsi_MinWidth = $80428fb2;


MUIA_Boopsi_Object

Declaration

Source position: mui.pas line 1852

const MUIA_Boopsi_Object = $80420178;


MUIA_Boopsi_Remember

Declaration

Source position: mui.pas line 1853

const MUIA_Boopsi_Remember = $8042f4bd;


MUIA_Boopsi_Smart

Declaration

Source position: mui.pas line 1854

const MUIA_Boopsi_Smart = $8042b8d7;


MUIA_Boopsi_TagDrawInfo

Declaration

Source position: mui.pas line 1855

const MUIA_Boopsi_TagDrawInfo = $8042bae7;


MUIA_Boopsi_TagScreen

Declaration

Source position: mui.pas line 1856

const MUIA_Boopsi_TagScreen = $8042bc71;


MUIA_Boopsi_TagWindow

Declaration

Source position: mui.pas line 1857

const MUIA_Boopsi_TagWindow = $8042e11d;


MUIA_BottomEdge

Declaration

Source position: mui.pas line 1576

const MUIA_BottomEdge = $8042e552;


MUIA_Coloradjust_Blue

Declaration

Source position: mui.pas line 2789

const MUIA_Coloradjust_Blue = $8042b8a3;


MUIA_Coloradjust_Green

Declaration

Source position: mui.pas line 2791

const MUIA_Coloradjust_Green = $804285ab;


MUIA_Coloradjust_ModeID

Declaration

Source position: mui.pas line 2793

const MUIA_Coloradjust_ModeID = $8042ec59;


MUIA_Coloradjust_Red

Declaration

Source position: mui.pas line 2795

const MUIA_Coloradjust_Red = $80420eaa;


MUIA_Coloradjust_RGB

Declaration

Source position: mui.pas line 2797

const MUIA_Coloradjust_RGB = $8042f899;


MUIA_Colorfield_Blue

Declaration

Source position: mui.pas line 1939

const MUIA_Colorfield_Blue = $8042d3b0;


MUIA_Colorfield_Green

Declaration

Source position: mui.pas line 1940

const MUIA_Colorfield_Green = $80424466;


MUIA_Colorfield_Pen

Declaration

Source position: mui.pas line 1941

const MUIA_Colorfield_Pen = $8042713a;


MUIA_Colorfield_Red

Declaration

Source position: mui.pas line 1942

const MUIA_Colorfield_Red = $804279f6;


MUIA_Colorfield_RGB

Declaration

Source position: mui.pas line 1943

const MUIA_Colorfield_RGB = $8042677a;


MUIA_ContextMenu

Declaration

Source position: mui.pas line 1577

const MUIA_ContextMenu = $8042b704;


MUIA_ContextMenuTrigger

Declaration

Source position: mui.pas line 1578

const MUIA_ContextMenuTrigger = $8042a2c1;


MUIA_ControlChar

Declaration

Source position: mui.pas line 1579

const MUIA_ControlChar = $8042120b;


MUIA_Cycle_Active

Declaration

Source position: mui.pas line 2771

const MUIA_Cycle_Active = $80421788;


MUIA_Cycle_Entries

Declaration

Source position: mui.pas line 2773

const MUIA_Cycle_Entries = $80420629;


MUIA_CycleChain

Declaration

Source position: mui.pas line 1580

const MUIA_CycleChain = $80421ce7;


MUIA_Dataspace_Pool

Declaration

Source position: mui.pas line 3061

const MUIA_Dataspace_Pool = $80424cf9;


MUIA_Dirlist_AcceptPattern

Declaration

Source position: mui.pas line 2209

const MUIA_Dirlist_AcceptPattern = $8042760a;


MUIA_Dirlist_Directory

Declaration

Source position: mui.pas line 2211

const MUIA_Dirlist_Directory = $8042ea41;


MUIA_Dirlist_DrawersOnly

Declaration

Source position: mui.pas line 2213

const MUIA_Dirlist_DrawersOnly = $8042b379;


MUIA_Dirlist_FilesOnly

Declaration

Source position: mui.pas line 2215

const MUIA_Dirlist_FilesOnly = $8042896a;


MUIA_Dirlist_FilterDrawers

Declaration

Source position: mui.pas line 2217

const MUIA_Dirlist_FilterDrawers = $80424ad2;


MUIA_Dirlist_FilterHook

Declaration

Source position: mui.pas line 2219

const MUIA_Dirlist_FilterHook = $8042ae19;


MUIA_Dirlist_MultiSelDirs

Declaration

Source position: mui.pas line 2221

const MUIA_Dirlist_MultiSelDirs = $80428653;


MUIA_Dirlist_NumBytes

Declaration

Source position: mui.pas line 2223

const MUIA_Dirlist_NumBytes = $80429e26;


MUIA_Dirlist_NumDrawers

Declaration

Source position: mui.pas line 2225

const MUIA_Dirlist_NumDrawers = $80429cb8;


MUIA_Dirlist_NumFiles

Declaration

Source position: mui.pas line 2227

const MUIA_Dirlist_NumFiles = $8042a6f0;


MUIA_Dirlist_Path

Declaration

Source position: mui.pas line 2229

const MUIA_Dirlist_Path = $80426176;


MUIA_Dirlist_RejectIcons

Declaration

Source position: mui.pas line 2231

const MUIA_Dirlist_RejectIcons = $80424808;


MUIA_Dirlist_RejectPattern

Declaration

Source position: mui.pas line 2233

const MUIA_Dirlist_RejectPattern = $804259c7;


MUIA_Dirlist_SortDirs

Declaration

Source position: mui.pas line 2235

const MUIA_Dirlist_SortDirs = $8042bbb9;


MUIA_Dirlist_SortHighLow

Declaration

Source position: mui.pas line 2237

const MUIA_Dirlist_SortHighLow = $80421896;


MUIA_Dirlist_SortType

Declaration

Source position: mui.pas line 2239

const MUIA_Dirlist_SortType = $804228bc;


MUIA_Dirlist_Status

Declaration

Source position: mui.pas line 2241

const MUIA_Dirlist_Status = $804240de;


MUIA_Disabled

Declaration

Source position: mui.pas line 1581

const MUIA_Disabled = $80423661;


MUIA_DoubleBuffer

Declaration

Source position: mui.pas line 1582

const MUIA_DoubleBuffer = $8042a9c7;


MUIA_Draggable

Declaration

Source position: mui.pas line 1583

const MUIA_Draggable = $80420b6e;


MUIA_Dropable

Declaration

Source position: mui.pas line 1584

const MUIA_Dropable = $8042fbce;


MUIA_Dtpic_Name

Declaration

Source position: mui.pas line 1674

const MUIA_Dtpic_Name = $80423d72;


MUIA_Family_Child

Declaration

Source position: mui.pas line 911

const MUIA_Family_Child = $8042c696;


MUIA_Family_List

Declaration

Source position: mui.pas line 912

const MUIA_Family_List = $80424b9e;


MUIA_FillArea

Declaration

Source position: mui.pas line 1585

const MUIA_FillArea = $804294a3;


MUIA_FixHeight

Declaration

Source position: mui.pas line 1586

const MUIA_FixHeight = $8042a92b;


MUIA_FixHeightTxt

Declaration

Source position: mui.pas line 1587

const MUIA_FixHeightTxt = $804276f2;


MUIA_FixWidth

Declaration

Source position: mui.pas line 1588

const MUIA_FixWidth = $8042a3f1;


MUIA_FixWidthTxt

Declaration

Source position: mui.pas line 1589

const MUIA_FixWidthTxt = $8042d044;


MUIA_Floattext_Justify

Declaration

Source position: mui.pas line 2163

const MUIA_Floattext_Justify = $8042dc03;


MUIA_Floattext_SkipChars

Declaration

Source position: mui.pas line 2165

const MUIA_Floattext_SkipChars = $80425c7d;


MUIA_Floattext_TabSize

Declaration

Source position: mui.pas line 2167

const MUIA_Floattext_TabSize = $80427d17;


MUIA_Floattext_Text

Declaration

Source position: mui.pas line 2169

const MUIA_Floattext_Text = $8042d16a;


MUIA_Font

Declaration

Source position: mui.pas line 1590

const MUIA_Font = $8042be50;


MUIA_Frame

Declaration

Source position: mui.pas line 1591

const MUIA_Frame = $8042ac64;


MUIA_FrameDynamic

Declaration

Source position: mui.pas line 1592

const MUIA_FrameDynamic = $804223c9;


MUIA_FramePhantomHoriz

Declaration

Source position: mui.pas line 1593

const MUIA_FramePhantomHoriz = $8042ed76;


MUIA_FrameTitle

Declaration

Source position: mui.pas line 1594

const MUIA_FrameTitle = $8042d1c7;


MUIA_FrameVisible

Declaration

Source position: mui.pas line 1595

const MUIA_FrameVisible = $80426498;


MUIA_Gadget_Gadget

Declaration

Source position: mui.pas line 1802

const MUIA_Gadget_Gadget = $8042ec1a;


MUIA_Gauge_Current

Declaration

Source position: mui.pas line 1910

const MUIA_Gauge_Current = $8042f0dd;


MUIA_Gauge_Divide

Declaration

Source position: mui.pas line 1911

const MUIA_Gauge_Divide = $8042d8df;


MUIA_Gauge_Horiz

Declaration

Source position: mui.pas line 1912

const MUIA_Gauge_Horiz = $804232dd;


MUIA_Gauge_InfoRate

Declaration

Source position: mui.pas line 1913

const MUIA_Gauge_InfoRate = $804253c8;


MUIA_Gauge_InfoText

Declaration

Source position: mui.pas line 1914

const MUIA_Gauge_InfoText = $8042bf15;


MUIA_Gauge_Max

Declaration

Source position: mui.pas line 1915

const MUIA_Gauge_Max = $8042bcdb;


MUIA_Group_ActivePage

Declaration

Source position: mui.pas line 2509

const MUIA_Group_ActivePage = $80424199;


MUIA_Group_Child

Declaration

Source position: mui.pas line 2511

const MUIA_Group_Child = $804226e6;


MUIA_Group_ChildList

Declaration

Source position: mui.pas line 2513

const MUIA_Group_ChildList = $80424748;


MUIA_Group_Columns

Declaration

Source position: mui.pas line 2515

const MUIA_Group_Columns = $8042f416;


MUIA_Group_Horiz

Declaration

Source position: mui.pas line 2517

const MUIA_Group_Horiz = $8042536b;


MUIA_Group_HorizSpacing

Declaration

Source position: mui.pas line 2519

const MUIA_Group_HorizSpacing = $8042c651;


MUIA_Group_LayoutHook

Declaration

Source position: mui.pas line 2521

const MUIA_Group_LayoutHook = $8042c3b2;


MUIA_Group_PageMode

Declaration

Source position: mui.pas line 2523

const MUIA_Group_PageMode = $80421a5f;


MUIA_Group_Rows

Declaration

Source position: mui.pas line 2525

const MUIA_Group_Rows = $8042b68f;


MUIA_Group_SameHeight

Declaration

Source position: mui.pas line 2527

const MUIA_Group_SameHeight = $8042037e;


MUIA_Group_SameSize

Declaration

Source position: mui.pas line 2529

const MUIA_Group_SameSize = $80420860;


MUIA_Group_SameWidth

Declaration

Source position: mui.pas line 2531

const MUIA_Group_SameWidth = $8042b3ec;


MUIA_Group_Spacing

Declaration

Source position: mui.pas line 2533

const MUIA_Group_Spacing = $8042866d;


MUIA_Group_VertSpacing

Declaration

Source position: mui.pas line 2535

const MUIA_Group_VertSpacing = $8042e1bf;


MUIA_Height

Declaration

Source position: mui.pas line 1596

const MUIA_Height = $80423237;


MUIA_HelpLine

Declaration

Source position: mui.pas line 844

const MUIA_HelpLine = $8042a825;


MUIA_HelpNode

Declaration

Source position: mui.pas line 845

const MUIA_HelpNode = $80420b85;


MUIA_HorizDisappear

Declaration

Source position: mui.pas line 1597

const MUIA_HorizDisappear = $80429615;


MUIA_HorizWeight

Declaration

Source position: mui.pas line 1598

const MUIA_HorizWeight = $80426db9;


MUIA_Image_FontMatch

Declaration

Source position: mui.pas line 1713

const MUIA_Image_FontMatch = $8042815d;


MUIA_Image_FontMatchHeight

Declaration

Source position: mui.pas line 1714

const MUIA_Image_FontMatchHeight = $80429f26;


MUIA_Image_FontMatchWidth

Declaration

Source position: mui.pas line 1715

const MUIA_Image_FontMatchWidth = $804239bf;


MUIA_Image_FreeHoriz

Declaration

Source position: mui.pas line 1716

const MUIA_Image_FreeHoriz = $8042da84;


MUIA_Image_FreeVert

Declaration

Source position: mui.pas line 1717

const MUIA_Image_FreeVert = $8042ea28;


MUIA_Image_OldImage

Declaration

Source position: mui.pas line 1718

const MUIA_Image_OldImage = $80424f3d;


MUIA_Image_Spec

Declaration

Source position: mui.pas line 1719

const MUIA_Image_Spec = $804233d5;


MUIA_Image_State

Declaration

Source position: mui.pas line 1720

const MUIA_Image_State = $8042a3ad;


MUIA_InnerBottom

Declaration

Source position: mui.pas line 1599

const MUIA_InnerBottom = $8042f2c0;


MUIA_InnerLeft

Declaration

Source position: mui.pas line 1600

const MUIA_InnerLeft = $804228f8;


MUIA_InnerRight

Declaration

Source position: mui.pas line 1601

const MUIA_InnerRight = $804297ff;


MUIA_InnerTop

Declaration

Source position: mui.pas line 1602

const MUIA_InnerTop = $80421eb6;


MUIA_InputMode

Declaration

Source position: mui.pas line 1603

const MUIA_InputMode = $8042fb04;


MUIA_LeftEdge

Declaration

Source position: mui.pas line 1604

const MUIA_LeftEdge = $8042bec6;


MUIA_Levelmeter_Label

Declaration

Source position: mui.pas line 2354

const MUIA_Levelmeter_Label = $80420dd5;


MUIA_List_Active

Declaration

Source position: mui.pas line 2091

const MUIA_List_Active = $8042391c;


MUIA_List_AdjustHeight

Declaration

Source position: mui.pas line 2093

const MUIA_List_AdjustHeight = $8042850d;


MUIA_List_AdjustWidth

Declaration

Source position: mui.pas line 2095

const MUIA_List_AdjustWidth = $8042354a;


MUIA_List_AutoVisible

Declaration

Source position: mui.pas line 2097

const MUIA_List_AutoVisible = $8042a445;


MUIA_List_CompareHook

Declaration

Source position: mui.pas line 2099

const MUIA_List_CompareHook = $80425c14;


MUIA_List_ConstructHook

Declaration

Source position: mui.pas line 2101

const MUIA_List_ConstructHook = $8042894f;


MUIA_List_DestructHook

Declaration

Source position: mui.pas line 2103

const MUIA_List_DestructHook = $804297ce;


MUIA_List_DisplayHook

Declaration

Source position: mui.pas line 2105

const MUIA_List_DisplayHook = $8042b4d5;


MUIA_List_DragSortable

Declaration

Source position: mui.pas line 2107

const MUIA_List_DragSortable = $80426099;


MUIA_List_DropMark

Declaration

Source position: mui.pas line 2109

const MUIA_List_DropMark = $8042aba6;


MUIA_List_Entries

Declaration

Source position: mui.pas line 2111

const MUIA_List_Entries = $80421654;


MUIA_List_First

Declaration

Source position: mui.pas line 2113

const MUIA_List_First = $804238d4;


MUIA_List_Format

Declaration

Source position: mui.pas line 2115

const MUIA_List_Format = $80423c0a;


MUIA_List_InsertPosition

Declaration

Source position: mui.pas line 2117

const MUIA_List_InsertPosition = $8042d0cd;


MUIA_List_MinLineHeight

Declaration

Source position: mui.pas line 2119

const MUIA_List_MinLineHeight = $8042d1c3;


MUIA_List_MultiTestHook

Declaration

Source position: mui.pas line 2121

const MUIA_List_MultiTestHook = $8042c2c6;


MUIA_List_Pool

Declaration

Source position: mui.pas line 2123

const MUIA_List_Pool = $80423431;


MUIA_List_PoolPuddleSize

Declaration

Source position: mui.pas line 2125

const MUIA_List_PoolPuddleSize = $8042a4eb;


MUIA_List_PoolThreshSize

Declaration

Source position: mui.pas line 2127

const MUIA_List_PoolThreshSize = $8042c48c;


MUIA_List_Quiet

Declaration

Source position: mui.pas line 2129

const MUIA_List_Quiet = $8042d8c7;


MUIA_List_ShowDropMarks

Declaration

Source position: mui.pas line 2131

const MUIA_List_ShowDropMarks = $8042c6f3;


MUIA_List_SourceArray

Declaration

Source position: mui.pas line 2133

const MUIA_List_SourceArray = $8042c0a0;


MUIA_List_Title

Declaration

Source position: mui.pas line 2135

const MUIA_List_Title = $80423e66;


MUIA_List_Visible

Declaration

Source position: mui.pas line 2137

const MUIA_List_Visible = $8042191f;


MUIA_Listview_ClickColumn

Declaration

Source position: mui.pas line 2717

const MUIA_Listview_ClickColumn = $8042d1b3;


MUIA_Listview_DefClickColumn

Declaration

Source position: mui.pas line 2719

const MUIA_Listview_DefClickColumn = $8042b296;


MUIA_Listview_DoubleClick

Declaration

Source position: mui.pas line 2721

const MUIA_Listview_DoubleClick = $80424635;


MUIA_Listview_DragType

Declaration

Source position: mui.pas line 2723

const MUIA_Listview_DragType = $80425cd3;


MUIA_Listview_Input

Declaration

Source position: mui.pas line 2725

const MUIA_Listview_Input = $8042682d;


MUIA_Listview_List

Declaration

Source position: mui.pas line 2727

const MUIA_Listview_List = $8042bcce;


MUIA_Listview_MultiSelect

Declaration

Source position: mui.pas line 2729

const MUIA_Listview_MultiSelect = $80427e08;


MUIA_Listview_ScrollerPos

Declaration

Source position: mui.pas line 2731

const MUIA_Listview_ScrollerPos = $8042b1b4;


MUIA_Listview_SelectChange

Declaration

Source position: mui.pas line 2733

const MUIA_Listview_SelectChange = $8042178f;


MUIA_MaxHeight

Declaration

Source position: mui.pas line 1605

const MUIA_MaxHeight = $804293e4;


MUIA_MaxWidth

Declaration

Source position: mui.pas line 1606

const MUIA_MaxWidth = $8042f112;


MUIA_Menu_Enabled

Declaration

Source position: mui.pas line 952

const MUIA_Menu_Enabled = $8042ed48;


MUIA_Menu_Title

Declaration

Source position: mui.pas line 953

const MUIA_Menu_Title = $8042a0e3;


MUIA_Menuitem_Checked

Declaration

Source position: mui.pas line 967

const MUIA_Menuitem_Checked = $8042562a;


MUIA_Menuitem_Checkit

Declaration

Source position: mui.pas line 968

const MUIA_Menuitem_Checkit = $80425ace;


MUIA_Menuitem_CommandString

Declaration

Source position: mui.pas line 969

const MUIA_Menuitem_CommandString = $8042b9cc;


MUIA_Menuitem_Enabled

Declaration

Source position: mui.pas line 970

const MUIA_Menuitem_Enabled = $8042ae0f;


MUIA_Menuitem_Exclude

Declaration

Source position: mui.pas line 971

const MUIA_Menuitem_Exclude = $80420bc6;


MUIA_Menuitem_Shortcut

Declaration

Source position: mui.pas line 972

const MUIA_Menuitem_Shortcut = $80422030;


MUIA_Menuitem_Title

Declaration

Source position: mui.pas line 973

const MUIA_Menuitem_Title = $804218be;


MUIA_Menuitem_Toggle

Declaration

Source position: mui.pas line 974

const MUIA_Menuitem_Toggle = $80424d5c;


MUIA_Menuitem_Trigger

Declaration

Source position: mui.pas line 975

const MUIA_Menuitem_Trigger = $80426f32;


MUIA_Menustrip_Enabled

Declaration

Source position: mui.pas line 940

const MUIA_Menustrip_Enabled = $8042815b;


MUIA_NoNotify

Declaration

Source position: mui.pas line 846

const MUIA_NoNotify = $804237f9;


MUIA_NoNotifyMethod

Declaration

Source position: mui.pas line 847

const MUIA_NoNotifyMethod = $80420a74;


MUIA_Numeric_CheckAllSizes

Declaration

Source position: mui.pas line 2317

const MUIA_Numeric_CheckAllSizes = $80421594;


MUIA_Numeric_Default

Declaration

Source position: mui.pas line 2319

const MUIA_Numeric_Default = $804263e8;


MUIA_Numeric_Format

Declaration

Source position: mui.pas line 2321

const MUIA_Numeric_Format = $804263e9;


MUIA_Numeric_Max

Declaration

Source position: mui.pas line 2323

const MUIA_Numeric_Max = $8042d78a;


MUIA_Numeric_Min

Declaration

Source position: mui.pas line 2325

const MUIA_Numeric_Min = $8042e404;


MUIA_Numeric_Reverse

Declaration

Source position: mui.pas line 2327

const MUIA_Numeric_Reverse = $8042f2a0;


MUIA_Numeric_RevLeftRight

Declaration

Source position: mui.pas line 2329

const MUIA_Numeric_RevLeftRight = $804294a7;


MUIA_Numeric_RevUpDown

Declaration

Source position: mui.pas line 2331

const MUIA_Numeric_RevUpDown = $804252dd;


MUIA_Numeric_Value

Declaration

Source position: mui.pas line 2333

const MUIA_Numeric_Value = $8042ae3a;


MUIA_ObjectID

Declaration

Source position: mui.pas line 848

const MUIA_ObjectID = $8042d76e;


MUIA_Palette_Entries

Declaration

Source position: mui.pas line 2810

const MUIA_Palette_Entries = $8042a3d8;


MUIA_Palette_Groupable

Declaration

Source position: mui.pas line 2812

const MUIA_Palette_Groupable = $80423e67;


MUIA_Palette_Names

Declaration

Source position: mui.pas line 2814

const MUIA_Palette_Names = $8042c3a2;


MUIA_Parent

Declaration

Source position: mui.pas line 849

const MUIA_Parent = $8042e35f;


MUIA_Penadjust_PSIMode

Declaration

Source position: mui.pas line 2576

const MUIA_Penadjust_PSIMode = $80421cbb;


MUIA_Pendisplay_Pen

Declaration

Source position: mui.pas line 2455

const MUIA_Pendisplay_Pen = $8042a748;


MUIA_Pendisplay_Reference

Declaration

Source position: mui.pas line 2457

const MUIA_Pendisplay_Reference = $8042dc24;


MUIA_Pendisplay_RGBcolor

Declaration

Source position: mui.pas line 2459

const MUIA_Pendisplay_RGBcolor = $8042a1a9;


MUIA_Pendisplay_Spec

Declaration

Source position: mui.pas line 2461

const MUIA_Pendisplay_Spec = $8042a204;


MUIA_Popasl_Active

Declaration

Source position: mui.pas line 2914

const MUIA_Popasl_Active = $80421b37;


MUIA_Popasl_StartHook

Declaration

Source position: mui.pas line 2916

const MUIA_Popasl_StartHook = $8042b703;


MUIA_Popasl_StopHook

Declaration

Source position: mui.pas line 2918

const MUIA_Popasl_StopHook = $8042d8d2;


MUIA_Popasl_Type

Declaration

Source position: mui.pas line 2920

const MUIA_Popasl_Type = $8042df3d;


MUIA_Poplist_Array

Declaration

Source position: mui.pas line 2893

const MUIA_Poplist_Array = $8042084c;


MUIA_Popobject_Follow

Declaration

Source position: mui.pas line 2868

const MUIA_Popobject_Follow = $80424cb5;


MUIA_Popobject_Light

Declaration

Source position: mui.pas line 2870

const MUIA_Popobject_Light = $8042a5a3;


MUIA_Popobject_Object

Declaration

Source position: mui.pas line 2872

const MUIA_Popobject_Object = $804293e3;


MUIA_Popobject_ObjStrHook

Declaration

Source position: mui.pas line 2874

const MUIA_Popobject_ObjStrHook = $8042db44;


MUIA_Popobject_StrObjHook

Declaration

Source position: mui.pas line 2876

const MUIA_Popobject_StrObjHook = $8042fbe1;


MUIA_Popobject_Volatile

Declaration

Source position: mui.pas line 2878

const MUIA_Popobject_Volatile = $804252ec;


MUIA_Popobject_WindowHook

Declaration

Source position: mui.pas line 2880

const MUIA_Popobject_WindowHook = $8042f194;


MUIA_Popstring_Button

Declaration

Source position: mui.pas line 2847

const MUIA_Popstring_Button = $8042d0b9;


MUIA_Popstring_CloseHook

Declaration

Source position: mui.pas line 2849

const MUIA_Popstring_CloseHook = $804256bf;


MUIA_Popstring_OpenHook

Declaration

Source position: mui.pas line 2851

const MUIA_Popstring_OpenHook = $80429d00;


MUIA_Popstring_String

Declaration

Source position: mui.pas line 2853

const MUIA_Popstring_String = $804239ea;


MUIA_Popstring_Toggle

Declaration

Source position: mui.pas line 2855

const MUIA_Popstring_Toggle = $80422b7a;


MUIA_Pressed

Declaration

Source position: mui.pas line 1607

const MUIA_Pressed = $80423535;


MUIA_Prop_Entries

Declaration

Source position: mui.pas line 1887

const MUIA_Prop_Entries = $8042fbdb;


MUIA_Prop_First

Declaration

Source position: mui.pas line 1888

const MUIA_Prop_First = $8042d4b2;


MUIA_Prop_Horiz

Declaration

Source position: mui.pas line 1889

const MUIA_Prop_Horiz = $8042f4f3;


MUIA_Prop_Slider

Declaration

Source position: mui.pas line 1890

const MUIA_Prop_Slider = $80429c3a;


MUIA_Prop_UseWinBorder

Declaration

Source position: mui.pas line 1891

const MUIA_Prop_UseWinBorder = $8042deee;


MUIA_Prop_Visible

Declaration

Source position: mui.pas line 1892

const MUIA_Prop_Visible = $8042fea6;


MUIA_Radio_Active

Declaration

Source position: mui.pas line 2756

const MUIA_Radio_Active = $80429b41;


MUIA_Radio_Entries

Declaration

Source position: mui.pas line 2758

const MUIA_Radio_Entries = $8042b6a1;


MUIA_Rectangle_BarTitle

Declaration

Source position: mui.pas line 1686

const MUIA_Rectangle_BarTitle = $80426689;


MUIA_Rectangle_HBar

Declaration

Source position: mui.pas line 1687

const MUIA_Rectangle_HBar = $8042c943;


MUIA_Rectangle_VBar

Declaration

Source position: mui.pas line 1688

const MUIA_Rectangle_VBar = $80422204;


MUIA_Register_Frame

Declaration

Source position: mui.pas line 2560

const MUIA_Register_Frame = $8042349b;


MUIA_Register_Titles

Declaration

Source position: mui.pas line 2562

const MUIA_Register_Titles = $804297ec;


MUIA_Revision

Declaration

Source position: mui.pas line 850

const MUIA_Revision = $80427eaa;


MUIA_RightEdge

Declaration

Source position: mui.pas line 1608

const MUIA_RightEdge = $8042ba82;


MUIA_Scale_Horiz

Declaration

Source position: mui.pas line 1927

const MUIA_Scale_Horiz = $8042919a;


MUIA_Scrollbar_Type

Declaration

Source position: mui.pas line 2700

const MUIA_Scrollbar_Type = $8042fb6b;


MUIA_Scrollgroup_Contents

Declaration

Source position: mui.pas line 2677

const MUIA_Scrollgroup_Contents = $80421261;


MUIA_Scrollgroup_FreeHoriz

Declaration

Source position: mui.pas line 2679

const MUIA_Scrollgroup_FreeHoriz = $804292f3;


MUIA_Scrollgroup_FreeVert

Declaration

Source position: mui.pas line 2681

const MUIA_Scrollgroup_FreeVert = $804224f2;


MUIA_Scrollgroup_HorizBar

Declaration

Source position: mui.pas line 2683

const MUIA_Scrollgroup_HorizBar = $8042b63d;


MUIA_Scrollgroup_UseWinBorder

Declaration

Source position: mui.pas line 2685

const MUIA_Scrollgroup_UseWinBorder = $804284c1;


MUIA_Scrollgroup_VertBar

Declaration

Source position: mui.pas line 2687

const MUIA_Scrollgroup_VertBar = $8042cdc0;


MUIA_Selected

Declaration

Source position: mui.pas line 1609

const MUIA_Selected = $8042654b;


MUIA_ShortHelp

Declaration

Source position: mui.pas line 1610

const MUIA_ShortHelp = $80428fe3;


MUIA_ShowMe

Declaration

Source position: mui.pas line 1611

const MUIA_ShowMe = $80429ba8;


MUIA_ShowSelState

Declaration

Source position: mui.pas line 1612

const MUIA_ShowSelState = $8042caac;


MUIA_Slider_Horiz

Declaration

Source position: mui.pas line 2375

const MUIA_Slider_Horiz = $8042fad1;


MUIA_Slider_Quiet

Declaration

Source position: mui.pas line 2380

const MUIA_Slider_Quiet = $80420b26;


MUIA_String_Accept

Declaration

Source position: mui.pas line 1816

const MUIA_String_Accept = $8042e3e1;


MUIA_String_Acknowledge

Declaration

Source position: mui.pas line 1817

const MUIA_String_Acknowledge = $8042026c;


MUIA_String_AdvanceOnCR

Declaration

Source position: mui.pas line 1818

const MUIA_String_AdvanceOnCR = $804226de;


MUIA_String_AttachedList

Declaration

Source position: mui.pas line 1819

const MUIA_String_AttachedList = $80420fd2;


MUIA_String_BufferPos

Declaration

Source position: mui.pas line 1820

const MUIA_String_BufferPos = $80428b6c;


MUIA_String_Contents

Declaration

Source position: mui.pas line 1821

const MUIA_String_Contents = $80428ffd;


MUIA_String_DisplayPos

Declaration

Source position: mui.pas line 1822

const MUIA_String_DisplayPos = $8042ccbf;


MUIA_String_EditHook

Declaration

Source position: mui.pas line 1823

const MUIA_String_EditHook = $80424c33;


MUIA_String_Format

Declaration

Source position: mui.pas line 1824

const MUIA_String_Format = $80427484;


MUIA_String_Integer

Declaration

Source position: mui.pas line 1825

const MUIA_String_Integer = $80426e8a;


MUIA_String_LonelyEditHook

Declaration

Source position: mui.pas line 1826

const MUIA_String_LonelyEditHook = $80421569;


MUIA_String_MaxLen

Declaration

Source position: mui.pas line 1827

const MUIA_String_MaxLen = $80424984;


MUIA_String_Reject

Declaration

Source position: mui.pas line 1828

const MUIA_String_Reject = $8042179c;


MUIA_String_Secret

Declaration

Source position: mui.pas line 1829

const MUIA_String_Secret = $80428769;


MUIA_Text_Contents

Declaration

Source position: mui.pas line 1776

const MUIA_Text_Contents = $8042f8dc;


MUIA_Text_ControlChar

Declaration

Source position: mui.pas line 1777

const MUIA_Text_ControlChar = $8042e6d0;


MUIA_Text_Copy

Declaration

Source position: mui.pas line 1778

const MUIA_Text_Copy = $80427727;


MUIA_Text_HiChar

Declaration

Source position: mui.pas line 1779

const MUIA_Text_HiChar = $804218ff;


MUIA_Text_PreParse

Declaration

Source position: mui.pas line 1780

const MUIA_Text_PreParse = $8042566d;


MUIA_Text_SetMax

Declaration

Source position: mui.pas line 1781

const MUIA_Text_SetMax = $80424d0a;


MUIA_Text_SetMin

Declaration

Source position: mui.pas line 1782

const MUIA_Text_SetMin = $80424e10;


MUIA_Text_SetVMax

Declaration

Source position: mui.pas line 1783

const MUIA_Text_SetVMax = $80420d8b;


MUIA_Text_Shorten

Declaration

Source position: mui.pas line 1784

const MUIA_Text_Shorten = $80428bbd;


MUIA_Text_Shortened

Declaration

Source position: mui.pas line 1785

const MUIA_Text_Shortened = $80425a86;


MUIA_Timer

Declaration

Source position: mui.pas line 1613

const MUIA_Timer = $80426435;


MUIA_TopEdge

Declaration

Source position: mui.pas line 1614

const MUIA_TopEdge = $8042509b;


MUIA_UserData

Declaration

Source position: mui.pas line 851

const MUIA_UserData = $80420313;


MUIA_Version

Declaration

Source position: mui.pas line 852

const MUIA_Version = $80422301;


MUIA_VertDisappear

Declaration

Source position: mui.pas line 1615

const MUIA_VertDisappear = $8042d12f;


MUIA_VertWeight

Declaration

Source position: mui.pas line 1616

const MUIA_VertWeight = $804298d0;


MUIA_Virtgroup_Height

Declaration

Source position: mui.pas line 2655

const MUIA_Virtgroup_Height = $80423038;


MUIA_Virtgroup_Input

Declaration

Source position: mui.pas line 2657

const MUIA_Virtgroup_Input = $80427f7e;


MUIA_Virtgroup_Left

Declaration

Source position: mui.pas line 2659

const MUIA_Virtgroup_Left = $80429371;


MUIA_Virtgroup_Top

Declaration

Source position: mui.pas line 2661

const MUIA_Virtgroup_Top = $80425200;


MUIA_Virtgroup_Width

Declaration

Source position: mui.pas line 2663

const MUIA_Virtgroup_Width = $80427c49;


MUIA_Weight

Declaration

Source position: mui.pas line 1617

const MUIA_Weight = $80421d1f;


MUIA_Width

Declaration

Source position: mui.pas line 1618

const MUIA_Width = $8042b59c;


MUIA_Window

Declaration

Source position: mui.pas line 1619

const MUIA_Window = $80421591;


MUIA_Window_Activate

Declaration

Source position: mui.pas line 1266

const MUIA_Window_Activate = $80428d2f;


MUIA_Window_ActiveObject

Declaration

Source position: mui.pas line 1267

const MUIA_Window_ActiveObject = $80427925;


MUIA_Window_AltHeight

Declaration

Source position: mui.pas line 1268

const MUIA_Window_AltHeight = $8042cce3;


MUIA_Window_AltLeftEdge

Declaration

Source position: mui.pas line 1269

const MUIA_Window_AltLeftEdge = $80422d65;


MUIA_Window_AltTopEdge

Declaration

Source position: mui.pas line 1270

const MUIA_Window_AltTopEdge = $8042e99b;


MUIA_Window_AltWidth

Declaration

Source position: mui.pas line 1271

const MUIA_Window_AltWidth = $804260f4;


MUIA_Window_AppWindow

Declaration

Source position: mui.pas line 1272

const MUIA_Window_AppWindow = $804280cf;


MUIA_Window_Backdrop

Declaration

Source position: mui.pas line 1273

const MUIA_Window_Backdrop = $8042c0bb;


MUIA_Window_Borderless

Declaration

Source position: mui.pas line 1274

const MUIA_Window_Borderless = $80429b79;


MUIA_Window_CloseGadget

Declaration

Source position: mui.pas line 1275

const MUIA_Window_CloseGadget = $8042a110;


MUIA_Window_CloseRequest

Declaration

Source position: mui.pas line 1276

const MUIA_Window_CloseRequest = $8042e86e;


MUIA_Window_DefaultObject

Declaration

Source position: mui.pas line 1277

const MUIA_Window_DefaultObject = $804294d7;


MUIA_Window_DepthGadget

Declaration

Source position: mui.pas line 1278

const MUIA_Window_DepthGadget = $80421923;


MUIA_Window_DragBar

Declaration

Source position: mui.pas line 1279

const MUIA_Window_DragBar = $8042045d;


MUIA_Window_FancyDrawing

Declaration

Source position: mui.pas line 1280

const MUIA_Window_FancyDrawing = $8042bd0e;


MUIA_Window_Height

Declaration

Source position: mui.pas line 1281

const MUIA_Window_Height = $80425846;


MUIA_Window_ID

Declaration

Source position: mui.pas line 1282

const MUIA_Window_ID = $804201bd;


MUIA_Window_InputEvent

Declaration

Source position: mui.pas line 1283

const MUIA_Window_InputEvent = $804247d8;


MUIA_Window_IsSubWindow

Declaration

Source position: mui.pas line 1284

const MUIA_Window_IsSubWindow = $8042b5aa;


MUIA_Window_LeftEdge

Declaration

Source position: mui.pas line 1285

const MUIA_Window_LeftEdge = $80426c65;


MUIA_Window_MenuAction

Declaration

Source position: mui.pas line 1286

const MUIA_Window_MenuAction = $80427521;


MUIA_Window_Menustrip

Declaration

Source position: mui.pas line 1287

const MUIA_Window_Menustrip = $8042855e;


MUIA_Window_MouseObject

Declaration

Source position: mui.pas line 1288

const MUIA_Window_MouseObject = $8042bf9b;


MUIA_Window_NeedsMouseObject

Declaration

Source position: mui.pas line 1289

const MUIA_Window_NeedsMouseObject = $8042372a;


MUIA_Window_NoMenus

Declaration

Source position: mui.pas line 1290

const MUIA_Window_NoMenus = $80429df5;


MUIA_Window_Open

Declaration

Source position: mui.pas line 1291

const MUIA_Window_Open = $80428aa0;


MUIA_Window_PublicScreen

Declaration

Source position: mui.pas line 1292

const MUIA_Window_PublicScreen = $804278e4;


MUIA_Window_RefWindow

Declaration

Source position: mui.pas line 1293

const MUIA_Window_RefWindow = $804201f4;


MUIA_Window_RootObject

Declaration

Source position: mui.pas line 1294

const MUIA_Window_RootObject = $8042cba5;


MUIA_Window_Screen

Declaration

Source position: mui.pas line 1295

const MUIA_Window_Screen = $8042df4f;


MUIA_Window_ScreenTitle

Declaration

Source position: mui.pas line 1296

const MUIA_Window_ScreenTitle = $804234b0;


MUIA_Window_SizeGadget

Declaration

Source position: mui.pas line 1297

const MUIA_Window_SizeGadget = $8042e33d;


MUIA_Window_SizeRight

Declaration

Source position: mui.pas line 1298

const MUIA_Window_SizeRight = $80424780;


MUIA_Window_Sleep

Declaration

Source position: mui.pas line 1299

const MUIA_Window_Sleep = $8042e7db;


MUIA_Window_Title

Declaration

Source position: mui.pas line 1300

const MUIA_Window_Title = $8042ad3d;


MUIA_Window_TopEdge

Declaration

Source position: mui.pas line 1301

const MUIA_Window_TopEdge = $80427c66;


MUIA_Window_UseBottomBorderScroller

Declaration

Source position: mui.pas line 1302

const MUIA_Window_UseBottomBorderScroller = $80424e79;


MUIA_Window_UseLeftBorderScroller

Declaration

Source position: mui.pas line 1303

const MUIA_Window_UseLeftBorderScroller = $8042433e;


MUIA_Window_UseRightBorderScroller

Declaration

Source position: mui.pas line 1304

const MUIA_Window_UseRightBorderScroller = $8042c05e;


MUIA_Window_Width

Declaration

Source position: mui.pas line 1305

const MUIA_Window_Width = $8042dcae;


MUIA_Window_Window

Declaration

Source position: mui.pas line 1306

const MUIA_Window_Window = $80426a42;


MUIA_WindowObject

Declaration

Source position: mui.pas line 1620

const MUIA_WindowObject = $8042669e;


MUIC_Aboutmui

Declaration

Source position: mui.pas line 1356

const MUIC_Aboutmui: PChar = 'Aboutmui.mui';


MUIC_Application

Declaration

Source position: mui.pas line 986

const MUIC_Application: PChar = 'Application.mui';

Description

Inheritance
rootclass --> Notify --> Application

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Application_Active | ISG | BOOL (0/1) | This attribute reflects the state that the user adjusted with commodities Exchange.
MUIA_Application_Author | I_G | PChar | Name of the applications author.
MUIA_Application_Base | I_G | PChar | The basename for an application.
MUIA_Application_Broker | __G | PBroker | Obtain a pointer to the applications Broker structure.
MUIA_Application_BrokerHook | ISG | PHook | The function will be called whenever a commodities message arrives.
MUIA_Application_BrokerPort | __G | PMsgPort | Get a pointer to the applications commodities message port.
MUIA_Application_BrokerPri | I_G | LongInt | Adjust the priority of an applications broker.
MUIA_Application_Commands | ISG | PMUI_Command | Include its own set of ARexx commands.
MUIA_Application_Copyright | I_G | PChar | A copyright string, containing the year and the company.
MUIA_Application_Description | I_G | PChar | Short description
MUIA_Application_DiskObject | ISG | PChar | Defines AppIcon when your application gets iconified.
MUIA_Application_DoubleStart | __G | BOOL (0/1) | Set if application get started twice. (Single Task App)
MUIA_Application_DropObject | IS_ | PObject_ | Object dropped on your AppIcon
MUIA_Application_ForceQuit | __G | BOOL (0/1) | Quit program without requesters.
MUIA_Application_HelpFile | ISG | PChar | Define AmigaGuide file as Help file.
MUIA_Application_Iconified | _SG | BOOL (0/1) | Iconify the application.
MUIA_Application_MenuAction | __G | LongWord | UserData of selected menu item
MUIA_Application_MenuHelp | __G | LongWord | UserData of menu item selected and Help key pressed.
MUIA_Application_Menustrip | I__ | PObject_ | Specify a menu strip object for the application.
MUIA_Application_RexxHook | ISG | PHook | Hook for arriving Rexx messages.
MUIA_Application_RexxMsg | __G | PRxMsg | Rexx message for arriving Rexx messages.
MUIA_Application_RexxString | _S_ | PChar | ARexx allows returning a string as result of a function call.
MUIA_Application_SingleTask | I__ | BOOL (0/1) | Define application as single task program.
MUIA_Application_Sleep | _S_ | BOOL (0/1) | This attribute can be used to put a whole application to sleep.
MUIA_Application_Title | I_G | PChar | Defines the title of an application.
MUIA_Application_UseCommodities | I__ | BOOL (0/1) | When set to False, the application will run without a commodities interface.
MUIA_Application_UsedClasses | ISG | PChar | Tell the MUI system what external classes your application might use.
MUIA_Application_UseRexx | I__ | BOOL (0/1) | When set to FALSE, the application will run without an ARexx interface.
MUIA_Application_Version | I_G | PChar | Define a version string for an application.
MUIA_Application_Window | I__ | PChar | A pointer to a MUI object of Window class.
MUIA_Application_WindowList | __G | PList | List of children (i.e. windows) of an application.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Application_AboutMUI | Show the MUI about window.
MUIM_Application_AddInputHandler | Set Input Handler for custom classes.
MUIM_Application_CheckRefresh | Check all currently open windows if they need refreshing and refreshes them if necessary.
MUIM_Application_InputBuffered | Buffer user input.
MUIM_Application_Load | Load programs configuration.
MUIM_Application_NewInput | This is an enhanced replacement for MUIM_Application_Input.
MUIM_Application_OpenConfigWindow | Open applications own MUI configuration.
MUIM_Application_PushMethod | Push method from second task to main task.
MUIM_Application_RemInputHandler | Remove Input Handler for custom classes.
MUIM_Application_ReturnID | Tell MUI to return the given id with the next call to MUIM_Application_NewInput.
MUIM_Application_Save | Save programs configuration.
MUIM_Application_SetConfigItem | Private Method for PSI.
MUIM_Application_ShowHelp | Show an AmigaGuide help file.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Applist

Declaration

Source position: mui.pas line 2974

const MUIC_Applist: PChar = 'Applist.mui';


MUIC_Area

Area class is a super class for every other MUI class except windows and applications.

Declaration

Source position: mui.pas line 1370

const MUIC_Area: PChar = 'Area.mui';

Description

Area class is a super class for every other MUI class except windows and applications. It holds information about an objects current position, size and weight and manages frames, fonts and backgrounds.

Additionally, area class handles the user input. By setting an objects MUIA_InputMode, you can make it behave like a button or like a toggle gadget. That's why MUI doesn't offer an extra button class. A button is simply a text object with a raised frame and a relverify input mode. Since especially group class is a subclass of area, you can create rather complex buttons consisting of many other display elements.

Inheritance
rootclass --> Notify --> Area

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Balance

Declaration

Source position: mui.pas line 1696

const MUIC_Balance: PChar = 'Balance.mui';

Description

The balance class is very simple and has no attributes. Simply insert objects of this class somewhere in your group (only horizontal or vertical groups, nothing 2-dimensional) allows your users to dynamically change the weight of your children.

Inheritance
rootclass --> Notify --> Area --> Balance

Fields
_______________ Field _______________ ___ Access ___ _____ Type _____ Short description
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Bitmap

Include a self-made image data in MUI applications.

Declaration

Source position: mui.pas line 1736

const MUIC_Bitmap: PChar = 'Bitmap.mui';

Description

The Bitmap class allows including self-made image data in MUI applications. Usually, image class was intended to be used for this purpose but unfortunately, its design was not very useful.

In its most simple usage, Bitmap class just display a given BitMap. However, you can also tell it to do automatic color remapping to match the current display context and you can define a transparent color to make the BitMap appear on any background.

Inheritance
rootclass --> Notify --> Area --> Bitmap

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Bitmap_Bitmap | ISG | PBitmap | This attribute specifies a pointer to a struct BitMap.
MUIA_Bitmap_Height | ISG | LongInt | Define the pixel height of the BitMap.
MUIA_Bitmap_MappingTable | ISG | PByte | Address of an array of Bytes, one for each color of the source BitMap.
MUIA_Bitmap_Precision | ISG | LongInt | Specify the precision value for remapping images.
MUIA_Bitmap_RemappedBitmap | __G | PBitmap | Between MUIM_Setup and MUIM_Cleanup, this attribute will hold a pointer to the remapped bitmap.
MUIA_Bitmap_SourceColors | ISG | PLongWord | This attribute defines the color palette of the source BitMap.
MUIA_Bitmap_Transparent | ISG | LongInt | Use defined color as transparent color.
MUIA_Bitmap_UseFriend | I__ | BOOL (0/1) | Try to allocate the remapped bitmap in a way that allows fastest displaying.
MUIA_Bitmap_Width | ISG | LongInt | Define the pixel width of the BitMap.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Bodychunk

Declaration

Source position: mui.pas line 1757

const MUIC_Bodychunk: PChar = 'Bodychunk.mui';

Description

Big and colorful images (e.g. About-Logos) usually take lots of space when stored in a traditional BitMap structure. To save memory, you can decide to have the picture compressed in your code and use the Bodychunk class instead of the Bitmap class for displaying. MUI will then automatically decompress your image when its about to appear in a window.

Since Bodychunk class is a subclass of Bitmap class, you can of course use all the Bitmaps remapping and transparency features.

Inheritance
rootclass --> Notify --> Area --> Bitmap --> Bodychunk

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Bodychunk_Body | ISG | PByte | Specify a pointer to the BODY data of your picture.
MUIA_Bodychunk_Compression | ISG | Byte | Specify compression of the Body.
MUIA_Bodychunk_Depth | ISG | LongInt | Specify the depth of your picture.
MUIA_Bodychunk_Masking | ISG | Byte | Indicate if your BODY data contains a masking plane.
Fields inherited from Bitmap
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Bitmap_Bitmap | ISG | PBitmap | This attribute specifies a pointer to a struct BitMap.
MUIA_Bitmap_Height | ISG | LongInt | Define the pixel height of the BitMap.
MUIA_Bitmap_MappingTable | ISG | PByte | Address of an array of Bytes, one for each color of the source BitMap.
MUIA_Bitmap_Precision | ISG | LongInt | Specify the precision value for remapping images.
MUIA_Bitmap_RemappedBitmap | __G | PBitmap | Between MUIM_Setup and MUIM_Cleanup, this attribute will hold a pointer to the remapped bitmap.
MUIA_Bitmap_SourceColors | ISG | PLongWord | This attribute defines the color palette of the source BitMap.
MUIA_Bitmap_Transparent | ISG | LongInt | Use defined color as transparent color.
MUIA_Bitmap_UseFriend | I__ | BOOL (0/1) | Try to allocate the remapped bitmap in a way that allows fastest displaying.
MUIA_Bitmap_Width | ISG | LongInt | Define the pixel width of the BitMap.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Boopsi

MUI's boopsi class provides an interface to standard, system style boopsi gadgets.

Declaration

Source position: mui.pas line 1842

const MUIC_Boopsi: PChar = 'Boopsi.mui';

Description

Since boopsis gadgetclass misses some important features needed for an automatic layout system like MUI, there are several problems with such an interface. MUI tries to solve these problems with some additional attributes.

Coming with release 3.x of the amiga operating system are some very nice boopsi gadgets such as "colorwheel.gadget" or "gradientslider.gadget". With MUI's boopsi class, you can use these gadgets just as if they were MUI objects.

You can talk to a MUIized boopsi object as if it was the boopsi object itself. MUI will pass through all attributes and try to be completely transparent. Additionally, if a boopsi object generates notification events via IDCMP_UPDATE, MUI turns them into MUI notification events. Thus, you can e.g. react on the change of WHEEL_Saturation in a MUI colorwheel boopsi gadget as on any other MUI attribute.

An example program "BoopsiDoor.c" is provided to show how this magic works.

Note: OS 3.0/3.1 colorwheel.gadget can accidently render itself one pixel too big, overwriting other parts of the window. As a workaround, MUI will subtract one from the width/height before passing it on to a colorwheel boopsi object.

Inheritance
rootclass --> Notify --> Area --> Gadget --> Boopsi

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Boopsi_Class | ISG | PIClass | Pointer to the (private) class you want to create a boopsi object from.
MUIA_Boopsi_ClassID | ISG | PChar | Name of the Boopsi class you want to create an object of.
MUIA_Boopsi_MaxHeight | ISG | LongWord | Maximal height for the boopsi gadget.
MUIA_Boopsi_MaxWidth | ISG | LongWord | Maximal width for the boopsi gadget.
MUIA_Boopsi_MinHeight | ISG | LongWord | Minimum Height for the boopsi gadget.
MUIA_Boopsi_MinWidth | ISG | LongWord | Minimum Width for the boopsi gadget.
MUIA_Boopsi_Object | __G | PObject_ | MUI returns when generating a BoopsiObject is a standard MUI object.
MUIA_Boopsi_Remember | I__ | LongWord | Attributes must be remembered during dispose/regeneration.
MUIA_Boopsi_Smart | I__ | BOOL (0/1) | Smart BOOPSI gadgets that allow resizing.
MUIA_Boopsi_TagDrawInfo | ISG | LongWord | Tell MUI where to fill in a needed DrawInfo structure.
MUIA_Boopsi_TagScreen | ISG | LongWord | Tell MUI where to fill in a needed Screen structure.
MUIA_Boopsi_TagWindow | ISG | LongWord | Tell MUI where to fill in a needed Window structure.
Fields inherited from Gadget
MUIA_Gadget_Gadget __G PGadget Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Cclist

Declaration

Source position: mui.pas line 2982

const MUIC_Cclist: PChar = 'Cclist.mui';


MUIC_Coloradjust

Declaration

Source position: mui.pas line 2782

const MUIC_Coloradjust: PChar = 'Coloradjust.mui';


MUIC_Colorfield

Declaration

Source position: mui.pas line 1935

const MUIC_Colorfield: PChar = 'Colorfield.mui';


MUIC_Configdata

Declaration

Source position: mui.pas line 3068

const MUIC_Configdata: PChar = 'Configdata.mui';


MUIC_Cycle

Declaration

Source position: mui.pas line 2765

const MUIC_Cycle: PChar = 'Cycle.mui';


MUIC_Dataspace

Declaration

Source position: mui.pas line 2991

const MUIC_Dataspace: PChar = 'Dataspace.mui';


MUIC_Dirlist

Declaration

Source position: mui.pas line 2192

const MUIC_Dirlist: PChar = 'Dirlist.mui';


MUIC_Dtpic

Declaration

Source position: mui.pas line 1668

const MUIC_Dtpic: PChar = 'Dtpic.mui';


MUIC_Family

Family class is the base class for objects that are able to handle a list of children.

Declaration

Source position: mui.pas line 860

const MUIC_Family: PChar = 'Family.mui';

Description

Family class is the base class for objects that are able to handle a list of children. This is e.g. the case for MUIs Menustrip, Menu and Menuitem objects.

Family class defines methods and attributes to add and remove children, sort children, and transfer children to other Family objects.

Group class and application class should also be a subclass of Family class, but due to BOOPSI system limitations, this is currently impossible. If the future will allow more logical class trees, things might change, but everything will be done in a compatible manner.

Inheritance
rootclass --> Notify --> Family

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Floattext

Declaration

Source position: mui.pas line 2157

const MUIC_Floattext: PChar = 'Floattext.mui';


MUIC_Frameadjust

Declaration

Source position: mui.pas line 2622

const MUIC_Frameadjust: PChar = 'Frameadjust.mui';


MUIC_Framedisplay

Declaration

Source position: mui.pas line 2388

const MUIC_Framedisplay: PChar = 'Framedisplay.mui';


MUIC_Gadget

This is the base class for intuition gadgets in MUI windows.

Declaration

Source position: mui.pas line 1798

const MUIC_Gadget: PChar = 'Gadget.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Gadget

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Gadget_Gadget | __G | PGadget | Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Gauge

A gauge object is a nice looking display element useful for some kind of progress display.

Declaration

Source position: mui.pas line 1906

const MUIC_Gauge: PChar = 'Gauge.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Gauge

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Gauge_Current | ISG | LongInt | Set the current level of the gauge.
MUIA_Gauge_Divide | ISG | LongWord | Every value set with MUIA_Gauge_Current will be divided by this before further processing.
MUIA_Gauge_Horiz | I__ | BOOL (0/1) | Determine if you want a horizontal or vertical gauge.
MUIA_Gauge_InfoText | ISG | STRPTR | Text given here is displayed within a gauge object.
MUIA_Gauge_Max | ISG | LongInt | Set the maximum value for the gauge.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Group

Declaration

Source position: mui.pas line 2476

const MUIC_Group: PChar = 'Group.mui';


MUIC_Image

Image class is used to display one of MUI's standard images or some selfmade image data.

Declaration

Source position: mui.pas line 1708

const MUIC_Image: PChar = 'Image.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Image

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Image_FontMatch | I__ | BOOL (0/1) | Width and height of the given image will be scaled to match the current font.
MUIA_Image_FontMatchHeight | I__ | BOOL (0/1) | Height of the given image will be scaled to match the current font.
MUIA_Image_FontMatchWidth | I__ | BOOL (0/1) | Width of the given image will be scaled to match the current font.
MUIA_Image_FreeHoriz | I__ | BOOL (0/1) | Tell the image if its allowed to get scaled horizontally.
MUIA_Image_FreeVert | I__ | BOOL (0/1) | Tell the image if its allowed to get scaled vertically.
MUIA_Image_OldImage | I__ | PImage | Allows you to use any conventional image structure within a MUI window.
MUIA_Image_Spec | I__ | PChar | Specify the type of your image.
MUIA_Image_State | IS_ | LongInt | Select state of multi state images.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Imageadjust

Declaration

Source position: mui.pas line 2632

const MUIC_Imageadjust: PChar = 'Imageadjust.mui';


MUIC_Imagedisplay

Declaration

Source position: mui.pas line 2404

const MUIC_Imagedisplay: PChar = 'Imagedisplay.mui';


MUIC_Knob

Declaration

Source position: mui.pas line 2340

const MUIC_Knob: PChar = 'Knob.mui';


MUIC_Levelmeter

Declaration

Source position: mui.pas line 2348

const MUIC_Levelmeter: PChar = 'Levelmeter.mui';


MUIC_List

Declaration

Source position: mui.pas line 1951

const MUIC_List: PChar = 'List.mui';


MUIC_Listview

Declaration

Source position: mui.pas line 2711

const MUIC_Listview: PChar = 'Listview.mui';


MUIC_Mccprefs

Declaration

Source position: mui.pas line 2547

const MUIC_Mccprefs: PChar = 'Mccprefs.mui';


MUIC_Menu

Objects of menu class describe exactly one pulldown menu.

Declaration

Source position: mui.pas line 948

const MUIC_Menu: PChar = 'Menu.mui';

Description

Objects of menu class describe exactly one pulldown menu. They don't feature many options themselves, but as a subclass of Family class, they act as father for their several menu item objects.

Inheritance
rootclass --> Notify --> Family --> Menu

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Menu_Enabled | ISG | BOOL (0/1) | Enable or disable the complete menu.
MUIA_Menu_Title | ISG | PChar | Describe the title of the menu.
Fields inherited from Family
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Family
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Menubar

Declaration

Source position: mui.pas line 1728

const MUIC_Menubar: PChar = 'Menubar.mui';


MUIC_Menuitem

Declaration

Source position: mui.pas line 961

const MUIC_Menuitem: PChar = 'Menuitem.mui';

Description

Menuitem class describes a single menu item. You can use all of the gadtools menus features expect Image menus here.

Since Menuitem class is a subclass of Family class, you can add other menu items as children of a menu item to indicate sub menus. MUI does not limit the level of sub menus, but the operating system currently allows a maximum nesting level of one. Because of this, children of menu items should not contain other menu items for now, the results are unpredictable.

Note: For handling menu items, MUIA_UserData and the methods MUIM_SetUData, MUIM_GetUData and MUIM_FindUData can become quite useful. See the Menu demo program and the accompanying documentation for details.

Inheritance
rootclass --> Notify --> Family --> MenuItem

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_MenuItem_Checked | ISG | BOOL (0/1) | Set/Get the checked state of a checkit menu item.
MUIA_Menuitem_Checkit | ISG | BOOL (0/1) | Set to True and this item will become a checkmarkable item.
MUIA_Menuitem_Enabled | ISG | BOOL (0/1) | Enabled/Disable the menu item.
MUIA_Menuitem_Exclude | ISG | LongInt | bitmask of menu item numbers that are to be deselected when this one is selected.
MUIA_Menuitem_Shortcut | ISG | PChar | Define the shortcut for a menu item.
MUIA_Menuitem_Title | ISG | PChar | Define the items title.
MUIA_Menuitem_Toggle | ISG | PChar | Define the state of the toggle flag for this item.
MUIA_Menuitem_Trigger | __G | PMenuItem | Trigger when menu item is selected.
Fields inherited from Family
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Family
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Menustrip

Menustrip class is the base class for MUI's object oriented menus.

Declaration

Source position: mui.pas line 920

const MUIC_Menustrip: PChar = 'Menustrip.mui';

Description

Menustrip class is the base class for MUI's object oriented menus. Its children are objects of Menu class, each of them describes exactly one menu.

A Menustrip object doesn't feature many options itself, but as a subclass of Family class, it simply acts as father for multiple Menu objects.

The Menustrip object is usually specified as a child of either Application class or window class with the attributes MUIA_Application_Menustrip or MUIA_Window_Menustrip.

Inheritance
rootclass --> Notify --> Family --> MenuStrip

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Menustrip_Enabled | ISG | BOOL (0/1) | Enable or disable the complete menu strip.
Fields inherited from Family
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Family
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Notify

Notify class is superclass of all other MUI classes.

Declaration

Source position: mui.pas line 694

const MUIC_Notify: PChar = 'Notify.mui';

Description

Notify class is superclass of all other MUI classes. It's main purpose is to handle MUI's notification mechanism, but it also contains some other methods and attributes useful for every object.

Inheritance
rootclass --> Notify
Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class
Methods
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Numeric

Declaration

Source position: mui.pas line 2256

const MUIC_Numeric: PChar = 'Numeric.mui';


MUIC_Numericbutton

Declaration

Source position: mui.pas line 2361

const MUIC_Numericbutton: PChar = 'Numericbutton.mui';


MUIC_Palette

Declaration

Source position: mui.pas line 2804

const MUIC_Palette: PChar = 'Palette.mui';


MUIC_Penadjust

Declaration

Source position: mui.pas line 2569

const MUIC_Penadjust: PChar = 'Penadjust.mui';


MUIC_Pendisplay

Declaration

Source position: mui.pas line 2421

const MUIC_Pendisplay: PChar = 'Pendisplay.mui';


MUIC_Popasl

Declaration

Source position: mui.pas line 2908

const MUIC_Popasl: PChar = 'Popasl.mui';


MUIC_Popframe

Declaration

Source position: mui.pas line 2397

const MUIC_Popframe: PChar = 'Popframe.mui';


MUIC_Popimage

Declaration

Source position: mui.pas line 2413

const MUIC_Popimage: PChar = 'Popimage.mui';


MUIC_Poplist

Declaration

Source position: mui.pas line 2887

const MUIC_Poplist: PChar = 'Poplist.mui';


MUIC_Popobject

Declaration

Source position: mui.pas line 2862

const MUIC_Popobject: PChar = 'Popobject.mui';


MUIC_Poppen

Declaration

Source position: mui.pas line 2468

const MUIC_Poppen: PChar = 'Poppen.mui';


MUIC_Popscreen

Declaration

Source position: mui.pas line 2900

const MUIC_Popscreen: PChar = 'Popscreen.mui';


MUIC_Popstring

Declaration

Source position: mui.pas line 2821

const MUIC_Popstring: PChar = 'Popstring.mui';


MUIC_Prop

Prop class generates the well known proportional gadgets.

Declaration

Source position: mui.pas line 1865

const MUIC_Prop: PChar = 'Prop.mui';

Description

It offers the same attributes as a usual boopsi gadget of propgclass. However, MUI's prop gadgets allow using any imagery for the knob and for the background.

Inheritance
rootclass --> Notify --> Area --> Gadget --> Prop

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Prop_Entries | ISG | LongInt | Set or get the total number of entries.
MUIA_Prop_First | ISG | LongInt | Set or get the number of the first entry.
MUIA_Prop_Horiz | ISG | BOOL (0/1) | Determine if you want a horizontal or a vertical prop gadget.
MUIA_Prop_Slider | ISG | BOOL (0/1) | Indicate that this prop gadget is used in a slider.
MUIA_Prop_UseWinBorder | I__ | LongInt | Link to one of the window border.
MUIA_Prop_Visible | ISG | LongInt | Set or get the number of visible entries.
Fields inherited from Prop
MUIA_Boopsi_Class | ISG | PIClass | Pointer to the (private) class you want to create a boopsi object from.
MUIA_Boopsi_ClassID | ISG | PChar | Name of the Boopsi class you want to create an object of.
MUIA_Boopsi_MaxHeight | ISG | LongWord | Maximal height for the boopsi gadget.
MUIA_Boopsi_MaxWidth | ISG | LongWord | Maximal width for the boopsi gadget.
MUIA_Boopsi_MinHeight | ISG | LongWord | Minimum Height for the boopsi gadget.
MUIA_Boopsi_MinWidth | ISG | LongWord | Minimum Width for the boopsi gadget.
MUIA_Boopsi_Object | __G | PObject_ | MUI returns when generating a BoopsiObject is a standard MUI object.
MUIA_Boopsi_Remember | I__ | LongWord | Attributes must be remembered during dispose/regeneration.
MUIA_Boopsi_Smart | I__ | BOOL (0/1) | Smart BOOPSI gadgets that allow resizing.
MUIA_Boopsi_TagDrawInfo | ISG | LongWord | Tell MUI where to fill in a needed DrawInfo structure.
MUIA_Boopsi_TagScreen | ISG | LongWord | Tell MUI where to fill in a needed Screen structure.
MUIA_Boopsi_TagWindow | ISG | LongWord | Tell MUI where to fill in a needed Window structure.
Fields inherited from Gadget
MUIA_Gadget_Gadget __G PGadget Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Prop_Decrease | This method decreases the value of a proportional gadget by the specified amount.
MUIM_Prop_Increase | This method increases the value of a proportional gadget by the specified amount.
Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Radio

Declaration

Source position: mui.pas line 2750

const MUIC_Radio: PChar = 'Radio.mui';


MUIC_Rectangle

Empty rectangle for space layout.

Declaration

Source position: mui.pas line 1682

const MUIC_Rectangle: PChar = 'Rectangle.mui';

Description

Rectangle class seems kind of useless since it doesn't define any attributes or methods itself. However, objects of this type are frequently used in every application. They allow insertion of space to control MUI's layout process.

Inheritance
rootclass --> Notify --> Area --> Rectangle

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Rectangle_BarTitle | I_G | PChar | Text displayed in group title style centered in the rectangle.
MUIA_Rectangle_HBar | I_G | BOOL (0/1) | Draw a horizontal bar in the middle of the rectangle.
MUIA_Rectangle_VBar | I_G | BOOL (0/1) | Draw a vertical bar in the middle of the rectangle.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Register

Declaration

Source position: mui.pas line 2554

const MUIC_Register: PChar = 'Register.mui';


MUIC_Scale

A Scale object generates a percentage scale running from 0% to 100%.

Declaration

Source position: mui.pas line 1923

const MUIC_Scale: PChar = 'Scale.mui';

Description

A Scale object generates a percentage scale running from 0% to 100%. A good place for such an object is e.g. below a fuel gauge.

Depending on how much space is available, the scale will be more or less detailed.

Due to MUI's automatic layout system, you don't need to worry about it's size. When placed in a vertical group just below the object you want to scale, everything is fine.

Inheritance
rootclass --> Notify --> Area --> Scale

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Scale_Horiz | ISG | BOOL (0/1) | Indicate whether you want a horizontal or a vertical scale.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Scrmodelist

Declaration

Source position: mui.pas line 2183

const MUIC_Scrmodelist: PChar = 'Scrmodelist.mui';


MUIC_Scrollbar

Declaration

Source position: mui.pas line 2694

const MUIC_Scrollbar: PChar = 'Scrollbar.mui';


MUIC_Scrollgroup

Declaration

Source position: mui.pas line 2670

const MUIC_Scrollgroup: PChar = 'Scrollgroup.mui';


MUIC_Semaphore

Declaration

Source position: mui.pas line 2927

const MUIC_Semaphore: PChar = 'Semaphore.mui';


MUIC_Settings

Declaration

Source position: mui.pas line 2612

const MUIC_Settings: PChar = 'Settings.mui';


MUIC_Settingsgroup

Declaration

Source position: mui.pas line 2583

const MUIC_Settingsgroup: PChar = 'Settingsgroup.mui';


MUIC_Slider

Declaration

Source position: mui.pas line 2369

const MUIC_Slider: PChar = 'Slider.mui';


MUIC_String

String class generates standard string gadgets with all editing facilities (clear, undo, etc.) enabled.

Declaration

Source position: mui.pas line 1810

const MUIC_String: PChar = 'String.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Gadget --> String

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_String_Accept | ISG | PChar | A string containing characters allowed as input for the string gadget.
MUIA_String_Acknowledge | __G | PChar | Contents of gadget if return is hit.
MUIA_String_AdvanceOnCR | ISG | BOOL (0/1) | Carriage returns in string gadgets behave like the TAB key.
MUIA_String_AttachedList | ISG | PObject_ | Control lists cursor from within the string gadget.
MUIA_String_BufferPos | _SG | LongInt | Get and set the position of the cursor.
MUIA_String_Contents | ISG | PChar | Get and set a string gadgets contents.
MUIA_String_DisplayPos | _SG | LongInt | Get and set the number of the first character of the string to be displayed.
MUIA_String_EditHook | ISG | PHook | Called on every edit of the gadget.
MUIA_String_Format | I_G | LongInt | Used to adjust the alignment of the input string.
MUIA_String_Integer | ISG | LongWord | Useful for turning a string gadget into an integer gadget.
MUIA_String_LonelyEditHook | ISG | BOOL (0/1) | Skip MUI's private edit hook completely.
MUIA_String_MaxLen | I_G | LongInt | Setup the maximum length for the string gadget.
MUIA_String_Reject | ISG | PChar | A string containing characters that should not be accepted as input for the string gadget.
MUIA_String_Secret | I_G | BOOL (0/1) | This attribute causes the string gadget to display only dots instead of the real contents.
Fields inherited from Gadget
MUIA_Gadget_Gadget __G PGadget Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Text

Text class allows generating objects that contain some kind of text.

Declaration

Source position: mui.pas line 1772

const MUIC_Text: PChar = 'Text.mui';

Description

You can control the outfit of your text with some special control characters, including italics, bold, underline and color codes. Format codes align text either left, centered or right, linefeeds allow multiline text fields.

Inheritance
rootclass --> Notify --> Area --> Text

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Text_Contents | ISG | PChar | String to be displayed in a text object.
MUIA_Text_HiChar | I__ | Char | This character in the displayed string, it will be underlined.
MUIA_Text_PreParse | ISG | PChar | String containing format definitions to be parsed before the text is printed.
MUIA_Text_SetMax | I__ | BOOL (0/1) | Use max limit width of element by string.
MUIA_Text_SetMin | I__ | BOOL (0/1) | Use min limit width of element by string.
MUIA_Text_SetVMax | I__ | BOOL (0/1) | Fix object height.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Virtgroup

Declaration

Source position: mui.pas line 2648

const MUIC_Virtgroup: PChar = 'Virtgroup.mui';


MUIC_Volumelist

Declaration

Source position: mui.pas line 2176

const MUIC_Volumelist: PChar = 'Volumelist.mui';


MUIC_Window

Objects of window class are used to generate windows and supply a place where MUI gadgets feel well.

Declaration

Source position: mui.pas line 1170

const MUIC_Window: PChar = 'Window.mui';

Description

Objects of window class are used to generate windows and supply a place where MUI gadgets feel well. It handles the complicated task of window resizing fully automatic, you don't need to worry about that.

Windows are children of an application, you cannot use a window object without having a parent application object. On the other side, the gadgets in a window are children of the window, you cannot use MUI gadgets without having a parent MUI window.

Creating a window object does not mean to open it instantly. This is done later by setting the window's MUIA_Window_Open attribute. If your application has several windows, the usual way is to create them all at once at startup time and open/close it later just by setting MUIA_Window_Open.

There is no difference in talking to gadgets whether their parent window is open or not. If you e.g. set the contents of a string gadget in an open window, the gadget will refresh immediately. If the window is closed, the gadget just remembers its new setting and displays it later.

Inheritance
rootclass --> Notify --> Window

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Window_Activate | ISG | BOOL (0/1) | Set to True to active the Window.
MUIA_Window_ActiveObject | _SG | PObject_ | Set or get the active object.
MUIA_Window_AltHeight | I_G | LongInt | Specify the alternate (zoomed) height of a window.
MUIA_Window_AltLeftEdge | I_G | LongInt | Specify the alternate (zoomed) left position of a window.
MUIA_Window_AltTopEdge | I_G | LongInt | Specify the alternate (zoomed) top position of a window.
MUIA_Window_AltWidth | I_G | LongInt | Specify the alternate (zoomed) width of a window.
MUIA_Window_AppWindow | I__ | BOOL (0/1) | Set Window as AppWindow.
MUIA_Window_Backdrop | I__ | BOOL (0/1) | Make the window a backdrop window.
MUIA_Window_Borderless | I__ | BOOL (0/1) | Make the window borderless.
MUIA_Window_CloseGadget | I__ | BOOL (0/1) | Set this to False and your window will not have a close gadget.
MUIA_Window_CloseRequest | __G | BOOL (0/1) | Set to True if the user tries to close the window.
MUIA_Window_DefaultObject | ISG | PObject_ | The default object in a window receives keyboard input.
MUIA_Window_DepthGadget | I__ | BOOL (0/1) | Enable or disable the depth gadget.
MUIA_Window_DragBar | I__ | BOOL (0/1) | Tell MUI to give your window a dragbar.
MUIA_Window_FancyDrawing | ISG | BOOL (0/1) | Obsolete relaxed way of custom class drawing.
MUIA_Window_Height | I_G | LongInt | Specify the height of a window.
MUIA_Window_ID | ISG | LongWord | Define an ID for the window.
MUIA_Window_InputEvent | __G | PInputEvent | Define an ID for the window.
MUIA_Window_IsSubWindow | ISG | BOOL (0/1) | Windows with this flag set to True dont get disposed when the application object is disposed.
MUIA_Window_LeftEdge | I_G | LongInt | Specify the left edge of a window.
MUIA_Window_MenuAction | ISG | LongWord | UserData field of selected Menu item.
MUIA_Window_Menustrip | I_G | PObject_ | Specify a menu strip object for this window.
MUIA_Window_MouseObject | __G | PObject_ | Identify mouse position.
MUIA_Window_NeedsMouseObject | I__ | BOOL (0/1) | Enable notification of changes of mouse position.
MUIA_Window_NoMenus | IS_ | BOOL (0/1) | Temporarily disable the menu strip of a window.
MUIA_Window_Open | _SG | BOOL (0/1) | Open or close the window.
MUIA_Window_PublicScreen | ISG | PChar | Force the window to appear on the public screen who's name is specified by this attribute.
MUIA_Window_RefWindow | IS_ | PObject_ | Calculate position relative to this window.
MUIA_Window_RootObject | ISG | PObject_ | This is a pointer to a MUI object and defines the contents of your window.
MUIA_Window_Screen | ISG | PScreen | You can get a pointer to the parent screen of a window by getting this attribute.
MUIA_Window_ScreenTitle | ISG | PChar | This text will appear in the screens title bar when the window is active.
MUIA_Window_SizeGadget | I__ | BOOL (0/1) | Tell MUI if you want a sizing gadget for this window.
MUIA_Window_SizeRight | I__ | BOOL (0/1) | When set to True, the size gadget will reside in the right window border.
MUIA_Window_Sleep | _SG | BOOL (0/1) | This attribute can be used to put a window to sleep.
MUIA_Window_Title | ISG | PChar | Specify the title of a window.
MUIA_Window_TopEdge | I_G | LongInt | Specify the top edge of a window.
MUIA_Window_UseBottomBorderScroller | ISG | BOOL (0/1) | If set to True, the window will feature a scrollbar in its bottom border.
MUIA_Window_UseLeftBorderScroller | ISG | BOOL (0/1) | If set to True, the window will feature a scrollbar in its left border.
MUIA_Window_UseRightBorderScroller | ISG | BOOL (0/1) | If set to True, the window will feature a scrollbar in its right border.
MUIA_Window_Width | I_G | LongInt | Specify the width of a window.
MUIA_Window_Window | __G | PWindow | Obtain a pointer to the intuition Window structure.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Window_AddEventHandler | Add an Event Handler for custom class.
MUIM_Window_RemEventHandler | Remove an Event Handler for custom class.
MUIM_Window_ScreenToBack | Put the window's screen to back.
MUIM_Window_ScreenToFront | Put the window's screen to front.
MUIM_Window_Snapshot | Remember Windows current position and size.
MUIM_Window_ToBack | Put the window to back.
MUIM_Window_ToFront | Put the window to front.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUICFG_PublicScreen

Declaration

Source position: mui.pas line 161

const MUICFG_PublicScreen = 36;


MUIE_InvalidWindowObject

Declaration

Source position: mui.pas line 315

const MUIE_InvalidWindowObject = 3;


MUIE_MissingLibrary

Declaration

Source position: mui.pas line 316

const MUIE_MissingLibrary = 4;


MUIE_NoARexx

Declaration

Source position: mui.pas line 317

const MUIE_NoARexx = 5;


Unit 'mui' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

MUIE_OK

Declaration

Source position: mui.pas line 312

const MUIE_OK = 0;


MUIE_OutOfGfxMemory

Declaration

Source position: mui.pas line 314

const MUIE_OutOfGfxMemory = 2;


MUIE_OutOfMemory

Declaration

Source position: mui.pas line 313

const MUIE_OutOfMemory = 1;


MUIE_SingleTask

Declaration

Source position: mui.pas line 318

const MUIE_SingleTask = 6;


MUII_ArrowDown

Declaration

Source position: mui.pas line 338

const MUII_ArrowDown = 12;


MUII_ArrowLeft

Declaration

Source position: mui.pas line 339

const MUII_ArrowLeft = 13;


MUII_ArrowRight

Declaration

Source position: mui.pas line 340

const MUII_ArrowRight = 14;


MUII_ArrowUp

Declaration

Source position: mui.pas line 337

const MUII_ArrowUp = 11;


MUII_Assign

Declaration

Source position: mui.pas line 355

const MUII_Assign = 29;


MUII_BACKGROUND

Declaration

Source position: mui.pas line 379

const MUII_BACKGROUND = 128;


MUII_BARBLOCK

Declaration

Source position: mui.pas line 397

const MUII_BARBLOCK = 146;


MUII_BARDETAIL

Declaration

Source position: mui.pas line 398

const MUII_BARDETAIL = 147;


MUII_ButtonBack

Declaration

Source position: mui.pas line 328

const MUII_ButtonBack = 2;


MUII_CheckMark

Declaration

Source position: mui.pas line 341

const MUII_CheckMark = 15;


MUII_Chip

Declaration

Source position: mui.pas line 351

const MUII_Chip = 25;


MUII_Count

Declaration

Source position: mui.pas line 377

const MUII_Count = 51;


MUII_Cycle

Declaration

Source position: mui.pas line 343

const MUII_Cycle = 17;


MUII_Disk

Declaration

Source position: mui.pas line 350

const MUII_Disk = 24;


MUII_Drawer

Declaration

Source position: mui.pas line 348

const MUII_Drawer = 22;


MUII_FILL

Declaration

Source position: mui.pas line 382

const MUII_FILL = 131;


MUII_FILLBACK

Declaration

Source position: mui.pas line 386

const MUII_FILLBACK = 135;


MUII_FILLBACK2

Declaration

Source position: mui.pas line 389

const MUII_FILLBACK2 = 138;


MUII_FILLSHINE

Declaration

Source position: mui.pas line 387

const MUII_FILLSHINE = 136;


MUII_GaugeEmpty

Declaration

Source position: mui.pas line 372

const MUII_GaugeEmpty = 46;


MUII_GaugeFull

Declaration

Source position: mui.pas line 371

const MUII_GaugeFull = 45;


MUII_GroupBack

Declaration

Source position: mui.pas line 361

const MUII_GroupBack = 35;


MUII_HardDisk

Declaration

Source position: mui.pas line 349

const MUII_HardDisk = 23;


MUII_HSHADOWBACK

Declaration

Source position: mui.pas line 391

const MUII_HSHADOWBACK = 140;


MUII_HSHADOWSHADOW

Declaration

Source position: mui.pas line 393

const MUII_HSHADOWSHADOW = 142;


MUII_HSHINEBACK

Declaration

Source position: mui.pas line 390

const MUII_HSHINEBACK = 139;


MUII_HSHINESHINE

Declaration

Source position: mui.pas line 392

const MUII_HSHINESHINE = 141;


MUII_ImageButtonBack

Declaration

Source position: mui.pas line 369

const MUII_ImageButtonBack = 43;


MUII_ImageSelectedBack

Declaration

Source position: mui.pas line 370

const MUII_ImageSelectedBack = 44;


MUII_LASTPAT

Declaration

Source position: mui.pas line 399

const MUII_LASTPAT = 147;


MUII_ListBack

Declaration

Source position: mui.pas line 329

const MUII_ListBack = 3;


MUII_ListCursor

Declaration

Source position: mui.pas line 334

const MUII_ListCursor = 8;


MUII_ListSelCur

Declaration

Source position: mui.pas line 336

const MUII_ListSelCur = 10;


MUII_ListSelect

Declaration

Source position: mui.pas line 335

const MUII_ListSelect = 9;


MUII_MARKBACKGROUND

Declaration

Source position: mui.pas line 396

const MUII_MARKBACKGROUND = 145;


MUII_MARKHALFSHINE

Declaration

Source position: mui.pas line 395

const MUII_MARKHALFSHINE = 144;


MUII_MARKSHINE

Declaration

Source position: mui.pas line 394

const MUII_MARKSHINE = 143;


MUII_Menudisplay

Declaration

Source position: mui.pas line 373

const MUII_Menudisplay = 47;


MUII_Network

Declaration

Source position: mui.pas line 354

const MUII_Network = 28;


MUII_PageBack

Declaration

Source position: mui.pas line 366

const MUII_PageBack = 40;


MUII_PopDrawer

Declaration

Source position: mui.pas line 346

const MUII_PopDrawer = 20;


MUII_PopFile

Declaration

Source position: mui.pas line 345

const MUII_PopFile = 19;


MUII_PopFont

Declaration

Source position: mui.pas line 368

const MUII_PopFont = 42;


MUII_PopUp

Declaration

Source position: mui.pas line 344

const MUII_PopUp = 18;


MUII_PopupBack

Declaration

Source position: mui.pas line 332

const MUII_PopupBack = 6;


MUII_PropBack

Declaration

Source position: mui.pas line 331

const MUII_PropBack = 5;


MUII_PropKnob

Declaration

Source position: mui.pas line 347

const MUII_PropKnob = 21;


MUII_PullOpen

Declaration

Source position: mui.pas line 374

const MUII_PullOpen = 48;


MUII_RadioButton

Declaration

Source position: mui.pas line 342

const MUII_RadioButton = 16;


MUII_ReadListBack

Declaration

Source position: mui.pas line 367

const MUII_ReadListBack = 41;


MUII_RegisterBack

Declaration

Source position: mui.pas line 353

const MUII_RegisterBack = 27;


MUII_RequesterBack

Declaration

Source position: mui.pas line 327

const MUII_RequesterBack = 1;


MUII_SelectedBack

Declaration

Source position: mui.pas line 333

const MUII_SelectedBack = 7;


MUII_SHADOW

Declaration

Source position: mui.pas line 380

const MUII_SHADOW = 129;


MUII_SHADOWBACK

Declaration

Source position: mui.pas line 383

const MUII_SHADOWBACK = 132;


MUII_SHADOWFILL

Declaration

Source position: mui.pas line 384

const MUII_SHADOWFILL = 133;


MUII_SHADOWSHINE

Declaration

Source position: mui.pas line 385

const MUII_SHADOWSHINE = 134;


MUII_SHINE

Declaration

Source position: mui.pas line 381

const MUII_SHINE = 130;


MUII_SHINEBACK

Declaration

Source position: mui.pas line 388

const MUII_SHINEBACK = 137;


MUII_SliderBack

Declaration

Source position: mui.pas line 362

const MUII_SliderBack = 36;


MUII_SliderKnob

Declaration

Source position: mui.pas line 363

const MUII_SliderKnob = 37;


MUII_StringActiveBack

Declaration

Source position: mui.pas line 376

const MUII_StringActiveBack = 50;


MUII_StringBack

Declaration

Source position: mui.pas line 375

const MUII_StringBack = 49;


MUII_TapeDown

Declaration

Source position: mui.pas line 365

const MUII_TapeDown = 39;


MUII_TapePause

Declaration

Source position: mui.pas line 358

const MUII_TapePause = 32;


MUII_TapePlay

Declaration

Source position: mui.pas line 356

const MUII_TapePlay = 30;


MUII_TapePlayBack

Declaration

Source position: mui.pas line 357

const MUII_TapePlayBack = 31;


MUII_TapeRecord

Declaration

Source position: mui.pas line 360

const MUII_TapeRecord = 34;


MUII_TapeStop

Declaration

Source position: mui.pas line 359

const MUII_TapeStop = 33;


MUII_TapeUp

Declaration

Source position: mui.pas line 364

const MUII_TapeUp = 38;


MUII_TextBack

Declaration

Source position: mui.pas line 330

const MUII_TextBack = 4;


MUII_Volume

Declaration

Source position: mui.pas line 352

const MUII_Volume = 26;


MUII_WindowBack

Declaration

Source position: mui.pas line 326

const MUII_WindowBack = 0;


MUIIHNF_TIMER

Declaration

Source position: mui.pas line 558

const MUIIHNF_TIMER = 1 shl 0;


MUIKEY_BOTTOM

Declaration

Source position: mui.pas line 3247

const MUIKEY_BOTTOM = 7;


MUIKEY_COUNT

Declaration

Source position: mui.pas line 3262

const MUIKEY_COUNT = 22;


MUIKEY_DOWN

Declaration

Source position: mui.pas line 3243

const MUIKEY_DOWN = 3;


MUIKEY_GADGET_NEXT

Declaration

Source position: mui.pas line 3254

const MUIKEY_GADGET_NEXT = 14;


MUIKEY_GADGET_OFF

Declaration

Source position: mui.pas line 3256

const MUIKEY_GADGET_OFF = 16;


MUIKEY_GADGET_PREV

Declaration

Source position: mui.pas line 3255

const MUIKEY_GADGET_PREV = 15;


MUIKEY_HELP

Declaration

Source position: mui.pas line 3260

const MUIKEY_HELP = 20;


MUIKEY_LEFT

Declaration

Source position: mui.pas line 3248

const MUIKEY_LEFT = 8;


MUIKEY_LINEEND

Declaration

Source position: mui.pas line 3253

const MUIKEY_LINEEND = 13;


MUIKEY_LINESTART

Declaration

Source position: mui.pas line 3252

const MUIKEY_LINESTART = 12;


MUIKEY_NONE

Declaration

Source position: mui.pas line 3239

const MUIKEY_NONE = - 1;


MUIKEY_PAGEDOWN

Declaration

Source position: mui.pas line 3245

const MUIKEY_PAGEDOWN = 5;


MUIKEY_PAGEUP

Declaration

Source position: mui.pas line 3244

const MUIKEY_PAGEUP = 4;


MUIKEY_POPUP

Declaration

Source position: mui.pas line 3261

const MUIKEY_POPUP = 21;


MUIKEY_PRESS

Declaration

Source position: mui.pas line 3240

const MUIKEY_PRESS = 0;


MUIKEY_RELEASE

Declaration

Source position: mui.pas line 3238

const MUIKEY_RELEASE = - 2;


MUIKEY_RIGHT

Declaration

Source position: mui.pas line 3249

const MUIKEY_RIGHT = 9;


MUIKEY_TOGGLE

Declaration

Source position: mui.pas line 3241

const MUIKEY_TOGGLE = 1;


MUIKEY_TOP

Declaration

Source position: mui.pas line 3246

const MUIKEY_TOP = 6;


MUIKEY_UP

Declaration

Source position: mui.pas line 3242

const MUIKEY_UP = 2;


MUIKEY_WINDOW_CLOSE

Declaration

Source position: mui.pas line 3257

const MUIKEY_WINDOW_CLOSE = 17;


MUIKEY_WINDOW_NEXT

Declaration

Source position: mui.pas line 3258

const MUIKEY_WINDOW_NEXT = 18;


MUIKEY_WINDOW_PREV

Declaration

Source position: mui.pas line 3259

const MUIKEY_WINDOW_PREV = 19;


MUIKEY_WORDLEFT

Declaration

Source position: mui.pas line 3250

const MUIKEY_WORDLEFT = 10;


MUIKEY_WORDRIGHT

Declaration

Source position: mui.pas line 3251

const MUIKEY_WORDRIGHT = 11;


MUIKEYF_BOTTOM

Declaration

Source position: mui.pas line 3271

const MUIKEYF_BOTTOM = 1 shl MUIKEY_BOTTOM;


MUIKEYF_DOWN

Declaration

Source position: mui.pas line 3267

const MUIKEYF_DOWN = 1 shl MUIKEY_DOWN;


MUIKEYF_GADGET_NEXT

Declaration

Source position: mui.pas line 3278

const MUIKEYF_GADGET_NEXT = 1 shl MUIKEY_GADGET_NEXT;


MUIKEYF_GADGET_OFF

Declaration

Source position: mui.pas line 3280

const MUIKEYF_GADGET_OFF = 1 shl MUIKEY_GADGET_OFF;


MUIKEYF_GADGET_PREV

Declaration

Source position: mui.pas line 3279

const MUIKEYF_GADGET_PREV = 1 shl MUIKEY_GADGET_PREV;


MUIKEYF_HELP

Declaration

Source position: mui.pas line 3284

const MUIKEYF_HELP = 1 shl MUIKEY_HELP;


MUIKEYF_LEFT

Declaration

Source position: mui.pas line 3272

const MUIKEYF_LEFT = 1 shl MUIKEY_LEFT;


MUIKEYF_LINEEND

Declaration

Source position: mui.pas line 3277

const MUIKEYF_LINEEND = 1 shl MUIKEY_LINEEND;


MUIKEYF_LINESTART

Declaration

Source position: mui.pas line 3276

const MUIKEYF_LINESTART = 1 shl MUIKEY_LINESTART;


MUIKEYF_PAGEDOWN

Declaration

Source position: mui.pas line 3269

const MUIKEYF_PAGEDOWN = 1 shl MUIKEY_PAGEDOWN;


MUIKEYF_PAGEUP

Declaration

Source position: mui.pas line 3268

const MUIKEYF_PAGEUP = 1 shl MUIKEY_PAGEUP;


MUIKEYF_POPUP

Declaration

Source position: mui.pas line 3285

const MUIKEYF_POPUP = 1 shl MUIKEY_POPUP;


MUIKEYF_PRESS

Declaration

Source position: mui.pas line 3264

const MUIKEYF_PRESS = 1 shl MUIKEY_PRESS;


MUIKEYF_RIGHT

Declaration

Source position: mui.pas line 3273

const MUIKEYF_RIGHT = 1 shl MUIKEY_RIGHT;


MUIKEYF_TOGGLE

Declaration

Source position: mui.pas line 3265

const MUIKEYF_TOGGLE = 1 shl MUIKEY_TOGGLE;


MUIKEYF_TOP

Declaration

Source position: mui.pas line 3270

const MUIKEYF_TOP = 1 shl MUIKEY_TOP;


MUIKEYF_UP

Declaration

Source position: mui.pas line 3266

const MUIKEYF_UP = 1 shl MUIKEY_UP;


MUIKEYF_WINDOW_CLOSE

Declaration

Source position: mui.pas line 3281

const MUIKEYF_WINDOW_CLOSE = 1 shl MUIKEY_WINDOW_CLOSE;


MUIKEYF_WINDOW_NEXT

Declaration

Source position: mui.pas line 3282

const MUIKEYF_WINDOW_NEXT = 1 shl MUIKEY_WINDOW_NEXT;


MUIKEYF_WINDOW_PREV

Declaration

Source position: mui.pas line 3283

const MUIKEYF_WINDOW_PREV = 1 shl MUIKEY_WINDOW_PREV;


MUIKEYF_WORDLEFT

Declaration

Source position: mui.pas line 3274

const MUIKEYF_WORDLEFT = 1 shl MUIKEY_WORDLEFT;


MUIKEYF_WORDRIGHT

Declaration

Source position: mui.pas line 3275

const MUIKEYF_WORDRIGHT = 1 shl MUIKEY_WORDRIGHT;


MUILM_LAYOUT

Declaration

Source position: mui.pas line 3140

const MUILM_LAYOUT = 2;


MUILM_MINMAX

Declaration

Source position: mui.pas line 3138

const MUILM_MINMAX = 1;


MUILM_UNKNOWN

Declaration

Source position: mui.pas line 3142

const MUILM_UNKNOWN = - 1;


MUIM_Application_AboutMUI

Declaration

Source position: mui.pas line 990

const MUIM_Application_AboutMUI = $8042d21d;


MUIM_Application_AddInputHandler

Declaration

Source position: mui.pas line 991

const MUIM_Application_AddInputHandler = $8042f099;


MUIM_Application_BuildSettingsPanel

Declaration

Source position: mui.pas line 992

const MUIM_Application_BuildSettingsPanel = $8042b58f;


MUIM_Application_CheckRefresh

Declaration

Source position: mui.pas line 993

const MUIM_Application_CheckRefresh = $80424d68;


MUIM_Application_DefaultConfigItem

Declaration

Source position: mui.pas line 994

const MUIM_Application_DefaultConfigItem = $8042d934;


MUIM_Application_InputBuffered

Declaration

Source position: mui.pas line 995

const MUIM_Application_InputBuffered = $80427e59;


MUIM_Application_Load

Declaration

Source position: mui.pas line 996

const MUIM_Application_Load = $8042f90d;


MUIM_Application_NewInput

Declaration

Source position: mui.pas line 997

const MUIM_Application_NewInput = $80423ba6;


MUIM_Application_OpenConfigWindow

Declaration

Source position: mui.pas line 998

const MUIM_Application_OpenConfigWindow = $804299ba;


MUIM_Application_PushMethod

Declaration

Source position: mui.pas line 999

const MUIM_Application_PushMethod = $80429ef8;


MUIM_Application_RemInputHandler

Declaration

Source position: mui.pas line 1000

const MUIM_Application_RemInputHandler = $8042e7af;


MUIM_Application_ReturnID

Declaration

Source position: mui.pas line 1001

const MUIM_Application_ReturnID = $804276ef;


MUIM_Application_Save

Declaration

Source position: mui.pas line 1002

const MUIM_Application_Save = $804227ef;


MUIM_Application_SetConfigItem

Declaration

Source position: mui.pas line 1003

const MUIM_Application_SetConfigItem = $80424a80;


MUIM_Application_ShowHelp

Declaration

Source position: mui.pas line 1004

const MUIM_Application_ShowHelp = $80426479;


MUIM_AskMinMax

Declaration

Source position: mui.pas line 1374

const MUIM_AskMinMax = $80423874;


MUIM_BoopsiQuery

Declaration

Source position: mui.pas line 634

const MUIM_BoopsiQuery = $80427157;


MUIM_CallHook

Call a standard amiga callback hook

Declaration

Source position: mui.pas line 698

const MUIM_CallHook = $8042b96b;

Description

Call a standard amiga callback hook, defined by a Hook structure. Together with MUIM_Notify, you can easily bind hooks to buttons, your hook will be called when the button is pressed.

The hook will be called with a pointer to the hook structure, a pointer to the calling object and a pointer to the first parameter.

See also

MUIM_Notify

Add a notification event handler to an object


MUIM_Cleanup

Declaration

Source position: mui.pas line 1375

const MUIM_Cleanup = $8042d985;


MUIM_ContextMenuAdd

Declaration

Source position: mui.pas line 1376

const MUIM_ContextMenuAdd = $8042df9e;


MUIM_ContextMenuBuild

Declaration

Source position: mui.pas line 1377

const MUIM_ContextMenuBuild = $80429d2e;


MUIM_ContextMenuChoice

Declaration

Source position: mui.pas line 1378

const MUIM_ContextMenuChoice = $80420f0e;


MUIM_CreateBubble

Declaration

Source position: mui.pas line 1379

const MUIM_CreateBubble = $80421c41;


MUIM_CreateShortHelp

Declaration

Source position: mui.pas line 1380

const MUIM_CreateShortHelp = $80428e93;


MUIM_Dataspace_Add

Declaration

Source position: mui.pas line 2997

const MUIM_Dataspace_Add = $80423366;


MUIM_Dataspace_Clear

Declaration

Source position: mui.pas line 2999

const MUIM_Dataspace_Clear = $8042b6c9;


MUIM_Dataspace_Find

Declaration

Source position: mui.pas line 3001

const MUIM_Dataspace_Find = $8042832c;


MUIM_Dataspace_Merge

Declaration

Source position: mui.pas line 3003

const MUIM_Dataspace_Merge = $80423e2b;


MUIM_Dataspace_ReadIFF

Declaration

Source position: mui.pas line 3005

const MUIM_Dataspace_ReadIFF = $80420dfb;


MUIM_Dataspace_Remove

Declaration

Source position: mui.pas line 3007

const MUIM_Dataspace_Remove = $8042dce1;


MUIM_Dataspace_WriteIFF

Declaration

Source position: mui.pas line 3009

const MUIM_Dataspace_WriteIFF = $80425e8e;


MUIM_DeleteBubble

Declaration

Source position: mui.pas line 1381

const MUIM_DeleteBubble = $804211af;


MUIM_DeleteShortHelp

Declaration

Source position: mui.pas line 1382

const MUIM_DeleteShortHelp = $8042d35a;


MUIM_Dirlist_ReRead

Declaration

Source position: mui.pas line 2198

const MUIM_Dirlist_ReRead = $80422d71;


MUIM_DoDrag

Declaration

Source position: mui.pas line 1383

const MUIM_DoDrag = $804216bb;


MUIM_DragBegin

Declaration

Source position: mui.pas line 1384

const MUIM_DragBegin = $8042c03a;


MUIM_DragDrop

Declaration

Source position: mui.pas line 1385

const MUIM_DragDrop = $8042c555;


MUIM_DragFinish

Declaration

Source position: mui.pas line 1386

const MUIM_DragFinish = $804251f0;


MUIM_DragQuery

Declaration

Source position: mui.pas line 1387

const MUIM_DragQuery = $80420261;


MUIM_DragReport

Declaration

Source position: mui.pas line 1388

const MUIM_DragReport = $8042edad;


MUIM_Draw

Declaration

Source position: mui.pas line 1389

const MUIM_Draw = $80426f3f;


MUIM_DrawBackground

Declaration

Source position: mui.pas line 1390

const MUIM_DrawBackground = $804238ca;


MUIM_Export

Called on export object to dataspace

Declaration

Source position: mui.pas line 699

const MUIM_Export = $80420f1c;

Description

DoMethod(obj, MUIM_Export, [DataSpace: PObject_]);

DataSpace
- dataspace object to save the properties.

This method is called for each object in the application tree (including menus) during execution of MUIM_Application_Save. It's purpose is to export an objects "contents" to a dataspace object for later saving to an IFF file.

If you override this method to export your custom data, you are supposed to use your MUIA_ObjectID as ID for the dataspace entry. Don't export if your MUIA_ObjectID is 0.

Return 0 if you dont want your superclasses to be able to import/export any values themselves. Otherwise Result := DoSuperMethodA(cl,obj,msg);

See also

MUIA_ObjectID |
MUIM_Import | Called on import object from dataspace
MUIM_Application_Load |
MUIM_Application_Save |


MUIM_Family_AddHead

Declaration

Source position: mui.pas line 864

const MUIM_Family_AddHead = $8042e200;


MUIM_Family_AddTail

Declaration

Source position: mui.pas line 865

const MUIM_Family_AddTail = $8042d752;


MUIM_Family_Insert

Declaration

Source position: mui.pas line 866

const MUIM_Family_Insert = $80424d34;


MUIM_Family_Remove

Declaration

Source position: mui.pas line 867

const MUIM_Family_Remove = $8042f8a9;


MUIM_Family_Sort

Declaration

Source position: mui.pas line 868

const MUIM_Family_Sort = $80421c49;


MUIM_Family_Transfer

Declaration

Source position: mui.pas line 869

const MUIM_Family_Transfer = $8042c14a;


MUIM_FindUData

Find a userdata in objects and childrens list and return the object

Declaration

Source position: mui.pas line 700

const MUIM_FindUData = $8042c196;

Description

DoMethod(obj, MUIM_FindUData, [UData: IPTR]);

UData
- userdata to look for.

This method tests if the MUIA_UserData of the object contains the given UData and returns the object pointer in this case.

Although this is not very useful for single objects, performing this method on objects that handle children can become very handy. In this case, all the children (any maybe their children) are tested against UData and the first matching object is returned.

This method is especially useful if you created your menu tree with a NewMenu structure and you want to find the object pointer for a single menu item.

Note: If you have many objects in your application, MUIM_FindUData may take quite long. You can limit the amount of time by performing the method not on the application but on the window or even on the group/family your object is placed in.

See also

MUIM_GetUData |
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object


MUIM_GetConfigItem

Declaration

Source position: mui.pas line 701

const MUIM_GetConfigItem = $80423edb;

Description

DoMethod(obj, MUIM_GetConfigItem, [id: LongWord, Storage: PLongWord]);


MUIM_GetUData

Declaration

Source position: mui.pas line 702

const MUIM_GetUData = $8042ed0c;

Description

DoMethod(obj, MUIM_GetUData, [udata: IPTR, Attr: LongWord, Storage: PLongWord]);

UData
- userdata to look for.
Attr
- attribute to get.
Storage
- place to store the attribute.

This method tests if the MUIA_UserData of the object contains the given UData and gets Attr to Storage for itself in this case.

Although this is not very useful for single objects, performing this method on objects that handle children can become very handy. In this case, all the children (any maybe their children) are searched against UData and the first matching objects will be asked for the specified attribute.

Note: If you have many objects in your application, MUIM_GetUData may take quite long. You can limit the amount of time by performing the method not on the application but on the window or even on the group/family your objects are place in.

See also

MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object


MUIM_Group_ExitChange

Declaration

Source position: mui.pas line 2482

const MUIM_Group_ExitChange = $8042d1cc;


MUIM_Group_InitChange

Declaration

Source position: mui.pas line 2484

const MUIM_Group_InitChange = $80420887;


MUIM_Group_Sort

Declaration

Source position: mui.pas line 2486

const MUIM_Group_Sort = $80427417;


MUIM_HandleEvent

Declaration

Source position: mui.pas line 1391

const MUIM_HandleEvent = $80426d66;


MUIM_HandleInput

Declaration

Source position: mui.pas line 1392

const MUIM_HandleInput = $80422a1a;


MUIM_Hide

Declaration

Source position: mui.pas line 1393

const MUIM_Hide = $8042f20f;


MUIM_Import

Called on import object from dataspace

Declaration

Source position: mui.pas line 703

const MUIM_Import = $8042d012;

Description

DoMethod(obj, MUIM_Import, [DataSpace: PObject_]);

DataSpace
dataspace object to save the properties.

This method is called for each object in the application tree (including menus) during execution of MUIM_Application_Load. It's purpose is to import an objects "contents" from a dataspace object after loading from an IFF file.

If you override this method to import your custom data, you are supposed to use your MUIA_ObjectID as ID for the dataspace entry. Don't import if your MUIA_ObjectID is 0.

See also

MUIM_Application_Load

MUIM_Application_Save


MUIM_KillNotify

kills previously given notifications on specific attributes

Declaration

Source position: mui.pas line 704

const MUIM_KillNotify = $8042d240;

Description

DoMethod(obj, MUIM_KillNotify, [TrigAttr: LongWord]);

TrigAttr
Attribute for which the notify was specified. If you set up more than one notify for an attribute, only the first one will be killed.

See also

MUIM_Notify

Add a notification event handler to an object


MUIM_KillNotifyObj

Declaration

Source position: mui.pas line 705

const MUIM_KillNotifyObj = $8042b145;

Description

DoMethod(obj, MUIM_KillNotifyObj, [TrigAttr: LongWord, Dest: PObject_]);


MUIM_List_Clear

Declaration

Source position: mui.pas line 1957

const MUIM_List_Clear = $8042ad89;


MUIM_List_CreateImage

Declaration

Source position: mui.pas line 1959

const MUIM_List_CreateImage = $80429804;


MUIM_List_DeleteImage

Declaration

Source position: mui.pas line 1961

const MUIM_List_DeleteImage = $80420f58;


MUIM_List_Exchange

Declaration

Source position: mui.pas line 1963

const MUIM_List_Exchange = $8042468c;


MUIM_List_GetEntry

Declaration

Source position: mui.pas line 1965

const MUIM_List_GetEntry = $804280ec;


MUIM_List_Insert

Declaration

Source position: mui.pas line 1967

const MUIM_List_Insert = $80426c87;


MUIM_List_InsertSingle

Declaration

Source position: mui.pas line 1969

const MUIM_List_InsertSingle = $804254d5;


MUIM_List_Jump

Declaration

Source position: mui.pas line 1971

const MUIM_List_Jump = $8042baab;


MUIM_List_Move

Declaration

Source position: mui.pas line 1973

const MUIM_List_Move = $804253c2;


MUIM_List_NextSelected

Declaration

Source position: mui.pas line 1975

const MUIM_List_NextSelected = $80425f17;


MUIM_List_Redraw

Declaration

Source position: mui.pas line 1977

const MUIM_List_Redraw = $80427993;


MUIM_List_Remove

Declaration

Source position: mui.pas line 1979

const MUIM_List_Remove = $8042647e;


MUIM_List_Select

Declaration

Source position: mui.pas line 1981

const MUIM_List_Select = $804252d8;


MUIM_List_Sort

Declaration

Source position: mui.pas line 1983

const MUIM_List_Sort = $80422275;


MUIM_List_TestPos

Declaration

Source position: mui.pas line 1985

const MUIM_List_TestPos = $80425f48;


MUIM_Menustrip_ExitChange

Declaration

Source position: mui.pas line 924

const MUIM_Menustrip_ExitChange = $8042ce4d;


MUIM_Menustrip_InitChange

Declaration

Source position: mui.pas line 925

const MUIM_Menustrip_InitChange = $8042dcd9;


MUIM_MultiSet

Set an attribute for multiple objects.

Declaration

Source position: mui.pas line 706

const MUIM_MultiSet = $8042d356;

Description

DoMethod(obj, MUIM_Export, [TrigAttr: LongWord; Val: IPTR, Obj1: APTR, ...]);

TrigAttr
- attribute to set.
value
- new value for the attribute.
Obj1, ...
- list of MUI objects, terminated with a nil pointer.

Set an attribute for multiple objects. Receiving an attribute/value pair and a list of objects, this method sets the new value for all the objects in the list. This is especially useful for disabling/enabling lots of objects with one singe function call.

The object that executes this method isn't affected!

See also

MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value.


MUIM_NoNotifySet

Acts like MUIM_Set but doesn't trigger any notification.

Declaration

Source position: mui.pas line 707

const MUIM_NoNotifySet = $8042216f;

Description

DoMethod(obj, MUIM_Export, [Attr: LongWord, Val: LongWord, ...]);

Attr
- attribute you want to set.
Val
- value to set the attribute to.

This can become useful to avoid deadlocks with bi-directional connections.


MUIM_Notify

Add a notification event handler to an object

Declaration

Source position: mui.pas line 708

const MUIM_Notify = $8042c9cb;

Description

DoMethod(obj, MUIM_Notify, [TrigAttr: LongWord, TrigVal: LongWord, DestObj: APTR, FollowParams: LongWord, ... );

TrigAttr
attribute that triggers the notification.
TrigValue
value that triggers the notification. The special value MUIV_EveryTime makes MUI execute the notification method every time when TrigAttr changes. In this case, the special value MUIV_TriggerValue in the notification method will be replaced with the value that TrigAttr has been set to. You can use MUIV_TriggerValue up to four times in one notification method. Since version 8 of muimaster.library, you can also use MUIV_NotTriggerValue here. In this case, MUI will replace True values with False and False values with True. This can become quite useful when you try to set "negative" attributes like MUIA_Disabled.
DestObj
object on which to perform the notification method. Either supply a valid object pointer or one of the following special values (V10) which will be resolved at the time the event occurs: MUIV_Notify_Self - notifies the object itself. MUIV_Notify_Window - notifies the object's parent window. MUIV_Notify_Application - notifies the object's application.
FollowParams
number of following parameters. If you e.g. have a notification method with three parts (maybe MUIM_Set,attr,val), you have to set FollowParams to 3. This allows MUI to copy the complete notification method into a private buffer for later use.
...
following is the notification method.

Add a notification event handler to an object. Notification is essential for every MUI application.

A notification statement consists of a source object, an attribute/value pair, a destination object and a notification method. The attribute/value pair belongs to the source object and determines when the notification method will be executed on the destination object.

Whenever the source object gets the given attribute set to the given value (this can happen because of the user pressing some gadgets or because of your program explicitly setting the attribute with SetAttrs()), the destination object will execute the notification method.

With some special values, you can trigger the notification every time the attribute is changing. In this case, you can include the triggering attributes value within the notification method. See below.

One big problem with notification are endless loops. Imagine you have a prop gadget and want to show its state with a gauge object. You connect MUIA_Prop_First with MUIA_Gauge_Max and everything is fine, the gauge gets updated when the user drags around the gadget. On the other hand, if your program sets the gauge to a new value, you might want your prop gadget to immediately show this change and connect MUIA_Gauge_Max width MUIA_Prop_First. Voila, a perfect endless loop.

To avoid these conditions, MUI always checks new attribute values against the current state and cancels notification when both values are equal. Thus, setting MUIA_Prop_First to 42 if the prop gadgets first position is already 42 won't trigger any notification event.


MUIM_Numeric_Decrease

Declaration

Source position: mui.pas line 2262

const MUIM_Numeric_Decrease = $804243a7;


MUIM_Numeric_Increase

Declaration

Source position: mui.pas line 2264

const MUIM_Numeric_Increase = $80426ecd;


MUIM_Numeric_ScaleToValue

Declaration

Source position: mui.pas line 2266

const MUIM_Numeric_ScaleToValue = $8042032c;


MUIM_Numeric_SetDefault

Declaration

Source position: mui.pas line 2268

const MUIM_Numeric_SetDefault = $8042ab0a;


MUIM_Numeric_Stringify

Declaration

Source position: mui.pas line 2270

const MUIM_Numeric_Stringify = $80424891;


MUIM_Numeric_ValueToScale

Declaration

Source position: mui.pas line 2272

const MUIM_Numeric_ValueToScale = $80423e4f;


MUIM_Pendisplay_SetColormap

Declaration

Source position: mui.pas line 2427

const MUIM_Pendisplay_SetColormap = $80426c80;


MUIM_Pendisplay_SetMUIPen

Declaration

Source position: mui.pas line 2429

const MUIM_Pendisplay_SetMUIPen = $8042039d;


MUIM_Pendisplay_SetRGB

Declaration

Source position: mui.pas line 2431

const MUIM_Pendisplay_SetRGB = $8042c131;


MUIM_Popstring_Close

Declaration

Source position: mui.pas line 2827

const MUIM_Popstring_Close = $8042dc52;


MUIM_Popstring_Open

Declaration

Source position: mui.pas line 2829

const MUIM_Popstring_Open = $804258ba;


MUIM_Prop_Decrease

Declaration

Source position: mui.pas line 1869

const MUIM_Prop_Decrease = $80420dd1;


MUIM_Prop_Increase

Declaration

Source position: mui.pas line 1870

const MUIM_Prop_Increase = $8042cac0;


MUIM_Semaphore_Attempt

Declaration

Source position: mui.pas line 2933

const MUIM_Semaphore_Attempt = $80426ce2;


MUIM_Semaphore_AttemptShared

Declaration

Source position: mui.pas line 2935

const MUIM_Semaphore_AttemptShared = $80422551;


MUIM_Semaphore_Obtain

Declaration

Source position: mui.pas line 2937

const MUIM_Semaphore_Obtain = $804276f0;


MUIM_Semaphore_ObtainShared

Declaration

Source position: mui.pas line 2939

const MUIM_Semaphore_ObtainShared = $8042ea02;


MUIM_Semaphore_Release

Declaration

Source position: mui.pas line 2941

const MUIM_Semaphore_Release = $80421f2d;


MUIM_Set

Set an attribute to a value.

Declaration

Source position: mui.pas line 709

const MUIM_Set = $8042549a;

Description

DoMethod(obj, MUIM_Export, [Attr: LongWord; Value: IPTR]);

Attr
attribute you want to set.
value
value to set the attribute to.

Set an attribute to a value. Normally, you would set attributes with intuition.library SetAttrs() or with the OM_SET method as with any other boopsi objects. But since these calls need a complete tag list, not just a single attribute/value pair, they are not useful within a MUIM_Notify method.

See also

MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_Notify | Add a notification event handler to an object
MUIM_NoNotifySet | Acts like MUIM_Set but doesn't trigger any notification.


MUIM_SetAsString

Set a (text kind) attribute to a string.

Declaration

Source position: mui.pas line 710

const MUIM_SetAsString = $80422590;

Description

DoMethod(obj, MUIM_Export, [Attr: LongWord; Format: PChar; Value: IPTR, ...]);

Attr
attribute you want to set.
Format
C like formatting string, remember to use '%ld'!
Value,...
one or more paremeters for the format string.

This can be useful if you want to connect a numeric attribute of an object with a text attribute of another object.

See also

MUIM_Set | Set an attribute to a value.
MUIM_Notify | Add a notification event handler to an object


MUIM_Settingsgroup_ConfigToGadgets

Declaration

Source position: mui.pas line 2589

const MUIM_Settingsgroup_ConfigToGadgets = $80427043;


MUIM_Settingsgroup_GadgetsToConfig

Declaration

Source position: mui.pas line 2591

const MUIM_Settingsgroup_GadgetsToConfig = $80425242;


MUIM_SetUData

Find a userdata in objects and childrens list and set an attribute of the object

Declaration

Source position: mui.pas line 711

const MUIM_SetUData = $8042c920;

Description

DoMethod(obj, MUIM_Export, [UData: IPTR; Attr: LongWord; Value: LongWord]);

UData
userdata to look for.
Attr
attribute to set.
Value
value to set attribute to.

This method tests if the MUIA_UserData of the object contains the given UData and sets Attr to Value for itself in this case.

Altough this is not very useful for single objects, performing this method on objects that handle children can become very handy. In this case, all the children (any maybe their children) are tested against UData and all matching objects will get the attribute set.

If you e.g. want to clear several string gadgets in your applciation at once, you simply give them the same MUIA_UserData and use

Note: If you have many objects in your application, MUIM_SetUData may take quite long. You can limit the amount of time by performing the method not on the application but on the window or even on the group your gadgets are place in.

See also

MUIM_GetUData |
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.


MUIM_SetUDataOnce

This method performs like MUIM_SetUData, but stop at first found object.

Declaration

Source position: mui.pas line 712

const MUIM_SetUDataOnce = $8042ca19;

Description

DoMethod(obj, MUIM_Export, [UData: IPTR; Attr: LongWord; Value: LongWord]);

UData
userdata to look for.
Attr
attribute to set.
Value
value to set attribute to.

This method performs like MUIM_SetUData, but stops when it has found an object with the given user data. If you don't have objects with equal user datas and don't rely on setting all of them, MUIM_SetUDataOnce is preferrable because it's more efficient.

See also

MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_GetUData |


MUIM_Setup

Declaration

Source position: mui.pas line 1394

const MUIM_Setup = $80428354;


MUIM_Show

Declaration

Source position: mui.pas line 1395

const MUIM_Show = $8042cc84;


MUIM_UpdateConfig

Declaration

Source position: mui.pas line 1396

const MUIM_UpdateConfig = $8042b0a9;


MUIM_Window_AddEventHandler

Declaration

Source position: mui.pas line 1173

const MUIM_Window_AddEventHandler = $804203b7;


MUIM_Window_Cleanup

Declaration

Source position: mui.pas line 1174

const MUIM_Window_Cleanup = $8042ab26;


MUIM_Window_RemEventHandler

Declaration

Source position: mui.pas line 1175

const MUIM_Window_RemEventHandler = $8042679e;


MUIM_Window_ScreenToBack

Declaration

Source position: mui.pas line 1176

const MUIM_Window_ScreenToBack = $8042913d;


MUIM_Window_ScreenToFront

Declaration

Source position: mui.pas line 1177

const MUIM_Window_ScreenToFront = $804227a4;


MUIM_Window_Setup

Declaration

Source position: mui.pas line 1178

const MUIM_Window_Setup = $8042c34c;


MUIM_Window_Snapshot

Declaration

Source position: mui.pas line 1179

const MUIM_Window_Snapshot = $8042945e;


MUIM_Window_ToBack

Declaration

Source position: mui.pas line 1180

const MUIM_Window_ToBack = $8042152e;


MUIM_Window_ToFront

Declaration

Source position: mui.pas line 1181

const MUIM_Window_ToFront = $8042554f;


MUIM_WriteLong

This method simply writes a longword somewhere to memory.

Declaration

Source position: mui.pas line 713

const MUIM_WriteLong = $80428d86;

Description

DoMethod(obj, MUIM_Export, [Value: LongWord, Memory: PLongWord]);

Value
value to set attribute to.
Memory
location to write the value to

This method simply writes a longword somewhere to memory. Although this seems quite useless, it might become handy if used within a notify statement. For instance, you could easily connect the current level of a slider with some member of your programs data structures.

See also

MUIM_WriteString | This method simply copies a string somewhere to memory.
MUIM_Notify | Add a notification event handler to an object


MUIM_WriteString

This method simply copies a string somewhere to memory.

Declaration

Source position: mui.pas line 714

const MUIM_WriteString = $80424bf4;

Description

DoMethod(obj, MUIM_Export, [Str: PChar, Memory: PChar]);

Str
string to copy
Memory
location to write the value to

This method simply copies a string somewhere to memory. Although this seems quite useless, it might become handy if used within a notify statement. For instance, you could easily connect the current contents of a string gadget with some member of your programs data structures.

Note: The string is copied with strcpy(), you must assure that the destination points to enough memory.

See also

MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_Notify | Add a notification event handler to an object


MUIMASTER_NAME

Declaration

Source position: mui.pas line 139

const MUIMASTER_NAME: PChar = 'muimaster.library';


MUIMASTER_VLATEST

Declaration

Source position: mui.pas line 141

const MUIMASTER_VLATEST = 19;


MUIMASTER_VMIN

Declaration

Source position: mui.pas line 140

const MUIMASTER_VMIN = 11;


MUIMasterBase

Declaration

Source position: mui.pas line 136

var MUIMasterBase: PLibrary = Nil;


MUIMRI_RECTFILL

Declaration

Source position: mui.pas line 3210

const MUIMRI_RECTFILL = 1 shl 0;


MUIMRI_REFRESHMODE

Declaration

Source position: mui.pas line 3226

const MUIMRI_REFRESHMODE = 1 shl 3;


MUIMRI_THINFRAMES

Declaration

Source position: mui.pas line 3220

const MUIMRI_THINFRAMES = 1 shl 2;


MUIMRI_TRUECOLOR

Declaration

Source position: mui.pas line 3215

const MUIMRI_TRUECOLOR = 1 shl 1;


MUIO_BarTitle

Declaration

Source position: mui.pas line 271

const MUIO_BarTitle = 15;


MUIO_Button

Declaration

Source position: mui.pas line 258

const MUIO_Button = 2;


MUIO_Checkmark

Declaration

Source position: mui.pas line 259

const MUIO_Checkmark = 3;


MUIO_Cycle

Declaration

Source position: mui.pas line 260

const MUIO_Cycle = 4;


MUIO_HBar

Declaration

Source position: mui.pas line 267

const MUIO_HBar = 11;


MUIO_HSpace

Declaration

Source position: mui.pas line 265

const MUIO_HSpace = 9;


MUIO_Label

Declaration

Source position: mui.pas line 257

const MUIO_Label = 1;


MUIO_Label_Centered

Declaration

Source position: mui.pas line 279

const MUIO_Label_Centered = 1 shl 11;


MUIO_Label_DoubleFrame

Declaration

Source position: mui.pas line 277

const MUIO_Label_DoubleFrame = 1 shl 9;


MUIO_Label_FreeVert

Declaration

Source position: mui.pas line 280

const MUIO_Label_FreeVert = 1 shl 12;


MUIO_Label_LeftAligned

Declaration

Source position: mui.pas line 278

const MUIO_Label_LeftAligned = 1 shl 10;


MUIO_Label_SingleFrame

Declaration

Source position: mui.pas line 276

const MUIO_Label_SingleFrame = 1 shl 8;


MUIO_Menuitem

Declaration

Source position: mui.pas line 270

const MUIO_Menuitem = 14;


MUIO_Menuitem_CopyStrings

Declaration

Source position: mui.pas line 274

const MUIO_Menuitem_CopyStrings = 1 shl 30;


MUIO_MenustripNM

Declaration

Source position: mui.pas line 269

const MUIO_MenustripNM = 13;


MUIO_MenustripNM_CommandKeyCheck

Declaration

Source position: mui.pas line 282

const MUIO_MenustripNM_CommandKeyCheck = 1 shl 0;


MUIO_NumericButton

Declaration

Source position: mui.pas line 272

const MUIO_NumericButton = 16;


MUIO_PopButton

Declaration

Source position: mui.pas line 264

const MUIO_PopButton = 8;


MUIO_Radio

Declaration

Source position: mui.pas line 261

const MUIO_Radio = 5;


MUIO_Slider

Declaration

Source position: mui.pas line 262

const MUIO_Slider = 6;


MUIO_String

Declaration

Source position: mui.pas line 263

const MUIO_String = 7;


MUIO_VBar

Declaration

Source position: mui.pas line 268

const MUIO_VBar = 12;


MUIO_VSpace

Declaration

Source position: mui.pas line 266

const MUIO_VSpace = 10;


MUIP_BoopsiQuery

Declaration

Source position: mui.pas line 679

type MUIP_BoopsiQuery = tMUI_BoopsiQuery;


MUIP_Dirlist_ReRead

Declaration

Source position: mui.pas line 2201

type MUIP_Dirlist_ReRead = record

  MethodID: LongWord;

end;


MUIP_Pendisplay_SetColormap

Declaration

Source position: mui.pas line 2434

type MUIP_Pendisplay_SetColormap = record

  MethodID: LongWord;

  colormap: LongInt;

end;


MUIP_Pendisplay_SetMUIPen

Declaration

Source position: mui.pas line 2439

type MUIP_Pendisplay_SetMUIPen = record

  MethodID: LongWord;

  muipen: LongInt;

end;


MUIP_Pendisplay_SetRGB

Declaration

Source position: mui.pas line 2444

type MUIP_Pendisplay_SetRGB = record

  MethodID: LongWord;

  red: LongWord;

  green: LongWord;

  blue: LongWord;

end;


MUIV_Application_OCW_ScreenPage

Declaration

Source position: mui.pas line 475

const MUIV_Application_OCW_ScreenPage = 1 shl 1;


MUIV_Application_ReturnID_Quit

Declaration

Source position: mui.pas line 419

const MUIV_Application_ReturnID_Quit = - 1;


MUIV_ContextMenuBuild_Default

Declaration

Source position: mui.pas line 477

const MUIV_ContextMenuBuild_Default = $ffffffff;


MUIV_CreateBubble_DontHidePointer

Declaration

Source position: mui.pas line 473

const MUIV_CreateBubble_DontHidePointer = 1 shl 0;


MUIV_Cycle_Active_Next

Declaration

Source position: mui.pas line 2774

const MUIV_Cycle_Active_Next = - 1;


MUIV_Cycle_Active_Prev

Declaration

Source position: mui.pas line 2775

const MUIV_Cycle_Active_Prev = - 2;


MUIV_Dirlist_SortDirs_First

Declaration

Source position: mui.pas line 2242

const MUIV_Dirlist_SortDirs_First = 0;


MUIV_Dirlist_SortDirs_Last

Declaration

Source position: mui.pas line 2243

const MUIV_Dirlist_SortDirs_Last = 1;


MUIV_Dirlist_SortDirs_Mix

Declaration

Source position: mui.pas line 2244

const MUIV_Dirlist_SortDirs_Mix = 2;


MUIV_Dirlist_SortType_Date

Declaration

Source position: mui.pas line 2246

const MUIV_Dirlist_SortType_Date = 1;


MUIV_Dirlist_SortType_Name

Declaration

Source position: mui.pas line 2245

const MUIV_Dirlist_SortType_Name = 0;


MUIV_Dirlist_SortType_Size

Declaration

Source position: mui.pas line 2247

const MUIV_Dirlist_SortType_Size = 2;


MUIV_Dirlist_Status_Invalid

Declaration

Source position: mui.pas line 2248

const MUIV_Dirlist_Status_Invalid = 0;


MUIV_Dirlist_Status_Reading

Declaration

Source position: mui.pas line 2249

const MUIV_Dirlist_Status_Reading = 1;


MUIV_Dirlist_Status_Valid

Declaration

Source position: mui.pas line 2250

const MUIV_Dirlist_Status_Valid = 2;


MUIV_DragQuery_Accept

Declaration

Source position: mui.pas line 466

const MUIV_DragQuery_Accept = 1;


MUIV_DragQuery_Refuse

Declaration

Source position: mui.pas line 465

const MUIV_DragQuery_Refuse = 0;


MUIV_DragReport_Abort

Declaration

Source position: mui.pas line 468

const MUIV_DragReport_Abort = 0;


MUIV_DragReport_Continue

Declaration

Source position: mui.pas line 469

const MUIV_DragReport_Continue = 1;


MUIV_DragReport_Lock

Declaration

Source position: mui.pas line 470

const MUIV_DragReport_Lock = 2;


MUIV_DragReport_Refresh

Declaration

Source position: mui.pas line 471

const MUIV_DragReport_Refresh = 3;


MUIV_EveryTime

Declaration

Source position: mui.pas line 409

const MUIV_EveryTime = $49893131;


MUIV_Family_GetChild_First

Declaration

Source position: mui.pas line 481

const MUIV_Family_GetChild_First = 0;


MUIV_Family_GetChild_Iterate

Declaration

Source position: mui.pas line 485

const MUIV_Family_GetChild_Iterate = - 4;


MUIV_Family_GetChild_Last

Declaration

Source position: mui.pas line 482

const MUIV_Family_GetChild_Last = - 1;


MUIV_Family_GetChild_Next

Declaration

Source position: mui.pas line 483

const MUIV_Family_GetChild_Next = - 2;


MUIV_Family_GetChild_Previous

Declaration

Source position: mui.pas line 484

const MUIV_Family_GetChild_Previous = - 3;


MUIV_Font_Big

Declaration

Source position: mui.pas line 1629

const MUIV_Font_Big = - 6;


MUIV_Font_Button

Declaration

Source position: mui.pas line 1630

const MUIV_Font_Button = - 7;


MUIV_Font_Fixed

Declaration

Source position: mui.pas line 1627

const MUIV_Font_Fixed = - 4;


MUIV_Font_Gauge

Declaration

Source position: mui.pas line 1632

const MUIV_Font_Gauge = - 9;


MUIV_Font_Inherit

Declaration

Source position: mui.pas line 1623

const MUIV_Font_Inherit = 0;


MUIV_Font_List

Declaration

Source position: mui.pas line 1625

const MUIV_Font_List = - 2;


MUIV_Font_Menudisplay

Declaration

Source position: mui.pas line 1633

const MUIV_Font_Menudisplay = - 10;


MUIV_Font_Normal

Declaration

Source position: mui.pas line 1624

const MUIV_Font_Normal = - 1;


MUIV_Font_Slider

Declaration

Source position: mui.pas line 1631

const MUIV_Font_Slider = - 8;


MUIV_Font_Tiny

Declaration

Source position: mui.pas line 1626

const MUIV_Font_Tiny = - 3;


MUIV_Font_Title

Declaration

Source position: mui.pas line 1628

const MUIV_Font_Title = - 5;


MUIV_Frame_Button

Declaration

Source position: mui.pas line 1635

const MUIV_Frame_Button = 1;


MUIV_Frame_Count

Declaration

Source position: mui.pas line 1656

const MUIV_Frame_Count = 22;


MUIV_Frame_Gauge

Declaration

Source position: mui.pas line 1642

const MUIV_Frame_Gauge = 8;


MUIV_Frame_GaugeInner

Declaration

Source position: mui.pas line 1648

const MUIV_Frame_GaugeInner = 14;


MUIV_Frame_Group

Declaration

Source position: mui.pas line 1643

const MUIV_Frame_Group = 9;


MUIV_Frame_ImageButton

Declaration

Source position: mui.pas line 1636

const MUIV_Frame_ImageButton = 2;


MUIV_Frame_InputList

Declaration

Source position: mui.pas line 1640

const MUIV_Frame_InputList = 6;


MUIV_Frame_Menudisplay

Declaration

Source position: mui.pas line 1649

const MUIV_Frame_Menudisplay = 15;


MUIV_Frame_MenudisplayMenu

Declaration

Source position: mui.pas line 1650

const MUIV_Frame_MenudisplayMenu = 16;


MUIV_Frame_None

Declaration

Source position: mui.pas line 1634

const MUIV_Frame_None = 0;


MUIV_Frame_Page

Declaration

Source position: mui.pas line 1654

const MUIV_Frame_Page = 20;


MUIV_Frame_PopUp

Declaration

Source position: mui.pas line 1644

const MUIV_Frame_PopUp = 10;


MUIV_Frame_Prop

Declaration

Source position: mui.pas line 1641

const MUIV_Frame_Prop = 7;


MUIV_Frame_PropKnob

Declaration

Source position: mui.pas line 1651

const MUIV_Frame_PropKnob = 17;


MUIV_Frame_ReadList

Declaration

Source position: mui.pas line 1639

const MUIV_Frame_ReadList = 5;


MUIV_Frame_Register

Declaration

Source position: mui.pas line 1655

const MUIV_Frame_Register = 21;


MUIV_Frame_Requester

Declaration

Source position: mui.pas line 1653

const MUIV_Frame_Requester = 19;


MUIV_Frame_Slider

Declaration

Source position: mui.pas line 1646

const MUIV_Frame_Slider = 12;


MUIV_Frame_SliderKnob

Declaration

Source position: mui.pas line 1647

const MUIV_Frame_SliderKnob = 13;


MUIV_Frame_String

Declaration

Source position: mui.pas line 1638

const MUIV_Frame_String = 4;


MUIV_Frame_Text

Declaration

Source position: mui.pas line 1637

const MUIV_Frame_Text = 3;


MUIV_Frame_Virtual

Declaration

Source position: mui.pas line 1645

const MUIV_Frame_Virtual = 11;


MUIV_Frame_Window

Declaration

Source position: mui.pas line 1652

const MUIV_Frame_Window = 18;


MUIV_Group_ActivePage_Advance

Declaration

Source position: mui.pas line 2540

const MUIV_Group_ActivePage_Advance = - 4;


MUIV_Group_ActivePage_First

Declaration

Source position: mui.pas line 2536

const MUIV_Group_ActivePage_First = 0;


MUIV_Group_ActivePage_Last

Declaration

Source position: mui.pas line 2537

const MUIV_Group_ActivePage_Last = - 1;


MUIV_Group_ActivePage_Next

Declaration

Source position: mui.pas line 2539

const MUIV_Group_ActivePage_Next = - 3;


MUIV_Group_ActivePage_Prev

Declaration

Source position: mui.pas line 2538

const MUIV_Group_ActivePage_Prev = - 2;


MUIV_Group_GetChild_First

Declaration

Source position: mui.pas line 487

const MUIV_Group_GetChild_First = MUIV_Family_GetChild_First;


MUIV_Group_GetChild_Iterate

Declaration

Source position: mui.pas line 491

const MUIV_Group_GetChild_Iterate = MUIV_Family_GetChild_Iterate;


MUIV_Group_GetChild_Last

Declaration

Source position: mui.pas line 488

const MUIV_Group_GetChild_Last = MUIV_Family_GetChild_Last;


MUIV_Group_GetChild_Next

Declaration

Source position: mui.pas line 489

const MUIV_Group_GetChild_Next = MUIV_Family_GetChild_Next;


MUIV_Group_GetChild_Previous

Declaration

Source position: mui.pas line 490

const MUIV_Group_GetChild_Previous = MUIV_Family_GetChild_Previous;


MUIV_Imageadjust_Type_All

Declaration

Source position: mui.pas line 2638

const MUIV_Imageadjust_Type_All = 0;


MUIV_Imageadjust_Type_Background

Declaration

Source position: mui.pas line 2640

const MUIV_Imageadjust_Type_Background = 2;


MUIV_Imageadjust_Type_Image

Declaration

Source position: mui.pas line 2639

const MUIV_Imageadjust_Type_Image = 1;


MUIV_Imageadjust_Type_Pen

Declaration

Source position: mui.pas line 2641

const MUIV_Imageadjust_Type_Pen = 3;


MUIV_InputMode_Immediate

Declaration

Source position: mui.pas line 1659

const MUIV_InputMode_Immediate = 2;


MUIV_InputMode_None

Declaration

Source position: mui.pas line 1657

const MUIV_InputMode_None = 0;


MUIV_InputMode_RelVerify

Declaration

Source position: mui.pas line 1658

const MUIV_InputMode_RelVerify = 1;


MUIV_InputMode_Toggle

Declaration

Source position: mui.pas line 1660

const MUIV_InputMode_Toggle = 3;


MUIV_List_Active_Bottom

Declaration

Source position: mui.pas line 2140

const MUIV_List_Active_Bottom = - 3;


MUIV_List_Active_Down

Declaration

Source position: mui.pas line 2142

const MUIV_List_Active_Down = - 5;


MUIV_List_Active_Off

Declaration

Source position: mui.pas line 2138

const MUIV_List_Active_Off = - 1;


MUIV_List_Active_PageDown

Declaration

Source position: mui.pas line 2144

const MUIV_List_Active_PageDown = - 7;


MUIV_List_Active_PageUp

Declaration

Source position: mui.pas line 2143

const MUIV_List_Active_PageUp = - 6;


MUIV_List_Active_Top

Declaration

Source position: mui.pas line 2139

const MUIV_List_Active_Top = - 2;


MUIV_List_Active_Up

Declaration

Source position: mui.pas line 2141

const MUIV_List_Active_Up = - 4;


MUIV_List_ConstructHook_String

Declaration

Source position: mui.pas line 2145

const MUIV_List_ConstructHook_String = - 1;


MUIV_List_CopyHook_String

Declaration

Source position: mui.pas line 2146

const MUIV_List_CopyHook_String = - 1;


MUIV_List_CursorType_Bar

Declaration

Source position: mui.pas line 2148

const MUIV_List_CursorType_Bar = 1;


MUIV_List_CursorType_None

Declaration

Source position: mui.pas line 2147

const MUIV_List_CursorType_None = 0;


MUIV_List_CursorType_Rect

Declaration

Source position: mui.pas line 2149

const MUIV_List_CursorType_Rect = 2;


MUIV_List_DestructHook_String

Declaration

Source position: mui.pas line 2150

const MUIV_List_DestructHook_String = - 1;


MUIV_List_EditEntry_Active

Declaration

Source position: mui.pas line 437

const MUIV_List_EditEntry_Active = - 1;


MUIV_List_Exchange_Active

Declaration

Source position: mui.pas line 451

const MUIV_List_Exchange_Active = - 1;


MUIV_List_Exchange_Bottom

Declaration

Source position: mui.pas line 452

const MUIV_List_Exchange_Bottom = - 2;


MUIV_List_Exchange_Next

Declaration

Source position: mui.pas line 453

const MUIV_List_Exchange_Next = - 3;


MUIV_List_Exchange_Previous

Declaration

Source position: mui.pas line 454

const MUIV_List_Exchange_Previous = - 4;


MUIV_List_Exchange_Top

Declaration

Source position: mui.pas line 450

const MUIV_List_Exchange_Top = 0;


MUIV_List_GetEntry_Active

Declaration

Source position: mui.pas line 436

const MUIV_List_GetEntry_Active = - 1;


MUIV_List_Insert_Active

Declaration

Source position: mui.pas line 422

const MUIV_List_Insert_Active = - 1;


MUIV_List_Insert_Bottom

Declaration

Source position: mui.pas line 424

const MUIV_List_Insert_Bottom = - 3;


MUIV_List_Insert_Sorted

Declaration

Source position: mui.pas line 423

const MUIV_List_Insert_Sorted = - 2;


MUIV_List_Insert_Top

Declaration

Source position: mui.pas line 421

const MUIV_List_Insert_Top = 0;


MUIV_List_Jump_Active

Declaration

Source position: mui.pas line 457

const MUIV_List_Jump_Active = - 1;


MUIV_List_Jump_Bottom

Declaration

Source position: mui.pas line 458

const MUIV_List_Jump_Bottom = - 2;


MUIV_List_Jump_Down

Declaration

Source position: mui.pas line 460

const MUIV_List_Jump_Down = - 3;


MUIV_List_Jump_Top

Declaration

Source position: mui.pas line 456

const MUIV_List_Jump_Top = 0;


MUIV_List_Jump_Up

Declaration

Source position: mui.pas line 459

const MUIV_List_Jump_Up = - 4;


MUIV_List_Move_Active

Declaration

Source position: mui.pas line 445

const MUIV_List_Move_Active = - 1;


MUIV_List_Move_Bottom

Declaration

Source position: mui.pas line 446

const MUIV_List_Move_Bottom = - 2;


MUIV_List_Move_Next

Declaration

Source position: mui.pas line 447

const MUIV_List_Move_Next = - 3;


MUIV_List_Move_Previous

Declaration

Source position: mui.pas line 448

const MUIV_List_Move_Previous = - 4;


MUIV_List_Move_Top

Declaration

Source position: mui.pas line 444

const MUIV_List_Move_Top = 0;


MUIV_List_NextSelected_End

Declaration

Source position: mui.pas line 463

const MUIV_List_NextSelected_End = - 1;


MUIV_List_NextSelected_Start

Declaration

Source position: mui.pas line 462

const MUIV_List_NextSelected_Start = - 1;


MUIV_List_Redraw_Active

Declaration

Source position: mui.pas line 441

const MUIV_List_Redraw_Active = - 1;


MUIV_List_Redraw_All

Declaration

Source position: mui.pas line 442

const MUIV_List_Redraw_All = - 2;


MUIV_List_Remove_Active

Declaration

Source position: mui.pas line 427

const MUIV_List_Remove_Active = - 1;


MUIV_List_Remove_First

Declaration

Source position: mui.pas line 426

const MUIV_List_Remove_First = 0;


MUIV_List_Remove_Last

Declaration

Source position: mui.pas line 428

const MUIV_List_Remove_Last = - 2;


MUIV_List_Remove_Selected

Declaration

Source position: mui.pas line 429

const MUIV_List_Remove_Selected = - 3;


MUIV_List_Select_Active

Declaration

Source position: mui.pas line 438

const MUIV_List_Select_Active = - 1;


MUIV_List_Select_All

Declaration

Source position: mui.pas line 439

const MUIV_List_Select_All = - 2;


MUIV_List_Select_Ask

Declaration

Source position: mui.pas line 434

const MUIV_List_Select_Ask = 3;


MUIV_List_Select_Off

Declaration

Source position: mui.pas line 431

const MUIV_List_Select_Off = 0;


MUIV_List_Select_On

Declaration

Source position: mui.pas line 432

const MUIV_List_Select_On = 1;


MUIV_List_Select_Toggle

Declaration

Source position: mui.pas line 433

const MUIV_List_Select_Toggle = 2;


MUIV_Listview_DragType_Immediate

Declaration

Source position: mui.pas line 2735

const MUIV_Listview_DragType_Immediate = 1;


MUIV_Listview_DragType_None

Declaration

Source position: mui.pas line 2734

const MUIV_Listview_DragType_None = 0;


MUIV_Listview_MultiSelect_Always

Declaration

Source position: mui.pas line 2739

const MUIV_Listview_MultiSelect_Always = 3;


MUIV_Listview_MultiSelect_Default

Declaration

Source position: mui.pas line 2737

const MUIV_Listview_MultiSelect_Default = 1;


MUIV_Listview_MultiSelect_None

Declaration

Source position: mui.pas line 2736

const MUIV_Listview_MultiSelect_None = 0;


MUIV_Listview_MultiSelect_Shifted

Declaration

Source position: mui.pas line 2738

const MUIV_Listview_MultiSelect_Shifted = 2;


MUIV_Listview_ScrollerPos_Default

Declaration

Source position: mui.pas line 2740

const MUIV_Listview_ScrollerPos_Default = 0;


MUIV_Listview_ScrollerPos_Left

Declaration

Source position: mui.pas line 2741

const MUIV_Listview_ScrollerPos_Left = 1;


MUIV_Listview_ScrollerPos_None

Declaration

Source position: mui.pas line 2743

const MUIV_Listview_ScrollerPos_None = 3;


MUIV_Listview_ScrollerPos_Right

Declaration

Source position: mui.pas line 2742

const MUIV_Listview_ScrollerPos_Right = 2;


MUIV_Menuitem_Shortcut_Check

Declaration

Source position: mui.pas line 978

const MUIV_Menuitem_Shortcut_Check = - 1;


MUIV_Notify_Application

Declaration

Source position: mui.pas line 413

const MUIV_Notify_Application = 3;


MUIV_Notify_Parent

Declaration

Source position: mui.pas line 414

const MUIV_Notify_Parent = 4;


MUIV_Notify_ParentParent

Declaration

Source position: mui.pas line 415

const MUIV_Notify_ParentParent = 5;


MUIV_Notify_ParentParentParent

Declaration

Source position: mui.pas line 416

const MUIV_Notify_ParentParentParent = 6;


MUIV_Notify_Self

Declaration

Source position: mui.pas line 411

const MUIV_Notify_Self = 1;


MUIV_Notify_Window

Declaration

Source position: mui.pas line 412

const MUIV_Notify_Window = 2;


MUIV_NotTriggerValue

Declaration

Source position: mui.pas line 408

const MUIV_NotTriggerValue = $49893133;


MUIV_Palette_Entry_End

Declaration

Source position: mui.pas line 529

const MUIV_Palette_Entry_End = - 1;


MUIV_Prop_UseWinBorder_Bottom

Declaration

Source position: mui.pas line 1898

const MUIV_Prop_UseWinBorder_Bottom = 3;


MUIV_Prop_UseWinBorder_Left

Declaration

Source position: mui.pas line 1896

const MUIV_Prop_UseWinBorder_Left = 1;


MUIV_Prop_UseWinBorder_None

Declaration

Source position: mui.pas line 1895

const MUIV_Prop_UseWinBorder_None = 0;


MUIV_Prop_UseWinBorder_Right

Declaration

Source position: mui.pas line 1897

const MUIV_Prop_UseWinBorder_Right = 2;


MUIV_Scrollbar_Type_Bottom

Declaration

Source position: mui.pas line 2702

const MUIV_Scrollbar_Type_Bottom = 1;


MUIV_Scrollbar_Type_Default

Declaration

Source position: mui.pas line 2701

const MUIV_Scrollbar_Type_Default = 0;


MUIV_Scrollbar_Type_Sym

Declaration

Source position: mui.pas line 2704

const MUIV_Scrollbar_Type_Sym = 3;


MUIV_Scrollbar_Type_Top

Declaration

Source position: mui.pas line 2703

const MUIV_Scrollbar_Type_Top = 2;


MUIV_String_Format_Center

Declaration

Source position: mui.pas line 1833

const MUIV_String_Format_Center = 1;


MUIV_String_Format_Left

Declaration

Source position: mui.pas line 1832

const MUIV_String_Format_Left = 0;


MUIV_String_Format_Right

Declaration

Source position: mui.pas line 1834

const MUIV_String_Format_Right = 2;


MUIV_Text_Shorten_Cutoff

Declaration

Source position: mui.pas line 1789

const MUIV_Text_Shorten_Cutoff = 1;


MUIV_Text_Shorten_Hide

Declaration

Source position: mui.pas line 1790

const MUIV_Text_Shorten_Hide = 2;


MUIV_Text_Shorten_Nothing

Declaration

Source position: mui.pas line 1788

const MUIV_Text_Shorten_Nothing = 0;


MUIV_TriggerValue

Declaration

Source position: mui.pas line 407

const MUIV_TriggerValue = $49893131;


MUIV_Window_ActiveObject_Down

Declaration

Source position: mui.pas line 1315

const MUIV_Window_ActiveObject_Down = - 6;


MUIV_Window_ActiveObject_Left

Declaration

Source position: mui.pas line 1312

const MUIV_Window_ActiveObject_Left = - 3;


MUIV_Window_ActiveObject_Next

Declaration

Source position: mui.pas line 1310

const MUIV_Window_ActiveObject_Next = - 1;


MUIV_Window_ActiveObject_None

Declaration

Source position: mui.pas line 1309

const MUIV_Window_ActiveObject_None = 0;


MUIV_Window_ActiveObject_Prev

Declaration

Source position: mui.pas line 1311

const MUIV_Window_ActiveObject_Prev = - 2;


MUIV_Window_ActiveObject_Right

Declaration

Source position: mui.pas line 1313

const MUIV_Window_ActiveObject_Right = - 4;


MUIV_Window_ActiveObject_Up

Declaration

Source position: mui.pas line 1314

const MUIV_Window_ActiveObject_Up = - 5;


MUIV_Window_AltHeight_Scaled

Declaration

Source position: mui.pas line 1320

const MUIV_Window_AltHeight_Scaled = - 1000;


MUIV_Window_AltLeftEdge_Centered

Declaration

Source position: mui.pas line 1321

const MUIV_Window_AltLeftEdge_Centered = - 1;


MUIV_Window_AltLeftEdge_Moused

Declaration

Source position: mui.pas line 1322

const MUIV_Window_AltLeftEdge_Moused = - 2;


MUIV_Window_AltLeftEdge_NoChange

Declaration

Source position: mui.pas line 1323

const MUIV_Window_AltLeftEdge_NoChange = - 1000;


MUIV_Window_AltTopEdge_Centered

Declaration

Source position: mui.pas line 1324

const MUIV_Window_AltTopEdge_Centered = - 1;


MUIV_Window_AltTopEdge_Moused

Declaration

Source position: mui.pas line 1325

const MUIV_Window_AltTopEdge_Moused = - 2;


MUIV_Window_AltTopEdge_NoChange

Declaration

Source position: mui.pas line 1327

const MUIV_Window_AltTopEdge_NoChange = - 1000;


MUIV_Window_AltWidth_Scaled

Declaration

Source position: mui.pas line 1331

const MUIV_Window_AltWidth_Scaled = - 1000;


MUIV_Window_Height_Default

Declaration

Source position: mui.pas line 1336

const MUIV_Window_Height_Default = - 1001;


MUIV_Window_Height_Scaled

Declaration

Source position: mui.pas line 1335

const MUIV_Window_Height_Scaled = - 1000;


MUIV_Window_LeftEdge_Centered

Declaration

Source position: mui.pas line 1337

const MUIV_Window_LeftEdge_Centered = - 1;


MUIV_Window_LeftEdge_Moused

Declaration

Source position: mui.pas line 1338

const MUIV_Window_LeftEdge_Moused = - 2;


MUIV_Window_TopEdge_Centered

Declaration

Source position: mui.pas line 1340

const MUIV_Window_TopEdge_Centered = - 1;


MUIV_Window_TopEdge_Moused

Declaration

Source position: mui.pas line 1341

const MUIV_Window_TopEdge_Moused = - 2;


MUIV_Window_Width_Default

Declaration

Source position: mui.pas line 1348

const MUIV_Window_Width_Default = - 1001;


MUIV_Window_Width_Scaled

Declaration

Source position: mui.pas line 1347

const MUIV_Window_Width_Scaled = - 1000;


MUIX_B

Declaration

Source position: mui.pas line 504

const MUIX_B = #27 + 'b';


MUIX_C

Declaration

Source position: mui.pas line 500

const MUIX_C = #27 + 'c';


MUIX_I

Declaration

Source position: mui.pas line 505

const MUIX_I = #27 + 'i';


MUIX_L

Declaration

Source position: mui.pas line 501

const MUIX_L = #27 + 'l';


MUIX_N

Declaration

Source position: mui.pas line 503

const MUIX_N = #27 + 'n';


MUIX_PH

Declaration

Source position: mui.pas line 509

const MUIX_PH = #27 + '8';


MUIX_PT

Declaration

Source position: mui.pas line 508

const MUIX_PT = #27 + '2';


MUIX_R

Declaration

Source position: mui.pas line 499

const MUIX_R = #27 + 'r';


MUIX_U

Declaration

Source position: mui.pas line 506

const MUIX_U = #27 + 'u';


p__dummyXFC2__

Declaration

Source position: mui.pas line 3235

type p__dummyXFC2__ = ^t__dummyXFC2__;


plongword

Declaration

Source position: mui.pas line 167

type plongword = ^LongWord;


pMUI_AreaData

Declaration

Source position: mui.pas line 3168

type pMUI_AreaData = ^tMUI_AreaData;


pMUI_BoopsiQuery

Declaration

Source position: mui.pas line 675

type pMUI_BoopsiQuery = ^tMUI_BoopsiQuery;


pMUI_Command

Declaration

Source position: mui.pas line 297

type pMUI_Command = ^tMUI_Command;


pMUI_CustomClass

Declaration

Source position: mui.pas line 3307

type pMUI_CustomClass = ^tMUI_CustomClass;


pMUI_EventHandlerNode

Declaration

Source position: mui.pas line 579

type pMUI_EventHandlerNode = ^tMUI_EventHandlerNode;


pMUI_GlobalInfo

Declaration

Source position: mui.pas line 3096

type pMUI_GlobalInfo = ^tMUI_GlobalInfo;


pMUI_InputHandlerNode

Declaration

Source position: mui.pas line 550

type pMUI_InputHandlerNode = ^tMUI_InputHandlerNode;


pMUI_LayoutMsg

Declaration

Source position: mui.pas line 3133

type pMUI_LayoutMsg = ^tMUI_LayoutMsg;


pMUI_List_TestPos_Result

Declaration

Source position: mui.pas line 607

type pMUI_List_TestPos_Result = ^tMUI_List_TestPos_Result;


pMUI_MinMax

Declaration

Source position: mui.pas line 1409

type pMUI_MinMax = ^tMUI_MinMax;


pMUI_NotifyData

Declaration

Source position: mui.pas line 3108

type pMUI_NotifyData = ^tMUI_NotifyData;


pMUI_Palette_Entry

Declaration

Source position: mui.pas line 526

type pMUI_Palette_Entry = ^tMUI_Palette_Entry;


pMUI_PenSpec

Declaration

Source position: mui.pas line 172

type pMUI_PenSpec = ^tMUI_PenSpec;


pMUI_PubScreenDesc

Declaration

Source position: mui.pas line 242

type pMUI_PubScreenDesc = ^tMUI_PubScreenDesc;


pMUI_RenderInfo

Declaration

Source position: mui.pas line 660

type pMUI_RenderInfo = ^tMUI_RenderInfo;


pMUI_RGBColor

Declaration

Source position: mui.pas line 212

type pMUI_RGBColor = ^tMUI_RGBcolor;


pMUIP_Application_AboutMUI

Declaration

Source position: mui.pas line 1011

type pMUIP_Application_AboutMUI = ^tMUIP_Application_AboutMUI;


pMUIP_Application_AddInputHandler

Declaration

Source position: mui.pas line 1017

type pMUIP_Application_AddInputHandler = ^tMUIP_Application_AddInputHandler;


pMUIP_Application_BuildSettingsPanel

Declaration

Source position: mui.pas line 1023

type pMUIP_Application_BuildSettingsPanel = ^tMUIP_Application_BuildSettingsPanel;


pMUIP_Application_CheckRefresh

Declaration

Source position: mui.pas line 1028

type pMUIP_Application_CheckRefresh = ^tMUIP_Application_CheckRefresh;


pMUIP_Application_DefaultConfigItem

Declaration

Source position: mui.pas line 1034

type pMUIP_Application_DefaultConfigItem = ^tMUIP_Application_DefaultConfigItem;


pMUIP_Application_GetMenuCheck

Declaration

Source position: mui.pas line 1040

type pMUIP_Application_GetMenuCheck = ^tMUIP_Application_GetMenuCheck;


pMUIP_Application_GetMenuState

Declaration

Source position: mui.pas line 1046

type pMUIP_Application_GetMenuState = ^tMUIP_Application_GetMenuState;


pMUIP_Application_Input

Declaration

Source position: mui.pas line 1052

type pMUIP_Application_Input = ^tMUIP_Application_Input;


pMUIP_Application_InputBuffered

Declaration

Source position: mui.pas line 1057

type pMUIP_Application_InputBuffered = ^tMUIP_Application_InputBuffered;


pMUIP_Application_NewInput

Declaration

Source position: mui.pas line 1068

type pMUIP_Application_NewInput = ^tMUIP_Application_NewInput;


pMUIP_Application_OpenConfigWindow

Declaration

Source position: mui.pas line 1074

type pMUIP_Application_OpenConfigWindow = ^tMUIP_Application_OpenConfigWindow;


pMUIP_Application_PushMethod

Declaration

Source position: mui.pas line 1081

type pMUIP_Application_PushMethod = ^tMUIP_Application_PushMethod;


pMUIP_Application_RemInputHandler

Declaration

Source position: mui.pas line 1087

type pMUIP_Application_RemInputHandler = ^tMUIP_Application_RemInputHandler;


pMUIP_Application_ReturnID

Declaration

Source position: mui.pas line 1093

type pMUIP_Application_ReturnID = ^tMUIP_Application_ReturnID;


pMUIP_Application_SetConfigItem

Declaration

Source position: mui.pas line 1105

type pMUIP_Application_SetConfigItem = ^tMUIP_Application_SetConfigItem;


pMUIP_Application_SetMenuCheck

Declaration

Source position: mui.pas line 1112

type pMUIP_Application_SetMenuCheck = ^tMUIP_Application_SetMenuCheck;


pMUIP_Application_SetMenuState

Declaration

Source position: mui.pas line 1119

type pMUIP_Application_SetMenuState = ^tMUIP_Application_SetMenuState;


pMUIP_Application_ShowHelp

Declaration

Source position: mui.pas line 1128

type pMUIP_Application_ShowHelp = ^tMUIP_Application_ShowHelp;


pMUIP_AskMinMax

Declaration

Source position: mui.pas line 1415

type pMUIP_AskMinMax = ^tMUIP_AskMinMax;


pMUIP_CallHook

Declaration

Source position: mui.pas line 722

type pMUIP_CallHook = ^tMUIP_CallHook;


pMUIP_Cleanup

Declaration

Source position: mui.pas line 1420

type pMUIP_Cleanup = ^tMUIP_Cleanup;


pMUIP_ContextMenuAdd

Declaration

Source position: mui.pas line 1430

type pMUIP_ContextMenuAdd = ^tMUIP_ContextMenuAdd;


pMUIP_ContextMenuBuild

Declaration

Source position: mui.pas line 1437

type pMUIP_ContextMenuBuild = ^tMUIP_ContextMenuBuild;


pMUIP_ContextMenuChoice

Declaration

Source position: mui.pas line 1443

type pMUIP_ContextMenuChoice = ^tMUIP_ContextMenuChoice;


pMUIP_CreateBubble

Declaration

Source position: mui.pas line 1452

type pMUIP_CreateBubble = ^tMUIP_CreateBubble;


pMUIP_CreateShortHelp

Declaration

Source position: mui.pas line 1459

type pMUIP_CreateShortHelp = ^tMUIP_CreateShortHelp;


pMUIP_Dataspace_Add

Declaration

Source position: mui.pas line 3018

type pMUIP_Dataspace_Add = ^tMUIP_Dataspace_Add;


pMUIP_Dataspace_Clear

Declaration

Source position: mui.pas line 3023

type pMUIP_Dataspace_Clear = ^tMUIP_Dataspace_Clear;


pMUIP_Dataspace_Find

Declaration

Source position: mui.pas line 3029

type pMUIP_Dataspace_Find = ^tMUIP_Dataspace_Find;


pMUIP_Dataspace_Merge

Declaration

Source position: mui.pas line 3035

type pMUIP_Dataspace_Merge = ^tMUIP_Dataspace_Merge;


pMUIP_Dataspace_ReadIFF

Declaration

Source position: mui.pas line 3041

type pMUIP_Dataspace_ReadIFF = ^tMUIP_Dataspace_ReadIFF;


pMUIP_Dataspace_Remove

Declaration

Source position: mui.pas line 3047

type pMUIP_Dataspace_Remove = ^tMUIP_Dataspace_Remove;


pMUIP_Dataspace_WriteIFF

Declaration

Source position: mui.pas line 3055

type pMUIP_Dataspace_WriteIFF = ^tMUIP_Dataspace_WriteIFF;


pMUIP_DeleteBubble

Declaration

Source position: mui.pas line 1465

type pMUIP_DeleteBubble = ^tMUIP_DeleteBubble;


pMUIP_DeleteShortHelp

Declaration

Source position: mui.pas line 1471

type pMUIP_DeleteShortHelp = ^tMUIP_DeleteShortHelp;


pMUIP_DoDrag

Declaration

Source position: mui.pas line 1479

type pMUIP_DoDrag = ^tMUIP_DoDrag;


pMUIP_DragBegin

Declaration

Source position: mui.pas line 1485

type pMUIP_DragBegin = ^tMUIP_DragBegin;


pMUIP_DragDrop

Declaration

Source position: mui.pas line 1493

type pMUIP_DragDrop = ^tMUIP_DragDrop;


pMUIP_DragFinish

Declaration

Source position: mui.pas line 1499

type pMUIP_DragFinish = ^tMUIP_DragFinish;


pMUIP_DragQuery

Declaration

Source position: mui.pas line 1505

type pMUIP_DragQuery = ^tMUIP_DragQuery;


pMUIP_DragReport

Declaration

Source position: mui.pas line 1514

type pMUIP_DragReport = ^tMUIP_DragReport;


pMUIP_Draw

Declaration

Source position: mui.pas line 1520

type pMUIP_Draw = ^tMUIP_Draw;


pMUIP_DrawBackground

Declaration

Source position: mui.pas line 1532

type pMUIP_DrawBackground = ^tMUIP_DrawBackground;


pMUIP_Export

Declaration

Source position: mui.pas line 728

type pMUIP_Export = ^tMUIP_Export;


pMUIP_Family_AddHead

Declaration

Source position: mui.pas line 876

type pMUIP_Family_AddHead = ^tMUIP_Family_AddHead;


pMUIP_Family_AddTail

Declaration

Source position: mui.pas line 882

type pMUIP_Family_AddTail = ^tMUIP_Family_AddTail;


pMUIP_Family_Insert

Declaration

Source position: mui.pas line 889

type pMUIP_Family_Insert = ^tMUIP_Family_Insert;


pMUIP_Family_Remove

Declaration

Source position: mui.pas line 895

type pMUIP_Family_Remove = ^tMUIP_Family_Remove;


pMUIP_Family_Sort

Declaration

Source position: mui.pas line 901

type pMUIP_Family_Sort = ^tMUIP_Family_Sort;


pMUIP_Family_Transfer

Declaration

Source position: mui.pas line 907

type pMUIP_Family_Transfer = ^tMUIP_Family_Transfer;


pMUIP_FindUData

Declaration

Source position: mui.pas line 734

type pMUIP_FindUData = ^tMUIP_FindUData;


pMUIP_GetConfigItem

Declaration

Source position: mui.pas line 741

type pMUIP_GetConfigItem = ^tMUIP_GetConfigItem;


pMUIP_GetUData

Declaration

Source position: mui.pas line 749

type pMUIP_GetUData = ^tMUIP_GetUData;


pMUIP_Group_ExitChange

Declaration

Source position: mui.pas line 2492

type pMUIP_Group_ExitChange = ^tMUIP_Group_ExitChange;


pMUIP_Group_InitChange

Declaration

Source position: mui.pas line 2497

type pMUIP_Group_InitChange = ^tMUIP_Group_InitChange;


pMUIP_Group_Sort

Declaration

Source position: mui.pas line 2503

type pMUIP_Group_Sort = ^tMUIP_Group_Sort;


pMUIP_HandleEvent

Declaration

Source position: mui.pas line 1539

type pMUIP_HandleEvent = ^tMUIP_HandleEvent;


pMUIP_HandleInput

Declaration

Source position: mui.pas line 1546

type pMUIP_HandleInput = ^tMUIP_HandleInput;


pMUIP_Hide

Declaration

Source position: mui.pas line 1551

type pMUIP_Hide = ^tMUIP_Hide;


pMUIP_Import

Declaration

Source position: mui.pas line 755

type pMUIP_Import = ^tMUIP_Import;


pMUIP_KillNotify

Declaration

Source position: mui.pas line 761

type pMUIP_KillNotify = ^tMUIP_KillNotify;


pMUIP_KillNotifyObj

Declaration

Source position: mui.pas line 768

type pMUIP_KillNotifyObj = ^tMUIP_KillNotifyObj;


pMUIP_List_Clear

Declaration

Source position: mui.pas line 1991

type pMUIP_List_Clear = ^tMUIP_List_Clear;


pMUIP_List_CreateImage

Declaration

Source position: mui.pas line 1998

type pMUIP_List_CreateImage = ^tMUIP_List_CreateImage;


pMUIP_List_DeleteImage

Declaration

Source position: mui.pas line 2004

type pMUIP_List_DeleteImage = ^tMUIP_List_DeleteImage;


pMUIP_List_Exchange

Declaration

Source position: mui.pas line 2011

type pMUIP_List_Exchange = ^tMUIP_List_Exchange;


pMUIP_List_GetEntry

Declaration

Source position: mui.pas line 2018

type pMUIP_List_GetEntry = ^tMUIP_List_GetEntry;


pMUIP_List_Insert

Declaration

Source position: mui.pas line 2026

type pMUIP_List_Insert = ^tMUIP_List_Insert;


pMUIP_List_InsertSingle

Declaration

Source position: mui.pas line 2033

type pMUIP_List_InsertSingle = ^tMUIP_List_InsertSingle;


pMUIP_List_Jump

Declaration

Source position: mui.pas line 2039

type pMUIP_List_Jump = ^tMUIP_List_Jump;


pMUIP_List_Move

Declaration

Source position: mui.pas line 2046

type pMUIP_List_Move = ^tMUIP_List_Move;


pMUIP_List_NextSelected

Declaration

Source position: mui.pas line 2052

type pMUIP_List_NextSelected = ^tMUIP_List_NextSelected;


pMUIP_List_Redraw

Declaration

Source position: mui.pas line 2058

type pMUIP_List_Redraw = ^tMUIP_List_Redraw;


pMUIP_List_Remove

Declaration

Source position: mui.pas line 2064

type pMUIP_List_Remove = ^tMUIP_List_Remove;


pMUIP_List_Select

Declaration

Source position: mui.pas line 2072

type pMUIP_List_Select = ^tMUIP_List_Select;


pMUIP_List_Sort

Declaration

Source position: mui.pas line 2077

type pMUIP_List_Sort = ^tMUIP_List_Sort;


pMUIP_List_TestPos

Declaration

Source position: mui.pas line 2085

type pMUIP_List_TestPos = ^tMUIP_List_TestPos;


pMUIP_Menustrip_ExitChange

Declaration

Source position: mui.pas line 931

type pMUIP_Menustrip_ExitChange = ^tMUIP_Menustrip_ExitChange;


pMUIP_Menustrip_InitChange

Declaration

Source position: mui.pas line 936

type pMUIP_Menustrip_InitChange = ^tMUIP_Menustrip_InitChange;


pMUIP_MultiSet

Declaration

Source position: mui.pas line 776

type pMUIP_MultiSet = ^tMUIP_MultiSet;


pMUIP_NoNotifySet

Declaration

Source position: mui.pas line 784

type pMUIP_NoNotifySet = ^tMUIP_NoNotifySet;


pMUIP_Notify

Declaration

Source position: mui.pas line 793

type pMUIP_Notify = ^tMUIP_Notify;


pMUIP_Numeric_Decrease

Declaration

Source position: mui.pas line 2279

type pMUIP_Numeric_Decrease = ^tMUIP_Numeric_Decrease;


pMUIP_Numeric_Increase

Declaration

Source position: mui.pas line 2285

type pMUIP_Numeric_Increase = ^tMUIP_Numeric_Increase;


pMUIP_Numeric_ScaleToValue

Declaration

Source position: mui.pas line 2293

type pMUIP_Numeric_ScaleToValue = ^tMUIP_Numeric_ScaleToValue;


pMUIP_Numeric_SetDefault

Declaration

Source position: mui.pas line 2298

type pMUIP_Numeric_SetDefault = ^tMUIP_Numeric_SetDefault;


pMUIP_Numeric_Stringify

Declaration

Source position: mui.pas line 2304

type pMUIP_Numeric_Stringify = ^tMUIP_Numeric_Stringify;


pMUIP_Numeric_ValueToScale

Declaration

Source position: mui.pas line 2311

type pMUIP_Numeric_ValueToScale = ^tMUIP_Numeric_ValueToScale;


pMUIP_Popstring_Close

Declaration

Source position: mui.pas line 2836

type pMUIP_Popstring_Close = ^tMUIP_Popstring_Close;


pMUIP_Popstring_Open

Declaration

Source position: mui.pas line 2841

type pMUIP_Popstring_Open = ^tMUIP_Popstring_Open;


pMUIP_Prop_Decrease

Declaration

Source position: mui.pas line 1877

type pMUIP_Prop_Decrease = ^tMUIP_Prop_Decrease;


pMUIP_Prop_Increase

Declaration

Source position: mui.pas line 1883

type pMUIP_Prop_Increase = ^tMUIP_Prop_Increase;


pMUIP_Semaphore_Attempt

Declaration

Source position: mui.pas line 2947

type pMUIP_Semaphore_Attempt = ^tMUIP_Semaphore_Attempt;


pMUIP_Semaphore_AttemptShared

Declaration

Source position: mui.pas line 2952

type pMUIP_Semaphore_AttemptShared = ^tMUIP_Semaphore_AttemptShared;


pMUIP_Semaphore_Obtain

Declaration

Source position: mui.pas line 2957

type pMUIP_Semaphore_Obtain = ^tMUIP_Semaphore_Obtain;


pMUIP_Semaphore_ObtainShared

Declaration

Source position: mui.pas line 2962

type pMUIP_Semaphore_ObtainShared = ^tMUIP_Semaphore_ObtainShared;


pMUIP_Semaphore_Release

Declaration

Source position: mui.pas line 2967

type pMUIP_Semaphore_Release = ^tMUIP_Semaphore_Release;


pMUIP_Set

Declaration

Source position: mui.pas line 800

type pMUIP_Set = ^tMUIP_Set;


pMUIP_SetAsString

Declaration

Source position: mui.pas line 808

type pMUIP_SetAsString = ^tMUIP_SetAsString;


pMUIP_Settingsgroup_ConfigToGadgets

Declaration

Source position: mui.pas line 2598

type pMUIP_Settingsgroup_ConfigToGadgets = ^tMUIP_Settingsgroup_ConfigToGadgets;


pMUIP_Settingsgroup_GadgetsToConfig

Declaration

Source position: mui.pas line 2604

type pMUIP_Settingsgroup_GadgetsToConfig = ^tMUIP_Settingsgroup_GadgetsToConfig;


pMUIP_SetUData

Declaration

Source position: mui.pas line 816

type pMUIP_SetUData = ^tMUIP_SetUData;


pMUIP_SetUDataOnce

Declaration

Source position: mui.pas line 824

type pMUIP_SetUDataOnce = ^tMUIP_SetUDataOnce;


pMUIP_Setup

Declaration

Source position: mui.pas line 1557

type pMUIP_Setup = ^tMUIP_Setup;


pMUIP_Show

Declaration

Source position: mui.pas line 1562

type pMUIP_Show = ^tMUIP_Show;


pMUIP_UpdateConfig

Declaration

Source position: mui.pas line 1571

type pMUIP_UpdateConfig = ^tMUIP_UpdateConfig;


pMUIP_Window_AddEventHandler

Declaration

Source position: mui.pas line 1188

type pMUIP_Window_AddEventHandler = ^tMUIP_Window_AddEventHandler;


pMUIP_Window_Cleanup

Declaration

Source position: mui.pas line 1193

type pMUIP_Window_Cleanup = ^tMUIP_Window_Cleanup;


pMUIP_Window_GetMenuCheck

Declaration

Source position: mui.pas line 1199

type pMUIP_Window_GetMenuCheck = ^tMUIP_Window_GetMenuCheck;


pMUIP_Window_GetMenuState

Declaration

Source position: mui.pas line 1205

type pMUIP_Window_GetMenuState = ^tMUIP_Window_GetMenuState;


pMUIP_Window_RemEventHandler

Declaration

Source position: mui.pas line 1211

type pMUIP_Window_RemEventHandler = ^tMUIP_Window_RemEventHandler;


pMUIP_Window_ScreenToBack

Declaration

Source position: mui.pas line 1216

type pMUIP_Window_ScreenToBack = ^tMUIP_Window_ScreenToBack;


pMUIP_Window_ScreenToFront

Declaration

Source position: mui.pas line 1221

type pMUIP_Window_ScreenToFront = ^tMUIP_Window_ScreenToFront;


pMUIP_Window_SetCycleChain

Declaration

Source position: mui.pas line 1227

type pMUIP_Window_SetCycleChain = ^tMUIP_Window_SetCycleChain;


pMUIP_Window_SetMenuCheck

Declaration

Source position: mui.pas line 1234

type pMUIP_Window_SetMenuCheck = ^tMUIP_Window_SetMenuCheck;


pMUIP_Window_SetMenuState

Declaration

Source position: mui.pas line 1241

type pMUIP_Window_SetMenuState = ^tMUIP_Window_SetMenuState;


pMUIP_Window_Setup

Declaration

Source position: mui.pas line 1246

type pMUIP_Window_Setup = ^tMUIP_Window_Setup;


pMUIP_Window_Snapshot

Declaration

Source position: mui.pas line 1252

type pMUIP_Window_Snapshot = ^tMUIP_Window_Snapshot;


pMUIP_Window_ToBack

Declaration

Source position: mui.pas line 1257

type pMUIP_Window_ToBack = ^tMUIP_Window_ToBack;


pMUIP_Window_ToFront

Declaration

Source position: mui.pas line 1262

type pMUIP_Window_ToFront = ^tMUIP_Window_ToFront;


pMUIP_WriteLong

Declaration

Source position: mui.pas line 831

type pMUIP_WriteLong = ^tMUIP_WriteLong;


pMUIP_WriteString

Declaration

Source position: mui.pas line 838

type pMUIP_WriteString = ^tMUIP_WriteString;


pMUIS_InfoClient

Declaration

Source position: mui.pas line 249

type pMUIS_InfoClient = ^tMUIS_InfoClient;


PSD_FILENAME_SAVE

Declaration

Source position: mui.pas line 193

const PSD_FILENAME_SAVE: PChar = 'envarc:mui/PublicScreens.iff';


PSD_FILENAME_USE

Declaration

Source position: mui.pas line 194

const PSD_FILENAME_USE: PChar = 'env:mui/PublicScreens.iff';


PSD_INITIAL_NAME

Declaration

Source position: mui.pas line 186

const PSD_INITIAL_NAME: PChar = '(unnamed)';


PSD_INITIAL_TITLE

Declaration

Source position: mui.pas line 187

const PSD_INITIAL_TITLE: PChar = 'MUI Public Screen';


PSD_MAXLEN_BACKGROUND

Declaration

Source position: mui.pas line 198

const PSD_MAXLEN_BACKGROUND = 256;


PSD_MAXLEN_FONT

Declaration

Source position: mui.pas line 197

const PSD_MAXLEN_FONT = 48;


PSD_MAXLEN_NAME

Declaration

Source position: mui.pas line 195

const PSD_MAXLEN_NAME = 32;


PSD_MAXLEN_TITLE

Declaration

Source position: mui.pas line 196

const PSD_MAXLEN_TITLE = 128;


PSD_MAXMUIPENS

Declaration

Source position: mui.pas line 202

const PSD_MAXMUIPENS = 10;


PSD_MAXSYSPENS

Declaration

Source position: mui.pas line 200

const PSD_MAXSYSPENS = 20;


PSD_NAME_FRONTMOST

Declaration

Source position: mui.pas line 192

const PSD_NAME_FRONTMOST: PChar = '?Frontmost?';


PSD_NUMCOLS

Declaration

Source position: mui.pas line 199

const PSD_NUMCOLS = 8;


PSD_NUMMUIPENS

Declaration

Source position: mui.pas line 203

const PSD_NUMMUIPENS = 8;


PSD_NUMSYSPENS

Declaration

Source position: mui.pas line 201

const PSD_NUMSYSPENS = 12;


t__dummyXFC2__

Declaration

Source position: mui.pas line 3231

type t__dummyXFC2__ = record

  mnd: tMUI_NotifyData;

  mad: tMUI_AreaData;

end;


tMUI_AreaData

Declaration

Source position: mui.pas line 3156

type tMUI_AreaData = record

  mad_RenderInfo: pMUI_RenderInfo;

  priv7: LongWord;

  mad_Font: PTextFont;

  mad_MinMax: tMUI_MinMax;

  mad_Box: TIBox;

  mad_addleft: Byte;

  mad_addtop: Byte;

  mad_subwidth: Byte;

  mad_subheight: Byte;

  mad_Flags: LongWord;

end;


tMUI_BoopsiQuery

Declaration

Source position: mui.pas line 663

type tMUI_BoopsiQuery = record

  mbq_MethodID: LongWord;

  mbq_Screen: PScreen;

  mbq_Flags: LongWord;

  mbq_MinWidth: LongInt;

  mbq_MinHeight: LongInt;

  mbq_MaxWidth: LongInt;

  mbq_MaxHeight: LongInt;

  mbq_DefWidth: LongInt;

  mbq_DefHeight: LongInt;

  mbq_RenderInfo: pMUI_RenderInfo;

end;


tMUI_Command

Declaration

Source position: mui.pas line 290

type tMUI_Command = record

  mc_Name: Pchar;

  mc_Template: Pchar;

  mc_Parameters: LongInt;

  mc_Hook: PHook;

  mc_Reserved: array [0..4] of LongInt;

end;


tMUI_CustomClass

Declaration

Source position: mui.pas line 3298

type tMUI_CustomClass = record

  mcc_UserData: Pointer;

  mcc_UtilityBase: PLibrary;

  mcc_DOSBase: PLibrary;

  mcc_GfxBase: PLibrary;

  mcc_IntuitionBase: PLibrary;

  mcc_Super: PIClass;

  mcc_Class: PIClass;

end;


tMUI_EventHandlerNode

Declaration

Source position: mui.pas line 570

type tMUI_EventHandlerNode = record

  ehn_Node: TMinNode;

  ehn_Reserved: Byte;

  ehn_Priority: Byte;

  ehn_Flags: Word;

  ehn_Object: PObject_;

  ehn_Class: PIClass;

  ehn_Events: LongWord;

end;


tMUI_GlobalInfo

Declaration

Source position: mui.pas line 3092

type tMUI_GlobalInfo = record

  priv0: LongWord;

  mgi_ApplicationObject: PObject_;

end;


tMUI_InputHandlerNode

Declaration

Source position: mui.pas line 536

type tMUI_InputHandlerNode = record

  ihn_Node: TMinNode;

  ihn_Object: PObject_;

  ihn_stuff: record

    case LongInt of

      0: (

          ihn_sigs: LongWord;

        );

      1: (

          ihn_timer: record

            ihn_millis: Word;

            ihn_current: Word;

          end;

        );

  end;

  ihn_Flags: LongWord;

  ihn_Method: LongWord;

end;


tMUI_LayoutMsg

Declaration

Source position: mui.pas line 3122

type tMUI_LayoutMsg = record

  lm_Type: LongWord;

  lm_Children: PMinList;

  lm_MinMax: tMUI_MinMax;

  lm_Layout: record

    Width: LongInt;

    Height: LongInt;

    priv5: LongWord;

    priv6: LongWord;

  end;

end;


tMUI_List_TestPos_Result

Declaration

Source position: mui.pas line 600

type tMUI_List_TestPos_Result = record

  entry: LongInt;

  column: Word;

  flags: Word;

  xoffset: Word;

  yoffset: Word;

end;


tMUI_MinMax

Declaration

Source position: mui.pas line 1401

type tMUI_MinMax = record

  MinWidth: SmallInt;

  MinHeight: SmallInt;

  MaxWidth: SmallInt;

  MaxHeight: SmallInt;

  DefWidth: SmallInt;

  DefHeight: SmallInt;

end;


tMUI_NotifyData

Declaration

Source position: mui.pas line 3099

type tMUI_NotifyData = record

  mnd_GlobalInfo: pMUI_GlobalInfo;

  mnd_UserData: LongWord;

  mnd_ObjectID: LongWord;

  priv1: LongWord;

  priv2: LongWord;

  priv3: LongWord;

  priv4: LongWord;

end;


tMUI_Palette_Entry

Declaration

Source position: mui.pas line 519

type tMUI_Palette_Entry = record

  mpe_ID: LongInt;

  mpe_Red: LongWord;

  mpe_Green: LongWord;

  mpe_Blue: LongWord;

  mpe_Group: LongInt;

end;


tMUI_PenSpec

Declaration

Source position: mui.pas line 169

type tMUI_PenSpec = record

  buf: array [0..31] of Char;

end;


tMUI_PubScreenDesc

Declaration

Source position: mui.pas line 214

type tMUI_PubScreenDesc = record

  Version: LongInt;

  Name: array [0..(PSD_MAXLEN_NAME)-1] of Char;

  Title: array [0..(PSD_MAXLEN_TITLE)-1] of Char;

  Font: array [0..(PSD_MAXLEN_FONT)-1] of Char;

  Background: array [0..(PSD_MAXLEN_BACKGROUND)-1] of Char;

  DisplayID: LongWord;

  DisplayWidth: Word;

  DisplayHeight: Word;

  DisplayDepth: Byte;

  OverscanType: Byte;

  AutoScroll: Byte;

  NoDrag: Byte;

  Exclusive: Byte;

  Interleaved: Byte;

  SysDefault: Byte;

  Behind: Byte;

  AutoClose: Byte;

  CloseGadget: Byte;

  DummyWasForeign: Byte;

  SystemPens: array [0..(PSD_MAXSYSPENS)-1] of Byte;

  Reserved: array [0..((1+(7*4))-PSD_MAXSYSPENS)-1] of Byte;

  Palette: array [0..(PSD_NUMCOLS)-1] of tMUI_RGBcolor;

  rsvd: array [0..(PSD_MAXSYSPENS-PSD_NUMCOLS)-1] of tMUI_RGBcolor;

  rsvd2: array [0..(PSD_MAXMUIPENS)-1] of tMUI_PenSpec;

  Changed: LongInt;

  UserData: Pointer;

end;


tMUI_RenderInfo

Declaration

Source position: mui.pas line 650

type tMUI_RenderInfo = record

  mri_WindowObject: PObject_;

  mri_Screen: PScreen;

  mri_DrawInfo: PDrawInfo;

  mri_Pens: ;

  mri_Window: PWindow;

  mri_RastPort: PRastPort;

  mri_Flags: LongWord;

  mri_DummyWasTinyFont: PTextFont;

end;


tMUI_RGBcolor

Declaration

Source position: mui.pas line 206

type tMUI_RGBcolor = record

  red: LongWord;

  green: LongWord;

  blue: LongWord;

end;


tMUIP_Application_AboutMUI

Declaration

Source position: mui.pas line 1007

type tMUIP_Application_AboutMUI = record

  MethodID: LongWord;

  refwindow: PObject_;

end;


tMUIP_Application_AddInputHandler

Declaration

Source position: mui.pas line 1013

type tMUIP_Application_AddInputHandler = record

  MethodID: LongWord;

  ihnode: pMUI_InputHandlerNode;

end;


tMUIP_Application_BuildSettingsPanel

Declaration

Source position: mui.pas line 1019

type tMUIP_Application_BuildSettingsPanel = record

  MethodID: LongWord;

  number: LongWord;

end;


tMUIP_Application_CheckRefresh

Declaration

Source position: mui.pas line 1025

type tMUIP_Application_CheckRefresh = record

  MethodID: LongWord;

end;


tMUIP_Application_DefaultConfigItem

Declaration

Source position: mui.pas line 1030

type tMUIP_Application_DefaultConfigItem = record

  MethodID: LongWord;

  cfgid: LongWord;

end;


tMUIP_Application_GetMenuCheck

Declaration

Source position: mui.pas line 1036

type tMUIP_Application_GetMenuCheck = record

  MethodID: LongWord;

  MenuID: LongWord;

end;


tMUIP_Application_GetMenuState

Declaration

Source position: mui.pas line 1042

type tMUIP_Application_GetMenuState = record

  MethodID: LongWord;

  MenuID: LongWord;

end;


tMUIP_Application_Input

Declaration

Source position: mui.pas line 1048

type tMUIP_Application_Input = record

  MethodID: LongWord;

  signal: plongword;

end;


tMUIP_Application_InputBuffered

Declaration

Source position: mui.pas line 1054

type tMUIP_Application_InputBuffered = record

  MethodID: LongWord;

end;


tMUIP_Application_Load

Declaration

Source position: mui.pas line 1059

type tMUIP_Application_Load = record

  MethodID: LongWord;

  name: PChar;

end;


tMUIP_Application_NewInput

Declaration

Source position: mui.pas line 1064

type tMUIP_Application_NewInput = record

  MethodID: LongWord;

  signal: plongword;

end;


tMUIP_Application_OpenConfigWindow

Declaration

Source position: mui.pas line 1070

type tMUIP_Application_OpenConfigWindow = record

  MethodID: LongWord;

  flags: LongWord;

end;


tMUIP_Application_PushMethod

Declaration

Source position: mui.pas line 1076

type tMUIP_Application_PushMethod = record

  MethodID: LongWord;

  dest: PObject_;

  count: LongInt;

end;


tMUIP_Application_RemInputHandler

Declaration

Source position: mui.pas line 1083

type tMUIP_Application_RemInputHandler = record

  MethodID: LongWord;

  ihnode: pMUI_InputHandlerNode;

end;


tMUIP_Application_ReturnID

Declaration

Source position: mui.pas line 1089

type tMUIP_Application_ReturnID = record

  MethodID: LongWord;

  retid: LongWord;

end;


tMUIP_Application_Save

Declaration

Source position: mui.pas line 1095

type tMUIP_Application_Save = record

  MethodID: LongWord;

  name: PChar;

end;


tMUIP_Application_SetConfigItem

Declaration

Source position: mui.pas line 1100

type tMUIP_Application_SetConfigItem = record

  MethodID: LongWord;

  item: LongWord;

  data: Pointer;

end;


tMUIP_Application_SetMenuCheck

Declaration

Source position: mui.pas line 1107

type tMUIP_Application_SetMenuCheck = record

  MethodID: LongWord;

  MenuID: LongWord;

  stat: LongInt;

end;


tMUIP_Application_SetMenuState

Declaration

Source position: mui.pas line 1114

type tMUIP_Application_SetMenuState = record

  MethodID: LongWord;

  MenuID: LongWord;

  stat: LongInt;

end;


tMUIP_Application_ShowHelp

Declaration

Source position: mui.pas line 1121

type tMUIP_Application_ShowHelp = record

  MethodID: LongWord;

  window: PObject_;

  name: Pchar;

  node: Pchar;

  line: LongInt;

end;


tMUIP_AskMinMax

Declaration

Source position: mui.pas line 1411

type tMUIP_AskMinMax = record

  MethodID: LongWord;

  MinMaxInfo: pMUI_MinMax;

end;


tMUIP_CallHook

Declaration

Source position: mui.pas line 717

type tMUIP_CallHook = record

  MethodID: LongWord;

  Hook: PHook;

  param1: LongWord;

end;


tMUIP_Cleanup

Declaration

Source position: mui.pas line 1417

type tMUIP_Cleanup = record

  MethodID: LongWord;

end;


tMUIP_ContextMenuAdd

Declaration

Source position: mui.pas line 1422

type tMUIP_ContextMenuAdd = record

  MethodID: LongWord;

  menustrip: PObject_;

  mx: LongInt;

  my: LongInt;

  mxp: pLongInt;

  myp: pLongInt;

end;


tMUIP_ContextMenuBuild

Declaration

Source position: mui.pas line 1432

type tMUIP_ContextMenuBuild = record

  MethodID: LongWord;

  mx: LongInt;

  my: LongInt;

end;


tMUIP_ContextMenuChoice

Declaration

Source position: mui.pas line 1439

type tMUIP_ContextMenuChoice = record

  MethodID: LongWord;

  item: PObject_;

end;


tMUIP_CreateBubble

Declaration

Source position: mui.pas line 1445

type tMUIP_CreateBubble = record

  MethodID: LongWord;

  x: LongInt;

  y: LongInt;

  txt: PChar;

  flags: LongWord;

end;


tMUIP_CreateShortHelp

Declaration

Source position: mui.pas line 1454

type tMUIP_CreateShortHelp = record

  MethodID: LongWord;

  mx: LongInt;

  my: LongInt;

end;


tMUIP_Dataspace_Add

Declaration

Source position: mui.pas line 3012

type tMUIP_Dataspace_Add = record

  MethodID: LongWord;

  data: Pointer;

  len: LongInt;

  id: LongWord;

end;


tMUIP_Dataspace_Clear

Declaration

Source position: mui.pas line 3020

type tMUIP_Dataspace_Clear = record

  MethodID: LongWord;

end;


tMUIP_Dataspace_Find

Declaration

Source position: mui.pas line 3025

type tMUIP_Dataspace_Find = record

  MethodID: LongWord;

  id: LongWord;

end;


tMUIP_Dataspace_Merge

Declaration

Source position: mui.pas line 3031

type tMUIP_Dataspace_Merge = record

  MethodID: LongWord;

  dataspace: PObject_;

end;


tMUIP_Dataspace_ReadIFF

Declaration

Source position: mui.pas line 3037

type tMUIP_Dataspace_ReadIFF = record

  MethodID: LongWord;

  handle: Pointer;

end;


tMUIP_Dataspace_Remove

Declaration

Source position: mui.pas line 3043

type tMUIP_Dataspace_Remove = record

  MethodID: LongWord;

  id: LongWord;

end;


tMUIP_Dataspace_WriteIFF

Declaration

Source position: mui.pas line 3049

type tMUIP_Dataspace_WriteIFF = record

  MethodID: LongWord;

  handle: Pointer;

  type_: LongWord;

  id: LongWord;

end;


tMUIP_DeleteBubble

Declaration

Source position: mui.pas line 1461

type tMUIP_DeleteBubble = record

  MethodID: LongWord;

  bubble: Pointer;

end;


tMUIP_DeleteShortHelp

Declaration

Source position: mui.pas line 1467

type tMUIP_DeleteShortHelp = record

  MethodID: LongWord;

  help: PChar;

end;


tMUIP_DoDrag

Declaration

Source position: mui.pas line 1473

type tMUIP_DoDrag = record

  MethodID: LongWord;

  touchx: LongInt;

  touchy: LongInt;

  flags: LongWord;

end;


tMUIP_DragBegin

Declaration

Source position: mui.pas line 1481

type tMUIP_DragBegin = record

  MethodID: LongWord;

  obj: PObject_;

end;


tMUIP_DragDrop

Declaration

Source position: mui.pas line 1487

type tMUIP_DragDrop = record

  MethodID: LongWord;

  obj: PObject_;

  x: LongInt;

  y: LongInt;

end;


tMUIP_DragFinish

Declaration

Source position: mui.pas line 1495

type tMUIP_DragFinish = record

  MethodID: LongWord;

  obj: PObject_;

end;


tMUIP_DragQuery

Declaration

Source position: mui.pas line 1501

type tMUIP_DragQuery = record

  MethodID: LongWord;

  obj: PObject_;

end;


tMUIP_DragReport

Declaration

Source position: mui.pas line 1507

type tMUIP_DragReport = record

  MethodID: LongWord;

  obj: PObject_;

  x: LongInt;

  y: LongInt;

  update: LongInt;

end;


tMUIP_Draw

Declaration

Source position: mui.pas line 1516

type tMUIP_Draw = record

  MethodID: LongWord;

  flags: LongWord;

end;


tMUIP_DrawBackground

Declaration

Source position: mui.pas line 1522

type tMUIP_DrawBackground = record

  MethodID: LongWord;

  left: LongInt;

  top: LongInt;

  width: LongInt;

  height: LongInt;

  xoffset: LongInt;

  yoffset: LongInt;

  flags: LongInt;

end;


tMUIP_Export

Declaration

Source position: mui.pas line 724

type tMUIP_Export = record

  MethodID: LongWord;

  dataspace: PObject_;

end;


tMUIP_Family_AddHead

Declaration

Source position: mui.pas line 872

type tMUIP_Family_AddHead = record

  MethodID: LongWord;

  obj: PObject_;

end;


tMUIP_Family_AddTail

Declaration

Source position: mui.pas line 878

type tMUIP_Family_AddTail = record

  MethodID: LongWord;

  obj: PObject_;

end;


tMUIP_Family_Insert

Declaration

Source position: mui.pas line 884

type tMUIP_Family_Insert = record

  MethodID: LongWord;

  obj: PObject_;

  pred: PObject_;

end;


tMUIP_Family_Remove

Declaration

Source position: mui.pas line 891

type tMUIP_Family_Remove = record

  MethodID: LongWord;

  obj: PObject_;

end;


tMUIP_Family_Sort

Declaration

Source position: mui.pas line 897

type tMUIP_Family_Sort = record

  MethodID: LongWord;

  obj: array [0..0] of PObject_;

end;


tMUIP_Family_Transfer

Declaration

Source position: mui.pas line 903

type tMUIP_Family_Transfer = record

  MethodID: LongWord;

  family: PObject_;

end;


tMUIP_FindUData

Declaration

Source position: mui.pas line 730

type tMUIP_FindUData = record

  MethodID: LongWord;

  udata: LongWord;

end;


tMUIP_GetConfigItem

Declaration

Source position: mui.pas line 736

type tMUIP_GetConfigItem = record

  MethodID: LongWord;

  id: LongWord;

  storage: plongword;

end;


tMUIP_GetUData

Declaration

Source position: mui.pas line 743

type tMUIP_GetUData = record

  MethodID: LongWord;

  udata: LongWord;

  attr: LongWord;

  storage: plongword;

end;


tMUIP_Group_ExitChange

Declaration

Source position: mui.pas line 2489

type tMUIP_Group_ExitChange = record

  MethodID: LongWord;

end;


tMUIP_Group_InitChange

Declaration

Source position: mui.pas line 2494

type tMUIP_Group_InitChange = record

  MethodID: LongWord;

end;


tMUIP_Group_Sort

Declaration

Source position: mui.pas line 2499

type tMUIP_Group_Sort = record

  MethodID: LongWord;

  obj: array [0..0] of PObject_;

end;


tMUIP_HandleEvent

Declaration

Source position: mui.pas line 1534

type tMUIP_HandleEvent = record

  MethodID: LongWord;

  imsg: PIntuiMessage;

  muikey: LongInt;

end;


tMUIP_HandleInput

Declaration

Source position: mui.pas line 1541

type tMUIP_HandleInput = record

  MethodID: LongWord;

  imsg: PIntuiMessage;

  muikey: LongInt;

end;


tMUIP_Hide

Declaration

Source position: mui.pas line 1548

type tMUIP_Hide = record

  MethodID: LongWord;

end;


tMUIP_Import

Declaration

Source position: mui.pas line 751

type tMUIP_Import = record

  MethodID: LongWord;

  dataspace: PObject_;

end;


tMUIP_KillNotify

Declaration

Source position: mui.pas line 757

type tMUIP_KillNotify = record

  MethodID: LongWord;

  TrigAttr: LongWord;

end;


tMUIP_KillNotifyObj

Declaration

Source position: mui.pas line 763

type tMUIP_KillNotifyObj = record

  MethodID: LongWord;

  TrigAttr: LongWord;

  dest: PObject_;

end;


tMUIP_List_Clear

Declaration

Source position: mui.pas line 1988

type tMUIP_List_Clear = record

  MethodID: LongWord;

end;


tMUIP_List_CreateImage

Declaration

Source position: mui.pas line 1993

type tMUIP_List_CreateImage = record

  MethodID: LongWord;

  obj: PObject_;

  flags: LongWord;

end;


tMUIP_List_DeleteImage

Declaration

Source position: mui.pas line 2000

type tMUIP_List_DeleteImage = record

  MethodID: LongWord;

  listimg: Pointer;

end;


tMUIP_List_Exchange

Declaration

Source position: mui.pas line 2006

type tMUIP_List_Exchange = record

  MethodID: LongWord;

  pos1: LongInt;

  pos2: LongInt;

end;


tMUIP_List_GetEntry

Declaration

Source position: mui.pas line 2013

type tMUIP_List_GetEntry = record

  MethodID: LongWord;

  pos: LongInt;

  entry: PPointer;

end;


tMUIP_List_Insert

Declaration

Source position: mui.pas line 2020

type tMUIP_List_Insert = record

  MethodID: LongWord;

  entries: PPointer;

  count: LongInt;

  pos: LongInt;

end;


tMUIP_List_InsertSingle

Declaration

Source position: mui.pas line 2028

type tMUIP_List_InsertSingle = record

  MethodID: LongWord;

  entry: Pointer;

  pos: LongInt;

end;


tMUIP_List_Jump

Declaration

Source position: mui.pas line 2035

type tMUIP_List_Jump = record

  MethodID: LongWord;

  pos: LongInt;

end;


tMUIP_List_Move

Declaration

Source position: mui.pas line 2041

type tMUIP_List_Move = record

  MethodID: LongWord;

  from: LongInt;

  too: LongInt;

end;


tMUIP_List_NextSelected

Declaration

Source position: mui.pas line 2048

type tMUIP_List_NextSelected = record

  MethodID: LongWord;

  pos: PLongInt;

end;


tMUIP_List_Redraw

Declaration

Source position: mui.pas line 2054

type tMUIP_List_Redraw = record

  MethodID: LongWord;

  pos: LongInt;

end;


tMUIP_List_Remove

Declaration

Source position: mui.pas line 2060

type tMUIP_List_Remove = record

  MethodID: LongWord;

  pos: LongInt;

end;


tMUIP_List_Select

Declaration

Source position: mui.pas line 2066

type tMUIP_List_Select = record

  MethodID: LongWord;

  pos: LongInt;

  seltype: LongInt;

  state: PLongInt;

end;


tMUIP_List_Sort

Declaration

Source position: mui.pas line 2074

type tMUIP_List_Sort = record

  MethodID: LongWord;

end;


tMUIP_List_TestPos

Declaration

Source position: mui.pas line 2079

type tMUIP_List_TestPos = record

  MethodID: LongWord;

  x: LongInt;

  y: LongInt;

  res: pMUI_List_TestPos_Result;

end;


tMUIP_Menustrip_ExitChange

Declaration

Source position: mui.pas line 928

type tMUIP_Menustrip_ExitChange = record

  MethodID: LongWord;

end;


tMUIP_Menustrip_InitChange

Declaration

Source position: mui.pas line 933

type tMUIP_Menustrip_InitChange = record

  MethodID: LongWord;

end;


tMUIP_MultiSet

Declaration

Source position: mui.pas line 770

type tMUIP_MultiSet = record

  MethodID: LongWord;

  attr: LongWord;

  val: LongWord;

  obj: Pointer;

end;


tMUIP_NoNotifySet

Declaration

Source position: mui.pas line 778

type tMUIP_NoNotifySet = record

  MethodID: LongWord;

  attr: LongWord;

  format: Pchar;

  val: LongWord;

end;


tMUIP_Notify

Declaration

Source position: mui.pas line 786

type tMUIP_Notify = record

  MethodID: LongWord;

  TrigAttr: LongWord;

  TrigVal: LongWord;

  DestObj: Pointer;

  FollowParams: LongWord;

end;


tMUIP_Numeric_Decrease

Declaration

Source position: mui.pas line 2275

type tMUIP_Numeric_Decrease = record

  MethodID: LongWord;

  amount: LongInt;

end;


tMUIP_Numeric_Increase

Declaration

Source position: mui.pas line 2281

type tMUIP_Numeric_Increase = record

  MethodID: LongWord;

  amount: LongInt;

end;


tMUIP_Numeric_ScaleToValue

Declaration

Source position: mui.pas line 2287

type tMUIP_Numeric_ScaleToValue = record

  MethodID: LongWord;

  scalemin: LongInt;

  scalemax: LongInt;

  scale: LongInt;

end;


tMUIP_Numeric_SetDefault

Declaration

Source position: mui.pas line 2295

type tMUIP_Numeric_SetDefault = record

  MethodID: LongWord;

end;


tMUIP_Numeric_Stringify

Declaration

Source position: mui.pas line 2300

type tMUIP_Numeric_Stringify = record

  MethodID: LongWord;

  value: LongInt;

end;


tMUIP_Numeric_ValueToScale

Declaration

Source position: mui.pas line 2306

type tMUIP_Numeric_ValueToScale = record

  MethodID: LongWord;

  scalemin: LongInt;

  scalemax: LongInt;

end;


tMUIP_Popstring_Close

Declaration

Source position: mui.pas line 2832

type tMUIP_Popstring_Close = record

  MethodID: LongWord;

  result: LongInt;

end;


tMUIP_Popstring_Open

Declaration

Source position: mui.pas line 2838

type tMUIP_Popstring_Open = record

  MethodID: LongWord;

end;


tMUIP_Prop_Decrease

Declaration

Source position: mui.pas line 1873

type tMUIP_Prop_Decrease = record

  MethodID: LongWord;

  amount: LongInt;

end;


tMUIP_Prop_Increase

Declaration

Source position: mui.pas line 1879

type tMUIP_Prop_Increase = record

  MethodID: LongWord;

  amount: LongInt;

end;


tMUIP_Semaphore_Attempt

Declaration

Source position: mui.pas line 2944

type tMUIP_Semaphore_Attempt = record

  MethodID: LongWord;

end;


tMUIP_Semaphore_AttemptShared

Declaration

Source position: mui.pas line 2949

type tMUIP_Semaphore_AttemptShared = record

  MethodID: LongWord;

end;


tMUIP_Semaphore_Obtain

Declaration

Source position: mui.pas line 2954

type tMUIP_Semaphore_Obtain = record

  MethodID: LongWord;

end;


tMUIP_Semaphore_ObtainShared

Declaration

Source position: mui.pas line 2959

type tMUIP_Semaphore_ObtainShared = record

  MethodID: LongWord;

end;


tMUIP_Semaphore_Release

Declaration

Source position: mui.pas line 2964

type tMUIP_Semaphore_Release = record

  MethodID: LongWord;

end;


tMUIP_Set

Declaration

Source position: mui.pas line 795

type tMUIP_Set = record

  MethodID: LongWord;

  attr: LongWord;

  val: LongWord;

end;


tMUIP_SetAsString

Declaration

Source position: mui.pas line 802

type tMUIP_SetAsString = record

  MethodID: LongWord;

  attr: LongWord;

  format: Pchar;

  val: LongWord;

end;


tMUIP_Settingsgroup_ConfigToGadgets

Declaration

Source position: mui.pas line 2594

type tMUIP_Settingsgroup_ConfigToGadgets = record

  MethodID: LongWord;

  configdata: PObject_;

end;


tMUIP_Settingsgroup_GadgetsToConfig

Declaration

Source position: mui.pas line 2600

type tMUIP_Settingsgroup_GadgetsToConfig = record

  MethodID: LongWord;

  configdata: PObject_;

end;


tMUIP_SetUData

Declaration

Source position: mui.pas line 810

type tMUIP_SetUData = record

  MethodID: LongWord;

  udata: LongWord;

  attr: LongWord;

  val: LongWord;

end;


tMUIP_SetUDataOnce

Declaration

Source position: mui.pas line 818

type tMUIP_SetUDataOnce = record

  MethodID: LongWord;

  udata: LongWord;

  attr: LongWord;

  val: LongWord;

end;


tMUIP_Setup

Declaration

Source position: mui.pas line 1553

type tMUIP_Setup = record

  MethodID: LongWord;

  RenderInfo: pMUI_RenderInfo;

end;


tMUIP_Show

Declaration

Source position: mui.pas line 1559

type tMUIP_Show = record

  MethodID: LongWord;

end;


tMUIP_UpdateConfig

Declaration

Source position: mui.pas line 1564

type tMUIP_UpdateConfig = record

  MethodID: LongWord;

  cfgid: LongWord;

  redrawcount: LongInt;

  redrawobj: array [0..63] of PObject_;

  redrawflags: array [0..63] of Byte;

end;


tMUIP_Window_AddEventHandler

Declaration

Source position: mui.pas line 1184

type tMUIP_Window_AddEventHandler = record

  MethodID: LongWord;

  ehnode: pMUI_EventHandlerNode;

end;


tMUIP_Window_Cleanup

Declaration

Source position: mui.pas line 1190

type tMUIP_Window_Cleanup = record

  MethodID: LongWord;

end;


tMUIP_Window_GetMenuCheck

Declaration

Source position: mui.pas line 1195

type tMUIP_Window_GetMenuCheck = record

  MethodID: LongWord;

  MenuID: LongWord;

end;


tMUIP_Window_GetMenuState

Declaration

Source position: mui.pas line 1201

type tMUIP_Window_GetMenuState = record

  MethodID: LongWord;

  MenuID: LongWord;

end;


tMUIP_Window_RemEventHandler

Declaration

Source position: mui.pas line 1207

type tMUIP_Window_RemEventHandler = record

  MethodID: LongWord;

  ehnode: pMUI_EventHandlerNode;

end;


tMUIP_Window_ScreenToBack

Declaration

Source position: mui.pas line 1213

type tMUIP_Window_ScreenToBack = record

  MethodID: LongWord;

end;


tMUIP_Window_ScreenToFront

Declaration

Source position: mui.pas line 1218

type tMUIP_Window_ScreenToFront = record

  MethodID: LongWord;

end;


tMUIP_Window_SetCycleChain

Declaration

Source position: mui.pas line 1223

type tMUIP_Window_SetCycleChain = record

  MethodID: LongWord;

  obj: array [0..0] of PObject_;

end;


tMUIP_Window_SetMenuCheck

Declaration

Source position: mui.pas line 1229

type tMUIP_Window_SetMenuCheck = record

  MethodID: LongWord;

  MenuID: LongWord;

  stat: LongInt;

end;


tMUIP_Window_SetMenuState

Declaration

Source position: mui.pas line 1236

type tMUIP_Window_SetMenuState = record

  MethodID: LongWord;

  MenuID: LongWord;

  stat: LongInt;

end;


tMUIP_Window_Setup

Declaration

Source position: mui.pas line 1243

type tMUIP_Window_Setup = record

  MethodID: LongWord;

end;


tMUIP_Window_Snapshot

Declaration

Source position: mui.pas line 1248

type tMUIP_Window_Snapshot = record

  MethodID: LongWord;

  flags: LongInt;

end;


tMUIP_Window_ToBack

Declaration

Source position: mui.pas line 1254

type tMUIP_Window_ToBack = record

  MethodID: LongWord;

end;


tMUIP_Window_ToFront

Declaration

Source position: mui.pas line 1259

type tMUIP_Window_ToFront = record

  MethodID: LongWord;

end;


tMUIP_WriteLong

Declaration

Source position: mui.pas line 826

type tMUIP_WriteLong = record

  MethodID: LongWord;

  val: LongWord;

  memory: plongword;

end;


tMUIP_WriteString

Declaration

Source position: mui.pas line 833

type tMUIP_WriteString = record

  MethodID: LongWord;

  str: Pchar;

  memory: Pchar;

end;


tMUIS_InfoClient

Declaration

Source position: mui.pas line 244

type tMUIS_InfoClient = record

  node: TMinNode;

  task: PTask;

  sigbit: LongWord;

end;


Reference for unit 'serial'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'serial': Constants

IOSERB_ABORT

IOSERB_ACTIVE

IOSERB_BUFRREAD

IOSERB_QUEUED

IOSERF_ABORT

IOSERF_ACTIVE

IOSERF_BUFRREAD

IOSERF_QUEUED

IOSTB_OVERRUN

IOSTB_READBREAK

IOSTB_WROTEBREAK

IOSTB_XOFFREAD

IOSTB_XOFFWRITE

IOSTF_OVERRUN

IOSTF_READBREAK

IOSTF_WROTEBREAK

IOSTF_XOFFREAD

IOSTF_XOFFWRITE

IO_STATB_OVERRUN

IO_STATB_READBREAK

IO_STATB_WROTEBREAK

IO_STATB_XOFFREAD

IO_STATB_XOFFWRITE

IO_STATF_OVERRUN

IO_STATF_READBREAK

IO_STATF_WROTEBREAK

IO_STATF_XOFFREAD

IO_STATF_XOFFWRITE

SDCMD_BREAK

SDCMD_QUERY

SDCMD_SETPARAMS

SERB_7WIRE

SERB_EOFMODE

SERB_PARTY_ODD

SERB_PARTY_ON

SERB_QUEUEDBRK

SERB_RAD_BOOGIE

SERB_SHARED

SERB_XDISABLED

SerErr_BaudMismatch

SerErr_BufErr

SerErr_BufOverflow

SerErr_DetectedBreak

SerErr_DevBusy

SerErr_InvParam

SerErr_LineErr

SerErr_NoDSR

SerErr_ParityErr

SerErr_TimerErr

SERF_7WIRE

SERF_EOFMODE

SERF_PARTY_ODD

SERF_PARTY_ON

SERF_QUEUEDBRK

SERF_RAD_BOOGIE

SERF_SHARED

SERF_XDISABLED

SERIALNAME

SER_DEFAULT_CTLCHAR

SEXTB_MARK

SEXTB_MSPON

SEXTF_MARK

SEXTF_MSPON


Reference for unit 'serial': Types

PIOExtSer

PIOTArray

TIOExtSer

TIOTArray


Index of all identifiers in unit 'serial'

I P S T

I

IOSERB_ABORT | IO_STATB_WROTEBREAK | IOSTB_WROTEBREAK
IOSERB_ACTIVE | IO_STATB_XOFFREAD | IOSTB_XOFFREAD
IOSERB_BUFRREAD | IO_STATB_XOFFWRITE | IOSTB_XOFFWRITE
IOSERB_QUEUED | IO_STATF_OVERRUN | IOSTF_OVERRUN
IOSERF_ABORT | IO_STATF_READBREAK | IOSTF_READBREAK
IOSERF_ACTIVE | IO_STATF_WROTEBREAK | IOSTF_WROTEBREAK
IOSERF_BUFRREAD | IO_STATF_XOFFREAD | IOSTF_XOFFREAD
IOSERF_QUEUED | IO_STATF_XOFFWRITE | IOSTF_XOFFWRITE
IO_STATB_OVERRUN | IOSTB_OVERRUN |
IO_STATB_READBREAK | IOSTB_READBREAK |

P

PIOExtSer PIOTArray

S

SDCMD_BREAK | SerErr_BaudMismatch | SERF_PARTY_ODD
SDCMD_QUERY | SerErr_BufErr | SERF_PARTY_ON
SDCMD_SETPARAMS | SerErr_BufOverflow | SERF_QUEUEDBRK
SERB_7WIRE | SerErr_DetectedBreak | SERF_RAD_BOOGIE
SERB_EOFMODE | SerErr_DevBusy | SERF_SHARED
SERB_PARTY_ODD | SerErr_InvParam | SERF_XDISABLED
SERB_PARTY_ON | SerErr_LineErr | SERIALNAME
SERB_QUEUEDBRK | SerErr_NoDSR | SEXTB_MARK
SERB_RAD_BOOGIE | SerErr_ParityErr | SEXTB_MSPON
SERB_SHARED | SerErr_TimerErr | SEXTF_MARK
SERB_XDISABLED | SERF_7WIRE | SEXTF_MSPON
SER_DEFAULT_CTLCHAR | SERF_EOFMODE |

T

TIOExtSer TIOTArray


IO_STATB_OVERRUN

Declaration

Source position: serial.pas line 115

const IO_STATB_OVERRUN = 8;


IO_STATB_READBREAK

Declaration

Source position: serial.pas line 111

const IO_STATB_READBREAK = 10;


IO_STATB_WROTEBREAK

Declaration

Source position: serial.pas line 113

const IO_STATB_WROTEBREAK = 9;


IO_STATB_XOFFREAD

Declaration

Source position: serial.pas line 107

const IO_STATB_XOFFREAD = 12;


IO_STATB_XOFFWRITE

Declaration

Source position: serial.pas line 109

const IO_STATB_XOFFWRITE = 11;


IO_STATF_OVERRUN

Declaration

Source position: serial.pas line 116

const IO_STATF_OVERRUN = 1 shl IO_STATB_OVERRUN;


IO_STATF_READBREAK

Declaration

Source position: serial.pas line 112

const IO_STATF_READBREAK = 1 shl IO_STATB_READBREAK;


IO_STATF_WROTEBREAK

Declaration

Source position: serial.pas line 114

const IO_STATF_WROTEBREAK = 1 shl IO_STATB_WROTEBREAK;


IO_STATF_XOFFREAD

Declaration

Source position: serial.pas line 108

const IO_STATF_XOFFREAD = 1 shl IO_STATB_XOFFREAD;


IO_STATF_XOFFWRITE

Declaration

Source position: serial.pas line 110

const IO_STATF_XOFFWRITE = 1 shl IO_STATB_XOFFWRITE;


IOSERB_ABORT

Declaration

Source position: serial.pas line 154

const IOSERB_ABORT = 5;


IOSERB_ACTIVE

Declaration

Source position: serial.pas line 156

const IOSERB_ACTIVE = 4;


IOSERB_BUFRREAD

Declaration

Source position: serial.pas line 150

const IOSERB_BUFRREAD = 7;


IOSERB_QUEUED

Declaration

Source position: serial.pas line 152

const IOSERB_QUEUED = 6;


IOSERF_ABORT

Declaration

Source position: serial.pas line 155

const IOSERF_ABORT = 1 shl IOSERB_ABORT;


IOSERF_ACTIVE

Declaration

Source position: serial.pas line 157

const IOSERF_ACTIVE = 1 shl IOSERB_ACTIVE;


IOSERF_BUFRREAD

Declaration

Source position: serial.pas line 151

const IOSERF_BUFRREAD = 1 shl IOSERB_BUFRREAD;


IOSERF_QUEUED

Declaration

Source position: serial.pas line 153

const IOSERF_QUEUED = 1 shl IOSERB_QUEUED;


IOSTB_OVERRUN

Declaration

Source position: serial.pas line 146

const IOSTB_OVERRUN = 0;


IOSTB_READBREAK

Declaration

Source position: serial.pas line 142

const IOSTB_READBREAK = 2;


IOSTB_WROTEBREAK

Declaration

Source position: serial.pas line 144

const IOSTB_WROTEBREAK = 1;


IOSTB_XOFFREAD

Declaration

Source position: serial.pas line 138

const IOSTB_XOFFREAD = 4;


IOSTB_XOFFWRITE

Declaration

Source position: serial.pas line 140

const IOSTB_XOFFWRITE = 3;


IOSTF_OVERRUN

Declaration

Source position: serial.pas line 147

const IOSTF_OVERRUN = 1 shl IOSTB_OVERRUN;


IOSTF_READBREAK

Declaration

Source position: serial.pas line 143

const IOSTF_READBREAK = 1 shl IOSTB_READBREAK;


IOSTF_WROTEBREAK

Declaration

Source position: serial.pas line 145

const IOSTF_WROTEBREAK = 1 shl IOSTB_WROTEBREAK;


IOSTF_XOFFREAD

Declaration

Source position: serial.pas line 139

const IOSTF_XOFFREAD = 1 shl IOSTB_XOFFREAD;


IOSTF_XOFFWRITE

Declaration

Source position: serial.pas line 141

const IOSTF_XOFFWRITE = 1 shl IOSTB_XOFFWRITE;


PIOExtSer

Declaration

Source position: serial.pas line 61

type PIOExtSer = ^TIOExtSer;


PIOTArray

Declaration

Source position: serial.pas line 28

type PIOTArray = ^TIOTArray;


SDCMD_BREAK

Declaration

Source position: serial.pas line 85

const SDCMD_BREAK = CMD_NONSTD + 1;


SDCMD_QUERY

Declaration

Source position: serial.pas line 84

const SDCMD_QUERY = CMD_NONSTD;


SDCMD_SETPARAMS

Declaration

Source position: serial.pas line 86

const SDCMD_SETPARAMS = CMD_NONSTD + 2;


SER_DEFAULT_CTLCHAR

Declaration

Source position: serial.pas line 35

const SER_DEFAULT_CTLCHAR = $11130000;


SERB_7WIRE

Declaration

Source position: serial.pas line 99

const SERB_7WIRE = 2;


SERB_EOFMODE

Declaration

Source position: serial.pas line 91

const SERB_EOFMODE = 6;


SERB_PARTY_ODD

Declaration

Source position: serial.pas line 101

const SERB_PARTY_ODD = 1;


SERB_PARTY_ON

Declaration

Source position: serial.pas line 103

const SERB_PARTY_ON = 0;


SERB_QUEUEDBRK

Declaration

Source position: serial.pas line 97

const SERB_QUEUEDBRK = 3;


SERB_RAD_BOOGIE

Declaration

Source position: serial.pas line 95

const SERB_RAD_BOOGIE = 4;


SERB_SHARED

Declaration

Source position: serial.pas line 93

const SERB_SHARED = 5;


SERB_XDISABLED

Declaration

Source position: serial.pas line 89

const SERB_XDISABLED = 7;


SerErr_BaudMismatch

Declaration

Source position: serial.pas line 125

const SerErr_BaudMismatch = 2;


SerErr_BufErr

Declaration

Source position: serial.pas line 126

const SerErr_BufErr = 4;


SerErr_BufOverflow

Declaration

Source position: serial.pas line 131

const SerErr_BufOverflow = 12;


SerErr_DetectedBreak

Declaration

Source position: serial.pas line 133

const SerErr_DetectedBreak = 15;


SerErr_DevBusy

Declaration

Source position: serial.pas line 124

const SerErr_DevBusy = 1;


SerErr_InvParam

Declaration

Source position: serial.pas line 127

const SerErr_InvParam = 5;


SerErr_LineErr

Declaration

Source position: serial.pas line 128

const SerErr_LineErr = 6;


SerErr_NoDSR

Declaration

Source position: serial.pas line 132

const SerErr_NoDSR = 13;


SerErr_ParityErr

Declaration

Source position: serial.pas line 129

const SerErr_ParityErr = 9;


SerErr_TimerErr

Declaration

Source position: serial.pas line 130

const SerErr_TimerErr = 11;


SERF_7WIRE

Declaration

Source position: serial.pas line 100

const SERF_7WIRE = 1 shl SERB_7WIRE;


SERF_EOFMODE

Declaration

Source position: serial.pas line 92

const SERF_EOFMODE = 1 shl SERB_EOFMODE;


SERF_PARTY_ODD

Declaration

Source position: serial.pas line 102

const SERF_PARTY_ODD = 1 shl SERB_PARTY_ODD;


SERF_PARTY_ON

Declaration

Source position: serial.pas line 104

const SERF_PARTY_ON = 1 shl SERB_PARTY_ON;


SERF_QUEUEDBRK

Declaration

Source position: serial.pas line 98

const SERF_QUEUEDBRK = 1 shl SERB_QUEUEDBRK;


SERF_RAD_BOOGIE

Declaration

Source position: serial.pas line 96

const SERF_RAD_BOOGIE = 1 shl SERB_RAD_BOOGIE;


SERF_SHARED

Declaration

Source position: serial.pas line 94

const SERF_SHARED = 1 shl SERB_SHARED;


SERF_XDISABLED

Declaration

Source position: serial.pas line 90

const SERF_XDISABLED = 1 shl SERB_XDISABLED;


SERIALNAME

Declaration

Source position: serial.pas line 159

const SERIALNAME: PChar = 'serial.device';


SEXTB_MARK

Declaration

Source position: serial.pas line 121

const SEXTB_MARK = 0;


SEXTB_MSPON

Declaration

Source position: serial.pas line 119

const SEXTB_MSPON = 1;


SEXTF_MARK

Declaration

Source position: serial.pas line 122

const SEXTF_MARK = 1 shl SEXTB_MARK;


SEXTF_MSPON

Declaration

Source position: serial.pas line 120

const SEXTF_MSPON = 1 shl SEXTB_MSPON;


TIOExtSer

Declaration

Source position: serial.pas line 47

type TIOExtSer = record

  IOSer: TIOStdReq;

  io_CtlChar: LongWord;

  io_RBufLen: LongWord;

  io_ExtFlags: LongWord;

  io_Baud: LongWord;

  io_BrkTime: LongWord;

  io_TermArray: TIOTArray;

  io_ReadLen: Byte;

  io_WriteLen: Byte;

  io_StopBits: Byte;

  io_SerFlags: Byte;

  io_Status: Word;

end;


TIOTArray

Declaration

Source position: serial.pas line 29

type TIOTArray = record

  TermArray0: LongWord;

  TermArray1: LongWord;

end;


Reference for unit 'timer'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'timer': Constants

TIMERNAME

TR_ADDREQUEST

TR_GETSYSTIME

TR_SETSYSTIME

UNIT_CPUCLOCK

UNIT_ECLOCK

UNIT_MICROHZ

UNIT_VBLANK

UNIT_WAITCPUCLOCK

UNIT_WAITECLOCK

UNIT_WAITUNTIL


Reference for unit 'timer': Types

PEClockVal

PTimeRequest

PTimeVal

TEClockVal

TTimeRequest

TTimeVal


PEClockVal

Declaration

Source position: timer.pas line 57

type PEClockVal = ^TEClockVal;


PTimeRequest

Declaration

Source position: timer.pas line 64

type PTimeRequest = ^TTimeRequest;


PTimeVal

Declaration

Source position: timer.pas line 50

type PTimeVal = ^TTimeVal;


TEClockVal

Declaration

Source position: timer.pas line 58

type TEClockVal = packed record

  ev_hi: DWord;

  ev_lo: DWord;

end;


TimerBase

Declaration

Source position: timer.pas line 27

var TimerBase: Pointer;


TIMERNAME

Declaration

Source position: timer.pas line 46

const TIMERNAME = 'timer.device';


TR_ADDREQUEST

Declaration

Source position: timer.pas line 72

const TR_ADDREQUEST = CMD_NONSTD;


TR_GETSYSTIME

Declaration

Source position: timer.pas line 73

const TR_GETSYSTIME = CMD_NONSTD + 1;


TR_SETSYSTIME

Declaration

Source position: timer.pas line 74

const TR_SETSYSTIME = CMD_NONSTD + 2;


TTimeRequest

Declaration

Source position: timer.pas line 65

type TTimeRequest = packed record

  tr_node: TIORequest;

  tr_time: TTimeVal;

end;


TTimeVal

Declaration

Source position: timer.pas line 51

type TTimeVal = packed record

  tv_secs: DWord;

  tv_micro: DWord;

end;


UNIT_CPUCLOCK

Declaration

Source position: timer.pas line 42

const UNIT_CPUCLOCK = 5;


UNIT_ECLOCK

Declaration

Source position: timer.pas line 38

const UNIT_ECLOCK = 2;


UNIT_MICROHZ

Declaration

Source position: timer.pas line 36

const UNIT_MICROHZ = 0;


UNIT_VBLANK

Declaration

Source position: timer.pas line 37

const UNIT_VBLANK = 1;


UNIT_WAITCPUCLOCK

Declaration

Source position: timer.pas line 43

const UNIT_WAITCPUCLOCK = 6;


UNIT_WAITECLOCK

Declaration

Source position: timer.pas line 40

const UNIT_WAITECLOCK = 4;


UNIT_WAITUNTIL

Declaration

Source position: timer.pas line 39

const UNIT_WAITUNTIL = 3;


Reference for unit 'tinygl'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Unit 'tinygl' | Package
[Overview][Constants][Procedures and functions][Variables][Index] | [#morphunits]

Reference for unit 'tinygl': Constants

TINYGLNAME


tglContext

Declaration

Source position: tinygl.pas line 33

var tglContext: Pointer = Nil;


TinyGLBase

Declaration

Source position: tinygl.pas line 32

var TinyGLBase: Pointer = Nil;


TINYGLNAME

Declaration

Source position: tinygl.pas line 29

const TINYGLNAME: PChar = 'tinygl.library';


ANO_Flags

Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)

Declaration

Source position: utility.pas line 82

const ANO_Flags = 4003;

Description

This allows you to initialize the value of the NameSpace flags which control certain aspects of the NameSpace.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


ANO_NameSpace

Tag for AllocNamedObjectA(). Tag to define namespace

Declaration

Source position: utility.pas line 79

const ANO_NameSpace = 4000;

Description

Allocate a NameSpace for this NamedObject. This will allow you to link other NamedObjects into a group. You cannot add a NamedObject with a NameSpace to another NameSpace. Boolean, default is False.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


ANO_Priority

Tag for AllocNamedObjectA(). Tag to define priority

Declaration

Source position: utility.pas line 81

const ANO_Priority = 4002;

Description

This is the List priority of the NamedObject and should be a ShortInt value between -128 and 127. This is taken into account in adding and finding NamedObjects, as the highest priority NamedObject will be returned first. The default value is 0.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


ANO_UserSpace

Tag for AllocNamedObjectA(). Taf to define userspace

Declaration

Source position: utility.pas line 80

const ANO_UserSpace = 4001;

Description

This tag says that you want extra memory allocated for a UserSpace. The ti_Data field of this TagItem contains the amount of memory to allocate. Specifying this Tag with a ti_Data of 0, is equivalent to the default, which is no UserSpace. The UserSpace address can be found in the no_Object field of the NamedObject structure.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


Reference for unit 'utility'

Tag Handling, Date routines in utility.library

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'utility': Constants

ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)
ANO_NameSpace | Tag for AllocNamedObjectA(). Tag to define namespace
ANO_Priority | Tag for AllocNamedObjectA(). Tag to define priority
ANO_UserSpace | Tag for AllocNamedObjectA(). Taf to define userspace
MAP_KEEP_NOT_FOUND | Mapping types for use with MapTags() keep tags that aren't in mapList
MAP_REMOVE_NOT_FOUND | Mapping types for use with MapTags() remove tags that aren't in mapList
NSB_CASE | Flag bit for ANO_Flags Default to caseless
NSB_NODUPS | Flag bit for ANO_Flags Default allow duplicates
NSF_CASE | Flag value for ANO_Flags Default to caseless
NSF_NODUPS | Flag value for ANO_Flags Default allow duplicates
PKCTRL_BIT |
PKCTRL_BYTE |
PKCTRL_FLIPBIT |
PKCTRL_LONG |
PKCTRL_PACKONLY |
PKCTRL_PACKUNPACK |
PKCTRL_UBYTE |
PKCTRL_ULONG |
PKCTRL_UNPACKONLY |
PKCTRL_UWORD |
PKCTRL_WORD |
PSTB_EXISTS | Control bit for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack
PSTB_PACK | Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...
PSTB_SIGNED | Control bit for PackStructureTags/UnpackStructureTags.
PSTB_UNPACK | Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...
PSTF_EXISTS | Control value for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack
PSTF_PACK | Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...
PSTF_SIGNED | Control value for PackStructureTags/UnpackStructureTags.
PSTF_UNPACK | Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...
TAGFILTER_AND | Tag filter logic specifiers for use with FilterTagItems() exclude everything but filter hits
TAGFILTER_NOT | Tag filter logic specifiers for use with FilterTagItems() exclude only filter hits
TAG_DONE | Tag terminate the array of TagItems.ti_Data unused
TAG_END | Tag terminate the array of TagItems.ti_Data unused
TAG_IGNORE | Ignore this item, not end of array
TAG_MORE | ti_Data is pointer to another array of TagItems note that this tag terminates the current array
TAG_SKIP | Skip this and the next ti_Data items
TAG_USER |
UtilityName


Reference for unit 'utility': Types

PClockData | Pointer to timing informations
PHook | Pointer to a callback function
PNamedObject | Pointer to named object structure
PPTagItem |
PTag |
PTagItem |
PUtilityBase | Pointer to utility libbase
LongWord |
TClockData | Structure to hold timing informations
THook | Hook function structure
TNamedObject | Named object structure
TTagItem |
TUtilityBase | Utility libbase


MAP_KEEP_NOT_FOUND

Mapping types for use with MapTags() keep tags that aren't in mapList

Declaration

Source position: utility.pas line 69

const MAP_KEEP_NOT_FOUND = 1;


MAP_REMOVE_NOT_FOUND

Mapping types for use with MapTags() remove tags that aren't in mapList

Declaration

Source position: utility.pas line 68

const MAP_REMOVE_NOT_FOUND = 0;


NSB_CASE

Flag bit for ANO_Flags Default to caseless

Declaration

Source position: utility.pas line 85

const NSB_CASE = 1;

See also

NSF_CASE

Flag value for ANO_Flags Default to caseless


NSB_NODUPS

Flag bit for ANO_Flags Default allow duplicates

Declaration

Source position: utility.pas line 84

const NSB_NODUPS = 0;

See also

NSF_NODUPS

Flag value for ANO_Flags Default allow duplicates


NSF_CASE

Flag value for ANO_Flags Default to caseless

Declaration

Source position: utility.pas line 88

const NSF_CASE = 1 shl NSB_CASE;

See also

ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


NSF_NODUPS

Flag value for ANO_Flags Default allow duplicates

Declaration

Source position: utility.pas line 87

const NSF_NODUPS = 1 shl NSB_NODUPS;

See also

ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


PClockData

Pointer to timing informations

Declaration

Source position: utility.pas line 31

type PClockData = ^TClockData;

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
Date2Amiga | Calculate seconds from 01-Jan-1978.
CheckDate | Checks a ClockData structure for legal date.


PHook

Pointer to a callback function

Declaration

Source position: utility.pas line 152

type PHook = ^THook;


PKCTRL_BIT

Declaration

Source position: utility.pas line 115

const PKCTRL_BIT = $18000000;


PKCTRL_BYTE

Declaration

Source position: utility.pas line 107

const PKCTRL_BYTE = $80000000;


PKCTRL_FLIPBIT

Declaration

Source position: utility.pas line 116

const PKCTRL_FLIPBIT = $98000000;


PKCTRL_LONG

Declaration

Source position: utility.pas line 109

const PKCTRL_LONG = $90000000;


PKCTRL_PACKONLY

Declaration

Source position: utility.pas line 104

const PKCTRL_PACKONLY = $40000000;


PKCTRL_PACKUNPACK

Declaration

Source position: utility.pas line 103

const PKCTRL_PACKUNPACK = $00000000;


PKCTRL_UBYTE

Declaration

Source position: utility.pas line 111

const PKCTRL_UBYTE = $00000000;


PKCTRL_ULONG

Declaration

Source position: utility.pas line 113

const PKCTRL_ULONG = $10000000;


PKCTRL_UNPACKONLY

Declaration

Source position: utility.pas line 105

const PKCTRL_UNPACKONLY = $20000000;


PKCTRL_UWORD

Declaration

Source position: utility.pas line 112

const PKCTRL_UWORD = $08000000;


PKCTRL_WORD

Declaration

Source position: utility.pas line 108

const PKCTRL_WORD = $88000000;


PNamedObject

Pointer to named object structure

Declaration

Source position: utility.pas line 73

type PNamedObject = ^TNamedObject;

See also

AddNamedObject | Add a named object to the given namespace.
RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AttemptRemNamedObject | Attempt to remove a named object.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


PPTagItem

Declaration

Source position: utility.pas line 48

type PPTagItem = ^Pointer;


PSTB_EXISTS

Control bit for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack

Declaration

Source position: utility.pas line 95

const PSTB_EXISTS = 26;


PSTB_PACK

Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 94

const PSTB_PACK = 29;


PSTB_SIGNED

Control bit for PackStructureTags/UnpackStructureTags.

Declaration

Source position: utility.pas line 92

const PSTB_SIGNED = 31;


PSTB_UNPACK

Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 93

const PSTB_UNPACK = 30;


PSTF_EXISTS

Control value for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack

Declaration

Source position: utility.pas line 100

const PSTF_EXISTS = 1 shl PSTB_EXISTS;


PSTF_PACK

Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 99

const PSTF_PACK = 1 shl PSTB_PACK;


PSTF_SIGNED

Control value for PackStructureTags/UnpackStructureTags.

Declaration

Source position: utility.pas line 97

const PSTF_SIGNED = 1 shl PSTB_SIGNED;


PSTF_UNPACK

Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 98

const PSTF_UNPACK = 1 shl PSTB_UNPACK;


Unit 'utility' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

PTag

Declaration

Source position: utility.pas line 46

type PTag = ^LongWord;


PTagItem

Declaration

Source position: utility.pas line 49

type PTagItem = ^TTagItem;


PUtilityBase

Pointer to utility libbase

Declaration

Source position: utility.pas line 143

type PUtilityBase = ^TUtilityBase;


Unit 'utility' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#morphunits]

Tag

Declaration

Source position: utility.pas line 45

type Tag = LongWord;


TAGFILTER_AND

Tag filter logic specifiers for use with FilterTagItems() exclude everything but filter hits

Declaration

Source position: utility.pas line 65

const TAGFILTER_AND = 0;


TAGFILTER_NOT

Tag filter logic specifiers for use with FilterTagItems() exclude only filter hits

Declaration

Source position: utility.pas line 66

const TAGFILTER_NOT = 1;


TClockData

Structure to hold timing informations

Declaration

Source position: utility.pas line 32

type TClockData = packed record
Sec: Word; | Seconds
Min: Word; | Minutes
Hour: Word; | Hour
MDay: Word; | Day
Month: Word; | Month
Year: Word; | Year
WDay: Word; | Weekday
end;

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
Date2Amiga | Calculate seconds from 01-Jan-1978.
CheckDate | Checks a ClockData structure for legal date.


THook

Hook function structure

Declaration

Source position: utility.pas line 153

type THook = packed record
h_MinNode: TMinNode; |
h_Entry: Pointer; | Main entry point.
h_SubEntry: Pointer; | Secondary entry point
h_Data: Pointer; | Owner specific data
end;

See also

CallHookPkt

Invoke a Hook function callback.


TNamedObject

Named object structure

Declaration

Source position: utility.pas line 74

type TNamedObject = packed record

  no_Object: Pointer;

Your pointer, for whatever you want

end;

See also

AddNamedObject | Add a named object to the given namespace.
RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AttemptRemNamedObject | Attempt to remove a named object.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


TTagItem

Declaration

Source position: utility.pas line 50

type TTagItem = packed record

  ti_Tag: LongWord;

  ti_Data: LongWord;

end;


TUtilityBase

Utility libbase

Declaration

Source position: utility.pas line 144

type TUtilityBase = packed record
ub_LibNode: TLibrary; | Standard libbase
ub_Language: Byte; | Language identifier
ub_Reserved: Byte; | Reserverd
end;


UtilityBase

Declaration

Source position: utility.pas line 27

var UtilityBase: Pointer;


UtilityName

Declaration

Source position: utility.pas line 139

const UtilityName = 'utility.library';


ADZMACTION_Enter

Action for adzm_Action, Something entered the AppItem

Declaration

Source position: workbench.pas line 350

const ADZMACTION_Enter = 0;


ADZMACTION_Leave

Action for adzm_Action, Something left the AppItem

Declaration

Source position: workbench.pas line 351

const ADZMACTION_Leave = 1;


AM_VERSION

If you find TAppMessage.am_Version >= AM_VERSION, you know this structure has at least the fields defined in this version of the include file

Declaration

Source position: workbench.pas line 133

const AM_VERSION = 1;


AMCLASSICON_Copy

Class for TAppMessage.am_Class. The "Copy" menu item was invoked

Declaration

Source position: workbench.pas line 163

const AMCLASSICON_Copy = 1;


AMCLASSICON_Delete

Class for TAppMessage.am_Class. The "Delete" menu item was invoked

Declaration

Source position: workbench.pas line 170

const AMCLASSICON_Delete = 8;


AMCLASSICON_EmptyTrash

Class for TAppMessage.am_Class. The "Empty Trash" menu item was invoked

Declaration

Source position: workbench.pas line 172

const AMCLASSICON_EmptyTrash = 10;


AMCLASSICON_FormatDisk

Class for TAppMessage.am_Class. The "Format Disk" menu item was invoked

Declaration

Source position: workbench.pas line 171

const AMCLASSICON_FormatDisk = 9;


AMCLASSICON_Information

Class for TAppMessage.am_Class. The "Information" menu item was invoked

Declaration

Source position: workbench.pas line 165

const AMCLASSICON_Information = 3;


AMCLASSICON_LeaveOut

Class for TAppMessage.am_Class. The "Leave Out" menu item was invoked

Declaration

Source position: workbench.pas line 168

const AMCLASSICON_LeaveOut = 6;


AMCLASSICON_Open

Class for TAppMessage.am_Class. The "Open" menu item was invoked, the icon got double-clicked or an icon got dropped on it.

Declaration

Source position: workbench.pas line 162

const AMCLASSICON_Open = 0;


AMCLASSICON_PutAway

Class for TAppMessage.am_Class. The "Put Away" menu item was invoked

Declaration

Source position: workbench.pas line 169

const AMCLASSICON_PutAway = 7;


AMCLASSICON_Rename

Class for TAppMessage.am_Class. The "Rename" menu item was invoked

Declaration

Source position: workbench.pas line 164

const AMCLASSICON_Rename = 2;


AMCLASSICON_Selected

Class for TAppMessage.am_Class. The icon is now selected

Declaration

Source position: workbench.pas line 174

const AMCLASSICON_Selected = 11;


AMCLASSICON_Snapshot

Class for TAppMessage.am_Class. The "Snapshot" menu item was invoked

Declaration

Source position: workbench.pas line 166

const AMCLASSICON_Snapshot = 4;


AMCLASSICON_Unselected

Class for TAppMessage.am_Class. The icon is now unselected

Declaration

Source position: workbench.pas line 175

const AMCLASSICON_Unselected = 12;


AMCLASSICON_UnSnapshot

Class for TAppMessage.am_Class. The "UnSnapshot" menu item was invoked

Declaration

Source position: workbench.pas line 167

const AMCLASSICON_UnSnapshot = 5;


AMTYPE_APPICON

Type for TAppMessage.am_Type, App icon message

Declaration

Source position: workbench.pas line 157

const AMTYPE_APPICON = 8;


AMTYPE_APPMENUITEM

Type for TAppMessage.am_Type, App menu item message

Declaration

Source position: workbench.pas line 158

const AMTYPE_APPMENUITEM = 9;


AMTYPE_APPWINDOW

Type for TAppMessage.am_Type, App window message

Declaration

Source position: workbench.pas line 156

const AMTYPE_APPWINDOW = 7;


AMTYPE_APPWINDOWZONE

Declaration

Source position: workbench.pas line 159

const AMTYPE_APPWINDOWZONE = 10;


CPACTION_Begin

Defines MessageType (cbm_Action) as PCopyBeginMsg

Declaration

Source position: workbench.pas line 410

const CPACTION_Begin = 0;


CPACTION_Copy

Defines MessageType (cdm_Action) as PCopyDataMsg

Declaration

Source position: workbench.pas line 411

const CPACTION_Copy = 1;

Description

This message arrives for each file or drawer to be copied.


CPACTION_End

Defines MessageType (cem_Action) as PCopyEndMsg

Declaration

Source position: workbench.pas line 412

const CPACTION_End = 2;

Description

This message arrives when all files/drawers have been copied.


DDFLAGS_SHOWALL

Flags for TDrawerData.dd_Flags Show all files

Declaration

Source position: workbench.pas line 93

const DDFLAGS_SHOWALL = 2;


DDFLAGS_SHOWDEFAULT

Flags for TDrawerData.dd_Flags Default (show only icons)

Declaration

Source position: workbench.pas line 91

const DDFLAGS_SHOWDEFAULT = 0;


DDFLAGS_SHOWICONS

Flags for TDrawerData.dd_Flags Show only icons

Declaration

Source position: workbench.pas line 92

const DDFLAGS_SHOWICONS = 1;


DDVM_BYDATE

View mode for TDrawerData.dd_ViewModes View as text, sorted by date

Declaration

Source position: workbench.pas line 86

const DDVM_BYDATE = 3;


DDVM_BYDEFAULT

View mode for TDrawerData.dd_ViewModes Default (inherit parent's view mode)

Declaration

Source position: workbench.pas line 83

const DDVM_BYDEFAULT = 0;


DDVM_BYICON

View mode for TDrawerData.dd_ViewModes View as icons

Declaration

Source position: workbench.pas line 84

const DDVM_BYICON = 1;


DDVM_BYNAME

View mode for TDrawerData.dd_ViewModes View as text, sorted by name

Declaration

Source position: workbench.pas line 85

const DDVM_BYNAME = 2;


DDVM_BYSIZE

View mode for TDrawerData.dd_ViewModes View as text, sorted by size

Declaration

Source position: workbench.pas line 87

const DDVM_BYSIZE = 4;


DDVM_BYTYPE

View mode for TDrawerData.dd_ViewModes View as text, sorted by type

Declaration

Source position: workbench.pas line 88

const DDVM_BYTYPE = 5;


DLACTION_BeginDiscard

Defined Messagetype .dbm_Action as PDeleteBeginMsg

Declaration

Source position: workbench.pas line 437

const DLACTION_BeginDiscard = 0;


DLACTION_BeginEmptyTrash

Defined Messagetype .dbm_Action as PDeleteBeginMsg

Declaration

Source position: workbench.pas line 438

const DLACTION_BeginEmptyTrash = 1;

Description

This indicates that the following delete operations are intended to empty the trashcan.


DLACTION_DeleteContents

Defined Messagetype .ddm_Action as PDeleteDataMsg

Declaration

Source position: workbench.pas line 439

const DLACTION_DeleteContents = 3;

Description

This indicates that the object described by lock and name refers to a drawer; you should empty its contents but do not delete the drawer itself!


DLACTION_DeleteObject

Defined Messagetype .ddm_Action as PDeleteDataMsg

Declaration

Source position: workbench.pas line 440

const DLACTION_DeleteObject = 4;

Description

This indicates that the object described by lock and name should be deleted; this could be a file or an empty drawer.


DLACTION_End

Defined Messagetype .dem_Action as PDeleteEndMsg

Declaration

Source position: workbench.pas line 441

const DLACTION_End = 5;

Description

This indicates that the deletion process is finished.


DRAWERDATAFILESIZE

the amount of DrawerData actually written to disk

Declaration

Source position: workbench.pas line 80

const DRAWERDATAFILESIZE = SizeOf(TDrawerData);

See also

TDrawerData | New Structure to describe the view of the content of a drawer
TDiskObject | Representation of an *.info file


GADGBACKFILL

Declaration

Source position: workbench.pas line 129

const GADGBACKFILL = GFLG_GADGBACKFILL;


GFLG_GADGBACKFILL

Declaration

Source position: workbench.pas line 128

const GFLG_GADGBACKFILL = $0001;


Reference for unit 'workbench'

Basic Workbench/AppIcons functions (workbench.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
AmigaDOS, | File and directory handling routines and types (dos.library)
utility, | Tag Handling, Date routines in utility.library
intuition, | Screen and Window handling routines of intuition.library
agraphics; | Native Amiga graphic functions (graphics.library)

Overview

Function related AppIcons, AppWindows, AppMenuitems and other Workbench display structures are located in this unit.


Reference for unit 'workbench': Constants

ADZMACTION_Enter | Action for adzm_Action, Something entered the AppItem
ADZMACTION_Leave | Action for adzm_Action, Something left the AppItem
AMCLASSICON_Copy | Class for TAppMessage.am_Class. The "Copy" menu item was invoked
AMCLASSICON_Delete | Class for TAppMessage.am_Class. The "Delete" menu item was invoked
AMCLASSICON_EmptyTrash | Class for TAppMessage.am_Class. The "Empty Trash" menu item was invoked
AMCLASSICON_FormatDisk | Class for TAppMessage.am_Class. The "Format Disk" menu item was invoked
AMCLASSICON_Information | Class for TAppMessage.am_Class. The "Information" menu item was invoked
AMCLASSICON_LeaveOut | Class for TAppMessage.am_Class. The "Leave Out" menu item was invoked
AMCLASSICON_Open | Class for TAppMessage.am_Class. The "Open" menu item was invoked, the icon got double-clicked or an icon got dropped on it.
AMCLASSICON_PutAway | Class for TAppMessage.am_Class. The "Put Away" menu item was invoked
AMCLASSICON_Rename | Class for TAppMessage.am_Class. The "Rename" menu item was invoked
AMCLASSICON_Selected | Class for TAppMessage.am_Class. The icon is now selected
AMCLASSICON_Snapshot | Class for TAppMessage.am_Class. The "Snapshot" menu item was invoked
AMCLASSICON_Unselected | Class for TAppMessage.am_Class. The icon is now unselected
AMCLASSICON_UnSnapshot | Class for TAppMessage.am_Class. The "UnSnapshot" menu item was invoked
AMTYPE_APPICON | Type for TAppMessage.am_Type, App icon message
AMTYPE_APPMENUITEM | Type for TAppMessage.am_Type, App menu item message
AMTYPE_APPWINDOW | Type for TAppMessage.am_Type, App window message
AMTYPE_APPWINDOWZONE
AM_VERSION | If you find TAppMessage.am_Version >= AM_VERSION, you know this structure has at least the fields defined in this version of the include file
CPACTION_Begin | Defines MessageType (cbm_Action) as PCopyBeginMsg
CPACTION_Copy | Defines MessageType (cdm_Action) as PCopyDataMsg
CPACTION_End | Defines MessageType (cem_Action) as PCopyEndMsg
DDFLAGS_SHOWALL | Flags for TDrawerData.dd_Flags Show all files
DDFLAGS_SHOWDEFAULT | Flags for TDrawerData.dd_Flags Default (show only icons)
DDFLAGS_SHOWICONS | Flags for TDrawerData.dd_Flags Show only icons
DDVM_BYDATE | View mode for TDrawerData.dd_ViewModes View as text, sorted by date
DDVM_BYDEFAULT | View mode for TDrawerData.dd_ViewModes Default (inherit parent's view mode)
DDVM_BYICON | View mode for TDrawerData.dd_ViewModes View as icons
DDVM_BYNAME | View mode for TDrawerData.dd_ViewModes View as text, sorted by name
DDVM_BYSIZE | View mode for TDrawerData.dd_ViewModes View as text, sorted by size
DDVM_BYTYPE | View mode for TDrawerData.dd_ViewModes View as text, sorted by type
DLACTION_BeginDiscard | Defined Messagetype .dbm_Action as PDeleteBeginMsg
DLACTION_BeginEmptyTrash | Defined Messagetype .dbm_Action as PDeleteBeginMsg
DLACTION_DeleteContents | Defined Messagetype .ddm_Action as PDeleteDataMsg
DLACTION_DeleteObject | Defined Messagetype .ddm_Action as PDeleteDataMsg
DLACTION_End | Defined Messagetype .dem_Action as PDeleteEndMsg
DRAWERDATAFILESIZE | the amount of DrawerData actually written to disk
GADGBACKFILL |
GFLG_GADGBACKFILL |
ISMACTION_Ignore | This value your hook code can return when the icon state should not be changed.
ISMACTION_Select | This value your hook code can return when the should be selected.
ISMACTION_Stop | This value your hook code can return when the icon state should not be changed and invoke the hook again.
ISMACTION_Unselect | This value your hook code can return when the icon should be unselected.
NO_ICON_POSITION | Icon without a fixed position has this Value
OLDDRAWERDATAFILESIZE | The amount of OldDrawerData actually written to disk
SCHMSTATE_Cleanup | State for .schm_State. Workbench will really shut down now.
SCHMSTATE_Setup | State for .schm_State. Workbench is operational again or could not be shut down.
SCHMSTATE_TryCleanup | State for .schm_State. Workbench will attempt to shut down now.
TIACTION_Execute |
TIACTION_NewDrawer |
TIACTION_RelabelVolume |
TIACTION_Rename |
UPDATEWB_ObjectAdded |
UPDATEWB_ObjectRemoved |
WBAPPICON | Type of Icon: AppIcon
WBAPPICONA_Clone
WBAPPICONA_NotifySelectState |
WBAPPICONA_PropagatePosition |
WBAPPICONA_RenderHook |
WBAPPICONA_SupportsCopy |
WBAPPICONA_SupportsDelete |
WBAPPICONA_SupportsEmptyTrash |
WBAPPICONA_SupportsFormatDisk |
WBAPPICONA_SupportsInformation |
WBAPPICONA_SupportsLeaveOut |
WBAPPICONA_SupportsOpen |
WBAPPICONA_SupportsPutAway |
WBAPPICONA_SupportsRename |
WBAPPICONA_SupportsSnapshot |
WBAPPICONA_SupportsUnSnapshot |
WBAPPMENUA_CommandKeyString |
WBAPPMENUA_GetKey |
WBAPPMENUA_GetTitleKey |
WBAPPMENUA_UseKey |
WBA_Dummy |
WBA_LAST_TAG |
WBA_Reserved1 |
WBA_Reserved10 |
WBA_Reserved11 |
WBA_Reserved12 |
WBA_Reserved13 |
WBA_Reserved14 |
WBA_Reserved15 |
WBA_Reserved16 |
WBA_Reserved17 |
WBA_Reserved18 |
WBA_Reserved19 |
WBA_Reserved2 |
WBA_Reserved3 |
WBA_Reserved4 |
WBA_Reserved5 |
WBA_Reserved6 |
WBA_Reserved7 |
WBA_Reserved8 |
WBA_Reserved9 |
WBCTRLA_AddHiddenDeviceName |
WBCTRLA_AddSetupCleanupHook |
WBCTRLA_DuplicateSearchPath |
WBCTRLA_FreeHiddenDeviceList |
WBCTRLA_FreeOpenDrawerList |
WBCTRLA_FreeProgramList |
WBCTRLA_FreeSearchPath |
WBCTRLA_FreeSelectedIconList |
WBCTRLA_GetCopyHook |
WBCTRLA_GetDefaultStackSize |
WBCTRLA_GetDeleteHook |
WBCTRLA_GetHiddenDeviceList |
WBCTRLA_GetOpenDrawerList |
WBCTRLA_GetProgramList |
WBCTRLA_GetSelectedIconList |
WBCTRLA_GetTextInputHook |
WBCTRLA_GetTypeRestartTime |
WBCTRLA_IsOpen |
WBCTRLA_RedrawAppIcon |
WBCTRLA_RemoveHiddenDeviceName |
WBCTRLA_RemSetupCleanupHook |
WBCTRLA_SetCopyHook |
WBCTRLA_SetDefaultStackSize |
WBCTRLA_SetDeleteHook |
WBCTRLA_SetTextInputHook |
WBCTRLA_SetTypeRestartTime |
WBDEVICE | Type of Icon: Device
WBDISK | Type of Icon: Disk
WBDRAWER | Type of Icon: Drawer/Folder
WBDZA_Box |
WBDZA_Height |
WBDZA_Hook |
WBDZA_Left |
WBDZA_RelBottom |
WBDZA_RelHeight |
WBDZA_RelRight |
WBDZA_RelWidth |
WBDZA_Top |
WBDZA_Width |
WBGARBAGE | Type of Icon: Trashcan
WBKICK | Type of Icon: KickStart disk
WBOPENA_ArgLock |
WBOPENA_ArgName |
WBOPENA_Show |
WBOPENA_ViewBy |
WBPROJECT | Type of Icon: Project (Data file)
WBTOOL | Type of Icon: Tool (Excutable)
WB_DISKMAGIC | A magic number, not easily impersonated
WB_DISKREVISION | Our current revision number
WB_DISKREVISIONMASK | We only use the lower 8 bits of Gadget.UserData for the revision #
WB_DISKVERSION | Our current version number
WORKBENCHNAME |


Reference for unit 'workbench': Types

PAppIcon |
PAppIconRenderMsg | The message your AppIcon rendering hook gets invoked with.
PAppMenu |
PAppMenuItem |
PAppMessage | Pointer to an Message from a AppWindow, AppIcon or AppMenuItem
PAppWindow |
PAppWindowDropZone |
PAppWindowDropZoneMsg | The message your drop zone hook gets invoked with.
PCopyBeginMsg | A message your copy hook is invoked with.
PCopyDataMsg | A message your copy hook is invoked with.
PCopyEndMsg | A message your copy hook is invoked with.
PDeleteBeginMsg | A Message your delete hook is invoked with.
PDeleteDataMsg | A Message your delete hook is invoked with.
PDeleteEndMsg | A Message your delete hook is invoked with.
PDiskObject |
PDrawerData | Pointer to Drawer structure
PFreeList | Memory management in the icon.library
PIconSelectMsg | The message your icon selection change hook is invoked with.
POldDrawerData | Pointer to OldDrawer structure
PSetupCleanupHookMsg | The message your setup/cleanup hook gets invoked with.
PTextInputMsg |
PWBArg | Pointer to an Workbench argument
PWBArgList |
PWBStartup |
TAppIcon |
TAppIconRenderMsg | The message your AppIcon rendering hook gets invoked with.
TAppMenu |
TAppMenuItem |
TAppMessage | Message from a AppWindow, AppIcon or AppMenuItem
TAppWindow |
TAppWindowDropZone |
TAppWindowDropZoneMsg | The message your drop zone hook gets invoked with.
TCopyBeginMsg | A message your copy hook is invoked with.
TCopyDataMsg | A message your copy hook is invoked with.
TCopyEndMsg | A message your copy hook is invoked with.
TDeleteBeginMsg | A Message your delete hook is invoked with.
TDeleteDataMsg | A Message your delete hook is invoked with.
TDeleteEndMsg | A Message your delete hook is invoked with.
TDiskObject | Representation of an *.info file
TDrawerData | New Structure to describe the view of the content of a drawer
TFreeList | Memory management in the icon.library
TIconSelectMsg | The message your icon selection change hook is invoked with.
TOldDrawerData | Old Structure to describe the view of the content of a drawer (pre AmigaOS V36)
TSetupCleanupHookMsg | The message your setup/cleanup hook gets invoked with.
TTextInputMsg |
TWBArg | Workbech argument list entry
TWBStartup |
WBArgList | Helper for TWBStartUP


ISMACTION_Ignore

This value your hook code can return when the icon state should not be changed.

Declaration

Source position: workbench.pas line 376

const ISMACTION_Ignore = 2;


ISMACTION_Select

This value your hook code can return when the should be selected.

Declaration

Source position: workbench.pas line 375

const ISMACTION_Select = 1;


ISMACTION_Stop

This value your hook code can return when the icon state should not be changed and invoke the hook again.

Declaration

Source position: workbench.pas line 377

const ISMACTION_Stop = 3;


ISMACTION_Unselect

This value your hook code can return when the icon should be unselected.

Declaration

Source position: workbench.pas line 374

const ISMACTION_Unselect = 0;


NO_ICON_POSITION

Icon without a fixed position has this Value

Declaration

Source position: workbench.pas line 131

const NO_ICON_POSITION = $80000000;


OLDDRAWERDATAFILESIZE

The amount of OldDrawerData actually written to disk

Declaration

Source position: workbench.pas line 66

const OLDDRAWERDATAFILESIZE = SizeOf(TOldDrawerData);

See also

TOldDrawerData

Old Structure to describe the view of the content of a drawer (pre AmigaOS V36)


PAppIcon

Declaration

Source position: workbench.pas line 189

type PAppIcon = ^TAppIcon;


PAppIconRenderMsg

The message your AppIcon rendering hook gets invoked with.

Declaration

Source position: workbench.pas line 325

type PAppIconRenderMsg = ^TAppIconRenderMsg;


PAppMenu

Declaration

Source position: workbench.pas line 199

type PAppMenu = ^TAppMenu;


PAppMenuItem

Declaration

Source position: workbench.pas line 194

type PAppMenuItem = ^TAppMenuItem;


PAppMessage

Pointer to an Message from a AppWindow, AppIcon or AppMenuItem

Declaration

Source position: workbench.pas line 136

type PAppMessage = ^TAppMessage;


PAppWindow

Declaration

Source position: workbench.pas line 179

type PAppWindow = ^TAppWindow;


PAppWindowDropZone

Declaration

Source position: workbench.pas line 184

type PAppWindowDropZone = ^TAppWindowDropZone;


PAppWindowDropZoneMsg

The message your drop zone hook gets invoked with.

Declaration

Source position: workbench.pas line 339

type PAppWindowDropZoneMsg = ^TAppWindowDropZoneMsg;


PCopyBeginMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 381

type PCopyBeginMsg = ^TCopyBeginMsg;


PCopyDataMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 389

type PCopyDataMsg = ^TCopyDataMsg;


PCopyEndMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 403

type PCopyEndMsg = ^TCopyEndMsg;


PDeleteBeginMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 416

type PDeleteBeginMsg = ^TDeleteBeginMsg;


PDeleteDataMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 422

type PDeleteDataMsg = ^TDeleteDataMsg;


PDeleteEndMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 430

type PDeleteEndMsg = ^TDeleteEndMsg;


PDiskObject

Declaration

Source position: workbench.pas line 96

type PDiskObject = ^TDiskObject;


PDrawerData

Pointer to Drawer structure

Declaration

Source position: workbench.pas line 69

type PDrawerData = ^TDrawerData;


PFreeList

Memory management in the icon.library

Declaration

Source position: workbench.pas line 118

type PFreeList = ^TFreeList;

See also

Icon.AddFreeList | Add memory to a free list.
Icon.FreeFreeList | Free all memory in a free list.


PIconSelectMsg

The message your icon selection change hook is invoked with.

Declaration

Source position: workbench.pas line 355

type PIconSelectMsg = ^TIconSelectMsg;


POldDrawerData

Pointer to OldDrawer structure

Declaration

Source position: workbench.pas line 57

type POldDrawerData = ^TOldDrawerData;


PSetupCleanupHookMsg

The message your setup/cleanup hook gets invoked with.

Declaration

Source position: workbench.pas line 311

type PSetupCleanupHookMsg = ^TSetupCleanupHookMsg;


PTextInputMsg

Declaration

Source position: workbench.pas line 445

type PTextInputMsg = ^TTextInputMsg;


PWBArg

Pointer to an Workbench argument

Declaration

Source position: workbench.pas line 27

type PWBArg = ^TWBArg;


PWBArgList

Declaration

Source position: workbench.pas line 34

type PWBArgList = ^WBArgList;


PWBStartup

Declaration

Source position: workbench.pas line 36

type PWBStartup = ^TWBStartup;


SCHMSTATE_Cleanup

State for .schm_State. Workbench will really shut down now.

Declaration

Source position: workbench.pas line 320

const SCHMSTATE_Cleanup = 1;


SCHMSTATE_Setup

State for .schm_State. Workbench is operational again or could not be shut down.

Declaration

Source position: workbench.pas line 321

const SCHMSTATE_Setup = 2;


SCHMSTATE_TryCleanup

State for .schm_State. Workbench will attempt to shut down now.

Declaration

Source position: workbench.pas line 319

const SCHMSTATE_TryCleanup = 0;


TAppIcon

Declaration

Source position: workbench.pas line 190

type TAppIcon = record

  ai_PRIVATE: Pointer;

end;


TAppIconRenderMsg

The message your AppIcon rendering hook gets invoked with.

Declaration

Source position: workbench.pas line 326

type TAppIconRenderMsg = record
arm_RastPort: PRastPort; | RastPort to render into
arm_Icon: PDiskObject; | The icon to be rendered
arm_Label: PChar; | The icon label txt
arm_Tags: PTagItem; | urther tags to be passed on to DrawIconStateA().
arm_Left: SmallInt; | Rendering origin, not taking the
arm_Top: SmallInt; | button border into account.
arm_Width: SmallInt; | Limit your rendering to
arm_Height: SmallInt; | this area.
arm_State: LongWord; | State of Icon (IDS_*)
end;


TAppMenu

Declaration

Source position: workbench.pas line 200

type TAppMenu = record

  am_PRIVATE: Pointer;

end;


TAppMenuItem

Declaration

Source position: workbench.pas line 195

type TAppMenuItem = record

  ami_PRIVATE: Pointer;

end;


TAppMessage

Message from a AppWindow, AppIcon or AppMenuItem

Declaration

Source position: workbench.pas line 137

type TAppMessage = record
am_Message: TMessage; | Standard message structure
am_Type: Word; | Message type (AMTYPE_*)
am_UserData: LongWord; | Application specific
am_ID: LongWord; | Application definable ID
am_NumArgs: LongInt; | Number of elements in arglist
am_ArgList: PWBArgList; | The arguements themselves
am_Version: Word; | Will be AM_VERSION
am_Class: Word; | Message class (AMCLASSICON_*)
am_MouseX: SmallInt; | Mouse x position of event
am_MouseY: SmallInt; | Mouse y position of event
am_Seconds: LongWord; | Current system clock time
am_Micros: LongWord; | Current system clock time
am_Reserved: array [0..7] of LongWord; | Avoid recompilation
end;


TAppWindow

Declaration

Source position: workbench.pas line 180

type TAppWindow = record

  aw_PRIVATE: Pointer;

end;


TAppWindowDropZone

Declaration

Source position: workbench.pas line 185

type TAppWindowDropZone = record

  awdz_PRIVATE: Pointer;

end;


TAppWindowDropZoneMsg

The message your drop zone hook gets invoked with.

Declaration

Source position: workbench.pas line 340

type TAppWindowDropZoneMsg = record
adzm_RastPort: PRastPort; | RastPort to render into.
adzm_DropZoneBox: TIBox; | Limit your rendering to this area.
adzm_ID: LongWord; | This is the ID straight from AddAppWindowDropZoneA().
adzm_UserData: LongWord; | This is the UserData straight from AddAppWindowDropZoneA().
adzm_Action: LongInt; | Action was done. ADZMACTION_Enter, ADZMACTION_Leave
end;


TCopyBeginMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 382

type TCopyBeginMsg = record
cbm_Length: LongWord; | Size of this data structure in bytes.
cbm_Action: LongInt; | Will be set to CPACTION_Begin.
cbm_SourceDrawer: LongInt; | A lock on the source drawer.
cbm_DestinationDrawer: LongInt; | A lock on the destination drawer.
end;


TCopyDataMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 390

type TCopyDataMsg = record
cdm_Length: LongWord; | Size of this data structure in bytes.
cdm_Action: LongInt; | Will be set to CPACTION_Copy
cdm_SourceLock: LongInt; | A lock on the parent directory of the source file/drawer.
cdm_SourceName: PChar; | The name of the source file or drawer.
cdm_DestinationLock: LongInt; | A lock on the parent directory of the destination file/drawer.
cdm_DestinationName: PChar; | The name of the destination file/drawer. This may or may not match the name of the source file/drawer in case the data is to be copied under a different name. For example, this is the case with the Workbench "Copy" command which creates duplicates of file/drawers by prefixing the duplicate's name with "Copy_XXX_of".
cdm_DestinationX: LongInt; | When the icon corresponding to the
cdm_DestinationY: LongInt; | destination is written to disk, this is the position (put into its PDiskObject^.do_CurrentX/PDiskObject^.do_CurrentY fields) it should be placed at.
end;


TCopyEndMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 404

type TCopyEndMsg = record
cem_Length: LongWord; | Size of this data structure in bytes.
cem_Action: LongInt; | Will be set to either DLACTION_BeginDiscard or DLACTION_BeginEmptyTrash
end;


TDeleteBeginMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 417

type TDeleteBeginMsg = record
dbm_Length: LongWord; | Size of this data structure in bytes.
dbm_Action: LongInt; | Will be set to either DLACTION_BeginDiscard or DLACTION_BeginEmptyTrash
end;


TDeleteDataMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 423

type TDeleteDataMsg = record
ddm_Length: LongWord; | Size of this data structure in bytes.
ddm_Action: LongInt; | Will be set to either DLACTION_DeleteContents or DLACTION_DeleteObject
ddm_Lock: LongInt; | A Lock on the parent directory of the object whose contents or which itself should be deleted.
ddm_Name: PChar; | The name of the object whose contents or which itself should be deleted.
end;


TDeleteEndMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 431

type TDeleteEndMsg = record
dem_Length: LongWord; | Size of this data structure in bytes.
dem_Action: LongInt; | Will be set to DLACTION_End
end;


TDiskObject

Representation of an *.info file

Declaration

Source position: workbench.pas line 97

type TDiskObject = record
do_Magic: Word; | A magic number at the start of the file
do_Version: Word; | A version number, so we can change it
do_Gadget: TGadget; | A copy of in core gadget
do_Type: Byte; | Type for icons (WB*)
do_DefaultTool: PChar; |
do_ToolTypes: PPChar; | List of ToolTypes
do_CurrentX: LongInt; | Current X Position of Icon
do_CurrentY: LongInt; | Current Y Position of Icon
do_DrawerData: PDrawerData; |
do_ToolWindow: PChar; | Only applies to tools
do_StackSize: LongInt; | Only applies to tools
end;


TDrawerData

New Structure to describe the view of the content of a drawer

Declaration

Source position: workbench.pas line 70

type TDrawerData = record
dd_NewWindow: TNewWindow; | Args to open window
dd_CurrentX: LongInt; | Current x coordinate of origin
dd_CurrentY: LongInt; | Current y coordinate of origin
dd_Flags: LongInt; | Flags for drawer (DDFLAGS_*)
dd_ViewModes: Word; | View mode for drawer (DDVM_*)
end;

See also

DRAWERDATAFILESIZE

the amount of DrawerData actually written to disk


TFreeList

Memory management in the icon.library

Declaration

Source position: workbench.pas line 119

type TFreeList = record

  fl_NumFree: SmallInt;

  fl_MemList: TList;

end;

See also

Icon.AddFreeList | Add memory to a free list.
Icon.FreeFreeList | Free all memory in a free list.


TIACTION_Execute

Declaration

Source position: workbench.pas line 456

const TIACTION_Execute = 3;


TIACTION_NewDrawer

Declaration

Source position: workbench.pas line 455

const TIACTION_NewDrawer = 2;


TIACTION_RelabelVolume

Declaration

Source position: workbench.pas line 454

const TIACTION_RelabelVolume = 1;


TIACTION_Rename

Declaration

Source position: workbench.pas line 453

const TIACTION_Rename = 0;


TIconSelectMsg

The message your icon selection change hook is invoked with.

Declaration

Source position: workbench.pas line 356

type TIconSelectMsg = record
ism_Length: LongWord; | Size of this data structure (in bytes).
ism_Drawer: LongInt; | Lock on the drawer this object resides in, nil for Workbench backdrop (devices).
ism_Name: PChar; | Name of the object in question.
ism_Type: Word; | One of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK.
ism_Selected: WordBool; | True if currently selected, False otherwise.
ism_Tags: PTagItem; | Pointer to the list of tag items passed to ChangeWorkbenchSelectionA().
ism_DrawerWindow: PWindow; | Pointer to the window attached to this icon, if the icon is a drawer-like object.
ism_ParentWindow: PWindow; | Pointer to the window the icon resides in.
ism_Left: SmallInt; | Position and size of the icon; note that the
ism_Top: SmallInt; | icon may not entirely reside within the visible
ism_Width: SmallInt; | bounds of the parent window.
ism_Height: SmallInt; |
end;


TOldDrawerData

Old Structure to describe the view of the content of a drawer (pre AmigaOS V36)

Declaration

Source position: workbench.pas line 58

type TOldDrawerData = record
dd_NewWindow: TNewWindow; | Args to open window
dd_CurrentX: LongInt; | Current x coordinate of origin
dd_CurrentY: LongInt; | Current y coordinate of origin
end;

See also

OLDDRAWERDATAFILESIZE

The amount of OldDrawerData actually written to disk


TSetupCleanupHookMsg

The message your setup/cleanup hook gets invoked with.

Declaration

Source position: workbench.pas line 312

type TSetupCleanupHookMsg = record
schm_Length: LongWord; | LEngth of Message
schm_State: LongInt; | State of Workbench shutdown (SCHMSTATE_*)
end;

See also

SCHMSTATE_TryCleanup | State for .schm_State. Workbench will attempt to shut down now.
SCHMSTATE_Cleanup | State for .schm_State. Workbench will really shut down now.
SCHMSTATE_Setup | State for .schm_State. Workbench is operational again or could not be shut down.


TTextInputMsg

Declaration

Source position: workbench.pas line 446

type TTextInputMsg = record

  tim_Length: LongWord;

  tim_Action: LongInt;

  tim_Prompt: PChar;

end;


TWBArg

Workbech argument list entry

Declaration

Source position: workbench.pas line 28

type TWBArg = record
wa_Lock: LongInt; | A lock descriptor
wa_Name: PChar; | A string relative to that lock
end;


TWBStartup

Declaration

Source position: workbench.pas line 37

type TWBStartup = record
sm_Message: TMessage; | A standard message structure
sm_Process: PMsgPort; | The process descriptor for you
sm_Segment: LongInt; | a descriptor for your code
sm_NumArgs: LongInt; | the number of elements in ArgList
sm_ToolWindow: PChar; | Description of window
sm_ArgList: PWBArgList; | The arguments themselves
end;


UPDATEWB_ObjectAdded

Declaration

Source position: workbench.pas line 460

const UPDATEWB_ObjectAdded = 1;


UPDATEWB_ObjectRemoved

Declaration

Source position: workbench.pas line 459

const UPDATEWB_ObjectRemoved = 0;


WB_DISKMAGIC

A magic number, not easily impersonated

Declaration

Source position: workbench.pas line 112

const WB_DISKMAGIC = $e310;


WB_DISKREVISION

Our current revision number

Declaration

Source position: workbench.pas line 114

const WB_DISKREVISION = 1;


WB_DISKREVISIONMASK

We only use the lower 8 bits of Gadget.UserData for the revision #

Declaration

Source position: workbench.pas line 115

const WB_DISKREVISIONMASK = 255;


WB_DISKVERSION

Our current version number

Declaration

Source position: workbench.pas line 113

const WB_DISKVERSION = 1;


WBA_Dummy

Declaration

Source position: workbench.pas line 206

const WBA_Dummy = TAG_USER + $A000;


WBA_LAST_TAG

Declaration

Source position: workbench.pas line 307

const WBA_LAST_TAG = WBAPPICONA_Clone;


WBA_Reserved1

Declaration

Source position: workbench.pas line 254

const WBA_Reserved1 = WBA_Dummy + 40;


WBA_Reserved2

Declaration

Source position: workbench.pas line 255

const WBA_Reserved2 = WBA_Dummy + 41;


WBA_Reserved3

Declaration

Source position: workbench.pas line 262

const WBA_Reserved3 = WBA_Dummy + 46;


WBA_Reserved4

Declaration

Source position: workbench.pas line 267

const WBA_Reserved4 = WBA_Dummy + 49;


WBA_Reserved5

Declaration

Source position: workbench.pas line 269

const WBA_Reserved5 = WBA_Dummy + 50;


WBA_Reserved6

Declaration

Source position: workbench.pas line 270

const WBA_Reserved6 = WBA_Dummy + 51;


WBA_Reserved7

Declaration

Source position: workbench.pas line 271

const WBA_Reserved7 = WBA_Dummy + 52;


WBA_Reserved8

Declaration

Source position: workbench.pas line 272

const WBA_Reserved8 = WBA_Dummy + 53;


WBA_Reserved9

Declaration

Source position: workbench.pas line 273

const WBA_Reserved9 = WBA_Dummy + 54;


WBA_Reserved10

Declaration

Source position: workbench.pas line 274

const WBA_Reserved10 = WBA_Dummy + 55;


WBA_Reserved11

Declaration

Source position: workbench.pas line 275

const WBA_Reserved11 = WBA_Dummy + 56;


WBA_Reserved12

Declaration

Source position: workbench.pas line 276

const WBA_Reserved12 = WBA_Dummy + 57;


WBA_Reserved13

Declaration

Source position: workbench.pas line 277

const WBA_Reserved13 = WBA_Dummy + 58;


WBA_Reserved14

Declaration

Source position: workbench.pas line 278

const WBA_Reserved14 = WBA_Dummy + 59;


WBA_Reserved15

Declaration

Source position: workbench.pas line 279

const WBA_Reserved15 = WBA_Dummy + 60;


WBA_Reserved16

Declaration

Source position: workbench.pas line 280

const WBA_Reserved16 = WBA_Dummy + 61;


WBA_Reserved17

Declaration

Source position: workbench.pas line 281

const WBA_Reserved17 = WBA_Dummy + 62;


WBA_Reserved18

Declaration

Source position: workbench.pas line 282

const WBA_Reserved18 = WBA_Dummy + 63;


WBA_Reserved19

Declaration

Source position: workbench.pas line 283

const WBA_Reserved19 = WBA_Dummy + 64;


WBAPPICON

Type of Icon: AppIcon

Declaration

Source position: workbench.pas line 54

const WBAPPICON = 8;


WBAPPICONA_Clone

Declaration

Source position: workbench.pas line 305

const WBAPPICONA_Clone = WBA_Dummy + 80;


WBAPPICONA_NotifySelectState

Declaration

Source position: workbench.pas line 221

const WBAPPICONA_NotifySelectState = WBA_Dummy + 14;


WBAPPICONA_PropagatePosition

Declaration

Source position: workbench.pas line 219

const WBAPPICONA_PropagatePosition = WBA_Dummy + 12;


WBAPPICONA_RenderHook

Declaration

Source position: workbench.pas line 220

const WBAPPICONA_RenderHook = WBA_Dummy + 13;


WBAPPICONA_SupportsCopy

Declaration

Source position: workbench.pas line 209

const WBAPPICONA_SupportsCopy = WBA_Dummy + 2;


WBAPPICONA_SupportsDelete

Declaration

Source position: workbench.pas line 216

const WBAPPICONA_SupportsDelete = WBA_Dummy + 9;


WBAPPICONA_SupportsEmptyTrash

Declaration

Source position: workbench.pas line 218

const WBAPPICONA_SupportsEmptyTrash = WBA_Dummy + 11;


WBAPPICONA_SupportsFormatDisk

Declaration

Source position: workbench.pas line 217

const WBAPPICONA_SupportsFormatDisk = WBA_Dummy + 10;


WBAPPICONA_SupportsInformation

Declaration

Source position: workbench.pas line 211

const WBAPPICONA_SupportsInformation = WBA_Dummy + 4;


WBAPPICONA_SupportsLeaveOut

Declaration

Source position: workbench.pas line 214

const WBAPPICONA_SupportsLeaveOut = WBA_Dummy + 7;


WBAPPICONA_SupportsOpen

Declaration

Source position: workbench.pas line 208

const WBAPPICONA_SupportsOpen = WBA_Dummy + 1;


WBAPPICONA_SupportsPutAway

Declaration

Source position: workbench.pas line 215

const WBAPPICONA_SupportsPutAway = WBA_Dummy + 8;


WBAPPICONA_SupportsRename

Declaration

Source position: workbench.pas line 210

const WBAPPICONA_SupportsRename = WBA_Dummy + 3;


WBAPPICONA_SupportsSnapshot

Declaration

Source position: workbench.pas line 212

const WBAPPICONA_SupportsSnapshot = WBA_Dummy + 5;


WBAPPICONA_SupportsUnSnapshot

Declaration

Source position: workbench.pas line 213

const WBAPPICONA_SupportsUnSnapshot = WBA_Dummy + 6;


WBAPPMENUA_CommandKeyString

Declaration

Source position: workbench.pas line 223

const WBAPPMENUA_CommandKeyString = WBA_Dummy + 15;


WBAPPMENUA_GetKey

Declaration

Source position: workbench.pas line 285

const WBAPPMENUA_GetKey = WBA_Dummy + 65;


WBAPPMENUA_GetTitleKey

Declaration

Source position: workbench.pas line 299

const WBAPPMENUA_GetTitleKey = WBA_Dummy + 77;


WBAPPMENUA_UseKey

Declaration

Source position: workbench.pas line 286

const WBAPPMENUA_UseKey = WBA_Dummy + 66;


WBArgList

Helper for TWBStartUP

Declaration

Source position: workbench.pas line 33

type WBArgList = array [1..100] of TWBArg;

Description

Only [1..smNumArgs] are valid entries


WBCTRLA_AddHiddenDeviceName

Declaration

Source position: workbench.pas line 259

const WBCTRLA_AddHiddenDeviceName = WBA_Dummy + 44;


WBCTRLA_AddSetupCleanupHook

Declaration

Source position: workbench.pas line 301

const WBCTRLA_AddSetupCleanupHook = WBA_Dummy + 78;


WBCTRLA_DuplicateSearchPath

Declaration

Source position: workbench.pas line 229

const WBCTRLA_DuplicateSearchPath = WBA_Dummy + 19;


WBCTRLA_FreeHiddenDeviceList

Declaration

Source position: workbench.pas line 258

const WBCTRLA_FreeHiddenDeviceList = WBA_Dummy + 43;


WBCTRLA_FreeOpenDrawerList

Declaration

Source position: workbench.pas line 252

const WBCTRLA_FreeOpenDrawerList = WBA_Dummy + 39;


WBCTRLA_FreeProgramList

Declaration

Source position: workbench.pas line 235

const WBCTRLA_FreeProgramList = WBA_Dummy + 25;


WBCTRLA_FreeSearchPath

Declaration

Source position: workbench.pas line 230

const WBCTRLA_FreeSearchPath = WBA_Dummy + 20;


WBCTRLA_FreeSelectedIconList

Declaration

Source position: workbench.pas line 250

const WBCTRLA_FreeSelectedIconList = WBA_Dummy + 37;


WBCTRLA_GetCopyHook

Declaration

Source position: workbench.pas line 289

const WBCTRLA_GetCopyHook = WBA_Dummy + 69;


WBCTRLA_GetDefaultStackSize

Declaration

Source position: workbench.pas line 231

const WBCTRLA_GetDefaultStackSize = WBA_Dummy + 21;


WBCTRLA_GetDeleteHook

Declaration

Source position: workbench.pas line 291

const WBCTRLA_GetDeleteHook = WBA_Dummy + 71;


WBCTRLA_GetHiddenDeviceList

Declaration

Source position: workbench.pas line 257

const WBCTRLA_GetHiddenDeviceList = WBA_Dummy + 42;


WBCTRLA_GetOpenDrawerList

Declaration

Source position: workbench.pas line 251

const WBCTRLA_GetOpenDrawerList = WBA_Dummy + 38;


WBCTRLA_GetProgramList

Declaration

Source position: workbench.pas line 234

const WBCTRLA_GetProgramList = WBA_Dummy + 24;


WBCTRLA_GetSelectedIconList

Declaration

Source position: workbench.pas line 249

const WBCTRLA_GetSelectedIconList = WBA_Dummy + 36;


WBCTRLA_GetTextInputHook

Declaration

Source position: workbench.pas line 293

const WBCTRLA_GetTextInputHook = WBA_Dummy + 73;


WBCTRLA_GetTypeRestartTime

Declaration

Source position: workbench.pas line 264

const WBCTRLA_GetTypeRestartTime = WBA_Dummy + 47;


WBCTRLA_IsOpen

Declaration

Source position: workbench.pas line 228

const WBCTRLA_IsOpen = WBA_Dummy + 18;


WBCTRLA_RedrawAppIcon

Declaration

Source position: workbench.pas line 233

const WBCTRLA_RedrawAppIcon = WBA_Dummy + 23;


WBCTRLA_RemoveHiddenDeviceName

Declaration

Source position: workbench.pas line 260

const WBCTRLA_RemoveHiddenDeviceName = WBA_Dummy + 45;


WBCTRLA_RemSetupCleanupHook

Declaration

Source position: workbench.pas line 302

const WBCTRLA_RemSetupCleanupHook = WBA_Dummy + 79;


WBCTRLA_SetCopyHook

Declaration

Source position: workbench.pas line 290

const WBCTRLA_SetCopyHook = WBA_Dummy + 70;


WBCTRLA_SetDefaultStackSize

Declaration

Source position: workbench.pas line 232

const WBCTRLA_SetDefaultStackSize = WBA_Dummy + 22;


WBCTRLA_SetDeleteHook

Declaration

Source position: workbench.pas line 292

const WBCTRLA_SetDeleteHook = WBA_Dummy + 72;


WBCTRLA_SetTextInputHook

Declaration

Source position: workbench.pas line 294

const WBCTRLA_SetTextInputHook = WBA_Dummy + 74;


WBCTRLA_SetTypeRestartTime

Declaration

Source position: workbench.pas line 265

const WBCTRLA_SetTypeRestartTime = WBA_Dummy + 48;


WBDEVICE

Type of Icon: Device

Declaration

Source position: workbench.pas line 52

const WBDEVICE = 6;


WBDISK

Type of Icon: Disk

Declaration

Source position: workbench.pas line 47

const WBDISK = 1;


WBDRAWER

Type of Icon: Drawer/Folder

Declaration

Source position: workbench.pas line 48

const WBDRAWER = 2;


WBDZA_Box

Declaration

Source position: workbench.pas line 245

const WBDZA_Box = WBA_Dummy + 34;


WBDZA_Height

Declaration

Source position: workbench.pas line 243

const WBDZA_Height = WBA_Dummy + 32;


WBDZA_Hook

Declaration

Source position: workbench.pas line 246

const WBDZA_Hook = WBA_Dummy + 35;


WBDZA_Left

Declaration

Source position: workbench.pas line 237

const WBDZA_Left = WBA_Dummy + 26;


WBDZA_RelBottom

Declaration

Source position: workbench.pas line 240

const WBDZA_RelBottom = WBA_Dummy + 29;


WBDZA_RelHeight

Declaration

Source position: workbench.pas line 244

const WBDZA_RelHeight = WBA_Dummy + 33;


WBDZA_RelRight

Declaration

Source position: workbench.pas line 238

const WBDZA_RelRight = WBA_Dummy + 27;


WBDZA_RelWidth

Declaration

Source position: workbench.pas line 242

const WBDZA_RelWidth = WBA_Dummy + 31;


WBDZA_Top

Declaration

Source position: workbench.pas line 239

const WBDZA_Top = WBA_Dummy + 28;


WBDZA_Width

Declaration

Source position: workbench.pas line 241

const WBDZA_Width = WBA_Dummy + 30;


WBGARBAGE

Type of Icon: Trashcan

Declaration

Source position: workbench.pas line 51

const WBGARBAGE = 5;


WBKICK

Type of Icon: KickStart disk

Declaration

Source position: workbench.pas line 53

const WBKICK = 7;


WBOPENA_ArgLock

Declaration

Source position: workbench.pas line 225

const WBOPENA_ArgLock = WBA_Dummy + 16;


WBOPENA_ArgName

Declaration

Source position: workbench.pas line 226

const WBOPENA_ArgName = WBA_Dummy + 17;


WBOPENA_Show

Declaration

Source position: workbench.pas line 296

const WBOPENA_Show = WBA_Dummy + 75;


WBOPENA_ViewBy

Declaration

Source position: workbench.pas line 297

const WBOPENA_ViewBy = WBA_Dummy + 76;


WBPROJECT

Type of Icon: Project (Data file)

Declaration

Source position: workbench.pas line 50

const WBPROJECT = 4;


WBTOOL

Type of Icon: Tool (Excutable)

Declaration

Source position: workbench.pas line 49

const WBTOOL = 3;


WorkbenchBase

Declaration

Source position: workbench.pas line 465

var WorkbenchBase: PLibrary = Nil;


WORKBENCHNAME

Declaration

Source position: workbench.pas line 462

const WORKBENCHNAME: PChar = 'workbench.library';