Reference for unit 'agraphics': Procedures and functions

AddAnimOb | Add an AnimOb to the linked list of AnimObs.
AddBob | Adds a Bob to current gel list.
AddFont | Add a font to the system list
AddVSprite | Add a VSprite to the current gel list.
AllocBitMap | Allocate a bitmap and attach bitplanes to it.
AllocBitMapTagList
AllocDBufInfo | Allocate structure for multi-buffered animation
AllocRaster | Allocate space for a bitplane.
AllocSpriteData | VarArgs Version of AllocSpriteDataA()
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.
Animate | Processes every AnimOb in the current animation list.
AreaCircle | Draws a Circle in an Area
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AskFont | Get the text attributes of the current font
AskSoftStyle | Get the soft style bits of the current font.
AttachPalExtra | Allocate and attach a palette sharing structure to a colormap
AttemptLockLayerRom | Attempt to Lock Layer structure by ROM(gfx lib) code
BestModeID | VarArgs version of BestModeIDA()
BestModeIDA | Calculate the best ModeID with given parameters
BitMapScale | Perform raster scaling on a bit map.
BltBitMap | Move a rectangular region of bits in a BitMap.
BltBitMaPRastPort | Blit from source bitmap to destination rastport.
BltBitMapTagList
BltClear | Clear a block of memory words to zero.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
BltPattern | Using standard drawing rules for areafill, blit through a mask.
BltTemplate | Cookie cut a shape in a rectangle to the RastPort.
BNDRYOFF | Turn Boundary off
CalcIVG | Calculate the number of blank lines above a ViewPort
CBump | Increment user copper list pointer (bump to next position in list).
ChangeExtSprite | VarArgs version of ChangeExtSpriteA
ChangeExtSpriteA | Change the sprite image pointer.
ChangeSprite | Change the sprite image pointer.
ChangeVPBitMap | Change display memory address for multi-buffered animation
ClearEOL | Clear from current position to end of line.
ClearRectRegion
ClearRegion |
ClearScreen | Clear from current position to end of RastPort.
ClipBlit | Calls BltBitMap() after accounting for windows
CloseFont | Release a pointer to a system font.
CloseMonitor | Close a MonitorSpec
CMove | Append copper move instruction to user copper list.
CoerceMode | Calculate ViewPort mode coercion
CompositeTagList
CopySBitMap | Syncronize Layer window with contents of Super BitMap
CWait | Append copper wait instruction to user copper list.
DisownBlitter | Returns blitter to free state.
DisposeRegion | Return all space for this region to free memory pool.
DoCollision | Test every gel in gel list for collisions.
Draw | Draw a line between the current pen position and the new x,y position.
DrawCircle | Draws a Circle
DrawEllipse | Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.
EraseRect | Fill a defined rectangular area using the current BackFill hook.
ExtendFont | Ensure TTextFont.tf_Extension has been built for a font
ExtendFontTags | VarArgs Version of ExtendFont()
FindColor | Find the closest matching color in a colormap.
FindDisplayInfo | Search for a record identified by a specific key
Flood | Flood rastport like areafill.
FontExtent | Get the font attributes of the current font
FreeBitMap | Free a bitmap created by AllocBitMap()
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.
FreeCopList | Deallocate intermediate copper list
FreeCprList | Deallocate hardware copper list
FreeDBufInfo | Free information for multi-buffered animation
FreeGBuffers | Deallocate memory obtained by GetGBuffers()
FreeRaster | Release an allocated area to the system free memory pool
FreeSprite | Return sprite for use by others and virtual sprite machine.
FreeSpriteData | free sprite data allocated by AllocSpriteData()
FreeVPortCopLists | Deallocate all intermediate copper lists and their headers from a viewport
GetAPen | Get the A Pen value for a RastPort
GetBitMapAttr | Returns information about a bitmap
GetBoardBytesPerRow
GetBoardDataTagList
GetBPen | Get the B Pen value for a RastPort
GetColorMap | Allocate and initialize Colormap
GetDisplayInfoData | Query DisplayInfo Record parameters
GetDrMd | Get the draw mode value for a RastPort
GetExtSprite | VarArgs Version of GetExtSpriteA()
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.
GetGBuffers | Attempt to allocate ALL buffers of an entire AnimOb.
GetMonitorDataTagList
GetOutlinePen | Get the O Pen value for a RastPort
GetRGB32 | Set a series of color registers for this Viewport.
GetRGB4 | Inquire value of entry in ColorMap.
GetRPAttrs | VarArgs Version for GetRPAttrsA()
GetRPAttrsA | Examine rastport settings via a tag list
GetSprite | Attempt to get a sprite for the simple sprite manager.
GetVPModeID | Get the 32 bit DisplayID from a ViewPort.
GfxAssociate | associate a graphics extended node with a given pointer
GfxClone
GfxExpunge
GfxFree | Free a graphics extended data structure
GfxLookUp | Find a graphics extended node associated with a given pointer
GfxMove | Move graphics pen position.
GfxNew | Allocate a graphics extended data structure
GfxObtain
GfxRelease
GfxText | Write text characters (no formatting).
GraphicsControlTagList
InitAnimate | Init AnimObject pointer, set to nil
InitArea | Initialize vector collection matrix
InitBitMap | Initialize bit map structure with input values.
InitGels | initialize a gel list; must be called before using gels.
InitGMasks | Initialize all of the masks of an AnimOb.
InitMasks | Initialize the BorderLine and CollMask masks of a VSprite.
InitRastPort | Initialize raster port structure
InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.
InitView | Initialize View structure.
InitVPort | Initialize ViewPort structure.
LoadRGB32 | Set a series of color registers for this Viewport.
LoadRGB4 | Load RGB color values from table.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.
LockBitMapTagList
LockBitMapToBoardTagList
LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
MakeVPort | Generate display copper list for a viewport.
ModeNotAvailable | Check to see if a DisplayID isn't available.
MoveSprite | Move sprite to a point relative to top of viewport.
MrgCop | Merge together coprocessor instructions.
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.
NextDisplayInfo | Iterate current displayinfo identifiers
ObtainBestPen | VarArgs Version of ObtainBestPenA()
ObtainBestPenA | Search for the closest color match, or allocate a new one.
ObtainPen | Obtain a free palette entry for use by your program.
OpenFont | Get a pointer to a system font.
OpenMonitor | Open a named MonitorSpec
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
OwnBlitter | get the blitter for private usage
PolyDraw | Draw lines from table of (x,y) values.
QBlit | Queue up a request for blitter usage
QBSBlit | Synchronize the blitter request with the video beam.
RasSize | Get Size of an rastport.
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
ReadPixelArray
ReadPixelArray8 | read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
ReadPixelColor
ReadPixelLine8 | read the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.
RectFill | Fill a rectangular region in a RastPort.
RectFillColor
ReleasePen | Release an allocated palette entry to the free pool.
RemFont | Remove a font from the system list.
RemIBob | Immediately remove a Bob from the gel list and the RastPort.
RemVSprite | Remove a VSprite from the current gel list.
SafeSetOutlinePen |
SafeSetWriteMask |
ScalerDiv | Get the scaling result that BitMapScale would.
ScrollRaster | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.
ScrollRasterBF | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().
ScrollVPort | Reinterpret RasInfo information in ViewPort to reflect the current Offset values.
SetABPenDrMd | Set pen colors and draw mode for a RastPort.
SetAfPt | Set Area PAttern and Point Size
SetAPen | Set the primary pen for a RastPort.
SetBPen | Set secondary pen for a RastPort
SetChipRev | Turns on the features of a Chip Set
SetCollision | Set a pointer to a user collision routine.
SetDrMd | Set drawing mode for a RastPort
SetDrPt | Set Draw Pattern
SetFont | Set the text font and attributes in a RastPort.
SetMaxPen | Set maximum pen value for a rastport
SetOPen | Set Outline pen
SetOutlinePen | Set the Outline Pen value for a RastPort
SetRast | Set an entire drawing area to a specified color.
SetRGB32 | Set one color register for this Viewport.
SetRGB32CM | Set one color register for this ColorMap.
SetRGB4 | Set one color register for this viewport.
SetRGB4CM | Set one color register for this ColorMap.
SetRPAttrs | VarArgs Version of SetRPAttrsA()
SetRPAttrsA | Modify rastport settings via a tag list
SetSoftStyle | Set the soft style of the current font.
SetWriteMask | Set the pixel write mask value for a RastPort
SetWrMsk | Set Write Mask for RastPort
SortGList | Sort the current gel list, ordering its y,x coordinates.
StripFont | Remove the TextFontExtension from a font
SyncSBitMap | Syncronize Super BitMap with whatever is in the standard Layer bounds.
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent
TextLength | Determine raster length of text data.
UCopperListInit | Allocates and initializes copperlist structures and buffers internal to UCopList structure.
UnlockBitMap
UnlockBitMapFromBoard
UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.
VBeamPos | Get vertical beam position at this instant.
VideoControl | Modify the operation of a ViewPort's ColorMap
VideoControlTags | VarArgs Version of VideoControl()
WaitBlit | Wait for the blitter to be finished before proceeding with anything else.
WaitBOVP | Wait till vertical beam reached bottom of this viewport.
WaitTOF | Wait for the top of the next video frame.
WriteChunkyPixels | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixel | Change the pen num of one specific pixel in a specified RastPort.
WritePixelArray
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelColor
WritePixelLine8 | Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
XorRegionRegion | Perform 2d XOR operation of one region with second region, leaving result in second region
Documentation generated on: 2021-07-30


Reference for unit 'agraphics': Variables

GfxBase

Graphics base library pointer for all graphics library functions, opened on unit initialization

IGfx


Index of all identifiers in unit 'agraphics'

A B C D E F G H I J L M N O P Q R S T U V W X

A

A2024FIFTEENHERTZ_KEY | ALPHAHOOKACTION_CHANGELAYERALPHA | AreaDraw
A2024_MONITOR_ID | ALPHAHOOKACTION_CREATELAYER | AreaEllipse
A2024TENHERTZ_KEY | ALPHAHOOKACTION_DELETELAYER | AreaEnd
AddAnimOb | ALPHAHOOKACTION_GETHOOKACTIONS | AreaMove
AddBob | ALPHAHOOKACTION_MOVELAYER | AREAOUTLINE
AddFont | ALPHAHOOKACTION_MOVESIZELAYER | AskFont
AddVSprite | ALPHAHOOKACTION_SIZELAYER | AskSoftStyle
AllocBitMap | AndRectRegion | AttachPalExtra
AllocBitMapTagList | AndRegionRegion | AttemptLockLayerRom
AllocDBufInfo | ANFRACSIZE | SmallInt
AllocRaster | Animate | AVOID_FLICKER
AllocSpriteData | ANIMHALF |
AllocSpriteDataA | AreaCircle |

B

B2BOBBER | BLITMSG_FAULTn | BMB_CLEAR
B2NORM | BLITT_ALPHATEMPLATE | BMB_DISPLAYABLE
B2SWAP | BLITT_ARGB32 | BMB_FRIENDISTAG
BACKSAVED | BLITT_BITMAP | BMB_HIJACKED
BANDWIDTH_1X | BLITT_CHUNKY | BMB_INTERLEAVED
BANDWIDTH_2XDBL | BLITT_RASTPORT | BMB_INVALID
BANDWIDTH_2XNML | BLITT_RGB16 | BMB_LOCKED
BANDWIDTH_4X | BLITT_RGB24 | BMB_MINPLANES
BDRAWN | BLITT_TEMPLATE | BMB_RTGCHECK
BestModeID | BltBitMap | BMB_RTGTAGS
BestModeIDA | BltBitMaPRastPort | BMB_STANDARD
BGBACKFILL | BltBitMapTagList | BMF_CHECKMASK
BIDTAG_BlueBits | BLTBMTAGS_BASE | BMF_CHECKVALUE
BIDTAG_COERCE | BltClear | BMF_CLEAR
BIDTAG_Depth | BltMaskBitMapRastPort | BMF_DISPLAYABLE
BIDTAG_DesiredHeight | BltPattern | BMF_FRIENDISTAG
BIDTAG_DesiredWidth | BltTemplate | BMF_HIJACKED
BIDTAG_DIPFMustHave | BMA_ACTUALWIDTH | BMF_INTERLEAVED
BIDTAG_DIPFMustNotHave | BMA_BITSPERPIXEL | BMF_INVALID
BIDTAG_GfxPrivate | BMA_BYTESPERPIXEL | BMF_LOCKED
BIDTAG_GreenBits | BMA_DEPTH | BMF_MINPLANES
BIDTAG_MaxDepth | BMA_FLAGS | BMF_RTGCHECK
BIDTAG_MonitorID | BMA_HEIGHT | BMF_RTGTAGS
BIDTAG_NominalHeight | BMA_ISRTG | BMF_STANDARD
BIDTAG_NominalWidth | BMA_PIXELFORMAT | BNDRYOFF
BIDTAG_RedBits | BMATags_Alignment | BOBISCOMP
BIDTAG_SourceID | BMATags_BitmapColors | BOBNIX
BIDTAG_ViewPort | BMATags_BitmapColors32 | BOBSAWAY
BITCLR | BMATags_BitmapInvisible | BOBUPDATE
BitMapScale | BMATags_Clear | BORDER_BLANKING
BITSET | BMATags_ConstantBytesPerRow | BORDERHIT
BLITA_Alpha | BMATags_Depth | BORDER_NOTRANSPARENCY
BLITA_AlphaMask | BMATags_Displayable | BORDERSPRITES
BLITA_CLUT | BMATags_DisplayID | BOTTOMHIT
BLITA_Dest | BMATags_Friend | BROADCAST_HBSTOP
BLITA_DestBytesPerRow | BMATags_ModeHeight | BROADCAST_HBSTRT
BLITA_DestType | BMATags_ModeWidth | BROADCAST_HSSTOP
BLITA_DestX | BMATags_NoMemory | BROADCAST_HSSTRT
BLITA_DestY | BMATags_NoSprite | BROADCAST_VBSTOP
BLITA_Height | BMATags_PixelFormat | BROADCAST_VBSTRT
BLITA_Mask | BMATags_Private1 | BROADCAST_VSSTOP
BLITA_MaskPlane | BMATags_Private2 | BROADCAST_VSSTRT
BLITA_Minterm | BMATags_Private3 | BSAF_AVERAGE
BLITA_Source | BMATags_Private4 | BSAF_BILINEAR
BLITA_SrcBytesPerRow | BMATags_Private5 | BSAF_RESERVED1
BLITA_SrcType | BMATags_Private6 | BSAF_RESERVED2
BLITA_SrcX | BMATags_Private7 | BUS_16
BLITA_SrcY | BMATags_RenderFunc | BUS_32
BLITA_UseDestAlpha | BMATags_SaveFunc | BUSERFLAGS
BLITA_UseSrcAlpha | BMATags_UserData | SmallInt
BLITA_Width | BMATags_UserPrivate | BWAITING
BLITMSG_FAULT | BMA_WIDTH |

C

CalcIVG | COMPFLAG_SrcAlphaOverride | COMPTAG_DisplayID
CBump | COMPFLAG_SrcFilter | COMPTAG_Flags
ChangeExtSprite | COMPLEMENT | COMPTAG_FriendBitMap
ChangeExtSpriteA | COMPOSITE_Clear | COMPTAG_IndexArray
ChangeSprite | COMPOSITE_Dest | COMPTAG_NumTriangles
ChangeVPBitMap | COMPOSITE_Dest_Atop_Src | COMPTAG_OffsetX
ClearEOL | COMPOSITE_Dest_In_Src | COMPTAG_OffsetY
ClearRectRegion | COMPOSITE_Dest_Out_Src | COMPTAG_Private
ClearRegion | COMPOSITE_Dest_Over_Src | COMPTAG_Private2
ClearScreen | COMPOSITE_Maximum | COMPTAG_ScaleX
ClipBlit | COMPOSITE_Minimum | COMPTAG_ScaleY
CloseFont | COMPOSITE_NumOperators | COMPTAG_SrcAlpha
CloseMonitor | COMPOSITE_Plus | COMPTAG_SrcAlphaMask
CMAB_DUALPF_DISABLE | COMPOSITE_Src | COMPTAG_SrcAlphaX
CMAB_FULLPALETTE | COMPOSITE_Src_Atop_Dest | COMPTAG_SrcAlphaY
CMAB_NO_COLOR_LOAD | COMPOSITE_Src_In_Dest | COMPTAG_SrcHeight
CMAB_NO_INTERMED_UPDATE | COMPOSITE_Src_Out_Dest | COMPTAG_SrcWidth
CMAF_DUALPF_DISABLE | COMPOSITE_Src_Over_Dest | COMPTAG_SrcX
CMAF_FULLPALETTE | COMPOSITE_Src_Xor_Dest | COMPTAG_SrcY
CMAF_NO_COLOR_LOAD | CompositeTagList | COMPTAG_SrcYUVMatrix
CMAF_NO_INTERMED_UPDATE | COMPTAG_Base | COMPTAG_SrcYUVStandard
CMF_BRDNTRAN | COMPTAG_Color0 | COMPTAG_VertexArray
CMF_BRDRBLNK | COMPTAG_Color0_Alpha | COMPTAG_VertexFormat
CMF_BRDRSPRT | COMPTAG_Color0_Blue | COMPVF_STW0_Present
CMF_CMTRANS | COMPTAG_Color0_Green | COMPVF_STW1_Present
CMF_CPTRANS | COMPTAG_Color0_Red | COMPYUV_BT601
CMove | COMPTAG_Color1 | COMPYUV_BT709
CoerceMode | COMPTAG_Color1_Alpha | COPPER_MOVE
CollTable | COMPTAG_Color1_Blue | COPPER_WAIT
COLORMAP_TRANSPARENCY | COMPTAG_Color1_Green | CopySBitMap
COLORMAP_TYPE_V1_2 | COMPTAG_Color1_Red | CPR_NT_LOF
COLORMAP_TYPE_V1_4 | COMPTAG_Color2 | CPR_NT_SHT
COLORMAP_TYPE_V36 | COMPTAG_Color2_Alpha | CPR_NT_SYS
COLORMAP_TYPE_V39 | COMPTAG_Color2_Blue | CPRNXTBUF
COLORON | COMPTAG_Color2_Green | CR_ALPHATYPE
COLORPLANE_TRANSPARENCY | COMPTAG_Color2_Red | CR_DAMAGECLIPPED
COMPERR_Generic | COMPTAG_Color3 | CR_INTUITION
COMPERR_Incompatible | COMPTAG_Color3_Alpha | CR_INVISIBLE
COMPERR_MissingInput | COMPTAG_Color3_Blue | CR_LAYERBITMAP
COMPERR_OutOfMemory | COMPTAG_Color3_Green | CR_USERCLIPPED
COMPERR_SoftwareFallback | COMPTAG_Color3_Red | CT_ANTIALIAS
COMPERR_Success | COMPTAG_DestAlpha | CTB_MAPCOLOR
COMPERR_UnknownOperator | COMPTAG_DestAlphaMask | CT_COLORFONT
COMPERR_Value | COMPTAG_DestAlphaX | CT_COLORMASK
COMPFLAG_Color1Modulate | COMPTAG_DestAlphaY | CTF_MAPCOLOR
COMPFLAG_DestAlphaOverride | COMPTAG_DestHeight | CT_GREYFONT
COMPFLAG_ForceSoftware | COMPTAG_DestWidth | CWait
COMPFLAG_HardwareOnly | COMPTAG_DestX |
COMPFLAG_IgnoreDestAlpha | COMPTAG_DestY |

D

DBL_CAS | DBLPALEXTRALORESDPF_KEY | DI_AVAIL_NOTWITHGENLOCK
DBLNTSCEXTRALORESDPF2FF_KEY | DBLPALEXTRALORESDPFLACE_KEY | DIPF_IS_AA
DBLNTSCEXTRALORESDPF2_KEY | DBLPALEXTRALORESEHBFF_KEY | DIPF_IS_BEAMSYNC
DBLNTSCEXTRALORESDPF2LACE_KEY | DBLPALEXTRALORESEHB_KEY | DIPF_IS_DBUFFER
DBLNTSCEXTRALORESDPFFF_KEY | DBLPALEXTRALORESEHBLACE_KEY | DIPF_IS_DRAGGABLE
DBLNTSCEXTRALORESDPF_KEY | DBLPALEXTRALORESFF_KEY | DIPF_IS_DUALPF
DBLNTSCEXTRALORESDPFLACE_KEY | DBLPALEXTRALORESHAMFF_KEY | DIPF_IS_ECS
DBLNTSCEXTRALORESEHBFF_KEY | DBLPALEXTRALORESHAM_KEY | DIPF_IS_EXTRAHALFBRITE
DBLNTSCEXTRALORESEHB_KEY | DBLPALEXTRALORESHAMLACE_KEY | DIPF_IS_FOREIGN
DBLNTSCEXTRALORESEHBLACE_KEY | DBLPALEXTRALORES_KEY | DIPF_IS_GENLOCK
DBLNTSCEXTRALORESFF_KEY | DBLPALEXTRALORESLACE_KEY | DIPF_IS_HAM
DBLNTSCEXTRALORESHAMFF_KEY | DBLPALHIRESDPF2FF_KEY | DIPF_IS_HWCOMPOSITE
DBLNTSCEXTRALORESHAM_KEY | DBLPALHIRESDPF2_KEY | DIPF_IS_LACE
DBLNTSCEXTRALORESHAMLACE_KEY | DBLPALHIRESDPF2LACE_KEY | DIPF_IS_PAL
DBLNTSCEXTRALORES_KEY | DBLPALHIRESDPFFF_KEY | DIPF_IS_PANELLED
DBLNTSCEXTRALORESLACE_KEY | DBLPALHIRESDPF_KEY | DIPF_IS_PF2PRI
DBLNTSCHIRESDPF2FF_KEY | DBLPALHIRESDPFLACE_KEY | DIPF_IS_PREFERREDMODE
DBLNTSCHIRESDPF2_KEY | DBLPALHIRESEHBFF_KEY | DIPF_IS_PROGBEAM
DBLNTSCHIRESDPF2LACE_KEY | DBLPALHIRESEHB_KEY | DIPF_IS_RTG
DBLNTSCHIRESDPFFF_KEY | DBLPALHIRESEHBLACE_KEY | DIPF_IS_SCANDBL
DBLNTSCHIRESDPF_KEY | DBLPALHIRESFF_KEY | DIPF_IS_SPRITES
DBLNTSCHIRESDPFLACE_KEY | DBLPALHIRESHAMFF_KEY | DIPF_IS_SPRITES_ATT
DBLNTSCHIRESEHBFF_KEY | DBLPALHIRESHAM_KEY | DIPF_IS_SPRITES_BORDER
DBLNTSCHIRESEHB_KEY | DBLPALHIRESHAMLACE_KEY | DIPF_IS_SPRITES_CHNG_BASE
DBLNTSCHIRESEHBLACE_KEY | DBLPALHIRES_KEY | DIPF_IS_SPRITES_CHNG_PRI
DBLNTSCHIRESFF_KEY | DBLPALHIRESLACE_KEY | DIPF_IS_SPRITES_CHNG_RES
DBLNTSCHIRESHAMFF_KEY | DBLPALLORESDPF2FF_KEY | DIPF_IS_WB
DBLNTSCHIRESHAM_KEY | DBLPALLORESDPF2_KEY | DisownBlitter
DBLNTSCHIRESHAMLACE_KEY | DBLPALLORESDPF2LACE_KEY | DisplayInfoHandle
DBLNTSCHIRES_KEY | DBLPALLORESDPFFF_KEY | DISPLAYNAMELEN
DBLNTSCHIRESLACE_KEY | DBLPALLORESDPF_KEY | DisposeRegion
DBLNTSCLORESDPF2FF_KEY | DBLPALLORESDPFLACE_KEY | DIW_HORIZ_POS
DBLNTSCLORESDPF2_KEY | DBLPALLORESEHBFF_KEY | DIW_VRTCL_POS
DBLNTSCLORESDPF2LACE_KEY | DBLPALLORESEHB_KEY | DIW_VRTCL_POS_SHIFT
DBLNTSCLORESDPFFF_KEY | DBLPALLORESEHBLACE_KEY | DoCollision
DBLNTSCLORESDPF_KEY | DBLPALLORESFF_KEY | DPMSLEVEL_OFF
DBLNTSCLORESDPFLACE_KEY | DBLPALLORESHAMFF_KEY | DPMSLEVEL_ON
DBLNTSCLORESEHBFF_KEY | DBLPALLORESHAM_KEY | DPMSLEVEL_STANDBY
DBLNTSCLORESEHB_KEY | DBLPALLORESHAMLACE_KEY | DPMSLEVEL_SUSPEND
DBLNTSCLORESEHBLACE_KEY | DBLPALLORES_KEY | Draw
DBLNTSCLORESFF_KEY | DBLPALLORESLACE_KEY | DrawCircle
DBLNTSCLORESHAMFF_KEY | DBLPAL_MONITOR_ID | DrawEllipse
DBLNTSCLORESHAM_KEY | DBLPF | DrawGList
DBLNTSCLORESHAMLACE_KEY | DBUFFER | DTAG_DIMS
DBLNTSCLORES_KEY | DEFAULT_MONITOR_ID | DTAG_DISP
DBLNTSCLORESLACE_KEY | DEFAULT_MONITOR_NAME | DTAG_MNTR
DBLNTSC_MONITOR_ID | DFTCH_MASK | DTAG_NAME
DBLPALEXTRALORESDPF2FF_KEY | DI_AVAIL_INVALID | DTAG_VEC
DBLPALEXTRALORESDPF2_KEY | DI_AVAIL_MONITOOL | DUALPF
DBLPALEXTRALORESDPF2LACE_KEY | DI_AVAIL_NOCHIPS |
DBLPALEXTRALORESDPFFF_KEY | DI_AVAIL_NOMONITOR |

E

EraseRect | EURO72EXTRALORESLACE_KEY | EURO72PRODUCTDPF2_KEY
EURO36_MONITOR_ID | EURO72HAM_KEY | EURO72PRODUCTDPF_KEY
EURO72EHB_KEY | EURO72HAMLACE_KEY | EURO72PRODUCTEHBDBL_KEY
EURO72EHBLACE_KEY | EURO72LORESDBL_KEY | EURO72PRODUCTHAMDBL_KEY
EURO72EXTRAHALFBRITE_KEY | EURO72LORESDPF2_KEY | EURO72PRODUCTHAM_KEY
EURO72EXTRAHALFBRITELACE_KEY | EURO72LORESDPF_KEY | EURO72PRODUCTHAMLACE_KEY
EURO72EXTRALORESDBL_KEY | EURO72LORESEHBDBL_KEY | EURO72PRODUCT_KEY
EURO72EXTRALORESDPF2_KEY | EURO72LORESEHB_KEY | EURO72PRODUCTLACEDPF2_KEY
EURO72EXTRALORESDPF_KEY | EURO72LORESEHBLACE_KEY | EURO72PRODUCTLACEDPF_KEY
EURO72EXTRALORESEHBDBL_KEY | EURO72LORESHAMDBL_KEY | EURO72PRODUCTLACE_KEY
EURO72EXTRALORESEHB_KEY | EURO72LORESHAM_KEY | EXTENDED_MODE
EURO72EXTRALORESEHBLACE_KEY | EURO72LORESHAMLACE_KEY | ExtendFont
EURO72EXTRALORESHAMDBL_KEY | EURO72LORES_KEY | ExtendFontTags
EURO72EXTRALORESHAM_KEY | EURO72LORESLACEDPF2_KEY | EXTEND_VSTRUCT
EURO72EXTRALORESHAMLACE_KEY | EURO72LORESLACEDPF_KEY | EXTRA_HALFBRITE
EURO72EXTRALORES_KEY | EURO72LORESLACE_KEY | EXTRAHALFBRITE_KEY
EURO72EXTRALORESLACEDPF2_KEY | EURO72_MONITOR_ID | EXTRAHALFBRITELACE_KEY
EURO72EXTRALORESLACEDPF_KEY | EURO72PRODUCTDBL_KEY |

F

FILLALPHA | FPF_REMOVED | FRST_DOT
FindColor | FPF_REVPATH | FSB_ANTIALIASED
FindDisplayInfo | FPF_ROMFONT | FSB_BOLD
Flood | FPF_TALLDOT | FSB_COLORFONT
FontExtent | FPF_WIDEDOT | FSB_EXTENDED
FPB_DESIGNED | FreeBitMap | FSB_ITALIC
FPB_DISKFONT | FreeColorMap | FSB_TAGGED
FPB_PROPORTIONAL | FreeCopList | FSB_UNDERLINED
FPB_REMOVED | FreeCprList | FSF_ANTIALIASED
FPB_REVPATH | FreeDBufInfo | FSF_BOLD
FPB_ROMFONT | FreeGBuffers | FSF_COLORFONT
FPB_TALLDOT | FreeRaster | FSF_EXTENDED
FPB_WIDEDOT | FreeSprite | FSF_ITALIC
FPF_DESIGNED | FreeSpriteData | FSF_TAGGED
FPF_DISKFONT | FreeVPortCopLists | FSF_UNDERLINED
FPF_PROPORTIONAL | FROM_MONITOR | FS_NORMAL

G

GBD_BoardDriver | GetColorMap | GFXF_NEW_DATABASE
GBD_BoardName | GetDisplayInfoData | GfxFree
GBD_ChipDriver | GetDrMd | GfxLookUp
GBD_FreeMemory | GetExtSprite | GfxMove
GBD_InternalMemorySize | GetExtSpriteA | GfxNew
GBD_LargestFreeMemory | GetGBuffers | GfxObtain
GBD_PCIProductID | GetMonitorDataTagList | GfxRelease
GBD_PCIVendorID | GetOutlinePen | GfxText
GBD_TagBase | GetRGB32 | GMD_BasicAudio
GBD_TotalMemory | GetRGB4 | GMD_DisplayHeight
GCTRL_Get31KHzScanRate | GetRPAttrs | GMD_DisplayWidth
GCTRL_GetDisableAmigaBlitter | GetRPAttrsA | GMD_DotClockMax
GCTRL_GetForceSWComposite | GetSprite | GMD_DotClockMin
GCTRL_GetPlanesToFast | GetVPModeID | GMD_EDIDRevision
GCTRL_GetUseAltiVec | GfxAssociate | GMD_EDIDVersion
GCTRL_GetUseDMA | GFXB_AA_ALICE | GMD_HSyncMax
GCTRL_Set31KHzScanRate | GFXB_AA_LISA | GMD_HSyncMin
GCTRL_SetDisableAmigaBlitter | GFXB_AA_MLISA | GMD_InputType
GCTRL_SetForceSWComposite | GfxBase | GMD_Product
GCTRL_SetPlanesToFast | GFXB_BIG_BLITS | GMD_ProductID
GCTRL_SetUseAltiVec | GFXB_HR_AGNUS | GMD_TagBase
GCTRL_SetUseDMA | GFXB_HR_DENISE | GMD_VendorID
GELGONE | GfxClone | GMD_VSyncMax
GENLOC | GfxExpunge | GMD_VSyncMin
GENLOCK_AUDIO | GFXF_AA_ALICE | GraphicsControlTagList
GENLOCK_VIDEO | GFXF_AA_LISA | GRAPHICSNAME
GetAPen | GFXF_AA_MLISA | GSTAG_ATTACHED
GetBitMapAttr | GFXF_BIG_BLITS | GSTAG_SCANDOUBLED
GetBoardBytesPerRow | GFXF_HAVECOMPOSITE | GSTAG_SOFTSPRITE
GetBoardDataTagList | GFXF_HR_AGNUS | GSTAG_SPRITE_NUM
GetBPen | GFXF_HR_DENISE |

H

HAM | HIRESEHB_KEY | HIRESLACEDPF2_KEY
HAM_KEY | HIRESEHBLACE_KEY | HIRESLACEDPF_KEY
HAMLACE_KEY | HIRESHAM_KEY | HIRESLACE_KEY
HIRES | HIRESHAMLACE_KEY | HOLDNMODIFY
HIRESDPF2_KEY | HIRESHAMSDBL_KEY |
HIRESDPF_KEY | HIRES_KEY |

I

IGfx | InitMasks | INTERLACE
IGNORE_MCOMPAT | InitRastPort | INVALID_ID
InitAnimate | InitTmpRas | INVERSVID
InitArea | InitView | ISGRTRX
InitBitMap | InitVPort | ISGRTRY
InitGels | INPUTTYPE_DVI | ISLESSX
InitGMasks | INPUTTYPE_VGA | ISLESSY

J

JAM1 JAM2

L

LACE | LoadRGB32 | LORESHAMSDBL_KEY
LBM_BaseAddress | LoadRGB4 | LORES_KEY
LBM_BytesPerRow | LoadView | LORESLACEDPF2_KEY
LBM_IsOnBoard | LockBitMapTagList | LORESLACEDPF_KEY
LBM_PixelFormat | LockBitMapToBoardTagList | LORESLACE_KEY
LBM_PlanarYUVInfo | LockLayerRom | LORESSDBL_KEY
LBM_TagBase | LORESDPF2_KEY | LPEN_SWAP_FRAMES
LEFTHIT | LORESDPF_KEY |
LEVELS | LORESEHBSDBL_KEY |

M

MakeVPort | MINTERM_A_XOR_C | MSB_DOUBLE_SPRITES
MAXFONTMATCHWEIGHT | MINTERM_B_EQUALS_C | MSB_REQUEST_A2024
MCOMPAT_MIXED | MINTERM_B_OR_C | MSB_REQUEST_NTSC
MCOMPAT_NOBODY | MINTERM_NABC | MSB_REQUEST_PAL
MCOMPAT_SELF | MINTERM_NABNC | MSB_REQUEST_SPECIAL
MCOP_NO_MEM | MINTERM_NANBC | MSF_DOUBLE_SPRITES
MCOP_NOP | MINTERM_NANBNC | MSF_REQUEST_A2024
MCOP_OK | MINTERM_NOTSRCMASK | MSF_REQUEST_NTSC
MIN_NTSC_ROW | MINTERM_SRCMASK | MSF_REQUEST_PAL
MIN_PAL_ROW | MIN_VGA70_ROW | MSF_REQUEST_SPECIAL
MINTERM_ABC | MIN_VGA_ROW | MUSTDRAW
MINTERM_ABNC | MODE_640 | MVP_NO_DISPLAY
MINTERM_ANBC | ModeNotAvailable | MVP_NO_DSPINS
MINTERM_ANBNC | MONITOR_ID_MASK | MVP_NO_MEM
MINTERM_A_OR_B | MONITOR_SPEC_TYPE | MVP_NO_VPE
MINTERM_A_OR_C | MoveSprite | MVP_OFF_BOTTOM
MINTERM_A_TO_D | MrgCop | MVP_OK

N

NewRegion | NOCROSSFILL | NTSC_MONITOR_NAME
NextDisplayInfo | NTSC |
NML_CAS | NTSC_MONITOR_ID |

O

OBP_FailIfBad | ONE_DOT | OUTSTEP
OBP_Precision | OpenFont | OVERLAY
ObtainBestPen | OpenMonitor | OwnBlitter
ObtainBestPenA | OrRectRegion |
ObtainPen | OrRegionRegion |

P

PAATextFont | PFBA | PPAnimOb
PAL | PFB_FINE_SCROLL_SHIFT | PPlanarYUVInfo
PAL_MONITOR_ID | PF_FINE_SCROLL_MASK | PPoint
PAL_MONITOR_NAME | PGelsInfo | PQueryHeader
PAlphaHookMsg | PGfxBase | PRasInfo
PAnalogSignalInterval | PIsrvstr | PRastPort
PAnimComp | PIXF_A8B8G8R8 | PRastPortExtra
PAnimOb | PIXF_A8R8G8B8 | PRECISION_EXACT
PAreaInfo | PIXF_ALPHA8 | PRECISION_GUI
PBitMap | PIXF_B5G5R5PC | PRECISION_ICON
PBitScaleArgs | PIXF_B5G6R5PC | PRECISION_IMAGE
Pointer | PIXF_B8G8R8 | PRect32
PBob | PIXF_B8G8R8A8 | PRectangle
PClipRect | PIXF_CLUT | PRegion
PCollTable | PIXF_NONE | PRegionRectangle
PColorFontColors | PIXF_R5G5B5 | PRESERVE_COLORS
PColorMap | PIXF_R5G5B5PC | PROTO_MONITOR_ID
PColorTextFont | PIXF_R5G6B5 | PShapeHookMsg
PCopInit | PIXF_R5G6B5PC | PSimpleSprite
PCopIns | PIXF_R8G8B8 | PSpecialMonitor
PCopList | PIXF_R8G8B8A8 | PTextAttr
PCprList | PIXF_YUV410P | PTextExtent
PDBufInfo | PIXF_YUV411 | PTextFont
PDBufPacket | PIXF_YUV420P | PTextFontExtension
PDimensionInfo | PIXF_YUV422 | PTmpRas
PDisplayInfo | PIXF_YUV422CGX | PTTextAttr
PENB_EXCLUSIVE | PIXF_YUV422PA | PUCopList
PENB_NO_SETCOLOR | PIXF_YUV422PC | PVecInfo
PEN_EXCLUSIVE | PLayer | PVecTable
PENF_EXCLUSIVE | PLNCNTMSK | PView
PENF_NO_SETCOLOR | PLNCNTSHFT | PViewExtra
PEN_NO_SETCOLOR | PMonitorInfo | PViewPort
PExtendedNode | PMonitorSpec | PViewPortExtra
PExtSprite | PNameInfo | PVSprite
PF2PRI | PolyDraw |
PFA_FINE_SCROLL | PPaletteExtra |

Q

QBlit | QBOWNERn
QBOWNER | QBSBlit

R

RasSize | REQUEST_A2024 | RPTAG_BPenColor
RATIO_FIXEDPART | REQUEST_NTSC | RPTAG_DrawBounds
RATIO_UNITY | REQUEST_PAL | RPTAG_DrMd
ReadPixel | REQUEST_SPECIAL | RPTAG_Font
ReadPixelArray | RIGHTHIT | RPTAG_MaxPen
ReadPixelArray8 | RINGTRIGGER | RPTAG_OPen
ReadPixelColor | RPF_FG_BLEND | RPTAG_OPenColor
ReadPixelLine8 | RPF_REMAP_COLORFONTS | RPTAG_OutlinePen
REALLY_PAL | RPF_USE_BGCOLOR | RPTAG_OutlinePenColor
RectFill | RPF_USE_FGCOLOR | RPTAG_RemapColorFonts
RectFillColor | RPF_USE_OCOLOR | RPTAG_WriteMask
ReleasePen | RPTAG_APen | RPTAG_XPos
RemFont | RPTAG_APenColor | RPTAG_YPos
RemIBob | RPTAG_BitMap |
RemVSprite | RPTAG_BPen |

S

SafeSetOutlinePen | SetWrMsk | STANDARD_PAL_BEAMCON
SafeSetWriteMask | SHAPEHOOKACTION_CHANGELAYERSHAPE | STANDARD_PAL_ROWS
SAVEBACK | SHAPEHOOKACTION_CREATELAYER | STANDARD_VBSTOP
SAVEBOB | SHAPEHOOKACTION_DELETELAYER | STANDARD_VBSTRT
SAVEPRESERVE | SHAPEHOOKACTION_GETHOOKACTIONS | STANDARD_VIEW_X
ScalerDiv | SHAPEHOOKACTION_MOVELAYER | STANDARD_VIEW_Y
ScrollRaster | SHAPEHOOKACTION_MOVESIZELAYER | STANDARD_VSSTOP
ScrollRasterBF | SHAPEHOOKACTION_SIZELAYER | STANDARD_VSSTRT
ScrollVPort | SortGList | STANDARD_XOFFSET
SetABPenDrMd | SPECIAL_MONITOR_TYPE | STANDARD_YOFFSET
SetAfPt | SPRITEA_Attached | StripFont
SetAPen | SPRITEA_OldDataFormat | SUPER72HIRESDBL_KEY
SetBPen | SPRITEA_OutputHeight | SUPER72HIRESEHBDBL_KEY
SetChipRev | SPRITE_ATTACHED | SUPER72HIRESHAMDBL_KEY
SETCHIPREV_A | SPRITEA_Width | SUPER72LORESDBL_KEY
SETCHIPREV_AA | SPRITEA_XReplication | SUPER72LORESEHBDBL_KEY
SETCHIPREV_BEST | SPRITEA_YReplication | SUPER72LORESHAMDBL_KEY
SETCHIPREV_ECS | SPRITERESN_140NS | SUPER72_MONITOR_ID
SetCollision | SPRITERESN_35NS | SUPER72SUPERDBL_KEY
SetDrMd | SPRITERESN_70NS | SUPER72SUPEREHBDBL_KEY
SetDrPt | SPRITERESN_DEFAULT | SUPER72SUPERHAMDBL_KEY
SetFont | SPRITERESN_ECS | SUPERDPF2_KEY
SetMaxPen | SPRITES | SUPERDPF_KEY
SetOPen | SS_GRAPHICS | SUPEREHB_KEY
SetOutlinePen | STANDARD_COLORCLOCKS | SUPEREHBLACE_KEY
SetRast | STANDARD_DENISE_MAX | SUPERHAM_KEY
SetRGB32 | STANDARD_DENISE_MIN | SUPERHAMLACE_KEY
SetRGB32CM | STANDARD_HBSTOP | SUPERHIRES
SetRGB4 | STANDARD_HBSTRT | SUPER_KEY
SetRGB4CM | STANDARD_HSSTOP | SUPERLACEDPF2_KEY
SetRPAttrs | STANDARD_HSSTRT | SUPERLACEDPF_KEY
SetRPAttrsA | STANDARD_MONITOR_MASK | SUPERLACE_KEY
SetSoftStyle | STANDARD_NTSC_BEAMCON | SUSERFLAGS
SetWriteMask | STANDARD_NTSC_ROWS | SyncSBitMap

T

TAATextFont | TE1F_NOANTIALIASING | TQueryHeader
TA_CharSet | TE1F_NODEEMBOLDENING | TRasInfo
TA_DeviceDPI | TE1F_NODESHEARING | TRastPort
TAlphaHookMsg | TE1F_NODEUNDERLINING | TRastPortExtra
TAnalogSignalInterval | TE1F_NOEMBOLDENING | TRect32
TAnimComp | TE1F_NOSHEARING | TRectangle
TAnimOb | TE1F_NOUNDERLINING | tRegion
TAreaInfo | TExtendedNode | TRegionRectangle
TA_Rebuild | TextExtent | TShapeHookMsg
TBitMap | TextFit | TSimpleSprite
TBitScaleArgs | TextLength | TSpecialMonitor
TBob | TExtSprite | TTextAttr
TClipRect | TGelsInfo | TTextExtent
TColorFontColors | TGfxBase | TTextFont
TColorMap | TIsrvstr | TTextFontExtension
TColorTextFont | TLayer | TTmpRas
TCopInit | TMonitorInfo | TTTextAttr
TCopIns | TMonitorSpec | TUCopList
TCopList | TNameInfo | TVecInfo
TCprList | TODA_SAFE | TVecTable
TDBufInfo | TO_MONITOR | TView
tDBufPacket | TOPHIT | TViewExtra
TDimensionInfo | TPaletteExtra | TViewPort
TDisplayInfo | LongWord | tViewPortExtra
TE0B_NOREMFONT | TPlanarYUVInfo | TVSprite
TE0F_NOREMFONT | PByte |
TE1F_GENFONT | TPoint |

U

UCopperListInit | UnlockBitMapFromBoard | USER_COPPER_CLIP
UnlockBitMap | UnlockLayerRom |

V

VBeamPos | VGALORESHAMLACE_KEY | VTAG_BITPLANEKEY_SET
VC_DPMSLevel | VGALORES_KEY | VTAG_BORDERBLANK_CLR
VC_DUALPF_Disable | VGALORESLACEDPF2_KEY | VTAG_BORDERBLANK_GET
VC_DUALPF_Disable_Query | VGALORESLACEDPF_KEY | VTAG_BORDERBLANK_SET
VC_IntermediateCLUpdate | VGALORESLACE_KEY | VTAG_BORDERNOTRANS_CLR
VC_IntermediateCLUpdate_Query | VGA_MONITOR_ID | VTAG_BORDERNOTRANS_GET
VC_NoColorPaletteLoad | VGA_MONITOR_NAME | VTAG_BORDERNOTRANS_SET
VC_NoColorPaletteLoad_Query | VGAPRODUCTDBL_KEY | VTAG_BORDERSPRITE_CLR
VGA70_COLORCLOCKS | VGAPRODUCTDPF2_KEY | VTAG_BORDERSPRITE_GET
VGA70_DENISE_MIN | VGAPRODUCTDPF_KEY | VTAG_BORDERSPRITE_SET
VGA70_HBSTOP | VGAPRODUCTEHBDBL_KEY | VTAG_CHROMAKEY_CLR
VGA70_HBSTRT | VGAPRODUCTHAMDBL_KEY | VTAG_CHROMAKEY_GET
VGA70_HSSTOP | VGAPRODUCTHAM_KEY | VTAG_CHROMAKEY_SET
VGA70_HSSTRT | VGAPRODUCTHAMLACE_KEY | VTAG_CHROMA_PEN_CLR
VGA70_MONITOR_NAME | VGAPRODUCT_KEY | VTAG_CHROMA_PEN_GET
VGA70_TOTAL_ROWS | VGAPRODUCTLACEDPF2_KEY | VTAG_CHROMA_PEN_SET
VGA70_VBSTOP | VGAPRODUCTLACEDPF_KEY | VTAG_CHROMA_PLANE_GET
VGA70_VBSTRT | VGAPRODUCTLACE_KEY | VTAG_CHROMA_PLANE_SET
VGA70_VSSTOP | VGA_TOTAL_ROWS | VTAG_COERCE_DISP_GET
VGA70_VSSTRT | VGA_VBSTOP | VTAG_COERCE_DISP_SET
VGA_COLORCLOCKS | VGA_VBSTRT | VTAG_DEFSPRITERESN_GET
VGA_DENISE_MIN | VGA_VSSTOP | VTAG_DEFSPRITERESN_SET
VGAEHB_KEY | VGA_VSSTRT | VTAG_END_CM
VGAEHBLACE_KEY | VideoControl | VTAG_FULLPALETTE_CLR
VGAEXTRAHALFBRITE_KEY | VIDEOCONTROL_BATCH | VTAG_FULLPALETTE_GET
VGAEXTRAHALFBRITELACE_KEY | VideoControlTags | VTAG_FULLPALETTE_SET
VGAEXTRALORESDBL_KEY | VIEW_EXTRA_TYPE | VTAG_IMMEDIATE
VGAEXTRALORESDPF2_KEY | VIEWPORT_EXTRA_TYPE | VTAG_NEXTBUF_CM
VGAEXTRALORESDPF_KEY | VPF_A2024 | VTAG_NORMAL_DISP_GET
VGAEXTRALORESEHBDBL_KEY | VPF_AGNUS | VTAG_NORMAL_DISP_SET
VGAEXTRALORESEHB_KEY | VPF_TENHZ | VTAG_PF1_BASE_GET
VGAEXTRALORESEHBLACE_KEY | VP_HIDE | VTAG_PF1_BASE_SET
VGAEXTRALORESHAMDBL_KEY | VPOSRLOF | VTAG_PF1_TO_SPRITEPRI_GET
VGAEXTRALORESHAM_KEY | VPXB_FREE_ME | VTAG_PF1_TO_SPRITEPRI_SET
VGAEXTRALORESHAMLACE_KEY | VPXB_LAST | VTAG_PF2_BASE_GET
VGAEXTRALORES_KEY | VPXB_STRADDLES_256 | VTAG_PF2_BASE_SET
VGAEXTRALORESLACEDPF2_KEY | VPXB_STRADDLES_512 | VTAG_PF2_TO_SPRITEPRI_GET
VGAEXTRALORESLACEDPF_KEY | VPXF_FREE_ME | VTAG_PF2_TO_SPRITEPRI_SET
VGAEXTRALORESLACE_KEY | VPXF_LAST | VTAG_SPEVEN_BASE_GET
VGAHAM_KEY | VPXF_STRADDLES_256 | VTAG_SPEVEN_BASE_SET
VGAHAMLACE_KEY | VPXF_STRADDLES_512 | VTAG_SPODD_BASE_GET
VGA_HBSTOP | VSOVERFLOW | VTAG_SPODD_BASE_SET
VGA_HBSTRT | VSPRITE_f | VTAG_SPRITERESN_GET
VGA_HSSTOP | VTAG_ATTACH_CM_GET | VTAG_SPRITERESN_SET
VGA_HSSTRT | VTAG_ATTACH_CM_SET | VTAG_USERCLIP_CLR
VGALORESDBL_KEY | VTAG_BATCH_CM_CLR | VTAG_USERCLIP_GET
VGALORESDPF2_KEY | VTAG_BATCH_CM_GET | VTAG_USERCLIP_SET
VGALORESDPF_KEY | VTAG_BATCH_CM_SET | VTAG_VIEWPORTEXTRA_GET
VGALORESEHBDBL_KEY | VTAG_BATCH_ITEMS_ADD | VTAG_VIEWPORTEXTRA_SET
VGALORESEHB_KEY | VTAG_BATCH_ITEMS_GET | VTAG_VPMODEID_CLR
VGALORESEHBLACE_KEY | VTAG_BATCH_ITEMS_SET | VTAG_VPMODEID_GET
VGALORESHAMDBL_KEY | VTAG_BITPLANEKEY_CLR | VTAG_VPMODEID_SET
VGALORESHAM_KEY | VTAG_BITPLANEKEY_GET | SmallInt

W

WaitBlit | WriteChunkyPixels | WritePixelArray8
WaitBOVP | WritePixel | WritePixelColor
WaitTOF | WritePixelArray | WritePixelLine8

X

XorRectRegion XorRegionRegion


AddAnimOb

Add an AnimOb to the linked list of AnimObs.

Declaration

Source position: agraphics.pas line 2319

procedure AddAnimOb(

  AnOb: PAnimOb;

  AnKey: PPAnimOb;

  Rp: PRastPort

);

Arguments

AnOb | Pointer to the TAnimOb structure to be added to the list
AnKey | Address of a Pointer to the first TAnimOb in the list (anKey = nil if there are no PAnimObs in the list so far)
Rp | Pointer to a valid RastPort

Description

Links this PAnimOb into the current list pointed to by animKey. Initializes all the Timers of the AnimOb's components. Calls AddBob with each component's Bob. TRastPort.GelsInfo must point to an initialized PGelsInfo structure.

See also

Animate

Processes every AnimOb in the current animation list.


AddBob

Adds a Bob to current gel list.

Declaration

Source position: agraphics.pas line 2309

procedure AddBob(

  Bob: PBob;

  Rp: PRastPort

);

Arguments

Bob | Pointer to the Bob structure to be added to the gel list
Rp | Pointer to a TRastPort structure

Description

Sets up the system Bob flags, then links this gel into the list via AddVSprite().

See also

InitGels | initialize a gel list; must be called before using gels.
AddVSprite | Add a VSprite to the current gel list.


AddFont

Add a font to the system list

Declaration

Source position: agraphics.pas line 2373

procedure AddFont(

  TextFont: PTextFont

);

Arguments

TextFont

A TextFont structure in public ram.

Description

This function adds the text font to the system, making it available for use by any application. The font added must be in public memory, and remain until successfully removed. This function will set the tf_Accessors to 0.

See also

SetFont | Set the text font and attributes in a RastPort.
RemFont | Remove a font from the system list.


AddVSprite

Add a VSprite to the current gel list.

Declaration

Source position: agraphics.pas line 2310

procedure AddVSprite(

  VSprite: PVSprite;

  Rp: PRastPort

);

Arguments

VSprite | Pointer to the VSprite structure to be added to the gel list
Rp | Pointer to a RastPort structure

See also

InitGels

initialize a gel list; must be called before using gels.


AllocBitMap

Allocate a bitmap and attach bitplanes to it.

Declaration

Source position: agraphics.pas line 2450

function AllocBitMap(

  SizeX: LongWord;

  SizeY: LongWord;

  Depth: LongWord;

  Flags: LongWord;

  const FriendBitmap: PBitMap

):PBitMap;

Arguments

SizeX | The width (in pixels) desired for the bitmap data.
SizeY | The height (in pixels) desired.
Depth | The number of bitplanes deep for the allocation. Pixels with at least this many bits will be allocated.
Flags | Flags for Bitmap creation (BMF_*)

Description

Allocates and initializes a bitmap structure. Allocates and initializes bitplane data, and sets the bitmap's planes to point to it.

BMF_CLEAR
to specify that the allocated raster should be filled with color 0.
BMF_DISPLAYABLE
to specify that this bitmap data should be allocated in such a manner that it can be displayed. Displayable data has more severe alignment restrictions than non-displayable data in some systems.
BMF_INTERLEAVED
tells graphics that you would like your bitmap to be allocated with one large chunk of display memory for all bitplanes. This minimizes color flashing on deep displays. If there is not enough contiguous RAM for an interleaved bitmap, graphics.library will fall back to a non-interleaved one.
BMF_MINPLANES
causes graphics to only allocate enough space in the bitmap structure for "depth" plane pointers. This is for system use and should not be used by applications use as it is inefficient, and may waste memory.

NOTE:

When allocating using a friend bitmap, it is not safe to assume anything about the structure of the bitmap data if that friend BitMap might not be a standard amiga bitmap (for instance, if the workbench is running on a non-amiga display device, its Screen^.RastPort^.BitMap won't be in standard amiga format. The only safe operations to perform on a non-standard BitMap are:

  • blitting it to another bitmap, which must be either a standard Amiga bitmap, or a friend of this bitmap.
  • blitting from this bitmap to a friend bitmap or to a standard Amiga bitmap.
  • attaching it to a rastport and making rendering calls.

Good arguments to pass for the friend_bitmap are your window's RPort^.BitMap, and your screen's RastPort^.BitMap. Do not pass @(screenptr^.BitMap)!

BitMaps not allocated with BMF_DISPLAYABLE may not be used as Intuition Custom BitMaps or as RasInfo^.BitMaps. They may be blitted to a BMF_DISPLAYABLE BitMap, using one of the BltBitMap() family of functions.

See also

FreeBitMap

Free a bitmap created by AllocBitMap()


AllocBitMapTagList

Declaration

Source position: agraphics.pas line 2482

function AllocBitMapTagList(

  SizeX: LongWord;

  SizeY: LongWord;

  Depth: LongWord;

  const Tags: PTagItem

):PBitMap;


AllocDBufInfo

Allocate structure for multi-buffered animation

Declaration

Source position: agraphics.pas line 2459

function AllocDBufInfo(

  Vp: PViewPort

):PDBufInfo;

Arguments

Vp

A pointer to a ViewPort structure.

Function result

Returns 0 if there is no memory available or if the display mode of the viewport does not support double-buffering.

Description

Allocates a structure which is used by the ChangeVPBitMap() routine.

The only fields of the TDBufInfo structure which can be used by application programs are the dbi_SafeMessage, dbi_DispMessage, dbi_UserData1 and dbi_UserData2 fields.

dbi_SafeMessage and dbi_DispMessage are standard exec message structures which may be used for synchronizing your animation with the screen update.

dbi_SafeMessage is a message which is replied to when it is safe to write to the old BitMap (the one which was installed when you called ChangeVPBitMap()).

dbi_DispMessage is replied to when it is safe to call ChangeVPBitMap() again and be certain that the new frame has been seen at least once.

The dbi_UserData1 and dbi_UserData2 fields, which are stored after each message, are for your application to stuff any data into that it may need to examine when looking at the reply coming into the ReplyPort for either of the embedded Message structures.

TDBufInfo structures must be allocated with this function. The size of the structure will grow in future releases.

See also

FreeDBufInfo | Free information for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation

Example

// The following fragment shows proper double buffering synchronization:
var
  SafeToChange: Boolean = True;
  SafeToWrite: Boolean = True;
  CurBuffer: Integer = 1;
  Ports: array[0..1] of PMsgPort; // reply ports for DispMessage and SafeMessage
  BmPtrs: array[0..1] of PBitmap;
  myDBI: PDBufInfo;
begin
  //... allocate bitmap pointers, DBufInfo, set up viewports, create Ports etc.
  myDBI^.dbi_SafeMessage.mn_ReplyPort := ports[0];
  myDBI^.dbi_DispMessage.mn_ReplyPort := ports[1];
  while not done do
  begin
    if not SafeToWrite then
    begin
      while GetMsg(ports[0]) = nil do
        Wait(1 shl ports[0]^.mp_SigBit);
    end;
    SafeToWrite := True;
// ... render to bitmap # CurBuffer.
    if not SafeToChange then
    begin
      while GetMsg(ports[1]) = nil do
        Wait(1 shl ports[1]^.mp_SigBit);
    end;
    SafeToChange := True;
    WaitBlit();         // be sure rendering has finished
    ChangeVPBitMap(vp, BmPtrs[CurBuffer], myDBI);
    SafeToChange := False;
    SafeToWrite := False;
    CurBuffer := (CurBuffer + 1) and 1; // toggle current buffer
  end;
  if not SafeToChange then
  begin
    while GetMsg(ports[1]) = nil do
      Wait(1 shl ports[1]^.mp_SigBit);
  end;
  if not SafeToWrite then
  begin
    while GetMsg(ports[0]) = nil do
      Wait(1 shl ports[0]^.mp_SigBit);
  end;
end;


AllocRaster

Allocate space for a bitplane.

Declaration

Source position: agraphics.pas line 2375

function AllocRaster(

  Width: LongWord;

  Height: LongWord

):PByte;

Arguments

Width | number of columns in bitplane
Height | number of rows in bitplane

Function result

Pointer to first word in bitplane, or nil if it was not possible to allocate the desired amount of memory.

Description

This function calls the memory allocation routines to allocate memory space for a bitplane "width" bits wide and "height" bits high.

In order to assure proper alignment of display memory, the AllocBitMap() function should be used instead of AllocRaster when you wish to allocate display memory (rasters which are attached to a ViewPort or Screen).

See also

FreeRaster

Release an allocated area to the system free memory pool


AllocSpriteData

VarArgs Version of AllocSpriteDataA()

Declaration

Source position: agraphics.pas line 2506

function AllocSpriteData(

  bm: PBitMap;

  const argv: array of PtrUInt

):PExtSprite;


AllocSpriteDataA

Allocate sprite data and convert from a bitmap.

Declaration

Source position: agraphics.pas line 2468

function AllocSpriteDataA(

  const Bm: PBitMap;

  const Tags: PTagItem

):PExtSprite;

Function result

a pointer to a ExtSprite structure, or nil if there is a failure. You should pass this pointer to FreeSpriteData() when finished with the sprite.

Description

Allocate memory to hold a sprite image, and convert the passed-in bitmap data to the appropriate format. The tags allow specification of width, scaling, and other options.

See also

FreeSpriteData | free sprite data allocated by AllocSpriteData()
FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.
AllocBitMap | Allocate a bitmap and attach bitplanes to it.
AllocSpriteData | VarArgs Version of AllocSpriteDataA()


AndRectRegion

Perform 2d AND operation of rectangle with region, leaving result in region.

Declaration

Source position: agraphics.pas line 2377

procedure AndRectRegion(

  Region: PRegion;

  const Rectangle: PRectangle

);

Description

Clip away any portion of the region that exists outside of the rectangle. Leave the result in region. Unlike the other rect-region primitives, AndRectRegion() cannot fail.

See also

AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.
ClearRectRegion


AndRegionRegion

Perform 2d AND operation of one region with second region, leaving result in second region.

Declaration

Source position: agraphics.pas line 2397

function AndRegionRegion(

  const SrcRegion: PRegion;

  DestRegion: PRegion

):LongBool;

Arguments

SrcRegion | A pointer to Region structure
DestRegion | A pointer to Region structure to use and for result

Function result

Returns True if successful operation, returns False if ran out of memory

Description

Remove any portion of region2 that is not in region1.

See also

OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.
ClearRectRegion


Animate

Processes every AnimOb in the current animation list.

Declaration

Source position: agraphics.pas line 2320

procedure Animate(

  AnKey: PPAnimOb;

  Rp: PRastPort

);

Arguments

AnKey | Address of the variable that points to the head AnimOb
Rp | Pointer to the RastPort structure

Description

For every AnimOb in the list:

  • update its location and velocities
  • call the AnimOb's special routine if one is supplied

for each component of the AnimOb:

  • if this sequence times out, switch to the new one
  • call this component's special routine if one is supplied
  • set the sequence's VSprite's y,x coordinates based on whatever these routines cause

See also

AddAnimOb

Add an AnimOb to the linked list of AnimObs.


AreaCircle

Draws a Circle in an Area

Declaration

Source position: agraphics.pas line 2536

function AreaCircle(

  Rp: PRastPort;

  xCenter: SmallInt;

  yCenter: SmallInt;

  r: SmallInt

):LongWord;

Arguments

Rp | A pointer to a RastPort
xCenter | X coordinate for center of Circle
yCenter | Y coordinate for center of Circle
r | Radius of Circle

Description

Calls AreaEllipse() with a = b = r


AreaDraw

Add a point to a list of end points for areafill.

Declaration

Source position: agraphics.pas line 2336

function AreaDraw(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongInt;

Arguments

Rp | Points to a RastPort structure.
X | X coordinate of a point in the raster.
Y | Y coordinate of a point in the raster.

Function result

0 for success, else -1 if no there was no space left in the vector list.

Description

Add point to the vector buffer.

See also

InitArea | Initialize vector collection matrix
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaCircle | Draws a Circle in an Area
AreaEnd | Process table of vectors and ellipses and produce areafill.


AreaEllipse

Add a ellipse to areainfo list for areafill.

Declaration

Source position: agraphics.pas line 2324

function AreaEllipse(

  Rp: PRastPort;

  XCenter: LongInt;

  YCenter: LongInt;

  A: LongInt;

  B: LongInt

):LongInt;

Arguments

Rp | A pointer to a RastPort structure
XCenter | X coordinate of the centerpoint relative to the rastport.
YCenter | Y coordinate of the centerpoint relative to the rastport.
A | The horizontal radius of the ellipse (note: a must be > 0)
B | The vertical radius of the ellipse (note: b must be > 0)

Function result

0 for success, or -1 if there is no space left in the vector list

Description

Add an ellipse to the vector buffer. It will be draw when AreaEnd() is called.

See also

InitArea | Initialize vector collection matrix
AreaMove | Define a new starting point for a new shape in the vector list.
AreaDraw | Add a point to a list of end points for areafill.
AreaCircle | Draws a Circle in an Area
AreaEnd | Process table of vectors and ellipses and produce areafill.


AreaEnd

Process table of vectors and ellipses and produce areafill.

Declaration

Source position: agraphics.pas line 2337

function AreaEnd(

  Rp: PRastPort

):LongInt;

Arguments

Rp

A pointer to a RastPort structure which specifies where the filled regions will be rendered to.

Function result

0 for success, or -1 if an error occurred anywhere.

Description

Trigger the filling operation. Process the vector buffer and generate required fill into the raster planes. After the fill is complete, reinitialize for the next AreaMove or AreaEllipse. Use the raster set up by InitTmpRas when generating an areafill mask.

Errors

There is still a problem when some polygons are filled that pixels are missing. This could be due to the way lines are drawn. All lines should be drawn from lower y coordinates to higher y coordinates since this is the way the algorithm calculates lines here. For example, it might make a difference whether a line is drawn from lower to higher y coordinates.

See also

InitArea | Initialize vector collection matrix
AreaMove | Define a new starting point for a new shape in the vector list.
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaCircle | Draws a Circle in an Area


AreaMove

Define a new starting point for a new shape in the vector list.

Declaration

Source position: agraphics.pas line 2335

function AreaMove(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongInt;

Arguments

Rp | Points to a RastPort structure
X | X position in Raster
Y | Y position in Raster

Function result

0 for success, or -1 if there is no space left in the vector list

Description

Close the last polygon and start another polygon at (x,y). Add the necessary points to vector buffer. Closing a polygon may result in the generation of another AreaDraw() to close previous polygon. Remember to have an initialized TAreaInfo structure attached to the RastPort.

See also

InitArea | Initialize vector collection matrix
AreaEnd | Process table of vectors and ellipses and produce areafill.
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaCircle | Draws a Circle in an Area


AskFont

Get the text attributes of the current font

Declaration

Source position: agraphics.pas line 2372

procedure AskFont(

  Rp: PRastPort;

  TextAttr: PTextAttr

);

Arguments

Rp | The RastPort from which the text attributes are extracted
TextAttr | The TextAttr structure to be filled. Note that there is no support for a TTextAttr.

Description

This function fills the text attributes structure with the attributes of the current font in the RastPort.


AskSoftStyle

Get the soft style bits of the current font.

Declaration

Source position: agraphics.pas line 2307

function AskSoftStyle(

  Rp: PRastPort

):LongWord;

Arguments

Rp

The RastPort from which the font and style are extracted.

Function result

Those bits in the style algorithmically generated. Style bits that are not defined are also set.

Description

This function returns those style bits of the current font that are not intrinsic in the font itself, but algorithmically generated. These are the bits that are valid to set in the enable mask for SetSoftStyle().

See also

SetSoftStyle

Set the soft style of the current font.


AttachPalExtra

Allocate and attach a palette sharing structure to a colormap

Declaration

Source position: agraphics.pas line 2435

function AttachPalExtra(

  Cm: PColorMap;

  Vp: PViewPort

):LongInt;

Arguments

Cm | A pointer to a color map created by GetColorMap().
Vp | A pointer to the viewport structure associated with the ColorMap.

Function result

0 if sucessful, else an error number. The only currently defined error number is out of memory (1).

Description

Allocates and attaches a PalExtra structure to a ColorMap. This is necessary for color palette sharing to work. The PalExtra structure will be freed by FreeColorMap(). The set of available colors will be determined by the mode and depth of the viewport.

Note:

This function is for use with custom ViewPorts and custom ColorMaps, as Intuition attaches a PalExtra to all of its Screens. If there is already a PalExtra associated with the ColorMap, then this function will do nothing.

See also

GetColorMap | Allocate and initialize Colormap
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.
ObtainPen | Obtain a free palette entry for use by your program.
ObtainBestPenA | Search for the closest color match, or allocate a new one.


AttemptLockLayerRom

Attempt to Lock Layer structure by ROM(gfx lib) code

Declaration

Source position: agraphics.pas line 2402

function AttemptLockLayerRom(

  Layer: PLayer

):LongBool;

Function result

True or False depending on whether the Layer was successfully locked by the caller.

Description

Query the current state of the lock on this Layer. If it is already locked then return False, could not lock. If the Layer was not locked then lock it and return True. This call does not destroy any registers. This call nests so that callers in this chain will not lock themselves out.

See also

LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.


BestModeID

VarArgs version of BestModeIDA()

Declaration

Source position: agraphics.pas line 2507

function BestModeID(

  const argv: array of PtrUInt

):LongWord;


BestModeIDA

Calculate the best ModeID with given parameters

Declaration

Source position: agraphics.pas line 2477

function BestModeIDA(

  const Tags: PTagItem

):LongWord;

Arguments

Tags

A pointer to an array of TagItems. (BIDTAGS_*)

Function result

ID of the best mode to use, or INVALID_ID if a match could not be found.

Description

This function takes into account the Compatability of the Monitor being matched to, and the source ViewPort or ModeID. Incompatibilitys will cause a result of INVALID_ID.

BIDTAG_NominalWidth, BIDTAG_NominalHeight, BIDTAG_DesiredWidth, BIDTAG_DesiredHeight, must all be non-0.

The comparisons are made against the DimensionInfo->Nominal values. ie, this will not return a best fit against overscan dimensions.

Snippet

IFF Display Program with a HAM image, to be displayed in the same monitor type as the Workbench ViewPort.

ID := BestModeID([BIDTAG_NominalWidth,  IFFImage^.Width,
                  BIDTAG_NominalHeight, IFFImage^.Height,
                  BIDTAG_Depth,         IFFImage^.Depth,
                  BIDTAG_DIPFMustHave,  DIPF_IS_HAM,
                  BIDTAG_MonitorID,     (GetVPModeID(WbVP) and MONITOR_ID_MASK)]);

To make an interlace version of a ViewPort:

ID := BestModeID([BIDTAG_ViewPort, ThisViewPort,
                  BIDTAG_MustHave, DIFP_IS_LACE]);

See also

BestModeID

VarArgs version of BestModeIDA()


BitMapScale

Perform raster scaling on a bit map.

Declaration

Source position: agraphics.pas line 2406

procedure BitMapScale(

  BitScaleArgs: PBitScaleArgs

);

Arguments

BitScaleArgs

Structure of parameters describing scale

Description

Scale a source bit map to a non-overlapping destination bit map.

Overlapping source and destination bitmaps are not supported Make sure that you provide enough memory for the destination bitmap to hold the result

In the destination bitmap only the area where the scaled source bitmap is put into is changed. A frame of the old bitmap is left.

Pass a BitScaleArgs structure filled with the following arguments to this function:

bsa_SrcX, bsa_SrcY
upper left coordinate in source bitmap
bsa_SrcWidth, bsa_SrcHeight
Width and Height of source bitmap
bsa_DestX, bsa_DestY
upper left coordinate in destination bitmap
bsa_DestWidth, bsa_DestHeight
this function will set these values. Use the bsa_???Factor for scaling
bsa_XSrcFactor:bsa_XDestFactor
Set these to get approximately the same ratio as bsa_SrcWidth:bsa_DestWidth, but usually not exactly the same number.
bsa_YSrcFactor:bsa_YDestFactor
Set these to get approximately the same ratio as bsa_SrcHeight:DestHeight, but usually not exactly the same number.
bsa_SrcBitMap
pointer to source bitmap to be scaled
bsa_DestBitMap
pointer to destination bitmap which will hold the scaled bitmap. Make sure it's big enough!
bsa_Flags
reserved for future use. Set it to zero!
bsa_XDDA, bsa_YDDA
for future use.
bsa_Reserved1, bsa_Reserved2
for future use.

bsa_DestWidth and bsa_DestHeight will be set by this function

See also

ScalerDiv

Get the scaling result that BitMapScale would.


BltBitMap

Move a rectangular region of bits in a BitMap.

Declaration

Source position: agraphics.pas line 2298

function BltBitMap(

  const SrcBitMap: PBitMap;

  XSrc: LongInt;

  YSrc: LongInt;

  DestBitMap: PBitMap;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt;

  MinTerm: LongWord;

  Mask: LongWord;

  TempA: PChar

):LongInt;

Arguments

SrcBitMap | Copy from this bitmap. as a special case, if a plane pointer in the SrcBitMap is nil, it acts as a pointer to a plane of all zeros, and if the plane pointer is $ffffffff, it acts as a pointer to a plane of all ones.
XSrc | Top Left corner of the Source rectangle
YSrc | Valid range is positive signed integer such that the raster word's offset 0..(32767-Size)
DestBitMap | Copy to this bitmap. May be the same as srcBitMap.
XDest | the x and y coordinates of the upper left corner of the destination for the rectangle.
YDest | Valid range is as for Src.
XSize | The size of the rectangle to be moved.
YSize | Valid range is (X: 1..976; Y: 1..1023 such that final raster word's offset is 0..32767)
MinTerm | See description
Mask | the write mask to apply to this operation. Bits set indicate the corresponding planes (if not greater than the minimum plane count) are to participate in the operation. Typically this is set to $ff.
TempA | If the copy overlaps exactly to the left or right (i.e. the scan line addresses overlap), and TempA is non-zero, it points to enough chip accessible memory to hold a line of A source for the blit (ie CHIP RAM). BltBitMap will allocate (and free) the needed TempA if none is provided and one is needed. Blit overlap is determined from the relation of the first non-masked planes in the source and destination bit maps.

Function result

The number of planes actually involved in the blit.

Description

Perform non-destructive blits to move a rectangle from one area in a BitMap to another area, which can be on a different BitMap. This blit is assumed to be friendly: no error conditions (e.g. a rectangle outside the BitMap bounds) are tested or reported.

If a special hardware is available, this function will use it.

MinTerm:

How to copy. Most useful values are 0x00C0 for a vanilla copy, 0x0030 to invert the source and then copy or 0x0050 to ignore the source and just invert the destination. If you want to calculate other values, then you must know that channel A is set, if you are inside the rectangle, channel B is the source and channel C is the destination of the rectangle.

Bit | ABC
0 | 000
1 | 001
2 | 010
3 | 011
4 | 100
5 | 101
6 | 110
7 | 111

So 0x00C0 means: D is set if one is inside the rectangle (A is set) and B (the source) is set and cleared otherwise.

To fill the rectangle, you would want to set D when A is set, so the value is 0x00F0.

See also

ClipBlit | Calls BltBitMap() after accounting for windows
BltBitMapRastPort | Blit from source bitmap to destination rastport.


BltBitMaPRastPort

Blit from source bitmap to destination rastport.

Declaration

Source position: agraphics.pas line 2394

function BltBitMaPRastPort(

  const SrcBitMap: PBitMap;

  XSrc: LongInt;

  YSrc: LongInt;

  DestRP: PRastPort;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt;

  Minterm: LongWord

):LongBool;

Arguments

SrcBitMap | A pointer to the source bitmap
XSrc | X offset into source bitmap
YSrc | Y offset into source bitmap
DestRP | A pointer to the destination rastport
XDest | X offset into dest rastport
YDest | Y offset into dest rastport
XSize | Width of blit in pixels
YSize | Height of blit in rows
Minterm | Minterm to use for this blit see description

Description

Blits from source bitmap to position specified in destination rastport using minterm.

MinTerm:

How to copy. Most useful values are 0x00C0 for a vanilla copy, 0x0030 to invert the source and then copy or 0x0050 to ignore the source and just invert the destination. If you want to calculate other values, then you must know that channel A is set, if you are inside the rectangle, channel B is the source and channel C is the destination of the rectangle.

Bit | ABC
0 | 000
1 | 001
2 | 010
3 | 011
4 | 100
5 | 101
6 | 110
7 | 111

So 0x00C0 means: D is set if one is inside the rectangle (A is set) and B (the source) is set and cleared otherwise.

To fill the rectangle, you would want to set D when A is set, so the value is 0x00F0.

See also

BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ClipBlit | Calls BltBitMap() after accounting for windows


BltBitMapTagList

Declaration

Source position: agraphics.pas line 2448

function BltBitMapTagList(

  const Tags: PTagItem

):LongInt;


BltClear

Clear a block of memory words to zero.

Declaration

Source position: agraphics.pas line 2343

procedure BltClear(

  MemBlock: PByte;

  ByteCount: LongWord;

  Flags: LongWord

);

Arguments

MemBlock | pointer to local memory to be cleared memBlock is assumed to be even.
ByteCount | if bit 1 is set to 1: bytecount contains an even number of bytes to clear if bit 1 is set to 0: low 16 bits are taken as number of bytes per row and upper 16 bits are taken as number of rows.
Flags | set bit 0 to force function to wait until the blit is done. set bit 1 to use row/bytesperrow.

Description

For memory that is local and blitter accessible, the most efficient way to clear a range of memory locations is to use the system's most efficient data mover, the blitter. This command accepts the starting location and count and clears that block to zeros.

THIS FUNCTION IS DEPRECATED


BltMaskBitMapRastPort

Blit from source bitmap to destination rastport with masking of source image.

Declaration

Source position: agraphics.pas line 2399

procedure BltMaskBitMapRastPort(

  const SrcBitMap: PBitMap;

  XSrc: LongInt;

  YSrc: LongInt;

  DestRP: PRastPort;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt;

  MinTerm: LongWord;

  const BltMask: PByte

);

Arguments

SrcBitMap | A pointer to the source bitmap
XSrc | X offset into source bitmap
YSrc | Y offset into source bitmap
DestRP | A pointer to the destination rastport
XDest | X offset into dest rastport
YDest | Y offset into dest rastport
XSize | Width of blit in pixels
YSize | Height of blit in rows
MinTerm | either (ABC or ABNC or ANBC) if copy source and blit thru mask or (ANBC) if invert source and blit thru mask
BltMask | A pointer to the single bit-plane mask, which must be the same size and dimensions as the planes of the source bitmap.

Description

Blits from source bitmap to position specified in destination rastport using bltmask to determine where source overlays destination, and minterm to determine whether to copy the source image "as is" or to "invert" the sense of the source image when copying. In either case, blit only occurs where the mask is non-zero.

See also

BltBitMapRastPort

Blit from source bitmap to destination rastport.


BltPattern

Using standard drawing rules for areafill, blit through a mask.

Declaration

Source position: agraphics.pas line 2345

procedure BltPattern(

  Rp: PRastPort;

  const Mask: PByte;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt;

  MaskBPR: LongWord

);

Arguments

Rp | Points to the destination RastPort for the blit.
Mask | points to 2 dimensional mask if needed if mask = nil then use a rectangle.
XMin | coordinates of upper left of rectangular region in RastPort
XMax | points to lower right of rectangular region in RastPort

Description

Blit using drawmode,areafill pattern, and mask at position rectangle (xl,yl) (maxx,maxy).

See also

AreaEnd

Process table of vectors and ellipses and produce areafill.


BltTemplate

Cookie cut a shape in a rectangle to the RastPort.

Declaration

Source position: agraphics.pas line 2299

procedure BltTemplate(

  const Source: PByte;

  XSrc: LongInt;

  SrcMod: LongInt;

  DestRP: PRastPort;

  XDest: LongInt;

  YDest: LongInt;

  XSize: LongInt;

  YSize: LongInt

);

Arguments

Source | A pointer to the first (nearest) word of the template mask.
XSrc | X bit offset into the template mask (range 0..15).
SrcMod | Number of bytes per row in template mask.
DestRP | A pointer to destination RastPort.
XDest | x coordinate of the upper left corner of the destination for the blit.
YDest | y coordinate of the upper left corner of the destination for the blit.
XSize | x size of the rectangle to be used as the template.
YSize | y size of the rectangle to be used as the template.

Description

This function draws the image in the template into the RastPort in the current color and drawing mode at the specified position. The template is assumed not to overlap the destination. If the template falls outside the RastPort boundary, it is truncated to that boundary.

Note:

The SrcTemplate pointer should point to the "nearest" word (rounded down) of the template mask. Fine alignment of the mask is achieved by setting the SrcX bit offseet within the range of 0 to 15 decimal.

See also

BltBitMap

Move a rectangular region of bits in a BitMap.


BNDRYOFF

Turn Boundary off

Declaration

Source position: agraphics.pas line 2518

procedure BNDRYOFF(

  w: PRastPort

);


CalcIVG

Calculate the number of blank lines above a ViewPort

Declaration

Source position: agraphics.pas line 2434

function CalcIVG(

  V: PView;

  Cp: PViewPort

):LongWord;

Function result

the number of ViewPort resolution scan lines needed to execute all the copper instructions for ViewPort, or 0 if any error

Description

To calculate the maximum number of blank lines above a viewport needed to load all the copper instructions, after accounting for the viewport bandwidth and size.

Errors

This function is unimplemented.


CBump

Increment user copper list pointer (bump to next position in list).

Declaration

Source position: agraphics.pas line 2354

procedure CBump(

  CopList: PUCopList

);

Arguments

CopList

A pointer to UCopList structure

Description

Increment pointer to space for next instruction in user copper list.

Note:

CBump is usually invoked for the programmer as part of the helper functions CWAIT or CMOVE.

See also

CWAIT | Append copper wait instruction to user copper list.
CMOVE | Append copper move instruction to user copper list.


ChangeExtSprite

VarArgs version of ChangeExtSpriteA

Declaration

Source position: agraphics.pas line 2508

function ChangeExtSprite(

  vp: PViewPort;

  oldsprite: PExtSprite;

  newsprite: PExtSprite;

  const argv: array of PtrUInt

):LongInt;


ChangeExtSpriteA

Change the sprite image pointer.

Declaration

Source position: agraphics.pas line 2470

function ChangeExtSpriteA(

  Vp: PViewPort;

  OldSprite: PExtSprite;

  NewSprite: PExtSprite;

  const Tags: PTagItem

):LongInt;

Arguments

Vp | A pointer to ViewPort structure that this sprite is relative to, or nil if relative only top of View
OldSprite | A pointer the old ExtSprite structure
NewSprite | A pointer to the new ExtSprite structure.
Tags | Tags for change the Sprite (GSTAG_*)

Function result

0 if there was an error.

Description

Attempt to change which sprite is displayed for a given sprite engine.

See also

ChangeExtSprite | VarArgs version of ChangeExtSpriteA
FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.


ChangeSprite

Change the sprite image pointer.

Declaration

Source position: agraphics.pas line 2363

procedure ChangeSprite(

  Vp: PViewPort;

  Sprite: PSimpleSprite;

  NewData: Pointer

);

Arguments

Vp | Pointer to ViewPort structure that this sprite is relative to, or nil if relative only top of View
NewData | Pointer to new data structure

Description

The sprite image is changed to use the data starting at newdata

Errors

This function is unimplemented.

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeExtSpriteA | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
AddVSprite | Add a VSprite to the current gel list.


ChangeVPBitMap

Change display memory address for multi-buffered animation

Declaration

Source position: agraphics.pas line 2455

procedure ChangeVPBitMap(

  Vp: PViewPort;

  Bm: PBitMap;

  Db: PDBufInfo

);

Arguments

Vp | A pointer to a viewport
Bm | This BitMap structure must be of the same layout as the one attached to the viewport (same depth, alignment, and BytesPerRow).
Db | A pointer to a DBufInfo.

Description

Changes the area of display memory which will be displayed in a viewport. This can be used to implement double (or triple) buffering, a method of achieving smooth animation.

This will set the vp^.RasInfo^.BitMap field to the bm pointer which is passed.

When using the synchronization features, you must carefully insure that all messages have been replied to before calling FreeDBufInfo or calling ChangeVPBitMap with the same DBufInfo.

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
AllocBitMap | Allocate a bitmap and attach bitplanes to it.


ClearEOL

Clear from current position to end of line.

Declaration

Source position: agraphics.pas line 2300

procedure ClearEOL(

  Rp: PRastPort

);

Arguments

Rp

A pointer to RastPort structure

Description

Clear a rectangular swath from the current position to the right edge of the rastPort. The height of the swath is taken from that of the current text font, and the vertical positioning of the swath is adjusted by the text baseline, such that text output at this position would lie wholly on this newly cleared area. Clearing consists of setting the color of the swath to zero, or, if the DrawMode is 2, to the BgPen. This function may use the blitter.

See also

GfxText | Write text characters (no formatting).
ClearScreen | Clear from current position to end of RastPort.
SetRast | Set an entire drawing area to a specified color.


ClearRectRegion

Declaration

Source position: agraphics.pas line 2380

function ClearRectRegion(

  Region: PRegion;

  const Rectangle: PRectangle

):LongBool;


ClearRegion

Declaration

Source position: agraphics.pas line 2381

procedure ClearRegion(

  Region: PRegion

);


ClearScreen

Clear from current position to end of RastPort.

Declaration

Source position: agraphics.pas line 2301

procedure ClearScreen(

  Rp: PRastPort

);

Arguments

Rp

A pointer to RastPort structure

Description

Clear a rectangular swath from the current position to the right edge of the rastPort with ClearEOL(), then clear the rest of the screen from just beneath the swath to the bottom of the rastPort. Clearing consists of setting the color of the swath to zero, or, if the DrawMode is 2, to the BgPen. This function may use the blitter.

See also

ClearEOL | Clear from current position to end of line.
GfxText | Write text characters (no formatting).
SetRast | Set an entire drawing area to a specified color.


ClipBlit

Calls BltBitMap() after accounting for windows

Declaration

Source position: agraphics.pas line 2385

procedure ClipBlit(

  SrcRP: PRastPort;

  XSrc: LongInt;

  ySrc: LongInt;

  DestRP: PRastPort;

  XDest: LongWord;

  YDest: LongWord;

  XSize: LongWord;

  YSize: LongWord;

  MinTerm: LongWord

);

Arguments

SrcRP | A pointer to the RastPort of the source for your blit
XSrc | The left offset into Src for your data
ySrc | The top offset into Src for your data
DestRP | A pointer to the RastPort to receive the blitted data
XDest | The left offset into the destination RastPort
YDest | The top offset into the destination RastPort
XSize | the width of the blit (must be ta least 1)
YSize | the height of the blit (must be at least 1)
MinTerm | the boolean blitter function, where SRCB is associated with the Src RastPort and SRCC goes to the Dest RastPort. see BltBitMap

Description

Performs the same function as BltBitMap(), except that it takes into account the Layers and ClipRects of the layer library, all of which are (and should be) transparent to you. So, whereas BltBitMap() requires pointers to BitMaps, ClipBlit requires pointers to the RastPorts that contain the Bitmaps, Layers, etcetera.

If you are going to blit blocks of data around via the RastPort of your Intuition Window, you must call this routine (rather than BltBitMap()).

Either the Src RastPort, the Dest RastPort, both, or neither, can have Layers. This routine takes care of all cases.

See BltBitMap() for a thorough explanation.

See also

BltBitMap

Move a rectangular region of bits in a BitMap.


CloseFont

Release a pointer to a system font.

Declaration

Source position: agraphics.pas line 2306

procedure CloseFont(

  TextFont: PTextFont

);

Arguments

TextFont

A font pointer as returned by OpenFont() or OpenDiskFont()

Description

This function indicates that the font specified is no longer in use. It is used to close a font opened by OpenFont(), so that fonts that are no longer in use do not consume system resources.


CloseMonitor

Close a MonitorSpec

Declaration

Source position: agraphics.pas line 2414

function CloseMonitor(

  MonitorSpec: PMonitorSpec

):LongBool;

Function result

False if MonitorSpec closed uneventfully. True if MonitorSpec could not be closed.

Description

Relinquish access to a MonitorSpec.


CMove

Append copper move instruction to user copper list.

Declaration

Source position: agraphics.pas line 2355

procedure CMove(

  CopList: PUCopList;

  DestOffset: LongInt;

  data: LongInt

);

Arguments

CopList

A pointer to a UCopList structure

Description

Add a copper move instruction to the given user copper list. The copper is told to move a value to register reg. If you are using CMOVE() a call to CMove() and CBump() will be made.


CoerceMode

Calculate ViewPort mode coercion

Declaration

Source position: agraphics.pas line 2454

function CoerceMode(

  Vp: PViewPort;

  MonitorID: LongWord;

  Flags: LongWord

):LongWord;

Arguments

MonitorID | Monitor number to coerce to (i.e. a mode masked with MONITOR_ID_MASK)
Flags | PRESERVE_COLORS = keep the number of bitplanes in the ViewPort AVOID_FLICKER = do not coerce to an interlace mode

Function result

ID of best mode to coerce to, or INVALID_ID if could not coerce

Description

To determine the best mode in the MonitorID to coerce RealViewPort to, given the restrictions set in Flags.

This function takes into account the compatibility of the Monitor being coerced to, and the ViewPort that is being coerced. Incompatibilities will cause a result of INVALID_ID.

Snippet

newmode := CoerceMode(vp, VGA_MONITOR_ID, PRESERVE_COLORS);

Errors

This function is unimplemented.


CompositeTagList

Declaration

Source position: agraphics.pas line 2480

function CompositeTagList(

  const Operator_: LongWord;

  const Source: PBitMap;

  const Destination: PBitMap;

  const Tags: PTagItem

):LongWord;


CopySBitMap

Syncronize Layer window with contents of Super BitMap

Declaration

Source position: agraphics.pas line 2368

procedure CopySBitMap(

  Layer: PLayer

);

Description

This is the inverse of SyncSBitMap(). Copy all bits from SuperBitMap to Layer bounds. This is used for those functions that do not want to deal with the ClipRect structures but do want to be able to work with a SuperBitMap Layer.

See also

LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
SyncSBitMap | Syncronize Super BitMap with whatever is in the standard Layer bounds.


CWait

Append copper wait instruction to user copper list.

Declaration

Source position: agraphics.pas line 2356

procedure CWait(

  CopList: PUCopList;

  V: LongInt;

  H: LongInt

);

Arguments

CopList | A pointer to UCopList structure
V | vertical beam position (relative to top of viewport)
H | horizontal beam position

Description

Add instruction to wait for vertical beam position v and horizontal position h to this intermediate copper list.

Errors

It's illegal to wait for horizontal values greater than 222 decimal!

See also

CMOVE

Append copper move instruction to user copper list.


DisownBlitter

Returns blitter to free state.

Declaration

Source position: agraphics.pas line 2370

procedure DisownBlitter;

Description

Free blitter up for use by other blitter users.

See also

OwnBlitter

get the blitter for private usage


DisposeRegion

Return all space for this region to free memory pool.

Declaration

Source position: agraphics.pas line 2382

procedure DisposeRegion(

  Region: PRegion

);

Arguments

Region

A pointer to Region structure

Description

Free all RegionRectangles for this Region then free the Region itself.

See also

NewRegion

Allocates memory for a new Region and initializes it to an empty Region.


DoCollision

Test every gel in gel list for collisions.

Declaration

Source position: agraphics.pas line 2311

procedure DoCollision(

  Rp: PRastPort

);

Arguments

Rp

A pointer to a RastPort

Description

Tests each gel in gel list for boundary and gel-to-gel collisions. On detecting one of these collisions, the appropriate collision- handling routine is called. See the documentation for a thorough description of which collision routine is called. This routine expects to find the gel list correctly sorted in Y,X order. The system routine SortGList() performs this function for the user.

See also

InitGels | initialize a gel list; must be called before using gels.
SortGList | Sort the current gel list, ordering its y,x coordinates.


Draw

Draw a line between the current pen position and the new x,y position.

Declaration

Source position: agraphics.pas line 2334

procedure Draw(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

);

Arguments

Rp | A pointer to the destination RastPort
X | X coordinate of where in the RastPort to end the line.
Y | Y coordinate of where in the RastPort to end the line.

Description

Draw a line from the current pen position to (x,y).

Errors

Not yet implemented:

  • handle layer^.Scroll_X/Scroll_Y.
  • handle FRST_DOT which indicates whether to draw or to don't draw first pixel of line. Important for COMPLEMENT drawmode.

See also

GfxMove

Move graphics pen position.


DrawCircle

Draws a Circle

Declaration

Source position: agraphics.pas line 2535

procedure DrawCircle(

  Rp: PRastPort;

  xCenter: LongInt;

  yCenter: LongInt;

  r: LongInt

);

Arguments

Rp | A pointer to a RastPort
xCenter | X coordinate for center of Circle
yCenter | Y coordinate for center of Circle
r | Radius of Circle

Description

Calls DrawEllipse() with a = b = r

See also

DrawEllipse

Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively


DrawEllipse

Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively

Declaration

Source position: agraphics.pas line 2323

procedure DrawEllipse(

  Rp: PRastPort;

  XCenter: LongInt;

  YCenter: LongInt;

  A: LongInt;

  B: LongInt

);

Arguments

Rp | A pointer to the RastPort into which the ellipse will be drawn.
XCenter | X coordinate of the centerpoint relative to the rastport.
YCenter | Y coordinate of the centerpoint relative to the rastport.
A | The horizontal radius of the ellipse (note: a must be > 0)
B | The vertical radius of the ellipse (note: b must be > 0)

Description

Creates an elliptical outline within the rectangular region specified by the parameters, using the current foreground pen color. this routine does not clip the ellipse to a non-layered rastport.

See also

DrawCircle

Draws a Circle


DrawGList

Process the gel list, queueing VSprites, drawing Bobs.

Declaration

Source position: agraphics.pas line 2312

procedure DrawGList(

  Rp: PRastPort;

  Vp: PViewPort

);

Arguments

Rp | A pointer to the RastPort where Bobs will be drawn
Vp | A pointer to the ViewPort for which VSprites will be created

Description

Performs one pass of the current gel list.

  • If nextLine and lastColor are defined, these are initialized for each gel.
  • If it's a VSprite, build it into the copper list.
  • If it's a Bob, draw it into the current raster.
  • Copy the save values into the "old" variables, double-buffering if required.

See also

InitGels

initialize a gel list; must be called before using gels.


EraseRect

Fill a defined rectangular area using the current BackFill hook.

Declaration

Source position: agraphics.pas line 2430

procedure EraseRect(

  Rp: PRastPort;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Rp | A pointer to a RastPort structure
XMin | X coordinate of the upper left corner of the region to fill.
YMin | Y coordinate of the upper left corner of the region to fill.
XMax | X coordinate of the lower right corner of the region to fill.
YMax | Y coordinate of the lower right corner of the region to fill.

Description

Fill the rectangular region specified by the parameters with the BackFill hook. If non-layered, the rectangular region specified by the parameters is cleared. If layered the ^.BackFill Hook is used. The following relation must be true: (xmax >= xmin) and (ymax >= ymin)


ExtendFont

Ensure TTextFont.tf_Extension has been built for a font

Declaration

Source position: agraphics.pas line 2431

function ExtendFont(

  Font: PTextFont;

  const FontTags: PTagItem

):LongWord;

Arguments

Font | The font to extend.
FontTags | An optional taglist. If nil, then a default is used. Currently, the only tag defined is TA_DeviceDPI.

Function result

1 if the TextFont was properly extended, else 0.

See also

ExtendFontTags

VarArgs Version of ExtendFont()


ExtendFontTags

VarArgs Version of ExtendFont()

Declaration

Source position: agraphics.pas line 2509

function ExtendFontTags(

  font: PTextFont;

  const argv: array of PtrUInt

):LongWord;


FindColor

Find the closest matching color in a colormap.

Declaration

Source position: agraphics.pas line 2466

function FindColor(

  Cm: PColorMap;

  R: LongWord;

  G: LongWord;

  B: LongWord;

  MaxColor: LongInt

):LongWord;

Arguments

Cm | Colormap
R | red level (32 bit left justified fraction)
G | green level (32 bit left justified fraction)
B | blue level (32 bit left justified fraction)

Description

The system will attempt to find the color in the passed colormap which most closely matches the RGB values passed. No new pens will be allocated, and you should not ReleasePen() the returned pen. This function is not sensitive to palette sharing issues. Its intended use is for:

  1. programs which pop up on public screens when those screens are not using palette sharing. You might use this function as a fallback when ObtainBestPenA() says that there are no sharable pens.
  2. Internal color matching by an application which is either running on a non-public screen, or which wants to match colors to an internal color table which may not be associated with any displayed screen.

In order to use the MaxPen=-1 feature, you must have initialized palette sharing via AttachPalExtra() (all intuition screens do this). Otherwise, MaxPen=-1 will search all colors in the colormap.

See also

ObtainBestPenA | Search for the closest color match, or allocate a new one.
GetColorMap | Allocate and initialize Colormap
ObtainPen | Obtain a free palette entry for use by your program.
ReleasePen | Release an allocated palette entry to the free pool.


FindDisplayInfo

Search for a record identified by a specific key

Declaration

Source position: agraphics.pas line 2415

function FindDisplayInfo(

  DisplayID: LongWord

):Pointer;

Function result

Handle to a displayinfo Record with that key or nil if no match.

Description

Given a 32-bit Mode Key, return a handle to a valid DisplayInfoRecord found in the graphics database. Using this handle, you can obtain information about this Mode, including its default dimensions, properties, and whether it is currently available for use.


Flood

Flood rastport like areafill.

Declaration

Source position: agraphics.pas line 2348

function Flood(

  Rp: PRastPort;

  Mode: LongWord;

  X: LongInt;

  Y: LongInt

):LongBool;

Arguments

Rp | A pointer to RastPort
Mode | 0 fill all adjacent pixels searching for border. 1 fill all adjacent pixels that have same pen number as the one at (x,y).
X | X coordinate in BitMap to start the flood fill at.
Y | Y coordinate in BitMap to start the flood fill at.

Description

Search the BitMap starting at (x,y). Fill all adjacent pixels if they are:

  • Mode 0: not the same color as AOLPen
  • Mode 1: the same color as the pixel at (x,y)

When actually doing the fill use the modes that apply to standard areafill routine such as drawmodes and patterns.

In order to use Flood, the destination RastPort must have a valid TmpRas raster whose size is as large as that of the RastPort.

See also

AreaEnd | Process table of vectors and ellipses and produce areafill.
InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.


FontExtent

Get the font attributes of the current font

Declaration

Source position: agraphics.pas line 2421

procedure FontExtent(

  const Font: PTextFont;

  FontExtent: PTextExtent

);

Arguments

Font | The TextFont from which the font metrics are extracted.
FontExtent | The TextExtent structure to be filled.

Description

This function fills the text extent structure with a bounding (i.e. maximum) extent for the characters in the specified font.

The TextFont, not the RastPort, is specified -- unlike TextExtent(), effect of algorithmic enhancements is not included, nor does te_Width include any effect of rp_TxSpacing. The returned te_Width will be negative only when FPF_REVPATH is set in the tf_Flags of the font -- the effect of left-moving characters is ignored for the width of a normal font, and the effect of right-moving characters is ignored if a REVPATH font. These characters will, however, be reflected in the bounding extent.

See also

TextExtent

Determine raster extent of text data.


FreeBitMap

Free a bitmap created by AllocBitMap()

Declaration

Source position: agraphics.pas line 2451

procedure FreeBitMap(

  Bm: PBitMap

);

Arguments

Bm

A pointer to a BitMap structure. Passing a nil-pointer (meaning "do nothing") is OK.

Description

Frees bitmap and all associated bitplanes. Be careful to insure that any rendering done to the bitmap has completed (by calling WaitBlit()) before you call this function.

See also

AllocBitMap

Allocate a bitmap and attach bitplanes to it.


FreeColorMap

Free the ColorMap structure and return memory to free memory pool.

Declaration

Source position: agraphics.pas line 2389

procedure FreeColorMap(

  ColorMap: PColorMap

);

Arguments

ColorMap

A pointer to ColorMap allocated with GetColorMap(). Passing a nil pointer (meaning "do nothing") is acceptable.

Description

Return the memory to the free memory pool that was allocated with GetColorMap().

See also

SetRGB4 | Set one color register for this viewport.
GetColorMap | Allocate and initialize Colormap


FreeCopList

Deallocate intermediate copper list

Declaration

Source position: agraphics.pas line 2384

procedure FreeCopList(

  CopList: PCopList

);

Arguments

CopList

A pointer to structure CopList

Description

Deallocate all memory associated with this copper list.


FreeCprList

Deallocate hardware copper list

Declaration

Source position: agraphics.pas line 2387

procedure FreeCprList(

  CprList: PCprList

);

Arguments

CprList

A pointer to cprlist structure

Description

Return cprlist to free memory pool


FreeDBufInfo

Free information for multi-buffered animation

Declaration

Source position: agraphics.pas line 2460

procedure FreeDBufInfo(

  Dbi: PDBufInfo

);

Arguments

Dbi

A pointer to a DBufInfo.

Description

Frees a structure obtained from AllocDBufInfo() FreeDBufInfo(nil) is a no-op.

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation


FreeGBuffers

Deallocate memory obtained by GetGBuffers()

Declaration

Source position: agraphics.pas line 2393

procedure FreeGBuffers(

  AnOb: PAnimOb;

  Rp: PRastPort;

  Flag: LongInt

);

Arguments

AnOb | A pointer to the AnimOb structure
Rp | A pointer to the current RastPort

Description

For each sequence of each component of the AnimOb, deallocate memory for:

  • SaveBuffer
  • BorderLine
  • CollMask and ImageShadow (point to same buffer)

if db is set (user had used double-buffering) deallocate:

  • DBufPacket
  • BufBuffer

A call to GetGBuffers() that resulted in a partially allocation of the required buffers will result in a deallocation of these buffers. (Possible incompatibility with the real thing, though)

See also

GetGBuffers

Attempt to allocate ALL buffers of an entire AnimOb.


FreeRaster

Release an allocated area to the system free memory pool

Declaration

Source position: agraphics.pas line 2376

procedure FreeRaster(

  P: PByte;

  Width: LongWord;

  Height: LongWord

);

Arguments

P | a pointer to a memory space returned as a result of a call to AllocRaster().
Width | The width in bits of the bitplane.
Height | Number of rows in bitplane.

Description

Return the memory associated with this PlanePtr of size width and height to the exec.MEMF_CHIP memory pool.

See also

AllocRaster | Allocate space for a bitplane.
AllocBitmap | Allocate a bitmap and attach bitplanes to it.
FreeBitmap | Free a bitmap created by AllocBitMap()


FreeSprite

Return sprite for use by others and virtual sprite machine.

Declaration

Source position: agraphics.pas line 2362

procedure FreeSprite(

  Num: LongInt

);

Description

Mark sprite as available for others to use. These sprite routines are provided to ease sharing of sprite hardware and to handle simple cases of sprite usage and movement. It is assumed the programs that use these routines do want to be good citizens in their hearts. ie: they will not FreeSprite unless they actually own the sprite. The Virtual Sprite machine may ignore the simple sprite machine.

See also

GetSprite | Attempt to get a sprite for the simple sprite manager.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.


FreeSpriteData

free sprite data allocated by AllocSpriteData()

Declaration

Source position: agraphics.pas line 2472

procedure FreeSpriteData(

  Sp: PExtSprite

);

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.
AllocBitMap | Allocate a bitmap and attach bitplanes to it.


FreeVPortCopLists

Deallocate all intermediate copper lists and their headers from a viewport

Declaration

Source position: agraphics.pas line 2383

procedure FreeVPortCopLists(

  Vp: PViewPort

);

Arguments

Vp

A pointer to ViewPort structure

Description

Search display, color, sprite, and user copper lists and call ExecFreeMem() to deallocate them from memory

The memory allocated to the various copper lists will be returned to the system's free memory pool, and the following fields in the viewport structure will be set to nil:

DspIns, Sprins, ClrIns, UCopIns


GetAPen

Get the A Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2440

function GetAPen(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the A pen for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently, for instance, using more bits.

See also

SetAPen

Set the primary pen for a RastPort.


GetBitMapAttr

Returns information about a bitmap

Declaration

Source position: agraphics.pas line 2458

function GetBitMapAttr(

  const Bm: PBitMap;

  AttrNum: LongWord

):LongWord;

Description

Determines information about a bitmap. This function should be used instead of reading the bitmap structure fields directly. This will provide future compatibility.

attribute_number = A number telling graphics which attribute of the bitmap should be returned:

BMA_HEIGHT
returns the height in pixels
BMA_WIDTH
returns the width in pixels.
BMA_DEPTH
returns the depth. This is the number of bits which are required to store the information for one pixel in the bitmap.
BMA_FLAGS
returns a longword bitfield describing various attributes which the bitmap may have. Currently defined flags are BMF_DISPLAYABLE, BMF_INTERLEAVED (see AllocBitMap()). The flag BMF_STANDARD returns will be set if the bitmap is represented as planar data in Amiga Chip RAM.

Unknown attributes are reserved for future use, and return zero.

BMF_DISPLAYABLE will only be set if the source bitmap meets all of the required alignment restrictions. A bitmap which does not meet these restrictions may still be displayable at some loss of efficiency.

Size values returned by this function may not exactly match the values which were passed to AllocBitMap(), due to alignment restrictions.

See also

AllocBitMap

Allocate a bitmap and attach bitplanes to it.


GetBoardBytesPerRow

Declaration

Source position: agraphics.pas line 2501

function GetBoardBytesPerRow(

  BoardNum: LongWord;

  PixelFormat: LongWord;

  Width: LongWord

):LongWord;


GetBoardDataTagList

Declaration

Source position: agraphics.pas line 2486

function GetBoardDataTagList(

  BoardNum: LongWord;

  const Tags: PTagItem

):LongInt;


GetBPen

Get the B Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2441

function GetBPen(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the B pen for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently, using more bits.

See also

SetBPen

Set secondary pen for a RastPort


GetColorMap

Allocate and initialize Colormap

Declaration

Source position: agraphics.pas line 2388

function GetColorMap(

  Entries: LongWord

):PColorMap;

Arguments

Entries

Number of entries for this colormap

Function result

The pointer value returned by this routine, if nonzero, may be stored into the ViewPort.ColorMap pointer. If a value of 0 is returned, the system was unable to allocate enough memory space for the required data structures.

Description

Allocates, initializes and returns a pointer to a ColorMap data structure, later enabling calls to SetRGB4()/SetRGB32() and LoadRGB4()/LoadRGB32() to load colors for a view port. The ColorTable pointer in the ColorMap structure points to a hardware specific colormap data structure. You should not count on it being anything you can understand. Use GetRGB4()/GetRGB32() to query it or SetRGB4CM()/SetRGB32CM() to set it directly.


GetDisplayInfoData

Query DisplayInfo Record parameters

Declaration

Source position: agraphics.pas line 2420

function GetDisplayInfoData(

  const Handle: Pointer;

  Buf: Pointer;

  Size: LongWord;

  TagID: LongWord;

  DisplayID: LongWord

):LongWord;

Arguments

Handle | A displayinfo handle
Buf | A pointer to destination buffer
Size | Buffer size in bytes
TagID | data chunk type (DTAG_*)

Function result

If positive, number of bytes actually transferred if zero, no information for ID was available

Description

GetDisplayInfoData() fills a buffer with data meaningful to the DisplayInfoRecord pointed at by your valid handle. The data type that you are interested in is indicated by a tagID for that chunk. The types of tagged information that may be available include:

DTAG_DISP:
(TDisplayInfo) properties and availability information.
DTAG_DIMS:
(TDimensionInfo) default dimensions and overscan info.
DTAG_MNTR:
(TMonitorInfo) type, position, scanrate, and compatibility
DTAG_NAME:
(TNameInfo) a user friendly way to refer to this mode.

See also

FindDisplayInfo | Search for a record identified by a specific key
NextDisplayInfo | Iterate current displayinfo identifiers


GetDrMd

Get the draw mode value for a RastPort

Declaration

Source position: agraphics.pas line 2442

function GetDrMd(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the draw mode for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently.

See also

SetDrMd

Set drawing mode for a RastPort


GetExtSprite

VarArgs Version of GetExtSpriteA()

Declaration

Source position: agraphics.pas line 2510

function GetExtSprite(

  ss: PExtSprite;

  const argv: array of PtrUInt

):LongInt;

See also

GetExtSprite

VarArgs Version of GetExtSpriteA()


GetExtSpriteA

Attempt to get a sprite for the extended sprite manager.

Declaration

Source position: agraphics.pas line 2452

function GetExtSpriteA(

  Ss: PExtSprite;

  const Tags: PTagItem

):LongInt;

Arguments

Tags

Tags GSTAG_*

Function result

a sprite number or -1 for an error. This call will fail if no sprites could be allocated, or if you try to allocate a sprite which would require a mode change when there are other sprites of incompatible modes in use.

Description

Attempt to allocate one of the eight sprites for private use with the extended sprite manager.

a standard tag list:

GSTAG_SPRITE_NUM
specifies a specific sprite to get by number.
GSTAG_ATTACHED
specifies that you wish to get a sprite pair. the tag data field points to a ExtSprite structure for the second sprite. You must free both sprites.

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.
GetSprite | Attempt to get a sprite for the simple sprite manager.


GetGBuffers

Attempt to allocate ALL buffers of an entire AnimOb.

Declaration

Source position: agraphics.pas line 2321

function GetGBuffers(

  AnOb: PAnimOb;

  Rp: PRastPort;

  Flag: LongInt

):LongBool;

Arguments

AnOb | A pointer to the AnimOb structure
Rp | A pointer to the current RastPort

Function result

True if the memory allocations were all successful, else False

Description

For each sequence of each component of the AnimOb, allocate memory for:

  • SaveBuffer
  • BorderLine
  • CollMask and ImageShadow (point to same buffer)

if db is set TRUE (user wants double-buffering) allocate:

  • DBufPacket
  • BufBuffer

If an AnimOb is passed to GetGBuffers twice new buffers will be allocated and therefore old pointers to buffers will be lost in space.

Errors

If any of the memory allocations fail it does not free the partial allocations that did succeed.

See also

FreeGBuffers

Deallocate memory obtained by GetGBuffers()


GetMonitorDataTagList

Declaration

Source position: agraphics.pas line 2484

function GetMonitorDataTagList(

  BoardNum: LongWord;

  MonitorNum: LongWord;

  Tags: PTagItem

):LongInt;


GetOutlinePen

Get the O Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2443

function GetOutlinePen(

  Rp: PRastPort

):LongWord;

Arguments

Rp

A pointer to a valid RastPort structure.

Description

Return the current value of the O pen for the rastport. This function should be used instead of peeking the structure directly, because future graphics devices may store it differently, for instance, using more bits.

See also

SetOutlinePen

Set the Outline Pen value for a RastPort


GetRGB32

Set a series of color registers for this Viewport.

Declaration

Source position: agraphics.pas line 2447

procedure GetRGB32(

  const Cm: PColorMap;

  Firstcolor: LongWord;

  NColors: LongWord;

  Table: PLongWord

);

Arguments

Cm | colormap
Firstcolor | The first color register to get
NColors | The number of color registers to set.
Table | A pointer to a series of 32-bit RGB triplets. Should point to at least ncolors*3 longwords.

See also

LoadRGB4 | Load RGB color values from table.
LoadRGB32 | Set a series of color registers for this Viewport.
GetColorMap | Allocate and initialize Colormap
SetRGB32CM | Set one color register for this ColorMap.


GetRGB4

Inquire value of entry in ColorMap.

Declaration

Source position: agraphics.pas line 2390

function GetRGB4(

  ColorMap: PColorMap;

  Entry: LongWord

):LongInt;

Arguments

ColorMap | A pointer to ColorMap structure
Entry | Index into colormap

Function result

Returns -1 if no valid entry return Word RGB value 4 bits per run right justified

Description

Read and format a value from the ColorMap.

Errors

Intuition's DisplayBeep() changes color 0. Reading Color 0 during a DisplayBeep() will lead to incorrect results.

See also

SetRGB4 | Set one color register for this viewport.
LoadRGB4 | Load RGB color values from table.
GetColorMap | Allocate and initialize Colormap
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.


GetRPAttrs

VarArgs Version for GetRPAttrsA()

Declaration

Source position: agraphics.pas line 2511

procedure GetRPAttrs(

  rp: PRastPort;

  const argv: array of PtrUInt

);


GetRPAttrsA

Examine rastport settings via a tag list

Declaration

Source position: agraphics.pas line 2475

function GetRPAttrsA(

  const Rp: PRastPort;

  const Tags: PTagItem

):LongWord;

Arguments

Rp | A pointer to a RastPort structure
Tags | A pointer to a taglist specifying the attributes to read and the addresses to store the results (RPTAG_*)

Description

Read the settings of a rastport into variables. The ti_Tag field of the TagItem specifies which attribute should be read, and the ti_Data field points at the location where the result hsould be stored. All current tags store the return data as LonInts (32 bits).

currently available tags are:

RPTAG_Font
(Byte) Font for GfxText()
RPTAG_APen
(Byte) Primary rendering pen
RPTAG_BPen
(Byte) Secondary rendering pen
RPTAG_DrMd
(Byte) Drawing mode
RPTAG_OutLinePen
(Byte) Area Outline pen
RPTAG_WriteMask
(LongWord) Bit Mask for writing.
RPTAG_MaxPen
(LongWord) Maximum pen to render (see SetMaxPen())

See also

GetRPAttrs | VarArgs Version for GetRPAttrsA()
SetRPAttrsA | Modify rastport settings via a tag list
GetAPen | Get the A Pen value for a RastPort
GetBPen | Get the B Pen value for a RastPort
GetOutLinePen | Get the O Pen value for a RastPort


GetSprite

Attempt to get a sprite for the simple sprite manager.

Declaration

Source position: agraphics.pas line 2361

function GetSprite(

  Sprite: PSimpleSprite;

  Num: LongInt

):LongInt;

Arguments

Sprite

A Pointer to programmers SimpleSprite structure.

Function result

If pick is 0-7 attempt to allocate the sprite. If the sprite is already allocated then return -1. If pick -1 allocate the next sprite starting search at 0. If no sprites are available return -1 and fill -1 in num entry of SimpleSprite structure. If the sprite is available for allocation, mark it allocated and fill in the 'num' entry of the SimpleSprite structure. If successful return the sprite number.

Description

Attempt to allocate one of the eight sprites for private use with the simple sprite manager. This must be done before using further calls to the simple sprite machine. If the programmer wants to use 15 color sprites, they must allocate both sprites and set the SPRITE_ATTACHED bit in the odd sprite's posctldata array.

Errors

On some machines this will never return anything else than -1!

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
MoveSprite | Move sprite to a point relative to top of viewport.


GetVPModeID

Get the 32 bit DisplayID from a ViewPort.

Declaration

Source position: agraphics.pas line 2426

function GetVPModeID(

  const Vp: PViewPort

):LongWord;

Arguments

Vp

A pointer to a ViewPort structure.

Function result

A 32 bit DisplayInfoRecord identifier associated with this ViewPort, or INVALID_ID.

Description

Returns the normal display modeID, if one is currently associated with this ViewPort. Test the return value of this function against INVALID_ID, not nil.

See also

ModeNotAvailable

Check to see if a DisplayID isn't available.


GfxAssociate

associate a graphics extended node with a given pointer

Declaration

Source position: agraphics.pas line 2405

procedure GfxAssociate(

  const AssociateNode: Pointer;

  GfxNodePtr: PExtendedNode

);

Description

Associate a special graphics extended data structure (each of which begins with an ExtendedNode structure) with another structure via the other structure's pointer. Later, when you call GfxLookUp() with the other structure's pointer you may retrieve a pointer to this special graphics extended data structure, if it is available.Never associate one special graphics extended data structure to several pointers. Only one pointer is allowed!

See also

GfxNew | Allocate a graphics extended data structure
GfxFree | Free a graphics extended data structure
GfxLookUp | Find a graphics extended node associated with a given pointer


GfxClone

Declaration

Source position: agraphics.pas line 2297

function GfxClone: PInterface;


GfxExpunge

Declaration

Source position: agraphics.pas line 2296

procedure GfxExpunge;


GfxFree

Free a graphics extended data structure

Declaration

Source position: agraphics.pas line 2404

procedure GfxFree(

  GfxNodePtr: PExtendedNode

);

Description

Free a special graphics extended data structure (each of which begins with an ExtendedNode structure). The node is deallocated from memory. graphics will disassociate this special graphics extended node from any associated data structures, if necessary, before freeing it (see GfxAssociate()).

Errors

An Alert() will be called if you attempt to free any structure other than a graphics extended data structure obtained via GfxFree().

See also

GfxNew | Allocate a graphics extended data structure
GfxAssociate | associate a graphics extended node with a given pointer
GfxLookUp | Find a graphics extended node associated with a given pointer


GfxLookUp

Find a graphics extended node associated with a given pointer

Declaration

Source position: agraphics.pas line 2410

function GfxLookUp(

  const AssociateNode: Pointer

):Pointer;

Function result

A pointer to the ExtendedNode that has previously been associated with the pointer.

Description

Finds a special graphics extended data structure (if any) associated with the pointer to a data structure (eg: ViewExtra associated with a View structure).

See also

GfxNew | Allocate a graphics extended data structure
GfxAssociate | associate a graphics extended node with a given pointer
GfxFree | Free a graphics extended data structure


GfxMove

Move graphics pen position.

Declaration

Source position: agraphics.pas line 2333

procedure GfxMove(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

);

Description

Move graphics pen position to (x,y) relative to upper left (0,0) of RastPort. This sets the starting point for subsequent Draw() and GfxText() calls.

See also

Draw

Draw a line between the current pen position and the new x,y position.


GfxNew

Allocate a graphics extended data structure

Declaration

Source position: agraphics.pas line 2403

function GfxNew(

  GfxNodeType: LongWord

):Pointer;

Function result

A pointer to the allocated graphics node or nil if the allocation failed.

Description

Allocate a special graphics extended data structure (each of which begins with an ExtendedNode structure). The type of structure to be allocated is specified by the node_type identifier.

See also

GfxLookUp | Find a graphics extended node associated with a given pointer
GfxAssociate | associate a graphics extended node with a given pointer
GfxFree | Free a graphics extended data structure


GfxObtain

Declaration

Source position: agraphics.pas line 2294

function GfxObtain: LongWord;


GfxRelease

Declaration

Source position: agraphics.pas line 2295

function GfxRelease: LongWord;


GfxText

Write text characters (no formatting).

Declaration

Source position: agraphics.pas line 2303

procedure GfxText(

  Rp: PRastPort;

  const String_: PChar;

  Count: LongWord

);

Arguments

Rp | A pointer to the RastPort which describes where the text is to be output
String_ | The address of string to output
Count | The number of characters in the string. If 0, there are no characters to be output.

Description

This graphics function writes printable text characters to the specified RastPort at the current position. No control meaning is applied to any of the characters, thus only text on the current line is output.

The current position in the RastPort is updated to the next character position. If the characters displayed run past the RastPort boundary, the current position is truncated to the boundary, and thus does not equal the old position plus the text length.

See also

GfxMove | Move graphics pen position.
TextLength | Determine raster length of text data.
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent


GraphicsControlTagList

Declaration

Source position: agraphics.pas line 2496

function GraphicsControlTagList(

  const Tags: PTagItem

):LongWord;


InitAnimate

Init AnimObject pointer, set to nil

Declaration

Source position: agraphics.pas line 2519

procedure InitAnimate(

  animkey: PPAnimOb

);


InitArea

Initialize vector collection matrix

Declaration

Source position: agraphics.pas line 2340

procedure InitArea(

  AreaInfo: PAreaInfo;

  VectorBuffer: Pointer;

  MaxVectors: LongInt

);

Arguments

AreaInfo | A pointer to AreaInfo structure
MaxVectors | max number of vectors this buffer can hold

Description

This function provides initialization for the vector collection matrix such that it has a size of (max vectors ). The size of the region pointed to by buffer (short pointer) should be five (5) times as large as maxvectors. This size is in bytes. Areafills done by using AreaMove, AreaDraw() and AreaEnd() must have enough space allocated in this table to store all the points of the largest fill. AreaEllipse() takes up two vectors for every call. If AreaMove/AreaDraw()/AreaEllipse() detect too many vectors going into the buffer they will return -1.

See also

AreaEnd | Process table of vectors and ellipses and produce areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaDraw | Add a point to a list of end points for areafill.
AreaEllipse | Add a ellipse to areainfo list for areafill.


InitBitMap

Initialize bit map structure with input values.

Declaration

Source position: agraphics.pas line 2358

procedure InitBitMap(

  BitMap: PBitMap;

  Depth: LongInt;

  Width: LongWord;

  Height: LongWord

);

Arguments

Depth | Number of bitplanes that this bitmap will have
Width | Number of bits (columns) wide for this BitMap
Height | Number of bits (rows) tall for this BitMap

Description

Initialize various elements in the BitMap structure to correctly reflect depth, width, and height. Must be used before use of BitMap in other graphics calls. The Planes[0..7] are not initialized and need to be set up by the caller. The Planes table was put at the end of the structure so that it may be truncated to conserve space, as well as extended. All routines that use BitMap should only depend on existence of depth number of bitplanes. The Flagsh and pad fields are reserved for future use and should not be used by application programs.


InitGels

initialize a gel list; must be called before using gels.

Declaration

Source position: agraphics.pas line 2313

procedure InitGels(

  Head: PVSprite;

  Tail: PVSprite;

  GelsInfo: PGelsInfo

);

Arguments

Head | Pointer to the VSprite structure to be used as the gel list head
Tail | Pointer to the VSprite structure to be used as the gel list tail
GelsInfo | Pointer to the GelsInfo structure to be initialized

Description

Assigns the VSprites as the head and tail of the gel list in GfxBase. Links these two gels together as the keystones of the list. If the collHandler vector points to some memory array, sets the BORDERHIT vector to nil.


InitGMasks

Initialize all of the masks of an AnimOb.

Declaration

Source position: agraphics.pas line 2322

procedure InitGMasks(

  AnOb: PAnimOb

);

Arguments

AnOb

A pointer to the AnimOb

Description

For every sequence of every component call InitMasks().

See also

InitMasks

Initialize the BorderLine and CollMask masks of a VSprite.


InitMasks

Initialize the BorderLine and CollMask masks of a VSprite.

Declaration

Source position: agraphics.pas line 2314

procedure InitMasks(

  VSprite: PVSprite

);

Arguments

VSprite

A pointer to the VSprite structure

Description

Creates the appropriate BorderLine and CollMask masks of the VSprite. Correctly detects if the VSprite is actually a Bob definition, handles the image data accordingly.

See also

InitGels

initialize a gel list; must be called before using gels.


InitRastPort

Initialize raster port structure

Declaration

Source position: agraphics.pas line 2326

procedure InitRastPort(

  Rp: PRastPort

);

Arguments

Rp

A pointer to a RastPort structure.

Description

Initialize a RastPort structure to standard values.

The struct Rastport describes a control structure for a write-able raster. The RastPort structure describes how a complete single playfield display will be written into. A RastPort structure is referenced whenever any drawing or filling operations are to be performed on a section of memory.

The section of memory which is being used in this way may or may not be presently a part of the current actual onscreen display memory. The name of the actual memory section which is linked to the RastPort is referred to here as a "raster" or as a bitmap.

Note:

Calling the routine InitRastPort only establishes various defaults. It does not establish where, in memory, the rasters are located. To do graphics with this RastPort the user must set up the BitMap pointer in the RastPort.

all entries in RastPort get zeroed out, with the following exceptions:

  • Mask, FgPen, AOLPen, and LinePtrn are set to -1.
  • The DrawMode is set to JAM2
  • The font is set to the standard system font


InitTmpRas

Initialize area of local memory for usage by areafill, floodfill, gfxtext.

Declaration

Source position: agraphics.pas line 2371

function InitTmpRas(

  TmpRas: PTmpRas;

  Buffer: PByte;

  Size: LongInt

):PTmpRas;

Arguments

TmpRas | A pointer to a TmpRas structure to be linked into a RastPort
Buffer | A pointer to a contiguous piece of chip memory.
Size | Size in bytes of buffer

Function result

Makes buffer available for users of RastPort

Description

The area of memory pointed to by buffer is set up to be used by RastPort routines that may need to get some memory for intermediate operations in preparation to putting the graphics into the final BitMap. Tmpras is used to control the usage of buffer.

Errors

The function itself is a bug. Why does this function exist at all? The necessary memory should be allocated in InitRastPort() or the functions that need it.

See also

AreaEnd | Process table of vectors and ellipses and produce areafill.
Flood | Flood rastport like areafill.
GfxText | Write text characters (no formatting).


InitView

Initialize View structure.

Declaration

Source position: agraphics.pas line 2353

procedure InitView(

  View: PView

);

Arguments

View

A pointer to a View structure

Description

Initialize View structure to default values. View structure set to all 0's except DxOffset,DyOffset, These are set to properly position: default display about .5 inches from top and left on monitor. InitView pays no attention to previous contents of view.

See also

MakeVPort

Generate display copper list for a viewport.


InitVPort

Initialize ViewPort structure.

Declaration

Source position: agraphics.pas line 2327

procedure InitVPort(

  Vp: PViewPort

);

Arguments

Vp

A pointer to a ViewPort structure

Description

Initialize ViewPort structure to default values. ViewPort is initialized to it`s default values - doesn't care about previous contents of this structure. All values except for SpritePriorities are set to 0's.

See also

MakeVPort

Generate display copper list for a viewport.


LoadRGB32

Set a series of color registers for this Viewport.

Declaration

Source position: agraphics.pas line 2444

procedure LoadRGB32(

  Vp: PViewPort;

  const Table: PLongWord

);

Arguments

Vp | viewport
Table | A pointer to a series of records which describe which colors to modify.

Description

The selected color registers are changed to match your specs. LoadRGB32() is faster than SetRGB32(), even for one color.

Passing a nil "table" is ignored. The format of the table passed to this function is a series of records, each with the following format:

1 Word with the number of colors to load 1 Word with the first color to be loaded. 3 longwords representing a left justified 32 bit rgb triplet. The list is terminated by a count value of 0.

Lower order bits of the palette specification will be discarded, depending on the color palette resolution of the target graphics device. Use 0xffffffff for the full value, 0x7fffffff for 50%, etc. You can find out the palette range for your screen by querying the graphics data base.

See also

LoadRGB4 | Load RGB color values from table.
GetColorMap | Allocate and initialize Colormap
GetRGB32 | Set a series of color registers for this Viewport.
SetRGB32CM | Set one color register for this ColorMap.


LoadRGB4

Load RGB color values from table.

Declaration

Source position: agraphics.pas line 2325

procedure LoadRGB4(

  Vp: PViewPort;

  const Colors: PWord;

  Count: LongWord

);

Arguments

Vp | A pointer to ViewPort, whose colors you wish to change
Colors | pointer to table of RGB values set up as an array of Words The colors are interpreted as 15 = maximum intensity. 0 = minimum intensity.
Count | number of Words in the table to load into the colormap starting at color 0(background) and proceeding to the next higher color number

Description

load the count words of the colormap from table starting at entry 0.

The ViewPort should have a pointer to a valid ColorMap to store the colors in. Updates the hardware copperlist to reflect the new colors. Updates the intermediate copperlist with the new colors.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB4 | Inquire value of entry in ColorMap.
SetRGB4 | Set one color register for this viewport.


LoadView

Use a (possibly freshly created) coprocessor instruction list to create the current display.

Declaration

Source position: agraphics.pas line 2330

procedure LoadView(

  View: PView

);

Arguments

View

A pointer to the View structure which contains the pointer to the constructed coprocessor instructions list, or nil.

Description

Install a new view to be displayed during the next display refresh pass. Coprocessor instruction list has been created by InitVPort(), MakeVPort(), and MrgCop().

If the View pointer is non-nil, the new View is displayed, according to your instructions. The vertical blank routine will pick this pointer up and direct the copper to start displaying this View.

If the View pointer is nil, no View is displayed.

Even though a LoadView(nil) is performed, display DMA will still be active. Sprites will continue to be displayed after a LoadView(nil) unless an OFF_SPRITE is subsequently performed.

See also

InitVPort | Initialize ViewPort structure.
MakeVPort | Generate display copper list for a viewport.
MrgCop | Merge together coprocessor instructions.
RethinkDisplay | Grand manipulation of the entire Intuition display.


LockBitMapTagList

Declaration

Source position: agraphics.pas line 2488

function LockBitMapTagList(

  BitMap: PBitMap;

  Tags: PTagItem

):Pointer;


LockBitMapToBoardTagList

Declaration

Source position: agraphics.pas line 2498

function LockBitMapToBoardTagList(

  BitMap: PBitMap;

  BoardNum: LongWord;

  Tags: PTagItem

):Pointer;


LockLayerRom

Lock Layer structure by ROM(gfx lib) code.

Declaration

Source position: agraphics.pas line 2365

procedure LockLayerRom(

  Layer: PLayer

);

Description

Return when the layer is locked and no other task may alter the ClipRect structure in the Layer structure. This call does not destroy any registers. This call nests so that callers in this chain will not lock themselves out. Do not have the Layer locked during a call to intuition. There is a potential deadlock problem here, if intuition needs to get other locks as well. Having the layer locked prevents other tasks from using the layer library functions, most notably intuition itself. So be brief. layers.library's LockLayer() is identical to LockLayerRom().

The layer is locked and the task can render assuming the ClipRects will not change out from underneath it until an UnlockLayerRom() is called.

See also

UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.
LockLayer | Lock layer to make changes to ClipRects.


MakeVPort

Generate display copper list for a viewport.

Declaration

Source position: agraphics.pas line 2329

function MakeVPort(

  View: PView;

  Vp: PViewPort

):LongWord;

Arguments

View

A pointer to a View structure

Function result

MakeVPort() will return an error if there is not enough memory, or the requested mode cannot be opened with the requested depth with the given bitmap (for higher bandwidth alignments). Check (MVP_*)

Description

Uses information in the View, ViewPort, TViewPort^.RasInfo to construct and intermediate copper list for this ViewPort.

Constructs intermediate copper list and puts pointers in viewport.DspIns If the ColorMap ptr in ViewPort is nil then it uses colors from the default color table. If DUALPF in Modes then there must be a second TRasInfo pointed to by the first TRasInfo

See also

InitVPort | Initialize ViewPort structure.
MrgCop | Merge together coprocessor instructions.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.
RemakeDisplay |
RethinkDisplay | Grand manipulation of the entire Intuition display.


ModeNotAvailable

Check to see if a DisplayID isn't available.

Declaration

Source position: agraphics.pas line 2427

function ModeNotAvailable(

  ModeID: LongWord

):LongWord;

Arguments

ModeID

A 32 bit DisplayInfoRecord identifier.

Function result

A general indication of why this modeID is not available, or nil if there is no reason why it shouldn't be available.

Description

Rturns an error code, indicating why this modeID is not available, or 0 if there is no reason known why this mode should not be there.

See also

GetVPModeID

Get the 32 bit DisplayID from a ViewPort.


MoveSprite

Move sprite to a point relative to top of viewport.

Declaration

Source position: agraphics.pas line 2364

procedure MoveSprite(

  Vp: PViewPort;

  Sprite: PSimpleSprite;

  X: LongInt;

  Y: LongInt

);

Arguments

Vp | A ViewPort for relative sprite positioning or nil
Sprite | A pointer to a sprite descriptor structure
X | A new X coordinate
Y | A new Y coordinate

Description

Move sprite to a new position on the screen. Coordinates are specified relatively to given ViewPort, or relatively to the entire View (physical display) if the ViewPort is nil.

This function works also with extended sprites, since TSimpleSprite is a part of TExtSprite.

Amiga currently supports only one sprite #0 for mouse pointer. Other sprite numbers are ignored by this function.

ViewPort is also used in order to specify the physical display. If it's not specified, Amiga(tm) chipset display is assumed. This is available only on Amiga(tm) architecture.

See also

FreeSprite | Return sprite for use by others and virtual sprite machine.
ChangeSprite | Change the sprite image pointer.
GetSprite | Attempt to get a sprite for the simple sprite manager.


MrgCop

Merge together coprocessor instructions.

Declaration

Source position: agraphics.pas line 2328

function MrgCop(

  View: PView

):LongWord;

Arguments

View

A pointer to the view structure to prepare

Function result

MrgCop() will return an error if there is not enough memory, or for some reason MrgCop() did not need to make any copper lists. Check MCOP_* for error codes

Description

Merge together the display, color, sprite and user coprocessor instructions into a single coprocessor instruction stream. This essentially creates a per-display-frame program for the coprocessor. This function MrgCop is used, for example, by the graphics animation routines which effectively add information into an essentially static background display. This changes some of the user or sprite instructions, but not those which have formed the basic display in the first place. When all forms of coprocessor instructions are merged together, you will have a complete per- frame instruction list for the coprocessor.

Restrictions: Each of the coprocessor instruction lists MUST be internally sorted in min to max Y-X order. The merge routines depend on this!

If the given view is already on display, changes appear immediately.

On non Amiga Systems it only prepares the View for being displayed.

See also

InitVPort | Initialize ViewPort structure.
MakeVPort | Generate display copper list for a viewport.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.
RethinkDisplay | Grand manipulation of the entire Intuition display.


NewRegion

Allocates memory for a new Region and initializes it to an empty Region.

Declaration

Source position: agraphics.pas line 2379

function NewRegion: PRegion;

Function result

A pointer to a newly created Region structure that should be freed by a call to DisposeRegion() or nil if not enough memory.


NextDisplayInfo

Iterate current displayinfo identifiers

Declaration

Source position: agraphics.pas line 2416

function NextDisplayInfo(

  DisplayID: LongWord

):LongWord;

Function result

subsequent displayinfo identifier or INVALID_ID if no more records.

Description

The basic iteration function with which to find all records in the graphics database. Using each ID in succession, you can then call FindDisplayInfo() to obtain the handle associated with each ID. Each ID is a 32-bit Key which uniquely identifies one record. The INVALID_ID is special, and indicates the end-of-list.

See also

FindDisplayInfo

Search for a record identified by a specific key


ObtainBestPen

VarArgs Version of ObtainBestPenA()

Declaration

Source position: agraphics.pas line 2512

function ObtainBestPen(

  cm: PColorMap;

  r: LongWord;

  g: LongWord;

  b: LongWord;

  const argv: array of PtrUInt

):LongInt;


ObtainBestPenA

Search for the closest color match, or allocate a new one.

Declaration

Source position: agraphics.pas line 2436

function ObtainBestPenA(

  Cm: PColorMap;

  R: LongWord;

  G: LongWord;

  B: LongWord;

  const Tags: PTagItem

):LongInt;

Arguments

Cm | Colormap
R | Red level (32 bit left justified fraction)
G | Green level (32 bit left justified fraction)
B | Blue level (32 bit left justified fraction)
Tags | a pointer to a standard tag list specifying the color matching settings desired: OBP_Precision, OBP_FailIfBad

Function result

The correct pen value, or -1 if no sharable palette entries are available.

Description

This function can be used by applications to figure out what pen to use to represent a given color.

The system will attempt to find the color in your viewport closest to the specified color. If there is no color within your tolerance, then a new one will be allocated, if available. If none is available, then the closest one found will be returned.

If this call succceeds, then you must call ReleasePen() when you are done with the color.

The error metric used for ObtainBestPen() is based on the magnitude squared between the two RGB values, scaled by the percentage of free entries.

See also

ObtainBestPen | VarArgs Version of ObtainBestPenA()
GetColorMap | Allocate and initialize Colormap
ObtainPen | Obtain a free palette entry for use by your program.
ReleasePen | Release an allocated palette entry to the free pool.


ObtainPen

Obtain a free palette entry for use by your program.

Declaration

Source position: agraphics.pas line 2457

function ObtainPen(

  Cm: PColorMap;

  N: LongWord;

  R: LongWord;

  G: LongWord;

  B: LongWord;

  F: LongInt

):LongInt;

Arguments

Cm | A pointer to a color map created by GetColorMap().
N | The index of the desired entry, or -1 if any one is acceptable
R | Red Value (32 bit left justified fractions)
G | Green Value (32 bit left justified fractions)
B | Blue Value (32 bit left justified fractions)

Description

Attempt to allocate an entry in the colormap for use by the application. If successful, you should ReleasePen() this entry after you have finished with it.

Applications needing exclusive use of a color register (say for color cycling) will typically call this function with n=-1. Applications needing only the shared use of a color will typically use ObtainBestPenA() instead. Other uses of this function are rare.

When you allocate a palette entry in non-exclusive mode, you should not change it (via SetRGB32()), because other programs on the same screen may be using it. With PEN_EXCLUSIVE mode, you can change the returned entry at will.

To avoid visual artifacts, you should not free up a palette entry until you are sure that your application is not displaying any pixels in that color at the time you free it. Otherwise, another task could allocate and set that color index, thus changing the colors of your pixels.

Generally, for shared access, you should use ObtainBestPenA() instead, since it will not allocate a new color if there is one "close enough" to the one you want already. If there is no Palextra attached to the colormap, then this routine will always fail.

See also

ObtainBestPenA | Search for the closest color match, or allocate a new one.
GetColorMap | Allocate and initialize Colormap
AttachPalExtra | Allocate and attach a palette sharing structure to a colormap
ReleasePen | Release an allocated palette entry to the free pool.


OpenFont

Get a pointer to a system font.

Declaration

Source position: agraphics.pas line 2305

function OpenFont(

  TextAttr: PTextAttr

):PTextFont;

Arguments

TextAttr

A PTextAttr or PTTextAttr structure that describes the text font attributes desired.

Function result

Nil if the desired font cannot be found. If the named font is found, but the size and style specified are not available, a font with the nearest attributes is returned.

Description

This function searches the system font space for the graphics text font that best matches the attributes specified. The pointer to the font returned can be used in subsequent SetFont() and CloseFont() calls. It is important to match this call with a corresponding CloseFont() call for effective management of ram fonts.

See also

CloseFont | Release a pointer to a system font.
SetFont | Set the text font and attributes in a RastPort.
OpenDiskFont |


OpenMonitor

Open a named MonitorSpec

Declaration

Source position: agraphics.pas line 2413

function OpenMonitor(

  const MonitorName: PChar;

  DisplayID: LongWord

):PMonitorSpec;

Arguments

MonitorName | A pointer to a null terminated string.
DisplayID | An optional 32 bit monitor/mode identifier

Function result

A pointer to an open MonitorSpec structure. nil if MonitorSpec could not be opened.

Description

Locate and open a named MonitorSpec.

  • if monitor_name is non-nil, the monitor will be opened by name.
  • if monitor_name is nil the monitor will be opened by optional ID.
  • if both monitor_name and display_id are nil returns default monitor.

See also

CloseMonitor

Close a MonitorSpec


OrRectRegion

Perform 2d OR operation of rectangle with region, leaving result in region.

Declaration

Source position: agraphics.pas line 2378

function OrRectRegion(

  Region: PRegion;

  const Rectangle: PRectangle

):LongBool;

Function result

Return True if successful operation, Return False if ran out of memory

Description

If any portion of rectangle is not in the region then add that portion to the region.

See also

AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
XorRegionRegion | Perform 2d XOR operation of one region with second region, leaving result in second region
ClearRectRegion
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.


OrRegionRegion

Perform 2d OR operation of one region with second region, leaving result in second region

Declaration

Source position: agraphics.pas line 2395

function OrRegionRegion(

  const SrcRegion: PRegion;

  DestRegion: PRegion

):LongBool;

Arguments

SrcRegion | A pointer to Source Region
DestRegion | A pointer to Destination Region

Function result

Return True if successful operation, Return False if ran out of memory

Description

If any portion of region1 is not in the region then add that portion to the region2

See also

AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRegionRegion | Perform 2d XOR operation of one region with second region, leaving result in second region
ClearRectRegion
NewRegion | Allocates memory for a new Region and initializes it to an empty Region.


OwnBlitter

get the blitter for private usage

Declaration

Source position: agraphics.pas line 2369

procedure OwnBlitter;

Description

If blitter is available return immediately with the blitter locked for your exclusive use. If the blitter is not available put task to sleep. It will be awakened as soon as the blitter is available. When the task first owns the blitter the blitter may still be finishing up a blit for the previous owner. You must do a WaitBlit() before actually using the blitter registers.

Calls to OwnBlitter() do not nest. If a task that owns the blitter calls OwnBlitter() again, a lockup will result. (Same situation if the task calls a system function that tries to own the blitter).

It is good practice to start the blitter immediately after calling this function and then call DisownBlitter() so other tasks can use the blitter.

See also

DisOwnBlitter | Returns blitter to free state.
WaitBlit | Wait for the blitter to be finished before proceeding with anything else.


PolyDraw

Draw lines from table of (x,y) values.

Declaration

Source position: agraphics.pas line 2349

procedure PolyDraw(

  Rp: PRastPort;

  Count: LongInt;

  const PolyTable: PSmallInt

);

Arguments

Rp | A pointer to RastPort structure
Count | Number of (x,y) pairs in the array
PolyTable | Pointer to first (x,y) pair

Description

Starting with the first pair in the array, draw connected lines to it and every successive pair.

See also

Draw | Draw a line between the current pen position and the new x,y position.
GfxMove | Move graphics pen position.


QBlit

Queue up a request for blitter usage

Declaration

Source position: agraphics.pas line 2339

procedure QBlit(

  blit: Pointer

);

Arguments

blit

A pointer to blitnode structure

Description

The routine that function in the bltnode is pointing to is called when the blitter is ready for work. No other task will be able to access the blitter while you're doing the blit. Queued blits have precedence over a task that tries to own the blitter via OwnBlitter(). So all queued blitter requests will be done first until the task that attempts a OwnBlitter can actually access the blitter.

Not all hardware has a blitter. On hardware where there is no blitter, a blitter is simulated. Therefore all code that will be executed in the function that is called must not contain code that is hacking the blitter's register but should contain calls to graphics functions instead.

See also

QBSBlit | Synchronize the blitter request with the video beam.
OwnBlitter | get the blitter for private usage
DisOwnBlitter | Returns blitter to free state.


QBSBlit

Synchronize the blitter request with the video beam.

Declaration

Source position: agraphics.pas line 2342

procedure QBSBlit(

  Blit: Pointer

);

Arguments

Blit

A pointer to blitnode structure

Description

The routine that function in the bltnode is pointing to is called when the blitter is ready for work. No other task will be able to access the blitter while you're doing the blit. Queued blits have precedence over a task that tries to own the blitter via OwnBlitter(). So all queued blitter requests will be done first until the task that attempts a OwnBlitter can actually access the blitter.

Not all hardware has a blitter. On hardware where there is no blitter, a blitter is simulated. Therefore all code that will be executed in the function that is called must not contain code that is hacking the blitter's register but should contain calls to graphics functions instead.

See also

QBlit | Queue up a request for blitter usage
OwnBlitter | get the blitter for private usage
DisOwnBlitter | Returns blitter to free state.


RasSize

Get Size of an rastport.

Declaration

Source position: agraphics.pas line 2538

function RasSize(

  w: Word;

  h: Word

):Integer;


ReadPixel

read the pen number value of the pixel at a specified x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2346

function ReadPixel(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongInt;

Arguments

Rp | A pointer to a RastPort structure
X | X Coordinate to read
Y | Y Coordinate to read

Function result

The pen number of the pixel at (x,y) is returned. -1 is returned if the pixel cannot be read for some reason.

Description

Combine the bits from each of the bit-planes used to describe a particular RastPort into the pen number selector which that bit combination normally forms for the system hardware selection of pixel color.

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


ReadPixelArray

Declaration

Source position: agraphics.pas line 2494

procedure ReadPixelArray(

  Src: PRastPort;

  SrcX: LongWord;

  SrcY: LongWord;

  Dst: PByte;

  DstX: LongWord;

  DstY: LongWord;

  DstBytesPerRow: LongWord;

  DstPixelFormat: LongWord;

  SizeX: LongWord;

  SizeY: LongWord

);


ReadPixelArray8

read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2424

function ReadPixelArray8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  XStop: LongWord;

  YStop: LongWord;

  Array_: PByte;

  TempRP: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X starting point
YStart | Y starting point
XStop | X stop point
YStop | Y stop point
Array_ | A Pointer to an array of Bytes from which to fetch the pixel data allocate at least ((((width + 15) shr 4) shl 4) * (ystop - ystart + 1)) bytes.
TempRP | A temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set == 1, temprp^.BytesPerRow = (((width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

The number of pixels read.

Description

For each pixel in a rectangular region, combine the bits from each of the bit-planes used to describe a particular RastPort into the pen number selector which that bit combination normally forms for the system hardware selection of pixel color.

xstop must be >= xstart; ystop must be >= ystart

This function doesn't make sense on true-/hicolor rastports.

See also

ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
ReadPixelLine8 | read the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelLine8 | Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.


ReadPixelColor

Declaration

Source position: agraphics.pas line 2493

function ReadPixelColor(

  Rp: PRastPort;

  X: LongWord;

  Y: LongWord

):LongWord;


ReadPixelLine8

read the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.

Declaration

Source position: agraphics.pas line 2422

function ReadPixelLine8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  Width: LongWord;

  Array_: PByte;

  TempRP: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X Postion in Line to start to read
YStart | Line to Read
Width | Length of line to read
Array_ | Pointer to an array of Bytes from which to fetch the pixel data allocate at least (((width + 15) shr 4) shl 4) bytes.
TempRP | A temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set == 1, temprp^.BytesPerRow = (((width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

The number of pixels read.

Description

For each pixel in a rectangular region, combine the bits from each of the bit-planes used to describe a particular RastPort into the pen number selector which that bit combination normally forms for the system hardware selection of pixel color.

width must be non negative

This function doesn't make sense on true-/hicolor rastports.

See also

ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
ReadPixelArray8 | read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.
WritePixelLine8 | Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.


RectFill

Fill a rectangular region in a RastPort.

Declaration

Source position: agraphics.pas line 2344

procedure RectFill(

  Rp: PRastPort;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Rp | A pointer to a RastPort
XMin | Left edge of rectange to fill
YMin | Top edge of rectange to fill
XMax | Right edge of rectange to fill
YMax | Bottom edge of rectange to fill

Description

Fills the rectangular region specified by the parameters with the chosen pen colors, areafill pattern, and drawing mode. If no areafill pattern is specified, fill the rectangular region with the FgPen color, taking into account the drawing mode.

The following relation must be true: (xmax >= xmin) and (ymax >= ymin)

Errors

Complement mode with FgPen complements all bitplanes.

See also

AreaEnd

Process table of vectors and ellipses and produce areafill.


RectFillColor

Declaration

Source position: agraphics.pas line 2491

procedure RectFillColor(

  Rp: PRastPort;

  XMin: LongWord;

  YMin: LongWord;

  XMax: LongWord;

  YMax: LongWord;

  Color: LongWord

);


ReleasePen

Release an allocated palette entry to the free pool.

Declaration

Source position: agraphics.pas line 2456

procedure ReleasePen(

  Cm: PColorMap;

  N: LongWord

);

Arguments

Cm | ColorMap structure where the pen was allocated
N | A palette index obtained via any of the palette allocation functions. Passing a -1 will result in this call doing nothing.

Description

Return the palette entry for use by other applications. If the reference count for this palette entry goes to zero, then it may be set to another RGB value.

See also

GetColorMap | Allocate and initialize Colormap
ObtainPen | Obtain a free palette entry for use by your program.
ObtainBestPenA | Search for the closest color match, or allocate a new one.


RemFont

Remove a font from the system list.

Declaration

Source position: agraphics.pas line 2374

procedure RemFont(

  TextFont: PTextFont

);

Arguments

TextFont

the TextFont structure to remove.

Description

This function removes a font from the system, ensuring that access to it is restricted to those applications that currently have an active pointer to it: i.e. no new SetFont() requests to this font are satisfied.

See also

OpenFont | Get a pointer to a system font.
CloseFont | Release a pointer to a system font.
SetFont | Set the text font and attributes in a RastPort.
AddFont | Add a font to the system list


RemIBob

Immediately remove a Bob from the gel list and the RastPort.

Declaration

Source position: agraphics.pas line 2315

procedure RemIBob(

  Bob: PBob;

  Rp: PRastPort;

  Vp: PViewPort

);

Arguments

Bob | A pointer to the Bob to be removed
Rp | A pointer to the RastPort if the Bob is to be erased
Vp | A pointer to the ViewPort for beam-synchronizing

Description

Removes a Bob immediately by uncoupling it from the gel list and erases it from the RastPort.

See also

InitGels | initialize a gel list; must be called before using gels.
RemVSprite | Remove a VSprite from the current gel list.


RemVSprite

Remove a VSprite from the current gel list.

Declaration

Source position: agraphics.pas line 2316

procedure RemVSprite(

  VSprite: PVSprite

);

Arguments

VSprite

A pointer to the VSprite structure to be removed from the gel list

Description

Unlinks the VSprite from the current gel list.

See also

InitGels | initialize a gel list; must be called before using gels.
RemIBob | Immediately remove a Bob from the gel list and the RastPort.


SafeSetOutlinePen

Declaration

Source position: agraphics.pas line 2525

procedure SafeSetOutlinePen(

  w: PRastPort;

  c: Byte

);


SafeSetWriteMask

Declaration

Source position: agraphics.pas line 2526

procedure SafeSetWriteMask(

  w: PRastPort;

  m: SmallInt

);


ScalerDiv

Get the scaling result that BitMapScale would.

Declaration

Source position: agraphics.pas line 2407

function ScalerDiv(

  Factor: LongWord;

  Numerator: LongWord;

  Denominator: LongWord

):LongWord;

Arguments

Factor | A number in the range 0..16383
Numerator | A number in the range 0..16383
Denominator | A number in the range 0..16383

Function result

Returns factor * numerator / denominator

Description

Calculate the expression (factor * numerator / denominator) such that the result is the same as the width of the destination result of BitMapScale() when the factor here is the width of the source, and the numerator and denominator are the XDestFactor and XSrcFactor for BitMapScale().

See also

BitMapScale

Perform raster scaling on a bit map.


ScrollRaster

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.

Declaration

Source position: agraphics.pas line 2359

procedure ScrollRaster(

  Rp: PRastPort;

  Dx: LongInt;

  Dy: LongInt;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Rp | A pointer to a rastport
Dx | x value to move
Dy | y value to move
XMin | Left edge of the rect to scroll
YMin | Upper edge of the rect to scroll
XMax | right edge of the rect to scroll
YMax | lower edge of the rect to scroll

Description

Scroll the contents of a rastport (dx,dy) towards (0,0). The empty spaces is filled by a call to RectFill(). Only the pixel in the rectangle (xMin,yMin)-(xMax,yMax) will be affected. The lower right corner (xMax, yMax) is automatically adjusted to the lower right corner in case it would be outside. After this operation the Flags bit of the layer associated with this rastport, if there is any layer, should be tested for simple layers in case there has any damage been created.

See also

ScrollRasterBF

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().


ScrollRasterBF

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().

Declaration

Source position: agraphics.pas line 2465

procedure ScrollRasterBF(

  Rp: PRastPort;

  Dx: LongWord;

  Dy: LongWord;

  XMin: LongWord;

  YMin: LongWord;

  XMax: LongWord;

  yMax: LongWord

);

Arguments

Rp | A pointer to a rastport
Dx | x value to move
Dy | y value to move
XMin | Left edge of the rect to scroll
YMin | Upper edge of the rect to scroll
XMax | right edge of the rect to scroll
yMax | lower edge of the rect to scroll

Description

Scroll the contents of a rastport (dx,dy) towards (0,0). The empty spaces is filled by a call to EraseRect(). Only the pixel in the rectangle (xMin,yMin)-(xMax,yMax) will be affected. The lower right corner (xMax, yMax) is automatically adjusted to the lower right corner in case it would be outside. After this operation the Flags bit of the layer associated with this rastport, if there is any layer, should be tested for simple layers in case there has any damage been created.

See also

ScrollRaster

Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.


ScrollVPort

Reinterpret RasInfo information in ViewPort to reflect the current Offset values.

Declaration

Source position: agraphics.pas line 2391

procedure ScrollVPort(

  Vp: PViewPort

);

Arguments

Vp

A pointer to a ViewPort structure that is currently be displayed.

Description

After the programmer has adjusted the Offset values in the RasInfo structures of ViewPort, change the the copper lists to reflect the the Scroll positions. Changing the BitMap ptr in RasInfo and not changing the the Offsets will effect a double buffering affect.

Errors

Amiga video drivers can perform a validation of offsets, and may refuse to scroll the screen too far (if they somehow can't provide the requested offset). In this case offset values in the ViewPort will be updated in order to reflect the real result of the operation.


SetABPenDrMd

Set pen colors and draw mode for a RastPort.

Declaration

Source position: agraphics.pas line 2446

procedure SetABPenDrMd(

  Rp: PRastPort;

  APen: LongWord;

  BPen: LongWord;

  DrawMode: LongWord

);

Arguments

Rp | A pointer to a RastPort
APen | primary pen value
BPen | secondary pen value
DrawMode | 0-255, some combinations may not make much sense.

Description

Set the pen values and drawing mode for lines, fills and text.

This call is essentially the same as a sequence of SetAPen()/SetBPen()/SetDrMD() calls, except that it is significantly faster. The minterms will only be generated once, or not at all if nothing changed (warning to illegal RastPort pokers!).

This functions turns on PenMode for the RastPort.

See also

SetAPen | Set the primary pen for a RastPort.
SetBPen | Set secondary pen for a RastPort
SetDrMD | Set drawing mode for a RastPort


SetAfPt

Set Area PAttern and Point Size

Declaration

Source position: agraphics.pas line 2520

procedure SetAfPt(

  w: PRastPort;

  p: Pointer;

  n: Byte

);

Arguments

w | A pointer to a Rastport
p | Area Fill pattern
n | Area Point Size


SetAPen

Set the primary pen for a RastPort.

Declaration

Source position: agraphics.pas line 2350

procedure SetAPen(

  Rp: PRastPort;

  Pen: LongWord

);

Arguments

Rp | A pointer to a RastPort
Pen | Pen (0..255)

Description

Set the primary drawing pen (A-Pen) for lines, fills, and text. This functions turns on PenMode for the RastPort.

See also

GetAPen | Get the A Pen value for a RastPort
SetBPen | Set secondary pen for a RastPort
GetBPen | Get the B Pen value for a RastPort


SetBPen

Set secondary pen for a RastPort

Declaration

Source position: agraphics.pas line 2351

procedure SetBPen(

  Rp: PRastPort;

  Pen: LongWord

);

Arguments

Rp | A pointer to a RastPort
Pen | Pen (0..255)

Description

Set the secondary drawing pen (B-Pen) for lines, fills, and text. This functions turns on PenMode for the RastPort.

See also

GetBPen | Get the B Pen value for a RastPort
SetAPen | Set the primary pen for a RastPort.
GetAPen | Get the A Pen value for a RastPort


SetChipRev

Turns on the features of a Chip Set

Declaration

Source position: agraphics.pas line 2445

function SetChipRev(

  Want: LongWord

):LongWord;

Function result

Actual bits set in GfxBase^.ChipRevBits0.

Description

Enables the features of the requested Chip Set if available, and updates the graphics database accordingly.

This routine should only be called once. It will be called by the system in the startup-sequence, but is included in the autodocs for authors of bootblock-games that wish to take advantage of post-ECS features.

Errors

This function isn't implemented on all platforms.


SETCHIPREV_A

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 2269

const SETCHIPREV_A = GFXF_HR_AGNUS;


SETCHIPREV_AA

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 2271

const SETCHIPREV_AA = GFXF_AA_ALICE or GFXF_AA_LISA or SETCHIPREV_ECS;


SETCHIPREV_BEST

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 2272

const SETCHIPREV_BEST = $ffffffff;


SETCHIPREV_ECS

Pass to SetChipRev()

Declaration

Source position: agraphics.pas line 2270

const SETCHIPREV_ECS = GFXF_HR_AGNUS or GFXF_HR_DENISE;


SetCollision

Set a pointer to a user collision routine.

Declaration

Source position: agraphics.pas line 2317

procedure SetCollision(

  Num: LongWord;

  Routine: Pointer;

  GelsInfo: PGelsInfo

);

Arguments

Num | Collision vector number
Routine | A pointer to the user's collision routine

Description

Sets a specified entry (num) in the user's collision vectors table equal to the address of the specified collision routine.

See also

InitGels

initialize a gel list; must be called before using gels.


SetDrMd

Set drawing mode for a RastPort

Declaration

Source position: agraphics.pas line 2352

procedure SetDrMd(

  Rp: PRastPort;

  DrawMode: LongWord

);

Arguments

Rp | A pointer to a RastPort.
DrawMode | 0-255, some combinations may not make much sense. (e.g. JAM1, JAM2, COMPLEMENT, INVERSVID, AREAOUTLINE or NOCROSSFILL )

Description

Set the drawing mode for lines, fills and text.


SetDrPt

Set Draw Pattern

Declaration

Source position: agraphics.pas line 2521

procedure SetDrPt(

  w: PRastPort;

  p: Word

);

Arguments

w | A pointer to a RastPort
p | Pattern to Set


SetFont

Set the text font and attributes in a RastPort.

Declaration

Source position: agraphics.pas line 2304

procedure SetFont(

  Rp: PRastPort;

  const TextFont: PTextFont

);

Arguments

Rp | The RastPort in which the text attributes are to be changed
TextFont | pointer to a TextFont structure returned from OpenFont() or OpenDiskFont

Description

This function sets the font in the RastPort to that described by font, and updates the text attributes to reflect that change. This function clears the effect of any previous soft styles.

This function had previously been documented that it would accept a null font. This practice is discouraged.

  • Use of a RastPort with a null font with text routines has always been incorrect and risked the guru.
  • Keeping an obsolete font pointer in the RastPort is no more dangerous than keeping a zero one there.
  • SetFont(rp, 0) causes spurious low memory accesses under some system software releases.

See also

OpenFont | Get a pointer to a system font.
OpenDiskFont |
StripFont | Remove the TextFontExtension from a font


SetMaxPen

Set maximum pen value for a rastport

Declaration

Source position: agraphics.pas line 2463

procedure SetMaxPen(

  Rp: PRastPort;

  MaxPen: LongWord

);

Arguments

Rp | A pointer to a RastPort
MaxPen | A longword pen value.

Description

This will instruct the graphics library that the owner of the rastport will not be rendering in any colors whose index is >maxpen. If there are any speed optimizations which the graphics device can make based on this fact (for instance, setting the pixel write mask), they will be done.

Basically this call sets the rastport mask, if this would improve speed. On devices where masking would slow things down (like with chunky pixels), it will be a no-op.

The maximum pen value passed must take into account not only which colors you intend to render in the future, but what colors you will be rendering on top of. SetMaxPen(rp, 0); doesn't make much sense.

See also

SetWriteMask

Set the pixel write mask value for a RastPort


SetOPen

Set Outline pen

Declaration

Source position: agraphics.pas line 2522

procedure SetOPen(

  w: PRastPort;

  c: Byte

);

Arguments

w | A pointer to a RastPort
c | Pen 0..255


SetOutlinePen

Set the Outline Pen value for a RastPort

Declaration

Source position: agraphics.pas line 2461

function SetOutlinePen(

  Rp: PRastPort;

  Pen: LongWord

):LongWord;

Arguments

Rp | A pointer to a RastPort
Pen | Pen 0..255

Function result

Returns the previous outline pen

Description

Set the current value of the O pen for the rastport and turn on area outline mode. This function should be used instead of poking the structure directly, because future graphics devices may store it differently, for instance, using more bits.


SetRast

Set an entire drawing area to a specified color.

Declaration

Source position: agraphics.pas line 2332

procedure SetRast(

  Rp: PRastPort;

  Pen: LongWord

);

Arguments

Rp | A pointer to a RastPort
Pen | The pen number (0-255) to jam into bitmap

Description

Set the entire contents of the specified RastPort to the specified pen.

See also

RectFill

Fill a rectangular region in a RastPort.


SetRGB32

Set one color register for this Viewport.

Declaration

Source position: agraphics.pas line 2439

procedure SetRGB32(

  Vp: PViewPort;

  N: LongWord;

  R: LongWord;

  G: LongWord;

  B: LongWord

);

Arguments

Vp | Viewport
N | The number of the color register to set.
R | Red level (32 bit left justified fraction)
G | green level (32 bit left justified fraction)
B | blue level (32 bit left justified fraction)

Description

If there is a ColorMap for this viewport, then the value will be stored in the ColorMap. The selected color register is changed to match your specs. If the color value is unused then nothing will happen.

Lower order bits of the palette specification will be discarded, depending on the color palette resolution of the target graphics device. Use $ffffffff for the full value, $7fffffff for 50%, etc. You can find out the palette range for your screen by querying the graphics data base.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB32 | Set a series of color registers for this Viewport.
SetRGB32CM | Set one color register for this ColorMap.
LoadRGB32 | Set a series of color registers for this Viewport.


SetRGB32CM

Set one color register for this ColorMap.

Declaration

Source position: agraphics.pas line 2464

procedure SetRGB32CM(

  Cm: PColorMap;

  N: LongWord;

  R: LongWord;

  G: LongWord;

  B: LongWord

);

Arguments

Cm | Colormap
N | The number of the color register to set. Must not exceed the number of colors allocated for the colormap.
R | red level (32 bit unsigned left justified fraction)
G | green level (32 bit unsigned left justified fraction)
B | blue level (32 bit unsigned left justified fraction)

Description

Store the (r,g,b) triplet at index n of the ColorMap structure. This function can be used to set up a ColorMap before before linking it into a viewport.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB32 | Set a series of color registers for this Viewport.
SetRGB32 | Set one color register for this Viewport.
LoadRGB32 | Set a series of color registers for this Viewport.


SetRGB4

Set one color register for this viewport.

Declaration

Source position: agraphics.pas line 2341

procedure SetRGB4(

  Vp: PViewPort;

  ColIndex: LongWord;

  Red: LongWord;

  Green: LongWord;

  Blue: LongWord

);

Arguments

Vp

Modify this viewport

Description

Change the color look up table so that this viewport displays the color (r,g,b) for pen number n.

If there is a ColorMap for this viewport, then the value will be stored in the ColorMap. The selected color register is changed to match your specs. If the color value is unused then nothing will happen.

Lower order bits of the palette specification will be discarded, depending on the color palette resolution of the target graphics device. Use $f for the full value, $7 for 50%, etc. You can find out the palette range for your screen by querying the graphics data base.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB4 | Inquire value of entry in ColorMap.
SetRGB4CM | Set one color register for this ColorMap.


SetRGB4CM

Set one color register for this ColorMap.

Declaration

Source position: agraphics.pas line 2398

procedure SetRGB4CM(

  ColorMap: PColorMap;

  ColIndex: LongWord;

  Red: LongWord;

  Green: LongWord;

  Blue: LongWord

);

Description

Store the (r,g,b) triplet at index n in the ColorMap structure. The changes will not be immediately displayed. Use this function before linking the ColorMap to a ViewPort.

See also

GetColorMap | Allocate and initialize Colormap
GetRGB4 | Inquire value of entry in ColorMap.
SetRGB4 | Set one color register for this viewport.


SetRPAttrs

VarArgs Version of SetRPAttrsA()

Declaration

Source position: agraphics.pas line 2513

procedure SetRPAttrs(

  rp: PRastPort;

  const argv: array of PtrUInt

);


SetRPAttrsA

Modify rastport settings via a tag list

Declaration

Source position: agraphics.pas line 2473

function SetRPAttrsA(

  Rp: PRastPort;

  const Tags: PTagItem

):LongWord;

Arguments

Rp | A pointer to a RastPort
Tags | Tags for the elements to get

Description

Modify settings of a rastport, based on the taglist passed. See GetRPAttrsA() for possible Tags

See also

SetRPAttrsA | Modify rastport settings via a tag list
SetFont | Set the text font and attributes in a RastPort.
SetSoftStyle | Set the soft style of the current font.
SetAPen | Set the primary pen for a RastPort.
SetBPen | Set secondary pen for a RastPort
SetDrMd | Set drawing mode for a RastPort
SetOutLinePen | Set the Outline Pen value for a RastPort
SetWriteMask | Set the pixel write mask value for a RastPort
SetMaxPen | Set maximum pen value for a rastport
GetRPAttrsA | Examine rastport settings via a tag list


SetSoftStyle

Set the soft style of the current font.

Declaration

Source position: agraphics.pas line 2308

function SetSoftStyle(

  Rp: PRastPort;

  Style: LongWord;

  Enable: LongWord

):LongWord;

Arguments

Rp | A pointer to a RastPort
Style | The new font style to set, subject to enable.
Enable | Those bits in style to be changed. Any set bits here that would not be set as a result of AskSoftStyle() will be ignored, and the Result will not be as expected.

Function result

The resulting style, both as a result of previous soft style selection, the effect of this function, and the style inherent in the set font.

Description

This function alters the soft style of the current font. Only those bits that are also set in enable are affected. The resulting style is returned, since some style request changes will not be honored when the implicit style of the font precludes changing them.

See also

AskSoftStyle

Get the soft style bits of the current font.


SetWriteMask

Set the pixel write mask value for a RastPort

Declaration

Source position: agraphics.pas line 2462

function SetWriteMask(

  Rp: PRastPort;

  Msk: LongWord

):LongWord;

Arguments

Rp

A pointer to a RastPort

Function result

Graphics devices which do not support per-bit masking will return 0 (failure).

Description

Set the current value of the bit write mask for the rastport. bits of the pixel with zeros in their mask will not be modified by subsequent drawing operations.


SetWrMsk

Set Write Mask for RastPort

Declaration

Source position: agraphics.pas line 2523

procedure SetWrMsk(

  w: PRastPort;

  m: Byte

);

Arguments

w | A pointer to a RastPort
m | Mask to set


SortGList

Sort the current gel list, ordering its y,x coordinates.

Declaration

Source position: agraphics.pas line 2318

procedure SortGList(

  Rp: PRastPort

);

Arguments

Rp

A pointer to the RastPort structure containing the GelsInfo

Description

Sorts the current gel list according to the gels' y,x coordinates. This sorting is essential before calls to DrawGList() or DoCollision().

See also

InitGels | initialize a gel list; must be called before using gels.
DoCollision | Test every gel in gel list for collisions.
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.


StripFont

Remove the TextFontExtension from a font

Declaration

Source position: agraphics.pas line 2433

procedure StripFont(

  Font: PTextFont

);

Arguments

Font

Font to remove extension from.

See also

ExtendFont

Ensure TTextFont.tf_Extension has been built for a font


SyncSBitMap

Syncronize Super BitMap with whatever is in the standard Layer bounds.

Declaration

Source position: agraphics.pas line 2367

procedure SyncSBitMap(

  Layer: PLayer

);

Description

Copy all bits from ClipRects in Layer into Super BitMap BitMap. This is used for those functions that do not want to deal with the ClipRect structures but do want to be able to work with a SuperBitMap Layer.

After calling this function, the programmer can manipulate the bits in the superbitmap associated with the layer. Afterwards, the programmer should call CopySBitMap to copy the bits back into the onscreen layer.

See also

CopySBitmap

Syncronize Layer window with contents of Super BitMap


TextExtent

Determine raster extent of text data.

Declaration

Source position: agraphics.pas line 2408

procedure TextExtent(

  Rp: PRastPort;

  const String_: PChar;

  Count: LongWord;

  TextExtent: PTextExtent

);

Arguments

Rp | A pointer to the RastPort which describes where the text attributes reside.
String_ | The address of the string to determine the length of.
Count | the number of characters in the string. If 0, there are no characters in the string.

Description

This function determines a more complete metric of the space that a text string would render into than the TextLength() function.

TextExtent_ is filled in as follows:

te_Width
same as TextLength() result: the RastPort current x position advance that rendering this text would cause.
te_Height
same as tf_YSize. The height of the font.
te_Extent.MinX
the offset to the left side of the rectangle this would render into. Often zero.
te_Extent.MinY
same as -tf_Baseline. The offset from the baseline to the top of the rectangle this would render into.
te_Extent.MaxX
the offset of the left side of the rectangle this would render into. Often the same as te_Width - 1.
te_Extent.MaxY
same as tf_YSize - tf_Baseline - 1. The offset from the baseline to the bottom of the rectangle this would render into.

See also

TextLength | Determine raster length of text data.
GfxText | Write text characters (no formatting).
TextFit | Count characters that will fit in a given extent


TextFit

Count characters that will fit in a given extent

Declaration

Source position: agraphics.pas line 2409

function TextFit(

  Rp: PRastPort;

  const String_: PChar;

  StrLen: LongWord;

  TextExtent: PTextExtent;

  ConstrainingExtent: PTextExtent;

  StrDirection: LongInt;

  ConstrainingBitWidth: LongWord;

  ConstrainingBitHeight: LongWord

):LongWord;

Arguments

Rp | A pointer to the RastPort which describes where the text attributes reside.
String_ | The address of string to determine the constraint of
StrLen | The number of characters in the string. If 0, there are no characters in the string.
ConstrainingExtent | The extent that the text must fit in. This can be nil, indicating only the constrainingBit dimensions will describe the constraint.
StrDirection | the offset to add to the string pointer to get to the next character in the string. Usually 1. Set to -1 and the string to the end of the string to perform a TextFit() anchored at the end. No other value is valid.
ConstrainingBitWidth | An alternative way to specify the rendering box constraint width that is independent of the rendering origin. Range 0..32767.
ConstrainingBitHeight | An alternative way to specify the rendering box constraint height that is independent of the rendering origin. Range 0..32767.

Function result

The number of characters from the origin of the given string that will fit in both the constraining extent (which specifies a CP bound and a rendering box relative to the origin) and in the rendering width and height specified.The result is 0 chars and an empty TextExtent when the fit cannot be performed. This occurs not only when no text will fit in the provided constraints, but also when: The RastPort's rp_TxSpacing sign and magnitude is so great it reverses the path of the text or the constrainingExtent does not include x = 0.

Description

This function determines how many of the characters of the provided string will fit into the space described by the constraining parameters. It also returns the extent of that number of characters.

See also

TextLength | Determine raster length of text data.
TextExtent | Determine raster extent of text data.
GfxText | Write text characters (no formatting).


TextLength

Determine raster length of text data.

Declaration

Source position: agraphics.pas line 2302

function TextLength(

  Rp: PRastPort;

  const String_: PChar;

  Count: LongWord

):LongInt;

Arguments

Rp | A pointer to the RastPort which describes where the text attributes reside.
String_ | The address of string to determine the length of
Count | The string length. If 0, there are no characters in the string.

Function result

The number of pixels in x this text would occupy, not including any negative kerning that may take place at the beginning of the text string, nor taking into account the effects of any clipping that may take place.

Description

This graphics function determines the length that text data would occupy if output to the specified RastPort with the current attributes. The length is specified as the number of raster dots: to determine what the current position would be after a GfxText() using this string, add the length to cp_x (cp_y is unchanged by GfxText()). Use the newer TextExtent() to get more information.

See also

TextFit | Count characters that will fit in a given extent
TextExtent | Determine raster extent of text data.
GfxText | Write text characters (no formatting).


UCopperListInit

Allocates and initializes copperlist structures and buffers internal to UCopList structure.

Declaration

Source position: agraphics.pas line 2392

function UCopperListInit(

  UCopList: PUCopList;

  N: LongInt

):PCopList;

See also

CMOVE | Append copper move instruction to user copper list.
CWAIT | Append copper wait instruction to user copper list.


UnlockBitMap

Declaration

Source position: agraphics.pas line 2490

procedure UnlockBitMap(

  Lock: Pointer

);


UnlockBitMapFromBoard

Declaration

Source position: agraphics.pas line 2500

procedure UnlockBitMapFromBoard(

  Lock: Pointer;

  Modified: LongInt

);


UnlockLayerRom

Unlock Layer structure by ROM(gfx lib) code.

Declaration

Source position: agraphics.pas line 2366

procedure UnlockLayerRom(

  Layer: PLayer

);

Description

Release the lock on this layer. If the same task has called LockLayerRom() more than once than the same number of calls to UnlockLayerRom() must happen before the layer is actually freed so that other tasks may use it. This call does destroy scratch registers. This call is identical to UnlockLayer().

See also

LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
UnlockLayer | Unlock layer and allow graphics routines to use it.
LockLayer | Lock layer to make changes to ClipRects.


VBeamPos

Get vertical beam position at this instant.

Declaration

Source position: agraphics.pas line 2357

function VBeamPos: LongInt;

Description

interrogates hardware for beam position and returns value. valid results in are the range of 0-511. Because of multitasking, the actual value returned may have no use. If you are the highest priority task then the value returned should be close, within 1 line.

Errors

This function isn't implemented on all platforms.


VideoControl

Modify the operation of a ViewPort's ColorMap

Declaration

Source position: agraphics.pas line 2411

function VideoControl(

  ColorMap: PColorMap;

  TagArray: PTagItem

):LongWord;

Function result

error = nil

Description

Process the commands in the VideoControl command TagItem buffer using cm as the target, with respect to its "attached" ViewPort.

Errors

Not implemented


VIDEOCONTROL_BATCH

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1348

const VIDEOCONTROL_BATCH = $10;


VideoControlTags

VarArgs Version of VideoControl()

Declaration

Source position: agraphics.pas line 2514

function VideoControlTags(

  colorMap: PColorMap;

  const argv: array of PtrUInt

):LongWord;

See also

GetColorMap | Allocate and initialize Colormap
FreeColorMap | Free the ColorMap structure and return memory to free memory pool.


WaitBlit

Wait for the blitter to be finished before proceeding with anything else.

Declaration

Source position: agraphics.pas line 2331

procedure WaitBlit;

Description

WaitBlit returns when the blitter is idle. This function should normally only be used when dealing with the blitter in a synchronous manner, such as when using OwnBlitter() and DisownBlitter(). WaitBlit() does not wait for all blits queued up using QBlit() or QBSBlit(). You should call WaitBlit() if you are just about to modify or free some memory that the blitter may be using.

Errors

This function is unimplemented.

See also

OwnBlitter | get the blitter for private usage
DisownBlitter | Returns blitter to free state.


WaitBOVP

Wait till vertical beam reached bottom of this viewport.

Declaration

Source position: agraphics.pas line 2360

procedure WaitBOVP(

  Vp: PViewPort

);

Arguments

Vp

A pointer to ViewPort structure

Description

Returns when the vertical beam has reached the bottom of this viewport

Errors

This function is unimplemented.


WaitTOF

Wait for the top of the next video frame.

Declaration

Source position: agraphics.pas line 2338

procedure WaitTOF;

Description

Wait for vertical blank to occur and all vertical blank interrupt routines to complete before returning to caller. Adds the task to the TOF queue; it will be signalled when the vertical blank interrupt occurs.


WriteChunkyPixels

Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2479

procedure WriteChunkyPixels(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  XStop: LongWord;

  YStop: LongWord;

  Array_: PByte;

  BytesPerRow: LongInt

);

Arguments

Rp | Destination RastPort
XStart | Starting x Point
YStart | Starting y Point
XStop | Stop X Point
YStop | Stop Y Point
Array_ | Array with pen values
BytesPerRow | The number of bytes per row in the source array. This should be at least as large as the number of pixels being written per line.

Description

For each pixel in a rectangular region, decode the pen number selector from a linear array of pen numbers into the bit-planes used to describe a particular rastport.

xstop must be >= xstart and ystop must be >= ystart The source array can be in fast RAM.

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


WritePixel

Change the pen num of one specific pixel in a specified RastPort.

Declaration

Source position: agraphics.pas line 2347

function WritePixel(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongInt;

Arguments

Rp | A pointer to a RastPort
X | X coordinate of Pixel
Y | Y coordinate of Pixel

Function result

0 if pixel succesfully changed = -1 if (x,y) is outside the RastPort

Description

Changes the pen number of the selected pixel in the specified RastPort to that currently specified by PenA, the primary drawing pen. Obeys minterms in RastPort.

See also

ReadPixel

read the pen number value of the pixel at a specified x,y location within a certain RastPort.


WritePixelArray

Declaration

Source position: agraphics.pas line 2495

procedure WritePixelArray(

  Src: PByte;

  SrcX: LongWord;

  SrcY: LongWord;

  SrcBytesPerRow: LongWord;

  SrcPixelFormat: LongWord;

  Dst: PRastPort;

  DstX: LongWord;

  DstY: LongWord;

  SizeX: LongWord;

  SizeY: LongWord

);


WritePixelArray8

Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.

Declaration

Source position: agraphics.pas line 2425

function WritePixelArray8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  XStop: LongWord;

  YStop: LongWord;

  Array_: PByte;

  TempRP: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X Start point
YStart | Y Start point
XStop | X end point
YStop | Y end point
Array_ | a pointer to an array of Bytess from which to fetch the pixel data. Allocate at least ((((Width + 15) shr 4) shl 4) * (ystop - ystart + 1)) bytes.
TempRP | A temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set = 1, temprp^.BitMap with BytesPerRow = (((width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

Count will be set to the number of pixels plotted.

Description

For each pixel in a rectangular region, decode the pen number selector from a linear array of pen numbers into the bit-planes used to describe a particular rastport. xstop must be >= xstart and ystop must be >= ystart

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


WritePixelColor

Declaration

Source position: agraphics.pas line 2492

function WritePixelColor(

  Rp: PRastPort;

  X: LongWord;

  Y: LongWord;

  Color: LongWord

):LongInt;


WritePixelLine8

Write the pen number value of a horizontal line of pixels starting at a specified x,y location and continuing right for count pixels.

Declaration

Source position: agraphics.pas line 2423

function WritePixelLine8(

  Rp: PRastPort;

  XStart: LongWord;

  YStart: LongWord;

  Width: LongWord;

  Array_: PByte;

  TempRP: PRastPort

):LongInt;

Arguments

Rp | A pointer to a RastPort
XStart | X Start point
YStart | Line To write
Width | Count of horizontal pixels to write
Array_ | pointer to an array of Bytes from which to fetch the pixel data allocate at least (((Width + 15) shr 4) shl 4) bytes.
TempRP | temporary rastport (copy of rp with Layer set = nil, temporary memory allocated for temprp^.BitMap with Rows set = 1, temprp^.BitMap BytesPerRow = (((Width + 15) shr 4) shl 1), and temporary memory allocated for temprp^.BitMap^.Planes[])

Function result

Count will be set to the number of pixels plotted

Description

For each pixel in a horizontal region, decode the pen number selector from a linear array of pen numbers into the bit-planes used to describe a particular rastport.

See also

WritePixel

Change the pen num of one specific pixel in a specified RastPort.


XorRectRegion

Perform 2d XOR operation of rectangle with region, leaving result in region

Declaration

Source position: agraphics.pas line 2386

function XorRectRegion(

  Region: PRegion;

  const Rectangle: PRectangle

):LongBool;

Function result

True if successful operation, False if ran out of memory

Description

Add portions of rectangle to region if they are not in the region. Remove portions of rectangle from region if they are in the region.

See also

OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.


XorRegionRegion

Perform 2d XOR operation of one region with second region, leaving result in second region

Declaration

Source position: agraphics.pas line 2396

function XorRegionRegion(

  const SrcRegion: PRegion;

  DestRegion: PRegion

):LongBool;

Arguments

SrcRegion | A pointer to Source Region
DestRegion | A pointer to Destination Region

Function result

True if successful operation, False if ran out of memory

Description

Join the regions together. If any part of SrcRegion overlaps DestRegion then remove that from the new region.

See also

OrRegionRegion | Perform 2d OR operation of one region with second region, leaving result in second region
AndRegionRegion | Perform 2d AND operation of one region with second region, leaving result in second region.


Reference for unit 'amigados': Procedures and functions

AddBuffers | Changes the number of buffers for a filesystem
AddCmdPathNode
AddDates
AddDosEntry | Add a Dos List entry to the lists
AddPart | Appends a file/dir to the end of a path
AddSegListTail
AddSegment | Adds a resident segment to the resident list
AddSegmentTagList
AllocateCmdPathList
AllocDosObject | Creates a dos object
AllocDosObjectTagList |
AllocDosObjectTags | Variable args version for AllocDosObject for direct tag use.
AllocSegList
AssignAdd | Adds a lock to an assign for multi-directory assigns
AssignAddToList
AssignLate | Creates an assignment to a specified path later
AssignLock | Creates an assignment to a locked object
AssignPath | Creates an assignment to a specified path
AttemptLockDosList | Attempt to lock the Dos Lists for use
BADDR | Convert a BPTR to a Pointer
CalculateSegmentChecksum
CapturePattern
ChangeFilePosition
ChangeFileSize
ChangeMode | Change the current mode of a lock or filehandle
CheckSignal | Checks for break signals
Cli | Returns a pointer to the CLI structure of the process
CliInitNewcli | Set up a process to be a shell using a startup packet.
CliInitRun | Set up a process to be a shell from initial packet
CompareDates | Compares two datestamps
CopyStringBSTRToC
CopyStringCToBSTR
CreateDir |
CreateDirTree
CreateNewProc | Create a new process from taglist
CreateNewProcTagList |
CreateNewProcTags | Variable args version for CreateNewProc for direct tag use.
CreateProc | Create a new process
CurrentDir | Make a directory lock the current directory
DateStamp | Fills the structure with the current time. Time is measured from 1. Jan. 1978.
DateStampToSeconds
DeleteVar | Deletes a local or environment variable
DeviceProc | Return the process MsgPort of specific I/O handler
DevNameFromFH
DevNameFromLock
DevNameFromPort
DismountDevice
DoPkt | Send a dos packet and wait for reply
DoPkt0 |
DoPkt1 |
DoPkt2 |
DoPkt3 |
DoPkt4 |
DosClone
DOSClose |
DosControl
DosDateToStr |
DosDelay | Delay a process for a specified time
DosDelete
DosDeleteFile | Delete a file or directory
DosExpunge
DosFlush | Flushes buffers for a buffered filehandle
DosInput | Identify the program's initial input file handle
DosObtain
DosOpen | Open a file for input or output
DosOutput | Identify the programs' initial output file handle
DosRead | Read bytes of data from a file
DosRelease
DosRename | Rename a directory or file
DosSeek | Set the current position for reading and writing
DosStrToDate |
DosSystem |
DosWrite | Write bytes of data to a file
DupFileHandle
DupLock | Duplicate a lock
DupLockFromFH | Gets a lock on an open file
EndNotify | Ends a notification request
ErrorOutput
ErrorReport | Displays a Retry/Cancel requester for an error
ExAll | Examine an entire directory
ExAllEnd | Stop an ExAll()
Examine | Examine a directory or file associated with a lock
ExamineDir
ExamineFH | Gets information on an open file
ExamineObject
Execute | Execute a CLI command
ExNext | Examine the next entry in a directory
Fault | Returns the text associated with a DOS error code
FClose
FFlush
FGetC | Read a character from the specified input (buffered)
FGets | Reads a line from the specified input (buffered)
FileHandleScan
FilePart | Returns the last component of a path
FileSystemAttr
FindArg | Find a keyword in a template
FindCliProc | Returns a pointer to the requested CLI process
FindDosEntry | Finds a specific Dos List entry
FindSegment | Finds a segment on the resident list
FindSegmentStackSize
FindTrackedAddress
FindVar | Finds a local variable
FixDateStamp
FlushVolume
FlushVolumePort
FOpen
FOpenFromLock
Format |
FormatPort
FPutC | Write a character to the specified output
FPuts | Writes a string the the specified output
FRead | Reads a number of blocks from an input (buffered)
FReadLine
FreeArgs | Free allocated memory after ReadArgs()
FreeCmdPathList
FreeDeviceProc | Releases port returned by GetDeviceProc()
FreeDiskFileSystemData
FreeDosEntry | Frees an entry created by MakeDosEntry
FreeDosObject | Frees an object allocated by AllocDosObject()
FWrite | Writes a number of blocks to an output (buffered)
GetArgStr | Returns the arguments for the process
GetCliCurrentDirName
GetCliProgramName
GetCliPrompt
GetConsolePort
GetCurrentDir
GetDeviceProc | Finds a handler to send a message to
GetDeviceProcFlags
GetDiskFileSystemData
GetDiskInfo
GetEntryData
GetExitData
GetFilePosition
GetFileSize
GetFileSysPort
GetFileSystemVectorPort
GetOwnerInfo
GetPID
GetProcMsgPort
GetProcSegList
GetProgramDir | Returns a lock on the directory the program was loaded from
GetSegListInfo
GetVar | Returns the value of a local or global variable
HexToLong
Info | Returns information about the disk
Inhibit | Inhibits access to a filesystem
InhibitPort
IoErr | Return extra information from the system
IsFileSystem | Returns whether a Dos handler is a filesystem
IsFileSystemPort
IsInteractive | Discover whether a file is "interactive"
LoadSeg | Scatterload a loadable file into memory
Lock | Lock a directory or file
LockDosList | Locks the specified Dos Lists for use
LockRecord | Locks a portion of a file
LockRecords | Lock a series of records
LockTagList
MakeDosEntry | Creates a DosList structure
MakeLink | Creates a filesystem link
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
MatchPattern | Checks for a pattern match with a string
MatchPatternNoCase | Checks for a pattern match with a string
MaxCli | Returns the highest CLI process number possibly in use
MKBADDR | Conbert a Pointer to a BPTR Value
MountDevice
NameFromFH | Get the name of an open filehandle
NameFromLock | Returns the name of a locked object
NameFromPort
NextDosEntry | Get the next Dos List entry
NonBlockingModifyDosEntry
NotifyDosListChange
NotifyProcListChange
NotifyVar
ObtainDirContext
OpenFromLock | Opens a file you have a lock on
ParentDir |
ParentOfFH | Returns a lock on the parent directory of a file
ParseCapturePattern
ParsePattern | Create a tokenized string for MatchPattern()
ParsePatternNoCase | Create a tokenized string for MatchPatternNoCase()
PathPart | Returns a pointer to the end of the next-to-last component of a path.
PrintFault | Returns the text associated with a DOS error code
ProcessScan
PutErrStr
PutStr | Writes a string the the default output (buffered)
ReadArgs | Read bytes of data from a file
ReadItem | Reads a single argument/name from command line
ReadLineItem
ReadSoftLink
Relabel | Change the volume name of a volume
ReleaseCapturedExpressions
ReleaseConsoleData
ReleaseDirContext
RemAssignList | Remove an entry from a multi-dir assign
RemDosEntry | Removes a Dos List entry from it's list
RemoveCmdPathNode
RemSegment | Removes a resident segment from the resident list
RenameDosEntry
ReplyPkt | Replies a packet to the person who sent it to you
ResolvePath
RunCommand | Runs a program using the current process
SameDevice | Are two locks are on partitions of the device?
SameFH
SameLock | Returns whether two locks are on the same object
ScanVars
SearchCmdPathList
SecondsToDateStamp
SelectErrorOutput
SelectInput | Select a filehandle as the default input channel
SelectOutput | Select a filehandle as the default output channel
SendPkt | Sends a packet to a handler
Serialize
SerializePort
SetArgStr | Sets the arguments for the current process
SetBlockingMode
SetCliCurrentDirName
SetCliProgramName
SetCliPrompt
SetComment | Change a files' comment string
SetConsolePort
SetCurrentCmdPathList
SetCurrentDir
SetDate
SetFileHandleAttr
SetFileSize | Sets the size of a file
SetFileSysPort
SetIoErr | Sets the value returned by IoErr()
SetMode | Set the current behavior of a handler
SetOwner | Set owner information for a file or directory
SetOwnerInfo
SetProcWindow
SetProgramDir | Sets the directory returned by GetProgramDir
SetProtection | Set protection for a file or directory
SetVar | Sets a local or environment variable
SetVBuf | Set buffering modes and size
SplitName | splits out a component of a pathname into a buffer
StartNotify | Starts notification on a file or directory
StrToLong | string to Integer value (decimal)
SubtractDates
SystemTagList | Have a shell execute a command line
SystemTags | Variable args version for SystemTagList for direct tag use.
TimedDosRequester
TrackAddressList
TrackSegmentList
UnGetC | Makes a char available for reading again. (buffered)
UnLoadSeg | Unload a seglist previously loaded by LoadSeg()
UnLock | Unlock a directory or file
UnLockDosList | Unlocks the Dos List
UnLockRecord | Unlock a record
UnLockRecords | Unlock a list of records
UnTrackAddress
UnTrackSegmentList
VFPrintf | format and print a string to a file (buffered)
VPrintf | Format and print string (buffered)
WaitForChar | Determine if chars arrive within a time limit
WaitForData
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
WriteChars | Writes bytes to the the default output (buffered)
WriteProtectVolume
WriteProtectVolumePort


Index of all identifiers in unit 'amigados'

A B C D E F G H I L M N O P R S T U V W

A

ABORT_BUSY | ACTION_NIL | ADO_Mask
ABORT_DISK_ERROR | ACTION_OBTAIN_CON_INFO | ADO_Name
ACCESS_READ | ACTION_PARENT | ADO_NotifyHook
ACCESS_WRITE | ACTION_PARENT_FH | ADO_NotifyInitial
ACTION_ADD_NOTIFY | ACTION_READ | ADO_NotifyMethod
ACTION_CHANGE_FILE_POSITION64 | ACTION_READ_RETURN | ADO_NotifyName
ACTION_CHANGE_FILE_SIZE64 | ACTION_READ_SOFT_LINK | ADO_NotifyPort
ACTION_CHANGE_MODE | ACTION_REMOVE_NOTIFY | ADO_NotifySignalNumber
ACTION_CHANGE_SIGNAL | ACTION_RENAME_DISK | ADO_NotifyTask
ACTION_COLLECT | ACTION_RENAME_OBJECT | ADO_NotifyUserData
ACTION_COPY_DIR | ACTION_SAME_FH | ADO_NotifyWaitReply
ACTION_COPY_LOCK_FH | ACTION_SAME_LOCK | ADO_Size
ACTION_CREATE_DIR | ACTION_SEEK | ADO_Strlen
ACTION_CURRENT_VOLUME | ACTION_SERIALIZE_DISK | ADO_TermChar
ACTION_DELETE_OBJECT | ACTION_SET_BLOCKING_MODE | ADO_TermCharStr
ACTION_DISK_INFO | ACTION_SET_COMMENT | ADO_Type
ACTION_END | ACTION_SET_DATE | ADO_Vectors
ACTION_EVENT | ACTION_SET_OWNER_INFO | AllocateCmdPathList
ACTION_EXAMINEDATA | ACTION_SET_PROTECT | AllocDosObject
ACTION_EXAMINEDATA_DIR | ACTION_SHUTDOWN | AllocDosObjectTagList
ACTION_EXAMINEDATA_FH | ACTION_SINGLE_CHARACTER_MODE | AllocDosObjectTags
ACTION_EXAMINE_NEXT | ACTION_STARTUP | AllocSegList
ACTION_EXAMINE_OBJECT | ACTION_TIMER | APB_DIDDIR
ACTION_FH_FROM_LOCK | ACTION_UID_TO_USERINFO | APB_DirChanged
ACTION_FILESYSTEM_ATTR | ACTION_USERNAME_TO_UID | APB_DODIR
ACTION_FINDINPUT | ACTION_WAIT_CHAR | APB_DODOT
ACTION_FINDOUTPUT | ACTION_WAIT_FOR_DATA | APB_DOWILD
ACTION_FINDUPDATE | ACTION_WRITE | APB_FollowHLinks
ACTION_FLUSH | ACTION_WRITE_PROTECT | APB_ITSWILD
ACTION_FORMAT | ACTION_WRITE_RETURN | APB_MultiAssigns
ACTION_FREE_DISK_FSSM | AddBuffers | APB_NOMEMERR
ACTION_FREE_LOCK | AddCmdPathNode | APF_DIDDIR
ACTION_FREE_RECORD64 | ADDCMDPATHNODE_HEAD | APF_DirChanged
ACTION_GET_DISK_FSSM | ADDCMDPATHNODE_TAIL | APF_DODIR
ACTION_GET_FILE_POSITION64 | AddDates | APF_DODOT
ACTION_GET_FILE_SIZE64 | AddDosEntry | APF_DOWILD
ACTION_GID_TO_GROUPINFO | AddPart | APF_FollowHLinks
ACTION_GROUPNAME_TO_GID | AddSegListTail | APF_ITSWILD
ACTION_ICONIFY | AddSegment | APF_MultiAssigns
ACTION_INFO | AddSegmentTagList | APF_NOMEMERR
ACTION_INHIBIT | ADO_AddColon | AS_Dummy
ACTION_INHIBIT_DOS_LONGPATH_HANDLING | ADO_AddedSize | AS_Entry
ACTION_INT_WRITE_RETURN | ADO_DOSMethodOnly | AS_SegmentList
ACTION_IS_FILESYSTEM | ADO_DOSType | AssignAdd
ACTION_LOCATE_OBJECT | ADO_Dummy | AssignAddToList
ACTION_LOCK_RECORD64 | ADO_ExamineData_CommentSize | AssignLate
ACTION_MAKE_LINK | ADO_ExamineData_LinkSize | AssignLock
ACTION_MORE_CACHE | ADO_ExamineData_NameSize | AssignPath
ACTION_NEWMEMFILE | ADO_ExamineDir_Context | AttemptLockDosList
ACTION_NEWMEMLOCK | ADO_Flags |

B

BADDR | BITSPERLONG
BITSPERBYTE | BYTESPERLONG

C

CalculateSegmentChecksum | CliInitNewcli | CreateDir
CapturePattern | CliInitRun | CreateDirTree
CHANGE_FH | CMD_DISABLED | CreateNewProc
ChangeFilePosition | CMD_INTERNAL | CreateNewProcTagList
ChangeFileSize | CMD_SYSTEM | CreateNewProcTags
CHANGE_LOCK | CompareDates | CreateProc
ChangeMode | COMPLEX_BIT | CurrentDir
CheckSignal | CopyStringBSTRToC |
Cli | CopyStringCToBSTR |

D

DateStamp | DE_NUMHEADS | DOS_FSVECTORPORT
DateStampToSeconds | DE_PREFAC | DOS_INFODATA
DC_AssignMountR | DE_RESERVEDBLKS | DosInput
DC_AssignMountW | DE_SECORG | DOS_LOCK
DC_BootCliCloseGadgetR | DE_SECSPERBLK | DOS_NOTIFYREQUEST
DC_BootCliCloseGadgetW | DE_SIZEBLOCK | DosObtain
DC_BootCliFontSizeR | DE_TABLESIZE | DosOpen
DC_BootCliFontSizeW | DE_UPPERCYL | DosOutput
DC_Dummy | DeviceProc | DOS_OWNER_NONE
DC_FHBufferR | DevNameFromFH | DOS_OWNER_ROOT
DC_FHBufferW | DevNameFromLock | DOS_RDARGS
DC_LocaleBaseR | DevNameFromPort | DosRead
DC_LocaleBaseW | DismountDevice | DosRelease
DC_MinProcStackR | DLT_DEVICE | DosRename
DC_MinProcStackW | DLT_LATE | DosSeek
DC_Reload68KApplistW | DLT_LOCK | DOS_STDPKT
DC_unused1R | DLT_NONBINDING | DosStrToDate
DC_WarnPostTimeR | DLT_PRIVATE | DosSystem
DC_WarnPostTimeW | DLT_VOLUME | DOSTRUE
DC_WarnWaitTimeR | DMDF_FORCE_DISMOUNT | DOS_VOLUMELIST
DC_WarnWaitTimeW | DMDF_KEEPDEVICE | DosWrite
DC_WildStarR | DMDF_REMOVEDEVICE | DP64_INIT
DC_WildStarW | DN_DEVICEONLY | DTB_FUTURE
DDB_AllBit | DN_FULLPATH | DTB_SUBST
DDB_Assign | DN_ROOTPATH | DTF_FUTURE
DDB_Completed | DoPkt | DTF_SUBST
DDB_Device | DoPkt0 | DupFileHandle
DDB_ExaminedBit | DoPkt1 | DupLock
DDB_PatternBit | DoPkt2 | DupLockFromFH
DDF_AllBit | DoPkt3 | DVPB_ASSIGNMENT
DDF_Assign | DoPkt4 | DVPB_CONSOLE
DDF_Completed | DOS_ANCHORPATH | DVPB_CURRDIR
DDF_Device | DOS_CLI | DVPB_DEVICE
DDF_ExaminedBit | DosClone | DVPB_FILESYS
DDF_PatternBit | DOSClose | DVPB_MULTIASSIGN
DE_BAUD | DosControl | DVPB_PROGDIR
DE_BLKSPERTRACK | DosDateToStr | DVPB_ROOTDIR
DE_BOOTBLOCKS | DosDelay | DVPB_UNLOCK
DE_BOOTPRI | DosDelete | DVPB_VOLUME
DE_BUFMEMTYPE | DosDeleteFile | DVPF_ASSIGNMENT
DE_CONTROL | DOS_DOSLIST | DVPF_CONSOLE
DE_DOSTYPE | DOS_EXALLCONTROL | DVPF_CURRDIR
DE_INTERLEAVE | DOS_EXAMINEDATA | DVPF_DEVICE
DeleteVar | DosExpunge | DVPF_FILESYS
DE_LOWCYL | DOSFALSE | DVPF_MULTIASSIGN
DE_MASK | DOS_FIB | DVPF_PROGDIR
DE_MAXTRANSFER | DOS_FILEHANDLE | DVPF_ROOTDIR
DE_MEMBUFTYPE | DosFlush | DVPF_UNLOCK
DE_NUMBUFFERS | DOS_FREADLINEDATA | DVPF_VOLUME

E

ED_COMMENT | ERROR_OBJECT_EXISTS | EXDF_HOLD
ED_DATE | ERROR_OBJECT_IN_USE | EXDF_NO_DELETE
ED_NAME | ERROR_OBJECT_LINKED | EXDF_NO_EXECUTE
ED_OWNER | ERROR_OBJECT_NOT_FOUND | EXDF_NO_READ
ED_PROTECTION | ERROR_OBJECT_TOO_LARGE | EXDF_NO_WRITE
ED_SIZE | ERROR_OBJECT_WRONG_TYPE | EXDF_OTR_DELETE
ED_TYPE | ErrorOutput | EXDF_OTR_EXECUTE
EndNotify | ERROR_READ_PROTECTED | EXDF_OTR_READ
ERROR_ACTION_NOT_KNOWN | ERROR_RECORD_NOT_LOCKED | EXDF_OTR_WRITE
ERROR_BAD_HUNK | ERROR_RENAME_ACROSS_DEVICES | EXDF_PURE
ERROR_BAD_NUMBER | ErrorReport | EXDF_SCRIPT
ERROR_BAD_SIGNAL_BIT | ERROR_REQUIRED_ARG_MISSING | EX_DirLock
ERROR_BAD_STREAM_NAME | ERROR_SEEK_ERROR | EX_DirLockInput
ERROR_BAD_TEMPLATE | ERROR_SIZE_MISSING | EX_DoCurrentDir
ERROR_BREAK | ERROR_STARTUP_STRING_TOO_LONG | EX_Dummy
ERROR_BROKEN_PIPE | ERROR_TASK_TABLE_FULL | Execute
ERROR_BUFFER_OVERFLOW | ERROR_TOO_MANY_ARGS | EXF_ALL
ERROR_COMMENT_TOO_BIG | ERROR_TOO_MANY_LEVELS | EXF_COMMENT
ERROR_CONTROL_STRING_TOO_LONG | ERROR_UNLOCK_ERROR | EXF_DATE
ERROR_DELETE_PROTECTED | ERROR_UNMATCHED_QUOTES | EX_FileHandle
ERROR_DEVICE_NAME_MISSING | ERROR_UNSUPPORTED_HARDWARE | EX_FileHandleInput
ERROR_DEVICE_NAME_TOO_LONG | ERROR_WOULD_BLOCK | EX_FileLock
ERROR_DEVICE_NOT_MOUNTED | ERROR_WRITE_PROTECTED | EX_FileLockInput
ERROR_DIRECTORY_NOT_EMPTY | ERROR_WRONG_PACKET_RETURNED | EXF_LINK
ERROR_DIR_NOT_FOUND | ExAll | EXF_NAME
ERROR_DISK_FULL | ExAllEnd | EXF_OBJECTID
ERROR_DISK_NOT_VALIDATED | Examine | EXF_OWNER
ERROR_DISK_WRITE_PROTECTED | EXAMINE_BIT | EXF_PROTECTION
ERROR_EXEC_DEVICE_NAME_TOO_LONG | ExamineDir | EXF_REFCOUNT
ERROR_FILE_NOT_OBJECT | ExamineFH | EXF_SIZE
ERROR_HANDLER_CANNOT_BE_STARTED | ExamineObject | EXF_spare1
ERROR_HANDLER_STRING_TOO_LONG | EXCLUSIVE_LOCK | EXF_spare2
ERROR_INVALID_COMPONENT_NAME | EX_DataFields | EXF_spare3
ERROR_INVALID_DEVICE_NAME | EXDB_ARCHIVE | EXF_spare4
ERROR_INVALID_DEVICE_TYPE | EXDB_GRP_DELETE | EXF_spare5
ERROR_INVALID_GLOBAL_VECTOR | EXDB_GRP_EXECUTE | EXF_spare6
ERROR_INVALID_LOCK | EXDB_GRP_READ | EXF_TYPE
ERROR_INVALID_NUMBER_OF_CYLINDERS | EXDB_GRP_WRITE | EX_LockInput
ERROR_INVALID_PACKET_MESSAGE | EXDB_HOLD | EX_MatchFunc
ERROR_INVALID_RESIDENT_LIBRARY | EXDB_NO_DELETE | EX_MatchString
ERROR_INVALID_SECTOR_SIZE | EXDB_NO_EXECUTE | ExNext
ERROR_INVALID_TASK_PRIORITY | EXDB_NO_READ | EX_ResetContext
ERROR_IS_PIPE | EXDB_NO_WRITE | EX_StringName
ERROR_IS_SOFT_LINK | EXDB_OTR_DELETE | EX_StringNameInput
ERROR_KEY_NEEDS_ARG | EXDB_OTR_EXECUTE | EXT_ABS
ERROR_LINE_TOO_LONG | EXDB_OTR_READ | EXT_COMMON
ERROR_LOCK_COLLISION | EXDB_OTR_WRITE | EXT_DEF
ERROR_LOCK_TIMEOUT | EXDB_PURE | EXT_DEXT16
ERROR_NO_DEFAULT_DIR | EXDB_SCRIPT | EXT_DEXT32
ERROR_NO_DISK | EXDF_ARCHIVE | EXT_DEXT8
ERROR_NO_FREE_STORE | EXDF_DEFAULT | EXT_REF16
ERROR_NO_MORE_ENTRIES | EXDF_GRP_DELETE | EXT_REF32
ERROR_NOT_A_DOS_DISK | EXDF_GRP_EXECUTE | EXT_REF8
ERROR_NOT_EXECUTABLE | EXDF_GRP_READ | EXT_RES
ERROR_NOT_IMPLEMENTED | EXDF_GRP_WRITE | EXT_SYMB

F

Fault | FIBF_OTR_WRITE | FreeDeviceProc
FAULT_MAX | FIBF_PURE | FreeDiskFileSystemData
FClose | FIBF_READ | FreeDosEntry
FFlush | FIBF_SCRIPT | FreeDosObject
FGetC | FIBF_WRITE | FSA_ActivityFlushTimeoutR
FGets | FileHandle | FSA_ActivityFlushTimeoutW
FH_BufferMode | FileHandleScan | FSA_DOSTypeR
FH_BufferSize | FileLock | FSA_Dummy
FH_Dummy | FilePart | FSA_FileHandleInput
FH_EndStream | FileSystemAttr | FSA_FileLockInput
FH_Locking | FindArg | FSA_HasRecycledEntriesR
FH_UserBuffer | FindCliProc | FSA_InactivityFlushTimeoutR
FIBB_ARCHIVE | FindDosEntry | FSA_InactivityFlushTimeoutW
FIBB_DELETE | FindSegment | FSA_LockInput
FIBB_EXECUTE | FindSegmentStackSize | FSA_MaxFileNameLengthR
FIBB_GRP_DELETE | FindTrackedAddress | FSA_MaxFileNameLengthW
FIBB_GRP_EXECUTE | FindVar | FSA_MaxRecycledEntriesR
FIBB_GRP_READ | FixDateStamp | FSA_MaxRecycledEntriesW
FIBB_GRP_WRITE | FlushVolume | FSA_MsgPortInput
FIBB_OTR_DELETE | FlushVolumePort | FSA_StringNameInput
FIBB_OTR_EXECUTE | FOpen | FSA_VersionNumberR
FIBB_OTR_READ | FOpenFromLock | FSA_VersionStringR
FIBB_OTR_WRITE | Format | FSA_VersionStringR_BufSize
FIBB_PURE | FORMAT_CDN | FSA_VersionStringR_Len
FIBB_READ | FORMAT_DEF | FSOF_ALTLINK
FIBB_SCRIPT | FORMAT_DOS | FSOF_LINK
FIBB_WRITE | FORMAT_INT | FSO_TYPE_DIRECTORY
FIBF_ARCHIVE | FORMAT_ISO | FSO_TYPE_FILE
FIBF_DELETE | FORMAT_MAX | FSO_TYPE_INVALID
FIBF_EXECUTE | FormatPort | FSO_TYPE_MASK
FIBF_GRP_DELETE | FORMAT_USA | FSO_TYPE_PIPE
FIBF_GRP_EXECUTE | FPutC | FSO_TYPE_SOCKET
FIBF_GRP_READ | FPuts | FSO_TYPE_SOFTLINK
FIBF_GRP_WRITE | FRead | FS_VECTORPORT_VERSION
FIBF_OTR_DELETE | FReadLine | FSVP
FIBF_OTR_EXECUTE | FreeArgs | FWrite
FIBF_OTR_READ | FreeCmdPathList |

G

GDI_Dummy | GetFileSystemVectorPort | GSLI_NATIVE
GDI_FileHandleInput | GetOwnerInfo | GSLI_ResidentStruct
GDI_FileLockInput | GetPID | GSLI_ResidentVersionString
GDI_InfoData | GetProcMsgPort | GSLI_SegmentSize
GDI_LockInput | GetProcSegList | GSLI_VersionString
GDI_MsgPortInput | GetProgramDir | GVB_BINARY_VAR
GDI_StringNameInput | GetSegListInfo | GVB_DONT_NULL_TERM
GDI_VolumeRequired | GetVar | GVB_GLOBAL_ONLY
GetArgStr | GPID_PARENT | GVB_LOCAL_ONLY
GetCliCurrentDirName | GPID_PROCESS | GVB_SAVE_VAR
GetCliProgramName | GPSLF_CLI | GVB_SCAN_ENVARC
GetCliPrompt | GPSLF_ENT | GVB_SCAN_LEVEL
GetConsolePort | GPSLF_RUN | GVB_SCAN_STARTDIR
GetCurrentDir | GPSLF_SEG | GVB_SCAN_TOPLEVEL
GetDeviceProc | GSLI_68KFileSize | GVF_BINARY_VAR
GetDeviceProcFlags | GSLI_68KFileXsum | GVF_DONT_NULL_TERM
GetDiskFileSystemData | GSLI_68KHUNK | GVF_GLOBAL_ONLY
GetDiskInfo | GSLI_68KOVLAY | GVF_LOCAL_ONLY
GetEntryData | GSLI_68KPS | GVF_SAVE_VAR
GetExitData | GSLI_Data | GVF_SCAN_ENVARC
GetFilePosition | GSLI_Dummy | GVF_SCAN_LEVEL
GetFileSize | GSLI_ElfHandle | GVF_SCAN_STARTDIR
GetFileSysPort | GSLI_HeaderSize |

H

HexToLong | HUNK_DREL32 | HUNK_NAME
HUNK_BREAK | HUNK_DREL8 | HUNK_OVERLAY
HUNK_BSS | HUNK_END | HUNK_RELOC16
HUNK_CODE | HUNK_EXT | HUNK_RELOC32
HUNK_DATA | HUNK_HEADER | HUNK_RELOC8
HUNK_DEBUG | HUNK_INDEX | HUNK_SYMBOL
HUNK_DREL16 | HUNK_LIB | HUNK_UNIT

I

ID_BOX0_DISK | ID_HFS_DISK | ID_VALIDATED
ID_BUSY_DISK | ID_INTER_DOS_DISK | ID_VALIDATING
ID_CDFS_DISK | ID_INTER_FFS_DISK | ID_VP255_DOS_DISK
ID_COLLECT_FILEHANDLE | ID_KICKSTART_DISK | ID_WRITE_PROTECTED
ID_COLLECT_LOCK | ID_LONGNAME_DOS_DISK | Info
ID_COLLECT_NOTIFICATION | ID_LONGNAME_FFS_DISK | Inhibit
ID_CON | ID_MSDOS_DISK | InhibitPort
ID_DOS_DISK | ID_MSDOS_DISK_DS | IoErr
ID_EXFAT_DISK | ID_MSDOS_DISK_HD | IsFileSystem
ID_EXT2_DISK | ID_NGFS_DISK | IsFileSystemPort
ID_FASTDIR_DOS_DISK | ID_NO_DISK_PRESENT | IsInteractive
ID_FASTDIR_FFS_DISK | ID_NOT_REALLY_DOS | ITEM_EQUAL
ID_FAT00_DISK | ID_NTFS_DISK | ITEM_ERROR
ID_FAT01_DISK | ID_RAWCON | ITEM_NOTHING
ID_FAT32_DISK | ID_SWAP_DISK | ITEM_QUOTED
ID_FFS_DISK | ID_UNREADABLE_DISK | ITEM_UNQUOTED

L

LDB_ASSIGNS | LK_InfoMask | LOCKF_ASSIGNMENT
LDB_DELETE | LK_Mode | LOCKF_CURRDIR
LDB_DEVICES | LK_Name | LOCKF_DEVICE
LDB_ENTRY | LK_ResolveMA | LOCKF_FILESYS
LDB_READ | LK_ResolveSL | LOCKF_PROGDIR
LDB_VOLUMES | LK_SoftLinks | LOCKF_ROOTDIR
LDB_WRITE | LoadSeg | LOCKF_SOFTLINK_ENDPART
LDF_ALL | Lock | LOCKF_SOFTLINK_MIDPART
LDF_ASSIGNS | LOCKB_ASSIGNMENT | LOCKF_VOLUME
LDF_DELETE | LOCKB_CURRDIR | LockRecord
LDF_DEVICES | LOCKB_DEVICE | LockRecords
LDF_ENTRY | LOCKB_FILESYS | LOCK_SAME
LDF_READ | LOCKB_PROGDIR | LOCK_SAME_HANDLER
LDF_VOLUMES | LOCKB_ROOTDIR | LockTagList
LDF_WRITE | LOCKB_SOFTLINK_ENDPART | LV_ALIAS
LEN_DATSTRING | LOCKB_SOFTLINK_MIDPART | LVB_IGNORE
LINK_HARD | LOCKB_VOLUME | LVF_IGNORE
LINK_SOFT | LOCK_DIFFERENT | LV_TYPE_MASK
LK_Dummy | LockDosList | LV_VAR

M

MakeDosEntry | MD_DOSType | MD_SectorsPerBlock
MakeLink | MD_Dummy | MD_SectorsPerTrack
MatchEnd | MD_Entry | MD_SegList
MatchFirst | MD_Flags | MD_StackSize
MatchNext | MD_GlobVec | MD_StartupNumber
MatchPattern | MD_Handler | MD_StartupString
MatchPatternNoCase | MD_HighCyl | MD_Surfaces
MaxCli | MD_IgnoreFSR | MDT_FileSystem
MAXINT | MD_LowCyl | MDT_Handler
MAX_VP_COMMENT | MD_Mask | MD_Unit
MAX_VP_FILENAME | MD_MaxTransfer | MININT
MAX_VP_SOFTLINK_TARGET | MD_NumBuffers | MKBADDR
MD_Activate | MD_Port | MODE_NEWFILE
MD_Baud | MD_PreAlloc | MODE_OLDFILE
MD_BufMemType | MD_Priority | MODE_READWRITE
MD_Control | MD_Reserved | MountDevice
MD_Device | MD_SectorSize |

N

NameFromFH | NP_CloseOutput | NP_OwnerUID
NameFromLock | NP_CommandName | NP_Path
NameFromPort | NP_ConsolePort | NP_Priority
NBM_ADDDOSENTRY | NP_ConsoleTask | NP_ProgramDir
NBM_CHANGESIGNAL | NP_CopyVars | NP_Seglist
NBM_DISKINSERTED | NP_CurrentDir | NP_StackSize
NBM_DISKREMOVED | NP_Dummy | NP_unused1
NBM_REMDOSENTRY | NP_Entry | NP_unused2
NBM_REMFREEDOSENTRY | NP_EntryCode | NP_UserData
NBM_RENAMEDOSENTRY | NP_EntryData | NP_WindowPtr
NDLC_END | NP_Error | NRB_CALL_HOOK
NextDosEntry | NP_ExitCode | NRB_DOS_NOTIFY_ONLY
NHM_ACTION_ADD | NP_ExitData | NRB_MAGIC
NHM_ACTION_CHANGE | NP_FinalCode | NRB_NOTIFY_INITIAL
NHM_ACTION_DELETE | NP_FinalData | NRB_SEND_MESSAGE
NHM_ACTION_INITIAL | NP_FreeSeglist | NRB_SEND_SIGNAL
NonBlockingModifyDosEntry | NP_Input | NRB_WAIT_REPLY
NOTIFY_CLASS | NPLC_END | NRF_CALL_HOOK
NOTIFY_CODE | NP_LocalAlias | NRF_DOS_NOTIFY_ONLY
NotifyDosListChange | NP_LocalVars | NRF_MAGIC
NotifyProcListChange | NP_LockStack | NRF_NOTIFY_INITIAL
NotifyVar | NP_Name | NRF_SEND_MESSAGE
NP_Arguments | NP_NotifyOnDeathMessage | NRF_SEND_SIGNAL
NP_Child | NP_NotifyOnDeathSignalBit | NRF_WAIT_REPLY
NP_Cli | NP_NotifyOnDeathSigTask | NR_HANDLER_FLAGS
NP_CloseError | NP_Output | NR_HANDLER_MASK
NP_CloseInput | NP_OwnerGID |

O

ObtainDirContext | OFFSET_CURRENT | OI_Process
OCD_Dummy | OFFSET_END | OI_ProcessInput
OCD_FileHandleInput | OI_Dummy | OI_StringName
OCD_MsgPortInput | OI_OwnerGID | OI_StringNameInput
OFFSET_BEGINNING | OI_OwnerUID | OpenFromLock

P

PAChain | PFindTrackedAddressMsg | PRB_spare18
PAddressAndSize | PFReadLineData | PRB_spare19
PAnchorPath | PInfoData | PRB_spare20
PAnchorPathOld | PLocalVar | PRB_spare21
P_ANY | PLock | PRB_spare22
ParentDir | PMultiAssign | PRB_spare23
ParentOfFH | P_NOT | PRDArgs
ParseCapturePattern | P_NOTCLASS | PRecordLock
ParsePattern | P_NOTEND | P_REPBEG
ParsePatternNoCase | PNotifyHookMsg | P_REPEND
pAssignList | PNotifyMessage | PRF_CHILDPROCESS
PAssignNode | PNotifyRequest | PRF_CLOSEERROR
PathPart | P_OREND | PRF_CLOSEINPUT
PCapturedExpression | P_ORNEXT | PRF_CLOSEOUTPUT
P_CLASS | P_ORSTART | PRF_EXTENDED_FLAGS
pCliProcList | PPathNode | PRF_FREEARGS_OBSOLETE
PCommandLineInterface | PProcess | PRF_FREECLI
PConsoleWindowData | PPseudoSegList | PRF_FREECURRDIR
PCSource | PRB_CHILDPROCESS | PRF_FREESEGLIST
PDateStamp | PRB_CLOSEERROR | PRF_HADCHILDREN
_PDateTime | PRB_CLOSEINPUT | PRF_HANDLERPROCESS
PDeathMessage | PRB_CLOSEOUTPUT | PRF_HASDLNOTIFY
pDeviceList | PRB_EXTENDED_FLAGS | PRF_HASPLNOTIFY
PDeviceNode | PRB_FREEARGS_OBSOLETE | PRF_LOCKSTACK
pDevInfo | PRB_FREECLI | PRF_SERVERPROCESS
PDevProc | PRB_FREECURRDIR | PRF_SHELLPROCESS
pDosEnvec | PRB_FREESEGLIST | PrintFault
pDosInfo | PRB_HADCHILDREN | ProcessScan
pDosLibrary | PRB_HANDLERPROCESS | pRootNode
PDOSList | PRB_HASDLNOTIFY | PSearchCmdPathListMsg
PDosPacket | PRB_HASPLNOTIFY | PSIKEY_ELF32
PDosPacket64 | PRB_LOCKSTACK | PSIKEY_INIT
PDosResidentSeg | PRB_SERVERPROCESS | PSIKEY_NFSYS
pErrorString | PRB_SHELLPROCESS | PSIKEY_NOFREE
PExAllControl | PRB_spare08 | P_SINGLE
PExAllData | PRB_spare09 | PSJUMP_MAGIC
PExamineData | PRB_spare10 | PStandardPacket
PFileHandle | PRB_spare11 | PStandardPacket64
PFileInfoBlock | PRB_spare12 | P_STOP
pFileLock | PRB_spare13 | PutErrStr
PFileSysStartupMsg | PRB_spare14 | PutStr
PFileSystemData | PRB_spare15 | PVolumeNode
PFileSystemVectorPort | PRB_spare16 |
PFileSystemVectors | PRB_spare17 |

R

RDAB_NOALLOC | ReleaseConsoleData | RLI_CommentChars
RDAB_NOPROMPT | ReleaseDirContext | RLI_CSourceInput
RDAB_STDIN | RemAssignList | RLI_Dummy
RDAF_NOALLOC | RemDosEntry | RLI_EscapeChars
RDAF_NOPROMPT | RemoveCmdPathNode | RLI_FileHandleInput
RDAF_STDIN | RemSegment | RLI_MultiLine
ReadArgs | RenameDosEntry | RLI_Substitute_E
ReadItem | ReplyPkt | RLI_Substitute_N
ReadLineItem | REPORT_INSERT | RNB_PRIVATE1
ReadSoftLink | REPORT_LOCK | RNB_WILDSTAR
REC_EXCLUSIVE | REPORT_STREAM | RNF_PRIVATE1
REC_EXCLUSIVE_IMMED | REPORT_TASK | RNF_WILDSTAR
RECF_DOS_METHOD_ONLY | REPORT_VOLUME | RunCommand
REC_MODE_MASK | ResolvePath | RUN_EXECUTE
REC_SHARED | RETURN_ERROR | RUN_SYSTEM
REC_SHARED_IMMED | RETURN_FAIL | RUN_SYSTEM_ASYNCH
Relabel | RETURN_OK |
ReleaseCapturedExpressions | RETURN_WARN |

S

SameDevice | SetDate | StartNotify
SameFH | SetFileHandleAttr | ST_FILE
SameLock | SetFileSize | ST_LINKDIR
SBM_BLOCKING | SetFileSysPort | ST_LINKFILE
SBM_NON_BLOCKING | SetIoErr | ST_PIPEFILE
ScanVars | SetMode | ST_ROOT
SearchCmdPathList | SetOwner | StrToLong
SecondsToDateStamp | SetOwnerInfo | ST_SOFTLINK
SelectErrorOutput | SetProcWindow | ST_USERDIR
SelectInput | SetProgramDir | SubtractDates
SelectOutput | SetProtection | SYS_Asynch
SendPkt | SetVar | SYS_CommandRunMode
Serialize | SetVBuf | SYS_CustomShell
SerializePort | SHARED_LOCK | SYS_Dummy
SetArgStr | SIGBREAKB_CTRL_C | SYS_Error
SetBlockingMode | SIGBREAKB_CTRL_D | SYS_ExecuteInputStream
SetCliCurrentDirName | SIGBREAKB_CTRL_E | SYS_Input
SetCliProgramName | SIGBREAKB_CTRL_F | SYS_Output
SetCliPrompt | SIGBREAKF_CTRL_C | SystemTagList
SetComment | SIGBREAKF_CTRL_D | SystemTags
SetConsolePort | SIGBREAKF_CTRL_E | SYS_UserShell
SetCurrentCmdPathList | SIGBREAKF_CTRL_F |
SetCurrentDir | SplitName |

T

TAChain | TDR_Arg5 | tFileLock
TAddressAndSize | TDR_Arg6 | TFileSysStartupMsg
TAnchorPath | TDR_Arg7 | TFileSystemData
TAnchorPathOld | TDR_Arg8 | TFileSystemVectorPort
tAssignList | TDR_Arg9 | TFileSystemVectors
TAssignNode | TDR_ArgArray | TFindTrackedAddressMsg
TCapturedExpression | TDR_CharSet | TFReadLineData
tCliProcList | TDR_Dummy | TICKS_PER_SECOND
TCommandLineInterface | TDR_EasyStruct | TimedDosRequester
TConsoleWindowData | TDR_FormatString | TInfoData
TCSource | TDR_GadgetString | TLocalVar
TDateStamp | TDR_IDCMP_Ptr | TLock
_TDateTime | TDRIMAGE_DEFAULT | TMultiAssign
TDeathMessage | TDRIMAGE_ERROR | TNotifyHookMsg
tDeviceList | TDRIMAGE_INFO | TNotifyMessage
TDeviceNode | TDRIMAGE_INSERTDISK | tNotifyRequest
tDevInfo | TDRIMAGE_QUESTION | TPathNode
TDevProc | TDR_ImageType | TProcess
tDosEnvec | TDRIMAGE_WARNING | TPseudoSegList
tDosInfo | TDR_Inactive | TrackAddressList
tDosLibrary | TDR_NonBlocking | TrackSegmentList
TDOSList | TDR_Timeout | TRDArgs
TDosPacket | TDR_TitleString | TRecordLock
TDosPacket64 | TDR_Window | tRootNode
TDosResidentSeg | tErrorString | TSearchCmdPathListMsg
TDR_Arg1 | TExAllControl | TStandardPacket
TDR_Arg10 | TExAllData | TStandardPacket64
TDR_Arg2 | TExamineData | TVolumeNode
TDR_Arg3 | TFileHandle |
TDR_Arg4 | TFileInfoBlock |

U

UnGetC | UnLockDosList | UnTrackAddress
UnLoadSeg | UnLockRecord | UnTrackSegmentList
UnLock | UnLockRecords |

V

VFPrintf VPrintf

W

WaitForChar | WFDB_WRITE | WriteProtectVolume
WaitForData | WFDF_READ | WriteProtectVolumePort
WaitPkt | WFDF_WRITE |
WFDB_READ | WriteChars |


AddBuffers

Changes the number of buffers for a filesystem

Declaration

Source position: amigados.pas line 2561

function AddBuffers(

  const Name: PChar;

  Number: LongInt

):LongBool;

Description

Add or remove cache memory to/from a filesystem. The amount of memory per cache buffer and the limit depends on the filesystem.

  • DosTrue on success (IoErr() gives the actual number of buffers).
  • DosFalse on error (IoErr() gives the error code).

Some old filesystems return the actual buffer size. See the example for a workaround for that case.

Snippet

Res1 := AddBuffers('df0:', 10);
Res2 := IoErr();
if (res1 <> DosFalse) and (res1 <> DosTrue) then
begin
  Res2 := Res1;
  Res1 := DosTrue;
end;

See also

IoErr

Return extra information from the system


AddCmdPathNode

Declaration

Source position: amigados.pas line 2650

function AddCmdPathNode(

  Pn: PPathNode;

  Lock: LongInt;

  Where: LongInt

):PPathNode;


ADDCMDPATHNODE_HEAD

Declaration

Source position: amigados.pas line 1979

const ADDCMDPATHNODE_HEAD = 0;


ADDCMDPATHNODE_TAIL

Declaration

Source position: amigados.pas line 1980

const ADDCMDPATHNODE_TAIL = 1;


AddDates

Declaration

Source position: amigados.pas line 2618

function AddDates(

  To_: PDateStamp;

  const From_: PDateStamp

):LongInt;


AddDosEntry

Add a Dos List entry to the lists

Declaration

Source position: amigados.pas line 2552

function AddDosEntry(

  DList: PDOSList

):LongBool;

Arguments

DList

Pointer to DOS list entry.

Function result

DosTrue if all went well. DosFalsefor errors; IoErr() will return additional error code.

Description

Adds a given dos list entry to the DOS list. Automatically locks the list for writing. There may be not more than one device or assign node of the same name. There are no restrictions on volume nodes except that the time stamps must differ.

See also

RemDosEntry | Removes a Dos List entry from it's list
FindDosEntry | Finds a specific Dos List entry
NextDosEntry | Get the next Dos List entry
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry
LockDosList | Locks the specified Dos Lists for use
AttemptLockDosList | Attempt to lock the Dos Lists for use


AddPart

Appends a file/dir to the end of a path

Declaration

Source position: amigados.pas line 2588

function AddPart(

  DestDirName: PChar;

  const FileName: PChar;

  Size: LongWord

):LongBool;

Arguments

FileName | The filename or directory name to add. May be a relative pathname from the current directory. (example: foo/bar). Can deal with leading '/'(s), indicating one directory up per '/', or with a ':', indicating it's relative to the root of the appropriate volume.
Size | size in bytes of the space allocated for dirname. Must not be 0.

Description

This functions adds a file, directory or other path name to a directory path. It will take into account any pre-existing separator characters (':','/'). If filename is an absolute path it will replace the current value of dirname.

See also

FilePart | Returns the last component of a path
PathPart | Returns a pointer to the end of the next-to-last component of a path.


AddSegListTail

Declaration

Source position: amigados.pas line 2641

function AddSegListTail(

  BSegList: LongInt;

  BSegNew: LongInt

):LongInt;


AddSegment

Adds a resident segment to the resident list

Declaration

Source position: amigados.pas line 2570

function AddSegment(

  const Name: PChar;

  Seg: LongInt;

  Type_: LongInt

):LongBool;

Arguments

Name | Name of the segment. This is used by FindSegment(). Will be copied.
Seg | Segment to add.
Type_ | What type of segment (initial use count). (CMD_*)

Function result

<> 0 = success, 0 = Error

Description

Adds a program segment to the system resident list. You can later use these segments to run programs.

The type field determines the type of resident program. Normal programs should have type >= 0, system segments should have type = CMD_SYSTEM.

Note that all other values of type are reserved.

See also

FindSegment | Finds a segment on the resident list
RemSegment | Removes a resident segment from the resident list
LoadSeg | Scatterload a loadable file into memory


AddSegmentTagList

Declaration

Source position: amigados.pas line 2620

function AddSegmentTagList(

  const Name: PChar;

  Type_: LongInt;

  const Tags: PTagItem

):LongInt;


AllocateCmdPathList

Declaration

Source position: amigados.pas line 2647

function AllocateCmdPathList(

  FirstLock: LongInt

):PPathNode;


AllocDosObject

Creates a dos object

Declaration

Source position: amigados.pas line 2463

function AllocDosObject(

  Type_: LongWord;

  const Tags: PTagItem

):Pointer;

Arguments

Type_ | Type of object requested
Tags | Pointer to taglist with additional information (DOS_* and ADO_*)

Function result

Pointer to the object or nil

Description

Create a dos objects of a given type, initializes it, and returns it to you. Note the DOS_STDPKT returns a pointer to the sp_Pkt of the structure.This memory has to be freed with FreeDosObject().

This function may be called by a task for all types and tags DOS_* and ADO_*. Any future types or tags will be documented as to whether a task may use them.

See also

FreeDosObject

Frees an object allocated by AllocDosObject()


AllocDosObjectTagList

Declaration

Source position: amigados.pas line 2464

function AllocDosObjectTagList(

  Type_: LongWord;

  const Tags: PTagItem

):Pointer;


AllocDosObjectTags

Variable args version for AllocDosObject for direct tag use.

Declaration

Source position: amigados.pas line 2735

function AllocDosObjectTags(

  type_: LongWord;

  const argv: array of PtrUInt

):POINTER;


AllocSegList

Declaration

Source position: amigados.pas line 2638

function AllocSegList(

  const Entry: Pointer;

  const Data: Pointer;

  DataLen: LongWord;

  IdentKey: LongWord

):LongInt;


AssignAdd

Adds a lock to an assign for multi-directory assigns

Declaration

Source position: amigados.pas line 2544

function AssignAdd(

  const Name: PChar;

  Lock: LongInt

):LongBool;

Arguments

Name | Name of the assign (without trailing ':').
Lock | Lock associated with the assigned name

Function result

If False the adding failed, lock is not unlocked. IoErr() gives more information.

Description

Adds a lock to an assign, making or adding to a multi-directory assign. Note that this only will succeed on an assign created with AssignLock(), or an assign created with AssignLate() which has been resolved (converted into a AssignLock()-assign).

NOTE: you should not use the lock in any way after making this call successfully. It becomes the part of the assign, and will be unlocked by the system when the assign is removed. If you need to keep the lock, pass a lock from DupLock() to AssignLock().

See also

Lock | Lock a directory or file
AssignLock | Creates an assignment to a locked object
AssignPath | Creates an assignment to a specified path
AssignLate | Creates an assignment to a specified path later
DupLock | Duplicate a lock
RemAssignList | Remove an entry from a multi-dir assign


AssignAddToList

Declaration

Source position: amigados.pas line 2673

function AssignAddToList(

  const Name: PChar;

  Lock: LongInt;

  EndPos: LongInt

):LongInt;


AssignLate

Creates an assignment to a specified path later

Declaration

Source position: amigados.pas line 2542

function AssignLate(

  const Name: PChar;

  const Path: PChar

):LongBool;

Arguments

Name | Name of device to be assigned (without trailing ':')
Path | Name of late assignment to be resolved on the first reference.

Function result

IoErr() gives more information of fail

Description

Create an assign for the given name, which will be resolved upon the first reference to it. If this succeeds (i.e. the path exists and can be locked) it will be turned into an AssignLock() type assign. This way you can create assigns to unmounted volumes which will only be requested when accessed.

See also

Lock | Lock a directory or file
AssignAdd | Adds a lock to an assign for multi-directory assigns
AssignPath | Creates an assignment to a specified path
AssignLock | Creates an assignment to a locked object


AssignLock

Creates an assignment to a locked object

Declaration

Source position: amigados.pas line 2541

function AssignLock(

  const Name: PChar;

  Lock: LongInt

):LongBool;

Arguments

Name | Name of device to assign lock to (without trailing ':')
Lock | Lock associated with the assigned name

Function result

On failure, the lock is not unlocked. IoErr() gives more information.

Description

Sets up an assign of a name to a given lock. Passing nil for a lock cancels any outstanding assign to that name. If an assign entry of that name is already on the list, this routine replaces that entry. If an entry is on the list that conflicts with the new assign, then a failure code is returned.

NOTE: you should not use the lock in any way after making this call successfully. It becomes the part of the assign, and will be unlocked by the system when the assign is removed. If you need to keep the lock, pass a lock from DupLock() to AssignLock().

See also

Lock | Lock a directory or file
AssignAdd | Adds a lock to an assign for multi-directory assigns
AssignPath | Creates an assignment to a specified path
AssignLate | Creates an assignment to a specified path later
DupLock | Duplicate a lock
RemAssignList | Remove an entry from a multi-dir assign


AssignPath

Creates an assignment to a specified path

Declaration

Source position: amigados.pas line 2543

function AssignPath(

  const Name: PChar;

  const Path: PChar

):LongBool;

Arguments

Name | Name of device to be assigned (without trailing ':')
Path | Name of late assignment to be resolved at each reference

Function result

IoErr() gives more information of fail

Description

Sets up a assignment that is expanded upon EACH reference to the name. This is implemented through a new device list type. The path (a string) would be attached to the node. When the name is referenced (DosOpen("FOO:xyzzy"...), the string will be used to determine where to do the open. No permanent lock will be part of it. For example, you could AssignPath() c2: to df2:c, and references to c2: would go to df2:c, even if you change disks.

The other major advantage is assigning things to unmounted volumes, which will be requested upon access (useful in startup sequences).


AttemptLockDosList

Attempt to lock the Dos Lists for use

Declaration

Source position: amigados.pas line 2550

function AttemptLockDosList(

  Flags: LongWord

):PDOSList;

Arguments

Flags

Flags stating which types of nodes you want to lock. (LDF_*)

Function result

Pointer to the beginning of the list or nil. Not a valid node its a pseudo element!

Description

Tries to get a lock on some of the dos lists. If all went well a handle is returned that can be used for FindDosEntry(). Don't try to busy wait until the lock can be granted - use LockDosList() instead.


BADDR

Convert a BPTR to a Pointer

Declaration

Source position: amigados.pas line 2731

function BADDR(

  bval: LongInt

):POINTER;


CalculateSegmentChecksum

Declaration

Source position: amigados.pas line 2637

function CalculateSegmentChecksum(

  Segment: LongInt

):LongWord;


CapturePattern

Declaration

Source position: amigados.pas line 2622

function CapturePattern(

  const Pat: PChar;

  const Str: PChar;

  CaseSen: LongInt;

  var Cap: PCapturedExpression

):LongInt;


ChangeFilePosition

Declaration

Source position: amigados.pas line 2682

function ChangeFilePosition(

  Fh: LongInt;

  Position: Int64;

  Offset: LongInt

):LongInt;


ChangeFileSize

Declaration

Source position: amigados.pas line 2683

function ChangeFileSize(

  Fh: LongInt;

  Pos: Int64;

  Mode: LongInt

):LongInt;


ChangeMode

Change the current mode of a lock or filehandle

Declaration

Source position: amigados.pas line 2510

function ChangeMode(

  Type_: LongInt;

  Fh: LongInt;

  NewMode: LongInt

):LongBool;

Arguments

Type_ | Either CHANGE_FH or CHANGE_LOCK
NewMode | The new mode you want

Description

This allows you to attempt to change the mode in use by a lock or filehandle. For example, you could attempt to turn a shared lock into an exclusive lock. The handler may well reject this request. Warning: if you use the wrong type for the object, the system may crash.

See also

Lock | Lock a directory or file
DosOpen | Open a file for input or output


CheckSignal

Checks for break signals

Declaration

Source position: amigados.pas line 2573

function CheckSignal(

  Mask: LongWord

):LongWord;

Arguments

Mask

The signal mask to check. ()SIGBREAKF_*)

Function result

The mask of all signals which were set. (SIGBREAKF_*)

Description

Checks the current task to see if any of the signals specified in the mask have been set. The mask of all signals which were set is returned. The signals specified in the mask will be cleared.


Cli

Returns a pointer to the CLI structure of the process

Declaration

Source position: amigados.pas line 2517

function Cli: PCommandLineInterface;

Function result

Pointer to the CLI structure, or nil

Description

Returns a pointer to the CLI structure of the current process, or nil if the process has no CLI structure.

Note: There is no CLI structure if started from WB, but also in shell it can be that it has no CLI structure, for example if it is started by an other program which didn't set the structure (famous example "make")


CliInitNewcli

Set up a process to be a shell using a startup packet.

Declaration

Source position: amigados.pas line 2596

function CliInitNewcli(

  Dp: PDosPacket

):LongInt;

Arguments

Dp

startup arguments that were passed to the shell If NULL, defaults will be used

Function result

Flags or a Pointer

Description

This function initializes a process and CLI structure for a new shell, from parameters in an initial packet passed by the system (NewShell or NewCLI, etc). The format of the data in the packet is purposely not defined. The setup includes all the normal fields in the structures that are required for proper operation (current directory, paths, input streams, etc).

It returns a set of flags containing information about what type of shell invocation this is.

Definitions for the values of fn:

Bit 31
Set to indicate flags are valid
Bit 3
Set to indicate asynch system call
Bit 2
Set if this is a SystemTagList() call
Bit 1
Set if user provided input stream
Bit 0
Set if RUN provided output stream

If Bit 31 is 0, then you must check IoErr() to determine if an error occurred. If IoErr() returns a pointer to your process, there has been an error, and you should clean up and exit. The packet will have already been returned by CliInitNewcli(). If it isn't a pointer to your process and Bit 31 is 0, reply the packet immediately. (Note: this is different from what you do for CliInitRun().)

This function is very similar to CliInitRun().

See also

CliInitRun | Set up a process to be a shell from initial packet
ReplyPkt | Replies a packet to the person who sent it to you
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
IoErr | Return extra information from the system


CliInitRun

Set up a process to be a shell from initial packet

Declaration

Source position: amigados.pas line 2597

function CliInitRun(

  Dp: PDosPacket

):LongInt;

Arguments

Dp

startup arguments specified as a packet

Function result

Flags or a Pointer

Description

This function initializes a process and CLI structure for a new shell, from parameters in an initial packet passed by the system (Run, SystemTagList(), Execute())). The format of the data in the packet is purposely not defined. The setup includes all the normal fields in the structures that are required for proper operation (current directory, paths, input streams, etc).

It returns a set of flags containing information about what type of shell invocation this is.

Definitions for the values of fn:

Bit 31
Set to indicate flags are valid
Bit 3
Set to indicate asynch system call
Bit 2
Set if this is a SystemTagList() call
Bit 1
Set if user provided input stream
Bit 0
Set if RUN provided output stream

If Bit 31 is 0, then you must check IoErr() to determine if an error occurred. If IoErr() returns a pointer to your process, there has been an error, and you should clean up and exit. The packet will have already been returned by CliInitNewcli(). If it isn't a pointer to your process and Bit 31 is 0, you should wait before replying the packet until after you've loaded the first command (or when you exit). This helps avoid disk "gronking" with the Run command. (Note: this is different from what you do for CliInitNewcli()).)

If Bit 31 is 1, then if Bit 3 is one, ReplyPkt() the packet immediately (Asynch SystemTagList()), otherwise wait until your shell exits (Sync SystemTagList(), Execute()). (Note: this is different from what you do for CliInitNewcli().)

This function is very similar to CliInitNewcli().

See also

CliInitNewcli | Set up a process to be a shell using a startup packet.
ReplyPkt | Replies a packet to the person who sent it to you
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
IoErr | Return extra information from the system
SystemTagList | Have a shell execute a command line
Execute | Execute a CLI command


CompareDates

Compares two datestamps

Declaration

Source position: amigados.pas line 2562

function CompareDates(

  const Date1: PDateStamp;

  const Date2: PDateStamp

):LongInt;

Arguments

Date1 | DateStamps to compare
Date2 | DateStamps to compare

Function result

<0, 0, or >0 based on comparison of two date stamps

Description

Compares two times for relative magnitide. <0 is returned if date1 is later than date2, 0 if they are equal, or >0 if date2 is later than date1. NOTE: this is not the same ordering as strcmp!

See also

DateStamp | Fills the structure with the current time. Time is measured from 1. Jan. 1978.
DOSStrToDate |


CopyStringBSTRToC

Declaration

Source position: amigados.pas line 2679

function CopyStringBSTRToC(

  BSrc: LongInt;

  Dst: PChar;

  Size: LongWord

):LongWord;


CopyStringCToBSTR

Declaration

Source position: amigados.pas line 2680

function CopyStringCToBSTR(

  const Src: PChar;

  BDest: LongInt;

  Size: LongWord

):LongWord;


CreateDir

Declaration

Source position: amigados.pas line 2444

function CreateDir(

  const Name: PChar

):LongInt;


CreateDirTree

Declaration

Source position: amigados.pas line 2659

function CreateDirTree(

  const Name: PChar

):LongInt;


CreateNewProc

Create a new process from taglist

Declaration

Source position: amigados.pas line 2518

function CreateNewProc(

  const Tags: PTagItem

):PProcess;

Arguments

Tags

Information on the new process as tags (NP_*).

Description

You must specify one of NP_Seglist or NP_Entry. NP_Seglist takes a seglist (as returned by LoadSeg()). NP_Entry takes a function pointer for the routine to call.

There are many options, as you can see by examining dos/dostags.h. The defaults are for a non-CLI process, with copies of your CurrentDir, HomeDir (used for PROGDIR:), priority, consoletask, windowptr, and variables. The input and output filehandles default to opens of NIL:, stack to 4000, and others as shown in dostags.h. This is a fairly reasonable default setting for creating threads, though you may wish to modify it (for example, to give a descriptive name to the process.)

CreateNewProc() is callable from a task, though any actions that require doing Dos I/O (DupLock() of currentdir, for example) will not occur.

NOTE: if you call CreateNewProc() with both NP_Arguments, you must not specify an NP_Input of nil. When NP_Arguments is specified, it needs to modify the input filehandle to make ReadArgs() work properly.


CreateNewProcTagList

Declaration

Source position: amigados.pas line 2519

function CreateNewProcTagList(

  const Tags: PTagItem

):PProcess;


CreateNewProcTags

Variable args version for CreateNewProc for direct tag use.

Declaration

Source position: amigados.pas line 2736

function CreateNewProcTags(

  const argv: array of PtrUInt

):PProcess;


CreateProc

Create a new process

Declaration

Source position: amigados.pas line 2448

function CreateProc(

  const Name: PChar;

  Pri: LongInt;

  SegList: LongInt;

  StackSize: LongInt

):PMsgPort;

Arguments

Name | Name of Process
Pri | Priority for the process
SegList | Pointer to a seglist to run
StackSize | Initial Stacksize for the process

Function result

Pointer to the new Process messageport or nil

Description

CreateProc() creates a new process of name 'name'. Processes are a superset of exec tasks.

A seglist, as returned by LoadSeg(), is passed as 'seglist'. This represents a section of code which is to be run as a new process. The code is entered at the first hunk in the segment list, which should contain suitable initialization code or a jump to such. A process control structure is allocated from memory and initialized.

The size of the root stack upon activation is passed as 'stackSize'. 'pri' specifies the required priority of the new process. The result will be the process msgport address of the new process, or nil if the routine failed. The argument 'name' specifies the new process name. A nil return code indicates error.

The seglist passed to CreateProc() is not freed when it exits; it is up to the parent process to free it, or for the code to unload itself.

See also

CreateNewProc | Create a new process from taglist
LoadSeg | Scatterload a loadable file into memory
UnLoadSeg | Unload a seglist previously loaded by LoadSeg()


CurrentDir

Make a directory lock the current directory

Declaration

Source position: amigados.pas line 2445

function CurrentDir(

  Lock: LongInt

):LongInt;

Arguments

Lock

Lock to directory should become new current directory

Function result

Pointer to a lock

Description

CurrentDir() causes a directory associated with a lock to be made the current directory. The old current directory lock is returned.

A value of nil is a valid result here, this nil lock represents the root of file system that you booted from.

Any call that has to DosOpen() or Lock() files (etc.) requires that the current directory be a valid lock or nil.

See also

Lock | Lock a directory or file
UnLock | Unlock a directory or file
DosOpen | Open a file for input or output
DupLock | Duplicate a lock


DateStamp

Fills the structure with the current time. Time is measured from 1. Jan. 1978.

Declaration

Source position: amigados.pas line 2457

function DateStamp(

  Date: PDateStamp

):PDateStamp;

Arguments

Date

Pointer to recieve the timing information.

Function result

Returns the supplied pointer

Description

DateStamp() takes a structure of three longwords that is set to the current time. The first element in the vector is a count of the number of days. The second element is the number of minutes elapsed in the day. The third is the number of ticks elapsed in the current minute. A tick happens 50 times a second. DateStamp() ensures that the day and minute are consistent. All three elements are zero if the date is unset.

See also

DOSStrToDate |
CompareDates | Compares two datestamps


DateStampToSeconds

Declaration

Source position: amigados.pas line 2616

function DateStampToSeconds(

  const Ds: PDateStamp

):LongWord;


DeleteVar

Deletes a local or environment variable

Declaration

Source position: amigados.pas line 2593

function DeleteVar(

  const Name: PChar;

  Flags: LongWord

):LongBool;

Arguments

Name | Pointer to an variable name. Note variable names follow filesystem syntax and semantics.
Flags | combination of type of var to delete (low 8 bits), and flags to control the behavior of this routine. Currently defined flags include: GVF_LOCAL_ONLY - delete a local (to your process) variable. GVF_GLOBAL_ONLY - delete a global environment variable. The default is to delete a local variable if found, otherwise a global environment variable if found (only for LV_VAR).

Function result

If not 0, the variable was sucessfully deleted, 0 indicates failure.

Description

Deletes a local or environment variable.

The default is to delete a local variable if one was found, or to delete a global environmental variable otherwise.

A global environmental variable will only be deleted for the type LV_VAR.

See also

GetVar | Returns the value of a local or global variable
SetVar | Sets a local or environment variable
FindVar | Finds a local variable
DOSDeleteFile | Delete a file or directory


DeviceProc

Return the process MsgPort of specific I/O handler

Declaration

Source position: amigados.pas line 2454

function DeviceProc(

  const Name: PChar

):PMsgPort;

Arguments

Name

The name of the DOS device, INCLUDING the ':'

Function result

A message port or nil

Description

DeviceProc() is an obsolete function that returns the MsgPort responsible for a DOS device.

DeviceProc() will fail if you ask for the MsgPort of a device created with AssignPath() as there is no process to return. If the device requested is an assign, the IoErr() will contain the Lock to the directory (the function will return the device on which the lock is set).

You should really use GetDeviceProc(), as that function returns a more useful structure (TDevProc), that will persist until FreeDeviceProc() is called on it.

See also

GetDeviceProc | Finds a handler to send a message to
FreeDeviceProc | Releases port returned by GetDeviceProc()
DupLock | Duplicate a lock
UnLock | Unlock a directory or file
Examine | Examine a directory or file associated with a lock


DevNameFromFH

Declaration

Source position: amigados.pas line 2672

function DevNameFromFH(

  Scb: LongInt;

  Buffer: PChar;

  BufLen: LongInt;

  Mode: LongInt

):LongInt;


DevNameFromLock

Declaration

Source position: amigados.pas line 2642

function DevNameFromLock(

  Lock: LongInt;

  Buffer: PChar;

  BufLen: LongInt;

  Mode: LongInt

):LongInt;


DevNameFromPort

Declaration

Source position: amigados.pas line 2715

function DevNameFromPort(

  Port: PMsgPort;

  Buffer: PChar;

  BufLen: LongInt;

  AddColon: LongInt

):LongInt;


DismountDevice

Declaration

Source position: amigados.pas line 2670

function DismountDevice(

  const Name: PChar;

  Flags: LongWord;

  Reserved: Pointer

):LongInt;


DoPkt

Send a dos packet and wait for reply

Declaration

Source position: amigados.pas line 2467

function DoPkt(

  Port: PMsgPort;

  Action: LongInt;

  Arg1: LongInt;

  Arg2: LongInt;

  Arg3: LongInt;

  Arg4: LongInt;

  Arg5: LongInt

):LongInt;

Description

Send a dos packet to a filesystem and wait for the action to complete. Callable from a task. This function should NOT be used; it's only here for AmigaOS compatibility.

See also

AllocDosObject | Creates a dos object
FreeDosObject | Frees an object allocated by AllocDosObject()
SendPkt | Sends a packet to a handler
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
CreateNewProc | Create a new process from taglist


DoPkt0

Declaration

Source position: amigados.pas line 2468

function DoPkt0(

  Port: PMsgPort;

  Action: LongInt

):LongInt;


DoPkt1

Declaration

Source position: amigados.pas line 2469

function DoPkt1(

  Port: PMsgPort;

  Action: LongInt;

  Arg1: LongInt

):LongInt;


DoPkt2

Declaration

Source position: amigados.pas line 2470

function DoPkt2(

  Port: PMsgPort;

  Action: LongInt;

  Arg1: LongInt;

  Arg2: LongInt

):LongInt;


DoPkt3

Declaration

Source position: amigados.pas line 2471

function DoPkt3(

  Port: PMsgPort;

  Action: LongInt;

  Arg1: LongInt;

  Arg2: LongInt;

  Arg3: LongInt

):LongInt;


DoPkt4

Declaration

Source position: amigados.pas line 2472

function DoPkt4(

  Port: PMsgPort;

  Action: LongInt;

  Arg1: LongInt;

  Arg2: LongInt;

  Arg3: LongInt;

  Arg4: LongInt

):LongInt;


DosClone

Declaration

Source position: amigados.pas line 2427

function DosClone: PInterface;


DOSClose

Declaration

Source position: amigados.pas line 2429

procedure DOSClose(

  File_: LongInt

);


DosControl

Declaration

Source position: amigados.pas line 2657

function DosControl(

  const Tags: PTagItem

):LongInt;


DosDateToStr

Declaration

Source position: amigados.pas line 2563

function DosDateToStr(

  DateTime: _PDateTime

):LongBool;


DosDelay

Delay a process for a specified time

Declaration

Source position: amigados.pas line 2458

procedure DosDelay(

  TimeOut: LongInt

);

Arguments

TimeOut

The minimum time to wait in ticks (1/50 seconds)

Description

The argument ticks specifies how many ticks (50 per second) to wait before returning control.


DosDelete

Declaration

Source position: amigados.pas line 2436

function DosDelete(

  const Name: PChar

):LongBool; overload;


DosDeleteFile

Delete a file or directory

Declaration

Source position: amigados.pas line 2435

function DosDeleteFile(

  const Name: PChar

):LongBool; overload;

Arguments

Name

Name of file or directory to delete.

Function result

If failed IoErr() gives detailed error message.

Description

This attempts to delete the file or directory specified by name. An error is returned if the deletion fails. Note that all the files within a directory must be deleted before the directory itself can be deleted.


DosExpunge

Declaration

Source position: amigados.pas line 2426

procedure DosExpunge;


DosFlush

Flushes buffers for a buffered filehandle

Declaration

Source position: amigados.pas line 2494

function DosFlush(

  Fh: LongInt

):LongBool;

Function result

0 on error. IoErr() gives additional information in that case.

Description

Flushes any pending writes on the file. If the file was used for input and there is still some data to read it tries to seek back to the expected position.

On Amiga calling DosFlush() from different tasks on the same file handle is serialised. This means that most of the time it is possible to do I/O in one task to a file handle where DosFlush() is being called in another task on that file handle. No multi-thread safety is guaranteed though and data may be lost if I/O is done in parallel from different tasks on the same file handle.


DosInput

Identify the program's initial input file handle

Declaration

Source position: amigados.pas line 2432

function DosInput: LongInt;

Function result

Nil if no current input stream defined.

Description

Input() is used to identify the initial input stream allocated when the program was initiated. Never close the filehandle returned by Input!

See also

DosOutput | Identify the programs' initial output file handle
SelectInput | Select a filehandle as the default input channel


DosObtain

Declaration

Source position: amigados.pas line 2424

function DosObtain: LongWord;


DosOpen

Open a file for input or output

Declaration

Source position: amigados.pas line 2428

function DosOpen(

  const Name: PChar;

  AccessMode: LongInt

):LongInt;

Arguments

Name | Name of file to opem
AccessMode | Access mode for file (MODE_*)

Description

The named file is opened and a file handle returned. If the accessMode is MODE_OLDFILE, an existing file is opened for reading or writing. If the value is MODE_NEWFILE, a new file is created for writing. MODE_READWRITE opens a file with an shared lock, but creates it if it didn't exist.

The name can be a filename (optionally prefaced by a device name), a simple device such as 'NIL:', a window specification such as 'CON:' or 'RAW:' followed by window parameters, or '*', representing the current window.

If the file cannot be opened for any reason, the value returned will be zero, and a secondary error code will be available by calling the routine IoErr().

See also

DosClose |
ChangeMode | Change the current mode of a lock or filehandle
NameFromFH | Get the name of an open filehandle
ParentOfFH | Returns a lock on the parent directory of a file
ExamineFH | Gets information on an open file


DosOutput

Identify the programs' initial output file handle

Declaration

Source position: amigados.pas line 2433

function DosOutput: LongInt;

Function result

Nil if no current output stream defined.

Description

Output() is used to identify the initial output stream allocated when the program was initiated. Never close the filehandle returned by Output().

See also

DosInput

Identify the program's initial input file handle


DosRead

Read bytes of data from a file

Declaration

Source position: amigados.pas line 2430

function DosRead(

  File_: LongInt;

  Buffer: Pointer;

  Length: LongInt

):LongInt;

Arguments

File_ | File handle
Buffer | Pointer to the buffer for the data
Length | number of bytes to read. The filesystem is advised to try to fulfill the request as good as possible.

Description

Data can be copied using a combination of DOSRead() and DOSWrite(). DosRead() reads bytes of information from an opened file (represented here by the argument file) into the buffer given. The argument length is the length of the buffer given.

The value returned is the length of the information actually read. So, when result is greater than 0, the value of result is the the number of characters read. Usually DosRead() will try to fill up your buffer before returning. A value of 0 means that end-of-file has been reached. Errors are indicated by a value of -1.

See also

DosOpen | Open a file for input or output
DosClose |
DosWrite | Write bytes of data to a file
DosSeek | Set the current position for reading and writing


DosRelease

Declaration

Source position: amigados.pas line 2425

function DosRelease: LongWord;


DosRename

Rename a directory or file

Declaration

Source position: amigados.pas line 2437

function DosRename(

  const OldName: PChar;

  const NewName: PChar

):LongBool;

Arguments

OldName | File to rename.
NewName | New name for the file.

Description

Rename() attempts to rename the file or directory specified as oldName with the name newName. If the file or directory newName exists, Rename() fails and returns an error. Both oldName and the newName can contain a directory specification. In this case, the file will be moved from one directory to another.

Note: it is impossible to Rename() a file from one volume to another.


DosSeek

Set the current position for reading and writing

Declaration

Source position: amigados.pas line 2434

function DosSeek(

  File_: LongInt;

  Position: LongInt;

  Offset: LongInt

):LongInt;

Arguments

File_ | Pointer to file handle.
Position | Value to seek (can be also negative for OFFSET_CURRENT or OFFSET_END)

Function result

Returns the position before the seek.

Description

DosSeek() sets the read/write cursor for the file file to the position 'position'. This position is used by both DosRead() and DosWrite() as a place to start reading or writing. The result is the current absolute position in the file, or -1 if an error occurs, in which case IoErr() can be used to find more information. mode can be OFFSET_BEGINNING (Start seek from file start), OFFSET_CURRENT (start seek from current position) or OFFSET_END (start seek from end of file). It is used to specify the relative start position. For example, 20 from current is a position 20 bytes forward from current, -20 is 20 bytes back from current.

So that to find out where you are, seek 0 from current. The end of the file is a Seek() positioned by 0 from end. You cannot Seek() beyond the end of a file.

See also

DosRead | Read bytes of data from a file
DosWrite | Write bytes of data to a file
SetFileSize | Sets the size of a file


DosStrToDate

Declaration

Source position: amigados.pas line 2564

function DosStrToDate(

  DateTime: _PDateTime

):LongBool;


DosSystem

Declaration

Source position: amigados.pas line 2539

function DosSystem(

  const Command: PChar;

  const Tags: PTagItem

):LongInt;


DosWrite

Write bytes of data to a file

Declaration

Source position: amigados.pas line 2431

function DosWrite(

  File_: LongInt;

  Buffer: Pointer;

  Length: LongInt

):LongInt;

Arguments

File_ | File handle
Buffer | Pointer to a buffer to write to file
Length | Number of bytes to write. The filesystem is advised to try to fulfill the request as good as possible.

Function result

Number of bytes written, -1 for error.

Description

DosWrite() writes bytes of data to the opened file file. length indicates the length of data to be transferred; buffer is a pointer to the buffer. The value returned is the length of information actually written. So, when length is greater than zero, the result is the number of characters written. Errors are indicated by a value of -1.

See also

DosRead | Read bytes of data from a file
DosSeek | Set the current position for reading and writing
DosOpen | Open a file for input or output
DosClose |


DupFileHandle

Declaration

Source position: amigados.pas line 2671

function DupFileHandle(

  Scb: LongInt

):LongInt;


DupLock

Duplicate a lock

Declaration

Source position: amigados.pas line 2440

function DupLock(

  Lock: LongInt

):LongInt;

Arguments

Lock

Lock to copy

Function result

Result 0 indicates an error.

Description

DupLock() is passed a shared filing system lock. This is the only way to obtain a duplicate of a lock... simply copying is not allowed.

Another lock to the same object is then returned. It is not possible to create a copy of a exclusive lock.

See also

Lock | Lock a directory or file
UnLock | Unlock a directory or file
DupLockFromFH | Gets a lock on an open file
ParentOfFH | Returns a lock on the parent directory of a file


DupLockFromFH

Gets a lock on an open file

Declaration

Source position: amigados.pas line 2497

function DupLockFromFH(

  Fh: LongInt

):LongInt;

Function result

Obtained lock or 0 for failure

Description

Obtain a lock on the object associated with fh. Only works if the file was opened using a non-exclusive mode. Other restrictions may be placed on success by the filesystem.

See also

DupLock | Duplicate a lock
Lock | Lock a directory or file
UnLock | Unlock a directory or file


EndNotify

Ends a notification request

Declaration

Source position: amigados.pas line 2590

procedure EndNotify(

  Notify: PNotifyRequest

);

Arguments

Notify

a structure passed to StartNotify()

Description

Removes a notification request. Safe to call even if StartNotify() failed. For NRF_SEND_MESSAGE, it searches your port for any messages about the object in question and removes and replies them before returning.

See also

StartNotify

Starts notification on a file or directory


ErrorOutput

Declaration

Source position: amigados.pas line 2631

function ErrorOutput: LongInt;


ErrorReport

Displays a Retry/Cancel requester for an error

Declaration

Source position: amigados.pas line 2515

function ErrorReport(

  Code: LongInt;

  Type_: LongInt;

  Arg1: LongWord;

  Device: PMsgPort

):LongBool;

Arguments

Code | Error code to put a requester up for.
Type_ | Request type
Arg1 | Variable parameter (see type)
Device | Optional handler task address (obsolete!)

Function result

Cancel/Retry indicator (0 means Retry)

Description

Based on the request type, this routine formats the appropriate requester to be displayed. If the code is not understood, it returns DOSTRUE immediately. Returns DOSTRUE if the user selects CANCEL or if the attempt to put up the requester fails, or if the process pr_WindowPtr is -1. Returns DOSFALSE if the user selects Retry. The routine will retry on DISKINSERTED for appropriate error codes. These return values are the opposite of what AutoRequest returns.

Note: this routine sets IoErr() to code before returning.

Error codes to put a requester up for. Current valid error codes are: ERROR_DISK_NOT_VALIDATED, ERROR_DISK_WRITE_PROTECTED, ERROR_DISK_FULL, ERROR_DEVICE_NOT_MOUNTED, ERROR_NOT_A_DOS_DISK, ERROR_NO_DISK, ABORT_DISK_ERROR, ABORT_BUSY

Valid Request types:

REPORT_LOCK
arg1 is a lock.
REPORT_VOLUME
arg1 is a volumenode.
REPORT_INSERT
arg1 is the string for the volumename

See also

Fault | Returns the text associated with a DOS error code
IoErr | Return extra information from the system


ExAll

Examine an entire directory

Declaration

Source position: amigados.pas line 2507

function ExAll(

  Lock: LongInt;

  Buffer: PExAllData;

  Size: LongInt;

  Data: LongInt;

  Control: PExAllControl

):LongBool;

Arguments

Lock | Lock on the directory to be examined
Buffer | Buffer for the data that is returned (must be aligned) which is filled with (partial) TExAllData structures
Size | Size of buffer
Data | Type of the data to be returned
Control | A control structure allocated by AllocDosObject()

Function result

An indicator of if ExAll() is done. If False is returned, either ExAll() has completed in which case IoErr() is ERROR_NO_MORE_ENTRIES or an error occurred. If a True is returned ExAll() must be called again until it returns False.

Description

Lock must be on a directory. Size is the size of the buffer supplied. The buffer will be filled with (partial) ExAllData structures, as specified by the type field.

ed_Type is a value from those shown below that determines which information is to be stored in the buffer. Each higher value adds a new thing to the list as described in the table below:

ED_NAME
FileName
ED_TYPE
Type
ED_SIZE
Size in bytes
ED_PROTECTION
Protection bits
ED_DATE
3 longwords of date
ED_COMMENT
Comment (will be nil if no comment)
ED_OWNER
Owner user-id and Group-id

Thus, ED_OWNER gives only filenames, and ED_OWNER gives everything.

The ed_Next entry gives a pointer to the next entry in the buffer. The last entry will have nil in ed_Next.

This is an incremental list meaning that if you specify ED_OWNER you will get all attributes!

Filesystems that support ExAll() must support at least up to ED_COMMENT. If a filesystem doesn't support a particular type, ERROR_BAD_NUMBER must be returned.

ed_Next
Pointer to the next entry in the buffer. The last entry has a nil value for ed_Next.
The control structure have the following fields.
eac_Entries
the number of entries in the buffer after a call to ExAll(). Make sure that your code handles the case when eac_Entries is 0 and ExAll() returns True.
eac_LastKey
Must be initialized to 0 before calling ExAll() for the first time.
eac_MatchString
If nil then information on all files will be returned. If non-nil it's interpreted as a pointer to a string used for pattern matching which files to return information on. This string must have been parsed by ParsePatternNoCase()!
ac_MatchFunc
to a hook that will be called to decide if an entry should be included in the buffer. If nil, no matching function will be called. The hook is called as follows

See also

ExAllEnd | Stop an ExAll()
AllocDosObject | Creates a dos object


ExAllEnd

Stop an ExAll()

Declaration

Source position: amigados.pas line 2607

procedure ExAllEnd(

  Lock: LongInt;

  Buffer: PExAllData;

  Size: LongInt;

  data: LongInt;

  Control: PExAllControl

);

Arguments

Lock | Lock on directory to be examined.
Buffer | Buffer for data returned (must be at least word-aligned, preferably long-word aligned).
Size | Size in bytes of buffer.
data | Type of data to be returned.
Control | Control data structure (see notes above). MUST have been allocated by AllocDosObject()!

Description

Stops an ExAll() on a directory before it hits ERROR_NO_MORE_ENTRIES. The full set of arguments that had been passed to ExAll() must be passed to ExAllEnd(), so it can handle filesystems that can't abort an ExAll() directly.

See also

ExAll | Examine an entire directory
AllocDosObject | Creates a dos object


Examine

Examine a directory or file associated with a lock

Declaration

Source position: amigados.pas line 2441

function Examine(

  Lock: LongInt;

  FileInfoBlock: PFileInfoBlock

):LongBool;

Arguments

Lock | Pointer to a Lock
FileInfoBlock | allocated File info Block

Description

Examine() fills in information in the TFileInfoBlock concerning the file or directory associated with the lock. This information includes the name, size, creation date and whether it is a file or directory. FileInfoBlock must be longword aligned. Examine() gives a return code of False if it fails.

You may make a local copy of the TFileInfoBlock, as long as it is never passed to ExNext().

So, follow these steps to examine a directory:

  1. Pass a Lock and a FileInfoBlock to Examine(). The lock must be on the directory you wish to examine.
  2. Pass ExNext() the same lock and TFileInfoBlock.
  3. Do something with the information returned in the TFileInfoBlock. Note that the fib_DirEntryType field is positive for directories, negative for files.
  4. Keep calling ExNext() until it returns False. Check IoErr() to ensure that the reason for failure was ERROR_NO_MORE_ENTRIES.

See also

Lock | Lock a directory or file
UnLock | Unlock a directory or file
ExNext | Examine the next entry in a directory
ExamineFH | Gets information on an open file
ExAll | Examine an entire directory

Example

program ExamineTest;
uses
  AmigaDos;
procedure CheckDir(ALock: BPTR);
var
  FIB: PFileInfoBlock;
begin
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) then
  begin
    if Examine(ALock, FIB) <> 0 then
    begin
      repeat
        writeln(FIB^.fib_FileName);
      until ExNext(ALock, FIB) = 0;
    end;
    if IOErr() = ERROR_NO_MORE_ENTRIES then
      writeln('nothing more found')
    else
      writeln('Something went wrong ', IOErr);
    FreeDosObject(DOS_FIB, FIB);
  end;
end;
var
  RAMLock: BPTR;
begin
  RAMLock := Lock('RAM:', SHARED_LOCK);
  CheckDir(RAMLock);
  unlock(RAMLock);
end.


EXAMINE_BIT

Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers

Declaration

Source position: amigados.pas line 789

const EXAMINE_BIT = 2;


ExamineDir

Declaration

Source position: amigados.pas line 2698

function ExamineDir(

  Context: Pointer

):PExamineData;


ExamineFH

Gets information on an open file

Declaration

Source position: amigados.pas line 2500

function ExamineFH(

  Fh: LongInt;

  Fib: PFileInfoBlock

):LongBool;

Arguments

Fh | Filehandle you wish to examine
Fib | FileInfoBlock, must be longword aligned.

Description

Examines a filehandle and returns information about the file in the FileInfoBlock. There are no guarantees as to whether the fib_Size field will reflect any changes made to the file size it was opened, though filesystems should attempt to provide up-to-date information for it.

Example

program ExamineFHTest;
uses
  AmigaDOS;
var
  FH: BPTR;
  FIB: PFileInfoBlock;
begin
  FH := DOSOpen('c:dir', MODE_OLDFILE);
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) and (FH <> 0) then
  begin
    if Boolean(ExamineFH(FH, FIB)) then
      writeln('Size: ',FIB^.fib_size);
  end;
  if Assigned(FIB) then FreeDosObject(DOS_FIB, FIB);
  if FH <> 0 then DOSClose(FH);
end.


ExamineObject

Declaration

Source position: amigados.pas line 2696

function ExamineObject(

  const CTags: PTagItem

):PExamineData;


Execute

Execute a CLI command

Declaration

Source position: amigados.pas line 2462

function Execute(

  const String_: PChar;

  File_: LongInt;

  File2: LongInt

):LongBool;

Arguments

String_

commandString

Function result

Boolean indicating whether Execute was successful in finding and starting the specified program. Note this is not the return code of the command(s).

Description

This function attempts to execute the string commandString as a Shell command and arguments. The string can contain any valid input that you could type directly in a Shell, including input and output redirection using < and >. Note that Execute() doesn't return until the command(s) in commandstring have returned.

The input file handle will normally be zero, and in this case Execute() will perform whatever was requested in the commandString and then return. If the input file handle is nonzero then after the (possibly empty) commandString is performed subsequent input is read from the specified input file handle until end of that file is reached.

In most cases the output file handle must be provided, and is used by the Shell commands as their output stream unless output redirection was specified. If the output file handle is set to zero then the current window, normally specified as *, is used. Note that programs running under the Workbench do not normally have a current window.

Execute() may also be used to create a new interactive Shell process just like those created with the NewShell command. In order to do this you would call Execute() with an empty commandString, and pass a file handle relating to a new window as the input file handle. The output file handle would be set to zero. The Shell will read commands from the new window, and will use the same window for output. This new Shell window can only be terminated by using the EndCLI command.


ExNext

Examine the next entry in a directory

Declaration

Source position: amigados.pas line 2442

function ExNext(

  Lock: LongInt;

  FileInfoBlock: PFileInfoBlock

):LongBool;

Arguments

Lock | Pointer to a lock originally used for the Examine() call
FileInfoBlock | Pointer to a TFileInfoBlock used on the previous Examine() or ExNext() call.

Description

This routine is passed a directory lock and a TFileInfoBlock that have been initialized by a previous call to Examine(), or updated by a previous call to ExNext(). ExNext() gives a return code of zero on failure. The most common cause of failure is reaching the end of the list of files in the owning directory. In this case, IoErr() will return ERROR_NO_MORE_ENTRIES and a good exit is appropriate.

So, follow these steps to examine a directory:

  1. Pass a Lock and a FileInfoBlock to Examine(). The lock must be on the directory you wish to examine.
  2. Pass ExNext() the same lock and TFileInfoBlock.
  3. Do something with the information returned in the TFileInfoBlock. Note that the fib_DirEntryType field is positive for directories, negative for files.
  4. Keep calling ExNext() until it returns False. Check IoErr() to ensure that the reason for failure was ERROR_NO_MORE_ENTRIES.

Attention

If you wish to recursively scan the file tree and you find another directory while ExNext()ing you must Lock that directory and Examine() it using a new FileInfoBlock. Use of the same FileInfoBlock to enter a directory would lose important state information such that it will be impossible to continue scanning the parent directory. While it is permissible to UnLock() and Lock() the parent directory between ExNext() calls, this is not recommended. Important state information is associated with the parent lock, so if it is freed between ExNext() calls this information has to be rebuilt on each new ExNext() call, and will significantly slow down directory scanning.

It is not legal to Examine() a file, and then to ExNext() from that TFileInfoBlock. You may make a local copy of the TFileInfoBlock, as long as it is never passed back to the operating system.

See also

Examine | Examine a directory or file associated with a lock
Lock | Lock a directory or file
UnLock | Unlock a directory or file
IoErr | Return extra information from the system
ExamineFH | Gets information on an open file
AllocDosObject | Creates a dos object
ExAll | Examine an entire directory

Example

program ExamineTest;
uses
  AmigaDos;
procedure CheckDir(ALock: BPTR);
var
  FIB: PFileInfoBlock;
begin
  FIB := AllocDosObject(DOS_FIB, nil);
  if Assigned(FIB) then
  begin
    if Examine(ALock, FIB) <> 0 then
    begin
      repeat
        writeln(FIB^.fib_FileName);
      until ExNext(ALock, FIB) = 0;
    end;
    if IOErr() = ERROR_NO_MORE_ENTRIES then
      writeln('nothing more found')
    else
      writeln('Something went wrong ', IOErr);
    FreeDosObject(DOS_FIB, FIB);
  end;
end;
var
  RAMLock: BPTR;
begin
  RAMLock := Lock('RAM:', SHARED_LOCK);
  CheckDir(RAMLock);
  unlock(RAMLock);
end.


Fault

Returns the text associated with a DOS error code

Declaration

Source position: amigados.pas line 2513

function Fault(

  Code: LongInt;

  const Header: PChar;

  Buffer: PChar;

  Len: LongInt

):LongBool;

Arguments

Code | Error code
Header | Header to output before error text
Buffer | Buffer to receive error message
Len | Length of buffer

Function result

Number of characters put into buffer (may be 0)

Description

This routine obtains the error message text for the given error code. The header is prepended to the text of the error message, followed by a colon. Puts a null-terminated string for the error message into the buffer. By convention, error messages should be no longer than 80 characters (+1 for termination), and preferably no more than 60. The value returned by IoErr() is set to the code passed in. If there is no message for the error code, the message will be "Error code number".

The number of characters put into the buffer is returned, which will be 0 if the code passed in was 0.

See also

IoErr | Return extra information from the system
SetIoErr | Sets the value returned by IoErr()
PrintFault | Returns the text associated with a DOS error code


FAULT_MAX

Max Length for error string

Declaration

Source position: amigados.pas line 368

const FAULT_MAX = 82;

Description

Standard maximum length for an error string from fault. However, most error strings should be kept under 60 characters if possible. Don't forget space for the header you pass in.


FClose

Declaration

Source position: amigados.pas line 2664

function FClose(

  Scb: LongInt

):LongInt;


FFlush

Declaration

Source position: amigados.pas line 2495

function FFlush(

  Fh: LongInt

):LongBool;


FGetC

Read a character from the specified input (buffered)

Declaration

Source position: amigados.pas line 2483

function FGetC(

  Fh: LongInt

):LongInt;

Function result

character read (0-255) or -1

Description

Reads the next character from the input stream. A -1 is returned when EOF or an error is encountered. This call is buffered. Use DosFlush() between buffered and unbuffered I/O on a filehandle.

See also

FPutC | Write a character to the specified output
UnGetC | Makes a char available for reading again. (buffered)
DosFlush | Flushes buffers for a buffered filehandle


FGets

Reads a line from the specified input (buffered)

Declaration

Source position: amigados.pas line 2488

function FGets(

  Fh: LongInt;

  Buf: PChar;

  BufLen: LongWord

):PChar;

Arguments

Fh | filehandle to use for buffered I/O
Buf | Area to read bytes into.
BufLen | Number of bytes to read, must be > 0.

Function result

Pointer to buffer passed in, or nil for immediate EOF or for an error. If nil is returnd for an EOF, IoErr() will return 0.

Description

This routine reads in a single line from the specified input stopping at a NEWLINE character or EOF. In either event, UP TO the number of len specified bytes minus 1 will be copied into the buffer. Hence if a length of 50 is passed and the input line is longer than 49 bytes, it will return 49 characters. It returns the buffer pointer normally, or NULL if EOF is the first thing read.

If terminated by a newline, the newline WILL be the last character in the buffer. This is a buffered read routine. The string read in IS null-terminated.

See also

FRead | Reads a number of blocks from an input (buffered)
FPuts | Writes a string the the specified output
FGetC | Read a character from the specified input (buffered)


FileHandleScan

Declaration

Source position: amigados.pas line 2724

function FileHandleScan(

  const Hook: PHook;

  const UserData: Pointer;

  Reserved: LongWord

):LongInt;


FilePart

Returns the last component of a path

Declaration

Source position: amigados.pas line 2586

function FilePart(

  const Path: PChar

):PChar;

Arguments

Path

pointer to an path string. May be relative to the current directory or the current disk.

Function result

pointer to the last component of the path.

Description

This function returns a pointer to the last component of a string path specification, which will normally be the file name. If there is only one component, it returns a pointer to the beginning of the string.

See also

PathPart | Returns a pointer to the end of the next-to-last component of a path.
AddPart | Appends a file/dir to the end of a path


FileSystemAttr

Declaration

Source position: amigados.pas line 2676

function FileSystemAttr(

  const Tags: PTagItem

):LongInt;


FindArg

Find a keyword in a template

Declaration

Source position: amigados.pas line 2575

function FindArg(

  const KeyWord: PChar;

  const ArgTemplate: PChar

):LongInt;

Arguments

KeyWord

Keyword to search for in template

Function result

Number of entry in template, or -1 if not found

Description

Returns the argument number of the keyword, or -1 if it is not a keyword for the template. Abbreviations are handled.

See also

ReadArgs | Read bytes of data from a file
ReadItem | Reads a single argument/name from command line
FreeArgs | Free allocated memory after ReadArgs()


FindCliProc

Returns a pointer to the requested CLI process

Declaration

Source position: amigados.pas line 2528

function FindCliProc(

  Num: LongWord

):PProcess;

Arguments

Num

Task number of CLI process (range 1-N)

Function result

Pointer to given CLI process

Description

This routine returns a pointer to the CLI process associated with the given CLI number. If the process isn't an active CLI process, nil is returned. NOTE: should normally be called inside a Forbid(), if you must use this function at all.

See also

Cli | Returns a pointer to the CLI structure of the process
MaxCli | Returns the highest CLI process number possibly in use
exec.Forbid | Forbid task scheduling.


FindDosEntry

Finds a specific Dos List entry

Declaration

Source position: amigados.pas line 2553

function FindDosEntry(

  const DList: PDOSList;

  const Name: PChar;

  Flags: LongWord

):PDOSList;

Arguments

DList | The device entry to start with.
Name | Name of device entry (without ':') to locate.
Flags | Search control flags. Use the flags you passed to LockDosList, or a subset of them. LDF_READ/LDF_WRITE are not required for this call.

Function result

The device entry or nil

Description

Locates an entry on the device list. Starts with the entry dlist. NOTE: must be called with the device list locked, no references may be made to dlist after unlocking.

See also

AddDosEntry | Add a Dos List entry to the lists
RemDosEntry | Removes a Dos List entry from it's list
NextDosEntry | Get the next Dos List entry
LockDosList | Locks the specified Dos Lists for use
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry


FindSegment

Finds a segment on the resident list

Declaration

Source position: amigados.pas line 2571

function FindSegment(

  const Name: PChar;

  const Seg: PDosResidentSeg;

  Sys: LongInt

):PDosResidentSeg;

Arguments

Name | Name of Segment to find
Seg | Segment to start the search after

Function result

The Segment found or nil

Description

Finds a segment on the Dos resident list by name and type, starting at the segment after 'start', or at the beginning if start is nil. If system is zero, it will only return nodes with a seg_UC of 0 or more. It does not increment the seg_UC, and it does not do any locking of the list. You must Forbid() lock the list to use this call.

To use an entry you have found, you must: if the seg_UC is 0 or more, increment it, and decrement it (under Forbid()!) when you're done the the seglist.

The other values for seg_UC are:

-1
system module, such as a filesystem or shell
-2
resident shell command
-999
disabled internal command, ignore

Negative values should never be modified. All other negative values between 0 and -32767 are reserved to AmigaDos and should not be used.

See also

AddSegment | Adds a resident segment to the resident list
RemSegment | Removes a resident segment from the resident list
exec.Forbid | Forbid task scheduling.


FindSegmentStackSize

Declaration

Source position: amigados.pas line 2636

function FindSegmentStackSize(

  Segment: LongInt

):LongWord;


FindTrackedAddress

Declaration

Source position: amigados.pas line 2624

procedure FindTrackedAddress(

  const Address: Pointer;

  Hook: PHook

);


FindVar

Finds a local variable

Declaration

Source position: amigados.pas line 2594

function FindVar(

  const Name: PChar;

  Type_: LongWord

):PLocalVar;

Arguments

Name | pointer to an variable name. Note variable names follow filesystem syntax and semantics.
Type_ | Type of variable to be found (GVF_*)

Description

Finds a local variable structure.

See also

DeleteVar | Deletes a local or environment variable
GetVar | Returns the value of a local or global variable
SetVar | Sets a local or environment variable


FixDateStamp

Declaration

Source position: amigados.pas line 2617

function FixDateStamp(

  Ds: PDateStamp

):LongInt;


FlushVolume

Declaration

Source position: amigados.pas line 2709

function FlushVolume(

  const Name: PChar

):LongInt;


FlushVolumePort

Declaration

Source position: amigados.pas line 2723

function FlushVolumePort(

  Port: PMsgPort

):LongBool;


FOpen

Declaration

Source position: amigados.pas line 2663

function FOpen(

  const Name: PChar;

  Mode: LongInt;

  BufSize: LongInt

):LongInt;


FOpenFromLock

Declaration

Source position: amigados.pas line 2665

function FOpenFromLock(

  Lock: LongInt;

  BufSize: LongInt

):LongInt;


Format

Declaration

Source position: amigados.pas line 2558

function Format(

  const Filesystem: PChar;

  const VolumeName: PChar;

  DosType: LongWord

):LongBool;


FORMAT_CDN

Declaration

Source position: amigados.pas line 622

const FORMAT_CDN = 3;


FORMAT_DEF

Declaration

Source position: amigados.pas line 623

const FORMAT_DEF = 4;


FORMAT_DOS

Declaration

Source position: amigados.pas line 619

const FORMAT_DOS = 0;


FORMAT_INT

Declaration

Source position: amigados.pas line 620

const FORMAT_INT = 1;


FORMAT_ISO

Declaration

Source position: amigados.pas line 625

const FORMAT_ISO = 5;


FORMAT_MAX

Declaration

Source position: amigados.pas line 626

const FORMAT_MAX = FORMAT_ISO;


FORMAT_USA

Declaration

Source position: amigados.pas line 621

const FORMAT_USA = 2;


FormatPort

Declaration

Source position: amigados.pas line 2721

function FormatPort(

  Port: PMsgPort;

  const VolumeName: PChar;

  DosType: LongInt

):LongBool;


FPutC

Write a character to the specified output

Declaration

Source position: amigados.pas line 2484

function FPutC(

  Fh: LongInt;

  Ch: LongInt

):LongInt;

Function result

Either the character written, or EOF for an error.

Description

Writes a single character to the output stream. This call is buffered. Use DosFlush() between buffered and unbuffered I/O on a filehandle. Interactive filehandles are flushed automatically on a newline, return, 0, or line feed.

See also

FGetC | Read a character from the specified input (buffered)
UnGetC | Makes a char available for reading again. (buffered)
DosFlush | Flushes buffers for a buffered filehandle


FPuts

Writes a string the the specified output

Declaration

Source position: amigados.pas line 2489

function FPuts(

  Fh: LongInt;

  const Str: PChar

):LongInt;

Function result

0 normally, otherwise -1. Note that this is opposite of most other Dos functions, which return success.

Description

This routine writes an unformatted string to the filehandle. No newline is appended to the string. This routine is buffered.

See also

FGets | Reads a line from the specified input (buffered)
FPutC | Write a character to the specified output
FWrite | Writes a number of blocks to an output (buffered)
PutStr | Writes a string the the default output (buffered)


FRead

Reads a number of blocks from an input (buffered)

Declaration

Source position: amigados.pas line 2486

function FRead(

  Fh: LongInt;

  Block: Pointer;

  BlockLen: LongWord;

  Number: LongWord

):LongWord;

Arguments

Fh | filehandle to use for buffered I/O
Block | Area to read bytes into.
BlockLen | number of bytes per block. Must be > 0.
Number | number of blocks to read. Must be > 0.

Function result

Number of _blocks_ read, or 0 for EOF. On an error, the number of blocks actually read is returned.

Description

Attempts to read a number of blocks, each blocklen long, into the specified buffer from the input stream. May return less than the number of blocks requested, either due to EOF or read errors. This call is buffered.

See also

FGetC | Read a character from the specified input (buffered)
FWrite | Writes a number of blocks to an output (buffered)
FGets | Reads a line from the specified input (buffered)


FReadLine

Declaration

Source position: amigados.pas line 2678

function FReadLine(

  Fh: LongInt;

  Frld: PFReadLineData

):LongInt;


FreeArgs

Free allocated memory after ReadArgs()

Declaration

Source position: amigados.pas line 2584

procedure FreeArgs(

  Args: PRDArgs

);

Arguments

Args

The data used by ReadArgs(). May be nil, in which case, FreeArgs() does nothing.

Description

FreeArgs() will clean up after a call to ReadArgs(). If the TRDArgs structure was allocated by the system in a call to ReadArgs(), then it will be freed. If however, you allocated the TRDArgs structure with AllocDosObject(), then you will have to free it yourself with FreeDosObject().

See also

ReadArgs | Read bytes of data from a file
ReadItem | Reads a single argument/name from command line
FindArg | Find a keyword in a template


FreeCmdPathList

Declaration

Source position: amigados.pas line 2648

procedure FreeCmdPathList(

  Pn: PPathNode

);


FreeDeviceProc

Releases port returned by GetDeviceProc()

Declaration

Source position: amigados.pas line 2547

procedure FreeDeviceProc(

  Dp: PDevProc

);

Arguments

Dp

A value returned by GetDeviceProc()

Description

Frees up the structure created by GetDeviceProc(), and any associated temporary locks.

Decrements the counter incremented by GetDeviceProc(). The counter is in an extension to the 1.3 process structure. After calling FreeDeviceProc(), do not use the port or lock again! It is safe to call FreeDeviceProc(nil).

See also

GetDeviceProc | Finds a handler to send a message to
AssignLock | Creates an assignment to a locked object
AssignLate | Creates an assignment to a specified path later
AssignPath | Creates an assignment to a specified path


FreeDiskFileSystemData

Declaration

Source position: amigados.pas line 2662

procedure FreeDiskFileSystemData(

  Fsd: PFileSystemData

);


FreeDosEntry

Frees an entry created by MakeDosEntry

Declaration

Source position: amigados.pas line 2556

procedure FreeDosEntry(

  DList: PDOSList

);

Arguments

DList

DosList to free.

Description

This routine should be eliminated and replaced by a value passed to FreeDosObject()!


FreeDosObject

Frees an object allocated by AllocDosObject()

Declaration

Source position: amigados.pas line 2466

procedure FreeDosObject(

  Type_: LongWord;

  Ptr: Pointer

);

Arguments

Type_ | Type passed to AllocDosObject()
Ptr | Pointer returned by AllocDosObject()

Description

Do not call for objects allocated in any other way.

See also

AllocDosObject | Creates a dos object
FreeVec | Free memory with tracked size made using AllocVec()


FWrite

Writes a number of blocks to an output (buffered)

Declaration

Source position: amigados.pas line 2487

function FWrite(

  Fh: LongInt;

  Block: Pointer;

  BlockLen: LongWord;

  Number: LongWord

):LongWord;

Arguments

Fh | filehandle to use for buffered I/O
Block | Area to write bytes from.
BlockLen | Number of blocks to block. Must be > 0.

Function result

Number of _blocks_ written. On an error, the number of blocks actually written is returned.

Description

Attempts to write a number of blocks, each blocklen long, from the specified buffer to the output stream. May return less than the number of blocks requested, if there is some error such as a full disk or r/w error. This call is buffered.

See also

FPutC | Write a character to the specified output
FRead | Reads a number of blocks from an input (buffered)
FPuts | Writes a string the the specified output


GetArgStr

Returns the arguments for the process

Declaration

Source position: amigados.pas line 2526

function GetArgStr: PChar;

Function result

Pointer to arguments

Description

Returns a pointer to the (null-terminated) arguments for the program (process). This is the same string passed on startup from CLI.

See also

SetArgStr | Sets the arguments for the current process
RunCommand | Runs a program using the current process


GetCliCurrentDirName

Declaration

Source position: amigados.pas line 2531

function GetCliCurrentDirName(

  Buf: PChar;

  Len: LongInt

):LongInt;


GetCliProgramName

Declaration

Source position: amigados.pas line 2533

function GetCliProgramName(

  Buf: PChar;

  Len: LongInt

):LongInt;


GetCliPrompt

Declaration

Source position: amigados.pas line 2535

function GetCliPrompt(

  Buf: PChar;

  Len: LongInt

):LongInt;


GetConsolePort

Declaration

Source position: amigados.pas line 2522

function GetConsolePort: PMsgPort;


GetCurrentDir

Declaration

Source position: amigados.pas line 2613

function GetCurrentDir: LongInt;


GetDeviceProc

Finds a handler to send a message to

Declaration

Source position: amigados.pas line 2546

function GetDeviceProc(

  const Name: PChar;

  Dp: PDevProc

):PDevProc;

Arguments

Name | name of the object you wish to access. This can be a relative path ('foo/bar'), relative to the current volume (':foo/bar'), or relative to a device/volume/assign ('foo:bar').
Dp | A value returned by GetDeviceProc() before, or nil

Function result

a pointer to a DevProc structure or nil

Description

Finds the handler/filesystem to send packets regarding name to. This may involve getting temporary locks. It returns a structure that includes a lock and msgport to send to to attempt your operation. It also includes information on how to handle multiple-directory assigns (by passing the DevProc back to GetDeviceProc() until it returns nil).

The initial call to GetDeviceProc() should pass nil for devproc. If after using the returned DevProc, you get an ERROR_OBJECT_NOT_FOUND, and (TDevProc) is True, you should call GetDeviceProc() again, passing it the devproc structure. It will either return a modified devproc structure, or nil (with ERROR_NO_MORE_ENTRIES in IoErr()). Continue until it returns nil.

This call also increments the counter that locks a handler/fs into memory. After calling FreeDeviceProc(), do not use the port or lock again!

See also

FreeDeviceProc | Releases port returned by GetDeviceProc()
AssignLock | Creates an assignment to a locked object
AssignLate | Creates an assignment to a specified path later
AssignPath | Creates an assignment to a specified path


GetDeviceProcFlags

Declaration

Source position: amigados.pas line 2656

function GetDeviceProcFlags(

  const Name: PChar;

  Odp: PDevProc;

  Flags: LongWord

):PDevProc;


GetDiskFileSystemData

Declaration

Source position: amigados.pas line 2661

function GetDiskFileSystemData(

  const Name: PChar

):PFileSystemData;


GetDiskInfo

Declaration

Source position: amigados.pas line 2693

function GetDiskInfo(

  const Tags: PTagItem

):LongInt;


GetEntryData

Declaration

Source position: amigados.pas line 2609

function GetEntryData: LongInt;


GetExitData

Declaration

Source position: amigados.pas line 2629

function GetExitData: LongInt;


GetFilePosition

Declaration

Source position: amigados.pas line 2681

function GetFilePosition(

  Fh: LongInt

):Int64;


GetFileSize

Declaration

Source position: amigados.pas line 2684

function GetFileSize(

  Fh: LongInt

):Int64;


GetFileSysPort

Declaration

Source position: amigados.pas line 2524

function GetFileSysPort: PMsgPort;


GetFileSystemVectorPort

Declaration

Source position: amigados.pas line 2725

function GetFileSystemVectorPort(

  Port: PMsgPort;

  MinVersion: LongWord

):PFileSystemVectorPort;


GetOwnerInfo

Declaration

Source position: amigados.pas line 2702

function GetOwnerInfo(

  const Tags: PTagItem

):Pointer;


GetPID

Declaration

Source position: amigados.pas line 2708

function GetPID(

  Process: PProcess

):LongWord;


GetProcMsgPort

Declaration

Source position: amigados.pas line 2643

function GetProcMsgPort(

  const Proc: PProcess

):PMsgPort;


GetProcSegList

Declaration

Source position: amigados.pas line 2654

function GetProcSegList(

  const Proc: PProcess;

  Flags: LongWord

):LongInt;


GetProgramDir

Returns a lock on the directory the program was loaded from

Declaration

Source position: amigados.pas line 2537

function GetProgramDir: LongInt;

Function result

A lock on the directory the current program was loaded from, or nil if loaded from resident list, etc.

Description

Returns a shared lock on the directory the program was loaded from. This can be used for a program to find data files, etc, that are stored with the program, or to find the program file itself. nil returns are valid, and may occur, for example, when running a program from the resident list. You should not unlock the lock.

See also

DosOpen

Open a file for input or output


GetSegListInfo

Declaration

Source position: amigados.pas line 2639

function GetSegListInfo(

  SegList: LongInt;

  const Tags: PTagItem

):LongInt;


GetVar

Returns the value of a local or global variable

Declaration

Source position: amigados.pas line 2592

function GetVar(

  const Name: PChar;

  Buffer: PChar;

  Size: LongInt;

  Flags: LongInt

):LongInt;

Arguments

Name | Pointer to a variable name.
Buffer | A user allocated area which will be used to store the value associated with the variable.
Size | Length of the buffer region in bytes.
Flags | combination of type of var to get value of (low 8 bits), and flags to control the behavior of this routine.

Function result

Size of environment variable. -1 indicates that the variable was not defined.

Description

Gets the value of a local or environment variable. It is advised to only use ASCII strings inside variables, but not required. This stops putting characters into the destination when a n is hit, unless GVF_BINARY_VAR is specified. (The n is not stored in the buffer.)

Currently defined flags include:

GVF_GLOBAL_ONLY
tries to get a global env variable.
GVF_LOCAL_ONLY
tries to get a local variable.
GVF_BINARY_VAR
don't stop at n
GVF_DONT_NULL_TERM
no null termination (only valid for binary variables).

The default is to try to get a local variable first, then to try to get a global environment variable.

See also

SetVar | Sets a local or environment variable
DeleteVar | Deletes a local or environment variable
FindVar | Finds a local variable


HexToLong

Declaration

Source position: amigados.pas line 2655

function HexToLong(

  const String_: PChar;

  ValuePtr: PLongWord

):LongInt;


Info

Returns information about the disk

Declaration

Source position: amigados.pas line 2443

function Info(

  Lock: LongInt;

  ParameterBlock: PInfoData

):LongBool;

Arguments

Lock | A lock on any file on the volume for which information should be supplied, or 0
ParameterBlock | pointer to the info

Description

Info() can be used to find information about any disk in use. lock refers to the disk, or any file on the disk. The parameter block is returned with information about the size of the disk, number of free blocks and any soft errors.


Inhibit

Inhibits access to a filesystem

Declaration

Source position: amigados.pas line 2560

function Inhibit(

  const Name: PChar;

  OnOff: LongInt

):LongBool;

Arguments

Name | Name of device to inhibit (with ':')
OnOff | New status. DOSTRUE = inhibited, DOSFALSE = uninhibited

Description

Sends an ACTION_INHIBIT packet to the indicated handler. This stops all activity by the handler until uninhibited. When uninhibited, anything may have happened to the disk in the drive, or there may no longer be one.


InhibitPort

Declaration

Source position: amigados.pas line 2720

function InhibitPort(

  Port: PMsgPort;

  State: LongInt

):LongBool;


IoErr

Return extra information from the system

Declaration

Source position: amigados.pas line 2447

function IoErr: LongInt;

Description

Most I/O routines return zero to indicate an error. When this happens (or whatever the defined error return for the routine) this routine may be called to determine more information. It is also used in some routines to pass back a secondary result.

Note: there is no guarantee as to the value returned from IoErr() after a successful operation, unless to specified by the routine.

See also

Fault | Returns the text associated with a DOS error code
PrintFault | Returns the text associated with a DOS error code
SetIoErr | Sets the value returned by IoErr()


IsFileSystem

Returns whether a Dos handler is a filesystem

Declaration

Source position: amigados.pas line 2557

function IsFileSystem(

  const Name: PChar

):LongBool;

Arguments

Name

Name of device in question, with trailing ':'.

Function result

Flag to indicate if device is a file system

Description

Returns whether the device is a filesystem or not. A filesystem supports seperate files storing information. It may also support sub-directories, but is not required to. If the filesystem doesn't support this new packet, IsFileSystem() will use Lock(":",...) as an indicator.

DF0:, HD0:, ... are filesystems. CON:, PIPE:, AUX:, ... are not. In AmigaOS if devicename contains no ':' then result is always True. Also volume and assign names return True.

See also

Lock

Lock a directory or file


IsFileSystemPort

Declaration

Source position: amigados.pas line 2719

function IsFileSystemPort(

  Port: PMsgPort

):LongBool;


IsInteractive

Discover whether a file is "interactive"

Declaration

Source position: amigados.pas line 2461

function IsInteractive(

  File_: LongInt

):LongBool;

Arguments

File_

file handle

Description

The return value status indicates whether the file associated with the file handle file is connected to a virtual terminal like a console or shell window.


LoadSeg

Scatterload a loadable file into memory

Declaration

Source position: amigados.pas line 2453

function LoadSeg(

  const Name: PChar

):LongInt;

Arguments

Name

Name of the file to load

Function result

Pointer to the seglist

Description

The file name should be a load module produced by the linker. LoadSeg() scatterloads the CODE, DATA and BSS segments into memory, chaining together the segments with BPTR's on their first words. The end of the chain is indicated by a zero. There can be any number of segments in a file. All necessary relocation is handled by LoadSeg().

In the event of an error any blocks loaded will be unloaded and a NULL result returned.

If the module is correctly loaded then the output will be a pointer at the beginning of the list of blocks. Loaded code is unloaded via a call to UnLoadSeg().

See also

UnLoadSeg | Unload a seglist previously loaded by LoadSeg()
CreateProc | Create a new process
CreateNewProc | Create a new process from taglist


Lock

Lock a directory or file

Declaration

Source position: amigados.pas line 2438

function Lock(

  const Name: PChar;

  Type_: LongInt

):LongInt;

Arguments

Name

Name of file or directory to lock

Function result

Pointer to lock or nil

Description

Gets a lock on a file or directory. There may be more than one shared lock on a file but only one if it is an exclusive one. Locked files or directories may not be deleted.

See also

UnLock | Unlock a directory or file
DupLock | Duplicate a lock
ChangeMode | Change the current mode of a lock or filehandle
NameFromLock | Returns the name of a locked object
DupLockFromFH | Gets a lock on an open file


LOCK_DIFFERENT

Value returned by SameLock

Declaration

Source position: amigados.pas line 535

const LOCK_DIFFERENT = - 1;


LOCK_SAME

Value returned by SameLock

Declaration

Source position: amigados.pas line 536

const LOCK_SAME = 0;


LOCK_SAME_HANDLER

Value returned by SameLock

Declaration

Source position: amigados.pas line 537

const LOCK_SAME_HANDLER = 1;


LOCKB_ASSIGNMENT

Declaration

Source position: amigados.pas line 61

const LOCKB_ASSIGNMENT = 18;


LOCKB_CURRDIR

Declaration

Source position: amigados.pas line 63

const LOCKB_CURRDIR = 20;


LOCKB_DEVICE

Declaration

Source position: amigados.pas line 59

const LOCKB_DEVICE = 16;


LOCKB_FILESYS

Declaration

Source position: amigados.pas line 65

const LOCKB_FILESYS = 24;


LOCKB_PROGDIR

Declaration

Source position: amigados.pas line 62

const LOCKB_PROGDIR = 19;


LOCKB_ROOTDIR

Declaration

Source position: amigados.pas line 64

const LOCKB_ROOTDIR = 21;


LOCKB_SOFTLINK_ENDPART

Declaration

Source position: amigados.pas line 58

const LOCKB_SOFTLINK_ENDPART = 9;


LOCKB_SOFTLINK_MIDPART

Declaration

Source position: amigados.pas line 56

const LOCKB_SOFTLINK_MIDPART = 8;


LOCKB_VOLUME

Declaration

Source position: amigados.pas line 60

const LOCKB_VOLUME = 17;


LockDosList

Locks the specified Dos Lists for use

Declaration

Source position: amigados.pas line 2548

function LockDosList(

  Flags: LongWord

):PDOSList;

Arguments

Flags

what lists to lock

Function result

Handle to the dos list. This is not a direct pointer to the first list element but to a pseudo element instead.

Description

Waits until the desired dos lists are free then gets a lock on them. A handle is returned that can be used for FindDosEntry(). Calls to this function nest, i.e. you must call UnLockDosList() as often as you called LockDosList(). Always lock all lists at once - do not try to get a lock on one of them then on another.

See also

AttemptLockDosList | Attempt to lock the Dos Lists for use
UnLockDosList | Unlocks the Dos List
exec.Forbid | Forbid task scheduling.
NextDosEntry | Get the next Dos List entry


LockRecord

Locks a portion of a file

Declaration

Source position: amigados.pas line 2717

function LockRecord(

  Fh: LongInt;

  Offset: Int64;

  Length: Int64;

  Mode: LongWord;

  TimeOut: LongWord

):LongBool;

Arguments

Fh | File handle for the file to lock a record of
Offset | Starting position of the lock
Length | Length of the record in bytes
Mode | Lock type (REC_*) For the IMMED modes, the timeout is ignored.
TimeOut | imeout interval in ticks (1/50 seconds). 0 is legal.

Description

Lock a portion of a file for exclusive access. A timeout may be specified which is the maximum amount of time to wait for the record to be available.

See also

LockRecords | Lock a series of records
UnLockRecord | Unlock a record
UnLockRecords | Unlock a list of records


LockRecords

Lock a series of records

Declaration

Source position: amigados.pas line 2478

function LockRecords(

  RecArray: PRecordLock;

  TimeOut: LongWord

):LongBool;

Arguments

RecArray | Array of records to lock
TimeOut | maximum number of ticks to wait for a lock to be ready (1/50 seconds)

Function result

Success/failure indication. In case of a success, all the record locks are locked. In case of failure, no record locks are locked.

Description

Lock several records at the same time. The timeout specified is applied to each lock to attempt. The array of RecordLock:s is terminated with an entry where rec_FH is equal to nil. A set of records should always be locked in the same order so as to reduce possiblities of deadlock.

See also

UnLockRecords

Unlock a list of records


LockTagList

Declaration

Source position: amigados.pas line 2706

function LockTagList(

  const Tags: PTagItem

):LongInt;


MakeDosEntry

Creates a DosList structure

Declaration

Source position: amigados.pas line 2555

function MakeDosEntry(

  const Name: PChar;

  Type_: LongInt

):PDOSList;

Arguments

Name | Name for the device/volume/assign node.
Type_ | Type of Node (LDF_*)

Function result

New device entry or nil

Description

Create a DosList structure, including allocating a name and correctly null-terminating the BSTR. It also sets the dol_Type field, and sets all other fields to 0. This routine should be eliminated and replaced by a value passed to AllocDosObject()!

See also

AllocDosObject | Creates a dos object
RemDosEntry | Removes a Dos List entry from it's list
FindDosEntry | Finds a specific Dos List entry
LockDosList | Locks the specified Dos Lists for use
NextDosEntry | Get the next Dos List entry
FreeDosEntry | Frees an entry created by MakeDosEntry


MakeLink

Creates a filesystem link

Declaration

Source position: amigados.pas line 2509

function MakeLink(

  const Name: PChar;

  Dest: Pointer;

  soft: LongInt

):LongBool;

Arguments

Name | The name of the link to create
Dest | If soft is True this must be a filename; if it is False a lock pointing to the file to be hard-linked must be provided
soft | True, if a soft link is to be created, False for a hard link

Function result

DOSTRUE or DOSFALSE. On error, IoErr() will contain more information.

Description

MakeLink() will create a link between two files or directories. A link is a filesystem object that refers to another file.

A soft link refers to another file or directory by name, and is resolved by the filesystem and the caller. Soft links are not restricted to the same volume and the target does not have to exist.

A hard link refers to another file by the location on a disk, and is resolved by the filesystem. Hard links are restricted to files or directories on the same volume.


MatchEnd

Free storage allocated for MatchFirst()/MatchNext()

Declaration

Source position: amigados.pas line 2580

procedure MatchEnd(

  Anchor: PAnchorPath

);

Description

Return all storage associated with a given search.

See also

MatchFirst | Finds file that matches pattern
ParsePattern | Create a tokenized string for MatchPattern()
Examine | Examine a directory or file associated with a lock
CurrentDir | Make a directory lock the current directory
MatchNext | Finds the next file or directory that matches pattern
ExNext | Examine the next entry in a directory


MatchFirst

Finds file that matches pattern

Declaration

Source position: amigados.pas line 2578

function MatchFirst(

  const Pat: PChar;

  Anchor: PAnchorPath

):LongInt;

Arguments

Pat

Pattern to search for

Function result

0 for success or error code.

Description

Locates the first file or directory that matches a given pattern. MatchFirst() is passed your pattern (you do not pass it through ParsePattern() - MatchFirst() does that for you), and the control structure. MatchFirst() normally initializes your AnchorPath structure for you, and returns the first file that matched your pattern, or an error. Note that MatchFirst()/ MatchNext() are unusual for Dos in that they return 0 for success, or the error code, instead of the application getting the error code from IoErr().

When looking at the result of MatchFirst()/ MatchNext(), the ap_Info field of your TAnchorPath has the results of an Examine() of the object. You normally get the name of the object from fib_FileName, and the directory it's in from ap_Current.an_Lock. To access this object, normally you would temporarily CurrentDir() to the lock, do an action to the file/dir, and then CurrentDir() back to your original directory. This makes certain you affect the right object even when two volumes of the same name are in the system. You can use ap_Buf (with ap_StrLen) to get a name to report to the user.

To initialize the TAnchorPath structure (particularily when reusing it), set ap_BreakBits to the signal bits (CDEF) that you want to take a break on, or nil, if you don't want to convenience the user. ap_Flags should be set to any flags you need or all 0's otherwise. ap_FoundBreak should be cleared if you'll be using breaks.

If you want to have the FULL PATH NAME of the files you found, allocate a buffer at the END of this structure, and put the size of it into ap_StrLen. If you don't want the full path name, make sure you set ap_StrLen to zero. In this case, the name of the file, and stats are available in the ap_Info, as per usual.

Then call MatchFirst() and then afterwards, MatchNext() with this structure. You should check the return value each time (see below) and take the appropriate action, ultimately calling MatchEnd() when there are no more files or you are done. You can tell when you are done by checking for the normal AmigaDOS return code ERROR_NO_MORE_ENTRIES.

Note: patterns with trailing slashes may cause MatchFirst()/ MatchNext() to return with an ap_Current.an_Lock on the object, and a filename of the empty string ('').

See ParsePattern() for more information on the patterns.

See also

MatchNext | Finds the next file or directory that matches pattern
ParsePattern | Create a tokenized string for MatchPattern()
Examine | Examine a directory or file associated with a lock
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()
ExNext | Examine the next entry in a directory

Example

program MatchTest;
uses
  amigados;
procedure FindIcons(Pattern: AnsiString);
var
  Anchor: TAnchorPath;
begin
  if MatchFirst(PChar(Pattern), @Anchor) = 0 then
  begin
    repeat
      writeln(Anchor.ap_Info.fib_Filename);
    until MatchNext(@Anchor) <> 0;
    MatchEnd(@Anchor);
  end;
end;
begin
  FindIcons('sys:#?.info');
end.


MatchNext

Finds the next file or directory that matches pattern

Declaration

Source position: amigados.pas line 2579

function MatchNext(

  Anchor: PAnchorPath

):LongInt;

Function result

0 for success or error code.

Description

Locates the next file or directory that matches a given pattern. Various bits in the flags (APF_*) allow the application to control the operation of MatchNext().

See also

MatchFirst | Finds file that matches pattern
ParsePattern | Create a tokenized string for MatchPattern()
Examine | Examine a directory or file associated with a lock
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()
ExNext | Examine the next entry in a directory


MatchPattern

Checks for a pattern match with a string

Declaration

Source position: amigados.pas line 2582

function MatchPattern(

  const Pat: PChar;

  Str: PChar

):LongBool;

Arguments

Pat | Special pattern string to match as returned by ParsePattern()
Str | String to match against given pattern

Function result

Success or failure of pattern match. On failure, IoErr() will return 0 or ERROR_TOO_MANY_LEVELS

Description

The pattern must be a tokenized string output by ParsePattern(). This routine is case-sensitive.

NOTE: this routine is highly recursive. You must have at least 1500 free bytes of stack to call this (it will cut off it's recursion before going any deeper than that and return failure). That's currently enough for about 100 levels deep of #, (, ~, etc.

See also

ParsePattern | Create a tokenized string for MatchPattern()
MatchPatternNoCase | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern


MatchPatternNoCase

Checks for a pattern match with a string

Declaration

Source position: amigados.pas line 2604

function MatchPatternNoCase(

  const Pat: PChar;

  Str: PChar

):LongBool;

Arguments

Pat | Special pattern string to match as returned by ParsePattern()
Str | String to match against given pattern

Function result

Success or failure of pattern match. On failure, IoErr() will return 0 or ERROR_TOO_MANY_LEVELS

Description

The pattern must be a tokenized string output by ParsePattern(). This routine is case-insensitive.

NOTE: this routine is highly recursive. You must have at least 1500 free bytes of stack to call this (it will cut off it's recursion before going any deeper than that and return failure). That's currently enough for about 100 levels deep of #, (, ~, etc.

See also

ParsePattern | Create a tokenized string for MatchPattern()
MatchPattern | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern


MaxCli

Returns the highest CLI process number possibly in use

Declaration

Source position: amigados.pas line 2529

function MaxCli: LongWord;

Function result

The highest CLI number that may be in use.

Description

Returns the highest CLI number that may be in use. CLI numbers are reused, and are usually as small as possible. To find all CLIs, scan using FindCliProc() from 1 to MaxCLI(). The number returned by MaxCli() may change as processes are created and destroyed.

See also

FindCliProc | Returns a pointer to the requested CLI process
Cli | Returns a pointer to the CLI structure of the process


MKBADDR

Conbert a Pointer to a BPTR Value

Declaration

Source position: amigados.pas line 2732

function MKBADDR(

  adr: Pointer

):LongInt;


MountDevice

Declaration

Source position: amigados.pas line 2633

function MountDevice(

  const Name: PChar;

  Type_: LongInt;

  Tags: PTagItem

):LongInt;


NameFromFH

Get the name of an open filehandle

Declaration

Source position: amigados.pas line 2503

function NameFromFH(

  Fh: LongInt;

  Buffer: PChar;

  Len: LongInt

):LongBool;

Arguments

Fh | Lock of object to be examined.
Buffer | Buffer to store name.

Description

Returns a fully qualified path for the filehandle. This routine is guaranteed not to write more than len characters into the buffer. The name will be null-terminated. See NameFromLock() for more information.

Note: Older filesystems that don't support ExamineFH() will cause NameFromFH().

See also

NameFromLock | Returns the name of a locked object
ExamineFH | Gets information on an open file


NameFromLock

Returns the name of a locked object

Declaration

Source position: amigados.pas line 2502

function NameFromLock(

  Lock: LongInt;

  Buffer: PChar;

  Len: LongInt

):LongBool;

Arguments

Lock | Lock of object to be examined.
Buffer | Buffer to store name.

Description

Returns a fully qualified path for the lock. This routine is guaranteed not to write more than len characters into the buffer. The name will be null-terminated.

NOTE: if the volume is not mounted, the system will request it (unless of course you set pr_WindowPtr to -1). If the volume is not mounted or inserted, it will return an error. If the lock passed in is nil, 'SYS:' will be returned. If the buffer is too short, an error will be returned, and IoErr() will return ERROR_LINE_TOO_LONG.

See also

NameFromFH | Get the name of an open filehandle
Lock | Lock a directory or file


NameFromPort

Declaration

Source position: amigados.pas line 2714

function NameFromPort(

  Port: PMsgPort;

  Buffer: PChar;

  BufLen: LongInt;

  AddColon: LongInt

):LongInt;


NextDosEntry

Get the next Dos List entry

Declaration

Source position: amigados.pas line 2554

function NextDosEntry(

  const DList: PDOSList;

  Flags: LongWord

):PDOSList;

Arguments

DList | Structure given by LockDosList() or the last call to FindDosEntry().
Flags | The same flags as given to LockDosList() or a subset of them.

Description

Find the next Dos List entry of the right type. You must have locked the types you're looking for. Returns nil if there are no more of that type in the list.

See also

AddDosEntry | Add a Dos List entry to the lists
RemDosEntry | Removes a Dos List entry from it's list
FindDosEntry | Finds a specific Dos List entry
LockDosList | Locks the specified Dos Lists for use
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry


NonBlockingModifyDosEntry

Declaration

Source position: amigados.pas line 2614

function NonBlockingModifyDosEntry(

  Dl: PDOSList;

  Mode: LongInt;

  Arg1: Pointer;

  Arg2: Pointer

):LongInt;


NotifyDosListChange

Declaration

Source position: amigados.pas line 2691

function NotifyDosListChange(

  Process: PProcess;

  SignalNum: LongWord;

  Reserved: LongWord

):LongInt;


NotifyProcListChange

Declaration

Source position: amigados.pas line 2692

function NotifyProcListChange(

  Process: PProcess;

  SignalNum: LongWord;

  Reserved: LongWord

):LongInt;


NotifyVar

Declaration

Source position: amigados.pas line 2660

function NotifyVar(

  const Name: PChar;

  Hook: PHook;

  Flags: LongInt;

  const UserData: Pointer

):LongInt;


ObtainDirContext

Declaration

Source position: amigados.pas line 2699

function ObtainDirContext(

  const CTags: PTagItem

):Pointer;


OpenFromLock

Opens a file you have a lock on

Declaration

Source position: amigados.pas line 2498

function OpenFromLock(

  Lock: LongInt

):LongInt;

Arguments

Lock

Lock on object to be opened.

Function result

Newly opened file handle or nil for failure

Description

Given a lock, this routine performs an open on that lock. If the open succeeds, the lock is (effectively) relinquished, and should not be UnLock()ed or used. If the open fails, the lock is still usable. The lock associated with the file internally is of the same access mode as the lock you gave up - shared is similar to MODE_OLDFILE, exclusive is similar to MODE_NEWFILE.

See also

DosOpen | Open a file for input or output
DosClose |
Lock | Lock a directory or file
UnLock | Unlock a directory or file


ParentDir

Declaration

Source position: amigados.pas line 2460

function ParentDir(

  Lock: LongInt

):LongInt;

Arguments

Lock

Lock to get parent directory of.

Function result

Returns a lock to the parent directory or 0, in which case the supplied lock has no parent directory (because it is the root directory) or an error occured. IoErr() returns 0 in the former case and a different value on error.

Description

The argument lock is associated with a given file or directory. ParentDir() returns newlock which is associated the parent directory of lock.

Taking the ParentDir() of the root of the current filing system returns a 0 lock. Note this 0 lock represents the root of file system that you booted from (which is, in effect, the parent of all other file system roots.)

See also

Lock | Lock a directory or file
DupLock | Duplicate a lock
UnLock | Unlock a directory or file
ParentOfFH | Returns a lock on the parent directory of a file
DupLockFromFH | Gets a lock on an open file


ParentOfFH

Returns a lock on the parent directory of a file

Declaration

Source position: amigados.pas line 2499

function ParentOfFH(

  Fh: LongInt

):LongInt;

Arguments

Fh

Filehandle you want the parent of.

Function result

Lock on parent directory of the filehandle or nil for failure.

Description

Returns a shared lock on the parent directory of the filehandle.

See also

ParentDir |
Lock | Lock a directory or file
UnLock | Unlock a directory or file
DupLockFromFH | Gets a lock on an open file


ParseCapturePattern

Declaration

Source position: amigados.pas line 2621

function ParseCapturePattern(

  const Pat: PChar;

  Dst: PChar;

  Length: LongInt;

  CaseSen: LongInt

):LongInt;


ParsePattern

Create a tokenized string for MatchPattern()

Declaration

Source position: amigados.pas line 2581

function ParsePattern(

  const Pat: PChar;

  Buf: PChar;

  BufLen: LongInt

):LongInt;

Function result

1
There are wildcards in the pattern (it might match more than one string).
0
No wildcards in it, all went fine.
-1
An error happened. IoErr() gives additional information in that case.

Description

Tokenizes a pattern, for use by MatchPattern(). Also indicates if there are any wildcards in the pattern (i.e. whether it might match more than one item). Note that Dest must be at least 2 times as large as Source plus bytes to be (almost) 100% certain of no buffer overflow. This is because each input character can currently expand to 2 tokens (with one exception that can expand to 3, but only once per string). Note: this implementation may change in the future, so you should handle error returns in all cases, but the size above should still be a reasonable upper bound for a buffer allocation.

The patterns are fairly extensive, and approximate some of the ability of Unix/grep "regular expression" patterns. Here are the available tokens:

?
Matches a single character.
#
Matches the following expression 0 or more times.
(ab|cd)
Matches any one of the items seperated by '|'.
~
Negates the following expression. It matches all strings that do not match the expression (aka ~(foo) matches all strings that are not exactly 'foo').
[abc]
Character class: matches any of the characters in the class.
[~bc]
Character class: matches any of the characters not in the class.
a-z
Character range (only within character classes).
%
Matches 0 characters always (useful in '(foo|bar|%)').
*
Synonym for "#?", not available by default in 2.0. Available as an option that can be turned on.

'Expression' in the above table means either a single character (ex: "#?"), or an alternation (ex: "#(ab|cd|ef)"), or a character class (ex: "#[a-zA-Z]").

See also

ParsePatternNoCase | Create a tokenized string for MatchPatternNoCase()
MatchPattern | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern


ParsePatternNoCase

Create a tokenized string for MatchPatternNoCase()

Declaration

Source position: amigados.pas line 2603

function ParsePatternNoCase(

  const Pat: PChar;

  Buf: PChar;

  BufLen: LongInt

):LongInt;

Function result

1
There are wildcards in the pattern (it might match more than one string).
0
No wildcards in it, all went fine.
-1
An error happened. IoErr() gives additional information in that case.

Description

Tokenizes a pattern, for use by MatchPatternNoCase(). Also indicates if there are any wildcards in the pattern (i.e. whether it might match more than one item). Note that Dest must be at least 2 times as large as Source plus 2 bytes. For a description of the wildcards, see ParsePattern().

See also

ParsePattern | Create a tokenized string for MatchPattern()
MatchPattern | Checks for a pattern match with a string
MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
ToUpper | Convert a character to upper case.


PathPart

Returns a pointer to the end of the next-to-last component of a path.

Declaration

Source position: amigados.pas line 2587

function PathPart(

  const Path: PChar

):PChar;

Arguments

Path

Pointer to an path string. May be relative to the current directory or the current disk.

Function result

Pointer to the end of the next-to-last component of the path.

Description

This function returns a pointer to the character after the next-to-last component of a path specification, which will normally be the directory name. If there is only one component, it returns a pointer to the beginning of the string. The only real difference between this and FilePart() is the handling of '/'.

See also

FilePart | Returns the last component of a path
AddPart | Appends a file/dir to the end of a path


PrintFault

Returns the text associated with a DOS error code

Declaration

Source position: amigados.pas line 2514

function PrintFault(

  Code: LongInt;

  const Header: PChar

):LongBool;

Arguments

Code | Error code
Header | Header to output before error text

Description

This routine obtains the error message text for the given error code. This is similar to the Fault() function, except that the output is written to the default output channel with buffered output. The value returned by IoErr() is set to the code passed in.

See also

IoErr | Return extra information from the system
Fault | Returns the text associated with a DOS error code
SetIoErr | Sets the value returned by IoErr()
DosOutput | Identify the programs' initial output file handle
FPuts | Writes a string the the specified output


ProcessScan

Declaration

Source position: amigados.pas line 2690

function ProcessScan(

  Hook: PHook;

  const UserData: Pointer;

  Reserved: LongWord

):LongInt;


PutErrStr

Declaration

Source position: amigados.pas line 2630

function PutErrStr(

  const str: PChar

):LongInt;


PutStr

Writes a string the the default output (buffered)

Declaration

Source position: amigados.pas line 2599

function PutStr(

  const Str: PChar

):LongInt;

Function result

0 for success, -1 for any error. NOTE: this is opposite most Dos function returns!

Description

This routine writes an unformatted string to the default output. No newline is appended to the string and any error is returned. This routine is buffered.

See also

FPuts | Writes a string the the specified output
FPutC | Write a character to the specified output
FWrite | Writes a number of blocks to an output (buffered)
WriteChars | Writes bytes to the the default output (buffered)


ReadArgs

Read bytes of data from a file

Declaration

Source position: amigados.pas line 2574

function ReadArgs(

  const ArgTemplate: PChar;

  Array_: PLongInt;

  Args: PRDArgs

):PRDArgs;

Arguments

Array_

Array to be filled with the result values. The array must be intialized to the default values before calling ReadArgs().

Function result

A handle for the memory allocated by ReadArgs(). Must be freed with FreeArgs() later.

Description

Parses the commandline, a given string or DosInput() and fills an argument array according to the options template given. The array must be initialized to the wanted defaults before each call to ReadArgs(). If the rdargs argument is nilReadArgs() tries to parse the commandline and continues on the input channel if it just consists of a single '?', prompting the user for input.

The template string is given as a number of options separated by ',' and modified by '/' modifiers, e.g. 'NAME,WIDTH/N,HEIGHT/N' means get a name string and two numbers (width and height). The possible modifiers are:

/S
Option is a switch. It may be either set or left out.
/T
Option is a boolean value. Requires an argument which may be "ON", "YES" (setting the respective argument to 1), "OFF" or "NO" (setting the respective argument to 0).
/N
Option is a number. Strings are not allowed. If the option is optional, a pointer to the actual number is returned. This is how you know if it was really given. The number is always of type LONG.
/A
Argument is required. If it is left out ReadArgs() fails.
/K
The keyword must be given when filling the option. Normally it's skipped.
/M
Multiple strings or, when used in combination with /N, numbers. The result is returned as an array of pointers to strings or LONGs, and is terminated with NULL. /M eats all strings that don't fit into any other option. If there are unfilled /A arguments after parsing they steal strings from /M. This makes it possible to, for example, write a Copy command template like 'FROM/A/M,TO/A'. There may be only one /M option in a template.
/F
Eats the rest of the line even if there are option keywords in it.

See also

FindArg | Find a keyword in a template
ReadItem | Reads a single argument/name from command line
FreeArgs | Free allocated memory after ReadArgs()
AllocDosObject | Creates a dos object
FreeDosObject | Frees an object allocated by AllocDosObject()


ReadItem

Reads a single argument/name from command line

Declaration

Source position: amigados.pas line 2576

function ReadItem(

  const Name: PChar;

  MaxChars: LongInt;

  CSource: PCSource

):LongInt;

Arguments

MaxChars | Size of the buffer. Must be at least 1 (for the #0 terminator).
CSource | A ready to use TCSource structure or nil which means 'read from the input stream'.

Function result

ITEM_UNQUOTED
Normal word read.
ITEM_QUOTED
Quoted string read.
ITEM_NOTHING
End of line found. Nothing read.
ITEM_EQUAL
'=' read. Buffer is empty.
ITEM_ERROR
An error happened. IoErr() gives additional information in that case.

Description

Read an item from a given character source. Items are words or quoted strings separated by whitespace or '=' just like on the commandline. The separator is unread and the output string is terminated by a #0 character.

See also

ReadArgs | Read bytes of data from a file
FindArg | Find a keyword in a template
UnGetC | Makes a char available for reading again. (buffered)
FGetC | Read a character from the specified input (buffered)
DosInput | Identify the program's initial input file handle
FreeArgs | Free allocated memory after ReadArgs()


ReadLineItem

Declaration

Source position: amigados.pas line 2610

function ReadLineItem(

  Buffer: PChar;

  MaxChars: LongInt;

  TagList: PTagItem

):LongInt;


ReadSoftLink

Declaration

Source position: amigados.pas line 2508

function ReadSoftLink(

  Port: PMsgPort;

  Lock: LongInt;

  const Path: PChar;

  Size: LongWord

):LongInt;


Relabel

Change the volume name of a volume

Declaration

Source position: amigados.pas line 2559

function Relabel(

  const Drive: PChar;

  const NewName: PChar

):LongBool;

Arguments

Drive | Full name of device to rename (with ':')
NewName | New name to apply to device (without ':')

Description

Changes the volumename of a volume, if supported by the filesystem.


ReleaseCapturedExpressions

Declaration

Source position: amigados.pas line 2623

procedure ReleaseCapturedExpressions(

  First: PCapturedExpression

);


ReleaseConsoleData

Declaration

Source position: amigados.pas line 2712

procedure ReleaseConsoleData(

  Data: PConsoleWindowData

);


ReleaseDirContext

Declaration

Source position: amigados.pas line 2701

procedure ReleaseDirContext(

  Contx: Pointer

);


RemAssignList

Remove an entry from a multi-dir assign

Declaration

Source position: amigados.pas line 2545

function RemAssignList(

  const Name: PChar;

  Lock: LongInt

):LongBool;

Arguments

Name | Name of device to remove lock from (without trailing ':')
Lock | Lock associated with the object to remove from the list

Description

Remove an entry from a multi-dir assign. The entry removed will be the first one that the SameLock() function called on the lock parameter returns that they belong to the same object.

The entry for this lock will be removed from the lock, and the lock for the entry in the list will be unlocked.

See also

Lock | Lock a directory or file
AssignLock | Creates an assignment to a locked object
AssignPath | Creates an assignment to a specified path
AssignLate | Creates an assignment to a specified path later
DupLock | Duplicate a lock
AssignAdd | Adds a lock to an assign for multi-directory assigns
UnLock | Unlock a directory or file


RemDosEntry

Removes a Dos List entry from it's list

Declaration

Source position: amigados.pas line 2551

function RemDosEntry(

  DList: PDOSList

):LongBool;

Arguments

DList

Device list entry to be removed.

Description

This removes an entry from the Dos Device list. The memory associated with the entry is not freed. NOTE: you must have locked the Dos List with the appropriate flags before calling this routine. Handler writers should see the AddDosEntry() caveats about locking and use a similar workaround to avoid deadlocks.

See also

AddDosEntry | Add a Dos List entry to the lists
FindDosEntry | Finds a specific Dos List entry
NextDosEntry | Get the next Dos List entry
LockDosList | Locks the specified Dos Lists for use
MakeDosEntry | Creates a DosList structure
FreeDosEntry | Frees an entry created by MakeDosEntry


RemoveCmdPathNode

Declaration

Source position: amigados.pas line 2649

function RemoveCmdPathNode(

  Pn: PPathNode;

  Lock: LongInt

):PPathNode;


RemSegment

Removes a resident segment from the resident list

Declaration

Source position: amigados.pas line 2572

function RemSegment(

  Seg: PDosResidentSeg

):LongBool;

Arguments

Seg

The segment to be removed

Description

Removes a resident segment from the Dos resident segment list, unloads it, and does any other cleanup required. Will only succeed if the seg_UC (usecount) is 0.

See also

FindSegment | Finds a segment on the resident list
AddSegment | Adds a resident segment to the resident list


RenameDosEntry

Declaration

Source position: amigados.pas line 2669

function RenameDosEntry(

  const DList: PDOSList;

  const NewName: PChar

):LongInt;


ReplyPkt

Replies a packet to the person who sent it to you

Declaration

Source position: amigados.pas line 2475

procedure ReplyPkt(

  Dp: PDosPacket;

  Res1: LongInt;

  Res2: LongInt

);

Arguments

Dp | Packet to reply, assumed to set up correctly.
Res1 | First result
Res2 | Secondary result

Description

This returns a packet to the process which sent it to you. In addition, puts your pr_MsgPort address in dp_Port, so using ReplyPkt() again will send the message to you. (This is used in "ping-ponging" packets between two processes). It uses result 1 and 2 to set the dp_Res1 and dp_Res2dp_Res2 fields of the packet.

See also

DoPkt | Send a dos packet and wait for reply
SendPkt | Sends a packet to a handler
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
IoErr | Return extra information from the system


ResolvePath

Declaration

Source position: amigados.pas line 2726

function ResolvePath(

  Port: PMsgPort;

  const Path: PChar;

  InLock: LongInt;

  Out_: PChar;

  OutLen: LongWord;

  var OutDir: LongInt;

  var SLCount: LongWord

):LongInt;


RunCommand

Runs a program using the current process

Declaration

Source position: amigados.pas line 2521

function RunCommand(

  Seg: LongInt;

  Stack: LongWord;

  const ParamPtr: PChar;

  ParamLen: LongInt

):LongInt;

Function result

Return code from executed command. -1 indicates failure

Description

Runs a command on your process/cli. Seg may be any language, including BCPL programs. Stack is in bytes. paramptr is a null- terminated string, paramlen is its length. Returns the returncode the program exited. Returns -1 if the stack couldn't be allocated.

NOTE: the argument string must be terminated with a newline to work properly with ReadArgs() and other argument parsers.

RunCommand also takes care of setting up the current input filehandle in such a way that ReadArgs() can be used in the program, and restores the state of the buffering before returning. It also sets the value returned by GetArgStr(), and restores it before returning.

It's usually appropriate to set the command name before calling RunCommand(). RunCommand() sets the value returned by GetArgStr() while the command is running.

See also

CreateNewProc | Create a new process from taglist
SystemTagList | Have a shell execute a command line
Execute | Execute a CLI command
GetArgStr | Returns the arguments for the process
ReadArgs | Read bytes of data from a file


SameDevice

Are two locks are on partitions of the device?

Declaration

Source position: amigados.pas line 2606

function SameDevice(

  Lock1: LongInt;

  Lock2: LongInt

):LongBool;

Arguments

Lock1 | Lock to compare
Lock2 | Lock to compare

Function result

Whether they're on the same device as far as Dos can determine. DosTrue

Description

SameDevice() returns whether two locks refer to partitions that are on the same physical device (if it can figure it out). This may be useful in writing copy routines to take advantage of asynchronous multi-device copies.


SameFH

Declaration

Source position: amigados.pas line 2716

function SameFH(

  Scb1: LongInt;

  Scb2: LongInt

):LongInt;


SameLock

Returns whether two locks are on the same object

Declaration

Source position: amigados.pas line 2505

function SameLock(

  Lock1: LongInt;

  Lock2: LongInt

):LongInt;

Arguments

Lock1 | 1st lock for comparison
Lock2 | 2nd lock for comparison

Function result

LOCK_SAME, LOCK_SAME_HANDLER or LOCK_DIFFERENT

Description

Compares two locks. Returns LOCK_SAME if they are on the same object, LOCK_SAME_HANDLER if on different objects on the same volume, and LOCK_DIFFERENT if they are on different volumes. Always compare for equality or non-equality with the results, in case new return values are added.


ScanVars

Declaration

Source position: amigados.pas line 2653

function ScanVars(

  Hook: PHook;

  Flags: LongWord;

  const UserData: Pointer

):LongInt;


SearchCmdPathList

Declaration

Source position: amigados.pas line 2651

function SearchCmdPathList(

  Pn: PPathNode;

  h: PHook;

  const Name: PChar;

  const Tags: PTagItem

):LongInt;


SecondsToDateStamp

Declaration

Source position: amigados.pas line 2615

function SecondsToDateStamp(

  Seconds: LongWord;

  Ds: PDateStamp

):PDateStamp;


SelectErrorOutput

Declaration

Source position: amigados.pas line 2632

function SelectErrorOutput(

  Fh: LongInt

):LongInt;


SelectInput

Select a filehandle as the default input channel

Declaration

Source position: amigados.pas line 2481

function SelectInput(

  Fh: LongInt

):LongInt;

Arguments

Fh

Newly default input handle

Function result

Previous default input filehandle

Description

Set the current input as the default input for the process. This changes the value returned by DosInput(). old_fh should be closed or saved as needed.

See also

DosInput | Identify the program's initial input file handle
SelectOutput | Select a filehandle as the default output channel
DosOutput | Identify the programs' initial output file handle


SelectOutput

Select a filehandle as the default output channel

Declaration

Source position: amigados.pas line 2482

function SelectOutput(

  Fh: LongInt

):LongInt;

Arguments

Fh

Newly desired output handle

Function result

Previous current output

Description

Set the current output as the default output for the process. This changes the value returned by Output(). old_fh should be closed or saved as needed.

See also

DosInput | Identify the program's initial input file handle
SelectInput | Select a filehandle as the default input channel
DosOutput | Identify the programs' initial output file handle


SendPkt

Sends a packet to a handler

Declaration

Source position: amigados.pas line 2473

procedure SendPkt(

  Dp: PDosPacket;

  Port: PMsgPort;

  ReplyPort: PMsgPort

);

Arguments

Dp | Packet to send, must be initialized and have a message.
Port | pr_MsgPort of handler process to send to.
ReplyPort | MsgPort for the packet to come back to.

Description

Sends a packet to a handler and does not wait. All fields in the packet must be initialized before calling this routine. The packet will be returned to replyport. If you wish to use this with WaitPkt(), use the address of your pr_MsgPort for replyport.

See also

DoPkt | Send a dos packet and wait for reply
WaitPkt | Waits for a packet to arrive at your pr_MsgPort
AllocDosObject | Creates a dos object
FreeDosObject | Frees an object allocated by AllocDosObject()


Serialize

Declaration

Source position: amigados.pas line 2713

function Serialize(

  const Name: PChar

):LongInt;


SerializePort

Declaration

Source position: amigados.pas line 2722

function SerializePort(

  Port: PMsgPort

):LongBool;


SetArgStr

Sets the arguments for the current process

Declaration

Source position: amigados.pas line 2527

function SetArgStr(

  const String_: PChar

):PChar;

Arguments

String_

Pointer to new argument string.

Function result

The previous argument string, can be nil

Description

Sets the arguments for the current program. The ptr MUST be reset to it's original value before process exit.

See also

GetArgStr | Returns the arguments for the process
RunCommand | Runs a program using the current process


SetBlockingMode

Declaration

Source position: amigados.pas line 2645

function SetBlockingMode(

  Stream: LongInt;

  NewBlocking: LongInt

):LongInt;


SetCliCurrentDirName

Declaration

Source position: amigados.pas line 2530

function SetCliCurrentDirName(

  const Name: PChar

):LongInt;


SetCliProgramName

Declaration

Source position: amigados.pas line 2532

function SetCliProgramName(

  const Name: PChar

):LongInt;


SetCliPrompt

Declaration

Source position: amigados.pas line 2534

function SetCliPrompt(

  const Name: PChar

):LongInt;


SetComment

Change a files' comment string

Declaration

Source position: amigados.pas line 2455

function SetComment(

  const Name: PChar;

  const Comment: PChar

):LongBool;

Arguments

Name | Name of File to set comment
Comment | Comment to set

Description

SetComment() sets a comment on a file or directory. The comment is a pointer to a null-terminated string of up to 80 characters in the current ROM filesystem (and RAM:). Note that not all filesystems will support comments (for example, NFS usually will not), or the size of comment supported may vary.

See also

Examine | Examine a directory or file associated with a lock
ExNext | Examine the next entry in a directory
SetProtection | Set protection for a file or directory


SetConsolePort

Declaration

Source position: amigados.pas line 2523

function SetConsolePort(

  const Port: PMsgPort

):PMsgPort;


SetCurrentCmdPathList

Declaration

Source position: amigados.pas line 2646

function SetCurrentCmdPathList(

  Pn: PPathNode

):PPathNode;


SetCurrentDir

Declaration

Source position: amigados.pas line 2446

function SetCurrentDir(

  Lock: LongInt

):LongInt;


SetDate

Declaration

Source position: amigados.pas line 2501

function SetDate(

  const Name: PChar;

  const Date: PDateStamp

):LongBool;


SetFileHandleAttr

Declaration

Source position: amigados.pas line 2674

function SetFileHandleAttr(

  Fh: LongInt;

  const Tags: PTagItem

):LongInt;


SetFileSize

Sets the size of a file

Declaration

Source position: amigados.pas line 2511

function SetFileSize(

  Fh: LongInt;

  Pos: LongInt;

  Mode: LongInt

):LongBool;

Arguments

Mode

One of OFFSET_BEGINNING, OFFSET_CURRENT, or OFFSET_END.

Description

Changes the file size, truncating or extending as needed. Not all handlers may support this; be careful and check the return code. If the file is extended, no values should be assumed for the new bytes. If the new position would be before the filehandle's current position in the file, the filehandle will end with a position at the end-of-file. If there are other filehandles open onto the file, the new size will not leave any filehandle pointing past the end-of-file. You can check for this by looking at the new size (which would be different than what you requested).

The seek position should not be changed unless the file is made smaller than the current seek position. However, see Errors.

Do NOT count on any specific values to be in any extended area.

Errors

The RAM: filesystem and the normal Amiga filesystem act differently in where the file position is left after SetFileSize(). RAM: leaves you at the new end of the file (incorrectly), while the Amiga ROM filesystem leaves the seek position alone, unless the new position is less than the current position, in which case you're left at the new EOF.

The best workaround is to not make any assumptions about the seek position after SetFileSize().

See also

DosSeek

Set the current position for reading and writing


SetFileSysPort

Declaration

Source position: amigados.pas line 2525

function SetFileSysPort(

  const Port: PMsgPort

):PMsgPort;


SetIoErr

Sets the value returned by IoErr()

Declaration

Source position: amigados.pas line 2512

function SetIoErr(

  Result: LongInt

):LongInt;

Description

This routine sets up the secondary result (pr_Result2) return code (returned by the IoErr() function).

See also

IoErr | Return extra information from the system
Fault | Returns the text associated with a DOS error code
PrintFault | Returns the text associated with a DOS error code


SetMode

Set the current behavior of a handler

Declaration

Source position: amigados.pas line 2506

function SetMode(

  Fh: LongInt;

  Mode: LongInt

):LongBool;

Arguments

Fh | filehandle
Mode | The new mode you want

Description

SetMode() sends a packet to the handler in question, normally for changing a CON: handler to raw mode or vice-versa. For CON:, use 1 to go to RAW: mode, 0 for CON: mode.


SetOwner

Set owner information for a file or directory

Declaration

Source position: amigados.pas line 2608

function SetOwner(

  const Name: PChar;

  OwnerInfo: LongInt

):LongBool;

Arguments

Name

Name of file

Description

SetOwner() sets the owner information for the file or directory. This value is a 32-bit value that is normally split into 16 bits of owner user id (bits 31-16), and 16 bits of owner group id (bits 15-0). However, other than returning them as shown by Examine()/ ExNext()/ExAll(), the filesystem take no interest in the values. These are primarily for use by networking software (clients and hosts), in conjunction with the FIBF_OTR_* and FIBF_GRP_* protection bits.

See also

Examine | Examine a directory or file associated with a lock
ExNext | Examine the next entry in a directory
ExAll | Examine an entire directory


SetOwnerInfo

Declaration

Source position: amigados.pas line 2704

function SetOwnerInfo(

  const Tags: PTagItem

):LongInt;


SetProcWindow

Declaration

Source position: amigados.pas line 2635

function SetProcWindow(

  const Win: Pointer

):Pointer;


SetProgramDir

Sets the directory returned by GetProgramDir

Declaration

Source position: amigados.pas line 2536

function SetProgramDir(

  Lock: LongInt

):LongInt;

Arguments

Lock

A lock on the directory the current program was loaded from

Function result

The previous ProgramDir.

Description

Sets a shared lock on the directory the program was loaded from. This can be used for a program to find data files, etc, that are stored with the program, or to find the program file itself. Nil is a valid input. This can be accessed via GetProgramDir or by using paths relative to PROGDIR:.

See also

GetProgramDir | Returns a lock on the directory the program was loaded from
DosOpen | Open a file for input or output


SetProtection

Set protection for a file or directory

Declaration

Source position: amigados.pas line 2456

function SetProtection(

  const Name: PChar;

  Protect: LongInt

):LongBool;

Arguments

Name | Name of File
Protect | Protection Mask required

Description

Sets the protection attributes on a file or directory. Use FIBF_* for protection bits. The archive bit should be cleared by the filesystem whenever the file is changed. Backup utilities will generally set the bit after backing up each file.

See also

SetComment | Change a files' comment string
Examine | Examine a directory or file associated with a lock
ExNext | Examine the next entry in a directory


SetVar

Sets a local or environment variable

Declaration

Source position: amigados.pas line 2591

function SetVar(

  const Name: PChar;

  Buffer: PChar;

  Size: LongInt;

  Flags: LongWord

):LongBool;

Arguments

Name | pointer to an variable name. Note variable names follow filesystem syntax and semantics.
Buffer | a user allocated area which contains a string that is the value to be associated with this variable.
Size | combination of type of var to set (low 8 bits), and flags to control the behavior of this routine.

Function result

If non-zero, the variable was sucessfully set, False indicates failure.

Description

Sets a local or environment variable. It is advised to only use ASCII strings inside variables, but not required.

GVF_LOCAL_ONLY
set a local (to your process) variable.
GVF_GLOBAL_ONLY
set a global environment variable.

The default is to set a local environment variable.

See also

GetVar | Returns the value of a local or global variable
DeleteVar | Deletes a local or environment variable
FindVar | Finds a local variable


SetVBuf

Set buffering modes and size

Declaration

Source position: amigados.pas line 2496

function SetVBuf(

  Fh: LongInt;

  Buff: PChar;

  Type_: LongInt;

  Size: LongInt

):LongBool;

Arguments

Buff | Buffer pointer for buffered I/O or nil. Must be 4-aligned!
Type_ | buffering mode (BUF_*)
Size | Size of buffer for buffered I/O (sizes less than 208 bytes will be rounded up to 208), or -1.

Description

Changes the buffering modes and buffer size for a filehandle. With buff = nil, the current buffer will be deallocated and a new one of (approximately) size will be allocated. If buffer is non-nil, it will be used for buffering and must be at least max(size,208) bytes long, and must be longword aligned. If size is -1, then only the buffering mode will be changed.

Note that a user-supplied buffer will not be freed if it is later replaced by another SetVBuf() call, nor will it be freed if the filehandle is closed.

Has no effect on the buffersize of filehandles that were not created by AllocDosObject().

See also

FPutC | Write a character to the specified output
FGetC | Read a character from the specified input (buffered)
UnGetC | Makes a char available for reading again. (buffered)
DosFlush | Flushes buffers for a buffered filehandle
FRead | Reads a number of blocks from an input (buffered)
FWrite | Writes a number of blocks to an output (buffered)
FGets | Reads a line from the specified input (buffered)
FPuts | Writes a string the the specified output
AllocDosObject | Creates a dos object


SplitName

splits out a component of a pathname into a buffer

Declaration

Source position: amigados.pas line 2504

function SplitName(

  const Name: PChar;

  Seperator: LongWord;

  Buf: PChar;

  OldPos: LongInt;

  Size: LongInt

):LongInt;

Arguments

Name | Filename being parsed.
Seperator | Separator charactor to split by.
Buf | Buffer to hold separated name.
OldPos | Current position in the file.
Size | Size of buf in bytes (including null termination).

Function result

New position for next call to splitname. -1 for last one.

Description

This routine splits out the next piece of a name from a given file name. Each piece is copied into the buffer, truncating at size-1 characters. The new position is then returned so that it may be passed in to the next call to splitname. If the separator is not found within size characters, then size-1 characters plus a null will be put into the buffer, and the position of the next separator will be returned.

If a a separator cannot be found, -1 is returned (but the characters from the old position to the end of the string are copied into the buffer, up to a maximum of size-1 characters). Both strings are null-terminated.

This function is mainly intended to support handlers.

See also

FilePart | Returns the last component of a path
PathPart | Returns a pointer to the end of the next-to-last component of a path.
AddPart | Appends a file/dir to the end of a path


StartNotify

Starts notification on a file or directory

Declaration

Source position: amigados.pas line 2589

function StartNotify(

  Notify: PNotifyRequest

):LongBool;

Arguments

Notify

A filled-in NotifyRequest structure

Description

Posts a notification request. Do not modify the notify structure while it is active. You will be notified when the file or directory changes. For files, you will be notified after the file is closed. Not all filesystems will support this: applications should not require it. In particular, most network filesystems won't support it.

See also

EndNotify

Ends a notification request


StrToLong

string to Integer value (decimal)

Declaration

Source position: amigados.pas line 2577

function StrToLong(

  const String_: PChar;

  var Value: LongInt

):LongInt;

Arguments

String_ | Input string.
Value | Pointer to integer value. Set to 0 if no digits are converted.

Function result

Number of characters converted or -1.

Description

Converts decimal string into Integer value. Returns number of characters converted. Skips over leading spaces and tabs (included in count). If no decimal digits are found (after skipping leading spaces and tabs), StrToLong() returns -1 for characters converted, and puts 0 into value.


SubtractDates

Declaration

Source position: amigados.pas line 2619

function SubtractDates(

  To_: PDateStamp;

  const From_: PDateStamp

):LongInt;


SystemTagList

Have a shell execute a command line

Declaration

Source position: amigados.pas line 2538

function SystemTagList(

  const Command: PChar;

  const Tags: PTagItem

):LongInt;

Arguments

Command | Program and arguments
Tags | Tags for start (SYS_*) some (NP_*)

Description

Similar to Execute(), but does not read commands from the input filehandle. Spawns a Shell process to execute the command, and returns the returncode the command produced, or -1 if the command could not be run for any reason. The input and output filehandles will not be closed by System, you must close them (if needed) after System returns, if you specified them via SYS_Input or SYS_Output.

By default the new process will use your current DosInput() and Output() filehandles. Normal Shell command-line parsing will be done including redirection on command. The current directory and path will be inherited from your process. Your path will be used to find the command (if no path is specified).

Note that you may NOT pass the same filehandle for both SYS_Input and SYS_Output. If you want input and output to both be to the same CON: window, pass a SYS_Input of a filehandle on the CON: window, and pass a SYS_Output of nil. The shell will automatically set the default Output() stream to the window you passed via SYS_Input, by opening '*' on that handler.

If used with the SYS_Asynch flag, it will close both it's input and output filehandles after running the command (even if these were your DosInput() and Output()!)

Normally uses the boot (ROM) shell, but other shells can be specified via SYS_UserShell and SYS_CustomShell. Normally, you should send things written by the user to the UserShell. The UserShell defaults to the same shell as the boot shell.

The tags are passed through to CreateNewProc() (tags that conflict with SystemTagList() will be filtered out). This allows setting things like priority, etc for the new process. The tags that are currently filtered out are:

  • NP_Seglist
  • NP_FreeSeglist
  • NP_Entry
  • NP_Input
  • NP_Output
  • NP_CloseInput
  • NP_CloseOutput
  • NP_HomeDir
  • NP_Cli

See also

Execute | Execute a CLI command
CreateNewProc | Create a new process from taglist
DosInput | Identify the program's initial input file handle
DosOutput | Identify the programs' initial output file handle


SystemTags

Variable args version for SystemTagList for direct tag use.

Declaration

Source position: amigados.pas line 2737

function SystemTags(

  command: PChar;

  const argv: array of PtrUInt

):LongInt;


TimedDosRequester

Declaration

Source position: amigados.pas line 2667

function TimedDosRequester(

  const Tags: PTagItem

):LongInt;


TrackAddressList

Declaration

Source position: amigados.pas line 2625

function TrackAddressList(

  const Name: PChar;

  Segment: LongInt;

  const ExtraInfo: Pointer;

  ExtraInfoSize: LongInt;

  const Aas: PAddressAndSize;

  NumPairs: LongInt

):LongInt;


TrackSegmentList

Declaration

Source position: amigados.pas line 2626

function TrackSegmentList(

  const Name: PChar;

  Segment: LongInt;

  const ExtraInfo: Pointer;

  ExtraInfoSize: LongInt

):LongInt;


UnGetC

Makes a char available for reading again. (buffered)

Declaration

Source position: amigados.pas line 2485

function UnGetC(

  Fh: LongInt;

  Character: LongInt

):LongInt;

Arguments

Character

Character to push back or -1

Function result

Character pushed back, or False if the character cannot be pushed back.

Description

Pushes the character specified back into the input buffer. Every time you use a buffered read routine, you can always push back 1 character. You may be able to push back more, though it is not recommended, since there is no guarantee on how many can be pushed back at a given moment.

Passing -1 for the character will cause the last character read to be pushed back. If the last character read was an EOF, the next character read will be an EOF.

Note: UnGetC can be used to make sure that a filehandle is set up as a read filehandle. This is only of importance if you are writing a shell, and must manipulate the filehandle's buffer.


UnLoadSeg

Unload a seglist previously loaded by LoadSeg()

Declaration

Source position: amigados.pas line 2451

procedure UnLoadSeg(

  Seglist: LongInt

);

Arguments

Seglist

Pointer to a segment identifier

Description

Unload a seglist loaded by LoadSeg(). seglist> may be zero. Overlaid segments will have all needed cleanup done, including closing files.

See also

LoadSeg

Scatterload a loadable file into memory


UnLock

Unlock a directory or file

Declaration

Source position: amigados.pas line 2439

procedure UnLock(

  Lock: LongInt

);

Arguments

Lock

Lock to unlock, zero is harmless

Description

The filing system lock (obtained from Lock(), DupLock(), or CreateDir()) is removed and deallocated.

See also

Lock | Lock a directory or file
DupLock | Duplicate a lock
ParentOfFH | Returns a lock on the parent directory of a file
DupLockFromFH | Gets a lock on an open file


UnLockDosList

Unlocks the Dos List

Declaration

Source position: amigados.pas line 2549

procedure UnLockDosList(

  Flags: LongWord

);

Description

Unlocks the access on the Dos Device List. You must pass the same flags you used to lock the list.

See also

AttemptLockDosList | Attempt to lock the Dos Lists for use
LockDosList | Locks the specified Dos Lists for use
Permit | Permit task rescheduling.


UnLockRecord

Unlock a record

Declaration

Source position: amigados.pas line 2718

function UnLockRecord(

  Fh: LongInt;

  Offset: Int64;

  Length: Int64

):LongBool;

Arguments

Fh | File handle of locked file
Offset | Record start position
Length | Length of record in bytes

Description

This releases the specified lock on a file. Note that you must use the same filehandle you used to lock the record, and offset and length must be the same values used to lock it. Every LockRecord() call must be balanced with an UnLockRecord() call.

See also

LockRecords | Lock a series of records
LockRecord | Locks a portion of a file
UnLockRecords | Unlock a list of records


UnLockRecords

Unlock a list of records

Declaration

Source position: amigados.pas line 2480

function UnLockRecords(

  RecArray: PRecordLock

):LongBool;

Arguments

RecArray

List of records to be unlocked

Description

This releases an array of record locks obtained using LockRecords. You should not modify the record_array while you have the records locked. Every LockRecords() call must be balanced with an UnLockRecords() call.

See also

LockRecords | Lock a series of records
LockRecord | Locks a portion of a file
UnLockRecord | Unlock a record


UnTrackAddress

Declaration

Source position: amigados.pas line 2627

procedure UnTrackAddress(

  Address: Pointer

);


UnTrackSegmentList

Declaration

Source position: amigados.pas line 2628

procedure UnTrackSegmentList(

  Segment: LongInt

);


VFPrintf

format and print a string to a file (buffered)

Declaration

Source position: amigados.pas line 2492

function VFPrintf(

  Fh: LongInt;

  const Format: PChar;

  const ArgArray: Pointer

):LongInt;

Arguments

Fh | Filehandle to write to
Format | RawDoFmt() style formatting string
ArgArray | Pointer to array of formatting values

Function result

Number of bytes written or -1 (EOF) for an error

Description

Writes the formatted string and values to the given file. This routine is assumed to handle all internal buffering so that the formatting string and resultant formatted values can be arbitrarily long. Any secondary error code is returned in IoErr(). This routine is buffered.

See also

VPrintf | Format and print string (buffered)
RawDoFmt | Format data into a character stream.
FPutC | Write a character to the specified output


VPrintf

Format and print string (buffered)

Declaration

Source position: amigados.pas line 2600

function VPrintf(

  const Format: PChar;

  const ArgArray: PLongInt

):LongInt;

Arguments

Format | exec.library RawDoFmt style formatting string
ArgArray | Pointer to array of formatting values

Function result

Number of bytes written or -1 (EOF) for an error

Description

Writes the formatted string and values to DosOutput(). This routine is assumed to handle all internal buffering so that the formatting string and resultant formatted values can be arbitrarily long. Any secondary error code is returned in IoErr(). This routine is buffered.

Note: RawDoFmt assumes 16 bit ints, so you will usually need 'l's in your formats (ex: %ld versus %d).

See also

VFPrintf | format and print a string to a file (buffered)
RawDoFmt | Format data into a character stream.
FPutC | Write a character to the specified output


WaitForChar

Determine if chars arrive within a time limit

Declaration

Source position: amigados.pas line 2459

function WaitForChar(

  File_: LongInt;

  TimeOut: LongInt

):LongBool;

Arguments

File_ | BCPL pointer to a file handle
TimeOut | In miliseconds

Description

If a character is available to be read from file within the time (in microseconds) indicated by timeout, WaitForChar() returns -1 (True). If a character is available, you can use Read() to read it. Note that WaitForChar() is only valid when the I/O stream is connected to a virtual terminal device. If a character is not available within timeout, a 0 (False) is returned.

See also

DosRead | Read bytes of data from a file
FGetC | Read a character from the specified input (buffered)


WaitForData

Declaration

Source position: amigados.pas line 2644

function WaitForData(

  Stream: LongInt;

  DataDirection: LongInt;

  TimeOut: LongInt

):LongInt;


WaitPkt

Waits for a packet to arrive at your pr_MsgPort

Declaration

Source position: amigados.pas line 2474

function WaitPkt: PDosPacket;

Function result

the packet that arrived at the port (from ln_Name of message).

Description

Waits for a packet to arrive at your pr_MsgPort. If anyone has installed a packet wait function in pr_PktWait, it will be called. The message will be automatically GetMsg()ed so that it is no longer on the port. It assumes the message is a dos packet. It is not guaranteed to clear the signal for the port.

See also

SendPkt | Sends a packet to a handler
DoPkt | Send a dos packet and wait for reply


WriteChars

Writes bytes to the the default output (buffered)

Declaration

Source position: amigados.pas line 2598

function WriteChars(

  const Buf: PChar;

  BufLen: LongWord

):LongInt;

Arguments

Buf | Buffer of characters to write
BufLen | Number of characters to write

Function result

Number of bytes written. -1 (EOF) indicates an error

Description

This routine writes a number of bytes to the default output. The length is returned. This routine is buffered.

See also

FPuts | Writes a string the the specified output
FPutC | Write a character to the specified output
FWrite | Writes a number of blocks to an output (buffered)
PutStr | Writes a string the the default output (buffered)


WriteProtectVolume

Declaration

Source position: amigados.pas line 2695

function WriteProtectVolume(

  const Name: PChar;

  OnOff: LongInt;

  PassKey: LongWord;

  Reserved: LongWord

):LongInt;


WriteProtectVolumePort

Declaration

Source position: amigados.pas line 2727

function WriteProtectVolumePort(

  Port: PMsgPort;

  OnOff: LongInt;

  PassKey: LongWord;

  Reserved: LongInt

):LongInt;


Reference for unit 'asl': Procedures and functions

AbortAslRequest

ActivateAslRequest

AllocAslRequest

AllocAslRequestTags

AllocFileRequest

AslAllocVec

ASLClone

AslControl

AslControlTags

ASLExpunge

AslFreeVec

ASLObtain

ASLRelease

AslRequest

AslRequestTags

FreeAslRequest

FreeFileRequest

RequestFile


Unit 'asl' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'asl': Variables

ASLBase

IASL


Index of all identifiers in unit 'asl'

A F I P R T

A

AbortAslRequest | ASLFR_Activate | ASLPOS_DefaultPosition
ActivateAslRequest | ASLFR_DoMultiSelect | ASLPOS_MASK
AllocAslRequest | ASLFR_DoPatterns | ASLPOS_ScreenPosition
AllocAslRequestTags | ASLFR_DoSaveMode | ASLPOS_WindowPosition
AllocFileRequest | ASLFR_DrawersOnly | ASLRelease
AslAllocVec | AslFreeVec | AslRequest
ASLBase | ASLFR_FilterDrawers | AslRequestTags
ASLClone | ASLFR_FilterFunc | ASL_ScreenModeRequest
AslControl | ASLFR_Flags1 | ASL_SEMAPHORE_NAME
AslControlTags | ASLFR_Flags2 | ASLSIZE_DefaultSize
ASL_Dummy | ASLFR_GetSortBy | ASLSIZE_MASK
ASLExpunge | ASLFR_GetSortDrawers | ASLSIZE_RelativeSize
ASL_FileRequest | ASLFR_GetSortOrder | ASLSM_Activate
ASLFO_Activate | ASLFR_HookFunc | ASLSM_CustomSMList
ASLFO_BackPens | ASLFR_InitialDrawer | ASLSM_DoAutoScroll
ASLFO_DoBackPen | ASLFR_InitialFile | ASLSM_DoDepth
ASLFO_DoDrawMode | ASLFR_InitialHeight | ASLSM_DoHeight
ASLFO_DoFrontPen | ASLFR_InitialLeftEdge | ASLSM_DoOverscanType
ASLFO_DoStyle | ASLFR_InitialPattern | ASLSM_DoWidth
ASLFO_FilterFunc | ASLFR_InitialShowVolumes | ASLSM_FilterFunc
ASLFO_FixedWidthOnly | ASLFR_InitialTopEdge | ASLSM_InitialAutoScroll
ASLFO_Flags | ASLFR_InitialWidth | ASLSM_InitialDisplayDepth
ASLFO_FrontPens | ASLFR_IntuiMsgFunc | ASLSM_InitialDisplayHeight
ASLFO_HookFunc | ASLFR_Locale | ASLSM_InitialDisplayID
ASLFO_InitialBackPen | ASLFR_NegativeText | ASLSM_InitialDisplayWidth
ASLFO_InitialDrawMode | ASLFR_PopToFront | ASLSM_InitialHeight
ASLFO_InitialFlags | ASLFR_PositiveText | ASLSM_InitialInfoLeftEdge
ASLFO_InitialFrontPen | ASLFR_PrivateIDCMP | ASLSM_InitialInfoOpened
ASLFO_InitialHeight | ASLFR_PubScreenName | ASLSM_InitialInfoTopEdge
ASLFO_InitialLeftEdge | ASLFR_RejectIcons | ASLSM_InitialLeftEdge
ASLFO_InitialName | ASLFR_RejectPattern | ASLSM_InitialOverscanType
ASLFO_InitialSize | ASLFR_Screen | ASLSM_InitialTopEdge
ASLFO_InitialStyle | ASLFR_SetSortBy | ASLSM_InitialWidth
ASLFO_InitialTopEdge | ASLFR_SetSortDrawers | ASLSM_IntuiMsgFunc
ASLFO_InitialWidth | ASLFR_SetSortOrder | ASLSM_Locale
ASLFO_IntuiMsgFunc | ASLFR_SleepWindow | ASLSM_MaxDepth
ASLFO_Locale | ASLFRSORTBY_Date | ASLSM_MaxHeight
ASLFO_MaxBackPen | ASLFRSORTBY_Name | ASLSM_MaxWidth
ASLFO_MaxFrontPen | ASLFRSORTBY_Size | ASLSM_MinDepth
ASLFO_MaxHeight | ASLFRSORTDRAWERS_First | ASLSM_MinHeight
ASLFO_MinHeight | ASLFRSORTDRAWERS_Last | ASLSM_MinWidth
ASLFO_ModeList | ASLFRSORTDRAWERS_Mix | ASLSM_NegativeText
ASLFO_NegativeText | ASLFRSORTORDER_Ascend | ASLSM_PopToFront
ASL_FontRequest | ASLFRSORTORDER_Descend | ASLSM_PositiveText
ASLFO_PopToFront | ASLFR_StayOnTop | ASLSM_PrivateIDCMP
ASLFO_PositiveText | ASLFR_TextAttr | ASLSM_PropertyFlags
ASLFO_PrivateIDCMP | ASLFR_TitleText | ASLSM_PropertyMask
ASLFO_PubScreenName | ASLFR_UserData | ASLSM_PubScreenName
ASLFO_SampleText | ASLFR_Window | ASLSM_Screen
ASLFO_Screen | ASL_LAST_TAG | ASLSM_SleepWindow
ASLFO_SleepWindow | ASLNAME | ASLSM_TextAttr
ASLFO_TextAttr | ASLObtain | ASLSM_TitleText
ASLFO_TitleText | ASLOPTION_ASLOverrides | ASLSM_UserData
ASLFO_UserData | ASLPOS_CenterMouse | ASLSM_Window
ASLFO_Window | ASLPOS_CenterScreen |
ASLFR_AcceptPattern | ASLPOS_CenterWindow |

F

FOB_DOBACKPEN | FOF_FILTERFUNC | FRB_REJECTICONS
FOB_DODRAWMODE | FOF_FIXEDWIDTHONLY | FreeAslRequest
FOB_DOFRONTPEN | FOF_INTUIFUNC | FreeFileRequest
FOB_DOSTYLE | FOF_PRIVATEIDCMP | FRF_DOMULTISELECT
FOB_FILTERFUNC | FRB_DOMULTISELECT | FRF_DOPATTERNS
FOB_FIXEDWIDTHONLY | FRB_DOPATTERNS | FRF_DOSAVEMODE
FOB_INTUIFUNC | FRB_DOSAVEMODE | FRF_DRAWERSONLY
FOB_PRIVATEIDCMP | FRB_DRAWERSONLY | FRF_FILTERDRAWERS
FOF_DOBACKPEN | FRB_FILTERDRAWERS | FRF_FILTERFUNC
FOF_DODRAWMODE | FRB_FILTERFUNC | FRF_INTUIFUNC
FOF_DOFRONTPEN | FRB_INTUIFUNC | FRF_PRIVATEIDCMP
FOF_DOSTYLE | FRB_PRIVATEIDCMP | FRF_REJECTICONS

I

IASL

P

PASLSemaphore | PFileRequester | PScreenModeRequester
PDisplayMode | PFontRequester |

R

RequestFile

T

TASLSemaphore | TFileRequester | TScreenModeRequester
TDisplayMode | TFontRequester |


AbortAslRequest

Declaration

Source position: asl.pas line 516

procedure AbortAslRequest(

  Requester: Pointer

);


ActivateAslRequest

Declaration

Source position: asl.pas line 517

procedure ActivateAslRequest(

  Requester: Pointer

);


AllocAslRequest

Declaration

Source position: asl.pas line 509

function AllocAslRequest(

  ReqType: LongWord;

  TagList: PTagItem

):Pointer;


AllocAslRequestTags

Declaration

Source position: asl.pas line 521

function AllocAslRequestTags(

  ReqType: LongWord;

  const Tags: array of PtrUInt

):Pointer;


AllocFileRequest

Declaration

Source position: asl.pas line 506

function AllocFileRequest: PFileRequester;


AslAllocVec

Declaration

Source position: asl.pas line 515

function AslAllocVec(

  ByteSize: LongWord;

  Attributes: LongWord

):Pointer;


ASLClone

Declaration

Source position: asl.pas line 505

function ASLClone: PInterface;


AslControl

Declaration

Source position: asl.pas line 518

function AslControl(

  const Tags: PTagItem

):LongWord;


AslControlTags

Declaration

Source position: asl.pas line 523

function AslControlTags(

  const Tags: array of PtrUInt

):LongWord;


ASLExpunge

Declaration

Source position: asl.pas line 504

procedure ASLExpunge;


AslFreeVec

Declaration

Source position: asl.pas line 514

procedure AslFreeVec(

  Memory: Pointer

);


ASLObtain

Declaration

Source position: asl.pas line 502

function ASLObtain: LongWord;


ASLRelease

Declaration

Source position: asl.pas line 503

function ASLRelease: LongWord;


AslRequest

Declaration

Source position: asl.pas line 512

function AslRequest(

  Requester: Pointer;

  TagList: PTagItem

):LongBool;


AslRequestTags

Declaration

Source position: asl.pas line 522

function AslRequestTags(

  Requester: Pointer;

  const Tags: array of PtrUInt

):LongBool;


FreeAslRequest

Declaration

Source position: asl.pas line 511

procedure FreeAslRequest(

  Requester: Pointer

);


FreeFileRequest

Declaration

Source position: asl.pas line 507

procedure FreeFileRequest(

  FileReq: PFileRequester

);


RequestFile

Declaration

Source position: asl.pas line 508

function RequestFile(

  FileReq: PFileRequester

):LongBool;


Reference for unit 'console': Procedures and functions

AddConSnipHook

CDInputHandler

GetConSnip

RawKeyConvert

RemConSnipHook

SetConSnip


Reference for unit 'console': Variables

ConsoleDevice

IConsoleDevice


Index of all identifiers in unit 'console'

A C D G I M R S T

A

AddConSnipHook

C

CD_ASKDEFAULTKEYMAP | CD_SETDEFAULTKEYMAP | CTC_HCLRTAB
CD_ASKKEYMAP | CD_SETKEYMAP | CTC_HCLRTABSALL
CDInputHandler | ConsoleDevice | CTC_HSETTAB

D

DSR_CPR

G

GetConSnip

I

IConsoleDevice

M

M_ASM M_AWM M_LNM

R

RawKeyConvert RemConSnipHook

S

SetConSnip | SGR_CLR4BG | SGR_MAGENTABG
SGR_BLACK | SGR_CLR5 | SGR_NEGATIVE
SGR_BLACKBG | SGR_CLR5BG | SGR_NORMAL
SGR_BLUE | SGR_CLR6 | SGR_NOTITALIC
SGR_BLUEBG | SGR_CLR6BG | SGR_NOTUNDERSCORE
SGR_BOLD | SGR_CLR7 | SGR_POSITIVE
SGR_CLR0 | SGR_CLR7BG | SGR_PRIMARY
SGR_CLR0BG | SGR_CYAN | SGR_RED
SGR_CLR1 | SGR_CYANBG | SGR_REDBG
SGR_CLR1BG | SGR_DEFAULT | SGR_UNDERSCORE
SGR_CLR2 | SGR_DEFAULTBG | SGR_WHITE
SGR_CLR2BG | SGR_GREEN | SGR_WHITEBG
SGR_CLR3 | SGR_GREENBG | SGR_YELLOW
SGR_CLR3BG | SGR_ITALIC | SGR_YELLOWBG
SGR_CLR4 | SGR_MAGENTA |

T

TBC_HCLRTAB TBC_HCLRTABSALL


AddConSnipHook

Declaration

Source position: console.pas line 120

procedure AddConSnipHook(

  Hook: PHook

);


CDInputHandler

Declaration

Source position: console.pas line 116

function CDInputHandler(

  Events: PInputEvent;

  ConsoleDev: PLibrary

):PInputEvent;


GetConSnip

Declaration

Source position: console.pas line 118

function GetConSnip: Pointer;


RawKeyConvert

Declaration

Source position: console.pas line 117

function RawKeyConvert(

  Events: PInputEvent;

  Buffer: PChar;

  Length: LongInt;

  KeyMap: PKeyMap

):LongInt;


RemConSnipHook

Declaration

Source position: console.pas line 121

procedure RemConSnipHook(

  Hook: PHook

);


SetConSnip

Declaration

Source position: console.pas line 119

function SetConSnip(

  Param: Pointer

):LongInt;


Reference for unit 'cybergraphics': Procedures and functions

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
BestCModeIDTagList | Calculate the best ModeID with given parameters
BestCModeIDTags | VarArgs version of BestCModeIDTagList
BltTemplateAlpha
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList
CVideoCtrlTagList | Control video output
CVideoCtrlTags | VarArgs version of CVideoCtrlTagList
CyberGfxClone
CyberGfxExpunge
CyberGfxObtain
CyberGfxRelease
DoCDrawMethodTagList | Do the given hook for the supplied rastport
DoCDrawMethodTags | VarArgs Version of DoCDrawMethodTagList
DOWNSHIFT_PIXFMT
ExtractColor | Extract the specified colour/CLUT value from a given CyberGraphX RastPort
FillPixelArray | fill a rectangular area with the supplied ARGB
FreeCModeList | Frees a previously allocated ModeList
GetCyberIDAttr | Returns information about a cybergraphics ID
GetCyberMapAttr | Returns information about a cybergraphics bitmap
InvertPixelArray | Invert a rectangular area
IsCyberModeID | Returns whether supplied ModeID is a cybergraphics ID
LockBitMapTagList | Lock supplied BitMap for a short amount of time to allow direct memory access
LockBitMapTags | VarArgs version of LockBitMapTagList
MovePixelArray | move the color values of a rectangular area
ReadPixelArray | Read the color values of a rectangular array
ReadRGBPixel | Reads a pixel from a specified location
ScalePixelArray | Scale the colors values of a rectangular array (V41)
SHIFT_PIXFMT |
UnLockBitMap | Unlock CyberGraphX BitMap that was previously locked
UnLockBitMapTagList | Unlock CyberGraphX BitMap that was previously
UnLockBitMapTags | VarArgs Version of UnLockBitMapTagList
WriteLUTPixelArray | write the color value generated from a given color table (V41)
WritePixelArray | write the color value of a rectangular array
WritePixelArrayAlpha
WriteRGBPixel | Writes a pixel to a specified location


Reference for unit 'cybergraphics': Variables

CyberGfxBase

CyberGraphics library base structure

ICyberGfx


Index of all identifiers in unit 'cybergraphics'

A B C D E F G I L M P R S T U W

A

AllocCModeListTagList AllocCModeListTags

B

BestCModeIDTagList | BltTemplateAlpha | BMF_SPECIALFMT
BestCModeIDTags | BMB_SPECIALFMT |

C

CModeRequestTagList | CYBRBIDTG_NominalHeight | CYBRMATTR_PIXFMT_ALPHA
CModeRequestTags | CYBRBIDTG_NominalWidth | CYBRMATTR_WIDTH
CTABFMT_XRGB8 | CYBRBIDTG_TB | CYBRMATTR_XMOD
CVideoCtrlTagList | CYBRIDATTR_BPPIX | CYBRMREQ_CancelText
CVideoCtrlTags | CYBRIDATTR_DEPTH | CYBRMREQ_CModelArray
CyberGfxBase | CYBRIDATTR_HEIGHT | CYBRMREQ_MaxDepth
CyberGfxClone | CYBRIDATTR_PIXFMT | CYBRMREQ_MaxHeight
CyberGfxExpunge | CYBRIDATTR_WIDTH | CYBRMREQ_MaxWidth
CYBERGFX_INCLUDE_VERSION | CYBRMATTR_BPPIX | CYBRMREQ_MinDepth
CYBERGFXNAME | CYBRMATTR_DEPTH | CYBRMREQ_MinHeight
CyberGfxObtain | CYBRMATTR_DISPADR | CYBRMREQ_MinWidth
CyberGfxRelease | CYBRMATTR_HEIGHT | CYBRMREQ_OKText
CYBRBIDTG_BoardName | CYBRMATTR_ISCYBERGFX | CYBRMREQ_Screen
CYBRBIDTG_Depth | CYBRMATTR_ISLINEARMEM | CYBRMREQ_TB
CYBRBIDTG_MonitorID | CYBRMATTR_PIXFMT | CYBRMREQ_WinTitle

D

DoCDrawMethodTagList | DPMS_OFF | DPMS_SUSPEND
DoCDrawMethodTags | DPMS_ON |
DOWNSHIFT_PIXFMT | DPMS_STANDBY |

E

ExtractColor

F

FillPixelArray FreeCModeList

G

GetCyberIDAttr GetCyberMapAttr

I

ICyberGfx InvertPixelArray IsCyberModeID

L

LBMI_BASEADDRESS | LBMI_DEPTH | LBMI_WIDTH
LBMI_BYTESPERPIX | LBMI_HEIGHT | LockBitMapTagList
LBMI_BYTESPERROW | LBMI_PIXFMT | LockBitMapTags

M

MovePixelArray

P

PCDrawMsg | PIXFMT_BGR16PC | PIXFMT_RGB16
PCyberModeNode | PIXFMT_BGR24 | PIXFMT_RGB16PC
PIXFMT_ARGB32 | PIXFMT_BGRA32 | PIXFMT_RGB24
PIXFMT_BGR15 | PIXFMT_LUT8 | PIXFMT_RGBA32
PIXFMT_BGR15PC | PIXFMT_RGB15 |
PIXFMT_BGR16 | PIXFMT_RGB15PC |

R

ReadPixelArray | RECTFMT_GREY8 | RECTFMT_RGB
ReadRGBPixel | RECTFMT_LUT8 | RECTFMT_RGBA
RECTFMT_ARGB | RECTFMT_RAW |

S

ScalePixelArray SETVC_DPMSLevel SHIFT_PIXFMT

T

TCDrawMsg TCyberModeNode

U

UBMI_REALLYUNLOCK | UnLockBitMap | UnLockBitMapTags
UBMI_UPDATERECTS | UnLockBitMapTagList |

W

WriteLUTPixelArray | WritePixelArrayAlpha
WritePixelArray | WriteRGBPixel


AllocCModeListTagList

Get an exec list with requested modes

Declaration

Source position: cybergraphics.pas line 159

function AllocCModeListTagList(

  ModeListTags: PTagItem

):PList;

Arguments

ModeListTags

Pointer to an optional tag list which may be used to control the number of returned modes

Function result

nil if no modes are available, a pointer to a exec list if there are modes which fit your needs. Use FreeCModeList to free it after use.

Description

Allocates a list structure which contains all requested modes (All nodes are of type CyberModeNode). See defines for more information about the structure of this nodes.

Available Tags:

CYBRMREQ_MinWidth
(LongWord) The minimum display width to let the user choose. Default is 320.
CYBRMREQ_MaxWidth
(LongWord) The maximum display width to let the user choose. Default is 1600.
CYBRMREQ_MinHeight
(LongWord) The minimum display height to let the user choose. Default is 240.
CYBRMREQ_MaxHeight
(LongWord) The maximum display height to let the user choose. Default is 1200.
CYBRMREQ_MinDepth
(Word) The minimum display depth to let the user choose. Default is 8.
CYBRMREQ_MaxDepth
(Word) The maximum display depth to let the user choose. Default is 32.
CYBRMREQ_CModelArray
(PWord) Array of color models which should be available for screenmode selection. Currently supported colormodels are: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32 default is all colormodels available, nothing filtered

See also

AllocCModeListTags | VarArgs version of AllocCModeListTagList
FreeCModeList | Frees a previously allocated ModeList


AllocCModeListTags

VarArgs version of AllocCModeListTagList

Declaration

Source position: cybergraphics.pas line 192

function AllocCModeListTags(

  const ModeListTags: array of PtrUInt

):PList;

See also

AllocCModeListTagList | Get an exec list with requested modes
FreeCModeList | Frees a previously allocated ModeList


BestCModeIDTagList

Calculate the best ModeID with given parameters

Declaration

Source position: cybergraphics.pas line 155

function BestCModeIDTagList(

  BestModeIDTags: PTagItem

):LongWord;

Arguments

BestModeIDTags

Pointer to an array of TagItems describing the wanted screen mode

Function result

DisplayID of the best mode to use, or INVALID_ID if a match could not be found.

Description

Returns the CyberGraphX displaymode ID which fits best for the parameters supplied in the TagList.

Available Tags:

CYBRBIDTG_Depth
(Word) Depth the returned ModeID must support. Default is 8
CYBRBIDTG_NominalWidth
(Word) desired width the ModeID should have
CYBRBIDTAG_NominalHeight
(Word) desired height the ModeID should have
CYBRBIDTG_MonitorID

(LongWord) if multiple graphics boards are installed in the system, you can choose the desired one with this tag Currently supported boards are:

  • 1 = CVision64
  • 2 = Piccolo
  • 3 = PicassoII
  • 4 = Spectrum
  • 5 = Domino
  • 6 = RetinaZ3/DraCoAltais
  • 7 = PiccoSD64
  • 8 = A2410
  • 13 = CVision3D (V41)
  • 14 = Inferno (V41)
  • 15 = PicassoIV (V41)
CYBRBIDTG_BoardName
(STRPTR) - Specify the card name directly. For example, pass 'CVision3D' to get a CyberVision64/3D board ID

Errors

Older versions return displaymode IDs with wrong depth if the desired color depth is not available. If you specify very small widths/heights (e.g. 50/20 icon size) this call returns INVALID_ID instead of the smallest available lowres ID.

See also

BestCModeIDTags

VarArgs version of BestCModeIDTagList


BestCModeIDTags

VarArgs version of BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 193

function BestCModeIDTags(

  const BestModeIDTags: array of PtrUInt

):LongWord;


BltTemplateAlpha

Declaration

Source position: cybergraphics.pas line 189

procedure BltTemplateAlpha(

  SrcTemplate: Pointer;

  SrcX: LongInt;

  SrcY: LongInt;

  Rp: PRastPort;

  DestX: LongInt;

  DestY: LongInt;

  Width: LongWord;

  Height: LongWord

);


CModeRequestTagList

Get screenmode from user using a requester.

Declaration

Source position: cybergraphics.pas line 157

function CModeRequestTagList(

  ModeRequest: Pointer;

  ModeRequestTags: PTagItem

):LongWord;

Arguments

ModeRequest | not used currently. You have to set it to nil!
ModeRequestTags | Pointer to an optional tag list which may be used to control features of the requester

Function result

0 if the user cancelled the requester or if something prevented the requester from opening. If <> 0 the displaymode ID of the selected screenmode is returned.

Description

Prompts the user for input by showing all available CyberGraphX screenmodes in a requester. If the user cancels or the system aborts the request, 0 is returned, otherwise the displaymode ID of the selected screenmode.

Available Tags:

CYBRMREQ_Screen
(PScreen) Screen on which to open the requester. Default locale will be used.
CYBRMREQ_WinTitle
(PChar) Title to use for the requesting window.
CYBRMREQ_OKText
(PChar) Label of the positive gadget in the requester. English default is 'OK'.
CYBRMREQ_CancelText
(PChar) Label of the negative gadget in the requester. English default is 'Cancel'.
CYBRMREQ_MinWidth
(LongWord) The minimum display width to let the user choose. Default is 320.
CYBRMREQ_MaxWidth
(LongWord) The maximum display width to let the user choose. Default is 1600.
CYBRMREQ_MinHeight
(LongWord) The minimum display height to let the user choose. Default is 240.
CYBRMREQ_MaxHeight
(LongWord) The maximum display height to let the user choose. Default is 1200.
CYBRMREQ_MinDepth
(Word) The minimum display depth to let the user choose. Default is 8.
CYBRMREQ_MaxDepth
(Word) The maximum display depth to let the user choose. Default is 32.
CYBRMREQ_CModelArray
(PWord) Array of color models which should be available for screenmode selection. Currently supported colormodels are: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32 default is all colormodels available, nothing filtered

Errors

The requester structure is not supported. You should better use asl.library/AslRequest() instead.

See also

AslRequest()

CModeRequestTags

VarArgs version of CModeRequestTagList


CModeRequestTags

VarArgs version of CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 194

function CModeRequestTags(

  ModeRequest: Pointer;

  const ModeRequestTags: array of PtrUInt

):LongWord;


CVideoCtrlTagList

Control video output

Declaration

Source position: cybergraphics.pas line 176

procedure CVideoCtrlTagList(

  Vp: PViewPort;

  TagList: PTagItem

);

Arguments

TagList

Pointer to Taglist to control operation

Description

This function controls the video output of the gfx board to which the specified ViewPort belongs to.

Available Tags

SETVC_DPMSLevel

(LongWord) Set the DPMS level for the specified viewport Supported levels are:

  • DPMS_ON Full operation
  • DPMS_STANDBY Optional state of minimal power reduction
  • DPMS_SUSPEND Significant reduction of power consumption
  • DPMS_OFF Lowest level of power consumption

Snippet

{ set DPMS level }
CVideoCtrlTags(@Scr^.ViewPort, [SETVC_DPMSLevel, DPMS_OFF, TAG_DONE]);

Errors

Some DPMS levels are not implemented for certain graphics cards

See also

CVideoCtrlTags

VarArgs version of CVideoCtrlTagList


CVideoCtrlTags

VarArgs version of CVideoCtrlTagList

Declaration

Source position: cybergraphics.pas line 195

procedure CVideoCtrlTags(

  ViewPort: PViewPort;

  const TagList: array of PtrUInt

);


CyberGfxClone

Declaration

Source position: cybergraphics.pas line 152

function CyberGfxClone: PInterface;


CyberGfxExpunge

Declaration

Source position: cybergraphics.pas line 151

procedure CyberGfxExpunge;


CyberGfxObtain

Declaration

Source position: cybergraphics.pas line 149

function CyberGfxObtain: LongWord;


CyberGfxRelease

Declaration

Source position: cybergraphics.pas line 150

function CyberGfxRelease: LongWord;


DoCDrawMethodTagList

Do the given hook for the supplied rastport

Declaration

Source position: cybergraphics.pas line 174

procedure DoCDrawMethodTagList(

  Hook: PHook;

  Rp: PRastPort;

  Tags: PTagItem

);

Arguments

Hook

Pointer to callback hook which will be called

Description

This function will call the given hook for the given rastport. Is is mainly used to do direct bitmap modifications in a locked graphics environment. You have to support all known color models, so only use this call if you really need it!!

Hook call parameter

object
PRastPort
message

pointer to TCDrawMsg:

  • MemPtr: APTR
  • XOffset: LongWord
  • YOffset: LongWord
  • XSize: LongWord
  • YSize: LongWord
  • BytesPerRow: Word
  • BytesPerPix: Word
  • ColorModel: Word

where colormodel is on of following: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32

Errors

In previous autodocs, the bytesperrow message field was described as an LongWord which in fact was an Word.

See also

DoCDrawMethodTags

VarArgs Version of DoCDrawMethodTagList


DoCDrawMethodTags

VarArgs Version of DoCDrawMethodTagList

Declaration

Source position: cybergraphics.pas line 196

procedure DoCDrawMethodTags(

  Hook: PHook;

  a1arg: PRastPort;

  const TagList: array of PtrUInt

);


DOWNSHIFT_PIXFMT

Declaration

Source position: cybergraphics.pas line 201

function DOWNSHIFT_PIXFMT(

  fmt: LongInt

):LongInt;


ExtractColor

Extract the specified colour/CLUT value from a given CyberGraphX RastPort

Declaration

Source position: cybergraphics.pas line 183

function ExtractColor(

  RastPort: PRastPort;

  SingleMap: PBitMap;

  Colour: LongWord;

  SX: LongWord;

  SY: LongWord;

  Width: LongWord;

  Height: LongWord

):LongWord;

Arguments

Colour | the color that should be extracted in AARRGGBB format for true color rastports or in indexed mode for CLUT rastports (index in BB).
Width | Width of the rectangle that should be analyzed
Height | Height of the rectangle that should be analyzed

Function result

Returns True (<> 0) if colour could be extracted, False (= 0) if not

Description

Extract the specified colour/CLUT value from a given CyberGraphX RastPort into a single plane bitmap starting at a certain x,y location and using the specified width and height. Use this function if you want to create masks. (V41)

Errors

This call was a no-op in very early revisions of cybergraphics v41


FillPixelArray

fill a rectangular area with the supplied ARGB

Declaration

Source position: cybergraphics.pas line 173

function FillPixelArray(

  Rp: PRastPort;

  DestX: LongInt;

  DestY: LongInt;

  Width: LongWord;

  Height: LongWord;

  Pixel: LongWord

):LongWord;

Arguments

DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort

Function result

Count will be set to the number of pixels plotted

Description

fill a rectangular area with the supplied ARGB value starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the supplied color value into the bitmap used to describe a particular rastport.

Attention

This function should only be used on screens depths >8 bits in cybergraphics versions prior v41.

Errors

The returned count value is wrong up to and including v41 of the cybergraphics.library

See also

InvertPixelArray

Invert a rectangular area


FreeCModeList

Frees a previously allocated ModeList

Declaration

Source position: cybergraphics.pas line 161

procedure FreeCModeList(

  ModeList: PList

);

Arguments

ModeList

a list structure which contains all the mode data.

Description

Frees all data which was previously allocated by AllocCModeListTagList

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList


GetCyberIDAttr

Returns information about a cybergraphics ID

Declaration

Source position: cybergraphics.pas line 165

function GetCyberIDAttr(

  CyberIDAttr: LongWord;

  CyberDisplayModeID: LongWord

):LongWord;

Arguments

CyberIDAttr | A number telling cybergraphics which attribute of the displaymode id should be returned
CyberDisplayModeID | CyberGraphX displaymode ID

Function result

depends on the supplied CyberIDAttr

Description

Returns information about a specified displaymode ID.

Available CyberIDAttr

You should know what you are doing if you call this function! Don't apply it on a non cybergraphics displaymode!

CYBRIDATTR_PIXFMT
return the pixel format of the supplied screenmode id
CYBRIDATTR_WIDTH
returns visible width in pixels
CYBRIDATTR_HEIGHT
returns visible height in lines
CYBRIDATTR_DEPTH
returns bits per pixel
CYBRIDATTR_BPPIX
returns bytes per pixel

Unknown attributes are reserved for future use, and return ($FFFFFFFF).


GetCyberMapAttr

Returns information about a cybergraphics bitmap

Declaration

Source position: cybergraphics.pas line 164

function GetCyberMapAttr(

  CyberGfxBitmap: PBitMap;

  CyberAttrTag: LongWord

):LongWord;

Arguments

CyberAttrTag

A number telling cybergraphics which attribute of the bitmap should be returned

Function result

Value described by CyberAttrTag

Description

Gets information about an extended cybergraphics bitmap. This function should be used instead of making any assumptions about fields in the bitmap structure. This will provide future compatibility.

You should know what you are doing if you call this function! Always use the CYBRMATTR_ISCYBERGFX attribute first to check if the bitmap is a CyberGraphX one.

Available CyberAttrTag

CYBRMATTR_XMOD
returns bytes per row of the supplied bitmap
CYBRMATTR_BPPIX
returns number of bytes per pixel
CYBRMATTR_PIXFMT
return the pixel format of the bitmap
CYBRMATTR_WIDTH
return width of the bitmap in pixels
CYBRMATTR_HEIGHT
return the height in lines
CYBRMATTR_DEPTH
returns bits per pixel
CYBRMATTR_ISCYBERGFX
returns True (result <> 0) if supplied bitmap is a CyberGraphX one
CYBRMATTR_ISLINEARMEM
returns True (result <> 0) if the related display buffer supports linear memory access

Unknown attributes are reserved for future use, and return ($FFFFFFFF).


InvertPixelArray

Invert a rectangular area

Declaration

Source position: cybergraphics.pas line 172

function InvertPixelArray(

  Rp: PRastPort;

  DestX: LongInt;

  DestY: LongInt;

  Width: LongWord;

  Height: LongWord

):LongWord;

Arguments

DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort

Function result

count will be set to the number of pixels plotted

Description

Invert each pixel in a rectangular region.

Attention

This function should only be used on screens depths > 8 bits with cybergraphics versions prior v41.

Errors

The count value returned is totally wrong.

See also

FillPixelArray

fill a rectangular area with the supplied ARGB


IsCyberModeID

Returns whether supplied ModeID is a cybergraphics ID

Declaration

Source position: cybergraphics.pas line 154

function IsCyberModeID(

  displayID: LongWord

):LongBool;

Arguments

displayID

a 32 bit display identifier.

Function result

Returns whether the supplied ModeID is a cybergraphics.library mode identifier (True) or not (False).


LockBitMapTagList

Lock supplied BitMap for a short amount of time to allow direct memory access

Declaration

Source position: cybergraphics.pas line 178

function LockBitMapTagList(

  Bitmap: Pointer;

  TagList: PTagItem

):Pointer;

Arguments

Bitmap | Pointer to a CyberGraphX bitmap pointer. please check if it is a cybermap by calling GetCyberMapAttr() first.
TagList | Pointer to a mandatory taglist which's tagdata pointer fields contain valid LongWords after a successful call.

Function result

0 if the bitmap could not be locked, <> 0 it contains a handle which should be passed to UnLockBitMap afterwards

Description

Lock supplied BitMap for a short amount of time to allow direct memory access

Available Tags

LBMI_WIDTH
(PLongWord) Points to a longword which contains the bitmap width after a succesful call
LBMI_HEIGHT
(PLongWord) Points to a longword which contains the bitmap height after a succesful call
LBMI_DEPTH
(PLongWord) Points to a longword which contains the bitmap depth after a succesful call
LBMI_PIXFMT
(PLongWord) Points to a longword which contains the usedpixel format. Possibly returned colormodels are: PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32
LBMI_BYTESPERPIX
(PLongWord) points to a longword which contains the amount of bytes per pixel data.
LBMI_BYTESPERROW
(PLongWord) points to a longword which contains the number of bytes per row for one bitmap line
LBMI_BASEADDRESS
(PLongWord) points to a longword which contains the bitmap base address. This address is only valid inside of the Lock/UnLockBitmap call!

See also

LockBitMapTags | VarArgs version of LockBitMapTagList
UnLockBitMap | Unlock CyberGraphX BitMap that was previously locked


LockBitMapTags

VarArgs version of LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 197

function LockBitMapTags(

  BitMap: Pointer;

  const TagList: array of PtrUInt

):Pointer;


MovePixelArray

move the color values of a rectangular area

Declaration

Source position: cybergraphics.pas line 170

function MovePixelArray(

  SrcX: LongWord;

  SrcY: LongWord;

  RastPort: PRastPort;

  DstX: LongWord;

  DstY: LongWord;

  SizeX: LongWord;

  SizeY: LongWord

):LongWord;

Arguments

SrcX | Starting x point in the source rectangle
SrcY | Starting y point in the source rectangle
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered

Function result

number of pixels moved

Description

move the color values of a rectangular area of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, move the pixel value from a specified source to a specified destination

The blitter can be used to move the data if the bitmap is in display memory. This is why you should use this call.

Errors

The count value returned is totally wrong. This function should only be used on screens depths > 8 bits with cybergraphics versions up to v40.

See also

FillPixelArray | fill a rectangular area with the supplied ARGB
InvertPixelArray | Invert a rectangular area
BltBitMapRastPort | Blit from source bitmap to destination rastport.


ReadPixelArray

Read the color values of a rectangular array

Declaration

Source position: cybergraphics.pas line 168

function ReadPixelArray(

  DestRect: Pointer;

  DestX: LongInt;

  DestY: LongInt;

  DestMod: LongWord;

  Rp: PRastPort;

  SrcX: LongInt;

  SrcY: LongInt;

  Width: LongWord;

  Height: LongWord;

  DstFormat: LongWord

):LongWord;

Arguments

DestRect | Pointer to an array of pixels where to write the pixel data to. The pixel format is specified in DestFormat
DestX | X starting point in the destination rectangle
DestY | Y starting point in the destination rectangle
DestMod | The number of bytes per row in the destination rectangle.
SrcX | X starting point in the RastPort
SrcY | Y starting point in the RastPort

Function result

number of pixels read

Description

Read the color values of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the color value to a linear array of color values from the bitmap used to describe a particular rastport.

Attention

This function should only be used on screens depths > 8 bits.

Errors

The count value returned is totally wrong.

See also

WritePixelArray | write the color value of a rectangular array
ReadPixelArray8 | read the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.


ReadRGBPixel

Reads a pixel from a specified location

Declaration

Source position: cybergraphics.pas line 166

function ReadRGBPixel(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt

):LongWord;

Arguments

X | the x coordinate of the pixel
Y | the y coordinate of the pixel

Function result

the desired color in AARRGGBB format. Every component allocates 8 bits in the returned longword.

Description

Read the alpha,red,green and blue 8-bit color components of the pixel at a specified x,y location within a certain RastPort

Attention

This function should only be used on screens depths > 8 bits. Use ReadPixel() on 8 bit screens!

See also

WriteRGBPixel | Writes a pixel to a specified location
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.


ScalePixelArray

Scale the colors values of a rectangular array (V41)

Declaration

Source position: cybergraphics.pas line 163

function ScalePixelArray(

  SrcRect: Pointer;

  SrcW: LongWord;

  SrcH: LongWord;

  SrcMod: LongWord;

  RastPort: PRastPort;

  DestX: LongInt;

  DestY: LongInt;

  DestW: LongWord;

  DestH: LongWord;

  SrcFormat: LongWord

):LongInt;

Arguments

SrcRect | Pointer to an array of pixels from which to fetch the pixel data. The pixel format is specified in SrcFormat
SrcW | Width of the source rectangle
SrcH | Height of the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
DestX | starting x point in the RastPort
DestY | starting y point in the RastPort
DestW | Width of the destination area
DestH | Height of the destination area
SrcFormat | pixel format in the source rectangle. Currently supported formats are: RECTFMT_RGB, RECTFMT_RGBA, RECTFMT_ARGB, RECTFMT_LUT8, RECTFMT_GREY8

Function result

number of pixels plotted

Description

Scale the colors values of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, scale the color values from a linear array of color values into the bitmap used to describe a particular rastport.

Attention

Up to v40, this function only worked on screens depths > 8 bits. You may specify RECTFMT_LUT8 on 8bit screens, too now if v41 is available

Errors

Very early v40 revision did not support RECTFMT_LUT8 and RECTFMT_GREY8. Scaling is not very accurate. If you need high quality, use graphics.library/BitMapScale() instead or custom code. The count value returned is totally wrong.

See also

BitMapScale()

Perform raster scaling on a bit map.


SHIFT_PIXFMT

Declaration

Source position: cybergraphics.pas line 200

function SHIFT_PIXFMT(

  fmt: LongInt

):LongInt;


UnLockBitMap

Unlock CyberGraphX BitMap that was previously locked

Declaration

Source position: cybergraphics.pas line 180

procedure UnLockBitMap(

  Handle: Pointer

);

Arguments

Handle

handle to the previously locked BitMap

Description

Unlock CyberGraphX BitMap that was previously locked.

See also

LockBitMapTagList

Lock supplied BitMap for a short amount of time to allow direct memory access


UnLockBitMapTagList

Unlock CyberGraphX BitMap that was previously

Declaration

Source position: cybergraphics.pas line 181

procedure UnLockBitMapTagList(

  Handle: Pointer;

  TagList: PTagItem

);

Arguments

Handle | handle to the previously locked BitMap
TagList | pointer to a mandatory taglist

Description

Unlock CyberGraphX BitMap that was previously locked

Available Tags

UBMI_UPDATERECTS

(PRectList) - Pointer to a rectlist which contains rectangles that should be updated. This is needed for cards that don't have a linear display memory address space

The RectList structure looks like this:

TRectList = record
  rl_num: LongWord;     // no. of rects in this list
  rl_next: PRectList;  // pointer to next list
  rect1: TRectangle;   // This is the first
end;
UBMI_REALLYUNLOCK
Specifies whether bitmap should really be unlocked (True) or not (False) in case you just want to update certain rectangles and unlock later.

Errors

Very early v40 revisions did not support this call

See also

LockBitMapTagList | Lock supplied BitMap for a short amount of time to allow direct memory access
UnLockBitMap | Unlock CyberGraphX BitMap that was previously locked
UnLockBitMapTags | VarArgs Version of UnLockBitMapTagList


UnLockBitMapTags

VarArgs Version of UnLockBitMapTagList

Declaration

Source position: cybergraphics.pas line 198

procedure UnLockBitMapTags(

  Handle: Pointer;

  const TagList: array of PtrUInt

);


WriteLUTPixelArray

write the color value generated from a given color table (V41)

Declaration

Source position: cybergraphics.pas line 185

function WriteLUTPixelArray(

  SrcRect: Pointer;

  SrcX: LongInt;

  SrcY: LongInt;

  SrcMod: LongWord;

  Rp: PRastPort;

  CTable: Pointer;

  DestX: LongInt;

  DestY: LongInt;

  SizeX: LongWord;

  SizeY: LongWord;

  CTabFormat: LongWord

):LongInt;

Arguments

SrcRect | Pointer to an array of pixels from which to fetch the CLUT data. Pixels are specified in bytes, 8bits/pixel
SrcX | X starting point in the source rectangle
SrcY | Y starting point in the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
SizeX | Width of the rectangle that should be transfered
SizeY | Height of the rectangle that should be transfered

Function result

number of pixels plotted

Description

write the color value generated from a given color table of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the color value generated with a given color lookup table from a linear array of indexed pixel values into the bitmap used to describe a particular rastport.

Attention

Does only work on rastports with depth > 8bits

Errors

The count value returned is totally wrong.

With cgxsystem.library up to version 41.19, the call returns immediately with CTABFMT_XRGB8 due to a bug in the code

See also

ReadPixelArray | Read the color values of a rectangular array
WritePixelArray | write the color value of a rectangular array
WritePixelArray8 | Write the pen number value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort.


WritePixelArray

write the color value of a rectangular array

Declaration

Source position: cybergraphics.pas line 169

function WritePixelArray(

  SrcRect: Pointer;

  SrcX: LongInt;

  SrcY: LongInt;

  SrcMod: LongWord;

  Rp: PRastPort;

  DestX: LongInt;

  DestY: LongInt;

  Width: LongWord;

  Height: LongWord;

  SrcFormat: LongWord

):LongWord;

Arguments

SrcRect | pointer to an array of pixels from which to fetch the pixel data. The pixel format is specified in SrcFormat
SrcX | X starting point in the source rectangle
SrcY | Y starting point in the source rectangle
SrcMod | The number of bytes per row in the source rectangle.
DestX | X starting point in the RastPort
DestY | Y starting point in the RastPort
SrcFormat | pixel format in the source rectangle. Currently supported formats are: RECTFMT_RGB, RECTFMT_RGBA, RECTFMT_ARGB, RECTFMT_LUT8, RECTFMT_GREY8

Function result

number of pixels plotted

Description

write the color value of a rectangular array of pixels starting at a specified x,y location and continuing through to another x,y location within a certain RastPort

For each pixel in a rectangular region, write the color value from a linear array of color values into the bitmap used to describe a particular rastport.

Attention

Only RECTFMT_LUT8 can be used on screen depths <= 8 bits. For > 8 bit rastport RECTFMT_LUT8 uses the actual colormap "attached" to the bitmap. If the bitmap is a friend bitmap of a screen bitmap or the screen bitmap itself, it uses the screen's viewport colormap.

Errors

The count value returned is totally wrong.

See also

ReadPixelArray | Read the color values of a rectangular array
WriteLUTPixelArray | write the color value generated from a given color table (V41)
WritePixelArray | write the color value of a rectangular array


WritePixelArrayAlpha

Declaration

Source position: cybergraphics.pas line 188

function WritePixelArrayAlpha(

  Src: Pointer;

  SrcX: LongInt;

  SrcY: LongInt;

  SrcMod: LongInt;

  Rp: PRastPort;

  DestX: LongInt;

  DestY: LongInt;

  Width: LongWord;

  Height: LongWord;

  GlobalAlpha: LongWord

):LongWord;


WriteRGBPixel

Writes a pixel to a specified location

Declaration

Source position: cybergraphics.pas line 167

function WriteRGBPixel(

  Rp: PRastPort;

  X: LongInt;

  Y: LongInt;

  Pixel: LongWord

):LongInt;

Arguments

X | X coordinate of the pixel
Y | Y coordinate of the pixel

Function result

error = 0 if pixel succesfully changed

= -1 if (x,y) is outside the rastport

Description

Write the alpha,red,green and blue 8-bit color component of the given color to a specified x,y location within a certain RastPort

Attention

This function should only be used on screens depths > 8 bits. Use WritePixel on 8 bit screens!

See also

ReadRGBPixel | Reads a pixel from a specified location
WritePixel | Change the pen num of one specific pixel in a specified RastPort.


Reference for unit 'datatypes': Procedures and functions

AddDTObject

CopyDTMethods

CopyDTTriggerMethods

DisposeDTObject

DoAsyncLayout

DoDTDomain

DoDTDomainA

DoDTMethod

DoDTMethodA

DrawDTObject

DrawDTObjectA

FindMethod

FindToolNode

FindToolNodeA

FindTriggerMethod

FreeDTMethods

GetDTAttrs

GetDTAttrsA

GetDTMethods

GetDTString

GetDTTriggerMethodDataFlags

GetDTTriggerMethods

LaunchTool

LaunchToolA

LockDataType

NewDTObject

NewDTObjectA

ObtainDataType

ObtainDataTypeA

ObtainDTDrawInfo

ObtainDTDrawInfoA

PrintDTObject

PrintDTObjectA

RefreshDTObject

RefreshDTObjectA

ReleaseDataType

ReleaseDTDrawInfo

RemoveDTObject

SaveDTObject

SaveDTObjectA

SetDTAttrs

SetDTAttrsA


Unit 'datatypes' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'datatypes': Variables

DataTypesBase

IDataTypes


Index of all identifiers in unit 'datatypes'

A C D F G I L M N O P R S T U

A

AddDTObject | ADTA_Height | ADTA_Screen
ADTA_Allocated | ADTA_KeyFrame | ADTA_SparseTable
ADTA_ColorRegisters | ADTA_LeftSample | ADTA_Volume
ADTA_ColorTable | ADTA_ModeID | ADTA_Width
ADTA_ColorTable2 | ADTA_NumAlloc | ADTM_Dummy
ADTA_CRegs | ADTA_NumColors | ADTM_LOADFRAME
ADTA_Cycles | ADTA_NumSparse | ADTM_LOADNEWFORMATFRAME
ADTA_Depth | ADTA_Period | ADTM_LOCATE
ADTA_Dummy | ADTA_PreloadFrameCount | ADTM_PAUSE
ADTA_Frame | ADTA_Remap | ADTM_START
ADTA_FrameIncrement | ADTA_RightSample | ADTM_STOP
ADTA_Frames | ADTA_Sample | ADTM_UNLOADFRAME
ADTA_FramesPerSecond | ADTA_SampleLength | ADTM_UNLOADNEWFORMATFRAME
ADTA_GRegs | ADTA_SamplesPerSec | ANIMATIONDTCLASS

C

cmpByteRun1 | cmpNone | CopyDTTriggerMethods
cmpByteRun2 | CMP_NONE |
CMP_FIBDELTA | CopyDTMethods |

D

DataTypesBase | DTA_ObjName | DTF_IFF
DATATYPESCLASS | DTA_ObjVersion | DTF_MISC
DATATYPESNAME | DTA_PrinterProc | DTF_SYSTEM1
DisposeDTObject | DTA_PrinterStatus | DTF_TYPE_MASK
DoAsyncLayout | DTA_RastPort | DTHSIZE
DoDTDomain | DTA_Repeat | DTM_ABORTPRINT
DoDTDomainA | DTA_Reserved | DTM_ASYNCLAYOUT
DoDTMethod | DTA_SelectDomain | DTM_CLEARSELECTED
DoDTMethodA | DTA_SourceAddress | DTM_COPY
DrawDTObject | DTA_SourceSize | DTM_DISPOSEMEMBER
DrawDTObjectA | DTA_SourceType | DTM_DRAW
DTA_ARexxPortName | DTA_Special | DTM_Dummy
DTA_BaseName | DTA_Sync | DTM_FRAMEBOX
DTA_Busy | DTA_TextAttr | DTM_GOTO
DTA_Conductor | DTA_TextFont | DTM_NEWMEMBER
DTA_ControlPanel | DTA_Title | DTM_OBTAINDRAWINFO
DTA_Data | DTA_TopHoriz | DTM_PRINT
DTA_DataType | DTA_TopVert | DTM_PROCLAYOUT
DTA_DestCols | DTA_TotalHoriz | DTM_RELEASEDRAWINFO
DTA_DestRows | DTA_TotalPHoriz | DTM_REMOVEDTOBJECT
DTA_Domain | DTA_TotalPVert | DTM_SELECT
DTA_Dummy | DTA_TotalVert | DTMSG_TYPE_OFFSET
DTA_ErrorLevel | DTA_TriggerMethods | DTM_TRIGGER
DTA_ErrorNumber | DTA_UserData | DTM_WRITE
DTA_ErrorString | DTA_VertUnit | DTNSIZE
DTA_FrameInfo | DTA_VisibleHoriz | DTSIF_DRAGGING
DTA_GroupID | DTA_VisibleVert | DTSIF_DRAGSELECT
DTA_Handle | DTERROR_COULDNT_OPEN | DTSIF_HIGHLIGHT
DTA_HorizUnit | DTERROR_COULDNT_OPEN_CLIPBOARD | DTSIF_LAYOUT
DTA_Immediate | DTERROR_COULDNT_SAVE | DTSIF_LAYOUTPROC
DTA_LayoutProc | DTERROR_COULDNT_SEND_MESSAGE | DTSIF_NEWSIZE
DTA_Methods | DTERROR_INVALID_DATA | DTSIF_PRINTING
DTA_Name | DTERROR_NOT_AVAILABLE | DTST_CLIPBOARD
DTA_NodeName | DTERROR_NOT_ENOUGH_DATA | DTST_FILE
DTA_NominalHoriz | DTERROR_Reserved | DTST_HOTLINK
DTA_NominalVert | DTERROR_UNKNOWN_COMPRESSION | DTST_MEMORY
DTA_ObjAnnotation | DTERROR_UNKNOWN_DATATYPE | DTST_RAM
DTA_ObjAuthor | DTF_ASCII | DTWM_IFF
DTA_ObjCopyright | DTF_BINARY | DTWM_RAW
DTA_ObjectID | DTF_CASE |

F

FIF_REMAPPABLE | FindMethod | FindTriggerMethod
FIF_SCALABLE | FindToolNode | FreeDTMethods
FIF_SCROLLABLE | FindToolNodeA |

G

GetDTAttrs | GetDTTriggerMethods | GID_MUSIC
GetDTAttrsA | GID_ANIMATION | GID_PICTURE
GetDTMethods | GID_DOCUMENT | GID_SOUND
GetDTString | GID_INSTRUMENT | GID_SYSTEM
GetDTTriggerMethodDataFlags | GID_MOVIE | GID_TEXT

I

ID_8SVX | ID_CHRS | ID_FTXT
ID_ANHD | ID_CMAP | ID_GRAB
ID_ANIM | ID_CODE | ID_ILBM
IDataTypes | ID_CRNG | ID_NAME
ID_BMHD | ID_DEST | ID_SPRT
ID_BODY | ID_DLTA | ID_TAGS
ID_CAMG | ID_DTHD | ID_TOOL
ID_CHAN | ID_DTYP | ID_VHDR

L

LaunchTool | LNF_LINK | LockDataType
LaunchToolA | LNF_OBJECT |
LNF_LF | LNF_SELECTED |

M

mskHasAlpha | mskHasTransparentColor | mskNone
mskHasMask | mskLasso |

N

NewDTObject NewDTObjectA

O

ObtainDataType | ObtainDTDrawInfo
ObtainDataTypeA | ObtainDTDrawInfoA

P

PadtFrame | PDTA_GetNumPictures | PDTM_Dummy
PadtNewFormatFrame | PDTA_Grab | PDTMethod
PadtStart | PDTA_GRegs | PDTM_READPIXELARRAY
PAnimHeader | PDTA_MaskPlane | PDTM_WRITEPIXELARRAY
PBitMapHeader | PDTA_MaxDitherPens | PdtSelect
PColorRegister | PDTA_ModeID | PDTSpecialInfo
PDataType | PDTA_NumAlloc | PdtTrigger
PDataTypeHeader | PDTA_NumColors | PdtWrite
PDTA_Allocated | PDTANUMPICTURES_Unknown | PFrameInfo
PDTA_AllocatedPens | PDTA_NumSparse | PICTUREDTCLASS
PDTA_BitMap | PDTA_Remap | PLine
PDTA_BitMapHeader | PDTA_ScaleQuality | PMODE_V42
PDTA_ClassBitMap | PDTA_Screen | PMODE_V43
PDTA_ColorRegisters | PDTA_SourceMode | PrintDTObject
PDTA_ColorTable | PDTA_SparseTable | PrintDTObjectA
PDTA_ColorTable2 | PDTA_UseFriendBitMap | PTHookContext
PDTA_CRegs | PDTA_WhichPicture | PTool
PDTA_DestBitMap | PdtDraw | PToolNode
PDTA_DestMode | PdtFrameBox | PVoiceHeader
PDTA_DitherQuality | PdtGeneral |
PDTA_FreeSourceBitMap | PdtGoto |

R

RefreshDTObject | ReleaseDataType | RemoveDTObject
RefreshDTObjectA | ReleaseDTDrawInfo |

S

SAMPLETYPE_Left | SDTA_SampleLength | STM_COMMAND
SAMPLETYPE_Right | SDTA_SamplesPerSec | STM_CONTENTS
SAMPLETYPE_Stereo | SDTA_SignalBit | STM_FASTFORWARD
SaveDTObject | SDTA_SignalBitMask | STM_INDEX
SaveDTObjectA | SDTA_SignalBitNumber | STM_LOCATE
SDTA_Continuous | SDTA_SignalTask | STM_NEXT_FIELD
SDTA_Cycles | SDTA_SyncSampleChange | STM_PAUSE
SDTA_Dummy | SDTA_VoiceHeader | STM_PLAY
SDTA_FreeSampleData | SDTA_Volume | STM_PREV_FIELD
SDTA_LeftSample | SetDTAttrs | STM_RESUME
SDTA_Pan | SetDTAttrsA | STM_RETRACE
SDTA_Period | SOUNDDTCLASS | STM_REWIND
SDTA_ReplayPeriod | STM_ACTIVATE_FIELD | STM_STOP
SDTA_RightSample | STM_BROWSE_NEXT |
SDTA_Sample | STM_BROWSE_PREV |

T

TadtFrame | TdtDraw | TF_SHELL
TadtNewFormatFrame | TdtFrameBox | TF_WORKBENCH
TadtStart | TdtGeneral | TLine
TAnimHeader | TdtGoto | TNSIZE
TBitMapHeader | TDTHookContext | TOOLSIZE
TColorRegister | TDTMethod | LongInt
TDataType | TdtSelect | TTool
TDataTypeHeader | TDTSpecialInfo | TToolNode
TDTA_Buffer | TdtTrigger | TVoiceHeader
TDTA_BufferLen | TdtWrite | TW_BROWSE
TDTA_LineList | TEXTDTCLASS | TW_EDIT
TDTA_WordDelim | TF_LAUNCH_MASK | TW_INFO
TDTA_WordSelect | TFrameInfo | TW_MAIL
TDTA_WordWrap | TF_RX | TW_PRINT

U

Unity


AddDTObject

Declaration

Source position: datatypes.pas line 836

function AddDTObject(

  Win: PWindow;

  Req: PRequester;

  o: PObject_;

  Pos: LongInt

):LongInt;


CopyDTMethods

Declaration

Source position: datatypes.pas line 854

function CopyDTMethods(

  Methods: PLongWord;

  Include: PLongWord;

  Exclude: PLongWord

):PLongWord;


CopyDTTriggerMethods

Declaration

Source position: datatypes.pas line 855

function CopyDTTriggerMethods(

  Methods: PDTMethod;

  Include: PDTMethod;

  Exclude: PDTMethod

):PDTMethod;


DisposeDTObject

Declaration

Source position: datatypes.pas line 833

procedure DisposeDTObject(

  o: PObject_

);


DoAsyncLayout

Declaration

Source position: datatypes.pas line 838

function DoAsyncLayout(

  o: PObject_;

  gpl: PgpLayout

):LongWord;


DoDTDomain

Declaration

Source position: datatypes.pas line 873

function DoDTDomain(

  O: PObject_;

  Win: PWindow;

  Req: PRequester;

  RPort: PRastPort;

  Which: LongWord;

  Domain: PIBox;

  const TagList: array of PtrUInt

):LongWord;


DoDTDomainA

Declaration

Source position: datatypes.pas line 859

function DoDTDomainA(

  O: PObject_;

  Win: PWindow;

  Req: PRequester;

  RPort: PRastPort;

  Which: LongWord;

  Domain: PIBox;

  Attrs: PTagItem

):LongWord;


DoDTMethod

Declaration

Source position: datatypes.pas line 866

function DoDTMethod(

  O: PObject_;

  Win: PWindow;

  Req: PRequester;

  const ArgList: array of PtrUInt

):PtrUInt;


DoDTMethodA

Declaration

Source position: datatypes.pas line 839

function DoDTMethodA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  Msg: PLongInt

):LongWord;


DrawDTObject

Declaration

Source position: datatypes.pas line 869

function DrawDTObject(

  Rp: PRastPort;

  O: PObject_;

  x: LongInt;

  y: LongInt;

  w: LongInt;

  h: LongInt;

  th: LongInt;

  tv: LongInt;

  const TagList: array of PtrUInt

):LongInt;


DrawDTObjectA

Declaration

Source position: datatypes.pas line 845

function DrawDTObjectA(

  Rp: PRastPort;

  o: PObject_;

  x: LongInt;

  y: LongInt;

  w: LongInt;

  h: LongInt;

  th: LongInt;

  tv: LongInt;

  Attrs: PTagItem

):LongInt;


FindMethod

Declaration

Source position: datatypes.pas line 852

function FindMethod(

  Methods: PLongWord;

  SearchModeID: LongWord

):PLongWord;


FindToolNode

Declaration

Source position: datatypes.pas line 870

function FindToolNode(

  ToolList: PList;

  const TagList: array of PtrUInt

):PToolNode;


FindToolNodeA

Declaration

Source position: datatypes.pas line 850

function FindToolNodeA(

  ToolList: PList;

  Attrs: PTagItem

):PToolNode;


FindTriggerMethod

Declaration

Source position: datatypes.pas line 853

function FindTriggerMethod(

  Methods: PDTMethod;

  Command: PChar;

  Method: LongWord

):PDTMethod;


FreeDTMethods

Declaration

Source position: datatypes.pas line 856

procedure FreeDTMethods(

  Methods: Pointer

);


GetDTAttrs

Declaration

Source position: datatypes.pas line 864

function GetDTAttrs(

  O: PObject_;

  const TagList: array of PtrUInt

):LongWord;


GetDTAttrsA

Declaration

Source position: datatypes.pas line 835

function GetDTAttrsA(

  o: PObject_;

  Attrs: PTagItem

):LongWord;


GetDTMethods

Declaration

Source position: datatypes.pas line 841

function GetDTMethods(

  Obj: PObject_

):Pointer;


GetDTString

Declaration

Source position: datatypes.pas line 847

function GetDTString(

  Id: LongWord

):PChar;


GetDTTriggerMethodDataFlags

Declaration

Source position: datatypes.pas line 857

function GetDTTriggerMethodDataFlags(

  Method: LongWord

):LongWord;


GetDTTriggerMethods

Declaration

Source position: datatypes.pas line 842

function GetDTTriggerMethods(

  Obj: PObject_

):PDTMethod;


LaunchTool

Declaration

Source position: datatypes.pas line 871

function LaunchTool(

  Tool: PTool;

  Project: PChar;

  const TagList: array of PtrUInt

):LongWord;


LaunchToolA

Declaration

Source position: datatypes.pas line 851

function LaunchToolA(

  Tool: PTool;

  Project: PChar;

  Attrs: PTagItem

):LongWord;


LockDataType

Declaration

Source position: datatypes.pas line 849

procedure LockDataType(

  Dt: PDataType

);


NewDTObject

Declaration

Source position: datatypes.pas line 862

function NewDTObject(

  Name: Pointer;

  const TagList: array of PtrUInt

):PObject_;


NewDTObjectA

Declaration

Source position: datatypes.pas line 832

function NewDTObjectA(

  Name: PChar;

  Attrs: PTagItem

):Pointer;


ObtainDataType

Declaration

Source position: datatypes.pas line 861

function ObtainDataType(

  Typ: LongWord;

  Handle: Pointer;

  const TagList: array of PtrUInt

):PDataType;


ObtainDataTypeA

Declaration

Source position: datatypes.pas line 830

function ObtainDataTypeA(

  Typ: LongWord;

  Handle: Pointer;

  Attrs: PTagItem

):PDataType;


ObtainDTDrawInfo

Declaration

Source position: datatypes.pas line 868

function ObtainDTDrawInfo(

  O: PObject_;

  const TagList: array of PtrUInt

):Pointer;


ObtainDTDrawInfoA

Declaration

Source position: datatypes.pas line 844

function ObtainDTDrawInfoA(

  o: PObject_;

  Attrs: PTagItem

):Pointer;


PrintDTObject

Declaration

Source position: datatypes.pas line 867

function PrintDTObject(

  Obj: PObject_;

  Window: PWindow;

  Requester: PRequester;

  const ArgList: array of PtrUInt

):LongWord;


PrintDTObjectA

Declaration

Source position: datatypes.pas line 843

function PrintDTObjectA(

  o: PObject_;

  w: PWindow;

  r: PRequester;

  Msg: Pointer

):LongWord;


RefreshDTObject

Declaration

Source position: datatypes.pas line 865

procedure RefreshDTObject(

  Obj: PObject_;

  Window: PWindow;

  Req: PRequester;

  const TagList: array of PtrUInt

);


RefreshDTObjectA

Declaration

Source position: datatypes.pas line 837

procedure RefreshDTObjectA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  Attrs: PTagItem

);


ReleaseDataType

Declaration

Source position: datatypes.pas line 831

procedure ReleaseDataType(

  Dt: PDataType

);


ReleaseDTDrawInfo

Declaration

Source position: datatypes.pas line 846

procedure ReleaseDTDrawInfo(

  o: PObject_;

  Handle: Pointer

);


RemoveDTObject

Declaration

Source position: datatypes.pas line 840

function RemoveDTObject(

  Win: PWindow;

  o: PObject_

):LongInt;


SaveDTObject

Declaration

Source position: datatypes.pas line 872

function SaveDTObject(

  O: PObject_;

  Win: PWindow;

  Req: PRequester;

  File_: PChar;

  Mode: LongWord;

  SaveIcon: SmallInt;

  const TagList: array of PtrUInt

):LongWord;


SaveDTObjectA

Declaration

Source position: datatypes.pas line 858

function SaveDTObjectA(

  O: PObject_;

  Win: PWindow;

  Req: PRequester;

  File_: PChar;

  Mode: LongWord;

  SaveIcon: SmallInt;

  Attrs: PTagItem

):LongWord;


SetDTAttrs

Declaration

Source position: datatypes.pas line 863

function SetDTAttrs(

  O: PObject_;

  Win: PWindow;

  Req: PRequester;

  const TagList: array of PtrUInt

):LongWord;


SetDTAttrsA

Declaration

Source position: datatypes.pas line 834

function SetDTAttrsA(

  o: PObject_;

  Win: PWindow;

  Req: PRequester;

  Attrs: PTagItem

):LongWord;


Reference for unit 'diskfont': Procedures and functions

AvailFonts | Inquire available memory and disk fonts.
CloseOutlineFont
DiskfontClone
DiskfontExpunge
DiskfontObtain
DiskfontRelease
DisposeFontContents |
ECloseEngine
EObtainInfoA
EOpenEngine
EReleaseInfoA
ESetInfoA
FreeTTextAttr
GetDiskFontCtrl |
NewFontContents |
NewScaledDiskFont |
ObtainCharsetInfo
ObtainTTextAttr
OpenDiskFont |
OpenOutlineFont
SetDiskFontCtrlA |
WriteDiskFontHeaderA
WriteFontContents


Unit 'diskfont' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'diskfont': Variables

DiskfontBase

IDiskfont


Index of all identifiers in unit 'diskfont'

A C D E F G I M N O P S T U W

A

AFB_BITMAP | AFB_TAGGED | AFF_OTAG
AFB_CHARSET | AFB_TYPE | AFF_SCALED
AFB_DISK | AFF_BITMAP | AFF_TAGGED
AFB_MEMORY | AFF_CHARSET | AFF_TYPE
AFB_OTAG | AFF_DISK | AvailFonts
AFB_SCALED | AFF_MEMORY |

C

CloseOutlineFont

D

DFCS_MAPTABLE | DFCTRL_CHARSET | DFH_ID
DFCS_MIMENAME | DFCTRL_SORT_ASC | DiskfontBase
DFCS_NAME | DFCTRL_SORT_DES | DiskfontClone
DFCS_NEXTNUMBER | DFCTRL_SORTMODE | DiskfontExpunge
DFCS_NUMBER | DFCTRL_SORT_OFF | DISKFONTNAME
DFCTRL_ANTIALIASING | DFCTRL_XDOTP | DiskfontObtain
DFCTRL_BASE | DFCTRL_XDPI | DiskfontRelease
DFCTRL_CACHE | DFCTRL_YDOTP | DisposeFontContents
DFCTRL_CACHEFLUSH | DFCTRL_YDPI |

E

ECloseEngine | EOpenEngine | ESetInfoA
EObtainInfoA | EReleaseInfoA |

F

FCH_ID FreeTTextAttr

G

GetDiskFontCtrl

I

IDiskfont

M

MAXFONTNAME MAXFONTPATH

N

NewFontContents NewScaledDiskFont

O

ObtainCharsetInfo | OTF_Type1CID | OTS_Black
ObtainTTextAttr | OTF_Type42 | OTS_Bold
OFB_OPEN | OTF_WinFonts | OTS_Book
OFCH_ID | OT_GlyphCode | OTS_DemiBold
OFF_OPEN | OT_GlyphCode2 | OTS_DemiLight
OpenDiskFont | OT_GlyphCode2_32 | OT_SerifFlag
OpenOutlineFont | OT_GlyphCode_32 | OT_SetFactor
OT_AFMFile | OT_GlyphMap | OTS_ExtraBlack
OT_AvailSizes | OT_GlyphMap8Bit | OTS_ExtraBold
OT_BaseLine | OT_GlyphMap8BitLCD | OTS_ExtraLight
OT_BIName | OT_GlyphMap8BitLCDV | OTS_ExtraThin
OT_BMSize | OT_GlyphName | OT_ShearCos
OT_BName | OT_GlyphWidth | OT_ShearSin
OT_DesignKernPair | OT_HasGlyphs | OTS_Italic
OT_DeviceDPI | OTH_Compressed | OT_SlantStyle
OT_DotSize | OTH_Condensed | OTS_LeftItalic
OTE_Bullet | OTH_Expanded | OTS_Light
OT_EmboldenX | OTH_ExtraCompressed | OTS_Medium
OT_EmboldenY | OTH_ExtraExpanded | OT_SpaceFactor
OT_Engine | OTH_Normal | OT_SpaceWidth
OTERR_BadData | OT_HorizStyle | OT_Spec
OTERR_BadFace | OTH_SemiExpanded | OT_Spec1
OTERR_BadGlyph | OTH_UltraCompressed | OT_SpecCount
OTERR_BadTag | OT_IName | OTS_SemiBold
OTERR_Failure | OT_Indirect | OTS_SemiLight
OTERR_NoFace | OT_InhibitAlgoStyle | OT_StemWeight
OTERR_NoGlyph | OT_IsFixed | OTS_Thin
OTERR_NoMemory | OT_IsUnderlined | OT_StrikeThrough
OTERR_NoRotate | OT_Level0 | OTSUFFIX
OTERR_NoShear | OT_Level1 | OTS_UltraBlack
OTERR_Success | OT_Level2 | OTS_UltraThin
OTERR_TooSmall | OT_Level3 | OTS_Upright
OTERR_UnknownGlyph | OT_MAXAVAILSIZES | OT_TextKernPair
OTERR_UnknownTag | OT_MemPtr | OTUL_Broken
OT_Family | OT_MemSize | OTUL_DoubleBroken
OTF_BDF | OT_MetricsFile | OTUL_DoubleSolid
OTF_CFF | OT_NumGlyphs | OTUL_None
OT_FileIdent | OT_NumKernPairs | OTUL_Solid
OTF_Intellifont | OT_OTagList | OT_UnderLined
OT_FontFile | OT_OTagPath | OT_UnicodeRanges
OT_FontFormat | OT_PointHeight | OT_WidthList
OTF_PCF | OT_PointSize | OT_WidthList32
OTF_PFR | OT_RName | OT_YSizeFactor
OTF_TrueType | OT_RotateCos | OUTL_DoubleBroken
OTF_Type1 | OT_RotateSin |

P

PAvailFonts | PFontContentsHeader | POutlineFont
PAvailFontsHeader | PGlyphEngine | PTAvailFonts
PDiskFontHeader | PGlyphMap | PTFontContents
PEGlyphEngine | PGlyphWidthEntry |
PFontContents | PGlyphWidthEntry32 |

S

SetDiskFontCtrlA

T

TAvailFonts | TFontContents | TGlyphWidthEntry32
TAvailFontsHeader | TFontContentsHeader | TOutlineFont
TDiskFontHeader | TGlyphEngine | TTAvailFonts
TEGlyphEngine | TGlyphMap | TTFontContents
TFCH_ID | TGlyphWidthEntry |

U

UCR_ALPHABETIC_PRESENTATION_FORMS | UCR_DINGBATS | UCR_LETTERLIKE_SYMBOLS
UCR_ARABIC | UCR_ENCLOSED_ALPHANUMERICS | UCR_MALAYALAM
UCR_ARABIC_PRESENTATIONS_A | UCR_ENCLOSED_CJK_LETTERS_MONTHS | UCR_MATHEMATICAL_OPERATORS
UCR_ARABIC_PRESENTATIONS_B | UCR_ETHIOPIC | UCR_MISCELLANEOUS_SYMBOLS
UCR_ARMENIAN | UCR_GENERAL_PUNCTUATION | UCR_MISCELLANEOUS_TECHNICAL
UCR_ARROWS | UCR_GEOMETRIC_SHAPES | UCR_MONGOLIAN
UCR_BASIC_LATIN | UCR_GEORGIAN | UCR_MYANMAR
UCR_BENGALI | UCR_GREEK | UCR_NUMBER_FORMS
UCR_BLOCK_ELEMENTS | UCR_GREEK_EXTENDED | UCR_OCR
UCR_BOPOMOFO | UCR_GUJARATI | UCR_OGHAM
UCR_BOX_DRAWING | UCR_GURMUKHI | UCR_ORIYA
UCR_BRAILLE | UCR_HALFWIDTH_FULLWIDTH_FORMS | UCR_PRIVATE_USE
UCR_CANADIAN_ABORIGINAL_SYLLABICS | UCR_HANGUL | UCR_RUNIC
UCR_CHEROKEE | UCR_HANGUL_COMPATIBILITY_JAMO | UCR_SINHALA
UCR_CJK_COMPATIBILITY | UCR_HANGUL_JAMO | UCR_SMALL_FORM_VARIANTS
UCR_CJK_COMPATIBILITY_FORMS | UCR_HEBREW | UCR_SPACING_MODIFIER
UCR_CJK_COMPATIBILITY_IDEOGRAPHS | UCR_HIRAGANA | UCR_SPECIALS
UCR_CJK_MISC | UCR_IPA_EXTENSIONS | UCR_SUPERSCRIPTS_SUBSCRIPTS
UCR_CJK_SYMBOLS | UCR_KANBUN | UCR_SURROGATES
UCR_CJK_UNIFIED_IDEOGRAPHS | UCR_KANNADA | UCR_SYRIAC
UCR_COMBINING_DIACRITICS | UCR_KATAKANA | UCR_TAMIL
UCR_COMBINING_DIACRITICS_SYMB | UCR_KHMER | UCR_TELUGU
UCR_COMBINING_HALF_MARKS | UCR_LAO | UCR_THAANA
UCR_CONTROL_PICTURES | UCR_LATIN1_SUPPLEMENT | UCR_THAI
UCR_CURRENCY_SYMBOLS | UCR_LATIN_EXTENDED_A | UCR_TIBETAN
UCR_CYRILLIC | UCR_LATIN_EXTENDED_ADDITIONAL | UCR_YI
UCR_DEVANAGARI | UCR_LATIN_EXTENDED_B |

W

WriteDiskFontHeaderA WriteFontContents


AvailFonts

Inquire available memory and disk fonts.

Declaration

Source position: diskfont.pas line 450

function AvailFonts(

  Buffer: PChar;

  BufBytes: LongInt;

  Flags: LongWord

):LongInt;

Arguments

Buffer | memory to be filled with TAvailFontsHeader followed by an array of TAvailFonts elements, which contains entries for the available fonts and their names.
BufBytes | the number of bytes in the buffer
Flags | AFF_MEMORY is set to search memory for fonts to fill the structure, AFF_DISK is set to search the disk for fonts to fill the structure. AFF_SCALED is set to not filter out memory fonts that are not designed. Any combination may be specified. AFF_TAGGED is set to fill the buffer with TTAvailFonts elements instead of TAvailFonts elements.

Function result

if non-zero, this indicates the number of bytes needed for AvailFonts in addition to those supplied. Thus structure elements were not returned because of insufficient bufBytes.

Description

AvailFonts fills a user supplied buffer with the structure, described below, that contains information about all the fonts available in memory and/or on disk. Those fonts available on disk need to be loaded into memory and opened via OpenDiskFont, those already in memory are accessed via OpenFont. The TTextAttr structure required by the open calls is part of the information AvailFonts supplies.

When AvailFonts fails, it returns the number of extra bytes it needed to complete the command. Add this number to your current buffer size, allocate a new buffer, and try again.


CloseOutlineFont

Declaration

Source position: diskfont.pas line 466

procedure CloseOutlineFont(

  Olf: POutlineFont;

  List: PList

);


DiskfontClone

Declaration

Source position: diskfont.pas line 448

function DiskfontClone: PInterface;


DiskfontExpunge

Declaration

Source position: diskfont.pas line 447

procedure DiskfontExpunge;


DiskfontObtain

Declaration

Source position: diskfont.pas line 445

function DiskfontObtain: LongWord;


DiskfontRelease

Declaration

Source position: diskfont.pas line 446

function DiskfontRelease: LongWord;


DisposeFontContents

Declaration

Source position: diskfont.pas line 452

procedure DisposeFontContents(

  FontContentsHeader: PFontContentsHeader

);


ECloseEngine

Declaration

Source position: diskfont.pas line 458

procedure ECloseEngine(

  EEngine: PEGlyphEngine

);


EObtainInfoA

Declaration

Source position: diskfont.pas line 461

function EObtainInfoA(

  EEngine: PEGlyphEngine;

  TagList: PTagItem

):LongWord;


EOpenEngine

Declaration

Source position: diskfont.pas line 457

function EOpenEngine(

  EEngine: PEGlyphEngine

):LongInt;


EReleaseInfoA

Declaration

Source position: diskfont.pas line 463

function EReleaseInfoA(

  EEngine: PEGlyphEngine;

  TagList: PTagItem

):LongWord;


ESetInfoA

Declaration

Source position: diskfont.pas line 459

function ESetInfoA(

  EEngine: PEGlyphEngine;

  TagList: PTagItem

):LongWord;


FreeTTextAttr

Declaration

Source position: diskfont.pas line 472

procedure FreeTTextAttr(

  Tta: PTextFont

);


GetDiskFontCtrl

Declaration

Source position: diskfont.pas line 454

function GetDiskFontCtrl(

  TagId: LongInt

):LongInt;


NewFontContents

Declaration

Source position: diskfont.pas line 451

function NewFontContents(

  FontsLock: LongInt;

  const FontName: PChar

):PFontContentsHeader;


NewScaledDiskFont

Declaration

Source position: diskfont.pas line 453

function NewScaledDiskFont(

  SourceFont: PTextFont;

  DestTextAttr: PTextAttr

):PDiskFontHeader;


ObtainCharsetInfo

Declaration

Source position: diskfont.pas line 470

function ObtainCharsetInfo(

  KnownTag: LongWord;

  KnowValue: LongWord;

  WantedTag: LongWord

):LongWord;


ObtainTTextAttr

Declaration

Source position: diskfont.pas line 471

function ObtainTTextAttr(

  Font: PTextFont

):PTextFont;


OpenDiskFont

Declaration

Source position: diskfont.pas line 449

function OpenDiskFont(

  TextAttr: PTextAttr

):PTextFont;


OpenOutlineFont

Declaration

Source position: diskfont.pas line 465

function OpenOutlineFont(

  const Name: PChar;

  List: PList;

  Flags: LongWord

):POutlineFont;


SetDiskFontCtrlA

Declaration

Source position: diskfont.pas line 455

procedure SetDiskFontCtrlA(

  TagList: PTagItem

);


WriteDiskFontHeaderA

Declaration

Source position: diskfont.pas line 468

function WriteDiskFontHeaderA(

  Font: PTextFont;

  const FileName: PChar;

  const TagList: PTagItem

):LongInt;


WriteFontContents

Declaration

Source position: diskfont.pas line 467

function WriteFontContents(

  FontsLock: LongInt;

  const FontName: PChar;

  FontContentsHeader: PFontContentsHeader

):LongInt;


Reference for unit 'exec': Procedures and functions

AbortIO | Attempt to abort an in-progress I/O request
AddDevice | Adds a device to the system
AddHead | Insert a node at the head of a list
AddInterface
AddIntServer | Adds a interrupt server to the system
AddLibrary | Adds a library to the system
AddMemHandler |
AddMemList | add memory to the system free pool
AddPort | Add a public message port to the system
AddResetCallback
AddResource | Add a resource to the system
AddSemaphore | Initialize then add a signal semaphore to the system
AddTail | Append node to tail of a list
AddTask | Add a Task to the System
AddTrackable
Alert | Alert the user of an error
AllocAbs | Allocate at a given location
Allocate | Allocate a block of memory
AllocEntry | Allocate many regions of memory
AllocNamedMemory
AllocPooled | Allocate memory in a memory pool
AllocSignal | Allocate a signal bit
AllocSysObject
AllocTaskMemEntry
AllocTrap | Allocate a processor trap vector
AllocVec | Allocate memory and keep track of the size
AllocVecPooled
AllocVecTagList
AttemptNamedMemory
AttemptSemaphore | Try to obtain a Semaphore without blocking
AttemptSemaphoreShared | Try to obtain a Semaphore without blocking in shared mode
AvailMem | Check memory available given certain requirements
AVL_AddNode |
AVL_FindFirstNode |
AVL_FindLastNode |
AVL_FindNextNodeByAddress |
AVL_FindNextNodeByKey |
AVL_FindNode |
AVL_FindPrevNodeByAddress |
AVL_FindPrevNodeByKey |
AVL_RemNodeByAddress |
AVL_RemNodeByKey |
BeginIO |
BitMask | Returns the Bit as Longint Value
CacheClearE |
CacheClearU |
CacheControl |
CachePostDMA |
CachePreDMA |
Cause | Fire and software interrupt
CheckIO | Check status on an I/O request
CloseDevice | Close access to a device.
CloseLibrary | Close access to library
ColdReboot | Reboot the Computer
CopyMem | Copy a given numbers ob bytes in memory
CopyMemQuick | Fast memory copy function
CreateExtIO |
CreateIORequest | Create a structure usable for an I/O request
CreateLibrary
CreateMsgPort | Create a new message port
CreatePool | Create a new pool for memory allocations
CreatePort |
CreateTask |
Deallocate | Free a block of memory
DeleteExtIO |
DeleteInterface
DeleteIORequest | Free an i/O request
DeleteLibrary
DeleteMsgPort | Free a message port
DeletePool | Free a memory pool
DeletePort |
DeleteTask |
DeleteTrackable
Disable | Disable interrupt processing
DoIO | Perform an I/O request and wait for its finish
DropInterface
Emulate
Enable | Enable interrupt processing
EndDMA
Enqueue | Insert or append node to a system list
ExecAllocMem | Allocate memory given certain requirements
ExecClone
ExecExpunge
ExecFreeMem | Free a memory block with given size
ExecInsert | Insert a node into a list
ExecObtain
ExecRelease
FindIName
FindName | Find a node in a system list by name
FindNamedMemory
FindPort | Find a system message port by name
FindResident | Find a resident module by name
FindSemaphore | Find Semaphore by name
FindTask | Find task by name get own task
FindTrackable
Forbid | Forbid task scheduling.
FreeEntry | Free many blocks of memory at once
FreeNamedMemory
FreePooled | Free pooled memory block
FreeSignal | Free a signal bit
FreeSysObject
FreeTrap | Free a processor trap
FreeVec | Free memory with tracked size made using AllocVec()
FreeVecPooled
GetCC |
GetCPUInfo
GetDMAList
GetHead
GetInterface
GetMsg | Get next message from message port
GetPred
GetSucc
GetTail
IceColdReboot
InitCode | Initialize resident code modules (internal function)
InitData
InitResident | Initialize resident module
InitSemaphore | Initialize a signal semaphore
InitStruct | Initialize memory from a table
IsListEmpty | Check if a list is empty
IsMinListEmpty
IsMsgPortEmpty | Check if a messageport is empty
IsNative
ItemPoolAlloc
ItemPoolControl
ItemPoolFlush
ItemPoolFree
ItemPoolGC
KMemCacheAlloc
KMemCacheCreate
KMemCacheDestroy
KMemCacheFind
KMemCacheFree
KMemCacheGrow
KMemCacheReap
LockMem
LockNamedMemory
Makefunctions | Construct a function jump table
MakeInterface
MakeLibrary | Construct a library
MoveList
MutexAttempt
MutexAttemptWithSignal
MutexObtain
MutexRelease
NewList |
NewListType
NewMinList |
NewStackRun
ObtainQuickVector | Obtain and install a Quick Interrupt vector
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreList | Get a List of semaphores
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
OpenDevice | Open a device for use
OpenLibrary | Open a library to use
OpenResource | Open an resource for use
OwnerOfMem
PageBackendAlloc
PageBackendAllocAligned
PageBackendFree
PageBackendLock
PageBackendUnlock
PageDrop
PageFindByVA
PageGet
PageHash
PageMap
PageMapAligned
PagerAssignPager
PagerFindPageOut
PagerPageIn
PagerPageOut
PageUnhash
PageUnmap
Permit | Permit task rescheduling.
Procure | Asynchron locking of a semaphore
PutMsg | Put a message to a message port
RawDoFmt | Format data into a character stream.
RawMayGetChar
RawPutChar
ReallocVec
ReleaseSemaphore | Make signal semaphore available to others
ReleaseSemaphoreList | Make a list of semaphores available
RemDevice | Remove a device from the system
RemHead | Remove the head node from a list
RemInterface
RemIntServer | Remove an interrupt server from a server chain
RemLibrary | Remove a library from the system
RemMemHandler | Remove low memory handler from exec
Remove | Remove a node from a list
RemPort | Remove a message port from the system
RemResetCallback
RemResource | Remove a resource from the system
RemSemaphore | Remove a signal semaphore from the system
RemTail | Remove the tail node from a list
RemTask | Remove a task from the system
RemTrackable
ReplyMsg | Put a message to its reply port
Reschedule
RestartTask
RMapAlloc
RMapExtAlloc
RMapExtFree
RMapFree
ScanNamedMemory
SendIO | Initiate an I/O command
SetExcept | Define certain signals to cause exceptions
Setfunction | Change a function vector in a library
SetIntVector | Set a new handler for a system interrupt vector
SetMethod
SetSignal | Define the state of this task's signals
SetSR | Get and/or set processor status register
SetTaskPri | Get and set the priority of a task
SetTaskTrap
Signal | Signal a task
StackSwap |
StartDMA
SumInterface
SumKickData |
SumLibrary | Compute and check the checksum on a library
SuperState | Enter supervisor state with user stack
Supervisor | Trap to a short supervisor mode function
SuspendTask
TypeOfMem | Determine attributes of a given memory address
UnLockMem
UnlockNamedMemory
UpdateNamedMemory
UserState | Return to user state with user stack
Vacate | Release a bidMessage from Procure()
VMAreaInit
VMAreaTerm
Wait | Wait for one or more signals
WaitIO | Wait for completion of an I/O request
WaitPort | Wait for a given port to be non-empty


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'exec': Variables

ExecBase


Index of all identifiers in unit 'exec'

A B C D E F G I K L M N O P R S T U V W

A

AbortIO | AN_DiskError | ASOHOOK_Subentry
AbsExecBase | AN_DiskfontLib | ASOINTR_Code
ACPU_AddressErr | AN_DiskRsrc | ASOINTR_Data
ACPU_AutoVec1 | AN_DOSLib | ASOINTR_Size
ACPU_AutoVec2 | AN_DRHasDisk | ASOINTR_SoftInt
ACPU_AutoVec3 | AN_DRIntNoAct | ASOIOR_Duplicate
ACPU_AutoVec4 | AN_endTask | ASOIOR_ReplyPort
ACPU_AutoVec5 | AN_ExcptVect | ASOIOR_Size
ACPU_AutoVec6 | AN_ExecLib | ASOITEM_BatchSize
ACPU_AutoVec7 | AN_ExpansionLib | ASOITEM_Constructor
ACPU_BusErr | AN_FileReclosed | ASOITEM_Destructor
ACPU_CHK | AN_FreeTwice | ASOITEM_GCParameter
ACPU_DivZero | AN_FreeVec | ASOITEM_GCPolicy
ACPU_Format | AN_GadgetType | ASOITEM_ItemSize
ACPU_InstErr | AN_GadTools | ASOITEM_MaxSize
ACPU_LineA | AN_GamePortDev | ASOITEM_MFlags
ACPU_LineF | AN_GfxFreeError | ASOITEM_Protected
ACPU_PrivErr | AN_GfxNewError | ASOKMEM_Alignment
ACPU_Spurious | AN_GfxNoLCM | ASOKMEM_Colored
ACPU_Trace | AN_GfxNoMem | ASOKMEM_Compact
ACPU_TRAPV | AN_GfxNoMemMspc | ASOKMEM_Constructor
AddDevice | AN_GraphicsLib | ASOKMEM_Destructor
AddHead | AN_IconLib | ASOKMEM_Name
AddInterface | AN_IFaceChkSum | ASOKMEM_Size
AddIntServer | AN_InitAPtr | ASOKMEM_Type
AddLibrary | AN_IntrMem | ASOLIST_Min
AddMemHandler | AN_Intuition | ASOLIST_Size
AddMemList | AN_IOAfterClose | ASOLIST_Type
AddPort | AN_IOUsedTwice | ASO_MemoryOvr
AddResetCallback | AN_ISemOrder | ASOMSG_Length
AddResource | AN_ItemAlloc | ASOMSG_Name
AddSemaphore | AN_ItemBoxTop | ASOMSG_ReplyPort
AddTail | AN_KeyboardDev | ASOMSG_Size
AddTask | AN_KeyFree | ASOMUTEX_Recursive
AddTrackable | AN_KeyRange | ASONODE_Min
AFB_4XX | AN_LayersLib | ASONODE_Name
AFB_603 | AN_LayersNoMem | ASONODE_Pri
AFB_604 | AN_LibChkSum | ASONODE_Size
AFB_68010 | AN_LongFrame | ASONODE_Type
AFB_68020 | AN_MakeVPort | ASO_NoTrack
AFB_68030 | AN_MathLib | ASOPOOL_CopyName
AFB_68040 | AN_MemCorrupt | ASOPOOL_LockMem
AFB_68060 | AN_MemoryInsane | ASOPOOL_MFlags
AFB_68881 | ANMERROR_DUPLICATENAME | ASOPOOL_Name
AFB_68882 | ANMERROR_NOERROR | ASOPOOL_Protected
AFB_7400 | ANMERROR_NOMEMORY | ASOPOOL_Puddle
AFB_750 | ANMERROR_PARAMETER | ASOPOOL_Threshold
AFB_ALTIVEC | AN_MiscRsrc | ASOPORT_Action
AFB_FPU40 | ANMT_CheckSum | ASOPORT_AllocSig
AFB_OTHER | ANMT_Error | ASOPORT_CopyName
AFB_PRIVATE | AN_NewlibLib | ASOPORT_Name
AFF_4XX | AN_NoBootNode | ASOPORT_Pri
AFF_603 | AN_NoConsole | ASOPORT_Public
AFF_604 | AN_NoFonts | ASOPORT_Signal
AFF_68010 | AN_NoISem | ASOPORT_Size
AFF_68020 | AN_NoWindow | ASOPORT_Target
AFF_68030 | AN_ObsoleteFont | ASORMAP_Base
AFF_68040 | AN_OpenScreen | ASORMAP_CacheMax
AFF_68060 | AN_OpenScrnRast | ASORMAP_Quantum
AFF_68881 | AN_OpenWindow | ASORMAP_Size
AFF_68882 | AN_PlaneAlloc | ASOSEM_CopyName
AFF_7400 | AN_QPktFail | ASOSEM_Name
AFF_750 | AN_RAMLib | ASOSEM_Pri
AFF_ALTIVEC | AN_RegionMemory | ASOSEM_Public
AFF_FPU40 | AN_SemCorrupt | ASOSEM_Size
AFF_OTHER | AN_ShortFrame | ASOTAGS_NumEntries
AFF_PRIVATE | AN_StackProbe | ASOTAGS_Size
AG_BadParm | AN_StartMem | ASOT_DMAENTRY
AG_CloseDev | AN_SubAlloc | ASOT_EXTMEM
AG_CloseLib | AN_SysScrnType | ASOT_HOOK
AG_IOError | AN_TDCalibSeek | ASOT_INTERRUPT
AG_MakeLib | AN_TDDelay | ASOT_IOREQUEST
AG_NoMemory | AN_TextTmpRas | ASOT_ITEMPOOL
AG_NoSignal | AN_TimerDev | ASOT_LIST
AG_Obsolete | AN_TMBadReq | ASOT_MEMPOOL
AG_Opendev | AN_TMBadSupply | ASOT_MESSAGE
AG_OpenLib | AN_TrackDiskDev | ASOT_MUTEX
AG_OpenRes | AN_Unknown | ASOT_NODE
AG_ProcCreate | AN_UtilityLib | ASOT_PORT
Alert | AN_WBBadIOMsg | ASOT_RMAP
AllocAbs | AN_WBBadStartupMsg1 | ASOT_SEMAPHORE
Allocate | AN_WBBadStartupMsg2 | ASOT_TAGLIST
AllocEntry | AN_WBReLayoutToolMenu | AT_Child
AllocNamedMemory | AN_WeirdEcho | AT_Deadend
AllocPooled | AN_Workbench | AT_Param1
AllocSignal | AO_AudioDev | AT_Param2
AllocSysObject | AO_BootStrap | AT_Param3
AllocTaskMemEntry | AO_CIARsrc | AT_Param4
AllocTrap | AO_ConsoleDev | AT_Param5
AllocVec | AO_DiskCopy | AT_Param6
AllocVecPooled | AO_DiskfontLib | AT_Param7
AllocVecTagList | AO_DiskRsrc | AT_Param8
AN_AddSWGadget | AO_DOSLib | AT_Recovery
AN_AsyncPkt | AO_ExecLib | AttemptNamedMemory
AN_AudioDev | AO_ExpansionLib | AttemptSemaphore
AN_BadChkSum | AO_GadTools | AttemptSemaphoreShared
AN_BadExpansionFree | AO_GamePortDev | AvailMem
AN_BadFreeAddr | AO_GraphicsLib | AVL_AddNode
AN_BadGadget | AO_IconLib | AVL_FindFirstNode
AN_BadHook | AO_Intuition | AVL_FindLastNode
AN_BadInitFunc | AO_KeyboardDev | AVL_FindNextNodeByAddress
AN_BadMemory | AO_KeyMapLib | AVL_FindNextNodeByKey
AN_BadMessage | AO_LayersLib | AVL_FindNode
AN_BadOverlay | AO_MathLib | AVL_FindPrevNodeByAddress
AN_BadSegList | AO_MiscRsrc | AVL_FindPrevNodeByKey
AN_BadSemaphore | AO_NewlibLib | AVLKEYCOMP
AN_BadState | AO_RAMLib | AVLNODECOMP
AN_BaseChkSum | AO_TimerDev | AVL_RemNodeByAddress
AN_BitMap | AO_TrackDiskDev | AVL_RemNodeByKey
AN_BltBitMap | AO_Unknown | AVT_Alignment
AN_BogusExcpt | AO_UtilityLib | AVT_Clear
AN_BootError | AO_Workbench | AVT_ClearValue
AN_BootStrap | Pointer | AVT_ClearWithValue
AN_CIARsrc | ASODMAE_NumEntries | AVT_Contiguous
AN_ConsoleDev | ASODMAE_Size | AVT_Lock
AN_CreatePort | ASOEXTMEM_AllocationPolicy | AVT_NoExpunge
AN_CybppcDev | ASOEXTMEM_Size | AVT_PhysicalAlignment
AN_CybppcNoTerm | ASOF_NOTRACK | AVT_Type
AN_CybppcNoWide | ASOHOOK_Data | AVT_Wait
AN_DiskBlkSeq | ASOHOOK_Entry |
AN_DiskCopy | ASOHOOK_Size |

B

BeginIO | SmallInt | LongInt
BitMask | LongInt |

C

CacheClearE | CLT_Seglist | CPUTYPE_PPC405GPR
CacheClearU | CLT_Vector68K | CPUTYPE_PPC405LP
CacheControl | CMD_CLEAR | CPUTYPE_PPC440EP
CachePostDMA | CMD_FLUSH | CPUTYPE_PPC440GP
CachePreDMA | CMD_INVALID | CPUTYPE_PPC440GX
CACRF_ClearD | CMD_NONSTD | CPUTYPE_PPC440SP
CACRF_ClearI | CMD_READ | CPUTYPE_PPC440SX
CACRF_CopyBack | CMD_RESET | CPUTYPE_PPC460EX
CACRF_DBE | CMD_START | CPUTYPE_PPC5121E
CACRF_EnableD | CMD_STOP | CPUTYPE_PPC603E
CACRF_EnableE | CMD_UPDATE | CPUTYPE_PPC604E
CACRF_EnableI | CMD_WRITE | CPUTYPE_PPC7410
CACRF_FreezeD | ColdReboot | CPUTYPE_PPC74XX_APOLLO
CACRF_FreezeI | CopyMem | CPUTYPE_PPC74XX_VGER
CACRF_IBE | CopyMemQuick | CPUTYPE_PPC750CXE
CACRF_InvalidateD | CPUFAMILY_4XX | CPUTYPE_PPC750FX
CACRF_WriteAllocate | CPUFAMILY_60X | CPUTYPE_PPC750GX
Cause | CPUFAMILY_74XX | CPUTYPE_UNKNOWN
CheckIO | CPUFAMILY_7X0 | CreateExtIO
CloseDevice | CPUFAMILY_E300 | CreateIORequest
CloseLibrary | CPUFAMILY_E5500 | CreateLibrary
CLT_DataSize | CPUFAMILY_PA6T | CreateMsgPort
CLT_InitData | CPUFAMILY_UNKNOWN | CreatePool
CLT_InitFunc | CPUTYPE_P50XX | CreatePort
CLT_Interfaces | CPUTYPE_PA6T_1682M | CreateTask
CLT_Legacy | CPUTYPE_PPC405EP | CT_LockStack
CLT_NoLegacyIFace | CPUTYPE_PPC405GP |

D

DBHMT_ADDTASK | DEBUG_SYMBOL_MODULE_STABS | DEV_ABORTIO
DBHMT_CLOSELIB | DEBUG_SYMBOL_NATIVE_MODULE | DEV_beginIO
DBHMT_EXCEPTION | DeleteExtIO | Disable
DBHMT_OPENLIB | DeleteInterface | DMA_Continue
DBHMT_REMTASK | DeleteIORequest | DMAF_Continue
DBHMT_SHAREDOBJECTCLOSE | DeleteLibrary | DMAF_NoModify
DBHMT_SHAREDOBJECTOPEN | DeleteMsgPort | DMAF_ReadFromRAM
Deallocate | DeletePool | DMA_NoModify
DEBUG_SYMBOL_68K_MODULE | DeletePort | DMA_ReadFromRAM
DEBUG_SYMBOL_KERNEL_MODULE | DeleteTask | DoIO
DEBUG_SYMBOL_MODULE | DeleteTrackable | DropInterface

E

ECF_FPU | ET_FPRegisters | ET_RegisterD7
ECF_FULL_FPU | ET_NoJIT | ET_SaveParamRegs
ECF_FULL_GPRS | ET_Offset | ET_SaveRegs
ECF_VECTOR | ET_RegisterA0 | ET_StackPtr
ECF_VRSAVE | ET_RegisterA1 | ET_SuperState
EFPF_FP0 | ET_RegisterA2 | ExecAllocMem
EFPF_FP1 | ET_RegisterA3 | ExecBase
EFPF_FP2 | ET_RegisterA4 | ExecClone
EFPF_FP3 | ET_RegisterA5 | ExecExpunge
EFPF_FP4 | ET_RegisterA6 | ExecFreeMem
EFPF_FP5 | ET_RegisterA7 | ExecInsert
EFPF_FP6 | ET_RegisterD0 | ExecObtain
EFPF_FP7 | ET_RegisterD1 | ExecRelease
Emulate | ET_RegisterD2 | EXTMEMPOLICY_ACCESS
Enable | ET_RegisterD3 | EXTMEMPOLICY_DELAYED
EndDMA | ET_RegisterD4 | EXTMEMPOLICY_IMMEDIATE
Enqueue | ET_RegisterD5 |
ET_FPRegisterMask | ET_RegisterD6 |

F

FindIName | FindTask | FreeSignal
FindName | FindTrackable | FreeSysObject
FindNamedMemory | Forbid | FreeTrap
FindPort | FreeEntry | FreeVec
FindResident | FreeNamedMemory | FreeVecPooled
FindSemaphore | FreePooled |

G

GCIT_CacheLineSize | GCIT_Model | GetCPUInfo
GCIT_CPUPageSize | GCIT_ModelString | GetDMAList
GCIT_ExecPageSize | GCIT_NumberOfCPUs | GetHead
GCIT_Extensions | GCIT_ProcessorSpeed | GetInterface
GCIT_Family | GCIT_TimeBaseSpeed | GetMsg
GCIT_FrontsideSpeed | GCIT_VectorUnit | GetPred
GCIT_L1CacheSize | GCIT_Version | GetSucc
GCIT_L2CacheSize | GCIT_VersionString | GetTail
GCIT_L3CacheSize | GetCC | GMAF_REPORT_CR

I

IceColdReboot | InitStruct | IsListEmpty
IFLF_CHANGED | INTB_NMI | IsMinListEmpty
IFLF_CLONED | INTF_NMI | IsMsgPortEmpty
IFLF_CLONE_EXPUNGE | IOB_QUICK | IsNative
IFLF_NONE | IOERR_ABORTED | ITEMGC_AFTERCOUNT
IFLF_NOT_NATIVE | IOERR_BADADDRESS | ITEMGC_NONE
IFLF_PRIVATE | IOERR_BADLENGTH | ItemPoolAlloc
IFLF_PROTECTED | IOERR_NOCMD | ItemPoolControl
IFLF_UNMODIFIED | IOERR_OPENFAIL | ItemPoolFlush
InitCode | IOERR_SELFTEST | ItemPoolFree
InitData | IOERR_SUCCESS | ItemPoolGC
InitResident | IOERR_UNITBUSY |
InitSemaphore | IOF_QUICK |

K

KMemCacheAlloc | KMemCacheFind | KMemCacheReap
KMemCacheCreate | KMemCacheFree | KMEMT_PRIVATE
KMemCacheDestroy | KMemCacheGrow | KMEMT_SHARED

L

LEN_DISASSEMBLE_OPCODE_STRING | LIB_EXTFUNC | LIB_RESERVED
LEN_DISASSEMBLE_OPERANDS_STRING | LIBF_CHANGED | LIB_USERDEF
LFalse | LIBF_DELEXP | LIB_VECTSIZE
LIBABI_68K | LIBF_EXP0CNT | LockMem
LIBABI_MIFACE | LIBF_SUMMING | LockNamedMemory
LIB_BASE | LIBF_SUMUSED | LongInt
LIB_CLOSE | LIB_NONSTD | LongWord
LIB_EXPUNGE | LIB_OPEN | LTrue

M

Makefunctions | MEMATTRF_SUPER_RO_USER_RO | MEMF_KICK
MakeInterface | MEMATTRF_SUPER_RW | MEMF_LARGEST
MakeLibrary | MEMATTRF_SUPER_RW_USER_RO | MEMF_LOCAL
MEM_ALL_DONE | MEMATTRF_SUPER_RW_USER_RW | MEMF_NO_EXPUNGE
MEMATTRF_CACHEINHIBIT | MEMATTRF_WRITETHROUGH | MEMF_PRIVATE
MEMATTRF_CHANGED | MEM_BLOCKMASK | MEMF_PUBLIC
MEMATTRF_COHERENT | MEM_BLOCKSIZE | MEMF_REVERSE
MEMATTRF_EXECUTE | MEM_DID_NOTHING | MEMF_SHARED
MEMATTRF_GUARDED | MEMF_24BITDMA | MEMF_TOTAL
MEMATTRF_NOT_MAPPED | MEMF_ANY | MEMF_VIRTUAL
MEMATTRF_READ_ONLY | MEMF_CHIP | MEMHF_RECYCLE
MEMATTRF_READ_WRITE | MEMF_CLEAR | MEM_TRY_AGAIN
MEMATTRF_REFERENCED | MEMF_CORE_RESIDENT | MoveList
MEMATTRF_RESERVED1 | MEMF_DELAYED | MutexAttempt
MEMATTRF_RESERVED2 | MEMF_EXECUTABLE | MutexAttemptWithSignal
MEMATTRF_RESERVER3 | MEMF_FAST | MutexObtain
MEMATTRF_RW_MASK | MEMF_HWALIGNED | MutexRelease

N

NewList | NT_DEATHMESSAGE | NT_MESSAGE
NewListType | NT_DEVICE | NT_MSGPORT
NewMinList | NT_ELFHANDLE | NT_PAGE
NewStackRun | NT_EXTENDED | NT_PROCESS
NSR_Arg1 | NT_EXTINTERRUPT | NT_REPLYMSG
NSR_Arg2 | NT_EXTSOFTINT | NT_RESERVED1
NSR_Arg3 | NT_FILESYSTEM | NT_RESOURCE
NSR_Arg4 | NT_FONT | NT_SEMAPHORE
NSR_Arg5 | NT_FREEMSG | NT_SIGNALSEM
NSR_Arg6 | NT_GRAPHICS | NT_SOFTINT
NSR_Dummy | NT_INTERFACE | NT_SOLIBHANDLE
NSR_LockStack | NT_INTERRUPT | NT_TASK
NSR_MinStackSize | NT_KICKMEM | NT_UNKNOWN
NSR_StackSize | NT_KMEMCACHE | NT_USER
NT_BOOTNODE | NT_LIBRARY | NT_VMAREA
NT_CLASS | NT_MEMORY | NT_VMAREA_PROXY

O

ObtainQuickVector | ObtainSemaphoreShared | OpenResource
ObtainSemaphore | OpenDevice | OwnerOfMem
ObtainSemaphoreList | OpenLibrary |

P

PageBackendAlloc | PAVLNODECOMP | PMessage
PageBackendAllocAligned | PDevice | PMinList
PageBackendFree | PDMAEntry | PMinNode
PageBackendLock | Permit | PMsgPort
PageBackendUnlock | PExceptionContext | PNode
PageDrop | PExecBase | PPAVLNode
PageFindByVA | PF_ACTION | PPTagItem
PageGet | PF_SIGALLOC | PResident
PageHash | PHook | Procure
PageMap | PInterface | PSemaphoreMessage
PageMapAligned | PInterrupt | PSemaphoreRequest
PagerAssignPager | PIntVector | PSignalSemaphore
PagerFindPageOut | PIORequest | PSNMMessage
PagerPageIn | PIOStdReq | PSoftIntList
PagerPageOut | PLibrary | PStackSwapStruct
PageUnhash | PList | PPChar
PageUnmap | PLONG | PTag
PA_IGNORE | PLONGBITS | PTagItem
PAPTR | PMemChunk | PTask
PA_SIGNAL | PMemEntry | PTrackable
PA_SOFTINT | PMemHandlerData | PULONG
PAVLKEYCOMP | PMemHeader | PUnit
PAVLNode | PMemList | PutMsg

R

RawDoFmt | REG68K_FP1 | RemTask
RawMayGetChar | REG68K_FP2 | RemTrackable
RawPutChar | REG68K_FP3 | ReplyMsg
ReallocVec | REG68K_FP4 | Reschedule
REG68K_A0 | REG68K_FP5 | RestartTask
REG68K_A1 | REG68K_FP6 | RMapAlloc
REG68K_A2 | REG68K_FP7 | RMapExtAlloc
REG68K_A3 | ReleaseSemaphore | RMapExtFree
REG68K_A4 | ReleaseSemaphoreList | RMapFree
REG68K_A5 | RemDevice | RTCF_FPU
REG68K_A6 | RemHead | RTCF_GENERAL
REG68K_A7 | RemInterface | RTCF_INFO
REG68K_D0 | RemIntServer | RTCF_SPECIAL
REG68K_D1 | RemLibrary | RTCF_STATE
REG68K_D2 | RemMemHandler | RTCF_VECTOR
REG68K_D3 | Remove | RTC_MATCHWORD
REG68K_D4 | RemPort | RTF_AFTERDOS
REG68K_D5 | RemResetCallback | RTF_AUTOINIT
REG68K_D6 | RemResource | RTF_COLDSTART
REG68K_D7 | RemSemaphore | RTF_NATIVE
REG68K_FP0 | RemTail | RTF_SINGLETASK

S

ScanNamedMemory | SIGB_INTUITION | STACK_FRAME_DECODED
SDONA_SignalMask | SIGB_NET | STACK_FRAME_INVALID_BACKCHAIN_PTR
SDONA_Task | SIGB_SINGLE | STACK_FRAME_TRASHED_MEMORY_LOOP
SendIO | SIGF_ABORT | StackSwap
SetExcept | SIGF_BLIT | StartDMA
Setfunction | SIGF_CHILD | STB_CRASHED
SetIntVector | SIGF_DOS | STB_REMOVED
SetMethod | SIGF_INTUITION | STF_CRASHED
SetSignal | SIGF_NET | STF_REMOVED
SetSR | SIGF_SINGLE | PChar
SetTaskPri | Signal | SumInterface
SetTaskTrap | SIH_PRIMASK | SumKickData
SIGB_ABORT | SM_EXCLUSIVE | SumLibrary
SIGB_BLIT | SM_SHARED | SuperState
SIGB_CHILD | SNMF_NAMESPACES_ONLY | Supervisor
SIGB_DOS | STACK_FRAME_BACKCHAIN_PTR_LOOP | SuspendTask

T

LongWord | TIORequest | TRAPNUM_SMI
TAG_USER | TIOStdReq | TRAPNUM_THERMAL
Pointer | TLibrary | TRAPNUM_TRACE
TAVLNode | TList | TRAPNUM_TRAP
TB_ETASK | TMemChunk | TRAPTYPE
TB_EXCEPT | TMemEntry | TRAPTYPENR
TB_LAUNCH | TMemHandlerData | TResident
TB_PROCTIME | TMemHeader | TS_ADDED
TB_STACKCHK | TMemList | TS_CRASHED
TB_SWITCH | TMessage | TSemaphoreMessage
TDebugOutputNotify | TMinList | TSemaphoreRequest
TDebugSymbol | TMinNode | TS_EXCEPT
TDevice | TMsgPort | TSignalSemaphore
TDMAEntry | TNode | TS_INVALID
TEmuTrap | TRACKF_COMPACT | TSNMMessage
TEmuTrapfunction | TRAPINST | TSoftIntList
TExceptionContext | TRAPNUM_ALIGNMENT | TS_READY
TExecBase | TRAPNUM_ALTIVEC_ASSIST | TS_REMOVED
TF_ETASK | TRAPNUM_BUS_ERROR | TS_RUN
TF_EXCEPT | TRAPNUM_DATA_BREAKPOINT | TS_SUSPENDED
TF_LAUNCH | TRAPNUM_DATA_SEGMENT_VIOLATION | TStackFrameMsg
TF_PROCTIME | TRAPNUM_FPU | TStackSwapStruct
TF_STACKCHK | TRAPNUM_ILLEGAL_INSTRUCTION | TS_WAIT
TF_SWITCH | TRAPNUM_INST_BREAKPOINT | TTagItem
THook | TRAPNUM_INST_SEGMENT_VIOLATION | TTask
TInterface | TRAPNUM_NUMTRAPS | TTrackable
TInterfaceData | TRAPNUM_PERFORMANCE | TUnit
TInterrupt | TRAPNUM_PRIVILEGE_VIOLATION | TypeOfMem
TIntVector | TRAPNUM_RESERVED1 |

U

Byte | UNITF_INTASK | UpdateNamedMemory
LongWord | UnLockMem | UserState
UNITF_ACTIVE | UnlockNamedMemory | Word

V

Vacate | VECTORTYPE_NONE | VMAreaTerm
VECTORTYPE_ALTIVEC | VMAreaInit |

W

Wait | WaitPort
WaitIO | Word


AbortIO

Attempt to abort an in-progress I/O request

Declaration

Source position: exec.pas line 1857

procedure AbortIO(

  IORequest: PIORequest

);

Arguments

IORequest

Pointer to an I/O request block (must have been used at least once. May be active or finished).

Description

Ask a device to abort a previously started IORequest. This is done by calling the device's ABORTIO vector, with your given IORequest.

AbortIO() is a command the device that may or may not grant. If successful, the device will stop processing the IORequest, and reply to it earlier than it would otherwise have done.

NOTE:

AbortIO() does NOT Remove() the IORequest from your ReplyPort, OR wait for it to complete. After an AbortIO() you must wait normally for the reply message before actually reusing the request.

If a request has already completed when AbortIO() is called, no action is taken.

Snippet

AbortIO(timer_request);
WaitIO(timer_request);
// Message is free to be reused

See also

SendIO | Initiate an I/O command
WaitIO | Wait for completion of an I/O request
DoIO | Perform an I/O request and wait for its finish


AddDevice

Adds a device to the system

Declaration

Source position: exec.pas line 1837

procedure AddDevice(

  Device: PDevice

);

Arguments

Device

Pointer to a initialized device structure

Description

This function adds a new device to the system device list, making it available to other programs. The device must be ready to be opened at this time.

See also

RemDevice | Remove a device from the system
OpenDevice | Open a device for use
CloseDevice | Close access to a device.
MakeLibrary | Construct a library


AddHead

Insert a node at the head of a list

Declaration

Source position: exec.pas line 1746

procedure AddHead(

  List: PList;

  Node: PNode

);

Arguments

List | Pointer to list to which the node should be inserted
Node | Pointer to node to insert

Description

This function inserts a node at the head of the list. The node will be the first node in the list after this function.

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.

See also

Exec.ExecInsert | Insert a node into a list
Remove | Remove a node from a list
RemHead | Remove the head node from a list
AddTail | Append node to tail of a list
RemTail | Remove the tail node from a list
Enqueue | Insert or append node to a system list


AddInterface

Declaration

Source position: exec.pas line 1842

procedure AddInterface(

  Lib: PLibrary;

  Interface_: PInterface

);


AddIntServer

Adds a interrupt server to the system

Declaration

Source position: exec.pas line 1866

procedure AddIntServer(

  IntNumber: LongWord;

  Interrupt_: PInterrupt

);

Arguments

IntNumber | Number of Interrupt
Interrupt_ | Pointer to an Interrupt structure. By convention, the LN_NAME of the interrupt structure must point a descriptive string so that other users may identify who currently has control of the interrupt.

Description

This function adds a new interrupt server to a given server chain. The node is located on the chain in a priority dependent position. If this is the first server on a particular chain, interrupts will be enabled for that chain.

See also

RemIntServer | Remove an interrupt server from a server chain
Cause | Fire and software interrupt


AddLibrary

Adds a library to the system

Declaration

Source position: exec.pas line 1835

procedure AddLibrary(

  Lib: PLibrary

);

Arguments

Lib

Pointer to a previously initialized library structure

Description

This function adds a new library to the library list. All programs can open it from now on. This function also calculates the checksum of the library.

See also

MakeLibrary | Construct a library
OpenLibrary | Open a library to use
RemLibrary | Remove a library from the system
CloseLibrary | Close access to library


AddMemHandler

Declaration

Source position: exec.pas line 1747

procedure AddMemHandler(

  MemHand: PInterrupt

);


AddMemList

add memory to the system free pool

Declaration

Source position: exec.pas line 1748

procedure AddMemList(

  Size: LongWord;

  Attributes: LongWord;

  Pri: LongInt;

  Base: Pointer;

  const Name: PChar

);

Arguments

Size | the size (in bytes) of the memory area
Attributes | the attributes word that the memory pool will have
Pri | the priority for this memory. The higher the priority, the closer to the head of the memory list it will be placed.
Base | the base of the new memory area
Name | the name that will be used in the memory header, or nil if no name is to be provided. This name is not copied, so it must remain valid for as long as the memory header is in the system.

Description

Add a new region of memory to the system free pool. The first few bytes will be used to hold the MemHeader structure. The remainder will be made available to the rest of the world.

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


AddPort

Add a public message port to the system

Declaration

Source position: exec.pas line 1802

procedure AddPort(

  Port: PMsgPort

);

Arguments

Port

Pointer to a message port

Description

This function attaches a message port structure to the system's public message port list, where it can be found by the FindPort() function. The name and priority fields of the port structure must be initialized prior to calling this function. If the user does not require the priority field, it should be initialized to zero.

Only ports that will be searched for with FindPort() need to be added to the system list. In addition, adding ports is often useful during debugging. If the port will be searched for, the priority field should be at least 1 (to avoid the large number of inactive ports at priority zero). If the port will be searched for often, set the priority in the 50-100 range (so it will be before other less used ports).

Once a port has been added to the naming list, you must be careful to remove the port from the list (via RemPort()) before deallocating its memory.

Do not AddPort an active port.

See also

RemPort | Remove a message port from the system
FindPort | Find a system message port by name


AddResetCallback

Declaration

Source position: exec.pas line 1921

function AddResetCallback(

  ResetCallBack: PInterrupt

):LongBool;


AddResource

Add a resource to the system

Declaration

Source position: exec.pas line 1863

procedure AddResource(

  Resource: Pointer

);

Arguments

Resource

Pointer an initialized resource node

Description

This function adds a new resource to the system and makes it available to other users. The resource must be ready to be called at this time.

Resources currently have no system-imposed structure, however they must start with a standard named node (LN_SIZE), and should with a standard Library node (LIB_SIZE).

See also

RemResource | Remove a resource from the system
OpenResource | Open an resource for use
MakeLibrary | Construct a library


AddSemaphore

Initialize then add a signal semaphore to the system

Declaration

Source position: exec.pas line 1814

procedure AddSemaphore(

  SigSem: PSignalSemaphore

);

Arguments

SigSem

An signal semaphore structure

Description

This function attaches a signal semaphore structure to the system's public signal semaphore list. The name and priority fields of the semaphore structure must be initialized prior to calling this function. If you do not want to let others rendezvous with this semaphore, use InitSemaphore() instead.

If a semaphore has been added to the naming list, you must be careful to remove the semaphore from the list (via RemSemaphore()) before deallocating its memory.

Semaphores that are linked together in an allocation list (which ObtainSemaphoreList() would use) may not be added to the system naming list, because the facilities use the link field of the signal semaphore in incompatible ways

See also

RemSemaphore | Remove a signal semaphore from the system
FindSemaphore | Find Semaphore by name
InitSemaphore | Initialize a signal semaphore


AddTail

Append node to tail of a list

Declaration

Source position: exec.pas line 1749

procedure AddTail(

  List: PList;

  Node: PNode

);

Arguments

List | Pointer to the target list
Node | Pointer to the Node to be added

Description

Add a node to the tail of a list. The Node will be the last node in the list.

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.


AddTask

Add a Task to the System

Declaration

Source position: exec.pas line 1787

function AddTask(

  Task: PTask;

  const InitPC: Pointer;

  const FinalPC: Pointer

):Pointer;

Arguments

Task | Pointer to the task control block (TCB). All unset fields must be zero.
InitPC | The initial entry point's address
FinalPC | the finalization code entry point's address. If zero, the system will use a general finalizer. This pointer is placed on the stack as if it were the outermost return address.

Function result

Pointer to Task

Description

Add a task to the system. A reschedule will be run; the task with the highest priority in the system will start to execute (this may or may not be the new task).

Certain fields of the task control block must be initialized and a stack allocated prior to calling this function. The absolute smallest stack that is allowable is something in the range of 100 bytes, but in general the stack size is dependent on what subsystems are called. In general 256 bytes is sufficient if only Exec is called, and 4K will do if anything in the system is called. DO NOT UNDERESTIMATE. If you use a stack sniffing utility, leave a healthy pad above the minimum value. The system guarantees that its stack operations will leave the stack longword aligned.

This function will temporarily use space from the new task's stack for the task's initial set of registers. This space is allocated starting at the SPREG location specified in the task control block (not from SPUPPER). This means that a task's stack may contain static data put there prior to its execution. This is useful for providing initialized global variables or some tasks may want to use this space for passing the task its initial arguments.

A task's initial registers are set to zero (except the PC).

The TC_MEMENTRY field of the task structure may be extended by the user to hold additional MemLists (as returned by AllocEntry()). These will be automatically be deallocated at RemTask() time. If the code you have used to start the task has already added something to the MEMENTRY list, simply use AddHead to add your new MemLists in. If no initialization has been done, a NewList will need to be performed.

Errors

If cannot create task Result will be nil.

See also

RemTask | Remove a task from the system
FindTask | Find task by name get own task


AddTrackable

Declaration

Source position: exec.pas line 1898

function AddTrackable(

  UsingTask: PTask;

  Obj: Pointer;

  DestFunc: PHook

):PTrackable;


Alert

Alert the user of an error

Declaration

Source position: exec.pas line 1870

procedure Alert(

  AlertNum: LongWord

);

Arguments

AlertNum

A number indicating the particular alert. -1 is not a valid input.

Description

Alerts the user of a serious system problem. This function will bring the system to a grinding halt, and do whatever is necessary to present the user with a message stating what happened. Interrupts are disabled, and an attempt to post the alert is made. If that fails, the system is reset. When the system comes up again, Exec notices the cause of the failure and tries again to post the alert.

If the Alert is a recoverable type, this call MAY return.

This call may be made at any time, including interrupts.


AllocAbs

Allocate at a given location

Declaration

Source position: exec.pas line 1750

function AllocAbs(

  ByteSize: LongWord;

  Location: Pointer

):Pointer;

Arguments

ByteSize | The size of the desired block in bytes This number is rounded up to the next larger block size for the actual allocation.
Location | The address where the memory MUST be.

Function result

A pointer to the newly allocated memory block or nil

Description

This function attempts to allocate memory at a given absolute memory location. Often this is used by boot-surviving entities such as recoverable ram-disks. If the memory is already being used, or if there is not enough memory to satisfy the request, AllocAbs will return nil.

This block may not be exactly the same as the requested block because of rounding, but if the return value is non-zero, the block is guaranteed to contain the requested range.

Errors

Result is nil if failed. If the free list is corrupt, the system will panic with alert AN_MemCorrupt, $01000005.

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
Exec.ExecFreeMem | Free a memory block with given size


Allocate

Allocate a block of memory

Declaration

Source position: exec.pas line 1751

function Allocate(

  FreeList: PMemHeader;

  ByteSize: LongWord

):Pointer;

Arguments

FreeList | Pointer to the local memory list header.
ByteSize | Size of the desired block in bytes.

Function result

A pointer to the just allocated free block. If there are no free regions large enough to satisfy the request, return nil.

Description

This function is used to allocate blocks of memory from a given private free memory pool (as specified by a MemHeader and its memory chunk list). Allocate will return the first free block that is greater than or equal to the requested size.

All blocks, whether free or allocated, will be block aligned; hence, all allocation sizes are rounded up to the next block even value (e.g. the minimum allocation resolution is currently 8 bytes. A request for 8 bytes will use up exactly 8 bytes. A request for 7 bytes will also use up exactly 8 bytes.).

This function can be used to manage an application's internal data memory. Note that no arbitration of the MemHeader and associated free chunk list is done. You must be the owner before calling Allocate.

Errors

If the free list is corrupt, the system will panic with alert AN_MemCorrupt, $01000005.

See also

Deallocate

Free a block of memory


AllocEntry

Allocate many regions of memory

Declaration

Source position: exec.pas line 1752

function AllocEntry(

  Entry: PMemList

):PMemList;

Arguments

Entry

A MemList structure filled in with MemEntry structures.

Function result

A different MemList filled in with the actual memory allocated in the me_Addr field, and their sizes in me_Length. If enough memory cannot be obtained, then the requirements of the allocation that failed is returned and bit 31 is set.

Description

This function takes a memList structure and allocates enough memory to hold the required memory as well as a MemList structure to keep track of it.

These MemList structures may be linked together in a task control block to keep track of the total memory usage of this task. (See the description of TC_MEMENTRY under RemTask).

See also

RemTask

Remove a task from the system


AllocNamedMemory

Declaration

Source position: exec.pas line 1966

function AllocNamedMemory(

  ByteSize: LongWord;

  const Space: PChar;

  const Name: PChar;

  TagList: PTagItem

):Pointer;


AllocPooled

Allocate memory in a memory pool

Declaration

Source position: exec.pas line 1754

function AllocPooled(

  PoolHeader: Pointer;

  MemSize: LongWord

):Pointer;

Arguments

PoolHeader | Pointer to the memory pool in which the memory should be allocated.
MemSize | Size of the memory block in bytes

Function result

Pointer to the allocated memory or nil

Description

Allocates memory in a memory pool which is tracked in the pool. A call to DeletePool will free all memory blocks allocated in the pool.

See also

FreePooled | Free pooled memory block
CreatePool | Create a new pool for memory allocations
DeletePool | Free a memory pool


AllocSignal

Allocate a signal bit

Declaration

Source position: exec.pas line 1796

function AllocSignal(

  SignalNum: LongInt

):ShortInt;

Arguments

SignalNum

The desired signal number (of [0..31]) or -1 for no preference.

Function result

The signal bit number allocated [0..31]. If no signals are available, this function returns -1.

Description

Allocate a signal bit from the current tasks' pool. Either a particular bit, or the next free bit may be allocated. The signal associated with the bit will be properly initialized (cleared). At least 16 user signals are available per task. Signals should be deallocated before the task exits.

If the signal is already in use (or no free signals are available) a -1 is returned.

Allocated signals are only valid for use with the task that allocated them.

WARNING

Signals may not be allocated or freed from exception handling code.

See also

FreeSignal

Free a signal bit


AllocSysObject

Declaration

Source position: exec.pas line 1902

function AllocSysObject(

  Type_: LongWord;

  const Tags: PTagItem

):Pointer;


AllocTaskMemEntry

Declaration

Source position: exec.pas line 1975

function AllocTaskMemEntry(

  MemList: PMemList

):PMemList;


AllocTrap

Allocate a processor trap vector

Declaration

Source position: exec.pas line 1875

function AllocTrap(

  TrapNum: LongWord

):LongInt;

Arguments

TrapNum

the desired trap number [0..15] or -1 for no preference.

Function result

The trap number allocated [0..15]. If no traps are available, this function returns -1.

Description

Allocate a trap number from the current task's pool. These trap numbers are those associated with the 68000 TRAP type instructions. Either a particular number, or the next free number may be allocated.

If the trap is already in use (or no free traps are available) a -1 is returned.

This function only affects the currently running task.

Traps are sent to the trap handler pointed at by tc_TrapCode. Unless changed by user code, this points to a standard trap handler.

tc_TrapData is not used.

WARNING

Traps may not be allocated or freed from exception handling code. You are not allowed to write to the exception table yourself.

See also

FreeTrap

Free a processor trap


AllocVec

Allocate memory and keep track of the size

Declaration

Source position: exec.pas line 1755

function AllocVec(

  ByteSize: LongWord;

  Requirements: LongWord

):Pointer;

Arguments

ByteSize | The size of the desired block in bytes. (The operating system will automatically round this number to a multiple of the system memory chunk size)
Requirements | If no flags are set, the system will return the best available memory block. For expanded systems, the fast memory pool is searched first. (MEMF_*)

Function result

A pointer to the newly allocated memory block. If there are no free memory regions large enough to satisfy the request, nil will be returned. The pointer must be checked for zero before the memory block may be used!

Description

Allocate a memory block and record its size, FreeVec() knows how many bytes to free.

Memory is allocated based on requirements and options. Any "requirement" must be met by a memory allocation, any "option" will be applied to the block regardless. AllocMem will try all memory spaces until one is found with the proper requirements and room for the memory request.

See also

FreeVec | Free memory with tracked size made using AllocVec()
Exec.ExecAllocMem | Allocate memory given certain requirements


AllocVecPooled

Declaration

Source position: exec.pas line 1756

function AllocVecPooled(

  PoolHeader: Pointer;

  Size: LongWord

):Pointer;


AllocVecTagList

Declaration

Source position: exec.pas line 1960

function AllocVecTagList(

  Size: LongWord;

  const Tags: PTagItem

):Pointer;


AttemptNamedMemory

Declaration

Source position: exec.pas line 1972

function AttemptNamedMemory(

  const Space: PChar;

  const Name: PChar

):Pointer;


AttemptSemaphore

Try to obtain a Semaphore without blocking

Declaration

Source position: exec.pas line 1815

function AttemptSemaphore(

  SigSem: PSignalSemaphore

):LongBool;

Arguments

SigSem

An initialized signal semaphore structure

Function result

True if the semaphore was locked, false if some other task already possessed the semaphore.

Description

Try to obtain a lock on a Semaphore in exclusive mode all other exclusive and shared locks on this semaphore has to be released before. This call is similar to ObtainSemaphore(), except that it will not block if the semaphore could not be locked.

See also

ReleaseSemaphore | Make signal semaphore available to others
ObtainSemaphore | Gain exclusive access to a semaphore
AttemptSemaphoreShared | Try to obtain a Semaphore without blocking in shared mode
ObtainSemaphoreShared | Gain access to a semaphore in shared mode


AttemptSemaphoreShared

Try to obtain a Semaphore without blocking in shared mode

Declaration

Source position: exec.pas line 1816

function AttemptSemaphoreShared(

  SigSem: PSignalSemaphore

):LongBool;

Arguments

SigSem

An initialized signal semaphore structure

Function result

True if the semaphore was locked, false if some other task already exclusively locked the semaphore.

Description

A lock on a signal semaphore may either be exclusive, or shared. Exclusive locks are granted by the ObtainSemaphore() and AttemptSemaphore() functions. Shared locks are granted by ObtainSemaphoreShared(). Calls may be nested.

Any number of tasks may simultaneously hold a shared lock on a semaphore. Only one task may hold an exclusive lock. A typical application is a list that is often read, but only occasionally written to.

Any exlusive locker will be held off until all shared lockers release the semaphore. Likewise, if an exlusive lock is held, all potential shared lockers will block until the exclusive lock is released. All shared lockers are restarted at the same time. This call is similar to ObtainSemaphoreShared(), except that it will not block if the semaphore could not be locked.


AvailMem

Check memory available given certain requirements

Declaration

Source position: exec.pas line 1757

function AvailMem(

  Requirements: LongWord

):LongWord;

Arguments

Requirements

A requirements mask for the memory properties (MEMF_*)

Function result

Number of bytes free with the given properties (or biggest Memory Block)

Description

This function returns the amount of free memory given certain attributes.

To find out what the largest block of a particular type is, add MEMF_LARGEST into the requirements argument. Returning the largest block is a slow operation.

WARNING

Due to the effect of multitasking, the value returned may not actually be the amount of free memory available at that instant.

Snippet

AvailMem(MEMF_LARGEST);
  // return size of largest available memory chunk


AVL_AddNode

Declaration

Source position: exec.pas line 1879

function AVL_AddNode(

  Root: PPAVLNode;

  Node: PAVLNode;

  Func: Pointer

):PAVLNode;


AVL_FindFirstNode

Declaration

Source position: exec.pas line 1880

function AVL_FindFirstNode(

  const Root: PAVLNode

):PAVLNode;


AVL_FindLastNode

Declaration

Source position: exec.pas line 1881

function AVL_FindLastNode(

  const Root: PAVLNode

):PAVLNode;


AVL_FindNextNodeByAddress

Declaration

Source position: exec.pas line 1882

function AVL_FindNextNodeByAddress(

  const Node: PAVLNode

):PAVLNode;


AVL_FindNextNodeByKey

Declaration

Source position: exec.pas line 1883

function AVL_FindNextNodeByKey(

  const Root: PAVLNode;

  Key: Pointer;

  Func: Pointer

):PAVLNode;


AVL_FindNode

Declaration

Source position: exec.pas line 1884

function AVL_FindNode(

  const Root: PAVLNode;

  Key: Pointer;

  Func: Pointer

):PAVLNode;


AVL_FindPrevNodeByAddress

Declaration

Source position: exec.pas line 1885

function AVL_FindPrevNodeByAddress(

  const Root: PAVLNode

):PAVLNode;


AVL_FindPrevNodeByKey

Declaration

Source position: exec.pas line 1886

function AVL_FindPrevNodeByKey(

  const Root: PAVLNode;

  Key: Pointer;

  Func: Pointer

):PAVLNode;


AVL_RemNodeByAddress

Declaration

Source position: exec.pas line 1887

function AVL_RemNodeByAddress(

  Root: PPAVLNode;

  Node: PAVLNode

):PAVLNode;


AVL_RemNodeByKey

Declaration

Source position: exec.pas line 1888

function AVL_RemNodeByKey(

  Root: PPAVLNode;

  Key: Pointer;

  Func: Pointer

):PAVLNode;


BeginIO

Declaration

Source position: exec.pas line 1861

procedure BeginIO(

  IORequest: PIORequest

);


BitMask

Returns the Bit as Longint Value

Declaration

Source position: exec.pas line 1987

function BitMask(

  No: ShortInt

):LongInt;

Arguments

No

Number of bit to set

Function result

Longint Value where the bit number no is set.

Description

Sets the Bit defined by no and returns the value.


CacheClearE

Declaration

Source position: exec.pas line 1850

procedure CacheClearE(

  Address: Pointer;

  Length: LongWord;

  Caches: LongWord

);


CacheClearU

Declaration

Source position: exec.pas line 1851

procedure CacheClearU;


CacheControl

Declaration

Source position: exec.pas line 1889

function CacheControl(

  CacheBits: LongWord;

  CacheMask: LongWord

):LongWord;


CachePostDMA

Declaration

Source position: exec.pas line 1894

procedure CachePostDMA(

  const VAddr: Pointer;

  var Length: LongWord;

  Flags: LongWord

);


CachePreDMA

Declaration

Source position: exec.pas line 1893

function CachePreDMA(

  const VAddr: Pointer;

  var Length: LongWord;

  Flags: LongWord

):Pointer;


Cause

Fire and software interrupt

Declaration

Source position: exec.pas line 1813

procedure Cause(

  Interrupt_: PInterrupt

);

Arguments

Interrupt_

Pointer to a initialized interrupt node

Description

This function causes a software interrupt to occur. If it is called from user mode (and processor level 0), the software interrupt will preempt the current task. This call is often used by high-level hardware interrupts to defer medium-length processing down to a lower interrupt level. Note that a software interrupt is still a real interrupt, and must obey the same restrictions on what system function it may call.

NOTE

When setting up the PInterrupt structure, set the node type to NT_INTERRUPT, or NT_UNKOWN.


CheckIO

Check status on an I/O request

Declaration

Source position: exec.pas line 1858

function CheckIO(

  IORequest: PIORequest

):PIORequest;

Arguments

IORequest

Pointer to an I/O request block

Function result

Nil if I/O is still in progress otherwise a pointer to the I/O Request.

Description

This function determines the current state of an I/O request and returns False if the I/O has not yet completed. This function effectively hides the internals of the I/O completion mechanism.

CheckIO() will NOT remove the returned IORequest from the reply port. This is best performed with WaitIO(). If the request has already completed, WaitIO() will return quickly. Use of the Remove() function is dangerous, since other tasks may still be adding things to your message port; a Disable() would be required.

This function should NOT be used to busy loop (looping until IO is complete). WaitIO() is provided for that purpose.

See also

DoIO | Perform an I/O request and wait for its finish
SendIO | Initiate an I/O command
WaitIO | Wait for completion of an I/O request
AbortIO | Attempt to abort an in-progress I/O request


CloseDevice

Close access to a device.

Declaration

Source position: exec.pas line 1854

procedure CloseDevice(

  IORequest: PIORequest

);

Arguments

IORequest

A pointer to an I/O request structure

Description

This function informs the device that access to a device/unit previously opened has been concluded. The device may perform certain house-cleaning operations.

The user must ensure that all outstanding IORequests have been returned before closing the device. The AbortIO function can kill any stragglers.

After a close, the I/O request structure is free to be reused.

See also

OpenDevice

Open a device for use


CloseLibrary

Close access to library

Declaration

Source position: exec.pas line 1834

function CloseLibrary(

  Lib: PLibrary

):Pointer;

Arguments

Lib

A Pointer to a library structure used to open the library

Description

This function informs the system that access to the given library has been concluded. The user must not reference the library or any function in the library after this close.

See also

OpenLibrary

Open a library to use


ColdReboot

Reboot the Computer

Declaration

Source position: exec.pas line 1910

procedure ColdReboot;

Description

Reboot the machine. All external memory and periperals will be reseted, and the machine will start its power up diagnostics.

This function never returns.


CopyMem

Copy a given numbers ob bytes in memory

Declaration

Source position: exec.pas line 1758

procedure CopyMem(

  const Source: Pointer;

  Dest: Pointer;

  Size: LongWord

);

Arguments

Source | A pointer to the begin of source data
Dest | A pointer to the begin of destination memory block
Size | Number of bytes to be copied from source to destination, 0 is allowed and do nothing

Description

This function implements a fast memory copy function. It can deal with arbitrary lengths, with its pointers on arbitrary alignments. It attempts to optimize larger copies with more efficient copies, it uses byte copies for small moves, parts of larger copies, or the entire copy if the source and destination are misaligned with respect to each other.

Arbitrary overlapping copies are not supported.

See also

CopyMemQuick

Fast memory copy function


CopyMemQuick

Fast memory copy function

Declaration

Source position: exec.pas line 1759

procedure CopyMemQuick(

  const Source: Pointer;

  Dest: Pointer;

  Size: LongWord

);

Arguments

Source | A long aligned pointer to the begin of source data
Dest | A long aligned pointer to begin of destination memory block
Size | Number of bytes to be copied from source to destination, 0 is allowed and do nothing

Description

CopyMemQuick is a highly optimized memory copy function, with restrictions on the size and alignment of its arguments. Both the source and destination pointers must be longword aligned. In addition, the size must be an integral number of longwords (e.g. the size must be evenly divisible by four).

Arbitrary overlapping copies are not supported.

See also

CopyMem

Copy a given numbers ob bytes in memory


CreateExtIO

Declaration

Source position: exec.pas line 1993

function CreateExtIO(

  const Mp: PMsgPort;

  Size: Integer

):PIORequest;


CreateIORequest

Create a structure usable for an I/O request

Declaration

Source position: exec.pas line 1855

function CreateIORequest(

  const IOReplyPort: PMsgPort;

  Size: LongWord

):PIORequest;

Arguments

Size

The size of the IO request to be created.

Function result

A pointer to the I/O request structure created or nil

Description

Allocates memory for and initializes a new IO request block of a user-specified number of bytes. The number of bytes must be at least as large as a TMessage.

See also

DeleteIORequest | Free an i/O request
CreateMsgPort | Create a new message port


CreateLibrary

Declaration

Source position: exec.pas line 1831

function CreateLibrary(

  const TagList: PTagItem

):PLibrary;


CreateMsgPort

Create a new message port

Declaration

Source position: exec.pas line 1804

function CreateMsgPort: PMsgPort;

Function result

A pointer to the fresh allocted and initialized MsgPort or nil if failed.

Description

Allocates and initializes a new message port. The message list of the new port will be prepared for use (via NewList). A signal bit will be allocated, and the port will be set to signal your task when a message arrives (PA_SIGNAL).

You must use DeleteMsgPort() to delete ports created with this function!

See also

DeleteMsgPort

Free a message port


CreatePool

Create a new pool for memory allocations

Declaration

Source position: exec.pas line 1760

function CreatePool(

  MemFlags: LongWord;

  PuddleSize: LongWord;

  ThreshSize: LongWord

):Pointer;

Arguments

PuddleSize | Size of puddles
ThreshSize | The largest allocation that goes into normal puddles This MUST be less than or equal to puddleSize (CreatePool() will fail if it is not)

Function result

A pointer to the new pool, or nil for error.

Description

Each pool is a separate tracking system for memory of a specific type. Any number of pools may exist in the system.

Pools automatically expand and shrink based on demand. Fixed sized "puddles" are allocated by the pool manager when more total memory is needed. Many small allocations can fit in a single puddle. Allocations larger than the threshSize are allocation in their own puddles.

At any time individual allocations may be freed. Or, the entire pool may be removed in a single step.

See also

DeletePool | Free a memory pool
AllocPooled | Allocate memory in a memory pool
FreePooled | Free pooled memory block


CreatePort

Declaration

Source position: exec.pas line 1803

function CreatePort(

  const Name: PChar;

  Pri: LongInt

):PMsgPort;


CreateTask

Declaration

Source position: exec.pas line 1827

function CreateTask(

  const Name: PChar;

  Pri: LongInt;

  const InitPC: Pointer;

  StackSize: LongWord;

  const TagList: PTagItem

):PTask;


Deallocate

Free a block of memory

Declaration

Source position: exec.pas line 1761

procedure Deallocate(

  MemHeader: PMemHeader;

  MemoryBlock: Pointer;

  ByteSize: LongWord

);

Arguments

MemoryBlock | Address of memory block to free
ByteSize | Number of bytes to free. nil is allowed and does nothing

Description

This function deallocates memory by returning it to the appropriate private free memory pool. This function can be used to free an entire block allocated with the above function, or it can be used to free a sub-block of a previously allocated block. Sub-blocks must be an even multiple of the memory chunk size (currently 8 bytes).

This function can even be used to add a new free region to an existing MemHeader, however the extent pointers in the MemHeader will no longer be valid.

If memoryBlock is not on a block boundary then it will be rounded down in a manner compatible with Allocate(). Note that this will work correctly with all the memory allocation functions, but may cause surprises if one is freeing only part of a region. The size of the block will be rounded up, so the freed block will fill to an even memory block boundary.

See also

Allocate

Allocate a block of memory


DeleteExtIO

Declaration

Source position: exec.pas line 1994

procedure DeleteExtIO(

  ioReq: PIORequest

);


DeleteInterface

Declaration

Source position: exec.pas line 1847

procedure DeleteInterface(

  Interface_: PInterface

);


DeleteIORequest

Free an i/O request

Declaration

Source position: exec.pas line 1856

procedure DeleteIORequest(

  IORequest: PIORequest

);

Arguments

IORequest

A pointer to the I/O request block to be freed. This function uses the mn_Length field to determine how much memory to free. nil is allowed and does nothing.

Description

Frees up an I/O request created by CreateIORequest().

See also

CreateIORequest

Create a structure usable for an I/O request


DeleteLibrary

Declaration

Source position: exec.pas line 1848

procedure DeleteLibrary(

  Lib: PLibrary

);


DeleteMsgPort

Free a message port

Declaration

Source position: exec.pas line 1806

procedure DeleteMsgPort(

  Port: PMsgPort

);

Arguments

Port

A pointer to a message port to free. nil is allowed and does nothing

Description

Frees a message port create by CreateMsgPort(). All messages that may have been attached to this port must have already been replied to.

See also

CreateMsgPort

Create a new message port


DeletePool

Free a memory pool

Declaration

Source position: exec.pas line 1762

procedure DeletePool(

  PoolHeader: Pointer

);

Description

Frees all memory in all pudles of the specified pool header, then deletes the pool header. Individual free calls are not needed.

See also

CreatePool | Create a new pool for memory allocations
AllocPooled | Allocate memory in a memory pool
FreePooled | Free pooled memory block


DeletePort

Declaration

Source position: exec.pas line 1805

procedure DeletePort(

  Port: PMsgPort

);


DeleteTask

Declaration

Source position: exec.pas line 1829

procedure DeleteTask(

  Task: PTask

);


DeleteTrackable

Declaration

Source position: exec.pas line 1901

procedure DeleteTrackable(

  Trackable: PTrackable

);


Disable

Disable interrupt processing

Declaration

Source position: exec.pas line 1789

procedure Disable;

Description

Prevents interrupts from being handled by the system, until a matching Enable() is executed. Disable() implies Forbid(). Normal task rescheduling does not occur while interrupts are disabled.

Do not use this call without a special reason, its very dangerous and hinder the basic function of the operating system and computer. It is important to remember that there is a danger in using disabled sections. Disabling interrupts for more than ~250 microseconds will prevent vital system functions (especially serial I/0) from operating in a normal fashion.

Think twice before using Disable(), then think once more. After all that, think again. With enough thought, the need for a Disable() can often be eliminated.

See also

Forbid | Forbid task scheduling.
Permit | Permit task rescheduling.
Enable | Enable interrupt processing


DoIO

Perform an I/O request and wait for its finish

Declaration

Source position: exec.pas line 1859

function DoIO(

  IORequest: PIORequest

):LongInt;

Arguments

IORequest

A sign-extended copy of the io_Error field of the I/O request. Most device commands require that the error return be checked.

Function result

A pointer to an I/O Request initialized by OpenDevice()

Description

This function requests a device driver to perform the I/O command specified in the I/O request. This function will always wait until the I/O request is fully complete.

DoIO() handles all the details, including Quick I/O, waiting for the request, and removing the reply message, etc..

This function first tries to complete the IO via the "Quick I/O" mechanism. The io_Flags field is always set to IOF_QUICK (0x01) before the internal device call.

The LN_TYPE field is used internally to flag completion. Active requests have type NT_MESSAGE. Requests that have been replied have type NT_REPLYMSG. It is illegal to start IO using a still active IORequest, or a request with type NT_REPLYMSG.

See also

SendIO | Initiate an I/O command
CheckIO | Check status on an I/O request
WaitIO | Wait for completion of an I/O request
AbortIO | Attempt to abort an in-progress I/O request


DropInterface

Declaration

Source position: exec.pas line 1841

procedure DropInterface(

  Interface_: PInterface

);


Emulate

Declaration

Source position: exec.pas line 1912

function Emulate(

  const InitPC: Pointer;

  const TagList: PTagItem

):LongWord;


Enable

Enable interrupt processing

Declaration

Source position: exec.pas line 1790

procedure Enable;

Description

Allow system interrupts again occur after a Disable() was called.

Errors

The programmer must execute exactly one call to Enable() for every call to Disable().

See also

Disable | Disable interrupt processing
Permit | Permit task rescheduling.
Forbid | Forbid task scheduling.


EndDMA

Declaration

Source position: exec.pas line 1896

function EndDMA(

  const StartAddr: Pointer;

  BlockSize: LongWord;

  Flags: LongWord

):LongWord;


Enqueue

Insert or append node to a system list

Declaration

Source position: exec.pas line 1763

procedure Enqueue(

  List: PList;

  Node: PNode

);

Arguments

List | A pointer to the system list header
Node | The node to enqueue. This must be a full featured node with type, priority and name fields.

Description

Insert or append a node into a system list. The insert is performed based on the node priority. It will keep the list properly sorted. New nodes will be inserted in front of the first node with a lower priority. Hence a FIFO queue for nodes of equal priority

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
Exec.ExecInsert | Insert a node into a list
Remove | Remove a node from a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list


ExecAllocMem

Allocate memory given certain requirements

Declaration

Source position: exec.pas line 1753

function ExecAllocMem(

  ByteSize: LongWord;

  Requirements: LongWord

):Pointer;

Arguments

ByteSize | The size of the desired block in bytes. (The operating system will automatically round this number to a multiple of the system memory chunk size)
Requirements | If no flags are set, the system will return the best available memory block. (MEMF_*)

Function result

A pointer to the newly allocated memory block. If there are no free memory regions large enough to satisfy the request, nil will be returned. The pointer must be checked for nil before the memory block may be used!

Description

This is the memory allocator to be used by system code and applications. It provides a means of specifying that the allocation should be made in a memory area accessible to the chips, or accessible to shared system code.

Memory is allocated based on requirements and options. Any "requirement" must be met by a memory allocation, any "option" will be applied to the block regardless. AllocMem will try all memory spaces until one is found with the proper requirements and room for the memory request.

Errors

>If the free list is corrupt, the system will panic with alert AN_MemCorrupt, $01000005.

This function may not be called from interrupts.

A DOS process will have its pr_Result2 field set to ERROR_NO_FREE_STORE if the memory allocation fails.

See also

Exec.ExecFreeMem | Free a memory block with given size
AllocVec | Allocate memory and keep track of the size


ExecClone

Declaration

Source position: exec.pas line 1745

function ExecClone: PInterface;


ExecExpunge

Declaration

Source position: exec.pas line 1744

procedure ExecExpunge;


ExecFreeMem

Free a memory block with given size

Declaration

Source position: exec.pas line 1768

procedure ExecFreeMem(

  MemoryBlock: Pointer;

  ByteSize: LongWord

);

Arguments

MemoryBlock | A pointer to the memory block to free
ByteSize | The size of the desired block in bytes. (The operating system will automatically round this number to a multiple of the system memory chunk size)

Description

Free a memory block allocated using ExecAllocMem(), program should not access this memory area anymore. If a memory block is freed twice an Guru will appear AN_FreeTwice. if a wrong pointer is passed a AN_MemCorrupt is fired. The original name FreeMem is colliding with the RTL Freemem.

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


ExecInsert

Insert a node into a list

Declaration

Source position: exec.pas line 1774

procedure ExecInsert(

  List: PList;

  Node: PNode;

  ListNode: PNode

);

Arguments

List | A pointer to the target list
Node | Node to insert

Description

Insert a node into a system list after a given node. Insertion at the head of a list is possible by passing a nil value for listNode, though the AddHead() function is slightly faster for that special case. The original name Insert is colliding with the RTL Insert.

WARNING

This function does not arbitrate for access to the list. The calling task must be the owner of the involved list.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
Enqueue | Insert or append node to a system list
Remove | Remove a node from a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list


ExecObtain

Declaration

Source position: exec.pas line 1742

function ExecObtain: LongWord;


ExecRelease

Declaration

Source position: exec.pas line 1743

function ExecRelease: LongWord;


FindIName

Declaration

Source position: exec.pas line 1765

function FindIName(

  Start: PList;

  const Name: PChar

):PNode;


FindName

Find a node in a system list by name

Declaration

Source position: exec.pas line 1764

function FindName(

  Start: PList;

  const Name: PChar

):PNode;

Arguments

Name

Node name to find in the list

Function result

A pointer to the node with the same name else nil to indicate that the string was not found.

Description

Search a system list for a node with the given name. To find multiple occurrences of a string, this function may be called with a different node starting point.

No arbitration is done for access to the list! If multiple tasks access the same list, an arbitration mechanism such as SignalSemaphores must be used.


FindNamedMemory

Declaration

Source position: exec.pas line 1969

function FindNamedMemory(

  const Space: PChar;

  const Name: PChar

):Pointer;


FindPort

Find a system message port by name

Declaration

Source position: exec.pas line 1807

function FindPort(

  const Name: PChar

):PMsgPort;

Arguments

Name

Name of the message port to find.

Function result

A pointer to the message port, or nil if not found.

Description

This function will search the system message port list for a port with the given name. The first port matching this name will be returned. No arbitration of the port list is done. This function must be protected with A Forbid()/Permit() pair!

Example

function SafePutToPort(Msg: PMessage; Portname: string): Integer;
var
  Port: PMsgPort;
  PName: PChar;
begin
  Result := -1;
  PName := PChar(Portname + #0);
  Forbid();
  Port := FindPort(PName);
  if Assigned(Port) then
  begin
    PutMsg(Port, Msg);
    Result := 0;
  end;
  Permit();
end;


FindResident

Find a resident module by name

Declaration

Source position: exec.pas line 1845

function FindResident(

  const Name: PChar

):PResident;

Arguments

Name

Name of the resident to find

Function result

A pointer to the resident tag structure or nil if none found.

Description

Search the system resident tag list for a resident tag ("ROMTag") with the given name. If found return a pointer to the resident tag structure, else return nil.

Resident modules are used by the system to pull all its parts together at startup. Resident tags are also found in disk based devices and libraries.

See also

InitResident

Initialize resident module


FindSemaphore

Find Semaphore by name

Declaration

Source position: exec.pas line 1817

function FindSemaphore(

  const Name: PChar

):PSignalSemaphore;

Function result

A pointer to the signal semaphore, or nil if none found.

Description

This function will search the system signal semaphore list for a semaphore with the given name. The first semaphore matching this name will be returned. This function must be protected with A Forbid()/Permit() pair!


FindTask

Find task by name get own task

Declaration

Source position: exec.pas line 1792

function FindTask(

  const Name: PChar

):PTask;

Arguments

Name

Name of task to found.

Function result

A pointer to the task or process, or nil if none found.

Description

This function will check all task queues for a task with the given name, and return a pointer to its task control block. If a nil name pointer is given a pointer to the current task will be returned.

Finding oneself with a nil for the name is very quick. Finding a task by name is very system expensive, and will disable interrupts for a long time. Since a task may remove itself at any time, a Forbid()/Permit() pair may be needed to ensure the pointer returned by FindTask() is still valid when used.


FindTrackable

Declaration

Source position: exec.pas line 1899

function FindTrackable(

  UsingTask: PTask;

  Obj: Pointer

):PTrackable;


Forbid

Forbid task scheduling.

Declaration

Source position: exec.pas line 1766

procedure Forbid;

Description

Prevents other tasks from being scheduled to run by the dispatcher, until a matching Permit() is executed, or this task is scheduled to Wait(). Interrupts are not disabled.

The current task will not be rescheduled as long as it is ready to run. In the event that the current task enters a wait state, other tasks may be scheduled. Upon return from the wait state, the original task will continue to run without disturbing the Forbid().

Calls to Forbid() nest. In order to restore normal task rescheduling, the programmer must execute exactly one call to Permit() for every call to Forbid().

Warning:

In the event of a task entering a Wait() after a Forbid(), the system "breaks" the forbidden state and runs normally until the task which called Forbid() is rescheduled. If caution is not taken, this can cause subtile bugs, since any device or DOS call will (in effect) cause your task to wait.

See also

Permit | Permit task rescheduling.
Disable | Disable interrupt processing
Enable | Enable interrupt processing


FreeEntry

Free many blocks of memory at once

Declaration

Source position: exec.pas line 1767

procedure FreeEntry(

  MemList: PMemList

);

Description

This function frees a list of memory blocks and frees all entries at once.

See also

AllocEntry

Allocate many regions of memory


FreeNamedMemory

Declaration

Source position: exec.pas line 1968

function FreeNamedMemory(

  const Space: PChar;

  const Name: PChar

):LongBool;


FreePooled

Free pooled memory block

Declaration

Source position: exec.pas line 1769

procedure FreePooled(

  PoolHeader: Pointer;

  Memory: Pointer;

  MemSize: LongWord

);

Arguments

PoolHeader | A pointer to the pool this memory block belongs to.
Memory | Pointer to the memory to free.
MemSize | Number of bytes to free. Must match the size used when AllocPooled was done.

Description

Free a memory block which belongs to a memory pool. The block is removed from the pool. Only Memory allocated with AllocPooled() are freed with this function.

See also

AllocPooled | Allocate memory in a memory pool
CreatePool | Create a new pool for memory allocations
DeletePool | Free a memory pool


FreeSignal

Free a signal bit

Declaration

Source position: exec.pas line 1797

procedure FreeSignal(

  SignalNum: LongInt

);

Arguments

SignalNum

The signal number to free [0..31].

Description

This function frees a previously allocated signal bit for reuse. This call must be performed while running in the same task in which the signal was allocated.

See also

AllocSignal

Allocate a signal bit


FreeSysObject

Declaration

Source position: exec.pas line 1904

procedure FreeSysObject(

  Type_: LongWord;

  Obj: Pointer

);


FreeTrap

Free a processor trap

Declaration

Source position: exec.pas line 1876

procedure FreeTrap(

  TrapNum: LongWord

);

Arguments

TrapNum

The trap number to free [of 0..15]

Description

This function frees a previously allocated trap number for reuse. This call must be performed while running in the same task in which the trap was allocated.

See also

AllocTrap

Allocate a processor trap vector


FreeVec

Free memory with tracked size made using AllocVec()

Declaration

Source position: exec.pas line 1770

procedure FreeVec(

  MemoryBlock: Pointer

);

Arguments

MemoryBlock

A Pointer to the memory block to free. nil is allowed and does nothing.

See also

AllocVec

Allocate memory and keep track of the size


FreeVecPooled

Declaration

Source position: exec.pas line 1771

procedure FreeVecPooled(

  PoolHeader: Pointer;

  MemoryBlock: Pointer

);


GetCC

Declaration

Source position: exec.pas line 1877

function GetCC: LongWord;


GetCPUInfo

Declaration

Source position: exec.pas line 1918

procedure GetCPUInfo(

  const TagList: PTagItem

);


GetDMAList

Declaration

Source position: exec.pas line 1897

procedure GetDMAList(

  const StartAddr: Pointer;

  BlockSize: LongWord;

  Flags: LongWord;

  DMAList: Pointer

);


GetHead

Declaration

Source position: exec.pas line 1929

function GetHead(

  List: PList

):PNode;


GetInterface

Declaration

Source position: exec.pas line 1839

function GetInterface(

  Lib: PLibrary;

  const Name: PChar;

  Version: LongWord;

  const TagList: PTagItem

):PInterface;


GetMsg

Get next message from message port

Declaration

Source position: exec.pas line 1808

function GetMsg(

  Port: PMsgPort

):PMessage;

Arguments

Port

Message port to check for new message

Function result

A pointer to the first message available. If there are no messages, nil is returned.

Description

This function receives a message from a given message port. It provides a fast, non-copying message receiving mechanism. The received message is removed from the message port.

This function will not wait. If a message is not present this function will return nil. If a program must wait for a message, it can Wait() on the signal specified for the port or use the WaitPort() function. There can only be one task waiting for any given port.

Getting a message does not imply to the sender that the message is free to be reused by the sender. When the receiver is finished with the message, it may ReplyMsg() it back to the sender.

Getting a signal does NOT always imply a message is ready. More than one message may arrive per signal, and signals may show up without messages. Typically you must loop to GetMsg() until it returns zero, then Wait() or WaitPort().

See also

PutMsg | Put a message to a message port
ReplyMsg | Put a message to its reply port
WaitPort | Wait for a given port to be non-empty
Wait | Wait for one or more signals


GetPred

Declaration

Source position: exec.pas line 1932

function GetPred(

  Node: PNode

):PNode;


GetSucc

Declaration

Source position: exec.pas line 1931

function GetSucc(

  Node: PNode

):PNode;


GetTail

Declaration

Source position: exec.pas line 1930

function GetTail(

  List: PList

):PNode;


IceColdReboot

Declaration

Source position: exec.pas line 1933

procedure IceColdReboot;


InitCode

Initialize resident code modules (internal function)

Declaration

Source position: exec.pas line 1785

procedure InitCode(

  StartClass: LongWord;

  Version: LongWord

);

Description

(This function may be ignored by application programmers)


InitData

Declaration

Source position: exec.pas line 1772

procedure InitData(

  const InitTab: Pointer;

  Memory: Pointer;

  Size: LongWord

);


InitResident

Initialize resident module

Declaration

Source position: exec.pas line 1784

function InitResident(

  const Resident_: PResident;

  SegList: LongWord

):Pointer;

Arguments

Resident_ | Pointer to a ROMTag
SegList | SegList of the loaded object, if loaded from disk. Libraries and Devices will cache this value for later return at close or expunge time. Pass nil for ROM modules.

Function result

Return value from the init code, usually the library or device base. Nil for failure.

Description

Initialize a ROMTag. ROMTags are used to link system modules together. Each disk based device or library must contain a ROMTag structure in the first code hunk.

Errors

FindResident


InitSemaphore

Initialize a signal semaphore

Declaration

Source position: exec.pas line 1818

procedure InitSemaphore(

  SigSem: PSignalSemaphore

);

Arguments

SigSem

A pointer to a signal semaphore structure (with all fields set to 0 before the call)

Description

This function initializes a signal semaphore and prepares it for use. It does not allocate anything, but does initialize list pointers and the semaphore counters.

Semaphores are often used to protect critical data structures or hardware that can only be accessed by one task at a time. After initialization, the address of the SignalSemaphore may be made available to any number of tasks. Typically a task will try to ObtainSemaphore(), passing this address in. If no other task owns the semaphore, then the call will lock and return quickly. If more tasks try to ObtainSemaphore(), they will be put to sleep. When the owner of the semaphore releases it, the next waiter in turn will be woken up.

Semaphores are often preferable to the old-style Forbid()/Permit() type arbitration. With Forbid()/Permit() >all other tasks are prevented from running. With semaphores, only those tasks that need access to whatever the semaphore protects are subject to waiting.

See also

ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
AttemptSemaphore | Try to obtain a Semaphore without blocking
ReleaseSemaphore | Make signal semaphore available to others
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


InitStruct

Initialize memory from a table

Declaration

Source position: exec.pas line 1773

procedure InitStruct(

  const InitTab: Pointer;

  Memory: Pointer;

  Size: LongWord

);

Arguments

Memory | The beginning of the memory to initialize. Must be on an even boundary if size is specified.
Size | The size of memory, which is used to clear it before initializing it via the initTable. If Size is zero, memory is not cleared before initializing. Must be an even number.

Description

Clear a memory area, then set up default values according to the data and offset values in the initTable.


IsListEmpty

Check if a list is empty

Declaration

Source position: exec.pas line 1988

function IsListEmpty(

  List: PList

):Boolean;

Arguments

List

A pointer to a list

Function result

True is list is empty, false if it contains nodes.


IsMinListEmpty

Declaration

Source position: exec.pas line 1989

function IsMinListEmpty(

  List: PMinList

):Boolean;


IsMsgPortEmpty

Check if a messageport is empty

Declaration

Source position: exec.pas line 1990

function IsMsgPortEmpty(

  mp: PMsgPort

):Boolean;

Arguments

mp

A pointer to the messageport

Function result

True if no messages are there, False if there are at least one message in the messageport

Description

Easy way to check if a messageport has messages or not without removing the message from the messageport.


IsNative

Declaration

Source position: exec.pas line 1915

function IsNative(

  const Code: Pointer

):LongBool;


ItemPoolAlloc

Declaration

Source position: exec.pas line 1923

function ItemPoolAlloc(

  ItemPool: Pointer

):Pointer;


ItemPoolControl

Declaration

Source position: exec.pas line 1926

function ItemPoolControl(

  ItemPool: Pointer;

  const TagList: PTagItem

):LongWord;


ItemPoolFlush

Declaration

Source position: exec.pas line 1928

procedure ItemPoolFlush(

  ItemPool: Pointer

);


ItemPoolFree

Declaration

Source position: exec.pas line 1924

procedure ItemPoolFree(

  ItemPool: Pointer

);


ItemPoolGC

Declaration

Source position: exec.pas line 1925

procedure ItemPoolGC(

  ItemPool: Pointer

);


KMemCacheAlloc

Declaration

Source position: exec.pas line 1936

function KMemCacheAlloc(

  Cache: Pointer;

  Flags: LongWord

):Pointer;


KMemCacheCreate

Declaration

Source position: exec.pas line 1934

function KMemCacheCreate(

  VMA: Pointer;

  const Name: PChar;

  Size: LongWord;

  Align: LongWord;

  const Constructor_: Pointer;

  const Destructor_: Pointer;

  Flag: LongWord;

  UserData: Pointer

):Pointer;


KMemCacheDestroy

Declaration

Source position: exec.pas line 1935

procedure KMemCacheDestroy(

  Cache: Pointer

);


KMemCacheFind

Declaration

Source position: exec.pas line 1940

function KMemCacheFind(

  const Name: PChar

):Pointer;


KMemCacheFree

Declaration

Source position: exec.pas line 1937

procedure KMemCacheFree(

  Cache: Pointer;

  Obj: Pointer

);


KMemCacheGrow

Declaration

Source position: exec.pas line 1938

procedure KMemCacheGrow(

  Cache: Pointer;

  Flags: LongWord

);


KMemCacheReap

Declaration

Source position: exec.pas line 1939

function KMemCacheReap(

  Cache: Pointer;

  NumPages: LongWord;

  Flags: LongWord

):LongWord;


LockMem

Declaration

Source position: exec.pas line 1890

function LockMem(

  BaseAddress: Pointer;

  Size: LongWord

):LongBool;


LockNamedMemory

Declaration

Source position: exec.pas line 1971

function LockNamedMemory(

  const Space: PChar;

  const Name: PChar

):Pointer;


Makefunctions

Construct a function jump table

Declaration

Source position: exec.pas line 1852

function Makefunctions(

  Target: Pointer;

  const FunctionArray: Pointer;

  const FuncDispBase: Pointer

):LongWord;

Arguments

Target | The target address for the high memory end of the function jump table. Typically this will be the library base pointer.
FunctionArray | A Pointer to an array of function pointers or function displacements. If nil, the array is assumed to contain absolute pointers to functions. If not nil, then the array is assumed to contain word displacements to functions. In both cases, the array is terminated by a -1 (of the same size as the actual entry.
FuncDispBase | A Pointer to the base about which all function displacements are relative. If nil, then the function array contains absolute pointers.

Description

A low level function used by MakeLibrary() to build jump tables of the type used by libraries, devices and resources. It allows the table to be built anywhere in memory, and can be used both for initialization and replacement. This function also supports function pointer compression by expanding relative displacements into absolute pointers.

See also

MakeLibrary

Construct a library


MakeInterface

Declaration

Source position: exec.pas line 1775

function MakeInterface(

  Lib: PLibrary;

  const TagList: PTagItem

):PInterface;


MakeLibrary

Construct a library

Declaration

Source position: exec.pas line 1911

function MakeLibrary(

  const Vectors: Pointer;

  const Structure: Pointer;

  const Init: Pointer;

  DataSize: LongWord;

  SegList: Pointer

):PLibrary;

Arguments

DataSize | the size of the library data area, including the standard library node data. This must be at leas SizeOf(TLibrary).
SegList | A pointer to an Amiga SegList (segment list). This is passed to a library's init code, and is used later for removing the library from memory.

Function result

The reference address of the library. This is the address used in references to the library, not the beginning of the memory area allocated. If the library vector table require more system memory than is available, this function will return nil.

Description

This function is used for constructing a library vector and data area. The same call is used to make devices. Space for the library is allocated from the system's free memory pool. The data portion of the library is initialized. Init may point to a library specific entry point.

See also

InitStruct | Initialize memory from a table
InitResident | Initialize resident module


MoveList

Declaration

Source position: exec.pas line 1907

procedure MoveList(

  DestinationList: PList;

  SourceList: PList

);


MutexAttempt

Declaration

Source position: exec.pas line 1981

function MutexAttempt(

  Mutex: Pointer

):LongBool;


MutexAttemptWithSignal

Declaration

Source position: exec.pas line 1983

function MutexAttemptWithSignal(

  Mutex: Pointer;

  SigSet: LongWord

):LongWord;


MutexObtain

Declaration

Source position: exec.pas line 1980

procedure MutexObtain(

  Mutex: Pointer

);


MutexRelease

Declaration

Source position: exec.pas line 1982

procedure MutexRelease(

  Mutex: Pointer

);


NewList

Declaration

Source position: exec.pas line 1908

procedure NewList(

  List: PList

);


NewListType

Declaration

Source position: exec.pas line 1991

procedure NewListType(

  var List: PList;

  NType: Byte

);


NewMinList

Declaration

Source position: exec.pas line 1909

procedure NewMinList(

  List: PMinList

);


NewStackRun

Declaration

Source position: exec.pas line 1984

function NewStackRun(

  InitPC: Pointer;

  const TagList: PTagItem

):LongInt;


ObtainQuickVector

Obtain and install a Quick Interrupt vector

Declaration

Source position: exec.pas line 1869

function ObtainQuickVector(

  InterruptCode: Pointer

):LongWord;

Arguments

InterruptCode

A pointer to your interrupt code. This code is not an EXEC interrupt but is dirrectly connected to the hardware interrupt.

Function result

If it returns 0, no quick interrupt was allocatable. The device should at this point switch to using the shared interrupt server method.

Description

This function will install the code pointer into the quick interrupt vector it allocates and returns to you the interrupt vector that your Quick Interrupt system needs to use.

This function may also return 0 if no vectors are available. Your hardware should be able to then fall back to using the shared interrupt server chain should this happen.

The interrupt code is a direct connect to the physical interrupt. This means that it is the responsibility of your code to do all of the context saving/restoring required by interrupt code.

Also, due to the performance of the interrupt controller, you may need to also watch for "false" interrupts. These are interrupts that come in just after a DISABLE. The reason this happens is because the interrupt may have been posted before the DISABLE hardware access is completed.


ObtainSemaphore

Gain exclusive access to a semaphore

Declaration

Source position: exec.pas line 1819

procedure ObtainSemaphore(

  SigSem: PSignalSemaphore

);

Arguments

SigSem

An initialized signal semaphore structure

Description

Signal semaphores are used to gain exclusive access to an object. ObtainSemaphore is the call used to gain this access. If another user currently has the semaphore locked the call will block until the object is available.

If the current task already has locked the semaphore and attempts to lock it again the call will still succeed. A "nesting count" is incremented each time the current owning task of the semaphore calls ObtainSemaphore(). This counter is decremented each time ReleaseSemaphore() is called. When the counter returns to zero the semaphore is actually released, and the next waiting task is called.

A queue of waiting tasks is maintained on the stacks of the waiting tasks. Each will be called in turn as soon as the current task releases the semaphore.

Signal Semaphores are different than Procure()/Vacate() semaphores. The former requires less CPU time, especially if the semaphore is not currently locked. They require very little set up and user thought. The latter flavor of semaphore make no assumptions about how they are used -- they are completely general. Unfortunately they are not as efficient as signal semaphores, and require the locker to have done some setup before doing the call.

See also

ObtainSemaphoreShared | Gain access to a semaphore in shared mode
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphoreList | Get a List of semaphores
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


ObtainSemaphoreList

Get a List of semaphores

Declaration

Source position: exec.pas line 1820

procedure ObtainSemaphoreList(

  SigSem: PList

);

Arguments

SigSem

A list of signal semaphores

Description

Signal semaphores may be linked together into a list. This function takes a list of these semaphores and attempts to lock all of them at once. This call is preferable to applying ObtainSemaphore() to each element in the list because it attempts to lock all the elements simultaneously, and won't deadlock if someone is attempting to lock in some other order.

This function assumes that only one task at a time will attempt to lock the entire list of semaphores. In other words, there needs to be a higher level lock (perhaps another signal semaphore...) that is used before someone attempts to lock the semaphore list via ObtainSemaphoreList().

Note that deadlocks may result if this call is used AND someone attempts to use ObtainSemaphore() to lock more than one semaphore on the list. If you wish to lock more than one semaphore (but not all of them) then you should obtain the higher level lock

See also

ObtainSemaphoreShared | Gain access to a semaphore in shared mode
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


ObtainSemaphoreShared

Gain access to a semaphore in shared mode

Declaration

Source position: exec.pas line 1821

procedure ObtainSemaphoreShared(

  SigSem: PSignalSemaphore

);

Arguments

SigSem

An initialized signal semaphore structure

Description

A lock on a signal semaphore may either be exclusive, or shared. Exclusive locks are granted by the ObtainSemaphore() and AttemptSemaphore() functions. Shared locks are granted by ObtainSemaphoreShared(). Calls may be nested.

Any number of tasks may simultaneously hold a shared lock on a semaphore. Only one task may hold an exclusive lock. A typical application is a list that is often read, but only occasionally written to.

Any exlusive locker will be held off until all shared lockers release the semaphore. Likewise, if an exlusive lock is held, all potential shared lockers will block until the exclusive lock is released. All shared lockers are restarted at the same time.

A task owning a shared lock must not attempt to get an exclusive lock on the same semaphore.

See also

ObtainSemaphoreList | Get a List of semaphores
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
Procure | Asynchron locking of a semaphore
Vacate | Release a bidMessage from Procure()


OpenDevice

Open a device for use

Declaration

Source position: exec.pas line 1853

function OpenDevice(

  const DevName: PChar;

  UnitNumber: LongWord;

  IORequest: PIORequest;

  Flags: LongWord

):LongInt;

Arguments

DevName | Requested device name
IORequest | The I/O request block to be returned with appropriate fields initialized.
Flags | An additional driver specific information. This is sometimes used to request opening a device with exclusive access.

Function result

Returns a sign-extended copy of the io_Error field of the IORequest. Zero if successful, else an error code is returned.

Description

This function opens the named device/unit and initializes the given I/O request block. Specific documentation on opening procedures may come with certain devices.

The device may exist in memory, or on disk; this is transparent to the OpenDevice caller.

A full path name for the device name is legitimate. For example "test:devs/fred.device". This allows the use of custom devices without requiring the user to copy the device into the system's DEVS: directory.

See also

CloseDevice | Close access to a device.
DoIO | Perform an I/O request and wait for its finish
SendIO | Initiate an I/O command
CheckIO | Check status on an I/O request
AbortIO | Attempt to abort an in-progress I/O request
WaitIO | Wait for completion of an I/O request


OpenLibrary

Open a library to use

Declaration

Source position: exec.pas line 1833

function OpenLibrary(

  const Name: PChar;

  Version: LongWord

):PLibrary;

Arguments

Version

The version of the library required, 0 if no special version required.

Function result

A library pointer for a successful open, else nil

Description

This function returns a pointer to a library that was previously installed into the system. If the requested library is exists, and if the library version is greater than or equal to the requested version, then the open will succeed.

The library may exist in memory, or on disk; this is transparent to the OpenLibrary caller. Only Processes are allowed to call OpenLibrary (since OpenLibrary may in turn call dos.library).

A full path name for the library name is legitimate. For example "wp:libs/wp.library". This allows the use of custom libraries without requiring the user to copy the library into the system's LIBS: directory.

See also

CloseLibrary

Close access to library


OpenResource

Open an resource for use

Declaration

Source position: exec.pas line 1865

function OpenResource(

  const ResName: PChar

):Pointer;

Arguments

ResName

The name of the resource requested.

Function result

A resource pointer if successful, else nil

Description

This function returns a pointer to a resource that was previously installed into the system.

There is no CloseResource() function.


OwnerOfMem

Declaration

Source position: exec.pas line 1920

function OwnerOfMem(

  const Address: Pointer

):PTask;


PageBackendAlloc

Declaration

Source position: exec.pas line 1948

function PageBackendAlloc(

  Order: LongWord;

  Flags: LongWord

):Pointer;


PageBackendAllocAligned

Declaration

Source position: exec.pas line 1965

procedure PageBackendAllocAligned(

  Order: LongWord;

  Alignment: LongWord;

  Flags: LongWord

);


PageBackendFree

Declaration

Source position: exec.pas line 1949

procedure PageBackendFree(

  Addr: Pointer;

  Order: LongWord

);


PageBackendLock

Declaration

Source position: exec.pas line 1950

procedure PageBackendLock;


PageBackendUnlock

Declaration

Source position: exec.pas line 1951

procedure PageBackendUnlock;


PageDrop

Declaration

Source position: exec.pas line 1944

procedure PageDrop(

  PageList: Pointer;

  NumPages: LongWord

);


PageFindByVA

Declaration

Source position: exec.pas line 1945

function PageFindByVA(

  AddressSpace: Pointer;

  VirtualAddress: Pointer

):Pointer;


PageGet

Declaration

Source position: exec.pas line 1941

function PageGet(

  VMA: Pointer;

  NumPages: LongWord;

  Alignment: LongWord

):Pointer;


PageHash

Declaration

Source position: exec.pas line 1946

procedure PageHash(

  Page: Pointer

);


PageMap

Declaration

Source position: exec.pas line 1942

function PageMap(

  PageList: Pointer;

  NumPages: LongWord;

  Attrs: LongWord;

  Flags: LongWord

):LongBool;


PageMapAligned

Declaration

Source position: exec.pas line 1962

function PageMapAligned(

  PageList: Pointer;

  NumPages: LongWord;

  Alignment: LongWord;

  Attrs: LongWord;

  Flags: LongWord

):LongBool;


PagerAssignPager

Declaration

Source position: exec.pas line 1979

function PagerAssignPager(

  PPage: Pointer;

  NFlags: LongWord

):LongBool;


PagerFindPageOut

Declaration

Source position: exec.pas line 1976

function PagerFindPageOut(

  NFlags: LongWord

):Pointer;


PagerPageIn

Declaration

Source position: exec.pas line 1977

function PagerPageIn(

  PPage: Pointer;

  NFlags: LongWord

):LongBool;


PagerPageOut

Declaration

Source position: exec.pas line 1978

function PagerPageOut(

  PPage: Pointer;

  NFlags: LongWord;

  PReceiver: Pointer

):LongBool;


PageUnhash

Declaration

Source position: exec.pas line 1947

procedure PageUnhash(

  Page: Pointer

);


PageUnmap

Declaration

Source position: exec.pas line 1943

procedure PageUnmap(

  PageList: Pointer;

  NumPages: LongWord

);


Permit

Permit task rescheduling.

Declaration

Source position: exec.pas line 1777

procedure Permit;

Description

Allow other tasks to be scheduled to run by the dispatcher, after a matching Forbid() has been executed. Other tasks will be rescheduled as they are ready to run. In order to restore normal task rescheduling, the programmer must execute exactly one call to Permit() for every call to Forbid().


Procure

Asynchron locking of a semaphore

Declaration

Source position: exec.pas line 1822

function Procure(

  SigSem: PSignalSemaphore;

  BidMessage: PSemaphoreMessage

):LongBool;

Arguments

SigSem

The SignalSemaphore that you wish to lock

Description

This function is used to obtain a semaphore in an async manner. Like ObtainSemaphore(), it will obtain a SignalSemaphore for you but unlike ObtainSemaphore(), you will not block until you get the semaphore. Procure() will just post a request for the semaphore and will return. When the semaphore is available (which could be at any time) the bidMessage will ReplyMsg() and you will own the semaphore. This lets you wait on multiple semaphores at once and to continue processing while waiting for the semaphore.

See also

ObtainSemaphoreList | Get a List of semaphores
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
Vacate | Release a bidMessage from Procure()


PutMsg

Put a message to a message port

Declaration

Source position: exec.pas line 1809

procedure PutMsg(

  Port: PMsgPort;

  Message: PMessage

);

Arguments

Port | A pointer to a message port
Message | A pointer to a message

Description

This function attaches a message to the end of a given message port. It provides a fast, non-copying message sending mechanism.

Messages can be attached to only one port at a time. The message body can be of any size or form. Because messages are not copied, cooperating tasks share the same message memory. The sender task must not recycle the message until it has been replied by the receiver. Of course this depends on the message handling conventions setup by the involved tasks. If the ReplyPort field is non-zero, when the message is replied by the receiver, it will be sent back to that port.

See also

GetMsg | Get next message from message port
ReplyMsg | Put a message to its reply port


RawDoFmt

Format data into a character stream.

Declaration

Source position: exec.pas line 1778

function RawDoFmt(

  const FormatString: PChar;

  const DataStream: Pointer;

  putChProc: TProcedure;

  PutChData: Pointer

):Pointer;

Arguments

FormatString | %[flags][width.limit][length]type
DataStream | A pointer to a zone of memory containing the data. Data has to be WORD aligned.
putChProc | Callback function. Called for each character, including the NULL terminator. or one of the values RAWFMTFUNC_*
PutChData | Data propagated to each call of the callback hook.

Function result

A pointer to the rest of the DataStream.

Description

perform "C"-language-like formatting of a data stream, outputting the result a character at a time. Where % formatting commands are found in the FormatString, they will be replaced with the corresponding element in the DataStream. %% must be used in the string if a % is desired in the output.


RawMayGetChar

Declaration

Source position: exec.pas line 1916

function RawMayGetChar: LongInt;


RawPutChar

Declaration

Source position: exec.pas line 1917

procedure RawPutChar(

  c: Char

);


ReallocVec

Declaration

Source position: exec.pas line 1892

function ReallocVec(

  MemBlock: Pointer;

  NewSize: LongWord;

  Flags: LongWord

):LongWord;


ReleaseSemaphore

Make signal semaphore available to others

Declaration

Source position: exec.pas line 1823

procedure ReleaseSemaphore(

  SigSem: PSignalSemaphore

);

Arguments

SigSem

An initialized signal semaphore structure which was obtained before

Description

ReleaseSemaphore() is the inverse of ObtainSemaphore(). It makes the semaphore lockable to other users. If tasks are waiting for the semaphore and this this task is done with the semaphore then the next waiting task is signalled.

Each ObtainSemaphore() call must be balanced by exactly one ReleaseSemaphore() call. This is because there is a nesting count maintained in the semaphore of the number of times that the current task has locked the semaphore. The semaphore is not released to other tasks until the number of releases matches the number of obtains.

Signal semaphores locked via ObtainSemaphoreShared are also released with this function.

Semaphores must released the same amount as is obtained.

See also

InitSemaphore | Initialize a signal semaphore
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode


ReleaseSemaphoreList

Make a list of semaphores available

Declaration

Source position: exec.pas line 1824

procedure ReleaseSemaphoreList(

  SigSem: PList

);

Arguments

SigSem

A list of signal semaphores

Description

ReleaseSemaphoreList() is the inverse of ObtainSemaphoreList(). It releases each element in the semaphore list.

See also

ObtainSemaphoreList

Get a List of semaphores


RemDevice

Remove a device from the system

Declaration

Source position: exec.pas line 1838

function RemDevice(

  Device: PDevice

):LongWord;

Arguments

Device

A pointer to a device node

Description

This function calls the device's EXPUNGE vector, which requests that a device delete itself. The device may refuse to do this if it is busy or currently open. This is not typically called by user code.

There are certain, limited circumstances where it may be appropriate to attempt to specifically flush a certain device.

See also

AddDevice | Adds a device to the system
OpenDevice | Open a device for use
CloseDevice | Close access to a device.


RemHead

Remove the head node from a list

Declaration

Source position: exec.pas line 1779

function RemHead(

  List: PList

):PNode;

Arguments

List

A pointer to the list

Function result

The node removed or nil when empty list

Description

Get a pointer to the head node and remove it from the list.

See also

AddTail | Append node to tail of a list
AddHead | Insert a node at the head of a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
Remove | Remove a node from a list
RemTail | Remove the tail node from a list


RemInterface

Declaration

Source position: exec.pas line 1843

procedure RemInterface(

  Interface_: PInterface

);


RemIntServer

Remove an interrupt server from a server chain

Declaration

Source position: exec.pas line 1867

procedure RemIntServer(

  IntNumber: LongWord;

  Interrupt_: PInterrupt

);

Arguments

IntNumber | The interrupt bit [0..14]
Interrupt_ | A pointer to an interrupt server node

Description

>This function removes an interrupt server node from the given server chain.

If this server was the last one on this chain, interrupts for this chain are disabled.

See also

AddIntServer

Adds a interrupt server to the system


RemLibrary

Remove a library from the system

Declaration

Source position: exec.pas line 1836

function RemLibrary(

  Lib: PLibrary

):LongWord;

Arguments

Lib

A pointer to a library node structure

Description

This function calls the library's EXPUNGE vector, which requests that a library delete itself. The library may refuse to do this if it is busy or currently open. This is not typically called by user code.

There are certain, limited circumstances where it may be appropriate to attempt to specifically flush a certain Library.


RemMemHandler

Remove low memory handler from exec

Declaration

Source position: exec.pas line 1780

procedure RemMemHandler(

  MemHandler: PInterrupt

);

Description

This function removes the low memory handler from the system. This function can be called from within a handler. If removing oneself, it is important that the handler returns MEM_ALL_DONE.

See also

AddMemHandler


Remove

Remove a node from a list

Declaration

Source position: exec.pas line 1781

procedure Remove(

  Node: PNode

);

Arguments

Node

A node to remove

Description

Unlink a node from whatever list it is in. Nodes that are not part of a list must not be passed to this function!

See also

AddTail | Append node to tail of a list
AddHead | Insert a node at the head of a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list


RemPort

Remove a message port from the system

Declaration

Source position: exec.pas line 1810

procedure RemPort(

  Port: PMsgPort

);

Arguments

Port

A pointer to a message port

Description

This function removes a message port structure from the system's message port list. Subsequent attempts to rendezvous by name with this port will fail.

See also

AddPort | Add a public message port to the system
FindPort | Find a system message port by name


RemResetCallback

Declaration

Source position: exec.pas line 1922

function RemResetCallback(

  ResetCallBack: PInterrupt

):LongBool;


RemResource

Remove a resource from the system

Declaration

Source position: exec.pas line 1864

procedure RemResource(

  Resource: Pointer

);

Arguments

Resource

A pointer to a resource node

Description

This function removes an existing resource from the system resource list. There must be no outstanding users of the resource.

See also

AddResource

Add a resource to the system


RemSemaphore

Remove a signal semaphore from the system

Declaration

Source position: exec.pas line 1825

procedure RemSemaphore(

  SigSem: PSignalSemaphore

);

Arguments

SigSem

An initialized signal semaphore structure

Description

This function removes a signal semaphore structure from the system's signal semaphore list. Subsequent attempts to rendezvous by name with this semaphore will fail.

See also

AddSemaphore | Initialize then add a signal semaphore to the system
FindSemaphore | Find Semaphore by name


RemTail

Remove the tail node from a list

Declaration

Source position: exec.pas line 1782

function RemTail(

  List: PList

):PNode;

Arguments

List

A pointer to a list

Function result

The node removed or nil when empty list

Description

Remove the last node from a list, and return a pointer to it. If the list is empty, return nil.

See also

AddTail | Append node to tail of a list
AddHead | Insert a node at the head of a list
Enqueue | Insert or append node to a system list
ExecInsert | Insert a node into a list
RemHead | Remove the head node from a list
Remove | Remove a node from a list


RemTask

Remove a task from the system

Declaration

Source position: exec.pas line 1793

procedure RemTask(

  Task: PTask

);

Arguments

Task

A pointer to the task node representing the task to be removed. A zero value indicates self removal, and will cause the next ready task to begin execution.

See also

AddTask | Add a Task to the System
AllocEntry | Allocate many regions of memory


RemTrackable

Declaration

Source position: exec.pas line 1900

function RemTrackable(

  UsingTask: PTask;

  Obj: Pointer;

  Trackable: PTrackable

):PTrackable;


ReplyMsg

Put a message to its reply port

Declaration

Source position: exec.pas line 1811

procedure ReplyMsg(

  Message: PMessage

);

Arguments

Message

A pointer to the message

Description

This function sends a message to its reply port. This is usually done when the receiver of a message has finished and wants to return it to the sender (so that it can be re-used or deallocated, whatever). The contents of the message should be copied before if it is needed for further processing.

This call may be made from interrupts.

See also

GetMsg | Get next message from message port
PutMsg | Put a message to a message port


Reschedule

Declaration

Source position: exec.pas line 1791

procedure Reschedule;


RestartTask

Declaration

Source position: exec.pas line 1906

procedure RestartTask(

  WhichTask: PTask;

  Flags: LongWord

);


RMapAlloc

Declaration

Source position: exec.pas line 1955

function RMapAlloc(

  Map: Pointer;

  Size: LongWord;

  Flags: LongWord

):Pointer;


RMapExtAlloc

Declaration

Source position: exec.pas line 1963

function RMapExtAlloc(

  Map: Pointer;

  Size: LongWord;

  Alignment: LongWord;

  Flags: LongWord

):Pointer;


RMapExtFree

Declaration

Source position: exec.pas line 1964

procedure RMapExtFree(

  Map: Pointer;

  Addr: Pointer;

  Size: LongWord

);


RMapFree

Declaration

Source position: exec.pas line 1956

procedure RMapFree(

  Map: Pointer;

  Addr: Pointer;

  Size: LongWord

);


ScanNamedMemory

Declaration

Source position: exec.pas line 1974

function ScanNamedMemory(

  SCHook: PHook;

  Flags: LongWord;

  User: Pointer

):LongWord;


SendIO

Initiate an I/O command

Declaration

Source position: exec.pas line 1860

procedure SendIO(

  IORequest: PIORequest

);

Arguments

IORequest

A pointer to an I/O request, or a device specific extended IORequest.

Description

This function requests the device driver start processing the given I/O request. The device will return control without waiting for the I/O to complete.

The io_Flags field of the IORequest will be set to zero before the request is sent.

See also

DoIO | Perform an I/O request and wait for its finish
CheckIO | Check status on an I/O request
WaitIO | Wait for completion of an I/O request
AbortIO | Attempt to abort an in-progress I/O request


SetExcept

Define certain signals to cause exceptions

Declaration

Source position: exec.pas line 1798

function SetExcept(

  NewSignals: LongWord;

  SignalMask: LongWord

):LongWord;

Arguments

NewSignals

Set of signals causing the exception.

Function result

The prior exception signals

Description

This function defines which of the task's signals will cause a private task exception. When any of the signals occurs the task's exception handler will be dispatched. If the signal occurred prior to calling SetExcept, the exception will happen immediately.


Setfunction

Change a function vector in a library

Declaration

Source position: exec.pas line 1849

function Setfunction(

  Lib: PLibrary;

  FuncOffset: LongInt;

  const Newfunction: Pointer

):Pointer;

Arguments

Lib | A pointer to the library to be changed
FuncOffset | The offset of the function to be replaced
Newfunction | A Pointer to new function

Function result

Pointer to the old function that was just replaced

Description

SetFunction is a functional way of changing where vectors in a library point. They are changed in such a way that the checksumming process will never falsely declare a library to be invalid.

Warning

While it's more or less safe to patch a library vector with SetFunction() it's not possible to safely remove the patch later. So don't use this function if it can be avoided.


SetIntVector

Set a new handler for a system interrupt vector

Declaration

Source position: exec.pas line 1868

function SetIntVector(

  IntNumber: LongWord;

  const Interrupt_: PInterrupt

):PInterrupt;

Arguments

IntNumber | Interrupt bit number [0..14]. Only non-chained interrupts should be set. Use AddIntServer() for server chains.
Interrupt_ | A pointer to an Interrupt structure containing the handler's entry point and data segment pointer. A NULL interrupt pointer will remove the current interrupt and set illegal values for IS_CODE and IS_DATA. By convention, the LN_NAME of the interrupt structure must point a descriptive string so that other users may identify who currently has control of the interrupt.

Function result

A pointer to the prior interrupt structure which had control of this interrupt.

Description

This function provides a mechanism for setting the system interrupt vectors. These are non-sharable; setting a new interrupt handler disconnects the old one. Installed handlers are responsible for processing, enabling and clearing the interrupt. Note that interrupts may have been left in any state by the previous code.

The IS_CODE and IS_DATA pointers of the Interrupt structure will be copied into a private place by Exec. A pointer to the previously installed Interrupt structure is returned.

See also

AddIntServer

Adds a interrupt server to the system


SetMethod

Declaration

Source position: exec.pas line 1846

function SetMethod(

  Interface_: PInterface;

  FuncOffset: LongInt;

  const NewFunc: Pointer

):Pointer;


SetSignal

Define the state of this task's signals

Declaration

Source position: exec.pas line 1799

function SetSignal(

  NewSignals: LongWord;

  SignalMask: LongWord

):LongWord;

Arguments

NewSignals

The new values for the signals specified in signalSet.

Function result

The prior values for all signals

Description

This function can query or modify the state of the current task's received signal mask. Setting the state of signals is considered dangerous. Reading the state of signals is safe.

//Get the current state of all signals
Sig := SetSignal(0, 0);
//Clear the CTRL-C signal:
Sig := SetSignal(0, SIGBREAKF_CTRL_C);
// Check and Clear Ctrl C Signal
if (SetSignal(0, SIGBREAKF_CTRL_C) and SIGBREAKF_CTRL_C) <> 0 then
begin
  writeln('CTRL-C pressed!');
end;

See also

Signal

Signal a task


SetSR

Get and/or set processor status register

Declaration

Source position: exec.pas line 1878

function SetSR(

  NewSR: LongWord;

  Mask: LongWord

):LongWord;

Arguments

NewSR | The new contents of the status register.
Mask | Mask of bits to change.

Function result

The old contents of the status register or 0 if this function is not implemented.

Description

This function provides a means of modifying the CPU status register in a "safe" way (well, how safe can a function like this be anyway?). This function will only affect the status register bits specified in the mask parameter. The prior content of the entire status register is returned.

The bits in the register mapped to those of the Motorola MC680x0 family of microprocessors.


SetTaskPri

Get and set the priority of a task

Declaration

Source position: exec.pas line 1794

function SetTaskPri(

  Task: PTask;

  Priority: LongInt

):LongInt;

Arguments

Task | Task to be affected
Priority | The new priority for the task (-127 to 5).

Function result

The tasks previous priority

Description

This function changes the priority of a task regardless of its state. The old priority of the task is returned. A reschedule is performed, and a context switch may result.

To change the priority of the currently running task, pass the result of FindTask(nil); as the task pointer.


SetTaskTrap

Declaration

Source position: exec.pas line 1874

function SetTaskTrap(

  TrapNum: LongWord;

  const TrapCode: Pointer;

  const TrapData: Pointer

):LongBool;


Signal

Signal a task

Declaration

Source position: exec.pas line 1800

procedure Signal(

  Task: PTask;

  Signals: LongWord

);

Arguments

Task

The task to be signalled

Description

This function signals a task with the given signals. If the task is currently waiting for one or more of these signals, it will be made ready and a reschedule will occur. If the task is not waiting for any of these signals, the signals will be posted to the task for possible later use. A signal may be sent to a task regardless of whether it is running, ready, or waiting.

This function is considered "low level". Its main purpose is to support multiple higher level functions like PutMsg().

This function is safe to call from interrupts.

See also

Wait | Wait for one or more signals
SetSignal | Define the state of this task's signals


StackSwap

Declaration

Source position: exec.pas line 1795

procedure StackSwap(

  NewStack: PStackSwapStruct

);


StartDMA

Declaration

Source position: exec.pas line 1895

function StartDMA(

  const StartAddr: Pointer;

  BlockSize: LongWord;

  Flags: LongWord

):LongWord;


SumInterface

Declaration

Source position: exec.pas line 1844

procedure SumInterface(

  Interface_: PInterface

);


SumKickData

Declaration

Source position: exec.pas line 1786

function SumKickData: LongWord;


SumLibrary

Compute and check the checksum on a library

Declaration

Source position: exec.pas line 1830

procedure SumLibrary(

  Lib: PLibrary

);

Arguments

Lib

A pointer to the library to be changed

Description

SumLibrary computes a new checksum on a library. It can also be used to check an old checksum. If an old checksum does not match, and the library has not been marked as changed, then the system will call Alert.

This call could also be periodically made by some future system-checking task.

See also

SetFunction

Change a function vector in a library


SuperState

Enter supervisor state with user stack

Declaration

Source position: exec.pas line 1871

function SuperState: Pointer;

Description

Enter supervisor mode while running on the user's stack. The user still has access to user stack variables. Be careful though, the user stack must be large enough to accommodate space for all interrupt data -- this includes all possible nesting of interrupts. This function does nothing when called from supervisor state. This is not a good function to use, it has limited scope, and will probably be even less useful in the future.

Errors

You can easily cause your system to cease operating normally.

See also

Supervisor | Trap to a short supervisor mode function
UserState | Return to user state with user stack


Supervisor

Trap to a short supervisor mode function

Declaration

Source position: exec.pas line 1873

function Supervisor(

  UserFunc: Pointer

):LongWord;

Description

Allow a normal user-mode program to execute a short assembly language function in the supervisor mode of the processor. Supervisor() does not modify or save registers; the user function has full access to the register set. All rules that apply to interrupt code must be followed. In addition, no system calls are permitted.

Errors

You can very easily make the system unusable with this function. In fact it is recommended that you do not use it at all.

See also

SuperState | Enter supervisor state with user stack
UserState | Return to user state with user stack


SuspendTask

Declaration

Source position: exec.pas line 1905

procedure SuspendTask(

  WhichTask: PTask;

  Flags: LongWord

);


TypeOfMem

Determine attributes of a given memory address

Declaration

Source position: exec.pas line 1783

function TypeOfMem(

  const address: Pointer

):LongWord;

Arguments

address

A memory address

Function result

A long word of memory attribute flags. If the address is not in known RAM, zero is returned.

Description

Given a RAM memory address, search the system memory lists and return its memory attributes. The memory attributes are similar to those specified when the memory was first allocated: (eg. MEMF_*)

If the address is not in known-space, a zero will be returned. (Anything that is not RAM, like the ROM or expansion area, will return zero. Also the first few bytes of a memory area are used up by the MemHeader.)


UnLockMem

Declaration

Source position: exec.pas line 1891

procedure UnLockMem(

  BaseAddress: Pointer;

  Size: LongWord

);


UnlockNamedMemory

Declaration

Source position: exec.pas line 1973

procedure UnlockNamedMemory(

  const Space: PChar;

  const Name: PChar

);


UpdateNamedMemory

Declaration

Source position: exec.pas line 1970

procedure UpdateNamedMemory(

  const Space: PChar;

  const Name: PChar

);


UserState

Return to user state with user stack

Declaration

Source position: exec.pas line 1872

procedure UserState(

  SysStack: Pointer

);

Arguments

SysStack

Supervisor stack pointer

Description

Return to user state with user stack, from supervisor state with user stack. This function is normally used in conjunction with the SuperState function.

This function must not be called from the user state.

See also

SuperState

Enter supervisor state with user stack


Vacate

Release a bidMessage from Procure()

Declaration

Source position: exec.pas line 1826

procedure Vacate(

  SigSem: PSignalSemaphore;

  BidMessage: PSemaphoreMessage

);

Arguments

SigSem

The SignalSemaphore that you wish to Vacate()

Description

This function can be used to release a semaphore obtained via Procure(). However, the main purpose for this call is to be able to remove a bid for a semaphore that has not yet responded. This is required when a Procure() was issued and the program no longer needs to get the semaphore and wishes to cancel the Procure() request. The canceled request will be replied with the ssm_Semaphore field set to nil. If you own the semaphore, the message was already replied and only the ssm_Semaphore field will be cleared.

See also

ObtainSemaphoreList | Get a List of semaphores
InitSemaphore | Initialize a signal semaphore
ReleaseSemaphore | Make signal semaphore available to others
AttemptSemaphore | Try to obtain a Semaphore without blocking
ObtainSemaphore | Gain exclusive access to a semaphore
ObtainSemaphoreShared | Gain access to a semaphore in shared mode
Procure | Asynchron locking of a semaphore


VMAreaInit

Declaration

Source position: exec.pas line 1957

function VMAreaInit(

  AddrSpace: Pointer;

  Shared: LongBool;

  Area: Pointer;

  const Tags: PTagItem

):LongBool;


VMAreaTerm

Declaration

Source position: exec.pas line 1959

procedure VMAreaTerm(

  Area: Pointer

);


Wait

Wait for one or more signals

Declaration

Source position: exec.pas line 1801

function Wait(

  SignalSet: LongWord

):LongWord;

Arguments

SignalSet

The set of signals for which to wait. Each bit represents a particular signal.

Function result

The set of signals that were active

Description

This function will cause the current task to suspend waiting for one or more signals. When one or more of the specified signals occurs, the task will return to the ready state, and those signals will be cleared.

If a signal occurred prior to calling Wait(), the wait condition will be immediately satisfied, and the task will continue to run without delay.

Warning:

This function cannot be called while in supervisor mode or interrupts! This function will break the action of a Forbid() or Disable() call.


WaitIO

Wait for completion of an I/O request

Declaration

Source position: exec.pas line 1862

procedure WaitIO(

  IORequest: PIORequest

);

Arguments

IORequest

A pointer to an I/O request block

Description

This function waits for the specified I/O request to complete, then removes it from the replyport. If the I/O has already completed, this function will return immediately.

This function should be used with care, as it does not return until the I/O request completes; if the I/O never completes, this function will never return, and your task will hang. If this situation is a possibility, it is safer to use the Wait() function. Wait() will return return when any of a specified set of signal is received. This is how I/O timeouts can be properly handled.

See also

DoIO | Perform an I/O request and wait for its finish
SendIO | Initiate an I/O command
CheckIO | Check status on an I/O request
AbortIO | Attempt to abort an in-progress I/O request


WaitPort

Wait for a given port to be non-empty

Declaration

Source position: exec.pas line 1812

function WaitPort(

  Port: PMsgPort

):PMessage;

Arguments

Port

A pointer to the message port

Function result

A pointer to the first available message

Description

This function waits for the given port to become non-empty. If necessary, the Wait() function will be called to wait for the port signal. If a message is already present at the port, this function will return immediately. The return value is always a pointer to the first message queued (but it is not removed from the queue).

More than one message may be at the port when this returns. It is proper to call the GetMsg() function in a loop until all messages have been handled, then wait for more to arrive.

To wait for more than one port, combine the signal bits from each port into one call to the Wait() function, then use a GetMsg() loop to collect any and all messages. It is possible to get a signal for a port WITHOUT a message showing up. Plan for this.

See also

GetMsg

Get next message from message port


Reference for unit 'icon': Procedures and functions

AddFreeList | Add memory to a free list.
BumpRevision | Reformat a name for a second copy.
BumpRevisionLength
ChangeToSelectedIconColor | Modify an RGB colour value for use in a selected icon image
DeleteDiskObject | Delete a Workbench disk object from disk.
DrawIconStateA | Draw an icon as if it were an image
DupDiskObjectA | Duplicate an icon
FindToolType | Find the value of a ToolType variable.
FreeAlloc
FreeDiskObject | Free all memory in a Workbench disk object.
FreeFree
FreeFreeList | Free all memory in a free list.
GetDefDiskObject | Read default wb disk object from disk.
GetDiskObject | Read in a Workbench disk object from disk.
GetDiskObjectNew | Read in a Workbench disk object from disk.
GetIconRectangleA | Query the size of the area an icon renders into
GetIconTagList | Retrieve an icon
GetToolTypes
IconClone
IconControlA | Set and get icon and icon.library options
IconExpunge
IconRelease
IcontObtain
LayoutIconA | Adapt a palette-mapped icon for display
MatchToolValue | Check a tool type variable for a particular value.
NewDiskObject | Create an empty icon
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
PutDefDiskObject | Write disk object as the default for its type.
PutDiskObject | Write out a DiskObject to disk.
PutIconTagList | Store an icon
UNPACK_ICON_ASPECT_RATIO


Unit 'icon' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'icon': Variables

IconBase

IIcon


Index of all identifiers in unit 'icon'

A B C D F G I L M N P S T U

A

AddFreeList

B

BumpRevision BumpRevisionLength

C

ChangeToSelectedIconColor

D

DeleteDiskObject DrawIconStateA DupDiskObjectA

F

FindToolType | FreeDiskObject | FreeFreeList
FreeAlloc | FreeFree |

G

GetDefDiskObject | GetDiskObjectNew | GetIconTagList
GetDiskObject | GetIconRectangleA | GetToolTypes

I

ICONA_Dummy | ICONCTRLA_GetTransparentColor2 | ICONDUPA_ActivateImageData
ICONA_ErrorCode | ICONCTRLA_GetWidth | ICONDUPA_AllowUpscaling
ICONA_ErrorTagItem | ICONCTRLA_HasRealImage2 | ICONDUPA_DuplicateDefaultTool
ICONA_LAST_TAG | ICONCTRLA_IsNativeIcon | ICONDUPA_DuplicateDrawerData
ICONA_Reserved1 | ICONCTRLA_IsNewIcon | ICONDUPA_DuplicateImageData
ICONA_Reserved10 | ICONCTRLA_IsPaletteMapped | ICONDUPA_DuplicateImages
ICONA_Reserved11 | ICONCTRLA_RemScaledSize | ICONDUPA_DuplicateScaledSizes
ICONA_Reserved12 | ICONCTRLA_SetAspectRatio | ICONDUPA_DuplicateToolTypes
ICONA_Reserved13 | ICONCTRLA_SetFrameless | ICONDUPA_DuplicateToolWindow
ICONA_Reserved2 | ICONCTRLA_SetGlobalColorIconSupport | ICONDUPA_ForceScaling
ICONA_Reserved3 | ICONCTRLA_SetGlobalEmbossRect | ICONDUPA_Height
ICONA_Reserved4 | ICONCTRLA_SetGlobalFrameless | ICONDUPA_SizeBounds
ICONA_Reserved5 | ICONCTRLA_SetGlobalIdentifyHook | ICONDUPA_UseFriendBitMap
ICONA_Reserved6 | ICONCTRLA_SetGlobalLeftOutMarking | ICONDUPA_Width
ICONA_Reserved7 | ICONCTRLA_SetGlobalMaxNameLength | IconExpunge
ICONA_Reserved8 | ICONCTRLA_SetGlobalNewIconsSupport | ICONGETA_AllowUpscaling
ICONA_Reserved9 | ICONCTRLA_SetGlobalPrecision | ICONGETA_FailIfUnavailable
ICON_ASPECT_RATIO_UNKNOWN | ICONCTRLA_SetGlobalScreen | ICONGETA_FileFormat
IconBase | ICONCTRLA_SetGlobalSelectEffect | ICONGETA_ForceScaling
IconClone | ICONCTRLA_SetHeight | ICONGETA_GenerateImageMasks
IconControlA | ICONCTRLA_SetIconModuleData | ICONGETA_GetDefaultName
ICONCTRLA_AddScaledSize | ICONCTRLA_SetImageData1 | ICONGETA_GetDefaultType
ICONCTRLA_GetAspectRatio | ICONCTRLA_SetImageData2 | ICONGETA_GetPaletteMappedIcon
ICONCTRLA_GetBitMap1 | ICONCTRLA_SetImageDataFormat | ICONGETA_Height
ICONCTRLA_GetBitMap2 | ICONCTRLA_SetNewIconsSupport | ICONGETA_IdentifyBuffer
ICONCTRLA_GetFrameless | ICONCTRLA_SetPalette1 | ICONGETA_IdentifyOnly
ICONCTRLA_GetGlobalColorIconSupport | ICONCTRLA_SetPalette2 | ICONGETA_IsDefaultIcon
ICONCTRLA_GetGlobalEmbossRect | ICONCTRLA_SetPaletteSize1 | ICONGETA_Label
ICONCTRLA_GetGlobalFrameless | ICONCTRLA_SetPaletteSize2 | ICONGETA_RemapIcon
ICONCTRLA_GetGlobalIdentifyHook | ICONCTRLA_SetTransparentColor1 | ICONGETA_Screen
ICONCTRLA_GetGlobalLeftOutMarking | ICONCTRLA_SetTransparentColor2 | ICONGETA_SizeBounds
ICONCTRLA_GetGlobalMaxNameLength | ICONCTRLA_SetWidth | ICONGETA_UseFriendBitMap
ICONCTRLA_GetGlobalNewIconsSupport | ICONCTRLA_UseFriendBitMap | ICONGETA_Width
ICONCTRLA_GetGlobalPrecision | ICON_DRAGGED | ICON_LEFTOUT
ICONCTRLA_GetGlobalScreen | ICONDRAWA_AllowUpscaling | ICONNAME
ICONCTRLA_GetGlobalSelectEffect | ICONDRAWA_Borderless | ICON_POINTED
ICONCTRLA_GetHeight | ICONDRAWA_Borders | ICONPUTA_DropChunkyIconImage
ICONCTRLA_GetIconFileFormat | ICONDRAWA_DrawIcon | ICONPUTA_DropNewIconToolTypes
ICONCTRLA_GetIconModuleData | ICONDRAWA_DrawInfo | ICONPUTA_DropPlanarIconImage
ICONCTRLA_GetImageData1 | ICONDRAWA_EraseBackground | ICONPUTA_FileFormat
ICONCTRLA_GetImageData2 | ICONDRAWA_EraseLabelBackground | ICONPUTA_NoFallback
ICONCTRLA_GetImageDataFormat | ICONDRAWA_Frameless | ICONPUTA_NotifyWorkbench
ICONCTRLA_GetImageMask1 | ICONDRAWA_Height | ICONPUTA_OnlyUpdatePosition
ICONCTRLA_GetImageMask2 | ICONDRAWA_IsLink | ICONPUTA_OptimizeImageSpace
ICONCTRLA_GetNewIconsSupport | ICONDRAWA_LabelOutline | ICONPUTA_PreserveOldIconImages
ICONCTRLA_GetPalette1 | ICONDRAWA_LabelShadow | ICONPUTA_PutDefaultName
ICONCTRLA_GetPalette2 | ICONDRAWA_Properties | ICONPUTA_PutDefaultType
ICONCTRLA_GetPaletteSize1 | ICONDRAWA_SizeBounds | IconRelease
ICONCTRLA_GetPaletteSize2 | ICONDRAWA_Transparency | IcontObtain
ICONCTRLA_GetScreen | ICONDRAWA_Width | IIcon
ICONCTRLA_GetTransparentColor1 | ICON_DROPPABLE |

L

LayoutIconA

M

MatchToolValue

N

NewDiskObject

P

PACK_ICON_ASPECT_RATIO | PutDefDiskObject | PutIconTagList
PIconIdentifyMsg | PutDiskObject |

S

SEL_BRIGHTEN | SEL_IMPOSE | SEL_ROTATERGB
SEL_DARKEN | SEL_NEGATIVE |

T

TIconIdentifyMsg TToolTypeArray

U

UNPACK_ICON_ASPECT_RATIO


AddFreeList

Add memory to a free list.

Declaration

Source position: icon.pas line 233

function AddFreeList(

  FreeList: PFreeList;

  const Mem: Pointer;

  Size: LongWord

):LongBool;

Arguments

FreeList | A Pointer to freelist struct previously allocated by the programmer.
Mem | Memory to add to the freelist.
Size | Size of memory chunk to add to the frelist.

Function result

TRue if the call succeeded else False

Description

This routine adds the specified memory to the free list. The free list will be extended (if required). If there is not enough memory to complete the call, NULL is returned.

Note that AddFreeList() does not allocate the requested memory. It only records the memory in the free list.

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Allocate many regions of memory
FreeFreeList | Free all memory in a free list.


BumpRevision

Reformat a name for a second copy.

Declaration

Source position: icon.pas line 239

function BumpRevision(

  NewName: PChar;

  const OldName: PChar

):PChar;

Arguments

NewName | The new buffer that will receive the name (it must be at least 31 characters long).
OldName | The original name

Function result

Pointer to NewName

Description

BumpRevision takes a name and turns it into a "copy_of_name". It knows how to deal with copies of copies. The routine will truncate the new name to the maximum dos name size (currently 30 characters).

Examples:

OldName | NewName
'foo' | 'copy_of_foo'
'copy_of_foo' | 'copy_2_of_foo'
'copy foo' | 'copy_1_of_foo'
'012345678901234567890123456789' | 'copy_of_0123456789012345678901'


BumpRevisionLength

Declaration

Source position: icon.pas line 262

function BumpRevisionLength(

  NewName: PChar;

  const OldName: PChar;

  MaxLength: LongWord

):PChar;


ChangeToSelectedIconColor

Modify an RGB colour value for use in a selected icon image

Declaration

Source position: icon.pas line 261

procedure ChangeToSelectedIconColor(

  Cr: Pointer

);

Arguments

Cr

Pointer to a ColorRegister, containing the RGB colour value to be changed.

Description

This function will change the provided RGB colour value to make it suitable for use in an icon's select image. This may involve darkening or toning the colour. Usually, icon.library calls this function when creating a select image for palette mapped icons which do not contain "real" select images.


DeleteDiskObject

Delete a Workbench disk object from disk.

Declaration

Source position: icon.pas line 244

function DeleteDiskObject(

  const Name: PChar

):LongBool;

Arguments

Name

Name of the icon file without the ".info"

Function result

True if it worked, False if not, check IoErr() for details.

Description

This routine will try to delete a Workbench disk object from disk. The name parameter will have ".info" postpended to it, and the icon file of that name will be deleted. If the call fails, it will return False. The reason for the failure may be obtained via IoErr().

This call also updates the Workbench screen if needed.

Using this routine protects you from any future changes to the way icons are stored within the system.

See also

IoErr() | Return extra information from the system
PutDiskObject | Write out a DiskObject to disk.
GetDiskObject | Read in a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetIconTagList | Retrieve an icon
PutIconTagList | Store an icon


DrawIconStateA

Draw an icon as if it were an image

Declaration

Source position: icon.pas line 250

procedure DrawIconStateA(

  Rp: PRastPort;

  const Icon: PDiskObject;

  const Label_: PChar;

  LeftOffset: LongInt;

  TopOffset: LongInt;

  State: LongWord;

  const Tags: PTagItem

);

Arguments

Rp | Pointer to the RastPort to draw into; the RastPort clipping rules, font, style, text colours and drawing mode will be used.
Icon | Pointer to a struct DiskObject.
Label_ | Label for the icon, if nil no label is printed
State | Select how and which icon image should be drawn; (IDS_*)
Tags | Additional drawing options (ICONDRAWA_*)

Description

This function will draw an icon as if it were an image; if a label is provided, it will be printed below it.

See also

DrawImageState | Draw an (extended) Intuition Image with special visual state.
GetIconRectangleA | Query the size of the area an icon renders into
IconControlA | Set and get icon and icon.library options


DupDiskObjectA

Duplicate an icon

Declaration

Source position: icon.pas line 246

function DupDiskObjectA(

  const DiskObject: PDiskObject;

  const Tags: PTagItem

):PDiskObject;

Arguments

Tags

Control options. (ICONDUPA_*)

Function result

Pointer to a struct DiskObject or nil in case of error. You can use IoErr() to retrieve the error code or use the ICONA_ErrorCode tag instead.

Description

This function is used to create a duplicate of a DiskObject in memory. It can also be used to create an extended ("native") DiskObject data structure from an existing, traditional format DiskObject data structure.

See also

IoErr()

Return extra information from the system


FindToolType

Find the value of a ToolType variable.

Declaration

Source position: icon.pas line 237

function FindToolType(

  const ToolTypeArray: PPChar;

  const TypeName: PChar

):PChar;

Arguments

ToolTypeArray | A Pointer to an array of tool types.
TypeName | The name of the tooltype entry

Description

This function searches a tool type array for a given entry, and returns a pointer to that entry. This is useful for finding standard tool type variables. The returned value is not a new copy of the string but is only a pointer to the part of the string after TypeName.

The ToolTypeArray can be get from TDiskObject.do_Tooltypes via GetDiskObject()

Snippet

//Assume the tool type array has two strings in it:
//    "FILETYPE=text"
//    "TEMPDIR=:t"
FindToolType(toolTypeArray, 'FILETYPE'); // returns 'text'
FindToolType(toolTypeArray, 'filetype'); // returns 'text'
FindToolType(toolTypeArray, 'TEMPDIR');  // returns ':t'
FindToolType(toolTypeArray, 'MAXSIZE');  // returns nil
FindToolType(toolTypeArray, 'text');     // returns nil
FindToolType(toolTypeArray, ':t');       // returns nil

See also

FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObject | Read in a Workbench disk object from disk.
MatchToolValue | Check a tool type variable for a particular value.
PDiskObject |


FreeAlloc

Declaration

Source position: icon.pas line 240

function FreeAlloc(

  FreeList: PFreeList;

  Len: LongWord;

  Type_: LongWord

):Pointer;


FreeDiskObject

Free all memory in a Workbench disk object.

Declaration

Source position: icon.pas line 236

procedure FreeDiskObject(

  DiskObj: PDiskObject

);

Arguments

DiskObj

A pointer to a DiskObject structure to free. Nil is allowed and does nothing.

Description

This routine frees all memory in a Workbench disk object, and the object itself. It is implemented via FreeFreeList().

GetDiskObject() takes care of all the initialization required to set up the object's free list. This procedure may only be called on a DiskObject allocated via GetDiskObject().

See also

GetDiskObject | Read in a Workbench disk object from disk.
PutDiskObject | Write out a DiskObject to disk.
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeFreeList | Free all memory in a free list.
GetIconTagList | Retrieve an icon
PutIconTagList | Store an icon


FreeFree

Declaration

Source position: icon.pas line 245

function FreeFree(

  FreeList: PFreeList;

  Address: Pointer

):LongBool;


FreeFreeList

Free all memory in a free list.

Declaration

Source position: icon.pas line 231

procedure FreeFreeList(

  FreeList: PFreeList

);

Arguments

FreeList

A Pointer to FreeList struct. Nil is allowed and does nothing.

Description

This routine frees all memory in a free list, and the free list itself. It is useful for easily getting rid of all memory in a series of structures. There is a free list in a Workbench object, and this contains all the memory associated with that object.

A TFreeList is a list of TMemList structures. See the TMemList and TMemEntry documentation for more information.

If the TFreeList itself is in the free list, it must be in the first TMemList in the TFreeList.

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Free many blocks of memory at once
AddFreeList | Add memory to a free list.


GetDefDiskObject

Read default wb disk object from disk.

Declaration

Source position: icon.pas line 241

function GetDefDiskObject(

  Typ: LongInt

):PDiskObject;

Arguments

Typ

Default icon type (Workbench.WBDISK thru Workbench.WBKICK see links).

Function result

The default Workbench disk object in question

Description

This routine reads in a default Workbench disk object from disk. The valid def_types can be found in workbench/workbench.h and currently include WBDISK thru WBKICK. If the call fails, it will return NULL. The reason for the failure may be obtained via IoErr().

Using this routine protects you from any future changes to the way default icons are stored within the system.

See also

IoErr() | Return extra information from the system
PutDefDiskObject | Write disk object as the default for its type.
PutIconTagList | Store an icon
WBDISK | Type of Icon: Disk
WBDRAWER | Type of Icon: Drawer/Folder
WBTOOL | Type of Icon: Tool (Excutable)
WBPROJECT | Type of Icon: Project (Data file)
WBGARBAGE | Type of Icon: Trashcan
WBDEVICE | Type of Icon: Device
WBKICK | Type of Icon: KickStart disk
WBAPPICON | Type of Icon: AppIcon


GetDiskObject

Read in a Workbench disk object from disk.

Declaration

Source position: icon.pas line 234

function GetDiskObject(

  const Name: PChar

):PDiskObject;

Arguments

Name

Name of the object or nil if you just want a DiskObject structure allocated for you (useful when calling AddAppIcon() in workbench.library).

Function result

The Workbench disk object in question

Description

This routine reads in a Workbench disk object in from disk. The name parameter will have ".info" postpended to it, and the icon file of that name will be read. If the call fails, it will return nil. The reason for the failure may be obtained via IoErr().

Using this routine protects you from any future changes to the way icons are stored within the system.

A TFreeList structure is allocated just after the DiskObject structure; FreeDiskObject() makes use of this to get rid of the memory that was allocated.

See also

IoErr() | Return extra information from the system
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObjectNew | Read in a Workbench disk object from disk.
GetIconTagList | Retrieve an icon
NewDiskObject | Create an empty icon
PutDiskObject | Write out a DiskObject to disk.
PutIconTagList | Store an icon
AddAppIconA |


GetDiskObjectNew

Read in a Workbench disk object from disk.

Declaration

Source position: icon.pas line 243

function GetDiskObjectNew(

  const Name: PChar

):PDiskObject;

Arguments

Name

Name of the object or nil if you just want a DiskObject structure allocated for you (useful when calling AddAppIcon() in workbench.library).

Function result

The Workbench disk object in question

Description

This routine reads in a Workbench disk object in from disk. The name parameter will have ".info" postpended to it, and the icon file of that name will be read. If the call fails, it will return zero. The reason for the failure may be obtained via IoErr().

Using this routine protects you from any future changes to the way icons are stored within the system.

A TFreeList structure is allocated just after the DiskObject structure; FreeDiskObject() makes use of this to get rid of the memory that was allocated.

This call is functionally identical to GetDiskObject() with one exception. If its call to GetDiskObject() fails, this function calls GetDefDiskObject(). This is useful when there is no .info file for the icon you are trying to get a disk object for. Applications that use workbench application windows must use this call if they want to handle the user dropping an icon (that doesn't have a '.info' file) on their window.

See also

IoErr() | Return extra information from the system
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObject | Read in a Workbench disk object from disk.
GetIconTagList | Retrieve an icon
NewDiskObject | Create an empty icon
PutDiskObject | Write out a DiskObject to disk.
PutIconTagList | Store an icon
AddAppIconA |


GetIconRectangleA

Query the size of the area an icon renders into

Declaration

Source position: icon.pas line 252

function GetIconRectangleA(

  Rp: PRastPort;

  const Icon: PDiskObject;

  const Label_: PChar;

  Rect: PRectangle;

  const Tags: PTagItem

):LongBool;

Arguments

Rp | Pointer to the RastPort to use for calculating the the size of the label with respect to the font and style options currently in use; this parameter may be NULL if the label is NULL, too.
Icon | True if the parameters were well-formed and the output data fits into the Rectangle data structure (which may not be the case if the image is too large for a signed 16 bit integer to hold).
Label_ | Label for icon, if nil no text is calculated
Rect | Pointer to a Rectangle to fill in. The contents will take the size of the icon image, the icon border size and -- if you provide RastPort and label text -- the icon label into account. Due to how labels are printed, the rectangle^.MinX and rectangle^.MinY members may be negative.
Tags | Additional drawing options to be taken into account. (ICONDRAWA_*)

Description

This function will calculate the size of the area icon rendering would affect.

Notes:

This function can be used to optimize on-screen rendering by precalculating the area rendering would cover. To make sure that the precalculated area size matches the one covered by the actual drawing operation, the RastPorts you use for measuring and for drawing should share the same font and the same text styles.

The image size calculated by this function can be slightly larger than the data you will find in the icon's do_Gadget.GadgetRender Image structure since the icon border will be taken into account. This happens regardless of whether icon.library was switched into frameless icon rendering mode or whether the icon is frameless. To obtain the size of the icon without taking the border into account, use the ICONDRAWA_Borderless tag.

See also

DrawIconStateA | Draw an icon as if it were an image
IconControlA | Set and get icon and icon.library options


GetIconTagList

Retrieve an icon

Declaration

Source position: icon.pas line 255

function GetIconTagList(

  const Name: PChar;

  const Tags: PTagItem

):PDiskObject;

Arguments

Name | Name of the object an icon is to be retrieved for, or nil if a default icon is to be retrieved.
Tags | Retrieval options. (ICONGETA_*)

Function result

Pointer to a struct DiskObject or nil in case of error. You can use IoErr() to retrieve the error code or use the ICONA_ErrorCode tag instead.

Description

This function is used to retrieve an icon; the icon can belong to a file/drawer/volume or it can be a default icon.

This function is a superset of GetDefDiskObject(), GetDiskObject() and GetDiskObjectNew().

If a palette-mapped icon is set to allocate its colours from the default screen, such as the Workbench screen, icon.library may resort to remap its colours in the course of Workbench screen close/reopen transitions. This means that you cannot depend upon the icon's image bitmaps to stay the same size, shape or colour. If this is what you need, you should either create your own images from the palette mapped data or make copies of the icon image bitmaps and the associated colour table.

If during Workbench close/open transitions the global remap screen becomes nil, GetIconTagList() may refuse to return a remapped icon and return with an error (ERROR_REQUIRED_ARG_MISSING) instead.

See also

GetDiskObject | Read in a Workbench disk object from disk.
GetDiskObjectNew | Read in a Workbench disk object from disk.
GetDefDiskObject | Read default wb disk object from disk.
IconControlA | Set and get icon and icon.library options
PutIconTagList | Store an icon


GetToolTypes

Declaration

Source position: icon.pas line 271

function GetToolTypes(

  Filename: AnsiString

):TToolTypeArray;


IconClone

Declaration

Source position: icon.pas line 229

function IconClone: PInterface;


IconControlA

Set and get icon and icon.library options

Declaration

Source position: icon.pas line 248

function IconControlA(

  Icon: PDiskObject;

  const Tags: PTagItem

):LongWord;

Arguments

Icon | Pointer to a struct DiskObject, or NULL if global options are to be modified/queried.
Tags | Options to modify/query.

Function result

Number of tags that were processed correctly, i.e. the number of tags whose parameters are in order, for which information could be returned, etc. If processing stops because of an error, the number returned by this function will be smaller than the number of tag items passed in. The same happens if the information you wanted to obtain is unavailable. In any case, check the error code this routine can set up for you.

Changing an icon's palette or image data does not automatically produce a different icon image you can use. To do this, you must re-layout it using LayoutIconA().

When querying parameters, make sure to always pass in a pointer to a LongWord variable to store the result in.

Some get/set operations may cause additional memory to be allocated. This may fail; be prepared.

IconControlA() processes the tag item list in sequential order. This has consequences for several tags, such as the palette size and the transparent colour. For example, if you want to make colour #14 of an icon image transparent, make sure to have the palette size set to at least 15 colours before you try to change the transparent colour. Otherwise, IconControlA() may refuse to set the transparent colour to #14 since it won't know that there should be more than 14 colours in that image at the time you try to set it. Therefore, if you wanted to change the palette size and the transparent colour in the same tag item list, make sure that the palette size change tag appears before the transparent colour change tag.

As described above, some of the operations on icons are not supported for DiskObjects not allocated through icon.library. In such cases you will receive an error code ERROR_ACTION_NOT_KNOWN.

Description

This function is used to modify and query icon and icon.library options.

See also

IoErr | Return extra information from the system
DupDiskObjectA | Duplicate an icon
GetIconTagList | Retrieve an icon
LayoutIconA | Adapt a palette-mapped icon for display
NewDiskObject | Create an empty icon
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ObtainBestPenA | Search for the closest color match, or allocate a new one.
CallHookPkt | Invoke a Hook function callback.


IconExpunge

Declaration

Source position: icon.pas line 228

procedure IconExpunge;


IconRelease

Declaration

Source position: icon.pas line 227

function IconRelease: LongWord;


IcontObtain

Declaration

Source position: icon.pas line 226

function IcontObtain: LongWord;


LayoutIconA

Adapt a palette-mapped icon for display

Declaration

Source position: icon.pas line 259

function LayoutIconA(

  Icon: PDiskObject;

  Screen: PScreen;

  Tags: PTagItem

):LongBool;

Arguments

Icon | The icon to be remapped. This must be a palette mapped icon.
Screen | Pointer to a screen to remap the icon for or nil to remap the icon to use the system default colour palette or something very similar to it (this means: four colours only).
Tags | Additional rendering options. OBP_Precision

Function result

True if the icon could be remapped, False if the remapping failed for some reason. In case of of failure, icon.library will try its best to keep the icon in a presentable state, but this may fail. In case of failure, the error code can be retrieved using IoErr().

Description

This function will prepare an icon for display, either on a specific screen or using a default colour palette. It is useful only for palette mapped icons.

You must make sure that the screen you remap to does not go away while there is an icon to use its colours. For a public screen, the easiest way to guarantee this is to keep it locked (see LockPubScreen()). For custom screens, just don't close them! If you have to close the screen or need to keep your icon around until after a screen is closed, you should call LayoutIconA() with a nil screen parameter. This will release all pens the icon has allocated and remap the icon to a default set of colours. Alternatively, you can dispose of the icon via FreeDiskObject() which will also release all pens the icon has allocated, including the icon itself, of course.

Icons remapped to the global default screen (normally, that would be the Workbench screen) may get changed and remapped again during Workbench close/open transitions. To prevent this from taking place, just make sure that the Workbench screen does not close (e.g. via LockPubScreen()("Workbench")).

See also

IoErr | Return extra information from the system
ObtainBestPenA | Search for the closest color match, or allocate a new one.
ObtainBestPenA | Release an allocated palette entry to the free pool.
FreeDiskObject | Free all memory in a Workbench disk object.
GetIconTagList | Retrieve an icon
IconControlA | Set and get icon and icon.library options
LockPubScreen | Prevent a public screen from closing.
UnLockPubScreen | Release lock on a public screen.


MatchToolValue

Check a tool type variable for a particular value.

Declaration

Source position: icon.pas line 238

function MatchToolValue(

  const TypeString: PChar;

  const Value: PChar

):SmallInt;

Arguments

TypeString | A ToolType value (as returned by FindToolType())
Value | You are interested if value appears in TypeString

Function result

True if the value was in TypeString else False.

Description

MatchToolValue is useful for parsing a tool type value for a known value. It knows how to parse the syntax for a tool type value (in particular, it knows that '|' separates alternate values). Note that the parsing is case insensitive.

Snippet

//Assume there are two type strings:
type1 := 'text';
type2 := 'a|b|c';
MatchToolValue(type1, 'text'); // returns True
MatchToolValue(type1, 'TEXT'); // returns True
MatchToolValue(type1, 'data'); // returns False
MatchToolValue(type2, 'a');    // returns True
MatchToolValue(type2, 'b');    // returns True
MatchToolValue(type2, 'd');    // returns False
MatchToolValue(type2, 'a|b');  // returns False

See also

FindToolType

Find the value of a ToolType variable.


NewDiskObject

Create an empty icon

Declaration

Source position: icon.pas line 254

function NewDiskObject(

  Type_: LongWord

):PDiskObject;

Arguments

Type_

Icon type to create, this must be one of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK.

Function result

Pointer to a struct DiskObject or nil in case of error. You can use IoErr() to retrieve the error code.

Description

This function is used to create an "empty" DiskObject structure, which has no image data associated with it. Still, all the necessary structures are in place, you just have to fill them in.

The DiskObject returned by this function will have a zero width and height Image in the do_Gadget.GadgetRender member and the do_Gadget.Width/do_Gadget.Height members will both be 0, too.

See also

IoErr()

Return extra information from the system


PACK_ICON_ASPECT_RATIO

Pack Numerator and a denominator into a single byte as icon aspect

Declaration

Source position: icon.pas line 265

function PACK_ICON_ASPECT_RATIO(

  Num: LongInt;

  Den: LongInt

):LongInt;

Arguments

Num | Numerator
Den | Denominator

See also

ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
IconControlA | Set and get icon and icon.library options


PutDefDiskObject

Write disk object as the default for its type.

Declaration

Source position: icon.pas line 242

function PutDefDiskObject(

  const Icon: PDiskObject

):LongBool;

Arguments

Icon

A pointer to a DiskObject

Function result

True if the call succeeded else False

Description

This routine writes out a DiskObject structure, and its associated information. If the call fails, False will be returned. The reason for the failure may be obtained via IoErr().

Note that this function calls PutDiskObject() internally which means that this call (if sucessful) notifies workbench than an icon has been created/modified.

Using this routine protects you from any future changes to the way default icons are stored within the system.

See also

IoErr() | Return extra information from the system
GetDefDiskObject | Read default wb disk object from disk.
GetIconTagList | Retrieve an icon
PutDiskObject | Write out a DiskObject to disk.


PutDiskObject

Write out a DiskObject to disk.

Declaration

Source position: icon.pas line 235

function PutDiskObject(

  const Name: PChar;

  const Icon: PDiskObject

):LongBool;

Arguments

Name | Name of the object
Icon | A pointer to a DiskObject

Description

This routine writes out a DiskObject structure, and its associated information. The file name of the info file will be the name parameter with ".info" postpended to it. If the call fails, False will be returned. The reason for the failure may be obtained via IoErr().

PutDiskObject() (if successful) notifies Workbench when an icon has been created/modified.

Using this routine protects you from any future changes to the way icons are stored within the system.

Note:

It is recommended that if you wish to copy an icon from one place to another than you use GetDiskObject() and PutDiskObject() and do not copy them directly.

See also

IoErr() | Return extra information from the system
DeleteDiskObject | Delete a Workbench disk object from disk.
FreeDiskObject | Free all memory in a Workbench disk object.
GetDiskObject | Read in a Workbench disk object from disk.
GetIconTagList | Retrieve an icon
PutIconTagList | Store an icon


PutIconTagList

Store an icon

Declaration

Source position: icon.pas line 257

function PutIconTagList(

  const Name: PChar;

  const Icon: PDiskObject;

  const Tags: PTagItem

):LongBool;

Arguments

Name | Name of the object the icon is to be stored for, or nil if a default icon is to be stored.
Icon | The icon to be stored.
Tags | Storage options. (ICONPUTA_*)

Function result

True if the icon file could be stored, FALSE otherwise. You can use IoErr() to retrieve the error code or use the ICONA_ErrorCode tag instead.

Description

This function is used to store an icon; the icon can belong to a file/drawer/volume or it can be a default icon.

This function is a superset of PutDefDiskObject() and PutDiskObject().

If the name of the icon file to be stored would be too long to fit (as set with IconControlA(..., ICONCTRLA_SetGlobalMaxNameLength, ...)) then PutIconTagList() will silently pretend that the icon file has been written to disk. However, it will not store the icon file on the disk since there would a risk of accidentally overwriting the file the icon belongs to. If you want to know whether the icon you wrote was in fact written to disk, provide an error code pointer with the ICONA_ErrorCode tag. If the name of the file was too long, PutIconTagList() will still pretend that the icon file was written successfully, but the error code ERROR_TOO_MANY_LEVELS will be stored in the variable you passed in with the ICONA_ErrorCode tag.

See also

GetIconTagList | Retrieve an icon
PutDefDiskObject | Write disk object as the default for its type.
PutDiskObject | Write out a DiskObject to disk.


UNPACK_ICON_ASPECT_RATIO

Declaration

Source position: icon.pas line 266

procedure UNPACK_ICON_ASPECT_RATIO(

  Aspect: LongInt;

  var Num: LongInt;

  var Den: LongInt

);


Reference for unit 'iffparse': Procedures and functions

AllocIFF

AllocLocalItem

CloseClipboard

CloseIFF

CollectionChunk

CollectionChunks

CurrentChunk

EntryHandler

ExitHandler

FindCollection

FindLocalItem

FindProp

FindPropContext

FreeIFF

FreeLocalItem

GoodID

GoodType

IDtoStr

IFFParseClone

IFFParseExpunge

IFFParseObtain

IFFParseRelease

InitIFF

InitIFFasClip

InitIFFasDOS

LocalItemData

Make_ID

OpenClipboard

OpenIFF

ParentChunk

ParseIFF

PopChunk

PropChunk

PropChunks

PushChunk

ReadChunkBytes

ReadChunkRecords

SetLocalItemPurge

StopChunk

StopChunks

StopOnExit

StoreItemInContext

StoreLocalItem

WriteChunkBytes

WriteChunkRecords


Unit 'iffparse' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'iffparse': Variables

IFFParseBase

IIFFParse


Index of all identifiers in unit 'iffparse'

A C E F G I L M O P R S T W

A

AllocIFF AllocLocalItem

C

CloseClipboard | CollectionChunk | CurrentChunk
CloseIFF | CollectionChunks |

E

EntryHandler ExitHandler

F

FindCollection | FindProp | FreeIFF
FindLocalItem | FindPropContext | FreeLocalItem

G

GoodID GoodType

I

ID_CAT | IFFERR_NOMEM | IFFParseClone
ID_FORM | IFFERR_NOSCOPE | IFFParseExpunge
ID_LIST | IFFERR_NOTIFF | IFFPARSENAME
ID_NULL | IFFERR_READ | IFFParseObtain
ID_PROP | IFFERR_SEEK | IFFPARSE_RAWSTEP
IDtoStr | IFFERR_SYNTAX | IFFParseRelease
IFFCMD_CLEANUP | IFFERR_WRITE | IFFPARSE_SCAN
IFFCMD_ENTRY | IFFF_FSEEK | IFFPARSE_STEP
IFFCMD_EXIT | IFFF_READ | IFF_RETURN2CLIENT
IFFCMD_INIT | IFFF_RESERVED | IFFSIZE_UNKNOWN
IFFCMD_PURGELCI | IFFF_RSEEK | IFFSLI_PROP
IFFCMD_READ | IFFF_RWBITS | IFFSLI_ROOT
IFFCMD_SEEK | IFFF_WRITE | IFFSLI_TOP
IFFCMD_WRITE | IFFLCI_COLLECTION | IIFFParse
IFFERR_EOC | IFFLCI_ENTRYHANDLER | InitIFF
IFFERR_EOF | IFFLCI_EXITHANDLER | InitIFFasClip
IFFERR_MANGLED | IFFLCI_PROP | InitIFFasDOS
IFFERR_NOHOOK | IFFParseBase |

L

LocalItemData

M

Make_ID

O

OpenClipboard OpenIFF

P

ParentChunk | PIFFHandle | PropChunks
ParseIFF | PIFFStreamCmd | PStoredProperty
PClipboardHandle | PLocalContextItem | PushChunk
PCollectionItem | PopChunk |
PContextNode | PropChunk |

R

ReadChunkBytes ReadChunkRecords

S

SetLocalItemPurge | StopChunks | StoreItemInContext
StopChunk | StopOnExit | StoreLocalItem

T

TClipboardHandle | TIFFHandle | TStoredProperty
TCollectionItem | TIFFStreamCmd |
TContextNode | TLocalContextItem |

W

WriteChunkBytes WriteChunkRecords


AllocIFF

Declaration

Source position: iffparse.pas line 165

function AllocIFF: PIFFHandle;


AllocLocalItem

Declaration

Source position: iffparse.pas line 190

function AllocLocalItem(

  Type_: LongInt;

  ID: LongInt;

  Ident: LongInt;

  DataSize: LongInt

):PLocalContextItem;


CloseClipboard

Declaration

Source position: iffparse.pas line 201

procedure CloseClipboard(

  clipHandle: PClipboardHandle

);


CloseIFF

Declaration

Source position: iffparse.pas line 168

procedure CloseIFF(

  Iff: PIFFHandle

);


CollectionChunk

Declaration

Source position: iffparse.pas line 182

function CollectionChunk(

  Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt

):LongInt;


CollectionChunks

Declaration

Source position: iffparse.pas line 183

function CollectionChunks(

  Iff: PIFFHandle;

  const PropArray: PLongInt;

  NumPairs: LongInt

):LongInt;


CurrentChunk

Declaration

Source position: iffparse.pas line 188

function CurrentChunk(

  const Iff: PIFFHandle

):PContextNode;


EntryHandler

Declaration

Source position: iffparse.pas line 176

function EntryHandler(

  Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt;

  Position: LongInt;

  Handler: PHook;

  Obj: Pointer

):LongInt;


ExitHandler

Declaration

Source position: iffparse.pas line 177

function ExitHandler(

  Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt;

  Position: LongInt;

  Handler: PHook;

  Obj: Pointer

):LongInt;


FindCollection

Declaration

Source position: iffparse.pas line 186

function FindCollection(

  const Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt

):PCollectionItem;


FindLocalItem

Declaration

Source position: iffparse.pas line 194

function FindLocalItem(

  const Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt;

  Ident: LongInt

):PLocalContextItem;


FindProp

Declaration

Source position: iffparse.pas line 185

function FindProp(

  const Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt

):PStoredProperty;


FindPropContext

Declaration

Source position: iffparse.pas line 187

function FindPropContext(

  const Iff: PIFFHandle

):PContextNode;


FreeIFF

Declaration

Source position: iffparse.pas line 169

procedure FreeIFF(

  Iff: PIFFHandle

);


FreeLocalItem

Declaration

Source position: iffparse.pas line 193

procedure FreeLocalItem(

  LocalItem: PLocalContextItem

);


GoodID

Declaration

Source position: iffparse.pas line 202

function GoodID(

  ID: LongInt

):LongInt;


GoodType

Declaration

Source position: iffparse.pas line 203

function GoodType(

  Type_: LongInt

):LongInt;


IDtoStr

Declaration

Source position: iffparse.pas line 204

function IDtoStr(

  ID: LongInt;

  Buf: PChar

):PChar;


IFFParseClone

Declaration

Source position: iffparse.pas line 164

function IFFParseClone: PInterface;


IFFParseExpunge

Declaration

Source position: iffparse.pas line 163

procedure IFFParseExpunge;


IFFParseObtain

Declaration

Source position: iffparse.pas line 161

function IFFParseObtain: LongWord;


IFFParseRelease

Declaration

Source position: iffparse.pas line 162

function IFFParseRelease: LongWord;


InitIFF

Declaration

Source position: iffparse.pas line 197

procedure InitIFF(

  Iff: PIFFHandle;

  Flags: LongInt;

  const StreamHook: PHook

);


InitIFFasClip

Declaration

Source position: iffparse.pas line 199

procedure InitIFFasClip(

  Iff: PIFFHandle

);


InitIFFasDOS

Declaration

Source position: iffparse.pas line 198

procedure InitIFFasDOS(

  Iff: PIFFHandle

);


LocalItemData

Declaration

Source position: iffparse.pas line 191

function LocalItemData(

  const LocalItem: PLocalContextItem

):POINTER;


Make_ID

Declaration

Source position: iffparse.pas line 206

function Make_ID(

  Str: string

):LongWord;


OpenClipboard

Declaration

Source position: iffparse.pas line 200

function OpenClipboard(

  UnitNumber: LongInt

):PClipboardHandle;


OpenIFF

Declaration

Source position: iffparse.pas line 166

function OpenIFF(

  Iff: PIFFHandle;

  RWMode: LongInt

):LongInt;


ParentChunk

Declaration

Source position: iffparse.pas line 189

function ParentChunk(

  const ContextNode: PContextNode

):PContextNode;


ParseIFF

Declaration

Source position: iffparse.pas line 167

function ParseIFF(

  Iff: PIFFHandle;

  Control: LongInt

):LongInt;


PopChunk

Declaration

Source position: iffparse.pas line 175

function PopChunk(

  Iff: PIFFHandle

):LongInt;


PropChunk

Declaration

Source position: iffparse.pas line 178

function PropChunk(

  Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt

):LongInt;


PropChunks

Declaration

Source position: iffparse.pas line 179

function PropChunks(

  Iff: PIFFHandle;

  const PropArray: PLongInt;

  NumPairs: LongInt

):LongInt;


PushChunk

Declaration

Source position: iffparse.pas line 174

function PushChunk(

  Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt;

  Size: LongInt

):LongInt;


ReadChunkBytes

Declaration

Source position: iffparse.pas line 170

function ReadChunkBytes(

  Iff: PIFFHandle;

  Buf: Pointer;

  NumBytes: LongInt

):LongInt;


ReadChunkRecords

Declaration

Source position: iffparse.pas line 172

function ReadChunkRecords(

  Iff: PIFFHandle;

  Buf: Pointer;

  BytesPerRecord: LongInt;

  NumRecords: LongInt

):LongInt;


SetLocalItemPurge

Declaration

Source position: iffparse.pas line 192

procedure SetLocalItemPurge(

  LocalItem: PLocalContextItem;

  const PurgeHook: PHook

);


StopChunk

Declaration

Source position: iffparse.pas line 180

function StopChunk(

  Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt

):LongInt;


StopChunks

Declaration

Source position: iffparse.pas line 181

function StopChunks(

  Iff: PIFFHandle;

  const PropArray: PLongInt;

  NumPairs: LongInt

):LongInt;


StopOnExit

Declaration

Source position: iffparse.pas line 184

function StopOnExit(

  Iff: PIFFHandle;

  Type_: LongInt;

  ID: LongInt

):LongInt;


StoreItemInContext

Declaration

Source position: iffparse.pas line 196

procedure StoreItemInContext(

  Iff: PIFFHandle;

  LocalItem: PLocalContextItem;

  ContextNode: PContextNode

);


StoreLocalItem

Declaration

Source position: iffparse.pas line 195

function StoreLocalItem(

  Iff: PIFFHandle;

  LocalItem: PLocalContextItem;

  Position: LongInt

):LongInt;


WriteChunkBytes

Declaration

Source position: iffparse.pas line 171

function WriteChunkBytes(

  Iff: PIFFHandle;

  const Buf: Pointer;

  NumBytes: LongInt

):LongInt;


WriteChunkRecords

Declaration

Source position: iffparse.pas line 173

function WriteChunkRecords(

  Iff: PIFFHandle;

  const Buf: Pointer;

  BytesPerRecord: LongInt;

  NumRecords: LongInt

):LongInt;


Reference for unit 'intuition': Procedures and functions

ActivateGadget | Activate a (string or custom) gadget.
ActivateWindow | Activate an Intuition window.
AddClass | Make a public class available
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
AllocRemember | Allocate Memory with tracking to make freeing easy.
AllocScreenBuffer | Get a ScreenBuffer for double-buffering.
AlohaWorkbench
AutoRequest | Automatically build and get response from a requester.
BASEOBJECT | Get "public" handle on baseclass instance from real beginning of obj data
BeginRefresh | Sets up a window for optimized refreshing.
BitMapInstanceControlA
BuildEasyRequestArgs | Simple creation of system request.
BuildSysRequest | Build and display a system requester.
ChangeScreenBuffer | Swap the screen's BitMap.
ChangeWindowBox | Change window position and dimensions.
ClearDMRequest | Clear (detaches) the DMRequest of the window.
ClearMenuStrip | Clear (detach) the menu strip from the window.
ClearPointer | Clear the mouse pointer definition from a window.
CloseClass
CloseGUIPlugin
CloseScreen | Close an Intuition screen.
CloseWindow | Close an Intuition window.
CloseWorkBench | Closes the Workbench screen.
CoerceMethod
CoerceMethodA | Perform method on coerced object.
CurrentTime | Get the current time values.
CUSTOM_HOOK | Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget
DirectionVector
DisableTemplate
DisableTemplateRGB
DisplayAlert | Create the display of an alert message.
DisplayBeep | Flash the video display.
DisposeObject | Deletes a 'boopsi' object.
DoGadgetMethodA | Invoke method on a boopsi gadget.
DoMethod | VarArgs Version of DoMethodA()
DoMethodA | Perform method on object.
DoRender
DoScrollHook
DoSuperMethod | VarArgs Version of DoSuperMethodA()
DoSuperMethodA | Perform method on object coerced to superclass.
DoubleClick | Test two time values for double-click timing.
DrawBorder | Draw the specified Border structure into a RastPort.
DrawGradient
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.
DrawSysImageA
EasyRequest | VarArgs Version of EasyRequestArgs()
EasyRequestArgs | Easy alternative to AutoRequest()
EmbossDisableRect
EmbossDisableText
EndRefresh | End the optimized refresh state of the window.
EndRequest | Remove a currently active requester.
EndScreenNotify
EraseImage | Erases an Image.
FindClass
FindMenuKey
FreeClass | Frees a boopsi class created by MakeClass().
FreeRemember | Free memory allocated by calls to AllocRemember().
FreeScreenBuffer | Free a ScreenBuffer structure.
FreeScreenDrawInfo | Finish using a DrawInfo structure.
FreeSysRequest | Free resources gotten by a call to BuildSysRequest().
FULLMENUNUM | Menu helper macro
GadgetBox
GadgetMouse | Calculate gadget-relative mouse position.
GADGET_BOX | Get bounding box of a gadget
GetAttr | Inquire the value of some attribute of an object.
GetAttrsA
GetDefaultPubScreen | Get name of default public screen.
GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetGUIAttrsA
GetHalfPens
GetMarkedBlock
GetPrefs | Get the current Intuition Preferences structure.
GetRenderDomain
GetScreenAttr
GetScreenAttrsA
GetScreenData | Get copy of a screen data structure.
GetScreenDrawInfo | Get pointer to rendering information.
GetWindowAttr
GetWindowAttrsA
HelpControl | Enable/disable Gadget-Help feature.
HideWindow
ICoerceMethodA
IDoMethodA
IDoSuperMethodA
IM_BGPEN | Set Image Background Pen
IM_BOX | Get Image bounding rectangle
IM_FGPEN | Set Image Foreground pen
InitRequester | Initialize a Requester structure.
INST_DATA | Finds Object local instance data
IntuiTextExtent
IntuiTextLength | Return the length (pixel-width) of an IntuiText.
IntuitionClone
IntuitionControlA
IntuitionExpunge
IntuitionObtain
IntuitionRelease
Intuition_
ISetSuperAttrsA
ItemAddress | Returns the address of the specified MenuItem.
ITEMNUM | Menu helper macro
LendMenus | Lend window's menu action to another window.
LockClassList
LockGUIPrefs
LockIBase | Invoke semaphore arbitration of TIntuitionBase.
LockPubScreen | Prevent a public screen from closing.
LockPubScreenList | Prevent changes to the system list.
LockScreen
LockScreenGI
LockScreenList
MakeClass | Create and initialize a boopsi class.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.
MENUNUM | Menu helper macro
ModifyIDCMP | Modify the state of a window's IDCMPFlags.
ModifyProp | Modify the current parameters of a proportional gadget.
MoveScreen | Attempt to move the screen by the increments provided.
MoveWindow | Ask Intuition to move a window.
MoveWindowInFrontOf | Arrange the relative depth of a window.
NewModifyProp | ModifyProp(), but with selective refresh.
NewObject | Varargs version of NewObjectA()
NewObjectA | Create an object from a class.
NextObject | Iterate through the object on an Exec list.
NextPubScreen | Identify next public screen in the cycle.
ObtainBitMapInstanceA
ObtainBitMapSourceA
ObtainGIRPort | Set up a RastPort for a custom gadget.
ObtainIBackFill
ObtainIPluginList
OCLASS | Get class pointer from an object handle
OffGadget | Disable the specified gadget.
OffMenu | Disable the given menu or menu item.
OnGadget | Enable the specified gadget.
OnMenu | Enable the given menu or menu item.
OpenClass
OpenGUIPlugin
OpenIntuition
OpenScreen | Open an Intuition screen
OpenScreenTagList | OpenScreen() with TagItem extension array.
OpenScreenTags | Varargs Version of OpenScreenTagList()
OpenWindow | Open an Intuition window.
OpenWindowTagList | OpenWindow() with TagItem extension.
OpenWindowTags | Varargs Version of OpenWindowTagList()
OpenWorkBench | Open the Workbench screen.
PointInImage | Tests whether an image "contains" a point.
PrintEmbossedDisabledIText
PrintIText | Print text described by the IntuiText argument.
PubScreenStatus | Change status flags for a public screen.
QueryOverscan | Inquire about a standard overscan region.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
RefreshSetGadgetAttrsA
RefreshWindowFrame | Ask Intuition to redraw your window border.
ReleaseBitMapInstance
ReleaseBitMapSource
ReleaseGIRPort | Release a custom gadget RastPort.
ReleaseIBackFill
ReleaseIPluginList
RemakeDisplay |
RemoveClass | Make a public boopsi class unavailable.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
ReportMouse | Tell Intuition whether to report mouse movement.
ReportMouse1
Request | Activate a requester.
ResetMenuStrip | Re-attach a menu strip to a window.
RethinkDisplay | Grand manipulation of the entire Intuition display.
ScreenDepth | Depth arrange a screen with extra control.
ScreenPosition | Move screens with greater control.
ScreenToBack | Send the specified screen to the back of the display.
ScreenToFront | Make the specified screen the frontmost.
ScrollWindowRaster | Scrolls the content of the rectangle
SetAttrs | Varargs Version of SetAttrsA()
SetAttrsA | Specify attribute values for an object.
SetDefaultPubScreen | Choose a new default public screen.
SetDisplayBeepHook
SetDMRequest | Set the DMRequest of a window.
SetEditHook | Set global processing for string gadgets.
SetGadgetAttrs | Varargs Version of SetGadgetAttrsA()
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.
SetGUIAttrsA
SetIPrefs
SetMarkedBlock
SetMenuStrip | Attach a menu strip to a window.
SetMouseQueue | Change limit on pending mouse messages.
SetPointer | Specify a pointer sprite image for a window.
SetPrefs | Set Intuition preferences data.
SetPubScreenModes | Establish global public screen behavior.
SetRenderDomain
SetScreenAttr
SetScreenAttrsA
SetScreenBitMapInstance
SetWindowAttr
SetWindowAttrsA
SetWindowPointer | Varargs Version of SetWindowPointerA()
SetWindowPointerA | Select a pointer for your window.
SetWindowTitles | Set the window's titles for both window and screen.
ShadeRectA
ShadeRectOld
SHIFTITEM | Menu helper macro
SHIFTMENU | Menu helper macro
SHIFTSUB | Menu helper macro
ShowTitle | Set the screen title bar display mode.
ShowWindow
SIZEOF_INSTANCE | Sizeof the instance data for a given class
SizeWindow | Ask Intuition to size a window.
StartScreenNotifyTagList
StripIntuiMessages
SUBNUM | Menu helper macro
SysReqHandler | Handle system requester input.
TimedDisplayAlert | Display an alert with automatic time-out.
UnlockClassList
UnlockGUIPrefs
UnlockIBase | Release a an Intuition lock gotten by LockIBase().
UnlockPubScreen | Release lock on a public screen.
UnlockPubScreenList | Release public screen list semaphore.
UnlockScreen
UnlockScreenGI
UnlockScreenList
ViewAddress | Return the address of the Intuition View structure.
ViewPortAddress | Return the address of a window's viewport.
WBenchToBack | Send the Workbench screen in back of all screens.
WBenchToFront | Bring the Workbench screen in front of all screens.
WindowLimits | Set the minimum and maximum limits of a window.
WindowToBack | Ask Intuition to send a window behind others.
WindowToFront | Ask Intuition to bring a window to the front.
ZipWindow | Change window to "alternate" position and dimensions.
_OBJ | convenient typecast to P_Object
__OBJECT | Get back to object data struct from public handle


Reference for unit 'intuition': Variables

IIntuition

IntuitionBase

Library Base for intuition.library


Index of all identifiers in unit 'intuition'

A B C D E F G H I K L M N O P Q R S T U V W Z

A

ABSOLUTE_DIMENSIONS | ALTLEFT | AUTOFRONTPEN
ActivateGadget | ALTRIGHT | AUTOITEXTFONT
ActivateWindow | AMIGAKEY | AUTOKNOB
AddClass | AMIGAKEYS | AUTOLEFTEDGE
AddGadget | AMIGALEFT | AUTONEXTTEXT
AddGList | AMIGARIGHT | AutoRequest
ALERT_TYPE | ANTI_ALIAS | AUTOSCROLL
AllocRemember | ASPECT_HORIZ | AUTOTOPEDGE
AllocScreenBuffer | ASPECT_VERT | AWCODE_INTERIM
AlohaWorkbench | AUTOBACKPEN | AWCODE_NORMAL
ALPHA_P_101 | AUTODRAWMODE |

B

BACKGROUNDPEN | BMICTRL_GetOutlineBitMap | BMI_TileWidth
BARBLOCKPEN | BMICTRL_GetOutlineMap | BMS_DoMask
BARCONTOURPEN | BMICTRL_GetReferencePen | BMS_DoOutline
BARDETAILPEN | BMICTRL_GetScreen | BMS_DoShade
BARTRIMPEN | BMICTRL_GetShadeMaskBitMap | BMS_Dummy
BASEOBJECT | BMICTRL_GetShadowMap | BMS_NoDiskIO
BAUD_110 | BMICTRL_GetShineMap | BOOLMASK
BAUD_1200 | BMICTRL_GetTileBox | BOOPSIMENU
BAUD_19200 | BMICTRL_GetTileHeight | BOUNDED_DIMENSIONS
BAUD_2400 | BMICTRL_GetTileLeft | BROTHER_15XL
BAUD_300 | BMICTRL_GetTileTop | BT_BACKGROUND
BAUD_4800 | BMICTRL_GetTileWidth | BT_DIRECTSHADE
BAUD_9600 | BMICTRL_GetWidth | BT_DRIPEN
BAUD_MIDI | BMICTRL_SetGradientSpec | BT_FLAGSMASK
BEEPING_F | BMICTRL_SetOffsets | BT_GADGET
BeginRefresh | BMICTRL_SetReferencePen | BT_MENU
BitMapInstanceControlA | BMICTRL_SetTileHeight | BT_OFFSETRECT
BLOCKPEN | BMICTRL_SetTileLeft | BT_PROPBG
BMI_CacheGradient | BMICTRL_SetTileTop | BT_PROPKNOB
BMICTRL_Dummy | BMICTRL_SetTileWidth | BT_REQUESTERBG
BMICTRL_GetAlphaMap | BMI_DoLevels | BT_SCREENBAR
BMICTRL_GetBitMap | BMI_Dummy | BT_TABPAGE
BMICTRL_GetBitMapSource | BMI_Exclusive | BT_WINBORDER
BMICTRL_GetBrightBitMap | BMI_GradientAxis | BT_WINDOWBAR
BMICTRL_GetDarkBitMap | BMI_GradientSpec | BT_WINDOWBG
BMICTRL_GetGradientSpec | BMI_IgnoreDomain | BT_WINPROPBG
BMICTRL_GetHalfBrightBitMap | BMI_LayerInfo | BT_WINPROPKNOB
BMICTRL_GetHalfDarkBitMap | BMI_Offsets | BuildEasyRequestArgs
BMICTRL_GetHeight | BMI_ReferencePen | BuildSysRequest
BMICTRL_GetHook | BMI_TileHeight | BUTTONGCLASS
BMICTRL_GetMaskBitMap | BMI_TileLeft |
BMICTRL_GetOffsets | BMI_TileTop |

C

CBM_MPS1000 | CLICKTAB_ACTIVEPENHLTEXT | COMMSEQ
CENTER_IMAGE | CLICKTAB_ACTIVEPENMASK | COMMWIDTH
ChangeScreenBuffer | CLICKTAB_ACTIVEPENTEXT | CORRECT_BLUE
ChangeWindowBox | CLICKTAB_ACTIVEPENTITLE | CORRECT_GREEN
CHECKED | CLICKTAB_EVENWIDTH | CORRECT_RED
CHECKIMAGE | CLICKTAB_INACTIVEDARK | CORRECT_RGB_MASK
CHECKIT | CloseClass | CurrentTime
CHECKMARKIMAGE | CLOSEGADGET | CURSORDOWN
CHECKWIDTH | CloseGUIPlugin | CURSORLEFT
ClassID | CLOSEIMAGE | CURSORRIGHT
ClearDMRequest | CloseScreen | CURSORUP
ClearMenuStrip | CloseWindow | CUSTOMBITMAP_F
ClearPointer | CloseWorkBench | CUSTOM_HOOK
CLF_INLIST | CMENU_BOTTOM | CUSTOMIMAGEDEPTH
CLICKTAB_ACTIVEBOLD | CMENU_CENTER | CUSTOM_NAME
CLICKTAB_ACTIVEBRIGHT | CMENU_CENTER_MOUSE | CUSTOM_PAPER
CLICKTAB_ACTIVEFILLFILL | CMENU_RIGHT | CUSTOMSCREEN_F
CLICKTAB_ACTIVEFILLGRAD | CM_QUERY | CWCODE_DEPTH
CLICKTAB_ACTIVEFILLMASK | CNTR_ABSOLUTE | CWCODE_MOVESIZE
CLICKTAB_ACTIVEFILLNONE | CNTR_CORRECT | CYCLEIMAGE
CLICKTAB_ACTIVEFILLSELECT | CoerceMethod |
CLICKTAB_ACTIVEFILLSHINE | CoerceMethodA |

D

DEADEND_ALERT | DisableTemplateRGB | DRAFT
DEFAULTMOUSEQUEUE | DisplayAlert | DRAGGADGET
DEFERREFRESH | DisplayBeep | DrawBorder
DEPTHIMAGE | DisposeObject | DrawGradient
DETAILPEN | DITHERING_MASK | DrawImage
DEVNAME_SIZE | DMODECOUNT | DrawImageState
DIAB_630 | DoGadgetMethodA | DrawSysImageA
DIAB_ADV_D25 | DoMethod | DRIF_NEWDISABLE
DIAB_C_150 | DoMethodA | DRIF_NEWLOOK
DIMENSIONS_MASK | DoRender | DRIF_REALSHADE
DirectionVector | DoScrollHook | DRIPENS_IGNORE
DISABLEDPEN | DoSuperMethod | DRI_VERSION
DISABLEDSHADOWPEN | DoSuperMethodA | DSHM_Jump
DISABLEDSHINEPEN | DoubleClick | DSHM_Smooth
DISABLEDTEXTPEN | DOWNBACKGADGET |
DisableTemplate | DOWNIMAGE |

E

EasyRequest | EO_REPLACECHAR | ESA_Position
EasyRequestArgs | EO_RESET | ESA_Underscore
EIGHT_LPI | EO_SPECIAL | ESF_EVENSIZE
ELITE | EO_UNDO | ESF_INACTIVE
EmbossDisableRect | EPSON | ESF_SCREEN
EmbossDisableText | EPSON_JX_80 | ESF_TAGGED
EndRefresh | EraseImage | ET_MENUHELP
EndRequest | ERROR_BAD_ACTION_ON_ITEM | ET_MENUPICK
EndScreenNotify | ERROR_BAD_ACTION_ON_MENU | EURO_A0
EO_BADFORMAT | ERROR_BAD_ACTION_ON_ROOT | EURO_A1
EO_BIGCHANGE | ERROR_BAD_ACTION_ON_SEPARATOR | EURO_A2
EO_CLEAR | ERROR_COMM_KEY_AT_TITLE_LEVEL | EURO_A3
EO_DELBACKWARD | ERROR_ITEM_ID_IS_ZERO | EURO_A4
EO_DELFORWARD | ERROR_ITEM_WITHOUT_ID | EURO_A5
EO_ENTER | ERROR_SEPARATOR_AT_TITLE_LEVEL | EURO_A6
EO_INSERTCHAR | ERROR_SUBITEMS_WITHOUT_PARENT | EURO_A7
EO_MOVECURSOR | ERROR_TITLE_OUT_OF_PLACE | EURO_A8
EO_NOOP | ESA_Dummy | EVENTMAX

F

FANFOLD_PT | FRAMEDISCOL_DISAB | FRAMESELCOL_SELECT
FILENAME_SIZE | FRAMEDISCOL_FOREG | FRAMESTRING_3D
FILLFLATPEN | FRAME_DISPLAY | FRAMESTRING_FLAT
FILLPEN | FRAMEDISPLAY_3D | FRAMESTRING_FRAMED
FILLRECTCLASS | FRAMEDISPLAY_FLAT | FRAMESTRING_FRAMED2
FILLSHADOWPEN | FRAMEDISPLAY_FRAMED | FRAMETHIN_EDGESONLYRAISED
FILLSHINEPEN | FRAMEDISPLAY_FRAMED2 | FRAMETHIN_EDGESONLYRECESSED
FILLTEXTPEN | FRAMEF_SPECIFY | FRAMETHIN_FILLEDRAISED
FindClass | FRAMEICLASS | FRAMETHIN_FILLEDRECESSED
FindMenuKey | FRAME_ICONDROPBOX | FRAMEWINDOW_3D
FINE | FRAMEPRESSED_INVERTED | FRAMEWINDOW_FLAT
FLATBORDERPEN | FRAMEPRESSED_PUSHED | FRAMEWINDOW_FRAMED
FLOYD_DITHERING | FRAMEPROP_3D | FRBUTTONCLASS
FOREGROUNDPEN | FRAME_PROPBORDER | FreeClass
FORESHADOWPEN | FRAMEPROP_FLAT | FREEHORIZ
FORESHINEPEN | FRAMEPROP_FRAMED | FreeRemember
FRAME_BUTTON | FRAME_PROPKNOB | FreeScreenBuffer
FRAMEBUTTON_3D | FRAMEPROP_NONE | FreeScreenDrawInfo
FRAMEBUTTON_FLAT | FRAME_RIDGE | FreeSysRequest
FRAMEBUTTON_FRAMED | FRAMESELCOL_BACKG | FREEVERT
FRAME_DEFAULT | FRAMESELCOL_FILL | FULLMENUNUM
FRAMEDISCOL_BACKG | FRAMESELCOL_FOREG |

G

GA_ActivateKey | GFLG_LABELSTRING | GUIA_FrameDisabledColors
GA_BackFill | GFLG_RELBOTTOM | GUIA_FrameDisBackfill
GA_Border | GFLG_RELHEIGHT | GUIA_FrameDisplayLook
GA_BottomBorder | GFLG_RELRIGHT | GUIA_FrameForceThinEdges
GA_Bounds | GFLG_RELSPECIAL | GUIA_FramePressedLook
GA_ContextMenu | GFLG_RELWIDTH | GUIA_FramePropLook
GACT_ACTIVEGADGET | GFLG_SELECTED | GUIA_FrameSelBackfill
GACT_ALTKEYMAP | GFLG_STRINGEXTEND | GUIA_FrameSelectedColor
GACT_BOOLEXTEND | GFLG_TABCYCLE | GUIA_FrameStringLook
GACT_BORDERSNIFF | GGF_BOUNDED | GUIA_GadgetArrowStyle
GACT_BOTTOMBORDER | GGF_CALCHSCROLLER | GUIA_GadgetArrowType
GACT_ENDGADGET | GGF_CALCHSOVERLAP | GUIA_GadgetCycleStyle
GACT_FOLLOWMOUSE | GGF_CALCVSCROLLER | GUIA_GadgetCycleType
GACT_IMMEDIATE | GGF_CALCVSOVERLAP | GUIA_GadgetGeometry
GACT_LEFTBORDER | GGF_INITIAL | GUIA_GadgetHorizPadding
GACT_LONGINT | GGPF_SCREENDRAGGING | GUIA_GadgetStyle
GACT_RELVERIFY | GHKHANDLEIMAGE | GUIA_GadgetTextAttr
GACT_RIGHTBORDER | GLEFTIMAGE | GUIA_GadgetVertPadding
GACT_STRINGCENTER | GLYPHFILLPEN | GUIA_GaugeLook
GACT_STRINGEXTEND | GLYPHPEN | GUIA_GlobalFlags
GACT_STRINGLEFT | GM_DOMAIN | GUIA_GroupLabelLook
GACT_STRINGRIGHT | GM_Dummy | GUIA_GroupLabelPlace
GACT_TOGGLESELECT | GM_EXTENT | GUIA_GroupLabelTextAttr
GACT_TOPBORDER | GM_GOACTIVE | GUIA_GroupLabelVertAlign
GadgetBox | GM_GOINACTIVE | GUIA_InactiveFillBrightContrast
GADGET_BOX | GM_HANDLEINPUT | GUIA_InactiveFillBrightCurve
GADGETCLASS | GM_HANDLESCROLL | GUIA_InactiveFillDarkContrast
GADGETCOUNT | GM_HELPTEST | GUIA_InactiveFillDarkCurve
GadgetMouse | GM_HITTEST | GUIA_LabelTextAttr
GADGETPEN | GM_KEYGOACTIVE | GUIA_LayoutHorizSpacing
GA_Disabled | GM_KEYGOINACTIVE | GUIA_LayoutVertSpacing
GA_DoLayout | GM_KEYTEST | GUIA_ListHierConnectType
GA_DrawInfo | GM_LAYOUT | GUIA_ListHierNodeStyle
GA_Dummy | GM_MENUHELP | GUIA_MenuBackfill
GA_EndGadget | GM_MENUPICK | GUIA_MenuBrightContrast
GA_FollowMouse | GMORE_BOUNDS | GUIA_MenuBrightCurve
GA_GadgetHelp | GMORE_GADGETHELP | GUIA_MenuCloseDelay
GA_GadgetHelpText | GMORE_HIDDEN | GUIA_MenuDarkContrast
GA_GZZGadget | GMORE_NOCMENUOFFLOAD | GUIA_MenuDarkCurve
GA_Height | GMORE_NOFILTERMENUKEYS | GUIA_MenuDropShadows
GA_Hidden | GMORE_NOFILTERWHEEL | GUIA_MenuFlags
GA_Highlight | GMORE_PRIVATE | GUIA_MenuOpenDelay
GA_HintInfo | GMORE_PRIVATE2 | GUIA_MenuRenderHook
GA_ID | GMORE_SCROLLRASTER | GUIA_MenuSelItemFrame
GA_Image | GM_POSTRENDER | GUIA_MenuStyle
GA_Immediate | GM_PRERENDER | GUIA_MenuTransparency
GA_IntuiText | GMQ_CONTEXTMENU | GUIA_MenuTransparencyLevel
GA_LabelImage | GMQ_HINTINFO | GUIA_MenuType
GA_Left | GM_QUERY | GUIA_OffScreenDragging
GA_LeftBorder | GMQ_WHICHMEMBER | GUIA_OffScreenResistance
GA_Next | GMR_CLIPDONE | GUIA_OffScreenSizing
GA_NoFilterMenuKeys | GM_RENDER | GUIA_PaletteLockTable
GA_NoFilterWheel | GMR_FULLBBOX | GUIA_PaletteRGBTable
GA_Previous | GMR_FULLHBOX | GUIA_PropBackfill
GA_ReadOnly | GMR_GADGETHIT | GUIA_PropBackground
GA_RelBottom | GMR_HELPCODE | GUIA_PropBorder
GA_RelHeight | GMR_HELPHIT | GUIA_PropKnobBackfill
GA_RelRight | GMR_INVALID | GUIA_PropKnobColor
GA_RelSpecial | GMR_KEYACTIVATE | GUIA_PropKnobHandle
GA_RelVerify | GMR_KEYACTIVE | GUIA_PropKnobHighlight
GA_RelWidth | GMR_KEYVERIFY | GUIA_PropOuterSpacing
GA_RightBorder | GMR_MASKDONE | GUIA_PropSelKnobBackfill
GA_Selected | GMR_MEACTIVE | GUIA_PropSpacing
GA_SelectRender | GMR_NEXTACTIVE | GUIA_RealShading
GA_SpecialInfo | GMR_NOHELPHIT | GUIA_RequesterBackfill
GA_SysGadget | GMR_NOREUSE | GUIA_RequestersPosition
GA_SysGType | GMR_PREVACTIVE | GUIA_Reserved1
GA_TabCycle | GMR_REUSE | GUIA_Reserved2
GA_Text | GMR_VERIFY | GUIA_Reserved3
GA_TextAttr | GPEF_ALLOWSUPER | GUIA_Reserved4
GA_Titlebar | GRADMODE_COLOR | GUIA_Reserved5
GA_ToggleSelect | GRADMODE_IMPOSE | GUIA_ScreenBarBackfill
GA_Top | GRADMODE_INVERT1 | GUIA_ScreenBarGadgetSize
GA_TopBorder | GRADMODE_INVERT2 | GUIA_ScreenBarPadding
GAUGE_BORDERPENS | GRADMODE_KEEPRATIO | GUIA_ScreenBarShadowColor
GAUGE_CONT_3D | GRADMODE_NONE | GUIA_ScreenBarShadowDisplacement
GAUGE_CONT_AUTOSTYLE | GRADMODE_PALETTE | GUIA_ScreenBarShadowSmoothness
GAUGE_CONT_BORDERLESS | GRADMODE_SHADE | GUIA_ScreenBarShadowStrength
GAUGE_CONT_FLAT | GRADMODE_SIMPLE | GUIA_ScreenDragging
GAUGE_CONT_FRAMED | GRADMODE_TYPEMASK | GUIA_ScreenTitlePosition
GAUGE_CONT_FRAMED2 | GREDRAW_REDRAW | GUIA_SelectBrightContrast
GAUGE_CONT_GRADIENT | GREDRAW_TOGGLE | GUIA_SelectBrightCurve
GAUGE_CONT_STYLEMASK | GREDRAW_UPDATE | GUIA_SelectDarkContrast
GAUGE_FILL_3D | GREY_SCALE2 | GUIA_SelectDarkCurve
GAUGE_FILL_AUTOSTYLE | GRIGHTIMAGE | GUIA_ShareComposeBitMap
GAUGE_FILL_BORDERLESS | GROUPGCLASS | GUIA_SizeGadgetHeight
GAUGE_FILL_FLAT | GTYP_BOOLGADGET | GUIA_SizeGadgetWidth
GAUGE_FILL_FRAMED | GTYP_CLOSE | GUIA_SliderDisplayMode
GAUGE_FILL_GRADIENT | GTYP_CUSTOMGADGET | GUIA_SpecialEffects
GAUGE_FILL_STYLEMASK | GTYP_GADGET0002 | GUIA_SysIGeometryType
GAUGEIA_InnerTicks | GTYP_GADGETTYPE | GUIA_SysImageFrameType
GAUGEIA_Level | GTYP_GTYPEMASK | GUIA_SysImageSymbolType
GAUGEIA_Max | GTYP_GZZGADGET | GUIA_TabActiveBackfill
GAUGEIA_Min | GTYP_PROPGadget | GUIA_TabInactiveBackfill
GAUGEIA_ScaleHook | GTYP_REQGADGET | GUIA_TabTitleBackfill
GAUGEIA_ShortTicks | GTYP_SCRGADGET | GUIA_VSyncCompose
GAUGEIA_Ticks | GTYP_SDEPTH | GUIA_WindowAlpha
GAUGEIA_TickSize | GTYP_SDOWNBACK | GUIA_WindowBackfill
GAUGE_INNERTICKS | GTYP_SDRAGGING | GUIA_WindowBarBackfill
GAUGE_RESERVED | GTYP_SIZING | GUIA_WindowBarFrameThickness
GAUGE_SPACINGMASK | GTYP_STRGADGET | GUIA_WindowBarGadgetSize
GAUGE_UNUSED | GTYP_SUNUSED | GUIA_WindowBarInactBackfill
GA_Underscore | GTYP_SUPFRONT | GUIA_WindowBarPadding
GA_UserData | GTYP_SYSGADGET | GUIA_WindowBorderBackfill
GA_UserInput | GTYP_SYSTYPEMASK | GUIA_WindowBorderBottom
GA_Width | GTYP_TBARGADGET | GUIA_WindowBorderInactBackfill
GBD_BOX | GTYP_WDEPTH | GUIA_WindowBorderLeft
GBD_GINFO | GTYP_WDOWNBACK | GUIA_WindowBorderLook
GBD_RECTANGLE | GTYP_WDRAGGING | GUIA_WindowBorderRight
GBD_WINDOW | GTYP_WUPFRONT | GUIA_WindowBorderStyle
GBF_BOUNDS | GTYP_WZOOM | GUIA_WindowBorderTop
GBF_MAKERECT | GUIA_ArrowGadgetHeight | GUIA_WindowCloseFadeTime
GCB_OK | GUIA_ArrowGadgetWidth | GUIA_WindowDragAlpha
GCB_UNKNOWN | GUIA_AutomaticEdgesContrast | GUIA_WindowFrameThickness
GDOMAIN_MAXIMUM | GUIA_BarBlockBrightContrast | GUIA_WindowGadgetFrameStyle
GDOMAIN_MINIMUM | GUIA_BarBlockBrightCurve | GUIA_WindowGadgetGeometry
GDOMAIN_NOMINAL | GUIA_BarBlockDarkContrast | GUIA_WindowGadgetStyle
GDOWNIMAGE | GUIA_BarBlockDarkCurve | GUIA_WindowGaugeLook
GetAttr | GUIA_BrightContrast | GUIA_WindowGoActiveFadeTime
GetAttrsA | GUIA_BrightCurve | GUIA_WindowGoInactiveFadeTime
GetDefaultPubScreen | GUIA_ClearBackground | GUIA_WindowInactAlpha
GetDefPrefs | GUIA_ClickTabLook | GUIA_WindowInnerFlatThickness
GetGUIAttrsA | GUIA_CycleLabelJustify | GUIA_WindowOpenFadeTime
GetHalfPens | GUIA_CycleLook | GUIA_WindowOuterFlatThickness
GetMarkedBlock | GUIA_DarkContrast | GUIA_WindowPropBackfill
GetPrefs | GUIA_DarkCurve | GUIA_WindowPropBackground
GetRenderDomain | GUIA_DefaultDRIPens | GUIA_WindowPropBorder
GetScreenAttr | GUIA_DefaultGeometry | GUIA_WindowPropInactBackfill
GetScreenAttrsA | GUIA_DefaultStyle | GUIA_WindowPropInactKnobBackfill
GetScreenData | GUIA_DisabledBrightContrast | GUIA_WindowPropKnobBackfill
GetScreenDrawInfo | GUIA_DisabledBrightCurve | GUIA_WindowPropKnobColor
GetWindowAttr | GUIA_DisabledDarkContrast | GUIA_WindowPropKnobHandle
GetWindowAttrsA | GUIA_DisabledDarkCurve | GUIA_WindowPropKnobHighlight
GEXTENT_ADD | GUIA_DRIPens | GUIA_WindowPropLook
GEXTENT_INVERT | GUIA_Dummy | GUIA_WindowPropSelKnobBackfill
GEXTENT_REMOVE | GUIA_EvenRequesterButtons | GUIA_WindowPropSpacing
GEXTENT_SECT | GUIA_FallbackTextAttr | GUIA_WindowRefresh
GFLG_DISABLED | GUIA_FillBrightContrast | GUIA_WindowReserved
GFLG_EXTENDED | GUIA_FillBrightCurve | GUIA_WindowShadowColor
GFLG_GADGHBOX | GUIA_FillDarkContrast | GUIA_WindowShadowDisplacement
GFLG_GADGHCOMP | GUIA_FillDarkCurve | GUIA_WindowShadowSizes
GFLG_GADGHIGHBITS | GUIA_ForeBrightContrast | GUIA_WindowShadowSmoothness
GFLG_GADGHIMAGE | GUIA_ForeBrightCurve | GUIA_WindowShadowStrength
GFLG_GADGHNONE | GUIA_ForeDarkContrast | GUIA_WindowShadowType
GFLG_GADGIMAGE | GUIA_ForeDarkCurve | GUIA_WindowSizeBorder
GFLG_IMAGEDISABLE | GUIA_FrameAlphaStatus | GUIA_WindowTitlePosition
GFLG_LABELIMAGE | GUIA_FrameBackfill | GUPIMAGE
GFLG_LABELITEXT | GUIA_FrameButtonLook | GVKHANDLEIMAGE
GFLG_LABELMASK | GUIA_FrameCornersType |

H

HALFSHADOWPEN | HIGHBOX | HIGHNONE
HALFSHINEPEN | HIGHCOMP | HIRESGADGET
HALFTONE_DITHERING | HIGHFLAGS | HIRESPICK
HC_GADGETHELP | HIGHIMAGE | HKHANDLEIMAGE
HelpControl | HIGHITEM | HP_LASERJET
HideWindow | HIGHLIGHTTEXTPEN | HP_LASERJET_PLUS

I

IA_ActivateKey | IDCMP_IDCMPUPDATE | IJ_CENTER
IA_APatSize | IDCMP_INACTIVEWINDOW | IJ_LEFT
IA_APattern | IDCMP_INTUITICKS | IJ_RIGHT
IA_BackFill | IDCMP_LONELYMESSAGE | IMAGECLASS
IA_BGPen | IDCMP_MENUHELP | IMAGE_NEGATIVE
IA_Data | IDCMP_MENUPICK | IMAGE_POSITIVE
IA_DisabledBackFill | IDCMP_MENUVERIFY | IM_BGPEN
IA_DoubleEmboss | IDCMP_MOUSEBUTTONS | IM_BOX
IA_Dummy | IDCMP_MOUSEMOVE | IM_DOMAINFRAME
IA_EdgesOnly | IDCMP_NEWPREFS | IM_DRAW
IA_EraseBackground | IDCMP_NEWSIZE | IM_DRAWFRAME
IA_FGPen | IDCMP_RAWKEY | IM_ERASE
IA_Font | IDCMP_REFRESHWINDOW | IM_ERASEFRAME
IA_FrameType | IDCMP_REQCLEAR | IM_EXTENT
IA_Height | IDCMP_REQSET | IM_EXTENTFRAME
IA_HighlightPen | IDCMP_REQVERIFY | IM_FGPEN
IA_InactiveBackFill | IDCMP_RESERVED1 | IM_FRAMEBOX
IA_InBorder | IDCMP_RESERVED2 | IM_HITFRAME
IA_Justification | IDCMP_SIZEVERIFY | IM_HITTEST
IA_Label | IDCMP_VANILLAKEY | IM_MOVE
IA_LabelPen | IDCMP_WBENCHMESSAGE | IMPF_ALLOWSUPER
IA_Left | IDOMAIN_MAXIMUM | IMR_CLIPDONE
IA_LineWidth | IDOMAIN_MINIMUM | IMR_INVALID
IA_Mode | IDOMAIN_NOMINAL | IMR_MASKDONE
IA_Orientation | IDoMethodA | IMSGCODE_INTUIRAWKEYDATA
IA_Outline | IDoSuperMethodA | IMSGCODE_INTUIWHEELDATA
IA_Pens | IDS_BUSY | IMTAG_Dummy
IA_Precision | IDS_DISABLED | IMTAG_MenuContext
IA_Recessed | IDSF_DISABLED | IMTAG_MenuType
IA_Resolution | IDSF_DISABLEDMASK | IMT_CONTEXT_GADGET_APP
IA_Scalable | IDSF_ERASEMASK | IMT_CONTEXT_GADGET_OBJ
IA_Screen | IDSF_INACTIVENORMAL | IMT_CONTEXT_WINDOW
IA_SelectedBackFill | IDSF_INACTIVESELECTED | IMT_DEFAULT
IA_ShadowPen | IDSF_MASK | INACTIVEFILLFLATPEN
IA_Simple | IDSF_NORMAL | INACTIVEFILLPEN
IA_SupportsDisable | IDSF_SELDISABLEDMASK | INACTIVEFILLSHADOWPEN
IA_Top | IDSF_SELECTED | INACTIVEFILLSHINEPEN
IA_Underscore | IDSF_SELECTEDDISABLED | INACTIVEFILLTEXTPEN
IA_Width | IDS_INACTIVEDISABLED | INACTIVEGLYPHPEN
ICA_Dummy | IDS_INACTIVENORMAL | InitRequester
ICA_MAP | IDS_INACTIVESELECTED | INST_DATA
ICA_TARGET | IDS_INDETERMINANT | INTEGER_SCALING
ICCLASS | IDS_INDETERMINATE | INTUIRAWKEYDATA_VERSION
ICM_CHECKLOOP | IDS_NORMAL | IntuiTextExtent
ICM_CLEARLOOP | IDS_SELECTED | IntuiTextLength
ICM_Dummy | IDS_SELECTEDDISABLED | Intuition_
ICM_SETLOOP | IEXTENT_ADD | IntuitionBase
ICoerceMethodA | IEXTENT_INVERT | IntuitionClone
ICONIFYIMAGE | IEXTENT_REMOVE | IntuitionControlA
ICSPECIAL_CODE | IEXTENT_SECT | IntuitionExpunge
ICTARGET_IDCMP | IGF_BRCORN | INTUITIONNAME
ICTRL_Dummy | IGF_HORIZARROW | IntuitionObtain
IDCMP_ACTIVEWINDOW | IGF_KEEPHEIGHT | IntuitionRelease
IDCMP_CHANGEWINDOW | IGF_KEEPLEFT | INTUIWHEELDATA_VERSION
IDCMP_CLOSEWINDOW | IGF_KEEPTOP | ISDRAWN
IDCMP_DELTAMOVE | IGF_KEEPWIDTH | ISetSuperAttrsA
IDCMP_DISKINSERTED | IGF_SBARLEFT | ItemAddress
IDCMP_DISKREMOVED | IGF_SBARRIGHT | ITEMENABLED
IDCMP_EXTENDEDKEYBOARD | IGF_VERTARROW | ITEMNUM
IDCMP_EXTENDEDMOUSE | IGF_WBARLEFT | ITEMTEXT
IDCMP_GADGETDOWN | IGF_WBARRIGHT | ITEXTICLASS
IDCMP_GADGETHELP | IGNORE_DIMENSIONS |
IDCMP_GADGETUP | IIntuition |

K

KEYCODE_B | KEYCODE_N | KNOBHIT
KEYCODE_GREATER | KEYCODE_Q | KNOBHMIN
KEYCODE_LESS | KEYCODE_V | KNOBVMIN
KEYCODE_M | KEYCODE_X |

L

LACEWB | LEVEL_DARK | LockScreenList
LAYOUTA_ChildMaxHeight | LEVEL_HALFBRIGHT | LORIENT_HORIZ
LAYOUTA_ChildMaxWidth | LEVEL_HALFDARK | LORIENT_NONE
LAYOUTA_Dummy | LEVEL_NORMAL | LORIENT_VERT
LAYOUTA_LayoutObj | LockClassList | LOWCHECKWIDTH
LAYOUTA_Orientation | LockGUIPrefs | LOWCOMMWIDTH
LAYOUTA_Spacing | LockIBase | LOWRESGADGET
LEFTIMAGE | LockPubScreen | LOWRESPICK
LendMenus | LockPubScreenList | LW_RESERVED
LETTER | LockScreen |
LEVEL_BRIGHT | LockScreenGI |

M

MA_AddChild | MA_Toggle | MENUTRANSP
MA_Catalog | MA_Type | MENUUP
MA_CharSet | MA_UserData | MENUWAITING
MA_Disabled | MAXBODY | MIDDLEDOWN
MA_Dummy | MAXPOT | MIDDLEUP
MA_EmbeddedKey | MAXPUBSCREENNAME | ML_SEPARATOR
MA_ErrorCode | MENUALTERN | MM_CLEANUP
MA_ErrorTagItem | MENUBACKGROUNDPEN | MM_DELETEMENU
MA_EvenSize | MENUCANCEL | MM_FINDID
MA_FreeImage | MENUCHECK | MM_GETSTATE
MA_HelpHook | MENUCMCORNER | MM_HANDLEHELP
MA_Hidden | MENUDOWN | MM_HANDLEPICK
MA_ID | MENUENABLED | MM_NEWMENU
MA_Image | MENUFLAT | MM_NEXTCHILD
MakeClass | MENUFRAMED | MM_NEXTSELECT
MakeScreen | MENUHOT | MM_SCAN
MA_Key | MENUMX | MM_SETSTATE
MA_Label | MENUNBPD | MM_SETUP
MA_LastSelected | MENUNBPU | MODELCLASS
MA_Level | MENUNULL | ModifyIDCMP
MA_MaxStringID | MENUNUM | ModifyProp
MA_MenuHelpID | MENUPDTCLDEL | MOUSE_ACCEL
MA_MenuPosX | MENUPDTOPDEL | MoveScreen
MA_MenuPosY | MENUSHADOW | MoveWindow
MA_MinStringID | MENUSHADOWPEN | MoveWindowInFrontOf
MA_MX | MENUSHINEPEN | MS_CHECKED
MA_Parent | MENUSTICKYPD | MS_DISABLED
MA_PickHook | MENUSTICKYPU | MT_POPUP
MA_RemoveChild | MENUSUB | MT_PULLDOWN
MA_Selected | MENUTEXTPEN | MT_RELATIVE
MA_Separator | MENUTOGGLE | MULTIPLY_DIMENSIONS
MA_StringHook | MENUTOGGLED | MXIMAGE
MA_TextAttr | MENUTRACK |

N

NewModifyProp | NM_SubItems | NSCODE_INTERIM
NewObject | NOISYREQ | NS_EXTENDED
NewObjectA | NOITEM | NSTAG_EXT_VPMODE
NextObject | NOMENU | N_TRACTOR
NextPubScreen | NO_MENU_ID | NUMDRIPENS
NM_Dummy | NOREQBACKFILL | _OBJ
NM_Item | NOSUB | __OBJECT
NM_Menu | NSCODE_FINAL |

O

LongWord | OM_NEW | OPUF_INTERIM
ObtainBitMapInstanceA | OM_NOTIFY | ORDERED_DITHERING
ObtainBitMapSourceA | OM_REMMEMBER | OSCAN_MAX
ObtainGIRPort | OM_REMOVE | OSCAN_STANDARD
ObtainIBackFill | OM_SET | OSCAN_TEXT
ObtainIPluginList | OM_UPDATE | OSCAN_VIDEO
OCLASS | OnGadget | OSERR_ATTACHFAIL
OffGadget | OnMenu | OSERR_BADBITMAP
OffMenu | OpenClass | OSERR_NOCHIPMEM
OKABORT | OpenGUIPlugin | OSERR_NOCHIPS
OKCANCEL | OpenIntuition | OSERR_NOMEM
OKIMATE_20 | OpenScreen | OSERR_NOMONITOR
OKOK | OpenScreenTagList | OSERR_NOTAVAILABLE
OM_ADDMEMBER | OpenScreenTags | OSERR_PUBNOTUNIQUE
OM_ADDTAIL | OpenWindow | OSERR_TOODEEP
OM_DISPOSE | OpenWindowTagList | OSERR_UNKNOWNMODE
OM_Dummy | OpenWindowTags |
OM_GET | OpenWorkBench |

P

PADLOCKIMAGE | PimpHitTest | POINTERTYPE_ROWRESIZE
PA_INTERNAL | PIntuiMessage | POINTERTYPE_RUBBER
PALETTELOCK_IGNORE | PIntuiRawKeyData | POINTERTYPE_SCROLLALL
PALETTERGB_IGNORE | PIntuiText | POINTERTYPE_SELECT
PARALLEL_PRINTER | PIntuitionBase | POINTERTYPE_SMUDGE
PBoolInfo | PIntuiWheelData | POINTERTYPE_SOUTHEASTRESIZE
PBorder | PIXEL_DIMENSIONS | POINTERTYPE_SOUTHRESIZE
PClassLibrary | PLUGIN_SYSI | POINTERTYPE_SOUTHWESTRESIZE
PColorSpec | PMenu | POINTERTYPE_TEXT
PContextMenuMsg | PMenuEventMessage | POINTERTYPE_VERTICALTEXT
PDrawInfo | PMenuItem | POINTERTYPE_WESTRESIZE
PEasyStruct | PMenuScanMessage | POINTERTYPE_ZOOMIN
PEN_ALPHA | PMenuStringMessage | POINTERTYPE_ZOOMOUT
PEN_ALPHASHADOW | PmpDeleteMenu | POINTERXRESN_140NS
PEN_ALPHASHINE | PmpFindID | POINTERXRESN_35NS
PEN_BRIGHT | PmpGetState | POINTERXRESN_70NS
PEN_C0 | PmpHandleEvent | POINTERXRESN_DEFAULT
PEN_C1 | PmpNewMenu | POINTERXRESN_HIRES
PEN_C2 | PmpNextChild | POINTERXRESN_LORES
PEN_C3 | PmpNextSelect | POINTERXRESN_SCREENRES
PEN_DARK | PmpScan | POINTERYRESN_DEFAULT
PEN_HALFBRIGHT | PmpSetState | POINTERYRESN_HIGH
PEN_HALFDARK | PmpSetup | POINTERYRESN_HIGHASPECT
PENSHARED | PMsg | POINTERYRESN_SCREENRES
PExtGadget | PNewScreen | POINTERYRESN_SCREENRESASPECT
PExtIntuiMessage | PNewWindow | PointInImage
PExtNewScreen | P_Object | POINTREL
PExtNewWindow | PObject_ | PopAddTail
PGA_ArrowDelta | POINTERA_BitMap | PopGet
PGA_ArrowDown | POINTERA_Dummy | PopMember
PGA_Borderless | POINTERA_Height | POPPUBSCREEN
PGadget | POINTERA_ImageData | PopSet
PGadgetGeometryMsg | POINTERA_Width | PopUpdate
PGadgetInfo | POINTERA_WordWidth | POPUPIMAGE
PGA_Dummy | POINTERA_XOffset | PPGX
PGA_Freedom | POINTERA_XResolution | PPObject_
PGA_HorizBody | POINTERA_YOffset | PPreferences
PGA_HorizPot | POINTERA_YResolution | PPropInfo
PGA_NewLook | POINTERCLASS | PPubScreenNode
PGA_Top | POINTERSIZE | PREDRAWN
PGA_Total | POINTERTYPE_ALIAS | PRemember
PGA_VertBody | POINTERTYPE_BUSY | PRenderMsg
PGA_VertPot | POINTERTYPE_CELL | PRequester
PGA_Visible | POINTERTYPE_COLUMNRESIZE | PrintEmbossedDisabledIText
PgpDomain | POINTERTYPE_CONTEXTMENU | PrintIText
PgpExtent | POINTERTYPE_COPY | PROPBORDERLESS
PgpGoInactive | POINTERTYPE_COUNT | PROPGCLASS
PgpHitTest | POINTERTYPE_CROSS | PROPNEWLOOK
PgpInput | POINTERTYPE_DRAGANDDROP | PScreen
PgpKeyGoInactive | POINTERTYPE_EASTRESIZE | PScreenBuffer
PgpKeyInput | POINTERTYPE_EASTWESTRESIZE | PScreenNotifyMessage
PgpKeyTest | POINTERTYPE_HAND | PScrollHook
PgpLayout | POINTERTYPE_HELP | PScrollMsg
PgpMenuEvent | POINTERTYPE_LINK | PSGWork
PgpQuery | POINTERTYPE_MENU | PSNF_PRIVATE
PgpRender | POINTERTYPE_NODROP | PStringExtend
PGradientSpec | POINTERTYPE_NONE | PStringInfo
PGUIPlugin | POINTERTYPE_NORMAL | PSubStyle
PIBox | POINTERTYPE_NORTHEASTRESIZE | PSysIPlugin
PICA | POINTERTYPE_NORTHEASTSOUTHWESTRESIZE | PTabletData
PIClass | POINTERTYPE_NORTHRESIZE | PTabletHookData
PImage | POINTERTYPE_NORTHSOUTHRESIZE | PTBGadgetData
PImageGeometryMsg | POINTERTYPE_NORTHWESTRESIZE | PUBLICSCREEN_F
PimpDomainFrame | POINTERTYPE_NORTHWESTSOUTHEASTRESIZE | PubScreenStatus
PimpDraw | POINTERTYPE_NOTALLOWED | PVector
PimpErase | POINTERTYPE_PEN | PVectorInfo
PimpExtent | POINTERTYPE_PROGRESS | PWindow
PimpFrameBox | POINTERTYPE_ROTATE |

Q

QueryOverscan QUME_LP_20

R

RCB_OK | ReleaseIPluginList | REQPOS_CENTERSCREEN
RCB_UNKNOWN | RemakeDisplay | REQPOS_CENTERWINDOW
RECOVERY_ALERT | RemoveClass | REQPOS_CORNER
RefreshGadgets | RemoveGadget | REQPOS_DEFAULT
RefreshGList | RemoveGList | Request
RefreshSetGadgetAttrsA | ReportMouse | RESCOUNT
RefreshWindowFrame | ReportMouse1 | RESERVEDPEN
ReleaseBitMapInstance | REQACTIVE | ResetMenuStrip
ReleaseBitMapSource | REQOFFWINDOW | RethinkDisplay
ReleaseGIRPort | REQPOS_BELOWBAR | RIGHTIMAGE
ReleaseIBackFill | REQPOS_CENTERMOUSE | ROOTCLASS

S

SA_ActiveWindow | SetAttrs | SNOTIFY_BEFORE_OPENSCREEN
SA_AutoScroll | SetAttrsA | SNOTIFY_BEFORE_OPENWB
SA_BackChild | SetDefaultPubScreen | SNOTIFY_BEFORE_OPENWINDOW
SA_BackFill | SetDisplayBeepHook | SNOTIFY_LOCKPUBSCREEN
SA_Behind | SetDMRequest | SNOTIFY_PUBSCREENSTATE
SA_BitMap | SetEditHook | SNOTIFY_SCREENDEPTH
SA_BlockPen | SetGadgetAttrs | SNOTIFY_UNLOCKPUBSCREEN
SA_ColorMapEntries | SetGadgetAttrsA | SNOTIFY_WAIT_REPLY
SA_Colors | SetGUIAttrsA | SORTASCIMAGE
SA_Colors32 | SetIPrefs | SORTDESIMAGE
SA_Compositing | SetMarkedBlock | SPA_GADGETGEOMETRY
SA_DClip | SetMenuStrip | SPA_GADGETSTYLE
SA_Depth | SetMouseQueue | SPA_MENUSTYLE
SA_DetailPen | SetPointer | SPARITY_BITS
SA_DisplayID | SetPrefs | SPARITY_EVEN
SA_Draggable | SetPubScreenModes | SPARITY_NONE
SA_Dummy | SetRenderDomain | SPARITY_ODD
SA_ErrorCode | SetScreenAttr | SPA_WINBFRAMESTYLE
SA_Exclusive | SetScreenAttrsA | SPA_WINBGADGEOMETRY
SA_Font | SetScreenBitMapInstance | SPA_WINBGADSTYLE
SA_FrontChild | SETTINGSIMAGE | SPA_WINBORDERSTYLE
SA_FullPalette | SetWindowAttr | SPOS_ABSOLUTE
SA_Height | SetWindowAttrsA | SPOS_FORCEDRAG
SA_Interleaved | SetWindowPointer | SPOS_MAKEVISIBLE
SA_Left | SetWindowPointerA | SPOS_RELATIVE
SA_LikeWorkbench | SetWindowTitles | SRA_DeltaX
SA_MaxWindowBox | SGA_BEEP | SRA_DeltaY
SA_MinimizeISG | SGA_END | SRA_DirectShade
SA_Obsolete1 | SGA_NEXTACTIVE | SRA_Domain
SA_OffScreenDragging | SGA_PREVACTIVE | SRA_Dummy
SA_Overscan | SGA_REDISPLAY | SRA_OffsetX
SA_Parent | SGA_REUSE | SRA_OffsetY
SA_Pens | SGA_USE | SRA_RefreshBG
SA_PubName | SG_DEFAULTMAXCHARS | SR_DRAW
SA_PubSig | SG_GADGETBOX | SR_DRAWALPHAMAP
SA_PubTask | SGH_CLICK | SR_DRAWDISMASK
SA_Quiet | SGH_KEY | SR_DRAWIMAGEFRAME
SA_Reserved | SG_IMAGEBOX | SR_DRAWLEVELMAP
SA_Reserved2 | SGM_CONTROL | SR_DRAWMASK
SA_Reserved3 | SGM_EXITHELP | SR_DRAWSELDISMASK
SA_SharePens | SGM_FIXEDFIELD | SR_DRAWSHADOWMAP
SA_ShowTitle | SGM_LONGINT | SR_DRAWSHINEMAP
SA_SysFont | SGM_NOCHANGE | SREAD_BITS
SA_Title | SGM_NOFILTER | SRF_HSCROLLERFRAME
SA_Top | SGM_NOWORKB | SRF_ISBITMAP
SA_Type | SGM_REPLACE | SRF_MONOCHROME
SA_VideoControl | SHADE_BW | SRF_VSCROLLERFRAME
SA_Width | SHADE_COLOR | SSTOP_BITS
SA_WindowDropShadows | SHADE_GREYSCALE | StartScreenNotifyTagList
SBARLOGO | ShadeRectA | STD_DISABLE_CONTRAST
SB_COPY_BITMAP | ShadeRectOld | STDSCREENHEIGHT
SB_SCREEN_BITMAP | SHADOWPEN | STDSCREENWIDTH
SBUF_1024 | SHANGHAI | STRGCLASS
SBUF_16000 | SHIFTITEM | STRINGA_ActivePens
SBUF_2048 | SHIFTMENU | STRINGA_AltKeyMap
SBUF_4096 | SHIFTSUB | STRINGA_Buffer
SBUF_512 | SHINEPEN | STRINGA_BufferPos
SBUF_8000 | ShowTitle | STRINGA_DispPos
SBUFSIZE_BITS | SHOWTITLE_F | STRINGA_Dummy
SC_ARROWGSTYLE | ShowWindow | STRINGA_EditHook
SC_CYCLEGSTYLE | SHSHAKE_BITS | STRINGA_EditModes
SC_GADGETGEOMETRY | SHSHAKE_NONE | STRINGA_ExitHelp
SC_GADGETSTYLE | SHSHAKE_RTS | STRINGA_FixedFieldMode
SC_GLOBALGEOMETRY | SHSHAKE_XON | STRINGA_Font
SC_GLOBALSTYLE | SI_BEGIN | STRINGA_Justification
SC_KHANDLESTYLE | SI_END | STRINGA_LongVal
SCLOSEIMAGE | SI_HPROPBACKGROUND | STRINGA_MarkedBlock
SC_MENUSTYLE | SIMPLEREQ | STRINGA_MaxChars
SCREENBEHIND_F | SINGLE_PT | STRINGA_NoFilterMode
ScreenDepth | SI_VPROPBACKGROUND | STRINGA_Pens
SCREEN_DRAG | SIX_LPI | STRINGA_ReplaceMode
SCREENHIRES | SIZEGADGET | STRINGA_TextVal
ScreenPosition | SIZEIMAGE | STRINGA_UndoBuffer
SCREENQUIET_F | SIZEOF_INSTANCE | STRINGA_WorkBuffer
SCREENSIMAGE | SizeWindow | StripIntuiMessages
ScreenToBack | SMA_Draw | SUBMENU
ScreenToFront | SMA_GetScrollerTop | SUBNUM
SCREENTYPE_F | SMA_RedrawAll | SUPFRONTGADGET
SCROLLERGCLASS | SMA_RepairDamage | SWRITE_BITS
ScrollWindowRaster | SMA_Scroll | SYSIA_BitMapCache
SC_WINBFRAMESTYLE | SNA_Hook | SYSIA_ContentsBox
SC_WINBGADGEOMETRY | SNA_MsgPort | SYSIA_Depth
SC_WINBGADSTYLE | SNA_Notify | SYSIA_DrawInfo
SC_WINBORDERSTYLE | SNA_Priority | SYSIA_FullFrame
SDEPTH_CHILDONLY | SNAPSHOTIMAGE | SYSIA_Label
SDEPTHIMAGE | SNA_PubName | SYSIA_Pens
SDEPTH_INFAMILY | SNA_SigBit | SYSIA_ReferenceFont
SDEPTH_TOBACK | SNA_SigTask | SYSIA_RenderHook
SDEPTH_TOFRONT | SNA_UserData | SYSIA_Size
SDOWNBACKGADGET | SNOTIFY_AFTER_CLOSESCREEN | SYSIA_VectorInfo
SDRAGGADGET | SNOTIFY_AFTER_CLOSEWB | SYSIA_Which
SELECTDOWN | SNOTIFY_AFTER_CLOSEWINDOW | SYSICLASS
SELECTPEN | SNOTIFY_AFTER_OPENSCREEN | SYSISIZE_HIRES
SELECTSHADOWPEN | SNOTIFY_AFTER_OPENWB | SYSISIZE_LOWRES
SELECTSHINEPEN | SNOTIFY_AFTER_OPENWINDOW | SYSISIZE_MEDRES
SELECTTEXTPEN | SNOTIFY_BEFORE_CLOSESCREEN | SysReqHandler
SELECTUP | SNOTIFY_BEFORE_CLOSEWB | SYSREQUEST
SERIAL_PRINTER | SNOTIFY_BEFORE_CLOSEWINDOW |

T

TABLETA_AngleX | TgpQuery | TNewScreen
TABLETA_AngleY | TgpRender | TNewWindow
TABLETA_AngleZ | TGradientSpec | T_Object
TABLETA_ButtonBits | TGUIPlugin | TopAddTail
TABLETA_Dummy | TIBox | TOPAZ_EIGHTY
TABLETA_InProximity | TIClass | TOPAZ_SIXTY
TABLETA_Pressure | TImage | TopGet
TABLETA_RangeZ | TImageGeometryMsg | TopMember
TABLETA_ResolutionX | TimedDisplayAlert | TopSet
TABLETA_ResolutionY | TimpDomainFrame | TopUpdate
TABLETA_TabletZ | TimpDraw | TPGX
TBFRAMEIMAGE | TimpErase | TPreferences
TBitMapInstance | TimpExtent | TPropInfo
TBitMapSource | TimpFrameBox | TPubScreenNode
TBoolInfo | TimpHitTest | TRemember
TBorder | TIntuiMessage | TRenderMsg
TClassLibrary | TIntuiRawKeyData | TRequester
TColorSpec | TIntuiText | T_ROOT
TContextMenuMsg | TIntuitionBase | TScreen
TDrawInfo | TIntuiWheelData | TScreenBuffer
TEasyStruct | T_ITEM | TScreenNotifyMessage
TExtGadget | TITLEPEN | TScrollHook
TExtIntuiMessage | TMenu | TScrollMsg
TExtNewScreen | T_MENU | TSGWork
TExtNewWindow | TMenuEventMessage | TStringExtend
TEXTPEN | TMenuItem | TStringInfo
TGadget | TMenuScanMessage | TSubStyle
TGadgetGeometryMsg | TMenuStringMessage | TSysIPlugin
TGadgetInfo | TmpDeleteMenu | TTabletData
TgpDomain | TmpFindID | TTabletHookData
TgpExtent | TmpGetState | TT_ALPHA16
TgpGoInactive | TmpHandleEvent | TT_ALPHA24
TgpHitTest | TmpNewMenu | TT_ALPHA32
TgpInput | TmpNextChild | TT_ALPHA8
tgpKeyGoInactive | TmpNextSelect | TTBGadgetData
TgpKeyInput | TmpScan | TT_BITPLANE
TgpKeyTest | TmpSetState | TVector
TgpLayout | TmpSetup | TVectorInfo
TgpMenuEvent | TMsg | TWindow

U

UnlockClassList | UnlockScreen | USEREQIMAGE
UnlockGUIPrefs | UnlockScreenGI | US_LEGAL
UnlockIBase | UnlockScreenList | US_LETTER
UnlockPubScreen | UPFRONTGADGET |
UnlockPubScreenList | UPIMAGE |

V

ViewAddress | VIF_MENU | VO_FILLELPS
ViewPortAddress | VIF_NOBUFFER | VO_FILLPOLY
VIF_3DDISABLE | VIF_PENSHADE | VO_FILLRECT
VIF_ALPHABLEND | VIF_REFFONT | VO_LINE
VIF_ALPHASHADE | VIF_ROUNDEDSCALING | VO_LINEELPS
VIF_ALPHASHADOW | VIF_SCREENBAR | VO_LINEPOLY
VIF_ALPHASHINE | VIF_TBLEFT | VO_LINERECT
VIF_BORDERMASK | VIF_TBRIGHT | VO_POLY
VIF_BRCORN | VIF_VERTARROW | VO_RECT
VIF_BUTTON | VIF_WMULTIPLY | VT_BOTH
VIF_HORIZARROW | VKHANDLEIMAGE | VT_COLOR
VIF_IGNOREHEIGHT | VO_ELPS | VT_MONO
VIF_IGNOREWIDTH | VO_END |
VIF_KEEPASPECT | VO_FILL |

W

WA_Activate | WA_MouseLimits | WBENCHSCREEN_F
WA_AlphaClips | WA_MouseQueue | WBenchToBack
WA_AlphaHook | WA_NewLookMenus | WBenchToFront
WA_AmigaKey | WA_NoCareRefresh | WFLG_ACTIVATE
WA_AutoAdjust | WA_NoHitThreshold | WFLG_BACKDROP
WA_AutoAdjustDClip | WA_NoMenuKeyVerify | WFLG_BORDERLESS
WA_Backdrop | WA_NotifyDepth | WFLG_CLOSEGADGET
WA_BackFill | WA_Opaqueness | WFLG_DEPTHGADGET
WA_BlockPen | WA_OverrideOpaqueness | WFLG_DRAGBAR
WA_Borderless | WA_Pointer | WFLG_GIMMEZEROZERO
WA_BusyPointer | WA_PointerDelay | WFLG_HASZOOM
WA_Checkmark | WA_PointerType | WFLG_INREQUEST
WA_CloseGadget | WA_PubScreen | WFLG_MENUSTATE
WA_Colors | WA_PubScreenFallBack | WFLG_NEWLOOKMENUS
WA_ContextMenuHook | WA_PubScreenName | WFLG_NOCAREREFRESH
WA_CustomScreen | WA_ReportMouse | WFLG_NW_EXTENDED
WA_DepthGadget | WA_Reserved1 | WFLG_OTHER_REFRESH
WA_DetailPen | WA_Reserved2 | WFLG_REFRESHBITS
WA_DragBar | WA_RMBTrap | WFLG_REPORTMOUSE
WA_DropShadows | WA_RptQueue | WFLG_RMBTRAP
WA_Dummy | WA_ScreenTitle | WFLG_SIMPLE_REFRESH
WA_FadeTime | WA_ShapeHook | WFLG_SIZEBBOTTOM
WA_Flags | WA_ShapeRegion | WFLG_SIZEBRIGHT
WA_Gadgets | WA_SimpleRefresh | WFLG_SIZEGADGET
WA_GimmeZeroZero | WA_SizeBBottom | WFLG_SMART_REFRESH
WA_GrabFocus | WA_SizeBRight | WFLG_SUPER_BITMAP
WA_Height | WA_SizeGadget | WFLG_VISITOR
WA_HelpGroup | WA_SmartRefresh | WFLG_WBENCHWINDOW
WA_HelpGroupWindow | WA_StayTop | WFLG_WINDOWACTIVE
WA_Hidden | WA_SuperBitMap | WFLG_WINDOWREFRESH
WA_IDCMP | WA_TabletMessages | WFLG_WINDOWTICKED
WA_InFrontOf | WA_Title | WFLG_ZOOMED
WA_InnerHeight | WA_ToolBox | WINDOW_BACKMOST
WA_InnerWidth | WA_Top | WINDOW_FRONTMOST
WA_Left | WA_UserPort | WindowLimits
WA_MaxHeight | WA_WBenchWindow | WindowToBack
WA_MaxWidth | WA_Width | WindowToFront
WA_MenuHelp | WA_WindowBox | WTPOS_CENTERABS
WA_MenuHook | WA_WindowName | WTPOS_CENTERREL
WA_MenuStrip | WA_Zoom | WTPOS_LEFT
WA_MinHeight | WBENCHCLOSE | W_TRACTOR
WA_MinWidth | WBENCHOPEN |

Z

ZipWindow ZOOMIMAGE


ActivateGadget

Activate a (string or custom) gadget.

Declaration

Source position: intuition.pas line 3879

function ActivateGadget(

  Gadgets: PGadget;

  Window: PWindow;

  Requester: PRequester

):LongBool;

Arguments

Window | A pointer to a window structure containing the gadget.
Requester | A pointer to a requester (may by nil if this isn't a requester gadget (i.e. GTYP_REQGADGET is not set)).

Function result

If the conditions are met, and the gadget is in fact a string gadget, then this function will return True, else False.

Description

Activates a string or custom gadget. If successful, this means that the user does not need to click in the gadget before typing.

The window parameter must point to the window which contains the gadget. If the gadget is actually in a requester, the window must contain the requester, and a pointer to the requester must also be passed. The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

The success of this function depends on a rather complex set of conditions. The intent is that the user is never interrupted from what interactions he may have underway.

The current set of conditions includes:

  • The window must be active. If you are opening a new window and want an active gadget in it, it is not sufficient to assume that the WFLG_ACTIVATE flag has taken effect by the time OpenWindow() returns, even if you insert a delay of some finite amount of time. Use the IDCMP_ACTIVEWINDOW IntuiMessage to tell when your window really becomes active. Many programs use an event loop that calls ActivateGadget() whenever they receive the IDCMP_ACTIVEWINDOW message, and also the IDCMP_MOUSEBUTTONS messages, and so on, to keep the gadget active until it is used (or the user selects some other "Cancel" gadget).
  • No other gadgets may be in use. This includes system gadgets, such as those for window sizing, dragging, etc.
  • If the gadget is in a requester, that requester must be active. (Use IDCMP_REQSET and IDCMP_REQCLEAR).
  • The right mouse button cannot be held down (e.g. menus)

Note: Don't try to activate a gadget which is disabled or not attached to a window or requester.


ActivateWindow

Activate an Intuition window.

Declaration

Source position: intuition.pas line 3877

procedure ActivateWindow(

  Window: PWindow

);

Arguments

Window

The window to activate

Description

Note that this call may have its action deferred: you cannot assume that when this call is made the selected window has become active. This action will be postponed while the user plays with gadgets and menus, or sizes and drags windows. You may detect when the window actually has become active by the IDCMP_ACTIVEWINDOW IDCMP message.

This call is intended to provide flexibility but not to confuse the user. Please call this function synchronously with some action by the user.

Errors

If the user has an autopointer tool (sunmouse), the call will succeed, but the tool will deactivate the window right after this function has activated it. It is not a good idea to try to prevent this by waiting for IDCMP_INACTIVEWINDOW and activating the window again since that will produce an annoying flicker and it will slow down the computer a lot.

See also

ModifyIDCMP | Modify the state of a window's IDCMPFlags.
OpenWindow | Open an Intuition window.
CloseWindow | Close an Intuition window.


AddClass

Make a public class available

Declaration

Source position: intuition.pas line 3924

procedure AddClass(

  ClassPtr: PIClass

);

Arguments

ClassPtr

The result of MakeClass()

Description

Adds a public boopsi class to the internal list of classes available for public consumption. You must call this function after you call MakeClass(). Do not use this function for private classes.

Errors

There is no protection against creating multiple classes with the same name yet. The operation of the system is undefined in this case.

See also

MakeClass | Create and initialize a boopsi class.
FreeClass | Frees a boopsi class created by MakeClass().
RemoveClass | Make a public boopsi class unavailable.


AddGadget

Add a gadget to the gadget list of a window.

Declaration

Source position: intuition.pas line 3808

function AddGadget(

  Window: PWindow;

  Gadget: PGadget;

  Position: LongWord

):LongWord;

Arguments

Window | A pointer to the window to get your gadget
Gadget | A pointer to the new gadget
Position | Integer position in the list for the new gadget (starting from zero as the first position in the list)

Function result

Returns the position of where the gadget was actually added.

Description

Adds the specified gadget to the gadget list of the given window, linked in at the position in the list specified by the position argument (that is, if Position == 0, the gadget will be inserted at the head of the list, and if Position == 1 then the gadget will be inserted after the first gadget and before the second). If the position you specify is greater than the number of gadgets in the list, your gadget will be added to the end of the list.

Calling AddGadget() does not cause your gadget to be redisplayed. The benefit of this is that you may add several gadgets without having the gadget list redrawn every time.

This procedure returns the position at which your gadget was added.

Note: A relatively safe way to add the gadget to the end of the list is to specify a position of -1 (i.e. Word $FFFF). That way, only the 65536th (and multiples of it) will be inserted at the wrong position. The return value of the procedure will tell you where it was actually inserted.

Note: The system window gadgets are initially added to the front of the gadget list. The reason for this is: If you position your own gadgets in some way that interferes with the graphical representation of the system gadgets, the system's ones will be "hit" first by user. If you then start adding gadgets to the front of the list, you will disturb this plan, so beware. On the other hand, if you don't violate the design rule of never overlapping your gadgets, there's no problem.

Note: You may not add your own gadgets to a screen. Gadgets may be added to backdrop windows, however, which can be visually similar, but also provide an IDCMP channel for gadget input messages.

See also

AddGList | Add a linked list of gadgets to a window or requester.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.


AddGList

Add a linked list of gadgets to a window or requester.

Declaration

Source position: intuition.pas line 3875

function AddGList(

  Window: PWindow;

  Gadget: PGadget;

  Position: LongWord;

  NumGad: LongInt;

  Requester: PRequester

):LongWord;

Arguments

Window | A pointer to the window to get your gadget
Gadget | A pointer to the first gadget to be added
Position | Integer position in the list for the new gadget (starting from zero as the first position in the list)
NumGad | The number of gadgets from the linked list to be added if Numgad equals -1, the entire nil-terminated list of gadgets will be added.
Requester | The requester the gadgets will be added to if the GTYP_REQGADGET GadgetType flag is set for the first gadget in the list

Function result

Returns the position of where the first gadget in the list was actually added.

Description

Adds the list of gadgets to the gadget list of the given window or requester linked in at the position in the list specified by the position argument.

See AddGadget() for more information about gadget list position, and more information about gadgets in general.

The requester parameter will be ignored unless the GTYP_REQGADGET bit is set in the GadgetType field of the first gadget in the list. In that case, the gadget list is added to the requester gadgets.

Note: be sure that GTYP_REQGADGET is either set or cleared consistently for all gadgets in the list.

Note also: The window parameter should point to the window that the requester (will) appear in.

Will add Numgad gadgets from gadget list linked by the field TGadget.NextGadget, or until some TGadget.NextGadget field is found to be nil. Does not assume that the Numgad'th gadget has TGadget.NextGadget equal to nil.

Note well: In order to link your gadget list in, the TGadget.NextGadget field of the Numgad'th (or last) gadget will be modified. Thus, if you are adding the first 3 gadgets from a linked list of five gadgets, this call will sever the connection between your third and fourth gadgets.

The gadgets will just be added. To make them visible, you must refresh the window or the gadgets.

See also

AddGadget | Add a gadget to the gadget list of a window.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.


AllocRemember

Allocate Memory with tracking to make freeing easy.

Declaration

Source position: intuition.pas line 3868

function AllocRemember(

  var RememberKey: PRemember;

  Size: LongWord;

  Flags: LongWord

):Pointer;

Arguments

RememberKey | Store information in this list. Must be nil for initial call.
Size | How many bytes to allocate
Flags | Attributes (see AllocMem())

Function result

If the memory allocation is successful, this routine returns the byte address of your requested memory block. Also, the node to your block will be linked into the list pointed to by your RememberKey variable. If the allocation fails, this routine returns nil and the list pointed to by RememberKey, if any, will be unchanged.

Description

This routine calls the Exec AllocMem() function for you, but also links the parameters of the allocation into a master list, so that you can simply call the Intuition routine FreeRemember() at a later time to deallocate all allocated memory without being required to remember the details of the memory you've allocated.

This routine will have two primary uses:

  • Let's say that you're doing a long series of allocations in a procedure. If any one of the allocations fails, your program may need to abort the procedure. Abandoning ship correctly involves freeing up what memory you've already allocated. This procedure allows you to free up that memory easily, without being required to keep track of how many allocations you've already done, what the sizes of the allocations were, or where the memory was allocated.
  • Also, in the more general case, you may do all of the allocations in your entire program using this routine. Then, when your program is exiting, you can free it all up at once with a simple call to FreeRemember().

You create the "anchor" for the allocation master list by creating a variable that's a pointer to struct Remember, and initializing that pointer to NULL. This is called the RememberKey. Whenever you call AllocRemember(), the routine actually does two memory allocations, one for the memory you want and the other for a copy of a Remember structure. The Remember structure is filled in with data describing your memory allocation, and it's linked into the master list pointed to by your RememberKey. Then, to free up any memory that's been allocated, all you have to do is call FreeRemember() with your RememberKey.

Please read the FreeRemember() function description, too. As you will see, you can select either to free just the link nodes and keep all the allocated memory for yourself, or to free both the nodes and your memory buffers.

See also

FreeRemember | Free memory allocated by calls to AllocRemember().
AllocMem | Allocate memory given certain requirements

Example

program RememberTest;
uses
  Intuition;
var
  RememberKey: PRemember;
begin
  RememberKey := nil;
  buffer := AllocRemember(@RememberKey, BUFSIZE, MEMF_CHIP);
  if Assigned(buffer) then
  begin
    // Use the buffer
    //...
  end;
  FreeRemember(@RememberKey, True);
end.


AllocScreenBuffer

Get a ScreenBuffer for double-buffering.

Declaration

Source position: intuition.pas line 3933

function AllocScreenBuffer(

  Sc: PScreen;

  Bm: PBitMap;

  Flags: LongWord

):PScreenBuffer;

Arguments

Flags

Flags see list SB_*

Function result

Pointer to a valid ScreenBuffer structure, or nil if failure. You may render into the resulting BitMap as appropriate. You may use the TScreenBuffer.sb_DBufInfo field to access graphics.library ViewPort-buffering features such as learning when it is safe to reuse the previous BitMap. If not, you risk writing into the on-screen BitMap, which can damage menu or gadget rendering!

Description

Allocates a ScreenBuffer structure and usually a BitMap. This structure can be used for double (or multiple) buffering in Intuition screens. You may use this call to obtain a ScreenBuffer structure for the screen's initial BitMap, or for other BitMaps you intend to swap in.

AllocScreenBuffer() also allocates a graphics.library DBufInfo structure. The ScreenBuffer structure this call returns contains a pointer to that TDBufInfo structure, which is free for your use. See AllocDBufInfo() for full details on using this structure to achieve notification of when it is safe to render into an old buffer and when it is right to switch again.

Flags:

SB_SCREEN_BITMAP
to get a ScreenBuffer referring to the screen's actual BitMap. (For CUSTOMBITMAP screens, just set the BitMap parameter to the BitMap you passed to OpenScreen()).
SB_COPY_BITMAP
If you would like the screen's BitMap copied into this ScreenBuffer's BitMap. This is required to get any menu-bar or gadget imagery into each ScreenBuffer's BitMap. If the screen has no Intuition rendering, you may omit this flag. Also, when allocating a ScreenBuffer for the screen's initial BitMap, this flag should not be set.

See also

FreeScreenBuffer | Free a ScreenBuffer structure.
ChangeScreenBuffer | Swap the screen's BitMap.
AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation


AlohaWorkbench

Declaration

Source position: intuition.pas line 3869

procedure AlohaWorkbench(

  WBPort: LongInt

);


AutoRequest

Automatically build and get response from a requester.

Declaration

Source position: intuition.pas line 3860

function AutoRequest(

  Window: PWindow;

  const Body: PIntuiText;

  const PosText: PIntuiText;

  const NegText: PIntuiText;

  PFlag: LongWord;

  nFlag: LongWord;

  Width: LongWord;

  Height: LongWord

):LongBool;

Arguments

Window | A pointer to a Window structure. See BuildSysRequest() for a full discussion.
Body | A pointer to an TIntuiText structure
PosText | A pointer to an TIntuiText structure, may by nil.
NegText | A pointer to an TIntuiText structure, must be valid!
PFlag | Flags for the IDCMP
nFlag | Flags for the IDCMP
Width | The width to be used for the rendering of the requester
Height | The height to be used for the rendering of the requester

Function result

The return value is either True or False. See the text above for a complete description of the chain of events that might lead to either of these values being returned.

Description

This procedure automatically builds a requester for you and then waits for a response from the user, or for the system to satisfy your request. If the response is positive, this procedure returns TRUE. If the response is negative, this procedure returns FALSE.

An IDCMPFlag specification is created by bitwise "or'ing" your PosFlags, NegFlags, and the IDCMP classes IDCMP_GADGETUP and IDCMP_RAWKEY. You may specify zero flags for either the PosFlags or NegFlags arguments.

The IntuiText arguments, and the width and height values, are passed directly to the BuildSysRequest() procedure along with your window pointer and the IDCMP flags. Please refer to BuildSysRequest() for a description of the IntuiText that you are expected to supply when calling this routine. It's an important but long-winded description that need not be duplicated here.

If the BuildSysRequest() procedure does not return a pointer to a window, it will return TRUE or FALSE (not valid structure pointers) instead, and these BOOL values will be returned to you immediately.

On the other hand, if a valid window pointer is returned, that window will have had its IDCMP ports and flags initialized according to your specifications. AutoRequest() then waits for IDCMP messages on the UserPort, which satisfies one of four requirements:

  • Iither the message is of a class that matches one of your PosFlags arguments (if you've supplied any), in which case this routine returns True.
  • or the message class matches one of your NegFlags arguments (if you've supplied any), in which case this routine returns False.
  • or the IDCMP message is of class IDCMP_GADGETUP, which means that one of the two gadgets, as provided with the PosText and NegText arguments, was selected by the user. If the True gadget was selected, True is returned. If the False gadget was selected, False is returned.
  • Lastly, two IDCMP_RAWKEY messages may satisfy the request: those for the V and B keys with the left Amiga key depressed. These keys, satisfy the gadgets on the left or right side of the requester--True or False--, respectively.

When the dust has settled, this routine calls FreeSysRequest() if necessary to clean up the requester and any other allocated memory.

When DOS brings up AutoRequests() on your process (eg. "Please insert volume XXX in any drive", they normally come up on the Workbench screen. If you set your Process pr_WindowPtr field to point to one of your windows, then DOS will bring its requesters up on the same screen as that window. A pr_WindowPtr of -1 prevents requesters from coming up at all. (Some FileSystem requesters cannot be redirected or supressed).

See also

EasyRequestArgs | Easy alternative to AutoRequest()
BuildSysRequest | Build and display a system requester.
SysReqHandler | Handle system requester input.


BASEOBJECT

Get "public" handle on baseclass instance from real beginning of obj data

Declaration

Source position: intuition.pas line 4051

function BASEOBJECT(

  o: P_Object

):Pointer;


BeginRefresh

Sets up a window for optimized refreshing.

Declaration

Source position: intuition.pas line 3861

procedure BeginRefresh(

  Window: PWindow

);

Arguments

Window

A pointer to the window structure which needs refreshing

Description

This routine sets up your window for optimized refreshing.

Its role is to provide Intuition integrated access to the Layers library function BeginUpdate(). Its additional contribution is to be sure that locking protocols for layers are followed, by locking both layers of a WFLG_GIMMEZEROZERO window only after the parent Layer_Info has been locked. Also, the WFLG_WINDOWREFRESH flag is set in your window, for your information.

The purpose of BeginUpdate(), and hence BeginRefresh(), is to restrict rendering in a window (layer) to the region that needs refreshing after an operation such as window sizing or uncovering. This restriction to the "damage region" persists until you call EndRefresh().

For instance, if you have a WFLG_SIMPLE_REFRESH window which is partially concealed and the user brings it to the front, you can receive an IDCMP_REFRESHWINDOW message asking you to refresh your display. If you call BeginRefresh() before doing any of the rendering, then the layer that underlies your window will be arranged so that the only rendering that will actually take place will be that which goes to the newly-revealed areas. This is very performance- efficient, and visually attractive.

After you have performed your refresh of the display, you should call EndRefresh() to reset the state of the layer and the window. Then you may proceed with rendering to the entire window as usual.

You learn that your window needs refreshing by receiving either a message of class IDCMP_REFRESHWINDOW through the IDCMP, or an input event of class IECLASS_REFRESHWINDOW through the Console device. Whenever you are told that your window needs refreshing, you should call BeginRefresh() and EndRefresh() to clear the refresh-needed state, even if you don't plan on doing any rendering. You may relieve yourself of even this burden by setting the WFLG_NOCAREREFRESH flag when opening your window.

Warning:

You should only perform simple graphics refreshing operations between BeginRefresh() and EndRefresh(). These include any graphics.library drawing functions or the simple Intuition rendering functions (DrawImage(), PrintIText(), DrawBorder(), and so on). In particular, do not call RefreshGadgets(), RefreshGList(), RefreshWindowFrame(), etc., since any of the complex Intuition functions run the risk of creating a deadlock. Also avoid any other high-level calls in Intuition or ones that might invoke Intuition. This means no calling SetPointer(), no calling LockIBase(), no dos.library functions (since an EasyRequest() might result), etc. Keep it simple.

By the time the application receives its IDCMP_REFRESHWINDOW message, Intuition has already repaired any damaged regions of the window border or the gadgets in the window, so attempts to redraw gadgets or borders are as unnecessary as they are dangerous.

Another Warning:

The concept of multiple refresh passes using EndRefresh(w, False); is not completely sound without further protection. The reason is that between two sessions, more damage can occur to your window. Your final EndRefresh(w, True); will dispose of all damage, including the new, and your initial refreshing pass will never get the chance to refresh the new damage.

To avoid this, you must protect your session using LockLayerInfo() which will prevent Intuition from performing window operations or anything else which might cause further damage from occurring. Again, while holding the LayerInfo lock make no Intuition function calls dealing with gadgets; just render.

You can, however, call InstallClipRegion() for the different refresh passes, if you have two clip regions.

Similar Warning:

Your program and Intuition "share" your window layer's DamageList. BeginRefresh() helps arbitrate this sharing, but the lower-level function layers.library/BeginUpdate() does not. It isn't really supported to use BeginUpdate() on a window's layer, but if you do for whatever reason it is critical that you first acquire the LayerInfo lock as in the above example: even if you only have one pass of refresh rendering to do. Otherwise, the refreshing of your window's borders and gadgets can be incomplete, and the problem might occur only under certain conditions of task priority and system load.

See also

EndRefresh | End the optimized refresh state of the window.
layers.BeginUpdate | Prepare to repair damaged layer.
OpenWindow | Open an Intuition window.
layers.InstallClipRegion | Install clip region in layer
layers.LockLayerInfo | Lock the LayerInfo structure.


BitMapInstanceControlA

Declaration

Source position: intuition.pas line 4008

function BitMapInstanceControlA(

  BitmapInstance: Pointer;

  TagList: PTagItem

):LongWord;


BuildEasyRequestArgs

Simple creation of system request.

Declaration

Source position: intuition.pas line 3902

function BuildEasyRequestArgs(

  Window: PWindow;

  const EasyStruct: PEasyStruct;

  IDCMP: LongWord;

  const Args: Pointer

):PWindow;

Arguments

Window | Reference window for requester: determines the requester window title and screen.
EasyStruct | A pointer to EasyStruct structure, as described in the EasyRequestArgs() .
IDCMP | (not a pointer) provided application specific IDCMP flags for the system requester window.
Args | see EasyRequestArgs()

Function result

A pointer to the system request window opened. In the event of problems, you may also be returned the value '0' which is to be interpreted as the "False, Cancel" choice, or (if you have a second gadget defined) the value '1', which is to be taken to mean the equivalent of your corresponding left-most gadget. If there is a problem creating the window, a recoverable alert may be substituted for the requester, and the result, either 0 or 1, returned.

Description

This function is to EasyRequestArgs() as BuildSysRequest() is to AutoRequest(): it returns a pointer to the system requester window. The input from that window can then be processed under application control.

It is recommended that this processing be done with SysReqHandler(), so that future enhancement to the processing will be enjoyed.

After you have determined that the requester is satisfied or cancelled, you must free this requester using FreeSysRequest().

Please see the autodoc for EasyRequestArgs().

Note: This function switches the processor stack to ensure sufficient stack space for the function to complete.

See also

EasyRequestArgs | Easy alternative to AutoRequest()
FreeSysRequest | Free resources gotten by a call to BuildSysRequest().
SysReqHandler | Handle system requester input.
BuildSysRequest | Build and display a system requester.
AutoRequest | Automatically build and get response from a requester.


BuildSysRequest

Build and display a system requester.

Declaration

Source position: intuition.pas line 3862

function BuildSysRequest(

  Window: PWindow;

  const Body: PIntuiText;

  const PosText: PIntuiText;

  const NegText: PIntuiText;

  Flags: LongWord;

  Width: LongWord;

  Height: LongWord

):PWindow;

Arguments

Window | A pointer to a Window structure
Body | A pointer to an IntuiText structure
PosText | A pointer to an IntuiText structure
NegText | A pointer to an IntuiText structure
Flags | The IDCMP flags you want used for the initialization of the IDCMP of the window containing this requester
Width | The width required to render your requester
Height | The height required to render your requester

Function result

If the requester was successfully created, the value returned by this procedure is a pointer to the window in which the requester is rendered. If the requester could not be created, this routine might have called DisplayAlert() before returning (it depends on the version) and will pass back True if the user pressed the left mouse button and False if the user pressed the right mouse button. If the version of Intuition doesn't call DisplayAlert(), or if it does, and there's not enough memory for the alert, the value of False is returned.

Description

This procedure builds a system requester based on the supplied information. If all goes well and the requester is constructed, this procedure returns a pointer to the window in which the requester appears. That window will have its IDCMP initialized to reflect the flags found in the IDCMPFlags argument. You may then wait on those ports to detect the user's response to your requester, which response may include either selecting one of the gadgets or causing some other event to be noticed by Intuition (like IDCMP_DISKINSERTED, for instance). After the requester is satisfied, you should call the FreeSysRequest() procedure to remove the requester and free up any allocated memory.

See the autodoc for SysReqHandler() for more information on the how to handle the IntuiMessages this window will receive.

The requester used by this function has the NOISYREQ flag bit set, which means that the set of IDCMPFlags that may be used here include IDCMP_RAWKEYIDCMP_RAWKEY, IDCMP_MOUSEBUTTONS, and others.

The function may return True (1) or False (nil) if it cannot post the requester.

If the window argument you supply is equal to NULL, a new window will be created for you in the Workbench screen. If you want the requester created by this routine to be bound to a particular window (i.e., to appear in the same screen as the window), you should not supply a window argument of nil.

If you pass a nil window pointer, the system requester will appear on the default public screen, which is not always the Workbench.

The text arguments are used to construct the display. Each is a pointer to an instance of the structure IntuiText.

The BodyText argument should be used to describe the nature of the requester. As usual with IntuiText data, you may link several lines of text together, and the text may be placed in various locations in the requester. This IntuiText pointer will be stored in the ReqText variable of the new requester.

The PosText argument describes the text that you want associated with the user choice of "Yes, True, Retry, Good." If the requester is successfully opened, this text will be rendered in a gadget in the lower-left of the requester, which gadget will have the GadgetID field set to True. If the requester cannot be opened and the DisplayAlert() mechanism is used, this text will be rendered in the lower-left corner of the alert display with additional text specifying that the left mouse button will select this choice. This pointer can be set to nil, which specifies that there is no True choice that can be made.

The NegText argument describes the text that you want associated with the user choice of "No, False, Cancel, Bad." If the requester is successfully opened, this text will be rendered in a gadget in the lower-right of the requester, which gadget will have the GadgetID field set to FALSE. If the requester cannot be opened and the DisplayAlert() mechanism is used, this text will be rendered in the lower-right corner of the alert display with additional text specifying that the right mouse button will select this choice. This pointer cannot be set to nil. There must always be a way for the user to cancel this requester.

The Positive and Negative Gadgets created by this routine have the following features:

  • GTYP_BOOLGADGET
  • GACT_RELVERIFY
  • GTYP_REQGADGET
  • GACT_TOGGLESELECT

When defining the text for your gadgets, you may find it convenient to use the special constants used by Intuition for the construction of the gadgets. These include defines like AUTODRAWMODE, AUTOLEFTEDGE, AUTOTOPEDGE and AUTOFRONTPEN.

These hard-coded constants are not very resolution or font sensitive.

The width and height values describe the size of the requester. All of your BodyText must fit within the width and height of your requester. The gadgets will be created to conform to your sizes.

Very important Note: for this release of this procedure, a new window is opened in the same screen as the one containing your window. Future alternatives may be provided as a function distinct from this one.

Note: This function will pop the screen the requester and its window appears in to the front of all screens. If the user doesn't perform any other screen arrangement before finishing with the requester, a popped screen will be pushed back behind.

See also

FreeSysRequest | Free resources gotten by a call to BuildSysRequest().
DisplayAlert | Create the display of an alert message.
ModifyIDCMP | Modify the state of a window's IDCMPFlags.
Wait | Wait for one or more signals
Request | Activate a requester.
AutoRequest | Automatically build and get response from a requester.
EasyRequestArgs | Easy alternative to AutoRequest()
BuildEasyRequestArgs | Simple creation of system request.


ChangeScreenBuffer

Swap the screen's BitMap.

Declaration

Source position: intuition.pas line 3935

function ChangeScreenBuffer(

  Sc: PScreen;

  Sb: PScreenBuffer

):LongWord;

Function result

Returns non-zero if the operation succeeded. Returns zero if the operation cannot be performed. This function will fail if Intuition's state cannot permit it, for example the user is playing with menus or gadgets.

Description

Performs double (or multiple) buffering on an Intuition screen in an Intuition-cooperative manner. The BitMap associated with the supplied ScreenBuffer will be installed in the specified screen, if possible. The previously-installed BitMap is available for re-use upon receiving a signal from graphics.library. See the graphics.library autodocs for AllocDBufInfo() and ChangeVPBitMap() for details.

It is not required to restore the original ScreenBuffer before closing the screen. Simply FreeScreenBuffer() each buffer (including the original and the currently-installed one) then close the screen. Of course, you cannot call ChangeScreenBuffer() after freeing the currently-installed one.

See also

AllocScreenBuffer | Get a ScreenBuffer for double-buffering.
FreeScreenBuffer | Free a ScreenBuffer structure.
ChangeVPBitMap | Change display memory address for multi-buffered animation


ChangeWindowBox

Change window position and dimensions.

Declaration

Source position: intuition.pas line 3883

procedure ChangeWindowBox(

  Window: PWindow;

  Left: LongInt;

  Top: LongInt;

  Width: LongInt;

  Height: LongInt

);

Arguments

Window | The window to change position/dimension
Left | Left edge the window should move to
Top | Top edge the window should move to
Width | New Width for window
Height | New height for window

Description

Makes simultaneous changes in window position and dimensions, in absolute (not relative) coordinates.

Like MoveWindow() and SizeWindow(), the effect of this function is deferred until the next input comes along. Unlike these functions, ChangeWindowBox() specifies absolute window position and dimensions, not relative. This makes for more reliable results considering that the action is deferred, so this function is typically preferable to MoveWindow() and SizeWindow() paired.

You can detect that this operation has completed by receiving the IDCMP_CHANGEWINDOW IDCMP message

The dimensions are limited to legal range, but you should still take care to specify sensible inputs based on the window's dimension limits and the size of its screen.

This function limits the position and dimensions to legal values.

See also

MoveWindow | Ask Intuition to move a window.
SizeWindow | Ask Intuition to size a window.
ZipWindow | Change window to "alternate" position and dimensions.
MoveSizeLayer | Position/Size layer


ClearDMRequest

Clear (detaches) the DMRequest of the window.

Declaration

Source position: intuition.pas line 3809

function ClearDMRequest(

  Eindow: PWindow

):LongBool;

Function result

If the DMRequest was not currently in use, detaches the DMRequest from the window and returns True. If the DMRequest was currently in use, doesn't change anything and returns False.

Description

Attempts to clear the DMRequest from the specified window, that is detaches the special requester that you attach to the double-click of the menu button which the user can then bring up on demand. This routine will not clear the DMRequest if it's active (in use by the user). The IDCMP message class IDCMP_REQCLEAR can be used to detect that the requester is not in use, but that message is sent only when the last of perhaps several requesters in use in a window is terminated.

See also

SetDMRequest | Set the DMRequest of a window.
Request | Activate a requester.


ClearMenuStrip

Clear (detach) the menu strip from the window.

Declaration

Source position: intuition.pas line 3810

procedure ClearMenuStrip(

  Window: PWindow

);

Arguments

Window

A pointer to a window structure

Description

Detaches the current menu strip from the window; menu strips are attached to windows using the SetMenuStrip() function.

If the menu is in use (for that matter if any menu is in use) this function will block (Wait()) until the user has finished.

Call this function before you make any changes to the data in a TMenu or TMenuItem structure# which is part of a menu strip linked into a window.

See also

SetMenuStrip | Attach a menu strip to a window.
ResetMenuStrip | Re-attach a menu strip to a window.


ClearPointer

Clear the mouse pointer definition from a window.

Declaration

Source position: intuition.pas line 3811

procedure ClearPointer(

  Window: PWindow

);

Arguments

Window

A pointer to the window to be cleared of its pointer definition

Description

Clears the window of its own definition of the Intuition mouse pointer. After calling ClearPointer(), every time this window is the active one the default Intuition pointer will be the pointer displayed to the user. If your window is the active one when this routine is called, the change will take place immediately.

Custom definitions of the mouse pointer which this function clears are installed by a call to SetPointer().

See also

SetWindowPointerA | Select a pointer for your window.
SetPointer | Specify a pointer sprite image for a window.


CloseClass

Declaration

Source position: intuition.pas line 3969

procedure CloseClass(

  Cl: PIClass

);


CloseGUIPlugin

Declaration

Source position: intuition.pas line 4013

procedure CloseGUIPlugin(

  Plugin: PGUIPlugin

);


CloseScreen

Close an Intuition screen.

Declaration

Source position: intuition.pas line 3812

function CloseScreen(

  Screen: PScreen

):LongBool;

Arguments

Screen

A pointer to the screen to be closed.

Function result

Returns DOSTrue (1) if screen is closed, returns DOSFalse (0) if screen had open windows when called.

Description

Unlinks the screen, unlinks the viewport, deallocates everything that Intuition allocated when the screen was opened (using OpenScreen()). Doesn't care whether or not there are still any windows attached to the screen. Doesn't try to close any attached windows; in fact, ignores them altogether.

If this is the last screen to go, attempts to reopen Workbench.

This function will refuse to close the screen if there are windows open on the screen or if there are any outstanding screen locks (see LockPubScreen()) when CloseScreen() is called. This avoids the almost certain crash when a screen is closed out from under a window.

See also

OpenScreen

Open an Intuition screen


CloseWindow

Close an Intuition window.

Declaration

Source position: intuition.pas line 3813

procedure CloseWindow(

  Window: PWindow

);

Arguments

Window

A pointer to a Window structure

Description

Closes an Intuition window. Unlinks it from the system, deallocates its memory, and makes it disappear.

When this function is called, all IDCMP messages which have been sent to your window are deallocated. If the window had shared a message Port with other windows, you must be sure that there are no unreplied messages for this window in the message queue. Otherwise, your program will try to make use of a linked list (the queue) which contains free memory (the old messages). This will give you big problems. See the code fragment CloseWindowSafely(), below.

Note: If you have added a Menu strip to this Window (via a call to SetMenuStrip()) you must be sure to remove that Menu strip (via a call to ClearMenuStrip()) before closing your Window.

Note: This function may block until it is safe to de-link and free your window. Your program may thus be suspended while the user plays with gadgets, menus, or window sizes and position.

If your window is a "Visitor Window" (see OpenWindow()) CloseWindow() will decrement the "visitor count" in the public screen on which the window was open. When the last visitor window is closed, a signal will be sent to the public screen task, if this was pre-arranged (see OpenWindow()).

{ these functions close an Intuition window
  that shares a port with other Intuition
  windows or IPC customers.

  We are careful to set the UserPort to
  nil before closing, and to free
  any messages that it might have been
  sent.}
procedure CloseWindowSafely(Win: PWindow);
begin
  // we forbid here to keep out of race conditions with Intuition
  Forbid();
  // send back any messages for this window that have not yet been processed
  StripIntuiMessages(Win^.UserPort, Win);
  // clear UserPort so Intuition will not free it
  Win^.UserPort := nil;
  // tell Intuition to stop sending more messages
  ModifyIDCMP(Win, 0);
  // turn multitasking back on
  Permit();
  // and really close the window
  CloseWindow(Win);
end;

{ Remove and reply all IntuiMessages on a port that
  have been sent to a particular window
  (note that we don't rely on the ln_Succ pointer
  of a message after we have replied it)}
procedure StripIntuiMessages(var Mp: PMsgPort; var Win: PWindow);
var
  msg: PIntuiMessage;
  Succ: PNode;
begin
  Msg := PIntuiMessage(Mp^.mp_MsgList.lh_Head);
  Succ := Msg^.ExecMessage.mn_Node.ln_Succ;
  while Assigned(succ) do
  begin
    if Msg^.IDCMPWindow = Win then
    begin
      // Intuition is about to free this message. Make sure that we have politely sent it back.
      Remove(Msg);
      ReplyMsg(Msg);
    end;
    Msg := PIntuiMessage(Succ);
    Succ := Msg^.ExecMessage.mn_Node.ln_Succ;
  end;
end;

See also

OpenWindow | Open an Intuition window.
OpenScreen | Open an Intuition screen
CloseScreen | Close an Intuition screen.


CloseWorkBench

Closes the Workbench screen.

Declaration

Source position: intuition.pas line 3814

function CloseWorkBench: LongBool;

Function result

DOSTrue if the Workbench screen closed successfully DOSFalse if the Workbench was not open, or if it has windows open which are not Workbench drawers.

Description

This routine attempts to close the Workbench screen:

  • Test whether or not any applications have opened windows on the Workbench, and return False if so. Otherwise ...
  • Clean up all special buffers
  • Close the Workbench screen
  • Make the Workbench program mostly inactive (it will still monitor disk activity)
  • Return DOSTrue

See also

OpenWorkBench

Open the Workbench screen.


CoerceMethod

Declaration

Source position: intuition.pas line 4043

function CoerceMethod(

  cl: PIClass;

  Obj: PObject_;

  const Args: array of PtrUInt

):LongWord;


CoerceMethodA

Perform method on coerced object.

Declaration

Source position: intuition.pas line 4042

function CoerceMethodA(

  cl: PIClass;

  Obj: PObject_;

  Message: Pointer

):LongWord;

Arguments

cl | A pointer to boopsi object
Obj | A pointer to boopsi object
Message | A pointer to method-specific message to send

Function result

Class and message-specific result.

Description

Boopsi support function that invokes the supplied message on the specified object, as though it were the specified class.

See also

DoMethodA | Perform method on object.
CoerceMethodA | Perform method on coerced object.
DoSuperMethodA | Perform method on object coerced to superclass.


CurrentTime

Get the current time values.

Declaration

Source position: intuition.pas line 3815

procedure CurrentTime(

  var Seconds: LongWord;

  var Micros: LongWord

);

Arguments

Seconds | A pointer to a LongInt variable to receive the current seconds value
Micros | A pointer to a LongInt variable for the current microseconds value

Description

Puts copies of the current time into the supplied argument pointers.

This time value is not extremely accurate, nor is it of a very fine resolution. This time will be updated no more than sixty times a a second, and will typically be updated far fewer times a second.


CUSTOM_HOOK

Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget

Declaration

Source position: intuition.pas line 4063

function CUSTOM_HOOK(

  gadget: PGadget

):PHook;


DirectionVector

Declaration

Source position: intuition.pas line 4020

function DirectionVector(

  Degrees: LongWord

):LongWord;


DisableTemplate

Declaration

Source position: intuition.pas line 4031

procedure DisableTemplate(

  Rp: PRastPort;

  Left: LongInt;

  Top: LongInt;

  Width: LongInt;

  Height: LongInt;

  TemplatePtr: Pointer;

  OffX: LongInt;

  OffY: LongInt;

  TemplateType: LongWord;

  BytesPerRow: LongWord;

  BackType: LongWord;

  Dri: PDrawInfo

);


DisableTemplateRGB

Declaration

Source position: intuition.pas line 4005

procedure DisableTemplateRGB(

  Rp: PRastPort;

  Left: LongInt;

  Top: LongInt;

  Width: LongInt;

  Height: LongInt;

  TemplatePtr: PByte;

  BrightLevel: LongWord;

  DarkLevel: LongWord

);


DisplayAlert

Create the display of an alert message.

Declaration

Source position: intuition.pas line 3816

function DisplayAlert(

  AlertNumber: LongWord;

  const String_: PChar;

  Height: LongWord

):LongBool;

Arguments

AlertNumber | The number of this alert message. The only pertinent bits of this number are the ALERT_TYPE bit(s). The rest of the number is ignored by this routine.
String_ | A pointer to the alert message string, as described above
Height | Minimum display lines required for your message

Function result

A LongBool value of True or False. If this is a DEADEND_ALERT, False is always the return value. If this is a RECOVERY_ALERT. The return value will be True if the user presses the left mouse button in response to your message, and False if the user presses the right hand button is response to your text, or if the alert could not be posted.

Description

Creates an alert display with the specified message.

If the system can recover from this alert, it's a RECOVERY_ALERT and this routine waits until the user presses one of the mouse buttons, after which the display is restored to its original state and a LongBool value is returned by this routine to specify whether or not the user pressed the Left mouse button.

If the system cannot recover from this alert, it's a DEADEND_ALERT and this routine returns immediately upon creating the alert display. The return value is False.

NOTE: If Intuition can't get enough memory for a RECOVERY_ALERT, the value False will be returned.

AlertNumber is a LongInt value, historically related to the value sent to the Alert() routine. But the only bits that are pertinent to this routine are the ALERT_TYPE bit(s). These bits must be set to either RECOVERY_ALERT for alerts from which the system may safely recover, or DEADEND_ALERT for those fatal alerts. These states are described in the paragraph above. There is a third type of alert, the DAISY_ALERT, which is used only by the Exec.

The String_ argument points to an AlertMessage string. The AlertMessage string is comprised of one or more substrings, each of which is composed of the following components:

  • first, a 16-bit x-coordinate and an 8-bit y-coordinate, describing where on the alert display you want this string to appear. The y-coordinate describes the offset to the baseline of the text.
  • then, the bytes of the string itself, which must be null-terminated (end with a byte of zero)
  • lastly, the continuation byte, which specifies whether or not there's another substring following this one. If the continuation byte is non-zero, there is another substring to be processed in this alert message. If the continuation byte is zero, this is the last substring in the message.

The last argument, Height, describes how many video lines tall you want the alert display to be.

Alerts are always rendered in Topaz 8 (80 column font), regardless of the system default font. Also, RECOVERY_ALERTs are displayed in amber, while DEADEND_ALERTs are still red. Alerts no longer push down the application screens to be displayed. Rather, they appear alone in a black display.

Alerts block each other out, and input during an alert is deprived of the rest of the system. Internal input buffers still cause alert clicks to be processed by applications sometimes.

Errors

This function is obsolete and exists only for backwards compatibility with AmigaOS(tm). On various modern systems this function has different effects. On classic Amiga(tm) this function may not work with RTG displays, so it is generally deprecated. Please don't use it in a new software! Use legitimate intuition requesters if you want to present some message to the user.

See also

TimedDisplayAlert

Display an alert with automatic time-out.


DisplayBeep

Flash the video display.

Declaration

Source position: intuition.pas line 3817

procedure DisplayBeep(

  Screen: PScreen

);

Arguments

Screen

A pointer to a screen. If nil, every screen in the display will be flashed

Description

"Beeps" the video display by flashing the background color of the specified screen. If the screen argument is nil, every screen in the display will be beeped. Flashing everyone's screen is not a polite thing to do, so this should be reserved for dire circumstances.

The reason such a routine is supported is because the Amiga has no internal bell or speaker. When the user needs to know of an event that is not serious enough to require the use of a requester, the DisplayBeep() function may be called.

Intuition calls DisplayBeep() through the external library vector. This means that if you call SetFunction() to replace DisplayBeep() with an audible beep, for example, then your change will affect even Intuition's calls to DisplayBeep().

Since this function changes color zero of the affected screen(s), surprising results could occur if the screen's owner reading colors or perhaps cycling them.


DisposeObject

Deletes a 'boopsi' object.

Declaration

Source position: intuition.pas line 3914

procedure DisposeObject(

  Obj: PObject_

);

Description

Deletes a boopsi object and all of it auxiliary data. These objects are all created by NewObject(). Objects of certain classes "own" other objects, which will also be deleted when the object is passed to DisposeObject(). Read the per-class documentation carefully to be aware of these instances.

This function invokes the OM_DISPOSE method.

See also

NewObject | Varargs version of NewObjectA()
SetAttrs | Varargs Version of SetAttrsA()
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


DoGadgetMethodA

Invoke method on a boopsi gadget.

Declaration

Source position: intuition.pas line 3940

function DoGadgetMethodA(

  Gad: PGadget;

  Win: PWindow;

  Req: PRequester;

  Message_: TMsg

):LongWord;

Arguments

Gad | An abstract pointer to a boopsi gadget
Win | window gadget has been added to using AddGList() or AddGadget()
Req | For REQGADGETs, requester containing the gadget

Function result

The object does whatever it wants with the message you sent, which might include updating its gadget visuals. The return value is defined per-method.

Description

Same as the DoMethodA() function, but provides context information and arbitration for classes which implement custom Intuition gadgets.

You should use this function for boopsi gadget objects, or for "models" which propagate information to gadgets.

Unlike DoMethodA(), this function provides a TGadgetInfo pointer (if possible) when invoking the method. Some classes may require or benefit from this.

Note: This function invokes the specified method with a TGadgetInfo derived from the Window and Requester pointers. The TGadgetInfo is passed as the second parameter of the message, except for OM_NEW, OM_SET, OM_NOTIFY, and OM_UPDATE, where the TGadgetInfo is passed as the third parameter.

Implementers of new gadget methods should ensure that the TGadgetInfo is the second long-word of their message!

See also

NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


DoMethod

VarArgs Version of DoMethodA()

Declaration

Source position: intuition.pas line 4041

function DoMethod(

  Obj: PObject_;

  const Args: array of PtrUInt

):LongWord;

Description

Boopsi support function that invokes the supplied message on the specified object. The message is invoked on the object's true class.

See also

DoMethodA | Perform method on object.
CoerceMethodA | Perform method on coerced object.
DoSuperMethodA | Perform method on object coerced to superclass.


DoMethodA

Perform method on object.

Declaration

Source position: intuition.pas line 4040

function DoMethodA(

  Obj: PObject_;

  Message: Pointer

):LongWord;

Arguments

Obj | A pointer to boopsi object
Message | A pointer to method-specific message to send

Function result

Specific to the message and the object's class.

Description

Boopsi support function that invokes the supplied message on the specified object. The message is invoked on the object's true class.

See also

DoMethod | VarArgs Version of DoMethodA()
CoerceMethodA | Perform method on coerced object.
DoSuperMethodA | Perform method on object coerced to superclass.


DoRender

Declaration

Source position: intuition.pas line 4016

function DoRender(

  O: PObject_;

  Gi: PGadgetInfo;

  Flags: LongWord

):LongWord;


DoScrollHook

Declaration

Source position: intuition.pas line 4023

procedure DoScrollHook(

  ScrollHook: PScrollHook;

  ScrollMode: LongInt

);


DoSuperMethod

VarArgs Version of DoSuperMethodA()

Declaration

Source position: intuition.pas line 4045

function DoSuperMethod(

  cl: PIClass;

  Obj: PObject_;

  const Args: array of PtrUInt

):LongWord;


DoSuperMethodA

Perform method on object coerced to superclass.

Declaration

Source position: intuition.pas line 4044

function DoSuperMethodA(

  cl: PIClass;

  Obj: PObject_;

  Message: Pointer

):LongWord;

Arguments

cl | A pointer to boopsi class whose superclass is to receive the message
Obj | A pointer to boopsi object
Message | A pointer to method-specific message to send

Function result

A class and message-specific result.

Description

Boopsi support function that invokes the supplied message on the specified object, as though it were the superclass of the specified class.

See also

DoMethodA | Perform method on object.
CoerceMethodA | Perform method on coerced object.
DoSuperMethod | VarArgs Version of DoSuperMethodA()


DoubleClick

Test two time values for double-click timing.

Declaration

Source position: intuition.pas line 3818

function DoubleClick(

  SSeconds: LongWord;

  SMicros: LongWord;

  CSeconds: LongWord;

  CMicros: LongWord

):LongBool;

Arguments

SSeconds | The timestamp value describing the start of the double-click time period you are considering
SMicros | Microseconds of start
CSeconds | The timestamp value describing the end of the double-click time period you are considering
CMicros | Microsecond of end

Function result

If the difference between the supplied timestamp values is within the double-click time range in the current set of Preferences, this function returns True, else it returns False

Description

Compares the difference in the time values with the double-click timeout range that the user has set (using the "Preferences" tool) or some other program has configured into the system. If the difference between the specified time values is within the current double-click time range, this function returns True, else it returns False.

These time values can be found in input events and IDCMP messages. The time values are not perfect; however, they are precise enough for nearly all applications.

See also

CurrentTime

Get the current time values.


DrawBorder

Draw the specified Border structure into a RastPort.

Declaration

Source position: intuition.pas line 3819

procedure DrawBorder(

  Rp: PRastPort;

  const Border: PBorder;

  LeftOffset: LongInt;

  TopOffset: LongInt

);

Arguments

Rp | A pointer to the RastPort to receive the border rendering
Border | A pointer to a Border structure
LeftOffset | The offset to be added to each vector's x coordinate
TopOffset | The offset to be added to each vector's y coordinate

Description

First, sets up the draw mode and pens in the RastPort according to the arguments of the Border structure. Then, draws the vectors of the border argument into the RastPort, offset by the left and top offsets.

As with all graphics rendering routines, the border will be clipped to to the boundaries of the RastPort's layer, if it exists. This is the case with window RastPorts.

This routine will draw all borders in the null-terminated list linked by the NextBorder field of the border argument.


DrawGradient

Declaration

Source position: intuition.pas line 4019

function DrawGradient(

  Rp: PRastPort;

  Left: LongInt;

  Top: LongInt;

  Width: LongInt;

  Height: LongInt;

  Domain: PIBox;

  Reserved: LongWord;

  GradientSpec: PGradientSpec;

  Dri: PDrawInfo

):LongWord;


DrawImage

Draw the specified Image structure into a RastPort.

Declaration

Source position: intuition.pas line 3820

procedure DrawImage(

  Rp: PRastPort;

  Image: PImage;

  LeftOffset: LongInt;

  TopOffset: LongInt

);

Arguments

Rp | A pointer to the RastPort to receive image rendering
Image | A pointer to an image structure
LeftOffset | The offset which will be added to the image's x coordinate
TopOffset | The offset which will be added to the image's y coordinate

Description

First, sets up the draw mode and pens in the RastPort according to the arguments of the Image structure. Then, moves the image data of the image argument into the RastPort, offset by the left and top offsets.

This routine does window layer clipping if you pass your window's (layered) RastPort -- if you draw an image outside of your window, your imagery will be clipped at the window's edge. If you pass a (non-layered) screen RastPort, you must be sure your image is wholly contained within the rastport bounds.

If the NextImage field of the image argument is non-nil, the next image is rendered as well, and so on until some NextImage field is found to be nil.

Note:

Intuition always has and will continue to assume there are at least as many planes of data pointed to by ImageData as there are '1' bits in the PlanePick field. Please ensure that this is so.

See also

DrawImageState | Draw an (extended) Intuition Image with special visual state.
EraseImage | Erases an Image.


DrawImageState

Draw an (extended) Intuition Image with special visual state.

Declaration

Source position: intuition.pas line 3909

procedure DrawImageState(

  Rp: PRastPort;

  Image: PImage;

  LeftOffset: LongInt;

  TopOffset: LongInt;

  State: LongWord;

  const DrawInfo: PDrawInfo

);

Arguments

Rp | RastPort for rendering
Image | A pointer to a (preferably custom) image
LeftOffset | Left positional offsets in pixels
TopOffset | Top positional offsets in pixels
State | Visual state selected from above
DrawInfo | A pointer to packed of pen selections and resolution.

Description

This function draws an Intuition Image structure in a variety of "visual states", these include:

IDS_NORMAL
like DrawImage()
IDS_SELECTED
represents the "selected state" of a Gadget
IDS_DISABLED
the "ghosted state" of a gadget
IDS_BUSY
for future functionality
IDS_INDETERMINATE
for future functionality
IDS_INACTIVENORMAL
for gadgets in window border
IDS_INACTIVESELECTED
for gadgets in window border
IDS_INACTIVEDISABLED
for gadgets in window border

Only IDS_NORMAL will make sense for traditional Image structures, this function is more useful when applied to new custom images or "object-oriented image classes."

Each class of custom images is responsible for documenting which visual states it supports, and you typically want to use images which support the appropriate states with your custom gadgets.

The DrawInfo parameter provides information invaluable to "rendered" images, such as pen color and resolution. Each image class must document whether this parameter is required.

See also

DrawImage | Draw the specified Image structure into a RastPort.
GetScreenDrawInfo | Get pointer to rendering information.


DrawSysImageA

Declaration

Source position: intuition.pas line 4014

function DrawSysImageA(

  Rp: PRastPort;

  Left: LongInt;

  Top: LongInt;

  Width: LongInt;

  Height: LongInt;

  Which: LongWord;

  BackType: LongWord;

  State: LongWord;

  Dri: PDrawInfo;

  TagList: PTagItem

):LongWord;


EasyRequest

VarArgs Version of EasyRequestArgs()

Declaration

Source position: intuition.pas line 4038

function EasyRequest(

  Window: PWindow;

  const EasyStruct: PEasyStruct;

  IDCMPPtr: PLongWord;

  const args: array of PtrUInt

):LongInt;


EasyRequestArgs

Easy alternative to AutoRequest()

Declaration

Source position: intuition.pas line 3900

function EasyRequestArgs(

  Window: PWindow;

  const EasyStruct: PEasyStruct;

  IDCMPPtr: PLongWord;

  const Args: Pointer

):LongInt;

Arguments

Window | Reference window pointer, determines the screen and title of the requester window. This can be nil, which means the requester is to appear on the Workbench screen, or default public screen, if defined.
EasyStruct | A Pointer to EasyStruct structure
Args | Arguments for format commands. Arguments for GadFmt follow arguments for TextFmt.

Function result

0, 1, ..., N = Successive GadgetID values, for the gadgets you specify for the requester. Note: The numbering from left to right is actually: 1, 2, ..., N, 0. This is for compatibility with AutoRequest(), which has False for the rightmost gadget.

-1 = Means that one of the caller-supplied IDCMPFlags occurred. The IDCMPFlag value is in the LongWord pointed to by IDCMP_ptr.

Description

This function provides a simpler method of using a 'System Requester' than provided by AutoRequest(). It performs layout and size calculations sensitive to the current font and screen resolution.

It provides for the descriptive body text and the gadget text to be constructed from printf style format strings.

It also provides a general way for the requester to be sensitive to particular IDCMP messages.

The first function listed is the actual Intuition library function. It is passed the arguments for the formatting operations as a pointer to the first argument.

Note: The formatting is done by RawDoFmt(), so be aware that to display a 32-bit integer argument, for example, you must say "%ld", not "%d", since RawDoFmt() is "word-oriented."

Note: This function switches the processor stack to ensure sufficient stack space for the function to complete.

See also

EasyRequest | VarArgs Version of EasyRequestArgs()
RawDoFmt | Format data into a character stream.
BuildEasyRequestArgs | Simple creation of system request.
SysReqHandler | Handle system requester input.
AutoRequest | Automatically build and get response from a requester.
BuildSysRequest | Build and display a system requester.


EmbossDisableRect

Declaration

Source position: intuition.pas line 4000

procedure EmbossDisableRect(

  Rp: PRastPort;

  MinX: LongInt;

  MinY: LongInt;

  MaxX: LongInt;

  MaxY: LongInt;

  BackType: LongWord;

  Contrast: LongWord;

  Dri: PDrawInfo

);


EmbossDisableText

Declaration

Source position: intuition.pas line 4001

procedure EmbossDisableText(

  Rp: PRastPort;

  const Text: PChar;

  Len: LongWord;

  BackType: LongWord;

  Contrast: LongWord;

  Dri: PDrawInfo

);


EndRefresh

End the optimized refresh state of the window.

Declaration

Source position: intuition.pas line 3863

procedure EndRefresh(

  Window: PWindow;

  Complete: LongBool

);

Arguments

Window | A pointer to the window currently in optimized-refresh mode
Complete | Boolean True or False describing whether or not this window is completely refreshed

Description

This function gets you out of the special refresh state of your window. It is called following a call to BeginRefresh(), which routine puts you into the special refresh state. While your window is in the refresh state, the only rendering that will be wrought in your window will be to those areas which were recently revealed and need to be refreshed.

After you've done all the refreshing you want to do for this window, you should call this routine to restore the window to its non-refreshing state. Then all rendering will go to the entire window, as usual.

The Complete argument is a boolean True or False value used to describe whether or not the refreshing you've done was all the refreshing that needs to be done at this time. Most often, this argument will be True. But if, for instance, you have multiple tasks or multiple procedure calls which must run to completely refresh the window, then each can call its own BeginRefresh()/EndRefresh() pair with a Complete argument of False, and only the last calls with a Complete argument of True.

Warning: Passing this function the value of False has its pitfalls. Please see BeginRefresh().

For your information, this routine calls the Layers library function EndUpdate(), unlocks your layers (calls UnlockLayerRom()), clears the LAYERREFRESH bit in your Layer Flags, and clears the WFLG_WINDOWREFRESH bit in your window Flags.

See also

BeginRefresh | Sets up a window for optimized refreshing.
EndUpdate | remove damage list and restore state of layer to normal.
UnlockLayerRom | Unlock Layer structure by ROM(gfx lib) code.


EndRequest

Remove a currently active requester.

Declaration

Source position: intuition.pas line 3821

procedure EndRequest(

  Requester: PRequester;

  Window: PWindow

);

Arguments

Requester | A pointer to the requester to be removed
Window | A pointer to the Window structure with which this requester is associated

Description

Ends the request by erasing the requester and decoupling it from the window.

Note that this doesn't necessarily clear all requesters from the window, only the specified one. If the window labors under other requesters, they will remain in the window.

See also

InitRequester | Initialize a Requester structure.
Request | Activate a requester.


EndScreenNotify

Declaration

Source position: intuition.pas line 4030

function EndScreenNotify(

  Request: Pointer

):LongBool;


EraseImage

Erases an Image.

Declaration

Source position: intuition.pas line 3911

procedure EraseImage(

  Rp: PRastPort;

  Image: PImage;

  LeftOffset: LongInt;

  TopOffset: LongInt

);

Arguments

Rp | RastPort to erase a part of
Image | Custom or standard image
LeftOffset | Left pixel offsets of Image position
TopOffset | Top pixel offsets of Image position

Description

Erases an Image. For a normal Image structure, this will call the graphics function EraseRect() (clear using layer backfill, if any) for the Image box (LeftEdge/TopEdge/Width/Height).

For custom image, the exact behavior is determined by the custom image class.

See also

EraseRect() | Fill a defined rectangular area using the current BackFill hook.
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.


FindClass

Declaration

Source position: intuition.pas line 3922

function FindClass(

  ClassID: ClassID

):PIClass;


FindMenuKey

Declaration

Source position: intuition.pas line 4007

function FindMenuKey(

  Menu: PMenu;

  Code: LongInt

):LongWord;


FreeClass

Frees a boopsi class created by MakeClass().

Declaration

Source position: intuition.pas line 3929

function FreeClass(

  ClassPtr: PIClass

):LongBool;

Function result

Returns False if the class could not be freed. Reasons include, but will not be limited to, having non-zero cl_ObjectCount or cl_SubclassCount. Returns True if the class could be freed. Calls RemoveClass() for the class in either case.

Description

For class implementors only.

Tries to free a boopsi class created by MakeClass(). This won't always succeed: classes with outstanding objects or with subclasses cannot be freed. You cannot allow the code which implements the class to be unloaded in this case.

For public classes, this function will always remove the class (see RemoveClass() ) making it unavailable, whether it succeeds or not.

If you have a dynamically allocated data for your class (hanging off of cl_UserData), try to free the class before you free the user data, so you don't get stuck with a half-freed class.

Snippet

// Free a public class with dynamic memory in cl_UserData
function freeMyClass(cl: PClass): Boolean;
var
  mpcd: PMyPerClassData;
begin
  Result := False;
  mpcd = PMyPerClassData(cl^.cl_UserData);
  if FreeClass(cl) then
  begin
    FreeMem(mpcd, SizeOf(TMyPerClassData));
    Result := True;
  end;
end;

See also

MakeClass

Create and initialize a boopsi class.


FreeRemember

Free memory allocated by calls to AllocRemember().

Declaration

Source position: intuition.pas line 3870

procedure FreeRemember(

  var RememberKey: PRemember;

  ReallyForget: LongInt

);

Arguments

RememberKey | The address of a pointer to struct Remember. This pointer should either be nil or set to some value (possibly nil) by a call to AllocRemember().
ReallyForget | A LongBool False or True describing, respectively, whether you want to free up only the Remember nodes or if you want this procedure to really forget about all of the memory, including both the nodes and the memory buffers referenced by the nodes.

Description

This function frees up memory allocated by the AllocRemember() function. It will either free up just the Remember structures, which supply the link nodes that tie your allocations together, or it will deallocate both the link nodes AND your memory buffers too.

If you want to deallocate just the Remember structure link nodes, you should set the ReallyForget argument to False. However, if you want FreeRemember() to really deallocate all the memory, including both the Remember structure link nodes and the buffers you requested via earlier calls to AllocRemember(), then you should set the ReallyForget argument to True.

Note well: Once you call this function passing it False, the linkages between all the memory chunks are lost, and you cannot subsequently use FreeRemember() to free them.

See also

AllocRemember | Allocate Memory with tracking to make freeing easy.
ExecFreeMem | Free a memory block with given size

Example

program RememberTest;
uses
  Intuition;
var
  RememberKey: PRemember;
begin
  RememberKey := nil;
  buffer := AllocRemember(@RememberKey, BUFSIZE, MEMF_CHIP);
  if Assigned(buffer) then
  begin
    // Use the buffer
    //...
  end;
  FreeRemember(@RememberKey, True);
end.


FreeScreenBuffer

Free a ScreenBuffer structure.

Declaration

Source position: intuition.pas line 3934

procedure FreeScreenBuffer(

  Sc: PScreen;

  Sb: PScreenBuffer

);

Description

Frees a ScreenBuffer structure you got from AllocScreenBuffer(), and releases associated resources. You must call FreeScreenBuffer() before you close your screen.

Notes:

Originally, FreeScreenBuffer() did not WaitBlit() before freeing a BitMap. The intent was that the application should do this. Application writers should ensure that freeing the buffer is safe by calling WaitBlit() themselves.

The SB_SCREEN_BITMAP flag instructs AllocScreenBuffer() to provide a ScreenBuffer referring to the screen's actual bitmap. When you are done changing screen buffers, you must FreeScreenBuffer() the currently-installed ScreenBuffer before you close the screen. Intuition will recognize when FreeScreenBuffer() is called for the currently-installed ScreenBuffer, and will know to free the supporting structures but not the BitMap. CloseScreen() will take care of that.

See also

AllocScreenBuffer | Get a ScreenBuffer for double-buffering.
ChangeScreenBuffer | Swap the screen's BitMap.
ChangeVPBitMap | Change display memory address for multi-buffered animation


FreeScreenDrawInfo

Finish using a DrawInfo structure.

Declaration

Source position: intuition.pas line 3926

procedure FreeScreenDrawInfo(

  Screen: PScreen;

  DrawInfo: PDrawInfo

);

Arguments

Screen | A pointer to screen passed to GetScreenDrawInfo().
DrawInfo | A pointer to DrawInfo returned by GetScreenDrawInfo(). A nil DrawInfo pointer is a valid parameter, signifying "do nothing".

Description

Declares that you are finished with the DrawInfo structure returned by GetScreenDrawInfo().

This function, and GetScreenDrawInfo(), don't really do much, but they provide an upward compatibility path. That means that if you misuse them today, they probably won't cause a problem, although they may someday later. So, please be very careful only to use the DrawInfo structure between calls to GetScreenDrawInfo() and FreeScreenDrawInfo(), and be sure that you don't forget FreeScreenDrawInfo().

See also

GetScreenDrawInfo

Get pointer to rendering information.


FreeSysRequest

Free resources gotten by a call to BuildSysRequest().

Declaration

Source position: intuition.pas line 3864

procedure FreeSysRequest(

  Window: PWindow

);

Arguments

Window

Value of the window pointer returned by a successful call to the BuildSysRequest() procedure

Description

This routine frees up all memory allocated by a successful call to the BuildSysRequest() procedure. If BuildSysRequest() returned a pointer to a window, then you are able to wait on the message port of that window to detect an event which satisfies the requester. When you want to remove the requester, you call this procedure. It ends the requester and deallocates any memory used in the creation of the requester. It also closes the special window that was opened for your system requester.

See also

BuildSysRequest | Build and display a system requester.
AutoRequest | Automatically build and get response from a requester.
CloseWindow | Close an Intuition window.


FULLMENUNUM

Menu helper macro

Declaration

Source position: intuition.pas line 4058

function FULLMENUNUM(

  menu: SmallInt;

  item: SmallInt;

  sub: SmallInt

):Word;


GadgetBox

Declaration

Source position: intuition.pas line 3957

function GadgetBox(

  Gadget: PGadget;

  Domain: Pointer;

  DomainType: LongWord;

  Flags: LongWord;

  Box: Pointer

):LongWord;


GadgetMouse

Calculate gadget-relative mouse position.

Declaration

Source position: intuition.pas line 3897

procedure GadgetMouse(

  Gadget: PGadget;

  GInfo: PGadgetInfo;

  MousePoint: PSmallInt

);

Arguments

Gadget | A pointer to the Gadget
GInfo | A pointer to a GadgetInfo structure as passed to the custom gadget hook routine.
MousePoint | Address of two Words, or a pointer to a structure of type Point.

Description

Determines the current location of the mouse pointer relative to the upper-left corner of a custom gadget. Typically used only in the GM_HANDLEINPUT and GM_GOACTIVE custom gadget hook routines.

News flash!!: These two hook routines are now passed the mouse coordinates, so this function has no known usefulness.

We recommend that you don't call it.

Note that this function calculates the mouse position taking "gadget relativity" (GFLG_RELRIGHT, GFLG_RELBOTTOM) into consideration. If your custom gadget intends to ignore these properties, then you should either enjoin or inhibit your users from setting those bits, since Intuition won't ask if you respect them.

Errors

This function is useless, because programs which need this information can get it in a cleaner way. It is recommended not to call this function!


GADGET_BOX

Get bounding box of a gadget

Declaration

Source position: intuition.pas line 4062

function GADGET_BOX(

  g: PGadget

):PIBox;


GetAttr

Inquire the value of some attribute of an object.

Declaration

Source position: intuition.pas line 3917

function GetAttr(

  AttrID: LongWord;

  obj: PObject_;

  StoragePtr: PLongWord

):LongWord; overload;

function GetAttr(

  AttrID: LongWord;

  obj: PObject_;

  var Storage: LongWord

):LongWord; overload;

Arguments

AttrID | The attribute tag ID understood by the object's class
StoragePtr | A pointer to appropriate storage for the answer

Function result

Mostly True if the method is supported for the specified attribute and False if it isn't or the attribute can't be read at this time. See the classes documentation for details.

Arguments

AttrID

The attribute tag ID understood by the object's class

Description

Inquires from the specified object the value of the specified attribute.

You always pass the address of a long variable, which will receive the same value that would be passed to SetAttrs() in the ti_Data portion of a TagItem element.

Not all attributes will respond to this function. Those that will are documented on a class-by-class basis.

This function sends OM_GET to the object.

See also

NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
SetAttrs | Varargs Version of SetAttrsA()
MakeClass | Create and initialize a boopsi class.


GetAttrsA

Declaration

Source position: intuition.pas line 3948

function GetAttrsA(

  Object_: PObject_;

  TagList: PTagItem

):LongWord;


GetDefaultPubScreen

Get name of default public screen.

Declaration

Source position: intuition.pas line 3899

procedure GetDefaultPubScreen(

  NameBuffer: PChar

);

Arguments

NameBuffer

A buffer of MAXPUBSCREENNAME. This can be nil.

Description

Provides the name of the current default public screen. Only anticipated use is for Public Screen Manager utilities, since it is easy to open a visitor window on the default public screen without specifying the name.

Note:

Only Public Screen Manager utilities want to use this function since it is easy to open a window on the default public screen without specifying a name.

Also note that if there no default public screen has been set, the return value of this function will be zero, and not a pointer to the Workbench screen.

See also

SetDefaultPubScreen | Choose a new default public screen.
OpenWindow | Open an Intuition window.


GetDefPrefs

Get a copy of the the Intuition default Preferences.

Declaration

Source position: intuition.pas line 3822

function GetDefPrefs(

  Preferences: PPreferences;

  Size: LongInt

):PPreferences;

Arguments

Preferences | A pointer to the memory buffer to receive your copy of the Intuition Preferences structure
Size | The number of bytes in your PrefBuffer, the number of bytes you want copied from the system's internal Preference settings

Function result

Returns your parameter Preferences.

Description

Gets a copy of the Intuition default preferences data. Writes the data into the buffer you specify. The number of bytes you want copied is specified by the size argument.

The default preferences are those that Intuition uses when it is first opened. If no preferences file is found, these are the preferences that are used. These would also be the startup preferences in an AmigaDOS-less environment.

It is legal to take a partial copy of the Preferences structure. The more pertinent preferences variables have been grouped near the top of the structure to facilitate the memory conservation that can be had by taking a copy of only some of the Preferences structure.

See also

GetPrefs | Get the current Intuition Preferences structure.
SetPrefs | Set Intuition preferences data.


GetGUIAttrsA

Declaration

Source position: intuition.pas line 3954

function GetGUIAttrsA(

  Reserved: Pointer;

  DrawInfo: PDrawInfo;

  TagList: PTagItem

):LongWord;


GetHalfPens

Declaration

Source position: intuition.pas line 3956

function GetHalfPens(

  DrawInfo: PDrawInfo;

  BasePen: LongWord;

  HalfShinePtr: PWord;

  HalfShadowPtr: PWord

):LongWord;


GetMarkedBlock

Declaration

Source position: intuition.pas line 3992

function GetMarkedBlock(

  Sgw: PSGWork

):LongWord;


GetPrefs

Get the current Intuition Preferences structure.

Declaration

Source position: intuition.pas line 3823

function GetPrefs(

  Preferences: PPreferences;

  Size: LongInt

):PPreferences;

Arguments

Preferences | A pointer to the memory buffer to receive your copy of the Intuition Preferences
Size | The number of bytes in your PrefBuffer, the number of bytes you want copied from the system's internal Preference settings

Function result

Returns your parameter Preferences.

Description

Gets a copy of the current Intuition Preferences structure. Writes the data into the buffer you specify. The number of bytes you want copied is specified by the size argument.

It is legal to take a partial copy of the Preferences structure. The more pertinent preferences variables have been grouped near the top of the structure to facilitate the memory conservation that can be had by taking a copy of only some of the Preferences structure.

A new and more extensible method for supplying Preferences has been introduced in V36, and relies on file system notification. The Intuition preferences items rely also on the IPrefs program. Certain elements of the Preferences structure have been superseded by this new method. As much as possible, the Preferences structure returned by GetPrefs() reflect the current state of Preferences. However, it is impossible to represent some of the V36-style preferences items using the existing Preferences structure.

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
SetPrefs | Set Intuition preferences data.


GetRenderDomain

Declaration

Source position: intuition.pas line 4018

function GetRenderDomain(

  Rp: PRastPort;

  Domain: PRectangle

):LongWord;


GetScreenAttr

Declaration

Source position: intuition.pas line 3986

function GetScreenAttr(

  Screen: PScreen;

  Attr: LongWord;

  Data: Pointer;

  Size: LongWord

):LongInt;


GetScreenAttrsA

Declaration

Source position: intuition.pas line 3982

function GetScreenAttrsA(

  Screen: PScreen;

  TagList: PTagItem

):LongInt;


GetScreenData

Get copy of a screen data structure.

Declaration

Source position: intuition.pas line 3873

function GetScreenData(

  Buffer: Pointer;

  Size: LongWord;

  Type_: LongWord;

  const Screen: PScreen

):LongBool;

Arguments

Buffer | A pointer to a buffer into which data can be copied
Size | The size of the buffer provided, in bytes
Type_ | The screen type, as specified in OpenWindow() (WBENCHSCREEN_f, CUSTOMSCREEN_f, ...)
Screen | Ignored, unless type is CUSTOMSCREEN_f, which results only in copying 'size' bytes from 'screen' to 'buffer'

Function result

True if successful. False if standard screen of Type 'type' could not be opened.

Description

This function copies into the caller's buffer data from a Screen structure. Typically, this call will be used to find the size, title bar height, and other values for a standard screen, such as the Workbench screen.

To get the data for the Workbench screen, one would call:

GetScreenData(buff, SizeOf(TScreen), WBENCHSCREEN_f, nil);

Note: If the requested standard screen is not open, this function will have the effect of opening it.

This function has been useful for two basic types of things:

  1. Determining information about the Workbench screen, in preparation for opening a window on it.
  2. Attempts at discerning the user's preferences in a working screen, for "cloning" the Workbench modes and dimensions when opening a similar custom screen.

The function LockPubScreen() is an improvement over this function, in that it doesn't copy the screen data but returns a pointer and a guarantee that the screen will not be closed.

If the global public screen SHANGHAI mode is in effect (see SetPubScreenModes()), this function will actually report on the default public screen, where "Workbench" windows will actually open.

This function does some "compatibility tricks" when you inquire about the WBENCHSCREEN_f. To keep programs from "stumbling" into modes they don't understand, and because an NTSC machine may be running a PAL Workbench or PRODUCTIVITY, for example, the following "false" information is returned.

The Screen.ViewPort.Modes field will either be HIRES or HIRES+LACE (with the SPRITES flag also set, as usual). HIRES+LACE is used if the display mode selected for the Workbench screen is an interlaced screen of any type.

The dimensions returned will be the smaller of the OSCAN_TEXT dimensions for the returned mode, and the actual dimensions of the Workbench screen.

Exception: For specific compatibility considerations, if the Workbench is in one of the A2024 modes, the mode returned in Screen.ViewPort.Modes will be HIRES+LACE (with perhaps some "special" bits also set for future improvement), but with dimensions equal to the actual A2024-mode Workbench screen. This will favor programs which open windows on the A2024 Workbench, but will cause some problems for programs which try to "clone" the Workbench screen using this function.

If you want the real information about the modern Workbench screen, call LockPubScreen('Workbench') and acquire its display mode ID by inquiring of the actual ViewPort (using GetVPModeID()).

You may then use the information you get to clone as many of the properties of the Workbench screen that you wish.

In the long run, it's probably better to provide your user with a screen mode selection option, and skip all this.

See also

OpenWindow | Open an Intuition window.
LockPubScreen | Prevent a public screen from closing.
GetVPModeID | Get the 32 bit DisplayID from a ViewPort.
SetPubScreenModes | Establish global public screen behavior.
OpenScreen | Open an Intuition screen


GetScreenDrawInfo

Get pointer to rendering information.

Declaration

Source position: intuition.pas line 3925

function GetScreenDrawInfo(

  Screen: PScreen

):PDrawInfo;

Arguments

Screen

A pointer to a valid, open screen.

Function result

A pointer to a system-allocated DrawInfo structure.

Description

Returns a pointer to a TDrawInfo structure derived from the screen passed. This data structure is Read Only. The field dri_Version identifies which version of TDrawInfo you are given a pointer to.

Note:

Some information in the TDrawInfo structure may in the future be calculated the first time this function is called for a particular screen.

You must call FreeScreenDrawInfo() when you are done using the returned pointer.

This function does not prevent a screen from closing. Apply it only to the screens you opened yourself, or apply a protocol such as LockPubScreen().

WARNING: Until further notice, the pointer returned does not remain valid after the screen is closed.

This function and FreeScreenDrawInfo() don't really do much now, but they provide an upward compatibility path. That means that if you misuse them today, they probably won't cause a problem, although they may someday later. So, please be very careful only to use the TDrawInfo structure between calls to GetScreenDrawInfo() and FreeScreenDrawInfo(), and be sure that you don't forget FreeScreenDrawInfo().

See also

LockPubScreen | Prevent a public screen from closing.
FreeScreenDrawInfo | Finish using a DrawInfo structure.


GetWindowAttr

Declaration

Source position: intuition.pas line 3977

function GetWindowAttr(

  Win: PWindow;

  Attr: LongWord;

  Data: Pointer;

  Size: LongWord

):LongInt;


GetWindowAttrsA

Declaration

Source position: intuition.pas line 3973

function GetWindowAttrsA(

  Win: PWindow;

  TagList: PTagItem

):LongInt;


HelpControl

Enable/disable Gadget-Help feature.

Declaration

Source position: intuition.pas line 3945

procedure HelpControl(

  Win: PWindow;

  Flags: LongWord

);

Arguments

Flags

Currently, HC_GADGETHELP or zero are the allowed values.

Description

This function can be used to turn Gadget-Help on or off for your window. Gadget-Help will also be enabled/disabled accordingly for all other windows which share the same help-group. This allows Gadget-Help to be well-behaved for multiple-window applications.

You must use GetUniqueID() to get a help-group identifier. Never ever supply your own!

See also

WA_HelpGroup | Tag for OpenWindowTagList(). Form Help groups
OpenWindowTagList | OpenWindow() with TagItem extension.


HideWindow

Declaration

Source position: intuition.pas line 3947

function HideWindow(

  Window: PWindow

):LongBool;


ICoerceMethodA

Declaration

Source position: intuition.pas line 3964

function ICoerceMethodA(

  Cl: PIClass;

  Object_: PObject_;

  Msg: TMsg

):LongWord;


IDoMethodA

Declaration

Source position: intuition.pas line 3966

function IDoMethodA(

  Object_: PObject_;

  Msg: TMsg

):LongWord;


IDoSuperMethodA

Declaration

Source position: intuition.pas line 3960

function IDoSuperMethodA(

  Cl: PIClass;

  Object_: PObject_;

  Msg: TMsg

):LongWord;


IM_BGPEN

Set Image Background Pen

Declaration

Source position: intuition.pas line 4059

function IM_BGPEN(

  im: PImage

):Byte;


IM_BOX

Get Image bounding rectangle

Declaration

Source position: intuition.pas line 4060

function IM_BOX(

  im: PImage

):PIBox;


IM_FGPEN

Set Image Foreground pen

Declaration

Source position: intuition.pas line 4061

function IM_FGPEN(

  im: PImage

):Byte;


InitRequester

Initialize a Requester structure.

Declaration

Source position: intuition.pas line 3824

procedure InitRequester(

  Requester: PRequester

);

Arguments

Requester

A pointer to a Requester structure

Description

Initializes a requester for general use. After calling InitRequester, you need fill in only those Requester values that fit your needs. The other values are set to nil--or zero--states.

Note that the example in the early versions of the Intuition Reference Manual is flawed because the Requester structure is initialized before InitRequester is called. Be sure to perform your initialization after calling InitRequester.

Errors

This function is obsolete.


INST_DATA

Finds Object local instance data

Declaration

Source position: intuition.pas line 4049

function INST_DATA(

  cl: PIClass;

  o: P_Object

):Pointer;

Arguments

cl | A pointer to a class
o | A pointer to the object

Function result

a pointer to the instance data local to Cl


IntuiTextExtent

Declaration

Source position: intuition.pas line 4003

function IntuiTextExtent(

  Rp: PRastPort;

  IText: PIntuiText;

  TextExtent: PTextExtent

):LongWord;


IntuiTextLength

Return the length (pixel-width) of an IntuiText.

Declaration

Source position: intuition.pas line 3857

function IntuiTextLength(

  const IText: PIntuiText

):LongInt;

Arguments

IText

A pointer to an instance of an IntuiText structure

Function result

The width of the text in pixels.

Description

This routine accepts a pointer to an instance of an IntuiText structure, and returns the length (the pixel-width) of the string which that instance of the structure represents.

Note: if the Font pointer of your IntuiText structure is set to nil, you'll get the pixel-width of your text in terms of the current system default font. You may wish to be sure that the field IText^.ITextFont for 'default font' text is equal to the Font field of the screen it is being measured for.

See also

OpenScreen

Open an Intuition screen


IntuitionClone

Declaration

Source position: intuition.pas line 3805

function IntuitionClone: PInterface;


IntuitionControlA

Declaration

Source position: intuition.pas line 4026

function IntuitionControlA(

  Object_: Pointer;

  TagList: PTagItem

):LongWord;


IntuitionExpunge

Declaration

Source position: intuition.pas line 3804

procedure IntuitionExpunge;


IntuitionObtain

Declaration

Source position: intuition.pas line 3802

function IntuitionObtain: LongWord;


IntuitionRelease

Declaration

Source position: intuition.pas line 3803

function IntuitionRelease: LongWord;


Intuition_

Declaration

Source position: intuition.pas line 3807

procedure Intuition_(

  iEvent: PInputEvent

);


ISetSuperAttrsA

Declaration

Source position: intuition.pas line 3962

function ISetSuperAttrsA(

  Cl: PIClass;

  Object_: PObject_;

  TagList: PTagItem

):LongWord;


ItemAddress

Returns the address of the specified MenuItem.

Declaration

Source position: intuition.pas line 3825

function ItemAddress(

  const MenuStrip: PMenu;

  MenuNumber: LongWord

):PMenuItem;

Arguments

MenuStrip | A pointer to the first menu in your menu strip
MenuNumber | The value which contains the packed data that selects the menu and item (and sub-item). See the Intuition Reference Manual for information on menu numbers.

Function result

If MenuNumber = MENUNULL, this routine returns nil, else this routine returns the address of the menu item specified by MenuNumber.

Description

This routine feels through the specified menu strip and returns the address of the item specified by the menu number. Typically, you will use this routine to get the address of a menu item from a menu number sent to you by Intuition after user has chosen from a window's menus.

This routine requires that the arguments are well-defined. MenuNumber may be equal to MENUNULL, in which case this routine returns nil. If MenuNumber doesn't equal MENUNULL, it's presumed to be a valid item number selector for your menu strip, which includes:

  • a valid menu number
  • a valid item number
  • if the item specified by the above two components has a sub-item, the menu number may have a sub-item component, too.

Note that there must be both a menu number and an item number. Because a sub-item specifier is optional, the address returned by this routine may point to either an item or a sub-item.


ITEMNUM

Menu helper macro

Declaration

Source position: intuition.pas line 4064

function ITEMNUM(

  n: Word

):Word;


LendMenus

Lend window's menu action to another window.

Declaration

Source position: intuition.pas line 3939

procedure LendMenus(

  FromWindow: PWindow;

  ToWindow: PWindow

);

Arguments

FromWindow | A pointer to the Window structure whose menu actions are to go to another window.
ToWindow | A pointer to the Window structure whose menus are to be displayed in place of the fromWindow's. If nil, turns off menu-lending from the fromWindow.

Description

This function is used to "lend" the menus of one window to another. This means that menu events (for example, the user presses the mouse menu button) will take place in another window's menu (using that other window's menu strip and screen).

The sole intended use of this function is to unify two windows on different screens that are attached. (See SA_Parent, SA_FrontChild, SA_BackChild). An example would be a program with a full-sized parent screen which has a short control panel screen attached in the front. Pressing the menu button even when the control panel window of the canvas screen is active can now cause the menus of the parent screen to appear.

See also

SetMenuStrip | Attach a menu strip to a window.
ClearMenuStrip | Clear (detach) the menu strip from the window.


LockClassList

Declaration

Source position: intuition.pas line 3930

function LockClassList: PList;


LockGUIPrefs

Declaration

Source position: intuition.pas line 3950

function LockGUIPrefs(

  Reserved: LongWord

):Pointer;


LockIBase

Invoke semaphore arbitration of TIntuitionBase.

Declaration

Source position: intuition.pas line 3871

function LockIBase(

  DontKnow: LongWord

):LongWord;

Function result

The result of this function must be passed to UnlockIBase().

Description

Grabs Intuition internal semaphore so that caller may examine TIntuitionBase safely. This function is not a magic "fix all my race conditions" panacea.

The idea here is that you can get the locks Intuition needs before such IntuitionBase fields as ActiveWindow and FirstScreen are changed, or linked lists of windows and screens are changed.

Do Not Get Tricky with this entry point, and do not hold these locks for long, as all Intuition input processing will wait for you to surrender the lock by a call to UnlockIBase().

Note Well: A call to this function must be paired with a subsequent call to UnlockIBase(), and soon, please.

Note Well: Do not call any Intuition functions (nor any graphics, layers, dos, or other high-level system function) while holding this lock.

See also

UnlockIBase

Release a an Intuition lock gotten by LockIBase().


LockPubScreen

Prevent a public screen from closing.

Declaration

Source position: intuition.pas line 3887

function LockPubScreen(

  const Name: PChar

):PScreen;

Arguments

Name

Name string for public screen or NULL for default public screen. The string 'Workbench' indicates the Workbench screen.

Function result

Returns pointer to a screen, if successful, else nil. The call can fail for reasons including that the named public screen doesn't exist or is in private state.

Description

Prevents a public screen (or the Workbench) from closing while you examine it in preparation of opening a visitor window.

The sequence you use to open a visitor window that needs to examine fields in the screen it is about to open on is:

LockPubScreen();
  // ... examine fields ...
  OpenWindow(); //on public screen
  UnlockPubScreen();
  // ... use your window ...
  // CloseWindow();

You needn't hold the "pubscreen lock" for the duration that your window is opened. LockPubScreen() basically has the same effect as an open visitor window: it prevents the screen from being closed.

If you pass the string 'Workbench' or you pass nil and there is no default public screen, the Workbench screen will be automatically opened if it is not already present.

See also

OpenWindow | Open an Intuition window.
UnlockPubScreen | Release lock on a public screen.
GetScreenData | Get copy of a screen data structure.


LockPubScreenList

Prevent changes to the system list.

Declaration

Source position: intuition.pas line 3889

function LockPubScreenList: PList;

Function result

A pointer to the public screen list.

Description

Arbitrates access to public screen list while you quickly make a copy of it for display to the user.

Note that this is intended only for the Public Screen Manager program.

Note:

The nodes on the list are PubScreenNode structures. Act quickly while holding this lock. The restrictions on LockIBase() apply here as well.

See also

UnlockPubScreenList | Release public screen list semaphore.
OpenScreen | Open an Intuition screen


LockScreen

Declaration

Source position: intuition.pas line 3971

function LockScreen(

  Screen: PScreen;

  Micros: LongWord

):LongBool;


LockScreenGI

Declaration

Source position: intuition.pas line 3990

function LockScreenGI(

  gi: PGadgetInfo;

  Micros: LongWord

):PScreen;


LockScreenList

Declaration

Source position: intuition.pas line 3988

function LockScreenList: PScreen;


MakeClass

Create and initialize a boopsi class.

Declaration

Source position: intuition.pas line 3923

function MakeClass(

  const ClassID: ClassID;

  const SuperClassID: ClassID;

  const SuperClassPtr: PIClass;

  InstanceSize: LongWord;

  Flags: LongWord

):PIClass;

Arguments

ClassID | Nil for private classes, the name/ID string for public classes
SuperClassID | Name/ID of your new class's superclass. Nil if superclass is a private class
SuperClassPtr | A pointer to private superclass. Only used if SuperClassID is nil. You are required never to provide a nil superclass.
InstanceSize | The size of the instance data that your class's objects will require, beyond that data defined for your superclass's objects.
Flags | For future enhancement, including possible additional parameters. Provide zero for now.

Function result

A pointer to the resulting class, or nil if not possible: no memory for class data structure, public superclass not found, public class of same name/ID as this one already exists

Description

For class implementors only.

This function creates a new public or private boopsi class. The superclass should be defined to be another boopsi class: all classes are descendants of the class "rootclass".

Superclasses can be public or private. You provide a name/ID for your class if it is to be a public class (but you must have registered your class name and your attribute ID's with Commodore before you do this!). For a public class, you would also call AddClass() to make it available after you have finished your initialization.

Returns pointer to an TIClass data structure for your class. You then initialize the Hook cl_Dispatcher for your class methods code. You can also set up special data shared by all objects in your class, and point cl_UserData at it. The last step for public classes is to call AddClass().

You dispose of a class created by this function by calling FreeClass().

No copy is made of classID. So make sure the lifetime of the contents of classID is at least the same as the lifetime of the class itself.

See also

FreeClass | Frees a boopsi class created by MakeClass().
AddClass | Make a public class available
RemoveClass | Make a public boopsi class unavailable.
NewObject | Varargs version of NewObjectA()


MakeScreen

Do an Intuition-integrated MakeVPort() of a screen.

Declaration

Source position: intuition.pas line 3865

function MakeScreen(

  Screen: PScreen

):LongInt;

Arguments

Screen

Address of the custom screen structure

Function result

Returns zero for success, non-zero for failure. Probable cause of failure is failure of MakeVPort().

Description

This procedure allows you to do a MakeVPort() for the viewport of your custom screen in an Intuition-integrated way. This way you can do your own screen manipulations without worrying about interference with Intuition's usage of the same viewport.

The operation of this function is as follows:

  • Block until the Intuition View structure is not in being changed.
  • Set the view modes correctly to reflect if there is a (visible) interlaced screen.
  • call MakeVPort(), passing the Intuition View and your screen's ViewPort.
  • Unlocks the Intuition View.

After calling this routine, you should call RethinkDisplay() to incorporate the new viewport of your custom screen into the Intuition display.

Note: Intuition may determine that because of a change in global interlace needs that all viewports need to be remade, so it may effectively call RemakeDisplay().

See also

RemakeDisplay |
RethinkDisplay | Grand manipulation of the entire Intuition display.
MakeVPort | Generate display copper list for a viewport.


MENUNUM

Menu helper macro

Declaration

Source position: intuition.pas line 4065

function MENUNUM(

  n: Word

):Word;


ModifyIDCMP

Modify the state of a window's IDCMPFlags.

Declaration

Source position: intuition.pas line 3826

function ModifyIDCMP(

  Window: PWindow;

  Flags: LongWord

):LongBool;

Arguments

Window | A pointer to the Window structure containing the IDCMP ports
Flags | The flag bits describing the new desired state of the IDCMP. (IDCMP_*)

Function result

This function returns False if it was unable to create the necessary message ports.

Description

This routine modifies the state of your window's IDCMP (Intuition Direct Communication Message Port). The state is modified to reflect your desires as described by the flag bits in the value IDCMPFlags.

The four actions that might be taken are:

  • if there is currently no IDCMP in the given window, and IDCMPFlags is zero, nothing happens
  • if there is currently no IDCMP in the given window, and any of the IDCMPFlags is selected (set), then the IDCMP of the window is created, including allocating and initializing the message ports and allocating a signal bit for your port.
  • if the IDCMP for the given window exists, and the IDCMPFlags argument is zero, this says that you want Intuition to close the ports, free the buffers and free your signal bit. You MUST be the same task that was active when this signal bit was allocated (either by ModifyIDCMP() or OpenWindow()).
  • if the IDCMP for the given window is opened, and the IDCMPFlags argument is not zero, this means that you want to change the state of which events will be broadcast to you through the IDCMP

Note: You can set up the Window^.UserPort to any port of your own before you call ModifyIDCMP(). If IDCMPFlags is non-null but your UserPort is already initialized, Intuition will assume that it's a valid port with task and signal data preset and Intuition won't disturb your set-up at all, Intuition will just allocate the Intuition message port half of it. The converse is true as well: if UserPort is nil when you call here with IDCMPFlags = 0, Intuition will deallocate only the Intuition side of the port.

This allows you to use a port that you already have allocated:

  • OpenWindow() with IDCMPFlags equal to 0 (open no ports)
  • set the UserPort variable of your window to any valid port of your own choosing
  • call ModifyIDCMP() with IDCMPFlags set to what you want
  • then, to clean up later, set UserPort equal to nil before calling CloseWindow() (leave IDCMPFlags alone) But first: you must make sure that no messages sent your window are queued at the port, since they will be returned to the memory free pool.

For an example of how to close a window with a shared IDCMP, see the description for CloseWindow().

See also

OpenWindow | Open an Intuition window.
CloseWindow | Close an Intuition window.


ModifyProp

Modify the current parameters of a proportional gadget.

Declaration

Source position: intuition.pas line 3827

procedure ModifyProp(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  Flags: LongWord;

  HorizPot: LongWord;

  VertPot: LongWord;

  HorizBody: LongWord;

  VertBody: LongWord

);

Arguments

Gadget | A pointer to a proportional gadget
Window | A pointer to the window containing the gadget or the window containing the requester containing the gadget.
Requester | A pointer to a requester (may be nil if this isn't a requester gadget)
Flags | Value to be stored in the Flags field of the TPropInfo
HorizPot | Value to be stored in the HorizPot field of the TPropInfo
VertPot | Value to be stored in the VertPot field of the TPropInfo
HorizBody | Value to be stored in the HorizBody field of the TPropInfo
VertBody | Value to be stored in the VertBody field of the TPropInfo

Description

Modifies the parameters of the specified proportional gadget. The gadget's internal state is then recalculated and the imagery is redisplayed in the window or requester that contains the gadget.

The requester variable can point to a requester structure. If the gadget has the GTYP_REQGADGET flag set, the gadget is in a requester and the window pointer must point to the window of the requester. If this is not the gadget of a requester, the requester argument may be nil.

Note: this function causes all gadgets from the proportional gadget to the end of the gadget list to be refreshed, for reasons of compatibility. For more refined display updating, use NewModifyProp().

ModifyProp() refreshing consists of redrawing gadgets completely. NewModifyProp() has changed this behavior.

See also

NewModifyProp

ModifyProp(), but with selective refresh.


MoveScreen

Attempt to move the screen by the increments provided.

Declaration

Source position: intuition.pas line 3828

procedure MoveScreen(

  Screen: PScreen;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Screen | A pointer to a Screen structure
Dx | Amount to move the screen on the x-axis
Dy | Amount to move the screen on the y-axis

Description

Moves the screen the specified increment, specified in screen pixel resolution coordinates.

Screen movement limits have been greatly relaxed, to support screen scrolling. In particular, negative values for screen LeftEdge and TopEdge may now be valid.

If the dX and dY variables you specify would move the screen in a way that violates any restrictions, the screen will be moved as far as possible. You may examine the LeftEdge and TopEdge fields of the Screen structure after this function returns to see where the screen really ended up.

See also

ScreenPosition | Move screens with greater control.
RethinkDisplay | Grand manipulation of the entire Intuition display.


MoveWindow

Ask Intuition to move a window.

Declaration

Source position: intuition.pas line 3829

procedure MoveWindow(

  Window: PWindow;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Window | A pointer to the structure of the Window to be moved
Dx | How far to move the Window on the x-axis
Dy | How far to move the Window on the y-axis

Description

This routine sends a request to Intuition asking to move the window the specified distance. The delta (dX, dY) arguments describe how far to move the window along the respective axes.

Note that the window will not be moved immediately, but rather will be moved the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second.

Interactions with other arbitration of Intuition data structures may defer this operation longer. You can use the IDCMP class IDCMP_CHANGEWINDOW to detect when this operation has completed.

Intuition now will do validity checking on the final position. To send absolute movements, or to move and size a window in one step, use ChangeWindowBox().

See also

ChangeWindowBox | Change window position and dimensions.
SizeWindow | Ask Intuition to size a window.
WindowToFront | Ask Intuition to bring a window to the front.
WindowToBack | Ask Intuition to send a window behind others.


MoveWindowInFrontOf

Arrange the relative depth of a window.

Declaration

Source position: intuition.pas line 3882

procedure MoveWindowInFrontOf(

  Window: PWindow;

  BehindWindow: PWindow

);

Arguments

Window | Window to re-position in front of another window
BehindWindow | Window to re-position in front of

Description

Depth-arranges a window in front of an another window. Brings out the MoveLayerInFrontOf() to the Intuition user.

See also

WindowToFront | Ask Intuition to bring a window to the front.
WindowToBack | Ask Intuition to send a window behind others.
MoveLayerInFrontOf | Put layer in front of another layer.


NewModifyProp

ModifyProp(), but with selective refresh.

Declaration

Source position: intuition.pas line 3880

procedure NewModifyProp(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  Flags: LongWord;

  HorizPot: LongWord;

  VertPot: LongWord;

  HorizBody: LongWord;

  VertBody: LongWord;

  NumGad: LongInt

);

Arguments

Gadget | A pointer to a proportional gadget
Window | A pointer to the window containing the gadget or the window containing the requester containing the gadget.
Requester | A pointer to a requester (may be nil if this isn't a requester gadget)
Flags | Value to be stored in the Flags field of the TPropInfo
HorizPot | Value to be stored in the HorizPot field of the
VertPot | Value to be stored in the VertPot field of the
HorizBody | Value to be stored in the HorizBody field of the
VertBody | Value to be stored in the VertBody field of the
NumGad | Number of gadgets to be refreshed after propgadget internals have been adjusted. -1 means "to end of list."

Description

Performs the function of ModifyProp(), but refreshes gadgets in the list as specified by the NumGad parameter. With NumGad = -1, this function is identical to ModifyProp().

When NumGad = 1, this function will now perform an incremental update of the proportional gadget knob image, rather than refreshing the entire gadget. This means much less flashing when programmatically scrolling a proportional gadget.

See also

ModifyProp

Modify the current parameters of a proportional gadget.


NewObject

Varargs version of NewObjectA()

Declaration

Source position: intuition.pas line 4035

function NewObject(

  ClassPtr: PIClass;

  ClassID: PChar;

  const argv: array of PtrUInt

):Pointer;


NewObjectA

Create an object from a class.

Declaration

Source position: intuition.pas line 3912

function NewObjectA(

  ClassPtr: PIClass;

  const ClassID: ClassID;

  const TagList: PTagItem

):PObject_;

Arguments

ClassPtr | An abstract pointer to a boopsi class gotten via MakeClass().
ClassID | The name/ID string of a public class. This parameter is only used if class is nil.
TagList | A pointer to array of TTagItems containing attribute/value pairs to be applied to the object being created

Function result

A boopsi object, which may be used in different contexts such as a gadget or image, and may be manipulated by generic functions. You eventually free the object using DisposeObject().

Description

This is the general method of creating objects from 'boopsi' classes. ('Boopsi' stands for "basic object-oriented programming system for Intuition".)

You specify a class either as a pointer (for a private class) or by its ID string (for public classes). If the class pointer is nil, then the classID is used.

You further specify initial "create-time" attributes for the object via a TagItem list, and they are applied to the resulting generic data object that is returned. The attributes, their meanings, attributes applied only at create-time, and required attributes are all defined and documented on a class-by-class basis.

This functions send OM_NEW to the dispatcher of the class.

See also

NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
SetAttrs | Varargs Version of SetAttrsA()
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


NextObject

Iterate through the object on an Exec list.

Declaration

Source position: intuition.pas line 3921

function NextObject(

  ObjectPtrPtr: PPObject_

):PObject_;

Arguments

ObjectPtrPtr

The pointer to a variable. This must be the same variable, as long as you iterate though the same list. This variable must initially be filled with the lh_Head of a list.

Function result

Returns pointers to each object in the list in turn, and nil when there are no more.

Description

Use this function to iterate through a list of BOOPSI objects. You may do whatever you want with the object returned, even remove it from the list or dispose it, and then continue to iterate through the list.

When you collect a set of boopsi objects on an Exec List structure by invoking their OM_ADDMEMBER method, you can (only) retrieve them by iterations of this function.

See also

DisposeObject | Deletes a 'boopsi' object.
SetAttrs | Varargs Version of SetAttrsA()
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


NextPubScreen

Identify next public screen in the cycle.

Declaration

Source position: intuition.pas line 3891

function NextPubScreen(

  const Screen: PScreen;

  NameBuf: PChar

):PChar;

Arguments

Screen | A pointer to the public screen your window is open in or nil if you don't have a pointer to a public screen.
NameBuf | A pointer to a buffer with (at least) MAXPUBSCREENNAME + 1 characters to put the name of the next public screen in.

Function result

Returns namebuff or nil if there are no public screens.

Description

Returns name of next public screen in system rotation, to allow visitor windows to provide function to "jump" among public-screens in a cycle.

Notes:

There is no guarantee that the public screen whose name was returned by this function will exist or be in "public" state by the time you call LockPubScreen(), etc. You must handle cases where LockPubScreen(), etc. will fail.

Note that this function may return the name of a public screen which is open but in "private mode" (see PubScreenStatus() and PSNF_PRIVATE).

The cycle order is undefined, so draw no conclusions based on it!

See also

OpenScreen | Open an Intuition screen
PubScreenStatus | Change status flags for a public screen.


ObtainBitMapInstanceA

Declaration

Source position: intuition.pas line 3997

function ObtainBitMapInstanceA(

  BitmapSource: Pointer;

  Screen: PScreen;

  TagList: PTagItem

):Pointer;


ObtainBitMapSourceA

Declaration

Source position: intuition.pas line 3994

function ObtainBitMapSourceA(

  const Name: PChar;

  TagList: PTagItem

):Pointer;


ObtainGIRPort

Set up a RastPort for a custom gadget.

Declaration

Source position: intuition.pas line 3895

function ObtainGIRPort(

  GInfo: PGadgetInfo

):PRastPort;

Arguments

GInfo

A pointer to a GadgetInfo structure, as passed to each custom gadget hook function.

Function result

A pointer to a RastPort that may be used for gadget rendering. This pointer may be nil, in which case you should do no rendering. You may (optionally) pass a nil return value to ReleReleaseGIRPort().

Description

Sets up a RastPort for use (only) by custom gadget hook routines. This function must be called each time a hook routine needing to perform gadget rendering is called, and must be accompanied by a corresponding call to ReleaseGIRPort().

Note that if a hook function passes you a RastPort pointer, e.g., GM_RENDER, you needn't call ObtainGIRPort() in that case.

See also

ReleaseGIRPort

Release a custom gadget RastPort.


ObtainIBackFill

Declaration

Source position: intuition.pas line 4024

function ObtainIBackFill(

  Dri: PDrawInfo;

  Element: LongWord;

  State: LongWord;

  Flags: LongWord

):PHook;


ObtainIPluginList

Declaration

Source position: intuition.pas line 4010

function ObtainIPluginList(

  Type_: LongWord;

  AttrMask: LongWord;

  ApplyMask: LongWord

):PList;


OCLASS

Get class pointer from an object handle

Declaration

Source position: intuition.pas line 4054

function OCLASS(

  o: Pointer

):PIClass;


OffGadget

Disable the specified gadget.

Declaration

Source position: intuition.pas line 3830

procedure OffGadget(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester

);

Arguments

Gadget | A pointer to the gadget that you want disabled
Window | A pointer to a window structure containing the gadget or containing the requester which contains the gadget
Requester | A pointer to a requester (may by nil if this isn't a requester gadget (i.e. GTYP_REQGADGET is not set)).

Description

This command disables the specified gadget. When a gadget is disabled, these things happen:

  • its imagery is displayed ghosted
  • the GFLG_DISABLED flag is set
  • the gadget cannot be selected by User

The window parameter must point to the window which contains the gadget, or which contains the requester that contains the gadget. The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

Note:it's never safe to tinker with the gadget list yourself. Don't supply some gadget that Intuition hasn't already processed in the usual way.

Note: This function will update the gadget (unlike the original function which would update all gadgets in the window).

See also

OnGadget | Enable the specified gadget.
AddGadget | Add a gadget to the gadget list of a window.
RefreshGadgets | Refresh (redraw) the gadget display.


OffMenu

Disable the given menu or menu item.

Declaration

Source position: intuition.pas line 3831

procedure OffMenu(

  Window: PWindow;

  MenuNumber: LongWord

);

Arguments

Window | A pointer to the window
MenuNumber | The menu piece to be disabled

Description

This command disables a sub-item, an item, or a whole menu. This depends on the contents of the data packed into MenuNumber, which is described in the Intuition Reference Manual.

See also

OnMenu | Enable the given menu or menu item.
ResetMenuStrip | Re-attach a menu strip to a window.


OnGadget

Enable the specified gadget.

Declaration

Source position: intuition.pas line 3832

procedure OnGadget(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester

);

Arguments

Gadget | A pointer to the gadget that you want disabled
Window | A pointer to a window structure containing the gadget or containing the requester which contains the gadget
Requester | A pointer to a requester (may by nil if this isn't a requester gadget (i.e. GTYP_REQGADGET is not set)).

Description

This command enables the specified gadget. When a gadget is enabled, these things happen:

  • its imagery is displayed normally (not ghosted)
  • the GFLG_DISABLED flag is cleared
  • the gadget can thereafter be selected by the user

The window parameter must point to the window which contains the gadget, or which contains the requester that contains the gadget The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

Note: it's never safe to tinker with the gadget list yourself. Don't supply some gadget that Intuition hasn't already processed in the usual way.

Note: This function will update the gadget (unlike the original function which would update all gadgets in the window).

See also

OffGadget

Disable the specified gadget.


OnMenu

Enable the given menu or menu item.

Declaration

Source position: intuition.pas line 3833

procedure OnMenu(

  Window: PWindow;

  MenuNumber: LongWord

);

Arguments

Window | A pointer to the window
MenuNumber | The menu piece to be enables

Description

This command enables a sub-item, an item, or a whole menu. This depends on the contents of the data packed into MenuNumber, which is described in the Intuition Reference Manual.

See also

OffMenu | Disable the given menu or menu item.
ResetMenuStrip | Re-attach a menu strip to a window.


OpenClass

Declaration

Source position: intuition.pas line 3968

function OpenClass(

  const Name: PChar;

  Version: LongWord;

  var ClassPtr: PIClass

):LongWord;


OpenGUIPlugin

Declaration

Source position: intuition.pas line 4012

function OpenGUIPlugin(

  Name: PChar;

  Version: LongWord;

  Type_: LongWord;

  AttrMask: LongWord;

  ApplyMask: LongWord

):PGUIPlugin;


OpenIntuition

Declaration

Source position: intuition.pas line 3806

procedure OpenIntuition;


OpenScreen

Open an Intuition screen

Declaration

Source position: intuition.pas line 3834

function OpenScreen(

  const NewScreen: PNewScreen

):PScreen;

Arguments

NewScreen

A pointer to an instance of a NewScreen structure.

Function result

If all is well, returns the pointer to your new screen If anything goes wrong, returns nil, with further error specification in the variable pointed to by the SA_ErrorCode data field.

Description

Opens an Intuition screen according to the specified parameters found in the TNewScreen structure.

Does all the allocations, sets up the screen structure and all substructures completely, and links this screen's viewport into Intuition's View structure.

Before you call OpenScreen(), you must initialize an instance of a NewScreen structure. TNewScreen is a structure that contains all of the arguments needed to open a screen. The TNewScreen structure may be discarded immediately after OpenScreen() returns.

The SHOWTITLE flag is set to True by default when a screen is opened. To change this, you must call the routine ShowTitle().

See also

OpenScreenTagList | OpenScreen() with TagItem extension array.
OpenWindow | Open an Intuition window.
PrintIText | Print text described by the IntuiText argument.
CloseScreen | Close an Intuition screen.
QueryOverscan | Inquire about a standard overscan region.
PubScreenStatus | Change status flags for a public screen.
ModeNotAvailable | Check to see if a DisplayID isn't available.
OpenDiskFont |
GetColorMap | Allocate and initialize Colormap


OpenScreenTagList

OpenScreen() with TagItem extension array.

Declaration

Source position: intuition.pas line 3907

function OpenScreenTagList(

  const NewScreen: PNewScreen;

  const TagList: PTagItem

):PScreen;

Arguments

NewScreen | An optional pointer to a NewScreen structure.
TagList | An optional pointer to (an array of) TagItem structures, terminated by the value TAG_END.

Function result

An open Intuition screen. Check ErrorCode when Screen is returned nil.

Description

Provides an extension to the parameters passed to OpenScreen(). This extensions is in the form of (a pointer to) an array of TagItem structures, which have to fields: ti_Tag, an ID identifying the meaning of the other field, ti_Data.

The tag items can supplement or override the values in NewScreen. In fact, you can pass a nil value of the TNewScreen pointer. For that matter, if you pass nil in both arguments, you'll get a screen with defaults in all fields, including display mode, depth, colors, dimension, title, and so on. We ask that you at least supply a title when you open a screen.

If you need a pointer to the screen's bitmap use Screen^.RastPort.BitMap instead of @(Screen^.BitMap).

If you want DOS requester to appear on your screen you have to do:

process := PProcess(FindTask(nil));
process^.pr_WindowPtr := APTR(window);

The old value of pr_WindowPtr must be reset before you quit your program.

See also

OpenScreen

Open an Intuition screen


OpenScreenTags

Varargs Version of OpenScreenTagList()

Declaration

Source position: intuition.pas line 4033

function OpenScreenTags(

  newScreen: PNewScreen;

  const TagList: array of PtrUInt

):PScreen;


OpenWindow

Open an Intuition window.

Declaration

Source position: intuition.pas line 3835

function OpenWindow(

  const NewWindow: PNewWindow

):PWindow;

Arguments

NewWindow

A pointer to an instance of a NewWindow structure.

Function result

A pointer to the new window or nil if it couldn't be opened. Reasons for this might be lack of memory or illegal attributes.

Description

Opens an Intuition window of the given dimensions and position, with the properties specified in the NewWindow structure. Allocates everything you need to get going.

You can provide extensions to the NewWindow parameters using and array of TagItem structures.

Before you call OpenWindow(), you must initialize an instance of a NewWindow structure. NewWindow is a structure that contains all of the arguments needed to open a window. The NewWindow structure may be discarded immediately after it is used to open the window.

If Type = CUSTOMSCREEN_f, you must have opened your own screen already via a call to OpenScreen(). Then Intuition uses your screen argument for the pertinent information needed to get your window going. On the other hand, if Type = one of the Intuition's standard screens, your screen argument is ignored. Instead, Intuition will check to see whether or not that screen already exists: if it doesn't, it will be opened first before Intuition opens your window in the standard screen.

If you specify Type = WBENCHSCREEN_f, then your window will appear on the Workbench screen, unless the global public screen mode SHANGHAI is set, in which case your window will be "hijacked" to the default public screen. See also SetPubScreenModes().

If the WFLG_NW_EXTENDED flag is set, it means that the field TExtNewWindow.Extension points to an array of TagItems. This provides an extensible means of providing extra parameters to OpenWindow(). For compatibility reasons, we could not add the Extension field to the TNewWindow structure, so we have define a new structure TExtNewWindow, which is identical to TNewWindow with the addition of the Extension field.

We recommend that rather than using TExtNewWindow.Extension, you use the new Intuition function OpenWindowTagList() and its varargs equivalent OpenWindowTags(). We document the window attribute tag ID's (ti_Tag values) here, rather than in OpenWindowTagList(), so that you can find all the parameters for a new window defined in one place.

If the WFLG_SUPER_BITMAP flag is set, the bitmap variable must point to your own bitmap.

See also

CloseWindow | Close an Intuition window.
ModifyIDCMP | Modify the state of a window's IDCMPFlags.


OpenWindowTagList

OpenWindow() with TagItem extension.

Declaration

Source position: intuition.pas line 3905

function OpenWindowTagList(

  const NewWindow: PNewWindow;

  const TagList: PTagItem

):PWindow;

Arguments

NewWindow | A optional pointer to a NewWindow structure.
TagList | A optional pointer to TagItem array, with tag values as described under the description for OpenWindow().

Function result

A newly created window, per your specifications.

Description

A variation of OpenWindow() that allow direct specification of a TagItem array of extension data. Recommended over using the TExtNewWindow.Extension field.

If you omit the NewWindow (pass nil), a set of defaults are used, and overridden by the tag items. Even without any tag items at all, a reasonable window opens on the Workbench or default public screen.

See also

OpenWindow

Open an Intuition window.


OpenWindowTags

Varargs Version of OpenWindowTagList()

Declaration

Source position: intuition.pas line 4034

function OpenWindowTags(

  newWindow: PNewWindow;

  const TagList: array of PtrUInt

):PWindow;


OpenWorkBench

Open the Workbench screen.

Declaration

Source position: intuition.pas line 3836

function OpenWorkBench: LongWord;

Function result

Non-zero if Workbench screen opened successfully, or was already opened. Zero if anything went wrong and the Workbench screen isn't out there.

Description

Tries to (re)open WorkBench screen. If successful return value is a pointer to the screen structure, which shouldn't be used, because other programs may close the WorkBench and make the pointer invalid.

If this function fails the return value is 0.

See also

CloseWorkBench

Closes the Workbench screen.


PointInImage

Tests whether an image "contains" a point.

Declaration

Source position: intuition.pas line 3910

function PointInImage(

  Point: LongWord;

  Image: PImage

):LongBool;

Arguments

Point | Two words, X/Y packed into a LongInt, with high word containing X. This is what you get if you pass a Point structure (not a pointer!).
Image | A pointer to a standard or custom Image data object. Note: If Image is nil, this function returns True.

Function result

Boolean result of the test. True is the point is inside the image, False otherwise.

Description

Tests whether a point is properly contained in an image. The intention of this is to provide custom gadgets a means to delegate "image mask" processing to the Image, where it belongs (superseding things like BOOLMASK). After all, a rounded rect image with a drop shadow knows more about what points are inside it than anybody else should.

For traditional Intuition Images, this routine checks if the point is in the Image box (LeftEdge/RightEdge/Width/Height).


PrintEmbossedDisabledIText

Declaration

Source position: intuition.pas line 4002

procedure PrintEmbossedDisabledIText(

  Rp: PRastPort;

  IText: PIntuiText;

  Left: LongInt;

  Top: LongInt;

  BackType: LongWord;

  Contrast: LongWord;

  Dri: PDrawInfo

);


PrintIText

Print text described by the IntuiText argument.

Declaration

Source position: intuition.pas line 3837

procedure PrintIText(

  Rp: PRastPort;

  const IText: PIntuiText;

  Left: LongInt;

  Top: LongInt

);

Arguments

Rp | The RastPort destination of the text
IText | A pointer to an instance of the structure IntuiText
Left | Left offset of the IntuiText into the RastPort
Top | Top offset of the IntuiText into the RastPort

Description

Prints the IntuiText into the specified RastPort. Sets up the RastPort as specified by the IntuiText values, then prints the text into the RastPort at the IntuiText x/y coordinates offset by the left/top arguments. Note, though, that the IntuiText structure itself may contain further text position coordinates: those coordinates and the Left/TopOffsets are added to obtain the true position of the text to be rendered.

This routine does window layer clipping as appropriate -- if you print text outside of your window, your characters will be clipped at the window's edge, providing you pass your window's (layered) RastPort.

If the NextText field of the IntuiText argument is non-nil, the next IntuiText is rendered as well, and so on until some NextText field is nil.

IntuiText with the ITextFont field nil are displayed in the font of the RastPort. If the RastPort font is also nil, the system default font, as set via the Preferences tool, will be used.


PubScreenStatus

Change status flags for a public screen.

Declaration

Source position: intuition.pas line 3894

function PubScreenStatus(

  Screen: PScreen;

  StatusFlags: LongWord

):LongWord;

Arguments

Screen | A pointer to public screen
StatusFlags | Any of the PSNF_ flags (only PSNF_PRIVATE is currently defined).

Function result

Returns 0 in the lowest order bit of the return value if the screen wasn't public, or because it can not be taken private because visitors are open in it. All other bits in the return code are reserved for future enhancement.

Description

Changes status flags for a given public screen. The only flag bit currently defined is PSNF_PRIVATE. Thus, PubScreenStatus(Screen, PSNF_PRIVATE); makes a screen private, while PubScreenStatus(Screen, 0); makes it public.

Do not apply this function to a screen if your program isn't the screen's "owner", in particular, don't call this function for the Workbench screen.

See also

OpenScreen

Open an Intuition screen


QueryOverscan

Inquire about a standard overscan region.

Declaration

Source position: intuition.pas line 3881

function QueryOverscan(

  DisplayID: LongWord;

  Rect: PRectangle;

  OScanType: LongInt

):LongInt;

Arguments

DisplayID | ID to be queried
Rect | Pointer to struct Rectangle to store result
OScanType | Overscan type OSCAN_*

Function result

0 (False) if the MonitorSpec your NewScreen requests does not exist. Non-zero (True) if it does.

Description

This function fills in a rectangle with one of the system overscan dimensions, scaled appropriately for the mode of the DisplayID it is passed.

System overscan values for OScanType:

OSCAN_TEXT:
completely visible, by user preference. Used for Workbench screen and screen dimensions STDSCREENWIDTH and STDSCREENHEIGHT. Left/Top is always 0,0.
OSCAN_STANDARD:
just beyond visible bounds of monitor, by user preference. Left/Top may be negative.
OSCAN_MAX:
The largest region we can display, and display any smaller region.
OSCAN_VIDEO:
The absolute largest region that the graphics.library can display. This region must be used as-is.

See also

OpenScreen

Open an Intuition screen


RefreshGadgets

Refresh (redraw) the gadget display.

Declaration

Source position: intuition.pas line 3838

procedure RefreshGadgets(

  Gadgets: PGadget;

  Window: PWindow;

  Requester: PRequester

);

Arguments

Gadgets | A pointer to the first in the list of gadgets wanting refreshment
Window | A pointer to the window containing the gadget or its requester
Requester | A pointer to a requester (ignored if gadget is not attached to a requester).

Description

Refreshes (redraws) all of the gadgets in the gadget list starting from the specified gadget.

The window parameter must point to the window which contains the gadget, or which contains the requester that contains the gadget The requester parameter must only be valid if the gadget has the GTYP_REQGADGET flag set, a requirement for all requester gadgets.

The two main reasons why you might want to use this routine are: first, that you've modified the imagery of the gadgets in your display and you want the new imagery to be displayed; secondly, if you think that some graphic operation you just performed trashed the gadgetry of your display, this routine will refresh the imagery for you.

Note that to modify the imagery of a gadget, you must first remove that gadget from the window's gadget list, using RemoveGadget() (or RemoveGList()). After changing the image, border, text (including text for a string gadget), the gadget is replaced in the gadget list (using AddGadget() or AddGList()). Adding gadgets does not cause them to be displayed (refreshed), so this function, or RefreshGList() is typically called.

A common technique is to set or reset the GFLG_SELECTED flag of a Boolean gadget and then call RefreshGadgets() to see it displayed highlighted if and only if GFLG_SELECTED is set. If you wish to do this and be completely proper, you must RemoveGadget(), change the GFLG_SELECTED flag, AddGadget(), and RefreshGadgets(), or the equivalent.

The gadgets argument can be a copy of the FirstGadget variable in the Window structure that you want refreshed: the effect of this will be that all gadgets will be redrawn. However, you can selectively refresh just some of the gadgets by starting the refresh part-way into the list: for instance, redrawing your window non-GTYP_GZZGADGET gadgets only, which you've conveniently grouped at the end of your gadget list.

Even more control is available using the RefreshGList() routine which enables you to refresh a single gadget, or number of your choice.

Note: It's never safe to tinker with the gadget list yourself. Don't supply some gadget list that Intuition hasn't already processed in the usual way.

Snippet

//Refresh all gadgets of a window
RefreshGadgets(Win^.FirstGadget, Win, nil);

See also

RefreshGList | Refresh (redraw) a chosen number of gadgets.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.


RefreshGList

Refresh (redraw) a chosen number of gadgets.

Declaration

Source position: intuition.pas line 3874

procedure RefreshGList(

  Gadgets: PGadget;

  Window: PWindow;

  Requester: PRequester;

  NumGad: LongWord

);

Arguments

Gadgets | A pointer to the first in the list of gadgets wanting refreshment
Window | A pointer to the window containing the gadget or its requester
Requester | A pointer to a requester (ignored if Gadget is not attached to a Requester).
NumGad | Maximum number of gadgets to be refreshed. A value of -1 will cause all gadgets to be refreshed from gadget to the end of the list. A value of -2 will also do this, but if Gadgets points to a Requester Gadget (GTYP_REQGADGET) ALL gadgets in the requester will be refreshed.)

Description

Refreshes (redraws) gadgets in the gadget list starting from the specified gadget. At most NumGad gadgets are redrawn. If NumGad is -1, all gadgets until a terminating nil value in the NextGadget field is found will be refreshed, making this routine a superset of RefreshGadgets().

The Requester parameter can point to a Requester structure. If the first gadget in the list has the GTYP_REQGADGET flag set, the gadget list refers to gadgets in a requester and the pointer must necessarily point to a window. If these are not the gadgets of a requester, the requester argument may be nil.

Be sure to see the RefreshGadgets() function description, as this function is simply an extension of that.

Snippet

// Refresh one gadget
RefreshGList(@Gadget, Win, nil, 1);

// Refresh all gadgets in the window
RefreshGList(Win^.FirstGadget, Win, nil, -1);

See also

RefreshGadgets

Refresh (redraw) the gadget display.


RefreshSetGadgetAttrsA

Declaration

Source position: intuition.pas line 3958

procedure RefreshSetGadgetAttrsA(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  TagList: PTagItem

);


RefreshWindowFrame

Ask Intuition to redraw your window border.

Declaration

Source position: intuition.pas line 3878

procedure RefreshWindowFrame(

  Window: PWindow

);

Arguments

Window

A pointer to a Window structure

Description

Refreshes the border of a window, including title region and all of the window's gadgets.

You may use this call if you wish to update the display of your borders. The expected use of this is to correct unavoidable corruption.


ReleaseBitMapInstance

Declaration

Source position: intuition.pas line 3999

procedure ReleaseBitMapInstance(

  BitmapInstance: Pointer

);


ReleaseBitMapSource

Declaration

Source position: intuition.pas line 3996

procedure ReleaseBitMapSource(

  BitmapSource: Pointer

);


ReleaseGIRPort

Release a custom gadget RastPort.

Declaration

Source position: intuition.pas line 3896

procedure ReleaseGIRPort(

  Rp: PRastPort

);

Arguments

Rp

A pointer to the RastPort returned by ObtainGIRPort(). This pointer can be nil, in which case nothing happens.

Description

The corresponding function to ObtainGIRPort(), it releases arbitration used by Intuition for gadget RastPorts.

See also

ObtainGIRPort

Set up a RastPort for a custom gadget.


ReleaseIBackFill

Declaration

Source position: intuition.pas line 4025

procedure ReleaseIBackFill(

  Hook: PHook

);


ReleaseIPluginList

Declaration

Source position: intuition.pas line 4011

procedure ReleaseIPluginList(

  List: PList

);


RemakeDisplay

Declaration

Source position: intuition.pas line 3866

function RemakeDisplay: LongInt;

Function result

Returns zero for success, non-zero for failure. Probable cause of failure is failure of MakeVPort() or of MrgCop().

Description

This is the big one.

This procedure remakes the entire View structure for the Intuition display. It does the equivalent of MakeScreen() for every screen in the system, and then it calls the internal equivalent of RethinkDisplay().

Warning: This routine can take many milliseconds to run, so do not use it lightly.

Calling MakeScreen() followed by RethinkDisplay() is typically a more efficient method for affecting changes to a single screen's ViewPort.

See also

RethinkDisplay | Grand manipulation of the entire Intuition display.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.
MakeVPort | Generate display copper list for a viewport.
MrgCop | Merge together coprocessor instructions.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.


RemoveClass

Make a public boopsi class unavailable.

Declaration

Source position: intuition.pas line 3928

procedure RemoveClass(

  ClassPtr: PIClass

);

Arguments

ClassPtr

A pointer to public class created by MakeClass(), may be nil.

Description

Makes a public class unavailable for public consumption. It's OK to call this function for a class which is not yet in the internal public class list, or has been already removed.

See also

MakeClass | Create and initialize a boopsi class.
FreeClass | Frees a boopsi class created by MakeClass().
AddClass | Make a public class available


RemoveGadget

Remove a gadget from a window.

Declaration

Source position: intuition.pas line 3839

function RemoveGadget(

  Window: PWindow;

  Gadget: PGadget

):LongWord;

Arguments

Window | A pointer to the window containing the gadget or the requester containing the gadget to be removed.
Gadget | A pointer to the gadget to be removed. The gadget itself describes whether this is a gadget that should be removed from the window or some requester.

Function result

Returns the ordinal position of the removed gadget. If the gadget wasn't found in the appropriate list, or if there are no gadgets in the list, returns $FFFF.

Description

Removes the given gadget from the gadget list of the specified window. Returns the ordinal position of the removed gadget.

If the gadget is in a requester attached the the window, this routine will look for it and remove it if it is found.

If the gadget pointer points to a gadget that isn't in the appropriate list, $FFFF is returned. If there aren't any gadgets in the list, $FFFF is returned. If you remove the 65535th gadget from the list $FFFF is returned.

Note: If one of the gadgets you wish to remove is the active gadget, this routine will wait for the user to release the mouse button before deactivating and removing the gadget.

See also

AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
RemoveGList | Remove a sublist of gadgets from a window.


RemoveGList

Remove a sublist of gadgets from a window.

Declaration

Source position: intuition.pas line 3876

function RemoveGList(

  RemPtr: PWindow;

  Gadget: PGadget;

  NumGad: LongInt

):LongWord;

Arguments

RemPtr | A pointer to the window containing the gadget or the requester containing the gadget to be removed.
Gadget | A pointer to the gadget to be removed. The gadget itself describes whether this is a gadget that should be removed from the window or some requester.
NumGad | Number of gadgets to be removed. If $FFFF, remove all gadgets to end of window gadget list

Function result

Returns the ordinal position of the removed gadget. If the gadget wasn't found in the appropriate list, or if there are no gadgets in the list, returns $FFFF.

Description

Removes Numgad gadgets from the gadget list of the specified window. Will remove gadgets from a requester if the first gadget's GadgetType flag GTYP_REQGADGET is set.

Otherwise identical to RemoveGadget().

Note: Last gadget's NextGadget field is set to nil.

If one of the gadgets you wish to remove is the active gadget, this routine will wait for the user to release the mouse button before deactivating and removing the gadget.

See also

RemoveGadget | Remove a gadget from a window.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.


ReportMouse

Tell Intuition whether to report mouse movement.

Declaration

Source position: intuition.pas line 3840

procedure ReportMouse(

  Flag: LongInt;

  Window: PWindow

);

Arguments

Flag | True (-1) or False (0) value specifying whether to turn this function on or off
Window | A pointer to a Window structure associated with this request

Description

Tells Intuition whether or not to broadcast mouse-movement events to your window when it's the active one. The Boolean value specifies whether to start or stop broadcasting position information of mouse-movement. If the window is the active one, mouse-movement reports start coming immediately afterwards. This same routine will change the current state of the GACT_FOLLOWMOUSE function of a currently-selected gadget too.

Note that calling ReportMouse() when a gadget is selected will only temporarily change whether or not mouse movements are reported while that gadget remains selected; the next time the gadget is selected, its GACT_FOLLOWMOUSE flag is examined anew.

The ReportMouse() function is first performed when OpenWindow() is first called; if the flag WFLG_REPORTMOUSE is included among the options, then all mouse-movement events are reported to the opening task and will continue to be reported until ReportMouse() is called with a Boolean value of FALSE. If WFLG_REPORTMOUSE is not set, then no mouse-movement reports will be broadcast until ReportMouse() is called with a Boolean of True.

Note that the WFLG_REPORTMOUSE flag, as managed by this routine, determines if mouse messages are to be broadcast. Determining how they are to be broadcast is determined by the IDCMP_MOUSEMOVE IDCMPFlag.


ReportMouse1

Declaration

Source position: intuition.pas line 3841

procedure ReportMouse1(

  Window: PWindow;

  Flag: LongInt

);


Request

Activate a requester.

Declaration

Source position: intuition.pas line 3842

function Request(

  Requester: PRequester;

  Window: PWindow

):LongBool;

Arguments

Requester | A pointer to the requester to be displayed.
Window | A pointer to the window into which this requester goes.

Function result

If the requester is successfully opened, True is returned. Otherwise, if the requester could not be opened, False is returned.

Description

Links in and displays a requester into the specified window. This routine ignores the window's IDCMP_REQVERIFY flag.

See also

EndRequest | Remove a currently active requester.
InitRequester | Initialize a Requester structure.


ResetMenuStrip

Re-attach a menu strip to a window.

Declaration

Source position: intuition.pas line 3927

function ResetMenuStrip(

  Window: PWindow;

  Menu: PMenu

):LongBool;

Arguments

Window | A pointer to a Window structure
Menu | A pointer to the first menu in the menu strip

Function result

True always.

Description

This function is simply a "fast" version of SetMenuStrip() that doesn't perform the precalculations of menu page sizes that SetMenuStrip() does.

You may call this function only if the menu strip and all items and sub-items have not changed since the menu strip was passed to SetMenuStrip(), with the following exceptions:

  • You may change the CHECKED flag to turn a checkmark on or off.
  • You may change the ITEMENABLED flag to enable/disable some MenuItem or Menu structures.

In all other ways, this function performs like SetMenuStrip().

The new sequence of events you can use is:

  • OpenWindow()

  • SetMenuStrip()

    zero or more iterations of:

    • ClearMenuStrip()
    • change CHECKED or ITEMENABLED flags
    • ResetMenuStrip()
  • ClearMenuStrip()
  • CloseWindow()

See also

SetMenuStrip | Attach a menu strip to a window.
ClearMenuStrip | Clear (detach) the menu strip from the window.


RethinkDisplay

Grand manipulation of the entire Intuition display.

Declaration

Source position: intuition.pas line 3867

function RethinkDisplay: LongInt;

Function result

Returns zero for success, non-zero for failure. Probable cause of failure is failure of MakeVPort() or of MrgCop().

Description

This function performs the Intuition global display reconstruction. This includes rethinking about all of the ViewPorts and their relationship to one another and reconstructing the entire display based on the results of this rethinking.

Specifically, and omitting many internal details, the operation consists of this:

  • Determine which ViewPorts are invisible and set their VP_HIDE ViewPort Mode flag. VP_HIDE flags are also set for screens that may not be simultaneously displayed with the frontmost.
  • If a change to a viewport height, or changing interlace or monitor scan rates require, MakeVPort() is called for specific screen viewports. After this phase, the intermediate Copper lists for each screen's viewport are correctly set up.
  • MrgCop() and LoadView() are then called to get these Copper lists in action, thus establishing the new state of the Intuition display.

You may perform a MakeScreen() on your Custom Screen before calling this routine. The results will be incorporated in the new display, but changing the interlace ViewPort mode for one screens must be reflected in the Intuition View, which is left to Intuition.

Warning: This routine can take several milliseconds to run, so do not use it lightly.

This routine is substantially changed to support new screen modes. In particular, if screen rearrangement has caused a change in interlace mode or scan rate, this routine will remake the copper lists for each screen's viewport.

See also

RemakeDisplay |
MakeVPort | Generate display copper list for a viewport.
MrgCop | Merge together coprocessor instructions.
LoadView | Use a (possibly freshly created) coprocessor instruction list to create the current display.
MakeScreen | Do an Intuition-integrated MakeVPort() of a screen.


ScreenDepth

Depth arrange a screen with extra control.

Declaration

Source position: intuition.pas line 3936

procedure ScreenDepth(

  Screen: PScreen;

  Flags: LongWord;

  Reserved: Pointer

);

Arguments

Screen | A pointer to the screen to move
Flags | One of SDEPTH_TOFRONT or SDEPTH_TOBACK (bringing the screen to front or back respectively). If the screen is an attached screen, then you may also specify SDEPTH_INFAMILY to move the screen within the screen family. If the screen is an attached screen and SDEPTH_INFAMILY is not specified, then the whole family will move, which is also the behavior of the ScreenToFront() and ScreenToBack() functions, as well as the user-interface controls.
Reserved | Must be nil for now.

Description

Brings the specified screen to the front or back, based on the supplied flags. Also allows control of screen depth-arranging within screen families.

See also

ScreenToFront | Make the specified screen the frontmost.
ScreenToBack | Send the specified screen to the back of the display.
SA_Parent | Tag start for OpenScreenTagList() Pointer to a "parent" screen to attach this one to. Attached screens slide and depth-arrange together.
SA_FrontChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the front of its family.
SA_BackChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the back of its family.


ScreenPosition

Move screens with greater control.

Declaration

Source position: intuition.pas line 3937

procedure ScreenPosition(

  Screen: PScreen;

  Flags: LongWord;

  X1: LongInt;

  Y1: LongInt;

  X2: LongInt;

  Y2: LongInt

);

Arguments

Screen | A pointer to a Screen structure
Flags | Set to one of SPOS_RELATIVE, SPOS_ABSOLUTE, or SPOS_MAKEVISIBLE. You may additionally set SPOS_FORCEDRAG if you need. Use SPOS_RELATIVE (zero) for normal use (move screen a relative amount expressed by x1,y1). Set the SPOS_ABSOLUTE flag if you wish x1 and y1 to be absolute coordinates to move the screen to. Set SPOS_MAKEVISIBLE to position an oversized scrolling screen so that the rectangle described by (x1,y1)-(x2,y2) is on the visible part of the display. (A word-processor may wish to support autoscrolling as the user types. In that case, it could call ScreenPosition() with the SPOS_MAKEVISIBLE flag and a rectangle that encompasses the cursor with some space around it. In addition to any one of the above choices, you can additionally set SPOS_FORCEDRAG if you wish to reposition a screen that was opened with the [SA_Draggable, False] attribute.
X1 | Absolute position or change in position you wish to apply to the screen, when using SPOS_ABSOLUTE or SPOS_RELATIVE.
Y1 | When using SPOS_MAKEVISIBLE, these variables describe the upper-left corner of the rectangle you would like to ensure is on the visible part of a scrolling screen.
X2 | Ignored when using SPOS_ABSOLUTE or SPOS_RELATIVE. When using SPOS_MAKEVISIBLE, these variables describe the lower-right corner of the rectangle you would like to ensure is on the visible part of a scrolling screen.
Y2 | Note that these coordinates are in the same resolution as the screen.

Description

Moves the screen to the specified position or by the specified increment, in screen pixel resolution coordinates.

If the x1 and y1 variables you specify would move the screen in a way that violates any restrictions, the screen will be moved as far as possible. You may examine the LeftEdge and TopEdge fields of the Screen structure after this function returns to see where the screen really ended up.

Note that negative values for screen LeftEdge and TopEdge are valid for screens bigger than their display clip.

See also

MoveScreen | Attempt to move the screen by the increments provided.
RethinkDisplay | Grand manipulation of the entire Intuition display.


ScreenToBack

Send the specified screen to the back of the display.

Declaration

Source position: intuition.pas line 3843

procedure ScreenToBack(

  Screen: PScreen

);

Arguments

Screen

A pointer to a Screen structure

Description

Move a screen behind all other screens. If the screen is in a group, the screen will be moved behind all other screens in the group only. If the screen is the parent of a group, the whole group will be moved in the back.

You will see the screen move behind all other screens. If some screen before this screen occupies the whole display, then it will disappear completely. If all other screens occupy only part of the display, the screen will appear behind the screens.

See also

ScreenToFront | Make the specified screen the frontmost.
ScreenDepth | Depth arrange a screen with extra control.


ScreenToFront

Make the specified screen the frontmost.

Declaration

Source position: intuition.pas line 3844

procedure ScreenToFront(

  Screen: PScreen

);

Arguments

Screen

A pointer to a Screen structure

Description

Move a screen in front of all other screens. If the screen is in a group, the screen will be moved in front of all other screens in the group only. If the screen is the parent of a group, the whole group will be moved in the front.

You will see the screen move in front of all other screens.

See also

ScreenToBack | Send the specified screen to the back of the display.
ScreenDepth | Depth arrange a screen with extra control.


ScrollWindowRaster

Scrolls the content of the rectangle

Declaration

Source position: intuition.pas line 3938

procedure ScrollWindowRaster(

  Win: PWindow;

  Dx: LongInt;

  Dy: LongInt;

  XMin: LongInt;

  YMin: LongInt;

  XMax: LongInt;

  YMax: LongInt

);

Arguments

Win | A pointer to a Window structure
Dx | May be postive, zero, or negative
Dy | May be postive, zero, or negative
XMin | Left of bounding rectangle
YMin | Upper of bounding rectangle
XMax | Right of bounding rectangle
YMax | Lower of bounding rectangle

Description

Calls ScrollRasterBF(), which moves the bits in the raster by (dx,dy) towards (0,0) The space vacated is filled by calling EraseRect().

Note: that vacated space is not considered damage! The scroll operation is limited to the rectangle defined by (xmin,ymin)-(xmax,ymax). Bits outside will not be affected. If (xmax,ymax) is outside the rastport then use the lower right corner of the rastport.

If a window is partly obscured, then it is possible for ScrollWindowRaster() to scroll some of the obscured area into view. If the window is simple-refresh, then the formerly obscured area is damage, and the application needs to repair it. If Intuition detects damage as a result of ScrollWindowRaster(), it will send an IDCMP_REFRESHWINDOW event to the application's window. This handling of damage is the principal reason ScrollWindowRaster() is preferred to ScrollRaster() and ScrollRasterBF().

Note: This call uses ScrollRasterBF(), which calls EraseRect() when clearing the newly exposed area. This allows use of a custom layer backfill hook.

Important: boopsi gadgets should use ScrollRaster() or ScrollRasterBF() directly! Never call ScrollWindowRaster() from inside a boopsi gadget's method handler. Note that Intuition will detect and handle damage caused by such use of ScrollRaster() or ScrollRasterBF(), for gadgets with the GMORE_SCROLLRASTER property.

VERY IMPORTANT: if you have any gadgets in your simple-refresh window with the GMORE_SCROLLRASTER property, you must use ScrollWindowRaster() instead of ScrollRaster() or ScrollRasterBF(). Handling of gadget scroll damage is incompatible with continued use of these graphics functions in an Intuition window. NB: If you're using a gadget class whose source code you do not control, that class might be using GMORE_SCROLLRASTER or might start to in a future version. For that reason, you should use ScrollWindowRaster() if you are using any such gadgets.

See also

ScrollRaster() | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle.
ScrollRasterBF() | Push bits in rectangle in raster around by dx,dy towards 0,0 inside rectangle. Newly empty areas will be filled via EraseRect().
EraseRect() | Fill a defined rectangular area using the current BackFill hook.
WA_BackFill | Tag for OpenWindowTagList(). BackFill hook


SetAttrs

Varargs Version of SetAttrsA()

Declaration

Source position: intuition.pas line 4036

function SetAttrs(

  obj: Pointer;

  const Tags: array of PtrUInt

):LongWord;


SetAttrsA

Specify attribute values for an object.

Declaration

Source position: intuition.pas line 3915

function SetAttrsA(

  obj: PObject_;

  const TagList: PTagItem

):LongWord;

Arguments

TagList

Array of TagItem structures with attribute/value pairs.

Function result

The object does whatever it wants with the attributes you provide. The return value tends to be non-zero if the changes would require refreshing gadget imagery, if the object is a gadget.

Description

Specifies a set of attribute/value pairs with meaning as defined by a 'boopsi' object's class.

This function does not provide enough context information or arbitration for boopsi gadgets which are attached to windows or requesters. For those objects, use SetGadgetAttrsA().

Note: This function invokes the OM_SET method with a nil GadgetInfo parameter.

See also

SetAttrs | Varargs Version of SetAttrsA()
NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


SetDefaultPubScreen

Choose a new default public screen.

Declaration

Source position: intuition.pas line 3892

procedure SetDefaultPubScreen(

  const Name: PChar

);

Arguments

Name

name of chosen public screen to be the new default. A value of nil means that the Workbench screen is to be the default public screen.

Description

Establishes a new default public screen for visitor windows.

This screen is used by windows asking for a named public screen that doesn't exist and the faqllback option is selected, and for windows asking for the default public screen directly.

See also

OpenWindow | Open an Intuition window.
OpenScreen | Open an Intuition screen


SetDisplayBeepHook

Declaration

Source position: intuition.pas line 3970

function SetDisplayBeepHook(

  Hook: PHook

):PHook;


SetDMRequest

Set the DMRequest of a window.

Declaration

Source position: intuition.pas line 3845

function SetDMRequest(

  Window: PWindow;

  Requester: PRequester

):LongBool;

Arguments

Window | The window from which the DMRequest is to be set
Requester | A pointer to the requester

Function result

True if old DMRequest was not in use and therefore changed to the new one, or False if the old DMRequest was in use and could not be set to the new one.

Description

A DMRequest is a requester that appears if the user double-clicks with the menu button. The new DMRequest will only be set if the old DMRequest is not in use. The official way to change the DMRequest is to call ClearDMRequest() until it returns True and then call SetDMRequest().

Note: If the DMRequest has the POINTREL flag set, the DMR will show up as close to the pointer as possible. The RelLeft/Top fields are used to fine-tune the positioning.

See also

ClearDMRequest | Clear (detaches) the DMRequest of the window.
Request | Activate a requester.


SetEditHook

Set global processing for string gadgets.

Declaration

Source position: intuition.pas line 3884

function SetEditHook(

  Hook: PHook

):PHook;

Arguments

Hook

A pointer to a struct Hook which determines a function in your code to be called every time the user types a key. This is done before control is passed to the gadget custom editing hook, so affects all string gadgets.

Function result

Returns previous global edit hook structure. You may need this hook if you wish to invoke the previous edit hook's behavior in addition to your own.

Description

Sets new global editing hook for string gadgets.

Warning: The use and integration of this function has not been explored, and thus should be considered a risky function. Do not use this in a commercial product until further notice.

There are a few key differences between a global edit hook and the more famililar per-gadget StringExtend->EditHook field. In the case of the latter, the hook's creator supplies a WorkBuffer. Intuition's idea of the result of a keystroke is stored in the SGWork structure (which references the WorkBuffer). The state of the gadget before Intuition's hook acted is available in the TStringInfo.Buffer, .BufferPos, and .NumChars fields.

In the case of a global editing hook, your hook becomes Intuition's hook, which affects all gadgets, most of which do not have a WorkBuffer. This means that if you invoke Intuition's original hook (which you got as the result of this function), there isn't any easy way for you to "undo" that after the fact. This means that if Intuition's behavior for certain keystrokes is incompatible with your hook's objectives, then you must avoid calling Intuition's hook for those keys. One approach is to run through your hook's code first, acting on those keys you wish to recognize. Then, call Intuition's hook for those keys you do not recognize, or for those keys whose default actions you wish to add to.

Do not forget to set SGA_REDISPLAY when needed, and please be sure to give the TSGWork^.EditOp field a value which is as meaningful as possible.

Currently, only SGH_KEY messages are sent to the global edit hook, though custom edit hooks do receive SGH_CLICK messages in addition.

Finally, there is currently no arbitration between a global edit hook and a custom edit hook as to ownership of keystrokes. It would be fair to expect that a custom edit hook would be written to match the current Intuition edit hook. If your global edit hook acts on (say) up and down arrow keystrokes, an undesirable result may occur if some string gadget's custom hook also acts on these keystrokes. There is currently no easy way to resolve this issue.


SetGadgetAttrs

Varargs Version of SetGadgetAttrsA()

Declaration

Source position: intuition.pas line 4037

function SetGadgetAttrs(

  gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  const argv: array of PtrUInt

):LongWord;


SetGadgetAttrsA

Specify attribute values for a boopsi gadget.

Declaration

Source position: intuition.pas line 3919

function SetGadgetAttrsA(

  Gadget: PGadget;

  Window: PWindow;

  Requester: PRequester;

  const TagList: PTagItem

):LongWord;

Arguments

Gadget | An abstract pointer to a boopsi gadget
Window | A window gadget has been added to using AddGList() or AddGadget()
Requester | For GTYP_REQGADGETs, requester containing the gadget
TagList | An array of TagItem structures with attribute/value pairs.

Function result

The object does whatever it wants with the attributes you provide, which might include updating its gadget visuals. The return value tends to be non-zero if the changes would require refreshing gadget imagery, if the object is a gadget.

Description

Same as SetAttrsA(), but provides context information and arbitration for classes which implement custom Intuition gadgets.

You should use this function for boopsi gadget objects which have already been added to a requester or a window, or for "models" which propagate information to gadget already added.

Typically, the gadgets will refresh their visuals to reflect changes to visible attributes, such as the value of a slider, the text in a string-type gadget, the selected state of a button.

You can use this as a replacement for SetAttrsA(), too, if you specify nil for the Window and Requester parameters.

Notes:

This function invokes the OM_SET method with a GadgetInfo derived from the Window and Requester pointers.

See also

SetGadgetAttrs | Varargs Version of SetGadgetAttrsA()
NewObject | Varargs version of NewObjectA()
DisposeObject | Deletes a 'boopsi' object.
GetAttr | Inquire the value of some attribute of an object.
MakeClass | Create and initialize a boopsi class.


SetGUIAttrsA

Declaration

Source position: intuition.pas line 3952

function SetGUIAttrsA(

  Reserved: Pointer;

  DrawInfo: PDrawInfo;

  TagList: PTagItem

):LongWord;


SetIPrefs

Declaration

Source position: intuition.pas line 3898

function SetIPrefs(

  Ptr: Pointer;

  Size: LongInt;

  Type_: LongInt

):Pointer;


SetMarkedBlock

Declaration

Source position: intuition.pas line 3993

procedure SetMarkedBlock(

  Sgw: PSGWork;

  Block: LongWord

);


SetMenuStrip

Attach a menu strip to a window.

Declaration

Source position: intuition.pas line 3846

function SetMenuStrip(

  Window: PWindow;

  Menu: PMenu

):LongBool;

Arguments

Window | The window to add the MenuStrip to
Menu | The menu to be added to the window above.

Function result

True if all menus have at least one menuitem.

Description

Attaches the menu strip to the window. After calling this routine, if the user presses the menu button, this specified menu strip will be displayed and accessible by the user.

Menus with zero menu items are not allowed.

Note: You should always design your menu strip changes to be a two-way operation, where for every menu strip you add to your window you should always plan to clear that strip sometime. Even in the simplest case, where you will have just one menu strip for the lifetime of your window, you should always clear the menu strip before closing the window. If you already have a menu strip attached to this window, the correct procedure for changing to a new menu strip involves calling ClearMenuStrip() to clear the old first.

The sequence of events should be:

  • OpenWindow()

  • zero or more iterations of:

    • SetMenuStrip()
    • ClearMenuStrip()
  • CloseWindow()

See also

ResetMenuStrip | Re-attach a menu strip to a window.
ClearMenuStrip | Clear (detach) the menu strip from the window.


SetMouseQueue

Change limit on pending mouse messages.

Declaration

Source position: intuition.pas line 3885

function SetMouseQueue(

  Window: PWindow;

  QueueLength: LongWord

):LongInt;

Arguments

Window | Your window
QueueLength | The new value of outstanding mouse movement messages you wish to allow.

Function result

-1 if Window is not known Otherwise the previous value of the queue limit. The corresponding function for changing the repeat key queue limit is not yet implemented.

Description

Change the number of mouse messages for your window to be allowed to be outstanding.

See also

OpenWindow

Open an Intuition window.


SetPointer

Specify a pointer sprite image for a window.

Declaration

Source position: intuition.pas line 3847

procedure SetPointer(

  Window: PWindow;

  Pointer_: PWord;

  Height: LongInt;

  Width: LongInt;

  XOffset: LongInt;

  yOffset: LongInt

);

Arguments

Window | A pointer to the window to receive this pointer definition
Pointer_ | A pointer to the data definition of a sprite
Height | The height of the pointer
Width | The width of the sprite (must be less than or equal to sixteen)
XOffset | The offset for your sprite from the mouse position
yOffset | The offset for your sprite from the mouse position

Description

Sets up the window with the sprite definition for the pointer. Then, whenever the window is the active one, the pointer image will change to the window's version. If the window is the active one when this routine is called, the change takes place immediately.

The XOffset and YOffset parameters are used to offset the upper-left corner of the hardware sprite image from what Intuition regards as the current position of the pointer. Another way of describing it is as the offset from the "hot spot" of the pointer to the top-left corner of the sprite. For instance, if you specify offsets of zero, zero, then the top-left corner of your sprite image will be placed at the mouse position. On the other hand, if you specify an XOffset of -7 (remember, sprites are 16 pixels wide) then your sprite will be centered over the mouse position. If you specify an XOffset of -15, the right-edge of the sprite will be over the mouse position.

See also

SetWindowPointerA | Select a pointer for your window.
ClearPointer | Clear the mouse pointer definition from a window.


SetPrefs

Set Intuition preferences data.

Declaration

Source position: intuition.pas line 3856

function SetPrefs(

  const Preferences: PPreferences;

  Size: LongInt;

  Inform: LongInt

):PPreferences;

Arguments

Size | The number of bytes of the buffer you want to be copied.
Inform | If True, all windows with IDCMP_NEWPREFS IDCMPFlags set get an IDCMP_NEWPREFS message.

Function result

Returns your parameter buffer.

Description

Sets new preferences values. Copies the first Size bytes from your preferences buffer to the system preferences table, and puts them into effect.

The Inform parameter, if True, indicates that an IDCMP_NEWPREFS message is to be sent to all windows that have the IDCMP_NEWPREFS IDCMPFlags set.

It is legal to set a partial copy of the Preferences structure. The most frequently changed values are grouped at the beginning of the Preferences structure.

Note: A new and more extensible method for supplying Preferences has been introduced, and relies on file system notification. The Intuition preferences items rely also on the IPrefs program. Certain elements of the Preferences structure have been superseded by this new method. (Elements are generally superseded as new hardware or software features demand more information than fits in struct Preferences. Parts of struct Preferences must be ignored so that applications calling GetPrefs(), modifying some other part of struct Preferences, then calling SetPrefs(), don't end up truncating the extended data).

Pointer Preferences: Only the pointer from the initial SetPrefs() (i.e. devs:system-configuration) is heeded.

Palette Preferences: Color changes submitted through SetPrefs() are ignored after the first time IPrefs sends Intuition new style palette preferences.

FontHeight and LaceWB: These are only respected from devs:system-configuration.

View centering and size: Changes to ViewX/YOffset and Row/ColumnSizeChange only apply to the default monitor (NTSC or PAL), and not to other monitors such as Productivity.

Other fields may be superseded in the future.

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetPrefs | Get the current Intuition Preferences structure.


SetPubScreenModes

Establish global public screen behavior.

Declaration

Source position: intuition.pas line 3893

function SetPubScreenModes(

  Modes: LongWord

):LongWord;

Arguments

Modes

new global modes flags.

Function result

Previous global mode settings

Description

Sets GLOBAL Intuition public screen modes. Values for flag bits are:

SHANGHAI:
workbench windows are to be opened on the default public screen
POPPUBSCREEN:
when a visitor window is opened, the public screen it opens on is to be brought to the front.

See also

OpenScreen

Open an Intuition screen


SetRenderDomain

Declaration

Source position: intuition.pas line 4017

function SetRenderDomain(

  Rp: PRastPort;

  Domain: PRectangle

):LongWord;


SetScreenAttr

Declaration

Source position: intuition.pas line 3987

function SetScreenAttr(

  Screen: PScreen;

  Attr: LongWord;

  Data: Pointer;

  Size: LongWord

):LongInt;


SetScreenAttrsA

Declaration

Source position: intuition.pas line 3984

function SetScreenAttrsA(

  Screen: PScreen;

  TagList: PTagItem

):LongInt;


SetScreenBitMapInstance

Declaration

Source position: intuition.pas line 4006

function SetScreenBitMapInstance(

  Scr: PScreen;

  ID: LongWord;

  Source: Pointer

):LongWord;


SetWindowAttr

Declaration

Source position: intuition.pas line 3978

function SetWindowAttr(

  Win: PWindow;

  Attr: LongWord;

  Data: Pointer;

  Size: LongWord

):LongInt;


SetWindowAttrsA

Declaration

Source position: intuition.pas line 3975

function SetWindowAttrsA(

  Win: PWindow;

  TagList: PTagItem

):LongInt;


SetWindowPointer

Varargs Version of SetWindowPointerA()

Declaration

Source position: intuition.pas line 4039

procedure SetWindowPointer(

  Win: PWindow;

  const Tags: array of PtrUInt

);


SetWindowPointerA

Select a pointer for your window.

Declaration

Source position: intuition.pas line 3942

procedure SetWindowPointerA(

  Win: PWindow;

  const Taglist: PTagItem

);

Arguments

Win | A pointer to the window to receive this pointer definition
Taglist | A pointer to a taglist describing your pointer

Description

Allows you to set the pointer image associated with the specified window. Whenever the window is the active one, the pointer image will change to the window's version. If the window is the active one when this routine is called, the change takes place immediately.

Tags:

The same three tags are also accepted by OpenWindowTagList(), which allows you to establish the initial pointer at the time you open your window.

WA_Pointer (APTR)
The pointer you wish to associate with your window. If nil, you are requesting the Preferences default pointer. Custom pointers should be allocated by performing a NewObject() on "pointerclass". Defaults to nil.
WA_BusyPointer (LongBool)
Set to True to request the Preferences busy-pointer. If False, your pointer will be as requested by WA_Pointer. Defaults to False.
WA_PointerDelay (LongBool)
Set to True to defer changing your pointer for a brief instant. This is typically used along with setting the busy pointer, especially when the application knows it may be busy for a very short while. If the application clears the pointer or sets another pointer before the delay expires, the pending pointer change is cancelled. This reduces short flashes of the busy pointer.

Snippet

This example sets the standard busy pointer with pointer-delay, does a bit of work, then clears the pointer:

// Put up the busy pointer, with pointer-delay
SetWindowPointer(Win,
   [WA_BusyPointer, True,
    WA_PointerDelay, True,
    TAG_DONE]);
// Do busy stuff here
  // No tags means "clear the pointer"
SetWindowPointer(Win, [TAG_DONE]);

See also

SetWindowPointer | Varargs Version of SetWindowPointerA()
SetPointer | Specify a pointer sprite image for a window.
ClearPointer | Clear the mouse pointer definition from a window.


SetWindowTitles

Set the window's titles for both window and screen.

Declaration

Source position: intuition.pas line 3848

procedure SetWindowTitles(

  Window: PWindow;

  const WindowTitle: PChar;

  const ScreenTitle: PChar

);

Arguments

Window | A pointer to your window structure
WindowTitle | A pointer to a null-terminated text string, or set to either the value of -1 (negative one) or 0 (zero). If you specify a string, this string is not copied.
ScreenTitle | A pointer to a null-terminated text string, or set to either the value of -1 (negative one) or 0 (zero). If you specify a title for the screen, this title will be shown when the window becomes active. If you specify a string, this string is not copied.

Description

Allows you to set the text which appears in the Window and/or Screen title bars.

The window title appears at all times along the window title bar. The window's screen title appears at the screen title bar whenever this window is the active one.

When this routine is called, your window title will be changed immediately. If your window is the active one when this routine is called, the screen title will be changed immediately.

You can specify a value of -1 (i.e. PByte($FF)) for either of the title pointers. This designates that you want Intuition to leave the current setting of that particular title alone, and modify only the other one. Of course, you could set both to -1.

Furthermore, you can set a value of nil for either of the title pointers. Doing so specifies that you want no title to appear (the title bar will be blank).

Both of the titles are rendered in the default font of the window's screen, as set using OpenScreen().

In setting the window's title, Intuition may do some other rendering in the top border of your window. If your own rendering sometimes appears in your window border areas, you may want to restore the entire window border frame. The function SetWindowTitles() does not do this in the newer versions. The function RefreshWindowFrame() is provided to do this kind of thing for you.

Note:You should be careful with specifying a screen title because that may irritate the user.

See also

OpenWindow | Open an Intuition window.
RefreshWindowFrame | Ask Intuition to redraw your window border.
OpenScreen | Open an Intuition screen


ShadeRectA

Declaration

Source position: intuition.pas line 4021

function ShadeRectA(

  Rp: PRastPort;

  MinX: LongInt;

  MinY: LongInt;

  MaxX: LongInt;

  MaxY: LongInt;

  ShadeLevel: LongWord;

  BackType: LongWord;

  State: LongWord;

  Dri: PDrawInfo;

  TagList: PTagItem

):LongWord;


ShadeRectOld

Declaration

Source position: intuition.pas line 4004

function ShadeRectOld(

  Rp: PRastPort;

  MinX: LongInt;

  MinY: LongInt;

  MaxX: LongInt;

  MaxY: LongInt;

  ShadeLevel: LongWord;

  BackType: LongWord;

  State: LongWord;

  Dri: PDrawInfo

):LongWord;


SHIFTITEM

Menu helper macro

Declaration

Source position: intuition.pas line 4055

function SHIFTITEM(

  n: SmallInt

):Word;


SHIFTMENU

Menu helper macro

Declaration

Source position: intuition.pas line 4056

function SHIFTMENU(

  n: SmallInt

):Word;


SHIFTSUB

Menu helper macro

Declaration

Source position: intuition.pas line 4057

function SHIFTSUB(

  n: SmallInt

):Word;


ShowTitle

Set the screen title bar display mode.

Declaration

Source position: intuition.pas line 3849

procedure ShowTitle(

  Screen: PScreen;

  ShowIt: LongInt

);

Arguments

Screen | A pointer to a Screen structure
ShowIt | A Boolean: True or False describing whether to show or hide the screen title bar

Description

This routine sets the SHOWTITLE flag of the specified screen, and then coordinates the redisplay of the screen and its windows.

The screen title bar can appear either in front of or behind WFLG_BACKDROP windows. This is contrasted with the fact that non-WFLG_BACKDROP windows always appear in front of the screen title bar. You specify whether you want the screen title bar to be in front of or behind the screen's WFLG_BACKDROP windows by calling this routine.

The ShowIt argument should be set to either True or False. If True, the screen's title bar will be shown in front of WFLG_BACKDROP windows.

If False, the title bar will be rendered behind all windows.

When a screen is first opened, the default setting of the SHOWTITLE flag is True.


SHOWTITLE_F

Flag for TScreen.Flags. This gets set by a call to ShowTitle()

Declaration

Source position: intuition.pas line 2009

const SHOWTITLE_F = $0010;


ShowWindow

Declaration

Source position: intuition.pas line 3946

function ShowWindow(

  Window: PWindow;

  Other: PWindow

):LongBool;


SIZEOF_INSTANCE

Sizeof the instance data for a given class

Declaration

Source position: intuition.pas line 4050

function SIZEOF_INSTANCE(

  cl: PIClass

):LongInt;


SizeWindow

Ask Intuition to size a window.

Declaration

Source position: intuition.pas line 3850

procedure SizeWindow(

  Window: PWindow;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Window | A pointer to the structure of the window to be sized
Dx | A signed value describing how much to size the window on the x-axis
Dy | A signed value describing how much to size the window on the y-axis

Description

This routine sends a request to Intuition asking to size the window the specified amounts. The delta arguments describe how much to size the window along the respective axes.

Note that the window will not be sized immediately, but rather will be sized the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second. You can discover when you window has finally been sized by setting the IDCMP_NEWSIZE flag of the IDCMP of your window.

Intuition now will do validity checking on the final dimensions. To change to new absolute dimensions, or to move and size a window in one step, use ChangeWindowBox().

However, limit checking against window MinWidth, MinHeight, MaxWidth, and MaxHeight was not done prior to V36, and these fields are still ignored (as documented) if you have no sizing gadget (WFLG_SIZEGADGET is not set). The are respected if WFLG_SIZEGADGET is set.

You can determine when the change in size has taken effect by receiving the IDCMP_CHANGEWINDOW IDCMP message.

See also

ChangeWindowBox | Change window position and dimensions.
MoveWindow | Ask Intuition to move a window.
WindowToFront | Ask Intuition to bring a window to the front.
WindowToBack | Ask Intuition to send a window behind others.


StartScreenNotifyTagList

Declaration

Source position: intuition.pas line 4028

function StartScreenNotifyTagList(

  TagList: PTagItem

):Pointer;


StripIntuiMessages

Declaration

Source position: intuition.pas line 3979

procedure StripIntuiMessages(

  Port: PMsgPort;

  Win: PWindow

);


SUBNUM

Menu helper macro

Declaration

Source position: intuition.pas line 4066

function SUBNUM(

  n: Word

):Word;


SysReqHandler

Handle system requester input.

Declaration

Source position: intuition.pas line 3904

function SysReqHandler(

  Window: PWindow;

  IDCMPPtr: PLongWord;

  WaitInput: LongInt

):LongInt;

Arguments

Window | Window pointer returned from BuildSysRequest(). Those functions can also return values 0 or 1, and these values may also be passed to SysReqHandler(), which will immediately return the same value.
WaitInput | Specifies that you want SysReqHandler() to to wait for IDCMP input if there is none pending.

Function result

0, 1, ..., N = Successive GadgetID values, for the gadgets you specify for the requester. NOTE: The numbering from left to right is actually: 1, 2, ..., N, 0. This is for compatibility with AutoRequests which has FALSE for the rightmost gadget.

-1 = Means that one of the caller-supplied IDCMPFlags occurred. The IDCMPFlag value is in the longword pointed to by IDCMPFlagsPtr.

-2 = input processed did not satisfy the requester. One example is a keystroke that does not satisfy the requester. Another example is if there is no input pending and you specified False for WaitInput.

Description

Handles input for a window returned by either BuildSysRequest(). These functions with SysReqHandler() you can perform an "asynchronous" EasyRequest() or AutoRequest(). That is to say, you can perform other processing while you wait for the requester to be satisfied.

Each time this function is called, it will process all IDCMPMessages that the window has received. If the parameter WaitInput is non-zero, SysReqHandler() will wait for input (by calling WaitPort()) if there are no IDCMP messages.

SysReqHandler() returns the same values as EasyRequest(): A gadget ID greater than equal to 0, and -1 if one of the other IDCMP events were received.

An additional value of -2 is returned if the input processed does not satisfy the requester. In this case, you might perform some processing and call SysReqHandler() again.

Note: this function does not terminate the system request. Not only must you call FreeSysRequest() to eliminate the request, but you may also continue processing after an event which would normally terminate a normal call to EasyRequest().

Snippet

Implementation of EasyRequest input loop:

Window := BuildEasyRequest(...);
while SysReqHandler(Window, IDCMP_Ptr, True) = -2 do
begin
 // loop
end;
FreeSysRequest(Window);

Errors

Gadget placing is still untidy. Does not support BuildSysRequest() requesters, yet.

See also

WaitPort | Wait for a given port to be non-empty
BuildSysRequest | Build and display a system requester.


TimedDisplayAlert

Display an alert with automatic time-out.

Declaration

Source position: intuition.pas line 3944

function TimedDisplayAlert(

  AlertNumber: LongWord;

  const String_: PChar;

  Height: LongWord;

  Time: LongWord

):LongBool;

Arguments

AlertNumber | The number of this alert message. The only pertinent bits of this number are the ALERT_TYPE bit(s). The rest of the number is ignored by this routine.
String_ | A pointer to the alert message string, as described above
Height | Minimum display lines required for your message
Time | Length of time the alert should wait for the user to respond. This time is the number of video frames the alert should remain up for.

Function result

A LongBool value of True or False. If this is a DEADEND_ALERT, False is always the return value. If this is a RECOVERY_ALERT. The return value will be True if the user presses the left mouse button in response to your message, and False if the user presses the right hand button is response to your text, or if the alert could not be posted. If the alert times out, the return value will be False.

Description

This function is equivalent to DisplayAlert(), except that if the user fails to respond in a given time, the alert comes down automatically.

See also

DisplayAlert

Create the display of an alert message.


UnlockClassList

Declaration

Source position: intuition.pas line 3931

procedure UnlockClassList;


UnlockGUIPrefs

Declaration

Source position: intuition.pas line 3951

procedure UnlockGUIPrefs(

  Lock: Pointer

);


UnlockIBase

Release a an Intuition lock gotten by LockIBase().

Declaration

Source position: intuition.pas line 3872

procedure UnlockIBase(

  IBLock: LongWord

);

Description

Calling this function when you do not own the specified lock will immediately crash the system.

See also

LockIBase

Invoke semaphore arbitration of TIntuitionBase.


UnlockPubScreen

Release lock on a public screen.

Declaration

Source position: intuition.pas line 3888

procedure UnlockPubScreen(

  const Name: PChar;

  Screen: PScreen

);

Arguments

Name | A pointer to name of public screen. If Name is nil, then argument Screen is used as a direct pointer to a public screen.
Screen | A pointer to a public screen. Used only if Name is nil. This pointer must have been returned by LockPubScreen(). It is safe to call UnlockPubScreen() with nil Name and Screen (the function will have no effect).

Description

Releases lock gotten by LockPubScreen(). It is best to identify the locked public screen by the pointer returned from LockPubScreen(). To do this, supply a nil Name pointer and the screen pointer.

In rare circumstances where it would be more convenient to pass a non-nil pointer to the public screen name string, the Screen parameter is ignored.

See also

LockPubScreen

Prevent a public screen from closing.


UnlockPubScreenList

Release public screen list semaphore.

Declaration

Source position: intuition.pas line 3890

procedure UnlockPubScreenList;

Description

Releases lock gotten by LockPubScreenList().


UnlockScreen

Declaration

Source position: intuition.pas line 3972

procedure UnlockScreen(

  Screen: PScreen

);


UnlockScreenGI

Declaration

Source position: intuition.pas line 3991

procedure UnlockScreenGI(

  gi: PGadgetInfo;

  Rp: PRastPort

);


UnlockScreenList

Declaration

Source position: intuition.pas line 3989

procedure UnlockScreenList;


ViewAddress

Return the address of the Intuition View structure.

Declaration

Source position: intuition.pas line 3851

function ViewAddress: PView;

Function result

Returns the address of the Intuition View structure

Description

Returns the address of the Intuition View structure. If you want to use any of the graphics, text, or animation primitives in your window and that primitive requires a pointer to a view, this routine will return the address of the view for you.


ViewPortAddress

Return the address of a window's viewport.

Declaration

Source position: intuition.pas line 3852

function ViewPortAddress(

  const Window: PWindow

):PViewPort;

Arguments

Window

A pointer to the window for which you want the viewport address

Function result

Returns the address of the Intuition ViewPort structure for your window's screen.

Description

Returns the address of the viewport associated with the specified window. The viewport is actually the viewport of the screen within which the window is displayed. If you want to use any of the graphics, text, or animation primitives in your window and that primitive requires a pointer to a viewport, you can use this call.

This pointer is only valid as long as your window's screen remains open, which is ensured by keeping your window open.


WBenchToBack

Send the Workbench screen in back of all screens.

Declaration

Source position: intuition.pas line 3858

function WBenchToBack: LongBool;

Function result

If the Workbench screen was opened, this function returns True, otherwise it returns False.

Description

Causes the Workbench screen, if it's currently opened, to go behind all other screens. This does not 'move' the screen up or down, instead only affects the depth-arrangement of the screens.

See also

ScreenToBack | Send the specified screen to the back of the display.
ScreenToFront | Make the specified screen the frontmost.
WBenchToFront | Bring the Workbench screen in front of all screens.


WBenchToFront

Bring the Workbench screen in front of all screens.

Declaration

Source position: intuition.pas line 3859

function WBenchToFront: LongBool;

Function result

If the Workbench screen was opened, this function returns True, otherwise it returns False.

Description

Causes the Workbench Screen, if it's currently opened, to come to the foreground. This does not 'move' the screen up or down, instead only affects the depth-arrangement of the screen.

See also

ScreenToBack | Send the specified screen to the back of the display.
ScreenToFront | Make the specified screen the frontmost.
WBenchToBack | Send the Workbench screen in back of all screens.


WindowLimits

Set the minimum and maximum limits of a window.

Declaration

Source position: intuition.pas line 3855

function WindowLimits(

  Window: PWindow;

  WidthMin: LongInt;

  HeightMin: LongInt;

  WidthMax: LongWord;

  HeightMax: LongWord

):LongBool;

Arguments

Window | A pointer to a Window structure
WidthMin | The new limits for the size of this window. If any of these is set to zero, it will be ignored and that setting will be unchanged.

Function result

Returns True if everything was in order. If any of the parameters was out of range (minimums greater than current size, maximums less than current size), False is returned and the errant limit request is not fulfilled (though the valid ones will be).

Description

Sets the minimum and maximum limits of the window's size. Until this routine is called, the window's size limits are equal to the initial values established in the OpenWindow() function.

After a call to this routine, the Window will be able to be sized to any dimensions within the specified limits.

If you don't want to change any one of the dimensions, set the limit argument for that dimension to zero. If any of the limit arguments is equal to zero, that argument is ignored and the initial setting of that parameter remains undisturbed.

If any of the arguments is out of range (minimums greater than the current size, maximums less than the current size), that limit will be ignored, though the others will still take effect if they are in range. If any are out of range, the return value from this procedure will be False. If all arguments are valid, the return value will be True.

If you want your window to be able to become "as large as possible" you may put -1 (i.e. not 0) in either or both Max arguments. But please note: screen sizes may vary for several reasons, and you must be able to handle any possible size of window you might end up with if you use this method. Note that you can use the function LockPubScreen() to find out how big the screen your window will appear in is. You may also refer to the WScreen field in your window structure, providing that your window remains open, which will ensure that the screen remains open, and thus the pointer remains valid.

If the user is currently sizing this window, the new limits will not take effect until after the sizing is completed.

See also

LockPubScreen

Prevent a public screen from closing.


WindowToBack

Ask Intuition to send a window behind others.

Declaration

Source position: intuition.pas line 3853

procedure WindowToBack(

  Window: PWindow

);

Arguments

Window

A pointer to the structure of the window to be sent to the back

Description

This routine sends a request to Intuition asking to send the window in back of all other windows in the screen.

Note that the window will not be depth-arranged immediately, but rather will be arranged the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second.

Remember that WFLG_BACKDROP windows cannot be depth-arranged.

See also

MoveWindow | Ask Intuition to move a window.
SizeWindow | Ask Intuition to size a window.
WindowToFront | Ask Intuition to bring a window to the front.
MoveWindowInFrontOf | Arrange the relative depth of a window.


WindowToFront

Ask Intuition to bring a window to the front.

Declaration

Source position: intuition.pas line 3854

procedure WindowToFront(

  Window: PWindow

);

Arguments

Window

A pointer to the structure of the window to be brought to front

Description

This routine sends a request to Intuition asking to bring the window in front of all other windows in the screen.

Note that the window will not be depth-arranged immediately, but rather will be arranged the next time Intuition receives an input event, which happens currently at a minimum rate of ten times per second, and a maximum of sixty times a second.

Remember that WFLG_BACKDROP windows cannot be depth-arranged.

See also

MoveWindow | Ask Intuition to move a window.
SizeWindow | Ask Intuition to size a window.
WindowToBack | Ask Intuition to send a window behind others.
MoveWindowInFrontOf | Arrange the relative depth of a window.


ZipWindow

Change window to "alternate" position and dimensions.

Declaration

Source position: intuition.pas line 3886

procedure ZipWindow(

  Window: PWindow

);

Arguments

Window

Window to be changed.

Description

Changes the position and dimension of a window to the values at the last occasion of ZipWindow being called (or invoked via the "zoom" gadget).

Typically this is used to snap between a normal, large, working dimension of the window to a smaller, more innocuous position and dimension.

Like MoveWindow(), SizeWindow(), and ChangeWindowBox(), the action of this function is deferred to the Intuition input handler.

More tuning needs to be done to establish initial values for the first invocation of this function for a window. You can provide initial values using the OpenWindowTagList() tag item WA_Zoom.

It could also use a new name, but "ZoomWindow" is misleading, since "Zoom" normally implies "scale."

The zoom gadget will appear (in the place of the old "toback" gadget) when you open your window if you either specify a sizing gadget or use WA_Zoom.

You can detect that this function has taken effect by receiving an IDCMP_CHANGEWINDOW IDCMP message.


_OBJ

convenient typecast to P_Object

Declaration

Source position: intuition.pas line 4052

function _OBJ(

  o: P_Object

):P_Object;


__OBJECT

Get back to object data struct from public handle

Declaration

Source position: intuition.pas line 4053

function __OBJECT(

  o: Pointer

):P_Object;


Reference for unit 'keymap': Procedures and functions

AskKeyMapDefault

CloseKeyMapHandle

KeymapClone

KeyMapControlTagList

KeymapExpunge

KeymapObtain

KeymapRelease

MapANSI

MapRawKey

ObtainKeyMapInfoA

ObtainRawKeyInfoA

OpenKeyMapHandleA

ReleaseKeyMapInfoA

SetKeyMapDefault


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'keymap': Variables

KeymapBase


Index of all identifiers in unit 'keymap'

A C D I K M O P R S T

A

AskKeyMapDefault

C

CloseKeyMapHandle

D

DP_2DFACSHIFT | DPB_DEAD | DPF_DEAD
DP_2DINDEXMASK | DPB_MOD | DPF_MOD

I

IKeymap

K

KCB_ALT | KCF_SHIFT | KEYMAPINFO_INFOTEXT_LOCAL
KCB_CONTROL | KCF_STRING | KEYMAPINFO_KEYMAPNODE
KCB_DEAD | KC_NOQUAL | KEYMAPINFO_PC_ONLY
KCB_DOWNUP | KC_VANILLA | KEYMAPINFO_SETCHARSET
KCB_NOP | KeymapBase | KEYMAPINFO_SETCLASSICKEYBOARD
KCB_SHIFT | KeymapClone | KEYMAPNAME
KCB_STRING | KeyMapControlTagList | KeymapObtain
KCF_ALT | KeymapExpunge | KeymapRelease
KCF_CONTROL | KEYMAPINFO_CLASSIC_ONLY | KMCTRL_GetAltAmigaSwap
KCF_DEAD | KEYMAPINFO_GETCLASSICKEYBOARD | KMCTRL_SetAltAmigaSwap
KCF_DOWNUP | KEYMAPINFO_INFOTEXT_CHARSET |
KCF_NOP | KEYMAPINFO_INFOTEXT_ENGLISH |

M

MapANSI MapRawKey

O

ObtainKeyMapInfoA ObtainRawKeyInfoA OpenKeyMapHandleA

P

PKeyMap PKeymapNode PKeyMapResource

R

RAWKEY_BACKSPACE | RAWKEY_F6 | RAWKEY_RCOMMAND
RAWKEY_BREAK | RAWKEY_F7 | RAWKEY_RETURN
RAWKEY_CAPSLOCK | RAWKEY_F8 | RAWKEY_RSHIFT
RAWKEY_CRSRDOWN | RAWKEY_F9 | RAWKEY_SPACE
RAWKEY_CRSRLEFT | RAWKEY_HELP | RAWKEY_TAB
RAWKEY_CRSRRIGHT | RAWKEY_HOME | ReleaseKeyMapInfoA
RAWKEY_CRSRUP | RAWKEY_INSERT | RKI_GET_EXT_RAWKEY
RAWKEY_DEL | RAWKEY_LALT | RKI_GET_FLAGS
RAWKEY_END | RAWKEY_LCOMMAND | RKI_GET_NAME
RAWKEY_ENTER | RAWKEY_LCTRL | RKI_GET_PS2_SET1
RAWKEY_ESC | RAWKEY_LSHIFT | RKI_GET_PS2_SET2
RAWKEY_F1 | RAWKEY_MEDIA_NEXT_TRACK | RKI_GET_RAWKEY
RAWKEY_F10 | RAWKEY_MEDIA_PLAY_PAUSE | RKI_GET_USB
RAWKEY_F11 | RAWKEY_MEDIA_PREV_TRACK | RKI_SET_TYPE
RAWKEY_F12 | RAWKEY_MEDIA_REPEAT | RKI_SET_VALUE
RAWKEY_F13 | RAWKEY_MEDIA_SHUFFLE | RKITYPE_EXT_RAWKEY
RAWKEY_F14 | RAWKEY_MEDIA_STOP | RKITYPE_PS2_SET1
RAWKEY_F15 | RAWKEY_MENU | RKITYPE_PS2_SET2
RAWKEY_F2 | RAWKEY_PAGEDOWN | RKITYPE_RAWKEY
RAWKEY_F3 | RAWKEY_PAGEUP | RKITYPE_USB
RAWKEY_F4 | RAWKEY_PRINTSCR | RKITYPE_USB_UPCODE
RAWKEY_F5 | RAWKEY_RALT |

S

SetKeyMapDefault

T

TKeyMap TKeyMapNode TKeyMapResource


AskKeyMapDefault

Declaration

Source position: keymap.pas line 198

function AskKeyMapDefault: PKeyMap;


CloseKeyMapHandle

Declaration

Source position: keymap.pas line 203

procedure CloseKeyMapHandle(

  Handle: Pointer

);


KeymapClone

Declaration

Source position: keymap.pas line 196

function KeymapClone: PInterface;


KeyMapControlTagList

Declaration

Source position: keymap.pas line 210

function KeyMapControlTagList(

  const TagList: PTagItem

):Pointer;


KeymapExpunge

Declaration

Source position: keymap.pas line 195

procedure KeymapExpunge;


KeymapObtain

Declaration

Source position: keymap.pas line 193

function KeymapObtain: LongWord;


KeymapRelease

Declaration

Source position: keymap.pas line 194

function KeymapRelease: LongWord;


MapANSI

Declaration

Source position: keymap.pas line 200

function MapANSI(

  TheString: PChar;

  Count: LongInt;

  Buffer: PChar;

  Length: LongInt;

  KeyMap: PKeyMap

):LongInt;


MapRawKey

Declaration

Source position: keymap.pas line 199

function MapRawKey(

  Event: PInputEvent;

  Buffer: PChar;

  Length: LongInt;

  KeyMap: PKeyMap

):SmallInt;


ObtainKeyMapInfoA

Declaration

Source position: keymap.pas line 204

function ObtainKeyMapInfoA(

  Handle: Pointer;

  const TagList: PTagItem

):Pointer;


ObtainRawKeyInfoA

Declaration

Source position: keymap.pas line 208

function ObtainRawKeyInfoA(

  const TagList: PTagItem

):Pointer;


OpenKeyMapHandleA

Declaration

Source position: keymap.pas line 201

function OpenKeyMapHandleA(

  const Filename: PChar;

  const TagList: PTagItem

):Pointer;


ReleaseKeyMapInfoA

Declaration

Source position: keymap.pas line 206

function ReleaseKeyMapInfoA(

  Handle: Pointer;

  const TagList: PTagItem

):Pointer;


SetKeyMapDefault

Declaration

Source position: keymap.pas line 197

procedure SetKeyMapDefault(

  KeyMap: PKeyMap

);


Reference for unit 'layers': Procedures and functions

AllocClipRect
BeginUpdate | Prepare to repair damaged layer.
BehindLayer | Put layer behind other layers.
ChangeLayerAlpha
ChangeLayerShape
ComposeLayersA
CreateBackFillHookA
CreateBehindHookLayer | Create a new layer behind all existing layers, using supplied callback BackFill hook.
CreateBehindLayer | Create a new layer behind all existing layers.
CreateLayerA
CreateUpfrontHookLayer | Create a new layer on top of existing layers, using supplied callback BackFill hook.
CreateUpfrontLayer | Create a new layer on top of existing layers.
DeleteBackFillHook
DeleteLayer | delete layer from layer list.
DisposeLayerInfo | Return all memory for LayerInfo to memory pool
DoHookClipRects | Do the given hook for each of the ClipRects
EndUpdate | remove damage list and restore state of layer to normal.
FattenLayerInfo | convert 1.0 LayerInfo to 1.1 LayerInfo Obsolete
FreeClipRect
GetBackFillHookAttrsA
GetLayerInfoAttrsA
GetOffScreenLayerBitMap
HideLayer
InitLayers | Initialize Layer_Info structure Obsolete
InstallClipRegion | Install clip region in layer
InstallLayerHook | safely install a new TLayer.BackFill hook
InstallLayerInfoHook | Install a backfill hook for non-layer
LayerOccluded
LayersClone
LayersExpunge
LayersObtain
LayersRelease
LockLayer | Lock layer to make changes to ClipRects.
LockLayerInfo | Lock the LayerInfo structure.
LockLayers | lock all layers from graphics output.
MoveLayer | Move layer to new position in BitMap.
MoveLayerInFrontOf | Put layer in front of another layer.
MoveSizeLayer | Position/Size layer
NewLayerInfo | Allocate and Initialize full Layer_Info structure.
ScrollLayer | Scroll around in a superbitmap, translate coordinates in non-superbitmap layer.
SetBackFillHookAttrsA
SetForegroundAlpha
SetLayerInfoAttrsA
SetLayerInfoBounds
SetLayerOpaqueness
SetLayerOverlayRect
ShowLayer
SizeLayer | Change the size of this nonbackdrop layer.
SortLayerCR |
SwapBitsRastPortClipRect | Swap bits between common bitmap and obscured ClipRect
ThinLayerInfo | convert 1.1 LayerInfo to 1.0 LayerInfo. Obsolete
UnlockLayer | Unlock layer and allow graphics routines to use it.
UnlockLayerInfo | Unlock the LayerInfo structure.
UnlockLayers | Unlock all layers from graphics output. Restart graphics output to layers that have been waiting
UpfrontLayer | Put layer in front of all other layers.
WhichLayer | Which Layer is this point in?


Unit 'layers' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'layers': Variables

ILayers

LayersBase


Index of all identifiers in unit 'layers'

A B C D E F G H I L M N P S T U W

A

AllocClipRect ALPHA_PREFIX

B

BeginUpdate | BFHA_BPen | BFHA_OffsetY
BehindLayer | BFHA_DrMd | BFHA_PatSize
BFHA_APen | BFHA_Height | BFHA_Pattern
BFHA_BitMap | BFHA_OffsetX | BFHA_Width

C

ChangeLayerAlpha | CreateBackFillHookA | CreateLayerA
ChangeLayerShape | CreateBehindHookLayer | CreateUpfrontHookLayer
ComposeLayersA | CreateBehindLayer | CreateUpfrontLayer

D

DeleteBackFillHook | DisposeLayerInfo
DeleteLayer | DoHookClipRects

E

EndUpdate

F

FattenLayerInfo FreeClipRect

G

GetBackFillHookAttrsA GetLayerInfoAttrsA GetOffScreenLayerBitMap

H

HideLayer

I

ILayers | InstallClipRegion | InstallLayerInfoHook
InitLayers | InstallLayerHook |

L

LAYA_AlphaClips | LAYERBACKDROP | LayersExpunge
LAYA_AlphaHook | LAYER_BACKMOST | LAYERSIMPLE
LAYA_Backdrop | LAYERBACKUP | LAYERSMART
LAYA_BackFillHook | LAYER_CLIPRECTS_LOST | LAYERSNAME
LAYA_Behind | LAYER_FRONTMOST | LAYERS_NOBACKFILL
LAYA_BitMap | LAYERHIDDEN | LayersObtain
LAYA_Flags | LAYERINFO_BackFillHook | LayersRelease
LAYA_Hidden | LAYERINFO_Bounds | LAYERSTAYTOP
LAYA_InFrontOf | LAYERINFO_ComposeHook | LAYERSUPER
LAYA_MaxX | LAYERINFO_ComposeLock | LAYERUPDATING
LAYA_MaxY | LAYERINFO_OffScreenBitMap | LCM_COMPOSE
LAYA_MinX | LAYERIREFRESH | LCM_DAMAGE
LAYA_MinY | LAYERIREFRESH2 | LIF_COLLECTONLY
LAYA_Opaqueness | LAYERMOVECHANGESSHAPE | LIF_EXTLBOUNDS
LAYA_Padding | LayerOccluded | LIF_IGNORE
LAYA_ShapeHook | LAYEROFFSCREEN | LIF_OFFSCREEN
LAYA_ShapeRegion | LAYERREFRESH | LIF_OPTIMIZE
LAYA_SimpleRefresh | LAYERSAVEBACK | LIF_SYNCALWAYS
LAYA_SmartRefresh | LAYERS_BACKFILL | LIF_SYNCCOMPOSE
LAYA_StayTop | LayersBase | LockLayer
LAYA_SuperBitMap | LayersClone | LockLayerInfo
LAYA_Window | LAYERS_DUMMY | LockLayers

M

MoveLayer MoveLayerInFrontOf MoveSizeLayer

N

NewLayerInfo NEWLAYERINFO_CALLED

P

PBackFillMessage PLayerComposeMsg PLayer_Info

S

ScrollLayer | SetLayerInfoBounds | SizeLayer
SetBackFillHookAttrsA | SetLayerOpaqueness | SortLayerCR
SetForegroundAlpha | SetLayerOverlayRect | SwapBitsRastPortClipRect
SetLayerInfoAttrsA | ShowLayer |

T

TBackFillMessage | TLayerComposeMsg
ThinLayerInfo | TLayer_Info

U

UnlockLayer | UnlockLayers
UnlockLayerInfo | UpfrontLayer

W

WhichLayer


AllocClipRect

Declaration

Source position: layers.pas line 191

function AllocClipRect(

  Li: PLayer_Info

):PClipRect;


BeginUpdate

Prepare to repair damaged layer.

Declaration

Source position: layers.pas line 163

function BeginUpdate(

  L: PLayer

):LongInt;

Arguments

L

pointer to a layer

Function result

True if damage list converted to ClipRect list successfully. False if list conversion aborted. (probably out of memory)

Description

Convert damage list to ClipRect list and swap in for programmer to redraw through. This routine simulates the ROM library environment. The idea is to only render in the "damaged" areas, saving time over redrawing all of the layer. The layer is locked against changes made by the layer library.

Errors

If BeginUpdate returns False, programmer must abort the attempt to refresh this layer and instead call EndUpdate(Layer, False) to restore original ClipRect and damage list.

See also

EndUpdate

remove damage list and restore state of layer to normal.


BehindLayer

Put layer behind other layers.

Declaration

Source position: layers.pas line 159

function BehindLayer(

  Dummy: LongInt;

  Layer: PLayer

):LongInt;

Arguments

Dummy | unused
Layer | Pointer to a layer

Function result

True - if operation successful. False - if operation unsuccessful (probably out of memory)

Description

Move this layer to the most behind position swapping bits in and out of the display with other layers. If other layers are REFRESH then collect their damage lists and set the LAYERREFRESH bit in the Flags fields of those layers that may be revealed. If this layer is a backdrop layer then put this layer behind all other backdrop layers. If this layer is not a backdrop layer then put in front of the top backdrop layer and behind all other layers.

Attention

This operation may generate refresh events in other layers associated with this layer's TLayer_Info structure.


ChangeLayerAlpha

Declaration

Source position: layers.pas line 210

function ChangeLayerAlpha(

  L: PLayer;

  Clips: PClipRect;

  Hook: PHook

):PClipRect;


ChangeLayerShape

Declaration

Source position: layers.pas line 195

function ChangeLayerShape(

  Layer: PLayer;

  Region: PRegion;

  Hook: PHook

):PRegion;


ComposeLayersA

Declaration

Source position: layers.pas line 203

function ComposeLayersA(

  L: PLayer;

  Rect: PRectangle;

  TagList: PTagItem

):LongWord;


CreateBackFillHookA

Declaration

Source position: layers.pas line 196

function CreateBackFillHookA(

  TList: PTagItem

):PHook;


CreateBehindHookLayer

Create a new layer behind all existing layers, using supplied callback BackFill hook.

Declaration

Source position: layers.pas line 182

function CreateBehindHookLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Hook: PHook;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Hook | BackFill callback Hook
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) Make this layer of type found in flags. Install Layer->BackFill callback Hook. If SuperBitMap, use bm2 as pointer to real SuperBitMap, and copy contents of Superbitmap into display layer. If this layer is a backdrop layer then place it behind all other layers including other backdrop layers. If this is not a backdrop layer then place it behind all nonbackdrop layers.

Attention

When using bm2 SuperBitmap, you should also set LAYERSMART flag.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


CreateBehindLayer

Create a new layer behind all existing layers.

Declaration

Source position: layers.pas line 157

function CreateBehindLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) Make this layer of type found in flags. If SuperBitMap, use bm2 as pointer to real SuperBitMap, and copy contents of Superbitmap into display layer. If this layer is a backdrop layer then place it behind all other layers including other backdrop layers. If this is not a backdrop layer then place it behind all nonbackdrop layers.

Attention

When using bm2 SuperBitmap, you should also set LAYERSMART flag.


CreateLayerA

Declaration

Source position: layers.pas line 193

function CreateLayerA(

  Li: PLayer_Info;

  TList: PTagItem

):PLayer;


CreateUpfrontHookLayer

Create a new layer on top of existing layers, using supplied callback BackFill hook.

Declaration

Source position: layers.pas line 181

function CreateUpfrontHookLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Hook: PHook;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Hook | BackFill callback Hook
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) and place it on top of all other layers. Make this layer of type found in flags Install Layer^.BackFill callback hook. if SuperBitMap, use bm2 as pointer to real SuperBitMap. and copy contents of Superbitmap into display layer.

Attention

When using bm2 SuperBitmap, you should also set LAYERSMART flag.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


CreateUpfrontLayer

Create a new layer on top of existing layers.

Declaration

Source position: layers.pas line 156

function CreateUpfrontLayer(

  Li: PLayer_Info;

  Bm: PBitMap;

  X0: LongInt;

  Y0: LongInt;

  X1: LongInt;

  Y1: LongInt;

  Flags: LongInt;

  Bm2: PBitMap

):PLayer;

Arguments

Li | pointer to LayerInfo structure
Bm | pointer to common BitMap used by all Layers
X0 | left corner of layer
Y0 | upper corner of layer
X1 | right corner of layer
Y1 | lower corner of layer
Flags | various types of layers supported as bit sets. Flags: LAYER*
Bm2 | pointer to optional Super BitMap

Function result

pointer to Layer structure if successful nil if not successful

Description

Create a new Layer of position and size (x0,y0)->(x1,y1) and place it on top of all other layers. Make this layer of type found in flags if SuperBitMap, use bm2 as pointer to real SuperBitMap. and copy contents of Superbitmap into display layer.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


DeleteBackFillHook

Declaration

Source position: layers.pas line 198

procedure DeleteBackFillHook(

  Hook: PHook

);


DeleteLayer

delete layer from layer list.

Declaration

Source position: layers.pas line 165

function DeleteLayer(

  Dummy: LongInt;

  Layer: PLayer

):LongInt;

Arguments

Dummy | unused
Layer | pointer to a layer

Function result

True if this layer successfully deleted from the system. False if layer not deleted. (probably out of memory )

Description

Remove this layer from the list of layers. Release memory associated with it. Restore other layers that may have been obscured by it. Trigger refresh in those that may need it. If this is a superbitmap layer make sure SuperBitMap is current. The SuperBitMap is not removed from the system but is available for program use even though the rest of the layer information has been deallocated.


DisposeLayerInfo

Return all memory for LayerInfo to memory pool

Declaration

Source position: layers.pas line 175

procedure DisposeLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to LayerInfo structure

Description

return LayerInfo and any other memory attached to this LayerInfo to memory allocator.

Attention

if you wish to delete the layers associated with this TLayer_Info structure, remember to call DeleteLayer() for each of the layers before calling DisposeLayerInfo().

Snippet

// delete the layers associated this Layer_Info structure --
DeleteLayer(li, Simple_Layer);
DeleteLayer(li, Smart_Layer);

// see documentation on DeleteLayer about deleting SuperBitMap layers --
My_Super_Bitmap_Ptr := Super_Layer^.SuperBitMap;
DeleteLayer(li, Super_Layer);

// now dispose of the Layer_Info structure itself --
DisposeLayerInfo(li);

See also

DeleteLayer

delete layer from layer list.


DoHookClipRects

Do the given hook for each of the ClipRects

Declaration

Source position: layers.pas line 186

procedure DoHookClipRects(

  Hook: PHook;

  RPort: PRastPort;

  const Rect: PRectangle

);

Arguments

Hook | pointer to layer callback Hook which will be called
RPort | A pointer to the RastPort that is to be operated on. This function will lock the layer if the RastPort is layered... If the rport is non-layered your hook will be called with the rectangle as passed, the RastPort, and a nil layer...
Rect | The bounding rectangle that should be used on the layer. This rectangle "clips" the cliprects to the bound given. If this is NULL, no bounding will take place. must not be nil if the RastPort is non-layered!

Description

This function will call the given hook for each cliprect in the layer that can be rendered into. This is how the backfill hook in Layers is implemented. This means that hidden simple-refresh cliprects will be ignored. It will call the SuperBitMap cliprects, smart refresh off-screen cliprects, and all on screen cliprects. If the rect parameter is not nil, the cliprects are bounded to the rectangle given.

Hook will be called with:

object = PRastPort(Result^.RastPort);
message = [ layer: PLayer, bounds: TRectangle, offsetx: LongInt, offsety: LongInt;]

This hook should fill the Rectangle in the RastPort with the BackFill pattern appropriate for offset x/y.

If hook is LAYERS_BACKFILL, the default backfill is used for the layer.

If hook is LAYERS_NOBACKFILL, the layer will not be backfilled (NO-OP).

Attention

The RastPort you are passed back is the same one passed to the function. You should not use "layered" rendering functions on this RastPort. Generally, you will wish to do BitMap operations such as BltBitMap(). The callback is a raw, low-level rendering call-back. If you need to call a rendering operation with a RastPort, make sure you use a copy of the RastPort and nil the Layer pointer.


EndUpdate

remove damage list and restore state of layer to normal.

Declaration

Source position: layers.pas line 164

procedure EndUpdate(

  Layer: PLayer;

  Flag: LongWord

);

Arguments

Layer | pointer to a layer
Flag | Use True if update was completed. The damage list is cleared. Use False if update not complete. The damage list is retained.

Description

After the programmer has redrawn his picture he calls this routine to restore the ClipRects to point to his standard layer tiling. The layer is then unlocked for access by the layer library.

Attention

Use flag := False if you are only making a partial update. You may use the other region functions (graphics functions such as OrRectRegion, AndRectRegion, and XorRectRegion) to clip adjust the DamageList to reflect a partial update.

Snippet

// begin update for first part of two-part refresh
BeginUpdate(my_layer);
// do some refresh, but not all
my_partial_refresh_routine(my_layer);
// end update, false (not completely done refreshing yet)
EndUpdate(my_layer, False);
// begin update for last part of refresh
BeginUpdate(my_layer);
// do rest of refresh
my_complete_refresh_routine(my_layer);
// end update, true (completely done refreshing now)
EndUpdate(my_layer, True);

See also

BeginUpdate

Prepare to repair damaged layer.


FattenLayerInfo

convert 1.0 LayerInfo to 1.1 LayerInfo Obsolete

Declaration

Source position: layers.pas line 176

function FattenLayerInfo(

  Li: PLayer_Info

):LongInt;

Arguments

Li

pointer to LayerInfo structure

Description

Obsolete

V1.1 software and any later releases need to have more info in the Layer_Info structure. To do this in a 1.0 supportable manner requires allocation and deallocation of the memory whenever most layer library functions are called. To prevent unnecessary allocation/deallocation FattenLayerInfo will preallocate the necessary data structures and fake out the layer library into thinking it has a LayerInfo gotten from NewLayerInfo. NewLayerInfo is the approved method for getting this structure. When a program needs to give up the LayerInfo structure it must call ThinLayerInfo before freeing the memory. ThinLayerInfo is not necessary if New/DisposeLayerInfo are used however.

See also

NewLayerInfo | Allocate and Initialize full Layer_Info structure.
ThinLayerInfo | convert 1.1 LayerInfo to 1.0 LayerInfo. Obsolete
DisposeLayerInfo | Return all memory for LayerInfo to memory pool


FreeClipRect

Declaration

Source position: layers.pas line 192

procedure FreeClipRect(

  Li: PLayer_Info;

  Cr: PClipRect

);


GetBackFillHookAttrsA

Declaration

Source position: layers.pas line 201

function GetBackFillHookAttrsA(

  Hook: PHook;

  Tags: PTagItem

):LongWord;


GetLayerInfoAttrsA

Declaration

Source position: layers.pas line 208

function GetLayerInfoAttrsA(

  Li: PLayer_Info;

  TagList: PTagItem

):LongWord;


GetOffScreenLayerBitMap

Declaration

Source position: layers.pas line 205

function GetOffScreenLayerBitMap(

  L: PLayer;

  FallBack: PBitMap;

  Bounds: PRectangle

):LongWord;


HideLayer

Declaration

Source position: layers.pas line 188

function HideLayer(

  Layer: PLayer

):LongInt;


InitLayers

Initialize Layer_Info structure Obsolete

Declaration

Source position: layers.pas line 155

procedure InitLayers(

  Li: PLayer_Info

);

Arguments

Li

pointer to LayerInfo structure

Description

Obsolete

Initialize Layer_Info structure in preparation to use other layer operations on this list of layers. Make the Layers unlocked (open), available to layer operations.

See also

NewLayerInfo | Allocate and Initialize full Layer_Info structure.
DisposeLayerInfo | Return all memory for LayerInfo to memory pool


InstallClipRegion

Install clip region in layer

Declaration

Source position: layers.pas line 179

function InstallClipRegion(

  Layer: PLayer;

  const Region: PRegion

):PRegion;

Arguments

Layer | pointer to a layer
Region | pointer to a region

Function result

The pointer to the previous ClipRegion that was installed. Returns nil if no previous ClipRegion installed.

Description

Installs a transparent Clip region in the layer. All subsequent graphics calls will be clipped to this region. You must remember to call InstallClipRegion(l, nil) before calling DeleteLayer(l) or the Intuition function CloseWindow() if you have installed a non-nil ClipRegion in layer.

Attention

If the system runs out of memory while computing the resulting ClipRects the LAYERS_CLIPRECTS_LOST bit will be set in layer^.Flags.

Errors

If the system runs out of memory during normal layer operations, the ClipRect list may get swept away and not restored. As soon as there is enough memory and the layer library gets called again the ClipRect list will be rebuilt.

See also

BeginUpdate | Prepare to repair damaged layer.
EndUpdate | remove damage list and restore state of layer to normal.

Example

program clipping;
{$mode fpc}
{ The following example shows the use of the layers library call
  InstallClipRegion(), as well as simple use of the graphics library
  regions functions. Be aware that it uses Release 2 functions for
  opening and closing Intuition windows.

  Clipping.pp converted from original RKRM clipping.c
  tested with FPC 3.2.0}
uses
  Exec, AmigaDOS, AGraphics, Layers, Intuition, Utility;

const
  MY_WIN_WIDTH  = 300;
  MY_WIN_HEIGHT = 100;

{ UnclipWindow()
 Used to remove a clipping region installed by ClipWindow() or
 ClipWindowToBorders(), disposing of the installed region and
 reinstalling the region removed.}
procedure UnclipWindow(Win: PWindow);
var
  Old_Region: PRegion;
begin
  Old_Region := InstallClipRegion(Win^.WLayer, nil);
  // Remove any old region by installing a nil region, then dispose of the old region if one was installed.
  if Assigned(Old_Region) then
    DisposeRegion(Old_Region);
end;

{ ClipWindow()
  Clip a window to a specified rectangle (given by upper left and
  lower right corner.)  the removed region is returned so that it
  may be re-installed later.}
function ClipWindow(Win: PWindow; MinX, MinY, MaxX, MaxY: LongInt): PRegion;
var
  New_Region: PRegion;
  My_Rectangle: TRectangle;
begin
  // set up the limits for the clip
  My_Rectangle.MinX := MinX;
  My_Rectangle.MinY := MinY;
  My_Rectangle.MaxX := MaxX;
  My_Rectangle.MaxY := MaxY;

  New_Region := NewRegion();
  // get a new region and OR in the limits.
  if Assigned(NewRegion()) then
  begin
    if not Boolean(OrRectRegion(New_Region, @My_Rectangle)) then
    begin
      DisposeRegion(New_Region);
      New_Region := nil;
    end;
  end;

  // Install the new region, and return any existing region.
  // If the above allocation and region processing failed, then
  // New_Region will be NULL and no clip region will be installed.
  ClipWindow := InstallClipRegion(Win^.WLayer, New_Region);
end;

{ ClipWindowToBorders()
 clip a window to its borders. The removed region is returned so that it may be re-installed later.}
function ClipWindowToBorders(Win: PWindow): PRegion;
begin
  ClipWindowToBorders := ClipWindow(Win, Win^.BorderLeft, Win^.BorderTop, Win^.Width - Win^.BorderRight - 1, Win^.Height - Win^.BorderBottom - 1);
end;

// Wait for the user to select the close gadget.
procedure Wait_For_Close(win: PWindow);
var
  Msg: PIntuiMessage;
  Done: Boolean;
begin
  Done := False;
  while not Done do
  begin
    // we only have one signal bit, so we do not have to check which bit broke the Wait().
    Wait(1 shl win^.UserPort^.mp_SigBit);
    repeat
      Msg := PIntuiMessage(GetMsg(win^.UserPort));
      if not Assigned(Msg) then
        Break;
      //* use a switch statement if looking for multiple event types */
      if Msg^.IClass = IDCMP_CLOSEWINDOW then
        Done := True;

      ReplyMsg(PMessage(Msg));
    until Done;
  end;
end;

{ Simple routine to blast all bits in a window with color three to show
  where the window is clipped.  After a delay, flush back to color zero
  and refresh the window borders.}
procedure Draw_In_Window(Win: PWindow; Message: AnsiString);
begin
  Write(Message, '...');
  SetRast(Win^.RPort, 3);
  DOSDelay(200);
  SetRast(Win^.RPort, 0);
  RefreshWindowFrame(Win);
  Writeln('done');
end;

{ Show drawing into an unclipped window, a window clipped to the
 borders and a window clipped to a random rectangle.  It is possible
 to clip more complex shapes by AND'ing, OR'ing and exclusive-OR'ing
 regions and rectangles to build a user clip region.

 This example assumes that old regions are not going to be re-used,
 so it simply throws them away.}
procedure Clip_Test(Win: PWindow);
var
  Old_Region: PRegion;
begin
  Draw_In_Window(Win, 'Window with no clipping');

  // if the application has never installed a user clip region, then Old_Region will be nil here.
  // Otherwise, delete the old region (you could save it and re-install it later...)
  Old_Region := ClipWindowToBorders(Win);
  if not Assigned(Old_Region) then
    DisposeRegion(Old_Region);
  Draw_In_Window(Win, 'Window clipped to window borders');
  UnclipWindow(Win);

  // here we know Old_Region will be NULL, as that is what we installed with UnclipWindow()...
  Old_Region := ClipWindow(Win,20,20,100,50);
  if not Assigned(Old_Region) then
    DisposeRegion(Old_Region);
  Draw_In_Window(Win, 'Window clipped from (20,20) to (100,50)');
  UnclipWindow(Win);

  Wait_For_Close(Win);
end;

// Open and close resources, call the test routine when ready.
procedure StartMe;
var
  Win: PWindow;
begin
  Win := OpenWindowTags(nil, [
          TAG_(WA_Width)      , AsTag(MY_WIN_WIDTH),
          TAG_(WA_Height)     , AsTag(MY_WIN_HEIGHT),
          TAG_(WA_IDCMP)      , AsTag(IDCMP_CLOSEWINDOW),
          TAG_(WA_CloseGadget), AsTag(True),
          TAG_(WA_DragBar)    , AsTag(True),
          TAG_(WA_Activate)   , AsTag(True),
          TAG_END]);
  if Assigned(Win) then
  begin
    Clip_Test(Win);
    CloseWindow(Win);
  end;
end;

begin
  StartMe
end.


InstallLayerHook

safely install a new TLayer.BackFill hook

Declaration

Source position: layers.pas line 183

function InstallLayerHook(

  Layer: PLayer;

  Hook: PHook

):PHook;

Arguments

Layer | pointer to the layer in which to install the Backfill Hook.
Hook | pointer to layer callback Hook which will be called

Function result

pointer to the TLayer.BackFill Hook that was previously active. Returns nil if it was the default hook. In V39, it could return 1 if there was no hook.

Description

Installs a new TLayer.BackFill Hook, waiting until it is safe to do so. Locks the layer while substituting the new Hook and removing the old one. If a new Hook is not provided, will install the default layer BackFill Hook.

Hook will be called with:

object = PRastPort(Result^.RastPort);
message = [ layer: PLayer, bounds: TRectangle, offsetx: LongInt, offsety: LongInt;]

This hook should fill the Rectangle in the RastPort with the BackFill pattern appropriate for offset x/y.

If hook is LAYERS_BACKFILL, the default backfill is used for the layer.

If hook is LAYERS_NOBACKFILL, the layer will not be backfilled (NO-OP).

Attention

The RastPort you are passed back is the same one passed to the function. You should not use "layered" rendering functions on this RastPort. Generally, you will wish to do BitMap operations such as BltBitMap(). The callback is a raw, low-level rendering call-back. If you need to call a rendering operation with a RastPort, make sure you use a copy of the RastPort and nil the Layer pointer.


InstallLayerInfoHook

Install a backfill hook for non-layer

Declaration

Source position: layers.pas line 184

function InstallLayerInfoHook(

  Li: PLayer_Info;

  const Hook: PHook

):PHook;

Arguments

Li | pointer to LayerInfo structure
Hook | pointer to layer callback Hook which will be called

Function result

Returns the backfill hook that was in the Layer_Info. Returns LAYERS_BACKFILL if the default was installed. Returns LAYERS_NOBACKFILL if there was a NO-OP hook. Returns -1 if there was some failure.

Description

This function will install a backfill hook for the Layer_Info structure passed. This backfill hook will be used to clear the background area where no layer exists. The hook function is passed the RastPort and the bounds just like the layer backfill hook. Note that this hook could be called for any layer.

Hook will be called with:

object = PRastPort(Result^.RastPort);
message = [ layer: PLayer, bounds: TRectangle, offsetx: LongInt, offsety: LongInt;]

This hook should fill the Rectangle in the RastPort with the BackFill pattern appropriate for offset x/y.

If hook is LAYERS_BACKFILL, the default backfill is used for the layer.

If hook is LAYERS_NOBACKFILL, the layer will not be backfilled (NO-OP).

Attention

When the hook is first installed, it is not called. It is up to the application to know if it is safe to fill in the area. Since the hook will be called when a layer is deleted, the easiest way to have layers call this hook is to create and delete a backdrop layer that is the size of the area.

Also, note that currently the first long word of the hook message contains an undefined value. This value may look like a layer pointer. It is not a layer pointer.

The RastPort you are passed back is the same one passed to the function. You should not use "layered" rendering functions on this RastPort. Generally, you will wish to do BitMap operations such as BltBitMap(). The callback is a raw, low-level rendering call-back. If you need to call a rendering operation with a RastPort, make sure you use a copy of the RastPort and nil the Layer pointer.


LayerOccluded

Declaration

Source position: layers.pas line 187

function LayerOccluded(

  Layer: PLayer

):LongInt;


LayersClone

Declaration

Source position: layers.pas line 154

function LayersClone: PInterface;


LayersExpunge

Declaration

Source position: layers.pas line 153

procedure LayersExpunge;


LayersObtain

Declaration

Source position: layers.pas line 151

function LayersObtain: LongWord;


LayersRelease

Declaration

Source position: layers.pas line 152

function LayersRelease: LongWord;


LockLayer

Lock layer to make changes to ClipRects.

Declaration

Source position: layers.pas line 166

procedure LockLayer(

  Dummy: LongInt;

  Layer: PLayer

);

Arguments

Dummy | unused
Layer | pointer to a layer

Description

Make this layer unavailable for other tasks to use. If another task is already using this layer then wait for it to complete and then reserve the layer for your own use. (this function does the same thing as graphics.library/LockLayerRom)

Atention

if you wish to lock more than one layer at a time, you must call LockLayerInfo() before locking those layers and then call UnlockLayerInfo() when you have finished. This is to prevent system "deadlocks".

while you hold the lock on a layer, Intuition will block on operations such as windowsizing, dragging, menus, and depth arranging windows in this layer's screen. It is recommended that you do not make Intuition function calls while the layer is locked.


LockLayerInfo

Lock the LayerInfo structure.

Declaration

Source position: layers.pas line 170

procedure LockLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to Layer_Info structure

Description

Before doing an operation that requires the LayerInfo structure, make sure that no other task is also using the LayerInfo structure. LockLayerInfo() returns when the LayerInfo belongs to this task. There should be an UnlockLayerInfo for every LockLayerInfo.

Attention

All layer routines presently LockLayerInfo() when they start up and UnlockLayerInfo() as they exit. Programmers will need to use these Lock/Unlock routines if they wish to do something with the LayerStructure that is not supported by the layer library.

See also

UnlockLayerInfo

Unlock the LayerInfo structure.


LockLayers

lock all layers from graphics output.

Declaration

Source position: layers.pas line 168

procedure LockLayers(

  Li: PLayer_Info

);

Arguments

Li

pointer to Layer_Info structure

Description

First calls LockLayerInfo() Make all layers in this layer list locked.

See also

LockLayer | Lock layer to make changes to ClipRects.
LockLayerInfo | Lock the LayerInfo structure.


MoveLayer

Move layer to new position in BitMap.

Declaration

Source position: layers.pas line 160

function MoveLayer(

  Dummy: LongInt;

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

):LongInt;

Arguments

Dummy | unused
Layer | pointer to a nonbackdrop layer
Dx | delta to add to current x position
Dy | delta to add to current y position

Function result

True if operation successful. False if failed (out of memory)

Description

Move this layer to new position in shared BitMap. If any refresh layers become revealed, collect damage and set REFRESH bit in layer Flags.

Errors

May not handle (dx,dy) which attempts to move the layer outside the layer's RastPort^.BitMap bounds .

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


MoveLayerInFrontOf

Put layer in front of another layer.

Declaration

Source position: layers.pas line 178

function MoveLayerInFrontOf(

  LayerToMove: PLayer;

  OtherLayer: PLayer

):LongInt;

Function result

True if operation successful. False if operation unsuccessful (probably out of memory)

Description

Move this layer in front of target layer, swapping bits in and out of the display with other layers. If this is a refresh layer then collect damage list and set the LAYERREFRESH bit in TLayer.Flags if redraw required.

Attention

this operation may generate refresh events in other layers associated with this layer's TLayer_Info structure.

Example

program LayersTest;
{ For the sake of brevity, the example is a single task.  No Layer
  locking is done.  Also note that the routine MyLabelLayer() is used
  to redraw a given layer.  It is called only when a layer needs
  refreshing.

  LayersTest.pp converted from original RKRM layers.c
  tested with FPC 3.2.0}
{$mode fpc}
uses
  Exec, AmigaDOS, AGraphics, Layers;
const
  L_DELAY = 100;
  S_DELAY =  50;

  DUMMY = 0;

  RED_PEN   = 1;
  GREEN_PEN = 2;
  BLUE_PEN  = 3;

  SCREEN_D =   2;
  SCREEN_W = 320;
  SCREEN_H = 200;

  // the starting size of example layers, offsets are used for placement
  W_H = 50;
  W_T = 5;
  W_B = (W_T + W_H) - 1;
  W_W = 80;
  W_L = (SCREEN_W div 2) - (W_W div 2);
  W_R = (W_L + W_W) - 1;

  // size of the superbitmap
  SUPER_H = SCREEN_H;
  SUPER_W = SCREEN_W;

  // starting size of the message layer
  M_H = 10;
  M_T = SCREEN_H - M_H;
  M_B = (M_T + M_H) - 1;
  M_W = SCREEN_W;
  M_L = 0;
  M_R = (M_L + M_W) - 1;

  // global constant data for initializing the layers
  TheLayerFlags: array[0..2] of LongInt = (LAYERSUPER, LAYERSMART, LAYERSIMPLE);
  ColorTable: array [0..3] of Word = ($000, $f44, $4f4, $44f);

// Clear the layer then draw in a text string.
procedure MyLabelLayer(Layer: PLayer; Color: LongInt; str: AnsiString);
begin
  // fill Layer with color
  SetRast(Layer^.rp, Color);

  // set up for writing text into Layer
  SetDrMd(Layer^.rp, JAM1);
  SetAPen(Layer^.rp, 0);
  GfxMove(Layer^.rp, 5, 7);

  // write into Layer
  GfxText(Layer^.rp, PChar(str), Length(str));
end;

// write a message into a layer with a delay.
procedure DoMessage(Layer: PLayer; Str: AnsiString);
begin
  DOSDelay(S_DELAY);
  MyLabelLayer(Layer, GREEN_PEN, str);
end;

// write an error message into a layer with a delay.
procedure Error(Layer: PLayer; Str: AnsiString);
begin
  MyLabelLayer(Layer, RED_PEN, Str);
  DOSDelay(L_DELAY);
end;

// do some layers manipulations to demonstrate their abilities.
procedure DoLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
  ktr_2: SmallInt;
begin
  DoMessage(MsgLayer, 'Label all Layers');
  MyLabelLayer(Layer_Array[0], RED_PEN,   'Super');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'MoveLayer 1 InFrontOf 0');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[1], Layer_Array[0])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'MoveLayer 2 InFrontOf 1');
  if not Boolean(MoveLayerInFrontOf(Layer_Array[2], Layer_Array[1])) then
    Error(MsgLayer, 'MoveLayerInFrontOf() failed.');

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Incrementally MoveLayers...');
  for ktr := 0 to 29 do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], -1, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], -2, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'make Layer 0 the UpfrontLayer');
  if not Boolean(UpfrontLayer(DUMMY, Layer_Array[0])) then
    Error(MsgLayer, 'UpfrontLayer() failed.');

  DoMessage(MsgLayer, 'make Layer 2 the BehindLayer');
  if not Boolean(BehindLayer(DUMMY, Layer_Array[2])) then
    Error(MsgLayer, 'BehindLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally MoveLayers again...');
  for ktr := 0 to Pred(30) do
  begin
    if not Boolean(MoveLayer(DUMMY, Layer_Array[1], 0, 1)) then
      Error(MsgLayer, 'MoveLayer() failed.');
    if not Boolean(MoveLayer(DUMMY, Layer_Array[2], 0, 2)) then
      Error(MsgLayer, 'MoveLayer() failed.');
  end;

  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN, 'Simple');

  DoMessage(MsgLayer, 'Big MoveLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(MoveLayer(DUMMY, Layer_Array[ktr], -Layer_Array[ktr]^.bounds.MinX, 0)) then
      Error(MsgLayer, 'MoveLayer() failed.');

  DoMessage(MsgLayer, 'Incrementally increase size');
  for ktr := 0 to 4 do
    for ktr_2 := 0 to High(Layer_Array) do
      if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr_2], 1, 1)) then
        Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'Big SizeLayer');
  for ktr := 0 to High(Layer_Array) do
    if not Boolean(SizeLayer(DUMMY, Layer_Array[ktr], SCREEN_W - (Layer_Array[ktr]^.bounds.MaxX) - 1, 0)) then
      Error(MsgLayer, 'SizeLayer() failed.');

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer down');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, -1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DoMessage(MsgLayer, 'ScrollLayer up');
  for ktr := 0 to 29 do
    for ktr_2 := 0 to High(Layer_Array) do
      ScrollLayer(DUMMY, Layer_Array[ktr_2], 0, 1);

  DoMessage(MsgLayer, 'Refresh Smart Refresh Layer');
  MyLabelLayer(Layer_Array[1], GREEN_PEN, 'Smart');
  DoMessage(MsgLayer, 'Refresh Simple Refresh Layer');
  MyLabelLayer(Layer_Array[2], BLUE_PEN,  'Simple');

  DOSDelay(L_DELAY);
end;

// delete the layer array created by allocLayers().
procedure DisposeLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer);
var
  ktr: SmallInt;
begin
  for ktr := 0 to High(Layer_Array) do
    if (Layer_Array[ktr] <> nil) then
      if not Boolean(DeleteLayer(DUMMY, Layer_Array[ktr])) then
        Error(MsgLayer, 'Error deleting layer');
end;

{Create some hard-coded layers.  The first must be super-bitmap, with
 the bitmap passed as an argument.  The others must not be super-bitmap.
 The pointers to the created layers are returned in Layer_Array.

 Return False on failure.  On a False return, the layers are
 properly cleaned up.}
function AllocLayers(MsgLayer: PLayer; var Layer_Array: array of PLayer; Super_Bitmap: PBitmap; TheLayerInfo: PLayer_Info; TheBitMap: PBitMap): Boolean;
var
  ktr: SmallInt;
  Create_Layer_Ok: Boolean = True;
begin
  ktr := 0;
  while (ktr < Length(Layer_Array)) and (Create_Layer_Ok) do
  begin
    DoMessage(MsgLayer, 'Create BehindLayer');
    if ktr = 0 then
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], Super_Bitmap);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := False;
    end
    else
    begin
      Layer_Array[ktr] := CreateBehindLayer(TheLayerInfo, TheBitMap, W_L + (ktr * 30), W_T + (ktr * 30), W_R + (ktr * 30), W_B + (ktr * 30), TheLayerFlags[ktr], nil);
      if not Assigned(Layer_Array[ktr]) then
        Create_Layer_Ok := FALSE;
    end;
    if Create_Layer_Ok then
    begin
      DoMessage(MsgLayer, 'Fill the RastPort');
      SetRast(Layer_Array[ktr]^.rp, ktr + 1);
    end;
    Inc(ktr);
  end;
  if not Create_Layer_Ok then
    DisposeLayers(MsgLayer, Layer_Array);

  AllocLayers := Create_Layer_Ok;
end;

// Set up to run the layers example, doLayers(). Clean up when done.
procedure StartLayers(TheLayerInfo: PLayer_Info; TheBitMap: PBitMap);
var
  MsgLayer: PLayer;
  TheSuperBitMap: PBitMap;
  TheLayers: array[0..2] of PLayer = (nil, nil, nil);
begin
  MsgLayer := CreateUpfrontLayer(TheLayerInfo, TheBitMap, M_L, M_T, M_R, M_B, LAYERSMART, nil);
  if Assigned(MsgLayer) then
  begin
    DoMessage(MsgLayer, 'Setting up Layers');
    TheSuperBitMap := AllocBitMap(SUPER_W, SUPER_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
    if Assigned(TheSuperBitMap) then
    begin
      if Boolean(AllocLayers(MsgLayer, TheLayers, TheSuperBitMap, TheLayerInfo, TheBitMap)) then
      begin
        DoLayers(MsgLayer, TheLayers);
        DisposeLayers(MsgLayer, TheLayers);
      end;
      FreeBitMap(TheSuperBitMap);
    end;
    if not Boolean(DeleteLayer(DUMMY, MsgLayer)) then
      Error(MsgLayer, 'Error deleting layer');
  end;
end;

{ Set up a low-level graphics display for layers to work on.  Layers
 should not be built directly on Intuition screens, use a low-level
 graphics view. If you need mouse or other events for the layers
 display, you have to get them directly from the input device. The
 only supported method of using layers library calls with Intuition
 (other than the InstallClipRegion() call) is through Intuition windows.

 See graphics primitives chapter for details on creating and using the
 low-level graphics calls.}
procedure RunNewView;
var
  TheView: TView;
  Oldview: PView;
  TheViewPort: TViewPort;
  TheRasInfo: TRasInfo;
  TheColorMap: PColorMap;
  TheLayerInfo: PLayer_Info;
  TheBitMap: PBitMap;
  ColorPalette: PWord;
  ktr: SmallInt;
begin
  //* save current view, to be restored when done */
  Oldview := PGfxBase(GfxBase)^.ActiView;
  if Assigned(Oldview) then
  begin
    //* get a LayerInfo structure */
    TheLayerInfo := NewLayerInfo;
    if Assigned(TheLayerInfo) then
    begin
      TheColorMap := GetColorMap(4);
      if Assigned(TheColorMap) then
      begin
        ColorPalette := PWord(TheColorMap^.ColorTable);
        for ktr := 0 to 3 do
        begin
          ColorPalette^ := colortable[ktr];
          Inc(ColorPalette);
        end;

        TheBitMap := AllocBitMap(SCREEN_W, SCREEN_H, SCREEN_D, BMF_CLEAR or BMF_DISPLAYABLE, nil);
        if Assigned(TheBitMap) then
        begin
          InitView(@TheView);
          InitVPort(@TheViewPort);

          TheView.ViewPort := @TheViewPort;

          TheViewPort.DWidth   := SCREEN_W;
          TheViewPort.DHeight  := SCREEN_H;
          TheViewPort.RasInfo  := @TheRasInfo;
          TheViewPort.ColorMap := TheColorMap;

          TheRasInfo.BitMap   := TheBitMap;
          TheRasInfo.RxOffset := 0;
          TheRasInfo.RyOffset := 0;
          TheRasInfo.Next     := nil;

          MakeVPort(@TheView, @TheViewPort);
          MrgCop(@TheView);
          LoadView(@TheView);
          WaitTOF;

          StartLayers(TheLayerInfo, TheBitMap);

          // put back the old view, wait for it to become active before freeing any of our display
          LoadView(Oldview);
          WaitTOF;

          // free dynamically created structures
          FreeVPortCopLists(@TheViewPort);
          FreeCprList(TheView.LOFCprList);

          FreeBitMap(TheBitMap);
        end;
        FreeColorMap(TheColorMap);  // free the color map
      end;
      DisposeLayerInfo(TheLayerInfo);
    end;
  end;
end;

begin
  RunNewView;
end.


MoveSizeLayer

Position/Size layer

Declaration

Source position: layers.pas line 180

function MoveSizeLayer(

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt;

  Dw: LongInt;

  Dh: LongInt

):LongInt;

Arguments

Layer | pointer to a nonbackdrop layer
Dx | change left corner by dx
Dy | change upper corner by dy
Dw | change size by dw
Dh | change size by dh

Function result

True if operation successful. False if failed (due to out of memory). False if failed (due to illegal layer^.bounds)

Description

Change upperleft and lower right position of Layer.


NewLayerInfo

Allocate and Initialize full Layer_Info structure.

Declaration

Source position: layers.pas line 174

function NewLayerInfo: PLayer_Info;

Function result

pointer to PLayer_Info structure if successful nil if not enough memory

Description

Allocate memory required for full PLayer_Info structure. Initialize PLayer_Info structure in preparation to use other layer operations on this list of layers. Make the PLayer_Info unlocked (open).


NEWLAYERINFO_CALLED

Declaration

Source position: layers.pas line 63

const NEWLAYERINFO_CALLED = 1;


ScrollLayer

Scroll around in a superbitmap, translate coordinates in non-superbitmap layer.

Declaration

Source position: layers.pas line 162

procedure ScrollLayer(

  Dummy: LongInt;

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

);

Arguments

Dummy | unused
Layer | pointer to a layer
Dx | delta to add to current x scroll value
Dy | delta to add to current y scroll value

Description

For a SuperBitMap Layer:

Update the SuperBitMap from the layer display, then copy bits between Layer and SuperBitMap to reposition layer over different portion of SuperBitMap.

For nonSuperBitMap layers, all (x,y) pairs are adjusted by the scroll(x,y) value in the layer. To cause (0,0) to actually be drawn at (3,10) use ScrollLayer(-3,-10). This can be useful along with InstallClipRegion to simulate Intuition GZZWindows without the overhead of an extra layer.

Errors

ay not handle (dx,dy) which attempts to move the layer outside the layer's SuperBitMap bounds.


SetBackFillHookAttrsA

Declaration

Source position: layers.pas line 199

function SetBackFillHookAttrsA(

  Hook: PHook;

  Tags: PTagItem

):LongWord;


SetForegroundAlpha

Declaration

Source position: layers.pas line 211

function SetForegroundAlpha(

  L: PLayer;

  TemplatePtr: Pointer;

  TemplateType: LongWord;

  BytesPerRow: LongWord;

  Left: LongInt;

  Top: LongInt;

  Width: LongWord;

  Height: LongWord;

  Flags: LongWord

):LongWord;


SetLayerInfoAttrsA

Declaration

Source position: layers.pas line 206

function SetLayerInfoAttrsA(

  Li: PLayer_Info;

  TagList: PTagItem

):LongWord;


SetLayerInfoBounds

Declaration

Source position: layers.pas line 190

function SetLayerInfoBounds(

  Li: PLayer_Info;

  Bounds: PRectangle

):LongInt;


SetLayerOpaqueness

Declaration

Source position: layers.pas line 212

function SetLayerOpaqueness(

  L: PLayer;

  Opaqueness: LongWord

):LongWord;


SetLayerOverlayRect

Declaration

Source position: layers.pas line 213

function SetLayerOverlayRect(

  L: PLayer;

  Left: LongInt;

  Top: LongInt;

  Width: LongInt;

  Height: LongInt;

  Flags: LongWord

):LongWord;


ShowLayer

Declaration

Source position: layers.pas line 189

function ShowLayer(

  Layer: PLayer

):LongInt;


SizeLayer

Change the size of this nonbackdrop layer.

Declaration

Source position: layers.pas line 161

function SizeLayer(

  Summy: LongInt;

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

):LongInt;

Arguments

Layer | pointer to a nonbackdrop layer
Dx | delta to add to current x size
Dy | delta to add to current y size

Function result

True if operation successful. False if failed (out of memory)

Description

Change the size of this layer by (dx,dy). The lower right hand corner is extended to make room for the larger layer. If there is SuperBitMap for this layer then copy pixels into or out of the layer depending on whether the layer increases or decreases in size. Collect damage list for those layers that may need to be refreshed if damage occurred.


SortLayerCR

Declaration

Source position: layers.pas line 185

procedure SortLayerCR(

  Layer: PLayer;

  Dx: LongInt;

  Dy: LongInt

);


SwapBitsRastPortClipRect

Swap bits between common bitmap and obscured ClipRect

Declaration

Source position: layers.pas line 171

procedure SwapBitsRastPortClipRect(

  Rp: PRastPort;

  Cr: PClipRect

);

Arguments

Rp | pointer to rastport
Cr | pointer to cliprect to swap bits with

Description

Support routine useful for those that need to do some operations not done by the layer library. Allows programmer to swap the contents of a small BitMap with a subsection of the display. This is accomplished without using extra memory. The bits in the display RastPort are exchanged with the bits in the ClipRect's BitMap.

Note: the ClipRect structures which the layer library allocates are actually a little bigger than those described in the graphics/clip.h include file. So be warned that it is not a good idea to have instances of cliprects in your code.

Attention

Because the blit operation started by this function is done asynchronously, it is imperative that a WaitBlit() be performed before releasing or using the processor to modify any of the associated structures.


ThinLayerInfo

convert 1.1 LayerInfo to 1.0 LayerInfo. Obsolete

Declaration

Source position: layers.pas line 177

procedure ThinLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to LayerInfo structure

Description

Obsolete

return the extra memory needed that was allocated with FattenLayerInfo. This is must be done prior to freeing the Layer_Info structure itself. V1.1 software should be using DisposeLayerInfo.

See also

DisposeLayerInfo | Return all memory for LayerInfo to memory pool
FattenLayerInfo | convert 1.0 LayerInfo to 1.1 LayerInfo Obsolete


UnlockLayer

Unlock layer and allow graphics routines to use it.

Declaration

Source position: layers.pas line 167

procedure UnlockLayer(

  Layer: PLayer

);

Arguments

Layer

pointer to a layer

Description

When finished changing the ClipRects or whatever you were doing with this layer you must call UnlockLayer() to allow other tasks to proceed with graphic output to the layer.


UnlockLayerInfo

Unlock the LayerInfo structure.

Declaration

Source position: layers.pas line 173

procedure UnlockLayerInfo(

  Li: PLayer_Info

);

Arguments

Li

pointer to the Layer_Info structure

Description

After the operation is complete that required a LockLayerInfo, unlock the LayerInfo structure so that other tasks may affect the layers.


UnlockLayers

Unlock all layers from graphics output. Restart graphics output to layers that have been waiting

Declaration

Source position: layers.pas line 169

procedure UnlockLayers(

  Li: PLayer_Info

);

Arguments

Li

pointer to the Layer_Info structure

Description

Make all layers in this layer list unlocked. Then call UnlockLayerInfo

See also

LockLayers | lock all layers from graphics output.
UnlockLayer | Unlock layer and allow graphics routines to use it.


UpfrontLayer

Put layer in front of all other layers.

Declaration

Source position: layers.pas line 158

function UpfrontLayer(

  Dummy: LongInt;

  Layer: PLayer

):LongInt;

Arguments

Dummy | unused
Layer | pointer to a nonbackdrop layer

Function result

True if operation successful. False if operation unsuccessful (probably out of memory)

Description

Move this layer to the most upfront position swapping bits in and out of the display with other layers. If this is a refresh layer then collect damage list and set the LAYERREFRESH bit in layer->Flags if redraw required. By clearing the BACKDROP bit in the layers Flags you may bring a Backdrop layer up to the front of all other layers.

Attention

This operation may generate refresh events in other layers associated with this layer's Layer_Info structure.


WhichLayer

Which Layer is this point in?

Declaration

Source position: layers.pas line 172

function WhichLayer(

  Li: PLayer_Info;

  X: LongInt;

  Y: LongInt

):PLayer;

Arguments

Li | pointer to LayerInfo structure
X | x coordinate in the BitMap
Y | y coordinate in the BitMap

Function result

pointer to the topmost layer that this point is in nil if this point is not in a layer

Description

Starting at the topmost layer check to see if this point (x,y) occurs in this layer. If it does return the pointer to this layer. Return nil if there is no layer at this point.


Reference for unit 'locale': Procedures and functions

CloseCatalog

CloseLocale

ConvToLower

ConvToUpper

FormatDate

FormatString

FormatString32

GetCatalogStr

GetLocaleStr

IsAlNum

IsAlpha

IsBlank

IsCntrl

IsDigit

IsGraph

IsLower

IsPrint

IsPunct

IsSpace

IsUpper

IsXDigit

LocaleClone

LocaleExpunge

LocaleObtain

LocaleRelease

Locale_DateToStr

Locale_StrToDate

OpenCatalog

OpenCatalogA

OpenLocale

ParseDate

StrConvert

StrnCmp


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'locale': Variables

ILocale

LocaleBase


Index of all identifiers in unit 'locale'

A C D F G H I L M N O P S T Y

A

ABDAY_1 | ABMON_4 | ALTMON_1
ABDAY_2 | ABMON_5 | ALTMON_10
ABDAY_3 | ABMON_6 | ALTMON_11
ABDAY_4 | ABMON_7 | ALTMON_12
ABDAY_5 | ABMON_8 | ALTMON_2
ABDAY_6 | ABMON_9 | ALTMON_3
ABDAY_7 | ALTDAY_1 | ALTMON_4
ABMON_1 | ALTDAY_2 | ALTMON_5
ABMON_10 | ALTDAY_3 | ALTMON_6
ABMON_11 | ALTDAY_4 | ALTMON_7
ABMON_12 | ALTDAY_5 | ALTMON_8
ABMON_2 | ALTDAY_6 | ALTMON_9
ABMON_3 | ALTDAY_7 | AM_STR

C

CloseCatalog | CSP_PRECEDES | CT_7SUN
CloseLocale | CSP_SUCCEEDS | CT_7THU
CLOSEQUOTE | CT_7FRI | CT_7TUE
ConvToLower | CT_7MON | CT_7WED
ConvToUpper | CT_7SAT |

D

DAY_1 | DAY_4 | DAY_7
DAY_2 | DAY_5 |
DAY_3 | DAY_6 |

F

FormatDate | FormatString32
FormatString | FUTURESTR

G

GetCatalogStr GetLocaleStr

H

HARDHYPHEN

I

ILocale | IsDigit | IsSpace
IsAlNum | IsGraph | IsUpper
IsAlpha | IsLower | IsXDigit
IsBlank | IsPrint |
IsCntrl | IsPunct |

L

LANG_CODE | Locale_DateToStr | LocaleRelease
LANG_NAME | LocaleExpunge | Locale_StrToDate
LocaleBase | LOCALENAME |
LocaleClone | LocaleObtain |

M

MAXSTRMSG | MON_3 | MON_9
MON_1 | MON_4 | MS_AMERICAN
MON_10 | MON_5 | MS_BRITISH
MON_11 | MON_6 | MS_IMPERIAL
MON_12 | MON_7 | MS_ISO
MON_2 | MON_8 |

N

NOSTR

O

OC_BuiltInCodeSet | OC_PreferExternal | OpenCatalog
OC_BuiltInLanguage | OC_TagBase | OpenCatalogA
OC_BuiltInVersion | OC_Version | OpenLocale
OC_Language | OC_WantedCodeSet | OPENQUOTE

P

ParseDate | PLocale | PM_STR
PCatalog | PLocaleBase |

S

SC_ASCII | SP_PREC_ALL | SS_SPACE
SC_COLLATE1 | SP_PREC_CURR | StrConvert
SC_COLLATE2 | SP_SUCC_ALL | StrnCmp
SOFTHYPHEN | SP_SUCC_CURR |
SP_PARENS | SS_NOSPACE |

T

TCatalog | TLocaleBase | TOMORROWSTR
TLocale | TODAYSTR |

Y

YESSTR YESTERDAYSTR


CloseCatalog

Declaration

Source position: locale.pas line 286

procedure CloseCatalog(

  Catalog: PCatalog

);


CloseLocale

Declaration

Source position: locale.pas line 287

procedure CloseLocale(

  Locale: PLocale

);


ConvToLower

Declaration

Source position: locale.pas line 288

function ConvToLower(

  Locale: PLocale;

  Character: LongWord

):LongWord;


ConvToUpper

Declaration

Source position: locale.pas line 289

function ConvToUpper(

  Locale: PLocale;

  Character: LongWord

):LongWord;


FormatDate

Declaration

Source position: locale.pas line 290

procedure FormatDate(

  Locale: PLocale;

  FmtTemplate: PChar;

  Date: PDateStamp;

  PutCharFunc: PHook

);


FormatString

Declaration

Source position: locale.pas line 291

function FormatString(

  Locale: PLocale;

  FmtTemplate: PChar;

  DataStream: Pointer;

  PutCharFunc: PHook

):POINTER;


FormatString32

Declaration

Source position: locale.pas line 315

function FormatString32(

  Locale: PLocale;

  FmtTemplate: PChar;

  DataStream: Pointer;

  PutCharFunc: PHook

):Pointer;


GetCatalogStr

Declaration

Source position: locale.pas line 292

function GetCatalogStr(

  Catalog: PCatalog;

  StringNum: LongInt;

  DefaultString: PChar

):PChar;


GetLocaleStr

Declaration

Source position: locale.pas line 293

function GetLocaleStr(

  Locale: PLocale;

  StringNum: LongWord

):PChar;


IsAlNum

Declaration

Source position: locale.pas line 294

function IsAlNum(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsAlpha

Declaration

Source position: locale.pas line 295

function IsAlpha(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsBlank

Declaration

Source position: locale.pas line 314

function IsBlank(

  Locale: PLocale;

  Character: LongWord

):LongInt;


IsCntrl

Declaration

Source position: locale.pas line 296

function IsCntrl(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsDigit

Declaration

Source position: locale.pas line 297

function IsDigit(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsGraph

Declaration

Source position: locale.pas line 298

function IsGraph(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsLower

Declaration

Source position: locale.pas line 299

function IsLower(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsPrint

Declaration

Source position: locale.pas line 300

function IsPrint(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsPunct

Declaration

Source position: locale.pas line 301

function IsPunct(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsSpace

Declaration

Source position: locale.pas line 302

function IsSpace(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsUpper

Declaration

Source position: locale.pas line 303

function IsUpper(

  Locale: PLocale;

  Character: LongWord

):LongBool;


IsXDigit

Declaration

Source position: locale.pas line 304

function IsXDigit(

  Locale: PLocale;

  Character: LongWord

):LongBool;


LocaleClone

Declaration

Source position: locale.pas line 284

function LocaleClone: PInterface;


LocaleExpunge

Declaration

Source position: locale.pas line 283

procedure LocaleExpunge;


LocaleObtain

Declaration

Source position: locale.pas line 281

function LocaleObtain: LongWord;


LocaleRelease

Declaration

Source position: locale.pas line 282

function LocaleRelease: LongWord;


Locale_DateToStr

Declaration

Source position: locale.pas line 312

function Locale_DateToStr(

  DateTime: PDateTime

):LongInt;


Locale_StrToDate

Declaration

Source position: locale.pas line 313

function Locale_StrToDate(

  DateTime: PDateTime

):LongInt;


OpenCatalog

Declaration

Source position: locale.pas line 317

function OpenCatalog(

  Locale: PLocale;

  Name: PChar;

  const Args: array of PtrUInt

):PCatalog;


OpenCatalogA

Declaration

Source position: locale.pas line 305

function OpenCatalogA(

  Locale: PLocale;

  Name: PChar;

  Tags: PTagItem

):PCatalog;


OpenLocale

Declaration

Source position: locale.pas line 307

function OpenLocale(

  Name: PChar

):PLocale;


ParseDate

Declaration

Source position: locale.pas line 308

function ParseDate(

  Locale: PLocale;

  Date: PDateStamp;

  FmtTemplate: PChar;

  GetCharFunc: PHook

):LongBool;


StrConvert

Declaration

Source position: locale.pas line 310

function StrConvert(

  Locale: PLocale;

  String1: PChar;

  Buffer: Pointer;

  BufferSize: LongWord;

  Typ: LongWord

):LongWord;


StrnCmp

Declaration

Source position: locale.pas line 311

function StrnCmp(

  Locale: PLocale;

  String1: PChar;

  String2: PChar;

  Length: LongInt;

  Typ: LongWord

):LongInt;


Reference for unit 'mui': Procedures and functions

MUIAreaData

MUIGlobalInfo

MUINotifyData

MUIObtain

MUIPen

MUIRelease

MUIRenderInfo

MUIUserData

MUIV_Window_AltHeight_MinMax

MUIV_Window_AltHeight_Screen

MUIV_Window_AltHeight_Visible

MUIV_Window_AltTopEdge_Delta

MUIV_Window_AltWidth_MinMax

MUIV_Window_AltWidth_Screen

MUIV_Window_AltWidth_Visible

MUIV_Window_Height_MinMax

MUIV_Window_Height_Screen

MUIV_Window_Height_Visible

MUIV_Window_TopEdge_Delta

MUIV_Window_Width_MinMax

MUIV_Window_Width_Screen

MUIV_Window_Width_Visible

MUI_AddClipping

MUI_AddClipRegion

MUI_AllocAslRequest

MUI_AllocAslRequestTags

MUI_AslRequest

MUI_AslRequestTags

MUI_BeginRefresh

MUI_CreateCustomClass

MUI_DeleteCustomClass

MUI_DisposeObject

MUI_EndRefresh

MUI_Error

MUI_FreeAslRequest

MUI_FreeClass

MUI_GetClass

MUI_Hide

MUI_Layout

MUI_LayoutObj

MUI_MakeObject

MUI_MakeObjectA

MUI_NewObject

MUI_NewObjectA

MUI_ObtainPen

MUI_Offset

MUI_Redraw

MUI_RejectIDCMP

MUI_ReleasePen

MUI_RemoveClipping

MUI_RemoveClipRegion

MUI_Request

MUI_RequestA

MUI_RequestIDCMP

MUI_SetError

MUI_Show

OBJ_AddLeft

OBJ_AddTop

OBJ_App

OBJ_Between

OBJ_Bottom

OBJ_DefHeight

OBJ_DefWidth

OBJ_Dri

OBJ_Flags

OBJ_Font

OBJ_Height

OBJ_IsInObject

OBJ_Left

OBJ_MaxHeight

OBJ_MaxWidth

OBJ_MBottom

OBJ_MHeight

OBJ_MinHeight

OBJ_MinWidth

OBJ_MLeft

OBJ_MRight

OBJ_MTop

OBJ_MWidth

OBJ_Pens

OBJ_Right

OBJ_Rp

OBJ_Screen

OBJ_SubHeight

OBJ_SubWidth

OBJ_Top

OBJ_Width

OBJ_Win

OBJ_Window


Unit 'mui' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'mui': Variables

IMui

MUIMasterBase


Index of all identifiers in unit 'mui'

I M O P T

I

IDCMP_MOUSEOBJECT IMSPEC_EXTERNAL_PREFIX IMui

M

MADF_DRAWALL | MUIB_Bodychunk | MUI_LPR_LEFT
MADF_DRAWOBJECT | MUIB_Boopsi | MUI_LPR_RIGHT
MADF_DRAWUPDATE | MUIB_ChunkyImage | MUI_MakeObject
MAXWINS | MUIB_Coloradjust | MUI_MakeObjectA
MBQF_HORIZ | MUIB_Colorfield | MUIM_Application_AboutMUI
MBQ_MUI_MAXMAX | MUIB_Configdata | MUIM_Application_AddInputHandler
MC_TEMPLATE_ID | MUIB_Cycle | MUIM_Application_CheckRefresh
MPEN_BACKGROUND | MUIB_Dataspace | MUIM_Application_Execute
MPEN_COUNT | MUIB_Dirlist | MUIM_Application_GetMenuCheck
MPEN_FILL | MUI_BeginRefresh | MUIM_Application_GetMenuState
MPEN_HALFSHADOW | MUIB_Family | MUIM_Application_Iconify
MPEN_HALFSHINE | MUIB_Floattext | MUIM_Application_Input
MPEN_MARK | MUIB_Frameadjust | MUIM_Application_InputBuffered
MPEN_SHADOW | MUIB_Framedisplay | MUIM_Application_Load
MPEN_SHINE | MUIB_Gauge | MUIM_Application_NewInput
MPEN_TEXT | MUIB_Group | MUIM_Application_OpenConfigWindow
MRI_RARRAY_SIZE | MUIB_Image | MUIM_Application_OpenWindows
MUIA_Aboutmui_Application | MUIB_Imageadjust | MUIM_Application_PushMethod
MUIA_Application_Active | MUIB_Imagedisplay | MUIM_Application_RemInputHandler
MUIA_Application_Author | MUIB_List | MUIM_Application_ReturnID
MUIA_Application_Base | MUIB_Listview | MUIM_Application_Save
MUIA_Application_Broker | MUIB_Menu | MUIM_Application_SetConfigdata
MUIA_Application_BrokerHook | MUIB_Menuitem | MUIM_Application_SetConfigItem
MUIA_Application_BrokerPort | MUIB_Menustrip | MUIM_Application_SetMenuCheck
MUIA_Application_BrokerPri | MUIB_MUI | MUIM_Application_SetMenuState
MUIA_Application_Commands | MUIB_Notify | MUIM_Application_ShowHelp
MUIA_Application_Configdata | MUIB_Numeric | MUIM_Application_UnpushMethod
MUIA_Application_Copyright | MUIB_Palette | MUIM_Application_UpdateMenus
MUIA_Application_CopyWinPosToApp | MUIB_Penadjust | MUIM_AskMinMax
MUIA_Application_Description | MUIB_Pendisplay | MUIMasterBase
MUIA_Application_DiskObject | MUIB_Pixmap | MUIMASTER_NAME
MUIA_Application_DoubleStart | MUIB_Popasl | MUIMASTER_VLATEST
MUIA_Application_DropObject | MUIB_Popframe | MUIMASTER_VMIN
MUIA_Application_ForceQuit | MUIB_Popimage | MUI_MAXMAX
MUIA_Application_GetWinPos | MUIB_Poplist | MUIM_BoopsiQuery
MUIA_Application_GetWinPosAddr | MUIB_Popobject | MUIM_CallHook
MUIA_Application_GetWinPosSize | MUIB_Poppen | MUIM_Cleanup
MUIA_Application_HelpFile | MUIB_Popscreen | MUIM_Configdata_GetString
MUIA_Application_Iconified | MUIB_Popstring | MUIM_Configdata_GetULong
MUIA_Application_MenuAction | MUIB_Prop | MUIM_Configdata_GetWindowPos
MUIA_Application_MenuHelp | MUIB_Radio | MUIM_Configdata_Load
MUIA_Application_Menustrip | MUIB_Rectangle | MUIM_Configdata_Save
MUIA_ApplicationObject | MUIB_Register | MUIM_Configdata_SetFont
MUIA_Application_RexxHook | MUIB_RSVD | MUIM_Configdata_SetFramespec
MUIA_Application_RexxMsg | MUIB_Scale | MUIM_Configdata_SetImspec
MUIA_Application_RexxString | MUIB_Scrmodelist | MUIM_Configdata_SetPenspec
MUIA_Application_SearchWinId | MUIB_Scrollbar | MUIM_Configdata_SetString
MUIA_Application_SetWinPos | MUIB_Scrollbutton | MUIM_Configdata_SetULong
MUIA_Application_SingleTask | MUIB_Scrollgroup | MUIM_Configdata_SetWindowPos
MUIA_Application_Sleep | MUIB_Semaphore | MUIM_ConnectParent
MUIA_Application_Title | MUIB_Settings | MUIM_ContextMenuBuild
MUIA_Application_UseCommodities | MUIB_Settingsgroup | MUIM_ContextMenuChoice
MUIA_Application_UsedClasses | MUIB_Slider | MUIM_CreateBubble
MUIA_Application_UseRexx | MUIB_String | MUIM_CreateDragImage
MUIA_Application_Version | MUIB_Text | MUIM_CreateShortHelp
MUIA_Application_Version_Date | MUIB_Virtgroup | MUIM_CustomBackfill
MUIA_Application_Version_Extra | MUIB_Volumelist | MUIM_Dataspace_Add
MUIA_Application_Version_Number | MUIB_Window | MUIM_Dataspace_Clear
MUIA_Application_Window | MUIB_ZUNE | MUIM_Dataspace_Find
MUIA_Application_WindowList | MUIC_Aboutmui | MUIM_Dataspace_Merge
MUIA_AppMessage | MUIC_Application | MUIM_Dataspace_ReadIFF
MUIA_Background | MUIC_Applist | MUIM_Dataspace_Remove
MUIA_Balance_Quiet | MUIC_Area | MUIM_Dataspace_WriteIFF
MUIA_Bitmap_Alpha | MUIC_Balance | MUIM_DeleteBubble
MUIA_Bitmap_Bitmap | MUIC_Bitmap | MUIM_DeleteDragImage
MUIA_Bitmap_Height | MUIC_Bodychunk | MUIM_DeleteShortHelp
MUIA_Bitmap_MappingTable | MUIC_Boopsi | MUIM_Dirlist_ReRead
MUIA_Bitmap_Precision | MUIC_Cclist | MUIM_DisconnectParent
MUIA_Bitmap_RemappedBitmap | MUIC_ChunkyImage | MUIM_DoDrag
MUIA_Bitmap_SourceColors | MUIC_Coloradjust | MUIM_DragBegin
MUIA_Bitmap_Transparent | MUIC_Colorfield | MUIM_DragDrop
MUIA_Bitmap_UseFriend | MUIC_Configdata | MUIM_DragFinish
MUIA_Bitmap_Width | MUIC_Crawling | MUIM_DragQuery
MUIA_Bodychunk_Body | MUIC_Cycle | MUIM_DragReport
MUIA_Bodychunk_Compression | MUIC_Dataspace | MUIM_Draw
MUIA_Bodychunk_Depth | MUIC_Dirlist | MUIM_DrawBackground
MUIA_Bodychunk_Masking | MUIC_Dtpic | MUIM_DrawParentBackground
MUIA_Boopsi_Class | MUIC_Family | MUIM_Export
MUIA_Boopsi_ClassID | MUICFG_ActiveObject_Color | MUIM_Family_AddHead
MUIA_Boopsi_MaxHeight | MUICFG_Background_Button | MUIM_Family_AddTail
MUIA_Boopsi_MaxWidth | MUICFG_Background_Framed | MUIM_Family_DoChildMethods
MUIA_Boopsi_MinHeight | MUICFG_Background_List | MUIM_Family_GetChild
MUIA_Boopsi_MinWidth | MUICFG_Background_ListCursor | MUIM_Family_Insert
MUIA_Boopsi_Object | MUICFG_Background_ListSelCur | MUIM_Family_Remove
MUIA_Boopsi_Remember | MUICFG_Background_ListSelect | MUIM_Family_Sort
MUIA_Boopsi_Smart | MUICFG_Background_Page | MUIM_Family_Transfer
MUIA_Boopsi_TagDrawInfo | MUICFG_Background_PopUp | MUIM_FindUData
MUIA_Boopsi_TagScreen | MUICFG_Background_Prop | MUIM_Floattext_Append
MUIA_Boopsi_TagWindow | MUICFG_Background_ReadList | MUIM_GetConfigItem
MUIA_BottomEdge | MUICFG_Background_Register | MUIM_GetUData
MUIA_ChunkyImage_Modulo | MUICFG_Background_Requester | MUIM_GoActive
MUIA_ChunkyImage_NumColors | MUICFG_Background_Selected | MUIM_GoInactive
MUIA_ChunkyImage_Palette | MUICFG_Background_Slider | MUIM_Group_AddHead
MUIA_ChunkyImage_Pixels | MUICFG_Background_SliderKnob | MUIM_Group_AddTail
MUIA_Coloradjust_Blue | MUICFG_Background_Text | MUIM_Group_DoMethodNoForward
MUIA_Coloradjust_Green | MUICFG_Background_Window | MUIM_Group_ExitChange
MUIA_Coloradjust_ModeID | MUICFG_Balance_Look | MUIM_Group_InitChange
MUIA_Coloradjust_Red | MUICFG_BubbleHelp_FirstDelay | MUIM_Group_Remove
MUIA_Coloradjust_RGB | MUICFG_BubbleHelp_NextDelay | MUIM_Group_Sort
MUIA_Colorfield_Blue | MUICFG_CustomFrame_1 | MUIM_HandleEvent
MUIA_Colorfield_Green | MUICFG_CustomFrame_10 | MUIM_HandleInput
MUIA_Colorfield_Pen | MUICFG_CustomFrame_11 | MUIM_Hide
MUIA_Colorfield_Red | MUICFG_CustomFrame_12 | MUIM_Import
MUIA_Colorfield_RGB | MUICFG_CustomFrame_13 | MUIM_KillNotify
MUIA_Configdata_Application | MUICFG_CustomFrame_14 | MUIM_KillNotifyObj
MUIA_Configdata_ApplicationBase | MUICFG_CustomFrame_15 | MUIM_Layout
MUIA_ContextMenu | MUICFG_CustomFrame_16 | MUIM_List_Clear
MUIA_ContextMenuTrigger | MUICFG_CustomFrame_2 | MUIM_List_Compare
MUIA_ControlChar | MUICFG_CustomFrame_3 | MUIM_List_Construct
MUIA_Cycle_Active | MUICFG_CustomFrame_4 | MUIM_List_CreateImage
MUIA_CycleChain | MUICFG_CustomFrame_5 | MUIM_List_DeleteImage
MUIA_Cycle_Entries | MUICFG_CustomFrame_6 | MUIM_List_Exchange
MUIA_Dataspace_Pool | MUICFG_CustomFrame_7 | MUIM_List_GetEntry
MUI_AddClipping | MUICFG_CustomFrame_8 | MUIM_List_Insert
MUI_AddClipRegion | MUICFG_CustomFrame_9 | MUIM_List_InsertSingle
MUIA_Dirlist_AcceptPattern | MUICFG_Cycle_MenuCtrl_Level | MUIM_List_Jump
MUIA_Dirlist_Directory | MUICFG_Cycle_MenuCtrl_Position | MUIM_List_Move
MUIA_Dirlist_DrawersOnly | MUICFG_Cycle_MenuCtrl_Speed | MUIM_List_NextSelected
MUIA_Dirlist_FilesOnly | MUICFG_Cycle_Menu_Recessed | MUIM_List_Redraw
MUIA_Dirlist_FilterDrawers | MUICFG_Drag_Autostart | MUIM_List_Remove
MUIA_Dirlist_FilterHook | MUICFG_Drag_Autostart_Length | MUIM_List_Select
MUIA_Dirlist_MultiSelDirs | MUICFG_Drag_LeftButton | MUIM_List_Sort
MUIA_Dirlist_NumBytes | MUICFG_Drag_LMBModifier | MUIM_List_TestPos
MUIA_Dirlist_NumDrawers | MUICFG_Drag_MiddleButton | MUIM_MultiSet
MUIA_Dirlist_NumFiles | MUICFG_Drag_MMBModifier | MUIM_NoNotifySet
MUIA_Dirlist_Path | MUICFG_Dragndrop_Look | MUIM_Notify
MUIA_Dirlist_RejectIcons | MUICFG_Font_Big | MUIM_Numeric_Decrease
MUIA_Dirlist_RejectPattern | MUICFG_Font_Button | MUIM_Numeric_Increase
MUIA_Dirlist_SortDirs | MUICFG_Font_Fixed | MUIM_Numeric_ScaleToValue
MUIA_Dirlist_SortHighLow | MUICFG_Font_Knob | MUIM_Numeric_SetDefault
MUIA_Dirlist_SortType | MUICFG_Font_List | MUIM_Numeric_Stringify
MUIA_Dirlist_Status | MUICFG_Font_Normal | MUIM_Numeric_ValueToScale
MUIA_Disabled | MUICFG_Font_Tiny | MUIM_Numeric_ValueToScaleExt
MUIA_DoubleBuffer | MUICFG_Font_Title | MUIM_Pendisplay_SetColormap
MUIA_Draggable | MUICFG_Frame_Button | MUIM_Pendisplay_SetMUIPen
MUIA_Dropable | MUICFG_Frame_Drag | MUIM_Pendisplay_SetRGB
MUIA_Dtpic_Alpha | MUICFG_Frame_Gauge | MUIM_Pixmap_DrawSection
MUIA_Dtpic_DarkenSelState | MUICFG_Frame_Group | MUIM_Popstring_Close
MUIA_Dtpic_Fade | MUICFG_Frame_ImageButton | MUIM_Popstring_Open
MUIA_Dtpic_LightenOnMouse | MUICFG_Frame_InputList | MUIM_Process_Kill
MUIA_Dtpic_Name | MUICFG_Frame_Knob | MUIM_Process_Launch
MUIA_Family_Child | MUICFG_Frame_PopUp | MUIM_Process_Process
MUIA_Family_ChildCount | MUICFG_Frame_Prop | MUIM_Process_Signal
MUIA_Family_List | MUICFG_Frame_ReadList | MUIM_Prop_Decrease
MUIA_FillArea | MUICFG_Frame_Slider | MUIM_Prop_Increase
MUIA_FixHeight | MUICFG_Frame_String | MUIMRI_RECTFILL
MUIA_FixHeightTxt | MUICFG_Frame_Text | MUIMRI_REFRESHMODE
MUIA_FixWidth | MUICFG_Frame_Virtual | MUIMRI_THINFRAMES
MUIA_FixWidthTxt | MUICFG_Group_HSpacing | MUIMRI_TRUECOLOR
MUIA_Floattext_Justify | MUICFG_GroupTitle_Color | MUIM_Semaphore_Attempt
MUIA_Floattext_SkiPChars | MUICFG_GroupTitle_Position | MUIM_Semaphore_AttemptShared
MUIA_Floattext_TabSize | MUICFG_Group_VSpacing | MUIM_Semaphore_Obtain
MUIA_Floattext_Text | MUICFG_Iconification_Hotkey | MUIM_Semaphore_ObtainShared
MUIA_Font | MUICFG_Iconification_OnStartup | MUIM_Semaphore_Release
MUIA_Frame | MUICFG_Iconification_ShowIcon | MUIM_Set
MUIA_Frameadjust_Spec | MUICFG_Iconification_ShowMenu | MUIM_SetAsString
MUIA_Framedisplay_Spec | MUICFG_Image_ArrowDown | MUIM_Settingsgroup_ConfigToGadgets
MUIA_FramePhantomHoriz | MUICFG_Image_ArrowLeft | MUIM_Settingsgroup_GadgetsToConfig
MUIA_FrameTitle | MUICFG_Image_ArrowRight | MUIM_SetUData
MUIA_Gadget_Gadget | MUICFG_Image_ArrowUp | MUIM_SetUDataOnce
MUIA_Gauge_Current | MUICFG_Image_Assign | MUIM_Setup
MUIA_Gauge_Divide | MUICFG_Image_CheckMark | MUIM_Show
MUIA_Gauge_DupInfoText | MUICFG_Image_Chip | MUIM_String_ClearSelected
MUIA_Gauge_Horiz | MUICFG_Image_Cycle | MUIM_String_FileNameStart
MUIA_Gauge_InfoText | MUICFG_Image_Disk | MUIM_String_Insert
MUIA_Gauge_Max | MUICFG_Image_Drawer | MUIM_UnknownDropDestination
MUIA_Group_ActivePage | MUICFG_Image_HardDisk | MUIM_Window_ActionIconify
MUIA_Group_Child | MUICFG_Image_Network | MUIM_Window_AddEventHandler
MUIA_Group_ChildList | MUICFG_Image_PopDrawer | MUIM_Window_AllocGadgetID
MUIA_Group_Columns | MUICFG_Image_PopFile | MUIM_Window_Cleanup
MUIA_Group_Forward | MUICFG_Image_PopUp | MUIM_Window_FreeGadgetID
MUIA_Group_Horiz | MUICFG_Image_PropKnob | MUIM_Window_RemEventHandler
MUIA_Group_HorizSpacing | MUICFG_Image_RadioButton | MUIM_Window_ScreenToBack
MUIA_Group_LayoutHook | MUICFG_Image_TapeDown | MUIM_Window_ScreenToFront
MUIA_Group_PageMode | MUICFG_Image_TapePause | MUIM_Window_Setup
MUIA_Group_Rows | MUICFG_Image_TapePlay | MUIM_Window_Snapshot
MUIA_Group_SameHeight | MUICFG_Image_TapePlayBack | MUIM_Window_ToBack
MUIA_Group_SameSize | MUICFG_Image_TapeRecord | MUIM_Window_ToFront
MUIA_Group_SameWidth | MUICFG_Image_TapeStop | MUIM_WriteLong
MUIA_Group_Spacing | MUICFG_Image_TapeUp | MUIM_WriteString
MUIA_Group_VertSpacing | MUICFG_Image_Volume | MUI_NewObject
MUIA_Group_Virtual | MUICFG_Interfaces_EnableARexx | MUI_NewObjectA
MUIA_Height | MUICFG_Invalid | MUINotifyData
MUIA_HelpLine | MUICFG_Keyboard_Bottom | MUIO_BarTitle
MUIA_HelpNode | MUICFG_Keyboard_CloseWindow | MUIObtain
MUIA_HorizDisappear | MUICFG_Keyboard_Down | MUI_ObtainPen
MUIA_HorizWeight | MUICFG_Keyboard_GadgetOff | MUIO_Button
MUIA_Imageadjust_Originator | MUICFG_Keyboard_Help | MUIO_Checkmark
MUIA_Imageadjust_Spec | MUICFG_Keyboard_Left | MUIO_Cycle
MUIA_Imageadjust_Type | MUICFG_Keyboard_LineEnd | MUI_Offset
MUIA_Imagedisplay_FreeHoriz | MUICFG_Keyboard_LineStart | MUIO_HBar
MUIA_Imagedisplay_FreeVert | MUICFG_Keyboard_NextGadget | MUIO_HSpace
MUIA_Imagedisplay_Spec | MUICFG_Keyboard_NextWindow | MUIO_Label
MUIA_Imagedisplay_UseDefSize | MUICFG_Keyboard_PageDown | MUIO_Label_Centered
MUIA_Image_FontMatch | MUICFG_Keyboard_PageUp | MUIO_Label_DontCopy
MUIA_Image_FontMatchHeight | MUICFG_Keyboard_Popup | MUIO_Label_DoubleFrame
MUIA_Image_FontMatchWidth | MUICFG_Keyboard_Press | MUIO_Label_FreeVert
MUIA_Image_FreeHoriz | MUICFG_Keyboard_PrevGadget | MUIO_Label_LeftAligned
MUIA_Image_FreeVert | MUICFG_Keyboard_PrevWindow | MUIO_Label_SingleFrame
MUIA_Image_OldImage | MUICFG_Keyboard_Right | MUIO_Label_Tiny
MUIA_Image_Spec | MUICFG_Keyboard_Toggle | MUIO_Menuitem
MUIA_Image_State | MUICFG_Keyboard_Top | MUIO_Menuitem_CopyStrings
MUIA_InnerBottom | MUICFG_Keyboard_Up | MUIO_MenustripNM
MUIA_InnerLeft | MUICFG_Keyboard_WordLeft | MUIO_MenustripNM_CommandKeyCheck
MUIA_InnerRight | MUICFG_Keyboard_WordRight | MUIO_NumericButton
MUIA_InnerTop | MUICFG_Listview_Font_Leading | MUIO_PopButton
MUIA_InputMode | MUICFG_Listview_Multi | MUIO_Radio
MUIA_LeftEdge | MUICFG_Listview_Refresh | MUIO_Slider
MUIA_Levelmeter_Label | MUICFG_Listview_Smoothed | MUIO_String
MUIA_List_Active | MUICFG_Listview_SmoothVal | MUIO_VBar
MUIA_List_AdjustHeight | MUICFG_PublicScreen | MUIO_VSpace
MUIA_List_AdjustWidth | MUICFG_PublicScreen_PopToFront | MUIP_BoopsiQuery
MUIA_List_AutoVisible | MUICFG_Radio_HSpacing | MUIPen
MUIA_List_CompareHook | MUICFG_Radio_VSpacing | MUIPEN_MASK
MUIA_List_ConstructHook | MUICFG_Register_TruncateTitles | MUI_Redraw
MUIA_List_DestructHook | MUICFG_Screen_Height | MUI_RejectIDCMP
MUIA_List_DisplayHook | MUICFG_Screen_Mode | MUIRelease
MUIA_List_DragSortable | MUICFG_Screen_Mode_ID | MUI_ReleasePen
MUIA_List_DropMark | MUICFG_Screen_Width | MUI_RemoveClipping
MUIA_List_Entries | MUICFG_Scrollbar_Arrangement | MUI_RemoveClipRegion
MUIA_List_First | MUICFG_Scrollbar_Type | MUIRenderInfo
MUIA_List_Format | MUICFG_String_ActiveBackground | MUI_Request
MUIA_List_InsertPosition | MUICFG_String_ActiveText | MUI_RequestA
MUIA_List_MinLineHeight | MUICFG_String_Background | MUI_RequestIDCMP
MUIA_List_MultiTestHook | MUICFG_String_Cursor | MUIR_String_FileNameStart_Volume
MUIA_List_Pool | MUICFG_String_MarkedBackground | MUI_RXERR_BADDEFINITION
MUIA_List_PoolPuddleSize | MUICFG_String_MarkedText | MUI_RXERR_BADSYNTAX
MUIA_List_PoolThreshSize | MUICFG_String_Text | MUI_RXERR_OUTOFMEMORY
MUIA_List_Quiet | MUICFG_Window_Buttons | MUI_RXERR_UNKNOWNCOMMAND
MUIA_List_ShowDropMarks | MUICFG_WindowPos | MUI_SetError
MUIA_List_SourceArray | MUICFG_Window_Positions | MUI_Show
MUIA_List_Title | MUICFG_Window_Redraw | MUIUserData
MUIA_Listview_ClickColumn | MUICFG_Window_Refresh | MUIV_Application_Load_ENV
MUIA_Listview_DefClickColumn | MUICFG_Window_Spacing_Bottom | MUIV_Application_Load_ENVARC
MUIA_Listview_DoubleClick | MUICFG_Window_Spacing_Left | MUIV_Application_OCW_ScreenPage
MUIA_Listview_DragType | MUICFG_Window_Spacing_Right | MUIV_Application_Package_NetConnect
MUIA_Listview_Input | MUICFG_Window_Spacing_Top | MUIV_Application_ReturnID_Quit
MUIA_Listview_List | MUIC_Floattext | MUIV_Application_Save_ENV
MUIA_Listview_MultiSelect | MUIC_Frameadjust | MUIV_Application_Save_ENVARC
MUIA_Listview_ScrollerPos | MUIC_Framedisplay | MUIV_ContextMenuBuild_Default
MUIA_Listview_SelectChange | MUIC_Gadget | MUIV_CreateBubble_DontHidePointer
MUIA_List_Visible | MUIC_Gauge | MUIV_Cycle_Active_Next
MUI_AllocAslRequest | MUIC_Group | MUIV_Cycle_Active_Prev
MUI_AllocAslRequestTags | MUIC_Image | MUIV_Dirlist_SortDirs_First
MUIA_MaxHeight | MUIC_Imageadjust | MUIV_Dirlist_SortDirs_Last
MUIA_MaxWidth | MUIC_Imagedisplay | MUIV_Dirlist_SortDirs_Mix
MUIA_Menu_Enabled | MUIC_Knob | MUIV_Dirlist_SortType_Date
MUIA_Menuitem_Checked | MUIC_Levelmeter | MUIV_Dirlist_SortType_Name
MUIA_Menuitem_Checkit | MUIC_List | MUIV_Dirlist_SortType_Size
MUIA_Menuitem_CommandString | MUIC_Listview | MUIV_Dirlist_Status_Invalid
MUIA_Menuitem_Enabled | MUIC_Mccprefs | MUIV_Dirlist_Status_Reading
MUIA_Menuitem_Exclude | MUIC_Menu | MUIV_Dirlist_Status_Valid
MUIA_Menuitem_NewMenu | MUIC_Menuitem | MUIV_DragQuery_Accept
MUIA_Menuitem_Shortcut | MUIC_Menustrip | MUIV_DragQuery_Refuse
MUIA_Menuitem_Title | MUIC_Notify | MUIV_DragReport_Abort
MUIA_Menuitem_Toggle | MUIC_Numeric | MUIV_DragReport_Continue
MUIA_Menuitem_Trigger | MUIC_Numericbutton | MUIV_DragReport_Lock
MUIA_Menustrip_Enabled | MUIC_Palette | MUIV_DragReport_Refresh
MUIA_Menu_Title | MUIC_Penadjust | MUIV_EveryTime
MUIA_NestedDisabled | MUIC_Pendisplay | MUIV_Family_GetChild_First
MUIA_NoNotify | MUIC_Pixmap | MUIV_Family_GetChild_Iterate
MUIA_NoNotifyMethod | MUIC_Popasl | MUIV_Family_GetChild_Last
MUIA_Numeric_CheckAllSizes | MUIC_Popframe | MUIV_Family_GetChild_Next
MUIA_Numeric_Default | MUIC_Popimage | MUIV_Family_GetChild_Previous
MUIA_Numeric_Format | MUIC_Poplist | MUIV_Font_Big
MUIA_Numeric_Max | MUIC_Popobject | MUIV_Font_Button
MUIA_Numeric_Min | MUIC_Poppen | MUIV_Font_Fixed
MUIA_Numeric_Reverse | MUIC_Popscreen | MUIV_Font_Inherit
MUIA_Numeric_RevLeftRight | MUIC_Popstring | MUIV_Font_Knob
MUIA_Numeric_RevUpDown | MUIC_Process | MUIV_Font_List
MUIA_Numeric_Value | MUIC_Prop | MUIV_Font_NegCount
MUIA_ObjectID | MUIC_Radio | MUIV_Font_Normal
MUIA_Palette_Entries | MUI_CreateCustomClass | MUIV_Font_Tiny
MUIA_Palette_Groupable | MUIC_Rectangle | MUIV_Font_Title
MUIA_Palette_Names | MUIC_Register | MUIV_Frame_Button
MUIA_Parent | MUIC_Scale | MUIV_Frame_Count
MUIA_Penadjust_PSIMode | MUIC_Scrmodelist | MUIV_Frame_Drag
MUIA_Pendisplay_Pen | MUIC_Scrollbar | MUIV_Frame_Gauge
MUIA_Pendisplay_Reference | MUIC_Scrollbutton | MUIV_Frame_Group
MUIA_Pendisplay_RGBcolor | MUIC_Scrollgroup | MUIV_Frame_ImageButton
MUIA_Pendisplay_Spec | MUIC_Semaphore | MUIV_Frame_InputList
MUIA_Pixmap_Alpha | MUIC_Settings | MUIV_Frame_Knob
MUIA_Pixmap_CLUT | MUIC_Settingsgroup | MUIV_Frame_None
MUIA_Pixmap_CompressedSize | MUIC_Slider | MUIV_Frame_PopUp
MUIA_Pixmap_Compression | MUIC_String | MUIV_Frame_Prop
MUIA_Pixmap_Data | MUIC_Text | MUIV_Frame_ReadList
MUIA_Pixmap_Format | MUIC_Title | MUIV_Frame_Register
MUIA_Pixmap_Height | MUIC_Virtgroup | MUIV_Frame_Slider
MUIA_Pixmap_UncompressedData | MUIC_Volumelist | MUIV_Frame_String
MUIA_Pixmap_Width | MUIC_Window | MUIV_Frame_Text
MUIA_Popasl_Active | MUI_DeleteCustomClass | MUIV_Frame_Virtual
MUIA_Popasl_StartHook | MUI_DisposeObject | MUIV_Group_ActivePage_Advance
MUIA_Popasl_StopHook | MUI_EHF_ALWAYSKEYS | MUIV_Group_ActivePage_First
MUIA_Popasl_Type | MUI_EHF_GUIMODE | MUIV_Group_ActivePage_Last
MUIA_Poplist_Array | MUI_EHF_ISACTIVE | MUIV_Group_ActivePage_Next
MUIA_Popobject_Follow | MUI_EHF_ISACTIVEGRP | MUIV_Group_ActivePage_Prev
MUIA_Popobject_Light | MUI_EHF_ISCALLING | MUIV_Group_GetChild_First
MUIA_Popobject_Object | MUI_EHF_ISENABLED | MUIV_Group_GetChild_Iterate
MUIA_Popobject_ObjStrHook | MUIE_InvalidWindowObject | MUIV_Group_GetChild_Last
MUIA_Popobject_StrObjHook | MUIE_MissingLibrary | MUIV_Group_GetChild_Next
MUIA_Popobject_Volatile | MUI_EndRefresh | MUIV_Group_GetChild_Previous
MUIA_Popobject_WindowHook | MUIE_NoARexx | MUIV_Imageadjust_Type_All
MUIA_Popstring_Button | MUIE_OK | MUIV_Imageadjust_Type_Background
MUIA_Popstring_CloseHook | MUIE_OutOfGfxMemory | MUIV_Imageadjust_Type_Image
MUIA_Popstring_OpenHook | MUIE_OutOfMemory | MUIV_Imageadjust_Type_Pen
MUIA_Popstring_String | MUI_Error | MUIV_InputMode_Immediate
MUIA_Popstring_Toggle | MUIE_SingleTask | MUIV_InputMode_None
MUIA_Pressed | MUI_EventHandlerRC_Eat | MUIV_InputMode_RelVerify
MUIA_Process_AutoLaunch | MUIF_DRAGIMAGE_HASMASK | MUIV_InputMode_Toggle
MUIA_Process_Name | MUIF_DRAGIMAGE_SOURCEALPHA | MUIV_List_Active_Bottom
MUIA_Process_Priority | MUI_FreeAslRequest | MUIV_List_Active_Down
MUIA_Process_SourceClass | MUI_FreeClass | MUIV_List_Active_Off
MUIA_Process_SourceObject | MUIF_Slave_Delegate_ForceSlave | MUIV_List_Active_PageDown
MUIA_Process_StackSize | MUI_GetClass | MUIV_List_Active_PageUp
MUIA_Process_Task | MUIGlobalInfo | MUIV_List_Active_Top
MUIA_Prop_DeltaFactor | MUI_Hide | MUIV_List_Active_Up
MUIA_Prop_DoSmooth | MUII_ArrowDown | MUIV_List_ConstructHook_String
MUIA_Prop_Entries | MUII_ArrowLeft | MUIV_List_CopyHook_String
MUIA_Prop_First | MUII_ArrowRight | MUIV_List_CursorType_Bar
MUIA_Prop_Horiz | MUII_ArrowUp | MUIV_List_CursorType_None
MUIA_Prop_Slider | MUII_Assign | MUIV_List_CursorType_Rect
MUIA_Prop_UseWinBorder | MUII_BACKGROUND | MUIV_List_DestructHook_String
MUIA_Prop_Visible | MUII_ButtonBack | MUIV_List_EditEntry_Active
MUIA_Radio_Active | MUII_CheckMark | MUIV_List_Exchange_Active
MUIA_Radio_Entries | MUII_Chip | MUIV_List_Exchange_Bottom
MUIAreaData | MUII_Close | MUIV_List_Exchange_Next
MUIA_Rectangle_BarTitle | MUII_Count | MUIV_List_Exchange_Previous
MUIA_Rectangle_HBar | MUII_Cycle | MUIV_List_Exchange_Top
MUIA_Rectangle_VBar | MUII_Disk | MUIV_List_GetEntry_Active
MUIA_Register_Columns | MUII_Drawer | MUIV_List_Insert_Active
MUIA_Register_Frame | MUII_FILL | MUIV_List_Insert_Bottom
MUIA_Register_Titles | MUII_FILLBACK | MUIV_List_Insert_Sorted
MUIA_Revision | MUII_FILLBACK2 | MUIV_List_Insert_Top
MUIA_RightEdge | MUII_FILLSHINE | MUIV_List_Jump_Active
MUIA_Scale_Horiz | MUII_GaugeEmpty | MUIV_List_Jump_Bottom
MUIA_Scrollbar_Type | MUII_GaugeFull | MUIV_List_Jump_Down
MUIA_Scrollbutton_Horiz | MUII_GroupBack | MUIV_List_Jump_Top
MUIA_Scrollbutton_HorizProp | MUII_GroupTitle | MUIV_List_Jump_Up
MUIA_Scrollbutton_NewPosition | MUII_HardDisk | MUIV_List_Move_Active
MUIA_Scrollbutton_Vert | MUIIHNF_TIMER | MUIV_List_Move_Bottom
MUIA_Scrollbutton_VertProp | MUIIHNF_TIMER_SCALE10 | MUIV_List_Move_Next
MUIA_Scrollgroup_Contents | MUIIHNF_TIMER_SCALE100 | MUIV_List_Move_Previous
MUIA_Scrollgroup_FreeHoriz | MUII_HSHADOWBACK | MUIV_List_Move_Top
MUIA_Scrollgroup_FreeVert | MUII_HSHADOWSHADOW | MUIV_List_NextSelected_End
MUIA_Scrollgroup_HorizBar | MUII_HSHINEBACK | MUIV_List_NextSelected_Start
MUIA_Scrollgroup_UseWinBorder | MUII_HSHINESHINE | MUIV_List_Redraw_Active
MUIA_Scrollgroup_VertBar | MUII_ImageButtonBack | MUIV_List_Redraw_All
MUIA_Selected | MUII_ImageSelectedBack | MUIV_List_Redraw_Entry
MUIA_ShortHelp | MUII_LASTPAT | MUIV_List_Remove_Active
MUIA_ShowMe | MUII_ListBack | MUIV_List_Remove_First
MUIA_ShowSelState | MUII_ListCursor | MUIV_List_Remove_Last
MUIA_Slider_Horiz | MUII_ListSelCur | MUIV_List_Remove_Selected
MUIA_Slider_Quiet | MUII_ListSelect | MUIV_List_Select_Active
MUI_AslRequest | MUII_ListTitle | MUIV_List_Select_All
MUI_AslRequestTags | MUII_MARKBACKGROUND | MUIV_List_Select_Ask
MUIA_String_Accept | MUII_MARKHALFSHINE | MUIV_List_Select_Off
MUIA_String_Acknowledge | MUII_MARKSHINE | MUIV_List_Select_On
MUIA_String_AdvanceOnCR | MUII_Menudisplay | MUIV_List_Select_Toggle
MUIA_String_AttachedList | MUII_Network | MUIV_Listview_DragType_Immediate
MUIA_String_BufferPos | MUII_PageBack | MUIV_Listview_DragType_None
MUIA_String_Columns | MUII_PopDrawer | MUIV_Listview_MultiSelect_Always
MUIA_String_Contents | MUII_PopFile | MUIV_Listview_MultiSelect_Default
MUIA_String_DisplayPos | MUII_PopFont | MUIV_Listview_MultiSelect_None
MUIA_String_EditHook | MUII_PopUp | MUIV_Listview_MultiSelect_Shifted
MUIA_String_Format | MUII_PopupBack | MUIV_Listview_ScrollerPos_Default
MUIA_String_Integer | MUII_PropBack | MUIV_Listview_ScrollerPos_Left
MUIA_String_KeyDownFocus | MUII_PropKnob | MUIV_Listview_ScrollerPos_None
MUIA_String_KeyUpFocus | MUII_PullOpen | MUIV_Listview_ScrollerPos_Right
MUIA_String_LonelyEditHook | MUII_RadioButton | MUIV_Menuitem_Shortcut_Check
MUIA_String_MaxLen | MUII_ReadListBack | MUIV_NList_SelectChange_Flag_Multi
MUIA_String_NoInput | MUII_RegisterBack | MUIV_Notify_Application
MUIA_String_Reject | MUII_RegisterTitle | MUIV_Notify_Parent
MUIA_String_Secret | MUII_RequesterBack | MUIV_Notify_ParentParent
MUIA_String_SelectSize | MUII_SelectedBack | MUIV_Notify_ParentParentParent
MUIA_String_StayActive | MUII_SHADOW | MUIV_Notify_Self
MUIA_Text_Contents | MUII_SHADOWBACK | MUIV_Notify_Window
MUIA_Text_HiChar | MUII_SHADOWFILL | MUIV_NotTriggerValue
MUIA_Text_HiCharIdx | MUII_SHADOWSHINE | MUIV_Palette_Entry_End
MUIA_Text_PreParse | MUII_SHINE | MUIV_Pixmap_Compression_BZip2
MUIA_Text_SetMax | MUII_SHINEBACK | MUIV_Pixmap_Compression_None
MUIA_Text_SetMin | MUII_SliderBack | MUIV_Pixmap_Compression_RLE
MUIA_Text_SetVMax | MUII_SliderKnob | MUIV_Pixmap_Format_ARGB32
MUIA_Timer | MUII_StringActiveBack | MUIV_Pixmap_Format_CLUT8
MUIA_TopEdge | MUII_StringBack | MUIV_Pixmap_Format_RGB24
MUIA_UserData | MUII_TapeDown | MUIV_Prop_UseWinBorder_Bottom
MUIA_Version | MUII_TapePause | MUIV_Prop_UseWinBorder_Left
MUIA_VertDisappear | MUII_TapePlay | MUIV_Prop_UseWinBorder_None
MUIA_VertWeight | MUII_TapePlayBack | MUIV_Prop_UseWinBorder_Right
MUIA_Virtgroup_Height | MUII_TapeRecord | MUIV_Scrollbar_Type_Bottom
MUIA_Virtgroup_Input | MUII_TapeStop | MUIV_Scrollbar_Type_Default
MUIA_Virtgroup_Left | MUII_TapeUp | MUIV_Scrollbar_Type_Sym
MUIA_Virtgroup_Top | MUII_TextBack | MUIV_Scrollbar_Type_Top
MUIA_Virtgroup_Width | MUII_Volume | MUIV_String_BufferPos_End
MUIA_Weight | MUII_WindowBack | MUIV_String_Format_Center
MUIA_Width | MUIKEY_BOTTOM | MUIV_String_Format_Left
MUIA_Window | MUIKEY_COUNT | MUIV_String_Format_Right
MUIA_Window_Activate | MUIKEY_DOWN | MUIV_String_Insert_BufferPos
MUIA_Window_ActiveObject | MUIKEYF_BOTTOM | MUIV_String_Insert_EndOfString
MUIA_Window_AltHeight | MUIKEYF_DOWN | MUIV_String_Insert_StartOfString
MUIA_Window_AltLeftEdge | MUIKEYF_GADGET_NEXT | MUIV_TriggerValue
MUIA_Window_AltTopEdge | MUIKEYF_GADGET_OFF | MUIV_Window_ActiveObject_Next
MUIA_Window_AltWidth | MUIKEYF_GADGET_PREV | MUIV_Window_ActiveObject_None
MUIA_Window_AppWindow | MUIKEYF_HELP | MUIV_Window_ActiveObject_Prev
MUIA_Window_Backdrop | MUIKEYF_LEFT | MUIV_Window_AltHeight_MinMax
MUIA_Window_Borderless | MUIKEYF_LINEEND | MUIV_Window_AltHeight_Scaled
MUIA_Window_CloseGadget | MUIKEYF_LINESTART | MUIV_Window_AltHeight_Screen
MUIA_Window_CloseRequest | MUIKEYF_PAGEDOWN | MUIV_Window_AltHeight_Visible
MUIA_Window_DefaultObject | MUIKEYF_PAGEUP | MUIV_Window_AltLeftEdge_Centered
MUIA_Window_DepthGadget | MUIKEYF_POPUP | MUIV_Window_AltLeftEdge_Moused
MUIA_Window_DisableKeys | MUIKEYF_PRESS | MUIV_Window_AltLeftEdge_NoChange
MUIA_Window_DragBar | MUIKEYF_RIGHT | MUIV_Window_AltTopEdge_Centered
MUIA_Window_EraseArea | MUIKEYF_TOGGLE | MUIV_Window_AltTopEdge_Delta
MUIA_Window_FancyDrawing | MUIKEYF_TOP | MUIV_Window_AltTopEdge_Moused
MUIA_Window_Height | MUIKEYF_UP | MUIV_Window_AltTopEdge_NoChange
MUIA_Window_ID | MUIKEYF_WINDOW_CLOSE | MUIV_Window_AltWidth_MinMax
MUIA_Window_InputEvent | MUIKEYF_WINDOW_NEXT | MUIV_Window_AltWidth_Scaled
MUIA_Window_IsSubWindow | MUIKEYF_WINDOW_PREV | MUIV_Window_AltWidth_Screen
MUIA_Window_LeftEdge | MUIKEYF_WORDLEFT | MUIV_Window_AltWidth_Visible
MUIA_Window_MenuAction | MUIKEYF_WORDRIGHT | MUIV_Window_Button_Iconify
MUIA_Window_Menustrip | MUIKEY_GADGET_NEXT | MUIV_Window_Button_MUI
MUIA_Window_MouseObject | MUIKEY_GADGET_OFF | MUIV_Window_Button_Popup
MUIA_Window_NeedsMouseObject | MUIKEY_GADGET_PREV | MUIV_Window_Button_Snapshot
MUIA_Window_NoMenus | MUIKEY_HELP | MUIV_Window_Height_Default
MUIA_WindowObject | MUIKEY_LEFT | MUIV_Window_Height_MinMax
MUIA_Window_Open | MUIKEY_LINEEND | MUIV_Window_Height_Scaled
MUIA_Window_PublicScreen | MUIKEY_LINESTART | MUIV_Window_Height_Screen
MUIA_Window_RefWindow | MUIKEY_NONE | MUIV_Window_Height_Visible
MUIA_Window_RootObject | MUIKEY_PAGEDOWN | MUIV_Window_LeftEdge_Centered
MUIA_Window_Screen | MUIKEY_PAGEUP | MUIV_Window_LeftEdge_Moused
MUIA_Window_ScreenTitle | MUIKEY_POPUP | MUIV_Window_TopEdge_Centered
MUIA_Window_SizeGadget | MUIKEY_PRESS | MUIV_Window_TopEdge_Delta
MUIA_Window_SizeRight | MUIKEY_RELEASE | MUIV_Window_TopEdge_Moused
MUIA_Window_Sleep | MUIKEY_RIGHT | MUIV_Window_Width_Default
MUIA_Window_Title | MUIKEY_TOGGLE | MUIV_Window_Width_MinMax
MUIA_Window_ToolBox | MUIKEY_TOP | MUIV_Window_Width_Scaled
MUIA_Window_TopEdge | MUIKEY_UP | MUIV_Window_Width_Screen
MUIA_Window_UseBottomBorderScroller | MUIKEY_WINDOW_CLOSE | MUIV_Window_Width_Visible
MUIA_Window_UseLeftBorderScroller | MUIKEY_WINDOW_NEXT | MUIX_B
MUIA_Window_UseRightBorderScroller | MUIKEY_WINDOW_PREV | MUIX_C
MUIA_Window_Width | MUIKEY_WORDLEFT | MUIX_I
MUIA_Window_Window | MUIKEY_WORDRIGHT | MUIX_L
MUIA_Window_ZoomGadget | MUI_Layout | MUIX_N
MUIB_Aboutmui | MUI_LayoutObj | MUIX_PH
MUIB_Application | MUILM_LAYOUT | MUIX_PT
MUIB_Area | MUILM_MINMAX | MUIX_R
MUIB_AROS | MUILM_UNKNOWN | MUIX_U
MUIB_Balance | MUI_LPR_ABOVE |
MUIB_Bitmap | MUI_LPR_BELOW |

O

OBJ_AddLeft | OBJ_IsInObject | OBJ_MWidth
OBJ_AddTop | OBJ_Left | OBJ_Pens
OBJ_App | OBJ_MaxHeight | OBJ_Right
OBJ_Between | OBJ_MaxWidth | OBJ_Rp
OBJ_Bottom | OBJ_MBottom | OBJ_Screen
OBJ_DefHeight | OBJ_MHeight | OBJ_SubHeight
OBJ_DefWidth | OBJ_MinHeight | OBJ_SubWidth
OBJ_Dri | OBJ_MinWidth | OBJ_Top
OBJ_Flags | OBJ_MLeft | OBJ_Width
OBJ_Font | OBJ_MRight | OBJ_Win
OBJ_Height | OBJ_MTop | OBJ_Window

P

Pdt_frame_image | PMUIP_DisconnectParent | PMUIP_Numeric_ValueToScale
P__dummyAreaData__ | PMUIP_DoDrag | PMUIP_Numeric_ValueToScaleExt
PMUI_AreaData | PMUIP_DragBegin | PMUIP_Pendisplay_SetColormap
PMUI_BoopsiQuery | PMUIP_DragDrop | PMUIP_Pendisplay_SetMUIPen
PMUI_Command | PMUIP_DragFinish | PMUIP_Pendisplay_SetRGB
PMUI_CustomClass | PMUIP_DragQuery | PMUIP_Popstring_Close
PMUI_DragImage | PMUIP_DragReport | PMUIP_Popstring_Open
PMUI_EventHandlerNode | PMUIP_Draw | PMUIP_Prop_Decrease
PMUI_FrameSpec | PMUIP_DrawBackground | PMUIP_Prop_Increase
PMUI_GlobalInfo | PMUIP_DrawBackgroundBuffered | PMUIP_Semaphore_Attempt
PMUI_ImageSpec_intern | PMUIP_DrawParentBackground | PMUIP_Semaphore_AttemptShared
PMUI_InputHandlerNode | PMUI_PenSpec | PMUIP_Semaphore_Obtain
PMUI_LayoutMsg | PMUIP_Export | PMUIP_Semaphore_ObtainShared
PMUI_List_TestPos_Result | PMUIP_Family_AddHead | PMUIP_Semaphore_Release
PMUI_MinMax | PMUIP_Family_AddTail | PMUIP_Set
PMUI_NotifyData | PMUIP_Family_GetChild | PMUIP_SetAsString
PMUI_Palette_Entry | PMUIP_Family_Insert | PMUIP_Settingsgroup_ConfigToGadgets
PMUIP_Application_AboutMUI | PMUIP_Family_Remove | PMUIP_Settingsgroup_GadgetsToConfig
PMUIP_Application_AddInputHandler | PMUIP_Family_Sort | PMUIP_SetUData
PMUIP_Application_CheckRefresh | PMUIP_Family_Transfer | PMUIP_SetUDataOnce
PMUIP_Application_GetMenuCheck | PMUIP_FindUData | PMUIP_Setup
PMUIP_Application_GetMenuState | PMUIP_Floattext_Append | PMUIP_Show
PMUIP_Application_Input | PMUIP_GetConfigItem | PMUIP_String_ClearSelected
PMUIP_Application_InputBuffered | PMUIP_GetUData | PMUI_PubScreenDesc
PMUIP_Application_Load | PMUIP_GoActive | PMUIP_UnknownDropDestination
PMUIP_Application_NewInput | PMUIP_GoInactive | PMUIP_Window_ActionIconify
PMUIP_Application_OpenConfigWindow | PMUIP_Group_AddHead | PMUIP_Window_AddControlCharHandler
PMUIP_Application_PushMethod | PMUIP_Group_AddTail | PMUIP_Window_AddEventHandler
PMUIP_Application_RemInputHandler | PMUIP_Group_DoMethodNoForward | PMUIP_Window_AllocGadgetID
PMUIP_Application_ReturnID | PMUIP_Group_ExitChange | PMUIP_Window_Cleanup
PMUIP_Application_SetConfigItem | PMUIP_Group_InitChange | PMUIP_Window_DragObject
PMUIP_Application_SetMenuCheck | PMUIP_Group_Remove | PMUIP_Window_DrawBackground
PMUIP_Application_SetMenuState | PMUIP_Group_Sort | PMUIP_Window_FreeGadgetID
PMUIP_Application_ShowHelp | PMUIP_HandleEvent | PMUIP_Window_RecalcDisplay
PMUIP_Application_UnpushMethod | PMUIP_HandleInput | PMUIP_Window_RemControlCharHandler
PMUIP_AskMinMax | PMUIP_Hide | PMUIP_Window_RemEventHandler
PMUIP_CallHook | PMUIP_Import | PMUIP_Window_ScreenToBack
PMUIP_Cleanup | PMUIP_KillNotify | PMUIP_Window_ScreenToFront
PMUIP_Configdata_GetString | PMUIP_KillNotifyObj | PMUIP_Window_Setup
PMUIP_Configdata_GetULong | PMUIP_Layout | PMUIP_Window_Snapshot
PMUIP_Configdata_Load | PMUIP_List_Clear | PMUIP_Window_ToBack
PMUIP_Configdata_Save | PMUIP_List_Compare | PMUIP_Window_ToFront
PMUIP_Configdata_SetFont | PMUIP_List_Construct | PMUIP_WriteLong
PMUIP_Configdata_SetFramespec | PMUIP_List_CreateImage | PMUIP_WriteString
PMUIP_Configdata_SetImspec | PMUIP_List_DeleteImage | PMUI_RenderInfo
PMUIP_Configdata_SetPenspec | PMUIP_List_Exchange | PMUI_RGBColor
PMUIP_Configdata_SetString | PMUIP_List_GetEntry | PMUIS_InfoClient
PMUIP_Configdata_SetULong | PMUIP_List_Insert | PSD_FILENAME_SAVE
PMUIP_ConnectParent | PMUIP_List_InsertSingle | PSD_FILENAME_USE
PMUIP_ContextMenuBuild | PMUIP_List_Jump | PSD_INITIAL_NAME
PMUIP_ContextMenuChoice | PMUIP_List_Move | PSD_INITIAL_TITLE
PMUIP_CreateBubble | PMUIP_List_NextSelected | PSD_MAXLEN_BACKGROUND
PMUIP_CreateDragImage | PMUIP_List_Redraw | PSD_MAXLEN_FONT
PMUIP_CreateShortHelp | PMUIP_List_Remove | PSD_MAXLEN_NAME
PMUIP_CustomBackfill | PMUIP_List_Select | PSD_MAXLEN_TITLE
PMUIP_Dataspace_Add | PMUIP_List_Sort | PSD_MAXMUIPENS
PMUIP_Dataspace_Clear | PMUIP_List_TestPos | PSD_MAXSYSPENS
PMUIP_Dataspace_Find | PMUIP_MultiSet | PSD_NAME_FRONTMOST
PMUIP_Dataspace_Merge | PMUIP_NoNotifySet | PSD_NUMCOLS
PMUIP_Dataspace_ReadIFF | PMUIP_Notify | PSD_NUMMUIPENS
PMUIP_Dataspace_Remove | PMUIP_Numeric_Decrease | PSD_NUMSYSPENS
PMUIP_Dataspace_WriteIFF | PMUIP_Numeric_Increase | PST_CMAP
PMUIP_DeleteBubble | PMUIP_Numeric_ScaleToValue | PST_MUI
PMUIP_DeleteDragImage | PMUIP_Numeric_SetDefault | PST_RGB
PMUIP_DeleteShortHelp | PMUIP_Numeric_Stringify | PST_SYS

T

Tdt_frame_image | TMUIP_DeleteBubble | TMUIP_Notify
T__dummyAreaData__ | TMUIP_DeleteDragImage | TMUIP_Numeric_Decrease
TMUI_AreaData | TMUIP_DeleteShortHelp | TMUIP_Numeric_Increase
TMUI_BoopsiQuery | TMUIP_Dirlist_ReRead | TMUIP_Numeric_ScaleToValue
TMUI_Command | TMUIP_DisconnectParent | TMUIP_Numeric_SetDefault
TMUI_CustomClass | TMUIP_DoDrag | TMUIP_Numeric_Stringify
TMUI_DragImage | TMUIP_DragBegin | TMUIP_Numeric_ValueToScale
TMUI_EventHandlerNode | TMUIP_DragDrop | TMUIP_Numeric_ValueToScaleExt
TMUI_FrameSpec | TMUIP_DragFinish | TMUIP_Pendisplay_SetColormap
TMUI_GlobalInfo | TMUIP_DragQuery | TMUIP_Pendisplay_SetMUIPen
TMUI_ImageSpec_intern | TMUIP_DragReport | TMUIP_Pendisplay_SetRGB
TMUI_InputHandlerNode | TMUIP_Draw | TMUIP_Pixmap_DrawSection
TMUI_LayoutMsg | TMUIP_DrawBackground | TMUIP_Popstring_Close
TMUI_List_TestPos_Result | TMUIP_DrawBackgroundBuffered | TMUIP_Popstring_Open
TMUI_MinMax | TMUIP_DrawParentBackground | TMUIP_Process_Kill
TMUI_NotifyData | TMUI_PenSpec | TMUIP_Process_Launch
TMUI_Palette_Entry | TMUIP_Export | TMUIP_Process_Process
TMUIP_Application_AboutMUI | TMUIP_Family_AddHead | TMUIP_Process_Signal
TMUIP_Application_AddInputHandler | TMUIP_Family_AddTail | TMUIP_Prop_Decrease
TMUIP_Application_CheckRefresh | TMUIP_Family_GetChild | TMUIP_Prop_Increase
TMUIP_Application_GetMenuCheck | TMUIP_Family_Insert | TMUIP_Semaphore_Attempt
TMUIP_Application_GetMenuState | TMUIP_Family_Remove | TMUIP_Semaphore_AttemptShared
TMUIP_Application_Input | TMUIP_Family_Sort | TMUIP_Semaphore_Obtain
TMUIP_Application_InputBuffered | TMUIP_Family_Transfer | TMUIP_Semaphore_ObtainShared
TMUIP_Application_Load | TMUIP_FindUData | TMUIP_Semaphore_Release
TMUIP_Application_NewInput | TMUIP_Floattext_Append | TMUIP_Set
TMUIP_Application_OpenConfigWindow | TMUIP_GetConfigItem | TMUIP_SetAsString
TMUIP_Application_PushMethod | TMUIP_GetUData | TMUIP_Settingsgroup_ConfigToGadgets
TMUIP_Application_RemInputHandler | TMUIP_GoActive | TMUIP_Settingsgroup_GadgetsToConfig
TMUIP_Application_ReturnID | TMUIP_GoInactive | TMUIP_SetUData
TMUIP_Application_Save | TMUIP_Group_AddHead | TMUIP_SetUDataOnce
TMUIP_Application_SetConfigItem | TMUIP_Group_AddTail | TMUIP_Setup
TMUIP_Application_SetMenuCheck | TMUIP_Group_DoMethodNoForward | TMUIP_Show
TMUIP_Application_SetMenuState | TMUIP_Group_ExitChange | TMUIP_String_ClearSelected
TMUIP_Application_ShowHelp | TMUIP_Group_InitChange | TMUIP_String_FileNameStart
TMUIP_Application_UnpushMethod | TMUIP_Group_Remove | TMUIP_String_Insert
TMUIP_AskMinMax | TMUIP_Group_Sort | TMUI_PubScreenDesc
TMUIP_CallHook | TMUIP_HandleEvent | TMUIP_UnknownDropDestination
TMUIP_Cleanup | TMUIP_HandleInput | TMUIP_Window_ActionIconify
TMUIP_Configdata_GetString | TMUIP_Hide | TMUIP_Window_AddControlCharHandler
TMUIP_Configdata_GetULong | TMUIP_Import | TMUIP_Window_AddEventHandler
TMUIP_Configdata_Load | TMUIP_KillNotify | TMUIP_Window_AllocGadgetID
TMUIP_Configdata_Save | TMUIP_KillNotifyObj | TMUIP_Window_Cleanup
TMUIP_Configdata_SetFont | TMUIP_Layout | TMUIP_Window_DragObject
TMUIP_Configdata_SetFramespec | TMUIP_List_Clear | TMUIP_Window_DrawBackground
TMUIP_Configdata_SetImspec | TMUIP_List_Compare | TMUIP_Window_FreeGadgetID
TMUIP_Configdata_SetPenspec | TMUIP_List_Construct | TMUIP_Window_RecalcDisplay
TMUIP_Configdata_SetString | TMUIP_List_CreateImage | TMUIP_Window_RemControlCharHandler
TMUIP_Configdata_SetULong | TMUIP_List_DeleteImage | TMUIP_Window_RemEventHandler
TMUIP_ConnectParent | TMUIP_List_Exchange | TMUIP_Window_ScreenToBack
TMUIP_ContextMenuBuild | TMUIP_List_GetEntry | TMUIP_Window_ScreenToFront
TMUIP_ContextMenuChoice | TMUIP_List_Insert | TMUIP_Window_Setup
TMUIP_CreateBubble | TMUIP_List_InsertSingle | TMUIP_Window_Snapshot
TMUIP_CreateDragImage | TMUIP_List_Jump | TMUIP_Window_ToBack
TMUIP_CreateShortHelp | TMUIP_List_Move | TMUIP_Window_ToFront
TMUIP_CustomBackfill | TMUIP_List_NextSelected | TMUIP_Window_UpdateMenu
TMUIP_Dataspace_Add | TMUIP_List_Redraw | TMUIP_WriteLong
TMUIP_Dataspace_Clear | TMUIP_List_Remove | TMUIP_WriteString
TMUIP_Dataspace_Find | TMUIP_List_Select | TMUI_RenderInfo
TMUIP_Dataspace_Merge | TMUIP_List_Sort | TMUI_RGBcolor
TMUIP_Dataspace_ReadIFF | TMUIP_List_TestPos | TMUIS_InfoClient
TMUIP_Dataspace_Remove | TMUIP_MultiSet | TWindowPos
TMUIP_Dataspace_WriteIFF | TMUIP_NoNotifySet |


MUIAreaData

Declaration

Source position: mui.pas line 3736

function MUIAreaData(

  Obj: Pointer

):PMUI_AreaData;


MUIGlobalInfo

Declaration

Source position: mui.pas line 3737

function MUIGlobalInfo(

  Obj: Pointer

):PMUI_GlobalInfo;


MUINotifyData

Declaration

Source position: mui.pas line 3735

function MUINotifyData(

  Obj: Pointer

):PMUI_NotifyData;


MUIObtain

Declaration

Source position: mui.pas line 3692

function MUIObtain: LongWord;


MUIPen

Declaration

Source position: mui.pas line 3740

function MUIPen(

  Pen: LongInt

):LongInt;


MUIPEN_MASK

Declaration

Source position: mui.pas line 443

const MUIPEN_MASK = $0000ffff;


MUIRelease

Declaration

Source position: mui.pas line 3693

function MUIRelease: LongWord;


MUIRenderInfo

Declaration

Source position: mui.pas line 3739

function MUIRenderInfo(

  Obj: Pointer

):PMUI_RenderInfo;


MUIUserData

Declaration

Source position: mui.pas line 3738

function MUIUserData(

  Obj: Pointer

):Pointer;


MUIV_Window_AltHeight_MinMax

Declaration

Source position: mui.pas line 3783

function MUIV_Window_AltHeight_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_AltHeight_Screen

Declaration

Source position: mui.pas line 3785

function MUIV_Window_AltHeight_Screen(

  p: LongInt

):LongInt;


MUIV_Window_AltHeight_Visible

Declaration

Source position: mui.pas line 3784

function MUIV_Window_AltHeight_Visible(

  p: LongInt

):LongInt;


MUIV_Window_AltTopEdge_Delta

Declaration

Source position: mui.pas line 3786

function MUIV_Window_AltTopEdge_Delta(

  p: LongInt

):LongInt;


MUIV_Window_AltWidth_MinMax

Declaration

Source position: mui.pas line 3787

function MUIV_Window_AltWidth_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_AltWidth_Screen

Declaration

Source position: mui.pas line 3789

function MUIV_Window_AltWidth_Screen(

  p: LongInt

):LongInt;


MUIV_Window_AltWidth_Visible

Declaration

Source position: mui.pas line 3788

function MUIV_Window_AltWidth_Visible(

  p: LongInt

):LongInt;


MUIV_Window_Height_MinMax

Declaration

Source position: mui.pas line 3790

function MUIV_Window_Height_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_Height_Screen

Declaration

Source position: mui.pas line 3792

function MUIV_Window_Height_Screen(

  p: LongInt

):LongInt;


MUIV_Window_Height_Visible

Declaration

Source position: mui.pas line 3791

function MUIV_Window_Height_Visible(

  p: LongInt

):LongInt;


MUIV_Window_TopEdge_Delta

Declaration

Source position: mui.pas line 3793

function MUIV_Window_TopEdge_Delta(

  p: LongInt

):LongInt;


MUIV_Window_Width_MinMax

Declaration

Source position: mui.pas line 3794

function MUIV_Window_Width_MinMax(

  p: LongInt

):LongInt;


MUIV_Window_Width_Screen

Declaration

Source position: mui.pas line 3796

function MUIV_Window_Width_Screen(

  p: LongInt

):LongInt;


MUIV_Window_Width_Visible

Declaration

Source position: mui.pas line 3795

function MUIV_Window_Width_Visible(

  p: LongInt

):LongInt;


MUI_AddClipping

Declaration

Source position: mui.pas line 3721

function MUI_AddClipping(

  Mri: PMUI_RenderInfo;

  l: LongInt;

  t: LongInt;

  w: LongInt;

  h: LongInt

):Pointer;


MUI_AddClipRegion

Declaration

Source position: mui.pas line 3723

function MUI_AddClipRegion(

  Mri: PMUI_RenderInfo;

  Region: PRegion

):Pointer;


MUI_AllocAslRequest

Declaration

Source position: mui.pas line 3701

function MUI_AllocAslRequest(

  Type_: LongWord;

  TagList: PTagItem

):Pointer;


MUI_AllocAslRequestTags

Declaration

Source position: mui.pas line 3800

function MUI_AllocAslRequestTags(

  ReqTyp: LongWord;

  const Tags: array of PtrUInt

):Pointer;


MUI_AslRequest

Declaration

Source position: mui.pas line 3703

function MUI_AslRequest(

  Req: Pointer;

  TagList: PTagItem

):LongBool;


MUI_AslRequestTags

Declaration

Source position: mui.pas line 3801

function MUI_AslRequestTags(

  req: Pointer;

  const Tags: array of PtrUInt

):LongBool;


MUI_BeginRefresh

Declaration

Source position: mui.pas line 3725

function MUI_BeginRefresh(

  Mri: PMUI_RenderInfo;

  Flags: LongWord

):LongBool;


MUI_CreateCustomClass

Declaration

Source position: mui.pas line 3713

function MUI_CreateCustomClass(

  Base: PLibrary;

  const Supername: PChar;

  Supermcc: PMUI_CustomClass;

  DataSize: LongWord;

  Dispatcher: Pointer

):PMUI_CustomClass;


MUI_DeleteCustomClass

Declaration

Source position: mui.pas line 3714

function MUI_DeleteCustomClass(

  Mcc: PMUI_CustomClass

):LongBool;


MUI_DisposeObject

Declaration

Source position: mui.pas line 3698

procedure MUI_DisposeObject(

  Obj: PObject_

);


MUI_EndRefresh

Declaration

Source position: mui.pas line 3726

procedure MUI_EndRefresh(

  Mri: PMUI_RenderInfo;

  Flags: LongWord

);


MUI_Error

Declaration

Source position: mui.pas line 3706

function MUI_Error: LongInt;


MUI_FreeAslRequest

Declaration

Source position: mui.pas line 3705

procedure MUI_FreeAslRequest(

  Req: Pointer

);


MUI_FreeClass

Declaration

Source position: mui.pas line 3709

procedure MUI_FreeClass(

  Cl: PIClass

);


MUI_GetClass

Declaration

Source position: mui.pas line 3708

function MUI_GetClass(

  const ClassID: PChar

):PIClass;


MUI_Hide

Declaration

Source position: mui.pas line 3729

function MUI_Hide(

  Obj: PObject_

):LongWord;


MUI_Layout

Declaration

Source position: mui.pas line 3717

function MUI_Layout(

  Obj: PObject_;

  l: LongInt;

  t: LongInt;

  w: LongInt;

  h: LongInt;

  Flags: LongWord

):LongBool;


MUI_LayoutObj

Declaration

Source position: mui.pas line 3730

function MUI_LayoutObj(

  Obj: PObject_;

  l: LongInt;

  t: LongInt;

  w: LongInt;

  h: LongInt;

  Flags: LongWord

):LongBool;


MUI_MakeObject

Declaration

Source position: mui.pas line 3802

function MUI_MakeObject(

  _Type: LongInt;

  const Params: array of PtrUInt

):PObject_;


MUI_MakeObjectA

Declaration

Source position: mui.pas line 3715

function MUI_MakeObjectA(

  Type_: LongInt;

  Params: PLongWord

):PObject_;


MUI_NewObject

Declaration

Source position: mui.pas line 3803

function MUI_NewObject(

  a0arg: PChar;

  const Tags: array of PtrUInt

):PObject_;


MUI_NewObjectA

Declaration

Source position: mui.pas line 3696

function MUI_NewObjectA(

  const ClassID: PChar;

  Tags: PTagItem

):PObject_;


MUI_ObtainPen

Declaration

Source position: mui.pas line 3719

function MUI_ObtainPen(

  Mri: PMUI_RenderInfo;

  Spec: PMUI_PenSpec;

  Flags: LongWord

):LongInt;


MUI_Offset

Declaration

Source position: mui.pas line 3731

function MUI_Offset(

  Obj: PObject_;

  X: LongInt;

  Y: LongInt

):LongBool;


MUI_Redraw

Declaration

Source position: mui.pas line 3712

procedure MUI_Redraw(

  Obj: PObject_;

  Flags: LongWord

);


MUI_RejectIDCMP

Declaration

Source position: mui.pas line 3711

procedure MUI_RejectIDCMP(

  Obj: PObject_;

  Flags: LongWord

);


MUI_ReleasePen

Declaration

Source position: mui.pas line 3720

procedure MUI_ReleasePen(

  Mri: PMUI_RenderInfo;

  Pen: LongInt

);


MUI_RemoveClipping

Declaration

Source position: mui.pas line 3722

procedure MUI_RemoveClipping(

  Mri: PMUI_RenderInfo;

  h: Pointer

);


MUI_RemoveClipRegion

Declaration

Source position: mui.pas line 3724

procedure MUI_RemoveClipRegion(

  Mri: PMUI_RenderInfo;

  Region: Pointer

);


MUI_Request

Declaration

Source position: mui.pas line 3804

function MUI_Request(

  App: Pointer;

  win: Pointer;

  Flags: LongWord;

  Title: PChar;

  Gadgets: PChar;

  Format: PChar;

  const Params: array of PtrUInt

):LongInt;


MUI_RequestA

Declaration

Source position: mui.pas line 3699

function MUI_RequestA(

  App: PObject_;

  Win: PObject_;

  Flags: LongWord;

  const Title: PChar;

  const Gadgets: PChar;

  const Format: PChar;

  Params: Pointer

):LongInt;


MUI_RequestIDCMP

Declaration

Source position: mui.pas line 3710

procedure MUI_RequestIDCMP(

  Obj: PObject_;

  Flags: LongWord

);


MUI_SetError

Declaration

Source position: mui.pas line 3707

function MUI_SetError(

  ErrNum: LongInt

):LongInt;


MUI_Show

Declaration

Source position: mui.pas line 3728

function MUI_Show(

  Obj: PObject_

):LongWord;


OBJ_AddLeft

Declaration

Source position: mui.pas line 3761

function OBJ_AddLeft(

  Obj: Pointer

):SmallInt;


OBJ_AddTop

Declaration

Source position: mui.pas line 3762

function OBJ_AddTop(

  Obj: Pointer

):SmallInt;


OBJ_App

Declaration

Source position: mui.pas line 3748

function OBJ_App(

  Obj: Pointer

):PObject_;


OBJ_Between

Declaration

Source position: mui.pas line 3780

function OBJ_Between(

  a: SmallInt;

  x: SmallInt;

  b: SmallInt

):Boolean;


OBJ_Bottom

Declaration

Source position: mui.pas line 3760

function OBJ_Bottom(

  Obj: Pointer

):SmallInt;


OBJ_DefHeight

Declaration

Source position: mui.pas line 3777

function OBJ_DefHeight(

  Obj: Pointer

):LongWord;


OBJ_DefWidth

Declaration

Source position: mui.pas line 3776

function OBJ_DefWidth(

  Obj: Pointer

):LongWord;


OBJ_Dri

Declaration

Source position: mui.pas line 3750

function OBJ_Dri(

  Obj: Pointer

):PDrawInfo;


OBJ_Flags

Declaration

Source position: mui.pas line 3778

function OBJ_Flags(

  Obj: Pointer

):LongWord;


OBJ_Font

Declaration

Source position: mui.pas line 3771

function OBJ_Font(

  Obj: Pointer

):PTextFont;


OBJ_Height

Declaration

Source position: mui.pas line 3758

function OBJ_Height(

  Obj: Pointer

):SmallInt;


OBJ_IsInObject

Declaration

Source position: mui.pas line 3781

function OBJ_IsInObject(

  x: SmallInt;

  y: SmallInt;

  Obj: PObject_

):Boolean;


OBJ_Left

Declaration

Source position: mui.pas line 3755

function OBJ_Left(

  Obj: Pointer

):SmallInt;


OBJ_MaxHeight

Declaration

Source position: mui.pas line 3775

function OBJ_MaxHeight(

  Obj: Pointer

):LongWord;


OBJ_MaxWidth

Declaration

Source position: mui.pas line 3774

function OBJ_MaxWidth(

  Obj: Pointer

):LongWord;


OBJ_MBottom

Declaration

Source position: mui.pas line 3770

function OBJ_MBottom(

  Obj: Pointer

):SmallInt;


OBJ_MHeight

Declaration

Source position: mui.pas line 3768

function OBJ_MHeight(

  Obj: Pointer

):SmallInt;


OBJ_MinHeight

Declaration

Source position: mui.pas line 3773

function OBJ_MinHeight(

  Obj: Pointer

):LongWord;


OBJ_MinWidth

Declaration

Source position: mui.pas line 3772

function OBJ_MinWidth(

  Obj: Pointer

):LongWord;


OBJ_MLeft

Declaration

Source position: mui.pas line 3765

function OBJ_MLeft(

  Obj: Pointer

):SmallInt;


OBJ_MRight

Declaration

Source position: mui.pas line 3769

function OBJ_MRight(

  Obj: Pointer

):SmallInt;


OBJ_MTop

Declaration

Source position: mui.pas line 3766

function OBJ_MTop(

  Obj: Pointer

):SmallInt;


OBJ_MWidth

Declaration

Source position: mui.pas line 3767

function OBJ_MWidth(

  Obj: Pointer

):SmallInt;


OBJ_Pens

Declaration

Source position: mui.pas line 3752

function OBJ_Pens(

  Obj: Pointer

):PWord;


OBJ_Right

Declaration

Source position: mui.pas line 3759

function OBJ_Right(

  Obj: Pointer

):SmallInt;


OBJ_Rp

Declaration

Source position: mui.pas line 3754

function OBJ_Rp(

  Obj: Pointer

):PRastPort;


OBJ_Screen

Declaration

Source position: mui.pas line 3751

function OBJ_Screen(

  Obj: Pointer

):PScreen;


OBJ_SubHeight

Declaration

Source position: mui.pas line 3764

function OBJ_SubHeight(

  Obj: Pointer

):SmallInt;


OBJ_SubWidth

Declaration

Source position: mui.pas line 3763

function OBJ_SubWidth(

  Obj: Pointer

):SmallInt;


OBJ_Top

Declaration

Source position: mui.pas line 3756

function OBJ_Top(

  Obj: Pointer

):SmallInt;


OBJ_Width

Declaration

Source position: mui.pas line 3757

function OBJ_Width(

  Obj: Pointer

):SmallInt;


OBJ_Win

Declaration

Source position: mui.pas line 3749

function OBJ_Win(

  Obj: Pointer

):PObject_;


OBJ_Window

Declaration

Source position: mui.pas line 3753

function OBJ_Window(

  Obj: Pointer

):PWindow;


Reference for unit 'picasso96api': Procedures and functions

p96AllocBitMap

p96AllocModeListTagList

p96AllocModeListTags

p96BestModeIDTagList

p96BestModeIDTags

p96Clone

p96CloseScreen

p96EncodeColor

p96Expunge

p96FreeBitMap

p96FreeModeList

p96GetBitMapAttr

p96GetBoardDataTagList

p96GetBoardDataTags

p96GetModeIDAttr

p96GetRTGDataTagList

p96GetRTGDataTags

p96LockBitMap

p96LockBitMapToBoard

p96Obtain

p96OpenScreenTagList

p96OpenScreenTags

p96PIP_Close

p96PIP_GetIMsg

p96PIP_GetTagList

p96PIP_GetTags

p96PIP_OpenTagList

p96PIP_OpenTags

p96PIP_ReplyIMsg

p96PIP_SetTagList

p96PIP_SetTags

p96ReadPixel

p96ReadPixelArray

p96ReadTrueColorData

p96RectFill

p96Release

p96RequestModeIDTagList

p96RequestModeIDTags

p96UnlockBitMap

p96UnlockBitMapFromBoard

p96WritePixel

p96WritePixelArray

p96WriteTrueColorData


Unit 'picasso96api' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'picasso96api': Variables

IP96

P96Base


Index of all identifiers in unit 'picasso96api'

B I M P R T

B

BMF_USERPRIVATE

I

IP96

M

MODENAMELENGTH

P

p96AllocBitMap | P96IDA_PABLOIVCOMPATIBLE | P96RD_Dummy
p96AllocModeListTagList | P96IDA_PALOMAIVCOMPATIBLE | P96RD_NumberOfBoards
p96AllocModeListTags | P96IDA_RGBFORMAT | p96ReadPixel
P96Base | P96IDA_STDBYTESPERROW | p96ReadPixelArray
P96BD_BoardDriver | P96IDA_VIDEOCOMPATIBLE | p96ReadTrueColorData
P96BD_BoardName | P96IDA_WIDTH | p96RectFill
P96BD_ChipDriver | p96LockBitMap | p96Release
P96BD_ChipName | p96LockBitMapToBoard | p96RequestModeIDTagList
P96BD_Dummy | P96MA_CancelText | p96RequestModeIDTags
P96BD_FreeMemory | P96MA_DisplayID | P96SA_Alignment
P96BD_InternalMemorySize | P96MA_Dummy | P96SA_AutoScroll
P96BD_LargestFreeMemory | P96MA_FormatsAllowed | P96SA_BackFill
P96BD_MemoryClock | P96MA_FormatsForbidden | P96SA_Behind
P96BD_MonitorDisplayHeight | P96MA_MaxDepth | P96SA_BitMap
P96BD_MonitorDisplayWidth | P96MA_MaxHeight | P96SA_BlockPen
P96BD_MonitorDotClockMax | P96MA_MaxWidth | P96SA_Colors
P96BD_MonitorDotClockMin | P96MA_MinDepth | P96SA_Colors32
P96BD_MonitorEDIDRev | P96MA_MinHeight | P96SA_ConstantBytesPerRow
P96BD_MonitorEDIDVer | P96MA_MinWidth | P96SA_ConstantByteSwapping
P96BD_MonitorHSyncMax | P96MA_OKText | P96SA_DClip
P96BD_MonitorHSyncMin | P96MA_PabloIVCompatible | P96SA_Depth
P96BD_MonitorInputType | P96MA_PalomaIVCompatible | P96SA_DetailPen
P96BD_MonitorProduct | P96MA_PubScreenName | P96SA_DisplayID
P96BD_MonitorProductID | P96MA_Screen | P96SA_Dummy
P96BD_MonitorSwitch | P96MA_VideoCompatible | P96SA_ErrorCode
P96BD_MonitorVendorID | P96MA_Window | P96SA_Exclusive
P96BD_MonitorVSyncMax | P96MA_WindowTitle | P96SA_FixedScreen
P96BD_MonitorVSyncMin | p96Obtain | P96SA_Font
P96BD_PCIProductID | p96OpenScreenTagList | P96SA_Height
P96BD_PCIVendorID | p96OpenScreenTags | P96SA_Left
P96BD_RGBFormats | P96PIP_Alignment | P96SA_NoMemory
P96BD_TotalMemory | P96PIP_AllowCropping | P96SA_NoSprite
p96BestModeIDTagList | P96PIP_Brightness | P96SA_Pens
p96BestModeIDTags | P96PIP_ClipHeight | P96SA_PubName
P96BIDTAG_Depth | P96PIP_ClipLeft | P96SA_PubSig
P96BIDTAG_Dummy | P96PIP_ClipTop | P96SA_PubTask
P96BIDTAG_FormatsAllowed | P96PIP_ClipWidth | P96SA_Quiet
P96BIDTAG_FormatsForbidden | p96PIP_Close | P96SA_RenderFunc
P96BIDTAG_NominalHeight | P96PIP_ColorKeyARGB | P96SA_RGBFormat
P96BIDTAG_NominalWidth | P96PIP_ColorKeyPen | P96SA_SaveFunc
P96BIDTAG_PabloIVCompatible | P96PIP_Colors | P96SA_SharePens
P96BIDTAG_PalomaIVCompatible | P96PIP_Colors32 | P96SA_ShowTitle
P96BIDTAG_VideoCompatible | P96PIP_ConstantBytesPerRow | P96SA_SysFont
P96BMA_BITSPERPIXEL | P96PIP_ConstantByteSwapping | P96SA_Title
P96BMA_BOARDIOBASE | P96PIP_DisplayedBuffer | P96SA_Top
P96BMA_BOARDMEMBASE | P96PIP_Dummy | P96SA_Type
P96BMA_BOARDMEMIOBASE | P96PIP_ErrorCode | P96SA_UserData
P96BMA_BYTESPERPIXEL | p96PIP_GetIMsg | P96SA_VideoControl
P96BMA_BYTESPERROW | p96PIP_GetTagList | P96SA_Width
P96BMA_DEPTH | p96PIP_GetTags | p96UnlockBitMap
P96BMA_HEIGHT | P96PIP_Height | p96UnlockBitMapFromBoard
P96BMA_ISONBOARD | P96PIP_InitialIntScaling | p96WritePixel
P96BMA_ISP96 | P96PIP_Left | p96WritePixelArray
P96BMA_MEMORY | P96PIP_NoMemory | p96WriteTrueColorData
P96BMA_RGBFORMAT | P96PIP_NumberOfBuffers | PICASSO96APINAME
P96BMA_WIDTH | p96PIP_OpenTagList | PIPERR_ATTACHFAIL
p96Clone | p96PIP_OpenTags | PIPERR_BADALIGNMENT
p96CloseScreen | P96PIP_Relativity | PIPERR_BADDIMENSIONS
p96EncodeColor | P96PIP_RenderFunc | PIPERR_CROPPED
p96Expunge | p96PIP_ReplyIMsg | PIPERR_NOMEMORY
p96FreeBitMap | P96PIP_SaveFunc | PIPERR_NOTAVAILABLE
p96FreeModeList | p96PIP_SetTagList | PIPERR_NOWINDOW
p96GetBitMapAttr | p96PIP_SetTags | PIPERR_OUTOFPENS
p96GetBoardDataTagList | P96PIP_SourceBitMap | PIPRel_Bottom
p96GetBoardDataTags | P96PIP_SourceFormat | PIPRel_Height
p96GetModeIDAttr | P96PIP_SourceHeight | PIPRel_Right
p96GetRTGDataTagList | P96PIP_SourceRPort | PIPRel_Width
p96GetRTGDataTags | P96PIP_SourceWidth | PIPT_MemoryWindow
P96IDA_BITSPERPIXEL | P96PIPT_MemoryWindow | PIPT_NUMTYPES
P96IDA_BOARDNAME | P96PIP_Top | PIPT_VideoWindow
P96IDA_BOARDNUMBER | P96PIPT_VideoWindow | PP96Mode
P96IDA_BYTESPERPIXEL | P96PIP_Type | PRenderInfo
P96IDA_COMPATIBLEFORMATS | P96PIP_UserData | PTrueColorInfo
P96IDA_DEPTH | P96PIP_VisibleBuffer | PYUVRenderInfo
P96IDA_HEIGHT | P96PIP_Width |
P96IDA_ISP96 | P96PIP_WorkBuffer |

R

RGBFB_A8B8G8R8 | RGBFB_YUV410P | RGBFF_NONE
RGBFB_A8R8G8B8 | RGBFB_YUV411 | RGBFF_R5G5B5
RGBFB_ALPHA8 | RGBFB_YUV420P | RGBFF_R5G5B5PC
RGBFB_B5G5R5PC | RGBFB_YUV422 | RGBFF_R5G6B5
RGBFB_B5G6R5PC | RGBFB_YUV422CGX | RGBFF_R5G6B5PC
RGBFB_B8G8R8 | RGBFB_YUV422PA | RGBFF_R8G8B8
RGBFB_B8G8R8A8 | RGBFB_YUV422PC | RGBFF_R8G8B8A8
RGBFB_CLUT | RGBFF_A8B8G8R8 | RGBFF_TRUEALPHA
RGBFB_MaxFormats | RGBFF_A8R8G8B8 | RGBFF_TRUECOLOR
RGBFB_NONE | RGBFF_ALPHA8 | RGBFF_YUV410P
RGBFB_R5G5B5 | RGBFF_B5G5R5PC | RGBFF_YUV411
RGBFB_R5G5B5PC | RGBFF_B5G6R5PC | RGBFF_YUV420P
RGBFB_R5G6B5 | RGBFF_B8G8R8 | RGBFF_YUV422
RGBFB_R5G6B5PC | RGBFF_B8G8R8A8 | RGBFF_YUV422CGX
RGBFB_R8G8B8 | RGBFF_CLUT | RGBFF_YUV422PA
RGBFB_R8G8B8A8 | RGBFF_HICOLOR | RGBFF_YUV422PC

T

TP96Mode | TRGBFTYPE | TYUVRenderInfo
TRenderInfo | TTrueColorInfo |


p96AllocBitMap

Declaration

Source position: picasso96api.pas line 328

function p96AllocBitMap(

  SizeX: LongWord;

  SizeY: LongWord;

  Depth: LongWord;

  Flags: LongWord;

  Friend: PBitMap;

  RGBFormat: TRGBFTYPE

):PBitMap;


p96AllocModeListTagList

Declaration

Source position: picasso96api.pas line 337

function p96AllocModeListTagList(

  Tags: PTagItem

):PList;


p96AllocModeListTags

Declaration

Source position: picasso96api.pas line 371

function p96AllocModeListTags(

  const Tags: array of PtrUInt

):PList;


p96BestModeIDTagList

Declaration

Source position: picasso96api.pas line 333

function p96BestModeIDTagList(

  Tags: PTagItem

):LongWord;


p96BestModeIDTags

Declaration

Source position: picasso96api.pas line 369

function p96BestModeIDTags(

  const Tags: array of PtrUInt

):LongWord;


p96Clone

Declaration

Source position: picasso96api.pas line 327

function p96Clone: PInterface;


p96CloseScreen

Declaration

Source position: picasso96api.pas line 343

function p96CloseScreen(

  Screen: PScreen

):Wordbool;


p96EncodeColor

Declaration

Source position: picasso96api.pas line 364

function p96EncodeColor(

  RGBFormat: TRGBFTYPE;

  Color: LongWord

):LongWord;


p96Expunge

Declaration

Source position: picasso96api.pas line 326

procedure p96Expunge;


p96FreeBitMap

Declaration

Source position: picasso96api.pas line 329

procedure p96FreeBitMap(

  BitMap: PBitMap

);


p96FreeModeList

Declaration

Source position: picasso96api.pas line 339

procedure p96FreeModeList(

  List: PList

);


p96GetBitMapAttr

Declaration

Source position: picasso96api.pas line 330

function p96GetBitMapAttr(

  BitMap: PBitMap;

  Attribute: LongWord

):LongWord;


p96GetBoardDataTagList

Declaration

Source position: picasso96api.pas line 362

function p96GetBoardDataTagList(

  Board: LongWord;

  Tags: PTagItem

):LongInt;


p96GetBoardDataTags

Declaration

Source position: picasso96api.pas line 377

function p96GetBoardDataTags(

  Board: LongWord;

  const Tags: array of PtrUInt

):LongInt;


p96GetModeIDAttr

Declaration

Source position: picasso96api.pas line 340

function p96GetModeIDAttr(

  Mode: LongWord;

  Attribute: LongWord

):LongWord;


p96GetRTGDataTagList

Declaration

Source position: picasso96api.pas line 360

function p96GetRTGDataTagList(

  Tags: PTagItem

):LongInt;


p96GetRTGDataTags

Declaration

Source position: picasso96api.pas line 376

function p96GetRTGDataTags(

  const Tags: array of PtrUInt

):LongInt;


p96LockBitMap

Declaration

Source position: picasso96api.pas line 331

function p96LockBitMap(

  BitMap: PBitMap;

  Buffer: PByte;

  Size: LongWord

):LongInt;


p96LockBitMapToBoard

Declaration

Source position: picasso96api.pas line 365

function p96LockBitMapToBoard(

  Bm: PBitMap;

  Board_Number: LongWord;

  Buf: PByte;

  Size: LongWord

):WordBool;


p96Obtain

Declaration

Source position: picasso96api.pas line 324

function p96Obtain: LongWord;


p96OpenScreenTagList

Declaration

Source position: picasso96api.pas line 341

function p96OpenScreenTagList(

  Tags: PTagItem

):PScreen;


p96OpenScreenTags

Declaration

Source position: picasso96api.pas line 372

function p96OpenScreenTags(

  const Tags: array of PtrUInt

):PScreen;


p96PIP_Close

Declaration

Source position: picasso96api.pas line 353

function p96PIP_Close(

  Window: PWindow

):Wordbool;


p96PIP_GetIMsg

Declaration

Source position: picasso96api.pas line 358

function p96PIP_GetIMsg(

  Port: PMsgPort

):PIntuiMessage;


p96PIP_GetTagList

Declaration

Source position: picasso96api.pas line 356

function p96PIP_GetTagList(

  Window: PWindow;

  Tags: PTagItem

):LongInt;


p96PIP_GetTags

Declaration

Source position: picasso96api.pas line 375

function p96PIP_GetTags(

  Window: PWindow;

  const Tags: array of PtrUInt

):LongInt;


p96PIP_OpenTagList

Declaration

Source position: picasso96api.pas line 351

function p96PIP_OpenTagList(

  Tags: PTagItem

):PWindow;


p96PIP_OpenTags

Declaration

Source position: picasso96api.pas line 373

function p96PIP_OpenTags(

  const Tags: array of PtrUInt

):PWindow;


p96PIP_ReplyIMsg

Declaration

Source position: picasso96api.pas line 359

procedure p96PIP_ReplyIMsg(

  IntuiMessage: PIntuiMessage

);


p96PIP_SetTagList

Declaration

Source position: picasso96api.pas line 354

function p96PIP_SetTagList(

  Window: PWindow;

  Tags: PTagItem

):LongInt;


p96PIP_SetTags

Declaration

Source position: picasso96api.pas line 374

function p96PIP_SetTags(

  Window: PWindow;

  const Tags: array of PtrUInt

):LongInt;


p96ReadPixel

Declaration

Source position: picasso96api.pas line 347

function p96ReadPixel(

  Rp: PRastPort;

  X: LongWord;

  Y: LongWord

):LongWord;


p96ReadPixelArray

Declaration

Source position: picasso96api.pas line 345

procedure p96ReadPixelArray(

  Ri: PRenderInfo;

  DestX: LongWord;

  DestY: LongWord;

  Rp: PRastPort;

  SrcX: LongWord;

  SrcY: LongWord;

  SizeX: LongWord;

  SizeY: LongWord

);


p96ReadTrueColorData

Declaration

Source position: picasso96api.pas line 350

procedure p96ReadTrueColorData(

  Tci: PTrueColorInfo;

  DestX: LongWord;

  DestY: LongWord;

  Rp: PRastPort;

  SrcX: LongWord;

  SrcY: LongWord;

  SizeX: LongWord;

  SizeY: LongWord

);


p96RectFill

Declaration

Source position: picasso96api.pas line 348

procedure p96RectFill(

  Rp: PRastPort;

  MinX: LongWord;

  MinY: LongWord;

  MaxX: LongWord;

  MaxY: LongWord;

  Color: LongWord

);


p96Release

Declaration

Source position: picasso96api.pas line 325

function p96Release: LongWord;


p96RequestModeIDTagList

Declaration

Source position: picasso96api.pas line 335

function p96RequestModeIDTagList(

  Tags: PTagItem

):LongWord;


p96RequestModeIDTags

Declaration

Source position: picasso96api.pas line 370

function p96RequestModeIDTags(

  const Tags: array of PtrUInt

):LongWord;


p96UnlockBitMap

Declaration

Source position: picasso96api.pas line 332

procedure p96UnlockBitMap(

  BitMap: PBitMap;

  Lock: LongInt

);


p96UnlockBitMapFromBoard

Declaration

Source position: picasso96api.pas line 366

procedure p96UnlockBitMapFromBoard(

  Bm: PBitMap;

  Modified: LongBool

);


p96WritePixel

Declaration

Source position: picasso96api.pas line 346

function p96WritePixel(

  Rp: PRastPort;

  X: LongWord;

  Y: LongWord;

  Color: LongWord

):LongWord;


p96WritePixelArray

Declaration

Source position: picasso96api.pas line 344

procedure p96WritePixelArray(

  Ri: PRenderInfo;

  SrcX: LongWord;

  SrcY: LongWord;

  Rp: PRastPort;

  DestX: LongWord;

  DestY: LongWord;

  SizeX: LongWord;

  SizeY: LongWord

);


p96WriteTrueColorData

Declaration

Source position: picasso96api.pas line 349

procedure p96WriteTrueColorData(

  Tci: PTrueColorInfo;

  SrcX: LongWord;

  SrcY: LongWord;

  Rp: PRastPort;

  DestX: LongWord;

  DestY: LongWord;

  SizeX: LongWord;

  SizeY: LongWord

);


Reference for unit 'timer': Procedures and functions

AddTime

CmpTime

GetSysTime

GetUpTime

MicroDelay

ReadEClock

SubTime

TimerClone

TimerExpunge

TimerObtain

TimerRelease


Unit 'timer' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'timer': Variables

ITimer

TimerBase


Index of all identifiers in unit 'timer'

A C G I M P R S T U

A

AddTime

C

CmpTime

G

GetSysTime GetUpTime

I

ITimer

M

MicroDelay

P

PEClockVal PTimeRequest PTimeVal

R

ReadEClock

S

SubTime

T

TEClockVal | TIMERNAME | TR_GETSYSTIME
TimerBase | TimerObtain | TR_SETSYSTIME
TimerClone | TimerRelease | TTimeRequest
TimerExpunge | TR_ADDREQUEST | TTimeVal

U

UNIT_ECLOCK | UNIT_MICROHZ | UNIT_WAITECLOCK
UNIT_ENTROPY | UNIT_VBLANK | UNIT_WAITUNTIL


AddTime

Declaration

Source position: timer.pas line 76

procedure AddTime(

  Dest: PTimeVal;

  Src: PTimeVal

);


CmpTime

Declaration

Source position: timer.pas line 77

function CmpTime(

  Dest: PTimeVal;

  Src: PTimeVal

):LongInt;


GetSysTime

Declaration

Source position: timer.pas line 80

procedure GetSysTime(

  Dest: PTimeVal

);


GetUpTime

Declaration

Source position: timer.pas line 81

procedure GetUpTime(

  Dest: PTimeVal

);


MicroDelay

Declaration

Source position: timer.pas line 82

procedure MicroDelay(

  MicroSeconds: LongWord

);


ReadEClock

Declaration

Source position: timer.pas line 79

function ReadEClock(

  Dest: PEClockVal

):LongWord;


SubTime

Declaration

Source position: timer.pas line 78

procedure SubTime(

  Dest: PTimeVal;

  Src: PTimeVal

);


TimerClone

Declaration

Source position: timer.pas line 75

function TimerClone: PInterface;


TimerExpunge

Declaration

Source position: timer.pas line 74

procedure TimerExpunge;


TimerObtain

Declaration

Source position: timer.pas line 72

function TimerObtain: LongWord;


TimerRelease

Declaration

Source position: timer.pas line 73

function TimerRelease: LongWord;


Reference for unit 'utility': Procedures and functions

AddNamedObject | Add a named object to the given namespace.
AllocateTagItems | Allocate a tag list.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
AllocNamedObjectA | Allocate a named object.
Amiga2Date | Fill in a ClockData structure based on a system time stamp
ApplyTagChanges | Change a tag list based on a second tag list.
AsTag |
AttemptRemNamedObject | Attempt to remove a named object.
CallHook
CallHookPkt | Invoke a Hook function callback.
CheckDate | Checks a ClockData structure for legal date.
ClearMem
CloneTagItems | Copy a tag list.
CreateSkipList
CreateSplayTree
Date2Amiga | Calculate seconds from 01-Jan-1978.
DeleteSkipList
DeleteSplayTree
FilterTagChanges | Eliminate tags which specify no change.
FilterTagItems | Remove selected items from a tag list.
FindNamedObject | Find the next object of a given name.
FindNameNC
FindSkipNode
FindSplayNode
FindTagItem | Scan a tag list for a specific tag.
FreeNamedObject | Frees a name object.
FreeTagItems | Free an allocated tag list.
GetFirstSkipNode
GetNextSkipNode
GetTagData | Obtain the data corresponding to a tag.
GetUniqueID | Return a relatively unique number.
InsertSkipNode
InsertSplayNode
MapTags | Convert ti_Tag values in a list via map pairing.
MessageDigest_SHA_Final
MessageDigest_SHA_Init
MessageDigest_SHA_Update
MoveMem
NamedObjectName | Return the name of the object.
NextTagItem | Iterate through a tag list.
PackBoolTags | Builds a "flag" word from a tag list
PackStructureTags | Pack a structure with values from taglist.
Random
RefreshTagItemClones | Rejuvenate a clone from the original.
ReleaseNamedObject | Free a named object.
RemNamedObject | Remove a named object.
RemoveSkipNode
RemoveSplayNode
SetMem
Stricmp | Case-insensitive string comparison.
Strlcat
Strlcpy
Strlen
Strnicmp | Length-limited case-insensitive string compare.
TagInArray | Check if a tag value appears in an array of tag values.
TAG_ |
ToLower | Convert a character to lower case.
ToUpper | Convert a character to upper case.
UCS4Count
UCS4ToLower
UCS4ToUpper
UCS4toUTF8
UCS4Valid
UnpackStructureTags | Unpack a structure to values in taglist.
UTF8Count
UTF8Decode
UTF8Encode
UTF8Stricmp
UTF8Strnicmp
UTF8toUCS4
UtilityClone
UtilityExpunge
UtilityObtain
UtilityRelease
VASPrintf
VSNPrintf


Unit 'utility' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'utility': Variables

UtilityBase


Index of all identifiers in unit 'utility'

A C D F G I M N P R S T U V

A

AddNamedObject | Amiga2Date | ANO_UserSpace
AllocateTagItems | ANO_Flags | ApplyTagChanges
AllocNamedObject | ANO_NameSpace | AsTag
AllocNamedObjectA | ANO_Priority | AttemptRemNamedObject

C

CallHook | ClearMem | CreateSplayTree
CallHookPkt | CloneTagItems |
CheckDate | CreateSkipList |

D

Date2Amiga DeleteSkipList DeleteSplayTree

F

FilterTagChanges | FindNameNC | FindTagItem
FilterTagItems | FindSkipNode | FreeNamedObject
FindNamedObject | FindSplayNode | FreeTagItems

G

GetFirstSkipNode | GetTagData
GetNextSkipNode | GetUniqueID

I

INSERTNODE_DUPLICATE_KEY | INSERTNODE_TOO_SHORT | InsertSplayNode
INSERTNODE_OUT_OF_MEMORY | InsertSkipNode |

M

MAP_KEEP_NOT_FOUND | MessageDigest_SHA_Final | MoveMem
MAP_REMOVE_NOT_FOUND | MessageDigest_SHA_Init |
MapTags | MessageDigest_SHA_Update |

N

NamedObjectName | NSB_CASE | NSF_CASE
NextTagItem | NSB_NODUPS | NSF_NODUPS

P

PackBoolTags | PKCTRL_ULONG | PSplayTree
PackStructureTags | PKCTRL_UNPACKONLY | PSTB_EXISTS
PClockData | PKCTRL_UWORD | PSTB_PACK
PKCTRL_BIT | PKCTRL_WORD | PSTB_SIGNED
PKCTRL_BYTE | PMessageDigest_SHA | PSTB_UNPACK
PKCTRL_FLIPBIT | PNamedObject | PSTF_EXISTS
PKCTRL_LONG | PRandomState | PSTF_PACK
PKCTRL_PACKONLY | PSkipList | PSTF_SIGNED
PKCTRL_PACKUNPACK | PSkipNode | PSTF_UNPACK
PKCTRL_UBYTE | PSplayNode | PUtilityBase

R

Random | ReleaseNamedObject | RemoveSkipNode
RefreshTagItemClones | RemNamedObject | RemoveSplayNode

S

SetMem | Strlcat | Strlen
Stricmp | Strlcpy | Strnicmp

T

TAG_ | TAG_MORE | ToUpper
TAG_DONE | TAG_SKIP | TRandomState
TAG_END | TAG_USER | TSkipList
TAGFILTER_AND | TClockData | TSkipNode
TAGFILTER_NOT | TMessageDigest_SHA | TSplayNode
TAG_IGNORE | TNamedObject | TSplayTree
TagInArray | ToLower | TUtilityBase

U

UCS4Count | UTF8Count | UTF_INVALID_SUBST_FFFD
UCS4ToLower | UTF8Decode | UtilityBase
UCS4ToUpper | UTF8Encode | UtilityClone
UCS4toUTF8 | UTF8Stricmp | UtilityExpunge
UCS4Valid | UTF8Strnicmp | UtilityObtain
UnpackStructureTags | UTF8toUCS4 | UtilityRelease

V

VASPrintf VSNPrintf


AddNamedObject

Add a named object to the given namespace.

Declaration

Source position: utility.pas line 263

function AddNamedObject(

  NameSpace: PNamedObject;

  Obj: PNamedObject

):LongBool;

Arguments

NameSpace

The NameSpace to add the NamedObject object to. If this value is nil, then the NamedObject will be added to the root NameSpace. This is useful for sharing NamedObjects between Tasks.

Function result

If the NamedObject can be added to either the supplied NameSpace or the system global NameSpace, this function will return True. Otherwise it will return False. This will generally happen when the NSF_NODUPS flag is set and this NamedObject has the same name as a second object, or when the object is already in a NameSpace.

Description

Adds a given NamedObject to a NameSpace which is addressed through a second NamedObject. Allows you to link a common group of NamedObjects together. If the NameSpace doesn't support duplicate names, then a search for a duplicate will be made, and False returned if one is found.

Errors

Although the AmigaOS 3.1 autodocs did not say so, under 3.0 you couldn't add a NamedObject to a NameSpace when the NamedObject you were adding had a NameSpace itself. This has changed. This is because the autodocs did not say this, and they are right :)

See also

RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AttemptRemNamedObject | Attempt to remove a named object.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


AllocateTagItems

Allocate a tag list.

Declaration

Source position: utility.pas line 247

function AllocateTagItems(

  NumTags: LongWord

):PTagItem;

Function result

the allocated chain of TagItem structures, or nil if there was not enough memory. An allocated tag list must eventually be freed using FreeTagItems().

Description

Allocates the specified number of usable TagItems slots.

Note that to access the TagItems in 'tagList', you should use the function NextTagItem(). This will insure you respect any chaining (TAG_MORE) and secret hiding places (TAG_IGNORE) that this function might generate.

See also

FreeTagItems | Free an allocated tag list.
CloneTagItems | Copy a tag list.


AllocNamedObject

VarArgs Version for AllocNamedObjectA()

Declaration

Source position: utility.pas line 322

function AllocNamedObject(

  Name: PChar;

  const Tags: array of PtrUInt

):PNamedObject;


AllocNamedObjectA

Allocate a named object.

Declaration

Source position: utility.pas line 264

function AllocNamedObjectA(

  const Name: PChar;

  const TagList: PTagItem

):PNamedObject;

Arguments

Name | The name of the NamedObject. Obviously this must be specified
TagList | A TagList containing some extra information for this NamedObject. (ANO_*)

Function result

The object allocated, or nil for failure. The object is defined as a pointer to a pointer. You can do what you wish with the pointer. (It may be nil or contain a pointer to memory that you had asked for in the tags.)

Description

Allocate a new NamedObject and initializes it as requested. This object can then be used as an object in a name space. Optionally you give this object a name space, and use it to nest name spaces. You can also allocate some memory which is attached to this object for your own personal use.

When the object is allocated, it will automatically have one user. To allow other users to remove this object from a namespace, you must call ReleaseNamedObject() on this object.

See also

FreeNamedObject | Frees a name object.
ANO_NameSpace | Tag for AllocNamedObjectA(). Tag to define namespace
ANO_UserSpace | Tag for AllocNamedObjectA(). Taf to define userspace
ANO_Priority | Tag for AllocNamedObjectA(). Tag to define priority
ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)


Amiga2Date

Fill in a ClockData structure based on a system time stamp

Declaration

Source position: utility.pas line 272

procedure Amiga2Date(

  DateAmiga: LongWord;

  Cd: PClockData

);

Description

Convert the time value given as the number of seconds since the 1st of January 1978 (00:00:00 1.1.78), to a more useful values, which is easier for most people to understand. These values will be stored in the ClockData structure whose address is passed as an argument.

The ClockData structure will contain the converted time values.

See also

CheckDate | Checks a ClockData structure for legal date.
Date2Amiga | Calculate seconds from 01-Jan-1978.


ApplyTagChanges

Change a tag list based on a second tag list.

Declaration

Source position: utility.pas line 248

procedure ApplyTagChanges(

  List: PTagItem;

  const ChangeList: PTagItem

);

Arguments

List | A list of existing tags (may be nil)
ChangeList | A list of tags to modify 'list' with (may be nil)

Description

For any tag that appears in both 'list' and 'changeList', this function will change the ti_Data field of the tag in 'list' to match the ti_Data field of the tag in 'changeList'. In effect, 'changeList' contains a series of new values for tags already in 'list'. Any tag in 'changeList' that is not in 'list' is ignored.

See also

FilterTagChanges

Eliminate tags which specify no change.


AsTag

Declaration

Source position: utility.pas line 330

function AsTag(

  value: pointer

):PtrUInt; overload;

function AsTag(

  value: PChar

):PtrUInt; overload;

function AsTag(

  value: Boolean

):PtrUInt; overload;

function AsTag(

  value: LongInt

):PtrUInt; overload;


AttemptRemNamedObject

Attempt to remove a named object.

Declaration

Source position: utility.pas line 266

function AttemptRemNamedObject(

  Obj: PNamedObject

):LongInt;

Function result

If the NamedObject can be removed, then it will be removed from the list. Otherwise the routine will just return. If the NamedObject has a removal message associated with it that message will be returned to the owner of the NamedObject.

Description

Attempts to remove an object from whatever NameSpace it's in. You must have found the object first (in order to get a use count) before trying to remove it. If the object is in use or is in the process of being removed, this function will return a failure code. If the object is fully removed, the object will then be available to be FreeNamedObject().

See also

RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AddNamedObject | Add a named object to the given namespace.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


CallHook

Declaration

Source position: utility.pas line 323

function CallHook(

  Hook: PHook;

  Obj: Pointer;

  Params: array of PtrUInt

):LongWord;


CallHookPkt

Invoke a Hook function callback.

Declaration

Source position: utility.pas line 261

function CallHookPkt(

  Hook: PHook;

  Obj: Pointer;

  Message_: Pointer

):LongWord;

Arguments

Hook

Pointer to an initialized Hook structure.

Function result

Depends upon the Hook itself.

Description

Call the callback hook defined by a Hook structure. This is effectively a long jump to the PHook^.h_Entry vector of the structure.

The Hook will be called with the same arguments as this function.

Errors

If your callback function does not have the correct register definitions, the result of this function is entirely unreliable.


CheckDate

Checks a ClockData structure for legal date.

Declaration

Source position: utility.pas line 273

function CheckDate(

  const Date: PClockData

):LongWord;

Arguments

Date

A ClockData structure desribing the date to check.

Function result

If the date is valid, the number of seconds from midnight 1-Jan-1978 AD to the date, or 0 if the date is invalud.

Description

Examine the date described in the ClockData structure and determine whether it is a valid date. In particular this checks whether the ranges of the fields are within normal limits.

This function does not check whether the wday field of the ClockData structure is valid.

The date 01-Jan-78 00:00:00 is actually returned as invalid.

This also assumes that the ClockDate refers to a date in the Gregorian calendar. (60 sec/min, 60 min/hour, 24 hr/day, 12 months/year).

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
Date2Amiga | Calculate seconds from 01-Jan-1978.


ClearMem

Declaration

Source position: utility.pas line 306

procedure ClearMem(

  Destination: Pointer;

  Size: LongWord

);


CloneTagItems

Copy a tag list.

Declaration

Source position: utility.pas line 249

function CloneTagItems(

  const Original: PTagItem

):PTagItem;

Function result

Copy of the original tag list, or nil if there was not enough memory. This tag list must eventually by freed by calling FreeTagItems().

Description

Copies the essential contents of a tag list into a new tag list.

The cloning is such that calling FindTagItem() with a given tag on the original or cloned tag lists will always return the same tag value. That is, the ordering of the tags is maintained.

See also

AllocateTagItems | Allocate a tag list.
FreeTagItems | Free an allocated tag list.
RefreshTagItemClones | Rejuvenate a clone from the original.


CreateSkipList

Declaration

Source position: utility.pas line 275

function CreateSkipList(

  Hook: PHook;

  MaxLevels: LongInt

):PSkipList;


CreateSplayTree

Declaration

Source position: utility.pas line 282

function CreateSplayTree(

  CompareHook: PHook

):PSplayTree;


Date2Amiga

Calculate seconds from 01-Jan-1978.

Declaration

Source position: utility.pas line 274

function Date2Amiga(

  const Date: PClockData

):LongWord;

Arguments

Date

A pointer to a ClockData structure containing the date of interest.

Function result

The number of seconds from 01-Jan-1978 to the date specified.

Description

Calculates the number of seconds from 01-Jan-1978 to the date specified in the ClockData structure.

Errors

This function does no sanity checking of the data in the ClockData structure.

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
CheckDate | Checks a ClockData structure for legal date.


DeleteSkipList

Declaration

Source position: utility.pas line 276

procedure DeleteSkipList(

  SkipList: PSkipList

);


DeleteSplayTree

Declaration

Source position: utility.pas line 283

procedure DeleteSplayTree(

  SplayTree: PSplayTree

);


FilterTagChanges

Eliminate tags which specify no change.

Declaration

Source position: utility.pas line 250

procedure FilterTagChanges(

  Changelist: PTagItem;

  OriginalList: PTagItem;

  Apply: LongWord

);

Arguments

Changelist | A list of new tags (may be nil)
Apply | Boolean specification as to whether the data values in originalList are to be updated to the data values in changeList.

Description

This function goes through changeList. For each item found in changeList, if the item is also present in originalList, and their data values are identical, then the tag is removed from changeList. If the two tag's data values are different and the 'apply' value is True, then the tag data in OldValues will be updated to match the value from ChangeList.

See also

ApplyTagChanges

Change a tag list based on a second tag list.


FilterTagItems

Remove selected items from a tag list.

Declaration

Source position: utility.pas line 251

function FilterTagItems(

  Taglist: PTagItem;

  const FilterArray: PLongWord;

  Logic: LongWord

):LongWord;

Arguments

Taglist | input list of tag items which is to be filtered by having selected items changed to TAG_IGNORE.
FilterArray | An array of tag values, terminated by TAG_DONE, as specified in the documentation for TagInArray().
Logic | Apecification whether items in 'tagArray' are to be included or excluded in the filtered result.

Function result

Number of valid items left in resulting filtered list.

Description

Removes tag items from a tag list (by changing ti_Data to TAG_IGNORETAG_IGNORE) depending on whether its ti_Data value is found in an array of tag values.

If the 'logic' parameter is TAGFILTER_ANDTAGFILTER_AND, then all items not appearing in 'tagArray' are excluded from 'tagList'.

If 'logic' is TAGFILTER_NOTTAGFILTER_NOT, then items not found in 'tagArray' are preserved, and the ones in the array are cast out.

See also

TagInArray

Check if a tag value appears in an array of tag values.


FindNamedObject

Find the next object of a given name.

Declaration

Source position: utility.pas line 267

function FindNamedObject(

  NameSpace: PNamedObject;

  const Name: PChar;

  PreviousObject: PNamedObject

):PNamedObject;

Arguments

NameSpace | The NameSpace to search through. If nil will use the system default NameSpace.
Name | The name of the object to search for. If nil, any and all NamedObjects will be matched.

Function result

If a NamedObject with the name supplied exists, it will be returned. Otherwise will return nil. When you have finised with this NamedObject, you should call ReleaseNamedObject().

Description

Finds an object and adds to the open count of the object. The object is guaranteed not to be freed until ReleaseNamedObject() is called. The name comparison is caseless, using the current locale string comparison routines.

If name is nil, then all objects will be matched.

If lastObject is non-nil, it must be an object from the same NameSpace found on a previous call to FindNamedObject(). It will not be freed by this call. The search will start at the node after lastobject, if non-nil.

nameSpace is the name space from the named object given or the root name space if nil is given.

If you are going to use a returned NamedObject to be the starting point for another search you must call ReleaseNamedObject() after searching, as the ReleaseNamedObject() call can cause the NamedObject to be freed, leaving you with an invalid pointer.

See also

ReleaseNamedObject

Free a named object.


FindNameNC

Declaration

Source position: utility.pas line 287

function FindNameNC(

  List: PList;

  const Name: PChar

):PNode;


FindSkipNode

Declaration

Source position: utility.pas line 277

function FindSkipNode(

  SkipList: PSkipList;

  Key: Pointer

):PSkipList;


FindSplayNode

Declaration

Source position: utility.pas line 284

function FindSplayNode(

  SplayTree: PSplayTree;

  Key: Pointer

):PSplayTree;


FindTagItem

Scan a tag list for a specific tag.

Declaration

Source position: utility.pas line 252

function FindTagItem(

  TagValue: LongWord;

  const TagList: PTagItem

):PTagItem;

Arguments

TagValue | A tag value to search for
TagList | A tag item list to search (may be nil)

Function result

A pointer to the item with ti_Tag matching 'tagValue' or nil if no match was found.

Description

Scans a tag list and returns a pointer to the first item with ti_Tag matching the 'tagValue' parameter.

See also

GetTagData | Obtain the data corresponding to a tag.
PackBoolTags | Builds a "flag" word from a tag list
NextTagITem | Iterate through a tag list.


FreeNamedObject

Frees a name object.

Declaration

Source position: utility.pas line 268

procedure FreeNamedObject(

  Obj: PNamedObject

);

Description

Free one of a number of structures used by utility.library. The item must not be a member of any NameSpace, and no one may have it open other than yourself. If the object also contained a NameSpace, that namespace must be empty. Any additional space allocated via the datasize parameter for AllocNamedObject() is also released.

See also

AllocNamedObjectA

Allocate a named object.


FreeTagItems

Free an allocated tag list.

Declaration

Source position: utility.pas line 253

procedure FreeTagItems(

  TagList: PTagItem

);

Arguments

TagList

list to free, must have been obtained from AllocateTagItems() or CloneTagItems() (may be nil)

Description

Frees the memory of a TagItem list allocated either by AllocateTagItems() or CloneTagItems().

var
  tagList: PTagItem;
begin
  tagList := AllocateTagItems(4);
  tagList[0]^.ti_Tag := NA_Name;
  tagList[0]^.ti_Data := IPTR(PChar('A list of tags'));
  tagList[3]^.ti_Tag := TAG_DONE;
// Do what you want with your TagList here ...
  FreeTagItems(tagList);
end;

See also

AllocateTagItems

Allocate a tag list.


GetFirstSkipNode

Declaration

Source position: utility.pas line 278

function GetFirstSkipNode(

  SkipList: PSkipList

):PSkipList;


GetNextSkipNode

Declaration

Source position: utility.pas line 279

function GetNextSkipNode(

  SkipList: PSkipList

):PSkipList;


GetTagData

Obtain the data corresponding to a tag.

Declaration

Source position: utility.pas line 254

function GetTagData(

  TagValue: LongWord;

  DefaultValue: LongWord;

  const TagList: PTagItem

):LongWord;

Arguments

TagValue | A tag value to search for
TagList | The tag list to search.

Function result

The ti_Data value for the first matching TagItem, or 'default' if a ti_Tag matching 'Tag' is not found.

Description

Searches a tag list for a matching tag, and returns the corresponding ti_Data value for the TagItem found. If no match is found, this function returns the value passed in as 'default'.

// Find out the value for the WA_Left tag
window^.Left := GetTagData(WA_Left, 320, wintags);

If the input TagList doesn't exist (e.g. for some reason equals nil), then the return value will be nil. This way you can check for broken code, whereas returing the default would allow code that is possibly buggy to still seem to work. (Until you tried to do anything special at least).

See also

FindTagItem | Scan a tag list for a specific tag.
PackBoolTags | Builds a "flag" word from a tag list
NextTagItem | Iterate through a tag list.


GetUniqueID

Return a relatively unique number.

Declaration

Source position: utility.pas line 288

function GetUniqueID: LongWord;

Function result

A 32-bit value that is unique.

Description

Returns a unique value each time it is called. This is useful for things that need unique ID such as the GadgetHelp ID, etc. Note that this is only unique for 4,294,967,295 calls to this function. Under normal use this is not a problem. This function is safe in interrupts.


InsertSkipNode

Declaration

Source position: utility.pas line 280

function InsertSkipNode(

  SkipList: PSkipList

):PSkipList;


InsertSplayNode

Declaration

Source position: utility.pas line 285

function InsertSplayNode(

  SplayTree: PSplayTree;

  Key: Pointer;

  DateSize: LongWord

):PSplayTree;


MapTags

Convert ti_Tag values in a list via map pairing.

Declaration

Source position: utility.pas line 255

procedure MapTags(

  TagList: PTagItem;

  const Maplist: PTagItem;

  MapType: LongWord

);

Arguments

TagList | Input list of tag items which is to be mapped to tag values as specified in MapList.
Maplist | A "mapping list" tag list which pairs tag values expected to appear in tagList with new values to be substituted in the ti_Tag fields of tagList (may be nil)
MapType | one of the available mapping types (MAP_*)

Description

Apply a "mapping list" mapList to tagList.

If the ti_Tag field of an item in tagList appears as ti_Tag in some item in mapList, overwrite ti_Tag with the corresponding ti_Data from the map list.

The mapType parameter specifies how the mapping operation is to proceed, with the following available types:

MAP_REMOVE_NOT_FOUND
If a tag in tagList does not appear in the mapList, remove it from tagList.
MAP_KEEP_NOT_FOUND
To have items which do not appear in the mapList survive the mapping process as-is.

MapTags() is central to BOOPSI gadget interconnections where you want to convert the tag values from one space (the sender) to another (the receiver).

The procedure will change the values of the input tag list tagList (but not mapList).

You can "filter" a list by passing MAP_REMOVE_NOT_FOUND as mapType, and having the data items in mapList equal the corresponding tags.

You can perform the inverse filter ("everything but") by passing a mapType of MAP_KEEP_NOT_FOUND, and creating a map item for every tag you want to filter out, pairing it with a mapped data value of TAG_IGNORE.

For safety and "order independence" of tag item arrays, if you attempt to map some tag to the value TAG_DONE, the value TAG_IGNORE will be substituted instead.

See also

ApplyTagChanges | Change a tag list based on a second tag list.
FilterTagChanges | Eliminate tags which specify no change.
MAP_REMOVE_NOT_FOUND | Mapping types for use with MapTags() remove tags that aren't in mapList
MAP_KEEP_NOT_FOUND | Mapping types for use with MapTags() keep tags that aren't in mapList


MessageDigest_SHA_Final

Declaration

Source position: utility.pas line 289

procedure MessageDigest_SHA_Final(

  SHAs: PMessageDigest_SHA

);


MessageDigest_SHA_Init

Declaration

Source position: utility.pas line 290

procedure MessageDigest_SHA_Init(

  SHAs: PMessageDigest_SHA

);


MessageDigest_SHA_Update

Declaration

Source position: utility.pas line 291

procedure MessageDigest_SHA_Update(

  SHAs: PMessageDigest_SHA;

  Data: Pointer;

  NumBytes: LongInt

);


MoveMem

Declaration

Source position: utility.pas line 307

procedure MoveMem(

  const Source: Pointer;

  Destination: Pointer;

  Size: LongWord

);


NamedObjectName

Return the name of the object.

Declaration

Source position: utility.pas line 269

function NamedObjectName(

  Obj: PNamedObject

):PChar;

Function result

A pointer to the name string, or nil if 'object' is nil.

Description

Returns the name of the object passed in... Note that the name string is passed back as just a pointer to a read-only name. If the object goes away, so does the name.

See also

FindNamedObject | Find the next object of a given name.
RemNamedObject | Remove a named object.


NextTagItem

Iterate through a tag list.

Declaration

Source position: utility.pas line 256

function NextTagItem(

  ItemPtr: PPTagItem

):PTagItem; overload;

function NextTagItem(

  var Item: PTagItem

):PTagItem; overload;

Function result

Each TagItem in the array or chain of arrays that should be processed according to system tag values is returned in turn with successive calls.

Arguments

Item

Doubly-indirect reference to a TagItem structure. The pointer will be changed to keep track of the iteration.

Description

Iterates through a tag list, skipping and chaining as dictated by system tags. TAG_SKIP will cause it to skip the entry and a number of following tags as specified in ti_Data. TAG_IGNORE ignores that single entry, and TAG_MORE has a pointer to another array of tags (and terminates the current array!). TAG_DONE also terminates the current array. Each call returns either the next tagitem you should examine, or nil when the end of the list has been reached.

procedure Iterate(tags: PTagItem);
var
  tag: PTagItem;
begin
  tag := NextTagItem(tags);
  while tag <> nil do
  begin
    case tag^.ti_Tag of
      TAG1: ...
      TAG2: ...
    else ...
    end;
    tag := NextTagItem(tags);
  end;
end;

See also

GetTagData | Obtain the data corresponding to a tag.
PackBoolTags | Builds a "flag" word from a tag list
FindTagItem | Scan a tag list for a specific tag.


PackBoolTags

Builds a "flag" word from a tag list

Declaration

Source position: utility.pas line 258

function PackBoolTags(

  InitialFlags: LongWord;

  const TagList: PTagItem;

  const Boolmap: PTagItem

):LongWord;

Arguments

InitialFlags | A starting set of bit-flags which will be changed by the processing of True and False boolean tags in tagList.
TagList | A TagItem list which may contain several tag items defined to be boolean by their presence in boolMap. The logical value of ti_Data determines whether a tag item causes the bit-flag value related by boolMap to be set or cleared in the returned flag longword.
Boolmap | A tag list defining the boolean tags to be recognized, and the bit (or bits) in the returned longword that are to be set or cleared when a boolean Tag is found to be True or False in tagList.

Function result

The accumulated longword of bit-flags, starting with initialFlags and modified by each boolean tag item encountered.

Description

Picks out the boolean tag items in a tag list and converts them into bit-flag representations according to a correspondence defined by the tag list 'boolMap'.

A boolean tag item is one where only the logical value of the ti_Data is relevant. If this field is 0, the value is False, otherwise True.


PackStructureTags

Pack a structure with values from taglist.

Declaration

Source position: utility.pas line 292

function PackStructureTags(

  Pack: Pointer;

  const PackTable: PLongWord;

  const TagList: PTagItem

):LongWord;

Arguments

Pack | A pointer to the data area to fill in.
PackTable | A pointer to the packing information table.
TagList | A pointer to the taglist to pack into the structure

Function result

The number of tag items packed

Description

For each table entry, a FindTagItem() will be done and if the matching tag is found in the taglist, the data field will be packed into the given structure based on the packtable definition.

See also

FindTagItem | Scan a tag list for a specific tag.
UnpackStructureTags | Unpack a structure to values in taglist.


Random

Declaration

Source position: utility.pas line 294

function Random(

  State: PRandomState

):LongWord;


RefreshTagItemClones

Rejuvenate a clone from the original.

Declaration

Source position: utility.pas line 259

procedure RefreshTagItemClones(

  Clone: PTagItem;

  const OriginalTagItems: PTagItem

);

Arguments

Clone

Return value from CloneTagItems(original)

Description

If (and only if) the tag list 'clone' was created from 'original' by CloneTagItems(), and if 'original' has not been changed in any way, you can reset the clone list to its original state by using this function.

See also

CloneTagItems | Copy a tag list.
AllocateTagItems | Allocate a tag list.
FreeTagItems | Free an allocated tag list.
ApplyTagChanges | Change a tag list based on a second tag list.


ReleaseNamedObject

Free a named object.

Declaration

Source position: utility.pas line 270

procedure ReleaseNamedObject(

  Obj: PNamedObject

);

Description

Decrements the open count of the object. If the object has been removed, and the count goes to 0, the remover will be notified that the object is now free.

See also

FindNamedObject | Find the next object of a given name.
RemNamedObject | Remove a named object.


RemNamedObject

Remove a named object.

Declaration

Source position: utility.pas line 271

procedure RemNamedObject(

  Obj: PNamedObject;

  Message_: PMessage

);

Description

This function will post a request to release the object from whatever NameSpace it is in. It will reply the message when the object is fully removed. The TMessage.mn_Node.ln_Name field will contain the object pointer or nil if the object was removed by another process.

This function will effectively do a ReleaseNamedObject() thus you must have "found" the object first.

The message is replied with the ln_Name field either being the object or nil. If it contains the object, the object is completely removed.

See also

AttemptRemNamedObject | Attempt to remove a named object.
AddNamedObject | Add a named object to the given namespace.
ReleaseNamedObject | Free a named object.


RemoveSkipNode

Declaration

Source position: utility.pas line 281

function RemoveSkipNode(

  SkipList: PSkipList;

  Key: Pointer

):LongBool;


RemoveSplayNode

Declaration

Source position: utility.pas line 286

function RemoveSplayNode(

  SplayTree: PSplayTree;

  Key: Pointer

):PSplayTree;


SetMem

Declaration

Source position: utility.pas line 295

function SetMem(

  Destination: Pointer;

  FillChar: Byte;

  Length: LongInt

):Pointer;


Stricmp

Case-insensitive string comparison.

Declaration

Source position: utility.pas line 296

function Stricmp(

  const S1: PChar;

  const S2: PChar

):LongInt;

Function result

Relationship between string1 and string2 <0 means string1 < string2 =0 means string1 = string2 >0 means string1 > string2

Description

This function compares two strings, ignoring case using a generic case conversion routine. If the strings have different lengths, the shorter is treated as if it were extended with zeros.

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, identical pairs of strings may return different values when passed to this function. This fact must be taken into consideration when using this function.

See also

Strnicmp

Length-limited case-insensitive string compare.


Strlcat

Declaration

Source position: utility.pas line 298

function Strlcat(

  Dst: PChar;

  const Src: PChar;

  Size: LongInt

):LongInt;


Strlcpy

Declaration

Source position: utility.pas line 297

function Strlcpy(

  Dst: PChar;

  const Src: PChar;

  Size: LongInt

):LongInt;


Strlen

Declaration

Source position: utility.pas line 308

function Strlen(

  const String_: PChar

):LongWord;


Strnicmp

Length-limited case-insensitive string compare.

Declaration

Source position: utility.pas line 299

function Strnicmp(

  const S1: PChar;

  const S2: PChar;

  n: LongInt

):LongInt;

Function result

Relationship between string1 and string2 <0 means string1 < string2 =0 means string1 = string2 >0 means string1 > string2

Description

This function compares two strings, ignoring case using a generic case conversion routine. If the strings have different lengths, the shorter is treated as if it were extended with zeros. This function never compares more than 'length' characters.

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, identical pairs of strings may return different values when passed to this function. This fact must be taken into consideration when using this function.

See also

Stricmp

Case-insensitive string comparison.


TagInArray

Check if a tag value appears in an array of tag values.

Declaration

Source position: utility.pas line 260

function TagInArray(

  TagValue: LongWord;

  const TagArray: PLongWord

):LongBool;

Arguments

TagValue | Tag value to search array for in array.
TagArray | A simple array of tag values terminated by TAG_DONE.

Function result

True if tagValue was found in tagArray.

Description

Determines whether the value tagValue exists in an array of Tags pointed to by tagArray. This array must be contiguous, and must be terminated by TAG_DONE. This is an array of Tags, not an array of TagItems.

See also

FilterTagItems

Remove selected items from a tag list.


TAG_

Declaration

Source position: utility.pas line 325

function TAG_(

  value: pointer

):PtrUInt; overload;

function TAG_(

  value: PChar

):PtrUInt; overload;

function TAG_(

  value: Boolean

):PtrUInt; overload;

function TAG_(

  value: LongInt

):PtrUInt; overload;


TAG_DONE

Tag terminate the array of TagItems.ti_Data unused

Declaration

Source position: utility.pas line 148

const TAG_DONE = 0;


TAG_END

Tag terminate the array of TagItems.ti_Data unused

Declaration

Source position: utility.pas line 149

const TAG_END = 0;


TAG_IGNORE

Ignore this item, not end of array

Declaration

Source position: utility.pas line 150

const TAG_IGNORE = 1;


TAG_MORE

ti_Data is pointer to another array of TagItems note that this tag terminates the current array

Declaration

Source position: utility.pas line 151

const TAG_MORE = 2;


TAG_SKIP

Skip this and the next ti_Data items

Declaration

Source position: utility.pas line 152

const TAG_SKIP = 3;


TAG_USER

Declaration

Source position: utility.pas line 155

const TAG_USER = DWord($80000000);


ToLower

Convert a character to lower case.

Declaration

Source position: utility.pas line 300

function ToLower(

  c: Char

):LongWord;

Function result

Lower case version of the input character.

Description

Converts a character to lower case, handling international character sets. Currently only works for ASCII characters. Would not be difficult to adapt for other character sets (Unicode for example).

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, a given character may return different results when passed to this function. This fact must be taken into consideration when using this function.

See also

ToUpper

Convert a character to upper case.


ToUpper

Convert a character to upper case.

Declaration

Source position: utility.pas line 301

function ToUpper(

  c: Char

):LongWord;

Arguments

c

Character to be converted.

Function result

Upper case version of input character.

Description

Converts a character to upper case, handling international character sets. Currently only works for ASCII characters. Would not be difficult to adapt for other character sets (Unicode for example).

Whenever locale.library is installed in a system, this function is replaced by language-specific code. This means that depending on which language the user has currently selected, a given character may return different results when passed to this function. This fact must be taken into consideration when using this function.

See also

ToLower

Convert a character to lower case.


UCS4Count

Declaration

Source position: utility.pas line 314

function UCS4Count(

  const UCS4String: PLongInt;

  Validate: LongInt

):LongInt;


UCS4ToLower

Declaration

Source position: utility.pas line 317

function UCS4ToLower(

  UCS4In: LongInt

):LongInt;


UCS4ToUpper

Declaration

Source position: utility.pas line 318

function UCS4ToUpper(

  UCS4In: LongInt

):LongInt;


UCS4toUTF8

Declaration

Source position: utility.pas line 310

function UCS4toUTF8(

  const UCS4Source: PLongInt;

  UTF8Destination: PChar;

  UTF8DestinationSize: LongInt;

  Flags: LongWord

):LongInt;


UCS4Valid

Declaration

Source position: utility.pas line 319

function UCS4Valid(

  UCS4: LongInt

):LongInt;


UnpackStructureTags

Unpack a structure to values in taglist.

Declaration

Source position: utility.pas line 293

function UnpackStructureTags(

  const Pack: Pointer;

  const PackTable: PLongWord;

  TagList: PTagItem

):LongWord;

Arguments

Pack | A pointer to the data area to be unpacked
PackTable | A pointer to the packing information table.
TagList | A pointer to the taglist to unpack into

Function result

The number of tag items unpacked

Description

For each table entry, a FindTagItem() will be done and if the matching tag is found in the taglist, the data in the structure will be placed into the memory pointed to by the tag's ti_Data. ti_Data must point to a LongWord.

See also

FindTagITem | Scan a tag list for a specific tag.
PackStructureTags | Pack a structure with values from taglist.


UTF8Count

Declaration

Source position: utility.pas line 313

function UTF8Count(

  const UTF8String: PChar;

  Validate: LongInt

):LongInt;


UTF8Decode

Declaration

Source position: utility.pas line 316

function UTF8Decode(

  const UTF8PPTR: PPChar;

  Flags: LongWord

):LongInt;


UTF8Encode

Declaration

Source position: utility.pas line 315

function UTF8Encode(

  UCS4: LongInt;

  Buffer: PChar;

  BufSize: LongInt;

  Flags: LongWord

):LongInt;


UTF8Stricmp

Declaration

Source position: utility.pas line 312

function UTF8Stricmp(

  const UTF8String1: PChar;

  const UTF8String2: PChar

):LongInt;


UTF8Strnicmp

Declaration

Source position: utility.pas line 311

function UTF8Strnicmp(

  const UTF8String1: PChar;

  const UTF8String2: PChar;

  MaxUCSchars: LongInt

):LongInt;


UTF8toUCS4

Declaration

Source position: utility.pas line 309

function UTF8toUCS4(

  const UTF8Source: PChar;

  UCS4Destination: PLongInt;

  UCS4DestinationSize: LongInt;

  Flags: LongWord

):LongInt;


UtilityClone

Declaration

Source position: utility.pas line 246

function UtilityClone: PInterface;


UtilityExpunge

Declaration

Source position: utility.pas line 245

procedure UtilityExpunge;


UtilityObtain

Declaration

Source position: utility.pas line 243

function UtilityObtain: LongWord;


UtilityRelease

Declaration

Source position: utility.pas line 244

function UtilityRelease: LongWord;


VASPrintf

Declaration

Source position: utility.pas line 302

function VASPrintf(

  const Fmt: PChar;

  Args: Pointer

):PChar;


VSNPrintf

Declaration

Source position: utility.pas line 304

function VSNPrintf(

  Buffer: PChar;

  BufferSize: LongInt;

  const Fmt: PChar;

  Args: Pointer

):PChar;


Reference for unit 'Workbench': Procedures and functions

AddAppIcon

AddAppIconA

AddAppMenuItem

AddAppMenuItemA

AddAppWindow

AddAppWindowA

AddAppWindowDropZone

AddAppWindowDropZoneA

ChangeWorkbenchSelectionA

CloseWorkbenchObject

CloseWorkbenchObjectA

MakeWorkbenchObjectVisible

MakeWorkbenchObjectVisibleA

OpenWorkbenchObject

OpenWorkbenchObjectA

RemoveAppIcon

RemoveAppMenuItem

RemoveAppWindow

RemoveAppWindowDropZone

UpdateWorkbench

WBClone

WBExpunge

WBInfo

WBObtain

WBRelease

WhichWorkbenchObjectA

WorkbenchControl

WorkbenchControlA


Unit 'Workbench' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Reference for unit 'Workbench': Variables

IWorkbench

WorkbenchBase


Index of all identifiers in unit 'Workbench'

A C D G I M N O P R S T U W

A

AddAppIcon | AMCLASSICON_Copy | AMCLASSICON_Snapshot
AddAppIconA | AMCLASSICON_Delete | AMCLASSICON_Unselected
AddAppMenuItem | AMCLASSICON_EmptyTrash | AMCLASSICON_UnSnapshot
AddAppMenuItemA | AMCLASSICON_FormatDisk | AMTYPE_APPICON
AddAppWindow | AMCLASSICON_Information | AMTYPE_APPMENUITEM
AddAppWindowA | AMCLASSICON_LeaveOut | AMTYPE_APPWINDOW
AddAppWindowDropZone | AMCLASSICON_Open | AMTYPE_APPWINDOWZONE
AddAppWindowDropZoneA | AMCLASSICON_PutAway | AM_VERSION
ADZMACTION_Enter | AMCLASSICON_Rename |
ADZMACTION_Leave | AMCLASSICON_Selected |

C

ChangeWorkbenchSelectionA | CloseWorkbenchObjectA | CPACTION_Copy
CloseWorkbenchObject | CPACTION_Begin | CPACTION_End

D

DDFLAGS_SHOWALL | DDVM_BYICON | DLACTION_BeginEmptyTrash
DDFLAGS_SHOWDEFAULT | DDVM_BYNAME | DLACTION_DeleteContents
DDFLAGS_SHOWICONS | DDVM_BYSIZE | DLACTION_DeleteObject
DDVM_BYDATE | DDVM_BYTYPE | DLACTION_End
DDVM_BYDEFAULT | DLACTION_BeginDiscard | DRAWERDATAFILESIZE

G

GFLG_GADGBACKFILL

I

ISMACTION_Ignore | ISMACTION_Stop | IWorkbench
ISMACTION_Select | ISMACTION_Unselect |

M

MakeWorkbenchObjectVisible | MTYPE_CLOSEDOWN | MTYPE_PSTD
MakeWorkbenchObjectVisibleA | MTYPE_COPYEXIT | MTYPE_TIMER
MTYPE_APPICON | MTYPE_DISKCHANGE | MTYPE_TOOLEXIT
MTYPE_APPMENUITEM | MTYPE_ICONPUT |
MTYPE_APPWINDOW | MTYPE_IOPROC |

N

NO_ICON_POSITION

O

OLDDRAWERDATAFILESIZE OpenWorkbenchObject OpenWorkbenchObjectA

P

PAppIcon | PCopyDataMsg | POldDrawerData
PAppIconRenderMsg | PCopyEndMsg | PSetupCleanupHookMsg
PAppMenu | PDeleteBeginMsg | PTextInputMsg
PAppMenuItem | PDeleteDataMsg | PWBArg
PAppMessage | PDeleteEndMsg | PWBArgList
PAppWindow | PDiskObject | PWBHandlerMessage
PAppWindowDropZone | PDrawerData | PWBStartup
PAppWindowDropZoneMsg | PFreeList |
PCopyBeginMsg | PIconSelectMsg |

R

RemoveAppIcon | RemoveAppWindow
RemoveAppMenuItem | RemoveAppWindowDropZone

S

SCHMSTATE_Cleanup SCHMSTATE_Setup SCHMSTATE_TryCleanup

T

TAppIcon | TCopyEndMsg | TIACTION_Rename
TAppIconRenderMsg | TDeleteBeginMsg | TIconSelectMsg
TAppMenu | TDeleteDataMsg | TOldDrawerData
TAppMenuItem | TDeleteEndMsg | TSetupCleanupHookMsg
TAppMessage | TDiskObject | TTextInputMsg
TAppWindow | TDrawerData | TWBArg
TAppWindowDropZone | TFreeList | TWBArgList
TAppWindowDropZoneMsg | TIACTION_Execute | TWBHandlerMessage
TCopyBeginMsg | TIACTION_NewDrawer | TWBHM_type
TCopyDataMsg | TIACTION_RelabelVolume | TWBStartup

U

UPDATEWB_ObjectAdded UPDATEWB_ObjectRemoved UpdateWorkbench

W

WBA_Dummy | WBA_Reserved5 | WB_DISKREVISION
WBA_LAST_TAG | WBA_Reserved6 | WB_DISKREVISIONMASK
WBAPPICON | WBA_Reserved7 | WB_DISKVERSION
WBAPPICONA_NotifySelectState | WBA_Reserved8 | WBDRAWER
WBAPPICONA_PropagatePosition | WBA_Reserved9 | WBDZA_Box
WBAPPICONA_RenderHook | WBClone | WBDZA_Height
WBAPPICONA_SupportsCopy | WBCTRLA_AddHiddenDeviceName | WBDZA_Hook
WBAPPICONA_SupportsDelete | WBCTRLA_AddSetupCleanupHook | WBDZA_Left
WBAPPICONA_SupportsEmptyTrash | WBCTRLA_DuplicateSearchPath | WBDZA_RelBottom
WBAPPICONA_SupportsFormatDisk | WBCTRLA_FreeHiddenDeviceList | WBDZA_RelHeight
WBAPPICONA_SupportsInformation | WBCTRLA_FreeOpenDrawerList | WBDZA_RelRight
WBAPPICONA_SupportsLeaveOut | WBCTRLA_FreeProgramList | WBDZA_RelWidth
WBAPPICONA_SupportsOpen | WBCTRLA_FreeSearchPath | WBDZA_Top
WBAPPICONA_SupportsPutAway | WBCTRLA_FreeSelectedIconList | WBDZA_Width
WBAPPICONA_SupportsRename | WBCTRLA_GetCopyHook | WBExpunge
WBAPPICONA_SupportsSnapshot | WBCTRLA_GetDefaultStackSize | WBGARBAGE
WBAPPICONA_SupportsUnSnapshot | WBCTRLA_GetDeleteHook | WBHM_TYPE_HIDE
WBAPPMENUA_CommandKeyString | WBCTRLA_GetHiddenDeviceList | WBHM_TYPE_OPEN
WBAPPMENUA_GetKey | WBCTRLA_GetOpenDrawerList | WBHM_TYPE_SHOW
WBAPPMENUA_GetTitleKey | WBCTRLA_GetProgramList | WBHM_TYPE_UPDATE
WBAPPMENUA_UseKey | WBCTRLA_GetSelectedIconList | WBInfo
WBA_Reserved1 | WBCTRLA_GetTextInputHook | WBKICK
WBA_Reserved10 | WBCTRLA_GettypeRestartTime | WBObtain
WBA_Reserved11 | WBCTRLA_IsOpen | WBOPENA_ArgLock
WBA_Reserved12 | WBCTRLA_RedrawAppIcon | WBOPENA_ArgName
WBA_Reserved13 | WBCTRLA_RemoveHiddenDeviceName | WBOPENA_Show
WBA_Reserved14 | WBCTRLA_RemSetupCleanupHook | WBOPENA_ViewBy
WBA_Reserved15 | WBCTRLA_SetCopyHook | WBPROJECT
WBA_Reserved16 | WBCTRLA_SetDefaultStackSize | WBRelease
WBA_Reserved17 | WBCTRLA_SetDeleteHook | WBTOOL
WBA_Reserved18 | WBCTRLA_SetTextInputHook | WhichWorkbenchObjectA
WBA_Reserved19 | WBCTRLA_SettypeRestartTime | WorkbenchBase
WBA_Reserved2 | WBDEVICE | WorkbenchControl
WBA_Reserved3 | WBDISK | WorkbenchControlA
WBA_Reserved4 | WB_DISKMAGIC | WORKBENCHNAME


AddAppIcon

Declaration

Source position: workbench.pas line 559

function AddAppIcon(

  ID: LongWord;

  UserData: LongWord;

  Text_: PChar;

  MsgPort: PMsgPort;

  Lock: LongInt;

  DiskObj: PDiskObject;

  const Tags: array of PtrUInt

):PAppIcon;


AddAppIconA

Declaration

Source position: workbench.pas line 533

function AddAppIconA(

  ID: LongWord;

  UserData: LongWord;

  Text_: PChar;

  MsgPort: PMsgPort;

  Lock: LongInt;

  DiskObj: PDiskObject;

  TagList: PTagItem

):PAppIcon;


AddAppMenuItem

Declaration

Source position: workbench.pas line 560

function AddAppMenuItem(

  ID: LongWord;

  UserData: LongWord;

  Text_: Pointer;

  MsgPort: PMsgPort;

  const Tags: array of PtrUInt

):PAppMenuItem;


AddAppMenuItemA

Declaration

Source position: workbench.pas line 536

function AddAppMenuItemA(

  ID: LongWord;

  UserData: LongWord;

  Text_: Pointer;

  MsgPort: PMsgPort;

  TagList: PTagItem

):PAppMenuItem;


AddAppWindow

Declaration

Source position: workbench.pas line 561

function AddAppWindow(

  ID: LongWord;

  UserData: LongWord;

  Window: PWindow;

  MsgPort: PMsgPort;

  const Tags: array of PtrUInt

):PAppWindow;


AddAppWindowA

Declaration

Source position: workbench.pas line 530

function AddAppWindowA(

  ID: LongWord;

  UserData: LongWord;

  Window: PWindow;

  MsgPort: PMsgPort;

  TagList: PTagItem

):PAppWindow;


AddAppWindowDropZone

Declaration

Source position: workbench.pas line 562

function AddAppWindowDropZone(

  Aw: PAppWindow;

  ID: LongWord;

  UserData: LongWord;

  const Tags: array of PtrUInt

):PAppWindowDropZone;


AddAppWindowDropZoneA

Declaration

Source position: workbench.pas line 547

function AddAppWindowDropZoneA(

  Aw: PAppWindow;

  ID: LongWord;

  UserData: LongWord;

  Tags: PTagItem

):PAppWindowDropZone;


ChangeWorkbenchSelectionA

Declaration

Source position: workbench.pas line 550

function ChangeWorkbenchSelectionA(

  Name: PChar;

  Hook: PHook;

  Tags: PTagItem

):LongBool;


CloseWorkbenchObject

Unit 'Workbench' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

CloseWorkbenchObject (unimplemented)

Declaration

Source position: workbench.pas line 563

function CloseWorkbenchObject(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


CloseWorkbenchObjectA

Declaration

Source position: workbench.pas line 543

function CloseWorkbenchObjectA(

  Name: PChar;

  Tags: PTagItem

):LongBool;


MakeWorkbenchObjectVisible

Unit 'Workbench' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MakeWorkbenchObjectVisible (unimplemented)

Declaration

Source position: workbench.pas line 564

function MakeWorkbenchObjectVisible(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


MakeWorkbenchObjectVisibleA

Declaration

Source position: workbench.pas line 552

function MakeWorkbenchObjectVisibleA(

  Name: PChar;

  Tags: PTagItem

):LongBool;


OpenWorkbenchObject

Declaration

Source position: workbench.pas line 565

function OpenWorkbenchObject(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


OpenWorkbenchObjectA

Declaration

Source position: workbench.pas line 541

function OpenWorkbenchObjectA(

  Name: PChar;

  Tags: PTagItem

):LongBool;


RemoveAppIcon

Declaration

Source position: workbench.pas line 535

function RemoveAppIcon(

  AppIcon: PAppIcon

):LongBool;


RemoveAppMenuItem

Declaration

Source position: workbench.pas line 538

function RemoveAppMenuItem(

  AppMenuItem: PAppMenuItem

):LongBool;


RemoveAppWindow

Declaration

Source position: workbench.pas line 532

function RemoveAppWindow(

  AppWindow: PAppWindow

):LongBool;


RemoveAppWindowDropZone

Declaration

Source position: workbench.pas line 549

function RemoveAppWindowDropZone(

  Aw: PAppWindow;

  DropZone: PAppWindowDropZone

):LongBool;


UpdateWorkbench

Declaration

Source position: workbench.pas line 527

procedure UpdateWorkbench(

  const Name: PChar;

  Lock: LongInt;

  Action: LongInt

);


WBClone

Declaration

Source position: workbench.pas line 526

function WBClone: PInterface;


WBExpunge

Declaration

Source position: workbench.pas line 525

procedure WBExpunge;


WBInfo

Declaration

Source position: workbench.pas line 540

function WBInfo(

  Lock: LongInt;

  const Name: PChar;

  Screen: PScreen

):LongBool;


WBObtain

Declaration

Source position: workbench.pas line 523

function WBObtain: LongWord;


WBRelease

Declaration

Source position: workbench.pas line 524

function WBRelease: LongWord;


WhichWorkbenchObjectA

Declaration

Source position: workbench.pas line 554

function WhichWorkbenchObjectA(

  Window: PWindow;

  X: LongInt;

  Y: LongInt;

  Tags: PTagItem

):LongBool;


WorkbenchControl

Declaration

Source position: workbench.pas line 566

function WorkbenchControl(

  Name: PChar;

  const Tags: array of PtrUInt

):LongBool;


WorkbenchControlA

Declaration

Source position: workbench.pas line 545

function WorkbenchControlA(

  Name: PChar;

  Tags: PTagItem

):LongBool;


Reference for package 'os4units'

Units

agraphics | Native Amiga graphic functions (graphics.library)
amigados | File and directory handling routines and types (dos.library)
asl
clipboard
console
conunit
cybergraphics | RTG Amiga graphic functions of the CyberGraphics System by phase5 (cybergraphics.library)
datatypes
diskfont |
exec | This unit contains the types and wrapper functions for the exec.library.
icon | Icon handling routines (icon.library)
iffparse
inputevent
intuition | Screen and Window handling routines of intuition.library
keymap
layers | Layer handling
locale
mui |
picasso96api
serial
timer
utility | Tag Handling, Date routines in utility.library
Workbench | Basic Workbench/AppIcons functions (workbench.library)


Index of all identifiers in package 'os4units'

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

A

A2024FIFTEENHERTZ_KEY | AG_OpenRes | ASLFO_HookFunc
A2024_MONITOR_ID | AG_ProcCreate | ASLFO_InitialBackPen
A2024TENHERTZ_KEY | agraphics | ASLFO_InitialDrawMode
ABDAY_1 | Alert | ASLFO_InitialFlags
ABDAY_2 | ALERT_TYPE | ASLFO_InitialFrontPen
ABDAY_3 | AllocAbs | ASLFO_InitialHeight
ABDAY_4 | AllocAslRequest | ASLFO_InitialLeftEdge
ABDAY_5 | AllocAslRequestTags | ASLFO_InitialName
ABDAY_6 | Allocate | ASLFO_InitialSize
ABDAY_7 | AllocateCmdPathList | ASLFO_InitialStyle
ABMON_1 | AllocateTagItems | ASLFO_InitialTopEdge
ABMON_10 | AllocBitMap | ASLFO_InitialWidth
ABMON_11 | AllocBitMapTagList | ASLFO_IntuiMsgFunc
ABMON_12 | AllocClipRect | ASLFO_Locale
ABMON_2 | AllocCModeListTagList | ASLFO_MaxBackPen
ABMON_3 | AllocCModeListTags | ASLFO_MaxFrontPen
ABMON_4 | AllocDBufInfo | ASLFO_MaxHeight
ABMON_5 | AllocDosObject | ASLFO_MinHeight
ABMON_6 | AllocDosObjectTagList | ASLFO_ModeList
ABMON_7 | AllocDosObjectTags | ASLFO_NegativeText
ABMON_8 | AllocEntry | ASL_FontRequest
ABMON_9 | AllocFileRequest | ASLFO_PopToFront
AbortAslRequest | AllocIFF | ASLFO_PositiveText
ABORT_BUSY | AllocLocalItem | ASLFO_PrivateIDCMP
ABORT_DISK_ERROR | AllocNamedMemory | ASLFO_PubScreenName
AbortIO | AllocNamedObject | ASLFO_SampleText
AbsExecBase | AllocNamedObjectA | ASLFO_Screen
ABSOLUTE_DIMENSIONS | AllocPooled | ASLFO_SleepWindow
ACCESS_READ | AllocRaster | ASLFO_TextAttr
ACCESS_WRITE | AllocRemember | ASLFO_TitleText
ACPU_AddressErr | AllocScreenBuffer | ASLFO_UserData
ACPU_AutoVec1 | AllocSegList | ASLFO_Window
ACPU_AutoVec2 | AllocSignal | ASLFR_AcceptPattern
ACPU_AutoVec3 | AllocSpriteData | ASLFR_Activate
ACPU_AutoVec4 | AllocSpriteDataA | ASLFR_DoMultiSelect
ACPU_AutoVec5 | AllocSysObject | ASLFR_DoPatterns
ACPU_AutoVec6 | AllocTaskMemEntry | ASLFR_DoSaveMode
ACPU_AutoVec7 | AllocTrap | ASLFR_DrawersOnly
ACPU_BusErr | AllocVec | AslFreeVec
ACPU_CHK | AllocVecPooled | ASLFR_FilterDrawers
ACPU_DivZero | AllocVecTagList | ASLFR_FilterFunc
ACPU_Format | AlohaWorkbench | ASLFR_Flags1
ACPU_InstErr | ALPHAHOOKACTION_CHANGELAYERALPHA | ASLFR_Flags2
ACPU_LineA | ALPHAHOOKACTION_CREATELAYER | ASLFR_GetSortBy
ACPU_LineF | ALPHAHOOKACTION_DELETELAYER | ASLFR_GetSortDrawers
ACPU_PrivErr | ALPHAHOOKACTION_GETHOOKACTIONS | ASLFR_GetSortOrder
ACPU_Spurious | ALPHAHOOKACTION_MOVELAYER | ASLFR_HookFunc
ACPU_Trace | ALPHAHOOKACTION_MOVESIZELAYER | ASLFR_InitialDrawer
ACPU_TRAPV | ALPHAHOOKACTION_SIZELAYER | ASLFR_InitialFile
ACTION_ADD_NOTIFY | ALPHA_P_101 | ASLFR_InitialHeight
ACTION_CHANGE_FILE_POSITION64 | ALPHA_PREFIX | ASLFR_InitialLeftEdge
ACTION_CHANGE_FILE_SIZE64 | ALTDAY_1 | ASLFR_InitialPattern
ACTION_CHANGE_MODE | ALTDAY_2 | ASLFR_InitialShowVolumes
ACTION_CHANGE_SIGNAL | ALTDAY_3 | ASLFR_InitialTopEdge
ACTION_COLLECT | ALTDAY_4 | ASLFR_InitialWidth
ACTION_COPY_DIR | ALTDAY_5 | ASLFR_IntuiMsgFunc
ACTION_COPY_LOCK_FH | ALTDAY_6 | ASLFR_Locale
ACTION_CREATE_DIR | ALTDAY_7 | ASLFR_NegativeText
ACTION_CURRENT_VOLUME | ALTLEFT | ASLFR_PopToFront
ACTION_DELETE_OBJECT | ALTMON_1 | ASLFR_PositiveText
ACTION_DISK_INFO | ALTMON_10 | ASLFR_PrivateIDCMP
ACTION_END | ALTMON_11 | ASLFR_PubScreenName
ACTION_EVENT | ALTMON_12 | ASLFR_RejectIcons
ACTION_EXAMINEDATA | ALTMON_2 | ASLFR_RejectPattern
ACTION_EXAMINEDATA_DIR | ALTMON_3 | ASLFR_Screen
ACTION_EXAMINEDATA_FH | ALTMON_4 | ASLFR_SetSortBy
ACTION_EXAMINE_NEXT | ALTMON_5 | ASLFR_SetSortDrawers
ACTION_EXAMINE_OBJECT | ALTMON_6 | ASLFR_SetSortOrder
ACTION_FH_FROM_LOCK | ALTMON_7 | ASLFR_SleepWindow
ACTION_FILESYSTEM_ATTR | ALTMON_8 | ASLFRSORTBY_Date
ACTION_FINDINPUT | ALTMON_9 | ASLFRSORTBY_Name
ACTION_FINDOUTPUT | ALTRIGHT | ASLFRSORTBY_Size
ACTION_FINDUPDATE | AMCLASSICON_Copy | ASLFRSORTDRAWERS_First
ACTION_FLUSH | AMCLASSICON_Delete | ASLFRSORTDRAWERS_Last
ACTION_FORMAT | AMCLASSICON_EmptyTrash | ASLFRSORTDRAWERS_Mix
ACTION_FREE_DISK_FSSM | AMCLASSICON_FormatDisk | ASLFRSORTORDER_Ascend
ACTION_FREE_LOCK | AMCLASSICON_Information | ASLFRSORTORDER_Descend
ACTION_FREE_RECORD64 | AMCLASSICON_LeaveOut | ASLFR_StayOnTop
ACTION_GET_DISK_FSSM | AMCLASSICON_Open | ASLFR_TextAttr
ACTION_GET_FILE_POSITION64 | AMCLASSICON_PutAway | ASLFR_TitleText
ACTION_GET_FILE_SIZE64 | AMCLASSICON_Rename | ASLFR_UserData
ACTION_GID_TO_GROUPINFO | AMCLASSICON_Selected | ASLFR_Window
ACTION_GROUPNAME_TO_GID | AMCLASSICON_Snapshot | ASL_LAST_TAG
ACTION_ICONIFY | AMCLASSICON_Unselected | ASLNAME
ACTION_INFO | AMCLASSICON_UnSnapshot | ASLObtain
ACTION_INHIBIT | Amiga2Date | ASLOPTION_ASLOverrides
ACTION_INHIBIT_DOS_LONGPATH_HANDLING | amigados | ASLPOS_CenterMouse
ACTION_INT_WRITE_RETURN | AMIGAKEY | ASLPOS_CenterScreen
ACTION_IS_FILESYSTEM | AMIGAKEYS | ASLPOS_CenterWindow
ACTION_LOCATE_OBJECT | AMIGALEFT | ASLPOS_DefaultPosition
ACTION_LOCK_RECORD64 | AMIGARIGHT | ASLPOS_MASK
ACTION_MAKE_LINK | AM_STR | ASLPOS_ScreenPosition
ACTION_MORE_CACHE | AMTYPE_APPICON | ASLPOS_WindowPosition
ACTION_NEWMEMFILE | AMTYPE_APPMENUITEM | ASLRelease
ACTION_NEWMEMLOCK | AMTYPE_APPWINDOW | AslRequest
ACTION_NIL | AMTYPE_APPWINDOWZONE | AslRequestTags
ACTION_OBTAIN_CON_INFO | AM_VERSION | ASL_ScreenModeRequest
ACTION_PARENT | AN_AddSWGadget | ASL_SEMAPHORE_NAME
ACTION_PARENT_FH | AN_AsyncPkt | ASLSIZE_DefaultSize
ACTION_READ | AN_AudioDev | ASLSIZE_MASK
ACTION_READ_RETURN | AN_BadChkSum | ASLSIZE_RelativeSize
ACTION_READ_SOFT_LINK | AN_BadExpansionFree | ASLSM_Activate
ACTION_REMOVE_NOTIFY | AN_BadFreeAddr | ASLSM_CustomSMList
ACTION_RENAME_DISK | AN_BadGadget | ASLSM_DoAutoScroll
ACTION_RENAME_OBJECT | AN_BadHook | ASLSM_DoDepth
ACTION_SAME_FH | AN_BadInitFunc | ASLSM_DoHeight
ACTION_SAME_LOCK | AN_BadMemory | ASLSM_DoOverscanType
ACTION_SEEK | AN_BadMessage | ASLSM_DoWidth
ACTION_SERIALIZE_DISK | AN_BadOverlay | ASLSM_FilterFunc
ACTION_SET_BLOCKING_MODE | AN_BadSegList | ASLSM_InitialAutoScroll
ACTION_SET_COMMENT | AN_BadSemaphore | ASLSM_InitialDisplayDepth
ACTION_SET_DATE | AN_BadState | ASLSM_InitialDisplayHeight
ACTION_SET_OWNER_INFO | AN_BaseChkSum | ASLSM_InitialDisplayID
ACTION_SET_PROTECT | AN_BitMap | ASLSM_InitialDisplayWidth
ACTION_SHUTDOWN | AN_BltBitMap | ASLSM_InitialHeight
ACTION_SINGLE_CHARACTER_MODE | AN_BogusExcpt | ASLSM_InitialInfoLeftEdge
ACTION_STARTUP | AN_BootError | ASLSM_InitialInfoOpened
ACTION_TIMER | AN_BootStrap | ASLSM_InitialInfoTopEdge
ACTION_UID_TO_USERINFO | AN_CIARsrc | ASLSM_InitialLeftEdge
ACTION_USERNAME_TO_UID | AN_ConsoleDev | ASLSM_InitialOverscanType
ACTION_WAIT_CHAR | AN_CreatePort | ASLSM_InitialTopEdge
ACTION_WAIT_FOR_DATA | AN_CybppcDev | ASLSM_InitialWidth
ACTION_WRITE | AN_CybppcNoTerm | ASLSM_IntuiMsgFunc
ACTION_WRITE_PROTECT | AN_CybppcNoWide | ASLSM_Locale
ACTION_WRITE_RETURN | AN_DiskBlkSeq | ASLSM_MaxDepth
ActivateAslRequest | AN_DiskCopy | ASLSM_MaxHeight
ActivateGadget | AN_DiskError | ASLSM_MaxWidth
ActivateWindow | AN_DiskfontLib | ASLSM_MinDepth
AddAnimOb | AN_DiskRsrc | ASLSM_MinHeight
AddAppIcon | AN_DOSLib | ASLSM_MinWidth
AddAppIconA | AndRectRegion | ASLSM_NegativeText
AddAppMenuItem | AndRegionRegion | ASLSM_PopToFront
AddAppMenuItemA | AN_DRHasDisk | ASLSM_PositiveText
AddAppWindow | AN_DRIntNoAct | ASLSM_PrivateIDCMP
AddAppWindowA | AN_endTask | ASLSM_PropertyFlags
AddAppWindowDropZone | AN_ExcptVect | ASLSM_PropertyMask
AddAppWindowDropZoneA | AN_ExecLib | ASLSM_PubScreenName
AddBob | AN_ExpansionLib | ASLSM_Screen
AddBuffers | AN_FileReclosed | ASLSM_SleepWindow
AddClass | ANFRACSIZE | ASLSM_TextAttr
AddCmdPathNode | AN_FreeTwice | ASLSM_TitleText
ADDCMDPATHNODE_HEAD | AN_FreeVec | ASLSM_UserData
ADDCMDPATHNODE_TAIL | AN_GadgetType | ASLSM_Window
AddConSnipHook | AN_GadTools | ASODMAE_NumEntries
AddDates | AN_GamePortDev | ASODMAE_Size
AddDevice | AN_GfxFreeError | ASOEXTMEM_AllocationPolicy
AddDosEntry | AN_GfxNewError | ASOEXTMEM_Size
AddDTObject | AN_GfxNoLCM | ASOF_NOTRACK
AddFont | AN_GfxNoMem | ASOHOOK_Data
AddFreeList | AN_GfxNoMemMspc | ASOHOOK_Entry
AddGadget | AN_GraphicsLib | ASOHOOK_Size
AddGList | AN_IconLib | ASOHOOK_Subentry
AddHead | AN_IFaceChkSum | ASOINTR_Code
AddInterface | Animate | ASOINTR_Data
AddIntServer | ANIMATIONDTCLASS | ASOINTR_Size
AddLibrary | ANIMHALF | ASOINTR_SoftInt
AddMemHandler | AN_InitAPtr | ASOIOR_Duplicate
AddMemList | AN_IntrMem | ASOIOR_ReplyPort
AddNamedObject | AN_Intuition | ASOIOR_Size
AddPart | AN_IOAfterClose | ASOITEM_BatchSize
AddPort | AN_IOUsedTwice | ASOITEM_Constructor
AddResetCallback | AN_ISemOrder | ASOITEM_Destructor
AddResource | AN_ItemAlloc | ASOITEM_GCParameter
AddSegListTail | AN_ItemBoxTop | ASOITEM_GCPolicy
AddSegment | AN_KeyboardDev | ASOITEM_ItemSize
AddSegmentTagList | AN_KeyFree | ASOITEM_MaxSize
AddSemaphore | AN_KeyRange | ASOITEM_MFlags
AddTail | AN_LayersLib | ASOITEM_Protected
AddTask | AN_LayersNoMem | ASOKMEM_Alignment
AddTime | AN_LibChkSum | ASOKMEM_Colored
AddTrackable | AN_LongFrame | ASOKMEM_Compact
AddVSprite | AN_MakeVPort | ASOKMEM_Constructor
ADO_AddColon | AN_MathLib | ASOKMEM_Destructor
ADO_AddedSize | AN_MemCorrupt | ASOKMEM_Name
ADO_DOSMethodOnly | AN_MemoryInsane | ASOKMEM_Size
ADO_DOSType | ANMERROR_DUPLICATENAME | ASOKMEM_Type
ADO_Dummy | ANMERROR_NOERROR | ASOLIST_Min
ADO_ExamineData_CommentSize | ANMERROR_NOMEMORY | ASOLIST_Size
ADO_ExamineData_LinkSize | ANMERROR_PARAMETER | ASOLIST_Type
ADO_ExamineData_NameSize | AN_MiscRsrc | ASO_MemoryOvr
ADO_ExamineDir_Context | ANMT_CheckSum | ASOMSG_Length
ADO_Flags | ANMT_Error | ASOMSG_Name
ADO_Mask | AN_NewlibLib | ASOMSG_ReplyPort
ADO_Name | AN_NoBootNode | ASOMSG_Size
ADO_NotifyHook | AN_NoConsole | ASOMUTEX_Recursive
ADO_NotifyInitial | AN_NoFonts | ASONODE_Min
ADO_NotifyMethod | AN_NoISem | ASONODE_Name
ADO_NotifyName | AN_NoWindow | ASONODE_Pri
ADO_NotifyPort | AN_ObsoleteFont | ASONODE_Size
ADO_NotifySignalNumber | ANO_Flags | ASONODE_Type
ADO_NotifyTask | ANO_NameSpace | ASO_NoTrack
ADO_NotifyUserData | AN_OpenScreen | ASOPOOL_CopyName
ADO_NotifyWaitReply | AN_OpenScrnRast | ASOPOOL_LockMem
ADO_Size | AN_OpenWindow | ASOPOOL_MFlags
ADO_Strlen | ANO_Priority | ASOPOOL_Name
ADO_TermChar | ANO_UserSpace | ASOPOOL_Protected
ADO_TermCharStr | AN_PlaneAlloc | ASOPOOL_Puddle
ADO_Type | AN_QPktFail | ASOPOOL_Threshold
ADO_Vectors | AN_RAMLib | ASOPORT_Action
ADTA_Allocated | AN_RegionMemory | ASOPORT_AllocSig
ADTA_ColorRegisters | AN_SemCorrupt | ASOPORT_CopyName
ADTA_ColorTable | AN_ShortFrame | ASOPORT_Name
ADTA_ColorTable2 | AN_StackProbe | ASOPORT_Pri
ADTA_CRegs | AN_StartMem | ASOPORT_Public
ADTA_Cycles | AN_SubAlloc | ASOPORT_Signal
ADTA_Depth | AN_SysScrnType | ASOPORT_Size
ADTA_Dummy | AN_TDCalibSeek | ASOPORT_Target
ADTA_Frame | AN_TDDelay | ASORMAP_Base
ADTA_FrameIncrement | AN_TextTmpRas | ASORMAP_CacheMax
ADTA_Frames | ANTI_ALIAS | ASORMAP_Quantum
ADTA_FramesPerSecond | AN_TimerDev | ASORMAP_Size
ADTA_GRegs | AN_TMBadReq | ASOSEM_CopyName
ADTA_Height | AN_TMBadSupply | ASOSEM_Name
ADTA_KeyFrame | AN_TrackDiskDev | ASOSEM_Pri
ADTA_LeftSample | AN_Unknown | ASOSEM_Public
ADTA_ModeID | AN_UtilityLib | ASOSEM_Size
ADTA_NumAlloc | AN_WBBadIOMsg | ASOTAGS_NumEntries
ADTA_NumColors | AN_WBBadStartupMsg1 | ASOTAGS_Size
ADTA_NumSparse | AN_WBBadStartupMsg2 | ASOT_DMAENTRY
ADTA_Period | AN_WBReLayoutToolMenu | ASOT_EXTMEM
ADTA_PreloadFrameCount | AN_WeirdEcho | ASOT_HOOK
ADTA_Remap | AN_Workbench | ASOT_INTERRUPT
ADTA_RightSample | AO_AudioDev | ASOT_IOREQUEST
ADTA_Sample | AO_BootStrap | ASOT_ITEMPOOL
ADTA_SampleLength | AO_CIARsrc | ASOT_LIST
ADTA_SamplesPerSec | AO_ConsoleDev | ASOT_MEMPOOL
ADTA_Screen | AO_DiskCopy | ASOT_MESSAGE
ADTA_SparseTable | AO_DiskfontLib | ASOT_MUTEX
ADTA_Volume | AO_DiskRsrc | ASOT_NODE
ADTA_Width | AO_DOSLib | ASOT_PORT
ADTM_Dummy | AO_ExecLib | ASOT_RMAP
ADTM_LOADFRAME | AO_ExpansionLib | ASOT_SEMAPHORE
ADTM_LOADNEWFORMATFRAME | AO_GadTools | ASOT_TAGLIST
ADTM_LOCATE | AO_GamePortDev | ASPECT_HORIZ
ADTM_PAUSE | AO_GraphicsLib | ASPECT_VERT
ADTM_START | AO_IconLib | AS_SegmentList
ADTM_STOP | AO_Intuition | AssignAdd
ADTM_UNLOADFRAME | AO_KeyboardDev | AssignAddToList
ADTM_UNLOADNEWFORMATFRAME | AO_KeyMapLib | AssignLate
ADZMACTION_Enter | AO_LayersLib | AssignLock
ADZMACTION_Leave | AO_MathLib | AssignPath
AFB_4XX | AO_MiscRsrc | AsTag
AFB_603 | AO_NewlibLib | AT_Child
AFB_604 | AO_RAMLib | AT_Deadend
AFB_68010 | AO_TimerDev | AT_Param1
AFB_68020 | AO_TrackDiskDev | AT_Param2
AFB_68030 | AO_Unknown | AT_Param3
AFB_68040 | AO_UtilityLib | AT_Param4
AFB_68060 | AO_Workbench | AT_Param5
AFB_68881 | APB_DIDDIR | AT_Param6
AFB_68882 | APB_DirChanged | AT_Param7
AFB_7400 | APB_DODIR | AT_Param8
AFB_750 | APB_DODOT | AT_Recovery
AFB_ALTIVEC | APB_DOWILD | AttachPalExtra
AFB_BITMAP | APB_FollowHLinks | AttemptLockDosList
AFB_CHARSET | APB_ITSWILD | AttemptLockLayerRom
AFB_DISK | APB_MultiAssigns | AttemptNamedMemory
AFB_FPU40 | APB_NOMEMERR | AttemptRemNamedObject
AFB_MEMORY | APF_DIDDIR | AttemptSemaphore
AFB_OTAG | APF_DirChanged | AttemptSemaphoreShared
AFB_OTHER | APF_DODIR | SmallInt
AFB_PRIVATE | APF_DODOT | AUTOBACKPEN
AFB_SCALED | APF_DOWILD | AUTODRAWMODE
AFB_TAGGED | APF_FollowHLinks | AUTOFRONTPEN
AFB_TYPE | APF_ITSWILD | AUTOITEXTFONT
AFF_4XX | APF_MultiAssigns | AUTOKNOB
AFF_603 | APF_NOMEMERR | AUTOLEFTEDGE
AFF_604 | ApplyTagChanges | AUTONEXTTEXT
AFF_68010 | Pointer | AutoRequest
AFF_68020 | AreaCircle | AUTOSCROLL
AFF_68030 | AreaDraw | AUTOTOPEDGE
AFF_68040 | AreaEllipse | AvailFonts
AFF_68060 | AreaEnd | AvailMem
AFF_68881 | AreaMove | AVL_AddNode
AFF_68882 | AREAOUTLINE | AVL_FindFirstNode
AFF_7400 | AS_Dummy | AVL_FindLastNode
AFF_750 | AS_Entry | AVL_FindNextNodeByAddress
AFF_ALTIVEC | AskFont | AVL_FindNextNodeByKey
AFF_BITMAP | AskKeyMapDefault | AVL_FindNode
AFF_CHARSET | AskSoftStyle | AVL_FindPrevNodeByAddress
AFF_DISK | asl | AVL_FindPrevNodeByKey
AFF_FPU40 | AslAllocVec | AVLKEYCOMP
AFF_MEMORY | ASLBase | AVLNODECOMP
AFF_OTAG | ASLClone | AVL_RemNodeByAddress
AFF_OTHER | AslControl | AVL_RemNodeByKey
AFF_PRIVATE | AslControlTags | AVOID_FLICKER
AFF_SCALED | ASL_Dummy | AVT_Alignment
AFF_TAGGED | ASLExpunge | AVT_Clear
AFF_TYPE | ASL_FileRequest | AVT_ClearValue
AG_BadParm | ASLFO_Activate | AVT_ClearWithValue
AG_CloseDev | ASLFO_BackPens | AVT_Contiguous
AG_CloseLib | ASLFO_DoBackPen | AVT_Lock
AG_IOError | ASLFO_DoDrawMode | AVT_NoExpunge
AG_MakeLib | ASLFO_DoFrontPen | AVT_PhysicalAlignment
AG_NoMemory | ASLFO_DoStyle | AVT_Type
AG_NoSignal | ASLFO_FilterFunc | AVT_Wait
AG_Obsolete | ASLFO_FixedWidthOnly | AWCODE_INTERIM
AG_Opendev | ASLFO_Flags | AWCODE_NORMAL
AG_OpenLib | ASLFO_FrontPens |

B

B2BOBBER | BLITT_RASTPORT | BMICTRL_GetScreen
B2NORM | BLITT_RGB16 | BMICTRL_GetShadeMaskBitMap
B2SWAP | BLITT_RGB24 | BMICTRL_GetShadowMap
BACKGROUNDPEN | BLITT_TEMPLATE | BMICTRL_GetShineMap
BACKSAVED | BLOCKPEN | BMICTRL_GetTileBox
BADDR | BltBitMap | BMICTRL_GetTileHeight
BANDWIDTH_1X | BltBitMaPRastPort | BMICTRL_GetTileLeft
BANDWIDTH_2XDBL | BltBitMapTagList | BMICTRL_GetTileTop
BANDWIDTH_2XNML | BLTBMTAGS_BASE | BMICTRL_GetTileWidth
BANDWIDTH_4X | BltClear | BMICTRL_GetWidth
BARBLOCKPEN | BltMaskBitMapRastPort | BMICTRL_SetGradientSpec
BARCONTOURPEN | BltPattern | BMICTRL_SetOffsets
BARDETAILPEN | BltTemplate | BMICTRL_SetReferencePen
BARTRIMPEN | BltTemplateAlpha | BMICTRL_SetTileHeight
BASEOBJECT | BMA_ACTUALWIDTH | BMICTRL_SetTileLeft
BAUD_110 | BMA_BITSPERPIXEL | BMICTRL_SetTileTop
BAUD_1200 | BMA_BYTESPERPIXEL | BMICTRL_SetTileWidth
BAUD_19200 | BMA_DEPTH | BMI_DoLevels
BAUD_2400 | BMA_FLAGS | BMI_Dummy
BAUD_300 | BMA_HEIGHT | BMI_Exclusive
BAUD_4800 | BMA_ISRTG | BMI_GradientAxis
BAUD_9600 | BMA_PIXELFORMAT | BMI_GradientSpec
BAUD_MIDI | BMATags_Alignment | BMI_IgnoreDomain
BDRAWN | BMATags_BitmapColors | BMI_LayerInfo
BEEPING_F | BMATags_BitmapColors32 | BMI_Offsets
BeginIO | BMATags_BitmapInvisible | BMI_ReferencePen
BeginRefresh | BMATags_Clear | BMI_TileHeight
BeginUpdate | BMATags_ConstantBytesPerRow | BMI_TileLeft
BehindLayer | BMATags_Depth | BMI_TileTop
BestCModeIDTagList | BMATags_Displayable | BMI_TileWidth
BestCModeIDTags | BMATags_DisplayID | BMS_DoMask
BestModeID | BMATags_Friend | BMS_DoOutline
BestModeIDA | BMATags_ModeHeight | BMS_DoShade
BFHA_APen | BMATags_ModeWidth | BMS_Dummy
BFHA_BitMap | BMATags_NoMemory | BMS_NoDiskIO
BFHA_BPen | BMATags_NoSprite | BNDRYOFF
BFHA_DrMd | BMATags_PixelFormat | BOBISCOMP
BFHA_Height | BMATags_Private1 | BOBNIX
BFHA_OffsetX | BMATags_Private2 | BOBSAWAY
BFHA_OffsetY | BMATags_Private3 | BOBUPDATE
BFHA_PatSize | BMATags_Private4 | SmallInt
BFHA_Pattern | BMATags_Private5 | BOOLMASK
BFHA_Width | BMATags_Private6 | BOOPSIMENU
BGBACKFILL | BMATags_Private7 | BORDER_BLANKING
BIDTAG_BlueBits | BMATags_RenderFunc | BORDERHIT
BIDTAG_COERCE | BMATags_SaveFunc | BORDER_NOTRANSPARENCY
BIDTAG_Depth | BMATags_UserData | BORDERSPRITES
BIDTAG_DesiredHeight | BMATags_UserPrivate | BOTTOMHIT
BIDTAG_DesiredWidth | BMA_WIDTH | BOUNDED_DIMENSIONS
BIDTAG_DIPFMustHave | BMB_CLEAR | LongInt
BIDTAG_DIPFMustNotHave | BMB_DISPLAYABLE | BROADCAST_HBSTOP
BIDTAG_GfxPrivate | BMB_FRIENDISTAG | BROADCAST_HBSTRT
BIDTAG_GreenBits | BMB_HIJACKED | BROADCAST_HSSTOP
BIDTAG_MaxDepth | BMB_INTERLEAVED | BROADCAST_HSSTRT
BIDTAG_MonitorID | BMB_INVALID | BROADCAST_VBSTOP
BIDTAG_NominalHeight | BMB_LOCKED | BROADCAST_VBSTRT
BIDTAG_NominalWidth | BMB_MINPLANES | BROADCAST_VSSTOP
BIDTAG_RedBits | BMB_RTGCHECK | BROADCAST_VSSTRT
BIDTAG_SourceID | BMB_RTGTAGS | BROTHER_15XL
BIDTAG_ViewPort | BMB_SPECIALFMT | BSAF_AVERAGE
BITCLR | BMB_STANDARD | BSAF_BILINEAR
BitMapInstanceControlA | BMF_CHECKMASK | BSAF_RESERVED1
BitMapScale | BMF_CHECKVALUE | BSAF_RESERVED2
BitMask | BMF_CLEAR | LongInt
BITSET | BMF_DISPLAYABLE | BT_BACKGROUND
BITSPERBYTE | BMF_FRIENDISTAG | BT_DIRECTSHADE
BITSPERLONG | BMF_HIJACKED | BT_DRIPEN
BLITA_Alpha | BMF_INTERLEAVED | BT_FLAGSMASK
BLITA_AlphaMask | BMF_INVALID | BT_GADGET
BLITA_CLUT | BMF_LOCKED | BT_MENU
BLITA_Dest | BMF_MINPLANES | BT_OFFSETRECT
BLITA_DestBytesPerRow | BMF_RTGCHECK | BT_PROPBG
BLITA_DestType | BMF_RTGTAGS | BT_PROPKNOB
BLITA_DestX | BMF_SPECIALFMT | BT_REQUESTERBG
BLITA_DestY | BMF_STANDARD | BT_SCREENBAR
BLITA_Height | BMF_USERPRIVATE | BT_TABPAGE
BLITA_Mask | BMI_CacheGradient | BT_WINBORDER
BLITA_MaskPlane | BMICTRL_Dummy | BT_WINDOWBAR
BLITA_Minterm | BMICTRL_GetAlphaMap | BT_WINDOWBG
BLITA_Source | BMICTRL_GetBitMap | BT_WINPROPBG
BLITA_SrcBytesPerRow | BMICTRL_GetBitMapSource | BT_WINPROPKNOB
BLITA_SrcType | BMICTRL_GetBrightBitMap | BuildEasyRequestArgs
BLITA_SrcX | BMICTRL_GetDarkBitMap | BuildSysRequest
BLITA_SrcY | BMICTRL_GetGradientSpec | BumpRevision
BLITA_UseDestAlpha | BMICTRL_GetHalfBrightBitMap | BumpRevisionLength
BLITA_UseSrcAlpha | BMICTRL_GetHalfDarkBitMap | BUS_16
BLITA_Width | BMICTRL_GetHeight | BUS_32
BLITMSG_FAULT | BMICTRL_GetHook | BUSERFLAGS
BLITMSG_FAULTn | BMICTRL_GetMaskBitMap | SmallInt
BLITT_ALPHATEMPLATE | BMICTRL_GetOffsets | BUTTONGCLASS
BLITT_ARGB32 | BMICTRL_GetOutlineBitMap | BWAITING
BLITT_BITMAP | BMICTRL_GetOutlineMap | BYTESPERLONG
BLITT_CHUNKY | BMICTRL_GetReferencePen |

C

CacheClearE | CMF_CMTRANS | CORRECT_RGB_MASK
CacheClearU | CMF_CPTRANS | CPACTION_Begin
CacheControl | CModeRequestTagList | CPACTION_Copy
CachePostDMA | CModeRequestTags | CPACTION_End
CachePreDMA | CMove | CPR_NT_LOF
CACRF_ClearD | cmpByteRun1 | CPR_NT_SHT
CACRF_ClearI | cmpByteRun2 | CPR_NT_SYS
CACRF_CopyBack | CMP_FIBDELTA | CPRNXTBUF
CACRF_DBE | cmpNone | CPUFAMILY_4XX
CACRF_EnableD | CMP_NONE | CPUFAMILY_60X
CACRF_EnableE | CmpTime | CPUFAMILY_74XX
CACRF_EnableI | CM_QUERY | CPUFAMILY_7X0
CACRF_FreezeD | CNTR_ABSOLUTE | CPUFAMILY_E300
CACRF_FreezeI | CNTR_CORRECT | CPUFAMILY_E5500
CACRF_IBE | CoerceMethod | CPUFAMILY_PA6T
CACRF_InvalidateD | CoerceMethodA | CPUFAMILY_UNKNOWN
CACRF_WriteAllocate | CoerceMode | CPUTYPE_P50XX
CalcIVG | ColdReboot | CPUTYPE_PA6T_1682M
CalculateSegmentChecksum | CollectionChunk | CPUTYPE_PPC405EP
CallHook | CollectionChunks | CPUTYPE_PPC405GP
CallHookPkt | CollTable | CPUTYPE_PPC405GPR
CapturePattern | COLORMAP_TRANSPARENCY | CPUTYPE_PPC405LP
Cause | COLORMAP_TYPE_V1_2 | CPUTYPE_PPC440EP
CBD_CHANGEHOOK | COLORMAP_TYPE_V1_4 | CPUTYPE_PPC440GP
CBD_CURRENTREADID | COLORMAP_TYPE_V36 | CPUTYPE_PPC440GX
CBD_CURRENTWRITEID | COLORMAP_TYPE_V39 | CPUTYPE_PPC440SP
CBD_POST | COLORON | CPUTYPE_PPC440SX
CBERR_OBSOLETEID | COLORPLANE_TRANSPARENCY | CPUTYPE_PPC460EX
CBM_MPS1000 | COMMSEQ | CPUTYPE_PPC5121E
CBump | COMMWIDTH | CPUTYPE_PPC603E
CD_ASKDEFAULTKEYMAP | CompareDates | CPUTYPE_PPC604E
CD_ASKKEYMAP | COMPERR_Generic | CPUTYPE_PPC7410
CDInputHandler | COMPERR_Incompatible | CPUTYPE_PPC74XX_APOLLO
CD_SETDEFAULTKEYMAP | COMPERR_MissingInput | CPUTYPE_PPC74XX_VGER
CD_SETKEYMAP | COMPERR_OutOfMemory | CPUTYPE_PPC750CXE
CENTER_IMAGE | COMPERR_SoftwareFallback | CPUTYPE_PPC750FX
ChangeExtSprite | COMPERR_Success | CPUTYPE_PPC750GX
ChangeExtSpriteA | COMPERR_UnknownOperator | CPUTYPE_UNKNOWN
CHANGE_FH | COMPERR_Value | CR_ALPHATYPE
ChangeFilePosition | COMPFLAG_Color1Modulate | CR_DAMAGECLIPPED
ChangeFileSize | COMPFLAG_DestAlphaOverride | CreateBackFillHookA
ChangeLayerAlpha | COMPFLAG_ForceSoftware | CreateBehindHookLayer
ChangeLayerShape | COMPFLAG_HardwareOnly | CreateBehindLayer
CHANGE_LOCK | COMPFLAG_IgnoreDestAlpha | CreateDir
ChangeMode | COMPFLAG_SrcAlphaOverride | CreateDirTree
ChangeScreenBuffer | COMPFLAG_SrcFilter | CreateExtIO
ChangeSprite | COMPLEMENT | CreateIORequest
ChangeToSelectedIconColor | COMPLEX_BIT | CreateLayerA
ChangeVPBitMap | ComposeLayersA | CreateLibrary
ChangeWindowBox | COMPOSITE_Clear | CreateMsgPort
ChangeWorkbenchSelectionA | COMPOSITE_Dest | CreateNewProc
CheckDate | COMPOSITE_Dest_Atop_Src | CreateNewProcTagList
CHECKED | COMPOSITE_Dest_In_Src | CreateNewProcTags
CHECKIMAGE | COMPOSITE_Dest_Out_Src | CreatePool
CheckIO | COMPOSITE_Dest_Over_Src | CreatePort
CHECKIT | COMPOSITE_Maximum | CreateProc
CHECKMARKIMAGE | COMPOSITE_Minimum | CreateSkipList
CheckSignal | COMPOSITE_NumOperators | CreateSplayTree
CHECKWIDTH | COMPOSITE_Plus | CreateTask
ClassID | COMPOSITE_Src | CreateUpfrontHookLayer
ClearDMRequest | COMPOSITE_Src_Atop_Dest | CreateUpfrontLayer
ClearEOL | COMPOSITE_Src_In_Dest | CR_INTUITION
ClearMem | COMPOSITE_Src_Out_Dest | CR_INVISIBLE
ClearMenuStrip | COMPOSITE_Src_Over_Dest | CR_LAYERBITMAP
ClearPointer | COMPOSITE_Src_Xor_Dest | CR_USERCLIPPED
ClearRectRegion | CompositeTagList | CSP_PRECEDES
ClearRegion | COMPTAG_Base | CSP_SUCCEEDS
ClearScreen | COMPTAG_Color0 | CT_7FRI
CLF_INLIST | COMPTAG_Color0_Alpha | CT_7MON
Cli | COMPTAG_Color0_Blue | CT_7SAT
CLICKTAB_ACTIVEBOLD | COMPTAG_Color0_Green | CT_7SUN
CLICKTAB_ACTIVEBRIGHT | COMPTAG_Color0_Red | CT_7THU
CLICKTAB_ACTIVEFILLFILL | COMPTAG_Color1 | CT_7TUE
CLICKTAB_ACTIVEFILLGRAD | COMPTAG_Color1_Alpha | CT_7WED
CLICKTAB_ACTIVEFILLMASK | COMPTAG_Color1_Blue | CTABFMT_XRGB8
CLICKTAB_ACTIVEFILLNONE | COMPTAG_Color1_Green | CT_ANTIALIAS
CLICKTAB_ACTIVEFILLSELECT | COMPTAG_Color1_Red | CTB_MAPCOLOR
CLICKTAB_ACTIVEFILLSHINE | COMPTAG_Color2 | CTC_HCLRTAB
CLICKTAB_ACTIVEPENHLTEXT | COMPTAG_Color2_Alpha | CTC_HCLRTABSALL
CLICKTAB_ACTIVEPENMASK | COMPTAG_Color2_Blue | CTC_HSETTAB
CLICKTAB_ACTIVEPENTEXT | COMPTAG_Color2_Green | CT_COLORFONT
CLICKTAB_ACTIVEPENTITLE | COMPTAG_Color2_Red | CT_COLORMASK
CLICKTAB_EVENWIDTH | COMPTAG_Color3 | CTF_MAPCOLOR
CLICKTAB_INACTIVEDARK | COMPTAG_Color3_Alpha | CT_GREYFONT
CliInitNewcli | COMPTAG_Color3_Blue | CT_LockStack
CliInitRun | COMPTAG_Color3_Green | CurrentChunk
ClipBlit | COMPTAG_Color3_Red | CurrentDir
clipboard | COMPTAG_DestAlpha | CurrentTime
CloneTagItems | COMPTAG_DestAlphaMask | CURSORDOWN
CloseCatalog | COMPTAG_DestAlphaX | CURSORLEFT
CloseClass | COMPTAG_DestAlphaY | CURSORRIGHT
CloseClipboard | COMPTAG_DestHeight | CURSORUP
CloseDevice | COMPTAG_DestWidth | CUSTOMBITMAP_F
CloseFont | COMPTAG_DestX | CUSTOM_HOOK
CLOSEGADGET | COMPTAG_DestY | CUSTOMIMAGEDEPTH
CloseGUIPlugin | COMPTAG_DisplayID | CUSTOM_NAME
CloseIFF | COMPTAG_Flags | CUSTOM_PAPER
CLOSEIMAGE | COMPTAG_FriendBitMap | CUSTOMSCREEN_F
CloseKeyMapHandle | COMPTAG_IndexArray | CVideoCtrlTagList
CloseLibrary | COMPTAG_NumTriangles | CVideoCtrlTags
CloseLocale | COMPTAG_OffsetX | CWait
CloseMonitor | COMPTAG_OffsetY | CWCODE_DEPTH
CloseOutlineFont | COMPTAG_Private | CWCODE_MOVESIZE
CLOSEQUOTE | COMPTAG_Private2 | CyberGfxBase
CloseScreen | COMPTAG_ScaleX | CyberGfxClone
CloseWindow | COMPTAG_ScaleY | CyberGfxExpunge
CloseWorkBench | COMPTAG_SrcAlpha | CYBERGFX_INCLUDE_VERSION
CloseWorkbenchObject | COMPTAG_SrcAlphaMask | CYBERGFXNAME
CloseWorkbenchObjectA | COMPTAG_SrcAlphaX | CyberGfxObtain
CLT_DataSize | COMPTAG_SrcAlphaY | CyberGfxRelease
CLT_InitData | COMPTAG_SrcHeight | cybergraphics
CLT_InitFunc | COMPTAG_SrcWidth | CYBRBIDTG_BoardName
CLT_Interfaces | COMPTAG_SrcX | CYBRBIDTG_Depth
CLT_Legacy | COMPTAG_SrcY | CYBRBIDTG_MonitorID
CLT_NoLegacyIFace | COMPTAG_SrcYUVMatrix | CYBRBIDTG_NominalHeight
CLT_Seglist | COMPTAG_SrcYUVStandard | CYBRBIDTG_NominalWidth
CLT_Vector68K | COMPTAG_VertexArray | CYBRBIDTG_TB
CMAB_DUALPF_DISABLE | COMPTAG_VertexFormat | CYBRIDATTR_BPPIX
CMAB_FULLPALETTE | COMPVF_STW0_Present | CYBRIDATTR_DEPTH
CMAB_NO_COLOR_LOAD | COMPVF_STW1_Present | CYBRIDATTR_HEIGHT
CMAB_NO_INTERMED_UPDATE | COMPYUV_BT601 | CYBRIDATTR_PIXFMT
CMAF_DUALPF_DISABLE | COMPYUV_BT709 | CYBRIDATTR_WIDTH
CMAF_FULLPALETTE | CONFLAG_DEFAULT | CYBRMATTR_BPPIX
CMAF_NO_COLOR_LOAD | CONFLAG_NODRAW_ON_NEWSIZE | CYBRMATTR_DEPTH
CMAF_NO_INTERMED_UPDATE | console | CYBRMATTR_DISPADR
CMD_CLEAR | ConsoleDevice | CYBRMATTR_HEIGHT
CMD_DISABLED | CONU_CHARMAP | CYBRMATTR_ISCYBERGFX
CMD_FLUSH | CONU_LIBRARY | CYBRMATTR_ISLINEARMEM
CMD_INTERNAL | conunit | CYBRMATTR_PIXFMT
CMD_INVALID | CONU_SNIPMAP | CYBRMATTR_PIXFMT_ALPHA
CMD_NONSTD | CONU_STANDARD | CYBRMATTR_WIDTH
CMD_READ | ConvToLower | CYBRMATTR_XMOD
CMD_RESET | ConvToUpper | CYBRMREQ_CancelText
CMD_START | COPPER_MOVE | CYBRMREQ_CModelArray
CMD_STOP | COPPER_WAIT | CYBRMREQ_MaxDepth
CMD_SYSTEM | CopyDTMethods | CYBRMREQ_MaxHeight
CMD_UPDATE | CopyDTTriggerMethods | CYBRMREQ_MaxWidth
CMD_WRITE | CopyMem | CYBRMREQ_MinDepth
CMENU_BOTTOM | CopyMemQuick | CYBRMREQ_MinHeight
CMENU_CENTER | CopySBitMap | CYBRMREQ_MinWidth
CMENU_CENTER_MOUSE | CopyStringBSTRToC | CYBRMREQ_OKText
CMENU_RIGHT | CopyStringCToBSTR | CYBRMREQ_Screen
CMF_BRDNTRAN | CORRECT_BLUE | CYBRMREQ_TB
CMF_BRDRBLNK | CORRECT_GREEN | CYBRMREQ_WinTitle
CMF_BRDRSPRT | CORRECT_RED | CYCLEIMAGE

D

datatypes | DeleteTrackable | DOSTRUE
DataTypesBase | DeleteVar | DoSuperMethod
DATATYPESCLASS | DE_LOWCYL | DoSuperMethodA
DATATYPESNAME | DE_MASK | DOS_VOLUMELIST
Date2Amiga | DE_MAXTRANSFER | DosWrite
DateStamp | DE_MEMBUFTYPE | DoubleClick
DateStampToSeconds | DE_NUMBUFFERS | DOWNBACKGADGET
DAY_1 | DE_NUMHEADS | DOWNIMAGE
DAY_2 | DE_PREFAC | DOWNSHIFT_PIXFMT
DAY_3 | DEPTHIMAGE | DP_2DFACSHIFT
DAY_4 | DE_RESERVEDBLKS | DP_2DINDEXMASK
DAY_5 | DE_SECORG | DP64_INIT
DAY_6 | DE_SECSPERBLK | DPB_DEAD
DAY_7 | DE_SIZEBLOCK | DPB_MOD
DBHMT_ADDTASK | DE_TABLESIZE | DPF_DEAD
DBHMT_CLOSELIB | DETAILPEN | DPF_MOD
DBHMT_EXCEPTION | DE_UPPERCYL | DPMSLEVEL_OFF
DBHMT_OPENLIB | DEV_ABORTIO | DPMSLEVEL_ON
DBHMT_REMTASK | DEV_beginIO | DPMSLEVEL_STANDBY
DBHMT_SHAREDOBJECTCLOSE | DeviceProc | DPMSLEVEL_SUSPEND
DBHMT_SHAREDOBJECTOPEN | DevNameFromFH | DPMS_OFF
DBL_CAS | DevNameFromLock | DPMS_ON
DBLNTSCEXTRALORESDPF2FF_KEY | DevNameFromPort | DPMS_STANDBY
DBLNTSCEXTRALORESDPF2_KEY | DEVNAME_SIZE | DPMS_SUSPEND
DBLNTSCEXTRALORESDPF2LACE_KEY | DFCS_MAPTABLE | DRAFT
DBLNTSCEXTRALORESDPFFF_KEY | DFCS_MIMENAME | DRAGGADGET
DBLNTSCEXTRALORESDPF_KEY | DFCS_NAME | Draw
DBLNTSCEXTRALORESDPFLACE_KEY | DFCS_NEXTNUMBER | DrawBorder
DBLNTSCEXTRALORESEHBFF_KEY | DFCS_NUMBER | DrawCircle
DBLNTSCEXTRALORESEHB_KEY | DFCTRL_ANTIALIASING | DrawDTObject
DBLNTSCEXTRALORESEHBLACE_KEY | DFCTRL_BASE | DrawDTObjectA
DBLNTSCEXTRALORESFF_KEY | DFCTRL_CACHE | DrawEllipse
DBLNTSCEXTRALORESHAMFF_KEY | DFCTRL_CACHEFLUSH | DRAWERDATAFILESIZE
DBLNTSCEXTRALORESHAM_KEY | DFCTRL_CHARSET | DrawGList
DBLNTSCEXTRALORESHAMLACE_KEY | DFCTRL_SORT_ASC | DrawGradient
DBLNTSCEXTRALORES_KEY | DFCTRL_SORT_DES | DrawIconStateA
DBLNTSCEXTRALORESLACE_KEY | DFCTRL_SORTMODE | DrawImage
DBLNTSCHIRESDPF2FF_KEY | DFCTRL_SORT_OFF | DrawImageState
DBLNTSCHIRESDPF2_KEY | DFCTRL_XDOTP | DrawSysImageA
DBLNTSCHIRESDPF2LACE_KEY | DFCTRL_XDPI | DRIF_NEWDISABLE
DBLNTSCHIRESDPFFF_KEY | DFCTRL_YDOTP | DRIF_NEWLOOK
DBLNTSCHIRESDPF_KEY | DFCTRL_YDPI | DRIF_REALSHADE
DBLNTSCHIRESDPFLACE_KEY | DFH_ID | DRIPENS_IGNORE
DBLNTSCHIRESEHBFF_KEY | DFTCH_MASK | DRI_VERSION
DBLNTSCHIRESEHB_KEY | DIAB_630 | DropInterface
DBLNTSCHIRESEHBLACE_KEY | DIAB_ADV_D25 | DSHM_Jump
DBLNTSCHIRESFF_KEY | DIAB_C_150 | DSHM_Smooth
DBLNTSCHIRESHAMFF_KEY | DI_AVAIL_INVALID | DSR_CPR
DBLNTSCHIRESHAM_KEY | DI_AVAIL_MONITOOL | DTA_ARexxPortName
DBLNTSCHIRESHAMLACE_KEY | DI_AVAIL_NOCHIPS | DTA_BaseName
DBLNTSCHIRES_KEY | DI_AVAIL_NOMONITOR | DTA_Busy
DBLNTSCHIRESLACE_KEY | DI_AVAIL_NOTWITHGENLOCK | DTA_Conductor
DBLNTSCLORESDPF2FF_KEY | DIMENSIONS_MASK | DTA_ControlPanel
DBLNTSCLORESDPF2_KEY | DIPF_IS_AA | DTA_Data
DBLNTSCLORESDPF2LACE_KEY | DIPF_IS_BEAMSYNC | DTA_DataType
DBLNTSCLORESDPFFF_KEY | DIPF_IS_DBUFFER | DTA_DestCols
DBLNTSCLORESDPF_KEY | DIPF_IS_DRAGGABLE | DTA_DestRows
DBLNTSCLORESDPFLACE_KEY | DIPF_IS_DUALPF | DTA_Domain
DBLNTSCLORESEHBFF_KEY | DIPF_IS_ECS | DTA_Dummy
DBLNTSCLORESEHB_KEY | DIPF_IS_EXTRAHALFBRITE | DTA_ErrorLevel
DBLNTSCLORESEHBLACE_KEY | DIPF_IS_FOREIGN | DTA_ErrorNumber
DBLNTSCLORESFF_KEY | DIPF_IS_GENLOCK | DTA_ErrorString
DBLNTSCLORESHAMFF_KEY | DIPF_IS_HAM | DTA_FrameInfo
DBLNTSCLORESHAM_KEY | DIPF_IS_HWCOMPOSITE | DTAG_DIMS
DBLNTSCLORESHAMLACE_KEY | DIPF_IS_LACE | DTAG_DISP
DBLNTSCLORES_KEY | DIPF_IS_PAL | DTAG_MNTR
DBLNTSCLORESLACE_KEY | DIPF_IS_PANELLED | DTAG_NAME
DBLNTSC_MONITOR_ID | DIPF_IS_PF2PRI | DTA_GroupID
DBLPALEXTRALORESDPF2FF_KEY | DIPF_IS_PREFERREDMODE | DTAG_VEC
DBLPALEXTRALORESDPF2_KEY | DIPF_IS_PROGBEAM | DTA_Handle
DBLPALEXTRALORESDPF2LACE_KEY | DIPF_IS_RTG | DTA_HorizUnit
DBLPALEXTRALORESDPFFF_KEY | DIPF_IS_SCANDBL | DTA_Immediate
DBLPALEXTRALORESDPF_KEY | DIPF_IS_SPRITES | DTA_LayoutProc
DBLPALEXTRALORESDPFLACE_KEY | DIPF_IS_SPRITES_ATT | DTA_Methods
DBLPALEXTRALORESEHBFF_KEY | DIPF_IS_SPRITES_BORDER | DTA_Name
DBLPALEXTRALORESEHB_KEY | DIPF_IS_SPRITES_CHNG_BASE | DTA_NodeName
DBLPALEXTRALORESEHBLACE_KEY | DIPF_IS_SPRITES_CHNG_PRI | DTA_NominalHoriz
DBLPALEXTRALORESFF_KEY | DIPF_IS_SPRITES_CHNG_RES | DTA_NominalVert
DBLPALEXTRALORESHAMFF_KEY | DIPF_IS_WB | DTA_ObjAnnotation
DBLPALEXTRALORESHAM_KEY | DirectionVector | DTA_ObjAuthor
DBLPALEXTRALORESHAMLACE_KEY | Disable | DTA_ObjCopyright
DBLPALEXTRALORES_KEY | DISABLEDPEN | DTA_ObjectID
DBLPALEXTRALORESLACE_KEY | DISABLEDSHADOWPEN | DTA_ObjName
DBLPALHIRESDPF2FF_KEY | DISABLEDSHINEPEN | DTA_ObjVersion
DBLPALHIRESDPF2_KEY | DISABLEDTEXTPEN | DTA_PrinterProc
DBLPALHIRESDPF2LACE_KEY | DisableTemplate | DTA_PrinterStatus
DBLPALHIRESDPFFF_KEY | DisableTemplateRGB | DTA_RastPort
DBLPALHIRESDPF_KEY | diskfont | DTA_Repeat
DBLPALHIRESDPFLACE_KEY | DiskfontBase | DTA_Reserved
DBLPALHIRESEHBFF_KEY | DiskfontClone | DTA_SelectDomain
DBLPALHIRESEHB_KEY | DiskfontExpunge | DTA_SourceAddress
DBLPALHIRESEHBLACE_KEY | DISKFONTNAME | DTA_SourceSize
DBLPALHIRESFF_KEY | DiskfontObtain | DTA_SourceType
DBLPALHIRESHAMFF_KEY | DiskfontRelease | DTA_Special
DBLPALHIRESHAM_KEY | DismountDevice | DTA_Sync
DBLPALHIRESHAMLACE_KEY | DisownBlitter | DTA_TextAttr
DBLPALHIRES_KEY | DisplayAlert | DTA_TextFont
DBLPALHIRESLACE_KEY | DisplayBeep | DTA_Title
DBLPALLORESDPF2FF_KEY | DisplayInfoHandle | DTA_TopHoriz
DBLPALLORESDPF2_KEY | DISPLAYNAMELEN | DTA_TopVert
DBLPALLORESDPF2LACE_KEY | DisposeDTObject | DTA_TotalHoriz
DBLPALLORESDPFFF_KEY | DisposeFontContents | DTA_TotalPHoriz
DBLPALLORESDPF_KEY | DisposeLayerInfo | DTA_TotalPVert
DBLPALLORESDPFLACE_KEY | DisposeObject | DTA_TotalVert
DBLPALLORESEHBFF_KEY | DisposeRegion | DTA_TriggerMethods
DBLPALLORESEHB_KEY | DITHERING_MASK | DTA_UserData
DBLPALLORESEHBLACE_KEY | DIW_HORIZ_POS | DTA_VertUnit
DBLPALLORESFF_KEY | DIW_VRTCL_POS | DTA_VisibleHoriz
DBLPALLORESHAMFF_KEY | DIW_VRTCL_POS_SHIFT | DTA_VisibleVert
DBLPALLORESHAM_KEY | DLACTION_BeginDiscard | DTB_FUTURE
DBLPALLORESHAMLACE_KEY | DLACTION_BeginEmptyTrash | DTB_SUBST
DBLPALLORES_KEY | DLACTION_DeleteContents | DTERROR_COULDNT_OPEN
DBLPALLORESLACE_KEY | DLACTION_DeleteObject | DTERROR_COULDNT_OPEN_CLIPBOARD
DBLPAL_MONITOR_ID | DLACTION_End | DTERROR_COULDNT_SAVE
DBLPF | DLT_DEVICE | DTERROR_COULDNT_SEND_MESSAGE
DBUFFER | DLT_LATE | DTERROR_INVALID_DATA
DC_AssignMountR | DLT_LOCK | DTERROR_NOT_AVAILABLE
DC_AssignMountW | DLT_NONBINDING | DTERROR_NOT_ENOUGH_DATA
DC_BootCliCloseGadgetR | DLT_PRIVATE | DTERROR_Reserved
DC_BootCliCloseGadgetW | DLT_VOLUME | DTERROR_UNKNOWN_COMPRESSION
DC_BootCliFontSizeR | DMA_Continue | DTERROR_UNKNOWN_DATATYPE
DC_BootCliFontSizeW | DMAF_Continue | DTF_ASCII
DC_Dummy | DMAF_NoModify | DTF_BINARY
DC_FHBufferR | DMAF_ReadFromRAM | DTF_CASE
DC_FHBufferW | DMA_NoModify | DTF_FUTURE
DC_LocaleBaseR | DMA_ReadFromRAM | DTF_IFF
DC_LocaleBaseW | DMDF_FORCE_DISMOUNT | DTF_MISC
DC_MinProcStackR | DMDF_KEEPDEVICE | DTF_SUBST
DC_MinProcStackW | DMDF_REMOVEDEVICE | DTF_SYSTEM1
DC_Reload68KApplistW | DMODECOUNT | DTF_TYPE_MASK
DC_unused1R | DN_DEVICEONLY | DTHSIZE
DC_WarnPostTimeR | DN_FULLPATH | DTM_ABORTPRINT
DC_WarnPostTimeW | DN_ROOTPATH | DTM_ASYNCLAYOUT
DC_WarnWaitTimeR | DoAsyncLayout | DTM_CLEARSELECTED
DC_WarnWaitTimeW | DoCDrawMethodTagList | DTM_COPY
DC_WildStarR | DoCDrawMethodTags | DTM_DISPOSEMEMBER
DC_WildStarW | DoCollision | DTM_DRAW
DDB_AllBit | DoDTDomain | DTM_Dummy
DDB_Assign | DoDTDomainA | DTM_FRAMEBOX
DDB_Completed | DoDTMethod | DTM_GOTO
DDB_Device | DoDTMethodA | DTM_NEWMEMBER
DDB_ExaminedBit | DoGadgetMethodA | DTM_OBTAINDRAWINFO
DDB_PatternBit | DoHookClipRects | DTM_PRINT
DDF_AllBit | DoIO | DTM_PROCLAYOUT
DDF_Assign | DoMethod | DTM_RELEASEDRAWINFO
DDF_Completed | DoMethodA | DTM_REMOVEDTOBJECT
DDF_Device | DoPkt | DTM_SELECT
DDF_ExaminedBit | DoPkt0 | DTMSG_TYPE_OFFSET
DDFLAGS_SHOWALL | DoPkt1 | DTM_TRIGGER
DDFLAGS_SHOWDEFAULT | DoPkt2 | DTM_WRITE
DDFLAGS_SHOWICONS | DoPkt3 | DTNSIZE
DDF_PatternBit | DoPkt4 | DTSIF_DRAGGING
DDVM_BYDATE | DoRender | DTSIF_DRAGSELECT
DDVM_BYDEFAULT | DOS_ANCHORPATH | DTSIF_HIGHLIGHT
DDVM_BYICON | DOS_CLI | DTSIF_LAYOUT
DDVM_BYNAME | DosClone | DTSIF_LAYOUTPROC
DDVM_BYSIZE | DOSClose | DTSIF_NEWSIZE
DDVM_BYTYPE | DosControl | DTSIF_PRINTING
DEADEND_ALERT | DoScrollHook | DTST_CLIPBOARD
Deallocate | DosDateToStr | DTST_FILE
DE_BAUD | DosDelay | DTST_HOTLINK
DE_BLKSPERTRACK | DosDelete | DTST_MEMORY
DE_BOOTBLOCKS | DosDeleteFile | DTST_RAM
DE_BOOTPRI | DOS_DOSLIST | DTWM_IFF
DE_BUFMEMTYPE | DOS_EXALLCONTROL | DTWM_RAW
DEBUG_SYMBOL_68K_MODULE | DOS_EXAMINEDATA | DUALPF
DEBUG_SYMBOL_KERNEL_MODULE | DosExpunge | DupDiskObjectA
DEBUG_SYMBOL_MODULE | DOSFALSE | DupFileHandle
DEBUG_SYMBOL_MODULE_STABS | DOS_FIB | DupLock
DEBUG_SYMBOL_NATIVE_MODULE | DOS_FILEHANDLE | DupLockFromFH
DE_CONTROL | DosFlush | DVPB_ASSIGNMENT
DE_DOSTYPE | DOS_FREADLINEDATA | DVPB_CONSOLE
DEFAULT_MONITOR_ID | DOS_FSVECTORPORT | DVPB_CURRDIR
DEFAULT_MONITOR_NAME | DOS_INFODATA | DVPB_DEVICE
DEFAULTMOUSEQUEUE | DosInput | DVPB_FILESYS
DEFERREFRESH | DOS_LOCK | DVPB_MULTIASSIGN
DE_INTERLEAVE | DOS_NOTIFYREQUEST | DVPB_PROGDIR
DeleteBackFillHook | DosObtain | DVPB_ROOTDIR
DeleteDiskObject | DosOpen | DVPB_UNLOCK
DeleteExtIO | DosOutput | DVPB_VOLUME
DeleteInterface | DOS_OWNER_NONE | DVPF_ASSIGNMENT
DeleteIORequest | DOS_OWNER_ROOT | DVPF_CONSOLE
DeleteLayer | DOS_RDARGS | DVPF_CURRDIR
DeleteLibrary | DosRead | DVPF_DEVICE
DeleteMsgPort | DosRelease | DVPF_FILESYS
DeletePool | DosRename | DVPF_MULTIASSIGN
DeletePort | DosSeek | DVPF_PROGDIR
DeleteSkipList | DOS_STDPKT | DVPF_ROOTDIR
DeleteSplayTree | DosStrToDate | DVPF_UNLOCK
DeleteTask | DosSystem | DVPF_VOLUME

E

EasyRequest | ERROR_OBJECT_IN_USE | EURO_A7
EasyRequestArgs | ERROR_OBJECT_LINKED | EURO_A8
ECF_FPU | ERROR_OBJECT_NOT_FOUND | EVENTMAX
ECF_FULL_FPU | ERROR_OBJECT_TOO_LARGE | ExAll
ECF_FULL_GPRS | ERROR_OBJECT_WRONG_TYPE | ExAllEnd
ECF_VECTOR | ErrorOutput | Examine
ECF_VRSAVE | ERROR_READ_PROTECTED | EXAMINE_BIT
ECloseEngine | ERROR_RECORD_NOT_LOCKED | ExamineDir
ED_COMMENT | ERROR_RENAME_ACROSS_DEVICES | ExamineFH
ED_DATE | ErrorReport | ExamineObject
ED_NAME | ERROR_REQUIRED_ARG_MISSING | EXCLUSIVE_LOCK
ED_OWNER | ERROR_SEEK_ERROR | EX_DataFields
ED_PROTECTION | ERROR_SEPARATOR_AT_TITLE_LEVEL | EXDB_ARCHIVE
ED_SIZE | ERROR_SIZE_MISSING | EXDB_GRP_DELETE
ED_TYPE | ERROR_STARTUP_STRING_TOO_LONG | EXDB_GRP_EXECUTE
EFPF_FP0 | ERROR_SUBITEMS_WITHOUT_PARENT | EXDB_GRP_READ
EFPF_FP1 | ERROR_TASK_TABLE_FULL | EXDB_GRP_WRITE
EFPF_FP2 | ERROR_TITLE_OUT_OF_PLACE | EXDB_HOLD
EFPF_FP3 | ERROR_TOO_MANY_ARGS | EXDB_NO_DELETE
EFPF_FP4 | ERROR_TOO_MANY_LEVELS | EXDB_NO_EXECUTE
EFPF_FP5 | ERROR_UNLOCK_ERROR | EXDB_NO_READ
EFPF_FP6 | ERROR_UNMATCHED_QUOTES | EXDB_NO_WRITE
EFPF_FP7 | ERROR_UNSUPPORTED_HARDWARE | EXDB_OTR_DELETE
EIGHT_LPI | ERROR_WOULD_BLOCK | EXDB_OTR_EXECUTE
ELITE | ERROR_WRITE_PROTECTED | EXDB_OTR_READ
EmbossDisableRect | ERROR_WRONG_PACKET_RETURNED | EXDB_OTR_WRITE
EmbossDisableText | ESA_Dummy | EXDB_PURE
Emulate | ESA_Position | EXDB_SCRIPT
Enable | ESA_Underscore | EXDF_ARCHIVE
EndDMA | ESetInfoA | EXDF_DEFAULT
EndNotify | ESF_EVENSIZE | EXDF_GRP_DELETE
EndRefresh | ESF_INACTIVE | EXDF_GRP_EXECUTE
EndRequest | ESF_SCREEN | EXDF_GRP_READ
EndScreenNotify | ESF_TAGGED | EXDF_GRP_WRITE
EndUpdate | ET_FPRegisterMask | EXDF_HOLD
Enqueue | ET_FPRegisters | EXDF_NO_DELETE
EntryHandler | ET_MENUHELP | EXDF_NO_EXECUTE
EO_BADFORMAT | ET_MENUPICK | EXDF_NO_READ
EO_BIGCHANGE | ET_NoJIT | EXDF_NO_WRITE
EObtainInfoA | ET_Offset | EXDF_OTR_DELETE
EO_CLEAR | ET_RegisterA0 | EXDF_OTR_EXECUTE
EO_DELBACKWARD | ET_RegisterA1 | EXDF_OTR_READ
EO_DELFORWARD | ET_RegisterA2 | EXDF_OTR_WRITE
EO_ENTER | ET_RegisterA3 | EXDF_PURE
EO_INSERTCHAR | ET_RegisterA4 | EXDF_SCRIPT
EO_MOVECURSOR | ET_RegisterA5 | EX_DirLock
EO_NOOP | ET_RegisterA6 | EX_DirLockInput
EOpenEngine | ET_RegisterA7 | EX_DoCurrentDir
EO_REPLACECHAR | ET_RegisterD0 | EX_Dummy
EO_RESET | ET_RegisterD1 | exec
EO_SPECIAL | ET_RegisterD2 | ExecAllocMem
EO_UNDO | ET_RegisterD3 | ExecBase
EPSON | ET_RegisterD4 | ExecClone
EPSON_JX_80 | ET_RegisterD5 | ExecExpunge
EraseImage | ET_RegisterD6 | ExecFreeMem
EraseRect | ET_RegisterD7 | ExecInsert
EReleaseInfoA | ET_SaveParamRegs | ExecObtain
ERROR_ACTION_NOT_KNOWN | ET_SaveRegs | ExecRelease
ERROR_BAD_ACTION_ON_ITEM | ET_StackPtr | Execute
ERROR_BAD_ACTION_ON_MENU | ET_SuperState | EXF_ALL
ERROR_BAD_ACTION_ON_ROOT | EURO36_MONITOR_ID | EXF_COMMENT
ERROR_BAD_ACTION_ON_SEPARATOR | EURO72EHB_KEY | EXF_DATE
ERROR_BAD_HUNK | EURO72EHBLACE_KEY | EX_FileHandle
ERROR_BAD_NUMBER | EURO72EXTRAHALFBRITE_KEY | EX_FileHandleInput
ERROR_BAD_SIGNAL_BIT | EURO72EXTRAHALFBRITELACE_KEY | EX_FileLock
ERROR_BAD_STREAM_NAME | EURO72EXTRALORESDBL_KEY | EX_FileLockInput
ERROR_BAD_TEMPLATE | EURO72EXTRALORESDPF2_KEY | EXF_LINK
ERROR_BREAK | EURO72EXTRALORESDPF_KEY | EXF_NAME
ERROR_BROKEN_PIPE | EURO72EXTRALORESEHBDBL_KEY | EXF_OBJECTID
ERROR_BUFFER_OVERFLOW | EURO72EXTRALORESEHB_KEY | EXF_OWNER
ERROR_COMMENT_TOO_BIG | EURO72EXTRALORESEHBLACE_KEY | EXF_PROTECTION
ERROR_COMM_KEY_AT_TITLE_LEVEL | EURO72EXTRALORESHAMDBL_KEY | EXF_REFCOUNT
ERROR_CONTROL_STRING_TOO_LONG | EURO72EXTRALORESHAM_KEY | EXF_SIZE
ERROR_DELETE_PROTECTED | EURO72EXTRALORESHAMLACE_KEY | EXF_spare1
ERROR_DEVICE_NAME_MISSING | EURO72EXTRALORES_KEY | EXF_spare2
ERROR_DEVICE_NAME_TOO_LONG | EURO72EXTRALORESLACEDPF2_KEY | EXF_spare3
ERROR_DEVICE_NOT_MOUNTED | EURO72EXTRALORESLACEDPF_KEY | EXF_spare4
ERROR_DIRECTORY_NOT_EMPTY | EURO72EXTRALORESLACE_KEY | EXF_spare5
ERROR_DIR_NOT_FOUND | EURO72HAM_KEY | EXF_spare6
ERROR_DISK_FULL | EURO72HAMLACE_KEY | EXF_TYPE
ERROR_DISK_NOT_VALIDATED | EURO72LORESDBL_KEY | ExitHandler
ERROR_DISK_WRITE_PROTECTED | EURO72LORESDPF2_KEY | EX_LockInput
ERROR_EXEC_DEVICE_NAME_TOO_LONG | EURO72LORESDPF_KEY | EX_MatchFunc
ERROR_FILE_NOT_OBJECT | EURO72LORESEHBDBL_KEY | EX_MatchString
ERROR_HANDLER_CANNOT_BE_STARTED | EURO72LORESEHB_KEY | ExNext
ERROR_HANDLER_STRING_TOO_LONG | EURO72LORESEHBLACE_KEY | EX_ResetContext
ERROR_INVALID_COMPONENT_NAME | EURO72LORESHAMDBL_KEY | EX_StringName
ERROR_INVALID_DEVICE_NAME | EURO72LORESHAM_KEY | EX_StringNameInput
ERROR_INVALID_DEVICE_TYPE | EURO72LORESHAMLACE_KEY | EXT_ABS
ERROR_INVALID_GLOBAL_VECTOR | EURO72LORES_KEY | EXT_COMMON
ERROR_INVALID_LOCK | EURO72LORESLACEDPF2_KEY | EXT_DEF
ERROR_INVALID_NUMBER_OF_CYLINDERS | EURO72LORESLACEDPF_KEY | EXT_DEXT16
ERROR_INVALID_PACKET_MESSAGE | EURO72LORESLACE_KEY | EXT_DEXT32
ERROR_INVALID_RESIDENT_LIBRARY | EURO72_MONITOR_ID | EXT_DEXT8
ERROR_INVALID_SECTOR_SIZE | EURO72PRODUCTDBL_KEY | EXTENDED_MODE
ERROR_INVALID_TASK_PRIORITY | EURO72PRODUCTDPF2_KEY | ExtendFont
ERROR_IS_PIPE | EURO72PRODUCTDPF_KEY | ExtendFontTags
ERROR_IS_SOFT_LINK | EURO72PRODUCTEHBDBL_KEY | EXTEND_VSTRUCT
ERROR_ITEM_ID_IS_ZERO | EURO72PRODUCTHAMDBL_KEY | EXTMEMPOLICY_ACCESS
ERROR_ITEM_WITHOUT_ID | EURO72PRODUCTHAM_KEY | EXTMEMPOLICY_DELAYED
ERROR_KEY_NEEDS_ARG | EURO72PRODUCTHAMLACE_KEY | EXTMEMPOLICY_IMMEDIATE
ERROR_LINE_TOO_LONG | EURO72PRODUCT_KEY | ExtractColor
ERROR_LOCK_COLLISION | EURO72PRODUCTLACEDPF2_KEY | EXTRA_HALFBRITE
ERROR_LOCK_TIMEOUT | EURO72PRODUCTLACEDPF_KEY | EXTRAHALFBRITE_KEY
ERROR_NO_DEFAULT_DIR | EURO72PRODUCTLACE_KEY | EXTRAHALFBRITELACE_KEY
ERROR_NO_DISK | EURO_A0 | EXT_REF16
ERROR_NO_FREE_STORE | EURO_A1 | EXT_REF32
ERROR_NO_MORE_ENTRIES | EURO_A2 | EXT_REF8
ERROR_NOT_A_DOS_DISK | EURO_A3 | EXT_RES
ERROR_NOT_EXECUTABLE | EURO_A4 | EXT_SYMB
ERROR_NOT_IMPLEMENTED | EURO_A5 |
ERROR_OBJECT_EXISTS | EURO_A6 |

F

FANFOLD_PT | FOB_DODRAWMODE | FreeArgs
FattenLayerInfo | FOB_DOFRONTPEN | FreeAslRequest
Fault | FOB_DOSTYLE | FreeBitMap
FAULT_MAX | FOB_FILTERFUNC | FreeClass
FCH_ID | FOB_FIXEDWIDTHONLY | FreeClipRect
FClose | FOB_INTUIFUNC | FreeCmdPathList
FFlush | FOB_PRIVATEIDCMP | FreeCModeList
FGetC | FOF_DOBACKPEN | FreeColorMap
FGets | FOF_DODRAWMODE | FreeCopList
FH_BufferMode | FOF_DOFRONTPEN | FreeCprList
FH_BufferSize | FOF_DOSTYLE | FreeDBufInfo
FH_Dummy | FOF_FILTERFUNC | FreeDeviceProc
FH_EndStream | FOF_FIXEDWIDTHONLY | FreeDiskFileSystemData
FH_Locking | FOF_INTUIFUNC | FreeDiskObject
FH_UserBuffer | FOF_PRIVATEIDCMP | FreeDosEntry
FIBB_ARCHIVE | FontExtent | FreeDosObject
FIBB_DELETE | FOpen | FreeDTMethods
FIBB_EXECUTE | FOpenFromLock | FreeEntry
FIBB_GRP_DELETE | Forbid | FreeFileRequest
FIBB_GRP_EXECUTE | FOREGROUNDPEN | FreeFree
FIBB_GRP_READ | FORESHADOWPEN | FreeFreeList
FIBB_GRP_WRITE | FORESHINEPEN | FreeGBuffers
FIBB_OTR_DELETE | Format | FREEHORIZ
FIBB_OTR_EXECUTE | FORMAT_CDN | FreeIFF
FIBB_OTR_READ | FormatDate | FreeLocalItem
FIBB_OTR_WRITE | FORMAT_DEF | FreeNamedMemory
FIBB_PURE | FORMAT_DOS | FreeNamedObject
FIBB_READ | FORMAT_INT | FreePooled
FIBB_SCRIPT | FORMAT_ISO | FreeRaster
FIBB_WRITE | FORMAT_MAX | FreeRemember
FIBF_ARCHIVE | FormatPort | FreeScreenBuffer
FIBF_DELETE | FormatString | FreeScreenDrawInfo
FIBF_EXECUTE | FormatString32 | FreeSignal
FIBF_GRP_DELETE | FORMAT_USA | FreeSprite
FIBF_GRP_EXECUTE | FPB_DESIGNED | FreeSpriteData
FIBF_GRP_READ | FPB_DISKFONT | FreeSysObject
FIBF_GRP_WRITE | FPB_PROPORTIONAL | FreeSysRequest
FIBF_OTR_DELETE | FPB_REMOVED | FreeTagItems
FIBF_OTR_EXECUTE | FPB_REVPATH | FreeTrap
FIBF_OTR_READ | FPB_ROMFONT | FreeTTextAttr
FIBF_OTR_WRITE | FPB_TALLDOT | FreeVec
FIBF_PURE | FPB_WIDEDOT | FreeVecPooled
FIBF_READ | FPF_DESIGNED | FREEVERT
FIBF_SCRIPT | FPF_DISKFONT | FreeVPortCopLists
FIBF_WRITE | FPF_PROPORTIONAL | FRF_DOMULTISELECT
FIF_REMAPPABLE | FPF_REMOVED | FRF_DOPATTERNS
FIF_SCALABLE | FPF_REVPATH | FRF_DOSAVEMODE
FIF_SCROLLABLE | FPF_ROMFONT | FRF_DRAWERSONLY
FileHandle | FPF_TALLDOT | FRF_FILTERDRAWERS
FileHandleScan | FPF_WIDEDOT | FRF_FILTERFUNC
FileLock | FPutC | FRF_INTUIFUNC
FILENAME_SIZE | FPuts | FRF_PRIVATEIDCMP
FilePart | FRAME_BUTTON | FRF_REJECTICONS
FileSystemAttr | FRAMEBUTTON_3D | FROM_MONITOR
FILLALPHA | FRAMEBUTTON_FLAT | FRST_DOT
FILLFLATPEN | FRAMEBUTTON_FRAMED | FSA_ActivityFlushTimeoutR
FILLPEN | FRAME_DEFAULT | FSA_ActivityFlushTimeoutW
FillPixelArray | FRAMEDISCOL_BACKG | FSA_DOSTypeR
FILLRECTCLASS | FRAMEDISCOL_DISAB | FSA_Dummy
FILLSHADOWPEN | FRAMEDISCOL_FOREG | FSA_FileHandleInput
FILLSHINEPEN | FRAME_DISPLAY | FSA_FileLockInput
FILLTEXTPEN | FRAMEDISPLAY_3D | FSA_HasRecycledEntriesR
FilterTagChanges | FRAMEDISPLAY_FLAT | FSA_InactivityFlushTimeoutR
FilterTagItems | FRAMEDISPLAY_FRAMED | FSA_InactivityFlushTimeoutW
FindArg | FRAMEDISPLAY_FRAMED2 | FSA_LockInput
FindClass | FRAMEF_SPECIFY | FSA_MaxFileNameLengthR
FindCliProc | FRAMEICLASS | FSA_MaxFileNameLengthW
FindCollection | FRAME_ICONDROPBOX | FSA_MaxRecycledEntriesR
FindColor | FRAMEPRESSED_INVERTED | FSA_MaxRecycledEntriesW
FindDisplayInfo | FRAMEPRESSED_PUSHED | FSA_MsgPortInput
FindDosEntry | FRAMEPROP_3D | FSA_StringNameInput
FindIName | FRAME_PROPBORDER | FSA_VersionNumberR
FindLocalItem | FRAMEPROP_FLAT | FSA_VersionStringR
FindMenuKey | FRAMEPROP_FRAMED | FSA_VersionStringR_BufSize
FindMethod | FRAME_PROPKNOB | FSA_VersionStringR_Len
FindName | FRAMEPROP_NONE | FSB_ANTIALIASED
FindNamedMemory | FRAME_RIDGE | FSB_BOLD
FindNamedObject | FRAMESELCOL_BACKG | FSB_COLORFONT
FindNameNC | FRAMESELCOL_FILL | FSB_EXTENDED
FindPort | FRAMESELCOL_FOREG | FSB_ITALIC
FindProp | FRAMESELCOL_SELECT | FSB_TAGGED
FindPropContext | FRAMESTRING_3D | FSB_UNDERLINED
FindResident | FRAMESTRING_FLAT | FSF_ANTIALIASED
FindSegment | FRAMESTRING_FRAMED | FSF_BOLD
FindSegmentStackSize | FRAMESTRING_FRAMED2 | FSF_COLORFONT
FindSemaphore | FRAMETHIN_EDGESONLYRAISED | FSF_EXTENDED
FindSkipNode | FRAMETHIN_EDGESONLYRECESSED | FSF_ITALIC
FindSplayNode | FRAMETHIN_FILLEDRAISED | FSF_TAGGED
FindTagItem | FRAMETHIN_FILLEDRECESSED | FSF_UNDERLINED
FindTask | FRAMEWINDOW_3D | FS_NORMAL
FindToolNode | FRAMEWINDOW_FLAT | FSOF_ALTLINK
FindToolNodeA | FRAMEWINDOW_FRAMED | FSOF_LINK
FindToolType | FRB_DOMULTISELECT | FSO_TYPE_DIRECTORY
FindTrackable | FRB_DOPATTERNS | FSO_TYPE_FILE
FindTrackedAddress | FRB_DOSAVEMODE | FSO_TYPE_INVALID
FindTriggerMethod | FRB_DRAWERSONLY | FSO_TYPE_MASK
FindVar | FRB_FILTERDRAWERS | FSO_TYPE_PIPE
FINE | FRB_FILTERFUNC | FSO_TYPE_SOCKET
FixDateStamp | FRB_INTUIFUNC | FSO_TYPE_SOFTLINK
FLATBORDERPEN | FRB_PRIVATEIDCMP | FS_VECTORPORT_VERSION
Flood | FRB_REJECTICONS | FSVP
FLOYD_DITHERING | FRBUTTONCLASS | FULLMENUNUM
FlushVolume | FRead | FUTURESTR
FlushVolumePort | FReadLine | FWrite
FOB_DOBACKPEN | FreeAlloc |

G

GA_ActivateKey | GetInterface | GTYP_GADGETTYPE
GA_BackFill | GetLayerInfoAttrsA | GTYP_GTYPEMASK
GA_Border | GetLocaleStr | GTYP_GZZGADGET
GA_BottomBorder | GetMarkedBlock | GTYP_PROPGadget
GA_Bounds | GetMonitorDataTagList | GTYP_REQGADGET
GA_ContextMenu | GetMsg | GTYP_SCRGADGET
GACT_ACTIVEGADGET | GetNextSkipNode | GTYP_SDEPTH
GACT_ALTKEYMAP | GetOffScreenLayerBitMap | GTYP_SDOWNBACK
GACT_BOOLEXTEND | GetOutlinePen | GTYP_SDRAGGING
GACT_BORDERSNIFF | GetOwnerInfo | GTYP_SIZING
GACT_BOTTOMBORDER | GetPID | GTYP_STRGADGET
GACT_ENDGADGET | GetPred | GTYP_SUNUSED
GACT_FOLLOWMOUSE | GetPrefs | GTYP_SUPFRONT
GACT_IMMEDIATE | GetProcMsgPort | GTYP_SYSGADGET
GACT_LEFTBORDER | GetProcSegList | GTYP_SYSTYPEMASK
GACT_LONGINT | GetProgramDir | GTYP_TBARGADGET
GACT_RELVERIFY | GetRenderDomain | GTYP_WDEPTH
GACT_RIGHTBORDER | GetRGB32 | GTYP_WDOWNBACK
GACT_STRINGCENTER | GetRGB4 | GTYP_WDRAGGING
GACT_STRINGEXTEND | GetRPAttrs | GTYP_WUPFRONT
GACT_STRINGLEFT | GetRPAttrsA | GTYP_WZOOM
GACT_STRINGRIGHT | GetScreenAttr | GUIA_ArrowGadgetHeight
GACT_TOGGLESELECT | GetScreenAttrsA | GUIA_ArrowGadgetWidth
GACT_TOPBORDER | GetScreenData | GUIA_AutomaticEdgesContrast
GadgetBox | GetScreenDrawInfo | GUIA_BarBlockBrightContrast
GADGET_BOX | GetSegListInfo | GUIA_BarBlockBrightCurve
GADGETCLASS | GetSprite | GUIA_BarBlockDarkContrast
GADGETCOUNT | GetSucc | GUIA_BarBlockDarkCurve
GadgetMouse | GetSysTime | GUIA_BrightContrast
GADGETPEN | GetTagData | GUIA_BrightCurve
GA_Disabled | GetTail | GUIA_ClearBackground
GA_DoLayout | GetToolTypes | GUIA_ClickTabLook
GA_DrawInfo | GetUniqueID | GUIA_CycleLabelJustify
GA_Dummy | GetUpTime | GUIA_CycleLook
GA_EndGadget | GetVar | GUIA_DarkContrast
GA_FollowMouse | GetVPModeID | GUIA_DarkCurve
GA_GadgetHelp | GetWindowAttr | GUIA_DefaultDRIPens
GA_GadgetHelpText | GetWindowAttrsA | GUIA_DefaultGeometry
GA_GZZGadget | GEXTENT_ADD | GUIA_DefaultStyle
GA_Height | GEXTENT_INVERT | GUIA_DisabledBrightContrast
GA_Hidden | GEXTENT_REMOVE | GUIA_DisabledBrightCurve
GA_Highlight | GEXTENT_SECT | GUIA_DisabledDarkContrast
GA_HintInfo | GFLG_DISABLED | GUIA_DisabledDarkCurve
GA_ID | GFLG_EXTENDED | GUIA_DRIPens
GA_Image | GFLG_GADGBACKFILL | GUIA_Dummy
GA_Immediate | GFLG_GADGHBOX | GUIA_EvenRequesterButtons
GA_IntuiText | GFLG_GADGHCOMP | GUIA_FallbackTextAttr
GA_LabelImage | GFLG_GADGHIGHBITS | GUIA_FillBrightContrast
GA_Left | GFLG_GADGHIMAGE | GUIA_FillBrightCurve
GA_LeftBorder | GFLG_GADGHNONE | GUIA_FillDarkContrast
GA_Next | GFLG_GADGIMAGE | GUIA_FillDarkCurve
GA_NoFilterMenuKeys | GFLG_IMAGEDISABLE | GUIA_ForeBrightContrast
GA_NoFilterWheel | GFLG_LABELIMAGE | GUIA_ForeBrightCurve
GA_Previous | GFLG_LABELITEXT | GUIA_ForeDarkContrast
GA_ReadOnly | GFLG_LABELMASK | GUIA_ForeDarkCurve
GA_RelBottom | GFLG_LABELSTRING | GUIA_FrameAlphaStatus
GA_RelHeight | GFLG_RELBOTTOM | GUIA_FrameBackfill
GA_RelRight | GFLG_RELHEIGHT | GUIA_FrameButtonLook
GA_RelSpecial | GFLG_RELRIGHT | GUIA_FrameCornersType
GA_RelVerify | GFLG_RELSPECIAL | GUIA_FrameDisabledColors
GA_RelWidth | GFLG_RELWIDTH | GUIA_FrameDisBackfill
GA_RightBorder | GFLG_SELECTED | GUIA_FrameDisplayLook
GA_Selected | GFLG_STRINGEXTEND | GUIA_FrameForceThinEdges
GA_SelectRender | GFLG_TABCYCLE | GUIA_FramePressedLook
GA_SpecialInfo | GfxAssociate | GUIA_FramePropLook
GA_SysGadget | GFXB_AA_ALICE | GUIA_FrameSelBackfill
GA_SysGType | GFXB_AA_LISA | GUIA_FrameSelectedColor
GA_TabCycle | GFXB_AA_MLISA | GUIA_FrameStringLook
GA_Text | GfxBase | GUIA_GadgetArrowStyle
GA_TextAttr | GFXB_BIG_BLITS | GUIA_GadgetArrowType
GA_Titlebar | GFXB_HR_AGNUS | GUIA_GadgetCycleStyle
GA_ToggleSelect | GFXB_HR_DENISE | GUIA_GadgetCycleType
GA_Top | GfxClone | GUIA_GadgetGeometry
GA_TopBorder | GfxExpunge | GUIA_GadgetHorizPadding
GAUGE_BORDERPENS | GFXF_AA_ALICE | GUIA_GadgetStyle
GAUGE_CONT_3D | GFXF_AA_LISA | GUIA_GadgetTextAttr
GAUGE_CONT_AUTOSTYLE | GFXF_AA_MLISA | GUIA_GadgetVertPadding
GAUGE_CONT_BORDERLESS | GFXF_BIG_BLITS | GUIA_GaugeLook
GAUGE_CONT_FLAT | GFXF_HAVECOMPOSITE | GUIA_GlobalFlags
GAUGE_CONT_FRAMED | GFXF_HR_AGNUS | GUIA_GroupLabelLook
GAUGE_CONT_FRAMED2 | GFXF_HR_DENISE | GUIA_GroupLabelPlace
GAUGE_CONT_GRADIENT | GFXF_NEW_DATABASE | GUIA_GroupLabelTextAttr
GAUGE_CONT_STYLEMASK | GfxFree | GUIA_GroupLabelVertAlign
GAUGE_FILL_3D | GfxLookUp | GUIA_InactiveFillBrightContrast
GAUGE_FILL_AUTOSTYLE | GfxMove | GUIA_InactiveFillBrightCurve
GAUGE_FILL_BORDERLESS | GfxNew | GUIA_InactiveFillDarkContrast
GAUGE_FILL_FLAT | GfxObtain | GUIA_InactiveFillDarkCurve
GAUGE_FILL_FRAMED | GfxRelease | GUIA_LabelTextAttr
GAUGE_FILL_GRADIENT | GfxText | GUIA_LayoutHorizSpacing
GAUGE_FILL_STYLEMASK | GGF_BOUNDED | GUIA_LayoutVertSpacing
GAUGEIA_InnerTicks | GGF_CALCHSCROLLER | GUIA_ListHierConnectType
GAUGEIA_Level | GGF_CALCHSOVERLAP | GUIA_ListHierNodeStyle
GAUGEIA_Max | GGF_CALCVSCROLLER | GUIA_MenuBackfill
GAUGEIA_Min | GGF_CALCVSOVERLAP | GUIA_MenuBrightContrast
GAUGEIA_ScaleHook | GGF_INITIAL | GUIA_MenuBrightCurve
GAUGEIA_ShortTicks | GGPF_SCREENDRAGGING | GUIA_MenuCloseDelay
GAUGEIA_Ticks | GHKHANDLEIMAGE | GUIA_MenuDarkContrast
GAUGEIA_TickSize | GID_ANIMATION | GUIA_MenuDarkCurve
GAUGE_INNERTICKS | GID_DOCUMENT | GUIA_MenuDropShadows
GAUGE_RESERVED | GID_INSTRUMENT | GUIA_MenuFlags
GAUGE_SPACINGMASK | GID_MOVIE | GUIA_MenuOpenDelay
GAUGE_UNUSED | GID_MUSIC | GUIA_MenuRenderHook
GA_Underscore | GID_PICTURE | GUIA_MenuSelItemFrame
GA_UserData | GID_SOUND | GUIA_MenuStyle
GA_UserInput | GID_SYSTEM | GUIA_MenuTransparency
GA_Width | GID_TEXT | GUIA_MenuTransparencyLevel
GBD_BoardDriver | GLEFTIMAGE | GUIA_MenuType
GBD_BoardName | GLYPHFILLPEN | GUIA_OffScreenDragging
GBD_BOX | GLYPHPEN | GUIA_OffScreenResistance
GBD_ChipDriver | GMAF_REPORT_CR | GUIA_OffScreenSizing
GBD_FreeMemory | GMD_BasicAudio | GUIA_PaletteLockTable
GBD_GINFO | GMD_DisplayHeight | GUIA_PaletteRGBTable
GBD_InternalMemorySize | GMD_DisplayWidth | GUIA_PropBackfill
GBD_LargestFreeMemory | GMD_DotClockMax | GUIA_PropBackground
GBD_PCIProductID | GMD_DotClockMin | GUIA_PropBorder
GBD_PCIVendorID | GMD_EDIDRevision | GUIA_PropKnobBackfill
GBD_RECTANGLE | GMD_EDIDVersion | GUIA_PropKnobColor
GBD_TagBase | GMD_HSyncMax | GUIA_PropKnobHandle
GBD_TotalMemory | GMD_HSyncMin | GUIA_PropKnobHighlight
GBD_WINDOW | GMD_InputType | GUIA_PropOuterSpacing
GBF_BOUNDS | GM_DOMAIN | GUIA_PropSelKnobBackfill
GBF_MAKERECT | GMD_Product | GUIA_PropSpacing
GCB_OK | GMD_ProductID | GUIA_RealShading
GCB_UNKNOWN | GMD_TagBase | GUIA_RequesterBackfill
GCIT_CacheLineSize | GM_Dummy | GUIA_RequestersPosition
GCIT_CPUPageSize | GMD_VendorID | GUIA_Reserved1
GCIT_ExecPageSize | GMD_VSyncMax | GUIA_Reserved2
GCIT_Extensions | GMD_VSyncMin | GUIA_Reserved3
GCIT_Family | GM_EXTENT | GUIA_Reserved4
GCIT_FrontsideSpeed | GM_GOACTIVE | GUIA_Reserved5
GCIT_L1CacheSize | GM_GOINACTIVE | GUIA_ScreenBarBackfill
GCIT_L2CacheSize | GM_HANDLEINPUT | GUIA_ScreenBarGadgetSize
GCIT_L3CacheSize | GM_HANDLESCROLL | GUIA_ScreenBarPadding
GCIT_Model | GM_HELPTEST | GUIA_ScreenBarShadowColor
GCIT_ModelString | GM_HITTEST | GUIA_ScreenBarShadowDisplacement
GCIT_NumberOfCPUs | GM_KEYGOACTIVE | GUIA_ScreenBarShadowSmoothness
GCIT_ProcessorSpeed | GM_KEYGOINACTIVE | GUIA_ScreenBarShadowStrength
GCIT_TimeBaseSpeed | GM_KEYTEST | GUIA_ScreenDragging
GCIT_VectorUnit | GM_LAYOUT | GUIA_ScreenTitlePosition
GCIT_Version | GM_MENUHELP | GUIA_SelectBrightContrast
GCIT_VersionString | GM_MENUPICK | GUIA_SelectBrightCurve
GCTRL_Get31KHzScanRate | GMORE_BOUNDS | GUIA_SelectDarkContrast
GCTRL_GetDisableAmigaBlitter | GMORE_GADGETHELP | GUIA_SelectDarkCurve
GCTRL_GetForceSWComposite | GMORE_HIDDEN | GUIA_ShareComposeBitMap
GCTRL_GetPlanesToFast | GMORE_NOCMENUOFFLOAD | GUIA_SizeGadgetHeight
GCTRL_GetUseAltiVec | GMORE_NOFILTERMENUKEYS | GUIA_SizeGadgetWidth
GCTRL_GetUseDMA | GMORE_NOFILTERWHEEL | GUIA_SliderDisplayMode
GCTRL_Set31KHzScanRate | GMORE_PRIVATE | GUIA_SpecialEffects
GCTRL_SetDisableAmigaBlitter | GMORE_PRIVATE2 | GUIA_SysIGeometryType
GCTRL_SetForceSWComposite | GMORE_SCROLLRASTER | GUIA_SysImageFrameType
GCTRL_SetPlanesToFast | GM_POSTRENDER | GUIA_SysImageSymbolType
GCTRL_SetUseAltiVec | GM_PRERENDER | GUIA_TabActiveBackfill
GCTRL_SetUseDMA | GMQ_CONTEXTMENU | GUIA_TabInactiveBackfill
GDI_Dummy | GMQ_HINTINFO | GUIA_TabTitleBackfill
GDI_FileHandleInput | GM_QUERY | GUIA_VSyncCompose
GDI_FileLockInput | GMQ_WHICHMEMBER | GUIA_WindowAlpha
GDI_InfoData | GMR_CLIPDONE | GUIA_WindowBackfill
GDI_LockInput | GM_RENDER | GUIA_WindowBarBackfill
GDI_MsgPortInput | GMR_FULLBBOX | GUIA_WindowBarFrameThickness
GDI_StringNameInput | GMR_FULLHBOX | GUIA_WindowBarGadgetSize
GDI_VolumeRequired | GMR_GADGETHIT | GUIA_WindowBarInactBackfill
GDOMAIN_MAXIMUM | GMR_HELPCODE | GUIA_WindowBarPadding
GDOMAIN_MINIMUM | GMR_HELPHIT | GUIA_WindowBorderBackfill
GDOMAIN_NOMINAL | GMR_INVALID | GUIA_WindowBorderBottom
GDOWNIMAGE | GMR_KEYACTIVATE | GUIA_WindowBorderInactBackfill
GELGONE | GMR_KEYACTIVE | GUIA_WindowBorderLeft
GENLOC | GMR_KEYVERIFY | GUIA_WindowBorderLook
GENLOCK_AUDIO | GMR_MASKDONE | GUIA_WindowBorderRight
GENLOCK_VIDEO | GMR_MEACTIVE | GUIA_WindowBorderStyle
GetAPen | GMR_NEXTACTIVE | GUIA_WindowBorderTop
GetArgStr | GMR_NOHELPHIT | GUIA_WindowCloseFadeTime
GetAttr | GMR_NOREUSE | GUIA_WindowDragAlpha
GetAttrsA | GMR_PREVACTIVE | GUIA_WindowFrameThickness
GetBackFillHookAttrsA | GMR_REUSE | GUIA_WindowGadgetFrameStyle
GetBitMapAttr | GMR_VERIFY | GUIA_WindowGadgetGeometry
GetBoardBytesPerRow | GoodID | GUIA_WindowGadgetStyle
GetBoardDataTagList | GoodType | GUIA_WindowGaugeLook
GetBPen | GPEF_ALLOWSUPER | GUIA_WindowGoActiveFadeTime
GetCatalogStr | GPID_PARENT | GUIA_WindowGoInactiveFadeTime
GetCC | GPID_PROCESS | GUIA_WindowInactAlpha
GetCliCurrentDirName | GPSLF_CLI | GUIA_WindowInnerFlatThickness
GetCliProgramName | GPSLF_ENT | GUIA_WindowOpenFadeTime
GetCliPrompt | GPSLF_RUN | GUIA_WindowOuterFlatThickness
GetColorMap | GPSLF_SEG | GUIA_WindowPropBackfill
GetConSnip | GRADMODE_COLOR | GUIA_WindowPropBackground
GetConsolePort | GRADMODE_IMPOSE | GUIA_WindowPropBorder
GetCPUInfo | GRADMODE_INVERT1 | GUIA_WindowPropInactBackfill
GetCurrentDir | GRADMODE_INVERT2 | GUIA_WindowPropInactKnobBackfill
GetCyberIDAttr | GRADMODE_KEEPRATIO | GUIA_WindowPropKnobBackfill
GetCyberMapAttr | GRADMODE_NONE | GUIA_WindowPropKnobColor
GetDefaultPubScreen | GRADMODE_PALETTE | GUIA_WindowPropKnobHandle
GetDefDiskObject | GRADMODE_SHADE | GUIA_WindowPropKnobHighlight
GetDefPrefs | GRADMODE_SIMPLE | GUIA_WindowPropLook
GetDeviceProc | GRADMODE_TYPEMASK | GUIA_WindowPropSelKnobBackfill
GetDeviceProcFlags | GraphicsControlTagList | GUIA_WindowPropSpacing
GetDiskFileSystemData | GRAPHICSNAME | GUIA_WindowRefresh
GetDiskFontCtrl | GREDRAW_REDRAW | GUIA_WindowReserved
GetDiskInfo | GREDRAW_TOGGLE | GUIA_WindowShadowColor
GetDiskObject | GREDRAW_UPDATE | GUIA_WindowShadowDisplacement
GetDiskObjectNew | GREY_SCALE2 | GUIA_WindowShadowSizes
GetDisplayInfoData | GRIGHTIMAGE | GUIA_WindowShadowSmoothness
GetDMAList | GROUPGCLASS | GUIA_WindowShadowStrength
GetDrMd | GSLI_68KFileSize | GUIA_WindowShadowType
GetDTAttrs | GSLI_68KFileXsum | GUIA_WindowSizeBorder
GetDTAttrsA | GSLI_68KHUNK | GUIA_WindowTitlePosition
GetDTMethods | GSLI_68KOVLAY | GUPIMAGE
GetDTString | GSLI_68KPS | GVB_BINARY_VAR
GetDTTriggerMethodDataFlags | GSLI_Data | GVB_DONT_NULL_TERM
GetDTTriggerMethods | GSLI_Dummy | GVB_GLOBAL_ONLY
GetEntryData | GSLI_ElfHandle | GVB_LOCAL_ONLY
GetExitData | GSLI_HeaderSize | GVB_SAVE_VAR
GetExtSprite | GSLI_NATIVE | GVB_SCAN_ENVARC
GetExtSpriteA | GSLI_ResidentStruct | GVB_SCAN_LEVEL
GetFilePosition | GSLI_ResidentVersionString | GVB_SCAN_STARTDIR
GetFileSize | GSLI_SegmentSize | GVB_SCAN_TOPLEVEL
GetFileSysPort | GSLI_VersionString | GVF_BINARY_VAR
GetFileSystemVectorPort | GSTAG_ATTACHED | GVF_DONT_NULL_TERM
GetFirstSkipNode | GSTAG_SCANDOUBLED | GVF_GLOBAL_ONLY
GetGBuffers | GSTAG_SOFTSPRITE | GVF_LOCAL_ONLY
GetGUIAttrsA | GSTAG_SPRITE_NUM | GVF_SAVE_VAR
GetHalfPens | GTYP_BOOLGADGET | GVF_SCAN_ENVARC
GetHead | GTYP_CLOSE | GVF_SCAN_LEVEL
GetIconRectangleA | GTYP_CUSTOMGADGET | GVF_SCAN_STARTDIR
GetIconTagList | GTYP_GADGET0002 | GVKHANDLEIMAGE

H

HALFSHADOWPEN | HIRES | HUNK_BSS
HALFSHINEPEN | HIRESDPF2_KEY | HUNK_CODE
HALFTONE_DITHERING | HIRESDPF_KEY | HUNK_DATA
HAM | HIRESEHB_KEY | HUNK_DEBUG
HAM_KEY | HIRESEHBLACE_KEY | HUNK_DREL16
HAMLACE_KEY | HIRESGADGET | HUNK_DREL32
HARDHYPHEN | HIRESHAM_KEY | HUNK_DREL8
HC_GADGETHELP | HIRESHAMLACE_KEY | HUNK_END
HelpControl | HIRESHAMSDBL_KEY | HUNK_EXT
HexToLong | HIRES_KEY | HUNK_HEADER
HideLayer | HIRESLACEDPF2_KEY | HUNK_INDEX
HideWindow | HIRESLACEDPF_KEY | HUNK_LIB
HIGHBOX | HIRESLACE_KEY | HUNK_NAME
HIGHCOMP | HIRESPICK | HUNK_OVERLAY
HIGHFLAGS | HKHANDLEIMAGE | HUNK_RELOC16
HIGHIMAGE | HOLDNMODIFY | HUNK_RELOC32
HIGHITEM | HP_LASERJET | HUNK_RELOC8
HIGHLIGHTTEXTPEN | HP_LASERJET_PLUS | HUNK_SYMBOL
HIGHNONE | HUNK_BREAK | HUNK_UNIT

I

IA_ActivateKey | IDCMP_EXTENDEDKEYBOARD | IFFParseBase
IA_APatSize | IDCMP_EXTENDEDMOUSE | IFFParseClone
IA_APattern | IDCMP_GADGETDOWN | IFFParseExpunge
IA_BackFill | IDCMP_GADGETHELP | IFFPARSENAME
IA_BGPen | IDCMP_GADGETUP | IFFParseObtain
IA_Data | IDCMP_IDCMPUPDATE | IFFPARSE_RAWSTEP
IA_DisabledBackFill | IDCMP_INACTIVEWINDOW | IFFParseRelease
IA_DoubleEmboss | IDCMP_INTUITICKS | IFFPARSE_SCAN
IA_Dummy | IDCMP_LONELYMESSAGE | IFFPARSE_STEP
IA_EdgesOnly | IDCMP_MENUHELP | IFF_RETURN2CLIENT
IA_EraseBackground | IDCMP_MENUPICK | IFFSIZE_UNKNOWN
IA_FGPen | IDCMP_MENUVERIFY | IFFSLI_PROP
IA_Font | IDCMP_MOUSEBUTTONS | IFFSLI_ROOT
IA_FrameType | IDCMP_MOUSEMOVE | IFFSLI_TOP
IA_Height | IDCMP_MOUSEOBJECT | IFLF_CHANGED
IA_HighlightPen | IDCMP_NEWPREFS | IFLF_CLONED
IA_InactiveBackFill | IDCMP_NEWSIZE | IFLF_CLONE_EXPUNGE
IA_InBorder | IDCMP_RAWKEY | IFLF_NONE
IA_Justification | IDCMP_REFRESHWINDOW | IFLF_NOT_NATIVE
IA_Label | IDCMP_REQCLEAR | IFLF_PRIVATE
IA_LabelPen | IDCMP_REQSET | IFLF_PROTECTED
IA_Left | IDCMP_REQVERIFY | IFLF_UNMODIFIED
IA_LineWidth | IDCMP_RESERVED1 | IGF_BRCORN
IA_Mode | IDCMP_RESERVED2 | IGF_HORIZARROW
IA_Orientation | IDCMP_SIZEVERIFY | IGF_KEEPHEIGHT
IA_Outline | IDCMP_VANILLAKEY | IGF_KEEPLEFT
IA_Pens | IDCMP_WBENCHMESSAGE | IGF_KEEPTOP
IA_Precision | ID_CODE | IGF_KEEPWIDTH
IA_Recessed | ID_COLLECT_FILEHANDLE | IGF_SBARLEFT
IA_Resolution | ID_COLLECT_LOCK | IGF_SBARRIGHT
IA_Scalable | ID_COLLECT_NOTIFICATION | IGF_VERTARROW
IA_Screen | ID_CON | IGF_WBARLEFT
IA_SelectedBackFill | ID_CRNG | IGF_WBARRIGHT
IA_ShadowPen | ID_DEST | IGfx
IA_Simple | ID_DLTA | IGNORE_DIMENSIONS
IASL | ID_DOS_DISK | IGNORE_MCOMPAT
IA_SupportsDisable | ID_DTHD | IIcon
IA_Top | ID_DTYP | IIFFParse
IA_Underscore | ID_EXFAT_DISK | IIntuition
IA_Width | ID_EXT2_DISK | IJ_CENTER
ICA_Dummy | ID_FASTDIR_DOS_DISK | IJ_LEFT
ICA_MAP | ID_FASTDIR_FFS_DISK | IJ_RIGHT
ICA_TARGET | ID_FAT00_DISK | IKeymap
ICCLASS | ID_FAT01_DISK | ILayers
IceColdReboot | ID_FAT32_DISK | ILocale
ICM_CHECKLOOP | ID_FFS_DISK | IMAGECLASS
ICM_CLEARLOOP | ID_FORM | IMAGE_NEGATIVE
ICM_Dummy | ID_FTXT | IMAGE_POSITIVE
ICM_SETLOOP | ID_GRAB | IM_BGPEN
ICoerceMethodA | ID_HFS_DISK | IM_BOX
icon | ID_ILBM | IM_DOMAINFRAME
ICONA_Dummy | ID_INTER_DOS_DISK | IM_DRAW
ICONA_ErrorCode | ID_INTER_FFS_DISK | IM_DRAWFRAME
ICONA_ErrorTagItem | IDiskfont | IM_ERASE
ICONA_LAST_TAG | ID_KICKSTART_DISK | IM_ERASEFRAME
ICONA_Reserved1 | ID_LIST | IM_EXTENT
ICONA_Reserved10 | ID_LONGNAME_DOS_DISK | IM_EXTENTFRAME
ICONA_Reserved11 | ID_LONGNAME_FFS_DISK | IM_FGPEN
ICONA_Reserved12 | ID_MSDOS_DISK | IM_FRAMEBOX
ICONA_Reserved13 | ID_MSDOS_DISK_DS | IM_HITFRAME
ICONA_Reserved2 | ID_MSDOS_DISK_HD | IM_HITTEST
ICONA_Reserved3 | ID_NAME | IM_MOVE
ICONA_Reserved4 | ID_NGFS_DISK | IMPF_ALLOWSUPER
ICONA_Reserved5 | ID_NO_DISK_PRESENT | IMR_CLIPDONE
ICONA_Reserved6 | ID_NOT_REALLY_DOS | IMR_INVALID
ICONA_Reserved7 | ID_NTFS_DISK | IMR_MASKDONE
ICONA_Reserved8 | ID_NULL | IMSGCODE_INTUIRAWKEYDATA
ICONA_Reserved9 | IDOMAIN_MAXIMUM | IMSGCODE_INTUIWHEELDATA
ICON_ASPECT_RATIO_UNKNOWN | IDOMAIN_MINIMUM | IMSPEC_EXTERNAL_PREFIX
IconBase | IDOMAIN_NOMINAL | IMTAG_Dummy
IconClone | IDoMethodA | IMTAG_MenuContext
IconControlA | IDoSuperMethodA | IMTAG_MenuType
ICONCTRLA_AddScaledSize | ID_PROP | IMT_CONTEXT_GADGET_APP
ICONCTRLA_GetAspectRatio | ID_RAWCON | IMT_CONTEXT_GADGET_OBJ
ICONCTRLA_GetBitMap1 | IDS_BUSY | IMT_CONTEXT_WINDOW
ICONCTRLA_GetBitMap2 | IDS_DISABLED | IMT_DEFAULT
ICONCTRLA_GetFrameless | IDSF_DISABLED | IMui
ICONCTRLA_GetGlobalColorIconSupport | IDSF_DISABLEDMASK | INACTIVEFILLFLATPEN
ICONCTRLA_GetGlobalEmbossRect | IDSF_ERASEMASK | INACTIVEFILLPEN
ICONCTRLA_GetGlobalFrameless | IDSF_INACTIVENORMAL | INACTIVEFILLSHADOWPEN
ICONCTRLA_GetGlobalIdentifyHook | IDSF_INACTIVESELECTED | INACTIVEFILLSHINEPEN
ICONCTRLA_GetGlobalLeftOutMarking | IDSF_MASK | INACTIVEFILLTEXTPEN
ICONCTRLA_GetGlobalMaxNameLength | IDSF_NORMAL | INACTIVEGLYPHPEN
ICONCTRLA_GetGlobalNewIconsSupport | IDSF_SELDISABLEDMASK | Info
ICONCTRLA_GetGlobalPrecision | IDSF_SELECTED | Inhibit
ICONCTRLA_GetGlobalScreen | IDSF_SELECTEDDISABLED | InhibitPort
ICONCTRLA_GetGlobalSelectEffect | IDS_INACTIVEDISABLED | InitAnimate
ICONCTRLA_GetHeight | IDS_INACTIVENORMAL | InitArea
ICONCTRLA_GetIconFileFormat | IDS_INACTIVESELECTED | InitBitMap
ICONCTRLA_GetIconModuleData | IDS_INDETERMINANT | InitCode
ICONCTRLA_GetImageData1 | IDS_INDETERMINATE | InitData
ICONCTRLA_GetImageData2 | IDS_NORMAL | InitGels
ICONCTRLA_GetImageDataFormat | ID_SPRT | InitGMasks
ICONCTRLA_GetImageMask1 | IDS_SELECTED | InitIFF
ICONCTRLA_GetImageMask2 | IDS_SELECTEDDISABLED | InitIFFasClip
ICONCTRLA_GetNewIconsSupport | ID_SWAP_DISK | InitIFFasDOS
ICONCTRLA_GetPalette1 | ID_TAGS | InitLayers
ICONCTRLA_GetPalette2 | ID_TOOL | InitMasks
ICONCTRLA_GetPaletteSize1 | IDtoStr | InitRastPort
ICONCTRLA_GetPaletteSize2 | ID_UNREADABLE_DISK | InitRequester
ICONCTRLA_GetScreen | ID_VALIDATED | InitResident
ICONCTRLA_GetTransparentColor1 | ID_VALIDATING | InitSemaphore
ICONCTRLA_GetTransparentColor2 | ID_VHDR | InitStruct
ICONCTRLA_GetWidth | ID_VP255_DOS_DISK | InitTmpRas
ICONCTRLA_HasRealImage2 | ID_WRITE_PROTECTED | InitView
ICONCTRLA_IsNativeIcon | IECLASS_ACTIVEWINDOW | InitVPort
ICONCTRLA_IsNewIcon | IECLASS_CHANGEWINDOW | inputevent
ICONCTRLA_IsPaletteMapped | IECLASS_CLOSEWINDOW | INPUTTYPE_DVI
ICONCTRLA_RemScaledSize | IECLASS_DISKINSERTED | INPUTTYPE_VGA
ICONCTRLA_SetAspectRatio | IECLASS_DISKREMOVED | INSERTNODE_DUPLICATE_KEY
ICONCTRLA_SetFrameless | IECLASS_EVENT | INSERTNODE_OUT_OF_MEMORY
ICONCTRLA_SetGlobalColorIconSupport | IECLASS_EXTENDEDRAWKEY | INSERTNODE_TOO_SHORT
ICONCTRLA_SetGlobalEmbossRect | IECLASS_GADGETDOWN | InsertSkipNode
ICONCTRLA_SetGlobalFrameless | IECLASS_GADGETUP | InsertSplayNode
ICONCTRLA_SetGlobalIdentifyHook | IECLASS_INACTIVEWINDOW | InstallClipRegion
ICONCTRLA_SetGlobalLeftOutMarking | IECLASS_MAX | InstallLayerHook
ICONCTRLA_SetGlobalMaxNameLength | IECLASS_MENUHELP | InstallLayerInfoHook
ICONCTRLA_SetGlobalNewIconsSupport | IECLASS_MENULIST | INST_DATA
ICONCTRLA_SetGlobalPrecision | IECLASS_MOUSEWHEEL | INTB_NMI
ICONCTRLA_SetGlobalScreen | IECLASS_NEWPOINTERPOS | INTEGER_SCALING
ICONCTRLA_SetGlobalSelectEffect | IECLASS_NEWPREFS | INTERLACE
ICONCTRLA_SetHeight | IECLASS_NULL | INTF_NMI
ICONCTRLA_SetIconModuleData | IECLASS_POINTERPOS | INTUIRAWKEYDATA_VERSION
ICONCTRLA_SetImageData1 | IECLASS_RAWKEY | IntuiTextExtent
ICONCTRLA_SetImageData2 | IECLASS_RAWMOUSE | IntuiTextLength
ICONCTRLA_SetImageDataFormat | IECLASS_REFRESHWINDOW | intuition
ICONCTRLA_SetNewIconsSupport | IECLASS_REQUESTER | Intuition_
ICONCTRLA_SetPalette1 | IECLASS_RESERVED | IntuitionBase
ICONCTRLA_SetPalette2 | IECLASS_SIZEWINDOW | IntuitionClone
ICONCTRLA_SetPaletteSize1 | IECLASS_TIMER | IntuitionControlA
ICONCTRLA_SetPaletteSize2 | IECODE_4TH_BUTTON | IntuitionExpunge
ICONCTRLA_SetTransparentColor1 | IECODE_5TH_BUTTON | INTUITIONNAME
ICONCTRLA_SetTransparentColor2 | IECODE_ASCII_DEL | IntuitionObtain
ICONCTRLA_SetWidth | IECODE_ASCII_FIRST | IntuitionRelease
ICONCTRLA_UseFriendBitMap | IECODE_ASCII_LAST | INTUIWHEELDATA_VERSION
ICON_DRAGGED | IECODE_C0_FIRST | INVALID_ID
ICONDRAWA_AllowUpscaling | IECODE_C0_LAST | INVERSVID
ICONDRAWA_Borderless | IECODE_C1_FIRST | InvertPixelArray
ICONDRAWA_Borders | IECODE_C1_LAST | IOB_QUICK
ICONDRAWA_DrawIcon | IECODE_COMM_CODE_FIRST | IoErr
ICONDRAWA_DrawInfo | IECODE_COMM_CODE_LAST | IOERR_ABORTED
ICONDRAWA_EraseBackground | IECODE_KEY_CODE_FIRST | IOERR_BADADDRESS
ICONDRAWA_EraseLabelBackground | IECODE_KEY_CODE_LAST | IOERR_BADLENGTH
ICONDRAWA_Frameless | IECODE_LATIN1_FIRST | IOERR_NOCMD
ICONDRAWA_Height | IECODE_LATIN1_LAST | IOERR_OPENFAIL
ICONDRAWA_IsLink | IECODE_LBUTTON | IOERR_SELFTEST
ICONDRAWA_LabelOutline | IECODE_MBUTTON | IOERR_SUCCESS
ICONDRAWA_LabelShadow | IECODE_NEWACTIVE | IOERR_UNITBUSY
ICONDRAWA_Properties | IECODE_NEWSIZE | IOF_QUICK
ICONDRAWA_SizeBounds | IECODE_NOBUTTON | IOSERB_ABORT
ICONDRAWA_Transparency | IECODE_RBUTTON | IOSERB_ACTIVE
ICONDRAWA_Width | IECODE_REFRESH | IOSERB_BUFRREAD
ICON_DROPPABLE | IECODE_REQCLEAR | IOSERB_QUEUED
ICONDUPA_ActivateImageData | IECODE_REQSET | IOSERF_ABORT
ICONDUPA_AllowUpscaling | IECODE_UP_PREFIX | IOSERF_ACTIVE
ICONDUPA_DuplicateDefaultTool | IEQUALIFIERB_CAPSLOCK | IOSERF_BUFRREAD
ICONDUPA_DuplicateDrawerData | IEQUALIFIERB_CONTROL | IOSERF_QUEUED
ICONDUPA_DuplicateImageData | IEQUALIFIERB_INTERRUPT | IO_STATB_OVERRUN
ICONDUPA_DuplicateImages | IEQUALIFIERB_LALT | IO_STATB_READBREAK
ICONDUPA_DuplicateScaledSizes | IEQUALIFIERB_LCOMMAND | IO_STATB_WROTEBREAK
ICONDUPA_DuplicateToolTypes | IEQUALIFIERB_LEFTBUTTON | IO_STATB_XOFFREAD
ICONDUPA_DuplicateToolWindow | IEQUALIFIERB_LSHIFT | IO_STATB_XOFFWRITE
ICONDUPA_ForceScaling | IEQUALIFIERB_MIDBUTTON | IO_STATF_OVERRUN
ICONDUPA_Height | IEQUALIFIERB_MULTIBROADCAST | IO_STATF_READBREAK
ICONDUPA_SizeBounds | IEQUALIFIERB_NUMERICPAD | IO_STATF_WROTEBREAK
ICONDUPA_UseFriendBitMap | IEQUALIFIERB_RALT | IO_STATF_XOFFREAD
ICONDUPA_Width | IEQUALIFIERB_RBUTTON | IO_STATF_XOFFWRITE
IconExpunge | IEQUALIFIERB_RCOMMAND | IOSTB_OVERRUN
ICONGETA_AllowUpscaling | IEQUALIFIERB_RELATIVEMOUSE | IOSTB_READBREAK
ICONGETA_FailIfUnavailable | IEQUALIFIERB_REPEAT | IOSTB_WROTEBREAK
ICONGETA_FileFormat | IEQUALIFIERB_RSHIFT | IOSTB_XOFFREAD
ICONGETA_ForceScaling | IEQUALIFIER_CAPSLOCK | IOSTB_XOFFWRITE
ICONGETA_GenerateImageMasks | IEQUALIFIER_CONTROL | IOSTF_OVERRUN
ICONGETA_GetDefaultName | IEQUALIFIER_INTERRUPT | IOSTF_READBREAK
ICONGETA_GetDefaultType | IEQUALIFIER_LALT | IOSTF_WROTEBREAK
ICONGETA_GetPaletteMappedIcon | IEQUALIFIER_LCOMMAND | IOSTF_XOFFREAD
ICONGETA_Height | IEQUALIFIER_LEFTBUTTON | IOSTF_XOFFWRITE
ICONGETA_IdentifyBuffer | IEQUALIFIER_LSHIFT | IP96
ICONGETA_IdentifyOnly | IEQUALIFIER_MIDBUTTON | IsAlNum
ICONGETA_IsDefaultIcon | IEQUALIFIER_MULTIBROADCAST | IsAlpha
ICONGETA_Label | IEQUALIFIER_NUMERICPAD | IsBlank
ICONGETA_RemapIcon | IEQUALIFIER_RALT | IsCntrl
ICONGETA_Screen | IEQUALIFIER_RBUTTON | IsCyberModeID
ICONGETA_SizeBounds | IEQUALIFIER_RCOMMAND | IsDigit
ICONGETA_UseFriendBitMap | IEQUALIFIER_RELATIVEMOUSE | ISDRAWN
ICONGETA_Width | IEQUALIFIER_REPEAT | ISetSuperAttrsA
ICONIFYIMAGE | IEQUALIFIER_RSHIFT | IsFileSystem
ICON_LEFTOUT | IESUBCLASS_AMIGA_RAWKEY | IsFileSystemPort
ICONNAME | IESUBCLASS_COMPATIBLE | IsGraph
ICON_POINTED | IESUBCLASS_HID_CONSUMER_DOWN_RAWKEY | ISGRTRX
ICONPUTA_DropChunkyIconImage | IESUBCLASS_HID_CONSUMER_UP_RAWKEY | ISGRTRY
ICONPUTA_DropNewIconToolTypes | IESUBCLASS_PIXEL | IsInteractive
ICONPUTA_DropPlanarIconImage | IESUBCLASS_SET1_RAWKEY | ISLESSX
ICONPUTA_FileFormat | IESUBCLASS_TABLET | ISLESSY
ICONPUTA_NoFallback | IEXTENT_ADD | IsListEmpty
ICONPUTA_NotifyWorkbench | IEXTENT_INVERT | IsLower
ICONPUTA_OnlyUpdatePosition | IEXTENT_REMOVE | ISMACTION_Ignore
ICONPUTA_OptimizeImageSpace | IEXTENT_SECT | ISMACTION_Select
ICONPUTA_PreserveOldIconImages | IFFCMD_CLEANUP | ISMACTION_Stop
ICONPUTA_PutDefaultName | IFFCMD_ENTRY | ISMACTION_Unselect
ICONPUTA_PutDefaultType | IFFCMD_EXIT | IsMinListEmpty
IconRelease | IFFCMD_INIT | IsMsgPortEmpty
IConsoleDevice | IFFCMD_PURGELCI | IsNative
IcontObtain | IFFCMD_READ | IsPrint
ICSPECIAL_CODE | IFFCMD_SEEK | IsPunct
ICTARGET_IDCMP | IFFCMD_WRITE | IsSpace
ICTRL_Dummy | IFFERR_EOC | IsUpper
ICyberGfx | IFFERR_EOF | IsXDigit
ID_8SVX | IFFERR_MANGLED | ItemAddress
ID_ANHD | IFFERR_NOHOOK | ITEMENABLED
ID_ANIM | IFFERR_NOMEM | ITEM_EQUAL
IDataTypes | IFFERR_NOSCOPE | ITEM_ERROR
ID_BMHD | IFFERR_NOTIFF | ITEMGC_AFTERCOUNT
ID_BODY | IFFERR_READ | ITEMGC_NONE
ID_BOX0_DISK | IFFERR_SEEK | ITEM_NOTHING
ID_BUSY_DISK | IFFERR_SYNTAX | ITEMNUM
ID_CAMG | IFFERR_WRITE | ItemPoolAlloc
ID_CAT | IFFF_FSEEK | ItemPoolControl
ID_CDFS_DISK | IFFF_READ | ItemPoolFlush
ID_CHAN | IFFF_RESERVED | ItemPoolFree
ID_CHRS | IFFF_RSEEK | ItemPoolGC
ID_CMAP | IFFF_RWBITS | ITEM_QUOTED
IDCMP_ACTIVEWINDOW | IFFF_WRITE | ITEMTEXT
IDCMP_CHANGEWINDOW | IFFLCI_COLLECTION | ITEM_UNQUOTED
IDCMP_CLOSEWINDOW | IFFLCI_ENTRYHANDLER | ITEXTICLASS
IDCMP_DELTAMOVE | IFFLCI_EXITHANDLER | ITimer
IDCMP_DISKINSERTED | IFFLCI_PROP | IWorkbench
IDCMP_DISKREMOVED | iffparse |

J

JAM1 JAM2

K

KCB_ALT | KEYCODE_M | KEYMAPNAME
KCB_CONTROL | KEYCODE_N | KeymapObtain
KCB_DEAD | KEYCODE_Q | KeymapRelease
KCB_DOWNUP | KEYCODE_V | KMCTRL_GetAltAmigaSwap
KCB_NOP | KEYCODE_X | KMCTRL_SetAltAmigaSwap
KCB_SHIFT | keymap | KMemCacheAlloc
KCB_STRING | KeymapBase | KMemCacheCreate
KCF_ALT | KeymapClone | KMemCacheDestroy
KCF_CONTROL | KeyMapControlTagList | KMemCacheFind
KCF_DEAD | KeymapExpunge | KMemCacheFree
KCF_DOWNUP | KEYMAPINFO_CLASSIC_ONLY | KMemCacheGrow
KCF_NOP | KEYMAPINFO_GETCLASSICKEYBOARD | KMemCacheReap
KCF_SHIFT | KEYMAPINFO_INFOTEXT_CHARSET | KMEMT_PRIVATE
KCF_STRING | KEYMAPINFO_INFOTEXT_ENGLISH | KMEMT_SHARED
KC_NOQUAL | KEYMAPINFO_INFOTEXT_LOCAL | KNOBHIT
KC_VANILLA | KEYMAPINFO_KEYMAPNODE | KNOBHMIN
KEYCODE_B | KEYMAPINFO_PC_ONLY | KNOBVMIN
KEYCODE_GREATER | KEYMAPINFO_SETCHARSET |
KEYCODE_LESS | KEYMAPINFO_SETCLASSICKEYBOARD |

L

LACE | LBM_PixelFormat | LocaleExpunge
LACEWB | LBM_PlanarYUVInfo | LOCALENAME
LANG_CODE | LBM_TagBase | LocaleObtain
LANG_NAME | LCM_COMPOSE | LocaleRelease
LaunchTool | LCM_DAMAGE | Locale_StrToDate
LaunchToolA | LDB_ASSIGNS | LocalItemData
LAYA_AlphaClips | LDB_DELETE | Lock
LAYA_AlphaHook | LDB_DEVICES | LOCKB_ASSIGNMENT
LAYA_Backdrop | LDB_ENTRY | LOCKB_CURRDIR
LAYA_BackFillHook | LDB_READ | LOCKB_DEVICE
LAYA_Behind | LDB_VOLUMES | LOCKB_FILESYS
LAYA_BitMap | LDB_WRITE | LockBitMapTagList
LAYA_Flags | LDF_ALL | LockBitMapTagList
LAYA_Hidden | LDF_ASSIGNS | LockBitMapTags
LAYA_InFrontOf | LDF_DELETE | LockBitMapToBoardTagList
LAYA_MaxX | LDF_DEVICES | LOCKB_PROGDIR
LAYA_MaxY | LDF_ENTRY | LOCKB_ROOTDIR
LAYA_MinX | LDF_READ | LOCKB_SOFTLINK_ENDPART
LAYA_MinY | LDF_VOLUMES | LOCKB_SOFTLINK_MIDPART
LAYA_Opaqueness | LDF_WRITE | LOCKB_VOLUME
LAYA_Padding | LEFTHIT | LockClassList
LAYA_ShapeHook | LEFTIMAGE | LockDataType
LAYA_ShapeRegion | LEN_DATSTRING | LOCK_DIFFERENT
LAYA_SimpleRefresh | LEN_DISASSEMBLE_OPCODE_STRING | LockDosList
LAYA_SmartRefresh | LEN_DISASSEMBLE_OPERANDS_STRING | LOCKF_ASSIGNMENT
LAYA_StayTop | LendMenus | LOCKF_CURRDIR
LAYA_SuperBitMap | LETTER | LOCKF_DEVICE
LAYA_Window | LEVEL_BRIGHT | LOCKF_FILESYS
LAYERBACKDROP | LEVEL_DARK | LOCKF_PROGDIR
LAYER_BACKMOST | LEVEL_HALFBRIGHT | LOCKF_ROOTDIR
LAYERBACKUP | LEVEL_HALFDARK | LOCKF_SOFTLINK_ENDPART
LAYER_CLIPRECTS_LOST | LEVEL_NORMAL | LOCKF_SOFTLINK_MIDPART
LAYER_FRONTMOST | LEVELS | LOCKF_VOLUME
LAYERHIDDEN | LFalse | LockGUIPrefs
LAYERINFO_BackFillHook | LIBABI_68K | LockIBase
LAYERINFO_Bounds | LIBABI_MIFACE | LockLayer
LAYERINFO_ComposeHook | LIB_BASE | LockLayerInfo
LAYERINFO_ComposeLock | LIB_CLOSE | LockLayerRom
LAYERINFO_OffScreenBitMap | LIB_EXPUNGE | LockLayers
LAYERIREFRESH | LIB_EXTFUNC | LockMem
LAYERIREFRESH2 | LIBF_CHANGED | LockNamedMemory
LAYERMOVECHANGESSHAPE | LIBF_DELEXP | LockPubScreen
LayerOccluded | LIBF_EXP0CNT | LockPubScreenList
LAYEROFFSCREEN | LIBF_SUMMING | LockRecord
LAYERREFRESH | LIBF_SUMUSED | LockRecords
layers | LIB_NONSTD | LOCK_SAME
LAYERSAVEBACK | LIB_OPEN | LOCK_SAME_HANDLER
LAYERS_BACKFILL | LIB_RESERVED | LockScreen
LayersBase | LIB_USERDEF | LockScreenGI
LayersClone | LIB_VECTSIZE | LockScreenList
LAYERS_DUMMY | LIF_COLLECTONLY | LockTagList
LayersExpunge | LIF_EXTLBOUNDS | LongInt
LAYERSIMPLE | LIF_IGNORE | LongWord
LAYERSMART | LIF_OFFSCREEN | LORESDPF2_KEY
LAYERSNAME | LIF_OPTIMIZE | LORESDPF_KEY
LAYERS_NOBACKFILL | LIF_SYNCALWAYS | LORESEHBSDBL_KEY
LayersObtain | LIF_SYNCCOMPOSE | LORESHAMSDBL_KEY
LayersRelease | LINK_HARD | LORES_KEY
LAYERSTAYTOP | LINK_SOFT | LORESLACEDPF2_KEY
LAYERSUPER | LK_Dummy | LORESLACEDPF_KEY
LAYERUPDATING | LK_InfoMask | LORESLACE_KEY
LAYOUTA_ChildMaxHeight | LK_Mode | LORESSDBL_KEY
LAYOUTA_ChildMaxWidth | LK_Name | LORIENT_HORIZ
LAYOUTA_Dummy | LK_ResolveMA | LORIENT_NONE
LAYOUTA_LayoutObj | LK_ResolveSL | LORIENT_VERT
LAYOUTA_Orientation | LK_SoftLinks | LOWCHECKWIDTH
LAYOUTA_Spacing | LNF_LF | LOWCOMMWIDTH
LayoutIconA | LNF_LINK | LOWRESGADGET
LBM_BaseAddress | LNF_OBJECT | LOWRESPICK
LBM_BytesPerRow | LNF_SELECTED | LPEN_SWAP_FRAMES
LBMI_BASEADDRESS | LoadRGB32 | LTrue
LBMI_BYTESPERPIX | LoadRGB4 | LV_ALIAS
LBMI_BYTESPERROW | LoadSeg | LVB_IGNORE
LBMI_DEPTH | LoadView | LVF_IGNORE
LBMI_HEIGHT | locale | LV_TYPE_MASK
LBMI_PIXFMT | LocaleBase | LV_VAR
LBM_IsOnBoard | LocaleClone | LW_RESERVED
LBMI_WIDTH | Locale_DateToStr |

M

MA_AddChild | MUIA_Menuitem_Toggle | MUII_Network
MA_Catalog | MUIA_Menuitem_Trigger | MUII_PageBack
MA_CharSet | MUIA_Menustrip_Enabled | MUII_PopDrawer
MADF_DRAWALL | MUIA_Menu_Title | MUII_PopFile
MADF_DRAWOBJECT | MUIA_NestedDisabled | MUII_PopFont
MADF_DRAWUPDATE | MUIA_NoNotify | MUII_PopUp
MA_Disabled | MUIA_NoNotifyMethod | MUII_PopupBack
MA_Dummy | MUIA_Numeric_CheckAllSizes | MUII_PropBack
MA_EmbeddedKey | MUIA_Numeric_Default | MUII_PropKnob
MA_ErrorCode | MUIA_Numeric_Format | MUII_PullOpen
MA_ErrorTagItem | MUIA_Numeric_Max | MUII_RadioButton
MA_EvenSize | MUIA_Numeric_Min | MUII_ReadListBack
MA_FreeImage | MUIA_Numeric_Reverse | MUII_RegisterBack
MA_HelpHook | MUIA_Numeric_RevLeftRight | MUII_RegisterTitle
MA_Hidden | MUIA_Numeric_RevUpDown | MUII_RequesterBack
MA_ID | MUIA_Numeric_Value | MUII_SelectedBack
MA_Image | MUIA_ObjectID | MUII_SHADOW
MakeClass | MUIA_Palette_Entries | MUII_SHADOWBACK
MakeDosEntry | MUIA_Palette_Groupable | MUII_SHADOWFILL
Makefunctions | MUIA_Palette_Names | MUII_SHADOWSHINE
Make_ID | MUIA_Parent | MUII_SHINE
MakeInterface | MUIA_Penadjust_PSIMode | MUII_SHINEBACK
MakeLibrary | MUIA_Pendisplay_Pen | MUII_SliderBack
MakeLink | MUIA_Pendisplay_Reference | MUII_SliderKnob
MakeScreen | MUIA_Pendisplay_RGBcolor | MUII_StringActiveBack
MakeVPort | MUIA_Pendisplay_Spec | MUII_StringBack
MakeWorkbenchObjectVisible | MUIA_Pixmap_Alpha | MUII_TapeDown
MakeWorkbenchObjectVisibleA | MUIA_Pixmap_CLUT | MUII_TapePause
MA_Key | MUIA_Pixmap_CompressedSize | MUII_TapePlay
MA_Label | MUIA_Pixmap_Compression | MUII_TapePlayBack
MA_LastSelected | MUIA_Pixmap_Data | MUII_TapeRecord
MA_Level | MUIA_Pixmap_Format | MUII_TapeStop
MA_MaxStringID | MUIA_Pixmap_Height | MUII_TapeUp
MA_MenuHelpID | MUIA_Pixmap_UncompressedData | MUII_TextBack
MA_MenuPosX | MUIA_Pixmap_Width | MUII_Volume
MA_MenuPosY | MUIA_Popasl_Active | MUII_WindowBack
MA_MinStringID | MUIA_Popasl_StartHook | MUIKEY_BOTTOM
MA_MX | MUIA_Popasl_StopHook | MUIKEY_COUNT
MapANSI | MUIA_Popasl_Type | MUIKEY_DOWN
MA_Parent | MUIA_Poplist_Array | MUIKEYF_BOTTOM
MA_PickHook | MUIA_Popobject_Follow | MUIKEYF_DOWN
MAP_KEEP_NOT_FOUND | MUIA_Popobject_Light | MUIKEYF_GADGET_NEXT
MapRawKey | MUIA_Popobject_Object | MUIKEYF_GADGET_OFF
MAP_REMOVE_NOT_FOUND | MUIA_Popobject_ObjStrHook | MUIKEYF_GADGET_PREV
MapTags | MUIA_Popobject_StrObjHook | MUIKEYF_HELP
MA_RemoveChild | MUIA_Popobject_Volatile | MUIKEYF_LEFT
MA_Selected | MUIA_Popobject_WindowHook | MUIKEYF_LINEEND
MA_Separator | MUIA_Popstring_Button | MUIKEYF_LINESTART
M_ASM | MUIA_Popstring_CloseHook | MUIKEYF_PAGEDOWN
MA_StringHook | MUIA_Popstring_OpenHook | MUIKEYF_PAGEUP
MatchEnd | MUIA_Popstring_String | MUIKEYF_POPUP
MatchFirst | MUIA_Popstring_Toggle | MUIKEYF_PRESS
MatchNext | MUIA_Pressed | MUIKEYF_RIGHT
MatchPattern | MUIA_Process_AutoLaunch | MUIKEYF_TOGGLE
MatchPatternNoCase | MUIA_Process_Name | MUIKEYF_TOP
MatchToolValue | MUIA_Process_Priority | MUIKEYF_UP
MA_TextAttr | MUIA_Process_SourceClass | MUIKEYF_WINDOW_CLOSE
MA_Toggle | MUIA_Process_SourceObject | MUIKEYF_WINDOW_NEXT
MA_Type | MUIA_Process_StackSize | MUIKEYF_WINDOW_PREV
MA_UserData | MUIA_Process_Task | MUIKEYF_WORDLEFT
M_AWM | MUIA_Prop_DeltaFactor | MUIKEYF_WORDRIGHT
MAXBODY | MUIA_Prop_DoSmooth | MUIKEY_GADGET_NEXT
MaxCli | MUIA_Prop_Entries | MUIKEY_GADGET_OFF
MAXFONTMATCHWEIGHT | MUIA_Prop_First | MUIKEY_GADGET_PREV
MAXFONTNAME | MUIA_Prop_Horiz | MUIKEY_HELP
MAXFONTPATH | MUIA_Prop_Slider | MUIKEY_LEFT
MAXINT | MUIA_Prop_UseWinBorder | MUIKEY_LINEEND
MAXPOT | MUIA_Prop_Visible | MUIKEY_LINESTART
MAXPUBSCREENNAME | MUIA_Radio_Active | MUIKEY_NONE
MAXSTRMSG | MUIA_Radio_Entries | MUIKEY_PAGEDOWN
MAXTABS | MUIAreaData | MUIKEY_PAGEUP
MAX_VP_COMMENT | MUIA_Rectangle_BarTitle | MUIKEY_POPUP
MAX_VP_FILENAME | MUIA_Rectangle_HBar | MUIKEY_PRESS
MAX_VP_SOFTLINK_TARGET | MUIA_Rectangle_VBar | MUIKEY_RELEASE
MAXWINS | MUIA_Register_Columns | MUIKEY_RIGHT
MBQF_HORIZ | MUIA_Register_Frame | MUIKEY_TOGGLE
MBQ_MUI_MAXMAX | MUIA_Register_Titles | MUIKEY_TOP
MCOMPAT_MIXED | MUIA_Revision | MUIKEY_UP
MCOMPAT_NOBODY | MUIA_RightEdge | MUIKEY_WINDOW_CLOSE
MCOMPAT_SELF | MUIA_Scale_Horiz | MUIKEY_WINDOW_NEXT
MCOP_NO_MEM | MUIA_Scrollbar_Type | MUIKEY_WINDOW_PREV
MCOP_NOP | MUIA_Scrollbutton_Horiz | MUIKEY_WORDLEFT
MCOP_OK | MUIA_Scrollbutton_HorizProp | MUIKEY_WORDRIGHT
MC_TEMPLATE_ID | MUIA_Scrollbutton_NewPosition | MUI_Layout
MD_Activate | MUIA_Scrollbutton_Vert | MUI_LayoutObj
MD_Baud | MUIA_Scrollbutton_VertProp | MUILM_LAYOUT
MD_BufMemType | MUIA_Scrollgroup_Contents | MUILM_MINMAX
MD_Control | MUIA_Scrollgroup_FreeHoriz | MUILM_UNKNOWN
MD_Device | MUIA_Scrollgroup_FreeVert | MUI_LPR_ABOVE
MD_DOSType | MUIA_Scrollgroup_HorizBar | MUI_LPR_BELOW
MD_Dummy | MUIA_Scrollgroup_UseWinBorder | MUI_LPR_LEFT
MD_Entry | MUIA_Scrollgroup_VertBar | MUI_LPR_RIGHT
MD_Flags | MUIA_Selected | MUI_MakeObject
MD_GlobVec | MUIA_ShortHelp | MUI_MakeObjectA
MD_Handler | MUIA_ShowMe | MUIM_Application_AboutMUI
MD_HighCyl | MUIA_ShowSelState | MUIM_Application_AddInputHandler
MD_IgnoreFSR | MUIA_Slider_Horiz | MUIM_Application_CheckRefresh
MD_LowCyl | MUIA_Slider_Quiet | MUIM_Application_Execute
MD_Mask | MUI_AslRequest | MUIM_Application_GetMenuCheck
MD_MaxTransfer | MUI_AslRequestTags | MUIM_Application_GetMenuState
MD_NumBuffers | MUIA_String_Accept | MUIM_Application_Iconify
MD_Port | MUIA_String_Acknowledge | MUIM_Application_Input
MD_PreAlloc | MUIA_String_AdvanceOnCR | MUIM_Application_InputBuffered
MD_Priority | MUIA_String_AttachedList | MUIM_Application_Load
MD_Reserved | MUIA_String_BufferPos | MUIM_Application_NewInput
MD_SectorSize | MUIA_String_Columns | MUIM_Application_OpenConfigWindow
MD_SectorsPerBlock | MUIA_String_Contents | MUIM_Application_OpenWindows
MD_SectorsPerTrack | MUIA_String_DisplayPos | MUIM_Application_PushMethod
MD_SegList | MUIA_String_EditHook | MUIM_Application_RemInputHandler
MD_StackSize | MUIA_String_Format | MUIM_Application_ReturnID
MD_StartupNumber | MUIA_String_Integer | MUIM_Application_Save
MD_StartupString | MUIA_String_KeyDownFocus | MUIM_Application_SetConfigdata
MD_Surfaces | MUIA_String_KeyUpFocus | MUIM_Application_SetConfigItem
MDT_FileSystem | MUIA_String_LonelyEditHook | MUIM_Application_SetMenuCheck
MDT_Handler | MUIA_String_MaxLen | MUIM_Application_SetMenuState
MD_Unit | MUIA_String_NoInput | MUIM_Application_ShowHelp
MEM_ALL_DONE | MUIA_String_Reject | MUIM_Application_UnpushMethod
MEMATTRF_CACHEINHIBIT | MUIA_String_Secret | MUIM_Application_UpdateMenus
MEMATTRF_CHANGED | MUIA_String_SelectSize | MUIM_AskMinMax
MEMATTRF_COHERENT | MUIA_String_StayActive | MUIMasterBase
MEMATTRF_EXECUTE | MUIA_Text_Contents | MUIMASTER_NAME
MEMATTRF_GUARDED | MUIA_Text_HiChar | MUIMASTER_VLATEST
MEMATTRF_NOT_MAPPED | MUIA_Text_HiCharIdx | MUIMASTER_VMIN
MEMATTRF_READ_ONLY | MUIA_Text_PreParse | MUI_MAXMAX
MEMATTRF_READ_WRITE | MUIA_Text_SetMax | MUIM_BoopsiQuery
MEMATTRF_REFERENCED | MUIA_Text_SetMin | MUIM_CallHook
MEMATTRF_RESERVED1 | MUIA_Text_SetVMax | MUIM_Cleanup
MEMATTRF_RESERVED2 | MUIA_Timer | MUIM_Configdata_GetString
MEMATTRF_RESERVER3 | MUIA_TopEdge | MUIM_Configdata_GetULong
MEMATTRF_RW_MASK | MUIA_UserData | MUIM_Configdata_GetWindowPos
MEMATTRF_SUPER_RO_USER_RO | MUIA_Version | MUIM_Configdata_Load
MEMATTRF_SUPER_RW | MUIA_VertDisappear | MUIM_Configdata_Save
MEMATTRF_SUPER_RW_USER_RO | MUIA_VertWeight | MUIM_Configdata_SetFont
MEMATTRF_SUPER_RW_USER_RW | MUIA_Virtgroup_Height | MUIM_Configdata_SetFramespec
MEMATTRF_WRITETHROUGH | MUIA_Virtgroup_Input | MUIM_Configdata_SetImspec
MEM_BLOCKMASK | MUIA_Virtgroup_Left | MUIM_Configdata_SetPenspec
MEM_BLOCKSIZE | MUIA_Virtgroup_Top | MUIM_Configdata_SetString
MEM_DID_NOTHING | MUIA_Virtgroup_Width | MUIM_Configdata_SetULong
MEMF_24BITDMA | MUIA_Weight | MUIM_Configdata_SetWindowPos
MEMF_ANY | MUIA_Width | MUIM_ConnectParent
MEMF_CHIP | MUIA_Window | MUIM_ContextMenuBuild
MEMF_CLEAR | MUIA_Window_Activate | MUIM_ContextMenuChoice
MEMF_CORE_RESIDENT | MUIA_Window_ActiveObject | MUIM_CreateBubble
MEMF_DELAYED | MUIA_Window_AltHeight | MUIM_CreateDragImage
MEMF_EXECUTABLE | MUIA_Window_AltLeftEdge | MUIM_CreateShortHelp
MEMF_FAST | MUIA_Window_AltTopEdge | MUIM_CustomBackfill
MEMF_HWALIGNED | MUIA_Window_AltWidth | MUIM_Dataspace_Add
MEMF_KICK | MUIA_Window_AppWindow | MUIM_Dataspace_Clear
MEMF_LARGEST | MUIA_Window_Backdrop | MUIM_Dataspace_Find
MEMF_LOCAL | MUIA_Window_Borderless | MUIM_Dataspace_Merge
MEMF_NO_EXPUNGE | MUIA_Window_CloseGadget | MUIM_Dataspace_ReadIFF
MEMF_PRIVATE | MUIA_Window_CloseRequest | MUIM_Dataspace_Remove
MEMF_PUBLIC | MUIA_Window_DefaultObject | MUIM_Dataspace_WriteIFF
MEMF_REVERSE | MUIA_Window_DepthGadget | MUIM_DeleteBubble
MEMF_SHARED | MUIA_Window_DisableKeys | MUIM_DeleteDragImage
MEMF_TOTAL | MUIA_Window_DragBar | MUIM_DeleteShortHelp
MEMF_VIRTUAL | MUIA_Window_EraseArea | MUIM_Dirlist_ReRead
MEMHF_RECYCLE | MUIA_Window_FancyDrawing | MUIM_DisconnectParent
MEM_TRY_AGAIN | MUIA_Window_Height | MUIM_DoDrag
MENUALTERN | MUIA_Window_ID | MUIM_DragBegin
MENUBACKGROUNDPEN | MUIA_Window_InputEvent | MUIM_DragDrop
MENUCANCEL | MUIA_Window_IsSubWindow | MUIM_DragFinish
MENUCHECK | MUIA_Window_LeftEdge | MUIM_DragQuery
MENUCMCORNER | MUIA_Window_MenuAction | MUIM_DragReport
MENUDOWN | MUIA_Window_Menustrip | MUIM_Draw
MENUENABLED | MUIA_Window_MouseObject | MUIM_DrawBackground
MENUFLAT | MUIA_Window_NeedsMouseObject | MUIM_DrawParentBackground
MENUFRAMED | MUIA_Window_NoMenus | MUIM_Export
MENUHOT | MUIA_WindowObject | MUIM_Family_AddHead
MENUMX | MUIA_Window_Open | MUIM_Family_AddTail
MENUNBPD | MUIA_Window_PublicScreen | MUIM_Family_DoChildMethods
MENUNBPU | MUIA_Window_RefWindow | MUIM_Family_GetChild
MENUNULL | MUIA_Window_RootObject | MUIM_Family_Insert
MENUNUM | MUIA_Window_Screen | MUIM_Family_Remove
MENUPDTCLDEL | MUIA_Window_ScreenTitle | MUIM_Family_Sort
MENUPDTOPDEL | MUIA_Window_SizeGadget | MUIM_Family_Transfer
MENUSHADOW | MUIA_Window_SizeRight | MUIM_FindUData
MENUSHADOWPEN | MUIA_Window_Sleep | MUIM_Floattext_Append
MENUSHINEPEN | MUIA_Window_Title | MUIM_GetConfigItem
MENUSTICKYPD | MUIA_Window_ToolBox | MUIM_GetUData
MENUSTICKYPU | MUIA_Window_TopEdge | MUIM_GoActive
MENUSUB | MUIA_Window_UseBottomBorderScroller | MUIM_GoInactive
MENUTEXTPEN | MUIA_Window_UseLeftBorderScroller | MUIM_Group_AddHead
MENUTOGGLE | MUIA_Window_UseRightBorderScroller | MUIM_Group_AddTail
MENUTOGGLED | MUIA_Window_Width | MUIM_Group_DoMethodNoForward
MENUTRACK | MUIA_Window_Window | MUIM_Group_ExitChange
MENUTRANSP | MUIA_Window_ZoomGadget | MUIM_Group_InitChange
MENUUP | MUIB_Aboutmui | MUIM_Group_Remove
MENUWAITING | MUIB_Application | MUIM_Group_Sort
MessageDigest_SHA_Final | MUIB_Area | MUIM_HandleEvent
MessageDigest_SHA_Init | MUIB_AROS | MUIM_HandleInput
MessageDigest_SHA_Update | MUIB_Balance | MUIM_Hide
MicroDelay | MUIB_Bitmap | MUIM_Import
MIDDLEDOWN | MUIB_Bodychunk | MUIM_KillNotify
MIDDLEUP | MUIB_Boopsi | MUIM_KillNotifyObj
MININT | MUIB_ChunkyImage | MUIM_Layout
MIN_NTSC_ROW | MUIB_Coloradjust | MUIM_List_Clear
MIN_PAL_ROW | MUIB_Colorfield | MUIM_List_Compare
MINTERM_ABC | MUIB_Configdata | MUIM_List_Construct
MINTERM_ABNC | MUIB_Cycle | MUIM_List_CreateImage
MINTERM_ANBC | MUIB_Dataspace | MUIM_List_DeleteImage
MINTERM_ANBNC | MUIB_Dirlist | MUIM_List_Exchange
MINTERM_A_OR_B | MUI_BeginRefresh | MUIM_List_GetEntry
MINTERM_A_OR_C | MUIB_Family | MUIM_List_Insert
MINTERM_A_TO_D | MUIB_Floattext | MUIM_List_InsertSingle
MINTERM_A_XOR_C | MUIB_Frameadjust | MUIM_List_Jump
MINTERM_B_EQUALS_C | MUIB_Framedisplay | MUIM_List_Move
MINTERM_B_OR_C | MUIB_Gauge | MUIM_List_NextSelected
MINTERM_NABC | MUIB_Group | MUIM_List_Redraw
MINTERM_NABNC | MUIB_Image | MUIM_List_Remove
MINTERM_NANBC | MUIB_Imageadjust | MUIM_List_Select
MINTERM_NANBNC | MUIB_Imagedisplay | MUIM_List_Sort
MINTERM_NOTSRCMASK | MUIB_List | MUIM_List_TestPos
MINTERM_SRCMASK | MUIB_Listview | MUIM_MultiSet
MIN_VGA70_ROW | MUIB_Menu | MUIM_NoNotifySet
MIN_VGA_ROW | MUIB_Menuitem | MUIM_Notify
MKBADDR | MUIB_Menustrip | MUIM_Numeric_Decrease
M_LNM | MUIB_MUI | MUIM_Numeric_Increase
ML_SEPARATOR | MUIB_Notify | MUIM_Numeric_ScaleToValue
MM_CLEANUP | MUIB_Numeric | MUIM_Numeric_SetDefault
MM_DELETEMENU | MUIB_Palette | MUIM_Numeric_Stringify
MM_FINDID | MUIB_Penadjust | MUIM_Numeric_ValueToScale
MM_GETSTATE | MUIB_Pendisplay | MUIM_Numeric_ValueToScaleExt
MM_HANDLEHELP | MUIB_Pixmap | MUIM_Pendisplay_SetColormap
MM_HANDLEPICK | MUIB_Popasl | MUIM_Pendisplay_SetMUIPen
MM_NEWMENU | MUIB_Popframe | MUIM_Pendisplay_SetRGB
MM_NEXTCHILD | MUIB_Popimage | MUIM_Pixmap_DrawSection
MM_NEXTSELECT | MUIB_Poplist | MUIM_Popstring_Close
MM_SCAN | MUIB_Popobject | MUIM_Popstring_Open
MM_SETSTATE | MUIB_Poppen | MUIM_Process_Kill
MM_SETUP | MUIB_Popscreen | MUIM_Process_Launch
MODE_640 | MUIB_Popstring | MUIM_Process_Process
MODELCLASS | MUIB_Prop | MUIM_Process_Signal
MODENAMELENGTH | MUIB_Radio | MUIM_Prop_Decrease
MODE_NEWFILE | MUIB_Rectangle | MUIM_Prop_Increase
ModeNotAvailable | MUIB_Register | MUIMRI_RECTFILL
MODE_OLDFILE | MUIB_RSVD | MUIMRI_REFRESHMODE
MODE_READWRITE | MUIB_Scale | MUIMRI_THINFRAMES
ModifyIDCMP | MUIB_Scrmodelist | MUIMRI_TRUECOLOR
ModifyProp | MUIB_Scrollbar | MUIM_Semaphore_Attempt
MON_1 | MUIB_Scrollbutton | MUIM_Semaphore_AttemptShared
MON_10 | MUIB_Scrollgroup | MUIM_Semaphore_Obtain
MON_11 | MUIB_Semaphore | MUIM_Semaphore_ObtainShared
MON_12 | MUIB_Settings | MUIM_Semaphore_Release
MON_2 | MUIB_Settingsgroup | MUIM_Set
MON_3 | MUIB_Slider | MUIM_SetAsString
MON_4 | MUIB_String | MUIM_Settingsgroup_ConfigToGadgets
MON_5 | MUIB_Text | MUIM_Settingsgroup_GadgetsToConfig
MON_6 | MUIB_Virtgroup | MUIM_SetUData
MON_7 | MUIB_Volumelist | MUIM_SetUDataOnce
MON_8 | MUIB_Window | MUIM_Setup
MON_9 | MUIB_ZUNE | MUIM_Show
MONITOR_ID_MASK | MUIC_Aboutmui | MUIM_String_ClearSelected
MONITOR_SPEC_TYPE | MUIC_Application | MUIM_String_FileNameStart
MountDevice | MUIC_Applist | MUIM_String_Insert
MOUSE_ACCEL | MUIC_Area | MUIM_UnknownDropDestination
MoveLayer | MUIC_Balance | MUIM_Window_ActionIconify
MoveLayerInFrontOf | MUIC_Bitmap | MUIM_Window_AddEventHandler
MoveList | MUIC_Bodychunk | MUIM_Window_AllocGadgetID
MoveMem | MUIC_Boopsi | MUIM_Window_Cleanup
MovePixelArray | MUIC_Cclist | MUIM_Window_FreeGadgetID
MoveScreen | MUIC_ChunkyImage | MUIM_Window_RemEventHandler
MoveSizeLayer | MUIC_Coloradjust | MUIM_Window_ScreenToBack
MoveSprite | MUIC_Colorfield | MUIM_Window_ScreenToFront
MoveWindow | MUIC_Configdata | MUIM_Window_Setup
MoveWindowInFrontOf | MUIC_Crawling | MUIM_Window_Snapshot
MPEN_BACKGROUND | MUIC_Cycle | MUIM_Window_ToBack
MPEN_COUNT | MUIC_Dataspace | MUIM_Window_ToFront
MPEN_FILL | MUIC_Dirlist | MUIM_WriteLong
MPEN_HALFSHADOW | MUIC_Dtpic | MUIM_WriteString
MPEN_HALFSHINE | MUIC_Family | MUI_NewObject
MPEN_MARK | MUICFG_ActiveObject_Color | MUI_NewObjectA
MPEN_SHADOW | MUICFG_Background_Button | MUINotifyData
MPEN_SHINE | MUICFG_Background_Framed | MUIO_BarTitle
MPEN_TEXT | MUICFG_Background_List | MUIObtain
MrgCop | MUICFG_Background_ListCursor | MUI_ObtainPen
MRI_RARRAY_SIZE | MUICFG_Background_ListSelCur | MUIO_Button
MS_AMERICAN | MUICFG_Background_ListSelect | MUIO_Checkmark
MSB_DOUBLE_SPRITES | MUICFG_Background_Page | MUIO_Cycle
MSB_REQUEST_A2024 | MUICFG_Background_PopUp | MUI_Offset
MSB_REQUEST_NTSC | MUICFG_Background_Prop | MUIO_HBar
MSB_REQUEST_PAL | MUICFG_Background_ReadList | MUIO_HSpace
MSB_REQUEST_SPECIAL | MUICFG_Background_Register | MUIO_Label
MS_BRITISH | MUICFG_Background_Requester | MUIO_Label_Centered
MS_CHECKED | MUICFG_Background_Selected | MUIO_Label_DontCopy
MS_DISABLED | MUICFG_Background_Slider | MUIO_Label_DoubleFrame
MSF_DOUBLE_SPRITES | MUICFG_Background_SliderKnob | MUIO_Label_FreeVert
MSF_REQUEST_A2024 | MUICFG_Background_Text | MUIO_Label_LeftAligned
MSF_REQUEST_NTSC | MUICFG_Background_Window | MUIO_Label_SingleFrame
MSF_REQUEST_PAL | MUICFG_Balance_Look | MUIO_Label_Tiny
MSF_REQUEST_SPECIAL | MUICFG_BubbleHelp_FirstDelay | MUIO_Menuitem
MS_IMPERIAL | MUICFG_BubbleHelp_NextDelay | MUIO_Menuitem_CopyStrings
MS_ISO | MUICFG_CustomFrame_1 | MUIO_MenustripNM
mskHasAlpha | MUICFG_CustomFrame_10 | MUIO_MenustripNM_CommandKeyCheck
mskHasMask | MUICFG_CustomFrame_11 | MUIO_NumericButton
mskHasTransparentColor | MUICFG_CustomFrame_12 | MUIO_PopButton
mskLasso | MUICFG_CustomFrame_13 | MUIO_Radio
mskNone | MUICFG_CustomFrame_14 | MUIO_Slider
MT_POPUP | MUICFG_CustomFrame_15 | MUIO_String
MT_PULLDOWN | MUICFG_CustomFrame_16 | MUIO_VBar
MT_RELATIVE | MUICFG_CustomFrame_2 | MUIO_VSpace
MTYPE_APPICON | MUICFG_CustomFrame_3 | MUIP_BoopsiQuery
MTYPE_APPMENUITEM | MUICFG_CustomFrame_4 | MUIPen
MTYPE_APPWINDOW | MUICFG_CustomFrame_5 | MUIPEN_MASK
MTYPE_CLOSEDOWN | MUICFG_CustomFrame_6 | MUI_Redraw
MTYPE_COPYEXIT | MUICFG_CustomFrame_7 | MUI_RejectIDCMP
MTYPE_DISKCHANGE | MUICFG_CustomFrame_8 | MUIRelease
MTYPE_ICONPUT | MUICFG_CustomFrame_9 | MUI_ReleasePen
MTYPE_IOPROC | MUICFG_Cycle_MenuCtrl_Level | MUI_RemoveClipping
MTYPE_PSTD | MUICFG_Cycle_MenuCtrl_Position | MUI_RemoveClipRegion
MTYPE_TIMER | MUICFG_Cycle_MenuCtrl_Speed | MUIRenderInfo
MTYPE_TOOLEXIT | MUICFG_Cycle_Menu_Recessed | MUI_Request
mui | MUICFG_Drag_Autostart | MUI_RequestA
MUIA_Aboutmui_Application | MUICFG_Drag_Autostart_Length | MUI_RequestIDCMP
MUIA_Application_Active | MUICFG_Drag_LeftButton | MUIR_String_FileNameStart_Volume
MUIA_Application_Author | MUICFG_Drag_LMBModifier | MUI_RXERR_BADDEFINITION
MUIA_Application_Base | MUICFG_Drag_MiddleButton | MUI_RXERR_BADSYNTAX
MUIA_Application_Broker | MUICFG_Drag_MMBModifier | MUI_RXERR_OUTOFMEMORY
MUIA_Application_BrokerHook | MUICFG_Dragndrop_Look | MUI_RXERR_UNKNOWNCOMMAND
MUIA_Application_BrokerPort | MUICFG_Font_Big | MUI_SetError
MUIA_Application_BrokerPri | MUICFG_Font_Button | MUI_Show
MUIA_Application_Commands | MUICFG_Font_Fixed | MUIUserData
MUIA_Application_Configdata | MUICFG_Font_Knob | MUIV_Application_Load_ENV
MUIA_Application_Copyright | MUICFG_Font_List | MUIV_Application_Load_ENVARC
MUIA_Application_CopyWinPosToApp | MUICFG_Font_Normal | MUIV_Application_OCW_ScreenPage
MUIA_Application_Description | MUICFG_Font_Tiny | MUIV_Application_Package_NetConnect
MUIA_Application_DiskObject | MUICFG_Font_Title | MUIV_Application_ReturnID_Quit
MUIA_Application_DoubleStart | MUICFG_Frame_Button | MUIV_Application_Save_ENV
MUIA_Application_DropObject | MUICFG_Frame_Drag | MUIV_Application_Save_ENVARC
MUIA_Application_ForceQuit | MUICFG_Frame_Gauge | MUIV_ContextMenuBuild_Default
MUIA_Application_GetWinPos | MUICFG_Frame_Group | MUIV_CreateBubble_DontHidePointer
MUIA_Application_GetWinPosAddr | MUICFG_Frame_ImageButton | MUIV_Cycle_Active_Next
MUIA_Application_GetWinPosSize | MUICFG_Frame_InputList | MUIV_Cycle_Active_Prev
MUIA_Application_HelpFile | MUICFG_Frame_Knob | MUIV_Dirlist_SortDirs_First
MUIA_Application_Iconified | MUICFG_Frame_PopUp | MUIV_Dirlist_SortDirs_Last
MUIA_Application_MenuAction | MUICFG_Frame_Prop | MUIV_Dirlist_SortDirs_Mix
MUIA_Application_MenuHelp | MUICFG_Frame_ReadList | MUIV_Dirlist_SortType_Date
MUIA_Application_Menustrip | MUICFG_Frame_Slider | MUIV_Dirlist_SortType_Name
MUIA_ApplicationObject | MUICFG_Frame_String | MUIV_Dirlist_SortType_Size
MUIA_Application_RexxHook | MUICFG_Frame_Text | MUIV_Dirlist_Status_Invalid
MUIA_Application_RexxMsg | MUICFG_Frame_Virtual | MUIV_Dirlist_Status_Reading
MUIA_Application_RexxString | MUICFG_Group_HSpacing | MUIV_Dirlist_Status_Valid
MUIA_Application_SearchWinId | MUICFG_GroupTitle_Color | MUIV_DragQuery_Accept
MUIA_Application_SetWinPos | MUICFG_GroupTitle_Position | MUIV_DragQuery_Refuse
MUIA_Application_SingleTask | MUICFG_Group_VSpacing | MUIV_DragReport_Abort
MUIA_Application_Sleep | MUICFG_Iconification_Hotkey | MUIV_DragReport_Continue
MUIA_Application_Title | MUICFG_Iconification_OnStartup | MUIV_DragReport_Lock
MUIA_Application_UseCommodities | MUICFG_Iconification_ShowIcon | MUIV_DragReport_Refresh
MUIA_Application_UsedClasses | MUICFG_Iconification_ShowMenu | MUIV_EveryTime
MUIA_Application_UseRexx | MUICFG_Image_ArrowDown | MUIV_Family_GetChild_First
MUIA_Application_Version | MUICFG_Image_ArrowLeft | MUIV_Family_GetChild_Iterate
MUIA_Application_Version_Date | MUICFG_Image_ArrowRight | MUIV_Family_GetChild_Last
MUIA_Application_Version_Extra | MUICFG_Image_ArrowUp | MUIV_Family_GetChild_Next
MUIA_Application_Version_Number | MUICFG_Image_Assign | MUIV_Family_GetChild_Previous
MUIA_Application_Window | MUICFG_Image_CheckMark | MUIV_Font_Big
MUIA_Application_WindowList | MUICFG_Image_Chip | MUIV_Font_Button
MUIA_AppMessage | MUICFG_Image_Cycle | MUIV_Font_Fixed
MUIA_Background | MUICFG_Image_Disk | MUIV_Font_Inherit
MUIA_Balance_Quiet | MUICFG_Image_Drawer | MUIV_Font_Knob
MUIA_Bitmap_Alpha | MUICFG_Image_HardDisk | MUIV_Font_List
MUIA_Bitmap_Bitmap | MUICFG_Image_Network | MUIV_Font_NegCount
MUIA_Bitmap_Height | MUICFG_Image_PopDrawer | MUIV_Font_Normal
MUIA_Bitmap_MappingTable | MUICFG_Image_PopFile | MUIV_Font_Tiny
MUIA_Bitmap_Precision | MUICFG_Image_PopUp | MUIV_Font_Title
MUIA_Bitmap_RemappedBitmap | MUICFG_Image_PropKnob | MUIV_Frame_Button
MUIA_Bitmap_SourceColors | MUICFG_Image_RadioButton | MUIV_Frame_Count
MUIA_Bitmap_Transparent | MUICFG_Image_TapeDown | MUIV_Frame_Drag
MUIA_Bitmap_UseFriend | MUICFG_Image_TapePause | MUIV_Frame_Gauge
MUIA_Bitmap_Width | MUICFG_Image_TapePlay | MUIV_Frame_Group
MUIA_Bodychunk_Body | MUICFG_Image_TapePlayBack | MUIV_Frame_ImageButton
MUIA_Bodychunk_Compression | MUICFG_Image_TapeRecord | MUIV_Frame_InputList
MUIA_Bodychunk_Depth | MUICFG_Image_TapeStop | MUIV_Frame_Knob
MUIA_Bodychunk_Masking | MUICFG_Image_TapeUp | MUIV_Frame_None
MUIA_Boopsi_Class | MUICFG_Image_Volume | MUIV_Frame_PopUp
MUIA_Boopsi_ClassID | MUICFG_Interfaces_EnableARexx | MUIV_Frame_Prop
MUIA_Boopsi_MaxHeight | MUICFG_Invalid | MUIV_Frame_ReadList
MUIA_Boopsi_MaxWidth | MUICFG_Keyboard_Bottom | MUIV_Frame_Register
MUIA_Boopsi_MinHeight | MUICFG_Keyboard_CloseWindow | MUIV_Frame_Slider
MUIA_Boopsi_MinWidth | MUICFG_Keyboard_Down | MUIV_Frame_String
MUIA_Boopsi_Object | MUICFG_Keyboard_GadgetOff | MUIV_Frame_Text
MUIA_Boopsi_Remember | MUICFG_Keyboard_Help | MUIV_Frame_Virtual
MUIA_Boopsi_Smart | MUICFG_Keyboard_Left | MUIV_Group_ActivePage_Advance
MUIA_Boopsi_TagDrawInfo | MUICFG_Keyboard_LineEnd | MUIV_Group_ActivePage_First
MUIA_Boopsi_TagScreen | MUICFG_Keyboard_LineStart | MUIV_Group_ActivePage_Last
MUIA_Boopsi_TagWindow | MUICFG_Keyboard_NextGadget | MUIV_Group_ActivePage_Next
MUIA_BottomEdge | MUICFG_Keyboard_NextWindow | MUIV_Group_ActivePage_Prev
MUIA_ChunkyImage_Modulo | MUICFG_Keyboard_PageDown | MUIV_Group_GetChild_First
MUIA_ChunkyImage_NumColors | MUICFG_Keyboard_PageUp | MUIV_Group_GetChild_Iterate
MUIA_ChunkyImage_Palette | MUICFG_Keyboard_Popup | MUIV_Group_GetChild_Last
MUIA_ChunkyImage_Pixels | MUICFG_Keyboard_Press | MUIV_Group_GetChild_Next
MUIA_Coloradjust_Blue | MUICFG_Keyboard_PrevGadget | MUIV_Group_GetChild_Previous
MUIA_Coloradjust_Green | MUICFG_Keyboard_PrevWindow | MUIV_Imageadjust_Type_All
MUIA_Coloradjust_ModeID | MUICFG_Keyboard_Right | MUIV_Imageadjust_Type_Background
MUIA_Coloradjust_Red | MUICFG_Keyboard_Toggle | MUIV_Imageadjust_Type_Image
MUIA_Coloradjust_RGB | MUICFG_Keyboard_Top | MUIV_Imageadjust_Type_Pen
MUIA_Colorfield_Blue | MUICFG_Keyboard_Up | MUIV_InputMode_Immediate
MUIA_Colorfield_Green | MUICFG_Keyboard_WordLeft | MUIV_InputMode_None
MUIA_Colorfield_Pen | MUICFG_Keyboard_WordRight | MUIV_InputMode_RelVerify
MUIA_Colorfield_Red | MUICFG_Listview_Font_Leading | MUIV_InputMode_Toggle
MUIA_Colorfield_RGB | MUICFG_Listview_Multi | MUIV_List_Active_Bottom
MUIA_Configdata_Application | MUICFG_Listview_Refresh | MUIV_List_Active_Down
MUIA_Configdata_ApplicationBase | MUICFG_Listview_Smoothed | MUIV_List_Active_Off
MUIA_ContextMenu | MUICFG_Listview_SmoothVal | MUIV_List_Active_PageDown
MUIA_ContextMenuTrigger | MUICFG_PublicScreen | MUIV_List_Active_PageUp
MUIA_ControlChar | MUICFG_PublicScreen_PopToFront | MUIV_List_Active_Top
MUIA_Cycle_Active | MUICFG_Radio_HSpacing | MUIV_List_Active_Up
MUIA_CycleChain | MUICFG_Radio_VSpacing | MUIV_List_ConstructHook_String
MUIA_Cycle_Entries | MUICFG_Register_TruncateTitles | MUIV_List_CopyHook_String
MUIA_Dataspace_Pool | MUICFG_Screen_Height | MUIV_List_CursorType_Bar
MUI_AddClipping | MUICFG_Screen_Mode | MUIV_List_CursorType_None
MUI_AddClipRegion | MUICFG_Screen_Mode_ID | MUIV_List_CursorType_Rect
MUIA_Dirlist_AcceptPattern | MUICFG_Screen_Width | MUIV_List_DestructHook_String
MUIA_Dirlist_Directory | MUICFG_Scrollbar_Arrangement | MUIV_List_EditEntry_Active
MUIA_Dirlist_DrawersOnly | MUICFG_Scrollbar_Type | MUIV_List_Exchange_Active
MUIA_Dirlist_FilesOnly | MUICFG_String_ActiveBackground | MUIV_List_Exchange_Bottom
MUIA_Dirlist_FilterDrawers | MUICFG_String_ActiveText | MUIV_List_Exchange_Next
MUIA_Dirlist_FilterHook | MUICFG_String_Background | MUIV_List_Exchange_Previous
MUIA_Dirlist_MultiSelDirs | MUICFG_String_Cursor | MUIV_List_Exchange_Top
MUIA_Dirlist_NumBytes | MUICFG_String_MarkedBackground | MUIV_List_GetEntry_Active
MUIA_Dirlist_NumDrawers | MUICFG_String_MarkedText | MUIV_List_Insert_Active
MUIA_Dirlist_NumFiles | MUICFG_String_Text | MUIV_List_Insert_Bottom
MUIA_Dirlist_Path | MUICFG_Window_Buttons | MUIV_List_Insert_Sorted
MUIA_Dirlist_RejectIcons | MUICFG_WindowPos | MUIV_List_Insert_Top
MUIA_Dirlist_RejectPattern | MUICFG_Window_Positions | MUIV_List_Jump_Active
MUIA_Dirlist_SortDirs | MUICFG_Window_Redraw | MUIV_List_Jump_Bottom
MUIA_Dirlist_SortHighLow | MUICFG_Window_Refresh | MUIV_List_Jump_Down
MUIA_Dirlist_SortType | MUICFG_Window_Spacing_Bottom | MUIV_List_Jump_Top
MUIA_Dirlist_Status | MUICFG_Window_Spacing_Left | MUIV_List_Jump_Up
MUIA_Disabled | MUICFG_Window_Spacing_Right | MUIV_List_Move_Active
MUIA_DoubleBuffer | MUICFG_Window_Spacing_Top | MUIV_List_Move_Bottom
MUIA_Draggable | MUIC_Floattext | MUIV_List_Move_Next
MUIA_Dropable | MUIC_Frameadjust | MUIV_List_Move_Previous
MUIA_Dtpic_Alpha | MUIC_Framedisplay | MUIV_List_Move_Top
MUIA_Dtpic_DarkenSelState | MUIC_Gadget | MUIV_List_NextSelected_End
MUIA_Dtpic_Fade | MUIC_Gauge | MUIV_List_NextSelected_Start
MUIA_Dtpic_LightenOnMouse | MUIC_Group | MUIV_List_Redraw_Active
MUIA_Dtpic_Name | MUIC_Image | MUIV_List_Redraw_All
MUIA_Family_Child | MUIC_Imageadjust | MUIV_List_Redraw_Entry
MUIA_Family_ChildCount | MUIC_Imagedisplay | MUIV_List_Remove_Active
MUIA_Family_List | MUIC_Knob | MUIV_List_Remove_First
MUIA_FillArea | MUIC_Levelmeter | MUIV_List_Remove_Last
MUIA_FixHeight | MUIC_List | MUIV_List_Remove_Selected
MUIA_FixHeightTxt | MUIC_Listview | MUIV_List_Select_Active
MUIA_FixWidth | MUIC_Mccprefs | MUIV_List_Select_All
MUIA_FixWidthTxt | MUIC_Menu | MUIV_List_Select_Ask
MUIA_Floattext_Justify | MUIC_Menuitem | MUIV_List_Select_Off
MUIA_Floattext_SkiPChars | MUIC_Menustrip | MUIV_List_Select_On
MUIA_Floattext_TabSize | MUIC_Notify | MUIV_List_Select_Toggle
MUIA_Floattext_Text | MUIC_Numeric | MUIV_Listview_DragType_Immediate
MUIA_Font | MUIC_Numericbutton | MUIV_Listview_DragType_None
MUIA_Frame | MUIC_Palette | MUIV_Listview_MultiSelect_Always
MUIA_Frameadjust_Spec | MUIC_Penadjust | MUIV_Listview_MultiSelect_Default
MUIA_Framedisplay_Spec | MUIC_Pendisplay | MUIV_Listview_MultiSelect_None
MUIA_FramePhantomHoriz | MUIC_Pixmap | MUIV_Listview_MultiSelect_Shifted
MUIA_FrameTitle | MUIC_Popasl | MUIV_Listview_ScrollerPos_Default
MUIA_Gadget_Gadget | MUIC_Popframe | MUIV_Listview_ScrollerPos_Left
MUIA_Gauge_Current | MUIC_Popimage | MUIV_Listview_ScrollerPos_None
MUIA_Gauge_Divide | MUIC_Poplist | MUIV_Listview_ScrollerPos_Right
MUIA_Gauge_DupInfoText | MUIC_Popobject | MUIV_Menuitem_Shortcut_Check
MUIA_Gauge_Horiz | MUIC_Poppen | MUIV_NList_SelectChange_Flag_Multi
MUIA_Gauge_InfoText | MUIC_Popscreen | MUIV_Notify_Application
MUIA_Gauge_Max | MUIC_Popstring | MUIV_Notify_Parent
MUIA_Group_ActivePage | MUIC_Process | MUIV_Notify_ParentParent
MUIA_Group_Child | MUIC_Prop | MUIV_Notify_ParentParentParent
MUIA_Group_ChildList | MUIC_Radio | MUIV_Notify_Self
MUIA_Group_Columns | MUI_CreateCustomClass | MUIV_Notify_Window
MUIA_Group_Forward | MUIC_Rectangle | MUIV_NotTriggerValue
MUIA_Group_Horiz | MUIC_Register | MUIV_Palette_Entry_End
MUIA_Group_HorizSpacing | MUIC_Scale | MUIV_Pixmap_Compression_BZip2
MUIA_Group_LayoutHook | MUIC_Scrmodelist | MUIV_Pixmap_Compression_None
MUIA_Group_PageMode | MUIC_Scrollbar | MUIV_Pixmap_Compression_RLE
MUIA_Group_Rows | MUIC_Scrollbutton | MUIV_Pixmap_Format_ARGB32
MUIA_Group_SameHeight | MUIC_Scrollgroup | MUIV_Pixmap_Format_CLUT8
MUIA_Group_SameSize | MUIC_Semaphore | MUIV_Pixmap_Format_RGB24
MUIA_Group_SameWidth | MUIC_Settings | MUIV_Prop_UseWinBorder_Bottom
MUIA_Group_Spacing | MUIC_Settingsgroup | MUIV_Prop_UseWinBorder_Left
MUIA_Group_VertSpacing | MUIC_Slider | MUIV_Prop_UseWinBorder_None
MUIA_Group_Virtual | MUIC_String | MUIV_Prop_UseWinBorder_Right
MUIA_Height | MUIC_Text | MUIV_Scrollbar_Type_Bottom
MUIA_HelpLine | MUIC_Title | MUIV_Scrollbar_Type_Default
MUIA_HelpNode | MUIC_Virtgroup | MUIV_Scrollbar_Type_Sym
MUIA_HorizDisappear | MUIC_Volumelist | MUIV_Scrollbar_Type_Top
MUIA_HorizWeight | MUIC_Window | MUIV_String_BufferPos_End
MUIA_Imageadjust_Originator | MUI_DeleteCustomClass | MUIV_String_Format_Center
MUIA_Imageadjust_Spec | MUI_DisposeObject | MUIV_String_Format_Left
MUIA_Imageadjust_Type | MUI_EHF_ALWAYSKEYS | MUIV_String_Format_Right
MUIA_Imagedisplay_FreeHoriz | MUI_EHF_GUIMODE | MUIV_String_Insert_BufferPos
MUIA_Imagedisplay_FreeVert | MUI_EHF_ISACTIVE | MUIV_String_Insert_EndOfString
MUIA_Imagedisplay_Spec | MUI_EHF_ISACTIVEGRP | MUIV_String_Insert_StartOfString
MUIA_Imagedisplay_UseDefSize | MUI_EHF_ISCALLING | MUIV_TriggerValue
MUIA_Image_FontMatch | MUI_EHF_ISENABLED | MUIV_Window_ActiveObject_Next
MUIA_Image_FontMatchHeight | MUIE_InvalidWindowObject | MUIV_Window_ActiveObject_None
MUIA_Image_FontMatchWidth | MUIE_MissingLibrary | MUIV_Window_ActiveObject_Prev
MUIA_Image_FreeHoriz | MUI_EndRefresh | MUIV_Window_AltHeight_MinMax
MUIA_Image_FreeVert | MUIE_NoARexx | MUIV_Window_AltHeight_Scaled
MUIA_Image_OldImage | MUIE_OK | MUIV_Window_AltHeight_Screen
MUIA_Image_Spec | MUIE_OutOfGfxMemory | MUIV_Window_AltHeight_Visible
MUIA_Image_State | MUIE_OutOfMemory | MUIV_Window_AltLeftEdge_Centered
MUIA_InnerBottom | MUI_Error | MUIV_Window_AltLeftEdge_Moused
MUIA_InnerLeft | MUIE_SingleTask | MUIV_Window_AltLeftEdge_NoChange
MUIA_InnerRight | MUI_EventHandlerRC_Eat | MUIV_Window_AltTopEdge_Centered
MUIA_InnerTop | MUIF_DRAGIMAGE_HASMASK | MUIV_Window_AltTopEdge_Delta
MUIA_InputMode | MUIF_DRAGIMAGE_SOURCEALPHA | MUIV_Window_AltTopEdge_Moused
MUIA_LeftEdge | MUI_FreeAslRequest | MUIV_Window_AltTopEdge_NoChange
MUIA_Levelmeter_Label | MUI_FreeClass | MUIV_Window_AltWidth_MinMax
MUIA_List_Active | MUIF_Slave_Delegate_ForceSlave | MUIV_Window_AltWidth_Scaled
MUIA_List_AdjustHeight | MUI_GetClass | MUIV_Window_AltWidth_Screen
MUIA_List_AdjustWidth | MUIGlobalInfo | MUIV_Window_AltWidth_Visible
MUIA_List_AutoVisible | MUI_Hide | MUIV_Window_Button_Iconify
MUIA_List_CompareHook | MUII_ArrowDown | MUIV_Window_Button_MUI
MUIA_List_ConstructHook | MUII_ArrowLeft | MUIV_Window_Button_Popup
MUIA_List_DestructHook | MUII_ArrowRight | MUIV_Window_Button_Snapshot
MUIA_List_DisplayHook | MUII_ArrowUp | MUIV_Window_Height_Default
MUIA_List_DragSortable | MUII_Assign | MUIV_Window_Height_MinMax
MUIA_List_DropMark | MUII_BACKGROUND | MUIV_Window_Height_Scaled
MUIA_List_Entries | MUII_ButtonBack | MUIV_Window_Height_Screen
MUIA_List_First | MUII_CheckMark | MUIV_Window_Height_Visible
MUIA_List_Format | MUII_Chip | MUIV_Window_LeftEdge_Centered
MUIA_List_InsertPosition | MUII_Close | MUIV_Window_LeftEdge_Moused
MUIA_List_MinLineHeight | MUII_Count | MUIV_Window_TopEdge_Centered
MUIA_List_MultiTestHook | MUII_Cycle | MUIV_Window_TopEdge_Delta
MUIA_List_Pool | MUII_Disk | MUIV_Window_TopEdge_Moused
MUIA_List_PoolPuddleSize | MUII_Drawer | MUIV_Window_Width_Default
MUIA_List_PoolThreshSize | MUII_FILL | MUIV_Window_Width_MinMax
MUIA_List_Quiet | MUII_FILLBACK | MUIV_Window_Width_Scaled
MUIA_List_ShowDropMarks | MUII_FILLBACK2 | MUIV_Window_Width_Screen
MUIA_List_SourceArray | MUII_FILLSHINE | MUIV_Window_Width_Visible
MUIA_List_Title | MUII_GaugeEmpty | MUIX_B
MUIA_Listview_ClickColumn | MUII_GaugeFull | MUIX_C
MUIA_Listview_DefClickColumn | MUII_GroupBack | MUIX_I
MUIA_Listview_DoubleClick | MUII_GroupTitle | MUIX_L
MUIA_Listview_DragType | MUII_HardDisk | MUIX_N
MUIA_Listview_Input | MUIIHNF_TIMER | MUIX_PH
MUIA_Listview_List | MUIIHNF_TIMER_SCALE10 | MUIX_PT
MUIA_Listview_MultiSelect | MUIIHNF_TIMER_SCALE100 | MUIX_R
MUIA_Listview_ScrollerPos | MUII_HSHADOWBACK | MUIX_U
MUIA_Listview_SelectChange | MUII_HSHADOWSHADOW | MULTIPLY_DIMENSIONS
MUIA_List_Visible | MUII_HSHINEBACK | MUSTDRAW
MUI_AllocAslRequest | MUII_HSHINESHINE | MutexAttempt
MUI_AllocAslRequestTags | MUII_ImageButtonBack | MutexAttemptWithSignal
MUIA_MaxHeight | MUII_ImageSelectedBack | MutexObtain
MUIA_MaxWidth | MUII_LASTPAT | MutexRelease
MUIA_Menu_Enabled | MUII_ListBack | MVP_NO_DISPLAY
MUIA_Menuitem_Checked | MUII_ListCursor | MVP_NO_DSPINS
MUIA_Menuitem_Checkit | MUII_ListSelCur | MVP_NO_MEM
MUIA_Menuitem_CommandString | MUII_ListSelect | MVP_NO_VPE
MUIA_Menuitem_Enabled | MUII_ListTitle | MVP_OFF_BOTTOM
MUIA_Menuitem_Exclude | MUII_MARKBACKGROUND | MVP_OK
MUIA_Menuitem_NewMenu | MUII_MARKHALFSHINE | MXIMAGE
MUIA_Menuitem_Shortcut | MUII_MARKSHINE |
MUIA_Menuitem_Title | MUII_Menudisplay |

N

NamedObjectName | NP_Cli | NSCODE_FINAL
NameFromFH | NP_CloseError | NSCODE_INTERIM
NameFromLock | NP_CloseInput | NS_EXTENDED
NameFromPort | NP_CloseOutput | NSF_CASE
NBM_ADDDOSENTRY | NP_CommandName | NSF_NODUPS
NBM_CHANGESIGNAL | NP_ConsolePort | NSR_Arg1
NBM_DISKINSERTED | NP_ConsoleTask | NSR_Arg2
NBM_DISKREMOVED | NP_CopyVars | NSR_Arg3
NBM_REMDOSENTRY | NP_CurrentDir | NSR_Arg4
NBM_REMFREEDOSENTRY | NP_Dummy | NSR_Arg5
NBM_RENAMEDOSENTRY | NP_Entry | NSR_Arg6
NDLC_END | NP_EntryCode | NSR_Dummy
NewDiskObject | NP_EntryData | NSR_LockStack
NewDTObject | NP_Error | NSR_MinStackSize
NewDTObjectA | NP_ExitCode | NSR_StackSize
NewFontContents | NP_ExitData | NSTAG_EXT_VPMODE
NewLayerInfo | NP_FinalCode | NT_BOOTNODE
NEWLAYERINFO_CALLED | NP_FinalData | NT_CLASS
NewList | NP_FreeSeglist | NT_DEATHMESSAGE
NewListType | NP_Input | NT_DEVICE
NewMinList | NPLC_END | NT_ELFHANDLE
NewModifyProp | NP_LocalAlias | NT_EXTENDED
NewObject | NP_LocalVars | NT_EXTINTERRUPT
NewObjectA | NP_LockStack | NT_EXTSOFTINT
NewRegion | NP_Name | NT_FILESYSTEM
NewScaledDiskFont | NP_NotifyOnDeathMessage | NT_FONT
NewStackRun | NP_NotifyOnDeathSignalBit | NT_FREEMSG
NextDisplayInfo | NP_NotifyOnDeathSigTask | NT_GRAPHICS
NextDosEntry | NP_Output | NT_INTERFACE
NextObject | NP_OwnerGID | NT_INTERRUPT
NextPubScreen | NP_OwnerUID | NT_KICKMEM
NextTagItem | NP_Path | NT_KMEMCACHE
NHM_ACTION_ADD | NP_Priority | NT_LIBRARY
NHM_ACTION_CHANGE | NP_ProgramDir | NT_MEMORY
NHM_ACTION_DELETE | NP_Seglist | NT_MESSAGE
NHM_ACTION_INITIAL | NP_StackSize | NT_MSGPORT
NM_Dummy | NP_unused1 | NT_PAGE
NM_Item | NP_unused2 | NT_PROCESS
NML_CAS | NP_UserData | N_TRACTOR
NM_Menu | NP_WindowPtr | NT_REPLYMSG
NM_SubItems | NRB_CALL_HOOK | NT_RESERVED1
NOCROSSFILL | NRB_DOS_NOTIFY_ONLY | NT_RESOURCE
NO_ICON_POSITION | NRB_MAGIC | NTSC
NOISYREQ | NRB_NOTIFY_INITIAL | NTSC_MONITOR_ID
NOITEM | NRB_SEND_MESSAGE | NTSC_MONITOR_NAME
NOMENU | NRB_SEND_SIGNAL | NT_SEMAPHORE
NO_MENU_ID | NRB_WAIT_REPLY | NT_SIGNALSEM
NonBlockingModifyDosEntry | NRF_CALL_HOOK | NT_SOFTINT
NOREQBACKFILL | NRF_DOS_NOTIFY_ONLY | NT_SOLIBHANDLE
NOSTR | NRF_MAGIC | NT_TASK
NOSUB | NRF_NOTIFY_INITIAL | NT_UNKNOWN
NOTIFY_CLASS | NRF_SEND_MESSAGE | NT_USER
NOTIFY_CODE | NRF_SEND_SIGNAL | NT_VMAREA
NotifyDosListChange | NRF_WAIT_REPLY | NT_VMAREA_PROXY
NotifyProcListChange | NR_HANDLER_FLAGS | NUMDRIPENS
NotifyVar | NR_HANDLER_MASK | _OBJ
NP_Arguments | NSB_CASE |
NP_Child | NSB_NODUPS |

O

OBJ_AddLeft | OM_GET | OTF_Type42
OBJ_AddTop | OM_NEW | OTF_WinFonts
OBJ_App | OM_NOTIFY | OT_GlyphCode
OBJ_Between | OM_REMMEMBER | OT_GlyphCode2
OBJ_Bottom | OM_REMOVE | OT_GlyphCode2_32
OBJ_DefHeight | OM_SET | OT_GlyphCode_32
OBJ_DefWidth | OM_UPDATE | OT_GlyphMap
OBJ_Dri | ONE_DOT | OT_GlyphMap8Bit
__OBJECT | OnGadget | OT_GlyphMap8BitLCD
LongWord | OnMenu | OT_GlyphMap8BitLCDV
OBJ_Flags | OpenCatalog | OT_GlyphName
OBJ_Font | OpenCatalogA | OT_GlyphWidth
OBJ_Height | OpenClass | OT_HasGlyphs
OBJ_IsInObject | OpenClipboard | OTH_Compressed
OBJ_Left | OpenDevice | OTH_Condensed
OBJ_MaxHeight | OpenDiskFont | OTH_Expanded
OBJ_MaxWidth | OpenFont | OTH_ExtraCompressed
OBJ_MBottom | OpenFromLock | OTH_ExtraExpanded
OBJ_MHeight | OpenGUIPlugin | OTH_Normal
OBJ_MinHeight | OpenIFF | OT_HorizStyle
OBJ_MinWidth | OpenIntuition | OTH_SemiExpanded
OBJ_MLeft | OpenKeyMapHandleA | OTH_UltraCompressed
OBJ_MRight | OpenLibrary | OT_IName
OBJ_MTop | OpenLocale | OT_Indirect
OBJ_MWidth | OpenMonitor | OT_InhibitAlgoStyle
OBJ_Pens | OpenOutlineFont | OT_IsFixed
OBJ_Right | OPENQUOTE | OT_IsUnderlined
OBJ_Rp | OpenResource | OT_Level0
OBJ_Screen | OpenScreen | OT_Level1
OBJ_SubHeight | OpenScreenTagList | OT_Level2
OBJ_SubWidth | OpenScreenTags | OT_Level3
OBJ_Top | OpenWindow | OT_MAXAVAILSIZES
OBJ_Width | OpenWindowTagList | OT_MemPtr
OBJ_Win | OpenWindowTags | OT_MemSize
OBJ_Window | OpenWorkBench | OT_MetricsFile
OBP_FailIfBad | OpenWorkbenchObject | OT_NumGlyphs
OBP_Precision | OpenWorkbenchObjectA | OT_NumKernPairs
ObtainBestPen | OPUF_INTERIM | OT_OTagList
ObtainBestPenA | ORDERED_DITHERING | OT_OTagPath
ObtainBitMapInstanceA | OrRectRegion | OT_PointHeight
ObtainBitMapSourceA | OrRegionRegion | OT_PointSize
ObtainCharsetInfo | OSCAN_MAX | OT_RName
ObtainDataType | OSCAN_STANDARD | OT_RotateCos
ObtainDataTypeA | OSCAN_TEXT | OT_RotateSin
ObtainDirContext | OSCAN_VIDEO | OTS_Black
ObtainDTDrawInfo | OSERR_ATTACHFAIL | OTS_Bold
ObtainDTDrawInfoA | OSERR_BADBITMAP | OTS_Book
ObtainGIRPort | OSERR_NOCHIPMEM | OTS_DemiBold
ObtainIBackFill | OSERR_NOCHIPS | OTS_DemiLight
ObtainIPluginList | OSERR_NOMEM | OT_SerifFlag
ObtainKeyMapInfoA | OSERR_NOMONITOR | OT_SetFactor
ObtainPen | OSERR_NOTAVAILABLE | OTS_ExtraBlack
ObtainQuickVector | OSERR_PUBNOTUNIQUE | OTS_ExtraBold
ObtainRawKeyInfoA | OSERR_TOODEEP | OTS_ExtraLight
ObtainSemaphore | OSERR_UNKNOWNMODE | OTS_ExtraThin
ObtainSemaphoreList | OT_AFMFile | OT_ShearCos
ObtainSemaphoreShared | OT_AvailSizes | OT_ShearSin
ObtainTTextAttr | OT_BaseLine | OTS_Italic
OC_BuiltInCodeSet | OT_BIName | OT_SlantStyle
OC_BuiltInLanguage | OT_BMSize | OTS_LeftItalic
OC_BuiltInVersion | OT_BName | OTS_Light
OCD_Dummy | OT_DesignKernPair | OTS_Medium
OCD_FileHandleInput | OT_DeviceDPI | OT_SpaceFactor
OCD_MsgPortInput | OT_DotSize | OT_SpaceWidth
OC_Language | OTE_Bullet | OT_Spec
OCLASS | OT_EmboldenX | OT_Spec1
OC_PreferExternal | OT_EmboldenY | OT_SpecCount
OC_TagBase | OT_Engine | OTS_SemiBold
OC_Version | OTERR_BadData | OTS_SemiLight
OC_WantedCodeSet | OTERR_BadFace | OT_StemWeight
OFB_OPEN | OTERR_BadGlyph | OTS_Thin
OFCH_ID | OTERR_BadTag | OT_StrikeThrough
OffGadget | OTERR_Failure | OTSUFFIX
OffMenu | OTERR_NoFace | OTS_UltraBlack
OFF_OPEN | OTERR_NoGlyph | OTS_UltraThin
OFFSET_BEGINNING | OTERR_NoMemory | OTS_Upright
OFFSET_CURRENT | OTERR_NoRotate | OT_TextKernPair
OFFSET_END | OTERR_NoShear | OTUL_Broken
OI_Dummy | OTERR_Success | OTUL_DoubleBroken
OI_OwnerGID | OTERR_TooSmall | OTUL_DoubleSolid
OI_OwnerUID | OTERR_UnknownGlyph | OTUL_None
OI_Process | OTERR_UnknownTag | OTUL_Solid
OI_ProcessInput | OT_Family | OT_UnderLined
OI_StringName | OTF_BDF | OT_UnicodeRanges
OI_StringNameInput | OTF_CFF | OT_WidthList
OKABORT | OT_FileIdent | OT_WidthList32
OKCANCEL | OTF_Intellifont | OT_YSizeFactor
OKIMATE_20 | OT_FontFile | OUTL_DoubleBroken
OKOK | OT_FontFormat | OUTSTEP
OLDDRAWERDATAFILESIZE | OTF_PCF | OVERLAY
OM_ADDMEMBER | OTF_PFR | OwnBlitter
OM_ADDTAIL | OTF_TrueType | OwnerOfMem
OM_DISPOSE | OTF_Type1 |
OM_Dummy | OTF_Type1CID |

P

p96AllocBitMap | PDTA_UseFriendBitMap | PMUIP_List_NextSelected
p96AllocModeListTagList | PDTA_WhichPicture | PMUIP_List_Redraw
p96AllocModeListTags | PdtDraw | PMUIP_List_Remove
P96Base | PdtFrameBox | PMUIP_List_Select
P96BD_BoardDriver | Pdt_frame_image | PMUIP_List_Sort
P96BD_BoardName | PdtGeneral | PMUIP_List_TestPos
P96BD_ChipDriver | PdtGoto | PMUIP_MultiSet
P96BD_ChipName | PDTM_Dummy | PMUIP_NoNotifySet
P96BD_Dummy | PDTMethod | PMUIP_Notify
P96BD_FreeMemory | PDTM_READPIXELARRAY | PMUIP_Numeric_Decrease
P96BD_InternalMemorySize | PDTM_WRITEPIXELARRAY | PMUIP_Numeric_Increase
P96BD_LargestFreeMemory | PdtSelect | PMUIP_Numeric_ScaleToValue
P96BD_MemoryClock | PDTSpecialInfo | PMUIP_Numeric_SetDefault
P96BD_MonitorDisplayHeight | PdtTrigger | PMUIP_Numeric_Stringify
P96BD_MonitorDisplayWidth | PdtWrite | PMUIP_Numeric_ValueToScale
P96BD_MonitorDotClockMax | P__dummyAreaData__ | PMUIP_Numeric_ValueToScaleExt
P96BD_MonitorDotClockMin | PEasyStruct | PMUIP_Pendisplay_SetColormap
P96BD_MonitorEDIDRev | PEClockVal | PMUIP_Pendisplay_SetMUIPen
P96BD_MonitorEDIDVer | PEGlyphEngine | PMUIP_Pendisplay_SetRGB
P96BD_MonitorHSyncMax | PEN_ALPHA | PMUIP_Popstring_Close
P96BD_MonitorHSyncMin | PEN_ALPHASHADOW | PMUIP_Popstring_Open
P96BD_MonitorInputType | PEN_ALPHASHINE | PMUIP_Prop_Decrease
P96BD_MonitorProduct | PENB_EXCLUSIVE | PMUIP_Prop_Increase
P96BD_MonitorProductID | PENB_NO_SETCOLOR | PMUIP_Semaphore_Attempt
P96BD_MonitorSwitch | PEN_BRIGHT | PMUIP_Semaphore_AttemptShared
P96BD_MonitorVendorID | PEN_C0 | PMUIP_Semaphore_Obtain
P96BD_MonitorVSyncMax | PEN_C1 | PMUIP_Semaphore_ObtainShared
P96BD_MonitorVSyncMin | PEN_C2 | PMUIP_Semaphore_Release
P96BD_PCIProductID | PEN_C3 | PMUIP_Set
P96BD_PCIVendorID | PEN_DARK | PMUIP_SetAsString
P96BD_RGBFormats | PEN_EXCLUSIVE | PMUIP_Settingsgroup_ConfigToGadgets
P96BD_TotalMemory | PENF_EXCLUSIVE | PMUIP_Settingsgroup_GadgetsToConfig
p96BestModeIDTagList | PENF_NO_SETCOLOR | PMUIP_SetUData
p96BestModeIDTags | PEN_HALFBRIGHT | PMUIP_SetUDataOnce
P96BIDTAG_Depth | PEN_HALFDARK | PMUIP_Setup
P96BIDTAG_Dummy | PEN_NO_SETCOLOR | PMUIP_Show
P96BIDTAG_FormatsAllowed | PENSHARED | PMUIP_String_ClearSelected
P96BIDTAG_FormatsForbidden | Permit | PMUI_PubScreenDesc
P96BIDTAG_NominalHeight | pErrorString | PMUIP_UnknownDropDestination
P96BIDTAG_NominalWidth | PExAllControl | PMUIP_Window_ActionIconify
P96BIDTAG_PabloIVCompatible | PExAllData | PMUIP_Window_AddControlCharHandler
P96BIDTAG_PalomaIVCompatible | PExamineData | PMUIP_Window_AddEventHandler
P96BIDTAG_VideoCompatible | PExceptionContext | PMUIP_Window_AllocGadgetID
P96BMA_BITSPERPIXEL | PExecBase | PMUIP_Window_Cleanup
P96BMA_BOARDIOBASE | PExtendedDeadKey | PMUIP_Window_DragObject
P96BMA_BOARDMEMBASE | PExtendedNode | PMUIP_Window_DrawBackground
P96BMA_BOARDMEMIOBASE | PExtGadget | PMUIP_Window_FreeGadgetID
P96BMA_BYTESPERPIXEL | PExtIntuiMessage | PMUIP_Window_RecalcDisplay
P96BMA_BYTESPERROW | PExtNewScreen | PMUIP_Window_RemControlCharHandler
P96BMA_DEPTH | PExtNewWindow | PMUIP_Window_RemEventHandler
P96BMA_HEIGHT | PExtSprite | PMUIP_Window_ScreenToBack
P96BMA_ISONBOARD | PF2PRI | PMUIP_Window_ScreenToFront
P96BMA_ISP96 | PF_ACTION | PMUIP_Window_Setup
P96BMA_MEMORY | PFA_FINE_SCROLL | PMUIP_Window_Snapshot
P96BMA_RGBFORMAT | PFBA | PMUIP_Window_ToBack
P96BMA_WIDTH | PFB_FINE_SCROLL_SHIFT | PMUIP_Window_ToFront
p96Clone | PF_FINE_SCROLL_MASK | PMUIP_WriteLong
p96CloseScreen | PFileHandle | PMUIP_WriteString
p96EncodeColor | PFileInfoBlock | PMUI_RenderInfo
p96Expunge | pFileLock | PMUI_RGBColor
p96FreeBitMap | PFileRequester | PMUIS_InfoClient
p96FreeModeList | PFileSysStartupMsg | PMultiAssign
p96GetBitMapAttr | PFileSystemData | PNamedObject
p96GetBoardDataTagList | PFileSystemVectorPort | PNameInfo
p96GetBoardDataTags | PFileSystemVectors | PNewScreen
p96GetModeIDAttr | PFindTrackedAddressMsg | PNewWindow
p96GetRTGDataTagList | PFontContents | PNode
p96GetRTGDataTags | PFontContentsHeader | P_NOT
P96IDA_BITSPERPIXEL | PFontRequester | P_NOTCLASS
P96IDA_BOARDNAME | PFrameInfo | P_NOTEND
P96IDA_BOARDNUMBER | PFReadLineData | PNotifyHookMsg
P96IDA_BYTESPERPIXEL | PFreeList | PNotifyMessage
P96IDA_COMPATIBLEFORMATS | PF_SIGALLOC | PNotifyRequest
P96IDA_DEPTH | PGA_ArrowDelta | P_Object
P96IDA_HEIGHT | PGA_ArrowDown | PObject_
P96IDA_ISP96 | PGA_Borderless | POINTERA_BitMap
P96IDA_PABLOIVCOMPATIBLE | PGadget | POINTERA_Dummy
P96IDA_PALOMAIVCOMPATIBLE | PGadgetGeometryMsg | POINTERA_Height
P96IDA_RGBFORMAT | PGadgetInfo | POINTERA_ImageData
P96IDA_STDBYTESPERROW | PGA_Dummy | POINTERA_Width
P96IDA_VIDEOCOMPATIBLE | PGA_Freedom | POINTERA_WordWidth
P96IDA_WIDTH | PGA_HorizBody | POINTERA_XOffset
p96LockBitMap | PGA_HorizPot | POINTERA_XResolution
p96LockBitMapToBoard | PGA_NewLook | POINTERA_YOffset
P96MA_CancelText | PGA_Top | POINTERA_YResolution
P96MA_DisplayID | PGA_Total | POINTERCLASS
P96MA_Dummy | PGA_VertBody | POINTERSIZE
P96MA_FormatsAllowed | PGA_VertPot | POINTERTYPE_ALIAS
P96MA_FormatsForbidden | PGA_Visible | POINTERTYPE_BUSY
P96MA_MaxDepth | PGelsInfo | POINTERTYPE_CELL
P96MA_MaxHeight | PGfxBase | POINTERTYPE_COLUMNRESIZE
P96MA_MaxWidth | PGlyphEngine | POINTERTYPE_CONTEXTMENU
P96MA_MinDepth | PGlyphMap | POINTERTYPE_COPY
P96MA_MinHeight | PGlyphWidthEntry | POINTERTYPE_COUNT
P96MA_MinWidth | PGlyphWidthEntry32 | POINTERTYPE_CROSS
P96MA_OKText | PgpDomain | POINTERTYPE_DRAGANDDROP
P96MA_PabloIVCompatible | PgpExtent | POINTERTYPE_EASTRESIZE
P96MA_PalomaIVCompatible | PgpGoInactive | POINTERTYPE_EASTWESTRESIZE
P96MA_PubScreenName | PgpHitTest | POINTERTYPE_HAND
P96MA_Screen | PgpInput | POINTERTYPE_HELP
P96MA_VideoCompatible | PgpKeyGoInactive | POINTERTYPE_LINK
P96MA_Window | PgpKeyInput | POINTERTYPE_MENU
P96MA_WindowTitle | PgpKeyTest | POINTERTYPE_NODROP
p96Obtain | PgpLayout | POINTERTYPE_NONE
p96OpenScreenTagList | PgpMenuEvent | POINTERTYPE_NORMAL
p96OpenScreenTags | PgpQuery | POINTERTYPE_NORTHEASTRESIZE
P96PIP_Alignment | PgpRender | POINTERTYPE_NORTHEASTSOUTHWESTRESIZE
P96PIP_AllowCropping | PGradientSpec | POINTERTYPE_NORTHRESIZE
P96PIP_Brightness | PGUIPlugin | POINTERTYPE_NORTHSOUTHRESIZE
P96PIP_ClipHeight | PHook | POINTERTYPE_NORTHWESTRESIZE
P96PIP_ClipLeft | PIBox | POINTERTYPE_NORTHWESTSOUTHEASTRESIZE
P96PIP_ClipTop | PICA | POINTERTYPE_NOTALLOWED
P96PIP_ClipWidth | picasso96api | POINTERTYPE_PEN
p96PIP_Close | PICASSO96APINAME | POINTERTYPE_PROGRESS
P96PIP_ColorKeyARGB | PIClass | POINTERTYPE_ROTATE
P96PIP_ColorKeyPen | PIconIdentifyMsg | POINTERTYPE_ROWRESIZE
P96PIP_Colors | PIconSelectMsg | POINTERTYPE_RUBBER
P96PIP_Colors32 | PICTUREDTCLASS | POINTERTYPE_SCROLLALL
P96PIP_ConstantBytesPerRow | PIENewTablet | POINTERTYPE_SELECT
P96PIP_ConstantByteSwapping | PIEPointerPixel | POINTERTYPE_SMUDGE
P96PIP_DisplayedBuffer | PIEPointerTablet | POINTERTYPE_SOUTHEASTRESIZE
P96PIP_Dummy | PIFFHandle | POINTERTYPE_SOUTHRESIZE
P96PIP_ErrorCode | PIFFStreamCmd | POINTERTYPE_SOUTHWESTRESIZE
p96PIP_GetIMsg | PImage | POINTERTYPE_TEXT
p96PIP_GetTagList | PImageGeometryMsg | POINTERTYPE_VERTICALTEXT
p96PIP_GetTags | PimpDomainFrame | POINTERTYPE_WESTRESIZE
P96PIP_Height | PimpDraw | POINTERTYPE_ZOOMIN
P96PIP_InitialIntScaling | PimpErase | POINTERTYPE_ZOOMOUT
P96PIP_Left | PimpExtent | POINTERXRESN_140NS
P96PIP_NoMemory | PimpFrameBox | POINTERXRESN_35NS
P96PIP_NumberOfBuffers | PimpHitTest | POINTERXRESN_70NS
p96PIP_OpenTagList | PInfoData | POINTERXRESN_DEFAULT
p96PIP_OpenTags | PInputEvent | POINTERXRESN_HIRES
P96PIP_Relativity | PInterface | POINTERXRESN_LORES
P96PIP_RenderFunc | PInterrupt | POINTERXRESN_SCREENRES
p96PIP_ReplyIMsg | PIntuiMessage | POINTERYRESN_DEFAULT
P96PIP_SaveFunc | PIntuiRawKeyData | POINTERYRESN_HIGH
p96PIP_SetTagList | PIntuiText | POINTERYRESN_HIGHASPECT
p96PIP_SetTags | PIntuitionBase | POINTERYRESN_SCREENRES
P96PIP_SourceBitMap | PIntuiWheelData | POINTERYRESN_SCREENRESASPECT
P96PIP_SourceFormat | PIntVector | PointInImage
P96PIP_SourceHeight | PIOClipReq | POINTREL
P96PIP_SourceRPort | PIOExtSer | POldDrawerData
P96PIP_SourceWidth | PIORequest | PolyDraw
P96PIPT_MemoryWindow | PIOStdReq | PopAddTail
P96PIP_Top | PIOTArray | PopChunk
P96PIPT_VideoWindow | PIPERR_ATTACHFAIL | PopGet
P96PIP_Type | PIPERR_BADALIGNMENT | PopMember
P96PIP_UserData | PIPERR_BADDIMENSIONS | POPPUBSCREEN
P96PIP_VisibleBuffer | PIPERR_CROPPED | PopSet
P96PIP_Width | PIPERR_NOMEMORY | PopUpdate
P96PIP_WorkBuffer | PIPERR_NOTAVAILABLE | POPUPIMAGE
P96RD_Dummy | PIPERR_NOWINDOW | P_OREND
P96RD_NumberOfBoards | PIPERR_OUTOFPENS | P_ORNEXT
p96ReadPixel | PIPRel_Bottom | P_ORSTART
p96ReadPixelArray | PIPRel_Height | POutlineFont
p96ReadTrueColorData | PIPRel_Right | PP96Mode
p96RectFill | PIPRel_Width | PPaletteExtra
p96Release | PIPT_MemoryWindow | PPAnimOb
p96RequestModeIDTagList | PIPT_NUMTYPES | PPathNode
p96RequestModeIDTags | PIPT_VideoWindow | PPAVLNode
P96SA_Alignment | PIsrvstr | PPGX
P96SA_AutoScroll | PIXEL_DIMENSIONS | PPlanarYUVInfo
P96SA_BackFill | PIXF_A8B8G8R8 | PPObject_
P96SA_Behind | PIXF_A8R8G8B8 | PPoint
P96SA_BitMap | PIXF_ALPHA8 | PPreferences
P96SA_BlockPen | PIXF_B5G5R5PC | PProcess
P96SA_Colors | PIXF_B5G6R5PC | PPropInfo
P96SA_Colors32 | PIXF_B8G8R8 | PPseudoSegList
P96SA_ConstantBytesPerRow | PIXF_B8G8R8A8 | PPTagItem
P96SA_ConstantByteSwapping | PIXF_CLUT | PPubScreenNode
P96SA_DClip | PIXFMT_ARGB32 | PQueryHeader
P96SA_Depth | PIXFMT_BGR15 | PRandomState
P96SA_DetailPen | PIXFMT_BGR15PC | PRasInfo
P96SA_DisplayID | PIXFMT_BGR16 | PRastPort
P96SA_Dummy | PIXFMT_BGR16PC | PRastPortExtra
P96SA_ErrorCode | PIXFMT_BGR24 | PRB_CHILDPROCESS
P96SA_Exclusive | PIXFMT_BGRA32 | PRB_CLOSEERROR
P96SA_FixedScreen | PIXFMT_LUT8 | PRB_CLOSEINPUT
P96SA_Font | PIXFMT_RGB15 | PRB_CLOSEOUTPUT
P96SA_Height | PIXFMT_RGB15PC | PRB_EXTENDED_FLAGS
P96SA_Left | PIXFMT_RGB16 | PRB_FREEARGS_OBSOLETE
P96SA_NoMemory | PIXFMT_RGB16PC | PRB_FREECLI
P96SA_NoSprite | PIXFMT_RGB24 | PRB_FREECURRDIR
P96SA_Pens | PIXFMT_RGBA32 | PRB_FREESEGLIST
P96SA_PubName | PIXF_NONE | PRB_HADCHILDREN
P96SA_PubSig | PIXF_R5G5B5 | PRB_HANDLERPROCESS
P96SA_PubTask | PIXF_R5G5B5PC | PRB_HASDLNOTIFY
P96SA_Quiet | PIXF_R5G6B5 | PRB_HASPLNOTIFY
P96SA_RenderFunc | PIXF_R5G6B5PC | PRB_LOCKSTACK
P96SA_RGBFormat | PIXF_R8G8B8 | PRB_SERVERPROCESS
P96SA_SaveFunc | PIXF_R8G8B8A8 | PRB_SHELLPROCESS
P96SA_SharePens | PIXF_YUV410P | PRB_spare08
P96SA_ShowTitle | PIXF_YUV411 | PRB_spare09
P96SA_SysFont | PIXF_YUV420P | PRB_spare10
P96SA_Title | PIXF_YUV422 | PRB_spare11
P96SA_Top | PIXF_YUV422CGX | PRB_spare12
P96SA_Type | PIXF_YUV422PA | PRB_spare13
P96SA_UserData | PIXF_YUV422PC | PRB_spare14
P96SA_VideoControl | PKCTRL_BIT | PRB_spare15
P96SA_Width | PKCTRL_BYTE | PRB_spare16
p96UnlockBitMap | PKCTRL_FLIPBIT | PRB_spare17
p96UnlockBitMapFromBoard | PKCTRL_LONG | PRB_spare18
p96WritePixel | PKCTRL_PACKONLY | PRB_spare19
p96WritePixelArray | PKCTRL_PACKUNPACK | PRB_spare20
p96WriteTrueColorData | PKCTRL_UBYTE | PRB_spare21
PAATextFont | PKCTRL_ULONG | PRB_spare22
PAChain | PKCTRL_UNPACKONLY | PRB_spare23
PackBoolTags | PKCTRL_UWORD | PRDArgs
PACK_ICON_ASPECT_RATIO | PKCTRL_WORD | PRECISION_EXACT
PackStructureTags | PKeyMap | PRECISION_GUI
PAddressAndSize | PKeymapNode | PRECISION_ICON
PADLOCKIMAGE | PKeyMapResource | PRECISION_IMAGE
PadtFrame | PLayer | PRecordLock
PadtNewFormatFrame | PLayerComposeMsg | PRect32
PadtStart | PLayer_Info | PRectangle
PageBackendAlloc | PLibrary | PREDRAWN
PageBackendAllocAligned | PLine | PRegion
PageBackendFree | PList | PRegionRectangle
PageBackendLock | PLNCNTMSK | PRemember
PageBackendUnlock | PLNCNTSHFT | PRenderInfo
PageDrop | PLocalContextItem | PRenderMsg
PageFindByVA | PLocale | P_REPBEG
PageGet | PLocaleBase | P_REPEND
PageHash | PLocalVar | PRequester
PageMap | PLock | PRESERVE_COLORS
PageMapAligned | PLONG | PResident
PagerAssignPager | PLONGBITS | PRF_CHILDPROCESS
PagerFindPageOut | PLUGIN_SYSI | PRF_CLOSEERROR
PagerPageIn | PMB_ASM | PRF_CLOSEINPUT
PagerPageOut | PMB_AWM | PRF_CLOSEOUTPUT
PageUnhash | PMemChunk | PRF_EXTENDED_FLAGS
PageUnmap | PMemEntry | PRF_FREEARGS_OBSOLETE
PA_IGNORE | PMemHandlerData | PRF_FREECLI
PA_INTERNAL | PMemHeader | PRF_FREECURRDIR
PAL | PMemList | PRF_FREESEGLIST
PALETTELOCK_IGNORE | PMenu | PRF_HADCHILDREN
PALETTERGB_IGNORE | PMenuEventMessage | PRF_HANDLERPROCESS
PAL_MONITOR_ID | PMenuItem | PRF_HASDLNOTIFY
PAL_MONITOR_NAME | PMenuScanMessage | PRF_HASPLNOTIFY
PAlphaHookMsg | PMenuStringMessage | PRF_LOCKSTACK
PAnalogSignalInterval | PMessage | PRF_SERVERPROCESS
PAnchorPath | PMessageDigest_SHA | PRF_SHELLPROCESS
PAnchorPathOld | PMinList | PRIMARY_CLIP
PAnimComp | PMinNode | PrintDTObject
PAnimHeader | PMODE_V42 | PrintDTObjectA
PAnimOb | PMODE_V43 | PrintEmbossedDisabledIText
P_ANY | PMonitorInfo | PrintFault
PAppIcon | PMonitorSpec | PrintIText
PAppIconRenderMsg | PmpDeleteMenu | ProcessScan
PAppMenu | PmpFindID | Procure
PAppMenuItem | PmpGetState | pRootNode
PAppMessage | PmpHandleEvent | PROPBORDERLESS
PAppWindow | PmpNewMenu | PropChunk
PAppWindowDropZone | PmpNextChild | PropChunks
PAppWindowDropZoneMsg | PmpNextSelect | PROPGCLASS
PAPTR | PmpScan | PROPNEWLOOK
PARALLEL_PRINTER | PmpSetState | PROTO_MONITOR_ID
PAreaInfo | PmpSetup | PSatisfyMsg
ParentChunk | PMsg | PScreen
ParentDir | PMsgPort | PScreenBuffer
ParentOfFH | PM_STR | PScreenModeRequester
ParseCapturePattern | PMUI_AreaData | PScreenNotifyMessage
ParseDate | PMUI_BoopsiQuery | PScrollHook
ParseIFF | PMUI_Command | PScrollMsg
ParsePattern | PMUI_CustomClass | PSD_FILENAME_SAVE
ParsePatternNoCase | PMUI_DragImage | PSD_FILENAME_USE
PA_SIGNAL | PMUI_EventHandlerNode | PSD_INITIAL_NAME
PASLSemaphore | PMUI_FrameSpec | PSD_INITIAL_TITLE
PA_SOFTINT | PMUI_GlobalInfo | PSD_MAXLEN_BACKGROUND
pAssignList | PMUI_ImageSpec_intern | PSD_MAXLEN_FONT
PAssignNode | PMUI_InputHandlerNode | PSD_MAXLEN_NAME
PathPart | PMUI_LayoutMsg | PSD_MAXLEN_TITLE
PAvailFonts | PMUI_List_TestPos_Result | PSD_MAXMUIPENS
PAvailFontsHeader | PMUI_MinMax | PSD_MAXSYSPENS
PAVLKEYCOMP | PMUI_NotifyData | PSD_NAME_FRONTMOST
PAVLNode | PMUI_Palette_Entry | PSD_NUMCOLS
PAVLNODECOMP | PMUIP_Application_AboutMUI | PSD_NUMMUIPENS
PBackFillMessage | PMUIP_Application_AddInputHandler | PSD_NUMSYSPENS
PBitMap | PMUIP_Application_CheckRefresh | PSearchCmdPathListMsg
PBitMapHeader | PMUIP_Application_GetMenuCheck | PSemaphoreMessage
PBitScaleArgs | PMUIP_Application_GetMenuState | PSemaphoreRequest
Pointer | PMUIP_Application_Input | PSetupCleanupHookMsg
PBob | PMUIP_Application_InputBuffered | PSGWork
PBoolInfo | PMUIP_Application_Load | PShapeHookMsg
PBorder | PMUIP_Application_NewInput | PSignalSemaphore
PCapturedExpression | PMUIP_Application_OpenConfigWindow | PSIKEY_ELF32
PCatalog | PMUIP_Application_PushMethod | PSIKEY_INIT
PCDrawMsg | PMUIP_Application_RemInputHandler | PSIKEY_NFSYS
P_CLASS | PMUIP_Application_ReturnID | PSIKEY_NOFREE
PClassLibrary | PMUIP_Application_SetConfigItem | PSimpleSprite
PClipboardHandle | PMUIP_Application_SetMenuCheck | P_SINGLE
PClipboardUnitPartial | PMUIP_Application_SetMenuState | PSJUMP_MAGIC
PClipHookMsg | PMUIP_Application_ShowHelp | PSkipList
PClipRect | PMUIP_Application_UnpushMethod | PSkipNode
pCliProcList | PMUIP_AskMinMax | PSNF_PRIVATE
PClockData | PMUIP_CallHook | PSNMMessage
PCollectionItem | PMUIP_Cleanup | PSoftIntList
PCollTable | PMUIP_Configdata_GetString | PSpecialMonitor
PColorFontColors | PMUIP_Configdata_GetULong | PSplayNode
PColorMap | PMUIP_Configdata_Load | PSplayTree
PColorRegister | PMUIP_Configdata_Save | PStackSwapStruct
PColorSpec | PMUIP_Configdata_SetFont | PStandardPacket
PColorTextFont | PMUIP_Configdata_SetFramespec | PStandardPacket64
PCommandLineInterface | PMUIP_Configdata_SetImspec | PSTB_EXISTS
PConsoleWindowData | PMUIP_Configdata_SetPenspec | PSTB_PACK
PContextMenuMsg | PMUIP_Configdata_SetString | PSTB_SIGNED
PContextNode | PMUIP_Configdata_SetULong | PSTB_UNPACK
PConUnit | PMUIP_ConnectParent | PST_CMAP
PCopInit | PMUIP_ContextMenuBuild | PSTF_EXISTS
PCopIns | PMUIP_ContextMenuChoice | PSTF_PACK
PCopList | PMUIP_CreateBubble | PSTF_SIGNED
PCopyBeginMsg | PMUIP_CreateDragImage | PSTF_UNPACK
PCopyDataMsg | PMUIP_CreateShortHelp | PST_MUI
PCopyEndMsg | PMUIP_CustomBackfill | P_STOP
PCprList | PMUIP_Dataspace_Add | PStoredProperty
PCSource | PMUIP_Dataspace_Clear | PST_RGB
PCyberModeNode | PMUIP_Dataspace_Find | PStringExtend
PDataType | PMUIP_Dataspace_Merge | PStringInfo
PDataTypeHeader | PMUIP_Dataspace_ReadIFF | PPChar
PDateStamp | PMUIP_Dataspace_Remove | PST_SYS
_PDateTime | PMUIP_Dataspace_WriteIFF | PSubStyle
PDBufInfo | PMUIP_DeleteBubble | PSysIPlugin
PDBufPacket | PMUIP_DeleteDragImage | PTabletData
PDeathMessage | PMUIP_DeleteShortHelp | PTabletHookData
PDeleteBeginMsg | PMUIP_DisconnectParent | PTag
PDeleteDataMsg | PMUIP_DoDrag | PTagItem
PDeleteEndMsg | PMUIP_DragBegin | PTask
PDevice | PMUIP_DragDrop | PTAvailFonts
pDeviceList | PMUIP_DragFinish | PTBGadgetData
PDeviceNode | PMUIP_DragQuery | PTextAttr
pDevInfo | PMUIP_DragReport | PTextExtent
PDevProc | PMUIP_Draw | PTextFont
PDimensionInfo | PMUIP_DrawBackground | PTextFontExtension
PDiskFontHeader | PMUIP_DrawBackgroundBuffered | PTextInputMsg
PDiskObject | PMUIP_DrawParentBackground | PTFontContents
PDisplayInfo | PMUI_PenSpec | PTHookContext
PDisplayMode | PMUIP_Export | PTimeRequest
PDMAEntry | PMUIP_Family_AddHead | PTimeVal
pDosEnvec | PMUIP_Family_AddTail | PTmpRas
pDosInfo | PMUIP_Family_GetChild | PTool
pDosLibrary | PMUIP_Family_Insert | PToolNode
PDOSList | PMUIP_Family_Remove | PTrackable
PDosPacket | PMUIP_Family_Sort | PTrueColorInfo
PDosPacket64 | PMUIP_Family_Transfer | PTTextAttr
PDosResidentSeg | PMUIP_FindUData | PUBLICSCREEN_F
PDrawerData | PMUIP_Floattext_Append | PubScreenStatus
PDrawInfo | PMUIP_GetConfigItem | PUCopList
PDTA_Allocated | PMUIP_GetUData | PULONG
PDTA_AllocatedPens | PMUIP_GoActive | PUnit
PDTA_BitMap | PMUIP_GoInactive | PushChunk
PDTA_BitMapHeader | PMUIP_Group_AddHead | PutDefDiskObject
PDTA_ClassBitMap | PMUIP_Group_AddTail | PutDiskObject
PDTA_ColorRegisters | PMUIP_Group_DoMethodNoForward | PutErrStr
PDTA_ColorTable | PMUIP_Group_ExitChange | PutIconTagList
PDTA_ColorTable2 | PMUIP_Group_InitChange | PUtilityBase
PDTA_CRegs | PMUIP_Group_Remove | PutMsg
PDTA_DestBitMap | PMUIP_Group_Sort | PutStr
PDTA_DestMode | PMUIP_HandleEvent | PVecInfo
PDTA_DitherQuality | PMUIP_HandleInput | PVecTable
PDTA_FreeSourceBitMap | PMUIP_Hide | PVector
PDTA_GetNumPictures | PMUIP_Import | PVectorInfo
PDTA_Grab | PMUIP_KillNotify | PView
PDTA_GRegs | PMUIP_KillNotifyObj | PViewExtra
PDTA_MaskPlane | PMUIP_Layout | PViewPort
PDTA_MaxDitherPens | PMUIP_List_Clear | PViewPortExtra
PDTA_ModeID | PMUIP_List_Compare | PVoiceHeader
PDTA_NumAlloc | PMUIP_List_Construct | PVolumeNode
PDTA_NumColors | PMUIP_List_CreateImage | PVSprite
PDTANUMPICTURES_Unknown | PMUIP_List_DeleteImage | PWBArg
PDTA_NumSparse | PMUIP_List_Exchange | PWBArgList
PDTA_Remap | PMUIP_List_GetEntry | PWBHandlerMessage
PDTA_ScaleQuality | PMUIP_List_Insert | PWBStartup
PDTA_Screen | PMUIP_List_InsertSingle | PWindow
PDTA_SourceMode | PMUIP_List_Jump | PYUVRenderInfo
PDTA_SparseTable | PMUIP_List_Move |

Q

QBlit | QBOWNERn | QueryOverscan
QBOWNER | QBSBlit | QUME_LP_20

R

Random | REG68K_D0 | RGBFB_R5G5B5
RasSize | REG68K_D1 | RGBFB_R5G5B5PC
RATIO_FIXEDPART | REG68K_D2 | RGBFB_R5G6B5
RATIO_UNITY | REG68K_D3 | RGBFB_R5G6B5PC
RawDoFmt | REG68K_D4 | RGBFB_R8G8B8
RAWKEY_BACKSPACE | REG68K_D5 | RGBFB_R8G8B8A8
RAWKEY_BREAK | REG68K_D6 | RGBFB_YUV410P
RAWKEY_CAPSLOCK | REG68K_D7 | RGBFB_YUV411
RawKeyConvert | REG68K_FP0 | RGBFB_YUV420P
RAWKEY_CRSRDOWN | REG68K_FP1 | RGBFB_YUV422
RAWKEY_CRSRLEFT | REG68K_FP2 | RGBFB_YUV422CGX
RAWKEY_CRSRRIGHT | REG68K_FP3 | RGBFB_YUV422PA
RAWKEY_CRSRUP | REG68K_FP4 | RGBFB_YUV422PC
RAWKEY_DEL | REG68K_FP5 | RGBFF_A8B8G8R8
RAWKEY_END | REG68K_FP6 | RGBFF_A8R8G8B8
RAWKEY_ENTER | REG68K_FP7 | RGBFF_ALPHA8
RAWKEY_ESC | Relabel | RGBFF_B5G5R5PC
RAWKEY_F1 | ReleaseBitMapInstance | RGBFF_B5G6R5PC
RAWKEY_F10 | ReleaseBitMapSource | RGBFF_B8G8R8
RAWKEY_F11 | ReleaseCapturedExpressions | RGBFF_B8G8R8A8
RAWKEY_F12 | ReleaseConsoleData | RGBFF_CLUT
RAWKEY_F13 | ReleaseDataType | RGBFF_HICOLOR
RAWKEY_F14 | ReleaseDirContext | RGBFF_NONE
RAWKEY_F15 | ReleaseDTDrawInfo | RGBFF_R5G5B5
RAWKEY_F2 | ReleaseGIRPort | RGBFF_R5G5B5PC
RAWKEY_F3 | ReleaseIBackFill | RGBFF_R5G6B5
RAWKEY_F4 | ReleaseIPluginList | RGBFF_R5G6B5PC
RAWKEY_F5 | ReleaseKeyMapInfoA | RGBFF_R8G8B8
RAWKEY_F6 | ReleaseNamedObject | RGBFF_R8G8B8A8
RAWKEY_F7 | ReleasePen | RGBFF_TRUEALPHA
RAWKEY_F8 | ReleaseSemaphore | RGBFF_TRUECOLOR
RAWKEY_F9 | ReleaseSemaphoreList | RGBFF_YUV410P
RAWKEY_HELP | RemakeDisplay | RGBFF_YUV411
RAWKEY_HOME | RemAssignList | RGBFF_YUV420P
RAWKEY_INSERT | RemConSnipHook | RGBFF_YUV422
RAWKEY_LALT | RemDevice | RGBFF_YUV422CGX
RAWKEY_LCOMMAND | RemDosEntry | RGBFF_YUV422PA
RAWKEY_LCTRL | RemFont | RGBFF_YUV422PC
RAWKEY_LSHIFT | RemHead | RIGHTHIT
RAWKEY_MEDIA_NEXT_TRACK | RemIBob | RIGHTIMAGE
RAWKEY_MEDIA_PLAY_PAUSE | RemInterface | RINGTRIGGER
RAWKEY_MEDIA_PREV_TRACK | RemIntServer | RKI_GET_EXT_RAWKEY
RAWKEY_MEDIA_REPEAT | RemLibrary | RKI_GET_FLAGS
RAWKEY_MEDIA_SHUFFLE | RemMemHandler | RKI_GET_NAME
RAWKEY_MEDIA_STOP | RemNamedObject | RKI_GET_PS2_SET1
RAWKEY_MENU | Remove | RKI_GET_PS2_SET2
RAWKEY_PAGEDOWN | RemoveAppIcon | RKI_GET_RAWKEY
RAWKEY_PAGEUP | RemoveAppMenuItem | RKI_GET_USB
RAWKEY_PRINTSCR | RemoveAppWindow | RKI_SET_TYPE
RAWKEY_RALT | RemoveAppWindowDropZone | RKI_SET_VALUE
RAWKEY_RCOMMAND | RemoveClass | RKITYPE_EXT_RAWKEY
RAWKEY_RETURN | RemoveCmdPathNode | RKITYPE_PS2_SET1
RAWKEY_RSHIFT | RemoveDTObject | RKITYPE_PS2_SET2
RAWKEY_SPACE | RemoveGadget | RKITYPE_RAWKEY
RAWKEY_TAB | RemoveGList | RKITYPE_USB
RawMayGetChar | RemoveSkipNode | RKITYPE_USB_UPCODE
RawPutChar | RemoveSplayNode | RLI_CommentChars
RCB_OK | RemPort | RLI_CSourceInput
RCB_UNKNOWN | RemResetCallback | RLI_Dummy
RDAB_NOALLOC | RemResource | RLI_EscapeChars
RDAB_NOPROMPT | RemSegment | RLI_FileHandleInput
RDAB_STDIN | RemSemaphore | RLI_MultiLine
RDAF_NOALLOC | RemTail | RLI_Substitute_E
RDAF_NOPROMPT | RemTask | RLI_Substitute_N
RDAF_STDIN | RemTrackable | RMapAlloc
ReadArgs | RemVSprite | RMapExtAlloc
ReadChunkBytes | RenameDosEntry | RMapExtFree
ReadChunkRecords | ReplyMsg | RMapFree
ReadEClock | ReplyPkt | RNB_PRIVATE1
ReadItem | REPORT_INSERT | RNB_WILDSTAR
ReadLineItem | REPORT_LOCK | RNF_PRIVATE1
ReadPixel | ReportMouse | RNF_WILDSTAR
ReadPixelArray | ReportMouse1 | ROOTCLASS
ReadPixelArray | REPORT_STREAM | RPF_FG_BLEND
ReadPixelArray8 | REPORT_TASK | RPF_REMAP_COLORFONTS
ReadPixelColor | REPORT_VOLUME | RPF_USE_BGCOLOR
ReadPixelLine8 | REQACTIVE | RPF_USE_FGCOLOR
ReadRGBPixel | REQOFFWINDOW | RPF_USE_OCOLOR
ReadSoftLink | REQPOS_BELOWBAR | RPTAG_APen
ReallocVec | REQPOS_CENTERMOUSE | RPTAG_APenColor
REALLY_PAL | REQPOS_CENTERSCREEN | RPTAG_BitMap
REC_EXCLUSIVE | REQPOS_CENTERWINDOW | RPTAG_BPen
REC_EXCLUSIVE_IMMED | REQPOS_CORNER | RPTAG_BPenColor
RECF_DOS_METHOD_ONLY | REQPOS_DEFAULT | RPTAG_DrawBounds
REC_MODE_MASK | Request | RPTAG_DrMd
RECOVERY_ALERT | REQUEST_A2024 | RPTAG_Font
REC_SHARED | RequestFile | RPTAG_MaxPen
REC_SHARED_IMMED | REQUEST_NTSC | RPTAG_OPen
RectFill | REQUEST_PAL | RPTAG_OPenColor
RectFillColor | REQUEST_SPECIAL | RPTAG_OutlinePen
RECTFMT_ARGB | Reschedule | RPTAG_OutlinePenColor
RECTFMT_GREY8 | RESCOUNT | RPTAG_RemapColorFonts
RECTFMT_LUT8 | RESERVEDPEN | RPTAG_WriteMask
RECTFMT_RAW | ResetMenuStrip | RPTAG_XPos
RECTFMT_RGB | ResolvePath | RPTAG_YPos
RECTFMT_RGBA | RestartTask | RTCF_FPU
RefreshDTObject | RethinkDisplay | RTCF_GENERAL
RefreshDTObjectA | RETURN_ERROR | RTCF_INFO
RefreshGadgets | RETURN_FAIL | RTCF_SPECIAL
RefreshGList | RETURN_OK | RTCF_STATE
RefreshSetGadgetAttrsA | RETURN_WARN | RTCF_VECTOR
RefreshTagItemClones | RGBFB_A8B8G8R8 | RTC_MATCHWORD
RefreshWindowFrame | RGBFB_A8R8G8B8 | RTF_AFTERDOS
REG68K_A0 | RGBFB_ALPHA8 | RTF_AUTOINIT
REG68K_A1 | RGBFB_B5G5R5PC | RTF_COLDSTART
REG68K_A2 | RGBFB_B5G6R5PC | RTF_NATIVE
REG68K_A3 | RGBFB_B8G8R8 | RTF_SINGLETASK
REG68K_A4 | RGBFB_B8G8R8A8 | RunCommand
REG68K_A5 | RGBFB_CLUT | RUN_EXECUTE
REG68K_A6 | RGBFB_MaxFormats | RUN_SYSTEM
REG68K_A7 | RGBFB_NONE | RUN_SYSTEM_ASYNCH

S

SA_ActiveWindow | SetFileHandleAttr | SORTASCIMAGE
SA_AutoScroll | SetFileSize | SORTDESIMAGE
SA_BackChild | SetFileSysPort | SortGList
SA_BackFill | SetFont | SortLayerCR
SA_Behind | SetForegroundAlpha | SOUNDDTCLASS
SA_BitMap | Setfunction | SPA_GADGETGEOMETRY
SA_BlockPen | SetGadgetAttrs | SPA_GADGETSTYLE
SA_ColorMapEntries | SetGadgetAttrsA | SPA_MENUSTYLE
SA_Colors | SetGUIAttrsA | SPARITY_BITS
SA_Colors32 | SetIntVector | SPARITY_EVEN
SA_Compositing | SetIoErr | SPARITY_NONE
SA_DClip | SetIPrefs | SPARITY_ODD
SA_Depth | SetKeyMapDefault | SPA_WINBFRAMESTYLE
SA_DetailPen | SetLayerInfoAttrsA | SPA_WINBGADGEOMETRY
SA_DisplayID | SetLayerInfoBounds | SPA_WINBGADSTYLE
SA_Draggable | SetLayerOpaqueness | SPA_WINBORDERSTYLE
SA_Dummy | SetLayerOverlayRect | SPECIAL_MONITOR_TYPE
SA_ErrorCode | SetLocalItemPurge | SplitName
SA_Exclusive | SetMarkedBlock | SPOS_ABSOLUTE
SafeSetOutlinePen | SetMaxPen | SPOS_FORCEDRAG
SafeSetWriteMask | SetMem | SPOS_MAKEVISIBLE
SA_Font | SetMenuStrip | SPOS_RELATIVE
SA_FrontChild | SetMethod | SP_PARENS
SA_FullPalette | SetMode | SP_PREC_ALL
SA_Height | SetMouseQueue | SP_PREC_CURR
SA_Interleaved | SetOPen | SPRITEA_Attached
SA_Left | SetOutlinePen | SPRITEA_OldDataFormat
SA_LikeWorkbench | SetOwner | SPRITEA_OutputHeight
SA_MaxWindowBox | SetOwnerInfo | SPRITE_ATTACHED
SameDevice | SetPointer | SPRITEA_Width
SameFH | SetPrefs | SPRITEA_XReplication
SameLock | SetProcWindow | SPRITEA_YReplication
SA_MinimizeISG | SetProgramDir | SPRITERESN_140NS
SAMPLETYPE_Left | SetProtection | SPRITERESN_35NS
SAMPLETYPE_Right | SetPubScreenModes | SPRITERESN_70NS
SAMPLETYPE_Stereo | SetRast | SPRITERESN_DEFAULT
SA_Obsolete1 | SetRenderDomain | SPRITERESN_ECS
SA_OffScreenDragging | SetRGB32 | SPRITES
SA_Overscan | SetRGB32CM | SP_SUCC_ALL
SA_Parent | SetRGB4 | SP_SUCC_CURR
SA_Pens | SetRGB4CM | SRA_DeltaX
SA_PubName | SetRPAttrs | SRA_DeltaY
SA_PubSig | SetRPAttrsA | SRA_DirectShade
SA_PubTask | SetScreenAttr | SRA_Domain
SA_Quiet | SetScreenAttrsA | SRA_Dummy
SA_Reserved | SetScreenBitMapInstance | SRA_OffsetX
SA_Reserved2 | SetSignal | SRA_OffsetY
SA_Reserved3 | SetSoftStyle | SRA_RefreshBG
SA_SharePens | SetSR | SR_DRAW
SA_ShowTitle | SetTaskPri | SR_DRAWALPHAMAP
SA_SysFont | SetTaskTrap | SR_DRAWDISMASK
SA_Title | SETTINGSIMAGE | SR_DRAWIMAGEFRAME
SA_Top | SetVar | SR_DRAWLEVELMAP
SA_Type | SetVBuf | SR_DRAWMASK
SAVEBACK | SETVC_DPMSLevel | SR_DRAWSELDISMASK
SAVEBOB | SetWindowAttr | SR_DRAWSHADOWMAP
SaveDTObject | SetWindowAttrsA | SR_DRAWSHINEMAP
SaveDTObjectA | SetWindowPointer | SREAD_BITS
SAVEPRESERVE | SetWindowPointerA | SRF_HSCROLLERFRAME
SA_VideoControl | SetWindowTitles | SRF_ISBITMAP
SA_Width | SetWriteMask | SRF_MONOCHROME
SA_WindowDropShadows | SetWrMsk | SRF_VSCROLLERFRAME
SBARLOGO | SEXTB_MARK | SS_GRAPHICS
SB_COPY_BITMAP | SEXTB_MSPON | SS_NOSPACE
SBM_BLOCKING | SEXTF_MARK | SS_SPACE
SBM_NON_BLOCKING | SEXTF_MSPON | SSTOP_BITS
SB_SCREEN_BITMAP | SGA_BEEP | STACK_FRAME_BACKCHAIN_PTR_LOOP
SBUF_1024 | SGA_END | STACK_FRAME_DECODED
SBUF_16000 | SGA_NEXTACTIVE | STACK_FRAME_INVALID_BACKCHAIN_PTR
SBUF_2048 | SGA_PREVACTIVE | STACK_FRAME_TRASHED_MEMORY_LOOP
SBUF_4096 | SGA_REDISPLAY | StackSwap
SBUF_512 | SGA_REUSE | STANDARD_COLORCLOCKS
SBUF_8000 | SGA_USE | STANDARD_DENISE_MAX
SBUFSIZE_BITS | SG_DEFAULTMAXCHARS | STANDARD_DENISE_MIN
ScalePixelArray | SG_GADGETBOX | STANDARD_HBSTOP
ScalerDiv | SGH_CLICK | STANDARD_HBSTRT
ScanNamedMemory | SGH_KEY | STANDARD_HSSTOP
ScanVars | SG_IMAGEBOX | STANDARD_HSSTRT
SC_ARROWGSTYLE | SGM_CONTROL | STANDARD_MONITOR_MASK
SC_ASCII | SGM_EXITHELP | STANDARD_NTSC_BEAMCON
SC_COLLATE1 | SGM_FIXEDFIELD | STANDARD_NTSC_ROWS
SC_COLLATE2 | SGM_LONGINT | STANDARD_PAL_BEAMCON
SC_CYCLEGSTYLE | SGM_NOCHANGE | STANDARD_PAL_ROWS
SC_GADGETGEOMETRY | SGM_NOFILTER | STANDARD_VBSTOP
SC_GADGETSTYLE | SGM_NOWORKB | STANDARD_VBSTRT
SC_GLOBALGEOMETRY | SGM_REPLACE | STANDARD_VIEW_X
SC_GLOBALSTYLE | SGR_BLACK | STANDARD_VIEW_Y
SCHMSTATE_Cleanup | SGR_BLACKBG | STANDARD_VSSTOP
SCHMSTATE_Setup | SGR_BLUE | STANDARD_VSSTRT
SCHMSTATE_TryCleanup | SGR_BLUEBG | STANDARD_XOFFSET
SC_KHANDLESTYLE | SGR_BOLD | STANDARD_YOFFSET
SCLOSEIMAGE | SGR_CLR0 | StartDMA
SC_MENUSTYLE | SGR_CLR0BG | StartNotify
SCREENBEHIND_F | SGR_CLR1 | StartScreenNotifyTagList
ScreenDepth | SGR_CLR1BG | STB_CRASHED
SCREEN_DRAG | SGR_CLR2 | STB_REMOVED
SCREENHIRES | SGR_CLR2BG | STD_DISABLE_CONTRAST
ScreenPosition | SGR_CLR3 | STDSCREENHEIGHT
SCREENQUIET_F | SGR_CLR3BG | STDSCREENWIDTH
SCREENSIMAGE | SGR_CLR4 | STF_CRASHED
ScreenToBack | SGR_CLR4BG | ST_FILE
ScreenToFront | SGR_CLR5 | STF_REMOVED
SCREENTYPE_F | SGR_CLR5BG | ST_LINKDIR
SCROLLERGCLASS | SGR_CLR6 | ST_LINKFILE
ScrollLayer | SGR_CLR6BG | STM_ACTIVATE_FIELD
ScrollRaster | SGR_CLR7 | STM_BROWSE_NEXT
ScrollRasterBF | SGR_CLR7BG | STM_BROWSE_PREV
ScrollVPort | SGR_CYAN | STM_COMMAND
ScrollWindowRaster | SGR_CYANBG | STM_CONTENTS
SC_WINBFRAMESTYLE | SGR_DEFAULT | STM_FASTFORWARD
SC_WINBGADGEOMETRY | SGR_DEFAULTBG | STM_INDEX
SC_WINBGADSTYLE | SGR_GREEN | STM_LOCATE
SC_WINBORDERSTYLE | SGR_GREENBG | STM_NEXT_FIELD
SDCMD_BREAK | SGR_ITALIC | STM_PAUSE
SDCMD_QUERY | SGR_MAGENTA | STM_PLAY
SDCMD_SETPARAMS | SGR_MAGENTABG | STM_PREV_FIELD
SDEPTH_CHILDONLY | SGR_NEGATIVE | STM_RESUME
SDEPTHIMAGE | SGR_NORMAL | STM_RETRACE
SDEPTH_INFAMILY | SGR_NOTITALIC | STM_REWIND
SDEPTH_TOBACK | SGR_NOTUNDERSCORE | STM_STOP
SDEPTH_TOFRONT | SGR_POSITIVE | StopChunk
SDONA_SignalMask | SGR_PRIMARY | StopChunks
SDONA_Task | SGR_RED | StopOnExit
SDOWNBACKGADGET | SGR_REDBG | StoreItemInContext
SDRAGGADGET | SGR_UNDERSCORE | StoreLocalItem
SDTA_Continuous | SGR_WHITE | ST_PIPEFILE
SDTA_Cycles | SGR_WHITEBG | StrConvert
SDTA_Dummy | SGR_YELLOW | STRGCLASS
SDTA_FreeSampleData | SGR_YELLOWBG | Stricmp
SDTA_LeftSample | SHADE_BW | STRINGA_ActivePens
SDTA_Pan | SHADE_COLOR | STRINGA_AltKeyMap
SDTA_Period | SHADE_GREYSCALE | STRINGA_Buffer
SDTA_ReplayPeriod | ShadeRectA | STRINGA_BufferPos
SDTA_RightSample | ShadeRectOld | STRINGA_DispPos
SDTA_Sample | SHADOWPEN | STRINGA_Dummy
SDTA_SampleLength | SHANGHAI | STRINGA_EditHook
SDTA_SamplesPerSec | SHAPEHOOKACTION_CHANGELAYERSHAPE | STRINGA_EditModes
SDTA_SignalBit | SHAPEHOOKACTION_CREATELAYER | STRINGA_ExitHelp
SDTA_SignalBitMask | SHAPEHOOKACTION_DELETELAYER | STRINGA_FixedFieldMode
SDTA_SignalBitNumber | SHAPEHOOKACTION_GETHOOKACTIONS | STRINGA_Font
SDTA_SignalTask | SHAPEHOOKACTION_MOVELAYER | STRINGA_Justification
SDTA_SyncSampleChange | SHAPEHOOKACTION_MOVESIZELAYER | STRINGA_LongVal
SDTA_VoiceHeader | SHAPEHOOKACTION_SIZELAYER | STRINGA_MarkedBlock
SDTA_Volume | SHARED_LOCK | STRINGA_MaxChars
SearchCmdPathList | SHIFTITEM | STRINGA_NoFilterMode
SecondsToDateStamp | SHIFTMENU | STRINGA_Pens
SEL_BRIGHTEN | SHIFT_PIXFMT | STRINGA_ReplaceMode
SEL_DARKEN | SHIFTSUB | STRINGA_TextVal
SELECTDOWN | SHINEPEN | STRINGA_UndoBuffer
SelectErrorOutput | ShowLayer | STRINGA_WorkBuffer
SelectInput | ShowTitle | StripFont
SelectOutput | SHOWTITLE_F | StripIntuiMessages
SELECTPEN | ShowWindow | Strlcat
SELECTSHADOWPEN | SHSHAKE_BITS | Strlcpy
SELECTSHINEPEN | SHSHAKE_NONE | Strlen
SELECTTEXTPEN | SHSHAKE_RTS | StrnCmp
SELECTUP | SHSHAKE_XON | Strnicmp
SEL_IMPOSE | SI_BEGIN | ST_ROOT
SEL_NEGATIVE | SI_END | PChar
SEL_ROTATERGB | SIGB_ABORT | StrToLong
SendIO | SIGB_BLIT | ST_SOFTLINK
SendPkt | SIGB_CHILD | ST_USERDIR
SERB_7WIRE | SIGB_DOS | SUBMENU
SERB_EOFMODE | SIGB_INTUITION | SUBNUM
SERB_PARTY_ODD | SIGB_NET | SubTime
SERB_PARTY_ON | SIGBREAKB_CTRL_C | SubtractDates
SERB_QUEUEDBRK | SIGBREAKB_CTRL_D | SumInterface
SERB_RAD_BOOGIE | SIGBREAKB_CTRL_E | SumKickData
SERB_SHARED | SIGBREAKB_CTRL_F | SumLibrary
SERB_XDISABLED | SIGBREAKF_CTRL_C | SUPER72HIRESDBL_KEY
SER_DEFAULT_CTLCHAR | SIGBREAKF_CTRL_D | SUPER72HIRESEHBDBL_KEY
SerErr_BaudMismatch | SIGBREAKF_CTRL_E | SUPER72HIRESHAMDBL_KEY
SerErr_BufErr | SIGBREAKF_CTRL_F | SUPER72LORESDBL_KEY
SerErr_BufOverflow | SIGB_SINGLE | SUPER72LORESEHBDBL_KEY
SerErr_DetectedBreak | SIGF_ABORT | SUPER72LORESHAMDBL_KEY
SerErr_DevBusy | SIGF_BLIT | SUPER72_MONITOR_ID
SerErr_InvParam | SIGF_CHILD | SUPER72SUPERDBL_KEY
SerErr_LineErr | SIGF_DOS | SUPER72SUPEREHBDBL_KEY
SerErr_NoDSR | SIGF_INTUITION | SUPER72SUPERHAMDBL_KEY
SerErr_ParityErr | SIGF_NET | SUPERDPF2_KEY
SerErr_TimerErr | SIGF_SINGLE | SUPERDPF_KEY
SERF_7WIRE | Signal | SUPEREHB_KEY
SERF_EOFMODE | SIH_PRIMASK | SUPEREHBLACE_KEY
SERF_PARTY_ODD | SI_HPROPBACKGROUND | SUPERHAM_KEY
SERF_PARTY_ON | SIMPLEREQ | SUPERHAMLACE_KEY
SERF_QUEUEDBRK | SINGLE_PT | SUPERHIRES
SERF_RAD_BOOGIE | SI_VPROPBACKGROUND | SUPER_KEY
SERF_SHARED | SIX_LPI | SUPERLACEDPF2_KEY
SERF_XDISABLED | SIZEGADGET | SUPERLACEDPF_KEY
serial | SIZEIMAGE | SUPERLACE_KEY
Serialize | SizeLayer | SuperState
SerializePort | SIZEOF_INSTANCE | Supervisor
SERIALNAME | SizeWindow | SUPFRONTGADGET
SERIAL_PRINTER | SMA_Draw | SUSERFLAGS
SetABPenDrMd | SMA_GetScrollerTop | SuspendTask
SetAfPt | SMA_RedrawAll | SwapBitsRastPortClipRect
SetAPen | SMA_RepairDamage | SWRITE_BITS
SetArgStr | SMA_Scroll | SyncSBitMap
SetAttrs | SM_EXCLUSIVE | SYS_Asynch
SetAttrsA | SM_SHARED | SYS_CommandRunMode
SetBackFillHookAttrsA | SNA_Hook | SYS_CustomShell
SetBlockingMode | SNA_MsgPort | SYS_Dummy
SetBPen | SNA_Notify | SYS_Error
SetChipRev | SNA_Priority | SYS_ExecuteInputStream
SETCHIPREV_A | SNAPSHOTIMAGE | SYSIA_BitMapCache
SETCHIPREV_AA | SNA_PubName | SYSIA_ContentsBox
SETCHIPREV_BEST | SNA_SigBit | SYSIA_Depth
SETCHIPREV_ECS | SNA_SigTask | SYSIA_DrawInfo
SetCliCurrentDirName | SNA_UserData | SYSIA_FullFrame
SetCliProgramName | SNMF_NAMESPACES_ONLY | SYSIA_Label
SetCliPrompt | SNOTIFY_AFTER_CLOSESCREEN | SYSIA_Pens
SetCollision | SNOTIFY_AFTER_CLOSEWB | SYSIA_ReferenceFont
SetComment | SNOTIFY_AFTER_CLOSEWINDOW | SYSIA_RenderHook
SetConSnip | SNOTIFY_AFTER_OPENSCREEN | SYSIA_Size
SetConsolePort | SNOTIFY_AFTER_OPENWB | SYSIA_VectorInfo
SetCurrentCmdPathList | SNOTIFY_AFTER_OPENWINDOW | SYSIA_Which
SetCurrentDir | SNOTIFY_BEFORE_CLOSESCREEN | SYSICLASS
SetDate | SNOTIFY_BEFORE_CLOSEWB | SYS_Input
SetDefaultPubScreen | SNOTIFY_BEFORE_CLOSEWINDOW | SYSISIZE_HIRES
SetDiskFontCtrlA | SNOTIFY_BEFORE_OPENSCREEN | SYSISIZE_LOWRES
SetDisplayBeepHook | SNOTIFY_BEFORE_OPENWB | SYSISIZE_MEDRES
SetDMRequest | SNOTIFY_BEFORE_OPENWINDOW | SYS_Output
SetDrMd | SNOTIFY_LOCKPUBSCREEN | SysReqHandler
SetDrPt | SNOTIFY_PUBSCREENSTATE | SYSREQUEST
SetDTAttrs | SNOTIFY_SCREENDEPTH | SystemTagList
SetDTAttrsA | SNOTIFY_UNLOCKPUBSCREEN | SystemTags
SetEditHook | SNOTIFY_WAIT_REPLY | SYS_UserShell
SetExcept | SOFTHYPHEN |

T

TAATextFont | TGadgetGeometryMsg | TMUIP_Numeric_Decrease
TABLETA_AngleX | TGadgetInfo | TMUIP_Numeric_Increase
TABLETA_AngleY | TGelsInfo | TMUIP_Numeric_ScaleToValue
TABLETA_AngleZ | TGfxBase | TMUIP_Numeric_SetDefault
TABLETA_ButtonBits | TGlyphEngine | TMUIP_Numeric_Stringify
TABLETA_Dummy | TGlyphMap | TMUIP_Numeric_ValueToScale
TABLETA_InProximity | TGlyphWidthEntry | TMUIP_Numeric_ValueToScaleExt
TABLETA_Pressure | TGlyphWidthEntry32 | TMUIP_Pendisplay_SetColormap
TABLETA_RangeZ | TgpDomain | TMUIP_Pendisplay_SetMUIPen
TABLETA_ResolutionX | TgpExtent | TMUIP_Pendisplay_SetRGB
TABLETA_ResolutionY | TgpGoInactive | TMUIP_Pixmap_DrawSection
TABLETA_TabletZ | TgpHitTest | TMUIP_Popstring_Close
TAChain | TgpInput | TMUIP_Popstring_Open
TA_CharSet | tgpKeyGoInactive | TMUIP_Process_Kill
TAddressAndSize | TgpKeyInput | TMUIP_Process_Launch
TA_DeviceDPI | TgpKeyTest | TMUIP_Process_Process
TadtFrame | TgpLayout | TMUIP_Process_Signal
TadtNewFormatFrame | TgpMenuEvent | TMUIP_Prop_Decrease
TadtStart | TgpQuery | TMUIP_Prop_Increase
LongWord | TgpRender | TMUIP_Semaphore_Attempt
TAG_ | TGradientSpec | TMUIP_Semaphore_AttemptShared
TAG_DONE | TGUIPlugin | TMUIP_Semaphore_Obtain
TAG_END | ThinLayerInfo | TMUIP_Semaphore_ObtainShared
TAGFILTER_AND | THook | TMUIP_Semaphore_Release
TAGFILTER_NOT | TIACTION_Execute | TMUIP_Set
TAG_IGNORE | TIACTION_NewDrawer | TMUIP_SetAsString
TagInArray | TIACTION_RelabelVolume | TMUIP_Settingsgroup_ConfigToGadgets
TAG_MORE | TIACTION_Rename | TMUIP_Settingsgroup_GadgetsToConfig
TAG_SKIP | TIBox | TMUIP_SetUData
TAG_USER | TICKS_PER_SECOND | TMUIP_SetUDataOnce
TAG_USER | TIClass | TMUIP_Setup
TAlphaHookMsg | TIconIdentifyMsg | TMUIP_Show
TAnalogSignalInterval | TIconSelectMsg | TMUIP_String_ClearSelected
TAnchorPath | TIENewTablet | TMUIP_String_FileNameStart
TAnchorPathOld | TIEPointerPixel | TMUIP_String_Insert
TAnimComp | TIEPointerTablet | TMUI_PubScreenDesc
TAnimHeader | TIFFHandle | TMUIP_UnknownDropDestination
TAnimOb | TIFFStreamCmd | TMUIP_Window_ActionIconify
TAppIcon | TImage | TMUIP_Window_AddControlCharHandler
TAppIconRenderMsg | TImageGeometryMsg | TMUIP_Window_AddEventHandler
TAppMenu | TimedDisplayAlert | TMUIP_Window_AllocGadgetID
TAppMenuItem | TimedDosRequester | TMUIP_Window_Cleanup
TAppMessage | timer | TMUIP_Window_DragObject
TAppWindow | TimerBase | TMUIP_Window_DrawBackground
TAppWindowDropZone | TimerClone | TMUIP_Window_FreeGadgetID
TAppWindowDropZoneMsg | TimerExpunge | TMUIP_Window_RecalcDisplay
TAreaInfo | TIMERNAME | TMUIP_Window_RemControlCharHandler
TA_Rebuild | TimerObtain | TMUIP_Window_RemEventHandler
TASLSemaphore | TimerRelease | TMUIP_Window_ScreenToBack
tAssignList | TimpDomainFrame | TMUIP_Window_ScreenToFront
TAssignNode | TimpDraw | TMUIP_Window_Setup
TAvailFonts | TimpErase | TMUIP_Window_Snapshot
TAvailFontsHeader | TimpExtent | TMUIP_Window_ToBack
Pointer | TimpFrameBox | TMUIP_Window_ToFront
TAVLNode | TimpHitTest | TMUIP_Window_UpdateMenu
TBackFillMessage | TInfoData | TMUIP_WriteLong
TBC_HCLRTAB | TInputEvent | TMUIP_WriteString
TBC_HCLRTABSALL | TInterface | TMUI_RenderInfo
TB_ETASK | TInterfaceData | TMUI_RGBcolor
TB_EXCEPT | TInterrupt | TMUIS_InfoClient
TBFRAMEIMAGE | TIntuiMessage | TMultiAssign
TBitMap | TIntuiRawKeyData | TNamedObject
TBitMapHeader | TIntuiText | TNameInfo
TBitMapInstance | TIntuitionBase | TNewScreen
TBitMapSource | TIntuiWheelData | TNewWindow
TBitScaleArgs | TIntVector | TNode
TB_LAUNCH | TIOClipReq | TNotifyHookMsg
TBob | TIOExtSer | TNotifyMessage
TBoolInfo | TIORequest | tNotifyRequest
TBorder | TIOStdReq | TNSIZE
TB_PROCTIME | TIOTArray | T_Object
TB_STACKCHK | TIsrvstr | TODA_SAFE
TB_SWITCH | T_ITEM | TODAYSTR
TCapturedExpression | TITLEPEN | TOldDrawerData
TCatalog | TKeyMap | ToLower
TCDrawMsg | TKeyMapNode | TO_MONITOR
TClassLibrary | TKeyMapResource | TOMORROWSTR
TClipboardHandle | TLayer | TOOLSIZE
TClipboardUnitPartial | TLayerComposeMsg | TopAddTail
TClipHookMsg | TLayer_Info | TOPAZ_EIGHTY
TClipRect | TLibrary | TOPAZ_SIXTY
tCliProcList | TLine | TopGet
TClockData | TList | TOPHIT
TCollectionItem | TLocalContextItem | TopMember
TColorFontColors | TLocale | TopSet
TColorMap | TLocaleBase | TopUpdate
TColorRegister | TLocalVar | ToUpper
TColorSpec | TLock | TOutlineFont
TColorTextFont | TMemChunk | TP96Mode
TCommandLineInterface | TMemEntry | TPaletteExtra
TConsoleWindowData | TMemHandlerData | TPathNode
TContextMenuMsg | TMemHeader | TPGX
TContextNode | TMemList | LongWord
TConUnit | TMenu | TPlanarYUVInfo
TCopInit | T_MENU | PByte
TCopIns | TMenuEventMessage | TPoint
TCopList | TMenuItem | TPreferences
TCopyBeginMsg | TMenuScanMessage | TProcess
TCopyDataMsg | TMenuStringMessage | TPropInfo
TCopyEndMsg | TMessage | TPseudoSegList
TCprList | TMessageDigest_SHA | TPubScreenNode
TCSource | TMinList | TQueryHeader
TCyberModeNode | TMinNode | TrackAddressList
TDataType | TMonitorInfo | TRACKF_COMPACT
TDataTypeHeader | TMonitorSpec | TrackSegmentList
TDateStamp | TmpDeleteMenu | TR_ADDREQUEST
_TDateTime | TmpFindID | TRandomState
TDBufInfo | TmpGetState | TRAPINST
tDBufPacket | TmpHandleEvent | TRAPNUM_ALIGNMENT
TDeathMessage | TmpNewMenu | TRAPNUM_ALTIVEC_ASSIST
TDebugOutputNotify | TmpNextChild | TRAPNUM_BUS_ERROR
TDebugSymbol | TmpNextSelect | TRAPNUM_DATA_BREAKPOINT
TDeleteBeginMsg | TmpScan | TRAPNUM_DATA_SEGMENT_VIOLATION
TDeleteDataMsg | TmpSetState | TRAPNUM_FPU
TDeleteEndMsg | TmpSetup | TRAPNUM_ILLEGAL_INSTRUCTION
TDevice | TMsg | TRAPNUM_INST_BREAKPOINT
tDeviceList | TMsgPort | TRAPNUM_INST_SEGMENT_VIOLATION
TDeviceNode | TMUI_AreaData | TRAPNUM_NUMTRAPS
tDevInfo | TMUI_BoopsiQuery | TRAPNUM_PERFORMANCE
TDevProc | TMUI_Command | TRAPNUM_PRIVILEGE_VIOLATION
TDimensionInfo | TMUI_CustomClass | TRAPNUM_RESERVED1
TDiskFontHeader | TMUI_DragImage | TRAPNUM_SMI
TDiskObject | TMUI_EventHandlerNode | TRAPNUM_THERMAL
TDisplayInfo | TMUI_FrameSpec | TRAPNUM_TRACE
TDisplayMode | TMUI_GlobalInfo | TRAPNUM_TRAP
TDMAEntry | TMUI_ImageSpec_intern | TRAPTYPE
tDosEnvec | TMUI_InputHandlerNode | TRAPTYPENR
tDosInfo | TMUI_LayoutMsg | TRasInfo
tDosLibrary | TMUI_List_TestPos_Result | TRastPort
TDOSList | TMUI_MinMax | TRastPortExtra
TDosPacket | TMUI_NotifyData | TRDArgs
TDosPacket64 | TMUI_Palette_Entry | TRecordLock
TDosResidentSeg | TMUIP_Application_AboutMUI | TRect32
TDR_Arg1 | TMUIP_Application_AddInputHandler | TRectangle
TDR_Arg10 | TMUIP_Application_CheckRefresh | tRegion
TDR_Arg2 | TMUIP_Application_GetMenuCheck | TRegionRectangle
TDR_Arg3 | TMUIP_Application_GetMenuState | TRemember
TDR_Arg4 | TMUIP_Application_Input | TRenderInfo
TDR_Arg5 | TMUIP_Application_InputBuffered | TRenderMsg
TDR_Arg6 | TMUIP_Application_Load | TRequester
TDR_Arg7 | TMUIP_Application_NewInput | TResident
TDR_Arg8 | TMUIP_Application_OpenConfigWindow | TRGBFTYPE
TDR_Arg9 | TMUIP_Application_PushMethod | TR_GETSYSTIME
TDR_ArgArray | TMUIP_Application_RemInputHandler | T_ROOT
TDrawerData | TMUIP_Application_ReturnID | tRootNode
TDrawInfo | TMUIP_Application_Save | TR_SETSYSTIME
TDR_CharSet | TMUIP_Application_SetConfigItem | TS_ADDED
TDR_Dummy | TMUIP_Application_SetMenuCheck | LongInt
TDR_EasyStruct | TMUIP_Application_SetMenuState | TSatisfyMsg
TDR_FormatString | TMUIP_Application_ShowHelp | TS_CRASHED
TDR_GadgetString | TMUIP_Application_UnpushMethod | TScreen
TDR_IDCMP_Ptr | TMUIP_AskMinMax | TScreenBuffer
TDRIMAGE_DEFAULT | TMUIP_CallHook | TScreenModeRequester
TDRIMAGE_ERROR | TMUIP_Cleanup | TScreenNotifyMessage
TDRIMAGE_INFO | TMUIP_Configdata_GetString | TScrollHook
TDRIMAGE_INSERTDISK | TMUIP_Configdata_GetULong | TScrollMsg
TDRIMAGE_QUESTION | TMUIP_Configdata_Load | TSearchCmdPathListMsg
TDR_ImageType | TMUIP_Configdata_Save | TSemaphoreMessage
TDRIMAGE_WARNING | TMUIP_Configdata_SetFont | TSemaphoreRequest
TDR_Inactive | TMUIP_Configdata_SetFramespec | TSetupCleanupHookMsg
TDR_NonBlocking | TMUIP_Configdata_SetImspec | TS_EXCEPT
TDR_Timeout | TMUIP_Configdata_SetPenspec | TSGWork
TDR_TitleString | TMUIP_Configdata_SetString | TShapeHookMsg
TDR_Window | TMUIP_Configdata_SetULong | TSignalSemaphore
TDTA_Buffer | TMUIP_ConnectParent | TSimpleSprite
TDTA_BufferLen | TMUIP_ContextMenuBuild | TS_INVALID
TDTA_LineList | TMUIP_ContextMenuChoice | TSkipList
TDTA_WordDelim | TMUIP_CreateBubble | TSkipNode
TDTA_WordSelect | TMUIP_CreateDragImage | TSNMMessage
TDTA_WordWrap | TMUIP_CreateShortHelp | TSoftIntList
TdtDraw | TMUIP_CustomBackfill | TSpecialMonitor
TdtFrameBox | TMUIP_Dataspace_Add | TSplayNode
Tdt_frame_image | TMUIP_Dataspace_Clear | TSplayTree
TdtGeneral | TMUIP_Dataspace_Find | TS_READY
TdtGoto | TMUIP_Dataspace_Merge | TS_REMOVED
TDTHookContext | TMUIP_Dataspace_ReadIFF | TS_RUN
TDTMethod | TMUIP_Dataspace_Remove | TS_SUSPENDED
TdtSelect | TMUIP_Dataspace_WriteIFF | TStackFrameMsg
TDTSpecialInfo | TMUIP_DeleteBubble | TStackSwapStruct
TdtTrigger | TMUIP_DeleteDragImage | TStandardPacket
TdtWrite | TMUIP_DeleteShortHelp | TStandardPacket64
T__dummyAreaData__ | TMUIP_Dirlist_ReRead | TStoredProperty
TE0B_NOREMFONT | TMUIP_DisconnectParent | TStringExtend
TE0F_NOREMFONT | TMUIP_DoDrag | TStringInfo
TE1F_GENFONT | TMUIP_DragBegin | TSubStyle
TE1F_NOANTIALIASING | TMUIP_DragDrop | TS_WAIT
TE1F_NODEEMBOLDENING | TMUIP_DragFinish | TSysIPlugin
TE1F_NODESHEARING | TMUIP_DragQuery | TTabletData
TE1F_NODEUNDERLINING | TMUIP_DragReport | TTabletHookData
TE1F_NOEMBOLDENING | TMUIP_Draw | TTagItem
TE1F_NOSHEARING | TMUIP_DrawBackground | TT_ALPHA16
TE1F_NOUNDERLINING | TMUIP_DrawBackgroundBuffered | TT_ALPHA24
TEasyStruct | TMUIP_DrawParentBackground | TT_ALPHA32
TEClockVal | TMUI_PenSpec | TT_ALPHA8
TEGlyphEngine | TMUIP_Export | TTask
TEmuTrap | TMUIP_Family_AddHead | TTAvailFonts
TEmuTrapfunction | TMUIP_Family_AddTail | TTBGadgetData
tErrorString | TMUIP_Family_GetChild | TT_BITPLANE
TExAllControl | TMUIP_Family_Insert | TTextAttr
TExAllData | TMUIP_Family_Remove | TTextExtent
TExamineData | TMUIP_Family_Sort | TTextFont
TExceptionContext | TMUIP_Family_Transfer | TTextFontExtension
TExecBase | TMUIP_FindUData | TTextInputMsg
TEXTDTCLASS | TMUIP_Floattext_Append | TTFontContents
TExtendedDeadKey | TMUIP_GetConfigItem | TTimeRequest
TExtendedNode | TMUIP_GetUData | TTimeVal
TextExtent | TMUIP_GoActive | TTmpRas
TextFit | TMUIP_GoInactive | TTool
TExtGadget | TMUIP_Group_AddHead | TToolNode
TExtIntuiMessage | TMUIP_Group_AddTail | TToolTypeArray
TextLength | TMUIP_Group_DoMethodNoForward | TTrackable
TExtNewScreen | TMUIP_Group_ExitChange | TTrueColorInfo
TExtNewWindow | TMUIP_Group_InitChange | TTTextAttr
TEXTPEN | TMUIP_Group_Remove | TUCopList
TExtSprite | TMUIP_Group_Sort | TUnit
TFCH_ID | TMUIP_HandleEvent | TUtilityBase
TF_ETASK | TMUIP_HandleInput | TVecInfo
TF_EXCEPT | TMUIP_Hide | TVecTable
TFileHandle | TMUIP_Import | TVector
TFileInfoBlock | TMUIP_KillNotify | TVectorInfo
tFileLock | TMUIP_KillNotifyObj | TView
TFileRequester | TMUIP_Layout | TViewExtra
TFileSysStartupMsg | TMUIP_List_Clear | TViewPort
TFileSystemData | TMUIP_List_Compare | tViewPortExtra
TFileSystemVectorPort | TMUIP_List_Construct | TVoiceHeader
TFileSystemVectors | TMUIP_List_CreateImage | TVolumeNode
TFindTrackedAddressMsg | TMUIP_List_DeleteImage | TVSprite
TF_LAUNCH | TMUIP_List_Exchange | TWBArg
TF_LAUNCH_MASK | TMUIP_List_GetEntry | TWBArgList
TFontContents | TMUIP_List_Insert | TWBHandlerMessage
TFontContentsHeader | TMUIP_List_InsertSingle | TWBHM_type
TFontRequester | TMUIP_List_Jump | TW_BROWSE
TF_PROCTIME | TMUIP_List_Move | TWBStartup
TFrameInfo | TMUIP_List_NextSelected | TW_EDIT
TFReadLineData | TMUIP_List_Redraw | TWindow
TFreeList | TMUIP_List_Remove | TWindowPos
TF_RX | TMUIP_List_Select | TW_INFO
TF_SHELL | TMUIP_List_Sort | TW_MAIL
TF_STACKCHK | TMUIP_List_TestPos | TW_PRINT
TF_SWITCH | TMUIP_MultiSet | TypeOfMem
TF_WORKBENCH | TMUIP_NoNotifySet | TYUVRenderInfo
TGadget | TMUIP_Notify |

U

UBMI_REALLYUNLOCK | UCR_KHMER | UnlockBitMapFromBoard
UBMI_UPDATERECTS | UCR_LAO | UnLockBitMapTagList
Byte | UCR_LATIN1_SUPPLEMENT | UnLockBitMapTags
UCopperListInit | UCR_LATIN_EXTENDED_A | UnlockClassList
UCR_ALPHABETIC_PRESENTATION_FORMS | UCR_LATIN_EXTENDED_ADDITIONAL | UnLockDosList
UCR_ARABIC | UCR_LATIN_EXTENDED_B | UnlockGUIPrefs
UCR_ARABIC_PRESENTATIONS_A | UCR_LETTERLIKE_SYMBOLS | UnlockIBase
UCR_ARABIC_PRESENTATIONS_B | UCR_MALAYALAM | UnlockLayer
UCR_ARMENIAN | UCR_MATHEMATICAL_OPERATORS | UnlockLayerInfo
UCR_ARROWS | UCR_MISCELLANEOUS_SYMBOLS | UnlockLayerRom
UCR_BASIC_LATIN | UCR_MISCELLANEOUS_TECHNICAL | UnlockLayers
UCR_BENGALI | UCR_MONGOLIAN | UnLockMem
UCR_BLOCK_ELEMENTS | UCR_MYANMAR | UnlockNamedMemory
UCR_BOPOMOFO | UCR_NUMBER_FORMS | UnlockPubScreen
UCR_BOX_DRAWING | UCR_OCR | UnlockPubScreenList
UCR_BRAILLE | UCR_OGHAM | UnLockRecord
UCR_CANADIAN_ABORIGINAL_SYLLABICS | UCR_ORIYA | UnLockRecords
UCR_CHEROKEE | UCR_PRIVATE_USE | UnlockScreen
UCR_CJK_COMPATIBILITY | UCR_RUNIC | UnlockScreenGI
UCR_CJK_COMPATIBILITY_FORMS | UCR_SINHALA | UnlockScreenList
UCR_CJK_COMPATIBILITY_IDEOGRAPHS | UCR_SMALL_FORM_VARIANTS | UNPACK_ICON_ASPECT_RATIO
UCR_CJK_MISC | UCR_SPACING_MODIFIER | UnpackStructureTags
UCR_CJK_SYMBOLS | UCR_SPECIALS | UnTrackAddress
UCR_CJK_UNIFIED_IDEOGRAPHS | UCR_SUPERSCRIPTS_SUBSCRIPTS | UnTrackSegmentList
UCR_COMBINING_DIACRITICS | UCR_SURROGATES | UpdateNamedMemory
UCR_COMBINING_DIACRITICS_SYMB | UCR_SYRIAC | UPDATEWB_ObjectAdded
UCR_COMBINING_HALF_MARKS | UCR_TAMIL | UPDATEWB_ObjectRemoved
UCR_CONTROL_PICTURES | UCR_TELUGU | UpdateWorkbench
UCR_CURRENCY_SYMBOLS | UCR_THAANA | UPFRONTGADGET
UCR_CYRILLIC | UCR_THAI | UpfrontLayer
UCR_DEVANAGARI | UCR_TIBETAN | UPIMAGE
UCR_DINGBATS | UCR_YI | USER_COPPER_CLIP
UCR_ENCLOSED_ALPHANUMERICS | UCS4Count | USEREQIMAGE
UCR_ENCLOSED_CJK_LETTERS_MONTHS | UCS4ToLower | UserState
UCR_ETHIOPIC | UCS4ToUpper | US_LEGAL
UCR_GENERAL_PUNCTUATION | UCS4toUTF8 | US_LETTER
UCR_GEOMETRIC_SHAPES | UCS4Valid | UTF8Count
UCR_GEORGIAN | LongWord | UTF8Decode
UCR_GREEK | UnGetC | UTF8Encode
UCR_GREEK_EXTENDED | UNIT_ECLOCK | UTF8Stricmp
UCR_GUJARATI | UNIT_ENTROPY | UTF8Strnicmp
UCR_GURMUKHI | UNITF_ACTIVE | UTF8toUCS4
UCR_HALFWIDTH_FULLWIDTH_FORMS | UNITF_INTASK | UTF_INVALID_SUBST_FFFD
UCR_HANGUL | UNIT_MICROHZ | utility
UCR_HANGUL_COMPATIBILITY_JAMO | UNIT_VBLANK | UtilityBase
UCR_HANGUL_JAMO | UNIT_WAITECLOCK | UtilityClone
UCR_HEBREW | UNIT_WAITUNTIL | UtilityExpunge
UCR_HIRAGANA | Unity | UtilityObtain
UCR_IPA_EXTENSIONS | UnLoadSeg | UtilityRelease
UCR_KANBUN | UnLock | Word
UCR_KANNADA | UnLockBitMap |
UCR_KATAKANA | UnlockBitMap |

V

Vacate | VGAPRODUCTHAM_KEY | VSOVERFLOW
VASPrintf | VGAPRODUCTHAMLACE_KEY | VSPRITE_f
VBeamPos | VGAPRODUCT_KEY | VTAG_ATTACH_CM_GET
VC_DPMSLevel | VGAPRODUCTLACEDPF2_KEY | VTAG_ATTACH_CM_SET
VC_DUALPF_Disable | VGAPRODUCTLACEDPF_KEY | VTAG_BATCH_CM_CLR
VC_DUALPF_Disable_Query | VGAPRODUCTLACE_KEY | VTAG_BATCH_CM_GET
VC_IntermediateCLUpdate | VGA_TOTAL_ROWS | VTAG_BATCH_CM_SET
VC_IntermediateCLUpdate_Query | VGA_VBSTOP | VTAG_BATCH_ITEMS_ADD
VC_NoColorPaletteLoad | VGA_VBSTRT | VTAG_BATCH_ITEMS_GET
VC_NoColorPaletteLoad_Query | VGA_VSSTOP | VTAG_BATCH_ITEMS_SET
VECTORTYPE_ALTIVEC | VGA_VSSTRT | VTAG_BITPLANEKEY_CLR
VECTORTYPE_NONE | VideoControl | VTAG_BITPLANEKEY_GET
VFPrintf | VIDEOCONTROL_BATCH | VTAG_BITPLANEKEY_SET
VGA70_COLORCLOCKS | VideoControlTags | VTAG_BORDERBLANK_CLR
VGA70_DENISE_MIN | ViewAddress | VTAG_BORDERBLANK_GET
VGA70_HBSTOP | VIEW_EXTRA_TYPE | VTAG_BORDERBLANK_SET
VGA70_HBSTRT | ViewPortAddress | VTAG_BORDERNOTRANS_CLR
VGA70_HSSTOP | VIEWPORT_EXTRA_TYPE | VTAG_BORDERNOTRANS_GET
VGA70_HSSTRT | VIF_3DDISABLE | VTAG_BORDERNOTRANS_SET
VGA70_MONITOR_NAME | VIF_ALPHABLEND | VTAG_BORDERSPRITE_CLR
VGA70_TOTAL_ROWS | VIF_ALPHASHADE | VTAG_BORDERSPRITE_GET
VGA70_VBSTOP | VIF_ALPHASHADOW | VTAG_BORDERSPRITE_SET
VGA70_VBSTRT | VIF_ALPHASHINE | VTAG_CHROMAKEY_CLR
VGA70_VSSTOP | VIF_BORDERMASK | VTAG_CHROMAKEY_GET
VGA70_VSSTRT | VIF_BRCORN | VTAG_CHROMAKEY_SET
VGA_COLORCLOCKS | VIF_BUTTON | VTAG_CHROMA_PEN_CLR
VGA_DENISE_MIN | VIF_HORIZARROW | VTAG_CHROMA_PEN_GET
VGAEHB_KEY | VIF_IGNOREHEIGHT | VTAG_CHROMA_PEN_SET
VGAEHBLACE_KEY | VIF_IGNOREWIDTH | VTAG_CHROMA_PLANE_GET
VGAEXTRAHALFBRITE_KEY | VIF_KEEPASPECT | VTAG_CHROMA_PLANE_SET
VGAEXTRAHALFBRITELACE_KEY | VIF_MENU | VTAG_COERCE_DISP_GET
VGAEXTRALORESDBL_KEY | VIF_NOBUFFER | VTAG_COERCE_DISP_SET
VGAEXTRALORESDPF2_KEY | VIF_PENSHADE | VTAG_DEFSPRITERESN_GET
VGAEXTRALORESDPF_KEY | VIF_REFFONT | VTAG_DEFSPRITERESN_SET
VGAEXTRALORESEHBDBL_KEY | VIF_ROUNDEDSCALING | VTAG_END_CM
VGAEXTRALORESEHB_KEY | VIF_SCREENBAR | VTAG_FULLPALETTE_CLR
VGAEXTRALORESEHBLACE_KEY | VIF_TBLEFT | VTAG_FULLPALETTE_GET
VGAEXTRALORESHAMDBL_KEY | VIF_TBRIGHT | VTAG_FULLPALETTE_SET
VGAEXTRALORESHAM_KEY | VIF_VERTARROW | VTAG_IMMEDIATE
VGAEXTRALORESHAMLACE_KEY | VIF_WMULTIPLY | VTAG_NEXTBUF_CM
VGAEXTRALORES_KEY | VKHANDLEIMAGE | VTAG_NORMAL_DISP_GET
VGAEXTRALORESLACEDPF2_KEY | VMAreaInit | VTAG_NORMAL_DISP_SET
VGAEXTRALORESLACEDPF_KEY | VMAreaTerm | VTAG_PF1_BASE_GET
VGAEXTRALORESLACE_KEY | VO_ELPS | VTAG_PF1_BASE_SET
VGAHAM_KEY | VO_END | VTAG_PF1_TO_SPRITEPRI_GET
VGAHAMLACE_KEY | VO_FILL | VTAG_PF1_TO_SPRITEPRI_SET
VGA_HBSTOP | VO_FILLELPS | VTAG_PF2_BASE_GET
VGA_HBSTRT | VO_FILLPOLY | VTAG_PF2_BASE_SET
VGA_HSSTOP | VO_FILLRECT | VTAG_PF2_TO_SPRITEPRI_GET
VGA_HSSTRT | VO_LINE | VTAG_PF2_TO_SPRITEPRI_SET
VGALORESDBL_KEY | VO_LINEELPS | VTAG_SPEVEN_BASE_GET
VGALORESDPF2_KEY | VO_LINEPOLY | VTAG_SPEVEN_BASE_SET
VGALORESDPF_KEY | VO_LINERECT | VTAG_SPODD_BASE_GET
VGALORESEHBDBL_KEY | VO_POLY | VTAG_SPODD_BASE_SET
VGALORESEHB_KEY | VO_RECT | VTAG_SPRITERESN_GET
VGALORESEHBLACE_KEY | VPF_A2024 | VTAG_SPRITERESN_SET
VGALORESHAMDBL_KEY | VPF_AGNUS | VTAG_USERCLIP_CLR
VGALORESHAM_KEY | VPF_TENHZ | VTAG_USERCLIP_GET
VGALORESHAMLACE_KEY | VP_HIDE | VTAG_USERCLIP_SET
VGALORES_KEY | VPOSRLOF | VTAG_VIEWPORTEXTRA_GET
VGALORESLACEDPF2_KEY | VPrintf | VTAG_VIEWPORTEXTRA_SET
VGALORESLACEDPF_KEY | VPXB_FREE_ME | VTAG_VPMODEID_CLR
VGALORESLACE_KEY | VPXB_LAST | VTAG_VPMODEID_GET
VGA_MONITOR_ID | VPXB_STRADDLES_256 | VTAG_VPMODEID_SET
VGA_MONITOR_NAME | VPXB_STRADDLES_512 | VT_BOTH
VGAPRODUCTDBL_KEY | VPXF_FREE_ME | VT_COLOR
VGAPRODUCTDPF2_KEY | VPXF_LAST | VT_MONO
VGAPRODUCTDPF_KEY | VPXF_STRADDLES_256 | SmallInt
VGAPRODUCTEHBDBL_KEY | VPXF_STRADDLES_512 |
VGAPRODUCTHAMDBL_KEY | VSNPrintf |

W

WA_Activate | WA_WindowBox | WBENCHOPEN
WA_AlphaClips | WA_WindowName | WBENCHSCREEN_F
WA_AlphaHook | WA_Zoom | WBenchToBack
WA_AmigaKey | WBA_Dummy | WBenchToFront
WA_AutoAdjust | WBA_LAST_TAG | WBExpunge
WA_AutoAdjustDClip | WBAPPICON | WBGARBAGE
WA_Backdrop | WBAPPICONA_NotifySelectState | WBHM_TYPE_HIDE
WA_BackFill | WBAPPICONA_PropagatePosition | WBHM_TYPE_OPEN
WA_BlockPen | WBAPPICONA_RenderHook | WBHM_TYPE_SHOW
WA_Borderless | WBAPPICONA_SupportsCopy | WBHM_TYPE_UPDATE
WA_BusyPointer | WBAPPICONA_SupportsDelete | WBInfo
WA_Checkmark | WBAPPICONA_SupportsEmptyTrash | WBKICK
WA_CloseGadget | WBAPPICONA_SupportsFormatDisk | WBObtain
WA_Colors | WBAPPICONA_SupportsInformation | WBOPENA_ArgLock
WA_ContextMenuHook | WBAPPICONA_SupportsLeaveOut | WBOPENA_ArgName
WA_CustomScreen | WBAPPICONA_SupportsOpen | WBOPENA_Show
WA_DepthGadget | WBAPPICONA_SupportsPutAway | WBOPENA_ViewBy
WA_DetailPen | WBAPPICONA_SupportsRename | WBPROJECT
WA_DragBar | WBAPPICONA_SupportsSnapshot | WBRelease
WA_DropShadows | WBAPPICONA_SupportsUnSnapshot | WBTOOL
WA_Dummy | WBAPPMENUA_CommandKeyString | WFDB_READ
WA_FadeTime | WBAPPMENUA_GetKey | WFDB_WRITE
WA_Flags | WBAPPMENUA_GetTitleKey | WFDF_READ
WA_Gadgets | WBAPPMENUA_UseKey | WFDF_WRITE
WA_GimmeZeroZero | WBA_Reserved1 | WFLG_ACTIVATE
WA_GrabFocus | WBA_Reserved10 | WFLG_BACKDROP
WA_Height | WBA_Reserved11 | WFLG_BORDERLESS
WA_HelpGroup | WBA_Reserved12 | WFLG_CLOSEGADGET
WA_HelpGroupWindow | WBA_Reserved13 | WFLG_DEPTHGADGET
WA_Hidden | WBA_Reserved14 | WFLG_DRAGBAR
WA_IDCMP | WBA_Reserved15 | WFLG_GIMMEZEROZERO
WA_InFrontOf | WBA_Reserved16 | WFLG_HASZOOM
WA_InnerHeight | WBA_Reserved17 | WFLG_INREQUEST
WA_InnerWidth | WBA_Reserved18 | WFLG_MENUSTATE
Wait | WBA_Reserved19 | WFLG_NEWLOOKMENUS
WaitBlit | WBA_Reserved2 | WFLG_NOCAREREFRESH
WaitBOVP | WBA_Reserved3 | WFLG_NW_EXTENDED
WaitForChar | WBA_Reserved4 | WFLG_OTHER_REFRESH
WaitForData | WBA_Reserved5 | WFLG_REFRESHBITS
WaitIO | WBA_Reserved6 | WFLG_REPORTMOUSE
WaitPkt | WBA_Reserved7 | WFLG_RMBTRAP
WaitPort | WBA_Reserved8 | WFLG_SIMPLE_REFRESH
WaitTOF | WBA_Reserved9 | WFLG_SIZEBBOTTOM
WA_Left | WBClone | WFLG_SIZEBRIGHT
WA_MaxHeight | WBCTRLA_AddHiddenDeviceName | WFLG_SIZEGADGET
WA_MaxWidth | WBCTRLA_AddSetupCleanupHook | WFLG_SMART_REFRESH
WA_MenuHelp | WBCTRLA_DuplicateSearchPath | WFLG_SUPER_BITMAP
WA_MenuHook | WBCTRLA_FreeHiddenDeviceList | WFLG_VISITOR
WA_MenuStrip | WBCTRLA_FreeOpenDrawerList | WFLG_WBENCHWINDOW
WA_MinHeight | WBCTRLA_FreeProgramList | WFLG_WINDOWACTIVE
WA_MinWidth | WBCTRLA_FreeSearchPath | WFLG_WINDOWREFRESH
WA_MouseLimits | WBCTRLA_FreeSelectedIconList | WFLG_WINDOWTICKED
WA_MouseQueue | WBCTRLA_GetCopyHook | WFLG_ZOOMED
WA_NewLookMenus | WBCTRLA_GetDefaultStackSize | WhichLayer
WA_NoCareRefresh | WBCTRLA_GetDeleteHook | WhichWorkbenchObjectA
WA_NoHitThreshold | WBCTRLA_GetHiddenDeviceList | WINDOW_BACKMOST
WA_NoMenuKeyVerify | WBCTRLA_GetOpenDrawerList | WINDOW_FRONTMOST
WA_NotifyDepth | WBCTRLA_GetProgramList | WindowLimits
WA_Opaqueness | WBCTRLA_GetSelectedIconList | WindowToBack
WA_OverrideOpaqueness | WBCTRLA_GetTextInputHook | WindowToFront
WA_Pointer | WBCTRLA_GettypeRestartTime | Word
WA_PointerDelay | WBCTRLA_IsOpen | Workbench
WA_PointerType | WBCTRLA_RedrawAppIcon | WorkbenchBase
WA_PubScreen | WBCTRLA_RemoveHiddenDeviceName | WorkbenchControl
WA_PubScreenFallBack | WBCTRLA_RemSetupCleanupHook | WorkbenchControlA
WA_PubScreenName | WBCTRLA_SetCopyHook | WORKBENCHNAME
WA_ReportMouse | WBCTRLA_SetDefaultStackSize | WriteChars
WA_Reserved1 | WBCTRLA_SetDeleteHook | WriteChunkBytes
WA_Reserved2 | WBCTRLA_SetTextInputHook | WriteChunkRecords
WA_RMBTrap | WBCTRLA_SettypeRestartTime | WriteChunkyPixels
WA_RptQueue | WBDEVICE | WriteDiskFontHeaderA
WA_ScreenTitle | WBDISK | WriteFontContents
WA_ShapeHook | WB_DISKMAGIC | WriteLUTPixelArray
WA_ShapeRegion | WB_DISKREVISION | WritePixel
WA_SimpleRefresh | WB_DISKREVISIONMASK | WritePixelArray
WA_SizeBBottom | WB_DISKVERSION | WritePixelArray
WA_SizeBRight | WBDRAWER | WritePixelArray8
WA_SizeGadget | WBDZA_Box | WritePixelArrayAlpha
WA_SmartRefresh | WBDZA_Height | WritePixelColor
WA_StayTop | WBDZA_Hook | WritePixelLine8
WA_SuperBitMap | WBDZA_Left | WriteProtectVolume
WA_TabletMessages | WBDZA_RelBottom | WriteProtectVolumePort
WA_Title | WBDZA_RelHeight | WriteRGBPixel
WA_ToolBox | WBDZA_RelRight | WTPOS_CENTERABS
WA_Top | WBDZA_RelWidth | WTPOS_CENTERREL
WA_UserPort | WBDZA_Top | WTPOS_LEFT
WA_WBenchWindow | WBDZA_Width | W_TRACTOR
WA_Width | WBENCHCLOSE |

X

XorRectRegion XorRegionRegion

Y

YESSTR YESTERDAYSTR

Z

ZipWindow ZOOMIMAGE


A2024_MONITOR_ID

Declaration

Source position: agraphics.pas line 1587

const A2024_MONITOR_ID = $00041000;


A2024FIFTEENHERTZ_KEY

Declaration

Source position: agraphics.pas line 1589

const A2024FIFTEENHERTZ_KEY = $00049000;


A2024TENHERTZ_KEY

Declaration

Source position: agraphics.pas line 1588

const A2024TENHERTZ_KEY = $00041000;


ALPHAHOOKACTION_CHANGELAYERALPHA

Declaration

Source position: agraphics.pas line 895

const ALPHAHOOKACTION_CHANGELAYERALPHA = 4;


ALPHAHOOKACTION_CREATELAYER

Declaration

Source position: agraphics.pas line 891

const ALPHAHOOKACTION_CREATELAYER = 0;


ALPHAHOOKACTION_DELETELAYER

Declaration

Source position: agraphics.pas line 896

const ALPHAHOOKACTION_DELETELAYER = 5;


ALPHAHOOKACTION_GETHOOKACTIONS

Declaration

Source position: agraphics.pas line 897

const ALPHAHOOKACTION_GETHOOKACTIONS = 6;


ALPHAHOOKACTION_MOVELAYER

Declaration

Source position: agraphics.pas line 892

const ALPHAHOOKACTION_MOVELAYER = 1;


ALPHAHOOKACTION_MOVESIZELAYER

Declaration

Source position: agraphics.pas line 894

const ALPHAHOOKACTION_MOVESIZELAYER = 3;


ALPHAHOOKACTION_SIZELAYER

Declaration

Source position: agraphics.pas line 893

const ALPHAHOOKACTION_SIZELAYER = 2;


ANFRACSIZE

Define for the animation procedures

Declaration

Source position: agraphics.pas line 425

const ANFRACSIZE = 6;


ANIMHALF

Define for the animation procedures

Declaration

Source position: agraphics.pas line 426

const ANIMHALF = $0020;


AREAOUTLINE

Used by areafiller only used for bobs

Declaration

Source position: agraphics.pas line 369

const AREAOUTLINE = $08;

See also

TRastPort

Basic structure for all drawing actions


AUserStuff

Declaration

Source position: agraphics.pas line 742

type AUserStuff = SmallInt;


AVOID_FLICKER

Flag for CoerceMode Ensure that the mode coerced to is not interlaced.

Declaration

Source position: agraphics.pas line 393

const AVOID_FLICKER = 2;


B2BOBBER

Declaration

Source position: agraphics.pas line 860

const B2BOBBER = 2;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

B2NORM

Declaration

Source position: agraphics.pas line 858

const B2NORM = 0;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

B2SWAP

Declaration

Source position: agraphics.pas line 859

const B2SWAP = 1;


BACKSAVED

System Set flag for TVsprite.Flags. This Bob's background has been saved

Declaration

Source position: agraphics.pas line 406

const BACKSAVED = $0100;


BANDWIDTH_1X

Memory Type

Declaration

Source position: agraphics.pas line 2279

const BANDWIDTH_1X = BUS_16 or NML_CAS;


BANDWIDTH_2XDBL

Memory Type

Declaration

Source position: agraphics.pas line 2281

const BANDWIDTH_2XDBL = DBL_CAS;


BANDWIDTH_2XNML

Memory Type

Declaration

Source position: agraphics.pas line 2280

const BANDWIDTH_2XNML = BUS_32;


BANDWIDTH_4X

Memory Type

Declaration

Source position: agraphics.pas line 2282

const BANDWIDTH_4X = BUS_32 or DBL_CAS;


BDRAWN

Bob System Flag for TBob.Flags set when Bob is drawn this DrawG pass

Declaration

Source position: agraphics.pas line 418

const BDRAWN = $0200;


BGBACKFILL

Declaration

Source position: agraphics.pas line 360

const BGBACKFILL = 8;


BIDTAG_BlueBits

Tag for BestModeID() Match up from the DataBase default - 4

Declaration

Source position: agraphics.pas line 1763

const BIDTAG_BlueBits = $8000000c;


BIDTAG_COERCE

Flags for CoerceMode Private

Declaration

Source position: agraphics.pas line 396

const BIDTAG_COERCE = 1;


BIDTAG_Depth

Tag for BestModeID() ModeID must support this depth. Default - TViewPort.RasInfo^.BitMap^.Depth or 1

Declaration

Source position: agraphics.pas line 1759

const BIDTAG_Depth = $80000008;


BIDTAG_DesiredHeight

Tag for BestModeID() Nominal Height of the returned ModeID. Default - same as Nominal

Declaration

Source position: agraphics.pas line 1758

const BIDTAG_DesiredHeight = $80000007;


BIDTAG_DesiredWidth

Tag for BestModeID() Nominal Width of the returned ModeID. Default - same as Nominal

Declaration

Source position: agraphics.pas line 1757

const BIDTAG_DesiredWidth = $80000006;


BIDTAG_DIPFMustHave

Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0

Declaration

Source position: agraphics.pas line 1752

const BIDTAG_DIPFMustHave = $80000001;


BIDTAG_DIPFMustNotHave

Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default

Declaration

Source position: agraphics.pas line 1753

const BIDTAG_DIPFMustNotHave = $80000002;


BIDTAG_GfxPrivate

Tag for BestModeID() Private do not use

Declaration

Source position: agraphics.pas line 1765

const BIDTAG_GfxPrivate = $8000000e;


BIDTAG_GreenBits

Tag for BestModeID() Match up from the DataBase default - 4

Declaration

Source position: agraphics.pas line 1764

const BIDTAG_GreenBits = $8000000d;


BIDTAG_MaxDepth

Declaration

Source position: agraphics.pas line 1766

const BIDTAG_MaxDepth = $8000000f;


BIDTAG_MonitorID

Tag for BestModeID() ModeID must use this monitor. Default - use best monitor available

Declaration

Source position: agraphics.pas line 1760

const BIDTAG_MonitorID = $80000009;


BIDTAG_NominalHeight

Tag for BestModeID() Override the TViewPort.Height. Default - SourceID NominalDimensionInfo or TViewPort.DHeight or 200 in that order

Declaration

Source position: agraphics.pas line 1756

const BIDTAG_NominalHeight = $80000005;


BIDTAG_NominalWidth

Tag for BestModeID() Override the TViewPort.Width. Default - SourceID NominalDimensionInfo or TViewPort.DWidth or 640 in that order

Declaration

Source position: agraphics.pas line 1755

const BIDTAG_NominalWidth = $80000004;


BIDTAG_RedBits

Tag for BestModeID() Match up from the DataBase default - 4

Declaration

Source position: agraphics.pas line 1762

const BIDTAG_RedBits = $8000000b;


BIDTAG_SourceID

Tag for BestModeID() Instead of a ViewPort. Default - VPModeID(vp) if BIDTAG_ViewPort is specified, else leave the BIDTAG_DIPFMustHave and BIDTAG_DIPFMustNotHave values untouched.

Declaration

Source position: agraphics.pas line 1761

const BIDTAG_SourceID = $8000000a;


BIDTAG_ViewPort

Tag for BestModeID() ViewPort for which a ModeID is sought. Default - nil

Declaration

Source position: agraphics.pas line 1754

const BIDTAG_ViewPort = $80000003;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

BITCLR

Declaration

Source position: agraphics.pas line 73

const BITCLR = 0;


BITSET

Declaration

Source position: agraphics.pas line 72

const BITSET = $8000;


BLITA_Alpha

Declaration

Source position: agraphics.pas line 46

const BLITA_Alpha = BLTBMTAGS_BASE + 19;


BLITA_AlphaMask

Declaration

Source position: agraphics.pas line 38

const BLITA_AlphaMask = BLTBMTAGS_BASE + 12;


BLITA_CLUT

Declaration

Source position: agraphics.pas line 48

const BLITA_CLUT = BLTBMTAGS_BASE + 20;


BLITA_Dest

Declaration

Source position: agraphics.pas line 34

const BLITA_Dest = BLTBMTAGS_BASE + 8;


BLITA_DestBytesPerRow

Declaration

Source position: agraphics.pas line 41

const BLITA_DestBytesPerRow = BLTBMTAGS_BASE + 15;


BLITA_DestType

Declaration

Source position: agraphics.pas line 42

const BLITA_DestType = BLTBMTAGS_BASE + 16;


BLITA_DestX

Declaration

Source position: agraphics.pas line 29

const BLITA_DestX = BLTBMTAGS_BASE + 3;


BLITA_DestY

Declaration

Source position: agraphics.pas line 30

const BLITA_DestY = BLTBMTAGS_BASE + 4;


BLITA_Height

Declaration

Source position: agraphics.pas line 32

const BLITA_Height = BLTBMTAGS_BASE + 6;


BLITA_Mask

Declaration

Source position: agraphics.pas line 36

const BLITA_Mask = BLTBMTAGS_BASE + 10;


BLITA_MaskPlane

Declaration

Source position: agraphics.pas line 37

const BLITA_MaskPlane = BLTBMTAGS_BASE + 11;


BLITA_Minterm

Declaration

Source position: agraphics.pas line 35

const BLITA_Minterm = BLTBMTAGS_BASE + 9;


BLITA_Source

Declaration

Source position: agraphics.pas line 33

const BLITA_Source = BLTBMTAGS_BASE + 7;


BLITA_SrcBytesPerRow

Declaration

Source position: agraphics.pas line 39

const BLITA_SrcBytesPerRow = BLTBMTAGS_BASE + 13;


BLITA_SrcType

Declaration

Source position: agraphics.pas line 40

const BLITA_SrcType = BLTBMTAGS_BASE + 14;


BLITA_SrcX

Declaration

Source position: agraphics.pas line 27

const BLITA_SrcX = BLTBMTAGS_BASE + 1;


BLITA_SrcY

Declaration

Source position: agraphics.pas line 28

const BLITA_SrcY = BLTBMTAGS_BASE + 2;


BLITA_UseDestAlpha

Declaration

Source position: agraphics.pas line 44

const BLITA_UseDestAlpha = BLTBMTAGS_BASE + 18;


BLITA_UseSrcAlpha

Declaration

Source position: agraphics.pas line 43

const BLITA_UseSrcAlpha = BLTBMTAGS_BASE + 17;


BLITA_Width

Declaration

Source position: agraphics.pas line 31

const BLITA_Width = BLTBMTAGS_BASE + 5;


BLITMSG_FAULT

Declaration

Source position: agraphics.pas line 2251

const BLITMSG_FAULT = 1 shl BLITMSG_FAULTn;


BLITMSG_FAULTn

Declaration

Source position: agraphics.pas line 2249

const BLITMSG_FAULTn = 2;


BLITT_ALPHATEMPLATE

Declaration

Source position: agraphics.pas line 54

const BLITT_ALPHATEMPLATE = 3;


BLITT_ARGB32

Declaration

Source position: agraphics.pas line 57

const BLITT_ARGB32 = 6;


BLITT_BITMAP

Declaration

Source position: agraphics.pas line 51

const BLITT_BITMAP = 0;


BLITT_CHUNKY

Declaration

Source position: agraphics.pas line 55

const BLITT_CHUNKY = 4;


BLITT_RASTPORT

Declaration

Source position: agraphics.pas line 52

const BLITT_RASTPORT = 1;


BLITT_RGB16

Declaration

Source position: agraphics.pas line 58

const BLITT_RGB16 = 7;


BLITT_RGB24

Declaration

Source position: agraphics.pas line 56

const BLITT_RGB24 = 5;


BLITT_TEMPLATE

Declaration

Source position: agraphics.pas line 53

const BLITT_TEMPLATE = 2;


BLTBMTAGS_BASE

Declaration

Source position: agraphics.pas line 26

const BLTBMTAGS_BASE = TAG_USER;


BMA_ACTUALWIDTH

Declaration

Source position: agraphics.pas line 205

const BMA_ACTUALWIDTH = 20;


BMA_BITSPERPIXEL

Declaration

Source position: agraphics.pas line 203

const BMA_BITSPERPIXEL = 18;


BMA_BYTESPERPIXEL

Declaration

Source position: agraphics.pas line 202

const BMA_BYTESPERPIXEL = 17;


BMA_DEPTH

ID are for GetBitMapAttr. Query depth of bitmap.

Declaration

Source position: agraphics.pas line 198

const BMA_DEPTH = 4;


BMA_FLAGS

ID are for GetBitMapAttr. Query Flags (BMF_*) of bitmap.

Declaration

Source position: agraphics.pas line 200

const BMA_FLAGS = 12;


BMA_HEIGHT

ID are for GetBitMapAttr. Query height of bitmap.

Declaration

Source position: agraphics.pas line 197

const BMA_HEIGHT = 0;


BMA_ISRTG

Declaration

Source position: agraphics.pas line 201

const BMA_ISRTG = 16;


BMA_PIXELFORMAT

Declaration

Source position: agraphics.pas line 204

const BMA_PIXELFORMAT = 19;


BMA_WIDTH

ID are for GetBitMapAttr. Query width of bitmap.

Declaration

Source position: agraphics.pas line 199

const BMA_WIDTH = 8;


BMATags_Alignment

Declaration

Source position: agraphics.pas line 178

const BMATags_Alignment = TAG_USER + 15;


BMATags_BitmapColors

Declaration

Source position: agraphics.pas line 190

const BMATags_BitmapColors = TAG_USER + $29;


BMATags_BitmapColors32

Declaration

Source position: agraphics.pas line 192

const BMATags_BitmapColors32 = TAG_USER + $43;


BMATags_BitmapInvisible

Declaration

Source position: agraphics.pas line 188

const BMATags_BitmapInvisible = TAG_USER + $37;


BMATags_Clear

Declaration

Source position: agraphics.pas line 166

const BMATags_Clear = TAG_USER + 3;


BMATags_ConstantBytesPerRow

Declaration

Source position: agraphics.pas line 180

const BMATags_ConstantBytesPerRow = TAG_USER + 16;


BMATags_Depth

Declaration

Source position: agraphics.pas line 164

const BMATags_Depth = TAG_USER + 1;


BMATags_Displayable

Declaration

Source position: agraphics.pas line 167

const BMATags_Displayable = TAG_USER + 4;


BMATags_DisplayID

Declaration

Source position: agraphics.pas line 186

const BMATags_DisplayID = TAG_USER + $32;


BMATags_Friend

Declaration

Source position: agraphics.pas line 163

const BMATags_Friend = TAG_USER + 0;


BMATags_ModeHeight

Declaration

Source position: agraphics.pas line 174

const BMATags_ModeHeight = TAG_USER + 11;


BMATags_ModeWidth

Declaration

Source position: agraphics.pas line 173

const BMATags_ModeWidth = TAG_USER + 10;


BMATags_NoMemory

Declaration

Source position: agraphics.pas line 169

const BMATags_NoMemory = TAG_USER + 6;


BMATags_NoSprite

Declaration

Source position: agraphics.pas line 170

const BMATags_NoSprite = TAG_USER + 7;


BMATags_PixelFormat

Declaration

Source position: agraphics.pas line 165

const BMATags_PixelFormat = TAG_USER + 2;


BMATags_Private1

Declaration

Source position: agraphics.pas line 168

const BMATags_Private1 = TAG_USER + 5;


BMATags_Private2

Declaration

Source position: agraphics.pas line 171

const BMATags_Private2 = TAG_USER + 8;


BMATags_Private3

Declaration

Source position: agraphics.pas line 172

const BMATags_Private3 = TAG_USER + 9;


BMATags_Private4

Declaration

Source position: agraphics.pas line 182

const BMATags_Private4 = TAG_USER + 18;


BMATags_Private5

Declaration

Source position: agraphics.pas line 183

const BMATags_Private5 = TAG_USER + 19;


BMATags_Private6

Declaration

Source position: agraphics.pas line 184

const BMATags_Private6 = TAG_USER + 20;


BMATags_Private7

Declaration

Source position: agraphics.pas line 185

const BMATags_Private7 = TAG_USER + 21;


BMATags_RenderFunc

Declaration

Source position: agraphics.pas line 175

const BMATags_RenderFunc = TAG_USER + 12;


BMATags_SaveFunc

Declaration

Source position: agraphics.pas line 176

const BMATags_SaveFunc = TAG_USER + 13;


BMATags_UserData

Declaration

Source position: agraphics.pas line 177

const BMATags_UserData = TAG_USER + 14;


BMATags_UserPrivate

Declaration

Source position: agraphics.pas line 181

const BMATags_UserPrivate = TAG_USER + 17;


BMB_CLEAR

Bit flag for AllocBitMap Fill Bitmap with color 0

Declaration

Source position: agraphics.pas line 131

const BMB_CLEAR = 0;


BMB_DISPLAYABLE

Bit flag for AllocBitMap Displayable Bitmap

Declaration

Source position: agraphics.pas line 132

const BMB_DISPLAYABLE = 1;

Description

This bitmap data should be allocated in such a manner that it can be displayed. Displayable data has more severe alignment restrictions than non-displayable data in some systems.


BMB_FRIENDISTAG

Declaration

Source position: agraphics.pas line 142

const BMB_FRIENDISTAG = 10;


BMB_HIJACKED

Declaration

Source position: agraphics.pas line 139

const BMB_HIJACKED = 7;


BMB_INTERLEAVED

Bit flag for AllocBitMap Interleaved Bitmap

Declaration

Source position: agraphics.pas line 133

const BMB_INTERLEAVED = 2;

Description

The bitmap will be allocated with one large chunk of display memory for all bitplanes. This minimizes color flashing on deep displays. If there is not enough contiguous RAM for an interleaved bitmap, graphics.library will fall back to a non-interleaved one.


BMB_INVALID

Declaration

Source position: agraphics.pas line 143

const BMB_INVALID = 11;


BMB_LOCKED

Declaration

Source position: agraphics.pas line 145

const BMB_LOCKED = 12;


BMB_MINPLANES

Bit flag for AllocBitMap Minimal memory use

Declaration

Source position: agraphics.pas line 135

const BMB_MINPLANES = 4;


BMB_RTGCHECK

Declaration

Source position: agraphics.pas line 141

const BMB_RTGCHECK = 9;


BMB_RTGTAGS

Declaration

Source position: agraphics.pas line 140

const BMB_RTGTAGS = 8;


BMB_STANDARD

Bit flag for AllocBitMap

Declaration

Source position: agraphics.pas line 134

const BMB_STANDARD = 3;


BMF_CHECKMASK

Declaration

Source position: agraphics.pas line 159

const BMF_CHECKMASK = BMF_HIJACKED or BMF_RTGTAGS or BMF_RTGCHECK or BMF_FRIENDISTAG or BMF_INVALID;


BMF_CHECKVALUE

Declaration

Source position: agraphics.pas line 160

const BMF_CHECKVALUE = BMF_RTGTAGS or BMF_RTGCHECK or BMF_FRIENDISTAG;


BMF_CLEAR

Bit value for AllocBitMap Fill Bitmap with color 0

Declaration

Source position: agraphics.pas line 147

const BMF_CLEAR = 1 shl BMB_CLEAR;


BMF_DISPLAYABLE

Bit flag for AllocBitMap Displayable Bitmap

Declaration

Source position: agraphics.pas line 148

const BMF_DISPLAYABLE = 1 shl BMB_DISPLAYABLE;

Description

This bitmap data should be allocated in such a manner that it can be displayed. Displayable data has more severe alignment restrictions than non-displayable data in some systems.


BMF_FRIENDISTAG

Declaration

Source position: agraphics.pas line 155

const BMF_FRIENDISTAG = 1 shl BMB_FRIENDISTAG;


BMF_HIJACKED

Declaration

Source position: agraphics.pas line 152

const BMF_HIJACKED = 1 shl BMB_HIJACKED;


BMF_INTERLEAVED

Bit flag for AllocBitMap Interleaved Bitmap

Declaration

Source position: agraphics.pas line 149

const BMF_INTERLEAVED = 1 shl BMB_INTERLEAVED;

Description

The bitmap will be allocated with one large chunk of display memory for all bitplanes. This minimizes color flashing on deep displays. If there is not enough contiguous RAM for an interleaved bitmap, graphics.library will fall back to a non-interleaved one.


BMF_INVALID

Declaration

Source position: agraphics.pas line 156

const BMF_INVALID = 1 shl BMB_INVALID;


BMF_LOCKED

Declaration

Source position: agraphics.pas line 157

const BMF_LOCKED = 1 shl BMB_LOCKED;


BMF_MINPLANES

Bit value for AllocBitMap Minimal memory use

Declaration

Source position: agraphics.pas line 151

const BMF_MINPLANES = 1 shl BMB_MINPLANES;


BMF_RTGCHECK

Declaration

Source position: agraphics.pas line 154

const BMF_RTGCHECK = 1 shl BMB_RTGCHECK;


BMF_RTGTAGS

Declaration

Source position: agraphics.pas line 153

const BMF_RTGTAGS = 1 shl BMB_RTGTAGS;


BMF_STANDARD

Bit value for AllocBitMap

Declaration

Source position: agraphics.pas line 150

const BMF_STANDARD = 1 shl BMB_STANDARD;


BOBISCOMP

Bob User Flag for TBob.Flags set to identify Bob as AnimComp

Declaration

Source position: agraphics.pas line 415

const BOBISCOMP = $0002;


BOBNIX

Bob System Flag for TBob.Flags Set when Bob is completely removed

Declaration

Source position: agraphics.pas line 420

const BOBNIX = $0800;


BOBSAWAY

Bob System Flag for TBob.Flags Set to initiate removal of Bob

Declaration

Source position: agraphics.pas line 419

const BOBSAWAY = $0400;


BOBUPDATE

System Set flag for TVsprite.Flags. Temporary flag, useless to outside world

Declaration

Source position: agraphics.pas line 407

const BOBUPDATE = $0200;


BORDER_BLANKING

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1346

const BORDER_BLANKING = $04;


BORDER_NOTRANSPARENCY

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1347

const BORDER_NOTRANSPARENCY = $08;


BORDERHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 916

const BORDERHIT = 0;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


BORDERSPRITES

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1386

const BORDERSPRITES = $40;


BOTTOMHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 925

const BOTTOMHIT = 2;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


BROADCAST_HBSTOP

Declaration

Source position: agraphics.pas line 1236

const BROADCAST_HBSTOP = $27;


BROADCAST_HBSTRT

Declaration

Source position: agraphics.pas line 1233

const BROADCAST_HBSTRT = $01;


BROADCAST_HSSTOP

Declaration

Source position: agraphics.pas line 1235

const BROADCAST_HSSTOP = $17;


BROADCAST_HSSTRT

Declaration

Source position: agraphics.pas line 1234

const BROADCAST_HSSTRT = $06;


BROADCAST_VBSTOP

Declaration

Source position: agraphics.pas line 1240

const BROADCAST_VBSTOP = $1C40;


BROADCAST_VBSTRT

Declaration

Source position: agraphics.pas line 1237

const BROADCAST_VBSTRT = $0000;


BROADCAST_VSSTOP

Declaration

Source position: agraphics.pas line 1239

const BROADCAST_VSSTOP = $054C;


BROADCAST_VSSTRT

Declaration

Source position: agraphics.pas line 1238

const BROADCAST_VSSTRT = $02A6;


BSAF_AVERAGE

Declaration

Source position: agraphics.pas line 2092

const BSAF_AVERAGE = 4;


BSAF_BILINEAR

Declaration

Source position: agraphics.pas line 2093

const BSAF_BILINEAR = 8;


BSAF_RESERVED1

Declaration

Source position: agraphics.pas line 2090

const BSAF_RESERVED1 = 1;


BSAF_RESERVED2

Declaration

Source position: agraphics.pas line 2091

const BSAF_RESERVED2 = 2;


BUS_16

Memory Type

Declaration

Source position: agraphics.pas line 2275

const BUS_16 = 0;


BUS_32

Memory Type

Declaration

Source position: agraphics.pas line 2277

const BUS_32 = 1;


BUSERFLAGS

Bob user Flag for TBob.Flags mask of all user-settable Bob-flags

Declaration

Source position: agraphics.pas line 413

const BUSERFLAGS = $00FF;


BUserStuff

Declaration

Source position: agraphics.pas line 741

type BUserStuff = SmallInt;


BWAITING

Bob System Flag for TBob.Flags set while Bob is waiting on 'after'

Declaration

Source position: agraphics.pas line 417

const BWAITING = $0100;


CMAB_DUALPF_DISABLE

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1402

const CMAB_DUALPF_DISABLE = 3;


CMAB_FULLPALETTE

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1396

const CMAB_FULLPALETTE = 0;


CMAB_NO_COLOR_LOAD

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1400

const CMAB_NO_COLOR_LOAD = 2;


CMAB_NO_INTERMED_UPDATE

Flag bit for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1398

const CMAB_NO_INTERMED_UPDATE = 1;


CMAF_DUALPF_DISABLE

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1403

const CMAF_DUALPF_DISABLE = 1 shl CMAB_DUALPF_DISABLE;


CMAF_FULLPALETTE

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1397

const CMAF_FULLPALETTE = 1 shl CMAB_FULLPALETTE;


CMAF_NO_COLOR_LOAD

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1401

const CMAF_NO_COLOR_LOAD = 1 shl CMAB_NO_COLOR_LOAD;


CMAF_NO_INTERMED_UPDATE

Flag value for TColorMap.AuxFlags

Declaration

Source position: agraphics.pas line 1399

const CMAF_NO_INTERMED_UPDATE = 1 shl CMAB_NO_INTERMED_UPDATE;


CMF_BRDNTRAN

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1354

const CMF_BRDNTRAN = 3;


CMF_BRDRBLNK

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1353

const CMF_BRDRBLNK = 2;


CMF_BRDRSPRT

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1355

const CMF_BRDRSPRT = 6;


CMF_CMTRANS

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1351

const CMF_CMTRANS = 0;


CMF_CPTRANS

Flag Bit for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1352

const CMF_CPTRANS = 1;


CollTable

Declaration

Source position: agraphics.pas line 439

type CollTable = array [0..15] of Pointer;


COLORMAP_TRANSPARENCY

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1344

const COLORMAP_TRANSPARENCY = $01;


COLORMAP_TYPE_V1_2

Colormap type for TColorMap.Type_ WB 1.2

Declaration

Source position: agraphics.pas line 1338

const COLORMAP_TYPE_V1_2 = $00;


COLORMAP_TYPE_V1_4

Declaration

Source position: agraphics.pas line 1339

const COLORMAP_TYPE_V1_4 = $01;


COLORMAP_TYPE_V36

Colormap type for TColorMap.Type_ V36

Declaration

Source position: agraphics.pas line 1340

const COLORMAP_TYPE_V36 = COLORMAP_TYPE_V1_4;


COLORMAP_TYPE_V39

Colormap type for TColorMap.Type_ V39

Declaration

Source position: agraphics.pas line 1341

const COLORMAP_TYPE_V39 = $02;


COLORON

Declaration

Source position: agraphics.pas line 1774

const COLORON = $0200;


COLORPLANE_TRANSPARENCY

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1345

const COLORPLANE_TRANSPARENCY = $02;


COMPERR_Generic

Declaration

Source position: agraphics.pas line 1055

const COMPERR_Generic = 5;


COMPERR_Incompatible

Declaration

Source position: agraphics.pas line 1051

const COMPERR_Incompatible = 1;


COMPERR_MissingInput

Declaration

Source position: agraphics.pas line 1057

const COMPERR_MissingInput = 7;


COMPERR_OutOfMemory

Declaration

Source position: agraphics.pas line 1054

const COMPERR_OutOfMemory = 4;


COMPERR_SoftwareFallback

Declaration

Source position: agraphics.pas line 1053

const COMPERR_SoftwareFallback = 3;


COMPERR_Success

Declaration

Source position: agraphics.pas line 1050

const COMPERR_Success = 0;


COMPERR_UnknownOperator

Declaration

Source position: agraphics.pas line 1056

const COMPERR_UnknownOperator = 6;


COMPERR_Value

Declaration

Source position: agraphics.pas line 1052

const COMPERR_Value = 2;


COMPFLAG_Color1Modulate

Declaration

Source position: agraphics.pas line 1033

const COMPFLAG_Color1Modulate = 1 shl 8;


COMPFLAG_DestAlphaOverride

Declaration

Source position: agraphics.pas line 1027

const COMPFLAG_DestAlphaOverride = 1 shl 1;


COMPFLAG_ForceSoftware

Declaration

Source position: agraphics.pas line 1032

const COMPFLAG_ForceSoftware = 1 shl 7;


COMPFLAG_HardwareOnly

Declaration

Source position: agraphics.pas line 1030

const COMPFLAG_HardwareOnly = 1 shl 3;


COMPFLAG_IgnoreDestAlpha

Declaration

Source position: agraphics.pas line 1031

const COMPFLAG_IgnoreDestAlpha = 1 shl 4;


COMPFLAG_SrcAlphaOverride

Declaration

Source position: agraphics.pas line 1025

const COMPFLAG_SrcAlphaOverride = 1 shl 0;


COMPFLAG_SrcFilter

Declaration

Source position: agraphics.pas line 1028

const COMPFLAG_SrcFilter = 1 shl 2;


COMPLEMENT

Drawing mode: XOR bits into raster

Declaration

Source position: agraphics.pas line 358

const COMPLEMENT = 2;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


COMPOSITE_Clear

Declaration

Source position: agraphics.pas line 929

const COMPOSITE_Clear = 0;


COMPOSITE_Dest

Declaration

Source position: agraphics.pas line 931

const COMPOSITE_Dest = 2;


COMPOSITE_Dest_Atop_Src

Declaration

Source position: agraphics.pas line 939

const COMPOSITE_Dest_Atop_Src = 10;


COMPOSITE_Dest_In_Src

Declaration

Source position: agraphics.pas line 935

const COMPOSITE_Dest_In_Src = 6;


COMPOSITE_Dest_Out_Src

Declaration

Source position: agraphics.pas line 937

const COMPOSITE_Dest_Out_Src = 8;


COMPOSITE_Dest_Over_Src

Declaration

Source position: agraphics.pas line 933

const COMPOSITE_Dest_Over_Src = 4;


COMPOSITE_Maximum

Declaration

Source position: agraphics.pas line 942

const COMPOSITE_Maximum = 13;


COMPOSITE_Minimum

Declaration

Source position: agraphics.pas line 943

const COMPOSITE_Minimum = 14;


COMPOSITE_NumOperators

Declaration

Source position: agraphics.pas line 944

const COMPOSITE_NumOperators = 15;


COMPOSITE_Plus

Declaration

Source position: agraphics.pas line 941

const COMPOSITE_Plus = 12;


COMPOSITE_Src

Declaration

Source position: agraphics.pas line 930

const COMPOSITE_Src = 1;


COMPOSITE_Src_Atop_Dest

Declaration

Source position: agraphics.pas line 938

const COMPOSITE_Src_Atop_Dest = 9;


COMPOSITE_Src_In_Dest

Declaration

Source position: agraphics.pas line 934

const COMPOSITE_Src_In_Dest = 5;


COMPOSITE_Src_Out_Dest

Declaration

Source position: agraphics.pas line 936

const COMPOSITE_Src_Out_Dest = 7;


COMPOSITE_Src_Over_Dest

Declaration

Source position: agraphics.pas line 932

const COMPOSITE_Src_Over_Dest = 3;


COMPOSITE_Src_Xor_Dest

Declaration

Source position: agraphics.pas line 940

const COMPOSITE_Src_Xor_Dest = 11;


COMPTAG_Base

Declaration

Source position: agraphics.pas line 947

const COMPTAG_Base = TAG_USER;


COMPTAG_Color0

Declaration

Source position: agraphics.pas line 979

const COMPTAG_Color0 = COMPTAG_Base + 40;


COMPTAG_Color0_Alpha

Declaration

Source position: agraphics.pas line 987

const COMPTAG_Color0_Alpha = COMPTAG_Base + 47;


COMPTAG_Color0_Blue

Declaration

Source position: agraphics.pas line 986

const COMPTAG_Color0_Blue = COMPTAG_Base + 46;


COMPTAG_Color0_Green

Declaration

Source position: agraphics.pas line 985

const COMPTAG_Color0_Green = COMPTAG_Base + 45;


COMPTAG_Color0_Red

Declaration

Source position: agraphics.pas line 984

const COMPTAG_Color0_Red = COMPTAG_Base + 44;


COMPTAG_Color1

Declaration

Source position: agraphics.pas line 980

const COMPTAG_Color1 = COMPTAG_Base + 41;


COMPTAG_Color1_Alpha

Declaration

Source position: agraphics.pas line 992

const COMPTAG_Color1_Alpha = COMPTAG_Base + 51;


COMPTAG_Color1_Blue

Declaration

Source position: agraphics.pas line 991

const COMPTAG_Color1_Blue = COMPTAG_Base + 50;


COMPTAG_Color1_Green

Declaration

Source position: agraphics.pas line 990

const COMPTAG_Color1_Green = COMPTAG_Base + 49;


COMPTAG_Color1_Red

Declaration

Source position: agraphics.pas line 989

const COMPTAG_Color1_Red = COMPTAG_Base + 48;


COMPTAG_Color2

Declaration

Source position: agraphics.pas line 981

const COMPTAG_Color2 = COMPTAG_Base + 42;


COMPTAG_Color2_Alpha

Declaration

Source position: agraphics.pas line 997

const COMPTAG_Color2_Alpha = COMPTAG_Base + 55;


COMPTAG_Color2_Blue

Declaration

Source position: agraphics.pas line 996

const COMPTAG_Color2_Blue = COMPTAG_Base + 54;


COMPTAG_Color2_Green

Declaration

Source position: agraphics.pas line 995

const COMPTAG_Color2_Green = COMPTAG_Base + 53;


COMPTAG_Color2_Red

Declaration

Source position: agraphics.pas line 994

const COMPTAG_Color2_Red = COMPTAG_Base + 52;


COMPTAG_Color3

Declaration

Source position: agraphics.pas line 982

const COMPTAG_Color3 = COMPTAG_Base + 43;


COMPTAG_Color3_Alpha

Declaration

Source position: agraphics.pas line 1002

const COMPTAG_Color3_Alpha = COMPTAG_Base + 59;


COMPTAG_Color3_Blue

Declaration

Source position: agraphics.pas line 1001

const COMPTAG_Color3_Blue = COMPTAG_Base + 58;


COMPTAG_Color3_Green

Declaration

Source position: agraphics.pas line 1000

const COMPTAG_Color3_Green = COMPTAG_Base + 57;


COMPTAG_Color3_Red

Declaration

Source position: agraphics.pas line 999

const COMPTAG_Color3_Red = COMPTAG_Base + 56;


COMPTAG_DestAlpha

Declaration

Source position: agraphics.pas line 957

const COMPTAG_DestAlpha = COMPTAG_Base + 9;


COMPTAG_DestAlphaMask

Declaration

Source position: agraphics.pas line 961

const COMPTAG_DestAlphaMask = COMPTAG_Base + 13;


COMPTAG_DestAlphaX

Declaration

Source position: agraphics.pas line 969

const COMPTAG_DestAlphaX = COMPTAG_Base + 16;


COMPTAG_DestAlphaY

Declaration

Source position: agraphics.pas line 970

const COMPTAG_DestAlphaY = COMPTAG_Base + 17;


COMPTAG_DestHeight

Declaration

Source position: agraphics.pas line 955

const COMPTAG_DestHeight = COMPTAG_Base + 7;


COMPTAG_DestWidth

Declaration

Source position: agraphics.pas line 954

const COMPTAG_DestWidth = COMPTAG_Base + 6;


COMPTAG_DestX

Declaration

Source position: agraphics.pas line 952

const COMPTAG_DestX = COMPTAG_Base + 4;


COMPTAG_DestY

Declaration

Source position: agraphics.pas line 953

const COMPTAG_DestY = COMPTAG_Base + 5;


COMPTAG_DisplayID

Declaration

Source position: agraphics.pas line 966

const COMPTAG_DisplayID = COMPTAG_Base + 23;


COMPTAG_Flags

Declaration

Source position: agraphics.pas line 962

const COMPTAG_Flags = COMPTAG_Base + 18;


COMPTAG_FriendBitMap

Declaration

Source position: agraphics.pas line 965

const COMPTAG_FriendBitMap = COMPTAG_Base + 22;


COMPTAG_IndexArray

Declaration

Source position: agraphics.pas line 973

const COMPTAG_IndexArray = COMPTAG_Base + 31;


COMPTAG_NumTriangles

Declaration

Source position: agraphics.pas line 975

const COMPTAG_NumTriangles = COMPTAG_Base + 33;


COMPTAG_OffsetX

Declaration

Source position: agraphics.pas line 963

const COMPTAG_OffsetX = COMPTAG_Base + 20;


COMPTAG_OffsetY

Declaration

Source position: agraphics.pas line 964

const COMPTAG_OffsetY = COMPTAG_Base + 21;


COMPTAG_Private

Declaration

Source position: agraphics.pas line 1018

const COMPTAG_Private = COMPTAG_Base + 34;


COMPTAG_Private2

Declaration

Source position: agraphics.pas line 1019

const COMPTAG_Private2 = COMPTAG_Base + 35;


COMPTAG_ScaleX

Declaration

Source position: agraphics.pas line 958

const COMPTAG_ScaleX = COMPTAG_Base + 10;


COMPTAG_ScaleY

Declaration

Source position: agraphics.pas line 959

const COMPTAG_ScaleY = COMPTAG_Base + 11;


COMPTAG_SrcAlpha

Declaration

Source position: agraphics.pas line 956

const COMPTAG_SrcAlpha = COMPTAG_Base + 8;


COMPTAG_SrcAlphaMask

Declaration

Source position: agraphics.pas line 960

const COMPTAG_SrcAlphaMask = COMPTAG_Base + 12;


COMPTAG_SrcAlphaX

Declaration

Source position: agraphics.pas line 967

const COMPTAG_SrcAlphaX = COMPTAG_Base + 14;


COMPTAG_SrcAlphaY

Declaration

Source position: agraphics.pas line 968

const COMPTAG_SrcAlphaY = COMPTAG_Base + 15;


COMPTAG_SrcHeight

Declaration

Source position: agraphics.pas line 951

const COMPTAG_SrcHeight = COMPTAG_Base + 3;


COMPTAG_SrcWidth

Declaration

Source position: agraphics.pas line 950

const COMPTAG_SrcWidth = COMPTAG_Base + 2;


COMPTAG_SrcX

Declaration

Source position: agraphics.pas line 948

const COMPTAG_SrcX = COMPTAG_Base + 0;


COMPTAG_SrcY

Declaration

Source position: agraphics.pas line 949

const COMPTAG_SrcY = COMPTAG_Base + 1;


COMPTAG_SrcYUVMatrix

Declaration

Source position: agraphics.pas line 1015

const COMPTAG_SrcYUVMatrix = COMPTAG_Base + 61;


COMPTAG_SrcYUVStandard

Declaration

Source position: agraphics.pas line 1011

const COMPTAG_SrcYUVStandard = COMPTAG_Base + 60;


COMPTAG_VertexArray

Declaration

Source position: agraphics.pas line 972

const COMPTAG_VertexArray = COMPTAG_Base + 30;


COMPTAG_VertexFormat

Declaration

Source position: agraphics.pas line 974

const COMPTAG_VertexFormat = COMPTAG_Base + 32;


COMPVF_STW0_Present

Declaration

Source position: agraphics.pas line 1022

const COMPVF_STW0_Present = $02;


COMPVF_STW1_Present

Declaration

Source position: agraphics.pas line 1023

const COMPVF_STW1_Present = $04;


COMPYUV_BT601

Declaration

Source position: agraphics.pas line 1012

const COMPYUV_BT601 = 0;


COMPYUV_BT709

Declaration

Source position: agraphics.pas line 1013

const COMPYUV_BT709 = 1;


COPPER_MOVE

Copper command. Pseudo opcode for move #XXXX,dir

Declaration

Source position: agraphics.pas line 384

const COPPER_MOVE = 0;


COPPER_WAIT

Copper command. Pseudo opcode for wait y,x

Declaration

Source position: agraphics.pas line 385

const COPPER_WAIT = 1;


CPR_NT_LOF

Copper command. Copper instruction only for Longint frames

Declaration

Source position: agraphics.pas line 387

const CPR_NT_LOF = $8000;


CPR_NT_SHT

Copper command. Copper instruction only for long frames

Declaration

Source position: agraphics.pas line 388

const CPR_NT_SHT = $4000;


CPR_NT_SYS

Copper command. Copper user instruction only

Declaration

Source position: agraphics.pas line 389

const CPR_NT_SYS = $2000;


CPRNXTBUF

Copper command. Continue processing with next buffer

Declaration

Source position: agraphics.pas line 386

const CPRNXTBUF = 2;


CR_ALPHATYPE

Declaration

Source position: agraphics.pas line 868

const CR_ALPHATYPE = 128;


CR_DAMAGECLIPPED

Declaration

Source position: agraphics.pas line 866

const CR_DAMAGECLIPPED = 32;


CR_INTUITION

Declaration

Source position: agraphics.pas line 870

const CR_INTUITION = 1024;


CR_INVISIBLE

Declaration

Source position: agraphics.pas line 869

const CR_INVISIBLE = 256;


CR_LAYERBITMAP

Declaration

Source position: agraphics.pas line 867

const CR_LAYERBITMAP = 64;


CR_USERCLIPPED

Declaration

Source position: agraphics.pas line 865

const CR_USERCLIPPED = 16;


CT_ANTIALIAS

Flag for TColorTextFont.ctf_Flags zero background thru fully saturated char

Declaration

Source position: agraphics.pas line 351

const CT_ANTIALIAS = $0004;


CT_COLORFONT

Flag for TColorTextFont.ctf_Flags color map contains designer's colors

Declaration

Source position: agraphics.pas line 349

const CT_COLORFONT = $0001;


CT_COLORMASK

Flag mask for TColorTextFont.ctf_Flags mask to get to all color styles

Declaration

Source position: agraphics.pas line 348

const CT_COLORMASK = $000F;


CT_GREYFONT

Flag for TColorTextFont.ctf_Flags color map describes even-stepped

Declaration

Source position: agraphics.pas line 350

const CT_GREYFONT = $0002;

Description

brightnesses from TColorTextFont.ctf_Low to TColorTextFont.ctf_High


CTB_MAPCOLOR

Flag Bit for TColorTextFont.ctf_Flags

Declaration

Source position: agraphics.pas line 352

const CTB_MAPCOLOR = 8;


CTF_MAPCOLOR

Flag for TColorTextFont.ctf_Flags mapped color

Declaration

Source position: agraphics.pas line 353

const CTF_MAPCOLOR = $0100;

Description

Map TColorTextFont.ctf_FgColor to the TRastPort.rp_FgPen. If it's is a valid color from TColorTextFont.ctf_Low to TColorTextFont.ctf_High.


DBL_CAS

Memory Type

Declaration

Source position: agraphics.pas line 2278

const DBL_CAS = 2;


DBLNTSC_MONITOR_ID

Declaration

Source position: agraphics.pas line 1656

const DBLNTSC_MONITOR_ID = $00091000;


DBLNTSCEXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1687

const DBLNTSCEXTRALORES_KEY = $00091200;


DBLNTSCEXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1691

const DBLNTSCEXTRALORESDPF2_KEY = $00091640;


DBLNTSCEXTRALORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1696

const DBLNTSCEXTRALORESDPF2FF_KEY = $00091644;


DBLNTSCEXTRALORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1701

const DBLNTSCEXTRALORESDPF2LACE_KEY = $00091645;


DBLNTSCEXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1690

const DBLNTSCEXTRALORESDPF_KEY = $00091600;


DBLNTSCEXTRALORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1695

const DBLNTSCEXTRALORESDPFFF_KEY = $00091604;


DBLNTSCEXTRALORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1700

const DBLNTSCEXTRALORESDPFLACE_KEY = $00091605;


DBLNTSCEXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1689

const DBLNTSCEXTRALORESEHB_KEY = $00091280;


DBLNTSCEXTRALORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1694

const DBLNTSCEXTRALORESEHBFF_KEY = $00091284;


DBLNTSCEXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1699

const DBLNTSCEXTRALORESEHBLACE_KEY = $00091285;


DBLNTSCEXTRALORESFF_KEY

Declaration

Source position: agraphics.pas line 1692

const DBLNTSCEXTRALORESFF_KEY = $00091204;


DBLNTSCEXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1688

const DBLNTSCEXTRALORESHAM_KEY = $00091a00;


DBLNTSCEXTRALORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1693

const DBLNTSCEXTRALORESHAMFF_KEY = $00091a04;


DBLNTSCEXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1698

const DBLNTSCEXTRALORESHAMLACE_KEY = $00091a05;


DBLNTSCEXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1697

const DBLNTSCEXTRALORESLACE_KEY = $00091205;


DBLNTSCHIRES_KEY

Declaration

Source position: agraphics.pas line 1672

const DBLNTSCHIRES_KEY = $00099000;


DBLNTSCHIRESDPF2_KEY

Declaration

Source position: agraphics.pas line 1684

const DBLNTSCHIRESDPF2_KEY = $00099440;


DBLNTSCHIRESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1685

const DBLNTSCHIRESDPF2FF_KEY = $00099444;


DBLNTSCHIRESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1686

const DBLNTSCHIRESDPF2LACE_KEY = $00099445;


DBLNTSCHIRESDPF_KEY

Declaration

Source position: agraphics.pas line 1681

const DBLNTSCHIRESDPF_KEY = $00099400;


DBLNTSCHIRESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1682

const DBLNTSCHIRESDPFFF_KEY = $00099404;


DBLNTSCHIRESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1683

const DBLNTSCHIRESDPFLACE_KEY = $00099405;


DBLNTSCHIRESEHB_KEY

Declaration

Source position: agraphics.pas line 1678

const DBLNTSCHIRESEHB_KEY = $00099080;


DBLNTSCHIRESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1679

const DBLNTSCHIRESEHBFF_KEY = $00099084;


DBLNTSCHIRESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1680

const DBLNTSCHIRESEHBLACE_KEY = $00099085;


DBLNTSCHIRESFF_KEY

Declaration

Source position: agraphics.pas line 1673

const DBLNTSCHIRESFF_KEY = $00099004;


DBLNTSCHIRESHAM_KEY

Declaration

Source position: agraphics.pas line 1674

const DBLNTSCHIRESHAM_KEY = $00099800;


DBLNTSCHIRESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1675

const DBLNTSCHIRESHAMFF_KEY = $00099804;


DBLNTSCHIRESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1677

const DBLNTSCHIRESHAMLACE_KEY = $00099805;


DBLNTSCHIRESLACE_KEY

Declaration

Source position: agraphics.pas line 1676

const DBLNTSCHIRESLACE_KEY = $00099005;


DBLNTSCLORES_KEY

Declaration

Source position: agraphics.pas line 1657

const DBLNTSCLORES_KEY = $00091000;


DBLNTSCLORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1669

const DBLNTSCLORESDPF2_KEY = $00091440;


DBLNTSCLORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1670

const DBLNTSCLORESDPF2FF_KEY = $00091444;


DBLNTSCLORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1671

const DBLNTSCLORESDPF2LACE_KEY = $00091445;


DBLNTSCLORESDPF_KEY

Declaration

Source position: agraphics.pas line 1666

const DBLNTSCLORESDPF_KEY = $00091400;


DBLNTSCLORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1667

const DBLNTSCLORESDPFFF_KEY = $00091404;


DBLNTSCLORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1668

const DBLNTSCLORESDPFLACE_KEY = $00091405;


DBLNTSCLORESEHB_KEY

Declaration

Source position: agraphics.pas line 1661

const DBLNTSCLORESEHB_KEY = $00091080;


DBLNTSCLORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1662

const DBLNTSCLORESEHBFF_KEY = $00091084;


DBLNTSCLORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1665

const DBLNTSCLORESEHBLACE_KEY = $00091085;


DBLNTSCLORESFF_KEY

Declaration

Source position: agraphics.pas line 1658

const DBLNTSCLORESFF_KEY = $00091004;


DBLNTSCLORESHAM_KEY

Declaration

Source position: agraphics.pas line 1659

const DBLNTSCLORESHAM_KEY = $00091800;


DBLNTSCLORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1660

const DBLNTSCLORESHAMFF_KEY = $00091804;


DBLNTSCLORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1664

const DBLNTSCLORESHAMLACE_KEY = $00091805;


DBLNTSCLORESLACE_KEY

Declaration

Source position: agraphics.pas line 1663

const DBLNTSCLORESLACE_KEY = $00091005;


DBLPAL_MONITOR_ID

Declaration

Source position: agraphics.pas line 1702

const DBLPAL_MONITOR_ID = $000a1000;


DBLPALEXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1733

const DBLPALEXTRALORES_KEY = $000a1200;


DBLPALEXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1737

const DBLPALEXTRALORESDPF2_KEY = $000a1640;


DBLPALEXTRALORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1742

const DBLPALEXTRALORESDPF2FF_KEY = $000a1644;


DBLPALEXTRALORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1747

const DBLPALEXTRALORESDPF2LACE_KEY = $000a1645;


DBLPALEXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1736

const DBLPALEXTRALORESDPF_KEY = $000a1600;


DBLPALEXTRALORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1741

const DBLPALEXTRALORESDPFFF_KEY = $000a1604;


DBLPALEXTRALORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1746

const DBLPALEXTRALORESDPFLACE_KEY = $000a1605;


DBLPALEXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1735

const DBLPALEXTRALORESEHB_KEY = $000a1280;


DBLPALEXTRALORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1740

const DBLPALEXTRALORESEHBFF_KEY = $000a1284;


DBLPALEXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1745

const DBLPALEXTRALORESEHBLACE_KEY = $000a1285;


DBLPALEXTRALORESFF_KEY

Declaration

Source position: agraphics.pas line 1738

const DBLPALEXTRALORESFF_KEY = $000a1204;


DBLPALEXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1734

const DBLPALEXTRALORESHAM_KEY = $000a1a00;


DBLPALEXTRALORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1739

const DBLPALEXTRALORESHAMFF_KEY = $000a1a04;


DBLPALEXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1744

const DBLPALEXTRALORESHAMLACE_KEY = $000a1a05;


DBLPALEXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1743

const DBLPALEXTRALORESLACE_KEY = $000a1205;


DBLPALHIRES_KEY

Declaration

Source position: agraphics.pas line 1718

const DBLPALHIRES_KEY = $000a9000;


DBLPALHIRESDPF2_KEY

Declaration

Source position: agraphics.pas line 1730

const DBLPALHIRESDPF2_KEY = $000a9440;


DBLPALHIRESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1731

const DBLPALHIRESDPF2FF_KEY = $000a9444;


DBLPALHIRESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1732

const DBLPALHIRESDPF2LACE_KEY = $000a9445;


DBLPALHIRESDPF_KEY

Declaration

Source position: agraphics.pas line 1727

const DBLPALHIRESDPF_KEY = $000a9400;


DBLPALHIRESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1728

const DBLPALHIRESDPFFF_KEY = $000a9404;


DBLPALHIRESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1729

const DBLPALHIRESDPFLACE_KEY = $000a9405;


DBLPALHIRESEHB_KEY

Declaration

Source position: agraphics.pas line 1724

const DBLPALHIRESEHB_KEY = $000a9080;


DBLPALHIRESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1725

const DBLPALHIRESEHBFF_KEY = $000a9084;


DBLPALHIRESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1726

const DBLPALHIRESEHBLACE_KEY = $000a9085;


DBLPALHIRESFF_KEY

Declaration

Source position: agraphics.pas line 1719

const DBLPALHIRESFF_KEY = $000a9004;


DBLPALHIRESHAM_KEY

Declaration

Source position: agraphics.pas line 1720

const DBLPALHIRESHAM_KEY = $000a9800;


DBLPALHIRESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1721

const DBLPALHIRESHAMFF_KEY = $000a9804;


DBLPALHIRESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1723

const DBLPALHIRESHAMLACE_KEY = $000a9805;


DBLPALHIRESLACE_KEY

Declaration

Source position: agraphics.pas line 1722

const DBLPALHIRESLACE_KEY = $000a9005;


DBLPALLORES_KEY

Declaration

Source position: agraphics.pas line 1703

const DBLPALLORES_KEY = $000a1000;


DBLPALLORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1715

const DBLPALLORESDPF2_KEY = $000a1440;


DBLPALLORESDPF2FF_KEY

Declaration

Source position: agraphics.pas line 1716

const DBLPALLORESDPF2FF_KEY = $000a1444;


DBLPALLORESDPF2LACE_KEY

Declaration

Source position: agraphics.pas line 1717

const DBLPALLORESDPF2LACE_KEY = $000a1445;


DBLPALLORESDPF_KEY

Declaration

Source position: agraphics.pas line 1712

const DBLPALLORESDPF_KEY = $000a1400;


DBLPALLORESDPFFF_KEY

Declaration

Source position: agraphics.pas line 1713

const DBLPALLORESDPFFF_KEY = $000a1404;


DBLPALLORESDPFLACE_KEY

Declaration

Source position: agraphics.pas line 1714

const DBLPALLORESDPFLACE_KEY = $000a1405;


DBLPALLORESEHB_KEY

Declaration

Source position: agraphics.pas line 1707

const DBLPALLORESEHB_KEY = $000a1080;


DBLPALLORESEHBFF_KEY

Declaration

Source position: agraphics.pas line 1708

const DBLPALLORESEHBFF_KEY = $000a1084;


DBLPALLORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1711

const DBLPALLORESEHBLACE_KEY = $000a1085;


DBLPALLORESFF_KEY

Declaration

Source position: agraphics.pas line 1704

const DBLPALLORESFF_KEY = $000a1004;


DBLPALLORESHAM_KEY

Declaration

Source position: agraphics.pas line 1705

const DBLPALLORESHAM_KEY = $000a1800;


DBLPALLORESHAMFF_KEY

Declaration

Source position: agraphics.pas line 1706

const DBLPALLORESHAMFF_KEY = $000a1804;


DBLPALLORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1710

const DBLPALLORESHAMLACE_KEY = $000a1805;


DBLPALLORESLACE_KEY

Declaration

Source position: agraphics.pas line 1709

const DBLPALLORESLACE_KEY = $000a1005;


DBLPF

Declaration

Source position: agraphics.pas line 1775

const DBLPF = $400;


DBUFFER

Flag set when RastPorts are double-buffered

Declaration

Source position: agraphics.pas line 367

const DBUFFER = $04;

See also

TRastPort

Basic structure for all drawing actions


DEFAULT_MONITOR_ID

Declaration

Source position: agraphics.pas line 1490

const DEFAULT_MONITOR_ID = $00000000;


DEFAULT_MONITOR_NAME

Declaration

Source position: agraphics.pas line 1173

const DEFAULT_MONITOR_NAME: PChar = 'default.monitor';


DFTCH_MASK

Declaration

Source position: agraphics.pas line 1790

const DFTCH_MASK = $FF;


DI_AVAIL_INVALID

Declaration

Source position: agraphics.pas line 1840

const DI_AVAIL_INVALID = $1000;


DI_AVAIL_MONITOOL

Declaration

Source position: agraphics.pas line 1841

const DI_AVAIL_MONITOOL = $2000;


DI_AVAIL_NOCHIPS

Availability for TDisplayInfo.NotAvailable

Declaration

Source position: agraphics.pas line 1837

const DI_AVAIL_NOCHIPS = $0001;


DI_AVAIL_NOMONITOR

Availability for TDisplayInfo.NotAvailable

Declaration

Source position: agraphics.pas line 1838

const DI_AVAIL_NOMONITOR = $0002;


DI_AVAIL_NOTWITHGENLOCK

Availability for TDisplayInfo.NotAvailable

Declaration

Source position: agraphics.pas line 1839

const DI_AVAIL_NOTWITHGENLOCK = $0004;


DIPF_IS_AA

Flag for TDisplayInfo.PropertyFlagsAA modes - may only be available if machine has correct memory type to support required bandwidth - check availability.

Declaration

Source position: agraphics.pas line 1849

const DIPF_IS_AA = $00010000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_BEAMSYNC

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1857

const DIPF_IS_BEAMSYNC = $00000800;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_DBUFFER

Flag for TDisplayInfo.PropertyFlags Mode supports double buffering

Declaration

Source position: agraphics.pas line 1866

const DIPF_IS_DBUFFER = $00100000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_DRAGGABLE

Flag for TDisplayInfo.PropertyFlags Mode can be dragged down

Declaration

Source position: agraphics.pas line 1855

const DIPF_IS_DRAGGABLE = $00000200;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_DUALPF

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1845

const DIPF_IS_DUALPF = $00000002;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_ECS

Flag for TDisplayInfo.PropertyFlags Mode which needs ECS Chipset (SHIRES, VGA, AND PRODUCTIVITY) do not support attached sprites.

Declaration

Source position: agraphics.pas line 1848

const DIPF_IS_ECS = $00000010;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_EXTRAHALFBRITE

Flag for TDisplayInfo.PropertyFlags EHB mode

Declaration

Source position: agraphics.pas line 1858

const DIPF_IS_EXTRAHALFBRITE = $00001000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_FOREIGN

Flag for TDisplayInfo.PropertyFlagsMode is not native to the Amiga

Declaration

Source position: agraphics.pas line 1872

const DIPF_IS_FOREIGN = DIPF_IS_RTG;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_GENLOCK

Flag for TDisplayInfo.PropertyFlags Mode wich support Genlocks

Declaration

Source position: agraphics.pas line 1853

const DIPF_IS_GENLOCK = $00000080;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_HAM

Flag for TDisplayInfo.PropertyFlags HAM6/8 Mode

Declaration

Source position: agraphics.pas line 1847

const DIPF_IS_HAM = $00000008;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_HWCOMPOSITE

Declaration

Source position: agraphics.pas line 1868

const DIPF_IS_HWCOMPOSITE = $00400000;


DIPF_IS_LACE

Flag for TDisplayInfo.PropertyFlags Interlace mode

Declaration

Source position: agraphics.pas line 1844

const DIPF_IS_LACE = $00000001;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_PAL

Flag for TDisplayInfo.PropertyFlags PAL Mode

Declaration

Source position: agraphics.pas line 1851

const DIPF_IS_PAL = $00000020;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_PANELLED

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1856

const DIPF_IS_PANELLED = $00000400;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_PF2PRI

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1846

const DIPF_IS_PF2PRI = $00000004;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_PREFERREDMODE

Declaration

Source position: agraphics.pas line 1869

const DIPF_IS_PREFERREDMODE = $00800000;


DIPF_IS_PROGBEAM

Flag for TDisplayInfo.PropertyFlags Mode is a programmed beam-sync mode

Declaration

Source position: agraphics.pas line 1867

const DIPF_IS_PROGBEAM = $00200000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_RTG

Declaration

Source position: agraphics.pas line 1870

const DIPF_IS_RTG = $80000000;


DIPF_IS_SCANDBL

Flag for TDisplayInfo.PropertyFlags Scan doubled mode

Declaration

Source position: agraphics.pas line 1862

const DIPF_IS_SCANDBL = $00020000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_SPRITES

Flag for TDisplayInfo.PropertyFlags

Declaration

Source position: agraphics.pas line 1852

const DIPF_IS_SPRITES = $00000040;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_SPRITES_ATT

Flag for TDisplayInfo.PropertyFlags Mode supports attached sprites

Declaration

Source position: agraphics.pas line 1859

const DIPF_IS_SPRITES_ATT = $00002000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_SPRITES_BORDER

Flag for TDisplayInfo.PropertyFlags Sprite can be displayed in the border

Declaration

Source position: agraphics.pas line 1861

const DIPF_IS_SPRITES_BORDER = $00008000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_SPRITES_CHNG_BASE

Flag for TDisplayInfo.PropertyFlags Mode can change the sprite base color

Declaration

Source position: agraphics.pas line 1863

const DIPF_IS_SPRITES_CHNG_BASE = $00040000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_SPRITES_CHNG_PRI

Flag for TDisplayInfo.PropertyFlags Mode can change the sprite priority with respect to the playfield(s).

Declaration

Source position: agraphics.pas line 1864

const DIPF_IS_SPRITES_CHNG_PRI = $00080000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_SPRITES_CHNG_RES

Flag for TDisplayInfo.PropertyFlags Mode supports variable sprite resolution

Declaration

Source position: agraphics.pas line 1860

const DIPF_IS_SPRITES_CHNG_RES = $00004000;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DIPF_IS_WB

Flag for TDisplayInfo.PropertyFlags Mode is useable for Workbench/Wanderer

Declaration

Source position: agraphics.pas line 1854

const DIPF_IS_WB = $00000100;

See also

BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default


DisplayInfoHandle

The "public" handle to a DisplayInfoRecord

Declaration

Source position: agraphics.pas line 1805

type DisplayInfoHandle = Pointer;


DISPLAYNAMELEN

Max name of monitor names see TNameInfo.Name

Declaration

Source position: agraphics.pas line 1917

const DISPLAYNAMELEN = 32;


DIW_HORIZ_POS

Declaration

Source position: agraphics.pas line 1785

const DIW_HORIZ_POS = $7F;


DIW_VRTCL_POS

Declaration

Source position: agraphics.pas line 1786

const DIW_VRTCL_POS = $1FF;


DIW_VRTCL_POS_SHIFT

Declaration

Source position: agraphics.pas line 1787

const DIW_VRTCL_POS_SHIFT = $7;


DPMSLEVEL_OFF

Declaration

Source position: agraphics.pas line 2035

const DPMSLEVEL_OFF = 3;


DPMSLEVEL_ON

Declaration

Source position: agraphics.pas line 2032

const DPMSLEVEL_ON = 0;


DPMSLEVEL_STANDBY

Declaration

Source position: agraphics.pas line 2033

const DPMSLEVEL_STANDBY = 1;


DPMSLEVEL_SUSPEND

Declaration

Source position: agraphics.pas line 2034

const DPMSLEVEL_SUSPEND = 2;


DTAG_DIMS

GetDisplayInfoData, results in PDimensionInfo

Declaration

Source position: agraphics.pas line 1798

const DTAG_DIMS = $80001000;


DTAG_DISP

Start tag for GetDisplayInfoData

Declaration

Source position: agraphics.pas line 1797

const DTAG_DISP = $80000000;


DTAG_MNTR

GetDisplayInfoData, results in PMonitorInfo

Declaration

Source position: agraphics.pas line 1799

const DTAG_MNTR = $80002000;


DTAG_NAME

GetDisplayInfoData, results in PNameInfo

Declaration

Source position: agraphics.pas line 1800

const DTAG_NAME = $80003000;


DTAG_VEC

GetDisplayInfoData, Internal use only (PVecInfo)

Declaration

Source position: agraphics.pas line 1801

const DTAG_VEC = $80004000;


DUALPF

Declaration

Source position: agraphics.pas line 1375

const DUALPF = $0400;


EURO36_MONITOR_ID

Declaration

Source position: agraphics.pas line 1640

const EURO36_MONITOR_ID = $00071000;


EURO72_MONITOR_ID

Declaration

Source position: agraphics.pas line 1593

const EURO72_MONITOR_ID = $00061000;


EURO72EHB_KEY

Declaration

Source position: agraphics.pas line 1627

const EURO72EHB_KEY = $000690a4;


EURO72EHBLACE_KEY

Declaration

Source position: agraphics.pas line 1628

const EURO72EHBLACE_KEY = $000690a5;


EURO72EXTRAHALFBRITE_KEY

Declaration

Source position: agraphics.pas line 1614

const EURO72EXTRAHALFBRITE_KEY = $00061084;


EURO72EXTRAHALFBRITELACE_KEY

Declaration

Source position: agraphics.pas line 1615

const EURO72EXTRAHALFBRITELACE_KEY = $00061085;


EURO72EXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1594

const EURO72EXTRALORES_KEY = $00061004;


EURO72EXTRALORESDBL_KEY

Declaration

Source position: agraphics.pas line 1631

const EURO72EXTRALORESDBL_KEY = $00061000;


EURO72EXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1608

const EURO72EXTRALORESDPF2_KEY = $00061444;


EURO72EXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1602

const EURO72EXTRALORESDPF_KEY = $00061404;


EURO72EXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1623

const EURO72EXTRALORESEHB_KEY = EURO72EXTRAHALFBRITE_KEY;


EURO72EXTRALORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1637

const EURO72EXTRALORESEHBDBL_KEY = $00061080;


EURO72EXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1624

const EURO72EXTRALORESEHBLACE_KEY = EURO72EXTRAHALFBRITELACE_KEY;


EURO72EXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1621

const EURO72EXTRALORESHAM_KEY = EURO72HAM_KEY;


EURO72EXTRALORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1634

const EURO72EXTRALORESHAMDBL_KEY = $00061800;


EURO72EXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1622

const EURO72EXTRALORESHAMLACE_KEY = EURO72HAMLACE_KEY;


EURO72EXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1598

const EURO72EXTRALORESLACE_KEY = $00061005;


EURO72EXTRALORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1611

const EURO72EXTRALORESLACEDPF2_KEY = $00061445;


EURO72EXTRALORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1605

const EURO72EXTRALORESLACEDPF_KEY = $00061405;


EURO72HAM_KEY

Declaration

Source position: agraphics.pas line 1597

const EURO72HAM_KEY = $00061804;


EURO72HAMLACE_KEY

Declaration

Source position: agraphics.pas line 1601

const EURO72HAMLACE_KEY = $00061805;


EURO72LORES_KEY

Declaration

Source position: agraphics.pas line 1595

const EURO72LORES_KEY = $00069004;


EURO72LORESDBL_KEY

Declaration

Source position: agraphics.pas line 1632

const EURO72LORESDBL_KEY = $00069000;


EURO72LORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1609

const EURO72LORESDPF2_KEY = $00069444;


EURO72LORESDPF_KEY

Declaration

Source position: agraphics.pas line 1603

const EURO72LORESDPF_KEY = $00069404;


EURO72LORESEHB_KEY

Declaration

Source position: agraphics.pas line 1625

const EURO72LORESEHB_KEY = $00069084;


EURO72LORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1638

const EURO72LORESEHBDBL_KEY = $00069080;


EURO72LORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1626

const EURO72LORESEHBLACE_KEY = $00069085;


EURO72LORESHAM_KEY

Declaration

Source position: agraphics.pas line 1619

const EURO72LORESHAM_KEY = $00069804;


EURO72LORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1635

const EURO72LORESHAMDBL_KEY = $00069800;


EURO72LORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1620

const EURO72LORESHAMLACE_KEY = $00069805;


EURO72LORESLACE_KEY

Declaration

Source position: agraphics.pas line 1599

const EURO72LORESLACE_KEY = $00069005;


EURO72LORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1612

const EURO72LORESLACEDPF2_KEY = $00069445;


EURO72LORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1606

const EURO72LORESLACEDPF_KEY = $00069405;


EURO72PRODUCT_KEY

Declaration

Source position: agraphics.pas line 1596

const EURO72PRODUCT_KEY = $00069024;


EURO72PRODUCTDBL_KEY

Declaration

Source position: agraphics.pas line 1633

const EURO72PRODUCTDBL_KEY = $00069020;


EURO72PRODUCTDPF2_KEY

Declaration

Source position: agraphics.pas line 1610

const EURO72PRODUCTDPF2_KEY = $00069464;


EURO72PRODUCTDPF_KEY

Declaration

Source position: agraphics.pas line 1604

const EURO72PRODUCTDPF_KEY = $00069424;


EURO72PRODUCTEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1639

const EURO72PRODUCTEHBDBL_KEY = $000690a0;


EURO72PRODUCTHAM_KEY

Declaration

Source position: agraphics.pas line 1617

const EURO72PRODUCTHAM_KEY = $00069824;


EURO72PRODUCTHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1636

const EURO72PRODUCTHAMDBL_KEY = $00069820;


EURO72PRODUCTHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1618

const EURO72PRODUCTHAMLACE_KEY = $00069825;


EURO72PRODUCTLACE_KEY

Declaration

Source position: agraphics.pas line 1600

const EURO72PRODUCTLACE_KEY = $00069025;


EURO72PRODUCTLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1613

const EURO72PRODUCTLACEDPF2_KEY = $00069465;


EURO72PRODUCTLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1607

const EURO72PRODUCTLACEDPF_KEY = $00069425;


EXTEND_VSTRUCT

Unused bit in Modes field of View TViewPort

Declaration

Source position: agraphics.pas line 1367

const EXTEND_VSTRUCT = $1000;


EXTENDED_MODE

Declaration

Source position: agraphics.pas line 1377

const EXTENDED_MODE = $1000;


EXTRA_HALFBRITE

Declaration

Source position: agraphics.pas line 1373

const EXTRA_HALFBRITE = $0080;


EXTRAHALFBRITE_KEY

Declaration

Source position: agraphics.pas line 1522

const EXTRAHALFBRITE_KEY = $00000080;


EXTRAHALFBRITELACE_KEY

Declaration

Source position: agraphics.pas line 1523

const EXTRAHALFBRITELACE_KEY = $00000084;


FILLALPHA

Declaration

Source position: agraphics.pas line 361

const FILLALPHA = 16;


FPB_DESIGNED

Flag Bit size is "designed", not constructed

Declaration

Source position: agraphics.pas line 321

const FPB_DESIGNED = 6;


FPB_DISKFONT

Flag Bit font is from diskfont.library

Declaration

Source position: agraphics.pas line 311

const FPB_DISKFONT = 1;


FPB_PROPORTIONAL

Flag Bit character sizes can vary from nominal

Declaration

Source position: agraphics.pas line 319

const FPB_PROPORTIONAL = 5;


FPB_REMOVED

Flag Bit the font has been removed

Declaration

Source position: agraphics.pas line 323

const FPB_REMOVED = 7;


FPB_REVPATH

Flag Bit designed path is reversed (e.g. left)

Declaration

Source position: agraphics.pas line 313

const FPB_REVPATH = 2;


FPB_ROMFONT

Flag Bit font is in rom

Declaration

Source position: agraphics.pas line 309

const FPB_ROMFONT = 0;


FPB_TALLDOT

Flag Bit designed for hires non-interlaced

Declaration

Source position: agraphics.pas line 315

const FPB_TALLDOT = 3;


FPB_WIDEDOT

Flag Bit designed for lores interlaced

Declaration

Source position: agraphics.pas line 317

const FPB_WIDEDOT = 4;


FPF_DESIGNED

Flag value size is "designed", not constructed

Declaration

Source position: agraphics.pas line 322

const FPF_DESIGNED = $40;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_DISKFONT

Flag value font is from diskfont.library

Declaration

Source position: agraphics.pas line 312

const FPF_DISKFONT = $02;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_PROPORTIONAL

Flag value character sizes can vary from nominal

Declaration

Source position: agraphics.pas line 320

const FPF_PROPORTIONAL = $20;

Description

For TTextAttr.ta_Flags, TTTextAttr.tta_Flags


FPF_REMOVED

Flag value the font has been removed

Declaration

Source position: agraphics.pas line 324

const FPF_REMOVED = 1 shl 7;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_REVPATH

Flag value designed path is reversed (e.g. left)

Declaration

Source position: agraphics.pas line 314

const FPF_REVPATH = $04;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_ROMFONT

Flag value font is in rom

Declaration

Source position: agraphics.pas line 310

const FPF_ROMFONT = $01;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_TALLDOT

Flag value designed for hires non-interlaced

Declaration

Source position: agraphics.pas line 316

const FPF_TALLDOT = $08;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FPF_WIDEDOT

Flag value designed for lores interlaced

Declaration

Source position: agraphics.pas line 318

const FPF_WIDEDOT = $10;

Description

For TTextAttr.ta_Flags,TTTextAttr.tta_Flags


FROM_MONITOR

Declaration

Source position: agraphics.pas line 1152

const FROM_MONITOR = 1;


FRST_DOT

Draw the first dot of this line

Declaration

Source position: agraphics.pas line 365

const FRST_DOT = $01;

See also

TRastPort

Basic structure for all drawing actions


FS_NORMAL

Bit Font Style normal text (no style bits set)

Declaration

Source position: agraphics.pas line 291

const FS_NORMAL = 0;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSB_ANTIALIASED

Declaration

Source position: agraphics.pas line 300

const FSB_ANTIALIASED = 4;


FSB_BOLD

Bit Font Style bold face text (ORed w/ shifted)

Declaration

Source position: agraphics.pas line 294

const FSB_BOLD = 1;


FSB_COLORFONT

Bit Font Style this uses ColorTextFont structure

Declaration

Source position: agraphics.pas line 303

const FSB_COLORFONT = 6;


FSB_EXTENDED

Bit Font Style extended face (wider than normal)

Declaration

Source position: agraphics.pas line 298

const FSB_EXTENDED = 3;


FSB_ITALIC

Bit Font Style italic (slanted 1:2 right)

Declaration

Source position: agraphics.pas line 296

const FSB_ITALIC = 2;


FSB_TAGGED

Bit Font Style the TextAttr is really an TTextAttr

Declaration

Source position: agraphics.pas line 305

const FSB_TAGGED = 7;


FSB_UNDERLINED

Bit Font Style underlined (under baseline)

Declaration

Source position: agraphics.pas line 292

const FSB_UNDERLINED = 0;


FSF_ANTIALIASED

Declaration

Source position: agraphics.pas line 301

const FSF_ANTIALIASED = $10;


FSF_BOLD

Font Style bold face text (ORed w/ shifted)

Declaration

Source position: agraphics.pas line 295

const FSF_BOLD = $02;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_COLORFONT

Bit Font Style this uses ColorTextFont structure

Declaration

Source position: agraphics.pas line 304

const FSF_COLORFONT = $40;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_EXTENDED

Font Style extended face (wider than normal)

Declaration

Source position: agraphics.pas line 299

const FSF_EXTENDED = $08;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_ITALIC

Font Style italic (slanted 1:2 right)

Declaration

Source position: agraphics.pas line 297

const FSF_ITALIC = $04;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_TAGGED

Font Style the TextAttr is really an TTextAttr

Declaration

Source position: agraphics.pas line 306

const FSF_TAGGED = $80;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


FSF_UNDERLINED

Font Style underlined (under baseline)

Declaration

Source position: agraphics.pas line 293

const FSF_UNDERLINED = $01;

Description

For TTextAttr.ta_Style, TTTextAttr.tta_Style


GBD_BoardDriver

Declaration

Source position: agraphics.pas line 69

const GBD_BoardDriver = GBD_TagBase + 8;


GBD_BoardName

Declaration

Source position: agraphics.pas line 62

const GBD_BoardName = GBD_TagBase + 1;


GBD_ChipDriver

Declaration

Source position: agraphics.pas line 70

const GBD_ChipDriver = GBD_TagBase + 9;


GBD_FreeMemory

Declaration

Source position: agraphics.pas line 64

const GBD_FreeMemory = GBD_TagBase + 3;


GBD_InternalMemorySize

Declaration

Source position: agraphics.pas line 66

const GBD_InternalMemorySize = GBD_TagBase + 5;


GBD_LargestFreeMemory

Declaration

Source position: agraphics.pas line 65

const GBD_LargestFreeMemory = GBD_TagBase + 4;


GBD_PCIProductID

Declaration

Source position: agraphics.pas line 68

const GBD_PCIProductID = GBD_TagBase + 7;


GBD_PCIVendorID

Declaration

Source position: agraphics.pas line 67

const GBD_PCIVendorID = GBD_TagBase + 6;


GBD_TagBase

Declaration

Source position: agraphics.pas line 61

const GBD_TagBase = TAG_USER;


GBD_TotalMemory

Declaration

Source position: agraphics.pas line 63

const GBD_TotalMemory = GBD_TagBase + 2;


GCTRL_Get31KHzScanRate

Declaration

Source position: agraphics.pas line 1046

const GCTRL_Get31KHzScanRate = TAG_USER + 11;


GCTRL_GetDisableAmigaBlitter

Declaration

Source position: agraphics.pas line 1042

const GCTRL_GetDisableAmigaBlitter = TAG_USER + 7;


GCTRL_GetForceSWComposite

Declaration

Source position: agraphics.pas line 1036

const GCTRL_GetForceSWComposite = TAG_USER + 1;


GCTRL_GetPlanesToFast

Declaration

Source position: agraphics.pas line 1044

const GCTRL_GetPlanesToFast = TAG_USER + 9;


GCTRL_GetUseAltiVec

Declaration

Source position: agraphics.pas line 1040

const GCTRL_GetUseAltiVec = TAG_USER + 5;


GCTRL_GetUseDMA

Declaration

Source position: agraphics.pas line 1038

const GCTRL_GetUseDMA = TAG_USER + 3;


GCTRL_Set31KHzScanRate

Declaration

Source position: agraphics.pas line 1047

const GCTRL_Set31KHzScanRate = TAG_USER + 12;


GCTRL_SetDisableAmigaBlitter

Declaration

Source position: agraphics.pas line 1043

const GCTRL_SetDisableAmigaBlitter = TAG_USER + 8;


GCTRL_SetForceSWComposite

Declaration

Source position: agraphics.pas line 1037

const GCTRL_SetForceSWComposite = TAG_USER + 2;


GCTRL_SetPlanesToFast

Declaration

Source position: agraphics.pas line 1045

const GCTRL_SetPlanesToFast = TAG_USER + 10;


GCTRL_SetUseAltiVec

Declaration

Source position: agraphics.pas line 1041

const GCTRL_SetUseAltiVec = TAG_USER + 6;


GCTRL_SetUseDMA

Declaration

Source position: agraphics.pas line 1039

const GCTRL_SetUseDMA = TAG_USER + 4;


GELGONE

System Set flag for TVsprite.Flags. Set if gel is completely clipped (offscreen)

Declaration

Source position: agraphics.pas line 408

const GELGONE = $0400;


GENLOC

Flag for TGfxBase.DisplayFlags Genlock is in use

Declaration

Source position: agraphics.pas line 2240

const GENLOC = 2;


GENLOCK_AUDIO

Declaration

Source position: agraphics.pas line 1374

const GENLOCK_AUDIO = $0100;


GENLOCK_VIDEO

Declaration

Source position: agraphics.pas line 1369

const GENLOCK_VIDEO = $0002;


GFXB_AA_ALICE

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2257

const GFXB_AA_ALICE = 2;


GFXB_AA_LISA

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2258

const GFXB_AA_LISA = 3;


GFXB_AA_MLISA

Bit defintion for TGfxBase.ChipRevBits0 Internal use only

Declaration

Source position: agraphics.pas line 2259

const GFXB_AA_MLISA = 4;


GFXB_BIG_BLITS

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2254

const GFXB_BIG_BLITS = 0;


GFXB_HR_AGNUS

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2255

const GFXB_HR_AGNUS = 0;


GFXB_HR_DENISE

Bit defintion for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2256

const GFXB_HR_DENISE = 1;


GfxBase

Graphics base library pointer for all graphics library functions, opened on unit initialization

Declaration

Source position: agraphics.pas line 2291

var GfxBase: PLibrary = Nil;


GFXF_AA_ALICE

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2264

const GFXF_AA_ALICE = 4;


GFXF_AA_LISA

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2265

const GFXF_AA_LISA = 8;


GFXF_AA_MLISA

Bit value for TGfxBase.ChipRevBits0 internal use only

Declaration

Source position: agraphics.pas line 2266

const GFXF_AA_MLISA = 16;


GFXF_BIG_BLITS

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2261

const GFXF_BIG_BLITS = 1;


GFXF_HAVECOMPOSITE

Declaration

Source position: agraphics.pas line 2286

const GFXF_HAVECOMPOSITE = $0002;


GFXF_HR_AGNUS

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2262

const GFXF_HR_AGNUS = 1;


GFXF_HR_DENISE

Bit value for TGfxBase.ChipRevBits0

Declaration

Source position: agraphics.pas line 2263

const GFXF_HR_DENISE = 2;


GFXF_NEW_DATABASE

Declaration

Source position: agraphics.pas line 2285

const GFXF_NEW_DATABASE = $0001;


GMD_BasicAudio

Declaration

Source position: agraphics.pas line 1074

const GMD_BasicAudio = GMD_TagBase + 15;


GMD_DisplayHeight

Declaration

Source position: agraphics.pas line 1070

const GMD_DisplayHeight = GMD_TagBase + 11;


GMD_DisplayWidth

Declaration

Source position: agraphics.pas line 1069

const GMD_DisplayWidth = GMD_TagBase + 10;


GMD_DotClockMax

Declaration

Source position: agraphics.pas line 1068

const GMD_DotClockMax = GMD_TagBase + 9;


GMD_DotClockMin

Declaration

Source position: agraphics.pas line 1067

const GMD_DotClockMin = GMD_TagBase + 8;


GMD_EDIDRevision

Declaration

Source position: agraphics.pas line 1073

const GMD_EDIDRevision = GMD_TagBase + 14;


GMD_EDIDVersion

Declaration

Source position: agraphics.pas line 1072

const GMD_EDIDVersion = GMD_TagBase + 13;


GMD_HSyncMax

Declaration

Source position: agraphics.pas line 1064

const GMD_HSyncMax = GMD_TagBase + 5;


GMD_HSyncMin

Declaration

Source position: agraphics.pas line 1063

const GMD_HSyncMin = GMD_TagBase + 4;


GMD_InputType

Declaration

Source position: agraphics.pas line 1071

const GMD_InputType = GMD_TagBase + 12;


GMD_Product

Declaration

Source position: agraphics.pas line 1061

const GMD_Product = GMD_TagBase + 2;


GMD_ProductID

Declaration

Source position: agraphics.pas line 1062

const GMD_ProductID = GMD_TagBase + 3;


GMD_TagBase

Declaration

Source position: agraphics.pas line 1059

const GMD_TagBase = TAG_USER;


GMD_VendorID

Declaration

Source position: agraphics.pas line 1060

const GMD_VendorID = GMD_TagBase + 1;


GMD_VSyncMax

Declaration

Source position: agraphics.pas line 1066

const GMD_VSyncMax = GMD_TagBase + 7;


GMD_VSyncMin

Declaration

Source position: agraphics.pas line 1065

const GMD_VSyncMin = GMD_TagBase + 6;


GRAPHICSNAME

Name of graphics library

Declaration

Source position: agraphics.pas line 2288

const GRAPHICSNAME: PChar = 'graphics.library';


GSTAG_ATTACHED

Tag for GetExtSpriteA()

Declaration

Source position: agraphics.pas line 2066

const GSTAG_ATTACHED = $82000022;


GSTAG_SCANDOUBLED

Tag for GetExtSpriteA() or ChangeExtSpriteA() request "NTSC-Like" height if possible.

Declaration

Source position: agraphics.pas line 2070

const GSTAG_SCANDOUBLED = $83000000;


GSTAG_SOFTSPRITE

Tag for GetExtSpriteA()

Declaration

Source position: agraphics.pas line 2067

const GSTAG_SOFTSPRITE = $82000024;


GSTAG_SPRITE_NUM

Tag for GetExtSpriteA()

Declaration

Source position: agraphics.pas line 2065

const GSTAG_SPRITE_NUM = $82000020;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

HAM

Declaration

Source position: agraphics.pas line 1376

const HAM = $0800;


HAM_KEY

Declaration

Source position: agraphics.pas line 1505

const HAM_KEY = $00000800;


HAMLACE_KEY

Declaration

Source position: agraphics.pas line 1509

const HAMLACE_KEY = $00000804;


HIRES

Declaration

Source position: agraphics.pas line 1380

const HIRES = $8000;


HIRES_KEY

Declaration

Source position: agraphics.pas line 1503

const HIRES_KEY = $00008000;


HIRESDPF2_KEY

Declaration

Source position: agraphics.pas line 1517

const HIRESDPF2_KEY = $00008440;


HIRESDPF_KEY

Declaration

Source position: agraphics.pas line 1511

const HIRESDPF_KEY = $00008400;


HIRESEHB_KEY

Declaration

Source position: agraphics.pas line 1527

const HIRESEHB_KEY = $00008080;


HIRESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1531

const HIRESEHBLACE_KEY = $00008084;


HIRESHAM_KEY

Declaration

Source position: agraphics.pas line 1525

const HIRESHAM_KEY = $00008800;


HIRESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1529

const HIRESHAMLACE_KEY = $00008804;


HIRESHAMSDBL_KEY

Declaration

Source position: agraphics.pas line 1537

const HIRESHAMSDBL_KEY = $00008808;


HIRESLACE_KEY

Declaration

Source position: agraphics.pas line 1507

const HIRESLACE_KEY = $00008004;


HIRESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1520

const HIRESLACEDPF2_KEY = $00008444;


HIRESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1514

const HIRESLACEDPF_KEY = $00008404;


HOLDNMODIFY

Declaration

Source position: agraphics.pas line 1776

const HOLDNMODIFY = $800;


IGfx

Declaration

Source position: agraphics.pas line 2292

var IGfx: PInterface = Nil;


IGNORE_MCOMPAT

Flags for CoerceMode Coercion should ignore monitor compatibility issues.

Declaration

Source position: agraphics.pas line 394

const IGNORE_MCOMPAT = 4;


Reference for unit 'agraphics'

Native Amiga graphic functions (graphics.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility; | Tag Handling, Date routines in utility.library

Overview

The Graphics library provide graphic functions for graphic centered programs. Beside drawing lines and circles, set points it provides function for Sprite-, Bob and VSprite manipulation. There are also some functions to work together with the layers.library.


Reference for unit 'agraphics': Constants

A2024FIFTEENHERTZ_KEY |
A2024TENHERTZ_KEY |
A2024_MONITOR_ID |
ALPHAHOOKACTION_CHANGELAYERALPHA
ALPHAHOOKACTION_CREATELAYER
ALPHAHOOKACTION_DELETELAYER
ALPHAHOOKACTION_GETHOOKACTIONS
ALPHAHOOKACTION_MOVELAYER
ALPHAHOOKACTION_MOVESIZELAYER
ALPHAHOOKACTION_SIZELAYER
ANFRACSIZE | Define for the animation procedures
ANIMHALF | Define for the animation procedures
AREAOUTLINE | Used by areafiller only used for bobs
AVOID_FLICKER | Flag for CoerceMode Ensure that the mode coerced to is not interlaced.
B2BOBBER |
B2NORM |
B2SWAP |
BACKSAVED | System Set flag for TVsprite.Flags. This Bob's background has been saved
BANDWIDTH_1X | Memory Type
BANDWIDTH_2XDBL | Memory Type
BANDWIDTH_2XNML | Memory Type
BANDWIDTH_4X | Memory Type
BDRAWN | Bob System Flag for TBob.Flags set when Bob is drawn this DrawG pass
BGBACKFILL
BIDTAG_BlueBits | Tag for BestModeID() Match up from the DataBase default - 4
BIDTAG_COERCE | Flags for CoerceMode Private
BIDTAG_Depth | Tag for BestModeID() ModeID must support this depth. Default - TViewPort.RasInfo^.BitMap^.Depth or 1
BIDTAG_DesiredHeight | Tag for BestModeID() Nominal Height of the returned ModeID. Default - same as Nominal
BIDTAG_DesiredWidth | Tag for BestModeID() Nominal Width of the returned ModeID. Default - same as Nominal
BIDTAG_DIPFMustHave | Tag for BestModeID() mask of the DIPF_* flags the ModeID must have Default - 0
BIDTAG_DIPFMustNotHave | Tag for BestModeID() mask of the DIPF_ flags the ModeID must not have Default
BIDTAG_GfxPrivate | Tag for BestModeID() Private do not use
BIDTAG_GreenBits | Tag for BestModeID() Match up from the DataBase default - 4
BIDTAG_MaxDepth
BIDTAG_MonitorID | Tag for BestModeID() ModeID must use this monitor. Default - use best monitor available
BIDTAG_NominalHeight | Tag for BestModeID() Override the TViewPort.Height. Default - SourceID NominalDimensionInfo or TViewPort.DHeight or 200 in that order
BIDTAG_NominalWidth | Tag for BestModeID() Override the TViewPort.Width. Default - SourceID NominalDimensionInfo or TViewPort.DWidth or 640 in that order
BIDTAG_RedBits | Tag for BestModeID() Match up from the DataBase default - 4
BIDTAG_SourceID | Tag for BestModeID() Instead of a ViewPort. Default - VPModeID(vp) if BIDTAG_ViewPort is specified, else leave the BIDTAG_DIPFMustHave and BIDTAG_DIPFMustNotHave values untouched.
BIDTAG_ViewPort | Tag for BestModeID() ViewPort for which a ModeID is sought. Default - nil
BITCLR |
BITSET |
BLITA_Alpha
BLITA_AlphaMask
BLITA_CLUT
BLITA_Dest
BLITA_DestBytesPerRow
BLITA_DestType
BLITA_DestX
BLITA_DestY
BLITA_Height
BLITA_Mask
BLITA_MaskPlane
BLITA_Minterm
BLITA_Source
BLITA_SrcBytesPerRow
BLITA_SrcType
BLITA_SrcX
BLITA_SrcY
BLITA_UseDestAlpha
BLITA_UseSrcAlpha
BLITA_Width
BLITMSG_FAULT |
BLITMSG_FAULTn
BLITT_ALPHATEMPLATE
BLITT_ARGB32
BLITT_BITMAP
BLITT_CHUNKY
BLITT_RASTPORT
BLITT_RGB16
BLITT_RGB24
BLITT_TEMPLATE
BLTBMTAGS_BASE
BMATags_Alignment
BMATags_BitmapColors
BMATags_BitmapColors32
BMATags_BitmapInvisible
BMATags_Clear
BMATags_ConstantBytesPerRow
BMATags_Depth
BMATags_Displayable
BMATags_DisplayID
BMATags_Friend
BMATags_ModeHeight
BMATags_ModeWidth
BMATags_NoMemory
BMATags_NoSprite
BMATags_PixelFormat
BMATags_Private1
BMATags_Private2
BMATags_Private3
BMATags_Private4
BMATags_Private5
BMATags_Private6
BMATags_Private7
BMATags_RenderFunc
BMATags_SaveFunc
BMATags_UserData
BMATags_UserPrivate
BMA_ACTUALWIDTH
BMA_BITSPERPIXEL
BMA_BYTESPERPIXEL
BMA_DEPTH | ID are for GetBitMapAttr. Query depth of bitmap.
BMA_FLAGS | ID are for GetBitMapAttr. Query Flags (BMF_*) of bitmap.
BMA_HEIGHT | ID are for GetBitMapAttr. Query height of bitmap.
BMA_ISRTG
BMA_PIXELFORMAT
BMA_WIDTH | ID are for GetBitMapAttr. Query width of bitmap.
BMB_CLEAR | Bit flag for AllocBitMap Fill Bitmap with color 0
BMB_DISPLAYABLE | Bit flag for AllocBitMap Displayable Bitmap
BMB_FRIENDISTAG
BMB_HIJACKED
BMB_INTERLEAVED | Bit flag for AllocBitMap Interleaved Bitmap
BMB_INVALID
BMB_LOCKED
BMB_MINPLANES | Bit flag for AllocBitMap Minimal memory use
BMB_RTGCHECK
BMB_RTGTAGS
BMB_STANDARD | Bit flag for AllocBitMap
BMF_CHECKMASK
BMF_CHECKVALUE
BMF_CLEAR | Bit value for AllocBitMap Fill Bitmap with color 0
BMF_DISPLAYABLE | Bit flag for AllocBitMap Displayable Bitmap
BMF_FRIENDISTAG
BMF_HIJACKED
BMF_INTERLEAVED | Bit flag for AllocBitMap Interleaved Bitmap
BMF_INVALID
BMF_LOCKED
BMF_MINPLANES | Bit value for AllocBitMap Minimal memory use
BMF_RTGCHECK
BMF_RTGTAGS
BMF_STANDARD | Bit value for AllocBitMap
BOBISCOMP | Bob User Flag for TBob.Flags set to identify Bob as AnimComp
BOBNIX | Bob System Flag for TBob.Flags Set when Bob is completely removed
BOBSAWAY | Bob System Flag for TBob.Flags Set to initiate removal of Bob
BOBUPDATE | System Set flag for TVsprite.Flags. Temporary flag, useless to outside world
BORDERHIT | Bit Description for SetCollision
BORDERSPRITES | Flag value for TColorMap.Flags
BORDER_BLANKING | Flag value for TColorMap.Flags
BORDER_NOTRANSPARENCY | Flag value for TColorMap.Flags
BOTTOMHIT | Bit Description for SetCollision
BROADCAST_HBSTOP |
BROADCAST_HBSTRT |
BROADCAST_HSSTOP |
BROADCAST_HSSTRT |
BROADCAST_VBSTOP |
BROADCAST_VBSTRT |
BROADCAST_VSSTOP |
BROADCAST_VSSTRT |
BSAF_AVERAGE
BSAF_BILINEAR
BSAF_RESERVED1
BSAF_RESERVED2
BUSERFLAGS | Bob user Flag for TBob.Flags mask of all user-settable Bob-flags
BUS_16 | Memory Type
BUS_32 | Memory Type
BWAITING | Bob System Flag for TBob.Flags set while Bob is waiting on 'after'
CMAB_DUALPF_DISABLE | Flag bit for TColorMap.AuxFlags
CMAB_FULLPALETTE | Flag bit for TColorMap.AuxFlags
CMAB_NO_COLOR_LOAD | Flag bit for TColorMap.AuxFlags
CMAB_NO_INTERMED_UPDATE | Flag bit for TColorMap.AuxFlags
CMAF_DUALPF_DISABLE | Flag value for TColorMap.AuxFlags
CMAF_FULLPALETTE | Flag value for TColorMap.AuxFlags
CMAF_NO_COLOR_LOAD | Flag value for TColorMap.AuxFlags
CMAF_NO_INTERMED_UPDATE | Flag value for TColorMap.AuxFlags
CMF_BRDNTRAN | Flag Bit for TColorMap.Flags
CMF_BRDRBLNK | Flag Bit for TColorMap.Flags
CMF_BRDRSPRT | Flag Bit for TColorMap.Flags
CMF_CMTRANS | Flag Bit for TColorMap.Flags
CMF_CPTRANS | Flag Bit for TColorMap.Flags
COLORMAP_TRANSPARENCY | Flag value for TColorMap.Flags
COLORMAP_TYPE_V1_2 | Colormap type for TColorMap.Type_ WB 1.2
COLORMAP_TYPE_V1_4 |
COLORMAP_TYPE_V36 | Colormap type for TColorMap.Type_ V36
COLORMAP_TYPE_V39 | Colormap type for TColorMap.Type_ V39
COLORON |
COLORPLANE_TRANSPARENCY | Flag value for TColorMap.Flags
COMPERR_Generic
COMPERR_Incompatible
COMPERR_MissingInput
COMPERR_OutOfMemory
COMPERR_SoftwareFallback
COMPERR_Success
COMPERR_UnknownOperator
COMPERR_Value
COMPFLAG_Color1Modulate
COMPFLAG_DestAlphaOverride
COMPFLAG_ForceSoftware
COMPFLAG_HardwareOnly
COMPFLAG_IgnoreDestAlpha
COMPFLAG_SrcAlphaOverride
COMPFLAG_SrcFilter
COMPLEMENT | Drawing mode: XOR bits into raster
COMPOSITE_Clear
COMPOSITE_Dest
COMPOSITE_Dest_Atop_Src
COMPOSITE_Dest_In_Src
COMPOSITE_Dest_Out_Src
COMPOSITE_Dest_Over_Src
COMPOSITE_Maximum
COMPOSITE_Minimum
COMPOSITE_NumOperators
COMPOSITE_Plus
COMPOSITE_Src
COMPOSITE_Src_Atop_Dest
COMPOSITE_Src_In_Dest
COMPOSITE_Src_Out_Dest
COMPOSITE_Src_Over_Dest
COMPOSITE_Src_Xor_Dest
COMPTAG_Base
COMPTAG_Color0
COMPTAG_Color0_Alpha
COMPTAG_Color0_Blue
COMPTAG_Color0_Green
COMPTAG_Color0_Red
COMPTAG_Color1
COMPTAG_Color1_Alpha
COMPTAG_Color1_Blue
COMPTAG_Color1_Green
COMPTAG_Color1_Red
COMPTAG_Color2
COMPTAG_Color2_Alpha
COMPTAG_Color2_Blue
COMPTAG_Color2_Green
COMPTAG_Color2_Red
COMPTAG_Color3
COMPTAG_Color3_Alpha
COMPTAG_Color3_Blue
COMPTAG_Color3_Green
COMPTAG_Color3_Red
COMPTAG_DestAlpha
COMPTAG_DestAlphaMask
COMPTAG_DestAlphaX
COMPTAG_DestAlphaY
COMPTAG_DestHeight
COMPTAG_DestWidth
COMPTAG_DestX
COMPTAG_DestY
COMPTAG_DisplayID
COMPTAG_Flags
COMPTAG_FriendBitMap
COMPTAG_IndexArray
COMPTAG_NumTriangles
COMPTAG_OffsetX
COMPTAG_OffsetY
COMPTAG_Private
COMPTAG_Private2
COMPTAG_ScaleX
COMPTAG_ScaleY
COMPTAG_SrcAlpha
COMPTAG_SrcAlphaMask
COMPTAG_SrcAlphaX
COMPTAG_SrcAlphaY
COMPTAG_SrcHeight
COMPTAG_SrcWidth
COMPTAG_SrcX
COMPTAG_SrcY
COMPTAG_SrcYUVMatrix
COMPTAG_SrcYUVStandard
COMPTAG_VertexArray
COMPTAG_VertexFormat
COMPVF_STW0_Present
COMPVF_STW1_Present
COMPYUV_BT601
COMPYUV_BT709
COPPER_MOVE | Copper command. Pseudo opcode for move #XXXX,dir
COPPER_WAIT | Copper command. Pseudo opcode for wait y,x
CPRNXTBUF | Copper command. Continue processing with next buffer
CPR_NT_LOF | Copper command. Copper instruction only for Longint frames
CPR_NT_SHT | Copper command. Copper instruction only for long frames
CPR_NT_SYS | Copper command. Copper user instruction only
CR_ALPHATYPE
CR_DAMAGECLIPPED
CR_INTUITION
CR_INVISIBLE
CR_LAYERBITMAP
CR_USERCLIPPED
CTB_MAPCOLOR | Flag Bit for TColorTextFont.ctf_Flags
CTF_MAPCOLOR | Flag for TColorTextFont.ctf_Flags mapped color
CT_ANTIALIAS | Flag for TColorTextFont.ctf_Flags zero background thru fully saturated char
CT_COLORFONT | Flag for TColorTextFont.ctf_Flags color map contains designer's colors
CT_COLORMASK | Flag mask for TColorTextFont.ctf_Flags mask to get to all color styles
CT_GREYFONT | Flag for TColorTextFont.ctf_Flags color map describes even-stepped
DBLNTSCEXTRALORESDPF2FF_KEY |
DBLNTSCEXTRALORESDPF2LACE_KEY |
DBLNTSCEXTRALORESDPF2_KEY |
DBLNTSCEXTRALORESDPFFF_KEY |
DBLNTSCEXTRALORESDPFLACE_KEY |
DBLNTSCEXTRALORESDPF_KEY |
DBLNTSCEXTRALORESEHBFF_KEY |
DBLNTSCEXTRALORESEHBLACE_KEY |
DBLNTSCEXTRALORESEHB_KEY |
DBLNTSCEXTRALORESFF_KEY |
DBLNTSCEXTRALORESHAMFF_KEY |
DBLNTSCEXTRALORESHAMLACE_KEY |
DBLNTSCEXTRALORESHAM_KEY |
DBLNTSCEXTRALORESLACE_KEY |
DBLNTSCEXTRALORES_KEY |
DBLNTSCHIRESDPF2FF_KEY |
DBLNTSCHIRESDPF2LACE_KEY |
DBLNTSCHIRESDPF2_KEY |
DBLNTSCHIRESDPFFF_KEY |
DBLNTSCHIRESDPFLACE_KEY |
DBLNTSCHIRESDPF_KEY |
DBLNTSCHIRESEHBFF_KEY |
DBLNTSCHIRESEHBLACE_KEY |
DBLNTSCHIRESEHB_KEY |
DBLNTSCHIRESFF_KEY |
DBLNTSCHIRESHAMFF_KEY |
DBLNTSCHIRESHAMLACE_KEY |
DBLNTSCHIRESHAM_KEY |
DBLNTSCHIRESLACE_KEY |
DBLNTSCHIRES_KEY |
DBLNTSCLORESDPF2FF_KEY |
DBLNTSCLORESDPF2LACE_KEY |
DBLNTSCLORESDPF2_KEY |
DBLNTSCLORESDPFFF_KEY |
DBLNTSCLORESDPFLACE_KEY |
DBLNTSCLORESDPF_KEY |
DBLNTSCLORESEHBFF_KEY |
DBLNTSCLORESEHBLACE_KEY |
DBLNTSCLORESEHB_KEY |
DBLNTSCLORESFF_KEY |
DBLNTSCLORESHAMFF_KEY |
DBLNTSCLORESHAMLACE_KEY |
DBLNTSCLORESHAM_KEY |
DBLNTSCLORESLACE_KEY |
DBLNTSCLORES_KEY |
DBLNTSC_MONITOR_ID |
DBLPALEXTRALORESDPF2FF_KEY |
DBLPALEXTRALORESDPF2LACE_KEY |
DBLPALEXTRALORESDPF2_KEY |
DBLPALEXTRALORESDPFFF_KEY |
DBLPALEXTRALORESDPFLACE_KEY |
DBLPALEXTRALORESDPF_KEY |
DBLPALEXTRALORESEHBFF_KEY |
DBLPALEXTRALORESEHBLACE_KEY |
DBLPALEXTRALORESEHB_KEY |
DBLPALEXTRALORESFF_KEY |
DBLPALEXTRALORESHAMFF_KEY |
DBLPALEXTRALORESHAMLACE_KEY |
DBLPALEXTRALORESHAM_KEY |
DBLPALEXTRALORESLACE_KEY |
DBLPALEXTRALORES_KEY |
DBLPALHIRESDPF2FF_KEY |
DBLPALHIRESDPF2LACE_KEY |
DBLPALHIRESDPF2_KEY |
DBLPALHIRESDPFFF_KEY |
DBLPALHIRESDPFLACE_KEY |
DBLPALHIRESDPF_KEY |
DBLPALHIRESEHBFF_KEY |
DBLPALHIRESEHBLACE_KEY |
DBLPALHIRESEHB_KEY |
DBLPALHIRESFF_KEY |
DBLPALHIRESHAMFF_KEY |
DBLPALHIRESHAMLACE_KEY |
DBLPALHIRESHAM_KEY |
DBLPALHIRESLACE_KEY |
DBLPALHIRES_KEY |
DBLPALLORESDPF2FF_KEY |
DBLPALLORESDPF2LACE_KEY |
DBLPALLORESDPF2_KEY |
DBLPALLORESDPFFF_KEY |
DBLPALLORESDPFLACE_KEY |
DBLPALLORESDPF_KEY |
DBLPALLORESEHBFF_KEY |
DBLPALLORESEHBLACE_KEY |
DBLPALLORESEHB_KEY |
DBLPALLORESFF_KEY |
DBLPALLORESHAMFF_KEY |
DBLPALLORESHAMLACE_KEY |
DBLPALLORESHAM_KEY |
DBLPALLORESLACE_KEY |
DBLPALLORES_KEY |
DBLPAL_MONITOR_ID |
DBLPF |
DBL_CAS | Memory Type
DBUFFER | Flag set when RastPorts are double-buffered
DEFAULT_MONITOR_ID |
DEFAULT_MONITOR_NAME |
DFTCH_MASK |
DIPF_IS_AA | Flag for TDisplayInfo.PropertyFlagsAA modes - may only be available if machine has correct memory type to support required bandwidth - check availability.
DIPF_IS_BEAMSYNC | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_DBUFFER | Flag for TDisplayInfo.PropertyFlags Mode supports double buffering
DIPF_IS_DRAGGABLE | Flag for TDisplayInfo.PropertyFlags Mode can be dragged down
DIPF_IS_DUALPF | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_ECS | Flag for TDisplayInfo.PropertyFlags Mode which needs ECS Chipset (SHIRES, VGA, AND PRODUCTIVITY) do not support attached sprites.
DIPF_IS_EXTRAHALFBRITE | Flag for TDisplayInfo.PropertyFlags EHB mode
DIPF_IS_FOREIGN | Flag for TDisplayInfo.PropertyFlagsMode is not native to the Amiga
DIPF_IS_GENLOCK | Flag for TDisplayInfo.PropertyFlags Mode wich support Genlocks
DIPF_IS_HAM | Flag for TDisplayInfo.PropertyFlags HAM6/8 Mode
DIPF_IS_HWCOMPOSITE
DIPF_IS_LACE | Flag for TDisplayInfo.PropertyFlags Interlace mode
DIPF_IS_PAL | Flag for TDisplayInfo.PropertyFlags PAL Mode
DIPF_IS_PANELLED | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_PF2PRI | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_PREFERREDMODE
DIPF_IS_PROGBEAM | Flag for TDisplayInfo.PropertyFlags Mode is a programmed beam-sync mode
DIPF_IS_RTG
DIPF_IS_SCANDBL | Flag for TDisplayInfo.PropertyFlags Scan doubled mode
DIPF_IS_SPRITES | Flag for TDisplayInfo.PropertyFlags
DIPF_IS_SPRITES_ATT | Flag for TDisplayInfo.PropertyFlags Mode supports attached sprites
DIPF_IS_SPRITES_BORDER | Flag for TDisplayInfo.PropertyFlags Sprite can be displayed in the border
DIPF_IS_SPRITES_CHNG_BASE | Flag for TDisplayInfo.PropertyFlags Mode can change the sprite base color
DIPF_IS_SPRITES_CHNG_PRI | Flag for TDisplayInfo.PropertyFlags Mode can change the sprite priority with respect to the playfield(s).
DIPF_IS_SPRITES_CHNG_RES | Flag for TDisplayInfo.PropertyFlags Mode supports variable sprite resolution
DIPF_IS_WB | Flag for TDisplayInfo.PropertyFlags Mode is useable for Workbench/Wanderer
DISPLAYNAMELEN | Max name of monitor names see TNameInfo.Name
DIW_HORIZ_POS |
DIW_VRTCL_POS |
DIW_VRTCL_POS_SHIFT |
DI_AVAIL_INVALID
DI_AVAIL_MONITOOL
DI_AVAIL_NOCHIPS | Availability for TDisplayInfo.NotAvailable
DI_AVAIL_NOMONITOR | Availability for TDisplayInfo.NotAvailable
DI_AVAIL_NOTWITHGENLOCK | Availability for TDisplayInfo.NotAvailable
DPMSLEVEL_OFF
DPMSLEVEL_ON
DPMSLEVEL_STANDBY
DPMSLEVEL_SUSPEND
DTAG_DIMS | GetDisplayInfoData, results in PDimensionInfo
DTAG_DISP | Start tag for GetDisplayInfoData
DTAG_MNTR | GetDisplayInfoData, results in PMonitorInfo
DTAG_NAME | GetDisplayInfoData, results in PNameInfo
DTAG_VEC | GetDisplayInfoData, Internal use only (PVecInfo)
DUALPF |
EURO36_MONITOR_ID |
EURO72EHBLACE_KEY |
EURO72EHB_KEY |
EURO72EXTRAHALFBRITELACE_KEY |
EURO72EXTRAHALFBRITE_KEY |
EURO72EXTRALORESDBL_KEY |
EURO72EXTRALORESDPF2_KEY |
EURO72EXTRALORESDPF_KEY |
EURO72EXTRALORESEHBDBL_KEY |
EURO72EXTRALORESEHBLACE_KEY |
EURO72EXTRALORESEHB_KEY |
EURO72EXTRALORESHAMDBL_KEY |
EURO72EXTRALORESHAMLACE_KEY |
EURO72EXTRALORESHAM_KEY |
EURO72EXTRALORESLACEDPF2_KEY |
EURO72EXTRALORESLACEDPF_KEY |
EURO72EXTRALORESLACE_KEY |
EURO72EXTRALORES_KEY |
EURO72HAMLACE_KEY |
EURO72HAM_KEY |
EURO72LORESDBL_KEY |
EURO72LORESDPF2_KEY |
EURO72LORESDPF_KEY |
EURO72LORESEHBDBL_KEY |
EURO72LORESEHBLACE_KEY |
EURO72LORESEHB_KEY |
EURO72LORESHAMDBL_KEY |
EURO72LORESHAMLACE_KEY |
EURO72LORESHAM_KEY |
EURO72LORESLACEDPF2_KEY |
EURO72LORESLACEDPF_KEY |
EURO72LORESLACE_KEY |
EURO72LORES_KEY |
EURO72PRODUCTDBL_KEY |
EURO72PRODUCTDPF2_KEY |
EURO72PRODUCTDPF_KEY |
EURO72PRODUCTEHBDBL_KEY |
EURO72PRODUCTHAMDBL_KEY |
EURO72PRODUCTHAMLACE_KEY |
EURO72PRODUCTHAM_KEY |
EURO72PRODUCTLACEDPF2_KEY |
EURO72PRODUCTLACEDPF_KEY |
EURO72PRODUCTLACE_KEY |
EURO72PRODUCT_KEY |
EURO72_MONITOR_ID |
EXTENDED_MODE |
EXTEND_VSTRUCT | Unused bit in Modes field of View TViewPort
EXTRAHALFBRITELACE_KEY |
EXTRAHALFBRITE_KEY |
EXTRA_HALFBRITE |
FILLALPHA
FPB_DESIGNED | Flag Bit size is "designed", not constructed
FPB_DISKFONT | Flag Bit font is from diskfont.library
FPB_PROPORTIONAL | Flag Bit character sizes can vary from nominal
FPB_REMOVED | Flag Bit the font has been removed
FPB_REVPATH | Flag Bit designed path is reversed (e.g. left)
FPB_ROMFONT | Flag Bit font is in rom
FPB_TALLDOT | Flag Bit designed for hires non-interlaced
FPB_WIDEDOT | Flag Bit designed for lores interlaced
FPF_DESIGNED | Flag value size is "designed", not constructed
FPF_DISKFONT | Flag value font is from diskfont.library
FPF_PROPORTIONAL | Flag value character sizes can vary from nominal
FPF_REMOVED | Flag value the font has been removed
FPF_REVPATH | Flag value designed path is reversed (e.g. left)
FPF_ROMFONT | Flag value font is in rom
FPF_TALLDOT | Flag value designed for hires non-interlaced
FPF_WIDEDOT | Flag value designed for lores interlaced
FROM_MONITOR |
FRST_DOT | Draw the first dot of this line
FSB_ANTIALIASED
FSB_BOLD | Bit Font Style bold face text (ORed w/ shifted)
FSB_COLORFONT | Bit Font Style this uses ColorTextFont structure
FSB_EXTENDED | Bit Font Style extended face (wider than normal)
FSB_ITALIC | Bit Font Style italic (slanted 1:2 right)
FSB_TAGGED | Bit Font Style the TextAttr is really an TTextAttr
FSB_UNDERLINED | Bit Font Style underlined (under baseline)
FSF_ANTIALIASED
FSF_BOLD | Font Style bold face text (ORed w/ shifted)
FSF_COLORFONT | Bit Font Style this uses ColorTextFont structure
FSF_EXTENDED | Font Style extended face (wider than normal)
FSF_ITALIC | Font Style italic (slanted 1:2 right)
FSF_TAGGED | Font Style the TextAttr is really an TTextAttr
FSF_UNDERLINED | Font Style underlined (under baseline)
FS_NORMAL | Bit Font Style normal text (no style bits set)
GBD_BoardDriver
GBD_BoardName
GBD_ChipDriver
GBD_FreeMemory
GBD_InternalMemorySize
GBD_LargestFreeMemory
GBD_PCIProductID
GBD_PCIVendorID
GBD_TagBase
GBD_TotalMemory
GCTRL_Get31KHzScanRate
GCTRL_GetDisableAmigaBlitter
GCTRL_GetForceSWComposite
GCTRL_GetPlanesToFast
GCTRL_GetUseAltiVec
GCTRL_GetUseDMA
GCTRL_Set31KHzScanRate
GCTRL_SetDisableAmigaBlitter
GCTRL_SetForceSWComposite
GCTRL_SetPlanesToFast
GCTRL_SetUseAltiVec
GCTRL_SetUseDMA
GELGONE | System Set flag for TVsprite.Flags. Set if gel is completely clipped (offscreen)
GENLOC | Flag for TGfxBase.DisplayFlags Genlock is in use
GENLOCK_AUDIO |
GENLOCK_VIDEO |
GFXB_AA_ALICE | Bit defintion for TGfxBase.ChipRevBits0
GFXB_AA_LISA | Bit defintion for TGfxBase.ChipRevBits0
GFXB_AA_MLISA | Bit defintion for TGfxBase.ChipRevBits0 Internal use only
GFXB_BIG_BLITS | Bit defintion for TGfxBase.ChipRevBits0
GFXB_HR_AGNUS | Bit defintion for TGfxBase.ChipRevBits0
GFXB_HR_DENISE | Bit defintion for TGfxBase.ChipRevBits0
GFXF_AA_ALICE | Bit value for TGfxBase.ChipRevBits0
GFXF_AA_LISA | Bit value for TGfxBase.ChipRevBits0
GFXF_AA_MLISA | Bit value for TGfxBase.ChipRevBits0 internal use only
GFXF_BIG_BLITS | Bit value for TGfxBase.ChipRevBits0
GFXF_HAVECOMPOSITE
GFXF_HR_AGNUS | Bit value for TGfxBase.ChipRevBits0
GFXF_HR_DENISE | Bit value for TGfxBase.ChipRevBits0
GFXF_NEW_DATABASE
GMD_BasicAudio
GMD_DisplayHeight
GMD_DisplayWidth
GMD_DotClockMax
GMD_DotClockMin
GMD_EDIDRevision
GMD_EDIDVersion
GMD_HSyncMax
GMD_HSyncMin
GMD_InputType
GMD_Product
GMD_ProductID
GMD_TagBase
GMD_VendorID
GMD_VSyncMax
GMD_VSyncMin
GRAPHICSNAME | Name of graphics library
GSTAG_ATTACHED | Tag for GetExtSpriteA()
GSTAG_SCANDOUBLED | Tag for GetExtSpriteA() or ChangeExtSpriteA() request "NTSC-Like" height if possible.
GSTAG_SOFTSPRITE | Tag for GetExtSpriteA()
GSTAG_SPRITE_NUM | Tag for GetExtSpriteA()
HAM |
HAMLACE_KEY |
HAM_KEY |
HIRES |
HIRESDPF2_KEY |
HIRESDPF_KEY |
HIRESEHBLACE_KEY |
HIRESEHB_KEY |
HIRESHAMLACE_KEY |
HIRESHAMSDBL_KEY |
HIRESHAM_KEY |
HIRESLACEDPF2_KEY |
HIRESLACEDPF_KEY |
HIRESLACE_KEY |
HIRES_KEY |
HOLDNMODIFY |
IGNORE_MCOMPAT | Flags for CoerceMode Coercion should ignore monitor compatibility issues.
INPUTTYPE_DVI
INPUTTYPE_VGA
INTERLACE |
INVALID_ID |
INVERSVID | Drawing mode: Inverse video for drawing modes
ISGRTRX |
ISGRTRY |
ISLESSX |
ISLESSY |
JAM1 | Drawing mode: Jam 1 color into raster
JAM2 | Drawing mode: Jam 2 colors into raster
LACE |
LBM_BaseAddress
LBM_BytesPerRow
LBM_IsOnBoard
LBM_PixelFormat
LBM_PlanarYUVInfo
LBM_TagBase
LEFTHIT | Bit Description for SetCollision
LEVELS
LORESDPF2_KEY |
LORESDPF_KEY |
LORESEHBSDBL_KEY |
LORESHAMSDBL_KEY |
LORESLACEDPF2_KEY |
LORESLACEDPF_KEY |
LORESLACE_KEY |
LORESSDBL_KEY |
LORES_KEY |
LPEN_SWAP_FRAMES
MAXFONTMATCHWEIGHT |
MCOMPAT_MIXED | Monitor compatibility for TMonitorInfo.Compatibility Can share display with other MCOMPAT_MIXED
MCOMPAT_NOBODY | Monitor compatibility for TMonitorInfo.Compatibility Only one viewport at a time
MCOMPAT_SELF | Monitor compatibility for TMonitorInfo.Compatibility Can share only within same monitor
MCOP_NOP | MrgCop() Error code: Can not merge any copper lists (eg, no ViewPorts in the list, or all marked as hidden).
MCOP_NO_MEM | MrgCop() Error code: insufficient memory to allocate the system copper lists.
MCOP_OK | MrgCop() Error code: No Error
MINTERM_ABC
MINTERM_ABNC
MINTERM_ANBC
MINTERM_ANBNC
MINTERM_A_OR_B
MINTERM_A_OR_C
MINTERM_A_TO_D
MINTERM_A_XOR_C
MINTERM_B_EQUALS_C
MINTERM_B_OR_C
MINTERM_NABC
MINTERM_NABNC
MINTERM_NANBC
MINTERM_NANBNC
MINTERM_NOTSRCMASK
MINTERM_SRCMASK
MIN_NTSC_ROW |
MIN_PAL_ROW |
MIN_VGA70_ROW |
MIN_VGA_ROW |
MODE_640 |
MONITOR_ID_MASK |
MONITOR_SPEC_TYPE | TExtendedNode.xln_Subsystem
MSB_DOUBLE_SPRITES | Flag bit for TMonitorSpec.ms_Flags>
MSB_REQUEST_A2024 | Flag bit for TMonitorSpec.ms_Flags>
MSB_REQUEST_NTSC | Flag bit for TMonitorSpec.ms_Flags
MSB_REQUEST_PAL | Flag bit for TMonitorSpec.ms_Flags>
MSB_REQUEST_SPECIAL | Flag bit for TMonitorSpec.ms_Flags>
MSF_DOUBLE_SPRITES | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_A2024 | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_NTSC | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_PAL | Flag value for TMonitorSpec.ms_Flags>
MSF_REQUEST_SPECIAL | Flag value for TMonitorSpec.ms_Flags>
MUSTDRAW | User Set flag for TVsprite.Flags. Set if VSprite absolutely must be drawn
MVP_NO_DISPLAY | MakeVPort() Error code: BitMap data is misaligned for this viewport's mode and depth - see AllocBitMap()
MVP_NO_DSPINS | MakeVPort() Error code: insufficient memory for intermidiate copper instructions.
MVP_NO_MEM | MakeVPort() Error code: insufficient memory for intermediate workspace
MVP_NO_VPE | MakeVPort() Error code: ViewPort does not have a ViewPortExtra, and insufficient memory to allocate a temporary one.
MVP_OFF_BOTTOM | MakeVPort() Error code: PRIVATE - you will never see this.
MVP_OK | MakeVPort() Error code: No Error
NML_CAS | Memory Type
NOCROSSFILL | Areafills have no crossovers only used for bobs
NTSC | Flag for TGfxBase.DisplayFlags Default mode is NTSC
NTSC_MONITOR_ID |
NTSC_MONITOR_NAME |
OBP_FailIfBad | Tag for ObtainBestPenA() If True and Precision is PRECISION_EXACT and no exact color can be found or allocated the function will fail.
OBP_Precision | Tag for ObtainBestPenA() Set the pen precision (PRECISION_*)
ONE_DOT | Use one dot mode for drawing lines
OUTSTEP | Bob System Flag for TBob.Flags For double-clearing if double-buffer
OVERLAY | User Set flag for TVsprite.Flags. Set to mask image of Bob onto background
PAL | Flag for TGfxBase.DisplayFlags Default mode is PAL
PAL_MONITOR_ID |
PAL_MONITOR_NAME |
PENB_EXCLUSIVE | Flag bit for ObtainPen()
PENB_NO_SETCOLOR | Flag bit for ObtainPen()
PENF_EXCLUSIVE | Flag value for ObtainPen()
PENF_NO_SETCOLOR | Flag value for ObtainPen()
PEN_EXCLUSIVE | Obsolete name for PENF_EXCLUSIVE
PEN_NO_SETCOLOR | Obsolete name for PENF_NO_SETCOLOR
PF2PRI |
PFA_FINE_SCROLL |
PFBA |
PFB_FINE_SCROLL_SHIFT |
PF_FINE_SCROLL_MASK |
PIXF_A8B8G8R8
PIXF_A8R8G8B8
PIXF_ALPHA8
PIXF_B5G5R5PC
PIXF_B5G6R5PC
PIXF_B8G8R8
PIXF_B8G8R8A8
PIXF_CLUT
PIXF_NONE
PIXF_R5G5B5
PIXF_R5G5B5PC
PIXF_R5G6B5
PIXF_R5G6B5PC
PIXF_R8G8B8
PIXF_R8G8B8A8
PIXF_YUV410P
PIXF_YUV411
PIXF_YUV420P
PIXF_YUV422
PIXF_YUV422CGX
PIXF_YUV422PA
PIXF_YUV422PC
PLNCNTMSK |
PLNCNTSHFT |
PRECISION_EXACT | Precision value for ObtainBestPenA()
PRECISION_GUI | Precision value for ObtainBestPenA()
PRECISION_ICON | Precision value for ObtainBestPenA()
PRECISION_IMAGE | Precision value for ObtainBestPenA()
PRESERVE_COLORS | Flag for CoerceMode Ensure that the mode coerced to can display just as many colours as the ViewPort being coerced.
PROTO_MONITOR_ID |
QBOWNER
QBOWNERn
RATIO_FIXEDPART |
RATIO_UNITY |
REALLY_PAL
REQUEST_A2024 |
REQUEST_NTSC |
REQUEST_PAL |
REQUEST_SPECIAL |
RIGHTHIT | Bit Description for SetCollision
RINGTRIGGER | Define for the animation procedures
RPF_FG_BLEND
RPF_REMAP_COLORFONTS
RPF_USE_BGCOLOR
RPF_USE_FGCOLOR
RPF_USE_OCOLOR
RPTAG_APen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set apen
RPTAG_APenColor
RPTAG_BitMap
RPTAG_BPen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set bpen
RPTAG_BPenColor
RPTAG_DrawBounds | Tag for GetRPAttrsA() Get rastport draw bounds. pass PRectangle
RPTAG_DrMd | Tag for GetRPAttrsA(), SetRPAttrsA() get/set draw mode
RPTAG_Font | Tag for GetRPAttrsA(), SetRPAttrsA() get/set font
RPTAG_MaxPen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set maxpen
RPTAG_OPen
RPTAG_OPenColor
RPTAG_OutlinePen | Tag for GetRPAttrsA(), SetRPAttrsA() get/set outline pen.
RPTAG_OutlinePenColor
RPTAG_RemapColorFonts
RPTAG_WriteMask | Tag for GetRPAttrsA(), SetRPAttrsA() get/set WriteMask
RPTAG_XPos
RPTAG_YPos
SAVEBACK | User Set flag for TVsprite.Flags. Set if background is to be saved/restored
SAVEBOB | Bob User Flag for TBob.Flags set to not erase Bob
SAVEPRESERVE | Bob System Flag for TBob.Flags For back-restore during double-buffer
SETCHIPREV_A | Pass to SetChipRev()
SETCHIPREV_AA | Pass to SetChipRev()
SETCHIPREV_BEST | Pass to SetChipRev()
SETCHIPREV_ECS | Pass to SetChipRev()
SHAPEHOOKACTION_CHANGELAYERSHAPE
SHAPEHOOKACTION_CREATELAYER
SHAPEHOOKACTION_DELETELAYER
SHAPEHOOKACTION_GETHOOKACTIONS
SHAPEHOOKACTION_MOVELAYER
SHAPEHOOKACTION_MOVESIZELAYER
SHAPEHOOKACTION_SIZELAYER
SPECIAL_MONITOR_TYPE | TExtendedNode.xln_Subsystem
SPRITEA_Attached | Tag for AllocSpriteDataA()
SPRITEA_OldDataFormat | Tag for AllocSpriteDataA() must pass in outputheight if using this tag
SPRITEA_OutputHeight | Tag for AllocSpriteDataA() height of Sprite
SPRITEA_Width | Tag for AllocSpriteDataA() Width of Sprite Default - 16
SPRITEA_XReplication | Tag for AllocSpriteDataA() Controls the horizontal pixel replication factor used when converting the bitmap data. Default - 0
SPRITEA_YReplication | Tag for AllocSpriteDataA() Controls the vertical pixel replication factor used when converting the bitmap data. Default - 0
SPRITERESN_140NS | Resolution for TColorMap.SpriteResolution
SPRITERESN_35NS | Resolution for TColorMap.SpriteResolution
SPRITERESN_70NS | Resolution for TColorMap.SpriteResolution
SPRITERESN_DEFAULT | Resolution for TColorMap.SpriteResolution
SPRITERESN_ECS | Resolution for TColorMap.SpriteResolution
SPRITES |
SPRITE_ATTACHED |
SS_GRAPHICS | TExtendedNode.xln_Subtype
STANDARD_COLORCLOCKS |
STANDARD_DENISE_MAX |
STANDARD_DENISE_MIN |
STANDARD_HBSTOP |
STANDARD_HBSTRT |
STANDARD_HSSTOP |
STANDARD_HSSTRT |
STANDARD_MONITOR_MASK |
STANDARD_NTSC_BEAMCON |
STANDARD_NTSC_ROWS |
STANDARD_PAL_BEAMCON |
STANDARD_PAL_ROWS |
STANDARD_VBSTOP |
STANDARD_VBSTRT |
STANDARD_VIEW_X |
STANDARD_VIEW_Y |
STANDARD_VSSTOP |
STANDARD_VSSTRT |
STANDARD_XOFFSET |
STANDARD_YOFFSET |
SUPER72HIRESDBL_KEY |
SUPER72HIRESEHBDBL_KEY |
SUPER72HIRESHAMDBL_KEY |
SUPER72LORESDBL_KEY |
SUPER72LORESEHBDBL_KEY |
SUPER72LORESHAMDBL_KEY |
SUPER72SUPERDBL_KEY |
SUPER72SUPEREHBDBL_KEY |
SUPER72SUPERHAMDBL_KEY |
SUPER72_MONITOR_ID |
SUPERDPF2_KEY |
SUPERDPF_KEY |
SUPEREHBLACE_KEY |
SUPEREHB_KEY |
SUPERHAMLACE_KEY |
SUPERHAM_KEY |
SUPERHIRES |
SUPERLACEDPF2_KEY |
SUPERLACEDPF_KEY |
SUPERLACE_KEY |
SUPER_KEY |
SUSERFLAGS | Mask of all user-settable TVsprite.Flags
TA_CharSet
TA_DeviceDPI | Tag for TTTextAttr.tta_Tags
TA_Rebuild
TE0B_NOREMFONT | Flag bit TTextFontExtension.tfe_Flags0 disallow RemFont for this font
TE0F_NOREMFONT | Flag value TTextFontExtension.tfe_Flags0 disallow RemFont for this font
TE1F_GENFONT
TE1F_NOANTIALIASING
TE1F_NODEEMBOLDENING
TE1F_NODESHEARING
TE1F_NODEUNDERLINING
TE1F_NOEMBOLDENING
TE1F_NOSHEARING
TE1F_NOUNDERLINING
TODA_SAFE | Flag for TGfxBase.DisplayFlags
TOPHIT | Bit Description for SetCollision
TO_MONITOR |
USER_COPPER_CLIP | Flag value for TColorMap.Flags
VC_DPMSLevel
VC_DUALPF_Disable | Tag for VideoControl() When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Default = False.
VC_DUALPF_Disable_Query | Tag for VideoControl()
VC_IntermediateCLUpdate | Tag for VideoControl() When set graphics will update the intermediate copper lists on color changes, etc. When False, it won't, and will be faster. default = True.
VC_IntermediateCLUpdate_Query | Tag for VideoControl() Get if intermediate copper is activated
VC_NoColorPaletteLoad | Tag for VideoControl() When set, graphics will only load color 0 for this View Port default = False.
VC_NoColorPaletteLoad_Query | Tag for VideoControl() Get if only color 0 will be set for this viewport.
VGA70_COLORCLOCKS |
VGA70_DENISE_MIN |
VGA70_HBSTOP |
VGA70_HBSTRT |
VGA70_HSSTOP |
VGA70_HSSTRT |
VGA70_MONITOR_NAME |
VGA70_TOTAL_ROWS |
VGA70_VBSTOP |
VGA70_VBSTRT |
VGA70_VSSTOP |
VGA70_VSSTRT |
VGAEHBLACE_KEY |
VGAEHB_KEY |
VGAEXTRAHALFBRITELACE_KEY |
VGAEXTRAHALFBRITE_KEY |
VGAEXTRALORESDBL_KEY |
VGAEXTRALORESDPF2_KEY |
VGAEXTRALORESDPF_KEY |
VGAEXTRALORESEHBDBL_KEY |
VGAEXTRALORESEHBLACE_KEY |
VGAEXTRALORESEHB_KEY |
VGAEXTRALORESHAMDBL_KEY |
VGAEXTRALORESHAMLACE_KEY |
VGAEXTRALORESHAM_KEY |
VGAEXTRALORESLACEDPF2_KEY |
VGAEXTRALORESLACEDPF_KEY |
VGAEXTRALORESLACE_KEY |
VGAEXTRALORES_KEY |
VGAHAMLACE_KEY |
VGAHAM_KEY |
VGALORESDBL_KEY |
VGALORESDPF2_KEY |
VGALORESDPF_KEY |
VGALORESEHBDBL_KEY |
VGALORESEHBLACE_KEY |
VGALORESEHB_KEY |
VGALORESHAMDBL_KEY |
VGALORESHAMLACE_KEY |
VGALORESHAM_KEY |
VGALORESLACEDPF2_KEY |
VGALORESLACEDPF_KEY |
VGALORESLACE_KEY |
VGALORES_KEY |
VGAPRODUCTDBL_KEY |
VGAPRODUCTDPF2_KEY |
VGAPRODUCTDPF_KEY |
VGAPRODUCTEHBDBL_KEY |
VGAPRODUCTHAMDBL_KEY |
VGAPRODUCTHAMLACE_KEY |
VGAPRODUCTHAM_KEY |
VGAPRODUCTLACEDPF2_KEY |
VGAPRODUCTLACEDPF_KEY |
VGAPRODUCTLACE_KEY |
VGAPRODUCT_KEY |
VGA_COLORCLOCKS |
VGA_DENISE_MIN |
VGA_HBSTOP |
VGA_HBSTRT |
VGA_HSSTOP |
VGA_HSSTRT |
VGA_MONITOR_ID |
VGA_MONITOR_NAME |
VGA_TOTAL_ROWS |
VGA_VBSTOP |
VGA_VBSTRT |
VGA_VSSTOP |
VGA_VSSTRT |
VIDEOCONTROL_BATCH | Flag value for TColorMap.Flags
VIEWPORT_EXTRA_TYPE | TExtendedNode.xln_Subsystem
VIEW_EXTRA_TYPE | TExtendedNode.xln_Subsystem
VPF_A2024 |
VPF_AGNUS |
VPF_TENHZ |
VPOSRLOF |
VPXB_FREE_ME
VPXB_LAST
VPXB_STRADDLES_256
VPXB_STRADDLES_512
VPXF_FREE_ME
VPXF_LAST
VPXF_STRADDLES_256
VPXF_STRADDLES_512
VP_HIDE |
VSOVERFLOW | System Set flag for TVsprite.Flags. VSprite overflow (if MUSTDRAW set we draw!)
VSPRITE_f |
VTAG_ATTACH_CM_GET | Tag for VideoControl()
VTAG_ATTACH_CM_SET | Tag for VideoControl()
VTAG_BATCH_CM_CLR | Tag for VideoControl()
VTAG_BATCH_CM_GET | Tag for VideoControl()
VTAG_BATCH_CM_SET | Tag for VideoControl()
VTAG_BATCH_ITEMS_ADD | Tag for VideoControl()
VTAG_BATCH_ITEMS_GET | Tag for VideoControl()
VTAG_BATCH_ITEMS_SET | Tag for VideoControl()
VTAG_BITPLANEKEY_CLR | Tag for VideoControl()
VTAG_BITPLANEKEY_GET | Tag for VideoControl()
VTAG_BITPLANEKEY_SET | Tag for VideoControl()
VTAG_BORDERBLANK_CLR | Tag for VideoControl()
VTAG_BORDERBLANK_GET | Tag for VideoControl()
VTAG_BORDERBLANK_SET | Tag for VideoControl()
VTAG_BORDERNOTRANS_CLR | Tag for VideoControl()
VTAG_BORDERNOTRANS_GET | Tag for VideoControl()
VTAG_BORDERNOTRANS_SET | Tag for VideoControl()
VTAG_BORDERSPRITE_CLR | Tag for VideoControl()
VTAG_BORDERSPRITE_GET | Tag for VideoControl()
VTAG_BORDERSPRITE_SET | Tag for VideoControl()
VTAG_CHROMAKEY_CLR | Tag for VideoControl()
VTAG_CHROMAKEY_GET | Tag for VideoControl()
VTAG_CHROMAKEY_SET | Tag for VideoControl()
VTAG_CHROMA_PEN_CLR | Tag for VideoControl()
VTAG_CHROMA_PEN_GET | Tag for VideoControl()
VTAG_CHROMA_PEN_SET | Tag for VideoControl()
VTAG_CHROMA_PLANE_GET | Tag for VideoControl()
VTAG_CHROMA_PLANE_SET | Tag for VideoControl()
VTAG_COERCE_DISP_GET | Tag for VideoControl()
VTAG_COERCE_DISP_SET | Tag for VideoControl()
VTAG_DEFSPRITERESN_GET | Tag for VideoControl()
VTAG_DEFSPRITERESN_SET | Tag for VideoControl()
VTAG_END_CM | Tag for VideoControl()
VTAG_FULLPALETTE_CLR | Tag for VideoControl()
VTAG_FULLPALETTE_GET | Tag for VideoControl()
VTAG_FULLPALETTE_SET | Tag for VideoControl()
VTAG_IMMEDIATE | Tag for VideoControl()
VTAG_NEXTBUF_CM | Tag for VideoControl()
VTAG_NORMAL_DISP_GET | Tag for VideoControl()
VTAG_NORMAL_DISP_SET | Tag for VideoControl()
VTAG_PF1_BASE_GET | Tag for VideoControl()
VTAG_PF1_BASE_SET | Tag for VideoControl()
VTAG_PF1_TO_SPRITEPRI_GET | Tag for VideoControl()
VTAG_PF1_TO_SPRITEPRI_SET | Tag for VideoControl()
VTAG_PF2_BASE_GET | Tag for VideoControl()
VTAG_PF2_BASE_SET | Tag for VideoControl()
VTAG_PF2_TO_SPRITEPRI_GET | Tag for VideoControl()
VTAG_PF2_TO_SPRITEPRI_SET | Tag for VideoControl()
VTAG_SPEVEN_BASE_GET | Tag for VideoControl()
VTAG_SPEVEN_BASE_SET | Tag for VideoControl()
VTAG_SPODD_BASE_GET | Tag for VideoControl()
VTAG_SPODD_BASE_SET | Tag for VideoControl()
VTAG_SPRITERESN_GET | Tag for VideoControl()
VTAG_SPRITERESN_SET | Tag for VideoControl()
VTAG_USERCLIP_CLR | Tag for VideoControl()
VTAG_USERCLIP_GET | Tag for VideoControl()
VTAG_USERCLIP_SET | Tag for VideoControl()
VTAG_VIEWPORTEXTRA_GET | Tag for VideoControl()
VTAG_VIEWPORTEXTRA_SET | Tag for VideoControl()
VTAG_VPMODEID_CLR | Tag for VideoControl()
VTAG_VPMODEID_GET | Tag for VideoControl()
VTAG_VPMODEID_SET | Tag for VideoControl()


Reference for unit 'agraphics': Types

SmallInt |
SmallInt |
CollTable |
DisplayInfoHandle | The "public" handle to a DisplayInfoRecord
PAATextFont
PAlphaHookMsg
PAnalogSignalInterval |
PAnimComp | Pointer to an animation
PAnimOb | Pointer to an animation object
PAreaInfo |
PBitMap | Pointer to a bitmap in memory, properties and data.
PBitScaleArgs | Pointer to BitScaleArgs structure used by BitMapScale()
Pointer
PBob | Pointer to an Blitter object structure
PClipRect | Pointer to a clip rectange
PCollTable | Pointer to a structure to contain the 16 collision procedure addresses
PColorFontColors |
PColorMap |
PColorTextFont | Pointer to color Text font
PCopInit |
PCopIns |
PCopList |
PCprList | Structure of cprlist that points to list that hardware actually executes
PDBufInfo | Pointer to a double buffer structure
PDBufPacket | Defines the values needed to be saved across buffer to buffer when in double-buffer mode
PDimensionInfo | Pointer to monitor dimensions
PDisplayInfo | Pointer to informations about the display
PExtendedNode |
PExtSprite | Pointer to an extended sprite Structure
PGelsInfo |
PGfxBase | Graphics Library Base pointer
PIsrvstr |
PLayer | Pointer to a layer structure
PMonitorInfo | Pointer to Monitor informations
PMonitorSpec |
PNameInfo | Pointer to Monitor name structure
PPaletteExtra | Structure controlling palette sharing
PPAnimOb |
PPlanarYUVInfo
PPoint | Pointer to an x,y defined point.
PQueryHeader | Header for TDisplayInfo
PRasInfo | Used in TViewPort
PRastPort | Basic structure for all drawing actions
PRastPortExtra
PRect32 | Pointer to Rectangle (Integer size Values)
PRectangle | Pointer to Rectangle (Word size values)
PRegion |
PRegionRectangle |
PShapeHookMsg
PSimpleSprite | Pointer to a simple sprite description
PSpecialMonitor |
PTextAttr | TextAttr node, matches text attributes in TRastPort
PTextExtent | Pointer to a measured text size
PTextFont |
PTextFontExtension |
PTmpRas | Temporary rast port
PTTextAttr | Extended TextAttr node, matches text attributes in TRastPort
PUCopList |
PVecInfo | This structure is PRIVATE, for our use only Touch these, and burn!
PVecTable
PView |
PViewExtra | Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree
PViewPort |
PViewPortExtra | Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()
PVSprite | Pointer to Sprite structure
TAATextFont
TAlphaHookMsg
TAnalogSignalInterval |
TAnimComp |
TAnimOb |
TAreaInfo |
TBitMap | Represents an image in ram.
TBitScaleArgs | BitScaleArgs structure used by BitMapScale()
TBob | Blitter object
TClipRect | Clip rectangle
TColorFontColors |
TColorMap | This structure is the primary storage for palette data.
TColorTextFont | Color font structure
TCopInit |
TCopIns | Copper structure
TCopList |
TCprList | Structure of cprlist that points to list that hardware actually executes
TDBufInfo | Double buffer structure
tDBufPacket | Defines the values needed to be saved across buffer to buffer when in double-buffer mode
TDimensionInfo | Monitor dimensions (like overscan)
TDisplayInfo | Structure to hold informations about Display.
TExtendedNode |
TExtSprite | Extended sprite Structure
TGelsInfo |
TGfxBase | Graphics library structure
TIsrvstr |
TLayer | Layer Structure
TMonitorInfo | Monitor Informations structure
TMonitorSpec |
TNameInfo | Name of the Display
TPaletteExtra | Structure controlling palette sharing
LongWord
TPlanarYUVInfo
PByte | Pointer to Bitplane coded image data, can be created with AllocRaster
TPoint | Basic definition of a point (x,y)
TQueryHeader | Header for TDisplayInfo
TRasInfo | Used in TViewPort
TRastPort | Basic structure for all drawing actions
TRastPortExtra
TRect32 | Basic struct for defining a rectengular region with integer values
TRectangle | Basic struct for defining a rectengular region with word values
tRegion |
TRegionRectangle |
TShapeHookMsg
TSimpleSprite | Sprite description structure
TSpecialMonitor |
TTextAttr | TextAttr node, matches text attributes in TRastPort
TTextExtent | A measured text size
TTextFont |
TTextFontExtension | Extended font description
TTmpRas | Temporary rast port
TTTextAttr | Extended TextAttr node, matches text attributes in TRastPort
TUCopList |
TVecInfo | This structure is PRIVATE, for our use only Touch these, and burn!
TVecTable
TView |
TViewExtra | Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree
TViewPort | Describes a displayed bitmap (or logical screen). Copperlists are relevant only to Amiga(tm) chipset, for other hardware they are nil.
tViewPortExtra | Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()
TVSprite | Sprite description
SmallInt |


INPUTTYPE_DVI

Declaration

Source position: agraphics.pas line 1078

const INPUTTYPE_DVI = 1;


INPUTTYPE_VGA

Declaration

Source position: agraphics.pas line 1077

const INPUTTYPE_VGA = 0;


INTERLACE

Declaration

Source position: agraphics.pas line 1777

const INTERLACE = 4;


INVALID_ID

Declaration

Source position: agraphics.pas line 1476

const INVALID_ID = not 0;


INVERSVID

Drawing mode: Inverse video for drawing modes

Declaration

Source position: agraphics.pas line 359

const INVERSVID = 4;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


ISGRTRX

Declaration

Source position: agraphics.pas line 287

const ISGRTRX = 4;


ISGRTRY

Declaration

Source position: agraphics.pas line 288

const ISGRTRY = 8;


ISLESSX

Declaration

Source position: agraphics.pas line 285

const ISLESSX = 1;


ISLESSY

Declaration

Source position: agraphics.pas line 286

const ISLESSY = 2;


JAM1

Drawing mode: Jam 1 color into raster

Declaration

Source position: agraphics.pas line 356

const JAM1 = 0;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


JAM2

Drawing mode: Jam 2 colors into raster

Declaration

Source position: agraphics.pas line 357

const JAM2 = 1;

See also

SetDrMd | Set drawing mode for a RastPort
GetDrMd | Get the draw mode value for a RastPort
TRastPort | Basic structure for all drawing actions


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

LACE

Declaration

Source position: agraphics.pas line 1370

const LACE = $0004;


LBM_BaseAddress

Declaration

Source position: agraphics.pas line 239

const LBM_BaseAddress = LBM_TagBase + 1;


LBM_BytesPerRow

Declaration

Source position: agraphics.pas line 240

const LBM_BytesPerRow = LBM_TagBase + 2;


LBM_IsOnBoard

Declaration

Source position: agraphics.pas line 243

const LBM_IsOnBoard = LBM_TagBase + 5;


LBM_PixelFormat

Declaration

Source position: agraphics.pas line 241

const LBM_PixelFormat = LBM_TagBase + 3;


LBM_PlanarYUVInfo

Declaration

Source position: agraphics.pas line 242

const LBM_PlanarYUVInfo = LBM_TagBase + 4;


LBM_TagBase

Declaration

Source position: agraphics.pas line 238

const LBM_TagBase = TAG_USER;


LEFTHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 926

const LEFTHIT = 4;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

LEVELS

Declaration

Source position: agraphics.pas line 362

const LEVELS = 32;


LORES_KEY

Declaration

Source position: agraphics.pas line 1502

const LORES_KEY = $00000000;


LORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1516

const LORESDPF2_KEY = $00000440;


LORESDPF_KEY

Declaration

Source position: agraphics.pas line 1510

const LORESDPF_KEY = $00000400;


LORESEHBSDBL_KEY

Declaration

Source position: agraphics.pas line 1536

const LORESEHBSDBL_KEY = $00000088;


LORESHAMSDBL_KEY

Declaration

Source position: agraphics.pas line 1535

const LORESHAMSDBL_KEY = $00000808;


LORESLACE_KEY

Declaration

Source position: agraphics.pas line 1506

const LORESLACE_KEY = $00000004;


LORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1519

const LORESLACEDPF2_KEY = $00000444;


LORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1513

const LORESLACEDPF_KEY = $00000404;


LORESSDBL_KEY

Declaration

Source position: agraphics.pas line 1534

const LORESSDBL_KEY = $00000008;


LPEN_SWAP_FRAMES

Declaration

Source position: agraphics.pas line 2245

const LPEN_SWAP_FRAMES = 32;


MAXFONTMATCHWEIGHT

Declaration

Source position: agraphics.pas line 331

const MAXFONTMATCHWEIGHT = 32767;


MCOMPAT_MIXED

Monitor compatibility for TMonitorInfo.Compatibility Can share display with other MCOMPAT_MIXED

Declaration

Source position: agraphics.pas line 1913

const MCOMPAT_MIXED = 0;


MCOMPAT_NOBODY

Monitor compatibility for TMonitorInfo.Compatibility Only one viewport at a time

Declaration

Source position: agraphics.pas line 1915

const MCOMPAT_NOBODY = - 1;


MCOMPAT_SELF

Monitor compatibility for TMonitorInfo.Compatibility Can share only within same monitor

Declaration

Source position: agraphics.pas line 1914

const MCOMPAT_SELF = 1;


MCOP_NO_MEM

MrgCop() Error code: insufficient memory to allocate the system copper lists.

Declaration

Source position: agraphics.pas line 1451

const MCOP_NO_MEM = 1;


MCOP_NOP

MrgCop() Error code: Can not merge any copper lists (eg, no ViewPorts in the list, or all marked as hidden).

Declaration

Source position: agraphics.pas line 1452

const MCOP_NOP = 2;


MCOP_OK

MrgCop() Error code: No Error

Declaration

Source position: agraphics.pas line 1450

const MCOP_OK = 0;


MIN_NTSC_ROW

Declaration

Source position: agraphics.pas line 1188

const MIN_NTSC_ROW = 21;


MIN_PAL_ROW

Declaration

Source position: agraphics.pas line 1189

const MIN_PAL_ROW = 29;


MIN_VGA70_ROW

Declaration

Source position: agraphics.pas line 1220

const MIN_VGA70_ROW = 35;


MIN_VGA_ROW

Declaration

Source position: agraphics.pas line 1204

const MIN_VGA_ROW = 29;


MINTERM_A_OR_B

Declaration

Source position: agraphics.pas line 264

const MINTERM_A_OR_B = MINTERM_ABC or MINTERM_ANBC or MINTERM_NABC or MINTERM_ABNC or MINTERM_ANBNC or MINTERM_NABNC;


MINTERM_A_OR_C

Declaration

Source position: agraphics.pas line 265

const MINTERM_A_OR_C = MINTERM_ABC or MINTERM_NABC or MINTERM_ABNC or MINTERM_ANBC or MINTERM_NANBC or MINTERM_ANBNC;


MINTERM_A_TO_D

Declaration

Source position: agraphics.pas line 267

const MINTERM_A_TO_D = MINTERM_ABC or MINTERM_ANBC or MINTERM_ABNC or MINTERM_ANBNC;


MINTERM_A_XOR_C

Declaration

Source position: agraphics.pas line 266

const MINTERM_A_XOR_C = MINTERM_NABC or MINTERM_ABNC or MINTERM_NANBC or MINTERM_ANBNC;


MINTERM_ABC

Declaration

Source position: agraphics.pas line 247

const MINTERM_ABC = $80;


MINTERM_ABNC

Declaration

Source position: agraphics.pas line 248

const MINTERM_ABNC = $40;


MINTERM_ANBC

Declaration

Source position: agraphics.pas line 249

const MINTERM_ANBC = $20;


MINTERM_ANBNC

Declaration

Source position: agraphics.pas line 250

const MINTERM_ANBNC = $10;


MINTERM_B_EQUALS_C

Declaration

Source position: agraphics.pas line 262

const MINTERM_B_EQUALS_C = MINTERM_ABC or MINTERM_ANBNC or MINTERM_NABC or MINTERM_NANBNC;


MINTERM_B_OR_C

Declaration

Source position: agraphics.pas line 263

const MINTERM_B_OR_C = MINTERM_ABC or MINTERM_ABNC or MINTERM_NABC or MINTERM_NABNC or MINTERM_ANBC or MINTERM_NANBC;


MINTERM_NABC

Declaration

Source position: agraphics.pas line 251

const MINTERM_NABC = $08;


MINTERM_NABNC

Declaration

Source position: agraphics.pas line 252

const MINTERM_NABNC = $04;


MINTERM_NANBC

Declaration

Source position: agraphics.pas line 253

const MINTERM_NANBC = $02;


MINTERM_NANBNC

Declaration

Source position: agraphics.pas line 254

const MINTERM_NANBNC = $01;


MINTERM_NOTSRCMASK

Declaration

Source position: agraphics.pas line 260

const MINTERM_NOTSRCMASK = MINTERM_ANBC;


MINTERM_SRCMASK

Declaration

Source position: agraphics.pas line 258

const MINTERM_SRCMASK = MINTERM_ABC or MINTERM_ABNC or MINTERM_ANBC;


MODE_640

Declaration

Source position: agraphics.pas line 1770

const MODE_640 = $8000;


MONITOR_ID_MASK

Declaration

Source position: agraphics.pas line 1489

const MONITOR_ID_MASK = $FFFF1000;


MONITOR_SPEC_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 1086

const MONITOR_SPEC_TYPE = 4;


MSB_DOUBLE_SPRITES

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1160

const MSB_DOUBLE_SPRITES = 4;


MSB_REQUEST_A2024

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1159

const MSB_REQUEST_A2024 = 3;


MSB_REQUEST_NTSC

Flag bit for TMonitorSpec.ms_Flags

Declaration

Source position: agraphics.pas line 1156

const MSB_REQUEST_NTSC = 0;


MSB_REQUEST_PAL

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1157

const MSB_REQUEST_PAL = 1;


MSB_REQUEST_SPECIAL

Flag bit for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1158

const MSB_REQUEST_SPECIAL = 2;


MSF_DOUBLE_SPRITES

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1165

const MSF_DOUBLE_SPRITES = 1 shl MSB_DOUBLE_SPRITES;


MSF_REQUEST_A2024

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1164

const MSF_REQUEST_A2024 = 1 shl MSB_REQUEST_A2024;


MSF_REQUEST_NTSC

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1161

const MSF_REQUEST_NTSC = 1 shl MSB_REQUEST_NTSC;


MSF_REQUEST_PAL

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1162

const MSF_REQUEST_PAL = 1 shl MSB_REQUEST_PAL;


MSF_REQUEST_SPECIAL

Flag value for TMonitorSpec.ms_Flags>

Declaration

Source position: agraphics.pas line 1163

const MSF_REQUEST_SPECIAL = 1 shl MSB_REQUEST_SPECIAL;


MUSTDRAW

User Set flag for TVsprite.Flags. Set if VSprite absolutely must be drawn

Declaration

Source position: agraphics.pas line 404

const MUSTDRAW = $0008;


MVP_NO_DISPLAY

MakeVPort() Error code: BitMap data is misaligned for this viewport's mode and depth - see AllocBitMap()

Declaration

Source position: agraphics.pas line 1445

const MVP_NO_DISPLAY = 4;


MVP_NO_DSPINS

MakeVPort() Error code: insufficient memory for intermidiate copper instructions.

Declaration

Source position: agraphics.pas line 1444

const MVP_NO_DSPINS = 3;


MVP_NO_MEM

MakeVPort() Error code: insufficient memory for intermediate workspace

Declaration

Source position: agraphics.pas line 1442

const MVP_NO_MEM = 1;


MVP_NO_VPE

MakeVPort() Error code: ViewPort does not have a ViewPortExtra, and insufficient memory to allocate a temporary one.

Declaration

Source position: agraphics.pas line 1443

const MVP_NO_VPE = 2;


MVP_OFF_BOTTOM

MakeVPort() Error code: PRIVATE - you will never see this.

Declaration

Source position: agraphics.pas line 1446

const MVP_OFF_BOTTOM = 5;


MVP_OK

MakeVPort() Error code: No Error

Declaration

Source position: agraphics.pas line 1441

const MVP_OK = 0;


NML_CAS

Memory Type

Declaration

Source position: agraphics.pas line 2276

const NML_CAS = 0;


NOCROSSFILL

Areafills have no crossovers only used for bobs

Declaration

Source position: agraphics.pas line 370

const NOCROSSFILL = $20;

See also

TRastPort

Basic structure for all drawing actions


NTSC

Flag for TGfxBase.DisplayFlags Default mode is NTSC

Declaration

Source position: agraphics.pas line 2239

const NTSC = 1;


NTSC_MONITOR_ID

Declaration

Source position: agraphics.pas line 1491

const NTSC_MONITOR_ID = $00011000;


NTSC_MONITOR_NAME

Declaration

Source position: agraphics.pas line 1174

const NTSC_MONITOR_NAME: PChar = 'ntsc.monitor';


OBP_FailIfBad

Tag for ObtainBestPenA() If True and Precision is PRECISION_EXACT and no exact color can be found or allocated the function will fail.

Declaration

Source position: agraphics.pas line 1435

const OBP_FailIfBad = $84000001;

Description

Specifies that you want ObtainBestPenA() to return a failure value if there is not a color within the given tolerance, instead of returning the closest color. With OBP_FailIfBad = False, ObtainBestPenA() will only fail if the ViewPort contains no sharable colors. Defaults to False.


OBP_Precision

Tag for ObtainBestPenA() Set the pen precision (PRECISION_*)

Declaration

Source position: agraphics.pas line 1434

const OBP_Precision = $84000000;

Description

Specifies the desired precision for the match. Should be PRECISION_GUI, PRECISION_ICON, or PRECISION_IMAGE or PRECISION_EXACT. Defaults to PRECISION_IMAGE.


ONE_DOT

Use one dot mode for drawing lines

Declaration

Source position: agraphics.pas line 366

const ONE_DOT = $02;

See also

TRastPort

Basic structure for all drawing actions


OUTSTEP

Bob System Flag for TBob.Flags For double-clearing if double-buffer

Declaration

Source position: agraphics.pas line 422

const OUTSTEP = $2000;


OVERLAY

User Set flag for TVsprite.Flags. Set to mask image of Bob onto background

Declaration

Source position: agraphics.pas line 403

const OVERLAY = $0004;


PAATextFont

Declaration

Source position: agraphics.pas line 574

type PAATextFont = ^TAATextFont;


PAL

Flag for TGfxBase.DisplayFlags Default mode is PAL

Declaration

Source position: agraphics.pas line 2241

const PAL = 4;


PAL_MONITOR_ID

Declaration

Source position: agraphics.pas line 1492

const PAL_MONITOR_ID = $00021000;


PAL_MONITOR_NAME

Declaration

Source position: agraphics.pas line 1175

const PAL_MONITOR_NAME: PChar = 'pal.monitor';


PAlphaHookMsg

Declaration

Source position: agraphics.pas line 899

type PAlphaHookMsg = ^TAlphaHookMsg;


PAnalogSignalInterval

Declaration

Source position: agraphics.pas line 1099

type PAnalogSignalInterval = ^TAnalogSignalInterval;

See also

TSpecialMonitor


PAnimComp

Pointer to an animation

Declaration

Source position: agraphics.pas line 431

type PAnimComp = ^TAnimComp;


PAnimOb

Pointer to an animation object

Declaration

Source position: agraphics.pas line 434

type PAnimOb = ^TAnimOb;


PAreaInfo

Declaration

Source position: agraphics.pas line 650

type PAreaInfo = ^TAreaInfo;

See also

InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


PBitMap

Pointer to a bitmap in memory, properties and data.

Declaration

Source position: agraphics.pas line 94

type PBitMap = ^TBitMap;

See also

AllocBitmap | Allocate a bitmap and attach bitplanes to it.
FreeBitmap | Free a bitmap created by AllocBitMap()
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
BltBitMap | Move a rectangular region of bits in a BitMap.
BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ChangeVPBitmap | Change display memory address for multi-buffered animation
GetBitMapAttr | Returns information about a bitmap
InitBitMap | Initialize bit map structure with input values.
TRastPort | Basic structure for all drawing actions


PBitScaleArgs

Pointer to BitScaleArgs structure used by BitMapScale()

Declaration

Source position: agraphics.pas line 2073

type PBitScaleArgs = ^TBitScaleArgs;


PBltNode

Declaration

Source position: agraphics.pas line 2118

type PBltNode = Pointer;


PBob

Pointer to an Blitter object structure

Declaration

Source position: agraphics.pas line 430

type PBob = ^TBob;


PClipRect

Pointer to a clip rectange

Declaration

Source position: agraphics.pas line 442

type PClipRect = ^TClipRect;

See also

TLayer

Layer Structure


PCollTable

Pointer to a structure to contain the 16 collision procedure addresses

Declaration

Source position: agraphics.pas line 440

type PCollTable = ^CollTable;

See also

TGelsInfo


PColorFontColors

Declaration

Source position: agraphics.pas line 551

type PColorFontColors = ^TColorFontColors;


PColorMap

Declaration

Source position: agraphics.pas line 1246

type PColorMap = ^TColorMap;


PColorTextFont

Pointer to color Text font

Declaration

Source position: agraphics.pas line 559

type PColorTextFont = ^TColorTextFont;


PCopInit

Declaration

Source position: agraphics.pas line 634

type PCopInit = ^TCopInit;


PCopIns

Declaration

Source position: agraphics.pas line 594

type PCopIns = ^TCopIns;


PCopList

Declaration

Source position: agraphics.pas line 609

type PCopList = ^TCopList;


PCprList

Structure of cprlist that points to list that hardware actually executes

Declaration

Source position: agraphics.pas line 602

type PCprList = ^TCprList;


PDBufInfo

Pointer to a double buffer structure

Declaration

Source position: agraphics.pas line 1455

type PDBufInfo = ^TDBufInfo;

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation
FreeDBufInfo | Free information for multi-buffered animation


PDBufPacket

Defines the values needed to be saved across buffer to buffer when in double-buffer mode

Declaration

Source position: agraphics.pas line 433

type PDBufPacket = ^TDBufPacket;


PDimensionInfo

Pointer to monitor dimensions

Declaration

Source position: agraphics.pas line 1875

type PDimensionInfo = ^TDimensionInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_DIMS | GetDisplayInfoData, results in PDimensionInfo


PDisplayInfo

Pointer to informations about the display

Declaration

Source position: agraphics.pas line 1815

type PDisplayInfo = ^TDisplayInfo;

See also

FindDisplayInfo | Search for a record identified by a specific key
GetDisplayInfoData | Query DisplayInfo Record parameters


PEN_EXCLUSIVE

Obsolete name for PENF_EXCLUSIVE

Declaration

Source position: agraphics.pas line 1426

const PEN_EXCLUSIVE = PENF_EXCLUSIVE;


PEN_NO_SETCOLOR

Obsolete name for PENF_NO_SETCOLOR

Declaration

Source position: agraphics.pas line 1427

const PEN_NO_SETCOLOR = PENF_NO_SETCOLOR;


PENB_EXCLUSIVE

Flag bit for ObtainPen()

Declaration

Source position: agraphics.pas line 1421

const PENB_EXCLUSIVE = 0;


PENB_NO_SETCOLOR

Flag bit for ObtainPen()

Declaration

Source position: agraphics.pas line 1422

const PENB_NO_SETCOLOR = 1;


PENF_EXCLUSIVE

Flag value for ObtainPen()

Declaration

Source position: agraphics.pas line 1423

const PENF_EXCLUSIVE = 1 shl PENB_EXCLUSIVE;


PENF_NO_SETCOLOR

Flag value for ObtainPen()

Declaration

Source position: agraphics.pas line 1424

const PENF_NO_SETCOLOR = 1 shl PENB_NO_SETCOLOR;


PExtendedNode

Declaration

Source position: agraphics.pas line 116

type PExtendedNode = ^TExtendedNode;


PExtSprite

Pointer to an extended sprite Structure

Declaration

Source position: agraphics.pas line 2048

type PExtSprite = ^TExtSprite;

See also

AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
ChangeExtSpriteA | Change the sprite image pointer.
FreeSpriteData | free sprite data allocated by AllocSpriteData()
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.


PF2PRI

Declaration

Source position: agraphics.pas line 1773

const PF2PRI = $40;


PF_FINE_SCROLL_MASK

Declaration

Source position: agraphics.pas line 1782

const PF_FINE_SCROLL_MASK = $F;


PFA_FINE_SCROLL

Declaration

Source position: agraphics.pas line 1780

const PFA_FINE_SCROLL = $F;


PFB_FINE_SCROLL_SHIFT

Declaration

Source position: agraphics.pas line 1781

const PFB_FINE_SCROLL_SHIFT = 4;


Unit 'agraphics' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

PFBA

Declaration

Source position: agraphics.pas line 1372

const PFBA = $0040;


PGelsInfo

Declaration

Source position: agraphics.pas line 669

type PGelsInfo = ^TGelsInfo;

See also

TRastPort | Basic structure for all drawing actions
InitGels | initialize a gel list; must be called before using gels.
SetCollision | Set a pointer to a user collision routine.


PGfxBase

Graphics Library Base pointer

Declaration

Source position: agraphics.pas line 2120

type PGfxBase = ^TGfxBase;


PIsrvstr

Declaration

Source position: agraphics.pas line 1090

type PIsrvstr = ^TIsrvstr;


PIXF_A8B8G8R8

Declaration

Source position: agraphics.pas line 216

const PIXF_A8B8G8R8 = 7;


PIXF_A8R8G8B8

Declaration

Source position: agraphics.pas line 215

const PIXF_A8R8G8B8 = 6;


PIXF_ALPHA8

Declaration

Source position: agraphics.pas line 235

const PIXF_ALPHA8 = 21;


PIXF_B5G5R5PC

Declaration

Source position: agraphics.pas line 222

const PIXF_B5G5R5PC = 13;


PIXF_B5G6R5PC

Declaration

Source position: agraphics.pas line 221

const PIXF_B5G6R5PC = 12;


PIXF_B8G8R8

Declaration

Source position: agraphics.pas line 212

const PIXF_B8G8R8 = 3;


PIXF_B8G8R8A8

Declaration

Source position: agraphics.pas line 218

const PIXF_B8G8R8A8 = 9;


PIXF_CLUT

Declaration

Source position: agraphics.pas line 210

const PIXF_CLUT = 1;


PIXF_NONE

Declaration

Source position: agraphics.pas line 209

const PIXF_NONE = 0;


PIXF_R5G5B5

Declaration

Source position: agraphics.pas line 220

const PIXF_R5G5B5 = 11;


PIXF_R5G5B5PC

Declaration

Source position: agraphics.pas line 214

const PIXF_R5G5B5PC = 5;


PIXF_R5G6B5

Declaration

Source position: agraphics.pas line 219

const PIXF_R5G6B5 = 10;


PIXF_R5G6B5PC

Declaration

Source position: agraphics.pas line 213

const PIXF_R5G6B5PC = 4;


PIXF_R8G8B8

Declaration

Source position: agraphics.pas line 211

const PIXF_R8G8B8 = 2;


PIXF_R8G8B8A8

Declaration

Source position: agraphics.pas line 217

const PIXF_R8G8B8A8 = 8;


PIXF_YUV410P

Declaration

Source position: agraphics.pas line 234

const PIXF_YUV410P = 20;


PIXF_YUV411

Declaration

Source position: agraphics.pas line 226

const PIXF_YUV411 = 15;


PIXF_YUV420P

Declaration

Source position: agraphics.pas line 233

const PIXF_YUV420P = 19;


PIXF_YUV422

Declaration

Source position: agraphics.pas line 229

const PIXF_YUV422 = 17;


PIXF_YUV422CGX

Declaration

Source position: agraphics.pas line 223

const PIXF_YUV422CGX = 14;


PIXF_YUV422PA

Declaration

Source position: agraphics.pas line 228

const PIXF_YUV422PA = 16;


PIXF_YUV422PC

Declaration

Source position: agraphics.pas line 232

const PIXF_YUV422PC = 18;


PLayer

Pointer to a layer structure

Declaration

Source position: agraphics.pas line 436

type PLayer = ^TLayer;

See also

AttemptLockLayerRom | Attempt to Lock Layer structure by ROM(gfx lib) code
UnLockLayerRom | Unlock Layer structure by ROM(gfx lib) code.
LockLayerRom | Lock Layer structure by ROM(gfx lib) code.
CopySBitMap | Syncronize Layer window with contents of Super BitMap
SyncSBitMap | Syncronize Super BitMap with whatever is in the standard Layer bounds.
TRastPort | Basic structure for all drawing actions


PLNCNTMSK

Declaration

Source position: agraphics.pas line 1771

const PLNCNTMSK = $7;


PLNCNTSHFT

Declaration

Source position: agraphics.pas line 1772

const PLNCNTSHFT = 12;


PMonitorInfo

Pointer to Monitor informations

Declaration

Source position: agraphics.pas line 1892

type PMonitorInfo = ^TMonitorInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_MNTR | GetDisplayInfoData, results in PMonitorInfo


PMonitorSpec

Declaration

Source position: agraphics.pas line 1120

type PMonitorSpec = ^TMonitorSpec;


PNameInfo

Pointer to Monitor name structure

Declaration

Source position: agraphics.pas line 1919

type PNameInfo = ^TNameInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_NAME | GetDisplayInfoData, results in PNameInfo


PPaletteExtra

Structure controlling palette sharing

Declaration

Source position: agraphics.pas line 1406

type PPaletteExtra = ^TPaletteExtra;


PPAnimOb

Declaration

Source position: agraphics.pas line 829

type PPAnimOb = ^PAnimOb;


PPlanarYUVInfo

Declaration

Source position: agraphics.pas line 272

type PPlanarYUVInfo = ^TPlanarYUVInfo;


PPoint

Pointer to an x,y defined point.

Declaration

Source position: agraphics.pas line 87

type PPoint = ^TPoint;


PQueryHeader

Header for TDisplayInfo

Declaration

Source position: agraphics.pas line 1807

type PQueryHeader = ^TQueryHeader;


PRasInfo

Used in TViewPort

Declaration

Source position: agraphics.pas line 1248

type PRasInfo = ^TRasInfo;


PRastPort

Basic structure for all drawing actions

Declaration

Source position: agraphics.pas line 435

type PRastPort = ^TRastPort;

See also

BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
BltPattern | Using standard drawing rules for areafill, blit through a mask.
ClearEOL | Clear from current position to end of line.
ClearScreen | Clear from current position to end of RastPort.
ClipBlit | Calls BltBitMap() after accounting for windows
Draw | Draw a line between the current pen position and the new x,y position.
DrawEllipse | Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.
EraseRect | Fill a defined rectangular area using the current BackFill hook.
Flood | Flood rastport like areafill.
GfxMove | Move graphics pen position.
InitRastPort | Initialize raster port structure
PolyDraw | Draw lines from table of (x,y) values.
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
WritePixel | Change the pen num of one specific pixel in a specified RastPort.
GfxText | Write text characters (no formatting).


PRastPortExtra

Declaration

Source position: agraphics.pas line 728

type PRastPortExtra = ^TRastPortExtra;


PRECISION_EXACT

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1429

const PRECISION_EXACT = - 1;


PRECISION_GUI

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1432

const PRECISION_GUI = 32;


PRECISION_ICON

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1431

const PRECISION_ICON = 16;


PRECISION_IMAGE

Precision value for ObtainBestPenA()

Declaration

Source position: agraphics.pas line 1430

const PRECISION_IMAGE = 0;


PRect32

Pointer to Rectangle (Integer size Values)

Declaration

Source position: agraphics.pas line 81

type PRect32 = ^TRect32;


PRectangle

Pointer to Rectangle (Word size values)

Declaration

Source position: agraphics.pas line 75

type PRectangle = ^TRectangle;

See also

AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
ClearRectRegion
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
TRegionRectangle |
TClipRect | Clip rectangle
TLayer | Layer Structure
TTextExtent | A measured text size


PRegion

Declaration

Source position: agraphics.pas line 110

type PRegion = ^tRegion;


PRegionRectangle

Declaration

Source position: agraphics.pas line 104

type PRegionRectangle = ^TRegionRectangle;


PRESERVE_COLORS

Flag for CoerceMode Ensure that the mode coerced to can display just as many colours as the ViewPort being coerced.

Declaration

Source position: agraphics.pas line 392

const PRESERVE_COLORS = 1;


PROTO_MONITOR_ID

Declaration

Source position: agraphics.pas line 1591

const PROTO_MONITOR_ID = $00051000;


PShapeHookMsg

Declaration

Source position: agraphics.pas line 881

type PShapeHookMsg = ^TShapeHookMsg;


PSimpleSprite

Pointer to a simple sprite description

Declaration

Source position: agraphics.pas line 2040

type PSimpleSprite = ^TSimpleSprite;

See also

ChangeSprite | Change the sprite image pointer.
GetSprite | Attempt to get a sprite for the simple sprite manager.
MoveSprite | Move sprite to a point relative to top of viewport.


PSpecialMonitor

Declaration

Source position: agraphics.pas line 1105

type PSpecialMonitor = ^TSpecialMonitor;


PTextAttr

TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 493

type PTextAttr = ^TTextAttr;

See also

SetFont | Set the text font and attributes in a RastPort.
OpenFont | Get a pointer to a system font.
StripFont | Remove the TextFontExtension from a font
OpenDiskFont |


PTextExtent

Pointer to a measured text size

Declaration

Source position: agraphics.pas line 587

type PTextExtent = ^TTextExtent;

See also

FontExtent | Get the font attributes of the current font
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent


PTextFont

Declaration

Source position: agraphics.pas line 512

type PTextFont = ^TTextFont;


PTextFontExtension

Declaration

Source position: agraphics.pas line 536

type PTextFontExtension = ^TTextFontExtension;


PTmpRas

Temporary rast port

Declaration

Source position: agraphics.pas line 662

type PTmpRas = ^TTmpRas;

See also

InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.
InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


PTTextAttr

Extended TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 501

type PTTextAttr = ^TTTextAttr;


PUCopList

Declaration

Source position: agraphics.pas line 625

type PUCopList = ^TUCopList;


PVecInfo

This structure is PRIVATE, for our use only Touch these, and burn!

Declaration

Source position: agraphics.pas line 1931

type PVecInfo = ^TVecInfo;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_VEC | GetDisplayInfoData, Internal use only (PVecInfo)


PVecTable

Declaration

Source position: agraphics.pas line 1291

type PVecTable = ^TVecTable;


PView

Declaration

Source position: agraphics.pas line 1256

type PView = ^TView;


PViewExtra

Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree

Declaration

Source position: agraphics.pas line 1267

type PViewExtra = ^TViewExtra;


PViewPort

Declaration

Source position: agraphics.pas line 1247

type PViewPort = ^TViewPort;


PViewPortExtra

Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()

Declaration

Source position: agraphics.pas line 1296

type PViewPortExtra = ^tViewPortExtra;


PVSprite

Pointer to Sprite structure

Declaration

Source position: agraphics.pas line 432

type PVSprite = ^TVSprite;


QBOWNER

Declaration

Source position: agraphics.pas line 2250

const QBOWNER = 1 shl QBOWNERn;


QBOWNERn

Declaration

Source position: agraphics.pas line 2248

const QBOWNERn = 1;


RATIO_FIXEDPART

Declaration

Source position: agraphics.pas line 1242

const RATIO_FIXEDPART = 4;


RATIO_UNITY

Declaration

Source position: agraphics.pas line 1243

const RATIO_UNITY = 1 shl RATIO_FIXEDPART;


REALLY_PAL

Declaration

Source position: agraphics.pas line 2243

const REALLY_PAL = 16;


REQUEST_A2024

Declaration

Source position: agraphics.pas line 1171

const REQUEST_A2024 = 1 shl MSB_REQUEST_A2024;


REQUEST_NTSC

Declaration

Source position: agraphics.pas line 1168

const REQUEST_NTSC = 1 shl MSB_REQUEST_NTSC;


REQUEST_PAL

Declaration

Source position: agraphics.pas line 1169

const REQUEST_PAL = 1 shl MSB_REQUEST_PAL;


REQUEST_SPECIAL

Declaration

Source position: agraphics.pas line 1170

const REQUEST_SPECIAL = 1 shl MSB_REQUEST_SPECIAL;


RIGHTHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 927

const RIGHTHIT = 8;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


RINGTRIGGER

Define for the animation procedures

Declaration

Source position: agraphics.pas line 427

const RINGTRIGGER = $0001;


RPF_FG_BLEND

Declaration

Source position: agraphics.pas line 375

const RPF_FG_BLEND = $800;


RPF_REMAP_COLORFONTS

Declaration

Source position: agraphics.pas line 376

const RPF_REMAP_COLORFONTS = $2000;


RPF_USE_BGCOLOR

Declaration

Source position: agraphics.pas line 373

const RPF_USE_BGCOLOR = $100;


RPF_USE_FGCOLOR

Declaration

Source position: agraphics.pas line 372

const RPF_USE_FGCOLOR = $80;


RPF_USE_OCOLOR

Declaration

Source position: agraphics.pas line 374

const RPF_USE_OCOLOR = $200;


RPTAG_APen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set apen

Declaration

Source position: agraphics.pas line 2098

const RPTAG_APen = $80000002;


RPTAG_APenColor

Declaration

Source position: agraphics.pas line 2107

const RPTAG_APenColor = $80000009;


RPTAG_BitMap

Declaration

Source position: agraphics.pas line 2112

const RPTAG_BitMap = $8000000D;


RPTAG_BPen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set bpen

Declaration

Source position: agraphics.pas line 2099

const RPTAG_BPen = $80000003;


RPTAG_BPenColor

Declaration

Source position: agraphics.pas line 2108

const RPTAG_BPenColor = $8000000A;


RPTAG_DrawBounds

Tag for GetRPAttrsA() Get rastport draw bounds. pass PRectangle

Declaration

Source position: agraphics.pas line 2105

const RPTAG_DrawBounds = $80000008;


RPTAG_DrMd

Tag for GetRPAttrsA(), SetRPAttrsA() get/set draw mode

Declaration

Source position: agraphics.pas line 2100

const RPTAG_DrMd = $80000004;


RPTAG_Font

Tag for GetRPAttrsA(), SetRPAttrsA() get/set font

Declaration

Source position: agraphics.pas line 2097

const RPTAG_Font = $80000000;


RPTAG_MaxPen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set maxpen

Declaration

Source position: agraphics.pas line 2104

const RPTAG_MaxPen = $80000007;


RPTAG_OPen

Declaration

Source position: agraphics.pas line 2102

const RPTAG_OPen = $80000005;


RPTAG_OPenColor

Declaration

Source position: agraphics.pas line 2109

const RPTAG_OPenColor = $8000000B;


RPTAG_OutlinePen

Tag for GetRPAttrsA(), SetRPAttrsA() get/set outline pen.

Declaration

Source position: agraphics.pas line 2101

const RPTAG_OutlinePen = $80000005;


RPTAG_OutlinePenColor

Declaration

Source position: agraphics.pas line 2110

const RPTAG_OutlinePenColor = $8000000B;


RPTAG_RemapColorFonts

Declaration

Source position: agraphics.pas line 2111

const RPTAG_RemapColorFonts = $8000000C;


RPTAG_WriteMask

Tag for GetRPAttrsA(), SetRPAttrsA() get/set WriteMask

Declaration

Source position: agraphics.pas line 2103

const RPTAG_WriteMask = $80000006;


RPTAG_XPos

Declaration

Source position: agraphics.pas line 2114

const RPTAG_XPos = $8000000E;


RPTAG_YPos

Declaration

Source position: agraphics.pas line 2115

const RPTAG_YPos = $8000000F;


SAVEBACK

User Set flag for TVsprite.Flags. Set if background is to be saved/restored

Declaration

Source position: agraphics.pas line 402

const SAVEBACK = $0002;


SAVEBOB

Bob User Flag for TBob.Flags set to not erase Bob

Declaration

Source position: agraphics.pas line 414

const SAVEBOB = $0001;


SAVEPRESERVE

Bob System Flag for TBob.Flags For back-restore during double-buffer

Declaration

Source position: agraphics.pas line 421

const SAVEPRESERVE = $1000;


SHAPEHOOKACTION_CHANGELAYERSHAPE

Declaration

Source position: agraphics.pas line 877

const SHAPEHOOKACTION_CHANGELAYERSHAPE = 4;


SHAPEHOOKACTION_CREATELAYER

Declaration

Source position: agraphics.pas line 873

const SHAPEHOOKACTION_CREATELAYER = 0;


SHAPEHOOKACTION_DELETELAYER

Declaration

Source position: agraphics.pas line 878

const SHAPEHOOKACTION_DELETELAYER = 5;


SHAPEHOOKACTION_GETHOOKACTIONS

Declaration

Source position: agraphics.pas line 879

const SHAPEHOOKACTION_GETHOOKACTIONS = 6;


SHAPEHOOKACTION_MOVELAYER

Declaration

Source position: agraphics.pas line 874

const SHAPEHOOKACTION_MOVELAYER = 1;


SHAPEHOOKACTION_MOVESIZELAYER

Declaration

Source position: agraphics.pas line 876

const SHAPEHOOKACTION_MOVESIZELAYER = 3;


SHAPEHOOKACTION_SIZELAYER

Declaration

Source position: agraphics.pas line 875

const SHAPEHOOKACTION_SIZELAYER = 2;


SPECIAL_MONITOR_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 1085

const SPECIAL_MONITOR_TYPE = 3;


SPRITE_ATTACHED

Declaration

Source position: agraphics.pas line 2037

const SPRITE_ATTACHED = $80;


SPRITEA_Attached

Tag for AllocSpriteDataA()

Declaration

Source position: agraphics.pas line 2061

const SPRITEA_Attached = $81000008;

Description

Tells the function that you wish to convert the data for the second sprite in an attached sprite pair. This will cause AllocSpriteDataA() to take its data from the 3rd and 4th bitplanes of the passed in bitmap.


SPRITEA_OldDataFormat

Tag for AllocSpriteDataA() must pass in outputheight if using this tag

Declaration

Source position: agraphics.pas line 2062

const SPRITEA_OldDataFormat = $8100000a;


SPRITEA_OutputHeight

Tag for AllocSpriteDataA() height of Sprite

Declaration

Source position: agraphics.pas line 2060

const SPRITEA_OutputHeight = $81000006;

Description

Specifies how tall the resulting sprite should be. Defaults to the bitmap height. The bitmap must be at least as tall as the output height.


SPRITEA_Width

Tag for AllocSpriteDataA() Width of Sprite Default - 16

Declaration

Source position: agraphics.pas line 2057

const SPRITEA_Width = $81000000;

Description

specifies how many pixels wide you desire the sprite to be. Specifying a width wider than the hardware can handle will cause the function to return failure. If the bitmap passed in is narrower than the width asked for, then it will be padded on the right with transparent pixels. Defaults to 16.


SPRITEA_XReplication

Tag for AllocSpriteDataA() Controls the horizontal pixel replication factor used when converting the bitmap data. Default - 0

Declaration

Source position: agraphics.pas line 2058

const SPRITEA_XReplication = $81000002;

Description

Controls the horizontal pixel replication factor used when converting the bitmap data. Valid values are:

0
perform a 1 to 1 conversion
1
each pixel from the source is replicated twice in the output.
2
each pixel is replicated 4 times.
-1
skip every other pixel in the source bitmap
-2
only include every fourth pixel from the source.

This tag is useful for converting data from one resolution to another. For instance, hi-res bitmap data can be correctly converted for a lo-res sprite by using an x replication factor of -1. Defaults to 0.


SPRITEA_YReplication

Tag for AllocSpriteDataA() Controls the vertical pixel replication factor used when converting the bitmap data. Default - 0

Declaration

Source position: agraphics.pas line 2059

const SPRITEA_YReplication = $81000004;

Description

controls the vertical pixel replication factor in the same manner as SPRITEA_XReplication controls the horizontal.


SPRITERESN_35NS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1392

const SPRITERESN_35NS = 3;


SPRITERESN_70NS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1391

const SPRITERESN_70NS = 2;


SPRITERESN_140NS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1390

const SPRITERESN_140NS = 1;


SPRITERESN_DEFAULT

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1393

const SPRITERESN_DEFAULT = - 1;


SPRITERESN_ECS

Resolution for TColorMap.SpriteResolution

Declaration

Source position: agraphics.pas line 1388

const SPRITERESN_ECS = 0;


SPRITES

Declaration

Source position: agraphics.pas line 1379

const SPRITES = $4000;


SS_GRAPHICS

TExtendedNode.xln_Subtype

Declaration

Source position: agraphics.pas line 1081

const SS_GRAPHICS = $02;


STANDARD_COLORCLOCKS

Declaration

Source position: agraphics.pas line 1180

const STANDARD_COLORCLOCKS = 226;


STANDARD_DENISE_MAX

Declaration

Source position: agraphics.pas line 1181

const STANDARD_DENISE_MAX = 455;


STANDARD_DENISE_MIN

Declaration

Source position: agraphics.pas line 1182

const STANDARD_DENISE_MIN = 93;


STANDARD_HBSTOP

Declaration

Source position: agraphics.pas line 1195

const STANDARD_HBSTOP = $2C;


STANDARD_HBSTRT

Declaration

Source position: agraphics.pas line 1192

const STANDARD_HBSTRT = $06;


STANDARD_HSSTOP

Declaration

Source position: agraphics.pas line 1194

const STANDARD_HSSTOP = $1C;


STANDARD_HSSTRT

Declaration

Source position: agraphics.pas line 1193

const STANDARD_HSSTRT = $0B;


STANDARD_MONITOR_MASK

Declaration

Source position: agraphics.pas line 1176

const STANDARD_MONITOR_MASK = REQUEST_NTSC or REQUEST_PAL;


STANDARD_NTSC_BEAMCON

Declaration

Source position: agraphics.pas line 1183

const STANDARD_NTSC_BEAMCON = $0000;


STANDARD_NTSC_ROWS

Declaration

Source position: agraphics.pas line 1178

const STANDARD_NTSC_ROWS = 262;


STANDARD_PAL_BEAMCON

Declaration

Source position: agraphics.pas line 1184

const STANDARD_PAL_BEAMCON = $0020;


STANDARD_PAL_ROWS

Declaration

Source position: agraphics.pas line 1179

const STANDARD_PAL_ROWS = 312;


STANDARD_VBSTOP

Declaration

Source position: agraphics.pas line 1199

const STANDARD_VBSTOP = $1066;


STANDARD_VBSTRT

Declaration

Source position: agraphics.pas line 1196

const STANDARD_VBSTRT = $0122;


STANDARD_VIEW_X

Declaration

Source position: agraphics.pas line 1190

const STANDARD_VIEW_X = $81;


STANDARD_VIEW_Y

Declaration

Source position: agraphics.pas line 1191

const STANDARD_VIEW_Y = $2C;


STANDARD_VSSTOP

Declaration

Source position: agraphics.pas line 1198

const STANDARD_VSSTOP = $03AA;


STANDARD_VSSTRT

Declaration

Source position: agraphics.pas line 1197

const STANDARD_VSSTRT = $02A6;


STANDARD_XOFFSET

Declaration

Source position: agraphics.pas line 1153

const STANDARD_XOFFSET = 9;


STANDARD_YOFFSET

Declaration

Source position: agraphics.pas line 1154

const STANDARD_YOFFSET = 0;


SUPER72_MONITOR_ID

Declaration

Source position: agraphics.pas line 1643

const SUPER72_MONITOR_ID = $00081000;


SUPER72HIRESDBL_KEY

Declaration

Source position: agraphics.pas line 1647

const SUPER72HIRESDBL_KEY = $00089008;


SUPER72HIRESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1653

const SUPER72HIRESEHBDBL_KEY = $00089088;


SUPER72HIRESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1650

const SUPER72HIRESHAMDBL_KEY = $00089808;


SUPER72LORESDBL_KEY

Declaration

Source position: agraphics.pas line 1646

const SUPER72LORESDBL_KEY = $00081008;


SUPER72LORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1652

const SUPER72LORESEHBDBL_KEY = $00081088;


SUPER72LORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1649

const SUPER72LORESHAMDBL_KEY = $00081808;


SUPER72SUPERDBL_KEY

Declaration

Source position: agraphics.pas line 1648

const SUPER72SUPERDBL_KEY = $00089028;


SUPER72SUPEREHBDBL_KEY

Declaration

Source position: agraphics.pas line 1654

const SUPER72SUPEREHBDBL_KEY = $000890a8;


SUPER72SUPERHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1651

const SUPER72SUPERHAMDBL_KEY = $00089828;


SUPER_KEY

Declaration

Source position: agraphics.pas line 1504

const SUPER_KEY = $00008020;


SUPERDPF2_KEY

Declaration

Source position: agraphics.pas line 1518

const SUPERDPF2_KEY = $00008460;


SUPERDPF_KEY

Declaration

Source position: agraphics.pas line 1512

const SUPERDPF_KEY = $00008420;


SUPEREHB_KEY

Declaration

Source position: agraphics.pas line 1528

const SUPEREHB_KEY = $000080a0;


SUPEREHBLACE_KEY

Declaration

Source position: agraphics.pas line 1532

const SUPEREHBLACE_KEY = $000080a4;


SUPERHAM_KEY

Declaration

Source position: agraphics.pas line 1526

const SUPERHAM_KEY = $00008820;


SUPERHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1530

const SUPERHAMLACE_KEY = $00008824;


SUPERHIRES

Declaration

Source position: agraphics.pas line 1371

const SUPERHIRES = $0020;


SUPERLACE_KEY

Declaration

Source position: agraphics.pas line 1508

const SUPERLACE_KEY = $00008024;


SUPERLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1521

const SUPERLACEDPF2_KEY = $00008464;


SUPERLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1515

const SUPERLACEDPF_KEY = $00008424;


SUSERFLAGS

Mask of all user-settable TVsprite.Flags

Declaration

Source position: agraphics.pas line 400

const SUSERFLAGS = $00FF;

See also

SAVEBACK | User Set flag for TVsprite.Flags. Set if background is to be saved/restored
OVERLAY | User Set flag for TVsprite.Flags. Set to mask image of Bob onto background
MUSTDRAW | User Set flag for TVsprite.Flags. Set if VSprite absolutely must be drawn


TA_CharSet

Declaration

Source position: agraphics.pas line 329

const TA_CharSet = 3 or TAG_USER;


TA_DeviceDPI

Tag for TTTextAttr.tta_Tags

Declaration

Source position: agraphics.pas line 328

const TA_DeviceDPI = 1 or TAG_USER;

Description

Tag value is Point union: Hi word XDPI, Lo word YDPI


TA_Rebuild

Declaration

Source position: agraphics.pas line 330

const TA_Rebuild = 4 or TAG_USER;


TAATextFont

Declaration

Source position: agraphics.pas line 575

type TAATextFont = record

  aatf_CTF: TColorTextFont;

  aatf_Modulo: Word;

  aatf_FreeMe: Word;

  aatf_CharData: Pointer;

  aatf_CharLoc: Pointer;

  aatf_SelfPtr: PAATextFont;

  aatf_Reserved: array [0..1] of LongWord;

end;


TAlphaHookMsg

Declaration

Source position: agraphics.pas line 900

type TAlphaHookMsg = record

  Action: LongWord;

  NewAlphaCR: PClipRect;

  OldAlphaCR: PClipRect;

  NewBounds: PRectangle;

  OldBounds: PRectangle;

end;


TAnalogSignalInterval

Declaration

Source position: agraphics.pas line 1100

type TAnalogSignalInterval = record

  asi_Start: Word;

  asi_Stop: Word;

end;

See also

TSpecialMonitor


TAnimComp

Declaration

Source position: agraphics.pas line 804

type TAnimComp = record
Flags: SmallInt; | AnimComp flags for system and user
Timer: SmallInt; | timer defines how long to keep this component active: if set non-zero, timer decrements to zero then switches to nextSeq if set to zero, AnimComp never switches
TimeSet: SmallInt; | Initial value for timer when the AnimComp is activated by the system
NextComp: PAnimComp; | Pointer to next components of animation object
PrevComp: PAnimComp; | Pointer to previous components of animation object
NextSeq: PAnimComp; | Pointer to component component definition of next image in sequence
PrevSeq: PAnimComp; | pointer to component component definition of previous image in sequence
AnimCRoutine: Pointer; | Pointer of special animation procedure
YTrans: SmallInt; | Initial y translation (if this is a component)
XTrans: SmallInt; | Initial x translation (if this is a component)
HeadOb: PAnimOb; |
AnimBob: PBob; |
end;


TAnimOb

Declaration

Source position: agraphics.pas line 830

type TAnimOb = record
NextOb: PAnimOb; | Next Bob
PrevOb: PAnimOb; | Previous Bob
Clock: LongInt; | Number of calls to Animate this AnimOb has endured
AnOldY: SmallInt; | Old y coordinate
AnOldX: SmallInt; | Old x coordinate
AnY: SmallInt; | y coordinate of the AnimOb
AnX: SmallInt; | x coordinate of the AnimOb
YVel: SmallInt; | Velocity of this object in y direction
XVel: SmallInt; | Velocity of this object in x direction
YAccel: SmallInt; | Acceleration of this object in y direction
XAccel: SmallInt; | Acceleration of this object in x direction
RingYTrans: SmallInt; | Ring translation y value
RingXTrans: SmallInt; | Ring translation x values
AnimORoutine: Pointer; | Pointer of special animation procedure
HeadComp: PAnimComp; | Pointer to first component
AUserExt: SmallInt; | AnimOb user extension
end;


TAreaInfo

Declaration

Source position: agraphics.pas line 651

type TAreaInfo = record
VctrTbl: PSmallInt; | Pointer to start of vector table
VctrPtr: PSmallInt; | Pointer to current vertex
FlagTbl: PByte; | Pointer to start of vector flag table
FlagPtr: PByte; | Pointers to areafill flags
Count: SmallInt; | Number of vertices in list
MaxCount: SmallInt; | AreaMove/AreaDraw will not allow Count>MaxCount
FirstX: SmallInt; | First point for this polygon (X coordinate)
FirstY: SmallInt; | First point for this polygon (Y coordinate)
end;

See also

InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


TBitMap

Represents an image in ram.

Declaration

Source position: agraphics.pas line 95

type TBitMap = record
BytesPerRow: Word; | Width of a line it Bytes (To get the width of the Bitmap in pixels you have to multiply this value with 8 and divide by the Depth.)
Rows: Word; | Number of lines in the Bitmap
Flags: Byte; | Flags for the bitmap when created on AllocBitmap (BMF_*)
Depth: Byte; | Number of Bitplanes
pad: Word; | Padding byte
Planes: array [0..7] of PByte; | Pointer to the bitplanes. Depth defines how many pointers
end;

Description

Drawing to a Bitmap is mostly done by drawing on a TRastPort with the linked Bitmap TRastPort.Bitmap.

See also

AllocBitmap | Allocate a bitmap and attach bitplanes to it.
FreeBitmap | Free a bitmap created by AllocBitMap()
AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
BltBitMap | Move a rectangular region of bits in a BitMap.
BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
ChangeVPBitmap | Change display memory address for multi-buffered animation
GetBitMapAttr | Returns information about a bitmap
InitBitMap | Initialize bit map structure with input values.
TRastPort | Basic structure for all drawing actions


TBitScaleArgs

BitScaleArgs structure used by BitMapScale()

Declaration

Source position: agraphics.pas line 2074

type TBitScaleArgs = record
bsa_SrcX: Word; | Source origin x position
bsa_SrcY: Word; | Source origin y position
bsa_SrcWidth: Word; | Source width
bsa_SrcHeight: Word; | Source height
bsa_XSrcFactor: Word; | Scale factor in x direction denominator
bsa_YSrcFactor: Word; | Scale factor in y direction denominator
bsa_DestX: Word; | Destination origin x position
bsa_DestY: Word; | Destination origin y position
bsa_DestWidth: Word; | Destination width
bsa_DestHeight: Word; | Destination height
bsa_XDestFactor: Word; | Destination scale factor in x direction numerator
bsa_YDestFactor: Word; | Destination scale factor in y direction numerator
bsa_SrcBitMap: PBitMap; | Source Bitmap
bsa_DestBitMap: PBitMap; | Destination Bitmap
bsa_Flags: LongWord; | reserved. Must be zero!
bsa_XDDA: Word; | reserved
bsa_YDDA: Word; | reserved
bsa_Reserved1: LongInt; |
bsa_Reserved2: LongInt; |
end;


TBob

Blitter object

Declaration

Source position: agraphics.pas line 787

type TBob = record
Flags: SmallInt; | General purpose flags
SaveBuffer: PSmallInt; | Pointer to the buffer for background save
ImageShadow: PSmallInt; | Pointer to the buffer for background save
Before: PBob; | Draw this Bob before Bob pointed to by before
After: PBob; | Draw this Bob after Bob pointed to by after
BobVSprite: PVSprite; | This Bob's VSprite definition
BobComp: PAnimComp; | PAnimComp pointer to this Bob's AnimComp def
DBuffer: PDBufPacket; | Pointer to this Bob's dBuf packet
BUserExt: SmallInt; | Bob user extension
end;


TClipRect

Clip rectangle

Declaration

Source position: agraphics.pas line 443

type TClipRect = record
Next: PClipRect; | Pointer to next ClipRect
OffX: SmallInt;
OffY: SmallInt;
lobs: PLayer; | Ignored by roms, used by windowlib
BitMap: PBitMap; |
bounds: TRectangle; | Set up by windowlib, used by roms
vlink: PClipRect;
home: Pointer;
Flags: LongInt; | Only exists in layer allocation
end;

See also

TLayer

Layer Structure


TColorFontColors

Declaration

Source position: agraphics.pas line 552

type TColorFontColors = record
cfc_Reserved: Word; | Must be zero
cfc_Count: Word; | Number of entries in cfc_ColorTable
cfc_ColorTable: PWord; | 4 bit per component color map packed xRGB
end;


TColorMap

This structure is the primary storage for palette data.

Declaration

Source position: agraphics.pas line 1311

type TColorMap = record
Flags: Byte; | Colormap flags (COLORMAP_*)
Type_: Byte; | Colormap type, reflects version (COLORMAP_TYPE_)
Count: Word; | Number of palette entries
ColorTable: Pointer; | Table of high nibbles of color values (see description above)
cm_vpe: PViewPortExtra; | ViewPortExtra, for faster access
LowColorBits: Pointer; | Table of low nibbles of color values
TransparencyPlane: Byte; |
SpriteResolution: Byte; |
SpriteResDefault: Byte; |
AuxFlags: Byte; | Additional flags (CMAF_*)
cm_vp: PViewPort; | Points back to a ViewPort this colormap belongs to
NormalDisplayInfo: Pointer; |
CoerceDisplayInfo: Pointer; |
cm_batch_items: PTagItem; |
VPModeID: LongWord; |
PalExtra: Pointer; | Structure controlling palette sharing
SpriteBase_Even: Word; | Color bank for even sprites
SpriteBase_Odd: Word; | The same for odd sprites
Bp_0_base: Word; |
Bp_1_base: Word; |
end;

Description

Color data itself is stored in two tables: ColorTable and LowColorBits. These fields are actually pointer to arrays of Words. Each Word corresponds to one color. Number of Words in these array is equal to Count value in this structure. ColorTable stores upper nibbles of RGB values, LowColorBits stores low nibbles.

Example:

color number 4, value: $00ABCDEF
   ColorTable[4] := $0ACE,
   LowColorBits[4] := $0BDF

SpriteBase fields keep bank number, not a color number. On m68k Amiga colors are divided into banks, 16 per each. So bank number is color number divided by 16. Base color is a number which is added to all colors of the sprite in order to look up the actual palette entry. Amiga may run on different hardware where sprites may have base colors that do not divide by 16. In order to cover this bank numbers have a form: ((c and $0F) shl 8 ) or (c shr 4), where c is actual color number (i. e. remainder is stored in a high byte of Word).


TColorTextFont

Color font structure

Declaration

Source position: agraphics.pas line 560

type TColorTextFont = record
ctf_TF: TTextFont; | Standard Textfont structure
ctf_Flags: Word; | Extended flags (CT_*)
ctf_Depth: Byte; | Number of bit planes
ctf_FgColor: Byte; | Color that is remapped to FgPen
ctf_Low: Byte; | Lowest color represented here
ctf_High: Byte; | Highest color represented here
ctf_PlanePick: Byte; | PlanePick ala Images
ctf_PlaneOnOff: Byte; | PlaneOnOff ala Images
ctf_ColorFontColors: PColorFontColors; | Colors for font
ctf_CharData: array [0..7] of Pointer; | Pointers to bit planes ala TTextFont.tf_CharData
end;


TCopInit

Declaration

Source position: agraphics.pas line 635

type TCopInit = record

  vsync_hblank: array [0..1] of Word;

  diagstrt: array [0..11] of Word;

  fm0: array [0..1] of Word;

  diwstart: array [0..9] of Word;

  bplcon2: array [0..1] of Word;

  sprfix: array [0..(2*8)-1] of Word;

  sprstrtup: array [0..(2*8*2)-1] of Word;

  wait14: array [0..1] of Word;

  norm_hblank: array [0..1] of Word;

  jump: array [0..1] of Word;

  wait_forever: array [0..5] of Word;

  sprstop: array [0..7] of Word;

end;


TCopIns

Copper structure

Declaration

Source position: agraphics.pas line 595

type TCopIns = record

  OpCode: SmallInt;

0 = move, 1 = wait

  VWaitAddr: SmallInt;

  HWaitData: SmallInt;

end;


TCopList

Declaration

Source position: agraphics.pas line 610

type TCopList = record
Next: PCopList; | Next block for this copper list
CopList: PCopList;
ViewPort: Pointer;
CopIns: PCopIns; | start of this block
CopPtr: PCopIns; | intermediate ptr
CopLStart: PWord; | mrgcop fills this in for Long Frame
CopSStart: PWord; | mrgcop fills this in for Longint Frame
Count: SmallInt; | intermediate counter
MaxCount: SmallInt; | max # of copins for this block
DyOffset: SmallInt; | offset this copper list vertical waits
SLRepeat: Word; |
Flags: Word; |
end;


TCprList

Structure of cprlist that points to list that hardware actually executes

Declaration

Source position: agraphics.pas line 603

type TCprList = record
Next: PCprList; |
Start: PSmallInt; | start of copper list
MaxCount: SmallInt; | Number of long instructions
end;


TDBufInfo

Double buffer structure

Declaration

Source position: agraphics.pas line 1456

type TDBufInfo = record
dbi_Link1: Pointer; |
dbi_Count1: LongWord; |
dbi_SafeMessage: TMessage; | Replied to when safe to write to old bitmap
dbi_UserData1: Pointer; | First user data
dbi_Link2: Pointer; |
dbi_Count2: LongWord; |
dbi_DispMessage: TMessage; | Replied to when new bitmap has been displayed at least once
dbi_UserData2: Pointer; | Second user data
dbi_MatchLong: LongWord; |
dbi_CopPtr1: Pointer; |
dbi_CopPtr2: Pointer; |
dbi_CopPtr3: Pointer; |
dbi_BeamPos1: Word; |
dbi_BeamPos2: Word; |
end;

See also

AllocDBufInfo | Allocate structure for multi-buffered animation
ChangeVPBitMap | Change display memory address for multi-buffered animation
FreeDBufInfo | Free information for multi-buffered animation


tDBufPacket

Defines the values needed to be saved across buffer to buffer when in double-buffer mode

Declaration

Source position: agraphics.pas line 850

type tDBufPacket = record
BufY: SmallInt; | Save other buffers screen coordinates
BufX: SmallInt; | Save other buffers screen coordinates
BufPath: PVSprite; | Carry the draw path over the gap
BufBuffer: PSmallInt; | These pointers must be filled in by the user pointer to other buffer's background save buffer
end;


TDimensionInfo

Monitor dimensions (like overscan)

Declaration

Source position: agraphics.pas line 1876

type TDimensionInfo = record
Header: TQueryHeader; |
MaxDepth: Word; | log2(max number of colors)
MinRasterWidth: Word; | Minimum width in pixels
MinRasterHeight: Word; | Minimum height in pixels
MaxRasterWidth: Word; | Maximum width in pixels
MaxRasterHeight: Word; | Maximum height in pixels
Nominal: TRectangle; | "Standard" dimensions without overscan
MaxOScan: TRectangle; | Fixed, hardware dependant
VideoOScan: TRectangle; | Fixed, hardware dependant
TxtOScan: TRectangle; | Editable via preferences
StdOScan: TRectangle; | Editable via preferences
Pad: array [0..13] of Byte; |
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_DIMS | GetDisplayInfoData, results in PDimensionInfo


TDisplayInfo

Structure to hold informations about Display.

Declaration

Source position: agraphics.pas line 1816

type TDisplayInfo = record
Header: TQueryHeader; |
NotAvailable: Word; | If 0 DisplayInfo available, else not available -> see Constants DI_AVAIL_*
PropertyFlags: LongWord; | Properties of this mode (DIPF_*)
Resolution: TPoint; | Ticks-per-pixel X/Y
PixelSpeed: Word; | Approximation in nanoseconds
NumStdSprites: Word; | Number of standard amiga sprites
PaletteRange: Word; | Distinguishable shades available
SpriteResolution: TPoint; | Standard sprite ticks-per-pixel X/Y
Pad: array [0..3] of Byte; |
RedBits: Byte; | Number of bits for Red color
GreenBits: Byte; | Number of bits for Green color
BlueBits: Byte; | Number of bits for Blue color
Pad2: array [0..4] of Byte; |
RTGBoardNum: Byte;
PixelFormat: LongWord;
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

FindDisplayInfo | Search for a record identified by a specific key
GetDisplayInfoData | Query DisplayInfo Record parameters


TE0B_NOREMFONT

Flag bit TTextFontExtension.tfe_Flags0 disallow RemFont for this font

Declaration

Source position: agraphics.pas line 334

const TE0B_NOREMFONT = 0;


TE0F_NOREMFONT

Flag value TTextFontExtension.tfe_Flags0 disallow RemFont for this font

Declaration

Source position: agraphics.pas line 335

const TE0F_NOREMFONT = $01;


TE1F_GENFONT

Declaration

Source position: agraphics.pas line 344

const TE1F_GENFONT = $80;


TE1F_NOANTIALIASING

Declaration

Source position: agraphics.pas line 343

const TE1F_NOANTIALIASING = $40;


TE1F_NODEEMBOLDENING

Declaration

Source position: agraphics.pas line 341

const TE1F_NODEEMBOLDENING = $10;


TE1F_NODESHEARING

Declaration

Source position: agraphics.pas line 342

const TE1F_NODESHEARING = $20;


TE1F_NODEUNDERLINING

Declaration

Source position: agraphics.pas line 340

const TE1F_NODEUNDERLINING = $08;


TE1F_NOEMBOLDENING

Declaration

Source position: agraphics.pas line 338

const TE1F_NOEMBOLDENING = $02;


TE1F_NOSHEARING

Declaration

Source position: agraphics.pas line 339

const TE1F_NOSHEARING = $04;


TE1F_NOUNDERLINING

Declaration

Source position: agraphics.pas line 337

const TE1F_NOUNDERLINING = $01;


TExtendedNode

Declaration

Source position: agraphics.pas line 117

type TExtendedNode = record
xln_Succ: PNode; |
xln_Pred: PNode; |
xln_Type: Byte; | NT_GRAPHICS
xln_Pri: ShortInt; |
xln_Name: PChar; |
xln_Subsystem: Byte; | VIEW_EXTRA_TYPE, VIEWPORT_EXTRA_TYPE, SPECIAL_MONITOR_TYPE or MONITOR_SPEC_TYPE
xln_Subtype: Byte; | SS_GRAPHICS
xln_Library: LongInt; |
xln_Init: Pointer; |
end;


TExtSprite

Extended sprite Structure

Declaration

Source position: agraphics.pas line 2049

type TExtSprite = record
es_SimpleSprite: TSimpleSprite; | Conventional simple sprite structure
es_wordwidth: Word; | Graphics use only, subject to change
es_flags: Word; | Graphics use only, subject to change
end;

See also

AllocSpriteDataA | Allocate sprite data and convert from a bitmap.
ChangeExtSpriteA | Change the sprite image pointer.
FreeSpriteData | free sprite data allocated by AllocSpriteData()
GetExtSpriteA | Attempt to get a sprite for the extended sprite manager.


TGelsInfo

Declaration

Source position: agraphics.pas line 670

type TGelsInfo = record
sprRsrvd: ShortInt; | Flag of which sprites to reserve from vsprite system
Flags: Byte; | System use
gelHead: PVSprite; | PVSprite Dummy vSprite for list management
gelTail: PVSprite; | PVSprite Dummy vSprite for list management
nextLine: PWord; | Pointer to array of 8 WORDS for sprite available lines
lastColor: Pointer; | Pointer to array of 8 pointers for color-last-assigned to vSprites
collHandler: PCollTable; | PCollTable Pointeres of collision routines
leftmost: SmallInt; |
rightmost: SmallInt; |
topmost: SmallInt; |
bottommost: SmallInt; |
firstBlissObj: Pointer; | System use only
lastBlissObj: Pointer; | System use only
end;

See also

TRastPort | Basic structure for all drawing actions
InitGels | initialize a gel list; must be called before using gels.
SetCollision | Set a pointer to a user collision routine.


TGfxBase

Graphics library structure

Declaration

Source position: agraphics.pas line 2121

type TGfxBase = record
LibNode: TLibrary; | Basic Library structure
ActiView: PView; |
copinit: PCopInit; | Pointer to copper start up list
cia: PLongInt; | For 8520 resource use
blitter: PLongInt; | For future blitter resource use
LOFlist: PWord; |
SHFlist: PWord; |
blthd: Pointer; |
blttl: Pointer; |
bsblthd: Pointer; |
bsblttl: Pointer; |
vbsrv: TInterrupt; |
timsrv: TInterrupt; |
bltsrv: TInterrupt; |
TextFonts: TList; | List of Fonts
DefaultFont: PTextFont; | Current default font
Modes: Word; | Copy of current first bplcon0
VBlank: ShortInt; |
Debug: ShortInt; |
BeamSync: SmallInt; |
system_bplcon0: SmallInt; | It is ored into each bplcon0 for display
SpriteReserved: Byte; |
bytereserved: Byte; |
Flags: Word; |
BlitLock: SmallInt; |
BlitNest: SmallInt; |
BlitWaitQ: TList; |
BlitOwner: PTask; |
TOF_WaitQ: TList; |
DisplayFlags: Word; | NTSC PAL GENLOC etc. Display flags are determined at power on
SimpleSprites: Pointer; | Simple sprite pointer
MaxDisplayRow: Word; | hardware stuff, do not use
MaxDisplayColumn: Word; | hardware stuff, do not use
NormalDisplayRows: Word; |
NormalDisplayColumns: Word; |
NormalDPMX: Word; | Dots per meter on display standard non interlace, 1/2 wb width
NormalDPMY: Word; | Dots per meter on display standard non interlace, 1/2 wb width
LastChanceMemory: PSignalSemaphore; |
LCMptr: Pointer; |
MicrosPerLine: Word; | 256 time usec/line
MinDisplayColumn: Word; |
ChipRevBits0: Byte; |
MemType: Byte; |
crb_reserved: array [0..3] of Byte; |
monitor_id: Word; | normally 0
hedley: array [0..7] of LongWord; |
hedley_sprites: array [0..7] of LongWord; | sprite ptrs for intuition mouse
hedley_sprites1: array [0..7] of LongWord; | sprite ptrs for intuition mouse
hedley_count: SmallInt; |
hedley_flags: Word; |
hedley_tmp: SmallInt; |
hash_table: PLongInt; | Hashtable used for GfxAssociate() and GfxLookup() (private!)
current_tot_rows: Word; |
current_tot_cclks: Word; |
hedley_hint: Byte; |
hedley_hint2: Byte; |
nreserved: array [0..3] of LongWord; |
a2024_sync_raster: PLongInt; |
control_delta_pal: Word; |
control_delta_ntsc: Word; |
current_monitor: PMonitorSpec; | MonitorSpec used for current display
MonitorList: TList; | List of all MonitorSpecs in the system
default_monitor: PMonitorSpec; | MonitorSpec of "default.monitor"
MonitorListSemaphore: PSignalSemaphore; | Semaphore for MonitorList access
DisplayInfoDataBase: Pointer; |
TopLine: Word; |
ActiViewCprSemaphore: PSignalSemaphore; | Semaphore for active view access
UtilityBase: Pointer; | for hook and tag utilities
ExecBase: Pointer; | to link with rom.lib
bwshifts: PByte; |
StrtFetchMasks: PWord; |
StopFetchMasks: PWord; |
Overrun: PWord; |
RealStops: PSmallInt; |
SpriteWidth: Word; | current width (in words) of sprites
SpriteFMode: Word; | current sprite fmode bits
SoftSprites: ShortInt; | bit mask of size change knowledgeable sprites
arraywidth: ShortInt; |
DefaultSpriteWidth: Word; | What width intuition wants
SprMoveDisable: ShortInt; |
WantChips: Byte; |
BoardMemType: Byte; |
Bugs: Byte; |
gb_LayersBase: Pointer; | layers.library base
ColorMask: LongWord; |
IVector: Pointer; |
IData: Pointer; |
SpecialCounter: LongWord; | special for double buffering
DBList: Pointer; |
MonitorFlags: Word; |
ScanDoubledSprites: Byte; |
BP3Bits: Byte; |
MonitorVBlank: TAnalogSignalInterval; |
natural_monitor: PMonitorSpec; | Default MonitorSpec for view without explicit MonitorSpec in ViewExtra
ProgData: Pointer; |
ExtSprites: Byte; |
ClassicAmiga: Byte;
GfxFlags: Word; |
VBCounter: LongWord; |
HashTableSemaphore: PSignalSemaphore; | Semaphore for hash_table access, private in fact
HWEmul: array [0..8] of PLongWord; |
DefaultCharSet: LongWord;
RegionPool: Pointer;
RegionPoolSemaphore: PSignalSemaphore;
DiskfontBase: PLibrary;
Antialiasing: LongWord;
end;


TIsrvstr

Declaration

Source position: agraphics.pas line 1091

type TIsrvstr = record

  is_Node: TNode;

  Iptr: PIsrvstr;

  code: Pointer;

  ccode: Pointer;

  Carg: Pointer;

end;


TLayer

Layer Structure

Declaration

Source position: agraphics.pas line 456

type TLayer = record
front: PLayer; | Link to next layer (in front of the current one)
back: PLayer; | Link to the previous layer (behind the current one)
ClipRect: PClipRect; | Read by roms to find first cliprect
rp: PRastPort; | Ignored by roms, I hope
bounds: TRectangle; | Ignored by roms
nlink: PLayer;
priority: Word; | system use only
Flags: Word; | obscured ?, Virtual BitMap?
SuperBitMap: PBitMap; |
SuperClipRect: PClipRect; | Super bitmap cliprects if VBitMap <> 0 else damage cliprect list for refresh
Window: Pointer; | Reserved for user interface use
Scroll_X: Word; |
Scroll_Y: Word; |
cr: PClipRect; | used by dedice
cr2: PClipRect; | used by dedice
cr3: PClipRect;
SuperSaveClipRects: PClipRect; | preallocated Clip rects
_Cliprects: PClipRect; | System use during refresh
LayerInfo: Pointer; | Points to head of the list
Lock: TSignalSemaphore; |
BackFill: PHook; |
ShapeRegion: PRegion;
ClipRegion: PRegion; |
Clipped: PClipRect;
Width: SmallInt; | Width of layer
Height: SmallInt; | Height of Layer
ShapeHook: PHook;
reserved2: array [0..3] of Byte; |
BitMap: PBitMap;
Extension: Pointer;
Reserved3: Byte;
Opaqueness: Byte;
DamageList: PRegion; | List of rectangles to refreshthrough
end;


TMonitorInfo

Monitor Informations structure

Declaration

Source position: agraphics.pas line 1893

type TMonitorInfo = record
Header: TQueryHeader; |
Mspc: PMonitorSpec; | Pointer to monitor specification
ViewPosition: TPoint; | Editable via preferences
ViewResolution: TPoint; | Standard monitor ticks-per-pixel
ViewPositionRange: TRectangle; | Fixed, hardware dependant
TotalRows: Word; | Display height in scanlines
TotalColorClocks: Word; | Scanline width in 280 ns units
MinRow: Word; | Absolute minimum active scanline
Compatibility: SmallInt; | how this coexists with others (MCOMPAT_*)
Pad: array [0..31] of Byte; |
MouseTicks: TPoint; |
DefaultViewPosition: TPoint; |
PreferredModeID: LongWord; |
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_MNTR | GetDisplayInfoData, results in PMonitorInfo


TMonitorSpec

Declaration

Source position: agraphics.pas line 1121

type TMonitorSpec = record
ms_Node: TExtendedNode; |
ms_Flags: Word; | Monitor Flags: (MSF_*)
ratioh: LongInt; |
ratiov: LongInt; |
total_rows: Word; | Total number of scanlines per frame
total_colorclocks: Word; | Total number of color clocks per line (in 1/280 ns units)
DeniseMaxDisplayColumn: Word; |
BeamCon0: Word; | Value for beamcon0 Amiga(tm) chipset register
min_row: Word; |
ms_Special: PSpecialMonitor; | Synchro signal timings description (optional)
ms_OpenCount: Word; | Driver open count
ms_transform: Pointer; |
ms_translate: Pointer; |
ms_scale: Pointer; |
ms_xoffset: Word; |
ms_yoffset: Word; |
ms_LegalView: TRectangle; | Allowed range for view positioning (right-bottom position included)
ms_maxoscan: Pointer; | maximum legal overscan
ms_videoscan: Pointer; | video display overscan
DeniseMinDisplayColumn: Word; |
DisplayCompatible: LongWord; |
DisplayInfoDataBase: TList; |
DisplayInfoDataBaseSemaphore: TSignalSemaphore; |
ms_MrgCop: Pointer; |
ms_LoadView: Pointer; |
ms_KillView: Pointer; |
end;


TNameInfo

Name of the Display

Declaration

Source position: agraphics.pas line 1920

type TNameInfo = record
Header: TQueryHeader; |
Name: array [0..DISPLAYNAMELEN-1] of Char; |
Reserved: array [0..1] of LongWord; | Terminator
end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_NAME | GetDisplayInfoData, results in PNameInfo


TO_MONITOR

Declaration

Source position: agraphics.pas line 1151

const TO_MONITOR = 0;


TODA_SAFE

Flag for TGfxBase.DisplayFlags

Declaration

Source position: agraphics.pas line 2242

const TODA_SAFE = 8;


TOPHIT

Bit Description for SetCollision

Declaration

Source position: agraphics.pas line 924

const TOPHIT = 1;

Description

This bit descriptor is used by the GEL boundry hit routines. When the user's boundry-hit routine is called (via the argument set by a call to SetCollision) the first argument passed to the user's routine is the Pointer of the GEL involved in the boundry-hit, and the second argument has the appropriate bit(s) set to describe which boundry was surpassed.


TPaletteExtra

Structure controlling palette sharing

Declaration

Source position: agraphics.pas line 1407

type TPaletteExtra = record
pe_Semaphore: TSignalSemaphore; | shared semaphore for arbitration
pe_FirstFree: Word; | private
pe_NFree: Word; | number of free colors
pe_FirstShared: Word; | private
pe_NShared: Word; | private
pe_RefCnt: PByte; | private
pe_AllocList: PByte; | private
pe_ViewPort: PViewPort; | Back pointer to viewport
pe_SharableColors: Word; | The number of sharable colors.
end;

Description

Structure may be extended so watch out!


TPIX_FMT

Declaration

Source position: agraphics.pas line 270

type TPIX_FMT = LongWord;


TPlanarYUVInfo

Declaration

Source position: agraphics.pas line 273

type TPlanarYUVInfo = record

  YMemory: Pointer;

  UMemory: Pointer;

  VMemory: Pointer;

  YBytesPerRow: LongWord;

  UBytesPerRow: LongWord;

  VBytesPerRow: LongWord;

end;


TPLANEPTR

Pointer to Bitplane coded image data, can be created with AllocRaster

Declaration

Source position: agraphics.pas line 92

type TPLANEPTR = PByte;

See also

AllocRaster | Allocate space for a bitplane.
FreeRaster | Release an allocated area to the system free memory pool


TPoint

Basic definition of a point (x,y)

Declaration

Source position: agraphics.pas line 88

type TPoint = record
x: SmallInt; | X-Value
y: SmallInt; | Y-Value
end;


TQueryHeader

Header for TDisplayInfo

Declaration

Source position: agraphics.pas line 1808

type TQueryHeader = record
StructID: LongWord; | datachunk type identifiers
DisplayID: LongWord; | Copy of display record key
SkipID: LongWord; | utility.TAG_SKIP
Length: LongWord; | Length of local data in double-longwords
end;


TRasInfo

Used in TViewPort

Declaration

Source position: agraphics.pas line 1249

type TRasInfo = record
Next: PRasInfo; | Used for Dual playfield
BitMap: PBitMap; |
RxOffset: SmallInt; | X Scroll offset in this BitMap
RyOffset: SmallInt; | Y Scroll offset in this BitMap
end;


TRastPort

Basic structure for all drawing actions

Declaration

Source position: agraphics.pas line 688

type TRastPort = record
Layer: PLayer; | Pointer to Layer of Rastport
BitMap: PBitMap; | Pointer to Bitmap data
AreaPtrn: PWord; | Area Fill pattern
TmpRas: PTmpRas; | Temporary Rastport, needed for Area actions
AreaInfo: PAreaInfo; |
GelsInfo: PGelsInfo; |
Mask: Byte; | Write mask for this raster
FgPen: ShortInt; | Foreground pen for this raster
BgPen: ShortInt; | Background pen for this raster
AOlPen: ShortInt; | AreaFill outline pen
DrawMode: ShortInt; | Drawing mode for fill, lines, and text (JAM1, JAM2, COMPLEMENT, INVERSVID)
AreaPtSz: ShortInt; | 2**n words for areafill pattern
linpatcnt: ShortInt; | current line drawing pattern preshift
dummy: ShortInt; |
Flags: Word; | Miscellaneous control bits (FRST_DOT, ONE_DOT, DBUFFER)
LinePtrn: Word; | 16 bits for textured lines
cp_x: SmallInt; | Current x pen position
cp_y: SmallInt; | Current y pen position
minterms: array [0..7] of Byte; |
PenWidth: SmallInt; |
PenHeight: SmallInt; |
Font: PTextFont; | PTextFont current font Pointer
AlgoStyle: Byte; | The algorithmically generated style
TxFlags: Byte; | Text specific flags
TxHeight: Word; | Text height
TxWidth: Word; | Text nominal width
TxBaseline: Word; | Text baseline
TxSpacing: SmallInt; | Text spacing (per character)
RP_User: Pointer; |
LongFlags: LongWord;
ExtensionData: Pointer;
RenderDomain: TRectangle;
FGColor: LongWord;
BGColor: LongWord;
OColor: LongWord;
wordreserved: Word; | Used to be a node
end;

See also

BltBitMapRastPort | Blit from source bitmap to destination rastport.
BltMaskBitMapRastPort | Blit from source bitmap to destination rastport with masking of source image.
BltPattern | Using standard drawing rules for areafill, blit through a mask.
ClearEOL | Clear from current position to end of line.
ClearScreen | Clear from current position to end of RastPort.
ClipBlit | Calls BltBitMap() after accounting for windows
Draw | Draw a line between the current pen position and the new x,y position.
DrawEllipse | Draw an ellipse centered at cx,cy with vertical and horizontal radii of a,b respectively
DrawGList | Process the gel list, queueing VSprites, drawing Bobs.
EraseRect | Fill a defined rectangular area using the current BackFill hook.
Flood | Flood rastport like areafill.
GfxMove | Move graphics pen position.
InitRastPort | Initialize raster port structure
PolyDraw | Draw lines from table of (x,y) values.
ReadPixel | read the pen number value of the pixel at a specified x,y location within a certain RastPort.
WritePixel | Change the pen num of one specific pixel in a specified RastPort.
GfxText | Write text characters (no formatting).


TRastPortExtra

Declaration

Source position: agraphics.pas line 729

type TRastPortExtra = record

  Node: TExtendedNode;

  RastPort: PRastPort;

  Reserved: array [0..15] of LongWord;

end;


TRect32

Basic struct for defining a rectengular region with integer values

Declaration

Source position: agraphics.pas line 82

type TRect32 = record
MinX: LongInt; | Left Edge
MinY: LongInt; | Top edge
MaxX: LongInt; | Right Edge
MaxY: LongInt; | Bottom Edge
end;


TRectangle

Basic struct for defining a rectengular region with word values

Declaration

Source position: agraphics.pas line 76

type TRectangle = record
MinX: SmallInt; | Left edge
MinY: SmallInt; | Top edge
MaxX: SmallInt; | Right edge
MaxY: SmallInt; | Bottom Edge
end;

See also

AndRectRegion | Perform 2d AND operation of rectangle with region, leaving result in region.
ClearRectRegion
OrRectRegion | Perform 2d OR operation of rectangle with region, leaving result in region.
XorRectRegion | Perform 2d XOR operation of rectangle with region, leaving result in region
TRegionRectangle |
TClipRect | Clip rectangle
TLayer | Layer Structure
TTextExtent | A measured text size


tRegion

Declaration

Source position: agraphics.pas line 111

type tRegion = record

  bounds: TRectangle;

  RegionRectangle: PRegionRectangle;

end;


TRegionRectangle

Declaration

Source position: agraphics.pas line 105

type TRegionRectangle = record

  Next: PRegionRectangle;

  Prev: PRegionRectangle;

  bounds: TRectangle;

end;


TShapeHookMsg

Declaration

Source position: agraphics.pas line 882

type TShapeHookMsg = record

  Action: LongWord;

  NewShape: PRegion;

  OldShape: PRegion;

  NewBounds: PRectangle;

  OldBounds: PRectangle;

end;


TSimpleSprite

Sprite description structure

Declaration

Source position: agraphics.pas line 2041

type TSimpleSprite = record
posctldata: PWord; |
height: Word; |
x: Word; | Current x position
y: Word; | Current y position
num: Word; |
end;

See also

ChangeSprite | Change the sprite image pointer.
GetSprite | Attempt to get a sprite for the simple sprite manager.
MoveSprite | Move sprite to a point relative to top of viewport.


TSpecialMonitor

Declaration

Source position: agraphics.pas line 1106

type TSpecialMonitor = record
spm_Node: TExtendedNode; |
spm_Flags: Word; | Reserved, set to 0
do_monitor: Pointer; | Driver call vector - set up a video mode
reserved1: Pointer; | Private do not touch
reserved2: Pointer; | Private do not touch
reserved3: Pointer; | Private do not touch
hblank: TAnalogSignalInterval; | Signal timings by themselves
vblank: TAnalogSignalInterval; |
hsync: TAnalogSignalInterval; |
vsync: TAnalogSignalInterval; |
end;


TTextAttr

TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 494

type TTextAttr = record
ta_Name: PChar; | Name of Font
ta_YSize: Word; | Height of Font
ta_Style: Byte; | Intrinsic Font Style (FSF_*)
ta_Flags: Byte; | Font preferences and flags (FPF_*)
end;

See also

SetFont | Set the text font and attributes in a RastPort.
OpenFont | Get a pointer to a system font.
StripFont | Remove the TextFontExtension from a font
OpenDiskFont |


TTextExtent

A measured text size

Declaration

Source position: agraphics.pas line 588

type TTextExtent = record
te_Width: Word; | Same as TextLength() the RastPort current x postion advance that rendering this text would cause.
te_Height: Word; | same as tf_YSize The height of the font.
te_Extent: TRectangle; | relative to CP
end;

See also

FontExtent | Get the font attributes of the current font
TextExtent | Determine raster extent of text data.
TextFit | Count characters that will fit in a given extent


TTextFont

Declaration

Source position: agraphics.pas line 513

type TTextFont = record
tf_Message: TMessage; | Reply message for font removal, Font name in tf_Message.mn_Node.ln_Name
tf_YSize: Word; | Font height
tf_Style: Byte; | Font style (FSF_*)
tf_Flags: Byte; | Preferences and flags (FPF_*)
tf_XSize: Word; | Nominal font width
tf_Baseline: Word; | Distance from the top of char to baseline
tf_BoldSmear: Word; | Smear to affect a bold enhancement
tf_Accessors: Word; | Access count
tf_LoChar: Byte; | The first character described here
tf_HiChar: Byte; | The last character described here
tf_CharData: Pointer; | The bit character data
tf_Modulo: Word; | The row modulo for the strike font data
tf_CharLoc: Pointer; | Pointer to location data for the strike font 2 words: bit offset then size
tf_CharSpace: Pointer; | Pointer to words of proportional spacing data
tf_CharKern: Pointer; | Pointer to words of kerning data
end;


TTextFontExtension

Extended font description

Declaration

Source position: agraphics.pas line 537

type TTextFontExtension = record
tfe_MatchWord: Word; | A magic cookie for the extension
tfe_Flags0: Byte; | System private flags TE0F_NOREMFONT
tfe_Flags1: Byte; | System private flags
tfe_BackPtr: PTextFont; | Validation of compilation
tfe_OrigReplyPort: PMsgPort; | Original value in TTextFont.tf_Extension
tfe_Tags: PTagItem; | Text Tags for the font
tfe_OFontPatchS: Pointer; | System private use
tfe_OFontPatchK: Pointer; | System private use
tfe_Private0: Pointer;
end;

Description

This structure is read-only


TTmpRas

Temporary rast port

Declaration

Source position: agraphics.pas line 663

type TTmpRas = record

  RasPtr: PByte;

  Size: LongInt;

end;

See also

InitTmpRas | Initialize area of local memory for usage by areafill, floodfill, gfxtext.
InitArea | Initialize vector collection matrix
TRastPort | Basic structure for all drawing actions
AreaDraw | Add a point to a list of end points for areafill.
AreaMove | Define a new starting point for a new shape in the vector list.
AreaEllipse | Add a ellipse to areainfo list for areafill.
AreaEnd | Process table of vectors and ellipses and produce areafill.


TTTextAttr

Extended TextAttr node, matches text attributes in TRastPort

Declaration

Source position: agraphics.pas line 502

type TTTextAttr = record
tta_Name: PChar; | Name of the Font
tta_YSize: Word; | Height of the Font
tta_Style: Byte; | Intrinsic Font Style (FSF_*)
tta_Flags: Byte; | Font preferences and flags (FPF_*)
tta_Tags: PTagItem; | Extended Attributes (TA_*)
end;


TUCopList

Declaration

Source position: agraphics.pas line 626

type TUCopList = record
Next: PUCopList; |
FirstCopList: PCopList; | head node of this copper list
CopList: PCopList; | Node in use
end;


TVecInfo

This structure is PRIVATE, for our use only Touch these, and burn!

Declaration

Source position: agraphics.pas line 1932

type TVecInfo = record

  Header: TQueryHeader;

  Vec: Pointer;

  Data: Pointer;

  vi_Type: Word;

  Pad: array [0..2] of Word;

  Reserved: array [0..1] of LongWord;

end;

See also

GetDisplayInfoData | Query DisplayInfo Record parameters
DTAG_VEC | GetDisplayInfoData, Internal use only (PVecInfo)


TVecTable

Declaration

Source position: agraphics.pas line 1292

type TVecTable = record

end;


TView

Declaration

Source position: agraphics.pas line 1257

type TView = record
ViewPort: PViewPort; |
LOFCprList: PCprList; | Used for interlaced and noninterlaced
SHFCprList: PCprList; | Only used during interlace
DyOffset: SmallInt; | For complete View positioning offsets are +- adjustments to standard #s
DxOffset: SmallInt; | For complete View positioning offsets are +- adjustments to standard #s
Modes: Word; | such as INTERLACE, GENLOC
end;


TViewExtra

Additional data for Amiga(tm) chipset. Not used by other hardware. these structures are obtained via GfxNew and disposed by GfxFree

Declaration

Source position: agraphics.pas line 1268

type TViewExtra = record
n: TExtendedNode; | Common Header
View: PView; | View it relates to
Monitor: PMonitorSpec; | Monitor used for displaying this View
TopLine: Word; |
end;


TViewPort

Describes a displayed bitmap (or logical screen). Copperlists are relevant only to Amiga(tm) chipset, for other hardware they are nil.

Declaration

Source position: agraphics.pas line 1275

type TViewPort = record
Next: PViewPort; |
ColorMap: PColorMap; | Table of colors for this viewport if this is nil, MakeVPort assumes default values
DspIns: PCopList; | user by MakeView, Preliminary partial display copperlist
SprIns: PCopList; | used by sprite stuff, Preliminary partial sprite copperlist
ClrIns: PCopList; | used by sprite stuff
UCopIns: PUCopList; | User copper list
DWidth: SmallInt; | Width of currently displayed part in pixels
DHeight: SmallInt; | Height of currently displayed part in pixels
DxOffset: SmallInt; | Displacement from the (0, 0) of the physical screen to (0, 0) of the raster
DyOffset: SmallInt; |
Modes: Word; | The same as in View
SpritePriorities: Byte; | used by makevp
ExtendedModes: Byte;
RasInfo: PRasInfo; | Playfield specification
end;


tViewPortExtra

Holds additional information about the ViewPort it is associated with this structure is obtained via GfxNew() and disposed by GfxFree()

Declaration

Source position: agraphics.pas line 1297

type tViewPortExtra = record
n: TExtendedNode; |
ViewPort: PViewPort; | ViewPort it relates to (backward link)
DisplayClip: TRectangle; | makevp display clipping information, Total size of displayable part
VecTable: Pointer; |
DriverData: array [0..1] of Pointer; | Private storage for display drivers. Do not touch!
Flags: Word; | Flags (VPXF_*)
Origin: array [0..1] of TPoint; | First visible point relative to the DClip. One for each possible playfield.
cop1ptr: LongWord; | private
cop2ptr: LongWord; | private
MonitorData: Pointer;
end;


TVSprite

Sprite description

Declaration

Source position: agraphics.pas line 745

type TVSprite = record
NextVSprite: PVSprite; | GEL linked list forward pointer sorted by y,x value
PrevVSprite: PVSprite; | GEL linked list backward pointer sorted by y,x value
DrawPath: PVSprite; | Pointer of overlay drawing
ClearPath: PVSprite; | Pointer for overlay clearing
OldY: SmallInt; | Previous x position
OldX: SmallInt; | Previous y position
Flags: SmallInt; | VSprite flags
Y: SmallInt; | Screen y position
X: SmallInt; | Screen x position
Height: SmallInt; | Number of lines of image data
Width: SmallInt; | Number of words per row of image data
Depth: SmallInt; | Number of planes
MeMask: SmallInt; | Which types can collide with this VSprite
HitMask: SmallInt; | Which types this VSprite can collide with
ImageData: PSmallInt; | Pointer to VSprite image
BorderLine: PSmallInt; | Logical OR of all VSprite bits
CollMask: PSmallInt; | Similar to above except this is a matrix
SprColors: PSmallInt; | Pointer to this VSprite's color definitions (not used by Bobs)
VSBob: PBob; | (PBob) points home if this VSprite is part of a Bob
PlanePick: ShortInt; | Plane flags
PlaneOnOff: ShortInt; |
VUserExt: SmallInt; | User definable
end;

Description

The VSprite positions are defined in (y,x) order to make sorting sorting easier, since (y,x) as a long Longint.

BorderLine is the one-dimensional logical OR of all the VSprite bits, used for fast collision detection of edge

PlanePick flag: set bit selects a plane from image, clear bit selects use of shadow mask for that plane OnOff flag: if using shadow mask to fill plane, this bit (corresponding to bit in planePick) describes whether to fill with 0's or 1's

There are two uses for these flags:

  • if this is the VSprite of a Bob, these flags describe how the Bob is to be drawn into memory
  • if this is a simple VSprite and the user intends on setting the MUSTDRAW flag of the VSprite, these flags must be set too to describe which color registers the user wants for the image


USER_COPPER_CLIP

Flag value for TColorMap.Flags

Declaration

Source position: agraphics.pas line 1349

const USER_COPPER_CLIP = $20;


VC_DPMSLevel

Declaration

Source position: agraphics.pas line 2029

const VC_DPMSLevel = $80000086;


VC_DUALPF_Disable

Tag for VideoControl() When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Default = False.

Declaration

Source position: agraphics.pas line 2017

const VC_DUALPF_Disable = $80000084;

Description

When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Even bitplanes will still come from the first BitMap and odd bitplanes from the second BitMap, and both R[xy]Offsets will be considered. This can be used (with appropriate palette selection) for cross-fades between differently scrolling images. When this flag is turned on, colors will be loaded forthe viewport as if it were a single viewport of depth depth1+depth2

See also

VC_DUALPF_Disable_Query

Tag for VideoControl()


VC_DUALPF_Disable_Query

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 2028

const VC_DUALPF_Disable_Query = $80000085;

See also

VC_DUALPF_Disable

Tag for VideoControl() When this flag is set, the dual-pf bit in Dual-Playfield screens will be turned off. Default = False.


VC_IntermediateCLUpdate

Tag for VideoControl() When set graphics will update the intermediate copper lists on color changes, etc. When False, it won't, and will be faster. default = True.

Declaration

Source position: agraphics.pas line 2011

const VC_IntermediateCLUpdate = $80000080;

See also

VC_IntermediateCLUpdate_Query

Tag for VideoControl() Get if intermediate copper is activated


VC_IntermediateCLUpdate_Query

Tag for VideoControl() Get if intermediate copper is activated

Declaration

Source position: agraphics.pas line 2013

const VC_IntermediateCLUpdate_Query = $80000081;

See also

VC_IntermediateCLUpdate

Tag for VideoControl() When set graphics will update the intermediate copper lists on color changes, etc. When False, it won't, and will be faster. default = True.


VC_NoColorPaletteLoad

Tag for VideoControl() When set, graphics will only load color 0 for this View Port default = False.

Declaration

Source position: agraphics.pas line 2014

const VC_NoColorPaletteLoad = $80000082;

Description

When set, graphics will only load color 0 for this ViewPort, and so the ViewPort's colors will come from the previous ViewPort's. Using this tag and VTAG_FULLPALETTE_SET together is undefined.

See also

VC_NoColorPaletteLoad_Query

Tag for VideoControl() Get if only color 0 will be set for this viewport.


VC_NoColorPaletteLoad_Query

Tag for VideoControl() Get if only color 0 will be set for this viewport.

Declaration

Source position: agraphics.pas line 2016

const VC_NoColorPaletteLoad_Query = $80000083;

See also

VC_NoColorPaletteLoad

Tag for VideoControl() When set, graphics will only load color 0 for this View Port default = False.


VGA70_COLORCLOCKS

Declaration

Source position: agraphics.pas line 1217

const VGA70_COLORCLOCKS = STANDARD_COLORCLOCKS / 2;


VGA70_DENISE_MIN

Declaration

Source position: agraphics.pas line 1219

const VGA70_DENISE_MIN = 59;


VGA70_HBSTOP

Declaration

Source position: agraphics.pas line 1224

const VGA70_HBSTOP = $1E;


VGA70_HBSTRT

Declaration

Source position: agraphics.pas line 1221

const VGA70_HBSTRT = $08;


VGA70_HSSTOP

Declaration

Source position: agraphics.pas line 1223

const VGA70_HSSTOP = $1C;


VGA70_HSSTRT

Declaration

Source position: agraphics.pas line 1222

const VGA70_HSSTRT = $0E;


VGA70_MONITOR_NAME

Declaration

Source position: agraphics.pas line 1231

const VGA70_MONITOR_NAME: PChar = 'vga70.monitor';


VGA70_TOTAL_ROWS

Declaration

Source position: agraphics.pas line 1218

const VGA70_TOTAL_ROWS = 449;


VGA70_VBSTOP

Declaration

Source position: agraphics.pas line 1228

const VGA70_VBSTOP = $0F73;


VGA70_VBSTRT

Declaration

Source position: agraphics.pas line 1225

const VGA70_VBSTRT = $0000;


VGA70_VSSTOP

Declaration

Source position: agraphics.pas line 1227

const VGA70_VSSTOP = $0388;


VGA70_VSSTRT

Declaration

Source position: agraphics.pas line 1226

const VGA70_VSSTRT = $02A6;


VGA_COLORCLOCKS

Declaration

Source position: agraphics.pas line 1201

const VGA_COLORCLOCKS = STANDARD_COLORCLOCKS / 2;


VGA_DENISE_MIN

Declaration

Source position: agraphics.pas line 1203

const VGA_DENISE_MIN = 59;


VGA_HBSTOP

Declaration

Source position: agraphics.pas line 1208

const VGA_HBSTOP = $1E;


VGA_HBSTRT

Declaration

Source position: agraphics.pas line 1205

const VGA_HBSTRT = $08;


VGA_HSSTOP

Declaration

Source position: agraphics.pas line 1207

const VGA_HSSTOP = $1C;


VGA_HSSTRT

Declaration

Source position: agraphics.pas line 1206

const VGA_HSSTRT = $0E;


VGA_MONITOR_ID

Declaration

Source position: agraphics.pas line 1539

const VGA_MONITOR_ID = $00031000;


VGA_MONITOR_NAME

Declaration

Source position: agraphics.pas line 1214

const VGA_MONITOR_NAME: PChar = 'vga.monitor';


VGA_TOTAL_ROWS

Declaration

Source position: agraphics.pas line 1202

const VGA_TOTAL_ROWS = STANDARD_NTSC_ROWS * 2;


VGA_VBSTOP

Declaration

Source position: agraphics.pas line 1212

const VGA_VBSTOP = $0CCD;


VGA_VBSTRT

Declaration

Source position: agraphics.pas line 1209

const VGA_VBSTRT = $0000;


VGA_VSSTOP

Declaration

Source position: agraphics.pas line 1211

const VGA_VSSTOP = $0235;


VGA_VSSTRT

Declaration

Source position: agraphics.pas line 1210

const VGA_VSSTRT = $0153;


VGAEHB_KEY

Declaration

Source position: agraphics.pas line 1573

const VGAEHB_KEY = $000390a4;


VGAEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1574

const VGAEHBLACE_KEY = $000390a5;


VGAEXTRAHALFBRITE_KEY

Declaration

Source position: agraphics.pas line 1560

const VGAEXTRAHALFBRITE_KEY = $00031084;


VGAEXTRAHALFBRITELACE_KEY

Declaration

Source position: agraphics.pas line 1561

const VGAEXTRAHALFBRITELACE_KEY = $00031085;


VGAEXTRALORES_KEY

Declaration

Source position: agraphics.pas line 1540

const VGAEXTRALORES_KEY = $00031004;


VGAEXTRALORESDBL_KEY

Declaration

Source position: agraphics.pas line 1577

const VGAEXTRALORESDBL_KEY = $00031000;


VGAEXTRALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1554

const VGAEXTRALORESDPF2_KEY = $00031444;


VGAEXTRALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1548

const VGAEXTRALORESDPF_KEY = $00031404;


VGAEXTRALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1569

const VGAEXTRALORESEHB_KEY = VGAEXTRAHALFBRITE_KEY;


VGAEXTRALORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1583

const VGAEXTRALORESEHBDBL_KEY = $00031080;


VGAEXTRALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1570

const VGAEXTRALORESEHBLACE_KEY = VGAEXTRAHALFBRITELACE_KEY;


VGAEXTRALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1565

const VGAEXTRALORESHAM_KEY = VGAHAM_KEY;


VGAEXTRALORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1580

const VGAEXTRALORESHAMDBL_KEY = $00031800;


VGAEXTRALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1568

const VGAEXTRALORESHAMLACE_KEY = VGAHAMLACE_KEY;


VGAEXTRALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1544

const VGAEXTRALORESLACE_KEY = $00031005;


VGAEXTRALORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1557

const VGAEXTRALORESLACEDPF2_KEY = $00031445;


VGAEXTRALORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1551

const VGAEXTRALORESLACEDPF_KEY = $00031405;


VGAHAM_KEY

Declaration

Source position: agraphics.pas line 1543

const VGAHAM_KEY = $00031804;


VGAHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1547

const VGAHAMLACE_KEY = $00031805;


VGALORES_KEY

Declaration

Source position: agraphics.pas line 1541

const VGALORES_KEY = $00039004;


VGALORESDBL_KEY

Declaration

Source position: agraphics.pas line 1578

const VGALORESDBL_KEY = $00039000;


VGALORESDPF2_KEY

Declaration

Source position: agraphics.pas line 1555

const VGALORESDPF2_KEY = $00039444;


VGALORESDPF_KEY

Declaration

Source position: agraphics.pas line 1549

const VGALORESDPF_KEY = $00039404;


VGALORESEHB_KEY

Declaration

Source position: agraphics.pas line 1571

const VGALORESEHB_KEY = $00039084;


VGALORESEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1584

const VGALORESEHBDBL_KEY = $00039080;


VGALORESEHBLACE_KEY

Declaration

Source position: agraphics.pas line 1572

const VGALORESEHBLACE_KEY = $00039085;


VGALORESHAM_KEY

Declaration

Source position: agraphics.pas line 1564

const VGALORESHAM_KEY = $00039804;


VGALORESHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1581

const VGALORESHAMDBL_KEY = $00039800;


VGALORESHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1567

const VGALORESHAMLACE_KEY = $00039805;


VGALORESLACE_KEY

Declaration

Source position: agraphics.pas line 1545

const VGALORESLACE_KEY = $00039005;


VGALORESLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1558

const VGALORESLACEDPF2_KEY = $00039445;


VGALORESLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1552

const VGALORESLACEDPF_KEY = $00039405;


VGAPRODUCT_KEY

Declaration

Source position: agraphics.pas line 1542

const VGAPRODUCT_KEY = $00039024;


VGAPRODUCTDBL_KEY

Declaration

Source position: agraphics.pas line 1579

const VGAPRODUCTDBL_KEY = $00039020;


VGAPRODUCTDPF2_KEY

Declaration

Source position: agraphics.pas line 1556

const VGAPRODUCTDPF2_KEY = $00039464;


VGAPRODUCTDPF_KEY

Declaration

Source position: agraphics.pas line 1550

const VGAPRODUCTDPF_KEY = $00039424;


VGAPRODUCTEHBDBL_KEY

Declaration

Source position: agraphics.pas line 1585

const VGAPRODUCTEHBDBL_KEY = $000390a0;


VGAPRODUCTHAM_KEY

Declaration

Source position: agraphics.pas line 1563

const VGAPRODUCTHAM_KEY = $00039824;


VGAPRODUCTHAMDBL_KEY

Declaration

Source position: agraphics.pas line 1582

const VGAPRODUCTHAMDBL_KEY = $00039820;


VGAPRODUCTHAMLACE_KEY

Declaration

Source position: agraphics.pas line 1566

const VGAPRODUCTHAMLACE_KEY = $00039825;


VGAPRODUCTLACE_KEY

Declaration

Source position: agraphics.pas line 1546

const VGAPRODUCTLACE_KEY = $00039025;


VGAPRODUCTLACEDPF2_KEY

Declaration

Source position: agraphics.pas line 1559

const VGAPRODUCTLACEDPF2_KEY = $00039465;


VGAPRODUCTLACEDPF_KEY

Declaration

Source position: agraphics.pas line 1553

const VGAPRODUCTLACEDPF_KEY = $00039425;


VIEW_EXTRA_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 1083

const VIEW_EXTRA_TYPE = 1;


VIEWPORT_EXTRA_TYPE

TExtendedNode.xln_Subsystem

Declaration

Source position: agraphics.pas line 1084

const VIEWPORT_EXTRA_TYPE = 2;


VP_HIDE

Declaration

Source position: agraphics.pas line 1378

const VP_HIDE = $2000;


VPF_A2024

Declaration

Source position: agraphics.pas line 1382

const VPF_A2024 = $40;


VPF_AGNUS

Declaration

Source position: agraphics.pas line 1383

const VPF_AGNUS = $20;


VPF_TENHZ

Declaration

Source position: agraphics.pas line 1384

const VPF_TENHZ = $20;


VPOSRLOF

Declaration

Source position: agraphics.pas line 1793

const VPOSRLOF = $8000;


VPXB_FREE_ME

Declaration

Source position: agraphics.pas line 1358

const VPXB_FREE_ME = 0;


VPXB_LAST

Declaration

Source position: agraphics.pas line 1360

const VPXB_LAST = 1;


VPXB_STRADDLES_256

Declaration

Source position: agraphics.pas line 1362

const VPXB_STRADDLES_256 = 4;


VPXB_STRADDLES_512

Declaration

Source position: agraphics.pas line 1364

const VPXB_STRADDLES_512 = 5;


VPXF_FREE_ME

Declaration

Source position: agraphics.pas line 1359

const VPXF_FREE_ME = 1 shl VPXB_FREE_ME;


VPXF_LAST

Declaration

Source position: agraphics.pas line 1361

const VPXF_LAST = 1 shl VPXB_LAST;


VPXF_STRADDLES_256

Declaration

Source position: agraphics.pas line 1363

const VPXF_STRADDLES_256 = 1 shl VPXB_STRADDLES_256;


VPXF_STRADDLES_512

Declaration

Source position: agraphics.pas line 1365

const VPXF_STRADDLES_512 = 1 shl VPXB_STRADDLES_512;


VSOVERFLOW

System Set flag for TVsprite.Flags. VSprite overflow (if MUSTDRAW set we draw!)

Declaration

Source position: agraphics.pas line 409

const VSOVERFLOW = $0800;


VSPRITE_f

Declaration

Source position: agraphics.pas line 401

const VSPRITE_f = $0001;


VTAG_ATTACH_CM_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1970

const VTAG_ATTACH_CM_GET = $8000001B;


VTAG_ATTACH_CM_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1954

const VTAG_ATTACH_CM_SET = $8000000B;


VTAG_BATCH_CM_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1956

const VTAG_BATCH_CM_CLR = $8000000D;


VTAG_BATCH_CM_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1971

const VTAG_BATCH_CM_GET = $8000001C;


VTAG_BATCH_CM_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1957

const VTAG_BATCH_CM_SET = $8000000E;


VTAG_BATCH_ITEMS_ADD

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1974

const VTAG_BATCH_ITEMS_ADD = $8000001F;


VTAG_BATCH_ITEMS_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1972

const VTAG_BATCH_ITEMS_GET = $8000001D;


VTAG_BATCH_ITEMS_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1973

const VTAG_BATCH_ITEMS_SET = $8000001E;


VTAG_BITPLANEKEY_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1945

const VTAG_BITPLANEKEY_CLR = $80000002;


VTAG_BITPLANEKEY_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1965

const VTAG_BITPLANEKEY_GET = $80000016;


VTAG_BITPLANEKEY_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1946

const VTAG_BITPLANEKEY_SET = $80000003;


VTAG_BORDERBLANK_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1947

const VTAG_BORDERBLANK_CLR = $80000004;


VTAG_BORDERBLANK_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1966

const VTAG_BORDERBLANK_GET = $80000017;


VTAG_BORDERBLANK_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1948

const VTAG_BORDERBLANK_SET = $80000005;


VTAG_BORDERNOTRANS_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1949

const VTAG_BORDERNOTRANS_CLR = $80000006;


VTAG_BORDERNOTRANS_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1967

const VTAG_BORDERNOTRANS_GET = $80000018;


VTAG_BORDERNOTRANS_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1950

const VTAG_BORDERNOTRANS_SET = $80000007;


VTAG_BORDERSPRITE_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1992

const VTAG_BORDERSPRITE_CLR = $80000030;


VTAG_BORDERSPRITE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1990

const VTAG_BORDERSPRITE_GET = $8000002e;


VTAG_BORDERSPRITE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1991

const VTAG_BORDERSPRITE_SET = $8000002f;


VTAG_CHROMA_PEN_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1951

const VTAG_CHROMA_PEN_CLR = $80000008;


VTAG_CHROMA_PEN_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1968

const VTAG_CHROMA_PEN_GET = $80000019;


VTAG_CHROMA_PEN_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1952

const VTAG_CHROMA_PEN_SET = $80000009;


VTAG_CHROMA_PLANE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1969

const VTAG_CHROMA_PLANE_GET = $8000001A;


VTAG_CHROMA_PLANE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1953

const VTAG_CHROMA_PLANE_SET = $8000000A;


VTAG_CHROMAKEY_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1943

const VTAG_CHROMAKEY_CLR = $80000000;


VTAG_CHROMAKEY_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1964

const VTAG_CHROMAKEY_GET = $80000015;


VTAG_CHROMAKEY_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1944

const VTAG_CHROMAKEY_SET = $80000001;


VTAG_COERCE_DISP_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1960

const VTAG_COERCE_DISP_GET = $80000011;


VTAG_COERCE_DISP_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1961

const VTAG_COERCE_DISP_SET = $80000012;


VTAG_DEFSPRITERESN_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 2004

const VTAG_DEFSPRITERESN_GET = $8000003C;


VTAG_DEFSPRITERESN_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 2003

const VTAG_DEFSPRITERESN_SET = $8000003B;


VTAG_END_CM

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1942

const VTAG_END_CM = $00000000;


VTAG_FULLPALETTE_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 2002

const VTAG_FULLPALETTE_CLR = $8000003A;


VTAG_FULLPALETTE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 2001

const VTAG_FULLPALETTE_GET = $80000039;


VTAG_FULLPALETTE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 2000

const VTAG_FULLPALETTE_SET = $80000038;


VTAG_IMMEDIATE

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1999

const VTAG_IMMEDIATE = $80000037;


VTAG_NEXTBUF_CM

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1955

const VTAG_NEXTBUF_CM = $8000000C;


VTAG_NORMAL_DISP_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1958

const VTAG_NORMAL_DISP_GET = $8000000F;


VTAG_NORMAL_DISP_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1959

const VTAG_NORMAL_DISP_SET = $80000010;


VTAG_PF1_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1982

const VTAG_PF1_BASE_GET = $80000026;


VTAG_PF1_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1986

const VTAG_PF1_BASE_SET = $8000002a;


VTAG_PF1_TO_SPRITEPRI_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1996

const VTAG_PF1_TO_SPRITEPRI_GET = $80000034;


VTAG_PF1_TO_SPRITEPRI_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1995

const VTAG_PF1_TO_SPRITEPRI_SET = $80000033;


VTAG_PF2_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1983

const VTAG_PF2_BASE_GET = $80000027;


VTAG_PF2_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1987

const VTAG_PF2_BASE_SET = $8000002b;


VTAG_PF2_TO_SPRITEPRI_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1998

const VTAG_PF2_TO_SPRITEPRI_GET = $80000036;


VTAG_PF2_TO_SPRITEPRI_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1997

const VTAG_PF2_TO_SPRITEPRI_SET = $80000035;


VTAG_SPEVEN_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1984

const VTAG_SPEVEN_BASE_GET = $80000028;


VTAG_SPEVEN_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1988

const VTAG_SPEVEN_BASE_SET = $8000002c;


VTAG_SPODD_BASE_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1985

const VTAG_SPODD_BASE_GET = $80000029;


VTAG_SPODD_BASE_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1989

const VTAG_SPODD_BASE_SET = $8000002d;


VTAG_SPRITERESN_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1994

const VTAG_SPRITERESN_GET = $80000032;


VTAG_SPRITERESN_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1993

const VTAG_SPRITERESN_SET = $80000031;


VTAG_USERCLIP_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1980

const VTAG_USERCLIP_CLR = $80000025;


VTAG_USERCLIP_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1978

const VTAG_USERCLIP_GET = $80000023;


VTAG_USERCLIP_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1979

const VTAG_USERCLIP_SET = $80000024;


VTAG_VIEWPORTEXTRA_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1962

const VTAG_VIEWPORTEXTRA_GET = $80000013;


VTAG_VIEWPORTEXTRA_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1963

const VTAG_VIEWPORTEXTRA_SET = $80000014;


VTAG_VPMODEID_CLR

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1977

const VTAG_VPMODEID_CLR = $80000022;


VTAG_VPMODEID_GET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1975

const VTAG_VPMODEID_GET = $80000020;


VTAG_VPMODEID_SET

Tag for VideoControl()

Declaration

Source position: agraphics.pas line 1976

const VTAG_VPMODEID_SET = $80000021;


VUserStuff

Declaration

Source position: agraphics.pas line 740

type VUserStuff = SmallInt;


_PDateTime

Declaration

Source position: amigados.pas line 597

type _PDateTime = ^_TDateTime;


_TDateTime

Declaration

Source position: amigados.pas line 598

type _TDateTime = record

  dat_Stamp: TDateStamp;

  dat_Format: Byte;

  dat_Flags: Byte;

  dat_StrDay: PChar;

  dat_StrDate: PChar;

  dat_StrTime: PChar;

end;


ABORT_BUSY

Error report busy at ErrorReport()

Declaration

Source position: amigados.pas line 1592

const ABORT_BUSY = 288;


ABORT_DISK_ERROR

Error report Read write error at ErrorReport()

Declaration

Source position: amigados.pas line 1591

const ABORT_DISK_ERROR = 296;


ACCESS_READ

Parameter for Lock File is readable by others

Declaration

Source position: amigados.pas line 48

const ACCESS_READ = - 2;


ACCESS_WRITE

Parameter for Lock Exclusive lock, so other access allowed

Declaration

Source position: amigados.pas line 50

const ACCESS_WRITE = - 1;


ACTION_ADD_NOTIFY

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1124

const ACTION_ADD_NOTIFY = 4097;


ACTION_CHANGE_FILE_POSITION64

Declaration

Source position: amigados.pas line 1134

const ACTION_CHANGE_FILE_POSITION64 = 8001;


ACTION_CHANGE_FILE_SIZE64

Declaration

Source position: amigados.pas line 1136

const ACTION_CHANGE_FILE_SIZE64 = 8003;


ACTION_CHANGE_MODE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1095

const ACTION_CHANGE_MODE = 1028;


ACTION_CHANGE_SIGNAL

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1077

const ACTION_CHANGE_SIGNAL = 995;


ACTION_COLLECT

Declaration

Source position: amigados.pas line 1111

const ACTION_COLLECT = 3001;


ACTION_COPY_DIR

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1056

const ACTION_COPY_DIR = 19;


ACTION_COPY_LOCK_FH

Declaration

Source position: amigados.pas line 1096

const ACTION_COPY_LOCK_FH = 1030;


ACTION_CREATE_DIR

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1059

const ACTION_CREATE_DIR = 22;


ACTION_CURRENT_VOLUME

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1049

const ACTION_CURRENT_VOLUME = 7;


ACTION_DELETE_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1053

const ACTION_DELETE_OBJECT = 16;


ACTION_DISK_INFO

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1062

const ACTION_DISK_INFO = 25;


ACTION_END

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1085

const ACTION_END = 1007;


ACTION_EVENT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1048

const ACTION_EVENT = 6;


ACTION_EXAMINE_NEXT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1061

const ACTION_EXAMINE_NEXT = 24;


ACTION_EXAMINE_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1060

const ACTION_EXAMINE_OBJECT = 23;


ACTION_EXAMINEDATA

Declaration

Source position: amigados.pas line 1120

const ACTION_EXAMINEDATA = 3030;


ACTION_EXAMINEDATA_DIR

Declaration

Source position: amigados.pas line 1122

const ACTION_EXAMINEDATA_DIR = 3040;


ACTION_EXAMINEDATA_FH

Declaration

Source position: amigados.pas line 1121

const ACTION_EXAMINEDATA_FH = 3031;


ACTION_FH_FROM_LOCK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1093

const ACTION_FH_FROM_LOCK = 1026;


ACTION_FILESYSTEM_ATTR

Declaration

Source position: amigados.pas line 1117

const ACTION_FILESYSTEM_ATTR = 3005;


ACTION_FINDINPUT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1083

const ACTION_FINDINPUT = 1005;


ACTION_FINDOUTPUT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1084

const ACTION_FINDOUTPUT = 1006;


ACTION_FINDUPDATE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1082

const ACTION_FINDUPDATE = 1004;


ACTION_FLUSH

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1064

const ACTION_FLUSH = 27;


ACTION_FORMAT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1089

const ACTION_FORMAT = 1020;


ACTION_FREE_DISK_FSSM

Declaration

Source position: amigados.pas line 1128

const ACTION_FREE_DISK_FSSM = 4202;


ACTION_FREE_LOCK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1052

const ACTION_FREE_LOCK = 15;


ACTION_FREE_RECORD64

Declaration

Source position: amigados.pas line 1139

const ACTION_FREE_RECORD64 = 8011;


ACTION_GET_DISK_FSSM

Declaration

Source position: amigados.pas line 1127

const ACTION_GET_DISK_FSSM = 4201;


ACTION_GET_FILE_POSITION64

Declaration

Source position: amigados.pas line 1135

const ACTION_GET_FILE_POSITION64 = 8002;


ACTION_GET_FILE_SIZE64

Declaration

Source position: amigados.pas line 1137

const ACTION_GET_FILE_SIZE64 = 8004;


ACTION_GID_TO_GROUPINFO

Declaration

Source position: amigados.pas line 1147

const ACTION_GID_TO_GROUPINFO = 20003;


ACTION_GROUPNAME_TO_GID

Declaration

Source position: amigados.pas line 1145

const ACTION_GROUPNAME_TO_GID = 20001;


ACTION_ICONIFY

Declaration

Source position: amigados.pas line 1087

const ACTION_ICONIFY = 1009;


ACTION_INFO

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1063

const ACTION_INFO = 26;


ACTION_INHIBIT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1068

const ACTION_INHIBIT = 31;


ACTION_INHIBIT_DOS_LONGPATH_HANDLING

Declaration

Source position: amigados.pas line 1131

const ACTION_INHIBIT_DOS_LONGPATH_HANDLING = 5323;


ACTION_INT_WRITE_RETURN

Declaration

Source position: amigados.pas line 1081

const ACTION_INT_WRITE_RETURN = 1003;


ACTION_IS_FILESYSTEM

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1094

const ACTION_IS_FILESYSTEM = 1027;


ACTION_LOCATE_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1050

const ACTION_LOCATE_OBJECT = 8;


ACTION_LOCK_RECORD64

Declaration

Source position: amigados.pas line 1138

const ACTION_LOCK_RECORD64 = 8010;


ACTION_MAKE_LINK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1090

const ACTION_MAKE_LINK = 1021;


ACTION_MORE_CACHE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1055

const ACTION_MORE_CACHE = 18;


ACTION_NEWMEMFILE

Declaration

Source position: amigados.pas line 1102

const ACTION_NEWMEMFILE = 1039;


ACTION_NEWMEMLOCK

Declaration

Source position: amigados.pas line 1103

const ACTION_NEWMEMLOCK = 1040;


ACTION_NIL

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1046

const ACTION_NIL = 0;


ACTION_OBTAIN_CON_INFO

Declaration

Source position: amigados.pas line 1118

const ACTION_OBTAIN_CON_INFO = 3006;


ACTION_PARENT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1066

const ACTION_PARENT = 29;


ACTION_PARENT_FH

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1097

const ACTION_PARENT_FH = 1031;


ACTION_READ

Action for TDosPacket.dp_Type = Ord('R') read from Filesystem

Declaration

Source position: amigados.pas line 1073

const ACTION_READ = 82;


ACTION_READ_RETURN

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1079

const ACTION_READ_RETURN = 1001;


ACTION_READ_SOFT_LINK

Declaration

Source position: amigados.pas line 1092

const ACTION_READ_SOFT_LINK = 1024;


ACTION_REMOVE_NOTIFY

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1125

const ACTION_REMOVE_NOTIFY = 4098;


ACTION_RENAME_DISK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1051

const ACTION_RENAME_DISK = 9;


ACTION_RENAME_OBJECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1054

const ACTION_RENAME_OBJECT = 17;


ACTION_SAME_FH

Declaration

Source position: amigados.pas line 1071

const ACTION_SAME_FH = 53;


ACTION_SAME_LOCK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1070

const ACTION_SAME_LOCK = 40;


ACTION_SEEK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1086

const ACTION_SEEK = 1008;


ACTION_SERIALIZE_DISK

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1126

const ACTION_SERIALIZE_DISK = 4200;


ACTION_SET_BLOCKING_MODE

Declaration

Source position: amigados.pas line 1106

const ACTION_SET_BLOCKING_MODE = 1999;


ACTION_SET_COMMENT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1065

const ACTION_SET_COMMENT = 28;


ACTION_SET_DATE

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1069

const ACTION_SET_DATE = 34;


ACTION_SET_OWNER_INFO

Declaration

Source position: amigados.pas line 1100

const ACTION_SET_OWNER_INFO = 1037;


ACTION_SET_PROTECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1058

const ACTION_SET_PROTECT = 21;


ACTION_SHUTDOWN

Declaration

Source position: amigados.pas line 1110

const ACTION_SHUTDOWN = 3000;


ACTION_SINGLE_CHARACTER_MODE

Declaration

Source position: amigados.pas line 1076

const ACTION_SINGLE_CHARACTER_MODE = 994;


ACTION_STARTUP

Declaration

Source position: amigados.pas line 1047

const ACTION_STARTUP = 0;


ACTION_TIMER

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1067

const ACTION_TIMER = 30;


ACTION_UID_TO_USERINFO

Declaration

Source position: amigados.pas line 1146

const ACTION_UID_TO_USERINFO = 20002;


ACTION_USERNAME_TO_UID

Declaration

Source position: amigados.pas line 1144

const ACTION_USERNAME_TO_UID = 20000;


ACTION_WAIT_CHAR

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1057

const ACTION_WAIT_CHAR = 20;


ACTION_WAIT_FOR_DATA

Declaration

Source position: amigados.pas line 1105

const ACTION_WAIT_FOR_DATA = 1998;


ACTION_WRITE

Action for TDosPacket.dp_Type = Ord('W') write to Filesystem

Declaration

Source position: amigados.pas line 1074

const ACTION_WRITE = 87;


ACTION_WRITE_PROTECT

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1091

const ACTION_WRITE_PROTECT = 1023;


ACTION_WRITE_RETURN

Action for TDosPacket.dp_Type

Declaration

Source position: amigados.pas line 1080

const ACTION_WRITE_RETURN = 1002;


ADO_AddColon

Declaration

Source position: amigados.pas line 2257

const ADO_AddColon = ADO_Mask;


ADO_AddedSize

Declaration

Source position: amigados.pas line 2249

const ADO_AddedSize = ADO_Dummy + 6;


ADO_DOSMethodOnly

Declaration

Source position: amigados.pas line 2269

const ADO_DOSMethodOnly = ADO_Dummy + 19;


ADO_DOSType

Declaration

Source position: amigados.pas line 2252

const ADO_DOSType = ADO_Flags;


ADO_Dummy

Tag for AllocDosObject start of Tag range

Declaration

Source position: amigados.pas line 2246

const ADO_Dummy = TAG_USER + 2000;


ADO_ExamineData_CommentSize

Declaration

Source position: amigados.pas line 2271

const ADO_ExamineData_CommentSize = ADO_Dummy + 21;


ADO_ExamineData_LinkSize

Declaration

Source position: amigados.pas line 2272

const ADO_ExamineData_LinkSize = ADO_Dummy + 22;


ADO_ExamineData_NameSize

Declaration

Source position: amigados.pas line 2270

const ADO_ExamineData_NameSize = ADO_Dummy + 20;


ADO_ExamineDir_Context

Declaration

Source position: amigados.pas line 2273

const ADO_ExamineDir_Context = ADO_Dummy + 23;


ADO_Flags

Declaration

Source position: amigados.pas line 2251

const ADO_Flags = ADO_Dummy + 7;


ADO_Mask

Declaration

Source position: amigados.pas line 2256

const ADO_Mask = ADO_Dummy + 8;


ADO_Name

Declaration

Source position: amigados.pas line 2258

const ADO_Name = ADO_Dummy + 9;


ADO_NotifyHook

Declaration

Source position: amigados.pas line 2265

const ADO_NotifyHook = ADO_Dummy + 15;


ADO_NotifyInitial

Declaration

Source position: amigados.pas line 2267

const ADO_NotifyInitial = ADO_Dummy + 17;


ADO_NotifyMethod

Declaration

Source position: amigados.pas line 2261

const ADO_NotifyMethod = ADO_Dummy + 11;


ADO_NotifyName

Declaration

Source position: amigados.pas line 2259

const ADO_NotifyName = ADO_Name;


ADO_NotifyPort

Declaration

Source position: amigados.pas line 2262

const ADO_NotifyPort = ADO_Dummy + 12;


ADO_NotifySignalNumber

Declaration

Source position: amigados.pas line 2264

const ADO_NotifySignalNumber = ADO_Dummy + 14;


ADO_NotifyTask

Declaration

Source position: amigados.pas line 2263

const ADO_NotifyTask = ADO_Dummy + 13;


ADO_NotifyUserData

Declaration

Source position: amigados.pas line 2260

const ADO_NotifyUserData = ADO_Dummy + 10;


ADO_NotifyWaitReply

Declaration

Source position: amigados.pas line 2266

const ADO_NotifyWaitReply = ADO_Dummy + 16;


ADO_Size

Declaration

Source position: amigados.pas line 2268

const ADO_Size = ADO_Dummy + 18;


ADO_Strlen

Declaration

Source position: amigados.pas line 2250

const ADO_Strlen = ADO_AddedSize;


ADO_TermChar

Declaration

Source position: amigados.pas line 2253

const ADO_TermChar = ADO_Flags;


ADO_TermCharStr

Declaration

Source position: amigados.pas line 2247

const ADO_TermCharStr = ADO_Dummy + 0;


ADO_Type

Declaration

Source position: amigados.pas line 2254

const ADO_Type = ADO_Flags;


ADO_Vectors

Declaration

Source position: amigados.pas line 2255

const ADO_Vectors = ADO_Flags;


APB_DIDDIR

Flag Bit for ap_Flags. Marks an an "expired" dir node.

Declaration

Source position: amigados.pas line 733

const APB_DIDDIR = 3;


APB_DirChanged

Flag Bit for ap_Flags. Allow conversion of '.' to CurrentDir

Declaration

Source position: amigados.pas line 736

const APB_DirChanged = 6;


APB_DODIR

Flag Bit for ap_Flags. Marks a Directory

Declaration

Source position: amigados.pas line 731

const APB_DODIR = 2;


APB_DODOT

Flag Bit for ap_Flags.

Declaration

Source position: amigados.pas line 735

const APB_DODOT = 5;


APB_DOWILD

User option ALL

Declaration

Source position: amigados.pas line 728

const APB_DOWILD = 0;


APB_FollowHLinks

Declaration

Source position: amigados.pas line 737

const APB_FollowHLinks = 7;


APB_ITSWILD

Flag Bit for ap_Flags. Set by MatchFirst, used by MatchNext

Declaration

Source position: amigados.pas line 729

const APB_ITSWILD = 1;


APB_MultiAssigns

Declaration

Source position: amigados.pas line 738

const APB_MultiAssigns = 8;


APB_NOMEMERR

Flag Bit for ap_Flags. Set on memory error

Declaration

Source position: amigados.pas line 734

const APB_NOMEMERR = 4;


APF_DIDDIR

Flag Value for ap_Flags. Marks an "expired" dir node.

Declaration

Source position: amigados.pas line 743

const APF_DIDDIR = 1 shl APB_DIDDIR;


APF_DirChanged

Flag Value for ap_Flags. Allow conversion of '.' to CurrentDir

Declaration

Source position: amigados.pas line 746

const APF_DirChanged = 1 shl APB_DirChanged;


APF_DODIR

Flag Value for ap_Flags. Marks a Directories

Declaration

Source position: amigados.pas line 742

const APF_DODIR = 1 shl APB_DODIR;


APF_DODOT

Flag Value for ap_Flags.

Declaration

Source position: amigados.pas line 745

const APF_DODOT = 1 shl APB_DODOT;


APF_DOWILD

Declaration

Source position: amigados.pas line 740

const APF_DOWILD = 1 shl APB_DOWILD;


APF_FollowHLinks

Declaration

Source position: amigados.pas line 747

const APF_FollowHLinks = 1 shl APB_FollowHLinks;


APF_ITSWILD

Flag Value for ap_Flags. Set by MatchFirst, used by MatchNext

Declaration

Source position: amigados.pas line 741

const APF_ITSWILD = 1 shl APB_ITSWILD;


APF_MultiAssigns

Declaration

Source position: amigados.pas line 748

const APF_MultiAssigns = 1 shl APB_MultiAssigns;


APF_NOMEMERR

Flag Value for ap_Flags. Set on memory error

Declaration

Source position: amigados.pas line 744

const APF_NOMEMERR = 1 shl APB_NOMEMERR;


AS_Dummy

Declaration

Source position: amigados.pas line 2175

const AS_Dummy = TAG_USER + 3000;


AS_Entry

Declaration

Source position: amigados.pas line 2177

const AS_Entry = AS_Dummy + 2;


AS_SegmentList

Declaration

Source position: amigados.pas line 2176

const AS_SegmentList = AS_Dummy + 1;


BITSPERBYTE

Numbers of Bits per Byte

Declaration

Source position: amigados.pas line 30

const BITSPERBYTE = 8;


BITSPERLONG

Number of Bits per LongWord

Declaration

Source position: amigados.pas line 32

const BITSPERLONG = 32;


BYTESPERLONG

Number of Bytes per LongWord

Declaration

Source position: amigados.pas line 31

const BYTESPERLONG = 4;


CHANGE_FH

Type for ChangeMode

Declaration

Source position: amigados.pas line 540

const CHANGE_FH = 1;


CHANGE_LOCK

Type for ChangeMode

Declaration

Source position: amigados.pas line 539

const CHANGE_LOCK = 0;


CMD_DISABLED

Declaration

Source position: amigados.pas line 1228

const CMD_DISABLED = - 999;


CMD_INTERNAL

Declaration

Source position: amigados.pas line 1227

const CMD_INTERNAL = - 2;


CMD_SYSTEM

Declaration

Source position: amigados.pas line 1226

const CMD_SYSTEM = - 1;


COMPLEX_BIT

Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers

Declaration

Source position: amigados.pas line 788

const COMPLEX_BIT = 1;


DC_AssignMountR

Declaration

Source position: amigados.pas line 2288

const DC_AssignMountR = DC_Dummy + 12;


DC_AssignMountW

Declaration

Source position: amigados.pas line 2287

const DC_AssignMountW = DC_Dummy + 11;


DC_BootCliCloseGadgetR

Declaration

Source position: amigados.pas line 2294

const DC_BootCliCloseGadgetR = DC_Dummy + 18;


DC_BootCliCloseGadgetW

Declaration

Source position: amigados.pas line 2293

const DC_BootCliCloseGadgetW = DC_Dummy + 17;


DC_BootCliFontSizeR

Declaration

Source position: amigados.pas line 2290

const DC_BootCliFontSizeR = DC_Dummy + 14;


DC_BootCliFontSizeW

Declaration

Source position: amigados.pas line 2289

const DC_BootCliFontSizeW = DC_Dummy + 13;


DC_Dummy

Declaration

Source position: amigados.pas line 2276

const DC_Dummy = TAG_USER + 5000;


DC_FHBufferR

Declaration

Source position: amigados.pas line 2280

const DC_FHBufferR = DC_Dummy + 4;


DC_FHBufferW

Declaration

Source position: amigados.pas line 2279

const DC_FHBufferW = DC_Dummy + 3;


DC_LocaleBaseR

Declaration

Source position: amigados.pas line 2296

const DC_LocaleBaseR = DC_Dummy + 20;


DC_LocaleBaseW

Declaration

Source position: amigados.pas line 2295

const DC_LocaleBaseW = DC_Dummy + 19;


DC_MinProcStackR

Declaration

Source position: amigados.pas line 2286

const DC_MinProcStackR = DC_Dummy + 10;


DC_MinProcStackW

Declaration

Source position: amigados.pas line 2285

const DC_MinProcStackW = DC_Dummy + 9;


DC_Reload68KApplistW

Declaration

Source position: amigados.pas line 2291

const DC_Reload68KApplistW = DC_Dummy + 15;


DC_unused1R

Declaration

Source position: amigados.pas line 2292

const DC_unused1R = DC_Dummy + 16;


DC_WarnPostTimeR

Declaration

Source position: amigados.pas line 2282

const DC_WarnPostTimeR = DC_Dummy + 6;


DC_WarnPostTimeW

Declaration

Source position: amigados.pas line 2281

const DC_WarnPostTimeW = DC_Dummy + 5;


DC_WarnWaitTimeR

Declaration

Source position: amigados.pas line 2284

const DC_WarnWaitTimeR = DC_Dummy + 8;


DC_WarnWaitTimeW

Declaration

Source position: amigados.pas line 2283

const DC_WarnWaitTimeW = DC_Dummy + 7;


DC_WildStarR

Declaration

Source position: amigados.pas line 2278

const DC_WildStarR = DC_Dummy + 2;


DC_WildStarW

Declaration

Source position: amigados.pas line 2277

const DC_WildStarW = DC_Dummy + 1;


DDB_AllBit

Declaration

Source position: amigados.pas line 756

const DDB_AllBit = 3;


DDB_Assign

Declaration

Source position: amigados.pas line 757

const DDB_Assign = 4;


DDB_Completed

Declaration

Source position: amigados.pas line 755

const DDB_Completed = 2;


DDB_Device

Declaration

Source position: amigados.pas line 758

const DDB_Device = 5;


DDB_ExaminedBit

Declaration

Source position: amigados.pas line 754

const DDB_ExaminedBit = 1;


DDB_PatternBit

Bit for ap_Current->an_Lock changed since last MatchNext call

Declaration

Source position: amigados.pas line 753

const DDB_PatternBit = 0;


DDF_AllBit

Declaration

Source position: amigados.pas line 762

const DDF_AllBit = 1 shl DDB_AllBit;


DDF_Assign

Declaration

Source position: amigados.pas line 761

const DDF_Assign = 1 shl DDB_Assign;


DDF_Completed

Declaration

Source position: amigados.pas line 763

const DDF_Completed = 1 shl DDB_Completed;


DDF_Device

Declaration

Source position: amigados.pas line 760

const DDF_Device = 1 shl DDB_Device;


DDF_ExaminedBit

Declaration

Source position: amigados.pas line 764

const DDF_ExaminedBit = 1 shl DDB_ExaminedBit;


DDF_PatternBit

Value for ap_Current->an_Lock changed since last MatchNext call

Declaration

Source position: amigados.pas line 765

const DDF_PatternBit = 1 shl DDB_PatternBit;


DE_BAUD

Offset TDosEnvec: in longwords: Baud rate for serial handler

Declaration

Source position: amigados.pas line 1724

const DE_BAUD = 17;


DE_BLKSPERTRACK

Offset TDosEnvec: in longwords: blocks per track. drive specific

Declaration

Source position: amigados.pas line 1711

const DE_BLKSPERTRACK = 5;


DE_BOOTBLOCKS

Offset TDosEnvec: in longwords: Number of blocks containing boot code

Declaration

Source position: amigados.pas line 1726

const DE_BOOTBLOCKS = 19;


DE_BOOTPRI

Offset TDosEnvec: in longwords: Boot priority for autoboot

Declaration

Source position: amigados.pas line 1722

const DE_BOOTPRI = 15;


DE_BUFMEMTYPE

Offset TDosEnvec: in longwords: type of mem to allocate for buffers.

Declaration

Source position: amigados.pas line 1719

const DE_BUFMEMTYPE = 12;


DE_CONTROL

Offset TDosEnvec: in longwords: Control SmallInt for handler/filesystem

Declaration

Source position: amigados.pas line 1725

const DE_CONTROL = 18;


DE_DOSTYPE

Offset TDosEnvec: in longwords: ASCII (HEX) string showing filesystem type

Declaration

Source position: amigados.pas line 1723

const DE_DOSTYPE = 16;


DE_INTERLEAVE

Offset TDosEnvec: in longwords: usually 0

Declaration

Source position: amigados.pas line 1714

const DE_INTERLEAVE = 8;


DE_LOWCYL

Offset TDosEnvec: in longwords: starting cylinder. typically 0

Declaration

Source position: amigados.pas line 1715

const DE_LOWCYL = 9;


DE_MASK

Offset TDosEnvec: in longwords: Address Mask to block out certain memory

Declaration

Source position: amigados.pas line 1721

const DE_MASK = 14;


DE_MAXTRANSFER

Offset TDosEnvec: in longwords: Max number bytes to transfer at a time

Declaration

Source position: amigados.pas line 1720

const DE_MAXTRANSFER = 13;


DE_MEMBUFTYPE

Offset TDosEnvec: in longwords: type of mem to allocate for buffers.

Declaration

Source position: amigados.pas line 1718

const DE_MEMBUFTYPE = 12;


DE_NUMBUFFERS

Offset TDosEnvec: in longwords: starting # of buffers. typically 5

Declaration

Source position: amigados.pas line 1717

const DE_NUMBUFFERS = 11;


DE_NUMHEADS

Offset TDosEnvec: in longwords: # of heads (surfaces). drive specific

Declaration

Source position: amigados.pas line 1709

const DE_NUMHEADS = 3;


DE_PREFAC

Offset TDosEnvec: in longwords: not used; must be 0

Declaration

Source position: amigados.pas line 1713

const DE_PREFAC = 7;


DE_RESERVEDBLKS

Offset TDosEnvec: in longwords: unavailable blocks at start. usually 2

Declaration

Source position: amigados.pas line 1712

const DE_RESERVEDBLKS = 6;


DE_SECORG

Offset TDosEnvec: in longwords: not used; must be 0

Declaration

Source position: amigados.pas line 1708

const DE_SECORG = 2;


DE_SECSPERBLK

Offset TDosEnvec: in longwords: not used; must be 1

Declaration

Source position: amigados.pas line 1710

const DE_SECSPERBLK = 4;


DE_SIZEBLOCK

Offset TDosEnvec: in longwords: standard value is 128

Declaration

Source position: amigados.pas line 1707

const DE_SIZEBLOCK = 1;


DE_TABLESIZE

Offset TDosEnvec: standard value is 11

Declaration

Source position: amigados.pas line 1706

const DE_TABLESIZE = 0;


DE_UPPERCYL

Offset TDosEnvec: in longwords: max cylinder. drive specific

Declaration

Source position: amigados.pas line 1716

const DE_UPPERCYL = 10;


DLT_DEVICE

Type for TDosList.dol_Type identifiers a device

Declaration

Source position: amigados.pas line 1490

const DLT_DEVICE = 0;


DLT_LATE

Type for TDosList.dol_Type identifiers a late binding assign

Declaration

Source position: amigados.pas line 1493

const DLT_LATE = 3;


DLT_LOCK

Declaration

Source position: amigados.pas line 1491

const DLT_LOCK = 1;


DLT_NONBINDING

Type for TDosList.dol_Type identifiers a non binding assign

Declaration

Source position: amigados.pas line 1494

const DLT_NONBINDING = 4;


DLT_PRIVATE

Type for TDosList.dol_Type for internal use

Declaration

Source position: amigados.pas line 1495

const DLT_PRIVATE = - 1;


DLT_VOLUME

Type for TDosList.dol_Type identifiers a volume

Declaration

Source position: amigados.pas line 1492

const DLT_VOLUME = 2;


DMDF_FORCE_DISMOUNT

Declaration

Source position: amigados.pas line 1870

const DMDF_FORCE_DISMOUNT = 1 shl 2;


DMDF_KEEPDEVICE

Declaration

Source position: amigados.pas line 1868

const DMDF_KEEPDEVICE = 1 shl 0;


DMDF_REMOVEDEVICE

Declaration

Source position: amigados.pas line 1869

const DMDF_REMOVEDEVICE = 1 shl 1;


DN_DEVICEONLY

Declaration

Source position: amigados.pas line 542

const DN_DEVICEONLY = 0;


DN_FULLPATH

Declaration

Source position: amigados.pas line 543

const DN_FULLPATH = 1;


DN_ROOTPATH

Declaration

Source position: amigados.pas line 544

const DN_ROOTPATH = 2;


DOS_ANCHORPATH

Declaration

Source position: amigados.pas line 566

const DOS_ANCHORPATH = 6;


DOS_CLI

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 564

const DOS_CLI = 4;


DOS_DOSLIST

Declaration

Source position: amigados.pas line 572

const DOS_DOSLIST = 12;


DOS_EXALLCONTROL

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 561

const DOS_EXALLCONTROL = 1;


DOS_EXAMINEDATA

Declaration

Source position: amigados.pas line 571

const DOS_EXAMINEDATA = 11;


DOS_FIB

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 562

const DOS_FIB = 2;


DOS_FILEHANDLE

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 560

const DOS_FILEHANDLE = 0;


DOS_FREADLINEDATA

Declaration

Source position: amigados.pas line 570

const DOS_FREADLINEDATA = 10;


DOS_FSVECTORPORT

Declaration

Source position: amigados.pas line 574

const DOS_FSVECTORPORT = 14;


DOS_INFODATA

Declaration

Source position: amigados.pas line 567

const DOS_INFODATA = 7;


DOS_LOCK

Declaration

Source position: amigados.pas line 569

const DOS_LOCK = 9;


DOS_NOTIFYREQUEST

Declaration

Source position: amigados.pas line 568

const DOS_NOTIFYREQUEST = 8;


DOS_OWNER_NONE

Declaration

Source position: amigados.pas line 246

const DOS_OWNER_NONE = 0;


DOS_OWNER_ROOT

Declaration

Source position: amigados.pas line 245

const DOS_OWNER_ROOT = 65535;


DOS_RDARGS

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 565

const DOS_RDARGS = 5;


DOS_STDPKT

Type for AllocDosObject/FreeDosObject

Declaration

Source position: amigados.pas line 563

const DOS_STDPKT = 3;


DOS_VOLUMELIST

Declaration

Source position: amigados.pas line 573

const DOS_VOLUMELIST = 13;


DOSFALSE

=0 as False Value for some Amiga functions.

Declaration

Source position: amigados.pas line 28

const DOSFALSE = 0;

Description

Some DOS functions can not handle the freepascal representation of True as -1. This functions expect a 1 as boolean True, for this purpose two constants are defined for True and False

See also

DOSTRUE

=1 as True Value for some Amiga functions.


DOSTRUE

=1 as True Value for some Amiga functions.

Declaration

Source position: amigados.pas line 27

const DOSTRUE = - 1;

Description

Some DOS functions can not handle the freepascal representation of True as -1. This functions expect a 1 as boolean True, for this purpose two constants are defined for True and False

See also

DOSFALSE

=0 as False Value for some Amiga functions.


DP64_INIT

Declaration

Source position: amigados.pas line 1044

const DP64_INIT = - 3;


DTB_FUTURE

Declaration

Source position: amigados.pas line 613

const DTB_FUTURE = 1;


DTB_SUBST

Declaration

Source position: amigados.pas line 612

const DTB_SUBST = 0;


DTF_FUTURE

Declaration

Source position: amigados.pas line 615

const DTF_FUTURE = 1 shl DTB_FUTURE;


DTF_SUBST

Declaration

Source position: amigados.pas line 614

const DTF_SUBST = 1 shl DTB_SUBST;


DVPB_ASSIGNMENT

Declaration

Source position: amigados.pas line 1565

const DVPB_ASSIGNMENT = 18;


DVPB_CONSOLE

Declaration

Source position: amigados.pas line 1569

const DVPB_CONSOLE = 23;


DVPB_CURRDIR

Declaration

Source position: amigados.pas line 1567

const DVPB_CURRDIR = 20;


DVPB_DEVICE

Declaration

Source position: amigados.pas line 1563

const DVPB_DEVICE = 16;


DVPB_FILESYS

Declaration

Source position: amigados.pas line 1570

const DVPB_FILESYS = 24;


DVPB_MULTIASSIGN

Declaration

Source position: amigados.pas line 1561

const DVPB_MULTIASSIGN = 1;


DVPB_PROGDIR

Declaration

Source position: amigados.pas line 1566

const DVPB_PROGDIR = 19;


DVPB_ROOTDIR

Declaration

Source position: amigados.pas line 1568

const DVPB_ROOTDIR = 21;


DVPB_UNLOCK

Flag Bit for TDevProc.dvp_Flags

Declaration

Source position: amigados.pas line 1560

const DVPB_UNLOCK = 0;


DVPB_VOLUME

Declaration

Source position: amigados.pas line 1564

const DVPB_VOLUME = 17;


DVPF_ASSIGNMENT

Declaration

Source position: amigados.pas line 1576

const DVPF_ASSIGNMENT = 1 shl DVPB_ASSIGNMENT;


DVPF_CONSOLE

Declaration

Source position: amigados.pas line 1580

const DVPF_CONSOLE = 1 shl DVPB_CONSOLE;


DVPF_CURRDIR

Declaration

Source position: amigados.pas line 1578

const DVPF_CURRDIR = 1 shl DVPB_CURRDIR;


DVPF_DEVICE

Declaration

Source position: amigados.pas line 1574

const DVPF_DEVICE = 1 shl DVPB_DEVICE;


DVPF_FILESYS

Declaration

Source position: amigados.pas line 1581

const DVPF_FILESYS = 1 shl DVPB_FILESYS;


DVPF_MULTIASSIGN

Declaration

Source position: amigados.pas line 1573

const DVPF_MULTIASSIGN = 1 shl DVPB_MULTIASSIGN;


DVPF_PROGDIR

Declaration

Source position: amigados.pas line 1577

const DVPF_PROGDIR = 1 shl DVPB_PROGDIR;


DVPF_ROOTDIR

Declaration

Source position: amigados.pas line 1579

const DVPF_ROOTDIR = 1 shl DVPB_ROOTDIR;


DVPF_UNLOCK

Flag Value for TDevProc.dvp_Flags

Declaration

Source position: amigados.pas line 1572

const DVPF_UNLOCK = 1 shl DVPB_UNLOCK;


DVPF_VOLUME

Declaration

Source position: amigados.pas line 1575

const DVPF_VOLUME = 1 shl DVPB_VOLUME;


ED_COMMENT

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1641

const ED_COMMENT = 6;


ED_DATE

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1640

const ED_DATE = 5;


ED_NAME

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1636

const ED_NAME = 1;


ED_OWNER

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1642

const ED_OWNER = 7;


ED_PROTECTION

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1639

const ED_PROTECTION = 4;


ED_SIZE

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1638

const ED_SIZE = 3;


ED_TYPE

Parameter for ExAll()

Declaration

Source position: amigados.pas line 1637

const ED_TYPE = 2;


ERROR_ACTION_NOT_KNOWN

Errorcode of IoErr

Declaration

Source position: amigados.pas line 461

const ERROR_ACTION_NOT_KNOWN = 209;


ERROR_BAD_HUNK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 483

const ERROR_BAD_HUNK = 235;


ERROR_BAD_NUMBER

Errorcode of IoErr

Declaration

Source position: amigados.pas line 446

const ERROR_BAD_NUMBER = 115;


ERROR_BAD_SIGNAL_BIT

Declaration

Source position: amigados.pas line 496

const ERROR_BAD_SIGNAL_BIT = 309;


ERROR_BAD_STREAM_NAME

Errorcode of IoErr

Declaration

Source position: amigados.pas line 459

const ERROR_BAD_STREAM_NAME = 206;


ERROR_BAD_TEMPLATE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 445

const ERROR_BAD_TEMPLATE = 114;


ERROR_BREAK

Returns from MatchFirst, MatchNext: A break character was received

Declaration

Source position: amigados.pas line 491

const ERROR_BREAK = 304;


ERROR_BROKEN_PIPE

Declaration

Source position: amigados.pas line 494

const ERROR_BROKEN_PIPE = 307;


ERROR_BUFFER_OVERFLOW

Returns from MatchFirst, MatchNext: User OR internal buffer overflow

Declaration

Source position: amigados.pas line 490

const ERROR_BUFFER_OVERFLOW = 303;


ERROR_COMMENT_TOO_BIG

Errorcode of IoErr

Declaration

Source position: amigados.pas line 472

const ERROR_COMMENT_TOO_BIG = 220;


ERROR_CONTROL_STRING_TOO_LONG

Declaration

Source position: amigados.pas line 504

const ERROR_CONTROL_STRING_TOO_LONG = 405;


ERROR_DELETE_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 474

const ERROR_DELETE_PROTECTED = 222;


ERROR_DEVICE_NAME_MISSING

Declaration

Source position: amigados.pas line 509

const ERROR_DEVICE_NAME_MISSING = 410;


ERROR_DEVICE_NAME_TOO_LONG

Declaration

Source position: amigados.pas line 502

const ERROR_DEVICE_NAME_TOO_LONG = 403;


ERROR_DEVICE_NOT_MOUNTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 470

const ERROR_DEVICE_NOT_MOUNTED = 218;


ERROR_DIR_NOT_FOUND

Errorcode of IoErr

Declaration

Source position: amigados.pas line 457

const ERROR_DIR_NOT_FOUND = 204;


ERROR_DIRECTORY_NOT_EMPTY

Errorcode of IoErr

Declaration

Source position: amigados.pas line 468

const ERROR_DIRECTORY_NOT_EMPTY = 216;


ERROR_DISK_FULL

Errorcode of IoErr

Declaration

Source position: amigados.pas line 473

const ERROR_DISK_FULL = 221;


ERROR_DISK_NOT_VALIDATED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 465

const ERROR_DISK_NOT_VALIDATED = 213;


ERROR_DISK_WRITE_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 466

const ERROR_DISK_WRITE_PROTECTED = 214;


ERROR_EXEC_DEVICE_NAME_TOO_LONG

Declaration

Source position: amigados.pas line 505

const ERROR_EXEC_DEVICE_NAME_TOO_LONG = 406;


ERROR_FILE_NOT_OBJECT

Errorcode of IoErr

Declaration

Source position: amigados.pas line 452

const ERROR_FILE_NOT_OBJECT = 121;


ERROR_HANDLER_CANNOT_BE_STARTED

Declaration

Source position: amigados.pas line 511

const ERROR_HANDLER_CANNOT_BE_STARTED = 412;


ERROR_HANDLER_STRING_TOO_LONG

Declaration

Source position: amigados.pas line 506

const ERROR_HANDLER_STRING_TOO_LONG = 407;


ERROR_INVALID_COMPONENT_NAME

Errorcode of IoErr

Declaration

Source position: amigados.pas line 462

const ERROR_INVALID_COMPONENT_NAME = 210;


ERROR_INVALID_DEVICE_NAME

Declaration

Source position: amigados.pas line 501

const ERROR_INVALID_DEVICE_NAME = 402;


ERROR_INVALID_DEVICE_TYPE

Declaration

Source position: amigados.pas line 500

const ERROR_INVALID_DEVICE_TYPE = 401;


ERROR_INVALID_GLOBAL_VECTOR

Declaration

Source position: amigados.pas line 512

const ERROR_INVALID_GLOBAL_VECTOR = 413;


ERROR_INVALID_LOCK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 463

const ERROR_INVALID_LOCK = 211;


ERROR_INVALID_NUMBER_OF_CYLINDERS

Declaration

Source position: amigados.pas line 510

const ERROR_INVALID_NUMBER_OF_CYLINDERS = 411;


ERROR_INVALID_PACKET_MESSAGE

Declaration

Source position: amigados.pas line 441

const ERROR_INVALID_PACKET_MESSAGE = 101;


ERROR_INVALID_RESIDENT_LIBRARY

Errorcode of IoErr

Declaration

Source position: amigados.pas line 453

const ERROR_INVALID_RESIDENT_LIBRARY = 122;


ERROR_INVALID_SECTOR_SIZE

Declaration

Source position: amigados.pas line 503

const ERROR_INVALID_SECTOR_SIZE = 404;


ERROR_INVALID_TASK_PRIORITY

Declaration

Source position: amigados.pas line 513

const ERROR_INVALID_TASK_PRIORITY = 414;


ERROR_IS_PIPE

Declaration

Source position: amigados.pas line 493

const ERROR_IS_PIPE = 306;


ERROR_IS_SOFT_LINK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 481

const ERROR_IS_SOFT_LINK = 233;


ERROR_KEY_NEEDS_ARG

Errorcode of IoErr

Declaration

Source position: amigados.pas line 448

const ERROR_KEY_NEEDS_ARG = 117;


ERROR_LINE_TOO_LONG

Errorcode of IoErr

Declaration

Source position: amigados.pas line 451

const ERROR_LINE_TOO_LONG = 120;


ERROR_LOCK_COLLISION

Errorcode of IoErr

Declaration

Source position: amigados.pas line 486

const ERROR_LOCK_COLLISION = 241;


ERROR_LOCK_TIMEOUT

Errorcode of IoErr

Declaration

Source position: amigados.pas line 487

const ERROR_LOCK_TIMEOUT = 242;


ERROR_NO_DEFAULT_DIR

Errorcode of IoErr

Declaration

Source position: amigados.pas line 454

const ERROR_NO_DEFAULT_DIR = 201;


ERROR_NO_DISK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 478

const ERROR_NO_DISK = 226;


ERROR_NO_FREE_STORE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 443

const ERROR_NO_FREE_STORE = 103;


ERROR_NO_MORE_ENTRIES

Errorcode of IoErr

Declaration

Source position: amigados.pas line 479

const ERROR_NO_MORE_ENTRIES = 232;


ERROR_NOT_A_DOS_DISK

Errorcode of IoErr

Declaration

Source position: amigados.pas line 477

const ERROR_NOT_A_DOS_DISK = 225;


ERROR_NOT_EXECUTABLE

Returns from MatchFirst, MatchNext: A file has E bit cleared

Declaration

Source position: amigados.pas line 492

const ERROR_NOT_EXECUTABLE = 305;


ERROR_NOT_IMPLEMENTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 484

const ERROR_NOT_IMPLEMENTED = 236;


ERROR_OBJECT_EXISTS

Errorcode of IoErr

Declaration

Source position: amigados.pas line 456

const ERROR_OBJECT_EXISTS = 203;


ERROR_OBJECT_IN_USE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 455

const ERROR_OBJECT_IN_USE = 202;


ERROR_OBJECT_LINKED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 482

const ERROR_OBJECT_LINKED = 234;


ERROR_OBJECT_NOT_FOUND

Errorcode of IoErr

Declaration

Source position: amigados.pas line 458

const ERROR_OBJECT_NOT_FOUND = 205;


ERROR_OBJECT_TOO_LARGE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 460

const ERROR_OBJECT_TOO_LARGE = 207;


ERROR_OBJECT_WRONG_TYPE

Errorcode of IoErr

Declaration

Source position: amigados.pas line 464

const ERROR_OBJECT_WRONG_TYPE = 212;


ERROR_READ_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 476

const ERROR_READ_PROTECTED = 224;


ERROR_RECORD_NOT_LOCKED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 485

const ERROR_RECORD_NOT_LOCKED = 240;


ERROR_RENAME_ACROSS_DEVICES

Errorcode of IoErr

Declaration

Source position: amigados.pas line 467

const ERROR_RENAME_ACROSS_DEVICES = 215;


ERROR_REQUIRED_ARG_MISSING

Errorcode of IoErr

Declaration

Source position: amigados.pas line 447

const ERROR_REQUIRED_ARG_MISSING = 116;


ERROR_SEEK_ERROR

Errorcode of IoErr

Declaration

Source position: amigados.pas line 471

const ERROR_SEEK_ERROR = 219;


ERROR_SIZE_MISSING

Declaration

Source position: amigados.pas line 508

const ERROR_SIZE_MISSING = 409;


ERROR_STARTUP_STRING_TOO_LONG

Declaration

Source position: amigados.pas line 507

const ERROR_STARTUP_STRING_TOO_LONG = 408;


ERROR_TASK_TABLE_FULL

Errorcode of IoErr

Declaration

Source position: amigados.pas line 444

const ERROR_TASK_TABLE_FULL = 105;


ERROR_TOO_MANY_ARGS

Errorcode of IoErr

Declaration

Source position: amigados.pas line 449

const ERROR_TOO_MANY_ARGS = 118;


ERROR_TOO_MANY_LEVELS

Errorcode of IoErr

Declaration

Source position: amigados.pas line 469

const ERROR_TOO_MANY_LEVELS = 217;


ERROR_UNLOCK_ERROR

Errorcode of IoErr

Declaration

Source position: amigados.pas line 488

const ERROR_UNLOCK_ERROR = 243;


ERROR_UNMATCHED_QUOTES

Errorcode of IoErr

Declaration

Source position: amigados.pas line 450

const ERROR_UNMATCHED_QUOTES = 119;


ERROR_UNSUPPORTED_HARDWARE

Declaration

Source position: amigados.pas line 498

const ERROR_UNSUPPORTED_HARDWARE = 350;


ERROR_WOULD_BLOCK

Declaration

Source position: amigados.pas line 495

const ERROR_WOULD_BLOCK = 308;


ERROR_WRITE_PROTECTED

Errorcode of IoErr

Declaration

Source position: amigados.pas line 475

const ERROR_WRITE_PROTECTED = 223;


ERROR_WRONG_PACKET_RETURNED

Declaration

Source position: amigados.pas line 442

const ERROR_WRONG_PACKET_RETURNED = 102;


EX_DataFields

Declaration

Source position: amigados.pas line 2416

const EX_DataFields = EX_Dummy + 10;


EX_DirLock

Declaration

Source position: amigados.pas line 2413

const EX_DirLock = EX_Dummy + 3;


EX_DirLockInput

Declaration

Source position: amigados.pas line 2411

const EX_DirLockInput = EX_Dummy + 3;


EX_DoCurrentDir

Declaration

Source position: amigados.pas line 2419

const EX_DoCurrentDir = EX_Dummy + 13;


EX_Dummy

Declaration

Source position: amigados.pas line 2402

const EX_Dummy = TAG_USER + 6500;


EX_FileHandle

Declaration

Source position: amigados.pas line 2407

const EX_FileHandle = EX_Dummy + 2;


EX_FileHandleInput

Declaration

Source position: amigados.pas line 2406

const EX_FileHandleInput = EX_Dummy + 2;


EX_FileLock

Declaration

Source position: amigados.pas line 2412

const EX_FileLock = EX_Dummy + 3;


EX_FileLockInput

Declaration

Source position: amigados.pas line 2410

const EX_FileLockInput = EX_Dummy + 3;


EX_LockInput

Declaration

Source position: amigados.pas line 2409

const EX_LockInput = EX_Dummy + 3;


EX_MatchFunc

Declaration

Source position: amigados.pas line 2417

const EX_MatchFunc = EX_Dummy + 11;


EX_MatchString

Declaration

Source position: amigados.pas line 2418

const EX_MatchString = EX_Dummy + 12;


EX_ResetContext

Declaration

Source position: amigados.pas line 2421

const EX_ResetContext = EX_Dummy + 14;


EX_StringName

Declaration

Source position: amigados.pas line 2404

const EX_StringName = EX_Dummy + 1;


EX_StringNameInput

Declaration

Source position: amigados.pas line 2403

const EX_StringNameInput = EX_Dummy + 1;


EXCLUSIVE_LOCK

Parameter for Lock Exclusive lock, so other access allowed

Declaration

Source position: amigados.pas line 49

const EXCLUSIVE_LOCK = - 1;


EXDB_ARCHIVE

Declaration

Source position: amigados.pas line 262

const EXDB_ARCHIVE = 4;


EXDB_GRP_DELETE

Declaration

Source position: amigados.pas line 257

const EXDB_GRP_DELETE = 8;


EXDB_GRP_EXECUTE

Declaration

Source position: amigados.pas line 256

const EXDB_GRP_EXECUTE = 9;


EXDB_GRP_READ

Declaration

Source position: amigados.pas line 254

const EXDB_GRP_READ = 11;


EXDB_GRP_WRITE

Declaration

Source position: amigados.pas line 255

const EXDB_GRP_WRITE = 10;


EXDB_HOLD

Declaration

Source position: amigados.pas line 259

const EXDB_HOLD = 7;


EXDB_NO_DELETE

Declaration

Source position: amigados.pas line 266

const EXDB_NO_DELETE = 0;


EXDB_NO_EXECUTE

Declaration

Source position: amigados.pas line 265

const EXDB_NO_EXECUTE = 1;


EXDB_NO_READ

Declaration

Source position: amigados.pas line 263

const EXDB_NO_READ = 3;


EXDB_NO_WRITE

Declaration

Source position: amigados.pas line 264

const EXDB_NO_WRITE = 2;


EXDB_OTR_DELETE

Declaration

Source position: amigados.pas line 253

const EXDB_OTR_DELETE = 12;


EXDB_OTR_EXECUTE

Declaration

Source position: amigados.pas line 252

const EXDB_OTR_EXECUTE = 13;


EXDB_OTR_READ

Declaration

Source position: amigados.pas line 250

const EXDB_OTR_READ = 15;


EXDB_OTR_WRITE

Declaration

Source position: amigados.pas line 251

const EXDB_OTR_WRITE = 14;


EXDB_PURE

Declaration

Source position: amigados.pas line 261

const EXDB_PURE = 5;


EXDB_SCRIPT

Declaration

Source position: amigados.pas line 260

const EXDB_SCRIPT = 6;


EXDF_ARCHIVE

Declaration

Source position: amigados.pas line 281

const EXDF_ARCHIVE = 1 shl EXDB_ARCHIVE;


EXDF_DEFAULT

Declaration

Source position: amigados.pas line 287

const EXDF_DEFAULT = 0;


EXDF_GRP_DELETE

Declaration

Source position: amigados.pas line 276

const EXDF_GRP_DELETE = 1 shl EXDB_GRP_DELETE;


EXDF_GRP_EXECUTE

Declaration

Source position: amigados.pas line 275

const EXDF_GRP_EXECUTE = 1 shl EXDB_GRP_EXECUTE;


EXDF_GRP_READ

Declaration

Source position: amigados.pas line 273

const EXDF_GRP_READ = 1 shl EXDB_GRP_READ;


EXDF_GRP_WRITE

Declaration

Source position: amigados.pas line 274

const EXDF_GRP_WRITE = 1 shl EXDB_GRP_WRITE;


EXDF_HOLD

Declaration

Source position: amigados.pas line 278

const EXDF_HOLD = 1 shl EXDB_HOLD;


EXDF_NO_DELETE

Declaration

Source position: amigados.pas line 285

const EXDF_NO_DELETE = 1 shl EXDB_NO_DELETE;


EXDF_NO_EXECUTE

Declaration

Source position: amigados.pas line 284

const EXDF_NO_EXECUTE = 1 shl EXDB_NO_EXECUTE;


EXDF_NO_READ

Declaration

Source position: amigados.pas line 282

const EXDF_NO_READ = 1 shl EXDB_NO_READ;


EXDF_NO_WRITE

Declaration

Source position: amigados.pas line 283

const EXDF_NO_WRITE = 1 shl EXDB_NO_WRITE;


EXDF_OTR_DELETE

Declaration

Source position: amigados.pas line 272

const EXDF_OTR_DELETE = 1 shl EXDB_OTR_DELETE;


EXDF_OTR_EXECUTE

Declaration

Source position: amigados.pas line 271

const EXDF_OTR_EXECUTE = 1 shl EXDB_OTR_EXECUTE;


EXDF_OTR_READ

Declaration

Source position: amigados.pas line 269

const EXDF_OTR_READ = 1 shl EXDB_OTR_READ;


EXDF_OTR_WRITE

Declaration

Source position: amigados.pas line 270

const EXDF_OTR_WRITE = 1 shl EXDB_OTR_WRITE;


EXDF_PURE

Declaration

Source position: amigados.pas line 280

const EXDF_PURE = 1 shl EXDB_PURE;


EXDF_SCRIPT

Declaration

Source position: amigados.pas line 279

const EXDF_SCRIPT = 1 shl EXDB_SCRIPT;


EXF_ALL

Declaration

Source position: amigados.pas line 220

const EXF_ALL = $FFFF;


EXF_COMMENT

Declaration

Source position: amigados.pas line 205

const EXF_COMMENT = 1 shl 3;


EXF_DATE

Declaration

Source position: amigados.pas line 202

const EXF_DATE = 1 shl 0;


EXF_LINK

Declaration

Source position: amigados.pas line 206

const EXF_LINK = 1 shl 4;


EXF_NAME

Declaration

Source position: amigados.pas line 204

const EXF_NAME = 1 shl 2;


EXF_OBJECTID

Declaration

Source position: amigados.pas line 211

const EXF_OBJECTID = 1 shl 9;


EXF_OWNER

Declaration

Source position: amigados.pas line 208

const EXF_OWNER = 1 shl 6;


EXF_PROTECTION

Declaration

Source position: amigados.pas line 207

const EXF_PROTECTION = 1 shl 5;


EXF_REFCOUNT

Declaration

Source position: amigados.pas line 203

const EXF_REFCOUNT = 1 shl 1;


EXF_SIZE

Declaration

Source position: amigados.pas line 210

const EXF_SIZE = 1 shl 8;


EXF_spare1

Declaration

Source position: amigados.pas line 213

const EXF_spare1 = 1 shl 10;


EXF_spare2

Declaration

Source position: amigados.pas line 214

const EXF_spare2 = 1 shl 11;


EXF_spare3

Declaration

Source position: amigados.pas line 215

const EXF_spare3 = 1 shl 12;


EXF_spare4

Declaration

Source position: amigados.pas line 216

const EXF_spare4 = 1 shl 13;


EXF_spare5

Declaration

Source position: amigados.pas line 217

const EXF_spare5 = 1 shl 14;


EXF_spare6

Declaration

Source position: amigados.pas line 218

const EXF_spare6 = 1 shl 15;


EXF_TYPE

Declaration

Source position: amigados.pas line 209

const EXF_TYPE = 1 shl 7;


EXT_ABS

Declaration

Source position: amigados.pas line 819

const EXT_ABS = 2;


EXT_COMMON

Declaration

Source position: amigados.pas line 822

const EXT_COMMON = 130;


EXT_DEF

Declaration

Source position: amigados.pas line 818

const EXT_DEF = 1;


EXT_DEXT8

Declaration

Source position: amigados.pas line 827

const EXT_DEXT8 = 135;


EXT_DEXT16

Declaration

Source position: amigados.pas line 826

const EXT_DEXT16 = 134;


EXT_DEXT32

Declaration

Source position: amigados.pas line 825

const EXT_DEXT32 = 133;


EXT_REF8

Declaration

Source position: amigados.pas line 824

const EXT_REF8 = 132;


EXT_REF16

Declaration

Source position: amigados.pas line 823

const EXT_REF16 = 131;


EXT_REF32

Declaration

Source position: amigados.pas line 821

const EXT_REF32 = 129;


EXT_RES

Declaration

Source position: amigados.pas line 820

const EXT_RES = 3;


EXT_SYMB

Declaration

Source position: amigados.pas line 817

const EXT_SYMB = 0;


FH_BufferMode

Declaration

Source position: amigados.pas line 2316

const FH_BufferMode = FH_Dummy + 3;


FH_BufferSize

Declaration

Source position: amigados.pas line 2314

const FH_BufferSize = FH_Dummy + 1;


FH_Dummy

Declaration

Source position: amigados.pas line 2312

const FH_Dummy = TAG_USER + 6000;


FH_EndStream

Declaration

Source position: amigados.pas line 2318

const FH_EndStream = FH_Dummy + 5;


FH_Locking

Declaration

Source position: amigados.pas line 2317

const FH_Locking = FH_Dummy + 4;


FH_UserBuffer

Declaration

Source position: amigados.pas line 2315

const FH_UserBuffer = FH_Dummy + 2;


FIBB_ARCHIVE

Protection Bit: Set as archive

Declaration

Source position: amigados.pas line 342

const FIBB_ARCHIVE = 4;

Description

Cleared whenever file is changed

See also

TFileInfoBlock

File information structure


FIBB_DELETE

Protection Bit: file can be deleted

Declaration

Source position: amigados.pas line 346

const FIBB_DELETE = 0;

See also

TFileInfoBlock

File information structure


FIBB_EXECUTE

Protection Bit: file is executable

Declaration

Source position: amigados.pas line 345

const FIBB_EXECUTE = 1;

See also

TFileInfoBlock

File information structure


FIBB_GRP_DELETE

Protection Bit Group: prevent file from being deleted

Declaration

Source position: amigados.pas line 338

const FIBB_GRP_DELETE = 8;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_GRP_EXECUTE

Protection Bit Group: file is executable

Declaration

Source position: amigados.pas line 337

const FIBB_GRP_EXECUTE = 9;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_GRP_READ

Protection Bit Group: file is readable

Declaration

Source position: amigados.pas line 335

const FIBB_GRP_READ = 11;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_GRP_WRITE

Protection Bit Group: file is writable

Declaration

Source position: amigados.pas line 336

const FIBB_GRP_WRITE = 10;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_DELETE

Protection Bit Other: prevent file from being deleted

Declaration

Source position: amigados.pas line 334

const FIBB_OTR_DELETE = 12;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_EXECUTE

Protection Bit Other: file is executable

Declaration

Source position: amigados.pas line 333

const FIBB_OTR_EXECUTE = 13;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_READ

Protection Bit Other: file is readable

Declaration

Source position: amigados.pas line 331

const FIBB_OTR_READ = 15;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_OTR_WRITE

Protection Bit Other: file is writable

Declaration

Source position: amigados.pas line 332

const FIBB_OTR_WRITE = 14;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBB_PURE

Protection Bit program is reentrant and rexecutable

Declaration

Source position: amigados.pas line 341

const FIBB_PURE = 5;

See also

TFileInfoBlock

File information structure


FIBB_READ

Protection Bit: file is readable

Declaration

Source position: amigados.pas line 343

const FIBB_READ = 3;

See also

TFileInfoBlock

File information structure


FIBB_SCRIPT

Protection Bit File can run as script

Declaration

Source position: amigados.pas line 340

const FIBB_SCRIPT = 6;

Description

File is a shell script file can be executed.

See also

TFileInfoBlock

File information structure


FIBB_WRITE

Protection Bit: file is writeable

Declaration

Source position: amigados.pas line 344

const FIBB_WRITE = 2;

See also

TFileInfoBlock

File information structure


FIBF_ARCHIVE

Protection Value File is marked as archived

Declaration

Source position: amigados.pas line 359

const FIBF_ARCHIVE = 16;

Description

Is cleared on every filechange

See also

TFileInfoBlock

File information structure


FIBF_DELETE

Protection Value file can be deleted

Declaration

Source position: amigados.pas line 363

const FIBF_DELETE = 1;

See also

TFileInfoBlock

File information structure


FIBF_EXECUTE

Protection Value file can be exceuted

Declaration

Source position: amigados.pas line 362

const FIBF_EXECUTE = 2;

See also

TFileInfoBlock

File information structure


FIBF_GRP_DELETE

Protection Value Group: Deleteable

Declaration

Source position: amigados.pas line 355

const FIBF_GRP_DELETE = 1 shl FIBB_GRP_DELETE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_GRP_EXECUTE

Protection Value: Group Executeable

Declaration

Source position: amigados.pas line 354

const FIBF_GRP_EXECUTE = 1 shl FIBB_GRP_EXECUTE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_GRP_READ

Protection Value Group Readable

Declaration

Source position: amigados.pas line 352

const FIBF_GRP_READ = 1 shl FIBB_GRP_READ;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_GRP_WRITE

Protection Value Group Writeable

Declaration

Source position: amigados.pas line 353

const FIBF_GRP_WRITE = 1 shl FIBB_GRP_WRITE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_DELETE

Protection Value Other Deleteable

Declaration

Source position: amigados.pas line 351

const FIBF_OTR_DELETE = 1 shl FIBB_OTR_DELETE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_EXECUTE

Protection Value: Other executeable

Declaration

Source position: amigados.pas line 350

const FIBF_OTR_EXECUTE = 1 shl FIBB_OTR_EXECUTE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_READ

Protection Value Other Readable

Declaration

Source position: amigados.pas line 348

const FIBF_OTR_READ = 1 shl FIBB_OTR_READ;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_OTR_WRITE

Protection Value Other writeable

Declaration

Source position: amigados.pas line 349

const FIBF_OTR_WRITE = 1 shl FIBB_OTR_WRITE;

Description

Only on filesystems support users and groups

See also

TFileInfoBlock

File information structure


FIBF_PURE

Protection Value program is reentrant and rexecutable

Declaration

Source position: amigados.pas line 358

const FIBF_PURE = 32;

See also

TFileInfoBlock

File information structure


FIBF_READ

Protection Value: File is readable

Declaration

Source position: amigados.pas line 360

const FIBF_READ = 8;

See also

TFileInfoBlock

File information structure


FIBF_SCRIPT

Protection Value: File is a script

Declaration

Source position: amigados.pas line 357

const FIBF_SCRIPT = 64;

Description

File is a shell script and can be executed

See also

TFileInfoBlock

File information structure


FIBF_WRITE

Protection Value file is writeable

Declaration

Source position: amigados.pas line 361

const FIBF_WRITE = 4;

See also

TFileInfoBlock

File information structure


FileHandle

File handle needed dor all File actions

Declaration

Source position: amigados.pas line 111

type FileHandle = LongInt;


FileLock

Declaration

Source position: amigados.pas line 112

type FileLock = LongInt;


FS_VECTORPORT_VERSION

Declaration

Source position: amigados.pas line 1756

const FS_VECTORPORT_VERSION = 53;


FSA_ActivityFlushTimeoutR

Declaration

Source position: amigados.pas line 2390

const FSA_ActivityFlushTimeoutR = FSA_Dummy + 14;


FSA_ActivityFlushTimeoutW

Declaration

Source position: amigados.pas line 2391

const FSA_ActivityFlushTimeoutW = FSA_Dummy + 15;


FSA_DOSTypeR

Declaration

Source position: amigados.pas line 2389

const FSA_DOSTypeR = FSA_Dummy + 13;


FSA_Dummy

Declaration

Source position: amigados.pas line 2380

const FSA_Dummy = TAG_USER + 9000;


FSA_FileHandleInput

Declaration

Source position: amigados.pas line 2382

const FSA_FileHandleInput = FSA_Dummy + 2;


FSA_FileLockInput

Declaration

Source position: amigados.pas line 2384

const FSA_FileLockInput = FSA_LockInput;


FSA_HasRecycledEntriesR

Declaration

Source position: amigados.pas line 2396

const FSA_HasRecycledEntriesR = FSA_Dummy + 20;


FSA_InactivityFlushTimeoutR

Declaration

Source position: amigados.pas line 2392

const FSA_InactivityFlushTimeoutR = FSA_Dummy + 16;


FSA_InactivityFlushTimeoutW

Declaration

Source position: amigados.pas line 2393

const FSA_InactivityFlushTimeoutW = FSA_Dummy + 17;


FSA_LockInput

Declaration

Source position: amigados.pas line 2383

const FSA_LockInput = FSA_Dummy + 3;


FSA_MaxFileNameLengthR

Declaration

Source position: amigados.pas line 2386

const FSA_MaxFileNameLengthR = FSA_Dummy + 10;


FSA_MaxFileNameLengthW

Declaration

Source position: amigados.pas line 2387

const FSA_MaxFileNameLengthW = FSA_Dummy + 11;


FSA_MaxRecycledEntriesR

Declaration

Source position: amigados.pas line 2394

const FSA_MaxRecycledEntriesR = FSA_Dummy + 18;


FSA_MaxRecycledEntriesW

Declaration

Source position: amigados.pas line 2395

const FSA_MaxRecycledEntriesW = FSA_Dummy + 19;


FSA_MsgPortInput

Declaration

Source position: amigados.pas line 2385

const FSA_MsgPortInput = FSA_Dummy + 4;


FSA_StringNameInput

Declaration

Source position: amigados.pas line 2381

const FSA_StringNameInput = FSA_Dummy + 1;


FSA_VersionNumberR

Declaration

Source position: amigados.pas line 2388

const FSA_VersionNumberR = FSA_Dummy + 12;


FSA_VersionStringR

Declaration

Source position: amigados.pas line 2397

const FSA_VersionStringR = FSA_Dummy + 21;


FSA_VersionStringR_BufSize

Declaration

Source position: amigados.pas line 2398

const FSA_VersionStringR_BufSize = FSA_Dummy + 22;


FSA_VersionStringR_Len

Declaration

Source position: amigados.pas line 2399

const FSA_VersionStringR_Len = FSA_VersionStringR_BufSize;


FSO_TYPE_DIRECTORY

Declaration

Source position: amigados.pas line 233

const FSO_TYPE_DIRECTORY = 2;


FSO_TYPE_FILE

Declaration

Source position: amigados.pas line 232

const FSO_TYPE_FILE = 1;


FSO_TYPE_INVALID

Declaration

Source position: amigados.pas line 237

const FSO_TYPE_INVALID = $FE;


FSO_TYPE_MASK

Declaration

Source position: amigados.pas line 229

const FSO_TYPE_MASK = $FF;


FSO_TYPE_PIPE

Declaration

Source position: amigados.pas line 234

const FSO_TYPE_PIPE = 3;


FSO_TYPE_SOCKET

Declaration

Source position: amigados.pas line 235

const FSO_TYPE_SOCKET = 4;


FSO_TYPE_SOFTLINK

Declaration

Source position: amigados.pas line 231

const FSO_TYPE_SOFTLINK = 0;


FSOF_ALTLINK

Declaration

Source position: amigados.pas line 242

const FSOF_ALTLINK = 1 shl 9;


FSOF_LINK

Declaration

Source position: amigados.pas line 241

const FSOF_LINK = 1 shl 8;


FSVP

Declaration

Source position: amigados.pas line 1828

type FSVP = TFileSystemVectorPort;


GDI_Dummy

Declaration

Source position: amigados.pas line 2147

const GDI_Dummy = TAG_USER + 500;


GDI_FileHandleInput

Declaration

Source position: amigados.pas line 2149

const GDI_FileHandleInput = GDI_Dummy + 2;


GDI_FileLockInput

Declaration

Source position: amigados.pas line 2151

const GDI_FileLockInput = GDI_LockInput;


GDI_InfoData

Declaration

Source position: amigados.pas line 2154

const GDI_InfoData = GDI_Dummy + 11;


GDI_LockInput

Declaration

Source position: amigados.pas line 2150

const GDI_LockInput = GDI_Dummy + 3;


GDI_MsgPortInput

Declaration

Source position: amigados.pas line 2152

const GDI_MsgPortInput = GDI_Dummy + 4;


GDI_StringNameInput

Declaration

Source position: amigados.pas line 2148

const GDI_StringNameInput = GDI_Dummy + 1;


GDI_VolumeRequired

Declaration

Source position: amigados.pas line 2153

const GDI_VolumeRequired = GDI_Dummy + 10;


GPID_PARENT

Declaration

Source position: amigados.pas line 100

const GPID_PARENT = 2;


GPID_PROCESS

Declaration

Source position: amigados.pas line 99

const GPID_PROCESS = 1;


GPSLF_CLI

Declaration

Source position: amigados.pas line 546

const GPSLF_CLI = 1 shl 1;


GPSLF_ENT

Declaration

Source position: amigados.pas line 548

const GPSLF_ENT = 1 shl 3;


GPSLF_RUN

Declaration

Source position: amigados.pas line 549

const GPSLF_RUN = 1 shl 4;


GPSLF_SEG

Declaration

Source position: amigados.pas line 547

const GPSLF_SEG = 1 shl 2;


GSLI_68KFileSize

Declaration

Source position: amigados.pas line 2167

const GSLI_68KFileSize = GSLI_Dummy + 7;


GSLI_68KFileXsum

Declaration

Source position: amigados.pas line 2168

const GSLI_68KFileXsum = GSLI_Dummy + 8;


GSLI_68KHUNK

Declaration

Source position: amigados.pas line 2165

const GSLI_68KHUNK = GSLI_Dummy + 5;


GSLI_68KOVLAY

Declaration

Source position: amigados.pas line 2166

const GSLI_68KOVLAY = GSLI_Dummy + 6;


GSLI_68KPS

Declaration

Source position: amigados.pas line 2163

const GSLI_68KPS = GSLI_Dummy + 3;


GSLI_Data

Declaration

Source position: amigados.pas line 2162

const GSLI_Data = GSLI_Dummy + 2;


GSLI_Dummy

Declaration

Source position: amigados.pas line 2160

const GSLI_Dummy = TAG_USER + 4000;


GSLI_ElfHandle

Declaration

Source position: amigados.pas line 2164

const GSLI_ElfHandle = GSLI_Dummy + 4;


GSLI_HeaderSize

Declaration

Source position: amigados.pas line 2169

const GSLI_HeaderSize = GSLI_Dummy + 9;


GSLI_NATIVE

Declaration

Source position: amigados.pas line 2161

const GSLI_NATIVE = GSLI_Dummy + 1;


GSLI_ResidentStruct

Declaration

Source position: amigados.pas line 2173

const GSLI_ResidentStruct = GSLI_Dummy + 13;


GSLI_ResidentVersionString

Declaration

Source position: amigados.pas line 2172

const GSLI_ResidentVersionString = GSLI_Dummy + 12;


GSLI_SegmentSize

Declaration

Source position: amigados.pas line 2170

const GSLI_SegmentSize = GSLI_Dummy + 10;


GSLI_VersionString

Declaration

Source position: amigados.pas line 2171

const GSLI_VersionString = GSLI_Dummy + 11;


GVB_BINARY_VAR

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2127

const GVB_BINARY_VAR = 10;


GVB_DONT_NULL_TERM

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2128

const GVB_DONT_NULL_TERM = 11;


GVB_GLOBAL_ONLY

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2125

const GVB_GLOBAL_ONLY = 8;


GVB_LOCAL_ONLY

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2126

const GVB_LOCAL_ONLY = 9;


GVB_SAVE_VAR

Flag bit passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2129

const GVB_SAVE_VAR = 12;


GVB_SCAN_ENVARC

Declaration

Source position: amigados.pas line 2130

const GVB_SCAN_ENVARC = 13;


GVB_SCAN_LEVEL

Declaration

Source position: amigados.pas line 2131

const GVB_SCAN_LEVEL = 14;


GVB_SCAN_STARTDIR

Declaration

Source position: amigados.pas line 2133

const GVB_SCAN_STARTDIR = 15;


GVB_SCAN_TOPLEVEL

Declaration

Source position: amigados.pas line 2132

const GVB_SCAN_TOPLEVEL = GVB_SCAN_LEVEL;


GVF_BINARY_VAR

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2138

const GVF_BINARY_VAR = 1 shl GVB_BINARY_VAR;


GVF_DONT_NULL_TERM

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2139

const GVF_DONT_NULL_TERM = 1 shl GVB_DONT_NULL_TERM;


GVF_GLOBAL_ONLY

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2136

const GVF_GLOBAL_ONLY = 1 shl GVB_GLOBAL_ONLY;


GVF_LOCAL_ONLY

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2137

const GVF_LOCAL_ONLY = 1 shl GVB_LOCAL_ONLY;


GVF_SAVE_VAR

Flag value passed to GetVar/SetVar/DeleteVar

Declaration

Source position: amigados.pas line 2140

const GVF_SAVE_VAR = 1 shl GVB_SAVE_VAR;


GVF_SCAN_ENVARC

Declaration

Source position: amigados.pas line 2141

const GVF_SCAN_ENVARC = 1 shl GVB_SCAN_ENVARC;


GVF_SCAN_LEVEL

Declaration

Source position: amigados.pas line 2142

const GVF_SCAN_LEVEL = 1 shl GVB_SCAN_LEVEL;


GVF_SCAN_STARTDIR

Declaration

Source position: amigados.pas line 2143

const GVF_SCAN_STARTDIR = 1 shl GVB_SCAN_STARTDIR;


HUNK_BREAK

Declaration

Source position: amigados.pas line 807

const HUNK_BREAK = 1014;


HUNK_BSS

Declaration

Source position: amigados.pas line 796

const HUNK_BSS = 1003;


HUNK_CODE

Declaration

Source position: amigados.pas line 794

const HUNK_CODE = 1001;


HUNK_DATA

Declaration

Source position: amigados.pas line 795

const HUNK_DATA = 1002;


HUNK_DEBUG

Declaration

Source position: amigados.pas line 802

const HUNK_DEBUG = 1009;


HUNK_DREL8

Declaration

Source position: amigados.pas line 811

const HUNK_DREL8 = 1017;


HUNK_DREL16

Declaration

Source position: amigados.pas line 810

const HUNK_DREL16 = 1016;


HUNK_DREL32

Declaration

Source position: amigados.pas line 809

const HUNK_DREL32 = 1015;


HUNK_END

Declaration

Source position: amigados.pas line 803

const HUNK_END = 1010;


HUNK_EXT

Declaration

Source position: amigados.pas line 800

const HUNK_EXT = 1007;


HUNK_HEADER

Declaration

Source position: amigados.pas line 804

const HUNK_HEADER = 1011;


HUNK_INDEX

Declaration

Source position: amigados.pas line 814

const HUNK_INDEX = 1019;


HUNK_LIB

Declaration

Source position: amigados.pas line 813

const HUNK_LIB = 1018;


HUNK_NAME

Declaration

Source position: amigados.pas line 793

const HUNK_NAME = 1000;


HUNK_OVERLAY

Declaration

Source position: amigados.pas line 806

const HUNK_OVERLAY = 1013;


HUNK_RELOC8

Declaration

Source position: amigados.pas line 799

const HUNK_RELOC8 = 1006;


HUNK_RELOC16

Declaration

Source position: amigados.pas line 798

const HUNK_RELOC16 = 1005;


HUNK_RELOC32

Declaration

Source position: amigados.pas line 797

const HUNK_RELOC32 = 1004;


HUNK_SYMBOL

Declaration

Source position: amigados.pas line 801

const HUNK_SYMBOL = 1008;


HUNK_UNIT

Declaration

Source position: amigados.pas line 792

const HUNK_UNIT = 999;


ID_BOX0_DISK

Declaration

Source position: amigados.pas line 431

const ID_BOX0_DISK = $424F5800;


ID_BUSY_DISK

Declaration

Source position: amigados.pas line 397

const ID_BUSY_DISK = $42555359;


ID_CDFS_DISK

Declaration

Source position: amigados.pas line 401

const ID_CDFS_DISK = Ord('C') shl 24 or Ord('D') shl 16 or Ord('0') shl 8 or $01;


ID_COLLECT_FILEHANDLE

Declaration

Source position: amigados.pas line 1114

const ID_COLLECT_FILEHANDLE = 2;


ID_COLLECT_LOCK

Declaration

Source position: amigados.pas line 1113

const ID_COLLECT_LOCK = 1;


ID_COLLECT_NOTIFICATION

Declaration

Source position: amigados.pas line 1115

const ID_COLLECT_NOTIFICATION = 3;


ID_CON

Declaration

Source position: amigados.pas line 417

const ID_CON = $434F4E00;


ID_DOS_DISK

Flag for Info .id_Diskstate DOS#0 OFS disk

Declaration

Source position: amigados.pas line 403

const ID_DOS_DISK = $444F5300;


ID_EXFAT_DISK

Declaration

Source position: amigados.pas line 432

const ID_EXFAT_DISK = $46415458;


ID_EXT2_DISK

Declaration

Source position: amigados.pas line 433

const ID_EXT2_DISK = $45585402;


ID_FASTDIR_DOS_DISK

Declaration

Source position: amigados.pas line 407

const ID_FASTDIR_DOS_DISK = $444F5304;


ID_FASTDIR_FFS_DISK

Declaration

Source position: amigados.pas line 408

const ID_FASTDIR_FFS_DISK = $444F5305;


ID_FAT00_DISK

Declaration

Source position: amigados.pas line 426

const ID_FAT00_DISK = Ord('F') shl 24 or Ord('A') shl 16 or Ord('T') shl 8 or $00;


ID_FAT01_DISK

Declaration

Source position: amigados.pas line 427

const ID_FAT01_DISK = Ord('F') shl 24 or Ord('A') shl 16 or Ord('T') shl 8 or $01;


ID_FAT32_DISK

Declaration

Source position: amigados.pas line 428

const ID_FAT32_DISK = Ord('F') shl 24 or Ord('A') shl 16 or Ord('T') shl 8 or $32;


ID_FFS_DISK

Flag for Info .id_Diskstate DOS#1 FFS disk

Declaration

Source position: amigados.pas line 404

const ID_FFS_DISK = $444F5301;


ID_HFS_DISK

Declaration

Source position: amigados.pas line 434

const ID_HFS_DISK = $48465300;


ID_INTER_DOS_DISK

Declaration

Source position: amigados.pas line 405

const ID_INTER_DOS_DISK = $444F5302;


ID_INTER_FFS_DISK

Declaration

Source position: amigados.pas line 406

const ID_INTER_FFS_DISK = $444F5303;


ID_KICKSTART_DISK

Flag for Info .id_Diskstate KICK Kickstart Disk

Declaration

Source position: amigados.pas line 400

const ID_KICKSTART_DISK = $4B49434B;


ID_LONGNAME_DOS_DISK

Declaration

Source position: amigados.pas line 409

const ID_LONGNAME_DOS_DISK = $444F5306;


ID_LONGNAME_FFS_DISK

Declaration

Source position: amigados.pas line 410

const ID_LONGNAME_FFS_DISK = $444F5307;


ID_MSDOS_DISK

Flag for Info .id_Diskstate MSD#0 MSDos Disk

Declaration

Source position: amigados.pas line 421

const ID_MSDOS_DISK = Ord('M') shl 24 or Ord('S') shl 16 or Ord('D') shl 8 or $00;


ID_MSDOS_DISK_DS

Declaration

Source position: amigados.pas line 423

const ID_MSDOS_DISK_DS = Ord('M') shl 24 or Ord('D') shl 16 or Ord('D') shl 8 or $00;


ID_MSDOS_DISK_HD

Declaration

Source position: amigados.pas line 422

const ID_MSDOS_DISK_HD = Ord('M') shl 24 or Ord('S') shl 16 or Ord('H') shl 8 or $00;


ID_NGFS_DISK

Declaration

Source position: amigados.pas line 414

const ID_NGFS_DISK = $4E474653;


ID_NO_DISK_PRESENT

Flag for Info .id_DiskType No Disk Present

Declaration

Source position: amigados.pas line 395

const ID_NO_DISK_PRESENT = - 1;


ID_NOT_REALLY_DOS

Flag for Info .id_Diskstate NDOS not a dos disk

Declaration

Source position: amigados.pas line 399

const ID_NOT_REALLY_DOS = $4E444F53;


ID_NTFS_DISK

Declaration

Source position: amigados.pas line 435

const ID_NTFS_DISK = $4e544653;


ID_RAWCON

Declaration

Source position: amigados.pas line 418

const ID_RAWCON = $52415700;


ID_SWAP_DISK

Declaration

Source position: amigados.pas line 398

const ID_SWAP_DISK = $53574150;


ID_UNREADABLE_DISK

Flag for Info .id_Diskstate BAD#0 Disk defective

Declaration

Source position: amigados.pas line 396

const ID_UNREADABLE_DISK = $42414400;


ID_VALIDATED

Flag for Info .id_Diskstate Device validated and writeable

Declaration

Source position: amigados.pas line 393

const ID_VALIDATED = 82;


ID_VALIDATING

Flag for Info .id_Diskstate Device is currently validating status

Declaration

Source position: amigados.pas line 392

const ID_VALIDATING = 81;


ID_VP255_DOS_DISK

Declaration

Source position: amigados.pas line 413

const ID_VP255_DOS_DISK = $444F5309;


ID_WRITE_PROTECTED

Flag for Info .id_Diskstate Device is write protected

Declaration

Source position: amigados.pas line 391

const ID_WRITE_PROTECTED = 80;


Reference for unit 'amigados'

File and directory handling routines and types (dos.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility, | Tag Handling, Date routines in utility.library
timer;

Overview

The DOS-Library has functions and types to work with files and directories on floppy discs, hard discs and ram discs.


Reference for unit 'amigados': Constants

ABORT_BUSY | Error report busy at ErrorReport()
ABORT_DISK_ERROR | Error report Read write error at ErrorReport()
ACCESS_READ | Parameter for Lock File is readable by others
ACCESS_WRITE | Parameter for Lock Exclusive lock, so other access allowed
ACTION_ADD_NOTIFY | Action for TDosPacket.dp_Type
ACTION_CHANGE_FILE_POSITION64
ACTION_CHANGE_FILE_SIZE64
ACTION_CHANGE_MODE | Action for TDosPacket.dp_Type
ACTION_CHANGE_SIGNAL | Action for TDosPacket.dp_Type
ACTION_COLLECT
ACTION_COPY_DIR | Action for TDosPacket.dp_Type
ACTION_COPY_LOCK_FH
ACTION_CREATE_DIR | Action for TDosPacket.dp_Type
ACTION_CURRENT_VOLUME | Action for TDosPacket.dp_Type
ACTION_DELETE_OBJECT | Action for TDosPacket.dp_Type
ACTION_DISK_INFO | Action for TDosPacket.dp_Type
ACTION_END | Action for TDosPacket.dp_Type
ACTION_EVENT | Action for TDosPacket.dp_Type
ACTION_EXAMINEDATA
ACTION_EXAMINEDATA_DIR
ACTION_EXAMINEDATA_FH
ACTION_EXAMINE_NEXT | Action for TDosPacket.dp_Type
ACTION_EXAMINE_OBJECT | Action for TDosPacket.dp_Type
ACTION_FH_FROM_LOCK | Action for TDosPacket.dp_Type
ACTION_FILESYSTEM_ATTR
ACTION_FINDINPUT | Action for TDosPacket.dp_Type
ACTION_FINDOUTPUT | Action for TDosPacket.dp_Type
ACTION_FINDUPDATE | Action for TDosPacket.dp_Type
ACTION_FLUSH | Action for TDosPacket.dp_Type
ACTION_FORMAT | Action for TDosPacket.dp_Type
ACTION_FREE_DISK_FSSM
ACTION_FREE_LOCK | Action for TDosPacket.dp_Type
ACTION_FREE_RECORD64
ACTION_GET_DISK_FSSM
ACTION_GET_FILE_POSITION64
ACTION_GET_FILE_SIZE64
ACTION_GID_TO_GROUPINFO
ACTION_GROUPNAME_TO_GID
ACTION_ICONIFY
ACTION_INFO | Action for TDosPacket.dp_Type
ACTION_INHIBIT | Action for TDosPacket.dp_Type
ACTION_INHIBIT_DOS_LONGPATH_HANDLING
ACTION_INT_WRITE_RETURN
ACTION_IS_FILESYSTEM | Action for TDosPacket.dp_Type
ACTION_LOCATE_OBJECT | Action for TDosPacket.dp_Type
ACTION_LOCK_RECORD64
ACTION_MAKE_LINK | Action for TDosPacket.dp_Type
ACTION_MORE_CACHE | Action for TDosPacket.dp_Type
ACTION_NEWMEMFILE
ACTION_NEWMEMLOCK
ACTION_NIL | Action for TDosPacket.dp_Type
ACTION_OBTAIN_CON_INFO
ACTION_PARENT | Action for TDosPacket.dp_Type
ACTION_PARENT_FH | Action for TDosPacket.dp_Type
ACTION_READ | Action for TDosPacket.dp_Type = Ord('R') read from Filesystem
ACTION_READ_RETURN | Action for TDosPacket.dp_Type
ACTION_READ_SOFT_LINK
ACTION_REMOVE_NOTIFY | Action for TDosPacket.dp_Type
ACTION_RENAME_DISK | Action for TDosPacket.dp_Type
ACTION_RENAME_OBJECT | Action for TDosPacket.dp_Type
ACTION_SAME_FH
ACTION_SAME_LOCK | Action for TDosPacket.dp_Type
ACTION_SEEK | Action for TDosPacket.dp_Type
ACTION_SERIALIZE_DISK | Action for TDosPacket.dp_Type
ACTION_SET_BLOCKING_MODE
ACTION_SET_COMMENT | Action for TDosPacket.dp_Type
ACTION_SET_DATE | Action for TDosPacket.dp_Type
ACTION_SET_OWNER_INFO
ACTION_SET_PROTECT | Action for TDosPacket.dp_Type
ACTION_SHUTDOWN
ACTION_SINGLE_CHARACTER_MODE
ACTION_STARTUP
ACTION_TIMER | Action for TDosPacket.dp_Type
ACTION_UID_TO_USERINFO
ACTION_USERNAME_TO_UID
ACTION_WAIT_CHAR | Action for TDosPacket.dp_Type
ACTION_WAIT_FOR_DATA
ACTION_WRITE | Action for TDosPacket.dp_Type = Ord('W') write to Filesystem
ACTION_WRITE_PROTECT | Action for TDosPacket.dp_Type
ACTION_WRITE_RETURN | Action for TDosPacket.dp_Type
ADDCMDPATHNODE_HEAD
ADDCMDPATHNODE_TAIL
ADO_AddColon
ADO_AddedSize
ADO_DOSMethodOnly
ADO_DOSType
ADO_Dummy | Tag for AllocDosObject start of Tag range
ADO_ExamineData_CommentSize
ADO_ExamineData_LinkSize
ADO_ExamineData_NameSize
ADO_ExamineDir_Context
ADO_Flags
ADO_Mask
ADO_Name
ADO_NotifyHook
ADO_NotifyInitial
ADO_NotifyMethod
ADO_NotifyName
ADO_NotifyPort
ADO_NotifySignalNumber
ADO_NotifyTask
ADO_NotifyUserData
ADO_NotifyWaitReply
ADO_Size
ADO_Strlen
ADO_TermChar
ADO_TermCharStr
ADO_Type
ADO_Vectors
APB_DIDDIR | Flag Bit for ap_Flags. Marks an an "expired" dir node.
APB_DirChanged | Flag Bit for ap_Flags. Allow conversion of '.' to CurrentDir
APB_DODIR | Flag Bit for ap_Flags. Marks a Directory
APB_DODOT | Flag Bit for ap_Flags.
APB_DOWILD | User option ALL
APB_FollowHLinks
APB_ITSWILD | Flag Bit for ap_Flags. Set by MatchFirst, used by MatchNext
APB_MultiAssigns
APB_NOMEMERR | Flag Bit for ap_Flags. Set on memory error
APF_DIDDIR | Flag Value for ap_Flags. Marks an "expired" dir node.
APF_DirChanged | Flag Value for ap_Flags. Allow conversion of '.' to CurrentDir
APF_DODIR | Flag Value for ap_Flags. Marks a Directories
APF_DODOT | Flag Value for ap_Flags.
APF_DOWILD |
APF_FollowHLinks
APF_ITSWILD | Flag Value for ap_Flags. Set by MatchFirst, used by MatchNext
APF_MultiAssigns
APF_NOMEMERR | Flag Value for ap_Flags. Set on memory error
AS_Dummy
AS_Entry
AS_SegmentList
BITSPERBYTE | Numbers of Bits per Byte
BITSPERLONG | Number of Bits per LongWord
BYTESPERLONG | Number of Bytes per LongWord
CHANGE_FH | Type for ChangeMode
CHANGE_LOCK | Type for ChangeMode
CMD_DISABLED |
CMD_INTERNAL |
CMD_SYSTEM |
COMPLEX_BIT | Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers
DC_AssignMountR
DC_AssignMountW
DC_BootCliCloseGadgetR
DC_BootCliCloseGadgetW
DC_BootCliFontSizeR
DC_BootCliFontSizeW
DC_Dummy
DC_FHBufferR
DC_FHBufferW
DC_LocaleBaseR
DC_LocaleBaseW
DC_MinProcStackR
DC_MinProcStackW
DC_Reload68KApplistW
DC_unused1R
DC_WarnPostTimeR
DC_WarnPostTimeW
DC_WarnWaitTimeR
DC_WarnWaitTimeW
DC_WildStarR
DC_WildStarW
DDB_AllBit |
DDB_Assign
DDB_Completed |
DDB_Device
DDB_ExaminedBit |
DDB_PatternBit | Bit for ap_Current->an_Lock changed since last MatchNext call
DDF_AllBit |
DDF_Assign
DDF_Completed |
DDF_Device
DDF_ExaminedBit |
DDF_PatternBit | Value for ap_Current->an_Lock changed since last MatchNext call
DE_BAUD | Offset TDosEnvec: in longwords: Baud rate for serial handler
DE_BLKSPERTRACK | Offset TDosEnvec: in longwords: blocks per track. drive specific
DE_BOOTBLOCKS | Offset TDosEnvec: in longwords: Number of blocks containing boot code
DE_BOOTPRI | Offset TDosEnvec: in longwords: Boot priority for autoboot
DE_BUFMEMTYPE | Offset TDosEnvec: in longwords: type of mem to allocate for buffers.
DE_CONTROL | Offset TDosEnvec: in longwords: Control SmallInt for handler/filesystem
DE_DOSTYPE | Offset TDosEnvec: in longwords: ASCII (HEX) string showing filesystem type
DE_INTERLEAVE | Offset TDosEnvec: in longwords: usually 0
DE_LOWCYL | Offset TDosEnvec: in longwords: starting cylinder. typically 0
DE_MASK | Offset TDosEnvec: in longwords: Address Mask to block out certain memory
DE_MAXTRANSFER | Offset TDosEnvec: in longwords: Max number bytes to transfer at a time
DE_MEMBUFTYPE | Offset TDosEnvec: in longwords: type of mem to allocate for buffers.
DE_NUMBUFFERS | Offset TDosEnvec: in longwords: starting # of buffers. typically 5
DE_NUMHEADS | Offset TDosEnvec: in longwords: # of heads (surfaces). drive specific
DE_PREFAC | Offset TDosEnvec: in longwords: not used; must be 0
DE_RESERVEDBLKS | Offset TDosEnvec: in longwords: unavailable blocks at start. usually 2
DE_SECORG | Offset TDosEnvec: in longwords: not used; must be 0
DE_SECSPERBLK | Offset TDosEnvec: in longwords: not used; must be 1
DE_SIZEBLOCK | Offset TDosEnvec: in longwords: standard value is 128
DE_TABLESIZE | Offset TDosEnvec: standard value is 11
DE_UPPERCYL | Offset TDosEnvec: in longwords: max cylinder. drive specific
DLT_DEVICE | Type for TDosList.dol_Type identifiers a device
DLT_LATE | Type for TDosList.dol_Type identifiers a late binding assign
DLT_LOCK
DLT_NONBINDING | Type for TDosList.dol_Type identifiers a non binding assign
DLT_PRIVATE | Type for TDosList.dol_Type for internal use
DLT_VOLUME | Type for TDosList.dol_Type identifiers a volume
DMDF_FORCE_DISMOUNT
DMDF_KEEPDEVICE
DMDF_REMOVEDEVICE
DN_DEVICEONLY
DN_FULLPATH
DN_ROOTPATH
DOSFALSE | =0 as False Value for some Amiga functions.
DOSTRUE | =1 as True Value for some Amiga functions.
DOS_ANCHORPATH
DOS_CLI | Type for AllocDosObject/FreeDosObject
DOS_DOSLIST
DOS_EXALLCONTROL | Type for AllocDosObject/FreeDosObject
DOS_EXAMINEDATA
DOS_FIB | Type for AllocDosObject/FreeDosObject
DOS_FILEHANDLE | Type for AllocDosObject/FreeDosObject
DOS_FREADLINEDATA
DOS_FSVECTORPORT
DOS_INFODATA
DOS_LOCK
DOS_NOTIFYREQUEST
DOS_OWNER_NONE
DOS_OWNER_ROOT
DOS_RDARGS | Type for AllocDosObject/FreeDosObject
DOS_STDPKT | Type for AllocDosObject/FreeDosObject
DOS_VOLUMELIST
DP64_INIT
DTB_FUTURE |
DTB_SUBST |
DTF_FUTURE |
DTF_SUBST |
DVPB_ASSIGNMENT
DVPB_CONSOLE
DVPB_CURRDIR
DVPB_DEVICE
DVPB_FILESYS
DVPB_MULTIASSIGN
DVPB_PROGDIR
DVPB_ROOTDIR
DVPB_UNLOCK | Flag Bit for TDevProc.dvp_Flags
DVPB_VOLUME
DVPF_ASSIGNMENT
DVPF_CONSOLE
DVPF_CURRDIR
DVPF_DEVICE
DVPF_FILESYS
DVPF_MULTIASSIGN
DVPF_PROGDIR
DVPF_ROOTDIR
DVPF_UNLOCK | Flag Value for TDevProc.dvp_Flags
DVPF_VOLUME
ED_COMMENT | Parameter for ExAll()
ED_DATE | Parameter for ExAll()
ED_NAME | Parameter for ExAll()
ED_OWNER | Parameter for ExAll()
ED_PROTECTION | Parameter for ExAll()
ED_SIZE | Parameter for ExAll()
ED_TYPE | Parameter for ExAll()
ERROR_ACTION_NOT_KNOWN | Errorcode of IoErr
ERROR_BAD_HUNK | Errorcode of IoErr
ERROR_BAD_NUMBER | Errorcode of IoErr
ERROR_BAD_SIGNAL_BIT
ERROR_BAD_STREAM_NAME | Errorcode of IoErr
ERROR_BAD_TEMPLATE | Errorcode of IoErr
ERROR_BREAK | Returns from MatchFirst, MatchNext: A break character was received
ERROR_BROKEN_PIPE
ERROR_BUFFER_OVERFLOW | Returns from MatchFirst, MatchNext: User OR internal buffer overflow
ERROR_COMMENT_TOO_BIG | Errorcode of IoErr
ERROR_CONTROL_STRING_TOO_LONG
ERROR_DELETE_PROTECTED | Errorcode of IoErr
ERROR_DEVICE_NAME_MISSING
ERROR_DEVICE_NAME_TOO_LONG
ERROR_DEVICE_NOT_MOUNTED | Errorcode of IoErr
ERROR_DIRECTORY_NOT_EMPTY | Errorcode of IoErr
ERROR_DIR_NOT_FOUND | Errorcode of IoErr
ERROR_DISK_FULL | Errorcode of IoErr
ERROR_DISK_NOT_VALIDATED | Errorcode of IoErr
ERROR_DISK_WRITE_PROTECTED | Errorcode of IoErr
ERROR_EXEC_DEVICE_NAME_TOO_LONG
ERROR_FILE_NOT_OBJECT | Errorcode of IoErr
ERROR_HANDLER_CANNOT_BE_STARTED
ERROR_HANDLER_STRING_TOO_LONG
ERROR_INVALID_COMPONENT_NAME | Errorcode of IoErr
ERROR_INVALID_DEVICE_NAME
ERROR_INVALID_DEVICE_TYPE
ERROR_INVALID_GLOBAL_VECTOR
ERROR_INVALID_LOCK | Errorcode of IoErr
ERROR_INVALID_NUMBER_OF_CYLINDERS
ERROR_INVALID_PACKET_MESSAGE
ERROR_INVALID_RESIDENT_LIBRARY | Errorcode of IoErr
ERROR_INVALID_SECTOR_SIZE
ERROR_INVALID_TASK_PRIORITY
ERROR_IS_PIPE
ERROR_IS_SOFT_LINK | Errorcode of IoErr
ERROR_KEY_NEEDS_ARG | Errorcode of IoErr
ERROR_LINE_TOO_LONG | Errorcode of IoErr
ERROR_LOCK_COLLISION | Errorcode of IoErr
ERROR_LOCK_TIMEOUT | Errorcode of IoErr
ERROR_NOT_A_DOS_DISK | Errorcode of IoErr
ERROR_NOT_EXECUTABLE | Returns from MatchFirst, MatchNext: A file has E bit cleared
ERROR_NOT_IMPLEMENTED | Errorcode of IoErr
ERROR_NO_DEFAULT_DIR | Errorcode of IoErr
ERROR_NO_DISK | Errorcode of IoErr
ERROR_NO_FREE_STORE | Errorcode of IoErr
ERROR_NO_MORE_ENTRIES | Errorcode of IoErr
ERROR_OBJECT_EXISTS | Errorcode of IoErr
ERROR_OBJECT_IN_USE | Errorcode of IoErr
ERROR_OBJECT_LINKED | Errorcode of IoErr
ERROR_OBJECT_NOT_FOUND | Errorcode of IoErr
ERROR_OBJECT_TOO_LARGE | Errorcode of IoErr
ERROR_OBJECT_WRONG_TYPE | Errorcode of IoErr
ERROR_READ_PROTECTED | Errorcode of IoErr
ERROR_RECORD_NOT_LOCKED | Errorcode of IoErr
ERROR_RENAME_ACROSS_DEVICES | Errorcode of IoErr
ERROR_REQUIRED_ARG_MISSING | Errorcode of IoErr
ERROR_SEEK_ERROR | Errorcode of IoErr
ERROR_SIZE_MISSING
ERROR_STARTUP_STRING_TOO_LONG
ERROR_TASK_TABLE_FULL | Errorcode of IoErr
ERROR_TOO_MANY_ARGS | Errorcode of IoErr
ERROR_TOO_MANY_LEVELS | Errorcode of IoErr
ERROR_UNLOCK_ERROR | Errorcode of IoErr
ERROR_UNMATCHED_QUOTES | Errorcode of IoErr
ERROR_UNSUPPORTED_HARDWARE
ERROR_WOULD_BLOCK
ERROR_WRITE_PROTECTED | Errorcode of IoErr
ERROR_WRONG_PACKET_RETURNED
EXAMINE_BIT | Values for TAnchorPath .an_Status, NOTE: These are the actual bit numbers
EXCLUSIVE_LOCK | Parameter for Lock Exclusive lock, so other access allowed
EXDB_ARCHIVE
EXDB_GRP_DELETE
EXDB_GRP_EXECUTE
EXDB_GRP_READ
EXDB_GRP_WRITE
EXDB_HOLD
EXDB_NO_DELETE
EXDB_NO_EXECUTE
EXDB_NO_READ
EXDB_NO_WRITE
EXDB_OTR_DELETE
EXDB_OTR_EXECUTE
EXDB_OTR_READ
EXDB_OTR_WRITE
EXDB_PURE
EXDB_SCRIPT
EXDF_ARCHIVE
EXDF_DEFAULT
EXDF_GRP_DELETE
EXDF_GRP_EXECUTE
EXDF_GRP_READ
EXDF_GRP_WRITE
EXDF_HOLD
EXDF_NO_DELETE
EXDF_NO_EXECUTE
EXDF_NO_READ
EXDF_NO_WRITE
EXDF_OTR_DELETE
EXDF_OTR_EXECUTE
EXDF_OTR_READ
EXDF_OTR_WRITE
EXDF_PURE
EXDF_SCRIPT
EXF_ALL
EXF_COMMENT
EXF_DATE
EXF_LINK
EXF_NAME
EXF_OBJECTID
EXF_OWNER
EXF_PROTECTION
EXF_REFCOUNT
EXF_SIZE
EXF_spare1
EXF_spare2
EXF_spare3
EXF_spare4
EXF_spare5
EXF_spare6
EXF_TYPE
EXT_ABS |
EXT_COMMON |
EXT_DEF |
EXT_DEXT16 |
EXT_DEXT32 |
EXT_DEXT8 |
EXT_REF16 |
EXT_REF32 |
EXT_REF8 |
EXT_RES |
EXT_SYMB |
EX_DataFields
EX_DirLock
EX_DirLockInput
EX_DoCurrentDir
EX_Dummy
EX_FileHandle
EX_FileHandleInput
EX_FileLock
EX_FileLockInput
EX_LockInput
EX_MatchFunc
EX_MatchString
EX_ResetContext
EX_StringName
EX_StringNameInput
FAULT_MAX | Max Length for error string
FH_BufferMode
FH_BufferSize
FH_Dummy
FH_EndStream
FH_Locking
FH_UserBuffer
FIBB_ARCHIVE | Protection Bit: Set as archive
FIBB_DELETE | Protection Bit: file can be deleted
FIBB_EXECUTE | Protection Bit: file is executable
FIBB_GRP_DELETE | Protection Bit Group: prevent file from being deleted
FIBB_GRP_EXECUTE | Protection Bit Group: file is executable
FIBB_GRP_READ | Protection Bit Group: file is readable
FIBB_GRP_WRITE | Protection Bit Group: file is writable
FIBB_OTR_DELETE | Protection Bit Other: prevent file from being deleted
FIBB_OTR_EXECUTE | Protection Bit Other: file is executable
FIBB_OTR_READ | Protection Bit Other: file is readable
FIBB_OTR_WRITE | Protection Bit Other: file is writable
FIBB_PURE | Protection Bit program is reentrant and rexecutable
FIBB_READ | Protection Bit: file is readable
FIBB_SCRIPT | Protection Bit File can run as script
FIBB_WRITE | Protection Bit: file is writeable
FIBF_ARCHIVE | Protection Value File is marked as archived
FIBF_DELETE | Protection Value file can be deleted
FIBF_EXECUTE | Protection Value file can be exceuted
FIBF_GRP_DELETE | Protection Value Group: Deleteable
FIBF_GRP_EXECUTE | Protection Value: Group Executeable
FIBF_GRP_READ | Protection Value Group Readable
FIBF_GRP_WRITE | Protection Value Group Writeable
FIBF_OTR_DELETE | Protection Value Other Deleteable
FIBF_OTR_EXECUTE | Protection Value: Other executeable
FIBF_OTR_READ | Protection Value Other Readable
FIBF_OTR_WRITE | Protection Value Other writeable
FIBF_PURE | Protection Value program is reentrant and rexecutable
FIBF_READ | Protection Value: File is readable
FIBF_SCRIPT | Protection Value: File is a script
FIBF_WRITE | Protection Value file is writeable
FORMAT_CDN |
FORMAT_DEF |
FORMAT_DOS |
FORMAT_INT |
FORMAT_ISO
FORMAT_MAX |
FORMAT_USA |
FSA_ActivityFlushTimeoutR
FSA_ActivityFlushTimeoutW
FSA_DOSTypeR
FSA_Dummy
FSA_FileHandleInput
FSA_FileLockInput
FSA_HasRecycledEntriesR
FSA_InactivityFlushTimeoutR
FSA_InactivityFlushTimeoutW
FSA_LockInput
FSA_MaxFileNameLengthR
FSA_MaxFileNameLengthW
FSA_MaxRecycledEntriesR
FSA_MaxRecycledEntriesW
FSA_MsgPortInput
FSA_StringNameInput
FSA_VersionNumberR
FSA_VersionStringR
FSA_VersionStringR_BufSize
FSA_VersionStringR_Len
FSOF_ALTLINK
FSOF_LINK
FSO_TYPE_DIRECTORY
FSO_TYPE_FILE
FSO_TYPE_INVALID
FSO_TYPE_MASK
FSO_TYPE_PIPE
FSO_TYPE_SOCKET
FSO_TYPE_SOFTLINK
FS_VECTORPORT_VERSION
GDI_Dummy
GDI_FileHandleInput
GDI_FileLockInput
GDI_InfoData
GDI_LockInput
GDI_MsgPortInput
GDI_StringNameInput
GDI_VolumeRequired
GPID_PARENT
GPID_PROCESS
GPSLF_CLI
GPSLF_ENT
GPSLF_RUN
GPSLF_SEG
GSLI_68KFileSize
GSLI_68KFileXsum
GSLI_68KHUNK
GSLI_68KOVLAY
GSLI_68KPS
GSLI_Data
GSLI_Dummy
GSLI_ElfHandle
GSLI_HeaderSize
GSLI_NATIVE
GSLI_ResidentStruct
GSLI_ResidentVersionString
GSLI_SegmentSize
GSLI_VersionString
GVB_BINARY_VAR | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_DONT_NULL_TERM | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_GLOBAL_ONLY | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_LOCAL_ONLY | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_SAVE_VAR | Flag bit passed to GetVar/SetVar/DeleteVar
GVB_SCAN_ENVARC
GVB_SCAN_LEVEL
GVB_SCAN_STARTDIR
GVB_SCAN_TOPLEVEL
GVF_BINARY_VAR | Flag value passed to GetVar/SetVar/DeleteVar
GVF_DONT_NULL_TERM | Flag value passed to GetVar/SetVar/DeleteVar
GVF_GLOBAL_ONLY | Flag value passed to GetVar/SetVar/DeleteVar
GVF_LOCAL_ONLY | Flag value passed to GetVar/SetVar/DeleteVar
GVF_SAVE_VAR | Flag value passed to GetVar/SetVar/DeleteVar
GVF_SCAN_ENVARC
GVF_SCAN_LEVEL
GVF_SCAN_STARTDIR
HUNK_BREAK |
HUNK_BSS |
HUNK_CODE |
HUNK_DATA |
HUNK_DEBUG |
HUNK_DREL16 |
HUNK_DREL32 |
HUNK_DREL8 |
HUNK_END |
HUNK_EXT |
HUNK_HEADER |
HUNK_INDEX |
HUNK_LIB |
HUNK_NAME |
HUNK_OVERLAY |
HUNK_RELOC16 |
HUNK_RELOC32 |
HUNK_RELOC8 |
HUNK_SYMBOL |
HUNK_UNIT |
ID_BOX0_DISK
ID_BUSY_DISK
ID_CDFS_DISK
ID_COLLECT_FILEHANDLE
ID_COLLECT_LOCK
ID_COLLECT_NOTIFICATION
ID_CON
ID_DOS_DISK | Flag for Info .id_Diskstate DOS#0 OFS disk
ID_EXFAT_DISK
ID_EXT2_DISK
ID_FASTDIR_DOS_DISK
ID_FASTDIR_FFS_DISK
ID_FAT00_DISK
ID_FAT01_DISK
ID_FAT32_DISK
ID_FFS_DISK | Flag for Info .id_Diskstate DOS#1 FFS disk
ID_HFS_DISK
ID_INTER_DOS_DISK
ID_INTER_FFS_DISK
ID_KICKSTART_DISK | Flag for Info .id_Diskstate KICK Kickstart Disk
ID_LONGNAME_DOS_DISK
ID_LONGNAME_FFS_DISK
ID_MSDOS_DISK | Flag for Info .id_Diskstate MSD#0 MSDos Disk
ID_MSDOS_DISK_DS
ID_MSDOS_DISK_HD
ID_NGFS_DISK
ID_NOT_REALLY_DOS | Flag for Info .id_Diskstate NDOS not a dos disk
ID_NO_DISK_PRESENT | Flag for Info .id_DiskType No Disk Present
ID_NTFS_DISK
ID_RAWCON
ID_SWAP_DISK
ID_UNREADABLE_DISK | Flag for Info .id_Diskstate BAD#0 Disk defective
ID_VALIDATED | Flag for Info .id_Diskstate Device validated and writeable
ID_VALIDATING | Flag for Info .id_Diskstate Device is currently validating status
ID_VP255_DOS_DISK
ID_WRITE_PROTECTED | Flag for Info .id_Diskstate Device is write protected
ITEM_EQUAL |
ITEM_ERROR |
ITEM_NOTHING |
ITEM_QUOTED |
ITEM_UNQUOTED |
LDB_ASSIGNS | Flag bit passed to LockDosList()
LDB_DELETE | Flag bit passed to LockDosList()
LDB_DEVICES | Flag bit passed to LockDosList()
LDB_ENTRY | Flag bit passed to LockDosList()
LDB_READ | Flag bit passed to LockDosList()
LDB_VOLUMES | Flag bit passed to LockDosList()
LDB_WRITE | Flag bit passed to LockDosList()
LDF_ALL | Flag value passed to LockDosList()
LDF_ASSIGNS | Flag value passed to LockDosList()
LDF_DELETE | Flag value passed to LockDosList()
LDF_DEVICES | Flag value passed to LockDosList()
LDF_ENTRY | Flag value passed to LockDosList()
LDF_READ | Flag valuepassed to LockDosList()
LDF_VOLUMES | Flag value passed to LockDosList()
LDF_WRITE | Flag value passed to LockDosList()
LEN_DATSTRING |
LINK_HARD | Value for MakeLink Hard link
LINK_SOFT | Value for MakeLink Soft link
LK_Dummy
LK_InfoMask
LK_Mode
LK_Name
LK_ResolveMA
LK_ResolveSL
LK_SoftLinks
LOCKB_ASSIGNMENT
LOCKB_CURRDIR
LOCKB_DEVICE
LOCKB_FILESYS
LOCKB_PROGDIR
LOCKB_ROOTDIR
LOCKB_SOFTLINK_ENDPART
LOCKB_SOFTLINK_MIDPART
LOCKB_VOLUME
LOCKF_ASSIGNMENT
LOCKF_CURRDIR
LOCKF_DEVICE
LOCKF_FILESYS
LOCKF_PROGDIR
LOCKF_ROOTDIR
LOCKF_SOFTLINK_ENDPART
LOCKF_SOFTLINK_MIDPART
LOCKF_VOLUME
LOCK_DIFFERENT | Value returned by SameLock
LOCK_SAME | Value returned by SameLock
LOCK_SAME_HANDLER | Value returned by SameLock
LVB_IGNORE | Bit Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar
LVF_IGNORE | Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar
LV_ALIAS | Bit Definition for TLocalVar.lv_Node.ln_Type defines an alias
LV_TYPE_MASK
LV_VAR | Bit Definition for TLocalVar.lv_Node.ln_Type defines a Variable
MAXINT | Biggest number useable as Integer
MAX_VP_COMMENT
MAX_VP_FILENAME
MAX_VP_SOFTLINK_TARGET
MDT_FileSystem
MDT_Handler
MD_Activate
MD_Baud
MD_BufMemType
MD_Control
MD_Device
MD_DOSType
MD_Dummy
MD_Entry
MD_Flags
MD_GlobVec
MD_Handler
MD_HighCyl
MD_IgnoreFSR
MD_LowCyl
MD_Mask
MD_MaxTransfer
MD_NumBuffers
MD_Port
MD_PreAlloc
MD_Priority
MD_Reserved
MD_SectorSize
MD_SectorsPerBlock
MD_SectorsPerTrack
MD_SegList
MD_StackSize
MD_StartupNumber
MD_StartupString
MD_Surfaces
MD_Unit
MININT | smallest number useable as Integer
MODE_NEWFILE | Parameter for DosOpen Create new file
MODE_OLDFILE | Parameter for DosOpen Open existing file read/write
MODE_READWRITE | Parameter for DosOpen Exclusive read/write file
NBM_ADDDOSENTRY
NBM_CHANGESIGNAL
NBM_DISKINSERTED
NBM_DISKREMOVED
NBM_REMDOSENTRY
NBM_REMFREEDOSENTRY
NBM_RENAMEDOSENTRY
NDLC_END
NHM_ACTION_ADD
NHM_ACTION_CHANGE
NHM_ACTION_DELETE
NHM_ACTION_INITIAL
NOTIFY_CLASS | NotifyMessage Class
NOTIFY_CODE | NotifyMessage Code
NPLC_END
NP_Arguments | Tag for CreateNewProc pointer to argument string (Default empty string)
NP_Child
NP_Cli | Tag for CreateNewProc create a CLI structure for new process (Default False)
NP_CloseError | Tag for CreateNewProc close error output on exit (Default True)
NP_CloseInput | Tag for CreateNewProc Close Input on exit (Default True)
NP_CloseOutput | Tag for CreateNewProc Close Output on ext (Default True)
NP_CommandName | Tag for CreateNewProc command name, valid only for CLI process
NP_ConsolePort
NP_ConsoleTask | Tag for CreateNewProc Pointer to console task (default same as host)
NP_CopyVars | Tag for CreateNewProc boolean to copy local vars to new process (Default True)
NP_CurrentDir | Tag for CreateNewProc Lock (default is host's current dir)
NP_Dummy | Tag for CreateNewProc start of tag range
NP_Entry | Tag for CreateNewProc Entry point to run - mutually exclusive with NP_Seglist
NP_EntryCode
NP_EntryData
NP_Error | Tag for CreateNewProc error filehandle (Default NIL:)
NP_ExitCode | Tag for CreateNewProc code to be called on process exit.
NP_ExitData | Tag for CreateNewProc argument for NP_ExitCode (default nil)
NP_FinalCode
NP_FinalData
NP_FreeSeglist | Tag for CreateNewProc free the seglist when program finished. (Default True)
NP_Input | Tag for CreateNewProc input file handle (Default NIL:)
NP_LocalAlias
NP_LocalVars
NP_LockStack
NP_Name | Tag for CreateNewProc Name for the process (Default New Process)
NP_NotifyOnDeathMessage
NP_NotifyOnDeathSignalBit
NP_NotifyOnDeathSigTask
NP_Output | Tag for CreateNewProc output filehandle (Default NIL:)
NP_OwnerGID
NP_OwnerUID
NP_Path | Tag for CreateNewProc Path, only valid if an CLI process (default copy of host's)
NP_Priority | Tag for CreateNewProc Priority for the new process (Default same as host application)
NP_ProgramDir
NP_Seglist | Tag for CreateNewProc seglist of code to run for the process
NP_StackSize | Tag for CreateNewProc Stacksize for the programm (Default 4000)
NP_unused1
NP_unused2
NP_UserData
NP_WindowPtr | Tag for CreateNewProc Window pointer (default same as host)
NRB_CALL_HOOK
NRB_DOS_NOTIFY_ONLY
NRB_MAGIC | Flag bit for TNotifyRequest.nr_Flags do not set or remove it! Only for use by handlers!
NRB_NOTIFY_INITIAL | Flag bit for TNotifyRequest.nr_Flags
NRB_SEND_MESSAGE | Flag bit for TNotifyRequest.nr_Flags
NRB_SEND_SIGNAL | Flag bit for TNotifyRequest.nr_Flags
NRB_WAIT_REPLY | Flag bit for TNotifyRequest.nr_Flags
NRF_CALL_HOOK
NRF_DOS_NOTIFY_ONLY
NRF_MAGIC | Flag for TNotifyRequest.nr_Flags
NRF_NOTIFY_INITIAL | Flag for TNotifyRequest.nr_Flags
NRF_SEND_MESSAGE | Flag for TNotifyRequest.nr_Flags
NRF_SEND_SIGNAL | Flag for TNotifyRequest.nr_Flags
NRF_WAIT_REPLY | Flag for TNotifyRequest.nr_Flags
NR_HANDLER_FLAGS | Flag for TNotifyRequest.nr_Flags reserved for private use by the handler
NR_HANDLER_MASK
OCD_Dummy
OCD_FileHandleInput
OCD_MsgPortInput
OFFSET_BEGINNING | Parameter for DosSeek Start seek from the beginning of file
OFFSET_CURRENT | Parameter for DosSeek Start the seek from the current position
OFFSET_END | Parameter for DosSeek Start the seek from the end of file
OI_Dummy
OI_OwnerGID
OI_OwnerUID
OI_Process
OI_ProcessInput
OI_StringName
OI_StringNameInput
PRB_CHILDPROCESS
PRB_CLOSEERROR
PRB_CLOSEINPUT | Flag bit for tProcess
PRB_CLOSEOUTPUT | Flag bit for tProcess
PRB_EXTENDED_FLAGS
PRB_FREEARGS_OBSOLETE
PRB_FREECLI | Flag bit for tProcess
PRB_FREECURRDIR | Flag bit for tProcess
PRB_FREESEGLIST | Flag bit for tProcess
PRB_HADCHILDREN
PRB_HANDLERPROCESS
PRB_HASDLNOTIFY
PRB_HASPLNOTIFY
PRB_LOCKSTACK
PRB_SERVERPROCESS
PRB_SHELLPROCESS
PRB_spare08
PRB_spare09
PRB_spare10
PRB_spare11
PRB_spare12
PRB_spare13
PRB_spare14
PRB_spare15
PRB_spare16
PRB_spare17
PRB_spare18
PRB_spare19
PRB_spare20
PRB_spare21
PRB_spare22
PRB_spare23
PRF_CHILDPROCESS
PRF_CLOSEERROR
PRF_CLOSEINPUT | Flag value for tProcess
PRF_CLOSEOUTPUT | Flag value for tProcess
PRF_EXTENDED_FLAGS
PRF_FREEARGS_OBSOLETE
PRF_FREECLI | Flag value for tProcess
PRF_FREECURRDIR | Flag value for tProcess
PRF_FREESEGLIST | Flag value for tProcess
PRF_HADCHILDREN
PRF_HANDLERPROCESS
PRF_HASDLNOTIFY
PRF_HASPLNOTIFY
PRF_LOCKSTACK
PRF_SERVERPROCESS
PRF_SHELLPROCESS
PSIKEY_ELF32
PSIKEY_INIT
PSIKEY_NFSYS
PSIKEY_NOFREE
PSJUMP_MAGIC
P_ANY | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_CLASS | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_NOT | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_NOTCLASS | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_NOTEND | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_OREND | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_ORNEXT | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_ORSTART | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_REPBEG | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_REPEND | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_SINGLE | Internal constants used by wildcard routines of MatchFirst and MatchNext
P_STOP | Internal constants used by wildcard routines of MatchFirst and MatchNext
RDAB_NOALLOC | Flag bit for TRDArgs.RDA_Flags If set, do not allocate extra string space.
RDAB_NOPROMPT | Flag bit for TRDArgs.RDA_Flags Disable reprompting for string input.
RDAB_STDIN | Flag bit for TRDArgs.RDA_Flags use StdIn rather than command line
RDAF_NOALLOC | Flag value for TRDArgs.RDA_Flags If set, do not allocate extra string space.
RDAF_NOPROMPT | Flag value for TRDArgs.RDA_Flags Disable reprompting for string input.
RDAF_STDIN | Flag value for TRDArgs.RDA_Flags use StdIn rather than command line
RECF_DOS_METHOD_ONLY
REC_EXCLUSIVE | Mode for TRecordLock.rec_Mode
REC_EXCLUSIVE_IMMED | Mode for TRecordLock.rec_Mode
REC_MODE_MASK
REC_SHARED | Mode for TRecordLock.rec_Mode
REC_SHARED_IMMED | Mode for TRecordLock.rec_Mode
REPORT_INSERT | Error report ""please inser volume" at ErrorReport()
REPORT_LOCK | Error report Lock at ErrorReport()
REPORT_STREAM | Error report stream at ErrorReport()
REPORT_TASK | Error report task at ErrorReport()
REPORT_VOLUME | Error report volume at ErrorReport()
RETURN_ERROR | Return Level error: errors occour can not finish
RETURN_FAIL | Return level Fail: something really bad happend
RETURN_OK | Return Level OK = no Problem, success
RETURN_WARN | Return level warn: some warnings appear
RLI_CommentChars
RLI_CSourceInput
RLI_Dummy
RLI_EscapeChars
RLI_FileHandleInput
RLI_MultiLine
RLI_Substitute_E
RLI_Substitute_N
RNB_PRIVATE1 |
RNB_WILDSTAR |
RNF_PRIVATE1 |
RNF_WILDSTAR |
RUN_EXECUTE | Type for initial packets to shells from run/newcli/execute/system.
RUN_SYSTEM | Type for initial packets to shells from run/newcli/execute/system.
RUN_SYSTEM_ASYNCH | Type for initial packets to shells from run/newcli/execute/system.
SBM_BLOCKING
SBM_NON_BLOCKING
SHARED_LOCK | Parameter for Lock File is readable by others
SIGBREAKB_CTRL_C | Bit numbers that signal you that a user has issued a break
SIGBREAKB_CTRL_D | Bit numbers that signal you that a user has issued a break
SIGBREAKB_CTRL_E | Bit numbers that signal you that a user has issued a break
SIGBREAKB_CTRL_F | Bit numbers that signal you that a user has issued a break
SIGBREAKF_CTRL_C | Value that signal you that a user has issued a break
SIGBREAKF_CTRL_D | Value that signal you that a user has issued a break
SIGBREAKF_CTRL_E | Value that signal you that a user has issued a break
SIGBREAKF_CTRL_F | Value that signal you that a user has issued a break
ST_FILE | Type for TFileInfoBlock.fib_DirEntryType ordinary file
ST_LINKDIR | Type for TFileInfoBlock.fib_DirEntryType hard link to directory
ST_LINKFILE | Type for TFileInfoBlock.fib_DirEntryType hard link to file
ST_PIPEFILE | Type for TFileInfoBlock.fib_DirEntryType pipes support ExamineFH
ST_ROOT | Type for TFileInfoBlock.fib_DirEntryType root directory of a device
ST_SOFTLINK | Type for TFileInfoBlock.fib_DirEntryType looks like a dir, but may point to a file
ST_USERDIR | Type for TFileInfoBlock.fib_DirEntryType
SYS_Asynch | Tag for SystemTagList run the process asynchron, closes the input/output on exit
SYS_CommandRunMode
SYS_CustomShell | Tag for SystemTagList send to a specific shell (name)
SYS_Dummy | Tag for SystemTagList start of Tag range
SYS_Error
SYS_ExecuteInputStream
SYS_Input | Tag for SystemTagList specifies an input file handle
SYS_Output | Tag for SystemTagList specifies an output file handle
SYS_UserShell | Tag for SystemTagList send to user shell instead of boot shell
TDRIMAGE_DEFAULT
TDRIMAGE_ERROR
TDRIMAGE_INFO
TDRIMAGE_INSERTDISK
TDRIMAGE_QUESTION
TDRIMAGE_WARNING
TDR_Arg1
TDR_Arg10
TDR_Arg2
TDR_Arg3
TDR_Arg4
TDR_Arg5
TDR_Arg6
TDR_Arg7
TDR_Arg8
TDR_Arg9
TDR_ArgArray
TDR_CharSet
TDR_Dummy
TDR_EasyStruct
TDR_FormatString
TDR_GadgetString
TDR_IDCMP_Ptr
TDR_ImageType
TDR_Inactive
TDR_NonBlocking
TDR_Timeout
TDR_TitleString
TDR_Window
TICKS_PER_SECOND | Number of ticks per second. Defines the acuracy of your time
WFDB_READ
WFDB_WRITE
WFDF_READ
WFDF_WRITE


Reference for unit 'amigados': Types

FileHandle | File handle needed dor all File actions
FileLock |
FSVP
PAChain |
PAddressAndSize
PAnchorPath | Structure expected by MatchFirst, MatchNext to find Files.
PAnchorPathOld
pAssignList |
PAssignNode
PCapturedExpression
pCliProcList |
PCommandLineInterface | DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them
PConsoleWindowData
PCSource | Pointer to Input structure for ReadItem and ReadArgs
PDateStamp | Pointer to a Date and Time representation
PDeathMessage
pDeviceList |
PDeviceNode | Pointer to Device node list
pDevInfo |
PDevProc | Structure return by GetDeviceProc()
pDosEnvec | Describes the disk geometry
pDosInfo |
pDosLibrary | This is how the base of dos.library looks like.
PDOSList |
PDosPacket | This is the extension to EXEC Messages used by DOS
PDosPacket64
PDosResidentSeg
pErrorString | A structure for holding error messages - stored as array with error = 0 for the last entry.
PExAllControl | Control structure passed to ExAll().
PExAllData | Structure in which exall results are returned in.
PExamineData
PFileHandle | This pointer is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls
PFileInfoBlock | Pointer to a file information structure
pFileLock | Lock structure, as returned by Lock() or DupLock()
PFileSysStartupMsg | Pointer to filesystem startup message for a device
PFileSystemData
PFileSystemVectorPort
PFileSystemVectors
PFindTrackedAddressMsg
PFReadLineData
PInfoData | General Disk informatons from Info
PLocalVar | Pointer to a Localvars list
PLock
PMultiAssign
PNotifyHookMsg
PNotifyMessage |
PNotifyRequest |
PPathNode
PProcess | All DOS processes have this structure
PPseudoSegList
PRDArgs | Input parameter ReadArgs()
PRecordLock | Parameter for TRecordLock.rec_Mode
pRootNode |
PSearchCmdPathListMsg
PStandardPacket |
PStandardPacket64
PVolumeNode
TAChain |
TAddressAndSize
TAnchorPath | Structure expected by MatchFirst, MatchNext to find Files.
TAnchorPathOld
tAssignList | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure used for multi-directory assigns.
TAssignNode
TCapturedExpression
tCliProcList | Only to be allocated by DOS!
TCommandLineInterface | DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them
TConsoleWindowData
TCSource | Input structure for ReadItem and ReadArgs
TDateStamp | Date and Time representation
TDeathMessage
tDeviceList | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a volume.
TDeviceNode | Device node list DLT_DEVICE
tDevInfo | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a device
TDevProc | Structure return by GetDeviceProc()
tDosEnvec | Describes the disk geometry
tDosInfo |
tDosLibrary | This is how the base of dos.library looks like.
TDOSList | This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure combined structure for devices, assigned directories, volumes.
TDosPacket | This is the extension to EXEC Messages used by DOS
TDosPacket64
TDosResidentSeg
tErrorString | A structure for holding error messages - stored as array with error = 0 for the last entry.
TExAllControl | Control structure passed to ExAll().
TExAllData | Structure in which exall results are returned in. Note that only the fields asked for will exist!
TExamineData
TFileHandle | The pointer of this structure is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls
TFileInfoBlock | File information structure
tFileLock | Lock structure, as returned by Lock() or DupLock()
TFileSysStartupMsg | Filesystem startup message for a device
TFileSystemData
TFileSystemVectorPort
TFileSystemVectors
TFindTrackedAddressMsg
TFReadLineData
TInfoData | General Disk informatons from Info
TLocalVar | The structure in the TProcess.pr_LocalVars list
TLock
TMultiAssign
TNotifyHookMsg
TNotifyMessage |
tNotifyRequest |
TPathNode
TProcess | All DOS processes have this structure
TPseudoSegList
TRDArgs | Input parameter structure used in ReadArgs()
TRecordLock | Parameter struct for TRecordLock.rec_Mode
tRootNode |
TSearchCmdPathListMsg
TStandardPacket |
TStandardPacket64
TVolumeNode
_PDateTime |
_TDateTime |


ITEM_EQUAL

Declaration

Source position: amigados.pas line 554

const ITEM_EQUAL = - 2;


ITEM_ERROR

Declaration

Source position: amigados.pas line 555

const ITEM_ERROR = - 1;


ITEM_NOTHING

Declaration

Source position: amigados.pas line 556

const ITEM_NOTHING = 0;


ITEM_QUOTED

Declaration

Source position: amigados.pas line 558

const ITEM_QUOTED = 2;


ITEM_UNQUOTED

Declaration

Source position: amigados.pas line 557

const ITEM_UNQUOTED = 1;


LDB_ASSIGNS

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 1502

const LDB_ASSIGNS = 4;


LDB_DELETE

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 1504

const LDB_DELETE = 6;


LDB_DEVICES

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 1500

const LDB_DEVICES = 2;


LDB_ENTRY

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 1503

const LDB_ENTRY = 5;


LDB_READ

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 1498

const LDB_READ = 0;


LDB_VOLUMES

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 1501

const LDB_VOLUMES = 3;


LDB_WRITE

Flag bit passed to LockDosList()

Declaration

Source position: amigados.pas line 1499

const LDB_WRITE = 1;


LDF_ALL

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 1518

const LDF_ALL = LDF_DEVICES or LDF_VOLUMES or LDF_ASSIGNS;


LDF_ASSIGNS

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 1513

const LDF_ASSIGNS = 1 shl LDB_ASSIGNS;


LDF_DELETE

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 1515

const LDF_DELETE = 1 shl LDB_DELETE;


LDF_DEVICES

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 1511

const LDF_DEVICES = 1 shl LDB_DEVICES;


LDF_ENTRY

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 1514

const LDF_ENTRY = 1 shl LDB_ENTRY;


LDF_READ

Flag valuepassed to LockDosList()

Declaration

Source position: amigados.pas line 1507

const LDF_READ = 1 shl LDB_READ;


LDF_VOLUMES

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 1512

const LDF_VOLUMES = 1 shl LDB_VOLUMES;


LDF_WRITE

Flag value passed to LockDosList()

Declaration

Source position: amigados.pas line 1508

const LDF_WRITE = 1 shl LDB_WRITE;


LEN_DATSTRING

Declaration

Source position: amigados.pas line 609

const LEN_DATSTRING = 16;


LINK_HARD

Value for MakeLink Hard link

Declaration

Source position: amigados.pas line 551

const LINK_HARD = 0;


LINK_SOFT

Value for MakeLink Soft link

Declaration

Source position: amigados.pas line 552

const LINK_SOFT = 1;


LK_Dummy

Declaration

Source position: amigados.pas line 2179

const LK_Dummy = TAG_USER + 5750;


LK_InfoMask

Declaration

Source position: amigados.pas line 2182

const LK_InfoMask = LK_Dummy + 3;


LK_Mode

Declaration

Source position: amigados.pas line 2181

const LK_Mode = LK_Dummy + 2;


LK_Name

Declaration

Source position: amigados.pas line 2180

const LK_Name = LK_Dummy + 1;


LK_ResolveMA

Declaration

Source position: amigados.pas line 2185

const LK_ResolveMA = LK_Dummy + 6;


LK_ResolveSL

Declaration

Source position: amigados.pas line 2184

const LK_ResolveSL = LK_Dummy + 5;


LK_SoftLinks

Declaration

Source position: amigados.pas line 2183

const LK_SoftLinks = LK_Dummy + 4;


LOCKF_ASSIGNMENT

Declaration

Source position: amigados.pas line 72

const LOCKF_ASSIGNMENT = 1 shl LOCKB_ASSIGNMENT;


LOCKF_CURRDIR

Declaration

Source position: amigados.pas line 74

const LOCKF_CURRDIR = 1 shl LOCKB_CURRDIR;


LOCKF_DEVICE

Declaration

Source position: amigados.pas line 70

const LOCKF_DEVICE = 1 shl LOCKB_DEVICE;


LOCKF_FILESYS

Declaration

Source position: amigados.pas line 76

const LOCKF_FILESYS = 1 shl LOCKB_FILESYS;


LOCKF_PROGDIR

Declaration

Source position: amigados.pas line 73

const LOCKF_PROGDIR = 1 shl LOCKB_PROGDIR;


LOCKF_ROOTDIR

Declaration

Source position: amigados.pas line 75

const LOCKF_ROOTDIR = 1 shl LOCKB_ROOTDIR;


LOCKF_SOFTLINK_ENDPART

Declaration

Source position: amigados.pas line 69

const LOCKF_SOFTLINK_ENDPART = 1 shl LOCKB_SOFTLINK_ENDPART;


LOCKF_SOFTLINK_MIDPART

Declaration

Source position: amigados.pas line 68

const LOCKF_SOFTLINK_MIDPART = 1 shl LOCKB_SOFTLINK_MIDPART;


LOCKF_VOLUME

Declaration

Source position: amigados.pas line 71

const LOCKF_VOLUME = 1 shl LOCKB_VOLUME;


LV_ALIAS

Bit Definition for TLocalVar.lv_Node.ln_Type defines an alias

Declaration

Source position: amigados.pas line 2119

const LV_ALIAS = 1;


LV_TYPE_MASK

Declaration

Source position: amigados.pas line 2122

const LV_TYPE_MASK = $FF;


LV_VAR

Bit Definition for TLocalVar.lv_Node.ln_Type defines a Variable

Declaration

Source position: amigados.pas line 2118

const LV_VAR = 0;


LVB_IGNORE

Bit Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar

Declaration

Source position: amigados.pas line 2121

const LVB_IGNORE = 7;


LVF_IGNORE

Definition for TLocalVar.lv_Node.ln_Type ignore on GetVar

Declaration

Source position: amigados.pas line 2135

const LVF_IGNORE = 1 shl LVB_IGNORE;


MAX_VP_COMMENT

Declaration

Source position: amigados.pas line 107

const MAX_VP_COMMENT = 255;


MAX_VP_FILENAME

Declaration

Source position: amigados.pas line 106

const MAX_VP_FILENAME = 255;


MAX_VP_SOFTLINK_TARGET

Declaration

Source position: amigados.pas line 108

const MAX_VP_SOFTLINK_TARGET = 4000;


MAXINT

Biggest number useable as Integer

Declaration

Source position: amigados.pas line 33

const MAXINT = $7FFFFFFF;


MD_Activate

Declaration

Source position: amigados.pas line 1860

const MD_Activate = MD_Dummy + 25;


MD_Baud

Declaration

Source position: amigados.pas line 1849

const MD_Baud = MD_Dummy + 14;


MD_BufMemType

Declaration

Source position: amigados.pas line 1845

const MD_BufMemType = MD_Dummy + 10;


MD_Control

Declaration

Source position: amigados.pas line 1850

const MD_Control = MD_Dummy + 15;


MD_Device

Declaration

Source position: amigados.pas line 1851

const MD_Device = MD_Dummy + 16;


MD_DOSType

Declaration

Source position: amigados.pas line 1848

const MD_DOSType = MD_Dummy + 13;


MD_Dummy

Declaration

Source position: amigados.pas line 1835

const MD_Dummy = TAG_USER + 4000;


MD_Entry

Declaration

Source position: amigados.pas line 1864

const MD_Entry = MD_Dummy + 29;


MD_Flags

Declaration

Source position: amigados.pas line 1853

const MD_Flags = MD_Dummy + 18;


MD_GlobVec

Declaration

Source position: amigados.pas line 1856

const MD_GlobVec = MD_Dummy + 21;


MD_Handler

Declaration

Source position: amigados.pas line 1861

const MD_Handler = MD_Dummy + 26;


MD_HighCyl

Declaration

Source position: amigados.pas line 1843

const MD_HighCyl = MD_Dummy + 8;


MD_IgnoreFSR

Declaration

Source position: amigados.pas line 1859

const MD_IgnoreFSR = MD_Dummy + 24;


MD_LowCyl

Declaration

Source position: amigados.pas line 1842

const MD_LowCyl = MD_Dummy + 7;


MD_Mask

Declaration

Source position: amigados.pas line 1847

const MD_Mask = MD_Dummy + 12;


MD_MaxTransfer

Declaration

Source position: amigados.pas line 1846

const MD_MaxTransfer = MD_Dummy + 11;


MD_NumBuffers

Declaration

Source position: amigados.pas line 1844

const MD_NumBuffers = MD_Dummy + 9;


MD_Port

Declaration

Source position: amigados.pas line 1863

const MD_Port = MD_Dummy + 28;


MD_PreAlloc

Declaration

Source position: amigados.pas line 1841

const MD_PreAlloc = MD_Dummy + 6;


MD_Priority

Declaration

Source position: amigados.pas line 1855

const MD_Priority = MD_Dummy + 20;


MD_Reserved

Declaration

Source position: amigados.pas line 1840

const MD_Reserved = MD_Dummy + 5;


MD_SectorSize

Declaration

Source position: amigados.pas line 1836

const MD_SectorSize = MD_Dummy + 1;


MD_SectorsPerBlock

Declaration

Source position: amigados.pas line 1838

const MD_SectorsPerBlock = MD_Dummy + 3;


MD_SectorsPerTrack

Declaration

Source position: amigados.pas line 1839

const MD_SectorsPerTrack = MD_Dummy + 4;


MD_SegList

Declaration

Source position: amigados.pas line 1862

const MD_SegList = MD_Dummy + 27;


MD_StackSize

Declaration

Source position: amigados.pas line 1854

const MD_StackSize = MD_Dummy + 19;


MD_StartupNumber

Declaration

Source position: amigados.pas line 1857

const MD_StartupNumber = MD_Dummy + 22;


MD_StartupString

Declaration

Source position: amigados.pas line 1858

const MD_StartupString = MD_Dummy + 23;


MD_Surfaces

Declaration

Source position: amigados.pas line 1837

const MD_Surfaces = MD_Dummy + 2;


MD_Unit

Declaration

Source position: amigados.pas line 1852

const MD_Unit = MD_Dummy + 17;


MDT_FileSystem

Declaration

Source position: amigados.pas line 1832

const MDT_FileSystem = 0;


MDT_Handler

Declaration

Source position: amigados.pas line 1833

const MDT_Handler = 1;


MININT

smallest number useable as Integer

Declaration

Source position: amigados.pas line 34

const MININT = $80000000;


MODE_NEWFILE

Parameter for DosOpen Create new file

Declaration

Source position: amigados.pas line 38

const MODE_NEWFILE = 1006;

Description

Create a new file an open it, if the file already exists it will be deleted and a new empty file is created.

See also

DosOpen

Open a file for input or output


MODE_OLDFILE

Parameter for DosOpen Open existing file read/write

Declaration

Source position: amigados.pas line 37

const MODE_OLDFILE = 1005;

Description

Open existing file read/write and set file position to beginning of file. Other programs can still access this file. (e.g. shared reading)

See also

DosOpen

Open a file for input or output


MODE_READWRITE

Parameter for DosOpen Exclusive read/write file

Declaration

Source position: amigados.pas line 39

const MODE_READWRITE = 1004;

Description

Open old file and lock it that noone else can open it as long as it is open.

See also

DosOpen

Open a file for input or output


NBM_ADDDOSENTRY

Declaration

Source position: amigados.pas line 1522

const NBM_ADDDOSENTRY = 1 shl 0;


NBM_CHANGESIGNAL

Declaration

Source position: amigados.pas line 1525

const NBM_CHANGESIGNAL = 1 shl 3;


NBM_DISKINSERTED

Declaration

Source position: amigados.pas line 1527

const NBM_DISKINSERTED = 1 shl 5;


NBM_DISKREMOVED

Declaration

Source position: amigados.pas line 1528

const NBM_DISKREMOVED = 1 shl 6;


NBM_REMDOSENTRY

Declaration

Source position: amigados.pas line 1523

const NBM_REMDOSENTRY = 1 shl 1;


NBM_REMFREEDOSENTRY

Declaration

Source position: amigados.pas line 1526

const NBM_REMFREEDOSENTRY = 1 shl 4;


NBM_RENAMEDOSENTRY

Declaration

Source position: amigados.pas line 1524

const NBM_RENAMEDOSENTRY = 1 shl 2;


NDLC_END

Declaration

Source position: amigados.pas line 89

const NDLC_END = $FFFFFFFF;


NHM_ACTION_ADD

Declaration

Source position: amigados.pas line 1965

const NHM_ACTION_ADD = 0;


NHM_ACTION_CHANGE

Declaration

Source position: amigados.pas line 1966

const NHM_ACTION_CHANGE = 1;


NHM_ACTION_DELETE

Declaration

Source position: amigados.pas line 1967

const NHM_ACTION_DELETE = 2;


NHM_ACTION_INITIAL

Declaration

Source position: amigados.pas line 1964

const NHM_ACTION_INITIAL = - 1;


NOTIFY_CLASS

NotifyMessage Class

Declaration

Source position: amigados.pas line 1874

const NOTIFY_CLASS = $40000000;


NOTIFY_CODE

NotifyMessage Code

Declaration

Source position: amigados.pas line 1876

const NOTIFY_CODE = $1234;


NP_Arguments

Tag for CreateNewProc pointer to argument string (Default empty string)

Declaration

Source position: amigados.pas line 2221

const NP_Arguments = NP_Dummy + 21;


NP_Child

Declaration

Source position: amigados.pas line 2227

const NP_Child = NP_Dummy + 27;


NP_Cli

Tag for CreateNewProc create a CLI structure for new process (Default False)

Declaration

Source position: amigados.pas line 2218

const NP_Cli = NP_Dummy + 18;


NP_CloseError

Tag for CreateNewProc close error output on exit (Default True)

Declaration

Source position: amigados.pas line 2208

const NP_CloseError = NP_Dummy + 9;


NP_CloseInput

Tag for CreateNewProc Close Input on exit (Default True)

Declaration

Source position: amigados.pas line 2205

const NP_CloseInput = NP_Dummy + 6;


NP_CloseOutput

Tag for CreateNewProc Close Output on ext (Default True)

Declaration

Source position: amigados.pas line 2206

const NP_CloseOutput = NP_Dummy + 7;


NP_CommandName

Tag for CreateNewProc command name, valid only for CLI process

Declaration

Source position: amigados.pas line 2220

const NP_CommandName = NP_Dummy + 20;


NP_ConsolePort

Declaration

Source position: amigados.pas line 2213

const NP_ConsolePort = NP_Dummy + 14;


NP_ConsoleTask

Tag for CreateNewProc Pointer to console task (default same as host)

Declaration

Source position: amigados.pas line 2214

const NP_ConsoleTask = NP_ConsolePort;


NP_CopyVars

Tag for CreateNewProc boolean to copy local vars to new process (Default True)

Declaration

Source position: amigados.pas line 2217

const NP_CopyVars = NP_Dummy + 17;


NP_CurrentDir

Tag for CreateNewProc Lock (default is host's current dir)

Declaration

Source position: amigados.pas line 2209

const NP_CurrentDir = NP_Dummy + 10;


NP_Dummy

Tag for CreateNewProc start of tag range

Declaration

Source position: amigados.pas line 2199

const NP_Dummy = TAG_USER + 1000;


NP_Entry

Tag for CreateNewProc Entry point to run - mutually exclusive with NP_Seglist

Declaration

Source position: amigados.pas line 2202

const NP_Entry = NP_Dummy + 3;


NP_EntryCode

Declaration

Source position: amigados.pas line 2235

const NP_EntryCode = NP_Dummy + 32;


NP_EntryData

Declaration

Source position: amigados.pas line 2236

const NP_EntryData = NP_Dummy + 33;


NP_Error

Tag for CreateNewProc error filehandle (Default NIL:)

Declaration

Source position: amigados.pas line 2207

const NP_Error = NP_Dummy + 8;


NP_ExitCode

Tag for CreateNewProc code to be called on process exit.

Declaration

Source position: amigados.pas line 2224

const NP_ExitCode = NP_Dummy + 24;


NP_ExitData

Tag for CreateNewProc argument for NP_ExitCode (default nil)

Declaration

Source position: amigados.pas line 2225

const NP_ExitData = NP_Dummy + 25;


NP_FinalCode

Declaration

Source position: amigados.pas line 2237

const NP_FinalCode = NP_Dummy + 34;


NP_FinalData

Declaration

Source position: amigados.pas line 2238

const NP_FinalData = NP_Dummy + 35;


NP_FreeSeglist

Tag for CreateNewProc free the seglist when program finished. (Default True)

Declaration

Source position: amigados.pas line 2201

const NP_FreeSeglist = NP_Dummy + 2;


NP_Input

Tag for CreateNewProc input file handle (Default NIL:)

Declaration

Source position: amigados.pas line 2203

const NP_Input = NP_Dummy + 4;


NP_LocalAlias

Declaration

Source position: amigados.pas line 2239

const NP_LocalAlias = NP_Dummy + 36;


NP_LocalVars

Declaration

Source position: amigados.pas line 2233

const NP_LocalVars = NP_Dummy + 31;


NP_LockStack

Declaration

Source position: amigados.pas line 2241

const NP_LockStack = NP_Dummy + 37;


NP_Name

Tag for CreateNewProc Name for the process (Default New Process)

Declaration

Source position: amigados.pas line 2211

const NP_Name = NP_Dummy + 12;


NP_NotifyOnDeathMessage

Declaration

Source position: amigados.pas line 2228

const NP_NotifyOnDeathMessage = NP_Dummy + 28;


NP_NotifyOnDeathSignalBit

Declaration

Source position: amigados.pas line 2232

const NP_NotifyOnDeathSignalBit = NP_Dummy + 30;


NP_NotifyOnDeathSigTask

Declaration

Source position: amigados.pas line 2230

const NP_NotifyOnDeathSigTask = NP_Dummy + 29;


NP_Output

Tag for CreateNewProc output filehandle (Default NIL:)

Declaration

Source position: amigados.pas line 2204

const NP_Output = NP_Dummy + 5;


NP_OwnerGID

Declaration

Source position: amigados.pas line 2243

const NP_OwnerGID = NP_Dummy + 39;


NP_OwnerUID

Declaration

Source position: amigados.pas line 2242

const NP_OwnerUID = NP_Dummy + 38;


NP_Path

Tag for CreateNewProc Path, only valid if an CLI process (default copy of host's)

Declaration

Source position: amigados.pas line 2219

const NP_Path = NP_Dummy + 19;


NP_Priority

Tag for CreateNewProc Priority for the new process (Default same as host application)

Declaration

Source position: amigados.pas line 2212

const NP_Priority = NP_Dummy + 13;


NP_ProgramDir

Declaration

Source position: amigados.pas line 2216

const NP_ProgramDir = NP_Dummy + 16;


NP_Seglist

Tag for CreateNewProc seglist of code to run for the process

Declaration

Source position: amigados.pas line 2200

const NP_Seglist = NP_Dummy + 1;


NP_StackSize

Tag for CreateNewProc Stacksize for the programm (Default 4000)

Declaration

Source position: amigados.pas line 2210

const NP_StackSize = NP_Dummy + 11;


NP_unused1

Declaration

Source position: amigados.pas line 2222

const NP_unused1 = NP_Dummy + 22;


NP_unused2

Declaration

Source position: amigados.pas line 2223

const NP_unused2 = NP_Dummy + 23;


NP_UserData

Declaration

Source position: amigados.pas line 2226

const NP_UserData = NP_Dummy + 26;


NP_WindowPtr

Tag for CreateNewProc Window pointer (default same as host)

Declaration

Source position: amigados.pas line 2215

const NP_WindowPtr = NP_Dummy + 15;


NPLC_END

Declaration

Source position: amigados.pas line 88

const NPLC_END = $FFFFFFFF;


NR_HANDLER_FLAGS

Flag for TNotifyRequest.nr_Flags reserved for private use by the handler

Declaration

Source position: amigados.pas line 1951

const NR_HANDLER_FLAGS = NR_HANDLER_MASK;


NR_HANDLER_MASK

Declaration

Source position: amigados.pas line 1950

const NR_HANDLER_MASK = $ffff0000;


NRB_CALL_HOOK

Declaration

Source position: amigados.pas line 1929

const NRB_CALL_HOOK = 5;


NRB_DOS_NOTIFY_ONLY

Declaration

Source position: amigados.pas line 1930

const NRB_DOS_NOTIFY_ONLY = 12;


NRB_MAGIC

Flag bit for TNotifyRequest.nr_Flags do not set or remove it! Only for use by handlers!

Declaration

Source position: amigados.pas line 1931

const NRB_MAGIC = 31;


NRB_NOTIFY_INITIAL

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1928

const NRB_NOTIFY_INITIAL = 4;


NRB_SEND_MESSAGE

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1925

const NRB_SEND_MESSAGE = 0;


NRB_SEND_SIGNAL

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1926

const NRB_SEND_SIGNAL = 1;


NRB_WAIT_REPLY

Flag bit for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1927

const NRB_WAIT_REPLY = 3;


NRF_CALL_HOOK

Declaration

Source position: amigados.pas line 1937

const NRF_CALL_HOOK = 1 shl NRB_CALL_HOOK;


NRF_DOS_NOTIFY_ONLY

Declaration

Source position: amigados.pas line 1944

const NRF_DOS_NOTIFY_ONLY = 1 shl NRB_DOS_NOTIFY_ONLY;


NRF_MAGIC

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1947

const NRF_MAGIC = 1 shl NRB_MAGIC;


NRF_NOTIFY_INITIAL

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1941

const NRF_NOTIFY_INITIAL = 1 shl NRB_NOTIFY_INITIAL;


NRF_SEND_MESSAGE

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1935

const NRF_SEND_MESSAGE = 1 shl NRB_SEND_MESSAGE;


NRF_SEND_SIGNAL

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1936

const NRF_SEND_SIGNAL = 1 shl NRB_SEND_SIGNAL;


NRF_WAIT_REPLY

Flag for TNotifyRequest.nr_Flags

Declaration

Source position: amigados.pas line 1939

const NRF_WAIT_REPLY = 1 shl NRB_WAIT_REPLY;


OCD_Dummy

Declaration

Source position: amigados.pas line 2156

const OCD_Dummy = TAG_USER + 600;


OCD_FileHandleInput

Declaration

Source position: amigados.pas line 2157

const OCD_FileHandleInput = OCD_Dummy + 1;


OCD_MsgPortInput

Declaration

Source position: amigados.pas line 2158

const OCD_MsgPortInput = OCD_Dummy + 2;


OFFSET_BEGINNING

Parameter for DosSeek Start seek from the beginning of file

Declaration

Source position: amigados.pas line 42

const OFFSET_BEGINNING = - 1;

See also

DosSeek

Set the current position for reading and writing


OFFSET_CURRENT

Parameter for DosSeek Start the seek from the current position

Declaration

Source position: amigados.pas line 43

const OFFSET_CURRENT = 0;

See also

DosSeek

Set the current position for reading and writing


OFFSET_END

Parameter for DosSeek Start the seek from the end of file

Declaration

Source position: amigados.pas line 44

const OFFSET_END = 1;

See also

DosSeek

Set the current position for reading and writing


OI_Dummy

Declaration

Source position: amigados.pas line 2321

const OI_Dummy = TAG_USER + 6200;


OI_OwnerGID

Declaration

Source position: amigados.pas line 2329

const OI_OwnerGID = OI_Dummy + 11;


OI_OwnerUID

Declaration

Source position: amigados.pas line 2327

const OI_OwnerUID = OI_Dummy + 10;


OI_Process

Declaration

Source position: amigados.pas line 2326

const OI_Process = OI_ProcessInput;


OI_ProcessInput

Declaration

Source position: amigados.pas line 2325

const OI_ProcessInput = OI_Dummy + 2;


OI_StringName

Declaration

Source position: amigados.pas line 2324

const OI_StringName = OI_StringNameInput;


OI_StringNameInput

Declaration

Source position: amigados.pas line 2323

const OI_StringNameInput = OI_Dummy + 1;


P_ANY

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 773

const P_ANY = $80;


P_CLASS

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 781

const P_CLASS = $88;


P_NOT

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 778

const P_NOT = $85;


P_NOTCLASS

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 780

const P_NOTCLASS = $87;


P_NOTEND

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 779

const P_NOTEND = $86;


P_OREND

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 777

const P_OREND = $84;


P_ORNEXT

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 776

const P_ORNEXT = $83;


P_ORSTART

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 775

const P_ORSTART = $82;


P_REPBEG

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 782

const P_REPBEG = $89;


P_REPEND

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 783

const P_REPEND = $8A;


P_SINGLE

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 774

const P_SINGLE = $81;


P_STOP

Internal constants used by wildcard routines of MatchFirst and MatchNext

Declaration

Source position: amigados.pas line 784

const P_STOP = $8B;


PAChain

Declaration

Source position: amigados.pas line 631

type PAChain = ^TAChain;


PAddressAndSize

Declaration

Source position: amigados.pas line 1163

type PAddressAndSize = ^TAddressAndSize;


PAnchorPath

Structure expected by MatchFirst, MatchNext to find Files.

Declaration

Source position: amigados.pas line 700

type PAnchorPath = ^TAnchorPath;

Description

To search for files call MatchFirst() and then afterwards, MatchNext() with this structure. You should check the return value each time and take the appropriate action, ultimately calling MatchEnd() when there are no more files and you are done. You can tell when you are done by checking for the normal DOS return code ERROR_NO_MORE_ENTRIES.

See also

MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()


PAnchorPathOld

Declaration

Source position: amigados.pas line 647

type PAnchorPathOld = ^TAnchorPathOld;


pAssignList

Declaration

Source position: amigados.pas line 1403

type pAssignList = ^tAssignList;


PAssignNode

Declaration

Source position: amigados.pas line 1388

type PAssignNode = ^TAssignNode;


PCapturedExpression

Declaration

Source position: amigados.pas line 1185

type PCapturedExpression = ^TCapturedExpression;


pCliProcList

Declaration

Source position: amigados.pas line 1309

type pCliProcList = ^tCliProcList;


PCommandLineInterface

DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them

Declaration

Source position: amigados.pas line 1322

type PCommandLineInterface = ^TCommandLineInterface;


PConsoleWindowData

Declaration

Source position: amigados.pas line 1151

type PConsoleWindowData = ^TConsoleWindowData;


PCSource

Pointer to Input structure for ReadItem and ReadArgs

Declaration

Source position: amigados.pas line 2030

type PCSource = ^TCSource;


PDateStamp

Pointer to a Date and Time representation

Declaration

Source position: amigados.pas line 115

type PDateStamp = ^TDateStamp;


PDeathMessage

Declaration

Source position: amigados.pas line 579

type PDeathMessage = ^TDeathMessage;


pDeviceList

Declaration

Source position: amigados.pas line 1451

type pDeviceList = ^tDeviceList;


PDeviceNode

Pointer to Device node list

Declaration

Source position: amigados.pas line 1359

type PDeviceNode = ^TDeviceNode;


pDevInfo

Declaration

Source position: amigados.pas line 1466

type pDevInfo = ^tDevInfo;


PDevProc

Structure return by GetDeviceProc()

Declaration

Source position: amigados.pas line 1551

type PDevProc = ^TDevProc;


pDosEnvec

Describes the disk geometry

Declaration

Source position: amigados.pas line 1678

type pDosEnvec = ^tDosEnvec;


pDosInfo

Declaration

Source position: amigados.pas line 1289

type pDosInfo = ^tDosInfo;


pDosLibrary

This is how the base of dos.library looks like.

Declaration

Source position: amigados.pas line 1251

type pDosLibrary = ^tDosLibrary;


PDOSList

Declaration

Source position: amigados.pas line 1410

type PDOSList = ^TDOSList;


PDosPacket

This is the extension to EXEC Messages used by DOS

Declaration

Source position: amigados.pas line 976

type PDosPacket = ^TDosPacket;


PDosPacket64

Declaration

Source position: amigados.pas line 1011

type PDosPacket64 = ^TDosPacket64;


PDosResidentSeg

Declaration

Source position: amigados.pas line 1218

type PDosResidentSeg = ^TDosResidentSeg;


pErrorString

A structure for holding error messages - stored as array with error = 0 for the last entry.

Declaration

Source position: amigados.pas line 1237

type pErrorString = ^tErrorString;


PExAllControl

Control structure passed to ExAll().

Declaration

Source position: amigados.pas line 1669

type PExAllControl = ^TExAllControl;


PExAllData

Structure in which exall results are returned in.

Declaration

Source position: amigados.pas line 1650

type PExAllData = ^TExAllData;


PExamineData

Declaration

Source position: amigados.pas line 135

type PExamineData = ^TExamineData;


PFileHandle

This pointer is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls

Declaration

Source position: amigados.pas line 955

type PFileHandle = ^TFileHandle;


PFileInfoBlock

Pointer to a file information structure

Declaration

Source position: amigados.pas line 304

type PFileInfoBlock = ^TFileInfoBlock;

See also

Examine

Examine a directory or file associated with a lock


pFileLock

Lock structure, as returned by Lock() or DupLock()

Declaration

Source position: amigados.pas line 1616

type pFileLock = ^tFileLock;


PFileSysStartupMsg

Pointer to filesystem startup message for a device

Declaration

Source position: amigados.pas line 1732

type PFileSysStartupMsg = ^TFileSysStartupMsg;


PFileSystemData

Declaration

Source position: amigados.pas line 1743

type PFileSystemData = ^TFileSystemData;


PFileSystemVectorPort

Declaration

Source position: amigados.pas line 1822

type PFileSystemVectorPort = ^TFileSystemVectorPort;


PFileSystemVectors

Declaration

Source position: amigados.pas line 1759

type PFileSystemVectors = ^TFileSystemVectors;


PFindTrackedAddressMsg

Declaration

Source position: amigados.pas line 1169

type PFindTrackedAddressMsg = ^TFindTrackedAddressMsg;


PFReadLineData

Declaration

Source position: amigados.pas line 588

type PFReadLineData = ^TFReadLineData;


PInfoData

General Disk informatons from Info

Declaration

Source position: amigados.pas line 374

type PInfoData = ^TInfoData;


PLocalVar

Pointer to a Localvars list

Declaration

Source position: amigados.pas line 2106

type PLocalVar = ^TLocalVar;


PLock

Declaration

Source position: amigados.pas line 1532

type PLock = ^TLock;


PMultiAssign

Declaration

Source position: amigados.pas line 1377

type PMultiAssign = ^TMultiAssign;


PNotifyHookMsg

Declaration

Source position: amigados.pas line 1955

type PNotifyHookMsg = ^TNotifyHookMsg;


PNotifyMessage

Declaration

Source position: amigados.pas line 1913

type PNotifyMessage = ^TNotifyMessage;


PNotifyRequest

Declaration

Source position: amigados.pas line 1882

type PNotifyRequest = ^tNotifyRequest;


PPathNode

Declaration

Source position: amigados.pas line 1971

type PPathNode = ^TPathNode;


PProcess

All DOS processes have this structure

Declaration

Source position: amigados.pas line 832

type PProcess = ^TProcess;


PPseudoSegList

Declaration

Source position: amigados.pas line 1195

type PPseudoSegList = ^TPseudoSegList;


PRB_CHILDPROCESS

Declaration

Source position: amigados.pas line 925

const PRB_CHILDPROCESS = 24;


PRB_CLOSEERROR

Declaration

Source position: amigados.pas line 906

const PRB_CLOSEERROR = 6;


PRB_CLOSEINPUT

Flag bit for tProcess

Declaration

Source position: amigados.pas line 903

const PRB_CLOSEINPUT = 3;


PRB_CLOSEOUTPUT

Flag bit for tProcess

Declaration

Source position: amigados.pas line 904

const PRB_CLOSEOUTPUT = 4;


PRB_EXTENDED_FLAGS

Declaration

Source position: amigados.pas line 932

const PRB_EXTENDED_FLAGS = 31;


PRB_FREEARGS_OBSOLETE

Declaration

Source position: amigados.pas line 905

const PRB_FREEARGS_OBSOLETE = 5;


PRB_FREECLI

Flag bit for tProcess

Declaration

Source position: amigados.pas line 902

const PRB_FREECLI = 2;


PRB_FREECURRDIR

Flag bit for tProcess

Declaration

Source position: amigados.pas line 901

const PRB_FREECURRDIR = 1;


PRB_FREESEGLIST

Flag bit for tProcess

Declaration

Source position: amigados.pas line 900

const PRB_FREESEGLIST = 0;


PRB_HADCHILDREN

Declaration

Source position: amigados.pas line 926

const PRB_HADCHILDREN = 25;


PRB_HANDLERPROCESS

Declaration

Source position: amigados.pas line 930

const PRB_HANDLERPROCESS = 29;


PRB_HASDLNOTIFY

Declaration

Source position: amigados.pas line 927

const PRB_HASDLNOTIFY = 26;


PRB_HASPLNOTIFY

Declaration

Source position: amigados.pas line 928

const PRB_HASPLNOTIFY = 27;


PRB_LOCKSTACK

Declaration

Source position: amigados.pas line 907

const PRB_LOCKSTACK = 7;


PRB_SERVERPROCESS

Declaration

Source position: amigados.pas line 929

const PRB_SERVERPROCESS = 28;


PRB_SHELLPROCESS

Declaration

Source position: amigados.pas line 931

const PRB_SHELLPROCESS = 30;


PRB_spare08

Declaration

Source position: amigados.pas line 908

const PRB_spare08 = 8;


PRB_spare09

Declaration

Source position: amigados.pas line 909

const PRB_spare09 = 9;


PRB_spare10

Declaration

Source position: amigados.pas line 910

const PRB_spare10 = 10;


PRB_spare11

Declaration

Source position: amigados.pas line 911

const PRB_spare11 = 11;


PRB_spare12

Declaration

Source position: amigados.pas line 912

const PRB_spare12 = 12;


PRB_spare13

Declaration

Source position: amigados.pas line 913

const PRB_spare13 = 13;


PRB_spare14

Declaration

Source position: amigados.pas line 914

const PRB_spare14 = 14;


PRB_spare15

Declaration

Source position: amigados.pas line 915

const PRB_spare15 = 15;


PRB_spare16

Declaration

Source position: amigados.pas line 917

const PRB_spare16 = 16;


PRB_spare17

Declaration

Source position: amigados.pas line 918

const PRB_spare17 = 17;


PRB_spare18

Declaration

Source position: amigados.pas line 919

const PRB_spare18 = 18;


PRB_spare19

Declaration

Source position: amigados.pas line 920

const PRB_spare19 = 19;


PRB_spare20

Declaration

Source position: amigados.pas line 921

const PRB_spare20 = 20;


PRB_spare21

Declaration

Source position: amigados.pas line 922

const PRB_spare21 = 21;


PRB_spare22

Declaration

Source position: amigados.pas line 923

const PRB_spare22 = 22;


PRB_spare23

Declaration

Source position: amigados.pas line 924

const PRB_spare23 = 23;


PRDArgs

Input parameter ReadArgs()

Declaration

Source position: amigados.pas line 2065

type PRDArgs = ^TRDArgs;


PRecordLock

Parameter for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 2095

type PRecordLock = ^TRecordLock;


PRF_CHILDPROCESS

Declaration

Source position: amigados.pas line 943

const PRF_CHILDPROCESS = 1 shl PRB_CHILDPROCESS;


PRF_CLOSEERROR

Declaration

Source position: amigados.pas line 940

const PRF_CLOSEERROR = 1 shl PRB_CLOSEERROR;


PRF_CLOSEINPUT

Flag value for tProcess

Declaration

Source position: amigados.pas line 937

const PRF_CLOSEINPUT = 1 shl PRB_CLOSEINPUT;


PRF_CLOSEOUTPUT

Flag value for tProcess

Declaration

Source position: amigados.pas line 938

const PRF_CLOSEOUTPUT = 1 shl PRB_CLOSEOUTPUT;


PRF_EXTENDED_FLAGS

Declaration

Source position: amigados.pas line 950

const PRF_EXTENDED_FLAGS = 1 shl PRB_EXTENDED_FLAGS;


PRF_FREEARGS_OBSOLETE

Declaration

Source position: amigados.pas line 939

const PRF_FREEARGS_OBSOLETE = 1 shl PRB_FREEARGS_OBSOLETE;


PRF_FREECLI

Flag value for tProcess

Declaration

Source position: amigados.pas line 936

const PRF_FREECLI = 1 shl PRB_FREECLI;


PRF_FREECURRDIR

Flag value for tProcess

Declaration

Source position: amigados.pas line 935

const PRF_FREECURRDIR = 1 shl PRB_FREECURRDIR;


PRF_FREESEGLIST

Flag value for tProcess

Declaration

Source position: amigados.pas line 934

const PRF_FREESEGLIST = 1 shl PRB_FREESEGLIST;


PRF_HADCHILDREN

Declaration

Source position: amigados.pas line 944

const PRF_HADCHILDREN = 1 shl PRB_HADCHILDREN;


PRF_HANDLERPROCESS

Declaration

Source position: amigados.pas line 948

const PRF_HANDLERPROCESS = 1 shl PRB_HANDLERPROCESS;


PRF_HASDLNOTIFY

Declaration

Source position: amigados.pas line 945

const PRF_HASDLNOTIFY = 1 shl PRB_HASDLNOTIFY;


PRF_HASPLNOTIFY

Declaration

Source position: amigados.pas line 946

const PRF_HASPLNOTIFY = 1 shl PRB_HASPLNOTIFY;


PRF_LOCKSTACK

Declaration

Source position: amigados.pas line 941

const PRF_LOCKSTACK = 1 shl PRB_LOCKSTACK;


PRF_SERVERPROCESS

Declaration

Source position: amigados.pas line 947

const PRF_SERVERPROCESS = 1 shl PRB_SERVERPROCESS;


PRF_SHELLPROCESS

Declaration

Source position: amigados.pas line 949

const PRF_SHELLPROCESS = 1 shl PRB_SHELLPROCESS;


pRootNode

Declaration

Source position: amigados.pas line 1265

type pRootNode = ^tRootNode;


PSearchCmdPathListMsg

Declaration

Source position: amigados.pas line 1984

type PSearchCmdPathListMsg = ^TSearchCmdPathListMsg;


PSIKEY_ELF32

Declaration

Source position: amigados.pas line 1213

const PSIKEY_ELF32 = $7F454C46;


PSIKEY_INIT

Declaration

Source position: amigados.pas line 1211

const PSIKEY_INIT = 0;


PSIKEY_NFSYS

Declaration

Source position: amigados.pas line 1214

const PSIKEY_NFSYS = $FFFFFFFF;


PSIKEY_NOFREE

Declaration

Source position: amigados.pas line 1212

const PSIKEY_NOFREE = $80000000;


PSJUMP_MAGIC

Declaration

Source position: amigados.pas line 1209

const PSJUMP_MAGIC = $4e714ef9;


PStandardPacket

Declaration

Source position: amigados.pas line 1003

type PStandardPacket = ^TStandardPacket;


PStandardPacket64

Declaration

Source position: amigados.pas line 1035

type PStandardPacket64 = ^TStandardPacket64;


PVolumeNode

Declaration

Source position: amigados.pas line 1343

type PVolumeNode = ^TVolumeNode;


RDAB_NOALLOC

Flag bit for TRDArgs.RDA_Flags If set, do not allocate extra string space.

Declaration

Source position: amigados.pas line 2077

const RDAB_NOALLOC = 1;


RDAB_NOPROMPT

Flag bit for TRDArgs.RDA_Flags Disable reprompting for string input.

Declaration

Source position: amigados.pas line 2078

const RDAB_NOPROMPT = 2;


RDAB_STDIN

Flag bit for TRDArgs.RDA_Flags use StdIn rather than command line

Declaration

Source position: amigados.pas line 2076

const RDAB_STDIN = 0;


RDAF_NOALLOC

Flag value for TRDArgs.RDA_Flags If set, do not allocate extra string space.

Declaration

Source position: amigados.pas line 2080

const RDAF_NOALLOC = 1 shl RDAB_NOALLOC;


RDAF_NOPROMPT

Flag value for TRDArgs.RDA_Flags Disable reprompting for string input.

Declaration

Source position: amigados.pas line 2081

const RDAF_NOPROMPT = 1 shl RDAB_NOPROMPT;


RDAF_STDIN

Flag value for TRDArgs.RDA_Flags use StdIn rather than command line

Declaration

Source position: amigados.pas line 2079

const RDAF_STDIN = 1 shl RDAB_STDIN;


REC_EXCLUSIVE

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 2084

const REC_EXCLUSIVE = 0;


REC_EXCLUSIVE_IMMED

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 2085

const REC_EXCLUSIVE_IMMED = 1;


REC_MODE_MASK

Declaration

Source position: amigados.pas line 2090

const REC_MODE_MASK = $FF;


REC_SHARED

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 2086

const REC_SHARED = 2;


REC_SHARED_IMMED

Mode for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 2087

const REC_SHARED_IMMED = 3;


RECF_DOS_METHOD_ONLY

Declaration

Source position: amigados.pas line 2089

const RECF_DOS_METHOD_ONLY = 1 shl 16;


REPORT_INSERT

Error report ""please inser volume" at ErrorReport()

Declaration

Source position: amigados.pas line 1588

const REPORT_INSERT = 4;


REPORT_LOCK

Error report Lock at ErrorReport()

Declaration

Source position: amigados.pas line 1586

const REPORT_LOCK = 2;


REPORT_STREAM

Error report stream at ErrorReport()

Declaration

Source position: amigados.pas line 1584

const REPORT_STREAM = 0;


REPORT_TASK

Error report task at ErrorReport()

Declaration

Source position: amigados.pas line 1585

const REPORT_TASK = 1;


REPORT_VOLUME

Error report volume at ErrorReport()

Declaration

Source position: amigados.pas line 1587

const REPORT_VOLUME = 3;


RETURN_ERROR

Return Level error: errors occour can not finish

Declaration

Source position: amigados.pas line 521

const RETURN_ERROR = 10;


RETURN_FAIL

Return level Fail: something really bad happend

Declaration

Source position: amigados.pas line 522

const RETURN_FAIL = 20;


RETURN_OK

Return Level OK = no Problem, success

Declaration

Source position: amigados.pas line 519

const RETURN_OK = 0;


RETURN_WARN

Return level warn: some warnings appear

Declaration

Source position: amigados.pas line 520

const RETURN_WARN = 5;


RLI_CommentChars

Declaration

Source position: amigados.pas line 2305

const RLI_CommentChars = RLI_Dummy + 12;


RLI_CSourceInput

Declaration

Source position: amigados.pas line 2301

const RLI_CSourceInput = RLI_Dummy + 2;


RLI_Dummy

Declaration

Source position: amigados.pas line 2299

const RLI_Dummy = TAG_USER + 5500;


RLI_EscapeChars

Declaration

Source position: amigados.pas line 2302

const RLI_EscapeChars = RLI_Dummy + 10;


RLI_FileHandleInput

Declaration

Source position: amigados.pas line 2300

const RLI_FileHandleInput = RLI_Dummy + 1;


RLI_MultiLine

Declaration

Source position: amigados.pas line 2304

const RLI_MultiLine = RLI_Dummy + 11;


RLI_Substitute_E

Declaration

Source position: amigados.pas line 2309

const RLI_Substitute_E = RLI_Dummy + 14;


RLI_Substitute_N

Declaration

Source position: amigados.pas line 2307

const RLI_Substitute_N = RLI_Dummy + 13;


RNB_PRIVATE1

Declaration

Source position: amigados.pas line 1285

const RNB_PRIVATE1 = 1;


RNB_WILDSTAR

Declaration

Source position: amigados.pas line 1283

const RNB_WILDSTAR = 24;


RNF_PRIVATE1

Declaration

Source position: amigados.pas line 1286

const RNF_PRIVATE1 = 2;


RNF_WILDSTAR

Declaration

Source position: amigados.pas line 1284

const RNF_WILDSTAR = 16777216;


RUN_EXECUTE

Type for initial packets to shells from run/newcli/execute/system.

Declaration

Source position: amigados.pas line 1595

const RUN_EXECUTE = - 1;


RUN_SYSTEM

Type for initial packets to shells from run/newcli/execute/system.

Declaration

Source position: amigados.pas line 1596

const RUN_SYSTEM = - 2;


RUN_SYSTEM_ASYNCH

Type for initial packets to shells from run/newcli/execute/system.

Declaration

Source position: amigados.pas line 1597

const RUN_SYSTEM_ASYNCH = - 3;


SBM_BLOCKING

Declaration

Source position: amigados.pas line 94

const SBM_BLOCKING = 1;


SBM_NON_BLOCKING

Declaration

Source position: amigados.pas line 95

const SBM_NON_BLOCKING = 2;


SHARED_LOCK

Parameter for Lock File is readable by others

Declaration

Source position: amigados.pas line 47

const SHARED_LOCK = - 2;


SIGBREAKB_CTRL_C

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 525

const SIGBREAKB_CTRL_C = 12;


SIGBREAKB_CTRL_D

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 526

const SIGBREAKB_CTRL_D = 13;


SIGBREAKB_CTRL_E

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 527

const SIGBREAKB_CTRL_E = 14;


SIGBREAKB_CTRL_F

Bit numbers that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 528

const SIGBREAKB_CTRL_F = 15;


SIGBREAKF_CTRL_C

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 530

const SIGBREAKF_CTRL_C = 1 shl SIGBREAKB_CTRL_C;


SIGBREAKF_CTRL_D

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 531

const SIGBREAKF_CTRL_D = 1 shl SIGBREAKB_CTRL_D;


SIGBREAKF_CTRL_E

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 532

const SIGBREAKF_CTRL_E = 1 shl SIGBREAKB_CTRL_E;


SIGBREAKF_CTRL_F

Value that signal you that a user has issued a break

Declaration

Source position: amigados.pas line 533

const SIGBREAKF_CTRL_F = 1 shl SIGBREAKB_CTRL_F;


ST_FILE

Type for TFileInfoBlock.fib_DirEntryType ordinary file

Declaration

Source position: amigados.pas line 1608

const ST_FILE = - 3;


ST_LINKDIR

Type for TFileInfoBlock.fib_DirEntryType hard link to directory

Declaration

Source position: amigados.pas line 1607

const ST_LINKDIR = 4;


ST_LINKFILE

Type for TFileInfoBlock.fib_DirEntryType hard link to file

Declaration

Source position: amigados.pas line 1609

const ST_LINKFILE = - 4;


ST_PIPEFILE

Type for TFileInfoBlock.fib_DirEntryType pipes support ExamineFH

Declaration

Source position: amigados.pas line 1610

const ST_PIPEFILE = - 5;


ST_ROOT

Type for TFileInfoBlock.fib_DirEntryType root directory of a device

Declaration

Source position: amigados.pas line 1604

const ST_ROOT = 1;


ST_SOFTLINK

Type for TFileInfoBlock.fib_DirEntryType looks like a dir, but may point to a file

Declaration

Source position: amigados.pas line 1606

const ST_SOFTLINK = 3;


ST_USERDIR

Type for TFileInfoBlock.fib_DirEntryType

Declaration

Source position: amigados.pas line 1605

const ST_USERDIR = 2;


SYS_Asynch

Tag for SystemTagList run the process asynchron, closes the input/output on exit

Declaration

Source position: amigados.pas line 2192

const SYS_Asynch = SYS_Dummy + 3;


SYS_CommandRunMode

Declaration

Source position: amigados.pas line 2189

const SYS_CommandRunMode = SYS_Dummy + 0;


SYS_CustomShell

Tag for SystemTagList send to a specific shell (name)

Declaration

Source position: amigados.pas line 2194

const SYS_CustomShell = SYS_Dummy + 5;


SYS_Dummy

Tag for SystemTagList start of Tag range

Declaration

Source position: amigados.pas line 2188

const SYS_Dummy = TAG_USER + 32;


SYS_Error

Declaration

Source position: amigados.pas line 2195

const SYS_Error = SYS_Dummy + 6;


SYS_ExecuteInputStream

Declaration

Source position: amigados.pas line 2196

const SYS_ExecuteInputStream = SYS_Dummy + 7;


SYS_Input

Tag for SystemTagList specifies an input file handle

Declaration

Source position: amigados.pas line 2190

const SYS_Input = SYS_Dummy + 1;


SYS_Output

Tag for SystemTagList specifies an output file handle

Declaration

Source position: amigados.pas line 2191

const SYS_Output = SYS_Dummy + 2;


SYS_UserShell

Tag for SystemTagList send to user shell instead of boot shell

Declaration

Source position: amigados.pas line 2193

const SYS_UserShell = SYS_Dummy + 4;


TAChain

Declaration

Source position: amigados.pas line 632

type TAChain = record

  an_Child: PAChain;

  an_Parent: PAChain;

  an_Lock: LongInt;

  an_Info: TFileInfoBlock;

  an_Flags: ShortInt;

  an_ExData: PExamineData;

  an_DevProc: Pointer;

  an_String: array [0..0] of Char;

end;


TAddressAndSize

Declaration

Source position: amigados.pas line 1164

type TAddressAndSize = record

  aas_Address: LongWord;

  aas_Size: LongWord;

end;


TAnchorPath

Structure expected by MatchFirst, MatchNext to find Files.

Declaration

Source position: amigados.pas line 701

type TAnchorPath = record
ap_Magic: LongInt;
case SmallInt of
0: (
ap_First: PAChain; | Pointer to first anchor
ap_Last: PAChain; | Pointer to last anchor
);
1: (
ap_Base: PAChain; |
ap_Current: PAChain; |
ap_BreakBits: LongWord; | Bits we want to break on (DDF_*)
ap_FoundBreak: LongWord; | Bits we broke on. Also returns ERROR_BREAK
ap_Flags: LongWord; | Extra flags
ap_ExData: PExamineData;
ap_CTXPrivate: Pointer;
ap_Reserved: array [0..1] of LongWord; |
ap_Strlen: LongWord; | This is what ap_Length used to be
ap_Buffer: PChar;
ap_Info: PFileInfoBlock; | Info block of the found file
ap_Private1: LongWord;
ap_Private2: LongWord;
);
end;

Description

Allocate this structure and initialize it as follows:

Set ap_BreakBits to the signal bits (DDB) that you want to take a break on, or nil, if you don't want to convenience the user.

If you want to have the full path name of the files you found, allocate a buffer at the end of this structure, and put the size of it into ap_Strlen. If you don't want the full path name, make sure you set ap_Strlen to 0. In this case, the name of the file, and stats are available in the ap_Info, as per usual.

Then call MatchFirst() and then afterwards, MatchNext() with this structure. You should check the return value each time and take the appropriate action, ultimately calling MatchEnd() when there are no more files and you are done. You can tell when you are done by checking for the normal DOS return code ERROR_NO_MORE_ENTRIES.

See also

MatchFirst | Finds file that matches pattern
MatchNext | Finds the next file or directory that matches pattern
MatchEnd | Free storage allocated for MatchFirst()/MatchNext()


TAnchorPathOld

Declaration

Source position: amigados.pas line 648

type TAnchorPathOld = record

  case SmallInt of

    0: (

        ap_First: PAChain;

        ap_Last: PAChain;

      );

    1: (

        ap_Base: PAChain;

        ap_Current: PAChain;

        ap_BreakBits: LongWord;

        ap_FoundBreak: LongWord;

        ap_Flags: ShortInt;

        ap_Reserved: ShortInt;

        ap_Strlen: Word;

        ap_Info: TFileInfoBlock;

        ap_Buf: array [0..0] of Char;

      );

end;


tAssignList

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure used for multi-directory assigns.

Declaration

Source position: amigados.pas line 1404

type tAssignList = record

  al_Next: pAssignList;

  al_Lock: LongInt;

end;


TAssignNode

Declaration

Source position: amigados.pas line 1389

type TAssignNode = record

  an_Next: LongInt;

  an_Type: LongInt;

  an_Port: PMsgPort;

  an_Lock: LongInt;

  an_AssignName: PChar;

  an_MultiAssignList: PMultiAssign;

  an_NBMultiAssignList: PMultiAssign;

  an_Unused: array [0..2] of LongInt;

  an_Name: LongInt;

  an_StructSize: LongInt;

  an_Reserved: array [0..3] of LongInt;

end;


TCapturedExpression

Declaration

Source position: amigados.pas line 1186

type TCapturedExpression = record

  cape_Next: PCapturedExpression;

  cape_Match: PChar;

  cape_Start: PChar;

  cape_End: PChar;

  cape_Pool: Pointer;

end;


tCliProcList

Only to be allocated by DOS!

Declaration

Source position: amigados.pas line 1310

type tCliProcList = record
cpl_Node: TMinNode; |
cpl_First: LongInt; | number of first entry in array
cpl_Array: array [0..0] of PMsgPort; | [0] is max number of CLI's in this entry (n), [1] is CPTR to process id of CLI cpl_First, [n] is CPTR to process id of CLI cpl_First+n-1
end;


TCommandLineInterface

DOS Processes started from the CLI via RUN or NEWCLI have this additional set to data associated with them

Declaration

Source position: amigados.pas line 1323

type TCommandLineInterface = record
cli_Result2: LongInt; | Value of IoErr from last command
cli_CurrentDirName: LongInt;
cli_PathList: LongInt;
cli_ReturnCode: LongInt; | Return code from last command
cli_CommandName: LongInt; | Name of current command
cli_FailLevel: LongInt; | Fail level (set by FAILAT)
cli_Prompt: LongInt; | Current prompt (set by PROMPT)
cli_StandardInput: LongInt; | Default (terminal) CLI input
cli_CurrentInput: LongInt; | Current CLI input
cli_CommandFile: LongInt; | Name of EXECUTE command file
cli_Interactive: LongInt; | Boolean; True if prompts required
cli_Background: LongInt; | Boolean; True if CLI created by RUN
cli_CurrentOutput: LongInt; | Current CLI output
cli_DefaultStack: LongWord; | Stack size to be obtained in long words
cli_StandardOutput: LongInt; | Default (terminal) CLI output
cli_Module: LongInt; | SegList of currently loaded command
end;


TConsoleWindowData

Declaration

Source position: amigados.pas line 1152

type TConsoleWindowData = record

  Reserved: array [0..3] of LongWord;

  ConsoleWindow: Pointer;

  ConsoleIO: PIORequest;

  ConsoleType: LongWord;

  DOSPrivate: array [0..1] of Pointer;

end;


TCSource

Input structure for ReadItem and ReadArgs

Declaration

Source position: amigados.pas line 2031

type TCSource = record
CS_Buffer: PChar; | Data source
CS_Length: LongInt; | Length of string
CS_CurChr: LongInt; |
end;

Description

The TCSource data structure defines the input source for ReadItem as well as the ReadArgs call. It is a publicly defined structure which may be used by applications which use code that follows the conventions defined for access.

To initialize a TCSource, you set TCSource.CS_Buffer to a string which is used as the data source, and set CS_Length to the number of characters in the string. Normally CS_CurChr should be initialized to 0, or left as it was from prior use as a TCSource.

When passed to the dos.library functions, the value passed as PCSource is defined as follows:

if PCSource = nil then
  // Use buffered IO  as data source
else
  // Use PCSource for input character stream


TDateStamp

Date and Time representation

Declaration

Source position: amigados.pas line 116

type TDateStamp = record
ds_Days: LongInt; | Number of days since 1. Jan. 1978
ds_Minute: LongInt; | Number of minutes of the day
ds_Tick: LongInt; | Number of ticks since past minute. Use TICKS_PER_SECOND to calculate the seconds.
end;

See also

TICKS_PER_SECOND | Number of ticks per second. Defines the acuracy of your time
DateStamp | Fills the structure with the current time. Time is measured from 1. Jan. 1978.
CompareDates | Compares two datestamps
TFileInfoBlock | File information structure


TDeathMessage

Declaration

Source position: amigados.pas line 580

type TDeathMessage = record

  dm_Msg: PMessage;

  dm_ReturnCode: LongInt;

  dm_Result2: LongInt;

end;


tDeviceList

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a volume.

Declaration

Source position: amigados.pas line 1452

type tDeviceList = record
dl_Next: LongInt; | Pointer to next device list
dl_Type: LongInt; | Type of record (DLT_*)
dl_Task: PMsgPort; | Pointer to handler task
dl_Lock: LongInt; | not for volumes
dl_VolumeDate: TDateStamp; | Creation date
dl_LockList: LongInt; | Outstanding locks
dl_DiskType: LongInt; | 'DOS', etc
dl_unused: LongInt; |
dl_Name: LongInt; | Name of device
end;


TDeviceNode

Device node list DLT_DEVICE

Declaration

Source position: amigados.pas line 1360

type TDeviceNode = record
dn_Next: LongInt; | Link to next node
dn_Type: LongInt; | Always 0 for dos "devices"
dn_Port: PMsgPort;
dn_Reserved1: LongInt;
dn_Handler: LongInt; | Filename to loadseg (if seglist is nil)
dn_StackSize: LongInt; | Stacksize to use when starting task
dn_Priority: LongInt; | Task priority when starting task
dn_Startup: LongInt; | Pointer to TFileSysStartupMsg for disks
dn_SegList: LongInt; | code to run to start new task (if necessary). if nil then dn_Handler will be loaded.
dn_GlobalVec: LongInt; | Global vector to use when starting a task.-1 means that dn_SegList is not for a bcpl program, so the dos won't try and construct one. 0 tell the dos that you obey BCPL linkage rules, and that it should construct a global vector for you.
dn_Name: LongInt; | the node name, e.g. '\3','D','F','3' for DF3:
dn_StructSize: LongInt;
dn_Reserved: array [0..3] of LongInt;
end;


tDevInfo

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure representing a device

Declaration

Source position: amigados.pas line 1467

type tDevInfo = record
dvi_Next: LongInt; | Pointer to next device list
dvi_Type: LongInt; | Type of record (DLT_*)
dvi_Task: Pointer; | Pointer to handler task
dvi_Lock: LongInt; | Lock to Device
dvi_Handler: LongInt; | Handler for device
dvi_StackSize: LongInt; | Stacksize
dvi_Priority: LongInt; | Priority in list
dvi_Startup: LongInt; |
dvi_SegList: LongInt; |
dvi_GlobVec: LongInt; |
dvi_Name: LongInt; |
end;


TDevProc

Structure return by GetDeviceProc()

Declaration

Source position: amigados.pas line 1552

type TDevProc = record
dvp_Port: PMsgPort; |
dvp_Lock: LongInt; |
dvp_Flags: LongWord; | Flags (DVPF_*)
end;


tDosEnvec

Describes the disk geometry

Declaration

Source position: amigados.pas line 1679

type tDosEnvec = record
de_TableSize: LongWord; | Size of Environment vector
de_SizeBlock: LongWord; | in longwords: standard value is 128
de_SecOrg: LongWord; | not used; must be 0
de_Surfaces: LongWord; | # of heads (surfaces). drive specific
de_SectorPerBlock: LongWord; | not used; must be 1
de_BlocksPerTrack: LongWord; | blocks per track. drive specific
de_Reserved: LongWord; | DOS reserved blocks at start of partition.
de_PreAlloc: LongWord; | DOS reserved blocks at end of partition
de_Interleave: LongWord; | usually 0
de_LowCyl: LongWord; | starting cylinder. typically 0
de_HighCyl: LongWord; | max cylinder. drive specific
de_NumBuffers: LongWord; | Initial # DOS of buffers.
de_BufMemType: LongWord; | Type of mem to allocate for buffers
de_MaxTransfer: LongWord; | Max number of bytes to transfer at a time
de_Mask: LongWord; | Address Mask to block out certain memory
de_BootPri: LongInt; | Boot priority for autoboot
de_DosType: LongWord; | ASCII (HEX) string showing filesystem type; $444F5300 OFS, $444F5301 FFS
de_Baud: LongWord; | Baud rate for serial handler
de_Control: LongWord; | Control SmallInt for handler/filesystem
de_BootBlocks: LongWord; | Number of blocks containing boot code
end;

Description

Here are the constants for a standard geometry. if you treat it as an array you can use the DE_* constants


tDosInfo

Declaration

Source position: amigados.pas line 1290

type tDosInfo = record
case SmallInt of
0: (
di_ResList: LongInt; |
);
1: (
di_McName: LongInt; | Network name of this machine; currently 0
di_DevInfo: LongInt; | Device List
di_Devices: LongInt; | Currently 0
di_Handlers: LongInt; | Currently 0
di_NetHand: Pointer; | Network handler processid; currently 0
di_DevLock: TSignalSemaphore; | do NOT access directly!
di_EntryLock: TSignalSemaphore; | do NOT access directly!
di_DeleteLock: TSignalSemaphore; | do NOT access directly!
);
end;


tDosLibrary

This is how the base of dos.library looks like.

Declaration

Source position: amigados.pas line 1252

type tDosLibrary = record
dl_lib: TLibrary; |
dl_Root: Pointer; | Pointer to RootNode
dl_GV: Pointer; |
dl_A2: LongInt; |
dl_A5: LongInt; |
dl_A6: LongInt; |
dl_Errors: pErrorString; | Pointer to array of error msgs
dl_TimeReq: PTimeRequest; | Private pointer to timer request
dl_UtilityBase: PLibrary; | Private ptr to utility library
dl_IntuitionBase: PLibrary; | Private ptr to intuition library
end;


TDOSList

This structure can take on different values depending on whether it is a device, an assigned directory, or a volume. This structure combined structure for devices, assigned directories, volumes.

Declaration

Source position: amigados.pas line 1411

type TDOSList = record
dol_Next: DWord; | Pointer to next device on list
dol_Type: LongInt; | Type of record (DLT_*)
dol_Task: PMsgPort; | Pointer to handler task
dol_Lock: DWord; |
case Byte of
0: (
dol_handler: record | file name to load if seglist is nil
dol_Handler: DWord; |
dol_StackSize: LongInt; |
dol_Priority: LongInt; |
dol_Startup: DWord; |
dol_SegList: DWord; |
dol_GlobVec: DWord; |
end;
);
1: (
dol_volume: record |
dol_VolumeDate: TDateStamp; |
dol_LockList: DWord; |
dol_DiskType: LongInt; |
end;
);
2: (
dol_assign: record |
dol_AssignName: PChar; |
dol_List: pAssignList; |
end;
);
3: (
dol_Misc: array [0..23] of Byte; |
dol_Name: DWord; | Name of Entry
);
end;


TDosPacket

This is the extension to EXEC Messages used by DOS

Declaration

Source position: amigados.pas line 977

type TDosPacket = record
dp_Link: PMessage; | Exec Message
dp_Port: PMsgPort; | Reply port for the packet. Must be filled in each send.
case SmallInt of
0: (
dp_Action: LongInt; |
dp_Status: LongInt; |
dp_Status2: LongInt; |
dp_BufAddr: LongInt; |
);
1: (
dp_Type: LongInt; | Type of access =Ord('W') write = Ord('R') read (ACTION_*)
dp_Res1: LongInt; |
dp_Res2: LongInt; |
dp_Arg1: LongInt; |
dp_Arg2: LongInt; |
dp_Arg3: LongInt; |
dp_Arg4: LongInt; |
dp_Arg5: LongInt; |
dp_Arg6: LongInt; |
dp_Arg7: LongInt; |
);
end;


TDosPacket64

Declaration

Source position: amigados.pas line 1012

type TDosPacket64 = record

  dp_Link: PMessage;

  dp_Port: PMsgPort;

  case SmallInt of

    0: (

        dp_Action: LongInt;

        dp_pad: LongInt;

        dp_Status2: LongInt;

        dp_Status: Int64;

        dp_BufAddr: LongInt;

      );

    1: (

        dp_Type: LongInt;

        dp_Res0: LongInt;

        dp_Res2: LongInt;

        dp_Res1: Int64;

        dp_Arg1: LongInt;

        dp_Arg2: Int64;

        dp_Arg3: LongInt;

        dp_Arg4: LongInt;

        dp_Arg5: Int64;

      );

end;


TDosResidentSeg

Declaration

Source position: amigados.pas line 1219

type TDosResidentSeg = record

  seg_Next: LongInt;

  seg_UC: LongInt;

  seg_Seg: LongInt;

  seg_Name: array [0..3] of Char;

end;


TDR_Arg1

Declaration

Source position: amigados.pas line 2368

const TDR_Arg1 = TDR_Dummy + 20;


TDR_Arg2

Declaration

Source position: amigados.pas line 2369

const TDR_Arg2 = TDR_Dummy + 21;


TDR_Arg3

Declaration

Source position: amigados.pas line 2370

const TDR_Arg3 = TDR_Dummy + 22;


TDR_Arg4

Declaration

Source position: amigados.pas line 2371

const TDR_Arg4 = TDR_Dummy + 23;


TDR_Arg5

Declaration

Source position: amigados.pas line 2372

const TDR_Arg5 = TDR_Dummy + 24;


TDR_Arg6

Declaration

Source position: amigados.pas line 2373

const TDR_Arg6 = TDR_Dummy + 25;


TDR_Arg7

Declaration

Source position: amigados.pas line 2374

const TDR_Arg7 = TDR_Dummy + 26;


TDR_Arg8

Declaration

Source position: amigados.pas line 2375

const TDR_Arg8 = TDR_Dummy + 27;


TDR_Arg9

Declaration

Source position: amigados.pas line 2376

const TDR_Arg9 = TDR_Dummy + 28;


TDR_Arg10

Declaration

Source position: amigados.pas line 2377

const TDR_Arg10 = TDR_Dummy + 29;


TDR_ArgArray

Declaration

Source position: amigados.pas line 2352

const TDR_ArgArray = TDR_Dummy + 9;


TDR_CharSet

Declaration

Source position: amigados.pas line 2358

const TDR_CharSet = TDR_Dummy + 11;


TDR_Dummy

Declaration

Source position: amigados.pas line 2332

const TDR_Dummy = TAG_USER + 3500;


TDR_EasyStruct

Declaration

Source position: amigados.pas line 2338

const TDR_EasyStruct = TDR_Dummy + 4;


TDR_FormatString

Declaration

Source position: amigados.pas line 2339

const TDR_FormatString = TDR_Dummy + 5;


TDR_GadgetString

Declaration

Source position: amigados.pas line 2342

const TDR_GadgetString = TDR_Dummy + 7;


TDR_IDCMP_Ptr

Declaration

Source position: amigados.pas line 2334

const TDR_IDCMP_Ptr = TDR_Dummy + 1;


TDR_ImageType

Declaration

Source position: amigados.pas line 2343

const TDR_ImageType = TDR_Dummy + 8;


TDR_Inactive

Declaration

Source position: amigados.pas line 2354

const TDR_Inactive = TDR_Dummy + 10;


TDR_NonBlocking

Declaration

Source position: amigados.pas line 2364

const TDR_NonBlocking = TDR_Dummy + 12;


TDR_Timeout

Declaration

Source position: amigados.pas line 2335

const TDR_Timeout = TDR_Dummy + 2;


TDR_TitleString

Declaration

Source position: amigados.pas line 2341

const TDR_TitleString = TDR_Dummy + 6;


TDR_Window

Declaration

Source position: amigados.pas line 2337

const TDR_Window = TDR_Dummy + 3;


TDRIMAGE_DEFAULT

Declaration

Source position: amigados.pas line 2345

const TDRIMAGE_DEFAULT = 0;


TDRIMAGE_ERROR

Declaration

Source position: amigados.pas line 2348

const TDRIMAGE_ERROR = 3;


TDRIMAGE_INFO

Declaration

Source position: amigados.pas line 2346

const TDRIMAGE_INFO = 1;


TDRIMAGE_INSERTDISK

Declaration

Source position: amigados.pas line 2350

const TDRIMAGE_INSERTDISK = 5;


TDRIMAGE_QUESTION

Declaration

Source position: amigados.pas line 2349

const TDRIMAGE_QUESTION = 4;


TDRIMAGE_WARNING

Declaration

Source position: amigados.pas line 2347

const TDRIMAGE_WARNING = 2;


tErrorString

A structure for holding error messages - stored as array with error = 0 for the last entry.

Declaration

Source position: amigados.pas line 1238

type tErrorString = record

  estr_Nums: Pointer;

  estr_Strings: Pointer;

end;


TExAllControl

Control structure passed to ExAll().

Declaration

Source position: amigados.pas line 1670

type TExAllControl = record
eac_Entries: LongWord; | Number of entries returned in buffer
eac_LastKey: LongWord; | Don't touch inbetween linked ExAll calls!
eac_MatchString: PChar; | Wildcard string for pattern match or nil
eac_MatchFunc: PHook; | optional private wildcard function pointer
end;

Description

Unused fields must be initialized to 0, expecially eac_LastKey.

eac_MatchFunc is a hook (see utility.library documentation for usage) It should return True if the entry is to returned, False if it is to be ignored.

This structure must be allocated by AllocDosObject()!


TExAllData

Structure in which exall results are returned in. Note that only the fields asked for will exist!

Declaration

Source position: amigados.pas line 1651

type TExAllData = record

  ed_Next: PExAllData;

  ed_Name: PChar;

  ed_Type: LongInt;

  ed_Size: LongWord;

  ed_Prot: LongWord;

  ed_Days: LongWord;

  ed_Mins: LongWord;

  ed_Ticks: LongWord;

  ed_Comment: PChar;

  ed_OwnerUID: Word;

  ed_OwnerGID: Word;

end;


TExamineData

Declaration

Source position: amigados.pas line 136

type TExamineData = record

  EXDnode: TMinNode;

  EXDinfo: LongWord;

  FSPrivate: LongWord;

  Reserved0: LongWord;

  DOSPrivate: Pointer;

  StructSize: LongWord;

  Type_: LongWord;

  FileSize: Int64;

  Date: TDateStamp;

  RefCount: LongWord;

  ObjectID: QWord;

  Name: PChar;

  NameSize: LongWord;

  Comment: PChar;

  CommentSize: LongWord;

  Link: PChar;

  LinkSize: LongWord;

  Protection: LongWord;

  OwnerUID: LongWord;

  OwnerGID: LongWord;

  Reserved2: LongWord;

  Reserved3: LongWord;

  Reserved4: LongWord;

end;


TFileHandle

The pointer of this structure is returned by DosOpen() and other routines that return a file. You need only worry about this struct to do async io's via PutMsg() instead of standard file system calls

Declaration

Source position: amigados.pas line 956

type TFileHandle = record
fh_StructSize: Word;
fh_Flags: Word; | EXEC message
fh_Interactive: LongInt;
fh_MsgPort: PMsgPort;
fh_Buf: LongInt; | Port to do ReplyMsg()
fh_Pos: LongInt; |
fh_End: LongInt; |
fh_Func1: Pointer; |
fh_Func2: Pointer; |
fh_Func3: Pointer; |
fh_Arg1: LongInt; |
fh_Arg2: Pointer; |
fh_OpenerPID: LongWord;
fh_Reserved2: LongInt;
fh_Reserved1: LongInt;
fh_Priv: array [0..17] of LongInt;
end;


TFileInfoBlock

File information structure

Declaration

Source position: amigados.pas line 305

type TFileInfoBlock = record
fib_DiskKey: LongWord; |
fib_DirEntryType: LongInt; | Type of File. < 0 plain file, > 0 a directory
fib_FileName: array [0..107] of Char; | Name of the File or Directory
fib_Protection: LongWord; | Protection bits (FIBF_*)
fib_Obsolete: LongInt;
fib_Size: LongWord; | Size of file in Bytes
fib_NumBlocks: LongWord; | Size of File in blocks
fib_Date: TDateStamp; | Last change Date of File
fib_Comment: array [0..79] of Char; | Comment of File
fib_OwnerUID: Word; | Owners User ID (0 = no user id)
fib_OwnerGID: Word; | Owners Group ID (0 = no group ID)
fib_Reserved: array [0..7] of Pointer; |
end;

Description

Provides many informations about a file without a need to open it.

See also

Examine | Examine a directory or file associated with a lock
FIBF_DELETE | Protection Value file can be deleted
FIBF_EXECUTE | Protection Value file can be exceuted
FIBF_WRITE | Protection Value file is writeable
FIBF_READ | Protection Value: File is readable
FIBF_ARCHIVE | Protection Value File is marked as archived
FIBF_PURE | Protection Value program is reentrant and rexecutable
FIBF_SCRIPT | Protection Value: File is a script


tFileLock

Lock structure, as returned by Lock() or DupLock()

Declaration

Source position: amigados.pas line 1617

type tFileLock = record
fl_Link: LongInt; | Pointer to next lock
fl_Key: LongInt; | Disk block number
fl_Access: LongInt; | Exclusive or share
fl_Task: PMsgPort; | Handler task's port
fl_Volume: LongInt; | Pointer to a DeviceList
end;


TFileSysStartupMsg

Filesystem startup message for a device

Declaration

Source position: amigados.pas line 1733

type TFileSysStartupMsg = record
fssm_Unit: LongWord; | Exec unit number for this device
fssm_Device: LongInt; | Device Name
fssm_Environ: LongInt; | Pointer to Dos environment table
fssm_Flags: LongWord; | Flags for OpenDevice()
end;

Description

The file system startup message is linked into a device node's startup field. It contains a pointer to the Dos environment table and the information needed to do an OpenDevice()


TFileSystemData

Declaration

Source position: amigados.pas line 1744

type TFileSystemData = record

  fsd_Size: LongWord;

  fsd_FileSystemName: PChar;

  fsd_DeviceName: PChar;

  fsd_DeviceUnit: LongWord;

  fsd_DeviceFlags: LongWord;

  fsd_Environment: pDosEnvec;

  fsd_DosPrivate: array [0..3] of Pointer;

  fsd_Reserved: array [0..3] of Pointer;

end;


TFileSystemVectorPort

Declaration

Source position: amigados.pas line 1823

type TFileSystemVectorPort = record

  MP: TMsgPort;

  FSV: TFileSystemVectors;

end;


TFileSystemVectors

Declaration

Source position: amigados.pas line 1760

type TFileSystemVectors = record

  StructSize: LongWord;

  Version: LongWord;

  FSPrivate: Pointer;

  Reserved: array [0..2] of LongWord;

  DOSPrivate: Pointer;

  DOSEmulatePacket: Pointer;

  FSLock: Pointer;

  FSUnLock: Pointer;

  FSDupLock: Pointer;

  FSCreateDir: Pointer;

  FSParentDir: Pointer;

  FSDupLockFromFH: Pointer;

  FSOpenFromLock: Pointer;

  FSParentOfFH: Pointer;

  FSOpen: Pointer;

  FSClose: Pointer;

  FSDelete: Pointer;

  FSRead: Pointer;

  FSWrite: Pointer;

  FSFlush: Pointer;

  FSChangeFilePosition: Pointer;

  FSChangeFileSize: Pointer;

  FSGetFilePosition: Pointer;

  FSGetFileSize: Pointer;

  FSChangeLockMode: Pointer;

  FSChangeFileMode: Pointer;

  FSSetDate: Pointer;

  FSSetProtection: Pointer;

  FSSetComment: Pointer;

  FSSetGroup: Pointer;

  FSSetOwner: Pointer;

  FSRename: Pointer;

  FSCreateSoftLink: Pointer;

  FSCreateHardLink: Pointer;

  FSReadSoftLink: Pointer;

  FSSameLock: Pointer;

  FSSameFile: Pointer;

  FSFileSystemAttr: Pointer;

  FSVolumeInfoData: Pointer;

  FSDeviceInfoData: Pointer;

  FSReserved1: Pointer;

  FSReserved2: Pointer;

  FSExamineLock: Pointer;

  FSExamineFile: Pointer;

  FSExamineDir: Pointer;

  FSInhibit: Pointer;

  FSWriteProtect: Pointer;

  FSFormat: Pointer;

  FSSerialize: Pointer;

  FSRelabel: Pointer;

  FSReserved3: Pointer;

  FSAddNotify: Pointer;

  FSRemoveNotify: Pointer;

  FSLockRecord: Pointer;

  FSUnLockRecord: Pointer;

  End_Marker: LongInt;

end;


TFindTrackedAddressMsg

Declaration

Source position: amigados.pas line 1170

type TFindTrackedAddressMsg = record

  ftam_Size: LongInt;

  ftam_Name: PChar;

  ftam_Date: TDateStamp;

  ftam_SegList: LongInt;

  ftam_SegmentNumber: LongWord;

  ftam_SegmentOffset: LongWord;

  ftam_ExtraInfo: Pointer;

  ftam_ExtraInfoSize: LongInt;

  ftam_AAS: TAddressAndSize;

end;


TFReadLineData

Declaration

Source position: amigados.pas line 589

type TFReadLineData = record

  frld_Line: PChar;

  frld_LineLength: LongWord;

  frld_DosPrivate: array [0..7] of LongWord;

end;


TICKS_PER_SECOND

Number of ticks per second. Defines the acuracy of your time

Declaration

Source position: amigados.pas line 123

const TICKS_PER_SECOND = 50;


TInfoData

General Disk informatons from Info

Declaration

Source position: amigados.pas line 375

type TInfoData = record
id_NumSoftErrors: LongInt; | Number of soft errors on disk
id_UnitNumber: LongInt; | Which unit disk is (was) mounted on
id_DiskState: LongInt; | Disk State (ID_*)
id_NumBlocks: LongWord; | Number of blocks on disk
id_NumBlocksUsed: LongWord; | Number of block in use
id_BytesPerBlock: LongWord; | Number of bytes per block
id_DiskType: LongInt; | Disk type code (ID_*)
id_VolumeNode: LongInt; | Pointer to volume node
id_InUse: LongInt; | If not it use = 0
end;

See also

Info

Returns information about the disk


TLocalVar

The structure in the TProcess.pr_LocalVars list

Declaration

Source position: amigados.pas line 2107

type TLocalVar = record
lv_Node: TNode; | Node of the entry. the .ln_Type (LV_*)
lv_Flags: Word; |
lv_Value: PChar; |
lv_Len: LongWord; |
end;

Description

Do not allocate yourself, use SetVar()! This structure may grow in future releases. The list should be left in alphabetical order, and may have multiple entries with the same name but different types.


TLock

Declaration

Source position: amigados.pas line 1533

type TLock = record

  fl_Link: LongInt;

  fl_Key: LongInt;

  fl_Access: LongInt;

  fl_Port: PMsgPort;

  fl_Volume: LongInt;

  fl_FSPrivate1: Pointer;

  fl_FSPrivate2: Pointer;

  fl_DOSType: LongWord;

  fl_StructSize: LongWord;

  fl_DosPrivate: LongInt;

  fl_Reserved: array [0..1] of LongInt;

end;


TMultiAssign

Declaration

Source position: amigados.pas line 1378

type TMultiAssign = record

  ma_Next: PMultiAssign;

  dat: record

    ma_lock: LongInt;

    ma_name: PChar;

  end;

end;


TNotifyHookMsg

Declaration

Source position: amigados.pas line 1956

type TNotifyHookMsg = record

  nhm_Size: LongInt;

  nhm_Action: LongInt;

  nhm_Name: PChar;

end;


TNotifyMessage

Declaration

Source position: amigados.pas line 1914

type TNotifyMessage = record

  nm_ExecMessage: TMessage;

  nm_Class: LongWord;

  nm_Code: Word;

  nm_NReq: PNotifyRequest;

  nm_DoNotTouch: LongWord;

  nm_DoNotTouch2: LongWord;

end;


tNotifyRequest

Declaration

Source position: amigados.pas line 1883

type tNotifyRequest = record
nr_Name: PChar; |
nr_FullName: PChar; |
nr_UserData: LongWord; |
nr_Flags: LongWord; | Flags for Notify Requesr (NRF_*)
nr_stuff: record |
case SmallInt of
0: (
nr_Msg: record |
nr_Port: PMsgPort; |
nr_MsgPad: array [0..3] of Byte;
end;
);
1: (
nr_Signal: record |
nr_Task: PTask; |
nr_SignalNum: Byte; |
nr_SigPad: array [0..2] of Byte;
end;
);
0: (
nr_CallHook: record
nr_Hook: PHook;
nr_HookPad: array [0..3] of Byte;
end;
);
end;
nr_Reserved: array [0..1] of LongWord; |
nr_DosPrivate: LongWord;
nr_FSPrivate: Pointer;
nr_MsgCount: LongWord; |
nr_Handler: PMsgPort; |
nr_Expansion: array [0..3] of LongWord;
end;


TPathNode

Declaration

Source position: amigados.pas line 1972

type TPathNode = record

  pn_Next: LongInt;

  pn_Lock: LongInt;

end;


TProcess

All DOS processes have this structure

Declaration

Source position: amigados.pas line 833

type TProcess = record
pr_Task: TTask; |
pr_MsgPort: TMsgPort; | This is address from DOS functions
pr_Size: Word;
pr_SegArray: LongInt;
pr_StackSize: LongWord; | Size of process stack in bytes
pr_gv: LongInt;
pr_CliNum: LongInt;
pr_sb: LongInt;
pr_Result2: LongInt; | Value of secondary result from last call
pr_CurrentDir: LongInt; | Lock associated with current directory
pr_CIS: LongInt; | Current CLI Input Stream
pr_COS: LongInt; | Current CLI Output Stream
pr_ConsoleTask: PMsgPort; | Console handler process for current window
pr_FileSystemTask: PMsgPort; | File handler process for current drive
pr_CLI: LongInt; | pointer to TConsoleLineInterpreter
pr_ra: Pointer;
pr_PktWait: Pointer; | Function to be called when awaiting msg
pr_WindowPtr: Pointer; | Window for error printing
pr_ProgramDir: LongInt;
pr_Flags: LongWord; | Flags telling dos about process (PRF_*)
pr_ExitCode: Pointer; | Code to call on exit of program or nil
pr_ExitData: LongInt; | Passed as an argument to pr_ExitCode.
pr_Arguments: PChar; | Arguments passed to the process at start
pr_LocalVars: TMinList; | Local environment variables
pr_ShellPrivate: LongWord; | for the use of the current shell
pr_CES: LongInt; | Error stream - if nil, use pr_COS
pr_PrData: Pointer;
pr_CurrentSeg: LongInt;
pr_EmulPrivate: LongWord;
pr_68kPrivate: LongWord;
pr_ParentID: LongWord;
pr_ProcessID: LongWord;
pr_Reserved4: LongWord;
pr_OGLContextData: Pointer;
pr_Reserved5: Pointer;
pr_CLibData: Pointer;
pr_Reserved6: Pointer;
pr_RestoreList: TMinList;
pr_DeathSigTask: Pointer;
pr_DeathSigBit: LongWord;
pr_DeathMessage: Pointer;
pr_EntryCode: Pointer;
pr_EntryData: LongInt;
pr_FinalCode: Pointer;
pr_FinalData: LongInt;
pr_DLNotifyData: LongWord;
pr_PLNotifyData: LongWord;
pr_UID: LongWord;
pr_GID: LongWord;
pr_Reserved3: LongInt;
pr_Reserved2: LongInt;
pr_Reserved1: LongInt;
pr_Reserved0: LongInt;
end;

Description

Create and Device Proc returns pointer to the MsgPort in this structure dev_proc = Address(SmallInt(DeviceProc()) - SizeOf(Task))


TPseudoSegList

Declaration

Source position: amigados.pas line 1196

type TPseudoSegList = record

  ps_Next: LongInt;

  ps_Jump: LongWord;

  ps_Entry: Pointer;

  ps_Ikey: LongWord;

  ps_DosPrivate: LongWord;

  ps_Reserved1: LongWord;

  ps_Reserved2: LongWord;

  ps_Data: array [0..3] of Byte;

end;


TRDArgs

Input parameter structure used in ReadArgs()

Declaration

Source position: amigados.pas line 2066

type TRDArgs = record
RDA_Source: TCSource; | Select input source
RDA_DAList: LongInt; | private field do not touch.
RDA_Buffer: PChar; | Optional string parsing space.
RDA_BufSiz: LongInt; | Size of RDA_Buffer (0..n)
RDA_ExtHelp: PChar; | Optional extended help
RDA_Flags: LongInt; | Flags for any required control (RDAF_*)
end;

Description

if RDA_Source.CS_Buffer is not nil, RDA_Source is used as the input character stream to parse, else the input comes from the buffered STDIN

RDA_DAList is a private address which is used internally to track allocations which are freed by FreeArgs(). This must be initialized to nil prior to the first call to ReadArgs().

The RDA_Buffer and RDA_BufSiz fields allow the application to supply a fixed-size buffer in which to store the parsed data. This allows the application to pre-allocate a buffer rather than requiring buffer space to be allocated. If either RDA_Buffer or RDA_BufSiz is nil or 0, the application has not supplied a buffer.

RDA_ExtHelp is a text string which will be displayed instead of the template string, if the user is prompted for input.

RDA_Flags bits control how ReadArgs() works. The flag bits are defined with (RDAF_*). Defaults are initialized to 0.


TRecordLock

Parameter struct for TRecordLock.rec_Mode

Declaration

Source position: amigados.pas line 2096

type TRecordLock = record
rec_Size: LongWord;
rec_FH: LongInt; | Filehandle
rec_Offset: LongWord; | Offset in file
rec_Length: LongWord; | Length of file to be locked
rec_Mode: LongWord; | Type of lock (REC_*)
end;


tRootNode

Declaration

Source position: amigados.pas line 1266

type tRootNode = record
rn_TaskArray: LongInt; | [0] is max number of CLI's [1] is APTR to process id of CLI 1 [n] is APTR to process id of CLI n
rn_ConsoleSegment: LongInt; | SegList for the CLI
rn_Time: TDateStamp; | Current time
rn_RestartSeg: LongInt; | SegList for the disk validator process
rn_Info: LongInt; | Pointer ot the Info structure
rn_FileHandlerSegment: LongInt; | Segment for a file handler
rn_CliList: TMinList; | New list of all CLI processes the first cpl_Array is also rn_TaskArray
rn_BootProc: PMsgPort; | Private pointer to msgport of boot file system
rn_ShellSegment: LongInt; | Seglist for Shell (for NewShell)
rn_Flags: LongInt; | dos flags
end;


TSearchCmdPathListMsg

Declaration

Source position: amigados.pas line 1985

type TSearchCmdPathListMsg = record

  splm_Size: LongInt;

  splm_Lock: LongInt;

  splm_Name: PChar;

end;


TStandardPacket

Declaration

Source position: amigados.pas line 1004

type TStandardPacket = record

  sp_Msg: TMessage;

  sp_Pkt: TDosPacket;

end;


TStandardPacket64

Declaration

Source position: amigados.pas line 1036

type TStandardPacket64 = record

  sp_Msg: TMessage;

  sp_Pkt: TDosPacket64;

end;


TVolumeNode

Declaration

Source position: amigados.pas line 1344

type TVolumeNode = record

  vn_Next: LongInt;

  vn_Type: LongInt;

  vn_Port: PMsgPort;

  vn_Reserved2: LongInt;

  vn_VolumeDate: TDateStamp;

  vn_LockList: LongInt;

  vn_DOSType: LongInt;

  vn_FSPrivate: LongInt;

  vn_Name: LongInt;

  vn_StructSize: LongInt;

  vn_Reserved: array [0..3] of LongInt;

end;


WFDB_READ

Declaration

Source position: amigados.pas line 80

const WFDB_READ = 0;


WFDB_WRITE

Declaration

Source position: amigados.pas line 81

const WFDB_WRITE = 1;


WFDF_READ

Declaration

Source position: amigados.pas line 83

const WFDF_READ = 1 shl WFDB_READ;


WFDF_WRITE

Declaration

Source position: amigados.pas line 84

const WFDF_WRITE = 1 shl WFDB_WRITE;


ASL_Dummy

Declaration

Source position: asl.pas line 25

const ASL_Dummy = TAG_USER + $80000;


ASL_FileRequest

Declaration

Source position: asl.pas line 28

const ASL_FileRequest = 0;


ASL_FontRequest

Declaration

Source position: asl.pas line 29

const ASL_FontRequest = 1;


ASL_LAST_TAG

Declaration

Source position: asl.pas line 365

const ASL_LAST_TAG = ASL_Dummy + 133;


ASL_ScreenModeRequest

Declaration

Source position: asl.pas line 30

const ASL_ScreenModeRequest = 2;


ASL_SEMAPHORE_NAME

Declaration

Source position: asl.pas line 372

const ASL_SEMAPHORE_NAME: PChar = 'asl.library';


ASLBase

Declaration

Source position: asl.pas line 499

var ASLBase: PLibrary;


ASLFO_Activate

Declaration

Source position: asl.pas line 196

const ASLFO_Activate = ASL_Dummy + 132;


ASLFO_BackPens

Declaration

Source position: asl.pas line 238

const ASLFO_BackPens = ASL_Dummy + 65;


ASLFO_DoBackPen

Declaration

Source position: asl.pas line 221

const ASLFO_DoBackPen = ASL_Dummy + 45;


ASLFO_DoDrawMode

Declaration

Source position: asl.pas line 223

const ASLFO_DoDrawMode = ASL_Dummy + 47;


ASLFO_DoFrontPen

Declaration

Source position: asl.pas line 220

const ASLFO_DoFrontPen = ASL_Dummy + 44;


ASLFO_DoStyle

Declaration

Source position: asl.pas line 222

const ASLFO_DoStyle = ASL_Dummy + 46;


ASLFO_FilterFunc

Declaration

Source position: asl.pas line 230

const ASLFO_FilterFunc = ASL_Dummy + 49;


ASLFO_FixedWidthOnly

Declaration

Source position: asl.pas line 227

const ASLFO_FixedWidthOnly = ASL_Dummy + 48;


ASLFO_Flags

Declaration

Source position: asl.pas line 219

const ASLFO_Flags = ASL_Dummy + 20;


ASLFO_FrontPens

Declaration

Source position: asl.pas line 237

const ASLFO_FrontPens = ASL_Dummy + 64;


ASLFO_HookFunc

Declaration

Source position: asl.pas line 231

const ASLFO_HookFunc = ASL_Dummy + 7;


ASLFO_InitialBackPen

Declaration

Source position: asl.pas line 215

const ASLFO_InitialBackPen = ASL_Dummy + 15;


ASLFO_InitialDrawMode

Declaration

Source position: asl.pas line 216

const ASLFO_InitialDrawMode = ASL_Dummy + 59;


ASLFO_InitialFlags

Declaration

Source position: asl.pas line 213

const ASLFO_InitialFlags = ASL_Dummy + 13;


ASLFO_InitialFrontPen

Declaration

Source position: asl.pas line 214

const ASLFO_InitialFrontPen = ASL_Dummy + 14;


ASLFO_InitialHeight

Declaration

Source position: asl.pas line 209

const ASLFO_InitialHeight = ASL_Dummy + 6;


ASLFO_InitialLeftEdge

Declaration

Source position: asl.pas line 206

const ASLFO_InitialLeftEdge = ASL_Dummy + 3;


ASLFO_InitialName

Declaration

Source position: asl.pas line 210

const ASLFO_InitialName = ASL_Dummy + 10;


ASLFO_InitialSize

Declaration

Source position: asl.pas line 211

const ASLFO_InitialSize = ASL_Dummy + 11;


ASLFO_InitialStyle

Declaration

Source position: asl.pas line 212

const ASLFO_InitialStyle = ASL_Dummy + 12;


ASLFO_InitialTopEdge

Declaration

Source position: asl.pas line 207

const ASLFO_InitialTopEdge = ASL_Dummy + 4;


ASLFO_InitialWidth

Declaration

Source position: asl.pas line 208

const ASLFO_InitialWidth = ASL_Dummy + 5;


ASLFO_IntuiMsgFunc

Declaration

Source position: asl.pas line 192

const ASLFO_IntuiMsgFunc = ASL_Dummy + 70;


ASLFO_Locale

Declaration

Source position: asl.pas line 200

const ASLFO_Locale = ASL_Dummy + 50;


ASLFO_MaxBackPen

Declaration

Source position: asl.pas line 233

const ASLFO_MaxBackPen = ASL_Dummy + 67;


ASLFO_MaxFrontPen

Declaration

Source position: asl.pas line 232

const ASLFO_MaxFrontPen = ASL_Dummy + 66;


ASLFO_MaxHeight

Declaration

Source position: asl.pas line 229

const ASLFO_MaxHeight = ASL_Dummy + 17;


ASLFO_MinHeight

Declaration

Source position: asl.pas line 228

const ASLFO_MinHeight = ASL_Dummy + 16;


ASLFO_ModeList

Declaration

Source position: asl.pas line 236

const ASLFO_ModeList = ASL_Dummy + 21;


ASLFO_NegativeText

Declaration

Source position: asl.pas line 203

const ASLFO_NegativeText = ASL_Dummy + 19;


ASLFO_PopToFront

Declaration

Source position: asl.pas line 195

const ASLFO_PopToFront = ASL_Dummy + 131;


ASLFO_PositiveText

Declaration

Source position: asl.pas line 202

const ASLFO_PositiveText = ASL_Dummy + 18;


ASLFO_PrivateIDCMP

Declaration

Source position: asl.pas line 191

const ASLFO_PrivateIDCMP = ASL_Dummy + 42;


ASLFO_PubScreenName

Declaration

Source position: asl.pas line 190

const ASLFO_PubScreenName = ASL_Dummy + 41;


ASLFO_SampleText

Declaration

Source position: asl.pas line 224

const ASLFO_SampleText = ASL_Dummy + 133;


ASLFO_Screen

Declaration

Source position: asl.pas line 189

const ASLFO_Screen = ASL_Dummy + 40;


ASLFO_SleepWindow

Declaration

Source position: asl.pas line 193

const ASLFO_SleepWindow = ASL_Dummy + 43;


ASLFO_TextAttr

Declaration

Source position: asl.pas line 199

const ASLFO_TextAttr = ASL_Dummy + 51;


ASLFO_TitleText

Declaration

Source position: asl.pas line 201

const ASLFO_TitleText = ASL_Dummy + 1;


ASLFO_UserData

Declaration

Source position: asl.pas line 194

const ASLFO_UserData = ASL_Dummy + 52;


ASLFO_Window

Declaration

Source position: asl.pas line 188

const ASLFO_Window = ASL_Dummy + 2;


ASLFR_AcceptPattern

Declaration

Source position: asl.pas line 105

const ASLFR_AcceptPattern = ASL_Dummy + 62;


ASLFR_Activate

Declaration

Source position: asl.pas line 74

const ASLFR_Activate = ASL_Dummy + 132;


ASLFR_DoMultiSelect

Declaration

Source position: asl.pas line 97

const ASLFR_DoMultiSelect = ASL_Dummy + 45;


ASLFR_DoPatterns

Declaration

Source position: asl.pas line 98

const ASLFR_DoPatterns = ASL_Dummy + 46;


ASLFR_DoSaveMode

Declaration

Source position: asl.pas line 96

const ASLFR_DoSaveMode = ASL_Dummy + 44;


ASLFR_DrawersOnly

Declaration

Source position: asl.pas line 101

const ASLFR_DrawersOnly = ASL_Dummy + 47;


ASLFR_FilterDrawers

Declaration

Source position: asl.pas line 106

const ASLFR_FilterDrawers = ASL_Dummy + 63;


ASLFR_FilterFunc

Declaration

Source position: asl.pas line 102

const ASLFR_FilterFunc = ASL_Dummy + 49;


ASLFR_Flags1

Declaration

Source position: asl.pas line 94

const ASLFR_Flags1 = ASL_Dummy + 20;


ASLFR_Flags2

Declaration

Source position: asl.pas line 95

const ASLFR_Flags2 = ASL_Dummy + 22;


ASLFR_GetSortBy

Declaration

Source position: asl.pas line 111

const ASLFR_GetSortBy = ASL_Dummy + 125;


ASLFR_GetSortDrawers

Declaration

Source position: asl.pas line 113

const ASLFR_GetSortDrawers = ASL_Dummy + 127;


ASLFR_GetSortOrder

Declaration

Source position: asl.pas line 115

const ASLFR_GetSortOrder = ASL_Dummy + 129;


ASLFR_HookFunc

Declaration

Source position: asl.pas line 107

const ASLFR_HookFunc = ASL_Dummy + 7;


ASLFR_InitialDrawer

Declaration

Source position: asl.pas line 89

const ASLFR_InitialDrawer = ASL_Dummy + 9;


ASLFR_InitialFile

Declaration

Source position: asl.pas line 88

const ASLFR_InitialFile = ASL_Dummy + 8;


ASLFR_InitialHeight

Declaration

Source position: asl.pas line 87

const ASLFR_InitialHeight = ASL_Dummy + 6;


ASLFR_InitialLeftEdge

Declaration

Source position: asl.pas line 84

const ASLFR_InitialLeftEdge = ASL_Dummy + 3;


ASLFR_InitialPattern

Declaration

Source position: asl.pas line 90

const ASLFR_InitialPattern = ASL_Dummy + 10;


ASLFR_InitialShowVolumes

Declaration

Source position: asl.pas line 91

const ASLFR_InitialShowVolumes = ASL_Dummy + 130;


ASLFR_InitialTopEdge

Declaration

Source position: asl.pas line 85

const ASLFR_InitialTopEdge = ASL_Dummy + 4;


ASLFR_InitialWidth

Declaration

Source position: asl.pas line 86

const ASLFR_InitialWidth = ASL_Dummy + 5;


ASLFR_IntuiMsgFunc

Declaration

Source position: asl.pas line 70

const ASLFR_IntuiMsgFunc = ASL_Dummy + 70;


ASLFR_Locale

Declaration

Source position: asl.pas line 78

const ASLFR_Locale = ASL_Dummy + 50;


ASLFR_NegativeText

Declaration

Source position: asl.pas line 81

const ASLFR_NegativeText = ASL_Dummy + 19;


ASLFR_PopToFront

Declaration

Source position: asl.pas line 73

const ASLFR_PopToFront = ASL_Dummy + 131;


ASLFR_PositiveText

Declaration

Source position: asl.pas line 80

const ASLFR_PositiveText = ASL_Dummy + 18;


ASLFR_PrivateIDCMP

Declaration

Source position: asl.pas line 69

const ASLFR_PrivateIDCMP = ASL_Dummy + 42;


ASLFR_PubScreenName

Declaration

Source position: asl.pas line 68

const ASLFR_PubScreenName = ASL_Dummy + 41;


ASLFR_RejectIcons

Declaration

Source position: asl.pas line 103

const ASLFR_RejectIcons = ASL_Dummy + 60;


ASLFR_RejectPattern

Declaration

Source position: asl.pas line 104

const ASLFR_RejectPattern = ASL_Dummy + 61;


ASLFR_Screen

Declaration

Source position: asl.pas line 67

const ASLFR_Screen = ASL_Dummy + 40;


ASLFR_SetSortBy

Declaration

Source position: asl.pas line 110

const ASLFR_SetSortBy = ASL_Dummy + 124;


ASLFR_SetSortDrawers

Declaration

Source position: asl.pas line 112

const ASLFR_SetSortDrawers = ASL_Dummy + 126;


ASLFR_SetSortOrder

Declaration

Source position: asl.pas line 114

const ASLFR_SetSortOrder = ASL_Dummy + 128;


ASLFR_SleepWindow

Declaration

Source position: asl.pas line 71

const ASLFR_SleepWindow = ASL_Dummy + 43;


ASLFR_StayOnTop

Declaration

Source position: asl.pas line 117

const ASLFR_StayOnTop = ASL_Dummy + 142;


ASLFR_TextAttr

Declaration

Source position: asl.pas line 77

const ASLFR_TextAttr = ASL_Dummy + 51;


ASLFR_TitleText

Declaration

Source position: asl.pas line 79

const ASLFR_TitleText = ASL_Dummy + 1;


ASLFR_UserData

Declaration

Source position: asl.pas line 72

const ASLFR_UserData = ASL_Dummy + 52;


ASLFR_Window

Declaration

Source position: asl.pas line 66

const ASLFR_Window = ASL_Dummy + 2;


ASLFRSORTBY_Date

Declaration

Source position: asl.pas line 145

const ASLFRSORTBY_Date = 1;


ASLFRSORTBY_Name

Declaration

Source position: asl.pas line 144

const ASLFRSORTBY_Name = 0;


ASLFRSORTBY_Size

Declaration

Source position: asl.pas line 146

const ASLFRSORTBY_Size = 2;


ASLFRSORTDRAWERS_First

Declaration

Source position: asl.pas line 149

const ASLFRSORTDRAWERS_First = 0;


ASLFRSORTDRAWERS_Last

Declaration

Source position: asl.pas line 151

const ASLFRSORTDRAWERS_Last = 2;


ASLFRSORTDRAWERS_Mix

Declaration

Source position: asl.pas line 150

const ASLFRSORTDRAWERS_Mix = 1;


ASLFRSORTORDER_Ascend

Declaration

Source position: asl.pas line 154

const ASLFRSORTORDER_Ascend = 0;


ASLFRSORTORDER_Descend

Declaration

Source position: asl.pas line 155

const ASLFRSORTORDER_Descend = 1;


ASLNAME

Declaration

Source position: asl.pas line 24

const ASLNAME: PChar = 'asl.library';


ASLOPTION_ASLOverrides

Declaration

Source position: asl.pas line 408

const ASLOPTION_ASLOverrides = 1 shl 6;


ASLPOS_CenterMouse

Declaration

Source position: asl.pas line 397

const ASLPOS_CenterMouse = 5;


ASLPOS_CenterScreen

Declaration

Source position: asl.pas line 394

const ASLPOS_CenterScreen = 2;


ASLPOS_CenterWindow

Declaration

Source position: asl.pas line 393

const ASLPOS_CenterWindow = 1;


ASLPOS_DefaultPosition

Declaration

Source position: asl.pas line 392

const ASLPOS_DefaultPosition = 0;


ASLPOS_MASK

Declaration

Source position: asl.pas line 398

const ASLPOS_MASK = $0F;


ASLPOS_ScreenPosition

Declaration

Source position: asl.pas line 396

const ASLPOS_ScreenPosition = 4;


ASLPOS_WindowPosition

Declaration

Source position: asl.pas line 395

const ASLPOS_WindowPosition = 3;


ASLSIZE_DefaultSize

Declaration

Source position: asl.pas line 401

const ASLSIZE_DefaultSize = 0 shl 4;


ASLSIZE_MASK

Declaration

Source position: asl.pas line 405

const ASLSIZE_MASK = $30;


ASLSIZE_RelativeSize

Declaration

Source position: asl.pas line 402

const ASLSIZE_RelativeSize = 1 shl 4;


ASLSM_Activate

Declaration

Source position: asl.pas line 320

const ASLSM_Activate = ASL_Dummy + 132;


ASLSM_CustomSMList

Declaration

Source position: asl.pas line 363

const ASLSM_CustomSMList = ASL_Dummy + 123;


ASLSM_DoAutoScroll

Declaration

Source position: asl.pas line 349

const ASLSM_DoAutoScroll = ASL_Dummy + 113;


ASLSM_DoDepth

Declaration

Source position: asl.pas line 347

const ASLSM_DoDepth = ASL_Dummy + 111;


ASLSM_DoHeight

Declaration

Source position: asl.pas line 346

const ASLSM_DoHeight = ASL_Dummy + 110;


ASLSM_DoOverscanType

Declaration

Source position: asl.pas line 348

const ASLSM_DoOverscanType = ASL_Dummy + 112;


ASLSM_DoWidth

Declaration

Source position: asl.pas line 345

const ASLSM_DoWidth = ASL_Dummy + 109;


ASLSM_FilterFunc

Declaration

Source position: asl.pas line 360

const ASLSM_FilterFunc = ASL_Dummy + 122;


ASLSM_InitialAutoScroll

Declaration

Source position: asl.pas line 339

const ASLSM_InitialAutoScroll = ASL_Dummy + 105;


ASLSM_InitialDisplayDepth

Declaration

Source position: asl.pas line 337

const ASLSM_InitialDisplayDepth = ASL_Dummy + 103;


ASLSM_InitialDisplayHeight

Declaration

Source position: asl.pas line 336

const ASLSM_InitialDisplayHeight = ASL_Dummy + 102;


ASLSM_InitialDisplayID

Declaration

Source position: asl.pas line 334

const ASLSM_InitialDisplayID = ASL_Dummy + 100;


ASLSM_InitialDisplayWidth

Declaration

Source position: asl.pas line 335

const ASLSM_InitialDisplayWidth = ASL_Dummy + 101;


ASLSM_InitialHeight

Declaration

Source position: asl.pas line 333

const ASLSM_InitialHeight = ASL_Dummy + 6;


ASLSM_InitialInfoLeftEdge

Declaration

Source position: asl.pas line 341

const ASLSM_InitialInfoLeftEdge = ASL_Dummy + 107;


ASLSM_InitialInfoOpened

Declaration

Source position: asl.pas line 340

const ASLSM_InitialInfoOpened = ASL_Dummy + 106;


ASLSM_InitialInfoTopEdge

Declaration

Source position: asl.pas line 342

const ASLSM_InitialInfoTopEdge = ASL_Dummy + 108;


ASLSM_InitialLeftEdge

Declaration

Source position: asl.pas line 330

const ASLSM_InitialLeftEdge = ASL_Dummy + 3;


ASLSM_InitialOverscanType

Declaration

Source position: asl.pas line 338

const ASLSM_InitialOverscanType = ASL_Dummy + 104;


ASLSM_InitialTopEdge

Declaration

Source position: asl.pas line 331

const ASLSM_InitialTopEdge = ASL_Dummy + 4;


ASLSM_InitialWidth

Declaration

Source position: asl.pas line 332

const ASLSM_InitialWidth = ASL_Dummy + 5;


ASLSM_IntuiMsgFunc

Declaration

Source position: asl.pas line 316

const ASLSM_IntuiMsgFunc = ASL_Dummy + 70;


ASLSM_Locale

Declaration

Source position: asl.pas line 324

const ASLSM_Locale = ASL_Dummy + 50;


ASLSM_MaxDepth

Declaration

Source position: asl.pas line 359

const ASLSM_MaxDepth = ASL_Dummy + 121;


ASLSM_MaxHeight

Declaration

Source position: asl.pas line 357

const ASLSM_MaxHeight = ASL_Dummy + 119;


ASLSM_MaxWidth

Declaration

Source position: asl.pas line 355

const ASLSM_MaxWidth = ASL_Dummy + 117;


ASLSM_MinDepth

Declaration

Source position: asl.pas line 358

const ASLSM_MinDepth = ASL_Dummy + 120;


ASLSM_MinHeight

Declaration

Source position: asl.pas line 356

const ASLSM_MinHeight = ASL_Dummy + 118;


ASLSM_MinWidth

Declaration

Source position: asl.pas line 354

const ASLSM_MinWidth = ASL_Dummy + 116;


ASLSM_NegativeText

Declaration

Source position: asl.pas line 327

const ASLSM_NegativeText = ASL_Dummy + 19;


ASLSM_PopToFront

Declaration

Source position: asl.pas line 319

const ASLSM_PopToFront = ASL_Dummy + 131;


ASLSM_PositiveText

Declaration

Source position: asl.pas line 326

const ASLSM_PositiveText = ASL_Dummy + 18;


ASLSM_PrivateIDCMP

Declaration

Source position: asl.pas line 315

const ASLSM_PrivateIDCMP = ASL_Dummy + 42;


ASLSM_PropertyFlags

Declaration

Source position: asl.pas line 352

const ASLSM_PropertyFlags = ASL_Dummy + 114;


ASLSM_PropertyMask

Declaration

Source position: asl.pas line 353

const ASLSM_PropertyMask = ASL_Dummy + 115;


ASLSM_PubScreenName

Declaration

Source position: asl.pas line 314

const ASLSM_PubScreenName = ASL_Dummy + 41;


ASLSM_Screen

Declaration

Source position: asl.pas line 313

const ASLSM_Screen = ASL_Dummy + 40;


ASLSM_SleepWindow

Declaration

Source position: asl.pas line 317

const ASLSM_SleepWindow = ASL_Dummy + 43;


ASLSM_TextAttr

Declaration

Source position: asl.pas line 323

const ASLSM_TextAttr = ASL_Dummy + 51;


ASLSM_TitleText

Declaration

Source position: asl.pas line 325

const ASLSM_TitleText = ASL_Dummy + 1;


ASLSM_UserData

Declaration

Source position: asl.pas line 318

const ASLSM_UserData = ASL_Dummy + 52;


ASLSM_Window

Declaration

Source position: asl.pas line 312

const ASLSM_Window = ASL_Dummy + 2;


FOB_DOBACKPEN

Declaration

Source position: asl.pas line 242

const FOB_DOBACKPEN = 1;


FOB_DODRAWMODE

Declaration

Source position: asl.pas line 244

const FOB_DODRAWMODE = 3;


FOB_DOFRONTPEN

Declaration

Source position: asl.pas line 241

const FOB_DOFRONTPEN = 0;


FOB_DOSTYLE

Declaration

Source position: asl.pas line 243

const FOB_DOSTYLE = 2;


FOB_FILTERFUNC

Declaration

Source position: asl.pas line 248

const FOB_FILTERFUNC = 7;


FOB_FIXEDWIDTHONLY

Declaration

Source position: asl.pas line 245

const FOB_FIXEDWIDTHONLY = 4;


FOB_INTUIFUNC

Declaration

Source position: asl.pas line 247

const FOB_INTUIFUNC = 6;


FOB_PRIVATEIDCMP

Declaration

Source position: asl.pas line 246

const FOB_PRIVATEIDCMP = 5;


FOF_DOBACKPEN

Declaration

Source position: asl.pas line 251

const FOF_DOBACKPEN = 1 shl FOB_DOBACKPEN;


FOF_DODRAWMODE

Declaration

Source position: asl.pas line 253

const FOF_DODRAWMODE = 1 shl FOB_DODRAWMODE;


FOF_DOFRONTPEN

Declaration

Source position: asl.pas line 250

const FOF_DOFRONTPEN = 1 shl FOB_DOFRONTPEN;


FOF_DOSTYLE

Declaration

Source position: asl.pas line 252

const FOF_DOSTYLE = 1 shl FOB_DOSTYLE;


FOF_FILTERFUNC

Declaration

Source position: asl.pas line 257

const FOF_FILTERFUNC = 1 shl FOB_FILTERFUNC;


FOF_FIXEDWIDTHONLY

Declaration

Source position: asl.pas line 254

const FOF_FIXEDWIDTHONLY = 1 shl FOB_FIXEDWIDTHONLY;


FOF_INTUIFUNC

Declaration

Source position: asl.pas line 256

const FOF_INTUIFUNC = 1 shl FOB_INTUIFUNC;


FOF_PRIVATEIDCMP

Declaration

Source position: asl.pas line 255

const FOF_PRIVATEIDCMP = 1 shl FOB_PRIVATEIDCMP;


FRB_DOMULTISELECT

Declaration

Source position: asl.pas line 124

const FRB_DOMULTISELECT = 3;


FRB_DOPATTERNS

Declaration

Source position: asl.pas line 125

const FRB_DOPATTERNS = 0;


FRB_DOSAVEMODE

Declaration

Source position: asl.pas line 122

const FRB_DOSAVEMODE = 5;


FRB_DRAWERSONLY

Declaration

Source position: asl.pas line 135

const FRB_DRAWERSONLY = 0;


FRB_FILTERDRAWERS

Declaration

Source position: asl.pas line 136

const FRB_FILTERDRAWERS = 1;


FRB_FILTERFUNC

Declaration

Source position: asl.pas line 120

const FRB_FILTERFUNC = 7;


FRB_INTUIFUNC

Declaration

Source position: asl.pas line 121

const FRB_INTUIFUNC = 6;


FRB_PRIVATEIDCMP

Declaration

Source position: asl.pas line 123

const FRB_PRIVATEIDCMP = 4;


FRB_REJECTICONS

Declaration

Source position: asl.pas line 137

const FRB_REJECTICONS = 2;


FRF_DOMULTISELECT

Declaration

Source position: asl.pas line 131

const FRF_DOMULTISELECT = 1 shl FRB_DOMULTISELECT;


FRF_DOPATTERNS

Declaration

Source position: asl.pas line 132

const FRF_DOPATTERNS = 1 shl FRB_DOPATTERNS;


FRF_DOSAVEMODE

Declaration

Source position: asl.pas line 129

const FRF_DOSAVEMODE = 1 shl FRB_DOSAVEMODE;


FRF_DRAWERSONLY

Declaration

Source position: asl.pas line 139

const FRF_DRAWERSONLY = 1 shl FRB_DRAWERSONLY;


FRF_FILTERDRAWERS

Declaration

Source position: asl.pas line 140

const FRF_FILTERDRAWERS = 1 shl FRB_FILTERDRAWERS;


FRF_FILTERFUNC

Declaration

Source position: asl.pas line 127

const FRF_FILTERFUNC = 1 shl FRB_FILTERFUNC;


FRF_INTUIFUNC

Declaration

Source position: asl.pas line 128

const FRF_INTUIFUNC = 1 shl FRB_INTUIFUNC;


FRF_PRIVATEIDCMP

Declaration

Source position: asl.pas line 130

const FRF_PRIVATEIDCMP = 1 shl FRB_PRIVATEIDCMP;


FRF_REJECTICONS

Declaration

Source position: asl.pas line 141

const FRF_REJECTICONS = 1 shl FRB_REJECTICONS;


IASL

Declaration

Source position: asl.pas line 500

var IASL: PInterface;


Reference for unit 'asl'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility, | Tag Handling, Date routines in utility.library
Workbench, | Basic Workbench/AppIcons functions (workbench.library)
agraphics; | Native Amiga graphic functions (graphics.library)


Reference for unit 'asl': Constants

ASLFO_Activate

ASLFO_BackPens

ASLFO_DoBackPen

ASLFO_DoDrawMode

ASLFO_DoFrontPen

ASLFO_DoStyle

ASLFO_FilterFunc

ASLFO_FixedWidthOnly

ASLFO_Flags

ASLFO_FrontPens

ASLFO_HookFunc

ASLFO_InitialBackPen

ASLFO_InitialDrawMode

ASLFO_InitialFlags

ASLFO_InitialFrontPen

ASLFO_InitialHeight

ASLFO_InitialLeftEdge

ASLFO_InitialName

ASLFO_InitialSize

ASLFO_InitialStyle

ASLFO_InitialTopEdge

ASLFO_InitialWidth

ASLFO_IntuiMsgFunc

ASLFO_Locale

ASLFO_MaxBackPen

ASLFO_MaxFrontPen

ASLFO_MaxHeight

ASLFO_MinHeight

ASLFO_ModeList

ASLFO_NegativeText

ASLFO_PopToFront

ASLFO_PositiveText

ASLFO_PrivateIDCMP

ASLFO_PubScreenName

ASLFO_SampleText

ASLFO_Screen

ASLFO_SleepWindow

ASLFO_TextAttr

ASLFO_TitleText

ASLFO_UserData

ASLFO_Window

ASLFRSORTBY_Date

ASLFRSORTBY_Name

ASLFRSORTBY_Size

ASLFRSORTDRAWERS_First

ASLFRSORTDRAWERS_Last

ASLFRSORTDRAWERS_Mix

ASLFRSORTORDER_Ascend

ASLFRSORTORDER_Descend

ASLFR_AcceptPattern

ASLFR_Activate

ASLFR_DoMultiSelect

ASLFR_DoPatterns

ASLFR_DoSaveMode

ASLFR_DrawersOnly

ASLFR_FilterDrawers

ASLFR_FilterFunc

ASLFR_Flags1

ASLFR_Flags2

ASLFR_GetSortBy

ASLFR_GetSortDrawers

ASLFR_GetSortOrder

ASLFR_HookFunc

ASLFR_InitialDrawer

ASLFR_InitialFile

ASLFR_InitialHeight

ASLFR_InitialLeftEdge

ASLFR_InitialPattern

ASLFR_InitialShowVolumes

ASLFR_InitialTopEdge

ASLFR_InitialWidth

ASLFR_IntuiMsgFunc

ASLFR_Locale

ASLFR_NegativeText

ASLFR_PopToFront

ASLFR_PositiveText

ASLFR_PrivateIDCMP

ASLFR_PubScreenName

ASLFR_RejectIcons

ASLFR_RejectPattern

ASLFR_Screen

ASLFR_SetSortBy

ASLFR_SetSortDrawers

ASLFR_SetSortOrder

ASLFR_SleepWindow

ASLFR_StayOnTop

ASLFR_TextAttr

ASLFR_TitleText

ASLFR_UserData

ASLFR_Window

ASLNAME

ASLOPTION_ASLOverrides

ASLPOS_CenterMouse

ASLPOS_CenterScreen

ASLPOS_CenterWindow

ASLPOS_DefaultPosition

ASLPOS_MASK

ASLPOS_ScreenPosition

ASLPOS_WindowPosition

ASLSIZE_DefaultSize

ASLSIZE_MASK

ASLSIZE_RelativeSize

ASLSM_Activate

ASLSM_CustomSMList

ASLSM_DoAutoScroll

ASLSM_DoDepth

ASLSM_DoHeight

ASLSM_DoOverscanType

ASLSM_DoWidth

ASLSM_FilterFunc

ASLSM_InitialAutoScroll

ASLSM_InitialDisplayDepth

ASLSM_InitialDisplayHeight

ASLSM_InitialDisplayID

ASLSM_InitialDisplayWidth

ASLSM_InitialHeight

ASLSM_InitialInfoLeftEdge

ASLSM_InitialInfoOpened

ASLSM_InitialInfoTopEdge

ASLSM_InitialLeftEdge

ASLSM_InitialOverscanType

ASLSM_InitialTopEdge

ASLSM_InitialWidth

ASLSM_IntuiMsgFunc

ASLSM_Locale

ASLSM_MaxDepth

ASLSM_MaxHeight

ASLSM_MaxWidth

ASLSM_MinDepth

ASLSM_MinHeight

ASLSM_MinWidth

ASLSM_NegativeText

ASLSM_PopToFront

ASLSM_PositiveText

ASLSM_PrivateIDCMP

ASLSM_PropertyFlags

ASLSM_PropertyMask

ASLSM_PubScreenName

ASLSM_Screen

ASLSM_SleepWindow

ASLSM_TextAttr

ASLSM_TitleText

ASLSM_UserData

ASLSM_Window

ASL_Dummy

ASL_FileRequest

ASL_FontRequest

ASL_LAST_TAG

ASL_ScreenModeRequest

ASL_SEMAPHORE_NAME

FOB_DOBACKPEN

FOB_DODRAWMODE

FOB_DOFRONTPEN

FOB_DOSTYLE

FOB_FILTERFUNC

FOB_FIXEDWIDTHONLY

FOB_INTUIFUNC

FOB_PRIVATEIDCMP

FOF_DOBACKPEN

FOF_DODRAWMODE

FOF_DOFRONTPEN

FOF_DOSTYLE

FOF_FILTERFUNC

FOF_FIXEDWIDTHONLY

FOF_INTUIFUNC

FOF_PRIVATEIDCMP

FRB_DOMULTISELECT

FRB_DOPATTERNS

FRB_DOSAVEMODE

FRB_DRAWERSONLY

FRB_FILTERDRAWERS

FRB_FILTERFUNC

FRB_INTUIFUNC

FRB_PRIVATEIDCMP

FRB_REJECTICONS

FRF_DOMULTISELECT

FRF_DOPATTERNS

FRF_DOSAVEMODE

FRF_DRAWERSONLY

FRF_FILTERDRAWERS

FRF_FILTERFUNC

FRF_INTUIFUNC

FRF_PRIVATEIDCMP

FRF_REJECTICONS


Reference for unit 'asl': Types

PASLSemaphore

PDisplayMode

PFileRequester

PFontRequester

PScreenModeRequester

TASLSemaphore

TDisplayMode

TFileRequester

TFontRequester

TScreenModeRequester


PASLSemaphore

Declaration

Source position: asl.pas line 375

type PASLSemaphore = ^TASLSemaphore;


PDisplayMode

Declaration

Source position: asl.pas line 302

type PDisplayMode = ^TDisplayMode;


PFileRequester

Declaration

Source position: asl.pas line 43

type PFileRequester = ^TFileRequester;


PFontRequester

Declaration

Source position: asl.pas line 167

type PFontRequester = ^TFontRequester;


PScreenModeRequester

Declaration

Source position: asl.pas line 269

type PScreenModeRequester = ^TScreenModeRequester;


TASLSemaphore

Declaration

Source position: asl.pas line 376

type TASLSemaphore = record

  as_Semaphore: TSignalSemaphore;

  as_Version: Word;

  as_Size: LongWord;

  as_SortBy: Byte;

  as_SortDrawers: Byte;

  as_SortOrder: Byte;

  as_SizePosition: Byte;

  as_RelativeLeft: SmallInt;

  as_RelativeTop: SmallInt;

  as_RelativeWidth: Byte;

  as_RelativeHeight: Byte;

end;


TDisplayMode

Declaration

Source position: asl.pas line 303

type TDisplayMode = record

  dm_Node: TNode;

  dm_DimensionInfo: TDimensionInfo;

  dm_PropertyFlags: LongWord;

end;


TFileRequester

Declaration

Source position: asl.pas line 44

type TFileRequester = record

  fr_Reserved0: array [0..3] of Byte;

  fr_File: PChar;

  fr_Drawer: PChar;

  fr_Reserved1: array [0..9] of Byte;

  fr_LeftEdge: SmallInt;

  fr_TopEdge: SmallInt;

  fr_Width: SmallInt;

  fr_Height: SmallInt;

  fr_Reserved2: array [0..1] of Byte;

  fr_NumArgs: LongInt;

  fr_ArgList: PWBArgList;

  fr_UserData: Pointer;

  fr_Reserved3: array [0..7] of Byte;

  fr_Pattern: PChar;

end;


TFontRequester

Declaration

Source position: asl.pas line 168

type TFontRequester = record

  fo_Reserved0: array [0..7] of Byte;

  fo_Attr: TTextAttr;

  fo_FrontPen: Byte;

  fo_BackPen: Byte;

  fo_DrawMode: Byte;

  fo_Reserved1: Byte;

  fo_UserData: Pointer;

  fo_LeftEdge: SmallInt;

  fo_TopEdge: SmallInt;

  fo_Width: SmallInt;

  fo_Height: SmallInt;

  fo_TAttr: TTTextAttr;

end;


TScreenModeRequester

Declaration

Source position: asl.pas line 270

type TScreenModeRequester = record

  sm_DisplayID: LongWord;

  sm_DisplayWidth: LongWord;

  sm_DisplayHeight: LongWord;

  sm_DisplayDepth: Word;

  sm_OverscanType: Word;

  sm_AutoScroll: WordBool;

  sm_BitMapWidth: LongWord;

  sm_BitMapHeight: LongWord;

  sm_LeftEdge: SmallInt;

  sm_TopEdge: SmallInt;

  sm_Width: SmallInt;

  sm_Height: SmallInt;

  sm_InfoOpened: WordBool;

  sm_InfoLeftEdge: SmallInt;

  sm_InfoTopEdge: SmallInt;

  sm_InfoWidth: SmallInt;

  sm_InfoHeight: SmallInt;

  sm_UserData: Pointer;

end;


CBD_CHANGEHOOK

Declaration

Source position: clipboard.pas line 26

const CBD_CHANGEHOOK = CMD_NONSTD + 3;


CBD_CURRENTREADID

Declaration

Source position: clipboard.pas line 24

const CBD_CURRENTREADID = CMD_NONSTD + 1;


CBD_CURRENTWRITEID

Declaration

Source position: clipboard.pas line 25

const CBD_CURRENTWRITEID = CMD_NONSTD + 2;


CBD_POST

Declaration

Source position: clipboard.pas line 23

const CBD_POST = CMD_NONSTD + 0;


CBERR_OBSOLETEID

Declaration

Source position: clipboard.pas line 28

const CBERR_OBSOLETEID = 1;


Reference for unit 'clipboard'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'clipboard': Constants

CBD_CHANGEHOOK

CBD_CURRENTREADID

CBD_CURRENTWRITEID

CBD_POST

CBERR_OBSOLETEID

PRIMARY_CLIP


Reference for unit 'clipboard': Types

PClipboardUnitPartial

PClipHookMsg

PIOClipReq

PSatisfyMsg

TClipboardUnitPartial

TClipHookMsg

TIOClipReq

TSatisfyMsg


Index of all identifiers in unit 'clipboard'

C P T

C

CBD_CHANGEHOOK | CBD_CURRENTWRITEID | CBERR_OBSOLETEID
CBD_CURRENTREADID | CBD_POST |

P

PClipboardUnitPartial | PIOClipReq | PSatisfyMsg
PClipHookMsg | PRIMARY_CLIP |

T

TClipboardUnitPartial | TIOClipReq
TClipHookMsg | TSatisfyMsg


PClipboardUnitPartial

Declaration

Source position: clipboard.pas line 31

type PClipboardUnitPartial = ^TClipboardUnitPartial;


PClipHookMsg

Declaration

Source position: clipboard.pas line 65

type PClipHookMsg = ^TClipHookMsg;


PIOClipReq

Declaration

Source position: clipboard.pas line 39

type PIOClipReq = ^TIOClipReq;


PRIMARY_CLIP

Declaration

Source position: clipboard.pas line 55

const PRIMARY_CLIP = 0;


PSatisfyMsg

Declaration

Source position: clipboard.pas line 58

type PSatisfyMsg = ^TSatisfyMsg;


TClipboardUnitPartial

Declaration

Source position: clipboard.pas line 32

type TClipboardUnitPartial = record

  cu_Node: TNode;

  cu_UnitNum: LongWord;

end;


TClipHookMsg

Declaration

Source position: clipboard.pas line 66

type TClipHookMsg = record

  chm_Type: LongWord;

  chm_ChangeCmd: LongInt;

  chm_ClipID: LongInt;

end;


TIOClipReq

Declaration

Source position: clipboard.pas line 40

type TIOClipReq = record

  io_Message: TMessage;

  io_Device: PDevice;

  io_Unit: PClipboardUnitPartial;

  io_Command: Word;

  io_Flags: Byte;

  io_Error: ShortInt;

  io_Actual: LongWord;

  io_Length: LongWord;

  io_Data: PChar;

  io_Offset: LongWord;

  io_ClipID: LongInt;

end;


TSatisfyMsg

Declaration

Source position: clipboard.pas line 59

type TSatisfyMsg = record

  sm_Msg: TMessage;

  sm_Unit: Word;

  sm_ClipID: LongInt;

end;


CD_ASKDEFAULTKEYMAP

Declaration

Source position: console.pas line 36

const CD_ASKDEFAULTKEYMAP = CMD_NONSTD + 2;


CD_ASKKEYMAP

Declaration

Source position: console.pas line 34

const CD_ASKKEYMAP = CMD_NONSTD + 0;


CD_SETDEFAULTKEYMAP

Declaration

Source position: console.pas line 37

const CD_SETDEFAULTKEYMAP = CMD_NONSTD + 3;


CD_SETKEYMAP

Declaration

Source position: console.pas line 35

const CD_SETKEYMAP = CMD_NONSTD + 1;


ConsoleDevice

Declaration

Source position: console.pas line 113

var ConsoleDevice: PDevice = Nil;


CTC_HCLRTAB

Declaration

Source position: console.pas line 100

const CTC_HCLRTAB = 2;


CTC_HCLRTABSALL

Declaration

Source position: console.pas line 101

const CTC_HCLRTABSALL = 5;


CTC_HSETTAB

Declaration

Source position: console.pas line 99

const CTC_HSETTAB = 0;


DSR_CPR

Declaration

Source position: console.pas line 96

const DSR_CPR = 6;


IConsoleDevice

Declaration

Source position: console.pas line 114

var IConsoleDevice: Pointer = Nil;


Reference for unit 'console'

uses

  System,

  exec,

This unit contains the types and wrapper functions for the exec.library.

  inputevent,

  keymap;


Reference for unit 'console': Constants

CD_ASKDEFAULTKEYMAP

CD_ASKKEYMAP

CD_SETDEFAULTKEYMAP

CD_SETKEYMAP

CTC_HCLRTAB

CTC_HCLRTABSALL

CTC_HSETTAB

DSR_CPR

M_ASM

M_AWM

M_LNM

SGR_BLACK

SGR_BLACKBG

SGR_BLUE

SGR_BLUEBG

SGR_BOLD

SGR_CLR0

SGR_CLR0BG

SGR_CLR1

SGR_CLR1BG

SGR_CLR2

SGR_CLR2BG

SGR_CLR3

SGR_CLR3BG

SGR_CLR4

SGR_CLR4BG

SGR_CLR5

SGR_CLR5BG

SGR_CLR6

SGR_CLR6BG

SGR_CLR7

SGR_CLR7BG

SGR_CYAN

SGR_CYANBG

SGR_DEFAULT

SGR_DEFAULTBG

SGR_GREEN

SGR_GREENBG

SGR_ITALIC

SGR_MAGENTA

SGR_MAGENTABG

SGR_NEGATIVE

SGR_NORMAL

SGR_NOTITALIC

SGR_NOTUNDERSCORE

SGR_POSITIVE

SGR_PRIMARY

SGR_RED

SGR_REDBG

SGR_UNDERSCORE

SGR_WHITE

SGR_WHITEBG

SGR_YELLOW

SGR_YELLOWBG

TBC_HCLRTAB

TBC_HCLRTABSALL


M_ASM

Declaration

Source position: console.pas line 109

const M_ASM = '>1';


M_AWM

Declaration

Source position: console.pas line 110

const M_AWM = '?7';


M_LNM

Declaration

Source position: console.pas line 108

const M_LNM = 20;


SGR_BLACK

Declaration

Source position: console.pas line 54

const SGR_BLACK = 30;


SGR_BLACKBG

Declaration

Source position: console.pas line 64

const SGR_BLACKBG = 40;


SGR_BLUE

Declaration

Source position: console.pas line 58

const SGR_BLUE = 34;


SGR_BLUEBG

Declaration

Source position: console.pas line 68

const SGR_BLUEBG = 44;


SGR_BOLD

Declaration

Source position: console.pas line 42

const SGR_BOLD = 1;


SGR_CLR0

Declaration

Source position: console.pas line 77

const SGR_CLR0 = 30;


SGR_CLR0BG

Declaration

Source position: console.pas line 86

const SGR_CLR0BG = 40;


SGR_CLR1

Declaration

Source position: console.pas line 78

const SGR_CLR1 = 31;


SGR_CLR1BG

Declaration

Source position: console.pas line 87

const SGR_CLR1BG = 41;


SGR_CLR2

Declaration

Source position: console.pas line 79

const SGR_CLR2 = 32;


SGR_CLR2BG

Declaration

Source position: console.pas line 88

const SGR_CLR2BG = 42;


SGR_CLR3

Declaration

Source position: console.pas line 80

const SGR_CLR3 = 33;


SGR_CLR3BG

Declaration

Source position: console.pas line 89

const SGR_CLR3BG = 43;


SGR_CLR4

Declaration

Source position: console.pas line 81

const SGR_CLR4 = 34;


SGR_CLR4BG

Declaration

Source position: console.pas line 90

const SGR_CLR4BG = 44;


SGR_CLR5

Declaration

Source position: console.pas line 82

const SGR_CLR5 = 35;


SGR_CLR5BG

Declaration

Source position: console.pas line 91

const SGR_CLR5BG = 45;


SGR_CLR6

Declaration

Source position: console.pas line 83

const SGR_CLR6 = 36;


SGR_CLR6BG

Declaration

Source position: console.pas line 92

const SGR_CLR6BG = 46;


SGR_CLR7

Declaration

Source position: console.pas line 84

const SGR_CLR7 = 37;


SGR_CLR7BG

Declaration

Source position: console.pas line 93

const SGR_CLR7BG = 47;


SGR_CYAN

Declaration

Source position: console.pas line 60

const SGR_CYAN = 36;


SGR_CYANBG

Declaration

Source position: console.pas line 70

const SGR_CYANBG = 46;


SGR_DEFAULT

Declaration

Source position: console.pas line 62

const SGR_DEFAULT = 39;


SGR_DEFAULTBG

Declaration

Source position: console.pas line 72

const SGR_DEFAULTBG = 49;


SGR_GREEN

Declaration

Source position: console.pas line 56

const SGR_GREEN = 32;


SGR_GREENBG

Declaration

Source position: console.pas line 66

const SGR_GREENBG = 42;


SGR_ITALIC

Declaration

Source position: console.pas line 43

const SGR_ITALIC = 3;


SGR_MAGENTA

Declaration

Source position: console.pas line 59

const SGR_MAGENTA = 35;


SGR_MAGENTABG

Declaration

Source position: console.pas line 69

const SGR_MAGENTABG = 45;


SGR_NEGATIVE

Declaration

Source position: console.pas line 45

const SGR_NEGATIVE = 7;


SGR_NORMAL

Declaration

Source position: console.pas line 47

const SGR_NORMAL = 22;


SGR_NOTITALIC

Declaration

Source position: console.pas line 48

const SGR_NOTITALIC = 23;


SGR_NOTUNDERSCORE

Declaration

Source position: console.pas line 49

const SGR_NOTUNDERSCORE = 24;


SGR_POSITIVE

Declaration

Source position: console.pas line 50

const SGR_POSITIVE = 27;


SGR_PRIMARY

Declaration

Source position: console.pas line 41

const SGR_PRIMARY = 0;


SGR_RED

Declaration

Source position: console.pas line 55

const SGR_RED = 31;


SGR_REDBG

Declaration

Source position: console.pas line 65

const SGR_REDBG = 41;


SGR_UNDERSCORE

Declaration

Source position: console.pas line 44

const SGR_UNDERSCORE = 4;


SGR_WHITE

Declaration

Source position: console.pas line 61

const SGR_WHITE = 37;


SGR_WHITEBG

Declaration

Source position: console.pas line 71

const SGR_WHITEBG = 47;


SGR_YELLOW

Declaration

Source position: console.pas line 57

const SGR_YELLOW = 33;


SGR_YELLOWBG

Declaration

Source position: console.pas line 67

const SGR_YELLOWBG = 43;


TBC_HCLRTAB

Declaration

Source position: console.pas line 104

const TBC_HCLRTAB = 0;


TBC_HCLRTABSALL

Declaration

Source position: console.pas line 105

const TBC_HCLRTABSALL = 3;


CONFLAG_DEFAULT

Declaration

Source position: conunit.pas line 34

const CONFLAG_DEFAULT = 0;


CONFLAG_NODRAW_ON_NEWSIZE

Declaration

Source position: conunit.pas line 35

const CONFLAG_NODRAW_ON_NEWSIZE = 1;


CONU_CHARMAP

Declaration

Source position: conunit.pas line 30

const CONU_CHARMAP = 1;


CONU_LIBRARY

Declaration

Source position: conunit.pas line 26

const CONU_LIBRARY = - 1;


CONU_SNIPMAP

Declaration

Source position: conunit.pas line 31

const CONU_SNIPMAP = 3;


CONU_STANDARD

Declaration

Source position: conunit.pas line 27

const CONU_STANDARD = 0;


Reference for unit 'conunit'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
console,
keymap,
inputevent,
intuition, | Screen and Window handling routines of intuition.library
agraphics; | Native Amiga graphic functions (graphics.library)


Reference for unit 'conunit': Constants

CONFLAG_DEFAULT

CONFLAG_NODRAW_ON_NEWSIZE

CONU_CHARMAP

CONU_LIBRARY

CONU_SNIPMAP

CONU_STANDARD

MAXTABS

PMB_ASM

PMB_AWM


Reference for unit 'conunit': Types

PConUnit

TConUnit


Index of all identifiers in unit 'conunit'

C M P T

C

CONFLAG_DEFAULT | CONU_CHARMAP | CONU_SNIPMAP
CONFLAG_NODRAW_ON_NEWSIZE | CONU_LIBRARY | CONU_STANDARD

M

MAXTABS

P

PConUnit PMB_ASM PMB_AWM

T

TConUnit


MAXTABS

Declaration

Source position: conunit.pas line 39

const MAXTABS = 80;


PConUnit

Declaration

Source position: conunit.pas line 44

type PConUnit = ^TConUnit;


PMB_ASM

Declaration

Source position: conunit.pas line 37

const PMB_ASM = M_LNM + 1;


PMB_AWM

Declaration

Source position: conunit.pas line 38

const PMB_AWM = PMB_ASM + 1;


TConUnit

Declaration

Source position: conunit.pas line 45

type TConUnit = record

  cu_MP: TMsgPort;

  cu_Window: PWindow;

  cu_XCP: SmallInt;

  cu_YCP: SmallInt;

  cu_XMax: SmallInt;

  cu_YMax: SmallInt;

  cu_XRSize: SmallInt;

  cu_YRSize: SmallInt;

  cu_XROrigin: SmallInt;

  cu_YROrigin: SmallInt;

  cu_XRExtant: SmallInt;

  cu_YRExtant: SmallInt;

  cu_XMinShrink: SmallInt;

  cu_YMinShrink: SmallInt;

  cu_XCCP: SmallInt;

  cu_YCCP: SmallInt;

  cu_KeyMapStruct: TKeyMap;

  cu_TabStops: array [0..MAXTABS-1] of Word;

  cu_Mask: ShortInt;

  cu_FgPen: ShortInt;

  cu_BgPen: ShortInt;

  cu_AOLPen: ShortInt;

  cu_DrawMode: ShortInt;

  cu_Obsolete1: ShortInt;

  cu_Obsolete2: Pointer;

  cu_Minterms: array [0..7] of Byte;

  cu_Font: PTextFont;

  cu_AlgoStyle: Byte;

  cu_TxFlags: Byte;

  cu_TxHeight: Word;

  cu_TxWidth: Word;

  cu_TxBaseline: Word;

  cu_TxSpacing: Word;

  cu_Modes: array [0..(PMB_AWM+7)div8-1] of Byte;

  cu_RawEvents: array [0..(IECLASS_MAX+7)div8-1] of Byte;

end;


BMB_SPECIALFMT

Use for AllocBitmap

Declaration

Source position: cybergraphics.pas line 142

const BMB_SPECIALFMT = 7;

Description

If you specify the BMB_SPECIALFMT bit for AllocBitmap extended flag, the upper 8 bits of the flags longword contain information on the pixel format of the requested bitmap. The following pixel formats are available:

PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32

Many of this pixel formats are device specific and should not be used, recommended formats are PIXFMT_LUT8, PIXFMT_RGB16, PIXFMT_RGB24 and PIXFMT_ARGB32.


BMF_SPECIALFMT

see BMB_SPECIALFMT

Declaration

Source position: cybergraphics.pas line 143

const BMF_SPECIALFMT = 1 shl BMB_SPECIALFMT;


CTABFMT_XRGB8

CTabFormat for WriteLUTPixelArray

Declaration

Source position: cybergraphics.pas line 140

const CTABFMT_XRGB8 = 0;

Description

CTable is a pointer to a LongWord table which contains 256 entries. Each entry specifies the rgb colour value for the related index. The format is XXRRGGBB.

  • XX - unused
  • RR - 8-bit red component of the pixel
  • GG - 8-bit green component
  • BB - 8-bit blue component


CYBERGFX_INCLUDE_VERSION

Minimal version of supported cybergraphics.library

Declaration

Source position: cybergraphics.pas line 25

const CYBERGFX_INCLUDE_VERSION = 41;


CyberGfxBase

CyberGraphics library base structure

Declaration

Source position: cybergraphics.pas line 146

var CyberGfxBase: PLibrary = Nil;


CYBERGFXNAME

Name of cybergraphics main library

Declaration

Source position: cybergraphics.pas line 24

const CYBERGFXNAME = 'cybergraphics.library';


CYBRBIDTG_BoardName

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 81

const CYBRBIDTG_BoardName = CYBRBIDTG_TB + 5;

Description

Value is PChar, specifies the card name directly. For example, pass "CVision3D" to get a CyberVision64/3D board ID

See also

BestCModeIDTagList | Calculate the best ModeID with given parameters
BestCModeIDTags | VarArgs version of BestCModeIDTagList


CYBRBIDTG_Depth

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 77

const CYBRBIDTG_Depth = CYBRBIDTG_TB + 0;

Description

Value is a LongWord describing the wanted depth the returned ModeID must support. Default = 8.

See also

BestCModeIDTagList | Calculate the best ModeID with given parameters
BestCModeIDTags | VarArgs version of BestCModeIDTagList


CYBRBIDTG_MonitorID

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 80

const CYBRBIDTG_MonitorID = CYBRBIDTG_TB + 3;

Description

Value is a Longword. If multiple graphics boards are installed in the system, you can choose the desired one with this tag

See also

BestCModeIDTagList | Calculate the best ModeID with given parameters
BestCModeIDTags | VarArgs version of BestCModeIDTagList


CYBRBIDTG_NominalHeight

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 79

const CYBRBIDTG_NominalHeight = CYBRBIDTG_TB + 2;

Description

Value is a Word describing the desired height the ModeID should have.

See also

BestCModeIDTagList | Calculate the best ModeID with given parameters
BestCModeIDTags | VarArgs version of BestCModeIDTagList


CYBRBIDTG_NominalWidth

Tag for BestCModeIDTagList

Declaration

Source position: cybergraphics.pas line 78

const CYBRBIDTG_NominalWidth = CYBRBIDTG_TB + 1;

Description

Value is a Word describing the desired width the ModeID should have.

See also

BestCModeIDTagList | Calculate the best ModeID with given parameters
BestCModeIDTags | VarArgs version of BestCModeIDTagList


CYBRBIDTG_TB

Declaration

Source position: cybergraphics.pas line 75

const CYBRBIDTG_TB = TAG_USER + $50000;


CYBRIDATTR_BPPIX

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 59

const CYBRIDATTR_BPPIX = $80000005;


CYBRIDATTR_DEPTH

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 58

const CYBRIDATTR_DEPTH = $80000004;


CYBRIDATTR_HEIGHT

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 57

const CYBRIDATTR_HEIGHT = $80000003;


CYBRIDATTR_PIXFMT

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 55

const CYBRIDATTR_PIXFMT = $80000001;


CYBRIDATTR_WIDTH

Attribute for GetCyberIDAttr

Declaration

Source position: cybergraphics.pas line 56

const CYBRIDATTR_WIDTH = $80000002;


CYBRMATTR_BPPIX

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 45

const CYBRMATTR_BPPIX = $80000002;


CYBRMATTR_DEPTH

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 50

const CYBRMATTR_DEPTH = $80000007;


CYBRMATTR_DISPADR

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 46

const CYBRMATTR_DISPADR = $80000003;


CYBRMATTR_HEIGHT

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 49

const CYBRMATTR_HEIGHT = $80000006;


CYBRMATTR_ISCYBERGFX

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 51

const CYBRMATTR_ISCYBERGFX = $80000008;


CYBRMATTR_ISLINEARMEM

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 52

const CYBRMATTR_ISLINEARMEM = $80000009;


CYBRMATTR_PIXFMT

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 47

const CYBRMATTR_PIXFMT = $80000004;


CYBRMATTR_PIXFMT_ALPHA

Declaration

Source position: cybergraphics.pas line 53

const CYBRMATTR_PIXFMT_ALPHA = $8000000A;


CYBRMATTR_WIDTH

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 48

const CYBRMATTR_WIDTH = $80000005;


CYBRMATTR_XMOD

Attribute for GetCyberMapAttr

Declaration

Source position: cybergraphics.pas line 44

const CYBRMATTR_XMOD = $80000001;


CYBRMREQ_CancelText

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 72

const CYBRMREQ_CancelText = CYBRMREQ_TB + 22;

Description

Value is PChar as Label of the negative gadget in the requester. English default is 'Cancel'.

See also

CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_CModelArray

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 69

const CYBRMREQ_CModelArray = CYBRMREQ_TB + 6;

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_MaxDepth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 64

const CYBRMREQ_MaxDepth = CYBRMREQ_TB + 1;

Description

Value is a word describing the maximum display depth to let the user choose. Default is 32.

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_MaxHeight

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 68

const CYBRMREQ_MaxHeight = CYBRMREQ_TB + 5;

Description

Value is a longword describing the maximum display width to let the user choose. Default is 1200.

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_MaxWidth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 66

const CYBRMREQ_MaxWidth = CYBRMREQ_TB + 3;

Description

Value is a longword describing the maximum display width to let the user choose. Default is 1600.

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_MinDepth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 63

const CYBRMREQ_MinDepth = CYBRMREQ_TB + 0;

Description

Value is a word describing the minimum display depth to let the user choose. Default is 8.

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_MinHeight

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 67

const CYBRMREQ_MinHeight = CYBRMREQ_TB + 4;

Description

Value is a longword describing the minimum display width to let the user choose. Default is 240.

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_MinWidth

Tag for AllocCModeListTagList and CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 65

const CYBRMREQ_MinWidth = CYBRMREQ_TB + 2;

Description

Value is a longword describing the minimum display width to let the user choose. Default is 320.

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_OKText

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 71

const CYBRMREQ_OKText = CYBRMREQ_TB + 21;

Description

Value is PChar as Label of the positive gadget in the requester. English default is 'OK'.

See also

CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_Screen

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 73

const CYBRMREQ_Screen = CYBRMREQ_TB + 30;

Description

Value is PScreen setting the Screen on which to open the requester. Default locale will be used.

See also

CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


CYBRMREQ_TB

Declaration

Source position: cybergraphics.pas line 61

const CYBRMREQ_TB = TAG_USER + $40000;


CYBRMREQ_WinTitle

Tag for CModeRequestTagList

Declaration

Source position: cybergraphics.pas line 70

const CYBRMREQ_WinTitle = CYBRMREQ_TB + 20;

Description

Value is PChar as Title to use for the requesting window.

See also

CModeRequestTagList | Get screenmode from user using a requester.
CModeRequestTags | VarArgs version of CModeRequestTagList


DPMS_OFF

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 111

const DPMS_OFF = 3;

See also

CVideoCtrlTagList

Control video output


DPMS_ON

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 108

const DPMS_ON = 0;

See also

CVideoCtrlTagList

Control video output


DPMS_STANDBY

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 109

const DPMS_STANDBY = 1;

See also

CVideoCtrlTagList

Control video output


DPMS_SUSPEND

Value for Tag SETVC_DPMSLevel

Declaration

Source position: cybergraphics.pas line 110

const DPMS_SUSPEND = 2;

See also

CVideoCtrlTagList

Control video output


ICyberGfx

Declaration

Source position: cybergraphics.pas line 147

var ICyberGfx: PInterface = Nil;


Reference for unit 'cybergraphics'

RTG Amiga graphic functions of the CyberGraphics System by phase5 (cybergraphics.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility; | Tag Handling, Date routines in utility.library

Overview

RTG Amiga graphic functions of the CyberGraphics System by phase5 (cybergraphics.library) Texts mainly from the official Autodocs http://aminet.net/package/dev/misc/CGraphX-DevKit.lha

Purpose

cybergraphics.library is meant to be a gfx board extension for the native graphics.library. Because C= never developed a rtg compliant graphics.library (up to OS3.1 there are no possibilities to add custom boards into the display database in a system friendly fashion), it patches some of the original graphics functions in order to integrate custom graphics boards into the system.

It also features some new functions which are not available in the standard graphics.library. Currently graphics.library v39 and v40 is supported.

Additionally it is possible to open screens deeper than 256 colours which are completely intuition compatible. Nearly every function may be used on such screen except some special blits which rely on planar bitmap graphics. Also, this screens are 8bit backwards compatible. Nearly every standard 8bit application will work on this 15/16/24 bit screen. But it only can use the additional features, if it knows of CyberGraphX, of course.

Maybe in a future release of graphics, CyberGraphX will be obsolete. But until then, cybergraphics.library is the only way to add truecolour features to your application under an intuition environment with minimum effort.

So, CyberGraphX is not meant to be a replacement for the original graphics/intuition system (just like EGS is for example), e.g. there is no ECS/AGA native chipset CyberGraphX driver, because all the functionality of the original chipset is already given in the original graphics.library.

Overview

This part only describes how to use the extended features of CyberGraphX. Anything else about programming graphics can be found in the original graphics.library documentation. Most graphics.library functions are extended to work on CyberGraphX's 15/16/24 bit rastports.

Bitmaps and CyberGraphX

Before OS 3.x there was no standard method to create bitmaps. It was up to the application programmer to allocate memory for the bitmap structure and to get the plane pointers by subsequent calls to AllocRaster()/gfx. A InitBitMap() call was available to initialize various elements in the bitmap structure.

Unfortunately some people didn't even use AllocRaster() and InitBitMap() to setup their bitmaps but used ExecAllocMem() and initialized the bitmap structure on their own.

Because there was only one certain bitplane format description, it was no problem to directly poke into the allocated planes. It even was no problem to alter the contents of the bitmap structure because the application had total control over the location and the contents of this structure and related plane pointers.

Starting with OS 3.x two new graphics calls were added to support bitmap creation and removal: AllocBitmap()/gfx and FreeBitmap()/gfx. With this calls the first step was made to allow custom bitmap formats. Before it was no problem at all to directly render into the planes or to make assumptions about the structure of the bitmap data. To get more information about the bitmap data an information retrieval call was added: GetBitmapAttr()/gfx. With this one you could get information on the width, height, depth and certain flags of the bitmap. This was the first step into the RTG direction. As soon as GetBitmapAttr(bm, BMA_FLAGS) didn't return BMF_STANDARD, the bitmap was not direct accessable anymore and could only be accessed by attachment to a rastport and subsequent rendering calls or by using blit calls with a standard amiga bitmap as destination.

Unfortunately many programs didn't follow these guide lines and didn't check for the BMF_STANDARD flag with OS3.0 and above. Up to now many programs still use the methods described at the beginning of this chapter. That's one reason why graphics extensions like CyberGraphX still have to fiddle around with planar to chunky conversions, even if the underlying hardware doesn't support planar graphics anymore. This often leads to dramatic speed losses with certain applications which often could be redundant if standard rendering calls were used.

So please use AllocBitmap()/FreeBitmap() whereever possible when running 3.x. It really gives you a major performance improvement in most cases when used on 3rd party display adapters. Don't forget to add a friend bitmap pointer whereever possible to allocate compatible bitmap structures.

With CyberGraphX you also have to add BMF_MINPLANES in the flags field of AllocBitmap()/gfx. This is due to bug in the standard picture.datatype which doesn't check for BMF_STANDARD and directly pokes into the bitplanes even if the returned bitmap is non planar ...... Using BMF_MINPLANES in a non CyberGraphX environment remains still compatible and should not lead to any problems, with CyberGraphX a chunky bitmap is returned, if a chunky friendbitmap is supplied. How to access the bitmap data will be discussed later on. Don't make assumptions on the bitmap contents before you have called the required CyberGraphX library calls!!

Besides the AllocBitmap() friend bitmap method, AllocBitmap() has been extended to allow for allocation of certain pixel format bitmaps when using CyberGraphX. With CyberGraphX, bitmaps aren't limited to planar image maps or 8 bit chunky data (which wasn't even available with the standard chipset/ graphics.library) anymore. It is also possible now to allocate device dependant pixel format bitmaps and standard 15/16/24/32 bit depth image maps. Therefore new bits in the 32bit flags field parameter of AllocBitmap() have been added. If you specify the BMB_SPECIALFMT bit (see includes), the upper 8 bits of the flags longword contain information on the pixel format of the requested bitmap. The following pixel formats are available:

PIXFMT_LUT8, PIXFMT_RGB15, PIXFMT_BGR15, PIXFMT_RGB15PC, PIXFMT_BGR15PC, PIXFMT_RGB16, PIXFMT_BGR16, PIXFMT_RGB16PC, PIXFMT_BGR16PC, PIXFMT_RGB24, PIXFMT_BGR24, PIXFMT_ARGB32, PIXFMT_BGRA32, PIXFMT_RGBA32

Many of this pixel formats are device specific and should not be used, recommended formats are PIXFMT_LUT8, PIXFMT_RGB16, PIXFMT_RGB24 and PIXFMT_ARGB32.

Once allocated, you can attach the returned bitmap to a rastport and do rendering calls. It is not possible to attach this bitmap to a screen by supplying it as custom bitmap with OpenScreenTagList()!!

You are not allowed to directly poke into the bitmap image data as long as the bitmap isn't locked! The location and contents of the image data is subject to change and is only valid when it's locked by using the available locking calls (see autodocs). LockBitmapTags()/UnLockBitmap() has been added for this purpose. You have to supply a taglist with LockBitmapTags() which contains pointers to longwords which are filled with valid data if the call returns with a non-zero value. Only if a non-zero value is returned you are able to access the bitmap directly! Check the address you get back with the LBMI_BASEADDRESS tag. This is the base address you can do your rendering to. Get the value of the LBMI_PIXFMT ULONG field to get information on the colormodel you have to use for image rendering. All models have to be supported! The other fields give you information on the layout of the bitmap data. It should be no problem, to directly render into the bitmap anymore. Keep in mind that all this values are only valid until a subsequent call to UnLockBitmap(). Afterwards you have to lock the bitmap again. Don't hold this lock for longer than one frame! You may use the standard graphics.library bitmap blitting calls to copy the bitmap contents to another bitmap. Copying truecolour bitmaps into indexed colour chunky bitmaps is not supported by now.


Reference for unit 'cybergraphics': Constants

BMB_SPECIALFMT | Use for AllocBitmap
BMF_SPECIALFMT | see BMB_SPECIALFMT
CTABFMT_XRGB8 | CTabFormat for WriteLUTPixelArray
CYBERGFXNAME | Name of cybergraphics main library
CYBERGFX_INCLUDE_VERSION | Minimal version of supported cybergraphics.library
CYBRBIDTG_BoardName | Tag for BestCModeIDTagList
CYBRBIDTG_Depth | Tag for BestCModeIDTagList
CYBRBIDTG_MonitorID | Tag for BestCModeIDTagList
CYBRBIDTG_NominalHeight | Tag for BestCModeIDTagList
CYBRBIDTG_NominalWidth | Tag for BestCModeIDTagList
CYBRBIDTG_TB |
CYBRIDATTR_BPPIX | Attribute for GetCyberIDAttr
CYBRIDATTR_DEPTH | Attribute for GetCyberIDAttr
CYBRIDATTR_HEIGHT | Attribute for GetCyberIDAttr
CYBRIDATTR_PIXFMT | Attribute for GetCyberIDAttr
CYBRIDATTR_WIDTH | Attribute for GetCyberIDAttr
CYBRMATTR_BPPIX | Attribute for GetCyberMapAttr
CYBRMATTR_DEPTH | Attribute for GetCyberMapAttr
CYBRMATTR_DISPADR | Attribute for GetCyberMapAttr
CYBRMATTR_HEIGHT | Attribute for GetCyberMapAttr
CYBRMATTR_ISCYBERGFX | Attribute for GetCyberMapAttr
CYBRMATTR_ISLINEARMEM | Attribute for GetCyberMapAttr
CYBRMATTR_PIXFMT | Attribute for GetCyberMapAttr
CYBRMATTR_PIXFMT_ALPHA
CYBRMATTR_WIDTH | Attribute for GetCyberMapAttr
CYBRMATTR_XMOD | Attribute for GetCyberMapAttr
CYBRMREQ_CancelText | Tag for CModeRequestTagList
CYBRMREQ_CModelArray | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MaxDepth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MaxHeight | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MaxWidth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MinDepth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MinHeight | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_MinWidth | Tag for AllocCModeListTagList and CModeRequestTagList
CYBRMREQ_OKText | Tag for CModeRequestTagList
CYBRMREQ_Screen | Tag for CModeRequestTagList
CYBRMREQ_TB |
CYBRMREQ_WinTitle | Tag for CModeRequestTagList
DPMS_OFF | Value for Tag SETVC_DPMSLevel
DPMS_ON | Value for Tag SETVC_DPMSLevel
DPMS_STANDBY | Value for Tag SETVC_DPMSLevel
DPMS_SUSPEND | Value for Tag SETVC_DPMSLevel
LBMI_BASEADDRESS | Tag for LockBitMapTagList
LBMI_BYTESPERPIX | Tag for LockBitMapTagList
LBMI_BYTESPERROW | Tag for LockBitMapTagList
LBMI_DEPTH | Tag for LockBitMapTagList
LBMI_HEIGHT | Tag for LockBitMapTagList
LBMI_PIXFMT | Tag for LockBitMapTagList
LBMI_WIDTH | Tag for LockBitMapTagList
PIXFMT_ARGB32 |
PIXFMT_BGR15 |
PIXFMT_BGR15PC |
PIXFMT_BGR16 |
PIXFMT_BGR16PC |
PIXFMT_BGR24 |
PIXFMT_BGRA32 |
PIXFMT_LUT8 |
PIXFMT_RGB15 |
PIXFMT_RGB15PC |
PIXFMT_RGB16 |
PIXFMT_RGB16PC |
PIXFMT_RGB24 |
PIXFMT_RGBA32 |
RECTFMT_ARGB | PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray
RECTFMT_GREY8 | PixelFormat for ScalePixelArray, WritePixelArray
RECTFMT_LUT8 | PixelFormat for ScalePixelArray, WritePixelArray
RECTFMT_RAW
RECTFMT_RGB | PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray
RECTFMT_RGBA | PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray
SETVC_DPMSLevel | Tag for CVideoCtrlTagList
UBMI_REALLYUNLOCK | Tag for UnLockBitMapTagList
UBMI_UPDATERECTS | Tag for UnLockBitMapTagList


Reference for unit 'cybergraphics': Types

PCDrawMsg | Message passed to the DoCDrawMethodTagList() hook function
PCyberModeNode | List of available screen modes returned by AllocCModeListTagList
TCDrawMsg |
TCyberModeNode | List of available screen modes pointer to it returned by AllocCModeListTagList


LBMI_BASEADDRESS

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 119

const LBMI_BASEADDRESS = $84001007;

Description

Value is a PLongWord to get the bitmap base address.


LBMI_BYTESPERPIX

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 117

const LBMI_BYTESPERPIX = $84001005;

Description

Value is a PLongWord to get bitmaps amount of bytes per pixel data.


LBMI_BYTESPERROW

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 118

const LBMI_BYTESPERROW = $84001006;

Description

Value is a PLongWord to get the number of bytes per row for one bitmap line.


LBMI_DEPTH

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 115

const LBMI_DEPTH = $84001003;

Description

Value is a PLongWord to get bitmaps color depth.


LBMI_HEIGHT

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 114

const LBMI_HEIGHT = $84001002;

Description

Value is a PLongWord to get bitmaps height.


LBMI_PIXFMT

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 116

const LBMI_PIXFMT = $84001004;

Description

Value is a PLongWord to get bitmaps pixel format.


LBMI_WIDTH

Tag for LockBitMapTagList

Declaration

Source position: cybergraphics.pas line 113

const LBMI_WIDTH = $84001001;

Description

Value is a PLongWord to get bitmaps width.


PCDrawMsg

Message passed to the DoCDrawMethodTagList() hook function

Declaration

Source position: cybergraphics.pas line 126

type PCDrawMsg = ^TCDrawMsg;


PCyberModeNode

List of available screen modes returned by AllocCModeListTagList

Declaration

Source position: cybergraphics.pas line 30

type PCyberModeNode = ^TCyberModeNode;

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList


PIXFMT_ARGB32

Declaration

Source position: cybergraphics.pas line 94

const PIXFMT_ARGB32 = 11;


PIXFMT_BGR15

Declaration

Source position: cybergraphics.pas line 85

const PIXFMT_BGR15 = 2;


PIXFMT_BGR15PC

Declaration

Source position: cybergraphics.pas line 87

const PIXFMT_BGR15PC = 4;


PIXFMT_BGR16

Declaration

Source position: cybergraphics.pas line 89

const PIXFMT_BGR16 = 6;


PIXFMT_BGR16PC

Declaration

Source position: cybergraphics.pas line 91

const PIXFMT_BGR16PC = 8;


PIXFMT_BGR24

Declaration

Source position: cybergraphics.pas line 93

const PIXFMT_BGR24 = 10;


PIXFMT_BGRA32

Declaration

Source position: cybergraphics.pas line 95

const PIXFMT_BGRA32 = 12;


PIXFMT_LUT8

Declaration

Source position: cybergraphics.pas line 83

const PIXFMT_LUT8 = 0;


PIXFMT_RGB15

Declaration

Source position: cybergraphics.pas line 84

const PIXFMT_RGB15 = 1;


PIXFMT_RGB15PC

Declaration

Source position: cybergraphics.pas line 86

const PIXFMT_RGB15PC = 3;


PIXFMT_RGB16

Declaration

Source position: cybergraphics.pas line 88

const PIXFMT_RGB16 = 5;


PIXFMT_RGB16PC

Declaration

Source position: cybergraphics.pas line 90

const PIXFMT_RGB16PC = 7;


PIXFMT_RGB24

Declaration

Source position: cybergraphics.pas line 92

const PIXFMT_RGB24 = 9;


PIXFMT_RGBA32

Declaration

Source position: cybergraphics.pas line 96

const PIXFMT_RGBA32 = 13;


RECTFMT_ARGB

PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 100

const RECTFMT_ARGB = 2;

Description

4 bytes per pixel, one byte red, one blue, one byte green component and the first byte is alpha channel information. If the board does not support alpha channel a 0 is returned for alpha channel information


RECTFMT_GREY8

PixelFormat for ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 102

const RECTFMT_GREY8 = 4;

Description

1 byte per pixel, specifying grey scale value.


RECTFMT_LUT8

PixelFormat for ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 101

const RECTFMT_LUT8 = 3;

Description

1 byte per pixel, specifying the pen number. On screen depths > 8 bits the data is converted using the actual color lookup table.


RECTFMT_RAW

Declaration

Source position: cybergraphics.pas line 103

const RECTFMT_RAW = 5;


RECTFMT_RGB

PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 98

const RECTFMT_RGB = 0;

Description

3 bytes per pixel, one byte red, one blue and one byte green component


RECTFMT_RGBA

PixelFormat for ReadPixelArray, ScalePixelArray, WritePixelArray

Declaration

Source position: cybergraphics.pas line 99

const RECTFMT_RGBA = 1;

Description

4 bytes per pixel, one byte red, one blue, one byte green component and the last byte is alpha channel information which is 0 if the board does not support alpha channel


SETVC_DPMSLevel

Tag for CVideoCtrlTagList

Declaration

Source position: cybergraphics.pas line 107

const SETVC_DPMSLevel = $88002001;


TCDrawMsg

Declaration

Source position: cybergraphics.pas line 127

type TCDrawMsg = record

  cdm_MemPtr: Pointer;

  cdm_offx: LongWord;

  cdm_offy: LongWord;

  cdm_xsize: LongWord;

  cdm_ysize: LongWord;

  cdm_BytesPerRow: Word;

  cdm_BytesPerPix: Word;

  cdm_ColorModel: Word;

end;


TCyberModeNode

List of available screen modes pointer to it returned by AllocCModeListTagList

Declaration

Source position: cybergraphics.pas line 31

type TCyberModeNode = record
Node: TNode; | Standard exec list structure.
ModeText: array [0..DISPLAYNAMELEN-1] of Char; | Name for this mode
DisplayID: LongWord; | Display id associated with the node
Width: Word; | Visible width
Height: Word; | Visible height
Depth: Word; | Display depth
DisplayTagList: PTagItem; | Taglist with extended ModeID information
end;

See also

AllocCModeListTagList | Get an exec list with requested modes
AllocCModeListTags | VarArgs version of AllocCModeListTagList
PCyberModeNode | List of available screen modes returned by AllocCModeListTagList


UBMI_REALLYUNLOCK

Tag for UnLockBitMapTagList

Declaration

Source position: cybergraphics.pas line 122

const UBMI_REALLYUNLOCK = $85001002;


UBMI_UPDATERECTS

Tag for UnLockBitMapTagList

Declaration

Source position: cybergraphics.pas line 121

const UBMI_UPDATERECTS = $85001001;


ADTA_Allocated

Declaration

Source position: datatypes.pas line 688

const ADTA_Allocated = PDTA_Allocated;


ADTA_ColorRegisters

Declaration

Source position: datatypes.pas line 683

const ADTA_ColorRegisters = PDTA_ColorRegisters;


ADTA_ColorTable

Declaration

Source position: datatypes.pas line 686

const ADTA_ColorTable = PDTA_ColorTable;


ADTA_ColorTable2

Declaration

Source position: datatypes.pas line 687

const ADTA_ColorTable2 = PDTA_ColorTable2;


ADTA_CRegs

Declaration

Source position: datatypes.pas line 684

const ADTA_CRegs = PDTA_CRegs;


ADTA_Cycles

Declaration

Source position: datatypes.pas line 711

const ADTA_Cycles = SDTA_Cycles;


ADTA_Depth

Declaration

Source position: datatypes.pas line 698

const ADTA_Depth = ADTA_Dummy + 3;


ADTA_Dummy

Declaration

Source position: datatypes.pas line 680

const ADTA_Dummy = DTA_Dummy + 600;


ADTA_Frame

Declaration

Source position: datatypes.pas line 700

const ADTA_Frame = ADTA_Dummy + 5;


ADTA_FrameIncrement

Declaration

Source position: datatypes.pas line 702

const ADTA_FrameIncrement = ADTA_Dummy + 7;


ADTA_Frames

Declaration

Source position: datatypes.pas line 699

const ADTA_Frames = ADTA_Dummy + 4;


ADTA_FramesPerSecond

Declaration

Source position: datatypes.pas line 701

const ADTA_FramesPerSecond = ADTA_Dummy + 6;


ADTA_GRegs

Declaration

Source position: datatypes.pas line 685

const ADTA_GRegs = PDTA_GRegs;


ADTA_Height

Declaration

Source position: datatypes.pas line 697

const ADTA_Height = ADTA_Dummy + 2;


ADTA_KeyFrame

Declaration

Source position: datatypes.pas line 682

const ADTA_KeyFrame = PDTA_BitMap;


ADTA_LeftSample

Declaration

Source position: datatypes.pas line 713

const ADTA_LeftSample = SDTA_LeftSample;


ADTA_ModeID

Declaration

Source position: datatypes.pas line 681

const ADTA_ModeID = PDTA_ModeID;


ADTA_NumAlloc

Declaration

Source position: datatypes.pas line 690

const ADTA_NumAlloc = PDTA_NumAlloc;


ADTA_NumColors

Declaration

Source position: datatypes.pas line 689

const ADTA_NumColors = PDTA_NumColors;


ADTA_NumSparse

Declaration

Source position: datatypes.pas line 693

const ADTA_NumSparse = PDTA_NumSparse;


ADTA_Period

Declaration

Source position: datatypes.pas line 709

const ADTA_Period = SDTA_Period;


ADTA_PreloadFrameCount

Declaration

Source position: datatypes.pas line 704

const ADTA_PreloadFrameCount = ADTA_Dummy + 8;


ADTA_Remap

Declaration

Source position: datatypes.pas line 691

const ADTA_Remap = PDTA_Remap;


ADTA_RightSample

Declaration

Source position: datatypes.pas line 714

const ADTA_RightSample = SDTA_RightSample;


ADTA_Sample

Declaration

Source position: datatypes.pas line 707

const ADTA_Sample = SDTA_Sample;


ADTA_SampleLength

Declaration

Source position: datatypes.pas line 708

const ADTA_SampleLength = SDTA_SampleLength;


ADTA_SamplesPerSec

Declaration

Source position: datatypes.pas line 715

const ADTA_SamplesPerSec = SDTA_SamplesPerSec;


ADTA_Screen

Declaration

Source position: datatypes.pas line 692

const ADTA_Screen = PDTA_Screen;


ADTA_SparseTable

Declaration

Source position: datatypes.pas line 694

const ADTA_SparseTable = PDTA_SparseTable;


ADTA_Volume

Declaration

Source position: datatypes.pas line 710

const ADTA_Volume = SDTA_Volume;


ADTA_Width

Declaration

Source position: datatypes.pas line 696

const ADTA_Width = ADTA_Dummy + 1;


ADTM_Dummy

Declaration

Source position: datatypes.pas line 768

const ADTM_Dummy = $700;


ADTM_LOADFRAME

Declaration

Source position: datatypes.pas line 769

const ADTM_LOADFRAME = $701;


ADTM_LOADNEWFORMATFRAME

Declaration

Source position: datatypes.pas line 776

const ADTM_LOADNEWFORMATFRAME = $707;


ADTM_LOCATE

Declaration

Source position: datatypes.pas line 774

const ADTM_LOCATE = $706;


ADTM_PAUSE

Declaration

Source position: datatypes.pas line 772

const ADTM_PAUSE = $704;


ADTM_START

Declaration

Source position: datatypes.pas line 771

const ADTM_START = $703;


ADTM_STOP

Declaration

Source position: datatypes.pas line 773

const ADTM_STOP = $705;


ADTM_UNLOADFRAME

Declaration

Source position: datatypes.pas line 770

const ADTM_UNLOADFRAME = $702;


ADTM_UNLOADNEWFORMATFRAME

Declaration

Source position: datatypes.pas line 777

const ADTM_UNLOADNEWFORMATFRAME = $708;


ANIMATIONDTCLASS

Declaration

Source position: datatypes.pas line 677

const ANIMATIONDTCLASS = 'animation.datatype';


CMP_FIBDELTA

Declaration

Source position: datatypes.pas line 604

const CMP_FIBDELTA = 1;


CMP_NONE

Declaration

Source position: datatypes.pas line 603

const CMP_NONE = 0;


cmpByteRun1

Declaration

Source position: datatypes.pas line 533

const cmpByteRun1 = 1;


cmpByteRun2

Declaration

Source position: datatypes.pas line 534

const cmpByteRun2 = 2;


cmpNone

Declaration

Source position: datatypes.pas line 532

const cmpNone = 0;


DataTypesBase

Declaration

Source position: datatypes.pas line 824

var DataTypesBase: PLibrary = Nil;


DATATYPESCLASS

Declaration

Source position: datatypes.pas line 187

const DATATYPESCLASS = 'datatypesclass';


DATATYPESNAME

Declaration

Source position: datatypes.pas line 828

const DATATYPESNAME: PChar = 'datatypes.library';


DTA_ARexxPortName

Declaration

Source position: datatypes.pas line 255

const DTA_ARexxPortName = DTA_Dummy + 404;


DTA_BaseName

Declaration

Source position: datatypes.pas line 212

const DTA_BaseName = DTA_Dummy + 30;


DTA_Busy

Declaration

Source position: datatypes.pas line 209

const DTA_Busy = DTA_Dummy + 28;


DTA_Conductor

Declaration

Source position: datatypes.pas line 217

const DTA_Conductor = DTA_Dummy + 35;


DTA_ControlPanel

Declaration

Source position: datatypes.pas line 218

const DTA_ControlPanel = DTA_Dummy + 36;


DTA_Data

Declaration

Source position: datatypes.pas line 203

const DTA_Data = DTA_Dummy + 22;


DTA_DataType

Declaration

Source position: datatypes.pas line 232

const DTA_DataType = DTA_Dummy + 103;


DTA_DestCols

Declaration

Source position: datatypes.pas line 251

const DTA_DestCols = DTA_Dummy + 400;


DTA_DestRows

Declaration

Source position: datatypes.pas line 252

const DTA_DestRows = DTA_Dummy + 401;


DTA_Domain

Declaration

Source position: datatypes.pas line 233

const DTA_Domain = DTA_Dummy + 104;


DTA_Dummy

Declaration

Source position: datatypes.pas line 189

const DTA_Dummy = TAG_USER + $1000;


DTA_ErrorLevel

Declaration

Source position: datatypes.pas line 214

const DTA_ErrorLevel = DTA_Dummy + 32;


DTA_ErrorNumber

Declaration

Source position: datatypes.pas line 215

const DTA_ErrorNumber = DTA_Dummy + 33;


DTA_ErrorString

Declaration

Source position: datatypes.pas line 216

const DTA_ErrorString = DTA_Dummy + 34;


DTA_FrameInfo

Declaration

Source position: datatypes.pas line 243

const DTA_FrameInfo = DTA_Dummy + 116;


DTA_GroupID

Declaration

Source position: datatypes.pas line 213

const DTA_GroupID = DTA_Dummy + 31;


DTA_Handle

Declaration

Source position: datatypes.pas line 231

const DTA_Handle = DTA_Dummy + 102;


DTA_HorizUnit

Declaration

Source position: datatypes.pas line 199

const DTA_HorizUnit = DTA_Dummy + 18;


DTA_Immediate

Declaration

Source position: datatypes.pas line 220

const DTA_Immediate = DTA_Dummy + 37;


DTA_LayoutProc

Declaration

Source position: datatypes.pas line 208

const DTA_LayoutProc = DTA_Dummy + 27;


DTA_Methods

Declaration

Source position: datatypes.pas line 205

const DTA_Methods = DTA_Dummy + 24;


DTA_Name

Declaration

Source position: datatypes.pas line 229

const DTA_Name = DTA_Dummy + 100;


DTA_NodeName

Declaration

Source position: datatypes.pas line 200

const DTA_NodeName = DTA_Dummy + 19;


DTA_NominalHoriz

Declaration

Source position: datatypes.pas line 248

const DTA_NominalHoriz = DTA_Dummy + 125;


DTA_NominalVert

Declaration

Source position: datatypes.pas line 247

const DTA_NominalVert = DTA_Dummy + 124;


DTA_ObjAnnotation

Declaration

Source position: datatypes.pas line 237

const DTA_ObjAnnotation = DTA_Dummy + 111;


DTA_ObjAuthor

Declaration

Source position: datatypes.pas line 236

const DTA_ObjAuthor = DTA_Dummy + 110;


DTA_ObjCopyright

Declaration

Source position: datatypes.pas line 238

const DTA_ObjCopyright = DTA_Dummy + 112;


DTA_ObjectID

Declaration

Source position: datatypes.pas line 240

const DTA_ObjectID = DTA_Dummy + 114;


DTA_ObjName

Declaration

Source position: datatypes.pas line 235

const DTA_ObjName = DTA_Dummy + 109;


DTA_ObjVersion

Declaration

Source position: datatypes.pas line 239

const DTA_ObjVersion = DTA_Dummy + 113;


DTA_PrinterProc

Declaration

Source position: datatypes.pas line 207

const DTA_PrinterProc = DTA_Dummy + 26;


DTA_PrinterStatus

Declaration

Source position: datatypes.pas line 206

const DTA_PrinterStatus = DTA_Dummy + 25;


DTA_RastPort

Declaration

Source position: datatypes.pas line 254

const DTA_RastPort = DTA_Dummy + 403;


DTA_Repeat

Declaration

Source position: datatypes.pas line 221

const DTA_Repeat = DTA_Dummy + 38;


DTA_Reserved

Declaration

Source position: datatypes.pas line 226

const DTA_Reserved = DTA_Dummy + 41;


DTA_SelectDomain

Declaration

Source position: datatypes.pas line 244

const DTA_SelectDomain = DTA_Dummy + 121;


DTA_SourceAddress

Declaration

Source position: datatypes.pas line 223

const DTA_SourceAddress = DTA_Dummy + 39;


DTA_SourceSize

Declaration

Source position: datatypes.pas line 224

const DTA_SourceSize = DTA_Dummy + 40;


DTA_SourceType

Declaration

Source position: datatypes.pas line 230

const DTA_SourceType = DTA_Dummy + 101;


DTA_Special

Declaration

Source position: datatypes.pas line 253

const DTA_Special = DTA_Dummy + 402;


DTA_Sync

Declaration

Source position: datatypes.pas line 210

const DTA_Sync = DTA_Dummy + 29;


DTA_TextAttr

Declaration

Source position: datatypes.pas line 191

const DTA_TextAttr = DTA_Dummy + 10;


DTA_TextFont

Declaration

Source position: datatypes.pas line 204

const DTA_TextFont = DTA_Dummy + 23;


DTA_Title

Declaration

Source position: datatypes.pas line 201

const DTA_Title = DTA_Dummy + 20;


DTA_TopHoriz

Declaration

Source position: datatypes.pas line 196

const DTA_TopHoriz = DTA_Dummy + 15;


DTA_TopVert

Declaration

Source position: datatypes.pas line 192

const DTA_TopVert = DTA_Dummy + 11;


DTA_TotalHoriz

Declaration

Source position: datatypes.pas line 198

const DTA_TotalHoriz = DTA_Dummy + 17;


DTA_TotalPHoriz

Declaration

Source position: datatypes.pas line 246

const DTA_TotalPHoriz = DTA_Dummy + 123;


DTA_TotalPVert

Declaration

Source position: datatypes.pas line 245

const DTA_TotalPVert = DTA_Dummy + 122;


DTA_TotalVert

Declaration

Source position: datatypes.pas line 194

const DTA_TotalVert = DTA_Dummy + 13;


DTA_TriggerMethods

Declaration

Source position: datatypes.pas line 202

const DTA_TriggerMethods = DTA_Dummy + 21;


DTA_UserData

Declaration

Source position: datatypes.pas line 241

const DTA_UserData = DTA_Dummy + 115;


DTA_VertUnit

Declaration

Source position: datatypes.pas line 195

const DTA_VertUnit = DTA_Dummy + 14;


DTA_VisibleHoriz

Declaration

Source position: datatypes.pas line 197

const DTA_VisibleHoriz = DTA_Dummy + 16;


DTA_VisibleVert

Declaration

Source position: datatypes.pas line 193

const DTA_VisibleVert = DTA_Dummy + 12;


DTERROR_COULDNT_OPEN

Declaration

Source position: datatypes.pas line 172

const DTERROR_COULDNT_OPEN = 2002;


DTERROR_COULDNT_OPEN_CLIPBOARD

Declaration

Source position: datatypes.pas line 175

const DTERROR_COULDNT_OPEN_CLIPBOARD = 2004;


DTERROR_COULDNT_SAVE

Declaration

Source position: datatypes.pas line 171

const DTERROR_COULDNT_SAVE = 2001;


DTERROR_COULDNT_SEND_MESSAGE

Declaration

Source position: datatypes.pas line 173

const DTERROR_COULDNT_SEND_MESSAGE = 2003;


DTERROR_INVALID_DATA

Declaration

Source position: datatypes.pas line 179

const DTERROR_INVALID_DATA = 2008;


DTERROR_NOT_AVAILABLE

Declaration

Source position: datatypes.pas line 181

const DTERROR_NOT_AVAILABLE = 2009;


DTERROR_NOT_ENOUGH_DATA

Declaration

Source position: datatypes.pas line 178

const DTERROR_NOT_ENOUGH_DATA = 2007;


DTERROR_Reserved

Declaration

Source position: datatypes.pas line 176

const DTERROR_Reserved = 2005;


DTERROR_UNKNOWN_COMPRESSION

Declaration

Source position: datatypes.pas line 177

const DTERROR_UNKNOWN_COMPRESSION = 2006;


DTERROR_UNKNOWN_DATATYPE

Declaration

Source position: datatypes.pas line 170

const DTERROR_UNKNOWN_DATATYPE = 2000;


DTF_ASCII

Declaration

Source position: datatypes.pas line 50

const DTF_ASCII = $0001;


DTF_BINARY

Declaration

Source position: datatypes.pas line 49

const DTF_BINARY = $0000;


DTF_CASE

Declaration

Source position: datatypes.pas line 53

const DTF_CASE = $0010;


DTF_IFF

Declaration

Source position: datatypes.pas line 51

const DTF_IFF = $0002;


DTF_MISC

Declaration

Source position: datatypes.pas line 52

const DTF_MISC = $0003;


DTF_SYSTEM1

Declaration

Source position: datatypes.pas line 54

const DTF_SYSTEM1 = $1000;


DTF_TYPE_MASK

Declaration

Source position: datatypes.pas line 48

const DTF_TYPE_MASK = $000F;


DTHSIZE

Declaration

Source position: datatypes.pas line 45

const DTHSIZE = SizeOf(TDataTypeHeader);


DTM_ABORTPRINT

Declaration

Source position: datatypes.pas line 313

const DTM_ABORTPRINT = $609;


DTM_ASYNCLAYOUT

Declaration

Source position: datatypes.pas line 305

const DTM_ASYNCLAYOUT = $603;


DTM_CLEARSELECTED

Declaration

Source position: datatypes.pas line 309

const DTM_CLEARSELECTED = $606;


DTM_COPY

Declaration

Source position: datatypes.pas line 311

const DTM_COPY = $607;


DTM_DISPOSEMEMBER

Declaration

Source position: datatypes.pas line 316

const DTM_DISPOSEMEMBER = $611;


DTM_DRAW

Declaration

Source position: datatypes.pas line 322

const DTM_DRAW = $641;


DTM_Dummy

Declaration

Source position: datatypes.pas line 301

const DTM_Dummy = $600;


DTM_FRAMEBOX

Declaration

Source position: datatypes.pas line 303

const DTM_FRAMEBOX = $601;


DTM_GOTO

Declaration

Source position: datatypes.pas line 318

const DTM_GOTO = $630;


DTM_NEWMEMBER

Declaration

Source position: datatypes.pas line 315

const DTM_NEWMEMBER = $610;


DTM_OBTAINDRAWINFO

Declaration

Source position: datatypes.pas line 321

const DTM_OBTAINDRAWINFO = $640;


DTM_PRINT

Declaration

Source position: datatypes.pas line 312

const DTM_PRINT = $608;


DTM_PROCLAYOUT

Declaration

Source position: datatypes.pas line 304

const DTM_PROCLAYOUT = $602;


DTM_RELEASEDRAWINFO

Declaration

Source position: datatypes.pas line 323

const DTM_RELEASEDRAWINFO = $642;


DTM_REMOVEDTOBJECT

Declaration

Source position: datatypes.pas line 306

const DTM_REMOVEDTOBJECT = $604;


DTM_SELECT

Declaration

Source position: datatypes.pas line 308

const DTM_SELECT = $605;


DTM_TRIGGER

Declaration

Source position: datatypes.pas line 319

const DTM_TRIGGER = $631;


DTM_WRITE

Declaration

Source position: datatypes.pas line 325

const DTM_WRITE = $650;


DTMSG_TYPE_OFFSET

Declaration

Source position: datatypes.pas line 183

const DTMSG_TYPE_OFFSET = 2100;


DTNSIZE

Declaration

Source position: datatypes.pas line 155

const DTNSIZE = SizeOf(TDataType);


DTSIF_DRAGGING

Declaration

Source position: datatypes.pas line 286

const DTSIF_DRAGGING = 1 shl 2;


DTSIF_DRAGSELECT

Declaration

Source position: datatypes.pas line 287

const DTSIF_DRAGSELECT = 1 shl 3;


DTSIF_HIGHLIGHT

Declaration

Source position: datatypes.pas line 288

const DTSIF_HIGHLIGHT = 1 shl 4;


DTSIF_LAYOUT

Declaration

Source position: datatypes.pas line 284

const DTSIF_LAYOUT = 1 shl 0;


DTSIF_LAYOUTPROC

Declaration

Source position: datatypes.pas line 290

const DTSIF_LAYOUTPROC = 1 shl 6;


DTSIF_NEWSIZE

Declaration

Source position: datatypes.pas line 285

const DTSIF_NEWSIZE = 1 shl 1;


DTSIF_PRINTING

Declaration

Source position: datatypes.pas line 289

const DTSIF_PRINTING = 1 shl 5;


DTST_CLIPBOARD

Declaration

Source position: datatypes.pas line 259

const DTST_CLIPBOARD = 3;


DTST_FILE

Declaration

Source position: datatypes.pas line 258

const DTST_FILE = 2;


DTST_HOTLINK

Declaration

Source position: datatypes.pas line 260

const DTST_HOTLINK = 4;


DTST_MEMORY

Declaration

Source position: datatypes.pas line 261

const DTST_MEMORY = 5;


DTST_RAM

Declaration

Source position: datatypes.pas line 257

const DTST_RAM = 1;


DTWM_IFF

Declaration

Source position: datatypes.pas line 465

const DTWM_IFF = 0;


DTWM_RAW

Declaration

Source position: datatypes.pas line 466

const DTWM_RAW = 1;


FIF_REMAPPABLE

Declaration

Source position: datatypes.pas line 353

const FIF_REMAPPABLE = $4;


FIF_SCALABLE

Declaration

Source position: datatypes.pas line 351

const FIF_SCALABLE = $1;


FIF_SCROLLABLE

Declaration

Source position: datatypes.pas line 352

const FIF_SCROLLABLE = $2;


GID_ANIMATION

Declaration

Source position: datatypes.pas line 89

const GID_ANIMATION = Ord('a') shl 24 + Ord('n') shl 16 + Ord('i') shl 8 + Ord('m');


GID_DOCUMENT

Declaration

Source position: datatypes.pas line 79

const GID_DOCUMENT = Ord('d') shl 24 + Ord('o') shl 16 + Ord('c') shl 8 + Ord('u');


GID_INSTRUMENT

Declaration

Source position: datatypes.pas line 83

const GID_INSTRUMENT = Ord('i') shl 24 + Ord('n') shl 16 + Ord('s') shl 8 + Ord('t');


GID_MOVIE

Declaration

Source position: datatypes.pas line 91

const GID_MOVIE = Ord('m') shl 24 + Ord('o') shl 16 + Ord('v') shl 8 + Ord('i');


GID_MUSIC

Declaration

Source position: datatypes.pas line 85

const GID_MUSIC = Ord('m') shl 24 + Ord('u') shl 16 + Ord('s') shl 8 + Ord('i');


GID_PICTURE

Declaration

Source position: datatypes.pas line 87

const GID_PICTURE = Ord('p') shl 24 + Ord('i') shl 16 + Ord('c') shl 8 + Ord('t');


GID_SOUND

Declaration

Source position: datatypes.pas line 81

const GID_SOUND = Ord('s') shl 24 + Ord('o') shl 16 + Ord('u') shl 8 + Ord('n');


GID_SYSTEM

Declaration

Source position: datatypes.pas line 75

const GID_SYSTEM = Ord('s') shl 24 + Ord('y') shl 16 + Ord('s') shl 8 + Ord('t');


GID_TEXT

Declaration

Source position: datatypes.pas line 77

const GID_TEXT = Ord('t') shl 24 + Ord('e') shl 16 + Ord('x') shl 8 + Ord('t');


ID_8SVX

Declaration

Source position: datatypes.pas line 632

const ID_8SVX = Ord('8') shl 24 + Ord('S') shl 16 + Ord('V') shl 8 + Ord('X');


ID_ANHD

Declaration

Source position: datatypes.pas line 719

const ID_ANHD = Ord('A') shl 24 + Ord('N') shl 16 + Ord('H') shl 8 + Ord('D');


ID_ANIM

Declaration

Source position: datatypes.pas line 718

const ID_ANIM = Ord('A') shl 24 + Ord('N') shl 16 + Ord('I') shl 8 + Ord('M');


ID_BMHD

Declaration

Source position: datatypes.pas line 565

const ID_BMHD = Ord('B') shl 24 + Ord('M') shl 16 + Ord('H') shl 8 + Ord('D');


ID_BODY

Declaration

Source position: datatypes.pas line 573

const ID_BODY = Ord('B') shl 24 + Ord('O') shl 16 + Ord('D') shl 8 + Ord('Y');


ID_CAMG

Declaration

Source position: datatypes.pas line 571

const ID_CAMG = Ord('C') shl 24 + Ord('A') shl 16 + Ord('M') shl 8 + Ord('G');


ID_CHAN

Declaration

Source position: datatypes.pas line 634

const ID_CHAN = Ord('C') shl 24 + Ord('H') shl 16 + Ord('A') shl 8 + Ord('N');


ID_CHRS

Declaration

Source position: datatypes.pas line 673

const ID_CHRS = Ord('C') shl 24 + Ord('H') shl 16 + Ord('R') shl 8 + Ord('S');


ID_CMAP

Declaration

Source position: datatypes.pas line 566

const ID_CMAP = Ord('C') shl 24 + Ord('M') shl 16 + Ord('A') shl 8 + Ord('P');


ID_CODE

Declaration

Source position: datatypes.pas line 94

const ID_CODE = Ord('D') shl 24 + Ord('T') shl 16 + Ord('C') shl 8 + Ord('D');


ID_CRNG

Declaration

Source position: datatypes.pas line 567

const ID_CRNG = Ord('C') shl 24 + Ord('R') shl 16 + Ord('N') shl 8 + Ord('G');


ID_DEST

Declaration

Source position: datatypes.pas line 570

const ID_DEST = Ord('D') shl 24 + Ord('E') shl 16 + Ord('S') shl 8 + Ord('T');


ID_DLTA

Declaration

Source position: datatypes.pas line 720

const ID_DLTA = Ord('D') shl 24 + Ord('L') shl 16 + Ord('T') shl 8 + Ord('A');


ID_DTHD

Declaration

Source position: datatypes.pas line 28

const ID_DTHD = Ord('D') shl 24 + Ord('T') shl 16 + Ord('H') shl 8 + Ord('D');


ID_DTYP

Declaration

Source position: datatypes.pas line 27

const ID_DTYP = Ord('D') shl 24 + Ord('T') shl 16 + Ord('Y') shl 8 + Ord('P');


ID_FTXT

Declaration

Source position: datatypes.pas line 672

const ID_FTXT = Ord('F') shl 24 + Ord('T') shl 16 + Ord('X') shl 8 + Ord('T');


ID_GRAB

Declaration

Source position: datatypes.pas line 568

const ID_GRAB = Ord('G') shl 24 + Ord('R') shl 16 + Ord('A') shl 8 + Ord('B');


ID_ILBM

Declaration

Source position: datatypes.pas line 564

const ID_ILBM = Ord('I') shl 24 + Ord('L') shl 16 + Ord('B') shl 8 + Ord('M');


ID_NAME

Declaration

Source position: datatypes.pas line 167

const ID_NAME = Ord('N') shl 24 + Ord('A') shl 16 + Ord('M') shl 8 + Ord('E');


ID_SPRT

Declaration

Source position: datatypes.pas line 569

const ID_SPRT = Ord('S') shl 24 + Ord('P') shl 16 + Ord('R') shl 8 + Ord('T');


ID_TAGS

Declaration

Source position: datatypes.pas line 140

const ID_TAGS = Ord('D') shl 24 + Ord('T') shl 16 + Ord('T') shl 8 + Ord('G');


ID_TOOL

Declaration

Source position: datatypes.pas line 114

const ID_TOOL = Ord('D') shl 24 + Ord('T') shl 16 + Ord('T') shl 8 + Ord('L');


ID_VHDR

Declaration

Source position: datatypes.pas line 633

const ID_VHDR = Ord('V') shl 24 + Ord('H') shl 16 + Ord('D') shl 8 + Ord('R');


IDataTypes

Declaration

Source position: datatypes.pas line 825

var IDataTypes: PInterface;


Reference for unit 'datatypes'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
amigados, | File and directory handling routines and types (dos.library)
intuition, | Screen and Window handling routines of intuition.library
utility, | Tag Handling, Date routines in utility.library
agraphics, | Native Amiga graphic functions (graphics.library)
iffparse;


Reference for unit 'datatypes': Constants

ADTA_Allocated

ADTA_ColorRegisters

ADTA_ColorTable

ADTA_ColorTable2

ADTA_CRegs

ADTA_Cycles

ADTA_Depth

ADTA_Dummy

ADTA_Frame

ADTA_FrameIncrement

ADTA_Frames

ADTA_FramesPerSecond

ADTA_GRegs

ADTA_Height

ADTA_KeyFrame

ADTA_LeftSample

ADTA_ModeID

ADTA_NumAlloc

ADTA_NumColors

ADTA_NumSparse

ADTA_Period

ADTA_PreloadFrameCount

ADTA_Remap

ADTA_RightSample

ADTA_Sample

ADTA_SampleLength

ADTA_SamplesPerSec

ADTA_Screen

ADTA_SparseTable

ADTA_Volume

ADTA_Width

ADTM_Dummy

ADTM_LOADFRAME

ADTM_LOADNEWFORMATFRAME

ADTM_LOCATE

ADTM_PAUSE

ADTM_START

ADTM_STOP

ADTM_UNLOADFRAME

ADTM_UNLOADNEWFORMATFRAME

ANIMATIONDTCLASS

cmpByteRun1

cmpByteRun2

cmpNone

CMP_FIBDELTA

CMP_NONE

DATATYPESCLASS

DATATYPESNAME

DTA_ARexxPortName

DTA_BaseName

DTA_Busy

DTA_Conductor

DTA_ControlPanel

DTA_Data

DTA_DataType

DTA_DestCols

DTA_DestRows

DTA_Domain

DTA_Dummy

DTA_ErrorLevel

DTA_ErrorNumber

DTA_ErrorString

DTA_FrameInfo

DTA_GroupID

DTA_Handle

DTA_HorizUnit

DTA_Immediate

DTA_LayoutProc

DTA_Methods

DTA_Name

DTA_NodeName

DTA_NominalHoriz

DTA_NominalVert

DTA_ObjAnnotation

DTA_ObjAuthor

DTA_ObjCopyright

DTA_ObjectID

DTA_ObjName

DTA_ObjVersion

DTA_PrinterProc

DTA_PrinterStatus

DTA_RastPort

DTA_Repeat

DTA_Reserved

DTA_SelectDomain

DTA_SourceAddress

DTA_SourceSize

DTA_SourceType

DTA_Special

DTA_Sync

DTA_TextAttr

DTA_TextFont

DTA_Title

DTA_TopHoriz

DTA_TopVert

DTA_TotalHoriz

DTA_TotalPHoriz

DTA_TotalPVert

DTA_TotalVert

DTA_TriggerMethods

DTA_UserData

DTA_VertUnit

DTA_VisibleHoriz

DTA_VisibleVert

DTERROR_COULDNT_OPEN

DTERROR_COULDNT_OPEN_CLIPBOARD

DTERROR_COULDNT_SAVE

DTERROR_COULDNT_SEND_MESSAGE

DTERROR_INVALID_DATA

DTERROR_NOT_AVAILABLE

DTERROR_NOT_ENOUGH_DATA

DTERROR_Reserved

DTERROR_UNKNOWN_COMPRESSION

DTERROR_UNKNOWN_DATATYPE

DTF_ASCII

DTF_BINARY

DTF_CASE

DTF_IFF

DTF_MISC

DTF_SYSTEM1

DTF_TYPE_MASK

DTHSIZE

DTMSG_TYPE_OFFSET

DTM_ABORTPRINT

DTM_ASYNCLAYOUT

DTM_CLEARSELECTED

DTM_COPY

DTM_DISPOSEMEMBER

DTM_DRAW

DTM_Dummy

DTM_FRAMEBOX

DTM_GOTO

DTM_NEWMEMBER

DTM_OBTAINDRAWINFO

DTM_PRINT

DTM_PROCLAYOUT

DTM_RELEASEDRAWINFO

DTM_REMOVEDTOBJECT

DTM_SELECT

DTM_TRIGGER

DTM_WRITE

DTNSIZE

DTSIF_DRAGGING

DTSIF_DRAGSELECT

DTSIF_HIGHLIGHT

DTSIF_LAYOUT

DTSIF_LAYOUTPROC

DTSIF_NEWSIZE

DTSIF_PRINTING

DTST_CLIPBOARD

DTST_FILE

DTST_HOTLINK

DTST_MEMORY

DTST_RAM

DTWM_IFF

DTWM_RAW

FIF_REMAPPABLE

FIF_SCALABLE

FIF_SCROLLABLE

GID_ANIMATION

GID_DOCUMENT

GID_INSTRUMENT

GID_MOVIE

GID_MUSIC

GID_PICTURE

GID_SOUND

GID_SYSTEM

GID_TEXT

ID_8SVX

ID_ANHD

ID_ANIM

ID_BMHD

ID_BODY

ID_CAMG

ID_CHAN

ID_CHRS

ID_CMAP

ID_CODE

ID_CRNG

ID_DEST

ID_DLTA

ID_DTHD

ID_DTYP

ID_FTXT

ID_GRAB

ID_ILBM

ID_NAME

ID_SPRT

ID_TAGS

ID_TOOL

ID_VHDR

LNF_LF

LNF_LINK

LNF_OBJECT

LNF_SELECTED

mskHasAlpha

mskHasMask

mskHasTransparentColor

mskLasso

mskNone

PDTANUMPICTURES_Unknown

PDTA_Allocated

PDTA_AllocatedPens

PDTA_BitMap

PDTA_BitMapHeader

PDTA_ClassBitMap

PDTA_ColorRegisters

PDTA_ColorTable

PDTA_ColorTable2

PDTA_CRegs

PDTA_DestBitMap

PDTA_DestMode

PDTA_DitherQuality

PDTA_FreeSourceBitMap

PDTA_GetNumPictures

PDTA_Grab

PDTA_GRegs

PDTA_MaskPlane

PDTA_MaxDitherPens

PDTA_ModeID

PDTA_NumAlloc

PDTA_NumColors

PDTA_NumSparse

PDTA_Remap

PDTA_ScaleQuality

PDTA_Screen

PDTA_SourceMode

PDTA_SparseTable

PDTA_UseFriendBitMap

PDTA_WhichPicture

PDTM_Dummy

PDTM_READPIXELARRAY

PDTM_WRITEPIXELARRAY

PICTUREDTCLASS

PMODE_V42

PMODE_V43

SAMPLETYPE_Left

SAMPLETYPE_Right

SAMPLETYPE_Stereo

SDTA_Continuous

SDTA_Cycles

SDTA_Dummy

SDTA_FreeSampleData

SDTA_LeftSample

SDTA_Pan

SDTA_Period

SDTA_ReplayPeriod

SDTA_RightSample

SDTA_Sample

SDTA_SampleLength

SDTA_SamplesPerSec

SDTA_SignalBit

SDTA_SignalBitMask

SDTA_SignalBitNumber

SDTA_SignalTask

SDTA_SyncSampleChange

SDTA_VoiceHeader

SDTA_Volume

SOUNDDTCLASS

STM_ACTIVATE_FIELD

STM_BROWSE_NEXT

STM_BROWSE_PREV

STM_COMMAND

STM_CONTENTS

STM_FASTFORWARD

STM_INDEX

STM_LOCATE

STM_NEXT_FIELD

STM_PAUSE

STM_PLAY

STM_PREV_FIELD

STM_RESUME

STM_RETRACE

STM_REWIND

STM_STOP

TDTA_Buffer

TDTA_BufferLen

TDTA_LineList

TDTA_WordDelim

TDTA_WordSelect

TDTA_WordWrap

TEXTDTCLASS

TF_LAUNCH_MASK

TF_RX

TF_SHELL

TF_WORKBENCH

TNSIZE

TOOLSIZE

TW_BROWSE

TW_EDIT

TW_INFO

TW_MAIL

TW_PRINT

Unity


Reference for unit 'datatypes': Types

PadtFrame

PadtNewFormatFrame

PadtStart

PAnimHeader

PBitMapHeader

PColorRegister

PDataType

PDataTypeHeader

PdtDraw

PdtFrameBox

PdtGeneral

PdtGoto

PDTMethod

PdtSelect

PDTSpecialInfo

PdtTrigger

PdtWrite

PFrameInfo

PLine

PTHookContext

PTool

PToolNode

PVoiceHeader

TadtFrame

TadtNewFormatFrame

TadtStart

TAnimHeader

TBitMapHeader

TColorRegister

TDataType

TDataTypeHeader

TdtDraw

TdtFrameBox

TdtGeneral

TdtGoto

TDTHookContext

TDTMethod

TdtSelect

TDTSpecialInfo

TdtTrigger

TdtWrite

TFrameInfo

TLine

LongInt

TTool

TToolNode

TVoiceHeader


LNF_LF

Declaration

Source position: datatypes.pas line 667

const LNF_LF = 1 shl 0;


LNF_LINK

Declaration

Source position: datatypes.pas line 668

const LNF_LINK = 1 shl 1;


LNF_OBJECT

Declaration

Source position: datatypes.pas line 669

const LNF_OBJECT = 1 shl 2;


LNF_SELECTED

Declaration

Source position: datatypes.pas line 670

const LNF_SELECTED = 1 shl 3;


mskHasAlpha

Declaration

Source position: datatypes.pas line 529

const mskHasAlpha = 4;


mskHasMask

Declaration

Source position: datatypes.pas line 526

const mskHasMask = 1;


mskHasTransparentColor

Declaration

Source position: datatypes.pas line 527

const mskHasTransparentColor = 2;


mskLasso

Declaration

Source position: datatypes.pas line 528

const mskLasso = 3;


mskNone

Declaration

Source position: datatypes.pas line 525

const mskNone = 0;


PadtFrame

Declaration

Source position: datatypes.pas line 781

type PadtFrame = ^TadtFrame;


PadtNewFormatFrame

Declaration

Source position: datatypes.pas line 797

type PadtNewFormatFrame = ^TadtNewFormatFrame;


PadtStart

Declaration

Source position: datatypes.pas line 817

type PadtStart = ^tadtStart;


PAnimHeader

Declaration

Source position: datatypes.pas line 724

type PAnimHeader = ^TAnimHeader;


PBitMapHeader

Declaration

Source position: datatypes.pas line 538

type PBitMapHeader = ^TBitMapHeader;


PColorRegister

Declaration

Source position: datatypes.pas line 555

type PColorRegister = ^TColorRegister;


PDataType

Declaration

Source position: datatypes.pas line 143

type PDataType = ^TDataType;


PDataTypeHeader

Declaration

Source position: datatypes.pas line 31

type PDataTypeHeader = ^TDataTypeHeader;


PDTA_Allocated

Declaration

Source position: datatypes.pas line 484

const PDTA_Allocated = DTA_Dummy + 208;


PDTA_AllocatedPens

Declaration

Source position: datatypes.pas line 501

const PDTA_AllocatedPens = DTA_Dummy + 223;


PDTA_BitMap

Declaration

Source position: datatypes.pas line 475

const PDTA_BitMap = DTA_Dummy + 202;


PDTA_BitMapHeader

Declaration

Source position: datatypes.pas line 474

const PDTA_BitMapHeader = DTA_Dummy + 201;


PDTA_ClassBitMap

Declaration

Source position: datatypes.pas line 492

const PDTA_ClassBitMap = DTA_Dummy + 216;


PDTA_ColorRegisters

Declaration

Source position: datatypes.pas line 476

const PDTA_ColorRegisters = DTA_Dummy + 203;


PDTA_ColorTable

Declaration

Source position: datatypes.pas line 480

const PDTA_ColorTable = DTA_Dummy + 206;


PDTA_ColorTable2

Declaration

Source position: datatypes.pas line 481

const PDTA_ColorTable2 = DTA_Dummy + 207;


PDTA_CRegs

Declaration

Source position: datatypes.pas line 477

const PDTA_CRegs = DTA_Dummy + 204;


PDTA_DestBitMap

Declaration

Source position: datatypes.pas line 491

const PDTA_DestBitMap = DTA_Dummy + 215;


PDTA_DestMode

Declaration

Source position: datatypes.pas line 510

const PDTA_DestMode = DTA_Dummy + 251;


PDTA_DitherQuality

Declaration

Source position: datatypes.pas line 500

const PDTA_DitherQuality = DTA_Dummy + 222;


PDTA_FreeSourceBitMap

Declaration

Source position: datatypes.pas line 489

const PDTA_FreeSourceBitMap = DTA_Dummy + 213;


PDTA_GetNumPictures

Declaration

Source position: datatypes.pas line 498

const PDTA_GetNumPictures = DTA_Dummy + 220;


PDTA_Grab

Declaration

Source position: datatypes.pas line 490

const PDTA_Grab = DTA_Dummy + 214;


PDTA_GRegs

Declaration

Source position: datatypes.pas line 478

const PDTA_GRegs = DTA_Dummy + 205;


PDTA_MaskPlane

Declaration

Source position: datatypes.pas line 512

const PDTA_MaskPlane = DTA_Dummy + 258;


PDTA_MaxDitherPens

Declaration

Source position: datatypes.pas line 499

const PDTA_MaxDitherPens = DTA_Dummy + 221;


PDTA_ModeID

Declaration

Source position: datatypes.pas line 473

const PDTA_ModeID = DTA_Dummy + 200;


PDTA_NumAlloc

Declaration

Source position: datatypes.pas line 486

const PDTA_NumAlloc = DTA_Dummy + 210;


PDTA_NumColors

Declaration

Source position: datatypes.pas line 485

const PDTA_NumColors = DTA_Dummy + 209;


PDTA_NumSparse

Declaration

Source position: datatypes.pas line 493

const PDTA_NumSparse = DTA_Dummy + 217;


PDTA_Remap

Declaration

Source position: datatypes.pas line 487

const PDTA_Remap = DTA_Dummy + 211;


PDTA_ScaleQuality

Declaration

Source position: datatypes.pas line 503

const PDTA_ScaleQuality = DTA_Dummy + 224;


PDTA_Screen

Declaration

Source position: datatypes.pas line 488

const PDTA_Screen = DTA_Dummy + 212;


PDTA_SourceMode

Declaration

Source position: datatypes.pas line 509

const PDTA_SourceMode = DTA_Dummy + 250;


PDTA_SparseTable

Declaration

Source position: datatypes.pas line 494

const PDTA_SparseTable = DTA_Dummy + 218;


PDTA_UseFriendBitMap

Declaration

Source position: datatypes.pas line 511

const PDTA_UseFriendBitMap = DTA_Dummy + 255;


PDTA_WhichPicture

Declaration

Source position: datatypes.pas line 497

const PDTA_WhichPicture = DTA_Dummy + 219;


PDTANUMPICTURES_Unknown

Declaration

Source position: datatypes.pas line 506

const PDTANUMPICTURES_Unknown = 0;


PdtDraw

Declaration

Source position: datatypes.pas line 441

type PdtDraw = ^TdtDraw;


PdtFrameBox

Declaration

Source position: datatypes.pas line 372

type PdtFrameBox = ^TdtFrameBox;


PdtGeneral

Declaration

Source position: datatypes.pas line 357

type PdtGeneral = ^TdtGeneral;


PdtGoto

Declaration

Source position: datatypes.pas line 383

type PdtGoto = ^TdtGoto;


PDTM_Dummy

Declaration

Source position: datatypes.pas line 519

const PDTM_Dummy = DTM_Dummy + $60;


PDTM_READPIXELARRAY

Declaration

Source position: datatypes.pas line 522

const PDTM_READPIXELARRAY = PDTM_Dummy + 1;


PDTM_WRITEPIXELARRAY

Declaration

Source position: datatypes.pas line 521

const PDTM_WRITEPIXELARRAY = PDTM_Dummy + 0;


PDTMethod

Declaration

Source position: datatypes.pas line 293

type PDTMethod = ^TDTMethod;


PdtSelect

Declaration

Source position: datatypes.pas line 364

type PdtSelect = ^TdtSelect;


PDTSpecialInfo

Declaration

Source position: datatypes.pas line 265

type PDTSpecialInfo = ^TDTSpecialInfo;


PdtTrigger

Declaration

Source position: datatypes.pas line 392

type PdtTrigger = ^TdtTrigger;


PdtWrite

Declaration

Source position: datatypes.pas line 455

type PdtWrite = ^TdtWrite;


PFrameInfo

Declaration

Source position: datatypes.pas line 329

type PFrameInfo = ^TFrameInfo;


PICTUREDTCLASS

Declaration

Source position: datatypes.pas line 470

const PICTUREDTCLASS = 'picture.datatype';


PLine

Declaration

Source position: datatypes.pas line 650

type PLine = ^TLine;


PMODE_V42

Declaration

Source position: datatypes.pas line 515

const PMODE_V42 = 0;


PMODE_V43

Declaration

Source position: datatypes.pas line 516

const PMODE_V43 = 1;


PTHookContext

Declaration

Source position: datatypes.pas line 98

type PTHookContext = ^TDTHookContext;


PTool

Declaration

Source position: datatypes.pas line 117

type PTool = ^TTool;


PToolNode

Declaration

Source position: datatypes.pas line 158

type PToolNode = ^TToolNode;


PVoiceHeader

Declaration

Source position: datatypes.pas line 610

type PVoiceHeader = ^TVoiceHeader;


SAMPLETYPE_Left

Declaration

Source position: datatypes.pas line 623

const SAMPLETYPE_Left = 2;


SAMPLETYPE_Right

Declaration

Source position: datatypes.pas line 624

const SAMPLETYPE_Right = 4;


SAMPLETYPE_Stereo

Declaration

Source position: datatypes.pas line 625

const SAMPLETYPE_Stereo = 6;


SDTA_Continuous

Declaration

Source position: datatypes.pas line 590

const SDTA_Continuous = SDTA_Dummy + 9;


SDTA_Cycles

Declaration

Source position: datatypes.pas line 585

const SDTA_Cycles = SDTA_Dummy + 6;


SDTA_Dummy

Declaration

Source position: datatypes.pas line 579

const SDTA_Dummy = DTA_Dummy + 500;


SDTA_FreeSampleData

Declaration

Source position: datatypes.pas line 599

const SDTA_FreeSampleData = SDTA_Dummy + 16;


SDTA_LeftSample

Declaration

Source position: datatypes.pas line 596

const SDTA_LeftSample = SDTA_Dummy + 13;


SDTA_Pan

Declaration

Source position: datatypes.pas line 598

const SDTA_Pan = SDTA_Dummy + 15;


SDTA_Period

Declaration

Source position: datatypes.pas line 583

const SDTA_Period = SDTA_Dummy + 4;


SDTA_ReplayPeriod

Declaration

Source position: datatypes.pas line 595

const SDTA_ReplayPeriod = SDTA_Dummy + 12;


SDTA_RightSample

Declaration

Source position: datatypes.pas line 597

const SDTA_RightSample = SDTA_Dummy + 14;


SDTA_Sample

Declaration

Source position: datatypes.pas line 581

const SDTA_Sample = SDTA_Dummy + 2;


SDTA_SampleLength

Declaration

Source position: datatypes.pas line 582

const SDTA_SampleLength = SDTA_Dummy + 3;


SDTA_SamplesPerSec

Declaration

Source position: datatypes.pas line 594

const SDTA_SamplesPerSec = SDTA_Dummy + 11;


SDTA_SignalBit

Declaration

Source position: datatypes.pas line 588

const SDTA_SignalBit = SDTA_Dummy + 8;


SDTA_SignalBitMask

Declaration

Source position: datatypes.pas line 589

const SDTA_SignalBitMask = SDTA_SignalBit;


SDTA_SignalBitNumber

Declaration

Source position: datatypes.pas line 593

const SDTA_SignalBitNumber = SDTA_Dummy + 10;


SDTA_SignalTask

Declaration

Source position: datatypes.pas line 587

const SDTA_SignalTask = SDTA_Dummy + 7;


SDTA_SyncSampleChange

Declaration

Source position: datatypes.pas line 600

const SDTA_SyncSampleChange = SDTA_Dummy + 17;


SDTA_VoiceHeader

Declaration

Source position: datatypes.pas line 580

const SDTA_VoiceHeader = SDTA_Dummy + 1;


SDTA_Volume

Declaration

Source position: datatypes.pas line 584

const SDTA_Volume = SDTA_Dummy + 5;


SOUNDDTCLASS

Declaration

Source position: datatypes.pas line 577

const SOUNDDTCLASS = 'sound.datatype';


STM_ACTIVATE_FIELD

Declaration

Source position: datatypes.pas line 411

const STM_ACTIVATE_FIELD = 10;


STM_BROWSE_NEXT

Declaration

Source position: datatypes.pas line 407

const STM_BROWSE_NEXT = 7;


STM_BROWSE_PREV

Declaration

Source position: datatypes.pas line 406

const STM_BROWSE_PREV = 6;


STM_COMMAND

Declaration

Source position: datatypes.pas line 413

const STM_COMMAND = 11;


STM_CONTENTS

Declaration

Source position: datatypes.pas line 403

const STM_CONTENTS = 3;


STM_FASTFORWARD

Declaration

Source position: datatypes.pas line 417

const STM_FASTFORWARD = 13;


STM_INDEX

Declaration

Source position: datatypes.pas line 404

const STM_INDEX = 4;


STM_LOCATE

Declaration

Source position: datatypes.pas line 420

const STM_LOCATE = 16;


STM_NEXT_FIELD

Declaration

Source position: datatypes.pas line 409

const STM_NEXT_FIELD = 8;


STM_PAUSE

Declaration

Source position: datatypes.pas line 401

const STM_PAUSE = 1;


STM_PLAY

Declaration

Source position: datatypes.pas line 402

const STM_PLAY = 2;


STM_PREV_FIELD

Declaration

Source position: datatypes.pas line 410

const STM_PREV_FIELD = 9;


STM_RESUME

Declaration

Source position: datatypes.pas line 419

const STM_RESUME = 15;


STM_RETRACE

Declaration

Source position: datatypes.pas line 405

const STM_RETRACE = 5;


STM_REWIND

Declaration

Source position: datatypes.pas line 416

const STM_REWIND = 12;


STM_STOP

Declaration

Source position: datatypes.pas line 418

const STM_STOP = 14;


TadtFrame

Declaration

Source position: datatypes.pas line 782

type TadtFrame = record

  MethodID: LongWord;

  alf_TimeStamp: LongWord;

  alf_Frame: LongWord;

  alf_Duration: LongWord;

  alf_BitMap: PBitMap;

  alf_CMap: PColorMap;

  alf_Sample: PShortInt;

  alf_SampleLength: LongWord;

  alf_Period: LongWord;

  alf_UserData: Pointer;

end;


TadtNewFormatFrame

Declaration

Source position: datatypes.pas line 798

type TadtNewFormatFrame = record

  MethodID: LongWord;

  alf_TimeStamp: LongWord;

  alf_Frame: LongWord;

  alf_Duration: LongWord;

  alf_BitMap: PBitMap;

  alf_CMap: PColorMap;

  alf_Sample: PShortInt;

  alf_SampleLength: LongWord;

  alf_Period: LongWord;

  alf_UserData: Pointer;

  alf_Size: LongWord;

  alf_LeftSample: PShortInt;

  alf_RightSample: PShortInt;

  alf_SamplesPerSec: LongWord;

end;


TadtStart

Declaration

Source position: datatypes.pas line 818

type TadtStart = record

  MethodID: LongWord;

  asa_Frame: LongWord;

end;


TAnimHeader

Declaration

Source position: datatypes.pas line 725

type TAnimHeader = record

  ah_Operation: Byte;

  ah_Mask: Byte;

  ah_Height: Word;

  ah_Width: Word;

  ah_Left: SmallInt;

  ah_Top: SmallInt;

  ah_AbsTime: LongWord;

  ah_RelTime: LongWord;

  ah_Interleave: Byte;

  ah_Pad0: Byte;

  ah_Flags: LongWord;

  ah_Pad: array [0..15] of Byte;

end;


TBitMapHeader

Declaration

Source position: datatypes.pas line 539

type TBitMapHeader = record

  bmh_Width: Word;

  bmh_Height: Word;

  bmh_Left: SmallInt;

  bmh_Top: SmallInt;

  bmh_Depth: Byte;

  bmh_Masking: Byte;

  bmh_Compression: Byte;

  bmh_Pad: Byte;

  bmh_Transparent: Word;

  bmh_XAspect: Byte;

  bmh_YAspect: Byte;

  bmh_PageWidth: SmallInt;

  bmh_PageHeight: SmallInt;

end;


TColorRegister

Declaration

Source position: datatypes.pas line 556

type TColorRegister = record

  red: Byte;

  green: Byte;

  blue: Byte;

end;


TDataType

Declaration

Source position: datatypes.pas line 144

type TDataType = record

  dtn_Node1: TNode;

  dtn_Node2: TNode;

  dtn_Header: PDataTypeHeader;

  dtn_ToolList: TList;

  dtn_FunctionName: PChar;

  dtn_AttrList: PTagItem;

  dtn_Length: LongWord;

end;


TDataTypeHeader

Declaration

Source position: datatypes.pas line 32

type TDataTypeHeader = record

  dth_Name: PChar;

  dth_BaseName: PChar;

  dth_Pattern: PChar;

  dth_Mask: PSmallInt;

  dth_GroupID: LongWord;

  dth_ID: LongWord;

  dth_MaskLen: SmallInt;

  dth_Pad: SmallInt;

  dth_Flags: Word;

  dth_Priority: Word;

end;


TDTA_Buffer

Declaration

Source position: datatypes.pas line 641

const TDTA_Buffer = DTA_Dummy + 300;


TDTA_BufferLen

Declaration

Source position: datatypes.pas line 642

const TDTA_BufferLen = DTA_Dummy + 301;


TDTA_LineList

Declaration

Source position: datatypes.pas line 643

const TDTA_LineList = DTA_Dummy + 302;


TDTA_WordDelim

Declaration

Source position: datatypes.pas line 645

const TDTA_WordDelim = DTA_Dummy + 304;


TDTA_WordSelect

Declaration

Source position: datatypes.pas line 644

const TDTA_WordSelect = DTA_Dummy + 303;


TDTA_WordWrap

Declaration

Source position: datatypes.pas line 646

const TDTA_WordWrap = DTA_Dummy + 305;


TdtDraw

Declaration

Source position: datatypes.pas line 442

type TdtDraw = record

  MethodID: LongWord;

  dtd_RPort: PRastPort;

  dtd_Left: LongInt;

  dtd_Top: LongInt;

  dtd_Width: LongInt;

  dtd_Height: LongInt;

  dtd_TopHoriz: LongInt;

  dtd_TopVert: LongInt;

  dtd_AttrList: PTagItem;

end;


TdtFrameBox

Declaration

Source position: datatypes.pas line 373

type TdtFrameBox = record

  MethodID: LongWord;

  dtf_GInfo: PGadgetInfo;

  dtf_ContentsInfo: PFrameInfo;

  dtf_FrameInfo: PFrameInfo;

  dtf_SizeFrameInfo: LongWord;

  dtf_FrameFlags: LongWord;

end;


TdtGeneral

Declaration

Source position: datatypes.pas line 358

type TdtGeneral = record

  MethodID: LongWord;

  dtg_GInfo: PGadgetInfo;

end;


TdtGoto

Declaration

Source position: datatypes.pas line 384

type TdtGoto = record

  MethodID: LongWord;

  dtg_GInfo: PGadgetInfo;

  dtg_NodeName: PChar;

  dtg_AttrList: PTagItem;

end;


TDTHookContext

Declaration

Source position: datatypes.pas line 99

type TDTHookContext = record

  dthc_SysBase: PLibrary;

  dthc_DOSBase: PLibrary;

  dthc_IFFParseBase: PLibrary;

  dthc_UtilityBase: PLibrary;

  dthc_Lock: LongInt;

  dthc_FIB: PFileInfoBlock;

  dthc_FileHandle: LongInt;

  dthc_IFF: PIFFHandle;

  dthc_Buffer: PChar;

  dthc_BufferLength: LongWord;

end;


TDTMethod

Declaration

Source position: datatypes.pas line 294

type TDTMethod = record

  dtm_Label: PChar;

  dtm_Command: PChar;

  dtm_Method: LongWord;

end;


TdtSelect

Declaration

Source position: datatypes.pas line 365

type TdtSelect = record

  MethodID: LongWord;

  dts_GInfo: PGadgetInfo;

  dts_Select: TRectangle;

end;


TDTSpecialInfo

Declaration

Source position: datatypes.pas line 266

type TDTSpecialInfo = record

  si_Lock: TSignalSemaphore;

  si_Flags: LongWord;

  si_TopVert: LongInt;

  si_VisVert: LongInt;

  si_TotVert: LongInt;

  si_OTopVert: LongInt;

  si_VertUnit: LongInt;

  si_TopHoriz: LongInt;

  si_VisHoriz: LongInt;

  si_TotHoriz: LongInt;

  si_OTopHoriz: LongInt;

  si_HorizUnit: LongInt;

end;


TdtTrigger

Declaration

Source position: datatypes.pas line 393

type TdtTrigger = record

  MethodID: LongWord;

  dtt_GInfo: PGadgetInfo;

  dtt_Function: LongWord;

  dtt_Data: Pointer;

end;


TdtWrite

Declaration

Source position: datatypes.pas line 456

type TdtWrite = record

  MethodID: LongWord;

  dtw_GInfo: PGadgetInfo;

  dtw_FileHandle: LongInt;

  dtw_Mode: LongWord;

  dtw_AttrList: PTagItem;

end;


TEXTDTCLASS

Declaration

Source position: datatypes.pas line 638

const TEXTDTCLASS = 'text.datatype';


TF_LAUNCH_MASK

Declaration

Source position: datatypes.pas line 135

const TF_LAUNCH_MASK = $000F;


TF_RX

Declaration

Source position: datatypes.pas line 138

const TF_RX = $0003;


TF_SHELL

Declaration

Source position: datatypes.pas line 136

const TF_SHELL = $0001;


TF_WORKBENCH

Declaration

Source position: datatypes.pas line 137

const TF_WORKBENCH = $0002;


TFrameInfo

Declaration

Source position: datatypes.pas line 330

type TFrameInfo = record

  fri_PropertyFlags: LongWord;

  fri_Resolution: TPoint;

  fri_RedBits: Byte;

  fri_GreenBits: Byte;

  fri_BlueBits: Byte;

  fri_Dimensions: record

    Width: LongWord;

    Height: LongWord;

    Depth: LongWord;

  end;

  fri_Screen: PScreen;

  fri_ColorMap: PColorMap;

  fri_Flags: LongWord;

end;


TLine

Declaration

Source position: datatypes.pas line 651

type TLine = record

  ln_Link: TMinNode;

  ln_Text: PChar;

  ln_TextLen: LongWord;

  ln_XOffset: Word;

  ln_YOffset: Word;

  ln_Width: Word;

  ln_Height: Word;

  ln_Flags: Word;

  ln_FgPen: ShortInt;

  ln_BgPen: ShortInt;

  ln_Style: LongWord;

  ln_Data: Pointer;

end;


TNSIZE

Declaration

Source position: datatypes.pas line 165

const TNSIZE = SizeOf(TToolNode);


TOOLSIZE

Declaration

Source position: datatypes.pas line 125

const TOOLSIZE = SizeOf(TTool);


TSampleType

Declaration

Source position: datatypes.pas line 628

type TSampleType = LongInt;


TTool

Declaration

Source position: datatypes.pas line 118

type TTool = record

  tn_Which: Word;

  tn_Flags: Word;

  tn_Program: PChar;

end;


TToolNode

Declaration

Source position: datatypes.pas line 159

type TToolNode = record

  tn_Node: TNode;

  tn_Tool: TTool;

  tn_Length: LongWord;

end;


TVoiceHeader

Declaration

Source position: datatypes.pas line 611

type TVoiceHeader = record

  vh_OneShotHiSamples: LongWord;

  vh_RepeatHiSamples: LongWord;

  vh_SamplesPerHiCycle: LongWord;

  vh_SamplesPerSec: Word;

  vh_Octaves: Byte;

  vh_Compression: Byte;

  vh_Volume: LongWord;

end;


TW_BROWSE

Declaration

Source position: datatypes.pas line 129

const TW_BROWSE = 2;


TW_EDIT

Declaration

Source position: datatypes.pas line 130

const TW_EDIT = 3;


TW_INFO

Declaration

Source position: datatypes.pas line 128

const TW_INFO = 1;


TW_MAIL

Declaration

Source position: datatypes.pas line 132

const TW_MAIL = 5;


TW_PRINT

Declaration

Source position: datatypes.pas line 131

const TW_PRINT = 4;


Unity

Declaration

Source position: datatypes.pas line 607

const Unity = $10000;


AFB_BITMAP

Declaration

Source position: diskfont.pas line 86

const AFB_BITMAP = 3;


AFB_CHARSET

Declaration

Source position: diskfont.pas line 90

const AFB_CHARSET = 5;


AFB_DISK

Declaration

Source position: diskfont.pas line 82

const AFB_DISK = 1;


AFB_MEMORY

Declaration

Source position: diskfont.pas line 80

const AFB_MEMORY = 0;


AFB_OTAG

Declaration

Source position: diskfont.pas line 88

const AFB_OTAG = 4;


AFB_SCALED

Declaration

Source position: diskfont.pas line 84

const AFB_SCALED = 2;


AFB_TAGGED

return TAvailFonts

Declaration

Source position: diskfont.pas line 95

const AFB_TAGGED = 16;


AFB_TYPE

Declaration

Source position: diskfont.pas line 92

const AFB_TYPE = 6;


AFF_BITMAP

Declaration

Source position: diskfont.pas line 87

const AFF_BITMAP = $0008;


AFF_CHARSET

Declaration

Source position: diskfont.pas line 91

const AFF_CHARSET = $0020;


AFF_DISK

Declaration

Source position: diskfont.pas line 83

const AFF_DISK = $0002;


AFF_MEMORY

Declaration

Source position: diskfont.pas line 81

const AFF_MEMORY = $0001;


AFF_OTAG

Declaration

Source position: diskfont.pas line 89

const AFF_OTAG = $0010;


AFF_SCALED

Declaration

Source position: diskfont.pas line 85

const AFF_SCALED = $0004;


AFF_TAGGED

return TAvailFonts

Declaration

Source position: diskfont.pas line 96

const AFF_TAGGED = $10000;


AFF_TYPE

Declaration

Source position: diskfont.pas line 93

const AFF_TYPE = $0040;


DFCS_MAPTABLE

Declaration

Source position: diskfont.pas line 420

const DFCS_MAPTABLE = DFCTRL_BASE + 4;


DFCS_MIMENAME

Declaration

Source position: diskfont.pas line 419

const DFCS_MIMENAME = DFCTRL_BASE + 3;


DFCS_NAME

Declaration

Source position: diskfont.pas line 418

const DFCS_NAME = DFCTRL_BASE + 2;


DFCS_NEXTNUMBER

Declaration

Source position: diskfont.pas line 417

const DFCS_NEXTNUMBER = DFCTRL_BASE + 1;


DFCS_NUMBER

Declaration

Source position: diskfont.pas line 416

const DFCS_NUMBER = DFCTRL_BASE + 0;


DFCTRL_ANTIALIASING

Declaration

Source position: diskfont.pas line 415

const DFCTRL_ANTIALIASING = DFCTRL_BASE + 9;


DFCTRL_BASE

Declaration

Source position: diskfont.pas line 400

const DFCTRL_BASE = TAG_USER + $0B000000;


DFCTRL_CACHE

Declaration

Source position: diskfont.pas line 406

const DFCTRL_CACHE = DFCTRL_BASE + 5;


DFCTRL_CACHEFLUSH

Declaration

Source position: diskfont.pas line 413

const DFCTRL_CACHEFLUSH = DFCTRL_BASE + 7;


DFCTRL_CHARSET

Declaration

Source position: diskfont.pas line 414

const DFCTRL_CHARSET = DFCTRL_BASE + 8;


DFCTRL_SORT_ASC

Declaration

Source position: diskfont.pas line 411

const DFCTRL_SORT_ASC = 1;


DFCTRL_SORT_DES

Declaration

Source position: diskfont.pas line 412

const DFCTRL_SORT_DES = not 0;


DFCTRL_SORT_OFF

Declaration

Source position: diskfont.pas line 409

const DFCTRL_SORT_OFF = 0;


DFCTRL_SORTMODE

Declaration

Source position: diskfont.pas line 407

const DFCTRL_SORTMODE = DFCTRL_BASE + 6;


DFCTRL_XDOTP

Declaration

Source position: diskfont.pas line 404

const DFCTRL_XDOTP = DFCTRL_BASE + 3;


DFCTRL_XDPI

Declaration

Source position: diskfont.pas line 402

const DFCTRL_XDPI = DFCTRL_BASE + 1;


DFCTRL_YDOTP

Declaration

Source position: diskfont.pas line 405

const DFCTRL_YDOTP = DFCTRL_BASE + 4;


DFCTRL_YDPI

Declaration

Source position: diskfont.pas line 403

const DFCTRL_YDPI = DFCTRL_BASE + 2;


DFH_ID

TDiskFontHeader.dfh_FileID

Declaration

Source position: diskfont.pas line 58

const DFH_ID = $0f80;


DiskfontBase

Declaration

Source position: diskfont.pas line 442

var DiskfontBase: PLibrary;


DISKFONTNAME

Declaration

Source position: diskfont.pas line 439

const DISKFONTNAME: PChar = 'diskfont.library';


FCH_ID

TFontContentsHeader.fch_FileID, then TFontContents

Declaration

Source position: diskfont.pas line 46

const FCH_ID = $0f00;


IDiskfont

Declaration

Source position: diskfont.pas line 443

var IDiskfont: PInterface;


Reference for unit 'diskfont'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'diskfont': Constants

AFB_BITMAP |
AFB_CHARSET
AFB_DISK |
AFB_MEMORY |
AFB_OTAG
AFB_SCALED |
AFB_TAGGED | return TAvailFonts
AFB_TYPE
AFF_BITMAP |
AFF_CHARSET
AFF_DISK |
AFF_MEMORY |
AFF_OTAG
AFF_SCALED |
AFF_TAGGED | return TAvailFonts
AFF_TYPE
DFCS_MAPTABLE
DFCS_MIMENAME
DFCS_NAME
DFCS_NEXTNUMBER
DFCS_NUMBER
DFCTRL_ANTIALIASING
DFCTRL_BASE
DFCTRL_CACHE
DFCTRL_CACHEFLUSH
DFCTRL_CHARSET
DFCTRL_SORTMODE
DFCTRL_SORT_ASC
DFCTRL_SORT_DES
DFCTRL_SORT_OFF
DFCTRL_XDOTP
DFCTRL_XDPI
DFCTRL_YDOTP
DFCTRL_YDPI
DFH_ID | TDiskFontHeader.dfh_FileID
DISKFONTNAME |
FCH_ID | TFontContentsHeader.fch_FileID, then TFontContents
MAXFONTNAME | Font name including '.font'#0
MAXFONTPATH | Maximum length (including null terminator) of a filesystem path to a Font file.
OFB_OPEN
OFCH_ID |
OFF_OPEN
OTERR_BadData
OTERR_BadFace
OTERR_BadGlyph
OTERR_BadTag
OTERR_Failure
OTERR_NoFace
OTERR_NoGlyph
OTERR_NoMemory
OTERR_NoRotate
OTERR_NoShear
OTERR_Success
OTERR_TooSmall
OTERR_UnknownGlyph
OTERR_UnknownTag
OTE_Bullet
OTF_BDF
OTF_CFF
OTF_Intellifont
OTF_PCF
OTF_PFR
OTF_TrueType
OTF_Type1
OTF_Type1CID
OTF_Type42
OTF_WinFonts
OTH_Compressed
OTH_Condensed
OTH_Expanded
OTH_ExtraCompressed
OTH_ExtraExpanded
OTH_Normal
OTH_SemiExpanded
OTH_UltraCompressed
OTSUFFIX
OTS_Black
OTS_Bold
OTS_Book
OTS_DemiBold
OTS_DemiLight
OTS_ExtraBlack
OTS_ExtraBold
OTS_ExtraLight
OTS_ExtraThin
OTS_Italic
OTS_LeftItalic
OTS_Light
OTS_Medium
OTS_SemiBold
OTS_SemiLight
OTS_Thin
OTS_UltraBlack
OTS_UltraThin
OTS_Upright
OTUL_Broken
OTUL_DoubleBroken
OTUL_DoubleSolid
OTUL_None
OTUL_Solid
OT_AFMFile
OT_AvailSizes
OT_BaseLine
OT_BIName
OT_BMSize
OT_BName
OT_DesignKernPair
OT_DeviceDPI
OT_DotSize
OT_EmboldenX
OT_EmboldenY
OT_Engine
OT_Family
OT_FileIdent
OT_FontFile
OT_FontFormat
OT_GlyphCode
OT_GlyphCode2
OT_GlyphCode2_32
OT_GlyphCode_32
OT_GlyphMap
OT_GlyphMap8Bit
OT_GlyphMap8BitLCD
OT_GlyphMap8BitLCDV
OT_GlyphName
OT_GlyphWidth
OT_HasGlyphs
OT_HorizStyle
OT_IName
OT_Indirect
OT_InhibitAlgoStyle
OT_IsFixed
OT_IsUnderlined
OT_Level0
OT_Level1
OT_Level2
OT_Level3
OT_MAXAVAILSIZES
OT_MemPtr
OT_MemSize
OT_MetricsFile
OT_NumGlyphs
OT_NumKernPairs
OT_OTagList
OT_OTagPath
OT_PointHeight
OT_PointSize
OT_RName
OT_RotateCos
OT_RotateSin
OT_SerifFlag
OT_SetFactor
OT_ShearCos
OT_ShearSin
OT_SlantStyle
OT_SpaceFactor
OT_SpaceWidth
OT_Spec
OT_Spec1
OT_SpecCount
OT_StemWeight
OT_StrikeThrough
OT_TextKernPair
OT_UnderLined
OT_UnicodeRanges
OT_WidthList
OT_WidthList32
OT_YSizeFactor
OUTL_DoubleBroken
TFCH_ID | TFontContentsHeader.fch_FileID, then TTFontContents
UCR_ALPHABETIC_PRESENTATION_FORMS
UCR_ARABIC
UCR_ARABIC_PRESENTATIONS_A
UCR_ARABIC_PRESENTATIONS_B
UCR_ARMENIAN
UCR_ARROWS
UCR_BASIC_LATIN
UCR_BENGALI
UCR_BLOCK_ELEMENTS
UCR_BOPOMOFO
UCR_BOX_DRAWING
UCR_BRAILLE
UCR_CANADIAN_ABORIGINAL_SYLLABICS
UCR_CHEROKEE
UCR_CJK_COMPATIBILITY
UCR_CJK_COMPATIBILITY_FORMS
UCR_CJK_COMPATIBILITY_IDEOGRAPHS
UCR_CJK_MISC
UCR_CJK_SYMBOLS
UCR_CJK_UNIFIED_IDEOGRAPHS
UCR_COMBINING_DIACRITICS
UCR_COMBINING_DIACRITICS_SYMB
UCR_COMBINING_HALF_MARKS
UCR_CONTROL_PICTURES
UCR_CURRENCY_SYMBOLS
UCR_CYRILLIC
UCR_DEVANAGARI
UCR_DINGBATS
UCR_ENCLOSED_ALPHANUMERICS
UCR_ENCLOSED_CJK_LETTERS_MONTHS
UCR_ETHIOPIC
UCR_GENERAL_PUNCTUATION
UCR_GEOMETRIC_SHAPES
UCR_GEORGIAN
UCR_GREEK
UCR_GREEK_EXTENDED
UCR_GUJARATI
UCR_GURMUKHI
UCR_HALFWIDTH_FULLWIDTH_FORMS
UCR_HANGUL
UCR_HANGUL_COMPATIBILITY_JAMO
UCR_HANGUL_JAMO
UCR_HEBREW
UCR_HIRAGANA
UCR_IPA_EXTENSIONS
UCR_KANBUN
UCR_KANNADA
UCR_KATAKANA
UCR_KHMER
UCR_LAO
UCR_LATIN1_SUPPLEMENT
UCR_LATIN_EXTENDED_A
UCR_LATIN_EXTENDED_ADDITIONAL
UCR_LATIN_EXTENDED_B
UCR_LETTERLIKE_SYMBOLS
UCR_MALAYALAM
UCR_MATHEMATICAL_OPERATORS
UCR_MISCELLANEOUS_SYMBOLS
UCR_MISCELLANEOUS_TECHNICAL
UCR_MONGOLIAN
UCR_MYANMAR
UCR_NUMBER_FORMS
UCR_OCR
UCR_OGHAM
UCR_ORIYA
UCR_PRIVATE_USE
UCR_RUNIC
UCR_SINHALA
UCR_SMALL_FORM_VARIANTS
UCR_SPACING_MODIFIER
UCR_SPECIALS
UCR_SUPERSCRIPTS_SUBSCRIPTS
UCR_SURROGATES
UCR_SYRIAC
UCR_TAMIL
UCR_TELUGU
UCR_THAANA
UCR_THAI
UCR_TIBETAN
UCR_YI


Reference for unit 'diskfont': Types

PAvailFonts |
PAvailFontsHeader |
PDiskFontHeader |
PEGlyphEngine
PFontContents |
PFontContentsHeader |
PGlyphEngine
PGlyphMap
PGlyphWidthEntry
PGlyphWidthEntry32
POutlineFont
PTAvailFonts |
PTFontContents |
TAvailFonts |
TAvailFontsHeader |
TDiskFontHeader | If dfh_TF.tf_Style FSB_TAGGED bit is set, dfh_Segment points to a TagList the taglist is destroyed on loading
TEGlyphEngine
TFontContents |
TFontContentsHeader |
TGlyphEngine
TGlyphMap
TGlyphWidthEntry
TGlyphWidthEntry32
TOutlineFont
TTAvailFonts |
TTFontContents |


MAXFONTNAME

Font name including '.font'#0

Declaration

Source position: diskfont.pas line 59

const MAXFONTNAME = 32;


MAXFONTPATH

Maximum length (including null terminator) of a filesystem path to a Font file.

Declaration

Source position: diskfont.pas line 23

const MAXFONTPATH = 256;


OFB_OPEN

Declaration

Source position: diskfont.pas line 172

const OFB_OPEN = 0;


OFCH_ID

Declaration

Source position: diskfont.pas line 48

const OFCH_ID = $0f03;


OFF_OPEN

Declaration

Source position: diskfont.pas line 173

const OFF_OPEN = $00000001;


OT_AFMFile

Declaration

Source position: diskfont.pas line 249

const OT_AFMFile = OT_MetricsFile;


OT_AvailSizes

Declaration

Source position: diskfont.pas line 308

const OT_AvailSizes = OT_Level1 or OT_Indirect or $20;


OT_BaseLine

Declaration

Source position: diskfont.pas line 234

const OT_BaseLine = OT_Level0 or OT_Indirect or $1c;


OT_BIName

Declaration

Source position: diskfont.pas line 265

const OT_BIName = OT_Level2 or OT_Indirect or $07;


OT_BMSize

Declaration

Source position: diskfont.pas line 311

const OT_BMSize = OT_Level2 or $21;


OT_BName

Declaration

Source position: diskfont.pas line 263

const OT_BName = OT_Level2 or OT_Indirect or $05;


OT_DesignKernPair

Declaration

Source position: diskfont.pas line 223

const OT_DesignKernPair = OT_Level0 or OT_Indirect or $23;


OT_DeviceDPI

Declaration

Source position: diskfont.pas line 196

const OT_DeviceDPI = OT_Level0 or $01;


OT_DotSize

Declaration

Source position: diskfont.pas line 197

const OT_DotSize = OT_Level0 or $02;


OT_EmboldenX

Declaration

Source position: diskfont.pas line 204

const OT_EmboldenX = OT_Level0 or $0e;


OT_EmboldenY

Declaration

Source position: diskfont.pas line 205

const OT_EmboldenY = OT_Level0 or $0f;


OT_Engine

Declaration

Source position: diskfont.pas line 244

const OT_Engine = OT_Level1 or OT_Indirect or $02;


OT_Family

Declaration

Source position: diskfont.pas line 246

const OT_Family = OT_Level1 or OT_Indirect or $03;


OT_FileIdent

Declaration

Source position: diskfont.pas line 243

const OT_FileIdent = OT_Level1 or $01;


OT_FontFile

Declaration

Source position: diskfont.pas line 247

const OT_FontFile = OT_Level2 or OT_Indirect or $24;


OT_FontFormat

Declaration

Source position: diskfont.pas line 250

const OT_FontFormat = OT_Level2 or OT_Indirect or $26;


OT_GlyphCode

Declaration

Source position: diskfont.pas line 207

const OT_GlyphCode = OT_Level0 or $11;


OT_GlyphCode2

Declaration

Source position: diskfont.pas line 208

const OT_GlyphCode2 = OT_Level0 or $12;


OT_GlyphCode2_32

Declaration

Source position: diskfont.pas line 210

const OT_GlyphCode2_32 = OT_Level0 or $19;


OT_GlyphCode_32

Declaration

Source position: diskfont.pas line 209

const OT_GlyphCode_32 = OT_Level0 or $18;


OT_GlyphMap

Declaration

Source position: diskfont.pas line 216

const OT_GlyphMap = OT_Level0 or OT_Indirect or $20;


OT_GlyphMap8Bit

Declaration

Source position: diskfont.pas line 217

const OT_GlyphMap8Bit = OT_Level0 or OT_Indirect or $1a;


OT_GlyphMap8BitLCD

Declaration

Source position: diskfont.pas line 218

const OT_GlyphMap8BitLCD = OT_Level0 or OT_Indirect or $27;


OT_GlyphMap8BitLCDV

Declaration

Source position: diskfont.pas line 219

const OT_GlyphMap8BitLCDV = OT_Level0 or OT_Indirect or $28;


OT_GlyphName

Declaration

Source position: diskfont.pas line 238

const OT_GlyphName = OT_Level0 or OT_Indirect or $26;


OT_GlyphWidth

Declaration

Source position: diskfont.pas line 211

const OT_GlyphWidth = OT_Level0 or $13;


OT_HasGlyphs

Declaration

Source position: diskfont.pas line 237

const OT_HasGlyphs = OT_Level0 or OT_Indirect or $1f;


OT_HorizStyle

Declaration

Source position: diskfont.pas line 295

const OT_HorizStyle = OT_Level1 or $17;


OT_IName

Declaration

Source position: diskfont.pas line 264

const OT_IName = OT_Level2 or OT_Indirect or $06;


OT_Indirect

Declaration

Source position: diskfont.pas line 193

const OT_Indirect = $8000;


OT_InhibitAlgoStyle

Declaration

Source position: diskfont.pas line 307

const OT_InhibitAlgoStyle = OT_Level2 or $19;


OT_IsFixed

Declaration

Source position: diskfont.pas line 269

const OT_IsFixed = OT_Level2 or $13;


OT_IsUnderlined

Declaration

Source position: diskfont.pas line 270

const OT_IsUnderlined = OT_Level2 or $23;


OT_Level0

Declaration

Source position: diskfont.pas line 189

const OT_Level0 = TAG_USER;


OT_Level1

Declaration

Source position: diskfont.pas line 190

const OT_Level1 = TAG_USER or $1000;


OT_Level2

Declaration

Source position: diskfont.pas line 191

const OT_Level2 = TAG_USER or $2000;


OT_Level3

Declaration

Source position: diskfont.pas line 192

const OT_Level3 = TAG_USER or $3000;


OT_MAXAVAILSIZES

Declaration

Source position: diskfont.pas line 309

const OT_MAXAVAILSIZES = 20;


OT_MemPtr

Declaration

Source position: diskfont.pas line 214

const OT_MemPtr = OT_Level0 or OT_Indirect or $16;


OT_MemSize

Declaration

Source position: diskfont.pas line 215

const OT_MemSize = OT_Level0 or $17;


OT_MetricsFile

Declaration

Source position: diskfont.pas line 248

const OT_MetricsFile = OT_Level2 or OT_Indirect or $25;


OT_NumGlyphs

Declaration

Source position: diskfont.pas line 235

const OT_NumGlyphs = OT_Level0 or OT_Indirect or $1d;


OT_NumKernPairs

Declaration

Source position: diskfont.pas line 236

const OT_NumKernPairs = OT_Level0 or OT_Indirect or $1e;


OT_OTagList

Declaration

Source position: diskfont.pas line 213

const OT_OTagList = OT_Level0 or OT_Indirect or $15;


OT_OTagPath

Declaration

Source position: diskfont.pas line 212

const OT_OTagPath = OT_Level0 or OT_Indirect or $14;


OT_PointHeight

Declaration

Source position: diskfont.pas line 198

const OT_PointHeight = OT_Level0 or $08;


OT_PointSize

Declaration

Source position: diskfont.pas line 206

const OT_PointSize = OT_Level0 or $10;


OT_RName

Declaration

Source position: diskfont.pas line 266

const OT_RName = OT_Level2 or OT_Indirect or $09;


OT_RotateCos

Declaration

Source position: diskfont.pas line 203

const OT_RotateCos = OT_Level0 or $0d;


OT_RotateSin

Declaration

Source position: diskfont.pas line 202

const OT_RotateSin = OT_Level0 or $0c;


OT_SerifFlag

Declaration

Source position: diskfont.pas line 271

const OT_SerifFlag = OT_Level1 or $14;


OT_SetFactor

Declaration

Source position: diskfont.pas line 199

const OT_SetFactor = OT_Level0 or $09;


OT_ShearCos

Declaration

Source position: diskfont.pas line 201

const OT_ShearCos = OT_Level0 or $0b;


OT_ShearSin

Declaration

Source position: diskfont.pas line 200

const OT_ShearSin = OT_Level0 or $0a;


OT_SlantStyle

Declaration

Source position: diskfont.pas line 291

const OT_SlantStyle = OT_Level1 or $16;


OT_SpaceFactor

Declaration

Source position: diskfont.pas line 306

const OT_SpaceFactor = OT_Level2 or $18;


OT_SpaceWidth

Declaration

Source position: diskfont.pas line 268

const OT_SpaceWidth = OT_Level2 or $12;


OT_Spec

Declaration

Source position: diskfont.pas line 396

const OT_Spec = OT_Level1 or $100;


OT_Spec1

Declaration

Source position: diskfont.pas line 397

const OT_Spec1 = OT_Level1 or $101;


OT_SpecCount

Declaration

Source position: diskfont.pas line 395

const OT_SpecCount = OT_Level1 or $100;


OT_StemWeight

Declaration

Source position: diskfont.pas line 272

const OT_StemWeight = OT_Level1 or $15;


OT_StrikeThrough

Declaration

Source position: diskfont.pas line 233

const OT_StrikeThrough = OT_Level0 or $25;


OT_TextKernPair

Declaration

Source position: diskfont.pas line 222

const OT_TextKernPair = OT_Level0 or OT_Indirect or $22;


OT_UnderLined

Declaration

Source position: diskfont.pas line 224

const OT_UnderLined = OT_Level0 or $24;


OT_UnicodeRanges

Declaration

Source position: diskfont.pas line 312

const OT_UnicodeRanges = OT_Level2 or OT_Indirect or $22;


OT_WidthList

Declaration

Source position: diskfont.pas line 220

const OT_WidthList = OT_Level0 or OT_Indirect or $21;


OT_WidthList32

Declaration

Source position: diskfont.pas line 221

const OT_WidthList32 = OT_Level0 or OT_Indirect or $1b;


OT_YSizeFactor

Declaration

Source position: diskfont.pas line 267

const OT_YSizeFactor = OT_Level1 or $11;


OTE_Bullet

Declaration

Source position: diskfont.pas line 245

const OTE_Bullet = 'bullet';


OTERR_BadData

Declaration

Source position: diskfont.pas line 427

const OTERR_BadData = 3;


OTERR_BadFace

Declaration

Source position: diskfont.pas line 430

const OTERR_BadFace = 6;


OTERR_BadGlyph

Declaration

Source position: diskfont.pas line 432

const OTERR_BadGlyph = 8;


OTERR_BadTag

Declaration

Source position: diskfont.pas line 425

const OTERR_BadTag = 1;


OTERR_Failure

Declaration

Source position: diskfont.pas line 423

const OTERR_Failure = - 1;


OTERR_NoFace

Declaration

Source position: diskfont.pas line 429

const OTERR_NoFace = 5;


OTERR_NoGlyph

Declaration

Source position: diskfont.pas line 431

const OTERR_NoGlyph = 7;


OTERR_NoMemory

Declaration

Source position: diskfont.pas line 428

const OTERR_NoMemory = 4;


OTERR_NoRotate

Declaration

Source position: diskfont.pas line 434

const OTERR_NoRotate = 10;


OTERR_NoShear

Declaration

Source position: diskfont.pas line 433

const OTERR_NoShear = 9;


OTERR_Success

Declaration

Source position: diskfont.pas line 424

const OTERR_Success = 0;


OTERR_TooSmall

Declaration

Source position: diskfont.pas line 435

const OTERR_TooSmall = 11;


OTERR_UnknownGlyph

Declaration

Source position: diskfont.pas line 436

const OTERR_UnknownGlyph = 12;


OTERR_UnknownTag

Declaration

Source position: diskfont.pas line 426

const OTERR_UnknownTag = 2;


OTF_BDF

Declaration

Source position: diskfont.pas line 252

const OTF_BDF = 'bdf';


OTF_CFF

Declaration

Source position: diskfont.pas line 253

const OTF_CFF = 'cff';


OTF_Intellifont

Declaration

Source position: diskfont.pas line 254

const OTF_Intellifont = 'intellifont';


OTF_PCF

Declaration

Source position: diskfont.pas line 255

const OTF_PCF = 'pcf';


OTF_PFR

Declaration

Source position: diskfont.pas line 256

const OTF_PFR = 'pfr';


OTF_TrueType

Declaration

Source position: diskfont.pas line 257

const OTF_TrueType = 'truetype';


OTF_Type1

Declaration

Source position: diskfont.pas line 258

const OTF_Type1 = 'type1';


OTF_Type1CID

Declaration

Source position: diskfont.pas line 259

const OTF_Type1CID = 't1cid';


OTF_Type42

Declaration

Source position: diskfont.pas line 260

const OTF_Type42 = 'type42';


OTF_WinFonts

Declaration

Source position: diskfont.pas line 261

const OTF_WinFonts = 'winfonts';


OTH_Compressed

Declaration

Source position: diskfont.pas line 299

const OTH_Compressed = 80;


OTH_Condensed

Declaration

Source position: diskfont.pas line 300

const OTH_Condensed = 112;


OTH_Expanded

Declaration

Source position: diskfont.pas line 303

const OTH_Expanded = 208;


OTH_ExtraCompressed

Declaration

Source position: diskfont.pas line 298

const OTH_ExtraCompressed = 48;


OTH_ExtraExpanded

Declaration

Source position: diskfont.pas line 304

const OTH_ExtraExpanded = 240;


OTH_Normal

Declaration

Source position: diskfont.pas line 301

const OTH_Normal = 144;


OTH_SemiExpanded

Declaration

Source position: diskfont.pas line 302

const OTH_SemiExpanded = 176;


OTH_UltraCompressed

Declaration

Source position: diskfont.pas line 297

const OTH_UltraCompressed = 16;


OTS_Black

Declaration

Source position: diskfont.pas line 287

const OTS_Black = 216;


OTS_Bold

Declaration

Source position: diskfont.pas line 285

const OTS_Bold = 184;


OTS_Book

Declaration

Source position: diskfont.pas line 281

const OTS_Book = 120;


OTS_DemiBold

Declaration

Source position: diskfont.pas line 284

const OTS_DemiBold = 168;


OTS_DemiLight

Declaration

Source position: diskfont.pas line 279

const OTS_DemiLight = 88;


OTS_ExtraBlack

Declaration

Source position: diskfont.pas line 288

const OTS_ExtraBlack = 232;


OTS_ExtraBold

Declaration

Source position: diskfont.pas line 286

const OTS_ExtraBold = 200;


OTS_ExtraLight

Declaration

Source position: diskfont.pas line 277

const OTS_ExtraLight = 56;


OTS_ExtraThin

Declaration

Source position: diskfont.pas line 275

const OTS_ExtraThin = 24;


OTS_Italic

Declaration

Source position: diskfont.pas line 293

const OTS_Italic = 1;


OTS_LeftItalic

Declaration

Source position: diskfont.pas line 294

const OTS_LeftItalic = 2;


OTS_Light

Declaration

Source position: diskfont.pas line 278

const OTS_Light = 72;


OTS_Medium

Declaration

Source position: diskfont.pas line 282

const OTS_Medium = 136;


OTS_SemiBold

Declaration

Source position: diskfont.pas line 283

const OTS_SemiBold = 152;


OTS_SemiLight

Declaration

Source position: diskfont.pas line 280

const OTS_SemiLight = 104;


OTS_Thin

Declaration

Source position: diskfont.pas line 276

const OTS_Thin = 40;


OTS_UltraBlack

Declaration

Source position: diskfont.pas line 289

const OTS_UltraBlack = 248;


OTS_UltraThin

Declaration

Source position: diskfont.pas line 274

const OTS_UltraThin = 8;


OTS_Upright

Declaration

Source position: diskfont.pas line 292

const OTS_Upright = 0;


OTSUFFIX

Declaration

Source position: diskfont.pas line 242

const OTSUFFIX = '.otag';


OTUL_Broken

Declaration

Source position: diskfont.pas line 228

const OTUL_Broken = 2;


OTUL_DoubleBroken

Declaration

Source position: diskfont.pas line 230

const OTUL_DoubleBroken = 4;


OTUL_DoubleSolid

Declaration

Source position: diskfont.pas line 229

const OTUL_DoubleSolid = 3;


OTUL_None

Declaration

Source position: diskfont.pas line 226

const OTUL_None = 0;


OTUL_Solid

Declaration

Source position: diskfont.pas line 227

const OTUL_Solid = 1;


OUTL_DoubleBroken

Declaration

Source position: diskfont.pas line 232

const OUTL_DoubleBroken = OTUL_DoubleBroken;


PAvailFonts

Declaration

Source position: diskfont.pas line 99

type PAvailFonts = ^TAvailFonts;


PAvailFontsHeader

Declaration

Source position: diskfont.pas line 111

type PAvailFontsHeader = ^TAvailFontsHeader;


PDiskFontHeader

Declaration

Source position: diskfont.pas line 62

type PDiskFontHeader = ^TDiskFontHeader;


PEGlyphEngine

Declaration

Source position: diskfont.pas line 163

type PEGlyphEngine = ^TEGlyphEngine;


PFontContents

Declaration

Source position: diskfont.pas line 26

type PFontContents = ^TFontContents;


PFontContentsHeader

Declaration

Source position: diskfont.pas line 51

type PFontContentsHeader = ^TFontContentsHeader;

See also

NewFontContents

DisposeFontContents


PGlyphEngine

Declaration

Source position: diskfont.pas line 119

type PGlyphEngine = ^TGlyphEngine;


PGlyphMap

Declaration

Source position: diskfont.pas line 128

type PGlyphMap = ^TGlyphMap;


PGlyphWidthEntry

Declaration

Source position: diskfont.pas line 146

type PGlyphWidthEntry = ^TGlyphWidthEntry;


PGlyphWidthEntry32

Declaration

Source position: diskfont.pas line 154

type PGlyphWidthEntry32 = ^TGlyphWidthEntry32;


POutlineFont

Declaration

Source position: diskfont.pas line 177

type POutlineFont = ^TOutlineFont;


PTAvailFonts

Declaration

Source position: diskfont.pas line 105

type PTAvailFonts = ^TTAvailFonts;


PTFontContents

Declaration

Source position: diskfont.pas line 34

type PTFontContents = ^TTFontContents;


TAvailFonts

Declaration

Source position: diskfont.pas line 100

type TAvailFonts = record
af_Type: Word; | AFF_MEMORY, AFF_DISK or AFF_SCALED
af_Attr: TTextAttr; | text attributes for font
end;


TAvailFontsHeader

Declaration

Source position: diskfont.pas line 112

type TAvailFontsHeader = record

  afh_NumEntries: Word;

number of AvailFonts elements

end;


TDiskFontHeader

If dfh_TF.tf_Style FSB_TAGGED bit is set, dfh_Segment points to a TagList the taglist is destroyed on loading

Declaration

Source position: diskfont.pas line 63

type TDiskFontHeader = record
dfh_DF: TNode; | Node to link disk fonts
dfh_FileID: Word; | DFH_ID
dfh_Revision: Word; | The font revision
dfh_Segment: LongInt; | The segment address when loaded
dfh_Name: array [0..MAXFONTNAME-1] of Char; | the font name (#0 terminated)
dfh_TF: TTextFont; | loaded TextFont structure
end;


TEGlyphEngine

Declaration

Source position: diskfont.pas line 164

type TEGlyphEngine = record

  ege_IBullet: PInterface;

  ege_BulletBase: PLibrary;

  ege_GlyphEngine: PGlyphEngine;

end;


TFCH_ID

TFontContentsHeader.fch_FileID, then TTFontContents

Declaration

Source position: diskfont.pas line 47

const TFCH_ID = $0f02;


TFontContents

Declaration

Source position: diskfont.pas line 27

type TFontContents = record

  fc_FileName: array [0..MAXFONTPATH-1] of Char;

  fc_YSize: Word;

  fc_Style: Byte;

  fc_Flags: Byte;

end;

See also

TFontContentsHeader


TFontContentsHeader

Declaration

Source position: diskfont.pas line 52

type TFontContentsHeader = record
fch_FileID: Word; |
fch_NumEntries: Word; | FCH_ID, TFCH_ID or OFCH_ID
end;

See also

NewFontContents

DisposeFontContents


TGlyphEngine

Declaration

Source position: diskfont.pas line 120

type TGlyphEngine = record

  gle_Library: PLibrary;

  gle_Name: PChar;

end;


TGlyphMap

Declaration

Source position: diskfont.pas line 129

type TGlyphMap = record

  glm_BMModulo: Word;

  glm_BMRows: Word;

  glm_BlackLeft: Word;

  glm_BlackTop: Word;

  glm_BlackWidth: Word;

  glm_BlackHeight: Word;

  glm_XOrigin: LongInt;

  glm_YOrigin: LongInt;

  glm_X0: SmallInt;

  glm_Y0: SmallInt;

  glm_X1: SmallInt;

  glm_Y1: SmallInt;

  glm_Width: LongInt;

  glm_BitMap: PByte;

end;


TGlyphWidthEntry

Declaration

Source position: diskfont.pas line 147

type TGlyphWidthEntry = record

  gwe_Node: TMinNode;

  gwe_Code: Word;

  gwe_Width: LongInt;

end;


TGlyphWidthEntry32

Declaration

Source position: diskfont.pas line 155

type TGlyphWidthEntry32 = record

  gwe32_Node: TNode;

  gwe32_reserved: Word;

  gwe32_Width: LongInt;

  gwe32_Code: LongWord;

end;


TOutlineFont

Declaration

Source position: diskfont.pas line 178

type TOutlineFont = record

  olf_OTagPath: PChar;

  olf_OTagList: PTagItem;

  olf_EngineName: PChar;

  olf_LibraryName: PChar;

  olf_EEngine: PEGlyphEngine;

  olf_Reserved: Pointer;

  olf_UserData: Pointer;

end;


TTAvailFonts

Declaration

Source position: diskfont.pas line 106

type TTAvailFonts = record
taf_Type: Word; | AFF_MEMORY, AFF_DISK or AFF_SCALED
taf_Attr: TTTextAttr; | text attributes for font
end;


TTFontContents

Declaration

Source position: diskfont.pas line 35

type TTFontContents = record
tfc_FileName: array [0..MAXFONTPATH-3] of Char; |
tfc_TagCount: Word; | Including the TAG_DONE tag. if tfc_TagCount is non-zero, tfc_FileName is overlayed with Text Tags
tfc_YSize: Word; |
tfc_Style: Byte; |
tfc_Flags: Byte; |
end;


UCR_ALPHABETIC_PRESENTATION_FORMS

Declaration

Source position: diskfont.pas line 372

const UCR_ALPHABETIC_PRESENTATION_FORMS = 1 shl 30;


UCR_ARABIC

Declaration

Source position: diskfont.pas line 325

const UCR_ARABIC = 1 shl 13;


UCR_ARABIC_PRESENTATIONS_A

Declaration

Source position: diskfont.pas line 373

const UCR_ARABIC_PRESENTATIONS_A = 1 shl 31;


UCR_ARABIC_PRESENTATIONS_B

Declaration

Source position: diskfont.pas line 377

const UCR_ARABIC_PRESENTATIONS_B = 1 shl 3;


UCR_ARMENIAN

Declaration

Source position: diskfont.pas line 323

const UCR_ARMENIAN = 1 shl 10;


UCR_ARROWS

Declaration

Source position: diskfont.pas line 347

const UCR_ARROWS = 1 shl 5;


UCR_BASIC_LATIN

Declaration

Source position: diskfont.pas line 314

const UCR_BASIC_LATIN = 1 shl 0;


UCR_BENGALI

Declaration

Source position: diskfont.pas line 327

const UCR_BENGALI = 1 shl 16;


UCR_BLOCK_ELEMENTS

Declaration

Source position: diskfont.pas line 354

const UCR_BLOCK_ELEMENTS = 1 shl 12;


UCR_BOPOMOFO

Declaration

Source position: diskfont.pas line 361

const UCR_BOPOMOFO = 1 shl 19;


UCR_BOX_DRAWING

Declaration

Source position: diskfont.pas line 353

const UCR_BOX_DRAWING = 1 shl 11;


UCR_BRAILLE

Declaration

Source position: diskfont.pas line 392

const UCR_BRAILLE = 1 shl 18;


UCR_CANADIAN_ABORIGINAL_SYLLABICS

Declaration

Source position: diskfont.pas line 387

const UCR_CANADIAN_ABORIGINAL_SYLLABICS = 1 shl 13;


UCR_CHEROKEE

Declaration

Source position: diskfont.pas line 386

const UCR_CHEROKEE = 1 shl 12;


UCR_CJK_COMPATIBILITY

Declaration

Source position: diskfont.pas line 366

const UCR_CJK_COMPATIBILITY = 1 shl 23;


UCR_CJK_COMPATIBILITY_FORMS

Declaration

Source position: diskfont.pas line 375

const UCR_CJK_COMPATIBILITY_FORMS = 1 shl 1;


UCR_CJK_COMPATIBILITY_IDEOGRAPHS

Declaration

Source position: diskfont.pas line 371

const UCR_CJK_COMPATIBILITY_IDEOGRAPHS = 1 shl 29;


UCR_CJK_MISC

Declaration

Source position: diskfont.pas line 363

const UCR_CJK_MISC = 1 shl 21;


UCR_CJK_SYMBOLS

Declaration

Source position: diskfont.pas line 358

const UCR_CJK_SYMBOLS = 1 shl 16;


UCR_CJK_UNIFIED_IDEOGRAPHS

Declaration

Source position: diskfont.pas line 369

const UCR_CJK_UNIFIED_IDEOGRAPHS = 1 shl 27;


UCR_COMBINING_DIACRITICS

Declaration

Source position: diskfont.pas line 320

const UCR_COMBINING_DIACRITICS = 1 shl 6;


UCR_COMBINING_DIACRITICS_SYMB

Declaration

Source position: diskfont.pas line 344

const UCR_COMBINING_DIACRITICS_SYMB = 1 shl 2;


UCR_COMBINING_HALF_MARKS

Declaration

Source position: diskfont.pas line 374

const UCR_COMBINING_HALF_MARKS = 1 shl 0;


UCR_CONTROL_PICTURES

Declaration

Source position: diskfont.pas line 350

const UCR_CONTROL_PICTURES = 1 shl 8;


UCR_CURRENCY_SYMBOLS

Declaration

Source position: diskfont.pas line 343

const UCR_CURRENCY_SYMBOLS = 1 shl 1;


UCR_CYRILLIC

Declaration

Source position: diskfont.pas line 322

const UCR_CYRILLIC = 1 shl 9;


UCR_DEVANAGARI

Declaration

Source position: diskfont.pas line 326

const UCR_DEVANAGARI = 1 shl 15;


UCR_DINGBATS

Declaration

Source position: diskfont.pas line 357

const UCR_DINGBATS = 1 shl 15;


UCR_ENCLOSED_ALPHANUMERICS

Declaration

Source position: diskfont.pas line 352

const UCR_ENCLOSED_ALPHANUMERICS = 1 shl 10;


UCR_ENCLOSED_CJK_LETTERS_MONTHS

Declaration

Source position: diskfont.pas line 365

const UCR_ENCLOSED_CJK_LETTERS_MONTHS = 1 shl 22;


UCR_ETHIOPIC

Declaration

Source position: diskfont.pas line 385

const UCR_ETHIOPIC = 1 shl 11;


UCR_GENERAL_PUNCTUATION

Declaration

Source position: diskfont.pas line 341

const UCR_GENERAL_PUNCTUATION = 1 shl 31;


UCR_GEOMETRIC_SHAPES

Declaration

Source position: diskfont.pas line 355

const UCR_GEOMETRIC_SHAPES = 1 shl 13;


UCR_GEORGIAN

Declaration

Source position: diskfont.pas line 337

const UCR_GEORGIAN = 1 shl 26;


UCR_GREEK

Declaration

Source position: diskfont.pas line 321

const UCR_GREEK = 1 shl 7;


UCR_GREEK_EXTENDED

Declaration

Source position: diskfont.pas line 340

const UCR_GREEK_EXTENDED = 1 shl 30;


UCR_GUJARATI

Declaration

Source position: diskfont.pas line 329

const UCR_GUJARATI = 1 shl 18;


UCR_GURMUKHI

Declaration

Source position: diskfont.pas line 328

const UCR_GURMUKHI = 1 shl 17;


UCR_HALFWIDTH_FULLWIDTH_FORMS

Declaration

Source position: diskfont.pas line 378

const UCR_HALFWIDTH_FULLWIDTH_FORMS = 1 shl 4;


UCR_HANGUL

Declaration

Source position: diskfont.pas line 367

const UCR_HANGUL = 1 shl 24;


UCR_HANGUL_COMPATIBILITY_JAMO

Declaration

Source position: diskfont.pas line 362

const UCR_HANGUL_COMPATIBILITY_JAMO = 1 shl 20;


UCR_HANGUL_JAMO

Declaration

Source position: diskfont.pas line 338

const UCR_HANGUL_JAMO = 1 shl 28;


UCR_HEBREW

Declaration

Source position: diskfont.pas line 324

const UCR_HEBREW = 1 shl 11;


UCR_HIRAGANA

Declaration

Source position: diskfont.pas line 359

const UCR_HIRAGANA = 1 shl 17;


UCR_IPA_EXTENSIONS

Declaration

Source position: diskfont.pas line 318

const UCR_IPA_EXTENSIONS = 1 shl 4;


UCR_KANBUN

Declaration

Source position: diskfont.pas line 364

const UCR_KANBUN = UCR_CJK_MISC;


UCR_KANNADA

Declaration

Source position: diskfont.pas line 333

const UCR_KANNADA = 1 shl 22;


UCR_KATAKANA

Declaration

Source position: diskfont.pas line 360

const UCR_KATAKANA = 1 shl 18;


UCR_KHMER

Declaration

Source position: diskfont.pas line 390

const UCR_KHMER = 1 shl 16;


UCR_LAO

Declaration

Source position: diskfont.pas line 336

const UCR_LAO = 1 shl 25;


UCR_LATIN1_SUPPLEMENT

Declaration

Source position: diskfont.pas line 315

const UCR_LATIN1_SUPPLEMENT = 1 shl 1;


UCR_LATIN_EXTENDED_A

Declaration

Source position: diskfont.pas line 316

const UCR_LATIN_EXTENDED_A = 1 shl 2;


UCR_LATIN_EXTENDED_ADDITIONAL

Declaration

Source position: diskfont.pas line 339

const UCR_LATIN_EXTENDED_ADDITIONAL = 1 shl 29;


UCR_LATIN_EXTENDED_B

Declaration

Source position: diskfont.pas line 317

const UCR_LATIN_EXTENDED_B = 1 shl 3;


UCR_LETTERLIKE_SYMBOLS

Declaration

Source position: diskfont.pas line 345

const UCR_LETTERLIKE_SYMBOLS = 1 shl 3;


UCR_MALAYALAM

Declaration

Source position: diskfont.pas line 334

const UCR_MALAYALAM = 1 shl 23;


UCR_MATHEMATICAL_OPERATORS

Declaration

Source position: diskfont.pas line 348

const UCR_MATHEMATICAL_OPERATORS = 1 shl 6;


UCR_MISCELLANEOUS_SYMBOLS

Declaration

Source position: diskfont.pas line 356

const UCR_MISCELLANEOUS_SYMBOLS = 1 shl 14;


UCR_MISCELLANEOUS_TECHNICAL

Declaration

Source position: diskfont.pas line 349

const UCR_MISCELLANEOUS_TECHNICAL = 1 shl 7;


UCR_MONGOLIAN

Declaration

Source position: diskfont.pas line 391

const UCR_MONGOLIAN = 1 shl 17;


UCR_MYANMAR

Declaration

Source position: diskfont.pas line 384

const UCR_MYANMAR = 1 shl 10;


UCR_NUMBER_FORMS

Declaration

Source position: diskfont.pas line 346

const UCR_NUMBER_FORMS = 1 shl 4;


UCR_OCR

Declaration

Source position: diskfont.pas line 351

const UCR_OCR = 1 shl 9;


UCR_OGHAM

Declaration

Source position: diskfont.pas line 388

const UCR_OGHAM = 1 shl 14;


UCR_ORIYA

Declaration

Source position: diskfont.pas line 330

const UCR_ORIYA = 1 shl 19;


UCR_PRIVATE_USE

Declaration

Source position: diskfont.pas line 370

const UCR_PRIVATE_USE = 1 shl 28;


UCR_RUNIC

Declaration

Source position: diskfont.pas line 389

const UCR_RUNIC = 1 shl 15;


UCR_SINHALA

Declaration

Source position: diskfont.pas line 383

const UCR_SINHALA = 1 shl 9;


UCR_SMALL_FORM_VARIANTS

Declaration

Source position: diskfont.pas line 376

const UCR_SMALL_FORM_VARIANTS = 1 shl 2;


UCR_SPACING_MODIFIER

Declaration

Source position: diskfont.pas line 319

const UCR_SPACING_MODIFIER = 1 shl 5;


UCR_SPECIALS

Declaration

Source position: diskfont.pas line 379

const UCR_SPECIALS = 1 shl 5;


UCR_SUPERSCRIPTS_SUBSCRIPTS

Declaration

Source position: diskfont.pas line 342

const UCR_SUPERSCRIPTS_SUBSCRIPTS = 1 shl 0;


UCR_SURROGATES

Declaration

Source position: diskfont.pas line 368

const UCR_SURROGATES = 1 shl 25;


UCR_SYRIAC

Declaration

Source position: diskfont.pas line 381

const UCR_SYRIAC = 1 shl 7;


UCR_TAMIL

Declaration

Source position: diskfont.pas line 331

const UCR_TAMIL = 1 shl 20;


UCR_TELUGU

Declaration

Source position: diskfont.pas line 332

const UCR_TELUGU = 1 shl 21;


UCR_THAANA

Declaration

Source position: diskfont.pas line 382

const UCR_THAANA = 1 shl 8;


UCR_THAI

Declaration

Source position: diskfont.pas line 335

const UCR_THAI = 1 shl 24;


UCR_TIBETAN

Declaration

Source position: diskfont.pas line 380

const UCR_TIBETAN = 1 shl 6;


UCR_YI

Declaration

Source position: diskfont.pas line 393

const UCR_YI = 1 shl 19;


AbsExecBase

Declaration

Source position: exec.pas line 1288

const AbsExecBase: PExecBase = Pointer(4);


ACPU_AddressErr

CPU AlertCode for Alert() Illegal address access (ie: odd)

Declaration

Source position: exec.pas line 200

const ACPU_AddressErr = $80000003;


ACPU_AutoVec1

CPU AlertCode for Alert() AutoVector Level 1 interrupt error

Declaration

Source position: exec.pas line 211

const ACPU_AutoVec1 = $80000019;


ACPU_AutoVec2

CPU AlertCode for Alert() AutoVector Level 2 interrupt error

Declaration

Source position: exec.pas line 212

const ACPU_AutoVec2 = $8000001A;


ACPU_AutoVec3

CPU AlertCode for Alert() AutoVector Level 3 interrupt error

Declaration

Source position: exec.pas line 213

const ACPU_AutoVec3 = $8000001B;


ACPU_AutoVec4

CPU AlertCode for Alert() AutoVector Level 4 interrupt error

Declaration

Source position: exec.pas line 214

const ACPU_AutoVec4 = $8000001C;


ACPU_AutoVec5

CPU AlertCode for Alert() AutoVector Level 5 interrupt error

Declaration

Source position: exec.pas line 215

const ACPU_AutoVec5 = $8000001D;


ACPU_AutoVec6

CPU AlertCode for Alert() AutoVector Level 6 interrupt error

Declaration

Source position: exec.pas line 216

const ACPU_AutoVec6 = $8000001E;


ACPU_AutoVec7

CPU AlertCode for Alert() AutoVector Level 7 interrupt error

Declaration

Source position: exec.pas line 217

const ACPU_AutoVec7 = $8000001F;


ACPU_BusErr

CPU AlertCode for Alert() Hardware bus fault/access error

Declaration

Source position: exec.pas line 199

const ACPU_BusErr = $80000002;


ACPU_CHK

CPU AlertCode for Alert() Check instruction error

Declaration

Source position: exec.pas line 203

const ACPU_CHK = $80000006;


ACPU_DivZero

CPU AlertCode for Alert() Divide by zero

Declaration

Source position: exec.pas line 202

const ACPU_DivZero = $80000005;


ACPU_Format

CPU AlertCode for Alert() Stack frame format error

Declaration

Source position: exec.pas line 209

const ACPU_Format = $8000000E;


ACPU_InstErr

CPU AlertCode for Alert() Illegal instruction

Declaration

Source position: exec.pas line 201

const ACPU_InstErr = $80000004;


ACPU_LineA

CPU AlertCode for Alert() Line 1010 Emulator error

Declaration

Source position: exec.pas line 207

const ACPU_LineA = $8000000A;


ACPU_LineF

CPU AlertCode for Alert() Line 1111 Emulator error

Declaration

Source position: exec.pas line 208

const ACPU_LineF = $8000000B;


ACPU_PrivErr

CPU AlertCode for Alert() Privilege violation error

Declaration

Source position: exec.pas line 205

const ACPU_PrivErr = $80000008;


ACPU_Spurious

CPU AlertCode for Alert() Spurious interrupt error

Declaration

Source position: exec.pas line 210

const ACPU_Spurious = $80000018;


ACPU_Trace

CPU AlertCode for Alert() Trace error

Declaration

Source position: exec.pas line 206

const ACPU_Trace = $80000009;


ACPU_TRAPV

CPU AlertCode for Alert() TrapV instruction error

Declaration

Source position: exec.pas line 204

const ACPU_TRAPV = $80000007;


AFB_4XX

Declaration

Source position: exec.pas line 1226

const AFB_4XX = 13;


AFB_603

Declaration

Source position: exec.pas line 1221

const AFB_603 = 8;


AFB_604

Declaration

Source position: exec.pas line 1222

const AFB_604 = 9;


AFB_750

Declaration

Source position: exec.pas line 1223

const AFB_750 = 10;


AFB_7400

Declaration

Source position: exec.pas line 1224

const AFB_7400 = 11;


AFB_68010

Declaration

Source position: exec.pas line 1211

const AFB_68010 = 0;


AFB_68020

Declaration

Source position: exec.pas line 1212

const AFB_68020 = 1;


AFB_68030

Declaration

Source position: exec.pas line 1213

const AFB_68030 = 2;


AFB_68040

Declaration

Source position: exec.pas line 1214

const AFB_68040 = 3;


AFB_68060

Declaration

Source position: exec.pas line 1218

const AFB_68060 = 7;


AFB_68881

Declaration

Source position: exec.pas line 1215

const AFB_68881 = 4;


AFB_68882

Declaration

Source position: exec.pas line 1216

const AFB_68882 = 5;


AFB_ALTIVEC

Declaration

Source position: exec.pas line 1225

const AFB_ALTIVEC = 12;


AFB_FPU40

Declaration

Source position: exec.pas line 1217

const AFB_FPU40 = 6;


AFB_OTHER

Declaration

Source position: exec.pas line 1227

const AFB_OTHER = 14;


AFB_PRIVATE

Declaration

Source position: exec.pas line 1237

const AFB_PRIVATE = 15;


AFF_4XX

Declaration

Source position: exec.pas line 1254

const AFF_4XX = 1 shl 13;


AFF_603

Declaration

Source position: exec.pas line 1249

const AFF_603 = 1 shl 8;


AFF_604

Declaration

Source position: exec.pas line 1250

const AFF_604 = 1 shl 9;


AFF_750

Declaration

Source position: exec.pas line 1251

const AFF_750 = 1 shl 10;


AFF_7400

Declaration

Source position: exec.pas line 1252

const AFF_7400 = 1 shl 11;


AFF_68010

Declaration

Source position: exec.pas line 1240

const AFF_68010 = 1 shl 0;


AFF_68020

Declaration

Source position: exec.pas line 1241

const AFF_68020 = 1 shl 1;


AFF_68030

Declaration

Source position: exec.pas line 1242

const AFF_68030 = 1 shl 2;


AFF_68040

Declaration

Source position: exec.pas line 1243

const AFF_68040 = 1 shl 3;


AFF_68060

Declaration

Source position: exec.pas line 1247

const AFF_68060 = 1 shl 7;


AFF_68881

Declaration

Source position: exec.pas line 1244

const AFF_68881 = 1 shl 4;


AFF_68882

Declaration

Source position: exec.pas line 1245

const AFF_68882 = 1 shl 5;


AFF_ALTIVEC

Declaration

Source position: exec.pas line 1253

const AFF_ALTIVEC = 1 shl 12;


AFF_FPU40

Declaration

Source position: exec.pas line 1246

const AFF_FPU40 = 1 shl 6;


AFF_OTHER

Declaration

Source position: exec.pas line 1255

const AFF_OTHER = 1 shl 14;


AFF_PRIVATE

Declaration

Source position: exec.pas line 1257

const AFF_PRIVATE = 1 shl 15;


AG_BadParm

General AlertCode for Alert()

Declaration

Source position: exec.pas line 245

const AG_BadParm = $00080000;


AG_CloseDev

General AlertCode for Alert() Usually too many closes or a mismatched close

Declaration

Source position: exec.pas line 247

const AG_CloseDev = $000A0000;


AG_CloseLib

General AlertCode for Alert() Usually too many closes or a mismatched close

Declaration

Source position: exec.pas line 246

const AG_CloseLib = $00090000;


AG_IOError

General AlertCode for Alert()

Declaration

Source position: exec.pas line 243

const AG_IOError = $00060000;


AG_MakeLib

General AlertCode for Alert()

Declaration

Source position: exec.pas line 239

const AG_MakeLib = $00020000;


AG_NoMemory

General AlertCode for Alert()

Declaration

Source position: exec.pas line 238

const AG_NoMemory = $00010000;


AG_NoSignal

General AlertCode for Alert()

Declaration

Source position: exec.pas line 244

const AG_NoSignal = $00070000;


AG_Obsolete

Declaration

Source position: exec.pas line 249

const AG_Obsolete = $000C0000;


AG_Opendev

General AlertCode for Alert()

Declaration

Source position: exec.pas line 241

const AG_Opendev = $00040000;


AG_OpenLib

General AlertCode for Alert()

Declaration

Source position: exec.pas line 240

const AG_OpenLib = $00030000;


AG_OpenRes

General AlertCode for Alert()

Declaration

Source position: exec.pas line 242

const AG_OpenRes = $00050000;


AG_ProcCreate

General AlertCode for Alert() Process creation failed

Declaration

Source position: exec.pas line 248

const AG_ProcCreate = $000B0000;


AN_AddSWGadget

Intuition AlertCode for Alert() add SW gadgets, no memory

Declaration

Source position: exec.pas line 348

const AN_AddSWGadget = $8401000A;


AN_AsyncPkt

Dos AlertCode for Alert() Unexpected packet received

Declaration

Source position: exec.pas line 365

const AN_AsyncPkt = $07000004;


AN_AudioDev

Audio AlertCode for Alert()

Declaration

Source position: exec.pas line 396

const AN_AudioDev = $10000000;


AN_BadChkSum

Dos AlertCode for Alert() Invalid checksum

Declaration

Source position: exec.pas line 370

const AN_BadChkSum = $07000009;


AN_BadExpansionFree

Expansion AlertCode for Alert() freeed free region

Declaration

Source position: exec.pas line 387

const AN_BadExpansionFree = $0A000001;


AN_BadFreeAddr

Exec AlertCode for Alert() Memory header not located. Usually an invalid address passed to exec.ExecFreeMem

Declaration

Source position: exec.pas line 310

const AN_BadFreeAddr = $0100000F;


AN_BadGadget

Intuition AlertCode for Alert() Recovery form of AN_GadgetType

Declaration

Source position: exec.pas line 339

const AN_BadGadget = $04000001;


AN_BadHook

Declaration

Source position: exec.pas line 313

const AN_BadHook = $01000012;


AN_BadInitFunc

Dos AlertCode for Alert() Invalid init packet for cli/shell

Declaration

Source position: exec.pas line 374

const AN_BadInitFunc = $0700000D;


AN_BadMemory

Declaration

Source position: exec.pas line 312

const AN_BadMemory = $01000011;


AN_BadMessage

Intuition AlertCode for Alert() Bad Message received by IDCMP

Declaration

Source position: exec.pas line 351

const AN_BadMessage = $8400000D;


AN_BadOverlay

Dos AlertCode for Alert() Bad overlay

Declaration

Source position: exec.pas line 373

const AN_BadOverlay = $0700000C;


AN_BadSegList

Ramlib AlertCode for Alert() no overlays in library seglists

Declaration

Source position: exec.pas line 380

const AN_BadSegList = $08000001;


AN_BadSemaphore

Exec AlertCode for Alert() An attempt was made to use the old message semaphores.

Declaration

Source position: exec.pas line 311

const AN_BadSemaphore = $01000010;


AN_BadState

Intuition AlertCode for Alert() Bad State Return entering Intuition

Declaration

Source position: exec.pas line 350

const AN_BadState = $8400000C;


AN_BaseChkSum

Exec AlertCode for Alert() Execbase checksum (obs.)

Declaration

Source position: exec.pas line 295

const AN_BaseChkSum = $01000002;


AN_BitMap

Dos AlertCode for Alert() Bitmap corrupt

Declaration

Source position: exec.pas line 368

const AN_BitMap = $07000007;


AN_BltBitMap

Graphics AlertCode for Alert() BltBitMap, no memory

Declaration

Source position: exec.pas line 321

const AN_BltBitMap = $8201000A;


AN_BogusExcpt

Exec AlertCode for Alert() illegal 68k exception taken (obs.)

Declaration

Source position: exec.pas line 305

const AN_BogusExcpt = $8100000A;


AN_BootError

Bootstrap AlertCode for Alert() boot code returned an error

Declaration

Source position: exec.pas line 436

const AN_BootError = $30000001;


AN_BootStrap

Bootstrap AlertCode for Alert()

Declaration

Source position: exec.pas line 435

const AN_BootStrap = $30000000;


AN_CIARsrc

CIA AlertCode for Alert()

Declaration

Source position: exec.pas line 424

const AN_CIARsrc = $20000000;


AN_ConsoleDev

Console AlertCode for Alert()

Declaration

Source position: exec.pas line 399

const AN_ConsoleDev = $11000000;


AN_CreatePort

Intuition AlertCode for Alert() create port, no memory

Declaration

Source position: exec.pas line 340

const AN_CreatePort = $84010002;


AN_CybppcDev

Declaration

Source position: exec.pas line 419

const AN_CybppcDev = $16000000;


AN_CybppcNoTerm

Declaration

Source position: exec.pas line 420

const AN_CybppcNoTerm = $16000001;


AN_CybppcNoWide

Declaration

Source position: exec.pas line 421

const AN_CybppcNoWide = $16000002;


AN_DiskBlkSeq

Dos AlertCode for Alert() Disk block sequence error

Declaration

Source position: exec.pas line 367

const AN_DiskBlkSeq = $07000006;


AN_DiskCopy

Diskcopy AlertCode for Alert()

Declaration

Source position: exec.pas line 447

const AN_DiskCopy = $32000000;


AN_DiskError

Dos AlertCode for Alert() Disk Error

Declaration

Source position: exec.pas line 371

const AN_DiskError = $0700000A;


AN_DiskfontLib

DiskFont AlertCode for Alert()

Declaration

Source position: exec.pas line 390

const AN_DiskfontLib = $0B000000;


AN_DiskRsrc

Disk AlertCode for Alert()

Declaration

Source position: exec.pas line 427

const AN_DiskRsrc = $21000000;


AN_DOSLib

Dos AlertCode for Alert()

Declaration

Source position: exec.pas line 361

const AN_DOSLib = $07000000;


AN_DRHasDisk

Disk AlertCode for Alert() get unit: already has disk

Declaration

Source position: exec.pas line 428

const AN_DRHasDisk = $21000001;


AN_DRIntNoAct

Disk AlertCode for Alert() interrupt: no active unit

Declaration

Source position: exec.pas line 429

const AN_DRIntNoAct = $21000002;


AN_endTask

Dos AlertCode for Alert() EndTask didn't end the Task

Declaration

Source position: exec.pas line 363

const AN_endTask = $07000002;


AN_ExcptVect

Exec AlertCode for Alert() 68000 exception vector checksum (obs.)

Declaration

Source position: exec.pas line 294

const AN_ExcptVect = $01000001;


AN_ExecLib

Exec AlertCode for Alert()

Declaration

Source position: exec.pas line 293

const AN_ExecLib = $01000000;


AN_ExpansionLib

Expansion AlertCode for Alert()

Declaration

Source position: exec.pas line 386

const AN_ExpansionLib = $0A000000;


AN_FileReclosed

Dos AlertCode for Alert() A filehandle was closed more than once

Declaration

Source position: exec.pas line 375

const AN_FileReclosed = $0700000E;


AN_FreeTwice

Exec AlertCode for Alert() Freeing memory already freed

Declaration

Source position: exec.pas line 304

const AN_FreeTwice = $01000009;


AN_FreeVec

Dos AlertCode for Alert() Freevec failed

Declaration

Source position: exec.pas line 366

const AN_FreeVec = $07000005;


AN_GadgetType

Intuition AlertCode for Alert() unknown gadget type

Declaration

Source position: exec.pas line 338

const AN_GadgetType = $84000001;


AN_GadTools

Gadtools AlertCode for Alert()

Declaration

Source position: exec.pas line 450

const AN_GadTools = $33000000;


AN_GamePortDev

Gameport AlertCode for Alert()

Declaration

Source position: exec.pas line 403

const AN_GamePortDev = $12000000;


AN_GfxFreeError

Graphics AlertCode for Alert()

Declaration

Source position: exec.pas line 325

const AN_GfxFreeError = $0200000D;


AN_GfxNewError

Graphics AlertCode for Alert()

Declaration

Source position: exec.pas line 324

const AN_GfxNewError = $0200000C;


AN_GfxNoLCM

Graphics AlertCode for Alert() emergency memory not available

Declaration

Source position: exec.pas line 327

const AN_GfxNoLCM = $82011234;


AN_GfxNoMem

Graphics AlertCode for Alert() graphics out of memory

Declaration

Source position: exec.pas line 316

const AN_GfxNoMem = $82010000;


AN_GfxNoMemMspc

Graphics AlertCode for Alert() MonitorSpec alloc, no memory

Declaration

Source position: exec.pas line 317

const AN_GfxNoMemMspc = $82010001;


AN_GraphicsLib

Graphics AlertCode for Alert()

Declaration

Source position: exec.pas line 315

const AN_GraphicsLib = $02000000;


AN_IconLib

Icon AlertCode for Alert()

Declaration

Source position: exec.pas line 383

const AN_IconLib = $09000000;


AN_IFaceChkSum

Declaration

Source position: exec.pas line 297

const AN_IFaceChkSum = $01000004;


AN_InitAPtr

Exec AlertCode for Alert() InitStruct() of an APTR source (obs.)

Declaration

Source position: exec.pas line 301

const AN_InitAPtr = $01000007;


AN_IntrMem

Exec AlertCode for Alert() No memory for interrupt servers

Declaration

Source position: exec.pas line 300

const AN_IntrMem = $81000006;


AN_Intuition

Intuition AlertCode for Alert()

Declaration

Source position: exec.pas line 337

const AN_Intuition = $04000000;


AN_IOAfterClose

Exec AlertCode for Alert() IO attempted on closed IORequest

Declaration

Source position: exec.pas line 308

const AN_IOAfterClose = $0100000D;


AN_IOUsedTwice

Exec AlertCode for Alert() Attempt to reuse active IORequest

Declaration

Source position: exec.pas line 306

const AN_IOUsedTwice = $0100000B;


AN_ISemOrder

Intuition AlertCode for Alert() Intuition obtained a semaphore in bad order

Declaration

Source position: exec.pas line 355

const AN_ISemOrder = $04000011;


AN_ItemAlloc

Intuition AlertCode for Alert() item plane alloc, no memory

Declaration

Source position: exec.pas line 341

const AN_ItemAlloc = $04010003;


AN_ItemBoxTop

Intuition AlertCode for Alert() item box top smaller than RelZero

Declaration

Source position: exec.pas line 344

const AN_ItemBoxTop = $84000006;


AN_KeyboardDev

Keyboard AlertCode for Alert()

Declaration

Source position: exec.pas line 406

const AN_KeyboardDev = $13000000;


AN_KeyFree

Dos AlertCode for Alert() Key already free

Declaration

Source position: exec.pas line 369

const AN_KeyFree = $07000008;


AN_KeyRange

Dos AlertCode for Alert() Key out of range

Declaration

Source position: exec.pas line 372

const AN_KeyRange = $0700000B;


AN_LayersLib

Layers AlertCode for Alert()

Declaration

Source position: exec.pas line 333

const AN_LayersLib = $03000000;


AN_LayersNoMem

Layers AlertCode for Alert() layers out of memory

Declaration

Source position: exec.pas line 334

const AN_LayersNoMem = $83010000;


AN_LibChkSum

Exec AlertCode for Alert() Library checksum failure

Declaration

Source position: exec.pas line 296

const AN_LibChkSum = $01000003;


AN_LongFrame

Graphics AlertCode for Alert() long frame, no memory

Declaration

Source position: exec.pas line 318

const AN_LongFrame = $82010006;


AN_MakeVPort

Graphics AlertCode for Alert() MakeVPort, no memory

Declaration

Source position: exec.pas line 323

const AN_MakeVPort = $82010030;


AN_MathLib

Math AlertCode for Alert()

Declaration

Source position: exec.pas line 358

const AN_MathLib = $05000000;


AN_MemCorrupt

Exec AlertCode for Alert() Corrupt memory list detected in exec.ExecFreeMem

Declaration

Source position: exec.pas line 299

const AN_MemCorrupt = $81000005;


AN_MemoryInsane

Exec AlertCode for Alert() Sanity check on memory list failed during AvailMem(MEMF_LARGEST)

Declaration

Source position: exec.pas line 307

const AN_MemoryInsane = $0100000C;


AN_MiscRsrc

Misc AlertCode for Alert()

Declaration

Source position: exec.pas line 432

const AN_MiscRsrc = $22000000;


AN_NewlibLib

Declaration

Source position: exec.pas line 393

const AN_NewlibLib = $0E000000;


AN_NoBootNode

Declaration

Source position: exec.pas line 376

const AN_NoBootNode = $0700000F;


AN_NoConsole

Intuition AlertCode for Alert() couldn't open the Console Device

Declaration

Source position: exec.pas line 353

const AN_NoConsole = $8400000F;


AN_NoFonts

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 440

const AN_NoFonts = $B1000001;


AN_NoISem

Intuition AlertCode for Alert() Intuition skipped obtaining a semaphore

Declaration

Source position: exec.pas line 354

const AN_NoISem = $04000010;


AN_NoWindow

Console AlertCode for Alert() Console can't open initial window

Declaration

Source position: exec.pas line 400

const AN_NoWindow = $11000001;


AN_ObsoleteFont

Graphics AlertCode for Alert() unsupported font description used

Declaration

Source position: exec.pas line 329

const AN_ObsoleteFont = $02000401;


AN_OpenScreen

Intuition AlertCode for Alert() open screen, no memory

Declaration

Source position: exec.pas line 345

const AN_OpenScreen = $84010007;


AN_OpenScrnRast

Intuition AlertCode for Alert() open screen, raster alloc, no memory

Declaration

Source position: exec.pas line 346

const AN_OpenScrnRast = $84010008;


AN_OpenWindow

Intuition AlertCode for Alert() open window, no memory

Declaration

Source position: exec.pas line 349

const AN_OpenWindow = $8401000B;


AN_PlaneAlloc

Intuition AlertCode for Alert() plane alloc, no memory

Declaration

Source position: exec.pas line 343

const AN_PlaneAlloc = $84010005;


AN_QPktFail

Dos AlertCode for Alert() Qpkt failure

Declaration

Source position: exec.pas line 364

const AN_QPktFail = $07000003;


AN_RAMLib

Ramlib AlertCode for Alert()

Declaration

Source position: exec.pas line 379

const AN_RAMLib = $08000000;


AN_RegionMemory

Graphics AlertCode for Alert() regions, memory not available

Declaration

Source position: exec.pas line 322

const AN_RegionMemory = $8201000B;


AN_SemCorrupt

Exec AlertCode for Alert() A semaphore is in an illegal state at ReleaseSempahore

Declaration

Source position: exec.pas line 302

const AN_SemCorrupt = $01000008;


AN_ShortFrame

Graphics AlertCode for Alert() short frame, no memory

Declaration

Source position: exec.pas line 319

const AN_ShortFrame = $82010007;


AN_StackProbe

Exec AlertCode for Alert() Stack appears to extend out of range

Declaration

Source position: exec.pas line 309

const AN_StackProbe = $0100000E;


AN_StartMem

Dos AlertCode for Alert() no memory at startup

Declaration

Source position: exec.pas line 362

const AN_StartMem = $07010001;


AN_SubAlloc

Intuition AlertCode for Alert() sub alloc, no memory

Declaration

Source position: exec.pas line 342

const AN_SubAlloc = $04010004;


AN_SysScrnType

Intuition AlertCode for Alert() open sys screen, unknown type

Declaration

Source position: exec.pas line 347

const AN_SysScrnType = $84000009;


AN_TDCalibSeek

Trackdisk AlertCode for Alert() calibrate: seek error

Declaration

Source position: exec.pas line 410

const AN_TDCalibSeek = $14000001;


AN_TDDelay

Trackdisk AlertCode for Alert() delay: error on timer wait

Declaration

Source position: exec.pas line 411

const AN_TDDelay = $14000002;


AN_TextTmpRas

Graphics AlertCode for Alert() text, no memory for TmpRas

Declaration

Source position: exec.pas line 320

const AN_TextTmpRas = $02010009;


AN_TimerDev

Timer AlertCode for Alert()

Declaration

Source position: exec.pas line 414

const AN_TimerDev = $15000000;


AN_TMBadReq

Timer AlertCode for Alert() bad request

Declaration

Source position: exec.pas line 415

const AN_TMBadReq = $15000001;


AN_TMBadSupply

Timer AlertCode for Alert() power supply -- no 50/60Hz ticks

Declaration

Source position: exec.pas line 416

const AN_TMBadSupply = $15000002;


AN_TrackDiskDev

Trackdisk AlertCode for Alert()

Declaration

Source position: exec.pas line 409

const AN_TrackDiskDev = $14000000;


AN_Unknown

utility AlertCode for Alert()

Declaration

Source position: exec.pas line 456

const AN_Unknown = $35000000;


AN_UtilityLib

utility AlertCode for Alert()

Declaration

Source position: exec.pas line 453

const AN_UtilityLib = $34000000;


AN_WBBadIOMsg

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 443

const AN_WBBadIOMsg = $31000003;


AN_WBBadStartupMsg1

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 441

const AN_WBBadStartupMsg1 = $31000001;


AN_WBBadStartupMsg2

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 442

const AN_WBBadStartupMsg2 = $31000002;


AN_WBReLayoutToolMenu

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 444

const AN_WBReLayoutToolMenu = $B1010009;


AN_WeirdEcho

Intuition AlertCode for Alert() Weird echo causing incomprehension

Declaration

Source position: exec.pas line 352

const AN_WeirdEcho = $8400000E;


AN_Workbench

Workbench AlertCode for Alert()

Declaration

Source position: exec.pas line 439

const AN_Workbench = $31000000;


ANMERROR_DUPLICATENAME

Declaration

Source position: exec.pas line 1604

const ANMERROR_DUPLICATENAME = 2;


ANMERROR_NOERROR

Declaration

Source position: exec.pas line 1602

const ANMERROR_NOERROR = 0;


ANMERROR_NOMEMORY

Declaration

Source position: exec.pas line 1603

const ANMERROR_NOMEMORY = 1;


ANMERROR_PARAMETER

Declaration

Source position: exec.pas line 1605

const ANMERROR_PARAMETER = 3;


ANMT_CheckSum

Declaration

Source position: exec.pas line 1597

const ANMT_CheckSum = TAG_USER + 1;


ANMT_Error

Declaration

Source position: exec.pas line 1598

const ANMT_Error = TAG_USER + 2;


AO_AudioDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 266

const AO_AudioDev = $00008010;


AO_BootStrap

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 277

const AO_BootStrap = $00008030;


AO_CIARsrc

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 273

const AO_CIARsrc = $00008020;


AO_ConsoleDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 267

const AO_ConsoleDev = $00008011;


AO_DiskCopy

AlertCode for Alert()

Declaration

Source position: exec.pas line 279

const AO_DiskCopy = $00008032;


AO_DiskfontLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 261

const AO_DiskfontLib = $0000800B;


AO_DiskRsrc

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 274

const AO_DiskRsrc = $00008021;


AO_DOSLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 257

const AO_DOSLib = $00008007;


AO_ExecLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 252

const AO_ExecLib = $00008001;


AO_ExpansionLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 260

const AO_ExpansionLib = $0000800A;


AO_GadTools

AlertCode for Alert()

Declaration

Source position: exec.pas line 280

const AO_GadTools = $00008033;


AO_GamePortDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 268

const AO_GamePortDev = $00008012;


AO_GraphicsLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 253

const AO_GraphicsLib = $00008002;


AO_IconLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 259

const AO_IconLib = $00008009;


AO_Intuition

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 255

const AO_Intuition = $00008004;


AO_KeyboardDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 269

const AO_KeyboardDev = $00008013;


AO_KeyMapLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 263

const AO_KeyMapLib = $0000800D;


AO_LayersLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 254

const AO_LayersLib = $00008003;


AO_MathLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 256

const AO_MathLib = $00008005;


AO_MiscRsrc

Resource AlertCode for Alert()

Declaration

Source position: exec.pas line 275

const AO_MiscRsrc = $00008022;


AO_NewlibLib

Declaration

Source position: exec.pas line 264

const AO_NewlibLib = $0000800E;


AO_RAMLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 258

const AO_RAMLib = $00008008;


AO_TimerDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 271

const AO_TimerDev = $00008015;


AO_TrackDiskDev

Device AlertCode for Alert()

Declaration

Source position: exec.pas line 270

const AO_TrackDiskDev = $00008014;


AO_Unknown

AlertCode for Alert()

Declaration

Source position: exec.pas line 281

const AO_Unknown = $00008035;


AO_UtilityLib

Library AlertCode for Alert()

Declaration

Source position: exec.pas line 262

const AO_UtilityLib = $0000800C;


AO_Workbench

AlertCode for Alert()

Declaration

Source position: exec.pas line 278

const AO_Workbench = $00008031;


APTR

A type free pointer.

Declaration

Source position: exec.pas line 31

type APTR = Pointer;


ASO_MemoryOvr

Declaration

Source position: exec.pas line 1474

const ASO_MemoryOvr = TAG_USER + 2;


ASO_NoTrack

Declaration

Source position: exec.pas line 1473

const ASO_NoTrack = TAG_USER + 1;


ASODMAE_NumEntries

Declaration

Source position: exec.pas line 1495

const ASODMAE_NumEntries = TAG_USER + 11;


ASODMAE_Size

Declaration

Source position: exec.pas line 1494

const ASODMAE_Size = TAG_USER + 10;


ASOEXTMEM_AllocationPolicy

Declaration

Source position: exec.pas line 1548

const ASOEXTMEM_AllocationPolicy = TAG_USER + 11;


ASOEXTMEM_Size

Declaration

Source position: exec.pas line 1547

const ASOEXTMEM_Size = TAG_USER + 10;


ASOF_NOTRACK

Declaration

Source position: exec.pas line 605

const ASOF_NOTRACK = 1 shl 1;


ASOHOOK_Data

Declaration

Source position: exec.pas line 1483

const ASOHOOK_Data = TAG_USER + 13;


ASOHOOK_Entry

Declaration

Source position: exec.pas line 1481

const ASOHOOK_Entry = TAG_USER + 11;


ASOHOOK_Size

Declaration

Source position: exec.pas line 1480

const ASOHOOK_Size = TAG_USER + 10;


ASOHOOK_Subentry

Declaration

Source position: exec.pas line 1482

const ASOHOOK_Subentry = TAG_USER + 12;


ASOINTR_Code

Declaration

Source position: exec.pas line 1486

const ASOINTR_Code = TAG_USER + 11;


ASOINTR_Data

Declaration

Source position: exec.pas line 1487

const ASOINTR_Data = TAG_USER + 12;


ASOINTR_Size

Declaration

Source position: exec.pas line 1485

const ASOINTR_Size = TAG_USER + 10;


ASOINTR_SoftInt

Declaration

Source position: exec.pas line 1488

const ASOINTR_SoftInt = TAG_USER + 13;


ASOIOR_Duplicate

Declaration

Source position: exec.pas line 1478

const ASOIOR_Duplicate = TAG_USER + 12;


ASOIOR_ReplyPort

Declaration

Source position: exec.pas line 1477

const ASOIOR_ReplyPort = TAG_USER + 11;


ASOIOR_Size

Declaration

Source position: exec.pas line 1476

const ASOIOR_Size = TAG_USER + 10;


ASOITEM_BatchSize

Declaration

Source position: exec.pas line 1537

const ASOITEM_BatchSize = TAG_USER + 12;


ASOITEM_Constructor

Declaration

Source position: exec.pas line 1541

const ASOITEM_Constructor = TAG_USER + 16;


ASOITEM_Destructor

Declaration

Source position: exec.pas line 1542

const ASOITEM_Destructor = TAG_USER + 17;


ASOITEM_GCParameter

Declaration

Source position: exec.pas line 1540

const ASOITEM_GCParameter = TAG_USER + 15;


ASOITEM_GCPolicy

Declaration

Source position: exec.pas line 1539

const ASOITEM_GCPolicy = TAG_USER + 14;


ASOITEM_ItemSize

Declaration

Source position: exec.pas line 1536

const ASOITEM_ItemSize = TAG_USER + 11;


ASOITEM_MaxSize

Declaration

Source position: exec.pas line 1538

const ASOITEM_MaxSize = TAG_USER + 13;


ASOITEM_MFlags

Declaration

Source position: exec.pas line 1535

const ASOITEM_MFlags = TAG_USER + 10;


ASOITEM_Protected

Declaration

Source position: exec.pas line 1543

const ASOITEM_Protected = TAG_USER + 18;


ASOKMEM_Alignment

Declaration

Source position: exec.pas line 1565

const ASOKMEM_Alignment = TAG_USER + 13;


ASOKMEM_Colored

Declaration

Source position: exec.pas line 1568

const ASOKMEM_Colored = TAG_USER + 16;


ASOKMEM_Compact

Declaration

Source position: exec.pas line 1569

const ASOKMEM_Compact = TAG_USER + 17;


ASOKMEM_Constructor

Declaration

Source position: exec.pas line 1566

const ASOKMEM_Constructor = TAG_USER + 14;


ASOKMEM_Destructor

Declaration

Source position: exec.pas line 1567

const ASOKMEM_Destructor = TAG_USER + 15;


ASOKMEM_Name

Declaration

Source position: exec.pas line 1562

const ASOKMEM_Name = TAG_USER + 10;


ASOKMEM_Size

Declaration

Source position: exec.pas line 1564

const ASOKMEM_Size = TAG_USER + 12;


ASOKMEM_Type

Declaration

Source position: exec.pas line 1563

const ASOKMEM_Type = TAG_USER + 11;


ASOLIST_Min

Declaration

Source position: exec.pas line 1492

const ASOLIST_Min = TAG_USER + 12;


ASOLIST_Size

Declaration

Source position: exec.pas line 1490

const ASOLIST_Size = TAG_USER + 10;


ASOLIST_Type

Declaration

Source position: exec.pas line 1491

const ASOLIST_Type = TAG_USER + 11;


ASOMSG_Length

Declaration

Source position: exec.pas line 1515

const ASOMSG_Length = TAG_USER + 12;


ASOMSG_Name

Declaration

Source position: exec.pas line 1516

const ASOMSG_Name = TAG_USER + 13;


ASOMSG_ReplyPort

Declaration

Source position: exec.pas line 1514

const ASOMSG_ReplyPort = TAG_USER + 11;


ASOMSG_Size

Declaration

Source position: exec.pas line 1513

const ASOMSG_Size = TAG_USER + 10;


ASOMUTEX_Recursive

Declaration

Source position: exec.pas line 1545

const ASOMUTEX_Recursive = TAG_USER + 10;


ASONODE_Min

Declaration

Source position: exec.pas line 1498

const ASONODE_Min = TAG_USER + 11;


ASONODE_Name

Declaration

Source position: exec.pas line 1501

const ASONODE_Name = TAG_USER + 14;


ASONODE_Pri

Declaration

Source position: exec.pas line 1500

const ASONODE_Pri = TAG_USER + 13;


ASONODE_Size

Declaration

Source position: exec.pas line 1497

const ASONODE_Size = TAG_USER + 10;


ASONODE_Type

Declaration

Source position: exec.pas line 1499

const ASONODE_Type = TAG_USER + 12;


ASOPOOL_CopyName

Declaration

Source position: exec.pas line 1532

const ASOPOOL_CopyName = TAG_USER + 15;


ASOPOOL_LockMem

Declaration

Source position: exec.pas line 1533

const ASOPOOL_LockMem = TAG_USER + 16;


ASOPOOL_MFlags

Declaration

Source position: exec.pas line 1527

const ASOPOOL_MFlags = TAG_USER + 10;


ASOPOOL_Name

Declaration

Source position: exec.pas line 1531

const ASOPOOL_Name = TAG_USER + 14;


ASOPOOL_Protected

Declaration

Source position: exec.pas line 1530

const ASOPOOL_Protected = TAG_USER + 13;


ASOPOOL_Puddle

Declaration

Source position: exec.pas line 1528

const ASOPOOL_Puddle = TAG_USER + 11;


ASOPOOL_Threshold

Declaration

Source position: exec.pas line 1529

const ASOPOOL_Threshold = TAG_USER + 12;


ASOPORT_Action

Declaration

Source position: exec.pas line 1505

const ASOPORT_Action = TAG_USER + 12;


ASOPORT_AllocSig

Declaration

Source position: exec.pas line 1504

const ASOPORT_AllocSig = TAG_USER + 11;


ASOPORT_CopyName

Declaration

Source position: exec.pas line 1511

const ASOPORT_CopyName = TAG_USER + 18;


ASOPORT_Name

Declaration

Source position: exec.pas line 1507

const ASOPORT_Name = TAG_USER + 14;


ASOPORT_Pri

Declaration

Source position: exec.pas line 1506

const ASOPORT_Pri = TAG_USER + 13;


ASOPORT_Public

Declaration

Source position: exec.pas line 1510

const ASOPORT_Public = TAG_USER + 17;


ASOPORT_Signal

Declaration

Source position: exec.pas line 1508

const ASOPORT_Signal = TAG_USER + 15;


ASOPORT_Size

Declaration

Source position: exec.pas line 1503

const ASOPORT_Size = TAG_USER + 10;


ASOPORT_Target

Declaration

Source position: exec.pas line 1509

const ASOPORT_Target = TAG_USER + 16;


ASORMAP_Base

Declaration

Source position: exec.pas line 1577

const ASORMAP_Base = TAG_USER + 10;


ASORMAP_CacheMax

Declaration

Source position: exec.pas line 1581

const ASORMAP_CacheMax = TAG_USER + 13;


ASORMAP_Quantum

Declaration

Source position: exec.pas line 1579

const ASORMAP_Quantum = TAG_USER + 12;


ASORMAP_Size

Declaration

Source position: exec.pas line 1578

const ASORMAP_Size = TAG_USER + 11;


ASOSEM_CopyName

Declaration

Source position: exec.pas line 1522

const ASOSEM_CopyName = TAG_USER + 14;


ASOSEM_Name

Declaration

Source position: exec.pas line 1519

const ASOSEM_Name = TAG_USER + 11;


ASOSEM_Pri

Declaration

Source position: exec.pas line 1520

const ASOSEM_Pri = TAG_USER + 12;


ASOSEM_Public

Declaration

Source position: exec.pas line 1521

const ASOSEM_Public = TAG_USER + 13;


ASOSEM_Size

Declaration

Source position: exec.pas line 1518

const ASOSEM_Size = TAG_USER + 10;


ASOT_DMAENTRY

Declaration

Source position: exec.pas line 1676

const ASOT_DMAENTRY = 4;


ASOT_EXTMEM

Declaration

Source position: exec.pas line 1686

const ASOT_EXTMEM = 14;


ASOT_HOOK

Declaration

Source position: exec.pas line 1673

const ASOT_HOOK = 1;


ASOT_INTERRUPT

Declaration

Source position: exec.pas line 1674

const ASOT_INTERRUPT = 2;


ASOT_IOREQUEST

Declaration

Source position: exec.pas line 1672

const ASOT_IOREQUEST = 0;


ASOT_ITEMPOOL

Declaration

Source position: exec.pas line 1683

const ASOT_ITEMPOOL = 11;


ASOT_LIST

Declaration

Source position: exec.pas line 1675

const ASOT_LIST = 3;


ASOT_MEMPOOL

Declaration

Source position: exec.pas line 1682

const ASOT_MEMPOOL = 10;


ASOT_MESSAGE

Declaration

Source position: exec.pas line 1679

const ASOT_MESSAGE = 7;


ASOT_MUTEX

Declaration

Source position: exec.pas line 1685

const ASOT_MUTEX = 13;


ASOT_NODE

Declaration

Source position: exec.pas line 1677

const ASOT_NODE = 5;


ASOT_PORT

Declaration

Source position: exec.pas line 1678

const ASOT_PORT = 6;


ASOT_RMAP

Declaration

Source position: exec.pas line 1684

const ASOT_RMAP = 12;


ASOT_SEMAPHORE

Declaration

Source position: exec.pas line 1680

const ASOT_SEMAPHORE = 8;


ASOT_TAGLIST

Declaration

Source position: exec.pas line 1681

const ASOT_TAGLIST = 9;


ASOTAGS_NumEntries

Declaration

Source position: exec.pas line 1525

const ASOTAGS_NumEntries = TAG_USER + 11;


ASOTAGS_Size

Declaration

Source position: exec.pas line 1524

const ASOTAGS_Size = TAG_USER + 10;


AT_Child

Declaration

Source position: exec.pas line 1720

const AT_Child = TAG_USER + 9;


AT_Deadend

CPU AlertCode for Alert() Alert type. Error can not be recovered, Computer must be restarted.

Declaration

Source position: exec.pas line 234

const AT_Deadend = $80000000;


AT_Param1

Declaration

Source position: exec.pas line 1712

const AT_Param1 = TAG_USER + 1;


AT_Param2

Declaration

Source position: exec.pas line 1713

const AT_Param2 = TAG_USER + 2;


AT_Param3

Declaration

Source position: exec.pas line 1714

const AT_Param3 = TAG_USER + 3;


AT_Param4

Declaration

Source position: exec.pas line 1715

const AT_Param4 = TAG_USER + 4;


AT_Param5

Declaration

Source position: exec.pas line 1716

const AT_Param5 = TAG_USER + 5;


AT_Param6

Declaration

Source position: exec.pas line 1717

const AT_Param6 = TAG_USER + 6;


AT_Param7

Declaration

Source position: exec.pas line 1718

const AT_Param7 = TAG_USER + 7;


AT_Param8

Declaration

Source position: exec.pas line 1719

const AT_Param8 = TAG_USER + 8;


AT_Recovery

CPU AlertCode for Alert() Alert type. Error can be recovered, system can continue running.

Declaration

Source position: exec.pas line 235

const AT_Recovery = $00000000;


AVLKEYCOMP

Declaration

Source position: exec.pas line 1304

type AVLKEYCOMP = Pointer;


AVLNODECOMP

Declaration

Source position: exec.pas line 1301

type AVLNODECOMP = Pointer;


AVT_Alignment

Declaration

Source position: exec.pas line 1588

const AVT_Alignment = TAG_USER + 4;


AVT_Clear

Declaration

Source position: exec.pas line 1590

const AVT_Clear = TAG_USER + 6;


AVT_ClearValue

Declaration

Source position: exec.pas line 1592

const AVT_ClearValue = TAG_USER + 6;


AVT_ClearWithValue

Declaration

Source position: exec.pas line 1591

const AVT_ClearWithValue = TAG_USER + 6;


AVT_Contiguous

Declaration

Source position: exec.pas line 1586

const AVT_Contiguous = TAG_USER + 2;


AVT_Lock

Declaration

Source position: exec.pas line 1587

const AVT_Lock = TAG_USER + 3;


AVT_NoExpunge

Declaration

Source position: exec.pas line 1594

const AVT_NoExpunge = TAG_USER + 8;


AVT_PhysicalAlignment

Declaration

Source position: exec.pas line 1589

const AVT_PhysicalAlignment = TAG_USER + 5;


AVT_Type

Declaration

Source position: exec.pas line 1585

const AVT_Type = TAG_USER + 1;


AVT_Wait

Declaration

Source position: exec.pas line 1593

const AVT_Wait = TAG_USER + 7;


BOOL

Boolean representation

Declaration

Source position: exec.pas line 34

type BOOL = SmallInt;


BPTR

A type free pointer. in ABIv0 its just a Pointer.

Declaration

Source position: exec.pas line 32

type BPTR = LongInt;


BSTR

Pointer to a string, in ABIv0 just like PChar.

Declaration

Source position: exec.pas line 33

type BSTR = LongInt;


CACRF_ClearD

Declaration

Source position: exec.pas line 1267

const CACRF_ClearD = 1 shl 11;


CACRF_ClearI

Declaration

Source position: exec.pas line 1263

const CACRF_ClearI = 1 shl 3;


CACRF_CopyBack

Declaration

Source position: exec.pas line 1277

const CACRF_CopyBack = 1 shl 31;


CACRF_DBE

Declaration

Source position: exec.pas line 1268

const CACRF_DBE = 1 shl 12;


CACRF_EnableD

Declaration

Source position: exec.pas line 1265

const CACRF_EnableD = 1 shl 8;


CACRF_EnableE

Declaration

Source position: exec.pas line 1271

const CACRF_EnableE = 1 shl 30;


CACRF_EnableI

Declaration

Source position: exec.pas line 1261

const CACRF_EnableI = 1 shl 0;


CACRF_FreezeD

Declaration

Source position: exec.pas line 1266

const CACRF_FreezeD = 1 shl 9;


CACRF_FreezeI

Declaration

Source position: exec.pas line 1262

const CACRF_FreezeI = 1 shl 1;


CACRF_IBE

Declaration

Source position: exec.pas line 1264

const CACRF_IBE = 1 shl 4;


CACRF_InvalidateD

Declaration

Source position: exec.pas line 1270

const CACRF_InvalidateD = 1 shl 15;


CACRF_WriteAllocate

Declaration

Source position: exec.pas line 1269

const CACRF_WriteAllocate = 1 shl 13;


CLT_DataSize

Declaration

Source position: exec.pas line 1695

const CLT_DataSize = TAG_USER + 10;


CLT_InitData

Declaration

Source position: exec.pas line 1691

const CLT_InitData = TAG_USER + 2;


CLT_InitFunc

Declaration

Source position: exec.pas line 1692

const CLT_InitFunc = TAG_USER + 3;


CLT_Interfaces

Declaration

Source position: exec.pas line 1694

const CLT_Interfaces = TAG_USER + 9;


CLT_Legacy

Declaration

Source position: exec.pas line 1696

const CLT_Legacy = TAG_USER + 11;


CLT_NoLegacyIFace

Declaration

Source position: exec.pas line 1697

const CLT_NoLegacyIFace = TAG_USER + 12;


CLT_Seglist

Declaration

Source position: exec.pas line 1693

const CLT_Seglist = TAG_USER + 8;


CLT_Vector68K

Declaration

Source position: exec.pas line 1690

const CLT_Vector68K = TAG_USER + 1;


CMD_CLEAR

Declaration

Source position: exec.pas line 1015

const CMD_CLEAR = 5;


CMD_FLUSH

Declaration

Source position: exec.pas line 1018

const CMD_FLUSH = 8;


CMD_INVALID

Declaration

Source position: exec.pas line 1010

const CMD_INVALID = 0;


CMD_NONSTD

Declaration

Source position: exec.pas line 1020

const CMD_NONSTD = 9;


CMD_READ

Declaration

Source position: exec.pas line 1012

const CMD_READ = 2;


CMD_RESET

Declaration

Source position: exec.pas line 1011

const CMD_RESET = 1;


CMD_START

Declaration

Source position: exec.pas line 1017

const CMD_START = 7;


CMD_STOP

Declaration

Source position: exec.pas line 1016

const CMD_STOP = 6;


CMD_UPDATE

Declaration

Source position: exec.pas line 1014

const CMD_UPDATE = 4;


CMD_WRITE

Declaration

Source position: exec.pas line 1013

const CMD_WRITE = 3;


CPUFAMILY_4XX

Declaration

Source position: exec.pas line 1632

const CPUFAMILY_4XX = 4;


CPUFAMILY_7X0

Declaration

Source position: exec.pas line 1630

const CPUFAMILY_7X0 = 2;


CPUFAMILY_60X

Declaration

Source position: exec.pas line 1629

const CPUFAMILY_60X = 1;


CPUFAMILY_74XX

Declaration

Source position: exec.pas line 1631

const CPUFAMILY_74XX = 3;


CPUFAMILY_E300

Declaration

Source position: exec.pas line 1634

const CPUFAMILY_E300 = 6;


CPUFAMILY_E5500

Declaration

Source position: exec.pas line 1635

const CPUFAMILY_E5500 = 7;


CPUFAMILY_PA6T

Declaration

Source position: exec.pas line 1633

const CPUFAMILY_PA6T = 5;


CPUFAMILY_UNKNOWN

Declaration

Source position: exec.pas line 1628

const CPUFAMILY_UNKNOWN = 0;


CPUTYPE_P50XX

Declaration

Source position: exec.pas line 1660

const CPUTYPE_P50XX = 21;


CPUTYPE_PA6T_1682M

Declaration

Source position: exec.pas line 1657

const CPUTYPE_PA6T_1682M = 18;


CPUTYPE_PPC74XX_APOLLO

Declaration

Source position: exec.pas line 1647

const CPUTYPE_PPC74XX_APOLLO = 8;


CPUTYPE_PPC74XX_VGER

Declaration

Source position: exec.pas line 1646

const CPUTYPE_PPC74XX_VGER = 7;


CPUTYPE_PPC405EP

Declaration

Source position: exec.pas line 1649

const CPUTYPE_PPC405EP = 10;


CPUTYPE_PPC405GP

Declaration

Source position: exec.pas line 1650

const CPUTYPE_PPC405GP = 11;


CPUTYPE_PPC405GPR

Declaration

Source position: exec.pas line 1651

const CPUTYPE_PPC405GPR = 12;


CPUTYPE_PPC405LP

Declaration

Source position: exec.pas line 1648

const CPUTYPE_PPC405LP = 9;


CPUTYPE_PPC440EP

Declaration

Source position: exec.pas line 1652

const CPUTYPE_PPC440EP = 13;


CPUTYPE_PPC440GP

Declaration

Source position: exec.pas line 1653

const CPUTYPE_PPC440GP = 14;


CPUTYPE_PPC440GX

Declaration

Source position: exec.pas line 1654

const CPUTYPE_PPC440GX = 15;


CPUTYPE_PPC440SP

Declaration

Source position: exec.pas line 1656

const CPUTYPE_PPC440SP = 17;


CPUTYPE_PPC440SX

Declaration

Source position: exec.pas line 1655

const CPUTYPE_PPC440SX = 16;


CPUTYPE_PPC460EX

Declaration

Source position: exec.pas line 1658

const CPUTYPE_PPC460EX = 19;


CPUTYPE_PPC603E

Declaration

Source position: exec.pas line 1640

const CPUTYPE_PPC603E = 1;


CPUTYPE_PPC604E

Declaration

Source position: exec.pas line 1641

const CPUTYPE_PPC604E = 2;


CPUTYPE_PPC750CXE

Declaration

Source position: exec.pas line 1642

const CPUTYPE_PPC750CXE = 3;


CPUTYPE_PPC750FX

Declaration

Source position: exec.pas line 1643

const CPUTYPE_PPC750FX = 4;


CPUTYPE_PPC750GX

Declaration

Source position: exec.pas line 1644

const CPUTYPE_PPC750GX = 5;


CPUTYPE_PPC5121E

Declaration

Source position: exec.pas line 1659

const CPUTYPE_PPC5121E = 20;


CPUTYPE_PPC7410

Declaration

Source position: exec.pas line 1645

const CPUTYPE_PPC7410 = 6;


CPUTYPE_UNKNOWN

Declaration

Source position: exec.pas line 1639

const CPUTYPE_UNKNOWN = 0;


CT_LockStack

Declaration

Source position: exec.pas line 1722

const CT_LockStack = TAG_USER + 20;


DBHMT_ADDTASK

Declaration

Source position: exec.pas line 1706

const DBHMT_ADDTASK = 5;


DBHMT_CLOSELIB

Declaration

Source position: exec.pas line 1705

const DBHMT_CLOSELIB = 4;


DBHMT_EXCEPTION

Declaration

Source position: exec.pas line 1702

const DBHMT_EXCEPTION = 1;


DBHMT_OPENLIB

Declaration

Source position: exec.pas line 1704

const DBHMT_OPENLIB = 3;


DBHMT_REMTASK

Declaration

Source position: exec.pas line 1703

const DBHMT_REMTASK = 2;


DBHMT_SHAREDOBJECTCLOSE

Declaration

Source position: exec.pas line 1708

const DBHMT_SHAREDOBJECTCLOSE = 7;


DBHMT_SHAREDOBJECTOPEN

Declaration

Source position: exec.pas line 1707

const DBHMT_SHAREDOBJECTOPEN = 6;


DEBUG_SYMBOL_68K_MODULE

Declaration

Source position: exec.pas line 1347

const DEBUG_SYMBOL_68K_MODULE = 1;


DEBUG_SYMBOL_KERNEL_MODULE

Declaration

Source position: exec.pas line 1349

const DEBUG_SYMBOL_KERNEL_MODULE = 3;


DEBUG_SYMBOL_MODULE

Declaration

Source position: exec.pas line 1350

const DEBUG_SYMBOL_MODULE = 4;


DEBUG_SYMBOL_MODULE_STABS

Declaration

Source position: exec.pas line 1351

const DEBUG_SYMBOL_MODULE_STABS = 5;


DEBUG_SYMBOL_NATIVE_MODULE

Declaration

Source position: exec.pas line 1348

const DEBUG_SYMBOL_NATIVE_MODULE = 2;


DEV_ABORTIO

Declaration

Source position: exec.pas line 1002

const DEV_ABORTIO = - 36;


DEV_beginIO

Declaration

Source position: exec.pas line 1001

const DEV_beginIO = - 30;


DMA_Continue

Declaration

Source position: exec.pas line 1280

const DMA_Continue = 1 shl 1;


DMA_NoModify

Declaration

Source position: exec.pas line 1282

const DMA_NoModify = 1 shl 2;


DMA_ReadFromRAM

Declaration

Source position: exec.pas line 1284

const DMA_ReadFromRAM = 1 shl 3;


DMAF_Continue

Declaration

Source position: exec.pas line 1281

const DMAF_Continue = DMA_Continue;


DMAF_NoModify

Declaration

Source position: exec.pas line 1283

const DMAF_NoModify = DMA_NoModify;


DMAF_ReadFromRAM

Declaration

Source position: exec.pas line 1285

const DMAF_ReadFromRAM = DMA_ReadFromRAM;


ECF_FPU

Declaration

Source position: exec.pas line 691

const ECF_FPU = 1 shl 1;


ECF_FULL_FPU

Declaration

Source position: exec.pas line 692

const ECF_FULL_FPU = 1 shl 2;


ECF_FULL_GPRS

Declaration

Source position: exec.pas line 688

const ECF_FULL_GPRS = 1 shl 0;


ECF_VECTOR

Declaration

Source position: exec.pas line 693

const ECF_VECTOR = 1 shl 3;


ECF_VRSAVE

Declaration

Source position: exec.pas line 694

const ECF_VRSAVE = 1 shl 4;


EFPF_FP0

Declaration

Source position: exec.pas line 1449

const EFPF_FP0 = 1;


EFPF_FP1

Declaration

Source position: exec.pas line 1450

const EFPF_FP1 = 1 shl 1;


EFPF_FP2

Declaration

Source position: exec.pas line 1451

const EFPF_FP2 = 1 shl 2;


EFPF_FP3

Declaration

Source position: exec.pas line 1452

const EFPF_FP3 = 1 shl 3;


EFPF_FP4

Declaration

Source position: exec.pas line 1453

const EFPF_FP4 = 1 shl 4;


EFPF_FP5

Declaration

Source position: exec.pas line 1454

const EFPF_FP5 = 1 shl 5;


EFPF_FP6

Declaration

Source position: exec.pas line 1455

const EFPF_FP6 = 1 shl 6;


EFPF_FP7

Declaration

Source position: exec.pas line 1456

const EFPF_FP7 = 1 shl 7;


ET_FPRegisterMask

Declaration

Source position: exec.pas line 1435

const ET_FPRegisterMask = TAG_USER + 19;


ET_FPRegisters

Declaration

Source position: exec.pas line 1434

const ET_FPRegisters = TAG_USER + 18;


ET_NoJIT

Declaration

Source position: exec.pas line 1432

const ET_NoJIT = TAG_USER + 17;


ET_Offset

Declaration

Source position: exec.pas line 1439

const ET_Offset = TAG_USER + 21;


ET_RegisterA0

Declaration

Source position: exec.pas line 1423

const ET_RegisterA0 = TAG_USER + 9;


ET_RegisterA1

Declaration

Source position: exec.pas line 1424

const ET_RegisterA1 = TAG_USER + 10;


ET_RegisterA2

Declaration

Source position: exec.pas line 1425

const ET_RegisterA2 = TAG_USER + 11;


ET_RegisterA3

Declaration

Source position: exec.pas line 1426

const ET_RegisterA3 = TAG_USER + 12;


ET_RegisterA4

Declaration

Source position: exec.pas line 1427

const ET_RegisterA4 = TAG_USER + 13;


ET_RegisterA5

Declaration

Source position: exec.pas line 1428

const ET_RegisterA5 = TAG_USER + 14;


ET_RegisterA6

Declaration

Source position: exec.pas line 1429

const ET_RegisterA6 = TAG_USER + 15;


ET_RegisterA7

Declaration

Source position: exec.pas line 1430

const ET_RegisterA7 = TAG_USER + 16;


ET_RegisterD0

Declaration

Source position: exec.pas line 1414

const ET_RegisterD0 = TAG_USER + 1;


ET_RegisterD1

Declaration

Source position: exec.pas line 1415

const ET_RegisterD1 = TAG_USER + 2;


ET_RegisterD2

Declaration

Source position: exec.pas line 1416

const ET_RegisterD2 = TAG_USER + 3;


ET_RegisterD3

Declaration

Source position: exec.pas line 1417

const ET_RegisterD3 = TAG_USER + 4;


ET_RegisterD4

Declaration

Source position: exec.pas line 1418

const ET_RegisterD4 = TAG_USER + 5;


ET_RegisterD5

Declaration

Source position: exec.pas line 1419

const ET_RegisterD5 = TAG_USER + 6;


ET_RegisterD6

Declaration

Source position: exec.pas line 1420

const ET_RegisterD6 = TAG_USER + 7;


ET_RegisterD7

Declaration

Source position: exec.pas line 1421

const ET_RegisterD7 = TAG_USER + 8;


ET_SaveParamRegs

Declaration

Source position: exec.pas line 1444

const ET_SaveParamRegs = TAG_USER + 24;


ET_SaveRegs

Declaration

Source position: exec.pas line 1443

const ET_SaveRegs = TAG_USER + 23;


ET_StackPtr

Declaration

Source position: exec.pas line 1441

const ET_StackPtr = TAG_USER + 22;


ET_SuperState

Declaration

Source position: exec.pas line 1437

const ET_SuperState = TAG_USER + 20;


ExecBase

Declaration

Source position: exec.pas line 1740

var ExecBase: PExecBase;


EXTMEMPOLICY_ACCESS

Declaration

Source position: exec.pas line 1559

const EXTMEMPOLICY_ACCESS = 2;


EXTMEMPOLICY_DELAYED

Declaration

Source position: exec.pas line 1558

const EXTMEMPOLICY_DELAYED = 1;


EXTMEMPOLICY_IMMEDIATE

Declaration

Source position: exec.pas line 1557

const EXTMEMPOLICY_IMMEDIATE = 0;


GCIT_CacheLineSize

Declaration

Source position: exec.pas line 1621

const GCIT_CacheLineSize = TAG_USER + 14;


GCIT_CPUPageSize

Declaration

Source position: exec.pas line 1622

const GCIT_CPUPageSize = TAG_USER + 15;


GCIT_ExecPageSize

Declaration

Source position: exec.pas line 1623

const GCIT_ExecPageSize = TAG_USER + 16;


GCIT_Extensions

Declaration

Source position: exec.pas line 1620

const GCIT_Extensions = TAG_USER + 13;


GCIT_Family

Declaration

Source position: exec.pas line 1609

const GCIT_Family = TAG_USER + 2;


GCIT_FrontsideSpeed

Declaration

Source position: exec.pas line 1614

const GCIT_FrontsideSpeed = TAG_USER + 7;


GCIT_L1CacheSize

Declaration

Source position: exec.pas line 1616

const GCIT_L1CacheSize = TAG_USER + 9;


GCIT_L2CacheSize

Declaration

Source position: exec.pas line 1617

const GCIT_L2CacheSize = TAG_USER + 10;


GCIT_L3CacheSize

Declaration

Source position: exec.pas line 1618

const GCIT_L3CacheSize = TAG_USER + 11;


GCIT_Model

Declaration

Source position: exec.pas line 1610

const GCIT_Model = TAG_USER + 3;


GCIT_ModelString

Declaration

Source position: exec.pas line 1611

const GCIT_ModelString = TAG_USER + 4;


GCIT_NumberOfCPUs

Declaration

Source position: exec.pas line 1608

const GCIT_NumberOfCPUs = TAG_USER + 1;


GCIT_ProcessorSpeed

Declaration

Source position: exec.pas line 1615

const GCIT_ProcessorSpeed = TAG_USER + 8;


GCIT_TimeBaseSpeed

Declaration

Source position: exec.pas line 1624

const GCIT_TimeBaseSpeed = TAG_USER + 17;


GCIT_VectorUnit

Declaration

Source position: exec.pas line 1619

const GCIT_VectorUnit = TAG_USER + 12;


GCIT_Version

Declaration

Source position: exec.pas line 1612

const GCIT_Version = TAG_USER + 5;


GCIT_VersionString

Declaration

Source position: exec.pas line 1613

const GCIT_VersionString = TAG_USER + 6;


GMAF_REPORT_CR

Declaration

Source position: exec.pas line 601

const GMAF_REPORT_CR = 1 shl 0;


IFLF_CHANGED

Declaration

Source position: exec.pas line 1060

const IFLF_CHANGED = $0008;


IFLF_CLONE_EXPUNGE

Declaration

Source position: exec.pas line 1067

const IFLF_CLONE_EXPUNGE = $0040;


IFLF_CLONED

Declaration

Source position: exec.pas line 1064

const IFLF_CLONED = $0020;


IFLF_NONE

Declaration

Source position: exec.pas line 1056

const IFLF_NONE = $0000;


IFLF_NOT_NATIVE

Declaration

Source position: exec.pas line 1058

const IFLF_NOT_NATIVE = $0002;


IFLF_PRIVATE

Declaration

Source position: exec.pas line 1059

const IFLF_PRIVATE = $0004;


IFLF_PROTECTED

Declaration

Source position: exec.pas line 1057

const IFLF_PROTECTED = $0001;


IFLF_UNMODIFIED

Declaration

Source position: exec.pas line 1061

const IFLF_UNMODIFIED = $0010;


Reference for unit 'exec'

This unit contains the types and wrapper functions for the exec.library.

uses

  System;

Overview

This unit contains the types and wrapper functions for the exec.library. This library supports the very basic functions of Amiga. It provides function for working with other libraries, tasks and other basic structures.


Reference for unit 'exec': Constants

AbsExecBase
ACPU_AddressErr | CPU AlertCode for Alert() Illegal address access (ie: odd)
ACPU_AutoVec1 | CPU AlertCode for Alert() AutoVector Level 1 interrupt error
ACPU_AutoVec2 | CPU AlertCode for Alert() AutoVector Level 2 interrupt error
ACPU_AutoVec3 | CPU AlertCode for Alert() AutoVector Level 3 interrupt error
ACPU_AutoVec4 | CPU AlertCode for Alert() AutoVector Level 4 interrupt error
ACPU_AutoVec5 | CPU AlertCode for Alert() AutoVector Level 5 interrupt error
ACPU_AutoVec6 | CPU AlertCode for Alert() AutoVector Level 6 interrupt error
ACPU_AutoVec7 | CPU AlertCode for Alert() AutoVector Level 7 interrupt error
ACPU_BusErr | CPU AlertCode for Alert() Hardware bus fault/access error
ACPU_CHK | CPU AlertCode for Alert() Check instruction error
ACPU_DivZero | CPU AlertCode for Alert() Divide by zero
ACPU_Format | CPU AlertCode for Alert() Stack frame format error
ACPU_InstErr | CPU AlertCode for Alert() Illegal instruction
ACPU_LineA | CPU AlertCode for Alert() Line 1010 Emulator error
ACPU_LineF | CPU AlertCode for Alert() Line 1111 Emulator error
ACPU_PrivErr | CPU AlertCode for Alert() Privilege violation error
ACPU_Spurious | CPU AlertCode for Alert() Spurious interrupt error
ACPU_Trace | CPU AlertCode for Alert() Trace error
ACPU_TRAPV | CPU AlertCode for Alert() TrapV instruction error
AFB_4XX
AFB_603
AFB_604
AFB_68010 |
AFB_68020 |
AFB_68030 |
AFB_68040 |
AFB_68060 |
AFB_68881 |
AFB_68882 |
AFB_7400
AFB_750
AFB_ALTIVEC
AFB_FPU40 |
AFB_OTHER
AFB_PRIVATE
AFF_4XX
AFF_603
AFF_604
AFF_68010 |
AFF_68020 |
AFF_68030 |
AFF_68040 |
AFF_68060 |
AFF_68881 |
AFF_68882 |
AFF_7400
AFF_750
AFF_ALTIVEC
AFF_FPU40 |
AFF_OTHER
AFF_PRIVATE
AG_BadParm | General AlertCode for Alert()
AG_CloseDev | General AlertCode for Alert() Usually too many closes or a mismatched close
AG_CloseLib | General AlertCode for Alert() Usually too many closes or a mismatched close
AG_IOError | General AlertCode for Alert()
AG_MakeLib | General AlertCode for Alert()
AG_NoMemory | General AlertCode for Alert()
AG_NoSignal | General AlertCode for Alert()
AG_Obsolete
AG_Opendev | General AlertCode for Alert()
AG_OpenLib | General AlertCode for Alert()
AG_OpenRes | General AlertCode for Alert()
AG_ProcCreate | General AlertCode for Alert() Process creation failed
ANMERROR_DUPLICATENAME
ANMERROR_NOERROR
ANMERROR_NOMEMORY
ANMERROR_PARAMETER
ANMT_CheckSum
ANMT_Error
AN_AddSWGadget | Intuition AlertCode for Alert() add SW gadgets, no memory
AN_AsyncPkt | Dos AlertCode for Alert() Unexpected packet received
AN_AudioDev | Audio AlertCode for Alert()
AN_BadChkSum | Dos AlertCode for Alert() Invalid checksum
AN_BadExpansionFree | Expansion AlertCode for Alert() freeed free region
AN_BadFreeAddr | Exec AlertCode for Alert() Memory header not located. Usually an invalid address passed to exec.ExecFreeMem
AN_BadGadget | Intuition AlertCode for Alert() Recovery form of AN_GadgetType
AN_BadHook
AN_BadInitFunc | Dos AlertCode for Alert() Invalid init packet for cli/shell
AN_BadMemory
AN_BadMessage | Intuition AlertCode for Alert() Bad Message received by IDCMP
AN_BadOverlay | Dos AlertCode for Alert() Bad overlay
AN_BadSegList | Ramlib AlertCode for Alert() no overlays in library seglists
AN_BadSemaphore | Exec AlertCode for Alert() An attempt was made to use the old message semaphores.
AN_BadState | Intuition AlertCode for Alert() Bad State Return entering Intuition
AN_BaseChkSum | Exec AlertCode for Alert() Execbase checksum (obs.)
AN_BitMap | Dos AlertCode for Alert() Bitmap corrupt
AN_BltBitMap | Graphics AlertCode for Alert() BltBitMap, no memory
AN_BogusExcpt | Exec AlertCode for Alert() illegal 68k exception taken (obs.)
AN_BootError | Bootstrap AlertCode for Alert() boot code returned an error
AN_BootStrap | Bootstrap AlertCode for Alert()
AN_CIARsrc | CIA AlertCode for Alert()
AN_ConsoleDev | Console AlertCode for Alert()
AN_CreatePort | Intuition AlertCode for Alert() create port, no memory
AN_CybppcDev
AN_CybppcNoTerm
AN_CybppcNoWide
AN_DiskBlkSeq | Dos AlertCode for Alert() Disk block sequence error
AN_DiskCopy | Diskcopy AlertCode for Alert()
AN_DiskError | Dos AlertCode for Alert() Disk Error
AN_DiskfontLib | DiskFont AlertCode for Alert()
AN_DiskRsrc | Disk AlertCode for Alert()
AN_DOSLib | Dos AlertCode for Alert()
AN_DRHasDisk | Disk AlertCode for Alert() get unit: already has disk
AN_DRIntNoAct | Disk AlertCode for Alert() interrupt: no active unit
AN_endTask | Dos AlertCode for Alert() EndTask didn't end the Task
AN_ExcptVect | Exec AlertCode for Alert() 68000 exception vector checksum (obs.)
AN_ExecLib | Exec AlertCode for Alert()
AN_ExpansionLib | Expansion AlertCode for Alert()
AN_FileReclosed | Dos AlertCode for Alert() A filehandle was closed more than once
AN_FreeTwice | Exec AlertCode for Alert() Freeing memory already freed
AN_FreeVec | Dos AlertCode for Alert() Freevec failed
AN_GadgetType | Intuition AlertCode for Alert() unknown gadget type
AN_GadTools | Gadtools AlertCode for Alert()
AN_GamePortDev | Gameport AlertCode for Alert()
AN_GfxFreeError | Graphics AlertCode for Alert()
AN_GfxNewError | Graphics AlertCode for Alert()
AN_GfxNoLCM | Graphics AlertCode for Alert() emergency memory not available
AN_GfxNoMem | Graphics AlertCode for Alert() graphics out of memory
AN_GfxNoMemMspc | Graphics AlertCode for Alert() MonitorSpec alloc, no memory
AN_GraphicsLib | Graphics AlertCode for Alert()
AN_IconLib | Icon AlertCode for Alert()
AN_IFaceChkSum
AN_InitAPtr | Exec AlertCode for Alert() InitStruct() of an APTR source (obs.)
AN_IntrMem | Exec AlertCode for Alert() No memory for interrupt servers
AN_Intuition | Intuition AlertCode for Alert()
AN_IOAfterClose | Exec AlertCode for Alert() IO attempted on closed IORequest
AN_IOUsedTwice | Exec AlertCode for Alert() Attempt to reuse active IORequest
AN_ISemOrder | Intuition AlertCode for Alert() Intuition obtained a semaphore in bad order
AN_ItemAlloc | Intuition AlertCode for Alert() item plane alloc, no memory
AN_ItemBoxTop | Intuition AlertCode for Alert() item box top smaller than RelZero
AN_KeyboardDev | Keyboard AlertCode for Alert()
AN_KeyFree | Dos AlertCode for Alert() Key already free
AN_KeyRange | Dos AlertCode for Alert() Key out of range
AN_LayersLib | Layers AlertCode for Alert()
AN_LayersNoMem | Layers AlertCode for Alert() layers out of memory
AN_LibChkSum | Exec AlertCode for Alert() Library checksum failure
AN_LongFrame | Graphics AlertCode for Alert() long frame, no memory
AN_MakeVPort | Graphics AlertCode for Alert() MakeVPort, no memory
AN_MathLib | Math AlertCode for Alert()
AN_MemCorrupt | Exec AlertCode for Alert() Corrupt memory list detected in exec.ExecFreeMem
AN_MemoryInsane | Exec AlertCode for Alert() Sanity check on memory list failed during AvailMem(MEMF_LARGEST)
AN_MiscRsrc | Misc AlertCode for Alert()
AN_NewlibLib
AN_NoBootNode
AN_NoConsole | Intuition AlertCode for Alert() couldn't open the Console Device
AN_NoFonts | Workbench AlertCode for Alert()
AN_NoISem | Intuition AlertCode for Alert() Intuition skipped obtaining a semaphore
AN_NoWindow | Console AlertCode for Alert() Console can't open initial window
AN_ObsoleteFont | Graphics AlertCode for Alert() unsupported font description used
AN_OpenScreen | Intuition AlertCode for Alert() open screen, no memory
AN_OpenScrnRast | Intuition AlertCode for Alert() open screen, raster alloc, no memory
AN_OpenWindow | Intuition AlertCode for Alert() open window, no memory
AN_PlaneAlloc | Intuition AlertCode for Alert() plane alloc, no memory
AN_QPktFail | Dos AlertCode for Alert() Qpkt failure
AN_RAMLib | Ramlib AlertCode for Alert()
AN_RegionMemory | Graphics AlertCode for Alert() regions, memory not available
AN_SemCorrupt | Exec AlertCode for Alert() A semaphore is in an illegal state at ReleaseSempahore
AN_ShortFrame | Graphics AlertCode for Alert() short frame, no memory
AN_StackProbe | Exec AlertCode for Alert() Stack appears to extend out of range
AN_StartMem | Dos AlertCode for Alert() no memory at startup
AN_SubAlloc | Intuition AlertCode for Alert() sub alloc, no memory
AN_SysScrnType | Intuition AlertCode for Alert() open sys screen, unknown type
AN_TDCalibSeek | Trackdisk AlertCode for Alert() calibrate: seek error
AN_TDDelay | Trackdisk AlertCode for Alert() delay: error on timer wait
AN_TextTmpRas | Graphics AlertCode for Alert() text, no memory for TmpRas
AN_TimerDev | Timer AlertCode for Alert()
AN_TMBadReq | Timer AlertCode for Alert() bad request
AN_TMBadSupply | Timer AlertCode for Alert() power supply -- no 50/60Hz ticks
AN_TrackDiskDev | Trackdisk AlertCode for Alert()
AN_Unknown | utility AlertCode for Alert()
AN_UtilityLib | utility AlertCode for Alert()
AN_WBBadIOMsg | Workbench AlertCode for Alert()
AN_WBBadStartupMsg1 | Workbench AlertCode for Alert()
AN_WBBadStartupMsg2 | Workbench AlertCode for Alert()
AN_WBReLayoutToolMenu | Workbench AlertCode for Alert()
AN_WeirdEcho | Intuition AlertCode for Alert() Weird echo causing incomprehension
AN_Workbench | Workbench AlertCode for Alert()
AO_AudioDev | Device AlertCode for Alert()
AO_BootStrap | Resource AlertCode for Alert()
AO_CIARsrc | Resource AlertCode for Alert()
AO_ConsoleDev | Device AlertCode for Alert()
AO_DiskCopy | AlertCode for Alert()
AO_DiskfontLib | Library AlertCode for Alert()
AO_DiskRsrc | Resource AlertCode for Alert()
AO_DOSLib | Library AlertCode for Alert()
AO_ExecLib | Library AlertCode for Alert()
AO_ExpansionLib | Library AlertCode for Alert()
AO_GadTools | AlertCode for Alert()
AO_GamePortDev | Device AlertCode for Alert()
AO_GraphicsLib | Library AlertCode for Alert()
AO_IconLib | Library AlertCode for Alert()
AO_Intuition | Library AlertCode for Alert()
AO_KeyboardDev | Device AlertCode for Alert()
AO_KeyMapLib | Library AlertCode for Alert()
AO_LayersLib | Library AlertCode for Alert()
AO_MathLib | Library AlertCode for Alert()
AO_MiscRsrc | Resource AlertCode for Alert()
AO_NewlibLib
AO_RAMLib | Library AlertCode for Alert()
AO_TimerDev | Device AlertCode for Alert()
AO_TrackDiskDev | Device AlertCode for Alert()
AO_Unknown | AlertCode for Alert()
AO_UtilityLib | Library AlertCode for Alert()
AO_Workbench | AlertCode for Alert()
ASODMAE_NumEntries
ASODMAE_Size
ASOEXTMEM_AllocationPolicy
ASOEXTMEM_Size
ASOF_NOTRACK
ASOHOOK_Data
ASOHOOK_Entry
ASOHOOK_Size
ASOHOOK_Subentry
ASOINTR_Code
ASOINTR_Data
ASOINTR_Size
ASOINTR_SoftInt
ASOIOR_Duplicate
ASOIOR_ReplyPort
ASOIOR_Size
ASOITEM_BatchSize
ASOITEM_Constructor
ASOITEM_Destructor
ASOITEM_GCParameter
ASOITEM_GCPolicy
ASOITEM_ItemSize
ASOITEM_MaxSize
ASOITEM_MFlags
ASOITEM_Protected
ASOKMEM_Alignment
ASOKMEM_Colored
ASOKMEM_Compact
ASOKMEM_Constructor
ASOKMEM_Destructor
ASOKMEM_Name
ASOKMEM_Size
ASOKMEM_Type
ASOLIST_Min
ASOLIST_Size
ASOLIST_Type
ASOMSG_Length
ASOMSG_Name
ASOMSG_ReplyPort
ASOMSG_Size
ASOMUTEX_Recursive
ASONODE_Min
ASONODE_Name
ASONODE_Pri
ASONODE_Size
ASONODE_Type
ASOPOOL_CopyName
ASOPOOL_LockMem
ASOPOOL_MFlags
ASOPOOL_Name
ASOPOOL_Protected
ASOPOOL_Puddle
ASOPOOL_Threshold
ASOPORT_Action
ASOPORT_AllocSig
ASOPORT_CopyName
ASOPORT_Name
ASOPORT_Pri
ASOPORT_Public
ASOPORT_Signal
ASOPORT_Size
ASOPORT_Target
ASORMAP_Base
ASORMAP_CacheMax
ASORMAP_Quantum
ASORMAP_Size
ASOSEM_CopyName
ASOSEM_Name
ASOSEM_Pri
ASOSEM_Public
ASOSEM_Size
ASOTAGS_NumEntries
ASOTAGS_Size
ASOT_DMAENTRY
ASOT_EXTMEM
ASOT_HOOK
ASOT_INTERRUPT
ASOT_IOREQUEST
ASOT_ITEMPOOL
ASOT_LIST
ASOT_MEMPOOL
ASOT_MESSAGE
ASOT_MUTEX
ASOT_NODE
ASOT_PORT
ASOT_RMAP
ASOT_SEMAPHORE
ASOT_TAGLIST
ASO_MemoryOvr
ASO_NoTrack
AT_Child
AT_Deadend | CPU AlertCode for Alert() Alert type. Error can not be recovered, Computer must be restarted.
AT_Param1
AT_Param2
AT_Param3
AT_Param4
AT_Param5
AT_Param6
AT_Param7
AT_Param8
AT_Recovery | CPU AlertCode for Alert() Alert type. Error can be recovered, system can continue running.
AVT_Alignment
AVT_Clear
AVT_ClearValue
AVT_ClearWithValue
AVT_Contiguous
AVT_Lock
AVT_NoExpunge
AVT_PhysicalAlignment
AVT_Type
AVT_Wait
CACRF_ClearD |
CACRF_ClearI |
CACRF_CopyBack |
CACRF_DBE |
CACRF_EnableD |
CACRF_EnableE |
CACRF_EnableI |
CACRF_FreezeD |
CACRF_FreezeI |
CACRF_IBE |
CACRF_InvalidateD
CACRF_WriteAllocate |
CLT_DataSize
CLT_InitData
CLT_InitFunc
CLT_Interfaces
CLT_Legacy
CLT_NoLegacyIFace
CLT_Seglist
CLT_Vector68K
CMD_CLEAR |
CMD_FLUSH |
CMD_INVALID |
CMD_NONSTD |
CMD_READ |
CMD_RESET |
CMD_START |
CMD_STOP |
CMD_UPDATE |
CMD_WRITE |
CPUFAMILY_4XX
CPUFAMILY_60X
CPUFAMILY_74XX
CPUFAMILY_7X0
CPUFAMILY_E300
CPUFAMILY_E5500
CPUFAMILY_PA6T
CPUFAMILY_UNKNOWN
CPUTYPE_P50XX
CPUTYPE_PA6T_1682M
CPUTYPE_PPC405EP
CPUTYPE_PPC405GP
CPUTYPE_PPC405GPR
CPUTYPE_PPC405LP
CPUTYPE_PPC440EP
CPUTYPE_PPC440GP
CPUTYPE_PPC440GX
CPUTYPE_PPC440SP
CPUTYPE_PPC440SX
CPUTYPE_PPC460EX
CPUTYPE_PPC5121E
CPUTYPE_PPC603E
CPUTYPE_PPC604E
CPUTYPE_PPC7410
CPUTYPE_PPC74XX_APOLLO
CPUTYPE_PPC74XX_VGER
CPUTYPE_PPC750CXE
CPUTYPE_PPC750FX
CPUTYPE_PPC750GX
CPUTYPE_UNKNOWN
CT_LockStack
DBHMT_ADDTASK
DBHMT_CLOSELIB
DBHMT_EXCEPTION
DBHMT_OPENLIB
DBHMT_REMTASK
DBHMT_SHAREDOBJECTCLOSE
DBHMT_SHAREDOBJECTOPEN
DEBUG_SYMBOL_68K_MODULE
DEBUG_SYMBOL_KERNEL_MODULE
DEBUG_SYMBOL_MODULE
DEBUG_SYMBOL_MODULE_STABS
DEBUG_SYMBOL_NATIVE_MODULE
DEV_ABORTIO |
DEV_beginIO |
DMAF_Continue
DMAF_NoModify
DMAF_ReadFromRAM
DMA_Continue |
DMA_NoModify |
DMA_ReadFromRAM |
ECF_FPU
ECF_FULL_FPU
ECF_FULL_GPRS
ECF_VECTOR
ECF_VRSAVE
EFPF_FP0
EFPF_FP1
EFPF_FP2
EFPF_FP3
EFPF_FP4
EFPF_FP5
EFPF_FP6
EFPF_FP7
ET_FPRegisterMask
ET_FPRegisters
ET_NoJIT
ET_Offset
ET_RegisterA0
ET_RegisterA1
ET_RegisterA2
ET_RegisterA3
ET_RegisterA4
ET_RegisterA5
ET_RegisterA6
ET_RegisterA7
ET_RegisterD0
ET_RegisterD1
ET_RegisterD2
ET_RegisterD3
ET_RegisterD4
ET_RegisterD5
ET_RegisterD6
ET_RegisterD7
ET_SaveParamRegs
ET_SaveRegs
ET_StackPtr
ET_SuperState
EXTMEMPOLICY_ACCESS
EXTMEMPOLICY_DELAYED
EXTMEMPOLICY_IMMEDIATE
GCIT_CacheLineSize
GCIT_CPUPageSize
GCIT_ExecPageSize
GCIT_Extensions
GCIT_Family
GCIT_FrontsideSpeed
GCIT_L1CacheSize
GCIT_L2CacheSize
GCIT_L3CacheSize
GCIT_Model
GCIT_ModelString
GCIT_NumberOfCPUs
GCIT_ProcessorSpeed
GCIT_TimeBaseSpeed
GCIT_VectorUnit
GCIT_Version
GCIT_VersionString
GMAF_REPORT_CR
IFLF_CHANGED
IFLF_CLONED
IFLF_CLONE_EXPUNGE
IFLF_NONE
IFLF_NOT_NATIVE
IFLF_PRIVATE
IFLF_PROTECTED
IFLF_UNMODIFIED
INTB_NMI |
INTF_NMI |
IOB_QUICK |
IOERR_ABORTED | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error request terminated early AbortIO
IOERR_BADADDRESS | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error invalid address (misaligned or bad range)
IOERR_BADLENGTH | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error not a valid length (usually IO_LENGTH)
IOERR_NOCMD | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error command not supported by device
IOERR_OPENFAIL | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device/unit failed to open
IOERR_SELFTEST | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error hardware failed self-test
IOERR_SUCCESS
IOERR_UNITBUSY | ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device opens ok, but requested unit is busy
IOF_QUICK |
ITEMGC_AFTERCOUNT
ITEMGC_NONE
KMEMT_PRIVATE
KMEMT_SHARED
LEN_DISASSEMBLE_OPCODE_STRING
LEN_DISASSEMBLE_OPERANDS_STRING
LFalse | Representation of False for Amiga function
LIBABI_68K
LIBABI_MIFACE
LIBF_CHANGED | One or some Library functions are changed.
LIBF_DELEXP | Library should be closed but an other tasks still use it. Waiting.
LIBF_EXP0CNT
LIBF_SUMMING | The checksum of Library is currently being calculated.
LIBF_SUMUSED | A checksum error of a Library results into a reset.
LIB_BASE |
LIB_CLOSE |
LIB_EXPUNGE |
LIB_EXTFUNC |
LIB_NONSTD |
LIB_OPEN |
LIB_RESERVED |
LIB_USERDEF |
LIB_VECTSIZE |
LTrue | Representation of True for Amiga functions
MEMATTRF_CACHEINHIBIT
MEMATTRF_CHANGED
MEMATTRF_COHERENT
MEMATTRF_EXECUTE
MEMATTRF_GUARDED
MEMATTRF_NOT_MAPPED
MEMATTRF_READ_ONLY
MEMATTRF_READ_WRITE
MEMATTRF_REFERENCED
MEMATTRF_RESERVED1
MEMATTRF_RESERVED2
MEMATTRF_RESERVER3
MEMATTRF_RW_MASK
MEMATTRF_SUPER_RO_USER_RO
MEMATTRF_SUPER_RW
MEMATTRF_SUPER_RW_USER_RO
MEMATTRF_SUPER_RW_USER_RW
MEMATTRF_WRITETHROUGH
MEMF_24BITDMA | Memory Requirement Type. DMAable memory within 24 bits of address.
MEMF_ANY | Memory Requirement Type. Any type of memory will do.
MEMF_CHIP | Memory Requirement Type
MEMF_CLEAR | Memory Requirement Type. Clear the memory when allocate.
MEMF_CORE_RESIDENT
MEMF_DELAYED
MEMF_EXECUTABLE
MEMF_FAST | Memory Requirement Type
MEMF_HWALIGNED
MEMF_KICK | Memory Requirement Type. Memory that can be used for KickTags.
MEMF_LARGEST | Memory Requirement Type. Return the largest available memory block.
MEMF_LOCAL | Memory Requirement Type
MEMF_NO_EXPUNGE | Memory Requirement Type. Do not cause expunge on failure
MEMF_PRIVATE
MEMF_PUBLIC | Memory Requirement Type.
MEMF_REVERSE | Memory Requirement Type
MEMF_SHARED
MEMF_TOTAL | Memory Requirement Type. Return the total size of Memory.
MEMF_VIRTUAL
MEMHF_RECYCLE | 0 = First time, 1 = recycle
MEM_ALL_DONE | We did all we could do
MEM_BLOCKMASK |
MEM_BLOCKSIZE |
MEM_DID_NOTHING | Nothing we could do
MEM_TRY_AGAIN | We did some, try the allocation again
NSR_Arg1
NSR_Arg2
NSR_Arg3
NSR_Arg4
NSR_Arg5
NSR_Arg6
NSR_Dummy
NSR_LockStack
NSR_MinStackSize
NSR_StackSize
NT_BOOTNODE | For TNode.ln_Type
NT_CLASS
NT_DEATHMESSAGE | For TNode.ln_Type
NT_DEVICE | For TNode.ln_Type identifies a device
NT_ELFHANDLE
NT_EXTENDED | For TNode.ln_Type
NT_EXTINTERRUPT
NT_EXTSOFTINT
NT_FILESYSTEM
NT_FONT | For TNode.ln_Type
NT_FREEMSG | For TNode.ln_Type Message has beed freed
NT_GRAPHICS | For TNode.ln_Type
NT_INTERFACE
NT_INTERRUPT | For TNode.ln_Type identifies an interrupt
NT_KICKMEM | For TNode.ln_Type
NT_KMEMCACHE
NT_LIBRARY | For TNode.ln_Type
NT_MEMORY | For TNode.ln_Type
NT_MESSAGE | For TNode.ln_Type indicates message is currently pending
NT_MSGPORT | For TNode.ln_Type identifies a message port
NT_PAGE
NT_PROCESS | For TNode.ln_Type identifies and Amiga Dos process
NT_REPLYMSG | For TNode.ln_Type Message has been replied
NT_RESERVED1
NT_RESOURCE | For TNode.ln_Type
NT_SEMAPHORE | For TNode.ln_Type
NT_SIGNALSEM | For TNode.ln_Type identifies an signal semaphore
NT_SOFTINT | For TNode.ln_Type Internal flag used ny SoftInits
NT_SOLIBHANDLE
NT_TASK | For TNode.ln_Type identifies an Exec Task
NT_UNKNOWN | For TNode.ln_Type
NT_USER | For TNode.ln_Type User nodes type.
NT_VMAREA
NT_VMAREA_PROXY
PA_IGNORE | Ignore arrival in TMsgPort
PA_SIGNAL | Signal task in mp_SigTask in tMsgPort
PA_SOFTINT | Signal SoftInt in mp_SoftInt/mp_SigTask in TMsgPort
PF_ACTION | Mask for all PA_* tMsgPort Flags
PF_SIGALLOC
REG68K_A0
REG68K_A1
REG68K_A2
REG68K_A3
REG68K_A4
REG68K_A5
REG68K_A6
REG68K_A7
REG68K_D0
REG68K_D1
REG68K_D2
REG68K_D3
REG68K_D4
REG68K_D5
REG68K_D6
REG68K_D7
REG68K_FP0
REG68K_FP1
REG68K_FP2
REG68K_FP3
REG68K_FP4
REG68K_FP5
REG68K_FP6
REG68K_FP7
RTCF_FPU
RTCF_GENERAL
RTCF_INFO
RTCF_SPECIAL
RTCF_STATE
RTCF_VECTOR
RTC_MATCHWORD | Matchword for rt_MatchWord
RTF_AFTERDOS | Flag for rt_Flags
RTF_AUTOINIT | Flag for rt_Flags
RTF_COLDSTART | Flag for rt_Flags
RTF_NATIVE
RTF_SINGLETASK | Flag for rt_Flags
SDONA_SignalMask
SDONA_Task
SIGB_ABORT |
SIGB_BLIT |
SIGB_CHILD |
SIGB_DOS |
SIGB_INTUITION |
SIGB_NET
SIGB_SINGLE |
SIGF_ABORT |
SIGF_BLIT |
SIGF_CHILD |
SIGF_DOS |
SIGF_INTUITION |
SIGF_NET
SIGF_SINGLE |
SIH_PRIMASK |
SM_EXCLUSIVE |
SM_SHARED |
SNMF_NAMESPACES_ONLY
STACK_FRAME_BACKCHAIN_PTR_LOOP
STACK_FRAME_DECODED
STACK_FRAME_INVALID_BACKCHAIN_PTR
STACK_FRAME_TRASHED_MEMORY_LOOP
STB_CRASHED
STB_REMOVED
STF_CRASHED
STF_REMOVED
TAG_USER
TB_ETASK | Flag Bit for tc_Flags
TB_EXCEPT | Flag Bit for tc_Flags Task gets no CPU time.
TB_LAUNCH | Flag Bit for tc_Flags Task is switched to CPU.
TB_PROCTIME | Flag Bit for tc_Flags Task uses CPU.
TB_STACKCHK | Flag Bit for tc_Flags Stack is checked.
TB_SWITCH | Flag Bit for tc_Flags Task is switched away from CPU.
TF_ETASK | Flag value for tc_Flags
TF_EXCEPT | Flag value for tc_Flags Task gets no CPU time.
TF_LAUNCH | Flag value for tc_Flags Task is switched to CPU.
TF_PROCTIME | Flag value for tc_Flags Task uses CPU.
TF_STACKCHK | Flag value for tc_Flags Stack is checked.
TF_SWITCH | Flag value for tc_Flags Task is switched away from CPU.
TRACKF_COMPACT
TRAPINST
TRAPNUM_ALIGNMENT
TRAPNUM_ALTIVEC_ASSIST
TRAPNUM_BUS_ERROR
TRAPNUM_DATA_BREAKPOINT
TRAPNUM_DATA_SEGMENT_VIOLATION
TRAPNUM_FPU
TRAPNUM_ILLEGAL_INSTRUCTION
TRAPNUM_INST_BREAKPOINT
TRAPNUM_INST_SEGMENT_VIOLATION
TRAPNUM_NUMTRAPS
TRAPNUM_PERFORMANCE
TRAPNUM_PRIVILEGE_VIOLATION
TRAPNUM_RESERVED1
TRAPNUM_SMI
TRAPNUM_THERMAL
TRAPNUM_TRACE
TRAPNUM_TRAP
TRAPTYPE
TRAPTYPENR
TS_ADDED | Task State for tc_State Task is currently inserted in List.
TS_CRASHED
TS_EXCEPT | Task State for tc_State Task gets no CPU time.
TS_INVALID | Task State for tc_State Invalid Task.
TS_READY | Task State for tc_State Task is ready to work.
TS_REMOVED | Task State for tc_State Task is removed at the moment.
TS_RUN | Task State for tc_State Task is running.
TS_SUSPENDED
TS_WAIT | Task State for tc_State Task is waiting for a signal.
UNITF_ACTIVE | tUnit is accessable
UNITF_INTASK | tUnit is currently working
VECTORTYPE_ALTIVEC
VECTORTYPE_NONE


Reference for unit 'exec': Types

Pointer | A type free pointer.
AVLKEYCOMP |
AVLNODECOMP |
SmallInt | Boolean representation
LongInt | A type free pointer. in ABIv0 its just a Pointer.
LongInt | Pointer to a string, in ABIv0 just like PChar.
LongInt | signed 32-Bit integer Value
LongWord |
PAPTR |
PAVLKEYCOMP |
PAVLNode |
PAVLNODECOMP |
PDevice | Device has the same structure as an Library
PDMAEntry
PExceptionContext
PExecBase |
PHook
PInterface
PInterrupt |
PIntVector | For EXEC use ONLY!
PIORequest |
PIOStdReq |
PLibrary | Library Base Structure
PList | Pointer to List structure
PLONG |
PLONGBITS |
PMemChunk |
PMemEntry |
PMemHandlerData | Memory Handler
PMemHeader |
PMemList | Pointer to the list of all Memory
PMessage | Message from/for a MessagePort
PMinList | Pointer to a minal list structure.
PMinNode |
PMsgPort | Port for inter-task communication.
PNode | Pointer to node structure
PPAVLNode |
PPTagItem
PResident |
PSemaphoreMessage |
PSemaphoreRequest | This is the structure used to request a signal semaphore
PSignalSemaphore |
PSNMMessage
PSoftIntList | For EXEC use ONLY!
PStackSwapStruct | Stack swap structure as passed to StackSwap
PPChar
PTag
PTagItem
PTask | Pointer to Task structure
PTrackable
PULONG |
PUnit |
PChar | Pointer to a string (compareable with a PChar)
LongWord
Pointer
TAVLNode |
TDebugOutputNotify
TDebugSymbol
TDevice | Device has the same structure as an Library
TDMAEntry
TEmuTrap
TEmuTrapfunction
TExceptionContext
TExecBase |
THook
TInterface
TInterfaceData
TInterrupt |
TIntVector | For EXEC use ONLY!
TIORequest |
TIOStdReq |
TLibrary | Library Base Structure
TList | List header.
TMemChunk |
TMemEntry |
TMemHandlerData | Memory Handler
TMemHeader |
TMemList | List of all available Memory
TMessage | Message from/for a MessagePort
TMinList | Minimal list strcture.
TMinNode | Minimal list entry without any type or name.
TMsgPort | Port for inter-task communication.
TNode | List node structure, Each member in a list starts with a node.
TResident |
TSemaphoreMessage |
TSemaphoreRequest | This is the structure used to request a signal semaphore
TSignalSemaphore |
TSNMMessage
TSoftIntList | For EXEC use ONLY!
TStackFrameMsg
TStackSwapStruct | Stack swap structure as passed to StackSwap
TTagItem
TTask | Every Amiga Task has one of these Task structures associated with it. To find yours, use FindTask(nil). Amiga processes tack a few more values on to the end of this structure, which is the difference between Tasks and Processes.
TTrackable
TUnit |
Byte | unsigned 8-Bit Value
LongWord | unsigned 32-Bit integer value
Word | unsigned 16-Bit Value
Word |


INTB_NMI

Declaration

Source position: exec.pas line 708

const INTB_NMI = 15;


INTF_NMI

Declaration

Source position: exec.pas line 709

const INTF_NMI = 1 shl INTB_NMI;


IOB_QUICK

Declaration

Source position: exec.pas line 1006

const IOB_QUICK = 0;


IOERR_ABORTED

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error request terminated early AbortIO

Declaration

Source position: exec.pas line 1463

const IOERR_ABORTED = - 2;


IOERR_BADADDRESS

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error invalid address (misaligned or bad range)

Declaration

Source position: exec.pas line 1466

const IOERR_BADADDRESS = - 5;


IOERR_BADLENGTH

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error not a valid length (usually IO_LENGTH)

Declaration

Source position: exec.pas line 1465

const IOERR_BADLENGTH = - 4;


IOERR_NOCMD

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error command not supported by device

Declaration

Source position: exec.pas line 1464

const IOERR_NOCMD = - 3;


IOERR_OPENFAIL

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device/unit failed to open

Declaration

Source position: exec.pas line 1462

const IOERR_OPENFAIL = - 1;


IOERR_SELFTEST

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error hardware failed self-test

Declaration

Source position: exec.pas line 1468

const IOERR_SELFTEST = - 7;


IOERR_SUCCESS

Declaration

Source position: exec.pas line 1461

const IOERR_SUCCESS = 0;


IOERR_UNITBUSY

ErrCode for TIORequest.io_Error or TIOStdReq.io_Error device opens ok, but requested unit is busy

Declaration

Source position: exec.pas line 1467

const IOERR_UNITBUSY = - 6;


IOF_QUICK

Declaration

Source position: exec.pas line 1007

const IOF_QUICK = 1 shl IOB_QUICK;


ITEMGC_AFTERCOUNT

Declaration

Source position: exec.pas line 1553

const ITEMGC_AFTERCOUNT = 1;


ITEMGC_NONE

Declaration

Source position: exec.pas line 1552

const ITEMGC_NONE = 0;


KMEMT_PRIVATE

Declaration

Source position: exec.pas line 1573

const KMEMT_PRIVATE = 0;


KMEMT_SHARED

Declaration

Source position: exec.pas line 1574

const KMEMT_SHARED = 1;


LEN_DISASSEMBLE_OPCODE_STRING

Declaration

Source position: exec.pas line 1309

const LEN_DISASSEMBLE_OPCODE_STRING = 15;


LEN_DISASSEMBLE_OPERANDS_STRING

Declaration

Source position: exec.pas line 1310

const LEN_DISASSEMBLE_OPERANDS_STRING = 40;


LFalse

Representation of False for Amiga function

Declaration

Source position: exec.pas line 145

const LFalse: LongInt = 0;

Description

Some Amiga functions expect a "1" for as True value and a "0" as False value and cannot handle the "-1" set by freepascal.

See also

ltrue

Representation of True for Amiga functions


LIB_BASE

Declaration

Source position: exec.pas line 904

const LIB_BASE = - LIB_VECTSIZE;


LIB_CLOSE

Declaration

Source position: exec.pas line 911

const LIB_CLOSE = - 12;


LIB_EXPUNGE

Declaration

Source position: exec.pas line 912

const LIB_EXPUNGE = - 18;


LIB_EXTFUNC

Declaration

Source position: exec.pas line 913

const LIB_EXTFUNC = - 24;


LIB_NONSTD

Declaration

Source position: exec.pas line 906

const LIB_NONSTD = LIB_USERDEF;


LIB_OPEN

Declaration

Source position: exec.pas line 910

const LIB_OPEN = - 6;


LIB_RESERVED

Declaration

Source position: exec.pas line 903

const LIB_RESERVED = 4;


LIB_USERDEF

Declaration

Source position: exec.pas line 905

const LIB_USERDEF = LIB_BASE - LIB_RESERVED * LIB_VECTSIZE;


LIB_VECTSIZE

Declaration

Source position: exec.pas line 902

const LIB_VECTSIZE = 6;


LIBABI_68K

Declaration

Source position: exec.pas line 937

const LIBABI_68K = 0;


LIBABI_MIFACE

Declaration

Source position: exec.pas line 938

const LIBABI_MIFACE = 1;


LIBF_CHANGED

One or some Library functions are changed.

Declaration

Source position: exec.pas line 942

const LIBF_CHANGED = 1 shl 1;


LIBF_DELEXP

Library should be closed but an other tasks still use it. Waiting.

Declaration

Source position: exec.pas line 944

const LIBF_DELEXP = 1 shl 3;


LIBF_EXP0CNT

Declaration

Source position: exec.pas line 945

const LIBF_EXP0CNT = 1 shl 4;


LIBF_SUMMING

The checksum of Library is currently being calculated.

Declaration

Source position: exec.pas line 941

const LIBF_SUMMING = 1 shl 0;


LIBF_SUMUSED

A checksum error of a Library results into a reset.

Declaration

Source position: exec.pas line 943

const LIBF_SUMUSED = 1 shl 2;


LONG

signed 32-Bit integer Value

Declaration

Source position: exec.pas line 30

type LONG = LongInt;


LONGBITS

Declaration

Source position: exec.pas line 37

type LONGBITS = LongWord;


LTrue

Representation of True for Amiga functions

Declaration

Source position: exec.pas line 144

const LTrue: LongInt = 1;

Description

Some Amiga functions expect a "1" for as True value and a "0" as False value and cannot handle the "-1" set by freepascal.

See also

lfalse

Representation of False for Amiga function


MEM_ALL_DONE

We did all we could do

Declaration

Source position: exec.pas line 569

const MEM_ALL_DONE = - 1;


MEM_BLOCKMASK

Declaration

Source position: exec.pas line 552

const MEM_BLOCKMASK = MEM_BLOCKSIZE - 1;


MEM_BLOCKSIZE

Declaration

Source position: exec.pas line 551

const MEM_BLOCKSIZE = 16;


MEM_DID_NOTHING

Nothing we could do

Declaration

Source position: exec.pas line 568

const MEM_DID_NOTHING = 0;


MEM_TRY_AGAIN

We did some, try the allocation again

Declaration

Source position: exec.pas line 570

const MEM_TRY_AGAIN = 1;


MEMATTRF_CACHEINHIBIT

Declaration

Source position: exec.pas line 575

const MEMATTRF_CACHEINHIBIT = 1 shl 1;


MEMATTRF_CHANGED

Declaration

Source position: exec.pas line 579

const MEMATTRF_CHANGED = 1 shl 5;


MEMATTRF_COHERENT

Declaration

Source position: exec.pas line 576

const MEMATTRF_COHERENT = 1 shl 2;


MEMATTRF_EXECUTE

Declaration

Source position: exec.pas line 588

const MEMATTRF_EXECUTE = 1 shl 9;


MEMATTRF_GUARDED

Declaration

Source position: exec.pas line 577

const MEMATTRF_GUARDED = 1 shl 3;


MEMATTRF_NOT_MAPPED

Declaration

Source position: exec.pas line 590

const MEMATTRF_NOT_MAPPED = 1 shl 10;


MEMATTRF_READ_ONLY

Declaration

Source position: exec.pas line 597

const MEMATTRF_READ_ONLY = MEMATTRF_SUPER_RO_USER_RO;


MEMATTRF_READ_WRITE

Declaration

Source position: exec.pas line 596

const MEMATTRF_READ_WRITE = MEMATTRF_SUPER_RW_USER_RW;


MEMATTRF_REFERENCED

Declaration

Source position: exec.pas line 578

const MEMATTRF_REFERENCED = 1 shl 4;


MEMATTRF_RESERVED1

Declaration

Source position: exec.pas line 591

const MEMATTRF_RESERVED1 = 1 shl 11;


MEMATTRF_RESERVED2

Declaration

Source position: exec.pas line 592

const MEMATTRF_RESERVED2 = 1 shl 12;


MEMATTRF_RESERVER3

Declaration

Source position: exec.pas line 593

const MEMATTRF_RESERVER3 = 1 shl 13;


MEMATTRF_RW_MASK

Declaration

Source position: exec.pas line 586

const MEMATTRF_RW_MASK = 3 shl 6;


MEMATTRF_SUPER_RO_USER_RO

Declaration

Source position: exec.pas line 585

const MEMATTRF_SUPER_RO_USER_RO = 3 shl 6;


MEMATTRF_SUPER_RW

Declaration

Source position: exec.pas line 582

const MEMATTRF_SUPER_RW = 0 shl 6;


MEMATTRF_SUPER_RW_USER_RO

Declaration

Source position: exec.pas line 583

const MEMATTRF_SUPER_RW_USER_RO = 1 shl 6;


MEMATTRF_SUPER_RW_USER_RW

Declaration

Source position: exec.pas line 584

const MEMATTRF_SUPER_RW_USER_RW = 2 shl 6;


MEMATTRF_WRITETHROUGH

Declaration

Source position: exec.pas line 574

const MEMATTRF_WRITETHROUGH = 1 shl 0;


MEMF_24BITDMA

Memory Requirement Type. DMAable memory within 24 bits of address.

Declaration

Source position: exec.pas line 537

const MEMF_24BITDMA = 1 shl 9;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_ANY

Memory Requirement Type. Any type of memory will do.

Declaration

Source position: exec.pas line 530

const MEMF_ANY = 0;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_CHIP

Memory Requirement Type

Declaration

Source position: exec.pas line 532

const MEMF_CHIP = 1 shl 1;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_CLEAR

Memory Requirement Type. Clear the memory when allocate.

Declaration

Source position: exec.pas line 542

const MEMF_CLEAR = 1 shl 16;

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


MEMF_CORE_RESIDENT

Declaration

Source position: exec.pas line 548

const MEMF_CORE_RESIDENT = 1 shl 22;


MEMF_DELAYED

Declaration

Source position: exec.pas line 547

const MEMF_DELAYED = 1 shl 21;


MEMF_EXECUTABLE

Declaration

Source position: exec.pas line 535

const MEMF_EXECUTABLE = 1 shl 4;


MEMF_FAST

Memory Requirement Type

Declaration

Source position: exec.pas line 533

const MEMF_FAST = 1 shl 2;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_HWALIGNED

Declaration

Source position: exec.pas line 546

const MEMF_HWALIGNED = 1 shl 20;


MEMF_KICK

Memory Requirement Type. Memory that can be used for KickTags.

Declaration

Source position: exec.pas line 538

const MEMF_KICK = 1 shl 10;

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


MEMF_LARGEST

Memory Requirement Type. Return the largest available memory block.

Declaration

Source position: exec.pas line 543

const MEMF_LARGEST = 1 shl 17;

See also

AvailMem

Check memory available given certain requirements


MEMF_LOCAL

Memory Requirement Type

Declaration

Source position: exec.pas line 536

const MEMF_LOCAL = 1 shl 8;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_NO_EXPUNGE

Memory Requirement Type. Do not cause expunge on failure

Declaration

Source position: exec.pas line 549

const MEMF_NO_EXPUNGE = 1 shl 31;

See also

Exec.ExecAllocMem

Allocate memory given certain requirements


MEMF_PRIVATE

Declaration

Source position: exec.pas line 539

const MEMF_PRIVATE = 1 shl 11;


MEMF_PUBLIC

Memory Requirement Type.

Declaration

Source position: exec.pas line 531

const MEMF_PUBLIC = 1 shl 0;

See also

Exec.ExecAllocMem | Allocate memory given certain requirements
AvailMem | Check memory available given certain requirements
CreatePool | Create a new pool for memory allocations


MEMF_REVERSE

Memory Requirement Type

Declaration

Source position: exec.pas line 544

const MEMF_REVERSE = 1 shl 18;

See also

AvailMem

Check memory available given certain requirements


MEMF_SHARED

Declaration

Source position: exec.pas line 540

const MEMF_SHARED = 1 shl 12;


MEMF_TOTAL

Memory Requirement Type. Return the total size of Memory.

Declaration

Source position: exec.pas line 545

const MEMF_TOTAL = 1 shl 19;

See also

AvailMem

Check memory available given certain requirements


MEMF_VIRTUAL

Declaration

Source position: exec.pas line 534

const MEMF_VIRTUAL = 1 shl 3;


MEMHF_RECYCLE

0 = First time, 1 = recycle

Declaration

Source position: exec.pas line 565

const MEMHF_RECYCLE = 1 shl 0;


NSR_Arg1

Declaration

Source position: exec.pas line 1730

const NSR_Arg1 = NSR_Dummy + 10;


NSR_Arg2

Declaration

Source position: exec.pas line 1731

const NSR_Arg2 = NSR_Dummy + 11;


NSR_Arg3

Declaration

Source position: exec.pas line 1732

const NSR_Arg3 = NSR_Dummy + 12;


NSR_Arg4

Declaration

Source position: exec.pas line 1733

const NSR_Arg4 = NSR_Dummy + 13;


NSR_Arg5

Declaration

Source position: exec.pas line 1734

const NSR_Arg5 = NSR_Dummy + 14;


NSR_Arg6

Declaration

Source position: exec.pas line 1735

const NSR_Arg6 = NSR_Dummy + 15;


NSR_Dummy

Declaration

Source position: exec.pas line 1726

const NSR_Dummy = TAG_USER + 500;


NSR_LockStack

Declaration

Source position: exec.pas line 1729

const NSR_LockStack = NSR_Dummy + 3;


NSR_MinStackSize

Declaration

Source position: exec.pas line 1728

const NSR_MinStackSize = NSR_Dummy + 2;


NSR_StackSize

Declaration

Source position: exec.pas line 1727

const NSR_StackSize = NSR_Dummy + 1;


NT_BOOTNODE

For TNode.ln_Type

Declaration

Source position: exec.pas line 83

const NT_BOOTNODE = 16;


NT_CLASS

Declaration

Source position: exec.pas line 93

const NT_CLASS = 24;


NT_DEATHMESSAGE

For TNode.ln_Type

Declaration

Source position: exec.pas line 86

const NT_DEATHMESSAGE = 19;


NT_DEVICE

For TNode.ln_Type identifies a device

Declaration

Source position: exec.pas line 70

const NT_DEVICE = 3;


NT_ELFHANDLE

Declaration

Source position: exec.pas line 106

const NT_ELFHANDLE = 41;


NT_EXTENDED

For TNode.ln_Type

Declaration

Source position: exec.pas line 110

const NT_EXTENDED = 255;


NT_EXTINTERRUPT

Declaration

Source position: exec.pas line 89

const NT_EXTINTERRUPT = 20;


NT_EXTSOFTINT

Declaration

Source position: exec.pas line 90

const NT_EXTSOFTINT = 21;


NT_FILESYSTEM

Declaration

Source position: exec.pas line 101

const NT_FILESYSTEM = 28;


NT_FONT

For TNode.ln_Type

Declaration

Source position: exec.pas line 79

const NT_FONT = 12;


NT_FREEMSG

For TNode.ln_Type Message has beed freed

Declaration

Source position: exec.pas line 73

const NT_FREEMSG = 6;


NT_GRAPHICS

For TNode.ln_Type

Declaration

Source position: exec.pas line 85

const NT_GRAPHICS = 18;


NT_INTERFACE

Declaration

Source position: exec.pas line 94

const NT_INTERFACE = 25;


NT_INTERRUPT

For TNode.ln_Type identifies an interrupt

Declaration

Source position: exec.pas line 69

const NT_INTERRUPT = 2;


NT_KICKMEM

For TNode.ln_Type

Declaration

Source position: exec.pas line 84

const NT_KICKMEM = 17;


NT_KMEMCACHE

Declaration

Source position: exec.pas line 97

const NT_KMEMCACHE = 26;


NT_LIBRARY

For TNode.ln_Type

Declaration

Source position: exec.pas line 76

const NT_LIBRARY = 9;


NT_MEMORY

For TNode.ln_Type

Declaration

Source position: exec.pas line 77

const NT_MEMORY = 10;


NT_MESSAGE

For TNode.ln_Type indicates message is currently pending

Declaration

Source position: exec.pas line 72

const NT_MESSAGE = 5;


NT_MSGPORT

For TNode.ln_Type identifies a message port

Declaration

Source position: exec.pas line 71

const NT_MSGPORT = 4;


NT_PAGE

Declaration

Source position: exec.pas line 104

const NT_PAGE = 40;


NT_PROCESS

For TNode.ln_Type identifies and Amiga Dos process

Declaration

Source position: exec.pas line 80

const NT_PROCESS = 13;


NT_REPLYMSG

For TNode.ln_Type Message has been replied

Declaration

Source position: exec.pas line 74

const NT_REPLYMSG = 7;


NT_RESERVED1

Declaration

Source position: exec.pas line 98

const NT_RESERVED1 = 27;


NT_RESOURCE

For TNode.ln_Type

Declaration

Source position: exec.pas line 75

const NT_RESOURCE = 8;


NT_SEMAPHORE

For TNode.ln_Type

Declaration

Source position: exec.pas line 81

const NT_SEMAPHORE = 14;


NT_SIGNALSEM

For TNode.ln_Type identifies an signal semaphore

Declaration

Source position: exec.pas line 82

const NT_SIGNALSEM = 15;


NT_SOFTINT

For TNode.ln_Type Internal flag used ny SoftInits

Declaration

Source position: exec.pas line 78

const NT_SOFTINT = 11;


NT_SOLIBHANDLE

Declaration

Source position: exec.pas line 107

const NT_SOLIBHANDLE = 42;


NT_TASK

For TNode.ln_Type identifies an Exec Task

Declaration

Source position: exec.pas line 68

const NT_TASK = 1;


NT_UNKNOWN

For TNode.ln_Type

Declaration

Source position: exec.pas line 67

const NT_UNKNOWN = 0;


NT_USER

For TNode.ln_Type User nodes type.

Declaration

Source position: exec.pas line 109

const NT_USER = 254;


NT_VMAREA

Declaration

Source position: exec.pas line 91

const NT_VMAREA = 22;


NT_VMAREA_PROXY

Declaration

Source position: exec.pas line 92

const NT_VMAREA_PROXY = 23;


PA_IGNORE

Ignore arrival in TMsgPort

Declaration

Source position: exec.pas line 864

const PA_IGNORE = 2;


PA_SIGNAL

Signal task in mp_SigTask in tMsgPort

Declaration

Source position: exec.pas line 862

const PA_SIGNAL = 0;


PA_SOFTINT

Signal SoftInt in mp_SoftInt/mp_SigTask in TMsgPort

Declaration

Source position: exec.pas line 863

const PA_SOFTINT = 1;


PAPTR

Declaration

Source position: exec.pas line 41

type PAPTR = ^Pointer;


PAVLKEYCOMP

Declaration

Source position: exec.pas line 1303

type PAVLKEYCOMP = ^AVLKEYCOMP;


PAVLNode

Declaration

Source position: exec.pas line 1292

type PAVLNode = ^TAVLNode;


PAVLNODECOMP

Declaration

Source position: exec.pas line 1300

type PAVLNODECOMP = ^AVLNODECOMP;


PDevice

Device has the same structure as an Library

Declaration

Source position: exec.pas line 954

type PDevice = ^TDevice;


PDMAEntry

Declaration

Source position: exec.pas line 624

type PDMAEntry = ^TDMAEntry;


PExceptionContext

Declaration

Source position: exec.pas line 664

type PExceptionContext = ^TExceptionContext;


PExecBase

Declaration

Source position: exec.pas line 1076

type PExecBase = ^TExecBase;


PF_ACTION

Mask for all PA_* tMsgPort Flags

Declaration

Source position: exec.pas line 858

const PF_ACTION = 3;


PF_SIGALLOC

Declaration

Source position: exec.pas line 859

const PF_SIGALLOC = 1 shl 7;


PHook

Declaration

Source position: exec.pas line 129

type PHook = ^THook;


PInterface

Declaration

Source position: exec.pas line 1050

type PInterface = ^TInterface;


PInterrupt

Declaration

Source position: exec.pas line 644

type PInterrupt = ^TInterrupt;

See also

AddIntServer | Adds a interrupt server to the system
RemIntServer | Remove an interrupt server from a server chain
AddMemHandler |
RemMemHandler | Remove low memory handler from exec
Cause | Fire and software interrupt
SetIntVector | Set a new handler for a system interrupt vector


PIntVector

For EXEC use ONLY!

Declaration

Source position: exec.pas line 651

type PIntVector = ^TIntVector;

See also

TExecBase


PIORequest

Declaration

Source position: exec.pas line 973

type PIORequest = ^TIORequest;


PIOStdReq

Declaration

Source position: exec.pas line 983

type PIOStdReq = ^TIOStdReq;


PLibrary

Library Base Structure

Declaration

Source position: exec.pas line 919

type PLibrary = ^TLibrary;

Description

Also used for Devices and some Resources

See also

OpenLibrary | Open a library to use
CloseLibrary | Close access to library
AddLibrary | Adds a library to the system
MakeLibrary | Construct a library
RemLibrary | Remove a library from the system
SumLibrary | Compute and check the checksum on a library
SetFunction | Change a function vector in a library


PList

Pointer to List structure

Declaration

Source position: exec.pas line 158

type PList = ^TList;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name
IsListEmpty | Check if a list is empty


PLONG

Declaration

Source position: exec.pas line 42

type PLONG = ^LongInt;


PLONGBITS

Declaration

Source position: exec.pas line 38

type PLONGBITS = ^LongWord;


PMemChunk

Declaration

Source position: exec.pas line 487

type PMemChunk = ^TMemChunk;

See also

TMemHeader


PMemEntry

Declaration

Source position: exec.pas line 507

type PMemEntry = ^TMemEntry;

See also

TMemList

List of all available Memory


PMemHandlerData

Memory Handler

Declaration

Source position: exec.pas line 557

type PMemHandlerData = ^TMemHandlerData;

Description

This structure is READ ONLY and only EXEC can create it!


PMemHeader

Declaration

Source position: exec.pas line 495

type PMemHeader = ^TMemHeader;

See also

Allocate | Allocate a block of memory
Deallocate | Free a block of memory


PMemList

Pointer to the list of all Memory

Declaration

Source position: exec.pas line 519

type PMemList = ^TMemList;

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Free many blocks of memory at once


PMessage

Message from/for a MessagePort

Declaration

Source position: exec.pas line 848

type PMessage = ^TMessage;

See also

GetMsg | Get next message from message port
PutMsg | Put a message to a message port
ReplyMsg | Put a message to its reply port
WaitPort | Wait for a given port to be non-empty


PMinList

Pointer to a minal list structure.

Declaration

Source position: exec.pas line 168

type PMinList = ^TMinList;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name
IsListEmpty | Check if a list is empty


PMinNode

Declaration

Source position: exec.pas line 56

type PMinNode = ^TMinNode;


PMsgPort

Port for inter-task communication.

Declaration

Source position: exec.pas line 837

type PMsgPort = ^TMsgPort;

See also

AddPort | Add a public message port to the system
RemPort | Remove a message port from the system
CreateIORequest | Create a structure usable for an I/O request
CreateMsgPort | Create a new message port
DeleteMsgPort | Free a message port
FindPort | Find a system message port by name
GetMsg | Get next message from message port
PutMsg | Put a message to a message port
WaitPort | Wait for a given port to be non-empty


PNode

Pointer to node structure

Declaration

Source position: exec.pas line 46

type PNode = ^TNode;


PPAVLNode

Declaration

Source position: exec.pas line 1296

type PPAVLNode = ^PAVLNode;


PPTagItem

Declaration

Source position: exec.pas line 127

type PPTagItem = ^PTagItem;


PResident

Declaration

Source position: exec.pas line 460

type PResident = ^TResident;

See also

FindResident | Find a resident module by name
InitResident | Initialize resident module


PSemaphoreMessage

Declaration

Source position: exec.pas line 888

type PSemaphoreMessage = ^TSemaphoreMessage;


PSemaphoreRequest

This is the structure used to request a signal semaphore

Declaration

Source position: exec.pas line 870

type PSemaphoreRequest = ^TSemaphoreRequest;


PSignalSemaphore

Declaration

Source position: exec.pas line 877

type PSignalSemaphore = ^TSignalSemaphore;


PSNMMessage

Declaration

Source position: exec.pas line 631

type PSNMMessage = ^TSNMMessage;


PSoftIntList

For EXEC use ONLY!

Declaration

Source position: exec.pas line 658

type PSoftIntList = ^TSoftIntList;

See also

TExecBase


PStackSwapStruct

Stack swap structure as passed to StackSwap

Declaration

Source position: exec.pas line 769

type PStackSwapStruct = ^TStackSwapStruct;


PSTRPTR

Declaration

Source position: exec.pas line 28

type PSTRPTR = PPChar;


PTag

Declaration

Source position: exec.pas line 120

type PTag = ^LongWord;


PTagItem

Declaration

Source position: exec.pas line 122

type PTagItem = ^TTagItem;


PTask

Pointer to Task structure

Declaration

Source position: exec.pas line 742

type PTask = ^TTask;

Description

Every Amiga Task has one of these Task structures associated with it. To find yours, use FindTask(nil). Amiga processes tack a few more values on to the end of this structure, which is the difference between Tasks and Processes.

See also

FindTask | Find task by name get own task
AddTask | Add a Task to the System
RemTask | Remove a task from the system
SetTaskPri | Get and set the priority of a task
Signal | Signal a task


PTrackable

Declaration

Source position: exec.pas line 610

type PTrackable = ^TTrackable;


PULONG

Declaration

Source position: exec.pas line 40

type PULONG = ^LongWord;


PUnit

Declaration

Source position: exec.pas line 960

type PUnit = ^TUnit;


REG68K_A0

Declaration

Source position: exec.pas line 1393

const REG68K_A0 = 32;


REG68K_A1

Declaration

Source position: exec.pas line 1394

const REG68K_A1 = 36;


REG68K_A2

Declaration

Source position: exec.pas line 1395

const REG68K_A2 = 40;


REG68K_A3

Declaration

Source position: exec.pas line 1396

const REG68K_A3 = 44;


REG68K_A4

Declaration

Source position: exec.pas line 1397

const REG68K_A4 = 48;


REG68K_A5

Declaration

Source position: exec.pas line 1398

const REG68K_A5 = 52;


REG68K_A6

Declaration

Source position: exec.pas line 1399

const REG68K_A6 = 56;


REG68K_A7

Declaration

Source position: exec.pas line 1400

const REG68K_A7 = 60;


REG68K_D0

Declaration

Source position: exec.pas line 1385

const REG68K_D0 = 0;


REG68K_D1

Declaration

Source position: exec.pas line 1386

const REG68K_D1 = 4;


REG68K_D2

Declaration

Source position: exec.pas line 1387

const REG68K_D2 = 8;


REG68K_D3

Declaration

Source position: exec.pas line 1388

const REG68K_D3 = 12;


REG68K_D4

Declaration

Source position: exec.pas line 1389

const REG68K_D4 = 16;


REG68K_D5

Declaration

Source position: exec.pas line 1390

const REG68K_D5 = 20;


REG68K_D6

Declaration

Source position: exec.pas line 1391

const REG68K_D6 = 24;


REG68K_D7

Declaration

Source position: exec.pas line 1392

const REG68K_D7 = 28;


REG68K_FP0

Declaration

Source position: exec.pas line 1402

const REG68K_FP0 = 64;


REG68K_FP1

Declaration

Source position: exec.pas line 1403

const REG68K_FP1 = 72;


REG68K_FP2

Declaration

Source position: exec.pas line 1404

const REG68K_FP2 = 80;


REG68K_FP3

Declaration

Source position: exec.pas line 1405

const REG68K_FP3 = 88;


REG68K_FP4

Declaration

Source position: exec.pas line 1406

const REG68K_FP4 = 96;


REG68K_FP5

Declaration

Source position: exec.pas line 1407

const REG68K_FP5 = 104;


REG68K_FP6

Declaration

Source position: exec.pas line 1408

const REG68K_FP6 = 112;


REG68K_FP7

Declaration

Source position: exec.pas line 1409

const REG68K_FP7 = 120;


RTC_MATCHWORD

Matchword for rt_MatchWord

Declaration

Source position: exec.pas line 475

const RTC_MATCHWORD = $4AFC;


RTCF_FPU

Declaration

Source position: exec.pas line 701

const RTCF_FPU = 1 shl 3;


RTCF_GENERAL

Declaration

Source position: exec.pas line 700

const RTCF_GENERAL = 1 shl 2;


RTCF_INFO

Declaration

Source position: exec.pas line 703

const RTCF_INFO = 1 shl 5;


RTCF_SPECIAL

Declaration

Source position: exec.pas line 698

const RTCF_SPECIAL = 1 shl 0;


RTCF_STATE

Declaration

Source position: exec.pas line 699

const RTCF_STATE = 1 shl 1;


RTCF_VECTOR

Declaration

Source position: exec.pas line 702

const RTCF_VECTOR = 1 shl 4;


RTF_AFTERDOS

Flag for rt_Flags

Declaration

Source position: exec.pas line 480

const RTF_AFTERDOS = 1 shl 2;


RTF_AUTOINIT

Flag for rt_Flags

Declaration

Source position: exec.pas line 478

const RTF_AUTOINIT = 1 shl 7;


RTF_COLDSTART

Flag for rt_Flags

Declaration

Source position: exec.pas line 482

const RTF_COLDSTART = 1 shl 0;


RTF_NATIVE

Declaration

Source position: exec.pas line 479

const RTF_NATIVE = 1 shl 5;


RTF_SINGLETASK

Flag for rt_Flags

Declaration

Source position: exec.pas line 481

const RTF_SINGLETASK = 1 shl 1;


SDONA_SignalMask

Declaration

Source position: exec.pas line 1363

const SDONA_SignalMask = TAG_USER + $1021001;


SDONA_Task

Declaration

Source position: exec.pas line 1361

const SDONA_Task = TAG_USER + $1021000;


SIGB_ABORT

Declaration

Source position: exec.pas line 807

const SIGB_ABORT = 0;


SIGB_BLIT

Declaration

Source position: exec.pas line 809

const SIGB_BLIT = 4;


SIGB_CHILD

Declaration

Source position: exec.pas line 808

const SIGB_CHILD = 1;


SIGB_DOS

Declaration

Source position: exec.pas line 813

const SIGB_DOS = 8;


SIGB_INTUITION

Declaration

Source position: exec.pas line 811

const SIGB_INTUITION = 5;


SIGB_NET

Declaration

Source position: exec.pas line 812

const SIGB_NET = 7;


SIGB_SINGLE

Declaration

Source position: exec.pas line 810

const SIGB_SINGLE = 4;


SIGF_ABORT

Declaration

Source position: exec.pas line 816

const SIGF_ABORT = 1 shl SIGB_ABORT;


SIGF_BLIT

Declaration

Source position: exec.pas line 818

const SIGF_BLIT = 1 shl SIGB_BLIT;


SIGF_CHILD

Declaration

Source position: exec.pas line 817

const SIGF_CHILD = 1 shl SIGB_CHILD;


SIGF_DOS

Declaration

Source position: exec.pas line 822

const SIGF_DOS = 1 shl SIGB_DOS;


SIGF_INTUITION

Declaration

Source position: exec.pas line 820

const SIGF_INTUITION = 1 shl SIGB_INTUITION;


SIGF_NET

Declaration

Source position: exec.pas line 821

const SIGF_NET = 1 shl SIGB_NET;


SIGF_SINGLE

Declaration

Source position: exec.pas line 819

const SIGF_SINGLE = 1 shl SIGB_SINGLE;


SIH_PRIMASK

Declaration

Source position: exec.pas line 705

const SIH_PRIMASK = $F0;


SM_EXCLUSIVE

Declaration

Source position: exec.pas line 897

const SM_EXCLUSIVE = 0;


SM_SHARED

Declaration

Source position: exec.pas line 896

const SM_SHARED = 1;


SNMF_NAMESPACES_ONLY

Declaration

Source position: exec.pas line 641

const SNMF_NAMESPACES_ONLY = 1 shl 0;


STACK_FRAME_BACKCHAIN_PTR_LOOP

Declaration

Source position: exec.pas line 1326

const STACK_FRAME_BACKCHAIN_PTR_LOOP = 4;


STACK_FRAME_DECODED

Declaration

Source position: exec.pas line 1323

const STACK_FRAME_DECODED = 1;


STACK_FRAME_INVALID_BACKCHAIN_PTR

Declaration

Source position: exec.pas line 1324

const STACK_FRAME_INVALID_BACKCHAIN_PTR = 2;


STACK_FRAME_TRASHED_MEMORY_LOOP

Declaration

Source position: exec.pas line 1325

const STACK_FRAME_TRASHED_MEMORY_LOOP = 3;


STB_CRASHED

Declaration

Source position: exec.pas line 825

const STB_CRASHED = 0;


STB_REMOVED

Declaration

Source position: exec.pas line 826

const STB_REMOVED = 1;


STF_CRASHED

Declaration

Source position: exec.pas line 829

const STF_CRASHED = 1 shl STB_CRASHED;


STF_REMOVED

Declaration

Source position: exec.pas line 830

const STF_REMOVED = 1 shl STB_REMOVED;


STRPTR

Pointer to a string (compareable with a PChar)

Declaration

Source position: exec.pas line 27

type STRPTR = PChar;


Unit 'exec' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

Tag

Declaration

Source position: exec.pas line 119

type Tag = LongWord;


TAG_USER

Declaration

Source position: exec.pas line 117

const TAG_USER = $80000000;


TAVLKey

Declaration

Source position: exec.pas line 1298

type TAVLKey = Pointer;


TAVLNode

Declaration

Source position: exec.pas line 1293

type TAVLNode = record

  Reserved: array [0..3] of LongWord;

end;


TB_ETASK

Flag Bit for tc_Flags

Declaration

Source position: exec.pas line 780

const TB_ETASK = 3;


TB_EXCEPT

Flag Bit for tc_Flags Task gets no CPU time.

Declaration

Source position: exec.pas line 782

const TB_EXCEPT = 5;


TB_LAUNCH

Flag Bit for tc_Flags Task is switched to CPU.

Declaration

Source position: exec.pas line 784

const TB_LAUNCH = 7;


TB_PROCTIME

Flag Bit for tc_Flags Task uses CPU.

Declaration

Source position: exec.pas line 779

const TB_PROCTIME = 0;


TB_STACKCHK

Flag Bit for tc_Flags Stack is checked.

Declaration

Source position: exec.pas line 781

const TB_STACKCHK = 4;


TB_SWITCH

Flag Bit for tc_Flags Task is switched away from CPU.

Declaration

Source position: exec.pas line 783

const TB_SWITCH = 6;


TDebugOutputNotify

Declaration

Source position: exec.pas line 1355

type TDebugOutputNotify = record

end;


TDebugSymbol

Declaration

Source position: exec.pas line 1330

type TDebugSymbol = record

  StructSize: LongWord;

  Type_: LongWord;

  Name: PChar;

  Offset: LongWord;

  SegmentNumber: LongWord;

  SegmentOffset: LongWord;

  SourceFileName: PChar;

  SourceLineNumber: LongWord;

  SourceFunctionName: PChar;

  SourceBaseName: PChar;

end;


TDevice

Device has the same structure as an Library

Declaration

Source position: exec.pas line 955

type TDevice = record

  dd_Library: TLibrary;

Device has the same structure as an Library

end;


TDMAEntry

Declaration

Source position: exec.pas line 625

type TDMAEntry = record

  PhysicalAddress: Pointer;

  BlockLength: LongWord;

end;


TEmuTrap

Declaration

Source position: exec.pas line 1371

type TEmuTrap = record

  Instruction: LongWord;

  Type_: Byte;

  Function_: TEmuTrapfunction;

end;


TEmuTrapfunction

Declaration

Source position: exec.pas line 1369

type TEmuTrapfunction = procedure(

  Reg68K: PLongWord

);


TExceptionContext

Declaration

Source position: exec.pas line 665

type TExceptionContext = record

  Flags: LongWord;

  Traptype: LongWord;

  msr: LongWord;

  ip: LongWord;

  gpr: array [0..31] of LongWord;

  cr: LongWord;

  xer: LongWord;

  ctr: LongWord;

  lr: LongWord;

  dsisr: LongWord;

  dar: LongWord;

  fpr: array [0..31] of Double;

  fpscr: QWord;

  vscr: array [0..15] of Byte;

  vr: array [0..511] of Byte;

  vrsave: LongWord;

end;


TExecBase

Declaration

Source position: exec.pas line 1077

type TExecBase = record
LibNode: TLibrary; | Standard library structure
SoftVer: Word; | Kickstart release number
LowMemChkSum: SmallInt; | Lower memory checksum
ChkBase: LongWord; | System base address
ColdCapture: Pointer; | Cold boot address
CoolCapture: Pointer; |
WarmCapture: Pointer; | Warm start address
SysStkUpper: Pointer; | System stack: upper border
SysStkLower: Pointer; | System stack: lower border
MaxLocMem: LongWord; | Maximal useable memory
DebugEntry: Pointer; | Jump address for debugger
DebugData: Pointer; | Pointer to data for debugger
AlertData: Pointer; | Pointer to alert data
MaxExtMem: Pointer; | Maximal available external memory
ChkSum: Word; | Checksum of the upper values
IntVects: array [0..15] of TIntVector; | Vector table of interrupts
ThisTask: PTask; | Pointer of the currently running task
IdleCount: LongWord; | Idle Counter
DispCount: LongWord; | Dispatch Counter
Quantum: Word; | CPU time of every task
Elapsed: Word; |
SysFlags: Word; | Used cput time
IDNestCnt: ShortInt; | interrupt disable nesting count
TDNestCnt: ShortInt; | task disable nesting count
AttnFlags: Word; | special attention flags (readable)
AttnResched: Word; | rescheduling attention
ResModules: Pointer; | resident module array pointer
TaskTrapCode: Pointer; | Task - Pointer
TaskExceptCode: Pointer; |
TaskExitCode: Pointer; |
TaskSigAlloc: LongWord; | Task - Signals
TaskTrapAlloc: Word; | Task - Traps
MemList: TList; | List of available memory.
ResourceList: TList; | List of available resources.
DeviceList: TList; | List of available devices.
IntrList: TList; | List of available Interrupts
LibList: TList; | List of open libraries
PortList: TList; | List of open Ports.
TaskReady: TList; | Tasks with state Ready
TaskWait: TList; | Tasks with State waiting for singal
SoftInts: array [0..4] of TSoftIntList; |
LastAlert: array [0..3] of LongInt; | Last alert number
VBlankFrequency: Byte; |
PowerSupplyFrequency: Byte; |
SemaphoreList: TList; |
KickMemPtr: Pointer; | Pointer to queue of mem lists
KickTagPtr: Pointer; | Pointer to rom tag queue
KickCheckSum: Pointer; | Checksum for mem and tags
ex_Pad0: Word; |
ex_LaunchPoint: LongWord; |
ex_RamLibPrivate: Pointer; |
ex_EClockFrequency: LongWord; |
ex_CacheControl: LongWord; | Private to CacheControl calls
ex_TaskID: LongWord; | Next available Task ID
ex_Reserved1: array [0..4] of LongWord; |
ex_MMULock: Pointer; |
ex_Reserved2: array [0..2] of LongWord; |
ex_MemHandlers: TMinList; | Memory Handler List
ex_MemHandler: Pointer; |
MainInterface: PInterface;
Private01: Pointer;
Private02: LongWord;
Private03: Pointer;
Private04: Pointer;
Private05: Pointer;
Private06: TList;
Private07: Pointer;
EmuWS: Pointer;
end;


TF_ETASK

Flag value for tc_Flags

Declaration

Source position: exec.pas line 787

const TF_ETASK = 8;


TF_EXCEPT

Flag value for tc_Flags Task gets no CPU time.

Declaration

Source position: exec.pas line 789

const TF_EXCEPT = 32;


TF_LAUNCH

Flag value for tc_Flags Task is switched to CPU.

Declaration

Source position: exec.pas line 791

const TF_LAUNCH = 128;


TF_PROCTIME

Flag value for tc_Flags Task uses CPU.

Declaration

Source position: exec.pas line 786

const TF_PROCTIME = 1;


TF_STACKCHK

Flag value for tc_Flags Stack is checked.

Declaration

Source position: exec.pas line 788

const TF_STACKCHK = 16;


TF_SWITCH

Flag value for tc_Flags Task is switched away from CPU.

Declaration

Source position: exec.pas line 790

const TF_SWITCH = 64;


THook

Declaration

Source position: exec.pas line 130

type THook = record

  h_MinNode: TMinNode;

  h_Entry: Pointer;

  h_SubEntry: Pointer;

  h_Data: Pointer;

end;


TInterface

Declaration

Source position: exec.pas line 1046

type TInterface = record

  Data: TInterfaceData;

end;


TInterfaceData

Declaration

Source position: exec.pas line 1030

type TInterfaceData = record

  Link: TNode;

  LibBase: PLibrary;

  RefCount: LongWord;

  Version: LongWord;

  Flags: LongWord;

  CheckSum: LongWord;

  PositiveSize: LongWord;

  NegativeSize: LongWord;

  IExecPrivate: Pointer;

  EnvironmentVector: Pointer;

  Reserved3: LongWord;

  Reserved4: LongWord;

end;


TInterrupt

Declaration

Source position: exec.pas line 645

type TInterrupt = record
is_Node: TNode; |
is_Data: Pointer; | Server data segment
is_Code: TProcedure; | Server code entry
end;

See also

AddIntServer | Adds a interrupt server to the system
RemIntServer | Remove an interrupt server from a server chain
AddMemHandler |
RemMemHandler | Remove low memory handler from exec
Cause | Fire and software interrupt
SetIntVector | Set a new handler for a system interrupt vector


TIntVector

For EXEC use ONLY!

Declaration

Source position: exec.pas line 652

type TIntVector = record

  iv_Data: Pointer;

  iv_Code: TProcedure;

  iv_Node: PNode;

end;

See also

TExecBase


TIORequest

Declaration

Source position: exec.pas line 974

type TIORequest = record
io_Message: TMessage; | Message structure
io_Device: PDevice; | Pointer to the device to use
io_Unit: PUnit; | pointer to unit (depends on device)
io_Command: Word; | Command send to device (CMD_*)
io_Flags: Byte; | Device flags, different for every device.
io_Error: ShortInt; | Device error messages, different for every device.
end;


TIOStdReq

Declaration

Source position: exec.pas line 984

type TIOStdReq = record
io_Message: TMessage; | Message structure
io_Device: PDevice; | Pointer to device to use
io_Unit: PUnit; | Pointer to unit, depend on the device
io_Command: Word; | Command to sent to device
io_Flags: Byte; | Flags for device, depend on device.
io_Error: ShortInt; | Error of device, depend on device
io_Actual: LongWord; | Number of bytes sent to device
io_Length: LongWord; | Number of bytes transfered.
io_Data: Pointer; | Pointer to data buffer
io_Offset: LongWord; | Offset for block structured devices
end;


TLibrary

Library Base Structure

Declaration

Source position: exec.pas line 920

type TLibrary = record
lib_Node: TNode; | For integrating the library into the system lists.
lib_Flags: Byte; | Flags for the Library (LIBF_*)
lib_ABIVersion: Byte;
lib_NegSize: Word; | Size of vector tavle in bytes.
lib_PosSize: Word; | Size of data in bytes.
lib_Version: Word; | Version number of the library.
lib_Revision: Word; | Revision number of the library.
lib_IdString: PChar; | Pointer to identification text.
lib_Sum: LongWord; | Library checksum.
lib_OpenCnt: Word; | Openning counter. Counts how many times this library is currently open.
end;

Description

Also used for Devices and some Resources

See also

OpenLibrary | Open a library to use
CloseLibrary | Close access to library
AddLibrary | Adds a library to the system
MakeLibrary | Construct a library
RemLibrary | Remove a library from the system
SumLibrary | Compute and check the checksum on a library
SetFunction | Change a function vector in a library


TList

List header.

Declaration

Source position: exec.pas line 159

type TList = record
lh_Head: PNode; | Pointer to first node in list.
lh_Tail: PNode; | Pointer to last node in list.
lh_TailPred: PNode; | Pointer to node before last node in list.
lh_Type: Byte; | Type of List (NT_*)
l_pad: Byte; | Padding byte
end;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name
IsListEmpty | Check if a list is empty


TMemChunk

Declaration

Source position: exec.pas line 488

type TMemChunk = record
mc_Next: PMemChunk; | pointer to next chunk
mc_Bytes: LongWord; | chunk byte size
end;

See also

TMemHeader


TMemEntry

Declaration

Source position: exec.pas line 508

type TMemEntry = record

  me_Un: record

    case LongInt of

      0: (

          meu_Reqs: LongWord;

        );

      1: (

          meu_Addr: Pointer;

        );

  end;

  me_Length: LongWord;

end;

See also

TMemList

List of all available Memory


TMemHandlerData

Memory Handler

Declaration

Source position: exec.pas line 558

type TMemHandlerData = record
memh_RequestSize: LongWord; | Requested allocation size
memh_RequestFlags: LongWord; | Requested allocation flags
memh_Flags: LongWord; | Flags = MEMHF_RECYCLE
end;

Description

This structure is READ ONLY and only EXEC can create it!


TMemHeader

Declaration

Source position: exec.pas line 496

type TMemHeader = record
mh_Node: TNode; |
mh_Attributes: Word; | characteristics of this region (MEMF_*)
mh_First: PMemChunk; | first free region
mh_Lower: Pointer; | lower memory bound
mh_Upper: Pointer; | upper memory bound + 1
mh_Free: LongWord; | total number of free bytes
end;

See also

Allocate | Allocate a block of memory
Deallocate | Free a block of memory


TMemList

List of all available Memory

Declaration

Source position: exec.pas line 520

type TMemList = record
ml_Node: TNode; |
ml_NumEntries: Word; | Number of entries in this struct
ml_ME: array [0..0] of TMemEntry; | The first entry
end;

Description

Note: SizeOf(TMemList) includes the size of the first MemEntry!

See also

AllocEntry | Allocate many regions of memory
FreeEntry | Free many blocks of memory at once


TMessage

Message from/for a MessagePort

Declaration

Source position: exec.pas line 849

type TMessage = record
mn_Node: TNode; | Node for linking of different messages.
mn_ReplyPort: PMsgPort; | Message port for the reply message using ReplyMsg.
mn_Length: Word; | Length ob message in bytes
end;

See also

GetMsg | Get next message from message port
PutMsg | Put a message to a message port
ReplyMsg | Put a message to its reply port
WaitPort | Wait for a given port to be non-empty


TMinList

Minimal list strcture.

Declaration

Source position: exec.pas line 169

type TMinList = record
mlh_Head: PMinNode; | Pointer to first node in list.
mlh_Tail: PMinNode; | Pointer to last node in list.
mlh_TailPred: PMinNode; | Pointer to node before last node in list.
end;

Description

Exec system lists, which are used to link various things. Exec provides several routines to handle list processing, so you can use these routines to save yourself the trouble of writing a list package.

See also

AddHead | Insert a node at the head of a list
AddTail | Append node to tail of a list
RemHead | Remove the head node from a list
RemTail | Remove the tail node from a list
Remove | Remove a node from a list
Enqueue | Insert or append node to a system list
Exec.ExecInsert | Insert a node into a list
FindName | Find a node in a system list by name
IsListEmpty | Check if a list is empty


TMinNode

Minimal list entry without any type or name.

Declaration

Source position: exec.pas line 57

type TMinNode = record
mln_Succ: PMinNode; | Pointer next node of the list.
mln_Pred: PMinNode; | Pointer previous node of the list.
end;

See also

tNode

List node structure, Each member in a list starts with a node.


TMsgPort

Port for inter-task communication.

Declaration

Source position: exec.pas line 838

type TMsgPort = record
mp_Node: TNode; | Node for connections to other Msgports in the system.
mp_Flags: Byte; | Flags, showing if a message arrived at port. (PA_*)
mp_SigBit: Byte; | Number of signal bit dedicated to this port.
mp_SigTask: Pointer; | Pointer to task to get the signal.
mp_MsgList: TList; | List of all available messages
end;

See also

AddPort | Add a public message port to the system
RemPort | Remove a message port from the system
CreateIORequest | Create a structure usable for an I/O request
CreateMsgPort | Create a new message port
DeleteMsgPort | Free a message port
FindPort | Find a system message port by name
GetMsg | Get next message from message port
PutMsg | Put a message to a message port
WaitPort | Wait for a given port to be non-empty
tMessage | Message from/for a MessagePort


TNode

List node structure, Each member in a list starts with a node.

Declaration

Source position: exec.pas line 47

type TNode = record
ln_Succ: PNode; | Pointer next node of the list.
ln_Pred: PNode; | Pointer previous node of the list.
ln_Type: Byte; | Type code.
ln_Pri: ShortInt; | Priority of node, mainly for list sorting.
ln_Name: PChar; | Identification string
end;

See also

tMinNode | Minimal list entry without any type or name.
tList | List header.


TRACKF_COMPACT

Declaration

Source position: exec.pas line 620

const TRACKF_COMPACT = 1 shl 0;


TRAPINST

Declaration

Source position: exec.pas line 1378

const TRAPINST = $4ef80000;


TRAPNUM_ALIGNMENT

Declaration

Source position: exec.pas line 721

const TRAPNUM_ALIGNMENT = $04000000;


TRAPNUM_ALTIVEC_ASSIST

Declaration

Source position: exec.pas line 732

const TRAPNUM_ALTIVEC_ASSIST = $0f000000;


TRAPNUM_BUS_ERROR

Declaration

Source position: exec.pas line 718

const TRAPNUM_BUS_ERROR = $01000000;


TRAPNUM_DATA_BREAKPOINT

Declaration

Source position: exec.pas line 727

const TRAPNUM_DATA_BREAKPOINT = $0a000000;


TRAPNUM_DATA_SEGMENT_VIOLATION

Declaration

Source position: exec.pas line 719

const TRAPNUM_DATA_SEGMENT_VIOLATION = $02000000;


TRAPNUM_FPU

Declaration

Source position: exec.pas line 725

const TRAPNUM_FPU = $08000000;


TRAPNUM_ILLEGAL_INSTRUCTION

Declaration

Source position: exec.pas line 722

const TRAPNUM_ILLEGAL_INSTRUCTION = $05000000;


TRAPNUM_INST_BREAKPOINT

Declaration

Source position: exec.pas line 728

const TRAPNUM_INST_BREAKPOINT = $0b000000;


TRAPNUM_INST_SEGMENT_VIOLATION

Declaration

Source position: exec.pas line 720

const TRAPNUM_INST_SEGMENT_VIOLATION = $03000000;


TRAPNUM_NUMTRAPS

Declaration

Source position: exec.pas line 735

const TRAPNUM_NUMTRAPS = 16;


TRAPNUM_PERFORMANCE

Declaration

Source position: exec.pas line 729

const TRAPNUM_PERFORMANCE = $0c000000;


TRAPNUM_PRIVILEGE_VIOLATION

Declaration

Source position: exec.pas line 723

const TRAPNUM_PRIVILEGE_VIOLATION = $06000000;


TRAPNUM_RESERVED1

Declaration

Source position: exec.pas line 731

const TRAPNUM_RESERVED1 = $0e000000;


TRAPNUM_SMI

Declaration

Source position: exec.pas line 733

const TRAPNUM_SMI = $10000000;


TRAPNUM_THERMAL

Declaration

Source position: exec.pas line 730

const TRAPNUM_THERMAL = $0d000000;


TRAPNUM_TRACE

Declaration

Source position: exec.pas line 726

const TRAPNUM_TRACE = $09000000;


TRAPNUM_TRAP

Declaration

Source position: exec.pas line 724

const TRAPNUM_TRAP = $07000000;


TRAPTYPE

Declaration

Source position: exec.pas line 1379

const TRAPTYPE = $0004;


TRAPTYPENR

Declaration

Source position: exec.pas line 1380

const TRAPTYPENR = $0005;


TResident

Declaration

Source position: exec.pas line 461

type TResident = record
rt_MatchWord: Word; | smallint to match on RTC_MATCHWORD
rt_MatchTag: PResident; | pointer to the above
rt_EndSkip: Pointer; | address to continue scan
rt_Flags: Byte; | various tag flags (RTF_*)
rt_Version: Byte; | release version number
rt_Type: Byte; | type of module (NT_mumble)
rt_Pri: ShortInt; | initialization priority
rt_Name: PChar; | pointer to node name
rt_IdString: PChar; | pointer to ident string
rt_Init: Pointer; | pointer to init code
end;

Description

FindResident InitResident


TS_ADDED

Task State for tc_State Task is currently inserted in List.

Declaration

Source position: exec.pas line 796

const TS_ADDED = 1;


TS_CRASHED

Declaration

Source position: exec.pas line 802

const TS_CRASHED = 7;


TS_EXCEPT

Task State for tc_State Task gets no CPU time.

Declaration

Source position: exec.pas line 800

const TS_EXCEPT = 5;


TS_INVALID

Task State for tc_State Invalid Task.

Declaration

Source position: exec.pas line 795

const TS_INVALID = 0;


TS_READY

Task State for tc_State Task is ready to work.

Declaration

Source position: exec.pas line 798

const TS_READY = 3;


TS_REMOVED

Task State for tc_State Task is removed at the moment.

Declaration

Source position: exec.pas line 801

const TS_REMOVED = 6;


TS_RUN

Task State for tc_State Task is running.

Declaration

Source position: exec.pas line 797

const TS_RUN = 2;


TS_SUSPENDED

Declaration

Source position: exec.pas line 803

const TS_SUSPENDED = 8;


TS_WAIT

Task State for tc_State Task is waiting for a signal.

Declaration

Source position: exec.pas line 799

const TS_WAIT = 4;


TSemaphoreMessage

Declaration

Source position: exec.pas line 889

type TSemaphoreMessage = record

  ssm_Message: TMessage;

  ssm_Semaphore: PSignalSemaphore;

end;


TSemaphoreRequest

This is the structure used to request a signal semaphore

Declaration

Source position: exec.pas line 871

type TSemaphoreRequest = record

  sr_Link: TMinNode;

  sr_Waiter: PTask;

end;


TSignalSemaphore

Declaration

Source position: exec.pas line 878

type TSignalSemaphore = record

  ss_Link: TNode;

  ss_NestCount: SmallInt;

  ss_WaitQueue: TMinList;

  ss_MultipleLink: TSemaphoreRequest;

  ss_Owner: PTask;

  ss_QueueCount: SmallInt;

end;


TSNMMessage

Declaration

Source position: exec.pas line 632

type TSNMMessage = record

  Namespace: PChar;

  Name: PChar;

  Memory: Pointer;

  Size: LongWord;

  Flags: LongWord;

end;


TSoftIntList

For EXEC use ONLY!

Declaration

Source position: exec.pas line 659

type TSoftIntList = record

  sh_List: TList;

  sh_Pad: Word;

end;

See also

TExecBase


TStackFrameMsg

Declaration

Source position: exec.pas line 1314

type TStackFrameMsg = record

  StructSize: LongWord;

  State: LongWord;

  MemoryAddress: Pointer;

  StackPointer: PLongWord;

end;


TStackSwapStruct

Stack swap structure as passed to StackSwap

Declaration

Source position: exec.pas line 770

type TStackSwapStruct = record
stk_Lower: Pointer; | Lowest byte of stack
stk_Upper: LongWord; | Upper end of stack (size + Lowest)
stk_Pointer: Pointer; | Stack pointer at switch point
end;


TTagItem

Declaration

Source position: exec.pas line 123

type TTagItem = record

  ti_Tag: LongWord;

  ti_Data: LongWord;

end;


TTask

Every Amiga Task has one of these Task structures associated with it. To find yours, use FindTask(nil). Amiga processes tack a few more values on to the end of this structure, which is the difference between Tasks and Processes.

Declaration

Source position: exec.pas line 743

type TTask = record
tc_Node: TNode; | Node for connecting several tasks.
tc_Flags: Byte; | Task flags (TF_*)
tc_State: Byte; | Task status (TS_*)
tc_IDNestCnt: ShortInt; | Number of suppressed Interrupts
tc_TDNestCnt: ShortInt; | Number of suppressed Tasks
tc_SigAlloc: LongWord; | Signals reserved for this Task
tc_SigWait: LongWord; | Signals, the task wait for.
tc_SigRecvd: LongWord; | Signals, the task recieved
tc_SigExcept: LongWord; | Signals, which fires Exceptions
tc_ETask: Pointer; |
tc_ExceptData: Pointer; | Pointer to exception data.
tc_ExceptCode: Pointer; | Pointer to exception code
tc_TrapData: Pointer; | Pointer to trap data.
tc_TrapCode: Pointer; | Pointer to trap code
tc_SPReg: Pointer; | Pointer to Stack of Task
tc_SPLower: Pointer; | Lower border of stack.
tc_SPUpper: Pointer; | Upper border of stack + 2
tc_Switch: TProcedure; | Pointer to switch code (remove task from CPU)
tc_Launch: TProcedure; | Pointer to switch code (put task to CPU)
tc_MemEntry: TList; | Pointer to memory the task uses.
tc_UserData: Pointer; | Pointer for userdata.
end;

See also

FindTask | Find task by name get own task
AddTask | Add a Task to the System
RemTask | Remove a task from the system
SetTaskPri | Get and set the priority of a task
Signal | Signal a task


TTrackable

Declaration

Source position: exec.pas line 611

type TTrackable = record

  Destructor_: THook;

  Object_: Pointer;

  Flags: LongWord;

  HashChain: PTrackable;

end;


TUnit

Declaration

Source position: exec.pas line 961

type TUnit = record
unit_MsgPort: TMsgPort; | Pointer to message port for unprocessed messages
unit_flags: Byte; | Flags of Unit (UNITF_*)
unit_pad: Byte; | Padding byte
unit_OpenCnt: Word; | Number of open Requests
end;


UBYTE

unsigned 8-Bit Value

Declaration

Source position: exec.pas line 39

type UBYTE = Byte;


ULONG

unsigned 32-Bit integer value

Declaration

Source position: exec.pas line 29

type ULONG = LongWord;


UNITF_ACTIVE

tUnit is accessable

Declaration

Source position: exec.pas line 969

const UNITF_ACTIVE = 1 shl 0;


UNITF_INTASK

tUnit is currently working

Declaration

Source position: exec.pas line 970

const UNITF_INTASK = 1 shl 1;


UWORD

unsigned 16-Bit Value

Declaration

Source position: exec.pas line 35

type UWORD = Word;


VECTORTYPE_ALTIVEC

Declaration

Source position: exec.pas line 1665

const VECTORTYPE_ALTIVEC = 1;


VECTORTYPE_NONE

Declaration

Source position: exec.pas line 1664

const VECTORTYPE_NONE = 0;


WORDBITS

Declaration

Source position: exec.pas line 36

type WORDBITS = Word;


ICON_ASPECT_RATIO_UNKNOWN

Icon aspect ratio is not known.

Declaration

Source position: icon.pas line 126

const ICON_ASPECT_RATIO_UNKNOWN = 0;

See also

ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
IconControlA | Set and get icon and icon.library options


ICON_DRAGGED

Declaration

Source position: icon.pas line 201

const ICON_DRAGGED = $00000001;


ICON_DROPPABLE

Declaration

Source position: icon.pas line 202

const ICON_DROPPABLE = $00000002;


ICON_LEFTOUT

Declaration

Source position: icon.pas line 203

const ICON_LEFTOUT = $00000004;


ICON_POINTED

Declaration

Source position: icon.pas line 204

const ICON_POINTED = $00000008;


ICONA_Dummy

Start of icon.library tags

Declaration

Source position: icon.pas line 26

const ICONA_Dummy = TAG_USER + $9000;


ICONA_ErrorCode

Errorcode (PLongInt)

Declaration

Source position: icon.pas line 27

const ICONA_ErrorCode = ICONA_Dummy + 1;

Description

Pointer to a LongWord variable to store error codes in. Note that this variable will be initialized regardless of whether an error occured or not. Thus, you can check for an error condition by comparing the variable contents against 0; 0 indicates success, all other values are error codes as defined by dos.library.

See also

ICONA_ErrorTagItem

Points to the tag item that caused the error (^PTagItem)


ICONA_ErrorTagItem

Points to the tag item that caused the error (^PTagItem)

Declaration

Source position: icon.pas line 28

const ICONA_ErrorTagItem = ICONA_Dummy + 75;

See also

ICONA_ErrorCode

Errorcode (PLongInt)


ICONA_LAST_TAG

The last Tag of icon.library

Declaration

Source position: icon.pas line 220

const ICONA_LAST_TAG = ICONA_Dummy + 126;


ICONA_Reserved1

Reserved tag; don't use!

Declaration

Source position: icon.pas line 206

const ICONA_Reserved1 = ICONA_Dummy + 73;


ICONA_Reserved2

Reserved tag; don't use!

Declaration

Source position: icon.pas line 207

const ICONA_Reserved2 = ICONA_Dummy + 74;


ICONA_Reserved3

Reserved tag; don't use!

Declaration

Source position: icon.pas line 208

const ICONA_Reserved3 = ICONA_Dummy + 76;


ICONA_Reserved4

Reserved tag; don't use!

Declaration

Source position: icon.pas line 209

const ICONA_Reserved4 = ICONA_Dummy + 81;


ICONA_Reserved5

Reserved tag; don't use!

Declaration

Source position: icon.pas line 210

const ICONA_Reserved5 = ICONA_Dummy + 85;


ICONA_Reserved6

Reserved tag; don't use!

Declaration

Source position: icon.pas line 211

const ICONA_Reserved6 = ICONA_Dummy + 86;


ICONA_Reserved7

Reserved tag; don't use!

Declaration

Source position: icon.pas line 212

const ICONA_Reserved7 = ICONA_Dummy + 87;


ICONA_Reserved8

Reserved tag; don't use!

Declaration

Source position: icon.pas line 213

const ICONA_Reserved8 = ICONA_Dummy + 88;


ICONA_Reserved9

Declaration

Source position: icon.pas line 214

const ICONA_Reserved9 = ICONA_Dummy + 99;


ICONA_Reserved10

Declaration

Source position: icon.pas line 215

const ICONA_Reserved10 = ICONA_Dummy + 100;


ICONA_Reserved11

Declaration

Source position: icon.pas line 216

const ICONA_Reserved11 = ICONA_Dummy + 109;


ICONA_Reserved12

Declaration

Source position: icon.pas line 217

const ICONA_Reserved12 = ICONA_Dummy + 110;


ICONA_Reserved13

Declaration

Source position: icon.pas line 218

const ICONA_Reserved13 = ICONA_Dummy + 121;


IconBase

Declaration

Source position: icon.pas line 223

var IconBase: PLibrary;


ICONCTRLA_AddScaledSize

Declaration

Source position: icon.pas line 121

const ICONCTRLA_AddScaledSize = ICONA_Dummy + 115;


ICONCTRLA_GetAspectRatio

Tag for IconControlA(),

Declaration

Source position: icon.pas line 103

const ICONCTRLA_GetAspectRatio = ICONA_Dummy + 37;

Description

Per Icon Option for IconControlA() Get the icon aspect ratio; this consists of a numerator and a denominator packed into a single byte. If the icon aspect ratio is unknown, ICON_ASPECT_RATIO_UNKNOWN will be returned.

See also

ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
ICON_ASPECT_RATIO_UNKNOWN | Icon aspect ratio is not known.


ICONCTRLA_GetBitMap1

Declaration

Source position: icon.pas line 114

const ICONCTRLA_GetBitMap1 = ICONA_Dummy + 91;


ICONCTRLA_GetBitMap2

Declaration

Source position: icon.pas line 115

const ICONCTRLA_GetBitMap2 = ICONA_Dummy + 92;


ICONCTRLA_GetFrameless

Tag for IconControlA(), Get if rendered without frame (BOOL)

Declaration

Source position: icon.pas line 99

const ICONCTRLA_GetFrameless = ICONA_Dummy + 33;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetFrameless

Tag for IconControlA(), Set if rendered without frame (BOOL)


ICONCTRLA_GetGlobalColorIconSupport

Tag for IconControlA(), Get Status of color icon support (BOOL)

Declaration

Source position: icon.pas line 43

const ICONCTRLA_GetGlobalColorIconSupport = ICONA_Dummy + 78;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalColorIconSupport

Tag for IconControlA(), Enable color icon support (BOOL)


ICONCTRLA_GetGlobalEmbossRect

Tag for IconControlA(), Get Icon frame size dimensions (PRectange)

Declaration

Source position: icon.pas line 37

const ICONCTRLA_GetGlobalEmbossRect = ICONA_Dummy + 7;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalEmbossRect

Tag for IconControlA(), Icon frame size dimensions (PRectange)


ICONCTRLA_GetGlobalFrameless

Tag for IconControlA(), Get if images are rendered without frame (BOOL)

Declaration

Source position: icon.pas line 39

const ICONCTRLA_GetGlobalFrameless = ICONA_Dummy + 9;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalFrameless

Tag for IconControlA(), Render image without frame (BOOL)


ICONCTRLA_GetGlobalIdentifyHook

Tag for IconControlA(), Get the hook to be called when identifying a file (exec.PHook)

Declaration

Source position: icon.pas line 45

const ICONCTRLA_GetGlobalIdentifyHook = ICONA_Dummy + 13;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalIdentifyHook

Tag for IconControlA(), Set the hook to be called when identifying a file (exec.PHook)


ICONCTRLA_GetGlobalLeftOutMarking

Declaration

Source position: icon.pas line 49

const ICONCTRLA_GetGlobalLeftOutMarking = ICONA_Dummy + 97;


ICONCTRLA_GetGlobalMaxNameLength

Tag for IconControlA(), Get the maximum length of a file/drawer name supported by icon.library (LONG).

Declaration

Source position: icon.pas line 47

const ICONCTRLA_GetGlobalMaxNameLength = ICONA_Dummy + 68;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalMaxNameLength

Tag for IconControlA(), Set the maximum length of a file/drawer name supported by icon.library (LONG).


ICONCTRLA_GetGlobalNewIconsSupport

Tag for IconControlA(), Get Status of NewIcons support (BOOL)

Declaration

Source position: icon.pas line 41

const ICONCTRLA_GetGlobalNewIconsSupport = ICONA_Dummy + 11;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalNewIconsSupport

Tag for IconControlA(), Enable NewIcons support (BOOL)


ICONCTRLA_GetGlobalPrecision

Tag for IconControlA(), Get Icon color remapping precision (PLongInt)

Declaration

Source position: icon.pas line 35

const ICONCTRLA_GetGlobalPrecision = ICONA_Dummy + 5;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalPrecision

Tag for IconControlA(), Icon color remapping precision (LongInt)


ICONCTRLA_GetGlobalScreen

Tag for IconControlA(), Get the Screen which is used icons (^PScreen)

Declaration

Source position: icon.pas line 33

const ICONCTRLA_GetGlobalScreen = ICONA_Dummy + 3;

Description

Global Option for IconControlA()

See also

ICONCTRLA_SetGlobalScreen

Tag for IconControlA(), Screen to use for remapping Workbench icons to (PScreen)


ICONCTRLA_GetGlobalSelectEffect

Declaration

Source position: icon.pas line 51

const ICONCTRLA_GetGlobalSelectEffect = ICONA_Dummy + 114;


ICONCTRLA_GetHeight

Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 107

const ICONCTRLA_GetHeight = ICONA_Dummy + 41;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONCTRLA_GetIconFileFormat

Declaration

Source position: icon.pas line 120

const ICONCTRLA_GetIconFileFormat = ICONA_Dummy + 111;


ICONCTRLA_GetIconModuleData

Declaration

Source position: icon.pas line 119

const ICONCTRLA_GetIconModuleData = ICONA_Dummy + 106;


ICONCTRLA_GetImageData1

Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)

Declaration

Source position: icon.pas line 95

const ICONCTRLA_GetImageData1 = ICONA_Dummy + 29;

Description

Per Icon Option for IconControlA() Get the image data to be used for a palette mapped icon image, in this case the regular icon image (icon->do_Gadget.GadgetRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result.

See also

ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)


ICONCTRLA_GetImageData2

Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)

Declaration

Source position: icon.pas line 97

const ICONCTRLA_GetImageData2 = ICONA_Dummy + 31;

Description

Per Icon Option for IconControlA() Get the image data to be used for a palette mapped icon image, in this case the alternate icon image (icon->do_Gadget.SelectRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. If there is no alternate image, no information may be available.

See also

ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)


ICONCTRLA_GetImageDataFormat

Declaration

Source position: icon.pas line 117

const ICONCTRLA_GetImageDataFormat = ICONA_Dummy + 104;


ICONCTRLA_GetImageMask1

Tag for IconControlA(), Get the icon rendering mask 1 (PLANEPTR)

Declaration

Source position: icon.pas line 80

const ICONCTRLA_GetImageMask1 = ICONA_Dummy + 14;

Description

Per Icon Option for IconControlA() Pointer to the mask plane for the regular icon image (Icon^.do_Gadget.GadgetRender). Note that this may be nil.

See also

ICONCTRLA_GetImageMask2

Tag for IconControlA(), Get the icon rendering mask 2 (PLANEPTR)


ICONCTRLA_GetImageMask2

Tag for IconControlA(), Get the icon rendering mask 2 (PLANEPTR)

Declaration

Source position: icon.pas line 81

const ICONCTRLA_GetImageMask2 = ICONA_Dummy + 15;

Description

Per Icon Option for IconControlA() Pointer to the mask plane for the alternate icon image (Icon^.do_Gadget.SelectRender). Note that this may be nil.

See also

ICONCTRLA_GetImageMask1

Tag for IconControlA(), Get the icon rendering mask 1 (PLANEPTR)


ICONCTRLA_GetNewIconsSupport

Tag for IconControlA(), Get if NewIcons support is enabled (BOOL)

Declaration

Source position: icon.pas line 101

const ICONCTRLA_GetNewIconsSupport = ICONA_Dummy + 35;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetNewIconsSupport

Tag for IconControlA(), Set if NewIcons support is enabled (BOOL)


ICONCTRLA_GetPalette1

Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)

Declaration

Source position: icon.pas line 87

const ICONCTRLA_GetPalette1 = ICONA_Dummy + 21;

Description

Per Icon Option for IconControlA() Get the colour palette for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. Note that the number of palette entries in this table matches the number of colours in use when the icon was first created.

See also

ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_GetPalette2

Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)

Declaration

Source position: icon.pas line 89

const ICONCTRLA_GetPalette2 = ICONA_Dummy + 23;

Description

Per Icon Option for IconControlA() Get the colour palette for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. If there is no alternate image, no information may be available. Note that the number of palette entries in this table matches the number of colours in use when the icon was first created.

See also

ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_GetPaletteSize1

Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)

Declaration

Source position: icon.pas line 91

const ICONCTRLA_GetPaletteSize1 = ICONA_Dummy + 25;

Description

Per Icon Option for IconControlA() Get the size of the colour palette to be used for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result.

See also

ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_GetPaletteSize2

Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)

Declaration

Source position: icon.pas line 93

const ICONCTRLA_GetPaletteSize2 = ICONA_Dummy + 27;

Description

Per Icon Option for IconControlA() Get the size of the colour palette to be used for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. If there is no alternate image, no information may be available.

See also

ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_GetScreen

Tag for IconControlA(), Get the screen the icon is attached to (^PScreen).

Declaration

Source position: icon.pas line 109

const ICONCTRLA_GetScreen = ICONA_Dummy + 43;

Description

Per Icon Option for IconControlA()


ICONCTRLA_GetTransparentColor1

Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)

Declaration

Source position: icon.pas line 83

const ICONCTRLA_GetTransparentColor1 = ICONA_Dummy + 17;

Description

Per Icon Option for IconControlA() Get the transparent colour for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). If the image is opaque, its "transparent colour" will be returned as -1. Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result.

See also

ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque


ICONCTRLA_GetTransparentColor2

Tag for IconControlA(), Get second transparent image color; -1 if opaque

Declaration

Source position: icon.pas line 85

const ICONCTRLA_GetTransparentColor2 = ICONA_Dummy + 19;

Description

Per Icon Option for IconControlA() Get the transparent colour for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). If the image is opaque, its "transparent colour" will be returned as -1. Note that this data is valid only for palette mapped icons; for other types, you may not receive any meaningful result. Likewise, if there is no alternate image, no information may be available.

See also

ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque


ICONCTRLA_GetWidth

Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 105

const ICONCTRLA_GetWidth = ICONA_Dummy + 39;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONCTRLA_HasRealImage2

Tag for IconControlA(), Check whether the icon has a real select image (PLongInt).

Declaration

Source position: icon.pas line 110

const ICONCTRLA_HasRealImage2 = ICONA_Dummy + 44;

Description

Per Icon Option for IconControlA()


ICONCTRLA_IsNativeIcon

Tag for IconControlA(), Check whether this icon was allocated by icon.library or if consists solely of a statically allocated struct DiskObject. (PLongInt).

Declaration

Source position: icon.pas line 112

const ICONCTRLA_IsNativeIcon = ICONA_Dummy + 80;

Description

Per Icon Option for IconControlA() There is an important difference between struct DiskObject icons allocated by icon.library itself (these are the so-called "native" icons) and statically initialized icons which consist solely of a simple struct DiskObject which may be part of a program's static data area. For example, you can attach a palette mapped icon image to a "native" icon, which is something you cannot do with a statically allocated icon. To help you tell the two types apart, you can use the ICONCTRLA_IsNativeIcon query tag.


ICONCTRLA_IsNewIcon

Tag for IconControlA(), Check whether the icon is of the NewIcon type (PLongInt).

Declaration

Source position: icon.pas line 111

const ICONCTRLA_IsNewIcon = ICONA_Dummy + 79;

Description

Per Icon Option for IconControlA()


ICONCTRLA_IsPaletteMapped

Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).

Declaration

Source position: icon.pas line 108

const ICONCTRLA_IsPaletteMapped = ICONA_Dummy + 42;

Description

Per Icon Option for IconControlA()


ICONCTRLA_RemScaledSize

Declaration

Source position: icon.pas line 122

const ICONCTRLA_RemScaledSize = ICONA_Dummy + 116;


ICONCTRLA_SetAspectRatio

Tag for IconControlA(), Set Icon aspect ratio (PBYTE)

Declaration

Source position: icon.pas line 102

const ICONCTRLA_SetAspectRatio = ICONA_Dummy + 36;

Description

Per Icon Option for IconControlA() Set the icon aspect ratio; this consists of a numerator and a denominator packed into a single byte (PACK_ICON_ASPECT_RATIO can be used for encoding this parameter). If the icon aspect ratio is unknown, ICON_ASPECT_RATIO_UNKNOWN should be used.

See also

ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
PACK_ICON_ASPECT_RATIO | Pack Numerator and a denominator into a single byte as icon aspect
ICON_ASPECT_RATIO_UNKNOWN | Icon aspect ratio is not known.


ICONCTRLA_SetFrameless

Tag for IconControlA(), Set if rendered without frame (BOOL)

Declaration

Source position: icon.pas line 98

const ICONCTRLA_SetFrameless = ICONA_Dummy + 32;

Description

Per Icon Option for IconControlA() This option defaults to False.

See also

ICONCTRLA_GetFrameless

Tag for IconControlA(), Get if rendered without frame (BOOL)


ICONCTRLA_SetGlobalColorIconSupport

Tag for IconControlA(), Enable color icon support (BOOL)

Declaration

Source position: icon.pas line 42

const ICONCTRLA_SetGlobalColorIconSupport = ICONA_Dummy + 77;

Description

Global Option for IconControlA() This option defaults to True.

See also

ICONCTRLA_GetGlobalColorIconSupport

Tag for IconControlA(), Get Status of color icon support (BOOL)


ICONCTRLA_SetGlobalEmbossRect

Tag for IconControlA(), Icon frame size dimensions (PRectange)

Declaration

Source position: icon.pas line 36

const ICONCTRLA_SetGlobalEmbossRect = ICONA_Dummy + 6;

Description

Global Option for IconControlA()

Set the frame sizes used for drawing icons. The Rectangle must be initialized as follows:

Rectangle^.MinX
Width of left edge border (negative), must be in the range [-255..-1]
Rectangle^.MinY
Height of top edge border (negative), must be in the range [-255..-1]
Rectangle^.MaxX
Width of right edge border (positive), must be in the range [1..255]
Rectangle^.MaxY
Height of bottom edge border (positive), must be in the range [1..255]

See also

ICONCTRLA_GetGlobalEmbossRect

Tag for IconControlA(), Get Icon frame size dimensions (PRectange)


ICONCTRLA_SetGlobalFrameless

Tag for IconControlA(), Render image without frame (BOOL)

Declaration

Source position: icon.pas line 38

const ICONCTRLA_SetGlobalFrameless = ICONA_Dummy + 8;

Description

Global Option for IconControlA() This option defaults to False.

See also

ICONCTRLA_GetGlobalFrameless

Tag for IconControlA(), Get if images are rendered without frame (BOOL)


ICONCTRLA_SetGlobalIdentifyHook

Tag for IconControlA(), Set the hook to be called when identifying a file (exec.PHook)

Declaration

Source position: icon.pas line 44

const ICONCTRLA_SetGlobalIdentifyHook = ICONA_Dummy + 12;

Description

Global Option for IconControlA()

Set the hook that is invoked when trying to find an icon for a file/drawer/volume that does not have an icon associated with it. If set to nil, no hook will be called. The hook will be called with the following parameters:

procedure HookFunc(Hook: Phook; reserved: APTR; IIMsg: PIconIdentifyMsg); cdecl;

The reserved parameter will be set to nil

See also

ICONCTRLA_GetGlobalIdentifyHook

Tag for IconControlA(), Get the hook to be called when identifying a file (exec.PHook)


ICONCTRLA_SetGlobalLeftOutMarking

Declaration

Source position: icon.pas line 48

const ICONCTRLA_SetGlobalLeftOutMarking = ICONA_Dummy + 96;


ICONCTRLA_SetGlobalMaxNameLength

Tag for IconControlA(), Set the maximum length of a file/drawer name supported by icon.library (LONG).

Declaration

Source position: icon.pas line 46

const ICONCTRLA_SetGlobalMaxNameLength = ICONA_Dummy + 67;

Description

Global Option for IconControlA()

icon.library has a built-in file name length limit that affects whether icon files are read and written. Currently, the default for this value is 25 characters. This is sufficient for an icon file name acceptable with the ROM filing system. This limit has two effects: if an icon file is to be written whose name would be longer than the limit, icon.library will silently abort the write attempt and pretend that the icon file has been written; this is done in order to avoid overwriting the original data file with the icon file. If an icon file was read that turns out to contain invalid icon data, another test is done in order to find out whether the file name was longer than the limit. If this is the case, it is assumed that the data was read from the original file rather than from the icon file. The library then pretends that the icon file was not found.

This tag can be used to set this length limit. The limit must be in the range [8..255].

See also

ICONCTRLA_GetGlobalMaxNameLength

Tag for IconControlA(), Get the maximum length of a file/drawer name supported by icon.library (LONG).


ICONCTRLA_SetGlobalNewIconsSupport

Tag for IconControlA(), Enable NewIcons support (BOOL)

Declaration

Source position: icon.pas line 40

const ICONCTRLA_SetGlobalNewIconsSupport = ICONA_Dummy + 10;

Description

Global Option for IconControlA() This option defaults to True.

See also

ICONCTRLA_GetGlobalNewIconsSupport

Tag for IconControlA(), Get Status of NewIcons support (BOOL)


ICONCTRLA_SetGlobalPrecision

Tag for IconControlA(), Icon color remapping precision (LongInt)

Declaration

Source position: icon.pas line 34

const ICONCTRLA_SetGlobalPrecision = ICONA_Dummy + 4;

Description

Global Option for IconControlA(), Default is PRECISION_ICON.

See also

ICONCTRLA_GetGlobalPrecision

Tag for IconControlA(), Get Icon color remapping precision (PLongInt)


ICONCTRLA_SetGlobalScreen

Tag for IconControlA(), Screen to use for remapping Workbench icons to (PScreen)

Declaration

Source position: icon.pas line 32

const ICONCTRLA_SetGlobalScreen = ICONA_Dummy + 2;

Description

Global Option for IconControlA(),Pointer to the screen to remap palette mapped icons to. This is commonly used by workbench.library after it has initialized itself and before/after screen open/close transitions. If the screen is set to nil, the icon colour remapping strategy is changed: colours are no longer allocated from a screen and the colours to map to will come from a default colour colour table with four palette entries. Please note that once you select a screen to remap to, you cannot tell icon.library to use a different screen; you first need to tell icon.library to "let go" of the previously selected screen by passing a nil ICONCTRLA_SetGlobalScreen parameter. You can set a different screen only after this is done.

See also

ICONCTRLA_GetGlobalScreen

Tag for IconControlA(), Get the Screen which is used icons (^PScreen)


ICONCTRLA_SetGlobalSelectEffect

Declaration

Source position: icon.pas line 50

const ICONCTRLA_SetGlobalSelectEffect = ICONA_Dummy + 113;


ICONCTRLA_SetHeight

Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 106

const ICONCTRLA_SetHeight = ICONA_Dummy + 40;

Description

Per Icon Option for IconControlA() This value must be in the range [1..256].

See also

ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONCTRLA_SetIconModuleData

Declaration

Source position: icon.pas line 118

const ICONCTRLA_SetIconModuleData = ICONA_Dummy + 105;


ICONCTRLA_SetImageData1

Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)

Declaration

Source position: icon.pas line 94

const ICONCTRLA_SetImageData1 = ICONA_Dummy + 28;

Description

Per Icon Option for IconControlA() Set the image data to be used for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). There must be exactly as many bytes of image data as the image width multiplied by its height requires. To drop the palette mapped image data associated with an icon, use "ICONCTRLA_SetImageData1,nil".

See also

ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)


ICONCTRLA_SetImageData2

Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)

Declaration

Source position: icon.pas line 96

const ICONCTRLA_SetImageData2 = ICONA_Dummy + 30;

Description

Per Icon Option for IconControlA() Set the image data to be used for a palette mapped icon image, in this case the alternate icon image (icon->do_Gadget.SelectRender). There must be exactly as many bytes of image data as the image width multiplied by its height requires. To drop the palette mapped image data associated with the alternate image of an icon, use "ICONCTRLA_SetImageData1,nil".

See also

ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)


ICONCTRLA_SetImageDataFormat

Declaration

Source position: icon.pas line 116

const ICONCTRLA_SetImageDataFormat = ICONA_Dummy + 103;


ICONCTRLA_SetNewIconsSupport

Tag for IconControlA(), Set if NewIcons support is enabled (BOOL)

Declaration

Source position: icon.pas line 100

const ICONCTRLA_SetNewIconsSupport = ICONA_Dummy + 34;

Description

Per Icon Option for IconControlA()

See also

ICONCTRLA_GetNewIconsSupport

Tag for IconControlA(), Get if NewIcons support is enabled (BOOL)


ICONCTRLA_SetPalette1

Tag for IconControlA(), Set Image color palette 1 (PColorRegister)

Declaration

Source position: icon.pas line 86

const ICONCTRLA_SetPalette1 = ICONA_Dummy + 20;

Description

Per Icon Option for IconControlA() Set the colour palette for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender).

See also

ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_SetPalette2

Tag for IconControlA(), Set Image color palette 2 (PColorRegister)

Declaration

Source position: icon.pas line 88

const ICONCTRLA_SetPalette2 = ICONA_Dummy + 22;

Description

Per Icon Option for IconControlA() Set the colour palette for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender).

See also

ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)


ICONCTRLA_SetPaletteSize1

Tag for IconControlA(), Set Size of image color palette 1 (LongInt)

Declaration

Source position: icon.pas line 90

const ICONCTRLA_SetPaletteSize1 = ICONA_Dummy + 24;

Description

Per Icon Option for IconControlA() Set the size of the colour palette to be used for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). This value must be in the range [1..256].

See also

ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_SetPaletteSize2

Tag for IconControlA(), Set Size of image color palette 2 (LongInt)

Declaration

Source position: icon.pas line 92

const ICONCTRLA_SetPaletteSize2 = ICONA_Dummy + 26;

Description

Per Icon Option for IconControlA() Set the size of the colour palette to be used for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). This value must be in the range [1..256].

See also

ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)


ICONCTRLA_SetTransparentColor1

Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)

Declaration

Source position: icon.pas line 82

const ICONCTRLA_SetTransparentColor1 = ICONA_Dummy + 16;

Description

Per Icon Option for IconControlA() Set the transparent colour for a palette mapped icon image, in this case the regular icon image (icon^.do_Gadget.GadgetRender). The colour must be among the valid palette entries, e.g. for a 16 colour image, the transparent colour may not be larger than 15. To make the icon image opaque, set its transparent colour to -1.

See also

ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque


ICONCTRLA_SetTransparentColor2

Tag for IconControlA(), Set second transparent image color; set to -1 if opaque

Declaration

Source position: icon.pas line 84

const ICONCTRLA_SetTransparentColor2 = ICONA_Dummy + 18;

Description

Per Icon Option for IconControlA() Set the transparent colour for a palette mapped icon image, in this case the alternate icon image (icon^.do_Gadget.SelectRender). The colour must be among the valid palette entries, e.g. for a 16 colour image, the transparent colour may not be larger than 15. To make the icon image opaque, set its transparent colour to -1. Please note that you can set the alternate image transparent colour only if there is an alternate image.

See also

ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque


ICONCTRLA_SetWidth

Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)

Declaration

Source position: icon.pas line 104

const ICONCTRLA_SetWidth = ICONA_Dummy + 38;

Description

Per Icon Option for IconControlA() This value must be in the range [1..256].

See also

ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).


ICONCTRLA_UseFriendBitMap

Declaration

Source position: icon.pas line 113

const ICONCTRLA_UseFriendBitMap = ICONGETA_UseFriendBitMap;


ICONDRAWA_AllowUpscaling

Declaration

Source position: icon.pas line 198

const ICONDRAWA_AllowUpscaling = ICONGETA_AllowUpscaling;


ICONDRAWA_Borderless

Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding border and frame (BOOL).

Declaration

Source position: icon.pas line 187

const ICONDRAWA_Borderless = ICONA_Dummy + 83;

Description

This tag defaults to False.


ICONDRAWA_Borders

Declaration

Source position: icon.pas line 199

const ICONDRAWA_Borders = ICONA_Dummy + 125;


ICONDRAWA_DrawIcon

Declaration

Source position: icon.pas line 192

const ICONDRAWA_DrawIcon = ICONA_Dummy + 98;


ICONDRAWA_DrawInfo

Tag for DrawIconStateA() and GetIconRectangleA, Drawing information to use (PDrawInfo).

Declaration

Source position: icon.pas line 184

const ICONDRAWA_DrawInfo = ICONA_Dummy + 66;

Description

Drawing information data associated with the RastPort to draw into. The DrawInfo contents affect the colours of the border drawn around the icon image and also carry display aspect ratio information. If this tag is nil, the default rendering pens for the screen selected via IconControlA(...,ICONCTRLA_SetGlobalScreen,...); will be used instead. This tag defaults to nil.


ICONDRAWA_EraseBackground

Tag for DrawIconStateA() and GetIconRectangleA, Erase the background before drawing a frameless icon (BOOL).

Declaration

Source position: icon.pas line 186

const ICONDRAWA_EraseBackground = ICONA_Dummy + 71;

Description

This tag defaults to True.


ICONDRAWA_EraseLabelBackground

Declaration

Source position: icon.pas line 193

const ICONDRAWA_EraseLabelBackground = ICONA_Dummy + 101;


ICONDRAWA_Frameless

Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding frame (BOOL).

Declaration

Source position: icon.pas line 185

const ICONDRAWA_Frameless = ICONA_Dummy + 70;

Description

This tag defaults to False.


ICONDRAWA_Height

Declaration

Source position: icon.pas line 196

const ICONDRAWA_Height = ICONGETA_Height;


ICONDRAWA_IsLink

Declaration

Source position: icon.pas line 188

const ICONDRAWA_IsLink = ICONA_Dummy + 89;


ICONDRAWA_LabelOutline

Declaration

Source position: icon.pas line 190

const ICONDRAWA_LabelOutline = ICONA_Dummy + 94;


ICONDRAWA_LabelShadow

Declaration

Source position: icon.pas line 189

const ICONDRAWA_LabelShadow = ICONA_Dummy + 93;


ICONDRAWA_Properties

Declaration

Source position: icon.pas line 191

const ICONDRAWA_Properties = ICONA_Dummy + 95;


ICONDRAWA_SizeBounds

Declaration

Source position: icon.pas line 197

const ICONDRAWA_SizeBounds = ICONGETA_SizeBounds;


ICONDRAWA_Transparency

Declaration

Source position: icon.pas line 194

const ICONDRAWA_Transparency = ICONA_Dummy + 102;


ICONDRAWA_Width

Declaration

Source position: icon.pas line 195

const ICONDRAWA_Width = ICONGETA_Width;


ICONDUPA_ActivateImageData

Tag for DupDiskObjectA(), If the icon to be duplicated is in fact a palette mapped icon which has never been set up to be displayed on the screen, turn the duplicate into that palette mapped icon.

Declaration

Source position: icon.pas line 173

const ICONDUPA_ActivateImageData = ICONA_Dummy + 82;

Description

If the source icon contains palette mapped image data that was never put to use (this happens if it is retrieved with the GetDiskObject() call rather than the new GetIconTagList() call), this tag will cause the image data to be analyzed and an attempt to be made to use that image data in the duplicate. The resulting icon will be remapped for display on the default screen, such as the Workbench screen.

This tag defaults to False.


ICONDUPA_AllowUpscaling

Declaration

Source position: icon.pas line 181

const ICONDUPA_AllowUpscaling = ICONGETA_AllowUpscaling;


ICONDUPA_DuplicateDefaultTool

Tag for DupDiskObjectA(), Duplicate the default tool.

Declaration

Source position: icon.pas line 170

const ICONDUPA_DuplicateDefaultTool = ICONA_Dummy + 63;

Description

This tag defaults to True.


ICONDUPA_DuplicateDrawerData

Tag for DupDiskObjectA(), Duplicate do_DrawerData

Declaration

Source position: icon.pas line 167

const ICONDUPA_DuplicateDrawerData = ICONA_Dummy + 60;

Description

This tag defaults to True.


ICONDUPA_DuplicateImageData

Tag for DupDiskObjectA(), Duplicate the image data (Image->ImageData) itself.

Declaration

Source position: icon.pas line 169

const ICONDUPA_DuplicateImageData = ICONA_Dummy + 62;

Description

Duplicate the icon image data; this tag works together with the ICONDUPA_DuplicateImages tag. If ICONDUPA_DuplicateImageData is set to True, you must also set ICONDUPA_DuplicateImages to True.

This tag defaults to TRUE.


ICONDUPA_DuplicateImages

Tag for DupDiskObjectA(), Duplicate the Image structures.

Declaration

Source position: icon.pas line 168

const ICONDUPA_DuplicateImages = ICONA_Dummy + 61;

Description

Duplicate the icon images; note that this DOES NOT include the associated image data. To get the image data duplicated, too, also use the ICONDUPA_DuplicateImageData tag.

This tag defaults to True.


ICONDUPA_DuplicateScaledSizes

Declaration

Source position: icon.pas line 176

const ICONDUPA_DuplicateScaledSizes = ICONA_Dummy + 119;


ICONDUPA_DuplicateToolTypes

Tag for DupDiskObjectA(), Duplicate the tool types list.

Declaration

Source position: icon.pas line 171

const ICONDUPA_DuplicateToolTypes = ICONA_Dummy + 64;

Description

This tag defaults to True.


ICONDUPA_DuplicateToolWindow

Tag for DupDiskObjectA(), Duplicate the tool window.

Declaration

Source position: icon.pas line 172

const ICONDUPA_DuplicateToolWindow = ICONA_Dummy + 65;

Description

This tag defaults to True.


ICONDUPA_ForceScaling

Declaration

Source position: icon.pas line 179

const ICONDUPA_ForceScaling = ICONGETA_ForceScaling;


ICONDUPA_Height

Declaration

Source position: icon.pas line 178

const ICONDUPA_Height = ICONGETA_Height;


ICONDUPA_SizeBounds

Declaration

Source position: icon.pas line 180

const ICONDUPA_SizeBounds = ICONGETA_SizeBounds;


ICONDUPA_UseFriendBitMap

Declaration

Source position: icon.pas line 175

const ICONDUPA_UseFriendBitMap = ICONGETA_UseFriendBitMap;


ICONDUPA_Width

Declaration

Source position: icon.pas line 177

const ICONDUPA_Width = ICONGETA_Width;


ICONGETA_AllowUpscaling

Declaration

Source position: icon.pas line 77

const ICONGETA_AllowUpscaling = ICONA_Dummy + 126;


ICONGETA_FailIfUnavailable

Tag for GetIconTagList(), Return a default icon if the requested icon file cannot be found (BOOL).

Declaration

Source position: icon.pas line 62

const ICONGETA_FailIfUnavailable = ICONA_Dummy + 47;

Description

If there is no icon for the specified object, this tag will control how to proceed: if ICONGETA_FailIfUnavailable is set to True, NULL and an error code will be returned; if set to False, icon.library will first invoke the global identification hook (see IconControlA) and then, if necessary, provide a default icon for the object in question. This tag defaults to True.


ICONGETA_FileFormat

Declaration

Source position: icon.pas line 70

const ICONGETA_FileFormat = ICONA_Dummy + 112;


ICONGETA_ForceScaling

Declaration

Source position: icon.pas line 73

const ICONGETA_ForceScaling = ICONA_Dummy + 120;


ICONGETA_GenerateImageMasks

Tag for GetIconTagList(), Generate icon image masks (BOOL).

Declaration

Source position: icon.pas line 66

const ICONGETA_GenerateImageMasks = ICONA_Dummy + 51;

Description

When loading icons with transparent colours or backfill imagery, bit plane masks will be generated for later use with DrawIconStateA(). If you do not need these masks, set this tag to FALSE. This tag defaults to TRUE.


ICONGETA_GetDefaultName

Tag for GetIconTagList(), Retrieve default icon for the given name (PChar)

Declaration

Source position: icon.pas line 61

const ICONGETA_GetDefaultName = ICONA_Dummy + 46;

Description

Query whether this icon is associated with a file/drawer/volume or is a "fake" icon that was constructed for an object that has no icon associated with it.


ICONGETA_GetDefaultType

Tag for GetIconTagList(), Default icon type to retrieve (LongInt)

Declaration

Source position: icon.pas line 60

const ICONGETA_GetDefaultType = ICONA_Dummy + 45;

Description

Type of the default icon to retrieve; must be one of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK. If this tag is used, the "name" parameter will be ignored.


ICONGETA_GetPaletteMappedIcon

Tag for GetIconTagList(), If possible, retrieve a palette mapped icon (BOOL).

Declaration

Source position: icon.pas line 63

const ICONGETA_GetPaletteMappedIcon = ICONA_Dummy + 48;

Description

By default, icon.library will try to retrieve the palette mapped version of an icon. To change this, set the ICONGETA_GetPaletteMappedIcon tag to False. This tag defaults to True.


ICONGETA_Height

Declaration

Source position: icon.pas line 72

const ICONGETA_Height = ICONA_Dummy + 118;


ICONGETA_IdentifyBuffer

Declaration

Source position: icon.pas line 74

const ICONGETA_IdentifyBuffer = ICONA_Dummy + 122;


ICONGETA_IdentifyOnly

Declaration

Source position: icon.pas line 75

const ICONGETA_IdentifyOnly = ICONA_Dummy + 123;


ICONGETA_IsDefaultIcon

Tag for GetIconTagList(), Set if the icon returned is a default icon (PLongBool).

Declaration

Source position: icon.pas line 64

const ICONGETA_IsDefaultIcon = ICONA_Dummy + 49;

Description

When retrieving an icon with the ICONGETA_FailIfUnavailable tag set to False, you may receive a default icon because there is no on-disk icon file for the object you wanted to retrieve it for. This type of default icon is also known as a "fake" icon. To find out whether you have received a fake icon, use the ICONGETA_IsDefaultIcon tag.


ICONGETA_Label

Tag for GetIconTagList(), Label text to be assigned to the icon (PChar).

Declaration

Source position: icon.pas line 67

const ICONGETA_Label = ICONA_Dummy + 52;

Description

The label text to be printed below the icon when it is put to use lateron. This parameter can be useful to figure out the type of the icon to be retrieved by the identification hook. For example, Workbench may label unreadable disk icons as "DF0:????". The identification hook could key on this and supply an appropriate icon for the disk. This tag defaults to NULL.


ICONGETA_RemapIcon

Tag for GetIconTagList(), Remap the icon to the default screen, if possible (BOOL).

Declaration

Source position: icon.pas line 65

const ICONGETA_RemapIcon = ICONA_Dummy + 50;

Description

Palette mapped icons will usually be automatically remapped for display on the screen selected using IconControlA. If you do not want this to happen because, for example, you want to use LayoutIconA instead, you can set the ICONGETA_RemapIcon tag to FALSE. Take care when doing this as the icon returned to you will have nil pointers in the do_Gadget.GadgetRender and do_Gadget.SelectRender members. This tag defaults to TRUE.


ICONGETA_Screen

Tag for GetIconTagList(), Screen to remap the icon to (PScreen).

Declaration

Source position: icon.pas line 68

const ICONGETA_Screen = ICONA_Dummy + 69;

Description

Pointer to the screen to remap the icon to; if set to nil, this keeps the icon from getting remapped in the first place (see ICONGETA_RemapIcon for the consequences). This tag defaults to the default screen to remap to, as preset by IconControlA().


ICONGETA_SizeBounds

Declaration

Source position: icon.pas line 76

const ICONGETA_SizeBounds = ICONA_Dummy + 124;


ICONGETA_UseFriendBitMap

Declaration

Source position: icon.pas line 69

const ICONGETA_UseFriendBitMap = ICONA_Dummy + 90;


ICONGETA_Width

Declaration

Source position: icon.pas line 71

const ICONGETA_Width = ICONA_Dummy + 117;


ICONNAME

Icon library name

Declaration

Source position: icon.pas line 24

const ICONNAME: PChar = 'icon.library';


ICONPUTA_DropChunkyIconImage

Tag for PutIconTagList(), Don't write the chunky icon image data to disk. (BOOL)

Declaration

Source position: icon.pas line 134

const ICONPUTA_DropChunkyIconImage = ICONA_Dummy + 57;

Description

This tag can be used to keep the chunky icon image data from getting written to disk. This tag defaults to FALSE.


ICONPUTA_DropNewIconToolTypes

Tag for PutIconTagList(), Don't write the NewIcons tool types to disk. (BOOL)

Declaration

Source position: icon.pas line 135

const ICONPUTA_DropNewIconToolTypes = ICONA_Dummy + 58;

Description

This tag controls whether any NewIcon tool types will be omitted when writing the icon to disk. TRUE will omit the data. This tag defaults to FALSE.


ICONPUTA_DropPlanarIconImage

Tag for PutIconTagList(), Do not store planar icon image (BOOL)

Declaration

Source position: icon.pas line 133

const ICONPUTA_DropPlanarIconImage = ICONA_Dummy + 56;

Description

If you decide that the palette mapped icon imagery is sufficient to represent an icon, you can tell icon.library not to store the original, planar icon image data with the icon file. To do this, set this tag to True. Instead of the planar icon images, a single default image will be stored. This can result in space savings but may not look too pretty. This tag defaults to False.


ICONPUTA_FileFormat

Declaration

Source position: icon.pas line 141

const ICONPUTA_FileFormat = ICONA_Dummy + 107;


ICONPUTA_NoFallback

Declaration

Source position: icon.pas line 142

const ICONPUTA_NoFallback = ICONA_Dummy + 108;


ICONPUTA_NotifyWorkbench

Tag for PutIconTagList(), Notify Workbench of the icon being written (BOOL)

Declaration

Source position: icon.pas line 130

const ICONPUTA_NotifyWorkbench = ICONA_Dummy + 53;

Description

Set this to True to notify Workbench of the fact that an icon was changed. This tag defaults to False.


ICONPUTA_OnlyUpdatePosition

Tag for PutIconTagList(), Write only new position. (Bool)

Declaration

Source position: icon.pas line 137

const ICONPUTA_OnlyUpdatePosition = ICONA_Dummy + 72;

Description

This tag can be used to reduce the overhead in updating icon information on disk if the only information changed is the icon position. For this case, you can set this tag to TRUE. The icon to be modified will have only its do_CurrentX/do_CurrentY member values changed, the remainer will stay unmodified. Please note that this tag only takes effect if the ICONPUTA_PutDefaultType and ICONPUTA_PutDefaultName tags are omitted.


ICONPUTA_OptimizeImageSpace

Tag for PutIconTagList(), Try to compress image data (BOOL)

Declaration

Source position: icon.pas line 136

const ICONPUTA_OptimizeImageSpace = ICONA_Dummy + 59;

Description

A palette mapped icon image might not use the entire icon palette. By default, icon.library does not bother about this, it expects the creator of the icon to choose its palette efficiently. But just in case, you can tell icon.library to attempt to identify how many colours are really in use and to optimize its image compressor for them. This may take extra time and is not recommended for daily use. This tag defaults to False.


ICONPUTA_PreserveOldIconImages

Tag for PutIconTagList(), Save old image before writing (BOOL)

Declaration

Source position: icon.pas line 138

const ICONPUTA_PreserveOldIconImages = ICONA_Dummy + 84;

Description

Before writing a palette mapped icon back to disk, icon.library will make sure that the original planar image data is stored in the file. If you don't want that to happen, set this option to False. This will allow you to change the planar icon image data written back to disk.


ICONPUTA_PutDefaultName

Tag for PutIconTagList(), Store icon as a default for the given name (PChar)

Declaration

Source position: icon.pas line 132

const ICONPUTA_PutDefaultName = ICONA_Dummy + 55;

Description

Name of the default object type this icon is to be stored as. If this tag is used, the "name" parameter will be ignored.


ICONPUTA_PutDefaultType

Tag for PutIconTagList(), Store icon as the default for this type (LongInt)

Declaration

Source position: icon.pas line 131

const ICONPUTA_PutDefaultType = ICONA_Dummy + 54;

Description

Type of the default icon to retrieve; must be one of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK. If this tag is used, the "name" parameter will be ignored.


IIcon

Declaration

Source position: icon.pas line 224

var IIcon: PInterface;


Reference for unit 'icon'

Icon handling routines (icon.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
Workbench, | Basic Workbench/AppIcons functions (workbench.library)
utility, | Tag Handling, Date routines in utility.library
amigados, | File and directory handling routines and types (dos.library)
agraphics, | Native Amiga graphic functions (graphics.library)
intuition; | Screen and Window handling routines of intuition.library

Overview

Functions and structures to work with Icons.


Reference for unit 'icon': Constants

ICONA_Dummy | Start of icon.library tags
ICONA_ErrorCode | Errorcode (PLongInt)
ICONA_ErrorTagItem | Points to the tag item that caused the error (^PTagItem)
ICONA_LAST_TAG | The last Tag of icon.library
ICONA_Reserved1 | Reserved tag; don't use!
ICONA_Reserved10
ICONA_Reserved11
ICONA_Reserved12
ICONA_Reserved13
ICONA_Reserved2 | Reserved tag; don't use!
ICONA_Reserved3 | Reserved tag; don't use!
ICONA_Reserved4 | Reserved tag; don't use!
ICONA_Reserved5 | Reserved tag; don't use!
ICONA_Reserved6 | Reserved tag; don't use!
ICONA_Reserved7 | Reserved tag; don't use!
ICONA_Reserved8 | Reserved tag; don't use!
ICONA_Reserved9
ICONCTRLA_AddScaledSize
ICONCTRLA_GetAspectRatio | Tag for IconControlA(),
ICONCTRLA_GetBitMap1
ICONCTRLA_GetBitMap2
ICONCTRLA_GetFrameless | Tag for IconControlA(), Get if rendered without frame (BOOL)
ICONCTRLA_GetGlobalColorIconSupport | Tag for IconControlA(), Get Status of color icon support (BOOL)
ICONCTRLA_GetGlobalEmbossRect | Tag for IconControlA(), Get Icon frame size dimensions (PRectange)
ICONCTRLA_GetGlobalFrameless | Tag for IconControlA(), Get if images are rendered without frame (BOOL)
ICONCTRLA_GetGlobalIdentifyHook | Tag for IconControlA(), Get the hook to be called when identifying a file (exec.PHook)
ICONCTRLA_GetGlobalLeftOutMarking
ICONCTRLA_GetGlobalMaxNameLength | Tag for IconControlA(), Get the maximum length of a file/drawer name supported by icon.library (LONG).
ICONCTRLA_GetGlobalNewIconsSupport | Tag for IconControlA(), Get Status of NewIcons support (BOOL)
ICONCTRLA_GetGlobalPrecision | Tag for IconControlA(), Get Icon color remapping precision (PLongInt)
ICONCTRLA_GetGlobalScreen | Tag for IconControlA(), Get the Screen which is used icons (^PScreen)
ICONCTRLA_GetGlobalSelectEffect
ICONCTRLA_GetHeight | Tag for IconControlA(), Get Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_GetIconFileFormat
ICONCTRLA_GetIconModuleData
ICONCTRLA_GetImageData1 | Tag for IconControlA(), Get Image 1 data; one by per pixel (PPBYTE)
ICONCTRLA_GetImageData2 | Tag for IconControlA(), Get Image 2 data; one by per pixel (PPBYTE)
ICONCTRLA_GetImageDataFormat
ICONCTRLA_GetImageMask1 | Tag for IconControlA(), Get the icon rendering mask 1 (PLANEPTR)
ICONCTRLA_GetImageMask2 | Tag for IconControlA(), Get the icon rendering mask 2 (PLANEPTR)
ICONCTRLA_GetNewIconsSupport | Tag for IconControlA(), Get if NewIcons support is enabled (BOOL)
ICONCTRLA_GetPalette1 | Tag for IconControlA(), Get Image color palette 1 (PPColorRegister)
ICONCTRLA_GetPalette2 | Tag for IconControlA(), Get Image color palette 2 (PPColorRegister)
ICONCTRLA_GetPaletteSize1 | Tag for IconControlA(), Get Size of image color palette 1 (PLongInt)
ICONCTRLA_GetPaletteSize2 | Tag for IconControlA(), Get Size of image color palette 2 (PLongInt)
ICONCTRLA_GetScreen | Tag for IconControlA(), Get the screen the icon is attached to (^PScreen).
ICONCTRLA_GetTransparentColor1 | Tag for IconControlA(), Get first transparent image color; -1 if opaque (PLongInt)
ICONCTRLA_GetTransparentColor2 | Tag for IconControlA(), Get second transparent image color; -1 if opaque
ICONCTRLA_GetWidth | Tag for IconControlA(), Get Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_HasRealImage2 | Tag for IconControlA(), Check whether the icon has a real select image (PLongInt).
ICONCTRLA_IsNativeIcon | Tag for IconControlA(), Check whether this icon was allocated by icon.library or if consists solely of a statically allocated struct DiskObject. (PLongInt).
ICONCTRLA_IsNewIcon | Tag for IconControlA(), Check whether the icon is of the NewIcon type (PLongInt).
ICONCTRLA_IsPaletteMapped | Tag for IconControlA(), Check whether the icon is palette mapped (PLongInt).
ICONCTRLA_RemScaledSize
ICONCTRLA_SetAspectRatio | Tag for IconControlA(), Set Icon aspect ratio (PBYTE)
ICONCTRLA_SetFrameless | Tag for IconControlA(), Set if rendered without frame (BOOL)
ICONCTRLA_SetGlobalColorIconSupport | Tag for IconControlA(), Enable color icon support (BOOL)
ICONCTRLA_SetGlobalEmbossRect | Tag for IconControlA(), Icon frame size dimensions (PRectange)
ICONCTRLA_SetGlobalFrameless | Tag for IconControlA(), Render image without frame (BOOL)
ICONCTRLA_SetGlobalIdentifyHook | Tag for IconControlA(), Set the hook to be called when identifying a file (exec.PHook)
ICONCTRLA_SetGlobalLeftOutMarking
ICONCTRLA_SetGlobalMaxNameLength | Tag for IconControlA(), Set the maximum length of a file/drawer name supported by icon.library (LONG).
ICONCTRLA_SetGlobalNewIconsSupport | Tag for IconControlA(), Enable NewIcons support (BOOL)
ICONCTRLA_SetGlobalPrecision | Tag for IconControlA(), Icon color remapping precision (LongInt)
ICONCTRLA_SetGlobalScreen | Tag for IconControlA(), Screen to use for remapping Workbench icons to (PScreen)
ICONCTRLA_SetGlobalSelectEffect
ICONCTRLA_SetHeight | Tag for IconControlA(), Set Icon Height, valid only for palette mapped icon images (LongInt)
ICONCTRLA_SetIconModuleData
ICONCTRLA_SetImageData1 | Tag for IconControlA(), Set Image 1 data; one by per pixel (PBYTE)
ICONCTRLA_SetImageData2 | Tag for IconControlA(), Set Image 2 data; one by per pixel (PBYTE)
ICONCTRLA_SetImageDataFormat
ICONCTRLA_SetNewIconsSupport | Tag for IconControlA(), Set if NewIcons support is enabled (BOOL)
ICONCTRLA_SetPalette1 | Tag for IconControlA(), Set Image color palette 1 (PColorRegister)
ICONCTRLA_SetPalette2 | Tag for IconControlA(), Set Image color palette 2 (PColorRegister)
ICONCTRLA_SetPaletteSize1 | Tag for IconControlA(), Set Size of image color palette 1 (LongInt)
ICONCTRLA_SetPaletteSize2 | Tag for IconControlA(), Set Size of image color palette 2 (LongInt)
ICONCTRLA_SetTransparentColor1 | Tag for IconControlA(), Set first transparent image color; set to -1 if opaque (LongInt)
ICONCTRLA_SetTransparentColor2 | Tag for IconControlA(), Set second transparent image color; set to -1 if opaque
ICONCTRLA_SetWidth | Tag for IconControlA(), Set Icon Width, valid only for palette mapped icon images (LongInt)
ICONCTRLA_UseFriendBitMap
ICONDRAWA_AllowUpscaling
ICONDRAWA_Borderless | Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding border and frame (BOOL).
ICONDRAWA_Borders
ICONDRAWA_DrawIcon
ICONDRAWA_DrawInfo | Tag for DrawIconStateA() and GetIconRectangleA, Drawing information to use (PDrawInfo).
ICONDRAWA_EraseBackground | Tag for DrawIconStateA() and GetIconRectangleA, Erase the background before drawing a frameless icon (BOOL).
ICONDRAWA_EraseLabelBackground
ICONDRAWA_Frameless | Tag for DrawIconStateA() and GetIconRectangleA, Draw the icon without the surrounding frame (BOOL).
ICONDRAWA_Height
ICONDRAWA_IsLink |
ICONDRAWA_LabelOutline
ICONDRAWA_LabelShadow
ICONDRAWA_Properties
ICONDRAWA_SizeBounds
ICONDRAWA_Transparency
ICONDRAWA_Width
ICONDUPA_ActivateImageData | Tag for DupDiskObjectA(), If the icon to be duplicated is in fact a palette mapped icon which has never been set up to be displayed on the screen, turn the duplicate into that palette mapped icon.
ICONDUPA_AllowUpscaling
ICONDUPA_DuplicateDefaultTool | Tag for DupDiskObjectA(), Duplicate the default tool.
ICONDUPA_DuplicateDrawerData | Tag for DupDiskObjectA(), Duplicate do_DrawerData
ICONDUPA_DuplicateImageData | Tag for DupDiskObjectA(), Duplicate the image data (Image->ImageData) itself.
ICONDUPA_DuplicateImages | Tag for DupDiskObjectA(), Duplicate the Image structures.
ICONDUPA_DuplicateScaledSizes
ICONDUPA_DuplicateToolTypes | Tag for DupDiskObjectA(), Duplicate the tool types list.
ICONDUPA_DuplicateToolWindow | Tag for DupDiskObjectA(), Duplicate the tool window.
ICONDUPA_ForceScaling
ICONDUPA_Height
ICONDUPA_SizeBounds
ICONDUPA_UseFriendBitMap
ICONDUPA_Width
ICONGETA_AllowUpscaling
ICONGETA_FailIfUnavailable | Tag for GetIconTagList(), Return a default icon if the requested icon file cannot be found (BOOL).
ICONGETA_FileFormat
ICONGETA_ForceScaling
ICONGETA_GenerateImageMasks | Tag for GetIconTagList(), Generate icon image masks (BOOL).
ICONGETA_GetDefaultName | Tag for GetIconTagList(), Retrieve default icon for the given name (PChar)
ICONGETA_GetDefaultType | Tag for GetIconTagList(), Default icon type to retrieve (LongInt)
ICONGETA_GetPaletteMappedIcon | Tag for GetIconTagList(), If possible, retrieve a palette mapped icon (BOOL).
ICONGETA_Height
ICONGETA_IdentifyBuffer
ICONGETA_IdentifyOnly
ICONGETA_IsDefaultIcon | Tag for GetIconTagList(), Set if the icon returned is a default icon (PLongBool).
ICONGETA_Label | Tag for GetIconTagList(), Label text to be assigned to the icon (PChar).
ICONGETA_RemapIcon | Tag for GetIconTagList(), Remap the icon to the default screen, if possible (BOOL).
ICONGETA_Screen | Tag for GetIconTagList(), Screen to remap the icon to (PScreen).
ICONGETA_SizeBounds
ICONGETA_UseFriendBitMap
ICONGETA_Width
ICONNAME | Icon library name
ICONPUTA_DropChunkyIconImage | Tag for PutIconTagList(), Don't write the chunky icon image data to disk. (BOOL)
ICONPUTA_DropNewIconToolTypes | Tag for PutIconTagList(), Don't write the NewIcons tool types to disk. (BOOL)
ICONPUTA_DropPlanarIconImage | Tag for PutIconTagList(), Do not store planar icon image (BOOL)
ICONPUTA_FileFormat
ICONPUTA_NoFallback
ICONPUTA_NotifyWorkbench | Tag for PutIconTagList(), Notify Workbench of the icon being written (BOOL)
ICONPUTA_OnlyUpdatePosition | Tag for PutIconTagList(), Write only new position. (Bool)
ICONPUTA_OptimizeImageSpace | Tag for PutIconTagList(), Try to compress image data (BOOL)
ICONPUTA_PreserveOldIconImages | Tag for PutIconTagList(), Save old image before writing (BOOL)
ICONPUTA_PutDefaultName | Tag for PutIconTagList(), Store icon as a default for the given name (PChar)
ICONPUTA_PutDefaultType | Tag for PutIconTagList(), Store icon as the default for this type (LongInt)
ICON_ASPECT_RATIO_UNKNOWN | Icon aspect ratio is not known.
ICON_DRAGGED
ICON_DROPPABLE
ICON_LEFTOUT
ICON_POINTED
SEL_BRIGHTEN
SEL_DARKEN
SEL_IMPOSE
SEL_NEGATIVE
SEL_ROTATERGB


Reference for unit 'icon': Types

PIconIdentifyMsg | Pointer to file identification structure
TIconIdentifyMsg | Tag for use with the file identification hook.
TToolTypeArray


PIconIdentifyMsg

Pointer to file identification structure

Declaration

Source position: icon.pas line 146

type PIconIdentifyMsg = ^TIconIdentifyMsg;


SEL_BRIGHTEN

Declaration

Source position: icon.pas line 54

const SEL_BRIGHTEN = $01000000;


SEL_DARKEN

Declaration

Source position: icon.pas line 53

const SEL_DARKEN = $00000000;


SEL_IMPOSE

Declaration

Source position: icon.pas line 55

const SEL_IMPOSE = $02000000;


SEL_NEGATIVE

Declaration

Source position: icon.pas line 56

const SEL_NEGATIVE = $03000000;


SEL_ROTATERGB

Declaration

Source position: icon.pas line 57

const SEL_ROTATERGB = $04000000;


TIconIdentifyMsg

Tag for use with the file identification hook.

Declaration

Source position: icon.pas line 147

type TIconIdentifyMsg = record
iim_SysBase: PLibrary; | ExecBase already opened for your use
iim_DOSBase: PLibrary; | DosBase already opened for your use
iim_UtilityBase: PLibrary; | Utility Base already opened for your use
iim_IconBase: PLibrary; | IconBase already opened for your use
iim_FileLock: LongInt; | Lock on the object to return an icon for.
iim_ParentLock: LongInt; | Lock on the object's parent directory, if available.
iim_FIB: PFileInfoBlock; | Already initialized for you.
iim_FileHandle: LongInt; | If non-NULL, pointer to the file to examine, positioned right at the first byte, ready for you to use.
iim_Tags: PTagItem; | Tags passed to GetIconTagList().
iim_IExec: PInterface;
iim_IDOS: PInterface;
iim_IUtility: PInterface;
iim_IIcon: PInterface;
end;


TToolTypeArray

Declaration

Source position: icon.pas line 269

type TToolTypeArray = array of AnsiString;


ID_CAT

Declaration

Source position: iffparse.pas line 120

const ID_CAT = 1128354848;


ID_FORM

Declaration

Source position: iffparse.pas line 118

const ID_FORM = 1179603533;


ID_LIST

Declaration

Source position: iffparse.pas line 119

const ID_LIST = 1279873876;


ID_NULL

Declaration

Source position: iffparse.pas line 122

const ID_NULL = 538976288;


ID_PROP

Declaration

Source position: iffparse.pas line 121

const ID_PROP = 1347571536;


IFF_RETURN2CLIENT

Declaration

Source position: iffparse.pas line 115

const IFF_RETURN2CLIENT = - 12;


IFFCMD_CLEANUP

Declaration

Source position: iffparse.pas line 146

const IFFCMD_CLEANUP = 1;


IFFCMD_ENTRY

Declaration

Source position: iffparse.pas line 150

const IFFCMD_ENTRY = 5;


IFFCMD_EXIT

Declaration

Source position: iffparse.pas line 151

const IFFCMD_EXIT = 6;


IFFCMD_INIT

Declaration

Source position: iffparse.pas line 145

const IFFCMD_INIT = 0;


IFFCMD_PURGELCI

Declaration

Source position: iffparse.pas line 152

const IFFCMD_PURGELCI = 7;


IFFCMD_READ

Declaration

Source position: iffparse.pas line 147

const IFFCMD_READ = 2;


IFFCMD_SEEK

Declaration

Source position: iffparse.pas line 149

const IFFCMD_SEEK = 4;


IFFCMD_WRITE

Declaration

Source position: iffparse.pas line 148

const IFFCMD_WRITE = 3;


IFFERR_EOC

Declaration

Source position: iffparse.pas line 105

const IFFERR_EOC = - 2;


IFFERR_EOF

Declaration

Source position: iffparse.pas line 104

const IFFERR_EOF = - 1;


IFFERR_MANGLED

Declaration

Source position: iffparse.pas line 111

const IFFERR_MANGLED = - 8;


IFFERR_NOHOOK

Declaration

Source position: iffparse.pas line 114

const IFFERR_NOHOOK = - 11;


IFFERR_NOMEM

Declaration

Source position: iffparse.pas line 107

const IFFERR_NOMEM = - 4;


IFFERR_NOSCOPE

Declaration

Source position: iffparse.pas line 106

const IFFERR_NOSCOPE = - 3;


IFFERR_NOTIFF

Declaration

Source position: iffparse.pas line 113

const IFFERR_NOTIFF = - 10;


IFFERR_READ

Declaration

Source position: iffparse.pas line 108

const IFFERR_READ = - 5;


IFFERR_SEEK

Declaration

Source position: iffparse.pas line 110

const IFFERR_SEEK = - 7;


IFFERR_SYNTAX

Declaration

Source position: iffparse.pas line 112

const IFFERR_SYNTAX = - 9;


IFFERR_WRITE

Declaration

Source position: iffparse.pas line 109

const IFFERR_WRITE = - 6;


IFFF_FSEEK

Declaration

Source position: iffparse.pas line 41

const IFFF_FSEEK = 1 shl 1;


IFFF_READ

Declaration

Source position: iffparse.pas line 38

const IFFF_READ = 0;


IFFF_RESERVED

Declaration

Source position: iffparse.pas line 43

const IFFF_RESERVED = $FFFF0000;


IFFF_RSEEK

Declaration

Source position: iffparse.pas line 42

const IFFF_RSEEK = 1 shl 2;


IFFF_RWBITS

Declaration

Source position: iffparse.pas line 40

const IFFF_RWBITS = IFFF_READ + IFFF_WRITE;


IFFF_WRITE

Declaration

Source position: iffparse.pas line 39

const IFFF_WRITE = 1;


IFFLCI_COLLECTION

Declaration

Source position: iffparse.pas line 125

const IFFLCI_COLLECTION = 1668246636;


IFFLCI_ENTRYHANDLER

Declaration

Source position: iffparse.pas line 126

const IFFLCI_ENTRYHANDLER = 1701734500;


IFFLCI_EXITHANDLER

Declaration

Source position: iffparse.pas line 127

const IFFLCI_EXITHANDLER = 1702389860;


IFFLCI_PROP

Declaration

Source position: iffparse.pas line 124

const IFFLCI_PROP = 1886547824;


IFFPARSE_RAWSTEP

Declaration

Source position: iffparse.pas line 132

const IFFPARSE_RAWSTEP = 2;


IFFPARSE_SCAN

Declaration

Source position: iffparse.pas line 130

const IFFPARSE_SCAN = 0;


IFFPARSE_STEP

Declaration

Source position: iffparse.pas line 131

const IFFPARSE_STEP = 1;


IFFParseBase

Declaration

Source position: iffparse.pas line 158

var IFFParseBase: PLibrary = Nil;


IFFPARSENAME

Declaration

Source position: iffparse.pas line 155

const IFFPARSENAME: PChar = 'iffparse.library';


IFFSIZE_UNKNOWN

Declaration

Source position: iffparse.pas line 141

const IFFSIZE_UNKNOWN = - 1;


IFFSLI_PROP

Declaration

Source position: iffparse.pas line 137

const IFFSLI_PROP = 3;


IFFSLI_ROOT

Declaration

Source position: iffparse.pas line 135

const IFFSLI_ROOT = 1;


IFFSLI_TOP

Declaration

Source position: iffparse.pas line 136

const IFFSLI_TOP = 2;


IIFFParse

Declaration

Source position: iffparse.pas line 159

var IIFFParse: PInterface = Nil;


Reference for unit 'iffparse'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
clipboard,
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'iffparse': Constants

ID_CAT

ID_FORM

ID_LIST

ID_NULL

ID_PROP

IFFCMD_CLEANUP

IFFCMD_ENTRY

IFFCMD_EXIT

IFFCMD_INIT

IFFCMD_PURGELCI

IFFCMD_READ

IFFCMD_SEEK

IFFCMD_WRITE

IFFERR_EOC

IFFERR_EOF

IFFERR_MANGLED

IFFERR_NOHOOK

IFFERR_NOMEM

IFFERR_NOSCOPE

IFFERR_NOTIFF

IFFERR_READ

IFFERR_SEEK

IFFERR_SYNTAX

IFFERR_WRITE

IFFF_FSEEK

IFFF_READ

IFFF_RESERVED

IFFF_RSEEK

IFFF_RWBITS

IFFF_WRITE

IFFLCI_COLLECTION

IFFLCI_ENTRYHANDLER

IFFLCI_EXITHANDLER

IFFLCI_PROP

IFFPARSENAME

IFFPARSE_RAWSTEP

IFFPARSE_SCAN

IFFPARSE_STEP

IFFSIZE_UNKNOWN

IFFSLI_PROP

IFFSLI_ROOT

IFFSLI_TOP

IFF_RETURN2CLIENT


Reference for unit 'iffparse': Types

PClipboardHandle

PCollectionItem

PContextNode

PIFFHandle

PIFFStreamCmd

PLocalContextItem

PStoredProperty

TClipboardHandle

TCollectionItem

TContextNode

TIFFHandle

TIFFStreamCmd

TLocalContextItem

TStoredProperty


PClipboardHandle

Declaration

Source position: iffparse.pas line 93

type PClipboardHandle = ^TClipBoardHandle;


PCollectionItem

Declaration

Source position: iffparse.pas line 85

type PCollectionItem = ^TCollectionItem;


PContextNode

Declaration

Source position: iffparse.pas line 58

type PContextNode = ^TContextNode;


PIFFHandle

Declaration

Source position: iffparse.pas line 29

type PIFFHandle = ^TIFFHandle;


PIFFStreamCmd

Declaration

Source position: iffparse.pas line 47

type PIFFStreamCmd = ^TIFFStreamCmd;


PLocalContextItem

Declaration

Source position: iffparse.pas line 69

type PLocalContextItem = ^TLocalContextItem;


PStoredProperty

Declaration

Source position: iffparse.pas line 77

type PStoredProperty = ^TStoredProperty;


TClipboardHandle

Declaration

Source position: iffparse.pas line 94

type TClipboardHandle = record

  cbh_Req: TIOClipReq;

  cbh_CBport: TMsgPort;

  cbh_SatisfyPort: TMsgPort;

end;


TCollectionItem

Declaration

Source position: iffparse.pas line 86

type TCollectionItem = record

  ci_Next: PCollectionItem;

  ci_Size: LongInt;

  ci_Data: Pointer;

end;


TContextNode

Declaration

Source position: iffparse.pas line 59

type TContextNode = record

  cn_Node: TMinNode;

  cn_ID: LongInt;

  cn_Type: LongInt;

  cn_Size: LongInt;

  cn_Scan: LongInt;

end;


TIFFHandle

Declaration

Source position: iffparse.pas line 30

type TIFFHandle = record

  iff_Stream: LongWord;

  iff_Flags: LongWord;

  iff_Depth: LongInt;

end;


TIFFStreamCmd

Declaration

Source position: iffparse.pas line 48

type TIFFStreamCmd = record

  sc_Command: LongInt;

  sc_Buf: Pointer;

  sc_NBytes: LongInt;

end;


TLocalContextItem

Declaration

Source position: iffparse.pas line 70

type TLocalContextItem = record

  lci_Node: TMinNode;

  lci_ID: LongWord;

  lci_Type: LongWord;

  lci_Ident: LongWord;

end;


TStoredProperty

Declaration

Source position: iffparse.pas line 78

type TStoredProperty = record

  sp_Size: LongInt;

  sp_Data: Pointer;

end;


IECLASS_ACTIVEWINDOW

Declaration

Source position: inputevent.pas line 43

const IECLASS_ACTIVEWINDOW = $11;


IECLASS_CHANGEWINDOW

Declaration

Source position: inputevent.pas line 47

const IECLASS_CHANGEWINDOW = $15;


IECLASS_CLOSEWINDOW

Declaration

Source position: inputevent.pas line 37

const IECLASS_CLOSEWINDOW = $0B;


IECLASS_DISKINSERTED

Declaration

Source position: inputevent.pas line 42

const IECLASS_DISKINSERTED = $10;


IECLASS_DISKREMOVED

Declaration

Source position: inputevent.pas line 41

const IECLASS_DISKREMOVED = $0F;


IECLASS_EVENT

Declaration

Source position: inputevent.pas line 30

const IECLASS_EVENT = $03;


IECLASS_EXTENDEDRAWKEY

Declaration

Source position: inputevent.pas line 50

const IECLASS_EXTENDEDRAWKEY = $18;


IECLASS_GADGETDOWN

Declaration

Source position: inputevent.pas line 33

const IECLASS_GADGETDOWN = $07;


IECLASS_GADGETUP

Declaration

Source position: inputevent.pas line 34

const IECLASS_GADGETUP = $08;


IECLASS_INACTIVEWINDOW

Declaration

Source position: inputevent.pas line 44

const IECLASS_INACTIVEWINDOW = $12;


IECLASS_MAX

Declaration

Source position: inputevent.pas line 52

const IECLASS_MAX = $18;


IECLASS_MENUHELP

Declaration

Source position: inputevent.pas line 46

const IECLASS_MENUHELP = $14;


IECLASS_MENULIST

Declaration

Source position: inputevent.pas line 36

const IECLASS_MENULIST = $0A;


IECLASS_MOUSEWHEEL

Declaration

Source position: inputevent.pas line 49

const IECLASS_MOUSEWHEEL = $17;


IECLASS_NEWPOINTERPOS

Declaration

Source position: inputevent.pas line 45

const IECLASS_NEWPOINTERPOS = $13;


IECLASS_NEWPREFS

Declaration

Source position: inputevent.pas line 40

const IECLASS_NEWPREFS = $0E;


IECLASS_NULL

Declaration

Source position: inputevent.pas line 27

const IECLASS_NULL = $00;


IECLASS_POINTERPOS

Declaration

Source position: inputevent.pas line 31

const IECLASS_POINTERPOS = $04;


IECLASS_RAWKEY

Declaration

Source position: inputevent.pas line 28

const IECLASS_RAWKEY = $01;


IECLASS_RAWMOUSE

Declaration

Source position: inputevent.pas line 29

const IECLASS_RAWMOUSE = $02;


IECLASS_REFRESHWINDOW

Declaration

Source position: inputevent.pas line 39

const IECLASS_REFRESHWINDOW = $0D;


IECLASS_REQUESTER

Declaration

Source position: inputevent.pas line 35

const IECLASS_REQUESTER = $09;


IECLASS_RESERVED

Declaration

Source position: inputevent.pas line 48

const IECLASS_RESERVED = $16;


IECLASS_SIZEWINDOW

Declaration

Source position: inputevent.pas line 38

const IECLASS_SIZEWINDOW = $0C;


IECLASS_TIMER

Declaration

Source position: inputevent.pas line 32

const IECLASS_TIMER = $06;


IECODE_4TH_BUTTON

Declaration

Source position: inputevent.pas line 151

const IECODE_4TH_BUTTON = $7E;


IECODE_5TH_BUTTON

Declaration

Source position: inputevent.pas line 152

const IECODE_5TH_BUTTON = $78;


IECODE_ASCII_DEL

Declaration

Source position: inputevent.pas line 142

const IECODE_ASCII_DEL = $7F;


IECODE_ASCII_FIRST

Declaration

Source position: inputevent.pas line 140

const IECODE_ASCII_FIRST = $20;


IECODE_ASCII_LAST

Declaration

Source position: inputevent.pas line 141

const IECODE_ASCII_LAST = $7E;


IECODE_C0_FIRST

Declaration

Source position: inputevent.pas line 138

const IECODE_C0_FIRST = $00;


IECODE_C0_LAST

Declaration

Source position: inputevent.pas line 139

const IECODE_C0_LAST = $1F;


IECODE_C1_FIRST

Declaration

Source position: inputevent.pas line 143

const IECODE_C1_FIRST = $80;


IECODE_C1_LAST

Declaration

Source position: inputevent.pas line 144

const IECODE_C1_LAST = $9F;


IECODE_COMM_CODE_FIRST

Declaration

Source position: inputevent.pas line 135

const IECODE_COMM_CODE_FIRST = $78;


IECODE_COMM_CODE_LAST

Declaration

Source position: inputevent.pas line 136

const IECODE_COMM_CODE_LAST = $7F;


IECODE_KEY_CODE_FIRST

Declaration

Source position: inputevent.pas line 133

const IECODE_KEY_CODE_FIRST = $00;


IECODE_KEY_CODE_LAST

Declaration

Source position: inputevent.pas line 134

const IECODE_KEY_CODE_LAST = $77;


IECODE_LATIN1_FIRST

Declaration

Source position: inputevent.pas line 145

const IECODE_LATIN1_FIRST = $A0;


IECODE_LATIN1_LAST

Declaration

Source position: inputevent.pas line 146

const IECODE_LATIN1_LAST = $FF;


IECODE_LBUTTON

Declaration

Source position: inputevent.pas line 148

const IECODE_LBUTTON = $68;


IECODE_MBUTTON

Declaration

Source position: inputevent.pas line 150

const IECODE_MBUTTON = $6A;


IECODE_NEWACTIVE

Declaration

Source position: inputevent.pas line 155

const IECODE_NEWACTIVE = $01;


IECODE_NEWSIZE

Declaration

Source position: inputevent.pas line 156

const IECODE_NEWSIZE = $02;


IECODE_NOBUTTON

Declaration

Source position: inputevent.pas line 153

const IECODE_NOBUTTON = $FF;


IECODE_RBUTTON

Declaration

Source position: inputevent.pas line 149

const IECODE_RBUTTON = $69;


IECODE_REFRESH

Declaration

Source position: inputevent.pas line 157

const IECODE_REFRESH = $03;


IECODE_REQCLEAR

Declaration

Source position: inputevent.pas line 161

const IECODE_REQCLEAR = $00;


IECODE_REQSET

Declaration

Source position: inputevent.pas line 160

const IECODE_REQSET = $01;


IECODE_UP_PREFIX

Declaration

Source position: inputevent.pas line 132

const IECODE_UP_PREFIX = $80;


IEQUALIFIER_CAPSLOCK

Declaration

Source position: inputevent.pas line 166

const IEQUALIFIER_CAPSLOCK = $0004;


IEQUALIFIER_CONTROL

Declaration

Source position: inputevent.pas line 167

const IEQUALIFIER_CONTROL = $0008;


IEQUALIFIER_INTERRUPT

Declaration

Source position: inputevent.pas line 174

const IEQUALIFIER_INTERRUPT = $0400;


IEQUALIFIER_LALT

Declaration

Source position: inputevent.pas line 168

const IEQUALIFIER_LALT = $0010;


IEQUALIFIER_LCOMMAND

Declaration

Source position: inputevent.pas line 170

const IEQUALIFIER_LCOMMAND = $0040;


IEQUALIFIER_LEFTBUTTON

Declaration

Source position: inputevent.pas line 178

const IEQUALIFIER_LEFTBUTTON = $4000;


IEQUALIFIER_LSHIFT

Declaration

Source position: inputevent.pas line 164

const IEQUALIFIER_LSHIFT = $0001;


IEQUALIFIER_MIDBUTTON

Declaration

Source position: inputevent.pas line 176

const IEQUALIFIER_MIDBUTTON = $1000;


IEQUALIFIER_MULTIBROADCAST

Declaration

Source position: inputevent.pas line 175

const IEQUALIFIER_MULTIBROADCAST = $0800;


IEQUALIFIER_NUMERICPAD

Declaration

Source position: inputevent.pas line 172

const IEQUALIFIER_NUMERICPAD = $0100;


IEQUALIFIER_RALT

Declaration

Source position: inputevent.pas line 169

const IEQUALIFIER_RALT = $0020;


IEQUALIFIER_RBUTTON

Declaration

Source position: inputevent.pas line 177

const IEQUALIFIER_RBUTTON = $2000;


IEQUALIFIER_RCOMMAND

Declaration

Source position: inputevent.pas line 171

const IEQUALIFIER_RCOMMAND = $0080;


IEQUALIFIER_RELATIVEMOUSE

Declaration

Source position: inputevent.pas line 179

const IEQUALIFIER_RELATIVEMOUSE = $8000;


IEQUALIFIER_REPEAT

Declaration

Source position: inputevent.pas line 173

const IEQUALIFIER_REPEAT = $0200;


IEQUALIFIER_RSHIFT

Declaration

Source position: inputevent.pas line 165

const IEQUALIFIER_RSHIFT = $0002;


IEQUALIFIERB_CAPSLOCK

Declaration

Source position: inputevent.pas line 183

const IEQUALIFIERB_CAPSLOCK = 2;


IEQUALIFIERB_CONTROL

Declaration

Source position: inputevent.pas line 184

const IEQUALIFIERB_CONTROL = 3;


IEQUALIFIERB_INTERRUPT

Declaration

Source position: inputevent.pas line 191

const IEQUALIFIERB_INTERRUPT = 10;


IEQUALIFIERB_LALT

Declaration

Source position: inputevent.pas line 185

const IEQUALIFIERB_LALT = 4;


IEQUALIFIERB_LCOMMAND

Declaration

Source position: inputevent.pas line 187

const IEQUALIFIERB_LCOMMAND = 6;


IEQUALIFIERB_LEFTBUTTON

Declaration

Source position: inputevent.pas line 195

const IEQUALIFIERB_LEFTBUTTON = 14;


IEQUALIFIERB_LSHIFT

Declaration

Source position: inputevent.pas line 181

const IEQUALIFIERB_LSHIFT = 0;


IEQUALIFIERB_MIDBUTTON

Declaration

Source position: inputevent.pas line 193

const IEQUALIFIERB_MIDBUTTON = 12;


IEQUALIFIERB_MULTIBROADCAST

Declaration

Source position: inputevent.pas line 192

const IEQUALIFIERB_MULTIBROADCAST = 11;


IEQUALIFIERB_NUMERICPAD

Declaration

Source position: inputevent.pas line 189

const IEQUALIFIERB_NUMERICPAD = 8;


IEQUALIFIERB_RALT

Declaration

Source position: inputevent.pas line 186

const IEQUALIFIERB_RALT = 5;


IEQUALIFIERB_RBUTTON

Declaration

Source position: inputevent.pas line 194

const IEQUALIFIERB_RBUTTON = 13;


IEQUALIFIERB_RCOMMAND

Declaration

Source position: inputevent.pas line 188

const IEQUALIFIERB_RCOMMAND = 7;


IEQUALIFIERB_RELATIVEMOUSE

Declaration

Source position: inputevent.pas line 196

const IEQUALIFIERB_RELATIVEMOUSE = 15;


IEQUALIFIERB_REPEAT

Declaration

Source position: inputevent.pas line 190

const IEQUALIFIERB_REPEAT = 9;


IEQUALIFIERB_RSHIFT

Declaration

Source position: inputevent.pas line 182

const IEQUALIFIERB_RSHIFT = 1;


IESUBCLASS_AMIGA_RAWKEY

Declaration

Source position: inputevent.pas line 62

const IESUBCLASS_AMIGA_RAWKEY = $00;


IESUBCLASS_COMPATIBLE

Declaration

Source position: inputevent.pas line 57

const IESUBCLASS_COMPATIBLE = $00;


IESUBCLASS_HID_CONSUMER_DOWN_RAWKEY

Declaration

Source position: inputevent.pas line 64

const IESUBCLASS_HID_CONSUMER_DOWN_RAWKEY = $02;


IESUBCLASS_HID_CONSUMER_UP_RAWKEY

Declaration

Source position: inputevent.pas line 65

const IESUBCLASS_HID_CONSUMER_UP_RAWKEY = $03;


IESUBCLASS_PIXEL

Declaration

Source position: inputevent.pas line 58

const IESUBCLASS_PIXEL = $01;


IESUBCLASS_SET1_RAWKEY

Declaration

Source position: inputevent.pas line 63

const IESUBCLASS_SET1_RAWKEY = $01;


IESUBCLASS_TABLET

Declaration

Source position: inputevent.pas line 59

const IESUBCLASS_TABLET = $02;


Reference for unit 'inputevent'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility, | Tag Handling, Date routines in utility.library
timer;


Reference for unit 'inputevent': Constants

IECLASS_ACTIVEWINDOW

IECLASS_CHANGEWINDOW

IECLASS_CLOSEWINDOW

IECLASS_DISKINSERTED

IECLASS_DISKREMOVED

IECLASS_EVENT

IECLASS_EXTENDEDRAWKEY

IECLASS_GADGETDOWN

IECLASS_GADGETUP

IECLASS_INACTIVEWINDOW

IECLASS_MAX

IECLASS_MENUHELP

IECLASS_MENULIST

IECLASS_MOUSEWHEEL

IECLASS_NEWPOINTERPOS

IECLASS_NEWPREFS

IECLASS_NULL

IECLASS_POINTERPOS

IECLASS_RAWKEY

IECLASS_RAWMOUSE

IECLASS_REFRESHWINDOW

IECLASS_REQUESTER

IECLASS_RESERVED

IECLASS_SIZEWINDOW

IECLASS_TIMER

IECODE_4TH_BUTTON

IECODE_5TH_BUTTON

IECODE_ASCII_DEL

IECODE_ASCII_FIRST

IECODE_ASCII_LAST

IECODE_C0_FIRST

IECODE_C0_LAST

IECODE_C1_FIRST

IECODE_C1_LAST

IECODE_COMM_CODE_FIRST

IECODE_COMM_CODE_LAST

IECODE_KEY_CODE_FIRST

IECODE_KEY_CODE_LAST

IECODE_LATIN1_FIRST

IECODE_LATIN1_LAST

IECODE_LBUTTON

IECODE_MBUTTON

IECODE_NEWACTIVE

IECODE_NEWSIZE

IECODE_NOBUTTON

IECODE_RBUTTON

IECODE_REFRESH

IECODE_REQCLEAR

IECODE_REQSET

IECODE_UP_PREFIX

IEQUALIFIERB_CAPSLOCK

IEQUALIFIERB_CONTROL

IEQUALIFIERB_INTERRUPT

IEQUALIFIERB_LALT

IEQUALIFIERB_LCOMMAND

IEQUALIFIERB_LEFTBUTTON

IEQUALIFIERB_LSHIFT

IEQUALIFIERB_MIDBUTTON

IEQUALIFIERB_MULTIBROADCAST

IEQUALIFIERB_NUMERICPAD

IEQUALIFIERB_RALT

IEQUALIFIERB_RBUTTON

IEQUALIFIERB_RCOMMAND

IEQUALIFIERB_RELATIVEMOUSE

IEQUALIFIERB_REPEAT

IEQUALIFIERB_RSHIFT

IEQUALIFIER_CAPSLOCK

IEQUALIFIER_CONTROL

IEQUALIFIER_INTERRUPT

IEQUALIFIER_LALT

IEQUALIFIER_LCOMMAND

IEQUALIFIER_LEFTBUTTON

IEQUALIFIER_LSHIFT

IEQUALIFIER_MIDBUTTON

IEQUALIFIER_MULTIBROADCAST

IEQUALIFIER_NUMERICPAD

IEQUALIFIER_RALT

IEQUALIFIER_RBUTTON

IEQUALIFIER_RCOMMAND

IEQUALIFIER_RELATIVEMOUSE

IEQUALIFIER_REPEAT

IEQUALIFIER_RSHIFT

IESUBCLASS_AMIGA_RAWKEY

IESUBCLASS_COMPATIBLE

IESUBCLASS_HID_CONSUMER_DOWN_RAWKEY

IESUBCLASS_HID_CONSUMER_UP_RAWKEY

IESUBCLASS_PIXEL

IESUBCLASS_SET1_RAWKEY

IESUBCLASS_TABLET


Reference for unit 'inputevent': Types

PExtendedDeadKey

PIENewTablet

PIEPointerPixel

PIEPointerTablet

PInputEvent

TExtendedDeadKey

TIENewTablet

TIEPointerPixel

TIEPointerTablet

TInputEvent


Index of all identifiers in unit 'inputevent'

I P T

I

IECLASS_ACTIVEWINDOW | IECODE_C0_FIRST | IEQUALIFIERB_RALT
IECLASS_CHANGEWINDOW | IECODE_C0_LAST | IEQUALIFIERB_RBUTTON
IECLASS_CLOSEWINDOW | IECODE_C1_FIRST | IEQUALIFIERB_RCOMMAND
IECLASS_DISKINSERTED | IECODE_C1_LAST | IEQUALIFIERB_RELATIVEMOUSE
IECLASS_DISKREMOVED | IECODE_COMM_CODE_FIRST | IEQUALIFIERB_REPEAT
IECLASS_EVENT | IECODE_COMM_CODE_LAST | IEQUALIFIERB_RSHIFT
IECLASS_EXTENDEDRAWKEY | IECODE_KEY_CODE_FIRST | IEQUALIFIER_CAPSLOCK
IECLASS_GADGETDOWN | IECODE_KEY_CODE_LAST | IEQUALIFIER_CONTROL
IECLASS_GADGETUP | IECODE_LATIN1_FIRST | IEQUALIFIER_INTERRUPT
IECLASS_INACTIVEWINDOW | IECODE_LATIN1_LAST | IEQUALIFIER_LALT
IECLASS_MAX | IECODE_LBUTTON | IEQUALIFIER_LCOMMAND
IECLASS_MENUHELP | IECODE_MBUTTON | IEQUALIFIER_LEFTBUTTON
IECLASS_MENULIST | IECODE_NEWACTIVE | IEQUALIFIER_LSHIFT
IECLASS_MOUSEWHEEL | IECODE_NEWSIZE | IEQUALIFIER_MIDBUTTON
IECLASS_NEWPOINTERPOS | IECODE_NOBUTTON | IEQUALIFIER_MULTIBROADCAST
IECLASS_NEWPREFS | IECODE_RBUTTON | IEQUALIFIER_NUMERICPAD
IECLASS_NULL | IECODE_REFRESH | IEQUALIFIER_RALT
IECLASS_POINTERPOS | IECODE_REQCLEAR | IEQUALIFIER_RBUTTON
IECLASS_RAWKEY | IECODE_REQSET | IEQUALIFIER_RCOMMAND
IECLASS_RAWMOUSE | IECODE_UP_PREFIX | IEQUALIFIER_RELATIVEMOUSE
IECLASS_REFRESHWINDOW | IEQUALIFIERB_CAPSLOCK | IEQUALIFIER_REPEAT
IECLASS_REQUESTER | IEQUALIFIERB_CONTROL | IEQUALIFIER_RSHIFT
IECLASS_RESERVED | IEQUALIFIERB_INTERRUPT | IESUBCLASS_AMIGA_RAWKEY
IECLASS_SIZEWINDOW | IEQUALIFIERB_LALT | IESUBCLASS_COMPATIBLE
IECLASS_TIMER | IEQUALIFIERB_LCOMMAND | IESUBCLASS_HID_CONSUMER_DOWN_RAWKEY
IECODE_4TH_BUTTON | IEQUALIFIERB_LEFTBUTTON | IESUBCLASS_HID_CONSUMER_UP_RAWKEY
IECODE_5TH_BUTTON | IEQUALIFIERB_LSHIFT | IESUBCLASS_PIXEL
IECODE_ASCII_DEL | IEQUALIFIERB_MIDBUTTON | IESUBCLASS_SET1_RAWKEY
IECODE_ASCII_FIRST | IEQUALIFIERB_MULTIBROADCAST | IESUBCLASS_TABLET
IECODE_ASCII_LAST | IEQUALIFIERB_NUMERICPAD |

P

PExtendedDeadKey | PIEPointerPixel | PInputEvent
PIENewTablet | PIEPointerTablet |

T

TExtendedDeadKey | TIEPointerPixel | TInputEvent
TIENewTablet | TIEPointerTablet |


PExtendedDeadKey

Declaration

Source position: inputevent.pas line 225

type PExtendedDeadKey = ^TExtendedDeadKey;


PIENewTablet

Declaration

Source position: inputevent.pas line 101

type PIENewTablet = ^TIENewTablet;


PIEPointerPixel

Declaration

Source position: inputevent.pas line 73

type PIEPointerPixel = ^TIEPointerPixel;


PIEPointerTablet

Declaration

Source position: inputevent.pas line 88

type PIEPointerTablet = ^TIEPointerTablet;


PInputEvent

Declaration

Source position: inputevent.pas line 200

type PInputEvent = ^TInputEvent;


TExtendedDeadKey

Declaration

Source position: inputevent.pas line 226

type TExtendedDeadKey = record

  Reserved: LongWord;

  Prev1DownClass: Word;

  Prev1DownCode: Word;

  Prev1DownQual: Word;

  Prev2DownClass: Word;

  Prev2DownCode: Word;

  Prev2DownQual: Word;

end;


TIENewTablet

Declaration

Source position: inputevent.pas line 102

type TIENewTablet = record

  ient_CallBack: PHook;

  ient_ScaledX: Word;

  ient_ScaledY: Word;

  ient_ScaledXFraction: Word;

  ient_ScaledYFraction: Word;

  ient_TabletX: LongWord;

  ient_TabletY: LongWord;

  ient_RangeX: LongWord;

  ient_RangeY: LongWord;

  ient_TagList: PTagItem;

end;


TIEPointerPixel

Declaration

Source position: inputevent.pas line 74

type TIEPointerPixel = record

  iepp_Screen: Pointer;

  iepp_Position: record

    x: SmallInt;

    y: SmallInt;

  end;

end;


TIEPointerTablet

Declaration

Source position: inputevent.pas line 89

type TIEPointerTablet = record

  iept_Range: record

    x: Word;

    y: Word;

  end;

  iept_Value: record

    x: Word;

    y: Word;

  end;

  iept_Pressure: Word;

end;


TInputEvent

Declaration

Source position: inputevent.pas line 201

type TInputEvent = record

  ie_NextEvent: PInputEvent;

  ie_Class: Byte;

  ie_SubClass: Byte;

  ie_Code: Word;

  ie_Qualifier: Word;

  ie_position: record

    case LongInt of

      0: (

          ie_xy: record

            ie_x: SmallInt;

            ie_y: SmallInt;

          end;

        );

      1: (

          ie_addr: Pointer;

        );

      2: (

          ie_dead: record

            ie_prev1DownCode: Byte;

            ie_prev1DownQual: Byte;

            ie_prev2DownCode: Byte;

            ie_prev2DownQual: Byte;

          end;

        );

  end;

  ie_TimeStamp: TTimeVal;

end;


ABSOLUTE_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as absolutes

Declaration

Source position: intuition.pas line 2420

const ABSOLUTE_DIMENSIONS = $0020;


ALERT_TYPE

Alert Type for DisplayAlert()

Declaration

Source position: intuition.pas line 1871

const ALERT_TYPE = $80000000;


ALPHA_P_101

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2376

const ALPHA_P_101 = $01;


ALTLEFT

Qualifier for TIntuiMessage.Qualifier. Left Alt Key pressed.

Declaration

Source position: intuition.pas line 1890

const ALTLEFT = IEQUALIFIER_LALT;


ALTRIGHT

Qualifier for TIntuiMessage.Qualifier. Right Alt Key pressed.

Declaration

Source position: intuition.pas line 1891

const ALTRIGHT = IEQUALIFIER_RALT;


AMIGAKEY

SYSIA_Which tag data values. Menu Amiga-key image

Declaration

Source position: intuition.pas line 3151

const AMIGAKEY = $11;


AMIGAKEYS

Qualifier for TIntuiMessage.Qualifier. An Amiga Key pressed.

Declaration

Source position: intuition.pas line 1894

const AMIGAKEYS = AMIGALEFT + AMIGARIGHT;


AMIGALEFT

Qualifier for TIntuiMessage.Qualifier. Left Amiga Key pressed.

Declaration

Source position: intuition.pas line 1892

const AMIGALEFT = IEQUALIFIER_LCOMMAND;


AMIGARIGHT

Qualifier for TIntuiMessage.Qualifier. Right Amiga Key pressed.

Declaration

Source position: intuition.pas line 1893

const AMIGARIGHT = IEQUALIFIER_RCOMMAND;


ANTI_ALIAS

Flag for TPreferences.PrintFlags anti-alias image

Declaration

Source position: intuition.pas line 2430

const ANTI_ALIAS = $0800;


ASPECT_HORIZ

Value for TPreferences.PrintAspect

Declaration

Source position: intuition.pas line 2352

const ASPECT_HORIZ = $00;


ASPECT_VERT

Value for TPreferences.PrintAspect

Declaration

Source position: intuition.pas line 2353

const ASPECT_VERT = $01;


AUTOBACKPEN

Declaration

Source position: intuition.pas line 1877

const AUTOBACKPEN = 1;


AUTODRAWMODE

Declaration

Source position: intuition.pas line 1878

const AUTODRAWMODE = JAM2;


AUTOFRONTPEN

Declaration

Source position: intuition.pas line 1876

const AUTOFRONTPEN = 0;


AUTOITEXTFONT

Declaration

Source position: intuition.pas line 1881

const AUTOITEXTFONT = Nil;


AUTOKNOB

Flag value for TPropInfo.Flags. Gimme that old auto-knob

Declaration

Source position: intuition.pas line 677

const AUTOKNOB = $0001;

Description

If you do not use an AUTOKNOB for a proportional gadget, you are currently limited to using a single Image of your own design: Intuition won't handle a linked list of images as a proportional gadget knob.


AUTOLEFTEDGE

Declaration

Source position: intuition.pas line 1879

const AUTOLEFTEDGE = 6;


AUTONEXTTEXT

Declaration

Source position: intuition.pas line 1882

const AUTONEXTTEXT = Nil;


AUTOSCROLL

Flag for TScreen.Flags. Screen is to autoscoll

Declaration

Source position: intuition.pas line 2017

const AUTOSCROLL = $4000;


AUTOTOPEDGE

Declaration

Source position: intuition.pas line 1880

const AUTOTOPEDGE = 3;


AWCODE_INTERIM

Declaration

Source position: intuition.pas line 905

const AWCODE_INTERIM = $0001;


AWCODE_NORMAL

Declaration

Source position: intuition.pas line 904

const AWCODE_NORMAL = $0000;


BACKGROUNDPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. always color 0

Declaration

Source position: intuition.pas line 1952

const BACKGROUNDPEN = $0007;


BARBLOCKPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. screen-bar/menus fill

Declaration

Source position: intuition.pas line 1956

const BARBLOCKPEN = $000A;

Description

Only present if DRI_VERSION >= 2


BARCONTOURPEN

Declaration

Source position: intuition.pas line 1959

const BARCONTOURPEN = $000C;


BARDETAILPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. text/detail in screen-bar/menus

Declaration

Source position: intuition.pas line 1955

const BARDETAILPEN = $0009;

Description

Only present if DRI_VERSION >= 2


BARTRIMPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. trim under screen-bar

Declaration

Source position: intuition.pas line 1957

const BARTRIMPEN = $000B;

Description

Only present if DRI_VERSION >= 2


BAUD_110

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2327

const BAUD_110 = $00;


BAUD_300

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2328

const BAUD_300 = $01;


BAUD_1200

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2329

const BAUD_1200 = $02;


BAUD_2400

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2330

const BAUD_2400 = $03;


BAUD_4800

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2331

const BAUD_4800 = $04;


BAUD_9600

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2332

const BAUD_9600 = $05;


BAUD_19200

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2333

const BAUD_19200 = $06;


BAUD_MIDI

Value for TPreferences.BaudRate

Declaration

Source position: intuition.pas line 2334

const BAUD_MIDI = $07;


BEEPING_F

Flag for TScreen.Flags. Set when Screen is beeping

Declaration

Source position: intuition.pas line 2010

const BEEPING_F = $0020;


BLOCKPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. compatible Intuition rendering pens

Declaration

Source position: intuition.pas line 1946

const BLOCKPEN = $0001;


BMI_CacheGradient

Declaration

Source position: intuition.pas line 3511

const BMI_CacheGradient = BMI_Dummy + 7;


BMI_DoLevels

Declaration

Source position: intuition.pas line 3506

const BMI_DoLevels = BMI_Dummy + 2;


BMI_Dummy

Declaration

Source position: intuition.pas line 3504

const BMI_Dummy = TAG_USER + $01547400;


BMI_Exclusive

Declaration

Source position: intuition.pas line 3505

const BMI_Exclusive = BMI_Dummy + 1;


BMI_GradientAxis

Declaration

Source position: intuition.pas line 3512

const BMI_GradientAxis = BMI_Dummy + 8;


BMI_GradientSpec

Declaration

Source position: intuition.pas line 3510

const BMI_GradientSpec = BMI_Dummy + 6;


BMI_IgnoreDomain

Declaration

Source position: intuition.pas line 3513

const BMI_IgnoreDomain = BMI_Dummy + 9;


BMI_LayerInfo

Declaration

Source position: intuition.pas line 3508

const BMI_LayerInfo = BMI_Dummy + 4;


BMI_Offsets

Declaration

Source position: intuition.pas line 3507

const BMI_Offsets = BMI_Dummy + 3;


BMI_ReferencePen

Declaration

Source position: intuition.pas line 3509

const BMI_ReferencePen = BMI_Dummy + 5;


BMI_TileHeight

Declaration

Source position: intuition.pas line 3517

const BMI_TileHeight = BMI_Dummy + 13;


BMI_TileLeft

Declaration

Source position: intuition.pas line 3514

const BMI_TileLeft = BMI_Dummy + 10;


BMI_TileTop

Declaration

Source position: intuition.pas line 3515

const BMI_TileTop = BMI_Dummy + 11;


BMI_TileWidth

Declaration

Source position: intuition.pas line 3516

const BMI_TileWidth = BMI_Dummy + 12;


BMICTRL_Dummy

Declaration

Source position: intuition.pas line 3520

const BMICTRL_Dummy = TAG_USER + $01547600;


BMICTRL_GetAlphaMap

Declaration

Source position: intuition.pas line 3537

const BMICTRL_GetAlphaMap = BMICTRL_Dummy + 15;


BMICTRL_GetBitMap

Declaration

Source position: intuition.pas line 3522

const BMICTRL_GetBitMap = BMICTRL_Dummy + 1;


BMICTRL_GetBitMapSource

Declaration

Source position: intuition.pas line 3540

const BMICTRL_GetBitMapSource = BMICTRL_Dummy + 18;


BMICTRL_GetBrightBitMap

Declaration

Source position: intuition.pas line 3529

const BMICTRL_GetBrightBitMap = BMICTRL_Dummy + 7;


BMICTRL_GetDarkBitMap

Declaration

Source position: intuition.pas line 3532

const BMICTRL_GetDarkBitMap = BMICTRL_Dummy + 10;


BMICTRL_GetGradientSpec

Declaration

Source position: intuition.pas line 3541

const BMICTRL_GetGradientSpec = BMICTRL_Dummy + 19;


BMICTRL_GetHalfBrightBitMap

Declaration

Source position: intuition.pas line 3530

const BMICTRL_GetHalfBrightBitMap = BMICTRL_Dummy + 8;


BMICTRL_GetHalfDarkBitMap

Declaration

Source position: intuition.pas line 3531

const BMICTRL_GetHalfDarkBitMap = BMICTRL_Dummy + 9;


BMICTRL_GetHeight

Declaration

Source position: intuition.pas line 3528

const BMICTRL_GetHeight = BMICTRL_Dummy + 6;


BMICTRL_GetHook

Declaration

Source position: intuition.pas line 3523

const BMICTRL_GetHook = BMICTRL_Dummy + 2;


BMICTRL_GetMaskBitMap

Declaration

Source position: intuition.pas line 3533

const BMICTRL_GetMaskBitMap = BMICTRL_Dummy + 11;


BMICTRL_GetOffsets

Declaration

Source position: intuition.pas line 3524

const BMICTRL_GetOffsets = BMICTRL_Dummy + 3;


BMICTRL_GetOutlineBitMap

Declaration

Source position: intuition.pas line 3534

const BMICTRL_GetOutlineBitMap = BMICTRL_Dummy + 12;


BMICTRL_GetOutlineMap

Declaration

Source position: intuition.pas line 3545

const BMICTRL_GetOutlineMap = BMICTRL_Dummy + 22;


BMICTRL_GetReferencePen

Declaration

Source position: intuition.pas line 3544

const BMICTRL_GetReferencePen = BMICTRL_Dummy + 21;


BMICTRL_GetScreen

Declaration

Source position: intuition.pas line 3539

const BMICTRL_GetScreen = BMICTRL_Dummy + 17;


BMICTRL_GetShadeMaskBitMap

Declaration

Source position: intuition.pas line 3538

const BMICTRL_GetShadeMaskBitMap = BMICTRL_Dummy + 16;


BMICTRL_GetShadowMap

Declaration

Source position: intuition.pas line 3536

const BMICTRL_GetShadowMap = BMICTRL_Dummy + 14;


BMICTRL_GetShineMap

Declaration

Source position: intuition.pas line 3535

const BMICTRL_GetShineMap = BMICTRL_Dummy + 13;


BMICTRL_GetTileBox

Declaration

Source position: intuition.pas line 3550

const BMICTRL_GetTileBox = BMICTRL_Dummy + 27;


BMICTRL_GetTileHeight

Declaration

Source position: intuition.pas line 3549

const BMICTRL_GetTileHeight = BMICTRL_Dummy + 26;


BMICTRL_GetTileLeft

Declaration

Source position: intuition.pas line 3546

const BMICTRL_GetTileLeft = BMICTRL_Dummy + 23;


BMICTRL_GetTileTop

Declaration

Source position: intuition.pas line 3547

const BMICTRL_GetTileTop = BMICTRL_Dummy + 24;


BMICTRL_GetTileWidth

Declaration

Source position: intuition.pas line 3548

const BMICTRL_GetTileWidth = BMICTRL_Dummy + 25;


BMICTRL_GetWidth

Declaration

Source position: intuition.pas line 3527

const BMICTRL_GetWidth = BMICTRL_Dummy + 5;


BMICTRL_SetGradientSpec

Declaration

Source position: intuition.pas line 3542

const BMICTRL_SetGradientSpec = BMICTRL_Dummy + 20;


BMICTRL_SetOffsets

Declaration

Source position: intuition.pas line 3525

const BMICTRL_SetOffsets = BMICTRL_Dummy + 4;


BMICTRL_SetReferencePen

Declaration

Source position: intuition.pas line 3559

const BMICTRL_SetReferencePen = BMICTRL_Dummy + 32;


BMICTRL_SetTileHeight

Declaration

Source position: intuition.pas line 3557

const BMICTRL_SetTileHeight = BMICTRL_Dummy + 31;


BMICTRL_SetTileLeft

Declaration

Source position: intuition.pas line 3551

const BMICTRL_SetTileLeft = BMICTRL_Dummy + 28;


BMICTRL_SetTileTop

Declaration

Source position: intuition.pas line 3553

const BMICTRL_SetTileTop = BMICTRL_Dummy + 29;


BMICTRL_SetTileWidth

Declaration

Source position: intuition.pas line 3555

const BMICTRL_SetTileWidth = BMICTRL_Dummy + 30;


BMS_DoMask

Declaration

Source position: intuition.pas line 3499

const BMS_DoMask = BMS_Dummy + 2;


BMS_DoOutline

Declaration

Source position: intuition.pas line 3500

const BMS_DoOutline = BMS_Dummy + 3;


BMS_DoShade

Declaration

Source position: intuition.pas line 3501

const BMS_DoShade = BMS_Dummy + 4;


BMS_Dummy

Declaration

Source position: intuition.pas line 3497

const BMS_Dummy = TAG_USER + $01547300;


BMS_NoDiskIO

Declaration

Source position: intuition.pas line 3498

const BMS_NoDiskIO = BMS_Dummy + 1;


BOOLMASK

Extension is for masked gadget

Declaration

Source position: intuition.pas line 642

const BOOLMASK = $0001;

Description

Set TBoolInfo.Flags to this flag bit. in the future, additional bits might mean more stuff hanging off of TBoolInfo.Reserved.


BOOPSIMENU

Declaration

Source position: intuition.pas line 114

const BOOPSIMENU = $0400;


BOUNDED_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as boundaries

Declaration

Source position: intuition.pas line 2419

const BOUNDED_DIMENSIONS = $0010;


BROTHER_15XL

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2377

const BROTHER_15XL = $02;


BT_BACKGROUND

Declaration

Source position: intuition.pas line 1405

const BT_BACKGROUND = $00000000;


BT_DIRECTSHADE

Declaration

Source position: intuition.pas line 1422

const BT_DIRECTSHADE = $00020000;


BT_DRIPEN

Declaration

Source position: intuition.pas line 1406

const BT_DRIPEN = $00100000;


BT_FLAGSMASK

Declaration

Source position: intuition.pas line 1420

const BT_FLAGSMASK = $000F0000;


BT_GADGET

Declaration

Source position: intuition.pas line 1408

const BT_GADGET = $00300000;


BT_MENU

Declaration

Source position: intuition.pas line 1413

const BT_MENU = $00800000;


BT_OFFSETRECT

Declaration

Source position: intuition.pas line 1421

const BT_OFFSETRECT = $00010000;


BT_PROPBG

Declaration

Source position: intuition.pas line 1410

const BT_PROPBG = $00500000;


BT_PROPKNOB

Declaration

Source position: intuition.pas line 1409

const BT_PROPKNOB = $00400000;


BT_REQUESTERBG

Declaration

Source position: intuition.pas line 1417

const BT_REQUESTERBG = $00C00000;


BT_SCREENBAR

Declaration

Source position: intuition.pas line 1414

const BT_SCREENBAR = $00900000;


BT_TABPAGE

Declaration

Source position: intuition.pas line 1418

const BT_TABPAGE = $00D00000;


BT_WINBORDER

Declaration

Source position: intuition.pas line 1407

const BT_WINBORDER = $00200000;


BT_WINDOWBAR

Declaration

Source position: intuition.pas line 1415

const BT_WINDOWBAR = $00A00000;


BT_WINDOWBG

Declaration

Source position: intuition.pas line 1416

const BT_WINDOWBG = $00B00000;


BT_WINPROPBG

Declaration

Source position: intuition.pas line 1412

const BT_WINPROPBG = $00700000;


BT_WINPROPKNOB

Declaration

Source position: intuition.pas line 1411

const BT_WINPROPKNOB = $00600000;


BUTTONGCLASS

Class identifier. A button gadget that keeps sending button presses while the user holds it down.

Declaration

Source position: intuition.pas line 2531

const BUTTONGCLASS: PChar = 'buttongclass';

Description

SuperClass: gadgetclass

A class of button gadget that continually sends interim OM_UPDATE messages to its target while the user holds down the button. The button sends a final OM_UPDATE message when the user lets go of the button. The imagery for these objects is not built directly into the gadget. Instead, a buttongclass object uses a Boopsi image object, which it gets from its GA_Image attribute.

Changed Methods:

GM_HITTEST, GM_HANDLEINPUT, GM_RENDER

Attributes:

GA_Image (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


CBM_MPS1000

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2378

const CBM_MPS1000 = $03;


CENTER_IMAGE

Flag for TPreferences.PrintFlags center image on paper

Declaration

Source position: intuition.pas line 2416

const CENTER_IMAGE = $0008;


CHECKED

Flag for TMenuItem.Flags set by the Application and intuition, if CHECKIT, then set this when selected

Declaration

Source position: intuition.pas line 111

const CHECKED = $0100;


CHECKIMAGE

SYSIA_Which tag data values. GadTools checkbox image

Declaration

Source position: intuition.pas line 3147

const CHECKIMAGE = $0E;


CHECKIT

Flag for TMenuItem.Flags set by the Application, whether to check this item if selected

Declaration

Source position: intuition.pas line 96

const CHECKIT = $0001;


CHECKMARKIMAGE

Declaration

Source position: intuition.pas line 3165

const CHECKMARKIMAGE = $1E;


CHECKWIDTH

Define for CHECKIT width for the CheckMark in a menu item

Declaration

Source position: intuition.pas line 1865

const CHECKWIDTH = 19;


ClassID

Name of the Object class

Declaration

Source position: intuition.pas line 29

type ClassID = PChar;


CLF_INLIST

class is in public class list (TIClass.cl_Flags)

Declaration

Source position: intuition.pas line 2628

const CLF_INLIST = $00000001;


CLICKTAB_ACTIVEBOLD

Declaration

Source position: intuition.pas line 1692

const CLICKTAB_ACTIVEBOLD = $00000001;


CLICKTAB_ACTIVEBRIGHT

Declaration

Source position: intuition.pas line 1705

const CLICKTAB_ACTIVEBRIGHT = $00001000;


CLICKTAB_ACTIVEFILLFILL

Declaration

Source position: intuition.pas line 1701

const CLICKTAB_ACTIVEFILLFILL = $00000000;


CLICKTAB_ACTIVEFILLGRAD

Declaration

Source position: intuition.pas line 1695

const CLICKTAB_ACTIVEFILLGRAD = $00000008;


CLICKTAB_ACTIVEFILLMASK

Declaration

Source position: intuition.pas line 1700

const CLICKTAB_ACTIVEFILLMASK = $00000F00;


CLICKTAB_ACTIVEFILLNONE

Declaration

Source position: intuition.pas line 1704

const CLICKTAB_ACTIVEFILLNONE = $00000F00;


CLICKTAB_ACTIVEFILLSELECT

Declaration

Source position: intuition.pas line 1703

const CLICKTAB_ACTIVEFILLSELECT = $00000200;


CLICKTAB_ACTIVEFILLSHINE

Declaration

Source position: intuition.pas line 1702

const CLICKTAB_ACTIVEFILLSHINE = $00000100;


CLICKTAB_ACTIVEPENHLTEXT

Declaration

Source position: intuition.pas line 1698

const CLICKTAB_ACTIVEPENHLTEXT = $00000010;


CLICKTAB_ACTIVEPENMASK

Declaration

Source position: intuition.pas line 1696

const CLICKTAB_ACTIVEPENMASK = $000000F0;


CLICKTAB_ACTIVEPENTEXT

Declaration

Source position: intuition.pas line 1697

const CLICKTAB_ACTIVEPENTEXT = $00000000;


CLICKTAB_ACTIVEPENTITLE

Declaration

Source position: intuition.pas line 1699

const CLICKTAB_ACTIVEPENTITLE = $00000020;


CLICKTAB_EVENWIDTH

Declaration

Source position: intuition.pas line 1693

const CLICKTAB_EVENWIDTH = $00000002;


CLICKTAB_INACTIVEDARK

Declaration

Source position: intuition.pas line 1694

const CLICKTAB_INACTIVEDARK = $00000004;


CLOSEGADGET

Declaration

Source position: intuition.pas line 2453

const CLOSEGADGET = 3;


CLOSEIMAGE

SYSIA_Which tag data values. Window close gadget image

Declaration

Source position: intuition.pas line 3141

const CLOSEIMAGE = $03;


CM_QUERY

Declaration

Source position: intuition.pas line 1296

const CM_QUERY = 0;


CMENU_BOTTOM

Declaration

Source position: intuition.pas line 185

const CMENU_BOTTOM = $10000000;


CMENU_CENTER

Declaration

Source position: intuition.pas line 186

const CMENU_CENTER = $20000000;


CMENU_CENTER_MOUSE

Declaration

Source position: intuition.pas line 188

const CMENU_CENTER_MOUSE = $2FFFFFFF;


CMENU_RIGHT

Declaration

Source position: intuition.pas line 184

const CMENU_RIGHT = $10000000;


CNTR_ABSOLUTE

Declaration

Source position: intuition.pas line 1432

const CNTR_ABSOLUTE = $0200;


CNTR_CORRECT

Declaration

Source position: intuition.pas line 1431

const CNTR_CORRECT = $0100;


COMMSEQ

Flag for TMenuItem.Flags set by the Application, set if there's an command sequence

Declaration

Source position: intuition.pas line 98

const COMMSEQ = $0004;


COMMWIDTH

Define for COMMSEQ width for the Command sequence in a menu item

Declaration

Source position: intuition.pas line 1866

const COMMWIDTH = 27;


CORRECT_BLUE

Flag for TPreferences.PrintFlags color correct blue shades

Declaration

Source position: intuition.pas line 2414

const CORRECT_BLUE = $0004;


CORRECT_GREEN

Flag for TPreferences.PrintFlags color correct green shades

Declaration

Source position: intuition.pas line 2413

const CORRECT_GREEN = $0002;


CORRECT_RED

Flag for TPreferences.PrintFlags color correct red shades

Declaration

Source position: intuition.pas line 2412

const CORRECT_RED = $0001;


CORRECT_RGB_MASK

Mask for TPreferences.PrintFlags color corrections RGB

Declaration

Source position: intuition.pas line 2433

const CORRECT_RGB_MASK = CORRECT_RED + CORRECT_GREEN + CORRECT_BLUE;


CURSORDOWN

RawKeycode for TIntuiMessage.Code. Cursor Down key pressed.

Declaration

Source position: intuition.pas line 1899

const CURSORDOWN = $4D;


CURSORLEFT

RawKeycode for TIntuiMessage.Code. Cursor left key pressed.

Declaration

Source position: intuition.pas line 1897

const CURSORLEFT = $4F;


CURSORRIGHT

RawKeycode for TIntuiMessage.Code. Cursor right key pressed.

Declaration

Source position: intuition.pas line 1898

const CURSORRIGHT = $4E;


CURSORUP

RawKeycode for TIntuiMessage.Code. Cursor up key pressed.

Declaration

Source position: intuition.pas line 1896

const CURSORUP = $4C;


CUSTOM_NAME

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2375

const CUSTOM_NAME = $00;


CUSTOM_PAPER

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 2363

const CUSTOM_PAPER = $40;


CUSTOMBITMAP_F

Flag for TScreen.Flags. If you are supplying your own BitMap

Declaration

Source position: intuition.pas line 2011

const CUSTOMBITMAP_F = $0040;


CUSTOMIMAGEDEPTH

if TImage.Depth is this, it's a new Image class object

Declaration

Source position: intuition.pas line 3051

const CUSTOMIMAGEDEPTH = - 1;


CUSTOMSCREEN_F

Screentype flag for TScreen.Flags and TNewScreen.SType. For that special look

Declaration

Source position: intuition.pas line 2008

const CUSTOMSCREEN_F = $000F;


CWCODE_DEPTH

Code for IDCMP_CHANGEWINDOW Window was depth-arranged

Declaration

Source position: intuition.pas line 902

const CWCODE_DEPTH = $0001;


CWCODE_MOVESIZE

Code for IDCMP_CHANGEWINDOW Window was moved and/or sized

Declaration

Source position: intuition.pas line 901

const CWCODE_MOVESIZE = $0000;


CYCLEIMAGE

Declaration

Source position: intuition.pas line 3164

const CYCLEIMAGE = $1D;


DEADEND_ALERT

Alert Type for DisplayAlert() no recovery possible, this is it

Declaration

Source position: intuition.pas line 1873

const DEADEND_ALERT = $80000000;


DEFAULTMOUSEQUEUE

Window value, No more mouse messaged

Declaration

Source position: intuition.pas line 1087

const DEFAULTMOUSEQUEUE = 5;


DEFERREFRESH

Flag for TRequester.Flags. Read-Only. This Requester stops a Refresh broadcast

Declaration

Source position: intuition.pas line 759

const DEFERREFRESH = $8000;


DEPTHIMAGE

SYSIA_Which tag data values. Window depth gadget image

Declaration

Source position: intuition.pas line 3138

const DEPTHIMAGE = $00;


DETAILPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. Compatible Intuition rendering pens

Declaration

Source position: intuition.pas line 1945

const DETAILPEN = $0000;


DEVNAME_SIZE

Devicename size for printer configuration

Declaration

Source position: intuition.pas line 2225

const DEVNAME_SIZE = 16;


DIAB_630

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2379

const DIAB_630 = $04;


DIAB_ADV_D25

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2380

const DIAB_ADV_D25 = $05;


DIAB_C_150

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2381

const DIAB_C_150 = $06;


DIMENSIONS_MASK

Mask for TPreferences.PrintFlags Dimensions mask

Declaration

Source position: intuition.pas line 2434

const DIMENSIONS_MASK = BOUNDED_DIMENSIONS + ABSOLUTE_DIMENSIONS + PIXEL_DIMENSIONS + MULTIPLY_DIMENSIONS;


DISABLEDPEN

Declaration

Source position: intuition.pas line 1969

const DISABLEDPEN = $0016;


DISABLEDSHADOWPEN

Declaration

Source position: intuition.pas line 1972

const DISABLEDSHADOWPEN = $0019;


DISABLEDSHINEPEN

Declaration

Source position: intuition.pas line 1971

const DISABLEDSHINEPEN = $0018;


DISABLEDTEXTPEN

Declaration

Source position: intuition.pas line 1970

const DISABLEDTEXTPEN = $0017;


DITHERING_MASK

Mask for TPreferences.PrintFlags Dithering mask

Declaration

Source position: intuition.pas line 2435

const DITHERING_MASK = HALFTONE_DITHERING + FLOYD_DITHERING;


DMODECOUNT

Declaration

Source position: intuition.pas line 2439

const DMODECOUNT = $0002;


DOWNBACKGADGET

Declaration

Source position: intuition.pas line 2451

const DOWNBACKGADGET = 1;


DOWNIMAGE

SYSIA_Which tag data values. Down-arrow gadget image

Declaration

Source position: intuition.pas line 3146

const DOWNIMAGE = $0D;


DRAFT

Value for TPreferences.PrintQuality

Declaration

Source position: intuition.pas line 2343

const DRAFT = $000;


DRAGGADGET

Declaration

Source position: intuition.pas line 2454

const DRAGGADGET = 4;


DRI_VERSION

Version of the TDrawInfo structure, can be found in TDrawInfo.dri_Version

Declaration

Source position: intuition.pas line 1916

const DRI_VERSION = 3;

Description

If you find TDrawInfo.dri_Version >= DRI_VERSION, you know this structure has at least the fields defined in this version of the include file


DRIF_NEWDISABLE

Declaration

Source position: intuition.pas line 1941

const DRIF_NEWDISABLE = $00000002;


DRIF_NEWLOOK

Flag for TDrawInfo.dri_Flags specified SA_Pens, full treatment

Declaration

Source position: intuition.pas line 1940

const DRIF_NEWLOOK = $00000001;


DRIF_REALSHADE

Declaration

Source position: intuition.pas line 1942

const DRIF_REALSHADE = $00000004;


DRIPENS_IGNORE

Declaration

Source position: intuition.pas line 1736

const DRIPENS_IGNORE = not 0;


DSHM_Jump

Declaration

Source position: intuition.pas line 1402

const DSHM_Jump = 1;


DSHM_Smooth

Declaration

Source position: intuition.pas line 1401

const DSHM_Smooth = 0;


EIGHT_LPI

Value for TPreferences.PrintSpacing

Declaration

Source position: intuition.pas line 2347

const EIGHT_LPI = $200;


ELITE

Value for TPreferences.PrintPitch

Declaration

Source position: intuition.pas line 2340

const ELITE = $400;


EO_BADFORMAT

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3465

const EO_BADFORMAT = $0009;

Description

didn't like the text data, e.g., Bad LONGINT


EO_BIGCHANGE

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3466

const EO_BIGCHANGE = $000A;

Description

unused by Intuition complete or major change to the text, e.g. new string


EO_CLEAR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3468

const EO_CLEAR = $000C;

Description

clear the string


EO_DELBACKWARD

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3458

const EO_DELBACKWARD = $0002;

Description

deleted some chars (maybe 0).


EO_DELFORWARD

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3459

const EO_DELFORWARD = $0003;

Description

deleted some characters under and in front of the cursor


EO_ENTER

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3461

const EO_ENTER = $0005;

Description

"enter" or "return" key, terminate


EO_INSERTCHAR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3464

const EO_INSERTCHAR = $0008;

Description

inserted one char into string or added one at end


EO_MOVECURSOR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3460

const EO_MOVECURSOR = $0004;

Description

moved the cursor


EO_NOOP

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3457

const EO_NOOP = $0001;

Description

did nothing


EO_REPLACECHAR

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3463

const EO_REPLACECHAR = $0007;

Description

replaced one character and (maybe) advanced cursor


EO_RESET

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3462

const EO_RESET = $0006;

Description

current Intuition-style undo


EO_SPECIAL

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3469

const EO_SPECIAL = $000D;

Description

unused by Intuition some operation that doesn't fit into the categories here


EO_UNDO

Value for TSGWork.EditOp

Declaration

Source position: intuition.pas line 3467

const EO_UNDO = $000B;

Description

unused by Intuition some other style of undo


EPSON

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2382

const EPSON = $07;


EPSON_JX_80

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2383

const EPSON_JX_80 = $08;


ERROR_BAD_ACTION_ON_ITEM

Declaration

Source position: intuition.pas line 337

const ERROR_BAD_ACTION_ON_ITEM = 4007;


ERROR_BAD_ACTION_ON_MENU

Declaration

Source position: intuition.pas line 336

const ERROR_BAD_ACTION_ON_MENU = 4006;


ERROR_BAD_ACTION_ON_ROOT

Declaration

Source position: intuition.pas line 335

const ERROR_BAD_ACTION_ON_ROOT = 4005;


ERROR_BAD_ACTION_ON_SEPARATOR

Declaration

Source position: intuition.pas line 338

const ERROR_BAD_ACTION_ON_SEPARATOR = 4008;


ERROR_COMM_KEY_AT_TITLE_LEVEL

Declaration

Source position: intuition.pas line 340

const ERROR_COMM_KEY_AT_TITLE_LEVEL = 4010;


ERROR_ITEM_ID_IS_ZERO

Declaration

Source position: intuition.pas line 339

const ERROR_ITEM_ID_IS_ZERO = 4009;


ERROR_ITEM_WITHOUT_ID

Declaration

Source position: intuition.pas line 333

const ERROR_ITEM_WITHOUT_ID = 4003;


ERROR_SEPARATOR_AT_TITLE_LEVEL

Declaration

Source position: intuition.pas line 334

const ERROR_SEPARATOR_AT_TITLE_LEVEL = 4004;


ERROR_SUBITEMS_WITHOUT_PARENT

Declaration

Source position: intuition.pas line 332

const ERROR_SUBITEMS_WITHOUT_PARENT = 4002;


ERROR_TITLE_OUT_OF_PLACE

Declaration

Source position: intuition.pas line 331

const ERROR_TITLE_OUT_OF_PLACE = 4001;


ESA_Dummy

Declaration

Source position: intuition.pas line 1805

const ESA_Dummy = $00340000;


ESA_Position

Declaration

Source position: intuition.pas line 1806

const ESA_Position = ESA_Dummy + 1;


ESA_Underscore

Declaration

Source position: intuition.pas line 1807

const ESA_Underscore = ESA_Dummy + 2;


ESF_EVENSIZE

Declaration

Source position: intuition.pas line 1802

const ESF_EVENSIZE = $00000004;


ESF_INACTIVE

Declaration

Source position: intuition.pas line 1803

const ESF_INACTIVE = $00000008;


ESF_SCREEN

Declaration

Source position: intuition.pas line 1800

const ESF_SCREEN = $00000001;


ESF_TAGGED

Declaration

Source position: intuition.pas line 1801

const ESF_TAGGED = $00000002;


ET_MENUHELP

Declaration

Source position: intuition.pas line 329

const ET_MENUHELP = 1;


ET_MENUPICK

Declaration

Source position: intuition.pas line 328

const ET_MENUPICK = 0;


EURO_A0

Value for TPreferences.PaperSize European size A0: 841 x 1189

Declaration

Source position: intuition.pas line 2365

const EURO_A0 = $50;


EURO_A1

Value for TPreferences.PaperSize European size A1: 594 x 841

Declaration

Source position: intuition.pas line 2366

const EURO_A1 = $60;


EURO_A2

Value for TPreferences.PaperSize European size A2: 420 x 594

Declaration

Source position: intuition.pas line 2367

const EURO_A2 = $70;


EURO_A3

Value for TPreferences.PaperSize European size A3: 297 x 420

Declaration

Source position: intuition.pas line 2368

const EURO_A3 = $80;


EURO_A4

Value for TPreferences.PaperSize European size A4: 210 x 297

Declaration

Source position: intuition.pas line 2369

const EURO_A4 = $90;


EURO_A5

Value for TPreferences.PaperSize European size A5: 148 x 210

Declaration

Source position: intuition.pas line 2370

const EURO_A5 = $A0;


EURO_A6

Value for TPreferences.PaperSize European size A6: 105 x 148

Declaration

Source position: intuition.pas line 2371

const EURO_A6 = $B0;


EURO_A7

Value for TPreferences.PaperSize European size A7: 74 x 105

Declaration

Source position: intuition.pas line 2372

const EURO_A7 = $C0;


EURO_A8

Value for TPreferences.PaperSize European size A8: 52 x 74

Declaration

Source position: intuition.pas line 2373

const EURO_A8 = $D0;


EVENTMAX

Declaration

Source position: intuition.pas line 2443

const EVENTMAX = 10;


FANFOLD_PT

Declaration

Source position: intuition.pas line 2336

const FANFOLD_PT = $00;


FILENAME_SIZE

Filename size for printer configuration

Declaration

Source position: intuition.pas line 2224

const FILENAME_SIZE = 30;


FILLFLATPEN

Declaration

Source position: intuition.pas line 1990

const FILLFLATPEN = $002B;


FILLPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. active-window/selected-gadget fill

Declaration

Source position: intuition.pas line 1950

const FILLPEN = $0005;


FILLRECTCLASS

Class identifier

Declaration

Source position: intuition.pas line 2527

const FILLRECTCLASS: PChar = 'fillrectclass';

Description

SuperClass: imageclass

This is a class of filled rectangles. The fillrectclass object can use a pattern to fill in its interior.

Changed Methods:

IM_DRAW

Attributes:

IA_APattern (IS)

IA_APatSize (IS)

IA_Mode (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


FILLSHADOWPEN

Declaration

Source position: intuition.pas line 1964

const FILLSHADOWPEN = $0011;


FILLSHINEPEN

Declaration

Source position: intuition.pas line 1963

const FILLSHINEPEN = $0010;


FILLTEXTPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. text over FILLPEN

Declaration

Source position: intuition.pas line 1951

const FILLTEXTPEN = $0006;


FINE

Value for TPreferences.PrintPitch

Declaration

Source position: intuition.pas line 2341

const FINE = $800;


FLATBORDERPEN

Declaration

Source position: intuition.pas line 1989

const FLATBORDERPEN = $002A;


FLOYD_DITHERING

Flag for TPreferences.PrintFlags Floyd-Steinberg dithering

Declaration

Source position: intuition.pas line 2428

const FLOYD_DITHERING = $0400;


FOREGROUNDPEN

Declaration

Source position: intuition.pas line 1960

const FOREGROUNDPEN = $000D;


FORESHADOWPEN

Declaration

Source position: intuition.pas line 1962

const FORESHADOWPEN = $000F;


FORESHINEPEN

Declaration

Source position: intuition.pas line 1961

const FORESHINEPEN = $000E;


FRAME_BUTTON

Data value for IA_FrameType Standard button gadget frames, having thicker sides and nicely edged corners.

Declaration

Source position: intuition.pas line 3184

const FRAME_BUTTON = 1;

Description

recognized by FrameIClass


FRAME_DEFAULT

Data value for IA_FrameType The standard V37-type frame, which has thin edges.

Declaration

Source position: intuition.pas line 3183

const FRAME_DEFAULT = 0;

Description

recognized by FrameIClass


FRAME_DISPLAY

Declaration

Source position: intuition.pas line 3190

const FRAME_DISPLAY = 6;


FRAME_ICONDROPBOX

Data value for IA_FrameType A broad ridge which is the standard imagery for areas in AppWindows where icons may be dropped.

Declaration

Source position: intuition.pas line 3186

const FRAME_ICONDROPBOX = 3;

Description

recognized by FrameIClass


FRAME_PROPBORDER

Declaration

Source position: intuition.pas line 3188

const FRAME_PROPBORDER = 4;


FRAME_PROPKNOB

Declaration

Source position: intuition.pas line 3189

const FRAME_PROPKNOB = 5;


FRAME_RIDGE

Data value for IA_FrameType A ridge such as used by standard string gadgets. You can recess the ridge to get a groove image.

Declaration

Source position: intuition.pas line 3185

const FRAME_RIDGE = 2;

Description

recognized by FrameIClass


FRAMEBUTTON_3D

Declaration

Source position: intuition.pas line 1665

const FRAMEBUTTON_3D = 0;


FRAMEBUTTON_FLAT

Declaration

Source position: intuition.pas line 1667

const FRAMEBUTTON_FLAT = 2;


FRAMEBUTTON_FRAMED

Declaration

Source position: intuition.pas line 1666

const FRAMEBUTTON_FRAMED = 1;


FRAMEDISCOL_BACKG

Declaration

Source position: intuition.pas line 1661

const FRAMEDISCOL_BACKG = 1;


FRAMEDISCOL_DISAB

Declaration

Source position: intuition.pas line 1662

const FRAMEDISCOL_DISAB = 2;


FRAMEDISCOL_FOREG

Declaration

Source position: intuition.pas line 1660

const FRAMEDISCOL_FOREG = 0;


FRAMEDISPLAY_3D

Declaration

Source position: intuition.pas line 1682

const FRAMEDISPLAY_3D = 0;


FRAMEDISPLAY_FLAT

Declaration

Source position: intuition.pas line 1684

const FRAMEDISPLAY_FLAT = 2;


FRAMEDISPLAY_FRAMED

Declaration

Source position: intuition.pas line 1683

const FRAMEDISPLAY_FRAMED = 1;


FRAMEDISPLAY_FRAMED2

Declaration

Source position: intuition.pas line 1685

const FRAMEDISPLAY_FRAMED2 = 3;


FRAMEF_SPECIFY

Flag for TimpFrameBox.imp_FrameFlags

Declaration

Source position: intuition.pas line 3240

const FRAMEF_SPECIFY = 1 shl 0;


FRAMEICLASS

Class identifier. This is a class of framing image, which can optionally fill itself.

Declaration

Source position: intuition.pas line 2525

const FRAMEICLASS: PChar = 'frameiclass';

Description

SuperClass: imageclass

This is a class of framing image, which can optionally fill itself. Its purpose is to frame other display elements using an embossed or recessed rectangular frame. The frame renders itself using the appropriate TDrawInfo pens (SHINEPEN, SHADOWPEN, etc.). This class is intelligent enough to bound or center its contents.

Changed Methods:

IM_DRAW, IDS_NORMAL, IDS_INACTIVENORMAL, IDS_DISABLED, IDS_SELECTED, IDS_INACTIVESELECTED, IM_DRAWFRAME, IM_FRAMEBOX

Attributes:

IA_Recessed (IS)

IA_EdgesOnly (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


FRAMEPRESSED_INVERTED

Declaration

Source position: intuition.pas line 1689

const FRAMEPRESSED_INVERTED = 1;


FRAMEPRESSED_PUSHED

Declaration

Source position: intuition.pas line 1688

const FRAMEPRESSED_PUSHED = 0;


FRAMEPROP_3D

Declaration

Source position: intuition.pas line 1676

const FRAMEPROP_3D = 0;


FRAMEPROP_FLAT

Declaration

Source position: intuition.pas line 1678

const FRAMEPROP_FLAT = 2;


FRAMEPROP_FRAMED

Declaration

Source position: intuition.pas line 1677

const FRAMEPROP_FRAMED = 1;


FRAMEPROP_NONE

Declaration

Source position: intuition.pas line 1679

const FRAMEPROP_NONE = 3;


FRAMESELCOL_BACKG

Declaration

Source position: intuition.pas line 1657

const FRAMESELCOL_BACKG = 3;


FRAMESELCOL_FILL

Declaration

Source position: intuition.pas line 1654

const FRAMESELCOL_FILL = 0;


FRAMESELCOL_FOREG

Declaration

Source position: intuition.pas line 1656

const FRAMESELCOL_FOREG = 2;


FRAMESELCOL_SELECT

Declaration

Source position: intuition.pas line 1655

const FRAMESELCOL_SELECT = 1;


FRAMESTRING_3D

Declaration

Source position: intuition.pas line 1670

const FRAMESTRING_3D = 0;


FRAMESTRING_FLAT

Declaration

Source position: intuition.pas line 1672

const FRAMESTRING_FLAT = 2;


FRAMESTRING_FRAMED

Declaration

Source position: intuition.pas line 1671

const FRAMESTRING_FRAMED = 1;


FRAMESTRING_FRAMED2

Declaration

Source position: intuition.pas line 1673

const FRAMESTRING_FRAMED2 = 3;


FRAMETHIN_EDGESONLYRAISED

Declaration

Source position: intuition.pas line 1650

const FRAMETHIN_EDGESONLYRAISED = $04;


FRAMETHIN_EDGESONLYRECESSED

Declaration

Source position: intuition.pas line 1651

const FRAMETHIN_EDGESONLYRECESSED = $08;


FRAMETHIN_FILLEDRAISED

Declaration

Source position: intuition.pas line 1648

const FRAMETHIN_FILLEDRAISED = $01;


FRAMETHIN_FILLEDRECESSED

Declaration

Source position: intuition.pas line 1649

const FRAMETHIN_FILLEDRECESSED = $02;


FRAMEWINDOW_3D

Declaration

Source position: intuition.pas line 1643

const FRAMEWINDOW_3D = 0;


FRAMEWINDOW_FLAT

Declaration

Source position: intuition.pas line 1645

const FRAMEWINDOW_FLAT = 2;


FRAMEWINDOW_FRAMED

Declaration

Source position: intuition.pas line 1644

const FRAMEWINDOW_FRAMED = 1;


FRBUTTONCLASS

Class identifier. A buttongclass gadget that outlines its imagery with a frame.

Declaration

Source position: intuition.pas line 2532

const FRBUTTONCLASS: PChar = 'frbuttonclass';

Description

This is a special class of button gadget that puts a Boopsi framing image around some other display element. This display element can be one of three things: plain text from the GA_Text attribute, an IntuiText from the GA_IntuiText attribute, or an Image from the GA_LabelImage attribute.

The user activates the gadget by clicking within the bounds of the gadget's framing image, which it gets from the GA_Image attribute. Usually the framing image is an instance of an image class that supports the IM_FRAMEBOX method (like frameiclass). If the framing image supports the IM_FRAMEBOX method, the frbuttonclass object centers the frame image around the display element. See the imageclass description of IM_FRAMEBOX for more information.

Changed Methods:

OM_NEW, GM_HITTEST, GM_RENDER

Attributes:

GA_Width (S)

GA_Height (S)

GA_DrawInfo (I)

GA_Text (IS)

GA_IntuiText (IS)

GA_LabelImage (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


FREEHORIZ

Flag value for TPropInfo.Flags. if set, the knob can move horizontally

Declaration

Source position: intuition.pas line 680

const FREEHORIZ = $0002;


FREEVERT

Flag value for TPropInfo.Flags. if set, the knob can move vertically

Declaration

Source position: intuition.pas line 681

const FREEVERT = $0004;


GA_ActivateKey

GadgetClass Tag. (PChar) Set/Get the gadgets shortcut/activation key(s) Default = nil

Declaration

Source position: intuition.pas line 2711

const GA_ActivateKey = GA_Dummy + 43;


GA_BackFill

GadgetClass Tag. (PHook) Backfill pattern hook. Defaults to nil.

Declaration

Source position: intuition.pas line 2712

const GA_BackFill = GA_Dummy + 44;


GA_Border

GadgetClass Tag. (PBorder) Gadget imagry is a border

Declaration

Source position: intuition.pas line 2670

const GA_Border = GA_Dummy + 11;


GA_BottomBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the bottom border or not. Default = False.

Declaration

Source position: intuition.pas line 2689

const GA_BottomBorder = GA_Dummy + 27;


GA_Bounds

GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.

Declaration

Source position: intuition.pas line 2704

const GA_Bounds = GA_Dummy + 38;


GA_ContextMenu

Declaration

Source position: intuition.pas line 2728

const GA_ContextMenu = GA_Dummy + 57;


GA_Disabled

GadgetClass Tag. [IS.] (LongWord) Takes GFLG_GADGH* flags as argument. Used to specify the highlighting technique.

Declaration

Source position: intuition.pas line 2673

const GA_Disabled = GA_Dummy + 14;


GA_DoLayout

Declaration

Source position: intuition.pas line 2717

const GA_DoLayout = GA_Dummy + 51;


GA_DrawInfo

GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.

Declaration

Source position: intuition.pas line 2696

const GA_DrawInfo = GA_Dummy + 33;

Description

Read the documentation of the subclasses to learn, which need this attribute. To be on the safe side, you can always supply it.


GA_Dummy

GadgetClass Start Tag.

Declaration

Source position: intuition.pas line 2659

const GA_Dummy = TAG_USER + $30000;


GA_EndGadget

GadgetClass Tag. [ISG] (LongBool) Indicate whether the gadget is selected or not. Default = False

Declaration

Source position: intuition.pas line 2679

const GA_EndGadget = GA_Dummy + 20;


GA_FollowMouse

GadgetClass Tag. [IS.] (LongBool) If this is set, the gadget receives information about the movement of the mouse as long as it is activated. Default = False

Declaration

Source position: intuition.pas line 2683

const GA_FollowMouse = GA_Dummy + 23;


GA_GadgetHelp

GadgetClass Tag. [..G] (LongBool) If this is set by the gadget, the sends GADGETHELP messages.

Declaration

Source position: intuition.pas line 2703

const GA_GadgetHelp = GA_Dummy + 37;


GA_GadgetHelpText

GadgetClass Tag. (PChar) RESERVERD/PRIVATE DO NOT USE. Default = nil

Declaration

Source position: intuition.pas line 2713

const GA_GadgetHelpText = GA_Dummy + 45;


GA_GZZGadget

GadgetClass Tag. [ISG] (LongBool) If this is set to true, the gadget is not selectable.

Declaration

Source position: intuition.pas line 2674

const GA_GZZGadget = GA_Dummy + 15;

Description

Often this is visually represented by using a special disabled pattern.


GA_Height

GadgetClass Tag. [ISG] (LongInt) Height of gadget.

Declaration

Source position: intuition.pas line 2666

const GA_Height = GA_Dummy + 7;


GA_Hidden

Declaration

Source position: intuition.pas line 2725

const GA_Hidden = GA_Dummy + 54;


GA_Highlight

GadgetClass Tag. [IS.] (PImage) Gadgets' image in selected state.

Declaration

Source position: intuition.pas line 2672

const GA_Highlight = GA_Dummy + 13;

Description

Note that if this is nil and GA_Image is in fact an image object, GA_Image may be tried to be drawn with IDS_SELECTED. So you do not need to fill this in, if you wish to have a special selected image and GA_Image is an image object that supports the selected state.


GA_HintInfo

Declaration

Source position: intuition.pas line 2727

const GA_HintInfo = GA_Dummy + 56;


GA_ID

GadgetClass Tag. [IS.] (LongBool) The Gadget is a GimmeZeroZero gadget. Default = False

Declaration

Source position: intuition.pas line 2675

const GA_ID = GA_Dummy + 16;


GA_Image

GadgetClass Tag. (PImage) Gadget imagry is an image

Declaration

Source position: intuition.pas line 2669

const GA_Image = GA_Dummy + 10;


GA_Immediate

GadgetClass Tag. [IS.] (LongBool) Only used for requester gadgets. Default = False

Declaration

Source position: intuition.pas line 2680

const GA_Immediate = GA_Dummy + 21;

Description

This tells intuition that the requester is to be closed, when the gadget is released.


GA_IntuiText

GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.

Declaration

Source position: intuition.pas line 2698

const GA_IntuiText = GA_Dummy + 34;


GA_LabelImage

GadgetClass Tag. [IS.] (PObject_) Label is an image object.

Declaration

Source position: intuition.pas line 2699

const GA_LabelImage = GA_Dummy + 35;


GA_Left

GadgetClass Tag. [ISG] (LongInt) Left edge of gadget.

Declaration

Source position: intuition.pas line 2660

const GA_Left = GA_Dummy + 1;


GA_LeftBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the left border or not. Default = False.

Declaration

Source position: intuition.pas line 2687

const GA_LeftBorder = GA_Dummy + 25;


GA_Next

GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.

Declaration

Source position: intuition.pas line 2695

const GA_Next = GA_Dummy + 32;


GA_NoFilterMenuKeys

Declaration

Source position: intuition.pas line 2721

const GA_NoFilterMenuKeys = GA_Dummy + 52;


GA_NoFilterWheel

Declaration

Source position: intuition.pas line 2726

const GA_NoFilterWheel = GA_Dummy + 55;


GA_Previous

GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.

Declaration

Source position: intuition.pas line 2693

const GA_Previous = GA_Dummy + 31;

Description

This is used to link the current gadget into a gadget list, before this list is used. It can not be used to add a gadget to a list of an open window or requester!


GA_ReadOnly

GadgetClass Tag. (LongBool) Indicate that the gadget is read-only (non-selectable). Default = False

Declaration

Source position: intuition.pas line 2708

const GA_ReadOnly = GA_Dummy + 41;


GA_RelBottom

GadgetClass Tag. [ISG] (LongInt) Top edge of gadget, depending on bottom window border: Top := Win^.Height - this - 1

Declaration

Source position: intuition.pas line 2663

const GA_RelBottom = GA_Dummy + 4;


GA_RelHeight

GadgetClass Tag. [ISG] (LongInt) Height of gadget, depending on window height: Height := Win^.Height - this

Declaration

Source position: intuition.pas line 2667

const GA_RelHeight = GA_Dummy + 8;


GA_RelRight

GadgetClass Tag. [ISG] (LongInt) Left edge of gadget, depending on right window border: Left := Win^.Width - this - 1

Declaration

Source position: intuition.pas line 2661

const GA_RelRight = GA_Dummy + 2;


GA_RelSpecial

GadgetClass Tag. [IS.] (LongInt) This attribute should only be set by subclasses of GadgetClass.

Declaration

Source position: intuition.pas line 2705

const GA_RelSpecial = GA_Dummy + 39;

Description

Applications should keep their hands away! If set this means, that GM_LAYOUT is called, when the window it is in is opened or its size changes. This allows gadgets to make their own size dependent on the size of the window.


GA_RelVerify

GadgetClass Tag. [IS.] (LongBool) If set the gadget responds immediatly, when the gadget is selected. Default = False

Declaration

Source position: intuition.pas line 2681

const GA_RelVerify = GA_Dummy + 22;


GA_RelWidth

GadgetClass Tag. [ISG] (LongInt) Width of gadget, depending on window width: Width := Win^.Width - this

Declaration

Source position: intuition.pas line 2665

const GA_RelWidth = GA_Dummy + 6;


GA_RightBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the right border or not. Default = False.

Declaration

Source position: intuition.pas line 2686

const GA_RightBorder = GA_Dummy + 24;


GA_Selected

GadgetClass Tag. (APTR) Pointer to additional information

Declaration

Source position: intuition.pas line 2678

const GA_Selected = GA_Dummy + 19;

Description

Needed by some gadgets (like string or integer gadgets). This field should generally only be set by subclasses of GadgetClass. Applications should keep their hands off it.


GA_SelectRender

GadgetClass Tag.

Declaration

Source position: intuition.pas line 2671

const GA_SelectRender = GA_Dummy + 12;


GA_SpecialInfo

GadgetClass Tag. [ISG] (IPTR) Fill with whatever you want to. This field is ignored by the system.

Declaration

Source position: intuition.pas line 2677

const GA_SpecialInfo = GA_Dummy + 18;


GA_SysGadget

GadgetClass private Tag. [IS.] (LongBool) Set, if gadget is a system-gadget e.g. a standard window border gadget. Default = False.

Declaration

Source position: intuition.pas line 2691

const GA_SysGadget = GA_Dummy + 29;


GA_SysGType

GadgetClass private Tag. [IS.] (LongWord) Reserved for system use to indicate the gadget type.

Declaration

Source position: intuition.pas line 2692

const GA_SysGType = GA_Dummy + 30;


GA_TabCycle

GadgetClass Tag. [IS.] (LongBool) If set to true that gadget participates in TAB handling, i.e. if tab is pressed, the next gadget is activated.

Declaration

Source position: intuition.pas line 2701

const GA_TabCycle = GA_Dummy + 36;


GA_Text

GadgetClass Tag. [IS.] (PChar) Label text. This is mutually exclusive with GA_IntuiText and GA_LabelImage.

Declaration

Source position: intuition.pas line 2668

const GA_Text = GA_Dummy + 9;


GA_TextAttr

GadgetClass Tag. [IS.] (PTextAttr) Indicate the font to use for the gadget.

Declaration

Source position: intuition.pas line 2707

const GA_TextAttr = GA_Dummy + 40;


GA_Titlebar

Declaration

Source position: intuition.pas line 2722

const GA_Titlebar = GA_Dummy + 53;


GA_ToggleSelect

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is toggle-selected or not. Default = False.

Declaration

Source position: intuition.pas line 2690

const GA_ToggleSelect = GA_Dummy + 28;


GA_Top

GadgetClass Tag. [ISG] (LongInt) Top edge of gadget.

Declaration

Source position: intuition.pas line 2662

const GA_Top = GA_Dummy + 3;


GA_TopBorder

GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the top border or not. Default = False.

Declaration

Source position: intuition.pas line 2688

const GA_TopBorder = GA_Dummy + 26;


GA_Underscore

GadgetClass Tag. (Char) Underscore/escape character for keyboard shortcuts. Defaults = '_'

Declaration

Source position: intuition.pas line 2710

const GA_Underscore = GA_Dummy + 42;


GA_UserData

GadgetClass Tag. (LongInt) Gadget ID assigned by the application (prevent double numbers)

Declaration

Source position: intuition.pas line 2676

const GA_UserData = GA_Dummy + 17;


GA_UserInput

GadgetClass Tag. (LongBool) Notification tag indicates this notification is from the activite gadget receiving user input - an attempt to make IDCMPUPDATE more efficient.

Declaration

Source position: intuition.pas line 2714

const GA_UserInput = GA_Dummy + 46;


GA_Width

GadgetClass Tag. [ISG] (LongInt) Width of gadget.

Declaration

Source position: intuition.pas line 2664

const GA_Width = GA_Dummy + 5;


GACT_ACTIVEGADGET

Activation flag for TGadget.Activation. This gadget is "active".

Declaration

Source position: intuition.pas line 564

const GACT_ACTIVEGADGET = $4000;

Description

This flag is maintained by Intuition, and you cannot count on its value persisting while you do something on your program's task. It can only be trusted by people implementing custom gadgets


GACT_ALTKEYMAP

Activation flag for TGadget.Activation. this String has an alternate keymap

Declaration

Source position: intuition.pas line 559

const GACT_ALTKEYMAP = $1000;


GACT_BOOLEXTEND

Activation flag for TGadget.Activation. this Boolean Gadget has a BoolInfo

Declaration

Source position: intuition.pas line 552

const GACT_BOOLEXTEND = $2000;


GACT_BORDERSNIFF

Activation flag for TGadget.Activation. neither set nor rely on this bit

Declaration

Source position: intuition.pas line 549

const GACT_BORDERSNIFF = $8000;


GACT_BOTTOMBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 548

const GACT_BOTTOMBORDER = $0080;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GACT_ENDGADGET

Activation flag for TGadget.Activation. when set, tells the system that this gadget, when selected, causes the Requester to be ended. Requesters that are ended are erased and unlinked from the system.

Declaration

Source position: intuition.pas line 535

const GACT_ENDGADGET = $0004;


GACT_FOLLOWMOUSE

Activation flag for TGadget.Activation. when set, specifies that you want to receive reports on mouse movements

Declaration

Source position: intuition.pas line 541

const GACT_FOLLOWMOUSE = $0008;

Description

Flag, when set, specifies that you want to receive reports on mouse movements while this gadget is active. You probably want to set the GACT_IMMEDIATE flag when using GACT_FOLLOWMOUSE, since that's the only reasonable way you have of learning why Intuition is suddenly sending you a stream of mouse movement events. If you don't set GACT_RELVERIFY, you'll get at least one Mouse Position event.


GACT_IMMEDIATE

Activation flag for TGadget.Activation. when set, informs the caller that the gadget was activated when it was activated. This flag works in conjunction with the GACT_RELVERIFY flag

Declaration

Source position: intuition.pas line 531

const GACT_IMMEDIATE = $0002;


GACT_LEFTBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 546

const GACT_LEFTBORDER = $0020;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GACT_LONGINT

Activation flag for TGadget.Activation. this String Gadget is for LongInts

Declaration

Source position: intuition.pas line 558

const GACT_LONGINT = $0800;


GACT_RELVERIFY

Activation flag for TGadget.Activation. Set if you want to verify that the pointer was still over the gadget when the select button was released. Will cause an IDCMP_GADGETUP message to be sent if so.

Declaration

Source position: intuition.pas line 527

const GACT_RELVERIFY = $0001;


GACT_RIGHTBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 545

const GACT_RIGHTBORDER = $0010;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GACT_STRINGCENTER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 556

const GACT_STRINGCENTER = $0200;


GACT_STRINGEXTEND

Activation flag for TGadget.Activation. this String Gadget has PStringExtend

Declaration

Source position: intuition.pas line 560

const GACT_STRINGEXTEND = $2000;


GACT_STRINGLEFT

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 555

const GACT_STRINGLEFT = $0000;


GACT_STRINGRIGHT

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 557

const GACT_STRINGRIGHT = $0400;


GACT_TOGGLESELECT

Activation flag for TGadget.Activation. this bit for toggle-select mode

Declaration

Source position: intuition.pas line 551

const GACT_TOGGLESELECT = $0100;


GACT_TOPBORDER

Activation flag for TGadget.Activation.

Declaration

Source position: intuition.pas line 547

const GACT_TOPBORDER = $0040;

Description

if set in a Gadget that's included in the Gadget list when a Window is opened, the corresponding Border will be adjusted to make room for the Gadget


GADGETCLASS

Class identifier. This is a base class for Intuition compatible gadget objects.

Declaration

Source position: intuition.pas line 2528

const GADGETCLASS: PChar = 'gadgetclass';

Description

SuperClass: rootclass

This is a base class for Intuition compatible gadget objects. The dispatcher for this class takes care of creating an Intuition Gadget structure as part of its local instance data. All of the standard Boopsi gadget classes build on this class. Normally there are no direct instances of this class, only instances of subclasses of gadgetclass.

The behavior of a Boopsi gadget depends on how it handles the five Boopsi gadget methods: GM_HITTEST, GM_RENDER, GM_GOACTIVE, GM_HANDLEINPUT, and GM_GOINACTIVE. Intuition controls a Boopsi gadget by sending it these types of messages. The structures that these methods use for their messages begin with the method's ID followed by a pointer to a TGadgetInfo structure . The GadgetInfo structure is a read-only structure that contains information about the gadget's rendering environment. The gadget uses this to find things like its window, screen, or pen array. Although this structure does contain a pointer to a RastPort for the gadget, the gadget must not use this RastPort for rendering. The gadget can obtain a RastPort for rendering by calling the Intuition function ObtainGIRPort() using the GadgetInfo structure.

These methods are not defined directly by gadgetclass. It is up to subclasses of gadgetclass to implement them.

Like all Boopsi methods, these methods run on the context of the task that called the method. Normally, Intuition is the only entity that calls these methods, so these normally operate in the input.device's task. Because a gadget may have to process a large number of input events, poor implementations of gadget methods (especially the GM_HANDLEINPUT method) can degrade system performance.

New Methods:

GM_HITTEST, GM_GOACTIVE, GM_GOINACTIVE, GM_RENDER, GM_HANDLEINPUT

Changed Methods:

OM_NEW, OM_NOTIFY

Attributes:

GA_Previous (I)

ICA_TARGET (IS)

ICA_MAP (IS)

GA_Left (IS)

GA_Top (IS)

GA_Width (IS)

GA_Height (IS)

GA_RelRight (IS)

GA_RelBottom (IS)

GA_RelWidth (IS)

GA_RelHeight (IS)

The remaining attributes defined by gadgetclass are used to set the fields in the Gadget structure of the Boopsi gadget. Some Boopsi gadgets do not pay attention to many of the fields in its Gadget structure, so most applications will not have to worry about the majority of these attributes. Some gadget classes assign special meanings to these attributes. See the documentation of the specific gadget classes for more details.

GA_IntuiText (IS)

GA_Text (IS)

GA_LabelImage (IS)

GA_Image (IS)

GA_Border (IS)

GA_SelectRender (IS)

GA_ID (IS)

GA_UserData (IS)

GA_SpecialInfo (IS)

GA_GZZGadget (IS)

GA_SysGadget (IS)

GA_Disabled (IS)

GA_Selected (IS)

GA_EndGadget (IS)

GA_Immediate (IS)

GA_RelVerify (IS)

GA_FollowMouse (IS)

GA_RightBorder (IS)

GA_LeftBorder (IS)

GA_TopBorder (IS)

GA_BottomBorder (IS)

GA_ToggleSelect (IS)

GA_TabCycle (IS)

GA_Highlight (IS)

GA_SysGType (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


GADGETCOUNT

Declaration

Source position: intuition.pas line 2449

const GADGETCOUNT = 8;


GADGETPEN

Declaration

Source position: intuition.pas line 1985

const GADGETPEN = $0026;


GAUGE_BORDERPENS

Declaration

Source position: intuition.pas line 1726

const GAUGE_BORDERPENS = $00100000;


GAUGE_CONT_3D

Declaration

Source position: intuition.pas line 1717

const GAUGE_CONT_3D = $00000100;


GAUGE_CONT_AUTOSTYLE

Declaration

Source position: intuition.pas line 1721

const GAUGE_CONT_AUTOSTYLE = $00000700;


GAUGE_CONT_BORDERLESS

Declaration

Source position: intuition.pas line 1716

const GAUGE_CONT_BORDERLESS = $00000000;


GAUGE_CONT_FLAT

Declaration

Source position: intuition.pas line 1719

const GAUGE_CONT_FLAT = $00000300;


GAUGE_CONT_FRAMED

Declaration

Source position: intuition.pas line 1718

const GAUGE_CONT_FRAMED = $00000200;


GAUGE_CONT_FRAMED2

Declaration

Source position: intuition.pas line 1720

const GAUGE_CONT_FRAMED2 = $00000400;


GAUGE_CONT_GRADIENT

Declaration

Source position: intuition.pas line 1722

const GAUGE_CONT_GRADIENT = $00001000;


GAUGE_CONT_STYLEMASK

Declaration

Source position: intuition.pas line 1715

const GAUGE_CONT_STYLEMASK = $00000700;


GAUGE_FILL_3D

Declaration

Source position: intuition.pas line 1710

const GAUGE_FILL_3D = $00000001;


GAUGE_FILL_AUTOSTYLE

Declaration

Source position: intuition.pas line 1713

const GAUGE_FILL_AUTOSTYLE = $00000007;


GAUGE_FILL_BORDERLESS

Declaration

Source position: intuition.pas line 1709

const GAUGE_FILL_BORDERLESS = $00000000;


GAUGE_FILL_FLAT

Declaration

Source position: intuition.pas line 1712

const GAUGE_FILL_FLAT = $00000003;


GAUGE_FILL_FRAMED

Declaration

Source position: intuition.pas line 1711

const GAUGE_FILL_FRAMED = $00000002;


GAUGE_FILL_GRADIENT

Declaration

Source position: intuition.pas line 1714

const GAUGE_FILL_GRADIENT = $00000010;


GAUGE_FILL_STYLEMASK

Declaration

Source position: intuition.pas line 1708

const GAUGE_FILL_STYLEMASK = $00000007;


GAUGE_INNERTICKS

Declaration

Source position: intuition.pas line 1724

const GAUGE_INNERTICKS = $00040000;


GAUGE_RESERVED

Declaration

Source position: intuition.pas line 1727

const GAUGE_RESERVED = $80000000;


GAUGE_SPACINGMASK

Declaration

Source position: intuition.pas line 1723

const GAUGE_SPACINGMASK = $00030000;


GAUGE_UNUSED

Declaration

Source position: intuition.pas line 1725

const GAUGE_UNUSED = $00080000;


GAUGEIA_InnerTicks

Declaration

Source position: intuition.pas line 3123

const GAUGEIA_InnerTicks = IA_Dummy + $35;


GAUGEIA_Level

Declaration

Source position: intuition.pas line 3119

const GAUGEIA_Level = IA_Dummy + $31;


GAUGEIA_Max

Declaration

Source position: intuition.pas line 3118

const GAUGEIA_Max = IA_Dummy + $30;


GAUGEIA_Min

Declaration

Source position: intuition.pas line 3117

const GAUGEIA_Min = IA_Dummy + $2F;


GAUGEIA_ScaleHook

Declaration

Source position: intuition.pas line 3124

const GAUGEIA_ScaleHook = IA_Dummy + $36;


GAUGEIA_ShortTicks

Declaration

Source position: intuition.pas line 3122

const GAUGEIA_ShortTicks = IA_Dummy + $34;


GAUGEIA_Ticks

Declaration

Source position: intuition.pas line 3120

const GAUGEIA_Ticks = IA_Dummy + $32;


GAUGEIA_TickSize

Declaration

Source position: intuition.pas line 3121

const GAUGEIA_TickSize = IA_Dummy + $33;


GBD_BOX

Declaration

Source position: intuition.pas line 619

const GBD_BOX = 1;


GBD_GINFO

Declaration

Source position: intuition.pas line 621

const GBD_GINFO = 3;


GBD_RECTANGLE

Declaration

Source position: intuition.pas line 620

const GBD_RECTANGLE = 2;


GBD_WINDOW

Declaration

Source position: intuition.pas line 618

const GBD_WINDOW = 0;


GBF_BOUNDS

Declaration

Source position: intuition.pas line 624

const GBF_BOUNDS = $00000001;


GBF_MAKERECT

Declaration

Source position: intuition.pas line 625

const GBF_MAKERECT = $00000002;


Unit 'intuition' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

GCB_OK

Declaration

Source position: intuition.pas line 3729

const GCB_OK = 0;


GCB_UNKNOWN

Declaration

Source position: intuition.pas line 3730

const GCB_UNKNOWN = 1;


GDOMAIN_MAXIMUM

Declaration

Source position: intuition.pas line 2929

const GDOMAIN_MAXIMUM = 2;


GDOMAIN_MINIMUM

Declaration

Source position: intuition.pas line 2927

const GDOMAIN_MINIMUM = 0;


GDOMAIN_NOMINAL

Declaration

Source position: intuition.pas line 2928

const GDOMAIN_NOMINAL = 1;


GDOWNIMAGE

Declaration

Source position: intuition.pas line 3169

const GDOWNIMAGE = $22;


GEXTENT_ADD

Declaration

Source position: intuition.pas line 2987

const GEXTENT_ADD = 1;


GEXTENT_INVERT

Declaration

Source position: intuition.pas line 2988

const GEXTENT_INVERT = 2;


GEXTENT_REMOVE

Declaration

Source position: intuition.pas line 2986

const GEXTENT_REMOVE = 0;


GEXTENT_SECT

Declaration

Source position: intuition.pas line 2989

const GEXTENT_SECT = 3;


GFLG_DISABLED

Flag for TGadget.SpecialInfo. Is initialized by you and later set by Intuition according to your calls to OnGadget/OffGadget. It specifies whether or not this Gadget is currently disabled from being selected

Declaration

Source position: intuition.pas line 497

const GFLG_DISABLED = $0100;


GFLG_EXTENDED

Flag for TGadget.SpecialInfo. Gadget is an PExtGadget

Declaration

Source position: intuition.pas line 522

const GFLG_EXTENDED = $8000;

Description

If set, this bit means that the Gadget is actually a PExtGadget, with new fields and flags. All boopsi gadgets are PExtGadget. Never ever attempt to read the extended fields of a gadget if this flag is not set.


GFLG_GADGHBOX

Flag for TGadget.SpecialInfo. Draw a box around the image

Declaration

Source position: intuition.pas line 474

const GFLG_GADGHBOX = $0001;


GFLG_GADGHCOMP

Flag for TGadget.Flags. Complement the select box

Declaration

Source position: intuition.pas line 473

const GFLG_GADGHCOMP = $0000;


GFLG_GADGHIGHBITS

Flag for TGadget.SpecialInfo.

Declaration

Source position: intuition.pas line 472

const GFLG_GADGHIGHBITS = $0003;


GFLG_GADGHIMAGE

Flag for TGadget.SpecialInfo. Blast in this alternate image

Declaration

Source position: intuition.pas line 475

const GFLG_GADGHIMAGE = $0002;


GFLG_GADGHNONE

Flag for TGadget.SpecialInfo. don't highlight

Declaration

Source position: intuition.pas line 476

const GFLG_GADGHNONE = $0003;


GFLG_GADGIMAGE

Flag for TGadget.SpecialInfo. set if TGadget.GadgetRender and TGadget.SelectRender is PImage, clear if it is a PBorder

Declaration

Source position: intuition.pas line 478

const GFLG_GADGIMAGE = $0004;


GFLG_IMAGEDISABLE

Flag for TGadget.SpecialInfo. Gadget's image knows how to do disabled rendering

Declaration

Source position: intuition.pas line 518

const GFLG_IMAGEDISABLE = $0800;

Description

This flag is automatically set if the custom image of this gadget knows how to do disabled rendering (more specifically, if its IA_SupportsDisable attribute is True). Intuition uses this to defer the ghosting to the image-class, instead of doing it itself (the old compatible way). Do not set this flag yourself - Intuition will do it for you.


GFLG_LABELIMAGE

Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PImage

Declaration

Source position: intuition.pas line 505

const GFLG_LABELIMAGE = $2000;


GFLG_LABELITEXT

Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText

Declaration

Source position: intuition.pas line 503

const GFLG_LABELITEXT = $0000;


GFLG_LABELMASK

Flag for TGadget.SpecialInfo.

Declaration

Source position: intuition.pas line 502

const GFLG_LABELMASK = $3000;


GFLG_LABELSTRING

Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PChar

Declaration

Source position: intuition.pas line 504

const GFLG_LABELSTRING = $1000;


GFLG_RELBOTTOM

Flag for TGadget.SpecialInfo. vertical position is relative to bottom edge

Declaration

Source position: intuition.pas line 484

const GFLG_RELBOTTOM = $0008;


GFLG_RELHEIGHT

Flag for TGadget.SpecialInfo. height is relative to req/window

Declaration

Source position: intuition.pas line 487

const GFLG_RELHEIGHT = $0040;


GFLG_RELRIGHT

Flag for TGadget.SpecialInfo. horizontal position is relative to right edge

Declaration

Source position: intuition.pas line 485

const GFLG_RELRIGHT = $0010;


GFLG_RELSPECIAL

Flag for TGadget.SpecialInfo. Custom gadget has special relativity. Gadget box values are absolutes, but can be changed via the GM_LAYOUT method.

Declaration

Source position: intuition.pas line 492

const GFLG_RELSPECIAL = $4000;

Description

Allows custom gadget implementors to make gadgets whose position and size depend in an arbitrary way on their window's dimensions. The GM_LAYOUT method will be invoked for such a gadget (or any other GREL_xxx gadget) at suitable times, such as when the window opens or the window's size changes.


GFLG_RELWIDTH

Flag for TGadget.SpecialInfo. width is relative to req/window

Declaration

Source position: intuition.pas line 486

const GFLG_RELWIDTH = $0020;


GFLG_SELECTED

Flag for TGadget.SpecialInfo. you may initialize and look at this

Declaration

Source position: intuition.pas line 493

const GFLG_SELECTED = $0080;


GFLG_STRINGEXTEND

Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend

Declaration

Source position: intuition.pas line 513

const GFLG_STRINGEXTEND = $0400;


GFLG_TABCYCLE

Flag for TGadget.SpecialInfo. (string OR custom) gadget participates in cycling activation with Tab or Shift-Tab

Declaration

Source position: intuition.pas line 508

const GFLG_TABCYCLE = $0200;


GGF_BOUNDED

Declaration

Source position: intuition.pas line 3777

const GGF_BOUNDED = $00000020;


GGF_CALCHSCROLLER

Declaration

Source position: intuition.pas line 3773

const GGF_CALCHSCROLLER = $00000002;


GGF_CALCHSOVERLAP

Declaration

Source position: intuition.pas line 3775

const GGF_CALCHSOVERLAP = $00000008;


GGF_CALCVSCROLLER

Declaration

Source position: intuition.pas line 3774

const GGF_CALCVSCROLLER = $00000004;


GGF_CALCVSOVERLAP

Declaration

Source position: intuition.pas line 3776

const GGF_CALCVSOVERLAP = $00000010;


GGF_INITIAL

Declaration

Source position: intuition.pas line 3772

const GGF_INITIAL = $00000001;


GGPF_SCREENDRAGGING

Declaration

Source position: intuition.pas line 1640

const GGPF_SCREENDRAGGING = $00000001;


GHKHANDLEIMAGE

Declaration

Source position: intuition.pas line 3170

const GHKHANDLEIMAGE = $23;


GLEFTIMAGE

Declaration

Source position: intuition.pas line 3166

const GLEFTIMAGE = $1F;


GLYPHFILLPEN

Declaration

Source position: intuition.pas line 1982

const GLYPHFILLPEN = $0023;


GLYPHPEN

Declaration

Source position: intuition.pas line 1981

const GLYPHPEN = $0022;


GM_DOMAIN

Declaration

Source position: intuition.pas line 2803

const GM_DOMAIN = 7;


GM_Dummy

GadgetClass Method IDs Start

Declaration

Source position: intuition.pas line 2795

const GM_Dummy = - 1;


GM_EXTENT

Declaration

Source position: intuition.pas line 2809

const GM_EXTENT = 13;


GM_GOACTIVE

GadgetClass Method ID. You are now going to be fed input

Declaration

Source position: intuition.pas line 2798

const GM_GOACTIVE = 2;

Description

Tells the gadget that it has become active and will receive input from now on from the method GM_HANDLEINPUT. This is stopped by using GM_GOINACTIVE.

See also

PgpInput | Pointer to Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT


GM_GOINACTIVE

GadgetClass Method ID. Whether or not by choice, you are done

Declaration

Source position: intuition.pas line 2800

const GM_GOINACTIVE = 4;

See also

PgpGoInactive | Pointer to Message parameter passed for GM_GOINACTIVE
TgpGoInactive | Message parameter passed for GM_GOINACTIVE


GM_HANDLEINPUT

GadgetClass Method ID.

Declaration

Source position: intuition.pas line 2799

const GM_HANDLEINPUT = 3;

Description

GM_GOACTIVE tells the gadget that it has become active and will receive input from now on from the method >GM_HANDLEINPUT. This is stopped by using GM_GOINACTIVE.


GM_HANDLESCROLL

Declaration

Source position: intuition.pas line 2810

const GM_HANDLESCROLL = 14;


GM_HELPTEST

GadgetClass Method ID. Will you send gadget help if the mouse is at the specified coordinates? See below for possible GMR_ values.

Declaration

Source position: intuition.pas line 2801

const GM_HELPTEST = 5;

See also

PgpHitTest | Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST


GM_HITTEST

GadgetClass Method ID. Returns GMR_GADGETHIT if you are clicked on (whether or not you are disabled).

Declaration

Source position: intuition.pas line 2796

const GM_HITTEST = 0;

Description

This method is used to test, if a mouse-click hit the gadget. You return GMR_GADGETHIT, if you were hit and 0 otherwise. Note that you have to test, if you were hit, no matter if you are disabled or not.

See also

PgpHitTest | Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST


GM_KEYGOACTIVE

Declaration

Source position: intuition.pas line 2805

const GM_KEYGOACTIVE = 9;


GM_KEYGOINACTIVE

Declaration

Source position: intuition.pas line 2806

const GM_KEYGOINACTIVE = 10;


GM_KEYTEST

Declaration

Source position: intuition.pas line 2804

const GM_KEYTEST = 8;


GM_LAYOUT

GadgetClass Method ID. Re-evaluate your size based on the GadgetInfo Domain. Do NOT re-render yourself yet, you will be called when it is time...

Declaration

Source position: intuition.pas line 2802

const GM_LAYOUT = 6;

Description

This method is called by intuition, if on of the GFLG_REL* flags or one of the GA_Rel* attributes is set and the window size changes or you are added to a window. In this method you should re-evaluate the size of yourself. You are not allowed to do any rendering operation during this method!

See also

PgpLayout | Pointer to Message parameter passed for GM_LAYOUT
TgpLayout | Message parameter passed for GM_LAYOUT


GM_MENUHELP

Declaration

Source position: intuition.pas line 2813

const GM_MENUHELP = 17;


GM_MENUPICK

Declaration

Source position: intuition.pas line 2812

const GM_MENUPICK = 16;


GM_POSTRENDER

Declaration

Source position: intuition.pas line 2808

const GM_POSTRENDER = 12;


GM_PRERENDER

Declaration

Source position: intuition.pas line 2807

const GM_PRERENDER = 11;


GM_QUERY

Declaration

Source position: intuition.pas line 2811

const GM_QUERY = 15;


GM_RENDER

GadgetClass Method ID. Draw yourself, in the appropriate state

Declaration

Source position: intuition.pas line 2797

const GM_RENDER = 1;

Description

This method is invoked to draw the gadget into a rastport.

See also

PgpRender | Pointer to Message parameter passed for GM_RENDER
TgpRender | Message parameter passed for GM_RENDER


GMORE_BOUNDS

Flag for TExtGadget.MoreFlags ExtGadget has valid Bounds

Declaration

Source position: intuition.pas line 607

const GMORE_BOUNDS = $00000001;


GMORE_GADGETHELP

Flag for TExtGadget.MoreFlags This gadget responds to gadget help

Declaration

Source position: intuition.pas line 608

const GMORE_GADGETHELP = $00000002;


GMORE_HIDDEN

Declaration

Source position: intuition.pas line 611

const GMORE_HIDDEN = $00000010;


GMORE_NOCMENUOFFLOAD

Declaration

Source position: intuition.pas line 615

const GMORE_NOCMENUOFFLOAD = $00000100;


GMORE_NOFILTERMENUKEYS

Declaration

Source position: intuition.pas line 610

const GMORE_NOFILTERMENUKEYS = $00000008;


GMORE_NOFILTERWHEEL

Declaration

Source position: intuition.pas line 614

const GMORE_NOFILTERWHEEL = $00000080;


GMORE_PRIVATE

Declaration

Source position: intuition.pas line 612

const GMORE_PRIVATE = $00000020;


GMORE_PRIVATE2

Declaration

Source position: intuition.pas line 613

const GMORE_PRIVATE2 = $00000040;


GMORE_SCROLLRASTER

Flag for TExtGadget.MoreFlags This (custom) gadget uses ScrollRaster

Declaration

Source position: intuition.pas line 609

const GMORE_SCROLLRASTER = $00000004;


GMQ_CONTEXTMENU

Declaration

Source position: intuition.pas line 3014

const GMQ_CONTEXTMENU = 3;


GMQ_HINTINFO

Declaration

Source position: intuition.pas line 3012

const GMQ_HINTINFO = 1;


GMQ_WHICHMEMBER

Declaration

Source position: intuition.pas line 3013

const GMQ_WHICHMEMBER = 2;


GMR_CLIPDONE

Declaration

Source position: intuition.pas line 2996

const GMR_CLIPDONE = $00000040;


GMR_FULLBBOX

Declaration

Source position: intuition.pas line 2995

const GMR_FULLBBOX = $00000020;


GMR_FULLHBOX

Declaration

Source position: intuition.pas line 2994

const GMR_FULLHBOX = $00000010;


GMR_GADGETHIT

Result for GM_HITTEST Hit

Declaration

Source position: intuition.pas line 2838

const GMR_GADGETHIT = $00000004;


GMR_HELPCODE

Result for GM_HELPTEST Hit, return low Word as code.

Declaration

Source position: intuition.pas line 2841

const GMR_HELPCODE = $00010000;

Description

The gadget was hit. Pass the lower word, returned by this method to the application by using the Code field of the IntuiMessage.


GMR_HELPHIT

Result for GM_HELPTEST Hit, The gadget was hit.

Declaration

Source position: intuition.pas line 2840

const GMR_HELPHIT = $FFFFFFFF;

Description

The lower word of the Code field of the IntuiMessage will be set to -1.


GMR_INVALID

Declaration

Source position: intuition.pas line 2993

const GMR_INVALID = $00000000;


GMR_KEYACTIVATE

Declaration

Source position: intuition.pas line 2957

const GMR_KEYACTIVATE = $00000000;


GMR_KEYACTIVE

Declaration

Source position: intuition.pas line 2958

const GMR_KEYACTIVE = $00000010;


GMR_KEYVERIFY

Declaration

Source position: intuition.pas line 2959

const GMR_KEYVERIFY = $00000020;


GMR_MASKDONE

Declaration

Source position: intuition.pas line 2997

const GMR_MASKDONE = $00000080;


GMR_MEACTIVE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2880

const GMR_MEACTIVE = 0;

Description

Gadget is still alive.


GMR_NEXTACTIVE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate next gadget.

Declaration

Source position: intuition.pas line 2888

const GMR_NEXTACTIVE = 1 shl 5;

Description

the gadget has become inactive, but the next or previous gadget, which has the GFLG_TABCYCLE flag set is to be activated.


GMR_NOHELPHIT

Result for GM_HELPTEST didn't hit

Declaration

Source position: intuition.pas line 2839

const GMR_NOHELPHIT = $00000000;


GMR_NOREUSE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2881

const GMR_NOREUSE = 1 shl 1;

Description

Gadget has become inactive, but the input event may not be used again.


GMR_PREVACTIVE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate previous gadget.

Declaration

Source position: intuition.pas line 2889

const GMR_PREVACTIVE = 1 shl 6;

Description

the gadget has become inactive, but the next or previous gadget, which has the GFLG_TABCYCLE flag set is to be activated.


GMR_REUSE

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2882

const GMR_REUSE = 1 shl 2;

Description

Gadget has become inactive, and the input event may be reused by intuition.


GMR_VERIFY

Return Flags for GM_HANDLEINPUT or GM_GOACTIVE

Declaration

Source position: intuition.pas line 2883

const GMR_VERIFY = 1 shl 3;


GPEF_ALLOWSUPER

Declaration

Source position: intuition.pas line 2991

const GPEF_ALLOWSUPER = $00000001;


GRADMODE_COLOR

Declaration

Source position: intuition.pas line 1847

const GRADMODE_COLOR = $0002;


GRADMODE_IMPOSE

Declaration

Source position: intuition.pas line 1849

const GRADMODE_IMPOSE = $0100;


GRADMODE_INVERT1

Declaration

Source position: intuition.pas line 1852

const GRADMODE_INVERT1 = $1000;


GRADMODE_INVERT2

Declaration

Source position: intuition.pas line 1853

const GRADMODE_INVERT2 = $2000;


GRADMODE_KEEPRATIO

Declaration

Source position: intuition.pas line 1850

const GRADMODE_KEEPRATIO = $0200;


GRADMODE_NONE

Declaration

Source position: intuition.pas line 1845

const GRADMODE_NONE = $0000;


GRADMODE_PALETTE

Declaration

Source position: intuition.pas line 1851

const GRADMODE_PALETTE = $0400;


GRADMODE_SHADE

Declaration

Source position: intuition.pas line 1848

const GRADMODE_SHADE = $0003;


GRADMODE_SIMPLE

Declaration

Source position: intuition.pas line 1846

const GRADMODE_SIMPLE = $0001;


GRADMODE_TYPEMASK

Declaration

Source position: intuition.pas line 1844

const GRADMODE_TYPEMASK = $000F;


GREDRAW_REDRAW

TgpRender.gpr_Redraw. Redraw the whole gadget

Declaration

Source position: intuition.pas line 2857

const GREDRAW_REDRAW = 1;


GREDRAW_TOGGLE

TgpRender.gpr_Redraw. Toggle highlight, if applicable

Declaration

Source position: intuition.pas line 2858

const GREDRAW_TOGGLE = 0;


GREDRAW_UPDATE

TgpRender.gpr_Redraw. Incremental update. Some data (e.g. the level of a slider) was updated. Just redraw the necessary parts.

Declaration

Source position: intuition.pas line 2856

const GREDRAW_UPDATE = 2;


GREY_SCALE2

Flag for TPreferences.PrintFlags for use with hi-res monitor

Declaration

Source position: intuition.pas line 2431

const GREY_SCALE2 = $1000;


GRIGHTIMAGE

Declaration

Source position: intuition.pas line 3168

const GRIGHTIMAGE = $21;


GROUPGCLASS

Class identifier. A special gadget class that creates one composite gadget out of several others.

Declaration

Source position: intuition.pas line 2533

const GROUPGCLASS: PChar = 'groupgclass';

Description

SuperClass: gadgetclass

This is a class of objects that maintains an internal list of gadgets. Its purpose is to make it easier to layout a group of gadgets. Any gadgets that are a member of a groupgclass object are rendered relative to the groupgclass object's GA_Left and GA_Top attributes. As new gadgets are added to the groupgclass object, the groupgclass object's dimensions grow to enclose the new gadgets. When the groupgclass object receives an OM_DISPOSE message, it not only disposes of itself, it also disposes of all the gadgets in its list. Groupgclass does not support the gadget relative flags (GA_RelWidth, GA_RelHeight, GA_RelBottom, and GA_RelRight).

Changed Methods:

OM_SET, GM_HITTEST, OM_ADDMEMBER, GM_RENDER, OM_REMMEMBER, GM_GOACTIVE, GM_GOINACTIVE, GM_HANDLEINPUT, OM_DISPOSE

Attributes:

GA_Left (IS)

GA_Top (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


GTYP_BOOLGADGET

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 596

const GTYP_BOOLGADGET = $0001;


GTYP_CLOSE

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 589

const GTYP_CLOSE = $0080;


GTYP_CUSTOMGADGET

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 600

const GTYP_CUSTOMGADGET = $0005;


GTYP_GADGET0002

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 597

const GTYP_GADGET0002 = $0002;


GTYP_GADGETTYPE

All Gadget Global type flags for TGadget.Type

Declaration

Source position: intuition.pas line 573

const GTYP_GADGETTYPE = $FC00;


GTYP_GTYPEMASK

Application gadget type for TGadget.Type mask you can apply to tell what class of gadget this is.

Declaration

Source position: intuition.pas line 595

const GTYP_GTYPEMASK = $0007;

Description

The possible classes: GTYP_BOOLGADGET, GTYP_GADGET0002, GTYP_PROPGADGET, GTYP_STRGADGET or GTYP_CUSTOMGADGET


GTYP_GZZGADGET

Application gadget type for TGadget.Type for WFLG_GIMMEZEROZERO borders

Declaration

Source position: intuition.pas line 576

const GTYP_GZZGADGET = $2000;


GTYP_PROPGadget

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 598

const GTYP_PROPGadget = $0003;


GTYP_REQGADGET

Application gadget type for TGadget.Type this is a Requester Gadget

Declaration

Source position: intuition.pas line 577

const GTYP_REQGADGET = $1000;


GTYP_SCRGADGET

Application gadget type for TGadget.Type 1 = ScreenGadget, 0 = WindowGadget

Declaration

Source position: intuition.pas line 575

const GTYP_SCRGADGET = $4000;


GTYP_SDEPTH

Declaration

Source position: intuition.pas line 586

const GTYP_SDEPTH = $0050;


GTYP_SDOWNBACK

Declaration

Source position: intuition.pas line 593

const GTYP_SDOWNBACK = GTYP_SUNUSED;


GTYP_SDRAGGING

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 584

const GTYP_SDRAGGING = $0030;


GTYP_SIZING

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 582

const GTYP_SIZING = $0010;


GTYP_STRGADGET

Application gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 599

const GTYP_STRGADGET = $0004;


GTYP_SUNUSED

Declaration

Source position: intuition.pas line 588

const GTYP_SUNUSED = $0070;


GTYP_SUPFRONT

Declaration

Source position: intuition.pas line 591

const GTYP_SUPFRONT = GTYP_SDEPTH;


GTYP_SYSGADGET

Application gadget type for TGadget.Type 1 = Allocated by the system, 0 = by application

Declaration

Source position: intuition.pas line 574

const GTYP_SYSGADGET = $8000;


GTYP_SYSTYPEMASK

Declaration

Source position: intuition.pas line 580

const GTYP_SYSTYPEMASK = $00F0;


GTYP_TBARGADGET

Declaration

Source position: intuition.pas line 602

const GTYP_TBARGADGET = $0200;


GTYP_WDEPTH

Declaration

Source position: intuition.pas line 585

const GTYP_WDEPTH = $0040;


GTYP_WDOWNBACK

Declaration

Source position: intuition.pas line 592

const GTYP_WDOWNBACK = GTYP_WZOOM;


GTYP_WDRAGGING

System gadget type for TGadget.Type

Declaration

Source position: intuition.pas line 583

const GTYP_WDRAGGING = $0020;


GTYP_WUPFRONT

Declaration

Source position: intuition.pas line 590

const GTYP_WUPFRONT = GTYP_WDEPTH;


GTYP_WZOOM

Declaration

Source position: intuition.pas line 587

const GTYP_WZOOM = $0060;


GUIA_ArrowGadgetHeight

Declaration

Source position: intuition.pas line 1457

const GUIA_ArrowGadgetHeight = GUIA_Dummy + 7;


GUIA_ArrowGadgetWidth

Declaration

Source position: intuition.pas line 1456

const GUIA_ArrowGadgetWidth = GUIA_Dummy + 6;


GUIA_AutomaticEdgesContrast

Declaration

Source position: intuition.pas line 1582

const GUIA_AutomaticEdgesContrast = GUIA_Dummy + 1026;


GUIA_BarBlockBrightContrast

Declaration

Source position: intuition.pas line 1576

const GUIA_BarBlockBrightContrast = GUIA_Dummy + 1020;


GUIA_BarBlockBrightCurve

Declaration

Source position: intuition.pas line 1593

const GUIA_BarBlockBrightCurve = GUIA_Dummy + 1038;


GUIA_BarBlockDarkContrast

Declaration

Source position: intuition.pas line 1577

const GUIA_BarBlockDarkContrast = GUIA_Dummy + 1021;


GUIA_BarBlockDarkCurve

Declaration

Source position: intuition.pas line 1594

const GUIA_BarBlockDarkCurve = GUIA_Dummy + 1039;


GUIA_BrightContrast

Declaration

Source position: intuition.pas line 1566

const GUIA_BrightContrast = GUIA_Dummy + 1010;


GUIA_BrightCurve

Declaration

Source position: intuition.pas line 1583

const GUIA_BrightCurve = GUIA_Dummy + 1028;


GUIA_ClearBackground

Declaration

Source position: intuition.pas line 1540

const GUIA_ClearBackground = GUIA_Dummy + 90;


GUIA_ClickTabLook

Declaration

Source position: intuition.pas line 1514

const GUIA_ClickTabLook = GUIA_Dummy + 64;


GUIA_CycleLabelJustify

Declaration

Source position: intuition.pas line 1513

const GUIA_CycleLabelJustify = GUIA_Dummy + 63;


GUIA_CycleLook

Declaration

Source position: intuition.pas line 1537

const GUIA_CycleLook = GUIA_Dummy + 87;


GUIA_DarkContrast

Declaration

Source position: intuition.pas line 1567

const GUIA_DarkContrast = GUIA_Dummy + 1011;


GUIA_DarkCurve

Declaration

Source position: intuition.pas line 1584

const GUIA_DarkCurve = GUIA_Dummy + 1029;


GUIA_DefaultDRIPens

Declaration

Source position: intuition.pas line 1637

const GUIA_DefaultDRIPens = GUIA_Dummy + 5003;


GUIA_DefaultGeometry

Declaration

Source position: intuition.pas line 1487

const GUIA_DefaultGeometry = GUIA_Dummy + 37;


GUIA_DefaultStyle

Declaration

Source position: intuition.pas line 1451

const GUIA_DefaultStyle = GUIA_Dummy + 1;


GUIA_DisabledBrightContrast

Declaration

Source position: intuition.pas line 1578

const GUIA_DisabledBrightContrast = GUIA_Dummy + 1022;


GUIA_DisabledBrightCurve

Declaration

Source position: intuition.pas line 1595

const GUIA_DisabledBrightCurve = GUIA_Dummy + 1040;


GUIA_DisabledDarkContrast

Declaration

Source position: intuition.pas line 1579

const GUIA_DisabledDarkContrast = GUIA_Dummy + 1023;


GUIA_DisabledDarkCurve

Declaration

Source position: intuition.pas line 1596

const GUIA_DisabledDarkCurve = GUIA_Dummy + 1041;


GUIA_DRIPens

Declaration

Source position: intuition.pas line 1602

const GUIA_DRIPens = GUIA_Dummy + 1047;


GUIA_Dummy

Declaration

Source position: intuition.pas line 1449

const GUIA_Dummy = TAG_USER + $4400000;


GUIA_EvenRequesterButtons

Declaration

Source position: intuition.pas line 1503

const GUIA_EvenRequesterButtons = GUIA_Dummy + 53;


GUIA_FallbackTextAttr

Declaration

Source position: intuition.pas line 1527

const GUIA_FallbackTextAttr = GUIA_Dummy + 77;


GUIA_FillBrightContrast

Declaration

Source position: intuition.pas line 1568

const GUIA_FillBrightContrast = GUIA_Dummy + 1012;


GUIA_FillBrightCurve

Declaration

Source position: intuition.pas line 1585

const GUIA_FillBrightCurve = GUIA_Dummy + 1030;


GUIA_FillDarkContrast

Declaration

Source position: intuition.pas line 1569

const GUIA_FillDarkContrast = GUIA_Dummy + 1013;


GUIA_FillDarkCurve

Declaration

Source position: intuition.pas line 1586

const GUIA_FillDarkCurve = GUIA_Dummy + 1031;


GUIA_ForeBrightContrast

Declaration

Source position: intuition.pas line 1580

const GUIA_ForeBrightContrast = GUIA_Dummy + 1024;


GUIA_ForeBrightCurve

Declaration

Source position: intuition.pas line 1597

const GUIA_ForeBrightCurve = GUIA_Dummy + 1042;


GUIA_ForeDarkContrast

Declaration

Source position: intuition.pas line 1581

const GUIA_ForeDarkContrast = GUIA_Dummy + 1025;


GUIA_ForeDarkCurve

Declaration

Source position: intuition.pas line 1598

const GUIA_ForeDarkCurve = GUIA_Dummy + 1043;


GUIA_FrameAlphaStatus

Declaration

Source position: intuition.pas line 1549

const GUIA_FrameAlphaStatus = GUIA_Dummy + 99;


GUIA_FrameBackfill

Declaration

Source position: intuition.pas line 1609

const GUIA_FrameBackfill = GUIA_Dummy + 1054;


GUIA_FrameButtonLook

Declaration

Source position: intuition.pas line 1606

const GUIA_FrameButtonLook = GUIA_Dummy + 1051;


GUIA_FrameCornersType

Declaration

Source position: intuition.pas line 1608

const GUIA_FrameCornersType = GUIA_Dummy + 1053;


GUIA_FrameDisabledColors

Declaration

Source position: intuition.pas line 1605

const GUIA_FrameDisabledColors = GUIA_Dummy + 1050;


GUIA_FrameDisBackfill

Declaration

Source position: intuition.pas line 1616

const GUIA_FrameDisBackfill = GUIA_Dummy + 1061;


GUIA_FrameDisplayLook

Declaration

Source position: intuition.pas line 1613

const GUIA_FrameDisplayLook = GUIA_Dummy + 1058;


GUIA_FrameForceThinEdges

Declaration

Source position: intuition.pas line 1603

const GUIA_FrameForceThinEdges = GUIA_Dummy + 1048;


GUIA_FramePressedLook

Declaration

Source position: intuition.pas line 1607

const GUIA_FramePressedLook = GUIA_Dummy + 1052;


GUIA_FramePropLook

Declaration

Source position: intuition.pas line 1612

const GUIA_FramePropLook = GUIA_Dummy + 1057;


GUIA_FrameSelBackfill

Declaration

Source position: intuition.pas line 1610

const GUIA_FrameSelBackfill = GUIA_Dummy + 1055;


GUIA_FrameSelectedColor

Declaration

Source position: intuition.pas line 1604

const GUIA_FrameSelectedColor = GUIA_Dummy + 1049;


GUIA_FrameStringLook

Declaration

Source position: intuition.pas line 1611

const GUIA_FrameStringLook = GUIA_Dummy + 1056;


GUIA_GadgetArrowStyle

Declaration

Source position: intuition.pas line 1494

const GUIA_GadgetArrowStyle = GUIA_Dummy + 44;


GUIA_GadgetArrowType

Declaration

Source position: intuition.pas line 1492

const GUIA_GadgetArrowType = GUIA_Dummy + 42;


GUIA_GadgetCycleStyle

Declaration

Source position: intuition.pas line 1495

const GUIA_GadgetCycleStyle = GUIA_Dummy + 45;


GUIA_GadgetCycleType

Declaration

Source position: intuition.pas line 1493

const GUIA_GadgetCycleType = GUIA_Dummy + 43;


GUIA_GadgetGeometry

Declaration

Source position: intuition.pas line 1489

const GUIA_GadgetGeometry = GUIA_Dummy + 39;


GUIA_GadgetHorizPadding

Declaration

Source position: intuition.pas line 1515

const GUIA_GadgetHorizPadding = GUIA_Dummy + 65;


GUIA_GadgetStyle

Declaration

Source position: intuition.pas line 1486

const GUIA_GadgetStyle = GUIA_Dummy + 36;


GUIA_GadgetTextAttr

Declaration

Source position: intuition.pas line 1528

const GUIA_GadgetTextAttr = GUIA_Dummy + 78;


GUIA_GadgetVertPadding

Declaration

Source position: intuition.pas line 1516

const GUIA_GadgetVertPadding = GUIA_Dummy + 66;


GUIA_GaugeLook

Declaration

Source position: intuition.pas line 1539

const GUIA_GaugeLook = GUIA_Dummy + 89;


GUIA_GlobalFlags

Declaration

Source position: intuition.pas line 1635

const GUIA_GlobalFlags = GUIA_Dummy + 5001;


GUIA_GroupLabelLook

Declaration

Source position: intuition.pas line 1525

const GUIA_GroupLabelLook = GUIA_Dummy + 75;


GUIA_GroupLabelPlace

Declaration

Source position: intuition.pas line 1524

const GUIA_GroupLabelPlace = GUIA_Dummy + 74;


GUIA_GroupLabelTextAttr

Declaration

Source position: intuition.pas line 1526

const GUIA_GroupLabelTextAttr = GUIA_Dummy + 76;


GUIA_GroupLabelVertAlign

Declaration

Source position: intuition.pas line 1531

const GUIA_GroupLabelVertAlign = GUIA_Dummy + 81;


GUIA_InactiveFillBrightContrast

Declaration

Source position: intuition.pas line 1570

const GUIA_InactiveFillBrightContrast = GUIA_Dummy + 1014;


GUIA_InactiveFillBrightCurve

Declaration

Source position: intuition.pas line 1587

const GUIA_InactiveFillBrightCurve = GUIA_Dummy + 1032;


GUIA_InactiveFillDarkContrast

Declaration

Source position: intuition.pas line 1571

const GUIA_InactiveFillDarkContrast = GUIA_Dummy + 1015;


GUIA_InactiveFillDarkCurve

Declaration

Source position: intuition.pas line 1588

const GUIA_InactiveFillDarkCurve = GUIA_Dummy + 1033;


GUIA_LabelTextAttr

Declaration

Source position: intuition.pas line 1529

const GUIA_LabelTextAttr = GUIA_Dummy + 79;


GUIA_LayoutHorizSpacing

Declaration

Source position: intuition.pas line 1522

const GUIA_LayoutHorizSpacing = GUIA_Dummy + 72;


GUIA_LayoutVertSpacing

Declaration

Source position: intuition.pas line 1523

const GUIA_LayoutVertSpacing = GUIA_Dummy + 73;


GUIA_ListHierConnectType

Declaration

Source position: intuition.pas line 1533

const GUIA_ListHierConnectType = GUIA_Dummy + 83;


GUIA_ListHierNodeStyle

Declaration

Source position: intuition.pas line 1532

const GUIA_ListHierNodeStyle = GUIA_Dummy + 82;


GUIA_MenuBackfill

Declaration

Source position: intuition.pas line 1564

const GUIA_MenuBackfill = GUIA_Dummy + 1008;


GUIA_MenuBrightContrast

Declaration

Source position: intuition.pas line 1572

const GUIA_MenuBrightContrast = GUIA_Dummy + 1016;


GUIA_MenuBrightCurve

Declaration

Source position: intuition.pas line 1589

const GUIA_MenuBrightCurve = GUIA_Dummy + 1034;


GUIA_MenuCloseDelay

Declaration

Source position: intuition.pas line 1631

const GUIA_MenuCloseDelay = GUIA_Dummy + 1075;


GUIA_MenuDarkContrast

Declaration

Source position: intuition.pas line 1573

const GUIA_MenuDarkContrast = GUIA_Dummy + 1017;


GUIA_MenuDarkCurve

Declaration

Source position: intuition.pas line 1590

const GUIA_MenuDarkCurve = GUIA_Dummy + 1035;


GUIA_MenuDropShadows

Declaration

Source position: intuition.pas line 1561

const GUIA_MenuDropShadows = GUIA_Dummy + 1005;


GUIA_MenuFlags

Declaration

Source position: intuition.pas line 1560

const GUIA_MenuFlags = GUIA_Dummy + 1004;


GUIA_MenuOpenDelay

Declaration

Source position: intuition.pas line 1629

const GUIA_MenuOpenDelay = GUIA_Dummy + 1074;


GUIA_MenuRenderHook

Declaration

Source position: intuition.pas line 1563

const GUIA_MenuRenderHook = GUIA_Dummy + 1007;


GUIA_MenuSelItemFrame

Declaration

Source position: intuition.pas line 1619

const GUIA_MenuSelItemFrame = GUIA_Dummy + 1064;


GUIA_MenuStyle

Declaration

Source position: intuition.pas line 1565

const GUIA_MenuStyle = GUIA_Dummy + 1009;


GUIA_MenuTransparency

Declaration

Source position: intuition.pas line 1562

const GUIA_MenuTransparency = GUIA_Dummy + 1006;


GUIA_MenuTransparencyLevel

Declaration

Source position: intuition.pas line 1622

const GUIA_MenuTransparencyLevel = GUIA_Dummy + 1067;


GUIA_MenuType

Declaration

Source position: intuition.pas line 1559

const GUIA_MenuType = GUIA_Dummy + 1003;


GUIA_OffScreenDragging

Declaration

Source position: intuition.pas line 1615

const GUIA_OffScreenDragging = GUIA_Dummy + 1060;


GUIA_OffScreenResistance

Declaration

Source position: intuition.pas line 1621

const GUIA_OffScreenResistance = GUIA_Dummy + 1066;


GUIA_OffScreenSizing

Declaration

Source position: intuition.pas line 1620

const GUIA_OffScreenSizing = GUIA_Dummy + 1065;


GUIA_PaletteLockTable

Declaration

Source position: intuition.pas line 1601

const GUIA_PaletteLockTable = GUIA_Dummy + 1046;


GUIA_PaletteRGBTable

Declaration

Source position: intuition.pas line 1600

const GUIA_PaletteRGBTable = GUIA_Dummy + 1045;


GUIA_PropBackfill

Declaration

Source position: intuition.pas line 1476

const GUIA_PropBackfill = GUIA_Dummy + 26;


GUIA_PropBackground

Declaration

Source position: intuition.pas line 1468

const GUIA_PropBackground = GUIA_Dummy + 18;


GUIA_PropBorder

Declaration

Source position: intuition.pas line 1479

const GUIA_PropBorder = GUIA_Dummy + 29;


GUIA_PropKnobBackfill

Declaration

Source position: intuition.pas line 1470

const GUIA_PropKnobBackfill = GUIA_Dummy + 20;


GUIA_PropKnobColor

Declaration

Source position: intuition.pas line 1483

const GUIA_PropKnobColor = GUIA_Dummy + 33;


GUIA_PropKnobHandle

Declaration

Source position: intuition.pas line 1482

const GUIA_PropKnobHandle = GUIA_Dummy + 32;


GUIA_PropKnobHighlight

Declaration

Source position: intuition.pas line 1599

const GUIA_PropKnobHighlight = GUIA_Dummy + 1044;


GUIA_PropOuterSpacing

Declaration

Source position: intuition.pas line 1511

const GUIA_PropOuterSpacing = GUIA_Dummy + 61;


GUIA_PropSelKnobBackfill

Declaration

Source position: intuition.pas line 1472

const GUIA_PropSelKnobBackfill = GUIA_Dummy + 22;


GUIA_PropSpacing

Declaration

Source position: intuition.pas line 1481

const GUIA_PropSpacing = GUIA_Dummy + 31;


GUIA_RealShading

Declaration

Source position: intuition.pas line 1617

const GUIA_RealShading = GUIA_Dummy + 1062;


GUIA_RequesterBackfill

Declaration

Source position: intuition.pas line 1518

const GUIA_RequesterBackfill = GUIA_Dummy + 68;


GUIA_RequestersPosition

Declaration

Source position: intuition.pas line 1504

const GUIA_RequestersPosition = GUIA_Dummy + 54;


GUIA_Reserved1

Declaration

Source position: intuition.pas line 1506

const GUIA_Reserved1 = GUIA_Dummy + 56;


GUIA_Reserved2

Declaration

Source position: intuition.pas line 1507

const GUIA_Reserved2 = GUIA_Dummy + 57;


GUIA_Reserved3

Declaration

Source position: intuition.pas line 1508

const GUIA_Reserved3 = GUIA_Dummy + 58;


GUIA_Reserved4

Declaration

Source position: intuition.pas line 1534

const GUIA_Reserved4 = GUIA_Dummy + 84;


GUIA_Reserved5

Declaration

Source position: intuition.pas line 1541

const GUIA_Reserved5 = GUIA_Dummy + 91;


GUIA_ScreenBarBackfill

Declaration

Source position: intuition.pas line 1618

const GUIA_ScreenBarBackfill = GUIA_Dummy + 1063;


GUIA_ScreenBarGadgetSize

Declaration

Source position: intuition.pas line 1490

const GUIA_ScreenBarGadgetSize = GUIA_Dummy + 40;


GUIA_ScreenBarPadding

Declaration

Source position: intuition.pas line 1558

const GUIA_ScreenBarPadding = GUIA_Dummy + 1002;


GUIA_ScreenBarShadowColor

Declaration

Source position: intuition.pas line 1626

const GUIA_ScreenBarShadowColor = GUIA_Dummy + 1071;


GUIA_ScreenBarShadowDisplacement

Declaration

Source position: intuition.pas line 1627

const GUIA_ScreenBarShadowDisplacement = GUIA_Dummy + 1072;


GUIA_ScreenBarShadowSmoothness

Declaration

Source position: intuition.pas line 1628

const GUIA_ScreenBarShadowSmoothness = GUIA_Dummy + 1073;


GUIA_ScreenBarShadowStrength

Declaration

Source position: intuition.pas line 1625

const GUIA_ScreenBarShadowStrength = GUIA_Dummy + 1070;


GUIA_ScreenDragging

Declaration

Source position: intuition.pas line 1636

const GUIA_ScreenDragging = GUIA_Dummy + 5002;


GUIA_ScreenTitlePosition

Declaration

Source position: intuition.pas line 1557

const GUIA_ScreenTitlePosition = GUIA_Dummy + 1001;


GUIA_SelectBrightContrast

Declaration

Source position: intuition.pas line 1574

const GUIA_SelectBrightContrast = GUIA_Dummy + 1018;


GUIA_SelectBrightCurve

Declaration

Source position: intuition.pas line 1591

const GUIA_SelectBrightCurve = GUIA_Dummy + 1036;


GUIA_SelectDarkContrast

Declaration

Source position: intuition.pas line 1575

const GUIA_SelectDarkContrast = GUIA_Dummy + 1019;


GUIA_SelectDarkCurve

Declaration

Source position: intuition.pas line 1592

const GUIA_SelectDarkCurve = GUIA_Dummy + 1037;


GUIA_ShareComposeBitMap

Declaration

Source position: intuition.pas line 1624

const GUIA_ShareComposeBitMap = GUIA_Dummy + 1069;


GUIA_SizeGadgetHeight

Declaration

Source position: intuition.pas line 1455

const GUIA_SizeGadgetHeight = GUIA_Dummy + 5;


GUIA_SizeGadgetWidth

Declaration

Source position: intuition.pas line 1454

const GUIA_SizeGadgetWidth = GUIA_Dummy + 4;


GUIA_SliderDisplayMode

Declaration

Source position: intuition.pas line 1512

const GUIA_SliderDisplayMode = GUIA_Dummy + 62;


GUIA_SpecialEffects

Declaration

Source position: intuition.pas line 1623

const GUIA_SpecialEffects = GUIA_Dummy + 1068;


GUIA_SysIGeometryType

Declaration

Source position: intuition.pas line 1497

const GUIA_SysIGeometryType = GUIA_Dummy + 47;


GUIA_SysImageFrameType

Declaration

Source position: intuition.pas line 1477

const GUIA_SysImageFrameType = GUIA_Dummy + 27;


GUIA_SysImageSymbolType

Declaration

Source position: intuition.pas line 1496

const GUIA_SysImageSymbolType = GUIA_Dummy + 46;


GUIA_TabActiveBackfill

Declaration

Source position: intuition.pas line 1520

const GUIA_TabActiveBackfill = GUIA_Dummy + 70;


GUIA_TabInactiveBackfill

Declaration

Source position: intuition.pas line 1521

const GUIA_TabInactiveBackfill = GUIA_Dummy + 71;


GUIA_TabTitleBackfill

Declaration

Source position: intuition.pas line 1519

const GUIA_TabTitleBackfill = GUIA_Dummy + 69;


GUIA_VSyncCompose

Declaration

Source position: intuition.pas line 1633

const GUIA_VSyncCompose = GUIA_Dummy + 1076;


GUIA_WindowAlpha

Declaration

Source position: intuition.pas line 1542

const GUIA_WindowAlpha = GUIA_Dummy + 92;


GUIA_WindowBackfill

Declaration

Source position: intuition.pas line 1517

const GUIA_WindowBackfill = GUIA_Dummy + 67;


GUIA_WindowBarBackfill

Declaration

Source position: intuition.pas line 1498

const GUIA_WindowBarBackfill = GUIA_Dummy + 48;


GUIA_WindowBarFrameThickness

Declaration

Source position: intuition.pas line 1509

const GUIA_WindowBarFrameThickness = GUIA_Dummy + 59;


GUIA_WindowBarGadgetSize

Declaration

Source position: intuition.pas line 1491

const GUIA_WindowBarGadgetSize = GUIA_Dummy + 41;


GUIA_WindowBarInactBackfill

Declaration

Source position: intuition.pas line 1499

const GUIA_WindowBarInactBackfill = GUIA_Dummy + 49;


GUIA_WindowBarPadding

Declaration

Source position: intuition.pas line 1463

const GUIA_WindowBarPadding = GUIA_Dummy + 13;


GUIA_WindowBorderBackfill

Declaration

Source position: intuition.pas line 1500

const GUIA_WindowBorderBackfill = GUIA_Dummy + 50;


GUIA_WindowBorderBottom

Declaration

Source position: intuition.pas line 1461

const GUIA_WindowBorderBottom = GUIA_Dummy + 11;


GUIA_WindowBorderInactBackfill

Declaration

Source position: intuition.pas line 1501

const GUIA_WindowBorderInactBackfill = GUIA_Dummy + 51;


GUIA_WindowBorderLeft

Declaration

Source position: intuition.pas line 1458

const GUIA_WindowBorderLeft = GUIA_Dummy + 8;


GUIA_WindowBorderLook

Declaration

Source position: intuition.pas line 1505

const GUIA_WindowBorderLook = GUIA_Dummy + 55;


GUIA_WindowBorderRight

Declaration

Source position: intuition.pas line 1460

const GUIA_WindowBorderRight = GUIA_Dummy + 10;


GUIA_WindowBorderStyle

Declaration

Source position: intuition.pas line 1452

const GUIA_WindowBorderStyle = GUIA_Dummy + 2;


GUIA_WindowBorderTop

Declaration

Source position: intuition.pas line 1459

const GUIA_WindowBorderTop = GUIA_Dummy + 9;


GUIA_WindowCloseFadeTime

Declaration

Source position: intuition.pas line 1546

const GUIA_WindowCloseFadeTime = GUIA_Dummy + 96;


GUIA_WindowDragAlpha

Declaration

Source position: intuition.pas line 1544

const GUIA_WindowDragAlpha = GUIA_Dummy + 94;


GUIA_WindowFrameThickness

Declaration

Source position: intuition.pas line 1510

const GUIA_WindowFrameThickness = GUIA_Dummy + 60;


GUIA_WindowGadgetFrameStyle

Declaration

Source position: intuition.pas line 1485

const GUIA_WindowGadgetFrameStyle = GUIA_Dummy + 35;


GUIA_WindowGadgetGeometry

Declaration

Source position: intuition.pas line 1488

const GUIA_WindowGadgetGeometry = GUIA_Dummy + 38;


GUIA_WindowGadgetStyle

Declaration

Source position: intuition.pas line 1453

const GUIA_WindowGadgetStyle = GUIA_Dummy + 3;


GUIA_WindowGaugeLook

Declaration

Source position: intuition.pas line 1538

const GUIA_WindowGaugeLook = GUIA_Dummy + 88;


GUIA_WindowGoActiveFadeTime

Declaration

Source position: intuition.pas line 1547

const GUIA_WindowGoActiveFadeTime = GUIA_Dummy + 97;


GUIA_WindowGoInactiveFadeTime

Declaration

Source position: intuition.pas line 1548

const GUIA_WindowGoInactiveFadeTime = GUIA_Dummy + 98;


GUIA_WindowInactAlpha

Declaration

Source position: intuition.pas line 1543

const GUIA_WindowInactAlpha = GUIA_Dummy + 93;


GUIA_WindowInnerFlatThickness

Declaration

Source position: intuition.pas line 1536

const GUIA_WindowInnerFlatThickness = GUIA_Dummy + 86;


GUIA_WindowOpenFadeTime

Declaration

Source position: intuition.pas line 1545

const GUIA_WindowOpenFadeTime = GUIA_Dummy + 95;


GUIA_WindowOuterFlatThickness

Declaration

Source position: intuition.pas line 1535

const GUIA_WindowOuterFlatThickness = GUIA_Dummy + 85;


GUIA_WindowPropBackfill

Declaration

Source position: intuition.pas line 1474

const GUIA_WindowPropBackfill = GUIA_Dummy + 24;


GUIA_WindowPropBackground

Declaration

Source position: intuition.pas line 1467

const GUIA_WindowPropBackground = GUIA_Dummy + 17;


GUIA_WindowPropBorder

Declaration

Source position: intuition.pas line 1478

const GUIA_WindowPropBorder = GUIA_Dummy + 28;


GUIA_WindowPropInactBackfill

Declaration

Source position: intuition.pas line 1475

const GUIA_WindowPropInactBackfill = GUIA_Dummy + 25;


GUIA_WindowPropInactKnobBackfill

Declaration

Source position: intuition.pas line 1473

const GUIA_WindowPropInactKnobBackfill = GUIA_Dummy + 23;


GUIA_WindowPropKnobBackfill

Declaration

Source position: intuition.pas line 1469

const GUIA_WindowPropKnobBackfill = GUIA_Dummy + 19;


GUIA_WindowPropKnobColor

Declaration

Source position: intuition.pas line 1466

const GUIA_WindowPropKnobColor = GUIA_Dummy + 16;


GUIA_WindowPropKnobHandle

Declaration

Source position: intuition.pas line 1465

const GUIA_WindowPropKnobHandle = GUIA_Dummy + 15;


GUIA_WindowPropKnobHighlight

Declaration

Source position: intuition.pas line 1614

const GUIA_WindowPropKnobHighlight = GUIA_Dummy + 1059;


GUIA_WindowPropLook

Declaration

Source position: intuition.pas line 1502

const GUIA_WindowPropLook = GUIA_Dummy + 52;


GUIA_WindowPropSelKnobBackfill

Declaration

Source position: intuition.pas line 1471

const GUIA_WindowPropSelKnobBackfill = GUIA_Dummy + 21;


GUIA_WindowPropSpacing

Declaration

Source position: intuition.pas line 1480

const GUIA_WindowPropSpacing = GUIA_Dummy + 30;


GUIA_WindowRefresh

Declaration

Source position: intuition.pas line 1530

const GUIA_WindowRefresh = GUIA_Dummy + 80;


GUIA_WindowReserved

Declaration

Source position: intuition.pas line 1464

const GUIA_WindowReserved = GUIA_Dummy + 14;


GUIA_WindowShadowColor

Declaration

Source position: intuition.pas line 1553

const GUIA_WindowShadowColor = GUIA_Dummy + 103;


GUIA_WindowShadowDisplacement

Declaration

Source position: intuition.pas line 1554

const GUIA_WindowShadowDisplacement = GUIA_Dummy + 104;


GUIA_WindowShadowSizes

Declaration

Source position: intuition.pas line 1550

const GUIA_WindowShadowSizes = GUIA_Dummy + 100;


GUIA_WindowShadowSmoothness

Declaration

Source position: intuition.pas line 1555

const GUIA_WindowShadowSmoothness = GUIA_Dummy + 105;


GUIA_WindowShadowStrength

Declaration

Source position: intuition.pas line 1551

const GUIA_WindowShadowStrength = GUIA_Dummy + 101;


GUIA_WindowShadowType

Declaration

Source position: intuition.pas line 1552

const GUIA_WindowShadowType = GUIA_Dummy + 102;


GUIA_WindowSizeBorder

Declaration

Source position: intuition.pas line 1484

const GUIA_WindowSizeBorder = GUIA_Dummy + 34;


GUIA_WindowTitlePosition

Declaration

Source position: intuition.pas line 1462

const GUIA_WindowTitlePosition = GUIA_Dummy + 12;


GUPIMAGE

Declaration

Source position: intuition.pas line 3167

const GUPIMAGE = $20;


GVKHANDLEIMAGE

Declaration

Source position: intuition.pas line 3171

const GVKHANDLEIMAGE = $24;


HALFSHADOWPEN

Declaration

Source position: intuition.pas line 1988

const HALFSHADOWPEN = $0029;


HALFSHINEPEN

Declaration

Source position: intuition.pas line 1987

const HALFSHINEPEN = $0028;


HALFTONE_DITHERING

Flag for TPreferences.PrintFlags halftone dithering

Declaration

Source position: intuition.pas line 2427

const HALFTONE_DITHERING = $0200;


HC_GADGETHELP

Flag for HelpControl() Set this flag to enable Gadget-Help for one or more windows.

Declaration

Source position: intuition.pas line 1301

const HC_GADGETHELP = 1;


HIGHBOX

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by "boxing" the selectbox

Declaration

Source position: intuition.pas line 107

const HIGHBOX = $0080;


HIGHCOMP

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by complementing the selectbox

Declaration

Source position: intuition.pas line 106

const HIGHCOMP = $0040;


HIGHFLAGS

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, see definitions below for these bits

Declaration

Source position: intuition.pas line 104

const HIGHFLAGS = $00C0;


HIGHIMAGE

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, use the user's "select image"

Declaration

Source position: intuition.pas line 105

const HIGHIMAGE = $0000;


HIGHITEM

Flag for TMenuItem.Flags set by intuition (ReadOnly), this item is currently highlighted

Declaration

Source position: intuition.pas line 116

const HIGHITEM = $2000;


HIGHLIGHTTEXTPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. special color text, on background

Declaration

Source position: intuition.pas line 1953

const HIGHLIGHTTEXTPEN = $0008;


HIGHNONE

SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, don't highlight

Declaration

Source position: intuition.pas line 108

const HIGHNONE = $00C0;


HIRESGADGET

Declaration

Source position: intuition.pas line 2446

const HIRESGADGET = 0;


HIRESPICK

Declaration

Source position: intuition.pas line 2440

const HIRESPICK = $0000;


HKHANDLEIMAGE

Declaration

Source position: intuition.pas line 3160

const HKHANDLEIMAGE = $19;


HP_LASERJET

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2387

const HP_LASERJET = $0B;


HP_LASERJET_PLUS

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2388

const HP_LASERJET_PLUS = $0C;


IA_ActivateKey

Declaration

Source position: intuition.pas line 3094

const IA_ActivateKey = IA_Dummy + $1e;


IA_APatSize

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3068

const IA_APatSize = IA_Dummy + $11;


IA_APattern

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3067

const IA_APattern = IA_Dummy + $10;


IA_BackFill

Declaration

Source position: intuition.pas line 3108

const IA_BackFill = IA_Dummy + $29;


IA_BGPen

ImageClass Attribute. IA_BGPen also means "PlaneOnOff"

Declaration

Source position: intuition.pas line 3059

const IA_BGPen = IA_Dummy + $06;


IA_Data

ImageClass Attribute. bitplanes, for classic image, other image classes may use it for other things

Declaration

Source position: intuition.pas line 3060

const IA_Data = IA_Dummy + $07;


IA_DisabledBackFill

Declaration

Source position: intuition.pas line 3110

const IA_DisabledBackFill = IA_Dummy + $2B;


IA_DoubleEmboss

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3073

const IA_DoubleEmboss = IA_Dummy + $16;


IA_Dummy

ImageClass Attributes start.

Declaration

Source position: intuition.pas line 3053

const IA_Dummy = TAG_USER + $20000;


IA_EdgesOnly

ImageClass Attribute. to specify that the interior of a frame should not be cleared

Declaration

Source position: intuition.pas line 3074

const IA_EdgesOnly = IA_Dummy + $17;


IA_EraseBackground

Declaration

Source position: intuition.pas line 3113

const IA_EraseBackground = IA_Dummy + $2D;


IA_FGPen

ImageClass Attribute. IA_FGPen also means "PlanePick"

Declaration

Source position: intuition.pas line 3058

const IA_FGPen = IA_Dummy + $05;


IA_Font

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3070

const IA_Font = IA_Dummy + $13;


IA_FrameType

SysIClass Attribute. FrameIClass recognizes several standard types of frame.

Declaration

Source position: intuition.pas line 3090

const IA_FrameType = IA_Dummy + $1b;

Description

Use one of the FRAME_* specifiers below. Default = FRAME_DEFAULT.


IA_Height

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3057

const IA_Height = IA_Dummy + $04;


IA_HighlightPen

Declaration

Source position: intuition.pas line 3084

const IA_HighlightPen = IA_Dummy + $0A;


IA_InactiveBackFill

Declaration

Source position: intuition.pas line 3111

const IA_InactiveBackFill = IA_Dummy + $2C;


IA_InBorder

Declaration

Source position: intuition.pas line 3114

const IA_InBorder = IA_Dummy + $2E;


IA_Justification

Declaration

Source position: intuition.pas line 3128

const IA_Justification = IA_Dummy + $37;


IA_Label

Declaration

Source position: intuition.pas line 3105

const IA_Label = IA_Dummy + $28;


IA_LabelPen

Declaration

Source position: intuition.pas line 3130

const IA_LabelPen = IA_Dummy + $38;


IA_Left

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3054

const IA_Left = IA_Dummy + $01;


IA_LineWidth

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3061

const IA_LineWidth = IA_Dummy + $08;


IA_Mode

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3069

const IA_Mode = IA_Dummy + $12;


IA_Orientation

Declaration

Source position: intuition.pas line 3100

const IA_Orientation = IA_Dummy + $23;


IA_Outline

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3071

const IA_Outline = IA_Dummy + $14;


IA_Pens

ImageClass Attribute. pointer to Word pens[], ala TDrawInfo.Pens, must be terminated by (not 0). Some classes can choose to have this, or SYSIA_DrawInfo, or both.

Declaration

Source position: intuition.pas line 3062

const IA_Pens = IA_Dummy + $0E;


IA_Precision

Declaration

Source position: intuition.pas line 3096

const IA_Precision = IA_Dummy + $20;


IA_Recessed

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3072

const IA_Recessed = IA_Dummy + $15;


IA_Resolution

ImageClass Attribute. packed Words for x/y resolution into a LongWord ala TDrawInfo.Resolution

Declaration

Source position: intuition.pas line 3064

const IA_Resolution = IA_Dummy + $0F;


IA_Scalable

Declaration

Source position: intuition.pas line 3093

const IA_Scalable = IA_Dummy + $1d;


IA_Screen

Declaration

Source position: intuition.pas line 3095

const IA_Screen = IA_Dummy + $1f;


IA_SelectedBackFill

Declaration

Source position: intuition.pas line 3109

const IA_SelectedBackFill = IA_Dummy + $2A;


IA_ShadowPen

Declaration

Source position: intuition.pas line 3083

const IA_ShadowPen = IA_Dummy + $09;


IA_Simple

Declaration

Source position: intuition.pas line 3101

const IA_Simple = IA_Dummy + $24;


IA_SupportsDisable

SysIClass Attribute. Tell intuition to use IDS_*DISABLED instead of own code

Declaration

Source position: intuition.pas line 3087

const IA_SupportsDisable = IA_Dummy + $1a;


IA_Top

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3055

const IA_Top = IA_Dummy + $02;


IA_Underscore

Declaration

Source position: intuition.pas line 3092

const IA_Underscore = IA_Dummy + $1c;


IA_Width

ImageClass Attribute.

Declaration

Source position: intuition.pas line 3056

const IA_Width = IA_Dummy + $03;


ICA_Dummy

Interconnection attributes start used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 3037

const ICA_Dummy = TAG_USER + $40000;


ICA_MAP

interconnection map tagitem list used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 3039

const ICA_MAP = ICA_Dummy + 2;

Description

see ICTARGET_IDCMP


ICA_TARGET

Interconnection target used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 3038

const ICA_TARGET = ICA_Dummy + 1;

Description

see ICTARGET_IDCMP


ICCLASS

Class identifier. Interconnection class

Declaration

Source position: intuition.pas line 2535

const ICCLASS: PChar = 'icclass';

Description

SuperClass: rootclass

Base class of simple OM_UPDATE forwarding objects. When an icclass object gets an OM_UPDATE message, it maps the attributes in the OM_UPDATE message according to its mapping list (its ICA_MAP attribute) and forwards the OM_UPDATE to its target (its ICA_TARGET attribute).

Changed Methods:

OM_SET, OM_UPDATE, OM_NOTIFY

Attributes:

ICA_TARGET (IS)

ICA_MAP (IS)

ICSPECIAL_CODE (*)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


ICM_CHECKLOOP

icclass Method. Set/increment loop

Declaration

Source position: intuition.pas line 3033

const ICM_CHECKLOOP = $0404;


ICM_CLEARLOOP

icclass Method. Clear/decrement loop counter

Declaration

Source position: intuition.pas line 3032

const ICM_CLEARLOOP = $0403;


ICM_Dummy

icclass Methods start

Declaration

Source position: intuition.pas line 3030

const ICM_Dummy = $0401;


ICM_SETLOOP

icclass Method. Set/increment loop counter

Declaration

Source position: intuition.pas line 3031

const ICM_SETLOOP = $0402;


ICONIFYIMAGE

Declaration

Source position: intuition.pas line 3157

const ICONIFYIMAGE = $16;


ICSPECIAL_CODE

a "pseudo-attribute" used by icclass, modelclass and gadgetclass

Declaration

Source position: intuition.pas line 3040

const ICSPECIAL_CODE = ICA_Dummy + 3;

Description

see ICTARGET_IDCMP


ICTARGET_IDCMP

Declaration

Source position: intuition.pas line 3048

const ICTARGET_IDCMP = not 0;

Description

Normally, the value for ICA_TARGET is some object pointer, but if you specify the special value ICTARGET_IDCMP, notification will be send as an IDCMP_IDCMPUPDATE message to the appropriate window's IDCMP port. See the definition of IDCMP_IDCMPUPDATE. When you specify ICTARGET_IDCMP for ICA_TARGET, the map you specify will be applied to derive the attribute list that is sent with the IDCMP_IDCMPUPDATE message. If you specify a map list which results in the attribute tag id ICSPECIAL_CODE, the lower sixteen bits of the corresponding ti_Data value will be copied into the Code field of the IDCMP_IDCMPUPDATE IntuiMessage.


ICTRL_Dummy

Declaration

Source position: intuition.pas line 1304

const ICTRL_Dummy = TAG_USER + $1C000;


IDCMP_ACTIVEWINDOW

IDCMP class: Window is activated

Declaration

Source position: intuition.pas line 877

const IDCMP_ACTIVEWINDOW = $00040000;

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_CHANGEWINDOW

IDCMP class: Window changed size or position

Declaration

Source position: intuition.pas line 887

const IDCMP_CHANGEWINDOW = $02000000;

Description

This message provides the window with notification of any change in the size or position of a window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_CLOSEWINDOW

IDCMP class: User pressed close button of window

Declaration

Source position: intuition.pas line 868

const IDCMP_CLOSEWINDOW = $00000200;

Description

IDCMP_CLOSEWINDOW messages are sent when the user selects the window's close gadget. Intuition does not close the window when the close gadget is selected. Rather, an IDCMP_CLOSEWINDOW message is sent to the window's IDCMP. It is up to the application to clean up and close the window itself. If closing a window means losing some data (perhaps the spreadsheet the user was working on), it would be appropriate for the application to first confirm that the user really meant to close the window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_DELTAMOVE

IDCMP class:

Declaration

Source position: intuition.pas line 879

const IDCMP_DELTAMOVE = $00100000;

Description

IDCMP_DELTAMOVE is not a message type, and events will never be sent to the application with this IDCMP identifier. This flag is a modifier, which changes how mouse movements are reported. When this flag is set, mouse movements are sent as delta values rather than as absolute positions.

The deltas are the amount of change of the mouse position from the last reported position. If the mouse does not move, then the delta values will be zero.

This flag works in conjunction with the IDCMP_MOUSEMOVE flag. When IDCMP_DELTAMOVE is set, IDCMP_MOUSEBUTTONS messages will also have relative values, instead of the absolute window position of the mouse.

Delta mouse movements are reported even after the Intuition pointer has reached the limits of the display. That is, if the pointer has reached the edge of the display and the user continues to move the mouse in the same direction, the IDCMP_MOUSEMOVE messages will continue to report changes in the mouse position even though the pointer is no longer moving.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_DISKINSERTED

IDCMP class: Floppy disk inserted

Declaration

Source position: intuition.pas line 874

const IDCMP_DISKINSERTED = $00008000;

Description

When the user inserts a floppy disk from any drive, Intuition will send one of these message types. This message type is broadcast to all IDCMP that have this flag set, not just to the active window. If the application has this flag set, it should be prepared to handle the event even if it is not active.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_DISKREMOVED

IDCMP class: Floppy disk removed

Declaration

Source position: intuition.pas line 875

const IDCMP_DISKREMOVED = $00010000;

Description

When the user removes a floppy disk from any drive, Intuition will send one of these message types. This message type is broadcast to all IDCMP that have this flag set, not just to the active window. If the application has this flag set, it should be prepared to handle the event even if it is not active.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_EXTENDEDKEYBOARD

Declaration

Source position: intuition.pas line 890

const IDCMP_EXTENDEDKEYBOARD = $10000000;


IDCMP_EXTENDEDMOUSE

Declaration

Source position: intuition.pas line 889

const IDCMP_EXTENDEDMOUSE = $08000000;


IDCMP_GADGETDOWN

IDCMP class: user selects a gadget

Declaration

Source position: intuition.pas line 864

const IDCMP_GADGETDOWN = $00000020;

Description

IDCMP_GADGETDOWN messages are sent when the user selects a gadget that was created with the GACT_IMMEDIATEGACT_IMMEDIATE flag set. The IAddress field will contain a pointer to the selected gadget.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_GADGETHELP

IDCMP class

Declaration

Source position: intuition.pas line 888

const IDCMP_GADGETHELP = $04000000;

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_GADGETUP

IDCMP class: user selects a gadget

Declaration

Source position: intuition.pas line 865

const IDCMP_GADGETUP = $00000040;

Description

IDCMP_GADGETUP messages are sent when the user selects a gadget that was created with the GACT_RELVERIFY flag set. The IAddress field will contain a pointer to the selected gadget.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_IDCMPUPDATE

IDCMP Class: gadget notification

Declaration

Source position: intuition.pas line 883

const IDCMP_IDCMPUPDATE = $00800000;

Description

Used for notification from Boopsi custom gadgets. The IAddress field contains a pointer to a tag item list.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_INACTIVEWINDOW

IDCMP class: Window is deactivated

Declaration

Source position: intuition.pas line 878

const IDCMP_INACTIVEWINDOW = $00080000;

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_INTUITICKS

IDCMP Class: Time ticks

Declaration

Source position: intuition.pas line 881

const IDCMP_INTUITICKS = $00400000;

Description

Intuition sends these messages to the active window based on an internal timer which "ticks" roughly ten times a second. This provides the application with simple timer events from Intuition.

Intuition does not allow IDCMP_INTUITICKS events to accumulate at a port. After an IDCMP_INTUITICKS message has been sent to a port, Intuition will not send another until the application replies to the first. This means that an application that has not been able to service the IDCMP for an extended period can expect at most one IDCMP_INTUITICKS message to be waiting at the port.

These events are to be used as "prods", and not as time counters. Do not rely on the timing accuracy of the event, or on the exact frequency at which they appear. Remember, IDCMP_INTUITICKS will only be sent to the active window. If the user selects another window, the events will no longer be received at the first window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_LONELYMESSAGE

IDCMP class: Private

Declaration

Source position: intuition.pas line 897

const IDCMP_LONELYMESSAGE = $80000000;

Description

For internal tracking by Intuition, system use only.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MENUHELP

IDCMP Class: Help key pressed

Declaration

Source position: intuition.pas line 885

const IDCMP_MENUHELP = $01000000;

Description

This message is sent by Intuition when the user selects the Help key while the menu system is activated. If a menu item was selected, the menu number of the menu item can be found in the Code field. If no item was selected, the Code field will be equal to MENUNULL.

These messages will only be sent if the WA_MenuHelp attribute is set for the window.

The menu number returned in IDCMP_MENUHELP may specify a position that cannot be generated through normal menu activity. For instance, the menu number may indicate one of the menu headers with no item or sub-item.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MENUPICK

IDCMP class: User opened the menu

Declaration

Source position: intuition.pas line 867

const IDCMP_MENUPICK = $00000100;

Description

This flag indicates that the user has pressed the menu button. If a menu item was selected, the menu number of the menu item can be found in the Code field. If no item was selected, the Code field will be equal to MENUNULL.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MENUVERIFY

IDCMP class: Verify ready to show menu

Declaration

Source position: intuition.pas line 872

const IDCMP_MENUVERIFY = $00002000;

Description

This is a special verification mode which allows the program to confirm that it is prepared to handle Intuition rendering, in this case, allowing menus to be drawn in the screen.

This is a special kind of verification, in that any window in the entire screen that has this flag set must respond before the menu operations may proceed. Also, the active window of the screen is allowed to cancel the menu operation. This is unique to IDCMP_MENUVERIFY. Refer to the "Intuition Menus" for a complete description.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MOUSEBUTTONS

IDCMP class: Contains reports about mouse button up and down events.

Declaration

Source position: intuition.pas line 862

const IDCMP_MOUSEBUTTONS = $00000008;

Description

Contains reports about mouse button up and down events. The events will be sent to the application only if they are not used internally by Intuition.

The Code field contains information on the specific mouse button event this message represents. The Code field will be equal to SELECTDOWN, SELECTUP, MENUDOWN, MENUUP, MIDDLEDOWN or MIDDLEUP, depending on the button pressed or released. In general, the select button is the left mouse button, the menu button is the right mouse button and the middle button is an optional third button usually located between the select and menu buttons.

Often, a mouse button event has extra meaning to Intuition, and the application may hear about it through a more specific message, for example a gadget or menu event. Other times, no event is generated at all, such as when the user depth-arranges a screen by clicking on the screen depth gadget. Note that menu button events are normally consumed by Intuition for menu handling. If an application wishes to hear IDCMP_MOUSEBUTTONS events for the menu button, it must set the WA_RMBTrap> attribute for its window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_MOUSEMOVE

IDCMP class: Reports about mouse movements

Declaration

Source position: intuition.pas line 863

const IDCMP_MOUSEMOVE = $00000010;

Description

Reports about mouse movements, sent in the form of x and y coordinates relative to the upper left corner of the window. One message will be sent to the application for each "tick" of the mouse.

The application can opt to receive IDCMP_MOUSEMOVE events only while certain gadgets are active, or during normal window operation. These events are sent whenever a gadget with GACT_FOLLOWMOUSE gadget is active, or for any window that has the WA_ReportMouse attribute set. This window attribute can be set or cleared by the application at will.

Requesting IDCMP_MOUSEMOVE messages can create a very large volume of messages arriving at the window's IDCMP. Do not request these messages unless the program is prepared to keep up with them. Intuition limits the number of mouse move events that pile up at your IDCMP.

All IDCMP messages contain a mouse x and y position that can be absolute values or delta values. See IDCMP_DELTAMOVE. If the application requires a less frequent reporting of the mouse position, consider using IDCMP_INTUITICKS. While IDCMP_MOUSEMOVE events are generated by changes in the mouse's position, IDCMP_INTUITICKS IntuiMessages are based on a timer. Since they contain mouse coordinates, they effectively sample the mouse position. These message come often enough for many applications, but not so frequently as to swamp the application.

The program will not be sent IDCMP_MOUSEMOVE messages while Intuition has the layers of the screen locked (during menu operations and window sizing/dragging). This avoids problems of messages accumulating while the program is blocked, waiting to render into a locked layer.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_NEWPREFS

IDCMP class: Preferences are changed

Declaration

Source position: intuition.pas line 873

const IDCMP_NEWPREFS = $00004000;

Description

IDCMP_NEWPREFS messages are sent when the system Preferences are changed by a call to SetPrefs(). The program can learn of these changes by setting this flag.

After receiving a message of class IDCMP_NEWPREFS, the application should call GetPrefs() to obtain a copy of the new Preferences.

Under the new Preferences scheme used an IDCMP_NEWPREFS message will not always be sent when the user changes a Preferences setting. Only Preferences values that can be modified by a call to SetPrefs(), will cause an IDCMP_NEWPREFS message to be sent. New Preferences items such as overscan or font settings rely on filesystem notification for monitoring changes.

This message type is broadcast to all IDCMP that have this flag set, not just to the active window. If the application has this flag set, it should be prepared to handle the event even if it is not active.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_NEWSIZE

IDCMP class: User resized the Window

Declaration

Source position: intuition.pas line 860

const IDCMP_NEWSIZE = $00000002;

Description

Intuition sends this message after the user has resized the window. After receiving this, the program can examine the size variables in the window structure to discover the new size of the window. The message is sent, even if the size of the window did not actually change.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_RAWKEY

IDCMP class: Raw keycodes from keyboard

Declaration

Source position: intuition.pas line 869

const IDCMP_RAWKEY = $00000400;

Description

IDCMP_RAWKEY messages give the raw keycodes from the keyboard. The numeric value of the keycode is sent in the Code field. Separate codes are returned for key down and key up. Qualifier codes, such as Shift or Alt and whether this key is a repeat, may be found in the Qualifier field of the message.

In general, the application should not assume any correspondence between the keycode and the key value. Character positions on the keyboard change from country to country, and the application should respect the keymap set by the user.

Programs using IDCMP_RAWKEY messages should perform their own key mapping by calling the console.device function RawKeyConvert(), or the keymap.library function MapRawKey(). (The latter is a bit more convenient). The Autodoc for the MapRawKey() function shows how you can process so-called dead keys. A dead key is a key combination that has no immediate effect, but instead modifies a subsequent keystroke. For example, on the default keymap, Alt-F is a dead key for the acute accent mark. The sequence of Alt-F followed by the E key yields an Ã© with an acute accent.

The application can assume that certain keys will always return the same raw keycode, these keys do not have to be mapped. In general these keys are in the high part of the keymap, above $40, and includes all non-alphanumeric keys. The fixed keys include the function keys, backspace, delete, help and cursor keys.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REFRESHWINDOW

IDCMP class: Window needs refreshing

Declaration

Source position: intuition.pas line 861

const IDCMP_REFRESHWINDOW = $00000004;

Description

This message is sent whenever the window needs refreshing. This flag makes sense only with windows that have a refresh type of WA_SimpleRefresh or WA_SmartRefresh.

As a minimum, the application must call BeginRefresh() and EndRefresh() for the window after receiving an IDCMP_REFRESHWINDOW event. Create the window with the WA_NoCareRefresh attribute if you do not want to manage these events.

Most of the graphics library calls used for display output are compatible with Intuition, with the exception of ScrollRaster(). Intuition will not send an IDCMP_REFRESHWINDOW event when damage is caused to a window by ScrollRaster(). This may happen in a simple refresh window which is partially obscured by another window--the region that scrolls out from behind the front window will be damaged, but the window will receive no notification. Check the layers.LAYERREFRESH bit in the Layer structure Flags field to see if damage did happen as a result of ScrollRaster().

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REQCLEAR

IDCMP class: Requester is cleared

Declaration

Source position: intuition.pas line 871

const IDCMP_REQCLEAR = $00001000;

Description

Intuition sends an IDCMP_REQCLEAR message to the window each time a requester is cleared from that window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REQSET

IDCMP class: Recive message when a requester opens

Declaration

Source position: intuition.pas line 866

const IDCMP_REQSET = $00000080;

Description

With this flag set, the program will receive a message whenever a requester opens in its window. The application will receive one IDCMP_REQSET event for each requester opened in the window.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_REQVERIFY

IDCMP class: Verify intuition is ready to render a requester

Declaration

Source position: intuition.pas line 870

const IDCMP_REQVERIFY = $00000800;

Description

Set this flag to allow the application to ensure it is prepared for Intuition to render a requester in the window. With this flag set, Intuition sends the application a message that a requester is pending, and then waits for the application to reply before drawing the requester in the window.

If several requesters open in the window, Intuition asks the application to verify only the first one. After that, Intuition assumes that all output is being held off until all the requesters are gone.

By setting the IDCMP_REQSET and IDCMP_REQCLEAR flags, the application can track how many requesters are open in the window and when the last requester is cleared. Once all of the requesters are cleared from the window, it is safe to write to the window until another IDCMP_REQVERIFY is received.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_RESERVED1

Declaration

Source position: intuition.pas line 891

const IDCMP_RESERVED1 = $20000000;


IDCMP_RESERVED2

Declaration

Source position: intuition.pas line 892

const IDCMP_RESERVED2 = $40000000;


IDCMP_SIZEVERIFY

IDCMP class: resize must be verified by application

Declaration

Source position: intuition.pas line 859

const IDCMP_SIZEVERIFY = $00000001;

Description

Set this flag if the program must complete some operation before the user sizes the window. When the user sizes the window, Intuition sends an IDCMP_SIZEVERIFY message to the application and then waits until the program replies before allowing the user to size the window. See the "Verification Functions" section below for some things to consider when using this flag.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_VANILLAKEY

IDCMP class: keyboard events

Declaration

Source position: intuition.pas line 880

const IDCMP_VANILLAKEY = $00200000;

Description

IDCMP_VANILLAKEY messages return keyboard events translated into the current default character keymap. The mapped character value is returned in the Code field.

An IDCMP_VANILLAKEY message is sent only if the translation results in a single byte value, therefore the program cannot read the Help or function keys using IDCMP_VANILLAKEY.

Programs using IDCMP_VANILLAKEY which also require the additional information of special keys, such as the Help key and the function keys, may set both IDCMP_VANILLAKEY and IDCMP_RAWKEY. When this combination is used, all keypresses that map to single character values will be returned as IDCMP_VANILLAKEY events; all other keyboard events will be sent as IDCMP_RAWKEY messages. Note that IDCMP_VANILLAKEY processing uses all of the key-up events, so the application will only receive key-down events in the IDCMP_RAWKEY format.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDCMP_WBENCHMESSAGE

IDCMP class: private

Declaration

Source position: intuition.pas line 876

const IDCMP_WBENCHMESSAGE = $00020000;

Description

Special messages for Workbench, system use only.

See also

TIntuiMessage | Intuition message structure
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported


IDOMAIN_MAXIMUM

Declaration

Source position: intuition.pas line 3309

const IDOMAIN_MAXIMUM = 2;


IDOMAIN_MINIMUM

Declaration

Source position: intuition.pas line 3307

const IDOMAIN_MINIMUM = 0;


IDOMAIN_NOMINAL

Declaration

Source position: intuition.pas line 3308

const IDOMAIN_NOMINAL = 1;


IDS_BUSY

Image draw style for IM_DRAW for future functionality

Declaration

Source position: intuition.pas line 3218

const IDS_BUSY = 3;


IDS_DISABLED

Image draw state for IM_DRAW for disabled gadgets

Declaration

Source position: intuition.pas line 3217

const IDS_DISABLED = 2;


IDS_INACTIVEDISABLED

Image draw style for IM_DRAW disabled, in inactive border

Declaration

Source position: intuition.pas line 3222

const IDS_INACTIVEDISABLED = 7;


IDS_INACTIVENORMAL

Image draw style for IM_DRAW normal, in inactive window border

Declaration

Source position: intuition.pas line 3220

const IDS_INACTIVENORMAL = 5;


IDS_INACTIVESELECTED

Image draw style for IM_DRAW selected, in inactive border

Declaration

Source position: intuition.pas line 3221

const IDS_INACTIVESELECTED = 6;


IDS_INDETERMINANT

Declaration

Source position: intuition.pas line 3226

const IDS_INDETERMINANT = IDS_INDETERMINATE;


IDS_INDETERMINATE

Image draw style for IM_DRAW for future functionality

Declaration

Source position: intuition.pas line 3219

const IDS_INDETERMINATE = 4;


IDS_NORMAL

Image draw style for IM_DRAW

Declaration

Source position: intuition.pas line 3215

const IDS_NORMAL = 0;


IDS_SELECTED

Image draw state for IM_DRAW for selected gadgets

Declaration

Source position: intuition.pas line 3216

const IDS_SELECTED = 1;


IDS_SELECTEDDISABLED

Image draw style for IM_DRAW disabled and selected

Declaration

Source position: intuition.pas line 3223

const IDS_SELECTEDDISABLED = 8;


IDSF_DISABLED

Declaration

Source position: intuition.pas line 3621

const IDSF_DISABLED = 1 shl IDS_DISABLED;


IDSF_DISABLEDMASK

Declaration

Source position: intuition.pas line 3627

const IDSF_DISABLEDMASK = $20000000;


IDSF_ERASEMASK

Declaration

Source position: intuition.pas line 3629

const IDSF_ERASEMASK = $80000000;


IDSF_INACTIVENORMAL

Declaration

Source position: intuition.pas line 3622

const IDSF_INACTIVENORMAL = 1 shl IDS_INACTIVENORMAL;


IDSF_INACTIVESELECTED

Declaration

Source position: intuition.pas line 3623

const IDSF_INACTIVESELECTED = 1 shl IDS_INACTIVESELECTED;


IDSF_MASK

Declaration

Source position: intuition.pas line 3626

const IDSF_MASK = $10000000;


IDSF_NORMAL

Declaration

Source position: intuition.pas line 3619

const IDSF_NORMAL = 1 shl IDS_NORMAL;


IDSF_SELDISABLEDMASK

Declaration

Source position: intuition.pas line 3628

const IDSF_SELDISABLEDMASK = $40000000;


IDSF_SELECTED

Declaration

Source position: intuition.pas line 3620

const IDSF_SELECTED = 1 shl IDS_SELECTED;


IDSF_SELECTEDDISABLED

Declaration

Source position: intuition.pas line 3624

const IDSF_SELECTEDDISABLED = 1 shl IDS_SELECTEDDISABLED;


IEXTENT_ADD

Declaration

Source position: intuition.pas line 3332

const IEXTENT_ADD = 1;


IEXTENT_INVERT

Declaration

Source position: intuition.pas line 3333

const IEXTENT_INVERT = 2;


IEXTENT_REMOVE

Declaration

Source position: intuition.pas line 3331

const IEXTENT_REMOVE = 0;


IEXTENT_SECT

Declaration

Source position: intuition.pas line 3334

const IEXTENT_SECT = 3;


IGF_BRCORN

Declaration

Source position: intuition.pas line 3752

const IGF_BRCORN = $00000040;


IGF_HORIZARROW

Declaration

Source position: intuition.pas line 3751

const IGF_HORIZARROW = $00000020;


IGF_KEEPHEIGHT

Declaration

Source position: intuition.pas line 3756

const IGF_KEEPHEIGHT = $00008000;


IGF_KEEPLEFT

Declaration

Source position: intuition.pas line 3753

const IGF_KEEPLEFT = $00001000;


IGF_KEEPTOP

Declaration

Source position: intuition.pas line 3754

const IGF_KEEPTOP = $00002000;


IGF_KEEPWIDTH

Declaration

Source position: intuition.pas line 3755

const IGF_KEEPWIDTH = $00004000;


IGF_SBARLEFT

Declaration

Source position: intuition.pas line 3748

const IGF_SBARLEFT = $00000004;


IGF_SBARRIGHT

Declaration

Source position: intuition.pas line 3749

const IGF_SBARRIGHT = $00000008;


IGF_VERTARROW

Declaration

Source position: intuition.pas line 3750

const IGF_VERTARROW = $00000010;


IGF_WBARLEFT

Declaration

Source position: intuition.pas line 3746

const IGF_WBARLEFT = $00000001;


IGF_WBARRIGHT

Declaration

Source position: intuition.pas line 3747

const IGF_WBARRIGHT = $00000002;


IGNORE_DIMENSIONS

Flag for TPreferences.PrintFlags ignore max width/height settings

Declaration

Source position: intuition.pas line 2418

const IGNORE_DIMENSIONS = $0000;


IIntuition

Declaration

Source position: intuition.pas line 3800

var IIntuition: PInterface = Nil;


IJ_CENTER

Declaration

Source position: intuition.pas line 3194

const IJ_CENTER = 1;


IJ_LEFT

Declaration

Source position: intuition.pas line 3193

const IJ_LEFT = 0;


IJ_RIGHT

Declaration

Source position: intuition.pas line 3195

const IJ_RIGHT = 2;


IM_DOMAINFRAME

Declaration

Source position: intuition.pas line 3208

const IM_DOMAINFRAME = $20A;


IM_DRAW

imageclass message id. draw yourself, with "state" (IDS_*)

Declaration

Source position: intuition.pas line 3198

const IM_DRAW = $202;

See also

PimpDraw | Pointer to message argument for IM_DRAW or IM_DRAWFRAME
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME


IM_DRAWFRAME

imageclass message id. draw with specified dimensions

Declaration

Source position: intuition.pas line 3203

const IM_DRAWFRAME = $206;

See also

PimpDraw | Pointer to message argument for IM_DRAW or IM_DRAWFRAME
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME


IM_ERASE

imageclass message id. erase yourself

Declaration

Source position: intuition.pas line 3200

const IM_ERASE = $204;

See also

PimpErase | Pointer to message argument for IM_ERASE or IM_ERASEFRAME
TimpErase | Message argument for IM_ERASE or IM_ERASEFRAME


IM_ERASEFRAME

imageclass message id. hittest with dimensions

Declaration

Source position: intuition.pas line 3206

const IM_ERASEFRAME = $209;

See also

PimpErase | Pointer to message argument for IM_ERASE or IM_ERASEFRAME
TimpErase | Message argument for IM_ERASE or IM_ERASEFRAME


IM_EXTENT

Declaration

Source position: intuition.pas line 3210

const IM_EXTENT = $20B;


IM_EXTENTFRAME

Declaration

Source position: intuition.pas line 3211

const IM_EXTENTFRAME = $20C;


IM_FRAMEBOX

imageclass message id. get recommended frame around some box

Declaration

Source position: intuition.pas line 3204

const IM_FRAMEBOX = $207;

See also

PimpFrameBox | Pointer to message argument for IM_FRAMEBOX
TimpFrameBox | Message argument for IM_FRAMEBOX


IM_HITFRAME

imageclass message id. hittest with dimensions

Declaration

Source position: intuition.pas line 3205

const IM_HITFRAME = $208;

See also

PimpHitTest | Pointer to message argument for IM_HITTEST or IM_HITFRAME
TimpHitTest | Message argument for IM_HITTEST or IM_HITFRAME


IM_HITTEST

imageclass message id. return True if click hits image

Declaration

Source position: intuition.pas line 3199

const IM_HITTEST = $203;

See also

PimpHitTest | Pointer to message argument for IM_HITTEST or IM_HITFRAME
TimpHitTest | Message argument for IM_HITTEST or IM_HITFRAME


IM_MOVE

imageclass message id. draw new and erase old, smoothly

Declaration

Source position: intuition.pas line 3201

const IM_MOVE = $205;


IMAGE_NEGATIVE

Value for TPreferences.PrintImage

Declaration

Source position: intuition.pas line 2350

const IMAGE_NEGATIVE = $01;


IMAGE_POSITIVE

Value for TPreferences.PrintImage

Declaration

Source position: intuition.pas line 2349

const IMAGE_POSITIVE = $00;


IMAGECLASS

Class identifier. This class is the base class for Boopsi Images.

Declaration

Source position: intuition.pas line 2524

const IMAGECLASS: PChar = 'imageclass';

Description

SuperClass: rootclass

This class is the base class for Boopsi Images. These images are backwards compatible with the conventional Intuition Images. Every Boopsi image has an Intuition Image structure embedded in it so Intuition can access the Boopsi image as a conventional Image structure when necessary. Normally there are no direct instances of this class, only instances of subclasses of imageclass.

New Methods:

IM_DRAW, IM_ERASE, IM_HITFRAME, IM_FRAMEBOX, IM_HITTEST, IM_DRAWFRAME, IM_ERASEFRAME

Changed Methods:

OM_NEW, OM_SET

Attributes:

IA_Left (ISG)

IA_Top (ISG)

IA_Width (ISG)

IA_Height (ISG)

IA_FGPen (ISG)

IA_BGPen (ISG)

IA_Data (ISG)

IA_Pens ()

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


IMPF_ALLOWSUPER

Declaration

Source position: intuition.pas line 3336

const IMPF_ALLOWSUPER = $01;


IMR_CLIPDONE

Declaration

Source position: intuition.pas line 3339

const IMR_CLIPDONE = $40;


IMR_INVALID

Declaration

Source position: intuition.pas line 3338

const IMR_INVALID = $00;


IMR_MASKDONE

Declaration

Source position: intuition.pas line 3340

const IMR_MASKDONE = $80;


IMSGCODE_INTUIRAWKEYDATA

Declaration

Source position: intuition.pas line 846

const IMSGCODE_INTUIRAWKEYDATA = 1 shl 14;


IMSGCODE_INTUIWHEELDATA

Declaration

Source position: intuition.pas line 845

const IMSGCODE_INTUIWHEELDATA = 1 shl 15;


IMT_CONTEXT_GADGET_APP

Declaration

Source position: intuition.pas line 853

const IMT_CONTEXT_GADGET_APP = 2;


IMT_CONTEXT_GADGET_OBJ

Declaration

Source position: intuition.pas line 854

const IMT_CONTEXT_GADGET_OBJ = 3;


IMT_CONTEXT_WINDOW

Declaration

Source position: intuition.pas line 852

const IMT_CONTEXT_WINDOW = 1;


IMT_DEFAULT

Declaration

Source position: intuition.pas line 851

const IMT_DEFAULT = 0;


IMTAG_Dummy

Declaration

Source position: intuition.pas line 815

const IMTAG_Dummy = TAG_USER + $414000;


IMTAG_MenuContext

Declaration

Source position: intuition.pas line 849

const IMTAG_MenuContext = IMTAG_Dummy + 2;


IMTAG_MenuType

Declaration

Source position: intuition.pas line 848

const IMTAG_MenuType = IMTAG_Dummy + 1;


INACTIVEFILLFLATPEN

Declaration

Source position: intuition.pas line 1991

const INACTIVEFILLFLATPEN = $002C;


INACTIVEFILLPEN

Declaration

Source position: intuition.pas line 1965

const INACTIVEFILLPEN = $0012;


INACTIVEFILLSHADOWPEN

Declaration

Source position: intuition.pas line 1968

const INACTIVEFILLSHADOWPEN = $0015;


INACTIVEFILLSHINEPEN

Declaration

Source position: intuition.pas line 1967

const INACTIVEFILLSHINEPEN = $0014;


INACTIVEFILLTEXTPEN

Declaration

Source position: intuition.pas line 1966

const INACTIVEFILLTEXTPEN = $0013;


INACTIVEGLYPHPEN

Declaration

Source position: intuition.pas line 1983

const INACTIVEGLYPHPEN = $0024;


Reference for unit 'intuition'

Screen and Window handling routines of intuition.library

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility, | Tag Handling, Date routines in utility.library
inputevent,
timer,
layers; | Layer handling


Reference for unit 'intuition': Constants

ABSOLUTE_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as absolutes
ALERT_TYPE | Alert Type for DisplayAlert()
ALPHA_P_101 | Value for TPreferences.PrinterType
ALTLEFT | Qualifier for TIntuiMessage.Qualifier. Left Alt Key pressed.
ALTRIGHT | Qualifier for TIntuiMessage.Qualifier. Right Alt Key pressed.
AMIGAKEY | SYSIA_Which tag data values. Menu Amiga-key image
AMIGAKEYS | Qualifier for TIntuiMessage.Qualifier. An Amiga Key pressed.
AMIGALEFT | Qualifier for TIntuiMessage.Qualifier. Left Amiga Key pressed.
AMIGARIGHT | Qualifier for TIntuiMessage.Qualifier. Right Amiga Key pressed.
ANTI_ALIAS | Flag for TPreferences.PrintFlags anti-alias image
ASPECT_HORIZ | Value for TPreferences.PrintAspect
ASPECT_VERT | Value for TPreferences.PrintAspect
AUTOBACKPEN |
AUTODRAWMODE |
AUTOFRONTPEN |
AUTOITEXTFONT
AUTOKNOB | Flag value for TPropInfo.Flags. Gimme that old auto-knob
AUTOLEFTEDGE |
AUTONEXTTEXT
AUTOSCROLL | Flag for TScreen.Flags. Screen is to autoscoll
AUTOTOPEDGE |
AWCODE_INTERIM
AWCODE_NORMAL
BACKGROUNDPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. always color 0
BARBLOCKPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. screen-bar/menus fill
BARCONTOURPEN
BARDETAILPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. text/detail in screen-bar/menus
BARTRIMPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. trim under screen-bar
BAUD_110 | Value for TPreferences.BaudRate
BAUD_1200 | Value for TPreferences.BaudRate
BAUD_19200 | Value for TPreferences.BaudRate
BAUD_2400 | Value for TPreferences.BaudRate
BAUD_300 | Value for TPreferences.BaudRate
BAUD_4800 | Value for TPreferences.BaudRate
BAUD_9600 | Value for TPreferences.BaudRate
BAUD_MIDI | Value for TPreferences.BaudRate
BEEPING_F | Flag for TScreen.Flags. Set when Screen is beeping
BLOCKPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. compatible Intuition rendering pens
BMICTRL_Dummy
BMICTRL_GetAlphaMap
BMICTRL_GetBitMap
BMICTRL_GetBitMapSource
BMICTRL_GetBrightBitMap
BMICTRL_GetDarkBitMap
BMICTRL_GetGradientSpec
BMICTRL_GetHalfBrightBitMap
BMICTRL_GetHalfDarkBitMap
BMICTRL_GetHeight
BMICTRL_GetHook
BMICTRL_GetMaskBitMap
BMICTRL_GetOffsets
BMICTRL_GetOutlineBitMap
BMICTRL_GetOutlineMap
BMICTRL_GetReferencePen
BMICTRL_GetScreen
BMICTRL_GetShadeMaskBitMap
BMICTRL_GetShadowMap
BMICTRL_GetShineMap
BMICTRL_GetTileBox
BMICTRL_GetTileHeight
BMICTRL_GetTileLeft
BMICTRL_GetTileTop
BMICTRL_GetTileWidth
BMICTRL_GetWidth
BMICTRL_SetGradientSpec
BMICTRL_SetOffsets
BMICTRL_SetReferencePen
BMICTRL_SetTileHeight
BMICTRL_SetTileLeft
BMICTRL_SetTileTop
BMICTRL_SetTileWidth
BMI_CacheGradient
BMI_DoLevels
BMI_Dummy
BMI_Exclusive
BMI_GradientAxis
BMI_GradientSpec
BMI_IgnoreDomain
BMI_LayerInfo
BMI_Offsets
BMI_ReferencePen
BMI_TileHeight
BMI_TileLeft
BMI_TileTop
BMI_TileWidth
BMS_DoMask
BMS_DoOutline
BMS_DoShade
BMS_Dummy
BMS_NoDiskIO
BOOLMASK | Extension is for masked gadget
BOOPSIMENU
BOUNDED_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as boundaries
BROTHER_15XL | Value for TPreferences.PrinterType
BT_BACKGROUND
BT_DIRECTSHADE
BT_DRIPEN
BT_FLAGSMASK
BT_GADGET
BT_MENU
BT_OFFSETRECT
BT_PROPBG
BT_PROPKNOB
BT_REQUESTERBG
BT_SCREENBAR
BT_TABPAGE
BT_WINBORDER
BT_WINDOWBAR
BT_WINDOWBG
BT_WINPROPBG
BT_WINPROPKNOB
BUTTONGCLASS | Class identifier. A button gadget that keeps sending button presses while the user holds it down.
CBM_MPS1000 | Value for TPreferences.PrinterType
CENTER_IMAGE | Flag for TPreferences.PrintFlags center image on paper
CHECKED | Flag for TMenuItem.Flags set by the Application and intuition, if CHECKIT, then set this when selected
CHECKIMAGE | SYSIA_Which tag data values. GadTools checkbox image
CHECKIT | Flag for TMenuItem.Flags set by the Application, whether to check this item if selected
CHECKMARKIMAGE
CHECKWIDTH | Define for CHECKIT width for the CheckMark in a menu item
CLF_INLIST | class is in public class list (TIClass.cl_Flags)
CLICKTAB_ACTIVEBOLD
CLICKTAB_ACTIVEBRIGHT
CLICKTAB_ACTIVEFILLFILL
CLICKTAB_ACTIVEFILLGRAD
CLICKTAB_ACTIVEFILLMASK
CLICKTAB_ACTIVEFILLNONE
CLICKTAB_ACTIVEFILLSELECT
CLICKTAB_ACTIVEFILLSHINE
CLICKTAB_ACTIVEPENHLTEXT
CLICKTAB_ACTIVEPENMASK
CLICKTAB_ACTIVEPENTEXT
CLICKTAB_ACTIVEPENTITLE
CLICKTAB_EVENWIDTH
CLICKTAB_INACTIVEDARK
CLOSEGADGET |
CLOSEIMAGE | SYSIA_Which tag data values. Window close gadget image
CMENU_BOTTOM
CMENU_CENTER
CMENU_CENTER_MOUSE
CMENU_RIGHT
CM_QUERY
CNTR_ABSOLUTE
CNTR_CORRECT
COMMSEQ | Flag for TMenuItem.Flags set by the Application, set if there's an command sequence
COMMWIDTH | Define for COMMSEQ width for the Command sequence in a menu item
CORRECT_BLUE | Flag for TPreferences.PrintFlags color correct blue shades
CORRECT_GREEN | Flag for TPreferences.PrintFlags color correct green shades
CORRECT_RED | Flag for TPreferences.PrintFlags color correct red shades
CORRECT_RGB_MASK | Mask for TPreferences.PrintFlags color corrections RGB
CURSORDOWN | RawKeycode for TIntuiMessage.Code. Cursor Down key pressed.
CURSORLEFT | RawKeycode for TIntuiMessage.Code. Cursor left key pressed.
CURSORRIGHT | RawKeycode for TIntuiMessage.Code. Cursor right key pressed.
CURSORUP | RawKeycode for TIntuiMessage.Code. Cursor up key pressed.
CUSTOMBITMAP_F | Flag for TScreen.Flags. If you are supplying your own BitMap
CUSTOMIMAGEDEPTH | if TImage.Depth is this, it's a new Image class object
CUSTOMSCREEN_F | Screentype flag for TScreen.Flags and TNewScreen.SType. For that special look
CUSTOM_NAME | Value for TPreferences.PrinterType
CUSTOM_PAPER | Value for TPreferences.PaperSize
CWCODE_DEPTH | Code for IDCMP_CHANGEWINDOW Window was depth-arranged
CWCODE_MOVESIZE | Code for IDCMP_CHANGEWINDOW Window was moved and/or sized
CYCLEIMAGE
DEADEND_ALERT | Alert Type for DisplayAlert() no recovery possible, this is it
DEFAULTMOUSEQUEUE | Window value, No more mouse messaged
DEFERREFRESH | Flag for TRequester.Flags. Read-Only. This Requester stops a Refresh broadcast
DEPTHIMAGE | SYSIA_Which tag data values. Window depth gadget image
DETAILPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. Compatible Intuition rendering pens
DEVNAME_SIZE | Devicename size for printer configuration
DIAB_630 | Value for TPreferences.PrinterType
DIAB_ADV_D25 | Value for TPreferences.PrinterType
DIAB_C_150 | Value for TPreferences.PrinterType
DIMENSIONS_MASK | Mask for TPreferences.PrintFlags Dimensions mask
DISABLEDPEN
DISABLEDSHADOWPEN
DISABLEDSHINEPEN
DISABLEDTEXTPEN
DITHERING_MASK | Mask for TPreferences.PrintFlags Dithering mask
DMODECOUNT |
DOWNBACKGADGET |
DOWNIMAGE | SYSIA_Which tag data values. Down-arrow gadget image
DRAFT | Value for TPreferences.PrintQuality
DRAGGADGET |
DRIF_NEWDISABLE
DRIF_NEWLOOK | Flag for TDrawInfo.dri_Flags specified SA_Pens, full treatment
DRIF_REALSHADE
DRIPENS_IGNORE
DRI_VERSION | Version of the TDrawInfo structure, can be found in TDrawInfo.dri_Version
DSHM_Jump
DSHM_Smooth
EIGHT_LPI | Value for TPreferences.PrintSpacing
ELITE | Value for TPreferences.PrintPitch
EO_BADFORMAT | Value for TSGWork.EditOp
EO_BIGCHANGE | Value for TSGWork.EditOp
EO_CLEAR | Value for TSGWork.EditOp
EO_DELBACKWARD | Value for TSGWork.EditOp
EO_DELFORWARD | Value for TSGWork.EditOp
EO_ENTER | Value for TSGWork.EditOp
EO_INSERTCHAR | Value for TSGWork.EditOp
EO_MOVECURSOR | Value for TSGWork.EditOp
EO_NOOP | Value for TSGWork.EditOp
EO_REPLACECHAR | Value for TSGWork.EditOp
EO_RESET | Value for TSGWork.EditOp
EO_SPECIAL | Value for TSGWork.EditOp
EO_UNDO | Value for TSGWork.EditOp
EPSON | Value for TPreferences.PrinterType
EPSON_JX_80 | Value for TPreferences.PrinterType
ERROR_BAD_ACTION_ON_ITEM
ERROR_BAD_ACTION_ON_MENU
ERROR_BAD_ACTION_ON_ROOT
ERROR_BAD_ACTION_ON_SEPARATOR
ERROR_COMM_KEY_AT_TITLE_LEVEL
ERROR_ITEM_ID_IS_ZERO
ERROR_ITEM_WITHOUT_ID
ERROR_SEPARATOR_AT_TITLE_LEVEL
ERROR_SUBITEMS_WITHOUT_PARENT
ERROR_TITLE_OUT_OF_PLACE
ESA_Dummy
ESA_Position
ESA_Underscore
ESF_EVENSIZE
ESF_INACTIVE
ESF_SCREEN
ESF_TAGGED
ET_MENUHELP
ET_MENUPICK
EURO_A0 | Value for TPreferences.PaperSize European size A0: 841 x 1189
EURO_A1 | Value for TPreferences.PaperSize European size A1: 594 x 841
EURO_A2 | Value for TPreferences.PaperSize European size A2: 420 x 594
EURO_A3 | Value for TPreferences.PaperSize European size A3: 297 x 420
EURO_A4 | Value for TPreferences.PaperSize European size A4: 210 x 297
EURO_A5 | Value for TPreferences.PaperSize European size A5: 148 x 210
EURO_A6 | Value for TPreferences.PaperSize European size A6: 105 x 148
EURO_A7 | Value for TPreferences.PaperSize European size A7: 74 x 105
EURO_A8 | Value for TPreferences.PaperSize European size A8: 52 x 74
EVENTMAX |
FANFOLD_PT |
FILENAME_SIZE | Filename size for printer configuration
FILLFLATPEN
FILLPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. active-window/selected-gadget fill
FILLRECTCLASS | Class identifier
FILLSHADOWPEN
FILLSHINEPEN
FILLTEXTPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. text over FILLPEN
FINE | Value for TPreferences.PrintPitch
FLATBORDERPEN
FLOYD_DITHERING | Flag for TPreferences.PrintFlags Floyd-Steinberg dithering
FOREGROUNDPEN
FORESHADOWPEN
FORESHINEPEN
FRAMEBUTTON_3D
FRAMEBUTTON_FLAT
FRAMEBUTTON_FRAMED
FRAMEDISCOL_BACKG
FRAMEDISCOL_DISAB
FRAMEDISCOL_FOREG
FRAMEDISPLAY_3D
FRAMEDISPLAY_FLAT
FRAMEDISPLAY_FRAMED
FRAMEDISPLAY_FRAMED2
FRAMEF_SPECIFY | Flag for TimpFrameBox.imp_FrameFlags
FRAMEICLASS | Class identifier. This is a class of framing image, which can optionally fill itself.
FRAMEPRESSED_INVERTED
FRAMEPRESSED_PUSHED
FRAMEPROP_3D
FRAMEPROP_FLAT
FRAMEPROP_FRAMED
FRAMEPROP_NONE
FRAMESELCOL_BACKG
FRAMESELCOL_FILL
FRAMESELCOL_FOREG
FRAMESELCOL_SELECT
FRAMESTRING_3D
FRAMESTRING_FLAT
FRAMESTRING_FRAMED
FRAMESTRING_FRAMED2
FRAMETHIN_EDGESONLYRAISED
FRAMETHIN_EDGESONLYRECESSED
FRAMETHIN_FILLEDRAISED
FRAMETHIN_FILLEDRECESSED
FRAMEWINDOW_3D
FRAMEWINDOW_FLAT
FRAMEWINDOW_FRAMED
FRAME_BUTTON | Data value for IA_FrameType Standard button gadget frames, having thicker sides and nicely edged corners.
FRAME_DEFAULT | Data value for IA_FrameType The standard V37-type frame, which has thin edges.
FRAME_DISPLAY
FRAME_ICONDROPBOX | Data value for IA_FrameType A broad ridge which is the standard imagery for areas in AppWindows where icons may be dropped.
FRAME_PROPBORDER
FRAME_PROPKNOB
FRAME_RIDGE | Data value for IA_FrameType A ridge such as used by standard string gadgets. You can recess the ridge to get a groove image.
FRBUTTONCLASS | Class identifier. A buttongclass gadget that outlines its imagery with a frame.
FREEHORIZ | Flag value for TPropInfo.Flags. if set, the knob can move horizontally
FREEVERT | Flag value for TPropInfo.Flags. if set, the knob can move vertically
GACT_ACTIVEGADGET | Activation flag for TGadget.Activation. This gadget is "active".
GACT_ALTKEYMAP | Activation flag for TGadget.Activation. this String has an alternate keymap
GACT_BOOLEXTEND | Activation flag for TGadget.Activation. this Boolean Gadget has a BoolInfo
GACT_BORDERSNIFF | Activation flag for TGadget.Activation. neither set nor rely on this bit
GACT_BOTTOMBORDER | Activation flag for TGadget.Activation.
GACT_ENDGADGET | Activation flag for TGadget.Activation. when set, tells the system that this gadget, when selected, causes the Requester to be ended. Requesters that are ended are erased and unlinked from the system.
GACT_FOLLOWMOUSE | Activation flag for TGadget.Activation. when set, specifies that you want to receive reports on mouse movements
GACT_IMMEDIATE | Activation flag for TGadget.Activation. when set, informs the caller that the gadget was activated when it was activated. This flag works in conjunction with the GACT_RELVERIFY flag
GACT_LEFTBORDER | Activation flag for TGadget.Activation.
GACT_LONGINT | Activation flag for TGadget.Activation. this String Gadget is for LongInts
GACT_RELVERIFY | Activation flag for TGadget.Activation. Set if you want to verify that the pointer was still over the gadget when the select button was released. Will cause an IDCMP_GADGETUP message to be sent if so.
GACT_RIGHTBORDER | Activation flag for TGadget.Activation.
GACT_STRINGCENTER | Activation flag for TGadget.Activation.
GACT_STRINGEXTEND | Activation flag for TGadget.Activation. this String Gadget has PStringExtend
GACT_STRINGLEFT | Activation flag for TGadget.Activation.
GACT_STRINGRIGHT | Activation flag for TGadget.Activation.
GACT_TOGGLESELECT | Activation flag for TGadget.Activation. this bit for toggle-select mode
GACT_TOPBORDER | Activation flag for TGadget.Activation.
GADGETCLASS | Class identifier. This is a base class for Intuition compatible gadget objects.
GADGETCOUNT |
GADGETPEN
GAUGEIA_InnerTicks
GAUGEIA_Level
GAUGEIA_Max
GAUGEIA_Min
GAUGEIA_ScaleHook
GAUGEIA_ShortTicks
GAUGEIA_Ticks
GAUGEIA_TickSize
GAUGE_BORDERPENS
GAUGE_CONT_3D
GAUGE_CONT_AUTOSTYLE
GAUGE_CONT_BORDERLESS
GAUGE_CONT_FLAT
GAUGE_CONT_FRAMED
GAUGE_CONT_FRAMED2
GAUGE_CONT_GRADIENT
GAUGE_CONT_STYLEMASK
GAUGE_FILL_3D
GAUGE_FILL_AUTOSTYLE
GAUGE_FILL_BORDERLESS
GAUGE_FILL_FLAT
GAUGE_FILL_FRAMED
GAUGE_FILL_GRADIENT
GAUGE_FILL_STYLEMASK
GAUGE_INNERTICKS
GAUGE_RESERVED
GAUGE_SPACINGMASK
GAUGE_UNUSED
GA_ActivateKey | GadgetClass Tag. (PChar) Set/Get the gadgets shortcut/activation key(s) Default = nil
GA_BackFill | GadgetClass Tag. (PHook) Backfill pattern hook. Defaults to nil.
GA_Border | GadgetClass Tag. (PBorder) Gadget imagry is a border
GA_BottomBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the bottom border or not. Default = False.
GA_Bounds | GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.
GA_ContextMenu
GA_Disabled | GadgetClass Tag. [IS.] (LongWord) Takes GFLG_GADGH* flags as argument. Used to specify the highlighting technique.
GA_DoLayout
GA_DrawInfo | GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.
GA_Dummy | GadgetClass Start Tag.
GA_EndGadget | GadgetClass Tag. [ISG] (LongBool) Indicate whether the gadget is selected or not. Default = False
GA_FollowMouse | GadgetClass Tag. [IS.] (LongBool) If this is set, the gadget receives information about the movement of the mouse as long as it is activated. Default = False
GA_GadgetHelp | GadgetClass Tag. [..G] (LongBool) If this is set by the gadget, the sends GADGETHELP messages.
GA_GadgetHelpText | GadgetClass Tag. (PChar) RESERVERD/PRIVATE DO NOT USE. Default = nil
GA_GZZGadget | GadgetClass Tag. [ISG] (LongBool) If this is set to true, the gadget is not selectable.
GA_Height | GadgetClass Tag. [ISG] (LongInt) Height of gadget.
GA_Hidden
GA_Highlight | GadgetClass Tag. [IS.] (PImage) Gadgets' image in selected state.
GA_HintInfo
GA_ID | GadgetClass Tag. [IS.] (LongBool) The Gadget is a GimmeZeroZero gadget. Default = False
GA_Image | GadgetClass Tag. (PImage) Gadget imagry is an image
GA_Immediate | GadgetClass Tag. [IS.] (LongBool) Only used for requester gadgets. Default = False
GA_IntuiText | GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.
GA_LabelImage | GadgetClass Tag. [IS.] (PObject_) Label is an image object.
GA_Left | GadgetClass Tag. [ISG] (LongInt) Left edge of gadget.
GA_LeftBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the left border or not. Default = False.
GA_Next | GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.
GA_NoFilterMenuKeys
GA_NoFilterWheel
GA_Previous | GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.
GA_ReadOnly | GadgetClass Tag. (LongBool) Indicate that the gadget is read-only (non-selectable). Default = False
GA_RelBottom | GadgetClass Tag. [ISG] (LongInt) Top edge of gadget, depending on bottom window border: Top := Win^.Height - this - 1
GA_RelHeight | GadgetClass Tag. [ISG] (LongInt) Height of gadget, depending on window height: Height := Win^.Height - this
GA_RelRight | GadgetClass Tag. [ISG] (LongInt) Left edge of gadget, depending on right window border: Left := Win^.Width - this - 1
GA_RelSpecial | GadgetClass Tag. [IS.] (LongInt) This attribute should only be set by subclasses of GadgetClass.
GA_RelVerify | GadgetClass Tag. [IS.] (LongBool) If set the gadget responds immediatly, when the gadget is selected. Default = False
GA_RelWidth | GadgetClass Tag. [ISG] (LongInt) Width of gadget, depending on window width: Width := Win^.Width - this
GA_RightBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the right border or not. Default = False.
GA_Selected | GadgetClass Tag. (APTR) Pointer to additional information
GA_SelectRender | GadgetClass Tag.
GA_SpecialInfo | GadgetClass Tag. [ISG] (IPTR) Fill with whatever you want to. This field is ignored by the system.
GA_SysGadget | GadgetClass private Tag. [IS.] (LongBool) Set, if gadget is a system-gadget e.g. a standard window border gadget. Default = False.
GA_SysGType | GadgetClass private Tag. [IS.] (LongWord) Reserved for system use to indicate the gadget type.
GA_TabCycle | GadgetClass Tag. [IS.] (LongBool) If set to true that gadget participates in TAB handling, i.e. if tab is pressed, the next gadget is activated.
GA_Text | GadgetClass Tag. [IS.] (PChar) Label text. This is mutually exclusive with GA_IntuiText and GA_LabelImage.
GA_TextAttr | GadgetClass Tag. [IS.] (PTextAttr) Indicate the font to use for the gadget.
GA_Titlebar
GA_ToggleSelect | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is toggle-selected or not. Default = False.
GA_Top | GadgetClass Tag. [ISG] (LongInt) Top edge of gadget.
GA_TopBorder | GadgetClass Tag. [IS.] (LongBool) Indicate whether the gadget is in the top border or not. Default = False.
GA_Underscore | GadgetClass Tag. (Char) Underscore/escape character for keyboard shortcuts. Defaults = '_'
GA_UserData | GadgetClass Tag. (LongInt) Gadget ID assigned by the application (prevent double numbers)
GA_UserInput | GadgetClass Tag. (LongBool) Notification tag indicates this notification is from the activite gadget receiving user input - an attempt to make IDCMPUPDATE more efficient.
GA_Width | GadgetClass Tag. [ISG] (LongInt) Width of gadget.
GBD_BOX
GBD_GINFO
GBD_RECTANGLE
GBD_WINDOW
GBF_BOUNDS
GBF_MAKERECT
GCB_OK
GCB_UNKNOWN
GDOMAIN_MAXIMUM |
GDOMAIN_MINIMUM |
GDOMAIN_NOMINAL |
GDOWNIMAGE
GEXTENT_ADD
GEXTENT_INVERT
GEXTENT_REMOVE
GEXTENT_SECT
GFLG_DISABLED | Flag for TGadget.SpecialInfo. Is initialized by you and later set by Intuition according to your calls to OnGadget/OffGadget. It specifies whether or not this Gadget is currently disabled from being selected
GFLG_EXTENDED | Flag for TGadget.SpecialInfo. Gadget is an PExtGadget
GFLG_GADGHBOX | Flag for TGadget.SpecialInfo. Draw a box around the image
GFLG_GADGHCOMP | Flag for TGadget.Flags. Complement the select box
GFLG_GADGHIGHBITS | Flag for TGadget.SpecialInfo.
GFLG_GADGHIMAGE | Flag for TGadget.SpecialInfo. Blast in this alternate image
GFLG_GADGHNONE | Flag for TGadget.SpecialInfo. don't highlight
GFLG_GADGIMAGE | Flag for TGadget.SpecialInfo. set if TGadget.GadgetRender and TGadget.SelectRender is PImage, clear if it is a PBorder
GFLG_IMAGEDISABLE | Flag for TGadget.SpecialInfo. Gadget's image knows how to do disabled rendering
GFLG_LABELIMAGE | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PImage
GFLG_LABELITEXT | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText
GFLG_LABELMASK | Flag for TGadget.SpecialInfo.
GFLG_LABELSTRING | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PChar
GFLG_RELBOTTOM | Flag for TGadget.SpecialInfo. vertical position is relative to bottom edge
GFLG_RELHEIGHT | Flag for TGadget.SpecialInfo. height is relative to req/window
GFLG_RELRIGHT | Flag for TGadget.SpecialInfo. horizontal position is relative to right edge
GFLG_RELSPECIAL | Flag for TGadget.SpecialInfo. Custom gadget has special relativity. Gadget box values are absolutes, but can be changed via the GM_LAYOUT method.
GFLG_RELWIDTH | Flag for TGadget.SpecialInfo. width is relative to req/window
GFLG_SELECTED | Flag for TGadget.SpecialInfo. you may initialize and look at this
GFLG_STRINGEXTEND | Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend
GFLG_TABCYCLE | Flag for TGadget.SpecialInfo. (string OR custom) gadget participates in cycling activation with Tab or Shift-Tab
GGF_BOUNDED
GGF_CALCHSCROLLER
GGF_CALCHSOVERLAP
GGF_CALCVSCROLLER
GGF_CALCVSOVERLAP
GGF_INITIAL
GGPF_SCREENDRAGGING
GHKHANDLEIMAGE
GLEFTIMAGE
GLYPHFILLPEN
GLYPHPEN
GMORE_BOUNDS | Flag for TExtGadget.MoreFlags ExtGadget has valid Bounds
GMORE_GADGETHELP | Flag for TExtGadget.MoreFlags This gadget responds to gadget help
GMORE_HIDDEN
GMORE_NOCMENUOFFLOAD
GMORE_NOFILTERMENUKEYS
GMORE_NOFILTERWHEEL
GMORE_PRIVATE
GMORE_PRIVATE2
GMORE_SCROLLRASTER | Flag for TExtGadget.MoreFlags This (custom) gadget uses ScrollRaster
GMQ_CONTEXTMENU
GMQ_HINTINFO
GMQ_WHICHMEMBER
GMR_CLIPDONE
GMR_FULLBBOX
GMR_FULLHBOX
GMR_GADGETHIT | Result for GM_HITTEST Hit
GMR_HELPCODE | Result for GM_HELPTEST Hit, return low Word as code.
GMR_HELPHIT | Result for GM_HELPTEST Hit, The gadget was hit.
GMR_INVALID
GMR_KEYACTIVATE
GMR_KEYACTIVE |
GMR_KEYVERIFY |
GMR_MASKDONE
GMR_MEACTIVE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GMR_NEXTACTIVE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate next gadget.
GMR_NOHELPHIT | Result for GM_HELPTEST didn't hit
GMR_NOREUSE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GMR_PREVACTIVE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE Activate previous gadget.
GMR_REUSE | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GMR_VERIFY | Return Flags for GM_HANDLEINPUT or GM_GOACTIVE
GM_DOMAIN
GM_Dummy | GadgetClass Method IDs Start
GM_EXTENT
GM_GOACTIVE | GadgetClass Method ID. You are now going to be fed input
GM_GOINACTIVE | GadgetClass Method ID. Whether or not by choice, you are done
GM_HANDLEINPUT | GadgetClass Method ID.
GM_HANDLESCROLL
GM_HELPTEST | GadgetClass Method ID. Will you send gadget help if the mouse is at the specified coordinates? See below for possible GMR_ values.
GM_HITTEST | GadgetClass Method ID. Returns GMR_GADGETHIT if you are clicked on (whether or not you are disabled).
GM_KEYGOACTIVE
GM_KEYGOINACTIVE
GM_KEYTEST
GM_LAYOUT | GadgetClass Method ID. Re-evaluate your size based on the GadgetInfo Domain. Do NOT re-render yourself yet, you will be called when it is time...
GM_MENUHELP
GM_MENUPICK
GM_POSTRENDER
GM_PRERENDER
GM_QUERY
GM_RENDER | GadgetClass Method ID. Draw yourself, in the appropriate state
GPEF_ALLOWSUPER
GRADMODE_COLOR
GRADMODE_IMPOSE
GRADMODE_INVERT1
GRADMODE_INVERT2
GRADMODE_KEEPRATIO
GRADMODE_NONE
GRADMODE_PALETTE
GRADMODE_SHADE
GRADMODE_SIMPLE
GRADMODE_TYPEMASK
GREDRAW_REDRAW | TgpRender.gpr_Redraw. Redraw the whole gadget
GREDRAW_TOGGLE | TgpRender.gpr_Redraw. Toggle highlight, if applicable
GREDRAW_UPDATE | TgpRender.gpr_Redraw. Incremental update. Some data (e.g. the level of a slider) was updated. Just redraw the necessary parts.
GREY_SCALE2 | Flag for TPreferences.PrintFlags for use with hi-res monitor
GRIGHTIMAGE
GROUPGCLASS | Class identifier. A special gadget class that creates one composite gadget out of several others.
GTYP_BOOLGADGET | Application gadget type for TGadget.Type
GTYP_CLOSE | System gadget type for TGadget.Type
GTYP_CUSTOMGADGET | Application gadget type for TGadget.Type
GTYP_GADGET0002 | Application gadget type for TGadget.Type
GTYP_GADGETTYPE | All Gadget Global type flags for TGadget.Type
GTYP_GTYPEMASK | Application gadget type for TGadget.Type mask you can apply to tell what class of gadget this is.
GTYP_GZZGADGET | Application gadget type for TGadget.Type for WFLG_GIMMEZEROZERO borders
GTYP_PROPGadget | Application gadget type for TGadget.Type
GTYP_REQGADGET | Application gadget type for TGadget.Type this is a Requester Gadget
GTYP_SCRGADGET | Application gadget type for TGadget.Type 1 = ScreenGadget, 0 = WindowGadget
GTYP_SDEPTH
GTYP_SDOWNBACK |
GTYP_SDRAGGING | System gadget type for TGadget.Type
GTYP_SIZING | System gadget type for TGadget.Type
GTYP_STRGADGET | Application gadget type for TGadget.Type
GTYP_SUNUSED
GTYP_SUPFRONT |
GTYP_SYSGADGET | Application gadget type for TGadget.Type 1 = Allocated by the system, 0 = by application
GTYP_SYSTYPEMASK
GTYP_TBARGADGET
GTYP_WDEPTH
GTYP_WDOWNBACK |
GTYP_WDRAGGING | System gadget type for TGadget.Type
GTYP_WUPFRONT |
GTYP_WZOOM
GUIA_ArrowGadgetHeight
GUIA_ArrowGadgetWidth
GUIA_AutomaticEdgesContrast
GUIA_BarBlockBrightContrast
GUIA_BarBlockBrightCurve
GUIA_BarBlockDarkContrast
GUIA_BarBlockDarkCurve
GUIA_BrightContrast
GUIA_BrightCurve
GUIA_ClearBackground
GUIA_ClickTabLook
GUIA_CycleLabelJustify
GUIA_CycleLook
GUIA_DarkContrast
GUIA_DarkCurve
GUIA_DefaultDRIPens
GUIA_DefaultGeometry
GUIA_DefaultStyle
GUIA_DisabledBrightContrast
GUIA_DisabledBrightCurve
GUIA_DisabledDarkContrast
GUIA_DisabledDarkCurve
GUIA_DRIPens
GUIA_Dummy
GUIA_EvenRequesterButtons
GUIA_FallbackTextAttr
GUIA_FillBrightContrast
GUIA_FillBrightCurve
GUIA_FillDarkContrast
GUIA_FillDarkCurve
GUIA_ForeBrightContrast
GUIA_ForeBrightCurve
GUIA_ForeDarkContrast
GUIA_ForeDarkCurve
GUIA_FrameAlphaStatus
GUIA_FrameBackfill
GUIA_FrameButtonLook
GUIA_FrameCornersType
GUIA_FrameDisabledColors
GUIA_FrameDisBackfill
GUIA_FrameDisplayLook
GUIA_FrameForceThinEdges
GUIA_FramePressedLook
GUIA_FramePropLook
GUIA_FrameSelBackfill
GUIA_FrameSelectedColor
GUIA_FrameStringLook
GUIA_GadgetArrowStyle
GUIA_GadgetArrowType
GUIA_GadgetCycleStyle
GUIA_GadgetCycleType
GUIA_GadgetGeometry
GUIA_GadgetHorizPadding
GUIA_GadgetStyle
GUIA_GadgetTextAttr
GUIA_GadgetVertPadding
GUIA_GaugeLook
GUIA_GlobalFlags
GUIA_GroupLabelLook
GUIA_GroupLabelPlace
GUIA_GroupLabelTextAttr
GUIA_GroupLabelVertAlign
GUIA_InactiveFillBrightContrast
GUIA_InactiveFillBrightCurve
GUIA_InactiveFillDarkContrast
GUIA_InactiveFillDarkCurve
GUIA_LabelTextAttr
GUIA_LayoutHorizSpacing
GUIA_LayoutVertSpacing
GUIA_ListHierConnectType
GUIA_ListHierNodeStyle
GUIA_MenuBackfill
GUIA_MenuBrightContrast
GUIA_MenuBrightCurve
GUIA_MenuCloseDelay
GUIA_MenuDarkContrast
GUIA_MenuDarkCurve
GUIA_MenuDropShadows
GUIA_MenuFlags
GUIA_MenuOpenDelay
GUIA_MenuRenderHook
GUIA_MenuSelItemFrame
GUIA_MenuStyle
GUIA_MenuTransparency
GUIA_MenuTransparencyLevel
GUIA_MenuType
GUIA_OffScreenDragging
GUIA_OffScreenResistance
GUIA_OffScreenSizing
GUIA_PaletteLockTable
GUIA_PaletteRGBTable
GUIA_PropBackfill
GUIA_PropBackground
GUIA_PropBorder
GUIA_PropKnobBackfill
GUIA_PropKnobColor
GUIA_PropKnobHandle
GUIA_PropKnobHighlight
GUIA_PropOuterSpacing
GUIA_PropSelKnobBackfill
GUIA_PropSpacing
GUIA_RealShading
GUIA_RequesterBackfill
GUIA_RequestersPosition
GUIA_Reserved1
GUIA_Reserved2
GUIA_Reserved3
GUIA_Reserved4
GUIA_Reserved5
GUIA_ScreenBarBackfill
GUIA_ScreenBarGadgetSize
GUIA_ScreenBarPadding
GUIA_ScreenBarShadowColor
GUIA_ScreenBarShadowDisplacement
GUIA_ScreenBarShadowSmoothness
GUIA_ScreenBarShadowStrength
GUIA_ScreenDragging
GUIA_ScreenTitlePosition
GUIA_SelectBrightContrast
GUIA_SelectBrightCurve
GUIA_SelectDarkContrast
GUIA_SelectDarkCurve
GUIA_ShareComposeBitMap
GUIA_SizeGadgetHeight
GUIA_SizeGadgetWidth
GUIA_SliderDisplayMode
GUIA_SpecialEffects
GUIA_SysIGeometryType
GUIA_SysImageFrameType
GUIA_SysImageSymbolType
GUIA_TabActiveBackfill
GUIA_TabInactiveBackfill
GUIA_TabTitleBackfill
GUIA_VSyncCompose
GUIA_WindowAlpha
GUIA_WindowBackfill
GUIA_WindowBarBackfill
GUIA_WindowBarFrameThickness
GUIA_WindowBarGadgetSize
GUIA_WindowBarInactBackfill
GUIA_WindowBarPadding
GUIA_WindowBorderBackfill
GUIA_WindowBorderBottom
GUIA_WindowBorderInactBackfill
GUIA_WindowBorderLeft
GUIA_WindowBorderLook
GUIA_WindowBorderRight
GUIA_WindowBorderStyle
GUIA_WindowBorderTop
GUIA_WindowCloseFadeTime
GUIA_WindowDragAlpha
GUIA_WindowFrameThickness
GUIA_WindowGadgetFrameStyle
GUIA_WindowGadgetGeometry
GUIA_WindowGadgetStyle
GUIA_WindowGaugeLook
GUIA_WindowGoActiveFadeTime
GUIA_WindowGoInactiveFadeTime
GUIA_WindowInactAlpha
GUIA_WindowInnerFlatThickness
GUIA_WindowOpenFadeTime
GUIA_WindowOuterFlatThickness
GUIA_WindowPropBackfill
GUIA_WindowPropBackground
GUIA_WindowPropBorder
GUIA_WindowPropInactBackfill
GUIA_WindowPropInactKnobBackfill
GUIA_WindowPropKnobBackfill
GUIA_WindowPropKnobColor
GUIA_WindowPropKnobHandle
GUIA_WindowPropKnobHighlight
GUIA_WindowPropLook
GUIA_WindowPropSelKnobBackfill
GUIA_WindowPropSpacing
GUIA_WindowRefresh
GUIA_WindowReserved
GUIA_WindowShadowColor
GUIA_WindowShadowDisplacement
GUIA_WindowShadowSizes
GUIA_WindowShadowSmoothness
GUIA_WindowShadowStrength
GUIA_WindowShadowType
GUIA_WindowSizeBorder
GUIA_WindowTitlePosition
GUPIMAGE
GVKHANDLEIMAGE
HALFSHADOWPEN
HALFSHINEPEN
HALFTONE_DITHERING | Flag for TPreferences.PrintFlags halftone dithering
HC_GADGETHELP | Flag for HelpControl() Set this flag to enable Gadget-Help for one or more windows.
HIGHBOX | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by "boxing" the selectbox
HIGHCOMP | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, highlight by complementing the selectbox
HIGHFLAGS | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, see definitions below for these bits
HIGHIMAGE | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, use the user's "select image"
HIGHITEM | Flag for TMenuItem.Flags set by intuition (ReadOnly), this item is currently highlighted
HIGHLIGHTTEXTPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. special color text, on background
HIGHNONE | SPECIAL HIGHLIGHT FLAG state meanings for TMenuItem.Flags, don't highlight
HIRESGADGET |
HIRESPICK |
HKHANDLEIMAGE
HP_LASERJET | Value for TPreferences.PrinterType
HP_LASERJET_PLUS | Value for TPreferences.PrinterType
IA_ActivateKey |
IA_APatSize | ImageClass Attribute.
IA_APattern | ImageClass Attribute.
IA_BackFill
IA_BGPen | ImageClass Attribute. IA_BGPen also means "PlaneOnOff"
IA_Data | ImageClass Attribute. bitplanes, for classic image, other image classes may use it for other things
IA_DisabledBackFill
IA_DoubleEmboss | ImageClass Attribute.
IA_Dummy | ImageClass Attributes start.
IA_EdgesOnly | ImageClass Attribute. to specify that the interior of a frame should not be cleared
IA_EraseBackground
IA_FGPen | ImageClass Attribute. IA_FGPen also means "PlanePick"
IA_Font | ImageClass Attribute.
IA_FrameType | SysIClass Attribute. FrameIClass recognizes several standard types of frame.
IA_Height | ImageClass Attribute.
IA_HighlightPen |
IA_InactiveBackFill
IA_InBorder
IA_Justification
IA_Label
IA_LabelPen
IA_Left | ImageClass Attribute.
IA_LineWidth | ImageClass Attribute.
IA_Mode | ImageClass Attribute.
IA_Orientation
IA_Outline | ImageClass Attribute.
IA_Pens | ImageClass Attribute. pointer to Word pens[], ala TDrawInfo.Pens, must be terminated by (not 0). Some classes can choose to have this, or SYSIA_DrawInfo, or both.
IA_Precision |
IA_Recessed | ImageClass Attribute.
IA_Resolution | ImageClass Attribute. packed Words for x/y resolution into a LongWord ala TDrawInfo.Resolution
IA_Scalable |
IA_Screen |
IA_SelectedBackFill
IA_ShadowPen |
IA_Simple
IA_SupportsDisable | SysIClass Attribute. Tell intuition to use IDS_*DISABLED instead of own code
IA_Top | ImageClass Attribute.
IA_Underscore |
IA_Width | ImageClass Attribute.
ICA_Dummy | Interconnection attributes start used by icclass, modelclass and gadgetclass
ICA_MAP | interconnection map tagitem list used by icclass, modelclass and gadgetclass
ICA_TARGET | Interconnection target used by icclass, modelclass and gadgetclass
ICCLASS | Class identifier. Interconnection class
ICM_CHECKLOOP | icclass Method. Set/increment loop
ICM_CLEARLOOP | icclass Method. Clear/decrement loop counter
ICM_Dummy | icclass Methods start
ICM_SETLOOP | icclass Method. Set/increment loop counter
ICONIFYIMAGE
ICSPECIAL_CODE | a "pseudo-attribute" used by icclass, modelclass and gadgetclass
ICTARGET_IDCMP |
ICTRL_Dummy
IDCMP_ACTIVEWINDOW | IDCMP class: Window is activated
IDCMP_CHANGEWINDOW | IDCMP class: Window changed size or position
IDCMP_CLOSEWINDOW | IDCMP class: User pressed close button of window
IDCMP_DELTAMOVE | IDCMP class:
IDCMP_DISKINSERTED | IDCMP class: Floppy disk inserted
IDCMP_DISKREMOVED | IDCMP class: Floppy disk removed
IDCMP_EXTENDEDKEYBOARD
IDCMP_EXTENDEDMOUSE
IDCMP_GADGETDOWN | IDCMP class: user selects a gadget
IDCMP_GADGETHELP | IDCMP class
IDCMP_GADGETUP | IDCMP class: user selects a gadget
IDCMP_IDCMPUPDATE | IDCMP Class: gadget notification
IDCMP_INACTIVEWINDOW | IDCMP class: Window is deactivated
IDCMP_INTUITICKS | IDCMP Class: Time ticks
IDCMP_LONELYMESSAGE | IDCMP class: Private
IDCMP_MENUHELP | IDCMP Class: Help key pressed
IDCMP_MENUPICK | IDCMP class: User opened the menu
IDCMP_MENUVERIFY | IDCMP class: Verify ready to show menu
IDCMP_MOUSEBUTTONS | IDCMP class: Contains reports about mouse button up and down events.
IDCMP_MOUSEMOVE | IDCMP class: Reports about mouse movements
IDCMP_NEWPREFS | IDCMP class: Preferences are changed
IDCMP_NEWSIZE | IDCMP class: User resized the Window
IDCMP_RAWKEY | IDCMP class: Raw keycodes from keyboard
IDCMP_REFRESHWINDOW | IDCMP class: Window needs refreshing
IDCMP_REQCLEAR | IDCMP class: Requester is cleared
IDCMP_REQSET | IDCMP class: Recive message when a requester opens
IDCMP_REQVERIFY | IDCMP class: Verify intuition is ready to render a requester
IDCMP_RESERVED1
IDCMP_RESERVED2
IDCMP_SIZEVERIFY | IDCMP class: resize must be verified by application
IDCMP_VANILLAKEY | IDCMP class: keyboard events
IDCMP_WBENCHMESSAGE | IDCMP class: private
IDOMAIN_MAXIMUM |
IDOMAIN_MINIMUM |
IDOMAIN_NOMINAL |
IDSF_DISABLED
IDSF_DISABLEDMASK
IDSF_ERASEMASK
IDSF_INACTIVENORMAL
IDSF_INACTIVESELECTED
IDSF_MASK
IDSF_NORMAL
IDSF_SELDISABLEDMASK
IDSF_SELECTED
IDSF_SELECTEDDISABLED
IDS_BUSY | Image draw style for IM_DRAW for future functionality
IDS_DISABLED | Image draw state for IM_DRAW for disabled gadgets
IDS_INACTIVEDISABLED | Image draw style for IM_DRAW disabled, in inactive border
IDS_INACTIVENORMAL | Image draw style for IM_DRAW normal, in inactive window border
IDS_INACTIVESELECTED | Image draw style for IM_DRAW selected, in inactive border
IDS_INDETERMINANT |
IDS_INDETERMINATE | Image draw style for IM_DRAW for future functionality
IDS_NORMAL | Image draw style for IM_DRAW
IDS_SELECTED | Image draw state for IM_DRAW for selected gadgets
IDS_SELECTEDDISABLED | Image draw style for IM_DRAW disabled and selected
IEXTENT_ADD
IEXTENT_INVERT
IEXTENT_REMOVE
IEXTENT_SECT
IGF_BRCORN
IGF_HORIZARROW
IGF_KEEPHEIGHT
IGF_KEEPLEFT
IGF_KEEPTOP
IGF_KEEPWIDTH
IGF_SBARLEFT
IGF_SBARRIGHT
IGF_VERTARROW
IGF_WBARLEFT
IGF_WBARRIGHT
IGNORE_DIMENSIONS | Flag for TPreferences.PrintFlags ignore max width/height settings
IJ_CENTER
IJ_LEFT
IJ_RIGHT
IMAGECLASS | Class identifier. This class is the base class for Boopsi Images.
IMAGE_NEGATIVE | Value for TPreferences.PrintImage
IMAGE_POSITIVE | Value for TPreferences.PrintImage
IMPF_ALLOWSUPER
IMR_CLIPDONE
IMR_INVALID
IMR_MASKDONE
IMSGCODE_INTUIRAWKEYDATA
IMSGCODE_INTUIWHEELDATA
IMTAG_Dummy
IMTAG_MenuContext
IMTAG_MenuType
IMT_CONTEXT_GADGET_APP
IMT_CONTEXT_GADGET_OBJ
IMT_CONTEXT_WINDOW
IMT_DEFAULT
IM_DOMAINFRAME |
IM_DRAW | imageclass message id. draw yourself, with "state" (IDS_*)
IM_DRAWFRAME | imageclass message id. draw with specified dimensions
IM_ERASE | imageclass message id. erase yourself
IM_ERASEFRAME | imageclass message id. hittest with dimensions
IM_EXTENT
IM_EXTENTFRAME
IM_FRAMEBOX | imageclass message id. get recommended frame around some box
IM_HITFRAME | imageclass message id. hittest with dimensions
IM_HITTEST | imageclass message id. return True if click hits image
IM_MOVE | imageclass message id. draw new and erase old, smoothly
INACTIVEFILLFLATPEN
INACTIVEFILLPEN
INACTIVEFILLSHADOWPEN
INACTIVEFILLSHINEPEN
INACTIVEFILLTEXTPEN
INACTIVEGLYPHPEN
INTEGER_SCALING | Flag for TPreferences.PrintFlags force integer scaling
INTUIRAWKEYDATA_VERSION
INTUITIONNAME
INTUIWHEELDATA_VERSION
ISDRAWN | Flag for TMenuItem.Flags set by intuition (ReadOnly), this item's subs are currently drawn
ITEMENABLED | Flag for TMenuItem.Flags set by the Application, set if this item is enabled
ITEMTEXT | Flag for TMenuItem.Flags set by the Application, set if textual, clear if graphical item
ITEXTICLASS | Class identifier. A specialized image class used for rendering text.
KEYCODE_B | RawKeycode for TIntuiMessage.Code. 'b' key pressed.
KEYCODE_GREATER | RawKeycode for TIntuiMessage.Code. '>' key pressed.
KEYCODE_LESS | RawKeycode for TIntuiMessage.Code. '<' key pressed.
KEYCODE_M | RawKeycode for TIntuiMessage.Code. 'm' key pressed.
KEYCODE_N | RawKeycode for TIntuiMessage.Code. 'n' key pressed.
KEYCODE_Q | RawKeycode for TIntuiMessage.Code. 'q' key pressed.
KEYCODE_V | RawKeycode for TIntuiMessage.Code. 'v' key pressed.
KEYCODE_X | RawKeycode for TIntuiMessage.Code. 'x' key pressed.
KNOBHIT | Flag value for TPropInfo.Flags. set when this Knob is hit
KNOBHMIN | Minimum horizontal size of the Knop
KNOBVMIN | minimum vertical size of the Knop
LACEWB | Interlace define for TPreferences.LaceWB
LAYOUTA_ChildMaxHeight | GadgetClass Layout Tag. (LongBool) Child objects are of equal height. Should default to True for gadgets with a vertical orientation.
LAYOUTA_ChildMaxWidth | GadgetClass Layout Tag. (LongBool) Child objects are of equal width. Should default to True for gadgets with a horizontal orientation.
LAYOUTA_Dummy | GadgetClass Layout start Tag.
LAYOUTA_LayoutObj | GadgetClass Layout Tag.
LAYOUTA_Orientation | GadgetClass Layout Tag. (LongInt) Orientation LORIENT_*
LAYOUTA_Spacing | GadgetClass Layout Tag.
LEFTIMAGE | SYSIA_Which tag data values. Left-arrow gadget image
LETTER | Value for TPreferences.PrintQuality
LEVEL_BRIGHT
LEVEL_DARK
LEVEL_HALFBRIGHT
LEVEL_HALFDARK
LEVEL_NORMAL
LORIENT_HORIZ | Orientation values for LAYOUTA_Orientation
LORIENT_NONE | Orientation values for LAYOUTA_Orientation
LORIENT_VERT | Orientation values for LAYOUTA_Orientation
LOWCHECKWIDTH | Define for CHECKIT width for the CheckMark (Low res resolution) in a menu item
LOWCOMMWIDTH | Define for COMMSEQ width for the Command sequence (Low resolution) in a menu item
LOWRESGADGET |
LOWRESPICK |
LW_RESERVED | internal use only for TPreferences.LaceWB
MAXBODY | Maximum body value in TPropInfo
MAXPOT | Maximum pot value in TPropInfo
MAXPUBSCREENNAME | Maximum length of public screen names. The buffers containing these strings must have a length of MAXPUBSCREENNAME + 1.
MA_AddChild
MA_Catalog
MA_CharSet
MA_Disabled
MA_Dummy
MA_EmbeddedKey
MA_ErrorCode
MA_ErrorTagItem
MA_EvenSize
MA_FreeImage
MA_HelpHook
MA_Hidden
MA_ID
MA_Image
MA_Key
MA_Label
MA_LastSelected
MA_Level
MA_MaxStringID
MA_MenuHelpID
MA_MenuPosX
MA_MenuPosY
MA_MinStringID
MA_MX
MA_Parent
MA_PickHook
MA_RemoveChild
MA_Selected
MA_Separator
MA_StringHook
MA_TextAttr
MA_Toggle
MA_Type
MA_UserData
MENUALTERN
MENUBACKGROUNDPEN
MENUCANCEL | Code for IDCMP_MENUVERIFY HOT Reply of this cancels Menu operation
MENUCHECK | SYSIA_Which tag data values. Menu checkmark image
MENUCMCORNER
MENUDOWN | RawMouse code for TIntuiMessage.Code. Right Mouse Button down.
MENUENABLED | Flag for TMenu.Flags, whether or not this menu is enabled
MENUFLAT
MENUFRAMED
MENUHOT | Code for IDCMP_MENUVERIFY Intuition wants verification or MENUCANCEL
MENUMX
MENUNBPD
MENUNBPU
MENUNULL |
MENUPDTCLDEL
MENUPDTOPDEL
MENUSHADOW
MENUSHADOWPEN
MENUSHINEPEN
MENUSTICKYPD
MENUSTICKYPU
MENUSUB
MENUTEXTPEN
MENUTOGGLE | Flag for TMenuItem.Flags set by the Application, set to toggle the check of a menu item
MENUTOGGLED | Flag for TMenuItem.Flags set by intuition (ReadOnly), this item was already toggled
MENUTRACK
MENUTRANSP
MENUUP | RawMouse code for TIntuiMessage.Code. Right Mouse Button up.
MENUWAITING | Code for IDCMP_MENUVERIFY Intuition simply wants a ReplyMsg() ASAP
MIDDLEDOWN | RawMouse code for TIntuiMessage.Code. Middle Mouse Button down.
MIDDLEUP | RawMouse code for TIntuiMessage.Code. Middle Mouse Button up.
ML_SEPARATOR
MM_CLEANUP
MM_DELETEMENU
MM_FINDID
MM_GETSTATE
MM_HANDLEHELP
MM_HANDLEPICK
MM_NEWMENU
MM_NEXTCHILD
MM_NEXTSELECT
MM_SCAN
MM_SETSTATE
MM_SETUP
MODELCLASS | Class identifier. Multiple Targets
MOUSE_ACCEL
MS_CHECKED
MS_DISABLED
MT_POPUP
MT_PULLDOWN
MT_RELATIVE
MULTIPLY_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as multipliers
MXIMAGE | SYSIA_Which tag data values. GadTools mutual exclude "button" image
NM_Dummy
NM_Item
NM_Menu
NM_SubItems
NOISYREQ | Flag for TRequester.Flags. Requester does not filter input.
NOITEM |
NOMENU |
NOREQBACKFILL | Flag for TRequester.Flags. Don't bother filling requester with TRequester.BackFill pen
NOSUB |
NO_MENU_ID
NSCODE_FINAL
NSCODE_INTERIM
NSTAG_EXT_VPMODE | this is an obsolete tag included only for compatibility with V35 interim release for the A2024 and Viking monitors
NS_EXTENDED | Flag for TScreen.Flags. TExtNewScreen.Extension is valid
NUMDRIPENS | Rendering pen number indexes into TDrawInfo.dri_Pens.
N_TRACTOR | Value for TPreferences.PaperSize
OKABORT | Internal token to represent state of verification attempts shown here as a clue. window rendered question moot
OKCANCEL | Internal token to represent state of verification attempts shown here as a clue. window sent cancel reply
OKIMATE_20 | Value for TPreferences.PrinterType
OKOK | Internal token to represent state of verification attempts shown here as a clue. guy didn't care
OM_ADDMEMBER | This method tells an object to add an object to its broadcast list.
OM_ADDTAIL | This method tells an object to add itself to the end of an Exec list.
OM_DISPOSE | This method tells an object to dispose of itself.
OM_Dummy | Start of dispatched method ID's
OM_GET | This method tells an object to report an attribute value.
OM_NEW | This method creates a new object.
OM_NOTIFY | This method tells an object to broadcast an attribute change to its broadcast list.
OM_REMMEMBER | This method tells an object to remove an object from its broadcast list.
OM_REMOVE | This method tells an object to remove itself from an Exec list.
OM_SET | This method tells an object to set one or more of its attribute values.
OM_UPDATE | This method tells an object to update one or more of its attribute values.
OPUF_INTERIM | Flag for TopUpdate.opu_Flags
ORDERED_DITHERING | Flag for TPreferences.PrintFlags ordered dithering
OSCAN_MAX | Identifier for SA_Overscan as much as possible
OSCAN_STANDARD | Identifier for SA_Overscan just past edges
OSCAN_TEXT | Identifier for SA_Overscan entirely visible
OSCAN_VIDEO | Identifier for SA_Overscan even more than is possible
OSERR_ATTACHFAIL
OSERR_BADBITMAP
OSERR_NOCHIPMEM | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get chipmem
OSERR_NOCHIPS | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode You need newer custom chips
OSERR_NOMEM | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get normal memory
OSERR_NOMONITOR | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Named monitor spec not available
OSERR_NOTAVAILABLE
OSERR_PUBNOTUNIQUE | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Public screen name already used
OSERR_TOODEEP
OSERR_UNKNOWNMODE | Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Don't recognize mode asked for
PADLOCKIMAGE
PALETTELOCK_IGNORE
PALETTERGB_IGNORE
PARALLEL_PRINTER | Value for TPreferences.PrinterPort
PA_INTERNAL
PENSHARED | Flag for TScreen.Flags. Screen opener set (SA_SharePens,True)
PEN_ALPHA
PEN_ALPHASHADOW
PEN_ALPHASHINE
PEN_BRIGHT
PEN_C0 | Complement of color 0
PEN_C1 | Complement of color 1
PEN_C2 | Complement of color 2
PEN_C3 | Complement of color 3
PEN_DARK
PEN_HALFBRIGHT
PEN_HALFDARK
PGA_ArrowDelta
PGA_ArrowDown
PGA_Borderless | PropGClass Tag. (LongBool) If set, no border will be rendered.
PGA_Dummy | PropGClass Start Tag.
PGA_Freedom | PropGClass Tag. [IS.] (LongWord) Define in which the direction gadget should stretch.
PGA_HorizBody | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_HorizPot | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_NewLook | PropGClass Tag. [IS.] (LongBool) If set, this indicated that the new look should be used for rendering.
PGA_Top | PropGClass Tag. [ISG] (Word) The first visible position.
PGA_Total | PropGClass Tag. [IS.] (Word) The total number of positions in the gadget.
PGA_VertBody | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_VertPot | PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.
PGA_Visible | PropGClass Tag. [IS.] (Word) The number of visible positions in the gadget.
PICA | Value for TPreferences.PrintPitch
PIXEL_DIMENSIONS | Flag for TPreferences.PrintFlags use max width/height as prt pixels
PLUGIN_SYSI
POINTERA_BitMap | PointerClass Attribute. (PBitmap) Pointer to bitmap to get pointer imagery from. Bitplane data need not be in chip RAM.
POINTERA_Dummy | PointerClass Attributes start.
POINTERA_Height
POINTERA_ImageData
POINTERA_Width
POINTERA_WordWidth | PointerClass Attribute. (LongWord) - designed width of the pointer in words
POINTERA_XOffset | PointerClass Attribute. (LongInt) - X-offset of the pointer hotspot.
POINTERA_XResolution | PointerClass Attribute. (LongWord) - one of the POINTERXRESN_* flags
POINTERA_YOffset | PointerClass Attribute. (LongInt) - Y-offset of the pointer hotspot.
POINTERA_YResolution | PointerClass Attribute. (LongWord) - one of the POINTERYRESN_* flags
POINTERCLASS | Class identifier
POINTERSIZE | Size of Pointer data buffer for printer configuration
POINTERTYPE_ALIAS
POINTERTYPE_BUSY
POINTERTYPE_CELL
POINTERTYPE_COLUMNRESIZE
POINTERTYPE_CONTEXTMENU
POINTERTYPE_COPY
POINTERTYPE_COUNT
POINTERTYPE_CROSS
POINTERTYPE_DRAGANDDROP
POINTERTYPE_EASTRESIZE
POINTERTYPE_EASTWESTRESIZE
POINTERTYPE_HAND
POINTERTYPE_HELP
POINTERTYPE_LINK
POINTERTYPE_MENU
POINTERTYPE_NODROP
POINTERTYPE_NONE
POINTERTYPE_NORMAL
POINTERTYPE_NORTHEASTRESIZE
POINTERTYPE_NORTHEASTSOUTHWESTRESIZE
POINTERTYPE_NORTHRESIZE
POINTERTYPE_NORTHSOUTHRESIZE
POINTERTYPE_NORTHWESTRESIZE
POINTERTYPE_NORTHWESTSOUTHEASTRESIZE
POINTERTYPE_NOTALLOWED
POINTERTYPE_PEN
POINTERTYPE_PROGRESS
POINTERTYPE_ROTATE
POINTERTYPE_ROWRESIZE
POINTERTYPE_RUBBER
POINTERTYPE_SCROLLALL
POINTERTYPE_SELECT
POINTERTYPE_SMUDGE
POINTERTYPE_SOUTHEASTRESIZE
POINTERTYPE_SOUTHRESIZE
POINTERTYPE_SOUTHWESTRESIZE
POINTERTYPE_TEXT
POINTERTYPE_VERTICALTEXT
POINTERTYPE_WESTRESIZE
POINTERTYPE_ZOOMIN
POINTERTYPE_ZOOMOUT
POINTERXRESN_140NS | Value for POINTERA_XResolution (pointer always in 140 ns pixels) = 140 ns always
POINTERXRESN_35NS | Value for POINTERA_XResolution (pointer always in 35 ns pixels) = 35 ns always
POINTERXRESN_70NS | Value for POINTERA_XResolution (pointer always in 70 ns pixels) = 70 ns always
POINTERXRESN_DEFAULT | Value for POINTERA_XResolution (ECS-compatible pointer width) = 70 ns if SUPERHIRES-type mode, 140 ns if not
POINTERXRESN_HIRES | Value for POINTERA_XResolution (pointer always in hires-like pixels) = 70 ns in 15kHz modes, 35 ns in 31kHz modes
POINTERXRESN_LORES | Value for POINTERA_XResolution (pointer always in lores-like pixels) = 140 ns in 15kHz modes, 70 ns in 31kHz modes
POINTERXRESN_SCREENRES | Value for POINTERA_XResolution Same as pixel speed of screen
POINTERYRESN_DEFAULT | Value for POINTERA_YResolution Default pointer
POINTERYRESN_HIGH | Value for POINTERA_YResolution Highres pointer
POINTERYRESN_HIGHASPECT | Value for POINTERA_YResolution Highres pointer
POINTERYRESN_SCREENRES | Value for POINTERA_YResolution Highres pointer
POINTERYRESN_SCREENRESASPECT | Value for POINTERA_YResolution Highres pointer
POINTREL | Flag for TRequester.Flags. If set TopLeft is relative to pointer to the coordinates of either the pointer or the window.
POPPUBSCREEN | Pub screen mode. pop pub screen to front when visitor opens
POPUPIMAGE
PREDRAWN | Flag for TRequester.Flags. If set, ImageBMap points to a custom bitmap.
PROPBORDERLESS | Flag value for TPropInfo.Flags. if set, no border will be rendered
PROPGCLASS | Class identifier. An easy to implement, horizontal or vertical proportional gadget.
PROPNEWLOOK | Flag value for TPropInfo.Flags. set this if you want to get the new look
PSNF_PRIVATE | Flag for TPubScreenNode.psn_Flags Private
PUBLICSCREEN_F | Screentype flag for TScreen.Flags and TNewScreen.SType.
QUME_LP_20 | Value for TPreferences.PrinterType
RCB_OK
RCB_UNKNOWN
RECOVERY_ALERT | Alert Type for DisplayAlert() the system can recover from this
REQACTIVE | Flag for TRequester.Flags. Read-Only. This requester is active
REQOFFWINDOW | Flag for TRequester.Flags. Read-Only. Part of one of the Gadgets was offwindow
REQPOS_BELOWBAR
REQPOS_CENTERMOUSE
REQPOS_CENTERSCREEN
REQPOS_CENTERWINDOW
REQPOS_CORNER
REQPOS_DEFAULT
RESCOUNT |
RESERVEDPEN
RIGHTIMAGE | SYSIA_Which tag data values. Right-arrow gadget image
ROOTCLASS | Root Class identifier, This is the universal base class for all other classes.
SA_ActiveWindow
SA_AutoScroll | Tag start for OpenScreenTagList() boolean equivalent to flag AUTOSCROLL
SA_BackChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the back of its family.
SA_BackFill | Tag start for OpenScreenTagList() provides a "backfill hook" for your screen's TLayer_Info. See Layers.InstallLayerInfoHook()
SA_Behind | Tag start for OpenScreenTagList() boolean equivalent to flag SCREENBEHIND_f
SA_BitMap | Tag start for OpenScreenTagList() ti_Data is pointer to custom BitMap. This implies TNewScreen.SType of CUSTOMBITMAP_f
SA_BlockPen | Tag start for OpenScreenTagList() serves as default for windows, too
SA_ColorMapEntries | Tag start for OpenScreenTagList() Allows you to override the number of entries in the ColorMap for your screen.
SA_Colors | Tag start for OpenScreenTagList() ti_Data is an array of TColorSpec, terminated by ColorIndex = -1. Specifies initial screen palette colors.
SA_Colors32 | Tag start for OpenScreenTagList() set the screen's initial palette colors at 32 bits-per-gun.
SA_Compositing
SA_DClip | Tag start for OpenScreenTagList() ti_Data points to a rectangle which defines screen display clip region
SA_Depth | Tag start for OpenScreenTagList() Screen bitmap depth
SA_DetailPen | Tag start for OpenScreenTagList() serves as default for windows, too
SA_DisplayID | Tag start for OpenScreenTagList() ti_Data is new extended display ID
SA_Draggable | Tag start for OpenScreenTagList() Boolean tag allowing non-draggable screens. Do not use without good reason! (Defaults to True).
SA_Dummy | Tag start for OpenScreenTagList() Tags
SA_ErrorCode | Tag start for OpenScreenTagList() ti_Data points to LongInt error code
SA_Exclusive | Tag start for OpenScreenTagList() Boolean tag allowing screens that won't share the display. (Defaults to False)
SA_Font | Tag start for OpenScreenTagList() equiv. to TNewScreen.Font
SA_FrontChild | Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the front of its family.
SA_FullPalette | Tag start for OpenScreenTagList() boolean: initialize color table to entire preferences palette, rather than compatible pens 0-3, 17-19, with remaining palette as returned by GetColorMap()
SA_Height | Tag start for OpenScreenTagList() eqivalent to TNewWindow.Height
SA_Interleaved | Tag start for OpenScreenTagList() Boolean tag requesting that the bitmap allocated for you be interleaved. (Defaults to False).
SA_Left | Tag start for OpenScreenTagList() eqivalent to TNewWindow.LeftEdge
SA_LikeWorkbench | Tag start for OpenScreenTagList() 1 = request a screen which is just like the Workbench. This gives you the same screen mode, depth, size, colors, etc., as the Workbench screen.
SA_MaxWindowBox
SA_MinimizeISG | Tag start for OpenScreenTagList() inter-screen gap is at least three non-interlaced lines
SA_Obsolete1 |
SA_OffScreenDragging
SA_Overscan | Tag start for OpenScreenTagList() Set Overscan defaults to OSCAN_TEXT
SA_Parent | Tag start for OpenScreenTagList() Pointer to a "parent" screen to attach this one to. Attached screens slide and depth-arrange together.
SA_Pens | Tag start for OpenScreenTagList() pointer to $FFFFFFFF terminated LongWord array, as found in TDrawInfo
SA_PubName | Tag start for OpenScreenTagList() Presence of this tag means that the screen is to be a public screen. Please specify before SA_PubSig and SA_PubTask
SA_PubSig | Tag start for OpenScreenTagList()
SA_PubTask | Tag start for OpenScreenTagList() Task ID and signal for being notified that the last window has closed on a public screen.
SA_Quiet | Tag start for OpenScreenTagList() boolean equivalent to flag SCREENQUIET_f
SA_Reserved | Tag start for OpenScreenTagList() Reserved for private Intuition use
SA_Reserved2
SA_Reserved3
SA_SharePens | Tag start for OpenScreenTagList() Allocate pens as shared
SA_ShowTitle | Tag start for OpenScreenTagList() boolean equivalent to flag SHOWTITLE
SA_SysFont | Tag start for OpenScreenTagList() Selects one of the preferences system fonts: 0 - old DefaultFont, fixed-width 1 - WB Screen preferred font
SA_Title | Tag start for OpenScreenTagList() default screen title
SA_Top | Tag start for OpenScreenTagList() eqivalent to TNewWindow.TopEdge
SA_Type | Tag start for OpenScreenTagList() equiv. to TNewScreen.SType
SA_VideoControl | Tag start for OpenScreenTagList() Pointer to a taglist that Intuition will pass to VideoControl(), upon opening the screen.
SA_Width | Tag start for OpenScreenTagList() eqivalent to TNewWindow.Width
SA_WindowDropShadows
SBARLOGO
SBUFSIZE_BITS | Mask for TPreferences.SerStopBuf lower nibble
SBUF_1024 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_16000 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_2048 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_4096 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_512 | Value for TPreferences.SerStopBuf Lower Nibble
SBUF_8000 | Value for TPreferences.SerStopBuf Lower Nibble
SB_COPY_BITMAP | Flag for AllocScreenBuffer().
SB_SCREEN_BITMAP | Flag for AllocScreenBuffer().
SCLOSEIMAGE
SCREENBEHIND_F | Flag for TScreen.Flags. If you want your screen to open behind already open screens
SCREENHIRES | Flag for TScreen.Flags. Do no use lowres gadgets (private)
SCREENQUIET_F | Flag for TScreen.Flags. If you do not want Intuition to render into your screen (gadgets, title)
SCREENSIMAGE
SCREENTYPE_F | Screentype flag for TScreen.Flags and TNewScreen.SType. All Screenstypes available
SCREEN_DRAG
SCROLLERGCLASS
SC_ARROWGSTYLE
SC_CYCLEGSTYLE
SC_GADGETGEOMETRY
SC_GADGETSTYLE
SC_GLOBALGEOMETRY
SC_GLOBALSTYLE
SC_KHANDLESTYLE
SC_MENUSTYLE
SC_WINBFRAMESTYLE
SC_WINBGADGEOMETRY
SC_WINBGADSTYLE
SC_WINBORDERSTYLE
SDEPTHIMAGE | SYSIA_Which tag data values. Screen depth gadget image
SDEPTH_CHILDONLY |
SDEPTH_INFAMILY | Flag for ScreenDepth(). Move an attached screen with respect to other screens of its family
SDEPTH_TOBACK | Flag for ScreenDepth(). Send screen to back
SDEPTH_TOFRONT | Flag for ScreenDepth(). Bring screen to front
SDOWNBACKGADGET |
SDRAGGADGET |
SELECTDOWN | RawMouse code for TIntuiMessage.Code. Left Mouse Button down.
SELECTPEN
SELECTSHADOWPEN
SELECTSHINEPEN
SELECTTEXTPEN
SELECTUP | RawMouse code for TIntuiMessage.Code. Left Mouse Button up.
SERIAL_PRINTER | Value for TPreferences.PrinterPort
SETTINGSIMAGE
SGA_BEEP | String Gadget Action Flag in TSGWork.Actions flash the screen for the user
SGA_END | String Gadget Action Flag in TSGWork.Actions terminate gadget, code in Code field
SGA_NEXTACTIVE | String Gadget Action Flag in TSGWork.Actions Make next possible gadget active.
SGA_PREVACTIVE | String Gadget Action Flag in TSGWork.Actions Make previous possible gadget active.
SGA_REDISPLAY | String Gadget Action Flag in TSGWork.Actions gadget visuals changed
SGA_REUSE | String Gadget Action Flag in TSGWork.Actions reuse input event
SGA_USE | String Gadget Action Flag in TSGWork.Actions use contents of TSGWork
SGH_CLICK | Function id for only existing custom string gadget edit hook. process mouse click cursor position
SGH_KEY | Function id for only existing custom string gadget edit hook. process editing keystroke
SGM_CONTROL | Internal Mode for TSGWork.Mode control char escape mode
SGM_EXITHELP | Mode for TSGWork.Mode exit with code = $5F if help hit
SGM_FIXEDFIELD | Mode for TSGWork.Mode fixed length buffer always set SGM_REPLACE, too
SGM_LONGINT | Internal Mode for TSGWork.Mode an intuition LongInt gadget
SGM_NOCHANGE | Internal Mode for TSGWork.Mode no edit changes yet
SGM_NOFILTER | Mode for TSGWork.Mode don't filter control chars
SGM_NOWORKB | Internal Mode for TSGWork.Mode Buffer = PrevBuffer
SGM_REPLACE | Mode for TSGWork.Mode replace mode please initialize StringInfo with in-range value of BufferPos if you are using SGM_REPLACE mode.
SG_DEFAULTMAXCHARS | Maximal length of text in StrgClass, if STRINGA_MaxChars is not set.
SG_GADGETBOX
SG_IMAGEBOX
SHADE_BW | Value for TPreferences.PrintShade
SHADE_COLOR | Value for TPreferences.PrintShade
SHADE_GREYSCALE | Value for TPreferences.PrintShade
SHADOWPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. dark edge on 3D objects
SHANGHAI | Pub Screen mode. put workbench windows on pub screen
SHINEPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. bright edge on 3D objects
SHOWTITLE_F | Flag for TScreen.Flags. This gets set by a call to ShowTitle()
SHSHAKE_BITS | Mask for TPreferences.SerParShk Lower nibble
SHSHAKE_NONE | Serial Handshake Mode TPreferences.SerParShk (lower nibble)
SHSHAKE_RTS | Serial Handshake Mode TPreferences.SerParShk (lower nibble)
SHSHAKE_XON | Serial Handshake Mode TPreferences.SerParShk (lower nibble
SIMPLEREQ | Flag for TRequester.Flags. If set, a SIMPLEREFRESH layer is used.
SINGLE_PT |
SIX_LPI | Value for TPreferences.PrintSpacing
SIZEGADGET |
SIZEIMAGE | SYSIA_Which tag data values. Window sizing gadget image
SI_BEGIN
SI_END
SI_HPROPBACKGROUND
SI_VPROPBACKGROUND
SMA_Draw
SMA_GetScrollerTop
SMA_RedrawAll
SMA_RepairDamage
SMA_Scroll
SNAPSHOTIMAGE
SNA_Hook
SNA_MsgPort
SNA_Notify
SNA_Priority
SNA_PubName
SNA_SigBit
SNA_SigTask
SNA_UserData
SNOTIFY_AFTER_CLOSESCREEN
SNOTIFY_AFTER_CLOSEWB
SNOTIFY_AFTER_CLOSEWINDOW
SNOTIFY_AFTER_OPENSCREEN
SNOTIFY_AFTER_OPENWB
SNOTIFY_AFTER_OPENWINDOW
SNOTIFY_BEFORE_CLOSESCREEN
SNOTIFY_BEFORE_CLOSEWB
SNOTIFY_BEFORE_CLOSEWINDOW
SNOTIFY_BEFORE_OPENSCREEN
SNOTIFY_BEFORE_OPENWB
SNOTIFY_BEFORE_OPENWINDOW
SNOTIFY_LOCKPUBSCREEN
SNOTIFY_PUBSCREENSTATE
SNOTIFY_SCREENDEPTH
SNOTIFY_UNLOCKPUBSCREEN
SNOTIFY_WAIT_REPLY
SORTASCIMAGE
SORTDESIMAGE
SPARITY_BITS | Mask for TPreferences.SerParShk upper nibble
SPARITY_EVEN | Serial Parity TPreferences.SerParShk (upper nibble)
SPARITY_NONE | Serial Parity TPreferences.SerParShk (upper nibble)
SPARITY_ODD | Serial Parity TPreferences.SerParShk (upper nibble)
SPA_GADGETGEOMETRY
SPA_GADGETSTYLE
SPA_MENUSTYLE
SPA_WINBFRAMESTYLE
SPA_WINBGADGEOMETRY
SPA_WINBGADSTYLE
SPA_WINBORDERSTYLE
SPOS_ABSOLUTE | Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the absolute coordinates you wish to move the screen to. Coordinates are expressed as absolutes, not relatives.
SPOS_FORCEDRAG | Flag for ScreenPosition(). Move non-draggable screen, You may additionally set SPOS_FORCEDRAG along with any of the above. Set this if you wish to reposition an [SA_Draggable, False] screen that you opened.
SPOS_MAKEVISIBLE | Flag for ScreenPosition(). Coordinates describe a box on the screen you wish to be made visible by autoscrolling (x1,y1)-(x2,y2) describes a rectangle on the screen which you would like autoscrolled into view.
SPOS_RELATIVE | Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the offset in coordinates you wish to move the screen by. Coordinates are relative
SRA_DeltaX
SRA_DeltaY
SRA_DirectShade
SRA_Domain
SRA_Dummy
SRA_OffsetX
SRA_OffsetY
SRA_RefreshBG
SREAD_BITS | Mask for TPreferences.SerRWBits Upper nibble
SRF_HSCROLLERFRAME
SRF_ISBITMAP
SRF_MONOCHROME
SRF_VSCROLLERFRAME
SR_DRAW
SR_DRAWALPHAMAP
SR_DRAWDISMASK
SR_DRAWIMAGEFRAME
SR_DRAWLEVELMAP
SR_DRAWMASK
SR_DRAWSELDISMASK
SR_DRAWSHADOWMAP
SR_DRAWSHINEMAP
SSTOP_BITS | Mask for TPreferences.SerStopBuf Upper nibble
STDSCREENHEIGHT | Supply in TNewScreen.Height Set Hight to standard height
STDSCREENWIDTH | Supply in TNewScreen.Width Set Hight to standard width
STD_DISABLE_CONTRAST
STRGCLASS | Class identifier. A string gadget.
STRINGA_ActivePens | StrgClass Tag. [IS.] (LongInt) Like STRINGA_Pens. These pens are used, if the gadget is active.
STRINGA_AltKeyMap | StrgClass Tag. [IS.] (PKeyMap) KeyMap to use
STRINGA_Buffer | StrgClass Tag. [I..] (STRPTR) Buffer for storing the current string of the gadget.
STRINGA_BufferPos | StrgClass Tag. [IS.] (SmallInt) Current position of cursor (relative to the beginning of the buffer).
STRINGA_DispPos | StrgClass Tag. [IS.] (SmallInt) FIXME
STRINGA_Dummy | StrgClass Start Tag.
STRINGA_EditHook | StrgClass Tag. [I..] (PHook) FIXME
STRINGA_EditModes | StrgClass Tag. [IS.] (LongWord) FIXME
STRINGA_ExitHelp | StrgClass Tag. [IS.] (LongBool) If this is set, pressing the "Help" key, while the gadget is active, will unselect the gadget.
STRINGA_FixedFieldMode | StrgClass Tag. [IS.] (LongBool) FIXME
STRINGA_Font | StrgClass Tag. [IS.] (PTextFont) Font to use for displaying the string
STRINGA_Justification | StrgClass Tag. [IS.] (Word) Where should the text be justified?
STRINGA_LongVal | StrgClass Tag. [ISG] (LongInt) If this is set, the string gadget will only accept numeric values.
STRINGA_MarkedBlock
STRINGA_MaxChars | StrgClass Tag. [I..] (SmallInt) Maximum number of characters the string gadget accepts. Default SG_DEFAULTMAXCHARS.
STRINGA_NoFilterMode | StrgClass Tag. [IS.] (LongBool) FIXME
STRINGA_Pens | StrgClass Tag. [IS.] (LongInt) The lower 16 bits specify the background-pen, the upper 16 bits the foreground-pen. The gadget is rendered, using these pens, if the gadget is inactive
STRINGA_ReplaceMode | StrgClass Tag. [IS.] (LongBool) If this is True, the current character is overwritten, if the use presses a key. Otherwise, the new character is inserted.
STRINGA_TextVal | StrgClass Tag. [ISG] (STRPTR) If this is set, the string gadget will accept strings.
STRINGA_UndoBuffer | StrgClass Tag. [I..] (STRPTR) Buffer for storing the old (undo) string of the gadget.
STRINGA_WorkBuffer | StrgClass Tag. [I..] (STRPTR) Buffer for the class to work with.
SUBMENU
SUPFRONTGADGET |
SWRITE_BITS | Mask for TPreferences.SerRWBits Lower nibble
SYSIA_BitMapCache
SYSIA_ContentsBox
SYSIA_Depth | SysIClass Attribute.
SYSIA_DrawInfo | SysIClass Attribute. Must be specified
SYSIA_FullFrame
SYSIA_Label
SYSIA_Pens |
SYSIA_ReferenceFont | SysIClass Attribute. Font to use as reference for scaling certain sysiclass images
SYSIA_RenderHook
SYSIA_Size | SysIClass Attribute. SYSISIZE_*
SYSIA_VectorInfo
SYSIA_Which | SysIClass Attribute. System image identifier
SYSICLASS | Class identifier. The class of system images. The class includes the images for the system and GadTools gadgets.
SYSISIZE_HIRES | Data value for SYSIA_Size
SYSISIZE_LOWRES | Data value for SYSIA_Size
SYSISIZE_MEDRES | Data value for SYSIA_Size
SYSREQUEST | Flag for TRequester.Flags. Read-Only. This requester caused by system
TABLETA_AngleX | Tag for TTabletData.td_TagList. The angle of rotation or tilt about the X-axis.
TABLETA_AngleY | Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Y-axis.
TABLETA_AngleZ | Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Z axis.
TABLETA_ButtonBits | Tag for TTabletData.td_TagList. Button States
TABLETA_Dummy | Tablet Tag Base
TABLETA_InProximity | Tag for TTabletData.td_TagList. For tablets that support proximity,
TABLETA_Pressure | Tag for TTabletData.td_TagList. The pressure reading of the stylus.
TABLETA_RangeZ | Tag for TTabletData.td_TagList. The maximum value of the tablet in the Z direction.
TABLETA_ResolutionX | Tag for TTabletData.td_TagList. X-axis resolution
TABLETA_ResolutionY | Tag for TTabletData.td_TagList. Y-axis resolution
TABLETA_TabletZ | Tag for TTabletData.td_TagList. The current value of the tablet in the Z direction.
TBFRAMEIMAGE
TEXTPEN | Rendering pen number indexes into TDrawInfo.dri_Pens. text on background
TITLEPEN
TOPAZ_EIGHTY | default font size
TOPAZ_SIXTY | default font size
TT_ALPHA16
TT_ALPHA24
TT_ALPHA32
TT_ALPHA8
TT_BITPLANE
T_ITEM
T_MENU
T_ROOT
UPFRONTGADGET |
UPIMAGE | SYSIA_Which tag data values. Up-arrow gadget image
USEREQIMAGE | Flag for TRequester.Flags. Render linked list ReqImage after BackFill but before gadgets and text
US_LEGAL | Value for TPreferences.PaperSize
US_LETTER | Value for TPreferences.PaperSize
VIF_3DDISABLE
VIF_ALPHABLEND
VIF_ALPHASHADE
VIF_ALPHASHADOW
VIF_ALPHASHINE
VIF_BORDERMASK
VIF_BRCORN
VIF_BUTTON
VIF_HORIZARROW
VIF_IGNOREHEIGHT
VIF_IGNOREWIDTH
VIF_KEEPASPECT
VIF_MENU
VIF_NOBUFFER
VIF_PENSHADE
VIF_REFFONT
VIF_ROUNDEDSCALING
VIF_SCREENBAR
VIF_TBLEFT
VIF_TBRIGHT
VIF_VERTARROW
VIF_WMULTIPLY
VKHANDLEIMAGE
VO_ELPS
VO_END
VO_FILL
VO_FILLELPS
VO_FILLPOLY
VO_FILLRECT
VO_LINE
VO_LINEELPS
VO_LINEPOLY
VO_LINERECT
VO_POLY
VO_RECT
VT_BOTH
VT_COLOR
VT_MONO
WA_Activate | Tag for OpenWindowTagList(). Activate the window when it opens.
WA_AlphaClips
WA_AlphaHook
WA_AmigaKey | Tag for OpenWindowTagList(). Amiga key image for Menus
WA_AutoAdjust | Tag for OpenWindowTagList().Auto adjust window size to screen maximum.
WA_AutoAdjustDClip
WA_Backdrop | Tag for OpenWindowTagList(). Make this window a backdrop window
WA_BackFill | Tag for OpenWindowTagList(). BackFill hook
WA_BlockPen | Tag for OpenWindowTagList(). Specifies the pen number for window block fills, like the title bar.
WA_Borderless | Tag for OpenWindowTagList(). Make window borderless
WA_BusyPointer | Tag for OpenWindowTagList(). Request standard busy pointer
WA_Checkmark | Tag for OpenWindowTagList(). Image for Menu entries
WA_CloseGadget | Tag for OpenWindowTagList(). Add CloseGadget to window
WA_Colors | Tag for OpenWindowTagList().
WA_ContextMenuHook
WA_CustomScreen | Tag for OpenWindowTagList(). Open the window on a specific screen
WA_DepthGadget | Tag for OpenWindowTagList(). Add Depthgadget to window
WA_DetailPen | Tag for OpenWindowTagList(). Specifies the pen number for the rendering of window details like gadgets or text in the title bar.
WA_DragBar | Tag for OpenWindowTagList(). Titlebar used to drag window
WA_DropShadows
WA_Dummy | Starting for window TagItems
WA_FadeTime
WA_Flags | Tag for OpenWindowTagList(). Window Flags (WFLG_*)
WA_Gadgets | Tag for OpenWindowTagList(). List of Gadgets
WA_GimmeZeroZero | Tag for OpenWindowTagList(). Zero-Zero window
WA_GrabFocus
WA_Height | Tag for OpenWindowTagList(). The initial window height in pixels
WA_HelpGroup | Tag for OpenWindowTagList(). Form Help groups
WA_HelpGroupWindow | Tag for OpenWindowTagList(). Form Help group windows
WA_Hidden
WA_IDCMP | Tag for OpenWindowTagList(). Which events should be reported
WA_InFrontOf
WA_InnerHeight | Tag for OpenWindowTagList(). Inner height of window
WA_InnerWidth | Tag for OpenWindowTagList(). Inner width for the window
WA_Left | Tag for OpenWindowTagList(). The initial x position
WA_MaxHeight | Tag for OpenWindowTagList(). Minimum height for resizeable windows
WA_MaxWidth | Tag for OpenWindowTagList(). Maximum width for resizeable windows
WA_MenuHelp | Tag for OpenWindowTagList(). Enabled Help button for Menu
WA_MenuHook
WA_MenuStrip
WA_MinHeight | Tag for OpenWindowTagList(). Minimum height for resizeable windows
WA_MinWidth | Tag for OpenWindowTagList(). Minimum width for resizeable windows
WA_MouseLimits
WA_MouseQueue | Tag for OpenWindowTagList(). Mouse event queue size
WA_NewLookMenus | Tag for OpenWindowTagList(). Activate NewLook menus
WA_NoCareRefresh | Tag for OpenWindowTagList(). Do not need Refresh message
WA_NoHitThreshold
WA_NoMenuKeyVerify
WA_NotifyDepth | Tag for OpenWindowTagList().
WA_Opaqueness
WA_OverrideOpaqueness
WA_Pointer | Tag for OpenWindowTagList(). Custom Pointer for window.
WA_PointerDelay | Tag for OpenWindowTagList(). Delay of pointer change
WA_PointerType
WA_PubScreen | Tag for OpenWindowTagList(). Specify screen to open window on
WA_PubScreenFallBack | Tag for OpenWindowTagList(). Fallback screen to default
WA_PubScreenName | Tag for OpenWindowTagList(). Choose screen by name
WA_ReportMouse | Tag for OpenWindowTagList(). Report mouse events
WA_Reserved1
WA_Reserved2
WA_RMBTrap | Tag for OpenWindowTagList().
WA_RptQueue | Tag for OpenWindowTagList(). Key event queue size
WA_ScreenTitle | Tag for OpenWindowTagList(). Title for screen when window is activated
WA_ShapeHook
WA_ShapeRegion
WA_SimpleRefresh | Tag for OpenWindowTagList().
WA_SizeBBottom | Tag for OpenWindowTagList(). Place the size gadget in the bottom border.
WA_SizeBRight | Tag for OpenWindowTagList(). Place the size gadget in the right border.
WA_SizeGadget | Tag for OpenWindowTagList().
WA_SmartRefresh | Tag for OpenWindowTagList().
WA_StayTop
WA_SuperBitMap | Tag for OpenWindowTagList(). SuperBitmap for scrolling windows
WA_TabletMessages | Tag for OpenWindowTagList(). Enabled tablet messages
WA_Title | Tag for OpenWindowTagList(). Title for window
WA_ToolBox
WA_Top | Tag for OpenWindowTagList(). The initial y position
WA_UserPort
WA_WBenchWindow | Tag for OpenWindowTagList(). Private
WA_Width | Tag for OpenWindowTagList(). The initial window width in pixels
WA_WindowBox
WA_WindowName | Tag for OpenWindowTagList().
WA_Zoom | Tag for OpenWindowTagList(). Define zoom size for window
WBENCHCLOSE | Code for IDCMP_WBENCHMESSAGE
WBENCHOPEN | Code for IDCMP_WBENCHMESSAGE
WBENCHSCREEN_F | Screentype flag for TScreen.Flags and TNewScreen.SType. The Workbench itself
WFLG_ACTIVATE | Flag for WA_Flags or TNewWindow.Flags. When window opens, it is active.
WFLG_BACKDROP | Flag for WA_Flags or TNewWindow.Flags. This is a backdrop window
WFLG_BORDERLESS | Flag for WA_Flags or TNewWindow.Flags. Get a window sans border.
WFLG_CLOSEGADGET | Flag for WA_Flags or TNewWindow.Flags. Include close-box system-gadget
WFLG_DEPTHGADGET | Flag for WA_Flags or TNewWindow.Flags. Include depth arrangement gadget
WFLG_DRAGBAR | Flag for WA_Flags or TNewWindow.Flags. Include dragging system-gadget
WFLG_GIMMEZEROZERO | Flag for WA_Flags or TNewWindow.Flags. A GimmeZeroZero window
WFLG_HASZOOM | Flag for TWindow.Flags. Window has a zoom gadget.
WFLG_INREQUEST | Flag for WA_Flags or TNewWindow.Flags. Private. This window is in request mode.
WFLG_MENUSTATE | Flag for WA_Flags or TNewWindow.Flags. Private. Window is active with menus on.
WFLG_NEWLOOKMENUS | Flag for WA_Flags or TNewWindow.Flags. Window has NewLook menus.
WFLG_NOCAREREFRESH | Flag for WA_Flags or TNewWindow.Flags. Not to be bothered with REFRESH
WFLG_NW_EXTENDED | Flag for TNewWindow.Flags. Extension data provided see TExtNewWindow.
WFLG_OTHER_REFRESH | Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap
WFLG_REFRESHBITS | Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap
WFLG_REPORTMOUSE | Flag for WA_Flags or TNewWindow.Flags. Fire an event for every mouse move
WFLG_RMBTRAP | Flag for WA_Flags or TNewWindow.Flags. Fire right mouse button events
WFLG_SIMPLE_REFRESH | Flag for WA_Flags or TNewWindow.Flags. Enable Simple Refresh
WFLG_SIZEBBOTTOM | Flag for WA_Flags or TNewWindow.Flags. Size gadget uses bottom border
WFLG_SIZEBRIGHT | Flag for WA_Flags or TNewWindow.Flags. Size gadget uses right border
WFLG_SIZEGADGET | Flag for WA_Flags or TNewWindow.Flags. Include sizing system-gadget
WFLG_SMART_REFRESH | Flag for WA_Flags or TNewWindow.Flags. Enable smart Refresh
WFLG_SUPER_BITMAP | Flag for WA_Flags or TNewWindow.Flags. Has super bitmap
WFLG_VISITOR | Flag for TWindow.Flags. Visitor window.
WFLG_WBENCHWINDOW | Flag for TWindow.Flags. Workbench tool only Window
WFLG_WINDOWACTIVE | Flag for WA_Flags or TNewWindow.Flags. Private. This window is the active one.
WFLG_WINDOWREFRESH | Flag for TWindow.Flags. Window is currently refreshing
WFLG_WINDOWTICKED | Flag for TWindow.Flags. Only one timer tick at a time
WFLG_ZOOMED | Flag for TWindow.Flags. Identifies "Zoom State"
WINDOW_BACKMOST
WINDOW_FRONTMOST
WTPOS_CENTERABS
WTPOS_CENTERREL
WTPOS_LEFT
W_TRACTOR | Value for TPreferences.PaperSize
ZOOMIMAGE | SYSIA_Which tag data values. Window zoom gadget image


Reference for unit 'intuition': Types

ClassID | Name of the Object class
LongWord | Handle for an BOOPSI Objects / Classes / Messages
PBoolInfo | Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_BOOLGADGET
PBorder | Pointer to Border Drawing structure
PClassLibrary | Pointer to a BOOPSI class libraries
PColorSpec | Pointer to Color table entry
PContextMenuMsg
PDrawInfo | Pointer to Draw info structure
PEasyStruct | The text and setup of an easy requester
PExtGadget | Pointer to and extended Gadget structure
PExtIntuiMessage | Pointer to an extended Intuition message
PExtNewScreen | Pointer to Extended New Screen structure
PExtNewWindow | Pointer to Future TNewWindow.
PGadget | Pointer to a Gadget structure
PGadgetGeometryMsg
PGadgetInfo | Pointer to Gadget Render Info
PgpDomain |
PgpExtent
PgpGoInactive | Pointer to Message parameter passed for GM_GOINACTIVE
PgpHitTest | Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST
PgpInput | Pointer to Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
PgpKeyGoInactive |
PgpKeyInput |
PgpKeyTest |
PgpLayout | Pointer to Message parameter passed for GM_LAYOUT
PgpMenuEvent
PgpQuery
PgpRender | Pointer to Message parameter passed for GM_RENDER
PGradientSpec
PGUIPlugin
PIBox | A data structure common in Intuition processing
PIClass | This structure is READ-ONLY, and allocated only by Intuition
PImage | This is a brief image structure for very simple transfers of image data to a RastPort
PImageGeometryMsg
PimpDomainFrame |
PimpDraw | Pointer to message argument for IM_DRAW or IM_DRAWFRAME
PimpErase | Pointer to message argument for IM_ERASE or IM_ERASEFRAME
PimpExtent
PimpFrameBox | Pointer to message argument for IM_FRAMEBOX
PimpHitTest | Pointer to message argument for IM_HITTEST or IM_HITFRAME
PIntuiMessage | Pointer to an Intuition message
PIntuiRawKeyData
PIntuiText | IntuiText is a series of strings.
PIntuitionBase | Pointer to Intution basic structures
PIntuiWheelData
PMenu | Pointer to a menu structure
PMenuEventMessage
PMenuItem | Pointer to an menu item
PMenuScanMessage
PMenuStringMessage
PmpDeleteMenu
PmpFindID
PmpGetState
PmpHandleEvent
PmpNewMenu
PmpNextChild
PmpNextSelect
PmpScan
PmpSetState
PmpSetup
PMsg |
PNewScreen | pointer to an instance of a NewScreen structure.
PNewWindow | Pointer to structure describes a new window
PObject_ | Pointer to an BOOPSI Object / Classe / Message Handle
PopAddTail | Pointer to message structure for OM_ADDTAIL
PopGet | Pointer to message structure for OM_GET
PopMember | Pointer to message structure for OM_ADDMEMBER/OM_REMMEMBER
PopSet | Pointer to message structure for OM_NEW/OM_SET
PopUpdate | Pointer to message structure for OM_NOTIFY/OM_UPDATE
PPGX | Pointer to System private data structure for now prop gadget extra info
PPObject_ | Pointer to an BOOPSI Object / Classe / Message Pointer Handle
PPreferences | Pointer to old style Preferences
PPropInfo | Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_PROPGADGET
PPubScreenNode | Pointer to Public Shared Screen Node
PRemember | Pointer to Memory allocating remember structure
PRenderMsg
PRequester | Requesters The following struct is used for standard intuition requesters
PScreen |
PScreenBuffer | Pointer to screen buffer
PScreenNotifyMessage
PScrollHook
PScrollMsg
PSGWork | Pointer to String gadget message
PStringExtend | Extended string info for Gadgets texts
PStringInfo | Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_STRGADGET
PSubStyle
PSysIPlugin
PTabletData | Pointer to a IntuiMessage TabletData
PTabletHookData |
PTBGadgetData
PVector
PVectorInfo
PWindow |
P_Object | Pointer to an Boopsi Object
TBitMapInstance
TBitMapSource
TBoolInfo | Boolgadget informations PBoolInfo
TBorder | Pointer drawing structure
TClassLibrary | BOOPSI class libraries structure
TColorSpec | Color table entry
TContextMenuMsg
TDrawInfo | Graphical informations for the 3D look
TEasyStruct | The text and setup of an easy requester
TExtGadget | Extended Gadget structure
TExtIntuiMessage | Extended Intuition message structure
TExtNewScreen | Extended TNewScreen structure
TExtNewWindow | Future TNewWindow
TGadget | Structure to describe a Gadget
TGadgetGeometryMsg
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
TgpDomain |
TgpExtent
TgpGoInactive | Message parameter passed for GM_GOINACTIVE
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
tgpKeyGoInactive |
TgpKeyInput |
TgpKeyTest |
TgpLayout | Message parameter passed for GM_LAYOUT
TgpMenuEvent
TgpQuery
TgpRender | Message parameter passed for GM_RENDER
TGradientSpec
TGUIPlugin
TIBox | A data structure common in Intuition processing
TIClass | This structure is READ-ONLY, and allocated only by Intuition
TImage | This is a brief image structure for very simple transfers of image data to a RastPort
TImageGeometryMsg
TimpDomainFrame |
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME
TimpErase | Message argument for IM_ERASE or IM_ERASEFRAME
TimpExtent
TimpFrameBox | Message argument for IM_FRAMEBOX
TimpHitTest | Message argument for IM_HITTEST or IM_HITFRAME
TIntuiMessage | Intuition message structure
TIntuiRawKeyData
TIntuiText | IntuiText is a series of strings.
TIntuitionBase | Intuition basic structure
TIntuiWheelData
TMenu | Structure to describe a menu
TMenuEventMessage
TMenuItem | Structure to describe a menu item
TMenuScanMessage
TMenuStringMessage
TmpDeleteMenu
TmpFindID
TmpGetState
TmpHandleEvent
TmpNewMenu
TmpNextChild
TmpNextSelect
TmpScan
TmpSetState
TmpSetup
TMsg |
TNewScreen | Description of a new screen
TNewWindow | New window structure
TopAddTail | Message structure for OM_ADDTAIL
TopGet | Message structure for OM_GET
TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TopSet | Message structure for OM_NEW/OM_SET
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TPGX | System private data structure for now prop gadget extra info
TPreferences | Old Style Preferences
TPropInfo | Proportional Gadget
TPubScreenNode | Public Shared Screen Node
TRemember | Structure to remember memory allocations
TRenderMsg
TRequester | Requesters The following struct is used for standard intuition requesters
TScreen | Basic screen structure
TScreenBuffer | Screen buffer structure
TScreenNotifyMessage
TScrollHook
TScrollMsg
TSGWork | String gadget message
TStringExtend | Extended string info for Gadgets texts
TStringInfo | String Gadget structure
TSubStyle
TSysIPlugin
TTabletData | IntuiMessage TabletData
TTabletHookData |
TTBGadgetData
TVector
TVectorInfo
TWindow | Window structure
T_Object | Boopsi Object structure


INTEGER_SCALING

Flag for TPreferences.PrintFlags force integer scaling

Declaration

Source position: intuition.pas line 2424

const INTEGER_SCALING = $0100;


INTUIRAWKEYDATA_VERSION

Declaration

Source position: intuition.pas line 843

const INTUIRAWKEYDATA_VERSION = 1;


IntuitionBase

Library Base for intuition.library

Declaration

Source position: intuition.pas line 3799

var IntuitionBase: PIntuitionBase;


INTUITIONNAME

Declaration

Source position: intuition.pas line 3796

const INTUITIONNAME: PChar = 'intuition.library';


INTUIWHEELDATA_VERSION

Declaration

Source position: intuition.pas line 829

const INTUIWHEELDATA_VERSION = 1;


ISDRAWN

Flag for TMenuItem.Flags set by intuition (ReadOnly), this item's subs are currently drawn

Declaration

Source position: intuition.pas line 115

const ISDRAWN = $1000;


ITEMENABLED

Flag for TMenuItem.Flags set by the Application, set if this item is enabled

Declaration

Source position: intuition.pas line 100

const ITEMENABLED = $0010;


ITEMTEXT

Flag for TMenuItem.Flags set by the Application, set if textual, clear if graphical item

Declaration

Source position: intuition.pas line 97

const ITEMTEXT = $0002;


ITEXTICLASS

Class identifier. A specialized image class used for rendering text.

Declaration

Source position: intuition.pas line 2537

const ITEXTICLASS: PChar = 'itexticlass';

Description

SuperClass: imageclass

This is a class of image objects that render an IntuiText structure. Using some of the imageclass attributes, the object can override some of the parameters in the IntuiText structure. This class makes it easy to share an IntuiText structure between objects.

Changed Methods:

IM_DRAW, IM_DRAWFRAME

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


KEYCODE_B

RawKeycode for TIntuiMessage.Code. 'b' key pressed.

Declaration

Source position: intuition.pas line 1906

const KEYCODE_B = $35;


KEYCODE_GREATER

RawKeycode for TIntuiMessage.Code. '>' key pressed.

Declaration

Source position: intuition.pas line 1908

const KEYCODE_GREATER = $39;


KEYCODE_LESS

RawKeycode for TIntuiMessage.Code. '<' key pressed.

Declaration

Source position: intuition.pas line 1907

const KEYCODE_LESS = $38;


KEYCODE_M

RawKeycode for TIntuiMessage.Code. 'm' key pressed.

Declaration

Source position: intuition.pas line 1904

const KEYCODE_M = $37;


KEYCODE_N

RawKeycode for TIntuiMessage.Code. 'n' key pressed.

Declaration

Source position: intuition.pas line 1903

const KEYCODE_N = $36;


KEYCODE_Q

RawKeycode for TIntuiMessage.Code. 'q' key pressed.

Declaration

Source position: intuition.pas line 1901

const KEYCODE_Q = $10;


KEYCODE_V

RawKeycode for TIntuiMessage.Code. 'v' key pressed.

Declaration

Source position: intuition.pas line 1905

const KEYCODE_V = $34;


KEYCODE_X

RawKeycode for TIntuiMessage.Code. 'x' key pressed.

Declaration

Source position: intuition.pas line 1902

const KEYCODE_X = $32;


KNOBHIT

Flag value for TPropInfo.Flags. set when this Knob is hit

Declaration

Source position: intuition.pas line 683

const KNOBHIT = $0100;


KNOBHMIN

Minimum horizontal size of the Knop

Declaration

Source position: intuition.pas line 686

const KNOBHMIN = 6;


KNOBVMIN

minimum vertical size of the Knop

Declaration

Source position: intuition.pas line 687

const KNOBVMIN = 4;


LACEWB

Interlace define for TPreferences.LaceWB

Declaration

Source position: intuition.pas line 2318

const LACEWB = 1 shl 0;


LAYOUTA_ChildMaxHeight

GadgetClass Layout Tag. (LongBool) Child objects are of equal height. Should default to True for gadgets with a vertical orientation.

Declaration

Source position: intuition.pas line 2789

const LAYOUTA_ChildMaxHeight = LAYOUTA_Dummy + $0005;


LAYOUTA_ChildMaxWidth

GadgetClass Layout Tag. (LongBool) Child objects are of equal width. Should default to True for gadgets with a horizontal orientation.

Declaration

Source position: intuition.pas line 2788

const LAYOUTA_ChildMaxWidth = LAYOUTA_Dummy + $0004;


LAYOUTA_Dummy

GadgetClass Layout start Tag.

Declaration

Source position: intuition.pas line 2783

const LAYOUTA_Dummy = TAG_USER + $38000;


LAYOUTA_LayoutObj

GadgetClass Layout Tag.

Declaration

Source position: intuition.pas line 2784

const LAYOUTA_LayoutObj = LAYOUTA_Dummy + $0001;


LAYOUTA_Orientation

GadgetClass Layout Tag. (LongInt) Orientation LORIENT_*

Declaration

Source position: intuition.pas line 2786

const LAYOUTA_Orientation = LAYOUTA_Dummy + $0003;


LAYOUTA_Spacing

GadgetClass Layout Tag.

Declaration

Source position: intuition.pas line 2785

const LAYOUTA_Spacing = LAYOUTA_Dummy + $0002;


LEFTIMAGE

SYSIA_Which tag data values. Left-arrow gadget image

Declaration

Source position: intuition.pas line 3143

const LEFTIMAGE = $0A;


LETTER

Value for TPreferences.PrintQuality

Declaration

Source position: intuition.pas line 2344

const LETTER = $100;


LEVEL_BRIGHT

Declaration

Source position: intuition.pas line 1424

const LEVEL_BRIGHT = 0;


LEVEL_DARK

Declaration

Source position: intuition.pas line 1428

const LEVEL_DARK = 4;


LEVEL_HALFBRIGHT

Declaration

Source position: intuition.pas line 1425

const LEVEL_HALFBRIGHT = 1;


LEVEL_HALFDARK

Declaration

Source position: intuition.pas line 1427

const LEVEL_HALFDARK = 3;


LEVEL_NORMAL

Declaration

Source position: intuition.pas line 1426

const LEVEL_NORMAL = 2;


LORIENT_HORIZ

Orientation values for LAYOUTA_Orientation

Declaration

Source position: intuition.pas line 2792

const LORIENT_HORIZ = 1;


LORIENT_NONE

Orientation values for LAYOUTA_Orientation

Declaration

Source position: intuition.pas line 2791

const LORIENT_NONE = 0;


LORIENT_VERT

Orientation values for LAYOUTA_Orientation

Declaration

Source position: intuition.pas line 2793

const LORIENT_VERT = 2;


LOWCHECKWIDTH

Define for CHECKIT width for the CheckMark (Low res resolution) in a menu item

Declaration

Source position: intuition.pas line 1867

const LOWCHECKWIDTH = 13;


LOWCOMMWIDTH

Define for COMMSEQ width for the Command sequence (Low resolution) in a menu item

Declaration

Source position: intuition.pas line 1868

const LOWCOMMWIDTH = 16;


LOWRESGADGET

Declaration

Source position: intuition.pas line 2447

const LOWRESGADGET = 1;


LOWRESPICK

Declaration

Source position: intuition.pas line 2441

const LOWRESPICK = $0001;


LW_RESERVED

internal use only for TPreferences.LaceWB

Declaration

Source position: intuition.pas line 2319

const LW_RESERVED = 1;


MA_AddChild

Declaration

Source position: intuition.pas line 160

const MA_AddChild = MA_Dummy + 50;


MA_Catalog

Declaration

Source position: intuition.pas line 163

const MA_Catalog = MA_Dummy + 81;


MA_CharSet

Declaration

Source position: intuition.pas line 166

const MA_CharSet = MA_Dummy + 84;


MA_Disabled

Declaration

Source position: intuition.pas line 148

const MA_Disabled = MA_Dummy + 8;


MA_Dummy

Declaration

Source position: intuition.pas line 140

const MA_Dummy = TAG_USER + $440000;


MA_EmbeddedKey

Declaration

Source position: intuition.pas line 168

const MA_EmbeddedKey = MA_Dummy + 86;


MA_ErrorCode

Declaration

Source position: intuition.pas line 172

const MA_ErrorCode = MA_Dummy + 98;


MA_ErrorTagItem

Declaration

Source position: intuition.pas line 173

const MA_ErrorTagItem = MA_Dummy + 99;


MA_EvenSize

Declaration

Source position: intuition.pas line 154

const MA_EvenSize = MA_Dummy + 14;


MA_FreeImage

Declaration

Source position: intuition.pas line 169

const MA_FreeImage = MA_Dummy + 87;


MA_HelpHook

Declaration

Source position: intuition.pas line 171

const MA_HelpHook = MA_Dummy + 89;


MA_Hidden

Declaration

Source position: intuition.pas line 155

const MA_Hidden = MA_Dummy + 15;


MA_ID

Declaration

Source position: intuition.pas line 145

const MA_ID = MA_Dummy + 5;


MA_Image

Declaration

Source position: intuition.pas line 147

const MA_Image = MA_Dummy + 7;


MA_Key

Declaration

Source position: intuition.pas line 146

const MA_Key = MA_Dummy + 6;


MA_Label

Declaration

Source position: intuition.pas line 142

const MA_Label = MA_Dummy + 2;


MA_LastSelected

Declaration

Source position: intuition.pas line 157

const MA_LastSelected = MA_Dummy + 17;


MA_Level

Declaration

Source position: intuition.pas line 143

const MA_Level = MA_Dummy + 3;


MA_MaxStringID

Declaration

Source position: intuition.pas line 165

const MA_MaxStringID = MA_Dummy + 83;


MA_MenuHelpID

Declaration

Source position: intuition.pas line 156

const MA_MenuHelpID = MA_Dummy + 16;


MA_MenuPosX

Declaration

Source position: intuition.pas line 158

const MA_MenuPosX = MA_Dummy + 18;


MA_MenuPosY

Declaration

Source position: intuition.pas line 159

const MA_MenuPosY = MA_Dummy + 19;


MA_MinStringID

Declaration

Source position: intuition.pas line 164

const MA_MinStringID = MA_Dummy + 82;


MA_MX

Declaration

Source position: intuition.pas line 150

const MA_MX = MA_Dummy + 10;


MA_Parent

Declaration

Source position: intuition.pas line 153

const MA_Parent = MA_Dummy + 13;


MA_PickHook

Declaration

Source position: intuition.pas line 170

const MA_PickHook = MA_Dummy + 88;


MA_RemoveChild

Declaration

Source position: intuition.pas line 161

const MA_RemoveChild = MA_Dummy + 51;


MA_Selected

Declaration

Source position: intuition.pas line 151

const MA_Selected = MA_Dummy + 11;


MA_Separator

Declaration

Source position: intuition.pas line 144

const MA_Separator = MA_Dummy + 4;


MA_StringHook

Declaration

Source position: intuition.pas line 162

const MA_StringHook = MA_Dummy + 80;


MA_TextAttr

Declaration

Source position: intuition.pas line 167

const MA_TextAttr = MA_Dummy + 85;


MA_Toggle

Declaration

Source position: intuition.pas line 149

const MA_Toggle = MA_Dummy + 9;


MA_Type

Declaration

Source position: intuition.pas line 141

const MA_Type = MA_Dummy + 1;


MA_UserData

Declaration

Source position: intuition.pas line 152

const MA_UserData = MA_Dummy + 12;


MAXBODY

Maximum body value in TPropInfo

Declaration

Source position: intuition.pas line 688

const MAXBODY = $FFFF;


MAXPOT

Maximum pot value in TPropInfo

Declaration

Source position: intuition.pas line 689

const MAXPOT = $FFFF;


MAXPUBSCREENNAME

Maximum length of public screen names. The buffers containing these strings must have a length of MAXPUBSCREENNAME + 1.

Declaration

Source position: intuition.pas line 2179

const MAXPUBSCREENNAME = 139;

See also

TPubScreenNode

Public Shared Screen Node


MENUALTERN

Declaration

Source position: intuition.pas line 1751

const MENUALTERN = $00000010;


MENUBACKGROUNDPEN

Declaration

Source position: intuition.pas line 1973

const MENUBACKGROUNDPEN = $001A;


MENUCANCEL

Code for IDCMP_MENUVERIFY HOT Reply of this cancels Menu operation

Declaration

Source position: intuition.pas line 912

const MENUCANCEL = $0002;


MENUCHECK

SYSIA_Which tag data values. Menu checkmark image

Declaration

Source position: intuition.pas line 3150

const MENUCHECK = $10;


MENUCMCORNER

Declaration

Source position: intuition.pas line 1757

const MENUCMCORNER = $00000800;


MENUDOWN

RawMouse code for TIntuiMessage.Code. Right Mouse Button down.

Declaration

Source position: intuition.pas line 1887

const MENUDOWN = IECODE_RBUTTON;


MENUENABLED

Flag for TMenu.Flags, whether or not this menu is enabled

Declaration

Source position: intuition.pas line 137

const MENUENABLED = $0001;


MENUFLAT

Declaration

Source position: intuition.pas line 1753

const MENUFLAT = $00000040;


MENUFRAMED

Declaration

Source position: intuition.pas line 1752

const MENUFRAMED = $00000020;


MENUHOT

Code for IDCMP_MENUVERIFY Intuition wants verification or MENUCANCEL

Declaration

Source position: intuition.pas line 911

const MENUHOT = $0001;


MENUMX

Declaration

Source position: intuition.pas line 3162

const MENUMX = $1B;


MENUNBPD

Declaration

Source position: intuition.pas line 1758

const MENUNBPD = $00001000;


MENUNBPU

Declaration

Source position: intuition.pas line 1759

const MENUNBPU = $00002000;


MENUNULL

Declaration

Source position: intuition.pas line 1861

const MENUNULL = - 1;


MENUPDTCLDEL

Declaration

Source position: intuition.pas line 1761

const MENUPDTCLDEL = $00020000;


MENUPDTOPDEL

Declaration

Source position: intuition.pas line 1760

const MENUPDTOPDEL = $00010000;


MENUSHADOW

Declaration

Source position: intuition.pas line 1750

const MENUSHADOW = $00000002;


MENUSHADOWPEN

Declaration

Source position: intuition.pas line 1976

const MENUSHADOWPEN = $001D;


MENUSHINEPEN

Declaration

Source position: intuition.pas line 1975

const MENUSHINEPEN = $001C;


MENUSTICKYPD

Declaration

Source position: intuition.pas line 1755

const MENUSTICKYPD = $00000200;


MENUSTICKYPU

Declaration

Source position: intuition.pas line 1756

const MENUSTICKYPU = $00000400;


MENUSUB

Declaration

Source position: intuition.pas line 3163

const MENUSUB = $1C;


MENUTEXTPEN

Declaration

Source position: intuition.pas line 1974

const MENUTEXTPEN = $001B;


MENUTOGGLE

Flag for TMenuItem.Flags set by the Application, set to toggle the check of a menu item

Declaration

Source position: intuition.pas line 99

const MENUTOGGLE = $0008;


MENUTOGGLED

Flag for TMenuItem.Flags set by intuition (ReadOnly), this item was already toggled

Declaration

Source position: intuition.pas line 117

const MENUTOGGLED = $4000;


MENUTRACK

Declaration

Source position: intuition.pas line 1754

const MENUTRACK = $00000100;


MENUTRANSP

Declaration

Source position: intuition.pas line 1749

const MENUTRANSP = $00000001;


MENUUP

RawMouse code for TIntuiMessage.Code. Right Mouse Button up.

Declaration

Source position: intuition.pas line 1886

const MENUUP = IECODE_RBUTTON + IECODE_UP_PREFIX;


MENUWAITING

Code for IDCMP_MENUVERIFY Intuition simply wants a ReplyMsg() ASAP

Declaration

Source position: intuition.pas line 913

const MENUWAITING = $0003;


MIDDLEDOWN

RawMouse code for TIntuiMessage.Code. Middle Mouse Button down.

Declaration

Source position: intuition.pas line 1889

const MIDDLEDOWN = IECODE_MBUTTON;


MIDDLEUP

RawMouse code for TIntuiMessage.Code. Middle Mouse Button up.

Declaration

Source position: intuition.pas line 1888

const MIDDLEUP = IECODE_MBUTTON + IECODE_UP_PREFIX;


ML_SEPARATOR

Declaration

Source position: intuition.pas line 180

const ML_SEPARATOR = STRPTR(not 0);


MM_CLEANUP

Declaration

Source position: intuition.pas line 201

const MM_CLEANUP = 4014;


MM_DELETEMENU

Declaration

Source position: intuition.pas line 193

const MM_DELETEMENU = 4004;


MM_FINDID

Declaration

Source position: intuition.pas line 190

const MM_FINDID = 4001;


MM_GETSTATE

Declaration

Source position: intuition.pas line 196

const MM_GETSTATE = 4007;


MM_HANDLEHELP

Declaration

Source position: intuition.pas line 199

const MM_HANDLEHELP = 4012;


MM_HANDLEPICK

Declaration

Source position: intuition.pas line 198

const MM_HANDLEPICK = 4011;


MM_NEWMENU

Declaration

Source position: intuition.pas line 192

const MM_NEWMENU = 4003;


MM_NEXTCHILD

Declaration

Source position: intuition.pas line 194

const MM_NEXTCHILD = 4005;


MM_NEXTSELECT

Declaration

Source position: intuition.pas line 197

const MM_NEXTSELECT = 4009;


MM_SCAN

Declaration

Source position: intuition.pas line 191

const MM_SCAN = 4002;


MM_SETSTATE

Declaration

Source position: intuition.pas line 195

const MM_SETSTATE = 4006;


MM_SETUP

Declaration

Source position: intuition.pas line 200

const MM_SETUP = 4013;


MODELCLASS

Class identifier. Multiple Targets

Declaration

Source position: intuition.pas line 2536

const MODELCLASS: PChar = 'modelclass';

Description

SuperClass: icclass

A class of OM_UPDATE forwarding objects that have multiple targets. In addition to the features the modelclass object inherits from icclass, when a modelclass object gets an OM_UPDATE message, it forwards that OM_UPDATE message to all of the objects in its broadcast list.

Changed Methods:

OM_ADDMEMBER, OM_REMMEMBER, OM_DISPOSE, OM_NOTIFY, OM_UPDATE

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


MOUSE_ACCEL

Declaration

Source position: intuition.pas line 2322

const MOUSE_ACCEL = 1 shl 15;


MS_CHECKED

Declaration

Source position: intuition.pas line 297

const MS_CHECKED = 1;


MS_DISABLED

Declaration

Source position: intuition.pas line 298

const MS_DISABLED = 2;


MT_POPUP

Declaration

Source position: intuition.pas line 1745

const MT_POPUP = 1;


MT_PULLDOWN

Declaration

Source position: intuition.pas line 1744

const MT_PULLDOWN = 0;


MT_RELATIVE

Declaration

Source position: intuition.pas line 1746

const MT_RELATIVE = 2;


MULTIPLY_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as multipliers

Declaration

Source position: intuition.pas line 2422

const MULTIPLY_DIMENSIONS = $0080;


MXIMAGE

SYSIA_Which tag data values. GadTools mutual exclude "button" image

Declaration

Source position: intuition.pas line 3148

const MXIMAGE = $0F;


N_TRACTOR

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 2361

const N_TRACTOR = $20;


NM_Dummy

Declaration

Source position: intuition.pas line 289

const NM_Dummy = TAG_USER + $450000;


NM_Item

Declaration

Source position: intuition.pas line 291

const NM_Item = NM_Dummy + 2;


NM_Menu

Declaration

Source position: intuition.pas line 290

const NM_Menu = NM_Dummy + 1;


NM_SubItems

Declaration

Source position: intuition.pas line 292

const NM_SubItems = NM_Dummy + 3;


NO_MENU_ID

Declaration

Source position: intuition.pas line 182

const NO_MENU_ID = 0;


NOISYREQ

Flag for TRequester.Flags. Requester does not filter input.

Declaration

Source position: intuition.pas line 749

const NOISYREQ = $0004;


NOITEM

Declaration

Source position: intuition.pas line 1859

const NOITEM = $003F;


NOMENU

Declaration

Source position: intuition.pas line 1858

const NOMENU = $001F;


NOREQBACKFILL

Flag for TRequester.Flags. Don't bother filling requester with TRequester.BackFill pen

Declaration

Source position: intuition.pas line 753

const NOREQBACKFILL = $0040;


NOSUB

Declaration

Source position: intuition.pas line 1860

const NOSUB = $001F;


NS_EXTENDED

Flag for TScreen.Flags. TExtNewScreen.Extension is valid

Declaration

Source position: intuition.pas line 2015

const NS_EXTENDED = $1000;


NSCODE_FINAL

Declaration

Source position: intuition.pas line 907

const NSCODE_FINAL = $0000;


NSCODE_INTERIM

Declaration

Source position: intuition.pas line 908

const NSCODE_INTERIM = $0001;


NSTAG_EXT_VPMODE

this is an obsolete tag included only for compatibility with V35 interim release for the A2024 and Viking monitors

Declaration

Source position: intuition.pas line 2105

const NSTAG_EXT_VPMODE = TAG_USER + 1;


NUMDRIPENS

Rendering pen number indexes into TDrawInfo.dri_Pens.

Declaration

Source position: intuition.pas line 1993

const NUMDRIPENS = $002D;

Description

Only present if DRI_VERSION >= 2


Object_

Handle for an BOOPSI Objects / Classes / Messages

Declaration

Source position: intuition.pas line 26

type Object_ = LongWord;


OKABORT

Internal token to represent state of verification attempts shown here as a clue. window rendered question moot

Declaration

Source position: intuition.pas line 917

const OKABORT = $0004;


OKCANCEL

Internal token to represent state of verification attempts shown here as a clue. window sent cancel reply

Declaration

Source position: intuition.pas line 918

const OKCANCEL = MENUCANCEL;


OKIMATE_20

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2384

const OKIMATE_20 = $09;


OKOK

Internal token to represent state of verification attempts shown here as a clue. guy didn't care

Declaration

Source position: intuition.pas line 916

const OKOK = MENUHOT;


OM_ADDMEMBER

This method tells an object to add an object to its broadcast list.

Declaration

Source position: intuition.pas line 2553

const OM_ADDMEMBER = $109;

Description

Tells an object to add another object to its personal Exec list. What the list is for depends on the class. The return value for this method is not explicitly defined.

One class that uses this method is modelclass. A modelclass object maintains a broadcast list. When a modelclass object gets an OM_NOTIFY message, it broadcasts an OM_UPDATE message about the OM_NOTIFY to every object in its broadcast list.

This method uses TopMember message.

opam_Object is the object to add to the list. A dispatcher typically implements OM_ADDMEMBER by sending the OM_ADDTAIL message to the opam_Object object.

See also

TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_ADDTAIL

This method tells an object to add itself to the end of an Exec list.

Declaration

Source position: intuition.pas line 2549

const OM_ADDTAIL = $105;

Description

This method tells an object to add itself to the end of a specified Exec list. Boopsi objects contain a MinNode structure used for this purpose. The return value for this method is not explicitly defined.

The method uses TopAddTail message

The opat_List can be any Exec list. Use the Intuition function NextObject() to step through this list.

See also

TopAddTail | Message structure for OM_ADDTAIL
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_DISPOSE

This method tells an object to dispose of itself.

Declaration

Source position: intuition.pas line 2546

const OM_DISPOSE = $102;

Description

This method instructs an object to delete itself. The rootclass dispatcher's OM_DISPOSE method decrements the true class's internal count of instances of true class. The return value for this method is not explicitly defined.

This method uses the default Boopsi message.

Applications should not call this method directly. Instead they should use the function DisposeObject().

For the OM_DISPOSE method, an object should do the following:

Free any additional resources the object explicitly allocated itself in the OM_NEW method (this does not include the instance data).

Pass the message up to the superclass, which will eventually reach rootclass, which will free the instance data allocated for the object.

If a class does not allocate any extra resources when it creates an object, it can defer all OM_DISPOSE processing to its superclass.

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_Dummy

Start of dispatched method ID's

Declaration

Source position: intuition.pas line 2544

const OM_Dummy = $100;


OM_GET

This method tells an object to report an attribute value.

Declaration

Source position: intuition.pas line 2548

const OM_GET = $104;

Description

Tells an object to report an attribute's value. Applications should not call this method directly. Instead, use the intuition.library function GetAttr(). The return value for this method is not explicitly defined.

This method uses TopGet message.

If the object's dispatcher recognizes opg_AttrID as one of the attributes defined by this class, the dispatcher should copy the value of that attribute to where opg_Storage points.

If the dispatcher does not recognize opg_AttrID, it should pass the message on to the superclass.

See also

TopGet | Message structure for OM_GET
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_NEW

This method creates a new object.

Declaration

Source position: intuition.pas line 2545

const OM_NEW = $101;

Description

This method tells a class to create a new instance of itself. If OM_NEW is successful, it returns a pointer to the new object, otherwise it returns nil.

For programmers who are only creating Boopsi objects rather than creating custom classes, use the intuition.library function NewObject()

The OM_NEW method receives the arguments via PopSet.

The ops_AttrList field contains a pointer to a tag list of attribute/value pairs. Each pair contains an attribute ID and the initial value of the corresponding attribute.

The ops_GInfo field is always nil for the OM_NEW method.

Unlike other methods, when the dispatcher gets an OM_NEW message, the object pointer does not point to an object, since the idea is to create a new object. The pointer normally used to pass a Boopsi object is instead used to pass the address of the object's "true class" (the class of which the object is an instance).

The first thing the dispatcher does when it processes an OM_NEW message is pass the OM_NEW message on to its superclass's dispatcher. It does this using function DoSuperMethodA().

Each superclass's dispatcher does this until the message gets to the rootclass dispatcher.

Each class keeps a record of how much memory its local instance data requires. The rootclass dispatcher's OM_NEW method looks at the object's true class (newobject from the prototype) to find out how much memory to allocate for the object's instance data. The rootclass dispatcher allocates enough memory for the true class's local instance data, plus enough memory for the local instance data of each of the true class's superclasses. If all goes well, the rootclass dispatcher increments the true class's internal count of instances of true class, and returns a pointer to the newly created object. it passes control back to the subclass dispatcher that called it. If there was a problem, the rootclass dispatcher passes back a nil.

When the rootclass dispatcher returns, the subclass dispatcher regains control from DoSuperMethodA(). DoSuperMethodA() will return either a pointer to the new object or nil if there was an error. Although the rootclass dispatcher allocated all the memory the object needs, it did not set up any of that memory. Now its the the subclass dispatcher's turn to do some work. It has to initialize the instance data that is local to its class. A dispatcher finds its local instance data by using the INST_DATA() macro.

After initializing its local instance data, the subclass dispatcher passes control down to its subclass dispatcher, which in turn, initializes its local instance data. Control passes down from class to subclass until the true class dispatcher regains control.

Now the true class dispatcher has to initialize its local instance data. It has to scan through the tag list of attribute/value pairs passed in the OM_NEW message (TopSet.ops_AttrList). If the dispatcher finds any attributes that the true class recognizes, it has to initialize them to the value passed in the attribute/value pair.

At this point, the new object can allocate other resources it needs that it did not allocate as part of its instance data. For example, the new Boopsi object might need a frame image around itself, so it can create a new one using a Boopsi frame image. If the object allocates any resources in this step, it must deallocate these resources later when it is disposed in the OM_DISPOSE method.

Finally, the dispatcher can return. When the dispatcher returns from an OM_NEW method, it returns a pointer to the new object.

See also

TopSet | Message structure for OM_NEW/OM_SET
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_NOTIFY

This method tells an object to broadcast an attribute change to its broadcast list.

Declaration

Source position: intuition.pas line 2551

const OM_NOTIFY = $107;

Description

This method tells an object to broadcast an attribute change to a set of target objects using OM_UPDATE messages. The return value for this method is not explicitly defined.

The OM_NOTIFY method uses the TopUpdate message structure.

Most dispatchers do not handle the OM_NOTIFY message directly. Normally they inherit this method from a superclass, so they pass the OM_NOTIFY message on to the superclass dispatcher.

Although most dispatchers don't have to process OM_NOTIFY messages, most do have to send them. Whenever an object receives an OM_SET or OM_UPDATE about one of its attributes, it may need to notify other objects of the change. For example, when a prop gadget's PGA_Top value changes, its target object(s) need to hear about it.

If an object needs to notify other objects about a change to one or more of its attributes, it sends itself an OM_NOTIFY message. The OM_NOTIFY message will eventually end up in the hands of a superclass that understands OM_NOTIFY and it will send OM_UPDATE messages to the target objects.

See also

TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_REMMEMBER

This method tells an object to remove an object from its broadcast list.

Declaration

Source position: intuition.pas line 2554

const OM_REMMEMBER = $10A;

Description

Tells an object to remove a member object from its personal list. The member object should have already been added with OM_ADDMEMBER. This method uses the TopMember message. Normally a dispatcher implements OM_REMMEMBER by sending the OM_REMOVE message to the opam_Object object. The return value for this method is not explicitly defined.

See also

TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_REMOVE

This method tells an object to remove itself from an Exec list.

Declaration

Source position: intuition.pas line 2550

const OM_REMOVE = $106;

Description

Remove an object from an Exec list. The return value for this method is not explicitly defined. This method uses the default Boopsi message.

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_SET

This method tells an object to set one or more of its attribute values.

Declaration

Source position: intuition.pas line 2547

const OM_SET = $103;

Description

This method tells an object to set one or more of its attributes. Applications should not call this method directly. Instead, use the intuition.library functions SetAttrs() and SetGadgetAttrs() to call this method. The return value for this method is not explicitly defined.

The return value for this method is not explicitly defined. However, in general, when implementing the OM_SET method, if setting an object attribute causes some sort of visual state change, the OM_SET method should return a value greater than zero. If changing an attribute does not affect the visual state, OM_SET should return zero.

This method uses a TopSet Message.

The ops_AttrList field contains a pointer to a tag list of attribute/value pairs. These pairs contain the IDs and the new values of the attributes to set. The dispatcher has to look through this list (see NextTagItem() function) for attributes its class recognizes and set the attribute's value accordingly. The dispatcher should let its superclass handle any attributes it does not recognize.

If the object is a gadget, the ops_GInfo field contains a pointer to a TGadgetInfo structure. Otherwise, the value in ops_GInfo is undefined. Intuition use the TGadgetInfo structure to pass display information to gadgets. See the gadgetclass methods for more details.

See also

TopSet | Message structure for OM_NEW/OM_SET
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OM_UPDATE

This method tells an object to update one or more of its attribute values.

Declaration

Source position: intuition.pas line 2552

const OM_UPDATE = $108;

Description

This method tells an object to update one or more of its attributes. No application should call this method. Only Boopsi objects send OM_UPDATE messages. The return value for this method is not explicitly defined.

A Boopsi object uses an OM_UPDATE message to notify another Boopsi object about transitory changes to one or more attributes.

From the point of view of most objects, an OM_UPDATE message is almost identical to OM_SET. Because the methods are so similar, When a typical dispatcher receives an OM_UPDATE message, it processes the OM_UPDATE the same way it would process an OM_SET message, usually using the same code.

There are actually two kinds of OM_UPDATE, an interim and final one. While a Boopsi object's attribute is in a transient state, it can send out interim OM_UPDATE messages to its target(s). For example, while the user is sliding a Boopsi prop gadget, the prop gadget sends interim OM_UPDATE message about changes to its PGA_Top value (the integer value of the prop gadget is the PGA_Top attribute) to some target object. When the user lets go of the prop gadget, the gadget is no longer in a transient state, so the gadget sends out a final OM_UPDATE about its PGA_Top attribute. The target object can choose to change one of its attributes based on the OM_UPDATE messages it receives.

The layout of the OM_UPDATE message is almost identical to the OM_SET message

Some dispatchers need to know the difference between an interim and final OM_UPDATE. A dispatcher can tell the difference between an interim and final OM_UPDATE message because the OM_UPDATE message has an extra field for flags. If the low order bit (the OPUF_INTERIM bit) is set, this is an interim OM_UPDATE message. The interim flag is useful to a class that wants to ignore any interim messages, processing only final attribute values.

See also

TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


OPUF_INTERIM

Flag for TopUpdate.opu_Flags

Declaration

Source position: intuition.pas line 2582

const OPUF_INTERIM = 1 shl 1;

Description

This flag means that the update message is being issued from something like an active gadget, a la GACT_FOLLOWMOUSE. When the gadget goes inactive, it will issue a final update message with this bit cleared. Examples of use are for GACT_FOLLOWMOUSE equivalents for propgclass, and repeat strobes for buttons.


ORDERED_DITHERING

Flag for TPreferences.PrintFlags ordered dithering

Declaration

Source position: intuition.pas line 2426

const ORDERED_DITHERING = $0000;


OSCAN_MAX

Identifier for SA_Overscan as much as possible

Declaration

Source position: intuition.pas line 2157

const OSCAN_MAX = 3;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSCAN_STANDARD

Identifier for SA_Overscan just past edges

Declaration

Source position: intuition.pas line 2156

const OSCAN_STANDARD = 2;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSCAN_TEXT

Identifier for SA_Overscan entirely visible

Declaration

Source position: intuition.pas line 2155

const OSCAN_TEXT = 1;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSCAN_VIDEO

Identifier for SA_Overscan even more than is possible

Declaration

Source position: intuition.pas line 2158

const OSCAN_VIDEO = 4;

See also

OpenScreenTagList

OpenScreen() with TagItem extension array.


OSERR_ATTACHFAIL

Declaration

Source position: intuition.pas line 2116

const OSERR_ATTACHFAIL = 8;


OSERR_BADBITMAP

Declaration

Source position: intuition.pas line 2118

const OSERR_BADBITMAP = 10;


OSERR_NOCHIPMEM

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get chipmem

Declaration

Source position: intuition.pas line 2112

const OSERR_NOCHIPMEM = 4;


OSERR_NOCHIPS

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode You need newer custom chips

Declaration

Source position: intuition.pas line 2110

const OSERR_NOCHIPS = 2;


OSERR_NOMEM

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Couldn't get normal memory

Declaration

Source position: intuition.pas line 2111

const OSERR_NOMEM = 3;


OSERR_NOMONITOR

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Named monitor spec not available

Declaration

Source position: intuition.pas line 2109

const OSERR_NOMONITOR = 1;


OSERR_NOTAVAILABLE

Declaration

Source position: intuition.pas line 2117

const OSERR_NOTAVAILABLE = 9;


OSERR_PUBNOTUNIQUE

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Public screen name already used

Declaration

Source position: intuition.pas line 2113

const OSERR_PUBNOTUNIQUE = 5;


OSERR_TOODEEP

Declaration

Source position: intuition.pas line 2115

const OSERR_TOODEEP = 7;


OSERR_UNKNOWNMODE

Error code of OpenScreen() returned into the PLongInt at SA_ErrorCode Don't recognize mode asked for

Declaration

Source position: intuition.pas line 2114

const OSERR_UNKNOWNMODE = 6;


P_Object

Pointer to an Boopsi Object

Declaration

Source position: intuition.pas line 2641

type P_Object = ^T_Object;


PA_INTERNAL

Declaration

Source position: intuition.pas line 395

const PA_INTERNAL = $10000000;


PADLOCKIMAGE

Declaration

Source position: intuition.pas line 3158

const PADLOCKIMAGE = $17;


PALETTELOCK_IGNORE

Declaration

Source position: intuition.pas line 1733

const PALETTELOCK_IGNORE = not 0;


PALETTERGB_IGNORE

Declaration

Source position: intuition.pas line 1730

const PALETTERGB_IGNORE = not 0;


PARALLEL_PRINTER

Value for TPreferences.PrinterPort

Declaration

Source position: intuition.pas line 2324

const PARALLEL_PRINTER = $00;


PBoolInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_BOOLGADGET

Declaration

Source position: intuition.pas line 631

type PBoolInfo = ^TBoolInfo;


PBorder

Pointer to Border Drawing structure

Declaration

Source position: intuition.pas line 62

type PBorder = ^TBorder;

Description

Data type Border, used for drawing a series of lines which is intended for use as a border drawing, but which may, in fact, be used to render any arbitrary vector shape. The routine DrawBorder sets up the RastPort with the appropriate variables, then does a Move to the first coordinate, then does Draws to the subsequent coordinates. After all the Draws are done, if NextBorder is non-zero we call DrawBorder recursively

See also

TRequester | Requesters The following struct is used for standard intuition requesters
GA_Border | GadgetClass Tag. (PBorder) Gadget imagry is a border
DrawBorder | Draw the specified Border structure into a RastPort.


PClassLibrary

Pointer to a BOOPSI class libraries

Declaration

Source position: intuition.pas line 2650

type PClassLibrary = ^TClassLibrary;


PColorSpec

Pointer to Color table entry

Declaration

Source position: intuition.pas line 1776

type PColorSpec = ^TColorSpec;


PContextMenuMsg

Declaration

Source position: intuition.pas line 1288

type PContextMenuMsg = ^TContextMenuMsg;


PDrawInfo

Pointer to Draw info structure

Declaration

Source position: intuition.pas line 1918

type PDrawInfo = ^TDrawInfo;

See also

TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
GA_DrawInfo | GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.
TimpFrameBox | Message argument for IM_FRAMEBOX
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME
DrawImageState | Draw an (extended) Intuition Image with special visual state.
FreeScreenDrawInfo | Finish using a DrawInfo structure.
GetScreenDrawInfo | Get pointer to rendering information.


PEasyStruct

The text and setup of an easy requester

Declaration

Source position: intuition.pas line 1788

type PEasyStruct = ^TEasyStruct;

See also

BuildEasyRequestArgs | Simple creation of system request.
EasyRequestArgs | Easy alternative to AutoRequest()


PEN_ALPHA

Declaration

Source position: intuition.pas line 3616

const PEN_ALPHA = $4000;


PEN_ALPHASHADOW

Declaration

Source position: intuition.pas line 3615

const PEN_ALPHASHADOW = $3000;


PEN_ALPHASHINE

Declaration

Source position: intuition.pas line 3614

const PEN_ALPHASHINE = $2000;


PEN_BRIGHT

Declaration

Source position: intuition.pas line 3610

const PEN_BRIGHT = $1000;


PEN_C0

Complement of color 0

Declaration

Source position: intuition.pas line 1999

const PEN_C0 = $FEFF;

Description

It is sometimes useful to specify that a pen value is to be the complement of color zero. This "magic" number serve that purpose.


PEN_C1

Complement of color 1

Declaration

Source position: intuition.pas line 1998

const PEN_C1 = $FEFE;

Description

It is sometimes useful to specify that a pen value is to be the complement of color one. This "magic" number serve that purpose.


PEN_C2

Complement of color 2

Declaration

Source position: intuition.pas line 1997

const PEN_C2 = $FEFD;

Description

It is sometimes useful to specify that a pen value is to be the complement of color two. This "magic" number serve that purpose.


PEN_C3

Complement of color 3

Declaration

Source position: intuition.pas line 1996

const PEN_C3 = $FEFC;

Description

It is sometimes useful to specify that a pen value is to be the complement of color three. This "magic" number serve that purpose.


PEN_DARK

Declaration

Source position: intuition.pas line 3613

const PEN_DARK = $1004;


PEN_HALFBRIGHT

Declaration

Source position: intuition.pas line 3611

const PEN_HALFBRIGHT = $1001;


PEN_HALFDARK

Declaration

Source position: intuition.pas line 3612

const PEN_HALFDARK = $1003;


PENSHARED

Flag for TScreen.Flags. Screen opener set (SA_SharePens,True)

Declaration

Source position: intuition.pas line 2019

const PENSHARED = $0400;


PExtGadget

Pointer to and extended Gadget structure

Declaration

Source position: intuition.pas line 444

type PExtGadget = ^TExtGadget;

See also

PGadget | Pointer to a Gadget structure
GFLG_EXTENDED | Flag for TGadget.SpecialInfo. Gadget is an PExtGadget


PExtIntuiMessage

Pointer to an extended Intuition message

Declaration

Source position: intuition.pas line 1366

type PExtIntuiMessage = ^TExtIntuiMessage;


PExtNewScreen

Pointer to Extended New Screen structure

Declaration

Source position: intuition.pas line 2140

type PExtNewScreen = ^TExtNewScreen;


PExtNewWindow

Pointer to Future TNewWindow.

Declaration

Source position: intuition.pas line 1131

type PExtNewWindow = ^TExtNewWindow;


PGA_ArrowDelta

Declaration

Source position: intuition.pas line 2745

const PGA_ArrowDelta = PGA_Dummy + $000B;


PGA_ArrowDown

Declaration

Source position: intuition.pas line 2746

const PGA_ArrowDown = PGA_Dummy + $000C;


PGA_Borderless

PropGClass Tag. (LongBool) If set, no border will be rendered.

Declaration

Source position: intuition.pas line 2734

const PGA_Borderless = PGA_Dummy + $0002;


PGA_Dummy

PropGClass Start Tag.

Declaration

Source position: intuition.pas line 2731

const PGA_Dummy = TAG_USER + $31000;


PGA_Freedom

PropGClass Tag. [IS.] (LongWord) Define in which the direction gadget should stretch.

Declaration

Source position: intuition.pas line 2732

const PGA_Freedom = PGA_Dummy + $0001;

Description

Possible values are FREEVERT and FREEHORIZ


PGA_HorizBody

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2736

const PGA_HorizBody = PGA_Dummy + $0004;


PGA_HorizPot

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2735

const PGA_HorizPot = PGA_Dummy + $0003;


PGA_NewLook

PropGClass Tag. [IS.] (LongBool) If set, this indicated that the new look should be used for rendering.

Declaration

Source position: intuition.pas line 2743

const PGA_NewLook = PGA_Dummy + $000A;


PGA_Top

PropGClass Tag. [ISG] (Word) The first visible position.

Declaration

Source position: intuition.pas line 2741

const PGA_Top = PGA_Dummy + $0009;

Description

Should not be used with PGA_HorizPot, PGA_HorizBody, PGA_VertPot and PGA_VertBody.


PGA_Total

PropGClass Tag. [IS.] (Word) The total number of positions in the gadget.

Declaration

Source position: intuition.pas line 2739

const PGA_Total = PGA_Dummy + $0007;

Description

Should not be used with PGA_HorizPot, PGA_HorizBody, PGA_VertPot and PGA_VertBody.


PGA_VertBody

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2738

const PGA_VertBody = PGA_Dummy + $0006;


PGA_VertPot

PropGClass Tag. [ISG] (Word) Should not be used with PGA_Total, PGA_Visible and PGA_Top.

Declaration

Source position: intuition.pas line 2737

const PGA_VertPot = PGA_Dummy + $0005;


PGA_Visible

PropGClass Tag. [IS.] (Word) The number of visible positions in the gadget.

Declaration

Source position: intuition.pas line 2740

const PGA_Visible = PGA_Dummy + $0008;

Description

Should not be used with PGA_HorizPot, PGA_HorizBody, PGA_VertPot and PGA_VertBody.


PGadget

Pointer to a Gadget structure

Declaration

Source position: intuition.pas line 416

type PGadget = ^TGadget;

See also

TRequester | Requesters The following struct is used for standard intuition requesters
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TScreen | Basic screen structure
TNewScreen | Description of a new screen
TExtNewScreen | Extended TNewScreen structure
GA_Previous | GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.
GA_Next | GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.
TSGWork | String gadget message
ActivateGadget | Activate a (string or custom) gadget.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
GadgetMouse | Calculate gadget-relative mouse position.
ModifyProp | Modify the current parameters of a proportional gadget.
ObtainGIRPort | Set up a RastPort for a custom gadget.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.
GADGET_BOX | Get bounding box of a gadget
CUSTOM_HOOK | Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget


PGadgetGeometryMsg

Declaration

Source position: intuition.pas line 3759

type PGadgetGeometryMsg = ^TGadgetGeometryMsg;


PGadgetInfo

Pointer to Gadget Render Info

Declaration

Source position: intuition.pas line 2484

type PGadgetInfo = ^TGadgetInfo;

See also

TopSet | Message structure for OM_NEW/OM_SET
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpRender | Message parameter passed for GM_RENDER
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
TgpGoInactive | Message parameter passed for GM_GOINACTIVE
TgpLayout | Message parameter passed for GM_LAYOUT
TgpDomain |
TSGWork | String gadget message
GadgetMouse | Calculate gadget-relative mouse position.
ObtainGIRPort | Set up a RastPort for a custom gadget.


PgpDomain

Declaration

Source position: intuition.pas line 2916

type PgpDomain = ^TgpDomain;


PgpExtent

Declaration

Source position: intuition.pas line 2974

type PgpExtent = ^TgpExtent;


PgpGoInactive

Pointer to Message parameter passed for GM_GOINACTIVE

Declaration

Source position: intuition.pas line 2893

type PgpGoInactive = ^TgpGoInactive;


PgpHitTest

Pointer to Message parameter passed for GM_HITTEST or GM_HELPTEST

Declaration

Source position: intuition.pas line 2819

type PgpHitTest = ^TgpHitTest;


PgpInput

Pointer to Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT

Declaration

Source position: intuition.pas line 2862

type PgpInput = ^TgpInput;


PgpKeyGoInactive

Declaration

Source position: intuition.pas line 2964

type PgpKeyGoInactive = ^tgpKeyGoInactive;


PgpKeyInput

Declaration

Source position: intuition.pas line 2948

type PgpKeyInput = ^TgpKeyInput;


PgpKeyTest

Declaration

Source position: intuition.pas line 2934

type PgpKeyTest = ^TgpKeyTest;


PgpLayout

Pointer to Message parameter passed for GM_LAYOUT

Declaration

Source position: intuition.pas line 2906

type PgpLayout = ^TgpLayout;


PgpMenuEvent

Declaration

Source position: intuition.pas line 3019

type PgpMenuEvent = ^TgpMenuEvent;


PgpQuery

Declaration

Source position: intuition.pas line 3002

type PgpQuery = ^TgpQuery;


PgpRender

Pointer to Message parameter passed for GM_RENDER

Declaration

Source position: intuition.pas line 2846

type PgpRender = ^TgpRender;


PGradientSpec

Declaration

Source position: intuition.pas line 1823

type PGradientSpec = ^TGradientSpec;


PGUIPlugin

Declaration

Source position: intuition.pas line 381

type PGUIPlugin = ^TGUIPlugin;


PIBox

A data structure common in Intuition processing

Declaration

Source position: intuition.pas line 926

type PIBox = ^TIBox;

See also

GA_Bounds | GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.
TimpFrameBox | Message argument for IM_FRAMEBOX
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
TPGX | System private data structure for now prop gadget extra info
TgpDomain |
IM_BOX | Get Image bounding rectangle
GADGET_BOX | Get bounding box of a gadget


PICA

Value for TPreferences.PrintPitch

Declaration

Source position: intuition.pas line 2339

const PICA = $000;


PIClass

This structure is READ-ONLY, and allocated only by Intuition

Declaration

Source position: intuition.pas line 2611

type PIClass = ^TIClass;


PImage

This is a brief image structure for very simple transfers of image data to a RastPort

Declaration

Source position: intuition.pas line 764

type PImage = ^TImage;

See also

TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TDrawInfo | Graphical informations for the 3D look
GA_Image | GadgetClass Tag. (PImage) Gadget imagry is an image
GA_SelectRender | GadgetClass Tag.
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.
EraseImage | Erases an Image.
PointInImage | Tests whether an image "contains" a point.
IM_BGPEN | Set Image Background Pen
IM_BOX | Get Image bounding rectangle
IM_FGPEN | Set Image Foreground pen


PImageGeometryMsg

Declaration

Source position: intuition.pas line 3733

type PImageGeometryMsg = ^TImageGeometryMsg;


PimpDomainFrame

Declaration

Source position: intuition.pas line 3295

type PimpDomainFrame = ^TimpDomainFrame;


PimpDraw

Pointer to message argument for IM_DRAW or IM_DRAWFRAME

Declaration

Source position: intuition.pas line 3244

type PimpDraw = ^TimpDraw;


PimpErase

Pointer to message argument for IM_ERASE or IM_ERASEFRAME

Declaration

Source position: intuition.pas line 3263

type PimpErase = ^TimpErase;


PimpExtent

Declaration

Source position: intuition.pas line 3316

type PimpExtent = ^TimpExtent;


PimpFrameBox

Pointer to message argument for IM_FRAMEBOX

Declaration

Source position: intuition.pas line 3230

type PimpFrameBox = ^TimpFrameBox;


PimpHitTest

Pointer to message argument for IM_HITTEST or IM_HITFRAME

Declaration

Source position: intuition.pas line 3279

type PimpHitTest = ^TimpHitTest;


PIntuiMessage

Pointer to an Intuition message

Declaration

Source position: intuition.pas line 796

type PIntuiMessage = ^TIntuiMessage;

See also

TWindow | Window structure
exec.GetMsg | Get next message from message port
exec.PutMsg | Put a message to a message port
exec.ReplyMsg | Put a message to its reply port
exec.WaitPort | Wait for a given port to be non-empty


PIntuiRawKeyData

Declaration

Source position: intuition.pas line 834

type PIntuiRawKeyData = ^TIntuiRawKeyData;


PIntuiText

IntuiText is a series of strings.

Declaration

Source position: intuition.pas line 45

type PIntuiText = ^TIntuiText;

Description

IntuiText is a series of strings that start with a screen location (always relative to the upper-left corner of something) and then the text of the string. The text is null-terminated.

See also

TGadget | Structure to describe a Gadget
TExtGadget | Extended Gadget structure
TRequester | Requesters The following struct is used for standard intuition requesters
GFLG_LABELITEXT | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText
GA_IntuiText | GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.
AutoRequest | Automatically build and get response from a requester.
BuildSysRequest | Build and display a system requester.
IntuiTextLength | Return the length (pixel-width) of an IntuiText.
PrintIText | Print text described by the IntuiText argument.


PIntuitionBase

Pointer to Intution basic structures

Declaration

Source position: intuition.pas line 2463

type PIntuitionBase = ^TIntuitionBase;

See also

TIntuitionBase

Intuition basic structure


PIntuiWheelData

Declaration

Source position: intuition.pas line 821

type PIntuiWheelData = ^TIntuiWheelData;


PIXEL_DIMENSIONS

Flag for TPreferences.PrintFlags use max width/height as prt pixels

Declaration

Source position: intuition.pas line 2421

const PIXEL_DIMENSIONS = $0040;


PLUGIN_SYSI

Declaration

Source position: intuition.pas line 3713

const PLUGIN_SYSI = 1;


PMenu

Pointer to a menu structure

Declaration

Source position: intuition.pas line 121

type PMenu = ^TMenu;

See also

TWindow | Window structure
ItemAddress | Returns the address of the specified MenuItem.
ResetMenuStrip | Re-attach a menu strip to a window.
SetMenuStrip | Attach a menu strip to a window.


PMenuEventMessage

Declaration

Source position: intuition.pas line 319

type PMenuEventMessage = ^TMenuEventMessage;


PMenuItem

Pointer to an menu item

Declaration

Source position: intuition.pas line 76

type PMenuItem = ^TMenuItem;

See also

TMenu | Structure to describe a menu
ItemAddress | Returns the address of the specified MenuItem.


PMenuScanMessage

Declaration

Source position: intuition.pas line 310

type PMenuScanMessage = ^TMenuScanMessage;


PMenuStringMessage

Declaration

Source position: intuition.pas line 301

type PMenuStringMessage = ^TMenuStringMessage;


PmpDeleteMenu

Declaration

Source position: intuition.pas line 230

type PmpDeleteMenu = ^TmpDeleteMenu;


PmpFindID

Declaration

Source position: intuition.pas line 206

type PmpFindID = ^TmpFindID;


PmpGetState

Declaration

Source position: intuition.pas line 256

type PmpGetState = ^TmpGetState;


PmpHandleEvent

Declaration

Source position: intuition.pas line 271

type PmpHandleEvent = ^TmpHandleEvent;


PmpNewMenu

Declaration

Source position: intuition.pas line 223

type PmpNewMenu = ^TmpNewMenu;


PmpNextChild

Declaration

Source position: intuition.pas line 238

type PmpNextChild = ^TmpNextChild;


PmpNextSelect

Declaration

Source position: intuition.pas line 263

type PmpNextSelect = ^TmpNextSelect;


PmpScan

Declaration

Source position: intuition.pas line 214

type PmpScan = ^TmpScan;


PmpSetState

Declaration

Source position: intuition.pas line 246

type PmpSetState = ^TmpSetState;


PmpSetup

Declaration

Source position: intuition.pas line 280

type PmpSetup = ^TmpSetup;


PMsg

Declaration

Source position: intuition.pas line 35

type PMsg = ^TMsg;

Description

You can use this type to point to a 'generic' message, in the object-oriented programming parlance. Based on the value of MethodID, you dispatch to processing for the various message types. The meaningful parameter packet structure definitions are defined below.

See also

DoGadgetMethodA

Invoke method on a boopsi gadget.


PNewScreen

pointer to an instance of a NewScreen structure.

Declaration

Source position: intuition.pas line 2122

type PNewScreen = ^TNewScreen;


PNewWindow

Pointer to structure describes a new window

Declaration

Source position: intuition.pas line 1094

type PNewWindow = ^TNewWindow;

See also

OpenWindow | Open an Intuition window.
OpenWindowTagList | OpenWindow() with TagItem extension.


PObject_

Pointer to an BOOPSI Object / Classe / Message Handle

Declaration

Source position: intuition.pas line 27

type PObject_ = ^LongWord;


POINTERA_BitMap

PointerClass Attribute. (PBitmap) Pointer to bitmap to get pointer imagery from. Bitplane data need not be in chip RAM.

Declaration

Source position: intuition.pas line 3347

const POINTERA_BitMap = POINTERA_Dummy + $01;


POINTERA_Dummy

PointerClass Attributes start.

Declaration

Source position: intuition.pas line 3346

const POINTERA_Dummy = TAG_USER + $39000;


POINTERA_Height

Declaration

Source position: intuition.pas line 3355

const POINTERA_Height = POINTERA_Dummy + $09;


POINTERA_ImageData

Declaration

Source position: intuition.pas line 3353

const POINTERA_ImageData = POINTERA_Dummy + $07;


POINTERA_Width

Declaration

Source position: intuition.pas line 3354

const POINTERA_Width = POINTERA_Dummy + $08;


POINTERA_WordWidth

PointerClass Attribute. (LongWord) - designed width of the pointer in words

Declaration

Source position: intuition.pas line 3350

const POINTERA_WordWidth = POINTERA_Dummy + $04;


POINTERA_XOffset

PointerClass Attribute. (LongInt) - X-offset of the pointer hotspot.

Declaration

Source position: intuition.pas line 3348

const POINTERA_XOffset = POINTERA_Dummy + $02;


POINTERA_XResolution

PointerClass Attribute. (LongWord) - one of the POINTERXRESN_* flags

Declaration

Source position: intuition.pas line 3351

const POINTERA_XResolution = POINTERA_Dummy + $05;


POINTERA_YOffset

PointerClass Attribute. (LongInt) - Y-offset of the pointer hotspot.

Declaration

Source position: intuition.pas line 3349

const POINTERA_YOffset = POINTERA_Dummy + $03;


POINTERA_YResolution

PointerClass Attribute. (LongWord) - one of the POINTERYRESN_* flags

Declaration

Source position: intuition.pas line 3352

const POINTERA_YResolution = POINTERA_Dummy + $06;


POINTERCLASS

Class identifier

Declaration

Source position: intuition.pas line 2538

const POINTERCLASS: PChar = 'pointerclass';

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


POINTERSIZE

Size of Pointer data buffer for printer configuration

Declaration

Source position: intuition.pas line 2227

const POINTERSIZE = (1 + 16 + 1) * (2);


POINTERTYPE_ALIAS

Declaration

Source position: intuition.pas line 3380

const POINTERTYPE_ALIAS = 2;


POINTERTYPE_BUSY

Declaration

Source position: intuition.pas line 3379

const POINTERTYPE_BUSY = 1;


POINTERTYPE_CELL

Declaration

Source position: intuition.pas line 3381

const POINTERTYPE_CELL = 3;


POINTERTYPE_COLUMNRESIZE

Declaration

Source position: intuition.pas line 3382

const POINTERTYPE_COLUMNRESIZE = 4;


POINTERTYPE_CONTEXTMENU

Declaration

Source position: intuition.pas line 3383

const POINTERTYPE_CONTEXTMENU = 5;


POINTERTYPE_COPY

Declaration

Source position: intuition.pas line 3384

const POINTERTYPE_COPY = 6;


POINTERTYPE_COUNT

Declaration

Source position: intuition.pas line 3418

const POINTERTYPE_COUNT = 40;


POINTERTYPE_CROSS

Declaration

Source position: intuition.pas line 3385

const POINTERTYPE_CROSS = 7;


POINTERTYPE_DRAGANDDROP

Declaration

Source position: intuition.pas line 3386

const POINTERTYPE_DRAGANDDROP = 8;


POINTERTYPE_EASTRESIZE

Declaration

Source position: intuition.pas line 3387

const POINTERTYPE_EASTRESIZE = 9;


POINTERTYPE_EASTWESTRESIZE

Declaration

Source position: intuition.pas line 3388

const POINTERTYPE_EASTWESTRESIZE = 10;


POINTERTYPE_HAND

Declaration

Source position: intuition.pas line 3389

const POINTERTYPE_HAND = 11;


POINTERTYPE_HELP

Declaration

Source position: intuition.pas line 3390

const POINTERTYPE_HELP = 12;


POINTERTYPE_LINK

Declaration

Source position: intuition.pas line 3391

const POINTERTYPE_LINK = 13;


POINTERTYPE_MENU

Declaration

Source position: intuition.pas line 3392

const POINTERTYPE_MENU = 14;


POINTERTYPE_NODROP

Declaration

Source position: intuition.pas line 3393

const POINTERTYPE_NODROP = 15;


POINTERTYPE_NONE

Declaration

Source position: intuition.pas line 3394

const POINTERTYPE_NONE = 16;


POINTERTYPE_NORMAL

Declaration

Source position: intuition.pas line 3378

const POINTERTYPE_NORMAL = 0;


POINTERTYPE_NORTHEASTRESIZE

Declaration

Source position: intuition.pas line 3395

const POINTERTYPE_NORTHEASTRESIZE = 17;


POINTERTYPE_NORTHEASTSOUTHWESTRESIZE

Declaration

Source position: intuition.pas line 3396

const POINTERTYPE_NORTHEASTSOUTHWESTRESIZE = 18;


POINTERTYPE_NORTHRESIZE

Declaration

Source position: intuition.pas line 3397

const POINTERTYPE_NORTHRESIZE = 19;


POINTERTYPE_NORTHSOUTHRESIZE

Declaration

Source position: intuition.pas line 3398

const POINTERTYPE_NORTHSOUTHRESIZE = 20;


POINTERTYPE_NORTHWESTRESIZE

Declaration

Source position: intuition.pas line 3399

const POINTERTYPE_NORTHWESTRESIZE = 21;


POINTERTYPE_NORTHWESTSOUTHEASTRESIZE

Declaration

Source position: intuition.pas line 3400

const POINTERTYPE_NORTHWESTSOUTHEASTRESIZE = 22;


POINTERTYPE_NOTALLOWED

Declaration

Source position: intuition.pas line 3401

const POINTERTYPE_NOTALLOWED = 23;


POINTERTYPE_PEN

Declaration

Source position: intuition.pas line 3413

const POINTERTYPE_PEN = 35;


POINTERTYPE_PROGRESS

Declaration

Source position: intuition.pas line 3402

const POINTERTYPE_PROGRESS = 24;


POINTERTYPE_ROTATE

Declaration

Source position: intuition.pas line 3414

const POINTERTYPE_ROTATE = 36;


POINTERTYPE_ROWRESIZE

Declaration

Source position: intuition.pas line 3403

const POINTERTYPE_ROWRESIZE = 25;


POINTERTYPE_RUBBER

Declaration

Source position: intuition.pas line 3415

const POINTERTYPE_RUBBER = 37;


POINTERTYPE_SCROLLALL

Declaration

Source position: intuition.pas line 3404

const POINTERTYPE_SCROLLALL = 26;


POINTERTYPE_SELECT

Declaration

Source position: intuition.pas line 3416

const POINTERTYPE_SELECT = 38;


POINTERTYPE_SMUDGE

Declaration

Source position: intuition.pas line 3417

const POINTERTYPE_SMUDGE = 39;


POINTERTYPE_SOUTHEASTRESIZE

Declaration

Source position: intuition.pas line 3405

const POINTERTYPE_SOUTHEASTRESIZE = 27;


POINTERTYPE_SOUTHRESIZE

Declaration

Source position: intuition.pas line 3406

const POINTERTYPE_SOUTHRESIZE = 28;


POINTERTYPE_SOUTHWESTRESIZE

Declaration

Source position: intuition.pas line 3407

const POINTERTYPE_SOUTHWESTRESIZE = 29;


POINTERTYPE_TEXT

Declaration

Source position: intuition.pas line 3408

const POINTERTYPE_TEXT = 30;


POINTERTYPE_VERTICALTEXT

Declaration

Source position: intuition.pas line 3409

const POINTERTYPE_VERTICALTEXT = 31;


POINTERTYPE_WESTRESIZE

Declaration

Source position: intuition.pas line 3410

const POINTERTYPE_WESTRESIZE = 32;


POINTERTYPE_ZOOMIN

Declaration

Source position: intuition.pas line 3411

const POINTERTYPE_ZOOMIN = 33;


POINTERTYPE_ZOOMOUT

Declaration

Source position: intuition.pas line 3412

const POINTERTYPE_ZOOMOUT = 34;


POINTERXRESN_35NS

Value for POINTERA_XResolution (pointer always in 35 ns pixels) = 35 ns always

Declaration

Source position: intuition.pas line 3362

const POINTERXRESN_35NS = 3;


POINTERXRESN_70NS

Value for POINTERA_XResolution (pointer always in 70 ns pixels) = 70 ns always

Declaration

Source position: intuition.pas line 3361

const POINTERXRESN_70NS = 2;


POINTERXRESN_140NS

Value for POINTERA_XResolution (pointer always in 140 ns pixels) = 140 ns always

Declaration

Source position: intuition.pas line 3360

const POINTERXRESN_140NS = 1;


POINTERXRESN_DEFAULT

Value for POINTERA_XResolution (ECS-compatible pointer width) = 70 ns if SUPERHIRES-type mode, 140 ns if not

Declaration

Source position: intuition.pas line 3359

const POINTERXRESN_DEFAULT = 0;


POINTERXRESN_HIRES

Value for POINTERA_XResolution (pointer always in hires-like pixels) = 70 ns in 15kHz modes, 35 ns in 31kHz modes

Declaration

Source position: intuition.pas line 3366

const POINTERXRESN_HIRES = 6;


POINTERXRESN_LORES

Value for POINTERA_XResolution (pointer always in lores-like pixels) = 140 ns in 15kHz modes, 70 ns in 31kHz modes

Declaration

Source position: intuition.pas line 3365

const POINTERXRESN_LORES = 5;


POINTERXRESN_SCREENRES

Value for POINTERA_XResolution Same as pixel speed of screen

Declaration

Source position: intuition.pas line 3364

const POINTERXRESN_SCREENRES = 4;


POINTERYRESN_DEFAULT

Value for POINTERA_YResolution Default pointer

Declaration

Source position: intuition.pas line 3370

const POINTERYRESN_DEFAULT = 0;

Description

In 15 kHz modes, the pointer resolution will be the same as a non-interlaced screen. In 31 kHz modes, the pointer will be doubled vertically. This means there will be about 200-256 pointer lines per screen.


POINTERYRESN_HIGH

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 3372

const POINTERYRESN_HIGH = 2;


POINTERYRESN_HIGHASPECT

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 3373

const POINTERYRESN_HIGHASPECT = 3;

Description

Where the hardware/software supports it, the pointer resolution will be high. This means there will be about 400-480 pointer lines per screen. When the pointer comes out double-height due to hardware/software restrictions, its width would be doubled as well, if possible (to preserve aspect).


POINTERYRESN_SCREENRES

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 3374

const POINTERYRESN_SCREENRES = 4;

Description

Will attempt to match the vertical resolution of the pointer to the screen's vertical resolution.


POINTERYRESN_SCREENRESASPECT

Value for POINTERA_YResolution Highres pointer

Declaration

Source position: intuition.pas line 3375

const POINTERYRESN_SCREENRESASPECT = 5;

Description

Will attempt to match the vertical resolution of the pointer to the screen's vertical resolution. When the pointer comes out double-height due to hardware/software restrictions, its width would be doubled as well, if possible (to preserve aspect).


POINTREL

Flag for TRequester.Flags. If set TopLeft is relative to pointer to the coordinates of either the pointer or the window.

Declaration

Source position: intuition.pas line 747

const POINTREL = $0001;


PopAddTail

Pointer to message structure for OM_ADDTAIL

Declaration

Source position: intuition.pas line 2594

type PopAddTail = ^TopAddTail;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


PopGet

Pointer to message structure for OM_GET

Declaration

Source position: intuition.pas line 2586

type PopGet = ^TopGet;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


PopMember

Pointer to message structure for OM_ADDMEMBER/OM_REMMEMBER

Declaration

Source position: intuition.pas line 2602

type PopMember = ^TopMember;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


POPPUBSCREEN

Pub screen mode. pop pub screen to front when visitor opens

Declaration

Source position: intuition.pas line 2182

const POPPUBSCREEN = $0002;


PopSet

Pointer to message structure for OM_NEW/OM_SET

Declaration

Source position: intuition.pas line 2559

type PopSet = ^TopSet;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


PopUpdate

Pointer to message structure for OM_NOTIFY/OM_UPDATE

Declaration

Source position: intuition.pas line 2567

type PopUpdate = ^TopUpdate;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


POPUPIMAGE

Declaration

Source position: intuition.pas line 3154

const POPUPIMAGE = $13;


PPGX

Pointer to System private data structure for now prop gadget extra info

Declaration

Source position: intuition.pas line 2510

type PPGX = ^TPGX;


PPObject_

Pointer to an BOOPSI Object / Classe / Message Pointer Handle

Declaration

Source position: intuition.pas line 28

type PPObject_ = ^PObject_;


PPreferences

Pointer to old style Preferences

Declaration

Source position: intuition.pas line 2237

type PPreferences = ^TPreferences;

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetPrefs | Get the current Intuition Preferences structure.
SetPrefs | Set Intuition preferences data.


PPropInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_PROPGADGET

Declaration

Source position: intuition.pas line 647

type PPropInfo = ^TPropInfo;


PPubScreenNode

Pointer to Public Shared Screen Node

Declaration

Source position: intuition.pas line 2165

type PPubScreenNode = ^TPubScreenNode;


PREDRAWN

Flag for TRequester.Flags. If set, ImageBMap points to a custom bitmap.

Declaration

Source position: intuition.pas line 748

const PREDRAWN = $0002;


PRemember

Pointer to Memory allocating remember structure

Declaration

Source position: intuition.pas line 1767

type PRemember = ^TRemember;

See also

AllocRemember | Allocate Memory with tracking to make freeing easy.
FreeRemember | Free memory allocated by calls to AllocRemember().


PRenderMsg

Declaration

Source position: intuition.pas line 403

type PRenderMsg = ^TRenderMsg;


PRequester

Requesters The following struct is used for standard intuition requesters

Declaration

Source position: intuition.pas line 719

type PRequester = ^TRequester;

Description

not to be mixed up with asl or easy requesters. See Request() for more information.

See also

TWindow | Window structure
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
ActivateGadget | Activate a (string or custom) gadget.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
EndRequest | Remove a currently active requester.
InitRequester | Initialize a Requester structure.
ModifyProp | Modify the current parameters of a proportional gadget.
NewModifyProp | ModifyProp(), but with selective refresh.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
Request | Activate a requester.
SetDMRequest | Set the DMRequest of a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.


PROPBORDERLESS

Flag value for TPropInfo.Flags. if set, no border will be rendered

Declaration

Source position: intuition.pas line 682

const PROPBORDERLESS = $0008;


PROPGCLASS

Class identifier. An easy to implement, horizontal or vertical proportional gadget.

Declaration

Source position: intuition.pas line 2529

const PROPGCLASS: PChar = 'propgclass';

Description

SuperClass: gadgetclass

A Boopsi proportional ("prop") gadget. The Boopsi prop gadget is similar to the conventional prop gadget, but extends its function to make it easier to use. The Boopsi prop gadget keeps its current integer value in its PGA_Top attribute.

Changed Methods:

GM_HANDLEINPUT

Attributes:

GA_Image (I)

GA_Border (I)

GA_Highlight (I)

PGA_Freedom (IG)

PGA_Top (ISGNU)

PGA_NewLook (I)

PGA_Visible (ISU)

PGA_Total (ISU)

PGA_Borderless (I)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


PROPNEWLOOK

Flag value for TPropInfo.Flags. set this if you want to get the new look

Declaration

Source position: intuition.pas line 684

const PROPNEWLOOK = $0010;


PScreen

Declaration

Source position: intuition.pas line 935

type PScreen = ^TScreen;


PScreenBuffer

Pointer to screen buffer

Declaration

Source position: intuition.pas line 2210

type PScreenBuffer = ^TScreenBuffer;

See also

AGraphics.AllocDBufInfo | Allocate structure for multi-buffered animation
AllocScreenBuffer | Get a ScreenBuffer for double-buffering.


PScreenNotifyMessage

Declaration

Source position: intuition.pas line 369

type PScreenNotifyMessage = ^TScreenNotifyMessage;


PScrollHook

Declaration

Source position: intuition.pas line 1374

type PScrollHook = ^TScrollHook;


PScrollMsg

Declaration

Source position: intuition.pas line 1383

type PScrollMsg = ^TScrollMsg;


PSGWork

Pointer to String gadget message

Declaration

Source position: intuition.pas line 3434

type PSGWork = ^TSGWork;


PSNF_PRIVATE

Flag for TPubScreenNode.psn_Flags Private

Declaration

Source position: intuition.pas line 2177

const PSNF_PRIVATE = $0001;


PStringExtend

Extended string info for Gadgets texts

Declaration

Source position: intuition.pas line 3421

type PStringExtend = ^TStringExtend;

See also

GFLG_STRINGEXTEND | Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend
GACT_STRINGEXTEND | Activation flag for TGadget.Activation. this String Gadget has PStringExtend
TStringInfo | String Gadget structure


PStringInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_STRGADGET

Declaration

Source position: intuition.pas line 694

type PStringInfo = ^TStringInfo;


PSubStyle

Declaration

Source position: intuition.pas line 3689

type PSubStyle = ^TSubStyle;


PSysIPlugin

Declaration

Source position: intuition.pas line 3695

type PSysIPlugin = ^TSysIPlugin;


PTabletData

Pointer to a IntuiMessage TabletData

Declaration

Source position: intuition.pas line 1339

type PTabletData = ^TTabletData;

Description

If your window sets WA_TabletMessages to True, then it will receive extended IntuiMessages (TExtIntuiMessage) whose .eim_TabletData field points at a TabletData structure. This structure contains additional information about the input event.

See also

TExtIntuiMessage

Extended Intuition message structure


PTabletHookData

Declaration

Source position: intuition.pas line 1353

type PTabletHookData = ^TTabletHookData;


PTBGadgetData

Declaration

Source position: intuition.pas line 3788

type PTBGadgetData = ^TTBGadgetData;


PUBLICSCREEN_F

Screentype flag for TScreen.Flags and TNewScreen.SType.

Declaration

Source position: intuition.pas line 2007

const PUBLICSCREEN_F = $0002;


PVector

Declaration

Source position: intuition.pas line 3568

type PVector = ^TVector;


PVectorInfo

Declaration

Source position: intuition.pas line 3578

type PVectorInfo = ^TVectorInfo;


PWindow

Declaration

Source position: intuition.pas line 936

type PWindow = ^TWindow;


QUME_LP_20

Value for TPreferences.PrinterType

Declaration

Source position: intuition.pas line 2385

const QUME_LP_20 = $0A;


Unit 'intuition' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

RCB_OK

Declaration

Source position: intuition.pas line 399

const RCB_OK = 0;


RCB_UNKNOWN

Declaration

Source position: intuition.pas line 400

const RCB_UNKNOWN = 1;


RECOVERY_ALERT

Alert Type for DisplayAlert() the system can recover from this

Declaration

Source position: intuition.pas line 1872

const RECOVERY_ALERT = $00000000;


REQACTIVE

Flag for TRequester.Flags. Read-Only. This requester is active

Declaration

Source position: intuition.pas line 757

const REQACTIVE = $2000;


REQOFFWINDOW

Flag for TRequester.Flags. Read-Only. Part of one of the Gadgets was offwindow

Declaration

Source position: intuition.pas line 756

const REQOFFWINDOW = $1000;


REQPOS_BELOWBAR

Declaration

Source position: intuition.pas line 1811

const REQPOS_BELOWBAR = 2;


REQPOS_CENTERMOUSE

Declaration

Source position: intuition.pas line 1812

const REQPOS_CENTERMOUSE = 3;


REQPOS_CENTERSCREEN

Declaration

Source position: intuition.pas line 1813

const REQPOS_CENTERSCREEN = 4;


REQPOS_CENTERWINDOW

Declaration

Source position: intuition.pas line 1814

const REQPOS_CENTERWINDOW = 5;


REQPOS_CORNER

Declaration

Source position: intuition.pas line 1810

const REQPOS_CORNER = 1;


REQPOS_DEFAULT

Declaration

Source position: intuition.pas line 1809

const REQPOS_DEFAULT = 0;


RESCOUNT

Declaration

Source position: intuition.pas line 2445

const RESCOUNT = 2;


RESERVEDPEN

Declaration

Source position: intuition.pas line 1984

const RESERVEDPEN = $0025;


RIGHTIMAGE

SYSIA_Which tag data values. Right-arrow gadget image

Declaration

Source position: intuition.pas line 3145

const RIGHTIMAGE = $0C;


ROOTCLASS

Root Class identifier, This is the universal base class for all other classes.

Declaration

Source position: intuition.pas line 2523

const ROOTCLASS: PChar = 'rootclass';

Description

All Classes are descendants of the rootclass. There are three primary classes that descend directly from rootclass: imageclass, gadgetclass, and icclass.

SuperClass: None

New Methods:

OM_NEW, OM_ADDTAIL, OM_DISPOSE, OM_REMOVE

The following methods are described at the rootclass level although its up to the subclasses to actually implement them. If a class does not implement these methods, it should either return zero, indicating that this class does not support the method, or defer processing on to its superclass.

OM_ADDMEMBER, OM_GET, OM_UPDATE, OM_REMMEMBER, OM_SET, OM_NOTIFY

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


SA_ActiveWindow

Declaration

Source position: intuition.pas line 2095

const SA_ActiveWindow = SA_Dummy + $002c;


SA_AutoScroll

Tag start for OpenScreenTagList() boolean equivalent to flag AUTOSCROLL

Declaration

Source position: intuition.pas line 2055

const SA_AutoScroll = SA_Dummy + $0019;

Description

Setting this flag will enable autoscroll for this screen when it is the active screen. (Currently, the screen may only be made active by activating a window in that screen either under user or application control.) Data is a boolean value (True to set flag). This tag is equivalent to the AUTOSCROLL flag of the TNewScreen.SType field.

Autoscroll means that screens larger than the visible display will automatically scroll when the user moves the mouse to the edge of the screen. Without this tag, the user moves the screen either by using the screen drag bar, or by pressing the mouse select button anywhere within the screen while holding down the left Amiga key and moving the mouse.


SA_BackChild

Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the back of its family.

Declaration

Source position: intuition.pas line 2084

const SA_BackChild = SA_Dummy + $0026;


SA_BackFill

Tag start for OpenScreenTagList() provides a "backfill hook" for your screen's TLayer_Info. See Layers.InstallLayerInfoHook()

Declaration

Source position: intuition.pas line 2073

const SA_BackFill = SA_Dummy + $0021;


SA_Behind

Tag start for OpenScreenTagList() boolean equivalent to flag SCREENBEHIND_f

Declaration

Source position: intuition.pas line 2053

const SA_Behind = SA_Dummy + $0017;

Description

Open this screen behind all other screens in the system. Data is a boolean value (True to set flag). This tag is equivalent to the SCREENBEHIND_f flag of the NewScreen.Type field.


SA_BitMap

Tag start for OpenScreenTagList() ti_Data is pointer to custom BitMap. This implies TNewScreen.SType of CUSTOMBITMAP_f

Declaration

Source position: intuition.pas line 2040

const SA_BitMap = SA_Dummy + $000E;

Description

Use a custom bitmap for this screen. Data is a AGraphics.PBitMap. This tag is equivalent to TNewScreen.CustomBitMap and implies the CUSTOMBITMAP_f flag of the NewScreen.Type field. The application is responsible for allocating and freeing the screen's bitmap.


SA_BlockPen

Tag start for OpenScreenTagList() serves as default for windows, too

Declaration

Source position: intuition.pas line 2033

const SA_BlockPen = SA_Dummy + $0007;

Description

Block pen for the screen. Data is a long, unsigned value. Used for rendering block fills in the screen title bar and menus. Use SA_Pens for more control of pen specification. If SA_Pens is not specified, the screen will not get the new 3D look and this value will be used as the block pen.


SA_ColorMapEntries

Tag start for OpenScreenTagList() Allows you to override the number of entries in the ColorMap for your screen.

Declaration

Source position: intuition.pas line 2059

const SA_ColorMapEntries = SA_Dummy + $001C;

Description

Intuition normally allocates ((1 shl depth) or 32), whichever is more, but you may require even more if you use certain graphics.library features (eg. palette-banking).


SA_Colors

Tag start for OpenScreenTagList() ti_Data is an array of TColorSpec, terminated by ColorIndex = -1. Specifies initial screen palette colors.

Declaration

Source position: intuition.pas line 2035

const SA_Colors = SA_Dummy + $0009;

Description

Specifies initial screen palette colors. Data is a pointer to an array of TColorSpec structures, terminated by a ColorSpec structure with ColorIndex=-1. Screen colors may be changed after the screen is opened with the graphics library functions SetRGB4() and LoadRGB4(). ColorSpec colors are right-justified, four bits per gun.


SA_Colors32

Tag start for OpenScreenTagList() set the screen's initial palette colors at 32 bits-per-gun.

Declaration

Source position: intuition.pas line 2076

const SA_Colors32 = SA_Dummy + $0023;

Description

ti_Data is a pointer to a table to be passed to the LoadRGB32() function. This format supports both runs of color registers and sparse registers. See the autodoc for that function for full details. Any color set here has precedence over the same register set by SA_Colors.


SA_Compositing

Declaration

Source position: intuition.pas line 2098

const SA_Compositing = SA_Dummy + $002f;


SA_DClip

Tag start for OpenScreenTagList() ti_Data points to a rectangle which defines screen display clip region

Declaration

Source position: intuition.pas line 2045

const SA_DClip = SA_Dummy + $0013;

Description

Custom display clip specification. Data is a pointer to a Rectangle structure that defines the screen display clip region.


SA_Depth

Tag start for OpenScreenTagList() Screen bitmap depth

Declaration

Source position: intuition.pas line 2031

const SA_Depth = SA_Dummy + $0005;

Description

Screen bitmap depth. Data is a LongWord. The depth of the screen determines the number of available colors. Do not set the depth to a value greater than that supported by the specific display mode. This information is available to the application through the graphics library display database. The default is one bitplane.


SA_DetailPen

Tag start for OpenScreenTagList() serves as default for windows, too

Declaration

Source position: intuition.pas line 2032

const SA_DetailPen = SA_Dummy + $0006;

Description

Detail pen for the screen. Data is a long, unsigned value. Used for rendering details in the screen title bar and menus. Use SA_Pens for more control of pen specification. If SA_Pens is not specified, the screen will not get the new 3D look of Intuition. Instead this value will be used as the detail pen.


SA_DisplayID

Tag start for OpenScreenTagList() ti_Data is new extended display ID

Declaration

Source position: intuition.pas line 2044

const SA_DisplayID = SA_Dummy + $0012;


SA_Draggable

Tag start for OpenScreenTagList() Boolean tag allowing non-draggable screens. Do not use without good reason! (Defaults to True).

Declaration

Source position: intuition.pas line 2064

const SA_Draggable = SA_Dummy + $001E;


SA_Dummy

Tag start for OpenScreenTagList() Tags

Declaration

Source position: intuition.pas line 2025

const SA_Dummy = TAG_USER + 32;


SA_ErrorCode

Tag start for OpenScreenTagList() ti_Data points to LongInt error code

Declaration

Source position: intuition.pas line 2036

const SA_ErrorCode = SA_Dummy + $000A;

Description

Extended error code. Data is a pointer to a LongInt which will contain the error code on return if OpenScreenTagList() returns nil. The error codes are described above.


SA_Exclusive

Tag start for OpenScreenTagList() Boolean tag allowing screens that won't share the display. (Defaults to False)

Declaration

Source position: intuition.pas line 2066

const SA_Exclusive = SA_Dummy + $001F;

Description

Use sparingly! Attached screens may be SA_Exclusive. Setting SA_Exclusive for each screen will produce an exclusive family.


SA_Font

Tag start for OpenScreenTagList() equiv. to TNewScreen.Font

Declaration

Source position: intuition.pas line 2037

const SA_Font = SA_Dummy + $000B;

Description

Data is a pointer to a AGraphics.TTextAttr structure which specifies the font, size and style to use for the screen. Equivalent to TNewScreen.Font.


SA_FrontChild

Tag start for OpenScreenTagList() Pointer to an already open screen that is to be the child of the screen being opened. The child screen will be moved to the front of its family.

Declaration

Source position: intuition.pas line 2082

const SA_FrontChild = SA_Dummy + $0025;


SA_FullPalette

Tag start for OpenScreenTagList() boolean: initialize color table to entire preferences palette, rather than compatible pens 0-3, 17-19, with remaining palette as returned by GetColorMap()

Declaration

Source position: intuition.pas line 2057

const SA_FullPalette = SA_Dummy + $001B;


SA_Height

Tag start for OpenScreenTagList() eqivalent to TNewWindow.Height

Declaration

Source position: intuition.pas line 2030

const SA_Height = SA_Dummy + $0004;

Description

Screen dimensions. Data is a LongWord. These may be larger, smaller or the same as the dimensions of the display clip Rectangle. The use of STDSCREENWIDTH will make the screen size equal to the display clip size.

To calculate the width of the display clip Rectangle, subtract the MinX value from the MaxX value plus one. Similarly, the height of the display clip may be calculated by subtracting the MinY value from the MaxY value plus one.


SA_Interleaved

Tag start for OpenScreenTagList() Boolean tag requesting that the bitmap allocated for you be interleaved. (Defaults to False).

Declaration

Source position: intuition.pas line 2075

const SA_Interleaved = SA_Dummy + $0022;


SA_Left

Tag start for OpenScreenTagList() eqivalent to TNewWindow.LeftEdge

Declaration

Source position: intuition.pas line 2027

const SA_Left = SA_Dummy + $0001;

Description

Initial screen position (left edge). Data is a LongInt, signed value. Offsets are relative to the text overscan rectangle.

If SA_Left is not specified and a TNewWindow structure is not passed in the OpenScreenTagList() call and SA_Width is not specified or is specified as STDSCREENWIDTH, then the left edge of the screen will default to the left edge of the actual display clip of the screen. If the other conditions are met but some explicit SA_Width is specified, then the left edge defaults to zero (text overscan rectangle left edge). Likewise, the top edge may, independent of the left edge value, default to zero or to the top edge of the actual display clip.

When opening a full sized overscan screen, SA_Left should be set to the MinX value of the display clip Rectangle used for the screen and This may be taken from the defaults, as explained above, or explicitly set by the application.

If your screen is larger than your display clip, you may wish to set the SA_Left to a value less than your display clip MinX in order to center a large screen on a smaller display.


SA_LikeWorkbench

Tag start for OpenScreenTagList() 1 = request a screen which is just like the Workbench. This gives you the same screen mode, depth, size, colors, etc., as the Workbench screen.

Declaration

Source position: intuition.pas line 2086

const SA_LikeWorkbench = SA_Dummy + $0027;


SA_MaxWindowBox

Declaration

Source position: intuition.pas line 2096

const SA_MaxWindowBox = SA_Dummy + $002d;


SA_MinimizeISG

Tag start for OpenScreenTagList() inter-screen gap is at least three non-interlaced lines

Declaration

Source position: intuition.pas line 2089

const SA_MinimizeISG = SA_Dummy + $0029;

Description

For compatibility, Intuition always ensures that the inter-screen gap is at least three non-interlaced lines. If your application would look best with the smallest possible inter-screen gap, set ti_Data to True. If you use the VideoControl() VC_NoColorPaletteLoad tag for your screen's ViewPort, you should also set this tag.


SA_Obsolete1

Declaration

Source position: intuition.pas line 2050

const SA_Obsolete1 = SA_Dummy + $0015;


SA_OffScreenDragging

Declaration

Source position: intuition.pas line 2093

const SA_OffScreenDragging = SA_Dummy + $002a;


SA_Overscan

Tag start for OpenScreenTagList() Set Overscan defaults to OSCAN_TEXT

Declaration

Source position: intuition.pas line 2046

const SA_Overscan = SA_Dummy + $0014;

Description

Set to one of the OSCAN_* specifiers to get a system standard verscan region for your display clip, screen dimensions (unless otherwise specified), and automatically centered position (partial support only so far). If you use this, you shouldn't specify SA_DClip. SA_Overscan is for "standard" overscan dimensions, SA_DClip is for your custom numeric specifications.


SA_Parent

Tag start for OpenScreenTagList() Pointer to a "parent" screen to attach this one to. Attached screens slide and depth-arrange together.

Declaration

Source position: intuition.pas line 2062

const SA_Parent = SA_Dummy + $001D;


SA_Pens

Tag start for OpenScreenTagList() pointer to $FFFFFFFF terminated LongWord array, as found in TDrawInfo

Declaration

Source position: intuition.pas line 2056

const SA_Pens = SA_Dummy + $001A;

Description

Pen specification for the screen. Data is a pointer to a LongWord array terminated with $FFFFFFFF, as found in the DrawInfo structure. Specifying the SA_Pens tag informs the system that the application is prepared to handle a screen rendered with the new 3D look of Intuition. Omitting this tag produces a screen with a flat look, but whose color usage is more backwards compatible.


SA_PubName

Tag start for OpenScreenTagList() Presence of this tag means that the screen is to be a public screen. Please specify before SA_PubSig and SA_PubTask

Declaration

Source position: intuition.pas line 2041

const SA_PubName = SA_Dummy + $000F;

Description

Presence of this tag means that the screen is to be a public screen. Data is a PChar. The string is the name of the public screen which is used by other applications to find the screen. This tag is order dependent, specify before SA_PubSig and SA_PubTask.


SA_PubSig

Tag start for OpenScreenTagList()

Declaration

Source position: intuition.pas line 2042

const SA_PubSig = SA_Dummy + $0010;

Description

Signal for notification that the last window has closed on a public screen. Data is a LongWord. This tag is order dependent, and must be specified after the tag SA_PubName.


SA_PubTask

Tag start for OpenScreenTagList() Task ID and signal for being notified that the last window has closed on a public screen.

Declaration

Source position: intuition.pas line 2043

const SA_PubTask = SA_Dummy + $0011;

Description

Task (returned by FindTask()) notification that the last window has closed on a public screen. Data is a long, unsigned value. Data is a pointer to a exec.TTask structure. This tag is order dependent, and must be specified after the tag SA_PubName.


SA_Quiet

Tag start for OpenScreenTagList() boolean equivalent to flag SCREENQUIET_f

Declaration

Source position: intuition.pas line 2054

const SA_Quiet = SA_Dummy + $0018;

Description

Disable Intuition rendering into screen. Data is a boolean value (True to set flag). This tag is equivalent to the SCREENQUIET_f flag of the TNewScreen.SType field. The screen will have no visible title bar or gadgets, but dragging and depth arrangement still function. In order to completely prevent Intuition from rendering into the screen, menu operations must be disabled for each window in the screen using WFLG_RMBTRAP.


SA_Reserved

Tag start for OpenScreenTagList() Reserved for private Intuition use

Declaration

Source position: intuition.pas line 2088

const SA_Reserved = SA_Dummy + $0028;


SA_Reserved2

Declaration

Source position: intuition.pas line 2094

const SA_Reserved2 = SA_Dummy + $002b;


SA_Reserved3

Declaration

Source position: intuition.pas line 2097

const SA_Reserved3 = SA_Dummy + $002e;


SA_SharePens

Tag start for OpenScreenTagList() Allocate pens as shared

Declaration

Source position: intuition.pas line 2069

const SA_SharePens = SA_Dummy + $0020;

Description

For those pens in the screen's DrawInfo^.dri_Pens, Intuition obtains them in shared mode (see ObtainPen()). For compatibility, Intuition obtains the other pens of a public screen as PEN_EXCLUSIVE. Screens that wish to manage the pens themselves should generally set this tag to True. This instructs Intuition to leave the other pens unallocated.


SA_ShowTitle

Tag start for OpenScreenTagList() boolean equivalent to flag SHOWTITLE

Declaration

Source position: intuition.pas line 2052

const SA_ShowTitle = SA_Dummy + $0016;

Description

Setting this flag places the screen's title bar in front of any backdrop windows that are opened on the screen. Data is a boolean value (True to set flag). This tag is equivalent to the SHOWTITLE flag of the TNewScreen.SType field. The title bar of the screen is always displayed behind any non-backdrop windows on that screen. This attribute can be changed after the screen is open with the ShowTitle() function.


SA_SysFont

Tag start for OpenScreenTagList() Selects one of the preferences system fonts: 0 - old DefaultFont, fixed-width 1 - WB Screen preferred font

Declaration

Source position: intuition.pas line 2038

const SA_SysFont = SA_Dummy + $000C;

Description

Alternative to SA_Font. Selects one of the preferences system fonts. Data is a LongWord, with the following values defined:

0
Open screen with the user's preferred fixed width font (the default).
1
Open screen with the user's preferred font, which may be proportional.

The Workbench screen is opened with [SA_SysFont, 1]. Table summarizes how the font selected at OpenScreen() time effects subsequent text operations in screens and windows.

 | What you tell OpenScreen() | Screen font | Window.RPort font
A. | TNewScreen.Font = myfont | myfont | myfont
B. | TNewScreen.Font = nil | AGraphics.TGfxBase.DefaultFont | AGraphics.TGfxBase.DefaultFont
C. | [SA_Font, myfont] | myfont | myfont
D. | [SA_SysFont, 0] | AGraphics.TGfxBase.DefaultFont | AGraphics.TGfxBase.DefaultFont
E. | [SA_SysFont, 1] | Font Prefs Screen text | AGraphics.TGfxBase.DefaultFont

Notes:

  • A and B are the options that existed in V34 and earlier OS versions.
  • C and D are tags in Release 2 equivalent to A and B respectively.
  • E is a new option for V36. The Workbench screen uses this option.
  • For `myfont', any font may be used including a proportional one. This is true under all releases of the OS.
  • AGraphics.TGfxBase.DefaultFont is always monospace. (This is the "System Default Text" from Font Preferences.)
  • Font Prefs Screen text (the "Screen Text" choice from Font Preferences) can be monospace or proportional.

The screen's font may not legally be changed after a screen is opened. The menu bar, window titles, menu items, and the contents of a string gadget all use the screen's font. The font used for menu items can be overridden in the menu item's IntuiText structure. Under V36 and higher, the font used in a string gadget can be overridden through the StringExtend structure. The font of the menu bar and window titles cannot be overridden.

The Window.RPort font shown above is the initial font that Intuition sets in your window's RastPort. It is legal to change that subsequently with SetFont(). IntuiText rendered into a window (either through PrintIText() or as a TGadget.GadgetText) defaults to the window's RastPort font, but can be overridden using its TGadget.TITextFont field. Text rendered with the graphics library call GfxText() uses the window's RastPort font.


SA_Title

Tag start for OpenScreenTagList() default screen title

Declaration

Source position: intuition.pas line 2034

const SA_Title = SA_Dummy + $0008;

Description

Default screen title. Data is a pointer to a character string. This is the title displayed when the active window has no screen title or when no window is active on the screen.


SA_Top

Tag start for OpenScreenTagList() eqivalent to TNewWindow.TopEdge

Declaration

Source position: intuition.pas line 2028

const SA_Top = SA_Dummy + $0002;

Description

Initial screen position (top edge). Data is a LongInt, signed value. Offsets are relative to the text overscan rectangle.

If SA_Top is not specified and a TNewWindow structure is not passed in the OpenScreenTagList() call and SA_Width is not specified or specified as STDSCREENHEIGHT, then the top edge of the screen will default to the top edge of the actual display clip of the screen. If the other conditions are met but some explicit SA_Height is specified, then the top edge defaults to zero (text overscan rectangle top edge).

When opening a full sized overscan screen, SA_Top should be set to the MinY value of the display clip. This may be taken from the defaults, as explained above, or explicitly set by the application.

If your screen is larger than your display clip, you may wish to set the SA_Top to a value less than your display clip MinY in order to center a large screen on a smaller display.


SA_Type

Tag start for OpenScreenTagList() equiv. to TNewScreen.SType

Declaration

Source position: intuition.pas line 2039

const SA_Type = SA_Dummy + $000D;

Description

Equivalent to the SCREENTYPE_f bits of the TNewScreen.SType field. Data is a LongWord, which may be set to either CUSTOMSCREEN_f or PUBLICSCREEN_f (WBENCHSCREEN_f is reserved for system use). See the tags SA_BitMap, SA_Behind, SA_Quiet, SA_ShowTitle and SA_AutoScroll for the other attributes of the TNewScreen.SType field.


SA_VideoControl

Tag start for OpenScreenTagList() Pointer to a taglist that Intuition will pass to VideoControl(), upon opening the screen.

Declaration

Source position: intuition.pas line 2080

const SA_VideoControl = SA_Dummy + $0024;


SA_Width

Tag start for OpenScreenTagList() eqivalent to TNewWindow.Width

Declaration

Source position: intuition.pas line 2029

const SA_Width = SA_Dummy + $0003;

Description

Screen dimensions. Data is a LongWord. These may be larger, smaller or the same as the dimensions of the display clip Rectangle. The use of STDSCREENWIDTH will make the screen size equal to the display clip size.

To calculate the width of the display clip Rectangle, subtract the MinX value from the MaxX value plus one. Similarly, the height of the display clip may be calculated by subtracting the MinY value from the MaxY value plus one.


SA_WindowDropShadows

Declaration

Source position: intuition.pas line 2101

const SA_WindowDropShadows = SA_Dummy + $0030;


SB_COPY_BITMAP

Flag for AllocScreenBuffer().

Declaration

Source position: intuition.pas line 2219

const SB_COPY_BITMAP = 2;


SB_SCREEN_BITMAP

Flag for AllocScreenBuffer().

Declaration

Source position: intuition.pas line 2218

const SB_SCREEN_BITMAP = 1;


SBARLOGO

Declaration

Source position: intuition.pas line 3153

const SBARLOGO = $12;


SBUF_512

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 2390

const SBUF_512 = $00;


SBUF_1024

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 2391

const SBUF_1024 = $01;


SBUF_2048

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 2392

const SBUF_2048 = $02;


SBUF_4096

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 2393

const SBUF_4096 = $03;


SBUF_8000

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 2394

const SBUF_8000 = $04;


SBUF_16000

Value for TPreferences.SerStopBuf Lower Nibble

Declaration

Source position: intuition.pas line 2395

const SBUF_16000 = $05;


SBUFSIZE_BITS

Mask for TPreferences.SerStopBuf lower nibble

Declaration

Source position: intuition.pas line 2400

const SBUFSIZE_BITS = $0F;


SC_ARROWGSTYLE

Declaration

Source position: intuition.pas line 3681

const SC_ARROWGSTYLE = 6;


SC_CYCLEGSTYLE

Declaration

Source position: intuition.pas line 3682

const SC_CYCLEGSTYLE = 7;


SC_GADGETGEOMETRY

Declaration

Source position: intuition.pas line 3686

const SC_GADGETGEOMETRY = 11;


SC_GADGETSTYLE

Declaration

Source position: intuition.pas line 3680

const SC_GADGETSTYLE = 5;


SC_GLOBALGEOMETRY

Declaration

Source position: intuition.pas line 3676

const SC_GLOBALGEOMETRY = 1;


SC_GLOBALSTYLE

Declaration

Source position: intuition.pas line 3675

const SC_GLOBALSTYLE = 0;


SC_KHANDLESTYLE

Declaration

Source position: intuition.pas line 3683

const SC_KHANDLESTYLE = 8;


SC_MENUSTYLE

Declaration

Source position: intuition.pas line 3684

const SC_MENUSTYLE = 9;


SC_WINBFRAMESTYLE

Declaration

Source position: intuition.pas line 3678

const SC_WINBFRAMESTYLE = 3;


SC_WINBGADGEOMETRY

Declaration

Source position: intuition.pas line 3685

const SC_WINBGADGEOMETRY = 10;


SC_WINBGADSTYLE

Declaration

Source position: intuition.pas line 3679

const SC_WINBGADSTYLE = 4;


SC_WINBORDERSTYLE

Declaration

Source position: intuition.pas line 3677

const SC_WINBORDERSTYLE = 2;


SCLOSEIMAGE

Declaration

Source position: intuition.pas line 3173

const SCLOSEIMAGE = $25;


SCREEN_DRAG

Declaration

Source position: intuition.pas line 2321

const SCREEN_DRAG = 1 shl 14;


SCREENBEHIND_F

Flag for TScreen.Flags. If you want your screen to open behind already open screens

Declaration

Source position: intuition.pas line 2012

const SCREENBEHIND_F = $0080;


SCREENHIRES

Flag for TScreen.Flags. Do no use lowres gadgets (private)

Declaration

Source position: intuition.pas line 2014

const SCREENHIRES = $0200;


SCREENQUIET_F

Flag for TScreen.Flags. If you do not want Intuition to render into your screen (gadgets, title)

Declaration

Source position: intuition.pas line 2013

const SCREENQUIET_F = $0100;


SCREENSIMAGE

Declaration

Source position: intuition.pas line 3174

const SCREENSIMAGE = $26;


SCREENTYPE_F

Screentype flag for TScreen.Flags and TNewScreen.SType. All Screenstypes available

Declaration

Source position: intuition.pas line 2004

const SCREENTYPE_F = $000F;


SCROLLERGCLASS

Declaration

Source position: intuition.pas line 2534

const SCROLLERGCLASS: PChar = 'scrollergclass';


SDEPTH_CHILDONLY

Declaration

Source position: intuition.pas line 2197

const SDEPTH_CHILDONLY = SDEPTH_INFAMILY;


SDEPTH_INFAMILY

Flag for ScreenDepth(). Move an attached screen with respect to other screens of its family

Declaration

Source position: intuition.pas line 2194

const SDEPTH_INFAMILY = 2;


SDEPTH_TOBACK

Flag for ScreenDepth(). Send screen to back

Declaration

Source position: intuition.pas line 2193

const SDEPTH_TOBACK = 1;


SDEPTH_TOFRONT

Flag for ScreenDepth(). Bring screen to front

Declaration

Source position: intuition.pas line 2192

const SDEPTH_TOFRONT = 0;


SDEPTHIMAGE

SYSIA_Which tag data values. Screen depth gadget image

Declaration

Source position: intuition.pas line 3142

const SDEPTHIMAGE = $05;


SDOWNBACKGADGET

Declaration

Source position: intuition.pas line 2456

const SDOWNBACKGADGET = 6;


SDRAGGADGET

Declaration

Source position: intuition.pas line 2457

const SDRAGGADGET = 7;


SELECTDOWN

RawMouse code for TIntuiMessage.Code. Left Mouse Button down.

Declaration

Source position: intuition.pas line 1885

const SELECTDOWN = IECODE_LBUTTON;


SELECTPEN

Declaration

Source position: intuition.pas line 1977

const SELECTPEN = $001E;


SELECTSHADOWPEN

Declaration

Source position: intuition.pas line 1980

const SELECTSHADOWPEN = $0021;


SELECTSHINEPEN

Declaration

Source position: intuition.pas line 1979

const SELECTSHINEPEN = $0020;


SELECTTEXTPEN

Declaration

Source position: intuition.pas line 1978

const SELECTTEXTPEN = $001F;


SELECTUP

RawMouse code for TIntuiMessage.Code. Left Mouse Button up.

Declaration

Source position: intuition.pas line 1884

const SELECTUP = IECODE_LBUTTON + IECODE_UP_PREFIX;


SERIAL_PRINTER

Value for TPreferences.PrinterPort

Declaration

Source position: intuition.pas line 2325

const SERIAL_PRINTER = $01;


SETTINGSIMAGE

Declaration

Source position: intuition.pas line 3155

const SETTINGSIMAGE = $14;


SG_DEFAULTMAXCHARS

Maximal length of text in StrgClass, if STRINGA_MaxChars is not set.

Declaration

Source position: intuition.pas line 2780

const SG_DEFAULTMAXCHARS = 128;


SG_GADGETBOX

Declaration

Source position: intuition.pas line 3725

const SG_GADGETBOX = 902;


SG_IMAGEBOX

Declaration

Source position: intuition.pas line 3724

const SG_IMAGEBOX = 901;


SGA_BEEP

String Gadget Action Flag in TSGWork.Actions flash the screen for the user

Declaration

Source position: intuition.pas line 3485

const SGA_BEEP = $4;


SGA_END

String Gadget Action Flag in TSGWork.Actions terminate gadget, code in Code field

Declaration

Source position: intuition.pas line 3484

const SGA_END = $2;


SGA_NEXTACTIVE

String Gadget Action Flag in TSGWork.Actions Make next possible gadget active.

Declaration

Source position: intuition.pas line 3489

const SGA_NEXTACTIVE = $20;


SGA_PREVACTIVE

String Gadget Action Flag in TSGWork.Actions Make previous possible gadget active.

Declaration

Source position: intuition.pas line 3490

const SGA_PREVACTIVE = $40;


SGA_REDISPLAY

String Gadget Action Flag in TSGWork.Actions gadget visuals changed

Declaration

Source position: intuition.pas line 3487

const SGA_REDISPLAY = $10;


SGA_REUSE

String Gadget Action Flag in TSGWork.Actions reuse input event

Declaration

Source position: intuition.pas line 3486

const SGA_REUSE = $8;


SGA_USE

String Gadget Action Flag in TSGWork.Actions use contents of TSGWork

Declaration

Source position: intuition.pas line 3483

const SGA_USE = $1;


SGH_CLICK

Function id for only existing custom string gadget edit hook. process mouse click cursor position

Declaration

Source position: intuition.pas line 3493

const SGH_CLICK = 2;

Description

This hook command is called when Intuition wants to position the cursor in response to a mouse click in the string gadget. Again, here are no parameters following the command LongWord. This time, Intuition has already calculated the mouse position character cell and put it in TSGWork.BufferPos. The previous BufferPos value remains in the TSGWork.StringInfo.BufferPos.

Intuition will again use the TSGWork fields listed above for SGH_KEY. One restriction is that you are not allowed to set SGA_END or SGA_REUSE for this command. Intuition will not stand for a gadget which goes inactive when you click in it.

You should always leave the SGA_REDISPLAY flag set, since Intuition uses this processing when activating a string gadget.


SGH_KEY

Function id for only existing custom string gadget edit hook. process editing keystroke

Declaration

Source position: intuition.pas line 3492

const SGH_KEY = 1;

Description

There are no parameters following the command LongWord. Intuition will put its idea of proper values in the TSGWork before calling you, and if you leave SGA_USE set in the TSGWork.Actions field, Intuition will use the values found in TSGWork fields WorkBuffer, NumChars, BufferPos, and LongInt_, copying the WorkBuffer back to the StringInfo Buffer.

Note: You may not change other TSGWork fields. If you clear SGA_USE, the string gadget will be unchanged.

If you set SGA_END, Intuition will terminate the activation of the string gadget. If you also set SGA_REUSE, Intuition will reuse the input event after it deactivates your gadget. In this case, Intuition will put the value found in TSGWork.Code into the TIntuiMessage.Code field of the IDCMP_GADGETUP message it sends to the application.

If you set SGA_BEEP, Intuition will call DisplayBeep() use this if the user has typed in error, or buffer is full.

Set SGA_REDISPLAY if the changes to the gadget warrant a gadget redisplay. Note: cursor movement requires a redisplay. You may set SGA_PREVACTIVE or SGA_NEXTACTIVE when you set SGA_END. This tells Intuition that you want the next or previous gadget with GFLG_TABCYCLE to be activated.


SGM_CONTROL

Internal Mode for TSGWork.Mode control char escape mode

Declaration

Source position: intuition.pas line 3480

const SGM_CONTROL = 1 shl 5;


SGM_EXITHELP

Mode for TSGWork.Mode exit with code = $5F if help hit

Declaration

Source position: intuition.pas line 3476

const SGM_EXITHELP = 1 shl 7;


SGM_FIXEDFIELD

Mode for TSGWork.Mode fixed length buffer always set SGM_REPLACE, too

Declaration

Source position: intuition.pas line 3473

const SGM_FIXEDFIELD = 1 shl 1;


SGM_LONGINT

Internal Mode for TSGWork.Mode an intuition LongInt gadget

Declaration

Source position: intuition.pas line 3481

const SGM_LONGINT = 1 shl 6;


SGM_NOCHANGE

Internal Mode for TSGWork.Mode no edit changes yet

Declaration

Source position: intuition.pas line 3478

const SGM_NOCHANGE = 1 shl 3;


SGM_NOFILTER

Mode for TSGWork.Mode don't filter control chars

Declaration

Source position: intuition.pas line 3474

const SGM_NOFILTER = 1 shl 2;


SGM_NOWORKB

Internal Mode for TSGWork.Mode Buffer = PrevBuffer

Declaration

Source position: intuition.pas line 3479

const SGM_NOWORKB = 1 shl 4;


SGM_REPLACE

Mode for TSGWork.Mode replace mode please initialize StringInfo with in-range value of BufferPos if you are using SGM_REPLACE mode.

Declaration

Source position: intuition.pas line 3472

const SGM_REPLACE = 1 shl 0;


SHADE_BW

Value for TPreferences.PrintShade

Declaration

Source position: intuition.pas line 2355

const SHADE_BW = $00;


SHADE_COLOR

Value for TPreferences.PrintShade

Declaration

Source position: intuition.pas line 2357

const SHADE_COLOR = $02;


SHADE_GREYSCALE

Value for TPreferences.PrintShade

Declaration

Source position: intuition.pas line 2356

const SHADE_GREYSCALE = $01;


SHADOWPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. dark edge on 3D objects

Declaration

Source position: intuition.pas line 1949

const SHADOWPEN = $0004;


SHANGHAI

Pub Screen mode. put workbench windows on pub screen

Declaration

Source position: intuition.pas line 2181

const SHANGHAI = $0001;


SHINEPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. bright edge on 3D objects

Declaration

Source position: intuition.pas line 1948

const SHINEPEN = $0003;


SHSHAKE_BITS

Mask for TPreferences.SerParShk Lower nibble

Declaration

Source position: intuition.pas line 2402

const SHSHAKE_BITS = $0F;


SHSHAKE_NONE

Serial Handshake Mode TPreferences.SerParShk (lower nibble)

Declaration

Source position: intuition.pas line 2410

const SHSHAKE_NONE = 2;


SHSHAKE_RTS

Serial Handshake Mode TPreferences.SerParShk (lower nibble)

Declaration

Source position: intuition.pas line 2409

const SHSHAKE_RTS = 1;


SHSHAKE_XON

Serial Handshake Mode TPreferences.SerParShk (lower nibble

Declaration

Source position: intuition.pas line 2408

const SHSHAKE_XON = 0;


SI_BEGIN

Declaration

Source position: intuition.pas line 294

const SI_BEGIN = 1;


Unit 'intuition' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

SI_END

Declaration

Source position: intuition.pas line 295

const SI_END = 0;


SI_HPROPBACKGROUND

Declaration

Source position: intuition.pas line 3179

const SI_HPROPBACKGROUND = $1001;


SI_VPROPBACKGROUND

Declaration

Source position: intuition.pas line 3180

const SI_VPROPBACKGROUND = $1002;


SIMPLEREQ

Flag for TRequester.Flags. If set, a SIMPLEREFRESH layer is used.

Declaration

Source position: intuition.pas line 750

const SIMPLEREQ = $0010;


SINGLE_PT

Declaration

Source position: intuition.pas line 2337

const SINGLE_PT = $80;


SIX_LPI

Value for TPreferences.PrintSpacing

Declaration

Source position: intuition.pas line 2346

const SIX_LPI = $000;


SIZEGADGET

Declaration

Source position: intuition.pas line 2452

const SIZEGADGET = 2;


SIZEIMAGE

SYSIA_Which tag data values. Window sizing gadget image

Declaration

Source position: intuition.pas line 3140

const SIZEIMAGE = $02;


SMA_Draw

Declaration

Source position: intuition.pas line 1397

const SMA_Draw = 3;


SMA_GetScrollerTop

Declaration

Source position: intuition.pas line 1393

const SMA_GetScrollerTop = 0;


SMA_RedrawAll

Declaration

Source position: intuition.pas line 1394

const SMA_RedrawAll = 1;


SMA_RepairDamage

Declaration

Source position: intuition.pas line 1399

const SMA_RepairDamage = 4;


SMA_Scroll

Declaration

Source position: intuition.pas line 1395

const SMA_Scroll = 2;


SNA_Hook

Declaration

Source position: intuition.pas line 349

const SNA_Hook = TAG_USER + $08;


SNA_MsgPort

Declaration

Source position: intuition.pas line 347

const SNA_MsgPort = TAG_USER + $06;


SNA_Notify

Declaration

Source position: intuition.pas line 343

const SNA_Notify = TAG_USER + $02;


SNA_Priority

Declaration

Source position: intuition.pas line 348

const SNA_Priority = TAG_USER + $07;


SNA_PubName

Declaration

Source position: intuition.pas line 342

const SNA_PubName = TAG_USER + $01;


SNA_SigBit

Declaration

Source position: intuition.pas line 346

const SNA_SigBit = TAG_USER + $05;


SNA_SigTask

Declaration

Source position: intuition.pas line 345

const SNA_SigTask = TAG_USER + $04;


SNA_UserData

Declaration

Source position: intuition.pas line 344

const SNA_UserData = TAG_USER + $03;


SNAPSHOTIMAGE

Declaration

Source position: intuition.pas line 3156

const SNAPSHOTIMAGE = $15;


SNOTIFY_AFTER_CLOSESCREEN

Declaration

Source position: intuition.pas line 360

const SNOTIFY_AFTER_CLOSESCREEN = 1 shl 9;


SNOTIFY_AFTER_CLOSEWB

Declaration

Source position: intuition.pas line 365

const SNOTIFY_AFTER_CLOSEWB = 1 shl 14;


SNOTIFY_AFTER_CLOSEWINDOW

Declaration

Source position: intuition.pas line 361

const SNOTIFY_AFTER_CLOSEWINDOW = 1 shl 10;


SNOTIFY_AFTER_OPENSCREEN

Declaration

Source position: intuition.pas line 351

const SNOTIFY_AFTER_OPENSCREEN = 1 shl 0;


SNOTIFY_AFTER_OPENWB

Declaration

Source position: intuition.pas line 353

const SNOTIFY_AFTER_OPENWB = 1 shl 2;


SNOTIFY_AFTER_OPENWINDOW

Declaration

Source position: intuition.pas line 355

const SNOTIFY_AFTER_OPENWINDOW = 1 shl 4;


SNOTIFY_BEFORE_CLOSESCREEN

Declaration

Source position: intuition.pas line 352

const SNOTIFY_BEFORE_CLOSESCREEN = 1 shl 1;


SNOTIFY_BEFORE_CLOSEWB

Declaration

Source position: intuition.pas line 354

const SNOTIFY_BEFORE_CLOSEWB = 1 shl 3;


SNOTIFY_BEFORE_CLOSEWINDOW

Declaration

Source position: intuition.pas line 356

const SNOTIFY_BEFORE_CLOSEWINDOW = 1 shl 5;


SNOTIFY_BEFORE_OPENSCREEN

Declaration

Source position: intuition.pas line 362

const SNOTIFY_BEFORE_OPENSCREEN = 1 shl 11;


SNOTIFY_BEFORE_OPENWB

Declaration

Source position: intuition.pas line 364

const SNOTIFY_BEFORE_OPENWB = 1 shl 13;


SNOTIFY_BEFORE_OPENWINDOW

Declaration

Source position: intuition.pas line 363

const SNOTIFY_BEFORE_OPENWINDOW = 1 shl 12;


SNOTIFY_LOCKPUBSCREEN

Declaration

Source position: intuition.pas line 358

const SNOTIFY_LOCKPUBSCREEN = 1 shl 7;


SNOTIFY_PUBSCREENSTATE

Declaration

Source position: intuition.pas line 357

const SNOTIFY_PUBSCREENSTATE = 1 shl 6;


SNOTIFY_SCREENDEPTH

Declaration

Source position: intuition.pas line 359

const SNOTIFY_SCREENDEPTH = 1 shl 8;


SNOTIFY_UNLOCKPUBSCREEN

Declaration

Source position: intuition.pas line 367

const SNOTIFY_UNLOCKPUBSCREEN = 1 shl 16;


SNOTIFY_WAIT_REPLY

Declaration

Source position: intuition.pas line 366

const SNOTIFY_WAIT_REPLY = 1 shl 15;


SORTASCIMAGE

Declaration

Source position: intuition.pas line 3176

const SORTASCIMAGE = $27;


SORTDESIMAGE

Declaration

Source position: intuition.pas line 3177

const SORTDESIMAGE = $28;


SPA_GADGETGEOMETRY

Declaration

Source position: intuition.pas line 3721

const SPA_GADGETGEOMETRY = $00000800;


SPA_GADGETSTYLE

Declaration

Source position: intuition.pas line 3718

const SPA_GADGETSTYLE = $00000020;


SPA_MENUSTYLE

Declaration

Source position: intuition.pas line 3719

const SPA_MENUSTYLE = $00000200;


SPA_WINBFRAMESTYLE

Declaration

Source position: intuition.pas line 3716

const SPA_WINBFRAMESTYLE = $00000008;


SPA_WINBGADGEOMETRY

Declaration

Source position: intuition.pas line 3720

const SPA_WINBGADGEOMETRY = $00000400;


SPA_WINBGADSTYLE

Declaration

Source position: intuition.pas line 3717

const SPA_WINBGADSTYLE = $00000010;


SPA_WINBORDERSTYLE

Declaration

Source position: intuition.pas line 3715

const SPA_WINBORDERSTYLE = $00000004;


SPARITY_BITS

Mask for TPreferences.SerParShk upper nibble

Declaration

Source position: intuition.pas line 2401

const SPARITY_BITS = $F0;


SPARITY_EVEN

Serial Parity TPreferences.SerParShk (upper nibble)

Declaration

Source position: intuition.pas line 2405

const SPARITY_EVEN = 1;


SPARITY_NONE

Serial Parity TPreferences.SerParShk (upper nibble)

Declaration

Source position: intuition.pas line 2404

const SPARITY_NONE = 0;


SPARITY_ODD

Serial Parity TPreferences.SerParShk (upper nibble)

Declaration

Source position: intuition.pas line 2406

const SPARITY_ODD = 2;


SPOS_ABSOLUTE

Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the absolute coordinates you wish to move the screen to. Coordinates are expressed as absolutes, not relatives.

Declaration

Source position: intuition.pas line 2201

const SPOS_ABSOLUTE = 1;


SPOS_FORCEDRAG

Flag for ScreenPosition(). Move non-draggable screen, You may additionally set SPOS_FORCEDRAG along with any of the above. Set this if you wish to reposition an [SA_Draggable, False] screen that you opened.

Declaration

Source position: intuition.pas line 2203

const SPOS_FORCEDRAG = 4;


SPOS_MAKEVISIBLE

Flag for ScreenPosition(). Coordinates describe a box on the screen you wish to be made visible by autoscrolling (x1,y1)-(x2,y2) describes a rectangle on the screen which you would like autoscrolled into view.

Declaration

Source position: intuition.pas line 2202

const SPOS_MAKEVISIBLE = 2;


SPOS_RELATIVE

Flag for ScreenPosition(). The x1 and y1 parameters to ScreenPosition() describe the offset in coordinates you wish to move the screen by. Coordinates are relative

Declaration

Source position: intuition.pas line 2200

const SPOS_RELATIVE = 0;


SR_DRAW

Declaration

Source position: intuition.pas line 3656

const SR_DRAW = 801;


SR_DRAWALPHAMAP

Declaration

Source position: intuition.pas line 3663

const SR_DRAWALPHAMAP = 808;


SR_DRAWDISMASK

Declaration

Source position: intuition.pas line 3658

const SR_DRAWDISMASK = 803;


SR_DRAWIMAGEFRAME

Declaration

Source position: intuition.pas line 3664

const SR_DRAWIMAGEFRAME = 809;


SR_DRAWLEVELMAP

Declaration

Source position: intuition.pas line 3660

const SR_DRAWLEVELMAP = 805;


SR_DRAWMASK

Declaration

Source position: intuition.pas line 3657

const SR_DRAWMASK = 802;


SR_DRAWSELDISMASK

Declaration

Source position: intuition.pas line 3659

const SR_DRAWSELDISMASK = 804;


SR_DRAWSHADOWMAP

Declaration

Source position: intuition.pas line 3662

const SR_DRAWSHADOWMAP = 807;


SR_DRAWSHINEMAP

Declaration

Source position: intuition.pas line 3661

const SR_DRAWSHINEMAP = 806;


SRA_DeltaX

Declaration

Source position: intuition.pas line 1437

const SRA_DeltaX = SRA_Dummy + 3;


SRA_DeltaY

Declaration

Source position: intuition.pas line 1438

const SRA_DeltaY = SRA_Dummy + 4;


SRA_DirectShade

Declaration

Source position: intuition.pas line 1440

const SRA_DirectShade = SRA_Dummy + 6;


SRA_Domain

Declaration

Source position: intuition.pas line 1439

const SRA_Domain = SRA_Dummy + 5;


SRA_Dummy

Declaration

Source position: intuition.pas line 1434

const SRA_Dummy = $03800000;


SRA_OffsetX

Declaration

Source position: intuition.pas line 1435

const SRA_OffsetX = SRA_Dummy + 1;


SRA_OffsetY

Declaration

Source position: intuition.pas line 1436

const SRA_OffsetY = SRA_Dummy + 2;


SRA_RefreshBG

Declaration

Source position: intuition.pas line 1441

const SRA_RefreshBG = SRA_Dummy + 7;


SREAD_BITS

Mask for TPreferences.SerRWBits Upper nibble

Declaration

Source position: intuition.pas line 2397

const SREAD_BITS = $F0;


SRF_HSCROLLERFRAME

Declaration

Source position: intuition.pas line 3670

const SRF_HSCROLLERFRAME = $00000004;


SRF_ISBITMAP

Declaration

Source position: intuition.pas line 3669

const SRF_ISBITMAP = $00000002;


SRF_MONOCHROME

Declaration

Source position: intuition.pas line 3668

const SRF_MONOCHROME = $00000001;


SRF_VSCROLLERFRAME

Declaration

Source position: intuition.pas line 3671

const SRF_VSCROLLERFRAME = $00000008;


SSTOP_BITS

Mask for TPreferences.SerStopBuf Upper nibble

Declaration

Source position: intuition.pas line 2399

const SSTOP_BITS = $F0;


STD_DISABLE_CONTRAST

Declaration

Source position: intuition.pas line 1430

const STD_DISABLE_CONTRAST = $1000;


STDSCREENHEIGHT

Supply in TNewScreen.Height Set Hight to standard height

Declaration

Source position: intuition.pas line 2021

const STDSCREENHEIGHT = - 1;


STDSCREENWIDTH

Supply in TNewScreen.Width Set Hight to standard width

Declaration

Source position: intuition.pas line 2022

const STDSCREENWIDTH = - 1;


STRGCLASS

Class identifier. A string gadget.

Declaration

Source position: intuition.pas line 2530

const STRGCLASS: PChar = 'strgclass';

Description

SuperClass: gadgetclass

Intuition compatible string gadgets. The Boopsi string gadget can either be a plain string gadget or an integer string gadget. An integer gadget filters out all characters except those that make up integer values.

Changed Methods:

OM_NEW

Attributes:

STRINGA_LongVal (ISGNU)

STRINGA_TextVal (ISGNU)

The remaining strgclass attributes correspond to the flags and fields that the conventional Intuition string gadget uses.

STRINGA_MaxChars (I)

STRINGA_Buffer (I)

STRINGA_UndoBuffer (I)

STRINGA_WorkBuffer (I)

STRINGA_BufferPos (ISU)

STRINGA_DispPos (ISU)

STRINGA_AltKeyMap (IS)

STRINGA_Font (IS)

STRINGA_Pens (IS)

STRINGA_ActivePens (IS)

STRINGA_EditHook (I)

STRINGA_EditModes (IS)

STRINGA_ReplaceMode (IS)

STRINGA_FixedFieldMode (IS)

STRINGA_NoFilterMode (IS)

STRINGA_Justification (IS)

STRINGA_ExitHelp (IS)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


STRINGA_ActivePens

StrgClass Tag. [IS.] (LongInt) Like STRINGA_Pens. These pens are used, if the gadget is active.

Declaration

Source position: intuition.pas line 2761

const STRINGA_ActivePens = STRINGA_Dummy + $000A;


STRINGA_AltKeyMap

StrgClass Tag. [IS.] (PKeyMap) KeyMap to use

Declaration

Source position: intuition.pas line 2758

const STRINGA_AltKeyMap = STRINGA_Dummy + $0007;


STRINGA_Buffer

StrgClass Tag. [I..] (STRPTR) Buffer for storing the current string of the gadget.

Declaration

Source position: intuition.pas line 2753

const STRINGA_Buffer = STRINGA_Dummy + $0002;


STRINGA_BufferPos

StrgClass Tag. [IS.] (SmallInt) Current position of cursor (relative to the beginning of the buffer).

Declaration

Source position: intuition.pas line 2756

const STRINGA_BufferPos = STRINGA_Dummy + $0005;


STRINGA_DispPos

StrgClass Tag. [IS.] (SmallInt) FIXME

Declaration

Source position: intuition.pas line 2757

const STRINGA_DispPos = STRINGA_Dummy + $0006;


STRINGA_Dummy

StrgClass Start Tag.

Declaration

Source position: intuition.pas line 2749

const STRINGA_Dummy = TAG_USER + $32000;


STRINGA_EditHook

StrgClass Tag. [I..] (PHook) FIXME

Declaration

Source position: intuition.pas line 2762

const STRINGA_EditHook = STRINGA_Dummy + $000B;


STRINGA_EditModes

StrgClass Tag. [IS.] (LongWord) FIXME

Declaration

Source position: intuition.pas line 2763

const STRINGA_EditModes = STRINGA_Dummy + $000C;


STRINGA_ExitHelp

StrgClass Tag. [IS.] (LongBool) If this is set, pressing the "Help" key, while the gadget is active, will unselect the gadget.

Declaration

Source position: intuition.pas line 2775

const STRINGA_ExitHelp = STRINGA_Dummy + $0013;


STRINGA_FixedFieldMode

StrgClass Tag. [IS.] (LongBool) FIXME

Declaration

Source position: intuition.pas line 2767

const STRINGA_FixedFieldMode = STRINGA_Dummy + $000E;


STRINGA_Font

StrgClass Tag. [IS.] (PTextFont) Font to use for displaying the string

Declaration

Source position: intuition.pas line 2759

const STRINGA_Font = STRINGA_Dummy + $0008;


STRINGA_Justification

StrgClass Tag. [IS.] (Word) Where should the text be justified?

Declaration

Source position: intuition.pas line 2770

const STRINGA_Justification = STRINGA_Dummy + $0010;

Description

Use one of GACT_STRINGCENTER, GACT_STRINGLEFT and GACT_STRINGRIGHT


STRINGA_LongVal

StrgClass Tag. [ISG] (LongInt) If this is set, the string gadget will only accept numeric values.

Declaration

Source position: intuition.pas line 2772

const STRINGA_LongVal = STRINGA_Dummy + $0011;

Description

Argument is the number, the string gadget is to be set to. When getting this attribute, this number is returned.


STRINGA_MarkedBlock

Declaration

Source position: intuition.pas line 2778

const STRINGA_MarkedBlock = STRINGA_Dummy + $0014;


STRINGA_MaxChars

StrgClass Tag. [I..] (SmallInt) Maximum number of characters the string gadget accepts. Default SG_DEFAULTMAXCHARS.

Declaration

Source position: intuition.pas line 2750

const STRINGA_MaxChars = STRINGA_Dummy + $0001;


STRINGA_NoFilterMode

StrgClass Tag. [IS.] (LongBool) FIXME

Declaration

Source position: intuition.pas line 2768

const STRINGA_NoFilterMode = STRINGA_Dummy + $000F;


STRINGA_Pens

StrgClass Tag. [IS.] (LongInt) The lower 16 bits specify the background-pen, the upper 16 bits the foreground-pen. The gadget is rendered, using these pens, if the gadget is inactive

Declaration

Source position: intuition.pas line 2760

const STRINGA_Pens = STRINGA_Dummy + $0009;


STRINGA_ReplaceMode

StrgClass Tag. [IS.] (LongBool) If this is True, the current character is overwritten, if the use presses a key. Otherwise, the new character is inserted.

Declaration

Source position: intuition.pas line 2766

const STRINGA_ReplaceMode = STRINGA_Dummy + $000D;


STRINGA_TextVal

StrgClass Tag. [ISG] (STRPTR) If this is set, the string gadget will accept strings.

Declaration

Source position: intuition.pas line 2773

const STRINGA_TextVal = STRINGA_Dummy + $0012;

Description

Argument is a string that is to be copied into the string gadget and its buffer.


STRINGA_UndoBuffer

StrgClass Tag. [I..] (STRPTR) Buffer for storing the old (undo) string of the gadget.

Declaration

Source position: intuition.pas line 2754

const STRINGA_UndoBuffer = STRINGA_Dummy + $0003;


STRINGA_WorkBuffer

StrgClass Tag. [I..] (STRPTR) Buffer for the class to work with.

Declaration

Source position: intuition.pas line 2755

const STRINGA_WorkBuffer = STRINGA_Dummy + $0004;


SUBMENU

Declaration

Source position: intuition.pas line 101

const SUBMENU = $0200;


SUPFRONTGADGET

Declaration

Source position: intuition.pas line 2455

const SUPFRONTGADGET = 5;


SWRITE_BITS

Mask for TPreferences.SerRWBits Lower nibble

Declaration

Source position: intuition.pas line 2398

const SWRITE_BITS = $0F;


SYSIA_BitMapCache

Declaration

Source position: intuition.pas line 3104

const SYSIA_BitMapCache = IA_Dummy + $27;


SYSIA_ContentsBox

Declaration

Source position: intuition.pas line 3099

const SYSIA_ContentsBox = IA_Dummy + $22;


SYSIA_Depth

SysIClass Attribute.

Declaration

Source position: intuition.pas line 3078

const SYSIA_Depth = IA_Dummy + $0C;


SYSIA_DrawInfo

SysIClass Attribute. Must be specified

Declaration

Source position: intuition.pas line 3080

const SYSIA_DrawInfo = IA_Dummy + $18;


SYSIA_FullFrame

Declaration

Source position: intuition.pas line 3098

const SYSIA_FullFrame = IA_Dummy + $21;


SYSIA_Label

Declaration

Source position: intuition.pas line 3106

const SYSIA_Label = IA_Label;


SYSIA_Pens

Declaration

Source position: intuition.pas line 3082

const SYSIA_Pens = IA_Pens;


SYSIA_ReferenceFont

SysIClass Attribute. Font to use as reference for scaling certain sysiclass images

Declaration

Source position: intuition.pas line 3086

const SYSIA_ReferenceFont = IA_Dummy + $19;


SYSIA_RenderHook

Declaration

Source position: intuition.pas line 3103

const SYSIA_RenderHook = IA_Dummy + $26;


SYSIA_Size

SysIClass Attribute. SYSISIZE_*

Declaration

Source position: intuition.pas line 3077

const SYSIA_Size = IA_Dummy + $0B;


SYSIA_VectorInfo

Declaration

Source position: intuition.pas line 3102

const SYSIA_VectorInfo = IA_Dummy + $25;


SYSIA_Which

SysIClass Attribute. System image identifier

Declaration

Source position: intuition.pas line 3079

const SYSIA_Which = IA_Dummy + $0D;

Description

Specifies which system gadget you want an image for. Some numbers correspond to internal Intuition

See also

DEPTHIMAGE | SYSIA_Which tag data values. Window depth gadget image
ZOOMIMAGE | SYSIA_Which tag data values. Window zoom gadget image
SIZEIMAGE | SYSIA_Which tag data values. Window sizing gadget image
CLOSEIMAGE | SYSIA_Which tag data values. Window close gadget image
SDEPTHIMAGE | SYSIA_Which tag data values. Screen depth gadget image
LEFTIMAGE | SYSIA_Which tag data values. Left-arrow gadget image
UPIMAGE | SYSIA_Which tag data values. Up-arrow gadget image
RIGHTIMAGE | SYSIA_Which tag data values. Right-arrow gadget image
DOWNIMAGE | SYSIA_Which tag data values. Down-arrow gadget image
CHECKIMAGE | SYSIA_Which tag data values. GadTools checkbox image
MXIMAGE | SYSIA_Which tag data values. GadTools mutual exclude "button" image
MENUCHECK | SYSIA_Which tag data values. Menu checkmark image
AMIGAKEY | SYSIA_Which tag data values. Menu Amiga-key image


SYSICLASS

Class identifier. The class of system images. The class includes the images for the system and GadTools gadgets.

Declaration

Source position: intuition.pas line 2526

const SYSICLASS: PChar = 'sysiclass';

Description

SuperClass: imageclass

This is a class of system images and standard application images. There are 11 possible sysiclass image glyphs to choose from:

DEPTHIMAGE
Window depth arrangement image.
ZOOMIMAGE
Window Zoom image.
SIZEIMAGE
Window Sizing image.
CLOSEIMAGE
Window close image.
SDEPTHIMAGE
Screen depth arrangement image.
LEFTIMAGE
Left arrow image.
RIGHTIMAGE
Right arrow image.
UPIMAGE
Up arrow image.
DOWNIMAGE
Down arrow image.
CHECKIMAGE
Checkmark image.
MXIMAGE
Radio button image.

The class caches the image's bitmap to improve rendering speed.

Attributes:

SYSIA_DrawInfo (I)

SYSIA_Which (I)

SYSIA_Size (I)

See also

ClassID | Name of the Object class
TIClass | This structure is READ-ONLY, and allocated only by Intuition
MakeClass | Create and initialize a boopsi class.
NewObjectA | Create an object from a class.


SYSISIZE_HIRES

Data value for SYSIA_Size

Declaration

Source position: intuition.pas line 3135

const SYSISIZE_HIRES = 2;


SYSISIZE_LOWRES

Data value for SYSIA_Size

Declaration

Source position: intuition.pas line 3134

const SYSISIZE_LOWRES = 1;


SYSISIZE_MEDRES

Data value for SYSIA_Size

Declaration

Source position: intuition.pas line 3133

const SYSISIZE_MEDRES = 0;


SYSREQUEST

Flag for TRequester.Flags. Read-Only. This requester caused by system

Declaration

Source position: intuition.pas line 758

const SYSREQUEST = $4000;


Unit 'intuition' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

T_ITEM

Declaration

Source position: intuition.pas line 177

const T_ITEM = 1;


Unit 'intuition' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

T_MENU

Declaration

Source position: intuition.pas line 176

const T_MENU = 0;


T_Object

Boopsi Object structure

Declaration

Source position: intuition.pas line 2642

type T_Object = record
o_Node: TMinNode; |
o_Class: PIClass; | Class pointer
end;

Description

We have this, the instance data of the root class, PRECEDING the 'object'. This is so that Gadget objects are Gadget pointers, and so on. If this structure grows, it will always have o_Class at the end, so the macro OCLASS(o) will always have the same offset back from the pointer returned from NewObject().


T_ROOT

Declaration

Source position: intuition.pas line 175

const T_ROOT = - 1;


TABLETA_AngleX

Tag for TTabletData.td_TagList. The angle of rotation or tilt about the X-axis.

Declaration

Source position: intuition.pas line 1323

const TABLETA_AngleX = TABLETA_Dummy + $03;

Description

The angle of rotation or tilt about the X-axis. This number should be normalized to fill a signed long LongInt. Positive values imply a clockwise rotation about the X-axis when viewing from +X towards the origin.


TABLETA_AngleY

Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Y-axis.

Declaration

Source position: intuition.pas line 1324

const TABLETA_AngleY = TABLETA_Dummy + $04;

Description

The angle of rotation or tilt about the Y-axis. This number should be normalized to fill a signed long LongInt. Positive values imply a clockwise rotation about the Y-axis when viewing from +Y towards the origin.


TABLETA_AngleZ

Tag for TTabletData.td_TagList. The angle of rotation or tilt about the Z axis.

Declaration

Source position: intuition.pas line 1325

const TABLETA_AngleZ = TABLETA_Dummy + $05;

Description

The angle of rotation or tilt about the Z axis. This number should be normalized to fill a signed long LongInt. Positive values imply a clockwise rotation about the Z-axis when viewing from +Z towards the origin.


TABLETA_ButtonBits

Tag for TTabletData.td_TagList. Button States

Declaration

Source position: intuition.pas line 1329

const TABLETA_ButtonBits = TABLETA_Dummy + $07;

Description

ti_Data is a long LongInt whose bits are to be interpreted at the state of the first 32 buttons of the tablet.


TABLETA_Dummy

Tablet Tag Base

Declaration

Source position: intuition.pas line 1320

const TABLETA_Dummy = TAG_USER + $3A000;


TABLETA_InProximity

Tag for TTabletData.td_TagList. For tablets that support proximity,

Declaration

Source position: intuition.pas line 1330

const TABLETA_InProximity = TABLETA_Dummy + $08;

Description

ti_Data is a boolean. For tablets that support proximity, they should send the (TABLETA_InProximity, False) tag item when the stylus is out of proximity. One possible use we can forsee is a mouse-blanking commodity which keys off this to blank the mouse. When this tag is absent, the stylus is assumed to be in proximity.


TABLETA_Pressure

Tag for TTabletData.td_TagList. The pressure reading of the stylus.

Declaration

Source position: intuition.pas line 1326

const TABLETA_Pressure = TABLETA_Dummy + $06;

Description

The pressure reading of the stylus. The pressure should be normalized to fill a signed long LongInt. Typical devices won't generate negative pressure, but the possibility is not precluded. The pressure threshold which is considered to cause a button-click is expected to be set in a Preferences program supplied by the tablet vendor. The tablet driver would send inputevent.IECODE_LBUTTON-type events as the pressure crossed that threshold.


TABLETA_RangeZ

Tag for TTabletData.td_TagList. The maximum value of the tablet in the Z direction.

Declaration

Source position: intuition.pas line 1322

const TABLETA_RangeZ = TABLETA_Dummy + $02;

Description

The maximum value of the tablet in the Z direction. Normally specified along with TABLETA_TabletZ, this allows the application to scale the actual Z value across its range.


TABLETA_ResolutionX

Tag for TTabletData.td_TagList. X-axis resolution

Declaration

Source position: intuition.pas line 1333

const TABLETA_ResolutionX = TABLETA_Dummy + $09;

Description

ti_Data is an unsigned long LongInt which is the x-axis resolution in dots per inch.


TABLETA_ResolutionY

Tag for TTabletData.td_TagList. Y-axis resolution

Declaration

Source position: intuition.pas line 1334

const TABLETA_ResolutionY = TABLETA_Dummy + $0A;

Description

ti_Data is an unsigned long LongInt which is the y-axis resolution in dots per inch.


TABLETA_TabletZ

Tag for TTabletData.td_TagList. The current value of the tablet in the Z direction.

Declaration

Source position: intuition.pas line 1321

const TABLETA_TabletZ = TABLETA_Dummy + $01;

Description

The current value of the tablet in the Z direction. This unsigned value should typically be in the natural units of the tablet. You should also provide TABLETA_RangeZ.


TBFRAMEIMAGE

Declaration

Source position: intuition.pas line 3159

const TBFRAMEIMAGE = $18;


TBitMapInstance

Declaration

Source position: intuition.pas line 3565

type TBitMapInstance = Pointer;


TBitMapSource

Declaration

Source position: intuition.pas line 3564

type TBitMapSource = Pointer;


TBoolInfo

Boolgadget informations PBoolInfo

Declaration

Source position: intuition.pas line 632

type TBoolInfo = record
Flags: Word; | Flags for BoolGadget BOOLMASK
Mask: PWord; | Bit mask for highlighting and selecting mask must follow the same rules as an Image plane. It's width and height are determined by the width and height of the gadget's select box. (i.e. TGadget.Width and TGadget.Height).
Reserved: LongWord; | Set to 0
end;


TBorder

Pointer drawing structure

Declaration

Source position: intuition.pas line 63

type TBorder = record
LeftEdge: SmallInt; | Initial left offsets from the origin
TopEdge: SmallInt; | Initial top offsets from the origin
FrontPen: Byte; | Front pen for rendering
BackPen: Byte; | Back pen for rendering
DrawMode: Byte; | Draw Mode for rendering
Count: ShortInt; | Number of XY pairs
XY: Pointer; | Vector coordinate pairs relative to LeftTop
NextBorder: PBorder; | pointer to any other Border too
end;

Description

Data type Border, used for drawing a series of lines which is intended for use as a border drawing, but which may, in fact, be used to render any arbitrary vector shape. The routine DrawBorder sets up the RastPort with the appropriate variables, then does a Move to the first coordinate, then does Draws to the subsequent coordinates. After all the Draws are done, if NextBorder is non-zero we call DrawBorder recursively

See also

TRequester | Requesters The following struct is used for standard intuition requesters
GA_Border | GadgetClass Tag. (PBorder) Gadget imagry is a border
DrawBorder | Draw the specified Border structure into a RastPort.


TClassLibrary

BOOPSI class libraries structure

Declaration

Source position: intuition.pas line 2651

type TClassLibrary = record
cl_Lib: TLibrary; | Embedded library
cl_Pad: Word; | Align the structure
cl_Class: PIClass; | Class pointer
end;

Description

BOOPSI class libraries should use this structure as the base for their library data. This allows developers to obtain the class pointer for performing object-less inquiries.


TColorSpec

Color table entry

Declaration

Source position: intuition.pas line 1777

type TColorSpec = record
ColorIndex: SmallInt; | -1 terminates an array of ColorSpec
Red: Word; | Only the bottom 4 bits recognized
Green: Word; | Only the bottom 4 bits recognized
Blue: Word; | Only the bottom 4 bits recognized
end;


TContextMenuMsg

Declaration

Source position: intuition.pas line 1289

type TContextMenuMsg = record

  State: LongWord;

  Menu: Pointer;

  Context: Pointer;

end;


TDrawInfo

Graphical informations for the 3D look

Declaration

Source position: intuition.pas line 1919

type TDrawInfo = record
dri_Version: Word; | Version of the structure, will be DRI_VERSION
dri_NumPens: Word; | Guaranteed to be >= numDrIPens
dri_Pens: PWord; | pointer to pen array
dri_Font: PTextFont; | Screen default font
dri_Depth: Word; | (initial) depth of screen bitmap
dri_Resolution: record | from DisplayInfo database for initial display mode
x: Word; |
y: Word; |
end;
dri_Flags: LongWord; | Draw Flags (DIRF_*)
dri_CheckMark: PImage; | pointer to scaled checkmark image Will be nil if DRI_VERSION < 2
dri_AmigaKey: PImage; | pointer to scaled Amiga-key image Will be nil if DRI_VERSION < 2
dri_Screen: PScreen;
dri_Prefs: Pointer;
dri_Reserved: array [0..2] of LongWord; | Place for future extensions
end;

Description

The DrawInfo structure provides information Intuition uses to support the 3D look and specifies graphical information for applications that use the screen. The information includes such items as aspect ratio (resolution), font, number of colors and drawing pens.

See also

TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
GA_DrawInfo | GadgetClass Tag. [I..] (PDrawInfo) Some gadgets need a DrawInfo structure to be able to perform correct rendering.
TimpFrameBox | Message argument for IM_FRAMEBOX
TimpDraw | Message argument for IM_DRAW or IM_DRAWFRAME
DrawImageState | Draw an (extended) Intuition Image with special visual state.
FreeScreenDrawInfo | Finish using a DrawInfo structure.
GetScreenDrawInfo | Get pointer to rendering information.


TEasyStruct

The text and setup of an easy requester

Declaration

Source position: intuition.pas line 1789

type TEasyStruct = record
es_StructSize: LongWord; | should be sizeof (TEasyStruct) Note that this size may change, if you update the includes! Do not use absolute values as the size of pointers may vary on different platforms!
es_Flags: LongWord; | should be 0 for now
es_Title: PChar; | Title of easy requester window. If this is nil, the title will be taken to be the same as the title of the reference window, if one is specified in the EasyRequestArgs() call, else the title will be "System Request".
es_TextFormat: PChar; | 'printf' style formatting string see RawDoFmt()
es_GadgetFormat: PChar; | Text of the gadgets, separated by '|' (vertical bar) support no further formating. At least one gadget must be specified.
es_Screen: PScreen;
es_TagList: PTagItem;
end;

See also

BuildEasyRequestArgs | Simple creation of system request.
EasyRequestArgs | Easy alternative to AutoRequest()


TExtGadget

Extended Gadget structure

Declaration

Source position: intuition.pas line 445

type TExtGadget = record
NextGadget: PExtGadget; |
LeftEdge: SmallInt; |
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
Flags: Word; |
Activation: Word; |
GadgetType: Word; |
GadgetRender: Pointer; |
SelectRender: Pointer; |
GadgetText: PIntuiText; |
MutualExclude: LongInt; |
SpecialInfo: Pointer; |
GadgetID: Word; |
UserData: Pointer; |
MoreFlags: LongWord; | Additional flags (GMORE_*)
BoundsLeftEdge: SmallInt; | Bounding extent for gadget, valid
BoundsTopEdge: SmallInt; | only if GMORE_BOUNDS is set. The
BoundsWidth: SmallInt; | GFLG_RELxxx flags affect these
BoundsHeight: SmallInt; | coordinates as well.
end;

Description

Check TGadget for the meaning for the first fields.

See also

TGadget | Structure to describe a Gadget
GFLG_EXTENDED | Flag for TGadget.SpecialInfo. Gadget is an PExtGadget


TExtIntuiMessage

Extended Intuition message structure

Declaration

Source position: intuition.pas line 1367

type TExtIntuiMessage = record
eim_IntuiMessage: TIntuiMessage; | Standard Intuition message
eim_TabletData: PTabletData; | Pointer to tablet data
end;

Description

All IntuiMessages are now slightly extended. The ExtIntuiMessage structure has an additional field for tablet data, which is usually nil.

Note

This structure is subject to grow in the future. Making assumptions about its size is a bad idea.


TExtNewScreen

Extended TNewScreen structure

Declaration

Source position: intuition.pas line 2141

type TExtNewScreen = record
LeftEdge: SmallInt; | see at TNewScreen
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
Depth: SmallInt; |
DetailPen: Byte; |
BlockPen: Byte; |
ViewModes: Word; |
Type_: Word;
Font: PTextAttr; |
DefaultTitle: PChar; |
Gadgets: PGadget; |
CustomBitMap: PBitMap; |
Extension: PTagItem; | TExtNewScreen specific extension SA_*
end;


TExtNewWindow

Future TNewWindow

Declaration

Source position: intuition.pas line 1132

type TExtNewWindow = record
LeftEdge: SmallInt; | see TNewWindow for the field explanations
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
DetailPen: Byte; |
BlockPen: Byte; |
IDCMPFlags: LongWord; |
Flags: LongWord; |
FirstGadget: PGadget; |
CheckMark: PImage; |
Title: PChar; |
Screen: PScreen;
BitMap: PBitMap;
MinWidth: SmallInt; |
MinHeight: SmallInt; |
MaxWidth: Word; |
MaxHeight: Word; |
Type_: Word;
Extension: PTagItem; | If the Flags value WFLG_NW_EXTENDED is set, then this field is assumed to point to an array ( or chain of arrays) of TagItem structures. See also TExtNewScreen for another use of TagItems to pass optional data.
end;

Description

Compatibility issues require that the size of NewWindow not change. Data in the common part (NewWindow) indicates the the extension fields are being used. NOTE WELL: This structure may be subject to future extension. Writing code depending on its size is not allowed.


TEXTPEN

Rendering pen number indexes into TDrawInfo.dri_Pens. text on background

Declaration

Source position: intuition.pas line 1947

const TEXTPEN = $0002;


TGadget

Structure to describe a Gadget

Declaration

Source position: intuition.pas line 417

type TGadget = record
NextGadget: PGadget; | Next Gadget in the list
LeftEdge: SmallInt; | Left edge of Hitbox
TopEdge: SmallInt; | Top edge of Hitbox
Width: SmallInt; | Width of Hitbox
Height: SmallInt; | Height of Hitbox
Flags: Word; | Flag for Gadget (GFLG_*)
Activation: Word; | Activation flag (GACT_*)
GadgetType: Word; | Gadget typ (GTYP_*)
GadgetRender: Pointer; | Application can specify that the Gadget be rendered as either as Border or an Image. This variable points to which (or equals nil if there's nothing to be rendered about this Gadget)
SelectRender: Pointer; | Application can specify "highlighted" imagery rather than algorithmic this can point to either Border or Image data
GadgetText: PIntuiText; | Text for this gadget
MutualExclude: LongInt; | obsolete
SpecialInfo: Pointer; | A pointer to a structure of special data required by Proportional, String and LongInt Gadgets
GadgetID: Word; | User-definable ID field
UserData: Pointer; | A pointer to general purpose User data (ignored by Intuition)
end;

See also

TRequester | Requesters The following struct is used for standard intuition requesters
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TScreen | Basic screen structure
TNewScreen | Description of a new screen
TExtNewScreen | Extended TNewScreen structure
GA_Previous | GadgetClass Tag. [I..] (PGadget) Pointer to previous gadget.
GA_Next | GadgetClass Tag. [I..] (PGadget) Next gadget in the linked list. Currently not implemented.
TSGWork | String gadget message
ActivateGadget | Activate a (string or custom) gadget.
AddGadget | Add a gadget to the gadget list of a window.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
GadgetMouse | Calculate gadget-relative mouse position.
ModifyProp | Modify the current parameters of a proportional gadget.
ObtainGIRPort | Set up a RastPort for a custom gadget.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
RemoveGadget | Remove a gadget from a window.
RemoveGList | Remove a sublist of gadgets from a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.
GADGET_BOX | Get bounding box of a gadget
CUSTOM_HOOK | Casts MutualExclude for easy assignment of a hook pointer to the unused MutualExclude field of a custom gadget


TGadgetGeometryMsg

Declaration

Source position: intuition.pas line 3760

type TGadgetGeometryMsg = record

  ggm_MethodID: LongWord;

  ggm_Window: PWindow;

  ggm_DrawInfo: PDrawInfo;

  ggm_BoundingBox: TIBox;

  ggm_HitBox: TIBox;

  ggm_IAddress: Pointer;

  ggm_Flags: LongWord;

end;


TGadgetInfo

The TGadgetInfo structure contains information about the display on which the gadget needs to render itself

Declaration

Source position: intuition.pas line 2485

type TGadgetInfo = record
gi_Screen: PScreen; | ScreenPtr
gi_Window: PWindow; | nil for screen gadgets
gi_Requester: PRequester; | nil IF not GTYP_REQGADGET
gi_RastPort: PRastPort; | Rendering information: don't use these without cloning/locking. Official way is to call ObtainGIRPort()
gi_Layer: PLayer; | LayerPtr
gi_Domain: TIBox; | Copy of dimensions of screen/window/g00/req(/group) that gadget resides in.
gi_Pens: record |
DetailPen: Byte; |
BlockPen: Byte; |
end;
gi_DrInfo: PDrawInfo; | the Detail and Block pens in gi_DrInfo^.dri_Pens[] are for the screen. Use the above for window-sensitive colors.
gi_Gadget: PGadget;
gi_Reserved: array [0..4] of LongWord; |
end;

Description

All the fields in this structure are read only.

Although this structure contains a pointer to the gadget's RastPort structure, applications should not use it for rendering. Instead, use the intuition.library function ObtainGIRPort() to obtain a copy of the GadgetInfo's RastPort. When the gadget is finished with this RastPort, it should call ReleaseGIRPort() to relinquish the RastPort.

See also

TopSet | Message structure for OM_NEW/OM_SET
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE
TgpHitTest | Message parameter passed for GM_HITTEST or GM_HELPTEST
TgpRender | Message parameter passed for GM_RENDER
TgpInput | Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT
TgpGoInactive | Message parameter passed for GM_GOINACTIVE
TgpLayout | Message parameter passed for GM_LAYOUT
TgpDomain |
TSGWork | String gadget message
GadgetMouse | Calculate gadget-relative mouse position.
ObtainGIRPort | Set up a RastPort for a custom gadget.


TgpDomain

Declaration

Source position: intuition.pas line 2917

type TgpDomain = record

  MethodID: LongWord;

  gpd_GInfo: PGadgetInfo;

  gpd_RPort: PRastPort;

  gpd_Which: LongInt;

  gpd_Domain: TIBox;

  gpd_Attrs: PTagItem;

end;


TgpExtent

Declaration

Source position: intuition.pas line 2975

type TgpExtent = record

  MethodID: LongWord;

  gpe_GInfo: PGadgetInfo;

  gpe_RPort: PRastPort;

  gpe_Region: PRegion;

  gpe_Action: LongWord;

  gpe_Flags: LongWord;

  gpe_Attrs: PTagItem;

end;


TgpGoInactive

Message parameter passed for GM_GOINACTIVE

Declaration

Source position: intuition.pas line 2894

type TgpGoInactive = record
MethodID: LongWord; | GM_GOINACTIVE
gpgi_GInfo: PGadgetInfo; |
gpgi_Abort: LongWord; | Boolean field to indicate, who wanted the gadget to go inactive. If this is 1 this method was sent, because intution wants the gadget to go inactive, if it is 0, it was the gadget itself that wanted it.
end;

Description

See GM_GOACTIVE


TgpHitTest

Message parameter passed for GM_HITTEST or GM_HELPTEST

Declaration

Source position: intuition.pas line 2820

type TgpHitTest = record
MethodID: LongWord; | GM_HITTEST or GM_HELPTEST
gpht_GInfo: PGadgetInfo; |
gpht_Mouse: record | These values are relative to the gadget select box for GM_HITTEST. For
x: SmallInt; |
y: SmallInt; |
end;
end;


TgpInput

Message parameter passed for GM_GOACTIVE or GM_HANDLEINPUT

Declaration

Source position: intuition.pas line 2863

type TgpInput = record
MethodID: LongWord; | GM_GOACTIVE or GM_HANDLEINPUT
gpi_GInfo: PGadgetInfo; | gadget context
gpi_IEvent: PInputEvent; | Pointer to the InputEvent that caused the method to be invoked.
gpi_Termination: PLongInt; | Pointer to a variable that is to be set by the gadget class, if GMR_VERIFY is returned. The lower 16 bits of this value are returned in the Code field of the IntuiMessage passed back to the application
gpi_Mouse: record | This struct defines the current mouse position, relative to the gadgets' bounding box.
x: SmallInt; |
y: SmallInt; |
end;
gpi_TabletData: PTabletData; | Pointer to TabletData structure or nil, if this input event did not originate from a tablet.
end;

Description

GM_GOACTIVE tells the gadget that it has become active and will receive input from now on from the method GM_HANDLEINPUT. This is stopped by using GM_GOINACTIVE.


tgpKeyGoInactive

Declaration

Source position: intuition.pas line 2965

type tgpKeyGoInactive = record

  MethodID: LongWord;

  gpki_GInfo: PGadgetInfo;

  gpki_Abort: LongWord;

end;


TgpKeyInput

Declaration

Source position: intuition.pas line 2949

type TgpKeyInput = record

  MethodID: LongWord;

  gpk_GInfo: PGadgetInfo;

  gpk_IEvent: PInputEvent;

  gpk_Termination: PLongInt;

end;


TgpKeyTest

Declaration

Source position: intuition.pas line 2935

type TgpKeyTest = record

  MethodID: LongWord;

  gpkt_GInfo: PGadgetInfo;

  gpkt_IMsg: PIntuiMessage;

  gpkt_VanillaKey: LongWord;

end;


TgpLayout

Message parameter passed for GM_LAYOUT

Declaration

Source position: intuition.pas line 2907

type TgpLayout = record
MethodID: LongWord; | GM_LAYOUT
gpl_GInfo: PGadgetInfo; |
gpl_Initial: LongWord; | Boolean that indicated, if this method was invoked, when you are added to a window (True) or if it is called, because the window was resized (False).
end;

Description

This method is called by intuition, if on of the GFLG_REL* flags or one of the GA_Rel* attributes is set and the window size changes or you are added to a window. In this method you should re-evaluate the size of yourself. You are not allowed to do any rendering operation during this method!


TgpMenuEvent

Declaration

Source position: intuition.pas line 3020

type TgpMenuEvent = record

  MethodID: LongWord;

  gpme_GInfo: PGadgetInfo;

  gpme_MenuAddress: Pointer;

  gpme_MenuNumber: LongWord;

  gpme_Window: PWindow;

end;


TgpQuery

Declaration

Source position: intuition.pas line 3003

type TgpQuery = record

  MethodID: LongWord;

  gpq_GInfo: PGadgetInfo;

  gpq_IEvent: PInputEvent;

  gpq_Type: LongWord;

  gpq_Data: LongInt;

end;


TgpRender

Message parameter passed for GM_RENDER

Declaration

Source position: intuition.pas line 2847

type TgpRender = record
MethodID: LongWord; | GM_RENDER
gpr_GInfo: PGadgetInfo; | Gadget context
gpr_RPort: PRastPort; | all ready for use
gpr_Redraw: LongInt; | might be a "highlight pass" (GREDRAW_*) Not all of these values make sense for all gadgets.
end;

Description

This method is invoked to draw the gadget into a rastport.


TGradientSpec

Declaration

Source position: intuition.pas line 1824

type TGradientSpec = record

  Direction: LongWord;

  Mode: Word;

  case LongInt of

    0: (

        Rel: record

          BasePen: Word;

          Contrast: array [0..1] of Byte;

        end;

      );

    1: (

        Abs: record

          RGBStart: array [0..2] of Byte;

          RGBEnd: array [0..2] of Byte;

          Reserved: array [0..3] of Byte;

        end;

      );

end;


TGUIPlugin

Declaration

Source position: intuition.pas line 382

type TGUIPlugin = record

  Node: TNode;

  Version: LongWord;

  Type_: LongWord;

  Attrs: LongWord;

  Flags: LongWord;

  AttrList: PTagItem;

  Reserved: array [0..3] of LongWord;

end;


TIBox

A data structure common in Intuition processing

Declaration

Source position: intuition.pas line 927

type TIBox = record

  Left: SmallInt;

  Top: SmallInt;

  Width: SmallInt;

  Height: SmallInt;

end;

Description

Describes a rectangle via a point with width and height

See also

GA_Bounds | GadgetClass Tag. [IS.] (PIBox) Bounds to be copied into the ExtGadget structure.
TimpFrameBox | Message argument for IM_FRAMEBOX
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
TPGX | System private data structure for now prop gadget extra info
TgpDomain |
IM_BOX | Get Image bounding rectangle
GADGET_BOX | Get bounding box of a gadget


TIClass

This structure is READ-ONLY, and allocated only by Intuition

Declaration

Source position: intuition.pas line 2612

type TIClass = record
cl_Dispatcher: THook; |
cl_Reserved: LongWord; | must be 0
cl_Super: PIClass; | Super Class
cl_ID: ClassID; |
cl_InstOffset: Word; | where within an object is the instance data for this class?
cl_InstSize: Word; | Size of instance data
cl_UserData: LongWord; | per-class data of your choice, application specific
cl_SubclassCount: LongWord; | # of direct suclasses
cl_ObjectCount: LongWord; | # of objects, made from this class must be 0, if the class is to be deleted
cl_Flags: LongWord; | Flags (CLF_INLIST)
end;


TImage

This is a brief image structure for very simple transfers of image data to a RastPort

Declaration

Source position: intuition.pas line 765

type TImage = record
LeftEdge: SmallInt; | Starting offset relative to some origin
TopEdge: SmallInt; | Starting offsets relative to some origin
Width: SmallInt; | Pixel size (though data is Word-aligned)
Height: SmallInt; | Height of image
Depth: SmallInt; | Pixel size
ImageData: Pointer; | A Pointer to the actual Word-aligned bits
PlanePick: Byte; |
PlaneOnOff: Byte; |
NextImage: PImage; | If not nil, Intuition presumes that it points to another Image structure with another Image to be rendered
end;

Description

The TImage.PlanePick and PlaneOnOff variables work much the same way as the equivalent GELS Bob variables. It's a space-saving mechanism for image data. Rather than defining the image data for every plane of the RastPort, you need define data only for the planes that are not entirely zero or one. As you define your Imagery, you will often find that most of the planes ARE just as color selectors. For instance, if you're designing a two-color Gadget to use colors two and three, and the Gadget will reside in a five-plane display, bit plane zero of your imagery would be all ones, bit plane one would have data that describes the imagery, and bit planes two through four would be all zeroes. Using these flags allows you to avoid wasting all that memory in this way: first, you specify which planes you want your data to appear in using the PlanePick variable. For each bit set in the variable, the next "plane" of your image data is blitted to the display. For each bit clear in this variable, the corresponding bit in PlaneOnOff is examined. If that bit is clear, a "plane" of zeroes will be used. If the bit is set, ones will go out instead. So, for our example:

Gadget.PlanePick = $02;

Gadget.PlaneOnOff = $01;

Note that this also allows for generic Gadgets, like the System Gadgets, which will work in any number of bit planes. Note also that if you want an Image that is only a filled rectangle, you can get this by setting PlanePick to zero (pick no planes of data) and set PlaneOnOff to describe the pen color of the rectangle.

See also

PImage | This is a brief image structure for very simple transfers of image data to a RastPort
TWindow | Window structure
TNewWindow | New window structure
TExtNewWindow | Future TNewWindow
TDrawInfo | Graphical informations for the 3D look
GA_Image | GadgetClass Tag. (PImage) Gadget imagry is an image
GA_SelectRender | GadgetClass Tag.
DrawImage | Draw the specified Image structure into a RastPort.
DrawImageState | Draw an (extended) Intuition Image with special visual state.
EraseImage | Erases an Image.
PointInImage | Tests whether an image "contains" a point.
IM_BGPEN | Set Image Background Pen
IM_BOX | Get Image bounding rectangle
IM_FGPEN | Set Image Foreground pen


TImageGeometryMsg

Declaration

Source position: intuition.pas line 3734

type TImageGeometryMsg = record

  igm_MethodID: LongWord;

  igm_RastPort: PRastPort;

  igm_DrawInfo: PDrawInfo;

  igm_ImageBox: TIBox;

  igm_RenderBox: TIBox;

  igm_Reserved: LongWord;

  igm_Flags: LongWord;

end;


TimpDomainFrame

Declaration

Source position: intuition.pas line 3296

type TimpDomainFrame = record

  MethodID: LongWord;

  imp_DrInfo: PDrawInfo;

  imp_RPort: PRastPort;

  imp_Which: LongInt;

  imp_Domain: TIBox;

  imp_Attrs: PTagItem;

end;


TimpDraw

Message argument for IM_DRAW or IM_DRAWFRAME

Declaration

Source position: intuition.pas line 3245

type TimpDraw = record
MethodID: LongWord; | IM_DRAW or IM_DRAWFRAME
imp_RPort: PRastPort; |
imp_Offset: record |
x: SmallInt; |
y: SmallInt; |
end;
imp_State: LongWord; |
imp_DrInfo: PDrawInfo; | May be nil
imp_Dimensions: record | Only valid for IM_DRAWFRAME
Width: SmallInt; |
Height: SmallInt; |
end;
end;


TimpErase

Message argument for IM_ERASE or IM_ERASEFRAME

Declaration

Source position: intuition.pas line 3264

type TimpErase = record
MethodID: LongWord; | IM_ERASE or IM_ERASEFRAME
imp_RPort: PRastPort; |
imp_Offset: record |
x: SmallInt; |
y: SmallInt; |
end;
imp_Dimensions: record | Only valid for IM_DRAWFRAME
Width: SmallInt; |
Height: SmallInt; |
end;
end;

Description

This is a subset of TimpDraw


TimpExtent

Declaration

Source position: intuition.pas line 3317

type TimpExtent = record

  MethodID: LongWord;

  imp_DrInfo: PDrawInfo;

  imp_RPort: PRastPort;

  imp_Region: PRegion;

  imp_Action: LongWord;

  imp_Flags: LongWord;

  imp_Attrs: PTagItem;

  imp_State: LongWord;

  imp_Frame: TIBox;

end;


TimpFrameBox

Message argument for IM_FRAMEBOX

Declaration

Source position: intuition.pas line 3231

type TimpFrameBox = record
MethodID: LongWord; | IM_FRAMEBOX
imp_ContentsBox: PIBox; | input: relative box of contents
imp_FrameBox: PIBox; | output: rel. box of encl frame
imp_DrInfo: PDrawInfo; | may be nil
imp_FrameFlags: LongWord; | FRAMEF_SPECIFY
end;


TimpHitTest

Message argument for IM_HITTEST or IM_HITFRAME

Declaration

Source position: intuition.pas line 3280

type TimpHitTest = record
MethodID: LongWord; | IM_HITTEST or IM_HITFRAME
imp_Point: record |
x: SmallInt; |
y: SmallInt; |
end;
imp_Dimensions: record | only valid for IM_HITFRAME
Width: SmallInt; |
Height: SmallInt; |
end;
end;


TIntuiMessage

Intuition message structure

Declaration

Source position: intuition.pas line 797

type TIntuiMessage = record
ExecMessage: TMessage; | Standard Exec message
IClass: LongWord; | The Class bits correspond directly with the IDCMP Flags (IDCMP_*), except for the special bit IDCMP_LONELYMESSAGE
Code: Word; | The Code field is for special values like Menu number, Keycode and so on
Qualifier: Word; | The Qualifier field is a copy of the current InputEvent's Qualifier
IAddress: Pointer; | IAddress contains particular addresses for Intuition functions, like the pointer to the Gadget or the Screen
MouseX: SmallInt; | When getting mouse movement reports, any event you get will have the the mouse coordinates in these variables.
MouseY: SmallInt; | the coordinates are relative to the upper-left corner of your Window (WA_GIMMEZEROZERO notwithstanding)
Seconds: LongWord; | The time values are copies of the current system clock time.
Micros: LongWord; | Micros are in units of microseconds, Seconds in seconds.
IDCMPWindow: Pointer; | The IDCMPWindow variable will always have the Pointer of the Window of this IDCMP
SpecialLink: PIntuiMessage; | System-use variable
end;

See also

TWindow | Window structure
exec.GetMsg | Get next message from message port
exec.PutMsg | Put a message to a message port
exec.ReplyMsg | Put a message to its reply port
exec.WaitPort | Wait for a given port to be non-empty


TIntuiRawKeyData

Declaration

Source position: intuition.pas line 835

type TIntuiRawKeyData = record

  Version: Word;

  Reserved: Word;

  Class_: Word;

  Code: Word;

  DeadKeys: TExtendedDeadKey;

end;


TIntuiText

IntuiText is a series of strings.

Declaration

Source position: intuition.pas line 46

type TIntuiText = record
FrontPen: Byte; | Front pen for Font rendering
BackPen: Byte; | Back pen for Font rendering
DrawMode: Byte; | The mode for rendering the text
LeftEdge: SmallInt; | relative left start location for the text
TopEdge: SmallInt; | relative top start location for the text
ITextFont: PTextAttr; | If nil, you accept the default
IText: PChar; | A pointer to null-terminated text
NextText: PIntuiText; | Continuation to TxWrite another text
end;

Description

IntuiText is a series of strings that start with a screen location (always relative to the upper-left corner of something) and then the text of the string. The text is null-terminated.

See also

TGadget | Structure to describe a Gadget
TExtGadget | Extended Gadget structure
TRequester | Requesters The following struct is used for standard intuition requesters
GFLG_LABELITEXT | Flag for TGadget.SpecialInfo. TGadget.GadgetText is a PIntuiText
GA_IntuiText | GadgetClass Tag. [IS.] (PIntuiText) Label is an IntuiText.
AutoRequest | Automatically build and get response from a requester.
BuildSysRequest | Build and display a system requester.
IntuiTextLength | Return the length (pixel-width) of an IntuiText.
PrintIText | Print text described by the IntuiText argument.


TIntuitionBase

Intuition basic structure

Declaration

Source position: intuition.pas line 2464

type TIntuitionBase = record
LibNode: TLibrary; | Standard Libnode
ViewLord: TView; |
ActiveWindow: PWindow; | Currently active Window
ActiveScreen: PScreen; | Currently Active Screen
FirstScreen: PScreen; | for linked list of all screens, the FirstScreen variable points to the frontmost Screen. Screens are then maintained in a front to back order using TScreen.NextScreen
Flags: LongWord; | values are all system private
MouseY: SmallInt; | Current Mouse position
MouseX: SmallInt; |
Seconds: LongWord; | timestamp of most current input event [s]
Micros: LongWord; | The data beyond this point has changed, is changing, and will continue to change.
end;

Description

It is sometimes necessary to examine the IntuitionBase structure. Items such as the address of the active screen and window, current mouse coordinates and more can be found there. It is never a good idea to simply read these fields, as they are prone to sudden change. The IntuitionBase structure must always be locked before looking at its fields.

It is necessary to inform Intuition that an application is about to examine IntuitionBase so that Intuition will not change any variables and IntuitionBase will remain static during the access. The call LockIBase(0) will lock the state of IntuitionBase so that it may be examined. During the time that the application has IntuitionBase locked, all Intuition input processing is frozen. Make every effort to examine IntuitionBase and release the lock as quickly as possible. When done call UnlockIBase(lock) where lock is what LockIBase(0) returned.

The values in IntuitionBase are read-only. Applications should never write values to IntuitionBase.


TIntuiWheelData

Declaration

Source position: intuition.pas line 822

type TIntuiWheelData = record

  Version: Word;

  Reserved: Word;

  WheelX: SmallInt;

  WheelY: SmallInt;

end;


TITLEPEN

Declaration

Source position: intuition.pas line 1986

const TITLEPEN = $0027;


TMenu

Structure to describe a menu

Declaration

Source position: intuition.pas line 122

type TMenu = record
NextMenu: PMenu; | Next Menu on the same level
LeftEdge: SmallInt; | Left position of the select box
TopEdge: SmallInt; | Top position of the select box
Width: SmallInt; | Width of the select box
Height: SmallInt; | Height of the select box
Flags: Word; | Flags for the menu (MENUENABLED)
MenuName: PChar; | Text for this Menu Header
FirstItem: PMenuItem; | Pointer to first menu item in chain
JazzX: SmallInt; |
JazzY: SmallInt; |
BeatX: SmallInt; |
BeatY: SmallInt; |
end;

See also

TWindow | Window structure
ItemAddress | Returns the address of the specified MenuItem.
ResetMenuStrip | Re-attach a menu strip to a window.
SetMenuStrip | Attach a menu strip to a window.


TMenuEventMessage

Declaration

Source position: intuition.pas line 320

type TMenuEventMessage = record

  StructSize: LongWord;

  EventType: LongWord;

  Window: Pointer;

  UserData: Pointer;

end;


TMenuItem

Structure to describe a menu item

Declaration

Source position: intuition.pas line 77

type TMenuItem = record
NextItem: PMenuItem; | Pointer to next in chained list
LeftEdge: SmallInt; | Left position of the select box
TopEdge: SmallInt; | Top position of the select box
Width: SmallInt; | Width of the select box
Height: SmallInt; | Height of the select box
Flags: Word; | Flags for the item (e.g. Checked, ISDRAWN, HIGHITEM, ITEMENABLED, MENUTOGGLE, COMMSEQ, ITEMTEXT, CHECKIT)
MutualExclude: LongInt; | Set bits mean this item excludes that
ItemFill: Pointer; | PImage, PIntuiText or nil
SelectFill: Pointer; | PImage, PIntuiText or nil when this item is pointed to by the cursor and the items highlight mode HIGHIMAGE is selected, this alternate image will be displayed.
Command: Char; | Only if application sets the COMMSEQ flag
SubItem: PMenuItem; | If non-nil, DrawMenu shows "->"
NextSelect: Word; | The NextSelect field represents the menu number of next selected item (when user has drag-selected several items)
end;

See also

TMenu | Structure to describe a menu
ItemAddress | Returns the address of the specified MenuItem.


TMenuScanMessage

Declaration

Source position: intuition.pas line 311

type TMenuScanMessage = record

  StructSize: LongWord;

  Level: LongInt;

  Args: array [0..3] of LongWord;

end;


TMenuStringMessage

Declaration

Source position: intuition.pas line 302

type TMenuStringMessage = record

  StructSize: LongWord;

  StringID: LongWord;

  Catalog: Pointer;

  CharSet: LongWord;

end;


TmpDeleteMenu

Declaration

Source position: intuition.pas line 231

type TmpDeleteMenu = record

  MethodID: LongWord;

  mpdm_Reserved: LongWord;

end;


TmpFindID

Declaration

Source position: intuition.pas line 207

type TmpFindID = record

  MethodID: LongWord;

  mpfi_Reserved: LongWord;

  mpfi_ID: LongWord;

end;


TmpGetState

Declaration

Source position: intuition.pas line 257

type TmpGetState = record

  MethodID: LongWord;

  mpgs_Reserved: LongWord;

  mpgs_ID: LongWord;

end;


TmpHandleEvent

Declaration

Source position: intuition.pas line 272

type TmpHandleEvent = record

  MethodID: LongWord;

  mphe_Reserved: LongWord;

  mphe_CurrentID: LongWord;

  mphe_Window: Pointer;

  mphe_UserData: Pointer;

end;


TmpNewMenu

Declaration

Source position: intuition.pas line 224

type TmpNewMenu = record

  MethodID: LongWord;

  mpnm_Reserved: LongWord;

  mpnm_AttrList: PTagItem;

end;


TmpNextChild

Declaration

Source position: intuition.pas line 239

type TmpNextChild = record

  MethodID: LongWord;

  mpnc_Reserved: LongWord;

  mpnc_Current: PObject_;

end;


TmpNextSelect

Declaration

Source position: intuition.pas line 264

type TmpNextSelect = record

  MethodID: LongWord;

  mpns_Reserved: LongWord;

  mpns_CurrentID: LongWord;

end;


TmpScan

Declaration

Source position: intuition.pas line 215

type TmpScan = record

  MethodID: LongWord;

  mps_Reserved: LongWord;

  mps_Hook: PHook;

  mps_Args: array [0..3] of LongWord;

end;


TmpSetState

Declaration

Source position: intuition.pas line 247

type TmpSetState = record

  MethodID: LongWord;

  mpss_Reserved: LongWord;

  mpss_ID: LongWord;

  mpss_ApplyMask: LongWord;

  mpss_StateMask: LongWord;

end;


TmpSetup

Declaration

Source position: intuition.pas line 281

type TmpSetup = record

  MethodID: LongWord;

  mps_Reserved: LongWord;

  mps_Initial: LongWord;

end;


TMsg

Declaration

Source position: intuition.pas line 36

type TMsg = record

  MethodID: LongWord;

Message ID OM_*

end;

See also

DoGadgetMethodA | Invoke method on a boopsi gadget.
TopSet | Message structure for OM_NEW/OM_SET
TopGet | Message structure for OM_GET
TopAddTail | Message structure for OM_ADDTAIL
TopMember | Message structure for OM_ADDMEMBER/OM_REMMEMBER
TopUpdate | Message structure for OM_NOTIFY/OM_UPDATE


TNewScreen

Description of a new screen

Declaration

Source position: intuition.pas line 2123

type TNewScreen = record
LeftEdge: SmallInt; | initial position of your screen
TopEdge: SmallInt; | Left and Top are specified relative to the Intuition's view, in same resolution as the screen pixels.
Width: SmallInt; | the width for this screen's RastPort, or the constant STDSCREENWIDTH to get the current default width
Height: SmallInt; | the height for his screen's RastPort, or the constant STDSCREENHEIGHT to get the current default height
Depth: SmallInt; | number of bitplanes
DetailPen: Byte; | pen number for details (like gadgets or text in title bar/border/gadget) The common value for this pen is 0.
BlockPen: Byte; | pen number for block fills (like title bar/border/gadget) The common value for this pen is 1.
ViewModes: Word; | the Modes for the ViewPort (and View)
Type_: Word;
Font: PTextAttr; | this Screen's default text attributes
DefaultTitle: PChar; | the default title for this Screen
Gadgets: PGadget; | your own Gadgets for this Screen
CustomBitMap: PBitMap; | if you have your own display memory that you want used for this screen, the CustomBitMap field should point to the BitMap structure that describes your display memory.
end;


TNewWindow

New window structure

Declaration

Source position: intuition.pas line 1095

type TNewWindow = record
LeftEdge: SmallInt; | Left edge of window
TopEdge: SmallInt; | Top edge of window
Width: SmallInt; | Width of window
Height: SmallInt; | Height of window
DetailPen: Byte; | For bar/border/gadget rendering
BlockPen: Byte; | For bar/border/gadget rendering
IDCMPFlags: LongWord; | User-selected IDCMP flags (IDCMP_*)
Flags: LongWord; | Window Flags (WFLG_*)
FirstGadget: PGadget; | You supply a linked-list of Gadgets for your Window. This list does not include system Gadgets.
CheckMark: PImage; | A Pointer to the imagery that will be used when rendering MenuItems of this Window that want to be checkmarked if this is equal to nil, you'll get the default imagery
Title: PChar; | The title text for this window
Screen: PScreen; | Only if you've defined a CUSTOMSCREEN and want this Window to open in it. If so, you pass the Pointer of the Custom Screen structure in this variable. Otherwise, this variable is ignored and doesn't have to be initialized.
BitMap: PBitMap; | SUPER_BITMAP Window? If so, put the Pointer of your BitMap structure in this variable. If not, this variable is ignored and doesn't have to be initialized
MinWidth: SmallInt; | Minimum / maximum size of your window, only if WFLG_SIZEGADGET is set,
MinHeight: SmallInt; | if MinWidth/Height = 0 then its set to the opening size.
MaxWidth: Word; |
MaxHeight: Word; |
WType: Word; | Describes the Screen in which you want this Window to open. The type value can either be CUSTOMSCREEN_f or one of the system standard Screen Types such as WBENCHSCREEN_f. See the type definitions under the Screen structure
end;

See also

OpenWindow | Open an Intuition window.
OpenWindowTagList | OpenWindow() with TagItem extension.


TopAddTail

Message structure for OM_ADDTAIL

Declaration

Source position: intuition.pas line 2595

type TopAddTail = record
MethodID: LongWord; | OM_ADDTAIL
opat_List: PList; | The exec list to add the object to
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TOPAZ_EIGHTY

default font size

Declaration

Source position: intuition.pas line 2233

const TOPAZ_EIGHTY = 8;

Description

This actually describe the height of the default font. The default font type is the topaz font, which is a fixed width font that can be used in either eighty-column or sixty-column mode. The Preferences structure reflects which is currently selected by the value found in the variable FontSize, which may have either of the values defined below. These values actually are used to select the height of the default font. By changing the height, the resolution of the font changes as well.

See also

TOPAZ_SIXTY

default font size


TOPAZ_SIXTY

default font size

Declaration

Source position: intuition.pas line 2234

const TOPAZ_SIXTY = 9;

Description

This actually describe the height of the default font. The default font type is the topaz font, which is a fixed width font that can be used in either eighty-column or sixty-column mode. The Preferences structure reflects which is currently selected by the value found in the variable FontSize, which may have either of the values defined below. These values actually are used to select the height of the default font. By changing the height, the resolution of the font changes as well.

See also

TOPAZ_EIGHTY

default font size


TopGet

Message structure for OM_GET

Declaration

Source position: intuition.pas line 2587

type TopGet = record
MethodID: LongWord; | OM_GET
opg_AttrID: LongWord; | ID of attribute to get
opg_Storage: PLongWord; | may be other types, but 'integer' types are all LongWord
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TopMember

Message structure for OM_ADDMEMBER/OM_REMMEMBER

Declaration

Source position: intuition.pas line 2603

type TopMember = record
MethodID: LongWord; | OM_ADDMEMBER or OM_REMMEMBER
opam_Object: PObject_; | add or remove this object
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TopSet

Message structure for OM_NEW/OM_SET

Declaration

Source position: intuition.pas line 2560

type TopSet = record
MethodID: LongWord; | OM_NEW or OM_SET
ops_AttrList: PTagItem; | new attributes
ops_GInfo: PGadgetInfo; | Always there for gadgets, when SetGadgetAttrsA() is used, but will be nil for OM_NEW
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TopUpdate

Message structure for OM_NOTIFY/OM_UPDATE

Declaration

Source position: intuition.pas line 2568

type TopUpdate = record
MethodID: LongWord; | OM_NOTIFY or OM_UPDATE
opu_AttrList: PTagItem; | tag list of new attributes
opu_GInfo: PGadgetInfo; | Non-nil when SetGadgetAttrsA() or notification resulting from gadget input occurs.
opu_Flags: LongWord; | Additional flags (OPUF_*)
end;

See also

TMsg |
DoSuperMethodA | Perform method on object coerced to superclass.


TPGX

System private data structure for now prop gadget extra info

Declaration

Source position: intuition.pas line 2511

type TPGX = record

  pgx_Container: TIBox;

  pgx_NewKnob: TIBox;

end;


TPreferences

Old Style Preferences

Declaration

Source position: intuition.pas line 2238

type TPreferences = record
FontHeight: ShortInt; | height for system default font
PrinterPort: Byte; | printer port connection constant describing what's hooked up to the port
BaudRate: Word; | baud rate for the serial port
KeyRptSpeed: TTimeVal; | repeat speed for keyboard
KeyRptDelay: TTimeVal; | Delay before keys repeat
DoubleClick: TTimeVal; | Interval allowed between clicks
PointerMatrix: array [0..POINTERSIZE-1] of Word; | Mouse Data: Definition of pointer sprite
XOffset: ShortInt; | Mouse Data: X-Offset for active 'bit'
YOffset: ShortInt; | Mouse Data: Y-Offset for active 'bit'
color17: Word; | Mouse Data: Colours for sprite pointer
color18: Word; | Mouse Data:
color19: Word; | Mouse Data:
PointerTicks: Word; | Mouse Data: Sensitivity of the pointer
color0: Word; | Workbench Screen colors
color1: Word; | Standard default colours
color2: Word; | Used in the Workbench
color3: Word; |
ViewXOffset: ShortInt; | Offset for top lefthand corner
ViewYOffset: ShortInt; | Y dimensions
ViewInitX: SmallInt; | X dimensions
ViewInitY: SmallInt; | View initial offset values
EnableCLI: WordBool; | CLI availability switch
PrinterType: Word; | printer type
PrinterFilename: array [0..FILENAME_SIZE-1] of Char; | file for printer
PrintPitch: Word; | print pitch
PrintQuality: Word; | print quality
PrintSpacing: Word; | number of lines per inch
PrintLeftMargin: Word; | left margin in characters
PrintRightMargin: Word; | right margin in characters
PrintImage: Word; | positive or negative
PrintAspect: Word; | horizontal or vertical
PrintShade: Word; | b/w, half-tone, or color
PrintThreshold: SmallInt; | darkness ctrl for b/w dumps
PaperSize: Word; | paper size
PaperLength: Word; | paper length in number of lines
PaperType: Word; | continuous or single sheet
SerRWBits: Byte; | Serial Setting: upper nibble = (8-number of read bits), lower nibble = (8-number of write bits)
SerStopBuf: Byte; | Serial Setting: upper nibble = (number of stop bits - 1), lower nibble = (table value for BufSize)
SerParShk: Byte; | Serial Setting: upper nibble = (value for Parity setting), lower nibble = (value for Handshake mode)
LaceWB: Byte; | if workbench is to be interlaced
Pad: array [0..FILENAME_SIZE-1] of Char; |
PrinterDevPrivateFlags: Byte;
PrtDevOpenDeviceFlags: LongWord;
PrtDevName: array [0..DEVNAME_SIZE-1] of Char; | Device used by printer.device (leave out the ".device")
DefaultPrtUnit: Byte; | Default unit opened by printer.device
DefaultSerUnit: Byte; | Default serial unit
RowSizeChange: SmallInt; | Affect NormalDisplayRows/Columns
ColumnSizeChange: SmallInt; |
PrintFlags: Word; | user preference flags
PrintMaxWidth: Word; | max width of printed picture in 10ths/inch
PrintMaxHeight: Word; | max height of printed picture in 10ths/inch
PrintDensity: Byte; | print density
PrintXOffset: Byte; | offset of printed picture in 10ths/inch
wb_Width: Word; | override default workbench width
wb_Height: Word; | override default workbench height
wb_Depth: Byte; | override default workbench depth
ext_size: Byte; | extension information -- do not touch! extension size in blocks of 64 bytes DO NOT TOUCH
end;

See also

GetDefPrefs | Get a copy of the the Intuition default Preferences.
GetPrefs | Get the current Intuition Preferences structure.
SetPrefs | Set Intuition preferences data.


TPropInfo

Proportional Gadget

Declaration

Source position: intuition.pas line 648

type TPropInfo = record
Flags: Word; | General purpose flag bits (e.g. AUTOKNOB, FREEHORIZ, FREEVERT, PROPBORDERLESS, KNOBHIT or PROPNEWLOOK)
HorizPot: Word; | 16-bit FixedPoint horizontal quantity percentage
VertPot: Word; | 16-bit FixedPoint vertical quantity percentage
HorizBody: Word; | horizontal Body
VertBody: Word; | vertical Body
CWidth: Word; | Container width (with any relativity absoluted) Intuition sets and maintain
CHeight: Word; | Container height (with any relativity absoluted) Intuition sets and maintain
HPotRes: Word; | Horizontal pot increment
VPotRes: Word; | Vertical pot increment
LeftBorder: Word; | Left Container border
TopBorder: Word; | Top Container border
end;

Description

You initialize the Pot variables before the Gadget is added to the system. Then you can look here for the current settings any time, even while User is playing with this Gadget. To adjust these after the Gadget is added to the System, use ModifyProp() The Pots are the actual proportional settings, where a value of zero means zero and a value of MAXPOT means that the Gadget is set to its maximum setting.

The 16-bit FixedPoint Body variables describe what percentage of the entire body of stuff referred to by this Gadget is actually shown at one time. This is used with the AUTOKNOB routines, to adjust the size of the AUTOKNOB according to how much of the data can be seen. This is also used to decide how far to advance the Pots when User hits the Container of the Gadget. For instance, if you were controlling the display of a 5-line Window of text with this Gadget, and there was a total of 15 lines that could be displayed, you would set the VertBody value to (MAXBODY / (TotalLines / DisplayLines)) = MAXBODY / 3. Therefore, the AUTOKNOB would fill 1/3 of the container, and if User hits the Cotainer outside of the knob, the pot would advance 1/3 (plus or minus) If there's no body to show, or the total amount of displayable info is less than the display area, set the Body variables to the max. To adjust these after the Gadget is added to the System, use ModifyProp()


TPubScreenNode

Public Shared Screen Node

Declaration

Source position: intuition.pas line 2166

type TPubScreenNode = record
psn_Node: TNode; | ln_Name is screen name
psn_Screen: PScreen; |
psn_Flags: Word; | Flags (PSNF_*)
psn_Size: SmallInt; | includes name buffer
psn_VisitorCount: SmallInt; | how many visitor windows
psn_SigTask: PTask; | who to signal when visitors gone
psn_SigBit: Byte; | which signal
end;

Description

This is the representative of a public shared screen. This is an internal data structure, but some functions may present a copy of it to the calling application. In that case, be aware that the screen pointer of the structure can NOT be used safely, since there is no guarantee that the referenced screen will remain open and a valid data structure. Never change one of these.


TRemember

Structure to remember memory allocations

Declaration

Source position: intuition.pas line 1768

type TRemember = record
NextRemember: PRemember; | Next memory block in List
RememberSize: LongWord; | Size of Memory Block
Memory: PByte; | Pointer to the allocated memory
end;

Description

This structure is used for remembering what memory has been allocated to date by a given routine, so that a premature abort or systematic exit can deallocate memory cleanly, easily, and completely

See also

AllocRemember | Allocate Memory with tracking to make freeing easy.
FreeRemember | Free memory allocated by calls to AllocRemember().


TRenderMsg

Declaration

Source position: intuition.pas line 404

type TRenderMsg = record

  rm_MethodID: LongWord;

  rm_RastPort: PRastPort;

  rm_DrawInfo: Pointer;

  rm_Bounds: TRectangle;

  rm_State: LongWord;

  rm_IAddress: Pointer;

  rm_Flags: LongWord;

  rm_TagList: PTagItem;

end;


TRequester

Requesters The following struct is used for standard intuition requesters

Declaration

Source position: intuition.pas line 720

type TRequester = record
OlderRequest: PRequester; |
LeftEdge: SmallInt; | dimensions of the entire box
TopEdge: SmallInt; |
Width: SmallInt; |
Height: SmallInt; |
RelLeft: SmallInt; | For Pointer relativity offsets
RelTop: SmallInt; |
ReqGadget: PGadget; | First gadget of the requester
ReqBorder: PBorder; | First border of the requester
ReqText: PIntuiText; | First intuitext of the requester
Flags: Word; | Flags for requester (e.g. POINTREL, PREDRAWN, NOISYREQ, SIMPLEREQ, USEREQIMAGE, NOREQBACKFILL, REQOFFWINDOW,REQACTIVE, SYSREQUEST or DEFERREFRESH)
BackFill: Byte; | Pen number for back-plane fill before draws
ReqLayer: PLayer; | Layer in place of clip rect
ReqPad1: array [0..31] of Byte; | Private
ImageBMap: PBitMap; | you may use this to fill the requester with your own image
RWindow: Pointer; | Window, which the requester belongs to
ReqImage: Pointer; | corresponds to USEREQIMAGE
ReqPad2: array [0..31] of Byte; | Private
end;

Description

The ClipRect and BitMap and used for rendering the requester

If the BitMap plane pointers are non-zero, this tells the system that the image comes pre-drawn (if the appliprog wants to define it's own box, in any shape or size it wants!); this is OK by Intuition as long as there's a good correspondence between the image and the specified Gadgets

See also

PRequester | Requesters The following struct is used for standard intuition requesters
TWindow | Window structure
TGadgetInfo | The TGadgetInfo structure contains information about the display on which the gadget needs to render itself
ActivateGadget | Activate a (string or custom) gadget.
AddGList | Add a linked list of gadgets to a window or requester.
DoGadgetMethodA | Invoke method on a boopsi gadget.
EndRequest | Remove a currently active requester.
InitRequester | Initialize a Requester structure.
ModifyProp | Modify the current parameters of a proportional gadget.
NewModifyProp | ModifyProp(), but with selective refresh.
OffGadget | Disable the specified gadget.
OnGadget | Enable the specified gadget.
RefreshGadgets | Refresh (redraw) the gadget display.
RefreshGList | Refresh (redraw) a chosen number of gadgets.
Request | Activate a requester.
SetDMRequest | Set the DMRequest of a window.
SetGadgetAttrsA | Specify attribute values for a boopsi gadget.


TScreen

Basic screen structure

Declaration

Source position: intuition.pas line 1010

type TScreen = record
NextScreen: PScreen; | linked list of screens in intuition
FirstWindow: PWindow; | linked list Screen's Windows
LeftEdge: SmallInt; | Left edge of Screen
TopEdge: SmallInt; | Top Edge of screen
Width: SmallInt; | Width of screen
Height: SmallInt; | Height of screen
MouseY: SmallInt; |
MouseX: SmallInt; | Current mouse position, relative to upper left edge
Flags: Word; | Screen flags
Title: PChar; | Screen title
DefaultTitle: PChar; | shown when window without screen title is active
BarHeight: ShortInt; | Bar sizes for this Screen
BarVBorder: ShortInt; |
BarHBorder: ShortInt; |
MenuVBorder: ShortInt; |
MenuHBorder: ShortInt; |
WBorTop: ShortInt; | Decoration size for all windows in this screen
WBorLeft: ShortInt; |
WBorRight: ShortInt; |
WBorBottom: ShortInt; |
Font: PTextAttr; | this screen's default font
ViewPort: TViewPort; | describing the Screen's display
RastPort: TRastPort; | describing Screen rendering
BitMap: TBitMap; | extra copy of RastPort BitMap obsolete
LayerInfo: TLayer_Info; | each screen gets a LayerInfo
FirstGadget: PGadget; | You supply a linked-list of Gadgets for your Screen. This list does not include system Gadgets. You get the standard system Screen Gadgets by default
DetailPen: Byte; | for bar/border/gadget rendering
BlockPen: Byte; | for bar/border/gadget rendering
SaveColor0: Word; | SAve variable for display Beep
BarLayer: PLayer; | This layer is for the Screen and Menu bars
ExtData: PByte; | general purpose to User data extension
UserData: PByte; |
end;


TScreenBuffer

Screen buffer structure

Declaration

Source position: intuition.pas line 2211

type TScreenBuffer = record
sb_BitMap: PBitMap; | BitMap of this buffer
sb_DBufInfo: PDBufInfo; | DBufInfo for this buffer
end;

Description

Intuition supports double-buffering in screens, with friendly interaction with menus and certain gadgets. For each buffer, you need to get one of these structures from the AllocScreenBuffer() call. Never allocate your own ScreenBuffer structures! The sb_DBufInfo field is for your use.

See also

AGraphics.AllocDBufInfo

Allocate structure for multi-buffered animation


TScreenNotifyMessage

Declaration

Source position: intuition.pas line 370

type TScreenNotifyMessage = record

  snm_Message: TMessage;

  snm_Class: LongWord;

  snm_Code: LongWord;

  snm_Object: Pointer;

  snm_UserData: Pointer;

  snm_Request: Pointer;

  snm_Reserved: array [0..4] of LongWord;

end;


TScrollHook

Declaration

Source position: intuition.pas line 1375

type TScrollHook = record

  sh_Hook: PHook;

  sh_Top: LongInt;

  sh_Total: LongInt;

  sh_Visible: LongInt;

  sh_Size: LongInt;

end;


TScrollMsg

Declaration

Source position: intuition.pas line 1384

type TScrollMsg = record

  sm_Action: LongWord;

  sm_NumItems: LongInt;

  sm_NumPixels: LongInt;

  sm_TopItem: LongInt;

  sm_TopPixel: LongInt;

end;


TSGWork

String gadget message

Declaration

Source position: intuition.pas line 3435

type TSGWork = record
Gadget: PGadget; | the contestant itself
StringInfo: PStringInfo; | easy access to sinfo
WorkBuffer: PChar; | intuition's planned result
PrevBuffer: PChar; | what was there before
Modes: LongWord; | current mode (SGM_*)
IEvent: PInputEvent; | actual event: do not change
Code: Word; | character code, if one Byte
BufferPos: SmallInt; | cursor position
NumChars: SmallInt; |
Actions: LongWord; | what Intuition will do
LongInt_: LongInt; | temp storage for LongInt
GadgetInfo: PGadgetInfo; |
EditOp: Word; | from constants below
end;

Description

The local (application) hook may only change the Code, Actions, WorkBuffer, NumChars, BufferPos and LongInt fields. None of the other fields in the TSGWork structure may be modified.


TStringExtend

Extended string info for Gadgets texts

Declaration

Source position: intuition.pas line 3422

type TStringExtend = record
Font: PTextFont; | Must be an open Font (not TextAttr)
Pens: array [0..1] of Byte; | Color of text/background
ActivePens: array [0..1] of Byte; | Colors when gadget is active
InitialModes: LongWord; | Initial mode flags (e.g. Checked, ISDRAWN, HIGHITEM, ITEMENABLED, MENUTOGGLE, COMMSEQ, ITEMTEXT, CHECKIT)
EditHook: PHook; | If non-nil, must supply WorkBuffer
WorkBuffer: PChar; | Must be as large as StringInfo.Buffer
Reserved: array [0..3] of LongWord; | Set to 0
end;

See also

GFLG_STRINGEXTEND | Flag for TGadget.SpecialInfo. this String Gadget has PStringExtend
GACT_STRINGEXTEND | Activation flag for TGadget.Activation. this String Gadget has PStringExtend
TStringInfo | String Gadget structure


TStringInfo

String Gadget structure

Declaration

Source position: intuition.pas line 695

type TStringInfo = record
Buffer: PChar; | The buffer containing the start and final string
UndoBuffer: PChar; | Optional buffer for undoing current entry
BufferPos: SmallInt; | Character position in Buffer
MaxChars: SmallInt; | Maximal number of chars in Buffer (including #0)
DispPos: SmallInt; | Buffer position of first displayed character
UndoPos: SmallInt; | Character position in the undo buffer
NumChars: SmallInt; | Number of characters currently in Buffer
DispCount: SmallInt; | Number of whole characters visible in Container
CLeft: SmallInt; | Left offset of the container
CTop: SmallInt; | Top offset of the container
Extension: Pointer; | you can initialize this variable before the gadget is submitted to Intuition, and then examine it later to discover what LongInt the user has entered (if the user never plays with the gadget, the value will be unchanged from your initial setting)
_LongInt: LongInt; |
AltKeyMap: Pointer; | If you want this Gadget to use your own Console keymapping, you set the GACT_ALTKEYMAP bit in the Activation flags of the Gadget, and then set this variable to point to your keymap. If you don't set the GACT_ALTKEYMAP, you'll get the standard ASCII keymapping.
end;

See also

PStringInfo

Special info for TGadget.SpecialInfo if TGadget.Type is a GTYP_STRGADGET


TSubStyle

Declaration

Source position: intuition.pas line 3690

type TSubStyle = record

  Name: PChar;

  Category: Word;

  ID: Word;

end;


TSysIPlugin

Declaration

Source position: intuition.pas line 3696

type TSysIPlugin = record

  Node: TNode;

  Version: LongWord;

  Type_: LongWord;

  Attrs: LongWord;

  Flags: LongWord;

  AttrList: PTagItem;

  Reserved: array [0..3] of LongWord;

  RenderHook: PHook;

  VIArray: PVectorInfo;

  Reserved1: Word;

  GeometryHook: PHook;

  SubStyles: PSubStyle;

  Reserved2: array [0..3] of LongWord;

end;


TT_ALPHA8

Declaration

Source position: intuition.pas line 1444

const TT_ALPHA8 = 1;


TT_ALPHA16

Declaration

Source position: intuition.pas line 1445

const TT_ALPHA16 = 2;


TT_ALPHA24

Declaration

Source position: intuition.pas line 1446

const TT_ALPHA24 = 3;


TT_ALPHA32

Declaration

Source position: intuition.pas line 1447

const TT_ALPHA32 = 4;


TT_BITPLANE

Declaration

Source position: intuition.pas line 1443

const TT_BITPLANE = 0;


TTabletData

IntuiMessage TabletData

Declaration

Source position: intuition.pas line 1340

type TTabletData = record
td_XFraction: Word; | Sub-pixel position of tablet, in screen coordinates, scaled to fill a Word fraction:
td_YFraction: Word; |
td_TabletX: LongWord; | Current tablet coordinates along each axis
td_TabletY: LongWord; |
td_RangeX: LongWord; | Tablet range along each axis. For example, if td_TabletX can take values 0-999, td_RangeX should be 1000.
td_RangeY: LongWord; |
td_TagList: PTagItem; | Pointer to tag-list of additional tablet attributes. TABLETA_*
end;

Description

If your window sets WA_TabletMessages to True, then it will receive extended IntuiMessages (TExtIntuiMessage) whose .eim_TabletData field points at a TabletData structure. This structure contains additional information about the input event.

See also

TExtIntuiMessage

Extended Intuition message structure


TTabletHookData

Declaration

Source position: intuition.pas line 1354

type TTabletHookData = record
thd_Screen: PScreen; | Pointer to the active screen: Note: if there are no open screens, thd_Screen will be nil.
thd_Width: LongWord; | Scaled to a standard NTSC width of 640.
thd_Height: LongWord; | Scaled to a standard NTSC height of 400
thd_ScreenChanged: LongInt; | Non-zero if the screen or something about the screen changed since the last time you were invoked
end;


TTBGadgetData

Declaration

Source position: intuition.pas line 3789

type TTBGadgetData = record

  DomainGadgetList: PGadget;

  GadgetGadgetList: PGadget;

end;


TVector

Declaration

Source position: intuition.pas line 3569

type TVector = record

  Operation: Byte;

  Type_: Byte;

  DRIPen: Word;

  States: LongWord;

  X: SmallInt;

  Y: SmallInt;

  Data: PWord;

end;


TVectorInfo

Declaration

Source position: intuition.pas line 3579

type TVectorInfo = record

  VectorID: LongWord;

  Vectors: PVector;

  DesignWidth: Word;

  DesignHeight: Word;

  Flags: LongWord;

  States: LongWord;

end;


TWindow

Window structure

Declaration

Source position: intuition.pas line 937

type TWindow = record
NextWindow: PWindow; | For the linked list in a screen
LeftEdge: SmallInt; | Left edge of window on the screen
TopEdge: SmallInt; | Top edge of window on the screen
Width: SmallInt; | Width of Window
Height: SmallInt; | Height of Window
MouseY: SmallInt; | Y Mouse position relative to upper-left edge of Window
MouseX: SmallInt; | X Mouse position relative to upper-left edge of Window
MinWidth: SmallInt; | Minimum width for resizeable windows
MinHeight: SmallInt; | Minimum height for resizeable windows
MaxWidth: Word; | Maximum width of resizeable windows
MaxHeight: Word; | Maximum height of resizeable windows
Flags: LongWord; | Window Flags (WFLG_*)
MenuStrip: PMenu; | The strip of menu headers
Title: PChar; | The title text for this window
FirstRequest: PRequester; | All active requesters
DMRequest: PRequester; | Double click requester
ReqCount: SmallInt; | Count of requester blocking Window
WScreen: PScreen; | This Window's Screen
RPort: PRastPort; | This Window's very own RastPort
BorderLeft: ShortInt; | Width of window decoration on the left
BorderTop: ShortInt; | Width of window decoration on the top
BorderRight: ShortInt; | Width of window decoration on the right
BorderBottom: ShortInt; | Width of window decoration on the bottom
BorderRPort: PRastPort; | Rastport to draw on the Border
FirstGadget: PGadget; | You supply a linked-list of Gadgets for your Window. This list does not include system gadgets.
Parent: PWindow; | these are for opening/closing the windows
Descendant: PWindow; |
_Pointer: PWord; | sprite data
PtrHeight: ShortInt; | sprite height (not including sprite padding)
PtrWidth: ShortInt; | sprite width (must be less than or equal to 16)
XOffset: ShortInt; | sprite X offset
YOffset: ShortInt; | sprite Y offset
IDCMPFlags: LongWord; | User-selected flags (IDCMP_*)
UserPort: PMsgPort; | User message port
WindowPort: PMsgPort; | Intuition's message port
MessageKey: PIntuiMessage; |
DetailPen: Byte; | for bar/border/gadget rendering
BlockPen: Byte; | for bar/border/gadget rendering
CheckMark: PImage; | the CheckMark is a pointer to the imagery that will be used when rendering MenuItems of this Window that want to be checkmarked if this is equal to nil, you'll get the default imagery
ScreenTitle: PChar; | if non-nil, Screen title when Window is active
GZZMouseX: SmallInt; | These variables have the mouse coordinates relative to the
GZZMouseY: SmallInt; | inner-Window of GIMMEZEROZERO Windows.
GZZWidth: SmallInt; | width of the inner-Window of GIMMEZEROZERO Windows
GZZHeight: SmallInt; | height of the inner-Window of GIMMEZEROZERO Windows
ExtData: PByte; | general-purpose pointer to User data extension
UserData: PSmallInt; | general-purpose pointer to User data extension
WLayer: PLayer; | Layer of the window
IFont: PTextFont; |
MoreFlags: LongWord; |
end;

Description

The border variables describe the window border. If you specify WA_GIMMEZEROZERO when you open the window, then the upper-left of the ClipRect for this window will be upper-left of the BitMap (with correct offsets when in SuperBitMap mode; you must select WA_GIMMEZEROZERO when using SuperBitMap). If you don't specify ZeroZero, then you save memory (no allocation of RastPort, Layer, ClipRect and associated Bitmaps), but you also must offset all your writes by BorderTop, BorderLeft and do your own mini-clipping to prevent writing over the system gadgets


UPFRONTGADGET

Declaration

Source position: intuition.pas line 2450

const UPFRONTGADGET = 0;


UPIMAGE

SYSIA_Which tag data values. Up-arrow gadget image

Declaration

Source position: intuition.pas line 3144

const UPIMAGE = $0B;


US_LEGAL

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 2360

const US_LEGAL = $10;


US_LETTER

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 2359

const US_LETTER = $00;


USEREQIMAGE

Flag for TRequester.Flags. Render linked list ReqImage after BackFill but before gadgets and text

Declaration

Source position: intuition.pas line 752

const USEREQIMAGE = $0020;


VIF_3DDISABLE

Declaration

Source position: intuition.pas line 3638

const VIF_3DDISABLE = $00000400;


VIF_ALPHABLEND

Declaration

Source position: intuition.pas line 3644

const VIF_ALPHABLEND = $00008000;


VIF_ALPHASHADE

Declaration

Source position: intuition.pas line 3643

const VIF_ALPHASHADE = $00006000;


VIF_ALPHASHADOW

Declaration

Source position: intuition.pas line 3642

const VIF_ALPHASHADOW = $00004000;


VIF_ALPHASHINE

Declaration

Source position: intuition.pas line 3641

const VIF_ALPHASHINE = $00002000;


VIF_BORDERMASK

Declaration

Source position: intuition.pas line 3645

const VIF_BORDERMASK = $00FF0000;


VIF_BRCORN

Declaration

Source position: intuition.pas line 3650

const VIF_BRCORN = $00100000;


VIF_BUTTON

Declaration

Source position: intuition.pas line 3653

const VIF_BUTTON = $00800000;


VIF_HORIZARROW

Declaration

Source position: intuition.pas line 3649

const VIF_HORIZARROW = $00080000;


VIF_IGNOREHEIGHT

Declaration

Source position: intuition.pas line 3635

const VIF_IGNOREHEIGHT = $00000040;


VIF_IGNOREWIDTH

Declaration

Source position: intuition.pas line 3634

const VIF_IGNOREWIDTH = $00000020;


VIF_KEEPASPECT

Declaration

Source position: intuition.pas line 3637

const VIF_KEEPASPECT = $00000200;


VIF_MENU

Declaration

Source position: intuition.pas line 3652

const VIF_MENU = $00400000;


VIF_NOBUFFER

Declaration

Source position: intuition.pas line 3639

const VIF_NOBUFFER = $00000800;


VIF_PENSHADE

Declaration

Source position: intuition.pas line 3640

const VIF_PENSHADE = $00001000;


VIF_REFFONT

Declaration

Source position: intuition.pas line 3633

const VIF_REFFONT = $00000010;


VIF_ROUNDEDSCALING

Declaration

Source position: intuition.pas line 3636

const VIF_ROUNDEDSCALING = $00000100;


VIF_SCREENBAR

Declaration

Source position: intuition.pas line 3651

const VIF_SCREENBAR = $00200000;


VIF_TBLEFT

Declaration

Source position: intuition.pas line 3646

const VIF_TBLEFT = $00010000;


VIF_TBRIGHT

Declaration

Source position: intuition.pas line 3647

const VIF_TBRIGHT = $00020000;


VIF_VERTARROW

Declaration

Source position: intuition.pas line 3648

const VIF_VERTARROW = $00040000;


VIF_WMULTIPLY

Declaration

Source position: intuition.pas line 3632

const VIF_WMULTIPLY = $0000000F;


VKHANDLEIMAGE

Declaration

Source position: intuition.pas line 3161

const VKHANDLEIMAGE = $1A;


VO_ELPS

Declaration

Source position: intuition.pas line 3593

const VO_ELPS = $04;


VO_END

Declaration

Source position: intuition.pas line 3602

const VO_END = $FF;


VO_FILL

Declaration

Source position: intuition.pas line 3590

const VO_FILL = $01;


VO_FILLELPS

Declaration

Source position: intuition.pas line 3600

const VO_FILLELPS = VO_FILL or VO_ELPS;


VO_FILLPOLY

Declaration

Source position: intuition.pas line 3598

const VO_FILLPOLY = VO_FILL or VO_POLY;


VO_FILLRECT

Declaration

Source position: intuition.pas line 3596

const VO_FILLRECT = VO_FILL or VO_RECT;


VO_LINE

Declaration

Source position: intuition.pas line 3589

const VO_LINE = $00;


VO_LINEELPS

Declaration

Source position: intuition.pas line 3599

const VO_LINEELPS = VO_LINE or VO_ELPS;


VO_LINEPOLY

Declaration

Source position: intuition.pas line 3597

const VO_LINEPOLY = VO_LINE or VO_POLY;


VO_LINERECT

Declaration

Source position: intuition.pas line 3595

const VO_LINERECT = VO_LINE or VO_RECT;


VO_POLY

Declaration

Source position: intuition.pas line 3592

const VO_POLY = $02;


VO_RECT

Declaration

Source position: intuition.pas line 3591

const VO_RECT = $00;


VT_BOTH

Declaration

Source position: intuition.pas line 3607

const VT_BOTH = $03;


VT_COLOR

Declaration

Source position: intuition.pas line 3606

const VT_COLOR = $02;


VT_MONO

Declaration

Source position: intuition.pas line 3605

const VT_MONO = $01;


W_TRACTOR

Value for TPreferences.PaperSize

Declaration

Source position: intuition.pas line 2362

const W_TRACTOR = $30;


WA_Activate

Tag for OpenWindowTagList(). Activate the window when it opens.

Declaration

Source position: intuition.pas line 1208

const WA_Activate = WA_Dummy + $26;

Description

Activate the window when it opens. Equivalent to TNewWindow.Flags with set WFLG_ACTIVATE. Use this flag carefully, as it can change where the user's input is going.


WA_AlphaClips

Declaration

Source position: intuition.pas line 1268

const WA_AlphaClips = WA_Dummy + $49;


WA_AlphaHook

Declaration

Source position: intuition.pas line 1269

const WA_AlphaHook = WA_Dummy + $4A;


WA_AmigaKey

Tag for OpenWindowTagList(). Amiga key image for Menus

Declaration

Source position: intuition.pas line 1222

const WA_AmigaKey = WA_Dummy + $31;

Description

Pointer to image for Amiga-key equiv in menus


WA_AutoAdjust

Tag for OpenWindowTagList().Auto adjust window size to screen maximum.

Declaration

Source position: intuition.pas line 1216

const WA_AutoAdjust = WA_Dummy + $2D;

Description

Allow Intuition to change the window's position and dimensions in order to fit it on screen. The window's position is adjusted first, then the size. This property may be especially important when using WA_InnerWidth and WA_InnerHeight as border size depends on a user specified font.


WA_AutoAdjustDClip

Declaration

Source position: intuition.pas line 1254

const WA_AutoAdjustDClip = WA_Dummy + $40;


WA_Backdrop

Tag for OpenWindowTagList(). Make this window a backdrop window

Declaration

Source position: intuition.pas line 1204

const WA_Backdrop = WA_Dummy + $22;

Description

Make this window a Backdrop window. Equivalent to TNewWindow.Flags with set WFLG_BACKDROP.


WA_BackFill

Tag for OpenWindowTagList(). BackFill hook

Declaration

Source position: intuition.pas line 1197

const WA_BackFill = WA_Dummy + $1C;

Description

Provides a "backfill hook" for your window's layer.


WA_BlockPen

Tag for OpenWindowTagList(). Specifies the pen number for window block fills, like the title bar.

Declaration

Source position: intuition.pas line 1164

const WA_BlockPen = WA_Dummy + $06;

Description

Equivalent to TNewWindow.BlockPen The specific color associated with each pen number depends on the screen. Specifying -1 for these values sets the window's detail and block pen the same as the screen's detail and block pen.


WA_Borderless

Tag for OpenWindowTagList(). Make window borderless

Declaration

Source position: intuition.pas line 1207

const WA_Borderless = WA_Dummy + $25;

Description

Open a window with no borders rendered by Intuition. Equivalent to TNewWindow.Flags with set WFLG_BORDERLESS.

Use caution setting this flag, as it may cause visual confusion on the screen. Also, some borders may be rendered if any of the system gadgets are requested, if text is supplied for the window's title bar, or if any of application gadgets are in the borders.


WA_BusyPointer

Tag for OpenWindowTagList(). Request standard busy pointer

Declaration

Source position: intuition.pas line 1228

const WA_BusyPointer = WA_Dummy + $35;

Description

ti_Data is a boolean. Set to True to request the standard busy pointer. This tag may be passed to OpenWindowTagList() or SetWindowPointerA().


WA_Checkmark

Tag for OpenWindowTagList(). Image for Menu entries

Declaration

Source position: intuition.pas line 1169

const WA_Checkmark = WA_Dummy + $0A;

Description

A pointer to an Image structure, which is to be used as the checkmark image in this window's menus. To use the default checkmark, do not specify this tag or set this field to nil. Equivalent to TNewWindow.CheckMark


WA_CloseGadget

Tag for OpenWindowTagList(). Add CloseGadget to window

Declaration

Source position: intuition.pas line 1203

const WA_CloseGadget = WA_Dummy + $21;

Description

Setting this flag attaches a close gadget to the window. When the user selects this gadget, Intuition transmits a message to the application. It is up to the application to close the window with a CloseWindow() call. Intuition places the close gadget in the upper left corner of the window. Equivalent to TNewWindow.Flags with set WFLG_CLOSEGADGET.


WA_Colors

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1190

const WA_Colors = WA_Dummy + $19;

Description

A ColorSpec array for colors to be set when this window is active. This is not implemented, and may not be, since the default values to restore would be hard to track. We'd like to at least support per-window colors for the mouse pointer sprite.


WA_ContextMenuHook

Declaration

Source position: intuition.pas line 1284

const WA_ContextMenuHook = WA_Dummy + $52;


WA_CustomScreen

Tag for OpenWindowTagList(). Open the window on a specific screen

Declaration

Source position: intuition.pas line 1173

const WA_CustomScreen = WA_Dummy + $0D;

Description

A pointer to the Screen structure of a screen created by this application. The window will be opened on this screen. The custom screen must already be opened when the OpenWindowTagList() call is made. Equivalent to NewWindow.Screen, also implies TNewWindow.Type of CUSTOMSCREEN_f.


WA_DepthGadget

Tag for OpenWindowTagList(). Add Depthgadget to window

Declaration

Source position: intuition.pas line 1202

const WA_DepthGadget = WA_Dummy + $20;

Description

Setting this flag adds a depth gadget to the window. This allows the user to change the window's depth arrangement with respect to other windows on the screen. Intuition places the depth gadget in the upper right corner of the window. Equivalent to TNewWindow.Flags with set WFLG_DEPTHGADGET.


WA_DetailPen

Tag for OpenWindowTagList(). Specifies the pen number for the rendering of window details like gadgets or text in the title bar.

Declaration

Source position: intuition.pas line 1163

const WA_DetailPen = WA_Dummy + $05;

Description

Equivalent to TNewWindow.DetailPen The specific color associated with each pen number depends on the screen. Specifying -1 for these values sets the window's detail and block pen the same as the screen's detail and block pen.


WA_DragBar

Tag for OpenWindowTagList(). Titlebar used to drag window

Declaration

Source position: intuition.pas line 1201

const WA_DragBar = WA_Dummy + $1F;

Description

This flag turns the entire title bar of the window into a drag gadget, allowing the user to position the window by clicking in the title bar and dragging the mouse. Equivalent to TNewWindow.Flags with set WFLG_DRAGBAR.


WA_DropShadows

Declaration

Source position: intuition.pas line 1278

const WA_DropShadows = WA_Dummy + $4F;


WA_Dummy

Starting for window TagItems

Declaration

Source position: intuition.pas line 1157

const WA_Dummy = TAG_USER + 99;


WA_FadeTime

Declaration

Source position: intuition.pas line 1271

const WA_FadeTime = WA_Dummy + $4C;


WA_Flags

Tag for OpenWindowTagList(). Window Flags (WFLG_*)

Declaration

Source position: intuition.pas line 1167

const WA_Flags = WA_Dummy + $08;

Description

Multiple initialization of window flags, equivalent to TNewWindow.Flags. Use the WFLG_* constants to initialize this field, multiple bits may be set by ORing the values together.


WA_Gadgets

Tag for OpenWindowTagList(). List of Gadgets

Declaration

Source position: intuition.pas line 1168

const WA_Gadgets = WA_Dummy + $09;

Description

A pointer to the first in the linked list of Gadget structures that are to be included in this window. These gadgets are application gadgets, not system gadgets. Equivalent to TNewWindow.FirstGadget


WA_GimmeZeroZero

Tag for OpenWindowTagList(). Zero-Zero window

Declaration

Source position: intuition.pas line 1217

const WA_GimmeZeroZero = WA_Dummy + $2E;

Description

Set this tag to create a GimmeZeroZero window. GimmeZeroZero windows have the window border and border gadgets rendered into an extra layer. This extra layer slows down window operations, thus it is recommended that applications only use GimmeZeroZero windows when they are required. For clipping graphics to the area within the borders of a window. Equivalent to TNewWindow.Flags with set WFLG_GIMMEZEROZERO.


WA_GrabFocus

Declaration

Source position: intuition.pas line 1258

const WA_GrabFocus = WA_Dummy + $44;


WA_Height

Tag for OpenWindowTagList(). The initial window height in pixels

Declaration

Source position: intuition.pas line 1162

const WA_Height = WA_Dummy + $04;

Description

Equivalent to TNewWindow.Height


WA_HelpGroup

Tag for OpenWindowTagList(). Form Help groups

Declaration

Source position: intuition.pas line 1239

const WA_HelpGroup = WA_Dummy + $38;

Description

When the active window has gadget help enabled, other windows of the same HelpGroup number will also get GadgetHelp. This allows GadgetHelp to work for multi-windowed applications. Pass the ID as ti_Data to all your windows.

See also

HelpControl

Enable/disable Gadget-Help feature.


WA_HelpGroupWindow

Tag for OpenWindowTagList(). Form Help group windows

Declaration

Source position: intuition.pas line 1242

const WA_HelpGroupWindow = WA_Dummy + $39;

Description

When the active window has gadget help enabled, other windows of the same HelpGroup will also get GadgetHelp. This allows GadgetHelp to work for multi-windowed applications. As an alternative to WA_HelpGroup, you can pass a pointer to any other window of the same group to join its help group. Defaults to nil, which has no effect.

See also

HelpControl

Enable/disable Gadget-Help feature.


WA_Hidden

Declaration

Source position: intuition.pas line 1250

const WA_Hidden = WA_Dummy + $3c;


WA_IDCMP

Tag for OpenWindowTagList(). Which events should be reported

Declaration

Source position: intuition.pas line 1165

const WA_IDCMP = WA_Dummy + $07;

Description

IDCMP flags tell Intuition what user input events the application wants to be notified about. (see IDCMP_*) Equivalent to TNewWindow.IDCMPFlags

If any of these flags are set, Intuition creates a pair of message ports for the window (one internal to Intuition and one used by the application). These ports are for handling messages about user input events. If WA_IDCMP is nil or unspecified, no IDCMP is created for this window.

The ModifyIDCMP() function can be used to change the window's IDCMP flags after it is open.


WA_InFrontOf

Declaration

Source position: intuition.pas line 1257

const WA_InFrontOf = WA_Dummy + $43;


WA_InnerHeight

Tag for OpenWindowTagList(). Inner height of window

Declaration

Source position: intuition.pas line 1182

const WA_InnerHeight = WA_Dummy + $14;

Description

Specify the dimensions of the interior region of the window, i.e., inside the border, independent of the border widths. When using this flag an application will probably want to set WA_AutoAdjust.


WA_InnerWidth

Tag for OpenWindowTagList(). Inner width for the window

Declaration

Source position: intuition.pas line 1181

const WA_InnerWidth = WA_Dummy + $13;

Description

Specify the dimensions of the interior region of the window, i.e., inside the border, independent of the border widths. When using this flag an application will probably want to set WA_AutoAdjust.


WA_Left

Tag for OpenWindowTagList(). The initial x position

Declaration

Source position: intuition.pas line 1159

const WA_Left = WA_Dummy + $01;

Description

Describe where the window will first appear on the screen and how large it will be initially. These dimensions are relative to the top left corner of the screen, which has the coordinates (0,0).

WA_Left is the initial x position, or offset, from the left edge of the screen. The leftmost pixel is pixel 0, and values increase to the right. Equivalent to TNewWindow.LeftEdge.


WA_MaxHeight

Tag for OpenWindowTagList(). Minimum height for resizeable windows

Declaration

Source position: intuition.pas line 1179

const WA_MaxHeight = WA_Dummy + $12;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored. Values are measured in pixels. Use -1 for this value to allow for a window as tall as the screen. This is the complete screen, not the visible part or display clip.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MaxHeight Use the WindowLimits() function to change window size limits after the window is opened.


WA_MaxWidth

Tag for OpenWindowTagList(). Maximum width for resizeable windows

Declaration

Source position: intuition.pas line 1178

const WA_MaxWidth = WA_Dummy + $11;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored. Values are measured in pixels. Use -1 for this value to allow for a window as wide as the screen. This is the complete screen, not the visible part or display clip.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MaxWidth Use the WindowLimits() function to change window size limits after the window is opened.


WA_MenuHelp

Tag for OpenWindowTagList(). Enabled Help button for Menu

Declaration

Source position: intuition.pas line 1219

const WA_MenuHelp = WA_Dummy + $2F;

Description

Enables IDCMP_MENUHELP: pressing Help during menus will return IDCMP_MENUHELP message.


WA_MenuHook

Declaration

Source position: intuition.pas line 1253

const WA_MenuHook = WA_Dummy + $3f;


WA_MenuStrip

Declaration

Source position: intuition.pas line 1283

const WA_MenuStrip = WA_Dummy + $51;


WA_MinHeight

Tag for OpenWindowTagList(). Minimum height for resizeable windows

Declaration

Source position: intuition.pas line 1177

const WA_MinHeight = WA_Dummy + $10;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MinHeight Use the WindowLimits() function to change window size limits after the window is opened.


WA_MinWidth

Tag for OpenWindowTagList(). Minimum width for resizeable windows

Declaration

Source position: intuition.pas line 1176

const WA_MinWidth = WA_Dummy + $0F;

Description

This tag set the minimum value to which the user may size the window. If the flag WFLG_SIZEGADGET is not set, then these variables are ignored.

Setting this variable to 0, will take the setting for that dimension from its initial value.

Equivalent to TNewWindow.MinWidth Use the WindowLimits() function to change window size limits after the window is opened.


WA_MouseLimits

Declaration

Source position: intuition.pas line 1263

const WA_MouseLimits = WA_Dummy + $46;


WA_MouseQueue

Tag for OpenWindowTagList(). Mouse event queue size

Declaration

Source position: intuition.pas line 1196

const WA_MouseQueue = WA_Dummy + $1B;

Description

An initial value for the mouse message backlog limit for this window. The SetMouseQueue() function will change this limit after the window is opened.


WA_NewLookMenus

Tag for OpenWindowTagList(). Activate NewLook menus

Declaration

Source position: intuition.pas line 1221

const WA_NewLookMenus = WA_Dummy + $30;

Description

Set to True if you want NewLook menus.


WA_NoCareRefresh

Tag for OpenWindowTagList(). Do not need Refresh message

Declaration

Source position: intuition.pas line 1206

const WA_NoCareRefresh = WA_Dummy + $24;

Description

This window does not want IDCMP_REFRESHWINDOW events. Set this flag to prevent the window from receiving refresh window messages. Equivalent to TNewWindow.Flags with set WFLG_NOCAREREFRESH. Intuition will manage BeginRefresh() and EndRefresh() internally.


WA_NoHitThreshold

Declaration

Source position: intuition.pas line 1274

const WA_NoHitThreshold = WA_Dummy + $4E;


WA_NoMenuKeyVerify

Declaration

Source position: intuition.pas line 1265

const WA_NoMenuKeyVerify = WA_Dummy + $47;


WA_NotifyDepth

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1223

const WA_NotifyDepth = WA_Dummy + $32;

Description

Requests IDCMP_CHANGEWINDOW message when window is depth arranged (imsg^.Code = CWCODE_DEPTH)


WA_Opaqueness

Declaration

Source position: intuition.pas line 1270

const WA_Opaqueness = WA_Dummy + $4B;


WA_OverrideOpaqueness

Declaration

Source position: intuition.pas line 1272

const WA_OverrideOpaqueness = WA_Dummy + $4D;


WA_Pointer

Tag for OpenWindowTagList(). Custom Pointer for window.

Declaration

Source position: intuition.pas line 1225

const WA_Pointer = WA_Dummy + $34;

Description

Allows you to specify a custom pointer for your window. ti_Data points to a pointer object you obtained via "pointerclass". Nil signifies the default pointer. This tag may be passed to OpenWindowTagList() or SetWindowPointerA().


WA_PointerDelay

Tag for OpenWindowTagList(). Delay of pointer change

Declaration

Source position: intuition.pas line 1230

const WA_PointerDelay = WA_Dummy + $36;

Description

ti_Data is a boolean. Set to True to request that the changing of the pointer be slightly delayed. The change will be called off if you call SetPointer() before the delay expires. This allows you to post a busy-pointer even if you think the busy-time may be very short, without fear of a flashing pointer. This tag may be passed to OpenWindowTagList() or SetWindowPointerA().


WA_PointerType

Declaration

Source position: intuition.pas line 1281

const WA_PointerType = WA_Dummy + $50;


WA_PubScreen

Tag for OpenWindowTagList(). Specify screen to open window on

Declaration

Source position: intuition.pas line 1184

const WA_PubScreen = WA_Dummy + $16;

Description

Open the window as a visitor window on the public screen whose address is in the ti_Data field of the WA_PubScreen TagItem. To ensure that this screen remains open until OpenWindowTagList() has completed, the application must either be the screen's owner, have a window open on the screen, or use LockPubScreen(). Setting this tag implies screen type of PUBLICSCREEN_f.


WA_PubScreenFallBack

Tag for OpenWindowTagList(). Fallback screen to default

Declaration

Source position: intuition.pas line 1186

const WA_PubScreenFallBack = WA_Dummy + $17;

Description

A Boolean, specifies whether a visitor window should "fall back" to the default public screen (or Workbench) if the named public screen isn't available This tag is only meaningful when used in conjunction with WA_PubScreenName.


WA_PubScreenName

Tag for OpenWindowTagList(). Choose screen by name

Declaration

Source position: intuition.pas line 1183

const WA_PubScreenName = WA_Dummy + $15;

Description

Declares that the window is to be opened as a visitor on the public screen whose name is pointed to by the ti_Data field of the WA_PubScreenName TagItem. The OpenWindowTagList() call will fail if it cannot obtain a lock on the named public screen and no fall back name (WA_PubScreenFallBack) is specified. Setting this tag implies screen type of PUBLICSCREEN_f.


WA_ReportMouse

Tag for OpenWindowTagList(). Report mouse events

Declaration

Source position: intuition.pas line 1205

const WA_ReportMouse = WA_Dummy + $23;

Description

Send mouse movement events to the window as x,y coordinates. Also see the description of the IDCMP flag IDCMP_MOUSEMOVE. Equivalent to TNewWindow.Flags with set WFLG_REPORTMOUSE.

The WFLG_REPORTMOUSE flag in the Flags field of the Window structure may be modified on the fly by the program. Changing this flag must be done as an atomic operation. If you are unsure of getting an atomic operation from your compiler, you may wish to do this operation in assembler, or bracket the code with a Forbid()/Permit() pair.

The use of the ReportMouse() function is strongly discouraged, due to historic confusion over the parameter ordering.


WA_Reserved1

Declaration

Source position: intuition.pas line 1252

const WA_Reserved1 = WA_Dummy + $3e;


WA_Reserved2

Declaration

Source position: intuition.pas line 1267

const WA_Reserved2 = WA_Dummy + $48;


WA_RMBTrap

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1209

const WA_RMBTrap = WA_Dummy + $27;

Description

Catch right mouse button events for application use. Set this flag to disable menu operations for the window. When set, right mouse button events will be received as IDCMP_MOUSEBUTTONS with the MENUUP and MENUDOWN qualifiers. Equivalent to TNewWindow.Flags with set WFLG_RMBTRAP.

The WFLG_RMBTRAP flag in the Window structure Flags field may be modified on the fly by the program. Changing this flag must be done as an atomic operation, as Intuition can preempt a multistep set or clear operation. An atomic operation can be done in assembler, using instructions that operate directly on memory. If you are unsure of generating such an instruction, place the operation within a Forbid()/Permit() pair. This will ensure proper operation by disabling multitasking while the flag is being changed.


WA_RptQueue

Tag for OpenWindowTagList(). Key event queue size

Declaration

Source position: intuition.pas line 1198

const WA_RptQueue = WA_Dummy + $1D;

Description

An initial value of repeat key backlog limit for this window.


WA_ScreenTitle

Tag for OpenWindowTagList(). Title for screen when window is activated

Declaration

Source position: intuition.pas line 1172

const WA_ScreenTitle = WA_Dummy + $0C;

Description

A pointer to a #0 terminated text string, which is used as the screen title and is displayed, when the window is active, in the screen's title bar. After the screen has been opened the screen's title may be changed by calling SetWindowTitles().


WA_ShapeHook

Declaration

Source position: intuition.pas line 1256

const WA_ShapeHook = WA_Dummy + $42;


WA_ShapeRegion

Declaration

Source position: intuition.pas line 1255

const WA_ShapeRegion = WA_Dummy + $41;


WA_SimpleRefresh

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1211

const WA_SimpleRefresh = WA_Dummy + $29;

Description

The application program takes complete responsibility for updating the window. Only specify if True. Equivalent to TNewWindow.Flags with set WFLG_SIMPLE_REFRESH.


WA_SizeBBottom

Tag for OpenWindowTagList(). Place the size gadget in the bottom border.

Declaration

Source position: intuition.pas line 1214

const WA_SizeBBottom = WA_Dummy + $2C;

Description

Place the size gadget in the bottom border. Equivalent to TNewWindow.Flags with set WFLG_SIZEBBOTTOM.


WA_SizeBRight

Tag for OpenWindowTagList(). Place the size gadget in the right border.

Declaration

Source position: intuition.pas line 1213

const WA_SizeBRight = WA_Dummy + $2B;

Description

Place the size gadget in the right border. Equivalent to TNewWindow.Flags with set WFLG_SIZEBRIGHT.


WA_SizeGadget

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1200

const WA_SizeGadget = WA_Dummy + $1E;

Description

Specifying this flag tells Intuition to add a sizing gadget to the window. Intuition places the sizing gadget in the lower right corner of the window. By default, the right border is adjusted to accommodate the sizing gadget, but the application can specify one of the following two flags to change this behavior. The WFLG_SIZEBRIGHT flag puts the sizing gadget in the right border. The WFLG_SIZEBBOTTOM flag puts the sizing gadget in the bottom border. Both flags may be specified, placing the gadget in both borders. Equivalent to TNewWindow.Flags with set WFLG_SIZEGADGET.


WA_SmartRefresh

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1212

const WA_SmartRefresh = WA_Dummy + $2A;

Description

Intuition handles all window updating, except for parts of the window revealed when the window is sized larger. Only specify if True. Equivalent to TNewWindow.Flags with set WFLG_SMART_REFRESH.

WA_SmartRefresh windows without a sizing gadget will never receive refresh events due to the user sizing the window. However, if the application sizes the window through a call like ChangeWindowBox(), ZipWindow() or SizeWindow(), a refresh event may be generated. Use WA_NoCareRefresh to disable refresh events.


WA_StayTop

Declaration

Source position: intuition.pas line 1262

const WA_StayTop = WA_Dummy + $45;


WA_SuperBitMap

Tag for OpenWindowTagList(). SuperBitmap for scrolling windows

Declaration

Source position: intuition.pas line 1174

const WA_SuperBitMap = WA_Dummy + $0E;

Description

This is a pointer to a BitMap structure for a SuperBitMap window. The application will be allocating and maintaining its own bitmap. Equivalent to TNewWindow.BitMap. Setting this tag implies the WFLG_SUPER_BITMAP property.


WA_TabletMessages

Tag for OpenWindowTagList(). Enabled tablet messages

Declaration

Source position: intuition.pas line 1234

const WA_TabletMessages = WA_Dummy + $37;

Description

ti_Data is a boolean. Set to True to request that tablet information be included in TIntuiMessage sent to your window. For a pointer to the TabletData, examine the ExtIntuiMessage^.eim_TabletData field.


WA_Title

Tag for OpenWindowTagList(). Title for window

Declaration

Source position: intuition.pas line 1170

const WA_Title = WA_Dummy + $0B;

Description

A pointer to a #0 terminated text string, which is used as the window title and is displayed in the window's title bar.

Intuition draws the text using the colors defined in the DrawInfo pen array (TDrawInfo.dri_Pens) and displays as much as possible of the window title, depending upon the current width of the title bar.

The title is rendered in the screen's default font.

A title bar is added to the window if any of the properties WA_DragBar (WFLG_DRAGBAR), WA_DepthGadget (WFLG_DEPTHGADGET), WA_CloseGadget (WFLG_CLOSEGADGET) or WA_Zoom are specified, or if text is specified for a window title. If no text is provided for the title, but one or more of these system gadgets are specified, the title bar will be blank. Equivalent to TNewWindow.Title.


WA_ToolBox

Declaration

Source position: intuition.pas line 1251

const WA_ToolBox = WA_Dummy + $3d;


WA_Top

Tag for OpenWindowTagList(). The initial y position

Declaration

Source position: intuition.pas line 1160

const WA_Top = WA_Dummy + $02;

Description

Describe where the window will first appear on the screen and how large it will be initially. These dimensions are relative to the top left corner of the screen, which has the coordinates (0,0).

WA_Top is the initial y position, or offset, from the top edge of the screen. The topmost pixel is pixel 0, and values increase to the bottom. Equivalent to TNewWindow.TopEdge.


WA_UserPort

Declaration

Source position: intuition.pas line 1247

const WA_UserPort = WA_Dummy + $3a;


WA_WBenchWindow

Tag for OpenWindowTagList(). Private

Declaration

Source position: intuition.pas line 1210

const WA_WBenchWindow = WA_Dummy + $28;

Description

Private tag


WA_Width

Tag for OpenWindowTagList(). The initial window width in pixels

Declaration

Source position: intuition.pas line 1161

const WA_Width = WA_Dummy + $03;

Description

Equivalent to TNewWindow.Width


WA_WindowBox

Declaration

Source position: intuition.pas line 1249

const WA_WindowBox = WA_Dummy + $3b;


WA_WindowName

Tag for OpenWindowTagList().

Declaration

Source position: intuition.pas line 1188

const WA_WindowName = WA_Dummy + $18;


WA_Zoom

Tag for OpenWindowTagList(). Define zoom size for window

Declaration

Source position: intuition.pas line 1193

const WA_Zoom = WA_Dummy + $1A;

Description

Pointer to an array of four SmallInts, the initial LeftEdge, TopEdge, Width and Height values for the alternate zoom position and size. It also specifies that the application wants a zoom gadget for the window, whether or not it has a sizing gadget.

A zoom gadget is always supplied to a window if it has both depth and sizing gadgets. This tag allows the application to open a window with a zoom gadget when the window does not have both the depth and sizing gadgets.


WBENCHCLOSE

Code for IDCMP_WBENCHMESSAGE

Declaration

Source position: intuition.pas line 922

const WBENCHCLOSE = $0002;


WBENCHOPEN

Code for IDCMP_WBENCHMESSAGE

Declaration

Source position: intuition.pas line 921

const WBENCHOPEN = $0001;


WBENCHSCREEN_F

Screentype flag for TScreen.Flags and TNewScreen.SType. The Workbench itself

Declaration

Source position: intuition.pas line 2006

const WBENCHSCREEN_F = $0001;


WFLG_ACTIVATE

Flag for WA_Flags or TNewWindow.Flags. When window opens, it is active.

Declaration

Source position: intuition.pas line 1068

const WFLG_ACTIVATE = $00001000;


WFLG_BACKDROP

Flag for WA_Flags or TNewWindow.Flags. This is a backdrop window

Declaration

Source position: intuition.pas line 1064

const WFLG_BACKDROP = $00000100;


WFLG_BORDERLESS

Flag for WA_Flags or TNewWindow.Flags. Get a window sans border.

Declaration

Source position: intuition.pas line 1067

const WFLG_BORDERLESS = $00000800;


WFLG_CLOSEGADGET

Flag for WA_Flags or TNewWindow.Flags. Include close-box system-gadget

Declaration

Source position: intuition.pas line 1054

const WFLG_CLOSEGADGET = $00000008;


WFLG_DEPTHGADGET

Flag for WA_Flags or TNewWindow.Flags. Include depth arrangement gadget

Declaration

Source position: intuition.pas line 1053

const WFLG_DEPTHGADGET = $00000004;


WFLG_DRAGBAR

Flag for WA_Flags or TNewWindow.Flags. Include dragging system-gadget

Declaration

Source position: intuition.pas line 1052

const WFLG_DRAGBAR = $00000002;


WFLG_GIMMEZEROZERO

Flag for WA_Flags or TNewWindow.Flags. A GimmeZeroZero window

Declaration

Source position: intuition.pas line 1066

const WFLG_GIMMEZEROZERO = $00000400;


WFLG_HASZOOM

Flag for TWindow.Flags. Window has a zoom gadget.

Declaration

Source position: intuition.pas line 1085

const WFLG_HASZOOM = $20000000;


WFLG_INREQUEST

Flag for WA_Flags or TNewWindow.Flags. Private. This window is in request mode.

Declaration

Source position: intuition.pas line 1078

const WFLG_INREQUEST = $00004000;


WFLG_MENUSTATE

Flag for WA_Flags or TNewWindow.Flags. Private. Window is active with menus on.

Declaration

Source position: intuition.pas line 1079

const WFLG_MENUSTATE = $00008000;


WFLG_NEWLOOKMENUS

Flag for WA_Flags or TNewWindow.Flags. Window has NewLook menus.

Declaration

Source position: intuition.pas line 1075

const WFLG_NEWLOOKMENUS = $00200000;


WFLG_NOCAREREFRESH

Flag for WA_Flags or TNewWindow.Flags. Not to be bothered with REFRESH

Declaration

Source position: intuition.pas line 1071

const WFLG_NOCAREREFRESH = $00020000;


WFLG_NW_EXTENDED

Flag for TNewWindow.Flags. Extension data provided see TExtNewWindow.

Declaration

Source position: intuition.pas line 1073

const WFLG_NW_EXTENDED = $00040000;


WFLG_OTHER_REFRESH

Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap

Declaration

Source position: intuition.pas line 1063

const WFLG_OTHER_REFRESH = $000000C0;


WFLG_REFRESHBITS

Flag for WA_Flags or TNewWindow.Flags. Simple refresh and super bitmap

Declaration

Source position: intuition.pas line 1059

const WFLG_REFRESHBITS = $000000C0;


WFLG_REPORTMOUSE

Flag for WA_Flags or TNewWindow.Flags. Fire an event for every mouse move

Declaration

Source position: intuition.pas line 1065

const WFLG_REPORTMOUSE = $00000200;


WFLG_RMBTRAP

Flag for WA_Flags or TNewWindow.Flags. Fire right mouse button events

Declaration

Source position: intuition.pas line 1070

const WFLG_RMBTRAP = $00010000;


WFLG_SIMPLE_REFRESH

Flag for WA_Flags or TNewWindow.Flags. Enable Simple Refresh

Declaration

Source position: intuition.pas line 1061

const WFLG_SIMPLE_REFRESH = $00000040;


WFLG_SIZEBBOTTOM

Flag for WA_Flags or TNewWindow.Flags. Size gadget uses bottom border

Declaration

Source position: intuition.pas line 1056

const WFLG_SIZEBBOTTOM = $00000020;


WFLG_SIZEBRIGHT

Flag for WA_Flags or TNewWindow.Flags. Size gadget uses right border

Declaration

Source position: intuition.pas line 1055

const WFLG_SIZEBRIGHT = $00000010;


WFLG_SIZEGADGET

Flag for WA_Flags or TNewWindow.Flags. Include sizing system-gadget

Declaration

Source position: intuition.pas line 1051

const WFLG_SIZEGADGET = $00000001;


WFLG_SMART_REFRESH

Flag for WA_Flags or TNewWindow.Flags. Enable smart Refresh

Declaration

Source position: intuition.pas line 1060

const WFLG_SMART_REFRESH = $00000000;


WFLG_SUPER_BITMAP

Flag for WA_Flags or TNewWindow.Flags. Has super bitmap

Declaration

Source position: intuition.pas line 1062

const WFLG_SUPER_BITMAP = $00000080;


WFLG_VISITOR

Flag for TWindow.Flags. Visitor window.

Declaration

Source position: intuition.pas line 1083

const WFLG_VISITOR = $08000000;


WFLG_WBENCHWINDOW

Flag for TWindow.Flags. Workbench tool only Window

Declaration

Source position: intuition.pas line 1081

const WFLG_WBENCHWINDOW = $02000000;


WFLG_WINDOWACTIVE

Flag for WA_Flags or TNewWindow.Flags. Private. This window is the active one.

Declaration

Source position: intuition.pas line 1077

const WFLG_WINDOWACTIVE = $00002000;


WFLG_WINDOWREFRESH

Flag for TWindow.Flags. Window is currently refreshing

Declaration

Source position: intuition.pas line 1080

const WFLG_WINDOWREFRESH = $01000000;


WFLG_WINDOWTICKED

Flag for TWindow.Flags. Only one timer tick at a time

Declaration

Source position: intuition.pas line 1082

const WFLG_WINDOWTICKED = $04000000;


WFLG_ZOOMED

Flag for TWindow.Flags. Identifies "Zoom State"

Declaration

Source position: intuition.pas line 1084

const WFLG_ZOOMED = $10000000;


WINDOW_BACKMOST

Declaration

Source position: intuition.pas line 1298

const WINDOW_BACKMOST = PWindow(Nil);


WINDOW_FRONTMOST

Declaration

Source position: intuition.pas line 1299

const WINDOW_FRONTMOST = PWindow(1);


WTPOS_CENTERABS

Declaration

Source position: intuition.pas line 1741

const WTPOS_CENTERABS = 2;


WTPOS_CENTERREL

Declaration

Source position: intuition.pas line 1740

const WTPOS_CENTERREL = 1;


WTPOS_LEFT

Declaration

Source position: intuition.pas line 1739

const WTPOS_LEFT = 0;


ZOOMIMAGE

SYSIA_Which tag data values. Window zoom gadget image

Declaration

Source position: intuition.pas line 3139

const ZOOMIMAGE = $01;


DP_2DFACSHIFT

Declaration

Source position: keymap.pas line 79

const DP_2DFACSHIFT = 4;


DP_2DINDEXMASK

Declaration

Source position: keymap.pas line 78

const DP_2DINDEXMASK = $0f;


DPB_DEAD

Declaration

Source position: keymap.pas line 75

const DPB_DEAD = 3;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DPB_MOD

Declaration

Source position: keymap.pas line 73

const DPB_MOD = 0;


DPF_DEAD

Declaration

Source position: keymap.pas line 76

const DPF_DEAD = $08;


DPF_MOD

Declaration

Source position: keymap.pas line 74

const DPF_MOD = $01;


IKeymap

Declaration

Source position: keymap.pas line 191

const IKeymap: PInterface = Nil;


Reference for unit 'keymap'

uses

  System,

  exec,

This unit contains the types and wrapper functions for the exec.library.

  inputevent;


Reference for unit 'keymap': Constants

DPB_DEAD

DPB_MOD

DPF_DEAD

DPF_MOD

DP_2DFACSHIFT

DP_2DINDEXMASK

IKeymap

KCB_ALT

KCB_CONTROL

KCB_DEAD

KCB_DOWNUP

KCB_NOP

KCB_SHIFT

KCB_STRING

KCF_ALT

KCF_CONTROL

KCF_DEAD

KCF_DOWNUP

KCF_NOP

KCF_SHIFT

KCF_STRING

KC_NOQUAL

KC_VANILLA

KEYMAPINFO_CLASSIC_ONLY

KEYMAPINFO_GETCLASSICKEYBOARD

KEYMAPINFO_INFOTEXT_CHARSET

KEYMAPINFO_INFOTEXT_ENGLISH

KEYMAPINFO_INFOTEXT_LOCAL

KEYMAPINFO_KEYMAPNODE

KEYMAPINFO_PC_ONLY

KEYMAPINFO_SETCHARSET

KEYMAPINFO_SETCLASSICKEYBOARD

KEYMAPNAME

KMCTRL_GetAltAmigaSwap

KMCTRL_SetAltAmigaSwap

RAWKEY_BACKSPACE

RAWKEY_BREAK

RAWKEY_CAPSLOCK

RAWKEY_CRSRDOWN

RAWKEY_CRSRLEFT

RAWKEY_CRSRRIGHT

RAWKEY_CRSRUP

RAWKEY_DEL

RAWKEY_END

RAWKEY_ENTER

RAWKEY_ESC

RAWKEY_F1

RAWKEY_F10

RAWKEY_F11

RAWKEY_F12

RAWKEY_F13

RAWKEY_F14

RAWKEY_F15

RAWKEY_F2

RAWKEY_F3

RAWKEY_F4

RAWKEY_F5

RAWKEY_F6

RAWKEY_F7

RAWKEY_F8

RAWKEY_F9

RAWKEY_HELP

RAWKEY_HOME

RAWKEY_INSERT

RAWKEY_LALT

RAWKEY_LCOMMAND

RAWKEY_LCTRL

RAWKEY_LSHIFT

RAWKEY_MEDIA_NEXT_TRACK

RAWKEY_MEDIA_PLAY_PAUSE

RAWKEY_MEDIA_PREV_TRACK

RAWKEY_MEDIA_REPEAT

RAWKEY_MEDIA_SHUFFLE

RAWKEY_MEDIA_STOP

RAWKEY_MENU

RAWKEY_PAGEDOWN

RAWKEY_PAGEUP

RAWKEY_PRINTSCR

RAWKEY_RALT

RAWKEY_RCOMMAND

RAWKEY_RETURN

RAWKEY_RSHIFT

RAWKEY_SPACE

RAWKEY_TAB

RKITYPE_EXT_RAWKEY

RKITYPE_PS2_SET1

RKITYPE_PS2_SET2

RKITYPE_RAWKEY

RKITYPE_USB

RKITYPE_USB_UPCODE

RKI_GET_EXT_RAWKEY

RKI_GET_FLAGS

RKI_GET_NAME

RKI_GET_PS2_SET1

RKI_GET_PS2_SET2

RKI_GET_RAWKEY

RKI_GET_USB

RKI_SET_TYPE

RKI_SET_VALUE


Reference for unit 'keymap': Types

PKeyMap

PKeymapNode

PKeyMapResource

TKeyMap

TKeyMapNode

TKeyMapResource


KC_NOQUAL

Declaration

Source position: keymap.pas line 52

const KC_NOQUAL = 0;


KC_VANILLA

Declaration

Source position: keymap.pas line 53

const KC_VANILLA = 7;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

KCB_ALT

Declaration

Source position: keymap.pas line 56

const KCB_ALT = 1;


KCB_CONTROL

Declaration

Source position: keymap.pas line 58

const KCB_CONTROL = 2;


KCB_DEAD

Declaration

Source position: keymap.pas line 63

const KCB_DEAD = 5;


KCB_DOWNUP

Declaration

Source position: keymap.pas line 60

const KCB_DOWNUP = 3;


Unit 'keymap' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

KCB_NOP

Declaration

Source position: keymap.pas line 69

const KCB_NOP = 7;


KCB_SHIFT

Declaration

Source position: keymap.pas line 54

const KCB_SHIFT = 0;


KCB_STRING

Declaration

Source position: keymap.pas line 66

const KCB_STRING = 6;


KCF_ALT

Declaration

Source position: keymap.pas line 57

const KCF_ALT = $02;


KCF_CONTROL

Declaration

Source position: keymap.pas line 59

const KCF_CONTROL = $04;


KCF_DEAD

Declaration

Source position: keymap.pas line 64

const KCF_DEAD = $20;


KCF_DOWNUP

Declaration

Source position: keymap.pas line 61

const KCF_DOWNUP = $08;


KCF_NOP

Declaration

Source position: keymap.pas line 70

const KCF_NOP = $80;


KCF_SHIFT

Declaration

Source position: keymap.pas line 55

const KCF_SHIFT = $01;


KCF_STRING

Declaration

Source position: keymap.pas line 67

const KCF_STRING = $40;


KeymapBase

Declaration

Source position: keymap.pas line 187

var KeymapBase: PLibrary = Nil;


KEYMAPINFO_CLASSIC_ONLY

Declaration

Source position: keymap.pas line 159

const KEYMAPINFO_CLASSIC_ONLY = TAG_USER + 6;


KEYMAPINFO_GETCLASSICKEYBOARD

Declaration

Source position: keymap.pas line 153

const KEYMAPINFO_GETCLASSICKEYBOARD = TAG_USER + 1;


KEYMAPINFO_INFOTEXT_CHARSET

Declaration

Source position: keymap.pas line 158

const KEYMAPINFO_INFOTEXT_CHARSET = TAG_USER + 5;


KEYMAPINFO_INFOTEXT_ENGLISH

Declaration

Source position: keymap.pas line 156

const KEYMAPINFO_INFOTEXT_ENGLISH = TAG_USER + 3;


KEYMAPINFO_INFOTEXT_LOCAL

Declaration

Source position: keymap.pas line 157

const KEYMAPINFO_INFOTEXT_LOCAL = TAG_USER + 4;


KEYMAPINFO_KEYMAPNODE

Declaration

Source position: keymap.pas line 152

const KEYMAPINFO_KEYMAPNODE = TAG_USER + 0;


KEYMAPINFO_PC_ONLY

Declaration

Source position: keymap.pas line 160

const KEYMAPINFO_PC_ONLY = TAG_USER + 7;


KEYMAPINFO_SETCHARSET

Declaration

Source position: keymap.pas line 161

const KEYMAPINFO_SETCHARSET = TAG_USER + 8;


KEYMAPINFO_SETCLASSICKEYBOARD

Declaration

Source position: keymap.pas line 154

const KEYMAPINFO_SETCLASSICKEYBOARD = TAG_USER + 2;


KEYMAPNAME

Declaration

Source position: keymap.pas line 190

const KEYMAPNAME: PChar = 'keymap.library';


KMCTRL_GetAltAmigaSwap

Declaration

Source position: keymap.pas line 184

const KMCTRL_GetAltAmigaSwap = TAG_USER + 1;


KMCTRL_SetAltAmigaSwap

Declaration

Source position: keymap.pas line 183

const KMCTRL_SetAltAmigaSwap = TAG_USER + 0;


PKeyMap

Declaration

Source position: keymap.pas line 25

type PKeyMap = ^TKeyMap;


PKeymapNode

Declaration

Source position: keymap.pas line 37

type PKeymapNode = ^TKeyMapNode;


PKeyMapResource

Declaration

Source position: keymap.pas line 44

type PKeyMapResource = ^TKeyMapResource;


RAWKEY_BACKSPACE

Declaration

Source position: keymap.pas line 85

const RAWKEY_BACKSPACE = $41;


RAWKEY_BREAK

Declaration

Source position: keymap.pas line 122

const RAWKEY_BREAK = $6E;


RAWKEY_CAPSLOCK

Declaration

Source position: keymap.pas line 112

const RAWKEY_CAPSLOCK = $62;


RAWKEY_CRSRDOWN

Declaration

Source position: keymap.pas line 96

const RAWKEY_CRSRDOWN = $4D;


RAWKEY_CRSRLEFT

Declaration

Source position: keymap.pas line 98

const RAWKEY_CRSRLEFT = $4F;


RAWKEY_CRSRRIGHT

Declaration

Source position: keymap.pas line 97

const RAWKEY_CRSRRIGHT = $4E;


RAWKEY_CRSRUP

Declaration

Source position: keymap.pas line 95

const RAWKEY_CRSRUP = $4C;


RAWKEY_DEL

Declaration

Source position: keymap.pas line 90

const RAWKEY_DEL = $46;


RAWKEY_END

Declaration

Source position: keymap.pas line 126

const RAWKEY_END = $71;


RAWKEY_ENTER

Declaration

Source position: keymap.pas line 87

const RAWKEY_ENTER = $43;


RAWKEY_ESC

Declaration

Source position: keymap.pas line 89

const RAWKEY_ESC = $45;


RAWKEY_F1

Declaration

Source position: keymap.pas line 99

const RAWKEY_F1 = $50;


RAWKEY_F2

Declaration

Source position: keymap.pas line 100

const RAWKEY_F2 = $51;


RAWKEY_F3

Declaration

Source position: keymap.pas line 101

const RAWKEY_F3 = $52;


RAWKEY_F4

Declaration

Source position: keymap.pas line 102

const RAWKEY_F4 = $53;


RAWKEY_F5

Declaration

Source position: keymap.pas line 103

const RAWKEY_F5 = $54;


RAWKEY_F6

Declaration

Source position: keymap.pas line 104

const RAWKEY_F6 = $55;


RAWKEY_F7

Declaration

Source position: keymap.pas line 105

const RAWKEY_F7 = $56;


RAWKEY_F8

Declaration

Source position: keymap.pas line 106

const RAWKEY_F8 = $57;


RAWKEY_F9

Declaration

Source position: keymap.pas line 107

const RAWKEY_F9 = $58;


RAWKEY_F10

Declaration

Source position: keymap.pas line 108

const RAWKEY_F10 = $59;


RAWKEY_F11

Declaration

Source position: keymap.pas line 94

const RAWKEY_F11 = $4B;


RAWKEY_F12

Declaration

Source position: keymap.pas line 124

const RAWKEY_F12 = $6F;


RAWKEY_F13

Declaration

Source position: keymap.pas line 147

const RAWKEY_F13 = $0103;


RAWKEY_F14

Declaration

Source position: keymap.pas line 148

const RAWKEY_F14 = $0104;


RAWKEY_F15

Declaration

Source position: keymap.pas line 149

const RAWKEY_F15 = $0105;


RAWKEY_HELP

Declaration

Source position: keymap.pas line 109

const RAWKEY_HELP = $5F;


RAWKEY_HOME

Declaration

Source position: keymap.pas line 125

const RAWKEY_HOME = $70;


RAWKEY_INSERT

Declaration

Source position: keymap.pas line 91

const RAWKEY_INSERT = $47;


RAWKEY_LALT

Declaration

Source position: keymap.pas line 114

const RAWKEY_LALT = $64;


RAWKEY_LCOMMAND

Declaration

Source position: keymap.pas line 116

const RAWKEY_LCOMMAND = $66;


RAWKEY_LCTRL

Declaration

Source position: keymap.pas line 113

const RAWKEY_LCTRL = $63;


RAWKEY_LSHIFT

Declaration

Source position: keymap.pas line 110

const RAWKEY_LSHIFT = $60;


RAWKEY_MEDIA_NEXT_TRACK

Declaration

Source position: keymap.pas line 142

const RAWKEY_MEDIA_NEXT_TRACK = $75;


RAWKEY_MEDIA_PLAY_PAUSE

Declaration

Source position: keymap.pas line 140

const RAWKEY_MEDIA_PLAY_PAUSE = $73;


RAWKEY_MEDIA_PREV_TRACK

Declaration

Source position: keymap.pas line 141

const RAWKEY_MEDIA_PREV_TRACK = $74;


RAWKEY_MEDIA_REPEAT

Declaration

Source position: keymap.pas line 144

const RAWKEY_MEDIA_REPEAT = $77;


RAWKEY_MEDIA_SHUFFLE

Declaration

Source position: keymap.pas line 143

const RAWKEY_MEDIA_SHUFFLE = $76;


RAWKEY_MEDIA_STOP

Declaration

Source position: keymap.pas line 139

const RAWKEY_MEDIA_STOP = $72;


RAWKEY_MENU

Declaration

Source position: keymap.pas line 118

const RAWKEY_MENU = $6B;


RAWKEY_PAGEDOWN

Declaration

Source position: keymap.pas line 93

const RAWKEY_PAGEDOWN = $49;


RAWKEY_PAGEUP

Declaration

Source position: keymap.pas line 92

const RAWKEY_PAGEUP = $48;


RAWKEY_PRINTSCR

Declaration

Source position: keymap.pas line 121

const RAWKEY_PRINTSCR = $6D;


RAWKEY_RALT

Declaration

Source position: keymap.pas line 115

const RAWKEY_RALT = $65;


RAWKEY_RCOMMAND

Declaration

Source position: keymap.pas line 117

const RAWKEY_RCOMMAND = $67;


RAWKEY_RETURN

Declaration

Source position: keymap.pas line 88

const RAWKEY_RETURN = $44;


RAWKEY_RSHIFT

Declaration

Source position: keymap.pas line 111

const RAWKEY_RSHIFT = $61;


RAWKEY_SPACE

Declaration

Source position: keymap.pas line 84

const RAWKEY_SPACE = $40;


RAWKEY_TAB

Declaration

Source position: keymap.pas line 86

const RAWKEY_TAB = $42;


RKI_GET_EXT_RAWKEY

Declaration

Source position: keymap.pas line 167

const RKI_GET_EXT_RAWKEY = TAG_USER + 3;


RKI_GET_FLAGS

Declaration

Source position: keymap.pas line 171

const RKI_GET_FLAGS = TAG_USER + 7;


RKI_GET_NAME

Declaration

Source position: keymap.pas line 172

const RKI_GET_NAME = TAG_USER + 8;


RKI_GET_PS2_SET1

Declaration

Source position: keymap.pas line 168

const RKI_GET_PS2_SET1 = TAG_USER + 4;


RKI_GET_PS2_SET2

Declaration

Source position: keymap.pas line 169

const RKI_GET_PS2_SET2 = TAG_USER + 5;


RKI_GET_RAWKEY

Declaration

Source position: keymap.pas line 166

const RKI_GET_RAWKEY = TAG_USER + 2;


RKI_GET_USB

Declaration

Source position: keymap.pas line 170

const RKI_GET_USB = TAG_USER + 6;


RKI_SET_TYPE

Declaration

Source position: keymap.pas line 164

const RKI_SET_TYPE = TAG_USER + 0;


RKI_SET_VALUE

Declaration

Source position: keymap.pas line 165

const RKI_SET_VALUE = TAG_USER + 1;


RKITYPE_EXT_RAWKEY

Declaration

Source position: keymap.pas line 176

const RKITYPE_EXT_RAWKEY = 2;


RKITYPE_PS2_SET1

Declaration

Source position: keymap.pas line 177

const RKITYPE_PS2_SET1 = 3;


RKITYPE_PS2_SET2

Declaration

Source position: keymap.pas line 178

const RKITYPE_PS2_SET2 = 4;


RKITYPE_RAWKEY

Declaration

Source position: keymap.pas line 175

const RKITYPE_RAWKEY = 1;


RKITYPE_USB

Declaration

Source position: keymap.pas line 179

const RKITYPE_USB = 5;


RKITYPE_USB_UPCODE

Declaration

Source position: keymap.pas line 180

const RKITYPE_USB_UPCODE = 6;


TKeyMap

Declaration

Source position: keymap.pas line 26

type TKeyMap = record

  km_LoKeyMapTypes: PByte;

  km_LoKeyMap: PLongWord;

  km_LoCapsable: PByte;

  km_LoRepeatable: PByte;

  km_HiKeyMapTypes: PByte;

  km_HiKeyMap: PLongWord;

  km_HiCapsable: PByte;

  km_HiRepeatable: PByte;

end;


TKeyMapNode

Declaration

Source position: keymap.pas line 38

type TKeyMapNode = record

  kn_Node: TNode;

  kn_KeyMap: TKeyMap;

end;


TKeyMapResource

Declaration

Source position: keymap.pas line 45

type TKeyMapResource = record

  kr_Node: TNode;

  kr_List: TList;

end;


ALPHA_PREFIX

Declaration

Source position: layers.pas line 41

const ALPHA_PREFIX = $01000000;


BFHA_APen

Declaration

Source position: layers.pas line 82

const BFHA_APen = LAYERS_DUMMY + 0;


BFHA_BitMap

Declaration

Source position: layers.pas line 87

const BFHA_BitMap = LAYERS_DUMMY + 5;


BFHA_BPen

Declaration

Source position: layers.pas line 83

const BFHA_BPen = LAYERS_DUMMY + 1;


BFHA_DrMd

Declaration

Source position: layers.pas line 84

const BFHA_DrMd = LAYERS_DUMMY + 2;


BFHA_Height

Declaration

Source position: layers.pas line 89

const BFHA_Height = LAYERS_DUMMY + 7;


BFHA_OffsetX

Declaration

Source position: layers.pas line 90

const BFHA_OffsetX = LAYERS_DUMMY + 8;


BFHA_OffsetY

Declaration

Source position: layers.pas line 91

const BFHA_OffsetY = LAYERS_DUMMY + 9;


BFHA_PatSize

Declaration

Source position: layers.pas line 85

const BFHA_PatSize = LAYERS_DUMMY + 3;


BFHA_Pattern

Declaration

Source position: layers.pas line 86

const BFHA_Pattern = LAYERS_DUMMY + 4;


BFHA_Width

Declaration

Source position: layers.pas line 88

const BFHA_Width = LAYERS_DUMMY + 6;


ILayers

Declaration

Source position: layers.pas line 149

var ILayers: PInterface = Nil;


Reference for unit 'layers'

Layer handling

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
agraphics, | Native Amiga graphic functions (graphics.library)
utility; | Tag Handling, Date routines in utility.library

Overview

provides routines that are used to manage overlapping rectangular drawing areas that share a common display. Intuition uses the layers library to manage its system of windows.

The concept of a layer is closely tied to Intuition windows. A layer is a rectangular drawing area. A layer can overlap other layers and has a display priority that determines whether it will appear in front or behind other layers. Every Intuition window has an associated Layer structure. Layers allow Intuition and application programs to :

  • Share a display's BitMap among various tasks in an orderly way by creating layers, separate drawing rectangles, within the BitMap.
  • Move, size or depth-arrange a layer while automatically keeping track of which portions of other layers are hidden or revealed by the operation.
  • Manage the remapping of coordinates, so the application need not track the layer's offset into the BitMap.
  • Maintain each layer as a separate entity, which may optionally have its own BitMap.
  • Automatically update same newly visible portions.

The layers library takes care of housekeeping: the low level, repetitive tasks which are required to keep track of where to place bits. The layers library also provides a locking mechanism which coordinates display updating when multiple tasks are drawing graphics to layers. The windowing environment provided by the Intuition library is largely based on layers.

Warning

Layers may not be created or used directly with Intuition screens. Intuition windows are the only supported method of adding layers to Intuition screens. Only the layer locking and unlocking functions are safe to use with Intuition. An application must create and manage its own View if it will be creating layers directly on the display.


Reference for unit 'layers': Constants

ALPHA_PREFIX

BFHA_APen

BFHA_BitMap

BFHA_BPen

BFHA_DrMd

BFHA_Height

BFHA_OffsetX

BFHA_OffsetY

BFHA_PatSize

BFHA_Pattern

BFHA_Width

LAYA_AlphaClips

LAYA_AlphaHook

LAYA_Backdrop

LAYA_BackFillHook

LAYA_Behind

LAYA_BitMap

LAYA_Flags

LAYA_Hidden

LAYA_InFrontOf

LAYA_MaxX

LAYA_MaxY

LAYA_MinX

LAYA_MinY

LAYA_Opaqueness

LAYA_Padding

LAYA_ShapeHook

LAYA_ShapeRegion

LAYA_SimpleRefresh

LAYA_SmartRefresh

LAYA_StayTop

LAYA_SuperBitMap

LAYA_Window

LAYERBACKDROP

LAYERBACKUP

LAYERHIDDEN

LAYERINFO_BackFillHook

LAYERINFO_Bounds

LAYERINFO_ComposeHook

LAYERINFO_ComposeLock

LAYERINFO_OffScreenBitMap

LAYERIREFRESH

LAYERIREFRESH2

LAYERMOVECHANGESSHAPE

LAYEROFFSCREEN

LAYERREFRESH

LAYERSAVEBACK

LAYERSIMPLE

LAYERSMART

LAYERSNAME

LAYERSTAYTOP

LAYERSUPER

LAYERS_BACKFILL

LAYERS_DUMMY

LAYERS_NOBACKFILL

LAYERUPDATING

LAYER_BACKMOST

LAYER_CLIPRECTS_LOST

LAYER_FRONTMOST

LCM_COMPOSE

LCM_DAMAGE

LIF_COLLECTONLY

LIF_EXTLBOUNDS

LIF_IGNORE

LIF_OFFSCREEN

LIF_OPTIMIZE

LIF_SYNCALWAYS

LIF_SYNCCOMPOSE

NEWLAYERINFO_CALLED


Reference for unit 'layers': Types

PBackFillMessage

PLayerComposeMsg

PLayer_Info

TBackFillMessage

TLayerComposeMsg

TLayer_Info


LAYA_AlphaClips

Declaration

Source position: layers.pas line 111

const LAYA_AlphaClips = LAYERS_DUMMY + 47;


LAYA_AlphaHook

Declaration

Source position: layers.pas line 112

const LAYA_AlphaHook = LAYERS_DUMMY + 48;


LAYA_Backdrop

Declaration

Source position: layers.pas line 106

const LAYA_Backdrop = LAYERS_DUMMY + 42;


LAYA_BackFillHook

Declaration

Source position: layers.pas line 108

const LAYA_BackFillHook = LAYERS_DUMMY + 44;


LAYA_Behind

Declaration

Source position: layers.pas line 109

const LAYA_Behind = LAYERS_DUMMY + 45;


LAYA_BitMap

Declaration

Source position: layers.pas line 101

const LAYA_BitMap = LAYERS_DUMMY + 37;


LAYA_Flags

Declaration

Source position: layers.pas line 107

const LAYA_Flags = LAYERS_DUMMY + 43;


LAYA_Hidden

Declaration

Source position: layers.pas line 105

const LAYA_Hidden = LAYERS_DUMMY + 41;


LAYA_InFrontOf

Declaration

Source position: layers.pas line 100

const LAYA_InFrontOf = LAYERS_DUMMY + 36;


LAYA_MaxX

Declaration

Source position: layers.pas line 96

const LAYA_MaxX = LAYERS_DUMMY + 32;


LAYA_MaxY

Declaration

Source position: layers.pas line 97

const LAYA_MaxY = LAYERS_DUMMY + 33;


LAYA_MinX

Declaration

Source position: layers.pas line 94

const LAYA_MinX = LAYERS_DUMMY + 30;


LAYA_MinY

Declaration

Source position: layers.pas line 95

const LAYA_MinY = LAYERS_DUMMY + 31;


LAYA_Opaqueness

Declaration

Source position: layers.pas line 113

const LAYA_Opaqueness = LAYERS_DUMMY + 49;


LAYA_Padding

Declaration

Source position: layers.pas line 115

const LAYA_Padding = LAYERS_DUMMY + 51;


LAYA_ShapeHook

Declaration

Source position: layers.pas line 99

const LAYA_ShapeHook = LAYERS_DUMMY + 35;


LAYA_ShapeRegion

Declaration

Source position: layers.pas line 98

const LAYA_ShapeRegion = LAYERS_DUMMY + 34;


LAYA_SimpleRefresh

Declaration

Source position: layers.pas line 103

const LAYA_SimpleRefresh = LAYERS_DUMMY + 39;


LAYA_SmartRefresh

Declaration

Source position: layers.pas line 104

const LAYA_SmartRefresh = LAYERS_DUMMY + 40;


LAYA_StayTop

Declaration

Source position: layers.pas line 110

const LAYA_StayTop = LAYERS_DUMMY + 46;


LAYA_SuperBitMap

Declaration

Source position: layers.pas line 102

const LAYA_SuperBitMap = LAYERS_DUMMY + 38;


LAYA_Window

Declaration

Source position: layers.pas line 114

const LAYA_Window = LAYERS_DUMMY + 50;


LAYER_BACKMOST

Declaration

Source position: layers.pas line 77

const LAYER_BACKMOST = PLayer(0);


LAYER_CLIPRECTS_LOST

Declaration

Source position: layers.pas line 32

const LAYER_CLIPRECTS_LOST = $100;


LAYER_FRONTMOST

Declaration

Source position: layers.pas line 78

const LAYER_FRONTMOST = PLayer(1);


LAYERBACKDROP

Declaration

Source position: layers.pas line 30

const LAYERBACKDROP = $40;


LAYERBACKUP

Declaration

Source position: layers.pas line 39

const LAYERBACKUP = $8000;


LAYERHIDDEN

Declaration

Source position: layers.pas line 36

const LAYERHIDDEN = $1000;


LAYERINFO_BackFillHook

Declaration

Source position: layers.pas line 118

const LAYERINFO_BackFillHook = LAYERS_DUMMY + 100;


LAYERINFO_Bounds

Declaration

Source position: layers.pas line 119

const LAYERINFO_Bounds = LAYERS_DUMMY + 101;


LAYERINFO_ComposeHook

Declaration

Source position: layers.pas line 121

const LAYERINFO_ComposeHook = LAYERS_DUMMY + 103;


LAYERINFO_ComposeLock

Declaration

Source position: layers.pas line 122

const LAYERINFO_ComposeLock = LAYERS_DUMMY + 104;


LAYERINFO_OffScreenBitMap

Declaration

Source position: layers.pas line 120

const LAYERINFO_OffScreenBitMap = LAYERS_DUMMY + 102;


LAYERIREFRESH

Declaration

Source position: layers.pas line 33

const LAYERIREFRESH = $200;


LAYERIREFRESH2

Declaration

Source position: layers.pas line 34

const LAYERIREFRESH2 = $400;


LAYERMOVECHANGESSHAPE

Declaration

Source position: layers.pas line 38

const LAYERMOVECHANGESSHAPE = $4000;


LAYEROFFSCREEN

Declaration

Source position: layers.pas line 28

const LAYEROFFSCREEN = 8;


LAYERREFRESH

Declaration

Source position: layers.pas line 31

const LAYERREFRESH = $80;


LAYERS_BACKFILL

Declaration

Source position: layers.pas line 74

const LAYERS_BACKFILL = PHook(0);


LAYERS_DUMMY

Declaration

Source position: layers.pas line 81

const LAYERS_DUMMY = TAG_USER;


LAYERS_NOBACKFILL

Declaration

Source position: layers.pas line 73

const LAYERS_NOBACKFILL = PHook(1);


LAYERSAVEBACK

Declaration

Source position: layers.pas line 35

const LAYERSAVEBACK = $800;


LayersBase

Declaration

Source position: layers.pas line 148

var LayersBase: PLibrary = Nil;


LAYERSIMPLE

Declaration

Source position: layers.pas line 25

const LAYERSIMPLE = 1;


LAYERSMART

Declaration

Source position: layers.pas line 26

const LAYERSMART = 2;


LAYERSNAME

Declaration

Source position: layers.pas line 146

const LAYERSNAME: PChar = 'layers.library';


LAYERSTAYTOP

Declaration

Source position: layers.pas line 37

const LAYERSTAYTOP = $2000;


LAYERSUPER

Declaration

Source position: layers.pas line 27

const LAYERSUPER = 4;


LAYERUPDATING

Declaration

Source position: layers.pas line 29

const LAYERUPDATING = $10;


LCM_COMPOSE

Declaration

Source position: layers.pas line 143

const LCM_COMPOSE = 0;


LCM_DAMAGE

Declaration

Source position: layers.pas line 144

const LCM_DAMAGE = 1;


LIF_COLLECTONLY

Declaration

Source position: layers.pas line 68

const LIF_COLLECTONLY = $2000;


LIF_EXTLBOUNDS

Declaration

Source position: layers.pas line 64

const LIF_EXTLBOUNDS = $0200;


LIF_IGNORE

Declaration

Source position: layers.pas line 69

const LIF_IGNORE = $4000;


LIF_OFFSCREEN

Declaration

Source position: layers.pas line 65

const LIF_OFFSCREEN = $0400;


LIF_OPTIMIZE

Declaration

Source position: layers.pas line 70

const LIF_OPTIMIZE = $8000;


LIF_SYNCALWAYS

Declaration

Source position: layers.pas line 67

const LIF_SYNCALWAYS = $1000;


LIF_SYNCCOMPOSE

Declaration

Source position: layers.pas line 66

const LIF_SYNCCOMPOSE = $0800;


PBackFillMessage

Declaration

Source position: layers.pas line 126

type PBackFillMessage = ^TBackFillMessage;


PLayer_Info

Declaration

Source position: layers.pas line 43

type PLayer_Info = ^TLayer_Info;


PLayerComposeMsg

Declaration

Source position: layers.pas line 135

type PLayerComposeMsg = ^TLayerComposeMsg;


TBackFillMessage

Declaration

Source position: layers.pas line 127

type TBackFillMessage = record

  Layer: PLayer;

  Bounds: TRectangle;

  OffsetX: LongInt;

  OffsetY: LongInt;

end;


TLayer_Info

Declaration

Source position: layers.pas line 44

type TLayer_Info = record

  top_layer: PLayer;

  resPtr1: Pointer;

  resPtr2: Pointer;

  FreeClipRects: PClipRect;

  Bounds: TRectangle;

  Lock: TSignalSemaphore;

  gs_Head: TMinList;

  PrivateReserve3: SmallInt;

  ClipRectPool: Pointer;

  Flags: Word;

  fatten_count: ShortInt;

  LockLayersCount: ShortInt;

  PrivateReserve5: SmallInt;

  BlankHook: PHook;

  LayerInfo_extra: Pointer;

end;


TLayerComposeMsg

Declaration

Source position: layers.pas line 136

type TLayerComposeMsg = record

  Action: LongWord;

  LayerInfo: PLayer_Info;

  BackBitMap: PBitMap;

  Bounds: TRectangle;

end;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

ABDAY_1

Declaration

Source position: locale.pas line 36

const ABDAY_1 = 8;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

ABDAY_2

Declaration

Source position: locale.pas line 37

const ABDAY_2 = 9;


ABDAY_3

Declaration

Source position: locale.pas line 38

const ABDAY_3 = 10;


ABDAY_4

Declaration

Source position: locale.pas line 39

const ABDAY_4 = 11;


ABDAY_5

Declaration

Source position: locale.pas line 40

const ABDAY_5 = 12;


ABDAY_6

Declaration

Source position: locale.pas line 41

const ABDAY_6 = 13;


ABDAY_7

Declaration

Source position: locale.pas line 42

const ABDAY_7 = 14;


ABMON_1

Declaration

Source position: locale.pas line 57

const ABMON_1 = 27;


ABMON_2

Declaration

Source position: locale.pas line 58

const ABMON_2 = 28;


ABMON_3

Declaration

Source position: locale.pas line 59

const ABMON_3 = 29;


ABMON_4

Declaration

Source position: locale.pas line 60

const ABMON_4 = 30;


ABMON_5

Declaration

Source position: locale.pas line 61

const ABMON_5 = 31;


ABMON_6

Declaration

Source position: locale.pas line 62

const ABMON_6 = 32;


ABMON_7

Declaration

Source position: locale.pas line 63

const ABMON_7 = 33;


ABMON_8

Declaration

Source position: locale.pas line 64

const ABMON_8 = 34;


ABMON_9

Declaration

Source position: locale.pas line 65

const ABMON_9 = 35;


ABMON_10

Declaration

Source position: locale.pas line 66

const ABMON_10 = 36;


ABMON_11

Declaration

Source position: locale.pas line 67

const ABMON_11 = 37;


ABMON_12

Declaration

Source position: locale.pas line 68

const ABMON_12 = 38;


ALTDAY_1

Declaration

Source position: locale.pas line 92

const ALTDAY_1 = 52;


ALTDAY_2

Declaration

Source position: locale.pas line 93

const ALTDAY_2 = 53;


ALTDAY_3

Declaration

Source position: locale.pas line 94

const ALTDAY_3 = 54;


ALTDAY_4

Declaration

Source position: locale.pas line 95

const ALTDAY_4 = 55;


ALTDAY_5

Declaration

Source position: locale.pas line 96

const ALTDAY_5 = 56;


ALTDAY_6

Declaration

Source position: locale.pas line 97

const ALTDAY_6 = 57;


ALTDAY_7

Declaration

Source position: locale.pas line 98

const ALTDAY_7 = 58;


ALTMON_1

Declaration

Source position: locale.pas line 103

const ALTMON_1 = 59;


ALTMON_2

Declaration

Source position: locale.pas line 104

const ALTMON_2 = 60;


ALTMON_3

Declaration

Source position: locale.pas line 105

const ALTMON_3 = 61;


ALTMON_4

Declaration

Source position: locale.pas line 106

const ALTMON_4 = 62;


ALTMON_5

Declaration

Source position: locale.pas line 107

const ALTMON_5 = 63;


ALTMON_6

Declaration

Source position: locale.pas line 108

const ALTMON_6 = 64;


ALTMON_7

Declaration

Source position: locale.pas line 109

const ALTMON_7 = 65;


ALTMON_8

Declaration

Source position: locale.pas line 110

const ALTMON_8 = 66;


ALTMON_9

Declaration

Source position: locale.pas line 111

const ALTMON_9 = 67;


ALTMON_10

Declaration

Source position: locale.pas line 112

const ALTMON_10 = 68;


ALTMON_11

Declaration

Source position: locale.pas line 113

const ALTMON_11 = 69;


ALTMON_12

Declaration

Source position: locale.pas line 114

const ALTMON_12 = 70;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

AM_STR

Declaration

Source position: locale.pas line 73

const AM_STR = 41;


CLOSEQUOTE

Declaration

Source position: locale.pas line 80

const CLOSEQUOTE = 46;


CSP_PRECEDES

Declaration

Source position: locale.pas line 221

const CSP_PRECEDES = 0;


CSP_SUCCEEDS

Declaration

Source position: locale.pas line 222

const CSP_SUCCEEDS = 1;


CT_7FRI

Declaration

Source position: locale.pas line 206

const CT_7FRI = 5;


CT_7MON

Declaration

Source position: locale.pas line 202

const CT_7MON = 1;


CT_7SAT

Declaration

Source position: locale.pas line 207

const CT_7SAT = 6;


CT_7SUN

Declaration

Source position: locale.pas line 201

const CT_7SUN = 0;


CT_7THU

Declaration

Source position: locale.pas line 205

const CT_7THU = 4;


CT_7TUE

Declaration

Source position: locale.pas line 203

const CT_7TUE = 2;


CT_7WED

Declaration

Source position: locale.pas line 204

const CT_7WED = 3;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DAY_1

Declaration

Source position: locale.pas line 28

const DAY_1 = 1;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DAY_2

Declaration

Source position: locale.pas line 29

const DAY_2 = 2;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DAY_3

Declaration

Source position: locale.pas line 30

const DAY_3 = 3;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DAY_4

Declaration

Source position: locale.pas line 31

const DAY_4 = 4;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DAY_5

Declaration

Source position: locale.pas line 32

const DAY_5 = 5;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DAY_6

Declaration

Source position: locale.pas line 33

const DAY_6 = 6;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

DAY_7

Declaration

Source position: locale.pas line 34

const DAY_7 = 7;


FUTURESTR

Declaration

Source position: locale.pas line 85

const FUTURESTR = 50;


HARDHYPHEN

Declaration

Source position: locale.pas line 77

const HARDHYPHEN = 44;


ILocale

Declaration

Source position: locale.pas line 276

var ILocale: PInterface = Nil;


Reference for unit 'locale'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
amigados, | File and directory handling routines and types (dos.library)
utility; | Tag Handling, Date routines in utility.library


Reference for unit 'locale': Constants

ABDAY_1

ABDAY_2

ABDAY_3

ABDAY_4

ABDAY_5

ABDAY_6

ABDAY_7

ABMON_1

ABMON_10

ABMON_11

ABMON_12

ABMON_2

ABMON_3

ABMON_4

ABMON_5

ABMON_6

ABMON_7

ABMON_8

ABMON_9

ALTDAY_1

ALTDAY_2

ALTDAY_3

ALTDAY_4

ALTDAY_5

ALTDAY_6

ALTDAY_7

ALTMON_1

ALTMON_10

ALTMON_11

ALTMON_12

ALTMON_2

ALTMON_3

ALTMON_4

ALTMON_5

ALTMON_6

ALTMON_7

ALTMON_8

ALTMON_9

AM_STR

CLOSEQUOTE

CSP_PRECEDES

CSP_SUCCEEDS

CT_7FRI

CT_7MON

CT_7SAT

CT_7SUN

CT_7THU

CT_7TUE

CT_7WED

DAY_1

DAY_2

DAY_3

DAY_4

DAY_5

DAY_6

DAY_7

FUTURESTR

HARDHYPHEN

LANG_CODE

LANG_NAME

LOCALENAME

MAXSTRMSG

MON_1

MON_10

MON_11

MON_12

MON_2

MON_3

MON_4

MON_5

MON_6

MON_7

MON_8

MON_9

MS_AMERICAN

MS_BRITISH

MS_IMPERIAL

MS_ISO

NOSTR

OC_BuiltInCodeSet

OC_BuiltInLanguage

OC_BuiltInVersion

OC_Language

OC_PreferExternal

OC_TagBase

OC_Version

OC_WantedCodeSet

OPENQUOTE

PM_STR

SC_ASCII

SC_COLLATE1

SC_COLLATE2

SOFTHYPHEN

SP_PARENS

SP_PREC_ALL

SP_PREC_CURR

SP_SUCC_ALL

SP_SUCC_CURR

SS_NOSPACE

SS_SPACE

TODAYSTR

TOMORROWSTR

YESSTR

YESTERDAYSTR


Reference for unit 'locale': Types

PCatalog

PLocale

PLocaleBase

TCatalog

TLocale

TLocaleBase


LANG_CODE

Declaration

Source position: locale.pas line 26

const LANG_CODE = 0;


LANG_NAME

Declaration

Source position: locale.pas line 87

const LANG_NAME = 51;


LocaleBase

Declaration

Source position: locale.pas line 275

var LocaleBase: PLocaleBase = Nil;


LOCALENAME

Declaration

Source position: locale.pas line 279

const LOCALENAME: PChar = 'locale.library';


MAXSTRMSG

Declaration

Source position: locale.pas line 116

const MAXSTRMSG = 71;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_1

Declaration

Source position: locale.pas line 44

const MON_1 = 15;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_2

Declaration

Source position: locale.pas line 45

const MON_2 = 16;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_3

Declaration

Source position: locale.pas line 46

const MON_3 = 17;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_4

Declaration

Source position: locale.pas line 47

const MON_4 = 18;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_5

Declaration

Source position: locale.pas line 48

const MON_5 = 19;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_6

Declaration

Source position: locale.pas line 49

const MON_6 = 20;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_7

Declaration

Source position: locale.pas line 50

const MON_7 = 21;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_8

Declaration

Source position: locale.pas line 51

const MON_8 = 22;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_9

Declaration

Source position: locale.pas line 52

const MON_9 = 23;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_10

Declaration

Source position: locale.pas line 53

const MON_10 = 24;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_11

Declaration

Source position: locale.pas line 54

const MON_11 = 25;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MON_12

Declaration

Source position: locale.pas line 55

const MON_12 = 26;


MS_AMERICAN

Declaration

Source position: locale.pas line 196

const MS_AMERICAN = 1;


MS_BRITISH

Declaration

Source position: locale.pas line 198

const MS_BRITISH = 3;


MS_IMPERIAL

Declaration

Source position: locale.pas line 197

const MS_IMPERIAL = 2;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

MS_ISO

Declaration

Source position: locale.pas line 195

const MS_ISO = 0;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

NOSTR

Declaration

Source position: locale.pas line 71

const NOSTR = 40;


OC_BuiltInCodeSet

Declaration

Source position: locale.pas line 243

const OC_BuiltInCodeSet = OC_TagBase + 2;


OC_BuiltInLanguage

Declaration

Source position: locale.pas line 242

const OC_BuiltInLanguage = OC_TagBase + 1;


OC_BuiltInVersion

Declaration

Source position: locale.pas line 247

const OC_BuiltInVersion = OC_TagBase + 6;


OC_Language

Declaration

Source position: locale.pas line 245

const OC_Language = OC_TagBase + 4;


OC_PreferExternal

Declaration

Source position: locale.pas line 248

const OC_PreferExternal = OC_TagBase + 7;


OC_TagBase

Declaration

Source position: locale.pas line 241

const OC_TagBase = TAG_USER + $90000;


OC_Version

Declaration

Source position: locale.pas line 244

const OC_Version = OC_TagBase + 3;


OC_WantedCodeSet

Declaration

Source position: locale.pas line 246

const OC_WantedCodeSet = OC_TagBase + 5;


OPENQUOTE

Declaration

Source position: locale.pas line 79

const OPENQUOTE = 45;


PCatalog

Declaration

Source position: locale.pas line 264

type PCatalog = ^TCatalog;


PLocale

Declaration

Source position: locale.pas line 133

type PLocale = ^TLocale;


PLocaleBase

Declaration

Source position: locale.pas line 123

type PLocaleBase = ^TLocaleBase;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

PM_STR

Declaration

Source position: locale.pas line 74

const PM_STR = 42;


SC_ASCII

Declaration

Source position: locale.pas line 255

const SC_ASCII = 0;


SC_COLLATE1

Declaration

Source position: locale.pas line 256

const SC_COLLATE1 = 1;


SC_COLLATE2

Declaration

Source position: locale.pas line 257

const SC_COLLATE2 = 2;


SOFTHYPHEN

Declaration

Source position: locale.pas line 76

const SOFTHYPHEN = 43;


SP_PARENS

Declaration

Source position: locale.pas line 214

const SP_PARENS = 0;


SP_PREC_ALL

Declaration

Source position: locale.pas line 215

const SP_PREC_ALL = 1;


SP_PREC_CURR

Declaration

Source position: locale.pas line 217

const SP_PREC_CURR = 3;


SP_SUCC_ALL

Declaration

Source position: locale.pas line 216

const SP_SUCC_ALL = 2;


SP_SUCC_CURR

Declaration

Source position: locale.pas line 218

const SP_SUCC_CURR = 4;


SS_NOSPACE

Declaration

Source position: locale.pas line 210

const SS_NOSPACE = 0;


SS_SPACE

Declaration

Source position: locale.pas line 211

const SS_SPACE = 1;


TCatalog

Declaration

Source position: locale.pas line 265

type TCatalog = record

  cat_Link: TNode;

  cat_Pad: Word;

  cat_Language: PChar;

  cat_CodeSet: LongWord;

  cat_Version: Word;

  cat_Revision: Word;

end;


TLocale

Declaration

Source position: locale.pas line 134

type TLocale = record

  loc_LocaleName: PChar;

  loc_LanguageName: PChar;

  loc_PrefLanguages: array [0..9] of PChar;

  loc_Flags: LongWord;

  loc_CodeSet: LongWord;

  loc_CountryCode: LongWord;

  loc_TelephoneCode: LongWord;

  loc_GMTOffset: LongWord;

  loc_MeasuringSystem: Byte;

  loc_CalendarType: Byte;

  loc_Reserved0: array [0..1] of Byte;

  loc_DateTimeFormat: PChar;

  loc_DateFormat: PChar;

  loc_TimeFormat: PChar;

  loc_ShortDateTimeFormat: PChar;

  loc_ShortDateFormat: PChar;

  loc_ShortTimeFormat: PChar;

  loc_DecimalPoint: PChar;

  loc_GroupSeparator: PChar;

  loc_FracGroupSeparator: PChar;

  loc_Grouping: PByte;

  loc_FracGrouping: PByte;

  loc_MonDecimalPoint: PChar;

  loc_MonGroupSeparator: PChar;

  loc_MonFracGroupSeparator: PChar;

  loc_MonGrouping: PByte;

  loc_MonFracGrouping: PByte;

  loc_MonFracDigits: Byte;

  loc_MonIntFracDigits: Byte;

  loc_Reserved1: array [0..1] of Byte;

  loc_MonCS: PChar;

  loc_MonSmallCS: PChar;

  loc_MonIntCS: PChar;

  loc_MonPositiveSign: PChar;

  loc_MonPositiveSpaceSep: Byte;

  loc_MonPositiveSignPos: Byte;

  loc_MonPositiveCSPos: Byte;

  loc_Reserved2: Byte;

  loc_MonNegativeSign: PChar;

  loc_MonNegativeSpaceSep: PChar;

  loc_MonNegativeSignPos: PChar;

  loc_MonNegativeCSPos: PChar;

  loc_Reserved3: Byte;

end;


TLocaleBase

Declaration

Source position: locale.pas line 124

type TLocaleBase = record

  lb_LibNode: TLibrary;

  lb_SysPatches: Boolean;

end;


TODAYSTR

Declaration

Source position: locale.pas line 83

const TODAYSTR = 48;


TOMORROWSTR

Declaration

Source position: locale.pas line 84

const TOMORROWSTR = 49;


Unit 'locale' | Package
[Overview][Constants][Types][Procedures and functions][Variables][Index] | [#os4units]

YESSTR

Declaration

Source position: locale.pas line 70

const YESSTR = 39;


YESTERDAYSTR

Declaration

Source position: locale.pas line 82

const YESTERDAYSTR = 47;


IDCMP_MOUSEOBJECT

Declaration

Source position: mui.pas line 599

const IDCMP_MOUSEOBJECT = $40000000;


IMSPEC_EXTERNAL_PREFIX

Declaration

Source position: mui.pas line 125

const IMSPEC_EXTERNAL_PREFIX = 'MUI:Images/';


IMui

Declaration

Source position: mui.pas line 3690

var IMui: PInterface = Nil;


Reference for unit 'mui'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
intuition, | Screen and Window handling routines of intuition.library
utility, | Tag Handling, Date routines in utility.library
agraphics, | Native Amiga graphic functions (graphics.library)
iffparse;

Overview

Notify |  |  |  |  |  | (implements notification mechanism)
+------------ | Family |  |  |  |  | (handles multiple children)
| | +------------ | Menustrip |  |  |  | (describes a complete menu strip)
| | +------------ | Menu |  |  |  | (describes a single menu)
| | \------------- | Menuitem |  |  |  | (describes a single menu item)
+------------ | Application |  |  |  |  | (main class for all applications)
+------------ | Window |  |  |  |  | (main class for all windows)
| | \------------- | Aboutmui |  |  |  | (About window of MUI preferences)
\------------- | Area |  |  |  |  | (base class for all GUI elements)
 | +------------ | Rectangle |  |  |  | (spacing object)
 | +------------ | Balance |  |  |  | (balancing separator bar)
 | +------------ | Image |  |  |  | (image display)
 | +------------ | Bitmap |  |  |  | (draws bitmaps)
 | | | \------------- | Bodychunk |  |  | (makes bitmap from ILBM body chunk)
 | +------------ | Text |  |  |  | (text display)
 | +------------ | Gadget |  |  |  | (base class for intuition gadgets)
 | | | +------------ | String |  |  | (string gadget)
 | | | +------------ | Boopsi |  |  | (interface to BOOPSI gadgets)
 | | | \------------- | Prop |  |  | (proportional gadget)
 | +------------ | Gauge |  |  |  | (fule gauge)
 | +------------ | Scale |  |  |  | (percentage scale)
 | +------------ | Colorfield |  |  |  | (field with changeable color)
 | +------------ | List |  |  |  | (line-oriented list)
 | | | +------------ | Floattext |  |  | (special list with floating text)
 | | | +------------ | Volumelist |  |  | (special list with volumes)
 | | | +------------ | Scrmodelist |  |  | (special list with screen modes)
 | | | \------------- | DirList |  |  | (special list with files)
 | +------------ | Numeric |  |  |  | (base class for slider gadgets)
 | | | +------------ | Knop |  |  | (turning knob)
 | | | +------------ | Levelmeter |  |  | (level display)
 | | | +------------ | Numericbutton |  |  | (space saving popup slider)
 | | | \------------- | Slider |  |  | (traditional slider)
 | +------------ | Framedisplay |  |  |  | (private)
 | | | \------------- | Popframe |  |  | (private)
 | +------------ | Imagedisplay |  |  |  | (private)
 | | | \------------- | Popimage |  |  | (private)
 | +------------ | Pendisplay |  |  |  | (displays a pen specification)
 | | | \------------- | Poppen |  |  | (popup button to adjust a pen spec)
 | \------------- | Group |  |  |  | (groups other GUI elements)
 |  | +------------ | Mccprefs |  |  | (private)
 |  | +------------ | Register |  |  | (handles page groups with titles)
 |  | | | \------------------ | Penadjust |  | (group to adjust a pen)
 |  | +------------ | Settingsgroup |  |  | (private)
 |  | +------------ | Settings |  |  | (private)
 |  | +------------ | Frameadjust |  |  | (private)
 |  | +------------ | Imageadjust |  |  | (private)
 |  | +------------ | Virtgroup |  |  | (handles virtual groups)
 |  | +------------ | Scrollgroup |  |  | (virtual groups with scrollbars)
 |  | +------------ | Scrollbar |  |  | (traditional scrollbar)
 |  | +------------ | Listview |  |  | (listview)
 |  | +------------ | Radio |  |  | (radio button)
 |  | +------------ | Cycle |  |  | (cycle gadget)
 |  | +------------ | Coloradjust |  |  | (several gadgets to adjust a color)
 |  | +------------ | Palette |  |  | (complete palette gadget)
 |  | \------------- | Popstring |  |  | (base class for popup objects)
 |  |  | +----------------- | Popobject |  | (popup aynthing in a separate window)
 |  |  | | | +------------ | Poplist | (popup a simple listview)
 |  |  | | | \------------- | Popscreen | (popup a list of public screens)
 |  |  | \------------------ | Popasl |  | (popup an asl requester)
Semaphore |  |  |  |  |  | (semaphore equipped objects)
+------------ | Applist |  |  |  |  | (private)
\------------- | Dataspace |  |  |  |  | (handles general purpose data spaces)
 | \------------- | Configdata |  |  |  | (private)


Reference for unit 'mui': Constants

IDCMP_MOUSEOBJECT
IMSPEC_EXTERNAL_PREFIX
MADF_DRAWALL
MADF_DRAWOBJECT |
MADF_DRAWUPDATE |
MAXWINS
MBQF_HORIZ |
MBQ_MUI_MAXMAX |
MC_TEMPLATE_ID |
MPEN_BACKGROUND |
MPEN_COUNT |
MPEN_FILL |
MPEN_HALFSHADOW |
MPEN_HALFSHINE |
MPEN_MARK |
MPEN_SHADOW |
MPEN_SHINE |
MPEN_TEXT |
MRI_RARRAY_SIZE
MUIA_Aboutmui_Application |
MUIA_ApplicationObject |
MUIA_Application_Active |
MUIA_Application_Author |
MUIA_Application_Base |
MUIA_Application_Broker |
MUIA_Application_BrokerHook |
MUIA_Application_BrokerPort |
MUIA_Application_BrokerPri |
MUIA_Application_Commands |
MUIA_Application_Configdata
MUIA_Application_Copyright |
MUIA_Application_CopyWinPosToApp
MUIA_Application_Description |
MUIA_Application_DiskObject |
MUIA_Application_DoubleStart |
MUIA_Application_DropObject |
MUIA_Application_ForceQuit |
MUIA_Application_GetWinPos
MUIA_Application_GetWinPosAddr
MUIA_Application_GetWinPosSize
MUIA_Application_HelpFile |
MUIA_Application_Iconified |
MUIA_Application_MenuAction |
MUIA_Application_MenuHelp |
MUIA_Application_Menustrip |
MUIA_Application_RexxHook |
MUIA_Application_RexxMsg |
MUIA_Application_RexxString |
MUIA_Application_SearchWinId
MUIA_Application_SetWinPos
MUIA_Application_SingleTask |
MUIA_Application_Sleep |
MUIA_Application_Title |
MUIA_Application_UseCommodities |
MUIA_Application_UsedClasses |
MUIA_Application_UseRexx |
MUIA_Application_Version |
MUIA_Application_Version_Date
MUIA_Application_Version_Extra
MUIA_Application_Version_Number
MUIA_Application_Window |
MUIA_Application_WindowList |
MUIA_AppMessage |
MUIA_Background |
MUIA_Balance_Quiet
MUIA_Bitmap_Alpha
MUIA_Bitmap_Bitmap |
MUIA_Bitmap_Height |
MUIA_Bitmap_MappingTable |
MUIA_Bitmap_Precision |
MUIA_Bitmap_RemappedBitmap |
MUIA_Bitmap_SourceColors |
MUIA_Bitmap_Transparent |
MUIA_Bitmap_UseFriend |
MUIA_Bitmap_Width |
MUIA_Bodychunk_Body |
MUIA_Bodychunk_Compression |
MUIA_Bodychunk_Depth |
MUIA_Bodychunk_Masking |
MUIA_Boopsi_Class |
MUIA_Boopsi_ClassID |
MUIA_Boopsi_MaxHeight |
MUIA_Boopsi_MaxWidth |
MUIA_Boopsi_MinHeight |
MUIA_Boopsi_MinWidth |
MUIA_Boopsi_Object |
MUIA_Boopsi_Remember |
MUIA_Boopsi_Smart |
MUIA_Boopsi_TagDrawInfo |
MUIA_Boopsi_TagScreen |
MUIA_Boopsi_TagWindow |
MUIA_BottomEdge |
MUIA_ChunkyImage_Modulo
MUIA_ChunkyImage_NumColors
MUIA_ChunkyImage_Palette
MUIA_ChunkyImage_Pixels
MUIA_Coloradjust_Blue |
MUIA_Coloradjust_Green |
MUIA_Coloradjust_ModeID |
MUIA_Coloradjust_Red |
MUIA_Coloradjust_RGB |
MUIA_Colorfield_Blue |
MUIA_Colorfield_Green |
MUIA_Colorfield_Pen |
MUIA_Colorfield_Red |
MUIA_Colorfield_RGB |
MUIA_Configdata_Application
MUIA_Configdata_ApplicationBase
MUIA_ContextMenu |
MUIA_ContextMenuTrigger |
MUIA_ControlChar |
MUIA_CycleChain |
MUIA_Cycle_Active |
MUIA_Cycle_Entries |
MUIA_Dataspace_Pool |
MUIA_Dirlist_AcceptPattern |
MUIA_Dirlist_Directory |
MUIA_Dirlist_DrawersOnly |
MUIA_Dirlist_FilesOnly |
MUIA_Dirlist_FilterDrawers |
MUIA_Dirlist_FilterHook |
MUIA_Dirlist_MultiSelDirs |
MUIA_Dirlist_NumBytes |
MUIA_Dirlist_NumDrawers |
MUIA_Dirlist_NumFiles |
MUIA_Dirlist_Path |
MUIA_Dirlist_RejectIcons |
MUIA_Dirlist_RejectPattern |
MUIA_Dirlist_SortDirs |
MUIA_Dirlist_SortHighLow |
MUIA_Dirlist_SortType |
MUIA_Dirlist_Status |
MUIA_Disabled |
MUIA_DoubleBuffer
MUIA_Draggable |
MUIA_Dropable |
MUIA_Dtpic_Alpha
MUIA_Dtpic_DarkenSelState
MUIA_Dtpic_Fade
MUIA_Dtpic_LightenOnMouse
MUIA_Dtpic_Name
MUIA_Family_Child |
MUIA_Family_ChildCount
MUIA_Family_List |
MUIA_FillArea |
MUIA_FixHeight |
MUIA_FixHeightTxt |
MUIA_FixWidth |
MUIA_FixWidthTxt |
MUIA_Floattext_Justify |
MUIA_Floattext_SkiPChars |
MUIA_Floattext_TabSize |
MUIA_Floattext_Text |
MUIA_Font |
MUIA_Frame |
MUIA_Frameadjust_Spec
MUIA_Framedisplay_Spec
MUIA_FramePhantomHoriz |
MUIA_FrameTitle |
MUIA_Gadget_Gadget |
MUIA_Gauge_Current |
MUIA_Gauge_Divide |
MUIA_Gauge_DupInfoText
MUIA_Gauge_Horiz |
MUIA_Gauge_InfoText |
MUIA_Gauge_Max |
MUIA_Group_ActivePage |
MUIA_Group_Child |
MUIA_Group_ChildList |
MUIA_Group_Columns |
MUIA_Group_Forward
MUIA_Group_Horiz |
MUIA_Group_HorizSpacing |
MUIA_Group_LayoutHook |
MUIA_Group_PageMode |
MUIA_Group_Rows |
MUIA_Group_SameHeight |
MUIA_Group_SameSize |
MUIA_Group_SameWidth |
MUIA_Group_Spacing |
MUIA_Group_VertSpacing |
MUIA_Group_Virtual
MUIA_Height |
MUIA_HelpLine |
MUIA_HelpNode |
MUIA_HorizDisappear |
MUIA_HorizWeight |
MUIA_Imageadjust_Originator
MUIA_Imageadjust_Spec
MUIA_Imageadjust_Type
MUIA_Imagedisplay_FreeHoriz
MUIA_Imagedisplay_FreeVert
MUIA_Imagedisplay_Spec
MUIA_Imagedisplay_UseDefSize
MUIA_Image_FontMatch |
MUIA_Image_FontMatchHeight |
MUIA_Image_FontMatchWidth |
MUIA_Image_FreeHoriz |
MUIA_Image_FreeVert |
MUIA_Image_OldImage |
MUIA_Image_Spec |
MUIA_Image_State |
MUIA_InnerBottom |
MUIA_InnerLeft |
MUIA_InnerRight |
MUIA_InnerTop |
MUIA_InputMode |
MUIA_LeftEdge |
MUIA_Levelmeter_Label |
MUIA_Listview_ClickColumn |
MUIA_Listview_DefClickColumn |
MUIA_Listview_DoubleClick |
MUIA_Listview_DragType |
MUIA_Listview_Input |
MUIA_Listview_List |
MUIA_Listview_MultiSelect |
MUIA_Listview_ScrollerPos |
MUIA_Listview_SelectChange |
MUIA_List_Active |
MUIA_List_AdjustHeight |
MUIA_List_AdjustWidth |
MUIA_List_AutoVisible |
MUIA_List_CompareHook |
MUIA_List_ConstructHook |
MUIA_List_DestructHook |
MUIA_List_DisplayHook |
MUIA_List_DragSortable |
MUIA_List_DropMark |
MUIA_List_Entries |
MUIA_List_First |
MUIA_List_Format |
MUIA_List_InsertPosition |
MUIA_List_MinLineHeight |
MUIA_List_MultiTestHook |
MUIA_List_Pool |
MUIA_List_PoolPuddleSize |
MUIA_List_PoolThreshSize |
MUIA_List_Quiet |
MUIA_List_ShowDropMarks |
MUIA_List_SourceArray |
MUIA_List_Title |
MUIA_List_Visible |
MUIA_MaxHeight |
MUIA_MaxWidth |
MUIA_Menuitem_Checked |
MUIA_Menuitem_Checkit |
MUIA_Menuitem_CommandString |
MUIA_Menuitem_Enabled |
MUIA_Menuitem_Exclude |
MUIA_Menuitem_NewMenu
MUIA_Menuitem_Shortcut |
MUIA_Menuitem_Title |
MUIA_Menuitem_Toggle |
MUIA_Menuitem_Trigger |
MUIA_Menustrip_Enabled |
MUIA_Menu_Enabled |
MUIA_Menu_Title |
MUIA_NestedDisabled
MUIA_NoNotify |
MUIA_NoNotifyMethod
MUIA_Numeric_CheckAllSizes |
MUIA_Numeric_Default |
MUIA_Numeric_Format |
MUIA_Numeric_Max |
MUIA_Numeric_Min |
MUIA_Numeric_Reverse |
MUIA_Numeric_RevLeftRight |
MUIA_Numeric_RevUpDown |
MUIA_Numeric_Value |
MUIA_ObjectID |
MUIA_Palette_Entries |
MUIA_Palette_Groupable |
MUIA_Palette_Names |
MUIA_Parent |
MUIA_Penadjust_PSIMode |
MUIA_Pendisplay_Pen |
MUIA_Pendisplay_Reference |
MUIA_Pendisplay_RGBcolor |
MUIA_Pendisplay_Spec |
MUIA_Pixmap_Alpha
MUIA_Pixmap_CLUT
MUIA_Pixmap_CompressedSize
MUIA_Pixmap_Compression
MUIA_Pixmap_Data
MUIA_Pixmap_Format
MUIA_Pixmap_Height
MUIA_Pixmap_UncompressedData
MUIA_Pixmap_Width
MUIA_Popasl_Active |
MUIA_Popasl_StartHook |
MUIA_Popasl_StopHook |
MUIA_Popasl_Type |
MUIA_Poplist_Array |
MUIA_Popobject_Follow |
MUIA_Popobject_Light |
MUIA_Popobject_Object |
MUIA_Popobject_ObjStrHook |
MUIA_Popobject_StrObjHook |
MUIA_Popobject_Volatile |
MUIA_Popobject_WindowHook |
MUIA_Popstring_Button |
MUIA_Popstring_CloseHook |
MUIA_Popstring_OpenHook |
MUIA_Popstring_String |
MUIA_Popstring_Toggle |
MUIA_Pressed |
MUIA_Process_AutoLaunch
MUIA_Process_Name
MUIA_Process_Priority
MUIA_Process_SourceClass
MUIA_Process_SourceObject
MUIA_Process_StackSize
MUIA_Process_Task
MUIA_Prop_DeltaFactor
MUIA_Prop_DoSmooth
MUIA_Prop_Entries |
MUIA_Prop_First |
MUIA_Prop_Horiz |
MUIA_Prop_Slider |
MUIA_Prop_UseWinBorder |
MUIA_Prop_Visible |
MUIA_Radio_Active |
MUIA_Radio_Entries |
MUIA_Rectangle_BarTitle |
MUIA_Rectangle_HBar |
MUIA_Rectangle_VBar |
MUIA_Register_Columns
MUIA_Register_Frame |
MUIA_Register_Titles |
MUIA_Revision |
MUIA_RightEdge |
MUIA_Scale_Horiz |
MUIA_Scrollbar_Type |
MUIA_Scrollbutton_Horiz
MUIA_Scrollbutton_HorizProp
MUIA_Scrollbutton_NewPosition
MUIA_Scrollbutton_Vert
MUIA_Scrollbutton_VertProp
MUIA_Scrollgroup_Contents |
MUIA_Scrollgroup_FreeHoriz |
MUIA_Scrollgroup_FreeVert |
MUIA_Scrollgroup_HorizBar |
MUIA_Scrollgroup_UseWinBorder |
MUIA_Scrollgroup_VertBar |
MUIA_Selected |
MUIA_ShortHelp |
MUIA_ShowMe |
MUIA_ShowSelState |
MUIA_Slider_Horiz |
MUIA_Slider_Quiet |
MUIA_String_Accept |
MUIA_String_Acknowledge |
MUIA_String_AdvanceOnCR |
MUIA_String_AttachedList |
MUIA_String_BufferPos |
MUIA_String_Columns
MUIA_String_Contents |
MUIA_String_DisplayPos |
MUIA_String_EditHook |
MUIA_String_Format |
MUIA_String_Integer |
MUIA_String_KeyDownFocus
MUIA_String_KeyUpFocus
MUIA_String_LonelyEditHook |
MUIA_String_MaxLen |
MUIA_String_NoInput
MUIA_String_Reject |
MUIA_String_Secret |
MUIA_String_SelectSize
MUIA_String_StayActive
MUIA_Text_Contents |
MUIA_Text_HiChar |
MUIA_Text_HiCharIdx
MUIA_Text_PreParse |
MUIA_Text_SetMax |
MUIA_Text_SetMin |
MUIA_Text_SetVMax |
MUIA_Timer |
MUIA_TopEdge |
MUIA_UserData |
MUIA_Version |
MUIA_VertDisappear |
MUIA_VertWeight |
MUIA_Virtgroup_Height |
MUIA_Virtgroup_Input |
MUIA_Virtgroup_Left |
MUIA_Virtgroup_Top |
MUIA_Virtgroup_Width |
MUIA_Weight |
MUIA_Width |
MUIA_Window |
MUIA_WindowObject |
MUIA_Window_Activate |
MUIA_Window_ActiveObject |
MUIA_Window_AltHeight |
MUIA_Window_AltLeftEdge |
MUIA_Window_AltTopEdge |
MUIA_Window_AltWidth |
MUIA_Window_AppWindow |
MUIA_Window_Backdrop |
MUIA_Window_Borderless |
MUIA_Window_CloseGadget |
MUIA_Window_CloseRequest |
MUIA_Window_DefaultObject |
MUIA_Window_DepthGadget |
MUIA_Window_DisableKeys
MUIA_Window_DragBar |
MUIA_Window_EraseArea
MUIA_Window_FancyDrawing |
MUIA_Window_Height |
MUIA_Window_ID |
MUIA_Window_InputEvent |
MUIA_Window_IsSubWindow |
MUIA_Window_LeftEdge |
MUIA_Window_MenuAction |
MUIA_Window_Menustrip |
MUIA_Window_MouseObject |
MUIA_Window_NeedsMouseObject |
MUIA_Window_NoMenus |
MUIA_Window_Open |
MUIA_Window_PublicScreen |
MUIA_Window_RefWindow |
MUIA_Window_RootObject |
MUIA_Window_Screen |
MUIA_Window_ScreenTitle |
MUIA_Window_SizeGadget |
MUIA_Window_SizeRight |
MUIA_Window_Sleep |
MUIA_Window_Title |
MUIA_Window_ToolBox
MUIA_Window_TopEdge |
MUIA_Window_UseBottomBorderScroller |
MUIA_Window_UseLeftBorderScroller |
MUIA_Window_UseRightBorderScroller |
MUIA_Window_Width |
MUIA_Window_Window |
MUIA_Window_ZoomGadget
MUIB_Aboutmui
MUIB_Application
MUIB_Area
MUIB_AROS
MUIB_Balance
MUIB_Bitmap
MUIB_Bodychunk
MUIB_Boopsi
MUIB_ChunkyImage
MUIB_Coloradjust
MUIB_Colorfield
MUIB_Configdata
MUIB_Cycle
MUIB_Dataspace
MUIB_Dirlist
MUIB_Family
MUIB_Floattext
MUIB_Frameadjust
MUIB_Framedisplay
MUIB_Gauge
MUIB_Group
MUIB_Image
MUIB_Imageadjust
MUIB_Imagedisplay
MUIB_List
MUIB_Listview
MUIB_Menu
MUIB_Menuitem
MUIB_Menustrip
MUIB_MUI
MUIB_Notify
MUIB_Numeric
MUIB_Palette
MUIB_Penadjust
MUIB_Pendisplay
MUIB_Pixmap
MUIB_Popasl
MUIB_Popframe
MUIB_Popimage
MUIB_Poplist
MUIB_Popobject
MUIB_Poppen
MUIB_Popscreen
MUIB_Popstring
MUIB_Prop
MUIB_Radio
MUIB_Rectangle
MUIB_Register
MUIB_RSVD
MUIB_Scale
MUIB_Scrmodelist
MUIB_Scrollbar
MUIB_Scrollbutton
MUIB_Scrollgroup
MUIB_Semaphore
MUIB_Settings
MUIB_Settingsgroup
MUIB_Slider
MUIB_String
MUIB_Text
MUIB_Virtgroup
MUIB_Volumelist
MUIB_Window
MUIB_ZUNE
MUICFG_ActiveObject_Color
MUICFG_Background_Button
MUICFG_Background_Framed
MUICFG_Background_List
MUICFG_Background_ListCursor
MUICFG_Background_ListSelCur
MUICFG_Background_ListSelect
MUICFG_Background_Page
MUICFG_Background_PopUp
MUICFG_Background_Prop
MUICFG_Background_ReadList
MUICFG_Background_Register
MUICFG_Background_Requester
MUICFG_Background_Selected
MUICFG_Background_Slider
MUICFG_Background_SliderKnob
MUICFG_Background_Text
MUICFG_Background_Window
MUICFG_Balance_Look
MUICFG_BubbleHelp_FirstDelay
MUICFG_BubbleHelp_NextDelay
MUICFG_CustomFrame_1
MUICFG_CustomFrame_10
MUICFG_CustomFrame_11
MUICFG_CustomFrame_12
MUICFG_CustomFrame_13
MUICFG_CustomFrame_14
MUICFG_CustomFrame_15
MUICFG_CustomFrame_16
MUICFG_CustomFrame_2
MUICFG_CustomFrame_3
MUICFG_CustomFrame_4
MUICFG_CustomFrame_5
MUICFG_CustomFrame_6
MUICFG_CustomFrame_7
MUICFG_CustomFrame_8
MUICFG_CustomFrame_9
MUICFG_Cycle_MenuCtrl_Level
MUICFG_Cycle_MenuCtrl_Position
MUICFG_Cycle_MenuCtrl_Speed
MUICFG_Cycle_Menu_Recessed
MUICFG_Dragndrop_Look
MUICFG_Drag_Autostart
MUICFG_Drag_Autostart_Length
MUICFG_Drag_LeftButton
MUICFG_Drag_LMBModifier
MUICFG_Drag_MiddleButton
MUICFG_Drag_MMBModifier
MUICFG_Font_Big
MUICFG_Font_Button
MUICFG_Font_Fixed
MUICFG_Font_Knob
MUICFG_Font_List
MUICFG_Font_Normal
MUICFG_Font_Tiny
MUICFG_Font_Title
MUICFG_Frame_Button
MUICFG_Frame_Drag
MUICFG_Frame_Gauge
MUICFG_Frame_Group
MUICFG_Frame_ImageButton
MUICFG_Frame_InputList
MUICFG_Frame_Knob
MUICFG_Frame_PopUp
MUICFG_Frame_Prop
MUICFG_Frame_ReadList
MUICFG_Frame_Slider
MUICFG_Frame_String
MUICFG_Frame_Text
MUICFG_Frame_Virtual
MUICFG_GroupTitle_Color
MUICFG_GroupTitle_Position
MUICFG_Group_HSpacing
MUICFG_Group_VSpacing
MUICFG_Iconification_Hotkey
MUICFG_Iconification_OnStartup
MUICFG_Iconification_ShowIcon
MUICFG_Iconification_ShowMenu
MUICFG_Image_ArrowDown
MUICFG_Image_ArrowLeft
MUICFG_Image_ArrowRight
MUICFG_Image_ArrowUp
MUICFG_Image_Assign
MUICFG_Image_CheckMark
MUICFG_Image_Chip
MUICFG_Image_Cycle
MUICFG_Image_Disk
MUICFG_Image_Drawer
MUICFG_Image_HardDisk
MUICFG_Image_Network
MUICFG_Image_PopDrawer
MUICFG_Image_PopFile
MUICFG_Image_PopUp
MUICFG_Image_PropKnob
MUICFG_Image_RadioButton
MUICFG_Image_TapeDown
MUICFG_Image_TapePause
MUICFG_Image_TapePlay
MUICFG_Image_TapePlayBack
MUICFG_Image_TapeRecord
MUICFG_Image_TapeStop
MUICFG_Image_TapeUp
MUICFG_Image_Volume
MUICFG_Interfaces_EnableARexx
MUICFG_Invalid
MUICFG_Keyboard_Bottom
MUICFG_Keyboard_CloseWindow
MUICFG_Keyboard_Down
MUICFG_Keyboard_GadgetOff
MUICFG_Keyboard_Help
MUICFG_Keyboard_Left
MUICFG_Keyboard_LineEnd
MUICFG_Keyboard_LineStart
MUICFG_Keyboard_NextGadget
MUICFG_Keyboard_NextWindow
MUICFG_Keyboard_PageDown
MUICFG_Keyboard_PageUp
MUICFG_Keyboard_Popup
MUICFG_Keyboard_Press
MUICFG_Keyboard_PrevGadget
MUICFG_Keyboard_PrevWindow
MUICFG_Keyboard_Right
MUICFG_Keyboard_Toggle
MUICFG_Keyboard_Top
MUICFG_Keyboard_Up
MUICFG_Keyboard_WordLeft
MUICFG_Keyboard_WordRight
MUICFG_Listview_Font_Leading
MUICFG_Listview_Multi
MUICFG_Listview_Refresh
MUICFG_Listview_Smoothed
MUICFG_Listview_SmoothVal
MUICFG_PublicScreen |
MUICFG_PublicScreen_PopToFront
MUICFG_Radio_HSpacing
MUICFG_Radio_VSpacing
MUICFG_Register_TruncateTitles
MUICFG_Screen_Height
MUICFG_Screen_Mode
MUICFG_Screen_Mode_ID
MUICFG_Screen_Width
MUICFG_Scrollbar_Arrangement
MUICFG_Scrollbar_Type
MUICFG_String_ActiveBackground
MUICFG_String_ActiveText
MUICFG_String_Background
MUICFG_String_Cursor
MUICFG_String_MarkedBackground
MUICFG_String_MarkedText
MUICFG_String_Text
MUICFG_WindowPos
MUICFG_Window_Buttons
MUICFG_Window_Positions
MUICFG_Window_Redraw
MUICFG_Window_Refresh
MUICFG_Window_Spacing_Bottom
MUICFG_Window_Spacing_Left
MUICFG_Window_Spacing_Right
MUICFG_Window_Spacing_Top
MUIC_Aboutmui |
MUIC_Application |
MUIC_Applist |
MUIC_Area | Area class is a super class for every other MUI class except windows and applications.
MUIC_Balance |
MUIC_Bitmap | Include a self-made image data in MUI applications.
MUIC_Bodychunk |
MUIC_Boopsi | MUI's boopsi class provides an interface to standard, system style boopsi gadgets.
MUIC_Cclist |
MUIC_ChunkyImage
MUIC_Coloradjust |
MUIC_Colorfield |
MUIC_Configdata |
MUIC_Crawling
MUIC_Cycle |
MUIC_Dataspace |
MUIC_Dirlist |
MUIC_Dtpic |
MUIC_Family | Family class is the base class for objects that are able to handle a list of children.
MUIC_Floattext |
MUIC_Frameadjust |
MUIC_Framedisplay |
MUIC_Gadget | This is the base class for intuition gadgets in MUI windows.
MUIC_Gauge | A gauge object is a nice looking display element useful for some kind of progress display.
MUIC_Group |
MUIC_Image | Image class is used to display one of MUI's standard images or some selfmade image data.
MUIC_Imageadjust |
MUIC_Imagedisplay |
MUIC_Knob |
MUIC_Levelmeter |
MUIC_List |
MUIC_Listview |
MUIC_Mccprefs |
MUIC_Menu | Objects of menu class describe exactly one pulldown menu.
MUIC_Menuitem |
MUIC_Menustrip | Menustrip class is the base class for MUI's object oriented menus.
MUIC_Notify | Notify class is superclass of all other MUI classes.
MUIC_Numeric |
MUIC_Numericbutton |
MUIC_Palette |
MUIC_Penadjust |
MUIC_Pendisplay |
MUIC_Pixmap
MUIC_Popasl |
MUIC_Popframe |
MUIC_Popimage |
MUIC_Poplist |
MUIC_Popobject |
MUIC_Poppen |
MUIC_Popscreen |
MUIC_Popstring |
MUIC_Process
MUIC_Prop | Prop class generates the well known proportional gadgets.
MUIC_Radio |
MUIC_Rectangle | Empty rectangle for space layout.
MUIC_Register |
MUIC_Scale | A Scale object generates a percentage scale running from 0% to 100%.
MUIC_Scrmodelist |
MUIC_Scrollbar |
MUIC_Scrollbutton
MUIC_Scrollgroup |
MUIC_Semaphore |
MUIC_Settings |
MUIC_Settingsgroup |
MUIC_Slider |
MUIC_String | String class generates standard string gadgets with all editing facilities (clear, undo, etc.) enabled.
MUIC_Text | Text class allows generating objects that contain some kind of text.
MUIC_Title
MUIC_Virtgroup |
MUIC_Volumelist |
MUIC_Window | Objects of window class are used to generate windows and supply a place where MUI gadgets feel well.
MUIE_InvalidWindowObject |
MUIE_MissingLibrary |
MUIE_NoARexx |
MUIE_OK |
MUIE_OutOfGfxMemory |
MUIE_OutOfMemory |
MUIE_SingleTask |
MUIF_DRAGIMAGE_HASMASK
MUIF_DRAGIMAGE_SOURCEALPHA
MUIF_Slave_Delegate_ForceSlave
MUIIHNF_TIMER |
MUIIHNF_TIMER_SCALE10
MUIIHNF_TIMER_SCALE100
MUII_ArrowDown |
MUII_ArrowLeft |
MUII_ArrowRight |
MUII_ArrowUp |
MUII_Assign |
MUII_BACKGROUND |
MUII_ButtonBack |
MUII_CheckMark |
MUII_Chip |
MUII_Close
MUII_Count |
MUII_Cycle |
MUII_Disk |
MUII_Drawer |
MUII_FILL |
MUII_FILLBACK |
MUII_FILLBACK2 |
MUII_FILLSHINE |
MUII_GaugeEmpty
MUII_GaugeFull
MUII_GroupBack |
MUII_GroupTitle
MUII_HardDisk |
MUII_HSHADOWBACK |
MUII_HSHADOWSHADOW |
MUII_HSHINEBACK |
MUII_HSHINESHINE |
MUII_ImageButtonBack
MUII_ImageSelectedBack
MUII_LASTPAT |
MUII_ListBack |
MUII_ListCursor |
MUII_ListSelCur |
MUII_ListSelect |
MUII_ListTitle
MUII_MARKBACKGROUND |
MUII_MARKHALFSHINE |
MUII_MARKSHINE |
MUII_Menudisplay
MUII_Network |
MUII_PageBack |
MUII_PopDrawer |
MUII_PopFile |
MUII_PopFont
MUII_PopUp |
MUII_PopupBack |
MUII_PropBack |
MUII_PropKnob |
MUII_PullOpen
MUII_RadioButton |
MUII_ReadListBack |
MUII_RegisterBack |
MUII_RegisterTitle
MUII_RequesterBack |
MUII_SelectedBack |
MUII_SHADOW |
MUII_SHADOWBACK |
MUII_SHADOWFILL |
MUII_SHADOWSHINE |
MUII_SHINE |
MUII_SHINEBACK |
MUII_SliderBack |
MUII_SliderKnob |
MUII_StringActiveBack
MUII_StringBack
MUII_TapeDown |
MUII_TapePause |
MUII_TapePlay |
MUII_TapePlayBack |
MUII_TapeRecord |
MUII_TapeStop |
MUII_TapeUp |
MUII_TextBack |
MUII_Volume |
MUII_WindowBack |
MUIKEYF_BOTTOM |
MUIKEYF_DOWN |
MUIKEYF_GADGET_NEXT |
MUIKEYF_GADGET_OFF |
MUIKEYF_GADGET_PREV |
MUIKEYF_HELP |
MUIKEYF_LEFT |
MUIKEYF_LINEEND |
MUIKEYF_LINESTART |
MUIKEYF_PAGEDOWN |
MUIKEYF_PAGEUP |
MUIKEYF_POPUP |
MUIKEYF_PRESS |
MUIKEYF_RIGHT |
MUIKEYF_TOGGLE |
MUIKEYF_TOP |
MUIKEYF_UP |
MUIKEYF_WINDOW_CLOSE |
MUIKEYF_WINDOW_NEXT |
MUIKEYF_WINDOW_PREV |
MUIKEYF_WORDLEFT |
MUIKEYF_WORDRIGHT |
MUIKEY_BOTTOM |
MUIKEY_COUNT |
MUIKEY_DOWN |
MUIKEY_GADGET_NEXT |
MUIKEY_GADGET_OFF |
MUIKEY_GADGET_PREV |
MUIKEY_HELP |
MUIKEY_LEFT |
MUIKEY_LINEEND |
MUIKEY_LINESTART |
MUIKEY_NONE |
MUIKEY_PAGEDOWN |
MUIKEY_PAGEUP |
MUIKEY_POPUP |
MUIKEY_PRESS |
MUIKEY_RELEASE |
MUIKEY_RIGHT |
MUIKEY_TOGGLE |
MUIKEY_TOP |
MUIKEY_UP |
MUIKEY_WINDOW_CLOSE |
MUIKEY_WINDOW_NEXT |
MUIKEY_WINDOW_PREV |
MUIKEY_WORDLEFT |
MUIKEY_WORDRIGHT |
MUILM_LAYOUT |
MUILM_MINMAX |
MUILM_UNKNOWN |
MUIMASTER_NAME |
MUIMASTER_VLATEST |
MUIMASTER_VMIN |
MUIMRI_RECTFILL |
MUIMRI_REFRESHMODE |
MUIMRI_THINFRAMES |
MUIMRI_TRUECOLOR |
MUIM_Application_AboutMUI |
MUIM_Application_AddInputHandler |
MUIM_Application_CheckRefresh |
MUIM_Application_Execute
MUIM_Application_GetMenuCheck
MUIM_Application_GetMenuState
MUIM_Application_Iconify
MUIM_Application_Input
MUIM_Application_InputBuffered |
MUIM_Application_Load |
MUIM_Application_NewInput |
MUIM_Application_OpenConfigWindow |
MUIM_Application_OpenWindows
MUIM_Application_PushMethod |
MUIM_Application_RemInputHandler |
MUIM_Application_ReturnID |
MUIM_Application_Save |
MUIM_Application_SetConfigdata
MUIM_Application_SetConfigItem |
MUIM_Application_SetMenuCheck
MUIM_Application_SetMenuState
MUIM_Application_ShowHelp |
MUIM_Application_UnpushMethod
MUIM_Application_UpdateMenus
MUIM_AskMinMax |
MUIM_BoopsiQuery |
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Cleanup |
MUIM_Configdata_GetString
MUIM_Configdata_GetULong
MUIM_Configdata_GetWindowPos
MUIM_Configdata_Load
MUIM_Configdata_Save
MUIM_Configdata_SetFont
MUIM_Configdata_SetFramespec
MUIM_Configdata_SetImspec
MUIM_Configdata_SetPenspec
MUIM_Configdata_SetString
MUIM_Configdata_SetULong
MUIM_Configdata_SetWindowPos
MUIM_ConnectParent
MUIM_ContextMenuBuild |
MUIM_ContextMenuChoice |
MUIM_CreateBubble |
MUIM_CreateDragImage
MUIM_CreateShortHelp |
MUIM_CustomBackfill
MUIM_Dataspace_Add |
MUIM_Dataspace_Clear |
MUIM_Dataspace_Find |
MUIM_Dataspace_Merge |
MUIM_Dataspace_ReadIFF |
MUIM_Dataspace_Remove |
MUIM_Dataspace_WriteIFF |
MUIM_DeleteBubble |
MUIM_DeleteDragImage
MUIM_DeleteShortHelp |
MUIM_Dirlist_ReRead |
MUIM_DisconnectParent
MUIM_DoDrag
MUIM_DragBegin |
MUIM_DragDrop |
MUIM_DragFinish |
MUIM_DragQuery |
MUIM_DragReport |
MUIM_Draw |
MUIM_DrawBackground |
MUIM_DrawParentBackground
MUIM_Export | Called on export object to dataspace
MUIM_Family_AddHead |
MUIM_Family_AddTail |
MUIM_Family_DoChildMethods
MUIM_Family_GetChild
MUIM_Family_Insert |
MUIM_Family_Remove |
MUIM_Family_Sort |
MUIM_Family_Transfer |
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_Floattext_Append
MUIM_GetConfigItem |
MUIM_GetUData |
MUIM_GoActive
MUIM_GoInactive
MUIM_Group_AddHead
MUIM_Group_AddTail
MUIM_Group_DoMethodNoForward
MUIM_Group_ExitChange |
MUIM_Group_InitChange |
MUIM_Group_Remove
MUIM_Group_Sort |
MUIM_HandleEvent |
MUIM_HandleInput |
MUIM_Hide |
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_Layout
MUIM_List_Clear |
MUIM_List_Compare
MUIM_List_Construct
MUIM_List_CreateImage |
MUIM_List_DeleteImage |
MUIM_List_Exchange |
MUIM_List_GetEntry |
MUIM_List_Insert |
MUIM_List_InsertSingle |
MUIM_List_Jump |
MUIM_List_Move |
MUIM_List_NextSelected |
MUIM_List_Redraw |
MUIM_List_Remove |
MUIM_List_Select |
MUIM_List_Sort |
MUIM_List_TestPos |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Set but doesn't trigger any notification.
MUIM_Notify | Add a notification event handler to an object
MUIM_Numeric_Decrease |
MUIM_Numeric_Increase |
MUIM_Numeric_ScaleToValue |
MUIM_Numeric_SetDefault |
MUIM_Numeric_Stringify |
MUIM_Numeric_ValueToScale |
MUIM_Numeric_ValueToScaleExt
MUIM_Pendisplay_SetColormap |
MUIM_Pendisplay_SetMUIPen |
MUIM_Pendisplay_SetRGB |
MUIM_Pixmap_DrawSection
MUIM_Popstring_Close |
MUIM_Popstring_Open |
MUIM_Process_Kill
MUIM_Process_Launch
MUIM_Process_Process
MUIM_Process_Signal
MUIM_Prop_Decrease |
MUIM_Prop_Increase |
MUIM_Semaphore_Attempt |
MUIM_Semaphore_AttemptShared |
MUIM_Semaphore_Obtain |
MUIM_Semaphore_ObtainShared |
MUIM_Semaphore_Release |
MUIM_Set | Set an attribute to a value.
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_Settingsgroup_ConfigToGadgets |
MUIM_Settingsgroup_GadgetsToConfig |
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_Setup |
MUIM_Show |
MUIM_String_ClearSelected
MUIM_String_FileNameStart
MUIM_String_Insert
MUIM_UnknownDropDestination
MUIM_Window_ActionIconify
MUIM_Window_AddEventHandler |
MUIM_Window_AllocGadgetID
MUIM_Window_Cleanup
MUIM_Window_FreeGadgetID
MUIM_Window_RemEventHandler |
MUIM_Window_ScreenToBack |
MUIM_Window_ScreenToFront |
MUIM_Window_Setup
MUIM_Window_Snapshot |
MUIM_Window_ToBack |
MUIM_Window_ToFront |
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.
MUIO_BarTitle |
MUIO_Button |
MUIO_Checkmark |
MUIO_Cycle |
MUIO_HBar |
MUIO_HSpace |
MUIO_Label |
MUIO_Label_Centered |
MUIO_Label_DontCopy
MUIO_Label_DoubleFrame |
MUIO_Label_FreeVert |
MUIO_Label_LeftAligned |
MUIO_Label_SingleFrame |
MUIO_Label_Tiny
MUIO_Menuitem |
MUIO_Menuitem_CopyStrings |
MUIO_MenustripNM |
MUIO_MenustripNM_CommandKeyCheck |
MUIO_NumericButton |
MUIO_PopButton |
MUIO_Radio |
MUIO_Slider |
MUIO_String |
MUIO_VBar |
MUIO_VSpace |
MUIPEN_MASK |
MUIR_String_FileNameStart_Volume
MUIV_Application_Load_ENV
MUIV_Application_Load_ENVARC
MUIV_Application_OCW_ScreenPage
MUIV_Application_Package_NetConnect |
MUIV_Application_ReturnID_Quit |
MUIV_Application_Save_ENV
MUIV_Application_Save_ENVARC
MUIV_ContextMenuBuild_Default
MUIV_CreateBubble_DontHidePointer
MUIV_Cycle_Active_Next |
MUIV_Cycle_Active_Prev |
MUIV_Dirlist_SortDirs_First |
MUIV_Dirlist_SortDirs_Last |
MUIV_Dirlist_SortDirs_Mix |
MUIV_Dirlist_SortType_Date |
MUIV_Dirlist_SortType_Name |
MUIV_Dirlist_SortType_Size |
MUIV_Dirlist_Status_Invalid |
MUIV_Dirlist_Status_Reading |
MUIV_Dirlist_Status_Valid |
MUIV_DragQuery_Accept |
MUIV_DragQuery_Refuse |
MUIV_DragReport_Abort |
MUIV_DragReport_Continue |
MUIV_DragReport_Lock |
MUIV_DragReport_Refresh |
MUIV_EveryTime |
MUIV_Family_GetChild_First
MUIV_Family_GetChild_Iterate
MUIV_Family_GetChild_Last
MUIV_Family_GetChild_Next
MUIV_Family_GetChild_Previous
MUIV_Font_Big |
MUIV_Font_Button |
MUIV_Font_Fixed |
MUIV_Font_Inherit |
MUIV_Font_Knob
MUIV_Font_List |
MUIV_Font_NegCount
MUIV_Font_Normal |
MUIV_Font_Tiny |
MUIV_Font_Title |
MUIV_Frame_Button |
MUIV_Frame_Count |
MUIV_Frame_Drag
MUIV_Frame_Gauge |
MUIV_Frame_Group |
MUIV_Frame_ImageButton |
MUIV_Frame_InputList |
MUIV_Frame_Knob
MUIV_Frame_None |
MUIV_Frame_PopUp |
MUIV_Frame_Prop |
MUIV_Frame_ReadList |
MUIV_Frame_Register
MUIV_Frame_Slider |
MUIV_Frame_String |
MUIV_Frame_Text |
MUIV_Frame_Virtual |
MUIV_Group_ActivePage_Advance |
MUIV_Group_ActivePage_First |
MUIV_Group_ActivePage_Last |
MUIV_Group_ActivePage_Next |
MUIV_Group_ActivePage_Prev |
MUIV_Group_GetChild_First
MUIV_Group_GetChild_Iterate
MUIV_Group_GetChild_Last
MUIV_Group_GetChild_Next
MUIV_Group_GetChild_Previous
MUIV_Imageadjust_Type_All |
MUIV_Imageadjust_Type_Background |
MUIV_Imageadjust_Type_Image |
MUIV_Imageadjust_Type_Pen |
MUIV_InputMode_Immediate |
MUIV_InputMode_None |
MUIV_InputMode_RelVerify |
MUIV_InputMode_Toggle |
MUIV_Listview_DragType_Immediate |
MUIV_Listview_DragType_None |
MUIV_Listview_MultiSelect_Always |
MUIV_Listview_MultiSelect_Default |
MUIV_Listview_MultiSelect_None |
MUIV_Listview_MultiSelect_Shifted |
MUIV_Listview_ScrollerPos_Default |
MUIV_Listview_ScrollerPos_Left |
MUIV_Listview_ScrollerPos_None |
MUIV_Listview_ScrollerPos_Right |
MUIV_List_Active_Bottom |
MUIV_List_Active_Down |
MUIV_List_Active_Off |
MUIV_List_Active_PageDown |
MUIV_List_Active_PageUp |
MUIV_List_Active_Top |
MUIV_List_Active_Up |
MUIV_List_ConstructHook_String |
MUIV_List_CopyHook_String |
MUIV_List_CursorType_Bar |
MUIV_List_CursorType_None |
MUIV_List_CursorType_Rect |
MUIV_List_DestructHook_String |
MUIV_List_EditEntry_Active
MUIV_List_Exchange_Active |
MUIV_List_Exchange_Bottom |
MUIV_List_Exchange_Next |
MUIV_List_Exchange_Previous |
MUIV_List_Exchange_Top |
MUIV_List_GetEntry_Active |
MUIV_List_Insert_Active |
MUIV_List_Insert_Bottom |
MUIV_List_Insert_Sorted |
MUIV_List_Insert_Top |
MUIV_List_Jump_Active |
MUIV_List_Jump_Bottom |
MUIV_List_Jump_Down |
MUIV_List_Jump_Top |
MUIV_List_Jump_Up |
MUIV_List_Move_Active |
MUIV_List_Move_Bottom |
MUIV_List_Move_Next |
MUIV_List_Move_Previous |
MUIV_List_Move_Top |
MUIV_List_NextSelected_End |
MUIV_List_NextSelected_Start |
MUIV_List_Redraw_Active |
MUIV_List_Redraw_All |
MUIV_List_Redraw_Entry
MUIV_List_Remove_Active |
MUIV_List_Remove_First |
MUIV_List_Remove_Last |
MUIV_List_Remove_Selected |
MUIV_List_Select_Active |
MUIV_List_Select_All |
MUIV_List_Select_Ask |
MUIV_List_Select_Off |
MUIV_List_Select_On |
MUIV_List_Select_Toggle |
MUIV_Menuitem_Shortcut_Check |
MUIV_NList_SelectChange_Flag_Multi
MUIV_Notify_Application |
MUIV_Notify_Parent |
MUIV_Notify_ParentParent
MUIV_Notify_ParentParentParent
MUIV_Notify_Self |
MUIV_Notify_Window |
MUIV_NotTriggerValue |
MUIV_Palette_Entry_End |
MUIV_Pixmap_Compression_BZip2
MUIV_Pixmap_Compression_None
MUIV_Pixmap_Compression_RLE
MUIV_Pixmap_Format_ARGB32
MUIV_Pixmap_Format_CLUT8
MUIV_Pixmap_Format_RGB24
MUIV_Prop_UseWinBorder_Bottom |
MUIV_Prop_UseWinBorder_Left |
MUIV_Prop_UseWinBorder_None |
MUIV_Prop_UseWinBorder_Right |
MUIV_Scrollbar_Type_Bottom |
MUIV_Scrollbar_Type_Default |
MUIV_Scrollbar_Type_Sym |
MUIV_Scrollbar_Type_Top |
MUIV_String_BufferPos_End
MUIV_String_Format_Center |
MUIV_String_Format_Left |
MUIV_String_Format_Right |
MUIV_String_Insert_BufferPos
MUIV_String_Insert_EndOfString
MUIV_String_Insert_StartOfString
MUIV_TriggerValue |
MUIV_Window_ActiveObject_Next |
MUIV_Window_ActiveObject_None |
MUIV_Window_ActiveObject_Prev |
MUIV_Window_AltHeight_Scaled |
MUIV_Window_AltLeftEdge_Centered |
MUIV_Window_AltLeftEdge_Moused |
MUIV_Window_AltLeftEdge_NoChange |
MUIV_Window_AltTopEdge_Centered |
MUIV_Window_AltTopEdge_Moused |
MUIV_Window_AltTopEdge_NoChange |
MUIV_Window_AltWidth_Scaled |
MUIV_Window_Button_Iconify
MUIV_Window_Button_MUI
MUIV_Window_Button_Popup
MUIV_Window_Button_Snapshot
MUIV_Window_Height_Default |
MUIV_Window_Height_Scaled |
MUIV_Window_LeftEdge_Centered |
MUIV_Window_LeftEdge_Moused |
MUIV_Window_TopEdge_Centered |
MUIV_Window_TopEdge_Moused |
MUIV_Window_Width_Default |
MUIV_Window_Width_Scaled |
MUIX_B |
MUIX_C |
MUIX_I |
MUIX_L |
MUIX_N |
MUIX_PH |
MUIX_PT |
MUIX_R |
MUIX_U |
MUI_EHF_ALWAYSKEYS |
MUI_EHF_GUIMODE
MUI_EHF_ISACTIVE
MUI_EHF_ISACTIVEGRP
MUI_EHF_ISCALLING
MUI_EHF_ISENABLED
MUI_EventHandlerRC_Eat |
MUI_LPR_ABOVE |
MUI_LPR_BELOW |
MUI_LPR_LEFT |
MUI_LPR_RIGHT |
MUI_MAXMAX |
MUI_RXERR_BADDEFINITION |
MUI_RXERR_BADSYNTAX |
MUI_RXERR_OUTOFMEMORY |
MUI_RXERR_UNKNOWNCOMMAND |
PSD_FILENAME_SAVE |
PSD_FILENAME_USE |
PSD_INITIAL_NAME |
PSD_INITIAL_TITLE |
PSD_MAXLEN_BACKGROUND |
PSD_MAXLEN_FONT |
PSD_MAXLEN_NAME |
PSD_MAXLEN_TITLE |
PSD_MAXMUIPENS |
PSD_MAXSYSPENS |
PSD_NAME_FRONTMOST |
PSD_NUMCOLS |
PSD_NUMMUIPENS |
PSD_NUMSYSPENS |
PST_CMAP
PST_MUI
PST_RGB
PST_SYS


Reference for unit 'mui': Types

MUIP_BoopsiQuery

Pdt_frame_image

PMUIP_Application_AboutMUI

PMUIP_Application_AddInputHandler

PMUIP_Application_CheckRefresh

PMUIP_Application_GetMenuCheck

PMUIP_Application_GetMenuState

PMUIP_Application_Input

PMUIP_Application_InputBuffered

PMUIP_Application_Load

PMUIP_Application_NewInput

PMUIP_Application_OpenConfigWindow

PMUIP_Application_PushMethod

PMUIP_Application_RemInputHandler

PMUIP_Application_ReturnID

PMUIP_Application_SetConfigItem

PMUIP_Application_SetMenuCheck

PMUIP_Application_SetMenuState

PMUIP_Application_ShowHelp

PMUIP_Application_UnpushMethod

PMUIP_AskMinMax

PMUIP_CallHook

PMUIP_Cleanup

PMUIP_Configdata_GetString

PMUIP_Configdata_GetULong

PMUIP_Configdata_Load

PMUIP_Configdata_Save

PMUIP_Configdata_SetFont

PMUIP_Configdata_SetFramespec

PMUIP_Configdata_SetImspec

PMUIP_Configdata_SetPenspec

PMUIP_Configdata_SetString

PMUIP_Configdata_SetULong

PMUIP_ConnectParent

PMUIP_ContextMenuBuild

PMUIP_ContextMenuChoice

PMUIP_CreateBubble

PMUIP_CreateDragImage

PMUIP_CreateShortHelp

PMUIP_CustomBackfill

PMUIP_Dataspace_Add

PMUIP_Dataspace_Clear

PMUIP_Dataspace_Find

PMUIP_Dataspace_Merge

PMUIP_Dataspace_ReadIFF

PMUIP_Dataspace_Remove

PMUIP_Dataspace_WriteIFF

PMUIP_DeleteBubble

PMUIP_DeleteDragImage

PMUIP_DeleteShortHelp

PMUIP_DisconnectParent

PMUIP_DoDrag

PMUIP_DragBegin

PMUIP_DragDrop

PMUIP_DragFinish

PMUIP_DragQuery

PMUIP_DragReport

PMUIP_Draw

PMUIP_DrawBackground

PMUIP_DrawBackgroundBuffered

PMUIP_DrawParentBackground

PMUIP_Export

PMUIP_Family_AddHead

PMUIP_Family_AddTail

PMUIP_Family_GetChild

PMUIP_Family_Insert

PMUIP_Family_Remove

PMUIP_Family_Sort

PMUIP_Family_Transfer

PMUIP_FindUData

PMUIP_Floattext_Append

PMUIP_GetConfigItem

PMUIP_GetUData

PMUIP_GoActive

PMUIP_GoInactive

PMUIP_Group_AddHead

PMUIP_Group_AddTail

PMUIP_Group_DoMethodNoForward

PMUIP_Group_ExitChange

PMUIP_Group_InitChange

PMUIP_Group_Remove

PMUIP_Group_Sort

PMUIP_HandleEvent

PMUIP_HandleInput

PMUIP_Hide

PMUIP_Import

PMUIP_KillNotify

PMUIP_KillNotifyObj

PMUIP_Layout

PMUIP_List_Clear

PMUIP_List_Compare

PMUIP_List_Construct

PMUIP_List_CreateImage

PMUIP_List_DeleteImage

PMUIP_List_Exchange

PMUIP_List_GetEntry

PMUIP_List_Insert

PMUIP_List_InsertSingle

PMUIP_List_Jump

PMUIP_List_Move

PMUIP_List_NextSelected

PMUIP_List_Redraw

PMUIP_List_Remove

PMUIP_List_Select

PMUIP_List_Sort

PMUIP_List_TestPos

PMUIP_MultiSet

PMUIP_NoNotifySet

PMUIP_Notify

PMUIP_Numeric_Decrease

PMUIP_Numeric_Increase

PMUIP_Numeric_ScaleToValue

PMUIP_Numeric_SetDefault

PMUIP_Numeric_Stringify

PMUIP_Numeric_ValueToScale

PMUIP_Numeric_ValueToScaleExt

PMUIP_Pendisplay_SetColormap

PMUIP_Pendisplay_SetMUIPen

PMUIP_Pendisplay_SetRGB

PMUIP_Popstring_Close

PMUIP_Popstring_Open

PMUIP_Prop_Decrease

PMUIP_Prop_Increase

PMUIP_Semaphore_Attempt

PMUIP_Semaphore_AttemptShared

PMUIP_Semaphore_Obtain

PMUIP_Semaphore_ObtainShared

PMUIP_Semaphore_Release

PMUIP_Set

PMUIP_SetAsString

PMUIP_Settingsgroup_ConfigToGadgets

PMUIP_Settingsgroup_GadgetsToConfig

PMUIP_SetUData

PMUIP_SetUDataOnce

PMUIP_Setup

PMUIP_Show

PMUIP_String_ClearSelected

PMUIP_UnknownDropDestination

PMUIP_Window_ActionIconify

PMUIP_Window_AddControlCharHandler

PMUIP_Window_AddEventHandler

PMUIP_Window_AllocGadgetID

PMUIP_Window_Cleanup

PMUIP_Window_DragObject

PMUIP_Window_DrawBackground

PMUIP_Window_FreeGadgetID

PMUIP_Window_RecalcDisplay

PMUIP_Window_RemControlCharHandler

PMUIP_Window_RemEventHandler

PMUIP_Window_ScreenToBack

PMUIP_Window_ScreenToFront

PMUIP_Window_Setup

PMUIP_Window_Snapshot

PMUIP_Window_ToBack

PMUIP_Window_ToFront

PMUIP_WriteLong

PMUIP_WriteString

PMUIS_InfoClient

PMUI_AreaData

PMUI_BoopsiQuery

PMUI_Command

PMUI_CustomClass

PMUI_DragImage

PMUI_EventHandlerNode

PMUI_FrameSpec

PMUI_GlobalInfo

PMUI_ImageSpec_intern

PMUI_InputHandlerNode

PMUI_LayoutMsg

PMUI_List_TestPos_Result

PMUI_MinMax

PMUI_NotifyData

PMUI_Palette_Entry

PMUI_PenSpec

PMUI_PubScreenDesc

PMUI_RenderInfo

PMUI_RGBColor

P__dummyAreaData__

Tdt_frame_image

TMUIP_Application_AboutMUI

TMUIP_Application_AddInputHandler

TMUIP_Application_CheckRefresh

TMUIP_Application_GetMenuCheck

TMUIP_Application_GetMenuState

TMUIP_Application_Input

TMUIP_Application_InputBuffered

TMUIP_Application_Load

TMUIP_Application_NewInput

TMUIP_Application_OpenConfigWindow

TMUIP_Application_PushMethod

TMUIP_Application_RemInputHandler

TMUIP_Application_ReturnID

TMUIP_Application_Save

TMUIP_Application_SetConfigItem

TMUIP_Application_SetMenuCheck

TMUIP_Application_SetMenuState

TMUIP_Application_ShowHelp

TMUIP_Application_UnpushMethod

TMUIP_AskMinMax

TMUIP_CallHook

TMUIP_Cleanup

TMUIP_Configdata_GetString

TMUIP_Configdata_GetULong

TMUIP_Configdata_Load

TMUIP_Configdata_Save

TMUIP_Configdata_SetFont

TMUIP_Configdata_SetFramespec

TMUIP_Configdata_SetImspec

TMUIP_Configdata_SetPenspec

TMUIP_Configdata_SetString

TMUIP_Configdata_SetULong

TMUIP_ConnectParent

TMUIP_ContextMenuBuild

TMUIP_ContextMenuChoice

TMUIP_CreateBubble

TMUIP_CreateDragImage

TMUIP_CreateShortHelp

TMUIP_CustomBackfill

TMUIP_Dataspace_Add

TMUIP_Dataspace_Clear

TMUIP_Dataspace_Find

TMUIP_Dataspace_Merge

TMUIP_Dataspace_ReadIFF

TMUIP_Dataspace_Remove

TMUIP_Dataspace_WriteIFF

TMUIP_DeleteBubble

TMUIP_DeleteDragImage

TMUIP_DeleteShortHelp

TMUIP_Dirlist_ReRead

TMUIP_DisconnectParent

TMUIP_DoDrag

TMUIP_DragBegin

TMUIP_DragDrop

TMUIP_DragFinish

TMUIP_DragQuery

TMUIP_DragReport

TMUIP_Draw

TMUIP_DrawBackground

TMUIP_DrawBackgroundBuffered

TMUIP_DrawParentBackground

TMUIP_Export

TMUIP_Family_AddHead

TMUIP_Family_AddTail

TMUIP_Family_GetChild

TMUIP_Family_Insert

TMUIP_Family_Remove

TMUIP_Family_Sort

TMUIP_Family_Transfer

TMUIP_FindUData

TMUIP_Floattext_Append

TMUIP_GetConfigItem

TMUIP_GetUData

TMUIP_GoActive

TMUIP_GoInactive

TMUIP_Group_AddHead

TMUIP_Group_AddTail

TMUIP_Group_DoMethodNoForward

TMUIP_Group_ExitChange

TMUIP_Group_InitChange

TMUIP_Group_Remove

TMUIP_Group_Sort

TMUIP_HandleEvent

TMUIP_HandleInput

TMUIP_Hide

TMUIP_Import

TMUIP_KillNotify

TMUIP_KillNotifyObj

TMUIP_Layout

TMUIP_List_Clear

TMUIP_List_Compare

TMUIP_List_Construct

TMUIP_List_CreateImage

TMUIP_List_DeleteImage

TMUIP_List_Exchange

TMUIP_List_GetEntry

TMUIP_List_Insert

TMUIP_List_InsertSingle

TMUIP_List_Jump

TMUIP_List_Move

TMUIP_List_NextSelected

TMUIP_List_Redraw

TMUIP_List_Remove

TMUIP_List_Select

TMUIP_List_Sort

TMUIP_List_TestPos

TMUIP_MultiSet

TMUIP_NoNotifySet

TMUIP_Notify

TMUIP_Numeric_Decrease

TMUIP_Numeric_Increase

TMUIP_Numeric_ScaleToValue

TMUIP_Numeric_SetDefault

TMUIP_Numeric_Stringify

TMUIP_Numeric_ValueToScale

TMUIP_Numeric_ValueToScaleExt

TMUIP_Pendisplay_SetColormap

TMUIP_Pendisplay_SetMUIPen

TMUIP_Pendisplay_SetRGB

TMUIP_Pixmap_DrawSection

TMUIP_Popstring_Close

TMUIP_Popstring_Open

TMUIP_Process_Kill

TMUIP_Process_Launch

TMUIP_Process_Process

TMUIP_Process_Signal

TMUIP_Prop_Decrease

TMUIP_Prop_Increase

TMUIP_Semaphore_Attempt

TMUIP_Semaphore_AttemptShared

TMUIP_Semaphore_Obtain

TMUIP_Semaphore_ObtainShared

TMUIP_Semaphore_Release

TMUIP_Set

TMUIP_SetAsString

TMUIP_Settingsgroup_ConfigToGadgets

TMUIP_Settingsgroup_GadgetsToConfig

TMUIP_SetUData

TMUIP_SetUDataOnce

TMUIP_Setup

TMUIP_Show

TMUIP_String_ClearSelected

TMUIP_String_FileNameStart

TMUIP_String_Insert

TMUIP_UnknownDropDestination

TMUIP_Window_ActionIconify

TMUIP_Window_AddControlCharHandler

TMUIP_Window_AddEventHandler

TMUIP_Window_AllocGadgetID

TMUIP_Window_Cleanup

TMUIP_Window_DragObject

TMUIP_Window_DrawBackground

TMUIP_Window_FreeGadgetID

TMUIP_Window_RecalcDisplay

TMUIP_Window_RemControlCharHandler

TMUIP_Window_RemEventHandler

TMUIP_Window_ScreenToBack

TMUIP_Window_ScreenToFront

TMUIP_Window_Setup

TMUIP_Window_Snapshot

TMUIP_Window_ToBack

TMUIP_Window_ToFront

TMUIP_Window_UpdateMenu

TMUIP_WriteLong

TMUIP_WriteString

TMUIS_InfoClient

TMUI_AreaData

TMUI_BoopsiQuery

TMUI_Command

TMUI_CustomClass

TMUI_DragImage

TMUI_EventHandlerNode

TMUI_FrameSpec

TMUI_GlobalInfo

TMUI_ImageSpec_intern

TMUI_InputHandlerNode

TMUI_LayoutMsg

TMUI_List_TestPos_Result

TMUI_MinMax

TMUI_NotifyData

TMUI_Palette_Entry

TMUI_PenSpec

TMUI_PubScreenDesc

TMUI_RenderInfo

TMUI_RGBcolor

TWindowPos

T__dummyAreaData__


MADF_DRAWALL

Declaration

Source position: mui.pas line 1725

const MADF_DRAWALL = 1 shl 31;


MADF_DRAWOBJECT

Declaration

Source position: mui.pas line 1723

const MADF_DRAWOBJECT = 1 shl 0;


MADF_DRAWUPDATE

Declaration

Source position: mui.pas line 1724

const MADF_DRAWUPDATE = 1 shl 1;


MAXWINS

Declaration

Source position: mui.pas line 1076

const MAXWINS = 300;


MBQ_MUI_MAXMAX

Declaration

Source position: mui.pas line 598

const MBQ_MUI_MAXMAX = 10000;


MBQF_HORIZ

Declaration

Source position: mui.pas line 597

const MBQF_HORIZ = 1 shl 0;


MC_TEMPLATE_ID

Declaration

Source position: mui.pas line 272

const MC_TEMPLATE_ID = - 1;


MPEN_BACKGROUND

Declaration

Source position: mui.pas line 435

const MPEN_BACKGROUND = 2;


MPEN_COUNT

Declaration

Source position: mui.pas line 441

const MPEN_COUNT = 8;


MPEN_FILL

Declaration

Source position: mui.pas line 439

const MPEN_FILL = 6;


MPEN_HALFSHADOW

Declaration

Source position: mui.pas line 436

const MPEN_HALFSHADOW = 3;


MPEN_HALFSHINE

Declaration

Source position: mui.pas line 434

const MPEN_HALFSHINE = 1;


MPEN_MARK

Declaration

Source position: mui.pas line 440

const MPEN_MARK = 7;


MPEN_SHADOW

Declaration

Source position: mui.pas line 437

const MPEN_SHADOW = 4;


MPEN_SHINE

Declaration

Source position: mui.pas line 433

const MPEN_SHINE = 0;


MPEN_TEXT

Declaration

Source position: mui.pas line 438

const MPEN_TEXT = 5;


MRI_RARRAY_SIZE

Declaration

Source position: mui.pas line 521

const MRI_RARRAY_SIZE = 20;


MUI_EHF_ALWAYSKEYS

Declaration

Source position: mui.pas line 420

const MUI_EHF_ALWAYSKEYS = 1 shl 0;


MUI_EHF_GUIMODE

Declaration

Source position: mui.pas line 421

const MUI_EHF_GUIMODE = 1 shl 1;


MUI_EHF_ISACTIVE

Declaration

Source position: mui.pas line 424

const MUI_EHF_ISACTIVE = 1 shl 13;


MUI_EHF_ISACTIVEGRP

Declaration

Source position: mui.pas line 423

const MUI_EHF_ISACTIVEGRP = 1 shl 12;


MUI_EHF_ISCALLING

Declaration

Source position: mui.pas line 425

const MUI_EHF_ISCALLING = 1 shl 14;


MUI_EHF_ISENABLED

Declaration

Source position: mui.pas line 426

const MUI_EHF_ISENABLED = 1 shl 15;


MUI_EventHandlerRC_Eat

Declaration

Source position: mui.pas line 430

const MUI_EventHandlerRC_Eat = 1 shl 0;


MUI_LPR_ABOVE

Declaration

Source position: mui.pas line 469

const MUI_LPR_ABOVE = 1 shl 0;


MUI_LPR_BELOW

Declaration

Source position: mui.pas line 470

const MUI_LPR_BELOW = 1 shl 1;


MUI_LPR_LEFT

Declaration

Source position: mui.pas line 471

const MUI_LPR_LEFT = 1 shl 2;


MUI_LPR_RIGHT

Declaration

Source position: mui.pas line 472

const MUI_LPR_RIGHT = 1 shl 3;


MUI_MAXMAX

Declaration

Source position: mui.pas line 3607

const MUI_MAXMAX = 10000;


MUI_RXERR_BADDEFINITION

Declaration

Source position: mui.pas line 273

const MUI_RXERR_BADDEFINITION = - 1;


MUI_RXERR_BADSYNTAX

Declaration

Source position: mui.pas line 276

const MUI_RXERR_BADSYNTAX = - 4;


MUI_RXERR_OUTOFMEMORY

Declaration

Source position: mui.pas line 274

const MUI_RXERR_OUTOFMEMORY = - 2;


MUI_RXERR_UNKNOWNCOMMAND

Declaration

Source position: mui.pas line 275

const MUI_RXERR_UNKNOWNCOMMAND = - 3;


MUIA_Aboutmui_Application

Declaration

Source position: mui.pas line 2903

const MUIA_Aboutmui_Application = MUIB_MUI or $422523;


MUIA_Application_Active

Declaration

Source position: mui.pas line 1024

const MUIA_Application_Active = MUIB_MUI or $4260ab;


MUIA_Application_Author

Declaration

Source position: mui.pas line 1025

const MUIA_Application_Author = MUIB_MUI or $424842;


MUIA_Application_Base

Declaration

Source position: mui.pas line 1026

const MUIA_Application_Base = MUIB_MUI or $42e07a;


MUIA_Application_Broker

Declaration

Source position: mui.pas line 1027

const MUIA_Application_Broker = MUIB_MUI or $42dbce;


MUIA_Application_BrokerHook

Declaration

Source position: mui.pas line 1028

const MUIA_Application_BrokerHook = MUIB_MUI or $428f4b;


MUIA_Application_BrokerPort

Declaration

Source position: mui.pas line 1029

const MUIA_Application_BrokerPort = MUIB_MUI or $42e0ad;


MUIA_Application_BrokerPri

Declaration

Source position: mui.pas line 1030

const MUIA_Application_BrokerPri = MUIB_MUI or $42c8d0;


MUIA_Application_Commands

Declaration

Source position: mui.pas line 1031

const MUIA_Application_Commands = MUIB_MUI or $428648;


MUIA_Application_Configdata

Declaration

Source position: mui.pas line 1066

const MUIA_Application_Configdata = MUIB_Application or $0;


MUIA_Application_Copyright

Declaration

Source position: mui.pas line 1032

const MUIA_Application_Copyright = MUIB_MUI or $42ef4d;


MUIA_Application_CopyWinPosToApp

Declaration

Source position: mui.pas line 1057

const MUIA_Application_CopyWinPosToApp = MUIB_MUI or $432392;


MUIA_Application_Description

Declaration

Source position: mui.pas line 1033

const MUIA_Application_Description = MUIB_MUI or $421fc6;


MUIA_Application_DiskObject

Declaration

Source position: mui.pas line 1034

const MUIA_Application_DiskObject = MUIB_MUI or $4235cb;


MUIA_Application_DoubleStart

Declaration

Source position: mui.pas line 1035

const MUIA_Application_DoubleStart = MUIB_MUI or $423bc6;


MUIA_Application_DropObject

Declaration

Source position: mui.pas line 1036

const MUIA_Application_DropObject = MUIB_MUI or $421266;


MUIA_Application_ForceQuit

Declaration

Source position: mui.pas line 1037

const MUIA_Application_ForceQuit = MUIB_MUI or $4257df;


MUIA_Application_GetWinPos

Declaration

Source position: mui.pas line 1053

const MUIA_Application_GetWinPos = MUIB_MUI or $432388;


MUIA_Application_GetWinPosAddr

Declaration

Source position: mui.pas line 1055

const MUIA_Application_GetWinPosAddr = MUIB_MUI or $432390;


MUIA_Application_GetWinPosSize

Declaration

Source position: mui.pas line 1056

const MUIA_Application_GetWinPosSize = MUIB_MUI or $432391;


MUIA_Application_HelpFile

Declaration

Source position: mui.pas line 1038

const MUIA_Application_HelpFile = MUIB_MUI or $4293f4;


MUIA_Application_Iconified

Declaration

Source position: mui.pas line 1039

const MUIA_Application_Iconified = MUIB_MUI or $42a07f;


MUIA_Application_MenuAction

Declaration

Source position: mui.pas line 1040

const MUIA_Application_MenuAction = MUIB_MUI or $428961;


MUIA_Application_MenuHelp

Declaration

Source position: mui.pas line 1041

const MUIA_Application_MenuHelp = MUIB_MUI or $42540b;


MUIA_Application_Menustrip

Declaration

Source position: mui.pas line 1042

const MUIA_Application_Menustrip = MUIB_MUI or $4252d9;


MUIA_Application_RexxHook

Declaration

Source position: mui.pas line 1043

const MUIA_Application_RexxHook = MUIB_MUI or $427c42;


MUIA_Application_RexxMsg

Declaration

Source position: mui.pas line 1044

const MUIA_Application_RexxMsg = MUIB_MUI or $42fd88;


MUIA_Application_RexxString

Declaration

Source position: mui.pas line 1045

const MUIA_Application_RexxString = MUIB_MUI or $42d711;


MUIA_Application_SearchWinId

Declaration

Source position: mui.pas line 1054

const MUIA_Application_SearchWinId = MUIB_MUI or $432389;


MUIA_Application_SetWinPos

Declaration

Source position: mui.pas line 1052

const MUIA_Application_SetWinPos = MUIB_MUI or $432387;


MUIA_Application_SingleTask

Declaration

Source position: mui.pas line 1046

const MUIA_Application_SingleTask = MUIB_MUI or $42a2c8;


MUIA_Application_Sleep

Declaration

Source position: mui.pas line 1047

const MUIA_Application_Sleep = MUIB_MUI or $425711;


MUIA_Application_Title

Declaration

Source position: mui.pas line 1048

const MUIA_Application_Title = MUIB_MUI or $4281b8;


MUIA_Application_UseCommodities

Declaration

Source position: mui.pas line 1049

const MUIA_Application_UseCommodities = MUIB_MUI or $425ee5;


MUIA_Application_UsedClasses

Declaration

Source position: mui.pas line 1050

const MUIA_Application_UsedClasses = MUIB_MUI or $42e9a7;


MUIA_Application_UseRexx

Declaration

Source position: mui.pas line 1051

const MUIA_Application_UseRexx = MUIB_MUI or $422387;


MUIA_Application_Version

Declaration

Source position: mui.pas line 1058

const MUIA_Application_Version = MUIB_MUI or $42b33f;


MUIA_Application_Version_Date

Declaration

Source position: mui.pas line 1068

const MUIA_Application_Version_Date = MUIB_Application or $2;


MUIA_Application_Version_Extra

Declaration

Source position: mui.pas line 1069

const MUIA_Application_Version_Extra = MUIB_Application or $3;


MUIA_Application_Version_Number

Declaration

Source position: mui.pas line 1067

const MUIA_Application_Version_Number = MUIB_Application or $1;


MUIA_Application_Window

Declaration

Source position: mui.pas line 1063

const MUIA_Application_Window = MUIB_MUI or $42bfe0;


MUIA_Application_WindowList

Declaration

Source position: mui.pas line 1064

const MUIA_Application_WindowList = MUIB_MUI or $429abe;


MUIA_ApplicationObject

Declaration

Source position: mui.pas line 772

const MUIA_ApplicationObject = MUIB_MUI or $42d3ee;


MUIA_AppMessage

Declaration

Source position: mui.pas line 773

const MUIA_AppMessage = MUIB_MUI or $421955;


MUIA_Background

Declaration

Source position: mui.pas line 1639

const MUIA_Background = MUIB_MUI or $42545b;


MUIA_Balance_Quiet

Declaration

Source position: mui.pas line 3224

const MUIA_Balance_Quiet = MUIB_Balance or $0;


MUIA_Bitmap_Alpha

Declaration

Source position: mui.pas line 2383

const MUIA_Bitmap_Alpha = MUIB_MUI or $423e71;


MUIA_Bitmap_Bitmap

Declaration

Source position: mui.pas line 2384

const MUIA_Bitmap_Bitmap = MUIB_MUI or $4279bd;


MUIA_Bitmap_Height

Declaration

Source position: mui.pas line 2385

const MUIA_Bitmap_Height = MUIB_MUI or $421560;


MUIA_Bitmap_MappingTable

Declaration

Source position: mui.pas line 2386

const MUIA_Bitmap_MappingTable = MUIB_MUI or $42e23d;


MUIA_Bitmap_Precision

Declaration

Source position: mui.pas line 2387

const MUIA_Bitmap_Precision = MUIB_MUI or $420c74;


MUIA_Bitmap_RemappedBitmap

Declaration

Source position: mui.pas line 2388

const MUIA_Bitmap_RemappedBitmap = MUIB_MUI or $423a47;


MUIA_Bitmap_SourceColors

Declaration

Source position: mui.pas line 2389

const MUIA_Bitmap_SourceColors = MUIB_MUI or $425360;


MUIA_Bitmap_Transparent

Declaration

Source position: mui.pas line 2390

const MUIA_Bitmap_Transparent = MUIB_MUI or $422805;


MUIA_Bitmap_UseFriend

Declaration

Source position: mui.pas line 2391

const MUIA_Bitmap_UseFriend = MUIB_MUI or $4239d8;


MUIA_Bitmap_Width

Declaration

Source position: mui.pas line 2392

const MUIA_Bitmap_Width = MUIB_MUI or $42eb3a;


MUIA_Bodychunk_Body

Declaration

Source position: mui.pas line 2404

const MUIA_Bodychunk_Body = MUIB_MUI or $42ca67;


MUIA_Bodychunk_Compression

Declaration

Source position: mui.pas line 2405

const MUIA_Bodychunk_Compression = MUIB_MUI or $42de5f;


MUIA_Bodychunk_Depth

Declaration

Source position: mui.pas line 2406

const MUIA_Bodychunk_Depth = MUIB_MUI or $42c392;


MUIA_Bodychunk_Masking

Declaration

Source position: mui.pas line 2407

const MUIA_Bodychunk_Masking = MUIB_MUI or $423b0e;


MUIA_Boopsi_Class

Declaration

Source position: mui.pas line 2077

const MUIA_Boopsi_Class = MUIB_MUI or $426999;


MUIA_Boopsi_ClassID

Declaration

Source position: mui.pas line 2078

const MUIA_Boopsi_ClassID = MUIB_MUI or $42bfa3;


MUIA_Boopsi_MaxHeight

Declaration

Source position: mui.pas line 2079

const MUIA_Boopsi_MaxHeight = MUIB_MUI or $42757f;


MUIA_Boopsi_MaxWidth

Declaration

Source position: mui.pas line 2080

const MUIA_Boopsi_MaxWidth = MUIB_MUI or $42bcb1;


MUIA_Boopsi_MinHeight

Declaration

Source position: mui.pas line 2081

const MUIA_Boopsi_MinHeight = MUIB_MUI or $422c93;


MUIA_Boopsi_MinWidth

Declaration

Source position: mui.pas line 2082

const MUIA_Boopsi_MinWidth = MUIB_MUI or $428fb2;


MUIA_Boopsi_Object

Declaration

Source position: mui.pas line 2083

const MUIA_Boopsi_Object = MUIB_MUI or $420178;


MUIA_Boopsi_Remember

Declaration

Source position: mui.pas line 2084

const MUIA_Boopsi_Remember = MUIB_MUI or $42f4bd;


MUIA_Boopsi_Smart

Declaration

Source position: mui.pas line 2085

const MUIA_Boopsi_Smart = MUIB_MUI or $42b8d7;


MUIA_Boopsi_TagDrawInfo

Declaration

Source position: mui.pas line 2086

const MUIA_Boopsi_TagDrawInfo = MUIB_MUI or $42bae7;


MUIA_Boopsi_TagScreen

Declaration

Source position: mui.pas line 2087

const MUIA_Boopsi_TagScreen = MUIB_MUI or $42bc71;


MUIA_Boopsi_TagWindow

Declaration

Source position: mui.pas line 2088

const MUIA_Boopsi_TagWindow = MUIB_MUI or $42e11d;


MUIA_BottomEdge

Declaration

Source position: mui.pas line 1640

const MUIA_BottomEdge = MUIB_MUI or $42e552;


MUIA_ChunkyImage_Modulo

Declaration

Source position: mui.pas line 2422

const MUIA_ChunkyImage_Modulo = MUIB_ChunkyImage or $3;


MUIA_ChunkyImage_NumColors

Declaration

Source position: mui.pas line 2421

const MUIA_ChunkyImage_NumColors = MUIB_ChunkyImage or $2;


MUIA_ChunkyImage_Palette

Declaration

Source position: mui.pas line 2420

const MUIA_ChunkyImage_Palette = MUIB_ChunkyImage or $1;


MUIA_ChunkyImage_Pixels

Declaration

Source position: mui.pas line 2419

const MUIA_ChunkyImage_Pixels = MUIB_ChunkyImage or $0;


MUIA_Coloradjust_Blue

Declaration

Source position: mui.pas line 3314

const MUIA_Coloradjust_Blue = MUIB_MUI or $42b8a3;


MUIA_Coloradjust_Green

Declaration

Source position: mui.pas line 3315

const MUIA_Coloradjust_Green = MUIB_MUI or $4285ab;


MUIA_Coloradjust_ModeID

Declaration

Source position: mui.pas line 3316

const MUIA_Coloradjust_ModeID = MUIB_MUI or $42ec59;


MUIA_Coloradjust_Red

Declaration

Source position: mui.pas line 3317

const MUIA_Coloradjust_Red = MUIB_MUI or $420eaa;


MUIA_Coloradjust_RGB

Declaration

Source position: mui.pas line 3318

const MUIA_Coloradjust_RGB = MUIB_MUI or $42f899;


MUIA_Colorfield_Blue

Declaration

Source position: mui.pas line 3298

const MUIA_Colorfield_Blue = MUIB_MUI or $42d3b0;


MUIA_Colorfield_Green

Declaration

Source position: mui.pas line 3299

const MUIA_Colorfield_Green = MUIB_MUI or $424466;


MUIA_Colorfield_Pen

Declaration

Source position: mui.pas line 3300

const MUIA_Colorfield_Pen = MUIB_MUI or $42713a;


MUIA_Colorfield_Red

Declaration

Source position: mui.pas line 3301

const MUIA_Colorfield_Red = MUIB_MUI or $4279f6;


MUIA_Colorfield_RGB

Declaration

Source position: mui.pas line 3302

const MUIA_Colorfield_RGB = MUIB_MUI or $42677a;


MUIA_Configdata_Application

Declaration

Source position: mui.pas line 2996

const MUIA_Configdata_Application = MUIB_Configdata or $00000000;


MUIA_Configdata_ApplicationBase

Declaration

Source position: mui.pas line 2997

const MUIA_Configdata_ApplicationBase = MUIB_Configdata or $00000002;


MUIA_ContextMenu

Declaration

Source position: mui.pas line 1641

const MUIA_ContextMenu = MUIB_MUI or $42b704;


MUIA_ContextMenuTrigger

Declaration

Source position: mui.pas line 1642

const MUIA_ContextMenuTrigger = MUIB_MUI or $42a2c1;


MUIA_ControlChar

Declaration

Source position: mui.pas line 1643

const MUIA_ControlChar = MUIB_MUI or $42120b;


MUIA_Cycle_Active

Declaration

Source position: mui.pas line 2786

const MUIA_Cycle_Active = MUIB_MUI or $421788;


MUIA_Cycle_Entries

Declaration

Source position: mui.pas line 2787

const MUIA_Cycle_Entries = MUIB_MUI or $420629;


MUIA_CycleChain

Declaration

Source position: mui.pas line 1644

const MUIA_CycleChain = MUIB_MUI or $421ce7;


MUIA_Dataspace_Pool

Declaration

Source position: mui.pas line 2280

const MUIA_Dataspace_Pool = MUIB_MUI or $424cf9;


MUIA_Dirlist_AcceptPattern

Declaration

Source position: mui.pas line 3382

const MUIA_Dirlist_AcceptPattern = MUIB_MUI or $42760a;


MUIA_Dirlist_Directory

Declaration

Source position: mui.pas line 3383

const MUIA_Dirlist_Directory = MUIB_MUI or $42ea41;


MUIA_Dirlist_DrawersOnly

Declaration

Source position: mui.pas line 3384

const MUIA_Dirlist_DrawersOnly = MUIB_MUI or $42b379;


MUIA_Dirlist_FilesOnly

Declaration

Source position: mui.pas line 3385

const MUIA_Dirlist_FilesOnly = MUIB_MUI or $42896a;


MUIA_Dirlist_FilterDrawers

Declaration

Source position: mui.pas line 3386

const MUIA_Dirlist_FilterDrawers = MUIB_MUI or $424ad2;


MUIA_Dirlist_FilterHook

Declaration

Source position: mui.pas line 3387

const MUIA_Dirlist_FilterHook = MUIB_MUI or $42ae19;


MUIA_Dirlist_MultiSelDirs

Declaration

Source position: mui.pas line 3388

const MUIA_Dirlist_MultiSelDirs = MUIB_MUI or $428653;


MUIA_Dirlist_NumBytes

Declaration

Source position: mui.pas line 3389

const MUIA_Dirlist_NumBytes = MUIB_MUI or $429e26;


MUIA_Dirlist_NumDrawers

Declaration

Source position: mui.pas line 3390

const MUIA_Dirlist_NumDrawers = MUIB_MUI or $429cb8;


MUIA_Dirlist_NumFiles

Declaration

Source position: mui.pas line 3391

const MUIA_Dirlist_NumFiles = MUIB_MUI or $42a6f0;


MUIA_Dirlist_Path

Declaration

Source position: mui.pas line 3392

const MUIA_Dirlist_Path = MUIB_MUI or $426176;


MUIA_Dirlist_RejectIcons

Declaration

Source position: mui.pas line 3393

const MUIA_Dirlist_RejectIcons = MUIB_MUI or $424808;


MUIA_Dirlist_RejectPattern

Declaration

Source position: mui.pas line 3394

const MUIA_Dirlist_RejectPattern = MUIB_MUI or $4259c7;


MUIA_Dirlist_SortDirs

Declaration

Source position: mui.pas line 3395

const MUIA_Dirlist_SortDirs = MUIB_MUI or $42bbb9;


MUIA_Dirlist_SortHighLow

Declaration

Source position: mui.pas line 3396

const MUIA_Dirlist_SortHighLow = MUIB_MUI or $421896;


MUIA_Dirlist_SortType

Declaration

Source position: mui.pas line 3397

const MUIA_Dirlist_SortType = MUIB_MUI or $4228bc;


MUIA_Dirlist_Status

Declaration

Source position: mui.pas line 3398

const MUIA_Dirlist_Status = MUIB_MUI or $4240de;


MUIA_Disabled

Declaration

Source position: mui.pas line 1645

const MUIA_Disabled = MUIB_MUI or $423661;


MUIA_DoubleBuffer

Declaration

Source position: mui.pas line 1646

const MUIA_DoubleBuffer = MUIB_MUI or $42a9c7;


MUIA_Draggable

Declaration

Source position: mui.pas line 1647

const MUIA_Draggable = MUIB_MUI or $420b6e;


MUIA_Dropable

Declaration

Source position: mui.pas line 1648

const MUIA_Dropable = MUIB_MUI or $42fbce;


MUIA_Dtpic_Alpha

Declaration

Source position: mui.pas line 3466

const MUIA_Dtpic_Alpha = MUIB_MUI or $42b4db;


MUIA_Dtpic_DarkenSelState

Declaration

Source position: mui.pas line 3467

const MUIA_Dtpic_DarkenSelState = MUIB_MUI or $423247;


MUIA_Dtpic_Fade

Declaration

Source position: mui.pas line 3468

const MUIA_Dtpic_Fade = MUIB_MUI or $420429;


MUIA_Dtpic_LightenOnMouse

Declaration

Source position: mui.pas line 3469

const MUIA_Dtpic_LightenOnMouse = MUIB_MUI or $42966a;


MUIA_Dtpic_Name

Declaration

Source position: mui.pas line 3470

const MUIA_Dtpic_Name = MUIB_MUI or $423d72;


MUIA_Family_Child

Declaration

Source position: mui.pas line 848

const MUIA_Family_Child = MUIB_MUI or $42c696;


MUIA_Family_ChildCount

Declaration

Source position: mui.pas line 850

const MUIA_Family_ChildCount = MUIB_MUI or $42b25a;


MUIA_Family_List

Declaration

Source position: mui.pas line 849

const MUIA_Family_List = MUIB_MUI or $424b9e;


MUIA_FillArea

Declaration

Source position: mui.pas line 1649

const MUIA_FillArea = MUIB_MUI or $4294a3;


MUIA_FixHeight

Declaration

Source position: mui.pas line 1651

const MUIA_FixHeight = MUIB_MUI or $42a92b;


MUIA_FixHeightTxt

Declaration

Source position: mui.pas line 1652

const MUIA_FixHeightTxt = MUIB_MUI or $4276f2;


MUIA_FixWidth

Declaration

Source position: mui.pas line 1653

const MUIA_FixWidth = MUIB_MUI or $42a3f1;


MUIA_FixWidthTxt

Declaration

Source position: mui.pas line 1654

const MUIA_FixWidthTxt = MUIB_MUI or $42d044;


MUIA_Floattext_Justify

Declaration

Source position: mui.pas line 2720

const MUIA_Floattext_Justify = MUIB_MUI or $42dc03;


MUIA_Floattext_SkiPChars

Declaration

Source position: mui.pas line 2721

const MUIA_Floattext_SkiPChars = MUIB_MUI or $425c7d;


MUIA_Floattext_TabSize

Declaration

Source position: mui.pas line 2722

const MUIA_Floattext_TabSize = MUIB_MUI or $427d17;


MUIA_Floattext_Text

Declaration

Source position: mui.pas line 2723

const MUIA_Floattext_Text = MUIB_MUI or $42d16a;


MUIA_Font

Declaration

Source position: mui.pas line 1656

const MUIA_Font = MUIB_MUI or $42be50;


MUIA_Frame

Declaration

Source position: mui.pas line 1657

const MUIA_Frame = MUIB_MUI or $42ac64;


MUIA_Frameadjust_Spec

Declaration

Source position: mui.pas line 3334

const MUIA_Frameadjust_Spec = MUIB_Frameadjust or $0;


MUIA_Framedisplay_Spec

Declaration

Source position: mui.pas line 3345

const MUIA_Framedisplay_Spec = MUIB_MUI or $421794;


MUIA_FramePhantomHoriz

Declaration

Source position: mui.pas line 1658

const MUIA_FramePhantomHoriz = MUIB_MUI or $42ed76;


MUIA_FrameTitle

Declaration

Source position: mui.pas line 1659

const MUIA_FrameTitle = MUIB_MUI or $42d1c7;


MUIA_Gadget_Gadget

Declaration

Source position: mui.pas line 3580

const MUIA_Gadget_Gadget = MUIB_MUI or $42ec1a;


MUIA_Gauge_Current

Declaration

Source position: mui.pas line 2802

const MUIA_Gauge_Current = MUIB_MUI or $42f0dd;


MUIA_Gauge_Divide

Declaration

Source position: mui.pas line 2803

const MUIA_Gauge_Divide = MUIB_MUI or $42d8df;


MUIA_Gauge_DupInfoText

Declaration

Source position: mui.pas line 2808

const MUIA_Gauge_DupInfoText = MUIB_Gauge or $0;


MUIA_Gauge_Horiz

Declaration

Source position: mui.pas line 2804

const MUIA_Gauge_Horiz = MUIB_MUI or $4232dd;


MUIA_Gauge_InfoText

Declaration

Source position: mui.pas line 2805

const MUIA_Gauge_InfoText = MUIB_MUI or $42bf15;


MUIA_Gauge_Max

Declaration

Source position: mui.pas line 2806

const MUIA_Gauge_Max = MUIB_MUI or $42bcdb;


MUIA_Group_ActivePage

Declaration

Source position: mui.pas line 1812

const MUIA_Group_ActivePage = MUIB_MUI or $424199;


MUIA_Group_Child

Declaration

Source position: mui.pas line 1813

const MUIA_Group_Child = MUIB_MUI or $4226e6;


MUIA_Group_ChildList

Declaration

Source position: mui.pas line 1814

const MUIA_Group_ChildList = MUIB_MUI or $424748;


MUIA_Group_Columns

Declaration

Source position: mui.pas line 1815

const MUIA_Group_Columns = MUIB_MUI or $42f416;


MUIA_Group_Forward

Declaration

Source position: mui.pas line 1816

const MUIA_Group_Forward = MUIB_MUI or $421422;


MUIA_Group_Horiz

Declaration

Source position: mui.pas line 1817

const MUIA_Group_Horiz = MUIB_MUI or $42536b;


MUIA_Group_HorizSpacing

Declaration

Source position: mui.pas line 1818

const MUIA_Group_HorizSpacing = MUIB_MUI or $42c651;


MUIA_Group_LayoutHook

Declaration

Source position: mui.pas line 1819

const MUIA_Group_LayoutHook = MUIB_MUI or $42c3b2;


MUIA_Group_PageMode

Declaration

Source position: mui.pas line 1820

const MUIA_Group_PageMode = MUIB_MUI or $421a5f;


MUIA_Group_Rows

Declaration

Source position: mui.pas line 1821

const MUIA_Group_Rows = MUIB_MUI or $42b68f;


MUIA_Group_SameHeight

Declaration

Source position: mui.pas line 1822

const MUIA_Group_SameHeight = MUIB_MUI or $42037e;


MUIA_Group_SameSize

Declaration

Source position: mui.pas line 1823

const MUIA_Group_SameSize = MUIB_MUI or $420860;


MUIA_Group_SameWidth

Declaration

Source position: mui.pas line 1824

const MUIA_Group_SameWidth = MUIB_MUI or $42b3ec;


MUIA_Group_Spacing

Declaration

Source position: mui.pas line 1825

const MUIA_Group_Spacing = MUIB_MUI or $42866d;


MUIA_Group_VertSpacing

Declaration

Source position: mui.pas line 1826

const MUIA_Group_VertSpacing = MUIB_MUI or $42e1bf;


MUIA_Group_Virtual

Declaration

Source position: mui.pas line 1828

const MUIA_Group_Virtual = MUIB_Group or $0;


MUIA_Height

Declaration

Source position: mui.pas line 1661

const MUIA_Height = MUIB_MUI or $423237;


MUIA_HelpLine

Declaration

Source position: mui.pas line 774

const MUIA_HelpLine = MUIB_MUI or $42a825;


MUIA_HelpNode

Declaration

Source position: mui.pas line 775

const MUIA_HelpNode = MUIB_MUI or $420b85;


MUIA_HorizDisappear

Declaration

Source position: mui.pas line 1662

const MUIA_HorizDisappear = MUIB_MUI or $429615;


MUIA_HorizWeight

Declaration

Source position: mui.pas line 1663

const MUIA_HorizWeight = MUIB_MUI or $426db9;


MUIA_Image_FontMatch

Declaration

Source position: mui.pas line 2820

const MUIA_Image_FontMatch = MUIB_MUI or $42815d;


MUIA_Image_FontMatchHeight

Declaration

Source position: mui.pas line 2821

const MUIA_Image_FontMatchHeight = MUIB_MUI or $429f26;


MUIA_Image_FontMatchWidth

Declaration

Source position: mui.pas line 2822

const MUIA_Image_FontMatchWidth = MUIB_MUI or $4239bf;


MUIA_Image_FreeHoriz

Declaration

Source position: mui.pas line 2823

const MUIA_Image_FreeHoriz = MUIB_MUI or $42da84;


MUIA_Image_FreeVert

Declaration

Source position: mui.pas line 2824

const MUIA_Image_FreeVert = MUIB_MUI or $42ea28;


MUIA_Image_OldImage

Declaration

Source position: mui.pas line 2825

const MUIA_Image_OldImage = MUIB_MUI or $424f3d;


MUIA_Image_Spec

Declaration

Source position: mui.pas line 2826

const MUIA_Image_Spec = MUIB_MUI or $4233d5;


MUIA_Image_State

Declaration

Source position: mui.pas line 2827

const MUIA_Image_State = MUIB_MUI or $42a3ad;


MUIA_Imageadjust_Originator

Declaration

Source position: mui.pas line 3175

const MUIA_Imageadjust_Originator = MUIB_Imageadjust or $0;


MUIA_Imageadjust_Spec

Declaration

Source position: mui.pas line 3173

const MUIA_Imageadjust_Spec = MUIB_MUI or $4279e1;


MUIA_Imageadjust_Type

Declaration

Source position: mui.pas line 3172

const MUIA_Imageadjust_Type = MUIB_MUI or $422f2b;


MUIA_Imagedisplay_FreeHoriz

Declaration

Source position: mui.pas line 2841

const MUIA_Imagedisplay_FreeHoriz = MUIB_Imagedisplay or $0;


MUIA_Imagedisplay_FreeVert

Declaration

Source position: mui.pas line 2842

const MUIA_Imagedisplay_FreeVert = MUIB_Imagedisplay or $1;


MUIA_Imagedisplay_Spec

Declaration

Source position: mui.pas line 2838

const MUIA_Imagedisplay_Spec = MUIB_MUI or $42a547;


MUIA_Imagedisplay_UseDefSize

Declaration

Source position: mui.pas line 2839

const MUIA_Imagedisplay_UseDefSize = MUIB_MUI or $42186d;


MUIA_InnerBottom

Declaration

Source position: mui.pas line 1665

const MUIA_InnerBottom = MUIB_MUI or $42f2c0;


MUIA_InnerLeft

Declaration

Source position: mui.pas line 1666

const MUIA_InnerLeft = MUIB_MUI or $4228f8;


MUIA_InnerRight

Declaration

Source position: mui.pas line 1667

const MUIA_InnerRight = MUIB_MUI or $4297ff;


MUIA_InnerTop

Declaration

Source position: mui.pas line 1668

const MUIA_InnerTop = MUIB_MUI or $421eb6;


MUIA_InputMode

Declaration

Source position: mui.pas line 1669

const MUIA_InputMode = MUIB_MUI or $42fb04;


MUIA_LeftEdge

Declaration

Source position: mui.pas line 1671

const MUIA_LeftEdge = MUIB_MUI or $42bec6;


MUIA_Levelmeter_Label

Declaration

Source position: mui.pas line 3449

const MUIA_Levelmeter_Label = MUIB_MUI or $420dd5;


MUIA_List_Active

Declaration

Source position: mui.pas line 2603

const MUIA_List_Active = MUIB_MUI or $42391c;


MUIA_List_AdjustHeight

Declaration

Source position: mui.pas line 2604

const MUIA_List_AdjustHeight = MUIB_MUI or $42850d;


MUIA_List_AdjustWidth

Declaration

Source position: mui.pas line 2605

const MUIA_List_AdjustWidth = MUIB_MUI or $42354a;


MUIA_List_AutoVisible

Declaration

Source position: mui.pas line 2606

const MUIA_List_AutoVisible = MUIB_MUI or $42a445;


MUIA_List_CompareHook

Declaration

Source position: mui.pas line 2607

const MUIA_List_CompareHook = MUIB_MUI or $425c14;


MUIA_List_ConstructHook

Declaration

Source position: mui.pas line 2608

const MUIA_List_ConstructHook = MUIB_MUI or $42894f;


MUIA_List_DestructHook

Declaration

Source position: mui.pas line 2609

const MUIA_List_DestructHook = MUIB_MUI or $4297ce;


MUIA_List_DisplayHook

Declaration

Source position: mui.pas line 2610

const MUIA_List_DisplayHook = MUIB_MUI or $42b4d5;


MUIA_List_DragSortable

Declaration

Source position: mui.pas line 2611

const MUIA_List_DragSortable = MUIB_MUI or $426099;


MUIA_List_DropMark

Declaration

Source position: mui.pas line 2612

const MUIA_List_DropMark = MUIB_MUI or $42aba6;


MUIA_List_Entries

Declaration

Source position: mui.pas line 2613

const MUIA_List_Entries = MUIB_MUI or $421654;


MUIA_List_First

Declaration

Source position: mui.pas line 2614

const MUIA_List_First = MUIB_MUI or $4238d4;


MUIA_List_Format

Declaration

Source position: mui.pas line 2615

const MUIA_List_Format = MUIB_MUI or $423c0a;


MUIA_List_InsertPosition

Declaration

Source position: mui.pas line 2616

const MUIA_List_InsertPosition = MUIB_MUI or $42d0cd;


MUIA_List_MinLineHeight

Declaration

Source position: mui.pas line 2617

const MUIA_List_MinLineHeight = MUIB_MUI or $42d1c3;


MUIA_List_MultiTestHook

Declaration

Source position: mui.pas line 2618

const MUIA_List_MultiTestHook = MUIB_MUI or $42c2c6;


MUIA_List_Pool

Declaration

Source position: mui.pas line 2619

const MUIA_List_Pool = MUIB_MUI or $423431;


MUIA_List_PoolPuddleSize

Declaration

Source position: mui.pas line 2620

const MUIA_List_PoolPuddleSize = MUIB_MUI or $42a4eb;


MUIA_List_PoolThreshSize

Declaration

Source position: mui.pas line 2621

const MUIA_List_PoolThreshSize = MUIB_MUI or $42c48c;


MUIA_List_Quiet

Declaration

Source position: mui.pas line 2622

const MUIA_List_Quiet = MUIB_MUI or $42d8c7;


MUIA_List_ShowDropMarks

Declaration

Source position: mui.pas line 2623

const MUIA_List_ShowDropMarks = MUIB_MUI or $42c6f3;


MUIA_List_SourceArray

Declaration

Source position: mui.pas line 2624

const MUIA_List_SourceArray = MUIB_MUI or $42c0a0;


MUIA_List_Title

Declaration

Source position: mui.pas line 2625

const MUIA_List_Title = MUIB_MUI or $423e66;


MUIA_List_Visible

Declaration

Source position: mui.pas line 2626

const MUIA_List_Visible = MUIB_MUI or $42191f;


MUIA_Listview_ClickColumn

Declaration

Source position: mui.pas line 2434

const MUIA_Listview_ClickColumn = MUIB_MUI or $42d1b3;


MUIA_Listview_DefClickColumn

Declaration

Source position: mui.pas line 2435

const MUIA_Listview_DefClickColumn = MUIB_MUI or $42b296;


MUIA_Listview_DoubleClick

Declaration

Source position: mui.pas line 2436

const MUIA_Listview_DoubleClick = MUIB_MUI or $424635;


MUIA_Listview_DragType

Declaration

Source position: mui.pas line 2437

const MUIA_Listview_DragType = MUIB_MUI or $425cd3;


MUIA_Listview_Input

Declaration

Source position: mui.pas line 2438

const MUIA_Listview_Input = MUIB_MUI or $42682d;


MUIA_Listview_List

Declaration

Source position: mui.pas line 2439

const MUIA_Listview_List = MUIB_MUI or $42bcce;


MUIA_Listview_MultiSelect

Declaration

Source position: mui.pas line 2440

const MUIA_Listview_MultiSelect = MUIB_MUI or $427e08;


MUIA_Listview_ScrollerPos

Declaration

Source position: mui.pas line 2441

const MUIA_Listview_ScrollerPos = MUIB_MUI or $42b1b4;


MUIA_Listview_SelectChange

Declaration

Source position: mui.pas line 2442

const MUIA_Listview_SelectChange = MUIB_MUI or $42178f;


MUIA_MaxHeight

Declaration

Source position: mui.pas line 1672

const MUIA_MaxHeight = MUIB_MUI or $4293e4;


MUIA_MaxWidth

Declaration

Source position: mui.pas line 1673

const MUIA_MaxWidth = MUIB_MUI or $42f112;


MUIA_Menu_Enabled

Declaration

Source position: mui.pas line 2187

const MUIA_Menu_Enabled = MUIB_MUI or $42ed48;


MUIA_Menu_Title

Declaration

Source position: mui.pas line 2188

const MUIA_Menu_Title = MUIB_MUI or $42a0e3;


MUIA_Menuitem_Checked

Declaration

Source position: mui.pas line 2200

const MUIA_Menuitem_Checked = MUIB_MUI or $42562a;


MUIA_Menuitem_Checkit

Declaration

Source position: mui.pas line 2201

const MUIA_Menuitem_Checkit = MUIB_MUI or $425ace;


MUIA_Menuitem_CommandString

Declaration

Source position: mui.pas line 2202

const MUIA_Menuitem_CommandString = MUIB_MUI or $42b9cc;


MUIA_Menuitem_Enabled

Declaration

Source position: mui.pas line 2203

const MUIA_Menuitem_Enabled = MUIB_MUI or $42ae0f;


MUIA_Menuitem_Exclude

Declaration

Source position: mui.pas line 2204

const MUIA_Menuitem_Exclude = MUIB_MUI or $420bc6;


MUIA_Menuitem_NewMenu

Declaration

Source position: mui.pas line 2210

const MUIA_Menuitem_NewMenu = MUIB_Menuitem or $0;


MUIA_Menuitem_Shortcut

Declaration

Source position: mui.pas line 2205

const MUIA_Menuitem_Shortcut = MUIB_MUI or $422030;


MUIA_Menuitem_Title

Declaration

Source position: mui.pas line 2206

const MUIA_Menuitem_Title = MUIB_MUI or $4218be;


MUIA_Menuitem_Toggle

Declaration

Source position: mui.pas line 2207

const MUIA_Menuitem_Toggle = MUIB_MUI or $424d5c;


MUIA_Menuitem_Trigger

Declaration

Source position: mui.pas line 2208

const MUIA_Menuitem_Trigger = MUIB_MUI or $426f32;


MUIA_Menustrip_Enabled

Declaration

Source position: mui.pas line 2175

const MUIA_Menustrip_Enabled = MUIB_MUI or $42815b;


MUIA_NestedDisabled

Declaration

Source position: mui.pas line 1691

const MUIA_NestedDisabled = MUIB_Area or $0;


MUIA_NoNotify

Declaration

Source position: mui.pas line 776

const MUIA_NoNotify = MUIB_MUI or $4237f9;


MUIA_NoNotifyMethod

Declaration

Source position: mui.pas line 782

const MUIA_NoNotifyMethod = MUIB_MUI or $420a74;


MUIA_Numeric_CheckAllSizes

Declaration

Source position: mui.pas line 1969

const MUIA_Numeric_CheckAllSizes = MUIB_MUI or $421594;


MUIA_Numeric_Default

Declaration

Source position: mui.pas line 1970

const MUIA_Numeric_Default = MUIB_MUI or $4263e8;


MUIA_Numeric_Format

Declaration

Source position: mui.pas line 1971

const MUIA_Numeric_Format = MUIB_MUI or $4263e9;


MUIA_Numeric_Max

Declaration

Source position: mui.pas line 1972

const MUIA_Numeric_Max = MUIB_MUI or $42d78a;


MUIA_Numeric_Min

Declaration

Source position: mui.pas line 1973

const MUIA_Numeric_Min = MUIB_MUI or $42e404;


MUIA_Numeric_Reverse

Declaration

Source position: mui.pas line 1974

const MUIA_Numeric_Reverse = MUIB_MUI or $42f2a0;


MUIA_Numeric_RevLeftRight

Declaration

Source position: mui.pas line 1975

const MUIA_Numeric_RevLeftRight = MUIB_MUI or $4294a7;


MUIA_Numeric_RevUpDown

Declaration

Source position: mui.pas line 1976

const MUIA_Numeric_RevUpDown = MUIB_MUI or $4252dd;


MUIA_Numeric_Value

Declaration

Source position: mui.pas line 1977

const MUIA_Numeric_Value = MUIB_MUI or $42ae3a;


MUIA_ObjectID

Declaration

Source position: mui.pas line 777

const MUIA_ObjectID = MUIB_MUI or $42d76e;


MUIA_Palette_Entries

Declaration

Source position: mui.pas line 3479

const MUIA_Palette_Entries = $8042a3d8;


MUIA_Palette_Groupable

Declaration

Source position: mui.pas line 3480

const MUIA_Palette_Groupable = $80423e67;


MUIA_Palette_Names

Declaration

Source position: mui.pas line 3481

const MUIA_Palette_Names = $8042c3a2;


MUIA_Parent

Declaration

Source position: mui.pas line 778

const MUIA_Parent = MUIB_MUI or $42e35f;


MUIA_Penadjust_PSIMode

Declaration

Source position: mui.pas line 3278

const MUIA_Penadjust_PSIMode = MUIB_MUI or $421cbb;


MUIA_Pendisplay_Pen

Declaration

Source position: mui.pas line 3263

const MUIA_Pendisplay_Pen = MUIB_MUI or $42a748;


MUIA_Pendisplay_Reference

Declaration

Source position: mui.pas line 3264

const MUIA_Pendisplay_Reference = MUIB_MUI or $42dc24;


MUIA_Pendisplay_RGBcolor

Declaration

Source position: mui.pas line 3265

const MUIA_Pendisplay_RGBcolor = MUIB_MUI or $42a1a9;


MUIA_Pendisplay_Spec

Declaration

Source position: mui.pas line 3266

const MUIA_Pendisplay_Spec = MUIB_MUI or $42a204;


MUIA_Pixmap_Alpha

Declaration

Source position: mui.pas line 3555

const MUIA_Pixmap_Alpha = MUIB_MUI or $421fef;


MUIA_Pixmap_CLUT

Declaration

Source position: mui.pas line 3556

const MUIA_Pixmap_CLUT = MUIB_MUI or $42042a;


MUIA_Pixmap_CompressedSize

Declaration

Source position: mui.pas line 3557

const MUIA_Pixmap_CompressedSize = MUIB_MUI or $42e7e4;


MUIA_Pixmap_Compression

Declaration

Source position: mui.pas line 3558

const MUIA_Pixmap_Compression = MUIB_MUI or $42ce74;


MUIA_Pixmap_Data

Declaration

Source position: mui.pas line 3559

const MUIA_Pixmap_Data = MUIB_MUI or $429ea0;


MUIA_Pixmap_Format

Declaration

Source position: mui.pas line 3560

const MUIA_Pixmap_Format = MUIB_MUI or $42ab14;


MUIA_Pixmap_Height

Declaration

Source position: mui.pas line 3561

const MUIA_Pixmap_Height = MUIB_MUI or $4288be;


MUIA_Pixmap_UncompressedData

Declaration

Source position: mui.pas line 3562

const MUIA_Pixmap_UncompressedData = MUIB_MUI or $42b085;


MUIA_Pixmap_Width

Declaration

Source position: mui.pas line 3563

const MUIA_Pixmap_Width = MUIB_MUI or $42ccb8;


MUIA_Popasl_Active

Declaration

Source position: mui.pas line 2854

const MUIA_Popasl_Active = MUIB_MUI or $421b37;


MUIA_Popasl_StartHook

Declaration

Source position: mui.pas line 2855

const MUIA_Popasl_StartHook = MUIB_MUI or $42b703;


MUIA_Popasl_StopHook

Declaration

Source position: mui.pas line 2856

const MUIA_Popasl_StopHook = MUIB_MUI or $42d8d2;


MUIA_Popasl_Type

Declaration

Source position: mui.pas line 2857

const MUIA_Popasl_Type = MUIB_MUI or $42df3d;


MUIA_Poplist_Array

Declaration

Source position: mui.pas line 3427

const MUIA_Poplist_Array = MUIB_MUI or $42084c;


MUIA_Popobject_Follow

Declaration

Source position: mui.pas line 2768

const MUIA_Popobject_Follow = MUIB_MUI or $424cb5;


MUIA_Popobject_Light

Declaration

Source position: mui.pas line 2769

const MUIA_Popobject_Light = MUIB_MUI or $42a5a3;


MUIA_Popobject_Object

Declaration

Source position: mui.pas line 2770

const MUIA_Popobject_Object = MUIB_MUI or $4293e3;


MUIA_Popobject_ObjStrHook

Declaration

Source position: mui.pas line 2771

const MUIA_Popobject_ObjStrHook = MUIB_MUI or $42db44;


MUIA_Popobject_StrObjHook

Declaration

Source position: mui.pas line 2772

const MUIA_Popobject_StrObjHook = MUIB_MUI or $42fbe1;


MUIA_Popobject_Volatile

Declaration

Source position: mui.pas line 2773

const MUIA_Popobject_Volatile = MUIB_MUI or $4252ec;


MUIA_Popobject_WindowHook

Declaration

Source position: mui.pas line 2774

const MUIA_Popobject_WindowHook = MUIB_MUI or $42f194;


MUIA_Popstring_Button

Declaration

Source position: mui.pas line 2752

const MUIA_Popstring_Button = MUIB_MUI or $42d0b9;


MUIA_Popstring_CloseHook

Declaration

Source position: mui.pas line 2753

const MUIA_Popstring_CloseHook = MUIB_MUI or $4256bf;


MUIA_Popstring_OpenHook

Declaration

Source position: mui.pas line 2754

const MUIA_Popstring_OpenHook = MUIB_MUI or $429d00;


MUIA_Popstring_String

Declaration

Source position: mui.pas line 2755

const MUIA_Popstring_String = MUIB_MUI or $4239ea;


MUIA_Popstring_Toggle

Declaration

Source position: mui.pas line 2756

const MUIA_Popstring_Toggle = MUIB_MUI or $422b7a;


MUIA_Pressed

Declaration

Source position: mui.pas line 1675

const MUIA_Pressed = MUIB_MUI or $423535;


MUIA_Process_AutoLaunch

Declaration

Source position: mui.pas line 3522

const MUIA_Process_AutoLaunch = MUIB_MUI or $428855;


MUIA_Process_Name

Declaration

Source position: mui.pas line 3523

const MUIA_Process_Name = MUIB_MUI or $42732b;


MUIA_Process_Priority

Declaration

Source position: mui.pas line 3524

const MUIA_Process_Priority = MUIB_MUI or $422a54;


MUIA_Process_SourceClass

Declaration

Source position: mui.pas line 3525

const MUIA_Process_SourceClass = MUIB_MUI or $42cf8b;


MUIA_Process_SourceObject

Declaration

Source position: mui.pas line 3526

const MUIA_Process_SourceObject = MUIB_MUI or $4212a2;


MUIA_Process_StackSize

Declaration

Source position: mui.pas line 3527

const MUIA_Process_StackSize = MUIB_MUI or $4230d0;


MUIA_Process_Task

Declaration

Source position: mui.pas line 3528

const MUIA_Process_Task = MUIB_MUI or $42b123;


MUIA_Prop_DeltaFactor

Declaration

Source position: mui.pas line 2130

const MUIA_Prop_DeltaFactor = MUIB_MUI or $427c5e;


MUIA_Prop_DoSmooth

Declaration

Source position: mui.pas line 2131

const MUIA_Prop_DoSmooth = MUIB_MUI or $4236ce;


MUIA_Prop_Entries

Declaration

Source position: mui.pas line 2118

const MUIA_Prop_Entries = $8042fbdb;


MUIA_Prop_First

Declaration

Source position: mui.pas line 2119

const MUIA_Prop_First = $8042d4b2;


MUIA_Prop_Horiz

Declaration

Source position: mui.pas line 2120

const MUIA_Prop_Horiz = $8042f4f3;


MUIA_Prop_Slider

Declaration

Source position: mui.pas line 2121

const MUIA_Prop_Slider = $80429c3a;


MUIA_Prop_UseWinBorder

Declaration

Source position: mui.pas line 2122

const MUIA_Prop_UseWinBorder = $8042deee;


MUIA_Prop_Visible

Declaration

Source position: mui.pas line 2123

const MUIA_Prop_Visible = $8042fea6;


MUIA_Radio_Active

Declaration

Source position: mui.pas line 3212

const MUIA_Radio_Active = MUIB_MUI or $429b41;


MUIA_Radio_Entries

Declaration

Source position: mui.pas line 3213

const MUIA_Radio_Entries = MUIB_MUI or $42b6a1;


MUIA_Rectangle_BarTitle

Declaration

Source position: mui.pas line 1866

const MUIA_Rectangle_BarTitle = MUIB_MUI or $426689;


MUIA_Rectangle_HBar

Declaration

Source position: mui.pas line 1867

const MUIA_Rectangle_HBar = MUIB_MUI or $42c943;


MUIA_Rectangle_VBar

Declaration

Source position: mui.pas line 1868

const MUIA_Rectangle_VBar = MUIB_MUI or $422204;


MUIA_Register_Columns

Declaration

Source position: mui.pas line 2163

const MUIA_Register_Columns = MUIB_Register or $0;


MUIA_Register_Frame

Declaration

Source position: mui.pas line 2160

const MUIA_Register_Frame = MUIB_MUI or $42349b;


MUIA_Register_Titles

Declaration

Source position: mui.pas line 2161

const MUIA_Register_Titles = MUIB_MUI or $4297ec;


MUIA_Revision

Declaration

Source position: mui.pas line 779

const MUIA_Revision = MUIB_MUI or $427eaa;


MUIA_RightEdge

Declaration

Source position: mui.pas line 1676

const MUIA_RightEdge = MUIB_MUI or $42ba82;


MUIA_Scale_Horiz

Declaration

Source position: mui.pas line 3200

const MUIA_Scale_Horiz = MUIB_MUI or $42919a;


MUIA_Scrollbar_Type

Declaration

Source position: mui.pas line 2143

const MUIA_Scrollbar_Type = MUIB_MUI or $42fb6b;


MUIA_Scrollbutton_Horiz

Declaration

Source position: mui.pas line 2326

const MUIA_Scrollbutton_Horiz = MUIB_Scrollbutton or $1;


MUIA_Scrollbutton_HorizProp

Declaration

Source position: mui.pas line 2328

const MUIA_Scrollbutton_HorizProp = MUIB_Scrollbutton or $3;


MUIA_Scrollbutton_NewPosition

Declaration

Source position: mui.pas line 2325

const MUIA_Scrollbutton_NewPosition = MUIB_Scrollbutton or $0;


MUIA_Scrollbutton_Vert

Declaration

Source position: mui.pas line 2327

const MUIA_Scrollbutton_Vert = MUIB_Scrollbutton or $2;


MUIA_Scrollbutton_VertProp

Declaration

Source position: mui.pas line 2329

const MUIA_Scrollbutton_VertProp = MUIB_Scrollbutton or $4;


MUIA_Scrollgroup_Contents

Declaration

Source position: mui.pas line 2308

const MUIA_Scrollgroup_Contents = MUIB_MUI or $421261;


MUIA_Scrollgroup_FreeHoriz

Declaration

Source position: mui.pas line 2309

const MUIA_Scrollgroup_FreeHoriz = MUIB_MUI or $4292f3;


MUIA_Scrollgroup_FreeVert

Declaration

Source position: mui.pas line 2310

const MUIA_Scrollgroup_FreeVert = MUIB_MUI or $4224f2;


MUIA_Scrollgroup_HorizBar

Declaration

Source position: mui.pas line 2311

const MUIA_Scrollgroup_HorizBar = MUIB_MUI or $42b63d;


MUIA_Scrollgroup_UseWinBorder

Declaration

Source position: mui.pas line 2312

const MUIA_Scrollgroup_UseWinBorder = MUIB_MUI or $4284c1;


MUIA_Scrollgroup_VertBar

Declaration

Source position: mui.pas line 2313

const MUIA_Scrollgroup_VertBar = MUIB_MUI or $42cdc0;


MUIA_Selected

Declaration

Source position: mui.pas line 1677

const MUIA_Selected = MUIB_MUI or $42654b;


MUIA_ShortHelp

Declaration

Source position: mui.pas line 1678

const MUIA_ShortHelp = MUIB_MUI or $428fe3;


MUIA_ShowMe

Declaration

Source position: mui.pas line 1679

const MUIA_ShowMe = MUIB_MUI or $429ba8;


MUIA_ShowSelState

Declaration

Source position: mui.pas line 1680

const MUIA_ShowSelState = MUIB_MUI or $42caac;


MUIA_Slider_Horiz

Declaration

Source position: mui.pas line 1989

const MUIA_Slider_Horiz = $8042fad1;


MUIA_Slider_Quiet

Declaration

Source position: mui.pas line 1990

const MUIA_Slider_Quiet = $80420b26;


MUIA_String_Accept

Declaration

Source position: mui.pas line 2009

const MUIA_String_Accept = MUIB_MUI or $42e3e1;


MUIA_String_Acknowledge

Declaration

Source position: mui.pas line 2010

const MUIA_String_Acknowledge = MUIB_MUI or $42026c;


MUIA_String_AdvanceOnCR

Declaration

Source position: mui.pas line 2011

const MUIA_String_AdvanceOnCR = MUIB_MUI or $4226de;


MUIA_String_AttachedList

Declaration

Source position: mui.pas line 2012

const MUIA_String_AttachedList = MUIB_MUI or $420fd2;


MUIA_String_BufferPos

Declaration

Source position: mui.pas line 2013

const MUIA_String_BufferPos = MUIB_MUI or $428b6c;


MUIA_String_Columns

Declaration

Source position: mui.pas line 2031

const MUIA_String_Columns = $ad001005;


MUIA_String_Contents

Declaration

Source position: mui.pas line 2014

const MUIA_String_Contents = MUIB_MUI or $428ffd;


MUIA_String_DisplayPos

Declaration

Source position: mui.pas line 2015

const MUIA_String_DisplayPos = MUIB_MUI or $42ccbf;


MUIA_String_EditHook

Declaration

Source position: mui.pas line 2016

const MUIA_String_EditHook = MUIB_MUI or $424c33;


MUIA_String_Format

Declaration

Source position: mui.pas line 2017

const MUIA_String_Format = MUIB_MUI or $427484;


MUIA_String_Integer

Declaration

Source position: mui.pas line 2018

const MUIA_String_Integer = MUIB_MUI or $426e8a;


MUIA_String_KeyDownFocus

Declaration

Source position: mui.pas line 2036

const MUIA_String_KeyDownFocus = $ad001009;


MUIA_String_KeyUpFocus

Declaration

Source position: mui.pas line 2035

const MUIA_String_KeyUpFocus = $ad001008;


MUIA_String_LonelyEditHook

Declaration

Source position: mui.pas line 2019

const MUIA_String_LonelyEditHook = MUIB_MUI or $421569;


MUIA_String_MaxLen

Declaration

Source position: mui.pas line 2020

const MUIA_String_MaxLen = MUIB_MUI or $424984;


MUIA_String_NoInput

Declaration

Source position: mui.pas line 2032

const MUIA_String_NoInput = $ad001007;


MUIA_String_Reject

Declaration

Source position: mui.pas line 2021

const MUIA_String_Reject = MUIB_MUI or $42179c;


MUIA_String_Secret

Declaration

Source position: mui.pas line 2022

const MUIA_String_Secret = MUIB_MUI or $428769;


MUIA_String_SelectSize

Declaration

Source position: mui.pas line 2033

const MUIA_String_SelectSize = $ad001001;


MUIA_String_StayActive

Declaration

Source position: mui.pas line 2034

const MUIA_String_StayActive = $ad001003;


MUIA_Text_Contents

Declaration

Source position: mui.pas line 1880

const MUIA_Text_Contents = MUIB_MUI or $42f8dc;


MUIA_Text_HiChar

Declaration

Source position: mui.pas line 1881

const MUIA_Text_HiChar = MUIB_MUI or $4218ff;


MUIA_Text_HiCharIdx

Declaration

Source position: mui.pas line 1882

const MUIA_Text_HiCharIdx = MUIB_MUI or $4214f5;


MUIA_Text_PreParse

Declaration

Source position: mui.pas line 1883

const MUIA_Text_PreParse = MUIB_MUI or $42566d;


MUIA_Text_SetMax

Declaration

Source position: mui.pas line 1884

const MUIA_Text_SetMax = MUIB_MUI or $424d0a;


MUIA_Text_SetMin

Declaration

Source position: mui.pas line 1885

const MUIA_Text_SetMin = MUIB_MUI or $424e10;


MUIA_Text_SetVMax

Declaration

Source position: mui.pas line 1886

const MUIA_Text_SetVMax = MUIB_MUI or $420d8b;


MUIA_Timer

Declaration

Source position: mui.pas line 1681

const MUIA_Timer = MUIB_MUI or $426435;


MUIA_TopEdge

Declaration

Source position: mui.pas line 1682

const MUIA_TopEdge = MUIB_MUI or $42509b;


MUIA_UserData

Declaration

Source position: mui.pas line 780

const MUIA_UserData = MUIB_MUI or $420313;


MUIA_Version

Declaration

Source position: mui.pas line 781

const MUIA_Version = MUIB_MUI or $422301;


MUIA_VertDisappear

Declaration

Source position: mui.pas line 1683

const MUIA_VertDisappear = MUIB_MUI or $42d12f;


MUIA_VertWeight

Declaration

Source position: mui.pas line 1684

const MUIA_VertWeight = MUIB_MUI or $4298d0;


MUIA_Virtgroup_Height

Declaration

Source position: mui.pas line 2292

const MUIA_Virtgroup_Height = MUIB_MUI or $423038;


MUIA_Virtgroup_Input

Declaration

Source position: mui.pas line 2293

const MUIA_Virtgroup_Input = MUIB_MUI or $427f7e;


MUIA_Virtgroup_Left

Declaration

Source position: mui.pas line 2294

const MUIA_Virtgroup_Left = MUIB_MUI or $429371;


MUIA_Virtgroup_Top

Declaration

Source position: mui.pas line 2295

const MUIA_Virtgroup_Top = MUIB_MUI or $425200;


MUIA_Virtgroup_Width

Declaration

Source position: mui.pas line 2296

const MUIA_Virtgroup_Width = MUIB_MUI or $427c49;


MUIA_Weight

Declaration

Source position: mui.pas line 1685

const MUIA_Weight = MUIB_MUI or $421d1f;


MUIA_Width

Declaration

Source position: mui.pas line 1686

const MUIA_Width = MUIB_MUI or $42b59c;


MUIA_Window

Declaration

Source position: mui.pas line 1687

const MUIA_Window = MUIB_MUI or $421591;


MUIA_Window_Activate

Declaration

Source position: mui.pas line 1279

const MUIA_Window_Activate = MUIB_MUI or $428d2f;


MUIA_Window_ActiveObject

Declaration

Source position: mui.pas line 1280

const MUIA_Window_ActiveObject = MUIB_MUI or $427925;


MUIA_Window_AltHeight

Declaration

Source position: mui.pas line 1281

const MUIA_Window_AltHeight = MUIB_MUI or $42cce3;


MUIA_Window_AltLeftEdge

Declaration

Source position: mui.pas line 1282

const MUIA_Window_AltLeftEdge = MUIB_MUI or $422d65;


MUIA_Window_AltTopEdge

Declaration

Source position: mui.pas line 1283

const MUIA_Window_AltTopEdge = MUIB_MUI or $42e99b;


MUIA_Window_AltWidth

Declaration

Source position: mui.pas line 1284

const MUIA_Window_AltWidth = MUIB_MUI or $4260f4;


MUIA_Window_AppWindow

Declaration

Source position: mui.pas line 1285

const MUIA_Window_AppWindow = MUIB_MUI or $4280cf;


MUIA_Window_Backdrop

Declaration

Source position: mui.pas line 1286

const MUIA_Window_Backdrop = MUIB_MUI or $42c0bb;


MUIA_Window_Borderless

Declaration

Source position: mui.pas line 1287

const MUIA_Window_Borderless = MUIB_MUI or $429b79;


MUIA_Window_CloseGadget

Declaration

Source position: mui.pas line 1288

const MUIA_Window_CloseGadget = MUIB_MUI or $42a110;


MUIA_Window_CloseRequest

Declaration

Source position: mui.pas line 1289

const MUIA_Window_CloseRequest = MUIB_MUI or $42e86e;


MUIA_Window_DefaultObject

Declaration

Source position: mui.pas line 1290

const MUIA_Window_DefaultObject = MUIB_MUI or $4294d7;


MUIA_Window_DepthGadget

Declaration

Source position: mui.pas line 1291

const MUIA_Window_DepthGadget = MUIB_MUI or $421923;


MUIA_Window_DisableKeys

Declaration

Source position: mui.pas line 1292

const MUIA_Window_DisableKeys = MUIB_MUI or $424c36;


MUIA_Window_DragBar

Declaration

Source position: mui.pas line 1293

const MUIA_Window_DragBar = MUIB_MUI or $42045d;


MUIA_Window_EraseArea

Declaration

Source position: mui.pas line 1323

const MUIA_Window_EraseArea = MUIB_Window or $0;


MUIA_Window_FancyDrawing

Declaration

Source position: mui.pas line 1294

const MUIA_Window_FancyDrawing = MUIB_MUI or $42bd0e;


MUIA_Window_Height

Declaration

Source position: mui.pas line 1295

const MUIA_Window_Height = MUIB_MUI or $425846;


MUIA_Window_ID

Declaration

Source position: mui.pas line 1296

const MUIA_Window_ID = MUIB_MUI or $4201bd;


MUIA_Window_InputEvent

Declaration

Source position: mui.pas line 1297

const MUIA_Window_InputEvent = MUIB_MUI or $4247d8;


MUIA_Window_IsSubWindow

Declaration

Source position: mui.pas line 1298

const MUIA_Window_IsSubWindow = MUIB_MUI or $42b5aa;


MUIA_Window_LeftEdge

Declaration

Source position: mui.pas line 1299

const MUIA_Window_LeftEdge = MUIB_MUI or $426c65;


MUIA_Window_MenuAction

Declaration

Source position: mui.pas line 1301

const MUIA_Window_MenuAction = MUIB_MUI or $427521;


MUIA_Window_Menustrip

Declaration

Source position: mui.pas line 1302

const MUIA_Window_Menustrip = MUIB_MUI or $42855e;


MUIA_Window_MouseObject

Declaration

Source position: mui.pas line 1303

const MUIA_Window_MouseObject = MUIB_MUI or $42bf9b;


MUIA_Window_NeedsMouseObject

Declaration

Source position: mui.pas line 1304

const MUIA_Window_NeedsMouseObject = MUIB_MUI or $42372a;


MUIA_Window_NoMenus

Declaration

Source position: mui.pas line 1305

const MUIA_Window_NoMenus = MUIB_MUI or $429df5;


MUIA_Window_Open

Declaration

Source position: mui.pas line 1306

const MUIA_Window_Open = MUIB_MUI or $428aa0;


MUIA_Window_PublicScreen

Declaration

Source position: mui.pas line 1307

const MUIA_Window_PublicScreen = MUIB_MUI or $4278e4;


MUIA_Window_RefWindow

Declaration

Source position: mui.pas line 1308

const MUIA_Window_RefWindow = MUIB_MUI or $4201f4;


MUIA_Window_RootObject

Declaration

Source position: mui.pas line 1309

const MUIA_Window_RootObject = MUIB_MUI or $42cba5;


MUIA_Window_Screen

Declaration

Source position: mui.pas line 1310

const MUIA_Window_Screen = MUIB_MUI or $42df4f;


MUIA_Window_ScreenTitle

Declaration

Source position: mui.pas line 1311

const MUIA_Window_ScreenTitle = MUIB_MUI or $4234b0;


MUIA_Window_SizeGadget

Declaration

Source position: mui.pas line 1312

const MUIA_Window_SizeGadget = MUIB_MUI or $42e33d;


MUIA_Window_SizeRight

Declaration

Source position: mui.pas line 1313

const MUIA_Window_SizeRight = MUIB_MUI or $424780;


MUIA_Window_Sleep

Declaration

Source position: mui.pas line 1314

const MUIA_Window_Sleep = MUIB_MUI or $42e7db;


MUIA_Window_Title

Declaration

Source position: mui.pas line 1315

const MUIA_Window_Title = MUIB_MUI or $42ad3d;


MUIA_Window_ToolBox

Declaration

Source position: mui.pas line 1325

const MUIA_Window_ToolBox = MUIB_Window or $3;


MUIA_Window_TopEdge

Declaration

Source position: mui.pas line 1316

const MUIA_Window_TopEdge = MUIB_MUI or $427c66;


MUIA_Window_UseBottomBorderScroller

Declaration

Source position: mui.pas line 1317

const MUIA_Window_UseBottomBorderScroller = MUIB_MUI or $424e79;


MUIA_Window_UseLeftBorderScroller

Declaration

Source position: mui.pas line 1318

const MUIA_Window_UseLeftBorderScroller = MUIB_MUI or $42433e;


MUIA_Window_UseRightBorderScroller

Declaration

Source position: mui.pas line 1319

const MUIA_Window_UseRightBorderScroller = MUIB_MUI or $42c05e;


MUIA_Window_Width

Declaration

Source position: mui.pas line 1320

const MUIA_Window_Width = MUIB_MUI or $42dcae;


MUIA_Window_Window

Declaration

Source position: mui.pas line 1321

const MUIA_Window_Window = MUIB_MUI or $426a42;


MUIA_Window_ZoomGadget

Declaration

Source position: mui.pas line 1324

const MUIA_Window_ZoomGadget = MUIB_Window or $2;


MUIA_WindowObject

Declaration

Source position: mui.pas line 1688

const MUIA_WindowObject = MUIB_MUI or $42669e;


MUIB_Aboutmui

Declaration

Source position: mui.pas line 2899

const MUIB_Aboutmui = MUIB_ZUNE or $0;


MUIB_Application

Declaration

Source position: mui.pas line 870

const MUIB_Application = MUIB_ZUNE or $00000100;


MUIB_Area

Declaration

Source position: mui.pas line 1368

const MUIB_Area = MUIB_ZUNE or $00000200;


MUIB_AROS

Declaration

Source position: mui.pas line 130

const MUIB_AROS = MUIB_RSVD or $00070000;


MUIB_Balance

Declaration

Source position: mui.pas line 3221

const MUIB_Balance = MUIB_ZUNE or $00000300;


MUIB_Bitmap

Declaration

Source position: mui.pas line 2379

const MUIB_Bitmap = MUIB_ZUNE or $00000400;


MUIB_Bodychunk

Declaration

Source position: mui.pas line 2400

const MUIB_Bodychunk = MUIB_ZUNE or $00000500;


MUIB_Boopsi

Declaration

Source position: mui.pas line 2073

const MUIB_Boopsi = MUIB_ZUNE or $00000600;


MUIB_ChunkyImage

Declaration

Source position: mui.pas line 2415

const MUIB_ChunkyImage = MUIB_ZUNE or $00004000;


MUIB_Coloradjust

Declaration

Source position: mui.pas line 3310

const MUIB_Coloradjust = MUIB_ZUNE or $00000700;


MUIB_Colorfield

Declaration

Source position: mui.pas line 3294

const MUIB_Colorfield = MUIB_ZUNE or $00000800;


MUIB_Configdata

Declaration

Source position: mui.pas line 2911

const MUIB_Configdata = MUIB_ZUNE or $00000900;


MUIB_Cycle

Declaration

Source position: mui.pas line 2782

const MUIB_Cycle = MUIB_ZUNE or $00000a00;


MUIB_Dataspace

Declaration

Source position: mui.pas line 2220

const MUIB_Dataspace = MUIB_ZUNE or $00000b00;


MUIB_Dirlist

Declaration

Source position: mui.pas line 3369

const MUIB_Dirlist = MUIB_ZUNE or $00001800;


MUIB_Family

Declaration

Source position: mui.pas line 790

const MUIB_Family = MUIB_ZUNE or $00000c00;


MUIB_Floattext

Declaration

Source position: mui.pas line 2706

const MUIB_Floattext = MUIB_ZUNE or $00001500;


MUIB_Frameadjust

Declaration

Source position: mui.pas line 3331

const MUIB_Frameadjust = MUIB_ZUNE or $00000d00;


MUIB_Framedisplay

Declaration

Source position: mui.pas line 3342

const MUIB_Framedisplay = MUIB_ZUNE or $00000e00;


MUIB_Gauge

Declaration

Source position: mui.pas line 2798

const MUIB_Gauge = MUIB_ZUNE or $00000f00;


MUIB_Group

Declaration

Source position: mui.pas line 1756

const MUIB_Group = MUIB_ZUNE or $00001000;


MUIB_Image

Declaration

Source position: mui.pas line 2816

const MUIB_Image = MUIB_ZUNE or $00001300;


MUIB_Imageadjust

Declaration

Source position: mui.pas line 3168

const MUIB_Imageadjust = MUIB_ZUNE or $00001100;


MUIB_Imagedisplay

Declaration

Source position: mui.pas line 2835

const MUIB_Imagedisplay = MUIB_ZUNE or $00001200;


MUIB_List

Declaration

Source position: mui.pas line 2463

const MUIB_List = MUIB_ZUNE or $00001400;


MUIB_Listview

Declaration

Source position: mui.pas line 2430

const MUIB_Listview = MUIB_ZUNE or $00001900;


MUIB_Menu

Declaration

Source position: mui.pas line 2183

const MUIB_Menu = MUIB_ZUNE or $00001b00;


MUIB_Menuitem

Declaration

Source position: mui.pas line 2196

const MUIB_Menuitem = MUIB_ZUNE or $00001c00;


MUIB_Menustrip

Declaration

Source position: mui.pas line 2171

const MUIB_Menustrip = MUIB_ZUNE or $00001a00;


MUIB_MUI

Declaration

Source position: mui.pas line 127

const MUIB_MUI = TAG_USER;


MUIB_Notify

Declaration

Source position: mui.pas line 612

const MUIB_Notify = MUIB_ZUNE or $00001d00;


MUIB_Numeric

Declaration

Source position: mui.pas line 1907

const MUIB_Numeric = MUIB_ZUNE or $00001e00;


MUIB_Palette

Declaration

Source position: mui.pas line 3462

const MUIB_Palette = MUIB_ZUNE or $00008a00;


MUIB_Penadjust

Declaration

Source position: mui.pas line 3274

const MUIB_Penadjust = MUIB_ZUNE or $00001f00;


MUIB_Pendisplay

Declaration

Source position: mui.pas line 3232

const MUIB_Pendisplay = MUIB_ZUNE or $00002000;


MUIB_Pixmap

Declaration

Source position: mui.pas line 3536

const MUIB_Pixmap = MUIB_ZUNE or $00003600;


MUIB_Popasl

Declaration

Source position: mui.pas line 2850

const MUIB_Popasl = MUIB_ZUNE or $00002100;


MUIB_Popframe

Declaration

Source position: mui.pas line 3353

const MUIB_Popframe = MUIB_ZUNE or $00002200;


MUIB_Popimage

Declaration

Source position: mui.pas line 3188

const MUIB_Popimage = MUIB_ZUNE or $00002300;


MUIB_Poplist

Declaration

Source position: mui.pas line 3423

const MUIB_Poplist = MUIB_ZUNE or $00002500;


MUIB_Popobject

Declaration

Source position: mui.pas line 2764

const MUIB_Popobject = MUIB_ZUNE or $00002400;


MUIB_Poppen

Declaration

Source position: mui.pas line 3286

const MUIB_Poppen = MUIB_ZUNE or $00002700;


MUIB_Popscreen

Declaration

Source position: mui.pas line 3435

const MUIB_Popscreen = MUIB_ZUNE or $00002600;


MUIB_Popstring

Declaration

Source position: mui.pas line 2731

const MUIB_Popstring = MUIB_ZUNE or $00002800;


MUIB_Prop

Declaration

Source position: mui.pas line 2096

const MUIB_Prop = MUIB_ZUNE or $00002900;


MUIB_Radio

Declaration

Source position: mui.pas line 3208

const MUIB_Radio = MUIB_ZUNE or $00002a00;


MUIB_Rectangle

Declaration

Source position: mui.pas line 1862

const MUIB_Rectangle = MUIB_ZUNE or $00002b00;


MUIB_Register

Declaration

Source position: mui.pas line 2156

const MUIB_Register = MUIB_ZUNE or $00002c00;


MUIB_RSVD

Declaration

Source position: mui.pas line 128

const MUIB_RSVD = MUIB_MUI or $10400000;


MUIB_Scale

Declaration

Source position: mui.pas line 3196

const MUIB_Scale = MUIB_ZUNE or $00002d00;


MUIB_Scrmodelist

Declaration

Source position: mui.pas line 2698

const MUIB_Scrmodelist = MUIB_ZUNE or $00001700;


MUIB_Scrollbar

Declaration

Source position: mui.pas line 2139

const MUIB_Scrollbar = MUIB_ZUNE or $00002e00;


MUIB_Scrollbutton

Declaration

Source position: mui.pas line 2321

const MUIB_Scrollbutton = MUIB_ZUNE or $00004100;


MUIB_Scrollgroup

Declaration

Source position: mui.pas line 2304

const MUIB_Scrollgroup = MUIB_ZUNE or $00002f00;


MUIB_Semaphore

Declaration

Source position: mui.pas line 2337

const MUIB_Semaphore = MUIB_ZUNE or $00003000;


MUIB_Settings

Declaration

Source position: mui.pas line 2891

const MUIB_Settings = MUIB_ZUNE or $00003200;


MUIB_Settingsgroup

Declaration

Source position: mui.pas line 2865

const MUIB_Settingsgroup = MUIB_ZUNE or $00003100;


MUIB_Slider

Declaration

Source position: mui.pas line 1985

const MUIB_Slider = MUIB_ZUNE or $00003300;


MUIB_String

Declaration

Source position: mui.pas line 2005

const MUIB_String = MUIB_ZUNE or $00003400;


MUIB_Text

Declaration

Source position: mui.pas line 1876

const MUIB_Text = MUIB_ZUNE or $00003500;


MUIB_Virtgroup

Declaration

Source position: mui.pas line 2288

const MUIB_Virtgroup = MUIB_ZUNE or $00003700;


MUIB_Volumelist

Declaration

Source position: mui.pas line 3361

const MUIB_Volumelist = MUIB_ZUNE or $1600;


MUIB_Window

Declaration

Source position: mui.pas line 1116

const MUIB_Window = MUIB_ZUNE or $00003600;


MUIB_ZUNE

Declaration

Source position: mui.pas line 129

const MUIB_ZUNE = MUIB_RSVD or $00020000;


MUIC_Aboutmui

Declaration

Source position: mui.pas line 2896

const MUIC_Aboutmui: PChar = 'Aboutmui.mui';


MUIC_Application

Declaration

Source position: mui.pas line 867

const MUIC_Application: PChar = 'Application.mui';

Description

Inheritance
rootclass --> Notify --> Application

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Application_Active | ISG | BOOL (0/1) | This attribute reflects the state that the user adjusted with commodities Exchange.
MUIA_Application_Author | I_G | PChar | Name of the applications author.
MUIA_Application_Base | I_G | PChar | The basename for an application.
MUIA_Application_Broker | __G | PBroker | Obtain a pointer to the applications Broker structure.
MUIA_Application_BrokerHook | ISG | PHook | The function will be called whenever a commodities message arrives.
MUIA_Application_BrokerPort | __G | PMsgPort | Get a pointer to the applications commodities message port.
MUIA_Application_BrokerPri | I_G | LongInt | Adjust the priority of an applications broker.
MUIA_Application_Commands | ISG | PMUI_Command | Include its own set of ARexx commands.
MUIA_Application_Copyright | I_G | PChar | A copyright string, containing the year and the company.
MUIA_Application_Description | I_G | PChar | Short description
MUIA_Application_DiskObject | ISG | PChar | Defines AppIcon when your application gets iconified.
MUIA_Application_DoubleStart | __G | BOOL (0/1) | Set if application get started twice. (Single Task App)
MUIA_Application_DropObject | IS_ | PObject_ | Object dropped on your AppIcon
MUIA_Application_ForceQuit | __G | BOOL (0/1) | Quit program without requesters.
MUIA_Application_HelpFile | ISG | PChar | Define AmigaGuide file as Help file.
MUIA_Application_Iconified | _SG | BOOL (0/1) | Iconify the application.
MUIA_Application_MenuAction | __G | LongWord | UserData of selected menu item
MUIA_Application_MenuHelp | __G | LongWord | UserData of menu item selected and Help key pressed.
MUIA_Application_Menustrip | I__ | PObject_ | Specify a menu strip object for the application.
MUIA_Application_RexxHook | ISG | PHook | Hook for arriving Rexx messages.
MUIA_Application_RexxMsg | __G | PRxMsg | Rexx message for arriving Rexx messages.
MUIA_Application_RexxString | _S_ | PChar | ARexx allows returning a string as result of a function call.
MUIA_Application_SingleTask | I__ | BOOL (0/1) | Define application as single task program.
MUIA_Application_Sleep | _S_ | BOOL (0/1) | This attribute can be used to put a whole application to sleep.
MUIA_Application_Title | I_G | PChar | Defines the title of an application.
MUIA_Application_UseCommodities | I__ | BOOL (0/1) | When set to False, the application will run without a commodities interface.
MUIA_Application_UsedClasses | ISG | PChar | Tell the MUI system what external classes your application might use.
MUIA_Application_UseRexx | I__ | BOOL (0/1) | When set to FALSE, the application will run without an ARexx interface.
MUIA_Application_Version | I_G | PChar | Define a version string for an application.
MUIA_Application_Window | I__ | PChar | A pointer to a MUI object of Window class.
MUIA_Application_WindowList | __G | PList | List of children (i.e. windows) of an application.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Application_AboutMUI | Show the MUI about window.
MUIM_Application_AddInputHandler | Set Input Handler for custom classes.
MUIM_Application_CheckRefresh | Check all currently open windows if they need refreshing and refreshes them if necessary.
MUIM_Application_InputBuffered | Buffer user input.
MUIM_Application_Load | Load programs configuration.
MUIM_Application_NewInput | This is an enhanced replacement for MUIM_Application_Input.
MUIM_Application_OpenConfigWindow | Open applications own MUI configuration.
MUIM_Application_PushMethod | Push method from second task to main task.
MUIM_Application_RemInputHandler | Remove Input Handler for custom classes.
MUIM_Application_ReturnID | Tell MUI to return the given id with the next call to MUIM_Application_NewInput.
MUIM_Application_Save | Save programs configuration.
MUIM_Application_SetConfigItem | Private Method for PSI.
MUIM_Application_ShowHelp | Show an AmigaGuide help file.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Applist

Declaration

Source position: mui.pas line 3585

const MUIC_Applist: PChar = 'Applist.mui';


MUIC_Area

Area class is a super class for every other MUI class except windows and applications.

Declaration

Source position: mui.pas line 1365

const MUIC_Area: PChar = 'Area.mui';

Description

Area class is a super class for every other MUI class except windows and applications. It holds information about an objects current position, size and weight and manages frames, fonts and backgrounds.

Additionally, area class handles the user input. By setting an objects MUIA_InputMode, you can make it behave like a button or like a toggle gadget. That's why MUI doesn't offer an extra button class. A button is simply a text object with a raised frame and a relverify input mode. Since especially group class is a subclass of area, you can create rather complex buttons consisting of many other display elements.

Inheritance
rootclass --> Notify --> Area

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Balance

Declaration

Source position: mui.pas line 3218

const MUIC_Balance: PChar = 'Balance.mui';

Description

The balance class is very simple and has no attributes. Simply insert objects of this class somewhere in your group (only horizontal or vertical groups, nothing 2-dimensional) allows your users to dynamically change the weight of your children.

Inheritance
rootclass --> Notify --> Area --> Balance

Fields
_______________ Field _______________ ___ Access ___ _____ Type _____ Short description
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Bitmap

Include a self-made image data in MUI applications.

Declaration

Source position: mui.pas line 2376

const MUIC_Bitmap: PChar = 'Bitmap.mui';

Description

The Bitmap class allows including self-made image data in MUI applications. Usually, image class was intended to be used for this purpose but unfortunately, its design was not very useful.

In its most simple usage, Bitmap class just display a given BitMap. However, you can also tell it to do automatic color remapping to match the current display context and you can define a transparent color to make the BitMap appear on any background.

Inheritance
rootclass --> Notify --> Area --> Bitmap

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Bitmap_Bitmap | ISG | PBitmap | This attribute specifies a pointer to a struct BitMap.
MUIA_Bitmap_Height | ISG | LongInt | Define the pixel height of the BitMap.
MUIA_Bitmap_MappingTable | ISG | PByte | Address of an array of Bytes, one for each color of the source BitMap.
MUIA_Bitmap_Precision | ISG | LongInt | Specify the precision value for remapping images.
MUIA_Bitmap_RemappedBitmap | __G | PBitmap | Between MUIM_Setup and MUIM_Cleanup, this attribute will hold a pointer to the remapped bitmap.
MUIA_Bitmap_SourceColors | ISG | PLongWord | This attribute defines the color palette of the source BitMap.
MUIA_Bitmap_Transparent | ISG | LongInt | Use defined color as transparent color.
MUIA_Bitmap_UseFriend | I__ | BOOL (0/1) | Try to allocate the remapped bitmap in a way that allows fastest displaying.
MUIA_Bitmap_Width | ISG | LongInt | Define the pixel width of the BitMap.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Bodychunk

Declaration

Source position: mui.pas line 2397

const MUIC_Bodychunk: PChar = 'Bodychunk.mui';

Description

Big and colorful images (e.g. About-Logos) usually take lots of space when stored in a traditional BitMap structure. To save memory, you can decide to have the picture compressed in your code and use the Bodychunk class instead of the Bitmap class for displaying. MUI will then automatically decompress your image when its about to appear in a window.

Since Bodychunk class is a subclass of Bitmap class, you can of course use all the Bitmaps remapping and transparency features.

Inheritance
rootclass --> Notify --> Area --> Bitmap --> Bodychunk

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Bodychunk_Body | ISG | PByte | Specify a pointer to the BODY data of your picture.
MUIA_Bodychunk_Compression | ISG | Byte | Specify compression of the Body.
MUIA_Bodychunk_Depth | ISG | LongInt | Specify the depth of your picture.
MUIA_Bodychunk_Masking | ISG | Byte | Indicate if your BODY data contains a masking plane.
Fields inherited from Bitmap
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Bitmap_Bitmap | ISG | PBitmap | This attribute specifies a pointer to a struct BitMap.
MUIA_Bitmap_Height | ISG | LongInt | Define the pixel height of the BitMap.
MUIA_Bitmap_MappingTable | ISG | PByte | Address of an array of Bytes, one for each color of the source BitMap.
MUIA_Bitmap_Precision | ISG | LongInt | Specify the precision value for remapping images.
MUIA_Bitmap_RemappedBitmap | __G | PBitmap | Between MUIM_Setup and MUIM_Cleanup, this attribute will hold a pointer to the remapped bitmap.
MUIA_Bitmap_SourceColors | ISG | PLongWord | This attribute defines the color palette of the source BitMap.
MUIA_Bitmap_Transparent | ISG | LongInt | Use defined color as transparent color.
MUIA_Bitmap_UseFriend | I__ | BOOL (0/1) | Try to allocate the remapped bitmap in a way that allows fastest displaying.
MUIA_Bitmap_Width | ISG | LongInt | Define the pixel width of the BitMap.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Boopsi

MUI's boopsi class provides an interface to standard, system style boopsi gadgets.

Declaration

Source position: mui.pas line 2070

const MUIC_Boopsi: PChar = 'Boopsi.mui';

Description

Since boopsis gadgetclass misses some important features needed for an automatic layout system like MUI, there are several problems with such an interface. MUI tries to solve these problems with some additional attributes.

Coming with release 3.x of the amiga operating system are some very nice boopsi gadgets such as "colorwheel.gadget" or "gradientslider.gadget". With MUI's boopsi class, you can use these gadgets just as if they were MUI objects.

You can talk to a MUIized boopsi object as if it was the boopsi object itself. MUI will pass through all attributes and try to be completely transparent. Additionally, if a boopsi object generates notification events via IDCMP_UPDATE, MUI turns them into MUI notification events. Thus, you can e.g. react on the change of WHEEL_Saturation in a MUI colorwheel boopsi gadget as on any other MUI attribute.

An example program "BoopsiDoor.c" is provided to show how this magic works.

Note: OS 3.0/3.1 colorwheel.gadget can accidently render itself one pixel too big, overwriting other parts of the window. As a workaround, MUI will subtract one from the width/height before passing it on to a colorwheel boopsi object.

Inheritance
rootclass --> Notify --> Area --> Gadget --> Boopsi

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Boopsi_Class | ISG | PIClass | Pointer to the (private) class you want to create a boopsi object from.
MUIA_Boopsi_ClassID | ISG | PChar | Name of the Boopsi class you want to create an object of.
MUIA_Boopsi_MaxHeight | ISG | LongWord | Maximal height for the boopsi gadget.
MUIA_Boopsi_MaxWidth | ISG | LongWord | Maximal width for the boopsi gadget.
MUIA_Boopsi_MinHeight | ISG | LongWord | Minimum Height for the boopsi gadget.
MUIA_Boopsi_MinWidth | ISG | LongWord | Minimum Width for the boopsi gadget.
MUIA_Boopsi_Object | __G | PObject_ | MUI returns when generating a BoopsiObject is a standard MUI object.
MUIA_Boopsi_Remember | I__ | LongWord | Attributes must be remembered during dispose/regeneration.
MUIA_Boopsi_Smart | I__ | BOOL (0/1) | Smart BOOPSI gadgets that allow resizing.
MUIA_Boopsi_TagDrawInfo | ISG | LongWord | Tell MUI where to fill in a needed DrawInfo structure.
MUIA_Boopsi_TagScreen | ISG | LongWord | Tell MUI where to fill in a needed Screen structure.
MUIA_Boopsi_TagWindow | ISG | LongWord | Tell MUI where to fill in a needed Window structure.
Fields inherited from Gadget
MUIA_Gadget_Gadget __G PGadget Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Cclist

Declaration

Source position: mui.pas line 3590

const MUIC_Cclist: PChar = 'Cclist.mui';


MUIC_ChunkyImage

Declaration

Source position: mui.pas line 2412

const MUIC_ChunkyImage: PChar = 'ChunkyImage.mui';


MUIC_Coloradjust

Declaration

Source position: mui.pas line 3307

const MUIC_Coloradjust: PChar = 'Coloradjust.mui';


MUIC_Colorfield

Declaration

Source position: mui.pas line 3291

const MUIC_Colorfield: PChar = 'Colorfield.mui';


MUIC_Configdata

Declaration

Source position: mui.pas line 2908

const MUIC_Configdata: PChar = 'Configdata.mui';


MUIC_Crawling

Declaration

Source position: mui.pas line 3440

const MUIC_Crawling: PChar = 'Crawling.mui';


MUIC_Cycle

Declaration

Source position: mui.pas line 2779

const MUIC_Cycle: PChar = 'Cycle.mui';


MUIC_Dataspace

Declaration

Source position: mui.pas line 2217

const MUIC_Dataspace: PChar = 'Dataspace.mui';


MUIC_Dirlist

Declaration

Source position: mui.pas line 3366

const MUIC_Dirlist: PChar = 'Dirlist.mui';


MUIC_Dtpic

Declaration

Source position: mui.pas line 3459

const MUIC_Dtpic: PChar = 'Dtpic.mui';


MUIC_Family

Family class is the base class for objects that are able to handle a list of children.

Declaration

Source position: mui.pas line 787

const MUIC_Family: PChar = 'Family.mui';

Description

Family class is the base class for objects that are able to handle a list of children. This is e.g. the case for MUIs Menustrip, Menu and Menuitem objects.

Family class defines methods and attributes to add and remove children, sort children, and transfer children to other Family objects.

Group class and application class should also be a subclass of Family class, but due to BOOPSI system limitations, this is currently impossible. If the future will allow more logical class trees, things might change, but everything will be done in a compatible manner.

Inheritance
rootclass --> Notify --> Family

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Floattext

Declaration

Source position: mui.pas line 2703

const MUIC_Floattext: PChar = 'Floattext.mui';


MUIC_Frameadjust

Declaration

Source position: mui.pas line 3328

const MUIC_Frameadjust: PChar = 'Frameadjust.mui';


MUIC_Framedisplay

Declaration

Source position: mui.pas line 3339

const MUIC_Framedisplay: PChar = 'Framedisplay.mui';


MUIC_Gadget

This is the base class for intuition gadgets in MUI windows.

Declaration

Source position: mui.pas line 3576

const MUIC_Gadget: PChar = 'Gadget.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Gadget

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Gadget_Gadget | __G | PGadget | Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Gauge

A gauge object is a nice looking display element useful for some kind of progress display.

Declaration

Source position: mui.pas line 2795

const MUIC_Gauge: PChar = 'Gauge.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Gauge

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Gauge_Current | ISG | LongInt | Set the current level of the gauge.
MUIA_Gauge_Divide | ISG | LongWord | Every value set with MUIA_Gauge_Current will be divided by this before further processing.
MUIA_Gauge_Horiz | I__ | BOOL (0/1) | Determine if you want a horizontal or vertical gauge.
MUIA_Gauge_InfoText | ISG | STRPTR | Text given here is displayed within a gauge object.
MUIA_Gauge_Max | ISG | LongInt | Set the maximum value for the gauge.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Group

Declaration

Source position: mui.pas line 1753

const MUIC_Group: PChar = 'Group.mui';


MUIC_Image

Image class is used to display one of MUI's standard images or some selfmade image data.

Declaration

Source position: mui.pas line 2813

const MUIC_Image: PChar = 'Image.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Image

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Image_FontMatch | I__ | BOOL (0/1) | Width and height of the given image will be scaled to match the current font.
MUIA_Image_FontMatchHeight | I__ | BOOL (0/1) | Height of the given image will be scaled to match the current font.
MUIA_Image_FontMatchWidth | I__ | BOOL (0/1) | Width of the given image will be scaled to match the current font.
MUIA_Image_FreeHoriz | I__ | BOOL (0/1) | Tell the image if its allowed to get scaled horizontally.
MUIA_Image_FreeVert | I__ | BOOL (0/1) | Tell the image if its allowed to get scaled vertically.
MUIA_Image_OldImage | I__ | PImage | Allows you to use any conventional image structure within a MUI window.
MUIA_Image_Spec | I__ | PChar | Specify the type of your image.
MUIA_Image_State | IS_ | LongInt | Select state of multi state images.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Imageadjust

Declaration

Source position: mui.pas line 3165

const MUIC_Imageadjust: PChar = 'Imageadjust.mui';


MUIC_Imagedisplay

Declaration

Source position: mui.pas line 2832

const MUIC_Imagedisplay: PChar = 'Imagedisplay.mui';


MUIC_Knob

Declaration

Source position: mui.pas line 3454

const MUIC_Knob: PChar = 'Knob.mui';


MUIC_Levelmeter

Declaration

Source position: mui.pas line 3445

const MUIC_Levelmeter: PChar = 'Levelmeter.mui';


MUIC_List

Declaration

Source position: mui.pas line 2460

const MUIC_List: PChar = 'List.mui';


MUIC_Listview

Declaration

Source position: mui.pas line 2427

const MUIC_Listview: PChar = 'Listview.mui';


MUIC_Mccprefs

Declaration

Source position: mui.pas line 3323

const MUIC_Mccprefs: PChar = 'Mccprefs.mui';


MUIC_Menu

Objects of menu class describe exactly one pulldown menu.

Declaration

Source position: mui.pas line 2180

const MUIC_Menu: PChar = 'Menu.mui';

Description

Objects of menu class describe exactly one pulldown menu. They don't feature many options themselves, but as a subclass of Family class, they act as father for their several menu item objects.

Inheritance
rootclass --> Notify --> Family --> Menu

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Menu_Enabled | ISG | BOOL (0/1) | Enable or disable the complete menu.
MUIA_Menu_Title | ISG | PChar | Describe the title of the menu.
Fields inherited from Family
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Family
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Menuitem

Declaration

Source position: mui.pas line 2193

const MUIC_Menuitem: PChar = 'Menuitem.mui';

Description

Menuitem class describes a single menu item. You can use all of the gadtools menus features expect Image menus here.

Since Menuitem class is a subclass of Family class, you can add other menu items as children of a menu item to indicate sub menus. MUI does not limit the level of sub menus, but the operating system currently allows a maximum nesting level of one. Because of this, children of menu items should not contain other menu items for now, the results are unpredictable.

Note: For handling menu items, MUIA_UserData and the methods MUIM_SetUData, MUIM_GetUData and MUIM_FindUData can become quite useful. See the Menu demo program and the accompanying documentation for details.

Inheritance
rootclass --> Notify --> Family --> MenuItem

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_MenuItem_Checked | ISG | BOOL (0/1) | Set/Get the checked state of a checkit menu item.
MUIA_Menuitem_Checkit | ISG | BOOL (0/1) | Set to True and this item will become a checkmarkable item.
MUIA_Menuitem_Enabled | ISG | BOOL (0/1) | Enabled/Disable the menu item.
MUIA_Menuitem_Exclude | ISG | LongInt | bitmask of menu item numbers that are to be deselected when this one is selected.
MUIA_Menuitem_Shortcut | ISG | PChar | Define the shortcut for a menu item.
MUIA_Menuitem_Title | ISG | PChar | Define the items title.
MUIA_Menuitem_Toggle | ISG | PChar | Define the state of the toggle flag for this item.
MUIA_Menuitem_Trigger | __G | PMenuItem | Trigger when menu item is selected.
Fields inherited from Family
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Family
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Menustrip

Menustrip class is the base class for MUI's object oriented menus.

Declaration

Source position: mui.pas line 2168

const MUIC_Menustrip: PChar = 'Menustrip.mui';

Description

Menustrip class is the base class for MUI's object oriented menus. Its children are objects of Menu class, each of them describes exactly one menu.

A Menustrip object doesn't feature many options itself, but as a subclass of Family class, it simply acts as father for multiple Menu objects.

The Menustrip object is usually specified as a child of either Application class or window class with the attributes MUIA_Application_Menustrip or MUIA_Window_Menustrip.

Inheritance
rootclass --> Notify --> Family --> MenuStrip

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Menustrip_Enabled | ISG | BOOL (0/1) | Enable or disable the complete menu strip.
Fields inherited from Family
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Family_Child | I__ | PObject_ | Add a child to family child list on creation
MUIA_Family_List | I__ | PMinList | Returns a pointer to a struct MinList which contains the children of a family object.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Family
_______________ Method _______________ | Short description
MUIM_Family_AddHead | Add an object as first object to the family.
MUIM_Family_AddTail | Add an object as last object to the family.
MUIM_Family_Insert | Add an object after another object to the family.
MUIM_Family_Remove | Remove an object from a family.
MUIM_Family_Sort | Sort the children of a family.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Notify

Notify class is superclass of all other MUI classes.

Declaration

Source position: mui.pas line 609

const MUIC_Notify: PChar = 'Notify.mui';

Description

Notify class is superclass of all other MUI classes. It's main purpose is to handle MUI's notification mechanism, but it also contains some other methods and attributes useful for every object.

Inheritance
rootclass --> Notify
Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class
Methods
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Numeric

Declaration

Source position: mui.pas line 1904

const MUIC_Numeric: PChar = 'Numeric.mui';


MUIC_Numericbutton

Declaration

Source position: mui.pas line 3415

const MUIC_Numericbutton: PChar = 'Numericbutton.mui';


MUIC_Palette

Declaration

Source position: mui.pas line 3475

const MUIC_Palette: PChar = 'Palette.mui';


MUIC_Penadjust

Declaration

Source position: mui.pas line 3271

const MUIC_Penadjust: PChar = 'Penadjust.mui';


MUIC_Pendisplay

Declaration

Source position: mui.pas line 3229

const MUIC_Pendisplay: PChar = 'Pendisplay.mui';


MUIC_Pixmap

Declaration

Source position: mui.pas line 3533

const MUIC_Pixmap: PChar = 'Pixmap.mui';


MUIC_Popasl

Declaration

Source position: mui.pas line 2847

const MUIC_Popasl: PChar = 'Popasl.mui';


MUIC_Popframe

Declaration

Source position: mui.pas line 3350

const MUIC_Popframe: PChar = 'Popframe.mui';


MUIC_Popimage

Declaration

Source position: mui.pas line 3185

const MUIC_Popimage: PChar = 'Popimage.mui';


MUIC_Poplist

Declaration

Source position: mui.pas line 3420

const MUIC_Poplist: PChar = 'Poplist.mui';


MUIC_Popobject

Declaration

Source position: mui.pas line 2761

const MUIC_Popobject: PChar = 'Popobject.mui';


MUIC_Poppen

Declaration

Source position: mui.pas line 3283

const MUIC_Poppen: PChar = 'Poppen.mui';


MUIC_Popscreen

Declaration

Source position: mui.pas line 3432

const MUIC_Popscreen: PChar = 'Popscreen.mui';


MUIC_Popstring

Declaration

Source position: mui.pas line 2728

const MUIC_Popstring: PChar = 'Popstring.mui';


MUIC_Process

Declaration

Source position: mui.pas line 3491

const MUIC_Process: PChar = 'Process.mui';


MUIC_Prop

Prop class generates the well known proportional gadgets.

Declaration

Source position: mui.pas line 2093

const MUIC_Prop: PChar = 'Prop.mui';

Description

It offers the same attributes as a usual boopsi gadget of propgclass. However, MUI's prop gadgets allow using any imagery for the knob and for the background.

Inheritance
rootclass --> Notify --> Area --> Gadget --> Prop

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Prop_Entries | ISG | LongInt | Set or get the total number of entries.
MUIA_Prop_First | ISG | LongInt | Set or get the number of the first entry.
MUIA_Prop_Horiz | ISG | BOOL (0/1) | Determine if you want a horizontal or a vertical prop gadget.
MUIA_Prop_Slider | ISG | BOOL (0/1) | Indicate that this prop gadget is used in a slider.
MUIA_Prop_UseWinBorder | I__ | LongInt | Link to one of the window border.
MUIA_Prop_Visible | ISG | LongInt | Set or get the number of visible entries.
Fields inherited from Prop
MUIA_Boopsi_Class | ISG | PIClass | Pointer to the (private) class you want to create a boopsi object from.
MUIA_Boopsi_ClassID | ISG | PChar | Name of the Boopsi class you want to create an object of.
MUIA_Boopsi_MaxHeight | ISG | LongWord | Maximal height for the boopsi gadget.
MUIA_Boopsi_MaxWidth | ISG | LongWord | Maximal width for the boopsi gadget.
MUIA_Boopsi_MinHeight | ISG | LongWord | Minimum Height for the boopsi gadget.
MUIA_Boopsi_MinWidth | ISG | LongWord | Minimum Width for the boopsi gadget.
MUIA_Boopsi_Object | __G | PObject_ | MUI returns when generating a BoopsiObject is a standard MUI object.
MUIA_Boopsi_Remember | I__ | LongWord | Attributes must be remembered during dispose/regeneration.
MUIA_Boopsi_Smart | I__ | BOOL (0/1) | Smart BOOPSI gadgets that allow resizing.
MUIA_Boopsi_TagDrawInfo | ISG | LongWord | Tell MUI where to fill in a needed DrawInfo structure.
MUIA_Boopsi_TagScreen | ISG | LongWord | Tell MUI where to fill in a needed Screen structure.
MUIA_Boopsi_TagWindow | ISG | LongWord | Tell MUI where to fill in a needed Window structure.
Fields inherited from Gadget
MUIA_Gadget_Gadget __G PGadget Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Prop_Decrease | This method decreases the value of a proportional gadget by the specified amount.
MUIM_Prop_Increase | This method increases the value of a proportional gadget by the specified amount.
Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Radio

Declaration

Source position: mui.pas line 3205

const MUIC_Radio: PChar = 'Radio.mui';


MUIC_Rectangle

Empty rectangle for space layout.

Declaration

Source position: mui.pas line 1859

const MUIC_Rectangle: PChar = 'Rectangle.mui';

Description

Rectangle class seems kind of useless since it doesn't define any attributes or methods itself. However, objects of this type are frequently used in every application. They allow insertion of space to control MUI's layout process.

Inheritance
rootclass --> Notify --> Area --> Rectangle

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Rectangle_BarTitle | I_G | PChar | Text displayed in group title style centered in the rectangle.
MUIA_Rectangle_HBar | I_G | BOOL (0/1) | Draw a horizontal bar in the middle of the rectangle.
MUIA_Rectangle_VBar | I_G | BOOL (0/1) | Draw a vertical bar in the middle of the rectangle.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Register

Declaration

Source position: mui.pas line 2153

const MUIC_Register: PChar = 'Register.mui';


MUIC_Scale

A Scale object generates a percentage scale running from 0% to 100%.

Declaration

Source position: mui.pas line 3193

const MUIC_Scale: PChar = 'Scale.mui';

Description

A Scale object generates a percentage scale running from 0% to 100%. A good place for such an object is e.g. below a fuel gauge.

Depending on how much space is available, the scale will be more or less detailed.

Due to MUI's automatic layout system, you don't need to worry about it's size. When placed in a vertical group just below the object you want to scale, everything is fine.

Inheritance
rootclass --> Notify --> Area --> Scale

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Scale_Horiz | ISG | BOOL (0/1) | Indicate whether you want a horizontal or a vertical scale.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Scrmodelist

Declaration

Source position: mui.pas line 2695

const MUIC_Scrmodelist: PChar = 'Scrmodelist.mui';


MUIC_Scrollbar

Declaration

Source position: mui.pas line 2136

const MUIC_Scrollbar: PChar = 'Scrollbar.mui';


MUIC_Scrollbutton

Declaration

Source position: mui.pas line 2318

const MUIC_Scrollbutton: PChar = 'Scrollbutton.mui';


MUIC_Scrollgroup

Declaration

Source position: mui.pas line 2301

const MUIC_Scrollgroup: PChar = 'Scrollgroup.mui';


MUIC_Semaphore

Declaration

Source position: mui.pas line 2334

const MUIC_Semaphore: PChar = 'Semaphore.mui';


MUIC_Settings

Declaration

Source position: mui.pas line 2888

const MUIC_Settings: PChar = 'Settings.mui';


MUIC_Settingsgroup

Declaration

Source position: mui.pas line 2862

const MUIC_Settingsgroup: PChar = 'Settingsgroup.mui';


MUIC_Slider

Declaration

Source position: mui.pas line 1982

const MUIC_Slider: PChar = 'Slider.mui';


MUIC_String

String class generates standard string gadgets with all editing facilities (clear, undo, etc.) enabled.

Declaration

Source position: mui.pas line 2002

const MUIC_String: PChar = 'String.mui';

Description

Inheritance
rootclass --> Notify --> Area --> Gadget --> String

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_String_Accept | ISG | PChar | A string containing characters allowed as input for the string gadget.
MUIA_String_Acknowledge | __G | PChar | Contents of gadget if return is hit.
MUIA_String_AdvanceOnCR | ISG | BOOL (0/1) | Carriage returns in string gadgets behave like the TAB key.
MUIA_String_AttachedList | ISG | PObject_ | Control lists cursor from within the string gadget.
MUIA_String_BufferPos | _SG | LongInt | Get and set the position of the cursor.
MUIA_String_Contents | ISG | PChar | Get and set a string gadgets contents.
MUIA_String_DisplayPos | _SG | LongInt | Get and set the number of the first character of the string to be displayed.
MUIA_String_EditHook | ISG | PHook | Called on every edit of the gadget.
MUIA_String_Format | I_G | LongInt | Used to adjust the alignment of the input string.
MUIA_String_Integer | ISG | LongWord | Useful for turning a string gadget into an integer gadget.
MUIA_String_LonelyEditHook | ISG | BOOL (0/1) | Skip MUI's private edit hook completely.
MUIA_String_MaxLen | I_G | LongInt | Setup the maximum length for the string gadget.
MUIA_String_Reject | ISG | PChar | A string containing characters that should not be accepted as input for the string gadget.
MUIA_String_Secret | I_G | BOOL (0/1) | This attribute causes the string gadget to display only dots instead of the real contents.
Fields inherited from Gadget
MUIA_Gadget_Gadget __G PGadget Subclasses may obtain a pointer to the intuition gadget here.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Text

Text class allows generating objects that contain some kind of text.

Declaration

Source position: mui.pas line 1873

const MUIC_Text: PChar = 'Text.mui';

Description

You can control the outfit of your text with some special control characters, including italics, bold, underline and color codes. Format codes align text either left, centered or right, linefeeds allow multiline text fields.

Inheritance
rootclass --> Notify --> Area --> Text

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Text_Contents | ISG | PChar | String to be displayed in a text object.
MUIA_Text_HiChar | I__ | Char | This character in the displayed string, it will be underlined.
MUIA_Text_PreParse | ISG | PChar | String containing format definitions to be parsed before the text is printed.
MUIA_Text_SetMax | I__ | BOOL (0/1) | Use max limit width of element by string.
MUIA_Text_SetMin | I__ | BOOL (0/1) | Use min limit width of element by string.
MUIA_Text_SetVMax | I__ | BOOL (0/1) | Fix object height.
Fields inherited from Area
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Background | IS_ | LongInt | Adjust the background for an object.
MUIA_BottomEdge | __G | LongInt | Current position and dimension of an object.
MUIA_ContextMenu | ISG | PObject_ | Specifies a context sensitive popup menu for the current object.
MUIA_ContextMenuTrigger | __G | PObject_ | Allows reacting on context menus with notificaton.
MUIA_ControlChar | ISG | PObject_ | Allows reacting on context menus with notificaton.
MUIA_CycleChain | ISG | LongInt | Define cycle chain position.
MUIA_Disabled | ISG | BOOL (0/1) | Disable or enable a gadget.
MUIA_Draggable | ISG | BOOL (0/1) | Set this if you want the complete object to be dragable for Drag'n'Drop operations.
MUIA_Dropable | ISG | BOOL (0/1) | Set as active Drag'n'Drop target.
MUIA_FillArea | IS_ | BOOL (0/1) | Define if a custom class should clear the background.
MUIA_FixHeight | I__ | LongInt | Give your object a fixed pixel height.
MUIA_FixHeightTxt | I__ | PChar | Give your object a fixed pixel height given by a text height.
MUIA_FixWidth | I__ | LongInt | Give your object a fixed pixel width.
MUIA_FixWidthTxt | I__ | PChar | Give your object a fixed pixel width given by a text height.
MUIA_Font | I_G | PTextFont | Give your object a fixed pixel width given by a text height.
MUIA_Frame | I__ | LongInt | Define a frame for the current object.
MUIA_FramePhantomHoriz | I__ | BOOL (0/1) | Do not draw horizontal frame border
MUIA_FrameTitle | I__ | PChar | Text displayed centered in the top line of a frame.
MUIA_Height | __G | PChar | Read current height of object.
MUIA_HorizDisappear | ISG | LongInt | Priority for disappearing if parent is too small in height.
MUIA_HorizWeight | ISG | SmallInt | Adjust the horizontal weight of an object.
MUIA_InnerBottom | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerLeft | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerRight | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InnerTop | I_G | LongInt | Adjust the space between an object and its frame.
MUIA_InputMode | I__ | LongInt | Adjust the input mode for an object.
MUIA_LeftEdge | __G | LongInt | Read current left edge of object.
MUIA_MaxHeight | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_MaxWidth | I__ | LongInt | Specify a maximum height for an object (in pixels).
MUIA_Pressed | __G | BOOL (0/1) | Get if a Button is pressed or not.
MUIA_RightEdge | __G | BOOL (0/1) | Read current right edge of object.
MUIA_Selected | ISG | BOOL (0/1) | Selected state of object.
MUIA_ShortHelp | ISG | PChar | Specify a string that is to be used as bubble help for this object.
MUIA_ShowMe | ISG | BOOL (0/1) | Define if the object is visible or not.
MUIA_ShowSelState | I__ | BOOL (0/1) | Reverse object frame if selected.
MUIA_Timer | __G | LongInt | Define a Button repeatly firing.
MUIA_TopEdge | __G | LongInt | Read current top edge of object.
MUIA_VertDisappear | __G | LongInt | Priority for disappearing if parent is too small in width.
MUIA_VertWeight | ISG | SmallInt | Adjust the vertical weight of an object.
MUIA_Weight | I__ | SmallInt | Adjust the vertical and horizontal weight of an object in one call.
MUIA_Width | __G | LongInt | Read current width of object.
MUIA_Window | __G | PWindow | Get intuition window struct of the parent window.
MUIA_WindowObject | __G | PObject_ | Get window object of the parent window.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods inherited from Area
_______________ Method _______________ | Short description
MUIM_AskMinMax | Ask minimum and maximum of the object. For custom classes only.
MUIM_Cleanup | For custom classes only.
MUIM_ContextMenuBuild | Allows dynamic creation of context menus.
MUIM_ContextMenuChoice | Allows reacting on context menus in subclasses.
MUIM_CreateBubble | Create a bubble message.
MUIM_CreateShortHelp | Allows dynamic creation of help bubble texts.
MUIM_DeleteBubble | Remove a bubble message.
MUIM_DeleteShortHelp | Remove help bubble texts memory.
MUIM_DragBegin | Inform an object that it has become the active destination of a drag'n'drop action.
MUIM_DragDrop | Indicate that the user dropped something on the current object.
MUIM_DragFinish | Indicate that an object is no longer the active destination object of a drag'n'drop action.
MUIM_DragQuery | Determine if drag'n'drop is allowed.
MUIM_DragReport | Object is still dragged around.
MUIM_Draw | Ask the object to draw itself. For use in Custom classes only
MUIM_DrawBackground | Draw the background of the object.
MUIM_HandleEvent | This method is invoked whenever one of an event handlers trigger signals arrives.
MUIM_HandleInput | Handle input messages. For custom classes only.
MUIM_Hide | For custom classes only.
MUIM_Setup | For custom classes only.
MUIM_Show | For custom classes only.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUIC_Title

Declaration

Source position: mui.pas line 3486

const MUIC_Title: PChar = 'Title.mui';


MUIC_Virtgroup

Declaration

Source position: mui.pas line 2285

const MUIC_Virtgroup: PChar = 'Virtgroup.mui';


MUIC_Volumelist

Declaration

Source position: mui.pas line 3358

const MUIC_Volumelist: PChar = 'Volumelist.mui';


MUIC_Window

Objects of window class are used to generate windows and supply a place where MUI gadgets feel well.

Declaration

Source position: mui.pas line 1113

const MUIC_Window: PChar = 'Window.mui';

Description

Objects of window class are used to generate windows and supply a place where MUI gadgets feel well. It handles the complicated task of window resizing fully automatic, you don't need to worry about that.

Windows are children of an application, you cannot use a window object without having a parent application object. On the other side, the gadgets in a window are children of the window, you cannot use MUI gadgets without having a parent MUI window.

Creating a window object does not mean to open it instantly. This is done later by setting the window's MUIA_Window_Open attribute. If your application has several windows, the usual way is to create them all at once at startup time and open/close it later just by setting MUIA_Window_Open.

There is no difference in talking to gadgets whether their parent window is open or not. If you e.g. set the contents of a string gadget in an open window, the gadget will refresh immediately. If the window is closed, the gadget just remembers its new setting and displays it later.

Inheritance
rootclass --> Notify --> Window

Fields
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_Window_Activate | ISG | BOOL (0/1) | Set to True to active the Window.
MUIA_Window_ActiveObject | _SG | PObject_ | Set or get the active object.
MUIA_Window_AltHeight | I_G | LongInt | Specify the alternate (zoomed) height of a window.
MUIA_Window_AltLeftEdge | I_G | LongInt | Specify the alternate (zoomed) left position of a window.
MUIA_Window_AltTopEdge | I_G | LongInt | Specify the alternate (zoomed) top position of a window.
MUIA_Window_AltWidth | I_G | LongInt | Specify the alternate (zoomed) width of a window.
MUIA_Window_AppWindow | I__ | BOOL (0/1) | Set Window as AppWindow.
MUIA_Window_Backdrop | I__ | BOOL (0/1) | Make the window a backdrop window.
MUIA_Window_Borderless | I__ | BOOL (0/1) | Make the window borderless.
MUIA_Window_CloseGadget | I__ | BOOL (0/1) | Set this to False and your window will not have a close gadget.
MUIA_Window_CloseRequest | __G | BOOL (0/1) | Set to True if the user tries to close the window.
MUIA_Window_DefaultObject | ISG | PObject_ | The default object in a window receives keyboard input.
MUIA_Window_DepthGadget | I__ | BOOL (0/1) | Enable or disable the depth gadget.
MUIA_Window_DragBar | I__ | BOOL (0/1) | Tell MUI to give your window a dragbar.
MUIA_Window_FancyDrawing | ISG | BOOL (0/1) | Obsolete relaxed way of custom class drawing.
MUIA_Window_Height | I_G | LongInt | Specify the height of a window.
MUIA_Window_ID | ISG | LongWord | Define an ID for the window.
MUIA_Window_InputEvent | __G | PInputEvent | Define an ID for the window.
MUIA_Window_IsSubWindow | ISG | BOOL (0/1) | Windows with this flag set to True dont get disposed when the application object is disposed.
MUIA_Window_LeftEdge | I_G | LongInt | Specify the left edge of a window.
MUIA_Window_MenuAction | ISG | LongWord | UserData field of selected Menu item.
MUIA_Window_Menustrip | I_G | PObject_ | Specify a menu strip object for this window.
MUIA_Window_MouseObject | __G | PObject_ | Identify mouse position.
MUIA_Window_NeedsMouseObject | I__ | BOOL (0/1) | Enable notification of changes of mouse position.
MUIA_Window_NoMenus | IS_ | BOOL (0/1) | Temporarily disable the menu strip of a window.
MUIA_Window_Open | _SG | BOOL (0/1) | Open or close the window.
MUIA_Window_PublicScreen | ISG | PChar | Force the window to appear on the public screen who's name is specified by this attribute.
MUIA_Window_RefWindow | IS_ | PObject_ | Calculate position relative to this window.
MUIA_Window_RootObject | ISG | PObject_ | This is a pointer to a MUI object and defines the contents of your window.
MUIA_Window_Screen | ISG | PScreen | You can get a pointer to the parent screen of a window by getting this attribute.
MUIA_Window_ScreenTitle | ISG | PChar | This text will appear in the screens title bar when the window is active.
MUIA_Window_SizeGadget | I__ | BOOL (0/1) | Tell MUI if you want a sizing gadget for this window.
MUIA_Window_SizeRight | I__ | BOOL (0/1) | When set to True, the size gadget will reside in the right window border.
MUIA_Window_Sleep | _SG | BOOL (0/1) | This attribute can be used to put a window to sleep.
MUIA_Window_Title | ISG | PChar | Specify the title of a window.
MUIA_Window_TopEdge | I_G | LongInt | Specify the top edge of a window.
MUIA_Window_UseBottomBorderScroller | ISG | BOOL (0/1) | If set to True, the window will feature a scrollbar in its bottom border.
MUIA_Window_UseLeftBorderScroller | ISG | BOOL (0/1) | If set to True, the window will feature a scrollbar in its left border.
MUIA_Window_UseRightBorderScroller | ISG | BOOL (0/1) | If set to True, the window will feature a scrollbar in its right border.
MUIA_Window_Width | I_G | LongInt | Specify the width of a window.
MUIA_Window_Window | __G | PWindow | Obtain a pointer to the intuition Window structure.
Fields inherited from Notify
_______________ Field _______________ | ___ Access ___ | _____ Type _____ | Short description
MUIA_ApplicationObject | __G | PObject_ | Obtain a pointer to the application object that some gadget belongs
MUIA_AppMessage | __G | PAppMessage | Listen to this field to get AppMessages (Icon dropped on the App window)
MUIA_HelpLine | ISG | LongInt | Define a line in a help file specified with MUIA_Application_HelpFile
MUIA_HelpNode | ISG | PChar | Define a node in a help file specified with MUIA_Application_HelpFile
MUIA_NoNotify | _S_ | BOOL (0/1) | Prevent notification from being triggered on attribute set
MUIA_ObjectID | ISG | LongWord | Identification for object on save/load
MUIA_Parent | __G | PObject_ | Get a pointer to the parent object of the current object
MUIA_Revision | __G | LongInt | Get the revision number of an objects class
MUIA_UserData | ISG | LongWord | A general purpose value to fill in any kind of information
MUIA_Version | __G | LongInt | Get the version number of an objects class

Methods
_______________ Method _______________ | Short description
MUIM_Window_AddEventHandler | Add an Event Handler for custom class.
MUIM_Window_RemEventHandler | Remove an Event Handler for custom class.
MUIM_Window_ScreenToBack | Put the window's screen to back.
MUIM_Window_ScreenToFront | Put the window's screen to front.
MUIM_Window_Snapshot | Remember Windows current position and size.
MUIM_Window_ToBack | Put the window to back.
MUIM_Window_ToFront | Put the window to front.
Methods inherited from Notify
_______________ Method _______________ | Short description
MUIM_CallHook | Call a standard amiga callback hook
MUIM_Export | Called on export object to dataspace
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_GetConfigItem |
MUIM_GetUData | Find a userdata in objects and childrens list and return an attribute of the object
MUIM_Import | Called on import object from dataspace
MUIM_KillNotify | Kills previously given notifications on specific attributes
MUIM_KillNotifyObj |
MUIM_MultiSet | Set an attribute for multiple objects.
MUIM_NoNotifySet | Acts like MUIM_Notify but doesn't trigger any notification
MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value
MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.
MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_WriteString | This method simply copies a string somewhere to memory.


MUICFG_ActiveObject_Color

Declaration

Source position: mui.pas line 3119

const MUICFG_ActiveObject_Color = $8f;


MUICFG_Background_Button

Declaration

Source position: mui.pas line 3044

const MUICFG_Background_Button = $39;


MUICFG_Background_Framed

Declaration

Source position: mui.pas line 3077

const MUICFG_Background_Framed = $5a;


MUICFG_Background_List

Declaration

Source position: mui.pas line 3045

const MUICFG_Background_List = $3a;


MUICFG_Background_ListCursor

Declaration

Source position: mui.pas line 3050

const MUICFG_Background_ListCursor = $3f;


MUICFG_Background_ListSelCur

Declaration

Source position: mui.pas line 3052

const MUICFG_Background_ListSelCur = $41;


MUICFG_Background_ListSelect

Declaration

Source position: mui.pas line 3051

const MUICFG_Background_ListSelect = $40;


MUICFG_Background_Page

Declaration

Source position: mui.pas line 3122

const MUICFG_Background_Page = $95;


MUICFG_Background_PopUp

Declaration

Source position: mui.pas line 3048

const MUICFG_Background_PopUp = $3d;


MUICFG_Background_Prop

Declaration

Source position: mui.pas line 3047

const MUICFG_Background_Prop = $3c;


MUICFG_Background_ReadList

Declaration

Source position: mui.pas line 3123

const MUICFG_Background_ReadList = $96;


MUICFG_Background_Register

Declaration

Source position: mui.pas line 3071

const MUICFG_Background_Register = $54;


MUICFG_Background_Requester

Declaration

Source position: mui.pas line 3043

const MUICFG_Background_Requester = $38;


MUICFG_Background_Selected

Declaration

Source position: mui.pas line 3049

const MUICFG_Background_Selected = $3e;


MUICFG_Background_Slider

Declaration

Source position: mui.pas line 3078

const MUICFG_Background_Slider = $5b;


MUICFG_Background_SliderKnob

Declaration

Source position: mui.pas line 3079

const MUICFG_Background_SliderKnob = $5c;


MUICFG_Background_Text

Declaration

Source position: mui.pas line 3046

const MUICFG_Background_Text = $3b;


MUICFG_Background_Window

Declaration

Source position: mui.pas line 3042

const MUICFG_Background_Window = $37;


MUICFG_Balance_Look

Declaration

Source position: mui.pas line 3105

const MUICFG_Balance_Look = $7b;


MUICFG_BubbleHelp_FirstDelay

Declaration

Source position: mui.pas line 3159

const MUICFG_BubbleHelp_FirstDelay = $706;


MUICFG_BubbleHelp_NextDelay

Declaration

Source position: mui.pas line 3160

const MUICFG_BubbleHelp_NextDelay = $707;


MUICFG_CustomFrame_1

Declaration

Source position: mui.pas line 3136

const MUICFG_CustomFrame_1 = $600;


MUICFG_CustomFrame_2

Declaration

Source position: mui.pas line 3137

const MUICFG_CustomFrame_2 = $601;


MUICFG_CustomFrame_3

Declaration

Source position: mui.pas line 3138

const MUICFG_CustomFrame_3 = $602;


MUICFG_CustomFrame_4

Declaration

Source position: mui.pas line 3139

const MUICFG_CustomFrame_4 = $603;


MUICFG_CustomFrame_5

Declaration

Source position: mui.pas line 3140

const MUICFG_CustomFrame_5 = $604;


MUICFG_CustomFrame_6

Declaration

Source position: mui.pas line 3141

const MUICFG_CustomFrame_6 = $605;


MUICFG_CustomFrame_7

Declaration

Source position: mui.pas line 3142

const MUICFG_CustomFrame_7 = $606;


MUICFG_CustomFrame_8

Declaration

Source position: mui.pas line 3143

const MUICFG_CustomFrame_8 = $607;


MUICFG_CustomFrame_9

Declaration

Source position: mui.pas line 3144

const MUICFG_CustomFrame_9 = $608;


MUICFG_CustomFrame_10

Declaration

Source position: mui.pas line 3145

const MUICFG_CustomFrame_10 = $609;


MUICFG_CustomFrame_11

Declaration

Source position: mui.pas line 3146

const MUICFG_CustomFrame_11 = $60a;


MUICFG_CustomFrame_12

Declaration

Source position: mui.pas line 3147

const MUICFG_CustomFrame_12 = $60b;


MUICFG_CustomFrame_13

Declaration

Source position: mui.pas line 3148

const MUICFG_CustomFrame_13 = $60c;


MUICFG_CustomFrame_14

Declaration

Source position: mui.pas line 3149

const MUICFG_CustomFrame_14 = $60d;


MUICFG_CustomFrame_15

Declaration

Source position: mui.pas line 3150

const MUICFG_CustomFrame_15 = $60e;


MUICFG_CustomFrame_16

Declaration

Source position: mui.pas line 3151

const MUICFG_CustomFrame_16 = $60f;


MUICFG_Cycle_Menu_Recessed

Declaration

Source position: mui.pas line 3019

const MUICFG_Cycle_Menu_Recessed = $19;


MUICFG_Cycle_MenuCtrl_Level

Declaration

Source position: mui.pas line 3016

const MUICFG_Cycle_MenuCtrl_Level = $11;


MUICFG_Cycle_MenuCtrl_Position

Declaration

Source position: mui.pas line 3017

const MUICFG_Cycle_MenuCtrl_Position = $12;


MUICFG_Cycle_MenuCtrl_Speed

Declaration

Source position: mui.pas line 3020

const MUICFG_Cycle_MenuCtrl_Speed = $1a;


MUICFG_Drag_Autostart

Declaration

Source position: mui.pas line 3117

const MUICFG_Drag_Autostart = $8d;


MUICFG_Drag_Autostart_Length

Declaration

Source position: mui.pas line 3118

const MUICFG_Drag_Autostart_Length = $8e;


MUICFG_Drag_LeftButton

Declaration

Source position: mui.pas line 3113

const MUICFG_Drag_LeftButton = $89;


MUICFG_Drag_LMBModifier

Declaration

Source position: mui.pas line 3115

const MUICFG_Drag_LMBModifier = $8b;


MUICFG_Drag_MiddleButton

Declaration

Source position: mui.pas line 3114

const MUICFG_Drag_MiddleButton = $8a;


MUICFG_Drag_MMBModifier

Declaration

Source position: mui.pas line 3116

const MUICFG_Drag_MMBModifier = $8c;


MUICFG_Dragndrop_Look

Declaration

Source position: mui.pas line 3121

const MUICFG_Dragndrop_Look = $94;


MUICFG_Font_Big

Declaration

Source position: mui.pas line 3028

const MUICFG_Font_Big = $23;


MUICFG_Font_Button

Declaration

Source position: mui.pas line 3106

const MUICFG_Font_Button = $80;


MUICFG_Font_Fixed

Declaration

Source position: mui.pas line 3026

const MUICFG_Font_Fixed = $21;


MUICFG_Font_Knob

Declaration

Source position: mui.pas line 3112

const MUICFG_Font_Knob = $88;


MUICFG_Font_List

Declaration

Source position: mui.pas line 3024

const MUICFG_Font_List = $1f;


MUICFG_Font_Normal

Declaration

Source position: mui.pas line 3023

const MUICFG_Font_Normal = $1e;


MUICFG_Font_Tiny

Declaration

Source position: mui.pas line 3025

const MUICFG_Font_Tiny = $20;


MUICFG_Font_Title

Declaration

Source position: mui.pas line 3027

const MUICFG_Font_Title = $22;


MUICFG_Frame_Button

Declaration

Source position: mui.pas line 3030

const MUICFG_Frame_Button = $2b;


MUICFG_Frame_Drag

Declaration

Source position: mui.pas line 3018

const MUICFG_Frame_Drag = $18;


MUICFG_Frame_Gauge

Declaration

Source position: mui.pas line 3037

const MUICFG_Frame_Gauge = $32;


MUICFG_Frame_Group

Declaration

Source position: mui.pas line 3038

const MUICFG_Frame_Group = $33;


MUICFG_Frame_ImageButton

Declaration

Source position: mui.pas line 3031

const MUICFG_Frame_ImageButton = $2c;


MUICFG_Frame_InputList

Declaration

Source position: mui.pas line 3035

const MUICFG_Frame_InputList = $30;


MUICFG_Frame_Knob

Declaration

Source position: mui.pas line 3120

const MUICFG_Frame_Knob = $90;


MUICFG_Frame_PopUp

Declaration

Source position: mui.pas line 3039

const MUICFG_Frame_PopUp = $34;


MUICFG_Frame_Prop

Declaration

Source position: mui.pas line 3036

const MUICFG_Frame_Prop = $31;


MUICFG_Frame_ReadList

Declaration

Source position: mui.pas line 3034

const MUICFG_Frame_ReadList = $2f;


MUICFG_Frame_Slider

Declaration

Source position: mui.pas line 3041

const MUICFG_Frame_Slider = $36;


MUICFG_Frame_String

Declaration

Source position: mui.pas line 3033

const MUICFG_Frame_String = $2e;


MUICFG_Frame_Text

Declaration

Source position: mui.pas line 3032

const MUICFG_Frame_Text = $2d;


MUICFG_Frame_Virtual

Declaration

Source position: mui.pas line 3040

const MUICFG_Frame_Virtual = $35;


MUICFG_Group_HSpacing

Declaration

Source position: mui.pas line 3007

const MUICFG_Group_HSpacing = $07;


MUICFG_Group_VSpacing

Declaration

Source position: mui.pas line 3008

const MUICFG_Group_VSpacing = $08;


MUICFG_GroupTitle_Color

Declaration

Source position: mui.pas line 3015

const MUICFG_GroupTitle_Color = $10;


MUICFG_GroupTitle_Position

Declaration

Source position: mui.pas line 3014

const MUICFG_GroupTitle_Position = $0f;


MUICFG_Iconification_Hotkey

Declaration

Source position: mui.pas line 3154

const MUICFG_Iconification_Hotkey = $701;


MUICFG_Iconification_OnStartup

Declaration

Source position: mui.pas line 3157

const MUICFG_Iconification_OnStartup = $704;


MUICFG_Iconification_ShowIcon

Declaration

Source position: mui.pas line 3155

const MUICFG_Iconification_ShowIcon = $702;


MUICFG_Iconification_ShowMenu

Declaration

Source position: mui.pas line 3156

const MUICFG_Iconification_ShowMenu = $703;


MUICFG_Image_ArrowDown

Declaration

Source position: mui.pas line 3054

const MUICFG_Image_ArrowDown = $43;


MUICFG_Image_ArrowLeft

Declaration

Source position: mui.pas line 3055

const MUICFG_Image_ArrowLeft = $44;


MUICFG_Image_ArrowRight

Declaration

Source position: mui.pas line 3056

const MUICFG_Image_ArrowRight = $45;


MUICFG_Image_ArrowUp

Declaration

Source position: mui.pas line 3053

const MUICFG_Image_ArrowUp = $42;


MUICFG_Image_Assign

Declaration

Source position: mui.pas line 3070

const MUICFG_Image_Assign = $53;


MUICFG_Image_CheckMark

Declaration

Source position: mui.pas line 3057

const MUICFG_Image_CheckMark = $46;


MUICFG_Image_Chip

Declaration

Source position: mui.pas line 3067

const MUICFG_Image_Chip = $50;


MUICFG_Image_Cycle

Declaration

Source position: mui.pas line 3059

const MUICFG_Image_Cycle = $48;


MUICFG_Image_Disk

Declaration

Source position: mui.pas line 3066

const MUICFG_Image_Disk = $4f;


MUICFG_Image_Drawer

Declaration

Source position: mui.pas line 3064

const MUICFG_Image_Drawer = $4d;


MUICFG_Image_HardDisk

Declaration

Source position: mui.pas line 3065

const MUICFG_Image_HardDisk = $4e;


MUICFG_Image_Network

Declaration

Source position: mui.pas line 3069

const MUICFG_Image_Network = $52;


MUICFG_Image_PopDrawer

Declaration

Source position: mui.pas line 3062

const MUICFG_Image_PopDrawer = $4b;


MUICFG_Image_PopFile

Declaration

Source position: mui.pas line 3061

const MUICFG_Image_PopFile = $4a;


MUICFG_Image_PopUp

Declaration

Source position: mui.pas line 3060

const MUICFG_Image_PopUp = $49;


MUICFG_Image_PropKnob

Declaration

Source position: mui.pas line 3063

const MUICFG_Image_PropKnob = $4c;


MUICFG_Image_RadioButton

Declaration

Source position: mui.pas line 3058

const MUICFG_Image_RadioButton = $47;


MUICFG_Image_TapeDown

Declaration

Source position: mui.pas line 3081

const MUICFG_Image_TapeDown = $5e;


MUICFG_Image_TapePause

Declaration

Source position: mui.pas line 3074

const MUICFG_Image_TapePause = $57;


MUICFG_Image_TapePlay

Declaration

Source position: mui.pas line 3072

const MUICFG_Image_TapePlay = $55;


MUICFG_Image_TapePlayBack

Declaration

Source position: mui.pas line 3073

const MUICFG_Image_TapePlayBack = $56;


MUICFG_Image_TapeRecord

Declaration

Source position: mui.pas line 3076

const MUICFG_Image_TapeRecord = $59;


MUICFG_Image_TapeStop

Declaration

Source position: mui.pas line 3075

const MUICFG_Image_TapeStop = $58;


MUICFG_Image_TapeUp

Declaration

Source position: mui.pas line 3080

const MUICFG_Image_TapeUp = $5d;


MUICFG_Image_Volume

Declaration

Source position: mui.pas line 3068

const MUICFG_Image_Volume = $51;


MUICFG_Interfaces_EnableARexx

Declaration

Source position: mui.pas line 3158

const MUICFG_Interfaces_EnableARexx = $705;


MUICFG_Invalid

Declaration

Source position: mui.pas line 3000

const MUICFG_Invalid = - 1;


MUICFG_Keyboard_Bottom

Declaration

Source position: mui.pas line 3089

const MUICFG_Keyboard_Bottom = $66;


MUICFG_Keyboard_CloseWindow

Declaration

Source position: mui.pas line 3099

const MUICFG_Keyboard_CloseWindow = $70;


MUICFG_Keyboard_Down

Declaration

Source position: mui.pas line 3085

const MUICFG_Keyboard_Down = $62;


MUICFG_Keyboard_GadgetOff

Declaration

Source position: mui.pas line 3098

const MUICFG_Keyboard_GadgetOff = $6f;


MUICFG_Keyboard_Help

Declaration

Source position: mui.pas line 3102

const MUICFG_Keyboard_Help = $73;


MUICFG_Keyboard_Left

Declaration

Source position: mui.pas line 3090

const MUICFG_Keyboard_Left = $67;


MUICFG_Keyboard_LineEnd

Declaration

Source position: mui.pas line 3095

const MUICFG_Keyboard_LineEnd = $6c;


MUICFG_Keyboard_LineStart

Declaration

Source position: mui.pas line 3094

const MUICFG_Keyboard_LineStart = $6b;


MUICFG_Keyboard_NextGadget

Declaration

Source position: mui.pas line 3096

const MUICFG_Keyboard_NextGadget = $6d;


MUICFG_Keyboard_NextWindow

Declaration

Source position: mui.pas line 3100

const MUICFG_Keyboard_NextWindow = $71;


MUICFG_Keyboard_PageDown

Declaration

Source position: mui.pas line 3087

const MUICFG_Keyboard_PageDown = $64;


MUICFG_Keyboard_PageUp

Declaration

Source position: mui.pas line 3086

const MUICFG_Keyboard_PageUp = $63;


MUICFG_Keyboard_Popup

Declaration

Source position: mui.pas line 3103

const MUICFG_Keyboard_Popup = $74;


MUICFG_Keyboard_Press

Declaration

Source position: mui.pas line 3082

const MUICFG_Keyboard_Press = $5f;


MUICFG_Keyboard_PrevGadget

Declaration

Source position: mui.pas line 3097

const MUICFG_Keyboard_PrevGadget = $6e;


MUICFG_Keyboard_PrevWindow

Declaration

Source position: mui.pas line 3101

const MUICFG_Keyboard_PrevWindow = $72;


MUICFG_Keyboard_Right

Declaration

Source position: mui.pas line 3091

const MUICFG_Keyboard_Right = $68;


MUICFG_Keyboard_Toggle

Declaration

Source position: mui.pas line 3083

const MUICFG_Keyboard_Toggle = $60;


MUICFG_Keyboard_Top

Declaration

Source position: mui.pas line 3088

const MUICFG_Keyboard_Top = $65;


MUICFG_Keyboard_Up

Declaration

Source position: mui.pas line 3084

const MUICFG_Keyboard_Up = $61;


MUICFG_Keyboard_WordLeft

Declaration

Source position: mui.pas line 3092

const MUICFG_Keyboard_WordLeft = $69;


MUICFG_Keyboard_WordRight

Declaration

Source position: mui.pas line 3093

const MUICFG_Keyboard_WordRight = $6a;


MUICFG_Listview_Font_Leading

Declaration

Source position: mui.pas line 3011

const MUICFG_Listview_Font_Leading = $0b;


MUICFG_Listview_Multi

Declaration

Source position: mui.pas line 3013

const MUICFG_Listview_Multi = $0d;


MUICFG_Listview_Refresh

Declaration

Source position: mui.pas line 3010

const MUICFG_Listview_Refresh = $0a;


MUICFG_Listview_Smoothed

Declaration

Source position: mui.pas line 3021

const MUICFG_Listview_Smoothed = $1b;


MUICFG_Listview_SmoothVal

Declaration

Source position: mui.pas line 3012

const MUICFG_Listview_SmoothVal = $0c;


MUICFG_PublicScreen

Declaration

Source position: mui.pas line 3029

const MUICFG_PublicScreen = $24;


MUICFG_PublicScreen_PopToFront

Declaration

Source position: mui.pas line 3153

const MUICFG_PublicScreen_PopToFront = $700;


MUICFG_Radio_HSpacing

Declaration

Source position: mui.pas line 3005

const MUICFG_Radio_HSpacing = $05;


MUICFG_Radio_VSpacing

Declaration

Source position: mui.pas line 3006

const MUICFG_Radio_VSpacing = $06;


MUICFG_Register_TruncateTitles

Declaration

Source position: mui.pas line 3127

const MUICFG_Register_TruncateTitles = $403;


MUICFG_Screen_Height

Declaration

Source position: mui.pas line 3132

const MUICFG_Screen_Height = $508;


MUICFG_Screen_Mode

Declaration

Source position: mui.pas line 3129

const MUICFG_Screen_Mode = $505;


MUICFG_Screen_Mode_ID

Declaration

Source position: mui.pas line 3130

const MUICFG_Screen_Mode_ID = $506;


MUICFG_Screen_Width

Declaration

Source position: mui.pas line 3131

const MUICFG_Screen_Width = $507;


MUICFG_Scrollbar_Arrangement

Declaration

Source position: mui.pas line 3009

const MUICFG_Scrollbar_Arrangement = $09;


MUICFG_Scrollbar_Type

Declaration

Source position: mui.pas line 3107

const MUICFG_Scrollbar_Type = $83;


MUICFG_String_ActiveBackground

Declaration

Source position: mui.pas line 3110

const MUICFG_String_ActiveBackground = $86;


MUICFG_String_ActiveText

Declaration

Source position: mui.pas line 3111

const MUICFG_String_ActiveText = $87;


MUICFG_String_Background

Declaration

Source position: mui.pas line 3108

const MUICFG_String_Background = $84;


MUICFG_String_Cursor

Declaration

Source position: mui.pas line 3124

const MUICFG_String_Cursor = $400;


MUICFG_String_MarkedBackground

Declaration

Source position: mui.pas line 3125

const MUICFG_String_MarkedBackground = $401;


MUICFG_String_MarkedText

Declaration

Source position: mui.pas line 3126

const MUICFG_String_MarkedText = $402;


MUICFG_String_Text

Declaration

Source position: mui.pas line 3109

const MUICFG_String_Text = $85;


MUICFG_Window_Buttons

Declaration

Source position: mui.pas line 3134

const MUICFG_Window_Buttons = $50a;


MUICFG_Window_Positions

Declaration

Source position: mui.pas line 3104

const MUICFG_Window_Positions = $7a;


MUICFG_Window_Redraw

Declaration

Source position: mui.pas line 3022

const MUICFG_Window_Redraw = $1d;


MUICFG_Window_Refresh

Declaration

Source position: mui.pas line 3128

const MUICFG_Window_Refresh = $404;


MUICFG_Window_Spacing_Bottom

Declaration

Source position: mui.pas line 3004

const MUICFG_Window_Spacing_Bottom = $04;


MUICFG_Window_Spacing_Left

Declaration

Source position: mui.pas line 3001

const MUICFG_Window_Spacing_Left = $01;


MUICFG_Window_Spacing_Right

Declaration

Source position: mui.pas line 3002

const MUICFG_Window_Spacing_Right = $02;


MUICFG_Window_Spacing_Top

Declaration

Source position: mui.pas line 3003

const MUICFG_Window_Spacing_Top = $03;


MUICFG_WindowPos

Declaration

Source position: mui.pas line 3133

const MUICFG_WindowPos = $509;


MUIE_InvalidWindowObject

Declaration

Source position: mui.pas line 282

const MUIE_InvalidWindowObject = 3;


MUIE_MissingLibrary

Declaration

Source position: mui.pas line 283

const MUIE_MissingLibrary = 4;


MUIE_NoARexx

Declaration

Source position: mui.pas line 284

const MUIE_NoARexx = 5;


MUIE_OK

Declaration

Source position: mui.pas line 279

const MUIE_OK = 0;


MUIE_OutOfGfxMemory

Declaration

Source position: mui.pas line 281

const MUIE_OutOfGfxMemory = 2;


MUIE_OutOfMemory

Declaration

Source position: mui.pas line 280

const MUIE_OutOfMemory = 1;


MUIE_SingleTask

Declaration

Source position: mui.pas line 285

const MUIE_SingleTask = 6;


MUIF_DRAGIMAGE_HASMASK

Declaration

Source position: mui.pas line 1634

const MUIF_DRAGIMAGE_HASMASK = 1 shl 0;


MUIF_DRAGIMAGE_SOURCEALPHA

Declaration

Source position: mui.pas line 1635

const MUIF_DRAGIMAGE_SOURCEALPHA = 1 shl 1;


MUIF_Slave_Delegate_ForceSlave

Declaration

Source position: mui.pas line 602

const MUIF_Slave_Delegate_ForceSlave = 1 shl 0;


MUII_ArrowDown

Declaration

Source position: mui.pas line 301

const MUII_ArrowDown = 12;


MUII_ArrowLeft

Declaration

Source position: mui.pas line 302

const MUII_ArrowLeft = 13;


MUII_ArrowRight

Declaration

Source position: mui.pas line 303

const MUII_ArrowRight = 14;


MUII_ArrowUp

Declaration

Source position: mui.pas line 300

const MUII_ArrowUp = 11;


MUII_Assign

Declaration

Source position: mui.pas line 318

const MUII_Assign = 29;


MUII_BACKGROUND

Declaration

Source position: mui.pas line 347

const MUII_BACKGROUND = 128;


MUII_ButtonBack

Declaration

Source position: mui.pas line 291

const MUII_ButtonBack = 2;


MUII_CheckMark

Declaration

Source position: mui.pas line 304

const MUII_CheckMark = 15;


MUII_Chip

Declaration

Source position: mui.pas line 314

const MUII_Chip = 25;


MUII_Close

Declaration

Source position: mui.pas line 343

const MUII_Close = 54;


MUII_Count

Declaration

Source position: mui.pas line 344

const MUII_Count = 55;


MUII_Cycle

Declaration

Source position: mui.pas line 306

const MUII_Cycle = 17;


MUII_Disk

Declaration

Source position: mui.pas line 313

const MUII_Disk = 24;


MUII_Drawer

Declaration

Source position: mui.pas line 311

const MUII_Drawer = 22;


MUII_FILL

Declaration

Source position: mui.pas line 350

const MUII_FILL = 131;


MUII_FILLBACK

Declaration

Source position: mui.pas line 354

const MUII_FILLBACK = 135;


MUII_FILLBACK2

Declaration

Source position: mui.pas line 357

const MUII_FILLBACK2 = 138;


MUII_FILLSHINE

Declaration

Source position: mui.pas line 355

const MUII_FILLSHINE = 136;


MUII_GaugeEmpty

Declaration

Source position: mui.pas line 335

const MUII_GaugeEmpty = 46;


MUII_GaugeFull

Declaration

Source position: mui.pas line 334

const MUII_GaugeFull = 45;


MUII_GroupBack

Declaration

Source position: mui.pas line 324

const MUII_GroupBack = 35;


MUII_GroupTitle

Declaration

Source position: mui.pas line 341

const MUII_GroupTitle = 52;


MUII_HardDisk

Declaration

Source position: mui.pas line 312

const MUII_HardDisk = 23;


MUII_HSHADOWBACK

Declaration

Source position: mui.pas line 359

const MUII_HSHADOWBACK = 140;


MUII_HSHADOWSHADOW

Declaration

Source position: mui.pas line 361

const MUII_HSHADOWSHADOW = 142;


MUII_HSHINEBACK

Declaration

Source position: mui.pas line 358

const MUII_HSHINEBACK = 139;


MUII_HSHINESHINE

Declaration

Source position: mui.pas line 360

const MUII_HSHINESHINE = 141;


MUII_ImageButtonBack

Declaration

Source position: mui.pas line 332

const MUII_ImageButtonBack = 43;


MUII_ImageSelectedBack

Declaration

Source position: mui.pas line 333

const MUII_ImageSelectedBack = 44;


MUII_LASTPAT

Declaration

Source position: mui.pas line 365

const MUII_LASTPAT = 146;


MUII_ListBack

Declaration

Source position: mui.pas line 292

const MUII_ListBack = 3;


MUII_ListCursor

Declaration

Source position: mui.pas line 297

const MUII_ListCursor = 8;


MUII_ListSelCur

Declaration

Source position: mui.pas line 299

const MUII_ListSelCur = 10;


MUII_ListSelect

Declaration

Source position: mui.pas line 298

const MUII_ListSelect = 9;


MUII_ListTitle

Declaration

Source position: mui.pas line 340

const MUII_ListTitle = 51;


MUII_MARKBACKGROUND

Declaration

Source position: mui.pas line 364

const MUII_MARKBACKGROUND = 145;


MUII_MARKHALFSHINE

Declaration

Source position: mui.pas line 363

const MUII_MARKHALFSHINE = 144;


MUII_MARKSHINE

Declaration

Source position: mui.pas line 362

const MUII_MARKSHINE = 143;


MUII_Menudisplay

Declaration

Source position: mui.pas line 336

const MUII_Menudisplay = 47;


MUII_Network

Declaration

Source position: mui.pas line 317

const MUII_Network = 28;


MUII_PageBack

Declaration

Source position: mui.pas line 329

const MUII_PageBack = 40;


MUII_PopDrawer

Declaration

Source position: mui.pas line 309

const MUII_PopDrawer = 20;


MUII_PopFile

Declaration

Source position: mui.pas line 308

const MUII_PopFile = 19;


MUII_PopFont

Declaration

Source position: mui.pas line 331

const MUII_PopFont = 42;


MUII_PopUp

Declaration

Source position: mui.pas line 307

const MUII_PopUp = 18;


MUII_PopupBack

Declaration

Source position: mui.pas line 295

const MUII_PopupBack = 6;


MUII_PropBack

Declaration

Source position: mui.pas line 294

const MUII_PropBack = 5;


MUII_PropKnob

Declaration

Source position: mui.pas line 310

const MUII_PropKnob = 21;


MUII_PullOpen

Declaration

Source position: mui.pas line 337

const MUII_PullOpen = 48;


MUII_RadioButton

Declaration

Source position: mui.pas line 305

const MUII_RadioButton = 16;


MUII_ReadListBack

Declaration

Source position: mui.pas line 330

const MUII_ReadListBack = 41;


MUII_RegisterBack

Declaration

Source position: mui.pas line 316

const MUII_RegisterBack = 27;


MUII_RegisterTitle

Declaration

Source position: mui.pas line 342

const MUII_RegisterTitle = 53;


MUII_RequesterBack

Declaration

Source position: mui.pas line 290

const MUII_RequesterBack = 1;


MUII_SelectedBack

Declaration

Source position: mui.pas line 296

const MUII_SelectedBack = 7;


MUII_SHADOW

Declaration

Source position: mui.pas line 348

const MUII_SHADOW = 129;


MUII_SHADOWBACK

Declaration

Source position: mui.pas line 351

const MUII_SHADOWBACK = 132;


MUII_SHADOWFILL

Declaration

Source position: mui.pas line 352

const MUII_SHADOWFILL = 133;


MUII_SHADOWSHINE

Declaration

Source position: mui.pas line 353

const MUII_SHADOWSHINE = 134;


MUII_SHINE

Declaration

Source position: mui.pas line 349

const MUII_SHINE = 130;


MUII_SHINEBACK

Declaration

Source position: mui.pas line 356

const MUII_SHINEBACK = 137;


MUII_SliderBack

Declaration

Source position: mui.pas line 325

const MUII_SliderBack = 36;


MUII_SliderKnob

Declaration

Source position: mui.pas line 326

const MUII_SliderKnob = 37;


MUII_StringActiveBack

Declaration

Source position: mui.pas line 339

const MUII_StringActiveBack = 50;


MUII_StringBack

Declaration

Source position: mui.pas line 338

const MUII_StringBack = 49;


MUII_TapeDown

Declaration

Source position: mui.pas line 328

const MUII_TapeDown = 39;


MUII_TapePause

Declaration

Source position: mui.pas line 321

const MUII_TapePause = 32;


MUII_TapePlay

Declaration

Source position: mui.pas line 319

const MUII_TapePlay = 30;


MUII_TapePlayBack

Declaration

Source position: mui.pas line 320

const MUII_TapePlayBack = 31;


MUII_TapeRecord

Declaration

Source position: mui.pas line 323

const MUII_TapeRecord = 34;


MUII_TapeStop

Declaration

Source position: mui.pas line 322

const MUII_TapeStop = 33;


MUII_TapeUp

Declaration

Source position: mui.pas line 327

const MUII_TapeUp = 38;


MUII_TextBack

Declaration

Source position: mui.pas line 293

const MUII_TextBack = 4;


MUII_Volume

Declaration

Source position: mui.pas line 315

const MUII_Volume = 26;


MUII_WindowBack

Declaration

Source position: mui.pas line 289

const MUII_WindowBack = 0;


MUIIHNF_TIMER

Declaration

Source position: mui.pas line 1089

const MUIIHNF_TIMER = 1 shl 0;


MUIIHNF_TIMER_SCALE10

Declaration

Source position: mui.pas line 1090

const MUIIHNF_TIMER_SCALE10 = 1 shl 1;


MUIIHNF_TIMER_SCALE100

Declaration

Source position: mui.pas line 1091

const MUIIHNF_TIMER_SCALE100 = 1 shl 2;


MUIKEY_BOTTOM

Declaration

Source position: mui.pas line 3627

const MUIKEY_BOTTOM = 7;


MUIKEY_COUNT

Declaration

Source position: mui.pas line 3642

const MUIKEY_COUNT = 22;


MUIKEY_DOWN

Declaration

Source position: mui.pas line 3623

const MUIKEY_DOWN = 3;


MUIKEY_GADGET_NEXT

Declaration

Source position: mui.pas line 3634

const MUIKEY_GADGET_NEXT = 14;


MUIKEY_GADGET_OFF

Declaration

Source position: mui.pas line 3636

const MUIKEY_GADGET_OFF = 16;


MUIKEY_GADGET_PREV

Declaration

Source position: mui.pas line 3635

const MUIKEY_GADGET_PREV = 15;


MUIKEY_HELP

Declaration

Source position: mui.pas line 3640

const MUIKEY_HELP = 20;


MUIKEY_LEFT

Declaration

Source position: mui.pas line 3628

const MUIKEY_LEFT = 8;


MUIKEY_LINEEND

Declaration

Source position: mui.pas line 3633

const MUIKEY_LINEEND = 13;


MUIKEY_LINESTART

Declaration

Source position: mui.pas line 3632

const MUIKEY_LINESTART = 12;


MUIKEY_NONE

Declaration

Source position: mui.pas line 3619

const MUIKEY_NONE = - 1;


MUIKEY_PAGEDOWN

Declaration

Source position: mui.pas line 3625

const MUIKEY_PAGEDOWN = 5;


MUIKEY_PAGEUP

Declaration

Source position: mui.pas line 3624

const MUIKEY_PAGEUP = 4;


MUIKEY_POPUP

Declaration

Source position: mui.pas line 3641

const MUIKEY_POPUP = 21;


MUIKEY_PRESS

Declaration

Source position: mui.pas line 3620

const MUIKEY_PRESS = 0;


MUIKEY_RELEASE

Declaration

Source position: mui.pas line 3618

const MUIKEY_RELEASE = - 2;


MUIKEY_RIGHT

Declaration

Source position: mui.pas line 3629

const MUIKEY_RIGHT = 9;


MUIKEY_TOGGLE

Declaration

Source position: mui.pas line 3621

const MUIKEY_TOGGLE = 1;


MUIKEY_TOP

Declaration

Source position: mui.pas line 3626

const MUIKEY_TOP = 6;


MUIKEY_UP

Declaration

Source position: mui.pas line 3622

const MUIKEY_UP = 2;


MUIKEY_WINDOW_CLOSE

Declaration

Source position: mui.pas line 3637

const MUIKEY_WINDOW_CLOSE = 17;


MUIKEY_WINDOW_NEXT

Declaration

Source position: mui.pas line 3638

const MUIKEY_WINDOW_NEXT = 18;


MUIKEY_WINDOW_PREV

Declaration

Source position: mui.pas line 3639

const MUIKEY_WINDOW_PREV = 19;


MUIKEY_WORDLEFT

Declaration

Source position: mui.pas line 3630

const MUIKEY_WORDLEFT = 10;


MUIKEY_WORDRIGHT

Declaration

Source position: mui.pas line 3631

const MUIKEY_WORDRIGHT = 11;


MUIKEYF_BOTTOM

Declaration

Source position: mui.pas line 3652

const MUIKEYF_BOTTOM = 1 shl MUIKEY_BOTTOM;


MUIKEYF_DOWN

Declaration

Source position: mui.pas line 3648

const MUIKEYF_DOWN = 1 shl MUIKEY_DOWN;


MUIKEYF_GADGET_NEXT

Declaration

Source position: mui.pas line 3659

const MUIKEYF_GADGET_NEXT = 1 shl MUIKEY_GADGET_NEXT;


MUIKEYF_GADGET_OFF

Declaration

Source position: mui.pas line 3661

const MUIKEYF_GADGET_OFF = 1 shl MUIKEY_GADGET_OFF;


MUIKEYF_GADGET_PREV

Declaration

Source position: mui.pas line 3660

const MUIKEYF_GADGET_PREV = 1 shl MUIKEY_GADGET_PREV;


MUIKEYF_HELP

Declaration

Source position: mui.pas line 3665

const MUIKEYF_HELP = 1 shl MUIKEY_HELP;


MUIKEYF_LEFT

Declaration

Source position: mui.pas line 3653

const MUIKEYF_LEFT = 1 shl MUIKEY_LEFT;


MUIKEYF_LINEEND

Declaration

Source position: mui.pas line 3658

const MUIKEYF_LINEEND = 1 shl MUIKEY_LINEEND;


MUIKEYF_LINESTART

Declaration

Source position: mui.pas line 3657

const MUIKEYF_LINESTART = 1 shl MUIKEY_LINESTART;


MUIKEYF_PAGEDOWN

Declaration

Source position: mui.pas line 3650

const MUIKEYF_PAGEDOWN = 1 shl MUIKEY_PAGEDOWN;


MUIKEYF_PAGEUP

Declaration

Source position: mui.pas line 3649

const MUIKEYF_PAGEUP = 1 shl MUIKEY_PAGEUP;


MUIKEYF_POPUP

Declaration

Source position: mui.pas line 3666

const MUIKEYF_POPUP = 1 shl MUIKEY_POPUP;


MUIKEYF_PRESS

Declaration

Source position: mui.pas line 3645

const MUIKEYF_PRESS = 1 shl MUIKEY_PRESS;


MUIKEYF_RIGHT

Declaration

Source position: mui.pas line 3654

const MUIKEYF_RIGHT = 1 shl MUIKEY_RIGHT;


MUIKEYF_TOGGLE

Declaration

Source position: mui.pas line 3646

const MUIKEYF_TOGGLE = 1 shl MUIKEY_TOGGLE;


MUIKEYF_TOP

Declaration

Source position: mui.pas line 3651

const MUIKEYF_TOP = 1 shl MUIKEY_TOP;


MUIKEYF_UP

Declaration

Source position: mui.pas line 3647

const MUIKEYF_UP = 1 shl MUIKEY_UP;


MUIKEYF_WINDOW_CLOSE

Declaration

Source position: mui.pas line 3662

const MUIKEYF_WINDOW_CLOSE = 1 shl MUIKEY_WINDOW_CLOSE;


MUIKEYF_WINDOW_NEXT

Declaration

Source position: mui.pas line 3663

const MUIKEYF_WINDOW_NEXT = 1 shl MUIKEY_WINDOW_NEXT;


MUIKEYF_WINDOW_PREV

Declaration

Source position: mui.pas line 3664

const MUIKEYF_WINDOW_PREV = 1 shl MUIKEY_WINDOW_PREV;


MUIKEYF_WORDLEFT

Declaration

Source position: mui.pas line 3655

const MUIKEYF_WORDLEFT = 1 shl MUIKEY_WORDLEFT;


MUIKEYF_WORDRIGHT

Declaration

Source position: mui.pas line 3656

const MUIKEYF_WORDRIGHT = 1 shl MUIKEY_WORDRIGHT;


MUILM_LAYOUT

Declaration

Source position: mui.pas line 1853

const MUILM_LAYOUT = 2;


MUILM_MINMAX

Declaration

Source position: mui.pas line 1852

const MUILM_MINMAX = 1;


MUILM_UNKNOWN

Declaration

Source position: mui.pas line 1854

const MUILM_UNKNOWN = - 1;


MUIM_Application_AboutMUI

Declaration

Source position: mui.pas line 874

const MUIM_Application_AboutMUI = MUIB_MUI or $42d21d;


MUIM_Application_AddInputHandler

Declaration

Source position: mui.pas line 875

const MUIM_Application_AddInputHandler = MUIB_MUI or $42f099;


MUIM_Application_CheckRefresh

Declaration

Source position: mui.pas line 876

const MUIM_Application_CheckRefresh = MUIB_MUI or $424d68;


MUIM_Application_Execute

Declaration

Source position: mui.pas line 898

const MUIM_Application_Execute = MUIB_Application or $00000003;


MUIM_Application_GetMenuCheck

Declaration

Source position: mui.pas line 877

const MUIM_Application_GetMenuCheck = MUIB_MUI or $42c0a7;


MUIM_Application_GetMenuState

Declaration

Source position: mui.pas line 878

const MUIM_Application_GetMenuState = MUIB_MUI or $42a58f;


MUIM_Application_Iconify

Declaration

Source position: mui.pas line 897

const MUIM_Application_Iconify = MUIB_Application or $00000002;


MUIM_Application_Input

Declaration

Source position: mui.pas line 879

const MUIM_Application_Input = MUIB_MUI or $42d0f5;


MUIM_Application_InputBuffered

Declaration

Source position: mui.pas line 880

const MUIM_Application_InputBuffered = MUIB_MUI or $427e59;


MUIM_Application_Load

Declaration

Source position: mui.pas line 881

const MUIM_Application_Load = MUIB_MUI or $42f90d;


MUIM_Application_NewInput

Declaration

Source position: mui.pas line 882

const MUIM_Application_NewInput = MUIB_MUI or $423ba6;


MUIM_Application_OpenConfigWindow

Declaration

Source position: mui.pas line 883

const MUIM_Application_OpenConfigWindow = MUIB_MUI or $4299ba;


MUIM_Application_OpenWindows

Declaration

Source position: mui.pas line 896

const MUIM_Application_OpenWindows = MUIB_Application or $00000001;


MUIM_Application_PushMethod

Declaration

Source position: mui.pas line 884

const MUIM_Application_PushMethod = MUIB_MUI or $429ef8;


MUIM_Application_RemInputHandler

Declaration

Source position: mui.pas line 885

const MUIM_Application_RemInputHandler = MUIB_MUI or $42e7af;


MUIM_Application_ReturnID

Declaration

Source position: mui.pas line 886

const MUIM_Application_ReturnID = MUIB_MUI or $4276ef;


MUIM_Application_Save

Declaration

Source position: mui.pas line 887

const MUIM_Application_Save = MUIB_MUI or $4227ef;


MUIM_Application_SetConfigdata

Declaration

Source position: mui.pas line 895

const MUIM_Application_SetConfigdata = MUIB_Application or $00000000;


MUIM_Application_SetConfigItem

Declaration

Source position: mui.pas line 888

const MUIM_Application_SetConfigItem = MUIB_MUI or $424a80;


MUIM_Application_SetMenuCheck

Declaration

Source position: mui.pas line 889

const MUIM_Application_SetMenuCheck = MUIB_MUI or $42a707;


MUIM_Application_SetMenuState

Declaration

Source position: mui.pas line 890

const MUIM_Application_SetMenuState = MUIB_MUI or $428bef;


MUIM_Application_ShowHelp

Declaration

Source position: mui.pas line 891

const MUIM_Application_ShowHelp = MUIB_MUI or $426479;


MUIM_Application_UnpushMethod

Declaration

Source position: mui.pas line 892

const MUIM_Application_UnpushMethod = MUIB_MUI or $4211dd;


MUIM_Application_UpdateMenus

Declaration

Source position: mui.pas line 899

const MUIM_Application_UpdateMenus = MUIB_Application or $00000004;


MUIM_AskMinMax

Declaration

Source position: mui.pas line 1372

const MUIM_AskMinMax = MUIB_MUI or $423874;


MUIM_BoopsiQuery

Declaration

Source position: mui.pas line 519

const MUIM_BoopsiQuery = $80427157;


MUIM_CallHook

Call a standard amiga callback hook

Declaration

Source position: mui.pas line 615

const MUIM_CallHook = MUIB_MUI or $42b96b;

Description

Call a standard amiga callback hook, defined by a Hook structure. Together with MUIM_Notify, you can easily bind hooks to buttons, your hook will be called when the button is pressed.

The hook will be called with a pointer to the hook structure, a pointer to the calling object and a pointer to the first parameter.

See also

MUIM_Notify

Add a notification event handler to an object


MUIM_Cleanup

Declaration

Source position: mui.pas line 1373

const MUIM_Cleanup = MUIB_MUI or $42d985;


MUIM_Configdata_GetString

Declaration

Source position: mui.pas line 2916

const MUIM_Configdata_GetString = MUIB_Configdata or $00000000;


MUIM_Configdata_GetULong

Declaration

Source position: mui.pas line 2917

const MUIM_Configdata_GetULong = MUIB_Configdata or $00000001;


MUIM_Configdata_GetWindowPos

Declaration

Source position: mui.pas line 2914

const MUIM_Configdata_GetWindowPos = MUIB_Configdata or $0000002A;


MUIM_Configdata_Load

Declaration

Source position: mui.pas line 2923

const MUIM_Configdata_Load = MUIB_Configdata or $00000007;


MUIM_Configdata_Save

Declaration

Source position: mui.pas line 2922

const MUIM_Configdata_Save = MUIB_Configdata or $00000006;


MUIM_Configdata_SetFont

Declaration

Source position: mui.pas line 2921

const MUIM_Configdata_SetFont = MUIB_Configdata or $00000005;


MUIM_Configdata_SetFramespec

Declaration

Source position: mui.pas line 2920

const MUIM_Configdata_SetFramespec = MUIB_Configdata or $00000004;


MUIM_Configdata_SetImspec

Declaration

Source position: mui.pas line 2919

const MUIM_Configdata_SetImspec = MUIB_Configdata or $00000003;


MUIM_Configdata_SetPenspec

Declaration

Source position: mui.pas line 2924

const MUIM_Configdata_SetPenspec = MUIB_Configdata or $00000008;


MUIM_Configdata_SetString

Declaration

Source position: mui.pas line 2925

const MUIM_Configdata_SetString = MUIB_Configdata or $00000009;


MUIM_Configdata_SetULong

Declaration

Source position: mui.pas line 2918

const MUIM_Configdata_SetULong = MUIB_Configdata or $00000002;


MUIM_Configdata_SetWindowPos

Declaration

Source position: mui.pas line 2915

const MUIM_Configdata_SetWindowPos = MUIB_Configdata or $0000002B;


MUIM_ConnectParent

Declaration

Source position: mui.pas line 633

const MUIM_ConnectParent = MUIB_Notify or 0;


MUIM_ContextMenuBuild

Declaration

Source position: mui.pas line 1374

const MUIM_ContextMenuBuild = MUIB_MUI or $429d2e;


MUIM_ContextMenuChoice

Declaration

Source position: mui.pas line 1375

const MUIM_ContextMenuChoice = MUIB_MUI or $420f0e;


MUIM_CreateBubble

Declaration

Source position: mui.pas line 1376

const MUIM_CreateBubble = MUIB_MUI or $421c41;


MUIM_CreateDragImage

Declaration

Source position: mui.pas line 1377

const MUIM_CreateDragImage = MUIB_MUI or $42eb6f;


MUIM_CreateShortHelp

Declaration

Source position: mui.pas line 1378

const MUIM_CreateShortHelp = MUIB_MUI or $428e93;


MUIM_CustomBackfill

Declaration

Source position: mui.pas line 1379

const MUIM_CustomBackfill = MUIB_MUI or $428d73;


MUIM_Dataspace_Add

Declaration

Source position: mui.pas line 2224

const MUIM_Dataspace_Add = MUIB_MUI or $423366;


MUIM_Dataspace_Clear

Declaration

Source position: mui.pas line 2225

const MUIM_Dataspace_Clear = MUIB_MUI or $42b6c9;


MUIM_Dataspace_Find

Declaration

Source position: mui.pas line 2226

const MUIM_Dataspace_Find = MUIB_MUI or $42832c;


MUIM_Dataspace_Merge

Declaration

Source position: mui.pas line 2227

const MUIM_Dataspace_Merge = MUIB_MUI or $423e2b;


MUIM_Dataspace_ReadIFF

Declaration

Source position: mui.pas line 2228

const MUIM_Dataspace_ReadIFF = MUIB_MUI or $420dfb;


MUIM_Dataspace_Remove

Declaration

Source position: mui.pas line 2229

const MUIM_Dataspace_Remove = MUIB_MUI or $42dce1;


MUIM_Dataspace_WriteIFF

Declaration

Source position: mui.pas line 2230

const MUIM_Dataspace_WriteIFF = MUIB_MUI or $425e8e;


MUIM_DeleteBubble

Declaration

Source position: mui.pas line 1380

const MUIM_DeleteBubble = MUIB_MUI or $4211af;


MUIM_DeleteDragImage

Declaration

Source position: mui.pas line 1381

const MUIM_DeleteDragImage = MUIB_MUI or $423037;


MUIM_DeleteShortHelp

Declaration

Source position: mui.pas line 1382

const MUIM_DeleteShortHelp = MUIB_MUI or $42d35a;


MUIM_Dirlist_ReRead

Declaration

Source position: mui.pas line 3373

const MUIM_Dirlist_ReRead = MUIB_MUI or $422d71;


MUIM_DisconnectParent

Declaration

Source position: mui.pas line 634

const MUIM_DisconnectParent = MUIB_Notify or 1;


MUIM_DoDrag

Declaration

Source position: mui.pas line 1383

const MUIM_DoDrag = MUIB_MUI or $4216bb;


MUIM_DragBegin

Declaration

Source position: mui.pas line 1384

const MUIM_DragBegin = MUIB_MUI or $42c03a;


MUIM_DragDrop

Declaration

Source position: mui.pas line 1385

const MUIM_DragDrop = MUIB_MUI or $42c555;


MUIM_DragFinish

Declaration

Source position: mui.pas line 1386

const MUIM_DragFinish = MUIB_MUI or $4251f0;


MUIM_DragQuery

Declaration

Source position: mui.pas line 1387

const MUIM_DragQuery = MUIB_MUI or $420261;


MUIM_DragReport

Declaration

Source position: mui.pas line 1388

const MUIM_DragReport = MUIB_MUI or $42edad;


MUIM_Draw

Declaration

Source position: mui.pas line 1389

const MUIM_Draw = MUIB_MUI or $426f3f;


MUIM_DrawBackground

Declaration

Source position: mui.pas line 1390

const MUIM_DrawBackground = MUIB_MUI or $4238ca;


MUIM_DrawParentBackground

Declaration

Source position: mui.pas line 1401

const MUIM_DrawParentBackground = MUIB_Area or $1;


MUIM_Export

Called on export object to dataspace

Declaration

Source position: mui.pas line 616

const MUIM_Export = MUIB_MUI or $420f1c;

Description

DoMethod(obj, MUIM_Export, [DataSpace: PObject_]);

DataSpace
- dataspace object to save the properties.

This method is called for each object in the application tree (including menus) during execution of MUIM_Application_Save. It's purpose is to export an objects "contents" to a dataspace object for later saving to an IFF file.

If you override this method to export your custom data, you are supposed to use your MUIA_ObjectID as ID for the dataspace entry. Don't export if your MUIA_ObjectID is 0.

Return 0 if you dont want your superclasses to be able to import/export any values themselves. Otherwise Result := DoSuperMethodA(cl,obj,msg);

See also

MUIA_ObjectID |
MUIM_Import | Called on import object from dataspace
MUIM_Application_Load |
MUIM_Application_Save |


MUIM_Family_AddHead

Declaration

Source position: mui.pas line 793

const MUIM_Family_AddHead = MUIB_MUI or $42e200;


MUIM_Family_AddTail

Declaration

Source position: mui.pas line 794

const MUIM_Family_AddTail = MUIB_MUI or $42d752;


MUIM_Family_DoChildMethods

Declaration

Source position: mui.pas line 800

const MUIM_Family_DoChildMethods = MUIB_MUI or $429a3c;


MUIM_Family_GetChild

Declaration

Source position: mui.pas line 799

const MUIM_Family_GetChild = MUIB_MUI or $42c556;


MUIM_Family_Insert

Declaration

Source position: mui.pas line 795

const MUIM_Family_Insert = MUIB_MUI or $424d34;


MUIM_Family_Remove

Declaration

Source position: mui.pas line 796

const MUIM_Family_Remove = MUIB_MUI or $42f8a9;


MUIM_Family_Sort

Declaration

Source position: mui.pas line 797

const MUIM_Family_Sort = MUIB_MUI or $421c49;


MUIM_Family_Transfer

Declaration

Source position: mui.pas line 798

const MUIM_Family_Transfer = MUIB_MUI or $42c14a;


MUIM_FindUData

Find a userdata in objects and childrens list and return the object

Declaration

Source position: mui.pas line 617

const MUIM_FindUData = MUIB_MUI or $42c196;

Description

DoMethod(obj, MUIM_FindUData, [UData: IPTR]);

UData
- userdata to look for.

This method tests if the MUIA_UserData of the object contains the given UData and returns the object pointer in this case.

Although this is not very useful for single objects, performing this method on objects that handle children can become very handy. In this case, all the children (any maybe their children) are tested against UData and the first matching object is returned.

This method is especially useful if you created your menu tree with a NewMenu structure and you want to find the object pointer for a single menu item.

Note: If you have many objects in your application, MUIM_FindUData may take quite long. You can limit the amount of time by performing the method not on the application but on the window or even on the group/family your object is placed in.

See also

MUIM_GetUData |
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object


MUIM_Floattext_Append

Declaration

Source position: mui.pas line 2709

const MUIM_Floattext_Append = MUIB_MUI or $42a221;


MUIM_GetConfigItem

Declaration

Source position: mui.pas line 618

const MUIM_GetConfigItem = MUIB_MUI or $423edb;

Description

DoMethod(obj, MUIM_GetConfigItem, [id: LongWord, Storage: PLongWord]);


MUIM_GetUData

Declaration

Source position: mui.pas line 619

const MUIM_GetUData = MUIB_MUI or $42ed0c;

Description

DoMethod(obj, MUIM_GetUData, [udata: IPTR, Attr: LongWord, Storage: PLongWord]);

UData
- userdata to look for.
Attr
- attribute to get.
Storage
- place to store the attribute.

This method tests if the MUIA_UserData of the object contains the given UData and gets Attr to Storage for itself in this case.

Although this is not very useful for single objects, performing this method on objects that handle children can become very handy. In this case, all the children (any maybe their children) are searched against UData and the first matching objects will be asked for the specified attribute.

Note: If you have many objects in your application, MUIM_GetUData may take quite long. You can limit the amount of time by performing the method not on the application but on the window or even on the group/family your objects are place in.

See also

MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object


MUIM_GoActive

Declaration

Source position: mui.pas line 1391

const MUIM_GoActive = MUIB_MUI or $42491a;


MUIM_GoInactive

Declaration

Source position: mui.pas line 1392

const MUIM_GoInactive = MUIB_MUI or $422c0c;


MUIM_Group_AddHead

Declaration

Source position: mui.pas line 1760

const MUIM_Group_AddHead = MUIB_MUI or $42e200;


MUIM_Group_AddTail

Declaration

Source position: mui.pas line 1761

const MUIM_Group_AddTail = MUIB_MUI or $42d752;


MUIM_Group_DoMethodNoForward

Declaration

Source position: mui.pas line 1767

const MUIM_Group_DoMethodNoForward = MUIB_Group or $0;


MUIM_Group_ExitChange

Declaration

Source position: mui.pas line 1762

const MUIM_Group_ExitChange = MUIB_MUI or $42d1cc;


MUIM_Group_InitChange

Declaration

Source position: mui.pas line 1763

const MUIM_Group_InitChange = MUIB_MUI or $420887;


MUIM_Group_Remove

Declaration

Source position: mui.pas line 1765

const MUIM_Group_Remove = MUIB_MUI or $42f8a9;


MUIM_Group_Sort

Declaration

Source position: mui.pas line 1764

const MUIM_Group_Sort = MUIB_MUI or $427417;


MUIM_HandleEvent

Declaration

Source position: mui.pas line 1393

const MUIM_HandleEvent = MUIB_MUI or $426d66;


MUIM_HandleInput

Declaration

Source position: mui.pas line 1394

const MUIM_HandleInput = MUIB_MUI or $422a1a;


MUIM_Hide

Declaration

Source position: mui.pas line 1395

const MUIM_Hide = MUIB_MUI or $42f20f;


MUIM_Import

Called on import object from dataspace

Declaration

Source position: mui.pas line 620

const MUIM_Import = MUIB_MUI or $42d012;

Description

DoMethod(obj, MUIM_Import, [DataSpace: PObject_]);

DataSpace
dataspace object to save the properties.

This method is called for each object in the application tree (including menus) during execution of MUIM_Application_Load. It's purpose is to import an objects "contents" from a dataspace object after loading from an IFF file.

If you override this method to import your custom data, you are supposed to use your MUIA_ObjectID as ID for the dataspace entry. Don't import if your MUIA_ObjectID is 0.

See also

MUIM_Application_Load

MUIM_Application_Save


MUIM_KillNotify

kills previously given notifications on specific attributes

Declaration

Source position: mui.pas line 621

const MUIM_KillNotify = MUIB_MUI or $42d240;

Description

DoMethod(obj, MUIM_KillNotify, [TrigAttr: LongWord]);

TrigAttr
Attribute for which the notify was specified. If you set up more than one notify for an attribute, only the first one will be killed.

See also

MUIM_Notify

Add a notification event handler to an object


MUIM_KillNotifyObj

Declaration

Source position: mui.pas line 622

const MUIM_KillNotifyObj = MUIB_MUI or $42b145;

Description

DoMethod(obj, MUIM_KillNotifyObj, [TrigAttr: LongWord, Dest: PObject_]);


MUIM_Layout

Declaration

Source position: mui.pas line 1400

const MUIM_Layout = MUIB_Area or $0;


MUIM_List_Clear

Declaration

Source position: mui.pas line 2467

const MUIM_List_Clear = MUIB_MUI or $42ad89;


MUIM_List_Compare

Declaration

Source position: mui.pas line 2468

const MUIM_List_Compare = MUIB_MUI or $421b68;


MUIM_List_Construct

Declaration

Source position: mui.pas line 2469

const MUIM_List_Construct = MUIB_MUI or $42d662;


MUIM_List_CreateImage

Declaration

Source position: mui.pas line 2470

const MUIM_List_CreateImage = MUIB_MUI or $429804;


MUIM_List_DeleteImage

Declaration

Source position: mui.pas line 2471

const MUIM_List_DeleteImage = MUIB_MUI or $420f58;


MUIM_List_Exchange

Declaration

Source position: mui.pas line 2472

const MUIM_List_Exchange = MUIB_MUI or $42468c;


MUIM_List_GetEntry

Declaration

Source position: mui.pas line 2473

const MUIM_List_GetEntry = MUIB_MUI or $4280ec;


MUIM_List_Insert

Declaration

Source position: mui.pas line 2474

const MUIM_List_Insert = MUIB_MUI or $426c87;


MUIM_List_InsertSingle

Declaration

Source position: mui.pas line 2475

const MUIM_List_InsertSingle = MUIB_MUI or $4254d5;


MUIM_List_Jump

Declaration

Source position: mui.pas line 2476

const MUIM_List_Jump = MUIB_MUI or $42baab;


MUIM_List_Move

Declaration

Source position: mui.pas line 2477

const MUIM_List_Move = MUIB_MUI or $4253c2;


MUIM_List_NextSelected

Declaration

Source position: mui.pas line 2478

const MUIM_List_NextSelected = MUIB_MUI or $425f17;


MUIM_List_Redraw

Declaration

Source position: mui.pas line 2479

const MUIM_List_Redraw = MUIB_MUI or $427993;


MUIM_List_Remove

Declaration

Source position: mui.pas line 2480

const MUIM_List_Remove = MUIB_MUI or $42647e;


MUIM_List_Select

Declaration

Source position: mui.pas line 2481

const MUIM_List_Select = MUIB_MUI or $4252d8;


MUIM_List_Sort

Declaration

Source position: mui.pas line 2482

const MUIM_List_Sort = MUIB_MUI or $422275;


MUIM_List_TestPos

Declaration

Source position: mui.pas line 2483

const MUIM_List_TestPos = MUIB_MUI or $425f48;


MUIM_MultiSet

Set an attribute for multiple objects.

Declaration

Source position: mui.pas line 623

const MUIM_MultiSet = MUIB_MUI or $42d356;

Description

DoMethod(obj, MUIM_Export, [TrigAttr: LongWord; Val: IPTR, Obj1: APTR, ...]);

TrigAttr
- attribute to set.
value
- new value for the attribute.
Obj1, ...
- list of MUI objects, terminated with a nil pointer.

Set an attribute for multiple objects. Receiving an attribute/value pair and a list of objects, this method sets the new value for all the objects in the list. This is especially useful for disabling/enabling lots of objects with one singe function call.

The object that executes this method isn't affected!

See also

MUIM_Notify | Add a notification event handler to an object
MUIM_Set | Set an attribute to a value.


MUIM_NoNotifySet

Acts like MUIM_Set but doesn't trigger any notification.

Declaration

Source position: mui.pas line 624

const MUIM_NoNotifySet = MUIB_MUI or $42216f;

Description

DoMethod(obj, MUIM_Export, [Attr: LongWord, Val: LongWord, ...]);

Attr
- attribute you want to set.
Val
- value to set the attribute to.

This can become useful to avoid deadlocks with bi-directional connections.


MUIM_Notify

Add a notification event handler to an object

Declaration

Source position: mui.pas line 625

const MUIM_Notify = MUIB_MUI or $42c9cb;

Description

DoMethod(obj, MUIM_Notify, [TrigAttr: LongWord, TrigVal: LongWord, DestObj: APTR, FollowParams: LongWord, ... );

TrigAttr
attribute that triggers the notification.
TrigValue
value that triggers the notification. The special value MUIV_EveryTime makes MUI execute the notification method every time when TrigAttr changes. In this case, the special value MUIV_TriggerValue in the notification method will be replaced with the value that TrigAttr has been set to. You can use MUIV_TriggerValue up to four times in one notification method. Since version 8 of muimaster.library, you can also use MUIV_NotTriggerValue here. In this case, MUI will replace True values with False and False values with True. This can become quite useful when you try to set "negative" attributes like MUIA_Disabled.
DestObj
object on which to perform the notification method. Either supply a valid object pointer or one of the following special values (V10) which will be resolved at the time the event occurs: MUIV_Notify_Self - notifies the object itself. MUIV_Notify_Window - notifies the object's parent window. MUIV_Notify_Application - notifies the object's application.
FollowParams
number of following parameters. If you e.g. have a notification method with three parts (maybe MUIM_Set,attr,val), you have to set FollowParams to 3. This allows MUI to copy the complete notification method into a private buffer for later use.
...
following is the notification method.

Add a notification event handler to an object. Notification is essential for every MUI application.

A notification statement consists of a source object, an attribute/value pair, a destination object and a notification method. The attribute/value pair belongs to the source object and determines when the notification method will be executed on the destination object.

Whenever the source object gets the given attribute set to the given value (this can happen because of the user pressing some gadgets or because of your program explicitly setting the attribute with SetAttrs()), the destination object will execute the notification method.

With some special values, you can trigger the notification every time the attribute is changing. In this case, you can include the triggering attributes value within the notification method. See below.

One big problem with notification are endless loops. Imagine you have a prop gadget and want to show its state with a gauge object. You connect MUIA_Prop_First with MUIA_Gauge_Max and everything is fine, the gauge gets updated when the user drags around the gadget. On the other hand, if your program sets the gauge to a new value, you might want your prop gadget to immediately show this change and connect MUIA_Gauge_Max width MUIA_Prop_First. Voila, a perfect endless loop.

To avoid these conditions, MUI always checks new attribute values against the current state and cancels notification when both values are equal. Thus, setting MUIA_Prop_First to 42 if the prop gadgets first position is already 42 won't trigger any notification event.


MUIM_Numeric_Decrease

Declaration

Source position: mui.pas line 1911

const MUIM_Numeric_Decrease = MUIB_MUI or $4243a7;


MUIM_Numeric_Increase

Declaration

Source position: mui.pas line 1912

const MUIM_Numeric_Increase = MUIB_MUI or $426ecd;


MUIM_Numeric_ScaleToValue

Declaration

Source position: mui.pas line 1913

const MUIM_Numeric_ScaleToValue = MUIB_MUI or $42032c;


MUIM_Numeric_SetDefault

Declaration

Source position: mui.pas line 1914

const MUIM_Numeric_SetDefault = MUIB_MUI or $42ab0a;


MUIM_Numeric_Stringify

Declaration

Source position: mui.pas line 1915

const MUIM_Numeric_Stringify = MUIB_MUI or $424891;


MUIM_Numeric_ValueToScale

Declaration

Source position: mui.pas line 1916

const MUIM_Numeric_ValueToScale = MUIB_MUI or $423e4f;


MUIM_Numeric_ValueToScaleExt

Declaration

Source position: mui.pas line 1918

const MUIM_Numeric_ValueToScaleExt = MUIB_Numeric or $0;


MUIM_Pendisplay_SetColormap

Declaration

Source position: mui.pas line 3236

const MUIM_Pendisplay_SetColormap = MUIB_MUI or $426c80;


MUIM_Pendisplay_SetMUIPen

Declaration

Source position: mui.pas line 3237

const MUIM_Pendisplay_SetMUIPen = MUIB_MUI or $42039d;


MUIM_Pendisplay_SetRGB

Declaration

Source position: mui.pas line 3238

const MUIM_Pendisplay_SetRGB = MUIB_MUI or $42c131;


MUIM_Pixmap_DrawSection

Declaration

Source position: mui.pas line 3539

const MUIM_Pixmap_DrawSection = MUIB_MUI or $42ce0f;


MUIM_Popstring_Close

Declaration

Source position: mui.pas line 2735

const MUIM_Popstring_Close = MUIB_MUI or $42dc52;


MUIM_Popstring_Open

Declaration

Source position: mui.pas line 2736

const MUIM_Popstring_Open = MUIB_MUI or $4258ba;


MUIM_Process_Kill

Declaration

Source position: mui.pas line 3494

const MUIM_Process_Kill = MUIB_MUI or $4264cf;


MUIM_Process_Launch

Declaration

Source position: mui.pas line 3495

const MUIM_Process_Launch = MUIB_MUI or $425df7;


MUIM_Process_Process

Declaration

Source position: mui.pas line 3496

const MUIM_Process_Process = MUIB_MUI or $4230aa;


MUIM_Process_Signal

Declaration

Source position: mui.pas line 3497

const MUIM_Process_Signal = MUIB_MUI or $42e791;


MUIM_Prop_Decrease

Declaration

Source position: mui.pas line 2100

const MUIM_Prop_Decrease = MUIB_MUI or $420dd1;


MUIM_Prop_Increase

Declaration

Source position: mui.pas line 2101

const MUIM_Prop_Increase = MUIB_MUI or $42cac0;


MUIM_Semaphore_Attempt

Declaration

Source position: mui.pas line 2341

const MUIM_Semaphore_Attempt = MUIB_MUI or $426ce2;


MUIM_Semaphore_AttemptShared

Declaration

Source position: mui.pas line 2342

const MUIM_Semaphore_AttemptShared = MUIB_MUI or $422551;


MUIM_Semaphore_Obtain

Declaration

Source position: mui.pas line 2343

const MUIM_Semaphore_Obtain = MUIB_MUI or $4276f0;


MUIM_Semaphore_ObtainShared

Declaration

Source position: mui.pas line 2344

const MUIM_Semaphore_ObtainShared = MUIB_MUI or $42ea02;


MUIM_Semaphore_Release

Declaration

Source position: mui.pas line 2345

const MUIM_Semaphore_Release = MUIB_MUI or $421f2d;


MUIM_Set

Set an attribute to a value.

Declaration

Source position: mui.pas line 626

const MUIM_Set = MUIB_MUI or $42549a;

Description

DoMethod(obj, MUIM_Export, [Attr: LongWord; Value: IPTR]);

Attr
attribute you want to set.
value
value to set the attribute to.

Set an attribute to a value. Normally, you would set attributes with intuition.library SetAttrs() or with the OM_SET method as with any other boopsi objects. But since these calls need a complete tag list, not just a single attribute/value pair, they are not useful within a MUIM_Notify method.

See also

MUIM_SetAsString | Set a (text kind) attribute to a string.
MUIM_Notify | Add a notification event handler to an object
MUIM_NoNotifySet | Acts like MUIM_Set but doesn't trigger any notification.


MUIM_SetAsString

Set a (text kind) attribute to a string.

Declaration

Source position: mui.pas line 627

const MUIM_SetAsString = MUIB_MUI or $422590;

Description

DoMethod(obj, MUIM_Export, [Attr: LongWord; Format: PChar; Value: IPTR, ...]);

Attr
attribute you want to set.
Format
C like formatting string, remember to use '%ld'!
Value,...
one or more paremeters for the format string.

This can be useful if you want to connect a numeric attribute of an object with a text attribute of another object.

See also

MUIM_Set | Set an attribute to a value.
MUIM_Notify | Add a notification event handler to an object


MUIM_Settingsgroup_ConfigToGadgets

Declaration

Source position: mui.pas line 2869

const MUIM_Settingsgroup_ConfigToGadgets = MUIB_MUI or $427043;


MUIM_Settingsgroup_GadgetsToConfig

Declaration

Source position: mui.pas line 2870

const MUIM_Settingsgroup_GadgetsToConfig = MUIB_MUI or $425242;


MUIM_SetUData

Find a userdata in objects and childrens list and set an attribute of the object

Declaration

Source position: mui.pas line 628

const MUIM_SetUData = MUIB_MUI or $42c920;

Description

DoMethod(obj, MUIM_Export, [UData: IPTR; Attr: LongWord; Value: LongWord]);

UData
userdata to look for.
Attr
attribute to set.
Value
value to set attribute to.

This method tests if the MUIA_UserData of the object contains the given UData and sets Attr to Value for itself in this case.

Altough this is not very useful for single objects, performing this method on objects that handle children can become very handy. In this case, all the children (any maybe their children) are tested against UData and all matching objects will get the attribute set.

If you e.g. want to clear several string gadgets in your applciation at once, you simply give them the same MUIA_UserData and use

Note: If you have many objects in your application, MUIM_SetUData may take quite long. You can limit the amount of time by performing the method not on the application but on the window or even on the group your gadgets are place in.

See also

MUIM_GetUData |
MUIM_FindUData | Find a userdata in objects and childrens list and return the object
MUIM_SetUDataOnce | This method performs like MUIM_SetUData, but stop at first found object.


MUIM_SetUDataOnce

This method performs like MUIM_SetUData, but stop at first found object.

Declaration

Source position: mui.pas line 629

const MUIM_SetUDataOnce = MUIB_MUI or $42ca19;

Description

DoMethod(obj, MUIM_Export, [UData: IPTR; Attr: LongWord; Value: LongWord]);

UData
userdata to look for.
Attr
attribute to set.
Value
value to set attribute to.

This method performs like MUIM_SetUData, but stops when it has found an object with the given user data. If you don't have objects with equal user datas and don't rely on setting all of them, MUIM_SetUDataOnce is preferrable because it's more efficient.

See also

MUIM_SetUData | Find a userdata in objects and childrens list and set an attribute of the object
MUIM_GetUData |


MUIM_Setup

Declaration

Source position: mui.pas line 1396

const MUIM_Setup = MUIB_MUI or $428354;


MUIM_Show

Declaration

Source position: mui.pas line 1397

const MUIM_Show = MUIB_MUI or $42cc84;


MUIM_String_ClearSelected

Declaration

Source position: mui.pas line 2038

const MUIM_String_ClearSelected = $ad001004;


MUIM_String_FileNameStart

Declaration

Source position: mui.pas line 2039

const MUIM_String_FileNameStart = $ad001006;


MUIM_String_Insert

Declaration

Source position: mui.pas line 2040

const MUIM_String_Insert = $ad001002;


MUIM_UnknownDropDestination

Declaration

Source position: mui.pas line 1399

const MUIM_UnknownDropDestination = MUIB_MUI or $425550;


MUIM_Window_ActionIconify

Declaration

Source position: mui.pas line 1119

const MUIM_Window_ActionIconify = MUIB_MUI or $422cc0;


MUIM_Window_AddEventHandler

Declaration

Source position: mui.pas line 1120

const MUIM_Window_AddEventHandler = MUIB_MUI or $4203b7;


MUIM_Window_AllocGadgetID

Declaration

Source position: mui.pas line 1130

const MUIM_Window_AllocGadgetID = MUIB_Window or $1;


MUIM_Window_Cleanup

Declaration

Source position: mui.pas line 1121

const MUIM_Window_Cleanup = MUIB_MUI or $42ab26;


MUIM_Window_FreeGadgetID

Declaration

Source position: mui.pas line 1131

const MUIM_Window_FreeGadgetID = MUIB_Window or $4;


MUIM_Window_RemEventHandler

Declaration

Source position: mui.pas line 1122

const MUIM_Window_RemEventHandler = MUIB_MUI or $42679e;


MUIM_Window_ScreenToBack

Declaration

Source position: mui.pas line 1123

const MUIM_Window_ScreenToBack = MUIB_MUI or $42913d;


MUIM_Window_ScreenToFront

Declaration

Source position: mui.pas line 1124

const MUIM_Window_ScreenToFront = MUIB_MUI or $4227a4;


MUIM_Window_Setup

Declaration

Source position: mui.pas line 1125

const MUIM_Window_Setup = MUIB_MUI or $42c34c;


MUIM_Window_Snapshot

Declaration

Source position: mui.pas line 1126

const MUIM_Window_Snapshot = MUIB_MUI or $42945e;


MUIM_Window_ToBack

Declaration

Source position: mui.pas line 1127

const MUIM_Window_ToBack = MUIB_MUI or $42152e;


MUIM_Window_ToFront

Declaration

Source position: mui.pas line 1128

const MUIM_Window_ToFront = MUIB_MUI or $42554f;


MUIM_WriteLong

This method simply writes a longword somewhere to memory.

Declaration

Source position: mui.pas line 630

const MUIM_WriteLong = MUIB_MUI or $428d86;

Description

DoMethod(obj, MUIM_Export, [Value: LongWord, Memory: PLongWord]);

Value
value to set attribute to.
Memory
location to write the value to

This method simply writes a longword somewhere to memory. Although this seems quite useless, it might become handy if used within a notify statement. For instance, you could easily connect the current level of a slider with some member of your programs data structures.

See also

MUIM_WriteString | This method simply copies a string somewhere to memory.
MUIM_Notify | Add a notification event handler to an object


MUIM_WriteString

This method simply copies a string somewhere to memory.

Declaration

Source position: mui.pas line 631

const MUIM_WriteString = MUIB_MUI or $424bf4;

Description

DoMethod(obj, MUIM_Export, [Str: PChar, Memory: PChar]);

Str
string to copy
Memory
location to write the value to

This method simply copies a string somewhere to memory. Although this seems quite useless, it might become handy if used within a notify statement. For instance, you could easily connect the current contents of a string gadget with some member of your programs data structures.

Note: The string is copied with strcpy(), you must assure that the destination points to enough memory.

See also

MUIM_WriteLong | This method simply writes a longword somewhere to memory.
MUIM_Notify | Add a notification event handler to an object


MUIMASTER_NAME

Declaration

Source position: mui.pas line 121

const MUIMASTER_NAME: PChar = 'muimaster.library';


MUIMASTER_VLATEST

Declaration

Source position: mui.pas line 123

const MUIMASTER_VLATEST = 20;


MUIMASTER_VMIN

Declaration

Source position: mui.pas line 122

const MUIMASTER_VMIN = 20;


MUIMasterBase

Declaration

Source position: mui.pas line 3689

var MUIMasterBase: PLibrary = Nil;


MUIMRI_RECTFILL

Declaration

Source position: mui.pas line 574

const MUIMRI_RECTFILL = 1 shl 0;


MUIMRI_REFRESHMODE

Declaration

Source position: mui.pas line 577

const MUIMRI_REFRESHMODE = 1 shl 3;


MUIMRI_THINFRAMES

Declaration

Source position: mui.pas line 576

const MUIMRI_THINFRAMES = 1 shl 2;


MUIMRI_TRUECOLOR

Declaration

Source position: mui.pas line 575

const MUIMRI_TRUECOLOR = 1 shl 1;


MUIO_BarTitle

Declaration

Source position: mui.pas line 244

const MUIO_BarTitle = 15;


MUIO_Button

Declaration

Source position: mui.pas line 231

const MUIO_Button = 2;


MUIO_Checkmark

Declaration

Source position: mui.pas line 232

const MUIO_Checkmark = 3;


MUIO_Cycle

Declaration

Source position: mui.pas line 233

const MUIO_Cycle = 4;


MUIO_HBar

Declaration

Source position: mui.pas line 240

const MUIO_HBar = 11;


MUIO_HSpace

Declaration

Source position: mui.pas line 238

const MUIO_HSpace = 9;


MUIO_Label

Declaration

Source position: mui.pas line 230

const MUIO_Label = 1;


MUIO_Label_Centered

Declaration

Source position: mui.pas line 252

const MUIO_Label_Centered = 1 shl 11;


MUIO_Label_DontCopy

Declaration

Source position: mui.pas line 255

const MUIO_Label_DontCopy = 1 shl 14;


MUIO_Label_DoubleFrame

Declaration

Source position: mui.pas line 250

const MUIO_Label_DoubleFrame = 1 shl 9;


MUIO_Label_FreeVert

Declaration

Source position: mui.pas line 253

const MUIO_Label_FreeVert = 1 shl 12;


MUIO_Label_LeftAligned

Declaration

Source position: mui.pas line 251

const MUIO_Label_LeftAligned = 1 shl 10;


MUIO_Label_SingleFrame

Declaration

Source position: mui.pas line 249

const MUIO_Label_SingleFrame = 1 shl 8;


MUIO_Label_Tiny

Declaration

Source position: mui.pas line 254

const MUIO_Label_Tiny = 1 shl 13;


MUIO_Menuitem

Declaration

Source position: mui.pas line 243

const MUIO_Menuitem = 14;


MUIO_Menuitem_CopyStrings

Declaration

Source position: mui.pas line 247

const MUIO_Menuitem_CopyStrings = 1 shl 30;


MUIO_MenustripNM

Declaration

Source position: mui.pas line 242

const MUIO_MenustripNM = 13;


MUIO_MenustripNM_CommandKeyCheck

Declaration

Source position: mui.pas line 257

const MUIO_MenustripNM_CommandKeyCheck = 1 shl 0;


MUIO_NumericButton

Declaration

Source position: mui.pas line 245

const MUIO_NumericButton = 16;


MUIO_PopButton

Declaration

Source position: mui.pas line 237

const MUIO_PopButton = 8;


MUIO_Radio

Declaration

Source position: mui.pas line 234

const MUIO_Radio = 5;


MUIO_Slider

Declaration

Source position: mui.pas line 235

const MUIO_Slider = 6;


MUIO_String

Declaration

Source position: mui.pas line 236

const MUIO_String = 7;


MUIO_VBar

Declaration

Source position: mui.pas line 241

const MUIO_VBar = 12;


MUIO_VSpace

Declaration

Source position: mui.pas line 239

const MUIO_VSpace = 10;


MUIP_BoopsiQuery

Declaration

Source position: mui.pas line 594

type MUIP_BoopsiQuery = TMUI_BoopsiQuery;


MUIR_String_FileNameStart_Volume

Declaration

Source position: mui.pas line 2047

const MUIR_String_FileNameStart_Volume = $ffffffff;


MUIV_Application_Load_ENV

Declaration

Source position: mui.pas line 1096

const MUIV_Application_Load_ENV = 0;


MUIV_Application_Load_ENVARC

Declaration

Source position: mui.pas line 1097

const MUIV_Application_Load_ENVARC = - 1;


MUIV_Application_OCW_ScreenPage

Declaration

Source position: mui.pas line 1404

const MUIV_Application_OCW_ScreenPage = 1 shl 1;


MUIV_Application_Package_NetConnect

Declaration

Source position: mui.pas line 1078

const MUIV_Application_Package_NetConnect = $a3ff7b49;


MUIV_Application_ReturnID_Quit

Declaration

Source position: mui.pas line 1100

const MUIV_Application_ReturnID_Quit = - 1;


MUIV_Application_Save_ENV

Declaration

Source position: mui.pas line 1094

const MUIV_Application_Save_ENV = 0;


MUIV_Application_Save_ENVARC

Declaration

Source position: mui.pas line 1095

const MUIV_Application_Save_ENVARC = - 1;


MUIV_ContextMenuBuild_Default

Declaration

Source position: mui.pas line 1405

const MUIV_ContextMenuBuild_Default = $ffffffff;


MUIV_CreateBubble_DontHidePointer

Declaration

Source position: mui.pas line 1403

const MUIV_CreateBubble_DontHidePointer = 1 shl 0;


MUIV_Cycle_Active_Next

Declaration

Source position: mui.pas line 2789

const MUIV_Cycle_Active_Next = - 1;


MUIV_Cycle_Active_Prev

Declaration

Source position: mui.pas line 2790

const MUIV_Cycle_Active_Prev = - 2;


MUIV_Dirlist_SortDirs_First

Declaration

Source position: mui.pas line 3400

const MUIV_Dirlist_SortDirs_First = 0;


MUIV_Dirlist_SortDirs_Last

Declaration

Source position: mui.pas line 3401

const MUIV_Dirlist_SortDirs_Last = 1;


MUIV_Dirlist_SortDirs_Mix

Declaration

Source position: mui.pas line 3402

const MUIV_Dirlist_SortDirs_Mix = 2;


MUIV_Dirlist_SortType_Date

Declaration

Source position: mui.pas line 3405

const MUIV_Dirlist_SortType_Date = 1;


MUIV_Dirlist_SortType_Name

Declaration

Source position: mui.pas line 3404

const MUIV_Dirlist_SortType_Name = 0;


MUIV_Dirlist_SortType_Size

Declaration

Source position: mui.pas line 3406

const MUIV_Dirlist_SortType_Size = 2;


MUIV_Dirlist_Status_Invalid

Declaration

Source position: mui.pas line 3408

const MUIV_Dirlist_Status_Invalid = 0;


MUIV_Dirlist_Status_Reading

Declaration

Source position: mui.pas line 3409

const MUIV_Dirlist_Status_Reading = 1;


MUIV_Dirlist_Status_Valid

Declaration

Source position: mui.pas line 3410

const MUIV_Dirlist_Status_Valid = 2;


MUIV_DragQuery_Accept

Declaration

Source position: mui.pas line 381

const MUIV_DragQuery_Accept = 1;


MUIV_DragQuery_Refuse

Declaration

Source position: mui.pas line 380

const MUIV_DragQuery_Refuse = 0;


MUIV_DragReport_Abort

Declaration

Source position: mui.pas line 383

const MUIV_DragReport_Abort = 0;


MUIV_DragReport_Continue

Declaration

Source position: mui.pas line 384

const MUIV_DragReport_Continue = 1;


MUIV_DragReport_Lock

Declaration

Source position: mui.pas line 385

const MUIV_DragReport_Lock = 2;


MUIV_DragReport_Refresh

Declaration

Source position: mui.pas line 386

const MUIV_DragReport_Refresh = 3;


MUIV_EveryTime

Declaration

Source position: mui.pas line 370

const MUIV_EveryTime = $49893131;


MUIV_Family_GetChild_First

Declaration

Source position: mui.pas line 852

const MUIV_Family_GetChild_First = 0;


MUIV_Family_GetChild_Iterate

Declaration

Source position: mui.pas line 856

const MUIV_Family_GetChild_Iterate = - 4;


MUIV_Family_GetChild_Last

Declaration

Source position: mui.pas line 853

const MUIV_Family_GetChild_Last = - 1;


MUIV_Family_GetChild_Next

Declaration

Source position: mui.pas line 854

const MUIV_Family_GetChild_Next = - 2;


MUIV_Family_GetChild_Previous

Declaration

Source position: mui.pas line 855

const MUIV_Family_GetChild_Previous = - 3;


MUIV_Font_Big

Declaration

Source position: mui.pas line 451

const MUIV_Font_Big = - 6;


MUIV_Font_Button

Declaration

Source position: mui.pas line 452

const MUIV_Font_Button = - 7;


MUIV_Font_Fixed

Declaration

Source position: mui.pas line 449

const MUIV_Font_Fixed = - 4;


MUIV_Font_Inherit

Declaration

Source position: mui.pas line 445

const MUIV_Font_Inherit = 0;


MUIV_Font_Knob

Declaration

Source position: mui.pas line 453

const MUIV_Font_Knob = - 8;


MUIV_Font_List

Declaration

Source position: mui.pas line 447

const MUIV_Font_List = - 2;


MUIV_Font_NegCount

Declaration

Source position: mui.pas line 454

const MUIV_Font_NegCount = - 9;


MUIV_Font_Normal

Declaration

Source position: mui.pas line 446

const MUIV_Font_Normal = - 1;


MUIV_Font_Tiny

Declaration

Source position: mui.pas line 448

const MUIV_Font_Tiny = - 3;


MUIV_Font_Title

Declaration

Source position: mui.pas line 450

const MUIV_Font_Title = - 5;


MUIV_Frame_Button

Declaration

Source position: mui.pas line 1728

const MUIV_Frame_Button = 1;


MUIV_Frame_Count

Declaration

Source position: mui.pas line 1742

const MUIV_Frame_Count = 15;


MUIV_Frame_Drag

Declaration

Source position: mui.pas line 1741

const MUIV_Frame_Drag = 14;


MUIV_Frame_Gauge

Declaration

Source position: mui.pas line 1735

const MUIV_Frame_Gauge = 8;


MUIV_Frame_Group

Declaration

Source position: mui.pas line 1736

const MUIV_Frame_Group = 9;


MUIV_Frame_ImageButton

Declaration

Source position: mui.pas line 1729

const MUIV_Frame_ImageButton = 2;


MUIV_Frame_InputList

Declaration

Source position: mui.pas line 1733

const MUIV_Frame_InputList = 6;


MUIV_Frame_Knob

Declaration

Source position: mui.pas line 1740

const MUIV_Frame_Knob = 13;


MUIV_Frame_None

Declaration

Source position: mui.pas line 1727

const MUIV_Frame_None = 0;


MUIV_Frame_PopUp

Declaration

Source position: mui.pas line 1737

const MUIV_Frame_PopUp = 10;


MUIV_Frame_Prop

Declaration

Source position: mui.pas line 1734

const MUIV_Frame_Prop = 7;


MUIV_Frame_ReadList

Declaration

Source position: mui.pas line 1732

const MUIV_Frame_ReadList = 5;


MUIV_Frame_Register

Declaration

Source position: mui.pas line 1743

const MUIV_Frame_Register = 21;


MUIV_Frame_Slider

Declaration

Source position: mui.pas line 1739

const MUIV_Frame_Slider = 12;


MUIV_Frame_String

Declaration

Source position: mui.pas line 1731

const MUIV_Frame_String = 4;


MUIV_Frame_Text

Declaration

Source position: mui.pas line 1730

const MUIV_Frame_Text = 3;


MUIV_Frame_Virtual

Declaration

Source position: mui.pas line 1738

const MUIV_Frame_Virtual = 11;


MUIV_Group_ActivePage_Advance

Declaration

Source position: mui.pas line 1834

const MUIV_Group_ActivePage_Advance = - 4;


MUIV_Group_ActivePage_First

Declaration

Source position: mui.pas line 1830

const MUIV_Group_ActivePage_First = 0;


MUIV_Group_ActivePage_Last

Declaration

Source position: mui.pas line 1831

const MUIV_Group_ActivePage_Last = - 1;


MUIV_Group_ActivePage_Next

Declaration

Source position: mui.pas line 1833

const MUIV_Group_ActivePage_Next = - 3;


MUIV_Group_ActivePage_Prev

Declaration

Source position: mui.pas line 1832

const MUIV_Group_ActivePage_Prev = - 2;


MUIV_Group_GetChild_First

Declaration

Source position: mui.pas line 858

const MUIV_Group_GetChild_First = MUIV_Family_GetChild_First;


MUIV_Group_GetChild_Iterate

Declaration

Source position: mui.pas line 862

const MUIV_Group_GetChild_Iterate = MUIV_Family_GetChild_Iterate;


MUIV_Group_GetChild_Last

Declaration

Source position: mui.pas line 859

const MUIV_Group_GetChild_Last = MUIV_Family_GetChild_Last;


MUIV_Group_GetChild_Next

Declaration

Source position: mui.pas line 860

const MUIV_Group_GetChild_Next = MUIV_Family_GetChild_Next;


MUIV_Group_GetChild_Previous

Declaration

Source position: mui.pas line 861

const MUIV_Group_GetChild_Previous = MUIV_Family_GetChild_Previous;


MUIV_Imageadjust_Type_All

Declaration

Source position: mui.pas line 3177

const MUIV_Imageadjust_Type_All = 0;


MUIV_Imageadjust_Type_Background

Declaration

Source position: mui.pas line 3179

const MUIV_Imageadjust_Type_Background = 2;


MUIV_Imageadjust_Type_Image

Declaration

Source position: mui.pas line 3178

const MUIV_Imageadjust_Type_Image = 1;


MUIV_Imageadjust_Type_Pen

Declaration

Source position: mui.pas line 3180

const MUIV_Imageadjust_Type_Pen = 3;


MUIV_InputMode_Immediate

Declaration

Source position: mui.pas line 1747

const MUIV_InputMode_Immediate = 2;


MUIV_InputMode_None

Declaration

Source position: mui.pas line 1745

const MUIV_InputMode_None = 0;


MUIV_InputMode_RelVerify

Declaration

Source position: mui.pas line 1746

const MUIV_InputMode_RelVerify = 1;


MUIV_InputMode_Toggle

Declaration

Source position: mui.pas line 1748

const MUIV_InputMode_Toggle = 3;


MUIV_List_Active_Bottom

Declaration

Source position: mui.pas line 2630

const MUIV_List_Active_Bottom = - 3;


MUIV_List_Active_Down

Declaration

Source position: mui.pas line 2632

const MUIV_List_Active_Down = - 5;


MUIV_List_Active_Off

Declaration

Source position: mui.pas line 2628

const MUIV_List_Active_Off = - 1;


MUIV_List_Active_PageDown

Declaration

Source position: mui.pas line 2634

const MUIV_List_Active_PageDown = - 7;


MUIV_List_Active_PageUp

Declaration

Source position: mui.pas line 2633

const MUIV_List_Active_PageUp = - 6;


MUIV_List_Active_Top

Declaration

Source position: mui.pas line 2629

const MUIV_List_Active_Top = - 2;


MUIV_List_Active_Up

Declaration

Source position: mui.pas line 2631

const MUIV_List_Active_Up = - 4;


MUIV_List_ConstructHook_String

Declaration

Source position: mui.pas line 2636

const MUIV_List_ConstructHook_String = - 1;


MUIV_List_CopyHook_String

Declaration

Source position: mui.pas line 2639

const MUIV_List_CopyHook_String = - 1;


MUIV_List_CursorType_Bar

Declaration

Source position: mui.pas line 2642

const MUIV_List_CursorType_Bar = 1;


MUIV_List_CursorType_None

Declaration

Source position: mui.pas line 2641

const MUIV_List_CursorType_None = 0;


MUIV_List_CursorType_Rect

Declaration

Source position: mui.pas line 2643

const MUIV_List_CursorType_Rect = 2;


MUIV_List_DestructHook_String

Declaration

Source position: mui.pas line 2637

const MUIV_List_DestructHook_String = - 1;


MUIV_List_EditEntry_Active

Declaration

Source position: mui.pas line 2661

const MUIV_List_EditEntry_Active = - 1;


MUIV_List_Exchange_Active

Declaration

Source position: mui.pas line 2676

const MUIV_List_Exchange_Active = - 1;


MUIV_List_Exchange_Bottom

Declaration

Source position: mui.pas line 2677

const MUIV_List_Exchange_Bottom = - 2;


MUIV_List_Exchange_Next

Declaration

Source position: mui.pas line 2678

const MUIV_List_Exchange_Next = - 3;


MUIV_List_Exchange_Previous

Declaration

Source position: mui.pas line 2679

const MUIV_List_Exchange_Previous = - 4;


MUIV_List_Exchange_Top

Declaration

Source position: mui.pas line 2675

const MUIV_List_Exchange_Top = 0;


MUIV_List_GetEntry_Active

Declaration

Source position: mui.pas line 2660

const MUIV_List_GetEntry_Active = - 1;


MUIV_List_Insert_Active

Declaration

Source position: mui.pas line 2646

const MUIV_List_Insert_Active = - 1;


MUIV_List_Insert_Bottom

Declaration

Source position: mui.pas line 2648

const MUIV_List_Insert_Bottom = - 3;


MUIV_List_Insert_Sorted

Declaration

Source position: mui.pas line 2647

const MUIV_List_Insert_Sorted = - 2;


MUIV_List_Insert_Top

Declaration

Source position: mui.pas line 2645

const MUIV_List_Insert_Top = 0;


MUIV_List_Jump_Active

Declaration

Source position: mui.pas line 2682

const MUIV_List_Jump_Active = - 1;


MUIV_List_Jump_Bottom

Declaration

Source position: mui.pas line 2683

const MUIV_List_Jump_Bottom = - 2;


MUIV_List_Jump_Down

Declaration

Source position: mui.pas line 2685

const MUIV_List_Jump_Down = - 3;


MUIV_List_Jump_Top

Declaration

Source position: mui.pas line 2681

const MUIV_List_Jump_Top = 0;


MUIV_List_Jump_Up

Declaration

Source position: mui.pas line 2684

const MUIV_List_Jump_Up = - 4;


MUIV_List_Move_Active

Declaration

Source position: mui.pas line 2670

const MUIV_List_Move_Active = - 1;


MUIV_List_Move_Bottom

Declaration

Source position: mui.pas line 2671

const MUIV_List_Move_Bottom = - 2;


MUIV_List_Move_Next

Declaration

Source position: mui.pas line 2672

const MUIV_List_Move_Next = - 3;


MUIV_List_Move_Previous

Declaration

Source position: mui.pas line 2673

const MUIV_List_Move_Previous = - 4;


MUIV_List_Move_Top

Declaration

Source position: mui.pas line 2669

const MUIV_List_Move_Top = 0;


MUIV_List_NextSelected_End

Declaration

Source position: mui.pas line 2688

const MUIV_List_NextSelected_End = - 1;


MUIV_List_NextSelected_Start

Declaration

Source position: mui.pas line 2687

const MUIV_List_NextSelected_Start = - 1;


MUIV_List_Redraw_Active

Declaration

Source position: mui.pas line 2665

const MUIV_List_Redraw_Active = - 1;


MUIV_List_Redraw_All

Declaration

Source position: mui.pas line 2666

const MUIV_List_Redraw_All = - 2;


MUIV_List_Redraw_Entry

Declaration

Source position: mui.pas line 2667

const MUIV_List_Redraw_Entry = - 3;


MUIV_List_Remove_Active

Declaration

Source position: mui.pas line 2651

const MUIV_List_Remove_Active = - 1;


MUIV_List_Remove_First

Declaration

Source position: mui.pas line 2650

const MUIV_List_Remove_First = 0;


MUIV_List_Remove_Last

Declaration

Source position: mui.pas line 2652

const MUIV_List_Remove_Last = - 2;


MUIV_List_Remove_Selected

Declaration

Source position: mui.pas line 2653

const MUIV_List_Remove_Selected = - 3;


MUIV_List_Select_Active

Declaration

Source position: mui.pas line 2662

const MUIV_List_Select_Active = - 1;


MUIV_List_Select_All

Declaration

Source position: mui.pas line 2663

const MUIV_List_Select_All = - 2;


MUIV_List_Select_Ask

Declaration

Source position: mui.pas line 2658

const MUIV_List_Select_Ask = 3;


MUIV_List_Select_Off

Declaration

Source position: mui.pas line 2655

const MUIV_List_Select_Off = 0;


MUIV_List_Select_On

Declaration

Source position: mui.pas line 2656

const MUIV_List_Select_On = 1;


MUIV_List_Select_Toggle

Declaration

Source position: mui.pas line 2657

const MUIV_List_Select_Toggle = 2;


MUIV_Listview_DragType_Immediate

Declaration

Source position: mui.pas line 2445

const MUIV_Listview_DragType_Immediate = 1;


MUIV_Listview_DragType_None

Declaration

Source position: mui.pas line 2444

const MUIV_Listview_DragType_None = 0;


MUIV_Listview_MultiSelect_Always

Declaration

Source position: mui.pas line 2450

const MUIV_Listview_MultiSelect_Always = 3;


MUIV_Listview_MultiSelect_Default

Declaration

Source position: mui.pas line 2448

const MUIV_Listview_MultiSelect_Default = 1;


MUIV_Listview_MultiSelect_None

Declaration

Source position: mui.pas line 2447

const MUIV_Listview_MultiSelect_None = 0;


MUIV_Listview_MultiSelect_Shifted

Declaration

Source position: mui.pas line 2449

const MUIV_Listview_MultiSelect_Shifted = 2;


MUIV_Listview_ScrollerPos_Default

Declaration

Source position: mui.pas line 2452

const MUIV_Listview_ScrollerPos_Default = 0;


MUIV_Listview_ScrollerPos_Left

Declaration

Source position: mui.pas line 2453

const MUIV_Listview_ScrollerPos_Left = 1;


MUIV_Listview_ScrollerPos_None

Declaration

Source position: mui.pas line 2455

const MUIV_Listview_ScrollerPos_None = 3;


MUIV_Listview_ScrollerPos_Right

Declaration

Source position: mui.pas line 2454

const MUIV_Listview_ScrollerPos_Right = 2;


MUIV_Menuitem_Shortcut_Check

Declaration

Source position: mui.pas line 2212

const MUIV_Menuitem_Shortcut_Check = - 1;


MUIV_NList_SelectChange_Flag_Multi

Declaration

Source position: mui.pas line 2690

const MUIV_NList_SelectChange_Flag_Multi = 1 shl 0;


MUIV_Notify_Application

Declaration

Source position: mui.pas line 374

const MUIV_Notify_Application = 3;


MUIV_Notify_Parent

Declaration

Source position: mui.pas line 375

const MUIV_Notify_Parent = 4;


MUIV_Notify_ParentParent

Declaration

Source position: mui.pas line 376

const MUIV_Notify_ParentParent = 5;


MUIV_Notify_ParentParentParent

Declaration

Source position: mui.pas line 377

const MUIV_Notify_ParentParentParent = 6;


MUIV_Notify_Self

Declaration

Source position: mui.pas line 372

const MUIV_Notify_Self = 1;


MUIV_Notify_Window

Declaration

Source position: mui.pas line 373

const MUIV_Notify_Window = 2;


MUIV_NotTriggerValue

Declaration

Source position: mui.pas line 369

const MUIV_NotTriggerValue = $49893133;


MUIV_Palette_Entry_End

Declaration

Source position: mui.pas line 399

const MUIV_Palette_Entry_End = - 1;


MUIV_Pixmap_Compression_BZip2

Declaration

Source position: mui.pas line 3567

const MUIV_Pixmap_Compression_BZip2 = 2;


MUIV_Pixmap_Compression_None

Declaration

Source position: mui.pas line 3565

const MUIV_Pixmap_Compression_None = 0;


MUIV_Pixmap_Compression_RLE

Declaration

Source position: mui.pas line 3566

const MUIV_Pixmap_Compression_RLE = 1;


MUIV_Pixmap_Format_ARGB32

Declaration

Source position: mui.pas line 3571

const MUIV_Pixmap_Format_ARGB32 = 2;


MUIV_Pixmap_Format_CLUT8

Declaration

Source position: mui.pas line 3569

const MUIV_Pixmap_Format_CLUT8 = 0;


MUIV_Pixmap_Format_RGB24

Declaration

Source position: mui.pas line 3570

const MUIV_Pixmap_Format_RGB24 = 1;


MUIV_Prop_UseWinBorder_Bottom

Declaration

Source position: mui.pas line 2128

const MUIV_Prop_UseWinBorder_Bottom = 3;


MUIV_Prop_UseWinBorder_Left

Declaration

Source position: mui.pas line 2126

const MUIV_Prop_UseWinBorder_Left = 1;


MUIV_Prop_UseWinBorder_None

Declaration

Source position: mui.pas line 2125

const MUIV_Prop_UseWinBorder_None = 0;


MUIV_Prop_UseWinBorder_Right

Declaration

Source position: mui.pas line 2127

const MUIV_Prop_UseWinBorder_Right = 2;


MUIV_Scrollbar_Type_Bottom

Declaration

Source position: mui.pas line 2146

const MUIV_Scrollbar_Type_Bottom = 1;


MUIV_Scrollbar_Type_Default

Declaration

Source position: mui.pas line 2145

const MUIV_Scrollbar_Type_Default = 0;


MUIV_Scrollbar_Type_Sym

Declaration

Source position: mui.pas line 2148

const MUIV_Scrollbar_Type_Sym = 3;


MUIV_Scrollbar_Type_Top

Declaration

Source position: mui.pas line 2147

const MUIV_Scrollbar_Type_Top = 2;


MUIV_String_BufferPos_End

Declaration

Source position: mui.pas line 2045

const MUIV_String_BufferPos_End = $ffffffff;


MUIV_String_Format_Center

Declaration

Source position: mui.pas line 2025

const MUIV_String_Format_Center = 1;


MUIV_String_Format_Left

Declaration

Source position: mui.pas line 2024

const MUIV_String_Format_Left = 0;


MUIV_String_Format_Right

Declaration

Source position: mui.pas line 2026

const MUIV_String_Format_Right = 2;


MUIV_String_Insert_BufferPos

Declaration

Source position: mui.pas line 2044

const MUIV_String_Insert_BufferPos = $ffffffff;


MUIV_String_Insert_EndOfString

Declaration

Source position: mui.pas line 2043

const MUIV_String_Insert_EndOfString = $fffffffe;


MUIV_String_Insert_StartOfString

Declaration

Source position: mui.pas line 2042

const MUIV_String_Insert_StartOfString = $00000000;


MUIV_TriggerValue

Declaration

Source position: mui.pas line 368

const MUIV_TriggerValue = $49893131;


MUIV_Window_ActiveObject_Next

Declaration

Source position: mui.pas line 1329

const MUIV_Window_ActiveObject_Next = - 1;


MUIV_Window_ActiveObject_None

Declaration

Source position: mui.pas line 1328

const MUIV_Window_ActiveObject_None = 0;


MUIV_Window_ActiveObject_Prev

Declaration

Source position: mui.pas line 1330

const MUIV_Window_ActiveObject_Prev = - 2;


MUIV_Window_AltHeight_Scaled

Declaration

Source position: mui.pas line 1332

const MUIV_Window_AltHeight_Scaled = - 1000;


MUIV_Window_AltLeftEdge_Centered

Declaration

Source position: mui.pas line 1333

const MUIV_Window_AltLeftEdge_Centered = - 1;


MUIV_Window_AltLeftEdge_Moused

Declaration

Source position: mui.pas line 1334

const MUIV_Window_AltLeftEdge_Moused = - 2;


MUIV_Window_AltLeftEdge_NoChange

Declaration

Source position: mui.pas line 1335

const MUIV_Window_AltLeftEdge_NoChange = - 1000;


MUIV_Window_AltTopEdge_Centered

Declaration

Source position: mui.pas line 1336

const MUIV_Window_AltTopEdge_Centered = - 1;


MUIV_Window_AltTopEdge_Moused

Declaration

Source position: mui.pas line 1337

const MUIV_Window_AltTopEdge_Moused = - 2;


MUIV_Window_AltTopEdge_NoChange

Declaration

Source position: mui.pas line 1338

const MUIV_Window_AltTopEdge_NoChange = - 1000;


MUIV_Window_AltWidth_Scaled

Declaration

Source position: mui.pas line 1339

const MUIV_Window_AltWidth_Scaled = - 1000;


MUIV_Window_Button_Iconify

Declaration

Source position: mui.pas line 1352

const MUIV_Window_Button_Iconify = 4;


MUIV_Window_Button_MUI

Declaration

Source position: mui.pas line 1350

const MUIV_Window_Button_MUI = 1;


MUIV_Window_Button_Popup

Declaration

Source position: mui.pas line 1353

const MUIV_Window_Button_Popup = 8;


MUIV_Window_Button_Snapshot

Declaration

Source position: mui.pas line 1351

const MUIV_Window_Button_Snapshot = 2;


MUIV_Window_Height_Default

Declaration

Source position: mui.pas line 1342

const MUIV_Window_Height_Default = - 1001;


MUIV_Window_Height_Scaled

Declaration

Source position: mui.pas line 1341

const MUIV_Window_Height_Scaled = - 1000;


MUIV_Window_LeftEdge_Centered

Declaration

Source position: mui.pas line 1343

const MUIV_Window_LeftEdge_Centered = - 1;


MUIV_Window_LeftEdge_Moused

Declaration

Source position: mui.pas line 1344

const MUIV_Window_LeftEdge_Moused = - 2;


MUIV_Window_TopEdge_Centered

Declaration

Source position: mui.pas line 1345

const MUIV_Window_TopEdge_Centered = - 1;


MUIV_Window_TopEdge_Moused

Declaration

Source position: mui.pas line 1346

const MUIV_Window_TopEdge_Moused = - 2;


MUIV_Window_Width_Default

Declaration

Source position: mui.pas line 1348

const MUIV_Window_Width_Default = - 1001;


MUIV_Window_Width_Scaled

Declaration

Source position: mui.pas line 1347

const MUIV_Window_Width_Scaled = - 1000;


MUIX_B

Declaration

Source position: mui.pas line 1894

const MUIX_B = #27 + 'b';


MUIX_C

Declaration

Source position: mui.pas line 1890

const MUIX_C = #27 + 'c';


MUIX_I

Declaration

Source position: mui.pas line 1895

const MUIX_I = #27 + 'i';


MUIX_L

Declaration

Source position: mui.pas line 1891

const MUIX_L = #27 + 'l';


MUIX_N

Declaration

Source position: mui.pas line 1893

const MUIX_N = #27 + 'n';


MUIX_PH

Declaration

Source position: mui.pas line 1899

const MUIX_PH = #27 + '8';


MUIX_PT

Declaration

Source position: mui.pas line 1898

const MUIX_PT = #27 + '2';


MUIX_R

Declaration

Source position: mui.pas line 1889

const MUIX_R = #27 + 'r';


MUIX_U

Declaration

Source position: mui.pas line 1896

const MUIX_U = #27 + 'u';


P__dummyAreaData__

Declaration

Source position: mui.pas line 3614

type P__dummyAreaData__ = ^T__dummyAreaData__;


Pdt_frame_image

Declaration

Source position: mui.pas line 525

type Pdt_frame_image = ^Tdt_frame_image;


PMUI_AreaData

Declaration

Source position: mui.pas line 1719

type PMUI_AreaData = ^TMUI_AreaData;


PMUI_BoopsiQuery

Declaration

Source position: mui.pas line 580

type PMUI_BoopsiQuery = ^TMUI_BoopsiQuery;


PMUI_Command

Declaration

Source position: mui.pas line 269

type PMUI_Command = ^TMUI_Command;


PMUI_CustomClass

Declaration

Source position: mui.pas line 3686

type PMUI_CustomClass = ^TMUI_CustomClass;


PMUI_DragImage

Declaration

Source position: mui.pas line 503

type PMUI_DragImage = ^TMUI_DragImage;


PMUI_EventHandlerNode

Declaration

Source position: mui.pas line 407

type PMUI_EventHandlerNode = ^TMUI_EventHandlerNode;


PMUI_FrameSpec

Declaration

Source position: mui.pas line 150

type PMUI_FrameSpec = ^TMUI_FrameSpec;


PMUI_GlobalInfo

Declaration

Source position: mui.pas line 1108

type PMUI_GlobalInfo = ^TMUI_GlobalInfo;


PMUI_ImageSpec_intern

Declaration

Source position: mui.pas line 1700

type PMUI_ImageSpec_intern = ^TMUI_ImageSpec_intern;


PMUI_InputHandlerNode

Declaration

Source position: mui.pas line 476

type PMUI_InputHandlerNode = ^TMUI_InputHandlerNode;


PMUI_LayoutMsg

Declaration

Source position: mui.pas line 1849

type PMUI_LayoutMsg = ^TMUI_LayoutMsg;


PMUI_List_TestPos_Result

Declaration

Source position: mui.pas line 459

type PMUI_List_TestPos_Result = ^TMUI_List_TestPos_Result;


PMUI_MinMax

Declaration

Source position: mui.pas line 1417

type PMUI_MinMax = ^TMUI_MinMax;


PMUI_NotifyData

Declaration

Source position: mui.pas line 3603

type PMUI_NotifyData = ^TMUI_NotifyData;


PMUI_Palette_Entry

Declaration

Source position: mui.pas line 390

type PMUI_Palette_Entry = ^TMUI_Palette_Entry;


PMUI_PenSpec

Declaration

Source position: mui.pas line 145

type PMUI_PenSpec = ^TMUI_PenSpec;


PMUI_PubScreenDesc

Declaration

Source position: mui.pas line 218

type PMUI_PubScreenDesc = ^TMUI_PubScreenDesc;


PMUI_RenderInfo

Declaration

Source position: mui.pas line 570

type PMUI_RenderInfo = ^TMUI_RenderInfo;


PMUI_RGBColor

Declaration

Source position: mui.pas line 182

type PMUI_RGBColor = ^TMUI_RGBcolor;


PMUIP_Application_AboutMUI

Declaration

Source position: mui.pas line 906

type PMUIP_Application_AboutMUI = ^TMUIP_Application_AboutMUI;


PMUIP_Application_AddInputHandler

Declaration

Source position: mui.pas line 912

type PMUIP_Application_AddInputHandler = ^TMUIP_Application_AddInputHandler;


PMUIP_Application_CheckRefresh

Declaration

Source position: mui.pas line 917

type PMUIP_Application_CheckRefresh = ^TMUIP_Application_CheckRefresh;


PMUIP_Application_GetMenuCheck

Declaration

Source position: mui.pas line 923

type PMUIP_Application_GetMenuCheck = ^TMUIP_Application_GetMenuCheck;


PMUIP_Application_GetMenuState

Declaration

Source position: mui.pas line 929

type PMUIP_Application_GetMenuState = ^TMUIP_Application_GetMenuState;


PMUIP_Application_Input

Declaration

Source position: mui.pas line 935

type PMUIP_Application_Input = ^TMUIP_Application_Input;


PMUIP_Application_InputBuffered

Declaration

Source position: mui.pas line 940

type PMUIP_Application_InputBuffered = ^TMUIP_Application_InputBuffered;


PMUIP_Application_Load

Declaration

Source position: mui.pas line 946

type PMUIP_Application_Load = ^TMUIP_Application_Load;


PMUIP_Application_NewInput

Declaration

Source position: mui.pas line 952

type PMUIP_Application_NewInput = ^TMUIP_Application_NewInput;


PMUIP_Application_OpenConfigWindow

Declaration

Source position: mui.pas line 958

type PMUIP_Application_OpenConfigWindow = ^TMUIP_Application_OpenConfigWindow;


PMUIP_Application_PushMethod

Declaration

Source position: mui.pas line 965

type PMUIP_Application_PushMethod = ^TMUIP_Application_PushMethod;


PMUIP_Application_RemInputHandler

Declaration

Source position: mui.pas line 979

type PMUIP_Application_RemInputHandler = ^TMUIP_Application_RemInputHandler;


PMUIP_Application_ReturnID

Declaration

Source position: mui.pas line 985

type PMUIP_Application_ReturnID = ^TMUIP_Application_ReturnID;


PMUIP_Application_SetConfigItem

Declaration

Source position: mui.pas line 997

type PMUIP_Application_SetConfigItem = ^TMUIP_Application_SetConfigItem;


PMUIP_Application_SetMenuCheck

Declaration

Source position: mui.pas line 1004

type PMUIP_Application_SetMenuCheck = ^TMUIP_Application_SetMenuCheck;


PMUIP_Application_SetMenuState

Declaration

Source position: mui.pas line 1011

type PMUIP_Application_SetMenuState = ^TMUIP_Application_SetMenuState;


PMUIP_Application_ShowHelp

Declaration

Source position: mui.pas line 1020

type PMUIP_Application_ShowHelp = ^TMUIP_Application_ShowHelp;


PMUIP_Application_UnpushMethod

Declaration

Source position: mui.pas line 973

type PMUIP_Application_UnpushMethod = ^TMUIP_Application_UnpushMethod;


PMUIP_AskMinMax

Declaration

Source position: mui.pas line 1423

type PMUIP_AskMinMax = ^TMUIP_AskMinMax;


PMUIP_CallHook

Declaration

Source position: mui.pas line 642

type PMUIP_CallHook = ^TMUIP_CallHook;


PMUIP_Cleanup

Declaration

Source position: mui.pas line 1428

type PMUIP_Cleanup = ^TMUIP_Cleanup;


PMUIP_Configdata_GetString

Declaration

Source position: mui.pas line 2932

type PMUIP_Configdata_GetString = ^TMUIP_Configdata_GetString;


PMUIP_Configdata_GetULong

Declaration

Source position: mui.pas line 2938

type PMUIP_Configdata_GetULong = ^TMUIP_Configdata_GetULong;


PMUIP_Configdata_Load

Declaration

Source position: mui.pas line 2978

type PMUIP_Configdata_Load = ^TMUIP_Configdata_Load;


PMUIP_Configdata_Save

Declaration

Source position: mui.pas line 2972

type PMUIP_Configdata_Save = ^TMUIP_Configdata_Save;


PMUIP_Configdata_SetFont

Declaration

Source position: mui.pas line 2966

type PMUIP_Configdata_SetFont = ^TMUIP_Configdata_SetFont;


PMUIP_Configdata_SetFramespec

Declaration

Source position: mui.pas line 2959

type PMUIP_Configdata_SetFramespec = ^TMUIP_Configdata_SetFramespec;


PMUIP_Configdata_SetImspec

Declaration

Source position: mui.pas line 2952

type PMUIP_Configdata_SetImspec = ^TMUIP_Configdata_SetImspec;


PMUIP_Configdata_SetPenspec

Declaration

Source position: mui.pas line 2985

type PMUIP_Configdata_SetPenspec = ^TMUIP_Configdata_SetPenspec;


PMUIP_Configdata_SetString

Declaration

Source position: mui.pas line 2992

type PMUIP_Configdata_SetString = ^TMUIP_Configdata_SetString;


PMUIP_Configdata_SetULong

Declaration

Source position: mui.pas line 2945

type PMUIP_Configdata_SetULong = ^TMUIP_Configdata_SetULong;


PMUIP_ConnectParent

Declaration

Source position: mui.pas line 763

type PMUIP_ConnectParent = ^TMUIP_ConnectParent;


PMUIP_ContextMenuBuild

Declaration

Source position: mui.pas line 1435

type PMUIP_ContextMenuBuild = ^TMUIP_ContextMenuBuild;


PMUIP_ContextMenuChoice

Declaration

Source position: mui.pas line 1441

type PMUIP_ContextMenuChoice = ^TMUIP_ContextMenuChoice;


PMUIP_CreateBubble

Declaration

Source position: mui.pas line 1450

type PMUIP_CreateBubble = ^TMUIP_CreateBubble;


PMUIP_CreateDragImage

Declaration

Source position: mui.pas line 1458

type PMUIP_CreateDragImage = ^TMUIP_CreateDragImage;


PMUIP_CreateShortHelp

Declaration

Source position: mui.pas line 1465

type PMUIP_CreateShortHelp = ^TMUIP_CreateShortHelp;


PMUIP_CustomBackfill

Declaration

Source position: mui.pas line 1476

type PMUIP_CustomBackfill = ^TMUIP_CustomBackfill;


PMUIP_Dataspace_Add

Declaration

Source position: mui.pas line 2239

type PMUIP_Dataspace_Add = ^TMUIP_Dataspace_Add;


PMUIP_Dataspace_Clear

Declaration

Source position: mui.pas line 2244

type PMUIP_Dataspace_Clear = ^TMUIP_Dataspace_Clear;


PMUIP_Dataspace_Find

Declaration

Source position: mui.pas line 2250

type PMUIP_Dataspace_Find = ^TMUIP_Dataspace_Find;


PMUIP_Dataspace_Merge

Declaration

Source position: mui.pas line 2256

type PMUIP_Dataspace_Merge = ^TMUIP_Dataspace_Merge;


PMUIP_Dataspace_ReadIFF

Declaration

Source position: mui.pas line 2262

type PMUIP_Dataspace_ReadIFF = ^TMUIP_Dataspace_ReadIFF;


PMUIP_Dataspace_Remove

Declaration

Source position: mui.pas line 2268

type PMUIP_Dataspace_Remove = ^TMUIP_Dataspace_Remove;


PMUIP_Dataspace_WriteIFF

Declaration

Source position: mui.pas line 2276

type PMUIP_Dataspace_WriteIFF = ^TMUIP_Dataspace_WriteIFF;


PMUIP_DeleteBubble

Declaration

Source position: mui.pas line 1482

type PMUIP_DeleteBubble = ^TMUIP_DeleteBubble;


PMUIP_DeleteDragImage

Declaration

Source position: mui.pas line 1488

type PMUIP_DeleteDragImage = ^TMUIP_DeleteDragImage;


PMUIP_DeleteShortHelp

Declaration

Source position: mui.pas line 1494

type PMUIP_DeleteShortHelp = ^TMUIP_DeleteShortHelp;


PMUIP_DisconnectParent

Declaration

Source position: mui.pas line 768

type PMUIP_DisconnectParent = ^TMUIP_DisconnectParent;


PMUIP_DoDrag

Declaration

Source position: mui.pas line 1502

type PMUIP_DoDrag = ^TMUIP_DoDrag;


PMUIP_DragBegin

Declaration

Source position: mui.pas line 1514

type PMUIP_DragBegin = ^TMUIP_DragBegin;


PMUIP_DragDrop

Declaration

Source position: mui.pas line 1522

type PMUIP_DragDrop = ^TMUIP_DragDrop;


PMUIP_DragFinish

Declaration

Source position: mui.pas line 1528

type PMUIP_DragFinish = ^TMUIP_DragFinish;


PMUIP_DragQuery

Declaration

Source position: mui.pas line 1534

type PMUIP_DragQuery = ^TMUIP_DragQuery;


PMUIP_DragReport

Declaration

Source position: mui.pas line 1543

type PMUIP_DragReport = ^TMUIP_DragReport;


PMUIP_Draw

Declaration

Source position: mui.pas line 1549

type PMUIP_Draw = ^TMUIP_Draw;


PMUIP_DrawBackground

Declaration

Source position: mui.pas line 1561

type PMUIP_DrawBackground = ^TMUIP_DrawBackground;


PMUIP_DrawBackgroundBuffered

Declaration

Source position: mui.pas line 1574

type PMUIP_DrawBackgroundBuffered = ^TMUIP_DrawBackgroundBuffered;


PMUIP_DrawParentBackground

Declaration

Source position: mui.pas line 1631

type PMUIP_DrawParentBackground = ^TMUIP_DrawParentBackground;


PMUIP_Export

Declaration

Source position: mui.pas line 648

type PMUIP_Export = ^TMUIP_Export;


PMUIP_Family_AddHead

Declaration

Source position: mui.pas line 806

type PMUIP_Family_AddHead = ^TMUIP_Family_AddHead;


PMUIP_Family_AddTail

Declaration

Source position: mui.pas line 812

type PMUIP_Family_AddTail = ^TMUIP_Family_AddTail;


PMUIP_Family_GetChild

Declaration

Source position: mui.pas line 844

type PMUIP_Family_GetChild = ^TMUIP_Family_GetChild;


PMUIP_Family_Insert

Declaration

Source position: mui.pas line 819

type PMUIP_Family_Insert = ^TMUIP_Family_Insert;


PMUIP_Family_Remove

Declaration

Source position: mui.pas line 825

type PMUIP_Family_Remove = ^TMUIP_Family_Remove;


PMUIP_Family_Sort

Declaration

Source position: mui.pas line 831

type PMUIP_Family_Sort = ^TMUIP_Family_Sort;


PMUIP_Family_Transfer

Declaration

Source position: mui.pas line 837

type PMUIP_Family_Transfer = ^TMUIP_Family_Transfer;


PMUIP_FindUData

Declaration

Source position: mui.pas line 654

type PMUIP_FindUData = ^TMUIP_FindUData;


PMUIP_Floattext_Append

Declaration

Source position: mui.pas line 2716

type PMUIP_Floattext_Append = ^TMUIP_Floattext_Append;


PMUIP_GetConfigItem

Declaration

Source position: mui.pas line 661

type PMUIP_GetConfigItem = ^TMUIP_GetConfigItem;


PMUIP_GetUData

Declaration

Source position: mui.pas line 669

type PMUIP_GetUData = ^TMUIP_GetUData;


PMUIP_GoActive

Declaration

Source position: mui.pas line 1579

type PMUIP_GoActive = ^TMUIP_GoActive;


PMUIP_GoInactive

Declaration

Source position: mui.pas line 1584

type PMUIP_GoInactive = ^TMUIP_GoInactive;


PMUIP_Group_AddHead

Declaration

Source position: mui.pas line 1774

type PMUIP_Group_AddHead = ^TMUIP_Group_AddHead;


PMUIP_Group_AddTail

Declaration

Source position: mui.pas line 1780

type PMUIP_Group_AddTail = ^TMUIP_Group_AddTail;


PMUIP_Group_DoMethodNoForward

Declaration

Source position: mui.pas line 1808

type PMUIP_Group_DoMethodNoForward = ^TMUIP_Group_DoMethodNoForward;


PMUIP_Group_ExitChange

Declaration

Source position: mui.pas line 1785

type PMUIP_Group_ExitChange = ^TMUIP_Group_ExitChange;


PMUIP_Group_InitChange

Declaration

Source position: mui.pas line 1790

type PMUIP_Group_InitChange = ^TMUIP_Group_InitChange;


PMUIP_Group_Remove

Declaration

Source position: mui.pas line 1802

type PMUIP_Group_Remove = ^TMUIP_Group_Remove;


PMUIP_Group_Sort

Declaration

Source position: mui.pas line 1796

type PMUIP_Group_Sort = ^TMUIP_Group_Sort;


PMUIP_HandleEvent

Declaration

Source position: mui.pas line 1591

type PMUIP_HandleEvent = ^TMUIP_HandleEvent;


PMUIP_HandleInput

Declaration

Source position: mui.pas line 1598

type PMUIP_HandleInput = ^TMUIP_HandleInput;


PMUIP_Hide

Declaration

Source position: mui.pas line 1603

type PMUIP_Hide = ^TMUIP_Hide;


PMUIP_Import

Declaration

Source position: mui.pas line 675

type PMUIP_Import = ^TMUIP_Import;


PMUIP_KillNotify

Declaration

Source position: mui.pas line 681

type PMUIP_KillNotify = ^TMUIP_KillNotify;


PMUIP_KillNotifyObj

Declaration

Source position: mui.pas line 688

type PMUIP_KillNotifyObj = ^TMUIP_KillNotifyObj;


PMUIP_Layout

Declaration

Source position: mui.pas line 1619

type PMUIP_Layout = ^TMUIP_Layout;


PMUIP_List_Clear

Declaration

Source position: mui.pas line 2489

type PMUIP_List_Clear = ^TMUIP_List_Clear;


PMUIP_List_Compare

Declaration

Source position: mui.pas line 2498

type PMUIP_List_Compare = ^TMUIP_List_Compare;


PMUIP_List_Construct

Declaration

Source position: mui.pas line 2505

type PMUIP_List_Construct = ^TMUIP_List_Construct;


PMUIP_List_CreateImage

Declaration

Source position: mui.pas line 2512

type PMUIP_List_CreateImage = ^TMUIP_List_CreateImage;


PMUIP_List_DeleteImage

Declaration

Source position: mui.pas line 2518

type PMUIP_List_DeleteImage = ^TMUIP_List_DeleteImage;


PMUIP_List_Exchange

Declaration

Source position: mui.pas line 2525

type PMUIP_List_Exchange = ^TMUIP_List_Exchange;


PMUIP_List_GetEntry

Declaration

Source position: mui.pas line 2532

type PMUIP_List_GetEntry = ^TMUIP_List_GetEntry;


PMUIP_List_Insert

Declaration

Source position: mui.pas line 2540

type PMUIP_List_Insert = ^TMUIP_List_Insert;


PMUIP_List_InsertSingle

Declaration

Source position: mui.pas line 2547

type PMUIP_List_InsertSingle = ^TMUIP_List_InsertSingle;


PMUIP_List_Jump

Declaration

Source position: mui.pas line 2553

type PMUIP_List_Jump = ^TMUIP_List_Jump;


PMUIP_List_Move

Declaration

Source position: mui.pas line 2560

type PMUIP_List_Move = ^TMUIP_List_Move;


PMUIP_List_NextSelected

Declaration

Source position: mui.pas line 2566

type PMUIP_List_NextSelected = ^TMUIP_List_NextSelected;


PMUIP_List_Redraw

Declaration

Source position: mui.pas line 2572

type PMUIP_List_Redraw = ^TMUIP_List_Redraw;


PMUIP_List_Remove

Declaration

Source position: mui.pas line 2578

type PMUIP_List_Remove = ^TMUIP_List_Remove;


PMUIP_List_Select

Declaration

Source position: mui.pas line 2586

type PMUIP_List_Select = ^TMUIP_List_Select;


PMUIP_List_Sort

Declaration

Source position: mui.pas line 2591

type PMUIP_List_Sort = ^TMUIP_List_Sort;


PMUIP_List_TestPos

Declaration

Source position: mui.pas line 2599

type PMUIP_List_TestPos = ^TMUIP_List_TestPos;


PMUIP_MultiSet

Declaration

Source position: mui.pas line 696

type PMUIP_MultiSet = ^TMUIP_MultiSet;


PMUIP_NoNotifySet

Declaration

Source position: mui.pas line 703

type PMUIP_NoNotifySet = ^TMUIP_NoNotifySet;


PMUIP_Notify

Declaration

Source position: mui.pas line 712

type PMUIP_Notify = ^TMUIP_Notify;


PMUIP_Numeric_Decrease

Declaration

Source position: mui.pas line 1925

type PMUIP_Numeric_Decrease = ^TMUIP_Numeric_Decrease;


PMUIP_Numeric_Increase

Declaration

Source position: mui.pas line 1931

type PMUIP_Numeric_Increase = ^TMUIP_Numeric_Increase;


PMUIP_Numeric_ScaleToValue

Declaration

Source position: mui.pas line 1939

type PMUIP_Numeric_ScaleToValue = ^TMUIP_Numeric_ScaleToValue;


PMUIP_Numeric_SetDefault

Declaration

Source position: mui.pas line 1944

type PMUIP_Numeric_SetDefault = ^TMUIP_Numeric_SetDefault;


PMUIP_Numeric_Stringify

Declaration

Source position: mui.pas line 1950

type PMUIP_Numeric_Stringify = ^TMUIP_Numeric_Stringify;


PMUIP_Numeric_ValueToScale

Declaration

Source position: mui.pas line 1957

type PMUIP_Numeric_ValueToScale = ^TMUIP_Numeric_ValueToScale;


PMUIP_Numeric_ValueToScaleExt

Declaration

Source position: mui.pas line 1965

type PMUIP_Numeric_ValueToScaleExt = ^TMUIP_Numeric_ValueToScaleExt;


PMUIP_Pendisplay_SetColormap

Declaration

Source position: mui.pas line 3245

type PMUIP_Pendisplay_SetColormap = ^TMUIP_Pendisplay_SetColormap;


PMUIP_Pendisplay_SetMUIPen

Declaration

Source position: mui.pas line 3251

type PMUIP_Pendisplay_SetMUIPen = ^TMUIP_Pendisplay_SetMUIPen;


PMUIP_Pendisplay_SetRGB

Declaration

Source position: mui.pas line 3259

type PMUIP_Pendisplay_SetRGB = ^TMUIP_Pendisplay_SetRGB;


PMUIP_Popstring_Close

Declaration

Source position: mui.pas line 2743

type PMUIP_Popstring_Close = ^TMUIP_Popstring_Close;


PMUIP_Popstring_Open

Declaration

Source position: mui.pas line 2748

type PMUIP_Popstring_Open = ^TMUIP_Popstring_Open;


PMUIP_Prop_Decrease

Declaration

Source position: mui.pas line 2108

type PMUIP_Prop_Decrease = ^TMUIP_Prop_Decrease;


PMUIP_Prop_Increase

Declaration

Source position: mui.pas line 2114

type PMUIP_Prop_Increase = ^TMUIP_Prop_Increase;


PMUIP_Semaphore_Attempt

Declaration

Source position: mui.pas line 2351

type PMUIP_Semaphore_Attempt = ^TMUIP_Semaphore_Attempt;


PMUIP_Semaphore_AttemptShared

Declaration

Source position: mui.pas line 2356

type PMUIP_Semaphore_AttemptShared = ^TMUIP_Semaphore_AttemptShared;


PMUIP_Semaphore_Obtain

Declaration

Source position: mui.pas line 2361

type PMUIP_Semaphore_Obtain = ^TMUIP_Semaphore_Obtain;


PMUIP_Semaphore_ObtainShared

Declaration

Source position: mui.pas line 2366

type PMUIP_Semaphore_ObtainShared = ^TMUIP_Semaphore_ObtainShared;


PMUIP_Semaphore_Release

Declaration

Source position: mui.pas line 2371

type PMUIP_Semaphore_Release = ^TMUIP_Semaphore_Release;


PMUIP_Set

Declaration

Source position: mui.pas line 719

type PMUIP_Set = ^TMUIP_Set;


PMUIP_SetAsString

Declaration

Source position: mui.pas line 727

type PMUIP_SetAsString = ^TMUIP_SetAsString;


PMUIP_Settingsgroup_ConfigToGadgets

Declaration

Source position: mui.pas line 2877

type PMUIP_Settingsgroup_ConfigToGadgets = ^TMUIP_Settingsgroup_ConfigToGadgets;


PMUIP_Settingsgroup_GadgetsToConfig

Declaration

Source position: mui.pas line 2883

type PMUIP_Settingsgroup_GadgetsToConfig = ^TMUIP_Settingsgroup_GadgetsToConfig;


PMUIP_SetUData

Declaration

Source position: mui.pas line 735

type PMUIP_SetUData = ^TMUIP_SetUData;


PMUIP_SetUDataOnce

Declaration

Source position: mui.pas line 743

type PMUIP_SetUDataOnce = ^TMUIP_SetUDataOnce;


PMUIP_Setup

Declaration

Source position: mui.pas line 1609

type PMUIP_Setup = ^TMUIP_Setup;


PMUIP_Show

Declaration

Source position: mui.pas line 1614

type PMUIP_Show = ^TMUIP_Show;


PMUIP_String_ClearSelected

Declaration

Source position: mui.pas line 2053

type PMUIP_String_ClearSelected = ^TMUIP_String_ClearSelected;


PMUIP_UnknownDropDestination

Declaration

Source position: mui.pas line 1508

type PMUIP_UnknownDropDestination = ^TMUIP_UnknownDropDestination;


PMUIP_Window_ActionIconify

Declaration

Source position: mui.pas line 1137

type PMUIP_Window_ActionIconify = ^TMUIP_Window_ActionIconify;


PMUIP_Window_AddControlCharHandler

Declaration

Source position: mui.pas line 1191

type PMUIP_Window_AddControlCharHandler = ^TMUIP_Window_AddControlCharHandler;


PMUIP_Window_AddEventHandler

Declaration

Source position: mui.pas line 1143

type PMUIP_Window_AddEventHandler = ^TMUIP_Window_AddEventHandler;


PMUIP_Window_AllocGadgetID

Declaration

Source position: mui.pas line 1196

type PMUIP_Window_AllocGadgetID = ^TMUIP_Window_AllocGadgetID;


PMUIP_Window_Cleanup

Declaration

Source position: mui.pas line 1148

type PMUIP_Window_Cleanup = ^TMUIP_Window_Cleanup;


PMUIP_Window_DragObject

Declaration

Source position: mui.pas line 1217

type PMUIP_Window_DragObject = ^TMUIP_Window_DragObject;


PMUIP_Window_DrawBackground

Declaration

Source position: mui.pas line 1208

type PMUIP_Window_DrawBackground = ^TMUIP_Window_DrawBackground;


PMUIP_Window_FreeGadgetID

Declaration

Source position: mui.pas line 1223

type PMUIP_Window_FreeGadgetID = ^TMUIP_Window_FreeGadgetID;


PMUIP_Window_RecalcDisplay

Declaration

Source position: mui.pas line 1229

type PMUIP_Window_RecalcDisplay = ^TMUIP_Window_RecalcDisplay;


PMUIP_Window_RemControlCharHandler

Declaration

Source position: mui.pas line 1235

type PMUIP_Window_RemControlCharHandler = ^TMUIP_Window_RemControlCharHandler;


PMUIP_Window_RemEventHandler

Declaration

Source position: mui.pas line 1154

type PMUIP_Window_RemEventHandler = ^TMUIP_Window_RemEventHandler;


PMUIP_Window_ScreenToBack

Declaration

Source position: mui.pas line 1159

type PMUIP_Window_ScreenToBack = ^TMUIP_Window_ScreenToBack;


PMUIP_Window_ScreenToFront

Declaration

Source position: mui.pas line 1164

type PMUIP_Window_ScreenToFront = ^TMUIP_Window_ScreenToFront;


PMUIP_Window_Setup

Declaration

Source position: mui.pas line 1169

type PMUIP_Window_Setup = ^TMUIP_Window_Setup;


PMUIP_Window_Snapshot

Declaration

Source position: mui.pas line 1175

type PMUIP_Window_Snapshot = ^TMUIP_Window_Snapshot;


PMUIP_Window_ToBack

Declaration

Source position: mui.pas line 1180

type PMUIP_Window_ToBack = ^TMUIP_Window_ToBack;


PMUIP_Window_ToFront

Declaration

Source position: mui.pas line 1185

type PMUIP_Window_ToFront = ^TMUIP_Window_ToFront;


PMUIP_WriteLong

Declaration

Source position: mui.pas line 750

type PMUIP_WriteLong = ^TMUIP_WriteLong;


PMUIP_WriteString

Declaration

Source position: mui.pas line 757

type PMUIP_WriteString = ^TMUIP_WriteString;


PMUIS_InfoClient

Declaration

Source position: mui.pas line 225

type PMUIS_InfoClient = ^TMUIS_InfoClient;


PSD_FILENAME_SAVE

Declaration

Source position: mui.pas line 164

const PSD_FILENAME_SAVE: PChar = 'envarc:mui/PublicScreens.iff';


PSD_FILENAME_USE

Declaration

Source position: mui.pas line 165

const PSD_FILENAME_USE: PChar = 'env:mui/PublicScreens.iff';


PSD_INITIAL_NAME

Declaration

Source position: mui.pas line 159

const PSD_INITIAL_NAME: PChar = '(unnamed)';


PSD_INITIAL_TITLE

Declaration

Source position: mui.pas line 160

const PSD_INITIAL_TITLE: PChar = 'MUI Public Screen';


PSD_MAXLEN_BACKGROUND

Declaration

Source position: mui.pas line 169

const PSD_MAXLEN_BACKGROUND = 256;


PSD_MAXLEN_FONT

Declaration

Source position: mui.pas line 168

const PSD_MAXLEN_FONT = 48;


PSD_MAXLEN_NAME

Declaration

Source position: mui.pas line 166

const PSD_MAXLEN_NAME = 32;


PSD_MAXLEN_TITLE

Declaration

Source position: mui.pas line 167

const PSD_MAXLEN_TITLE = 128;


PSD_MAXMUIPENS

Declaration

Source position: mui.pas line 173

const PSD_MAXMUIPENS = 10;


PSD_MAXSYSPENS

Declaration

Source position: mui.pas line 171

const PSD_MAXSYSPENS = 20;


PSD_NAME_FRONTMOST

Declaration

Source position: mui.pas line 163

const PSD_NAME_FRONTMOST: PChar = '?Frontmost?';


PSD_NUMCOLS

Declaration

Source position: mui.pas line 170

const PSD_NUMCOLS = 8;


PSD_NUMMUIPENS

Declaration

Source position: mui.pas line 174

const PSD_NUMMUIPENS = 8;


PSD_NUMSYSPENS

Declaration

Source position: mui.pas line 172

const PSD_NUMSYSPENS = 12;


PST_CMAP

Declaration

Source position: mui.pas line 133

const PST_CMAP = 'p';


PST_MUI

Declaration

Source position: mui.pas line 132

const PST_MUI = 'm';


PST_RGB

Declaration

Source position: mui.pas line 134

const PST_RGB = 'r';


PST_SYS

Declaration

Source position: mui.pas line 135

const PST_SYS = 's';


T__dummyAreaData__

Declaration

Source position: mui.pas line 3610

type T__dummyAreaData__ = record

  mnd: TMUI_NotifyData;

  mad: TMUI_AreaData;

end;


Tdt_frame_image

Declaration

Source position: mui.pas line 523

type Tdt_frame_image = record

end;


TMUI_AreaData

Declaration

Source position: mui.pas line 1704

type TMUI_AreaData = record

  mad_RenderInfo: PMUI_RenderInfo;

  mad_Background: PMUI_ImageSpec_intern;

  mad_Font: PTextFont;

  mad_MinMax: TMUI_MinMax;

  mad_Box: TIBox;

  mad_addleft: ShortInt;

  mad_addtop: ShortInt;

  mad_subwidth: ShortInt;

  mad_subheight: ShortInt;

  mad_Flags: LongWord;

  mad_Flags2: LongWord;

end;


TMUI_BoopsiQuery

Declaration

Source position: mui.pas line 581

type TMUI_BoopsiQuery = record

  mbq_MethodID: LongWord;

  mbq_Screen: PScreen;

  mbq_Flags: LongWord;

  mbq_MinWidth: LongInt;

  mbq_MinHeight: LongInt;

  mbq_MaxWidth: LongInt;

  mbq_MaxHeight: LongInt;

  mbq_DefWidth: LongInt;

  mbq_DefHeight: LongInt;

  mbq_RenderInfo: PMUI_RenderInfo;

end;


TMUI_Command

Declaration

Source position: mui.pas line 262

type TMUI_Command = record

  mc_Name: PChar;

  mc_Template: PChar;

  mc_Parameters: LongInt;

  mc_Hook: PHook;

  mc_Reserved: array [0..4] of LongInt;

end;


TMUI_CustomClass

Declaration

Source position: mui.pas line 3671

type TMUI_CustomClass = record

  mcc_UserData: Pointer;

  mcc_UtilityBase: PLibrary;

  mcc_DOSBase: PLibrary;

  mcc_GfxBase: PLibrary;

  mcc_IntuitionBase: PLibrary;

  mcc_Super: PIClass;

  mcc_Class: PIClass;

  mcc_Module: PLibrary;

end;


TMUI_DragImage

Declaration

Source position: mui.pas line 495

type TMUI_DragImage = record

  bm: PBitMap;

  width: SmallInt;

  height: SmallInt;

  touchx: SmallInt;

  touchy: SmallInt;

  flags: LongWord;

end;


TMUI_EventHandlerNode

Declaration

Source position: mui.pas line 408

type TMUI_EventHandlerNode = record

  ehn_Node: TMinNode;

  ehn_Reserved: Byte;

  ehn_Priority: Byte;

  ehn_Flags: Word;

  ehn_Object: PObject_;

  ehn_Class: PIClass;

  ehn_Events: LongWord;

end;


TMUI_FrameSpec

Declaration

Source position: mui.pas line 151

type TMUI_FrameSpec = record

  buf: array [0..31] of Char;

end;


TMUI_GlobalInfo

Declaration

Source position: mui.pas line 1103

type TMUI_GlobalInfo = record

  priv0: LongWord;

  mgi_ApplicationObject: PObject_;

end;


TMUI_ImageSpec_intern

Declaration

Source position: mui.pas line 1698

type TMUI_ImageSpec_intern = record

end;


TMUI_InputHandlerNode

Declaration

Source position: mui.pas line 477

type TMUI_InputHandlerNode = record

  ihn_Node: TMinNode;

  ihn_Object: PObject_;

  ihn_stuff: record

    case LongInt of

      0: (

          ihn_sigs: LongWord;

        );

      1: (

          ihn_timer: record

            ihn_millis: Word;

            ihn_current: Word;

          end;

        );

  end;

  ihn_Flags: LongWord;

  ihn_Method: LongWord;

end;


TMUI_LayoutMsg

Declaration

Source position: mui.pas line 1838

type TMUI_LayoutMsg = record

  lm_Type: LongWord;

  lm_Children: PMinList;

  lm_MinMax: TMUI_MinMax;

  lm_Layout: record

    Width: LongInt;

    Height: LongInt;

    priv5: LongWord;

    priv6: LongWord;

  end;

end;


TMUI_List_TestPos_Result

Declaration

Source position: mui.pas line 460

type TMUI_List_TestPos_Result = record

  entry: LongInt;

  column: SmallInt;

  flags: Word;

  xoffset: SmallInt;

  yoffset: SmallInt;

end;


TMUI_MinMax

Declaration

Source position: mui.pas line 1409

type TMUI_MinMax = record

  MinWidth: SmallInt;

  MinHeight: SmallInt;

  MaxWidth: SmallInt;

  MaxHeight: SmallInt;

  DefWidth: SmallInt;

  DefHeight: SmallInt;

end;


TMUI_NotifyData

Declaration

Source position: mui.pas line 3594

type TMUI_NotifyData = record

  mnd_GlobalInfo: PMUI_GlobalInfo;

  mnd_UserData: LongWord;

  mnd_ObjectID: LongWord;

  priv1: LongWord;

  priv2: LongWord;

  priv3: LongWord;

  priv4: LongWord;

end;


TMUI_Palette_Entry

Declaration

Source position: mui.pas line 391

type TMUI_Palette_Entry = record

  mpe_ID: LongInt;

  mpe_Red: LongWord;

  mpe_Green: LongWord;

  mpe_Blue: LongWord;

  mpe_Group: LongInt;

end;


TMUI_PenSpec

Declaration

Source position: mui.pas line 146

type TMUI_PenSpec = record

  ps_buf: array [0..31] of Char;

end;


TMUI_PubScreenDesc

Declaration

Source position: mui.pas line 184

type TMUI_PubScreenDesc = record

  Version: LongInt;

  Name: array [0..PSD_MAXLEN_NAME-1] of Char;

  Title: array [0..PSD_MAXLEN_TITLE-1] of Char;

  Font: array [0..PSD_MAXLEN_FONT-1] of Char;

  Background: array [0..PSD_MAXLEN_BACKGROUND-1] of Char;

  DisplayID: LongWord;

  DisplayWidth: Word;

  DisplayHeight: Word;

  DisplayDepth: Byte;

  OverscanType: Byte;

  AutoScroll: Byte;

  NoDrag: Byte;

  Exclusive: Byte;

  Interleaved: Byte;

  SysDefault: Byte;

  Behind: Byte;

  AutoClose: Byte;

  CloseGadget: Byte;

  DummyWasForeign: Byte;

  SystemPens: array [0..(PSD_MAXSYSPENS)-1] of Byte;

  Reserved: array [0..((1+(7*4))-PSD_MAXSYSPENS)-1] of Byte;

  Palette: array [0..(PSD_NUMCOLS)-1] of TMUI_RGBcolor;

  rsvd: array [0..(PSD_MAXSYSPENS-PSD_NUMCOLS)-1] of TMUI_RGBcolor;

  rsvd2: array [0..(PSD_MAXMUIPENS)-1] of TMUI_PenSpec;

  Changed: LongInt;

  UserData: Pointer;

end;


TMUI_RenderInfo

Declaration

Source position: mui.pas line 528

type TMUI_RenderInfo = record

  mri_WindowObject: PObject_;

  mri_Screen: PScreen;

  mri_DrawInfo: PDrawInfo;

  mri_Pens: PWord;

  mri_Window: PWindow;

  mri_RastPort: PRastPort;

  mri_Flags: LongWord;

  mri_Colormap: PColorMap;

  mri_ScreenWidth: Word;

  mri_ScreenHeight: Word;

  mri_PensStorage: array [0..MPEN_COUNT-1] of Word;

  mri_Fonts: array [0..(0-MUIV_Font_NegCount)-1] of PTextFont;

  mri_rArray: array [0..MRI_RARRAY_SIZE-1] of PRegion;

  mri_rCount: Integer;

  mri_ClipRect: TRectangle;

  mri_BorderTop: Word;

  mri_BorderBottom: Word;

  mri_BorderLeft: Word;

  mri_BorderRight: Word;

  mri_LeftImage: PObject_;

  mri_RightImage: PObject_;

  mri_UpImage: PObject_;

  mri_DownImage: PObject_;

  mri_SizeImage: PObject_;

  mri_VertProp: PObject_;

  mri_HorizProp: PObject_;

  mri_BufferRP: TRastPort;

  mri_BufferBM: PBitMap;

  mri_FrameImage: array [0..15] of Pdt_frame_image;

end;


TMUI_RGBcolor

Declaration

Source position: mui.pas line 177

type TMUI_RGBcolor = record

  Red: LongWord;

  Green: LongWord;

  Blue: LongWord;

end;


TMUIP_Application_AboutMUI

Declaration

Source position: mui.pas line 902

type TMUIP_Application_AboutMUI = record

  MethodID: LongWord;

  refwindow: PObject_;

end;


TMUIP_Application_AddInputHandler

Declaration

Source position: mui.pas line 908

type TMUIP_Application_AddInputHandler = record

  MethodID: LongWord;

  ihnode: PMUI_InputHandlerNode;

end;


TMUIP_Application_CheckRefresh

Declaration

Source position: mui.pas line 914

type TMUIP_Application_CheckRefresh = record

  MethodID: LongWord;

end;


TMUIP_Application_GetMenuCheck

Declaration

Source position: mui.pas line 919

type TMUIP_Application_GetMenuCheck = record

  MethodID: LongWord;

  MenuID: LongWord;

end;


TMUIP_Application_GetMenuState

Declaration

Source position: mui.pas line 925

type TMUIP_Application_GetMenuState = record

  MethodID: LongWord;

  MenuID: LongWord;

end;


TMUIP_Application_Input

Declaration

Source position: mui.pas line 931

type TMUIP_Application_Input = record

  MethodID: LongWord;

  signal: PLongWord;

end;


TMUIP_Application_InputBuffered

Declaration

Source position: mui.pas line 937

type TMUIP_Application_InputBuffered = record

  MethodID: LongWord;

end;


TMUIP_Application_Load

Declaration

Source position: mui.pas line 942

type TMUIP_Application_Load = record

  MethodID: LongWord;

  name: PChar;

end;


TMUIP_Application_NewInput

Declaration

Source position: mui.pas line 948

type TMUIP_Application_NewInput = record

  MethodID: LongWord;

  signal: PLongWord;

end;


TMUIP_Application_OpenConfigWindow

Declaration

Source position: mui.pas line 954

type TMUIP_Application_OpenConfigWindow = record

  MethodID: LongWord;

  flags: LongWord;

end;


TMUIP_Application_PushMethod

Declaration

Source position: mui.pas line 960

type TMUIP_Application_PushMethod = record

  MethodID: LongWord;

  dest: PObject_;

  count: LongInt;

end;


TMUIP_Application_RemInputHandler

Declaration

Source position: mui.pas line 975

type TMUIP_Application_RemInputHandler = record

  MethodID: LongWord;

  ihnode: PMUI_InputHandlerNode;

end;


TMUIP_Application_ReturnID

Declaration

Source position: mui.pas line 981

type TMUIP_Application_ReturnID = record

  MethodID: LongWord;

  retid: LongWord;

end;


TMUIP_Application_Save

Declaration

Source position: mui.pas line 987

type TMUIP_Application_Save = record

  MethodID: LongWord;

  name: PChar;

end;


TMUIP_Application_SetConfigItem

Declaration

Source position: mui.pas line 992

type TMUIP_Application_SetConfigItem = record

  MethodID: LongWord;

  item: LongWord;

  data: Pointer;

end;


TMUIP_Application_SetMenuCheck

Declaration

Source position: mui.pas line 999

type TMUIP_Application_SetMenuCheck = record

  MethodID: LongWord;

  MenuID: LongWord;

  stat: LongInt;

end;


TMUIP_Application_SetMenuState

Declaration

Source position: mui.pas line 1006

type TMUIP_Application_SetMenuState = record

  MethodID: LongWord;

  MenuID: LongWord;

  stat: LongInt;

end;


TMUIP_Application_ShowHelp

Declaration

Source position: mui.pas line 1013

type TMUIP_Application_ShowHelp = record

  MethodID: LongWord;

  window: PObject_;

  name: PChar;

  node: PChar;

  line: LongInt;

end;


TMUIP_Application_UnpushMethod

Declaration

Source position: mui.pas line 967

type TMUIP_Application_UnpushMethod = record

  MethodID: LongWord;

  dest: PObject_;

  NewMethodID: LongWord;

  method: LongWord;

end;


TMUIP_AskMinMax

Declaration

Source position: mui.pas line 1419

type TMUIP_AskMinMax = record

  MethodID: LongWord;

  MinMaxInfo: PMUI_MinMax;

end;


TMUIP_CallHook

Declaration

Source position: mui.pas line 637

type TMUIP_CallHook = record

  MethodID: LongWord;

  Hook: PHook;

  param1: LongWord;

end;


TMUIP_Cleanup

Declaration

Source position: mui.pas line 1425

type TMUIP_Cleanup = record

  MethodID: LongWord;

end;


TMUIP_Configdata_GetString

Declaration

Source position: mui.pas line 2928

type TMUIP_Configdata_GetString = record

  MethodID: LongWord;

  id: LongWord;

end;


TMUIP_Configdata_GetULong

Declaration

Source position: mui.pas line 2934

type TMUIP_Configdata_GetULong = record

  MethodID: LongWord;

  id: LongWord;

end;


TMUIP_Configdata_Load

Declaration

Source position: mui.pas line 2974

type TMUIP_Configdata_Load = record

  MethodID: LongWord;

  filename: PChar;

end;


TMUIP_Configdata_Save

Declaration

Source position: mui.pas line 2968

type TMUIP_Configdata_Save = record

  MethodID: LongWord;

  filename: PChar;

end;


TMUIP_Configdata_SetFont

Declaration

Source position: mui.pas line 2961

type TMUIP_Configdata_SetFont = record

  MethodID: LongWord;

  id: LongWord;

  font: PChar;

end;


TMUIP_Configdata_SetFramespec

Declaration

Source position: mui.pas line 2954

type TMUIP_Configdata_SetFramespec = record

  MethodID: LongWord;

  id: LongWord;

  framespec: PChar;

end;


TMUIP_Configdata_SetImspec

Declaration

Source position: mui.pas line 2947

type TMUIP_Configdata_SetImspec = record

  MethodID: LongWord;

  id: LongWord;

  imspec: PChar;

end;


TMUIP_Configdata_SetPenspec

Declaration

Source position: mui.pas line 2980

type TMUIP_Configdata_SetPenspec = record

  MethodID: LongWord;

  id: LongWord;

  penspec: PChar;

end;


TMUIP_Configdata_SetString

Declaration

Source position: mui.pas line 2987

type TMUIP_Configdata_SetString = record

  MethodID: LongWord;

  id: LongWord;

  Newstring: PChar;

end;


TMUIP_Configdata_SetULong

Declaration

Source position: mui.pas line 2940

type TMUIP_Configdata_SetULong = record

  MethodID: LongWord;

  id: LongWord;

  val: LongWord;

end;


TMUIP_ConnectParent

Declaration

Source position: mui.pas line 759

type TMUIP_ConnectParent = record

  MethodID: LongWord;

  parent: PObject_;

end;


TMUIP_ContextMenuBuild

Declaration

Source position: mui.pas line 1430

type TMUIP_ContextMenuBuild = record

  MethodID: LongWord;

  mx: LongInt;

  my: LongInt;

end;


TMUIP_ContextMenuChoice

Declaration

Source position: mui.pas line 1437

type TMUIP_ContextMenuChoice = record

  MethodID: LongWord;

  item: PObject_;

end;


TMUIP_CreateBubble

Declaration

Source position: mui.pas line 1443

type TMUIP_CreateBubble = record

  MethodID: LongWord;

  x: LongInt;

  y: LongInt;

  txt: PChar;

  flags: LongWord;

end;


TMUIP_CreateDragImage

Declaration

Source position: mui.pas line 1452

type TMUIP_CreateDragImage = record

  MethodID: LongWord;

  touchx: LongInt;

  touchy: LongInt;

  flags: LongWord;

end;


TMUIP_CreateShortHelp

Declaration

Source position: mui.pas line 1460

type TMUIP_CreateShortHelp = record

  MethodID: LongWord;

  mx: LongInt;

  my: LongInt;

end;


TMUIP_CustomBackfill

Declaration

Source position: mui.pas line 1467

type TMUIP_CustomBackfill = record

  MethodID: LongWord;

  left: LongInt;

  top: LongInt;

  right: LongInt;

  bottom: LongInt;

  xoffset: LongInt;

  yoffset: LongInt;

end;


TMUIP_Dataspace_Add

Declaration

Source position: mui.pas line 2233

type TMUIP_Dataspace_Add = record

  MethodID: LongWord;

  data: Pointer;

  len: LongInt;

  id: LongWord;

end;


TMUIP_Dataspace_Clear

Declaration

Source position: mui.pas line 2241

type TMUIP_Dataspace_Clear = record

  MethodID: LongWord;

end;


TMUIP_Dataspace_Find

Declaration

Source position: mui.pas line 2246

type TMUIP_Dataspace_Find = record

  MethodID: LongWord;

  id: LongWord;

end;


TMUIP_Dataspace_Merge

Declaration

Source position: mui.pas line 2252

type TMUIP_Dataspace_Merge = record

  MethodID: LongWord;

  dataspace: PObject_;

end;


TMUIP_Dataspace_ReadIFF

Declaration

Source position: mui.pas line 2258

type TMUIP_Dataspace_ReadIFF = record

  MethodID: LongWord;

  Handle: PIFFHandle;

end;


TMUIP_Dataspace_Remove

Declaration

Source position: mui.pas line 2264

type TMUIP_Dataspace_Remove = record

  MethodID: LongWord;

  id: LongWord;

end;


TMUIP_Dataspace_WriteIFF

Declaration

Source position: mui.pas line 2270

type TMUIP_Dataspace_WriteIFF = record

  MethodID: LongWord;

  handle: PIFFHandle;

  type_: LongWord;

  id: LongWord;

end;


TMUIP_DeleteBubble

Declaration

Source position: mui.pas line 1478

type TMUIP_DeleteBubble = record

  MethodID: LongWord;

  bubble: Pointer;

end;


TMUIP_DeleteDragImage

Declaration

Source position: mui.pas line 1484

type TMUIP_DeleteDragImage = record

  MethodID: LongWord;

  di: PMUI_DragImage;

end;


TMUIP_DeleteShortHelp

Declaration

Source position: mui.pas line 1490

type TMUIP_DeleteShortHelp = record

  MethodID: LongWord;

  help: PChar;

end;


TMUIP_Dirlist_ReRead

Declaration

Source position: mui.pas line 3376

type TMUIP_Dirlist_ReRead = record

  MethodID: LongWord;

end;


TMUIP_DisconnectParent

Declaration

Source position: mui.pas line 765

type TMUIP_DisconnectParent = record

  MethodID: LongWord;

end;


TMUIP_DoDrag

Declaration

Source position: mui.pas line 1496

type TMUIP_DoDrag = record

  MethodID: LongWord;

  touchx: LongInt;

  touchy: LongInt;

  flags: LongWord;

end;


TMUIP_DragBegin

Declaration

Source position: mui.pas line 1510

type TMUIP_DragBegin = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_DragDrop

Declaration

Source position: mui.pas line 1516

type TMUIP_DragDrop = record

  MethodID: LongWord;

  obj: PObject_;

  x: LongInt;

  y: LongInt;

end;


TMUIP_DragFinish

Declaration

Source position: mui.pas line 1524

type TMUIP_DragFinish = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_DragQuery

Declaration

Source position: mui.pas line 1530

type TMUIP_DragQuery = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_DragReport

Declaration

Source position: mui.pas line 1536

type TMUIP_DragReport = record

  MethodID: LongWord;

  obj: PObject_;

  x: LongInt;

  y: LongInt;

  update: LongInt;

end;


TMUIP_Draw

Declaration

Source position: mui.pas line 1545

type TMUIP_Draw = record

  MethodID: LongWord;

  flags: LongWord;

end;


TMUIP_DrawBackground

Declaration

Source position: mui.pas line 1551

type TMUIP_DrawBackground = record

  MethodID: LongWord;

  left: LongInt;

  top: LongInt;

  width: LongInt;

  height: LongInt;

  xoffset: LongInt;

  yoffset: LongInt;

  flags: LongInt;

end;


TMUIP_DrawBackgroundBuffered

Declaration

Source position: mui.pas line 1563

type TMUIP_DrawBackgroundBuffered = record

  MethodID: LongWord;

  rp: PRastPort;

  left: LongInt;

  top: LongInt;

  width: LongInt;

  height: LongInt;

  xoffset: LongInt;

  yoffset: LongInt;

  flags: LongInt;

end;


TMUIP_DrawParentBackground

Declaration

Source position: mui.pas line 1621

type TMUIP_DrawParentBackground = record

  MethodID: LongWord;

  left: LongInt;

  top: LongInt;

  width: LongInt;

  height: LongInt;

  xoffset: LongInt;

  yoffset: LongInt;

  flags: LongInt;

end;


TMUIP_Export

Declaration

Source position: mui.pas line 644

type TMUIP_Export = record

  MethodID: LongWord;

  dataspace: PObject_;

end;


TMUIP_Family_AddHead

Declaration

Source position: mui.pas line 802

type TMUIP_Family_AddHead = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_Family_AddTail

Declaration

Source position: mui.pas line 808

type TMUIP_Family_AddTail = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_Family_GetChild

Declaration

Source position: mui.pas line 839

type TMUIP_Family_GetChild = record

  MethodID: LongWord;

  nr: LongInt;

  ref: PObject_;

end;


TMUIP_Family_Insert

Declaration

Source position: mui.pas line 814

type TMUIP_Family_Insert = record

  MethodID: LongWord;

  obj: PObject_;

  pred: PObject_;

end;


TMUIP_Family_Remove

Declaration

Source position: mui.pas line 821

type TMUIP_Family_Remove = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_Family_Sort

Declaration

Source position: mui.pas line 827

type TMUIP_Family_Sort = record

  MethodID: LongWord;

  obj: array [0..0] of PObject_;

end;


TMUIP_Family_Transfer

Declaration

Source position: mui.pas line 833

type TMUIP_Family_Transfer = record

  MethodID: LongWord;

  family: PObject_;

end;


TMUIP_FindUData

Declaration

Source position: mui.pas line 650

type TMUIP_FindUData = record

  MethodID: LongWord;

  udata: LongWord;

end;


TMUIP_Floattext_Append

Declaration

Source position: mui.pas line 2712

type TMUIP_Floattext_Append = record

  MethodID: LongWord;

  Text: PChar;

end;


TMUIP_GetConfigItem

Declaration

Source position: mui.pas line 656

type TMUIP_GetConfigItem = record

  MethodID: LongWord;

  id: LongWord;

  storage: PLongWord;

end;


TMUIP_GetUData

Declaration

Source position: mui.pas line 663

type TMUIP_GetUData = record

  MethodID: LongWord;

  udata: LongWord;

  attr: LongWord;

  storage: PLongWord;

end;


TMUIP_GoActive

Declaration

Source position: mui.pas line 1576

type TMUIP_GoActive = record

  MethodID: LongWord;

end;


TMUIP_GoInactive

Declaration

Source position: mui.pas line 1581

type TMUIP_GoInactive = record

  MethodID: LongWord;

end;


TMUIP_Group_AddHead

Declaration

Source position: mui.pas line 1770

type TMUIP_Group_AddHead = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_Group_AddTail

Declaration

Source position: mui.pas line 1776

type TMUIP_Group_AddTail = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_Group_DoMethodNoForward

Declaration

Source position: mui.pas line 1804

type TMUIP_Group_DoMethodNoForward = record

  MethodID: LongWord;

  DoMethodID: LongWord;

end;


TMUIP_Group_ExitChange

Declaration

Source position: mui.pas line 1782

type TMUIP_Group_ExitChange = record

  MethodID: LongWord;

end;


TMUIP_Group_InitChange

Declaration

Source position: mui.pas line 1787

type TMUIP_Group_InitChange = record

  MethodID: LongWord;

end;


TMUIP_Group_Remove

Declaration

Source position: mui.pas line 1798

type TMUIP_Group_Remove = record

  MethodID: LongWord;

  obj: PObject_;

end;


TMUIP_Group_Sort

Declaration

Source position: mui.pas line 1792

type TMUIP_Group_Sort = record

  MethodID: LongWord;

  obj: array [0..0] of PObject_;

end;


TMUIP_HandleEvent

Declaration

Source position: mui.pas line 1586

type TMUIP_HandleEvent = record

  MethodID: LongWord;

  imsg: PIntuiMessage;

  muikey: LongInt;

end;


TMUIP_HandleInput

Declaration

Source position: mui.pas line 1593

type TMUIP_HandleInput = record

  MethodID: LongWord;

  imsg: PIntuiMessage;

  muikey: LongInt;

end;


TMUIP_Hide

Declaration

Source position: mui.pas line 1600

type TMUIP_Hide = record

  MethodID: LongWord;

end;


TMUIP_Import

Declaration

Source position: mui.pas line 671

type TMUIP_Import = record

  MethodID: LongWord;

  dataspace: PObject_;

end;


TMUIP_KillNotify

Declaration

Source position: mui.pas line 677

type TMUIP_KillNotify = record

  MethodID: LongWord;

  TrigAttr: LongWord;

end;


TMUIP_KillNotifyObj

Declaration

Source position: mui.pas line 683

type TMUIP_KillNotifyObj = record

  MethodID: LongWord;

  TrigAttr: LongWord;

  dest: PObject_;

end;


TMUIP_Layout

Declaration

Source position: mui.pas line 1616

type TMUIP_Layout = record

  MethodID: LongWord;

end;


TMUIP_List_Clear

Declaration

Source position: mui.pas line 2486

type TMUIP_List_Clear = record

  MethodID: LongWord;

end;


TMUIP_List_Compare

Declaration

Source position: mui.pas line 2491

type TMUIP_List_Compare = record

  MethodID: LongWord;

  entry1: Pointer;

  entry2: Pointer;

  sort_type1: LongInt;

  sort_type2: LongInt;

end;


TMUIP_List_Construct

Declaration

Source position: mui.pas line 2500

type TMUIP_List_Construct = record

  MethodID: LongWord;

  entry: Pointer;

  pool: Pointer;

end;


TMUIP_List_CreateImage

Declaration

Source position: mui.pas line 2507

type TMUIP_List_CreateImage = record

  MethodID: LongWord;

  obj: PObject_;

  flags: LongWord;

end;


TMUIP_List_DeleteImage

Declaration

Source position: mui.pas line 2514

type TMUIP_List_DeleteImage = record

  MethodID: LongWord;

  listimg: Pointer;

end;


TMUIP_List_Exchange

Declaration

Source position: mui.pas line 2520

type TMUIP_List_Exchange = record

  MethodID: LongWord;

  pos1: LongInt;

  pos2: LongInt;

end;


TMUIP_List_GetEntry

Declaration

Source position: mui.pas line 2527

type TMUIP_List_GetEntry = record

  MethodID: LongWord;

  pos: LongInt;

  entry: PAPTR;

end;


TMUIP_List_Insert

Declaration

Source position: mui.pas line 2534

type TMUIP_List_Insert = record

  MethodID: LongWord;

  entries: PAPTR;

  count: LongInt;

  pos: LongInt;

end;


TMUIP_List_InsertSingle

Declaration

Source position: mui.pas line 2542

type TMUIP_List_InsertSingle = record

  MethodID: LongWord;

  entry: Pointer;

  pos: LongInt;

end;


TMUIP_List_Jump

Declaration

Source position: mui.pas line 2549

type TMUIP_List_Jump = record

  MethodID: LongWord;

  pos: LongInt;

end;


TMUIP_List_Move

Declaration

Source position: mui.pas line 2555

type TMUIP_List_Move = record

  MethodID: LongWord;

  from: LongInt;

  too: LongInt;

end;


TMUIP_List_NextSelected

Declaration

Source position: mui.pas line 2562

type TMUIP_List_NextSelected = record

  MethodID: LongWord;

  pos: PLongInt;

end;


TMUIP_List_Redraw

Declaration

Source position: mui.pas line 2568

type TMUIP_List_Redraw = record

  MethodID: LongWord;

  pos: LongInt;

end;


TMUIP_List_Remove

Declaration

Source position: mui.pas line 2574

type TMUIP_List_Remove = record

  MethodID: LongWord;

  pos: LongInt;

end;


TMUIP_List_Select

Declaration

Source position: mui.pas line 2580

type TMUIP_List_Select = record

  MethodID: LongWord;

  pos: LongInt;

  seltype: LongInt;

  state: PLongInt;

end;


TMUIP_List_Sort

Declaration

Source position: mui.pas line 2588

type TMUIP_List_Sort = record

  MethodID: LongWord;

end;


TMUIP_List_TestPos

Declaration

Source position: mui.pas line 2593

type TMUIP_List_TestPos = record

  MethodID: LongWord;

  x: LongInt;

  y: LongInt;

  res: PMUI_List_TestPos_Result;

end;


TMUIP_MultiSet

Declaration

Source position: mui.pas line 690

type TMUIP_MultiSet = record

  MethodID: LongWord;

  attr: LongWord;

  val: LongWord;

  obj: Pointer;

end;


TMUIP_NoNotifySet

Declaration

Source position: mui.pas line 698

type TMUIP_NoNotifySet = record

  MethodID: LongWord;

  attr: LongWord;

  val: LongWord;

end;


TMUIP_Notify

Declaration

Source position: mui.pas line 705

type TMUIP_Notify = record

  MethodID: LongWord;

  TrigAttr: LongWord;

  TrigVal: LongWord;

  DestObj: Pointer;

  FollowParams: LongWord;

end;


TMUIP_Numeric_Decrease

Declaration

Source position: mui.pas line 1921

type TMUIP_Numeric_Decrease = record

  MethodID: LongWord;

  amount: LongInt;

end;


TMUIP_Numeric_Increase

Declaration

Source position: mui.pas line 1927

type TMUIP_Numeric_Increase = record

  MethodID: LongWord;

  amount: LongInt;

end;


TMUIP_Numeric_ScaleToValue

Declaration

Source position: mui.pas line 1933

type TMUIP_Numeric_ScaleToValue = record

  MethodID: LongWord;

  scalemin: LongInt;

  scalemax: LongInt;

  scale: LongInt;

end;


TMUIP_Numeric_SetDefault

Declaration

Source position: mui.pas line 1941

type TMUIP_Numeric_SetDefault = record

  MethodID: LongWord;

end;


TMUIP_Numeric_Stringify

Declaration

Source position: mui.pas line 1946

type TMUIP_Numeric_Stringify = record

  MethodID: LongWord;

  value: LongInt;

end;


TMUIP_Numeric_ValueToScale

Declaration

Source position: mui.pas line 1952

type TMUIP_Numeric_ValueToScale = record

  MethodID: LongWord;

  scalemin: LongInt;

  scalemax: LongInt;

end;


TMUIP_Numeric_ValueToScaleExt

Declaration

Source position: mui.pas line 1959

type TMUIP_Numeric_ValueToScaleExt = record

  MethodID: LongWord;

  value: LongInt;

  scalemin: LongInt;

  scalemax: LongInt;

end;


TMUIP_Pendisplay_SetColormap

Declaration

Source position: mui.pas line 3241

type TMUIP_Pendisplay_SetColormap = record

  MethodID: LongWord;

  colormap: LongInt;

end;


TMUIP_Pendisplay_SetMUIPen

Declaration

Source position: mui.pas line 3247

type TMUIP_Pendisplay_SetMUIPen = record

  MethodID: LongWord;

  muipen: LongInt;

end;


TMUIP_Pendisplay_SetRGB

Declaration

Source position: mui.pas line 3253

type TMUIP_Pendisplay_SetRGB = record

  MethodID: LongWord;

  red: LongWord;

  green: LongWord;

  blue: LongWord;

end;


TMUIP_Pixmap_DrawSection

Declaration

Source position: mui.pas line 3542

type TMUIP_Pixmap_DrawSection = record

  MethodID: LongWord;

  sx: LongInt;

  sy: LongInt;

  sw: LongInt;

  sh: LongInt;

  mri: PMUI_RenderInfo;

  dx: LongInt;

  dy: LongInt;

end;


TMUIP_Popstring_Close

Declaration

Source position: mui.pas line 2739

type TMUIP_Popstring_Close = record

  MethodID: LongWord;

  result: LongInt;

end;


TMUIP_Popstring_Open

Declaration

Source position: mui.pas line 2745

type TMUIP_Popstring_Open = record

  MethodID: LongWord;

end;


TMUIP_Process_Kill

Declaration

Source position: mui.pas line 3500

type TMUIP_Process_Kill = record

  MethodID: LongWord;

  maxdelay: LongInt;

end;


TMUIP_Process_Launch

Declaration

Source position: mui.pas line 3505

type TMUIP_Process_Launch = record

  MethodID: LongWord;

end;


TMUIP_Process_Process

Declaration

Source position: mui.pas line 3509

type TMUIP_Process_Process = record

  MethodID: LongWord;

  kill: PLongWord;

  proc: PObject_;

end;


TMUIP_Process_Signal

Declaration

Source position: mui.pas line 3515

type TMUIP_Process_Signal = record

  MethodID: LongWord;

  sigs: LongWord;

end;


TMUIP_Prop_Decrease

Declaration

Source position: mui.pas line 2104

type TMUIP_Prop_Decrease = record

  MethodID: LongWord;

  amount: LongInt;

end;


TMUIP_Prop_Increase

Declaration

Source position: mui.pas line 2110

type TMUIP_Prop_Increase = record

  MethodID: LongWord;

  amount: LongInt;

end;


TMUIP_Semaphore_Attempt

Declaration

Source position: mui.pas line 2348

type TMUIP_Semaphore_Attempt = record

  MethodID: LongWord;

end;


TMUIP_Semaphore_AttemptShared

Declaration

Source position: mui.pas line 2353

type TMUIP_Semaphore_AttemptShared = record

  MethodID: LongWord;

end;


TMUIP_Semaphore_Obtain

Declaration

Source position: mui.pas line 2358

type TMUIP_Semaphore_Obtain = record

  MethodID: LongWord;

end;


TMUIP_Semaphore_ObtainShared

Declaration

Source position: mui.pas line 2363

type TMUIP_Semaphore_ObtainShared = record

  MethodID: LongWord;

end;


TMUIP_Semaphore_Release

Declaration

Source position: mui.pas line 2368

type TMUIP_Semaphore_Release = record

  MethodID: LongWord;

end;


TMUIP_Set

Declaration

Source position: mui.pas line 714

type TMUIP_Set = record

  MethodID: LongWord;

  attr: LongWord;

  val: LongWord;

end;


TMUIP_SetAsString

Declaration

Source position: mui.pas line 721

type TMUIP_SetAsString = record

  MethodID: LongWord;

  attr: LongWord;

  format: PChar;

  val: LongWord;

end;


TMUIP_Settingsgroup_ConfigToGadgets

Declaration

Source position: mui.pas line 2873

type TMUIP_Settingsgroup_ConfigToGadgets = record

  MethodID: LongWord;

  configdata: PObject_;

end;


TMUIP_Settingsgroup_GadgetsToConfig

Declaration

Source position: mui.pas line 2879

type TMUIP_Settingsgroup_GadgetsToConfig = record

  MethodID: LongWord;

  configdata: PObject_;

end;


TMUIP_SetUData

Declaration

Source position: mui.pas line 729

type TMUIP_SetUData = record

  MethodID: LongWord;

  udata: LongWord;

  attr: LongWord;

  val: LongWord;

end;


TMUIP_SetUDataOnce

Declaration

Source position: mui.pas line 737

type TMUIP_SetUDataOnce = record

  MethodID: LongWord;

  udata: LongWord;

  attr: LongWord;

  val: LongWord;

end;


TMUIP_Setup

Declaration

Source position: mui.pas line 1605

type TMUIP_Setup = record

  MethodID: LongWord;

  RenderInfo: PMUI_RenderInfo;

end;


TMUIP_Show

Declaration

Source position: mui.pas line 1611

type TMUIP_Show = record

  MethodID: LongWord;

end;


TMUIP_String_ClearSelected

Declaration

Source position: mui.pas line 2050

type TMUIP_String_ClearSelected = record

  MethodID: LongWord;

end;


TMUIP_String_FileNameStart

Declaration

Source position: mui.pas line 2055

type TMUIP_String_FileNameStart = record

  MethodID: LongWord;

  buffer: PChar;

  pos: LongInt;

end;


TMUIP_String_Insert

Declaration

Source position: mui.pas line 2061

type TMUIP_String_Insert = record

  MethodID: LongWord;

  text: PChar;

  pos: LongInt;

end;


TMUIP_UnknownDropDestination

Declaration

Source position: mui.pas line 1504

type TMUIP_UnknownDropDestination = record

  MethodID: LongWord;

  imsg: PIntuiMessage;

end;


TMUIP_Window_ActionIconify

Declaration

Source position: mui.pas line 1134

type TMUIP_Window_ActionIconify = record

  MethodID: LongWord;

end;


TMUIP_Window_AddControlCharHandler

Declaration

Source position: mui.pas line 1187

type TMUIP_Window_AddControlCharHandler = record

  MethodID: LongWord;

  ccnode: PMUI_EventHandlerNode;

end;


TMUIP_Window_AddEventHandler

Declaration

Source position: mui.pas line 1139

type TMUIP_Window_AddEventHandler = record

  MethodID: LongWord;

  ehnode: PMUI_EventHandlerNode;

end;


TMUIP_Window_AllocGadgetID

Declaration

Source position: mui.pas line 1193

type TMUIP_Window_AllocGadgetID = record

  MethodID: LongWord;

end;


TMUIP_Window_Cleanup

Declaration

Source position: mui.pas line 1145

type TMUIP_Window_Cleanup = record

  MethodID: LongWord;

end;


TMUIP_Window_DragObject

Declaration

Source position: mui.pas line 1210

type TMUIP_Window_DragObject = record

  MethodID: LongWord;

  obj: PObject_;

  touchx: LongInt;

  touchy: LongInt;

  flags: LongWord;

end;


TMUIP_Window_DrawBackground

Declaration

Source position: mui.pas line 1198

type TMUIP_Window_DrawBackground = record

  MethodID: LongWord;

  left: LongInt;

  top: LongInt;

  width: LongInt;

  height: LongInt;

  xoffset: LongInt;

  yoffset: LongInt;

  flags: LongInt;

end;


TMUIP_Window_FreeGadgetID

Declaration

Source position: mui.pas line 1219

type TMUIP_Window_FreeGadgetID = record

  MethodID: LongWord;

  gadgetid: LongInt;

end;


TMUIP_Window_RecalcDisplay

Declaration

Source position: mui.pas line 1225

type TMUIP_Window_RecalcDisplay = record

  MethodID: LongWord;

  originator: PObject_;

end;


TMUIP_Window_RemControlCharHandler

Declaration

Source position: mui.pas line 1231

type TMUIP_Window_RemControlCharHandler = record

  MethodID: LongWord;

  ccnode: PMUI_EventHandlerNode;

end;


TMUIP_Window_RemEventHandler

Declaration

Source position: mui.pas line 1150

type TMUIP_Window_RemEventHandler = record

  MethodID: LongWord;

  ehnode: PMUI_EventHandlerNode;

end;


TMUIP_Window_ScreenToBack

Declaration

Source position: mui.pas line 1156

type TMUIP_Window_ScreenToBack = record

  MethodID: LongWord;

end;


TMUIP_Window_ScreenToFront

Declaration

Source position: mui.pas line 1161

type TMUIP_Window_ScreenToFront = record

  MethodID: LongWord;

end;


TMUIP_Window_Setup

Declaration

Source position: mui.pas line 1166

type TMUIP_Window_Setup = record

  MethodID: LongWord;

end;


TMUIP_Window_Snapshot

Declaration

Source position: mui.pas line 1171

type TMUIP_Window_Snapshot = record

  MethodID: LongWord;

  flags: LongInt;

end;


TMUIP_Window_ToBack

Declaration

Source position: mui.pas line 1177

type TMUIP_Window_ToBack = record

  MethodID: LongWord;

end;


TMUIP_Window_ToFront

Declaration

Source position: mui.pas line 1182

type TMUIP_Window_ToFront = record

  MethodID: LongWord;

end;


TMUIP_Window_UpdateMenu

Declaration

Source position: mui.pas line 1237

type TMUIP_Window_UpdateMenu = record

  MethodID: LongWord;

end;


TMUIP_WriteLong

Declaration

Source position: mui.pas line 745

type TMUIP_WriteLong = record

  MethodID: LongWord;

  val: LongWord;

  memory: PLongWord;

end;


TMUIP_WriteString

Declaration

Source position: mui.pas line 752

type TMUIP_WriteString = record

  MethodID: LongWord;

  str: PChar;

  memory: PChar;

end;


TMUIS_InfoClient

Declaration

Source position: mui.pas line 220

type TMUIS_InfoClient = record

  Node: TMinNode;

  Task: PTask;

  SigBit: LongWord;

end;


TWindowPos

Declaration

Source position: mui.pas line 1081

type TWindowPos = record

  id: LongWord;

  x1: SmallInt;

  y1: SmallInt;

  w1: SmallInt;

  h1: SmallInt;

  x2: SmallInt;

  y2: SmallInt;

  w2: SmallInt;

  h2: SmallInt;

end;


BMF_USERPRIVATE

Declaration

Source position: picasso96api.pas line 85

const BMF_USERPRIVATE = $8000;


Reference for unit 'picasso96api'

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
utility, | Tag Handling, Date routines in utility.library
agraphics, | Native Amiga graphic functions (graphics.library)
intuition; | Screen and Window handling routines of intuition.library


Reference for unit 'picasso96api': Constants

BMF_USERPRIVATE

MODENAMELENGTH

P96BD_BoardDriver

P96BD_BoardName

P96BD_ChipDriver

P96BD_ChipName

P96BD_Dummy

P96BD_FreeMemory

P96BD_InternalMemorySize

P96BD_LargestFreeMemory

P96BD_MemoryClock

P96BD_MonitorDisplayHeight

P96BD_MonitorDisplayWidth

P96BD_MonitorDotClockMax

P96BD_MonitorDotClockMin

P96BD_MonitorEDIDRev

P96BD_MonitorEDIDVer

P96BD_MonitorHSyncMax

P96BD_MonitorHSyncMin

P96BD_MonitorInputType

P96BD_MonitorProduct

P96BD_MonitorProductID

P96BD_MonitorSwitch

P96BD_MonitorVendorID

P96BD_MonitorVSyncMax

P96BD_MonitorVSyncMin

P96BD_PCIProductID

P96BD_PCIVendorID

P96BD_RGBFormats

P96BD_TotalMemory

P96BIDTAG_Depth

P96BIDTAG_Dummy

P96BIDTAG_FormatsAllowed

P96BIDTAG_FormatsForbidden

P96BIDTAG_NominalHeight

P96BIDTAG_NominalWidth

P96BIDTAG_PabloIVCompatible

P96BIDTAG_PalomaIVCompatible

P96BIDTAG_VideoCompatible

P96BMA_BITSPERPIXEL

P96BMA_BOARDIOBASE

P96BMA_BOARDMEMBASE

P96BMA_BOARDMEMIOBASE

P96BMA_BYTESPERPIXEL

P96BMA_BYTESPERROW

P96BMA_DEPTH

P96BMA_HEIGHT

P96BMA_ISONBOARD

P96BMA_ISP96

P96BMA_MEMORY

P96BMA_RGBFORMAT

P96BMA_WIDTH

P96IDA_BITSPERPIXEL

P96IDA_BOARDNAME

P96IDA_BOARDNUMBER

P96IDA_BYTESPERPIXEL

P96IDA_COMPATIBLEFORMATS

P96IDA_DEPTH

P96IDA_HEIGHT

P96IDA_ISP96

P96IDA_PABLOIVCOMPATIBLE

P96IDA_PALOMAIVCOMPATIBLE

P96IDA_RGBFORMAT

P96IDA_STDBYTESPERROW

P96IDA_VIDEOCOMPATIBLE

P96IDA_WIDTH

P96MA_CancelText

P96MA_DisplayID

P96MA_Dummy

P96MA_FormatsAllowed

P96MA_FormatsForbidden

P96MA_MaxDepth

P96MA_MaxHeight

P96MA_MaxWidth

P96MA_MinDepth

P96MA_MinHeight

P96MA_MinWidth

P96MA_OKText

P96MA_PabloIVCompatible

P96MA_PalomaIVCompatible

P96MA_PubScreenName

P96MA_Screen

P96MA_VideoCompatible

P96MA_Window

P96MA_WindowTitle

P96PIPT_MemoryWindow

P96PIPT_VideoWindow

P96PIP_Alignment

P96PIP_AllowCropping

P96PIP_Brightness

P96PIP_ClipHeight

P96PIP_ClipLeft

P96PIP_ClipTop

P96PIP_ClipWidth

P96PIP_ColorKeyARGB

P96PIP_ColorKeyPen

P96PIP_Colors

P96PIP_Colors32

P96PIP_ConstantBytesPerRow

P96PIP_ConstantByteSwapping

P96PIP_DisplayedBuffer

P96PIP_Dummy

P96PIP_ErrorCode

P96PIP_Height

P96PIP_InitialIntScaling

P96PIP_Left

P96PIP_NoMemory

P96PIP_NumberOfBuffers

P96PIP_Relativity

P96PIP_RenderFunc

P96PIP_SaveFunc

P96PIP_SourceBitMap

P96PIP_SourceFormat

P96PIP_SourceHeight

P96PIP_SourceRPort

P96PIP_SourceWidth

P96PIP_Top

P96PIP_Type

P96PIP_UserData

P96PIP_VisibleBuffer

P96PIP_Width

P96PIP_WorkBuffer

P96RD_Dummy

P96RD_NumberOfBoards

P96SA_Alignment

P96SA_AutoScroll

P96SA_BackFill

P96SA_Behind

P96SA_BitMap

P96SA_BlockPen

P96SA_Colors

P96SA_Colors32

P96SA_ConstantBytesPerRow

P96SA_ConstantByteSwapping

P96SA_DClip

P96SA_Depth

P96SA_DetailPen

P96SA_DisplayID

P96SA_Dummy

P96SA_ErrorCode

P96SA_Exclusive

P96SA_FixedScreen

P96SA_Font

P96SA_Height

P96SA_Left

P96SA_NoMemory

P96SA_NoSprite

P96SA_Pens

P96SA_PubName

P96SA_PubSig

P96SA_PubTask

P96SA_Quiet

P96SA_RenderFunc

P96SA_RGBFormat

P96SA_SaveFunc

P96SA_SharePens

P96SA_ShowTitle

P96SA_SysFont

P96SA_Title

P96SA_Top

P96SA_Type

P96SA_UserData

P96SA_VideoControl

P96SA_Width

PICASSO96APINAME

PIPERR_ATTACHFAIL

PIPERR_BADALIGNMENT

PIPERR_BADDIMENSIONS

PIPERR_CROPPED

PIPERR_NOMEMORY

PIPERR_NOTAVAILABLE

PIPERR_NOWINDOW

PIPERR_OUTOFPENS

PIPRel_Bottom

PIPRel_Height

PIPRel_Right

PIPRel_Width

PIPT_MemoryWindow

PIPT_NUMTYPES

PIPT_VideoWindow

RGBFF_A8B8G8R8

RGBFF_A8R8G8B8

RGBFF_ALPHA8

RGBFF_B5G5R5PC

RGBFF_B5G6R5PC

RGBFF_B8G8R8

RGBFF_B8G8R8A8

RGBFF_CLUT

RGBFF_HICOLOR

RGBFF_NONE

RGBFF_R5G5B5

RGBFF_R5G5B5PC

RGBFF_R5G6B5

RGBFF_R5G6B5PC

RGBFF_R8G8B8

RGBFF_R8G8B8A8

RGBFF_TRUEALPHA

RGBFF_TRUECOLOR

RGBFF_YUV410P

RGBFF_YUV411

RGBFF_YUV420P

RGBFF_YUV422

RGBFF_YUV422CGX

RGBFF_YUV422PA

RGBFF_YUV422PC


Reference for unit 'picasso96api': Types

PP96Mode

PRenderInfo

PTrueColorInfo

PYUVRenderInfo

TP96Mode

TRenderInfo

TRGBFTYPE

TTrueColorInfo

TYUVRenderInfo


IP96

Declaration

Source position: picasso96api.pas line 322

var IP96: PInterface = Nil;


MODENAMELENGTH

Declaration

Source position: picasso96api.pas line 191

const MODENAMELENGTH = 48;


P96Base

Declaration

Source position: picasso96api.pas line 321

var P96Base: PLibrary = Nil;


P96BD_BoardDriver

Declaration

Source position: picasso96api.pas line 316

const P96BD_BoardDriver = P96BD_Dummy + 26;


P96BD_BoardName

Declaration

Source position: picasso96api.pas line 291

const P96BD_BoardName = P96BD_Dummy + 1;


P96BD_ChipDriver

Declaration

Source position: picasso96api.pas line 317

const P96BD_ChipDriver = P96BD_Dummy + 27;


P96BD_ChipName

Declaration

Source position: picasso96api.pas line 292

const P96BD_ChipName = P96BD_Dummy + 2;


P96BD_Dummy

Declaration

Source position: picasso96api.pas line 290

const P96BD_Dummy = TAG_USER + $50000 + 96;


P96BD_FreeMemory

Declaration

Source position: picasso96api.pas line 294

const P96BD_FreeMemory = P96BD_Dummy + 5;


P96BD_InternalMemorySize

Declaration

Source position: picasso96api.pas line 318

const P96BD_InternalMemorySize = P96BD_Dummy + 28;


P96BD_LargestFreeMemory

Declaration

Source position: picasso96api.pas line 295

const P96BD_LargestFreeMemory = P96BD_Dummy + 6;


P96BD_MemoryClock

Declaration

Source position: picasso96api.pas line 298

const P96BD_MemoryClock = P96BD_Dummy + 9;


P96BD_MonitorDisplayHeight

Declaration

Source position: picasso96api.pas line 314

const P96BD_MonitorDisplayHeight = P96BD_Dummy + 25;


P96BD_MonitorDisplayWidth

Declaration

Source position: picasso96api.pas line 313

const P96BD_MonitorDisplayWidth = P96BD_Dummy + 24;


P96BD_MonitorDotClockMax

Declaration

Source position: picasso96api.pas line 309

const P96BD_MonitorDotClockMax = P96BD_Dummy + 20;


P96BD_MonitorDotClockMin

Declaration

Source position: picasso96api.pas line 308

const P96BD_MonitorDotClockMin = P96BD_Dummy + 19;


P96BD_MonitorEDIDRev

Declaration

Source position: picasso96api.pas line 312

const P96BD_MonitorEDIDRev = P96BD_Dummy + 23;


P96BD_MonitorEDIDVer

Declaration

Source position: picasso96api.pas line 311

const P96BD_MonitorEDIDVer = P96BD_Dummy + 22;


P96BD_MonitorHSyncMax

Declaration

Source position: picasso96api.pas line 305

const P96BD_MonitorHSyncMax = P96BD_Dummy + 16;


P96BD_MonitorHSyncMin

Declaration

Source position: picasso96api.pas line 304

const P96BD_MonitorHSyncMin = P96BD_Dummy + 15;


P96BD_MonitorInputType

Declaration

Source position: picasso96api.pas line 310

const P96BD_MonitorInputType = P96BD_Dummy + 21;


P96BD_MonitorProduct

Declaration

Source position: picasso96api.pas line 302

const P96BD_MonitorProduct = P96BD_Dummy + 13;


P96BD_MonitorProductID

Declaration

Source position: picasso96api.pas line 303

const P96BD_MonitorProductID = P96BD_Dummy + 14;


P96BD_MonitorSwitch

Declaration

Source position: picasso96api.pas line 296

const P96BD_MonitorSwitch = P96BD_Dummy + 7;


P96BD_MonitorVendorID

Declaration

Source position: picasso96api.pas line 301

const P96BD_MonitorVendorID = P96BD_Dummy + 12;


P96BD_MonitorVSyncMax

Declaration

Source position: picasso96api.pas line 307

const P96BD_MonitorVSyncMax = P96BD_Dummy + 18;


P96BD_MonitorVSyncMin

Declaration

Source position: picasso96api.pas line 306

const P96BD_MonitorVSyncMin = P96BD_Dummy + 17;


P96BD_PCIProductID

Declaration

Source position: picasso96api.pas line 300

const P96BD_PCIProductID = P96BD_Dummy + 11;


P96BD_PCIVendorID

Declaration

Source position: picasso96api.pas line 299

const P96BD_PCIVendorID = P96BD_Dummy + 10;


P96BD_RGBFormats

Declaration

Source position: picasso96api.pas line 297

const P96BD_RGBFormats = P96BD_Dummy + 8;


P96BD_TotalMemory

Declaration

Source position: picasso96api.pas line 293

const P96BD_TotalMemory = P96BD_Dummy + 4;


P96BIDTAG_Depth

Declaration

Source position: picasso96api.pas line 125

const P96BIDTAG_Depth = P96BIDTAG_Dummy + $0005;


P96BIDTAG_Dummy

Declaration

Source position: picasso96api.pas line 120

const P96BIDTAG_Dummy = TAG_USER + 96;


P96BIDTAG_FormatsAllowed

Declaration

Source position: picasso96api.pas line 121

const P96BIDTAG_FormatsAllowed = P96BIDTAG_Dummy + $0001;


P96BIDTAG_FormatsForbidden

Declaration

Source position: picasso96api.pas line 122

const P96BIDTAG_FormatsForbidden = P96BIDTAG_Dummy + $0002;


P96BIDTAG_NominalHeight

Declaration

Source position: picasso96api.pas line 124

const P96BIDTAG_NominalHeight = P96BIDTAG_Dummy + $0004;


P96BIDTAG_NominalWidth

Declaration

Source position: picasso96api.pas line 123

const P96BIDTAG_NominalWidth = P96BIDTAG_Dummy + $0003;


P96BIDTAG_PabloIVCompatible

Declaration

Source position: picasso96api.pas line 127

const P96BIDTAG_PabloIVCompatible = P96BIDTAG_Dummy + $0007;


P96BIDTAG_PalomaIVCompatible

Declaration

Source position: picasso96api.pas line 128

const P96BIDTAG_PalomaIVCompatible = P96BIDTAG_Dummy + $0008;


P96BIDTAG_VideoCompatible

Declaration

Source position: picasso96api.pas line 126

const P96BIDTAG_VideoCompatible = P96BIDTAG_Dummy + $0006;


P96BMA_BITSPERPIXEL

Declaration

Source position: picasso96api.pas line 95

const P96BMA_BITSPERPIXEL = 6;


P96BMA_BOARDIOBASE

Declaration

Source position: picasso96api.pas line 100

const P96BMA_BOARDIOBASE = 11;


P96BMA_BOARDMEMBASE

Declaration

Source position: picasso96api.pas line 99

const P96BMA_BOARDMEMBASE = 10;


P96BMA_BOARDMEMIOBASE

Declaration

Source position: picasso96api.pas line 101

const P96BMA_BOARDMEMIOBASE = 12;


P96BMA_BYTESPERPIXEL

Declaration

Source position: picasso96api.pas line 94

const P96BMA_BYTESPERPIXEL = 5;


P96BMA_BYTESPERROW

Declaration

Source position: picasso96api.pas line 93

const P96BMA_BYTESPERROW = 4;


P96BMA_DEPTH

Declaration

Source position: picasso96api.pas line 91

const P96BMA_DEPTH = 2;


P96BMA_HEIGHT

Declaration

Source position: picasso96api.pas line 90

const P96BMA_HEIGHT = 1;


P96BMA_ISONBOARD

Declaration

Source position: picasso96api.pas line 98

const P96BMA_ISONBOARD = 9;


P96BMA_ISP96

Declaration

Source position: picasso96api.pas line 97

const P96BMA_ISP96 = 8;


P96BMA_MEMORY

Declaration

Source position: picasso96api.pas line 92

const P96BMA_MEMORY = 3;


P96BMA_RGBFORMAT

Declaration

Source position: picasso96api.pas line 96

const P96BMA_RGBFORMAT = 7;


P96BMA_WIDTH

Declaration

Source position: picasso96api.pas line 89

const P96BMA_WIDTH = 0;


P96IDA_BITSPERPIXEL

Declaration

Source position: picasso96api.pas line 108

const P96IDA_BITSPERPIXEL = 4;


P96IDA_BOARDNAME

Declaration

Source position: picasso96api.pas line 113

const P96IDA_BOARDNAME = 9;


P96IDA_BOARDNUMBER

Declaration

Source position: picasso96api.pas line 111

const P96IDA_BOARDNUMBER = 7;


P96IDA_BYTESPERPIXEL

Declaration

Source position: picasso96api.pas line 107

const P96IDA_BYTESPERPIXEL = 3;


P96IDA_COMPATIBLEFORMATS

Declaration

Source position: picasso96api.pas line 114

const P96IDA_COMPATIBLEFORMATS = 10;


P96IDA_DEPTH

Declaration

Source position: picasso96api.pas line 106

const P96IDA_DEPTH = 2;


P96IDA_HEIGHT

Declaration

Source position: picasso96api.pas line 105

const P96IDA_HEIGHT = 1;


P96IDA_ISP96

Declaration

Source position: picasso96api.pas line 110

const P96IDA_ISP96 = 6;


P96IDA_PABLOIVCOMPATIBLE

Declaration

Source position: picasso96api.pas line 116

const P96IDA_PABLOIVCOMPATIBLE = 12;


P96IDA_PALOMAIVCOMPATIBLE

Declaration

Source position: picasso96api.pas line 117

const P96IDA_PALOMAIVCOMPATIBLE = 13;


P96IDA_RGBFORMAT

Declaration

Source position: picasso96api.pas line 109

const P96IDA_RGBFORMAT = 5;


P96IDA_STDBYTESPERROW

Declaration

Source position: picasso96api.pas line 112

const P96IDA_STDBYTESPERROW = 8;


P96IDA_VIDEOCOMPATIBLE

Declaration

Source position: picasso96api.pas line 115

const P96IDA_VIDEOCOMPATIBLE = 11;


P96IDA_WIDTH

Declaration

Source position: picasso96api.pas line 104

const P96IDA_WIDTH = 0;


P96MA_CancelText

Declaration

Source position: picasso96api.pas line 142

const P96MA_CancelText = P96MA_Dummy + $000c;


P96MA_DisplayID

Declaration

Source position: picasso96api.pas line 137

const P96MA_DisplayID = P96MA_Dummy + $0007;


P96MA_Dummy

Declaration

Source position: picasso96api.pas line 130

const P96MA_Dummy = TAG_USER + $10000 + 96;


P96MA_FormatsAllowed

Declaration

Source position: picasso96api.pas line 138

const P96MA_FormatsAllowed = P96MA_Dummy + $0008;


P96MA_FormatsForbidden

Declaration

Source position: picasso96api.pas line 139

const P96MA_FormatsForbidden = P96MA_Dummy + $0009;


P96MA_MaxDepth

Declaration

Source position: picasso96api.pas line 136

const P96MA_MaxDepth = P96MA_Dummy + $0006;


P96MA_MaxHeight

Declaration

Source position: picasso96api.pas line 135

const P96MA_MaxHeight = P96MA_Dummy + $0005;


P96MA_MaxWidth

Declaration

Source position: picasso96api.pas line 134

const P96MA_MaxWidth = P96MA_Dummy + $0004;


P96MA_MinDepth

Declaration

Source position: picasso96api.pas line 133

const P96MA_MinDepth = P96MA_Dummy + $0003;


P96MA_MinHeight

Declaration

Source position: picasso96api.pas line 132

const P96MA_MinHeight = P96MA_Dummy + $0002;


P96MA_MinWidth

Declaration

Source position: picasso96api.pas line 131

const P96MA_MinWidth = P96MA_Dummy + $0001;


P96MA_OKText

Declaration

Source position: picasso96api.pas line 141

const P96MA_OKText = P96MA_Dummy + $000b;


P96MA_PabloIVCompatible

Declaration

Source position: picasso96api.pas line 147

const P96MA_PabloIVCompatible = P96MA_Dummy + $0011;


P96MA_PalomaIVCompatible

Declaration

Source position: picasso96api.pas line 148

const P96MA_PalomaIVCompatible = P96MA_Dummy + $0012;


P96MA_PubScreenName

Declaration

Source position: picasso96api.pas line 144

const P96MA_PubScreenName = P96MA_Dummy + $000e;


P96MA_Screen

Declaration

Source position: picasso96api.pas line 145

const P96MA_Screen = P96MA_Dummy + $000f;


P96MA_VideoCompatible

Declaration

Source position: picasso96api.pas line 146

const P96MA_VideoCompatible = P96MA_Dummy + $0010;


P96MA_Window

Declaration

Source position: picasso96api.pas line 143

const P96MA_Window = P96MA_Dummy + $000d;


P96MA_WindowTitle

Declaration

Source position: picasso96api.pas line 140

const P96MA_WindowTitle = P96MA_Dummy + $000a;


P96PIP_Alignment

Declaration

Source position: picasso96api.pas line 251

const P96PIP_Alignment = P96PIP_Dummy + 20;


P96PIP_AllowCropping

Declaration

Source position: picasso96api.pas line 253

const P96PIP_AllowCropping = P96PIP_Dummy + 22;


P96PIP_Brightness

Declaration

Source position: picasso96api.pas line 239

const P96PIP_Brightness = P96PIP_Dummy + 8;


P96PIP_ClipHeight

Declaration

Source position: picasso96api.pas line 258

const P96PIP_ClipHeight = P96PIP_Dummy + 27;


P96PIP_ClipLeft

Declaration

Source position: picasso96api.pas line 255

const P96PIP_ClipLeft = P96PIP_Dummy + 24;


P96PIP_ClipTop

Declaration

Source position: picasso96api.pas line 256

const P96PIP_ClipTop = P96PIP_Dummy + 25;


P96PIP_ClipWidth

Declaration

Source position: picasso96api.pas line 257

const P96PIP_ClipWidth = P96PIP_Dummy + 26;


P96PIP_ColorKeyARGB

Declaration

Source position: picasso96api.pas line 265

const P96PIP_ColorKeyARGB = P96PIP_Dummy + 34;


P96PIP_ColorKeyPen

Declaration

Source position: picasso96api.pas line 260

const P96PIP_ColorKeyPen = P96PIP_Dummy + 29;


P96PIP_Colors

Declaration

Source position: picasso96api.pas line 245

const P96PIP_Colors = P96PIP_Dummy + 14;


P96PIP_Colors32

Declaration

Source position: picasso96api.pas line 246

const P96PIP_Colors32 = P96PIP_Dummy + 15;


P96PIP_ConstantBytesPerRow

Declaration

Source position: picasso96api.pas line 252

const P96PIP_ConstantBytesPerRow = P96PIP_Dummy + 21;


P96PIP_ConstantByteSwapping

Declaration

Source position: picasso96api.pas line 259

const P96PIP_ConstantByteSwapping = P96PIP_Dummy + 28;


P96PIP_DisplayedBuffer

Declaration

Source position: picasso96api.pas line 264

const P96PIP_DisplayedBuffer = P96PIP_Dummy + 33;


P96PIP_Dummy

Declaration

Source position: picasso96api.pas line 231

const P96PIP_Dummy = TAG_USER + $30000 + 96;


P96PIP_ErrorCode

Declaration

Source position: picasso96api.pas line 238

const P96PIP_ErrorCode = P96PIP_Dummy + 7;


P96PIP_Height

Declaration

Source position: picasso96api.pas line 243

const P96PIP_Height = P96PIP_Dummy + 12;


P96PIP_InitialIntScaling

Declaration

Source position: picasso96api.pas line 254

const P96PIP_InitialIntScaling = P96PIP_Dummy + 23;


P96PIP_Left

Declaration

Source position: picasso96api.pas line 240

const P96PIP_Left = P96PIP_Dummy + 9;


P96PIP_NoMemory

Declaration

Source position: picasso96api.pas line 247

const P96PIP_NoMemory = P96PIP_Dummy + 16;


P96PIP_NumberOfBuffers

Declaration

Source position: picasso96api.pas line 261

const P96PIP_NumberOfBuffers = P96PIP_Dummy + 30;


P96PIP_Relativity

Declaration

Source position: picasso96api.pas line 244

const P96PIP_Relativity = P96PIP_Dummy + 13;


P96PIP_RenderFunc

Declaration

Source position: picasso96api.pas line 248

const P96PIP_RenderFunc = P96PIP_Dummy + 17;


P96PIP_SaveFunc

Declaration

Source position: picasso96api.pas line 249

const P96PIP_SaveFunc = P96PIP_Dummy + 18;


P96PIP_SourceBitMap

Declaration

Source position: picasso96api.pas line 233

const P96PIP_SourceBitMap = P96PIP_Dummy + 2;


P96PIP_SourceFormat

Declaration

Source position: picasso96api.pas line 232

const P96PIP_SourceFormat = P96PIP_Dummy + 1;


P96PIP_SourceHeight

Declaration

Source position: picasso96api.pas line 236

const P96PIP_SourceHeight = P96PIP_Dummy + 5;


P96PIP_SourceRPort

Declaration

Source position: picasso96api.pas line 234

const P96PIP_SourceRPort = P96PIP_Dummy + 3;


P96PIP_SourceWidth

Declaration

Source position: picasso96api.pas line 235

const P96PIP_SourceWidth = P96PIP_Dummy + 4;


P96PIP_Top

Declaration

Source position: picasso96api.pas line 241

const P96PIP_Top = P96PIP_Dummy + 10;


P96PIP_Type

Declaration

Source position: picasso96api.pas line 237

const P96PIP_Type = P96PIP_Dummy + 6;


P96PIP_UserData

Declaration

Source position: picasso96api.pas line 250

const P96PIP_UserData = P96PIP_Dummy + 19;


P96PIP_VisibleBuffer

Declaration

Source position: picasso96api.pas line 262

const P96PIP_VisibleBuffer = P96PIP_Dummy + 31;


P96PIP_Width

Declaration

Source position: picasso96api.pas line 242

const P96PIP_Width = P96PIP_Dummy + 11;


P96PIP_WorkBuffer

Declaration

Source position: picasso96api.pas line 263

const P96PIP_WorkBuffer = P96PIP_Dummy + 32;


P96PIPT_MemoryWindow

Declaration

Source position: picasso96api.pas line 271

const P96PIPT_MemoryWindow = PIPT_MemoryWindow;


P96PIPT_VideoWindow

Declaration

Source position: picasso96api.pas line 272

const P96PIPT_VideoWindow = PIPT_VideoWindow;


P96RD_Dummy

Declaration

Source position: picasso96api.pas line 287

const P96RD_Dummy = TAG_USER + $40000 + 96;


P96RD_NumberOfBoards

Declaration

Source position: picasso96api.pas line 288

const P96RD_NumberOfBoards = P96RD_Dummy + 1;


P96SA_Alignment

Declaration

Source position: picasso96api.pas line 185

const P96SA_Alignment = P96SA_Dummy + $0023;


P96SA_AutoScroll

Declaration

Source position: picasso96api.pas line 173

const P96SA_AutoScroll = P96SA_Dummy + $0017;


P96SA_BackFill

Declaration

Source position: picasso96api.pas line 176

const P96SA_BackFill = P96SA_Dummy + $001a;


P96SA_Behind

Declaration

Source position: picasso96api.pas line 171

const P96SA_Behind = P96SA_Dummy + $0015;


P96SA_BitMap

Declaration

Source position: picasso96api.pas line 164

const P96SA_BitMap = P96SA_Dummy + $000e;


P96SA_BlockPen

Declaration

Source position: picasso96api.pas line 157

const P96SA_BlockPen = P96SA_Dummy + $0007;


P96SA_Colors

Declaration

Source position: picasso96api.pas line 159

const P96SA_Colors = P96SA_Dummy + $0009;


P96SA_Colors32

Declaration

Source position: picasso96api.pas line 177

const P96SA_Colors32 = P96SA_Dummy + $001b;


P96SA_ConstantBytesPerRow

Declaration

Source position: picasso96api.pas line 188

const P96SA_ConstantBytesPerRow = P96SA_Dummy + $0026;


P96SA_ConstantByteSwapping

Declaration

Source position: picasso96api.pas line 189

const P96SA_ConstantByteSwapping = P96SA_Dummy + $0027;


P96SA_DClip

Declaration

Source position: picasso96api.pas line 169

const P96SA_DClip = P96SA_Dummy + $0013;


P96SA_Depth

Declaration

Source position: picasso96api.pas line 155

const P96SA_Depth = P96SA_Dummy + $0005;


P96SA_DetailPen

Declaration

Source position: picasso96api.pas line 156

const P96SA_DetailPen = P96SA_Dummy + $0006;


P96SA_DisplayID

Declaration

Source position: picasso96api.pas line 168

const P96SA_DisplayID = P96SA_Dummy + $0012;


P96SA_Dummy

Declaration

Source position: picasso96api.pas line 150

const P96SA_Dummy = TAG_USER + $20000 + 96;


P96SA_ErrorCode

Declaration

Source position: picasso96api.pas line 160

const P96SA_ErrorCode = P96SA_Dummy + $000a;


P96SA_Exclusive

Declaration

Source position: picasso96api.pas line 187

const P96SA_Exclusive = P96SA_Dummy + $0025;


P96SA_FixedScreen

Declaration

Source position: picasso96api.pas line 186

const P96SA_FixedScreen = P96SA_Dummy + $0024;


P96SA_Font

Declaration

Source position: picasso96api.pas line 161

const P96SA_Font = P96SA_Dummy + $000b;


P96SA_Height

Declaration

Source position: picasso96api.pas line 154

const P96SA_Height = P96SA_Dummy + $0004;


P96SA_Left

Declaration

Source position: picasso96api.pas line 151

const P96SA_Left = P96SA_Dummy + $0001;


P96SA_NoMemory

Declaration

Source position: picasso96api.pas line 181

const P96SA_NoMemory = P96SA_Dummy + $001f;


P96SA_NoSprite

Declaration

Source position: picasso96api.pas line 180

const P96SA_NoSprite = P96SA_Dummy + $001e;


P96SA_Pens

Declaration

Source position: picasso96api.pas line 174

const P96SA_Pens = P96SA_Dummy + $0018;


P96SA_PubName

Declaration

Source position: picasso96api.pas line 165

const P96SA_PubName = P96SA_Dummy + $000f;


P96SA_PubSig

Declaration

Source position: picasso96api.pas line 166

const P96SA_PubSig = P96SA_Dummy + $0010;


P96SA_PubTask

Declaration

Source position: picasso96api.pas line 167

const P96SA_PubTask = P96SA_Dummy + $0011;


P96SA_Quiet

Declaration

Source position: picasso96api.pas line 172

const P96SA_Quiet = P96SA_Dummy + $0016;


P96SA_RenderFunc

Declaration

Source position: picasso96api.pas line 182

const P96SA_RenderFunc = P96SA_Dummy + $0020;


P96SA_RGBFormat

Declaration

Source position: picasso96api.pas line 179

const P96SA_RGBFormat = P96SA_Dummy + $001d;


P96SA_SaveFunc

Declaration

Source position: picasso96api.pas line 183

const P96SA_SaveFunc = P96SA_Dummy + $0021;


P96SA_SharePens

Declaration

Source position: picasso96api.pas line 175

const P96SA_SharePens = P96SA_Dummy + $0019;


P96SA_ShowTitle

Declaration

Source position: picasso96api.pas line 170

const P96SA_ShowTitle = P96SA_Dummy + $0014;


P96SA_SysFont

Declaration

Source position: picasso96api.pas line 162

const P96SA_SysFont = P96SA_Dummy + $000c;


P96SA_Title

Declaration

Source position: picasso96api.pas line 158

const P96SA_Title = P96SA_Dummy + $0008;


P96SA_Top

Declaration

Source position: picasso96api.pas line 152

const P96SA_Top = P96SA_Dummy + $0002;


P96SA_Type

Declaration

Source position: picasso96api.pas line 163

const P96SA_Type = P96SA_Dummy + $000d;


P96SA_UserData

Declaration

Source position: picasso96api.pas line 184

const P96SA_UserData = P96SA_Dummy + $0022;


P96SA_VideoControl

Declaration

Source position: picasso96api.pas line 178

const P96SA_VideoControl = P96SA_Dummy + $001c;


P96SA_Width

Declaration

Source position: picasso96api.pas line 153

const P96SA_Width = P96SA_Dummy + $0003;


PICASSO96APINAME

Declaration

Source position: picasso96api.pas line 26

const PICASSO96APINAME: PChar = 'Picasso96API.library';


PIPERR_ATTACHFAIL

Declaration

Source position: picasso96api.pas line 279

const PIPERR_ATTACHFAIL = 2;


PIPERR_BADALIGNMENT

Declaration

Source position: picasso96api.pas line 284

const PIPERR_BADALIGNMENT = 7;


PIPERR_BADDIMENSIONS

Declaration

Source position: picasso96api.pas line 282

const PIPERR_BADDIMENSIONS = 5;


PIPERR_CROPPED

Declaration

Source position: picasso96api.pas line 285

const PIPERR_CROPPED = 8;


PIPERR_NOMEMORY

Declaration

Source position: picasso96api.pas line 278

const PIPERR_NOMEMORY = 1;


PIPERR_NOTAVAILABLE

Declaration

Source position: picasso96api.pas line 280

const PIPERR_NOTAVAILABLE = 3;


PIPERR_NOWINDOW

Declaration

Source position: picasso96api.pas line 283

const PIPERR_NOWINDOW = 6;


PIPERR_OUTOFPENS

Declaration

Source position: picasso96api.pas line 281

const PIPERR_OUTOFPENS = 4;


PIPRel_Bottom

Declaration

Source position: picasso96api.pas line 275

const PIPRel_Bottom = 2;


PIPRel_Height

Declaration

Source position: picasso96api.pas line 277

const PIPRel_Height = 8;


PIPRel_Right

Declaration

Source position: picasso96api.pas line 274

const PIPRel_Right = 1;


PIPRel_Width

Declaration

Source position: picasso96api.pas line 276

const PIPRel_Width = 4;


PIPT_MemoryWindow

Declaration

Source position: picasso96api.pas line 267

const PIPT_MemoryWindow = 0;


PIPT_NUMTYPES

Declaration

Source position: picasso96api.pas line 269

const PIPT_NUMTYPES = 2;


PIPT_VideoWindow

Declaration

Source position: picasso96api.pas line 268

const PIPT_VideoWindow = 1;


PP96Mode

Declaration

Source position: picasso96api.pas line 193

type PP96Mode = ^TP96Mode;


PRenderInfo

Declaration

Source position: picasso96api.pas line 203

type PRenderInfo = ^TRenderInfo;


PTrueColorInfo

Declaration

Source position: picasso96api.pas line 219

type PTrueColorInfo = ^TTrueColorInfo;


PYUVRenderInfo

Declaration

Source position: picasso96api.pas line 211

type PYUVRenderInfo = ^TYUVRenderInfo;


RGBFF_A8B8G8R8

Declaration

Source position: picasso96api.pas line 64

const RGBFF_A8B8G8R8 = 1 shl 7;


RGBFF_A8R8G8B8

Declaration

Source position: picasso96api.pas line 63

const RGBFF_A8R8G8B8 = 1 shl 6;


RGBFF_ALPHA8

Declaration

Source position: picasso96api.pas line 78

const RGBFF_ALPHA8 = 1 shl 21;


RGBFF_B5G5R5PC

Declaration

Source position: picasso96api.pas line 70

const RGBFF_B5G5R5PC = 1 shl 13;


RGBFF_B5G6R5PC

Declaration

Source position: picasso96api.pas line 69

const RGBFF_B5G6R5PC = 1 shl 12;


RGBFF_B8G8R8

Declaration

Source position: picasso96api.pas line 60

const RGBFF_B8G8R8 = 1 shl 3;


RGBFF_B8G8R8A8

Declaration

Source position: picasso96api.pas line 66

const RGBFF_B8G8R8A8 = 1 shl 9;


RGBFF_CLUT

Declaration

Source position: picasso96api.pas line 58

const RGBFF_CLUT = 1 shl 1;


RGBFF_HICOLOR

Declaration

Source position: picasso96api.pas line 80

const RGBFF_HICOLOR = RGBFF_R5G6B5PC or RGBFF_R5G5B5PC or RGBFF_R5G6B5 or RGBFF_R5G5B5 or RGBFF_B5G6R5PC or RGBFF_B5G5R5PC;


RGBFF_NONE

Declaration

Source position: picasso96api.pas line 57

const RGBFF_NONE = 1 shl 0;


RGBFF_R5G5B5

Declaration

Source position: picasso96api.pas line 68

const RGBFF_R5G5B5 = 1 shl 11;


RGBFF_R5G5B5PC

Declaration

Source position: picasso96api.pas line 62

const RGBFF_R5G5B5PC = 1 shl 5;


RGBFF_R5G6B5

Declaration

Source position: picasso96api.pas line 67

const RGBFF_R5G6B5 = 1 shl 10;


RGBFF_R5G6B5PC

Declaration

Source position: picasso96api.pas line 61

const RGBFF_R5G6B5PC = 1 shl 4;


RGBFF_R8G8B8

Declaration

Source position: picasso96api.pas line 59

const RGBFF_R8G8B8 = 1 shl 2;


RGBFF_R8G8B8A8

Declaration

Source position: picasso96api.pas line 65

const RGBFF_R8G8B8A8 = 1 shl 8;


RGBFF_TRUEALPHA

Declaration

Source position: picasso96api.pas line 82

const RGBFF_TRUEALPHA = RGBFF_A8R8G8B8 or RGBFF_A8B8G8R8 or RGBFF_R8G8B8A8 or RGBFF_B8G8R8A8;


RGBFF_TRUECOLOR

Declaration

Source position: picasso96api.pas line 81

const RGBFF_TRUECOLOR = RGBFF_R8G8B8 or RGBFF_B8G8R8;


RGBFF_YUV410P

Declaration

Source position: picasso96api.pas line 77

const RGBFF_YUV410P = 1 shl 20;


RGBFF_YUV411

Declaration

Source position: picasso96api.pas line 72

const RGBFF_YUV411 = 1 shl 15;


RGBFF_YUV420P

Declaration

Source position: picasso96api.pas line 76

const RGBFF_YUV420P = 1 shl 19;


RGBFF_YUV422

Declaration

Source position: picasso96api.pas line 73

const RGBFF_YUV422 = 1 shl 16;


RGBFF_YUV422CGX

Declaration

Source position: picasso96api.pas line 71

const RGBFF_YUV422CGX = 1 shl 14;


RGBFF_YUV422PA

Declaration

Source position: picasso96api.pas line 75

const RGBFF_YUV422PA = 1 shl 18;


RGBFF_YUV422PC

Declaration

Source position: picasso96api.pas line 74

const RGBFF_YUV422PC = 1 shl 17;


TP96Mode

Declaration

Source position: picasso96api.pas line 194

type TP96Mode = record

  Node: TNode;

  Description: array [0..MODENAMELENGTH-1] of Char;

  Width: Word;

  Height: Word;

  Depth: Word;

  DisplayID: LongWord;

end;


TRenderInfo

Declaration

Source position: picasso96api.pas line 204

type TRenderInfo = record

  Memory: Pointer;

  BytesPerRow: Word;

  pad: Word;

  RGBFormat: TRGBFTYPE;

end;


TRGBFTYPE

Declaration

Source position: picasso96api.pas line 30

type TRGBFTYPE = (

  RGBFB_NONE,

  RGBFB_CLUT,

  RGBFB_R8G8B8,

  RGBFB_B8G8R8,

  RGBFB_R5G6B5PC,

  RGBFB_R5G5B5PC,

  RGBFB_A8R8G8B8,

  RGBFB_A8B8G8R8,

  RGBFB_R8G8B8A8,

  RGBFB_B8G8R8A8,

  RGBFB_R5G6B5,

  RGBFB_R5G5B5,

  RGBFB_B5G6R5PC,

  RGBFB_B5G5R5PC,

  RGBFB_YUV422CGX,

  RGBFB_YUV411,

  RGBFB_YUV422PA,

  RGBFB_YUV422,

  RGBFB_YUV422PC,

  RGBFB_YUV420P,

  RGBFB_YUV410P,

  RGBFB_ALPHA8,

  RGBFB_MaxFormats

);


TTrueColorInfo

Declaration

Source position: picasso96api.pas line 220

type TTrueColorInfo = record

  PixelDistance: LongWord;

  BytesPerRow: LongWord;

  RedData: PByte;

  GreenData: PByte;

  BlueData: PByte;

end;


TYUVRenderInfo

Declaration

Source position: picasso96api.pas line 212

type TYUVRenderInfo = record

  RI: TRenderInfo;

  Planes: array [0..2] of Pointer;

  BytesPerRow: array [0..2] of Word;

  padWord: Word;

end;


Reference for unit 'serial'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'serial': Constants

IOSERB_ABORT

IOSERB_ACTIVE

IOSERB_BUFRREAD

IOSERB_QUEUED

IOSERF_ABORT

IOSERF_ACTIVE

IOSERF_BUFRREAD

IOSERF_QUEUED

IOSTB_OVERRUN

IOSTB_READBREAK

IOSTB_WROTEBREAK

IOSTB_XOFFREAD

IOSTB_XOFFWRITE

IOSTF_OVERRUN

IOSTF_READBREAK

IOSTF_WROTEBREAK

IOSTF_XOFFREAD

IOSTF_XOFFWRITE

IO_STATB_OVERRUN

IO_STATB_READBREAK

IO_STATB_WROTEBREAK

IO_STATB_XOFFREAD

IO_STATB_XOFFWRITE

IO_STATF_OVERRUN

IO_STATF_READBREAK

IO_STATF_WROTEBREAK

IO_STATF_XOFFREAD

IO_STATF_XOFFWRITE

SDCMD_BREAK

SDCMD_QUERY

SDCMD_SETPARAMS

SERB_7WIRE

SERB_EOFMODE

SERB_PARTY_ODD

SERB_PARTY_ON

SERB_QUEUEDBRK

SERB_RAD_BOOGIE

SERB_SHARED

SERB_XDISABLED

SerErr_BaudMismatch

SerErr_BufErr

SerErr_BufOverflow

SerErr_DetectedBreak

SerErr_DevBusy

SerErr_InvParam

SerErr_LineErr

SerErr_NoDSR

SerErr_ParityErr

SerErr_TimerErr

SERF_7WIRE

SERF_EOFMODE

SERF_PARTY_ODD

SERF_PARTY_ON

SERF_QUEUEDBRK

SERF_RAD_BOOGIE

SERF_SHARED

SERF_XDISABLED

SERIALNAME

SER_DEFAULT_CTLCHAR

SEXTB_MARK

SEXTB_MSPON

SEXTF_MARK

SEXTF_MSPON


Reference for unit 'serial': Types

PIOExtSer

PIOTArray

TIOExtSer

TIOTArray


Index of all identifiers in unit 'serial'

I P S T

I

IOSERB_ABORT | IO_STATB_WROTEBREAK | IOSTB_WROTEBREAK
IOSERB_ACTIVE | IO_STATB_XOFFREAD | IOSTB_XOFFREAD
IOSERB_BUFRREAD | IO_STATB_XOFFWRITE | IOSTB_XOFFWRITE
IOSERB_QUEUED | IO_STATF_OVERRUN | IOSTF_OVERRUN
IOSERF_ABORT | IO_STATF_READBREAK | IOSTF_READBREAK
IOSERF_ACTIVE | IO_STATF_WROTEBREAK | IOSTF_WROTEBREAK
IOSERF_BUFRREAD | IO_STATF_XOFFREAD | IOSTF_XOFFREAD
IOSERF_QUEUED | IO_STATF_XOFFWRITE | IOSTF_XOFFWRITE
IO_STATB_OVERRUN | IOSTB_OVERRUN |
IO_STATB_READBREAK | IOSTB_READBREAK |

P

PIOExtSer PIOTArray

S

SDCMD_BREAK | SerErr_BaudMismatch | SERF_PARTY_ODD
SDCMD_QUERY | SerErr_BufErr | SERF_PARTY_ON
SDCMD_SETPARAMS | SerErr_BufOverflow | SERF_QUEUEDBRK
SERB_7WIRE | SerErr_DetectedBreak | SERF_RAD_BOOGIE
SERB_EOFMODE | SerErr_DevBusy | SERF_SHARED
SERB_PARTY_ODD | SerErr_InvParam | SERF_XDISABLED
SERB_PARTY_ON | SerErr_LineErr | SERIALNAME
SERB_QUEUEDBRK | SerErr_NoDSR | SEXTB_MARK
SERB_RAD_BOOGIE | SerErr_ParityErr | SEXTB_MSPON
SERB_SHARED | SerErr_TimerErr | SEXTF_MARK
SERB_XDISABLED | SERF_7WIRE | SEXTF_MSPON
SER_DEFAULT_CTLCHAR | SERF_EOFMODE |

T

TIOExtSer TIOTArray


IO_STATB_OVERRUN

Declaration

Source position: serial.pas line 115

const IO_STATB_OVERRUN = 8;


IO_STATB_READBREAK

Declaration

Source position: serial.pas line 111

const IO_STATB_READBREAK = 10;


IO_STATB_WROTEBREAK

Declaration

Source position: serial.pas line 113

const IO_STATB_WROTEBREAK = 9;


IO_STATB_XOFFREAD

Declaration

Source position: serial.pas line 107

const IO_STATB_XOFFREAD = 12;


IO_STATB_XOFFWRITE

Declaration

Source position: serial.pas line 109

const IO_STATB_XOFFWRITE = 11;


IO_STATF_OVERRUN

Declaration

Source position: serial.pas line 116

const IO_STATF_OVERRUN = 1 shl IO_STATB_OVERRUN;


IO_STATF_READBREAK

Declaration

Source position: serial.pas line 112

const IO_STATF_READBREAK = 1 shl IO_STATB_READBREAK;


IO_STATF_WROTEBREAK

Declaration

Source position: serial.pas line 114

const IO_STATF_WROTEBREAK = 1 shl IO_STATB_WROTEBREAK;


IO_STATF_XOFFREAD

Declaration

Source position: serial.pas line 108

const IO_STATF_XOFFREAD = 1 shl IO_STATB_XOFFREAD;


IO_STATF_XOFFWRITE

Declaration

Source position: serial.pas line 110

const IO_STATF_XOFFWRITE = 1 shl IO_STATB_XOFFWRITE;


IOSERB_ABORT

Declaration

Source position: serial.pas line 154

const IOSERB_ABORT = 5;


IOSERB_ACTIVE

Declaration

Source position: serial.pas line 156

const IOSERB_ACTIVE = 4;


IOSERB_BUFRREAD

Declaration

Source position: serial.pas line 150

const IOSERB_BUFRREAD = 7;


IOSERB_QUEUED

Declaration

Source position: serial.pas line 152

const IOSERB_QUEUED = 6;


IOSERF_ABORT

Declaration

Source position: serial.pas line 155

const IOSERF_ABORT = 1 shl IOSERB_ABORT;


IOSERF_ACTIVE

Declaration

Source position: serial.pas line 157

const IOSERF_ACTIVE = 1 shl IOSERB_ACTIVE;


IOSERF_BUFRREAD

Declaration

Source position: serial.pas line 151

const IOSERF_BUFRREAD = 1 shl IOSERB_BUFRREAD;


IOSERF_QUEUED

Declaration

Source position: serial.pas line 153

const IOSERF_QUEUED = 1 shl IOSERB_QUEUED;


IOSTB_OVERRUN

Declaration

Source position: serial.pas line 146

const IOSTB_OVERRUN = 0;


IOSTB_READBREAK

Declaration

Source position: serial.pas line 142

const IOSTB_READBREAK = 2;


IOSTB_WROTEBREAK

Declaration

Source position: serial.pas line 144

const IOSTB_WROTEBREAK = 1;


IOSTB_XOFFREAD

Declaration

Source position: serial.pas line 138

const IOSTB_XOFFREAD = 4;


IOSTB_XOFFWRITE

Declaration

Source position: serial.pas line 140

const IOSTB_XOFFWRITE = 3;


IOSTF_OVERRUN

Declaration

Source position: serial.pas line 147

const IOSTF_OVERRUN = 1 shl IOSTB_OVERRUN;


IOSTF_READBREAK

Declaration

Source position: serial.pas line 143

const IOSTF_READBREAK = 1 shl IOSTB_READBREAK;


IOSTF_WROTEBREAK

Declaration

Source position: serial.pas line 145

const IOSTF_WROTEBREAK = 1 shl IOSTB_WROTEBREAK;


IOSTF_XOFFREAD

Declaration

Source position: serial.pas line 139

const IOSTF_XOFFREAD = 1 shl IOSTB_XOFFREAD;


IOSTF_XOFFWRITE

Declaration

Source position: serial.pas line 141

const IOSTF_XOFFWRITE = 1 shl IOSTB_XOFFWRITE;


PIOExtSer

Declaration

Source position: serial.pas line 61

type PIOExtSer = ^TIOExtSer;


PIOTArray

Declaration

Source position: serial.pas line 28

type PIOTArray = ^TIOTArray;


SDCMD_BREAK

Declaration

Source position: serial.pas line 85

const SDCMD_BREAK = CMD_NONSTD + 1;


SDCMD_QUERY

Declaration

Source position: serial.pas line 84

const SDCMD_QUERY = CMD_NONSTD;


SDCMD_SETPARAMS

Declaration

Source position: serial.pas line 86

const SDCMD_SETPARAMS = CMD_NONSTD + 2;


SER_DEFAULT_CTLCHAR

Declaration

Source position: serial.pas line 35

const SER_DEFAULT_CTLCHAR = $11130000;


SERB_7WIRE

Declaration

Source position: serial.pas line 99

const SERB_7WIRE = 2;


SERB_EOFMODE

Declaration

Source position: serial.pas line 91

const SERB_EOFMODE = 6;


SERB_PARTY_ODD

Declaration

Source position: serial.pas line 101

const SERB_PARTY_ODD = 1;


SERB_PARTY_ON

Declaration

Source position: serial.pas line 103

const SERB_PARTY_ON = 0;


SERB_QUEUEDBRK

Declaration

Source position: serial.pas line 97

const SERB_QUEUEDBRK = 3;


SERB_RAD_BOOGIE

Declaration

Source position: serial.pas line 95

const SERB_RAD_BOOGIE = 4;


SERB_SHARED

Declaration

Source position: serial.pas line 93

const SERB_SHARED = 5;


SERB_XDISABLED

Declaration

Source position: serial.pas line 89

const SERB_XDISABLED = 7;


SerErr_BaudMismatch

Declaration

Source position: serial.pas line 125

const SerErr_BaudMismatch = 2;


SerErr_BufErr

Declaration

Source position: serial.pas line 126

const SerErr_BufErr = 4;


SerErr_BufOverflow

Declaration

Source position: serial.pas line 131

const SerErr_BufOverflow = 12;


SerErr_DetectedBreak

Declaration

Source position: serial.pas line 133

const SerErr_DetectedBreak = 15;


SerErr_DevBusy

Declaration

Source position: serial.pas line 124

const SerErr_DevBusy = 1;


SerErr_InvParam

Declaration

Source position: serial.pas line 127

const SerErr_InvParam = 5;


SerErr_LineErr

Declaration

Source position: serial.pas line 128

const SerErr_LineErr = 6;


SerErr_NoDSR

Declaration

Source position: serial.pas line 132

const SerErr_NoDSR = 13;


SerErr_ParityErr

Declaration

Source position: serial.pas line 129

const SerErr_ParityErr = 9;


SerErr_TimerErr

Declaration

Source position: serial.pas line 130

const SerErr_TimerErr = 11;


SERF_7WIRE

Declaration

Source position: serial.pas line 100

const SERF_7WIRE = 1 shl SERB_7WIRE;


SERF_EOFMODE

Declaration

Source position: serial.pas line 92

const SERF_EOFMODE = 1 shl SERB_EOFMODE;


SERF_PARTY_ODD

Declaration

Source position: serial.pas line 102

const SERF_PARTY_ODD = 1 shl SERB_PARTY_ODD;


SERF_PARTY_ON

Declaration

Source position: serial.pas line 104

const SERF_PARTY_ON = 1 shl SERB_PARTY_ON;


SERF_QUEUEDBRK

Declaration

Source position: serial.pas line 98

const SERF_QUEUEDBRK = 1 shl SERB_QUEUEDBRK;


SERF_RAD_BOOGIE

Declaration

Source position: serial.pas line 96

const SERF_RAD_BOOGIE = 1 shl SERB_RAD_BOOGIE;


SERF_SHARED

Declaration

Source position: serial.pas line 94

const SERF_SHARED = 1 shl SERB_SHARED;


SERF_XDISABLED

Declaration

Source position: serial.pas line 90

const SERF_XDISABLED = 1 shl SERB_XDISABLED;


SERIALNAME

Declaration

Source position: serial.pas line 159

const SERIALNAME: PChar = 'serial.device';


SEXTB_MARK

Declaration

Source position: serial.pas line 121

const SEXTB_MARK = 0;


SEXTB_MSPON

Declaration

Source position: serial.pas line 119

const SEXTB_MSPON = 1;


SEXTF_MARK

Declaration

Source position: serial.pas line 122

const SEXTF_MARK = 1 shl SEXTB_MARK;


SEXTF_MSPON

Declaration

Source position: serial.pas line 120

const SEXTF_MSPON = 1 shl SEXTB_MSPON;


TIOExtSer

Declaration

Source position: serial.pas line 47

type TIOExtSer = record

  IOSer: TIOStdReq;

  io_CtlChar: LongWord;

  io_RBufLen: LongWord;

  io_ExtFlags: LongWord;

  io_Baud: LongWord;

  io_BrkTime: LongWord;

  io_TermArray: TIOTArray;

  io_ReadLen: Byte;

  io_WriteLen: Byte;

  io_StopBits: Byte;

  io_SerFlags: Byte;

  io_Status: Word;

end;


TIOTArray

Declaration

Source position: serial.pas line 29

type TIOTArray = record

  TermArray0: LongWord;

  TermArray1: LongWord;

end;


Reference for unit 'timer'

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'timer': Constants

TIMERNAME

TR_ADDREQUEST

TR_GETSYSTIME

TR_SETSYSTIME

UNIT_ECLOCK

UNIT_ENTROPY

UNIT_MICROHZ

UNIT_VBLANK

UNIT_WAITECLOCK

UNIT_WAITUNTIL


Reference for unit 'timer': Types

PEClockVal

PTimeRequest

PTimeVal

TEClockVal

TTimeRequest

TTimeVal


ITimer

Declaration

Source position: timer.pas line 70

var ITimer: Pointer = Nil;


PEClockVal

Declaration

Source position: timer.pas line 49

type PEClockVal = ^TEClockVal;


PTimeRequest

Declaration

Source position: timer.pas line 43

type PTimeRequest = ^TTimeRequest;


PTimeVal

Declaration

Source position: timer.pas line 37

type PTimeVal = ^TTimeVal;


TEClockVal

Declaration

Source position: timer.pas line 50

type TEClockVal = record

  ev_hi: LongWord;

  ev_lo: LongWord;

end;


TimerBase

Declaration

Source position: timer.pas line 69

var TimerBase: Pointer = Nil;


TIMERNAME

Declaration

Source position: timer.pas line 34

const TIMERNAME: PChar = 'timer.device';


TR_ADDREQUEST

Declaration

Source position: timer.pas line 57

const TR_ADDREQUEST = CMD_NONSTD;


TR_GETSYSTIME

Declaration

Source position: timer.pas line 58

const TR_GETSYSTIME = CMD_NONSTD + 1;


TR_SETSYSTIME

Declaration

Source position: timer.pas line 59

const TR_SETSYSTIME = CMD_NONSTD + 2;


TTimeRequest

Declaration

Source position: timer.pas line 44

type TTimeRequest = record

  tr_node: TIORequest;

  tr_time: TTimeVal;

end;


TTimeVal

Declaration

Source position: timer.pas line 38

type TTimeVal = record

  tv_secs: LongWord;

  tv_micro: LongWord;

end;


UNIT_ECLOCK

Declaration

Source position: timer.pas line 29

const UNIT_ECLOCK = 2;


UNIT_ENTROPY

Declaration

Source position: timer.pas line 32

const UNIT_ENTROPY = 5;


UNIT_MICROHZ

Declaration

Source position: timer.pas line 27

const UNIT_MICROHZ = 0;


UNIT_VBLANK

Declaration

Source position: timer.pas line 28

const UNIT_VBLANK = 1;


UNIT_WAITECLOCK

Declaration

Source position: timer.pas line 31

const UNIT_WAITECLOCK = 4;


UNIT_WAITUNTIL

Declaration

Source position: timer.pas line 30

const UNIT_WAITUNTIL = 3;


ANO_Flags

Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)

Declaration

Source position: utility.pas line 55

const ANO_Flags = 4003;

Description

This allows you to initialize the value of the NameSpace flags which control certain aspects of the NameSpace.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


ANO_NameSpace

Tag for AllocNamedObjectA(). Tag to define namespace

Declaration

Source position: utility.pas line 52

const ANO_NameSpace = 4000;

Description

Allocate a NameSpace for this NamedObject. This will allow you to link other NamedObjects into a group. You cannot add a NamedObject with a NameSpace to another NameSpace. Boolean, default is False.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


ANO_Priority

Tag for AllocNamedObjectA(). Tag to define priority

Declaration

Source position: utility.pas line 54

const ANO_Priority = 4002;

Description

This is the List priority of the NamedObject and should be a ShortInt value between -128 and 127. This is taken into account in adding and finding NamedObjects, as the highest priority NamedObject will be returned first. The default value is 0.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


ANO_UserSpace

Tag for AllocNamedObjectA(). Taf to define userspace

Declaration

Source position: utility.pas line 53

const ANO_UserSpace = 4001;

Description

This tag says that you want extra memory allocated for a UserSpace. The ti_Data field of this TagItem contains the amount of memory to allocate. Specifying this Tag with a ti_Data of 0, is equivalent to the default, which is no UserSpace. The UserSpace address can be found in the no_Object field of the NamedObject structure.

See also

AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


Reference for unit 'utility'

Tag Handling, Date routines in utility.library

uses

  System,

  exec;

This unit contains the types and wrapper functions for the exec.library.


Reference for unit 'utility': Constants

ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)
ANO_NameSpace | Tag for AllocNamedObjectA(). Tag to define namespace
ANO_Priority | Tag for AllocNamedObjectA(). Tag to define priority
ANO_UserSpace | Tag for AllocNamedObjectA(). Taf to define userspace
INSERTNODE_DUPLICATE_KEY
INSERTNODE_OUT_OF_MEMORY
INSERTNODE_TOO_SHORT
MAP_KEEP_NOT_FOUND | Mapping types for use with MapTags() keep tags that aren't in mapList
MAP_REMOVE_NOT_FOUND | Mapping types for use with MapTags() remove tags that aren't in mapList
NSB_CASE | Flag bit for ANO_Flags Default to caseless
NSB_NODUPS | Flag bit for ANO_Flags Default allow duplicates
NSF_CASE | Flag value for ANO_Flags Default to caseless
NSF_NODUPS | Flag value for ANO_Flags Default allow duplicates
PKCTRL_BIT |
PKCTRL_BYTE |
PKCTRL_FLIPBIT |
PKCTRL_LONG |
PKCTRL_PACKONLY |
PKCTRL_PACKUNPACK |
PKCTRL_UBYTE |
PKCTRL_ULONG |
PKCTRL_UNPACKONLY |
PKCTRL_UWORD |
PKCTRL_WORD |
PSTB_EXISTS | Control bit for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack
PSTB_PACK | Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...
PSTB_SIGNED | Control bit for PackStructureTags/UnpackStructureTags.
PSTB_UNPACK | Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...
PSTF_EXISTS | Control value for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack
PSTF_PACK | Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...
PSTF_SIGNED | Control value for PackStructureTags/UnpackStructureTags.
PSTF_UNPACK | Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...
TAGFILTER_AND | Tag filter logic specifiers for use with FilterTagItems() exclude everything but filter hits
TAGFILTER_NOT | Tag filter logic specifiers for use with FilterTagItems() exclude only filter hits
TAG_DONE | Tag terminate the array of TagItems.ti_Data unused
TAG_END | Tag terminate the array of TagItems.ti_Data unused
TAG_IGNORE | Ignore this item, not end of array
TAG_MORE | ti_Data is pointer to another array of TagItems note that this tag terminates the current array
TAG_SKIP | Skip this and the next ti_Data items
TAG_USER |
UTF_INVALID_SUBST_FFFD


Reference for unit 'utility': Types

PClockData | Pointer to timing informations
PMessageDigest_SHA
PNamedObject | Pointer to named object structure
PRandomState
PSkipList
PSkipNode
PSplayNode
PSplayTree
PUtilityBase | Pointer to utility libbase
TClockData | Structure to hold timing informations
TMessageDigest_SHA
TNamedObject | Named object structure
TRandomState
TSkipList
TSkipNode
TSplayNode
TSplayTree
TUtilityBase | Utility libbase


INSERTNODE_DUPLICATE_KEY

Declaration

Source position: utility.pas line 220

const INSERTNODE_DUPLICATE_KEY = 2;


INSERTNODE_OUT_OF_MEMORY

Declaration

Source position: utility.pas line 219

const INSERTNODE_OUT_OF_MEMORY = 1;


INSERTNODE_TOO_SHORT

Declaration

Source position: utility.pas line 221

const INSERTNODE_TOO_SHORT = 3;


MAP_KEEP_NOT_FOUND

Mapping types for use with MapTags() keep tags that aren't in mapList

Declaration

Source position: utility.pas line 171

const MAP_KEEP_NOT_FOUND = 1;


MAP_REMOVE_NOT_FOUND

Mapping types for use with MapTags() remove tags that aren't in mapList

Declaration

Source position: utility.pas line 170

const MAP_REMOVE_NOT_FOUND = 0;


NSB_CASE

Flag bit for ANO_Flags Default to caseless

Declaration

Source position: utility.pas line 60

const NSB_CASE = 1;

See also

NSF_CASE

Flag value for ANO_Flags Default to caseless


NSB_NODUPS

Flag bit for ANO_Flags Default allow duplicates

Declaration

Source position: utility.pas line 59

const NSB_NODUPS = 0;

See also

NSF_NODUPS

Flag value for ANO_Flags Default allow duplicates


NSF_CASE

Flag value for ANO_Flags Default to caseless

Declaration

Source position: utility.pas line 63

const NSF_CASE = 1 shl NSB_CASE;

See also

ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


NSF_NODUPS

Flag value for ANO_Flags Default allow duplicates

Declaration

Source position: utility.pas line 62

const NSF_NODUPS = 1 shl NSB_NODUPS;

See also

ANO_Flags | Tag for AllocNamedObjectA(). Tag to define flags (NSF_*)
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()


PClockData

Pointer to timing informations

Declaration

Source position: utility.pas line 27

type PClockData = ^TClockData;

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
Date2Amiga | Calculate seconds from 01-Jan-1978.
CheckDate | Checks a ClockData structure for legal date.


PKCTRL_BIT

Declaration

Source position: utility.pas line 135

const PKCTRL_BIT = $18000000;


PKCTRL_BYTE

Declaration

Source position: utility.pas line 127

const PKCTRL_BYTE = $80000000;


PKCTRL_FLIPBIT

Declaration

Source position: utility.pas line 136

const PKCTRL_FLIPBIT = $98000000;


PKCTRL_LONG

Declaration

Source position: utility.pas line 129

const PKCTRL_LONG = $90000000;


PKCTRL_PACKONLY

Declaration

Source position: utility.pas line 124

const PKCTRL_PACKONLY = $40000000;


PKCTRL_PACKUNPACK

Declaration

Source position: utility.pas line 123

const PKCTRL_PACKUNPACK = $00000000;


PKCTRL_UBYTE

Declaration

Source position: utility.pas line 131

const PKCTRL_UBYTE = $00000000;


PKCTRL_ULONG

Declaration

Source position: utility.pas line 133

const PKCTRL_ULONG = $10000000;


PKCTRL_UNPACKONLY

Declaration

Source position: utility.pas line 125

const PKCTRL_UNPACKONLY = $20000000;


PKCTRL_UWORD

Declaration

Source position: utility.pas line 132

const PKCTRL_UWORD = $08000000;


PKCTRL_WORD

Declaration

Source position: utility.pas line 128

const PKCTRL_WORD = $88000000;


PMessageDigest_SHA

Declaration

Source position: utility.pas line 228

type PMessageDigest_SHA = ^TMessageDigest_SHA;


PNamedObject

Pointer to named object structure

Declaration

Source position: utility.pas line 43

type PNamedObject = ^TNamedObject;

See also

AddNamedObject | Add a named object to the given namespace.
RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AttemptRemNamedObject | Attempt to remove a named object.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


PRandomState

Declaration

Source position: utility.pas line 234

type PRandomState = ^TRandomState;


PSkipList

Declaration

Source position: utility.pas line 192

type PSkipList = ^TSkipList;


PSkipNode

Declaration

Source position: utility.pas line 197

type PSkipNode = ^TSkipNode;


PSplayNode

Declaration

Source position: utility.pas line 210

type PSplayNode = ^TSplayNode;


PSplayTree

Declaration

Source position: utility.pas line 205

type PSplayTree = ^TSplayTree;


PSTB_EXISTS

Control bit for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack

Declaration

Source position: utility.pas line 112

const PSTB_EXISTS = 26;


PSTB_PACK

Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 111

const PSTB_PACK = 29;


PSTB_SIGNED

Control bit for PackStructureTags/UnpackStructureTags.

Declaration

Source position: utility.pas line 109

const PSTB_SIGNED = 31;


PSTB_UNPACK

Control bit for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 110

const PSTB_UNPACK = 30;


PSTF_EXISTS

Control value for PackStructureTags/UnpackStructureTags. Tag exists bit true flag hack

Declaration

Source position: utility.pas line 118

const PSTF_EXISTS = 1 shl PSTB_EXISTS;


PSTF_PACK

Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 116

const PSTF_PACK = 1 shl PSTB_PACK;


PSTF_SIGNED

Control value for PackStructureTags/UnpackStructureTags.

Declaration

Source position: utility.pas line 114

const PSTF_SIGNED = 1 shl PSTB_SIGNED;


PSTF_UNPACK

Control value for PackStructureTags/UnpackStructureTags. Note that these are active low...

Declaration

Source position: utility.pas line 115

const PSTF_UNPACK = 1 shl PSTB_UNPACK;


PUtilityBase

Pointer to utility libbase

Declaration

Source position: utility.pas line 174

type PUtilityBase = ^TUtilityBase;


TAGFILTER_AND

Tag filter logic specifiers for use with FilterTagItems() exclude everything but filter hits

Declaration

Source position: utility.pas line 165

const TAGFILTER_AND = 0;


TAGFILTER_NOT

Tag filter logic specifiers for use with FilterTagItems() exclude only filter hits

Declaration

Source position: utility.pas line 166

const TAGFILTER_NOT = 1;


TClockData

Structure to hold timing informations

Declaration

Source position: utility.pas line 28

type TClockData = record
sec: Word; | Seconds
min: Word; | Minutes
hour: Word; | Hour
mday: Word; | Day
month: Word; | Month
year: Word; | Year
wday: Word; | Weekday
end;

See also

Amiga2Date | Fill in a ClockData structure based on a system time stamp
Date2Amiga | Calculate seconds from 01-Jan-1978.
CheckDate | Checks a ClockData structure for legal date.


TMessageDigest_SHA

Declaration

Source position: utility.pas line 229

type TMessageDigest_SHA = record

  mdsha_Code: array [0..19] of Byte;

  mdsha_Reserved: array [0..327] of Byte;

end;


TNamedObject

Named object structure

Declaration

Source position: utility.pas line 44

type TNamedObject = record

  no_Object: Pointer;

Your pointer, for whatever you want

end;

See also

AddNamedObject | Add a named object to the given namespace.
RemNamedObject | Remove a named object.
AllocNamedObjectA | Allocate a named object.
AllocNamedObject | VarArgs Version for AllocNamedObjectA()
ReleaseNamedObject | Free a named object.
FreeNamedObject | Frees a name object.
AttemptRemNamedObject | Attempt to remove a named object.
FindNamedObject | Find the next object of a given name.
NamedObjectName | Return the name of the object.


TRandomState

Declaration

Source position: utility.pas line 235

type TRandomState = record

  rs_High: LongInt;

  rs_Low: LongInt;

end;


TSkipList

Declaration

Source position: utility.pas line 193

type TSkipList = record

  sl_Error: LongInt;

end;


TSkipNode

Declaration

Source position: utility.pas line 198

type TSkipNode = record

  sn_Reserved: Pointer;

  sn_Key: Pointer;

end;


TSplayNode

Declaration

Source position: utility.pas line 211

type TSplayNode = record

  sn_UserData: Pointer;

end;


TSplayTree

Declaration

Source position: utility.pas line 206

type TSplayTree = record

  st_Error: LongInt;

end;


TUtilityBase

Utility libbase

Declaration

Source position: utility.pas line 175

type TUtilityBase = record
ub_LibNode: TLibrary; | Standard libbase
ub_Language: Byte; | Language identifier
ub_Reserved: Byte; | Reserverd
end;


UTF_INVALID_SUBST_FFFD

Declaration

Source position: utility.pas line 184

const UTF_INVALID_SUBST_FFFD = 1 shl 0;


UtilityBase

Declaration

Source position: utility.pas line 241

var UtilityBase: PUtilityBase;


ADZMACTION_Enter

Action for adzm_Action, Something entered the AppItem

Declaration

Source position: workbench.pas line 217

const ADZMACTION_Enter = 0;


ADZMACTION_Leave

Action for adzm_Action, Something left the AppItem

Declaration

Source position: workbench.pas line 218

const ADZMACTION_Leave = 1;


AM_VERSION

If you find TAppMessage.am_Version >= AM_VERSION, you know this structure has at least the fields defined in this version of the include file

Declaration

Source position: workbench.pas line 167

const AM_VERSION = 1;


AMCLASSICON_Copy

Class for TAppMessage.am_Class. The "Copy" menu item was invoked

Declaration

Source position: workbench.pas line 177

const AMCLASSICON_Copy = 1;


AMCLASSICON_Delete

Class for TAppMessage.am_Class. The "Delete" menu item was invoked

Declaration

Source position: workbench.pas line 184

const AMCLASSICON_Delete = 8;


AMCLASSICON_EmptyTrash

Class for TAppMessage.am_Class. The "Empty Trash" menu item was invoked

Declaration

Source position: workbench.pas line 186

const AMCLASSICON_EmptyTrash = 10;


AMCLASSICON_FormatDisk

Class for TAppMessage.am_Class. The "Format Disk" menu item was invoked

Declaration

Source position: workbench.pas line 185

const AMCLASSICON_FormatDisk = 9;


AMCLASSICON_Information

Class for TAppMessage.am_Class. The "Information" menu item was invoked

Declaration

Source position: workbench.pas line 179

const AMCLASSICON_Information = 3;


AMCLASSICON_LeaveOut

Class for TAppMessage.am_Class. The "Leave Out" menu item was invoked

Declaration

Source position: workbench.pas line 182

const AMCLASSICON_LeaveOut = 6;


AMCLASSICON_Open

Class for TAppMessage.am_Class. The "Open" menu item was invoked, the icon got double-clicked or an icon got dropped on it.

Declaration

Source position: workbench.pas line 176

const AMCLASSICON_Open = 0;


AMCLASSICON_PutAway

Class for TAppMessage.am_Class. The "Put Away" menu item was invoked

Declaration

Source position: workbench.pas line 183

const AMCLASSICON_PutAway = 7;


AMCLASSICON_Rename

Class for TAppMessage.am_Class. The "Rename" menu item was invoked

Declaration

Source position: workbench.pas line 178

const AMCLASSICON_Rename = 2;


AMCLASSICON_Selected

Class for TAppMessage.am_Class. The icon is now selected

Declaration

Source position: workbench.pas line 187

const AMCLASSICON_Selected = 11;


AMCLASSICON_Snapshot

Class for TAppMessage.am_Class. The "Snapshot" menu item was invoked

Declaration

Source position: workbench.pas line 180

const AMCLASSICON_Snapshot = 4;


AMCLASSICON_Unselected

Class for TAppMessage.am_Class. The icon is now unselected

Declaration

Source position: workbench.pas line 188

const AMCLASSICON_Unselected = 12;


AMCLASSICON_UnSnapshot

Class for TAppMessage.am_Class. The "UnSnapshot" menu item was invoked

Declaration

Source position: workbench.pas line 181

const AMCLASSICON_UnSnapshot = 5;


AMTYPE_APPICON

Type for TAppMessage.am_Type, App icon message

Declaration

Source position: workbench.pas line 171

const AMTYPE_APPICON = 8;


AMTYPE_APPMENUITEM

Type for TAppMessage.am_Type, App menu item message

Declaration

Source position: workbench.pas line 172

const AMTYPE_APPMENUITEM = 9;


AMTYPE_APPWINDOW

Type for TAppMessage.am_Type, App window message

Declaration

Source position: workbench.pas line 170

const AMTYPE_APPWINDOW = 7;


AMTYPE_APPWINDOWZONE

Declaration

Source position: workbench.pas line 173

const AMTYPE_APPWINDOWZONE = 10;


CPACTION_Begin

Defines MessageType (cbm_Action) as PCopyBeginMsg

Declaration

Source position: workbench.pas line 278

const CPACTION_Begin = 0;


CPACTION_Copy

Defines MessageType (cdm_Action) as PCopyDataMsg

Declaration

Source position: workbench.pas line 279

const CPACTION_Copy = 1;

Description

This message arrives for each file or drawer to be copied.


CPACTION_End

Defines MessageType (cem_Action) as PCopyEndMsg

Declaration

Source position: workbench.pas line 280

const CPACTION_End = 2;

Description

This message arrives when all files/drawers have been copied.


DDFLAGS_SHOWALL

Flags for TDrawerData.dd_Flags Show all files

Declaration

Source position: workbench.pas line 90

const DDFLAGS_SHOWALL = 2;


DDFLAGS_SHOWDEFAULT

Flags for TDrawerData.dd_Flags Default (show only icons)

Declaration

Source position: workbench.pas line 88

const DDFLAGS_SHOWDEFAULT = 0;


DDFLAGS_SHOWICONS

Flags for TDrawerData.dd_Flags Show only icons

Declaration

Source position: workbench.pas line 89

const DDFLAGS_SHOWICONS = 1;


DDVM_BYDATE

View mode for TDrawerData.dd_ViewModes View as text, sorted by date

Declaration

Source position: workbench.pas line 83

const DDVM_BYDATE = 3;


DDVM_BYDEFAULT

View mode for TDrawerData.dd_ViewModes Default (inherit parent's view mode)

Declaration

Source position: workbench.pas line 80

const DDVM_BYDEFAULT = 0;


DDVM_BYICON

View mode for TDrawerData.dd_ViewModes View as icons

Declaration

Source position: workbench.pas line 81

const DDVM_BYICON = 1;


DDVM_BYNAME

View mode for TDrawerData.dd_ViewModes View as text, sorted by name

Declaration

Source position: workbench.pas line 82

const DDVM_BYNAME = 2;


DDVM_BYSIZE

View mode for TDrawerData.dd_ViewModes View as text, sorted by size

Declaration

Source position: workbench.pas line 84

const DDVM_BYSIZE = 4;


DDVM_BYTYPE

View mode for TDrawerData.dd_ViewModes View as text, sorted by type

Declaration

Source position: workbench.pas line 85

const DDVM_BYTYPE = 5;


DLACTION_BeginDiscard

Defined Messagetype .dbm_Action as PDeleteBeginMsg

Declaration

Source position: workbench.pas line 306

const DLACTION_BeginDiscard = 0;


DLACTION_BeginEmptyTrash

Defined Messagetype .dbm_Action as PDeleteBeginMsg

Declaration

Source position: workbench.pas line 307

const DLACTION_BeginEmptyTrash = 1;

Description

This indicates that the following delete operations are intended to empty the trashcan.


DLACTION_DeleteContents

Defined Messagetype .ddm_Action as PDeleteDataMsg

Declaration

Source position: workbench.pas line 308

const DLACTION_DeleteContents = 3;

Description

This indicates that the object described by lock and name refers to a drawer; you should empty its contents but do not delete the drawer itself!


DLACTION_DeleteObject

Defined Messagetype .ddm_Action as PDeleteDataMsg

Declaration

Source position: workbench.pas line 309

const DLACTION_DeleteObject = 4;

Description

This indicates that the object described by lock and name should be deleted; this could be a file or an empty drawer.


DLACTION_End

Defined Messagetype .dem_Action as PDeleteEndMsg

Declaration

Source position: workbench.pas line 310

const DLACTION_End = 5;

Description

This indicates that the deletion process is finished.


DRAWERDATAFILESIZE

the amount of DrawerData actually written to disk

Declaration

Source position: workbench.pas line 77

const DRAWERDATAFILESIZE = SizeOf(TDrawerData);

See also

TDrawerData | New Structure to describe the view of the content of a drawer
TDiskObject | Representation of an *.info file


GFLG_GADGBACKFILL

Declaration

Source position: workbench.pas line 140

const GFLG_GADGBACKFILL = $0001;


Reference for unit 'Workbench'

Basic Workbench/AppIcons functions (workbench.library)

uses
System,
exec, | This unit contains the types and wrapper functions for the exec.library.
amigados, | File and directory handling routines and types (dos.library)
utility, | Tag Handling, Date routines in utility.library
intuition, | Screen and Window handling routines of intuition.library
agraphics; | Native Amiga graphic functions (graphics.library)

Overview

Function related AppIcons, AppWindows, AppMenuitems and other Workbench display structures are located in this unit.


Reference for unit 'Workbench': Constants

ADZMACTION_Enter | Action for adzm_Action, Something entered the AppItem
ADZMACTION_Leave | Action for adzm_Action, Something left the AppItem
AMCLASSICON_Copy | Class for TAppMessage.am_Class. The "Copy" menu item was invoked
AMCLASSICON_Delete | Class for TAppMessage.am_Class. The "Delete" menu item was invoked
AMCLASSICON_EmptyTrash | Class for TAppMessage.am_Class. The "Empty Trash" menu item was invoked
AMCLASSICON_FormatDisk | Class for TAppMessage.am_Class. The "Format Disk" menu item was invoked
AMCLASSICON_Information | Class for TAppMessage.am_Class. The "Information" menu item was invoked
AMCLASSICON_LeaveOut | Class for TAppMessage.am_Class. The "Leave Out" menu item was invoked
AMCLASSICON_Open | Class for TAppMessage.am_Class. The "Open" menu item was invoked, the icon got double-clicked or an icon got dropped on it.
AMCLASSICON_PutAway | Class for TAppMessage.am_Class. The "Put Away" menu item was invoked
AMCLASSICON_Rename | Class for TAppMessage.am_Class. The "Rename" menu item was invoked
AMCLASSICON_Selected | Class for TAppMessage.am_Class. The icon is now selected
AMCLASSICON_Snapshot | Class for TAppMessage.am_Class. The "Snapshot" menu item was invoked
AMCLASSICON_Unselected | Class for TAppMessage.am_Class. The icon is now unselected
AMCLASSICON_UnSnapshot | Class for TAppMessage.am_Class. The "UnSnapshot" menu item was invoked
AMTYPE_APPICON | Type for TAppMessage.am_Type, App icon message
AMTYPE_APPMENUITEM | Type for TAppMessage.am_Type, App menu item message
AMTYPE_APPWINDOW | Type for TAppMessage.am_Type, App window message
AMTYPE_APPWINDOWZONE
AM_VERSION | If you find TAppMessage.am_Version >= AM_VERSION, you know this structure has at least the fields defined in this version of the include file
CPACTION_Begin | Defines MessageType (cbm_Action) as PCopyBeginMsg
CPACTION_Copy | Defines MessageType (cdm_Action) as PCopyDataMsg
CPACTION_End | Defines MessageType (cem_Action) as PCopyEndMsg
DDFLAGS_SHOWALL | Flags for TDrawerData.dd_Flags Show all files
DDFLAGS_SHOWDEFAULT | Flags for TDrawerData.dd_Flags Default (show only icons)
DDFLAGS_SHOWICONS | Flags for TDrawerData.dd_Flags Show only icons
DDVM_BYDATE | View mode for TDrawerData.dd_ViewModes View as text, sorted by date
DDVM_BYDEFAULT | View mode for TDrawerData.dd_ViewModes Default (inherit parent's view mode)
DDVM_BYICON | View mode for TDrawerData.dd_ViewModes View as icons
DDVM_BYNAME | View mode for TDrawerData.dd_ViewModes View as text, sorted by name
DDVM_BYSIZE | View mode for TDrawerData.dd_ViewModes View as text, sorted by size
DDVM_BYTYPE | View mode for TDrawerData.dd_ViewModes View as text, sorted by type
DLACTION_BeginDiscard | Defined Messagetype .dbm_Action as PDeleteBeginMsg
DLACTION_BeginEmptyTrash | Defined Messagetype .dbm_Action as PDeleteBeginMsg
DLACTION_DeleteContents | Defined Messagetype .ddm_Action as PDeleteDataMsg
DLACTION_DeleteObject | Defined Messagetype .ddm_Action as PDeleteDataMsg
DLACTION_End | Defined Messagetype .dem_Action as PDeleteEndMsg
DRAWERDATAFILESIZE | the amount of DrawerData actually written to disk
GFLG_GADGBACKFILL |
ISMACTION_Ignore | This value your hook code can return when the icon state should not be changed.
ISMACTION_Select | This value your hook code can return when the should be selected.
ISMACTION_Stop | This value your hook code can return when the icon state should not be changed and invoke the hook again.
ISMACTION_Unselect | This value your hook code can return when the icon should be unselected.
MTYPE_APPICON | msg from an app icon
MTYPE_APPMENUITEM | msg from an app menuitem
MTYPE_APPWINDOW | msg from an app window
MTYPE_CLOSEDOWN |
MTYPE_COPYEXIT | exit msg from copy process
MTYPE_DISKCHANGE | Dos telling us of a disk change
MTYPE_ICONPUT | msg from PutDiskObject in icon.library
MTYPE_IOPROC |
MTYPE_PSTD | A "standard Potion" message
MTYPE_TIMER | We got a timer tick
MTYPE_TOOLEXIT | Exit message from our tools
NO_ICON_POSITION | Icon without a fixed position has this Value
OLDDRAWERDATAFILESIZE | The amount of OldDrawerData actually written to disk
SCHMSTATE_Cleanup | State for .schm_State. Workbench will really shut down now.
SCHMSTATE_Setup | State for .schm_State. Workbench is operational again or could not be shut down.
SCHMSTATE_TryCleanup | State for .schm_State. Workbench will attempt to shut down now.
TIACTION_Execute |
TIACTION_NewDrawer |
TIACTION_RelabelVolume |
TIACTION_Rename |
UPDATEWB_ObjectAdded |
UPDATEWB_ObjectRemoved |
WBAPPICON | Type of Icon: AppIcon
WBAPPICONA_NotifySelectState |
WBAPPICONA_PropagatePosition |
WBAPPICONA_RenderHook |
WBAPPICONA_SupportsCopy |
WBAPPICONA_SupportsDelete |
WBAPPICONA_SupportsEmptyTrash |
WBAPPICONA_SupportsFormatDisk |
WBAPPICONA_SupportsInformation |
WBAPPICONA_SupportsLeaveOut |
WBAPPICONA_SupportsOpen |
WBAPPICONA_SupportsPutAway |
WBAPPICONA_SupportsRename |
WBAPPICONA_SupportsSnapshot |
WBAPPICONA_SupportsUnSnapshot |
WBAPPMENUA_CommandKeyString |
WBAPPMENUA_GetKey |
WBAPPMENUA_GetTitleKey |
WBAPPMENUA_UseKey |
WBA_Dummy |
WBA_LAST_TAG |
WBA_Reserved1 |
WBA_Reserved10 |
WBA_Reserved11 |
WBA_Reserved12 |
WBA_Reserved13 |
WBA_Reserved14 |
WBA_Reserved15 |
WBA_Reserved16 |
WBA_Reserved17 |
WBA_Reserved18 |
WBA_Reserved19 |
WBA_Reserved2 |
WBA_Reserved3 |
WBA_Reserved4 |
WBA_Reserved5 |
WBA_Reserved6 |
WBA_Reserved7 |
WBA_Reserved8 |
WBA_Reserved9 |
WBCTRLA_AddHiddenDeviceName |
WBCTRLA_AddSetupCleanupHook |
WBCTRLA_DuplicateSearchPath |
WBCTRLA_FreeHiddenDeviceList |
WBCTRLA_FreeOpenDrawerList |
WBCTRLA_FreeProgramList |
WBCTRLA_FreeSearchPath |
WBCTRLA_FreeSelectedIconList |
WBCTRLA_GetCopyHook |
WBCTRLA_GetDefaultStackSize |
WBCTRLA_GetDeleteHook |
WBCTRLA_GetHiddenDeviceList |
WBCTRLA_GetOpenDrawerList |
WBCTRLA_GetProgramList |
WBCTRLA_GetSelectedIconList |
WBCTRLA_GetTextInputHook |
WBCTRLA_GettypeRestartTime |
WBCTRLA_IsOpen |
WBCTRLA_RedrawAppIcon |
WBCTRLA_RemoveHiddenDeviceName |
WBCTRLA_RemSetupCleanupHook |
WBCTRLA_SetCopyHook |
WBCTRLA_SetDefaultStackSize |
WBCTRLA_SetDeleteHook |
WBCTRLA_SetTextInputHook |
WBCTRLA_SettypeRestartTime |
WBDEVICE | Type of Icon: Device
WBDISK | Type of Icon: Disk
WBDRAWER | Type of Icon: Drawer/Folder
WBDZA_Box |
WBDZA_Height |
WBDZA_Hook |
WBDZA_Left |
WBDZA_RelBottom |
WBDZA_RelHeight |
WBDZA_RelRight |
WBDZA_RelWidth |
WBDZA_Top |
WBDZA_Width |
WBGARBAGE | Type of Icon: Trashcan
WBKICK | Type of Icon: KickStart disk
WBOPENA_ArgLock |
WBOPENA_ArgName |
WBOPENA_Show |
WBOPENA_ViewBy |
WBPROJECT | Type of Icon: Project (Data file)
WBTOOL | Type of Icon: Tool (Excutable)
WB_DISKMAGIC | A magic number, not easily impersonated
WB_DISKREVISION | Our current revision number
WB_DISKREVISIONMASK | We only use the lower 8 bits of Gadget.UserData for the revision #
WB_DISKVERSION | Our current version number
WORKBENCHNAME |


Reference for unit 'Workbench': Types

PAppIcon |
PAppIconRenderMsg | The message your AppIcon rendering hook gets invoked with.
PAppMenu |
PAppMenuItem |
PAppMessage | Pointer to an Message from a AppWindow, AppIcon or AppMenuItem
PAppWindow |
PAppWindowDropZone |
PAppWindowDropZoneMsg | The message your drop zone hook gets invoked with.
PCopyBeginMsg | A message your copy hook is invoked with.
PCopyDataMsg | A message your copy hook is invoked with.
PCopyEndMsg | A message your copy hook is invoked with.
PDeleteBeginMsg | A Message your delete hook is invoked with.
PDeleteDataMsg | A Message your delete hook is invoked with.
PDeleteEndMsg | A Message your delete hook is invoked with.
PDiskObject |
PDrawerData | Pointer to Drawer structure
PFreeList | Memory management in the icon.library
PIconSelectMsg | The message your icon selection change hook is invoked with.
POldDrawerData | Pointer to OldDrawer structure
PSetupCleanupHookMsg | The message your setup/cleanup hook gets invoked with.
PTextInputMsg |
PWBArg | Pointer to an Workbench argument
PWBArgList |
PWBHandlerMessage
PWBStartup |
TAppIcon |
TAppIconRenderMsg | The message your AppIcon rendering hook gets invoked with.
TAppMenu |
TAppMenuItem |
TAppMessage | Message from a AppWindow, AppIcon or AppMenuItem
TAppWindow |
TAppWindowDropZone |
TAppWindowDropZoneMsg | The message your drop zone hook gets invoked with.
TCopyBeginMsg | A message your copy hook is invoked with.
TCopyDataMsg | A message your copy hook is invoked with.
TCopyEndMsg | A message your copy hook is invoked with.
TDeleteBeginMsg | A Message your delete hook is invoked with.
TDeleteDataMsg | A Message your delete hook is invoked with.
TDeleteEndMsg | A Message your delete hook is invoked with.
TDiskObject | Representation of an *.info file
TDrawerData | New Structure to describe the view of the content of a drawer
TFreeList | Memory management in the icon.library
TIconSelectMsg | The message your icon selection change hook is invoked with.
TOldDrawerData | Old Structure to describe the view of the content of a drawer (pre AmigaOS V36)
TSetupCleanupHookMsg | The message your setup/cleanup hook gets invoked with.
TTextInputMsg |
TWBArg | Workbech argument list entry
TWBArgList
TWBHandlerMessage
TWBHM_type
TWBStartup |


ISMACTION_Ignore

This value your hook code can return when the icon state should not be changed.

Declaration

Source position: workbench.pas line 242

const ISMACTION_Ignore = 2;


ISMACTION_Select

This value your hook code can return when the should be selected.

Declaration

Source position: workbench.pas line 241

const ISMACTION_Select = 1;


ISMACTION_Stop

This value your hook code can return when the icon state should not be changed and invoke the hook again.

Declaration

Source position: workbench.pas line 243

const ISMACTION_Stop = 3;


ISMACTION_Unselect

This value your hook code can return when the icon should be unselected.

Declaration

Source position: workbench.pas line 240

const ISMACTION_Unselect = 0;


IWorkbench

Declaration

Source position: workbench.pas line 521

var IWorkbench: PInterface;


MTYPE_APPICON

msg from an app icon

Declaration

Source position: workbench.pas line 483

const MTYPE_APPICON = 8;


MTYPE_APPMENUITEM

msg from an app menuitem

Declaration

Source position: workbench.pas line 484

const MTYPE_APPMENUITEM = 9;


MTYPE_APPWINDOW

msg from an app window

Declaration

Source position: workbench.pas line 482

const MTYPE_APPWINDOW = 7;


MTYPE_CLOSEDOWN

Declaration

Source position: workbench.pas line 480

const MTYPE_CLOSEDOWN = 5;


MTYPE_COPYEXIT

exit msg from copy process

Declaration

Source position: workbench.pas line 485

const MTYPE_COPYEXIT = 10;


MTYPE_DISKCHANGE

Dos telling us of a disk change

Declaration

Source position: workbench.pas line 478

const MTYPE_DISKCHANGE = 3;


MTYPE_ICONPUT

msg from PutDiskObject in icon.library

Declaration

Source position: workbench.pas line 486

const MTYPE_ICONPUT = 11;


MTYPE_IOPROC

Declaration

Source position: workbench.pas line 481

const MTYPE_IOPROC = 6;


MTYPE_PSTD

A "standard Potion" message

Declaration

Source position: workbench.pas line 476

const MTYPE_PSTD = 1;


MTYPE_TIMER

We got a timer tick

Declaration

Source position: workbench.pas line 479

const MTYPE_TIMER = 4;


MTYPE_TOOLEXIT

Exit message from our tools

Declaration

Source position: workbench.pas line 477

const MTYPE_TOOLEXIT = 2;


NO_ICON_POSITION

Icon without a fixed position has this Value

Declaration

Source position: workbench.pas line 142

const NO_ICON_POSITION = $80000000;


OLDDRAWERDATAFILESIZE

The amount of OldDrawerData actually written to disk

Declaration

Source position: workbench.pas line 64

const OLDDRAWERDATAFILESIZE = SizeOf(TOldDrawerData);

See also

TOldDrawerData

Old Structure to describe the view of the content of a drawer (pre AmigaOS V36)


PAppIcon

Declaration

Source position: workbench.pas line 360

type PAppIcon = ^TAppIcon;


PAppIconRenderMsg

The message your AppIcon rendering hook gets invoked with.

Declaration

Source position: workbench.pas line 192

type PAppIconRenderMsg = ^TAppIconRenderMsg;


PAppMenu

Declaration

Source position: workbench.pas line 350

type PAppMenu = ^TAppMenu;


PAppMenuItem

Declaration

Source position: workbench.pas line 365

type PAppMenuItem = ^TAppMenuItem;


PAppMessage

Pointer to an Message from a AppWindow, AppIcon or AppMenuItem

Declaration

Source position: workbench.pas line 145

type PAppMessage = ^TAppMessage;


PAppWindow

Declaration

Source position: workbench.pas line 345

type PAppWindow = ^TAppWindow;


PAppWindowDropZone

Declaration

Source position: workbench.pas line 355

type PAppWindowDropZone = ^TAppWindowDropZone;


PAppWindowDropZoneMsg

The message your drop zone hook gets invoked with.

Declaration

Source position: workbench.pas line 206

type PAppWindowDropZoneMsg = ^TAppWindowDropZoneMsg;


PCopyBeginMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 247

type PCopyBeginMsg = ^TCopyBeginMsg;


PCopyDataMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 255

type PCopyDataMsg = ^TCopyDataMsg;


PCopyEndMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 271

type PCopyEndMsg = ^TCopyEndMsg;


PDeleteBeginMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 284

type PDeleteBeginMsg = ^TDeleteBeginMsg;


PDeleteDataMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 290

type PDeleteDataMsg = ^TDeleteDataMsg;


PDeleteEndMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 298

type PDeleteEndMsg = ^TDeleteEndMsg;


PDiskObject

Declaration

Source position: workbench.pas line 93

type PDiskObject = ^TDiskObject;


PDrawerData

Pointer to Drawer structure

Declaration

Source position: workbench.pas line 67

type PDrawerData = ^TDrawerData;


PFreeList

Memory management in the icon.library

Declaration

Source position: workbench.pas line 125

type PFreeList = ^TFreeList;

See also

Icon.AddFreeList | Add memory to a free list.
Icon.FreeFreeList | Free all memory in a free list.


PIconSelectMsg

The message your icon selection change hook is invoked with.

Declaration

Source position: workbench.pas line 222

type PIconSelectMsg = ^TIconSelectMsg;


POldDrawerData

Pointer to OldDrawer structure

Declaration

Source position: workbench.pas line 56

type POldDrawerData = ^TOldDrawerData;


PSetupCleanupHookMsg

The message your setup/cleanup hook gets invoked with.

Declaration

Source position: workbench.pas line 314

type PSetupCleanupHookMsg = ^TSetupCleanupHookMsg;


PTextInputMsg

Declaration

Source position: workbench.pas line 327

type PTextInputMsg = ^TTextInputMsg;


PWBArg

Pointer to an Workbench argument

Declaration

Source position: workbench.pas line 27

type PWBArg = ^TWBArg;


PWBArgList

Declaration

Source position: workbench.pas line 35

type PWBArgList = ^TWBArgList;


PWBHandlerMessage

Declaration

Source position: workbench.pas line 498

type PWBHandlerMessage = ^TWBHandlerMessage;


PWBStartup

Declaration

Source position: workbench.pas line 40

type PWBStartup = ^TWBStartup;


SCHMSTATE_Cleanup

State for .schm_State. Workbench will really shut down now.

Declaration

Source position: workbench.pas line 322

const SCHMSTATE_Cleanup = 1;


SCHMSTATE_Setup

State for .schm_State. Workbench is operational again or could not be shut down.

Declaration

Source position: workbench.pas line 323

const SCHMSTATE_Setup = 2;


SCHMSTATE_TryCleanup

State for .schm_State. Workbench will attempt to shut down now.

Declaration

Source position: workbench.pas line 321

const SCHMSTATE_TryCleanup = 0;


TAppIcon

Declaration

Source position: workbench.pas line 361

type TAppIcon = record

  ai_PRIVATE: Pointer;

end;


TAppIconRenderMsg

The message your AppIcon rendering hook gets invoked with.

Declaration

Source position: workbench.pas line 193

type TAppIconRenderMsg = record
arm_RastPort: PRastPort; | RastPort to render into
arm_Icon: PDiskObject; | The icon to be rendered
arm_Label: PChar; | The icon label txt
arm_Tags: PTagItem; | urther tags to be passed on to DrawIconStateA().
arm_Left: SmallInt; | Rendering origin, not taking the
arm_Top: SmallInt; | button border into account.
arm_Width: SmallInt; | Limit your rendering to
arm_Height: SmallInt; | this area.
arm_State: LongWord; | State of Icon (IDS_*)
end;


TAppMenu

Declaration

Source position: workbench.pas line 351

type TAppMenu = record

  am_PRIVATE: pointer;

end;


TAppMenuItem

Declaration

Source position: workbench.pas line 366

type TAppMenuItem = record

  ami_PRIVATE: Pointer;

end;


TAppMessage

Message from a AppWindow, AppIcon or AppMenuItem

Declaration

Source position: workbench.pas line 146

type TAppMessage = record
am_Message: TMessage; | Standard message structure
am_type: Word; | Message type (AMTYPE_*)
am_UserData: LongWord; | Application specific
am_ID: LongWord; | Application definable ID
am_NumArgs: LongInt; | Number of elements in arglist
am_ArgList: PWBArgList; | The arguements themselves
am_Version: Word; | Will be AM_VERSION
am_Class: Word; | Message class (AMCLASSICON_*)
am_MouseX: SmallInt; | Mouse x position of event
am_MouseY: SmallInt; | Mouse y position of event
am_Seconds: LongWord; | Current system clock time
am_Micros: LongWord; | Current system clock time
am_Reserved: array [0..7] of LongWord; | Avoid recompilation
end;


TAppWindow

Declaration

Source position: workbench.pas line 346

type TAppWindow = record

  aw_PRIVATE: pointer;

end;


TAppWindowDropZone

Declaration

Source position: workbench.pas line 356

type TAppWindowDropZone = record

  awdz_PRIVATE: pointer;

end;


TAppWindowDropZoneMsg

The message your drop zone hook gets invoked with.

Declaration

Source position: workbench.pas line 207

type TAppWindowDropZoneMsg = record
adzm_RastPort: PRastPort; | RastPort to render into.
adzm_DropZoneBox: TIBox; | Limit your rendering to this area.
adzm_ID: LongWord; | This is the ID straight from AddAppWindowDropZoneA().
adzm_UserData: LongWord; | This is the UserData straight from AddAppWindowDropZoneA().
adzm_Action: LongInt; | Action was done. ADZMACTION_Enter, ADZMACTION_Leave
end;


TCopyBeginMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 248

type TCopyBeginMsg = record
cbm_Length: LongWord; | Size of this data structure in bytes.
cbm_Action: LongInt; | Will be set to CPACTION_Begin.
cbm_SourceDrawer: LongInt; | A lock on the source drawer.
cbm_DestinationDrawer: LongInt; | A lock on the destination drawer.
end;


TCopyDataMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 256

type TCopyDataMsg = record
cdm_Length: LongWord; | Size of this data structure in bytes.
cdm_Action: LongInt; | Will be set to CPACTION_Copy
cdm_SourceLock: LongInt; | A lock on the parent directory of the source file/drawer.
cdm_SourceName: PChar; | The name of the source file or drawer.
cdm_DestinationLock: LongInt; | A lock on the parent directory of the destination file/drawer.
cdm_DestinationName: PChar; | The name of the destination file/drawer. This may or may not match the name of the source file/drawer in case the data is to be copied under a different name. For example, this is the case with the Workbench "Copy" command which creates duplicates of file/drawers by prefixing the duplicate's name with "Copy_XXX_of".
cdm_DestinationX: LongInt; | When the icon corresponding to the
cdm_DestinationY: LongInt; | destination is written to disk, this is the position (put into its PDiskObject^.do_CurrentX/PDiskObject^.do_CurrentY fields) it should be placed at.
end;


TCopyEndMsg

A message your copy hook is invoked with.

Declaration

Source position: workbench.pas line 272

type TCopyEndMsg = record
cem_Length: LongWord; | Size of this data structure in bytes.
cem_Action: LongInt; | Will be set to either DLACTION_BeginDiscard or DLACTION_BeginEmptyTrash
end;


TDeleteBeginMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 285

type TDeleteBeginMsg = record
dbm_Length: LongWord; | Size of this data structure in bytes.
dbm_Action: LongInt; | Will be set to either DLACTION_BeginDiscard or DLACTION_BeginEmptyTrash
end;


TDeleteDataMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 291

type TDeleteDataMsg = record
ddm_Length: LongWord; | Size of this data structure in bytes.
ddm_Action: LongInt; | Will be set to either DLACTION_DeleteContents or DLACTION_DeleteObject
ddm_Lock: LongInt; | A Lock on the parent directory of the object whose contents or which itself should be deleted.
ddm_Name: PChar; | The name of the object whose contents or which itself should be deleted.
end;


TDeleteEndMsg

A Message your delete hook is invoked with.

Declaration

Source position: workbench.pas line 299

type TDeleteEndMsg = record
dem_Length: LongWord; | Size of this data structure in bytes.
dem_Action: LongInt; | Will be set to DLACTION_End
end;


TDiskObject

Representation of an *.info file

Declaration

Source position: workbench.pas line 94

type TDiskObject = record
do_Magic: Word; | A magic number at the start of the file
do_Version: Word; | A version number, so we can change it
do_Gadget: TGadget; | A copy of in core gadget
do_type: Byte; | Type for icons (WB*)
do_DefaultTool: PChar; |
do_Tooltypes: PPChar; | List of ToolTypes
do_CurrentX: LongInt; | Current X Position of Icon
do_CurrentY: LongInt; | Current Y Position of Icon
do_DrawerData: PDrawerData; |
do_ToolWindow: PChar; | Only applies to tools
do_StackSize: LongInt; | Only applies to tools
end;


TDrawerData

New Structure to describe the view of the content of a drawer

Declaration

Source position: workbench.pas line 68

type TDrawerData = record
dd_NewWindow: TNewWindow; | Args to open window
dd_CurrentX: LongInt; | Current x coordinate of origin
dd_CurrentY: LongInt; | Current y coordinate of origin
dd_Flags: LongWord; | Flags for drawer (DDFLAGS_*)
dd_ViewModes: Word; | View mode for drawer (DDVM_*)
end;

See also

DRAWERDATAFILESIZE

the amount of DrawerData actually written to disk


TFreeList

Memory management in the icon.library

Declaration

Source position: workbench.pas line 126

type TFreeList = record

  fl_NumFree: SmallInt;

  fl_MemList: TList;

end;

See also

Icon.AddFreeList | Add memory to a free list.
Icon.FreeFreeList | Free all memory in a free list.


TIACTION_Execute

Declaration

Source position: workbench.pas line 338

const TIACTION_Execute = 3;


TIACTION_NewDrawer

Declaration

Source position: workbench.pas line 337

const TIACTION_NewDrawer = 2;


TIACTION_RelabelVolume

Declaration

Source position: workbench.pas line 336

const TIACTION_RelabelVolume = 1;


TIACTION_Rename

Declaration

Source position: workbench.pas line 335

const TIACTION_Rename = 0;


TIconSelectMsg

The message your icon selection change hook is invoked with.

Declaration

Source position: workbench.pas line 223

type TIconSelectMsg = record
ism_Length: LongWord; | Size of this data structure (in bytes).
ism_Drawer: LongInt; | Lock on the drawer this object resides in, nil for Workbench backdrop (devices).
ism_Name: PChar; | Name of the object in question.
ism_type: Word; | One of WBDISK, WBDRAWER, WBTOOL, WBPROJECT, WBGARBAGE, WBDEVICE or WBKICK.
ism_Selected: LongBool; | True if currently selected, False otherwise.
ism_Tags: PTagItem; | Pointer to the list of tag items passed to ChangeWorkbenchSelectionA().
ism_DrawerWindow: PWindow; | Pointer to the window attached to this icon, if the icon is a drawer-like object.
ism_ParentWindow: PWindow; | Pointer to the window the icon resides in.
ism_Left: SmallInt; | Position and size of the icon; note that the
ism_Top: SmallInt; | icon may not entirely reside within the visible
ism_Width: SmallInt; | bounds of the parent window.
ism_Height: SmallInt; |
end;


TOldDrawerData

Old Structure to describe the view of the content of a drawer (pre AmigaOS V36)

Declaration

Source position: workbench.pas line 57

type TOldDrawerData = record
dd_NewWindow: TNewWindow; | Args to open window
dd_CurrentX: LongInt; | Current x coordinate of origin
dd_CurrentY: LongInt; | Current y coordinate of origin
end;

See also

OLDDRAWERDATAFILESIZE

The amount of OldDrawerData actually written to disk


TSetupCleanupHookMsg

The message your setup/cleanup hook gets invoked with.

Declaration

Source position: workbench.pas line 315

type TSetupCleanupHookMsg = record
schm_Length: LongWord; | LEngth of Message
schm_State: LongInt; | State of Workbench shutdown (SCHMSTATE_*)
end;

See also

SCHMSTATE_TryCleanup | State for .schm_State. Workbench will attempt to shut down now.
SCHMSTATE_Cleanup | State for .schm_State. Workbench will really shut down now.
SCHMSTATE_Setup | State for .schm_State. Workbench is operational again or could not be shut down.


TTextInputMsg

Declaration

Source position: workbench.pas line 328

type TTextInputMsg = record

  tim_Length: LongWord;

  tim_Action: LongInt;

  tim_Prompt: PChar;

end;


TWBArg

Workbech argument list entry

Declaration

Source position: workbench.pas line 28

type TWBArg = record
wa_Lock: LongInt; | A lock descriptor
wa_Name: PChar; | A string relative to that lock
end;


TWBArgList

Declaration

Source position: workbench.pas line 36

type TWBArgList = array [1..100] of TWBArg;


TWBHandlerMessage

Declaration

Source position: workbench.pas line 499

type TWBHandlerMessage = record

  wbhm_Message: TMessage;

  wbhm_type: TWBHM_type;

  case Integer of

    0: (

        Open: record

          OpenName: PChar;

        end;

      );

    1: (

        Update: record

          UpdateName: PChar;

          Updatetype: LongInt;

        end;

      );

end;


TWBHM_type

Declaration

Source position: workbench.pas line 490

type TWBHM_type = (

  WBHM_TYPE_SHOW,

  WBHM_TYPE_HIDE,

  WBHM_TYPE_OPEN,

  WBHM_TYPE_UPDATE

);


TWBStartup

Declaration

Source position: workbench.pas line 41

type TWBStartup = record
sm_Message: TMessage; | A standard message structure
sm_Process: PMsgPort; | The process descriptor for you
sm_Segment: LongInt; | a descriptor for your code
sm_NumArgs: LongInt; | the number of elements in ArgList
sm_ToolWindow: PChar; | Description of window
sm_ArgList: PWBArgList; | The arguments themselves
end;


UPDATEWB_ObjectAdded

Declaration

Source position: workbench.pas line 470

const UPDATEWB_ObjectAdded = 1;


UPDATEWB_ObjectRemoved

Declaration

Source position: workbench.pas line 469

const UPDATEWB_ObjectRemoved = 0;


WB_DISKMAGIC

A magic number, not easily impersonated

Declaration

Source position: workbench.pas line 122

const WB_DISKMAGIC = $E310;


WB_DISKREVISION

Our current revision number

Declaration

Source position: workbench.pas line 119

const WB_DISKREVISION = 1;


WB_DISKREVISIONMASK

We only use the lower 8 bits of Gadget.UserData for the revision #

Declaration

Source position: workbench.pas line 120

const WB_DISKREVISIONMASK = $FF;


WB_DISKVERSION

Our current version number

Declaration

Source position: workbench.pas line 118

const WB_DISKVERSION = 1;


WBA_Dummy

Declaration

Source position: workbench.pas line 372

const WBA_Dummy = TAG_USER + $A000;


WBA_LAST_TAG

Declaration

Source position: workbench.pas line 466

const WBA_LAST_TAG = WBA_Dummy + 64;


WBA_Reserved1

Declaration

Source position: workbench.pas line 445

const WBA_Reserved1 = WBA_Dummy + 40;


WBA_Reserved2

Declaration

Source position: workbench.pas line 446

const WBA_Reserved2 = WBA_Dummy + 41;


WBA_Reserved3

Declaration

Source position: workbench.pas line 447

const WBA_Reserved3 = WBA_Dummy + 46;


WBA_Reserved4

Declaration

Source position: workbench.pas line 448

const WBA_Reserved4 = WBA_Dummy + 49;


WBA_Reserved5

Declaration

Source position: workbench.pas line 449

const WBA_Reserved5 = WBA_Dummy + 50;


WBA_Reserved6

Declaration

Source position: workbench.pas line 450

const WBA_Reserved6 = WBA_Dummy + 51;


WBA_Reserved7

Declaration

Source position: workbench.pas line 451

const WBA_Reserved7 = WBA_Dummy + 52;


WBA_Reserved8

Declaration

Source position: workbench.pas line 452

const WBA_Reserved8 = WBA_Dummy + 53;


WBA_Reserved9

Declaration

Source position: workbench.pas line 453

const WBA_Reserved9 = WBA_Dummy + 54;


WBA_Reserved10

Declaration

Source position: workbench.pas line 454

const WBA_Reserved10 = WBA_Dummy + 55;


WBA_Reserved11

Declaration

Source position: workbench.pas line 455

const WBA_Reserved11 = WBA_Dummy + 56;


WBA_Reserved12

Declaration

Source position: workbench.pas line 456

const WBA_Reserved12 = WBA_Dummy + 57;


WBA_Reserved13

Declaration

Source position: workbench.pas line 457

const WBA_Reserved13 = WBA_Dummy + 58;


WBA_Reserved14

Declaration

Source position: workbench.pas line 458

const WBA_Reserved14 = WBA_Dummy + 59;


WBA_Reserved15

Declaration

Source position: workbench.pas line 459

const WBA_Reserved15 = WBA_Dummy + 60;


WBA_Reserved16

Declaration

Source position: workbench.pas line 460

const WBA_Reserved16 = WBA_Dummy + 61;


WBA_Reserved17

Declaration

Source position: workbench.pas line 461

const WBA_Reserved17 = WBA_Dummy + 62;


WBA_Reserved18

Declaration

Source position: workbench.pas line 462

const WBA_Reserved18 = WBA_Dummy + 63;


WBA_Reserved19

Declaration

Source position: workbench.pas line 463

const WBA_Reserved19 = WBA_Dummy + 64;


WBAPPICON

Type of Icon: AppIcon

Declaration

Source position: workbench.pas line 116

const WBAPPICON = 8;


WBAPPICONA_NotifySelectState

Declaration

Source position: workbench.pas line 389

const WBAPPICONA_NotifySelectState = WBA_Dummy + 14;


WBAPPICONA_PropagatePosition

Declaration

Source position: workbench.pas line 387

const WBAPPICONA_PropagatePosition = WBA_Dummy + 12;


WBAPPICONA_RenderHook

Declaration

Source position: workbench.pas line 388

const WBAPPICONA_RenderHook = WBA_Dummy + 13;


WBAPPICONA_SupportsCopy

Declaration

Source position: workbench.pas line 376

const WBAPPICONA_SupportsCopy = WBA_Dummy + 2;


WBAPPICONA_SupportsDelete

Declaration

Source position: workbench.pas line 383

const WBAPPICONA_SupportsDelete = WBA_Dummy + 9;


WBAPPICONA_SupportsEmptyTrash

Declaration

Source position: workbench.pas line 385

const WBAPPICONA_SupportsEmptyTrash = WBA_Dummy + 11;


WBAPPICONA_SupportsFormatDisk

Declaration

Source position: workbench.pas line 384

const WBAPPICONA_SupportsFormatDisk = WBA_Dummy + 10;


WBAPPICONA_SupportsInformation

Declaration

Source position: workbench.pas line 378

const WBAPPICONA_SupportsInformation = WBA_Dummy + 4;


WBAPPICONA_SupportsLeaveOut

Declaration

Source position: workbench.pas line 381

const WBAPPICONA_SupportsLeaveOut = WBA_Dummy + 7;


WBAPPICONA_SupportsOpen

Declaration

Source position: workbench.pas line 375

const WBAPPICONA_SupportsOpen = WBA_Dummy + 1;


WBAPPICONA_SupportsPutAway

Declaration

Source position: workbench.pas line 382

const WBAPPICONA_SupportsPutAway = WBA_Dummy + 8;


WBAPPICONA_SupportsRename

Declaration

Source position: workbench.pas line 377

const WBAPPICONA_SupportsRename = WBA_Dummy + 3;


WBAPPICONA_SupportsSnapshot

Declaration

Source position: workbench.pas line 379

const WBAPPICONA_SupportsSnapshot = WBA_Dummy + 5;


WBAPPICONA_SupportsUnSnapshot

Declaration

Source position: workbench.pas line 380

const WBAPPICONA_SupportsUnSnapshot = WBA_Dummy + 6;


WBAPPMENUA_CommandKeyString

Declaration

Source position: workbench.pas line 392

const WBAPPMENUA_CommandKeyString = WBA_Dummy + 15;


WBAPPMENUA_GetKey

Declaration

Source position: workbench.pas line 393

const WBAPPMENUA_GetKey = WBA_Dummy + 65;


WBAPPMENUA_GetTitleKey

Declaration

Source position: workbench.pas line 395

const WBAPPMENUA_GetTitleKey = WBA_Dummy + 77;


WBAPPMENUA_UseKey

Declaration

Source position: workbench.pas line 394

const WBAPPMENUA_UseKey = WBA_Dummy + 66;


WBCTRLA_AddHiddenDeviceName

Declaration

Source position: workbench.pas line 419

const WBCTRLA_AddHiddenDeviceName = WBA_Dummy + 44;


WBCTRLA_AddSetupCleanupHook

Declaration

Source position: workbench.pas line 429

const WBCTRLA_AddSetupCleanupHook = WBA_Dummy + 78;


WBCTRLA_DuplicateSearchPath

Declaration

Source position: workbench.pas line 405

const WBCTRLA_DuplicateSearchPath = WBA_Dummy + 19;


WBCTRLA_FreeHiddenDeviceList

Declaration

Source position: workbench.pas line 418

const WBCTRLA_FreeHiddenDeviceList = WBA_Dummy + 43;


WBCTRLA_FreeOpenDrawerList

Declaration

Source position: workbench.pas line 415

const WBCTRLA_FreeOpenDrawerList = WBA_Dummy + 39;


WBCTRLA_FreeProgramList

Declaration

Source position: workbench.pas line 411

const WBCTRLA_FreeProgramList = WBA_Dummy + 25;


WBCTRLA_FreeSearchPath

Declaration

Source position: workbench.pas line 406

const WBCTRLA_FreeSearchPath = WBA_Dummy + 20;


WBCTRLA_FreeSelectedIconList

Declaration

Source position: workbench.pas line 413

const WBCTRLA_FreeSelectedIconList = WBA_Dummy + 37;


WBCTRLA_GetCopyHook

Declaration

Source position: workbench.pas line 423

const WBCTRLA_GetCopyHook = WBA_Dummy + 69;


WBCTRLA_GetDefaultStackSize

Declaration

Source position: workbench.pas line 407

const WBCTRLA_GetDefaultStackSize = WBA_Dummy + 21;


WBCTRLA_GetDeleteHook

Declaration

Source position: workbench.pas line 425

const WBCTRLA_GetDeleteHook = WBA_Dummy + 71;


WBCTRLA_GetHiddenDeviceList

Declaration

Source position: workbench.pas line 416

const WBCTRLA_GetHiddenDeviceList = WBA_Dummy + 42;


WBCTRLA_GetOpenDrawerList

Declaration

Source position: workbench.pas line 414

const WBCTRLA_GetOpenDrawerList = WBA_Dummy + 38;


WBCTRLA_GetProgramList

Declaration

Source position: workbench.pas line 410

const WBCTRLA_GetProgramList = WBA_Dummy + 24;


WBCTRLA_GetSelectedIconList

Declaration

Source position: workbench.pas line 412

const WBCTRLA_GetSelectedIconList = WBA_Dummy + 36;


WBCTRLA_GetTextInputHook

Declaration

Source position: workbench.pas line 427

const WBCTRLA_GetTextInputHook = WBA_Dummy + 73;


WBCTRLA_GettypeRestartTime

Declaration

Source position: workbench.pas line 421

const WBCTRLA_GettypeRestartTime = WBA_Dummy + 47;


WBCTRLA_IsOpen

Declaration

Source position: workbench.pas line 404

const WBCTRLA_IsOpen = WBA_Dummy + 18;


WBCTRLA_RedrawAppIcon

Declaration

Source position: workbench.pas line 409

const WBCTRLA_RedrawAppIcon = WBA_Dummy + 23;


WBCTRLA_RemoveHiddenDeviceName

Declaration

Source position: workbench.pas line 420

const WBCTRLA_RemoveHiddenDeviceName = WBA_Dummy + 45;


WBCTRLA_RemSetupCleanupHook

Declaration

Source position: workbench.pas line 430

const WBCTRLA_RemSetupCleanupHook = WBA_Dummy + 79;


WBCTRLA_SetCopyHook

Declaration

Source position: workbench.pas line 424

const WBCTRLA_SetCopyHook = WBA_Dummy + 70;


WBCTRLA_SetDefaultStackSize

Declaration

Source position: workbench.pas line 408

const WBCTRLA_SetDefaultStackSize = WBA_Dummy + 22;


WBCTRLA_SetDeleteHook

Declaration

Source position: workbench.pas line 426

const WBCTRLA_SetDeleteHook = WBA_Dummy + 72;


WBCTRLA_SetTextInputHook

Declaration

Source position: workbench.pas line 428

const WBCTRLA_SetTextInputHook = WBA_Dummy + 74;


WBCTRLA_SettypeRestartTime

Declaration

Source position: workbench.pas line 422

const WBCTRLA_SettypeRestartTime = WBA_Dummy + 48;


WBDEVICE

Type of Icon: Device

Declaration

Source position: workbench.pas line 114

const WBDEVICE = 6;


WBDISK

Type of Icon: Disk

Declaration

Source position: workbench.pas line 109

const WBDISK = 1;


WBDRAWER

Type of Icon: Drawer/Folder

Declaration

Source position: workbench.pas line 110

const WBDRAWER = 2;


WBDZA_Box

Declaration

Source position: workbench.pas line 441

const WBDZA_Box = WBA_Dummy + 34;


WBDZA_Height

Declaration

Source position: workbench.pas line 439

const WBDZA_Height = WBA_Dummy + 32;


WBDZA_Hook

Declaration

Source position: workbench.pas line 442

const WBDZA_Hook = WBA_Dummy + 35;


WBDZA_Left

Declaration

Source position: workbench.pas line 433

const WBDZA_Left = WBA_Dummy + 26;


WBDZA_RelBottom

Declaration

Source position: workbench.pas line 436

const WBDZA_RelBottom = WBA_Dummy + 29;


WBDZA_RelHeight

Declaration

Source position: workbench.pas line 440

const WBDZA_RelHeight = WBA_Dummy + 33;


WBDZA_RelRight

Declaration

Source position: workbench.pas line 434

const WBDZA_RelRight = WBA_Dummy + 27;


WBDZA_RelWidth

Declaration

Source position: workbench.pas line 438

const WBDZA_RelWidth = WBA_Dummy + 31;


WBDZA_Top

Declaration

Source position: workbench.pas line 435

const WBDZA_Top = WBA_Dummy + 28;


WBDZA_Width

Declaration

Source position: workbench.pas line 437

const WBDZA_Width = WBA_Dummy + 30;


WBGARBAGE

Type of Icon: Trashcan

Declaration

Source position: workbench.pas line 113

const WBGARBAGE = 5;


WBKICK

Type of Icon: KickStart disk

Declaration

Source position: workbench.pas line 115

const WBKICK = 7;


WBOPENA_ArgLock

Declaration

Source position: workbench.pas line 398

const WBOPENA_ArgLock = WBA_Dummy + 16;


WBOPENA_ArgName

Declaration

Source position: workbench.pas line 399

const WBOPENA_ArgName = WBA_Dummy + 17;


WBOPENA_Show

Declaration

Source position: workbench.pas line 400

const WBOPENA_Show = WBA_Dummy + 75;


WBOPENA_ViewBy

Declaration

Source position: workbench.pas line 401

const WBOPENA_ViewBy = WBA_Dummy + 76;


WBPROJECT

Type of Icon: Project (Data file)

Declaration

Source position: workbench.pas line 112

const WBPROJECT = 4;


WBTOOL

Type of Icon: Tool (Excutable)

Declaration

Source position: workbench.pas line 111

const WBTOOL = 3;


WorkbenchBase

Declaration

Source position: workbench.pas line 520

var WorkbenchBase: PLibrary;


WORKBENCHNAME

Declaration

Source position: workbench.pas line 53

const WORKBENCHNAME: PChar = 'workbench.library';